Xfmea/RCM++/RBI 11 User's Guide

© 1992-2017 HBM United Kingdom Limited ("HBM UK Ltd"), at Technology Centre, Advanced Manufacturing Park, Brunel Way, Catcliffe, Rotherham S60 5WG. HBM UK Ltd is an affiliate of ReliaSoft Corporation. ALL RIGHTS RESERVED.

This license agreement ("License Agreement") sets forth the terms and conditions that govern the distribution and use of the HBM UK Ltd software documentation (the "HBM Software Documentation"), including any and all derivative works. Any unauthorized distribution or use of the HBM Software Documentation is strictly prohibited.

Licensee hereby acknowledges and agrees to the following terms and conditions of this License Agreement for its use of the HBM Software Documentation:

HBM UK Ltd grants the Licensee who accepts and abides by the terms of this License Agreement a non-exclusive, non-transferable, royalty-free, and revocable license to the HBM Software Documentation. Unless otherwise indicated, all HBM Software Documentation are copyrighted and owned by HBM UK Ltd and are the property of HBM UK Ltd. They are licensed to you and for your use only as an individual who has purchased the software ("Licensee"). Notwithstanding this License Agreement, the Licensee shall not have a license to the trademarks, logos, or any other intellectual property of HBM UK Ltd and/or its affiliates or Licensor(s).

Licensee may print a single copy of the HBM Software Documentation for his/her reference. Licensee may reprint the HBM Software Documentation, as needed, if the original printed copy is damaged and/or destroyed.

Except as provided above, no part of the HBM Software Documentation, either text or image, may be used for any purpose other than Licensee’s own personal use and reference as a learning aid. Therefore, the reproduction, modification, creation of derivative works, storage in a retrieval system, or retransmission, in any form or by any means, electronic, mechanical or otherwise, for reasons other than Licensee’s personal use, is strictly prohibited.

Certain photos and images in the HBM Software Documentation are used under non-transferable licenses obtained by HBM UK Ltd and/or its affiliates and are owned by its Licensor(s) ("Licensor"). Images depicting photos of actual persons are licensed to HBM UK Ltd and/or its affiliates and the signed model releases for these images are on file with the Licensor(s). HBM UK Ltd makes no copyright claims on these images. All ownership and intellectual property rights to the HBM Software Documentation are reserved by either HBM UK Ltd and/or its affiliates or its Licensor(s).

DISCLAIMER: THE HBM SOFTWARE DOCUMENTATION IS PROVIDED "AS IS" WITHOUT WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO: 1) ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT OF INTELLECTUAL PROPERTY; 2) ANY WARRANTY THAT THE HBM COURSE MATERIALS WILL CONFORM TO SPECIFICATIONS; 3) ANY WARRANTY THAT THE WORK WILL BE ERROR FREE OR VIRUS FREE. IN NO EVENT SHALL HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSOR(S) BE LIABLE FOR ANY DAMAGES, INCLUDING, BUT NOT LIMITED TO, DIRECT, INDIRECT, SPECIAL OR CONSEQUENTIAL DAMAGES, ARISING OUT OF, RESULTING FROM, OR IN ANY WAY CONNECTED WITH THE HBM SOFTWARE DOCUMENTATION, WHETHER OR NOT BASED UPON WARRANTY, CONTRACT, TORT, OR OTHERWISE, WHETHER OR NOT LOSS WAS SUSTAINED FROM, OR AROSE OUT OF THE RESULTS OF, OR USE OF, THE HBM SOFTWARE DOCUMENTATION. LICENSEES AGREE TO WAIVE ANY AND ALL CLAIMS AGAINST HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSOR(S), AND SHALL INDEMNIFY, DEFEND AND HOLD HARMLESS HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSOR(S) FOR ANY AND ALL LIABILITIES, CLAIMS, DEMANDS, DAMAGES, EXPENSES OR LOSSES THAT MAY ARISE FROM THE LICENSEE’S USE OR DISTRIBUTION OF THE HBM SOFTWARE DOCUMENTATION, INCLUDING ANY LIABILITIES OR DAMAGES FROM DERIVATIVE WORKS OR OTHER PRODUCTS BASED ON, OR RESULTING FROM, THE USE THEREOF.

This License Agreement is subject to change without notice and does not represent any commitment on the part of HBM UK Ltd and/or its affiliates to the Licensee, including any commitment to maintain or update the HBM Software Documentation. The names of companies, products, people, characters, and/or data mentioned in the HBM Software Documentation are not intended to represent any real individual, company, product or event, unless otherwise noted. Any rights not expressly granted herein are reserved for HBM UK Ltd.

TRADEMARKS:
ReliaSoft, Synthesis Platform, Weibull++, ALTA, DOE++, RGA, BlockSim, RENO, Lambda Predict, Xfmea, RCM++ and XFRACAS are all trademarks of ReliaSoft Corporation.

GlyphWorks, VibeSys, DesignLife and the nCode logos are all trademarks of HBM UK Ltd.

Other product names and services identified in the HBM Software Documentation are trademarks belonging to their respective trademark holders, and are used for illustration purposes. Their use in no way conveys an endorsement or other affiliation with HBM UK Ltd and/or its affiliates.
Table of Contents

Chapter 1: Getting Started.............................................................................................................. 1

New in Version 11: Xfmea, RCM++ and RBI................................................................................ 1

Parameter Diagrams (P-Diagrams) ................................................................................................. 1

Item Risk.................................................................................................................................. 2

New Options for Risk Discovery Ratings................................................................................... 2

Analysis Plan - Updated Way of Entering Team Members........................................................ 2

Change Log for Control Plans and P-Diagrams .......................................................................... 2

Mechanism of Failure is Now Available for Cause Records..................................................... 2

Ability to Link Multiple Actions to a Single Control................................................................. 2

Ability to Repeat Data in the Grayed Out Area of a Worksheet............................................. 3

Ability to Set the Quantity of an Item that Affects the FMRA.................................................. 3

Updated Select Existing Utility................................................................................................. 3

New Query Options..................................................................................................................... 3

Improved Excel Import/Export .................................................................................................. 3

Batch Update Reliability Policies ............................................................................................... 4

Ratings Update.......................................................................................................................... 4

Remove Links to FMEAs in Reference Projects....................................................................... 4

Option to Define a Default FMEA Structure for a Database.................................................... 4

Configure Color Spectrum......................................................................................................... 4

Auto Creation of Scheduled Tasks (RBI Only).......................................................................... 4

More Flexibility in Project Manager ......................................................................................... 4

Major Interface Updates for the Synthesis Enterprise Portal (SEP) ......................................... 5

Quick Tour................................................................................................................................... 5

Quick Tour of Xfmea and RCM++.............................................................................................. 5

Using Repositories and Projects ............................................................................................... 6

Xfmea/RCM++/RBI 11 User’s Guide
# Contents

- Standard Repositories ................................................................. 48
- Synthesis Files ............................................................................... 49
- Enterprise Repositories ............................................................... 50

## Projects ....................................................................................... 60
- Creating and Managing Projects .................................................. 61
- Project Properties .......................................................................... 62
- Project Owner ............................................................................... 65
- Public, Private and Reference Projects ......................................... 67
- Locked and Unlocked Projects ....................................................... 68
- Check In and Check Out Projects .................................................. 69

## Manage Projects Window ............................................................ 71
- Recycle Bin .................................................................................. 73

## Security ......................................................................................... 74
- Applying Login Security ............................................................... 74
- Planning Your Security Approach .................................................. 75
- User Accounts ............................................................................. 81
- Managing Security Groups .......................................................... 88
- Associating Security Groups with Active Directory ......................... 96
- Setting Item Permissions ............................................................... 98

## Status Indicators ......................................................................... 99
- Reset "In Use" Flags ...................................................................... 101
- Repository Logins ........................................................................ 102

## Repository Settings ..................................................................... 102
- E-mail Settings Page ..................................................................... 103
- Other Settings Page ..................................................................... 103
- Time and Usage Units .................................................................. 103
Contents

Default Name Formats ........................................................................................................ 104
Project Planning Resources ................................................................................................. 106
Working Days/Holidays ....................................................................................................... 107
XFRACAS Connection .......................................................................................................... 108
Managing and Restoring Data ............................................................................................ 109
Enterprise Database Maintenance ..................................................................................... 109
Standard Database Maintenance ....................................................................................... 110
Restore Points ..................................................................................................................... 112

Chapter 3: Desktop Application Interfaces ................................................................................. 115
Ribbon and Backstage View .................................................................................................... 115
Project Manager and My Portal ............................................................................................ 115
Status Bar ................................................................................................................................ 116
Show, Tile, Dock and Pin Panels ............................................................................................. 116
  Show or Hide ....................................................................................................................... 116
  Tile or View One Page at a Time ......................................................................................... 116
  Dock or Float ....................................................................................................................... 118
  Pinned or Unpinned ............................................................................................................ 120
Project Manager ..................................................................................................................... 121
  Opening a Project ............................................................................................................... 121
  Filtering the List of Projects ............................................................................................... 121
  Searching for a Particular Project ....................................................................................... 122
Current Project Explorer ........................................................................................................ 122
Working with Multiple Projects .......................................................................................... 124

My Portal ................................................................................................................................. 125
Portal Messages ..................................................................................................................... 126
Actions in My Portal ............................................................................................................. 127
## Contents

- ReliaSoft Online Pane ........................................................................................................... 156
- Help Center (File > Help) and Help Tab ............................................................................... 156
- Home Tab ................................................................................................................................ 158
- Clipboard ..................................................................................................................................... 158
- Edit .............................................................................................................................................. 159
- Move Record ........................................................................................................................... 159
- Reporting .................................................................................................................................... 160
- Launch ........................................................................................................................................ 160
- Synthesis .................................................................................................................................... 160
- My Portal Tab ............................................................................................................................. 161
- Messages ..................................................................................................................................... 161
- Actions ........................................................................................................................................ 161
- Users .......................................................................................................................................... 161
- Project Tab .................................................................................................................................. 162
- Management ............................................................................................................................... 162
- E-mail Project ............................................................................................................................ 164
- Security ....................................................................................................................................... 164
- Current Item ............................................................................................................................... 164
- Synthesis ..................................................................................................................................... 165
- Data Management ..................................................................................................................... 165
- Reports ....................................................................................................................................... 166
- System Hierarchy Tab ................................................................................................................ 166
- Add Items ................................................................................................................................. 166
- Risk Based Inspection (available only for RBI) ....................................................................... 167
- Current Item ............................................................................................................................... 167
- Tools .......................................................................................................................................... 168
Contents

XFRACAS ........................................................................................................................................ 170
Analyses Tab ................................................................................................................................ 171
Planning ...................................................................................................................................... 171
FMEA ........................................................................................................................................... 171
Other .......................................................................................................................................... 171
View Tab ..................................................................................................................................... 171
Refresh ....................................................................................................................................... 172
Project Manager ..................................................................................................................... 172
My Portal .................................................................................................................................... 172
Workspace Layout ................................................................................................................... 172
Expand/Collapse ...................................................................................................................... 173
Zoom ......................................................................................................................................... 174
Window ...................................................................................................................................... 174
FMRA .......................................................................................................................................... 174
Show ......................................................................................................................................... 175
Paste Special Window .............................................................................................................. 175
Active Tabs ............................................................................................................................... 175
Control Plan Tab ..................................................................................................................... 175
DRBFM Tab ................................................................................................................................ 177
DVP&R Tab ................................................................................................................................ 178
FMEA Tab .................................................................................................................................. 179
FMRA Tab .................................................................................................................................. 184
P-Diagram Tab .......................................................................................................................... 186
PFD Worksheet Tab - Ribbon ..................................................................................................... 186
Chapter 5: Configurable Settings ............................................................................................... 189
  Transferring Settings Between the Library and the Projects ...................................................... 189

Xfmea/RCM++/RBI 11 User’s Guide
Contents

Unmatched Settings Window ........................................................................................................ 191
Profiles/Library Manager ........................................................................................................... 192
Viewing or Editing Settings ....................................................................................................... 192
Importing Settings from Another Database ............................................................................ 193
Active File and Reset Library .................................................................................................. 193
Importing Settings to a Library ............................................................................................... 193
Importing an Entire Profile ...................................................................................................... 194
Copy Existing .......................................................................................................................... 194
Profiles ..................................................................................................................................... 195
Selecting the Default Profile .................................................................................................... 195
Profile Settings ........................................................................................................................ 196
Interface Styles ........................................................................................................................ 197
Viewing or Editing Settings .................................................................................................... 198
Customizing Record Properties ............................................................................................. 199
Modifying Drop-Down Lists .................................................................................................. 200
Worksheet Columns ................................................................................................................ 201
FMEA > RPNs ........................................................................................................................... 202
FMEA > Criticality ..................................................................................................................... 203
FMEA > Sync Options ............................................................................................................. 206
Control Plan > Sync Options .................................................................................................. 207
DVP&R > Sync Options ........................................................................................................... 208
Rating Scales ............................................................................................................................ 209
Editing a Scale ......................................................................................................................... 210
Quantitative Values ................................................................................................................ 210
Risk Discovery Questions ........................................................................................................ 211
Editing a Set of Risk Discovery Questions ............................................................................. 211
Contents

Moving Items ...................................................................................................................... 232
Cutting/Copying and Pasting Items .................................................................................... 232
Smart Add and Import ........................................................................................................ 233
Item Properties ....................................................................................................................... 234
Item Categories in Xfmea/RCM++/RBI ................................................................................... 236
Smart Add Category ............................................................................................................ 236
Select from Category List .................................................................................................... 237
Create Categories ................................................................................................................ 237
Smart Add Keywords ............................................................................................................... 238
Associated Analyses and Diagrams ......................................................................................... 239
Available Analyses ............................................................................................................... 240
Available Diagrams .............................................................................................................. 241
Importing Analysis Data ....................................................................................................... 241
Smart Add and Import ........................................................................................................ 241
Import Existing (Items or FMEA Records) ........................................................................ 243
Import Existing Items (Browse Method) ............................................................................ 245
Importing from Lambda Predict to Xfmea/RCM++/RBI ...................................................... 246
Importing MPC Systems Into Xfmea, RCM++ or RBI .......................................................... 248
Import or Sync from XFRACAS ........................................................................................... 250
Chapter 7: FMEA Analysis ..................................................................................................... 255
FMEA Background ............................................................................................................... 255
FMEA Applications and Benefits ......................................................................................... 256
When to Perform an FMEA .................................................................................................. 256
Basic Analysis Procedure for FMEA .................................................................................... 257
Identify the Functions, Failure Modes, Effects, Causes and Controls ................................ 261
Integration with Other Analyses (Including APQP) .......................................................... 264

http://xfmea.reliasoft.com
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>FMEA Worksheet</td>
<td>281</td>
</tr>
<tr>
<td>FMEA Filtered View</td>
<td>284</td>
</tr>
<tr>
<td>FMEA Records</td>
<td>285</td>
</tr>
<tr>
<td>Record # and ID</td>
<td>285</td>
</tr>
<tr>
<td>Associated Records</td>
<td>285</td>
</tr>
<tr>
<td>History (and History Log, if applicable)</td>
<td>286</td>
</tr>
<tr>
<td>Ribbon Commands</td>
<td>286</td>
</tr>
<tr>
<td>Functions</td>
<td>287</td>
</tr>
<tr>
<td>Failures (Functional Failures)</td>
<td>288</td>
</tr>
<tr>
<td>Effects</td>
<td>289</td>
</tr>
<tr>
<td>Causes (Failure Modes)</td>
<td>291</td>
</tr>
<tr>
<td>Controls in FMEAs</td>
<td>293</td>
</tr>
<tr>
<td>Actions in FMEAs</td>
<td>295</td>
</tr>
<tr>
<td>RPNs and Related Metrics</td>
<td>296</td>
</tr>
<tr>
<td>Configure Projects for RPN Metrics</td>
<td>296</td>
</tr>
<tr>
<td>RPN Metrics in FMEAs, Reports and Plots</td>
<td>298</td>
</tr>
<tr>
<td>Risk Ranking Logic</td>
<td>302</td>
</tr>
<tr>
<td>Item SxO and Item Risk</td>
<td>304</td>
</tr>
<tr>
<td>Risk Matrix</td>
<td>306</td>
</tr>
<tr>
<td>Quantitative Consequence Priority Numbers (QCPNs)</td>
<td>308</td>
</tr>
<tr>
<td>Criticality Analysis</td>
<td>310</td>
</tr>
<tr>
<td>Qualitative Criticality Analysis</td>
<td>310</td>
</tr>
<tr>
<td>Quantitative Criticality Analysis</td>
<td>311</td>
</tr>
<tr>
<td>MIL-1629A Criticality Analysis</td>
<td>315</td>
</tr>
<tr>
<td>FMEA Plots</td>
<td>317</td>
</tr>
<tr>
<td>Types of Plots</td>
<td>318</td>
</tr>
</tbody>
</table>

http://xfmea.reliasoft.com
<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy Information from the Plot</td>
<td>319</td>
</tr>
<tr>
<td>FMEA Dashboards</td>
<td>319</td>
</tr>
<tr>
<td>Data Source Drop-Down List</td>
<td>320</td>
</tr>
<tr>
<td>FMEA/FMRA Dashboard Data Fields</td>
<td>321</td>
</tr>
<tr>
<td>FMEA Tools</td>
<td>323</td>
</tr>
<tr>
<td>Find and Replace</td>
<td>323</td>
</tr>
<tr>
<td>Transfer Projects</td>
<td>324</td>
</tr>
<tr>
<td>Ratings Update</td>
<td>325</td>
</tr>
<tr>
<td>Failure - Cause Matrix</td>
<td>326</td>
</tr>
<tr>
<td>FMEA Statistics Window</td>
<td>326</td>
</tr>
<tr>
<td>Diagnostic Logic Assistant (DLA)</td>
<td>327</td>
</tr>
<tr>
<td>Chapter 8: RCM Analysis</td>
<td>329</td>
</tr>
<tr>
<td>RCM Background</td>
<td>329</td>
</tr>
<tr>
<td>Prepare for the Analysis</td>
<td>330</td>
</tr>
<tr>
<td>Select the Equipment to Be Analyzed</td>
<td>331</td>
</tr>
<tr>
<td>Identify the Functions</td>
<td>332</td>
</tr>
<tr>
<td>Identify the Functional Failures</td>
<td>332</td>
</tr>
<tr>
<td>Identify and Categorize the Effects of Failure</td>
<td>332</td>
</tr>
<tr>
<td>Identify the Causes of Failure (Failure Modes)</td>
<td>333</td>
</tr>
<tr>
<td>Select the Appropriate Maintenance Tasks</td>
<td>334</td>
</tr>
<tr>
<td>RCM References</td>
<td>336</td>
</tr>
<tr>
<td>Functional Failure Analysis (FFA)</td>
<td>336</td>
</tr>
<tr>
<td>Failure Effect Categorization (FEC)</td>
<td>338</td>
</tr>
<tr>
<td>Task Manager and Task Selection</td>
<td>340</td>
</tr>
<tr>
<td>Task Selection</td>
<td>340</td>
</tr>
<tr>
<td>Using Maintenance Task Selection Logic</td>
<td>341</td>
</tr>
</tbody>
</table>
Contents

Simulation and Cost Calculations ........................................................................................................ 342
Task Types in RCM++/RBI ....................................................................................................................... 346
Optimum Replacement Window .............................................................................................................. 348
Available Items .................................................................................................................................... 348
Planned and Unplanned Replacement Costs .......................................................................................... 349
Calculation Options .............................................................................................................................. 349
Results and Plots .................................................................................................................................. 349
Create Tasks .......................................................................................................................................... 349
Task Packaging ........................................................................................................................................ 349
Scheduled Task Packaging Window ....................................................................................................... 350

Chapter 9: RBI Analysis .............................................................................................................................. 355
RBI Background ....................................................................................................................................... 355
Introduction ........................................................................................................................................... 355
Consequences of Failure ......................................................................................................................... 356
Probability of Failure .............................................................................................................................. 356
Program Parts .......................................................................................................................................... 357
Date Definitions ....................................................................................................................................... 357
Risk Categories (Current Repository) ....................................................................................................... 358
The Scoring Matrix ................................................................................................................................. 361
Defining the Management Score ................................................................................................................. 361
Building the RBI System Hierarchy ......................................................................................................... 362
Adding RBI Equipment ............................................................................................................................ 363
Adding RBI Components ......................................................................................................................... 363
Converting System Hierarchy Items to RBI Equipment ............................................................................. 364
RBI Assessment ....................................................................................................................................... 364
RBI Properties .......................................................................................................................................... 364
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Properties</td>
<td>365</td>
</tr>
<tr>
<td>Damage Factors Selection</td>
<td>366</td>
</tr>
<tr>
<td>Damage Factor Properties</td>
<td>367</td>
</tr>
<tr>
<td>Consequence Properties</td>
<td>367</td>
</tr>
<tr>
<td>RBI Results</td>
<td>370</td>
</tr>
<tr>
<td>RBI Plots</td>
<td>374</td>
</tr>
<tr>
<td>Special Item Types</td>
<td>374</td>
</tr>
<tr>
<td>Configuring a HEXTUBE Component</td>
<td>374</td>
</tr>
<tr>
<td>Configuring Pressure Relief Devices</td>
<td>377</td>
</tr>
<tr>
<td>Table of Steel Types</td>
<td>379</td>
</tr>
<tr>
<td>Chapter 10: Analysis Plans</td>
<td>383</td>
</tr>
<tr>
<td>Analysis Plan Window</td>
<td>383</td>
</tr>
<tr>
<td>Team Tab</td>
<td>384</td>
</tr>
<tr>
<td>Analysis Checklist Tab</td>
<td>384</td>
</tr>
<tr>
<td>Ground Rules and Assumptions Tab</td>
<td>385</td>
</tr>
<tr>
<td>Work Sessions Tab</td>
<td>385</td>
</tr>
<tr>
<td>Quality Survey Tab</td>
<td>385</td>
</tr>
<tr>
<td>Chapter 11: Risk Discovery</td>
<td>387</td>
</tr>
<tr>
<td>Showing Results in the System Panel</td>
<td>387</td>
</tr>
<tr>
<td>Generating a Report</td>
<td>388</td>
</tr>
<tr>
<td>Using Questions</td>
<td>388</td>
</tr>
<tr>
<td>Showing Results in the System Panel</td>
<td>389</td>
</tr>
<tr>
<td>Generating a Report</td>
<td>389</td>
</tr>
<tr>
<td>Using Ratings</td>
<td>390</td>
</tr>
<tr>
<td>Showing Results in the System Panel</td>
<td>390</td>
</tr>
<tr>
<td>Generating a Report</td>
<td>391</td>
</tr>
</tbody>
</table>
## Chapters

### Chapter 12: Parameter Diagrams (P-Diagrams)

**Add a P-Diagram** ................................................................. 393
**Enter the Data** ................................................................. 393
**Select Existing Text** .......................................................... 394
**Import Elements from Excel** ............................................ 394
**Reports and Queries** ...................................................... 395
**P-Diagram Elements** ....................................................... 395
**Input Signals** ................................................................. 396
**Control Factors** ............................................................. 396
**Noise Factors** ............................................................... 396
**Ideal Responses** ............................................................. 396
**Error States** ................................................................. 397

### Chapter 13: Test Plans

**Selecting Which Columns to Display** ............................... 399
**Show Actions in Test Plans** ............................................. 400
**Associating Actions with Controls** ................................. 401
**Viewing Control Actions in Filtered View and Queries** ......... 402

### Chapter 14: Design Verification Plans (DVP&R)

**DVP&R Header** ............................................................... 404
**DVP&R Worksheet** ......................................................... 406
**DVP&R Worksheet Columns** ........................................... 408
**Synchronizing a DVP&R with a DFMEA** ......................... 409
**Sync Options for New DVP&Rs** ....................................... 410
**Sync Options for Existing DVP&Rs** ................................. 411

### Chapter 15: PFD Worksheets (Process Flow Diagrams)

**Adding a PFD Worksheet** ............................................... 413
Contents

PFD Worksheet Header................................................................. 415
PFD Worksheet Tab......................................................................... 415
PFD Worksheet Columns .......................................................... 418
Sync Options for PFD Worksheets ............................................. 419
  General Sync Workflow ......................................................... 420
Chapter 16: Process Control Plans.......................................... 425
  Adding a Control Plan .......................................................... 425
  Control Plan Header ............................................................... 425
  Control Plan Worksheet .......................................................... 427
  Control Plan Worksheet Columns ........................................... 429
Sync Options for Control Plans ................................................. 430
  Automatic Transfer ............................................................... 431
  Manual Transfer .................................................................. 431
Chapter 17: Design Reviews Based on Failure Mode (DRBFM)  433
  DRBFM Header ................................................................. 434
  DRBFM Worksheet .............................................................. 435
    Parts/Functions Columns ..................................................... 437
    Concerns Columns ............................................................ 437
    DRBFM Effects Columns .................................................... 438
    DRBFM Causes Columns .................................................... 438
    DRBFM Controls Columns ............................................... 439
    DRBFM Actions Columns .................................................. 439
  Transferring Data Between a DRBFM and a FMEA ............... 441
    Sending FMEA Data to the DRBFM ................................... 441
    Sending DRBFM Data to the FMEA .................................... 441
Chapter 18: FMEA Diagrams ............................................... 443

Xfmea/RCM++/RBI 11 User’s Guide xvii
Contents

FMEA Block Diagrams ............................................................................................................. 443
Create the FMEA Block Diagram ......................................................................................... 444
Add the Connections (Interfaces) Between Items .............................................................. 445
Create FMEA Functions ....................................................................................................... 446
Converting Existing Diagrams ............................................................................................. 447
Process Flow Diagrams ........................................................................................................... 447
Cause and Effect Diagrams ..................................................................................................... 448
Reading the Cause and Effect Diagram ............................................................................... 449
Failure Relationship Diagrams ............................................................................................. 451
Building Diagrams ................................................................................................................... 452
Connecting Blocks ............................................................................................................... 452
Arranging and Resizing Blocks ............................................................................................ 455
Keyboard and Mouse Combinations .................................................................................. 457
Diagram Find Window ........................................................................................................ 461
Diagram Ribbon ...................................................................................................................... 461
Diagram Ribbon Home Tab ................................................................................................. 461
Diagram Ribbon Diagram Tab ............................................................................................. 463
Diagram Ribbon Format Tab ............................................................................................... 465
Diagram Skins and Appearance Settings ................................................................................ 466
Using Diagram Skins ............................................................................................................ 467
Converting Version 9 Skins ................................................................................................. 469
Diagram Style Settings ........................................................................................................ 470
Block Style Settings ............................................................................................................. 473
Connector Style Settings ..................................................................................................... 476
Chapter 19: Failure Modes and Reliability Analysis (FMRA) ....................................................... 479
Enabling and Viewing the FMRA ........................................................................................ 479

http://xfmea.reliasoft.com
Query Templates..................................................................................................................... 519
   Using a Saved Template in the Query Utility................................................................. 520
   Saving New Templates from the Query Utility............................................................. 520
Chapter 22: Excel Templates for Import/Export................................................................. 523
   Import from Excel ....................................................................................................... 523
   Export to Excel .......................................................................................................... 524
   Creating and Managing Import/Export Templates ..................................................... 525
      Import/Export Template Window ........................................................................... 525
   Validating Data for Import ........................................................................................... 526
Chapter 23: Change Logs ................................................................................................. 529
   General Information About Change Logs ................................................................. 529
   Change Log Window (for Entire Analysis) ................................................................... 530
      Change Log Activation ............................................................................................. 530
      Version History ......................................................................................................... 531
      Change Log ............................................................................................................... 531
   Starting and Ending Revisions ................................................................................... 532
      To start a revision: .................................................................................................... 532
      To end a revision: ..................................................................................................... 532
      To reopen the most recent revision: ......................................................................... 533
      Version Details Window ........................................................................................... 533
   Record Change Log Window (for Specific Records) ....................................................... 533
   Reason for Change Window .......................................................................................... 533
   Electronic Approval Tracking ....................................................................................... 534
      Assign Approvers Window ....................................................................................... 534
      Approve Version Window ........................................................................................ 535
      Approve Multiple Change Logs ................................................................................ 535
Contents

Workflow Overview for Using a Change Log ................................................................. 536
Without Electronic Approval Tracking ........................................................................ 536
With Electronic Approval Tracking ............................................................................ 537
Chapter 24: Xfmea, RCM++ and RBI Settings .......................................................... 539
Synthesis Settings ....................................................................................................... 539
Backup/Check Out Options ....................................................................................... 541
Other Synthesis Settings ........................................................................................... 541
Application-Specific Settings ...................................................................................... 542
General Settings ......................................................................................................... 542
System Hierarchy Settings ......................................................................................... 543
FMRA Settings ............................................................................................................ 544
FMEA Hierarchy Settings .......................................................................................... 544
Reset Settings ............................................................................................................. 545
Project Item Settings .................................................................................................. 546
Region and Language Settings .................................................................................. 546
Viewing or Changing the Region and Language Settings for Your Computer .......... 547
Which Language is Selected by Default When You Install the Software .................... 549
Defining Date and Time Formats ............................................................................... 550
Changing the Decimal Symbol, the List Separator and the Currency Symbol ............ 550
Setting the Measurement System in the Page Setup .................................................. 551
Chapter 25: Synthesis Platform Tools ......................................................................... 553
Categories, Identifiers and Filters ............................................................................. 553
Defining Categories .................................................................................................... 553
Synthesis Identifiers ................................................................................................. 555
Project and Item Filters ............................................................................................ 558
Synthesis Explorer ................................................................................................................... 560
Save and Apply Views ............................................................................................................ 561
Project and Item Filters ......................................................................................................... 561
Category Panel ....................................................................................................................... 562
Built-in Find/Filter, Configuration and Grouping Tools ....................................................... 562
Synthesis Explorer Dashboards ............................................................................................ 563
Synthesis Explorer Properties .............................................................................................. 566
Synthesis Locator Links ......................................................................................................... 567
Creating a Locator Link ......................................................................................................... 568
Posting Locator Links on a Web Page .................................................................................... 568
Watches and Alerts ................................................................................................................ 569
Enable Alerts via E-mail or SMS .......................................................................................... 570
Subscribing to a Watch ......................................................................................................... 570
Action Alert Preferences ...................................................................................................... 572
Action and Gate Monitors .................................................................................................... 573
What is Your SMS Address? .................................................................................................. 573
History Logs ........................................................................................................................... 574
Activating a Project History Log .......................................................................................... 575
Viewing Record History Logs ............................................................................................... 576
Import, Export and Data Conversion ..................................................................................... 576
Importing from an Existing Repository .................................................................................. 577
Importing from Prior Version Files ....................................................................................... 578
Importing/Exporting Projects ............................................................................................... 591
Importing/Exporting Project Items or Resources .................................................................. 592
Importing from Excel or Delimited Text Files into a Folio .................................................... 594
Using XML in BlockSim and Lambda Predict ....................................................................... 598
Attachments ............................................................................................................................ 599
Attachment Locations .............................................................................................................. 601
Select Existing Text Window ..................................................................................................... 602
Project and Item Filters ........................................................................................................... 603
Record Filter ............................................................................................................................. 604
Phrase Sets ............................................................................................................................... 604
Field Text ................................................................................................................................... 605
Record Filter Options .............................................................................................................. 605
Check Spelling .......................................................................................................................... 607
Results Window ....................................................................................................................... 608
Quick Parameter Estimator (QPE) ............................................................................................ 609
Quick Parameter Estimator Wizard View ............................................................................... 610
Quick Parameter Estimator Expert View ............................................................................... 611
Quick Parameter Estimator (ALTA) ......................................................................................... 612
Chapter 26: Synthesis Resources .......................................................................................... 617
Types of Resources ................................................................................................................... 617
Used in Multiple Applications ............................................................................................... 617
Used Only in BlockSim ............................................................................................................. 619
Used Only in RENO ................................................................................................................. 619
Used Only in ALTA .................................................................................................................. 620
Local, Global and Reference Resources .................................................................................. 620
Parent/Child Resource Relationships ...................................................................................... 620
Keeping Resources Together .................................................................................................... 621
Creating and Selecting Resources .......................................................................................... 622
Opening a Resource Wizard ..................................................................................................... 622
Back Arrow and Main Page ....................................................................................................... 623
| Contents |
|---------------------------------|------------------|
| Selecting an Existing Resource | 624 |
| Creating a Resource             | 625 |
| Editing a Resource              | 625 |
| Removing a Resource             | 625 |
| Universal Reliability Definitions (URDs) | 626 |
| Naming the Resource             | 626 |
| Hierarchy Tab                   | 626 |
| Filtered Tab                    | 627 |
| Trace Usage                     | 628 |
| Models                          | 628 |
| Naming the Resource             | 628 |
| Associated Analysis             | 628 |
| Model Category                  | 628 |
| Model Type                      | 629 |
| Additional Tools                | 630 |
| Publishing Models               | 630 |
| Tasks                           | 632 |
| Corrective Tasks                | 636 |
| Preventive Tasks                | 639 |
| Inspection Tasks                | 641 |
| On Condition Tasks              | 644 |
| Task Scheduling                 | 645 |
| Crews                           | 647 |
| Spare Part Pools                | 649 |
| Metrics                         | 653 |
| Metric Types                    | 654 |
## Contents

Calculated Result and Saved Values ................................................................. 654  
Target Conditions and Result Indicator ......................................................... 655  
Identifiers, History, Watch and Trace Usage .................................................. 655  
Showing Metrics in Folios/Diagrams .............................................................. 656  
Using Metrics in Project Planner Gates ......................................................... 658  
Pushing Metrics from an FMRA ................................................................. 660  
Variables ........................................................................................................ 661  
Using Variables to Store Output Values in RENO ......................................... 662  
Profiles ........................................................................................................... 665  
Creating Profiles ......................................................................................... 665  
Importing Data from nCode GlyphWorks ..................................................... 667  
Maintenance Groups ..................................................................................... 668  
Maintenance Group Manager ....................................................................... 669  
Mirror Groups ............................................................................................... 671  
Task Packages .............................................................................................. 671  
Actions .......................................................................................................... 673  
Actions as Resources .................................................................................... 673  
Configurable Settings .................................................................................... 674  
Show/Hide Properties for Individual Records .............................................. 674  
Priority .......................................................................................................... 674  
Action Status and Review Status .................................................................. 675  
E-mail and Alerts ........................................................................................... 675  
Add to Outlook Calendar ............................................................................... 676  
Person Responsible and Resources ............................................................... 676  
Action Timeline and Status .......................................................................... 677  
Costs and Man Hours ................................................................................... 678  

http://xfmea.reliasoft.com
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action Status Updates</td>
<td>680</td>
</tr>
<tr>
<td>Review and Approve Actions</td>
<td>681</td>
</tr>
<tr>
<td>Configurable Settings for Actions and Controls</td>
<td>682</td>
</tr>
<tr>
<td>Actions Explorer</td>
<td>683</td>
</tr>
<tr>
<td>Controls</td>
<td>685</td>
</tr>
<tr>
<td>Configurable Settings</td>
<td>686</td>
</tr>
<tr>
<td>Resource Manager</td>
<td>686</td>
</tr>
<tr>
<td>Resource Filter</td>
<td>687</td>
</tr>
<tr>
<td>Built-in Find/Filter, Configuration and Grouping Tools</td>
<td>687</td>
</tr>
<tr>
<td>Creating, Viewing, Editing and Deleting Resources</td>
<td>687</td>
</tr>
<tr>
<td>Tracing Where Resources Are Used</td>
<td>688</td>
</tr>
<tr>
<td>Local and Global and Reference Resources</td>
<td>688</td>
</tr>
<tr>
<td>Exporting Information from the Resource Manager</td>
<td>689</td>
</tr>
<tr>
<td>Finding and Filtering Records</td>
<td>689</td>
</tr>
<tr>
<td>Configuring Columns</td>
<td>693</td>
</tr>
<tr>
<td>Grouping Panel</td>
<td>695</td>
</tr>
<tr>
<td>Removing Unused and Duplicate Resources</td>
<td>696</td>
</tr>
<tr>
<td>Select Resource Window</td>
<td>697</td>
</tr>
<tr>
<td>Trace Usage</td>
<td>698</td>
</tr>
<tr>
<td>Dependency Viewer</td>
<td>698</td>
</tr>
<tr>
<td>Dependency Viewer - Diagram View</td>
<td>700</td>
</tr>
<tr>
<td>Batch Properties Editor</td>
<td>703</td>
</tr>
<tr>
<td>Spreadsheet Editor</td>
<td>705</td>
</tr>
<tr>
<td>Exporting Information from the Batch Properties Editor</td>
<td>705</td>
</tr>
<tr>
<td>Chapter 27: Synthesis Project Planner</td>
<td>707</td>
</tr>
<tr>
<td>Creating a Project Plan</td>
<td>707</td>
</tr>
</tbody>
</table>
Contents

Importing or Starting Again from a Blank Plan ................................................................. 707
Project Plan Hierarchy .................................................................................................. 708
Project Planner Columns ............................................................................................. 709
Project Planner Timelines .......................................................................................... 710
Planned Dates ............................................................................................................... 710
Actual Dates ................................................................................................................ 711
Expected Dates ............................................................................................................ 711
Project Planner Gates .................................................................................................. 712
Gate Properties ............................................................................................................ 712
Gate Status .................................................................................................................. 713
Actions in Project Plans ............................................................................................... 713
Adding Actions to the Plan ......................................................................................... 714
Project Plan Summary Panel ....................................................................................... 714
Check Utilization ......................................................................................................... 717
Project Planner Gantt View ......................................................................................... 718
Project Planner Plot View .......................................................................................... 719
Set Colors .................................................................................................................. 720
Project Planner Dashboards ....................................................................................... 721
Data Source Drop-Down List ...................................................................................... 721
Examples for Different Field Types ............................................................................ 722
Project Planner Ribbon ............................................................................................... 724
Project Planner Tab ..................................................................................................... 724
View Tab ..................................................................................................................... 727
Chapter 28: Synthesis Plot Utilities ............................................................................. 729
Basic Plot Features ..................................................................................................... 729
Redraw Plots ................................................................................................................. 729
Contents

Plot Defaults Window: Plot Items Display Page ................................................................. 750
ReliaSoft Draw ......................................................................................................................... 750
Overlay Plots ........................................................................................................................... 750
Creating an Overlay Plot ..................................................................................................... 750
Adding or Removing Analyses ............................................................................................. 751
Available Plot Types for Overlay Plots ................................................................................ 751
Side-By-Side Plots ................................................................................................................... 752
Choosing Plots to Display .................................................................................................... 752
3D Plots ................................................................................................................................... 753
Creating 3D Plots ................................................................................................................. 753
Defining the X, Y and Z Axes ............................................................................................... 754
Rotating 3D Plots ................................................................................................................ 754
3D Plot Setup ...................................................................................................................... 756
Chapter 29: Synthesis Workbooks .............................................................................................. 759
Synthesis Workbook Wizard ................................................................................................... 759
If you prefer to start with a blank report: ........................................................................... 759
If you want to assign the first data source: ........................................................................ 759
If you want to use a saved template: ................................................................................. 760
Associated Data Sources......................................................................................................... 760
Associating Data Sources .................................................................................................... 760
Linking Multiple Data Sources with Different Time Units .................................................. 762
Synthesis Workbook Templates ............................................................................................. 762
Saving Your Own Templates ............................................................................................... 763
Using a Template ................................................................................................................ 763
Spreadsheet Module ............................................................................................................... 764
Send to Excel ....................................................................................................................... 764

http://xfmea.reliasoft.com
Contents

Inserting Functions .............................................................................................................. 764
Showing Formulas ............................................................................................................... 764
Recalculate Formulas .......................................................................................................... 765
Adding Custom Charts ........................................................................................................ 765
Defining Names ................................................................................................................... 765
Word Processing Module ........................................................................................................ 766
Using the Function Wizard .................................................................................................. 766
Using the Plot Wizard ......................................................................................................... 766
Using Spreadsheet References ........................................................................................... 766
Formulas and Functions .......................................................................................................... 766
Function Wizard - Data Sources .......................................................................................... 766
Function Wizard - Formulas ............................................................................................... 769
Data Entry Tips for Functions .............................................................................................. 770
Returning Confidence Bounds ............................................................................................ 774
Plot Wizard .............................................................................................................................. 775
Select the Plot Type ............................................................................................................ 776
Select the Data Source ........................................................................................................ 776
Insert the Plot Holder .......................................................................................................... 777
Custom Charts ........................................................................................................................ 778
Adding a Chart .................................................................................................................... 778
Changing the Data Displayed on an Axis ............................................................................ 779
Changing the Chart Type and/or Data Set .......................................................................... 779
Applying a Chart Layout and/or Chart Style ....................................................................... 780
Renaming Chart and Axes Titles ......................................................................................... 780
Modifying the Axes and Gridlines ....................................................................................... 781
Defined Names ...................................................................................................................... 781
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Syntax Rules for Names</td>
<td>781</td>
</tr>
<tr>
<td>Managing Names</td>
<td>782</td>
</tr>
<tr>
<td>Defining Names</td>
<td>782</td>
</tr>
<tr>
<td>Spreadsheet References</td>
<td>784</td>
</tr>
<tr>
<td>DOE Analysis Reports</td>
<td>785</td>
</tr>
<tr>
<td>Inserting a DOE Analysis Report</td>
<td>786</td>
</tr>
<tr>
<td>Using DOE Report Profiles</td>
<td>786</td>
</tr>
<tr>
<td>Chapter 30: Synthesis Dashboards</td>
<td>789</td>
</tr>
<tr>
<td>Dashboard Viewer</td>
<td>790</td>
</tr>
<tr>
<td>Resizing Panels</td>
<td>790</td>
</tr>
<tr>
<td>Showing Details in Charts and Pies</td>
<td>790</td>
</tr>
<tr>
<td>Drill Downs and Master Filters</td>
<td>791</td>
</tr>
<tr>
<td>Sorting and Filtering Data in a Grid</td>
<td>791</td>
</tr>
<tr>
<td>Printing or Exporting the Dashboard</td>
<td>791</td>
</tr>
<tr>
<td>Viewing Drill Downs</td>
<td>792</td>
</tr>
<tr>
<td>Using Master Filters</td>
<td>793</td>
</tr>
<tr>
<td>Dashboard Layout Manager</td>
<td>794</td>
</tr>
<tr>
<td>Show in Viewer</td>
<td>795</td>
</tr>
<tr>
<td>Layout Properties</td>
<td>795</td>
</tr>
<tr>
<td>Importing Layouts</td>
<td>796</td>
</tr>
<tr>
<td>Dashboard Layout Designer</td>
<td>796</td>
</tr>
<tr>
<td>Separate Layouts for Each Data Type</td>
<td>796</td>
</tr>
<tr>
<td>Configuring a Dashboard Item</td>
<td>796</td>
</tr>
<tr>
<td>Available Dashboard Items</td>
<td>802</td>
</tr>
<tr>
<td>Configuring a Drill Down</td>
<td>803</td>
</tr>
<tr>
<td>Filtering</td>
<td>803</td>
</tr>
</tbody>
</table>

http://xfmea.reliasoft.com
Chapter 31: Synthesis Data Warehouse ................................................................. 807
  Managing Data Sources ..................................................................................... 807
  Built-in Find/Filter, Configuration and Grouping Tools ................................. 808
  Building the Data Set ....................................................................................... 808
  Extracting Data from XFRACAS .............................................................. 809
  Data Fields for XFRACAS Data Collections ................................................ 811
  Transferring from the SDW to an Analysis Folio .......................................... 814
    Tips for Mapping the Columns ................................................................. 815
  SDW Dashboards ......................................................................................... 816
  Custom Connections in the SDW .............................................................. 817
    Connect to an External Database .......................................................... 817
    Connection Issues ..................................................................................... 817
    Connect to XFRACAS Report ............................................................... 819
  Import to a Static Data Collection ............................................................ 820
Chapter 32: Synthesis Enterprise Portal ......................................................... 821
  SEP Home .................................................................................................. 821
  Project Plans ............................................................................................... 822
  Actions and Portal Messages ...................................................................... 822
  Project and Analysis Summaries ............................................................... 822
  System Hierarchies and FMEAs ............................................................... 823
  Dashboards & Reports ............................................................................... 823
  Metrics (Key Performance Indicators) ......................................................... 823
  Synthesis Explorer and Synthesis Data Warehouse ...................................... 824
  XFRACAS ................................................................................................. 824
  How to Implement the SEP ................................................................. 824
    Establish the Database and Web Server(s) .............................................. 825
Contents

Install the Website and Connect to a Synthesis Repository .......................................................... 825
Set Up Synthesis Platform User Accounts and Permissions ......................................................... 825
Assign SEP Access to Users ........................................................................................................ 826
Enable Publish to Synthesis Enterprise Portal ............................................................................. 826
Configure Custom Content for Home ........................................................................................... 826
Configure URLs for Links to Actions in SEP ............................................................................. 827
Configure Links Between XFRACAS and SEP ............................................................................ 828
Distribute SEP Website Link to All Users ..................................................................................... 828

Customizing the SEP Home Page ............................................................................................... 828
Custom Content .......................................................................................................................... 828
Home Page Panels ....................................................................................................................... 828

My Projects in SEP ...................................................................................................................... 829
Managing Actions in SEP ............................................................................................................. 831
My Actions Panel in SEP Home .................................................................................................... 831
My Actions Page .......................................................................................................................... 831
Actions in a Project Summary ........................................................................................................ 833
Actions in a Project Plan or FMEA ............................................................................................... 834
Links to SEP from Action Alert E-mails and Portal Messages ..................................................... 835

Publishing to SEP ......................................................................................................................... 835
Data Sheets or Diagrams ................................................................................................................ 836
Synthesis Workbooks .................................................................................................................. 837
Prediction Reports and Plots ......................................................................................................... 837
Xfmea/RCM++/RBI Reports .......................................................................................................... 838

Dashboards and Reports in SEP .................................................................................................. 838
Save, Copy or E-mail the URL ...................................................................................................... 839
Watch This Report ....................................................................................................................... 839
Chapter 1: Getting Started

ReliaSoft's Xfmea facilitates data management and reporting for all types of Failure Modes and Effects Analysis - FMEA - and Failure Modes, Effects and Criticality Analysis - FMECA. Our RCM++ software facilitates the Reliability Centered Maintenance (RCM) analysis approach for creating scheduled maintenance plans, which is an important aspect of an effective asset management program. ReliaSoft's RBI software facilitates risk based inspection (RBI) analysis to the principles and guidelines presented in the American Petroleum Institute's recommendations in the RP 580 and RP 581 publications, as well as the American Society of Mechanical Engineers' recommendations in the ASME PCC-3-2007 publication.

This help file provides detailed documentation for all three products. The features that are available on your computer will depend on the license that you have purchased from ReliaSoft.

- This graphic indicates a feature that is available only for users with an RCM++ or RBI license. 🖼️ RCM++ & 🖼️ RBI Only
- This graphic indicates a feature that is available only for users with an RBI license. 🖼️ RBI Only

These applications are also part of the Synthesis Platform, which provides intelligent integration between reliability program activities and tools, while simultaneously facilitating effective information sharing and cooperation between engineering teams of any size. For information about features that are shared by all (or most) of the Synthesis desktop applications, see the Repositories and Projects, Desktop Application Interfaces and Synthesis Platform Tools chapters.

To get started learning about Xfmea, RCM++ and RBI, see New in Version 11: Xfmea, RCM++ and RBI or use the Contents navigate to a specific topic.

New in Version 11: Xfmea, RCM++ and RBI

Here's a quick overview of the main new and improved features in Xfmea, RCM++ and RBI Version 11.

Parameter Diagrams (P-Diagrams)

New in Version 11, a Parameter Diagram (P-Diagram) is a structured tool that identifies the inputs from a system and relates those inputs to the desired system outputs, while considering the controlled and uncontrolled factors. It is useful in brainstorming and documenting input signals, noise factors, control factors, error states and ideal responses, and helps the FMEA team understand and make visible the
robustness of the design that is being analyzed. It can provide important input to System and Design FMEAs.

**Item Risk**

For items, you can use the Item Risk feature to quickly evaluate the risk for items in the system hierarchy using the same Severity and Occurrence rating scales that are available to calculate RPNs in FMEAs.

**New Options for Risk Discovery Ratings**

For risk discovery analysis (e.g., preliminary risk analysis, change point analysis, equipment selection, etc.), you can choose to use either questions or ratings. The risk discovery ratings method uses a set of factors and ratings that calculate a numerical value. New in Version 11, you can specify how the ratings will be calculated — product, sum, max or average.

**Analysis Plan - Updated Way of Entering Team Members**

The Analysis Plan utility allows you to keep track of team members, ground rules, estimated completion dates, scheduled work sessions and other details that will help you to plan and manage your analysis projects. In Version 11, you can now import existing users as team members without having to manually enter their information.

**Change Log for Control Plans and P-Diagrams**

Change logs allow you to control when users will be able to edit analyses, and record a history of revisions. The change log functionality is now available for control plans and P-Diagrams in addition to FMEAS and DVP&Rs.

**Mechanism of Failure is Now Available for Cause Records**

The Mechanism of Failure field is now available for cause records in addition to failure records. The user can choose whether to enable it for each record type.

**Ability to Link Multiple Actions to a Single Control**

You can now associate multiple actions with a single control.
Ability to Repeat Data in the Grayed Out Area of a Worksheet

A new Application Setup option allows you to display relevant text from a prior row in the gray areas of analysis worksheet views. For example, if there are 3 failures for the same function, the worksheet will show the function description in all 3 rows.

Ability to Set the Quantity of an Item that Affects the FMRA

In the Operation properties of an item, you can now define how many identical sub-items the item represents. This affects the calculations in the FMRA.

Updated Select Existing Utility

In the Select Existing Text window, there are now more options to identify and select the different sources of data (e.g., you can copy function descriptions from another FMEA, a phrase set, the PFD Worksheet, the system hierarchy or the P-Diagram).

In the FMEA and P-Diagram, you can now use this utility to select multiple descriptions and create new records.

New Query Options

The Query utility includes several new features, among them:

- You can now query for Cause records that do not have associated actions and/or control records. This is particularly useful when searching for causes with high RPN values and no assigned actions.
- You can now query for Action records that are associated with control records.

Improved Excel Import/Export

There is now more flexibility for importing/exporting system hierarchy and FMEA data via Excel, including options to:

- Match record IDs during import (to update existing records in the FMEA)
- Import system hierarchy items below the selected item
- Export data from linked FMEAs
Chapter 1: Getting Started

Batch Update Reliability Policies
You can now define separate options for items with dependents and items without dependents when using the batch update utility (e.g., you can choose to define the reliability at the component level unless the item has an FMEA).

Ratings Update
When using risk priority numbers in an FMEA, you can now set the revised ratings to match the initial rating values in an FMEA if they are not already defined. For example, if the recommended actions do not reduce the severity of an effect, then you can leave the Revised Severity field blank while recording the analysis and later use the utility to set all of the empty revised rating fields to match the initial ratings.

Remove Links to FMEAs in Reference Projects
If you used FMEAs linked from a reference project to build your FMEA, you will need to remove the links when you finalize the project so that the FMEAs are no longer updated automatically when there is a change in the external source. You can now quickly remove the links to all external FMEAs with a single command, replacing the records with new unique records in the local FMEA.

Option to Define a Default FMEA Structure for a Database
You can now set a default FMEA structure (i.e., Effects Before Causes, Grouped Causes and Effects or Causes Before Effects) for all projects created in a database.

Configure Color Spectrum
For features in BlockSim, Lambda Predict and Xfmea/RCM++/RBI that use a color spectrum to highlight results of high, medium or low concern, the Application Setup now provides the option to select the color that will be used for each range.

In Xfmea/RCM++/RBI, these colors are used in the FMRA to highlight blocks that need improvement in each calculated result column.

Auto Creation of Scheduled Tasks (RBI Only)
In RBI when you calculate the results, RBI will automatically create an Inspection or Preventive task at the appropriate date.

More Flexibility in Project Manager
For all Synthesis desktop applications, the project filter now gives the option to select specific projects (instead of only filtering by specific criteria such as "Project Owner"). If you’re working
in an enterprise repository with many projects, this makes it easier for you to quickly access the specific projects of interest to you.

Major Interface Updates for the Synthesis Enterprise Portal (SEP)

If your organization chooses to implement a web-based Synthesis Enterprise Portal (SEP) for an enterprise database, the entire team – including managers and colleagues who don't have Synthesis desktop applications installed – will be able to access key analysis and project management details from any web-enabled device.

In Version 11, the SEP has a fresh new look with responsive design for better performance on mobile devices and more control for quickly accessing the information that’s of interest to you. The website provides at-a-glance summaries of the project plans, actions, messages, metrics, dashboards and reports that you need to stay on top of, and makes it easy to drill down for more detail. It also allows users throughout your organization to view the FMEAs and published reports created in ReliaSoft’s Xfmea/RCM++/RBI without having the desktop application installed.

Quick Tour

Quick Tour of Xfmea and RCM++

Xfmea facilitates data management and reporting for all types of FMEA (including Design FMEA, Process FMEA, FMECA, etc.). It also supports related analyses such as P-Diagrams, DVP&Rs (Test Plans), Design Reviews Based on Failure Mode (DRBFMs), Process Flow Diagrams and Process Control Plans.

RCM++ facilitates the Reliability Centered Maintenance (RCM) approach for creating effective scheduled maintenance plans. It supports traditional RCM decision logic diagrams, and also offers simulation/calculation engines to compare maintenance strategies based on cost and availability.

Answer a wide variety of questions such as:

- What is the risk in a product or process?
- Which components or assemblies pose the greatest risk?
- What failure modes might occur? What is the effect of failure?
- What controls are in place to mitigate the risk?
- What tests need to be performed?
Chapter 1: Getting Started

- How can we improve the design?
- How should we plan for scheduled inspections and maintenance?

Using Repositories and Projects

**File Menu**

Use commands on the File menu (New, Recent or Open Repository) to create or open a Synthesis repository (database). (See Database Types.)

Each database supports simultaneous access by multiple users. If you have admin permissions, use File > Manage Repository to control user access and manage configurable settings that apply throughout the database. (See Security Options and Backstage View.)

Use File > Help to access online help and shipped examples.

![File Menu screenshot](http://xfmea.reliasoft.com)

**Project List**

Each database can contain multiple projects. Use the project list to create or open a Synthesis project. (See Project Manager.)

If you have a lot of projects:

- Use the project filter to limit what’s displayed.
• Use the **project category** to group projects within the list.

**System Panel and Analysis Panel**

The **System panel** shows the items that may be analyzed in the project.

- It can be a single item or a complex multi-level system configuration.
- It can be physical components/equipment or steps in a process.
The **Analysis panel** shows properties and analyses for the item that is currently selected.

![Analysis panel](image)

**Project Properties**

**FMEA Structure**

Each project has an **FMEA structure** that will be the same for all FMEAs and RCMs in the project.

- **Grouped Effects and Causes** (commonly used for FMEA)

  The effects will be entered as separate records but displayed together in the FMEA; the software calculates RPNs based on the highest severity rating.

<table>
<thead>
<tr>
<th>Description</th>
<th>Si</th>
<th>Oi</th>
<th>Di</th>
<th>RPNi</th>
</tr>
</thead>
<tbody>
<tr>
<td>Function</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Failure Mode A</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Grouped Effects</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Effect 1 (2)</td>
<td></td>
<td></td>
<td></td>
<td>8</td>
</tr>
<tr>
<td>Cause 1</td>
<td>5</td>
<td>5</td>
<td>200</td>
<td></td>
</tr>
<tr>
<td>Cause 2</td>
<td>5</td>
<td>5</td>
<td>200</td>
<td></td>
</tr>
<tr>
<td>Cause 3</td>
<td>5</td>
<td>5</td>
<td>200</td>
<td></td>
</tr>
</tbody>
</table>
• **Effects Before Causes** (can be used for FMEA or RCM)

<table>
<thead>
<tr>
<th>Description</th>
<th>Si</th>
<th>Oi</th>
<th>Di</th>
<th>RPNi</th>
</tr>
</thead>
<tbody>
<tr>
<td>Function</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Failure Mode A</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Effect 1</td>
<td></td>
<td></td>
<td>5</td>
<td>200</td>
</tr>
<tr>
<td>Cause 1</td>
<td></td>
<td></td>
<td>5</td>
<td>200</td>
</tr>
<tr>
<td>Cause 2</td>
<td></td>
<td></td>
<td>5</td>
<td>200</td>
</tr>
<tr>
<td>Cause 3</td>
<td></td>
<td></td>
<td>5</td>
<td>200</td>
</tr>
</tbody>
</table>

• **Causes Before Effects** (sometimes used for RCM)

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Function</td>
</tr>
<tr>
<td>Functional Failure</td>
</tr>
<tr>
<td>Failure Mode</td>
</tr>
<tr>
<td>Effect</td>
</tr>
</tbody>
</table>

**Configurable Settings**

Each project also has its own **configurable settings** that enable you to customize:

• Data fields and names
• Classifications, categories and other drop-down lists
• Rating scales and preferences for FMEA risk priority metrics
• Logic for risk discovery and RCM decision charts

Use the **Select Profile from Library** option in the project properties to quickly apply a predefined group of settings.
Using FMEAs

Failure Modes and Effects Analysis (FMEA) and Failure Modes, Effects and Criticality Analysis (FMECA) are methodologies designed to identify potential failure modes for a product or process, to assess the risk associated with those failure modes, to rank the issues in terms of importance and to identify and carry out corrective actions to address the most serious concerns.

The basic steps for using an FMEA are:

1. **Create the project and set project properties**

   Choose **Project > Management > Create Project**.

   In the Project Properties window, specify the **FMEA Structure** and the **Profile** that will be used to set the configurable settings. (See **Choosing the FMEA Structure** and **Profiles**.)

   ![FMEA Structure and Profile Selection](image)

2. **Add items in the system hierarchy**

   The first item is added to the system hierarchy when you create the project. Use the Properties tab in the Analysis panel to rename it and set other properties.

   ![Project Structure and Properties](image)
To add items, right-click inside the system hierarchy and choose Add System, Add Next Level Item, etc. (See Building the System Hierarchy.)

3. Add a new FMEA

To add an FMEA for an item, right-click the item in the system hierarchy and choose Analyses > Add FMEA.

4. Add records in the FMEA hierarchy

The Hierarchy tab for an FMEA displays the analysis records in a hierarchical tree, which tends to be good for viewing a lot of information in a small amount of space. In this view, you will use properties windows to add or edit FMEA records.
Chapter 1: Getting Started

When you add a new FMEA, the Function window will automatically open. Enter the details and click either **Add Function** (to add the next function description), **Add Failure** (to add the first failure mode for this function) or **OK** (to close the window).

5. **Use Select Existing Text utilities**

The Select Existing Text window provides a list of existing descriptions that might apply to the current text field or analysis. (See [Select Existing Text Window](http://xfmea.reliasoft.com).)
If you want to use this utility to replace or append text in an input field, click the icon next to the field.

The Select Existing Text window can also be used to add multiple records at once. For example, right-click a function record and choose **Add Multiple Failures > Select Existing Text**.

6. **View RPNs and related metrics**

You can choose to calculate and display a variety of metrics based on the Severity, Occurrence and Detection ratings that have been assigned for effects and causes in the FMEA: RPN, SxO, SOD, SD or QCPN. (See [RPNs and Related Metrics](#).)

To configure the metrics that are enabled for the current project, choose **FMEA > Tools > Configurable Settings**.

On the RPNs page, use the Enabled column to specify which metrics will be available in the current project.
Use the **Highlight Priority Based On** area to configure the logic that will be employed when a user turns on the priority highlights feature. (See FMEA > RPNs.)

To choose which metrics will be displayed in the FMEA hierarchy for your computer, right-click a column header in the FMEA and choose **Customize Columns**.

To turn on priority highlighting, choose **FMEA > Tools > Highlight Priority**.

7. Use the filtered and worksheet views
   a. **Filtered view**

   Click the Filtered tab at the bottom of the FMEA to open the filtered view. This view presents a sortable list of all records of a particular type, such as causes sorted by RPN or actions sorted by due date. (See FMEA Filtered View.)
Use the **Filter By** drop-down list to select which records are displayed. Then click inside the column header you wish to sort by.
b. **FMEA worksheet**

Click the Worksheet tab at the bottom of the FMEA to open the worksheet view. This view allows you to type directly into the worksheet cells and tab through the analysis as you would in a spreadsheet application. (See [FMEA Worksheet](http://xfmea.reliasoft.com).)

<table>
<thead>
<tr>
<th>Function</th>
<th>Potential Failure Mode</th>
<th>Potential Effect(s) of Failure</th>
<th>SEV</th>
<th>Classification</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Projector provides the 2X zoom capability throughout the life of the projector under all operating conditions as defined in the technical specification</td>
<td>Zoom capability is less than 2X</td>
<td>Unable to enlarge image to required specification. Image is too small for close-up projection. (7)</td>
<td>7</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>The image is distorted at the maximum zoom of 2X</td>
<td>Image is unclear, difficult to read printed words (7)</td>
<td>7</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>The zoom capability degrades over the life of the project</td>
<td>Unable to enlarge image to required specification. Image is too small for close-up projection. (7)</td>
<td>7</td>
<td></td>
</tr>
</tbody>
</table>

To use the entire workspace for the worksheet view, choose **View > Workspace Layout > Hide System Panel.**

To return to a split workspace, choose **View > Workspace Layout > Split Panels.**

8. **Create plots**

Choose **Home > Reporting > Plots.** (See [FMEA Plots](http://xfmea.reliasoft.com).)
Select the item(s) that you want to include in the plot. Then use the control panel to select the plot type and other settings.

9. Run a query

Choose Home > Reporting > Queries. (See Query Utility.)
Chapter 1: Getting Started

First use the left panel to specify the data source (selected projects throughout the database or selected items within the current project). Then use the right panel to specify the query criteria and output preferences.

Select the type of record you wish to query

Click Run Query to view the records that match the criteria.

10. View a dashboard

Choose Home > Reporting > Dashboard > Dashboard Viewer. (See FMEA Dashboards.)
In the **Layout** drop-down list, select one of the layouts that have been predefined for FMEA data and then use the dashboard to view the desired information. For example, in the RPN Dashboard you can click an item in the **Item Drill Down** panel to select which item’s data will be displayed in the other 2 panels.

11. **Generate a report**

Choose **Home > Reporting > Reports**. (See **Reports Window**)

---

_Xfmea/RCM++/RBI 11 User’s Guide_ 19
Select the items that you want to create a report for, the report forms you want to include in the generated report and the desired output type (Excel or Word).

Click **Generate Report** to create the report.

**Using RCMs**

Reliability Centered Maintenance (RCM) analysis provides a structured framework for analyzing the functions and potential failures for a physical asset in order to develop a scheduled maintenance plan that will provide an acceptable level of operability, with an acceptable level of risk, in an efficient and cost effective manner.

The basic steps for performing RCM analysis are:
1. **Create the project and set project properties**

Choose **Project > Management > Create Project**.

In the Project Properties window, specify the **FMEA Structure** and the **Profile** that will be used to set the configurable settings. (See [Choosing the FMEA Structure and Profiles](#).)

<table>
<thead>
<tr>
<th>FMEA Structure</th>
<th>Select Profile from Library</th>
</tr>
</thead>
<tbody>
<tr>
<td>Effects Before Causes</td>
<td>Standard RCM</td>
</tr>
</tbody>
</table>

2. **Add items in the system hierarchy**

The first item is added to the system hierarchy when you create the project. Use the Properties tab in the Analysis panel to rename it and set other properties.
Chapter 1: Getting Started

To add items, right-click inside the system hierarchy and choose Add System, Add Next Level Item, etc. (See Building the System Hierarchy.)

3. **Perform equipment selection**

   For each system hierarchy item that you want to perform equipment selection for, right-click the item and choose Analyses > Add Risk Discovery. (See Risk Discovery.)
Depending on the configurable settings for the project, this can be a list of yes/no questions or a set of rating scales.

<table>
<thead>
<tr>
<th>Label</th>
<th>Question</th>
<th>Response</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Safety</td>
<td>Could failure affect safety or have other hazardous consequences?</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Detectability</td>
<td>Could failure be undetectable or not likely to be detected during normal operation?</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Operational</td>
<td>Could failure have significant operational impact?</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Economic</td>
<td>Could failure have significant economic impact?</td>
<td>Yes</td>
<td></td>
</tr>
</tbody>
</table>

4. **Add a new functional failure analysis**

Right-click the system hierarchy item that you want to create a functional failure analysis for and choose **Analyses > Add FMEA**.
5. **Add functional failure analysis records**

When you add the analysis, the Function window will automatically open. Enter the details and click either **Add Function** (to add the next function description), **Add Failure** (to add the first functional failure for this function) or **OK** (to close the window).

Continue adding analysis records as needed. Note that RCM failure modes are described using the cause record type.
6. **Perform failure effect categorization**

Right-click an effect in the functional failure analysis and choose **Effect Categorization**. (See **Failure Effect Categorization**.)

The questions and categories depend on the configurable settings for the project.
7. **Perform maintenance task selection and add a task**

Right-click a failure mode (cause) and choose **Task Manager**. (See **Using Maintenance Task Selection Logic**.)

<table>
<thead>
<tr>
<th>Description</th>
<th></th>
<th></th>
<th>FFE</th>
</tr>
</thead>
<tbody>
<tr>
<td>To use internal combustion to rotate the crankshaft and camshaft, thereby providing power to the vehicle.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fails to provide power to the vehicle.</td>
<td></td>
<td></td>
<td>FEE</td>
</tr>
<tr>
<td>Automobile does not function properly.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Engine oil is depleted or dirty; oil filter is dirty.</td>
<td></td>
<td></td>
<td>EO</td>
</tr>
<tr>
<td>Engine air filter is damaged.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Problem with spark plugs.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Problem with engine valve clearance.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Problem with the timing belt.</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
In the Task Manager, answer the questions by clicking inside the Yes/No column. These questions may or may not be dependent on the failure effect categorization, depending on the task selection logic defined for the project.
Chapter 1: Getting Started

To add a task, click **Add Task**.

- Specify the task name and task type (see [Task Types in RCM++/RBI](http://xfmea.reliasoft.com)), then indicate when the task is to be performed (see [Task Scheduling](http://xfmea.reliasoft.com)).
Chapter 1: Getting Started

- Continue to specify task properties as needed. The configurable fields for traditional RCM are entered under the RCM node. (For information on defining tasks for simulation and cost calculations, see Using Simulation and Cost Calculations.)
Chapter 1: Getting Started

More Analyses and Tools

Analysis Plans

Analysis Plans allow you to keep track of team members, ground rules, estimated completion dates, scheduled work sessions and other details that will help you to plan and manage your FMEA and RCM projects.
Parameter Diagrams (P-Diagrams)

A **Parameter Diagram (P-Diagram)** is a structured tool that identifies the inputs from a system and relates those inputs to the desired system outputs, while considering the controlled and uncontrolled factors.
FMEA Block Diagrams

An FMEA Block Diagram visually depicts the system assembly that will be analyzed in a design FMEA. These diagrams help to define the scope of a particular analysis project and also may provide additional information that will be useful to the analysis team when they attempt to identify potential failure modes.
**PFD Worksheets**

A PFD worksheet records detailed information, including process characteristics (inputs) and product characteristics (outputs), for each step of the manufacturing or assembly process. The complete PFD worksheet provides a structure for preparing process FMEAs (PFMEAs) and control plans.

```
<table>
<thead>
<tr>
<th>Op Seq Number</th>
<th>Operation Description</th>
<th>Operation Type</th>
<th>Symbol</th>
<th>Changeover</th>
<th>Class</th>
<th>Significant Product Characteristics (Outputs)</th>
<th>Class</th>
<th>Significant Process Characteristics (Inputs)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.1.1</td>
<td>Front Door L.H. - Hang Process</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1.1.1.1</td>
<td>Remove door assembly from conveyor using fixture (eye &amp; move to vehicle body)</td>
<td>Move</td>
<td></td>
<td></td>
<td>P,T</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1.1.1.2</td>
<td>Align hinge attachment holes on door to body &amp; finger start 4 bolts</td>
<td>Fab</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1.1.1.3</td>
<td>Secure alignment fixture to opening &amp; remove transfer fixture</td>
<td>Move</td>
<td></td>
<td></td>
<td>P,T</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1.1.1.4</td>
<td>Bring automatic bolt driver to assembly and drive 4 bolts</td>
<td>Fab</td>
<td></td>
<td></td>
<td>T</td>
<td>Camp load between hinge strap and hinge pillar</td>
<td>C</td>
<td>Bolt torque (4)</td>
</tr>
<tr>
<td>1.1.1.5</td>
<td>Remove bolt driver when cycle is complete</td>
<td>Move</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```
Chapter 1: Getting Started

Control Plans

Control plans are used to track critical characteristics that must be kept in control during a manufacturing or assembly process, and record the methods for maintaining control.

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Op. No.: Manual application of wax in molded door cover over inner door leaves</td>
<td>Spray wax A-12345</td>
<td>1</td>
<td>Wax thickness</td>
<td>Manually inserted spray head not inserted far enough</td>
<td>S</td>
<td>Wax thickness must be between 0.1 and 0.0</td>
<td>Instrument (Y12345)</td>
<td>10</td>
<td>per hour</td>
<td>Variables check for wax thickness</td>
<td>Check the insertion of the spray head and reapply wax as affected units</td>
</tr>
<tr>
<td>2</td>
<td>Spreader head dropped because viscosity is too high, temperature is too low or pressure is too low</td>
<td>S</td>
<td>Viscosity must be AA to BB, Temperature must be CC to DD, Pressure must be EE to FF.</td>
<td>Instrument (Y12345)</td>
<td>All startup and after idle periods</td>
<td>Test spray pattern at startup and after idle periods</td>
<td>Spray head maintenance</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Spray head deflected due to impact</td>
<td>S</td>
<td>Full inspection and cleaning of the spray head.</td>
<td>Monthly</td>
<td>Preventive maintenance program to maintain heads</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Sprayer leaves insufficient</td>
<td>S</td>
<td>Wax meter over the following critical areas: A1, B1, C1, and D1.</td>
<td>Visual</td>
<td>10</td>
<td>per hour</td>
<td>Lab sampling and visual check for coverage of critical areas</td>
<td>Planned the operator of the appropriate spray time and reapply wax as affected units</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Test Plans

The Test Plan tab in the Analysis panel displays a list of actions that describe specific tests that need to be performed. The list is created on-the-fly based on actions and/or controls in the FMEA.
Technical Support
ReliaSoft reliability software products are renowned for their ease of use and unparalleled after sale support. For users with an active maintenance agreement, we provide technical support for software-related issues via a network of regional offices and partners/distributors throughout the world.

You can request assistance directly from within the software by choosing File > Help > E-mail Support. This option creates an e-mail message that is pre-populated with information about your license and operating system, which the technical support representative will need for troubleshooting the issue.

You can also contact us directly via phone, e-mail or mail. To find the office that serves your region, choose File > Help > Contact Global Support Center or visit http://www.reliasoft.com/contact.htm.

When Requesting Support
When you contact ReliaSoft to request technical support, please be prepared to provide the following information:

- Your phone number and e-mail address.
- The product name and the Compile Release Version number of your application. To determine the Compile Release Version (CRV) of the application on your computer, choose File > Help. The CRV is displayed in the About area. Note that the CRV will also indicate whether you are running the 32-Bit version or the 64-Bit version of the software.
- Your product license key.
  - To determine the license for the application on your computer, you can choose File > Application Setup and click any of the main headings in the Application Setup window.
- The operating system (e.g., Windows 7), RAM and hard disk space on your computer.
- Describe what you were doing when the problem occurred and exactly what happened. Please include the specific wording of any message(s) that appeared.

Note: ReliaSoft technical support representatives are not reliability consultants, and their assistance is limited to technical issues that you may encounter with the software tools. To get assistance with your analysis from a subject matter expert, please contact Reliability Consulting Services. ReliaSoft also offers
a comprehensive selection of training courses that cover both the underlying principles and theory, as well as the applicable software tools. For details, visit http://seminars.reliasoft.com/

Reliability Consulting

If your organization does not have sufficient time, expertise or objectivity in-house to accomplish specific reliability goals, turning to ReliaSoft expert reliability consultants can prove to be the most effective and economical solution. Whether you need a quick statistical analysis, a complete assessment of your reliability program plan or something in between, Reliability Consulting Services (RCS) is ready to help.

- Our reliability consulting services team has combined expertise in almost all areas of reliability and quality engineering with experience that spans a broad spectrum of product types, from micro-electronics and appliances to advanced weapons systems and off-shore oil well drilling equipment.

- Unlike engaging a consultant who works independently, RCS consultants have direct access to all of ReliaSoft global resources, expertise and contacts.

- Our team-based approach to consulting, combined with ReliaSoft global reliability engineering organization, allows us to provide you with reliability consultants who understand your culture and speak your language while ensuring that the appropriate reliability expertise can be applied to each and every project.

- RCS is structured to accommodate requests of any size or complexity, from short telephone consultations to multiple experts at a client's site for an extended time period.

Please visit http://consulting.reliasoft.com for a published list of commonly requested services, answers to frequently asked questions, and other useful information about this service.

System Requirements

In addition to the information below, ReliaSoft provides an automated tool that determines whether your computer and Internet connection meet the requirements for running and activating Synthesis. It will also determine whether you could install the 64-bit version of Synthesis, if desired. [Download Requirements and Compatibility Test Tool...]

Operating Systems

32- and 64-bit versions are supported, except where noted. [See our 32-bit vs. 64-bit FAQ...]
• Microsoft Windows® 7, Windows 8, Windows 8.1, or Windows 10.

• Microsoft Windows Server 2008 with Service Pack 2, Windows Server 2008 R2 (64-bit version), or newer. (Requires a license that specifically allows server installations/deployments.)

**Note:** Upgrading your operating system after Synthesis has already been installed can cause issues with the activation. To prevent this, it is recommended to uninstall Synthesis prior to upgrading your operating system and then reinstall it after the upgrade. For other options, and for information about how to handle the "activated license is corrupt" message that may appear if you upgrade your operating system with live activations, please refer to [http://www.reliasoft.com/support/rs20025.htm](http://www.reliasoft.com/support/rs20025.htm).

**Minimum Hardware Requirements**

- Intel Pentium® processor; 1.5 GHz or faster processor
- 2 GB of RAM for the 32-bit version of Windows; 8 GB of RAM for the 64-bit version.
- Display: 1024 x 768 or higher resolution at 96 dpi, with 24-bit color and 64 MB of dedicated VRAM.
- 1 GB of free disk space for install; minimum of 500 MB swap space.
- Internet connection is required to use the License Manager and the internet-enabled features in the software interface.

**Additional Software**

- Microsoft Office 2000 or higher (Excel®, Word and Outlook®) are required for automated exports, report generation and e-mail/calendar integration. ReliaSoft recommends Microsoft Office 2010.

**Enterprise Database Platforms**

32- and 64-bit versions are supported.

- SQL Server® 2008 or newer
- SQL Server Express Edition 2008 or newer
- Oracle® 10g or newer
- Oracle Express 11g or newer

Although the enterprise database platform (Microsoft SQL Server or Oracle) could be installed on the same computer where the Synthesis applications reside, most organizations will choose to set up a separate server to host the database. Both the 32-bit and 64-bit versions of the
Synthesis-enabled applications will work with either the 32-bit or 64-bit versions of a back-end database/server. The minimum hardware/software requirements for each server hosting the database should be obtained directly from the selected database vendor (i.e., Microsoft or Oracle). In general, ReliaSoft recommends a minimum CPU speed of 2 GHz and 4 GB of RAM.

**Tip:** If you're considering the option to use the free "Express" edition of Microsoft SQL Server, the document at [http://www.reliasoft.com/synthesis/sql_express.htm](http://www.reliasoft.com/synthesis/sql_express.htm) provides some information that may help you to get started.

## Synthesis Installation and Licensing

There are two alternative ways that Synthesis desktop applications may be licensed on your computer. The installation process depends on the type of licensing.

- **Locally Hosted Licensing**
  - You received a license file (*.lic) and/or a license settings file (*.prnrsl)
  - Allows your organization to manage license seats or, for token-based licenses, CRS units in-house without the requirement to connect with ReliaSoft’s external license server

- **ReliaSoft-Hosted Licensing**
  - You received only a license key (a 32-digit alphanumeric code)
  - Requires you to connect with ReliaSoft’s secure external license server to activate/deactivate licenses and to control access for multi-user (floating) license seats

One or both methods can be used on the same computer. For example, if you have your own single-user license for BlockSim and will share your department’s new multi-user (floating) license for Weibull++/ALTA, you will receive a license key for BlockSim and a license settings file for Weibull++/ALTA.

If you will use both types of licensing on the same computer, use the install instructions for locally hosted licenses. When you launch any of the applications that aren’t included in your license settings file, the ReliaSoft License Manager will allow you to perform the activation of your ReliaSoft-hosted license(s) using a product license key.

Your license information, along with the name and contact information that you provide during the activation process or upon first launching an application, can be viewed by clicking any of the main headings in the Application Setup or by going to the Contact Information tab of the License Manager (File > Help > License Manager).
The contact information used elsewhere in the software (such as in plots, report output, e-mail alerts, etc.) is stored in the database and managed via the **User Login and Contact Information window** ([My Portal > Users > My Profile](#)). If you need to change your contact information, you must apply the same change(s) to each database that you work with.

### Requirements for All Synthesis Installations
- Before running the installation program, make sure your computer meets the **system requirements** for Synthesis.
- You must be logged in with a user account that has **administrative rights**.
- It is strongly recommended that you **close all other applications** during the installation.

### Installing Using Locally Hosted Licensing
If you received a license file (*.lic) or license settings file (*.prnrsl), you will be using locally hosted licensing. This allows you to manage available license seats or CRS units in-house without the requirement to connect to ReliaSoft’s external license server.

**IMPORTANT:** The first step is for a license administrator to configure your organization’s license server and provide each individual user with a) the path to the license server/host (e.g., 6220@servername) and a license settings file (*.prnrsl) that specifies which ReliaSoft products on your computer will use locally hosted licensing. For detailed instructions, see [http://www.synthesisplatform.net/licensing_locally_hosted.htm](http://www.synthesisplatform.net/licensing_locally_hosted.htm).

Perform the following steps for each client installation. If you have previously connected the client computer to the appropriate license server, you can start at step 4.

1. Open the Synthesis ePack and decompress the *.zip archive in the Locally Hosted Licensing Utility folder
2. Install the HBM Prenscia Licensing Administration utility by double-clicking licinst.exe and following the prompts. The utility will start as soon as installation is complete.
3. On the Client tab of the Licensing Administration utility, click **Set Client License Path** and enter the path to the license server (e.g., 6220@servername).
4. Install the Synthesis desktop applications by double-clicking the installation program from the ePack (e.g., Synthesis11_1.exe) and following the prompts.
5. Open the Import/Export License Settings utility by choosing **ReliaSoft > Synthesis 11 > Additional Tools > Synthesis 11 License Settings Import-Export** in the Windows Start menu. Follow the on-screen instructions to import the license settings file.

The first time you launch an application, you may be asked to provide your name and basic contact information. This is required to be eligible for technical support.
Chapter 1: Getting Started

**Note:** Applications using locally hosted licensing must have an active connection to the license server unless you have borrowed a license. If you see a message that indicates that a license could not be obtained, this could be for a variety of reasons (e.g., you are not connected to the license server, the license server is down or there are no seats or CRS units available for the license). In addition, if you lose connection to the license server while you are using an application, you will see a message warning you to save your work before the application closes.

Installing and Activating Using ReliaSoft-Hosted Licensing

If you are requesting a demo or have already received a license key (a 32-digit alphanumeric code), you will be using ReliaSoft-hosted licensing. With this type of licensing, you must be able to connect with ReliaSoft’s secure external license server to register and activate or deactivate the application(s). This external server also controls access for multi-user (floating) licenses.

If your computer has an active Internet connection and your firewall allows the software to access the secure ReliaSoft License Server at https://Validate.ReliaSoft.org, only a few simple steps are required for activation:

1. Install the Synthesis desktop applications by double-clicking the installation program from the ePack (e.g., Synthesis11_1.exe) and following the prompts.

2. The first time you launch an application, the activation wizard will appear. On the first page, select whether you want to activate a license or request a free demo license.

3. On the next page, enter a valid e-mail address to serve as your **ReliaSoft ID**. This is the e-mail address where you will receive confirmation e-mails from the ReliaSoft License Server. This must be your company e-mail address — not gmail, hotmail, etc.
   - **Name and Contact Info:** If this is the first time that you have registered a Synthesis application on this computer with this e-mail address, the next page will request your name and basic contact information.
   - **Demo License:** If you need a demo license, most requests will be addressed immediately during normal business hours; for some locations, please allow up to 2 business days.

4. On the next page, enter the product license key provided by ReliaSoft. **Tip:** If you are able to copy the key from a product delivery e-mail, the Paste icon saves time by automatically entering each section into the appropriate input box.

http://xfmea.reliasoft.com
• **Confirmation Codes**: If your license type requires a confirmation code, the next page requires you to copy/paste a code that you will receive from ReliaSoft via e-mail. *Tip: If the e-mail does not appear in your Inbox within a few minutes, check your Junk mail or SPAM folders.*

• **Activate Multiple Applications**: If your license key includes other Synthesis applications that have not yet been activated on this computer, the next page gives you the opportunity to activate any or all of them at the same time.

5. When you see the “Your product has been activated” message, click **Finish** to start using the software.

If the computer does not have an active Internet connection, or if you encounter issues with the firewall, there are other ways to complete the activation. Please visit [http://www.synthesisplatform.net/licensing.htm](http://www.synthesisplatform.net/licensing.htm) for details. And, of course, you can always contact ReliaSoft for assistance ([http://www.reliasoft.com/contact.htm](http://www.reliasoft.com/contact.htm)).

**Uninstalling Synthesis**

If you wish to stop using all of the Synthesis desktop applications on this computer, you can perform the following steps to uninstall Synthesis:

*Tip: If you are using ReliaSoft-hosted licensing (i.e., if you received a license key and activated specific application(s) on your computer), you also have the option to deactivate one or more applications without performing a complete uninstall. For instructions, see [http://www.synthesisplatform.net/license_deactivation.htm](http://www.synthesisplatform.net/license_deactivation.htm).*

1. Make sure you do not have any Synthesis applications currently open.

2. For locally hosted licenses, if you are uninstalling permanently (i.e., if you are not doing this as part of an uninstall/reinstall), open the Import/Export License Settings utility by choosing **ReliaSoft > Synthesis 11 > Additional Tools > Synthesis 11 License Settings Import-Export** in the Windows Start menu. Follow the on-screen instructions to delete the license settings file.

3. Open the Windows Control Panel and click **Programs and Features** (or use the search box in the Windows Start menu to find and select **Add or Remove Programs**).

4. In the Uninstall or change a program window, double-click **ReliaSoft Synthesis 11** and follow the prompts.
Chapter 1: Getting Started

5. If you have installed the HBM Prenscia Licensing Administration tool, you can follow similar steps to uninstall it.

License Manager

The License Manager allows you to view and manage license-related details for the Synthesis desktop applications that are currently activated on your computer. You can use this interface to:

- View and, for ReliaSoft-hosted licenses, edit the **contact information** that is on file with ReliaSoft or change the **password** associated with your ReliaSoft ID. [Learn more…]
- For ReliaSoft-hosted licenses, **deactivate the current application** (if you don't plan to continue to use it on this computer or for this user). [Learn more…]
- For ReliaSoft-hosted floating licenses, **check out or check in a license**. [Learn more…]

To open the License Manager, click the **License Manager** link in the Help Center or choose Help > Updates & Licensing > License Manager.

You may be prompted to enter the password that was sent via e-mail when you first registered your ReliaSoft ID. This password is required if you want to modify your contact information. For everything else, you can click **Cancel** to proceed without it. (If you forgot your password, you can request to have the information sent to the e-mail address on file for your registration by clicking **E-mail my password to me**.)

Contact Information and Password

The **Contact Information** page displays the name, phone number and other details that are on file with ReliaSoft. For locally hosted licenses, this information is read-only and can only be edited by **uninstalling** and reinstalling the software. For ReliaSoft-hosted licenses:

- If you need to download the latest information from the license server, click **Synchronize**.
- If you want to change your password or any of the current contact information, type the new information into the fields on this page and then click **Update Information on Server**.

Both actions require authentication. If you have not already entered the current password that's associated with your ReliaSoft ID, you will be prompted again to enter it.
Deactivate the Current Application
For ReliaSoft-hosted licenses, if you don't plan to continue to use the current Synthesis application on a particular computer (or for a particular user), you can use the License Manager to deactivate it. This does not require authentication; you can proceed with the deactivation even if you have not entered your password.

Click the **Deactivate** button in the current product area on the **Products** page.

The application will shut down immediately after you deactivate, so you will be prompted to confirm that you're ready to continue. If you later try to access this application again for this computer/user, you will be prompted to repeat the activation process.

Borrowing Licenses
For certain license types, your computer must be able to connect to a license server to determine whether shared license seats (or, for token-based licenses, the required number of CRS units) are available when you attempt to launch a Synthesis application.

If you need to use the application(s) when your computer is not connected to the license server, you can either "**borrow**" or "**check out**" the licenses (depending on the **license type**). This reduces the number of seats (or CRS units) available to other users until the licenses are returned. (For ReliaSoft-hosted licenses, you can also use this feature to make sure a license seat will be available when you need it.)

Borrowing Locally Hosted Licenses
If you have a locally hosted license, you can use the ReliaSoft License Borrowing utility to borrow licenses for selected product(s) for a specified duration.

**IMPORTANT:** If at least one ReliaSoft product with a locally hosted license is borrowed, you will only be able to use the product(s) that are borrowed and only when the computer is not connected to the license server. All desired products must be borrowed or returned at the same time.

If any of the Synthesis applications on your computer use a ReliaSoft-hosted license (i.e., a license key
rather than a license settings file), they will be unaffected by locally hosted license borrowing. For those products, see [Checking Out ReliaSoft-Hosted Licenses](#) below.

### Borrow License(s)
Before attempting to borrow licenses, first make sure that your computer is connected to the license server and shut down all Synthesis desktop applications.

1. To open the ReliaSoft License Borrowing utility, navigate to the [ReliaSoft > Synthesis 11 > Additional Tools](#) folder in the Windows Start menu and click [ReliaSoft License Borrowing 11](#).

2. The window shows all of the Synthesis desktop applications on your computer that use locally hosted licensing. Specify the borrow duration and select which product(s) you want to borrow. (Remember that all desired products must be borrowed or returned at the same time.)

3. Click **Borrow Selected Licenses**.

4. Close the window.

You will only be able to use the product(s) that are borrowed, and only when the computer is not connected to the license server. If you need to change which products are borrowed, you can reconnect to the license server and repeat the same steps again (this will restart the borrow duration for all selected products). If you need to be able to use the applications while connected to the server, you can return the licenses as described below.

### Return License(s)
Before attempting to return licenses, shut down all Synthesis desktop applications and reconnect your computer to the license server.

1. Open the ReliaSoft License Borrowing utility.

2. Click **Return All Licenses**.

3. Close the window.

*Note:* You can borrow licenses only while your license is valid (e.g., if the annual expiration date of your locally hosted license is 2 days from now, you cannot borrow a license for a duration of 3 days). In addition, you cannot borrow licenses during the 24 hours prior to annual license expiration.

### Checking Out ReliaSoft-Hosted Licenses
If you have a ReliaSoft-hosted floating license, you can use ReliaSoft's [License Manager](#) to reserve a license.
1. Open the Synthesis application.

2. Open the License Manager by clicking the License Manager link in the Help Center or choosing Help > Updates & Licensing > License Manager.

3. In the current product area on the Products page, click Check Out or Check In.
Chapter 2: Repositories and Projects

With integration into the Synthesis Platform, ReliaSoft’s desktop applications have transitioned from a standalone document/file format to a multi-user, database-driven approach. This offers enormous potential to integrate reliability program activities and tools, while simultaneously facilitating effective information sharing and cooperation between engineering teams of any size.

The experience of working in a database-driven, multi-user environment will be a bit different than using prior versions of ReliaSoft’s applications (Version 7 or older) and other document-centered applications such as Microsoft Excel. For example, your organization (or team) will need to choose the most appropriate database type and security, implement shared settings that will effectively facilitate project management, and establish adequate backups and database maintenance to protect against data loss. In addition, individual users must be aware that changes are saved automatically as they work (except with the Synthesis file type *.rsr11), and become familiar with the features that facilitate simultaneous access by multiple users.

This chapter discusses some of the basic requirements for using Synthesis repositories and projects. For information about other features, see Synthesis Platform Tools.

Synthesis Repositories

Database Types

Synthesis desktop applications offer three types of databases for storing projects and analysis data. The type of database you choose will depend on the requirements of your organization.

- **Standard repositories** (*.rsr11) are basic database files for single- or multi-user environments. Implementation of a database server is not required; however, there are limits on the amount of data and the number of simultaneous users.

- **Synthesis files** (*.rsf11) are similar to standard repositories except that they can only be used by one person at a time, and changes are not saved until you choose File > Save or Save As. This type of database is therefore best for individual users who are working alone in a single Synthesis desktop application and prefer to be able to close a file without saving changes.

- **Enterprise repositories** require implementation and support of Oracle or Microsoft SQL Server, but they are a more robust platform that can store much more analysis information in the same database and support access by many more simultaneous users.
Chapter 2: Repositories and Projects

Synthesis applications are compatible with Microsoft SQL Server 2008 or later and Oracle 10g or later (including the free Express editions of all of these). They can be accessed via an enterprise repository connection file with the extension *.rserp.

Standard Repositories
A standard repository is a basic database file for single- or multi-user environments. Implementation of a database server is not required; however, there are limits on the amount of data and the number of simultaneous users. (If you prefer to use a more robust Oracle or SQL Server database, see Enterprise Repositories. If you plan to work alone and don’t want changes to be saved automatically, see Synthesis Files.)

Creating a New Standard Repository
To create a new standard database, choose File > New > Standard Repository.

In the Repository name field, specify the filename for the new *.rsr11 file. The path where the file will be saved is shown below this field; to change the location, click the browse icon in the field.

The following options are available when you create a new standard database:

- Select the Apply login security check box if you want the new database to be login secure. You can then select the Open security window upon creation check box if you want to add user accounts as part of the database creation process. Note that you cannot automatically remove security from a database once it has been enabled. However, you can create a new non-secure database and use the Import from existing repository check box to automatically import all of the data from the secure database to the non-secure one.

- Select the Import from existing repository check box if you want to import entire projects and other data from an existing database, after the new database is created.

Opening an Existing Standard Repository
If you have opened the file recently, choose File > Recent and then select the file in the Recent Repositories list.

Otherwise, choose File > Open Repository and then browse for the *.rsr11 file.
If the repository has login security enabled and you are unable to connect, you may be encountering one of the following issues:

- **No access to the repository.** If you have not been given access to the repository, you will see a message stating that your account in the repository is not active or not assigned to at least one security group. You will need assistance from someone who can create and update user accounts (see Managing User Accounts).

- **Windows authentication failed.** If your Windows login (domain and username) is different from what was specified for your user account, you will see a message to connect using alternative credentials. You will need assistance from someone who can enable the use of alternative credentials for your user account.

### Synthesis Files

Synthesis files (*.rsf11) are similar to standard repositories except that they can only be used by one person at a time, and changes are not saved until you choose **File > Save** or **Save As**. This type of database is therefore best for individual users who are working alone in a single Synthesis desktop application and prefer to be able to close a file without saving changes. If your workflow demands simultaneous access by multiple users, we recommend that you use either a standard database or enterprise database.

Note that if you have the same Synthesis file open simultaneously in two different Synthesis applications on the same computer (this situation is not common), saving changes in any of the open applications will save all changes up to that point.

### Creating a New Synthesis File

To create a new Synthesis file, choose **File > New > Synthesis File**.

In the **Repository** name field, specify the filename for the new *.rsf11 file. The path where the file will be saved is shown below this field; to change the location, click the browse icon in the field.

The following options are available when you create a new Synthesis file:

- Select the **Apply login security** check box if you want the new database to be login secure. Note that:
  - If you do not apply login security, any database user will be able to access and edit your Synthesis file, so long as the file is saved in a location that the user has read/write access to (e.g., a shared network folder).
Chapter 2: Repositories and Projects

- If you apply login security, only you will have access to the file; however, you can grant other database users the permissions to view/edit your file, if desired. Select the **Open security window upon creation** check box if you want to add user accounts to the file as part of the database creation process. (For complete instructions on implementing security settings, see [Security Options](http://xfmea.reliasoft.com).)

  Note that you cannot automatically remove security from a Synthesis file once it has been enabled. However, you can create a new Synthesis file and use the **Import from existing repository** check box to automatically import all of the data from the secure file to the non-secure one.

- Select the **Import from existing repository** check box if you want to import entire projects and other data from an existing database, after the new file is created.

### Opening an Existing Synthesis File

If you have opened the file recently, choose **File > Recent** and then select the file in the Recent Repositories list.

Otherwise, choose **File > Open Repository** and then browse for the *.rsf11* file.

If you are unable to open a Synthesis file, you may be encountering one of the following issues:

- **File is in use.** Synthesis files can only be used by one person at a time; therefore, it is automatically locked to the first user who has it open. You will not be able to open nor view the contents of the file until the other user closes the file.

- If the Synthesis file has **login security** enabled, you may also encounter the following issues:
  
  - **No access to the repository.** If you have not been given access to the repository, you will see a message stating that your account in the repository is not active or not assigned to at least one security group. You will need assistance from someone who can create and update user accounts (see [Managing User Accounts](http://xfmea.reliasoft.com)).
  
  - **Windows authentication failed.** If your Windows login (domain and username) is different from what was specified for your user account, you will see a message to connect using **alternative credentials**. You will need assistance from someone who can enable the use of alternative credentials for your user account.

### Enterprise Repositories

Unlike **standard repositories** or **Synthesis files**, enterprise repositories require an established database server with Oracle or Microsoft SQL Server. This allows you to store more analysis information in the same repository and support access by many more simultaneous users.
Synthesis applications are compatible with Microsoft SQL Server 2008 or later and Oracle 10g or later (including the free Express editions of all of these).

To establish a database server, you will need to purchase an appropriate license package from Oracle or Microsoft. The license, as well the IT maintenance and support needed to establish the database server, is separate from the ReliaSoft license agreement and must be negotiated directly with Oracle or Microsoft.

As an alternative, you may choose to use the free versions of Oracle or SQL Server if the expected load for the database fits within the limited capabilities of the Express edition (as specified by Oracle/Microsoft). With the free editions, you can establish a functioning enterprise database on your own without making a large investment of time and resources. If your organization's needs grow beyond the capabilities of the Express edition, you can then upgrade to a more robust version with the appropriate IT infrastructure and support.

**Tip:** Although ReliaSoft cannot provide full documentation and support for third-party database platforms, we do provide a limited number of resources as a convenience for users who wish to explore the possibilities of an enterprise database implementation. For resources on SQL Server (including instructions for configuring the Express edition), see [http://synthesis.reliasoft.com/sql_server.htm](http://synthesis.reliasoft.com/sql_server.htm). For resources on Oracle, see [http://synthesis.reliasoft.com/oracle.htm](http://synthesis.reliasoft.com/oracle.htm).

The following topics will be of interest to database administrators:

- Creating a New Enterprise Repository
- SQL Server Logins or Impersonation
- Upgrading an Enterprise Repository (from Version 8, 9 or 10)
- Synthesis Admin Tool

The following topics will be of interest to all enterprise repository users:

- Creating an Enterprise Repository Connection File (*.rserp)
- Monitoring Connection Speed

**Creating a New Enterprise Repository**
If your organization already has established a database server with Oracle or Microsoft SQL Server and you have the permissions necessary to create databases on the server, you can create a new Synthesis enterprise repository by choosing **File > Manage Repository > New Enterprise Repository.**
You can choose to create the new database in either Oracle or Microsoft SQL Server.

If you choose SQL Server, you will be required to enter:

- **Server Name**: The name of the Microsoft SQL Server implementation where the new database will be created. Note that if you are using SQL Server Express, the server name is usually your login for that computer followed by \SQLEXPRESS (e.g., Username\SQLEXPRESS).

- **Database Name**: The name of the new database that will be created.

If you choose Oracle, you will be required to enter:

- **Port**, **Host** and **Service** identifiers for the Oracle server where the new database will be created.

- The **Schema** of the new Enterprise database.

- The **Password** for the new enterprise database schema.

- The administrative username and password for the Oracle server (entered in the **Admin Information** area).

For either server type, select the **Import from existing repository** check box if you want to import entire projects and other data from an existing database.

Click **OK** to create the database. The database will not open automatically; you must connect to it. (See **Connecting to an Existing Enterprise Repository**.)

**Connecting to an Existing Enterprise Repository**

If your organization has already created an enterprise database on Oracle or Microsoft SQL Server and you have an active user account, you can use an enterprise repository connection file (*.rserp) to connect with it. You can create this file yourself or use a file that has been created by someone else. Once this file is created, it can be used to connect to the database and to import from or export to the database.

**Creating a Connection File**

To create a connection file, choose **File > New > Enterprise Repository Connection File.**
This command creates a Synthesis repository connection file (*.rserp) that is stored locally on your computer; the file contains all of the necessary information for connecting to the enterprise database.

Enter a name for the connection file, then choose the database type and version (i.e., Microsoft SQL Server 2008 or later, or Oracle 10 or later).

- For SQL Server databases, enter the server name and database name. Select the Use impersonation check box if you want the new connection file to impersonate a Windows user account with a SQL Server login that can be shared by multiple users. This connection file can then be distributed to any user who does not have his/her own individual SQL Server login and is not part of a Microsoft Active Directory® group that has a login. (See SQL Server Logins or Using Windows Impersonation.)

- For Oracle databases, enter the port, host and service identifiers and the database schema. Your Windows login credentials are used for access to the database; enter your Windows password.

**Using an *.rserp File to Connect to an Enterprise Repository**

If you have used the connection file recently, choose File > Recent and then select the file in the Recent Repositories list.

Otherwise, choose File > Open Repository and then browse for the *.rserp file.

If you are unable to connect to an enterprise repository, you may be encountering any of the following issues:

- **No access to the repository.** If you have not been given access to the repository, you will see a message stating that your account in the repository is not active or not assigned to at least one security group. You will need assistance from someone who can create and update user accounts (see Managing User Accounts).

- **Windows authentication failed.** If your Windows login (domain and username) is different from what was specified for your user account, you will see a message to connect using alternative credentials. You will need assistance from someone who can enable the use of alternative credentials for your user account.

- **Cannot connect to the server or login failed.** Server-related issues may occur for several reasons, and you may see various messages pertaining to the situation. Common issues are:
  - You do not have a network connection or you may have entered the incorrect database name (i.e., Synthesis repository name) or server name in the connection file.
The server may not be configured to allow remote connections, has certain firewall settings or is experiencing other issues. In this case, you will need to contact the IT support group responsible for the server.

In SQL Server databases, a login issue may occur if your username is not associated with a SQL Server Login. (See SQL Server Logins or Using Windows Impersonation.)

**Note:** If you get an "error occurred when reading the connection file" message, the connection file may be corrupted or is using old encryption. You can create a new connection file by choosing File > New > Enterprise Repository Connection File.

### SQL Server Logins or Using Windows Impersonation

Connecting with a SQL Server database via Windows authentication requires a "SQL Server login" that allows the database platform to recognize the user and gives access to the Synthesis repository. There are three ways that a Synthesis user account may be recognized by SQL Server:

- **Individual Login:** The user has an individual SQL Server login that is associated directly with his/her Windows username.

- **Group Login:** The user belongs to an Active Directory group that has a SQL Server login shared by all members of the group.

- **Use Impersonation for Connection File:** The user does not have an individual or group login but he/she connects to the database with an enterprise connection file (*.rserp) that impersonates another Windows user account that does have a SQL Server login.

Your organization may choose to use any or all of these methods for your Synthesis implementation (e.g., some users may have their own individual logins, while other users connect using Windows identity impersonation). This document provides an overview of all three options.

### Option 1: Creating Individual SQL Server Logins

If you choose to create individual SQL Server logins for some or all of the Synthesis user accounts, you have two options. (For details and instructions on performing these tasks in SQL Server, see [http://www.reliasoft.com/synthesis/sql_server.htm](http://www.reliasoft.com/synthesis/sql_server.htm).)

1. A database administrator for SQL Server can create SQL Server logins in advance for every potential user and give the logins access to the application database (at least the db_datareader and db_datawriter roles are required). This would be performed directly in SQL Server (not via one of the Synthesis applications).
2. A database administrator for SQL Server can grant the appropriate level of database authority for creating SQL Server logins and database roles (e.g., securityadmin or sysadmin) to any user who has the ability to create user accounts in the Synthesis repository. The additional authority would be added directly in SQL Server. Then, when any of these administrative users creates a new user account via the Synthesis application, the required SQL Server login can be created and the application database roles can be assigned automatically at the same time.

If you are using the first approach, clear the **Create SQL Server login** check box that is displayed when you are adding or importing a user account. If you are using the second approach, you must select this check box.
Chapter 2: Repositories and Projects

Tip: If the user already has a SQL Server login and access to the application database, it does not matter whether you select or clear the **Create SQL Server login** check box because the application attempts to create the login only if one does not already exist.

Furthermore, if the user who is creating the user account does not have the necessary level of database authority in SQL Server, the login will not be created even if the check box is selected.

**Option 2: Using a Group Login**

If the user belongs to an Active Directory group that has a SQL Server login shared by all members of the group and that group has access to the application database, you can clear the **Create SQL Server login** check box that is displayed when you are adding or importing a user account.

For example, base installations of Microsoft SQL Server Express 2008 include the "Builtin\Users" Active Directory group as a SQL Server login by default. This means all users with a Windows account for that domain will be able to log in to the enterprise database with no need to create individual SQL Server logins in SQL Server Express. However, it will still be necessary to grant access for this group login to the application database (at least the db_datareader and db_datawriter roles are required).

**Option 3: Using Windows Impersonation for the Connection File**

If you choose to have some (or all) users connect to the SQL Server database with a connection file that impersonates a shared Windows user account that has a SQL Server login, you must do the following:

- A Windows network administrator must establish the shared user account on Windows.
- A database administrator for SQL Server must create a SQL Server login for the shared Windows user account and grant this login access to the application database (at least the db_datareader and db_datawriter roles are required).
- A Synthesis user must create an enterprise repository connection file that impersonates the shared Windows user account:
  1. Choose **File > New** then click **Enterprise Repository Connection File**.
  2. Under **Repository Connection Settings**, select **Microsoft SQL Server (2008 or later)** from the drop-down list and then select the **Use impersonation** check box.
  3. Enter the server and database name for the SQL Server database, then enter the domain, username and password for the shared Windows account that users will need to impersonate.
  4. Click **OK** to create the connection file (*.rserp). It will be stored in the location specified under **Connection File Name**. Note that the default filename will be...
“SQL_(Server Name)_(Database Name),” but you can assign any name that fits the process your organization will use for distributing the file to users. (Note that while the window shown next is for Weibull++, the settings are the same for all Synthesis applications.)

Once you have created a connection file that impersonates the shared Windows user account, you can distribute the file to any Synthesis user who needs it. To connect to the repository using this file, the user can:

1. Choose **File > Open Repository** and browse for the connection file.
2. Click **Open** to connect with the repository.
After the first connection, this *.rserp file will be saved in the list of recent repositories, which can be accessed by choosing **File > Recent**.

**Note:** For the purpose of being recognized by SQL Server and accessing the application database, the user will be impersonating the shared Windows login. For the purpose of performing actions via the Synthesis applications, the user's actions will be governed by his/her own user account in Synthesis. In other words, multiple users can connect with the database using the same enterprise connection file, but their activities within the Synthesis applications will be governed by the permissions established in their own individual Synthesis user accounts, and any changes made to the analysis data will be recorded in Synthesis under their own usernames.

### Enterprise Repository Connection Speed

If the Synthesis desktop application is exhibiting slow performance when you’re connected to an enterprise repository, the issue may be related to your network connection. The MDI status bar displays a connection speed indicator on the lower right side of the window.

The following icons are used to indicate the connection speed. In cases of poor network performance, you will need to request assistance from the IT support group responsible for the server.

- ⚪️ < 30 ms: Good (acceptable performance)
- 🟢 30 - 70 ms: OK (may exhibit some delays in operations, opening/closing windows, etc.)
- 🟡 70 - 110 ms: Slow (will exhibit some delays in operations, opening/closing windows, etc.)
- 🟡 110 - 150 ms: Very slow (will exhibit significant delays in operations, opening/closing windows, etc.)
- 🟢clipse < 150 ms: Extremely slow (will result in unacceptable performance and usability)

### Upgrading an Enterprise Repository from a Previous Version

If you have an existing enterprise database that was created with any of the Version 8, Version 9 or Version 10 Synthesis applications, you can transfer or convert all of the existing data into a new database that is compatible with the latest version.

All of the same requirements for [creating a new enterprise database](#) apply here (e.g., you must have an established database server and the necessary permissions to create a database on the
server). In addition, you must be a member of the Admin group in the database to perform the task.

**Tip**: If you need to be able to upgrade an enterprise database without using a Synthesis desktop application (i.e., without taking up one of the available license seats), you can access this same feature from the Synthesis Admin tool.

### Upgrading from Version 9 or 10

It is strongly recommended that you create a backup of the Version 9/10 enterprise repository. The upgrade process converts the database itself to the latest version. **This change cannot be undone.**

To upgrade the database, choose File > Manage Repository > Upgrade Version 9/10 Repository.

In the window, specify the Version 9/10 enterprise database that you wish to upgrade. Click OK to start the process.

### Upgrading from Version 8

You do not need to create a backup before upgrading a Version 8 enterprise repository. The upgrade process does not involve a direct conversion of data, but rather copies over all existing data into a new database. This complete switch to a new database is required in order to support the exclusive features in the latest version.

To upgrade the database, open any Version 11 Synthesis application and choose File > Manage Repository > Upgrade Version 8 Repository.

Use the left side of the window to specify the Version 8 enterprise database that you wish to upgrade. Use the right side of the window to define the new Version 11 enterprise database that the existing data will be copied into. Click OK to start the upgrade.

### Synthesis Admin Tool

The Synthesis Platform includes an admin tool that allows a database administrator to set up and manage enterprise databases without requiring a software user license or an activated Synthesis desktop application.
Chapter 2: Repositories and Projects

To use the Synthesis Admin tool, your organization must have already established a database server with Oracle or Microsoft SQL Server, and you must have the permissions necessary to create databases on the server.

To access the tool, open the Windows Start menu and choose ReliaSoft > Synthesis 11 > Additional Tools > Synthesis 11 Admin from the programs list. Alternatively, you can open the Windows Start menu and type Synthesis 11 Admin in the search bar.

The following features from the Synthesis desktop applications are available in the admin tool.

- Creating a new enterprise repository
- Upgrading a Version 10, Version 9 or Version 8 enterprise repository
- Manage Synthesis user accounts:
  - Adding and editing user accounts
  - Importing users from Active Directory
  - Creating alternative credentials
  - Editing user login and contact info
  - Managing security groups
- Configuring the XFRACAS or Synthesis Enterprise Portal (SEP) applications on a web server. For details, please consult the implementation guides for those web applications.

Projects

In Synthesis repositories, projects serve as a way to keep related analyses together. Each project can contain analyses (e.g., folios, diagrams, plots, FMEAs, etc.), a Project Planner, resources that can be shared between analyses (e.g., models, tasks, actions, etc.) and attachments.

Any project can be opened in any Synthesis application; however, application-specific analyses (e.g., folios in Weibull++, diagrams in BlockSim, etc.) are visible only in the application(s) that can edit them.
Creating and Managing Projects

This topic describes how to create and manage the projects that are accessible to you via the project list (View > Project Manager > Show Project Manager). This depends on your permissions in the database and any security that has been defined at the project level.

There are three types of projects: private, public or reference. In addition, a project may be locked or checked out at any given time. Each type of project is displayed under the appropriate heading in the project list:

Tip: The Manage Projects window (Project > Management > Manage Projects) allows you to perform administrative tasks for multiple projects all at once, and to manage the private projects of other users. (See Manage Projects Window.)

Creating a New Project

When you create a new project, you must specify whether it will be public, private or reference. Select or right-click the appropriate heading in the project list and (i.e., Private, Public or Reference), and then choose Project > Management > Create Project.

The selected project type will be displayed at the bottom of the Project Properties window. If desired, you can change the selection before clicking OK to create the project.
Tip: If you later need to change the project type, select the project and choose Project > Security > [Make Private, Make Public, or Make Reference]. The same commands are also available in the Manage Projects window.

### Duplicating Projects

To duplicate an existing project, select it and choose Project > Management > Duplicate Project.

This command will create an exact duplicate of the original project with a name that contains an increment number (e.g., Project_1, Project_2, etc.). Note that duplicate projects do not retain the security settings of the original project.

### Deleting Projects

To delete a project, select it and press DELETE or choose Project > Management > Delete Project.

To make sure that your analysis information is not deleted by mistake, you will always be prompted to confirm before proceeding. By default, the project will be moved to the recycle bin, which will give you a chance to recover it later if needed. If you want to permanently delete the project now (no way to undo unless you have a backup or restore point), clear the Send project to recycle bin check box in the confirmation window.

**Note:** You cannot delete a reference project if any of its resources are in use, including by projects in the recycle bin.

### Project Properties

The Project Properties window will be displayed when you create a new project or when you choose Project > Management > Edit Project Properties.
Chapter 2: Repositories and Projects

The options available in this window will vary depending on which application you are using and whether the database has login security enabled. For MPC, see MPC's Project Properties (below). For all other Synthesis desktop applications, this may include:

- **General Tab**
- **Security Tab** (available only for public/reference projects in secure databases)
- **Configurable Settings Tab** (only in Xfmea/RCM++/RBI)

In addition, the status bar at the bottom of the window always displays the following information:

**Project Owner:** The user who has been identified as the project owner. In a secure database, the ability to edit the project properties is restricted to the project owner and to users with the relevant "manage all projects" permissions.

**Last Update:** The time and date the project was last changed/updated, and the user who made the change. This considers any change to any of the analysis data in the project (not just the project properties).

**General Tab**

The General tab contains the following options:

- **Name** is the identifier for the project that will appear in the current project explorer and in many other windows and reports throughout the software. This field is required and cannot contain any of the following characters: \/:*?<>|

- **Description** and **Remarks** can contain more detailed notes or information about the project.

- **Proprietary Label** can contain a copyright or distribution statement, if desired. This label may appear in the footer of some reports generated in Xfmea/RCM++/RBI or MPC.

- **Project Category** allows you to assign a project category that can be used to filter the projects displayed in the project list and in many other windows throughout the software.

In Xfmea/RCM++/RBI, this tab also contains:

- **FMEA Structure** determines how the software will display the effect and cause records in the FMEA hierarchy. This is applicable only in Xfmea/RCM++/RBI. (See Choosing the FMEA Structure in the Xfmea/RCM++/RBI documentation.)

- **Select Profile from Library** displays a list of all profiles that have been defined in the active library. When you choose a profile from the list, all of the configurable settings for the project will be set/reset based on the settings that have been predefined for that
profile. If you are editing a project, the current profile is shown in brackets. (In a secure database, the ability to add and edit a profile is available only for users with the "Manage profiles and templates in Xfmea/RCM++/RBI" permission.)

Security Tab
The Security tab is available only when you are working with a public or reference project in a secure database. For a full discussion on how to use these settings, see Planning Your Security Approach.

For quick access to the Security tab, you can select the project in the project list and choose Project > Security > Project Security.

Configurable Settings Tab
The Configurable Settings tab is available for Xfmea/RCM++/RBI only. It provides access to all of the configurable settings that have been defined for the current project, based on the profile that was selected on the General tab.

This tab allows you to make specific changes that will apply to the current project only. For example, if you are using a predefined profile but want to make a change to the interface style for this particular project only, you could click the Edit icon associated with the Interface Style drop-down list in the Interface Settings area.

It is important to note that any change to the Configurable Settings page will update the settings for the current project, but it will not alter the original profile. If you want the project’s current settings to be available as a new profile in the active library, click the Send Settings to Library button and then type the name and description for the new profile that will be created.

In the Enable Legacy Analyses section, you can choose whether to allow users to create and use DVP&R or DRBFM analyses in the project. These settings are not part of the profile and may be different for each project. (See Design Verification Plans (DVP&Rs) and Design Reviews Based on Failure Mode (DRBFMs) in the Xfmea/RCM++/RBI documentation.)
MPC’s Project Properties
For users of MPC, the interface has been customized to display only the information that is directly relevant for MSG-3 analyses. This includes the Name, Description, Remarks and Project Category. In addition, you will be able to define the following:

- **Short Description** appears in the header of the Standard report template. It is not applicable for Dassault or Sukhoi reports.

- **Proprietary Label** appears in the footer of the Standard report template. It is not applicable for Dassault or Sukhoi reports.

- **MSG-3 Guidelines** displays a list of the available MSG-3 guidelines that can be used for the systems and powerplant analysis.
  - In most cases, the version that you select will not have any impact on the MSG-3 logic displayed in the interface and print-ready reports.
  - The only substantive difference occurs when you select MSG-3 Revision 2002.1 because this older version of the guideline uses slightly different titles for two of the maintenance significant item (MSI) questions, and lists the questions in a different order.

- **Model/Equipment/Effectivity** allows you to enter the information that will appear on the title page of the Dassault and Sukhoi templates.

Project Owner
For each project in a Synthesis repository, one user will be assigned as the *project owner*. By default, the owner will be the user who created the project, but this can be changed when needed.

In a **secure database**, being the project owner means that you have full permissions over the project. This includes the ability to edit the project properties, add/edit/delete project items and resources, lock and unlock, set security settings, create restore points and delete the project. These permissions are always in effect regardless of the **project security settings** or **item permissions** that may be in place.

**Changing the Project Owner**
To change the owner, select the project in the project list and choose **Project > Security > Change Owner**.
In a secure database, this is available only for users with the applicable "manage all projects" permissions.

Identifying the Project Owner
There are three ways to identify the current owner of a project:

- Use the filters in the project list to filter and/or group projects based on the project owner. For example:

```
<table>
<thead>
<tr>
<th>Private</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bill Engineer</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Public</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project D</td>
</tr>
<tr>
<td>Jane Engineer</td>
</tr>
<tr>
<td>Project C</td>
</tr>
<tr>
<td>Joe Analyst</td>
</tr>
<tr>
<td>Project A</td>
</tr>
<tr>
<td>Project B</td>
</tr>
</tbody>
</table>
```

- The Project Properties window (Project > Management > Edit Project Properties) displays the name of the current owner in the status bar at the bottom of the window.

```
Project Owner: Bill Engineer
Last Updated: 10/8/2014 3:41 PM   User: Bill Engineer
```

- The Manage Projects window (Project > Management > Manage Projects) displays a list of all projects and their owners in a table format. You can use custom filters to filter, sort and/or group the list based on the project owner.

<table>
<thead>
<tr>
<th>Name</th>
<th>Owner</th>
<th>Security</th>
<th>Last Updated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Private</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Project E</td>
<td>Bill Engineer</td>
<td>Private</td>
<td>10/9/2014 9:04 AM</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Public</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project A</td>
</tr>
<tr>
<td>Project D</td>
</tr>
<tr>
<td>Project C</td>
</tr>
<tr>
<td>Project B</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project F</td>
</tr>
</tbody>
</table>
Public, Private and Reference Projects

In Synthesis repositories, there are three types of projects you can create:

- **A public** project may be accessible to any user who has access to the database, depending on the **security settings** that have been implemented.

- **A private** project can be viewed and edited only by the **project owner**. The **project list** shows only your own private projects, while the **Manage Projects window** provides the ability to manage all users’ private projects (including delete, lock/unlock or changing the project type).

- **A reference** project is like any regular public project, except that you can share its **resources** and FMEAs with other projects in the database. This gives you a pool of resources that can be used throughout the database by specified users (based on the security settings for the reference project), while allowing you to maintain fully functional analyses within the reference project itself. (For more information, see *Local, Global and Reference Resources*, and *Linked FMEAs* in the Xfmea/RCM++/RBI documentation.)

In the project list, each type of project is displayed under the appropriate heading, as shown in the following example.

![Project List](image)

**Note:** In MPC, the Reference heading will appear only if reference projects already exist in the database (created by another Synthesis desktop application). You cannot create a new reference project or convert an existing project into a reference project in MPC.
Chapter 2: Repositories and Projects

**Setting the Initial Project Type**
When you create a new project, you must specify whether it will be public, private or reference. Select or right-click the appropriate heading in the project list and (i.e., Private, Public or Reference), and then choose **Project > Management > Create Project**.

The selected project type will be displayed at the bottom of the **Project Properties window**. If desired, you can change the selection before clicking **OK** to create the project.

**Changing the Project Type**
To change the project type for one project, select it in the project list and choose **Project > Security** and then one of the following options:

- Make Private
- Make Public
- Make Reference

To change the project type for multiple projects simultaneously, use the **Manage Projects window** instead.

**Locked and Unlocked Projects**
In all Synthesis repositories, a project can be *locked* to prevent users from editing the data. If a project is locked, it will be moved to the *Locked* heading in the **project list** and it cannot be edited by any database user unless it is unlocked again.

In a secure database, locking and unlocking a project are available only if the user a) is the **project owner**, b) has the "Lock or check out project" permission for the project or c) has the applicable "manage all projects" permissions.

**Locking a Project**
To lock a project, select it in the project list and choose **Project > Security > Lock Project**.
When a project is locked, all database users (including the user who locked the project) will have read-only access to the project. In addition, a locked project cannot be deleted or have its properties and public/private/reference status edited.

**Unlocking a Project**

To unlock a project, select it in the project list and choose *Project > Security > Unlock Project*.

*Tip:* The *Manage Projects window* allows you to select multiple projects and lock or unlock them all at once.

---

**Check In and Check Out Projects**

In all Synthesis repositories, both private and public projects can be checked out to temporarily allow one particular user to work on a project independently for a period of time and/or to work on a computer that is not connected to the network where the shared database resides (e.g., if you need to work on the project while you’re out of the office). When a project is checked out, two things happen:

- An editable copy of the project will be saved into a *standard database* (*.rsr11) in the specified "Checked Out" folder on your local computer. This database will have the same name as the project.

- The original project will be set to read-only and moved under the *Checked Out* heading in the *project list*. This allows other users who would normally be able to access the project to see that it is currently being edited exclusively by one particular user. It also provides read-only access to the latest version of the project at the time it was checked out so those users can query, copy data, etc. while you’re editing the project "offline."

You can then edit the project as needed in the standard database and check the project back in when you’re finished.

*IMPORTANT:* If the project uses resources or FMEAs from a *reference project* (e.g., linked FMEAs, models, URDs) the links won’t be maintained when you check out the project. Any linked resources/FMEAs will be replaced with local copies of the resources/FMEAs and stored directly within the project. See also *Local, Global and Reference Resources*.

---

**Specifying the "Checked Out" Folder**

By default, projects will be checked out to the default Documents folder on your computer (e.g., My Documents\ReliaSoft\Files\Checked Out).
Chapter 2: Repositories and Projects

To change this location, open the Backup/Check Out Options page of the Application Setup window and browse for a new default path under Check In/Out. Keep in mind that anyone who has access to the folder will have full access to the checked out project; however, only the user who has the project checked out will have the ability to check in the project.

Tip: If you need to work on the project from a different computer after it has been checked out to the local folder, you will simply need to make sure that the latest copy of the standard database file is saved back to the exact same check-out location and filename before you check the project back in.

Checking Out a Project
To check out a project, select it in the project list then choose Project > Management > Check In/Out > Check Out.

In a secure database, this is available only if the user a) is the project owner, b) has the "Lock or check out project" permission for the project or c) has the applicable "manage all projects" permissions.

Checking in a Project
To check in a project, select it under the Checked Out heading in the project list and choose Project > Management > Check In/Out > Check In.

Note that when you check in a project, the software creates a restore point, which is an exact replica (i.e., a backup) of the project before it was checked out. This allows you to restore the project to its prior state when and if needed. The restore point will include a description of the user who checked out the project, as well as the date and time of the check out. (See Restore Points.)

Undo Check Out
To discard changes and restore the project to the state it was in before it was checked out, select the project under the Checked Out heading in the project list and choose Project > Management > Check In/Out > Undo Check Out.

In a secure database, this is available only if the user a) is the user who checked out the project, b) is the project owner or c) has the applicable “manage all projects” permissions.
Manage Projects Window
The Manage Project window displays a list of all the projects that currently exist for the database and allows you to perform administrative tasks for multiple projects all at once. If you have created custom project filters, you can apply those same filters in this window.

To open the Manage Projects window, choose Project > Management > Manage Projects.

In a secure database, this is available only to users with the applicable "manage all projects" permissions. Only the type of project that you have permissions for will be displayed. Projects that are under the Locked, Checked Out and Recycle Bin headings will be visible only if you have permissions for all three project types.

Tasks You Can Perform
Some of the tasks you can perform in this window include:

- See a list of private projects created by other users (and perform any administrative tasks that may be needed for those projects).
- Change multiple public projects to private all at once, and vice versa.
- Change the owner for multiple projects all at once.
- Apply the same changes to the project properties for multiple projects all at once.
- Review and edit the security settings (if applicable) for multiple projects all at once.
- Delete, restore, lock and unlock, or undo check out for multiple projects all at once.
- Review and sort projects based on the user who made the last change to a project, the date/time of the last change and the last application that was used to make the change.

**Tip:** The Manage Projects window allows you to edit the properties of a project that is currently open or in use. When you make a change, the user who has the project open will see the change you have made when the database refreshes (the refresh happens automatically whenever the user makes a change, such as closing a window, selecting a different item, etc.).

Tools
The Manage Project window contains the following commands:

**Project**
- **Close** closes the Manage Projects window.
Chapter 2: Repositories and Projects

Edit Project Properties allows you to view and edit the properties of the selected project(s).

Delete Project permanently deletes the selected project(s) and bypasses the recycle bin. There is no undo for delete unless you have a stored backup or restore point.

Restore Project is available only when you have selected project(s) under the Recycle Bin heading. Each selected project will be recovered from the recycle bin and restored to its original location in the project list.

Security

Lock Project moves the selected project(s) into the Locked heading of the project list. When a project is locked, all database users (including the user who locked the project) will have read-only access to the project. In addition, a locked project cannot be deleted or have its properties and public/private/reference status edited. To unlock project(s), choose Unlock Project. (See Locked and Unlocked Projects.)

Make Private moves the selected project(s) into the Private heading of the project list. To move private project(s) to the Public heading, choose Make Public. (See Public, Private and Reference Projects.)

Change Owner assigns a different database user to be the owner for the selected project(s). (See Project Owner.)

Project Security is available only for public and reference projects in secure databases. It opens the Project Properties window with the Security tab active, where you can specify the user accounts that can view/modify the selected project. (See Planning Your Security Approach.)

Check Out

Undo Check Out discards all changes made to a checked out project and restores it to the state it was in at the time it was checked out. (See Check In and Check Out Projects.)

Excel

Send to Excel exports the data currently displayed in the Manage Projects window to an Excel spreadsheet.
Recycle Bin
The recycle bin is a temporary storage location for projects that have been deleted. It gives you a chance to restore the deleted project to its original location, if needed. Projects in the recycle bin are stored until you either empty the recycle bin or delete each individual project from the recycle bin.

Sending Projects to the Recycle Bin
Whenever you delete a project from a database, a confirmation window like the one shown next will appear.

![Confirmation Window]

If you want to move the project to the recycle bin, make sure the Send project to recycle bin check box is selected. If you want to immediately and permanently delete the project, clear the check box. Remember that once you empty or delete a particular project from the recycle bin, there will be no way to get it back unless you have previously created a backup or restore point.

Restoring and Deleting Projects from the Recycle Bin
In a secure database, the ability to restore and delete projects from the recycle bin is available only if the user a) is the project owner, b) has the "Delete project" permission, or c) has the applicable "manage all projects" permissions).

To restore a project from the recycle bin, select it and choose Project > Management > Recycle Bin > Restore Project.

To permanently delete a project in the recycle bin (no way to undo unless you have a backup or restore point), select it in the recycle bin and choose Project > Management > Recycle Bin > Delete Project.
Chapter 2: Repositories and Projects

To permanently delete all projects currently in the recycle bin (no way to undo unless you have a backup or restore point), select the Recycle Bin heading in the project list and choose Project > Management > Recycle Bin > Empty Recycle Bin.

Security

All enterprise databases use login security, meaning that the Synthesis applications use Windows authentication (or alternative credentials) to identify each user and control the user’s access via security groups. For a standard database or Synthesis file, you can choose whether to apply login security; if you don’t, any user who has read/write access to the file will have full permissions throughout the database.

By default, each user in a secure database will have the same set of permissions for every public/reference project in the database (e.g., Jane Engineer has read-write access to all projects, Bill User has read-only access to all projects, and so on). Alternatively, you can configure the database to provide different permissions for different public/reference projects, if desired (e.g., Jane Engineer has read-write access to all of Department A’s projects, but she has read-only access to other projects). With either approach, you also have the option to further limit access for specific project items (e.g., folios, diagrams, system hierarchy items, etc.) if needed. There are many different ways these options can be configured depending on your organization’s particular needs.

Tip: If you need to be able to manage an enterprise database without using a Synthesis desktop application (i.e., without taking up one of the available license seats), you can access the same security features from the Synthesis Admin tool.

Applying Login Security

All enterprise databases use login security. For standard databases or Synthesis files, there are two ways to apply login security if desired:

- Upon creating a new standard database or Synthesis file (File > New), you can make it login secure by selecting the Apply login security check box.
• For an existing standard database, you can apply login security at any time by choosing File > Manage Repository > Users and Security and then clicking the Apply Login Security button at the lower left corner of the window.

When you create an enterprise database or apply login security to a standard database or Synthesis file, you will automatically be a member of the Admin security group, which has full permissions throughout the database. You can then use the Users and Security window to add/edit/delete other user accounts and assign them to appropriate security groups.

Note: You cannot automatically remove security from a database once it has been enabled. However, you can create a new non-secure database and use the Import from existing repository check box to automatically import all of the data from the secure database to the non-secure one.

Planning Your Security Approach

In secure databases, there are two basic factors that determine what a typical user can see and do in the database: the security group(s) that the user account belongs to and the public/reference project security settings.

This topic discusses two general approaches you can use to configure the security groups and project security settings to fit your organization’s specific needs:

• Same permissions for all public/reference projects
• Different permissions for different public/reference projects

Tip: In addition to these considerations, it is also important to note the following: a) Users with the applicable "manage all projects" permissions (in any of the security groups that they belong to) will always have full project-level permissions for all public or reference projects in the database; b) The
project owner will always have full project-level permissions within that particular project; and c) The item permissions can be used to further limit access to specific items within a project (e.g., folios, diagrams, system hierarchy items, etc.).

Same Permissions for All Public/Reference Projects
If you want each user to have the same set of permissions for all public/reference projects in the database (e.g., Jane Engineer has read-write access to all projects, Bill User has read-only access to all projects, and so on), follow these steps:

1. **User Accounts and Security Groups**: Assign each user account to an appropriate security group. This can be one of the four security groups that are created by default in each new Synthesis repository — Admin, Power, User (Read/Write) or View (Read-Only) — or you can configure new or existing security groups to meet your particular needs.

   Select or clear the **Allow access to projects with repository-level security** check box. If some of the projects in the database will continue to use repository-level security, this allows you to specify whether each user will be able to access those projects.

   - If the option is selected (default), the user will be able to access any public/reference project that is set to use repository-level security, with the combined permissions from any of the assigned security groups.

   - If the option is cleared, the user will only be able to access a project if it is specifically assigned to a security group that he/she belongs to, or if the user account is specifically assigned to the project.
2. **Project Security**: Accept the default option on the *Security* tab of the Project Properties for all public and reference projects (*Project > Security > Project Security*). Note that if a user belongs to more than one security group (and the *Allow access to projects with repository-level security* check box is selected for his/her user account), that user will have the combined permissions of those groups in any project that is set to repository-level security.
Different Permissions for Different Public/Reference Projects

If you want the same user to have different permissions for different public/reference projects (e.g., Jane Engineer has read-write access to all of Department A’s projects, but she has read-only access to other projects), follow these steps:

1. **Security Groups**: Create a security group for each distinct type of access that users might need in any particular public/reference project. Here’s a simple example:
2. **User Accounts**: Assign the appropriate security group(s) to each user account. For the example shown below, the user will have read/write permissions in projects that are assigned to "Department A," and read-only access in projects that are assigned to "Read-Only."

If some of the projects in the database will continue to use repository-level security, the **Allow access to projects with repository-level security** check box gives you the option to decide whether each user will be able to access those projects.

- If the option is selected (default), the user will be able to access any public/reference project that is set to use repository-level security, with the combined permissions from any of the assigned security groups.
If the option is cleared, the user will only be able to access a project if it is specifically assigned to a security group that he/she belongs to, or if the user account is specifically assigned to the project.

3. **Project Security**: Assign the appropriate security group(s) and/or specific user(s) for every public/reference project in the database.

- When you assign a security group, every user who belongs to that group will be able to access the project with the permissions that are specified in the group.

- When you assign a specific user, the combined permissions from all of the security groups that the user belongs to will be displayed. Use the check boxes to select which of those permissions will be in effect for that user in this particular project.

For the example shown below, users from Department A will have read/write access (because they belong to the "Department A" security group), users from Departments B and C will have read-only access (because they belong to the "Read-Only" security group) and Fred Consultant will have read/write access (because he belongs to the "Consultants" security group and has been specifically assigned to have those permissions in this project).
User Accounts

Every person who will access a Synthesis repository, be assigned to some role in an assigned action, and/or receive alerts via e-mail or SMS message must have a personalized user account in the database.

- **In non-secure databases**, the software automatically creates an account for anyone who opens the file. Every user has full permissions throughout the database, including the ability to create, edit or delete other user accounts (e.g., so you can modify contact information or send alerts to someone who has not yet had an account created automatically).

- **In secure databases**, the accounts must be created and managed by users with the "Manage users and logins" permission. The security group(s) assigned to each account determines what the user can see and do in the database.

To view and manage the user accounts in a database, choose **File > Manage Repository > Users and Security**.
Chapter 2: Repositories and Projects

This topic describes how to use the Users and Security window to create, edit or delete/deactivate user accounts. The same window can also be used to enable login security for a standard database or Synthesis file, and to manage security groups (permissions) for a secure database.

**Built-in Find/Filter, Configuration and Grouping Tools**
The Users tab of the Users and Security window offers the same filter, column configuration and grouping tools that are built in to other Synthesis utilities that use a similar grid (e.g., the Synthesis Explorer, Actions Explorer, etc.). For details about how to use each feature, see:

- Finding and Filtering Records
- Configuring Columns
- Grouping Panel

**Creating and Editing User Accounts**
The Users tab of the Users and Security window displays a table of all user accounts that have been created in the database. You can use the **Add** or **Edit** buttons below the table to create or modify individual accounts.

You can also import user accounts from Microsoft Active Directory by clicking the **Active Directory** button. (See Importing Users from Active Directory.)

Keep in mind the following requirements when creating new user accounts for a secure database:

- In order to use Windows authentication, the user must be logged in to a computer with the same domain/username that is defined in the Synthesis user account. If a user needs to connect to a database from a different domain, you can set up alternative credentials that will allow access without domain authentication. (See Creating Alternative Credentials.)

- In order to access the database, the user account must be assigned to at least one security group. (If you simply wish to send e-mail alerts to the user, a security group is not required.)

- For SQL Server databases, the username must be associated with a "SQL Server Login" that allows the database platform to recognize the user and give access to the application database. This can be accomplished with an individual login, a group login or Windows impersonation. (See SQL Server Logins or Using Windows Impersonation.)

**Deleting or Deactivating User Accounts**
If an account has never been used and you want to permanently remove it, select the account name from the list and click **Delete**.
If an account has already been logged in at least once (the Last Login column shows this information), attempting to delete the account will deactivate it instead. A deactivated account will not have access to the database.

You can manually deactivate an account by clearing the check box in the Active column for the account. To reactivate the account and give the user access to the database again, select the check box in the Active column.

User Login and Contact Information
The User Login and Contact Information window contains the contact information, alerts preferences and action resource details for an individual Synthesis user. In a secure database, it also includes access settings (security groups and alternative credentials).

To view or edit your own user account, double-click your name in the MDI status bar or choose My Portal > Users > My Profile.

To view or edit any user account in the database, choose File > Manage Repository > Users and Security, then double-click any row in the Users table. (In a secure database, this is available only for users with the "Manage users and logins permission.")
All of the user account options are described below. Some of these settings cannot be modified when you are editing your own profile.

**User Info Tab**
- **Domain** and **Username** contain the credentials used by Windows authentication to identify the user and give him/her access to the database.
- **Contact Details**. Each user can update his/her own contact details, if desired. Note that the Display Name will appear in all projects, analyses and plots you create or modify in the database. Click the **Active Directory** button to update the contact details based on information stored in Active Directory.
- **User Image**. Each user can save a profile photo, which will appear in locations such as the **User Page** of My Portal. Saved images are resized to 100 x 100 pixels.
- **Security Groups** control the user's access to the database. (See **Managing Security Groups**.)
- **Allow access to projects with repository-level security**
  - If the option is selected (default), the user will be able to access any public/reference project that is set to use repository-level security, with the combined permissions from any of the assigned security groups.
  - If the option is cleared, the user will only be able to access a project if it is specifically assigned to a security group that he/she belongs to, or if the user account is specifically assigned to the project.

For more information, see **Planning Your Security Approach**.

- **Update security groups upon login (if associated with Active Directory)**
  - If the option is selected (default), the user's security groups will be assigned automatically based on his/her security group in Active Directory. (See **Associating Security Groups with Active Directory**.)
  - If the option is cleared, the user can be manually assigned to any of the available security groups.
- **Active**. Clear or select the check box to deactivate or activate the account. A deactivated account will not have access to the database.

**Alerts/Actions Tab**
- **Receive automated alerts**. Each user can choose to receive alerts via e-mail, SMS text message or Synthesis portal messages. (See **Watches and Alerts** and **What is Your SMS Address?**) Note that alerts via e-mail and SMS text are available only if a valid SMTP
server has been defined for the database and the user account has an e-mail address/SMS contact defined.

- **When assigned to actions.** When a user account is assigned to an action (either as the Person Responsible or as part of the Team resource), the **Cost Category** and **Hours per Day** are used to calculate resource utilization and costs. (See **Costs and Man Hours**.)

**Alternative Credentials Tab**
The Alternative Credentials tab is available only for secure databases. Select the check box to allow the user to bypass Windows authentication and connect to the database using an alternative username and password. (See **Creating Alternative Credentials**.)

**Importing Users from Active Directory**
If your organization uses Microsoft Active Directory, this topic explains how to import username and contact information from the directory to create new user accounts in the Synthesis repository. (If you also wish to use Active Directory to manage the membership in Synthesis security groups, see **Associating Security Groups with Active Directory**.)

To import users from Active Directory, choose **File > Manage Repository > Users and Security**, click the **Active Directory** button, and then follow these steps:

1. Enter or select the domain name in the **Domains** field. If your organization’s directory is large, you may also choose to limit the search to specific groups by clicking **Load Groups** and then choosing an option from the drop-down list. You can also use the **Filter By** field to further limit the search. When you have specified the desired filters, click **Load Users** to update the table.

2. In the table of user accounts that match the filter criteria, select the check box for each user you want to create a Synthesis account for. (The names of users who already have an account in the current database will appear grayed out.)
3. For secure databases only, use the **Import as Members Of** field to select the security group(s) that will be assigned to the new user account(s). If you skip this option now, you can assign security groups later for each individual account. (See [Managing Security Groups](#).)

4. For SQL Server databases only, select the **Create SQL Server login** check box if you want to create an individual SQL Server login for each new Synthesis user account. (See [SQL Server Logins or Using Windows Impersonation](#).)

5. Click **Import** to create the account(s). After the process completes, the window will remain open to allow you to import additional users, if desired.

### Creating Alternative Credentials

**Secure databases** use Windows authentication by default. This means that users must be logged in to a computer using the same domain and username specified for their Synthesis user accounts. You can, however, allow specific users to bypass Windows authentication as needed. This may be useful for situations where:

- A user needs to work on a copy of a secure standard database or Synthesis file on a computer that is not connected to the company's network.

- A user needs to connect to an enterprise database from a different domain.

For these situations, you can set up alternative credentials for a user’s account that will allow that user to access the database without domain authentication. These credentials must be set up in advance, before the user attempts the connection.

If you have the "Manage users and logins" permission, you can create alternative credentials for a user account by following these steps:

1. Open the Users and Security window (File > Manage Repository > Users and Security). On the Users tab, select the account name from the list and click **Edit**.

2. In the User Login and Contact Information window, click the **Alternative Credentials** tab and then select the check box to enable alternative credentials.
3. With the setting enabled, create an alternative username and password for the account. The username and password must be unique within the database, and the password is Case Sensitive.

Once you have created the credentials, instruct the user to enter this login whenever the database prompts for it. The database will ask for the alternative credentials whenever the user account cannot be matched based on domain authentication.

**Tip:** The first time you connect to a database using alternative credentials, the application will automatically remember the login information on your computer. If you wish to clear the saved login, you can click the Clear Alternative Credentials link on the Other Synthesis Settings page of the Application Setup.

### User Groups

The User Groups window (formerly called “Notification Groups”) allows you to create and manage groups of users that can be assigned throughout the current database for:

- Recipients for portal messages
- Monitors for assigned actions
- Team members in the Project Planning Resources

To access the window, choose File > Manage Repository > User Groups.

In a secure database, this is available only for users with the "Manage users and logins" permission.

**Adding or Editing a Group**

The table displays a list of the user groups that have already been defined in the current database.

To add a new group, click Add.
Chapter 2: Repositories and Projects

To view or edit an existing group, double-click the row or select the row and click **Edit**.

The **Available Users** list shows all of the user accounts in the current database that are not yet assigned to the group. Double-click or use the buttons to move at least one user into the **Selected Users** list.

**Deleting a Group**

To delete an existing group, select a row and click **Delete** or press the **DELETE** key.

If the user group has been assigned to any existing actions, messages or project planning teams, the group will be removed automatically and those users will no longer be assigned in the affected records. **There is no undo for delete.**

**Managing Security Groups**

In a secure database, *Synthesis security groups* control what users can see and do in the database. By default, the software includes four predefined security groups: Admin, Power, User and View. The Admin group, which has full permissions throughout the database, can neither be deleted nor have its permissions modified. For the other predefined groups, you can edit their permissions or replace them with new groups that fit the specific way the database will be used. As discussed in **Planning Your Security Approach**, there are two basic approaches you can use:

- **Same permissions for all public/reference projects** — each user account is assigned to one security group and all public/reference projects use the default security option (repository-level security).

- **Different permissions for different public/reference projects** — each user account may be assigned to multiple security groups and each public/reference project may be accessed only by specific security groups and/or users.

**Creating, Editing or Deleting Security Groups**

You can manage the security groups by choosing **File > Manage Repository > Users and Security**. (In a secure database, this is available only to users with the "Manage users and logins" permission.)

In the Users and Security window, click the **Security** tab to see all the security groups that have been created in the database. Use the **Add**, **Edit** or **Delete** buttons below the table to manage the groups.

When you edit a security group, the left side of the Security Group window allows you to choose the permissions, while the right side shows all the users currently assigned to the group.
If you have selected to **Associate this security group with an Active Directory group**, the list of assigned users can be updated automatically, or you will only be able to manually import/assign users who belong to the designated Active Directory group. (See [Associating Security Groups with Active Directory](#).)

**Synthesis Permissions**
Here is a summary of all the permissions that can be granted to a particular security group.

**Basic permissions throughout repository**
These permissions apply throughout the database if they are in any of the security groups that the user belongs to. These permissions do not depend on the security settings for a particular project.

| Create and own private projects | You can create and own *private* projects in the database that are accessible only to you. (Users with the "Manage all private projects" permission can still perform administrative tasks on all private projects, such as editing their properties, locking them, converting them to public projects, etc.) |

---

---
Create and own public projects
You can create and own *public* projects that other users can view and edit (depending on the project security settings).

Create and own reference projects
You can create and own *reference* projects for sharing resources and FMEAs with other projects in the database (depending on the project security settings).

Create portal messages
You can create new messages, and edit or delete the messages you have personally created via the Messages page in My Portal.

Publish to Synthesis Enterprise Portal
You can publish your progress, results and analyses from a given project to the Synthesis Enterprise Portal (SEP), making the information accessible from any web-enabled device.

Create/edit/delete SDW data collections
You can create, edit and delete data collections in the Synthesis Data Warehouse (SDW). This includes data extraction from XFRACAS as well as custom connections, and confers the ability to create dashboard layouts for custom connections.

**Basic and advanced permissions at project level**
A user can have these permissions in some projects but not others, depending on the project security settings. Regardless of the project security settings, these permissions are always automatically granted to the current project owner.

<table>
<thead>
<tr>
<th>Read</th>
<th>You can perform tasks that do not modify the data in the project (e.g., view the analysis, calculate metrics in a Quick Calculation Pad, export data, etc.).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create/edit project items</td>
<td>You can create and edit items in a given project such as folios in Weibull++/ALTA, diagrams in BlockSim, system hierarchy items in Xfmea/RCM++/RBI, etc., as well as update the item properties.</td>
</tr>
<tr>
<td>Create/edit/delete own resources</td>
<td>You can create Synthesis resources (e.g., URDs, models, etc.) and edit or delete any existing resources you have created.</td>
</tr>
<tr>
<td>Feature</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Delete project items</td>
<td>You can delete any item in a given project (e.g., folios in Weibull++/ALTA, diagrams in BlockSim, system hierarchy items in Xfmea/RCM++/RBI, etc.). This permission cannot be assigned unless you also have the &quot;Create/edit project items&quot; permission.</td>
</tr>
<tr>
<td>Create/edit project plans</td>
<td>You can create and edit project plans for a given project.</td>
</tr>
<tr>
<td>Create/edit/delete local resources</td>
<td>You can create, edit and delete any local resources in the project (not just the ones that you created).</td>
</tr>
<tr>
<td>Set project security</td>
<td>You can control who can view and edit a given project. This permission allows you to configure both project security settings and item permissions.</td>
</tr>
<tr>
<td>Edit project properties</td>
<td>You can use the Project Properties window to edit the name, description, category and other settings of a given project.</td>
</tr>
<tr>
<td>Lock or check out project</td>
<td>You can:</td>
</tr>
<tr>
<td></td>
<td>- Lock and unlock a given project.</td>
</tr>
<tr>
<td></td>
<td>- Check in and check out a given project.</td>
</tr>
<tr>
<td>Create restore points</td>
<td>You can utilize restore points for a given project, which are exact replicas of the project at a particular point in time (i.e., backups).</td>
</tr>
<tr>
<td>Delete project</td>
<td>You can delete a given project.</td>
</tr>
<tr>
<td>Manage change logs in Xfmea/RCM++/RBI</td>
<td>You can enable and manage change logs within a given project. Change logs can be created for FMEAs, DVP&amp;R, Control Plan and P-  Diagram analyses in Xfmea, RCM++ and RBI. See Change Logs in the Xfmea/RCM++/RBI documentation.</td>
</tr>
<tr>
<td>Approve change logs in Xfmea/RCM++/RBI</td>
<td>You can implement electronic approval tracking for change logs within a given project. See Electronic Approval Tracking in the Xfmea/RCM++/RBI documentation.</td>
</tr>
</tbody>
</table>
Chapter 2: Repositories and Projects

**Administrative permissions throughout repository**
These permissions apply throughout the database if they are in any of the security groups that the user belongs to. These permissions do not depend on the security settings for a particular project.

<table>
<thead>
<tr>
<th>Manage users and logins</th>
<th>You can:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Use the <a href="http://xfmea.reliasoft.com">Users and Security window</a> to add user accounts to the database and define security groups, as well as create alternative credentials for user accounts.</td>
</tr>
<tr>
<td></td>
<td>• Use the <a href="http://xfmea.reliasoft.com">User Groups window</a> to add and manage distribution groups for e-mail alerts, portal messages, action alerts and projecting planning resources.</td>
</tr>
<tr>
<td></td>
<td>• Use the <a href="http://xfmea.reliasoft.com">Repository Logins window</a> to view and export a history of database logins.</td>
</tr>
<tr>
<td></td>
<td>• Use the <a href="http://xfmea.reliasoft.com">Reset &quot;In Use&quot; Flags window</a> to clear the &quot;in use&quot; status for selected database users (not just your own).</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Manage project planning resources and working days</th>
<th>You can:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Use the <a href="http://xfmea.reliasoft.com">Project Planning Resources window</a> to manage the cost categories, teams, materials and facilities that are used for tracking resource utilization in Project Planner gates and actions.</td>
</tr>
<tr>
<td></td>
<td>• Use the <a href="http://xfmea.reliasoft.com">Working Days/Holidays window</a> to specify the business days that will be used for Project Planner gates and actions.</td>
</tr>
</tbody>
</table>

| Manage project/item categories | You can use the [Project/Item Categories window](http://xfmea.reliasoft.com) to define the project and item categories that can be used for grouping and filtering projects and items in the database. |
### Chapter 2: Repositories and Projects

<table>
<thead>
<tr>
<th>Manage other repository settings</th>
<th>You can:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Use the <strong>Time and Usage Units window</strong> to define the time units available for use in any project within the database.</td>
</tr>
<tr>
<td></td>
<td>• Use the <strong>Default Name Formats window</strong> to specify how default names for resources and blocks are created.</td>
</tr>
<tr>
<td></td>
<td>• Use the Task Types window in RCM++, RBI and MPC.</td>
</tr>
<tr>
<td></td>
<td>• In RCM++ and RBI, you can map the task types that are used only in RCM++/RBI to the task classes in the universal reliability definition (URD). See <strong>Task Types in RCM++/RBI</strong> in the RCM++/RBI documentation.</td>
</tr>
<tr>
<td></td>
<td>• In MPC, you can modify the abbreviations used for MSG-3 task types. See <strong>Task Type Abbreviations in MPC</strong> in the MPC documentation.</td>
</tr>
<tr>
<td></td>
<td>• Use the <strong>Repository Settings window</strong> to set some default settings for existing and new databases. This includes enabling e-mail alerts for the database, activating history logs, etc.</td>
</tr>
<tr>
<td></td>
<td>• Set up <strong>XFRACAS connection settings</strong> that allow Synthesis desktop applications to access the XFRACAS data stored in the database. This is available only for standard databases (*.rsr11).</td>
</tr>
</tbody>
</table>

| Create/edit/delete global resources | You can create, edit and delete any **global resources** in the project (not just the ones that you created). In addition, you can transfer data from **XFRACAS to the SDW**. |

| Approve actions | You can review and approve **actions**, which are Synthesis resources that allow you to track progress made in a project. |

| Manage all portal messages | You can edit or delete any messages that are visible to you via the Messages page in **My Portal**. This includes any messages for which you are the creator or one of the recipients. |

| Manage dashboard layouts | You can create and save layouts for use in the **Dashboard Viewer** in Weibull+++, BlockSim and RGA. |
## Manage profiles and templates in Xfmea/RCM++/RBI

This permission is available only in enterprise databases. You can:

- Use the Profiles/Library Manager window in Xfmea/RCM++/RBI to configure the predefined settings stored in the active library of the enterprise database. See Profiles/Library Manager in the Xfmea/RCM++/RBI documentation.

- Use the Templates Manager window in Xfmea/RCM++/RBI to configure report templates stored in the enterprise database. See Templates Manager in the Xfmea/RCM++/RBI documentation.

## Manage Lambda Predict repository settings

You can:

- Use the FIDES Settings Manager window in Lambda Predict to configure the FIDES-related settings stored in the database. This applies to the FIDES prediction standard only (see FIDES Settings Manager in the Lambda Predict documentation).

- Use the Custom Derating Standards Manager window in Lambda Predict to create, edit or delete user-defined derating standards stored in the database. See Creating Custom Derating Standards in the Lambda Predict documentation.

- Use the MIL-217 Custom Connections window in Lambda Predict to define failure rates for user-defined connectors stored in the database. This applies to the MIL-217 prediction standard only. See MIL-217 Custom Connection Types in the Lambda Predict documentation.
### Chapter 2: Repositories and Projects

<table>
<thead>
<tr>
<th>Manage MPC Settings</th>
<th>You can:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Use the Manage ATA Chapters window in MPC to define the systems and subsystems that are available for use in the database. See Managing ATA Chapters in the MPC documentation.</td>
</tr>
<tr>
<td></td>
<td>• Use the Manage Major Zones window in MPC to define the zones and major sub-zones that are available for use in the database. See Managing Major Zones in the MPC documentation.</td>
</tr>
<tr>
<td></td>
<td>• Use the Configurable Options for Systems and Powerplant Analysis window in MPC to enable or disable the display of some item properties and task properties fields. See Configurable Options for Systems and Powerplant Analysis in the MPC documentation.</td>
</tr>
<tr>
<td></td>
<td>• Use the Configurable Options for Structural Analysis window in MPC to customize the settings for environmental deterioration (ED) and accidental damage (AD) analyses that can be performed for any structural item in MPC Plus. See Configurable Options for Structural Analysis in the MPC documentation.</td>
</tr>
<tr>
<td></td>
<td>• Use the Configurable Options for Zonal and L/HIRF Analysis window in MPC to customize the settings for the standard zonal, enhanced zonal and L/HIRF analyses that can be performed for any zonal item in MPC Plus. See Configurable Options for Zonal and L/HIRF Analysis in the MPC documentation.</td>
</tr>
</tbody>
</table>

| Manage all public projects | You have all the basic and advanced project-level permissions for public projects in the database. You can also change the project owner for any public project in the database. |
| Manage all reference projects | You have all the basic and advanced project-level permissions for reference projects in the database. You can also change the project owner for any reference project in the database. |
| Manage all private projects | You have all the basic and advanced project-level permissions for private projects in the database. You can also change the project owner for any private project in the database. |
Associating Security Groups with Active Directory

If your organization uses Microsoft Active Directory (AD), you can give an AD group a specific set of permissions in the Synthesis repository. The members of the AD group can then access the database based on the set of permissions associated with the group.

In addition, the software offers the option to automatically update the permissions of a user whenever that user is added or removed from an AD group. For example, if a user is moved from AD group A to AD group B, his/her Synthesis user account can be automatically updated with the permissions associated with AD group B. The changes will take effect the next time the user connects to the database via any of the Synthesis desktop applications. (Note that for users who will connect only via the Synthesis Enterprise Portal (SEP) website, you’ll need to update their permissions manually either via a desktop application or the Synthesis Admin tool on the web server.)

Tip: Multiple security groups can be assigned to the same user account, if appropriate. For example, a user can be assigned to the "ABC Team" group (which is associated with Active Directory) and the "Read-Only" group (which is not). (See Planning Your Security Approach.)

Assigning Permissions to an Active Directory Group

To associate a Synthesis security group with an Active Directory group, choose File > Manage Repository > Users and Security and click the Security tab. Then double-click the security group you want to edit.

In the Edit Security Group window, select the Associate this security group with Active Directory check box, and then specify the domain name and Active Directory group to use. There are two additional options, which apply only when users log in from a Synthesis desktop application:

- **Automatically update this security group's members.** If a user is added to the AD group, his/her Synthesis user account will automatically have this set of permissions the next time the user logs in to the database via any of the Synthesis desktop applications. Likewise, if the user leaves the AD group, his/her Synthesis user account will no longer have this set of permissions.

  If you do not want the changes in Active Directory to be automatically applied to a particular user, clear the Update security groups upon login check box in that user's account in the Synthesis repository.

- **Automatically create new user accounts on first login.** If a member of the AD group does not already have a Synthesis user account, it will be created automatically (and
assigned to this security group) the first time he/she tries to connect via any of the Synthesis desktop applications.

Creating/Updating Accounts Now
If you don’t want to wait for all users to log in before creating/updating their Synthesis user accounts, click the Assign button at the bottom of the window.

- To create new accounts, choose Import users who are members of this Active Directory group. This opens the Import Users from Active Directory window, but you can only choose users from the associated Active Directory group.

- To update the security groups for existing accounts, choose Assign existing repository users who are members of this Active Directory group. This shows a list of existing Synthesis users who also belong to the associated Active Directory group; you can select to update any or all of their accounts.
Chapter 2: Repositories and Projects

Setting Item Permissions
In a secure database, all project items (e.g., folios, diagrams, system hierarchy items, etc.) are, by default, set to inherit their permissions from the project. This means that if a user has the "Create/edit items" permission for the project, he or she will be able to edit all of the items by default. If you want to prevent some or all of those users from editing a particular item (i.e., lock or limit access to the item), you can use the Item Permissions window.

The window functions a little differently depending on whether you’re working with items in a project explorer (e.g., folios, diagrams, etc.) or items in a system hierarchy.

Project Explorer Items
In Weibull++, ALTA, BlockSim, RENO, RGA or Lambda Predict, select the item in the current project explorer and choose Project > Current Item > Item Properties. (In a secure database, this is available only if the user a) is the project owner, b) has the "Set project security" permission, or c) has the applicable "manage all projects" permissions.)

The settings are displayed on the Permissions tab of the properties window.

In the Item Permissions window, select the Restrict editing to selected project users option and then select which specific users will be able to edit this particular item. All others can view, but not edit, the item. Only users with editing rights to the project will appear in the list.

To remove item permissions and change the security settings back to the defaults, select the Inherit from project option.

System Hierarchy Items
In Xfmea, RCM++ or RBI, select the item and choose System Hierarchy > Current Item > Item Permissions. In MPC, select an item and choose [Systems/Structures/Zones] > Security > Item Permissions. (In a secure database, this is available only if the user a) is the project owner, b) has the "Set project security" permission, or c) has the applicable "manage all projects" permissions.)

In the Item Permissions window, you can choose to:

- Define the permissions for the item by selecting the Restrict editing to selected project users option and then selecting which specific users will be able to edit this particular item. All others can view, but not edit, the item. Only users with editing rights to the project will appear in the list.

- Set the item to inherit the same permissions as the next item above it in the system hierarchy by selecting the Inherit from parent item option.
• Remove item permissions and change the security settings back to the defaults by selecting the Inherit from project option.

If you select the Apply to all dependents check box, the software will automatically set the permissions for all next-level items in this branch of the hierarchy to match the item you are currently editing. For example, consider a case where each item in an Xfmea system hierarchy has different permissions, as shown next.

For a quick way to reset all of the item permissions to the defaults, you can open the Item Permissions window for SubSystem 1, set to Inherit from parent item and select the Apply to all dependents check box. The resulting system hierarchy is shown next.

Status Indicators
Synthesis desktop applications include status indicators that tell you which project items (e.g., folios, diagrams, system hierarchy items, etc.) are in use or restricted.

When you encounter an item that is read-only (e.g., OK button is disabled in the window or you are unable to type in the cells of a worksheet or table), you can check the status of the item to see if it is currently in use (i.e., you can’t edit the item until the user closes the folio/diagram...
or selects a different item in the hierarchy) or restricted (i.e., you don’t have permissions to edit the item). If the item is in use, move the pointer over the icon to identify the user.

The location of these status icons will vary depending on which Synthesis application you are using:

- In projects that use a current project explorer to manage analysis data, the status icons are displayed next to the item’s name in the current project explorer, as in the example shown next.

- In projects that use hierarchical trees to manage analysis data (as seen in the Xfmea, RCM++, RBI and MPC applications), the status icons are displayed in the User Access column of the system hierarchy. (To hide or display columns, right-click the column headings, then click Customize Columns to select which columns you want to display.)

**Tip:** The application interface refreshes automatically whenever you make a change (e.g., close a project, create a resource, select a different item, etc.). If your computer will not let you edit an item that is in fact not currently being edited by another user, it could be because your computer has not been recently refreshed with the latest changes made by other database users. You can initiate the
refresh manually by choosing View > Refresh.

In addition, the software employs “in use” flags within the database to record when an analysis is currently being edited by a particular user. If the refresh still does not show that the item has been released, then something might have occurred to prevent the flags from being reset correctly (e.g., a network interruption or if the software closes unexpectedly). Refer to the Reset “In Use” Flags topic for instructions on how to reset the flags throughout the database if this problem occurs.

**Reset "In Use" Flags**

Because Synthesis repositories allow simultaneous access by multiple users, it is necessary to store “in use” flags within the database to indicate when a particular portion of the analysis is currently being edited by a particular user. There are some circumstances when these flags might not be reset correctly when a user stops editing an analysis (e.g., if there is a network interruption or if the software closes unexpectedly). If that occurs, then the analysis will be locked for editing because the software receives an erroneous indication that it is still in use by another user.

To correct the problem, it is necessary to reset some or all of the “in use” flags within the database. To reset the flags, choose File > Manage Repository > Reset 'In Use' Flags.

(In a secure database, this is available only for users with the "Manage users and logins" permission.)

This opens the Reset 'In Use' Flags window, which shows all users who have an account in the database. (If you are working in a non-secure database, any user who has ever opened the database will have an account created automatically and will be shown in this list.) A status light is displayed for each user; if it is "lit up" (i.e., green), the user is currently logged in to the database. In addition, the Connections column shows the Synthesis application(s) that the user currently has connected to the database. You can select the check box for each user for whom you want to reset "in use" flags, then click OK to reset the flags.

**IMPORTANT:** It is important to make sure that no selected user is currently logged in to the database when you use this command. Users currently logged into the database can be viewed on the Users Page of My Portal.
Chapter 2: Repositories and Projects

**Repository Logins**

The Repository Logins window displays a record of the date and time the users in the database logged in. To open the Repository Logins window, choose **File > Manage Repository > Repository Logins**. (In a secure database, this is available only for users with the "Manage users and logins" permission.)

The following options are available:

- Use the **Most Recent** filter to display in the table the last 10; 100; 10,00 or 10,000 users who logged in to the database.
- Use the **User** filter to specify whether the table will display the logs for all users or display only the logs for a selected database user.
- Click the **Send to Excel** button to export the data currently displayed in the table to an Excel spreadsheet.
- Click the **Clear Logins** button to clear the entire history of users who logged in to the database. Since this action cannot be undone, you will be prompted to confirm that you want to proceed before the records are erased.

Users currently logged into the database can be viewed on the **Users page** of My Portal.

**Repository Settings**

The Repository Settings window contains settings that are shared by all users and analysis projects in the database. To access this window, choose **File > Manage Repository > Repository Settings**. (In a secure database, this is available only for users with the “Manage other repository settings” permission.)

In a standard database or Synthesis file, you can save the current settings as the default for each new standard database/Synthesis file that you create from this computer by clicking the **Set as Default** button at the bottom of the window.

*What’s Changed?* In prior versions, these preferences were defined in the E-mail and Other Settings window.
E-mail Settings Page

- **Enable Alerts via E-mail or SMS** configures the database to enable alerts via e-mail or SMS text message. (See [Enable Alerts via E-mail or SMS](#).)

- **Action Alerts** apply to action resources. The database can be configured to auto-subscribe a "watch" for users based on their role(s) for a particular action. You can also specify the default text that will be used at the beginning of each action alert. (See [Action Alert Preferences](#).)

Other Settings Page

- **FMEA Structure (Xfmea/RCM++/RBI)** allows you to select the default FMEA structure for new projects created in the database, which determines how the software will display the effect and cause records in the FMEAs. If you don't specify a default, users will be prompted to select the structure for each new project they create in Xfmea/RCM++/RBI. (See [Choosing the FMEA Structure](#) in the Xfmea/RCM++/RBI documentation.)

- **History Logs** allows you to turn the log on (or off) for all active projects, and stores a preference for whether the log should be activated by default for each new project. (See [History Logs](#).)

- **Actions** allows you to automatically sets the person who created an action to be the person responsible for it. (See [Person Responsible and Resources](#).)

- **Enable publish to Synthesis Enterprise Portal** is available only in enterprise databases. If your organization has established a web-based Synthesis Enterprise Portal (SEP) for the current database, select this check box to enable users to publish analysis summaries, Synthesis Workbooks and other information to the portal.

- **Delete Portal Messages** deletes all portal messages for all users in the database. *There is no undo for deleting portal messages.*

Time and Usage Units

The Time and Usage Units window defines the time units that will be available for use in any project within the database. This allows users to work with time-based inputs and results in the units that are appropriate for the situation. For example, you can enter data into a Weibull++ life data folio data sheet in hours and then obtain results from the QCP in terms of years. Similarly, in RCM++, RBI or BlockSim, you can define the duration of a maintenance task in terms of hours and specify the total operating time of a system in terms of months.
**IMPORTANT:** It is important to realize that making changes to the existing units can have implications for all analyses throughout the database; therefore, it is best to set up units once, upon creation of the database.

To define time units, choose **File > Manage Repository > Time and Usage Units**. (In a secure database, this is available only to users with the "Manage other repository settings" permission.)

The units are defined in relation to a common, or "base," unit so that the software can convert data from one unit to another. For example, the units defined by default assign a conversion factor of 1 to the Hour unit, which indicates that an hour is equal to 1 System Base Unit (SBU); the Year unit has a conversion factor of 8760, which indicates that a year is equal to 8,760 SBUs (i.e., 8.760 hours). Note, however, that the SBU does not have to be hours. You could consider days to be your base unit and define all other units in relation to a day (e.g., an hour would be 1/24th of a base unit, with a conversion factor of 0.04167). The SBU does not have to be the default unit either; you can set any unit as the default by selecting it in the **Default** column; the default unit will be used automatically each time the software requires a unit.

Each unit must have a name, an abbreviation of up to three characters and a conversion factor. In addition, each unit must be assigned to any one of the two available categories: Time or Usage. (If you will be using the usage format of the Weibull++ warranty folio, only the units assigned to the Usage category will be available for those analyses; units assigned in the Time category are not available in the warranty usage format.)

Use the **Delete** and **Insert** buttons below the window to manage the list of units. You can also move a unit up or down its current position by selecting it and using the **Move Up** or **Move Down** buttons.

**Note:** In Weibull++, you can specify which of the configurable repository time units are equivalent to the built-in (not configurable) "warranty time units" used in some warranty folio formats. For details, see **Manage Warranty Units** in the Weibull++/ALTA documentation.

### Default Name Formats

In all Synthesis desktop applications except MPC, the Default Name Formats window specifies the default names for new Synthesis resources, as well as new blocks in BlockSim RBDs, fault trees and phase diagrams. For example, when you create a new model, the default name will be the word "Model" plus an increment to make the name unique (e.g., "Model," "Model_1," etc.). You can configure the database to use a different default name format if desired.
Chapter 2: Repositories and Projects

To open the window, choose File > Manage Repository > Default Name Formats. (In a secure database, this is available only for users with the "Manage other repository settings" permission.)

The Resource Name column displays the basic name label for each type of resource or block. This will be represented by the \N code in the name format.

The Name Format column allows you to use any of the following elements to define the default name format for each type of resource or block:

- \N returns the label from the Resource Name column plus an increment to make the name unique (e.g., "Model," "Model_1," etc.).
- \U returns the name of the user who created the resource or block.
- \D returns the date when the resource or block was created.
- \S adds a sequential number that reflects the order in which the resource/block was added to the database.
- \T returns the Synthesis application ("tool") used to create the resource or block.
- \F returns the contents of all of the identifier fields except the category and comments fields.
- \G returns a summary of the properties of the resource or block. For example, for a node in a BlockSim diagram, \G returns the "k out of n" paths that are required.
- \I is only applicable for resources. It functions the same as \N unless there is another window, resource or analysis that it can "inherit" part of the name from. Some examples:
  - If you create a URD from BlockSim’s block properties window, the default name will be "[Block Name]_URD."
  - If you create a metric based on a model, the default name will be "[Model Name]_Metric."
  - If you push a metric from a Project Planner gate, the default name will be "[Gate Name]_[Property Name]_Metric."

Tip: In BlockSim diagrams, you can use an asterisk (*) to insert the default block name. For example, if you enter *System for the block name, the diagram will display the default name for the block followed by the word "System." The asterisk also allows the block name to be updated dynamically when relevant properties change.
Chapter 2: Repositories and Projects

Project Planning Resources
In all Synthesis desktop applications except MPC, project planning resources can be assigned to actions in order to track the required costs and time in the Project Planner and anywhere else that actions are used. Because project planning resources are shared throughout the database, any change made to one is automatically applied to all actions in the database that use it.

- **Cost Categories** specify direct and/or per instance costs that can be assigned to any team member, facility or material.
- **Teams** identify groups of users who will work together on any given action.
- **Facilities** specify the cost and maximum utilization for facilities (e.g., test lab) or other resources for which the cost depends on the duration of use (e.g., rented test equipment).
- **Materials** specify the cost and quantity for materials (e.g., test units) or other resources for which the cost depends on the amount used rather than the duration (e.g., purchased usage data).

To open the Project Planning Resources window, choose File > Manage Repository > Project Planning Resources. (In a secure database, only users with the “Manage project planning resources and working days” permission will be able to create and edit these resources; other users can select from the resources that have already been predefined.)

Cost Categories
Cost categories can be created from the Project Planning Resources window, or when you are creating/editing a facility, material or individual user account. Enter the Currency Symbol to use for displayed costs at the bottom of the window.

- The **Direct Cost per Hour or Unit** is the per-hour cost when assigned to a team member or facility, or the per-unit cost when assigned to a material (e.g., the cost of a single light bulb).
- The **Cost per Instance** is a one-time cost that applies every time a team, facility or material is used.
Teams
Teams can be created from the Project Planning Resources window, or when you are defining an action. A team can include:

- Individual **Users** who have active user accounts in the database.
- **Groups** of active user accounts that have been predefined in the database.

Note that you cannot assign a cost category directly to a team. Instead, the team's cost/utilization is based on the cost category and maximum hours per day for each team member. Both of these properties are set on the **Alerts/Actions** tab of the **User Login and Contact Information window**.

Facilities
Facilities can be created from the Project Planning Resources window, or when you are defining an action.

- The **Cost Category** specifies the facility's hourly and/or per-use costs.
- The **Max Hours Per Day** is the number of hours of use if the facility is set to be 100% utilized for a given action (as specified in the action properties).

Materials
Materials can be created from the Project Planning Resources window, or when you are defining an action.

- The **Cost Category** specifies the cost per unit (e.g., the cost for each test prototype), as well as any additional fixed cost (e.g., the cost for manufacturing a sufficient number of test prototypes).
- The **Quantity** that will be used (e.g., 100 light bulbs).

Working Days/Holidays
In all Synthesis desktop applications except MPC, **actions** and **Project Planner gates** contain important dates like start dates and due dates. You can specify which dates will be considered working days for all actions and gates in the repository. This way, an action's cost/time estimates, as well as its duration, will be based solely on working days.

To define the working days for the repository, choose **File > Manage Repository > Working Days/Holidays**. (In a secure database, this is available only for users with the **"Manage project planning resources and working days" permission**.)
In the window that appears, use the Define Work Week area on the left side to specify which days of the week will be considered regular working days (e.g., Monday-Friday).

**Define Holidays**
On the Define Holidays tab, you can define three different types of holidays.

- **Fixed Date - Recurring** holidays occur every year on the same calendar date (e.g., New Year’s Day is always January 1).
- **Variable Date - Recurring** holidays occur every year, but not always on the same date (e.g., Thanksgiving is always the fourth Thursday of November).
- **Fixed Date - Non-recurring** holidays occur once and do not happen again. For example, a specific Monday could become a non-working day due to weather conditions.

In the Holiday Properties window, select Move to adjacent working day if necessary to make sure the holiday will be observed when a) it occurs outside the work week, but b) there is a regular working day immediately before/after it. In this case, the holiday is observed on the nearest working day. (If there is a working day immediately before and after the holiday, it is observed on the following day.)

**View Observed Holidays**
The View Observed Holidays tab allows you to easily examine the names and dates of all holidays that will be observed during the work week, and can also help you make sure your working days/holidays settings are correct. Specify the years you want to view in the Displayed Range in Years area.

**XFRACAS Connection**
ReliaSoft’s XFRACAS is a web-based, closed-loop, incident (failure) reporting, analysis and corrective action system designed for the acquisition, management and analysis of product quality and reliability data from multiple sources. There are several ways in which you might wish to share data between XFRACAS and the analyses that you perform in Synthesis desktop applications:

- Use the Synthesis Data Warehouse in Weibull++/ALTA or RGA to extract data from XFRACAS incidents. (See Synthesis Data Warehouse.)

- Share system configuration and failure mode data between XFRACAS and Xfmea/RCM++/RBI. (See Import or Sync from XFRACAS in the Xfmea/RCM++/RBI documentation.)

When you are working with an enterprise database, the data from XFRACAS and Synthesis desktop applications can be stored in the same SQL Server or Oracle database.
When you are working with a standard database (*.rsr11) or Synthesis file (*.rsf11), you will need to establish a connection to an enterprise database that contains XFRACAS data. To do this, choose File > Manage Repository > XFRACAS Connection. (In a secure database, this is available only for users with the "Manage other repository settings" permission.)

In the XFRACAS Connection Settings Window, select Connect to an enterprise repository with XFRACAS data then choose Microsoft SQL Server or Oracle.

- For a SQL Server database, enter the server name and database name.
  - Select the Use impersonation check box if you want the connection settings to impersonate a Windows user account with a SQL Server login that is shared by multiple users. (See SQL Server Logins or Using Windows Impersonation.) If you do not use impersonation, then each user who uses the features that utilize XFRACAS must have an account in the external database that contains the XFRACAS data.
- For an Oracle database, enter the port, host and service identifiers and the database schema. Your Windows login credentials are used for access to the database; enter your Windows password.

### Managing and Restoring Data

Since each database may contain a large amount of valuable information that would be difficult to re-create, it is essential to make sure that you are diligent about storing adequate backups and performing the necessary maintenance activities to keep the database operating smoothly. The necessary procedures vary depending on the type of database.

### Enterprise Database Maintenance

When you choose to store analysis information in an enterprise database, a database administrator must perform backups and database maintenance activities using the data management tools that are packaged with and/or designed for the database platform (e.g., SQL Server Enterprise Manager for SQL Server). Each individual organization typically establishes its own procedures for protecting the data stored in the Oracle or SQL Server databases. As a convenience for users who wish to explore the possibilities of an enterprise database implementation without making a large investment of time and resources, instructions on how to perform ReliaSoft’s minimum database maintenance recommendations are posted on the ReliaSoft website:


Standard Database Maintenance

When you choose to store analysis information in a standard database, it will be subject to the same limitations and vulnerabilities as any other file that uses the Microsoft Access® database file format. For example, the maximum file size is ~ 2GB, maximum number of concurrent users is 255, etc. In addition, some specific database vulnerabilities are discussed in a Microsoft publication at http://support.microsoft.com/kb/283849/EN-US/. As this publication states:

"Microsoft Jet, the database engine that is used in Microsoft Access, is a file sharing database system. When Microsoft Jet is used in a multi-user environment, multiple client processes are using file read, write, and locking operations on a shared database. Because multiple client processes are reading and writing to the same database and because Jet does not use a transaction log (as do the more advanced database systems, such as SQL Server), it is not possible to reliably prevent any and all database corruption." [emphasis added]

Although ReliaSoft’s developers have made every effort to reduce or eliminate the possibility that the software will induce a database error, there is no way to absolutely prevent corruption that might be caused by other factors, such as faulty network hardware, an unexpected "crash" on your PC or a network interruption. Therefore, this section provides some recommendations for standard precautions that all users can take to protect the data in their standard databases from this type of corruption and reduce the impact of the data loss if corruption is unavoidable.

1. Create backups regularly. As with any resource that contains a large amount of valuable information that would be difficult to re-create, it is essential to make sure that you are diligent about creating and storing backup files. There are a number of ways this can be accomplished:

   • If you select Automatically back up database upon closing from the Backup/Check Out Options page of the Application Setup, the Synthesis desktop application that you use to open the database will back up the database every time you close the file.

   • If you have a database open and choose File > Save As, the application will create a copy of the database to a pathname/filename of your choosing.

   • If you browse to the database file (*.rsr11) in one of the Windows file management tools (such as My Computer or Windows Explorer), you can copy and paste the database file as needed.
2. **Compact and repair regularly.** Using the "Compact and Repair" feature will help to reduce the size of the database file and help to protect against problems with the operation of the database. If you have the database open and it is not currently in use by another user, you can initiate the process by at any time by choosing **File > Manage Repository > Compact and Repair.**

3. **Do not store the database in a shared network location if you suspect that your network connection and/or hardware may be unreliable.** According to Microsoft, faulty network hardware is one of the main reasons why a file that uses the Microsoft Access database file format may become corrupted. As the Microsoft publication at [http://support.microsoft.com/kb/283849/EN-US/](http://support.microsoft.com/kb/283849/EN-US/) states:

   "The cause can be one or more links in the hardware chain between the computer that the database resides on and the computer that has the database open. This list includes, but is not limited to, network interface cards, network cabling, routers, and hubs.

   Hardware-based corruption is typically indicated by .mdb files that cannot be restored through the use of compacting, repairing, or Jetcomp. **Hardware corruption will typically recur until the responsible hardware is repaired or replaced.**" [emphasis added]

If you have experienced this type of corruption for a standard database file, it is recommended that you take steps to correct the network problem or refrain from accessing database files over the network. In such cases, you may choose to use an enterprise database instead (i.e., Oracle or SQL Server), which would be less vulnerable to network interruptions. Alternatively, you could keep multiple analysis projects together in a single shared standard database file but ask users to export the analysis to a separate "working" database on their own computers when there is a need to make substantial modifications. Users could then import the data back into the shared database after the modifications have been completed.
4. **Do not allow the file size of the database to grow too large.** Performance will be affected by the size of the database and the number of simultaneous users. Therefore, it is important for users to monitor the sizes of their database files and take steps to export the data into several smaller and more manageable files if they become too large. Please be aware of the following factors, which can lead to very large database files:

- Failure to compact and repair the database on a regular basis.
- Using a very large number of attached documents. In some cases, using a link instead of an attachment may provide equivalent functionality with a much smaller impact on the size of the database file.

If you try to open a standard database via the software and receive a message that says "Unable to open the database," this is an indication that the database file may have become corrupted. Please contact ReliaSoft’s **Technical Support** and provide as much information as possible about exactly what you were doing when the corruption occurred. Whenever possible, please provide a copy of the corrupted file. In some cases, ReliaSoft may be able to provide assistance with salvaging some or all of the affected data. However, in many cases, the best recourse may be to restore the latest backup from before the corruption occurred.

---

**Restore Points**

In all Synthesis desktop applications, you can create and manage *restore points* (formerly called "project baselines") for any analysis project. Within the context of Synthesis, the phrase "restore point" refers to an exact replica of the project at a particular point in time (i.e., a backup) that can be restored when and if it is needed. A restore point will include all the data that the project contained at the time the restore point was created, including information about the project properties, security settings and project owner.

There are a variety of ways that this functionality could be used, depending on your particular analysis process and data management requirements. For example, if you are about to begin a major revision to an existing project, you could choose to archive the original version as a restore point and then proceed with updating the project. This would ensure that the active projects in the database contain only the most recent information but also provide easy access to a fully editable copy of the previous version of the analysis if it is ever needed.

**Create a Restore Point**

You can create a restore point for a project at any time by choosing **Project > Management > Restore Point > Create Restore Point** or by right-clicking the name of the project in the **project list** and choosing the command on the shortcut menu.
In a secure database, this is available only if the user is the project owner or has the "Create restore points" permission.

**IMPORTANT:** When you create a restore point, any global, reference and FMEA resources used in the project are converted to local resources and stored with the backup. This ensures that you will have access to these resources upon restoration, regardless of what may have happened to those resources in the interim.

### Restore a Project

To restore all data from an existing restore point, use the **Restore Project** command. This opens the Restore Project window, which displays a list of all existing restore points for the project, if any. You have two options:

- **Overwrite existing project** uses the restore point to roll back the current project to the earlier state. The restore process will complete as long as the project is not currently in use by another user. There is no undo for project overwrites. Therefore, it would be prudent to create a new restore point for the project before you overwrite it with one of the older restore points.

- **Create new project** uses the restore point to create a new project. You may enter a unique name for the new project. When the restore process completes, the new project will be accessible from the project list.

### Manage all Restore Points in the Database

To manage all the restore points that have been created in the database, choose **File > Manage Repository > Restore Points**. (In a secure database, this is available only for users who have all three "manage all projects" permissions.)

This opens the Restore Points window, which displays the details for each of the restore points.

- To create a new restore point, click the **Create** button then select the project you want to back up. Enter any notes that are appropriate to describe the purpose or the circumstances of the restore point and click **OK**.

- To delete an existing restore point, select the row and click the **Delete** button or press DELETE. **There is no undo for delete.**

- To create a new project that restores all of the data from an existing restore point, select the row and click the **Restore Project** button. You will be prompted to specify a unique name for the new project.
Chapter 3: Desktop Application Interfaces

Most Synthesis desktop applications have their own Multiple Document Interfaces (MDIs) that provide full-featured support for the relevant analysis methods. (The exceptions are Weibull++/ALTA and BlockSim/RENO, which can display both applications in a shared MDI.)

When you are using multiple Synthesis applications simultaneously, different applications will open in separate MDIs but they can all connect to the same database, and even to the same analysis project.

All Synthesis MDIs share a common structure, which includes the following elements.

Ribbon and Backstage View

The ribbon at the top of the MDI replaces the toolbars and menus of previous versions of the software. The ribbon is divided into tabs that organize commands into logical groups. Some tabs will always be available (such as File, Home, etc.) while others are contextual and will appear only when you are working on a particular task.

The first tab, the File tab, provides access to a special type of interface called the Backstage view. This is where you will create and open databases, manage settings that apply to the entire database, access the Help Center, etc.

Project Manager and My Portal

The Project Manager allows you to manage the projects within the current database and, for many Synthesis applications, it also allows you to manage all of the folios, diagrams, reports, attachments, etc. in the currently open project(s). This panel is docked on the left side of the MDI and pinned by default. ("Pinned" means that the entire panel is always visible unless you decide to hide or "unpin" it.)

My Portal provides quick access to messages, assigned actions and other information that may be of personal interest to you while working in the Synthesis Platform. This panel is docked on the right side of the MDI and unpinned by default. ("Unpinned" means that only a small tab will be visible in the interface unless you move the pointer over the tab to make the entire panel visible.)

For both of these MDI features, you can decide whether the panel will be visible and how it will be positioned in the interface. (See Show, Tile, Dock and Pin Panels.)
Tip: If desired, you can change the overall color scheme used in the MDIs for all Synthesis desktop applications on your computer. Use the Skins drop-down list on the Synthesis Settings page of the Application Setup to select the style you prefer.

Status Bar
As an example, the following picture shows the status bar at the bottom of the MDI for an enterprise database:

For more information about the connection speed indicator, see Enterprise Repository Connection Speed.

If working with a Synthesis file, the status bar also displays a reminder that you will need to save any changes before closing.

Show, Tile, Dock and Pin Panels
In all Synthesis desktop applications, the MDI includes a Project Manager panel and a My Portal panel. You can decide whether each panel will be displayed and how it will be positioned in the interface at any given time.

Show or Hide
To show or hide the Project Manager panel, choose View > Project Manager and toggle the Show Project Manager command on or off.


You can also hide either panel by clicking the X at the top of the window.

Tile or View One Page at a Time
In all Synthesis desktop applications, My Portal consists of four pages. You have the option to view one page at a time (and use large buttons or small icons at the bottom of the panel to
switch between pages) or tile the pages so that more than one page can be visible at the same time. To specify your preference, choose **View > My Portal** and toggle the **Tile My Portal** command on or off.

When applicable, these same options are available for the Project Manager panel. Choose **View > Project Manager** and toggle the **Tile Project Manager** command on or off. (This command is not available in applications such as Xfmea, RCM++, RBI and MPC, which have only a single page in the Project Manager.)

As an example, the first picture shows the My Portal panel when it is not tiled. The second picture shows the tiled panel, with two of the four pages expanded to be visible at the same time.

![My Portal panel](image1)

When the panel is not tiled, you can drag the horizontal splitter bar up to display large buttons or down to display small icons.

![Splitter bar](image2)
When the panel is tiled, you can use the handle buttons to expand or collapse each page.

![Click to Expand]

**Dock or Float**

For both panels, you have the option to dock the panel on the left, right, top or bottom side of the MDI. When the panel is docked, it cannot be moved but you can change the width (if docked left or right) or height (if docked top or bottom) by dragging the edge to the desired position.

Alternatively, you can choose to float the panel as a window that can be resized and dragged to any location on the desktop.

There are several ways to set the docking position:

- Choose View > Project Manager > Dock Project Manager and then choose the desired option.

![Dock Project Manager]

The same options are available when you choose View > My Portal > Dock My Portal.

- If the panel is currently floating:
  - Double-click the window's title bar to return it to the most recent docked position.
  - OR
  - Click the window's title bar and drag it onto one of the location icons that become visible while you are moving the window. When the window is correctly positioned, blue shading will show where the window will be docked when you release the mouse button. (Note that the window's title bar must be exactly positioned above one of these location icons before the blue shading appears. If you don’t see blue shading, the panel will not be docked when you release the mouse button.)
If you prefer to float the window, you can:

- Choose either:
  - View > Project Manager > Dock Project Manager > Floating Project Manager
  or
- Double-click the title bar of the docked panel.
Pinned or Unpinned

When docked, both panels can also be toggled between pinned and unpinned states by clicking the pushpin icon in the panel's title bar. When the pushpin in the icon is vertical  ✅, the panel is pinned and will be displayed at all times.

When the pushpin is horizontal  ❌, the panel is unpinned. A tab will be displayed at the docking location for each unpinned panel.

The behavior for unpinned panels is as follows:

- If you point to the tab, the panel displays only until you point to something else.
- If you click the tab, the panel stays displayed until you click something else.
- When a panel is unpinned, it cannot be undocked or moved.

As an example, the following picture shows the Project Manager panel docked on the left side of the MDI, unpinned and hidden, while the My Portal panel is docked on the right side of the MDI, unpinned and visible (either because the user moved the pointer over or clicked the tab).
Project Manager

The Project Manager provides the tools you need to browse or search for a particular project or analysis folio in a Synthesis repository. Depending on the application, the Project Manager consists of either one or two pages:

- In all Synthesis desktop applications, the project list displays all the projects in the current database. (For Xfmea, RCM++, RBI and MPC, this is the only page available in the Project Manager).

- In Weibull++, ALTA, BlockSim, RENO, RGA and Lambda Predict, the Open Project(s) page of the Project Manager (i.e., the current project explorer) displays all the analysis folios, reports and other items in the current project(s) that apply to the software you are using.

There may be up to five nodes in the project list, indicating the sharing status of the projects: Private, Public or Reference projects, Locked projects and Checked Out projects. Additionally, the Recycle Bin is shown in the project list.

Each node may be further broken down by project category and/or by project owner. This ensures that projects will be organized in a logical, manageable way within the project list.

Opening a Project

To open an existing project, double-click the project name or select the project and choose Project > Management > Open Project.

Note: Remember that each project may contain items from any Synthesis application but you will see only the items that are relevant for the application you are currently working with (e.g., Weibull++ analysis folios are visible only when the project is opened in Weibull++). Common items, such as project attachments, are visible from all applications.

Filtering the List of Projects

The project list can utilize the same project filters that are available in many other locations throughout Synthesis desktop applications. For example, with the filter shown below, the project list will show only projects belonging to Department B.
Chapter 3: Desktop Application Interfaces

This feature might be particularly useful for an enterprise database that may be used to store analysis projects for the entire organization in a single centralized location. In such cases, the number of projects displayed in the project list could become overwhelming and these filters provide the ability to display only those projects that are of interest to you at any given time.

To remove the filter, select Show All from the drop-down list.

**Searching for a Particular Project**

You can also search for projects by entering text in the Find field. The project list updates dynamically to show only the projects with names that contain the text that you have entered. As an example, the following picture shows a quick way to find all of the projects for a particular product line by using the project names instead of predefined categories or other filter criteria.

![Project List Example](Image)

**Current Project Explorer**

In all Synthesis desktop applications except Xfmea, RCM++, RBI and MPC (which use the system hierarchy to manage all of the different analyses in a given project), the Open Project(s) page of the Project Manager allows you to manage all of the relevant *project items* (e.g., folios, diagrams, etc.) in the project(s) that are currently open.

Applications that use the current project explorer can have multiple projects open at the same time. (See Working with Multiple Projects.)

*Note:* Remember that each project may contain items from any Synthesis desktop application but you will see only the items that are relevant for the application you are currently working with (e.g., Weibull++ analysis folios are visible only when the project is opened in Weibull++). Common items, such as project attachments, are visible from all applications.
Filtering the Project Items
The current project explorer can utilize the same item filters that are now available in many other locations throughout Synthesis desktop applications. (This provides more flexibility than the Filter based on creator feature in prior versions.)

For example, with the filter shown below, the current project explorer will show only items created by Joe User and updated within the current month.

To remove the filter, select Show All from the drop-down list.

Opening Items
Double-click an item to open that item in the MDI or to bring that item to the front of the MDI if it is already open. (Note that if you double-click an attachment that appears in the current project explorer, it will open in its corresponding application, as long as that application is installed on your computer.)

Tip: In all Synthesis applications, projects can be shared by multiple users and the current project explorer may display an "in-use" icon to indicate the status of an item that can't be edited because it is currently locked or being edited by another user. (See Status Indicators.)

Adding Items
You can add items to the project by choosing the relevant command on the Insert tab of the ribbon. You can also right-click the relevant folder and choose an appropriate command on the shortcut menu that appears.
Chapter 3: Desktop Application Interfaces

**Editing, Renaming, Duplicating or Deleting Items**
To manage existing items within the project (i.e., *Edit Item*, *Rename Item*, *Duplicate Item* and *Delete Item*), right-click the item and choose a command from the shortcut menu or select the item and use the commands in the Current Item group on the Project tab of the ribbon.

**Sub-Folders and Drag and Drop**
In addition to the top-level folders that are fixed for each application, you also have the ability to create your own custom sub-folders to organize project items (the exception being the Attachments folder, which you cannot add sub-folders to). To add a custom sub-folder, right-click any existing folder and choose *Add Folder* on the shortcut menu.

You can also arrange custom sub-folders and project items by dragging them to the desired location. Dragging a folder or project item onto a folder will place it into the bottom of that folder. Dragging a folder or project item onto a project item will place it in the same level above that item.

**Working with Multiple Projects**
Synthesis desktop applications that use the current project explorer (i.e., Weibull++, ALTA, BlockSim, RENO, RGA and Lambda Predict) can have multiple projects open at the same time. To enable this functionality, select the *Allow multiple projects (project explorer)* check box on the *Synthesis Settings page* of the Application Setup.

*Tip:* There is a separate setting that controls the ability to have multiple projects open in Xfmea/RCM++/RBI.

When you have more than one project open, the projects will be shown in the current project explorer with the most recently opened project at the top. Note that the icon shown beside each project indicates whether it is a *public, private or reference project* and, when applicable, whether it is locked or checked out.

<table>
<thead>
<tr>
<th></th>
<th>Unlocked, Not Checked Out</th>
<th>Locked</th>
<th>Checked Out</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Public Project</strong></td>
<td>![Icon]</td>
<td>![Icon]</td>
<td>![Icon]</td>
</tr>
<tr>
<td><strong>Private Project</strong></td>
<td>![Icon]</td>
<td>![Icon]</td>
<td>![Icon]</td>
</tr>
<tr>
<td><strong>Reference Project</strong></td>
<td>![Icon]</td>
<td>![Icon]</td>
<td>N/A</td>
</tr>
</tbody>
</table>
In addition to the convenience of being able to view analyses from multiple projects, having multiple projects open allows you to transfer data between the projects quickly and easily. Specifically:

- For any item that can be imported/exported between projects, you can simply drag the item (analysis, multiplot, report, etc.) from the source project to the appropriate folder in the destination project. This opens the Export window, where you can just click Export to finish the export, or add more items to export before you finish the process.

- In Weibull++, ALTA and RGA, data can be copied from an analysis in one project and pasted to an analysis in another project.

- In BlockSim and RENO, blocks can be copied from a diagram in one project and pasted to a diagram in another project, according to the following rules:

  - If the block uses resources that are local to the source project, they will also be copied and added to the destination project.
    - If a resource of the same name exists in the destination project, the name of the copy will be incremented (e.g., if "Model1" already exists, the new copy might be renamed to "Model1_1").
    - If a model is associated with a data source (e.g., a model published from a Weibull++ folio), the model is copied into the destination project as a model with the association removed.
  - If the block uses resources that are global or in a reference project, they will not be duplicated. They will retain their original reference to that global/reference resource.
  - Subdiagram blocks cannot be copied and pasted across projects.

**Note:** The FMRA view is not available in BlockSim when you have multiple projects open.

### My Portal

In all Synthesis desktop applications, *My Portal* provides quick access to messages, assigned actions and other information that may be of personal interest to you while working in the Synthesis Platform. (When you first activate the software, My Portal will be "docked" on the right side of the MDI and "unpinned." Move your mouse pointer over the tab to make the panel visible at any time. For other options, see Show, Tile, Dock and Pin Panels.)
If your organization chooses to implement a web-based Synthesis Enterprise Portal (SEP) for an enterprise database, you can also access many of these same features – as well as selected metrics, reports and other details from specific analyses – from any web-enabled device.

**Portal Messages**
The Synthesis Platform’s messages feature provides a convenient way to communicate with other database users. Messages are displayed in a "timeline" format similar to social media websites like Facebook®.

These messages are displayed both in My Portal (in any Synthesis desktop application) and in the Synthesis Enterprise Portal (if it is implemented for your database).

All database users will be able to view their own messages. In a secure database, the following permissions are required to create, edit or delete messages:

- **Create portal messages** allows you to create new messages, and edit or delete the messages you have personally created.
- **Manage all portal messages** allows you to edit or delete any messages that are visible to you. This includes any message for which you are the creator or one of the recipients.

**Message Display Options**
The messages timeline will display all messages that were created by or addressed to you. You can sort the message threads in two ways:

- **Newest Active** considers the dates/times of both the main messages and the replies.
- **Newest Message** considers only the dates/times of the main messages.

**Create, Edit, Delete or Reply to Messages**
In Synthesis desktop applications, you can access the message commands from the My Portal tab of the ribbon, and by right-clicking inside the Messages page of the panel.
Note that the purpose of the **Refresh Messages** command is to update the display with any new messages that were recently added or changed by another database user.

**Message Recipients**
You can specify whether a message will be visible to all database users or only to specific users or groups. If you select Selected Groups/Users, you can choose from two lists: user groups that have been predefined in the database and/or individual user accounts.

If a valid SMTP server has been defined for the database, you can select the **Also send this via e-mail** check box to send an e-mail copy of the message to the recipient(s). (See [Enable Alerts via E-mail or SMS](#).)

**Actions in My Portal**
Throughout the Synthesis Platform, your team can use actions to track specific assignments that need to be performed. These versatile Synthesis resources can be used multiple times in different locations, if appropriate. This may include actions in Project Plans, FMEAs or Test Plans, as well as actions that are independent of any particular analysis or plan.

This topic discusses how to view and manage actions via My Portal (in any Synthesis desktop application). If you want to view/manage all action records, see [Actions Explorer](#) or [Resource Manager](#). For information about the action properties and other general considerations that apply wherever the action may be used, see [Action Resources](#).

**Actions Displayed in My Portal**
The Actions page in [My Portal](#) (and in the [Synthesis Enterprise Portal](#)) display action records that:

- Need to be reviewed by you.
Chapter 3: Desktop Application Interfaces

- Are relevant to you in some way and are:
  - **Past Due** – the completion date has passed.
  - **Due Next 7 Days** – the completion date occurs within the next 7 days.
  - **Past Start Date** – the start date has passed.
  - **Start Today** – the start date is today.
  - **Start Tomorrow** – the start date is tomorrow.
  - **Start Next 7 Days** – the start date occurs within the next 7 days.
  - **In Progress** – the actual start date has been entered and the action is not yet "Past Due" or "Due Next 7 Days."

If the action is not used in the [Project Planner](http://xfmea.reliasoft.com), this will be based on the *planned* start/completion dates. But if the action is used in a plan, it’s based on the *expected* dates (which can shift automatically if there are recorded delays in prior gates/actions).

Also note that if an action fits under more than one heading, it will display under the more urgent one. For example, if the action is both due in the next 7 days and past the planned start date, it will show under "Due Next 7 Days."

**Create, Edit or Delete Actions from My Portal**

In Synthesis desktop applications, you can access the portal actions commands from the [My Portal](http://xfmea.reliasoft.com) tab of the ribbon, and by right-clicking inside the [Actions](http://xfmea.reliasoft.com) page of the panel.

![Actions Menu](http://xfmea.reliasoft.com)

*Tip:* If an action doesn’t fit the My Portal display criteria for your computer/username (see details below), the new record won’t be displayed in your portal after you create or edit it. In such cases, you can use the [Actions Explorer](http://xfmea.reliasoft.com) or [Resource Manager](http://xfmea.reliasoft.com) to access the record.
Add to Outlook Calendar
The Add to Outlook Calendar command will be enabled if Microsoft Outlook is installed on your computer.

It launches Outlook’s interface for creating a new calendar event and automatically populates the subject and date. You can modify the details as needed before saving the new event to your calendar.

Note that you may need to give focus to the Outlook application in order to see the window.

Refresh Actions
The Refresh Actions command updates the display with any new actions that were recently added or changed by another database user.

Action Display Settings
To specify your personal preferences for displaying actions in My Portal (stored per computer/username), right-click inside the panel and choose Action Display Settings.

If you select the Display ‘Show Actions’ labels in portal check box, the panel will also include headings that indicate how the action is relevant to you:

- **I am responsible for**
  - You are assigned in the Person Responsible field.

- **I am a team member in**
  - You belong to the team assigned in the Team field.

- **I need to review/approve**
  - You are assigned in the Reviewer field.

- **I am monitoring**
  - You are assigned in the Action Monitors window, or you have personally subscribed to “watch” the action.

- **Other actions I created**
  - You are listed in the Created By field and none of the other roles apply.
Finally, you can choose to **Sort by Start Date** or **Sort by Due Date** within each node of the display.

**Action Explorer**
The *Actions Explorer* command opens a flexibility utility that allows you to explore all of the action resources that are stored in the current database. You can use it to filter, sort, add, edit or delete actions. (See *Actions Explorer*.)

Note that when you return to the Actions page in My Portal, you will need to use the **Refresh Actions** command to view any changes.

**Repository Users List**
The repository users list shows all active user accounts in the database, and identifies which of those users are currently connected to the database with any of the Synthesis applications.

This list is displayed both in *My Portal* (in any Synthesis desktop application) and in the *Synthesis Enterprise Portal* (if it is implemented for your database).

In Synthesis desktop applications, you can access the users list commands from the *My Portal* tab of the ribbon, and by right-clicking inside the *Users* page of the panel. Similar commands are available in the web-based Synthesis Enterprise Portal, if applicable.
My Profile opens the User Login and Contact Information window, which allows you to edit the contact information associated with your user account.

Refresh Users updates the list to reflect any recent changes in user activity.

**Project Plan Summary in My Portal**

In all Synthesis desktop applications except MPC, the Project Plan Summary page in My Portal provides a summary of the plan for the current project, if applicable.

The summary in My Portal always reflects the entire plan for the current project, based on the actual date/time from your computer. If you want to see the summary for a particular gate or action, or to estimate what the statuses would be for a different date, you must use the Project Planner window.

- Choose Project > Management > Project Planner.

- Click the link in the project name bar at the top of the summary in My Portal.
How to Read the Summary

The plan summary in My Portal provides the following information at-a-glance. (For details, see Project Plan Summary Panel.)

<table>
<thead>
<tr>
<th>Project Current Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto</td>
</tr>
</tbody>
</table>

By default, this shows the current date, which is used to determine the status (e.g., "Missed Start Date"), resource usage to date, etc.

Use Refresh to obtain the latest information from the Project Planner.

<table>
<thead>
<tr>
<th>FMEA (Chandelier)</th>
</tr>
</thead>
<tbody>
<tr>
<td>EXPECTED 3/23/2015 4/10/2015</td>
</tr>
<tr>
<td>ACTUAL 3/23/2015 -</td>
</tr>
</tbody>
</table>

The top bar displays name of the project that the summary applies to. Click the link to open the project in the Project Planner.

The next two rows show the expected dates and any actual dates, and the last row shows the status.

<table>
<thead>
<tr>
<th>Progress</th>
</tr>
</thead>
<tbody>
<tr>
<td>In Progress 33%</td>
</tr>
</tbody>
</table>

This is the percentage of the total duration of dependent actions/gates that is complete. For example, if Action 1 (duration = 3 days) is complete and Action 2 (duration = 1 day) is incomplete, the progress is 75%.

<table>
<thead>
<tr>
<th>Resource Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Man Hours Planned: 112.0</td>
</tr>
<tr>
<td>Costs Planned: $5,500.00</td>
</tr>
</tbody>
</table>

For resource usage, the black bars show the planned man hours and costs. The colored bars show either the expected usage to date (estimated based on the number of days in progress), or the actual usage if complete. (See Costs and Man Hours.)

- Yellow = In progress and usage to date is still within plan
- Orange = In progress and usage to date has exceeded plan
- Green = Complete and actual usage was within plan
- Red = Complete and actual usage exceeded plan
Displays only if actions have been assigned to the project or gate (either directly or via dependent gates).

- **Not Started** = Actions that have not started and can complete on time
- **In Progress** = Actions that are in progress and can complete on time
- **Completed** = Completed actions that have been approved, or don't require approval
- **Past Due** = Actions that have not completed and can no longer complete on time

**Folios**

**Data Sheets**
The data sheets in Weibull++/ALTA and RGA folios share some common components and features. The following picture shows the basic components of a data sheet using one particular format as an example.
• **Caption** shows the name of the folio and the name of the sheet that is currently displayed.

• **Name Box** shows the location of the currently selected cell by listing the column letter and row number that intersect at the cell's location.

• **Data Entry Bar** shows the contents of the selected cell, which may be text, a numerical value or a formula. For text or numerical values, you can enter/edit the information directly inside the cell or inside the data entry bar. For a formula, you must use the data entry bar for editing; the cell will display only the calculated value.

• **Row Headings** identify the row numbers. Each data sheet contains up to 65,536 rows. The application's speed of execution is inversely proportional to the number of data rows in the current data set.

• **Column Headings** indicate the titles of the columns. To rename a heading, right-click it and choose **Rename Column**. When applicable, you can save the column titles and use them as the default headings for all new data sheets of the current type. (See **Default Column Headings**.)

• **Sheet Tabs** represent the different sheets within the folio. To rename a sheet, double-click the tab. The number of folios that can be opened at once depends on the amount of memory of your system (up to a maximum of 256 for some folio types).

**Default Column Headings**
In life data (Weibull++), life-stress (ALTA) and growth data (RGA) folios, creating a new data sheet automatically applies default column headings that are generally appropriate for the...
analysis. If there are certain types of data that you frequently use (e.g., miles-to-failure, cycles-
to-failure, etc.), you can customize the column headings to always use your preferred column
titles.

To modify the defaults for a particular data type, first rename the column headings in an
existing data sheet. Right-click the heading and choose Rename Column on the shortcut menu.
Then save the new titles as the defaults. In Weibull++, choose Life Data > Format and View >
Set Headers as Default. (In ALTA, the command is in the Life-Stress Data tab; in RGA, it's in the
Growth tab.)

These preferences are saved for the current computer/username, and will be applied the next
time you create a new data sheet for that particular data type.

To apply the new default headings to an existing analysis, open the data sheet and choose [Life
Data/Life-Stress Data/Growth Data] > Format and View > Apply Default Headers.

If you ever need to restore the default column headings back to the shipped settings, choose
File > Application Setup, then click Reset Application Settings or Reset All Settings on the Reset
Settings page.

Resizing Columns
Column widths are set to span evenly by default. If you want to resize and have the changes
saved with the folio, right-click a column heading and choose Column Width Style > Default.

To resize a column, drag the edge of the heading to the desired position, or right-click it and
choose Column Width.

Entering Formulas in the Data Sheet
Data sheets in Weibull++, ALTA and RGA allow you to enter formulas in columns that do not
require entries to be dates, times or text (e.g., you cannot use formulas in the State F or S
column in a Weibull++ life data folio, or in the Classification column in an RGA growth data
folio). For example, in a Weibull++ life data folio, if you have a data set where the units were
inspected every 24 hours, you can speed up data entry by creating a formula to add 24 hours to
the previous inspection time, as shown next.
There are two types of cell references (locations) when inputting a formula: absolute and relative. By default, the cell reference is relative, meaning that as a formula is copied and pasted to other cells, the cell references in the formula will be adjusted to reflect the new relative location. In the previous figure, the formula in cell C2 is copied and pasted into cell C4. This changes the cell reference in the formula from "=C1+24" to "=C3+24"; therefore, the time value in C4 is 72+24 = 96.

In contrast, an absolute reference does not change when the formula is copied to other cells. Absolute references are designated by placing a dollar sign ($) in front of the row and/or column to be made absolute. If the formula in the example were rewritten to "=$C$1+24", then copying the formula to cell C4 would retain the cell reference to C1 and the time value in C4 would be 24+24 = 48.

## Change Units

In Weibull++, ALTA and RGA, you have the ability to define the time units used for the data set and calculations. For example, if your data set contains failure times in hours, you now have the option to perform calculations using different time units such as years, months, days, etc. The software performs the unit conversion automatically. Authorized users can define the time units that will be available for use in any project within the database and set up the conversion factors.

The units are displayed in the heading of the relevant column in the data sheet. If you wish to change the time units of an existing data sheet, click the **Change Units** icon on the Main page of the control panel.

In the Change Units window, the units that are currently being used in the data sheet will be displayed at the top of the window. In the **Change Units To** field, you can choose any other
defined time unit to be used in the data sheet. In the **Conversion Options** area, specify what will happen when the units are changed:

- You can convert the existing data to the new units. For example, if you had a time of 10 in a data sheet that was using hours, that time would become 600 if you converted the data to minutes (10 hours x 60 minutes per hour = 600 minutes). For Weibull++ life data, ALTA life-stress data and RGA growth data folios, when this option is selected, you can select whether you want to copy the data to a new sheet in the folio and then perform the conversion, leaving the original data sheet unchanged, or convert the data in the current sheet.

- You can leave the data unchanged and just apply the new units. This would be appropriate if, for example, you had entered all of your data and then realized that the data sheet was using different units from the original units in which the times were measured.

**General Spreadsheets**

General Spreadsheets can be inserted into a Weibull++ life data folio, ALTA life-stress data folio or RGA growth data folio. They provide the same spreadsheet capabilities that are available in the spreadsheet module in *Synthesis Workbooks*, but are stored together with an analysis folio. You may prefer to use this reporting tool if you are performing custom calculations based on the data sheets in the same folio and you wish to keep the analyses together with their source data.

To add a General Spreadsheet to a folio, right-click the data sheet tab area (the area at the bottom of the window that shows the name of the data sheets in the folio) and choose **Insert General Spreadsheet** on the shortcut menu. This command also appears on the ribbon tab for the particular type of data folio. For example, to insert a general spreadsheet into a Weibull++ life data folio, you can choose **Life Data > Folio Sheets > Insert General Spreadsheet**.

**Inserting Data Source Functions**

To build and insert functions that utilize a referenced analysis (data source), click a cell in the general spreadsheet and choose **Sheet > Sheet Actions > Function Wizard**.
Chapter 3: Desktop Application Interfaces

The following picture shows the most complex configuration as an example:

For the function arguments:

- Brackets [ ] indicate that the input is optional.
- You can use cell references as inputs. For example, instead of entering 1000 for the Age input, you could specify to use whatever time is currently entered into cell A10, using either the relative reference (A10) or the absolute reference ($A$10). (See Cell References.)
- You can also use variable names as inputs. (See Defined Names.)

For the data source:

- Click the Select button and then select which data sheet in the folio to use as the data source.
- Any time you make changes to the data source, the general spreadsheet will need to be recalculated to reflect the most current results. Choose Sheet > Format and View > More Settings > Recalculate Formulas. The general spreadsheet may return "N/C" if the data source needs to be recalculated.
Inserting Math Functions
To add math, date, logic and other functions, click a cell in the general spreadsheet and choose Sheet > Sheet Actions > Insert Function.

Select a function from the drop-down list and click OK. You can enter inputs for the function arguments by either selecting the cells in the sheet or typing them directly into the appropriate field.

Referencing a Data Source
Some functions (e.g., AMEAN, D_COUNT, etc.) require you to reference a particular data source.

To reference a data source, use the following syntax, with the quotes and exclamation marks (!). You can only reference sheets in the same folio.

"Application!Folio!DataSheet"

In the following example, the data source is a data sheet called "Data1" in the Weibull++ folio called "Folio1".

Control Panels
Many of the analysis folios, diagram sheets and other interfaces in Synthesis desktop applications utilize a control panel that allows you to make required inputs, initiate the desired analysis or simulation and view/access applicable results. This topic describes some features that are common to most control panels. (For Xfmea, RCM++, RBI, MPC and Lambda Predict, see System Panel and Analysis panel instead.)
Switching Between Pages

Many control panels and navigation panels contain multiple pages that vary depending on the type of analysis. You can switch between pages by clicking either the large buttons or the small icons at the bottom of the panel.

If you drag the horizontal splitter bar to the bottom of the control panel, all of the pages will be accessed by small icons. If you drag it as far up as it will go, all of the pages will be accessed by large buttons.

Hiding or Displaying a Control Panel

The control panel can be toggled between hidden and displayed states by clicking the Hide or Show icon in its title bar.

When the control panel is hidden, only the title bar and page icons will be visible on the right side of the window (as shown next using a Weibull++ folio as an example). When you click the bar, the active page will be displayed temporarily. When you click anywhere outside of the control panel page, it will be automatically hidden again.
Identifiers Page
The Identifiers page of the control panel allows you to enter identifying details (e.g., category, name, part number, etc.) that will be associated with the analysis and any models or SEP summaries that are published from the analysis. This will help you to find, filter and group analyses and resources throughout the repository.

In folios that can have multiple data sheets, the Folio Identifiers are edited via the Item Properties window, and the Data Sheet Identifiers can be entered directly in the control panel. Use an asterisk (*) if you want the data sheet’s identifiers to be the same as the folio’s (see Synthesis Identifiers).

Publishing Page
The Publishing page allows you to view and manage information from the current analysis that is shared throughout the Synthesis Platform.

- **Model/Fitted Model** – publishes a model based on the current analysis. See Publishing Models.
Chapter 3: Desktop Application Interfaces

- **SEP Summary** – publishes a summary of the current analysis to the Synthesis Enterprise portal website. This is visible only if the enterprise database is configured for SEP and you have the "Publish to Synthesis Enterprise Portal" permission. See [Publishing to SEP](http://xfmea.reliasoft.com).

- **Metrics** – shows all of the metric resources that are associated with the current analysis. See [Showing Metrics in Folios/Diagrams](http://xfmea.reliasoft.com).

**Notifications Page**

When applicable, the Notifications page provides information on the **Current Status** of the analysis, along with any warnings or errors. A green light indicates that the folio has been analyzed, and a red light indicates that the folio has not been analyzed since changes were last made. The **Latest Notifications** area displays any warnings and errors generated during analysis.

![](image)

**Utilized Resources Page**

In BlockSim only, the Utilized Resources page displays a grouped list of all of the **resources** that are used directly by blocks in the diagram (i.e., not applied via any other resource or tool).

For example, a **URD** that is assigned to a block will be displayed in this list, but the **model** assigned to the URD will not be shown, nor will any **tasks** assigned to the URD. Similarly, if a block belongs to a maintenance group, that maintenance group will be shown in the list. However, if a block has a state change trigger, the maintenance group(s) used for that trigger will not be shown unless some block in the diagram belongs to them.

This list is not updated automatically; if you have made changes to the diagram, click the **Refresh** icon to update the list.
Double-click a resource in the list to open its properties window for viewing or editing. Click the 
Resource Manager icon to view/manage all of the resources available in the project.

System Panel and Analysis Panel

Some Synthesis applications use two convenient panels to manage all of the analysis information in a particular project (Xfmea, RCM++, RBI and MPC) or in a particular prediction folio within the project (Lambda Predict).

The first panel (called the System panel or the System Hierarchy panel) allows you to build simple or complex multi-level configurations that contain the items you plan to analyze. The second panel (called the Analysis panel or the Properties panel) contains all of the properties and analyses for the item that is currently selected.

This topic discusses the ways in which you can configure the layout of these two panels to fit your particular workspace preferences.

Change Orientation

You can display the panels side-by-side or with one panel above the other.

To switch between layouts, choose View > Workspace Layout > Change Orientation.

Resize a Panel

You can resize the panels by dragging and dropping the vertical (or horizontal) separator into the desired position.
Hide a Panel
You can also completely hide either panel so that the other can fill the available space. Choose View > Workspace Layout > Hide [System Panel/System Hierarchy] or [Analysis Panel/Properties].

When you wish to return to the two-panel layout, choose the Split Panels command.

Expand or Collapse Nodes
When the panel presents data in a hierarchical tree configuration (e.g., the system hierarchy, FMEA hierarchy, etc.), the View tab provides several flexible options for expanding and collapsing the nodes (branches) that are currently displayed.

To expand or collapse all branches at the same time, choose Expand Tree or Collapse Tree.

To expand or collapse a specific branch, you can click the + or - icons, or select the item and choose Expand Node or Collapse Node.

To collapse all branches in the tree to a specific level, select any item at the desired level and choose Collapse to Level.

As an example, the following pictures show how the hierarchy collapses to the second (subsystem) level.
Selecting Which Columns to Display
When applicable, you can hide, display or reorder the columns shown in a particular type of hierarchy by right-clicking any column heading and choosing Customize Columns. These settings are stored per computer/username, and different users may have different display preferences without affecting the stored data. The same preferences can also be managed from the relevant page of the Application Setup.

Printing
Synthesis desktop applications use different windows (Print, Page Setup and Print Preview) for different types of features.

- Printing Plots and Diagrams
- Printing Data Sheets and Synthesis Workbooks

When a report is generated in Microsoft Word or Microsoft Excel (Xfmea, RCM++, RBI, MPC and Lambda Predict), you will need to use the utilities built in to those applications.

Printing a plot from within RS Draw uses the commands specific to it.

Plots and Diagrams
To print a plot in Xfmea, RCM++, RBI or Lambda Predict, click the Print icon on the plot control panel. To print a diagram in Xfmea, RCM++ or RBI, or a diagram or plot in Weibull++, ALTA, BlockSim, RENO or RGA, choose Home > Print > Print.

Specify the properties, then print the plot or diagram.

When printing a plot, you can open the Print Preview window to preview the plot before sending it to the printer. Closing the Print Preview window will return you to the plot, not the Print window.

Printing Diagrams in BlockSim
When printing a diagram in BlockSim, you must first choose whether to print only the Current diagram (and possibly its subdiagrams on separate pages) or Choose Multiple diagrams from the current project to print.
Considerations for Printing Plots

- In Xfmea/RCM++/RBI and Lambda Predict, when printing Pareto (bar) charts or matrix charts, set the orientation of the printed page to landscape for best results. When the orientation is set to portrait, the chart may appear stretched.

- When printing pie charts with the orientation set to portrait, the pie details, legend and user information may be cut off on the printed page because the chart is too wide to fit the page. If this occurs, change the orientation to landscape or use the Plot Setup window to remove the details or the legend/user information from the plot.

Print Preview - Plots and Diagrams

To preview how a plot or diagram will look on the printed page before printing it, click Preview in the Print window; click the Print Preview icon on the plot control panel or choose Home > Print > Print Preview.

Use the toolbar icons to set how many pages to display. You can open the Page Setup window to specify the printing options.

Print Layout

For diagrams in Weibull++, ALTA, BlockSim, RENO, Xfmea, RCM++ and RBI, the Print Layout option allows you to view how a diagram will appear on the printed page. The page orientation (i.e., portrait or landscape) depends on the orientation selected in the Page Setup window. To display the page boundary lines, choose Home > Print > Print Layout.

Everything within the boundary lines will appear on the printed page. Use this to make any necessary adjustments before printing the diagram.

To exit the print layout mode, choose Home > Print > Print Layout.

Page Setup - Plots and Diagrams

The Page Setup window allows you to make selections for how the page(s) will be printed. You can open it from the Print Preview window. For diagrams and plots in Weibull++, ALTA, BlockSim, RENO and RGA, or a diagram in Xfmea, RCM++ or RBI, you can also choose Home > Print > Page Setup.
Page Tab
Use the Page tab to set the layout, scaling and other options.

Margins Tab
Use the Margins tab to set the margins.

Use the Units drop-down list to specify the units in which the margins will be printed. The options are System's default (which uses the units used by your computer), Inches or Centimeters.

Header/Footer Tab
Use the Header/Footer tab to set the header and footer formats.

Use the toolbar on the tab to quickly insert common format codes into the selected section of the header or footer.

Header/Footer Format Codes - Plots and Diagrams
Use these format codes for printing the headers and footers in plots and diagrams.

By default, text will be centered in the headers/footers unless otherwise specified. Please note that the alignment codes (i.e., &L, &C, &R) restart each format code section. For example, in the format code &L&P &R&ZI, the page number will be left aligned and the sheet name will be right aligned. Unless otherwise stated, all format codes can be used by all items.

<table>
<thead>
<tr>
<th>Format Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;L</td>
<td>Left aligns the item.</td>
</tr>
<tr>
<td>&amp;C</td>
<td>Center aligns the item.</td>
</tr>
<tr>
<td>&amp;R</td>
<td>Right aligns the item.</td>
</tr>
<tr>
<td>&amp;A</td>
<td>Prints the sheet name. (For plots in Xfmea, RCM++, RBI and Lambda Predict, nothing is printed.)</td>
</tr>
<tr>
<td>&amp;D</td>
<td>Prints the current date.</td>
</tr>
<tr>
<td>&amp;T</td>
<td>Prints the current time.</td>
</tr>
<tr>
<td>&amp;P</td>
<td>Prints the page number.</td>
</tr>
<tr>
<td>&amp;P+number (e.g., &amp;P+2)</td>
<td>Prints the page number plus the specified number.</td>
</tr>
<tr>
<td>------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>&amp;P-number (e.g., &amp;P-2)</td>
<td>Prints the page number minus the specified number.</td>
</tr>
<tr>
<td>&amp; &amp;</td>
<td>Prints an ampersand.</td>
</tr>
<tr>
<td>&amp;N</td>
<td>Prints the total number of pages.</td>
</tr>
<tr>
<td>&amp;ZA</td>
<td>Prints the name of the application (e.g., Weibull++).</td>
</tr>
<tr>
<td>&amp;ZC</td>
<td>Prints the company name.</td>
</tr>
<tr>
<td>&amp;ZU</td>
<td>Prints the user name.</td>
</tr>
<tr>
<td>&amp;ZP</td>
<td>Prints the project name.</td>
</tr>
<tr>
<td>&amp;ZI</td>
<td>Prints the name of the item.</td>
</tr>
<tr>
<td></td>
<td>(For plots in Xfmea, RCM++, RBI and Lambda Predict, nothing is printed.)</td>
</tr>
<tr>
<td>&amp;ZL</td>
<td>Print the path to the current repository.</td>
</tr>
</tbody>
</table>

Data Sheets and Synthesis Workbooks

To print a data sheet in Weibull++, ALTA or RGA, choose **Home > Print > Print**. To print a Synthesis Workbook in Weibull++, ALTA, BlockSim, RENO or RGA, choose **Print > Print in the Preview window**.

Specify the properties, then print the data sheet or Synthesis Workbook.

Print Preview - Data Sheets and Synthesis Workbooks

To preview how a data sheet will look on the printed page before printing it, choose **Home > Print > Print Preview**. For Synthesis Workbooks, choose **View > Print > Print Preview**.
You can open the Page Setup window to specify the printing options.

**Page Setup - Data Sheets and Synthesis Workbooks**
The Page Setup window allows you to make selections for how the page(s) will be printed. For data sheets, you can open it either from the Print Preview window or by choosing Home > Print > Page Setup. For Synthesis Workbooks, choose View > Print > Page Setup.

**Spreadsheet Module**

**Page Tab**
Use the Page tab to set the orientation, scaling and other printer options.

**Margins Tab**
Use the Margins tab to set the margins.

**Header/Footer Tab**
Use the Header/Footer tab to set the header and footer formats.

Click Custom Header/Footer to open the Header/Footer window and define the format - use the specific format codes for data sheets and Synthesis Workbooks. If you choose to use different values for the first page and/or for odd and even pages, the window includes separate tabs where you define the individual formats.

**Sheet Tab**
Use the Sheet tab to specify how the pages will print and in what order they will print.

If desired, use the Print area field to limit the printed material to either a selected cell range or to a defined name.

**Word Processing Module**

**Margins Tab**
Use the Margins tab to set the margins.

**Paper Tab**
Use the Paper tab to set the paper size.
Chapter 3: Desktop Application Interfaces

**Layout Tab**

Use the Layout tab to see the header and footer options.

**Header/Footer Format Codes - Data Sheets and Synthesis Workbooks**

Use these format codes for printing the headers and footers in data sheets and Synthesis Workbooks.

<table>
<thead>
<tr>
<th>Format Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;[Page]</td>
<td>Prints the page number.</td>
</tr>
<tr>
<td>&amp;[Pages]</td>
<td>Prints the number of pages.</td>
</tr>
<tr>
<td>&amp;[Date]</td>
<td>Prints the date.</td>
</tr>
<tr>
<td>&amp;[Time]</td>
<td>Prints the time.</td>
</tr>
<tr>
<td>&amp;[Path][File]</td>
<td>Prints the file path.</td>
</tr>
<tr>
<td>&amp;[File]</td>
<td>Prints the file name.</td>
</tr>
<tr>
<td>&amp;[Tab]</td>
<td>Prints the sheet name.</td>
</tr>
<tr>
<td>&amp;[Picture]</td>
<td>Prints a selected picture.</td>
</tr>
<tr>
<td></td>
<td>Click the Format Picture icon on the Header/Footer window to set the image size and other properties.</td>
</tr>
</tbody>
</table>
Chapter 4: Xfmea, RCM++ and RBI Ribbons

In Synthesis desktop applications, the *ribbon* replaces the toolbars and menus used in older software. The ribbon is divided into tabs that relate to a task or activity, such as managing the projects in a database or performing a specific type of analysis. Depending on the current activity, some commands may appear dimmed or will not appear at all.

Note that many features in the application also have a shortcut menu (accessed by right-clicking) that gives access to commands that are commonly used for that feature. All commands available in the shortcut menus are also available on the ribbon. In addition, the ribbon includes a customizable **Quick Access Toolbar** that allows you to display frequently used commands.

**Tip:** To maximize your workspace, you can choose to automatically minimize the ribbon and display only the tab names. To do this, click the arrow on the right-side of the ribbon (labeled "Minimize Ribbon" in the picture below). The ribbon will be expanded when you click a tab and then minimized after you click a command.

**Quick Access Toolbar**

The Quick Access Toolbar is a customizable feature of the ribbon that allows you to access frequently used commands without changing the tabs.

- To add your favorite commands to the Quick Access Toolbar, right-click the command on the ribbon and select **Add to Quick Access Toolbar**.

- To remove a command from the toolbar, right-click the command on the ribbon or on the Quick Access Toolbar and select **Remove from Quick Access Toolbar**.

- Right-clicking anywhere within the Quick Access Toolbar also gives you the following commands:
Chapter 4: Xfmea, RCM++ and RBI Ribbons

- **Show Quick Access Toolbar Below the Ribbon** or **Show Quick Access Toolbar Above the Ribbon**. The command that appears depends on where the toolbar is currently displayed on the ribbon.

- **Minimize the Ribbon** maximizes your workspace by allowing you to display only the tab names on the ribbon. The ribbon will be expanded when you click a tab and then minimized after you click a command. To keep the ribbon always expanded, clear the check box.

**Backstage View (File Tab)**

The *Backstage view* (File tab) is the first view you will see when you start a Synthesis desktop application. This topic provides a summary of the commands available in the *Tab Pane* on the left side. For information about the right side, see ReliaSoft Online Pane.

**Save** (available only when a Synthesis file is currently open) saves all recent changes to the Synthesis file (*.rsf11). This command is not applicable in a standard or enterprise database, because the changes are saved automatically as you work.

**Save As** (available only when a standard database or Synthesis file is currently open) saves a copy of the standard database or Synthesis file to another pathname/filename and/or file type. You can save the file as a new standard database (*.rsr11), Synthesis file (*.rsf11) or compressed standard database (*.rsgz11).

**Pack and E-mail** (available only when a standard database or Synthesis file is currently open) sends a compressed version of the standard database or Synthesis file via e-mail.

**Open Repository** opens an existing standard database (*.rsr11), enterprise database (*.rserp), Synthesis file (*.rsf11) or a compressed standard database (*.rsgz11).

**Close Repository** closes the database. You also can close the database by opening another database or by exiting the application.

**Recent** shows a list of recently opened database files (*.rsr11, *.rserp and *.rsf11) and a list of recently accessed locations. Clicking a database will open it, and clicking a location will allow you to browse for databases in that location. The number of items in these lists is set in the *Synthesis Settings page* of the Application Setup. You can pin items to a list by clicking the pushpin icon associated with the item; when the pin is vertical, the item will not roll off the list.
New allows you to create a new standard database (*.rsr11), Synthesis file (*.rsf11) or connection file for access to an enterprise database (*.rserp).

Launch Application provides quick launch icons for other Synthesis desktop applications that are installed on your computer. If you are currently connected to a database when you click one of these icons, the same database will be opened automatically in the new application.

Manage Repository provides a variety of tools and configurable settings for the repository. The settings are shared by all users and all analysis projects in a database.

Help Center provides a variety of resources to help you use the application more effectively. In addition, the Help Center displays information about the application, including the Compile Release Version (CRV) and License information.

Application Setup allows you to set your personal preferences for working with analyses, such as the math precision, default plot settings and the like. The settings apply only to the current computer/username, and they do not affect the results of the analyses.

Exit closes the current database (if any) and shuts down the application.

Manage Repository
The Manage Repository section of the Backstage View contains the following commands. The available commands depend on the current application and the database type.

Users

Users and Security controls which users can access the repository and their permissions.

User Groups create and manage groups of users that can be assigned to actions, messages, etc. throughout the current database.

Repository Logins displays a list of users who have connected to the repository and allows you to export this information to Excel.

Reset "In Use" Flags allows you to reset the flags that indicate the "in use" status of projects or items within a project.
Lambda Predict Repository Settings
Available only in Lambda Predict:

- **FIDES Settings Manager** defines the settings related to the FIDES prediction standard such as process audits, pi factors, categories, etc. (See FIDES Settings Manager in the Lambda Predict documentation.)

- **Custom Derating Standards Manager** allows you to add, edit, delete or import/export custom derating standards. (See Creating Custom Derating Standards in the Lambda Predict documentation.)

- **MIL-217 Custom Connections** defines custom connection types for use with the MIL-HDBK-217F prediction standard. (See MIL-217 Custom Connection Types in the Lambda Predict documentation.)

Xfmea/RCM++/RBI Libraries
Available only in Xfmea, RCM++ and RBI:

- **Profiles/Library Manager** configures the predefined settings of the profiles stored in the software library. Profiles allow you to customize the look, drop-down lists, rating scales and other settings of a particular project in order to fit the needs of the analysis. (See Profiles/Library Manager in the Xfmea/RCM++/RBI documentation.)

- **Templates Manager** allows you to manage the configurable templates that can be used for customized reports, saved queries or importing/exporting data via Excel. (See Templates Manager in the Xfmea/RCM++/RBI documentation.)

Settings and Predefined Options

- **Repository Settings** allows you to enable alerts via e-mail or SMS, activate history logs, and other settings.

- **Time and Usage Units** defines the time units that will be available for use in any project within the database. This allows users to work with time-based inputs and results in the units that are appropriate for the situation.

- **Project/Item Categories** defines the categories that can be used to filter and group data throughout the database.

- **Default Name Formats** (not applicable for MPC) specifies the default names for new Synthesis resources, as well as new blocks in BlockSim RBDs, fault trees and phase diagrams.
**Project Planning Resources** (not applicable for MPC) defines the cost categories, teams, materials and facilities that are used for tracking costs, man hours and resource utilization in actions and Project Planner gates.

**Working Days/Holidays** (not applicable for MPC) specifies the business days when project planning resources can be utilized.

**Dashboard Layout Manager** (not applicable for MPC) shows all of the predefined dashboard layouts that will be available for any Synthesis user to view for a particular data set.

**Task Types** (applicable only in RCM++, RBI and MPC) maps the task types used in RCM++ and RBI (e.g., Restoration, Failure Finding, etc.) to the corresponding task classes in the universal reliability definition (e.g., Preventive, Inspection, etc.) so that simulation and cost calculation results are accurate. (See Task Types in RCM++/RBI in the Xfmea/RCM++/RBI documentation.) In MPC, it allows you to modify the abbreviations used for the MSG-3 task types. (See Task Type Abbreviations in MPC in the MPC documentation.)

**XFRACAS Connection** is available only for standard databases (*.rsr11) or Synthesis files (*.rsf11) in Weibull++/ALTA, RGA, and Xfmea/RCM++/RBI. It allows you to define connection settings for an enterprise repository.

### Database Tools

**New Enterprise Repository** opens a wizard that leads you through the steps to create a new enterprise repository (SQL Server or Oracle database). To use this option, you must have access to a server with a supported version of SQL Server or Oracle and you must have the appropriate permissions to create a new database on the server.

**Upgrade Version 9/10 Repository** converts an existing Version 9 or Version 10 enterprise database to a Version 11 enterprise database. *This cannot be undone*. It is recommended that you create a backup of the Version 9/10 database before performing the upgrade.

**Upgrade Version 8 Repository** copies all of the existing data from a Version 8 enterprise database to a new Version 11 enterprise database.

**Restore Points** manages all of the project backups that are stored in the current database.
**ReliaSoft Online Pane**

On the *Backstage view*, the area on the right side is called the *ReliaSoft Online Pane*. There are three pages available in this pane, accessed by the icons at the top of the pane:

- The **ReliaSoft Online Home** page displays software tips, announcements and upcoming training seminars for this application.
- The **Latest News** page displays recent announcements about ReliaSoft’s reliability software and services.
- The **Synthesis Platform** page displays tips and announcements related to the entire Synthesis Platform.

Note that an active Internet connection is required to see this information.

This pane can be hidden by clearing the **Display ReliaSoft Online pane** check box on the *Synthesis Settings page* of the Application Setup.

**Help Center (File > Help) and Help Tab**

The Help Center, which is part of the *Backstage view*, is intended to help you use the application more effectively by providing quick access to a variety of support tools. To access the Help Center, choose **File > Help**. For your convenience, the same commands are also available ’s Help tab.

**Using This Application**

- **Online Help File** opens the application's help file. If you have an active Internet connection, the help topics that you see will always be the most up-to-date versions available. If you do not have an active Internet connection, the help topics that you see will be the local copy that was installed on your machine.
**User Guide** opens the application's *User's Guide* (in PDF format) if you have an active Internet connection.

### Online Resources

- **ReliaSoft.com** opens the main page of the [reliasoft.com website](http://reliasoft.com).
- **Weibull.com** opens the [weibull.com website](http://weibull.com), which is devoted entirely to the topic of reliability engineering, reliability theory and reliability data analysis and modeling.
- **ReliaWiki.org** opens the [ReliaWiki website](http://reliawiki.org), which is both a resource portal and a wiki for professionals in reliability engineering and related fields.
- **Reliability Discussion Forum** opens the [Reliability Discussion Forum website](http://reliabilityforum.com), which is designed to facilitate communication within the reliability engineering field. These forums are open to everyone and no password is required. ReliaSoft personnel monitor and participate in the discussions.
- **ReliaSoft.tv** opens the [ReliaSoft TV website](http://reliasoft.tv).

### Examples

- **Open Examples Folder** provides access to a set of example projects that are designed to help you explore various software features.

### Technical Support

- **E-mail Support** generates an e-mail to request technical support. The e-mail is pre-populated with information about your license and operating system, which the technical support representative will need for troubleshooting the issue.
- **Contact USA Office** provides the contact information you will need to obtain technical support.
- **Contact Global Support Center** helps you find your localized support center.
- **Check for Update** allows you to download the latest free service release for the software.

- **Licensing** displays your [license and registration](http://license.licensefile.com) details. To view or edit additional information, click **License Manager**. The **License Manager** displays additional information about which products you have currently registered and/or your contact information on file with ReliaSoft.
• **About** displays the application’s Compile Release Version (CRV) (sometimes called a "build number"), which allows you to determine whether you have the latest version of the software.

**Home Tab**

The Home tab contains the following commands:

**Clipboard**

- **Paste** pastes the contents of the Clipboard into the current item or record.

  For items in the System panel, the pasted item(s) will be placed into the level below the currently selected item and will include any lower level items and associated analyses. If you want to paste the items to the same level or system level — or if you want to paste the item without associated information — use the **Paste Special** command.

  For records in the FMEA hierarchy view in the Analysis panel, the pasted data will include any dependent records (e.g., if you copied a cause that has associated actions or controls, the actions and controls will be pasted also). If you want to paste the record only, use the **Paste Without Dependents** command.

- **Paste As Top Level** pastes each cut/copied item as a system.

- **Paste Special** is available only when working in the System panel and opens the **Paste Special window**.

- **Paste Without Dependents** is available only when working with an FMEA. For example, if you cut/copy a function, it pastes only the function without associated failures, effects, etc.

- **Paste as Unique** is available only when working with controls or actions in an FMEA. It pastes the selected control or action as a new resource that is not associated with (linked to) the original. The description of the new record will be incremented automatically so it remains unique. For example, if the original description is "Do this and that," then the description of the new record might be "Do this and that_1." After you break the association, changes that are made to one resource will not be applied automatically to the other.
**Cut** cuts the selected item or record (along with any associated analyses or dependent records) to the Clipboard. You can then paste this information into another location within the same database.

**Copy** copies the selected item or record (along with any associated analyses or dependent records) to the Clipboard. You can then paste this information into another location within the same database.

**Copy Active View** (formerly called "Copy Current View to Graphic") copies the currently visible contents of the System panel or Analysis panel to the Clipboard as a graphic that can be pasted into other applications. The entire visible area within the active panel/tab will be copied but any information that is not currently visible will be excluded.

**Copy Analysis** and **Paste Analysis** allow you to copy and paste the analysis (FMEA, Control Plan, etc.) that currently has focus in the Analysis panel. Note that you will only be able to copy/paste analyses between projects that have the same FMEA structure.

**Delete Analysis** deletes the analysis that currently has focus in the Analysis panel.

### Edit

**Delete** deletes the selected item or record and all associated data.

**Spelling** allows you to automatically spell check the entire analysis displayed in the table or worksheet that is currently displayed (e.g., FMEA worksheet, control plan worksheet, etc.). If you want to use spell check for the records in the FMEA hierarchy, use the command that appears in each separate record properties window.

**Find and Replace** allows you to find or replace specified text, dates, numbers or drop-down list options within the current project.

**Undo Last Delete** cancels the last delete action you performed within the project.

### Move Record

**Promote** and **Demote** move the selected item to the next higher or lower level in the system hierarchy.

An item can be demoted only if there is another item on the same level and above the selected item that it can be demoted under.
Up and Down move the selected record up or down in a branch of the system hierarchy or FMEA hierarchy view.

**Reporting**

- **Reports** allows you to generate predefined reports in Microsoft Word or Excel.
- **Queries** allows you to search the project or database for the records that meet your specific query criteria. The results can be exported to Excel and you also have the option to save and reuse queries.
- **Plots** allows you to create graphical charts based on analysis data. First, you will be prompted to select the item(s) from the current project that will be the source of the data. Then you can choose the chart type and make any other required inputs.

**Dashboard**

- **Dashboard Viewer** opens the Dashboard Viewer so you can view dashboards based on predefined layouts.
- **Dashboard Manager** opens the Dashboard Layout Manager so you can create, edit and delete the predefined layouts that will be available for any Synthesis user to view for any analysis in the database.

**MIL-1629A Criticality** will be visible only if you have selected the option on the Settings page of the Application Setup window. If there is at least one criticality analysis field enabled in the project, this command opens the MIL-1629A Criticality Analysis window, which provides an alternative to the standard criticality analysis performed directly in the FMRA.

**Launch**

- **Another Synthesis Application** provides a drop-down list of the other Synthesis desktop applications that are installed on your computer. When you click an icon, the same database will automatically be opened in the new application.

**Synthesis**

- **Synthesis Explorer** allows you to explore all of the different analyses that are stored in the current database. You can filter, group and sort the analyses in a flexible grid, and also present the information in a wide variety of dashboard charts. (See Synthesis Explorer.)
Actions Explorer allows you to explore all of the action resources that are stored in the current database. You can filter and sort by date, status, person responsible, relevancy to you, etc. (See Actions Explorer.)

My Portal Tab

Messages
Create Message opens the Message window, which allows you to compose and send messages within the database.
Edit Message opens the Message window, which allows you to view and edit all of the properties of the message.
Reply to Message opens Message Reply window, which allows you to respond to a message sent to you.
Delete Message deletes the current message.

Actions
Create Action opens the Action window and adds an action to the project.
Edit Action opens the Action window, which allows you to view and edit all of the properties of the action record.
Delete Action deletes the current action record.
Add Action to Outlook adds an event, on the Action's due date, to your Outlook calendar.

Users
My Profile opens the User Login and Contact Information window where you change your contact details for your user account in the current database.
Project Tab

Unless otherwise indicated, these commands apply to the project that is currently selected in the project list. There are three ways to select a project and apply a command:

- By right-clicking the project in the project list and choosing the command from the shortcut menu.
- By selecting the project in the project list and then clicking the command on the ribbon.
- By clicking anywhere inside the project that is currently open/visible and then clicking the command on the ribbon.

Note: For secure databases, access to the commands on this tab may be restricted based on the permissions assigned to the user account.

Management

Create Project adds a new project to the current database. At a minimum, you must specify the project name.

Open Project opens the selected project.

Close Project closes the project that is currently open/visible and all of the analyses it contains.

Edit Project Properties allows you to view and edit the properties of the selected project.

Duplicate Project creates a copy of the selected project. The new project will have the same name as the original with an increment number added to the end (e.g., Project_1, Project_2, etc.).

Delete Project moves the selected project to the recycle bin.

Transfer Project is available only in Xfmea/RCM++/RBI. It allows you to create a new project with data transferred from the selected project. (See Transfer Projects in the Xfmea/RCM++/RBI documentation.)

Task Numbering is available only in MPC. It allows you to specify whether or not you want to reuse task numbers within the project. (See Task Numbering in MPC in the MPC documentation.)
Manage Projects opens the Manage Projects window, which allows you to edit the security settings and properties of all projects in the database in one location.

Import/Export gives you the option to open either the Import or Export wizard. The Import wizard allows you to import projects, resources or items from an existing database into the current database, while the Export wizard allows you to export to a new or existing database. (See Import, Export and Data Conversion.)

Configurable Settings is available only in Xfmea/RCM++/RBI. It allows you to view/modify the configurable settings for the current project. (See Configurable Settings in the Xfmea/RCM++/RBI documentation.)

Restore Points gives you the option to utilize restore points, which are exact replicas of the project at a particular point in time (i.e., backups). To create a restore point for the selected project, use the Create Restore Point command. To restore all data from an existing restore point, use the Restore Project command.

Check In/Out allows you to check out the selected project and make it available for editing only to you, while all other users in the database have read-only access to the project. No other user can edit the project unless you check in the project or undo the check out.

Recycle Bin

Empty Recycle Bin permanently deletes all projects under the Recycle Bin heading in the project list. There is no undo for emptying the recycle bin.

Restore Project is available only when you have selected a project under the Recycle Bin heading. The selected project will be recovered from the recycle bin and restored to its original location in the project list.

Delete Project permanently deletes the selected project. There is no undo for delete unless you have a stored backup or restore point.

History Log is available only if you are the project owner or have the applicable "manage all projects" permissions. It opens the Project History Log window, which allows you to activate and deactivate the history log for the project and, if the history log is currently activated, to view changes that have been performed throughout the entire project, with any Synthesis application.
Project Planner opens the Project Planner, which provides full project planning and management capabilities for the current project. This command is not available in MPC.

**E-mail Project**

Pack and E-mail compresses a copy of the selected project to a *.rsgz11 file and attaches it to a new e-mail message. If no e-mail program is installed or no default e-mail program is defined on the computer, a message notifying you of this will be shown.

**Security**

Project Security is available only for public projects in secure databases. It opens the Project Properties window with the Security tab active, where you can specify the user accounts that can view/modify the selected project.

Change Owner allows you to assign a different database user to be the owner for the selected project.

Lock Project moves the project into the Locked heading of the project list. When a project is locked, all database users (including the user who locked the project) will have read-only access to the project. In addition, a locked project cannot be deleted or have its properties and public/private status edited. To unlock a project, choose Unlock Project. (See Locked and Unlocked Projects.)

Make Private moves the selected public project into the Private heading of the project list. (See Public, Private and Reference Projects.)

Make Public moves the selected private or reference project into the Public heading of the project list.

Make Reference moves the selected public project into the Reference heading of the project list. This command is not available in MPC.

**Current Item**

The following commands are available when you select a specific item (a diagram, report, multiplot, etc.) in the current project explorer. This group is not available in Xfmea/RCM++/RBI or in MPC.

Edit brings the selected item to the front of the windows and activates it as the current control. If an attachment is selected, the command opens the attachment in the appropriate application, if that application is installed on your computer.
Rename allows you to rename the selected item.

Duplicate creates a copy of the selected item within the project. The duplicate will have the same name as the original with an increment number added to the end (e.g., RBD1_1, RBD1_2, etc.). In BlockSim, you can choose to Duplicate With Resources, which also creates duplicate resources in the Resource Manager window.

Delete deletes the selected item. There is no undo for delete.

Item Properties is available only for project explorer items (e.g., folios, diagrams, plots, etc.). It opens the Item Properties window, which allows you to view and edit the item's Synthesis identifiers, item settings (if applicable) and item permissions (in secure databases).

Locator Link is a link file (similar to a Windows shortcut) that provides quick access to the specific analysis. In an enterprise database, you can choose to Save or E-mail the file. In a standard database or Synthesis file, the only option is to save the file. In Xfmea/RCM++/RBI, these commands are available in the System Hierarchy tab. In MPC, they are in the Systems, Structures or Zones tab.

Synthesis

Resource Manager opens the Resource Manager window, which allows you to view and edit all of the resources (URDs, models, tasks, etc.) available to the selected project. This command is not available in MPC.

Batch Properties Editor opens the Batch Properties Editor, which allows you to perform batch editing of most types of local resources in the current project. In BlockSim, it also allows you to edit the blocks used in the diagrams. This command is not available in MPC.

Attachments is available only in Xfmea/RCM++/RBI and MPC. It adds linked or attached files to the selected project. In other Synthesis desktop applications, attachments commands are available in the current project explorer, and in the Insert tab of the ribbon.

Data Management

The following commands are available only in BlockSim.

Mirror Group Manager opens the Mirror Group Manager window which allows you to add, view and edit groups of mirrored blocks within the project that is currently
open/visible. (See Mirroring (Using Blocks in Multiple Locations) in the BlockSim documentation.)

**Maintenance Group Manager** opens the Maintenance Group Manager window, which allows you to add, view and edit the maintenance task groups available to the project that is currently open/visible. (See Maintenance Groups.)

### Reports

**MRBR** is available only in MPC. It allows you to generate a maintenance review board report in Microsoft Word. (See Maintenance Review Board Reports in the MPC documentation.)

### System Hierarchy Tab

The System Hierarchy tab contains commands related to using the System panel.

### Add Items

- **Add System** adds a new top level (system) item to the System panel at the bottom of the list.

- **Add Next Level Item** adds a new item to the next level below the item that is currently selected in the System panel. The new item will be added to the bottom of the list for that level.

- **Add Same Level Item** adds a new item to the same level as the item that is currently selected in the System panel. The new item will be added to the bottom of the list for that level.

- **Insert Same Level Item** adds a new item to the same level as the item that is currently selected in the System panel. The new item will be inserted above the selected item.

- **Smart Add Items** allows you to quickly find and copy item names from other similar analyses.

- **Import**

  - **Import Items (Query)** allows you to query for items that you wish to import.
Import Items (Browse) allows you to browse for items and/or FMEA information that you wish to import.

Import from Excel allows you to import data from an Excel spreadsheet.

Import Lambda Predict Items allows you import systems from a Lambda Predict analysis.

Import MPC Systems allows you import systems from an MPC analysis.

**Risk Based Inspection (available only for RBI)**

Add RBI Equipment and Add Component allow you to select one of the equipment types or component types that are eligible for RBI analysis and add the item to the system hierarchy. (See Building the RBI System Hierarchy.)

Convert to Equipment converts the selected system hierarchy item to an RBI equipment item. (See Converting System Hierarchy Items to RBI Equipment.)

PRD Components are available when working with a pressure relief device and the RBI Properties tab is active in the analysis panel.

Assign Components opens a window where you can select which existing components to add to the pressure relief device.

Go to Component displays the properties of the selected component.

Remove Component removes the component from the pressure relief device.

Risk Categories allows you to view or modify the Risk Priority rating scales that will be used for all RBI analyses in the current database.

Management Score allows you to set the Management Systems Evaluation score for all RBI analyses in the current project.

Calculate Risk calculates the results of the RBI analysis.

**Current Item**

Item Permissions is available only for secure databases. It allows you to prevent specific users from editing the item and its related analyses. (See Item Permissions,)
Chapter 4: Xfmea, RCM++ and RBI Ribbons

**Diagrams**

- **Process Flow Diagram** opens the process flow diagram associated with the selected item (if any), or allows you to create a new one.

- **FMEA Block Diagram** opens the FMEA Block Diagram associated with the selected item (if any), or allows you to create a new one.

- **Cause and Effect Diagram** opens the existing cause and effect diagram (also called a "fishbone diagram") associated with the selected item (if any), or allows you to create a new one.

**Item History** is available only if a history log has been activated at the project level. It opens the Record History Log window for the current item and displays changes that have been performed for the item.

**Attachments** allows you to manage the linked or attached files for the selected item.

**Locator Link** creates a link file (similar to a Windows shortcut) that provides quick access to a specific analysis or record.

**Tools**

- **Configurable Settings** opens the Properties window where you can change the properties that are available for the items in this project.

- **Create Categories** creates new item categories based on the names of the current system and its dependents, then applies the new categories to the items in the branch. (See Item Categories in Xfmea/RCM+/RBI.)

- **Renumber All Items** renumbers all items based on their positions in the system hierarchy. *This cannot be undone.* If you also want to display the full context in the Reference Number field (e.g., # = 3 and Reference Number = 1.2.4.3), select the Apply to reference number field check box.

- **Update Names** changes the Name field in every FMEA record in the project to an asterisk (*), which shows the first 50 characters in the record's Description field in the appropriate places.
**Reporting** provides convenient access to all of the same commands that also appear on the **Home tab**.

**Reports** allows you to generate **predefined reports** in Microsoft Word or Excel.

**Plots** allows you to create ** graphical charts** based on analysis data. First, you will be prompted to select the item(s) from the current project that will be the source of the data. Then you can choose the chart type and make any other required inputs.

**Dashboard**

**Dashboard Viewer** opens the **Dashboard Viewer** so you can view dashboards based on predefined layouts.

**Dashboard Manager** opens the **Dashboard Layout Manager** so you can create, edit and delete the predefined layouts that will be available for any Synthesis user to view for any analysis in the database.

**MIL-1629A Criticality** will be visible only if you have selected the option on the **Settings page** of the Application Setup window. If there is at least one criticality analysis field enabled in the project, this command opens the **MIL-1629A Criticality Analysis window**, which provides an alternative to the standard criticality analysis performed directly in the FMRA.

**Send Active View to Excel** sends the contents of the System panel or the tab in the Analysis panel that currently has focus to an Excel spreadsheet.

**Export to Excel** exports data to an Excel spreadsheet. You can choose an existing template or create a new template that determines how the data will be "mapped" from the software to the Excel file.

**Risk Matrix** opens the **Risk Matrix window**, which provides a visual way to evaluate the risk based on either the Severity and Occurrence ratings or the Severity and Detection ratings.

**Diagnostic Logic Assistant** opens the **Diagnostic Logic Assistant window**, which extracts relevant information from the FMEA that you can use to prepare troubleshooting documentation.
FMEA Statistics opens the FMEA Statistics window, which displays some overall statistics for the FMEA. This includes details such as the total number of causes defined in the analysis, the percentage of causes that have the RPN ratings defined, the total number of actions defined in the analysis, the percentage of actions that are complete, etc.

Remove External FMEAs removes the links to all FMEAs that come from reference projects and replaces them with local FMEA records.

Task Packaging is available only in RCM++ and RBI. It opens the Scheduled Task Packaging window, which allows you to group tasks into task packages for the most efficient allocation of resources and downtime management.

XFRACAS

Import XFRACAS Items allows you to import XFRACAS systems into the system hierarchy.

Associate Item creates an association between the currently selected item and an item in the XFRACAS hierarchy. To remove the association, choose Remove Association.

Synchronize Item opens the Synchronize with XFRACAS window, where you choose the type of synchronization that you want to perform for the item, from updating only the current item properties, to adding new dependents, to adding any associated failures and causes.

Import Failures opens the Import Failure Modes from XFRACAS window, where you choose which FMEA failures and causes to update with their associated records in XFRACAS.
Analyses Tab
The Analyses tab contains the following commands.

Planning

Add Risk Discovery adds a tab in the Analysis panel for the risk discovery analysis associated with the selected item.

Add Analysis Plan adds a tab in the Analysis panel for the analysis plan associated with the selected item.

Add P-Diagram adds a tab in the Analysis panel for the Parameter Diagram (P-Diagram) associated with the selected item.

FMEA

Add FMEA adds a tab in the Analysis panel for the failure modes and effects analysis (FMEA) associated with the selected item.

Add DRBFM adds a tab in the Analysis panel for the design review based on failure modes (DRBFM) analysis associated with the selected item. It will be visible only if you have selected the option on the Configurable Settings page of the Project Properties window.

Other

Add DVP&R adds a tab in the Analysis panel for the design verification plan (DVP&R) analysis associated with the selected item. It will be visible only if you have selected the option on the Configurable Settings tab of the Project Properties window.

Add PFD Worksheet adds a tab in the Analysis panel for the process flow diagram worksheet associated with the selected item.

Add Control Plan adds a tab in the Analysis panel for the control plan associated with the selected item.

View Tab
The View tab contains commands related to configuring the layout of the application's interface.
Chapter 4: Xfmea, RCM++ and RBI Ribbons

Refresh

Refresh refreshes the display in the Project window. If multiple users are accessing the same project simultaneously, this command will refresh your screen with any changes made by other users. When you make a change to the project, your window will be refreshed automatically.

Project Manager

Show Project Manager brings the Project Manager into focus. If the Project Manager is unpinned and hidden, choosing this command will display it.

Tile Project Manager tiles the project list and current project explorer so they are both displayed simultaneously in the Project Manager panel. This command is not available in Xfmea, RCM++, RBI or MPC.

Dock Project Manager opens a submenu that allows you to choose the desired position for the Project Manager: Dock Left, Dock Right, Dock Top, Dock Bottom or Floating.

My Portal

Show My Portal opens the My Portal window, which provides information relevant to your work within the database, such as messages from other users, recommended actions for a particular project item, status of other users logged in to the database and other information.

Tile My Portal tiles the Messages, Actions and Users pages so they are all displayed simultaneously within the My Portal panel.

Dock My Portal opens a submenu that allows you to choose the desired position for the Portal: Dock Left, Dock Right, Dock Top, Dock Bottom or Floating.

Workspace Layout

The commands in this group are available only in Xfmea, RCM++, RBI, MPC and Lambda Predict.

Change Orientation toggles between the two possible orientations for the System panel and the Analysis/Properties panel. These panels can be side-by-side or one on top of the other.

Hide System [Panel/Hierarchy] hides the System panel in the Project window. When you want to show the panel again, choose View > Workspace Layout > Split Panels.
Hide [Analysis Panel/Properties] hides the Analysis/Properties panel in the Project window. When you want to show the panel again, choose View > Workspace Layout > Split Panels.

Split Panels splits the Project window into two equal panels, with 50% of the available space used for the System panel and 50% of the available space used for the Analysis/Properties panel.

Properties View. These commands are available only in Lambda Predict.

Tree View organizes the properties depending on whether they are physical properties (e.g., part quality level, case type, etc.) or application properties (e.g., ambient temperature, applied voltage, etc.). Depending on the prediction standard and component you are working with, the properties may also be organized according to failure mechanisms or type of data.

Pi Factor View organizes the item properties based on the pi factors that they contribute to so you can see how the values affect the failure rate calculations. The relevant pi factors will vary depending on the item’s failure rate model. (See the Tree View and Pi Factor View topic in the Lambda Predict documentation.)

Expand/Collapse
The commands in this group apply to the hierarchical view that currently has focus. Depending on the application, this can be the project list, the current project explorer, the System panel, the Properties panel (Lambda Predict only) or the Analysis panel if it is using a hierarchical view.

Expand Tree expands the entire tree in the hierarchical view.

Collapse Tree collapses the entire tree in the hierarchical view.

Expand Node expands the selected branch in the hierarchical view.

Collapse Node collapses the selected branch in the hierarchical view.

Collapse to Level collapses the hierarchical view to the level of the item that is currently selected. For example, if you have selected a cause in the FMEA hierarchy view and choose this command, all branches in the FMEA hierarchy view will be collapsed to the cause level and the nodes for controls and actions will be hidden.
Zoom

- **Normal Zoom** sets the degree of magnification to 100%.
- **Zoom In** increases the degree of magnification.
- **Zoom Out** decreases the degree of magnification.
- **Custom Zoom** allows you to specify the degree of magnification.

Window

- **Use Tabbed MDI** maximizes the windows to fill the full space available in the MDI and shows a tab for each open window. If you clear this command, the open windows will be displayed as separate windows that can be resized and moved around within the MDI.

- **Cascade** cascades all open project windows inside the MDI.
- **Tile Horizontally** horizontally tiles all open project windows inside the MDI.
- **Tile Vertically** vertically tiles all open project windows inside the MDI.

- The **Windows** drop-down list displays a list of all project windows currently open inside the MDI. You can make any of the open project windows active by clicking its name in this ribbon.

- **Close All Windows** closes all open project windows inside the MDI, leaving only the Project Manager and My Portal panels open (if they were selected to be shown).

FMRA

The commands in this group are available only in BlockSim. (See [Failure Modes and Reliability Analysis (FMRA)](http://xfmea.reliasoft.com) in the BlockSim documentation.)

- **Show FMRA** opens the FMRA view, which displays the FMRA (failures modes and reliability analysis) hierarchy that is associated with the project.

- **Disassociate FMRA** deletes all of the diagrams and blocks associated with the current FMRA hierarchy and closes the FMRA view.
Show
The commands in this group are available only in Xfmea, RCM++ and RBI.

- **Show FMRA** enables/disables the FMRA tab in the System panel.
- **Show Test Plan** opens the Test Plan tab in the analysis panel, which displays a list of actions that describe specific tests that need to be performed. (See the Test Plans topic in the Xfmea/RCM++/RBI documentation.)

Paste Special Window
The Paste Special window allows you to specify how the item(s) that were cut or copied in the System panel will be pasted.

The options in the **Paste at this level** section allow you to specify the level in the system hierarchy to which the item(s) will be pasted:

- **As system** pastes to the top (system) level.
- **As same level** pastes to the same level as the item that is currently selected. (This position also might be referred to as a "sibling.")
- **As next level** pastes to the level below the item that is currently selected. (This position also might be referred to as a "child.")

The options in the **Other Options** section allow you to specify which associated data, if any, will be pasted along with the item(s).

- **Include lower level items** pastes any lower level items (sub-items).
- **Include analyses** pastes any associated analyses (i.e., PFD worksheet, risk discovery, analysis plan, FMEA, DRBFM, DVP&R or, control plan). If this check box is not selected, only the item properties and attachments (i.e., links/attachments, process flow diagram, FMEA Block Diagram, cause and effect diagram) will be pasted.

Active Tabs

Control Plan Tab
The Control Plan tab is visible when working with a control plan analysis.
Chapter 4: Xfmea, RCM++ and RBI Ribbons

Part/Process

Add Part/Process adds cells to the control plan worksheet for describing the part/process that is being analyzed.

Insert Part/Process inserts new cells above the part/process record that is currently selected.

Characteristic

Add Characteristic adds cells to the control plan worksheet for describing the characteristics that must be kept under control.

Insert Characteristic inserts new cells above the characteristic that is currently selected.

Method

Add Method adds cells to the control plan worksheet for describing the control methods that have been defined.

Insert Method inserts new cells above the method that is currently selected.

Sync

Sync with PFD Worksheet allows you to transfer data from the PFD worksheet to the control plan. (See Sync Options for Control Plans.)

Sync with FMEA allows you to transfer data from the FMEA to the control plan based on the criteria that you specify.

Tools

History Log is available only if a history log has been activated at the project level. It opens the Record History Log window for the current analysis and displays changes that have been performed for the analysis.

Configurable Settings opens the Properties window where you can change the properties that are available for the control plan records in this project.

Change Log

Activate Change Log or View Change Log allows you to activate or view a change log for this control plan analysis. A change log records a history of the specific changes that were made in each tracked revision to the analysis since the log was activated.
Approve Change Logs displays a list of all the control plan change logs in the project that are assigned to you for approval and are ready to be approved. (See Electronic Approval Tracking.)

DRBFM Tab
The DRBFM tab is visible when working with a Design Review Based on Failure Mode (DRBFM) analysis.

DRBFM Records

- Parts/Functions adds or inserts cells in the DRBFM worksheet for describing the change and the parts/functions that might be affected by the change.

- Concerns adds or inserts cells in the DRBFM worksheet for describing concerns related to the change. The concerns in a DRBFM are similar to the failure modes in an FMEA. The DRBFM worksheet provides two columns for concerns. The Design Engineer view displays only the first column and the Review Team view displays both columns. For a given row of the worksheet, you can type in only one column or the other.

- Effects adds or inserts cells in the DRBFM worksheet for describing the effects that may result if the concern (failure mode) occurs.

- Causes adds or inserts cells in the DRBFM worksheet for describing the possible causes of the concern. The DRBFM worksheet provides two columns for causes. The Design Engineer view displays only the first column and the Review Team view displays both columns. For a given row of the worksheet, you can type in only one column or the other.

- Controls adds or inserts cells in the DRBFM worksheet for describing the controls that are in place to reduce the likelihood that the cause will occur (Prevention Controls) or increase the likelihood that the cause will be detected before it reaches the end user (Detection Controls).

- Actions adds or inserts cells in the DRBFM worksheet for describing the actions that will be assigned to address the concern. The DRBFM worksheet provides separate columns for three types of actions: design-related actions, testing-related actions and manufacturing-related actions. For a given row of the worksheet, you can define any or all of the three types of action.
Chapter 4: Xfmea, RCM++ and RBI Ribbons

Sync

Get Functions from FMEA displays a list of all functions defined in the FMEA. You can choose to import any of these functions to the DRBFM.

Send Functions to FMEA displays a list of all functions defined in the DRBFM. You can choose to export any of these functions (along with all related concerns, effects, causes, controls and actions) to the end of the FMEA.

Get Header from FMEA imports the data from the FMEA header to the DRBFM header. This will replace any header information that has been defined already for the DRBFM.

Send Header to FMEA exports the data from the DRBFM header to the FMEA header. This will replace any header information that has been defined already for the FMEA.

Tools

History Log is available only if a history log has been activated at the project level. It opens the Record History Log window for the current analysis and displays changes that have been performed for the analysis.

Configurable Settings opens the Properties window where you can change the properties that are available for the DRBFM records in this project.

DVP&R Tab

The DVP&R tab is visible when working with a Design Verification Plans (DVP&Rs) analysis.

Plan

Add Plan adds cells to the DVP&R worksheet for describing a test plan.

Insert Plan inserts new cells above the test plan that is currently selected.

Report

Add Report adds cells to the DVP&R worksheet for describing the results of a test.

Insert Report inserts new cells above the test report that is currently selected.
Sync

Sync with FMEA allows you to transfer data from the FMEA to the DVP&R based on the criteria that you specify.

Tools

History Log is available only if a history log has been activated at the project level. It opens the Record History Log window for the current analysis and displays changes that have been performed for the analysis.

Configurable Settings opens the Properties window where you can change the properties that are available for the DVP&R records in this project.

Attachments adds linked or attached files to the selected plan or report.

Change Log

Activate Change Log or View Change Log allows you to activate or view a change log for this DVP&R analysis. A change log records a history of the specific changes that were made in each tracked revision to the analysis since the log was activated.

Approve Change Logs displays a list of all the DVP&R change logs in the project that are assigned to you for approval and are ready to be approved. (See Electronic Approval Tracking.)

FMEA Tab

The FMEA tab is visible when you are working in the FMEA tab in the Analysis panel. This tab can be used to perform a Failure Modes and Effects Analysis or to record the Functional Failure Analysis for RCM.

FMEA Records

Functions

Add Function adds a function to the FMEA.

Insert Function inserts a function above the function that is currently selected in the FMEA.

Smart Add Functions allows you to quickly find and copy FMEA records from other similar analyses.
Chapter 4: Xfmea, RCM++ and RBI Ribbons

**Import Functions** allows you to query an existing data source and then select existing record(s) to import into the FMEA.

**Select Existing Text** allows you to add existing text elements (using the Select Existing Text window) as new function records to the FMEA.

**Edit Function** opens the Function Properties window, which allows you to view and edit all of the properties of the function record.

**Locator Link** creates a link file (similar to a Windows shortcut) that provides quick access to a specific analysis or record.

**Failures**

**Add Failure** adds a failure mode to the FMEA.

**Insert Failure** inserts a failure mode above the failure mode that is currently selected in the FMEA.

**Smart Add Failures** allows you to quickly find and copy FMEA records from other similar analyses.

**Import Failures** allows you to query an existing data source and then select existing record(s) to import into the FMEA.

**Select Existing Text** allows you to add existing text elements (using the Select Existing Text window) as new failure records to the FMEA.

**Edit Failure** opens the Failure Properties window, which allows you to view and edit all of the properties of the failure mode record.

**Relationship Diagram** creates or opens an existing failure relationship diagram, which presents all of the causes and effects that have been defined for the selected failure mode.

**Locator Link** creates a link file (similar to a Windows shortcut) that provides quick access to a specific analysis or record.

**Effects**

**Add Effect** adds an effect to the FMEA.
**Insert Effect** inserts an effect above the effect that is currently selected in the FMEA.

**Smart Add Effects** allows you to quickly find and copy FMEA records from other similar analyses.

**Import Effects** allows you to query an existing data source and then select existing record(s) to import into the FMEA.

**Select Existing Text** allows you to add existing text elements (using the Select Existing Text window) as new effect records to the FMEA.

**Edit Effect** opens the Effect Properties window, which allows you to view and edit all of the properties of the effect record.

**Effect Categorization** is available only in RCM++ and RBI. It opens the Failure Effect Categorization window, which allows you to identify and evaluate the effects of the functional failure when applicable.

**Cause and Effect Diagram** creates or opens an existing cause and effect diagram (also called a "fishbone diagram"), which presents all of the events that lead to the selected effect.

**Locator Link** creates a link file (similar to a Windows shortcut) that provides quick access to a specific analysis or record.

**Causes**

**Add Cause** adds a cause to the FMEA.

**Insert Cause** inserts a cause above the cause that is currently selected in the FMEA.

**Smart Add Causes** allows you to quickly find and copy FMEA records from other similar analyses.

**Import Causes** allows you to query an existing data source and then select existing record(s) to import into the FMEA.

**Select Existing Text** allows you to add existing text elements (using the Select Existing Text window) as new cause records to the FMEA.
**Edit Cause** opens the [Cause Properties window](http://xfmea.reliasoft.com), which allows you to view and edit all of the properties of the cause record.

**Reliability Policy** is displayed only if the *Hide reliability policy node* option is cleared on the FMEA Hierarchy page of the Application Setup. This is used for Failure Modes and Reliability Analysis (FMRA). (See [Setting the Reliability Policies](http://xfmea.reliasoft.com).)

**Task Manager** is available only in RCM++ and RBI. It opens the [Task Manager window](http://xfmea.reliasoft.com), which allows you to specify an appropriate maintenance strategy for the current failure cause.

**Locator Link** creates a [link file](http://xfmea.reliasoft.com) (similar to a Windows shortcut) that provides quick access to a specific analysis or record.

**Controls**

**Add Control** adds a control to the FMEA.

**Insert Control** inserts a control above the control that is currently selected in the FMEA.

**Reuse Control Resources** allows you to add existing control records (using the [Select Resource window](http://xfmea.reliasoft.com)) to the FMEA.

**Make Control Unique** creates a new record that is not associated with (linked to) the existing Synthesis resource. The description of the new record will be incremented automatically so it remains unique. For example, if the original description is "Do this and that," then the description of the new record might be "Do this and that_1." After you break the association, changes that are made to one resource will not be applied automatically to the other.

**Change Control Resource** opens the [Select Resource window](http://xfmea.reliasoft.com) so that you can replace the selected record with a Synthesis resource that already exists in the project. After you create this association, changes that are made to one instance of the resource will be applied automatically to all other instances.

**Edit Control** opens the [Control Properties window](http://xfmea.reliasoft.com), which allows you to view and edit all of the properties of the control record.

**Locator Link** creates a [link file](http://xfmea.reliasoft.com) (similar to a Windows shortcut) that provides quick access to a specific analysis or record.
**Actions**

- **Add Action** adds an action to the FMEA.
- **Insert Action** inserts an action above the action that is currently selected in the FMEA.
- **Reuse Action Resources** allows you to add existing action records (using the *Select Resource window*) to the FMEA.
- **Make Action Unique** creates a new record that is not associated with (linked to) the existing Synthesis resource. The description of the new record will be incremented automatically so it remains unique. For example, if the original description is "Do this and that," then the description of the new record might be "Do this and that_1." After you break the association, changes that are made to one resource will not be applied automatically to the other.
- **Change Action Resource** opens the *Select Resource window* so that you can replace the selected record with a Synthesis resource that already exists in the project. After you create this association, changes that are made to one instance of the resource will be applied automatically to all other instances.
- **Edit Action** opens the *Action window*, which allows you to view and edit all of the properties of the action record.
- **Locator Link** creates a *link file* (similar to a Windows shortcut) that provides quick access to a specific analysis or record.

**Tools**

- **Attachments** allows you to manage the *linked or attached files* for the selected record.
- **Highlight Priority** if selected, uses color to highlight the FMEA records based on logic that has been defined for the project. (See *Priority Highlights*.)
- **Ratings Update** opens the *Batch Update Revised RPN Rating window*, which allows you to quickly populate the revised RPN ratings in the FMEA records.
- **FMEA Statistics** opens the *FMEA Statistics window*, which displays some overall statistics for the FMEA. This includes details such as the total number of causes defined in the analysis, the percentage of causes that have the RPN ratings defined, the total
number of actions defined in the analysis, the percentage of actions that are complete, etc.

**Failure - Cause Matrix** opens the Failure - Cause Matrix window, which displays the unique failure modes and causes that have been defined in the FMEA. This matrix helps to see when the same cause has been identified for more than one failure mode.

**Export to Phrase Set**

- **Export to a New FMEA Phrase Set** allows you to export the descriptions from the current FMEA to a new phrase set in the active library. (See Phrase Sets.)
- **Export to an Existing FMEA Phrase Set** allows you to export the descriptions from the current FMEA to an existing phrase set.

**Configurable Settings** opens the Properties window where you can change the properties that are available for the FMEA records in this project.

**History Log** is available only if a history log has been activated at the project level. It opens the Record History Log window for the current analysis and displays changes that have been performed for the analysis.

**Change Log**

- **Activate Change Log** or **View Change Log** allows you to activate or view a change log for this FMEA analysis. A change log records a history of the specific changes that were made in each tracked revision to the analysis since the log was activated.

- **Approve Change Logs** displays a list of all the FMEA change logs in the project that are assigned to you for approval and are ready to be approved. (See Electronic Approval Tracking.)

**FMRA Tab**

The FMRA tab is visible when you are working in the FMRA tab in the System panel with a Failure Modes and Reliability Analysis (FMRA).

**Add System Items**

- **Add System** adds a new top-level system hierarchy item.

- **Add Next Level Item** adds a new system hierarchy item below the one that is currently selected.
**Add Same Level Item** adds a new system hierarchy item in the same level as the one that is currently selected.

**Add FMEA Items**

- **Add Function** adds a function to the FMEA. If an FMEA does not already exist for the current item, it will be created automatically.
- **Add Failure** adds a failure mode to the FMEA.
- **Add Cause** adds a cause to the FMEA. If the FMEA does not already include an effect to add the cause to, one will be created automatically.

**Calculations**

- **Calculate (Reliability)** calculates and displays the reliability and criticality values for each record in the FMRA hierarchy.
- **Simulate (Availability)** is available only in RCM++ and RBI. It displays the reliability, availability and cost calculations (obtained via simulation) for each record at the end time specified in the simulation settings.
- **Highlight** applies a color-coding gradient to the results shown in each column, from green (least "desirable" result) to red (most "desirable" result). This command toggles highlighting on and off.
- **Policy Update** opens the Batch Update Reliability Policy window, where you can change the reliability policy type for all applicable records in the FMRA hierarchy.
- **Mirrors** allows you to create and manage mirror groups for the causes in the FMRA. Mirror groups can be used if you need to consider common cause failures. (See Using Mirror Groups in an FMRA.)
- **Optimum Replacement** is available only in RCM++ and RBI. It opens the Optimum Replacement window, which allows you to define the cost of planned and unplanned replacement tasks and calculate the optimum replacement time, as well as the cost per unit time at that replacement time.

**Allocation**

- **Allocate Target Reliability** sets the target reliability values for sub-items, based on the selected item's target value.
Allocate Target Availability is available only in RCM++ and RBI. It sets the target availability values for sub-items, based on the selected item’s target value.

P-Diagram Tab
The P-Diagram tab is visible when working with a Parameter Diagram analysis.

Records
- **Add Record** adds a row to the input box that currently has focus.
- **Insert Record** inserts a new row above the one that is currently selected.
- **Select Existing Text** allows you to choose text from existing P-Diagrams or other relevant analyses to create one or multiple new rows in the input box that currently has focus. (See Select Existing Text.)
- **Delete Record(s)** deletes the rows that are currently selected.

Up and Down move the selected row up or down in the input box (i.e., to change the order).

Change Log
- **Activate Change Log** or **View Change Log** allows you to activate or view a change log for this P-Diagram analysis. A change log records a history of the specific changes that were made in each tracked revision to the analysis since the log was activated.

- **Approve Change Logs** displays a list of all the P-Diagram change logs in the project that are assigned to you for approval and are ready to be approved. (See Electronic Approval Tracking.)

PFD Worksheet Tab - Ribbon
The PFD Worksheet tab is visible when working with a process flow diagram worksheet.

Operation
- **Add Operation** adds cells to the PFD worksheet for describing the operation that is being analyzed.
**Insert Operation** inserts new cells above the operation record that is currently selected.

**Product Characteristic**

- **Add Product Characteristic** adds cells to the PFD worksheet for describing the product characteristics that must be kept under control (e.g., thread depth, wax thickness, length of a cut, etc.).
- **Insert Product Characteristic** inserts new cells above the product characteristic that is currently selected.

**Process Characteristic**

- **Add Process Characteristic** adds cells to the PFD worksheet for describing the process characteristics that must be kept under control (e.g., furnace temperature, flow pressure, coolant concentration, etc.).
- **Insert Process Characteristic** inserts new cells above the process characteristic that is currently selected.

**Sync**

- **Sync with System Hierarchy** allows you to transfer data from the PFD worksheet to the system hierarchy.

**Tools**

- **History Log** is available only if a history log has been activated at the project level. It opens the Record History Log window for the current analysis and displays changes that have been performed for the analysis.
- **Configurable Settings** opens the Properties window where you can change the properties that are available for the PFD worksheet records in this project.
Chapter 5: Configurable Settings

All of the analysis settings that can be configured in Xfmea, RCM++ or RBI (including the data fields, the options in drop-down lists, the rating scales used for risk assessment and other analysis preferences) are stored together with the data for each project. This makes it possible to define different properties for different types of projects and, when multiple users cooperate on the analysis, it also ensures that all users see the same configurable settings for a particular project.

To save time and ensure consistency, authorized users can manage a library of predefined settings and profiles that can be copied into any particular analysis project. With an enterprise database, the library is stored directly in the database and can be accessed only by users with the "Manage profiles and templates in Xfmea/RCM++/RBI" permission. With standard databases, the library is a separate database (*.lb11) that can be stored on your computer or a shared network folder. Although you can maintain multiple library databases if desired, only one library can be active at any given time.

Transferring Settings Between the Library and the Projects

As you begin working with the configurable settings in Xfmea, RCM++ or RBI, it may be helpful to keep a few basic principles in mind:

- A complete set of configurable settings are stored with each project in the database.
- The library contains predefined settings that can be copied into any given project at any time.
- Settings are copied, not linked.
  - Changing settings in the library does not automatically update any of the settings for existing projects. You will need to reapply the updated profile to each affected project.
  - Changing settings for a particular project does not automatically update the library that the settings were originally copied from. You will need to apply/transfer the same changes in the library, if appropriate.

For new users, we recommend the following basic workflow:

1. **Configure the library to contain the settings your organization will need.** Assign one user (or a small team of users) to use the Profiles/Libraries Manager to create a library...
that contains a predefined profile for each type of project your team may need to use. For example, your organization may need one profile for Design FMEAs, a second profile for Process FMEAs and a third profile for RCMs (if applicable). Alternatively, you may need to create different profiles (e.g., with different rating scale criteria) for different product lines, etc.

**Tip:** If you start with the library that is installed with the software, it may help to avoid confusion if you delete any settings that are not relevant for your team. You can **restore the original shipped library** at any time if you need it.

2. **Make sure that all users are sharing the same active library.** With an enterprise database, this is the only option. With standard databases, you can place the library database in a shared network location and then instruct all users to set this shared file as the active library on their computers. Alternatively, you can simply distribute a copy of the latest file to all users. When you’re working with a standard repository, the active library can be set at the top of the Profiles/Libraries Manager window, as shown next.

3. **Establish the configurable settings for each project.** The simplest way to set the properties for a particular project is to choose a predefined profile from the drop-down list on the General tab of the Project Properties window. This will automatically copy all of the relevant settings from the library to the project.

4. **View/modify the settings for an individual project, if desired.** If you need to view or modify the settings for one particular project only, use the Configurable Settings tab of the Project Properties window or choose **Project > Management > Configurable Settings.**
Remember that changing the settings in an individual project does not automatically update the library or any other projects.

- **If you want the changes to apply to all future projects**, it may be more efficient to update the active library and then reapply the profile to any existing projects that need to be updated.

- **If you want to change a particular project only**, edit the project settings directly via the Configurable Settings tab of the Project Properties window or by choosing the appropriate option from the ribbon.

**Unmatched Settings Window**

If you change a drop-down list or rating scale in a project that already contains data, the Unmatched Settings window provides a quick and easy way to update existing records, if desired. This window will appear automatically when it is applicable.

For example, if you remove or rename one of the options in the **Action Category** drop-down list, and if the project contains any actions that have already been assigned to that option, you will be prompted to specify which category those actions should be reassigned to (if any). Simply select the appropriate option from the **New Value** drop-down list, as shown next. (This picture shows Xfmea, but it works the same in RCM++ and RBI.)
Profiles/Library Manager

A profile is a collection of predefined settings for a particular type of analysis. For example, your organization may need one profile for Design FMEAs and a second profile for Process FMEAs and a third profile for RCMs (if applicable). A library, on the other hand, is a collection of profiles and other settings that can be applied to any project. The library file that is in effect at any given time on your computer is called the active library.

Note that:

- For standard databases (*.rsr11), library files have the extension *.lb11 and can be saved on your own computer or stored in a shared network location. The ability to modify the settings depends on whether the user has read/write access to the file.

- For enterprise databases (SQL Server or Oracle), the active library is stored within the enterprise database itself, and the ability to edit this library is restricted to authorized users only.

If you have the necessary permissions, you can view and edit all of the profiles in a library via the Profiles/Library Manager. To access this utility, first open a database, then choose File > Manage Repository > Xfmea/RCM++/RBI Libraries > Profiles/Library Manager.

If you are connected to a standard database, the address bar at the top of the Profiles/Library Manager window shows the location and name of the active library for your computer. You can click the Browse button to select a different library file to use.

Viewing or Editing Settings

The navigation panel on the left lists the different types of settings that can be predefined and stored in the library. The table on the right displays the predefined settings for the type that is currently selected. To view or edit the settings, simply double-click the row in the table or select the row and click Add, Edit or Delete.

- Profiles, which use the following settings
  - Interface Styles
  - Rating Scales (i.e., severity scale, occurrence scale and detection scale)
  - Risk Discovery Questions
Chapter 5: Configurable Settings

- **Risk Discovery Ratings**
- **FEC Logic** (only in RCM++ and RBI)
- **Task Logic** (only in RCM++ and RBI)
- **Phrase Sets**
- **Checklists**
- **Assumptions**
- **Surveys**

**Importing Settings from Another Database**

If you want to import settings from another database, first select the type of setting then click the **Import** button. If you import a profile, the application will also import copies of all related settings (i.e., the interface style, severity scale, etc.). (See **Importing Settings to a Library**.)

In addition, the **Copy Existing** button appears in many windows throughout the Profiles/Library Manager. This feature allows you to copy selected settings from another library to replace the ones in the current window. (See **Copy Existing**.)

**Active File and Reset Library**

When a standard database or Synthesis file (*.rsr11 or *.rsf11) is currently open, the **Reset Library** button will be displayed at the bottom of the window. This button restores the default file that was shipped with the software (Library.lb11) and makes it active for your computer/username. This will not replace whatever library currently exists. Rather, it will create a new standard library file in the ReliaSoft folder under My Documents on your computer (e.g., C:\Users\username\My Documents\ReliaSoft\Common) If a file with the name Library.lb11 already exists in this location, the new filename will have an increment at the end (e.g., Library_1.lb11).

**Importing Settings to a Library**

It is easy to import profiles and other settings (e.g., interface styles, rating scales, etc.) from another database. To do this, open the **Profiles/Library Manager window**, select the setting of interest from the navigation panel and then click the **Import** button.
In the Import to Library window, do the following:

1. Use the drop-down list or browse button (…) to select the library that you want to import from. This can be a standard library file (*.lb11) or an enterprise database connection file (*.rserp).

2. The table shows all of the applicable settings in the library that is currently selected. Use the check boxes to select which settings you wish to import.

3. Click **OK** to copy the data into your active library.

**Importing an Entire Profile**

When you select to import a profile, the application will also import all related settings (e.g., the interface style, severity scale, etc.). If settings with the same name already exist in the destination library, the application will import them anyway and increment the name(s).

If you prefer for the imported profile to use any of the settings that were already present in the destination library, you can edit the profile to link to the existing settings and then delete the duplicate settings that were imported.

*Tip:* If you need to import multiple profiles that reference some of the same settings (e.g., if they all use the same rating scales or risk discovery questions), we recommend to import all of the profiles at the same time in order to limit the amount of work that will be required to manually adjust the profiles and delete extra settings.

**Copy Existing**

The **Copy Existing** button appears in many windows throughout the Profiles/Library Manager. This feature allows you to select another library and copy selected settings to replace the ones in the current window. The following instructions explain how to copy an existing interface style. You can use a similar procedure for rating scales, risk discovery questions, etc.
1. Open an existing interface style and click the **Copy Existing** button at the bottom of the window.

![Copy Existing button](image)

2. In the Select window that appears, browse for the library file that contains the interface style you want to copy.

![Select library](image)

3. The table displays a list of the interface styles that have been predefined in the library that is currently selected. Double-click or select a row and click **OK**. This replaces all of the settings in the current interface style with the settings that were copied from the selected one.

Profiles

A **profile** is a collection of predefined settings that can be used to update all of the configurable settings for any project at the same time.

The Profiles page in the Profiles/Library Manager shows all of the predefined profiles in the active library.

- To add a new profile, click **Add**.
- To edit an existing profile, select the row and click **Edit** or double-click the row.

You can also add or edit a profile from the General page of Project Properties window, as shown next.

![Edit Profile](image)

Selecting the Default Profile

If you select the **Set this as the default profile** check box, the profile will be selected by default for each new project that you create when this library is active. Because only one profile can be the default at any given time, selecting this check box for one profile will have the effect of clearing it from the other profile that previously was the default.
Profile Settings
Each profile contains the following settings. For each type of setting, you can use the following menu to a) **Select** settings that have been predefined in the active library, b) **Add** new settings and/or c) **Edit** the predefined settings that are currently selected in the drop-down list.

- **General tab**
  - The **Interface Style** determines the data fields that will be enabled in the project, the options from configurable drop-down lists, the method of risk assessment, the order of the columns in analysis worksheets and other configurable preferences.
  - The **RPN Scales** will be used for any risk priority number (RPN) calculations in the project. For information about how to enable these rating scales for effect and cause records in the FMEA, see **FMEA > RPNs**. For information about how to create rating scales, see **Rating Scales**.
    - The **Severity Scale** can be enabled for effect records in the FMEAs.
    - The **Occurrence Scale** and **Detection Scale** can be enabled for cause records in the FMEAs.
  - The **Criticality Scales** will be used for any criticality analyses that you perform in the project. For information about how to enable these rating scales for failure records in the FMEAs, see **FMEA > Criticality**.
    - The **Severity Class** can use any of the predefined severity rating scales.
    - The **Failure Probability** can use any of the predefined occurrence rating scales.

- **Risk Discovery tab**
  For risk discovery analysis (e.g., preliminary risk analysis, change point analysis, equipment selection, etc.), you can choose to use either questions or ratings.
  - The **Risk Discovery Questions** method uses a series of yes/no questions.
  - The **Risk Discovery Ratings** method uses a set of factors and ratings that calculate a numerical value.
Tasks tab

In RCM++ or RBI only, the Tasks tab contains the settings for the logic diagrams used in traditional reliability centered maintenance (RCM) analysis.

- The **FEC Logic** will be used in the Failure Effect Categorization window for effect records.
- The **Task Selection Logic** will be used in the Maintenance Task Manager window for cause records.

**Note:** For any given profile, if you have chosen a task selection logic that presents different questions depending on the failure effect categorization then you must choose a failure effect categorization logic with the same number of categories. If the logics do not match, a message will be displayed when you attempt to save the profile.

Interface Styles

An *interface style* determines the data fields that will be enabled in the project, the options from configurable drop-down lists, the method of risk assessment, the order of the columns in analysis worksheets and other configurable preferences.

The Interface page in the Profiles/Library Manager shows all of the predefined interface styles in the active library.

- To add a new interface style, click **Add**.
- To edit an existing style, select the row and click **Edit** or double-click the row.

There are also several ways to edit the interface style for a particular project. Remember that changing the settings in an individual project does not automatically update the library or any other projects (Learn more...).

- Choose **Project > Management > Configurable Settings > Interface Style**.
- Click the **Edit** icon on the Configurable Settings tab of the Project Properties window.
Click any of the **Configurable Settings** icons that are available in FMEA record properties windows.

Viewing or Editing Settings
The navigation panel on the left lists the properties and other options that can be customized via the interface style. The table on the right allows you to view or edit the settings that are currently selected. The appearance of each page will differ depending on what can be customized. Each type of interface is discussed in the sections that follow.

- Customizing Record Properties
- Modifying Drop-Down Lists
- Reordering Worksheet Columns
- Configuring Risk Assessment Settings
  - FMEA > RPNs
  - FMEA > Criticality
- Configuring Synchronization Preferences
  - FMEA > Sync Options
  - Control Plan > Sync Options
  - DVP&R > Sync Options
Customizing Record Properties

For many types of records, you have the option to choose which properties will be enabled and what they will be called. All of the available properties will be displayed in a table like the one shown next:

<table>
<thead>
<tr>
<th>Property</th>
<th>Type</th>
<th>Enabled</th>
<th>Display Name</th>
<th>Tooltip</th>
</tr>
</thead>
<tbody>
<tr>
<td>CauseDescription</td>
<td>Text (2000)</td>
<td>*Yes</td>
<td>Cause</td>
<td>List the potential cause(s) for each failure. This should be the “actionable” level of the analysis, which is the level of causation at which corrective actions and/or controls could effectively be a...</td>
</tr>
<tr>
<td>Detection Method</td>
<td>Text (150)</td>
<td>No</td>
<td>Detection Method</td>
<td>Describe the mechanisms that are in place to detect the failure cause.</td>
</tr>
<tr>
<td>Compensating Provisions</td>
<td>Text (150)</td>
<td>No</td>
<td>Compensating Provisions</td>
<td>Describe the mechanisms that are in place to compensate if the failure cause occurs.</td>
</tr>
<tr>
<td>Classification</td>
<td>Drop-Down</td>
<td>Yes</td>
<td>Classification</td>
<td>Use this column to identify and classify characteristics that require special manufacturing control, e.g. Critical, Significant, Key Leading, etc.</td>
</tr>
</tbody>
</table>

- **Property** is the basic name for the field. This cannot be changed.
- **Type** indicates whether the field contains text, a date, a number or a drop-down list.
  - If text, the number in parentheses indicates the maximum number of characters.
  - If a drop-down list (and if the property is enabled), you can click the **Edit** icon to view or edit the options that appear in the list.
- **Enabled** indicates whether the field will be enabled in the interface and report output. Click inside the cell to toggle between Yes and No. An asterisk (*) indicates that the field cannot be disabled.
- **Display Name** is the name that will appear in the interface and report output. This can be changed to whatever fits your needs.
- **Tooltip** is a short statement that will be displayed when a user holds the mouse over the field in a table or worksheet. This can be changed to whatever fits your needs.

[![Clear Tooltips](image)](image) deletes all of the tooltips from all of the properties in the current interface style.
Option to Disable Controls or Actions
On the FMEA > Controls page and the FMEA > Actions page, an additional option will be displayed above each properties table.

- If you clear the Enable Controls for Causes check box, all controls-related functionality will be disabled within the project. The properties table will be disabled because these settings are not applicable for this interface style.

- If you clear the Enable Actions for Causes check box, the actions-related functionality in FMEAs will be disabled within the project. However, the properties table will remain enabled because these settings will still be used for action records in the Project Planner and the My Portal window.

Modifying Drop-Down Lists
The Modify Drop-Downs window allows you to customize any of the drop-down lists that can be enabled via the interface style.

- If you want to edit one particular list, click the Edit icon in the Type column in the record properties table.

- If you want to edit all of the drop-down lists that are currently enabled in the interface style, click the Modify Drop-Downs button at the bottom of the interface style window.

For most of the drop-down lists, you can simply type inside the table and use the buttons to Delete Row, Insert Row or Move Up/Move Down. For the certain fields that can be enabled for process flow diagram (PFD) worksheets, an additional step is required as described next.

Define PFD Symbols Images
For the Operation Type and Operation Type Symbol fields that can be enabled for PFD worksheets, you will need to select an image to represent each option type.
To customize the list of available images, click the **PFD Symbols** button at the bottom of the Modify Drop-Downs window. This opens the Define PFD Symbols Images window, as shown next. (This picture shows Xfmea, but it works the same in RCM++ and RBI.)

![Define PFD Symbols Images](image)

- To add an image, click the **Add** button and select a file. The available formats are *.png, *.bmp, *.dib, *.gif, *.jpg, *.wmf and *.emf. The file name and image appear in the window.
- To delete an image, click the image and then click **Delete**.

**Worksheet Columns**

For many of the analyses that use a worksheet (including FMEAs, PFD worksheets, DVP&Rs and DRBFMs), the **Worksheet Columns** page of the interface style allows you to specify the order in which the property columns will be displayed. These preferences will be saved with the project so the column order will be the same for all users who view the analysis.
Chapter 5: Configurable Settings

The table shows all of the properties for that type of analysis that are currently enabled in the interface style (using the display name that has been specified in the record properties table(s)). You can use the arrows to move a selected property up or down in the list.

![Worksheet Columns]

**FMEA > RPNs**
The FMEA > RPNs page of the interface style allows you to customize properties and functionality related RPNs and related metrics for failure causes in an FMEA. (To configure the Item Risk metrics for items in the system hierarchy, use the Item > Properties page instead.)

**RPN Properties and Metrics**
The table at the top of the page works like the other record properties tables except:

- The metrics can be enabled only if the applicable rating scales are enabled. For example, if you disable the Initial Severity property, the Initial RPN will be disabled automatically.

- **Initial Risk Ranking** and **Revised Risk Ranking** can be enabled only if you have selected to highlight priority based on "Risk Ranking" as discussed below.

- **Short Display Name** specifies the abbreviation that will be used in some locations within the interface, plots and/or report output where the full display name will not fit.

**Priority Highlights**
The options under the table allow you to configure the logic that will be employed when a user turns on the priority highlights feature (**FMEA > Tools > Highlight Priority**) for FMEAs within the project.
In the **Highlight Priority Based on** area, the options will depend on which ratings and metrics have been enabled in the properties table. For example, if you have disabled the Initial RPN and Revised RPN properties, you can't choose to highlight based on RPN.

If you select RPN, Severity, Occurrence or Detection, you can specify the **High Priority >=** and **Low Priority <=** thresholds and **Select Highlight Colors**.

For example, with the settings shown below:

<table>
<thead>
<tr>
<th>Highlight Priority Based on</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>RPN</td>
<td></td>
</tr>
<tr>
<td>High Priority &gt;= 300</td>
<td></td>
</tr>
<tr>
<td>Low Priority &lt;= 30</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Select Highlight Colors</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>High Priority</td>
<td></td>
</tr>
<tr>
<td>Medium Priority</td>
<td></td>
</tr>
<tr>
<td>Low Priority</td>
<td></td>
</tr>
</tbody>
</table>

- Causes that do not have a calculated RPN will not be highlighted
- Causes with an RPN equal to or greater than 300 will be highlighted with red
- Causes with an RPN from 31 to 299 will be highlighted with yellow
- Causes with an RPN equal to or less than 30 will be highlighted with green

**Risk Ranking Logic**
If you want to define more complex criteria to assign priority, click the **Risk Ranking Logic** button.

This logic can be used for **Priority Highlights in FMEAs** if you select "Risk Ranking" under **Highlight Priority Based on**. It can also be used for assigning **Item Risk** in the system hierarchy and for applying highlight colors in the **Risk Matrix**. For more details, see **Risk Ranking Logic**.

**FMEA > Criticality**
The FMEA > Criticality page of the **interface style** allows you to customize properties and functionality related to quantitative or qualitative criticality analysis.

**Criticality Properties**
The table at the top of the page works like the other **record properties** tables except:

- **Short Display Name** specifies the abbreviation that will be used in some locations within the interface and/or report output where the full display name will not fit.
Chapter 5: Configurable Settings

- At least one of these properties must be enabled if you want to perform Criticality Analysis.

**Criticality Matrix Priority Highlights**

The settings at the bottom of the page allow you to customize the priority highlight colors that will be added to any quantitative or qualitative criticality matrix reports that you generate.

Do the following:

1. Click the **Preview** button to create a sample matrix, and then use the drop-down lists to specify the size of the matrix that you will be creating for criticality analyses in this project. For example, if you have configured the project to use the criticality rating scales from MIL-STD-1629A (a five-point scale for Failure Probability and a four-point scale for Severity Class):
   - The qualitative criticality matrix report will be 5 x 4 (i.e., Failure Probability on the vertical axis and Severity Class on the horizontal axis).
   - The quantitative criticality matrix will be 10 x 4 (i.e., calculated criticality on the vertical axis and Severity Class on the horizontal axis).
The following picture shows a sample for the MIL-1629A qualitative matrix. Note that the software has assigned a value to each cell such that the smallest number appears in the bottom left corner and the largest number appears in the top right corner. It has also applied the highlight colors based on the thresholds that are currently specified (in this case, .6 for high priority and .4 for medium priority). (This picture shows Xfmea, but it works the same in RCM++ and RBI.)

2. If you are not satisfied with the highlights that are shown in the sample, use the numbers in the cells to determine how the threshold values should be changed. For example, in the sample matrix shown above, if you wanted the top left corner of the matrix to be highlighted as medium instead of low priority, you would need to set the medium priority threshold to .25 instead of .4.

3. Return to the FMEA > Criticality page and enter the new threshold values. Each number must be greater than zero and less than or equal to 1. In addition, the High Priority Threshold must be larger than the Medium Priority Threshold.
4. Click the **Preview** button and set the matrix size again, then check to see if the new threshold values will result in the desired highlight pattern. For example, the following picture shows a new preview for a 5 x 4 matrix in which the high priority threshold has been changed to .5, and the medium priority threshold has been changed to .25. (This picture shows Xfmea, but it works the same in RCM++ and RBI.)

![Criticality Matrix Example](image)

5. You can repeat this process as many times as needed until you’re able to confirm that the specified threshold values will result in the highlight pattern you prefer for criticality matrix reports.

**FMEA > Sync Options**

The FMEA > Sync Options page of the interface style determines how FMEA functions will be created when a new FMEA is added to an analysis. Select one of the following options:

- Select **None** to not create any default functions.
- Select **Create functions from PFD worksheet operations** to use the operation descriptions in the PFD worksheet as functions in the FMEA.
- Select **Create functions from system hierarchy item** to use the name of the system hierarchy item as functions in the FMEA.
- Select **Create functions from system hierarchy item and dependents** to use the names of the system hierarchy and its dependents as functions in the FMEA.
Control Plan > Sync Options

The Control Plan > Sync Options page of the interface style determines how control plan data will be created when a new control plan is added to an analysis.

You can start a control plan with a blank worksheet or with data imported from either FMEAs or a PFD worksheet. Below are descriptions of the options available for FMEAs and PFD worksheets.

FMEA

In the Map Records for Transfer area, select which data to transfer as process names and cause descriptions in the control plan:

- In the Part/Process list: If you stored descriptions of the process in the system hierarchy, select the Transfer from Items option; if the descriptions are stored as functions in the FMEA, select the Transfer from Functions option.

- In the Characteristic list, specify whether the cause records are more likely to be product characteristics or process characteristics. Your selection determines which column the data will be transferred to. If your cause records do not have data that would be a good starting point for defining the characteristics in the control plan, then you could leave the characteristic records blank.

In the Transfer Controls Options area, select the All controls option to transfer all the controls from the FMEA to the control plan. To transfer only the controls that meet the desired requirements, select the Controls where type= option and then select the required control type from the drop-down list.
Chapter 5: Configurable Settings

**PFD Worksheet**

- Choose **Transfer product and process characteristics to separate rows** to transfer all the classifications that were defined in the PFD worksheet, as in the following example (where C1 is the classification of the product characteristic and C2 is the classification of the process characteristic):

  ![Example of product and process characteristics transferred to separate rows.](image)

- Choose **Transfer to same row and use the process characteristics classification** to transfer only the classifications of the process characteristics, as in the following example:

  ![Example of product and process characteristics transferred to the same row.](image)

**DVP&R > Sync Options**

The DVP&R > Sync Options page of the interface style determines how FMEA data will be transferred to new DVP&Rs.

If the **Integrate New DVP&Rs with FMEA** check box is selected, data will be transferred automatically from the FMEA when you add a new DVP&R for an item that already has an
FMEA. If the check box is not selected, data will not be transferred automatically and the new DVP&R worksheet will be blank.

As described in Sync Options for New DVP&Rs, when you choose to transfer data automatically from the FMEA to the DVP&R, the software will create new Test Plan records in the DVP&R by transferring control descriptions from the FMEA. In addition, you have the option to:

- Create new Test Plan records in the DVP&R by transferring control and/or action descriptions from the FMEA.
  - If the Control Category property is enabled for the project (from the FMEA > Controls page of the interface style) or if the Controls where type = field is empty, then all controls descriptions will be transferred to the DVP&R. If the Control Category property is enabled, you can use the Controls where type = field to limit the transfer to only those controls descriptions with the specified categories. To define multiple control categories, use commas to separate the labels.
  - If the Action Category property is enabled for the project (from the FMEA > Actions page of the interface style) or if the Actions where category = field is empty, then all action descriptions will be transferred to the DVP&R. If the Action Category property is enabled, you can use the Actions where category = field to limit the transfer to only those action descriptions with the specified categories that you select. To define multiple action categories, select multiple items. Or you can select the No actions option to not transfer any actions.
  - Transfer the cause description along with each control or action description. For example, if the Incorporate cause description with controls and actions transferred to DVP&R check box is selected and the cause description in the FMEA is "Failure cause" and the control description is "Design control" then the transferred test plan will be "Design control : Failure cause."

**Rating Scales**

Severity, occurrence and/or detection rating scales can be used in either of the risk assessment methods: risk priority numbers or criticality analysis. These scales can contain any number of ratings (e.g., five-point scale, ten-point scale, etc.), and you can fully customize the values, descriptions and criteria.

The Severity, Occurrence and Detection pages in the Profiles/Library Manager show all of the predefined rating scales in the active library.

- To add a new rating scale, click Add.
Chapter 5: Configurable Settings

- To edit an existing scale, select the row and click **Edit** or double-click the row.

There are also several ways to edit the rating scales for a particular project. Remember that changing the settings in an individual project does not automatically update the library or any other projects (Learn more...).

- **Choose Project > Management > Configurable Settings > [Severity/Occurrence/Detection].**
- **Click one of the Edit icons on the Configurable Settings tab of the Project Properties window.**

![FMEA Scales](image)

**Editing a Scale**

- **Each Value** must be unique within the scale and the values can be whole numbers or decimals. The software will order the numbers from smallest to greatest when you save the scale.

- **Description** specifies the short text description that will be associated with the numerical rating in the drop-down lists within the interface.

- **Criteria 1** and **Criteria 2** specify longer text descriptions of the criteria that can be used to determine whether the rating will be assigned to a particular issue. This information will be visible when the user clicks the drop-down list for each rating scale in an FMEA.

**Quantitative Values**

If you are working with an Occurrence or Failure Probability scale, this window will also display an **Occurrence Probability** column and a **Treat Occurrence Probability As** area. These settings apply if you want to use the qualitative rating assigned to a record to set that record's quantitative probability of failure model. The model can then be used for reliability or criticality calculations in the FMRA. (See **Using Rating Scales to Set the Reliability Policies**.)
Risk Discovery Questions
For risk discovery analysis (e.g., preliminary risk analysis, change point analysis, equipment selection, etc.), you can choose to use either questions or ratings.

The risk discovery questions method uses a series of yes/no questions.

The RD Questions page in the Profiles/Library Manager shows all of the predefined sets of risk discovery questions in the active library.

- To add a new set of questions, click Add.
- To edit an existing set of questions, select the row and click Edit or double-click the row.

If you want to view/modify the risk discovery questions for a particular project:

- Choose Project > Management > Configurable Settings > RD Questions.
- Click the Edit icon on the Configurable Settings tab of the Project Properties window.

Remember that changing the settings in an individual project does not automatically update the library or any other projects (Learn more...). Also note that these options will be disabled if you have selected to use ratings rather than questions for the current project.

Editing a Set of Risk Discovery Questions
- **Label** - a short text string (up to 50 characters) that summarizes the issue.
- **Question** - a longer text string (up to 255 characters) that contains a question that can be answered with Yes or No.

To edit any existing entry, simply type directly in the table cell.

To add or delete a question, click inside an appropriate cell and then use the buttons under the table.

To import a set of questions that have already been defined in another project or library, click Copy Existing.
Risk Discovery Ratings

For risk discovery analysis (e.g., preliminary risk analysis, change point analysis, equipment selection, etc.), you can choose to use either questions or ratings.

The risk discovery ratings method uses a set of factors and ratings that calculate a numerical value. New in Version 11, you can specify how the ratings will be calculated.

The RD Ratings page in the Profiles/Library Manager shows all of the predefined sets of risk discovery ratings in the active library.

- To add a new set of ratings, click Add.
- To edit an existing set of ratings, select the row and click Edit or double-click the row.

If you want to view/modify the risk discovery ratings for a particular project:

- Choose Project > Management > Configurable Settings > RD Ratings.
- Click the Edit icon on the Configurable Settings tab of the Project Properties window.

Remember that changing the settings in an individual project does not automatically update the library or any other projects (Learn more...). Also note that these options will be disabled if you have selected to use questions rather than ratings for the current project.

Editing a Set of Risk Discovery Ratings

The Calculation Methods area specifies how the rating will be calculated for each category defined in the table and for the item overall.

- **Item** - the software calculates the overall rating for the item by obtaining the sum, product, max or average of the category ratings.

- **Category** - the software calculates the rating for each category by obtaining the sum, product, max or average of the factors in that category. If you select "Define for each," the table provides an additional column to specify the calculation method for each category.
Using a simplified example, the following settings would calculate the Safety rating (Potential for Injury x Severity of Injury) and the Maintenance Rating (Downtime + Repair Costs), and then calculate the overall Item rating as Safety + Maintenance.

To edit any existing entry, simply type directly in the table cell.

To add or delete a category, factor or option, click inside an appropriate cell and then use the buttons under the table. For example, if you want to add another option above "Moderate" in the "Repair Costs" rating scale, click inside any of the three cells for that option and then click Insert Option to insert a new row above.

To import a set of ratings that have already been defined in another project or library, click Copy Existing.

Phrase Sets

A phrase set contains lists of predefined descriptions that can be used to define any of the text-based record properties in an FMEA. The descriptions in a phrase set are accessible via the Select Existing Text window when the phrase set has been selected to be "active" from the window’s Phrase Sets page.
Chapter 5: Configurable Settings

The Phrase Sets page in the Profiles/Library Manager shows all of the sets of predefined phrases in the active library.

- To add a new phrase set, click Add.
- To edit an existing phrase set, select the row and click Edit or double-click the row.

**Note:** Unlike many of the other settings stored in the active library and managed via the Profiles/Library Manager, the descriptions in a phrase set are not stored in the project properties for individual analysis projects. Rather, you can use any phrase set from the active library on your computer for any analysis project that you may be working on, and it is possible to use phrases from multiple different phrase sets in the same project.

You can use any or all of the following methods to create/update phrase sets.

- **Type phrases into the tables**
- **Import phrases from Excel**
- **Export FMEA descriptions to phrase sets**

**Type Phrases Into the Tables**
The navigation panel on the left side of the Edit Phrase Set window shows the types of records for which you can save phrases. The table on the right allows you to view/edit/add phrases for the record type that is currently selected.

Note that the columns show the basic names for all of the possible fields (i.e., the tables are not customized based on the display name and enabled/disabled preferences in a particular interface style). You can ignore any record types and/or record properties that you don’t want to save phrases for.

**Import Phrases from Excel**
When you click the Import from Excel or Export to Excel buttons, the software will import or export the descriptions in the phrase set from/to the Excel file.

**Note:** When importing from an Excel file, this functionality adds unique descriptions only and appends them to the phrase set. For example, if the existing phrase set contains a failure cause called "Excessive condensation" and so does the Excel file that is being imported from, the phrase will not be duplicated.
Exporting FMEA Descriptions to Phrase Sets

You can export the descriptions from an existing FMEA to a new or existing phrase set in the active library. Do the following:

1. Open the FMEA.
2. Choose FMEA > Tools > Export to Phrase Set > [Export to a New/Existing FMEA Phrase Set].
   
   a. If you choose to export to a new phrase set, you will be prompted to enter the name (required) and description.
   
   b. If you choose to export to an existing phrase set, you will be prompted to select one of the phrase sets from the active library.

Note: This functionality adds unique descriptions only. For example, if the existing phrase set contains a failure cause called "Excessive condensation" and so does the FMEA analysis that is being exported, the phrase will not be duplicated.

FEC Logic

The FEC logic determines the questions and categories that will be displayed in the Failure Effect Categorization window for effect records. This is used for performing traditional reliability centered maintenance (RCM) analysis.

The FEC Logic page in the Profiles/Library Manager shows all of the predefined FEC logic diagrams in the active library.

- To add a new logic, click Add.
- To edit an existing logic, select the row and click Edit or double-click the row.

There are also several ways to edit the FEC logic for a particular project. Remember that changing the settings in an individual project does not automatically update the library or any other projects (Learn more...).

- Choose Project > Management > Configurable Settings > FEC Logic.
Chapter 5: Configurable Settings

- Click the **Edit** icon on the Configurable Settings tab of the Project Properties window.

**Editing the FEC Logic**

The first step is to choose the logic tree configuration from the drop-down list at the top of the window. Then you can type directly in the text boxes that are displayed. Each question can contain up to 255 characters and each category must have a label (up to 50 characters) and an abbreviation (up to 5 characters).

To import a logic tree that has already been defined in another project or library, click **Copy Existing**.

**Available Tree Configurations**

- **4 Categories** allows you to define three questions that lead to four FEC categories.

  ![Diagram of 4 Categories](http://xfmea.reliasoft.com)

- **5 Categories (Split in Yes Branch)** allows you to define four questions that lead to five FEC categories. If the user answers "yes" to the first question and "no" to the second question, there will be a third question in that branch before the category is assigned.

  ![Diagram of 5 Categories (Split in Yes Branch)](http://xfmea.reliasoft.com)
• **5 Categories (Split in No Branch)** allows you to define four questions that lead to five FEC categories. If the user answers "no" to the first question and "no" to the second question, there will be a third question in that branch before the category is assigned.

![Diagram of 5 Categories (Split in No Branch)](image)

• **6 Categories (Split in No Branch)** allows you to define five questions that lead to six FEC categories.

![Diagram of 6 Categories (Split in No Branch)](image)

### Task Logic

**RCM++ & RBI Only**

The *task selection logic* determines the questions that will be displayed in the *Task Manager window* for cause records. This is used for traditional reliability centered maintenance (RCM) analysis.

The Task Logic page in the *Profiles/Library Manager* shows all of the predefined task selection logics in the active library.

- To add a new logic, click *Add*.
- To edit an existing logic, select the row and click *Edit* or double-click the row.

There are also several ways to edit the task selection logic for a particular project. Remember that changing the settings in an individual project does not automatically update the library or any other projects (Learn more...).

- Choose *Project > Management > Configurable Settings > Tasks Logic.*
Click the Edit icon on the Configurable Settings tab of the Project Properties window.

### Editing the Task Logic

The first step is to specify whether the task selection questions will depend on the failure effect categorization (FEC) that has been assigned to the associated effect.

If you select **Same Questions for All FEC**, there will be a single table for defining the questions. The analysis will always consider the same types of maintenance tasks regardless of the consequences of failure.

If you select **Specific Questions for Each FEC in Selected Logic**, two additional drop-down lists will become enabled so you can define a separate set of questions for each effect categorization:

- Use the first drop-down list to specify the number of categories in the FEC logic that this task selection logic is planned to be used with (i.e., 4 categories, 5 categories or 6 categories).
- Use the second drop-down list (labeled FEC) to choose which set of questions will be currently displayed in the table.

Each table contains the following columns:

- **#**: Displays the numeric or alphanumerical label used to identify the question. This can contain up to 5 characters (e.g., 1, 2, 3, .... or 1A, 1B, 1C, ... etc.).
- **Question**: Displays the question. This can be up to 255 characters.

To edit any existing entry, simply type directly in the table cell.

To add or delete a question, click inside an appropriate cell and then use the buttons under the table.

To import a set of task selection questions that have already been defined in another project or library, click **Copy Existing**.
Checklists

A checklist contains a list of activities that need to be performed during an analysis project. You can copy a checklist from the active library to any analysis plan in a software project.

**Note:** Unlike many of the other settings stored in the active library and managed via the Profiles/Library Manager, the checklists are not stored in the project properties for individual analysis projects. Rather, you can use any checklist from the active library on your computer for any project that you may be working on, and it is possible to use different checklists for different analysis plans in the same project.

The Checklists page in the Profiles/Library Manager shows all of the sets of predefined checklists in the active library.

- To add a new checklist, click Add.
- To edit an existing checklist, select the row and click Edit or double-click the row.

Editing a Checklist

To edit any existing entry, simply type directly in the table cell.

To add or delete a description, click inside an appropriate cell and then use the buttons under the table.

To import a checklist that has already been defined in another project or library, click Copy Existing.

Assumptions

The ground rules and assumptions are a list of the information that all members of the analyses team will use to make judgments with in an analysis project. You can copy the assumptions from the active library to any analysis plan in a software project.

**Note:** Unlike many of the other settings stored in the active library and managed via the Profiles/Library Manager, the assumption lists are not stored in the project properties for individual analysis projects. Rather, you can use any assumption list from the active library on your computer for any project that you may be working on, and it is possible to use different assumption lists for different analysis plans in the same project.
Chapter 5: Configurable Settings

The Assumptions page in the Profiles/Library Manager shows all of the sets of predefined assumption lists in the active library.

- To add a new assumption list, click Add.
- To edit an existing assumption list, select the row and click Edit or double-click the row.

Editing an Assumption List
To edit any existing entry, simply type directly in the table cell.

To add or delete a description, click inside an appropriate cell and then use the buttons under the table.

To import an assumption list that has already been defined in another project or library, click Copy Existing.

Surveys
A survey contains a list of requirements that are believed to influence the success of an analysis project. You can copy a survey from the active library to any analysis plan in a software project.

Note: Unlike many of the other settings stored in the active library and managed via the Profiles/Library Manager, the surveys are not stored in the project properties for individual analysis projects. Rather, you can use any survey from the active library on your computer for any project that you may be working on, and it is possible to use different surveys for different analysis plans in the same project.

The Surveys page in the Profiles/Library Manager shows all of the sets of predefined surveys in the active library.

- To add a new survey, click Add.
- To edit an existing survey, select the row and click Edit or double-click the row.

Editing a Survey
To edit any existing entry, simply type directly in the table cell.

To add or delete a category, click inside an appropriate cell and then use the buttons under the table.

To import a survey that has already been defined in another project or library, click Copy Existing.
Converting Prior Version Libraries

Converting Libraries and Profiles from Version 5
If you have customized the configurable settings in your Xfmea/RCM++ 5 library, you can automatically convert them for use in the new version. This topic describes:

- How to import an entire library or selected profiles from a Version 5 standard library file (*.lb5).
- How to import library settings from a Version 5 Enterprise database.
- The new configurable settings that will be added to support new features that were added in the Synthesis Version. (You may need to modify the default options for these new settings after the profile(s) have been converted.)

Converting Standard Library Files (*.lb5)
If you have an existing Xfmea/RCM++ 5 standard library file (*.lb5), you can convert the entire library or just convert and import selected profiles.

To convert the entire library:

1. Open any standard database in the Synthesis version of Xfmea, RCM++ or RBI.
2. Choose File > Manage Repository > Profiles/Library Manager.
3. In the Profiles/Library Manager, click the Browse button in the top-right corner and choose Xfmea 5/RCM++ 5 Library (*.lb5) from the Files of type drop-down list, then select the file you want to convert.
4. Click Open and, when prompted, confirm that you want to proceed.

The application will create a new standard library file in the same directory with the extension *.lb11; the existing *.lb5 file will remain unchanged.

To convert and import only selected profile(s):

2. Choose File > Manage Repository > Profiles/Library Manager.
3. Select Profiles in the navigation panel and then click Import.
4. In the Import Profiles to Library window, use the drop-down list or browse button at the top of the window to select the file you want to import from.
Chapter 5: Configurable Settings

5. The table shows the profiles that have been defined in the selected library. Select the profile you wish to import and click OK.

The application will import the profile and all of the associated settings (e.g., the interface style, severity scale, etc.). If settings with the same name already exist in the destination library, the application will import them anyway and increment the name(s). (See Import Settings to a Library.)

Converting an Enterprise Database Library
To convert and import library settings from an Xfmea/RCM++ 5 enterprise database, you must have both of the following permissions:

- The "Admin" access level in the Version 5 database.
- The "Manage all projects" and "Manage users and logins" permissions in the Synthesis repository.

There are two ways to import the data. If you want to import the entire library, including settings that are not directly associated with a profile (e.g., phrase sets, checklists, project plan templates, etc.), you must use the Import from Version 5 method described below. If you want to import selected profiles, you can use this method or the Import Profiles to Library method described above.

To use the Import from Version 5 method:

1. Connect with the enterprise database you want to import into.
2. Choose File > Manage Repository > Import from Version 5.
3. In the area at the top of the Import from Version 5 Enterprise Database window, enter the connection information for the Version 5 enterprise database and click Connect.
4. The table shows all of the data and settings that are available to be imported. Find the Profiles heading.
   - If you select the Profiles check box, application will import the entire library, including settings that are not directly associated with a profile.
   - If you select individual profiles, the application will import only the selected profiles and the settings that are directly used by those profiles.
5. Click OK to copy the data.
Converting Configurable Settings from Version 5

When you convert an existing library profile from Xfmea/RCM++ 5, the application will add new configurable settings for new features that were added in the Synthesis version. Likewise, when you convert an existing project, its configurable settings will be updated in the same way.

Here is a summary of the settings that will be added, modified or changed:

<table>
<thead>
<tr>
<th>Setting Type</th>
<th>Page</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interface</td>
<td>FMEA &gt; Functions</td>
<td>New <strong>Op Seq Number</strong> field, which can be used to add a reference number to a function. In synchronized worksheets, the op seq number is also used to link a function to a particular item in the associated PDF worksheet or Control Plan worksheet.</td>
</tr>
<tr>
<td>Tasks &gt; Properties (RCM specific)</td>
<td></td>
<td>Many of the properties that were in the FMEA &gt; Tasks page are now configured as part of the task resources. (See Task Properties.) The task properties that apply only in RCM++/RBI can be configured via the new <strong>Tasks &gt; Properties (RCM specific)</strong> page.</td>
</tr>
<tr>
<td>FMEA &gt; Sync Options</td>
<td></td>
<td>New options for creating FMEA functions from system hierarchy items or PFD worksheet operations.</td>
</tr>
<tr>
<td>FMEA &gt; Criticality</td>
<td></td>
<td>The Probability of Loss field was removed and is now generated from the FMRA.</td>
</tr>
<tr>
<td>Control Plan &gt; Sync Options</td>
<td></td>
<td>New options for synchronizing from the PFD Worksheet.</td>
</tr>
<tr>
<td>DVP&amp;R &gt; Sync Options</td>
<td></td>
<td>New options for separately synchronizing controls and actions.</td>
</tr>
<tr>
<td>PFD Worksheet</td>
<td></td>
<td>Added properties for the new PFD Worksheet functionality.</td>
</tr>
</tbody>
</table>
Chapter 5: Configurable Settings

<table>
<thead>
<tr>
<th>Occurrence Scale</th>
<th>Properties</th>
<th>New Quantitative Value column and options for automatically creating failure models based on the RPN occurrence ratings.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Task Logic</td>
<td>Properties</td>
<td>Some of the task properties were removed because they are now part of the task resources.</td>
</tr>
</tbody>
</table>

Upon conversion, the application will apply default values for all of the new settings. It is important to note that these defaults may need to be modified after the conversion if you plan to use the Quantitative Value setting in the FMRA calculations for the converted project. This is because the application is not able to interpret the numerical thresholds (if any) recorded in the Criteria descriptions, and therefore it must apply the same values for all converted rating scales.

For example, the following table shows part of the occurrence scale from the "DFMEA: AIAG-4" profile. As you can see, the default values that would be applied if you convert this rating scale from Version 5 would need to be changed to more appropriate values that match the thresholds specified in the text descriptions. For example, 1 in 1,000,000 vehicles is 0.000001, and so on.

<table>
<thead>
<tr>
<th>Rating</th>
<th>Criteria</th>
<th>Quantitative Value</th>
<th>Quantitative Value</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>These are the values that will be applied to all scales by default upon conversion.</td>
<td>These are more appropriate values that match the criteria in this particular scale.</td>
</tr>
<tr>
<td>1 - Very Low</td>
<td>Failure is eliminated through preventive control.</td>
<td>0.000001</td>
<td>0.0000001</td>
</tr>
<tr>
<td>2 - Low</td>
<td>&lt;=0.001 per thousand items/vehicles, 1 in 1,000,000</td>
<td>0.000010</td>
<td>0.000001</td>
</tr>
<tr>
<td>3 - Low</td>
<td>0.01 per thousand items/vehicles, 1 in 100,000</td>
<td>0.000100</td>
<td>0.000010</td>
</tr>
</tbody>
</table>
When feasible, the most efficient and consistent way to apply these updates is to first obtain a fully updated profile in the Profiles/Library Manager and then use this profile to re-apply the settings for each converted project. Specifically, you will need to do the following:

1. Decide which library you will use and then confirm that the new settings are fully updated for all active profiles in the library:
   - If you had not customized any of the predefined profiles in the Version 5 library, we recommend using the new default library provided with the Synthesis version because it has appropriate values for the new settings (e.g., quantitative values that match any numerical criteria specified in the occurrence rating scales).
   - If you had created your own custom profiles in Version 5 or customized any of the predefined ones, we recommend converting the existing library and then reviewing/updating all of the new settings that were added during the conversion.

2. Convert one or more existing projects from Version 5.

3. For each converted project:
   - Choose Project > Management > Edit Project Properties.
   - On the General page of the Project Properties, choose the appropriate profile from the Select Profiles from Library drop-down list.
   - Click OK to reset all of the project's configurable settings based on the fully updated profile defined in the library.

Of course, you also have the option to review and manually update the configurable settings for any particular project, if desired. These are accessible from the Configurable Settings pages in the Project Profiles window, and also from Project > Management > Configurable Settings.
Chapter 6: System Hierarchy

In Xfmea, RCM++ and RBI, the flexible system hierarchy allows you to manage large, multi-level system configurations with as many levels as you need and any number of items per level. You can fully define the properties for each item (e.g., supplier, part number, expected operating environment, etc.) and perform relevant analyses for selected items.

For RCM and FMEA analyses, the hierarchy will consist of systems, subsystems and components, and you can perform a variety of analyses at any level in the configuration. (See Building the System Hierarchy.)

For RBI analyses, you also have the option to define systems, subsystems and components. However, the risk based inspection analysis can be performed only for specialized items that represent specific equipment and component types that are addressed in the API RP 580/1 guidelines. (See Building the RBI System Hierarchy.)
System Hierarchy Filtered View

On the Filtered View tab of the System panel, you can also select or create an item filter to find and focus on the specific items of interest.

System Hierarchy Columns

To hide or display system hierarchy columns, or change the column order, right-click the column headings then click Customize Columns. (You can also change the column order by dragging and dropping column headings into the desired positions.) These settings are stored per computer/username in the System Hierarchy page of the Application Setup. Any project that you open on this computer will have the same columns displayed, but other users may have different display preferences.

The following columns are available:

- **#** displays the record position number assigned by the software based on the position of the item in the system hierarchy. For example, if you insert a new item above an existing item, then the new item will take the number of the existing item and all items below it will be renumbered. Likewise, if you delete an item, all items below it will be renumbered automatically.

- **Name** displays the item name. This is a required field, and it is specified on the Properties tab of the Analysis panel.
• **Component Type**  
  This is relevant only for Component items in a risk based inspection analysis and indicates the type of component (which determines the analysis method that will be used).

• **Area Risk (Plan Date) and Financial Risk (Plan Date)**  
  These are relevant only for Component items in a risk based inspection analysis and indicate the risk priority that has been calculated from the RBI analysis. As discussed in more detail in **RBI Results**, the "Plan Date" is the next date when the component is scheduled to undergo major maintenance or replacement. The "Area Risk" represents the risk to the surrounding area assuming that you do not schedule any inspections prior to the plan date, while the "Financial Risk" represents the financial consequences.

• **Record ID** displays a unique identifier assigned by the software. The record ID is unique among all system hierarchy items that are defined in the database. It can also be used in the **Query Utility** to help identify a specific item that may share the same name with another item.

• **User Access** displays status indicator when the record is in use (🔒) or when it is restricted to selected users (🔒).

• **XFRACAS Associated Hierarchy Item** is available for enterprise databases only. It indicates that the item is associated with an XFRACAS hierarchy item. If an association exists, future changes made to the item and/or its failures and causes in XFRACAS can be brought into the software by synchronizing the data.

• **Reference Number** displays the reference number associated with the item. To display this column in the current project, the field must be enabled on the Item > Properties page of the interface style. The number is specified on the Properties tab of the Analysis panel.

  **Tip:** If you wish to automatically generate reference numbers (e.g., 1.2.1) for all items based on their positions in the hierarchy, choose **System Hierarchy > Tools > Renumber All Items** and then select the **Apply to reference number field** check box. **This cannot be undone.**

• **Part Number** displays the part number associated with the item. To display this column in the current project, the field must be enabled on the Item > Properties page of the interface style. The number is specified on the Properties tab of the Analysis panel.

• **FMEA Document Number** displays the document number for the local FMEA associated with the item, if any. To display this column in the current project, the field must be enabled on the FMEA > Header page of the interface style. This number is specified on the **Header tab** of the FMEA, if there’s an FMEA defined for the item.
• **Attachment** displays a paper clip icon ☐ if one or more files have been attached to the corresponding item.

• **Flag** displays a flag for the item, if desired. The available flags are: Complete (indicated by a green flag), In Progress (indicated by a yellow flag) and Incomplete (indicated by a red flag). In all Synthesis applications, flags are displayed in the interface only and do not affect analysis results or reports.

• **Item SxO** displays the calculated rating from the Item Severity x Item Occurrence (if enabled for the project). If a Risk Ranking Logic is defined for the project, the value will be color-coded based on the specified risk criteria.

• **Item Risk** displays the calculated Risk Ranking Logic value for the item, if it is defined for the project.

• **Risk Discovery** displays an icon if a risk discovery analysis has been performed on the item. If the analysis indicates that the item requires more detailed investigation, the icon will be red ⚪; otherwise, the icon will be green ⬤.

• **Risk Discovery Details** displays a number if a risk discovery analysis has been performed on the item.
  
  • If the analysis uses risk discovery questions, then this cell will display the number of questions with "Yes" answers. More "Yes" answers indicates greater risk.
  
  • If the analysis uses risk discovery ratings, then this cell will display the calculated value of all categories, which is based on the method in use for the Risk Discovery Ratings used in the project. Higher values indicate greater risk.

• **P-Diagram** displays ☒ if a Parameter Diagram (P-Diagram) has been created for the item, ☑ when a P-Diagram change log is present and that a revision is in progress or ☐ when a P-Diagram change log is present and no revision is active.

• **Process Flow Diagram Worksheet** displays ✅ if a PFD worksheet has been created for the item.

• **FMEA** displays ☐ if an FMEA has been created for the item, ☑ when an FMEA change log is present for the local FMEA and that a revision is in progress or ☐ when an FMEA change log is present for the local FMEA and no revision is active.

• **DRBFM** displays ☐ if a design review based on failure mode (DRBFM) analysis has been created for the item.

• **DVP&R** displays ☐ if a design verification plan and report (DVP&R) analysis has been created for the item, ☑ when a DVP&R change log is present and that a revision is in progress or ☐ when a DVP&R change log is present and that no revision is active.
Chapter 6: System Hierarchy

- **Control Plan** displays 📊 if a [control plan analysis](#) has been created for the item, 📊 when a [control plan change log](#) is present and that a revision is in progress or 📊 when a control plan change log is present and no revision is active.

- **Process Flow Diagram** displays 📊 if a [graphical process flow diagram](#) has been created for the item.

- **FMEA Block Diagram** displays 📊 if an [FMEA Block Diagram](#) has been created for the item.

- **Cause and Effect Diagram** displays 📊 if a [cause and effect diagram](#) has been created for the item.

- **QCPNi and QCPNr** display the calculated initial and revised [Quantitative Consequence Priority Numbers](#). To display these columns in the current project, the fields must be enabled on the FMEA > RPNs page of interface style.

---

**Building the System Hierarchy**

There are many ways to build the system hierarchy in Xfmea/RCM++/RBI.

**Adding New Items**

When you create a project, the first item is automatically added to the system hierarchy. To add more new items, follow any of the instructions below. If you choose "add," the new item will be added to the bottom of the list for the associated level. If you choose "insert," the new item will be inserted above the selected item.

- To add a new top-level item, choose **System Hierarchy > Add Items > Add System**.

  ![Add System](#)

- To add a new item to the next level below a selected item, choose **System Hierarchy > Add Items > Add Next Level Item**.

  ![Add Next Level Item](#)

- To add a new item to the same level as a selected item, choose **System Hierarchy > Add Items > Add Same Level Item** or **Insert Same Level Item**.

  ![Add Same Level Item](#)
  ![Insert Same Level Item](#)
Deleting Items
To delete an item from the system hierarchy, select the item and press DELETE. The item will be deleted, along with all sub-items and all associated analyses and attachments. You can undo the last deletion only.

Moving Items
You can move items within the system hierarchy by dragging and dropping them to the desired location. When an item is moved, all associated analyses and attachments will also be moved. You can also use the following methods:

- To move a selected item to the next higher or lower level, choose Home > Move Record > Promote or Demote. An item can be demoted only if there is another item on the same level and above the selected item that it can be demoted under.

- To move an item up or down within its current level, choose Home > Move Record > Up or Down.

Cutting/Copying and Pasting Items
You can cut or copy items in the system hierarchy and paste them to the same project or to another project within the same database.

To cut/copy multiple items all at once, hold the CTRL key while clicking all the items you wish to select. To select multiple items that are adjacent, click the first item and then hold the SHIFT key while you click the last item.

You can then use the standard keyboard shortcuts for cut/copy (CTRL+X and CTRL+C) or you can choose Home > Clipboard > Cut or Copy. All sub-items will also be cut or copied, along with any analyses and attachments. You can then paste the item to the desired level in the system hierarchy.

- To paste the item in the next level below the selected item, choose Home > Clipboard > Paste or press CTRL+V.

- To paste the item as a system, choose Home > Clipboard > Paste > Paste as Top Level.
• For additional options, choose Paste Special. The Paste Special window allows you to paste to the same level, and to choose whether sub-items and/or related analyses/attachments will be pasted.

After an item has been cut or copied, any edits that are made to the original will also be applied to its copy in the Clipboard. Likewise, if you delete the original, its copy will also be deleted from the Clipboard.

Note that you will not be able to cut or copy items in a project that is locked by another user.

**Smart Add and Import**

There are also several ways to add items that were copied from an existing analysis, another Synthesis desktop application or an external data source.

• System Hierarchy > Add Items > Smart Add Items.

The Smart Add Items utility makes it easy to copy item names from existing system hierarchies when the parent items were similar (based on category, part number, name and/or keywords).

• System Hierarchy > Add Items > Import > Import Items (Query) or (Browse).

Both of these utilities allow you to find and copy items from existing system hierarchies, with the option to include sub-items and/or related analyses/attachments if desired. You can use the Query method or the Browse method.

• System Hierarchy > Add Items > Import > Import from Excel.

The Import from Excel utility can be used to import system configuration, FMEA or other analysis data using flexible templates that you can customize to fit your particular needs.

• System Hierarchy > Add Items > Import > Import Lambda Predict Items or Import MPC Systems.

These commands allow you to import items from Lambda Predict prediction folios or the MPC system hierarchy in the same project (if applicable).
Chapter 6: System Hierarchy

- **System Hierarchy > XFRACAS > Import XFRACAS Items.**

Import Hierarchy Items from XFRACAS is available only when you are working in a database that has **associated XFRACAS tables**.

**Item Properties**

Each item in the system hierarchy can have basic properties associated with it (such as name, description, part number, etc.) as well as reliability characteristics (such as operating time, target reliability, etc.). When an item is selected in the **system hierarchy** or the **failure modes and reliability analysis (FMRA)**, you can view and edit this information on the Properties tab in the **Analysis panel**.

Some of the fields that are enabled in the interface, as well as the options available in configurable drop-down lists, will depend on the **interface style** for the current project.

- **Identifiers** are the same Synthesis Identifiers that are used to filter and group resources and analyses in all Synthesis desktop applications.
  - **Image**: An image that is displayed for the item in the Analysis panel only. Click the icon to open a window and browse for the desired image file.
  - **Name**: This field is populated automatically by the software based on the item’s position within the system hierarchy, but it can be changed by the user. The field cannot be blank and cannot contain any of the following characters: \\ / : " * ? < > |.
  - **Category**: A predefined category that can be used throughout the current database to find, filter and group analysis data. (See **Item Categories in Xfmea/RCM++/RBI**.)
  - **Part Number, Version, Supplier, Application, Description and Comments**: Optional fields that provide additional information about the item.
  - **Keywords**: Words or phrases (separated by commas) that can be used to find or filter analysis data. If desired, you can use the **Smart Add Keywords** utility to automatically choose words from the name and/or description for this item.

- **Other Item Properties**
  - **FMEA % Completed**: This field is always displayed in the item properties. Enter the percentage as a number => 0 and <=100. This value can be displayed in **dashboard charts**, **queries** and generated **reports**.
• **Reference Number**: A reference number associated with the item.

• **Alternate Part Number**: An alternate part number for the item.

• **CAGE Code**: The Commercial and Government Entity (CAGE) code associated with the item.

• **LCN**: The Logistic Control Number (LCN) associated with the item.

• **Reference Designator**: The reference designator for the item.

• **Drawing Number**: The number of the drawing associated with the item.

• **Qty per System** and **Qty per Assembly**: These properties are applicable only if the item is not a top-level system. They represent:
  - Quantity of identical sub-items in the system (e.g., 4 engines per airplane).
  - Quantity of sub-items in the next higher level assembly (e.g., 2 engines per wing).

*Note*: These fields are informational only and do not affect the reliability calculations in the FMRA. To affect these values, use the Qty field in the Operation node. Refer to Setting the Operation Properties for an FMRA for more information.

• **Similar To**: Another item similar to this one.

• **Design Engineer**: The name of the design engineer for the item.

• **MMEL**: The item's impact on the Minimum Master Equipment List (MMEL), as used in the aircraft industry.

• The **Ratings** fields are used if you want to perform item risk calculations on the system hierarchy items. (See Item Risk.)

• **User-Defined**: Up to five text fields, two date fields, two number fields and two drop-down lists.

• The **Operation** and **Reliability Policy** fields are relevant if you wish to a) calculate criticality metrics, b) generate a baseline system reliability based on information in the FMEA or c) share system configuration and failure mode data between the software and BlockSim. (See Failure Modes and Reliability Analysis (FMRA).)

• The **Reliability/Availability** fields allow you to enter the target reliability and availability that you hope to achieve, and compare them to the current estimates from the FMRA.
• If desired, you can set the target for a system or assembly and use the FMRA to automatically allocate the targets for sub-items. (See Allocate Target Reliability and Availability.)

• The software also applies automatic color-coding to highlight situations when the expected reliability/availability does not meet the specified target(s). (See Highlights Based on Target Reliability/Availability.)

• The Push to Metrics fields allow you to associate metric resources with the current reliability/availability. The metric is automatically updated whenever you recalculate/resimulate the value in the FMRA. (See Pushing Metrics from an FMRA.)

• The History fields display information about when the record was created and last modified. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the item.

Item Categories in Xfmea/RCM++/RBI

In all Synthesis desktop applications, you can use flexible categories and identifiers to find, filter, and group analysis data. In Xfmea/RCM++/RBI, these properties can be assigned to any item in the system hierarchy. They apply for any analysis or diagram that is associated with the item.

This topic discusses several options that are available for assigning categories to system hierarchy items: Smart Add Category, Select from Category List or Create Categories.

Remember that the same list of categories can be assigned for any project item (e.g., folio, diagram, system hierarchy item, etc.) or resource (e.g., model, URD, etc.) in the database.

Smart Add Category

When you click the Smart Add Category icon inside the Category field in the Item Properties, the software checks to see if a category already exists that exactly matches the item’s name.
If there’s a match, the category will be assigned automatically. If not, you’ll be prompted to select the category manually if desired.

**Select from Category List**
To manually set an item’s category, click twice inside the Category field and then select an option from the list.

To modify the list for the entire database, click **Edit Categories**.

**Create Categories**
The Create Categories feature can save a lot of time if you want the categories used throughout the database to match the item names in one or more of the system hierarchies defined in Xfmea/RCM++/RBI. To use the feature, open the project that contains the system hierarchy and choose **System Hierarchy > Tools > Create Categories**. (In a secure database, this is only available for users with the "Manage project item/categories" permission.)
The software automatically creates a category for every item in a system hierarchy and assigns the appropriate category for each item’s properties.

**Smart Add Keywords**

The **Keywords** field is one of the [Synthesis identifiers](http://xfmea.reliasoft.com) you can use to find, filter and group analysis data in all Synthesis desktop applications.

In Xfmea/RCM++/RBI, this field can also be used by the [Smart Add utilities](http://xfmea.reliasoft.com) to quickly find and copy item names or FMEA record descriptions from other similar analyses.

In either the **item properties** or the **FMEA record properties**, you can enter keywords manually by typing the words or phrases (separated by commas) directly into the **Keywords** field.
Alternatively, you can click the **Smart Add Keywords** icon to open a utility that makes it easy to choose keywords from the text already entered into other fields.

Specifically, the Smart Add Keywords utility shows a list of all words from the record’s name and description that have more than two characters and are not on the *Excluded Keywords List* (marked *Always Exclude*) for the current database.

If a candidate keyword is on the *Preferred Keywords List* (marked *Always Select*), it will be selected automatically in the Add column. You can also clear and set these check boxes manually.

When you click **OK**, the selected keywords will be automatically inserted into the **Keywords** field. (This picture shows RCM++, but it works the same in Xfmea and RBI.)

Note that the excluded and preferred keywords lists will be the same for all projects in the database, and they can be modified by any user who has write-access to any public or private project.

**Associated Analyses and Diagrams**

This topic describes the FMEA, RCM and related analyses and diagrams that can be associated with any item in the **system hierarchy**. For information about the risk based inspection analysis properties and results, see **RBI Properties**.
Available Analyses

The available analyses are summarized below. To add an analysis for an item, select the item and click the appropriate command on the Analysis tab of the ribbon. You can also right-click the item name and choose an analysis from the Analyses submenu.

A **Risk Discovery Analysis** is a preliminary analysis that can involve answering questions and/or assigning ratings about possible risks. It can help you to choose which items should receive more detailed consideration via a failure mode and effects analysis (FMEA) or reliability centered maintenance (RCM) analysis.

A **Parameter Diagram (P-Diagram)** is a structured tool that identifies the inputs from a system and relates those inputs to desired system outputs, while considering the controlled and uncontrolled factors.

An **Analysis Plan** allows you to keep track of team members, ground rules and assumptions, estimated completion dates, scheduled work sessions and other details to help you plan and manage your analysis projects.

A **Failure Modes and Effects Analysis (FMEA)** is a methodology designed to identify potential failure modes for a product or process, to assess the risk associated with those failure modes, to rank the issues in terms of importance and to identify and carry out corrective actions to address the most serious concerns.

**Design Review Based on Failure Mode (DRBFM)** is a methodology used to evaluate proposed changes to an existing design. It was developed by Tatsuhiko Yoshimura, working with Toyota Motor Corporation. DRBFM uses a worksheet similar to the FMEA worksheet, but it typically focuses on the failure modes that might be introduced by a specific change to a product or process.

A **Design Verification Plan and Report (DVP&R)** is a worksheet that is used to track the progress of design verification tests.

A **PFD Worksheet** captures details about what happens to the item in each step of its manufacturing or assembly process, and it records the product and process characteristics that are important to keep under control. The information from this worksheet can be used as an input to the process FMEA (PFMEA) and control plan for the item.

A **Control Plan** is used to keep track of characteristics that affect a product during the manufacturing process to ensure that the desired product specifications are met.
during the manufacturing process. It is often integrated with the PFD worksheet and/or process FMEA.

**Available Diagrams**

The available diagrams are summarized below. To create a diagram, choose System Hierarchy > Current Item > Diagrams > [Diagram Type].

- A [Process Flow Diagram](#) is a high level chart that helps you visualize the steps that a product goes through in a manufacturing or assembly process. You can create a blank diagram or base one on the FMEA or control plan associated with the item.

  **Tip:** If you want to use a process flow diagram as a starting point for preparing process FMEAs (PFMEAs) or control plans, then the PFD worksheet may be a more appropriate tool. The PFD worksheet integrates the chart into a worksheet that records more detailed information about each step in the process and it allows you to synchronize the relevant information with the FMEA or control plan analysis. (See PFD Worksheets.)

- A [FMEA Block Diagram (Boundary Diagram)](#) helps to define the scope of a particular analysis project and also may provide additional information that will be useful to the analysis team when they attempt to identify potential failure modes.

- A [Cause and Effect Diagram](#) helps you visualize the relationships among the events described in your analysis. When you select an item and choose System Hierarchy > Diagrams > Cause and Effect Diagram, the diagram will be constructed based on the events described in the FMEA for that item.

**Importing Analysis Data**

**Smart Add and Import**

**Smart Add (Items or FMEA Records)**
The Smart Add utilities make it easy to quickly find and copy item names or FMEA descriptions from other similar analyses.

For system hierarchy items, choose System Hierarchy > Add Items > Smart Add Items.
Chapter 6: System Hierarchy

For FMEA records, choose the command for the desired record type. For example, FMEA > Functions > Smart Add Functions.

**Smart Add Settings and Query Criteria**
The utility displays all of the unique item names or FMEA record descriptions that meet the requirements currently specified in the Smart Add Settings window.

- For system hierarchy items, you can consider the category, part number, name and/or keywords for the parent item in the system hierarchy.

- For FMEA records, you can consider the category and/or part number of the system hierarchy item that the FMEA belongs to, as well as the description and/or keywords for the parent record in the FMEA hierarchy.

To access the settings window, click the **Smart Add Settings** icon.

To see the actual query criteria, point your mouse cursor over the text at the top of the Smart Add utility. Note that the query will always be evaluated from left to right. For example, "A and B or C or D" will be implemented as "((A and B) or C) or D".

As an example, the following query will provide a list of all unique failure descriptions in the database that match the system hierarchy item’s category and part number OR the parent function’s keywords OR the parent function’s description. (This picture shows Xfmea, but it works the same in RCM++ and RBI.)
Transfer Criteria to Import Existing Window
The Smart Add utility copies only the item name or the FMEA record description. If you prefer to copy the entire record and/or have the option to import dependent records and attachments, click the Import Existing icon at the bottom of the window.

This will transfer the Smart Add utility’s query criteria to the Import Existing window.

Import Existing (Items or FMEA Records)
The Import Existing windows make it easy to find and import existing system hierarchy items or FMEA records. You can use up to four search terms, with the Boolean operators AND and OR.

For system hierarchy items, choose System Hierarchy > Add Items > Import > Import Items (Query) (or choose Items (Query) in the Import Wizard).
For FMEA records, choose the command for the desired record type. For example, **FMEA > Functions > Import Functions.**

**Tip:** When using this feature from within the new [Smart Add utilities](http://xfmea.reliasoft.com) it will be pre-populated with the same query criteria.

### Using the Utility
Regardless of the record type, all five of these utilities function in a similar manner.

1. Use the **Repository Location** area to choose where you wish to search. This can be:
   - Only the current project.
   - All projects in the current repository.
   - All projects in another repository.

2. Use the **Query Criteria** area to specify the keywords and/or phrases that you want to consider in the search. You can define up to four search terms, with the Boolean operators AND and OR. Refer to [Query Criteria](http://xfmea.reliasoft.com) below for more information.

3. Click **Search** to display a list of records that meet your criteria. Note that this will only consider projects that have the same **FMEA structure** as the current project.

4. Use the check boxes to choose which records you want to import.

5. Use the options at the bottom of the window to specify additional preferences. Specifically:
   - If you are importing items, specify which level in the system hierarchy the new items will be imported to:
     - **As system** pastes to the top level.
     - **As same level** pastes to the same level as the item that is currently selected.
     - **As next level** pastes to the level below the item that is currently selected.
   - Also specify whether you want to import the sub-items and analysis data associated with the selected items:
     - **Include lower level items** imports any sub-items associated with the selected items.
• **Include analyses** imports any associated FMEAs, control plans, etc. associated with the selected items. If this check box is not selected, only the item properties, attachments and diagrams will be imported.

• If you are importing FMEA records, specify whether to include the dependent records. For example, if you are importing functions, you can import only the functions, or you can import the functions and their related failures, effects, causes, etc.

• By default, dependent records will be imported. If you want to import only the individual records, select the **Import without dependents** check box.

6. Click **OK** to copy the data.

**Query Criteria**

You can use the four fields in the **Query Criteria** area to limit the search by up to four keywords or phrases. Note that these drop-down lists use the **property names** (i.e., the basic name for the field, which cannot be changed) and not the **display names** (i.e., the names that can be customized for each project).

![Query Criteria Table]

To match, the record must contain the search term anywhere within the field.

• **AND** searches for the records that match both requirements.

• **OR** searches for the records that match either requirement.

Note that the query will always be evaluated from left to right. For example, "A and B or C or D" will be implemented as "((A and B) or C) or D".

**Import Existing Items (Browse Method)**

You can use the Import Existing Items (Browse) window to import selected items from the system hierarchy and/or selected records from an existing FMEA.

For system hierarchy items, choose **System Hierarchy > Add Items > Import > Import Items (Browse)** (or choose **Items (Browse)** in the Import Wizard).
To use the Import Existing Items (Browse) window, do the following:

- Use the **Select Repository** area to select the database you wish to import from.
- Use the **Projects** area to select one of the projects in the database.

**Note:** This utility will display only projects that have the same FMEA structure as the project that is currently open. The FMEA structure determines how the effect and cause records will be displayed in the FMEA hierarchy, and it is set via the Project Properties window in Xfmea/RCM++/RBI.

- Use the options at the bottom of the window to select what will be imported, and then select the specific records you want to import:
  
  - **Import selected items and all functions:** You can select one or more items from the System Hierarchy area. The selected items will be imported along with all of their associated FMEA data.
  
  - **Import item and selected functions:** You can select only one item from the System Hierarchy area and then use the FMEA Hierarchy area to select which of that item's FMEA records you wish to import. Both the item and the selected FMEA records will be imported.
  
  - **Import selected FMEA records only:** This is the same as the previous option except that the item will not be imported. Instead, the selected FMEA records will be imported to the item that is currently selected in the project.

- Click **Import** to copy the data.

**Importing from Lambda Predict to Xfmea/RCM++/RBI**

Although the system hierarchy that you work with in Lambda Predict is independent from the system hierarchy that you work with in Xfmea/RCM++/RBI, the Synthesis Platform makes it easy to import items from a prediction folio into a hierarchy that will be used for FMEA, RCM or RBI analysis. The original system configuration in the prediction folio will remain unchanged, and new (independent) records will be created in Xfmea/RCM++/RBI.

To use this feature, open the project in Xfmea, RCM++ or RBI and choose **System Hierarchy > Add Items > Import > Import Lambda Predict Items**.

The left side of the window displays all of the prediction folios that have been created in the current project using Lambda Predict. The right side of the window displays the system
hierarchy from the prediction folio that is currently selected. Use the check boxes to select which items will be imported.

Any item properties in Lambda Predict that have an equivalent field in Xfmea/RCM++/RBI analyses (such as Part Number, Supplier, Item Description, etc.) will be imported.

There are two additional options:

**Create URDs from published prediction models**

The Synthesis Platform makes it possible to publish any failure rate calculated in a Lambda Predict prediction folio as a model resource that may be used in other Synthesis applications. (For details, see Publishing Models from Failure Rate Predictions in the Lambda Predict documentation.)

If you are importing prediction items that have been used to publish Synthesis models and you wish to use these published models to automatically define the reliability policies for the new items that will be created in Xfmea/RCM++/RBI, select the Create URD from published prediction models check box.

As an example, the following picture shows the reliability policy for an item imported from a MIL-217 prediction.

![Reliability Policy](image)

**Create FMEA functions from the 'Function Description' field**

If you are importing prediction items that have text in the "Function Description" field of the Lambda Predict item properties and you wish to use this text to automatically create the first FMEA functions for the new items that will be created in Xfmea/RCM++/RBI, select the Create FMEA functions from 'Function Description' field check box.
Chapter 6: System Hierarchy

As an example, the following picture shows the function description for an item in Lambda Predict. This can be used to create the first function in the FMEA for the new item that is imported to the Xfmea/RCM++/RBI system hierarchy.

![Function Description Example](image)

**Importing MPC Systems Into Xfmea, RCM++ or RBI**

Although the system hierarchy and F-F-E-C that you create in MPC for an aircraft systems and powerplant analysis has many similarities with the FMEA and RCM analyses that you can perform in Xfmea, RCM++ or RBI, some key differences are that:

- The analysis in MPC is designed specifically for the needs of the aircraft industry and is subject to certain logic constraints and restrictions imposed by the MSG-3 guidelines.
- Xfmea/RCM++/RBI provide more flexibility and more options for data-driven system analyses (such as the ability to use failure mode and/or component data to estimate the reliability/availability for higher-level assemblies and systems).

Therefore, each application must store and manage the analysis data independently. In other words, if you are accessing the same project with both applications, the system hierarchy that you work with in MPC is independent from the system hierarchy that you work with in Xfmea/RCM++/RBI.

However, it is easy to copy any system from the MPC systems and powerplant analysis into the more flexible Xfmea/RCM++/RBI system hierarchy in the same project. The original system
hierarchy in MPC will remain unchanged, and new (independent) records will be created in Xfmea/RCM++/RBI.

To use this feature, open the project in Xfmea, RCM++ or RBI and choose **System Hierarchy** > **Add Items** > **Import** > **Import MPC Systems**.

The window displays a list of the systems, if any, that have been defined in the MPC system hierarchy for the current project. Use the check boxes to select the MPC systems you wish to copy and click **OK**.

This process will automatically convert all of the relevant analysis information into the applicable feature(s) in Xfmea/RCM++/RBI.
If you are working with RCM++/RBI and you wish to see the MSI selection questions, failure effect categorization and task selection responses for the systems you import from MPC, make sure that the configurable project properties in RCM++/RBI are consistent with the MSG-3 guidelines. The easiest way to do this is to open the Project Properties in RCM++/RBI (Project > Management > Edit Project Properties) and check to make sure that the configurable settings are based on the MSG-3 profile from the default library installed with Synthesis.

![Edit Project Properties](image)

**Import or Sync from XFRACAS**

If your organization uses ReliaSoft’s XFRACAS for incident/failure reporting and team-based problem resolution, you can import or synchronize data with related analyses in Xfmea, RCM++ or RBI. The available options depend on the database you are working with.

**Enterprise Databases** – In an enterprise database that has an XFRACAS website, the icon in the XFRACAS Associated Hierarchy Item column in the System Hierarchy (if displayed on your computer) indicates that the desktop item is "associated" with a template part in XFRACAS.

http://xfmea.reliasoft.com
Chapter 6: System Hierarchy

When an association exists, you will be able to synchronize the following:

- Certain item properties:
  - Item name
  - Part number (if enabled in the desktop project)
  - Version (if enabled in the desktop project)
  - Item category (if there is a corresponding detail field in XFRACAS)
- Failure and cause descriptions (called "failure mode" and "root cause" in XFRACAS).

You can also view the number of **Observed Occurrences** reported in XFRACAS for a particular part and failure mode.

The following actions require the "Synthesis – Read Failure Mode Data" permission in XFRACAS:

- **Import XFRACAS Items** adds new items in the desktop system hierarchy that are associated to the XFRACAS parts they were copied from.
- **Associate Item** creates association(s) for a desktop item or branch that already exists.
- **Remove Association** breaks the association(s) for an item or branch.
- **Synchronize Item** updates part names, dependents and/or failures and causes in the desktop to reflect any changes to associated records in XFRACAS.
- **Import Failures** adds or updates failures and causes in the FMEA based on failure modes defined for the XFRACAS template part.

**Tip:** For users with the required admin permission in XFRACAS, the Template page provides similar options to a) import desktop items, b) remove the association to a desktop item and/or c) update part names, dependents or failure modes to reflect any changes to associated desktop items. In other words, users in either application can choose to copy more recent data from the other. If you will be importing desktop items into XFRACAS and plan to be creating serialized incidents using those items, you must make sure that the Part Number field is enabled and populated for each item.

**Standard Databases/Synthesis Files** – If the file is connected to an enterprise database that has XFRACAS data (see XFRACAS Connection), the **Import XFRACAS Items** or **Import Failures** commands will copy data from XFRACAS without creating an association.

**Observed Occurrences**

For desktop items that are associated with an XFRACAS template part, the Observed Occurrences column in the FMEA Hierarchy (if displayed on your computer) shows the number of occurrences reported in XFRACAS for a particular part and failure mode.
Chapter 6: System Hierarchy

In Version 11, depending on your selection on the FMEA Hierarchy page of the Application Setup, the quantity can be calculated based on one of the following XFRACAS record types:

- **Incidents** – the quantity of XFRACAS incidents that match the "responsible part" and "failure mode."

- **Problems** – the quantity of XFRACAS incidents that are assigned to an XFRACAS problem that matches the "part category" and "failure mode." This may be useful if the XFRACAS entity is configured to assign the failure mode at the problem level rather than for each individual incident. If a problem matches the part and failure mode but does not have any assigned incidents, it will not be counted.

- **Failure Analyses** – the quantity of XFRACAS failure analysis reports that match the repaired/replaced part ("incoming part") and the "failure mode."

**Tip:** Although failure modes can be assigned in XFRACAS as a combination of failure mode and root cause, the quantity of observed occurrences is based only on the failure mode. For example, "Failure Mode1 > Root Cause1" and "Failure Mode1 > Root Cause2" will both be counted as occurrences of "Failure Mode1." If both of those root causes are assigned to the same incident or failure analysis report, it will be counted as 2 occurrences of the failure mode. If both root causes are assigned to a problem that has 5 incidents, it will be counted as 10 occurrences.

### Import XFRACAS Items

Choose **System Hierarchy > XFRACAS > XFRACAS > Import XFRACAS Items.**

- **Select Entity** – select from a list of entities that you have permission to import from in XFRACAS.

- **Select Parts** – select from a list of template parts in the entity you selected.

- An 📊 icon indicates that failure modes have been defined for the part in XFRACAS. Select the **Import associated failures and causes** check box if you want to import these "failure modes" and "root causes" to start new FMEA(s) for the new item(s).

In an enterprise database, the new desktop items will be associated with the XFRACAS template parts they were copied from. In a standard database, the data will be copied without creating an association.

### Associate Item

Select an item in the desktop system hierarchy that a) is not associated with an XFRACAS part and b) is not the dependent of an item that is associated. Then choose **System Hierarchy > XFRACAS > Associate Item.**
You may be prompted to select an XFRACAS entity and template part. If you also want to copy any failure modes that don’t already exist in the FMEA, select the **Import associated failures and causes** check box. Note that:

- If the XFRACAS part has different item properties (i.e., name, part number, version and/or item category), this will update the properties of the desktop item.
- If the XFRACAS part has dependents, this will also create associations for any desktop item dependents that have the same names. If the names of the dependents do not match, this will create new desktop items that are associated to the XFRACAS parts they were copied from.

**Remove Association**

Select an item in the desktop system hierarchy that a) is associated with an XFRACAS part and b) is not the dependent of an item that is associated. Then choose **System Hierarchy > XFRACAS > XFRACAS > Remove Association**.

If the item has dependents that are also associated, you will be prompted to select:

- **Remove association from current item only**
- **Remove association from current item and its dependents**

**Synchronize Item**

Select an item in the desktop hierarchy that is associated with an XFRACAS part and choose **System Hierarchy > XFRACAS > XFRACAS > Synchronize Item**.

You can choose which updates will be performed if applicable for the current data.

- **Update current item** changes the item properties (i.e., name, part number, version and item category) of the desktop item to match the current properties of the associated XFRACAS part.
- **Update current item dependents** changes the properties of the desktop item’s dependents to match the current properties of the associated XFRACAS parts. If there are any unassociated dependents of the desktop item that have the same names as unassociated dependents of the XFRACAS part, this will create the associations.
Chapter 6: System Hierarchy

- **Add new dependents** creates new desktop item dependents if there are any unassociated dependents of the XFRACAS part that do not have the same name as an unassociated desktop item dependent.

The last two actions can be performed for the current item (if you have also selected **Update current item**) and/or for the dependents (if you have also selected **Update current item dependents**).

- **Update already synchronized failures and causes** changes the descriptions for any failures and causes in the FMEA that were previously synchronized with XFRACAS failure modes.

- **Synchronize and import failures based on description** creates new failures and causes in the FMEA if there are new failure modes and root causes for the XFRACAS part.

**Import Failures**
Select an item and choose **System Hierarchy > XFRACAS > XFRACAS > Import Failures**.

In the first window, select an entity and a part that has failure modes defined in XFRACAS (indicated with an icon) and click **OK**.

In the second window, you can compare the failure modes already defined in the existing FMEA (on the left) to the failure modes that have been defined for the part in XFRACAS (on the right), and select which records you want to import or update.

- **Pink** indicates that the failure/cause does not exist in the FMEA; select the check box if you want to import it.

- **Yellow** indicates that the failure/cause has been previously imported but the description has changed in XFRACAS; select the check box if you want to update the desktop description.

- **Green** indicates that the failure/cause already exists; the check box is disabled.

For failure modes that have not been previously imported, you can use the Associated Function column to either create a new function or select an existing function. When applicable, effects will be created with a default description ("<Undefined>") that you can modify after the import.
Chapter 7: FMEA Analysis

Failure Modes and Effects Analysis (FMEA) and Failure Modes, Effects and Criticality Analysis (FMECA) are methodologies designed to identify potential failure modes for a product or process, to assess the risk associated with those failure modes, to rank the issues in terms of importance and to identify and carry out corrective actions to address the most serious concerns.

Tip: For information about how to use the FMEA tab to perform reliability centered maintenance analysis (RCM) in RCM++ or RBI, see RCM Analysis.

- A general overview of typical FMEA analysis methods.
- Choosing an FMEA structure (Grouped Effects and Causes, Effects Before Causes or Causes Before Effects).
- Creating, copying or deleting a local FMEA.
- Working with linked FMEAs.
- The four tabs in the FMEA analysis panel Header, Hierarchy, Worksheet or Filtered.
- Using the record properties windows to add or edit FMEA records (function, failure, effects, etc.).
- Calculating displaying RPNs and related metrics (RPN, SxO, QCPN, etc.).
- A choice of three criticality analysis methods: Qualitative, Quantitative in the FMRA or MIL-1629A.
- Tools that utilize the data from an FMEA: Failure Cause Matrix, Risk Matrices, FMEA Statistics Window, Diagnostic Logic Assistant, Transfer Projects and Ratings Update.

FMEA Background

Failure Mode and Effects Analysis (FMEA) is a methodology designed to:

- Identify and fully understand potential failure modes for a product or process.
- Assess the risk associated with those failure modes and prioritize issues for corrective action.
- Identify and carry out corrective actions to address the most serious concerns.
Chapter 7: FMEA Analysis

This topic provides a brief, general overview of common principles and applications for Failure Mode and Effects Analysis (FMEA) and related analyses, such as Criticality Analysis (FMECA), design verification plans (DVP&Rs), process flow diagrams (PFDs), process control plans (PCPs) and design reviews based on failure mode (DRBFM).

FMEA Applications and Benefits
Usually, the primary objective of an FMEA is to identify and mitigate risks in a product or process in order to improve the design. In addition, since the FMEA provides a central location for reliability-related information for the product or process, it can be used as a learning tool for new engineers, a resource when considering modifications to the design or developing a similar design, a resource for service personnel to identify possible corrective actions when problems occur in the field, and so on.

FMEA is often performed in conjunction with Design for Reliability (DFR), Design for Six Sigma (DFSS), ISO quality programs and other initiatives. It also may be performed to satisfy a customer or regulatory requirement.

When performed effectively, an FMEA can contribute to improved designs for products and processes, resulting in higher reliability, better quality, increased safety, enhanced customer satisfaction and reduced costs.

When to Perform an FMEA
Many references cite three situations in which an FMEA commonly may be performed:

- Creating a new design or process
- Modifying an existing design or process
- Using an existing design or process in a new environment
The FMEA should be performed during the "window of opportunity" when it can most effectively impact the product or process design. In general, it should be an "up-front" activity, rather than "after-the-fact." Citing the "factor of 10 rule," most practitioners agree that it is more cost effective to correct reliability issues early in the process.

Basic Analysis Procedure for FMEA

This section introduces the basic analysis procedure for FMEAs. Of course, the specific implementation approach will vary among different organizations, practitioners and applications.

Determining the Scope

Before you can begin the FMEA, you must decide what you are going to analyze. Determining the scope of the analysis is an extremely important step because it helps to identify which FMEA(s) will be performed and then, for each particular FMEA, the boundaries for what issues will be considered and the approach that the analysts will take during the analysis. The determination of the scope may be based on a variety of factors, including (but probably not limited to) timing, complexity and characteristics of the design, risk/importance, available budget, customer requirements, etc. The tools available for determining the scope will vary depending on whether you are performing a design FMEA or a process FMEA.

If you are performing a Design FMEA, you may wish to start by defining the system configuration. Early in the design process, you may wish to perform a high-level FMEA on the entire system. As the design matures, it will be possible to perform more detailed FMEAs on individual assemblies or components. A change point analysis or preliminary risk assessment...
may help to focus the analysis effort on the aspects of the design that have the greatest risk and/or have the greatest potential benefit from design improvements. Factors may include:

- New technology or new application of existing technology
- Potential for safety or regulatory issues
- History of significant field problems
- Mission-critical applications
- Supplier capability
- Etc.

**Tip:** There are many different ways that the preliminary risk assessment can be performed. The Risk Discovery Analysis feature supports two possible methods: one based on a series of yes/no questions and another based on rating scales.

For each individual FMEA that you will perform, it may also be useful to define what components and interactions will be included in the analysis. A boundary diagram (or block diagram) shows the physical and logical relationships between the components in the system or assembly. It can identify relationships and dependencies between components as well as critical inputs and outputs.

**Tip:** You can use the Attachments feature to provide easy access to boundary/block diagrams that have been created with other software tools (such as Visio or PowerPoint). Alternatively, you can use the FMEA Block Diagram feature to create the diagram and link it to the rest of the analysis.

If you are performing a Process FMEA, you may start by identifying the steps in the process and the operations that must be performed at each step. In most cases, the scope of the PFMEA will be the entire process. However, in some situations, the organization may choose to exclude low-risk portions of the process.

The process flow diagram (PFD) provides a logical, visual depiction of the process that is being analyzed. The diagram typically uses specific symbols to describe different types of activities (e.g., operation, decision, inspection, storage, etc.). It also may include an identification of the product or process characteristics that need to be monitored at each step (e.g., temperature of the oven, thickness of the wax, diameter of the hole, etc.) and the possible sources of variation (e.g., incorrect setup, contamination, machine maintenance, etc.). Such diagrams can be useful to determine the steps in the process that will be analyzed in the PFMEA and to determine the functions and critical characteristics that will be considered in the analysis.
**Tip:** You can use the **Attachments** feature to provide easy access to process flow diagrams that have been created with other software tools (such as Excel, Visio or PowerPoint). Alternatively, you can use the **process flow diagram** feature to create the diagram and link it to the rest of the analysis.

---

**Assemble the Team**
One of the first steps in performing an FMEA is to assemble a cross-functional team of knowledgeable individuals to perform the analysis. The team should be large enough to make sure that relevant viewpoints and knowledge are represented but not too large. If the team is too large, it will be difficult to have productive discussions during meetings and it will be a waste of an extremely valuable resource – the time and patience of your organization’s subject matter experts. Team members should be familiar with the FMEA analysis process, as it is practiced by the organization. In addition, a skilled facilitator can help to make sure that team meeting time is used effectively and the analysis is performed correctly.

The composition of the team at any particular meeting may vary depending on the focus of the discussion. This may include representatives from Design, Analysis/Testing, Materials, Suppliers/OEM, Manufacturing/Assembly, Quality/Reliability, System Integration, Field Service, Maintenance, etc.

**Tip:** You can use the **analysis plan** feature to document the members of the analysis team for each FMEA.

---

**Establish the Ground Rules and Assumptions**
Before beginning the analysis, the team should discuss (and probably document) the underlying assumptions of the analysis and specific ground rules for how the analysis will be performed. Some of these guidelines may be determined already by the organization’s standard practices for FMEA and some may be specific to the particular analysis project. Some of the questions that might be considered include (but are not limited to) the following:

- What will be considered a failure?
- What are the assumed environmental and operating conditions?
- Will the analysis consider failures that result from abuse?
- What is the budget and timescale for the project and what are the project deliverables?
- What other activities within the organization will the team need to interact with and have the necessary communications been established?
- When and where will the team meet?
- Will there be a facilitator?
Chapter 7: FMEA Analysis

- How will decisions be made within the team and how will conflicts be resolved?
- What will be the format of the analysis worksheet and what rating scales will be used?
- How will the organization track the completion of recommended actions?
- And so on...

This list is provided as an example. Other issues may be applicable for your particular situation.

**Tip:** You can use the **analysis plan** feature to document the ground rules and assumptions for each FMEA.

Gather and Review Information (Pre-Work)
Taking the time to gather and review available information before the analysis meetings begin can help to make the most efficient use of team meeting time and achieve an analysis that is thorough and accurate. The appropriate resources will vary depending on the type of FMEA that you are performing and the specific product or process that you are analyzing. This may include:

- Bill of materials and/or process flow diagrams
- Customer requirements, business requirements, functional specs, technical specs
- Design schematics, drawings
- Feasibility studies or trade-off analyses
- Information from similar designs, including field data, FMEAs, etc.
- Documentation or contracts from suppliers
- Applicable government or safety regulations

This is an incomplete list that is provided as an example. Other resources may be applicable for your particular situation.

**Tip:** You can use the **Attachments feature** to provide easy access to supporting documentation that may be relevant to a particular analysis.
Identify the Functions, Failure Modes, Effects, Causes and Controls

For each item or step that will be analyzed, the analysis team will use engineering and business judgment to identify the functions, failure modes, effects, causes and controls that will be considered in the analysis.

- **Function**: An intended function or purpose, as described by a required standard of performance.

- **Failure Mode**: The inability to perform a function within the specified limits.

- **Effect**: The anticipated consequences if the failure mode occurs.

- **Cause**: The specific reason for the failure. This may be found by asking "why" until the basic mechanism that brings about the failure is determined. In many cases, there are several levels of detail that could be used to describe the cause of failure. In general, it is best to choose the level at which the organization is able to control the condition and/or take corrective action.

- **Current Control**: A method or action that is planned or currently in place to reduce or eliminate the risk. In many cases, the current controls are classified as "Prevention" or "Detection," where:
  - **Prevention Controls** are intended to reduce the likelihood that the problem will occur.
  - **Detection Controls** are intended to increase the likelihood that the problem will be detected before it reaches the end user.

**Tip**: In many situations, an existing document may contain information that would be useful to import directly into your FMEA analysis (such as a requirements document, a process flow diagram worksheet, an FMEA from a similar product/process or a predefined "phrase set"). The software provides numerous features to help you find and import this information. These features are described in [Importing, Exporting and Data Conversion](#).

Evaluate Risk for Potential Failures

A typical FMEA incorporates some method to identify and evaluate the risk associated with the potential problems identified through the analysis. Risk Priority Numbers (RPNs) and criticality analysis are the most commonly used methods for this.

To use the **Risk Priority Number (RPN)** method, the analysis team must:

- Rate the severity of each effect of failure.

- Rate the likelihood of occurrence for each cause of failure.
Chapter 7: FMEA Analysis

- Rate the likelihood of detection for each cause of failure.
- Calculate the RPN by obtaining the product of the three ratings:
  \[ \text{RPN} = \text{Severity} \times \text{Occurrence} \times \text{Detection} \]

To use **Qualitative Criticality Analysis**, the analysis team must a) rate the severity of the potential effects of failure and b) rate the likelihood of occurrence of each potential failure mode. It is then possible to compare failure modes, via a Criticality Matrix, which identifies severity on the horizontal axis and occurrence on the vertical axis.

To use **Quantitative Criticality Analysis**, the analysis team considers the reliability/unreliability for each item at a given operating time and identifies the portion of the item's unreliability that can be attributed to each potential failure mode. For each failure mode, they also rate the probability that it will result in system failure. The team uses these factors to calculate the criticality for each potential failure and for each item.

**Tip:** The software provides an extensive array of features to support risk assessment based on RPN and related metrics. (See [Risk Priority Numbers (RPNs)](http://xfmea.reliasoft.com).)

Quantitative and qualitative criticality analysis patterned after the concepts in MIL-STD-1629A are also supported. (See [Criticality Analysis](http://xfmea.reliasoft.com).)

**Identify and Assign Corrective Action(s)**

The next step is to identify, assign and track the completion of recommended actions that will help to reduce the risk associated with potential failures. In some situations, it may be possible to take an action that will reduce the severity of the effect when the failure occurs but in most cases, the recommended actions will be designed to either reduce the likelihood that the failure will occur or to increase the likelihood that it will be detected and controlled before the problem reaches the end user. When selecting the actions to recommend, the team may consider:

- Existing controls.
- The relative importance (prioritization) of the issue.
- The cost and potential effectiveness of the corrective action.

**Tip:** One of the most costly mistakes among FMEA practitioners is the failure to follow up and track the completion of recommended actions. The software provides multiple features that will help to ensure that your organization implements the actions suggested by the analysis in order to achieve the benefits that come from improving the design and reducing the risk. (See [Actions](http://xfmea.reliasoft.com).)
Perform Corrective Actions and Re-evaluate Risk

In many cases, it may be appropriate to revise the risk assessment after the recommended actions have been completed (or based on the results that the analysis team expects to achieve when they are completed). This will provide an indication of the effectiveness of corrective actions and the benefits achieved by performing the FMEA. To use revised RPNs for this purpose, the analysis team will:

- Assign revised severity, occurrence and detection ratings.
- Calculate a revised RPN.
- Compare the initial and revised RPNs.

The % reduction in RPN can be calculated with the following equation:

$$\text{\% Reduction in RPN} = \frac{RPN_i - RPN_f}{RPN_i}$$

Distribute, Review and Update Analysis Results

FMEAs are typically reported in a tabular (worksheet) format. The style varies depending on the standard/guidelines and the terminology used during the analysis. In addition to the worksheet, other tabular reports can be useful to support decision-making and communicate the results of the analysis, such as Assigned Actions, Causes Ranked By RPN, etc. Pareto (bar), pie and matrix charts also can help to visualize analysis results.

An FMEA is most effective when it is a "living" document. When completed, the analysis should be distributed as appropriate throughout the organization so that it can be used as a resource for other activities. Your organization invested too much effort and knowledge to bury the document in the file cabinet!

**Tip:** You can use the Reports window and the Query Utility to create the reports to distribute the results of your FMEAs. In addition, the Plot Viewer provides a variety of charts to present the information graphically.

In general, the FMEA should be reviewed and updated:

- When there is a change to the design.
- When other factors change (such as the operating conditions or the intended application).
- When new information from the field is available.
**Tip:** There are several ways to manage revisions to an existing analysis, including a formal Change Log that can automatically record all revisions to an existing analysis and facilitate a process for electronic approval tracking.

After the completion of an FMEA project, it can also be a good idea to have an expert in the FMEA methodology evaluate (audit) the FMEA. In addition, you may wish to solicit feedback from the team members who participated in the analysis in order to identify issues that should be addressed in future analysis projects. A suitable checklist could be obtained from the FMEA literature or your organization may choose to develop its own audit requirements.

**Tip:** You can use the analysis plan feature to document the results of the quality survey for each FMEA.

### Integration with Other Analyses (Including APQP)

Within the automotive industry and some other industries, practitioners have integrated FMEA with other quality planning efforts, as shown in the following diagram and described next.

**DFMEA and DVP&R**

The design verification plan and report (DVP&R) is a worksheet that is used to track the progress of design verification tests. The lessons learned from the DFMEA can be a valuable input to the DVP&R (and vice-versa). For example: if the design FMEA indicates that Part X will fail if the incorrect wax thickness is applied for protection, then it may be appropriate to add a test to the design verification plan for determining the optimum wax thickness to be applied.
Tip: The DVP&R Analysis feature provides a configurable worksheet for design verification planning and reporting, including the ability to synchronize the DVP&R with information transferred from an existing FMEA.

**DFMEA to PFMEA**

The lessons learned from a design FMEA also can be a valuable input to the process FMEA. Analysts may wish to transfer relevant information between analyses, where:

- Causes in the DFMEA can become failures in the PFMEA.
- Failures in the DFMEA can become effects in the PFMEA.

For example, if the design FMEA indicates that Part X will leak if the hole diameter is too wide then the design FMEA will consider whether the specified hole diameter is appropriate while the process FMEA will consider aspects of the manufacturing process that may cause the hole diameter to vary from the specification.

- DFMEA: Failure = Leak; Cause = Hole too wide.
- PFMEA: Failure = Hole too wide; Effect = Leak.
  - Causes = ?
  - Controls = ?
  - Actions = ?

Tip: The Transfer Projects feature allows you to transfer selected data from an existing design FMEA to a new process FMEA.

**Process Flow Diagram, Process FMEA and Process Control Plan**

As described above, the process flow diagram (PFD) provides a logical, visual depiction of the process that is being analyzed and such diagrams can be useful to determine the steps in the process and the critical characteristics that will be analyzed in the PFMEA.

In addition, the process control plan (PCP) describes the actions that are required at each phase of the process to ensure that all process outputs will be in a state of control. The process flow diagram and the lessons learned from a process FMEA can be a valuable input to the process control plan. The linkages between these documents might be applied as follows:

- **Operation # and Description** flow from the Process Flow Diagram to the PFMEA to the control plan.
- **Significant Product Characteristics (and Classifications)** contribute to the definition of failure modes and/or causes in the PFMEA. They also flow to the control plan.
Current Controls flow from the PFMEA to the control plan.

Tip: The **PFD Worksheet** feature provides integration with both the Process FMEA and the **Process Control Plan** worksheet.

### Design Review Based on Failure Mode (DRBFM)

DRBFM is a methodology used to evaluate proposed changes to an existing design, using a worksheet that is usually similar to, but not identical to, an FMEA.

Although some organizations may choose to perform DRBFM instead of FMEA, most practitioners start with a baseline FMEA and then use the DRBFM worksheet for evaluating the risks that might be introduced by changes to the original design.

Tip: The **DRBFM Analysis** feature provides a configurable worksheet for design review based on failure mode, including the option to select functions that will be transferred from an existing FMEA and the ability to update the FMEA with new information from the DRBFM.

### References


- **Automotive Industry Action Group (AIAG)**, *Advanced Product Quality Planning and Control Plan (APQP)*. (June 1994 and July 2008).


Chapter 7: FMEA Analysis


### Choosing the FMEA Structure

On the General page of the Project Properties window, the **FMEA Structure** field determines how the effect and cause records will be displayed in the hierarchy for all FMEAs in the project. You have three options:

- **Grouped Causes and Effects** (commonly used for FMEA)
- **Effects Before Causes** (can be used for FMEA or RCM)
- **Causes Before Effects** (sometimes used for RCM)

If you want to copy/paste or import/export data between projects, the FMEA structure must be the same. Also note that some data conversion may need to be applied if you change the FMEA structure for an existing project.

### Grouped Effects and Causes

The "Grouped Effects and Causes" structure is often used for FMEA if you want to display causes and effects at the same level of the hierarchy under the failure mode that they are both associated with. This assumes that you will always define the failures such that any of the causes may result in any of the possible effects.
With this structure, the Grouped Effects window stores a separate description and severity rating for each effect. When using the RPN risk assessment method, the software will automatically choose the highest severity rating to calculate the RPN for all of the causes associated with that failure mode.

Effects Before Causes
The "Effects Before Causes" structure can be used for either FMEA or Reliability Centered Maintenance (RCM).
If the failures are defined such that any of the causes will result in any of the effects (which is typical for FMEA), you can define all of the effects together in the same record (using CTRL+ENTER to force linebreaks in the text box when needed), and then choose a single severity rating that you want to use to calculate the RPN for all of the causes.

Alternatively, if the failure mode is defined rather generally, such that specific causes may result in different effects, you can enter them separately as shown below. If you are calculating RPNs, the software can use different severity ratings for different causes.

**Causes Before Effects**
The "Causes Before Effects" structure, which is sometimes used for RCM analysis, assumes that functional failures will be defined rather generally and requires that there can be only one
Setting the Default FMEA Structure

Now in Version 11, you have the option to either set a default FMEA structure for all new projects in a database or to require that a user choose a structure when a project is created.

For projects created in Xfmea/RCM++/RBI, the software will either prompt you to select the structure when you create the project, or use the default that has been defined for the database by an administrator. (See Repository Settings window.)

A project created in MPC will always use the "Effects Before Causes" structure to ensure that the hierarchies will be compatible with Xfmea, RCM++ or RBI. This will happen even if a different FMEA structure has been selected for the database. A project created in any other Synthesis desktop application will either use the default for the database (if that has been defined) or the structure for the last database created.

Changing the FMEA Structure

If you change the FMEA structure for an existing project, some data conversion may need to be applied. Specifically:

From Grouped Causes and Effects to:

- **Effects Before Causes**: The highest severity rating from the group will be used for each new effect.
- **Causes Before Effects**: Direct conversion is not possible. You must first convert to "Effects Before Causes."

From Effects Before Causes to:

- **Grouped Causes and Effects**: All effects associated with a given failure are merged into one grouped effect.
- **Causes Before Effects**: Each effect record is duplicated under each cause record.
From **Causes Before Effects** to:

- **Effects Before Causes**: All records are converted without adjustment.
- **Grouped Causes and Effects**: Direct conversion is not possible. You must first convert to "Effects Before Causes."

**Local FMEAs**

This topic discusses basic capabilities for creating and working with an FMEA that is directly associated with the current system hierarchy item (which is now called a *local FMEA*). If you want to link to an existing FMEA that has already been defined for another item, see [Linked FMEAs](#).

**Add an FMEA**

To add an FMEA for any item in the system hierarchy, select or right-click the item and choose **Analyses > Add FMEA**.

This adds the FMEA tab in the Analysis panel and prompts you to add the first function. If the FMEA column is **enabled in the system hierarchy**, the shows that the item has an FMEA.

For more information about using the four FMEA tabs at the bottom of the Analysis panel, see [FMEA Header](#), [FMEA Hierarchy](#), [FMEA Worksheet](#) and [FMEA Filtered View](#). For information about working with the functions, failures, etc., see [FMEA Records](#).

**Copy/Paste an FMEA**

It is easy to copy/paste an entire FMEA (i.e., all functions and all of their dependent records) to another item, either in the same project or in a different project.
Chapter 7: FMEA Analysis

To copy an FMEA, right-click the item and choose **Analyses > Copy Analysis**.

To paste the FMEA, right-click a different item and choose **Analyses > Paste Analysis**.

(Both of these commands are also available when you right-click the tab at the top of the Analysis panel, and from **Home > Clipboard** on the ribbon.)

If the copied analysis is not eligible to be linked in the new location, the functions (et al) will be pasted as new records in the local FMEA for the item that you’re pasting to. If the destination item already has a local FMEA, the new records will be appended to the bottom of the list.

If the copied analysis is eligible to be linked in the new location (i.e., if it is associated with an item in the same project or in a reference project, and it is not already linked from the selected item), you can choose:

- **Paste as New** pastes the functions (et al) as new records in the item’s local FMEA.
- **Paste as Linked** creates a linked FMEA that gets updated automatically if the original analysis changes.

**Cut/Copy and Paste Portions of an FMEA**

You also have the option to cut/copy and paste portions of an FMEA (e.g., one selected function, two selected failures, etc.). If you are working in the FMEA hierarchy, you can use **CTRL** or **SHIFT** to select multiple records of the same type.

The cut/copy/paste commands are available when you select the record(s) in the FMEA and choose **Home > Clipboard > [Cut, Copy, Paste, Paste Without Dependents]**, and when you right-click the record(s).

In this case, you can choose whether to include the dependents or just the top level record.
Delete an FMEA
To delete an entire FMEA, right-click the item and choose Analyses > Delete Analysis.

(This command is also available when you right-click the tab at the top of the Analysis panel, and from Home > Clipboard on the ribbon.)

Delete a Portion of an FMEA
To delete a portion of an FMEA, select the record or branch and press Delete or right-click and choose Delete.

You will always be asked to confirm before the records are deleted. If you want to be able to undo the action, make sure that Allow undo this operation is selected before you click Yes.

Linked FMEAs
You can use the same FMEA in more than one location in the database, if desired. For example, if you are using the same component in multiple different designs, you can create the FMEA in one location and link to the exact same analysis from other locations.

Any item in the system hierarchy can have one local FMEA and/or one or multiple linked FMEAs.

- Local FMEA: The functions, failures, etc. that are directly associated with the current item.

- Linked FMEA: Links to the exact same functions, failures, etc. that are associated with another item. A change in the source analysis will be reflected in all locations where it is linked. To be eligible for linking, an FMEA must be a) associated with another item in the current project or in a reference project and b) not already linked from the current item.

This topic focuses on the following special considerations associated with linked FMEAs. For information about FMEA features, see Local FMEAs. For information on how importing/exporting or checking out a project affects linked FMEAs, see Local, Global and Reference Resources.
Chapter 7: FMEA Analysis

Linked Analyses in the FMEA Hierarchy

If an FMEA is linked, the icons in the FMEA hierarchy will include a link symbol and you won’t be able to edit the records directly (i.e., the OK button in the record properties window will be disabled).

If an item has more than one FMEA, the hierarchy will use an additional top-level heading to identify each analysis (i.e., "Local Analysis" or "Linked Analysis - Source: <ITEM NAME>"). To change the order in which the analyses are displayed, drag and drop the heading into the desired position.

If a local FMEA is being linked from at least one other location, then the FMEA hierarchy states how many other locations the FMEA is used in.
Linked Analysis Commands
There are two ways to access the commands for a linked or source analysis (Copy Analysis, Remove Link, Go to Source Analysis, Show Locations Used, etc.):

- Right-click the analysis heading.
- Select any record in the analysis and right-click the FMEA tab.

Add Linked FMEA
To add a linked FMEA, select or right-click an item and choose Analyses > Add FMEA > Add Linked FMEA.

The Add Linked FMEA window allows you to select an existing analysis that is eligible to be linked from the current item. If desired, you can use the project and/or item filters to further limit the analyses you can choose from. When you find the FMEA you wish to link, select the row and click OK.

Paste as Linked
Alternatively, you can also use copy/paste to create a linked FMEA.

1. Copy the FMEA you want to link to (the source analysis). To be eligible for linking, this must be a local FMEA in the same project or a reference project that is not already linked from the item you will be pasting to.
Chapter 7: FMEA Analysis

2. Select or right-click the item you want to link from and choose Analyses > Paste Analysis.

3. If the copied FMEA is eligible for linking, the following options will be displayed:

   Paste Options
   - Paste as New
   - Paste as Linked

Choose Paste as Linked and click OK.

**Go to Source Analysis**
To view/edit the source analysis for a linked FMEA, right-click the FMEA tab or the Linked Analysis heading and choose Go to Source Analysis.

**Show Locations Used**
For any source analysis (i.e., local FMEA that is linked in at least one other location), the Show Locations Used window provides a list of all locations where the FMEA is currently linked. To access this window, double-click the Local Analysis heading or right-click the heading and choose Show Locations Used.
To go to one of the linked locations, select it in the list and click the **Go To** button.

**Delete Analysis**
To remove a linked analysis from an item, right-click the FMEA tab or the analysis heading and choose **Delete Analysis**.

The original source analysis will remain unchanged.

**Remove Link**
To convert a linked analysis to a local analysis, right-click the FMEA tab or the analysis heading and choose **Remove Link**.

This will break the link to the original analysis and replace it with new unique records that are directly associated with the current item. If the item already has a local FMEA, the new records will be appended to the end.

**Remove External FMEAs**
If you need to break the links to all FMEAs in the current project that were linked from a reference project (e.g., because you are finalizing the project and you do not want the FMEAs to continue to be updated automatically when there is a change in the external source), choose **System Hierarchy > Tools > Remove External FMEAs**.

The links will be replaced by new unique records in the local FMEAs.
FMEA Analysis Tab

FMEA Header
The Header tab for an FMEA contains the information that will be displayed at the top of any FMEA spreadsheet reports that you generate from the Reports window.

FMEA Header Properties
The fields that are enabled in the interface and the options available in configurable drop-down lists will depend on the interface style for the current project. This may include:

- **FMEA Type**: The type of FMEA. This field is a configurable drop-down list.
- **Document Number**: A unique document identifier.
- **Key Date**: The date when the FMEA should be completed.
- **FMEA Date (Orig.)** and **FMEA Date (Rev.)**: The dates when the FMEA was first completed and last revised.
- **Prepared By**: The person who prepared the document.
- **Primary Approval** and **Approval Date**: The person who gave primary approval for the document, and the date of approval.
- **Product**: The product that the FMEA applies to.
- **Model Year(s)/Program(s)**: The model year and/or program identifier that the FMEA applies to.
- **Mission**: The mission that the item is intended to perform.
Chapter 7: FMEA Analysis

- **Release Date**: The date when the design will be released.
- **Responsibility**: The person who is responsible for the design that is being analyzed.
- **Core Team**: The primary team of people who worked on the analysis. If the item has an Analysis Plan, you can click to import the display names of the analysis plan team members (up to 255 characters).
- **Support Team** and **Others Affected**: The individuals and teams involved with the support and/or who are involved with or affected by the analysis.
- **User-Defined Fields**: Up to five text fields, two date fields, two number fields and two drop-down lists.

*Last Updated* and *Last Updated By* are populated automatically by the software.

**FMEA Hierarchy**

The Hierarchy tab for an FMEA displays the analysis records in a hierarchical tree, which tends to be good for viewing a lot of information in a small amount of space. It can be especially useful when copying and pasting data or when scanning the analysis to find a particular section of the FMEA.

![Hierarchy Tab](image)

Double-click a row to open its properties window. If you click another row while the properties window is still open, it will automatically update to show the current selection.
To access other relevant commands (add, insert, copy, paste, etc.), right-click inside the hierarchy or use the FMEA tab on the ribbon. The options depend on which record (or heading) is currently selected. (See FMEA Tab for a complete list.)

To move a record up or down in the list, drag and drop the row to the desired location, or select the row and choose Home > Move Record > [Up or Down].

FMEA Hierarchy Columns
To hide or display columns, right-click the column headers in the FMEA hierarchy view, then click Customize Columns to select which columns you want to display. These settings are stored per computer/username in the FMEA Hierarchy page of the Application Setup, so any project that you open on this computer will have the same columns displayed.

The available columns include the following:

- **#** is assigned automatically based on the current position of the record in the FMEA hierarchy. This number will change if the record’s position within the FMEA changes.
- **Description** is the record description.
- **Record ID** is assigned automatically when the record is created. It is unique throughout the repository for a given record type and it does not change. If you copy/paste or import a record, each new instance will receive its own unique ID.
- **Attachment** displays a paper clip icon if there are any links or attachments for the record.
- **Flag** displays a flag for the record, if desired. The available flags are: Complete (indicated by a green flag), In Progress (indicated by a yellow flag) and Incomplete (indicated by a red flag). In all Synthesis applications, flags are displayed in the interface only and do not affect analysis results or reports.
- **Classification** may be assigned to cause records in order to identify design characteristics that require special manufacturing control (e.g., Critical, Significant, Key Leading, etc.).
- **FEC** This displays the abbreviation generated in the Failure Effect Categorization window.
- **Observed Occurrences** is available only if you are working with an item that has a current association with a part in XFRACAS. It displays the number of incidents, problems or failure analyses recorded in XFRACAS for the failure mode/cause combination. (See Import or Sync from XFRACAS for more details.)
The following columns for RPN ratings and/or metrics can be displayed only if the column is selected in the Customize Columns window and the property is enabled in the interface style for the current project. The lowercase letter "i" indicates an initial rating or metric while the letter "r" indicates revised.

- **S**, **O** and **D** display the severity, occurrence and detection ratings assigned to the effect and cause records.
- **RPN** displays the calculated Severity x Occurrence x Detection.
- **QCPN** displays the calculated Quantitative Consequence Priority Number.
- **SxO** displays the calculated Severity x Occurrence.
- **SOD** and **SD** combine the ratings into a 3 or 2 digit number. For example, if the severity is 7, the occurrence is 5 and the detection is 6, then SOD = 756 and SD = 76.
- **RR** displays the risk ranking value for the cause. (See Risk Ranking Logic.)

**FMEA Worksheet**

The Worksheet tab for an FMEA presents the analysis data in the traditional tabular format that most FMEA practitioners are familiar with. It allows you to type directly into the worksheet cells and tab through the analysis as you would in a spreadsheet application such as Microsoft Excel.
The status bar at the bottom of the tab displays the record type and the number of attachments the record has. For controls and actions, it also includes a link to the Dependency Viewer where you can see where the resource is used.

**Adding or Editing Records**

To add or edit records in the worksheet, you can use the commands on the FMEA ribbon, or right-click inside a cell and use the shortcut menu. The options depend on which cell is currently selected. (See FMEA Tab for a complete list.)

You can also add and edit records directly in the worksheet cells. The options vary depending on whether the cell is selected or in edit mode.

When a cell is selected:

- Click twice or press ENTER to switch to edit mode.
- Use the HOME, END and arrow keys to navigate between selected cells.
- Use CTRL+C and CTRL+V to copy and paste an entire record.
When a cell is in edit mode:

- Press **ALT** to save changes and exit edit mode. Press **ESC** to exit edit mode without saving changes.
- Press **TAB** to navigate to the next column on the same row. Press **SHIFT+TAB** to navigate to the previous column.
- Press **ENTER** to navigate down to the next row. If you press **ENTER** from the last record in a column, the software prepares a new row so that you can create a new record.
- Use the **HOME**, **END** and arrow keys to move through the text within the cell.
- Use **CTRL+C** and **CTRL+V** to copy and paste selected text within the cell.
- Click the **Select Existing** icon to find and reuse text that has already been entered in this type of field.

**Reordering Columns**

The project’s interface style determines which columns are displayed in the FMEA worksheet, as well as the column order. This will be the same for any user who views the analysis.

If you drag and drop a column header into a new position while using the worksheet, the new order will be saved in the interface style if you have write access for the project. If you have read-only access, the new order will not be retained after you leave the current worksheet.

**Resizing Columns**

To resize a column, drag the column heading to the desired width. The preferred widths will be saved per computer/username. This will be the same for any analysis you view on this computer, but other users may have different column size preferences.

**Repeating Data**

To populate the gray areas in the worksheet with the relevant information from a prior row, choose **File > Application Setup**. On the Settings page select the **Repeat data in worksheet views** check box.

**Inserting or Removing a Split Bar**

A split bar creates two areas in the worksheet that scroll separately.

- To insert a split bar to the left of a selected column, right-click the heading and choose **Split**.
To remove the split bar, right-click again and choose Remove Split.

FMEA Filtered View
The Filtered tab for an FMEA presents a sortable list of all records of a particular type. For example, you may wish to see all cause records sorted by RPN, or all actions that are overdue. This view allows you to generate these lists on-the-fly as you work on the analysis.

Double-click a row to open its properties window. If you click another row while the properties window is still open, it will automatically update to show the current selection.

You cannot create or delete records from the filtered view.

Filtered View Columns
The columns displayed in the filtered view will depend on the record type and the fields enabled in the project’s interface style. To hide specific columns and/or change the column

http://xfmea.reliasoft.com
order, right-click inside any of the column headers and choose **Customize Columns**. These preferences are stored per computer/username.

## FMEA Records

This topic describes some features that are the same for any record in an **FMEA**.

### Record # and ID

Each record in an FMEA has a record position number (#) and a record identifier (ID). These values can be displayed in the **FMEA Hierarchy** or **FMEA Filtered View**, and they are also used in the **Query Utility** and **Reports**.

- **#** is assigned automatically based on the current position of the record in the FMEA hierarchy. This number will change if the record’s position within the FMEA changes.
  
  - For example, a failure record with # = 2.3 is currently the third failure for the second function in a particular FMEA.

- **ID** is assigned automatically when the record is created. It is unique throughout the repository for a given record type and it does not change. If you copy/paste or import a record, each new instance will receive its own unique ID.
  
  - For example, a failure record with ID = 25 is the 25th failure record that was created in any of the FMEAs within the current repository.

- **Keywords** are words or phrases (separated by commas) that can be used to find or filter analysis data. If desired, you can use the **Smart Add Keywords** utility to automatically choose words from the name and/or description for this record.

### Associated Records

The fields under the **Associated Records** heading show the item, function, failure, effect and/or cause that the current record is associated with.
History (and History Log, if applicable)
The fields under the History heading show when the record was created and last modified (and by whom).

If the history log has been activated for the project, you can click the View Item History icon to see a list of changes to this record since the log was activated.

Ribbon Commands
When you open the properties window from within the FMEA hierarchy, the following ribbon commands are available:

Home > Add
These commands make it easy to add records to the FMEA without closing and reopening the properties window. The options vary depending on the current record type. For example, all of the following commands may be available if you are editing a cause record.

Home > Tools

Configurable Settings allows you to adjust the settings for this record type in the project’s interface style. (In a secure database, this is available only for users with the “Edit project properties” permission.)

Spelling checks the spelling in all text fields within the window.

Attachments opens the Attachments window, which allows you to manage the linked and attached files for the record.
Effect Categorization opens the Failure Effect Categorization window, which allows you to identify and evaluate the effects of the functional failure. This displays only for effect records in RCM++ and RBI.

Task Manager opens the Task Manager window, which allows you to work with tasks assigned to causes within the FMEA and to choose an appropriate maintenance strategy by using one or both of the available task selection methods. This displays only for cause records in RCM++ and RBI.

Change Log is available only if a change log has been activated for the FMEA and only if changes have been made to this record since the log was activated. It opens the Record Change Log window for this record.

Navigate
These commands make it easy to browse through the FMEA without closing and reopening the properties window. The options vary depending on the current record type.

Functions
In an FMEA or RCM, the functions typically state what the item or process is intended to do, usually to a given standard of performance or requirement.

To access the commands to add or edit function records, right-click inside the FMEA hierarchy or worksheet, or use the FMEA tab of the ribbon. (See FMEA Tab for a complete list.)

The properties enabled (and their display names) will depend on the interface style for the current project. To view or change these settings, choose Project > Management > Configurable Settings > Interface Style.
Note the following:

- The **Description** is required.
- The **Name** will be used in locations where the full description would be too long to display (e.g., diagrams).
  - If the field contains an asterisk (*) or is blank when you save the record, the software automatically uses the first 50 characters of the full description.
- The **#, ID, Associated Records, History** and ribbon commands are similar for any FMEA record type. (See [FMEA Records](#)).

**Tip:** You can specify for a default function to be created for all new items added to the System panel by choosing **File > Application Setup** and selecting the **Create a default function for new items** option on the [Settings page](#) of the Application Setup.

---

**Failures (Functional Failures)**

In an **FMEA** or **RCM**, the **failures**, (typically called **functional failures** in RCM analysis), state the manner in which the item or operation fails to meet or deliver the intended function and its requirements.

To access the commands to add or edit failure records, right-click inside the FMEA hierarchy or worksheet, or use the **FMEA** tab of the ribbon. (See [FMEA Tab](#) for a complete list.)

The properties enabled (and their display names) will depend on the interface style for the current project. To view or change these settings, choose **Project > Management > Configurable Settings > Interface Style**.
Note: In Version 11, the Mechanism of Failure field is now available for both Failure records and Cause records. You can use the project’s interface style to enable the field for either record type.

Note the following:

- The Description is required.
- The Name will be used in locations where the full description would be too long to display (e.g., diagrams).
  - If the field contains an asterisk (*) or is blank when you save the record, the software automatically uses the first 50 characters of the full description.
- The #, ID, Associated Records, History and ribbon commands are similar for any FMEA record type. (See FMEA Records.)
- The Failure Probability and Severity Class fields are used in criticality analysis and will only be available if they are enabled on the FMEA > Criticality page of the project's interface style. Note that the application will not fully validate these factors until you perform the criticality analysis.

Tip: If you need to define the reliability/maintainability characteristics for this record, use the FMRA tab. These characteristics will be applicable if you wish to perform criticality analysis, use the FMEA occurrence ratings to calculate a preliminary baseline estimate of the system reliability, share system configuration/reliability data between RCM++/RBI and BlockSim or perform RCM cost/availability calculations.

Effects

In an FMEA or RCM, the effects typically state the consequence of the failure on the system or end user. Some of the features for working with effects will depend on the FMEA structure that has been selected for the current project.
Chapter 7: FMEA Analysis

To access the commands to add or edit effect records, right-click inside the FMEA hierarchy or worksheet, or use the FMEA tab of the ribbon. (See FMEA Tab for a complete list.)

As discussed in Choosing the FMEA Structure, the FMEA Structure field on the General page of the Project Properties determines how the effect and cause records will be displayed in the FMEA hierarchy.

- **Causes Before Effects** - you are limited to only one effect for each cause and you cannot add or insert additional effects.

- **Grouped Effects and Causes** - the properties window will be divided into two sections. In the table at the top of the window, you can enter a separate description and severity rating for each potential effect.

<table>
<thead>
<tr>
<th>Grouped Effect(s) Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
</tr>
<tr>
<td>First possible effect</td>
</tr>
<tr>
<td>Second possible effect</td>
</tr>
<tr>
<td>Third possible effect</td>
</tr>
</tbody>
</table>

When this effect is displayed in a hierarchy or worksheet, all of the descriptions will be combined into a single cell. The individual severity ratings will be shown in parentheses and the highest rating will always be used for the purpose of RPN calculations.
The properties enabled (and their display names) will depend on the interface style for the current project. To view or change these settings, choose Project > Management > Configurable Settings > Interface Style.

Note the following:

- The Description is required.
- The Name will be used in locations where the full description would be too long to display (e.g., diagrams).
  - If the field contains an asterisk (*) or is blank when you save the record, the software automatically uses the first 50 characters of the full description.
- The #, ID, Associated Records, History and ribbon commands are similar for any FMEA record type. (See FMEA Records.)
- The Initial Severity and Revised Severity ratings are numerical values that indicate how serious the consequences will be if the failure occurs. The options in these drop-down lists are based on the severity scale that has been assigned in the configurable settings for the current project. A severity rating must be defined in order for the RPN to be calculated automatically. (The drop-down list works just like the Find panel found elsewhere in the software.)
- In RCM++ and RBI only, the FEC field displays the current Failure Effect Categorization rating that is used for traditional RCM analysis.

Causes (Failure Modes)
In an FMEA or RCM, the causes (typically called failure modes in RCM analysis), state the specific reason for the failure, preferably found by asking "why" until the root cause is determined.
Chapter 7: FMEA Analysis

To access the commands to add or edit cause records, right-click inside the FMEA hierarchy or worksheet, or use the FMEA tab of the ribbon. (See FMEA Tab for a complete list.)

As discussed in Choosing the FMEA Structure, the FMEA Structure field on the General page of the Project Properties determines how the effect and cause records will be displayed in the FMEA hierarchy.

- Causes Before Effects or Grouped Effects and Causes - each cause will be associated with a failure record.
- Effects Before Causes - the cause will be associated with an effect record.

The properties enabled (and their display names) will depend on the interface style for the current project. To view or change these settings, choose Project > Management > Configurable Settings > Interface Style.

Note: In Version 11, the Mechanism of Failure field is now available for both Failure records and Cause records. You can use the project's interface style to enable the field for either record type.

Note the following:

- The Description is required.
- The Name will be used in locations where the full description would be too long to display (e.g., diagrams).
  - If the field contains an asterisk (*) or is blank when you save the record, the software automatically uses the first 50 characters of the full description.
- The #, ID, Associated Records, History and ribbon commands are similar for any FMEA record type. (See FMEA Records.)
• Use **Classification** to identify design characteristics that require special manufacturing control (e.g., Critical, Significant, Key Leading, etc.).

• The options in the following drop-down lists are based on the rating scales that have been assigned in the *configurable settings* for the current project. The **RPN** will be calculated automatically if you have defined a Severity rating for the effect, and Occurrence and Detection ratings for the cause. (The drop-down lists work just like the **Find panel** found elsewhere in the software.)
  
  • The **Initial Occurrence** and **Revised Occurrence** ratings estimate the probability of occurrence for the potential failure cause.

  • The **Initial Detection** and **Revised Detection** ratings estimate the probability that the problem will be detected before it reaches the customer or end user.

---

**Tip:** If you need to define the reliability/maintainability characteristics for this record, use the **FMRA tab**. These characteristics will be applicable if you wish to perform criticality analysis, use the FMEA occurrence ratings to calculate a preliminary baseline estimate of the system reliability, share system configuration/reliability data between the software and BlockSim or perform RCM cost/availability calculations in RCM++ or RBI.

---

**Controls in FMEAs**

In an **FMEA**, the *controls* typically are the methods to prevent or detect the cause during product development, or can be actions to detect a problem during service before it become catastrophic. There can be many controls for each cause.

Controls will be available in FMEAs only if the **Enable Controls for Causes** option is selected in the current project's interface style. They can also be created and used in control plans and PFD worksheets.
To access the commands to add or edit control records, right-click inside the FMEA hierarchy or worksheet, or use the FMEA tab of the ribbon. (See FMEA Tab for a complete list.)

The properties (and their display names) will depend on the interface style for the current project. To view or change these settings, choose Project > Management > Configurable Settings > Interface Style.

Note the following:

- The **Description** is required.

- The **Name** will be used in locations where the full description would be too long to display (e.g., diagrams).
  - If the field contains an asterisk (*) or is blank when you save the record, the software automatically uses the first 50 characters of the full description.

- The #, ID, **Associated Records**, **History** and ribbon commands are similar for any FMEA record type. (See FMEA Records.)

- The options in the **Control Type** drop-down list depend on the current project’s interface style. By default:
  - **Detection** controls will help to detect the failure before it reaches the end user.
  - **Prevention** controls will help to prevent the failure from occurring.

In the FMEA worksheet view, these controls can be displayed in either one or two columns depending on the project’s settings for the **Number of Controls Columns in Worksheet View** option in the interface style.

- Use the **Associated Actions** node to link the control to new or existing action records. The associated action(s) can be used to incorporate the control into the Test Plan feature, or to track specific responsibilities required to implement a particular control. (See Associating Actions with Controls.)
Deleting Controls from an FMEA
To delete a control from a specific location in an FMEA, select the control and press Delete or right-click the control and choose Delete from the shortcut menu.

This removes the control from the current location, but the resource remains in the project so it can continue to be used in other places. If a resource is not being used in any other locations, in a secure database, an authorized user (i.e., the project owner or any user with the applicable "create/edit/delete resources" permission) can delete it via the Resource Manager.

Actions in FMEAs
In an FMEA or RCM, the actions typically are the tasks recommended by the FMEA team that can be performed to reduce or eliminate the risk associated with a potential cause of failure. Actions are Synthesis resources that can be used multiple times in different locations, if appropriate. Any changes made to the action properties will be reflected in all locations where the same resource is used.

Actions will be available in FMEAs only if the Enable Actions for Causes option is selected in the current project's interface style. They can also be created and used in project plans and My Portal.

To access the commands to add or edit action records, right-click inside the FMEA hierarchy or worksheet, or use the FMEA tab of the ribbon. (See FMEA Tab for a complete list.)

For information about the action properties and other general considerations that are applicable wherever the action may be used, see Actions.
Chapter 7: FMEA Analysis

Deleting Actions from an FMEA
To delete an action from a specific location in an FMEA, select the action and press **Delete** or right-click the action and choose **Delete** from the shortcut menu.

This removes the action from the current location, but the resource remains in the project so it can continue to be used in other places. If a resource is not being used in any other locations, in a secure database an authorized user (i.e., the project owner, the action creator or any user with the applicable "create/edit/delete resources" permission) can delete it via the **Resource Manager**.

RPNs and Related Metrics

Xfmea, RCM++ and RBI make it easy to calculate and display a variety of metrics based on the Severity, Occurrence and Detection ratings that have been assigned for effects and causes in the FMEA:

- **Risk Priority Number (RPN)** is the product of severity x occurrence x detection.
- **SxO** is the product of severity x occurrence.
- **SOD** and **SD** combine the ratings into a 3 or 2 digit number. For example, if the severity is 7, the occurrence is 5 and the detection is 6, then SOD = 756 and SD = 76. When the issues are sorted in descending order, they will be prioritized first by severity, then by occurrence and then by detection.
- **Quantitative Consequence Priority Number (QCPN)** is based on quantitative values associated with each rating in the severity, occurrence and detection rating scales. If you use actual dollar amounts for severity, the QCPN metric will reflect the total expected cost for each issue.

Now in Version 11, the severity and occurrence scales can also be applied to items in the **system hierarchy** to provide a quick estimate of the "Item Risk."

Configure Projects for RPN Metrics

There are two minimum requirements to configure a project to use **RPNs or related metrics** for risk assessment and prioritization. In a secure database, these tasks can be performed only by a user with the "**Edit project properties**" permission for the project.

1. Select or create the appropriate severity, occurrence and detection rating scales.
2. Enable at least one of the metrics in the project’s interface style.

If you want to use the customizable Risk Ranking logic in the FMEA, system hierarchy or risk matrix, you will also need to define the logic in the project’s interface style. (See Risk Ranking Logic.)

**Select or Create Rating Scales**

The default library shipped with Xfmea/RCM++/RBI provides a variety of rating scales that have been published in the literature and popular FMEA standards. You can customize any of these scales or create your own.

To view, edit or select the rating scales for the current project, choose **Project > Management > Edit Project Properties**.

On the Configurable Settings tab, the **FMEA Scales** (Severity, Occurrence, Detection) are used for FMEA RPN metrics and item risk. The **Criticality Scales** (Severity Class, Failure Prob) are used for criticality analysis.
Enable Metric(s) in the Interface Style
To enable the applicable RPN metrics for the project, choose Project > Management > Configurable Settings > Interface Style.

For FMEA metrics (calculated for the failure cause), use the table on the FMEAs > RPNs page of the interface style. For Item Risk metrics (calculated for items in the system hierarchy), use the Item > Properties page.

RPN Metrics in FMEAs, Reports and Plots
When you are working with an FMEA in the Analysis panel, the RPN metrics that have been enabled for a project (except QCPNs) will be displayed in the FMEA.

If you want to display these metrics in the FMEA hierarchy and filtered view, right-click the column headings then click Customize Columns. These settings are stored per computer/username in the FMEA Hierarchy page of the Application Setup.
Here’s an example that shows the causes sorted by initial RPN, and also shows the SxO and SOD.

### Priority Highlights

In all three FMEA views, you also have the option to use color to highlight issues based on priority. Choose **FMEA > Tools > Highlight Priority** to turn the colors on or off.

The logic used to determine the priority for each issue is configurable and can be defined on the **FMEA > RPNs page** in the **interface style** for the project. The highlights can be based solely on the PRN values, or you can define a more complex **Risk Ranking Logic**.
Here's an example that shows highlights based on initial RPN (High Priority >= 300, Low Priority <= 30).

Queries and Reports
Any of the RPN metrics that have been enabled in the project can be used in the queries and reports that you create.

To open the Query Utility, choose Home > Reporting > Queries.

To open the Reports window, choose Home > Reporting > Reports.
As an example, the following query creates a list of failure causes with an initial RPN greater than 200.

**Plot Viewer**
To open the Plot Viewer, choose **Home > Reporting > Plots.**
Refer to the FMEA Plots topic for a list of the available plot types and their descriptions. As an example, the following plot shows the top 10 causes ranked by their initial RPN value.

**Risk Ranking Logic**

The Risk Ranking Logic feature allows you to define your own custom criteria to prioritize issues based on any combination of Severity, Occurrence, Detection, RPN, SxO or SxD. This feature can be used for:

- **Priority Highlights in FMEAs** (if you have selected to highlight priority based on "Risk Ranking" in the project's interface style)
- **Item Risk** in the System Hierarchy
- **Risk Matrix**

To define or modify the Risk Ranking Logic in the current project, first open the interface style (e.g., choose **Project > Management > Configurable Settings > Interface Style**). Then navigate to the **FMEA > RPNs** page and click the **Risk Ranking Logic** button.
If you want to use a risk ranking logic that has already been defined in a library or another project, use the **Copy Existing** feature to import an existing logic. If you want to define a new set of criteria, follow the instructions below.

**Define the Priority Levels**
Click the icon inside the **Priority** column heading to set the levels and colors. For example, this could be [High, Medium and Low], [Action Required and No Action Required], [Critical, High, Medium and Low], and so on.

<table>
<thead>
<tr>
<th>Criterion 1</th>
<th>AND</th>
<th>Criterion 2</th>
<th>AND</th>
<th>Criterion 3</th>
<th>Priority</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Define the Logic Statements**
Each row in the table defines a logic statement based on up to three criteria. Each criterion specifies that a rating or metric must be equal to (=), greater than (>), greater than or equal to (>=), less than (<) or less than or equal to (<=) the specified value.

For example, the following logic identifies an issue as "High" priority if the severity rating for the effect is greater than or equal to 8 and the RPN is greater than or equal to 200.

<table>
<thead>
<tr>
<th>Criterion 1</th>
<th>AND</th>
<th>Criterion 2</th>
<th>AND</th>
<th>Criterion 3</th>
<th>Priority</th>
</tr>
</thead>
<tbody>
<tr>
<td>Severity</td>
<td>&gt;=</td>
<td>RPN</td>
<td>&gt;=</td>
<td></td>
<td>High</td>
</tr>
<tr>
<td>1</td>
<td></td>
<td>8</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>RPN</td>
<td>&gt;=</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
The application considers the statements from top to bottom and applies the priority for the first true statement. For example, if the logic is defined as shown in the following table and an FMEA failure cause is set to S:9 x O:4 x D:6 = RPN:216, then the cause will match both statements. The priority from the first true statement (Medium) will be applied.

<table>
<thead>
<tr>
<th>Criterion 1</th>
<th>AND</th>
<th>Criterion 2</th>
<th>AND</th>
<th>Criterion 3</th>
<th>Priority</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>RPN &gt; 30</td>
<td>RPN &lt; 300</td>
<td></td>
<td></td>
<td>Medium</td>
</tr>
<tr>
<td>2</td>
<td>Severity &gt;= 8</td>
<td>RPN &gt;= 200</td>
<td></td>
<td></td>
<td>High</td>
</tr>
<tr>
<td>3</td>
<td>Item SxO</td>
<td>Item Risk</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Item SxO and Item Risk**

New in Version 11, the Item Risk feature provides a quick way to evaluate the risk for items in the system hierarchy, using the same Severity and Occurrence rating scales that are available to calculate RPNs in FMEAs. The ratings can be used to calculate one or both of the following metrics:

- **Item SxO** is the severity x the occurrence from the ratings that were assigned at the item level.
- **Item Risk** uses the risk ranking logic defined for the project to apply a priority.

**Tip:** If you need more flexibility for the risk assessment, the Risk Discovery Ratings feature allows you to define your own set of categories, factors and rating scales. In Version 11, it also allows you to specify the calculation method (sum, product, max or average).

**Enable Item Risk Metrics for the Project**

To configure a project to calculate the Item SxO or Item Risk, you must enable the ratings and the desired metric(s) on the Item > Properties page of the project’s interface style. (In a secure database, this can be performed only by a user with the "Edit project properties" permission for the project.)
If you choose to use the Item Risk, you must also define the risk ranking logic on the FMEA > RPNs page. The following picture shows a simple example with three priority levels; you can configure the priorities to meet your needs, and set the criteria based on Severity, Occurrence or SxO. (See Risk Ranking Logic.)

<table>
<thead>
<tr>
<th>Property</th>
<th>Type</th>
<th>Enabled</th>
<th>Display Name</th>
<th>Tooltip</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item Severity</td>
<td>Drop-Down</td>
<td>Yes</td>
<td>Item Severity</td>
<td>Rate the severity of item failure using the same Severity rating scale defined for FMEA RPNs. It's used to calculate Item SxO and/or Item Risk.</td>
</tr>
<tr>
<td>Item Occurrence</td>
<td>Drop-Down</td>
<td>Yes</td>
<td>Item Occurrence</td>
<td>Rate the likelihood of item failure using the same Occurrence rating scale defined for FMEA RPNs. It's used to calculate Item SxO and/or Item Risk.</td>
</tr>
<tr>
<td>Item SxO</td>
<td>Number</td>
<td>Yes</td>
<td>Item SxO</td>
<td>Item SxO is based on the Item Severity and Item Occurrence (if enabled for the project). If a Risk Ranking Logic is defined for the project, the value will be color-coded.</td>
</tr>
<tr>
<td>Item Risk</td>
<td>Text (25)</td>
<td>Yes</td>
<td>Item Risk</td>
<td>Item Risk is based on the Item Severity, Item Occurrence and Risk Ranking Logic (if enabled and defined for the project).</td>
</tr>
</tbody>
</table>

System Hierarchy and Item Properties
When the Item Severity and Item Occurrence ratings are enabled for the project, you can view and set the ratings for any item in the system hierarchy from the Properties tab in the Analysis panel.

The Item Risk priorities and highlight colors will be applied automatically if a risk ranking logic is defined for the project and the item's ratings meet the specified criteria.

To view these metrics in the System panel, right-click on the column headings then click Customize Columns. These settings are stored per computer/username in the System Hierarchy page of the Application Setup.
Chapter 7: FMEA Analysis

**Risk Matrix, Queries and Reports**
You can use the same Risk Matrix utility that is available for FMEA RPNs to view the Item SxO or Item Risk for any items in the system hierarchy that have the ratings set. (See Risk Matrix.)

You can also consider these ratings and metrics in configurable report templates (by choosing Home > Reporting > Reports) and queries (by choosing Home > Reporting > Queries).

**Risk Matrix**
The Risk Matrix window provides a visual way to evaluate the risk based on either the Severity and Occurrence ratings or the Severity and Detection ratings. Expanded in Version 11, this utility can now be used for either of the following (if the relevant ratings are enabled in the project’s interface style):

- Failure causes in an FMEA (see FMEA Analysis)
- Items in the system hierarchy (see Item Risk)

If you have configured a customized risk ranking logic for the project that assigns priorities based on SxO or SxD, the matrix will include highlight colors, as shown next.

To open the utility, choose System Hierarchy > Tools > Risk Matrix.

**Select the Matrix Type**
Use the Matrix Type drop-down list to select which ratings to display in the current matrix. The Severity scale will always be displayed on the horizontal axis and you can choose to display either the Occurrence or Detection scale on the vertical axis.
The options will depend on which ratings and metrics are enabled in the project's interface style. For example, if both Item Risk and FMEA RPNs are enabled for the project, you can choose:

- If you are viewing FMEA causes, the matrix can contain causes from a single item's FMEA or the FMEAs for multiple selected items.
- If you are viewing Item Risk, the matrix will contain all of the selected items that have the Item Severity and Item Occurrence defined in the item properties.

### Select the FMEA(s) or Items
In the System Hierarchy area, specify the FMEAs or system hierarchy items that will be included in the matrix.

- If you are viewing FMEA causes, the matrix can contain causes from a single item's FMEA or the FMEAs for multiple selected items.
- If you are viewing Item Risk, the matrix will contain all of the selected items that have the Item Severity and Item Occurrence defined in the item properties.

### View the Items or Causes for Each Cell in the Matrix
The Risk Matrix shows the quantity of FMEA causes or items for each combination of ratings.

The panel below the matrix provides a searchable list of all the records with the combination of ratings for the cell that is currently selected.

To filter the list, type text in the input box. To see where the record appears in the FMEA or system hierarchy, double-click the row or click Go to Record.
In the example below, the panel shows a list of all the causes in all selected FMEAs where S=8 and O=8, and the description contains the word "gear."

Quantitative Consequence Priority Numbers (QCPNs)
The Quantitative Consequence Priority Number (QCPN) is based on quantitative values associated with each rating in the severity, occurrence and detection rating scales.

- **OC** = Probability that the failure will occur (0 < OC => 1)
- **PD** = Probability that the failure will be detected (0 < PD => 1)
- **SD** and **SU** = Cost / impact / consequence / severity if the failure occurs and is either detected (SD) or undetected (SU). This can be any value => 0. It may be greater if the failure is undetected. (SD => 0, SU => 0 and SD <= SU)

\[
QCPN = OC \times PD + (1 - PD) \times SU
\]

If you use actual dollar amounts for severity, the QCPN metric will reflect the total expected cost for each issue.

Since this value is quantitative, it can be rolled up to the item level as a summation.
Enabling and Showing the QCPN Metrics

Similar to other RPN metrics, there are two requirements to configure a project to enable QCPN calculations. (See Configure Projects for RPN Metrics.)

1. Select or create the appropriate severity, occurrence and detection rating scales. For QCPN calculations, the scale must include appropriate quantitative values for all ratings, as discussed below.

2. Enable at least one of the metrics in the project's interface style. For QCPN calculations, you must enable at least S, O, D and QCPN on the FMEAs > RPNs page.

QCPNs can be displayed in the FMEA hierarchy, the filtered view and in customized queries and reports.

Quantitative Values for Rating Scales

The QCPN calculations are based on the quantitative values associated with each rating in the Severity, Occurrence and Detection scales defined for the current project. As an example, the following picture shows portions of three rating scales that were set to meet the needs of a particular project. Your organization can choose different scales or configure the values to fit your particular products and processes.

In this example, an effect rated S = 2 is expected to cost $7,000 if detected or $10,000 if undetected. The probability of occurrence for a cause rated O = 2 is 1 in 100,000 (0.00001). The probability of detection for a cause rated D = 2 is 99 out of 100 (.99). And so on. Therefore, if the S = 2, O = 2 and D = 2, the calculated QCPN would be:

\[
QCPN = 0.000001 \times (0.99 \times 7000 + 0.01 \times 10000) = 0.0703
\]
Chapter 7: FMEA Analysis

Criticality Analysis

Xfmea/RCM++/RBI provide three methods for performing Failure Modes, Effects and Criticality Analysis (FMECA). In the Synthesis version, users have the option to use the updated method (which is integrated directly into the FMRA and FMEA interfaces) or the original method (which has a dedicated utility that can be enabled via the Application Setup, if desired).

Qualitative Criticality Analysis

For qualitative criticality analysis, analysts use predefined rating scales to rate the likelihood of occurrence for each failure mode and the severity of the potential effects of failure. A matrix with severity on the horizontal axis and occurrence on the vertical axis can be used to compare failure modes.

Steps to Perform Qualitative Analysis

1. Make sure that the applicable criticality analysis fields have been enabled for the project (on the FMEA > Criticality page of the interface style).
   - Qualitative analysis uses Failure Probability and Severity Class, as well as Mission Phase/Operational Mode, if desired.

2. Define the item(s) that will be included in the analysis.

3. For each item, create an FMEA and define the functions, failure modes, effects and causes.

4. Define the following for each failure mode. These factors can be specified via the Failure Properties window, FMEA worksheet, FMRA or MIL-1629A Criticality Analysis window (if it is enabled on your computer).
   - Mission Phase/Operational Mode is a description of the conditions when the failure mode might occur. For example, in an airplane, a failure might occur during takeoff, while flying or during landing. This is not required for the analysis but it is usually displayed as a column in MIL-STD style reports.
   - Failure Probability rates the likelihood that the failure mode will occur, according to a predefined scale. The available ratings are based on the Failure Probability rating scale that has been defined for the Project Properties.
   - Severity Class rates the severity of the potential effects of failure, according to a predefined scale. The available ratings are based on the Severity Class rating scale that has been defined for the Project Properties.
5. To generate a report, choose Home > Reporting > Reports to open the Reports window and select all of the items you wish to include in the analysis. Then select the desired criticality reports, which are located under the Criticality heading, as shown next.

<table>
<thead>
<tr>
<th>Criticality</th>
<th>Analysis (Standard)</th>
<th>(1)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Criticality Analysis (MIL-STD Quantitative)</td>
<td>(2)</td>
</tr>
<tr>
<td></td>
<td>Criticality Matrix (MIL-STD Quantitative)</td>
<td>(3)</td>
</tr>
<tr>
<td></td>
<td>Criticality Analysis (MIL-STD Qualitative)</td>
<td>(4)</td>
</tr>
<tr>
<td></td>
<td>Criticality Matrix (MIL-STD Qualitative)</td>
<td>(5)</td>
</tr>
<tr>
<td></td>
<td>Criticality Ranks</td>
<td>(6)</td>
</tr>
</tbody>
</table>

The following reports are applicable for qualitative criticality analysis:

- (4) shows the qualitative criticality analysis in a traditional tabular format.
- (5) shows a matrix with the Severity Class on the horizontal axis and the Failure Probability on the vertical axis.

(These reports can also be generated from the MIL-1629A Criticality Analysis window if it is enabled on your computer.)

Quantitative Criticality Analysis

In the Synthesis version, Xfmea/RCM++/RBI offer a methodology for quantitative criticality analysis that is patterned after MIL-STD-1629A but uses a more general approach that overcomes several inherent limitations and simplifications present in the military standard (including the assumption of a constant failure rate). Furthermore, and instead of dealing with an arbitrary number, this methodology presents the computed criticality number in terms of the probability "that a failure will be caused by the current mode," which is significantly more meaningful and powerful. For specific details on this approach, see [http://www.reliawiki.org/index.php/Criticality_Analysis](http://www.reliawiki.org/index.php/Criticality_Analysis).

This analysis is performed directly in the FMRA with report output generated from the Reports window. If your organization is obligated to use the original method instead, see [MIL-1629A Criticality Analysis](http://www.reliawiki.org/index.php/Criticality_Analysis).

Steps to Calculate Criticality in the FMRA

1. Make sure that the applicable criticality analysis fields have been enabled for the project (on the FMEA > Criticality page of the interface style).
   - Quantitative analysis requires at least Mode Criticality for the quantitative calculation options to become available in the software.

2. Define the item(s) that will be included in the analysis.
3. For each item, create an FMEA and define the functions, failure modes, effects and causes.

4. If the FMRA is not already displayed in the System panel, choose View > FMRA > Show FMRA to make it visible.

5. If the criticality analysis columns are not already displayed in the FMRA hierarchy, right-click any of the column headers, then click Customize Columns. Select the four columns shown next and click OK to save the changes.

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Probability of Failure (Analytical)</td>
<td>Displays the record's probability of failure at the system's specified operating time. This is the inverse of reliability (1-R).</td>
</tr>
<tr>
<td>Mode Ratio</td>
<td>Normalized mode ratio of the item's probability of failure (for criticality analysis).</td>
</tr>
<tr>
<td>Prob of Loss</td>
<td>Displays a factor from 0 to 1 that describes the probability that this failure mode would result in a system failure.</td>
</tr>
<tr>
<td>Criticality</td>
<td>Displays the calculated criticality value. (This column must be displayed when the mode ratio or probability of loss is displayed.)</td>
</tr>
</tbody>
</table>

6. Click the first failure mode in the FMRA hierarchy to display its reliability-related properties in the Analysis panel. The following fields may be applicable for quantitative criticality analysis:

- **Mission Phase/Operational Mode** is a description of the phase or conditions when the failure mode might occur. This is not required for the analysis but it is typically displayed as a column in MIL-STD style reports.

- **Failure Probability** rates the likelihood that the failure mode will occur, according to a predefined scale. The available ratings are based on the Failure Probability rating scale that has been defined for the Project Properties. This is used if you want to define the Reliability Policy based on failure probability.

- **Severity Class** rates the severity of the potential effects of failure, according to a predefined scale. The available ratings are based on the Severity Class rating scale that has been defined for the Project Properties. This is needed if you want the failure mode to appear in the Criticality Matrix report form.

- **Mode Ratio** is the probability that the item's failure will be due to the failure mode under consideration (i.e., the percentage of all failures for the item that will be due to the given mode). This will be calculated automatically by the
software based on all of the failure probabilities that have been defined for the analysis.

- **Probability of Loss (Model)** is a factor from 0 to 1 that describes the probability that this failure mode would result in a system failure. By default, this is set to 1 (Actual Loss). To enter a different value, double-click inside the field to display the Model Wizard. Using a Constant or a Distribution: Note that the software also allows you to define this factor with a time-dependent distribution for situations when the probability of loss increases as the operating time increases. In this case, the software will calculate the decimal based on the distribution/parameters and the operating time you have specified for the criticality analysis. To switch from a constant to a distribution (and vice-versa), click the buttons in the top-right corner of the Model Wizard. When a constant model is displayed in the wizard, the New Distribution icon allows you to switch to a distribution. When a distribution is displayed, the New Constant icon allows you to switch to a constant.

- **Reliability Policy** allows you to specify how the software will calculate the failure mode's probability of failure. The options include:
  
  - **Based on Failure Probability**: If the Failure Probability rating scale is enabled for this project and if you have selected a rating for this mode, then the software can automatically assign a quantitative model based on the specified rating. (See Using Rating Scales to Set the Reliability Policies.)
  
  - **Define at this level**: If you know the probability for this failure mode, you can either create a new model or select an existing model to define it here.
  
  - **Inherit**: If you have defined the probabilities for all of the associated causes, the software can automatically calculate the probability that the failure mode will occur. For details, refer to Setting the Reliability Policies.

7. Select the top-level item in the FMRA hierarchy and specify the relevant **Operation** properties.

   - The **Operating Time** field must be entered.
   
   - The software assumes that the item was new at the beginning of the mission (Current Age = 0) and it will operate for 100% of the operating time (Duty Cycle = 1), but you can adjust these factors if desired.
Chapter 7: FMEA Analysis

- The **Maintenance Group** field is not relevant for criticality calculations.

<table>
<thead>
<tr>
<th>Operation</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating Time</td>
<td>750 (Hr)</td>
</tr>
<tr>
<td>Current Age</td>
<td>0 (Hr)</td>
</tr>
<tr>
<td>Duty Cycle</td>
<td>1</td>
</tr>
<tr>
<td>Maintenance Group</td>
<td></td>
</tr>
</tbody>
</table>

**Note:** The operating time can be defined only for top-level (system) items in the hierarchy, and this time applies to all of the system’s dependents. Thus, if your criticality analysis considers the failure modes associated with only one system, and if you want to compare the failure modes, then you only need to define the operating time for that system. However, if your criticality analysis considers multiple systems that you want to compare, then, to make a valid comparison, you need to enter the same operating time for each system.

8. Finally, to perform the calculations, choose **FMRA > Calculations > Calculate (Reliability)**.

The Calculation Options window provides the following options:

- **What items do you want to calculate?** If the project contains more than one top-level item, you can choose to perform the analysis only for the system that is currently selected, or for all systems defined in the hierarchy.

- **Calculation Method:** If the FMRA is synchronized with BlockSim, you can choose to use BlockSim's version to calculate the probabilities of failure; otherwise you must use the software's calculations, which assume a reliability-wise series configuration among all the records in the FMRA hierarchy.

When you click **OK**, the software will calculate the probability of failure for each failure mode and automatically determine the Mode Ratios based on all of the failure modes that have been defined for each item. (To give a very simple example, if the item has two failure modes that both have the same probability of failure, then they will both contribute equally to the item’s probability of failure, and therefore they both have Mode Ratio = 0.5.)

Then the software will calculate the mode criticality and item criticality, and the results will be displayed in the Criticality column of the FMRA hierarchy.

**Tip:** To specify the displayed math precision for the calculated values, choose **File > Application Setup** then define your preferences on the Settings page.
9. To generate a report, choose Home > Reporting > Reports to open the Reports window and select all of the items you wish to include in the analysis. Then select the desired criticality reports, which are located under the Criticality heading, as shown next.

<table>
<thead>
<tr>
<th>Criticality</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Criticality Analysis (Standard)</td>
<td>(1)</td>
</tr>
<tr>
<td>Criticality Analysis (MIL-STD Quantitative)</td>
<td>(2)</td>
</tr>
<tr>
<td>Criticality Matrix (MIL-STD Quantitative)</td>
<td>(3)</td>
</tr>
<tr>
<td>Criticality Analysis (MIL-STD Qualitative)</td>
<td>(4)</td>
</tr>
<tr>
<td>Criticality Matrix (MIL-STD Qualitative)</td>
<td>(5)</td>
</tr>
<tr>
<td>Criticality Ranks</td>
<td>(6)</td>
</tr>
</tbody>
</table>

The following reports are applicable for quantitative criticality analysis:

- (1) or (2) will show the quantitative criticality analysis in a traditional tabular format.
- (3) shows a matrix with the Severity Class on the horizontal axis and Mode Criticality on the vertical axis.
- (6) displays the items/failure modes ranked by item criticality and then by mode criticality.

**MIL-1629A Criticality Analysis**

This topic describes how to enable and use the MIL-1629A Criticality Analysis utility. If you prefer to use the criticality analysis methods that are performed directly in the FMRA, see Qualitative Criticality Analysis or Quantitative Criticality Analysis.

**Enabling and Accessing the MIL-1629A Analysis**

If you wish to be able to access the MIL-1629A Criticality Analysis window on your computer, select the Enable MIL-1629A Criticality check box on the Settings page of the Application Setup. When this option is selected, the MIL-1629A Criticality command will be visible on the Home tab of the ribbon.

This command will be available only if at least one criticality analysis field is enabled in the project. Furthermore, in order to be able to calculate results, there must be at least one failure mode defined for each item before you open the window.

**Using the Utility**

When you open the utility, use the Select Items window to select one or more items from the current project that you want to include in the criticality analysis and click OK.
Chapter 7: FMEA Analysis

When the MIL-1629A Criticality Analysis window opens, the worksheet will display the specific data fields from the item, function and failure mode properties that are relevant for criticality analysis.

Note the following:

- For most of the fields that are editable in the worksheet, you will be able to view/edit the property in either the MIL-1629A Criticality Analysis window or the Item Properties/FMEA/FMRA. Any changes made in one location will be visible in the others. The only exceptions are the Mode Ratio and Prob of Loss columns. These properties can be entered and viewed only via the MIL-1629A Criticality Analysis window. The values that you enter are saved with the failure mode (and visible the next time you view this failure mode in the MIL-1629A Criticality Analysis window), but they are not visible in the Failure properties window in the FMEA or FMRA.

  For the Prob of Loss, if you want to assume a total loss, accept the default setting of 1 (actual loss). If you want to enter a specific decimal value (e.g., 0.3 or 0.73), click in the field and select or create a constant model defined with the appropriate value.

- The reliability type for each item must be set to Define at this level.

- The sum of the values in the Mode Ratio column must be equal to 1 for each item. For example, if an item has four failure modes, the ratios could be something like: Mode A - 0.1, Mode B - 0.3, Mode C - 0.45, Mode D - 0.15 (i.e., 0.1 + 0.3 + 0.45 + 0.15 = 1).

- The cells with a green background color will display the calculated results after you enter all required inputs and click the Calculate button.

The Display Options at the bottom of the window allow you to customize the worksheet to meet your specific needs:

- Select Show current age, quantity and duty cycle if you are using those properties in the item reliability calculations. If the Current Age is 0, the Quantity is 1 and the Duty Cycle is 1 (i.e., there is one item that operates continuously and is subjected to the same loads and/or stresses as the rest of the system), these fields are not relevant and do not need to be displayed. (See Setting the Operation Properties for an FMRA.) These values are not considered in the original military standard methodology and should not be changed if you want to follow that standard exactly.

- Select Include causes with failures if you want to display the cause descriptions in the same column with the failure modes. If only the failure modes are displayed, you will be able to edit the descriptions directly in the MIL-1629A worksheet, if desired. If both the failure mode and cause descriptions are displayed in the same cell, you will not be able to edit the text without closing the MIL-1629A Criticality Analysis window and returning to the FMEA/FMRA.
• Select **Show columns for qualitative analysis** if you want to display the Mission Phase/Operational Mode and Failure Probability columns, which are applicable only if you are performing qualitative analysis.

When the worksheet displays all of the required inputs for quantitative criticality analysis, click **Calculate** to perform the calculations. You can then click **Send to Excel** to export all of the information currently displayed in the worksheet to an Excel file, or click **Reports** to select from a set of predefined report forms that can be generated in either Word or Excel.

**FMEA Plots**

You can create an ad hoc plot for an FMEA or RCM analysis by choosing **Home > Reporting > Plots**.

In the window that appears, select the item(s) you want to include in the plot. The selected item(s) must include at least one FMEA, functional failure analysis or risk discovery analysis; otherwise the plot will not display any data. Click **OK** to launch the Plot Viewer, which will display the plot and provide options for editing the plot.

Note that for all pareto charts, you can specify the range of the FMEA records to show on the plot by using the **Display Range** area on the Plot Viewer's control panel. The scaling of the dependent axis will be based on the minimum and maximum data values of the records in the specified range. If you wish to manually assign values for the scaling, clear the **Automatic Scaling** check box on the control panel and then enter the desired values in the **From** and **To** fields, as shown next.

To save an image of the plot, click the **Export Plot Graphic** icon on the Plot Viewer's control panel. Plot images can be saved in *.*.jpg, *.*.gif, *.*.png or *.*.wmf format.
Types of Plots
The following list describes all available plots that can be created for an FMEA analysis. For general information on working with plots, see Synthesis Plot Utilities.

- **RPN (Pareto)** shows the Risk Priority Numbers (RPNs) of the causes ranked from highest to lowest. Click the **RPN Type** drop-down list on the control panel to choose which values to display. You can view the initial RPNs only, the revised RPNs only, or both values in combination. If you view both values, you can select to sort by either initial or revised values.

- **RPN % Reduction Pareto** shows the reduction in the RPNs of the causes, from the initial values to the revised values, ranked from the greatest percentage reduction to the lowest percentage reduction.

- **Occurrence/Severity Matrix** displays the severity ratings on the horizontal axis and occurrence ratings on the vertical axis and then plots each cause at the intersection of its severity and occurrence ratings. You can specify whether you want to view the initial or the revised ratings, and you can use the **Priority Area Coordinates** area of the control panel to specify the end points for the high and low priority lines.

  *Note:* Pointing to a point on the generated occurrence/severity matrix will display information about the cause, including its severity and occurrence ratings. Note that if your analysis contains a very large number of cause descriptions, pointing to a symbol in the matrix may not display all of the causes represented by that point. However, all causes are still displayed in the Plot Summary.

- **SxO Pareto, Effect Severity Pareto, Cause Occurrence Pareto** and **Cause Detection Pareto** show the applicable values ranked from highest to lowest. Click the drop-down list on the control panel to choose which values to display. You can view the initial values only, the revised values only, or both values in combination. If you view both values, you can select to sort by either initial or revised values.

- **Effect Severity Pie, Cause Occurrence Pie** and **Cause Detection Pie** show the percentage of the effects or causes in the selected analysis that are represented by the rating value displayed in the plot legend. You can view the initial values or the revised values by clicking the drop-down list on the control panel.

- **Classification Pie** shows the percentage of the causes in the selected analysis that are represented by each special design manufacturing characteristic displayed in the plot legend.

- **Action Status Pie** shows the percentage of the actions in the selected analysis that are represented by each status type displayed in the plot legend. To exclude actions with a specific description, such as "None," you can select the **Exclude Records with Description** check box, then enter the specific values in the field.
• **Control Type Pie** shows the percentage of the controls in the selected analysis that are represented by each control type displayed in the plot legend.

• **RD Questions Pie** shows the percentage of the selected items that have a "Yes" answer to each risk discovery question displayed in the plot legend.

• **RD Ratings Pareto** shows the risk discovery rating values of the items ranked from highest to lowest.

• **Effect FEC Pie** is available only in RCM++ and RBI and shows the percentage of the effects in the selected analysis that are represented by each failure effect categorization type displayed in the plot legend.

**Copy Information from the Plot**

You can copy the plot data to the Clipboard so that you can paste it into another application by clicking the **Copy Plot Data** icon in the plot's control panel.

You can copy the plot summary information to the Clipboard so that you can paste it into another application by clicking the **Copy Plot Summary** icon in the plot's control panel.

**FMEA Dashboards**

You can now use the flexible **Synthesis Dashboard utility** for presenting data from the FMEA and FMRA analyses that you perform in Xfmea/RCM++/RBI.

To access this feature, open a project and choose **Home > Reporting > Dashboard**.
Chapter 7: FMEA Analysis

As with any other Synthesis dashboard, you can use the Dashboard Viewer to select any of the layouts that have been predefined for this type of data. In a secure database, only users with the "Manage dashboard layouts" permission can use the Dashboard Manager to create or edit layouts.

Tip: These dashboards always consider all of the FMEA/FMRA data in the current project, so it doesn’t matter which item is currently selected in the system hierarchy. If you wish to focus only on specific item(s) of interest, use the built-in filtering and drill-down capabilities when you configure the dashboard layout. (See Configuring a Drill Down and Configuring a Master Filter.)

Data Source Drop-Down List

When you are creating a dashboard layout based on FMEA/FMRA data, the drop-down list at the top of the Data Source panel gives two options.

- **All FMEA Record Types** returns data from items, functions, failures, effects and causes.
- **FMEA Causes** only returns data from cause records.

As a simplified example, the following picture shows two dashboard grids for the same set of data. The first one uses the data fields for all FMEA record types, while the second uses the fields for FMEA causes only.
## FMEA/FMRA Dashboard Data Fields

<table>
<thead>
<tr>
<th>Data Field</th>
<th>Description</th>
<th>FMEA Causes</th>
<th>All FMEA Record Types</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Properties</strong> (these field names are preceded by the Property- prefix)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Record Type</td>
<td>This can be Item, Function, Failure, Effect or Cause.</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Name</td>
<td>For system hierarchy items, the name is required but the description can be blank. For FMEA records, the description is required. If the name field contains an asterisk (*) or is blank when you save the record, the software automatically uses the first 50 characters of the full description.</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Cause, Effect, Failure, Function, Item</td>
<td>The description for the cause, as well as the effect, failure, function and item that the cause is associated with.</td>
<td>X</td>
<td>-</td>
</tr>
<tr>
<td>FMEA % Completed</td>
<td>The percentage that has been entered via the item properties.</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Target Reliability Target Availability</td>
<td>The value that has been entered via the item properties (for items) or via the FMRA record properties (for causes).</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td><strong>RPN metrics and qualitative ratings</strong> (these field names are preceded by the RPN- prefix)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Si, Sr</td>
<td>The initial and revised severity rating.</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Oi, Or</td>
<td>The initial and revised occurrence rating.</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Di, Dr</td>
<td>The initial and revised detection rating.</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>RPNi, RPNr</td>
<td>The initial and revised RPNs (S x O x D).</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>(SxO)i, (SxO)r</td>
<td>The initial and revised severity times occurrence (S x O).</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>SODi, SODr, SDi, SDr</td>
<td>The initial and revised SOD or SD metrics.</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>
### RPN Reduction %
The percent reduction from the initial to revised RPN. & X & X

### QCPN metrics and quantitative values for ratings (these field names are preceded by the QCPN- prefix)

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
<th>X</th>
<th>X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sev_Det_i, Sev_Det_r</td>
<td>The initial and revised severity if the failure is detected.</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Sev_Un_i, Sev_Un_r</td>
<td>The initial and revised severity if the failure is undetected.</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Occ_Prob_i, Occ_Prob_r</td>
<td>The initial and revised probability of occurrence.</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Det_Prob_i, Det_Prob_r</td>
<td>The initial and revised probability of detection.</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>QCPNi, QCPNr</td>
<td>The initial and revised Quantitative Consequence Priority Number (QCPN).</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>QCPN Reduction %</td>
<td>The percent reduction from the initial to revised QCPN.</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

### FMRA calculations and simulations (these field names are preceded by the FMRA- prefix)

<table>
<thead>
<tr>
<th>Calculation</th>
<th>Description</th>
<th>X</th>
<th>X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reliability</td>
<td>Prob of Failure</td>
<td>Values obtained from <a href="http://xfmea.reliasoft.com">FMRA analytical calculations</a>.</td>
<td>X</td>
</tr>
<tr>
<td>Availability</td>
<td>Operating Cost</td>
<td>Values obtained from <a href="http://xfmea.reliasoft.com">FMRA simulations</a>.</td>
<td>X</td>
</tr>
</tbody>
</table>

### Criticality analysis (these field names are preceded by the Criticality- prefix)

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
<th>X</th>
<th>X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prob of Loss</td>
<td>A quantitative criticality analysis factor defined via the FMRA properties for failure modes.</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Mode Ratio, Criticality</td>
<td>Values obtained from criticality analysis calculations in the FMRA.</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Failure Probability (Scale) Severity Class</td>
<td>The text labels associated with the failure probability and severity class ratings assigned for the failure mode (e.g., Level E – Extremely Unlikely and Category IV – Minor).</td>
<td>-</td>
<td>X</td>
</tr>
</tbody>
</table>
FMEA Tools

Find and Replace

In Xfmea, RCM++ and RBI, the Find and Replace tool allows you to search and replace FMEA records within a specified project in the current database. To access the tool, choose Home > Edit > Find and Replace.

The following picture shows an example of the Find and Replace tool in Xfmea.

To use the Find and Replace tool, follow these steps:

1. Use the Search area to specify which project, analyses and/or record properties to search. If you want to search all data in the current project, accept the default All Analyses option.
2. Use the Find area to choose which type of data to search (Text, Date or Number) and the criterion for the match (Contains, Begins With, is, is empty), and to enter the search word or value.
As an option, you can select the **Case Sensitivity** check box to limit the results to text that have the same case. For example, the search term "teXt" will not find "Text" because the case does not match.

3. In the **Replace With** area, specify the text or value that will be used to replace the existing data for any matches that you select. (Optional)

4. Click the **Find** button. The **Matches Found** area will display a list of any records that match your search criteria. To view the details of a record, double-click it, or select the record and click the **Go To** button. The project will open with the matching record selected.

To replace a text or value with the data that you have specified in the **Replace With** area, select the check box for each record and click the **Replace** button. To select all matched records for replacement, click the check box in the table heading.

**Transfer Projects**

The Transfer Project utility allows you to create a new project with FMEA data transferred from an existing project. This might be used, for example, to create a new process FMEA with data transferred from an existing design FMEA.

**Note:** This utility is intended to be used for transferring FMEA data from one project to another. Related analyses, such as design verification plans, control plans, etc. will not be transferred. This tool is not available for projects that contain linked FMEAs.

When you select an existing project in the project list and choose **Project > Management > Transfer Project**, the Transfer Project window will be displayed.

In the **Edit Project** area, type the name of the new project and choose the profile that will be used to set the configurable settings for the new project.
In the Map Records for Transfer area, select options from the drop-down lists to define how the data will be "mapped" from the original project to the new project. If you click Use Default to reset all of the menus to their defaults, the new project will have all of the same items and functions from the original project. However, the failures in the new project will be based on the causes from the original project, the new effects will be based on the original failures and no causes will be created in the new project. You can then use the new project as a starting point for a new analysis.

<table>
<thead>
<tr>
<th>Map Records for Transfer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create new items from original items.</td>
</tr>
<tr>
<td>Create new functions from original</td>
</tr>
<tr>
<td>Create new failures from original</td>
</tr>
<tr>
<td>Create new effects from original</td>
</tr>
<tr>
<td>Create new causes from original</td>
</tr>
</tbody>
</table>

If the default selections do not meet your needs, you can choose other options from the lists to specify how each type of record in the new project will be created.

**Ratings Update**

When using risk priority numbers in an FMEA, the revised RPN uses a second set of severity, occurrence and detection ratings to estimate the risk after the recommended actions have been implemented.

Now in Version 11, the Batch Update Revised RPN Ratings utility provides a quick way to set the revised ratings to match the initial ratings if they are not already defined. For example, if the recommended actions do not reduce the severity of an effect, then you can leave the Revised Severity field blank while recording the analysis and later use the utility to set all of the empty revised rating fields to match the initial ratings.

Choose FMEA > Tools > Ratings Update.

- **Update** - select to update the revised severity, occurrence and/or detection ratings that are not already set (if any).
- **Apply** - select to update only the records in the current FMEA or in all FMEAs in the current project.
When you click **OK**, you will be prompted to confirm because *this cannot be undone*. The specific changes will not be recorded in any **history log** or **change log**.

### Failure - Cause Matrix

The Failure – Cause Matrix allows you to view the unique failure modes and causes that have been defined in the FMEA. This matrix helps to see when the same cause has been identified for more than one failure mode. To do this, open the FMEA and then choose **FMEA > Tools > Failure – Cause Matrix**.

In the matrix, the failures associated with the selected item will appear by row (i.e., vertically) and the unique causes will appear by column (i.e., horizontally). An X will appear in the intersecting cell when the failure is associated with the cause. You may have to scroll through the window to view all failures and causes associated with the selected item.

This report is not saved within the software. It is automatically generated based on current data each time you open the window. If desired, click **Send to Excel** to save the current report to an Excel spreadsheet.

### FMEA Statistics Window

The FMEA Statistics window displays various statistics about the **FMEA** (both local and linked), including the number of causes, the percentage of causes that have RPN ratings assigned, the number of actions, etc. You can use these statistics to see how many items need ratings defined and what is the status of the actions assigned to the causes. To view them, open the FMEA and then choose **FMEA > Tools > FMEA Statistics**.

Information about the database, project and item is displayed at the top of the report followed by the statistics. If the **Include sub-items** option is selected, the totals represent the records associated with the FMEA for the selected item and the FMEAs for all of its sub-items. If this option is not selected, the totals represent the records in the current FMEA only.

This report is not saved within the software. It is automatically generated based on current data each time you open the window. Click **Send to Excel** to save the current report to an Excel spreadsheet.
Diagnostic Logic Assistant (DLA)

The product knowledge recorded in an FMEA can be a valuable resource for many other activities in the product life cycle. One practical application for this data is to assist in the development of diagnostic/repair/troubleshooting documentation that may be provided in repair manuals and used by customer care agents.

The Diagnostic Logic Assistant window makes it easy to extract relevant data from the FMEA into Microsoft Excel, where you can organize and filter it as needed when preparing supporting documentation. To access the utility, choose System Hierarchy > Tools > Diagnostic Logic Assistant.

The table displays all of the effects from all of the FMEAs in the current project. The Component column indicates which item’s FMEA the effect appears in, while the Failure and Cause columns identify the possible failure modes that might result in this outcome.

You can use the check boxes at the top of the window to determine whether the table will also display the occurrence and detection ratings that were assigned to these potential failure modes in the FMEA (if any).
For example, the following picture in Xfmea shows fictional data from the FMEAs performed on the components of a chandelier, and the partial troubleshooting guide that might be developed based on the data for the "No light" effect.

Note that this report is not saved within the Synthesis repository. It is automatically generated based on current data each time you open the window. Click **Send to Excel** to save the current report to an Excel spreadsheet.
Chapter 8: RCM Analysis

RCM++ & RBI Only

ReliaSoft’s RCM++ and RBI applications both offer a complete set of utilities to address the analysis steps specific to reliability centered maintenance (RCM).

Note About RCM Terminology: This application combines RCM and FMEA capabilities together in the same software interface. Although the property names within the software are fully configurable to fit the specific analysis terminology used by your organization, the ribbon commands, icons and window names are the same for all projects. Therefore, regardless of whether you are performing an RCM analysis or an FMEA, all of the information related to the functions and failure modes will be displayed in the FMEA tab of the Analysis panel and you will use the commands in the FMEA tab to manage this information. In other words, the term "FMEA" is often used within the software interface in place of "functional failure analysis."

In addition, when a name is not configurable, the term "Failure" is used to refer to the second level in the analysis hierarchy and the term "Cause" is used to refer to the fourth level. If you are performing an RCM analysis, you might refer to these levels as the "Functional Failure" and "Failure Mode." If you are performing an FMEA analysis, you might refer to these levels as the "Failure Mode" and "Cause."

RCM Background

RCM++ & RBI Only

Reliability Centered Maintenance (RCM) analysis provides a structured framework for analyzing the functions and potential failures for a physical asset (such as an airplane, a manufacturing production line, etc.) in order to develop a scheduled maintenance plan that will provide an acceptable level of operability, with an acceptable level of risk, in an efficient and cost effective manner.

According to the SAE JA1011 standard, which describes the minimum criteria that a process must comply with to be called "RCM," a reliability centered maintenance process answers the following seven questions:

- What are the functions and associated desired standards of performance of the asset in its present operating context (functions)?
- In what ways can it fail to fulfill its functions (functional failures)?
- What causes each functional failure (failure modes)?
Chapter 8: RCM Analysis

- What happens when each failure occurs (failure effects)?
- In what way does each failure matter (failure consequences)?
- What should be done to predict or prevent each failure (proactive tasks and task intervals)?
- What should be done if a suitable proactive task cannot be found (default actions)?

Although there is a great deal of variation in the application of RCM, this topic provides a brief general overview of common RCM techniques and requirements.

Prepare for the Analysis

As with almost any project, some preliminary work will be required to prepare for the RCM analysis. Some important up-front activities include:

- **Assemble Analysis Team**: One of the first steps in performing an RCM analysis is to assemble a cross-functional team of knowledgeable individuals to perform the analysis. The team should be large enough to make sure that relevant viewpoints and knowledge are represented but not too large. If the team is too large, it will be difficult to have productive discussions during meetings and it will be a waste of an extremely valuable resource – the time and patience of your organization’s subject matter experts.

  The composition of the team at any particular meeting may vary depending on the focus of the discussion. Team members should be familiar with the RCM analysis process, as it is practiced by the organization. In addition, a skilled facilitator can help to make sure that team meeting time is used effectively and the analysis is performed correctly.

- **Establish Ground Rules and Assumptions**: Identifying and documenting the ground rules and assumptions that will be followed can facilitate the analysis process by making sure that all members of the team understand and accept the conditions of the analysis. Issues to be discussed when preparing for the analysis may include:
  - Identify the scope of the analysis project and address other project management issues, such as schedule, budget, meeting procedures, etc.
  - Define the expected operational environment for the equipment and any other assumptions that may affect the analysis. For example, if the equipment is expected to be operated within a specific temperature/humidity range, will potential failures that occur beyond these ranges be considered in the analysis?
  - Agree on the definitions of failure that will be followed during the analysis.

- **Gather and Review Relevant Documentation**: The analysis team may identify existing references that will provide valuable input to the RCM analysis activity, such as operation manuals, previous maintenance plans, prior failure reports, etc.
Tip: You can use the analysis plan feature for a variety of project planning features, including the ability to document the members of the analysis team and the ground rules and assumptions.

Select the Equipment to Be Analyzed

Because RCM analysis requires an investment of time and resources, the organization may wish to focus analysis resources on selected pieces of equipment based on safety, legal, economic and other considerations. Two methods of equipment selection that are commonly employed are directly supported within the software.

The Selection Questions method consists of a series of yes/no questions that are designed to identify whether analysis is indicated for a particular piece of equipment. For example, the MSG-3 guideline, which is used to develop initial scheduled maintenance plans for the aircraft industry, proposes four questions (from the ATA MSG-3 Operator/Manufacturer Scheduled Maintenance Development guidelines, Revision 2003.1, Air Transport Association of America, 2003):

- Could failure be undetectable or not likely to be detected by the operating crew during normal duties?
- Could failure affect safety (on ground or in flight), including safety/emergency systems or equipment?
- Could failure have significant operational impact?
- Could failure have significant economic impact?

If the analysts answer "yes" for at least one of these questions, then detailed analysis is indicated for the equipment.

The Criticality Factors method consists of a set of rating scales designed to evaluate the criticality of the equipment in terms of relevant factors, such as safety, maintenance, operations and environmental impact. Each factor is rated according to a predefined scale where the higher ratings indicate higher criticality. The equipment’s overall criticality value can then be used as a ranking and/or as a threshold. For example, the analysis team may choose to start on the equipment with the highest criticality and proceed down the list as resources allow. Alternatively, the team may agree to perform detailed analysis for equipment with a criticality value higher than a specified threshold or to perform detailed analysis for all equipment with a criticality value in the top 20%.

Other methods may also be applied, such as Pareto analysis of equipment based on downtime, unreliability or another relevant metric. Whichever method (or combination of methods) is employed, the goal is to focus RCM analysis resources on the equipment that will provide the maximum benefit to the organization in terms of safety, legal, operational, economic and related priorities.
Identify the Functions
One of the primary tenets of the RCM approach is that maintenance activities should be focused toward preserving equipment functionality. Therefore, it follows that the first step in analyzing a particular piece of equipment is to identify the functions it is intended to perform.

Many RCM references recommend including specific performance requirements in function descriptions, which will help to specifically identify functional failures. For example, "To provide hydraulic pressure of 3000 psi +/- 200 psi."

Identify the Functional Failures
Functional failures describe ways that the equipment may fail to perform its intended functions. This may include failure to perform a function, poor performance of a function, over-performance of a function, performing an unintended function, etc. As mentioned above, the performance limits that have been identified for the function may provide a guide to the functional failure description. For example, if the function is "To provide hydraulic pressure of 3000 psi +/- 200 psi" then the functional failures might include: "Provides hydraulic pressure of more than 3200 psi," "Provides hydraulic pressure of less than 2800 psi," etc.

Identify and Categorize the Effects of Failure
Identifying and evaluating the effects of failure will help the team to prioritize and choose the appropriate maintenance strategy to address a potential failure. Many RCM references contain logic diagrams that can be used to categorize the effects of failure. The following logic diagram is provided as an example in the SAE JA1012 “Guide to the Reliability-Centered Maintenance (RCM) Standard.” (From SAE JA1012 “A Guide to the Reliability-Centered Maintenance (RCM) Standard,” issued in January 2002) Note: Only the Failure Effect Categorization portion of the logic is presented here. For the Task Selection portion, see Select the Appropriate Maintenance Tasks.
Chapter 8: RCM Analysis

This diagram has 5 questions with 6 failure effect categories. Other published logic diagrams may consist of 3 or 4 questions with 4 or 5 failure effect categories.

Tip: You can use any of the predefined logic diagrams that are shipped with the software or define your own custom logic diagram with 4, 5 or 6 categories.

Identify the Causes of Failure (Failure Modes)

The cause of failure (sometimes also called failure mode) represents the specific reason for the functional failure at the actionable level (i.e., the level at which it is will be possible to apply a maintenance strategy to address the potential failure). This determination is based on engineering judgment and relies on the team’s experience and skill with the RCM analysis process.

The SAE JA1012 guideline presents a useful demonstration of the many levels of detail that can be used to describe failure modes. For example (from SAE JA1012 "A Guide to the Reliability-Centered Maintenance (RCM) Standard," issued in January 2002):

- Pump set fails
  - Pump fails
    - Impeller fails
      - Impeller comes adrift
• Mounting nut undone
  • Nut not tightened correctly
  • Assembly error

The recommendation states that "failure modes should be described in enough detail for it to be possible to select an appropriate failure management policy, but not in so much detail that excessive amounts of time are wasted on the analysis process itself."

Select the Appropriate Maintenance Tasks

Once you have identified the ways that the equipment might fail to perform its intended functions and evaluated the consequences of these failures, the next step is to define the appropriate maintenance strategy for the equipment. Although there is variation among practitioners regarding the terminology used to describe the available maintenance techniques, the typical options that the RCM analysis team may recommend include:

• Run-to-Failure – fix the equipment when it fails but do not perform any scheduled maintenance actions.

• Scheduled Inspections
  • Failure Finding Inspections – inspect the equipment on a scheduled basis to discover hidden failures. If the equipment is found to be failed, initiate corrective maintenance.
  • On-Condition Inspections – inspect the equipment on a scheduled or ongoing basis (condition monitoring) to discover conditions that indicate a failure is about to occur. If the equipment is found to be about to fail, initiate preventive maintenance.

• Scheduled Preventive Maintenance
  • Service – perform lubrication or other minor servicing actions on a scheduled basis. These actions may renew the equipment to some extent but they are not expected to have the same effect as a full repair or replacement.
  • Repair – repair or overhaul the equipment on a scheduled basis.
  • Replace – replace the equipment on a scheduled basis.

• Design Change – re-design the equipment, select different equipment or make some other one-time change to improve the reliability/availability of the equipment.

The RCM analysis team’s decision of which strategy (or strategies) to employ for each potential failure may be based on judgment/experience, a predefined logic diagram (often connected to the failure effect categorization), cost comparisons, or some combination of factors. To
continue with the SAE JA1012 example introduced in Identify and Evaluate (Categorize) the Effects of Failure, the following picture shows the questions to be considered for failures with effects that have been categorized as "Hidden Operational." The full logic diagram also includes a separate set of questions for each of the other five categories.

Tip: You can use one of the predefined sets of task selection questions that are shipped with the software or define your own custom questions and task types.

Another approach is to compare normalized cost values and select the maintenance task that provides the desired level of availability for the minimum cost. For example, the team may recommend a run-to-failure maintenance strategy if a) the issue does not have an impact on safety, b) the run-to-failure approach provides an acceptable level of equipment availability (uptime) and c) the cost per uptime is less than it would be with a scheduled repair/replacement.
Chapter 8: RCM Analysis

Tip: You can simulate the operation of the equipment for a specified period of time in order to make estimates about the cost and availability that you can expect from potential maintenance strategies.

RCM References

- "Practical Application of Reliability-Centered Maintenance" by the Reliability Analysis Center, issued in 2003.

**Functional Failure Analysis (FFA)**

After you have determined which pieces of equipment will be analyzed with RCM techniques, the next step is to perform a functional failure analysis on the equipment. You do this in a manner similar to creating a Failure Modes and Effects Analysis (FMEA).

Tip: This section provides basic instructions for this portion of the analysis. The FMEA Analysis section of this documentation provides more detailed information about the features available in the Analysis.
1. Select an item in the system hierarchy and choose *Analyses > FMEA > Add FMEA*. The FMEA analysis tab will open in the Analysis panel. In addition, the FMEA icon (F) will appear in the FMEA column in the system hierarchy, if the column is displayed.

When working in the Analysis panel, you have a choice of several ways to enter and edit the information. To use one of these views, click its tab at the bottom of the Analysis panel.

- You can use the **Hierarchy** view, which displays the analysis records defined in your analysis (e.g., functions, actions, etc.) at a glance in a hierarchical tree structure. For more information about using this view, refer to [*FMEA Hierarchy View*](#).

- You can use the **Worksheet** view, which displays the functional failure analysis in a tabular format. The worksheet presents a column for each data field that has been enabled in the interface style for the project. For more information about using this view, refer to [*FMEA Worksheet View*](#).

- You can use the **Filtered** view, which displays only records of a specific type (e.g., functions, tasks, etc.). Choose the record type that you want to view from the drop-down list at the upper right corner of the Analysis panel. For more information about using this view, refer to [*FMEA Filtered View*](#).

2. Describe the functions the equipment is intended to perform.

   To add a function to the analysis, choose *FMEA > FMEA Records > Functions* and then provide information about what functions the equipment is intended to perform (e.g., for an airplane fire extinguishing system, a function might be "Store extinguishing agent under pressure").

3. Describe the potential functional failures.

   To add a functional failure to the analysis, choose *FMEA > FMEA Records > Failures* and then provide information about the ways that the equipment might fail to perform its intended functions (e.g., for an airplane fire extinguishing system, a functional failure might be "Fails to maintain full quantity of agent at correct pressure").
4. Describe the effects of each functional failure.

   To add an effect to the analysis, choose FMEA > FMEA Records > Effects and provide information about the potential consequences if a failure occurs (e.g., for an airplane fire extinguishing system, an effect might be "Insufficient agent available in the Fire Extinguisher bottle for effective discharge").

5. Describe the potential failure modes.

   To add a failure mode to the analysis, choose FMEA > FMEA Records > Causes and provide information about the specific reason for the functional failure at the actionable level (e.g., for an airplane fire extinguishing system, a failure mode might be "Leakage from Fire Extinguisher bottle assembly").

The following sections describe how to apply an RCM logic diagram and/or cost-based comparisons in order to determine the appropriate maintenance strategy to address the issues that have been identified in the functional failure analysis.

**Failure Effect Categorization (FEC)**

*RCM++ & RBI Only*

The Failure Effect Categorization window allows you to evaluate and categorize the effects of each functional failure, which can help the RCM analysis team to prioritize and choose the appropriate maintenance strategy to address the issues that have been identified.

**Authorized users** can define the questions and categories that will be used for this portion of the analysis. If you want to edit the questions and categories for the current project only, go to the Configurable Settings page of the Project Properties window and click the View/Edit Settings icon at the right side of the FEC Logic drop-down list.

If you want to define questions and categories that could be applied to other projects also, use the Profiles/Library Manager to update the active library and then return to the Project Properties window and apply the questions and categories to the current project. If you want the settings to apply only to the current project, change the settings in the Project Properties window only.
There are three ways to access the Failure Effect Categorization window, you can:

- Select an existing effect and choose FMEA > FMEA Records > Effects > Effect Categorization.
- Click the View/Edit Effect Categorization button that appears when you click the FEC field in the Effect Properties window.
- In the Task Manager, click Effect Categorization.

To begin the failure effect categorization process, answer Question 1 by selecting the Yes or No option. After doing so, the Answer 1 field on the right side of the window becomes available. You can use this field to document the reasons why the team chose the answer they did. To save time and ensure consistency, you can select from responses that have been set for this question for other effects. Click the Select Existing button next to the input field to open the Select Existing Text window.

Your answer to a question determines which of the following questions must be answered. Continue answering the rest of the applicable questions by selecting the Yes or No option and documenting the reasons, if desired. After you have answered the last question, the FEC category will be highlighted at the bottom of the window.

The FEC will also appear in the Category box on the right side of the window. You can select the category directly from the drop-down list in the Category box; doing this will automatically set the answers to the categorization questions and enable the appropriate answer fields.

Click OK to set the category. The failure effect categorization will also appear in the FEC column in the Analysis panel, if the column is displayed. To hide or display columns, right-click the column headers in the FMEA hierarchy view, then click Customize Columns to select which columns you want to display. These settings are stored per computer/username in the FMEA Hierarchy page of the Application Setup, so any project that you open on this computer will have the same columns displayed.

Clear All: Clears all entries and selections made in the window.

Spelling: Checks the spelling of the text in all input boxes within the window.
Chapter 8: RCM Analysis

The status bar at the bottom of the window displays the date/time of the last change to the failure effect categorization and the user who made the change.

Task Manager and Task Selection

The Task Manager allows you to work with tasks assigned to causes within the FMEA and to choose an appropriate maintenance strategy by using one or both of the available task selection methods.

To open the Task Manager from the FMEA hierarchy, double-click the Tasks node associated with the relevant cause or right-click it and choose Task Manager from the shortcut menu.

Note: For a general explanation of how to create and edit task records, refer to the Tasks topic. For instructions on how to use simulation to compare potential maintenance strategies based on cost and/or availability, refer to Using Simulation and Cost Calculations.

You can use the commands in the Tasks group of the Task Manager's ribbon to add a new task to the cause's URD, add an existing task to the URD, edit a task already associated with the URD or delete (i.e., remove) a task from the URD. You can use the commands in the Related Records group to view and/or edit the associated URD, model and corrective task.

Task Selection

The software's Task Manager supports two different methods that can help with the maintenance task selection portion of the analysis. One approach uses a series of questions that can guide you through the process of selecting an appropriate maintenance strategy. The other approach allows you to simulate the operation of the equipment with a given maintenance strategy in order to make estimates that can be used to compare tasks. You can choose to use one approach or the other, or a combination of both.

- **Using Maintenance Task Selection Logic**: For instructions on how to use a predefined set of questions to help you choose the appropriate maintenance strategy, refer to Using Maintenance Task Selection Logic.

- **Using Simulation and Cost Calculations**: For instructions on how to use simulation to compare potential maintenance strategies based on cost and/or availability, refer to Using Simulation and Cost Calculations.

In addition, once you have determined which scheduled tasks are most appropriate to address each failure mode, you may wish to use the software’s built-in utility for calculating the optimum maintenance interval.
Finally, once you have defined the maintenance tasks, you may wish to use the Scheduled Task Packaging window to review the entire maintenance plan and/or create groups of tasks.

### Using Maintenance Task Selection Logic

**RCM++ & RBI Only**

This section provides instructions on how to use a predefined maintenance task selection logic to choose the appropriate maintenance strategy.

**Note:** For a general explanation of how to create and edit task records, refer to the Tasks topic. For instructions on how to use simulation to compare potential maintenance strategies based on cost and/or availability, refer to Using Simulation and Cost Calculations.

Maintenance task selection logic is shown in the Task Manager. To use the maintenance task selection logic approach, you must first have performed failure effect categorization for the associated effect. If this has already been done, the failure effect category of the associated effect will be displayed at the top of the Task Manager. If it has not, you can click Effect Categorization to open the Failure Effect Categorization window.

To begin the maintenance task selection process, answer the first question by clicking inside the Yes/No column. You can use the Explanation column to document the reasons why the team chose each answer. To save time and ensure consistency, you can select from responses that have been set for this question in other tasks. Click the input field and then click the Select Existing button next to the input field to open the Select Existing Text window.

The answers to the questions will help you determine which type(s) of tasks will be applicable and effective to address the current failure mode.

Authorized users can define the questions that will be used for this portion of the analysis. If you want to edit the questions for the current project only, go to the Configurable Settings page of the Project Properties window and click the View/Edit Settings icon at the right side of the Task Selection Logic drop-down list.

If you want to define questions that could be applied to other projects also, use the Profiles/Library Manager to update the active library and then return to the Project Properties window and apply the questions to the current project.
Chapter 8: RCM Analysis

Simulation and Cost Calculations

RCM++ & RBI Only

This section provides instructions on how to use simulation to compare potential maintenance strategies based on cost and/or availability.

Note: For a general explanation of how to create and edit task records, refer to the Tasks topic. For instructions on how to use a predefined maintenance task selection logic to choose the appropriate maintenance strategy refer to Using Maintenance Task Selection Logic.

If you are using the simulation and cost calculations approach, you will be able to define different types of tasks, simulate the operation of the equipment for a specified time and then compare the results to select which task(s) will be most cost-effective in addressing the failure mode.

What's Changed? In previous versions of RCM++, you needed to specify time units in order to use the simulation and cost calculations approach. Units were defined via the interface style. In the Synthesis version, time units are required for all time inputs, allowing compatibility across all Synthesis applications. Authorized users define units at the database level, via the Define Units window.

Define the Probability of Occurrence for the Failure Mode

The model assigned to the cause record (via the URD assigned to the cause record) is used to define the probability that the item will fail due to the particular failure mode. (For information about using the exponential distribution, refer to A Note About the Exponential Distribution (Failure Rate or MTBF).)

Although models can be assigned at various levels in the analysis via the FMRA, you must have a model assigned at the failure mode level in order to use simulation to compare potential maintenance strategies based on cost and/or availability.

Define the Corrective Maintenance Scenario

The corrective maintenance scenario is defined by assigning a corrective task to the URD that is assigned to the cause record. This information is used to estimate the average availability and cost per operating time that could be expected from a run-to-failure maintenance strategy (i.e., performing corrective maintenance only) and it is also required for the simulations of any preventive maintenance strategies that you define.
Chapter 8: RCM Analysis

The following corrective task properties are considered when simulating the run-to-failure maintenance strategy:

- Whether or not the failure mode is detectable. This is based on your selection in the **Start corrective task** field; select **Upon item failure** if the failure mode is detectable or **When found failed during an inspection** if the failure is undetectable.

- The **Task duration**, which is the amount of time that the equipment is expected to be down for each corrective maintenance action. This may include logistical delays and actual repair time.

- Whether the task brings the system down, in addition to bringing the item down. This is defined using the **Task Consequences** properties.

- How much the task restores the equipment, specified using the **Restoration** properties.

- The costs associated directly with the task, as specified in the **Additional Costs to Consider** properties. This may include downtime costs, labor costs, material costs and any other miscellaneous costs. (Note that if you have provided information on crews and/or **spare part pools** for the task, then labor costs and material costs may be accounted for via those resources.)

**Define the Preventive Maintenance Scenario(s)**
In order to use simulation to compare potential maintenance strategies based on cost and/or availability, you will need to define a task record for each potential maintenance strategy that you are considering. Any scheduled task can be part of the preventive maintenance strategy. Authorized users can **define the task types** that will be used for this portion of the analysis.

Scheduled tasks can be assigned to the URD that is assigned to the cause record either via the **Task Manager** or via the **URD window**.

**Perform Simulation**
Once you have defined the probability of occurrence for the failure mode, the corrective task and the possible scheduled tasks, you can click **Simulate** in the Task Manager. You will be asked to **define the simulation settings**. The software will then simulate the operation of the equipment for the specified operating time, given the reliability and maintainability characteristics that you have specified.

In the middle of the Task Manager, the cost per operating time and the average availability associated with a run-to-failure maintenance strategy will be displayed. At the bottom of the Task Manager, the table will display the same metrics for each proposed scheduled task.

**Compare the Maintenance Strategies and Assign the Tasks**
The final step when using the simulation and cost calculations method is to compare the results from the potential maintenance strategies and choose which task(s) will be performed. For
each task that you choose not to add to the scheduled maintenance plan, you can either remove the task from the URD or, if it is not used anywhere else, you can delete the task resource entirely.

**Simulation Settings**

When using the simulation and cost calculations method, once you have defined the probability of failure and the maintenance scenarios for the failure mode, you can then define the simulation settings and run the simulation. To do this, click **Simulate** in the Task Manager.

The Simulate window will appear, allowing you to specify the settings used in simulation.

*Note:* The Simulate window is also used to specify simulation settings in order to predict system availability and operation costs at the system level in the **FMRA**. In this case, it is accessed by selecting the system that you want to simulate and choosing **FMRA > Calculations > Simulate (Availability)**.

The software uses the simulation engines from ReliaSoft’s BlockSim software for system reliability, maintainability and availability analysis.

- **Simulation Setup**
  - **Operation Time:** Specify the amount of operating time to be simulated (i.e., the simulation time) and the time units. The value you enter here will change the system's operating time, shown in the item properties.
  - **Number of Simulations:** Enter the number of simulations that will be performed. A higher number of simulations will take longer to process but may yield more accurate results.

- **Repeatability**
  - **Use Starting Seed:** If you need your results to be repeatable, select this option and enter a seed, which specifies a starting point from which the random numbers used in simulation will be generated. The same random numbers and, therefore, the same simulation results will be generated when the same seed value is used.
  - **Number of Threads:** You can run simulations in multiple threads, which may improve performance and save time when simulating complex configurations. In general, using twice as many threads as the number of cores in your computer is appropriate; a ratio of threads to cores greater than this 2:1 ratio is likely to
degrade performance. To have the application automatically determine the number of cores in your system and set the number of threads accordingly, click the Suggested button beside the Number of Threads field.

The number of threads you use affects repeatability of results. In order for your results to be repeatable, you must use the same number of threads and the same seed each time you simulate the diagram. When you are using multithreading, the seed that you specify is the seed for the first thread; seeds for additional threads are sequential (e.g., if you are using 3 threads and your starting seed is 7, the threads will use 7, 8 and 9 as the starting points for random number generation).

Click OK to perform the simulation.

What's Changed? In previous versions of RCM++, the simulation time was set in the item properties or the cause properties.

A Note About the Exponential Distribution (Failure Rate or MTBF)

When deciding whether an item should be replaced preventively, there are two requirements that must be met: the item's reliability must get worse with time (i.e., it has an increasing failure rate) and the cost of preventive maintenance must be less than the cost of the corrective maintenance. If both of these requirements are not met, then preventive maintenance will not be effective, either on a reliability basis or on a cost basis.

If you want to use mean time before/between failure (MTBF) or failure rate to describe the probability of failure, then you will be defining a constant failure rate (i.e., a rate that does not vary with time). In other words, you are assuming an exponential distribution. On the Settings page of the Application Setup, RCM++ and RBI provide two options for defining the exponential parameter: Lambda (which is also called failure rate) or Mean Time (which is also called MTBF).

Therefore, it is important to note that if the equipment's failure behavior follows an exponential distribution, then preventive maintenance will not improve the overall reliability of the equipment. The following simple example illustrates this point.

Suppose that two components follow an exponential distribution with MTBF = 100 hours (or failure rate = 0.01). Component 1 is preventively replaced every 50 hours, while component 2 is never maintained. If we compare the reliabilities of the two components from 0 to 60 hours:

- **Component 1, with PM:** With PM, the reliability from 0 to 60 hours is based on the reliability of the original item operating for 50 hours, \( R(t=50) = 60.65\% \), multiplied by the reliability of the new item operating for 10 hours, \( R(t=10) = 90.48\% \). The overall result is 54.88%.
• **Component 2, without PM**: Without PM, the reliability from 0 to 60 hours is based on the reliability of the original item operating to 60 hours, $R(60)=54.88\%$.

Likewise, if we compare the reliabilities of the two components from 50 to 60 hours:

• **Component 1, with PM**: With PM, the reliability from 50 to 60 hours is based on the reliability of the new item operating for 10 hours, $R(t=10)=90.48\%$.

• **Component 2, without PM**: Without PM, the reliability from 50 to 60 hours is based on the conditional reliability of the original item operating to 60 hours, having already survived to 50 hours, or $RC(T=60|50)=R(60)/R(50)=90.48\%$.

As this example demonstrates, both maintenance strategies result in the same reliability. In other words, the preventive maintenance does not improve the equipment’s reliability. If you choose to perform preventive maintenance on equipment that does not exhibit an increasing failure rate (i.e., wearout), you may be wasting resources on maintenance actions that provide no benefit. In addition, the unnecessary maintenance may actually reduce the equipment’s reliability by reintroducing infant mortality and/or introducing new failures due to maintenance errors.

**Task Types in RCM++/RBI**

RCM++ and RBI allow users to define a variety of task types for scheduled maintenance, so that the available task types match their organization’s terminology. In order for simulation and cost calculation results in RCM++ and RBI to be accurate, it is necessary to map these task types to the **three scheduled task classes** used in URDs (i.e., preventive, inspection or on condition). To
define the available task types, including their task class association, choose File > Manage Repository > Task Types.

(In a secure database, this is available only to users with the "Manage other repository settings" permission.)

The table in the window displays a list of the existing task types defined for the database. For each task type, you must specify a name, an abbreviation of up to three characters, and a task class that it corresponds to. Click the cell in the Task Class column to choose one of the three scheduled task classes from the drop-down list. You can have multiple task types that use the same task class. This can be helpful in indicating to users which properties should be defined for a given task. For example, a service task and a failure finding task could both be classified as inspection tasks for the purposes of the simulation; however, for the service task, a user will want to define a restoration factor, whereas for the failure finding task, no restoration occurs.

- To edit an existing task type, click inside the cell and either edit the text (in the Name and Abbreviation columns) or choose a new option from the drop-down list (in the Task Class column).
- To add a new task type to the bottom of the list, click inside the last row and enter the data.
- To delete a task type, select the row and click the Delete icon. There is no undo for delete.
- To insert a new task type above an existing one, select the existing row and click Insert.
- To move an existing option up or down in the list, select the row and click the Move Up or Move Down icon.

**What's Changed?** In previous versions of RCM++, task types and the cost calculation methods associated with them were defined via the task selection logic.
Optimum Replacement Window

The Optimum Replacement window helps you to determine the best time to replace components, based on the costs for planned (i.e., preventive) and unplanned (i.e., corrective) maintenance.

Preventive maintenance is a logical choice if, and only if, the following two conditions are met:

- Condition #1: The failure rate of the component in question increases with time, implying wearout.
- Condition #2: The overall cost of the preventive maintenance action is less than the overall cost of a corrective action. (The overall cost for a corrective action should include ancillary tangible and/or intangible costs, such as downtime costs, loss of production costs, lawsuits over the failure of a safety-critical item, loss of goodwill, etc.)

To access the Optimum Replacement window, choose FMRA > Calculations > Optimum Replacement.

Available Items

The Available Items area on the left side of the window shows, for the current branch of the system hierarchy, any item, function, failure or cause that has an associated URD. The following requirements must be met for an item to be available for inclusion in the optimization calculations:

- Must have a failure distribution.
- The failure model must meet the following requirements.
  - Fixed reliability and exponential distributions are not allowed.
  - Weibull distributions must have beta > 1.
  - Gamma distributions must have k > 1.
  - Loglogistic distributions must have std < 1.
  - For generalized gamma distributions and mixed Weibull distributions, there must be an increasing failure rate within at least one time period. A local optimum can then be found within intervals with an increasing failure rate.
Planned and Unplanned Replacement Costs

In the table, the columns with white backgrounds require input. The Planned Replacement Cost and Unplanned Replacement Cost are always required. Simply type the cost directly into each cell.

Calculation Options

When you click Calculate, you can choose from the following options:

- Calculate the individual optimum replacement time for each item.
- Calculate a common optimum replacement time, which is the most cost-effective time to replace all of the selected items concurrently.
- Calculate clustered optimum replacement times, which allows you to specify a number of times to replace groups of the selected items concurrently. For example, if you enter 3 in the Number of clusters field, the software will determine the three best times to replace groups of items such that all of the selected items are replaced at one of the three times.

Results and Plots

The table shows the results for each item. The total costs per unit time based on all included items are displayed under the table.

Click Cost vs. Time Plot to show a plot of the results.

Create Tasks

You can click Create Maintenance Task(s) > At Replacement Time to create preventive tasks for one or more of the items.

The window that appears allows you to select which items to create tasks for. The preventive tasks created in this way restore the item to as good as new condition and are scheduled at fixed intervals based on item age, equal to the optimum replacement time.

Task Packaging
Scheduled Task Packaging Window

For a given project, you can use the Scheduled Task Packaging window to review all of the tasks that have been proposed to be performed at fixed intervals (based either on item age or calendar time), choose which ones to incorporate in the final maintenance plan and, if desired, group tasks into **task packages** for the most efficient allocation of resources.

To open this window, choose **System Hierarchy > Tools > Task Packaging**.

This window consists of two tabs: the Tasks tab and the Plot tab. The Tasks tab allows you to group tasks according to a variety of criteria, and the Plot tab provides a graphical view of how the tasks are currently grouped. You can move tasks into and out of groups as many times as needed, until you come up with a configuration that meets your needs. None of the changes that you make in this window are permanent until you click one of the following:

- **Apply Changes** accepts all changes that you have made in the Scheduled Task Packaging window and commits them to the database.

- **Create Selected Packages** takes the groups that are currently selected in the window and commits them to the database as task packages.

You can tell the difference between a group (which is a proposed task package that has not yet been committed to the database) and a task package (which exists as a resource in the database) by looking at their icons.

To use the Scheduled Task Packaging window, first decide whether you want to view only unpackaged tasks, only packaged tasks or all tasks proposed to be performed at fixed intervals, and make the appropriate selection in the **Filter Tasks** field.

**Grouping Tasks**

You can select any group (including Unpackaged) or package and group the tasks that are in it. Tasks can be automatically grouped by:

- **Task type**

- **Zone**, provided this property is enabled for tasks in the *interface style*.
• Access, provided this property is enabled for tasks in the interface style.

• Time, in three ways:
  • Clusters of time, based on Euclidean distance:
    • Click **Time - Bisect** to divide the tasks into two groups.
    • In the **Time - Clusters** field, specify the number of time clusters to group the tasks into and then click the button.
  • Click **Time - Fixed Interval** to create a group scheduled to be performed at a specified interval.

  In the window that appears:
  • In the **Perform every** field, enter the length of the interval at which the tasks will be performed. You must specify time units for this value.
  • The **Packaging Intervals** fields allow you to specify a range of scheduled intervals that will automatically be incorporated into the task package. The time units for these fields are the same as those specified for the **Perform every** field. For example, if you enter 150 hours in the **Start Time** field and 200 hours in the **End Time** field, then tasks that are scheduled to be performed at fixed intervals from 150 to 200 hours can automatically be included in the group to be performed at the scheduled time rather than at their individually scheduled times.

The groups that are created by automatic grouping are named according to the way in which they were created, but you can double-click a group to change its name.

You can also drag any task into a group or package. Note that you can do this regardless of whether the task meets any criteria that may have been used to create the group or package; it is the user's responsibility to determine whether or not the move is appropriate.

**Managing Groups and Packages**

The following commands are available for working with the groups and packages shown in the Scheduled Task Packaging window.

• To move all tasks out of a group or package and into the Unpackaged group, click **Ungroup Selected**. Note that if you move all tasks out of a group, the group is deleted. If you move all tasks out of a package, the package is not deleted but is empty. While groups may occasionally appear empty, such groups are automatically deleted the next time you perform any operation that refreshes the Tasks tab.
To remove all empty packages, click **Delete Empty Packages**.

If you want to delete a single package, you can do so through the **Resource Manager**.

You can delete a group level by clicking **Remove Level**.

The effect of this command varies depending on what is selected.

- If you have selected a group that has subgroups, the selected level will be deleted, leaving all tasks within the subgroups that they are currently assigned to.

- If you have selected a group that has tasks assigned to it, the group and all of its "sibling" groups (i.e., all groups of that level that share the same parent group) will be deleted and the tasks will be moved up into the parent group. If there is no parent group (i.e., if the selected group is at the top level), the tasks will be moved into the Unpackaged group.

The reason for this behavior is that a group can contain tasks or it can contain subgroups; no group can ever contain both tasks and subgroups. Thus, if you delete one group and move its tasks into its parent group, the same operation must be performed for all of its sibling groups.

You can return to the packaging state saved in the database by clicking **Start Over**. As mentioned above, no changes that you make in the Scheduled Task Packaging window are saved in the database until you click either **Apply Changes** (to accept all changes) or **Create Selected Packages** (to create only the package(s) currently selected).

To mark groups and/or packages as complete or incomplete, select the groups and/or packages and then click **Complete** or **Incomplete**. A flag will appear in the Flag column for each selected group or package. You can remove the flag by selecting the group or package and clicking **Clear**.
Display Options
In addition to the Filter drop-down list, which allows you to specify whether you want to view only packaged tasks, only unpackaged tasks or all tasks, there are several other tools to help you control how information is displayed in the Tasks tab.

- You can use the Time Units drop-down list to change the units displayed in the window.
- The Color Code drop-down list allows you to apply a color-coding gradient to the tasks shown in the window, based on their assigned intervals, from green (shortest interval) to red (longest interval). Choose Overall to apply a single gradient to all tasks, regardless of their package. Choose Within Packages to apply a separate gradient to the tasks within each package. Remove all color-coding by choosing None.
- Click Expand All to show all levels of the hierarchy in the window, or Collapse All to show only the top level. Clicking Collapse Tasks collapses the tasks within each group or package, so that you see only the hierarchical structure of the groups/packages without seeing any of the associated tasks. This command is a toggle; if it is selected, you can expand a group or package, and the next time you perform an action that refreshes the Tasks tab, the tasks will be collapsed again.

Additional Tools
You can click Send View to Excel to send the current contents of the Tasks tab to a new Excel file. The file will then open automatically if the software is installed on your computer.

The Plot tab provides a graphical view of the task grouping/packaging, as it currently stands within the Task tab. Note that this is not a reflection of changes that have been committed to the database, but of the current proposed grouping. The following plot types are available for the Scheduled Task Packaging window:

- Packages displays the groups and packages with vertical lines demarcating their start and end intervals. Tasks assigned to each group are shown with a +, while unpackaged tasks are shown with an X. Note that tasks that share an assigned interval are plotted in the exact same location, so only one is visible. You can select Include Interval to display the interval at which each group is scheduled to be performed as an additional vertical line.
- Packages - Horizontal displays the groups and packages as horizontal lines with points demarcating their start and end intervals. Tasks assigned to each group are shown with a +. Note that tasks that share an assigned interval are plotted in the exact same
location, so only one is visible. Unpackaged tasks are not shown in this plot. You can select **Include Interval** to display the interval at which each group is scheduled to be performed as an additional point on the group line.
Chapter 9: RBI Analysis

RBI Only

ReliaSoft’s RBI software facilitates risk based inspection (RBI) analysis for the oil & gas, chemical and power plants in adherence to the principles and guidelines presented in the American Petroleum Institute's recommendations in the API RP 580 and RP 581 publications, as well as the American Society of Mechanical Engineers’ recommendations in the ASME PCC-3-2007 publication.

RBI Background

The American Petroleum Institute (API) recommends to develop an inspection program using risk-based methods. You can use ReliaSoft's RBI software to record the data relating to the potential damage to specific equipment and components, and then forecast future physical and economic consequences of failure as well as the probabilities of failure for individual components, equipment and entire plants. In addition, you will be able to better plan when to inspect, maintain and replace weak components before failure occurs.

The program is primarily based on two publications: API RP 580 and API RP 581. Both provide guidance on developing a risk-based inspection program for fixed equipment in refining, petrochemical and chemical process plants. The documents are written to include RBI methods for pressurized fixed equipment such as pressure vessels, piping, tanks, pressure relief devices and heat exchanger tube bundles, among others.

Note: RBI corrects several errors that are present in the API RP 580 and API RP 581 standards so the results obtained in the RBI software may differ from those calculated using other methods. These changes included correcting several property values in tables (e.g., the nominal boiling point of NO₂ is 22°C and not the 135°C shown in the standard), correcting inconsistencies in equations and correcting some theoretical inconsistencies.

Introduction

The RBI software calculates the probability of failure and the consequence of failure for given components in a pressurized environment. These calculations are used to help plan inspections and reduce the risk of failure.

The API defines failure as the loss of containment from a pressure boundary resulting in leakage to the atmosphere or a rupture of the pressurized component. Throughout a given period of
time, damage will accumulate within a pressured environment. That damage causes increased risk of failure to equipment and components. After a significant amount of damage, a predetermined risk target is exceeded and an inspection of that component is recommended to better understand and measure the damage.

**Consequences of Failure**

Within RBI, there are two types of consequence analyses: area and financial. The loss of containment by leakage, rupture or other causes can cause damage to nearby equipment, the environment and/or be harmful to personnel. Some components must have both types of consequence analysis performed, while others do not. The consequence properties help to rank components based on risk.

The consequence analysis in the RBI software is modeled after API RP 581’s Level 1 consequence analysis, which is a method used to evaluate the consequences of fluid or gas release.

**Probability of Failure**

In an RBI assessment, the probability of a component failing is based on several factors:

- Each component has its own set of internal properties including its **generic failure frequency** (GFF), which is the frequency of failure prior to any specific damage occurring from exposure to the operating environment. The RBI software calculates the GFF value using four different damage hole sizes and uses adjustment factors to reflect departures from industry data and to account for damage within a given component’s normal operating environment. Hole sizes are Small, Medium, Large and Rupture.

- The **Management Systems Score** is an adjustment factor that accounts for the management influence of a given plant’s supervisors and management on the mechanical integrity of the plant equipment. This factor helps to measure how likely it will be that management finds issues related to the plant’s mechanical integrity. The factor is calculated based on a Management Score Survey that evaluates the facility’s management systems and their effect on a given plant’s risk.

- Each **Damage Factor** is determined in accordance with API RP 581 and is based upon damage mechanisms relevant to construction, process services, current condition and prior damage inspections. According to API 581, the purpose of these damage factors is to provide a way to statistically evaluate the amount of damage that may be present as a function of time in service and effectiveness of an inspection activity to quantify damage.
Program Parts
The API RBI program can be broken down into three parts:

- Determining the Management Score.
- Defining the probability of failure in an RBI Assessment.
- Modeling the consequences in API RBI.

Date Definitions
In a risk based inspection, the following dates are used:

- The installation date is the date the component was installed or replaced. This is set on the General Properties tab.
- The plan date is the next date when the component is scheduled to undergo major maintenance or replacement. It is also set on the General Properties tab.
- The RBI date is the date when you perform the calculations. This is displayed on the Results tab.
- If the RBI analysis indicates that inspections are needed before the plan date, then the Target date is the date when the inspections should be performed to reduce the risk to an acceptable level on the plan date. It is also displayed on the Results tab.
The following graphic shows the risk vs. time curve (i.e., the risk increases as time increases). When you perform an inspection, the risk should go down.

**Risk Categories (Current Repository)**

The Risk Priority labels that are assigned on the Results tab from an RBI analysis (i.e., Low, Medium, Medium High and High) are determined based on two scoring matrices that can be customized to reflect the specific risk tolerance of your organization. Both scoring systems use the same 5-point scale to assign a rating based on the failure probability. In one, this is combined with a second 5-point scale that focuses on the financial consequences of failure (in terms of US$). In the other, the second 5-point scale focuses on the size of the surrounding area that might be affected if a containment failure occurs (in terms of square meters).
To view or modify the rating scales that will be used for all RBI analyses in the current database, choose **System Hierarchy > Risk Based Inspection > Risk Categories**.

For each 5-point rating scale, you can set the **Range** of values that determine which rating will be applied in the RBI analysis results. For example, with the default settings shown in the picture below, the application assigns the lowest (best case) rating of 1 if the calculated failure probability is between 0 and 0.1; whereas, the application assigns the highest (worst case) rating of 5 if the probability is between 0.5 and 1.
You also have the option to customize the Display preferences for these rating scales. For example, with the default settings shown in the picture, the failure probability ratings will be displayed in the RBI analysis results as numbers from 1 to 5, but the consequence ratings will be displayed as letters from A to E. Therefore, if the analysis indicates that the failure probability and consequence both fall into the lowest (best case) rating, the results will display 1 for the failure probability and A for the consequence, while the highest (worst case) ratings will display 5 and E, and so on. The application then uses the scoring matrix table shown below to apply applicable Risk Priority label (Low, Medium, Medium High or High).

When you click OK to save the changes, any existing RBI analysis will be updated automatically.
The Scoring Matrix
The following table shows the scoring matrix.

<table>
<thead>
<tr>
<th>Probability</th>
<th>Consequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td></td>
</tr>
</tbody>
</table>

Defining the Management Score

Each project must include a Management Systems Evaluation score, which is made up of 13 different types of questions and is used in the RBI evaluation results. There are a total of 101 questions with a maximum of 1,000 points. The questions pertain to the areas of plant management, operations, maintenance, safety, inspection, training and engineering. Typically this is done by auditors who are qualified to answer the specific questions.

To open the Management Systems Score window, choose System Hierarchy > Risk Based Inspection > Management Score.

In the Management Score Options area, choose one of the following options:

- If you already know what the score is, such as from a recent inspection, choose Enter score from 0 to 1000 without answering questions and enter a value in the Score field.
If you decide not to or cannot conduct an audit, choose **Assume average score of 500**. In this case the **Score** field value is automatically set to 500.

If you are ready to perform the audit, choose **Answer questionnaire and calculate score**, then do the following:

- Select any row in the **Categories** area on the left. The **Questions** area on the right then displays the applicable questions.

- The **Possible Score** column shows the maximum value (i.e., best case scenario) for each question while the **Actual Score** column allows you to select the applicable score from the drop-down lists.

- If desired, you can use the **Comments** column to record any additional information that is relevant to your rating for the question (up to 255 characters). You can type directly in this field or click anywhere in the field to display the **Select Existing** icon. This icon opens the **Select Existing Text window** that allows you to choose comments used in other data sources.

The **Score** field at the top of the window displays the sum of all the individual question scores.

### Building the RBI System Hierarchy

For RBI analyses, you also have the option to define systems, subsystems and components. However, the risk based inspection analysis can be performed only for specialized items that represent specific equipment and component types that are addressed in the API RP 580/1 guidelines. To perform an RBI analysis, the hierarchy must include:

- At least one piece of equipment that is eligible for RBI analysis. The Add RBI Equipment window provides a list of the equipment types that can be analyzed (e.g., compressor, heat exchanger, etc.).

- At least one component for each piece equipment. The Add RBI Component window provides a list of the component types that are available for the equipment type that is currently selected.
**Note:** The specific types of equipment and components are defined by the RBI methodology and may not be modified or deleted. You can have multiple instances of each type of equipment and component in the same project.

RBI items have the same [item properties](#) as other items in the system hierarchy and can have additional analyses attached (i.e., they can include FMEAs, Risk Discovery Analyses, etc.). They do have the following differences:

- While you can place an RBI item under a non-RBI item, you cannot place a non-RBI item under an RBI item.
- An RBI component item must always be under the relevant equipment type and cannot be placed or promoted above it.

**Adding RBI Equipment**

When you add an RBI equipment to the system hierarchy, it will be added to the bottom of the list.

- Select any item in the system hierarchy other than an RBI component item and choose **System Hierarchy > Risk Based Inspection > Add RBI Equipment**.

  The command opens a window that displays the list of equipment types that have been predefined for RBI analysis. Use the check boxes to select one or more items to add to the system configuration and click **OK**.

**Adding RBI Components**

When you add an RBI component to a piece of equipment, it will be added to the bottom of the list for that equipment.

- Select an RBI equipment item and choose **System Hierarchy > Risk Based Inspection > Add Component**.

  The command opens a window that displays the list of components for that type of equipment (based on the RBI standards). When adding a component, you have the option to create the item immediately or work through the wizard to define the [general properties](#) and [damage factors](#) first. If you choose not to define the properties when adding the component, you can still view/edit these properties at any time from the tabs in the Analysis panel.
Converting System Hierarchy Items to RBI Equipment

You can convert a non-RBI item in the system hierarchy to an RBI item if it is either at the lowest level in its branch or if it has no more than one level of dependents. In addition, the item must not have any RBI equipment items as dependents.

- Select the item and choose **System Hierarchy > Risk Based Inspection > Convert to Equipment**.

The command opens a window where you can choose which equipment type to convert the item to.

- If the item is at the lowest level in its branch, select the desired RBI equipment type and click **OK** to convert the item.
- If the item has dependents, select the desired RBI equipment type and then click **Next >**. On the second page, choose which RBI component type each dependent item will be converted to, then click **OK**.

All converted items retain the original item properties they had before the conversion.

RBI Assessment

RBI Properties

When you have selected an RBI component in the system hierarchy, the RBI properties tab will be visible in the Analysis panel. There are five tabs at the bottom of the panel that lead you through the five steps in the RBI assessment process. For each component, you will be able to:

1. **Define the general properties**.
2. **Select which damage factors are relevant**.
3. **Set the analysis properties** for the relevant damage factors.
4. **Set the consequence properties**.
5. **Generate and evaluate the results**.
6. **View the generated plot**.

Note that the selections you make in earlier steps determine which properties you must set in later steps. You have the option to perform the first two steps when you are adding the RBI
component item to the system hierarchy. You can then view and/or edit these properties in the Analysis panel at any time after the item is created.

**Specifying the Default Unit of Measure for Each Field**

When you set the unit of measurement for a field, the software will use the last selected unit of measure for future uses of that field. (For example, on the General Properties tab, if you set the Operating Temperature to be "81 (F)" then the next time that you create a component, its unit of measure will be Fahrenheit. If you then change the unit of measure to Kelvin, then Kelvin becomes the default unit of measure.) This applies to the every use of the same property by any component.

On the Results tab, the **Area Consequence Results** will display the same unit of measure that is used with the **Risk Target for Area Consequence** field on the Consequence Properties tab.

**General Properties**

The General Properties tab contains properties that are later used both for the potential screening of possible damage factors and the screening of possible consequences, as well as for calculations of failure and consequence.

*Note:* These properties also appear in the Add RBI Component window when adding a component to the system hierarchy.

Note the following:

- The **Material of Construction** and **Processed Fluid Type** fields are optional. For each field, if you select an option, the software will hide the non-relevant damage factors on the Damage Factors Selection tab. If the applicable construction material or fluid type is not shown in the drop-down list, then leave the field blank.

- The **Operating Temperature** value must be \( \geq -250 \) and \( \leq 1,000 \) Celsius or the equivalent in other units.

- The **Operating Pressure** value must be \( \geq 101,325 \) Pascals or the equivalent in other units. If you accept the default (i.e., atmospheric pressure) then the component is treated as being non-pressurized.

*Note:* For Tank650 equipment, if a COURSE or TANKBOTTOM component is not pressurized then the analysis is simplified and has fewer consequence properties.
Chapter 9: RBI Analysis

- Use the **Date of Component Installation** to specify when the component was installed in the system. It must be before the current date.

- Use the **Plan Date** to specify the date when the component is scheduled to be maintained. It must be later than the current date.

If desired, you can use the **Notes** column, ![Notes icon](image), to record any notes about the information supplied. These notes only appear in the RBI Properties tab and do not display in any reports. Double-click inside the cell to open the Notes window. An icon in the cell indicates that notes have been saved for that field.

**IMPORTANT:** For fields that you set the measurement unit for, if you change the unit, you must also manually change the specified value as the RBI software will not change the values.

---

### Damage Factors Selection

This tab allows you to select which damage factors apply to the component. The list of factors that may be considered will depend on the component and your answers on the **General Properties tab**. For example, for a tank bottom, and assuming that the other values remain at their defaults, nine damage factors will be displayed if the material of construction is carbon or low alloy steel, but only three damage factors will be displayed if the material is austenitic stainless steel.

**Note:** These factors also appear in the Add RBI Component window when adding a component to the system hierarchy.

For each factor, click inside the **Applies?** column to answer Yes or No. If the factor applies, it will be highlighted in red and you will be prompted to specify the relevant properties on the **Damage Factors Properties tab**.

Each factor also includes a **Comments** field where you can enter any additional information (up to 255 characters) that is relevant to your response to the damage factor. You can type directly in this field or click anywhere in the field to display the **Select Existing** icon. This icon opens the **Select Existing Text window** that allows you to choose comments used in other data sources.
**Damage Factor Properties**

The Damage Factors Properties tab allows you to make the required inputs for the damage factors that are applicable for the component (based on your selections on the [Damage Factors Selection](#) tab).

The properties are grouped into nodes based on the relevant damage factor. However, if a property applies to multiple damage factors, then it will appear in the [Apply to Multiple Damage Factors](#) node at the top of the tab and will only need to be specified once regardless of how many damage factors share the property.

All damage factor properties and consequences properties must be filled out before you can calculate the RBI results.

If desired, you can use the [Notes](#) column, to record any notes about the information supplied. These notes only appear in the RBI Properties tab and do not display in any reports. Double-click inside the cell to open the Notes window. An icon in the cell indicates that notes have been saved for that field.

---

**IMPORTANT:** For fields that you set the measurement unit for, if you change the unit, you must also manually change the specified value as the RBI software will not change the values.

---

**Consequence Properties**

The Consequences Properties tab allows you to make the required inputs to evaluate the consequences of failure in terms of flammability, toxicity and financial loss. These properties apply regardless of the selected damage factors and damage factor properties.

**Note:** For Tank650 equipment, if a COURSE or TANKBOTTOM component is not pressurized (i.e., the operating pressure is 101325 Pa) then the analysis is simplified and has fewer consequence properties.

RBI performs an API RBI RP Level 1 consequence analysis to calculate the risk based upon releases for common risk-causing fluids. Flammable and non-flammable consequence areas are calculated for each hole release rate based upon a given hole size within the component, and these are all combined based on the relative frequency of failure for each hole size. (See the [Fluid List](#).)
Chapter 9: RBI Analysis

If desired, you can use the Notes column, ☐, to record any notes about the information supplied. These notes only appear in the RBI Properties tab and do not display in any reports. Double-click inside the cell to open the Notes window. An icon in the cell indicates that notes have been saved for that field.

**IMPORTANT:** For fields that you set the measurement unit for, if you change the unit, you must also manually change the specified value as the RBI software will not change the values.

**Flow Rates/Flammability**
The Flow Rates/Flammability properties define the general properties of the process fluid and the storage/process area. Note the following:

- Use the **Representative Process Fluid** drop-down list to select the fluid that the component most often handles.
- In the **Atmospheric Temperature** field enter a value that must be >= -100 and <= 100 Celsius or the equivalent in other units.
- In the **Component Mass** (i.e., the amount of material stored in the component) and **Inventory Mass** (i.e., the amount of material included in the component and that can flow into the component from other connected components) fields, enter values greater than 0.

**Toxicity**
The Toxicity properties are used to determine the physical damage from loss of containment or rupture that may occur to the surrounding equipment, components, personnel and environment. The impact areas may occur from pool fires, flash fires, fireballs, jet fires and/or vapor cloud explosions. Note the following:

- In the **Toxicity Mitigation Reduction (%)** field, enter a value greater than or equal to 0 that specifies the percentage by which the toxic effects are lessened due to mitigation systems.
- In the remaining fields, enter the specific **mass fractions** (i.e., the fraction of the process fluid that is composed of that compound) as decimal values that must be >= 0.0 and <= 1.0.

**Financial**
The Financial properties are used to determine the monetary cost of failure. These calculations take into consideration or calculate the hole costs, material costs, plant downtime, cost of the equipment, the cost on the surrounding area and the personal injury costs.
### Fluid List

The following table shows the risk-causing fluids that can be considered in the analysis.

<table>
<thead>
<tr>
<th>Representative Fluid</th>
<th>Examples of Applicable Materials</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1 - C2</td>
<td>Fuel gas, methane, ethane, ethylene, LNG</td>
</tr>
<tr>
<td>C3 - C4</td>
<td>Propane, butane, isobutane, LPG</td>
</tr>
<tr>
<td>C5</td>
<td>Pentane</td>
</tr>
<tr>
<td>C6 - C8</td>
<td>Gasoline, naptha, light straight run, heptane</td>
</tr>
<tr>
<td>C9 - C12</td>
<td>Diesel, kerosene</td>
</tr>
<tr>
<td>C13 - C16</td>
<td>Jet fuel, kerosene, atmospheric gas oil</td>
</tr>
<tr>
<td>C17 - C25</td>
<td>Gas oil, typical crude oil</td>
</tr>
<tr>
<td>C25+</td>
<td>Residuum, heavy crude, lube oil, seal oil</td>
</tr>
<tr>
<td>Hydrogen (gas)</td>
<td>Hydrogen only</td>
</tr>
<tr>
<td>Hydrogen Sulfide (H2S)</td>
<td>Hydrogen sulfide only</td>
</tr>
<tr>
<td>Hydrogen Fluoride</td>
<td>Hydrogen fluoride</td>
</tr>
<tr>
<td>Water</td>
<td>Water</td>
</tr>
<tr>
<td>Steam</td>
<td>Steam</td>
</tr>
<tr>
<td>Acid (low)</td>
<td>Acid, caustic</td>
</tr>
<tr>
<td>Aromatics</td>
<td>Benzene, Toluene, Xylene, Cunene</td>
</tr>
</tbody>
</table>

**Note:** Styrene is an aromatic and is treated as such for calculation purposes. (This is per API RP 581, page 3-50.)

| Aluminum Trichloride | Aluminum Chloride |
### Chapter 9: RBI Analysis

**Pyrophoric** | **Pyrophoric Materials**
---|---
Ammonia | Ammonia
Chlorine | Chlorine
Carbon Monoxide (CO) | Carbon Monoxide
Diethyl Ether | Diethyl Ether
Hydrogen Chloride (HCl) | Hydrogen Chloride
Nitric Acid | Nitric Acid
Nitrogen Dioxide | Nitrogen Dioxide
Phosgene | Phosgene
Toluene Diisocyanate (TDI) | Toluene Diisocyanate
Methanol | Methanol
Propylene Oxide | Propylene Oxide
Ethylene Glycol Monoethyl Ether Acetate | Ethylene Glycol Monoethyl Ether Acetate
Ethylene Glycol Monoethyl Ether | Ethylene Glycol Monoethyl Ether
Ethylene Glycol | Ethylene Glycol
Ethylene Oxide (EO) | Ethylene Oxide

### RBI Results

After you have entered all of the component data, you can calculate the results by choosing **System Hierarchy > Risk Based Inspection > Calculate Risk.**
The Calculations Options window allows you to select which components to calculate.

**Calculation Options**

If you select **Ignore incomplete components**, the software will not attempt to calculate the results for components that do not have all of their RBI properties defined. If not selected, RBI will validate all components before calculating the results and will stop validation on the incomplete component and not calculate the results for any component.

If you select the **Set reliability policy to 'Based on RBI Analysis'** check box, the software will use the model created from the RBI results as the reliability policy on the Properties tab of the Analysis panel.

**Calculated Results**

- **Area and Financial Consequence Results:**
  - **Area Consequence Results** displays the estimated effect of a failure based on safety.
  - **Financial Consequence Results** displays the estimated monetary effect of a failure (i.e., the repair, clean-up, replacement and other costs).
- **RBI Date Results** displays results on the date the results were calculated:
  - **Overall Damage Factor and Probability of Failure** displays the total damage factor associated with the component as well as the probability of failure associated with the total damage factor.
Chapter 9: RBI Analysis

- **Risk Analysis (Area)** displays the calculated *area at risk* (i.e., the total area value times the probability of failure at the given date) and the probability category of the component failing (as based on the Risk Category values for the project) at the given date. It also displays the calculated Risk Priority value based on the scoring matrix (i.e., Low, Medium, Medium High or High).

- **Risk Analysis (Financial)** displays similar information for the financial consequences of failure.

- **Plan Date Results** displays the same type of results as the RBI Date Results node, but shows the risk values on the plan date (i.e., the date of the planned maintenance) assuming you do nothing until then.

- If the analysis indicates that an inspection is required before the plan date, the **Target Date Results** node specifies the *target date* (i.e., the date at which the component will exceed the maximum acceptable risk(s) and is therefore the date when the next set of inspection(s) should take place) and provides information about when you should inspect the component and the anticipated state of the component on that date.

  If the risk on the plan date is less than the maximum acceptable risk, then no target date is given as no inspections are needed until the plan date.

- **Recommended Inspection(s):** If applicable, this node displays the number of inspections needed for each type of damage and the level of inspection that you will need to perform on the target date when you inspect the component to get your desired results.

  While the exact meaning of *effectiveness* varies depending on the component and what its properties are, the following table shows a generic version of the inspection levels that can be recommended to be performed.

<table>
<thead>
<tr>
<th>Level</th>
<th>Generic Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Highly Effective</td>
</tr>
<tr>
<td>B</td>
<td>Usually Effective</td>
</tr>
<tr>
<td>C</td>
<td>Fairly Effective</td>
</tr>
<tr>
<td>D</td>
<td>Poorly Effective</td>
</tr>
<tr>
<td>E</td>
<td>Ineffective</td>
</tr>
</tbody>
</table>

- **Plan Date with Inspection Results** displays the same type of results as the RBI Date Results node, but shows the risk values on the plan date assuming that the
recommended inspections on the target date are carried out. If no inspections are needed, the node states that.

**Generated URDs**

If you select to generate a URD based on the RBI analysis results, the failure model is always a 2-parameter Weibull with the time units set to Years. These models cannot be directly modified by any user. To change them, you must change the analysis and recalculate the model.

If you already have an existing model for the component, you can clear the **Set reliability policy to ‘Based on RBI Analysis’** check box and base the reliability on it instead. (In other words, the model generated by the RBI software is best used in cases where you do not already have an established reliability model.)

Models are not created for PRDs, which are replaced either at the date the maximum acceptable risk is reached, or when the plan date is reached, whichever is sooner.

**Generating Scheduled Tasks**

Now in Version 11, the software also creates a scheduled task for the component:

- For non-HEXTUBE components:
  - If inspections are needed, then an **Inspection task** is created and scheduled for the date given in the Target Date Results node on the Results tab.
  - If inspections are not needed, then a **Preventive task** is created, scheduled for the plan date.

- For HEXTUBE components:
  - If no life extension will be performed, then an Inspection task is created.
  - If life extension will be performed, then a Preventive task is created.

The task is scheduled for the target date, if it exists. Otherwise, the task is scheduled for the plan date.

**Using the Generated URD in Other Analyses**

The generated URD and model can be used in many places in your analyses. For example:

- You can use it with a **Functional Failure Analysis (FFA)** to generate the **maintenance tasks** for the component.

- You can use it in the **Failure Modes and Reliability Analysis (FMRA)** to determine the reliability of the entire system (including synchronizing the hierarchy with BlockSim) or calculate the **system availability and cost values**.

- You can use it when **performing simulations and cost calculations**.
**RBI Plots**

The RBI Plot tab shows the risks associated with the component versus the various critical dates during the analysis. You can choose to view a plot either of the financial risk or the area risk. Note that for components that do not have a calculated area risk (e.g., tank components at atmospheric pressure), the area risk plot will not show any meaningful data.

The risk values that always appear for a component are those associated with the RBI date and the Plan Date without any recommended inspections. If calculated results indicate that the component requires inspections prior to the Plan Date, then the risks at the Target date (for inspections) and the Plan Date (with Inspections performed) are also shown. In addition, if by estimation the component reaches minimum wall thickness, a red line will be shown to signify the date associated with reaching minimum wall thickness.

**Plot Capabilities**

When working with the RBI Plot tab, you have the same capabilities that you have when working with plots in an FMEA or functional failure analysis. (See Basic Plot Features.)

**Special Item Types**

**Configuring a HEXTUBE Component**

Used in heat exchangers, HEXTUBEs are used to carry gas and/or liquids from one side of the heat exchanger to the other. They only require that you define the general properties and then review the calculated results.

**General Properties**

The General Properties tab contains information about the HEXTUBE and is divided into two nodes: General and Financial.

**IMPORTANT:** For fields that you set the measurement unit for, if you change the unit, you must also manually change the specified value as the RBI software will not change the values.
General
The properties in this node determine the basic properties of the HEXTUBE. Note the following:

- The **Initial HexTube Model** is optional and allows you to assign a model, which may represent a fixed time or a distribution, to describe the damage properties of the HEXTUBE. You can choose an existing model or create a new one. If no model is assigned, it is assumed that the HEXTUBE cannot fail.

  The model can be generated from previous inspection data of HEXTUBEIs in identical or similar process environments. If no previous data is available, you can create a model from whatever information is available, such as estimated corrosion rates and corrosion allowance information.

- Use the **Date of Component Installation** to specify when the HEXTUBE was installed in the system. It must be before the current date.

- Use the **Plan Date** to specify the date when the HEXTUBE is scheduled to be maintained. It must be later than the current date.

- Use the **Planned Shutdown Date After Current Plan Date** to specify the date of inspection (shutdown) following the plan date.

Financial
The Financial properties are used to determine the monetary cost of the HEXTUBE failing. These calculations take into consideration or calculate the hole costs, material costs, plant downtime, cost of the equipment, the cost on the surrounding area and the personal injury costs. Note the following:

- Use the **Date of Last Inspection** to indicate the last date that the component was inspected. If there was no inspection, use date the component was installed.

If desired, you can use the **Notes** column, to record any notes about the information supplied. These notes only appear in the RBI Properties tab and do not display in any reports. Double-click inside the cell to open the Notes window. An icon in the cell indicates that notes have been saved for that field.

Results Properties
The results are displayed in the following nodes:

- The **Financial Consequence Results** node displays the total cost of the HEXTUBE if it breaks (i.e., the repair, clean-up, replacement and other costs).
Chapter 9: RBI Analysis

- The **RBI Date Results** node displays the results as of the date the results were calculated:
  - The **Probability Category** displays the probability of the component failing (as based on the **Risk Category values** for the project) at the given date.
  - The **Consequence Category** displays similar information for the financial consequences of failure.
  - The **Risk Priority** displays the calculated value based on the **scoring matrix** (i.e., Low, Medium, Medium High or High).

- **Plan Date Results**: This node displays the same type of results as the RBI Date Results node, but shows the risk values on the plan date (i.e., the date of the planned maintenance) assuming you do nothing until then.

- If the analysis indicates that an inspection is required before the plan date, the **Target Date Results** node specifies the **target date** and provides information about when you should inspect the HEXTUBE and the anticipated state of the HEXTUBE on that date.

  If the risk on the plan date is less than the maximum acceptable risk, then no target date is given as no inspections are needed until the plan date.

- **Plan Date with Inspection Results**: This node displays the same type of results as the RBI Date Results node, but shows the risk values on the plan date assuming that the recommended inspections on the target date are carried out. If no inspections are needed, the node states that.

- **Inspection Planning without Repair**: This node displays the recommended actions if you do not repair the HEXTUBE, but only inspect and replace it.
  - **Perform Inspection** displays **Yes** if you should inspect the HEXTUBE at the next plan date, or **No** if you should wait until following plan date to inspect the HEXTUBE.
  - **Perform Replacement** displays **Yes** if you should replace the HEXTUBE at the next plan date, or **No** if you should wait until following plan date to replace the HEXTUBE.
  - **Optimal Replacement Frequency** is the optimal time between replacements assuming no repairs are done.

**RBI Plot**
The RBI Plot tab shows the risks associated with the HEXTUBE versus the various critical dates during the analysis in a financial risk plot. (Note that the Area Risk plot does not show any data as HEXTUBES are not concerned with the risk to the surrounding area.)
The risk values that always appear for a component are those associated with the RBI date and the Plan Date without any recommended inspections. If calculated results indicate that the component require inspections prior to the Plan Date, then the risks at the Target date (for inspections) and the Plan Date (with Inspections performed) are also shown. In addition, if by estimation the component reaches minimum wall thickness, a red line will be shown to signify the date associated with reaching minimum wall thickness.

**Plot Capabilities**
When working with the RBI Plot tab, you have the same capabilities that you have when working with plots in an FMEA or functional failure analysis. For more information, refer to Basic Plot Features.

**Configuring Pressure Relief Devices**
Pressure relief devices are used to relieve excess pressure build-up in a plant and they are the only pieces of RBI equipment that include RBI-specific properties.

**General Properties**
The General Properties tab contains information about the pressure relief device and is divided into three nodes: General, Financial and Demand.

**IMPORTANT:** For fields that you set the measurement unit for, if you change the unit, you must also manually change the specified value as the RBI software will not change the values.

**General**
The properties in this node determine the basic properties of the pressure relief device. Note the following:

- The **Maximum Allowed Working Pressure** value must be greater than 101325 Pascals or the equivalent in other units.

- The **Failure on Demand Model Available** field allows you to specify that there is a model available that describes the failure properties of the pressure relief device. You can then use the **Reliability Model for PRD FOD** field to assign a model, which may represent a fixed time or a distribution. You can choose an existing model or create a new one.

- The **Leakage Model Available** field allows you to specify that there is a model available that describes the leakage properties of the pressure relief device. You can then use the **Reliability Model for PRD POL** field to assign a model, which may represent a fixed time or a distribution. You can choose an existing model or create a new one.
If no models are available, then you must answer other several other questions that RBI uses to generate the internal models that will be used in the RBI calculations. (These internal models are not resources and cannot be modified by the user.)

- Use the **Last Installation Date/Inspection Re-furbish Date** to specify when the pressure relief device was installed or last refurbished. It must be before the current date.
- Use the **Plan Date** to specify the date when the pressure relief device is scheduled to be maintained. It must be later than the current date.
- Use the **Regulatory Inspection Interval (yrs)** to specify the maximum number of years allowed between the refurbishing of the pressure relief device.

**Financial**
The Financial properties are used to determine the monetary cost of failure. These calculations take into consideration or calculate the hole costs, material costs, plant downtime, cost of the equipment, the cost on the surrounding area and the personal injury costs.

**Demand**
The Demand properties are used to determine the properties that relate to the various overpressure demands to which the pressure relief device can be subjected. Note the following:

- In the **Overpressure Multiplier** field, enter a value between 1 and 4, where 1 indicates the best case scenario and 4 indicates the worst case scenario (i.e., the component is expected to rupture).

If desired, you can use the **Notes** column, 📝, to record any notes about the information supplied. These notes only appear in the RBI Properties tab and do not display in any reports. Double-click inside the cell to open the Notes window. An icon in the cell indicates that notes have been saved for that field.

**Assigning Components**
For each pressure relief device you must assign the components that are being protected by the device. The possible component types that can be assigned are:

- All component types for the Compressor, Pipe, Pump and Vessel-FinFan equipment types.
- The HEXSS and HEXTS component types for the Heat Exchanger equipment.

Each assigned component must already have its properties defined in its parent piece of equipment before being used by the pressure relief device.
To assign a component to the PRD, while on the General Properties tab, choose System Hierarchy > Risk Based Inspection > PRD Components > Assign Components.

In the window that displays, select the applicable components. You can assign the same component to multiple pressure relief devices.

**Results Properties**

The displayed results include the following information:

- The **Area - Based Risk** and **Financial - Based Risk ($)** fields display the risk at the next recommended inspection/refurbishment date.
- The **Target Date** displays the date of the next recommended inspection/refurbishment.

**Table of Steel Types**

The following table is derived from the API RP 581 document and provides information about materials that are made of either carbon steel or a low-alloy steel. It is used with several damage factors on the Damage Factor Properties tab.

<table>
<thead>
<tr>
<th>Group</th>
<th>Material (A), (B), (C)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1. All carbon and low alloy steel bars, plates and structural shapes not otherwise listed in this table.</td>
</tr>
<tr>
<td></td>
<td>2. SA-216: Grades WCC and WCB, and SA - 217: Grade WC6, if they are water-quenched or normalized, and tempered.</td>
</tr>
<tr>
<td></td>
<td>4. Obsolete 1934 ASME Code, Section VIII material specifications: S1, S2, S25, S26, and S27 (E).</td>
</tr>
<tr>
<td></td>
<td>5. Steel made using A201 and A212 specifications unless it can be established that the steel was produced by a fine-grain practice (F).</td>
</tr>
</tbody>
</table>
### Chapter 9: RBI Analysis

1. SA-216: Grade WCA if water-quenched or normalized, and tempered.
   - SA-216: Grades WCB and WCC if water-quenched and tempered, produced to a fine grain practice and the thickness does not exceed 2 inches.
   - SA-217: Grade WC9 if tempered and normalized
   - SA-285: Grades A and B and SA-414: Grade A
   - SA-442: Grade 55 if normalized, not produced using a fine grain particle and is > 1 inch thick
   - SA-442: Grade 60 if it is normalized and not produced using a fine grain practice
   - SA-515: Grades 55 and 60
   - SA-516: Grades 65 and 70, SA-612 and SA-662: Grade B if not normalized

2. All materials from Group 1 that are produced using a fine grain practice and are normalized and are not listed in Groups 3 and 4 below. This does not apply for cast steels.

3. All fittings, forgings, pipes and tubing not listed in Groups 3 and 4 below.

4. If the parts were fabricated using the guidelines from paragraph UG-11, Section VIII, Division 1 of the ASME Code must be included in this group, regardless of which group they should otherwise be in.

5. Steel made using A201 and A212 specifications if it can be established that the steel was produced by a fine-grain practice.

<table>
<thead>
<tr>
<th>3</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. SA-182: Grades 21 and 22, SA-336: Grades F21 and F22, and SA-387: Grades 21 and 22, if tempered and normalized</td>
</tr>
<tr>
<td>- SA-302: Grades C and D</td>
</tr>
<tr>
<td>- SA-442: Grades 55 &lt; 1 in. if normalized and not produced using a fine grain practice</td>
</tr>
<tr>
<td>- SA-516: Grades 55 and 60 if not normalized</td>
</tr>
<tr>
<td>- SA-533: Grades B and C, SA-662: Grade A</td>
</tr>
<tr>
<td>2. All material of Group 2 if normalized and produced to fine grain practice and not listed in Group 4 below.</td>
</tr>
</tbody>
</table>
SA-203
SA-442, if normalized and produced using a fine grain practice
SA-508: Class 1
SA-516, SA 612 and SA 662 if normalized
SA-524 and SA 537: Classes 1 and 2
SA-738: Grade A

Notes:

A. When a material sub-classification is not shown, all sub-classifications of the material are included.

B. For all material assignment notes:
   i. As permitted by the material specifications, all cooling rates faster than those by air, followed by
      tempering, are considered to be equal to tempering and normalizing heat treatments.
   ii. As described in SA-20, the production to fine grain practice is the necessary procedures for obtaining a fine
       austenitic grain size.

C. Unless specific information to the contrary is available, all product forms containing materials made using
   obsolete specifications for pipes, tubes, castings, forgings and bars should be assigned to Group 1.

D. Discontinued in 1956, the API Code for Unfired Pressure Vessels, 1st edition, included these ASTM specifications
   for carbon steel plates, which were intended to be used for structural steel for locomotives, bridges and rail cars.
   Additional uses included locomotive and stationary service boilers and firebox steel. The A149 and A150 ASTM codes
   were designed for pressure vessels containing high-tensile-strength carbon steel plates.

E. The S1 and S2 forge welding, S26 and S27 carbon steel plates and S25 open-hearth iron standards were included
   in Section VIII of the 1934 edition of the ASME Code for steel specifications and the titles of some of these specifications
   are similar to those ASTM specifications given in the API Code for Unfired Pressure Vessels, 1934 edition.

F. The four grades included in the ASTM A 515 and the four grades included in the ASTM 516 specifications replaced
   the A201 and A212 steels. In addition, steel that was made using the ASTM A 212 specification was made in strength
   grades equivalent to Grades 65 and 70, which have accounted for several known brittle failures. Unless it can be
   established that the steel was enhanced in toughness properties using the fine grain practice production method, steel
   made using the ASTM A 201 and A 212 specifications should be assigned to Group 1.
Chapter 10: Analysis Plans

The Analysis Plan utility allows you to:

- Specify the members and leaders of a project team.
- Define the tasks involved in your analysis and keep track of their completion.
- List the information that all members of the analysis team will use to make judgments in the analysis.
- Track the time spent working on the analysis and the members who have attended the sessions.
- Track team members’ assessments of how effective the FMEA analysis process has been.

You can assign an analysis plan to an item at any level of the system hierarchy. For instance, if you want the entire project to be covered by one plan, you could assign an analysis plan only to the top-level system. Conversely, you might prefer to have a separate analysis plan for each subsystem.

Analysis Plan Window

To access the Analysis Plan window, select the item in the System panel that the analysis plan will be applied to, then choose Analyses > Planning > Add Analysis Plan.

You can manage analysis plans by clicking the Analysis Plan tab in the Analysis panel.

The Analysis Plan window consists of five tabs. The information on these tabs is included in the Analysis Plans Summary and Analysis Plan Details reports created view in the Reports window. Each tab and its components are presented next.

Note that the name, description and status of the analysis plan are displayed at the top of all tabs. The status of the analysis plan is shown above the four dates fields and is based on the dates given in those fields:

- Scheduled - This indicates that a starting date for the project has been defined but the project has not started (i.e., the planned start date is later than the current date, and no start date or completion date has been entered).
Chapter 10: Analysis Plans

- **Late Start** - This indicates that the planned starting date for the project has passed and the project has not started (i.e., the planned start date is later than the current data, and no actual start date or completion date has been entered).

- **In Progress** - This indicates that the project is in progress and the due date has not arrived (i.e., the actual start date is earlier than the current date, and there is no completion date).

- **Overdue** - This indicates that the project is in progress but the due date has passed (i.e., there is an actual start date, the current date is later than the due date, and there is no completion date).

- **Complete** - This indicates that the project has been completed (i.e., there is a completion date).

**Team Tab**
The Team tab of the Analysis Plan window allows you to specify the members of the team who are involved with the project.

To add a team member, click inside a cell to enter their information. First Name, Last Name and Display Name are required fields. All others are optional. You can also import existing users as team members by clicking the **Import Existing Users** button and selecting existing database users. If you do so, or if you pick an existing user from the **Display Name** drop-down list, then the remaining fields (except for the Leader field) are populated with data and cannot be changed.

To mark whether a team member is a project leader, click inside the cell in the Leader column to select **Yes** or **No** using the drop-down list. More than one team member can be a project leader.

At the bottom of the Import Existing Users window is the **Show repository users only** check box. If this check box is selected, then only users who have access to the database are displayed. Clear the check box to display the users who have access to the database and all persons who have been added as a team member to any analysis plan in the database.

**Analysis Checklist Tab**
The Analysis Checklist tab allows you to define the tasks involved in your analysis and keep track of their completion.

You can work from an analysis checklist in the active library by selecting a checklist from the **Reset Checklist from Library** drop-down list, or you can create your own. If you create your own analysis checklist or make changes to one from the library, you can click the **Save Checklist in Library** button to open the Save Checklist in Library window, which allows you to store your new checklist in the library for future use.
You can enter estimated and actual completion dates for each task in the checklist. When you click in a date cell, you can enter a date manually or click the calendar icon and select a date in the calendar that appears.

In the bottom right corner of the window, you can estimate the level of completion of the analysis, either by entering your own estimate in the Completion Estimate field or by reviewing the automatically generated values that show the number of checklist tasks completed or the number of actions completed for the item(s) to which the analysis plan applies. These figures will refresh automatically whenever you make changes to the actual completion dates or in the analysis plan.

**Ground Rules and Assumptions Tab**
The Ground Rules and Assumptions tab of the Analysis Plan window allows you to list the information that all members of the analysis team will use to make judgments in the analysis.

You can work from a list of assumptions in the active library by selecting an assumptions list from the Reset Assumptions from Library drop-down list, or you can create your own. If you create your own list of assumptions or make changes to one from the library, you can click the Save Assumptions in Library button to open the Save Assumptions in Library window, which allows you to store your new assumption list in the library for future use.

**Work Sessions Tab**
The Work Sessions tab allows you to track the time spent working on the analysis and the members who have attended the sessions. The time can be entered using multiple formats (e.g., 8 AM, 3pm, 1700, etc.).

You can specify which members of the analysis team attended each work session listed by clicking the Enter Attendance button or by clicking a cell in the Attendance column to open the Enter Attendance window.

If you have made changes on the tab, the Total Work Session Time (Hours) field will update automatically. This calculation is based on the start and end times entered for each work session.

**Quality Survey Tab**
The Quality Survey tab allows you to track team members’ assessments of how effective the FMEA analysis process has been.

You can work from a survey in the active library by selecting a survey from the Reset Survey from Library drop-down list, or you can create your own. If you create your own survey or make changes to one from the library, you can click the Save Survey in Library button to open the Save Survey in Library window, which allows you to store your new survey in the library for future use.
Chapter 10: Analysis Plans

Each user involved in the process may answer the survey questions after the analysis is complete. When you have the answers to the survey, click in the **Average Rating** cell for each question and enter the average rating, which must be a numerical value of zero or greater. The Overall Average Rating will update automatically based on your changes.
Chapter 11: Risk Discovery

The Risk Discovery tab in the Analysis panel allows you to perform a preliminary analysis that can help you select the equipment that will receive more detailed analysis.

- For FMEA, this may be referred to as a Change Point Analysis or Preliminary Risk Assessment.
- For RCM, this may be referred to as the Equipment Selection.
- For RBI, this may be referred to as Qualitative RBI.

There are two configurable methods available for performing this analysis; the one you use depends on your choice in the project properties.

- Risk discovery questions allows you to answer a series of yes/no questions.
- Risk discovery ratings allows you to assign ratings for a variety of different factors and then calculate an overall criticality value for each item or piece of equipment.

Whichever method is selected, the goal of this task is to provide a systematic approach to focus limited analysis resources where they will provide the maximum benefit and ensure the highest return on investment.

To add a Risk Discovery analysis, select an item in the System panel then choose Analyses > Planning > Add Risk Discovery.

The Risk Discovery tab will open in the Analysis panel. In addition, the Risk Discovery icon will appear in the corresponding column in the System Hierarchy tab of the System panel while the Risk Discovery value will appear in the Risk Discovery Details column (if those columns have been selected for display on your computer).

Showing Results in the System Panel

In the System panel, the Risk Discovery column displays a green icon if a Risk Discovery analysis is associated with the item. Additionally, if the Mark item for more detailed analysis check box is selected at the bottom of the Risk Discovery analysis, then the Risk Discovery icon will display in red.
Chapter 11: Risk Discovery

In the System panel, what the Risk Discovery Details column displays depends on the Risk Discovery type:

- If the project is using risk discovery questions, then this column will display the number of questions with "Yes" answers. More "Yes" answers indicates greater risk.
- If the project is using risk discovery ratings, then this column will display the calculated value of all categories, which is based on the method in use for the ratings used in the project. Higher values indicate greater risk.

Generating a Report
To generate a report of the Risk Discovery data, choose Home > Reporting > Reports.

In the Reports window, select any of the predefined report forms under the Risk Discovery heading.

Using Questions
If the project is configured to use questions for Risk Discovery analysis, you can answer a variety of yes/no questions and then calculate a value for each item or piece of equipment.

The questions will depend on the configurable settings for the current project. To view or change the settings, choose Project > Management > Configurable Settings > RD Questions. (In a secure database, this is only available for users with the "Edit project properties" permission.)

When you select a response for a question, the label changes color to give a visual indication of the question's status, where green indicates a No answer (not critical) and red indicates a Yes answer (critical). (See Risk Discovery Questions.)
If desired, use the Comments field to provide any additional information that is relevant to your answer (up to 255 characters per question). Click anywhere in the field to display the Select Existing icon. This icon opens the Select Existing Text window that allows you to choose comments used in other data sources.

### Showing Results in the System Panel

In the System panel, if the Risk Discovery Details column has been selected for display on your computer, then it will display the number of questions with "Yes" answers. More "Yes" answers indicates greater risk. Additionally, if the Mark item for more detailed analysis check box is selected, then the Risk Discovery icon will display in red.

### Generating a Report

To generate a report of the Risk Discovery data, choose Home > Reporting > Reports.

In the Reports window, select any of the predefined report forms under the Risk Discovery heading.
Using Ratings

If the project is configured to use ratings for Risk Discovery analysis, you can assign ratings for a variety of different factors and then calculate an overall item criticality value for each item or piece of equipment.

The categories, factors and rating scale options will depend on the configurable settings for the current project. To view or change the settings, choose Project > Management > Configurable Settings > RD Ratings. (In a secure database, this is only available for users with the "Edit project properties" permission.)

When you select a rating for each factor, the software calculates a Category Rating for each category and an Overall Rating for the item. New in Version 11, the calculation method can use the product, sum, max or average. (See Risk Discovery Ratings.)

If desired, use the Comments field to provide any additional information that is relevant to your ratings (up to 255 characters per factor). Click anywhere in the field to display the Select Existing icon. This icon opens the Select Existing Text window that allows you to choose comments used in other data sources.

Showing Results in the System Panel

In the System panel, if the Risk Discovery Details column has been selected for display on your computer, then it will display the calculated value of the overall rating used in the analysis. Higher values indicate greater risk. Additionally, if the Mark item for more detailed analysis check box is selected, then the Risk Discovery icon will display in red.
Generating a Report
To generate a report of the Risk Discovery data, choose Home > Reporting > Reports.

In the Reports window, select any of the predefined report forms under the Risk Discovery heading.
Chapter 12: Parameter Diagrams (P-Diagrams)

A Parameter Diagram (P-Diagram) is a structured tool that identifies the inputs from a system and relates those inputs to the desired system outputs, while considering the controlled and uncontrolled factors. It is useful in brainstorming and documenting input signals, noise factors, control factors, error states and ideal responses, and helps the FMEA team understand and make visible the robustness of the design that is being analyzed. It can provide important input to System and Design FMEAs.

Add a P-Diagram

To add a P-Diagram for any item in the system hierarchy, select or right-click the item and choose Analyses > Add P-Diagram.

The P-Diagram tab will open in the Analysis panel. In addition, the P-Diagram icon will appear in the corresponding column in the System Hierarchy tab of the System panel (if that column has been selected for display on your computer).

Enter the Data

The P-Diagram tab provides input boxes for the elements that are typically recorded in this type of analysis: Input Signals, Noise Factors, Control Factors, Ideal Response and Error States. (Refer to P-Diagram Elements for more information about what to enter for each element, and opportunities to share specific inputs and outputs with other relevant analyses.)

You can type directly into the rows for each input box, and use the ribbon commands to insert a row, delete a row, or move a selected row up or down in the list.
Select Existing Text

There are two ways to use the Select Existing Text window to copy and reuse text from existing P-Diagrams or other relevant analyses:

- **Replace or append text in the current row** - If you click the icon inside a row in one of the input boxes, the utility will either replace the current text in that row, or append text to the end of the current description.

- **Create one or multiple new rows** - If you click the command in the P-Diagram tab of the ribbon, the utility will create a new row for each description that you select.

In both cases you can use the filters at the top of the window to specify which descriptions are displayed. The following example shows the options for creating new rows in the Control Factors input box. For this type of input, you can select control factors from existing P-Diagrams or causes from existing FMEAs.

![Select Existing Text Window](image)

Import Elements from Excel

If you have the text elements in an Excel file, you can right-click the P-Diagram analysis tab in the Analysis panel and choose **Import from Excel**.
You can then select an Excel file and import the data from Excel. If a P-Diagram does not already exist, then one is created. If a P-Diagram already exists, then the new records are added to the end of the affected elements.

**Reports and Queries**

To generate a report of the P-Diagram, choose Home > Reporting > Reports to open the Reports window.

Select the system hierarchy item and then select any of the predefined or custom reports under the P-Diagram heading. (For custom reporting needs, see Xfmea/RCM++/RBI Report Templates.)

To query P-Diagram data, choose Home > Reporting > Queries to open the Query Utility.

Select any of the P-Diagram elements from the drop-down list.

**P-Diagram Elements**

Creating a P-Diagram is an optional step when preparing a System or Subsystem FMEA. It is most useful when the item being analyzed is a complex system with many system interactions, operating conditions and design parameters as it helps the FMEA team to visually see these elements. While it can be a time-intensive step, it does provide great value in helping the FMEA team to understand and control the system and identify the outputs to the FMEA.
This topic discusses the typical elements in a P-Diagram and opportunities to share specific inputs and outputs with other relevant analyses (including the system hierarchy, FMEA analysis plans and the FMEA).

**Input Signals**
These are descriptions of the energy sources required for fulfilling the system functionality, such as speed, acceleration, input torque, etc. They can help the FMEA team to understand the nature of the system being analyzed and can use the same text as the items in the system hierarchy.

**Control Factors**
These are typically the system design parameters that the engineering team can change, such as a shaft diameter, stiffness, density, hardness, etc. and can be used to identify significant product characteristics. They can help the FMEA team to identify potential cause descriptions for the FMEA and can use the same text as the FMEA Causes.

**Noise Factors**
These are things that can influence the design but that are not under the direct control of the engineer, such as those listed below. These factors, if not protected against, can make the design ineffective (i.e., the design is not robust against the expected noise factors). There are five types of noise factors:

- The uncontrollable **Piece to Piece** variation in parts or manufacturing processes. They can use the same text as the Analysis Plan Assumptions, FMEA Causes and the PFD Worksheet Product Characteristics.

- The **Change Over Time**, or the anticipated degradation of the system components or materials. They can help to identify the specific failure mode descriptions that are associated with the cause descriptions and can use the same text as the Analysis Plan Assumptions and the FMEA Causes.

- The **Usage** in the ways the customer uses the system, either intended or unintended. They can use the same text as the Analysis Plan Assumptions.

- The set of anticipated **Environments** that the system must operate within. They can use the same text as the Analysis Plan Assumptions.

- The **System Interactions** with other components.

**Ideal Responses**
These are the primary intended functional outputs of the system, such as output torque, speed, etc. They can be used as inputs to the function descriptions in the FMEA and can use the same text as the FMEA Functions.
Error States
These are any kind of inherent loss of energy transfer or other undesirable system outputs, such as exhaust gases, heat, vibration, leakage, unusual noise or bad odor. They can help the FMEA team as inputs to failure mode descriptions in the FMEA and can use the same text as the FMEA Failures.
Chapter 13: Test Plans

The Test Plan tab in the Analysis panel displays a list of actions that describe specific tests that need to be performed. You may choose to use this feature instead of the legacy DVP&R analysis.

To hide or display this tab for your computer/username, choose View > Show > Show Test Plan.

The list is created on-the-fly based on actions and/or controls in the FMEA for the current item (if you choose Selected item only) or the FMEAs for the current item and all of its sub-items (if you choose Selected item and dependents).

This tab only displays actions that are specifically designated to show in the test plan and are either a) part of the FMEA or b) associated with a control that is part of the FMEA. (See Show Actions in Test Plans.)

Note the following:

- When applicable, the column headings show the configurable labels defined in the current project’s interface style (e.g., for Action Description, Planned Start Date, etc.).

- The Specifications, Requirements and Reports fields are displayed in the action window if the record is configured as a "detailed action."

You can include these fields in a query or report along with other action fields.

Selecting Which Columns to Display

You can hide, display or reorder the columns shown in the test plan by right-clicking any column header and choosing Customize Columns. These settings are stored per computer/username, and different users may have different display preferences without affecting the stored data.
Show Actions in Test Plans

To configure an action so it is eligible to be included in the Test Plan, select "Yes" for the Show in Test Plan field in the action properties.

If the record is not already configured as a "detailed action," it will be updated automatically to show the additional properties for Specifications, Requirements and Reports.

There are then two ways that the action can appear in the Test Plan tab:

- The action is part of the FMEA.
- The action is associated with a control that is part of the FMEA.
Chapter 13: Test Plans

Assessing Actions with Controls

If you wish to include the information from an FMEA control in the Test Plan, you must associate it with an action record that contains the relevant details.

Alternatively, you may choose to create new actions to track specific responsibilities required to implement a particular control. Actions that are associated with a control but do not appear in an FMEA are referred to as Control Actions.

In Version 11, you can now associate multiple actions with the same control, if desired.

To associate one or more actions with a control, open the control window and navigate to the Associated Actions heading:

- **Associate with a New Action** creates a new action resource that will be associated with this control. If you intend for the action to appear in the automatically generated test plan, make sure it is set as a Detailed Action in the ribbon, and the Show in Test Plan field is set to "Yes."

- **Associate with Existing Action(s)** allows you to select one or more existing actions from the current project.

If the control is already associated with at least one action:

- **Edit Associated Action** allows you to view or modify the selected action record. Any changes to the action properties will be reflected in all locations where the resource is used.

- **Remove Association** disassociates the selected action from this control. The action resource will remain in the project unless/until an authorized user deletes it from the project.
Viewing Control Actions in Filtered View and Queries

In Version 11, you can now view control actions in the FMEA filtered view and queries, even when they don't appear in the FMEA.

In the filtered view, select Actions from the drop-down list and select the Include control actions check box.

In the Query utility, select to query from FMEA Control Actions.
Chapter 14: Design Verification Plans (DVP&R)

The software allows you to add a design verification plan and report (DVP&R) analysis for any item in the system hierarchy. A DVP&R is a worksheet that is used to track the progress of design verification tests. The lessons learned from the design FMEA can be a valuable input to the DVP&R (and vice-versa).

If you wish to be able to add a DVP&R analysis to an item in your project, select the Enable Legacy DVP&R check box Configurable Settings page of the Project Properties window. When this option is selected, the Add DVP&R command will be visible on the Analyses tab of the ribbon.

The DVP&R analysis tab will open in the Analysis panel. In addition, the DVP&R icon will appear in the corresponding column in the System Hierarchy tab of the System panel (if that column has been selected for display on your computer).

The DVP&R analysis contains two tabs: a Header tab and a Worksheet tab. The Header tab contains general information about the entire analysis that will be displayed in the header of the report output while the Worksheet tab contains the analysis data. A DVP&R can have zero, one or many plan records. Each plan can be associated with one or many report records. The background color in each cell of the DVP&R worksheet identifies the record type (plan = blue and report = green).

Typically, DVP&Rs are used in one of two ways:

- As a stand-alone analysis. In this case, you:
  - Add the DVP&R analysis.
  - Define the header information on the Header tab.
  - Use the Worksheet tab to record all of the test plans and reports that need to be tracked.

- In tandem with a Design FMEA. In this case, you:
  - Create an FMEA for the item.
  - Add the DVP&R analysis to the item. The software automatically transfers the controls and/or actions from the FMEA to be the starting point for the new DVP&R.
• Define the header information on the Header tab.

• Use the Worksheet tab to record all of the test plans and reports that need to be tracked. This may require that you edit or add to the data transferred from the DFMEA.

**DVP&R Header**

The following fields may be found on the DVP&R Header tab.

*Note:* The fields that are enabled in the interface and the options available in configurable drop-down lists will depend on the interface style settings that have been defined for the current project. You can choose Project > Management > Configurable Settings > Interface Style to open the Edit Interface Style (This Project) window and change the settings for the current project.

- **DVP&R Number:** A unique document identifier.
- **Date (Orig.):** The original DVP&R completion date.
- **Date (Rev.):** The latest DVP&R revision date.
- **Revision Level/Description:** The revision identifier for the DVP&R document.
- **Part Number:** The part number for the item that the DVP&R applies to.
- **Latest Change Level:** The latest change level for the part number.
- **Part Name/Description:** The name and description for the item that the DVP&R applies to.
- **Specification/Drawing Number:** The specification or drawing number for the item that the DVP&R applies to.
- **Model Year(s)/Program(s):** The model year and/or program identifier that the DVP&R applies to.
- **Supplier/Plant:** The supplier/plant that will be manufacturing the item.
- **Supplier Code:** An identifying code for the supplier/plant.
- **Key Contact:** The primary contact for the DVP&R.
- **Key Contact Phone:** The phone number of the primary contact for the DVP&R.
- **Core Team:** The primary team involved with preparing the DVP&R.
- **Engineer1/2/3 Approval:** An engineer who approved the DVP&R.
• **Engineer1/2/3 Approval Date:** The date when the engineer approved the DVP&R.

• **User-Defined Fields:** Up to two text fields, one date field, one number field and one drop-down list.

• **Last Updated By:** The date when the DVP&R header was last updated. This is populated by the software.

• **Last Updated:** The user who last updated the DVP&R header. This is populated by the software.

For text fields, you can click the **Select Existing** icon inside the field. This will open a window that allows you to reuse text that has already been entered in this type of field.

For date fields, you can click the field once to open a calendar or twice to type the date. You must use the mm/dd/yy or mm/dd/yyyy format.
DVP&R Worksheet

The Worksheet tab displays the test plans (blue fields) and reports (green fields) that will be tracked with the DVP&R. If you have the permissions necessary to edit the project properties, you can choose which fields will be enabled and what they will be called. This includes user-defined fields and the ability to define the options in the user-defined drop-down menus, when applicable. The following image shows the relationship of the plan and report records in the DVP&R.

Example of the data-entry columns that you could enable or configure in a DVP&R

When using the DVP&R worksheet, you have the following options:

- To enter or edit data, double-click the cell.
  - For text columns, you can use the HOME, END and arrow keys to move through the text in the cell. For date columns, you can click the column once to open a calendar or twice to type the date. You must use the mm/dd/yy or mm/dd/yyyy format.
  - To save the changes, either press ENTER or TAB or click somewhere outside of the cell.
- The following options apply to plans and reports. While the examples given are for plans, the commands are similar for each record type:
  - To add a plan, choose DVP&R > Plan > Add Plan.
• To insert a plan above the currently selected one, choose DVP&R > Plan > Insert Plan.

• To copy, select the plan in the worksheet area and choose Home > Clipboard > Copy. To paste a copied plan, choose Home > Clipboard > Paste.

• To move a record up or down one place in the list of plans, select the plan in the worksheet area, then right-click the worksheet and choose Up or Down from the shortcut menu or choose Home > Move Record > Up or Home > Move Record > Down.

• To delete, select the plan in the worksheet area and either choose Home > Edit > Delete or press DELETE.

• To transfer data from the associated FMEA to the DVP&R, choose DVP&R > Sync > Sync with FMEA.

• To import data from an Excel spreadsheet, choose System Hierarchy > Add Items > Import > Import from Excel. To export data from the DVP&R worksheet to an Excel spreadsheet, choose System Hierarchy > Tools > Reporting > Export to Excel.

• To generate a report of the DVP&R data, choose Home > Reporting > Reports. In the Reports window, the DVP&R reports are located in the DVP&R Spreadsheet and DVP&R Records sections of the Available Reports area.

• To split the worksheet view so that you can view text at one side of the worksheet without moving the text at the other side, right-click a column header and choose Split. A split bar will be placed to the left of the column. To remove the bar, right-click any column header and choose Remove Split. (For example, you use this to see the test request number while working on the reports.)

• To rearrange the order in which the columns are displayed, select a column header and drag it to the place in the worksheet area you want it to appear. This updates the interface style for the project. You also can change the column order through the Interface Style window.

• To change the descriptive information about each column that displays in tooltip form when you move the pointer over the column headers, open the Project Interface Style window and change the text in the appropriate DVP&R pages.

• To populate the gray areas in the worksheet with the relevant text from a prior row, choose File > Application Setup. On the Settings page select the Repeat data in worksheet views check box.
DVP&R Worksheet Columns

This topic describes the fields found on the Worksheet tab of the DVP&R worksheet. For a description on how to use the Worksheet tab to document the process steps, see DVP&R Worksheet.

Note: The fields that are enabled in the interface and the options available in configurable drop-down lists will depend on the interface style settings that have been defined for the current project. You can choose Project > Management > Configurable Settings > Interface Style to open the Edit Interface Style (This Project) window and change the settings for the current project.

- Plan Records
  - Test Request #: The number of the test that needs to be performed. This is a required column.
  - Test Identifier (Name): A short name for the test that needs to be performed.
  - Test/Specification Method: A short description of the test that needs to be performed. This is a required column.
  - Acceptance Criteria: The criteria that must be met in order to pass the test.
  - Requirement Source: The source of the requirement that must be met in order to pass the test.
  - Requirement: The requirement that must be met in order to pass the test.
  - Specification Type: The type of specification that must be met in order to pass the test.
  - Classification: The special characteristic classification.
  - Planned Test Location: The location where the test will be performed.
  - Planned Test Phase: The phase of development in which the test will be performed.
  - Planned Sample Size: The sample size that is planned for the test.
  - Planned Sample Type: The type of sample that is planned to be used for the test.
  - Planned Test Duration: The planned duration of the test.
  - Planned Start: The planned start date for the test.
  - Planned End: The planned end date for the test.
  - Assigned To: The person or group responsible for performing the test.
Chapter 14: Design Verification Plans (DVP&R)

- **Notes (Plan)**: Any notes related to the planned test.
- **User-Defined Fields**: Up to three text fields, one date field, one number field and one drop-down list.

**Report Records**

- **Test Report #**: The number of the report for the completed test. This is a required column.
- **Test Report Identifier**: A short name for the report for the completed test.
- **Status**: The status of the test report (e.g., "active" or "replaced by test YYY," etc.).
- **Actual Start**: The actual start date for the test.
- **Actual End**: The actual end date for the test.
- **Actual Sample Size**: The actual sample size that was used in the test.
- **Test Results**: The results of the test. This is a required column.
- **Completed By**: The person or group who completed the test.
- **Notes (Results)**: Any notes related to the completed test.
- **User-Defined Fields**: Up to three text fields, one date field, one number field and one drop-down list.

**Synchronizing a DVP&R with a DFMEA**

You can choose to transfer data automatically from the FMEA each time that you create a DVP&R analysis. In this case, the logic is set in the interface style that has been defined for the project. You can also manually sync at any time. In this case, the logic is set in the Synchronization Options window.

Please note that the data is transferred, not linked. Changes made in the FMEA do not appear automatically in the DVP&R and vice versa. The synchronization functionality is intended to provide you with a starting point for the DVP&R by transferring relevant data from the FMEA. You can then make any necessary modifications and additions to the DVP&R.
The following data from the analysis can be transferred to the header or worksheet area in the DVP&R.

<table>
<thead>
<tr>
<th>FMEA</th>
<th>DVP&amp;R</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item Number/Item Name</td>
<td>Part Name/Description (Header tab)</td>
</tr>
<tr>
<td>Model Year(s)/Program(s)</td>
<td>Model Year/Program (Header tab)</td>
</tr>
<tr>
<td>Control Number or Action Number</td>
<td>Test Request # (Worksheet tab)</td>
</tr>
<tr>
<td>Current Design Controls or Recommended</td>
<td>Test/Specification Method (Worksheet tab)</td>
</tr>
<tr>
<td>Actions</td>
<td>Classification (Worksheet tab)</td>
</tr>
<tr>
<td>Cause Class</td>
<td>Planned Start (Worksheet tab)</td>
</tr>
<tr>
<td>Action Due Date</td>
<td></td>
</tr>
<tr>
<td>Action Person Responsible</td>
<td>Assigned To (Worksheet tab)</td>
</tr>
</tbody>
</table>

**Sync Options for New DVP&Rs**

The following options are available on the DVP&R > Sync Options page of the interface style when you select the **Integrate New DVP&Rs with FMEA** check box, as shown next.

When you choose to transfer data automatically from the FMEA to the DVP&R, you have the option to:

- Create new Test Plan records in the DVP&R by transferring control and/or action descriptions from the FMEA.
• If the Control Category property is enabled for the project (from the FMEA > Controls page of the interface style) or if the Controls where type = field is empty, then all controls descriptions will be transferred to the DVP&R. If the Control Category property is enabled, you can use the Controls where type = field to limit the transfer to only those controls descriptions with the specified categories. To define multiple control categories, use commas to separate the labels.

• If the Action Category property is enabled for the project (from the FMEA > Actions page of the interface style) or if the Actions where category = field is empty, then all action descriptions will be transferred to the DVP&R. If the Action Category property is enabled, you can use the Actions where category = field to limit the transfer to only those action descriptions with the specified categories that you select. To define multiple action categories, select multiple items. Or you can select the No Actions option to not transfer any actions.

• Transfer the cause description along with each control or action description. For example, if the Incorporate cause description with controls and actions transferred to DVP&R check box is selected and the cause description in the FMEA is "Failure cause" and the control description is "Design control" then the transferred test plan will be "Design control : Failure cause."

Sync Options for Existing DVP&Rs
You can choose DVP&R > Sync > Sync with FMEA to update the DVP&R with new data transferred from the FMEA.

• Header
  • To clear all of the information on the Header tab of the DVP&R and replace it with data from the associated FMEA, select the Clear the header and replace from FMEA option.
  • To leave the data in the header as-is, select the Do not change the header option.

• Worksheet
  • To clear all of the information in the worksheet area of the DVP&R and replace it with the data from the associated FMEA, select the Clear the worksheet and replace from FMEA option.
  • To add the data from the FMEA to the end of the existing data in the DVP&R worksheet, select the Append data from FMEA to end of worksheet option.
• **Transfer Controls/Actions Options**
  
  • To transfer all eligible data (i.e., controls and actions) from the FMEA to the DVP&R, select the **All Controls** and **All Actions** options.

  • To transfer only the data that meet the desired requirements, select the **Controls where Type =** and/or **Actions where Category =** option and then select the desired options.

  • To further limit the transfer, enter as many criteria elements as desired in the following fields:

    • **Classification** transfers only the data with the selected classification. Select **All** if you want all data, no matter the classification, to be transferred. This includes data with no classification. Select **Any** if you want to transfer the record if any classification has been assigned to it. If there is no classification assigned to it, the data will not be transferred.

    • **Cause RPN (Initial) >=** transfers only the data with an initial cause RPN that is greater than or equal to the value that you specify in the input box.

    • **Cause RPN (Revised) >=** transfers only the data with a revised cause RPN that is greater than or equal to the value that you specify in the input box.

    • **Cause Initial SxO >=** transfers only the data with an initial cause severity x occurrence rating that is greater than or equal to the value that you specify in the input box.

    • **Cause Revised SxO >=** transfers only the data with a revised cause severity x occurrence rating that is greater than or equal to the value that you specify in the input box.

  • To transfer the cause description along with each control or action description, select the **Cause Description with Controls and Actions** check box. For example, if this check box is selected and the cause description in the FMEA is "Failure cause" and the control description is "Design control," then the transferred test plan will be "Design control : Failure cause."

  • After making your selections, click **OK** to transfer the data from the FMEA to the DVP&R.
Chapter 15: PFD Worksheets (Process Flow Diagrams)

In the software, there are two kinds of process flow diagrams (PFDs): a graphical process flow diagram, which is a high-level chart of a process; and a PFD worksheet, which integrates the chart into a worksheet that records more detailed information about what the product goes through in each step of the manufacturing or assembly process.

A PFD worksheet serves as a starting point for documenting a process. It defines every possible step that a product undergoes, including processing of individual components, transportation of materials, storage, etc. For each step, the process characteristics (inputs) and product characteristics (outputs) are identified. The inputs are the factors in the process that need to be controlled in order to achieve the desired outputs. For example, the input may be the temperature range for wax that will be sprayed onto the finished vehicle, and the output may be the required wax thickness.

A complete PFD worksheet provides a structure for preparing process FMEAs (PFMEAs) and control plans. The outputs of a PFD worksheet can be translated into the PFMEA as potential failure modes, while the inputs can be translated into potential causes. The information from the PFD worksheet or PFMEA can then form the basis for a control plan. Put simply, the PFD worksheet defines the process, the PFMEA analyzes the process for ways to prevent or mitigate risk, and the control plan records the strategy for controlling the critical characteristics that have been identified.

Adding a PFD Worksheet

PFD worksheets can be created for complete processes or sub-processes defined in the system hierarchy.

To add a PFD worksheet to a project, select an item in the System panel then choose Analyses > Other > Add PFD Worksheet.
The item’s description, reference number and dependents are automatically copied to the appropriate fields in the new PFD worksheet, as shown in the following picture. In addition, the PFD worksheet icon appears in the corresponding column in the system hierarchy (if that column has been selected for display on your computer).

If you make changes to the system hierarchy, you can copy those changes to the PFD worksheet by choosing PFD Worksheet > Sync > Sync with System Hierarchy.

New system hierarchy items will be appended to the bottom of the PFD worksheet, while any modifications to the reference numbers and descriptions will be reflected in the existing records.

Deleted system hierarchy items will not be automatically deleted from the PFD worksheet, and any items steps that you add to the PFD worksheet will remain after you resync. In addition, if you reorganize the items in the system hierarchy, the new positions of the items will not be reflected in the PFD worksheet; however, you can manually edit their positions.

If desired, you can use the information in the PFD worksheet to automatically populate relevant fields in the PFMEA and/or control plan. (See Sync Options for PFD Worksheets.)
PFD Worksheet Header
The Header tab contains information that may be displayed in the header of a report output. This topic describes the fields found on the Header tab of a PFD worksheet.

Note: The fields that are enabled in the interface and the options available in configurable drop-down lists will depend on the interface style settings that have been defined for the current project. You can choose Project > Management > Configurable Settings > Interface Style to open the Edit Interface Style (This Project) window and change the settings for the current project.

- **Product**: The name of the item being analyzed.
- **Revision Date**: The latest revision date for the PFD worksheet.
- **Prepared By**: The name of the person who prepared the PFD worksheet.
- **Part Number**: The part number for the item being analyzed.
- **Alternate Part Number**: The alternate part number, if any, for the item being analyzed.
- **User-Defined Fields**: Up to three text fields, one date field, one number field and one drop-down list.
- **Last Updated By**: The name of the last user who updated the PFD worksheet header.
- **Last Updated**: The date and time of the last update to the PFD worksheet header.

For text fields, you can click the Select Existing icon inside the field. This will open a window that allows you to reuse text that has already been entered in this type of field.

For date fields, you can click the field once to open a calendar or twice to type the date. You must use the mm/dd/yy or mm/dd/yyyy format.

PFD Worksheet Tab
This topic describes how to enter data in the Worksheet tab. For a description of all columns that could be displayed in a PFD worksheet analysis, see PFD Worksheet Columns.

The Worksheet tab provides the structure for documenting each step that a product goes through in a manufacturing or assembly process. There are three types of records in the analysis: operation records, product characteristics records and process characteristics records. The following figure shows an example of a PFD worksheet based on the Standard FMEA profile that is shipped with the software. You can vary the format of the PFD worksheet based on your treatment...
company's guidelines and standards. If you have the permissions necessary to edit the project properties, you can choose which columns will be enabled for each type of record and what they will be called. This includes user-defined fields and the ability to define the options in the configurable drop-down lists, when applicable.

```
Example of a PFD worksheet based on the Standard FMEA profile that is shipped with the software.
```

When using the PFD worksheet, you have the following options:

- To enter or edit data, double-click the cell.
  - For text columns, you can use the HOME, END and arrow keys to move through the text in the cell. For date columns, you can click the column once to open a calendar or twice to type the date. You must use the mm/dd/yy or mm/dd/yyyy format.
  - After entering the desired information, either press ENTER, TAB or click somewhere outside of the cell to save the changes.
• The following options apply to operation, product characteristics and process characteristics records. While the examples given are for operation records, the commands are similar for each record type:
  • To add an operation, choose PFD Worksheet > Operation > Add Operation.
  • To insert an operation above the currently selected one, choose PFD Worksheet > Operation > Insert Operation.
  • To copy, select the operation in the worksheet area and choose Home > Clipboard > Copy. To paste a copied operation, choose Home > Clipboard > Paste.
  • To move a record up or down one place in the list of operations, select the operation in the worksheet area, then right-click the worksheet and choose Up or Down from the shortcut menu or choose Home > Move Record > Up or Home > Move Record > Down.
  • To delete, select the operation in the worksheet area and either choose Home > Edit > Delete or press DELETE. You can undo the last deletion only.
  • To import data from an Excel spreadsheet, choose System Hierarchy > Add Items > Import > Import from Excel. To export data from the PFD worksheet to an Excel spreadsheet, choose System Hierarchy > Tools > Reporting > Export to Excel.
  • To generate a report of the PFD worksheet data, choose Home > Reporting > Reports. In the Reports window, the PFD worksheet reports are located in the "PFD Spreadsheet" and "PFD Records" sections of the Available Reports list.
  • To split the worksheet view so that you can view text at one side of the worksheet without losing sight of text at the other side, right-click a column header and choose Split. To remove the split bar, right-click a column header and choose Remove Split. (For example, you could use this to see the Operation Description column while working with the Process Characteristic column.)
  • To rearrange the order in which the columns are displayed, select a column header and drag it to the place in the worksheet area you want it to appear. This updates the interface style for the project. You also can change the column order through the PFD Worksheet > Worksheet Columns page of the Interface Style window.
  • To change the descriptive information about each column that displays in tooltip form when you move the pointer over the column headers, open the Interface Style window and change the text in the appropriate PFD worksheet pages.
• To populate the gray areas in the worksheet with the relevant text from a prior row, choose File > Application Setup. On the Settings page select the Repeat data in worksheet views check box.

PFD Worksheet Columns
This topic describes the fields found on the Worksheet tab of the PFD worksheet. For a description on how to use the Worksheet tab to document the process steps, see PFD Worksheet Tab.

Note: The fields that are enabled in the interface and the options available in configurable drop-down lists will depend on the interface style settings that have been defined for the current project. You can choose Project > Management > Configurable Settings > Interface Style to open the Edit Interface Style (This Project) window and change the settings for the current project.

• Process Step/Operation Records

• Sources of Variation: A description of the process inputs or variables that affect the results in each process step, such as improper setup, machine calibration and maintenance, contamination of materials, etc.

• Op Seq Number: The reference number for the process step. This is a required column.

• Operation Type: The type of process or activity, such as an assembly, an inspection, a fabrication, etc. The drop-down list in this column can be configured per project.

• Operation Type Symbol: The graphic symbol associated with the type of process or activity; for example, inspection procedures may be represented by a square symbol. The symbols can be configured per project.

• Deliverables: A description of the results of each process step.

• Changeover: Allows you to flag the process steps that are affected by changeover activities. The drop-down list in this column can be configured per project.

• Operation Description: A description of the process step from the product's perspective. The process that the product goes through must be described step by step. This is a required column.

• User-defined fields: Up to five text fields, two date fields, two number fields and two drop-down lists.
• **Product Characteristics Records**
  
  • **Classification**: An abbreviation of the classification that has been assigned to the product characteristic, if any. This field is used to identify characteristics that require special manufacturing control (e.g., Critical, Significant, Key Leading, etc.).
  
  • **Product Characteristics Description**: A description of the product characteristics (outputs) that are affected by each process step; for example, thread depth, wax thickness, length of a cut, etc.
  
  • **User-defined fields**: Up to three text fields, one date field, one number field and one drop-down list.

• **Process Characteristics Records**
  
  • **Classification**: An abbreviation of the classification that has been assigned to the process characteristic, if any. This field is used to identify design characteristics that require special manufacturing control (e.g., Critical, Significant, Key Leading, etc.).
  
  • **Process Characteristics Description**: A description of the process characteristics (inputs) that require control to ensure that the product characteristics meet the specification; for example, furnace temperature, flow pressure, coolant concentration, etc.
  
  • **User-defined fields**: Up to three text fields, one date field, one number field and one drop-down list.

### Sync Options for PFD Worksheets

In the software, there are several ways that a PFD worksheet, process FMEA and control plan can be used together to document a manufacturing or assembly process. In this topic, we will describe the sync options available and provide some recommendations.

*Note*: The descriptions in this topic are based on the default names of the fields. Your worksheet may have different fields depending on the interface style settings that have been defined for the current project. If you have the permissions necessary to edit the project properties, you can enable, hide or rename any of the fields in the worksheets that are part of the synchronization process via the Interface Style window.
General Sync Workflow

The synchronization functionality is intended to provide you with a starting point for a new analysis by copying relevant data. In general, the information flows as shown below (the dotted arrows represent alternative sync actions).

Note: When syncing data, the data are copied, not linked. Changes made in one analysis worksheet do not automatically appear in the related worksheets and vice versa.

Generally, the system hierarchy is synced with the PFD worksheet, which is then synced with the PFMEA. The PFMEA is then synced with the PCP. The main advantage of the general sync workflow is that you’ll be able to track each process step across all worksheets via the reference numbers (operation sequence numbers). For example, process step #1.2.5 in the system hierarchy will have the same reference number in the PFD worksheet, PFMEA and PCP. In addition, the same operation descriptions will be copied across all worksheets. You’ll have the option to edit the descriptions after each sync process, if desired.

The software offers alternative sync workflows and several options for choosing which data to sync in each worksheet. Your sync approach may vary depending on how your organization performs the analyses. The following sections describe the available sync options for each worksheet.
Chapter 15: PFD Worksheets (Process Flow Diagrams)

Sync with PFD Worksheet
The PFD worksheet is always synced with the system hierarchy. This means that when you create a new PFD worksheet for a top-level item, the descriptions and reference numbers of all its dependents are automatically copied to the relevant fields in the new PFD worksheet, as shown in the following example. This provides you with a starting point for filling out the rest of the PFD worksheet.

![PFD Worksheet Example]

Sync with PFMEAs
You can choose to start with a blank PFMEA or with data imported automatically from either the PFD worksheet or the system hierarchy. The settings are configured via the FMEA > Sync Options page of the Interface Style window.

- **Sync with PFD worksheet** - Uses the operation descriptions in the PFD worksheet to populate the function description fields in the new PFMEA. You might select this option if you want the same descriptions for both fields. Special care with the wording of the descriptions may be required in order for them to make sense within the context of each worksheet. Alternatively, you can opt to edit the descriptions after the sync.

  Or

- **Sync with system hierarchy** - Uses the item descriptions in the system hierarchy to populate the function description fields in the new PFMEA. You might select this option if you prefer to use a graphical process flow diagram or other analysis method, instead of the PFD worksheet.

The following example highlights the FMEA columns that can be automatically populated by the sync process. In addition to the automatic sync, you can use the Select Existing icon (also...
Chapter 15: PFD Worksheets (Process Flow Diagrams)

highlighted) to manually copy selected product and process characteristic descriptions in the PFD worksheet to the failures and causes fields in the PFMEA, if desired.

Sync with Control Plans (PCPs)
You can choose to start with a blank control plan or with data imported automatically from either the PFMEA or PFD worksheet. The settings are configured via the Control Plan > Sync Options page of the Interface Style window.

- **Sync with PFMEA** - Uses the function, cause, classification and control descriptions in the PFMEA to populate the operation description, characteristics, classification and control method fields in the new PCP. (Alternatively, if you prefer to sync with the item descriptions in the system hierarchy, choose the Transfer from Items option in the Control Plan > Sync Options page of the Interface Style window.)

Or

- **Sync with PFD worksheet** - Uses the operation descriptions and characteristics defined in the PFD worksheet to populate the relevant fields in the new PCP. You might select this option, for example, if you use the PFD worksheet to define the key product and control characteristics (KPCs and KCCs) of the process steps that are currently in place, and then use the PFMEA to analyze subsequent changes to the process steps, with new KPCs and KCCs being identified. In this case, syncing the PCP with the PFD worksheet provides continuity to the analyses of the KPCs and KCC identified in the PFD worksheet.
The following example highlights the PCP columns that can be automatically populated by the sync process. (Note that the Control Method column can be synced only with PFMEAs.) In addition, you can use the Select Existing Text icon (also highlighted) to manually copy text from either the PFD worksheet or PFMEA, if desired.

In the PCP, you can use the Select Existing icon to:

- Copy selected functions and control descriptions in the PFMEAs to the operation description and control method fields in the PCP.
- Copy selected failure and cause descriptions in the PFMEA to the product and process characteristics fields in the PCP.
- Copy selected product and process characteristic descriptions in the PFD worksheet to the product and process characteristics fields in the PCP.
Chapter 16: Process Control Plans

Control plans are used to track critical characteristics that must be kept in control during a manufacturing or assembly process, and record the methods for maintaining control. Examples of critical process characteristics that might need to be controlled are the temperature range for wax that will be sprayed onto the finished vehicle, uniformity of a cut, calibration for a machine tool, and the like. These characteristics may be kept under control by performing inspections, maintenance procedures, error-proofing and other methods.

Adding a Control Plan

A control plan can be created for any complete systems or sub-systems defined in the system hierarchy.

To add a control plan to a project, select an item in the System panel then choose Analyses > Other > Add Control Plan.

The Control Plan tab will open in the Analysis panel. In addition, the control plan icon will appear in the corresponding column in the System Hierarchy tab of the System panel (if that column has been selected for display on your computer).

The control plan analysis contains two tabs: a Header tab and a Worksheet tab. Use the Header tab to enter general information about the entire analysis and use the Worksheet tab to enter descriptions about the manufacturing or assembly process, the associated characteristics that need to be tracked and the strategy for controlling the characteristics that have been identified.

If desired, you can automatically import data from process FMEAs (PFMEA) or PFD worksheets. (See Sync Options for Control Plans.)

Control Plan Header

The Header tab contains information that may be displayed in the header of a report output. The following fields may be found on the Header tab of a Control Plan.

Note: The fields that are enabled in the interface and the options available in configurable drop-down lists will depend on the interface style settings that have been defined for the current project. You can choose Project > Management > Configurable Settings > Interface Style to open the Edit Interface Style (This Project) window and change the settings for the current project.
• **Control Plan Type**: The type of control plan.
• **Control Plan Number**: A unique identifier for the control plan document.
• **Date (Orig.)**: The original completion date for the control plan.
• **Date (Rev.)**: The latest revision date for the control plan.
• **Part Number**: The part number for the item.
• **Latest Change Level**: The latest change level for the part number.
• **Part Name/Description**: The name and description for the item.
• **Supplier/Plant**: The supplier/plant that will be manufacturing the item.
• **Supplier Code**: An identifying number for the supplier/plant.
• **Key Contact**: The primary contact for the control plan.
• **Key Contact Phone**: The phone number for the primary contact.
• **Core Team**: The primary team involved with preparing the control plan.
• **Approval Fields**: Up to four approval fields that allow you to identify the representative who approved the control plan.
• **Approval Date Fields**: Up to four approval data fields that allow you to enter the date when the representative approved the control plan.
• **User-Defined Fields**: Up to two text fields, one date field, one number field and one drop-down list.
• **Last Updated**: The date when the control plan header was last updated. This is populated by the software.
• **Last Updated By**: The user who last updated the control plan header. This is populated by the software.

For text fields, you can click the **Select Existing** icon inside the field. This will open a window that allows you to reuse text that has already been entered in this type of field.

For date fields, you can click the field once to open a calendar or twice to type the date. You must use the mm/dd/yy or mm/dd/yyyy format.
Control Plan Worksheet

This topic describes how to enter data in the Worksheet tab. For a description of all columns that could be displayed in a Control Plan worksheet analysis, see Control Plan Worksheet Columns.

The Worksheet tab provides the structure for documenting the characteristics that will be tracked in the control plan and the strategy for keeping those characteristics under control. There are three types of records in the control plan Worksheet tab: part/process records (purple fields), characteristic records (green fields) and method records (tan fields). The following figure shows an example of a control plan. Note that you can vary the format of the control plan based on the needs of your analysis. If you have the permissions necessary to edit the project properties, you can choose which columns will be enabled for each type of record and what they will be called. This includes user-defined fields and the ability to define the options in the configurable drop-down lists, when applicable.

<table>
<thead>
<tr>
<th>Op. #</th>
<th>Process Name/Operation Description</th>
<th>Machine, Device, Jig, Tools for Mfg</th>
<th>Characteristic #</th>
<th>Process Characteristic</th>
<th>Control Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.2.1</td>
<td>1.2.1 Get wheel hub from parts presentation device</td>
<td>Station A.1</td>
<td>1</td>
<td>Correct tubes are in parts presentation device</td>
<td>Standardized Work - material handling Bar code scan &amp; verification</td>
</tr>
<tr>
<td>1.2.2</td>
<td>1.2.2 Orient and place wheel hub in wheel assembly fixture</td>
<td>Station A.1</td>
<td>2</td>
<td>Fixture does not allow incorrect hub placement</td>
<td>Standardized Work - material handling Bar code scan &amp; verification</td>
</tr>
<tr>
<td>1.2.3</td>
<td>1.2.3 Get wheel rim from parts presentation device</td>
<td>Station A.1</td>
<td>3</td>
<td>Correct wheel rims are in parts presentation device</td>
<td>Standardized Work - material handling Bar code scan &amp; verification</td>
</tr>
<tr>
<td>1.2.4</td>
<td>1.2.4 Orient and place wheel rim in wheel assembly fixture</td>
<td>Station B</td>
<td>4</td>
<td>Fixture does not allow incorrect wheel rim placement</td>
<td>Standardized Work - material handling Bar code scan &amp; verification</td>
</tr>
</tbody>
</table>

Example of the data-entry columns that you could enable or configure in a control plan.

When using the control plan worksheet, you have the following options:

- To enter or edit data, double-click the cell.
For text columns, you can use the HOME, END and arrow keys to move through the text in the cell. For date columns, you can click the column once to open a calendar or twice to type the date. You must use the mm/dd/yy or mm/dd/yyyy format.

After entering the desired information, either press ENTER, TAB or click somewhere outside of the cell to save the changes.

The following options apply to the part/process, characteristic and method records. While the examples given are for the part/process records, the commands are similar for each record type:

- To add a part/process record, choose Control Plan > Part/Process > Add Part/Process.
- To insert a part/process record above the currently selected one, choose Control Plan > Part/Process > Insert Part/Process.
- To copy, select the part/process record in the worksheet area and choose Home > Clipboard > Copy. To paste a copied part/process record, choose Home > Clipboard > Paste.
- To move a record up or down one place in the list of parts/processes, select the record in the worksheet area, then right-click the worksheet and choose Up or Down from the shortcut menu or choose Home > Move Record > Up or Home > Move Record > Down.
- To delete, select the part/process record in the worksheet area and choose either Home > Edit > Delete or press DELETE. You can undo the last deletion only.

To import data from an Excel spreadsheet, choose System Hierarchy > Add Items > Import > Import from Excel. To export data from the control plan worksheet to an Excel spreadsheet, choose System Hierarchy > Tools > Reporting > Export to Excel.

To generate a report of the control plan data, choose Home > Reporting > Reports. In the Reports window, the control plan reports are located in the "Control Plan Spreadsheet" and "Control Plan Records" sections of the Available Reports area.

To split the worksheet view so that you can view text at one side of the worksheet without moving the text at the other side, right-click a column header and choose Split. A split bar will be placed to the left of the column. To remove the bar, right-click any column header and choose Remove Split. (For example, you could use this to see the Process Name/Operation Description column while working on the Reaction column.)
• To rearrange the order in which the columns are displayed, select a column header and drag it to the place in the worksheet area you want it to appear. This updates the interface style for the project. You also can change the column order on the Control Plan > Worksheet Columns page of the Interface Style window.

• To change the descriptive information about each column that displays in tooltip form when you move the pointer over the column headers, open the Interface Style window and change the text in the appropriate control plan pages.

• To populate the gray areas in the worksheet with the relevant text from a prior row, choose File > Application Setup. On the Settings page select the Repeat data in worksheet views check box.

Control Plan Worksheet Columns
This topic describes the fields found on the Worksheet tab of the control plan. For a description on how to use the Worksheet tab to build a control plan, see Control Plan Worksheet Tab.

Note: The fields that are enabled in the interface and the options available in configurable drop-down lists will depend on the interface style settings that have been defined for the current project. You can choose Project > Management > Configurable Settings > Interface Style to open the Edit Interface Style (This Project) window and change the settings for the current project.

• Part/Process Records
  • Part/Process Number: The reference number for the part or process step. This is a required column.
  • Process Name/Operation Description: The process name and/or a description of the operation. This is a required column.
  • Machine, Device, Jig, Tools for Mfg: The name or a description of the device where the operation is performed.
  • User-Defined Fields: Up to two text fields, one date field, one number field and one drop-down list.

• Characteristic Records
  • Characteristic Number: The identifying number for the characteristic that must be controlled. This is a required column.
  • Product Characteristic: A description of the product characteristics that need to be tracked; for example, thread depth, wax thickness, length of a cut, etc.
• **Process Characteristic:** A description of the process characteristics that require control to ensure that the product characteristics meet the specification; for example, furnace temperature, flow pressure, coolant concentration, etc.

• **Special Char. Class:** An abbreviation of the classification that has been assigned to the process characteristics, if any. This field is used to identify characteristics that require special manufacturing control (e.g., Critical, Significant, Key Leading, etc.).

• **User-Defined Fields:** Up to two text fields, one date field, one number field and one drop-down list.

• **Method Records**
  
  • **Specification/Tolerance:** A description of the specification or tolerance that will be used to evaluate the characteristic.

  • **Evaluation/Measurement Technique:** A description of the measurement method that will be used to make sure the characteristic meets the specification/tolerance.

  • **Sample Size:** When sampling is required, the number of units that will be sampled.

  • **Sample Frequency:** When sampling is required, the frequency at which the units will be sampled.

  • **Control Method:** A description of how the operation will be controlled, including procedure numbers when applicable. This is a required column.

  • **Reaction Plan:** A description of the corrective actions that will occur if the characteristic does not meet the specification/tolerance.

  • **Responsibility:** The person or group responsible for carrying out the reaction plan.

  • **Remarks:** Any remarks related to the control method.

  • **User-Defined Fields:** Up to three text fields, one date field, one number field and one drop-down list.

---

**Sync Options for Control Plans**

You can start a control plan with a blank worksheet or with data imported from either FMEAs or a PFD worksheet. Automatically importing the data provides you with a starting point for preparing the control plan. You can then make any necessary modifications and additions to
data, and if necessary, re-synchronize later to append any new data from the FMEAs or PFD worksheet.

**Automatic Transfer**

You can choose to transfer data automatically from either FMEAs or PFD worksheets each time you create a new control plan. You can configure the setting via the Control Plan > Sync Options page of the Interface Style window.

If you later make any changes to the FMEAs or PFD worksheet, you can update the control plan with the changes via manual transfer, if desired.

**Manual Transfer**

You can transfer data from an existing FMEA or PFD worksheet to a control plan any time via manual sync. The following options are available:

**Sync with Process FMEA**

To sync with an existing process FMEA, choose Control Plan > Sync > Sync with FMEA.

The following settings are available:

- In the **Header** area, select whether to leave the data in the Header tab of the control plan as-is or replace it with data from the associated FMEA.

- In the **Worksheet** area, select whether to replace all of the information in the Worksheet tab of the control plan with data from the associated FMEA or append the FMEA data to the end of the existing data in the worksheet.

- In the **Map Records for Transfer** area, select which data to transfer as process names and cause descriptions in the control plan:
  
  - In the **Part/Process** list: If you stored descriptions of the process in the system hierarchy, select the **Transfer from Items** option; if the descriptions are stored as functions in the FMEA, select the **Transfer from Functions** option.

  - In the **Characteristic** list, specify whether the cause records are more likely to be product characteristics or process characteristics. Your selection determines which column the data will be transferred to. If your cause records do not have data that would be a good starting point for defining the characteristics in the control plan, then you could leave the characteristic records blank.

  - In the **Transfer Controls Options** area, select the **All controls** option to transfer all the controls from the FMEA to the control plan. To transfer only the controls that meet the
desired requirements, select the **Controls where type=** option and then select the required control type from the drop-down list.

- The **Limiting Criteria** area allows you to specify which data to transfer to the control plan by using any of the following criteria:
  - **Classification** transfers only the cause data with the selected classification. Select **All** if you want all cause data, no matter the classification, to be transferred. This includes cause data with no classification. Select **Any** if you want to transfer the record if any classification has been assigned to it. If there is no classification assigned to it, the cause data will not be transferred.
  - **Cause RPN (Initial) >=** transfers only the data with an initial cause RPN that is greater than or equal to the value that you specify in the input box.
  - **Cause RPN (Revised) >=** transfers only the data with a revised cause RPN that is greater than or equal to the value that you specify in the input box.
  - **Cause SxO (Initial) >=** transfers only the data with an initial cause severity x occurrence rating that is greater than or equal to the value that you specify in the input box.
  - **Cause SxO (Revised) >=** transfers only the data with a revised cause severity x occurrence rating that is greater than or equal to the value that you specify in the input box.

**Sync with PFD Worksheet**

To sync with an existing PFD worksheet, choose **Control Plan > Sync > Sync with PFD Worksheet**.

You will be asked to choose whether to overwrite the existing data in the control plan with the data from the PFD worksheet or append the new data. Click **OK** to complete the process.
Chapter 17: Design Reviews Based on Failure Mode (DRBFM)

Design Review Based on Failure Mode (DRBFM) is a methodology used to evaluate proposed changes to an existing item. It was developed by Tatsuhiko Yoshimura, working with Toyota Motor Corporation. DRBFM uses a worksheet modeled after the FMEA worksheet, but some of the relevant differences include:

- **DRBFM usually focuses on changes to an existing design.**
- **DRBFM focuses on "points of concern" to the engineers.**
- **DRBFM follows the GD3 philosophy:**
  - Good Design
  - Good Discussion
  - Good Design Review
- **The structure of the DRBFM analysis worksheet is somewhat different than the typical worksheets for FMEA.**

Although some organizations may choose to perform DRBFM instead of FMEA, most practitioners start with a baseline FMEA and then use the DRBFM worksheet for evaluating the risks that might be introduced by changes to the original design.

If you wish to be able to add a DRBFM analysis to an item in your project, select the Enable Legacy DRBFM check box Configurable Settings page of the Project Properties window. When this option is selected, the Add DRBFM command will be visible on the Analyses tab of the ribbon.

The DRBFM analysis tab will open in the Analysis panel. In addition, the DRBFM icon will appear in the corresponding column in the System Hierarchy tab of the System panel (if that column has been selected for display on your computer).

The DRBFM analysis contains two tabs: a Header tab and a Worksheet tab. The Header tab contains general information about the entire analysis that will be displayed in the header of the report output while the Worksheet tab contains the analysis data.
Chapter 17: Design Reviews Based on Failure Mode (DRBFM)

**DRBFM Header**

The following fields may be found on the DRBFM Header tab.

*Note:* The fields that are enabled in the interface and the options available in configurable drop-down lists will depend on the interface style settings that have been defined for the current project. You can choose *Project > Management > Configurable Settings > Interface Style* to open the Edit Interface Style (This Project) window and change the settings for the current project.

- **DRBFM Type:** The type of DRBFM (choose from menu).
- **Document Number:** A unique document identifier.
- **Key Date:** The date when the DRBFM should be completed.
- **DRBFM Date (Orig.):** The original DRBFM completion date.
- **DRBFM Date (Rev.):** The latest DRBFM revision date.
- **Prepared By:** The person who prepared the document.
- **Primary Approval:** The person who approved the document.
- **Approval Date:** The date when the document was approved.
- **Product:** The product that the DRBFM applies to.
- **Model Year(s)/Program(s):** The model year and/or program identifier that the DRBFM applies to.
- **Mission:** The mission that the item is intended to perform.
- **Release Date:** The date when the design will be released.
- **Responsibility:** The person who is responsible for the design that is being analyzed.
- **Core Team:** The primary team of people who worked on the analysis.
- **Support Team:** The support team for the analysis.
- **Others Affected:** Other people who were involved with or affected by the analysis.
- **User-Defined Fields:** Up to five text fields, one date field, one number field and one drop-down list.
- **Last Updated By:** The date when the DRBFM header was last updated. This is populated by the software.
Chapter 17: Design Reviews Based on Failure Mode (DRBFM)

- **Last Updated**: The user who last updated the DRBFM header. This is populated by the software.

For text fields, you can click the **Select Existing** icon inside the field. This will open a window that allows you to reuse text that has already been entered in this type of field.

For date fields, you can click the field once to open a calendar or twice to type the date. You must use the mm/dd/yy or mm/dd/yyyy format.

**DRBFM Worksheet**

The Worksheet tab displays the records that will be tracked with the DRBFM. If you have the permissions necessary to edit the project properties, you can choose which fields will be enabled and what they will be called. For example, you can include user-defined fields and define the options in the user-defined drop-down menus, when applicable.

The software provides two different "views" for the worksheet; one is intended to be used by the Design Engineer who performs the first draft of the analysis and the other is intended to be used by the entire Review Team to modify and expand upon the initial draft. Use the options at the top of the worksheet to toggle between the two views.

- Select **Design Engineer** to hide the Other Concerns, Other Causes and Actions columns in the worksheet.
- Select **Review Team** to display all enabled columns in the worksheet.

**Note**: If the Severity, Occurrence and Detection columns are enabled in the FMEA, then those columns are also displayed in the DRBFM Worksheet along with the initial and revised RPNs. (See [FMEA > RPNs](#)).

When using the DRBFM worksheet, you have the following options:

- To enter or edit data, double-click the cell.
  - For text columns, you can use the HOME, END and arrow keys to move through the text in the cell. For date columns, you can click the column once to open a calendar or twice to type the date. You must use the mm/dd/yy or mm/dd/yyyy format.
  - To save the changes, either press **ENTER** or **TAB** or click somewhere outside of the cell.
The following options apply to parts, functions, concerns, effects, causes, controls and actions. While the examples given are for parts, the commands are similar for each record type:

- To add a part, choose DRBFM > DRBFM Records > Parts/Functions > Add Part/Function.
- To insert a part above the currently selected one, choose DRBFM > DRBFM Records > Parts/Functions > Insert Part/Function.
- To copy, select the part in the worksheet area and choose Home > Clipboard > Copy. To paste a copied part, choose Home > Clipboard > Paste.
- To move a record up or down one place in the list of parts, select the part in the worksheet area, then right-click the worksheet and choose Up or Down from the shortcut menu or choose Home > Move Record > Up or Home > Move Record > Down.
- To delete, select the part in the worksheet area and either choose Home > Edit > Delete or press DELETE. You can undo the last deletion only.

- To import functions from the FMEA, choose DRBFM > Sync > Get Functions from FMEA. To export the functions to the FMEA, choose DRBFM > Sync > Send Functions to FMEA.
- To import header properties from the FMEA, choose DRBFM > Sync > Get Header from FMEA. To export the header properties to the FMEA, choose DRBFM > Sync > Send Header to FMEA. Performing either action makes the headers identical.
- To import data from an Excel spreadsheet, choose System Hierarchy > Add Items > Import > Import from Excel. To export data from the DRBFM worksheet to an Excel spreadsheet, choose System Hierarchy > Tools > Reporting > Export to Excel.
- To generate a report of the DRBFM data, choose Home > Reporting > Reports. In the Reports window, the DRBFM reports are located in the DRBFM Spreadsheet and DRBFM Records sections of the Available Reports area.
- To split the worksheet view so that you can view text at one side of the worksheet without moving the text at the other side, right-click a column header and choose Split. A split bar will be placed to the left of the column. To remove the bar, right-click any column header and choose Remove Split. (For example, you use this to see the function number while working on the actions.)
- To rearrange the order in which the columns are displayed, select a column header and drag it to the place in the worksheet area you want it to appear. This updates the interface style for the project. You also can change the column order through the Project Interface Style window.
To change the descriptive information about each column that displays in tooltip form when you move the pointer over the column headers, open the Project Interface Style window and change the text in the appropriate DRBFM pages.

To populate the gray areas in the worksheet with the relevant text from a prior row, choose File > Application Setup. On the Settings page select the Repeat data in worksheet views check box.

### Parts/Functions Columns

The following fields may be found in the parts/functions columns of the Worksheet tab of the DRBFM.

- **Part/Change to Design or Environment**: List the part and the change that is being made to the design or the operating conditions. This is a required column.
- **Function**: List the functions that might be affected by the change. This is a required column.
- **User-Defined Fields**: Up to one text field, one date field, one number field and one drop-down list.

### Concerns Columns

The Concerns Related to Change and Other Concerns columns are similar to the "Failure" description in an FMEA. The Concerns Related to Change column is intended for the Design Engineer, but may be used by the Review Team. The Other Concerns column can be used only by the Review Team. Therefore, while information cannot be entered in both columns on the same row, each row must contain a description, which could be in either column.

The following fields may be found in the concerns columns area of the Worksheet tab of the DRBFM.

*Note*: The fields that are enabled in the interface and the options available in configurable drop-down lists will depend on the interface style settings that have been defined for the current project. You can choose Project > Management > Configurable Settings > Interface Style to open the Edit Interface Style (This Project) window and change the settings for the current project.
choose Project > Management > Configurable Settings > Interface Style to open the Edit Interface Style (This Project) window and change the settings for the current project.

- **Concerns Related to Change**: List concerns related to the change, as identified by the Design Engineer. This is a required column for the Design Engineer.
- **Other Concerns**: List other concerns related to the change, as identified by the Review Team. This is a required column.
- **User-Defined Fields**: Up to one text field, one date field, one number field and one drop-down list.

**DRBFM Effects Columns**
The following fields may be found in the effects columns area of the Worksheet tab of the DRBFM.

*Note: The fields that are enabled in the interface and the options available in configurable drop-down lists will depend on the interface style settings that have been defined for the current project. You can choose Project > Management > Configurable Settings > Interface Style to open the Edit Interface Style (This Project) window and change the settings for the current project.*

- **Potential Effects of Concern**: List the potential effects if the concern (failure) occurs. This is a required column.
- **User-Defined Fields**: Up to one text field, one date field, one number field and one drop-down list.

**DRBFM Causes Columns**
The Potential Cause of Concern column is intended for the Design Engineer, but may be used by the Review Team. The Other Causes column can only be used by the Review Team. Therefore, while information cannot be entered in both columns on the same row, you must enter information in one of the columns.

The following fields may be found in the Causes columns area of the Worksheet tab of the DRBFM.

*Note: The fields that are enabled in the interface and the options available in configurable drop-down lists will depend on the interface style settings that have been defined for the current project. You can*
Chapter 17: Design Reviews Based on Failure Mode (DRBFM)

choose **Project > Management > Configurable Settings > Interface Style** to open the Edit Interface Style (This Project) window and change the settings for the current project.

- **Class**: Special characteristic classification, if applicable.
- **Potential Cause of Concern**: List the potential causes for the concern, as identified by the Design Engineer. This is a required column for the Design Engineer.
- **Other Causes**: List other potential causes for the concern, as identified by the Review Team. This column is required if the Potential Cause of Concern field is empty.
- **User-Defined Fields**: Up to one text field, one date field, one number field and one drop-down list.

### DRBFM Controls Columns

The following fields may be found in the controls columns area of the Worksheet tab of the **DRBFM**.

**Note**: The fields that are enabled in the interface and the options available in configurable drop-down lists will depend on the interface style settings that have been defined for the current project. You can choose **Project > Management > Configurable Settings > Interface Style** to open the Edit Interface Style (This Project) window and change the settings for the current project.

- **Current Design Controls Detection**: List the controls that are currently in place to improve the likelihood that the cause will be detected before it reaches the end user. This is a required column.
- **Current Design Controls Prevention**: List the controls that are currently in place to reduce the likelihood that the cause will occur.
- **User-Defined Fields**: Up to one text field, one date field, one number field and one drop-down list.

### DRBFM Actions Columns

The following fields may be found in the actions columns area of the Worksheet tab of the **DRBFM**.

**Note**: The fields that are enabled in the interface and the options available in configurable drop-down lists will depend on the interface style settings that have been defined for the current project. You can
choose **Project > Management > Configurable Settings > Interface Style** to open the [Edit Interface Style (This Project) window](http://xfmea.reliasoft.com) and change the settings for the current project.

*Note:* You can view and change the data in the Action columns only if the Review Team view is selected.

- **Recommended Action Design:** List the design-related actions that could be taken to reduce the risk associated with the issue. This is a required column.

- **Recommended Action Design - Responsibility:** The person (or department) responsible for completing each design-related action.

- **Recommended Action Design - Due Date:** The date when each design-related action must be completed.

- **Recommended Action Validation / Test:** List the testing-related actions that could be taken to reduce the risk associated with the issue.

- **Recommended Action Validation / Test - Responsibility:** The person (or department) responsible for completing each testing-related action.

- **Recommended Action Validation / Test - Due Date:** The date when each testing-related action must be completed.

- **Recommended Action Manufacturing / Supplier:** List the manufacturing-related actions that could be taken to reduce the risk associated with the issue.

- **Recommended Action Manufacturing / Supplier Responsibility:** The person (or department) responsible for completing each manufacturing-related action.

- **Recommended Action Manufacturing / Supplier Due Date:** The date when each manufacturing-related action must be completed.

- **Recommended Action Manufacturing / Supplier:** List the manufacturing-related actions that could be taken to reduce the risk associated with the issue.

- **Actions Taken:** The actions taken (or result) for each action. This is a required column.

- **User-Defined Fields:** Up to one text field, one date field, one number field and one drop-down list.
Transferring Data Between a DRBFM and a FMEA

Data in the DRBFM can be transferred to and from the associated FMEA.

Please note that changes made in the FMEA do not appear automatically in the DRBFM and vice versa.

Sending FMEA Data to the DRBFM

You can synchronize the document headers and/or transfer selected functions from the FMEA to the DRBFM. For example, if you want to use the DRBFM to evaluate the risks that might be introduced by changes to an existing design, you can transfer the specific FMEA functions that might be affected by the change as a starting point for the new DRBFM.

- Synchronize the Document Headers
  
  To send the FMEA header data to the DRBFM header, choose DRBFM > Sync > Get Header from FMEA.

- Sending FMEA Functions to the DRBFM
  
  To transfer selected FMEA functions, choose DRBFM > Sync > Get Functions from FMEA. You can choose functions from the current item only, or from the current item and all of its sub-items.

Sending DRBFM Data to the FMEA

You can synchronize the document headers and/or append selected DRBFM functions (and related records) to the end of the FMEA. For example, if the DRBFM identifies additional risks that may be introduced by changes to an existing design, you can transfer the specific information back to the main FMEA if desired.

- Synchronize the Document Headers
  
  To send the DRBFM header data to the FMEA header, choose DRBFM > Sync > Send Header to FMEA.

- Sending DRBFM Record Data to the FMEA
To transfer DRBFM records to the FMEA, choose DRBFM > Sync > Send Functions to FMEA, then select the specific functions to transfer.

When sending DRBFM data to the FMEA, the following rules apply:

- The Part/Change to Design or Environment column will not be transferred because data in this column is exclusive to the DRBFM.
- The Function column will transfer as function descriptions.
- The Concerns Related to Change and Other Concerns columns will transfer as failure descriptions.
- The Potential Effects of Concern column will transfer as effect descriptions.
- The Potential Cause of Concern and Other Causes columns will transfer as cause descriptions.
- The Current Design Controls columns will transfer as control descriptions with the appropriate Control Type (i.e., detection or prevention).
  - The Detection column will transfer to the first Control Type defined for the project and the Prevention column will transfer to the second Control Type. If the Control Type settings in your project differ, you can adjust them in the project’s interface style so that Detection is first and Prevention second.
  - If there are two controls per row in the DRBFM worksheet, any associated User Defined field information will transfer to both controls in the FMEA.
- The Recommended Action columns (i.e., Recommended Action - Design, Recommended Action - Validation/Test and Recommended Action - Manufacturing/Supplier) will transfer as separate action descriptions.
  - If there are multiple actions per row, the associated Actions Taken and User Defined field information will transfer to each of those actions in the FMEA.
Chapter 18: FMEA Diagrams

There are four types of diagrams that can be used in conjunction with your FMEAs:

- **FMEA Block Diagrams**
- **Process Flow Diagrams**
- **Cause and Effect Diagrams**
- **Failure Relationship Diagrams**

You can choose to work with these diagrams on-the-fly, or save them with the analysis. When a diagram has been saved for a particular system hierarchy item, an icon will be displayed in the hierarchy if the relevant column is enabled for your computer/username.

Depending on the diagram type, you can choose to build the diagram automatically from selected analysis data and/or customize the presentation by adding/modifying blocks, connectors, annotations, etc. These diagrams support many of the same features for building diagrams and customizing appearance settings that are available in BlockSim and other Synthesis applications. For more information, see:

- **Connecting Blocks**
- **Arranging and Resizing Blocks**
- **Keyboard and Mouse Combinations**
- **Diagram Find window**
- **Diagram ribbon tabs:** Home, Diagram and Format
- **Diagram Skins and Appearance Settings**

**FMEA Block Diagrams**

You can create an FMEA Block Diagram for any item in the system hierarchy that visually depicts the system assembly that will be analyzed in a design FMEA. These diagrams help to
define the scope of a particular analysis project and also may provide additional information that will be useful to the analysis team when they attempt to identify potential failure modes.

The FMEA Block Diagram is interactive with both the system hierarchy and the FMEA (if desired). This means that the software will automatically populate the diagram with the components in the selected branch of the system hierarchy. You can then add additional blocks for other factors (e.g., human interactions) and add the appropriate connections (physical, material exchange, data exchange or energy transfer) to complete the diagram. Finally, you can choose to automatically create functions for the selected interactions as a starting point in the FMEA (e.g., "Energy Transfer from Component A to Component B").

Create the FMEA Block Diagram

To create a new FMEA Block Diagram (or open or delete a saved one), select an item in the System panel then choose System Hierarchy > Current Item > Diagrams > FMEA Block Diagram. You can also right-click the item and choose Diagrams > FMEA Block Diagram.

If a diagram has already been saved for the current item, you will be prompted to open, delete or replace it. (If you are opening a diagram that was created in an earlier version of the software, see Converting Existing Diagrams below.)

The FMEA Block Diagram shows all of the items from the selected branch of the system hierarchy. If an item has sub-items (i.e., an assembly), it will be represented as a container block. If not, it will be represented as a standard block.

You can add blocks to the diagram so that you can add connections that need to be considered in the FMEA. For example, in the image shown below, the "Ground" and "Rider" blocks are not included in the system hierarchy, but were added to the diagram so that their interfaces could be included. The indicator in the top left corner of the block indicates that this is an "Additional Item."

To add a standard block (i.e., an item), choose Diagram > Blocks > Add Block.
To add a container block (i.e., a next higher level item), choose **Diagram > Blocks > Add Container**.

---

**Add the Connections (Interfaces) Between Items**

To add connectors (also known as *interfaces*), choose **Diagram > Settings > Connect Blocks** and select a specific connection type. That connection type will be used until you change it.

---

You can include up to four separate connectors between blocks, and the same two blocks can be connected in multiple ways.
Chapter 18: FMEA Diagrams

The default appearance for each connection type is shown here. If you wish to modify the appearance (e.g., add arrowheads to indicate the direction, change the color, etc.), use the Defaults pages in the Diagram Style (which updates all connectors in the diagram that are configured to use default settings) or the Connector Style (which updates only the connector(s) that are currently selected). For more information, see Diagram Skins and Appearance Settings.

- **Physical Connection (PH):** The items are attached to each other (e.g., brackets, bolts, clamps and various types of connectors).

  ![Physical Connection](image)

- **Material Exchange (ME):** The items can transfer materials between each other (e.g., pneumatic fluids, hydraulic fluids or any other fluid or material exchange).

  ![Material Exchange](image)

- **Energy Transfer (ET):** The items can transfer energy between each other (e.g., heat transfer, friction or motion transfer such as chain links or gears).

  ![Energy Transfer](image)

- **Data Exchange (DE):** The items can transfer data between themselves (e.g., computer inputs or outputs, wiring harnesses, electrical signals or any other types of information exchange).

  ![Data Exchange](image)

### Create FMEA Functions

The Connections area on the right side of the window lists the connections between the blocks. Use the check boxes to select which connections you want to add as functions to the FMEA for the item, and then choose **Diagram > Blocks > Create Functions** or click the **Create Functions** icon.
The created functions use the following naming convention: [Connection type]: [First item] – [Second item]. Once in the FMEA, you can change the wording as needed.

**Converting Existing Diagrams**
When opening an FMEA Block Diagram created in Version 9 or earlier version of the software, you will be given the option to update the diagram to the new format:

- If you click **Yes**, the original diagram displays at the top of the window, similar to how it looked previously. In addition, new diagram blocks that are linked to the system hierarchy are included at the bottom of the window.
- If you click **No**, the diagram displays the same as it did in the earlier version.

**Process Flow Diagrams**
You can create a process flow diagram for any item in the system hierarchy. These diagrams are high level charts that help you to visualize the steps that a product goes through in a manufacturing or assembly process.

**Tip:** If you want to use the process flow diagram as a starting point for preparing process FMEAs (PFMEAs) or control plans, then the PFD worksheet may be a more appropriate tool. The PFD worksheet integrates the chart into a worksheet that records more detailed information about each step in the process and it allows you to synchronize the relevant information with the PFMEA or control plan analysis. (See [PFD Worksheets](#).)

To create a new process flow diagram (or open or delete a saved one), select an item in the System panel then choose **System Hierarchy > Current Item > Diagrams > Process Flow Diagram**. You can also right-click the item and choose **Diagrams > Process Flow Diagram**.

If a diagram has already been saved for the current item, you will be prompted to open, delete or replace it.

When you are creating a new process flow diagram, the Create Process Flow Diagram window gives you the option to start with a blank diagram or generate blocks based on the item’s FMEA or control plan. Specifically:

- **Based on system hierarchy** creates blocks for the selected item and any sub-items.
- **Based on system hierarchy and FMEA functions** creates block for each function in the FMEA for the selected item, as well as any sub-items.
Chapter 18: FMEA Diagrams

- **Based on control plan** creates a block for each Process Name/Operation Description in the control plan associated with the selected item.

**Cause and Effect Diagrams**

A cause and effect diagram (also known as a *fishbone* or *Ishikawa* diagram) helps you to visualize the relationship among the events described in your analysis. This diagram presents all of the events that lead up to the selected effect or item failure.
To create a new cause and effect diagram for an item (or open or delete an existing one), select the item and choose **System Hierarchy > Current Item > Diagrams > Cause and Effect Diagram**.

For an effect, choose **FMEA > FMEA Records > Effects > Cause and Effect Diagram**.

If the diagram has already been saved for the current item/effect, you will be prompted to open, delete or replace it.

**Reading the Cause and Effect Diagram**

Although the cause and effect diagram does not have the traditional look of the Ishikawa or fishbone diagram, it can be read the same way. For example, the following diagrams show the events that lead to the failure of System A.
Cause and Effect Diagram for an Item Record

If you create a cause and effect diagram for an effect record, the diagram will consist simply of the failures that lead to that effect and the causes that lead to those failures.
Failure Relationship Diagrams

You can create failure relationship diagram for any failure in an FMEA. These diagrams present all of the causes and effects that have been defined for the selected failure.

To create a new failure relationship diagram (or open or delete an existing one), select the failure record in the Analysis panel and choose FMEA > FMEA Records > Failures > Relationship Diagram.
Chapter 18: FMEA Diagrams

If a diagram has already been saved for the current effect, you will be prompted to open, delete or replace it.

Building Diagrams

Connecting Blocks
Connectors represent the flow of the process or system being diagrammed, and the lines contain information about the relationship between the specific source and destination blocks that they connect.

Adding Connectors
To add a connector between blocks, you can:

- Right-click the diagram (not blocks) and choose Connect Blocks.

http://xfmea.reliasoft.com
• Hold down the **ALT** key.

In both methods, the pointer will change to display small crosshairs. Click the source block, hold down the left mouse button and drag a line from the source block to the destination block. When the crosshairs are located over the connection point box, release the mouse button to create a connector.

![Connector point](Image)

**Source block**  **Destination block**

Note that existing connectors can be dragged to different destination blocks, if needed. Also note that the curved, custom curve and custom angled connector types give you the option to connect to the top or bottom of a block, if desired. When this option is available, the blocks will show additional connection point boxes when you create or move a connector.

**Stop Adding Connectors**

To stop adding connectors and return the pointer to its normal mode, release the **ALT** key or click inside the diagram.

**Tip:** If you do not click the diagram or clear the Connect Blocks option to return the pointer to its normal mode, you will not be able to perform certain other activities, such as moving or deleting blocks. If you are experiencing difficulties with the application, make sure that the pointer is in its normal mode.

**Inserting Blocks/Splitting Connectors**

Starting in Version 11, RBDs and Markov diagrams allow you to insert a block into the flow of the diagram without having to delete and add connectors. Simply drag an unconnected block onto an existing connector. When the pointer changes to a double-headed arrow, drop the block to split the existing connector and insert the block.
Connector Types
There are several types of connector that can be used in a diagram. The simplest is a straight line but there are options for adding line bends to create curved or angled lines. For details about available connector styles and defining preferences, see Connector Style Settings.

Using Curved, Custom Curve or Angle Connectors
When using curved, custom curve or custom angle connectors, you can choose the location where they connect to the blocks (top, middle or bottom) and add one or more bends to the line. These options can be used separately or in combination.

To add or modify line bends:

- **Curved connectors** have a single bend point in the center of the connector. To change the angle, click and drag the point to the desired location.

- For **custom curve and custom angle connectors**, add line bend(s) by clicking anywhere on the connector and dragging the selected point to the desired location.
These custom bends can be removed by right-clicking the connector and choosing **Remove all Bend Points** or, to remove a single bend point, by right-clicking the bend point and choosing **Remove Bend Point**.

**Arranging and Resizing Blocks**
There are a number of commands that can be used to arrange and resize the blocks in a diagram. They can be used separately or in combination.

- To select multiple blocks, select the first block and then hold down the **CTRL** key while clicking each of the other blocks.
- If you apply a command and don’t like the result, you can use **CTRL+Z** to return to the original layout.

**Align Blocks**
To align the blocks (align by center, top, bottom, left, etc.), select the block you want to use as the reference alignment position then select the other blocks. Right-click inside one of the blocks and choose **Align Blocks** then the desired alignment style.

The selected blocks will be aligned with the first block selected. For example, if you choose **Align Middles**, the blocks will be aligned to the vertical center of the first selected block, as shown next.
Chapter 18: FMEA Diagrams

**Resize**
Select the block then click one of the sizing handles and drag it to the desired size.

**Make Same Size**
To make the blocks the same size, select the block that has the desired dimension(s) then select the other blocks that you want to resize. Right-click inside one of the blocks and choose **Make Same Size** then choose to match the width and/or height of the first selected block.

For example, if you choose **Height**, the blocks will be resized to the same height as the first selected block.

**Make Spacing Equal**
To adjust the spacing between blocks, select the blocks that will be affected (the selection order does not matter). Right-click inside one of the blocks and choose **Make Spacing Equal** then the desired direction.

The selected blocks will be moved so that they are equally spaced over the original size of horizontal and/or vertical area.
Auto Arrange
To automatically arrange the blocks in the diagram so that all blocks are placed in logical order depending on their connections, right-click the diagram (not blocks) and choose Auto Arrange.

Note that for Markov diagrams in BlockSim/RENO, you also need to select the starting block that is going to be the top left block in the diagram.

The space between blocks depends on the settings specified in the Background and Grid page of the Diagram Style window.

Auto Fit Width
In some BlockSim/RENO diagrams, you can also choose Auto Fit Width to automatically arrange the blocks in the diagram to fit evenly spaced within the width of the diagram window.

Keyboard and Mouse Combinations
This topic describes the various keyboard and mouse key combinations that you can use while working with diagrams.

Note the following:

- A unit is equal to either 1 millimeter or 0.1 inches, depending on the system setting.
- When selecting multiple objects, you can select either blocks or connectors. A selection cannot include both blocks and connectors. Note that while you can include Standby Containers and Load Sharing Containers in a selection, any changes you make, such as resizing the containers, do not apply to the blocks or connectors in the containers. If you
Chapter 18: FMEA Diagrams

start a selection inside a container, that selection can include only those blocks and connectors within that container.

<table>
<thead>
<tr>
<th>Selecting Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select a block or connector</td>
</tr>
<tr>
<td>Select multiple blocks or connectors</td>
</tr>
<tr>
<td>Select a group of blocks</td>
</tr>
<tr>
<td>Add additional blocks or connectors to the currently selected group</td>
</tr>
<tr>
<td>Select all blocks in the diagram</td>
</tr>
<tr>
<td>Clear all selections in the diagram</td>
</tr>
<tr>
<td>Switch the status of a block or connector from selected to not selected or from not selected to selected.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Moving Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move a block</td>
</tr>
<tr>
<td>Move multiple blocks</td>
</tr>
<tr>
<td>Move block(s) by 1-unit increments</td>
</tr>
<tr>
<td>Move block(s) the distance of 1 grid line</td>
</tr>
</tbody>
</table>
## Resizing Objects

<table>
<thead>
<tr>
<th>Description</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resize a block</td>
<td>Select the block then click one of the sizing handles and drag it to the desired size.</td>
</tr>
<tr>
<td>Resize block(s) by 1-unit increments</td>
<td>Select the block(s) then press <strong>SHIFT</strong> and the desired arrow key. The up and down arrow keys move the bottom edge of each selected block by a single unit; the right and left arrow keys move the right edge of each selected block by a single unit.</td>
</tr>
<tr>
<td>Resize block(s) by 5-unit increments</td>
<td>Select the block(s) then press <strong>CTRL + SHIFT</strong> + the desired arrow key. The up and down arrow keys move the bottom edge of each selected block by 5 units; the right and left arrow keys move the right edge of each selected block by 5 units.</td>
</tr>
</tbody>
</table>

## Connectors

<table>
<thead>
<tr>
<th>Description</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a new connector</td>
<td>Press <strong>ALT</strong> and drag the connector from the source block to the destination block.</td>
</tr>
<tr>
<td>Change a connector’s source or destination</td>
<td>Select the connector then drag the appropriate connection handle to the new source or destination block.</td>
</tr>
<tr>
<td>Add a bending point to a connector.</td>
<td>Click the connector and drag the bending point to the desired location.</td>
</tr>
</tbody>
</table>

**Note:** The connector must use the Custom style. To set the style, refer to the [Connector Style Settings topic](#).

## Scrolling

<table>
<thead>
<tr>
<th>Description</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scroll vertically</td>
<td>Rotate the mouse wheel.</td>
</tr>
<tr>
<td>Scroll horizontally</td>
<td>Press <strong>SHIFT</strong> and rotate the mouse wheel.</td>
</tr>
<tr>
<td>Action</td>
<td>Instructions</td>
</tr>
<tr>
<td>---------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Scroll in any direction</td>
<td>With nothing selected, press the desired arrow key.</td>
</tr>
<tr>
<td>Scroll horizontally to the far left</td>
<td>Press <strong>HOME</strong>.</td>
</tr>
<tr>
<td>Scroll horizontally to the far right</td>
<td>Press <strong>END</strong>.</td>
</tr>
<tr>
<td>Scroll to the upper left corner of the diagram</td>
<td>Press <strong>CTRL+HOME</strong> or <strong>CTRL+PAGE UP</strong>.</td>
</tr>
<tr>
<td>Scroll to the lower right corner of the diagram</td>
<td>Press <strong>CTRL+END</strong> or <strong>CTRL+PAGE DOWN</strong>.</td>
</tr>
<tr>
<td>Scroll by the size of the visible area of the diagram</td>
<td>With nothing selected, press <strong>CTRL</strong> + the desired arrow key. For vertical</td>
</tr>
<tr>
<td></td>
<td>scrolling, you can also press <strong>PAGE UP</strong> and <strong>PAGE DOWN</strong>.</td>
</tr>
<tr>
<td>Move the diagram in any direction</td>
<td>Press <strong>SHIFT</strong>, click the diagram and drag. This is like dragging the</td>
</tr>
<tr>
<td></td>
<td>diagram sheet itself (e.g. to see objects lower in the diagram, you would</td>
</tr>
<tr>
<td></td>
<td>drag the diagram upward).</td>
</tr>
<tr>
<td></td>
<td><strong>Other</strong></td>
</tr>
<tr>
<td>Zoom in or out</td>
<td>Press <strong>CTRL</strong> and rotate the mouse wheel.</td>
</tr>
<tr>
<td>Exit the Format Painter or Connect Blocks modes</td>
<td>Press <strong>ESC</strong>.</td>
</tr>
<tr>
<td>Create a copy of a block and move the copy to the desired location</td>
<td>Press <strong>CTRL+SHIFT</strong> and click the block then drag to the desired location.</td>
</tr>
<tr>
<td>Add blocks to the mirror group currently shown in the</td>
<td>Press <strong>CTRL+SHIFT</strong> and drag the block from the diagram into the Mirrored</td>
</tr>
<tr>
<td>Mirror Group Manager window</td>
<td>Blocks area of the Mirror Group Manager.</td>
</tr>
</tbody>
</table>

http://xfmea.reliasoft.com
Diagram Find Window

The Find window in FMEA diagrams allows you to search for text and/or numbers. To open the Find window, choose Home > Edit > Find.

- Use the **Find what** field to type the text and/or number you want to find in the current diagram.
- Use the **Search** field to find the text and/or number by block caption.
  - **By Block Caption** searches for the block(s) with the text and/or number in the block caption.
- Select **Match case** to find only the text in the current sheet with the same case. For example, the search term "teXt" will not find "Text" because the case does not match.
- Select **Find whole field** if you want to find only the text where the entire word matches the text and/or number you specified in the Find What field. If your search term makes up only part of a word, that word will not be found.

Click **Find Next** to find the next matching text and/or number. When the text and/or numbers are found, the cursor will go to that particular block.

Diagram Ribbon

Diagram Ribbon Home Tab

The Home tab in the Diagram window contains the following commands:

**File**
- **Save** saves the diagram.
- **Close** closes the Diagram window.

**Clipboard**
- **Paste** pastes the contents of the Clipboard onto the diagram.
- **Cut** cuts the selected block to the Clipboard. Data stored in the Clipboard can be pasted into this and other applications.
Chapter 18: FMEA Diagrams

- **Copy** copies the selected graphic element to the Clipboard. You can then paste this element into another location within the diagram.

  - **Copy Diagram as Graphic** copies the current diagram to the Clipboard. The diagram can then be pasted as an enhanced metafile (*.emf) graphic into other documents as an enhanced metafile (*.emf) graphic.

  - **Copy Block(s) as Graphic** copies the selected blocks to the Clipboard. The blocks can then be pasted into other documents as an *.emf graphic.

- **Format Painter** allows you to copy the format properties of text in a sheet and apply it to other text. To use the Format Painter, select the text with the format properties that are to be copied and then choose Format Painter. Next, click the text to which the format properties are to be applied.

**Print**

- **Print** sends the current diagram to the printer.

- **Print Preview** opens the Print Preview window, which allows you to view how the current diagram will appear on the printed page.

- **Page Setup** opens the Page Setup window, which allows you to specify printing options.

- **Print Layout** displays the page boundary lines on the diagram. Everything within the boundary lines will appear on the printed page and this view allows you to make any necessary adjustments to the final look of the diagram before sending it to the printer.

**Edit**

- **Redo** reapplies the previously canceled action. You can redo multiple actions by choosing Redo again.

- **Undo** cancels the last editing change you made.

- **Delete** deletes the selected blocks.

- **Select All** selects all of the blocks in the diagram.

- **Find** opens the Find window, which allows you to search through the diagram for text and/or numbers.
View

- **Normal Zoom** sets the degree of magnification back to 100%.
- **Zoom In** increases the degree of magnification.
- **Zoom Out** decreases the degree of magnification.
- **Zoom%** allows you to specify the degree of magnification.

Diagram Ribbon Diagram Tab

The Diagram tab in the Diagram window contains the following commands:

**Blocks**

- **Add Block** adds a new block to the diagram.
- **Add Container** is available only for an FMEA block diagram and adds a new container block to the diagram.
- **Add Annotation** adds a new annotation to the diagram. You can edit the text that appears in the annotation by double-clicking it to open the Edit User-Defined Label window.
- **Auto Arrange** automatically arranges the blocks in the diagram so that all blocks are evenly spaced and aligned. (See [Arranging and Resizing Blocks](#).)
- **Create Functions** is available only for an FMEA Block Diagram and creates new FMEA functions for the current item based on the selected connections in the Connections area.

**Settings**

- **Connect Blocks** allows you to create connectors between blocks in the current diagram. When this command is selected, click the source block, hold down the left mouse button and drag a line from the source block to the destination block. When the crosshairs are located above the destination block, release the mouse button to create a connector. To stop adding connectors and return to the normal mode, right-click the diagram or clear the **Connect Blocks** command (i.e., by choosing the command again).
The following options are only available if you are working with an FMEA Block Diagram.
Before creating a connection, select the appropriate type. The command indicates which type of connector will be created:

- Physical Connection
- Material Exchange
- Energy Transfer
- Data Exchange

Lock Diagram locks the current diagram. When the diagram is locked, you cannot make changes to it. Select Lock Diagram again to unlock the diagram.

**Properties**

- Rename Block opens the Rename Block window, which allows you to customize the block's name.
- Line Bend alters the bend style of the selected connectors. The commands are: Angle, Right Angle, Straight Line, Curved, Custom Curves, Custom Angles and Default.

The following commands are available only if the style is Custom Curves or Custom Angles: Remove Bend Point and Remove All Bend Points.

- Connector Type is available only for an FMEA Block Diagram and allows you to change the type of connector used. The options are Physical Connection, Material Exchange, Energy Transfer and Data Exchange.

**Selection**

- Cascade Select selects all the blocks that are connected from the selected block. This allows you to easily select all blocks that are connected to a block.
- Trace Path traces the path of the selected block. Click another block or the diagram to remove the traced path. The color of the traced path is the same as the color for a selected connector and can be set in the Diagram Style window. The thickness of the path can also be set in the Diagram Style window, independent of the properties of a selected connector,
- Diagram Actions allows you to perform various actions on the diagram.
- Refresh Diagram updates the diagram to show any changes.
Diagram Style opens the Diagram Style window, which allows you to customize the appearance of the current diagram and set the default properties for connectors and new blocks that are added to the diagram.

Export Graphic saves the diagram as a graphic in one of the following formats: *.wmf, *.png, *.gif or *.jpg. You will be able to use the exported graphic in any application, provided that the application supports the file format.

Diagram Ribbon Format Tab
The Format tab in the Diagram window contains the following commands:

Format
Select Font opens the font window which allows you to set the font properties for the selected blocks.

Font Color opens the Color Palette, which allows you to set the font color for the selected text.

Fill Color opens the Color Palette, which allows you to set the fill color for the selected text.

Styles
Diagram Style opens the Diagram Style window, which allows you to customize the appearance of the current diagram and set the default properties for connectors and new blocks that are added to the diagram.

Block Style opens the Block Style window, which allows you to customize the appearance of the selected block or annotation.

Connector Style opens the Connector Style window where you can customize the appearance of the selected connectors.

Alignment and Spacing
Align Blocks allows you to easily adjust the position of multiple blocks. The selected blocks will be aligned with the first block selected, except for Align to Grid, which moves each selected block to its nearest point on the grid. (See Arranging and Resizing Blocks.)
**Chapter 18: FMEA Diagrams**

**Make Spacing Equal** allows you to easily adjust the spacing between multiple blocks. The selected blocks will be moved so that they are equally spaced over the original size of horizontal and/or vertical area. (See [Arranging and Resizing Blocks](http://xfmea.reliasoft.com).)

**Make Same Size** allows you to resize multiple blocks of different sizes. The selected blocks will be resized to match the height and/or width of the first selected block. (See [Arranging and Resizing Blocks](http://xfmea.reliasoft.com).)

**Bring to Front** moves the currently selected blocks in front of other objects on the diagram.

**Send to Back** moves the currently selected blocks behind other objects on the diagram.

### Diagram Skins and Appearance Settings

Most of the appearance settings in a diagram can be customized to meet your particular preferences.

**Diagram Skin** – sets (or resets) all of the settings in the Diagram Style for a particular diagram.

**Diagram Style** – contains all of the style settings for the current diagram (e.g., background color and grid style) as well as default settings for the blocks and connectors within this diagram.

**Block Style** and **Connector Style** – allow you to override the default settings for specific blocks or connectors, if desired.

For consistency and ease of use, the simplest option is to choose a preferred skin and set it as the default for your computer. Each new diagram you create will have the preferred settings applied automatically. If desired, you also have the option to change settings for a particular diagram, and/or for particular blocks or connectors.

**Tip:** If you use the Block Style or Connector Style windows to modify the settings for specific blocks or connectors, those settings will no longer be linked to the default settings in the Diagram Style and they won’t be updated if you change the skin. If you want the block/connector settings to be determined by the diagram style/skin, make sure they are set to "Diagram Default."
Using Diagram Skins

A diagram skin provides a quick and easy way to set (or reset) all of the settings in the Diagram Style for a particular diagram.

Diagram skins are universal across all Synthesis applications. This means that a single skin can contain the appearance settings for all types of diagrams in BlockSim/RENO, Weibull++/ALTA and Xfmea/RCM++/RBI. However, you will only be able to see/modify the settings for the type of diagram that you are currently working with.

The new universal skins are stored with a *.dskin extension at C:\Users\Public\Public Documents\ReliaSoft\Skins. If you have already customized skins from a prior version, see Converting Version 9 Skins.

In order to create, modify or manage the skins on your computer, you must first open a diagram then right-click and choose Diagram Style.

The commands that you will use are located in the lower-left corner of the window.

Select Skin

To apply an existing skin to the current diagram:

1. Click the Select Skin (✓) icon.
2. Choose a skin from the list and click OK. The name of the selected skin will be displayed in Skin field.
3. Click OK to close the Diagram Style window and apply the relevant settings to the diagram.

If you don’t like the result, you can undo the action by pressing CTRL+Z, or simply return to the Diagram Style window and select a different skin.

Modifying or Creating a Skin

1. Open a diagram that has the settings you want to reuse or create the diagram. Open the Diagram Style window.
2. Make your changes. For details on the settings that can be changed, see the Diagram Style Settings.
3. Click the **Save as Skin** (+) icon. Enter a name for the skin and click **OK**. If you specify a name that already exists, you’ll be asked to confirm that you want to replace the settings for this particular diagram type.

**Note:** Skin names cannot contain the following characters: < > | / \ ? : * or quotes. The names are not case sensitive.

Skins are stored with a *.dskin extension in the Skins folder (C:\Users\Public\Public Documents\ReliaSoft\Skins).

### Save as Skin

To use the settings in the current diagram to create a new skin, or to update an existing skin:

1. Click the **Save as Skin** (+) icon.
2. Enter a name for the skin and click **OK**. If you specify a name that already exists, you’ll be asked to confirm that you want to replace the settings in the existing skin for this particular diagram type. (The settings that are specific to other diagram types will remain unchanged.)

**Note:** Skin names cannot contain the following characters: < > | / \ ? : * or quotes.

### Manage Skins

To view or manage the skins that are available to use on your computer, click the **Manage Skins** (…) icon. From here you can:

- Click **Import** to browse for *.dskin files in another location (e.g., skins that were created by another user or on a different computer) and copy them into the designated folder for your computer.

**Tip:** You can also copy/paste *.dskin files directly into the C:\Users\Public\Public Documents\ReliaSoft\Skins folder. However, they won’t appear in the skins list until you restart the application.

- Select a skin and click **Rename**, then specify a new name. This will change the name of the *.dskin file in the designated folder for your computer.
- Select a skin and click **Delete**. This will remove the *.dskin file from the designated folder on your computer and cannot be undone.
- Click **Set Defaults** and then specify which skin will be used by default for each new diagram you create.
Converting Version 9 Skins

Starting in Version 10, diagram skins are universal to all Synthesis applications that use diagrams. This means that a single skin can contain the appearance settings for all types of diagrams in BlockSim/RENO, Weibull++/ALTA and Xfmea/RCM++/RBI.

Many of the predefined skins installed with Version 9 applications have already been merged and converted into universal skins that are ready to use in any diagram type in later versions. For example, the new White.dskin replaces the old RBDWhite.dskinrbd, FTDWhite.dskinftd, etc.

If you created your own customized skins in Version 9, this topic explains how to convert them for use in later versions.

Preparing the Version 9 Skins Folders

The conversion utility considers the old Version 9 skins that are stored in the following locations:

- C:\Users\Public\Public Documents\ReliaSoft\Skins\BlockSim9
- C:\Users\Public\Public Documents\ReliaSoft\Skins\Xfmea9
- C:\Users\Public\Public Documents\ReliaSoft\Skins\RCM9
- C:\Users\Public\Public Documents\ReliaSoft\Skins\Weibull9

Before running the utility, you can:

1. Delete any Version 9 skins that you don’t wish to use or convert. (This is not required but it may help to avoid confusion when you run the conversion utility.)
2. For any Version 9 skins that you wish to combine into the same universal skin, rename them to the same filename (while still retaining the different file extensions).

   For example, if you want to combine RBDCustom.dskinrbd and FTDCustom.dskinftd into the same universal skin, you could rename the files to Custom.dskinrbd and Custom.dskinftd.

Running the Conversion Utility

After you have prepared the Version 9 skins folders as described above:

1. Choose File > Application Setup.
2. On the Synthesis Settings > Other page, click Convert.
3. The Convert Skins window will display all of the unique filenames that remain in the Version 9 skins folders. (If you want to combine multiple skins into the same new universal skin, make sure you have already renamed the files as described above.) Select the skins you want to use in later versions and click **Convert**.

4. Close the application so the skin(s) will be added to the Skins folder.

The new file(s) are stored at C:\Users\Public\Public Documents\ReliaSoft\Skins with a *.dskin extension and “_V9” appended to the name.

**A Note about Diagram Backgrounds**
Universal skins contain appearance settings for diagram background and grid, and connector and block handles that are applied to all diagram types. When you create a universal skin from individual skins with different background/grid/handle settings, only one set of these appearance settings will be stored in the skin. The settings that are saved into the universal skin are from the last skin that was merged. If these are not the settings you desire, you can use the Diagram Style window to change them.

**Diagram Style Settings**

In the Diagram Style window, you can define diagram-level appearance settings, and default settings for the blocks and connectors within the diagram. These settings can be saved in a **diagram skin** and reused with other diagrams.

To open the Diagram Style window, right-click the diagram (not blocks) and choose **Diagram Style**.

This window consists of multiple pages. The number and type of pages depend on the type of diagram that you are working with. Settings that can be defined are divided into two groups: Diagram and Defaults.

- At the diagram level, you can define the appearance of the diagram sheet and those aspects of the appearance of diagram components (i.e., blocks and connectors) that cannot be configured at the individual component level.

- You can define the default appearance settings for diagram components (i.e., connectors, blocks and annotations). See **Defaults for Blocks and Connectors**.
Background and Grid
You can customize the background and grid appearance of the diagram.

- **Grid Style**: Whether to display grid lines and, if so, the style of the lines (e.g. solid, dash, etc.).
- **Grid Spacing**: The size (width and height) of the grid squares, in inches.
- **Shadow**: The size and color of the shadow "cast" by blocks in the diagram. Note that this applies to all block types, but the shadow will be shown only if the **Show Shadow** check box is selected on the Defaults > General page for that block type.
- **Colors**: The colors used for the background, grid lines and page separator lines. Page separator lines appear in the Print Layout view and indicate the boundaries of each printed page. You can display this view by choosing **Home > Print > Print Layout**.
- **Auto Arrange**: The horizontal and vertical spacing between blocks, in inches, that will be used if you choose the **Auto Arrange** ribbon command.

For fault trees in BlockSim, you can also select the **Always Auto Arrange** check box to turn on Auto Arrange by default.

- **Block Caption ID**: Whether to display the block ID, which is an internal ID number assigned to each block when it is created. You can choose not to display the ID or to display it in decimal or hexadecimal format. If it is displayed, it will appear directly below the block name (i.e., its location, alignment and font will be dictated by the properties that are specified for the block caption).

Connector Handles and Indicators
You can customize the following diagram-level connector properties. These settings apply to all connectors of all types within the diagram and cannot be overridden at the connector level.

- If you select **Show Connectors Over Blocks**, any connectors that cross blocks will be shown over (i.e., in front of) those blocks. Otherwise, the blocks will be displayed on top.

- Where connectors attach to blocks if the blocks are not in direct horizontal or vertical alignment. If the **Automatic Connection Preference** field is set to **Left-Right**, the connector will attach to the sides of the blocks; if it is set to **Top-Bottom**, the connector will attach to the top and bottom of the blocks. If **No Preference** is chosen, the connector will attach to the closest edges.

- The **colors** used for:
  - All connector handles and selected connectors.
• Connectors to/from highlighted blocks (i.e., blocks that are part of a multiple selection).

• Connectors leading to or from a selected block. This can be helpful in visualizing how a block is connected within a complex diagram.

• The size of the arrow head, in inches.

• The thickness of connectors in a traced path.

Block Handles and General Indicators
You can customize the following diagram-level block properties. These settings apply to all blocks of all types within the diagram and cannot be overridden at the block level.

• The colors used for the handles that appear when you are resizing a block or connecting blocks.
  • The properties for a highlighted block, including:
    • The colors used for the caption, border and fill (i.e., the area background).

• The fill style (i.e., how the color is applied to the area).

• Flag settings:
  In BlockSim/RENO, can be used to indicate anything you want. For example, each flag could represent a level of analysis that has been completed. These flags are not used by BlockSim for analyses or simulations.

  In Weibull++/ALTA, the block flags are used to mark blocks that represent a data sheet that has been changed and has not been calculated or a data sheet that has since been deleted.

  • Block flag size: Block flags, which are added by selecting one or more blocks, right-clicking one of the blocks and choosing Set Block Flag.

  • Block flag borders: The style (e.g., solid, dash, etc.), color and thickness of the border for block flags.

• Cross out lines for blocks: In BlockSim diagrams, the style, color and thickness of the line that is used to cross out blocks that are set as failed. Blocks can be set as failed by selecting the Set block as failed option in the Block Properties window. You can also set this option by right-clicking the block and choosing Set Block as Failed.
Block Corner Indicators (BlockSim/RENO Only)
The Block Corner Indicators pages allow you to customize the appearance of status indicators that are displayed at the corners of blocks. Such indicators include the colored shapes that are used to indicate certain block and text labels that may appear independently or in conjunction with a shape. The available Block Corner Indicators pages will vary depending on the type of diagram that you are working with.

Defaults for Blocks and Connectors
Default appearance settings can be defined for diagram components (i.e., connectors, blocks and annotations. A diagram skin can hold the appearance settings for all diagram types (e.g., RBD, fault tree, process flow, etc.); however, you can only modify the settings for the diagram type you are working with. To define these settings, see:

- Block style settings
- Connector style settings

Block Style Settings
The block style settings can be defined at the diagram level in the Diagram Style window or at the block level in the Block Style window. The block-specific settings defined in the Block Style window have priority over the default settings defined in the Diagram Style window for the diagram you are working with. For details on how the diagram-level and connector-level settings relate to each other, see Appearance Settings.

Diagram Level
To open the Diagram Style window, right-click the diagram (not blocks) and choose Diagram Style.

Block Level
To open the Block Style window, select one or more blocks, right-click one of the blocks then choose Block Style.

Note that if you are using this window, you must clear the various Use Default check boxes in order to modify some settings.
Chapter 18: FMEA Diagrams

General Properties

Block Properties
- **Shape and shadow**: The options available in the *Shape* drop-down list depend on the block type. You can change the shape of standard blocks in RBDs, events in fault trees and all blocks in process flow and cause/effect diagrams; all other block types have permanently assigned shapes. You can add a shadow to any available shape.

- **Size**: Unlike the other options on this page, changes to this setting made at the diagram level will apply only to blocks subsequently added to the diagram.

- **Color and style**: The background color is the underlying color applied to the block; the fill color is applied over the background color in the pattern specified by the fill style.

Caption Properties
The caption text comes from a block name in BlockSim/RENO, folio name in Weibull++/ALTA or property name in Xfmea/RCM++/RBI.

- **Location and Horizontal Alignment**: Specify where the caption will be displayed (e.g., under the block, inside the block, etc.) and whether it will be left aligned, center aligned or right aligned.
  - If you choose to place the caption to the left, right or inside the block, you can also specify the *Vertical Alignment* (i.e., at the top, center or bottom of the block).
  - If you choose to hide the caption, the Alignment fields will not be available.

- The *width* and *height* of the area used for the text. You can enter a fixed value for either or both of these. If *Block Width* is selected in the *Width* field, the caption text will wrap, if necessary, up to the vertical limit set in the *Height* field. If *Auto Height* is selected in the *Height* field, no limit is placed on the height of the text area.
  - The *color* and *font* used for the text.

Description Box Properties
These properties are available for BlockSim/RENO blocks only.

The description box displays the text entered in the Description field of the Block Properties window.
Description Box Properties

- **Box width and height**: You can enter a fixed value for either or both of these or you can set them to be the same as the settings used for the caption area.
  
  - If **Block Width** is selected in the Width field, the description text will wrap, if necessary, up to the vertical limit set in the Height field.
  
  - If **Auto Height** is selected in the Height field, no limit is placed on the height of the text area.

- **Box color and style**: The background color is the underlying color applied to the description box; the fill color is applied over the background color in the pattern specified by the fill style.

Description Text Properties

- **Text Location** and **Horizontal Alignment** allow you to specify where the description area will be displayed (i.e., above the block, inside the block or hidden) and whether it will be left aligned, center aligned or right aligned.
  
  - If you choose to place the caption inside the block, you can also specify the **Vertical Alignment** (i.e., at the top, center or bottom of the block).
  
  - If you choose to hide the description area, the Alignment fields will not be available.

  Note that if you place the description inside the block, only the description text will be shown. The settings for the surrounding area (i.e., background color, fill color and border properties) will not be used. The properties for the background color fill color and fill style of the block will be used instead.

- **The color and font** used for the text.

Using the Same Location Settings for Captions and Descriptions

Block captions and descriptions both have the option to place the text above or inside the block. If you choose the same location for both, the description text will display under the caption text.
Chapter 18: FMEA Diagrams

Images
To load an image:

1. Clear **Use default image**, if applicable.
2. Click **Load**, and browse for and select the desired image file.
3. Use the **Position** drop-down list to specify how the image will be placed on the block (e.g., stretched to fit inside the block's current dimensions, centered, etc.). If you select stretched, you can also define the margins you want.
4. Select the **Transparency Mask Color** check box to choose a color that will be shown as transparent when the image is displayed on the block.

   Note: If you choose to use an image that is larger than 800x600 pixels, you will be given the option to down sample the image in order to reduce its size and alleviate possible delays related to database size.

5. Click the **Clear** button to remove the loaded image and use no image at all.

Returning Block-Level Settings to Diagram Defaults
To use the diagram style settings again, in the Block Style window, choose **Diagram Default** from the drop-down lists and select the **Use Default** check boxes.

Connector Style Settings
The connector style settings can be defined at the diagram level in the Diagram Style window or the connector level in the Connector Style window. The connector-specific settings defined in the Connector Style window have priority over the default settings defined in the Diagram Style window for the diagram you are working with. For details on how the diagram-level and connector-level settings relate to each other, see Appearance Settings.

Diagram Level
To open the Diagram Style window, right-click the diagram (not blocks) and choose **Diagram Style**.
Connector Level

To open the Connector Style window, select one or more connectors, right-click one of the connectors then choose Connector Style.

Note that if you are using the this window, you must clear the Use Default check boxes in order to modify some settings.

**Line Settings**

- **Line Settings**: Specify the connector's line style (e.g., solid, dash, etc.), thickness and color.

- **Line Bend and Arrows**: Use the Line Bend drop-down list to specify the kind of bend that you want in the lines. Note that if you select Angle or Right Angle, the Line Bend % field will be enabled. This field allows you to specify the point, in percent, at which the line will bend. For example, if you enter 0.5 (50%), an angle (bend) will appear in the line at the horizontal halfway point.

![Line Bend](image)
Chapter 18: FMEA Diagrams

The available bend styles are shown next.

| Angle (50%) | Right Angle (50%) | Straight | Curved | Custom Curves | Custom Angles |

**Caption Settings**

Specify the location, text color and font used for the caption. The caption text for a connector is entered in the Connector Style window.

Note that in BlockSim/RENO, you cannot enter caption text for connectors used in phase diagrams, RENO flowcharts and Markov diagrams.

**Returning Connector-Level Settings to Diagram Defaults**

To use the diagram style settings again, in the Connector Style window, choose **Diagram Default** from the drop-down lists and select the **Use Default** check boxes.
Chapter 19: Failure Modes and Reliability Analysis (FMRA)

The Failure Modes and Reliability Analysis (FMRA) feature is available in both Xfmea/RCM++/RBI and BlockSim.

In Xfmea/RCM++/RBI, the FMRA displays all of the system hierarchy and FMEA records from the current project that could have an impact on system reliability/maintainability/criticality calculations (which may include items, functions, failures and causes). If you define the necessary properties for these records (reliability policy, operating time, etc.), you can use the FMRA to calculate or simulate a variety of results based on the assumption of a reliability-wise series configuration.

For more advanced analyses — including the ability to change the reliability-wise configuration — you can synchronize the FMRA you built in Xfmea/RCM++/RBI with reliability block diagrams in BlockSim.

Enabling and Viewing the FMRA

In both Xfmea/RCM++/RBI and BlockSim, you can use the Show FMRA command in the View tab of the ribbon to enable or disable the feature for your computer. (You can set this separately for each application.)

To view the FMRA once it is enabled:

- In Xfmea/RCM++/RBI, go to the FMRA tab in the System panel.
In BlockSim, go to the **FMRA** tab of the current project explorer.

**Note:** In BlockSim, you can view the FMRA only when you have a single project open.

### FMRA Columns

To hide or display columns in the FMRA, or change the column order, right-click the column headings and choose **Customize Columns**. (You can also change the column order by dragging and dropping column headings into the desired positions.) These preferences are set separately for each application, and they are stored per computer/username.

- **Name** displays the record description/name. This column cannot be hidden.
- **User Access** displays a **status indicator** when the record is in use (✓), when you don’t have permission to edit (☐) or when the record is locked by an FMEA change log (🔒).
- **Record Type** indicates whether the record is an item from the system hierarchy, or a function, failure or cause from an FMEA.
• **Synchronized with BlockSim** displays ✏️ if the record is being synchronized with an FMRA diagram in BlockSim. (See [FMRA Diagrams and Reliability-Wise Configurations](#).)

• **Reliability Policy** displays one of the following. (See [Setting the Reliability Policies](#).)
  - **Inherit** indicates that the record's reliability/maintainability will be determined by its dependent records.
  - **Default (Not Set)** indicates that the record is set to "Define at this level" but does not yet have an assigned URD. The software will assume that the reliability is 100%.
  - The name of the [universal reliability definition (URD)](#) that is assigned to the record.

• **Mirror Group** displays the name of the mirror group that a cause belongs to, if any. All the causes in a mirror group are treated as the exact same event. (See [Using Mirror Groups in an FMRA](#).)

The remaining columns pertain to FMRA results, which are discussed in [Analytical Results in an FMRA](#) and [Simulation Results in an FMRA](#).

### Building the FMRA Hierarchy

The FMRA hierarchy will automatically display any records from the Xfmea/RCM++/RBI system hierarchy and FMEA that are relevant to the reliability/maintainability/criticality calculations. This may include items, functions, failures and causes.

You also have the option to add records directly within the FMRA hierarchy in either Xfmea/RCM++/RBI or BlockSim. Any records that you add in this manner will also appear in the system hierarchy or FMEA.

### Adding New Records

The options for adding new records will depend on the record that is currently selected and the reliability policies. If a record's **reliability policy** is set to "Define at this level," you will not be able to add new dependents via the FMRA because those records would be irrelevant to the reliability/maintainability/criticality calculations.

The following commands may be available on the FMRA tab of the ribbon, and when you right-click inside the FMRA hierarchy.

- **Add System** adds a new top-level system hierarchy item.
Add Next Level Item adds a new system hierarchy item below the one that is currently selected.

Add Same Level Item adds a new system hierarchy item in the same level as the one that is currently selected.

Add Function adds a new function to the FMEA. If an FMEA does not already exist for this item, it will be created automatically.

Add Failure adds a new failure to the FMEA.

Add Cause adds a new cause to the FMEA. If the FMEA does not already include an effect to add the cause to, one will be created automatically.

Note: The FMRA always adds causes under the last effect in the FMEA hierarchy. If you want to add causes under different effects, you must add them directly in the FMEA.

Deleting Records
To delete a record, select it in the hierarchy and press DELETE (or choose Home > Edit > Delete). The record will be deleted, along with any dependents. There is no undo for deleting a record.

Using Cut/Copy to Move or Duplicate Records
To move or duplicate records in the FMRA, you can use the same cut/copy and paste commands that are available in the Xfmea/RCM++/RBI system hierarchy and FMEA.

The FMRA does not allow drag/drop, move up/move down or promote/demote.

Tip: Remember that after an item has been cut or copied, any edits that are made to the original will also be applied to its copy in the Clipboard. Likewise, if you delete the original, its copy will also be deleted from the Clipboard (and cannot be pasted later).

Setting FMRA Record Properties

Setting the Reliability Policies
The reliability policy determines the reliability/maintainability characteristics for the records in an FMRA.
To view or set the reliability policy in Xfmea/RCM++/RBI, select the record in the system hierarchy or FMRA and go to the **Reliability Policy** heading in the Properties tab. (Note that the following picture includes the maintainability characteristics that can be defined in RCM++ or RBI. In Xfmea, only the reliability model will be displayed.)

![Reliability Policy Table]

In BlockSim, right-click the record in the FMRA and choose **Inherit** or **Define at This Level**. If a record is set to define at this level, you can use the Block Properties window to view or edit the **universal reliability definition (URD)**.

When creating or assigning URDs to records in an FMRA, note that:

- An item's model represents the item's reliability (i.e., the probability that the item will not fail for the specified period of time).
- A function's model represents the probability that the item will fail to perform its intended function within the specified period of time.
- A failure's model represents the probability that the failure will occur within the specified period of time.
- A cause's model represents the probability that the cause will occur within the specified period of time.

**Tip:** In Xfmea/RCM++/RBI only, you can use the **Batch Update Reliability Policy window** to change the policy types of multiple records all at once.
Chapter 19: Failure Modes and Reliability Analysis (FMRA)

**Basic Reliability Policy Types**

Two basic reliability policy types are available for all FMRA records in both Xfmea/RCM++/RBI and BlockSim:

- **Inherit** indicates that the record will inherit its reliability/maintainability characteristics from the URDs assigned to its dependents. In the following example, System 1 inherits from its two components; while SubSystem 1 inherits from its two causes (URD_1 and URD_2) and SubSystem 2 inherits from its failure (URD_3).

<table>
<thead>
<tr>
<th>Name</th>
<th>Reliability Policy</th>
</tr>
</thead>
<tbody>
<tr>
<td>System 1</td>
<td>Inherit</td>
</tr>
<tr>
<td>SubSystem 1</td>
<td>Inherit</td>
</tr>
<tr>
<td>Function 1</td>
<td>Inherit</td>
</tr>
<tr>
<td>Failure 1.1</td>
<td>Inherit</td>
</tr>
<tr>
<td>Cause 1.1.1</td>
<td>URD_1</td>
</tr>
<tr>
<td>Cause 1.1.2</td>
<td>URD_2</td>
</tr>
<tr>
<td>SubSystem 2</td>
<td>Inherit</td>
</tr>
<tr>
<td>Function 2</td>
<td>Inherit</td>
</tr>
<tr>
<td>Failure 2.1</td>
<td>URD_3</td>
</tr>
</tbody>
</table>

- **Define at this level** allows you to assign a URD directly to the record. The reliability policy will either display the name of the URD or “Default (Not Set).” If the URD is not set, the software assumes the reliability is 100% (i.e., the item never fails, the cause never occurs, etc.).

*Tip:* If you use this option with a record that has dependents, the software will hide those dependents in the FMRA because they will be irrelevant to the FMRA’s calculations.

**Only in Xfmea, RCM++ or RBI**

In Xfmea, RCM++ and RBI only, you also have the option to set the reliability policies based on the occurrence ratings from risk priority number (RPN) calculations or the failure probability ratings from criticality analysis. (See [Using Rating Scales to Set the Reliability Policy](#).)

When selected, a read-only probability of failure model (i.e., the probability that the cause or failure mode will occur) will be automatically assigned to the record based on the rating assigned in the FMEA.

- **Based on Initial Occurrence** or **Based on Revised Occurrence**: These options are only available for causes, and only when the initial and/or revised occurrence properties are enabled for the project (on the FMEA > RPNs page in the interface style).
• Based on Failure Probability: This option is only available for failure records, and only when the failure probability field is enabled for the project (on the FMEA > Criticality page in the interface style).

In RBI only, you can use the model generated in the risk based inspection analysis results:

• Based on RBI analysis: This option is only available for RBI components, and only when the option to do so is selected when generating the RBI results. When selected, the model generated by the RBI analysis will be assigned to the component. If you later recalculate the results, this model will change.

Using Rating Scales to Set the Reliability Policy

In Xfmea, RCM++ and RBI, you have the option to set reliability policies for the FMRA based on the occurrence ratings used in RPN calculations or the failure probability ratings used for qualitative criticality analysis. For example, you might use this feature to:

• Generate a preliminary baseline reliability estimate based on occurrence ratings that have been assigned to cause records in an FMEA, and then update the estimate later when actual data is available. (See http://www.reliawiki.org/index.php/Using_FMRA_to_Estimate_Baseline_Reliability.)

**IMPORTANT:** Results based on occurrence ratings are appropriate only for preliminary estimates; it is highly recommended to carefully consider the assumptions behind these results, and to update the reliability policies when better information becomes available.

• Perform a quantitative criticality analysis based on failure probability ratings that have been assigned to failure records in an FMEA.

Viewing or Editing the Rating Scale

To use occurrence or failure probability ratings to set the reliability policy in an FMRA, there must be an appropriate quantitative model associated with each qualitative rating in the scale. In a secure database, only users with the "Edit project properties" permission can modify the rating scales in the current project.

To open the Occurrence scale (used in RPN calculations), choose Project > Management > Configurable Settings > Occurrence.
To open the Failure Probability scale (used in criticality analysis), choose **Project > Management > Configurable Settings > Failure Probability**.

To configure either type of scale, you must enter the **Occurrence Probability (Q)** for each rating in the scale (this was called “Quantitative Value” in Version 8 and 9). As an example, here’s an excerpt from the “RS DFR Focus” occurrence scale that is installed with the software, where “1 in 1 Million” is 0.000001, and so on.

<table>
<thead>
<tr>
<th>Value</th>
<th>Occurrence Probability</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1E-06</td>
<td>1 in 1 Million</td>
</tr>
<tr>
<td>2</td>
<td>1E-05</td>
<td>1 in 100,000</td>
</tr>
<tr>
<td>3</td>
<td>0.0001</td>
<td>1 in 10,000</td>
</tr>
<tr>
<td>4</td>
<td>0.001</td>
<td>1 in 1,000</td>
</tr>
<tr>
<td>5</td>
<td>0.002</td>
<td>1 in 500</td>
</tr>
</tbody>
</table>

Then specify whether each value will be treated as a fixed probability that does not vary with time, or converted to an exponential distribution.

If you choose to use distributions, the software will treat the value as an unreliability point at the specified time and use this point to solve for the exponential distribution’s parameter (using the same method available in the [Quick Parameter Estimator](http://xfmea.reliasoft.com)).

For example, if the value is 0.01 and the time is 1,000 hours, the model will be an exponential distribution with lambda = 1.01e-5 (or Mean Time = 99,499.16 hours if you’ve selected that option in the Application Setup).

**Note:** If you edit these ratings for a standard library via the Profiles/Libraries Manager, the time specified for this option will always be entered in base units. This is because the same standard library might be used by different databases with different time units.

**Using the Rating to Set the Reliability Policy**

When users are performing an analysis, they first set the ratings for the cause or failure records. Then, they select the record in the FMRA and choose to set the **Reliability Policy**:
• **Based on Initial Occurrence** or **Based on Revised Occurrence**: These options are only available for causes, and only when the initial and/or revised occurrence properties are enabled for the project (on the FMEA > RPNs page in the interface style).

• **Based on Failure Probability**: This option is only available for failure records, and only when the failure probability field is enabled for the project (on the FMEA > Criticality page in the interface style).

The software assigns a read-only probability of failure model (i.e., the probability that the cause or failure mode will occur) based on the current rating. If you later change the rating for the cause or failure record, the reliability policy model will be updated automatically.

![Reliability Policy](image)

**Batch Update Reliability Policies**

In Xfmea/RCM++/RBI only, the Batch Update Reliability Policy window makes it easy to change the reliability policy type for multiple FMRA records at the same time.

To open the window, choose **FMRA > Calculations > Policy Update**.

**Inherit vs. Define**

• If you select **Inherit**, you will need to make sure that dependent records have reliability policies defined.

• If you select **Define at this level**, any records that previously had a different policy will be changed to "Default (Not Set)" status. The software will assume that their reliability is 100% unless/until you assign a URD.

**Sub-items or FMEA**

In Version 11, you can now consider whether the item has sub-items and/or an FMEA. For example:
Chapter 19: Failure Modes and Reliability Analysis (FMRA)

Based on Rating Scale
If you select Based on Failure Probability, Based on Initial Occurrence or Based on Revised Occurrence, the following logic applies. (See Using Rating Scales to Set the Reliability Policy.)

- If there is no URD, the software sets the reliability policy to “based on” even if a rating is not yet defined.
- If there is a URD and a rating has been defined, the software sets the reliability policy to “based on.” This will change the reliability model associated with the URD.
- If there is a URD and the rating has not been defined, the software will not change the reliability policy. The reliability model associated with the URD will remain unchanged.

Using Mirror Groups in an FMRA
In both Xfmea/RCM++/RBI and BlockSim, you can use the Mirrors commands on the FMRA tab of the ribbon to place the exact same cause record in more than one location in the FMRA.
This is useful when you need to consider common cause failures (i.e., single faults that result in the failure of multiple components). Typical examples of common cause failures include impact, vibration, temperature, contaminants, miscalibration, improper maintenance, and so forth.

All cause records in a mirror group (i.e., "mirrored causes") represent the very same cause for the purpose of FMRA calculations/simulations. To accommodate this, the use of mirror groups will change the properties of cause records in the following ways. **Note that there is no undo for changed cause properties.**

- When a cause is added to a new mirror group or an existing empty group (i.e., one that includes no other causes), that cause’s properties will determine the group’s properties.

- When a cause is added to a mirror group that already includes other causes, that cause’s properties (e.g., the short description, reliability policy, etc.) will be changed to match the group’s properties.

- If you change the properties of a mirrored cause, that change will also be applied to all other causes in the same mirror group.

Also note that, because mirror groups are Synthesis resources, clearing or removing the causes will not delete the mirror group resource from the project. To delete a resource, use the [Resource Manager](#).

### Setting the Operation Properties for an FMRA

Before you perform analytical calculations or simulations in the FMRA, make sure you at least specify the operating time for the top-level item. If applicable, you can also specify other operation properties at the individual item level.

These properties are located under the **Operation** heading when you select an item in the FMRA in Xfmea/RCM++/RBI.

- **Operating Time:** The amount of time for which the system is expected to operate (and the time for which the results are estimated). This can be modified at the system level only. When you perform a simulation-based calculation, you can also edit this value in the simulation settings window.

- **Current Age:** The age of the item at the start of the analysis. It allows you to define items that have already accumulated age prior to the start of the current mission (i.e., used components).

- **Qty:** The number of identical sub-items represented. New in Version 11, this property allows you to represent multiple copies of the same item with the same properties without having to create individual items (e.g., the 4 tires on a car). A value greater than 1 in this field will cause the item to be represented in the [FMRA Diagram](#) as a multi-
block. By default, the multi block will be configured so that the items are connected in series, but you can manually change this to a parallel configuration. (For more information on multi blocks, see Standard Blocks and Basic Configuration in the BlockSim/RENO documentation.) This value is taken into account at all levels for FMRA calculations performed in Xfmea/RCM++/RBI; it does not apply at the system level in FMRA calculations in BlockSim.

- **Duty Cycle**: Allows you to model situations where the actual usage during system operation is not identical to the usage for which you have data (either from testing or from the field). This can include situations where the item:
  
  o Does not operate continuously (e.g., a DVD drive that was tested in continuous operation, but in actual use within a computer accumulates only 18 minutes of usage for every hour the computer operates).
  
  o Is subjected to loads that are greater than or less than the rated loads (e.g., a motor that is rated to operate at 1,000 rpm but is being used at 800 rpm).
  
  o Is affected by changes in environmental stress (e.g., a laptop computer that is typically used indoors at room temperature, but is being used outdoors in tropical conditions).

  In these cases, continuous operation at the rated load is considered to be a duty cycle of 1. Any other level of usage is expressed as a percentage of the rated load value or operating time. For example, consider the DVD drive mentioned above; its duty cycle value would be $18 \text{ min} / 60 \text{ min} = 0.3$. A duty cycle value higher than 1 indicates a load in excess of the rated value.

  If a duty cycle is specified for a subsystem or item, it specifies the percentage of operation as relates to the parent item. That is, the effects of the duty cycle for a parent item and the duty cycle for a sub-item are compounded. For instance, if a system has a duty cycle of 2 and its subsystem has a duty cycle of 0.3, the effective duty cycle for the subsystem would be $2 \times 0.3 = 0.6$, or about 2/3 the rated load value or operating time.


- **Maintenance Group**: Allows you to model situations in which some event within the group can trigger maintenance for other items(s). This field is applicable only for FMRA simulations in RCM++/RBI, and it considers system hierarchy items only.

  Note: Maintenance groups defined for top-level systems in RCM++/RBI will not transfer to FMRA diagrams in BlockSim if you use FMRA synchronization. Similarly, maintenance groups defined for FMEA records in BlockSim’s diagrams will not transfer to RCM++/RBI. This is because the applications use different structures to represent the FMRA hierarchy.
Allocate Target Reliability and Availability

In Xfmea/RCM++/RBI, the **Reliability/Availability** fields in the Properties tab of the Analysis Panel allow you to enter the target reliability and availability that you hope to achieve, and compare them to the current estimates from the Failure Modes and Reliability Analysis (FMRA).

Starting in Version 10, you can set the targets for a system or assembly and then use the FMRA to automatically allocate the targets for sub-items (and also failures/effects/causes if the item's reliability policy is set to "inherit" from the FMEA).

This feature uses an "equal allocation" approach that distributes the reliability/availability uniformly so the target defined for system/assembly will be met. It assumes a reliability-wise series configuration.

To perform the allocation:

1. Go to the FMRA tab in the system panel. (See Enabling and Viewing the FMRA.)

2. Select a system or assembly in the hierarchy and enter the target reliability/availability in the Properties tab.

3. Choose **FMRA > Allocation > [Allocate Target Reliability]** or [Allocate Target Availability].

---

### Example Table

<table>
<thead>
<tr>
<th>Name</th>
<th>Reliability Policy</th>
<th>Target Reliability</th>
</tr>
</thead>
<tbody>
<tr>
<td>System 1</td>
<td>Inherit</td>
<td>0.900000</td>
</tr>
<tr>
<td>SubSystem 1</td>
<td>SubSystem 1 URD</td>
<td>0.965489</td>
</tr>
<tr>
<td>SubSystem 2</td>
<td>SubSystem 2 URD</td>
<td>0.965489</td>
</tr>
<tr>
<td>SubSystem 3</td>
<td>SubSystem 3 URD</td>
<td>0.965489</td>
</tr>
</tbody>
</table>

---

### Example Diagrams

- Allocate Target Reliability
- Allocate Target Availability
Highlights Based on Target Reliability/Availability

The FMRA in Xfmea/RCM++/RBI applies automatic color-coding in the Properties tab of the Analysis Panel to highlight situations when the expected reliability/availability does not meet the specified targets. The highlights can be applied to the calculated/simulated values, and also to the cause occurrence ratings if applicable.

Highlighting the Calculated/Simulated Values

For all records in the FMRA, if the calculated/simulated current value is less than the target value, the field will be highlighted in red.

For example, in the following picture, the Current Reliability calculated via the FMRA (.816780) is highlighted because it is less than the target (.95).

The Current Availability simulated via the FMRA (.971283) is not highlighted because it exceeds the target (.95).

Highlighting the Occurrence Ratings

Highlight colors will also be applied when you have selected a cause record in the FMRA. If the quantitative value associated with the occurrence rating meets the target, the field will be highlighted in green. If not, it will be highlighted in red.

For example, in the following picture, the quantitative probability of failure associated with an Initial Occurrence rating of 8 (Q = .1) is highlighted in red because it does not meet the target reliability of .95.

The probability of failure associated with a Revised Occurrence rating of 6 (Q = .01) is highlighted in green because it exceeds the target.
FMRA Diagrams and Reliability-Wise Configurations

By default, the records in an FMRA are assumed to have a reliability-wise series configuration. In other words, if any failure mode occurs or any component fails, then the entire system fails. However, you can use BlockSim’s FMRA diagrams to represent more complex configurations.

To do this, choose **FMRA > Refresh > Synchronize FMRA** to refresh the FMRA and create the associated diagrams and blocks.

Note the following about FMRA synchronization:

- Changes that are made in BlockSim are synchronized and propagated to Xfmea/RCM++/RBI automatically, although you may need to refresh the view to see them (**View > Refresh**).

- When records are added to the current FMRA in Xfmea/RCM++/RBI, they will not be displayed in BlockSim’s FMRA hierarchy until you synchronize the FMRA (**FMRA > Refresh > Synchronize FMRA**). This will refresh the FMRA hierarchy and create the associated diagrams and blocks. Depending on the changes that were made in Xfmea/RCM++/RBI, this may affect your FMRA diagrams.

- If you no longer wish to synchronize the FMRA with BlockSim diagrams, you can choose **View > FMRA > Disassociate FMRA** to delete all of the FMRA diagrams and close the FMRA view. You can resynchronize at any time.

Working with FMRA Diagrams

It is important to note that the diagrams that you work with from within the FMRA are distinct from the other diagrams in BlockSim’s current project explorer. FMRA diagrams relate to the analysis being performed in the project using Xfmea/RCM++/RBI. They are accessible only via the FMRA view, while all other diagrams are accessible only from the Standard tab of BlockSim’s current project explorer.

Each record in the FMRA hierarchy represents a reliability block diagram, with the exception of the lowest-level record in each branch, which represents a block in the parent diagram. The levels of the hierarchy are expressed using subdiagrams. For example, consider the FMRA hierarchy shown next.
Now, let's look at the branch of the FMRA that begins with SubSystem 1. The associated FMRA diagrams are:

As you can see, the causes are assumed to be in a series configuration, as is the case with all reliability-wise configurations built in Xfmea/RCM++/RBI. Working with the FMRA in BlockSim
allows you to change the reliability-wise configuration. For instance, let's imagine that the causes are actually in a parallel configuration—in other words, the item will not fail if only Cause 1.1.1 happens OR only Cause 1.1.2 occurs, but the item will fail if both occur. To represent this, you would change the Failure 1.1 diagram as follows (with the first node acting as a starter block):

![Failure 1.1 Diagram]

Analytical and Simulation FMRA Diagrams
By default, the FMRA diagrams are created as analytical diagrams (which use the exact algebraic equation for the model but impose limitations on what can be modeled and what results can be obtained). You can choose FMRA > Inheritance > Toggle Diagram Type to change them to simulation diagrams (which provide more modeling options and results but must be analyzed with discrete event simulation; repairable systems must be represented using simulation diagrams), or to change simulation diagrams to analytical ones. This command changes all of the FMRA diagrams in the project; you cannot have both analytical and simulation FMRA diagrams in the same project.

Like any other RBD, the diagram type affects the available functionality, both in terms of configuration and results. For instance, maintenance groups can be assigned only in simulation RBDs. You can analyze or simulate an FMRA diagram just as you would any other RBD, and can generate plots and QCP results for each diagram. You also can perform analytical calculations or simulation at the FMRA level.

FMRA Calculations
Chapter 19: Failure Modes and Reliability Analysis (FMRA)

Analytical Results in an FMRA
The analytical results in the FMRA may include reliability or probability of failure (which are available in both Xfmea/RCM++/RBI and BlockSim), and criticality (which is available only in Xfmea/RCM++/RBI).

To perform analytical calculations, choose FMRA > Calculations > Calculate (Reliability).

In Xfmea/RCM++/RBI, if there are multiple systems (top-level items) or if the FMRA is synchronized with BlockSim, you will be prompted to specify a) which systems to calculate and/or b) whether to consider a more complex reliability-wise configuration that may have been modeled in the BlockSim diagrams. (See Calculation Options Window.)

In BlockSim, these calculations are available when you are using analytical FMRA diagrams. If there is only one system in the FMRA, this will calculate results for the entire FMRA. If there are multiple systems, you will be asked to choose whether you want to calculate the entire system hierarchy or just the currently selected system and its dependents.

Reliability and Probability of Failure
You can display the following FMRA columns in both Xfmea/RCM++/RBI and BlockSim:

- **Analytical Results Status** displays a green indicator light if the analytical results are based on the current inputs. It displays a red light if they are not.

- **Reliability (Analytical)** displays the record's calculated reliability at the system's specified operating time. In Xfmea/RCM++/RBI, the reliability for each item will also be displayed in the Current Reliability field of the Properties tab when the item is selected. This value will be highlighted in red if it is below the specified target reliability.

- **Probability of Failure (Analytical)** displays the record's probability of failure at the system's specified operating time. This is the complement of reliability (1-R).

Criticality Analysis
In Xfmea/RCM++/RBI only, you can also display the following FMRA columns for quantitative criticality analysis:

- **Mode Ratio** displays the probability that the item failure will be due to the failure mode under consideration.

- **Prob of Loss** displays a factor from 0 to 1 that describes the probability that this failure mode would result in a system failure. By default, this is set to 1 (Actual Loss).

- **Criticality** displays the calculated criticality value. This column must be displayed when the mode ratio or probability of loss is displayed.
Calculation Options Window (Xfmea/RCM++/RBI)
In Xfmea/RCM++/RBI only, the Calculation Options window lets you choose which system(s) in the failure modes and reliability analysis (FMRA) will be calculated and which application will be used to perform the calculations.

If the FMRA has multiple systems, or if it has records synchronized with BlockSim, this window will appear when you calculate the FMRA.

In the What items do you want to calculate? area, you can choose to perform calculations only for the system that is currently selected, or for all the systems in the hierarchy.

In the Calculation Method area:

- The Calculate using BlockSim option is available only when there are records in the FMRA that are currently synchronized with BlockSim. If you calculate using this option, the software synchronizes all records and then returns results based on the reliability-wise configuration of the synchronized RBDs in BlockSim.

- The Calculate using current application option is always available. If you calculate using this option, the software will assume a reliability-wise series configuration among all the records in the FMRA.

Simulation Results in an FMRA
The simulation results in an FMRA consider both reliability and maintainability characteristics in order to estimate availability, operating costs, and other useful metrics about the operation of a repairable system over time. They are available in RCM++/RBI and BlockSim.

Tip: When you perform FMRA simulations in RCM++/RBI, the software always assumes a reliability-wise series configuration. If you modified the configuration using BlockSim, then you must perform the simulation within BlockSim in order to take the new configuration into account.

To perform an FMRA simulation in RCM++/RBI, choose FMRA > Calculations > Simulate (Availability).

A window will open where you can change the simulation settings. Click OK to perform the simulation.
In BlockSim, you can use the simulation batch mode to get simulation results. To do this, change the diagrams to simulation diagrams and choose FMRA > Calculations > Simulate (Availability). Then click Run to perform the simulation.

A Note about Simulation with Constant Models
Note that it is not possible to simulate failure times if the reliability policy is defined with a constant value (rather than a distribution that varies with time). Thus, the costs estimated from the simulation will always be zero for any record with a constant reliability model. In such cases, you may wish to change the affected reliability policies to time-dependent distributions before simulating again.

Simulation Results
- **Simulation Results Status** displays a green light if the simulation results are based on the current inputs. It displays a red light if they are not.

- **Operating Cost** displays the total costs that accrued during the simulation. Note that this will always be zero if the reliability is defined by a constant value (rather than a time-dependent distribution).

- **Cost per Operating Time** displays the operating cost divided by the total operating time.

- **Availability** displays the average availability (i.e., uptime divided by total operating time). This is a metric that reflects the probability that the item is operational (not failed or undergoing repair) when it is requested for use during the simulation.

- **RS FCI** (ReliaSoft Failure Criticality Index) is a relative index showing the percentage of times a failure of the component caused a system failure (i.e., the number of system failures caused by the component divided by the total number of system failures). Note that this relates only to failures; it does not include every event that could bring the system down (such as routine maintenance).

- **RS DECI** (ReliaSoft Downing Event Criticality Index) is a relative index showing the percentage of times that a downing event of the component caused the system to go down (i.e., the number of system downing events caused by the component divided by the total number of system downing events). Note that this only relates to downing events with a non-zero duration.

- **RS DTCI** (ReliaSoft Downtime Criticality Index) is a relative index showing the contribution of each component's downtime to the system’s downtime (i.e., the system downtime caused by the component divided by the total system downtime).
Chapter 20: Generated Reports

Xfmea/RCM++/RBI Reports Window

In Xfmea/RCM++/RBI, the Reports window makes it easy to build report documents that include the predefined report forms, custom report forms and/or custom queries that will be most effective to present your analyses.

You can save generated reports with the project, which enables all users to view/print the same report documents. In addition, if your organization chooses to implement a web-based Synthesis Enterprise Portal (SEP) for an enterprise database, you can also publish these reports to the portal (in Word, Excel, or PDF format), where they can be accessed from any web-enabled device.

To open the Reports window, choose Home > Reporting > Reports or System Hierarchy > Tools > Reporting > Reports.

Select Items

In the Select Items area, specify the items from the system hierarchy that will be included in the report. You can generate a report that contains data from a single analysis or from multiple analyses together.

Selected Report Forms

The Available Reports area displays all of the available report forms that are not yet selected. This list includes the standard report forms that are shipped with the software, as well as any custom report templates and custom queries that you have created.

The Selected Reports area displays the forms that have been selected for inclusion in the generated report, in the order in which they will appear.

You can double-click a form or use the Include (>, >>) or Exclude (<, <<) icons to move the form between the areas.

Drag and drop the selected forms into the desired position or use the Up/Down icons.
Chapter 20: Generated Reports

When applicable, you can use the **Sort By** and **Ascending** columns to specify how tabular report forms will be sorted. For example, you can generate a Causes report that sorts by **Initial RPN** in ascending order.

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Sort By</th>
<th>Ascending</th>
</tr>
</thead>
<tbody>
<tr>
<td>Causes</td>
<td>Initial RPN</td>
<td>Yes</td>
</tr>
</tbody>
</table>

**Templates Manager**

If you want to create or edit any of the custom report templates, click **Manage > Templates Manager** in the ribbon.

In a secure database, this option is only available for users with the "Manage profiles and templates in Xfmea/RCM++/RBI" permission.

**Report Customization/Settings**

If you want to customize any of the report settings (e.g., font, paper size, add a logo, etc.), click **Manage > Settings** to open the **Report Customization/Settings window**.

**Save/Publish**

If you want to save the generated report with the project (and also publish to the Synthesis Enterprise Portal (SEP) if applicable), select the desired output types on the ribbon.

To see the reports that have already been saved/published, click **Save/Publish > Published Reports Manager**.

**Generate Report**

Before generating the report, make sure the desired output type is selected in the ribbon (**Excel Spreadsheet** or **Word Document**) and then click **Generate Report**.
Tips

- If you have set your computer to use large fonts, you will need to set your screen display to at least 1152x864 to display correctly. If you have set your computer to use small fonts, you will need to set your screen display to 600x800.

- If you have enable the "Check spelling as you type" and "Check grammar as you type" options in Microsoft Word and you have a very large number of spelling/grammar issues in your data set, then Microsoft Word may stop responding during report generation, resulting in a blank document and possibly error messages such as "RPC Server Unavailable." If this occurs, you can temporarily disable these options in Word and regenerate the report.

- The regional settings for Windows and Microsoft Office (Word and/or Excel) must be compatible when generating reports in the software.

- The number of forms in your report cannot exceed the maximum supported by Microsoft Excel. Generated reports will include as many forms as possible up to the limit, which will vary depending on the version of Excel that you are using, and will omit the rest.

Standard Report Forms

The following predefined forms can be included in the reports you generate from the Xfmea/RCM++/RBI Reports window.

General

- **Report Summary** presents a list of the report forms that are included in the main report.

- **Rating Criteria and Classifications** presents the calculation method, rating criteria and classification options used in the analysis.

- **Analysis Plans Summary** presents full information for each analysis plan.

- **Analysis Plan Details (One per Item)** presents the details for each analysis plan associated with each of the selected items.

Items

- **Items Summary (All Items)** presents the system hierarchy plus a full summary of the properties for each item. If the system hierarchy contains more than one system, then the items under the first system will be displayed followed by the items for the second system, and so forth.
Chapter 20: Generated Reports

- **Items Integrated Documents** is available only for reports generated in Microsoft Word. It includes any integrated documents attached to each item (via the [Attachments window](http://xfmea.reliasoft.com)).

- **Risk Based Inspection** (available only for RBI)
  - **Equipment/Component Types (All Project Items)** displays the RBI equipment types or RBI component types in the system and how many there are of each type.
  - **Risk Matrix Reports** are a group of eight reports that display either the area [risk scoring matrix](http://xfmea.reliasoft.com) or the financial risk scoring matrix as of the plan date. The following types of reports are available:
    - To see the total number of items in the project that fall into each cell of the matrix, generate the "All Project Items" report. If you want to see the names of only the selected items, generate the "Selected Items" report.
    - The basic report shows the results as of the plan date, assuming that you do nothing until then. To generate a matrix with the results as of the plan date assuming that the recommended inspections on the target date are carried out, generate the "Results Assuming Inspections Performed" report.
  - **Consequence Summary** displays information about the possible damage consequences for each non-HEXTUBE and non PRD component.
  - **Damage Summary at RBI Date/Plan Date** displays the calculated damage summary values at the applicable date for each non-HEXTUBE and non PRD component.
  - **Recommended Inspections at Due Date** lists the number of suggested inspections and the needed effectiveness ratings for each damage factor for each non-HEXTUBE and non PRD component.
  - **Probability at RBI Date** lists the probability of failure and financial consequences at the RBI date for each non-HEXTUBE and non PRD component.
  - **Risk Summary at RBI Date/Plan Date** lists the financial risk details at the applicable date for each non-HEXTUBE and non PRD component.
  - **HexTubes Summary** displays information about each HEXTUBE component.
  - **PRDs Summary** displays information about each pressure relief device.
  - **Thinning Damage Factor** displays information about the thinning damage factor properties for each selected component.
• Risk Discovery
  • Risk Discovery Logic presents the risk discovery questions and ratings used in the analysis.
  • Risk Discovery Summary (with Questions) presents the answers given to questions in the risk discovery analysis, if any.
  • Risk Discovery Summary (with Ratings) presents the risk discovery ratings specified in the risk discovery analysis, if any.
  • Risk Discovery Details (One per Item) presents a separate report for each selected item showing the answers given to the risk discovery questions and the risk discovery ratings specified in the risk discovery analysis.

• P-Diagram
  • P-Diagram (One per Item) presents a separate report for each Parameter Diagram (P-Diagram) that has been defined for the selected items.

• PFD Spreadsheet
  • PFD Standard presents the process flow diagrams (PFD) data, if any, in the traditional tabular format. Reports will be generated only for selected items that have an associated PFD analysis.

• PFD Records. There are no standard report forms for PFD records. This category may contain any relevant custom report templates and/or any custom queries that you have created.

• FMEA Spreadsheet presents the FMEA data in the traditional tabular format. The number of separate forms generated will depend on the items selected in the Select Items area. (See Sub-Item Data Combined or Separated.)
  • FMEA Standard creates an FMEA spreadsheet that includes information from the most basic elements of most FMEAs. This is a very basic style and should only be used when you are not required to meet published guidelines for the current profile.
  • AIAG Form A through AIAG Form E create FMEA spreadsheets that are consistent with the examples published in the Automotive Industry Action Group (AIAG) guidelines.
  • J1739 (2002) and J1739 (2009) create FMEA spreadsheets that are consistent with the examples published in the 2002 and 2009 revisions of the Society of Automotive Engineers (SAE) guidelines.
Chapter 20: Generated Reports

- **MIL-STD-1629A** creates an FMEA spreadsheet that is consistent with the example published in the military standard.

- **VDA-86** and **VDA-96** create FMEA spreadsheets that are consistent with the examples published in the VDA Volume 4 guidelines used by the German automotive industry.

**Tip:** In addition to the predefined spreadsheets, you can also export the FMEA data by choosing System Hierarchy > Tools > Reporting > Send Active View to Excel or Export to Excel.

- **FMEA Records**
  - **VDA Action Tracking** presents an actions summary report configured to match the "Action Tracking" template in the VDA Volume 4 guidelines used by the German automotive industry.
  
  **Action Details (One per Action)** presents a separate report for each action that has been defined for the selected items. If this report form is selected for inclusion in the generated report, the Select Actions for Detail Report window will appear when you click **Generate Report**.

  - **Functions, Failures, Effects, Causes, Controls** and **Actions** are available only if the default Standard templates file is selected in the Templates Manager. They are report templates that were created by ReliaSoft and saved in the default Standard templates file, XRUT.xrt11, which is located by default in your My Documents folder (e.g., C:\Users\<your USERNAME>\My Documents\ReliaSoft\Common).

- **Criticality** presents the results from quantitative or qualitative criticality analysis performed in the FMRA.

  - **Criticality Analysis (Standard)** presents the quantitative criticality analysis in a tabular format that is based on MIL-STD-1629A but includes some modifications to the header information and uses customized column headings.

  - **Criticality Analysis (MIL-STD Quantitative)** and **Criticality Matrix (MIL-STD Quantitative)** present the quantitative criticality analysis in a format that is based on MIL-STD-1629A. For the matrix, Severity Classification is on the horizontal axis and Mode Criticality is on the vertical axis.

  - **Criticality Analysis (MIL-STD Qualitative)** and **Criticality Matrix (MIL-STD Qualitative)** present the qualitative criticality analysis in a format that is based on MIL-STD-1629A. For the matrix, Severity Classification is on the horizontal axis and Failure Probability is on the vertical axis.
• **Criticality Ranks** presents the items and failure modes, ranked by item criticality and then by mode criticality.

• **RCM** (available only for RCM++ and RBI)
  - **Functional Failure Analysis** presents the functions, functional failures, effects and causes (failure modes) that have been identified for all selected items.
  - **Failure Effect Categorization (One per Effect)** presents a separate report for each failure effect showing the FEC logic diagram decisions, along with any notes/remarks.
  - **Maintenance Task Selection (One per Cause)** presents a separate report for each maintenance task that has been defined for the selected items.

• **Tasks** is available only if the default Standard templates file is selected in the Templates Manager. It is a report template that was created by ReliaSoft and saved in the default Standard templates file, XRUT.xrt11, which is located by default in your My Documents folder (e.g., C:\Users\<your USERNAME>\My Documents\ReliaSoft\Common). It lists the tasks and related details that have been defined for the selected items.

  **Note:** This report includes properties from the higher-level records (i.e., the cause and item) that the task is associated with. This means that the same task may be repeated in the report if it is used multiple times. To generate a report that lists unique tasks only, you can create a query using the "FMEA Cause Tasks" group that only includes properties that belong to the task records. You can then use that query as a report.

• **Control Plan Spreadsheet**
  - **Control Plan Standard** presents control plan data, if any, in the traditional tabular format. Reports will be generated only for selected items that have an associated control plan analysis.

• **Control Plan Records.** There are no standard report forms for control plan records. This category may contain any relevant custom report templates and/or any custom queries that you have created.

• **DVP&R Spreadsheet**
  - **DVP&R Standard** presents design verification plan data, if any, in the traditional tabular format. Reports will be generated only for selected items that have an associated DVP&R analysis.
Chapter 20: Generated Reports

- **DVP&R Records**. There are no standard report forms for DVP&R records. This category may contain any relevant custom report templates and/or any custom queries that you have created.

- **DRBFM Spreadsheet**
  - **DRBFM Standard** presents design review based on failure mode analysis data, if any, in the traditional tabular format. Reports will be generated only for selected items that have an associated DRBFM analysis.

- **DRBFM Records**. There are no standard report forms for DRBFM records. This category may contain any relevant custom report templates and/or any custom queries that you have created.

**Sub-Item Data Combined or Separated**
When you select any FMEA Spreadsheet, PFD Standard, Control Plan Standard, DVP&R Standard or DRBFM Standard report form in the Reports window, the number of separate forms generated will depend on the system hierarchy items selected. Specifically, the utility will generate a separate spreadsheet for each item that is the top selected item in a branch of the hierarchy. The analysis for the selected sub-items will be included in the same spreadsheet as the top item in the branch. The header in each form will display the information that has been defined for the top level item for that spreadsheet.

For example, consider the item selections in the following picture:
Based on these selections, the utility will generate four separate report forms:

- The first form will have a header based on the properties defined for System A and will contain the analysis data for System A, followed by the analysis data for Subsystem A1, Subsystem A2, and then Subsystem A3. A grey row with the item’s name will separate each item’s analysis within the same spreadsheet.

- The second form will have a header based on the properties defined for System B and will contain the analysis data for System B, followed by the analysis data for Subsystem B1, and then Subsystem B3. The data for Subsystem B2 will not be included in the report because it was not selected in the Reports window.

- The third and fourth forms will have headers based on the properties defined for Subsystems C1 and C2, respectively, and will contain analysis data for each single item by itself. A report will not be generated for System C because it was not selected in the Reports window.

When the report is generated in Excel, each separate form will be placed in a separate worksheet and named based on the type of form (i.e., FMEA, control plan, DVP&R or DRBFM) and the top level item for that sheet. If the selected items have the same name, then the name of the second worksheet will have a 2 added to it to make it unique, the name of the third worksheet will have a 3 added to it, and so on.

**Report Customization/Settings Window**

The Report Customization/Settings window allows you to establish your preferences for configurable reporting options, such as the logo to be displayed in report documents, the font style and size, etc.

To open the utility, click **Manage > Settings** in the Reports window.

- **Report Font, Header Font** and **Footer Font** set the font and size for the text in the body, header and footer of the reports that you generate from your computer. Please note that there are specific limitations for some fonts and sizes, as discussed in **Font Size and Style Considerations** below.

- **Logo for Printed Reports** will display in the document header, if specified.
  - **No Report Logo** displays no logo on the printed report.
• **Default Logo** displays the default software graphic that was shipped with the application.

• **Paper Size for Reports** specifies whether the Word and Excel documents will be configured for U.S. Letter or A4-sized paper.

• **Action Details Report Options**
  
  • **Set orientation to portrait.** Select the check box to print the report in portrait orientation (top edge along the short side of the page). If not selected, the report will be printed in landscape orientation (top edge along the long side of the page).

  • **Include full FMEA record properties.** Clear the check box to include only the description for Function, Failure, Effect and Cause records in the report. Select the check box to include all other enabled properties for the associated Function, Failure, Effect and Cause records in the report. For example, if the analysis uses three levels of effects (according to the interface style), then all three fields will be included in the report.

• **Other**
  
  • **Display FMEA spreadsheet column headers on every page for Excel reports** repeats the rows up to and including the column headers on every page of FMEA spreadsheet reports generated in Excel.

  • **Repeat data in spreadsheet reports** ensures that each row in the FMEA Spreadsheet report will contain all FMEA information related to that row, even if some of the information is repeated from the row above and would otherwise have been "merged" within the table. For example, if there are two causes for the same failure, then the report will display the same function, failure and effect data in both rows. This option is useful if, for instance, you need to be able to sort the rows in the generated report or if you need to copy a single line of the report for external use.

  • **Merge cells in spreadsheet reports** merges the blank cells below a record in a column with that cell.

  • **Set generated report files as read-only** sets the generated Word and Excel documents to "Read-only" on the General page of the document Properties window.

  • **Show Priority Colors** highlights the FMEA records based on the priority categories specified in the interface style defined for the project.
• **Use name (not abbreviation) for time units** specifies how the units will be displayed in the report (e.g., 12650 Hour or 12650 Hr).

• **Use letters to identify failures and causes in RCM reports**: In RCM++ or RBI, RCM reports will use letters to identify failures and causes for the first 26 failures or causes, and then revert to numbers.

• **Footer for Printed Reports** sets the text displayed in the footer of all reports.

### Font Size and Style Considerations

Please note that the software allows you to select a font size as small as 6 pt even though Excel may be unable to properly render certain fonts at sizes that small. This limitation tends to apply to more ornate fonts (e.g., Lucida Calligraphy). If you encounter a situation where the report generated by the software does not display in the font that you have selected, it is recommended to increase the font size to 8 pt or higher and generate the report again.

### Xfmea/RCM++/RBI Templates Manager

In Xfmea/RCM++/RBI, the Templates Manager allows you to manage the configurable templates for customized reports, saved queries or importing/exporting data via Excel. If a standard database or Synthesis file (*.rsr11 or *.rsf11) is currently open, you will be managing the templates in the standard templates file (*.xrt11) that is currently active for your computer. If an enterprise database (SQL Server or Oracle) is currently open, you will be managing the templates stored within the enterprise database itself.

To open the utility, choose **File > Manage Repository > Templates Manager** (or use the command in the Reports window ribbon).

The utility has three tabs, one for **report templates**, one for **query templates** and another for **import/export templates**.

### Active File and Reset Templates

When a standard database or Synthesis file (*.rsr11 or *.rsf11) is currently open, the **Reset Templates** button will be displayed at the bottom of the window.

This button restores the default file that is shipped with the software (XRUT.xrt11) and makes it active for your computer/username. This will not replace whatever file currently exists. Rather, it will create a new standard templates file in the ReliaSoft folder under My Documents on your computer (e.g., C:\Users\<your USERNAME>\My Documents\ReliaSoft\Common). If a file with
the name XRUT.xrt11 already exists in this location, then the new filename will have an increment at the end (e.g., XRUT1.xrt11).

**Import Templates**

To import existing templates, select the tab for the type of template you want to import (Report, Query or Import/Export) and then click the **Import** button.

In the Import Templates window, select the Standard template (*.xrt11) or enterprise database (*.rserp) file that the templates will be imported from.

The table displays a list of the templates that have been defined in the selected file or database. Select the templates that you want to import, and then click **OK** to start the import.

**Xfmea/RCM++/RBI Report Templates**

If you have reporting needs that are not met by the standard report forms included with Xfmea/RCM++/RBI, you can create custom report templates. They will be shown in the list of available report forms in the **Reports window** and can be included in your generated reports.

To open the Report Template window, click the **Add** button or the **Edit** button on the Report Templates tab of the **Templates Manager**.

- The **Fields tab** allows you to choose and configure the fields to be shown in the body of the report.
- The **Column Header Customization tab** allows you to configure the column headers shown in the report.
- The Preview tab displays an approximate preview of the template incorporating the settings you have specified on the other two tabs.

**Note:** Report templates can be used to generate reports for projects that use any interface style. For this reason, all fields are available for use in the template, regardless of whether they are enabled in the current project’s interface style. When the report is generated, only those fields that are enabled in the current project’s interface style will appear in the report.

**Fields**

On the Fields tab of the Report Template window, the **Available Fields** area displays all of the properties available to use that are not yet selected.
The **Selected Fields** area displays the properties that have been selected for inclusion in the template, in the order in which they will appear. You can drag and drop the selected properties into the desired position or use the **Up/Down** icons.

You can double-click a property or use the **Include/Exclude** icons to move the property between the areas.

**Note:** Each query to the database can include a maximum of 225 fields. If your query exceeds this number, you will see a message that notifies you of the issue and asks you to reduce the number of fields and try again.

For the FMEA Spreadsheet, FMEA Spreadsheet with Items, Functional Failure (FFEC) and Functional Failure (FFEC) with Items report template types, the **Show Two Control Columns** option will appear above the **Selected Fields** area. Select the check box if you want prevention and detection controls displayed in separate columns. (See [Controls in FMEAs](#).)

### Column Header Customization

Each field that you have selected for inclusion in the report template on the Fields tab will appear in the table on the Column Header Customization tab.

There are four options for the column width:

- **Fit Header** will size to fit the text in the column header (i.e., the column name).
- **Fit Data** will size to fit the widest data text in the column (i.e., all of the rows below the column name).
- **Fit Header/Data** will size to fit the widest text in the column, regardless of whether it is the column name or the data.
- **User Defined** allows you to specify the exact column width (number of characters).

By default, the column headings will use the names shown in the **Property Name** column. You can overwrite that by entering text in the **Overwrite Default Header Text** column.

Once you have configured all options to suit your needs, you can go to the Preview tab to see what the report template looks like. You can also click **OK** to save the report template.

### Repeat Column Headers in Word

If you generate a report in Microsoft Word, you may have cases where a report table splits across multiple pages. By default, Word does not repeat the header rows at the top of every page. However, you can force Word to do so by using the following instructions.
Chapter 20: Generated Reports

The following instructions are for Word 2010; if you are using another version of Word, the options may vary.

- Generate the report in Word.
- On the first page of the table, select the column headings and then choose **Layout > Data > Repeat Header Rows**.

If you experience problems with the bottom border not displaying properly for a row that spans across two pages, then you can do the following:

- Generate the report in Word.
- Select the first data row in the table then choose **Layout > Rows & Columns > Insert Above**. This row is going to be used to assure that there is always a bottom border for the heading rows, even if the data rows span across pages.
- Select this row and the rows above (i.e., the column headings) and choose **Layout > Data > Repeat Header Rows**.
- Select the row that you inserted and choose **Layout > Table > Properties**.
- On the Row tab, specify **0.001** and **Exactly** for the **Row Height**, then click **OK**.

Save/Publish Reports

You can save generated Xfmea/RCM++/RBI reports with the project in Word, Excel or PDF format. This enables all users to view/print the same report documents that are saved in the shared database.

If your organization chooses to implement a web-based *Synthesis Enterprise Portal (SEP)* for an enterprise database, these same report documents will also be published on the SEP website.

To create or view saved/published reports choose **Home > Reporting > Reports** or **System Hierarchy > Tools > Reporting > Reports**.

Saving and Publishing

To create a new saved/published report, first use the options in the **Reports window** to build the report.
Chapter 20: Generated Reports

Before you generate the report, select at least one of the output types in the Save/Publish group on ribbon. (PDF is available only if you have Microsoft Office 2007 or higher.)

When you click Generate Report, a document will be created in Word or Excel and the report will also be saved with the project in each of the specified formats.

Published Reports Manager
Click Published Reports Manager to see all of the report documents that have been saved with the project.

Any user can open a report document, or save a copy. In a secure database, only the project owner or a user with the applicable “manage all projects” permissions will be able to delete saved reports or edit the name and description.

Viewing the Reports in SEP
To view the saved report in the SEP website, click the FMEAs link in the project summary and then go to the Published Reports tab.
What's Changed? In Version 11, you cannot create files in MHTML format. You can view the reports created in MHTML in Version 10 using Internet Explorer or FireFox (with an add-on).
Chapter 21: Query Utility

The Query utility can be a powerful analysis tool that makes it easy to find and open specific sections of the analysis. It is also a flexible custom reporting tool that allows you to create and manage saved queries that meet your particular presentation requirements.

To access the Query utility, choose Home > Reporting > Queries.

Use the left panel to specify the data source (either selected items from the active project or selected projects from the entire database). Use the right panel to choose the type of query (items, FMEA causes, etc.) and specify the criteria/output preferences. Then click Run Query to view and use the results.

Specify the Data Source

Use the panel on the left side of the Query window to specify the data source for the query. This can be either selected item(s) from the active project, or selected project(s) from the entire database.

- **Active Project**: With this option, you can query any or all of the items in the project that is currently active.

- **Database**: With this option, you must specify a Profile and FMEA Structure. You can also use the same project filters that are available in many other locations throughout the
Synthesis desktop applications. You can then select to query any or all of the projects in the current database that use the specified FMEA structure (i.e., grouped effects and causes, causes before effects, etc.) and that match the specified project filter, if one is used. The criteria and results will use the property names from the selected profile.

Using the project filter might be particularly useful for an enterprise database that may be used to store analysis projects for the entire organization in a single centralized location. In such cases, the number of projects displayed in the project list could become overwhelming and these filters provide the ability to display only those projects that are of interest to you at any given time.

To remove the filter, select Show All from the drop-down list.

Specify the Query Criteria
After you have selected the data source in the left panel of the Query window, you can use the right panel to specify the query criteria and output preferences.

First use the drop-down list at the top of the panel to choose which type of record you wish to query (items, FMEA causes, etc.). This will update the Criteria tab to display the relevant properties for the selected record type. Then specify whether the query results will match the
conditions from **All rows** in which criteria are specified (i.e., AND) or from **Any row** in which a criterion is specified (i.e., OR).

Then use the table to enter the criteria and choose which columns will be displayed in the results.

As an example, the following picture shows a query for system hierarchy items where the item name contains "bulb" AND the supplier name contains either "Acme" OR "Sterling." The Name, Part Number and Supplier columns will be included in the results.

### Two Types of Actions Queries

New in Version 11, there are now two types of queries for actions:

- **FMEA Cause Actions** considers recommended actions that have been defined for a failure cause and that are visible in the FMEA.

- **FMEA Control Actions** considers actions that have been associated with control records (if any). These actions can be used to incorporate controls in the Test Plans feature, or to track specific responsibilities associated with implementing a control. (See [Associating Actions with Controls](#).)

### Causes With or Without Actions and Controls

Now in Version 11, the **FMEA Causes** query provides two additional query properties: **Has Actions** and **Has Controls**. This allows the query to consider whether the cause has actions and controls defined.
Chapter 21: Query Utility

For example, the following criteria will only return causes that don't have actions or controls.

<table>
<thead>
<tr>
<th>Has Actions</th>
<th></th>
<th>is</th>
<th>No</th>
</tr>
</thead>
<tbody>
<tr>
<td>Has Controls</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Customize the Column Headers**

After you have specified the query criteria in the Query window, you can use the Headers Customization tab to determine how the selected properties will be displayed in the query results.

Use the up and down arrows to set the desired column order.

There are four options for the column width:

- fit the label in the column heading
- fit the widest label in the column data
- fit the widest label in either the heading or data
- use a fixed width (as specified in the User-Defined Column Width (Characters) column)

By default, the column headings will use the names shown in the Property Name column. You can overwrite that by entering text in the Overwrite Default Heading Text column.

For example, the following picture shows a query where the Part Number column will be exactly 15 characters wide while the Item and Supplier columns will be as wide as the heading text. In addition, the heading of the supplier column will display as "Manufacturer."

![Query window with customized column headers]

**View and Use the Query Results**

Once you have configured the query criteria and the column headings to suit your needs, click Run Query to display the results on the Results tab.
Chapter 21: Query Utility

To go to a specific record, either double-click the record in the table or select the record and click the **Go To** icon.

The Query utility will remain open, but the focus will change to the Project window and the record will be selected in the **System panel** or in the **Analysis panel**.

You also can click the **Send to Excel** icon to save the results table to an Excel spreadsheet.

**Special Consideration for Action, Control and Task Query Results**

Actions, controls and tasks are resources that can be used multiple times within the same FMEA or across FMEAs. When you search for actions, controls or tasks, note that matching records may be repeated in the query results if applicable. Specifically:

- If you have considered only the action/control/task record properties, each matching record will be displayed only once in the results (even if it is used in multiple different locations).
- However, if you have considered properties from any of the parent records (e.g., causes, items, etc.), the results will include a separate row for each relevant instance.

For example, the following picture shows query results from a situation in which the exact same action is recommended in two locations within the same FMEA. The record is shown twice in the results because the query has been configured to include details about where the action is used (in this case, Failure Cause and Item Name).

**Query Templates**

Query templates allow you to save a great deal of time if you have particular queries that you run repeatedly. Saved query templates are also listed in the **Available Reports** area of the **Reports window** and can be included in generated reports.
Chapter 21: Query Utility

If a standard database (*.rsr11) is open when you save a query, it will be stored in the standard templates file (*.xrt11) that is active for your computer. If an enterprise database (SQL Server or Oracle) is open, then the query will be stored within the enterprise database itself.

**Using a Saved Template in the Query Utility**

To use a saved template in the Query window, click the Open Saved Query icon.

The Select Existing Query window will display all saved templates for the type of query that was selected in the Query window (items, FMEA causes, etc.). If you want to search for a different record type, use the drop-down list to update the table.

To select a template, double-click the row or select it and click **OK**.

The settings on the Criteria and Headers Customization tabs of the Query utility will change to reflect the settings used in the saved query.

- If you change the criteria in the Query utility after applying a template, your changes will not affect the saved template. (If you want to update an existing query, use the **Edit** command in the Templates Manager, or simply delete the old template and replace it with a new one.)

- If the saved template contains criteria for a property that is not enabled for the current data source, that part of the query will be ignored. For example, if the saved template searches for items where the **Name** contains “bulb” AND the **Supplier** contains "ACME," but the current data source has the Supplier field disabled, then the query will return items where the name contains "bulb."

**Saving New Templates from the Query Utility**

To create a template from within the Query utility, configure all of the desired options on the Criteria and Headers Customization tabs and then click the Save Query icon.

The saved template includes all of the settings specified on the Criteria and Headers Customization tabs. It can then be applied to any data source.

**Adding and Editing Templates via the Query Template Window**

You can also create or edit query templates from the Templates Manager. To open the manager, choose **File > Manage Repository > Templates Manager**.
Then click either the **Add** button or the **Edit** button on the Query Templates tab. The Query Template window works in the same way as the [Query utility](#), with the following exceptions:

- You cannot specify the data source, as the query template can be used with any data source and any interface style. For this reason, all properties are available for use in the Query Template window.
- On the panel on the left side of the window, you must specify a name and, if desired, a description for the query template.
- Instead of a Results tab, the Query Template window has a Preview tab that shows the columns you have selected to include in the results.
Chapter 22: Excel Templates for Import/Export

In Xfmea/RCM++/RBI, it is easy to import and export system hierarchy and analysis data via an Excel spreadsheet. This includes:

- System Hierarchy Items
- FMEA Spreadsheet
- FMEA Spreadsheet with Items

There are some considerations for validating system hierarchy items. See Validating Data.

- Control Plan Spreadsheet
- DVP&R Spreadsheet
- DRBFM Spreadsheet
- PFD Spreadsheet
- P-Diagram

Import from Excel

1. Right-click the tab in the Analysis panel or choose System Hierarchy > Add Items > Import > Import from Excel.

2. Select the Import Type and Import/Export Template. (See Creating and Managing Import/Export Templates.)

3. Browse for the Excel Spreadsheet file (*.xls or *.xlsx) that contains the data. If applicable, use the Worksheet drop-down list to select which sheet to import from.

4. Enter the Starting Row that contains the first row of data you want to import.

5. Select additional options at the bottom of the window, if applicable.
   - System hierarchy items
     - Update items based on 'Item ID' updates existing records of the system hierarchy items if the "Item ID" matches. If the ID does not match an existing record, then it is added as a new item.
Chapter 22: Excel Templates for Import/Export

- **Import below current item** imports under the branch that is currently selected in the system hierarchy (instead of starting at the system level).

- **Worksheet (FMEA, control plan, etc.)**
  - **Replace** clears all the current data and replaces it with new records.
  - **Append** adds new records to the end of the current analysis.
  - **Update based on 'Record ID'** is available only for FMEA Spreadsheets and the template must include the function, failure, effect and cause ID fields. If the IDs match, the software updates the existing record. If the IDs do not match, then it appends a new record at the end of the branch.

6. Click **Next** to preview the data that will be imported. If the last column does not contain the expected values, the template may not fit your data. Click **Back** to change the selections or **Finish** to import the data.

### Export to Excel

1. Right-click the tab in the Analysis panel or choose **System Hierarchy > Tools > Reporting > Export to Excel**.

2. Select the **Export Type** and **Export Template**. (See Creating and Managing Import/Export Templates.)

3. Select additional options at the bottom of the window, if applicable.
   - **System hierarchy items**
     - **Item and dependents** exports the selected item and all dependent items.
     - **Entire system hierarchy** exports the entire system hierarchy.
   - **FMEA data**
     - **Include linked analyses** includes linked FMEA records, if any, along with the local FMEA records.

     Records that come from linked FMEAs cannot be re-imported as a linked analysis; they will become local records when imported.

4. Click **OK**. In the Save As window, provide a name for the export file, then click **Save**.
Creating and Managing Import/Export Templates

Saved import/export templates can be managed from within the Templates Manager. To open the Templates Manager, choose File > Manage Repository > Xfmea/RCM++/RBI Libraries > Templates Manager.

If a standard database or Synthesis file (*.rsr11 or *.rsf11) is currently open, you will be managing the templates stored in a local template library (*.xrt11) that is active for your computer, and you will be able to browse for another template library, if desired. If an enterprise database (SQL Server or Oracle) is currently open, you will be managing the templates stored within the enterprise database itself.

The Import/Export Templates page of the Templates Manager shows a list of the Excel templates that have already been created. You can also view or create these templates when you choose System Hierarchy > Import > Import from Excel or System Hierarchy > Reporting > Export to Excel. Select the import type and then use the select, add and edit icons in the template field.

Import/Export Template Window

When you create or edit an Excel template, the Import/Export Template window will be configured for a specific type of data (items, FMEA spreadsheets, control plans, etc.).

The Available Fields area displays all of the available properties (for the selected import type) that are not yet included in the template.

The Selected Fields area displays the properties that have been selected for inclusion in the template, in the order in which they will appear. You can drag and drop the selected properties into the desired position or use the Up/Down icons.

You can also double-click a property or use the Include/Exclude icons to move the property between the areas.

Note the following:

- For the "FMEA Spreadsheet" and the "FMEA Spreadsheet with Items" import types, select the Show Two Control Columns option if you want to include separate columns
for Prevention and Detection controls. Clear the check box to place all control
descriptions in one column and place the control type in another column. (See Controls
in FMEAs.)

- For the "FMEA Spreadsheet with Items" import type, if the selected item includes both a
  local FMEA and one or more linked FMEAs, only the header data for the local FMEA will
  be exported. If you later re-import the data, all of the functions will be imported to the
  local FMEA.

Validating Data for Import

When importing data from Excel, for most of the columns in the spreadsheet, the only
validation is to make sure that the data meet the software database requirements for the
fields. For example, if the text is too long to fit the field, it will be truncated. If it is the wrong
format (e.g., there is text where a number is required), it will be ignored.

When importing items into the system hierarchy, the following additional validation
requirements apply:

- The Level column identifies the position of the item in the system hierarchy. 1 indicates
  a top level (system) item. 2 indicates a sub-item below the nearest Level 1 item above, 3
  indicates a sub-item below the nearest Level 2 item above, and so on.

An example of how the rows in the import spreadsheet translate to the system
configurations in the software is shown next.

<table>
<thead>
<tr>
<th>Level</th>
<th>Item #</th>
<th>Item Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>System A</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>Sub-system A.1</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>Component A.1.1</td>
</tr>
<tr>
<td>3</td>
<td>2</td>
<td>Component A.1.2</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>Sub-system A.2</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>Component A.2.1</td>
</tr>
<tr>
<td>3</td>
<td>2</td>
<td>Component A.2.2</td>
</tr>
</tbody>
</table>
If the Level column is not present, then all items are imported as systems. The position of the row in the import spreadsheet determines the position of the item in the software system hierarchy. In order to identify the appropriate "parent" item in the hierarchy, you must enter all items for a given branch of the hierarchy before moving on to the next branch. For example, if the system consists of two subsystems and each subsystem has three components, list the system first (Level 1), then the first subsystem (Level 2), then the three components of the first subsystem (Level 3), then the second subsystem (Level 2), then the three components of the second subsystem (Level 3).

The row will be considered invalid if the "Level" column does not contain a whole number or contains a number that is greater than one more than the previous level number (e.g., Level 5 can be entered below Level 4 but cannot be entered below Level 3). For example, the level numbers 1, 2, 4, 6 are not. The reason is that a lower number indicates another item on a previous level (which can always be added) but a higher number indicates an item on the next level and you cannot skip a level. Some examples of valid and invalid "Level" entries are presented below.

<table>
<thead>
<tr>
<th></th>
<th></th>
<th>System B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2</td>
<td>Component B.1</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>Component B.2</td>
</tr>
</tbody>
</table>

### System Hierarchy

```
System A
  - Sub-system 1
    - Component A.1.1
    - Component A.1.2
  - Sub-system A.2
    - Component A.2.1
    - Component A.2.2

System B
  - Component B.1
  - Component B.2
```
If a validation issue is detected in the middle of the import, then the remaining records in that branch will be imported as systems. You can then use the Promote/Demote, Drag and Drop and/or Cut/Paste functionality in the System panel to correct the configuration.
Chapter 23: Change Logs

The change log utility is available for FMEAs, DVP&Rs, control plans and P-Diagrams. It controls when users will be able to edit the analysis, and also records a history of the revisions since the change log was activated.

The Change Log window shows the changes for the entire analysis while the Record Change Log window shows the changes for a particular record. Depending on the settings, the log can record:

- The date and time of the change.
- The user who made the change.
- The type of change (e.g., Add, Edit, Delete).
- The record that was changed and the specific property.
- The value before the change and the value after.
- The reason (or justification) that the user provided at the time of the change.

If desired, the change log utility can also be used to facilitate electronic approval tracking by storing an electronic record of the users who have reviewed and approved each version of an analysis.

General Information About Change Logs

Change log icons: When a change log has been activated for an analysis, the icon on the tab in the Analysis panel (and in the FMEA, DVP&R, Control Plan or P-Diagram column in the System panel, if displayed) will indicate that the change log is in one of two states:

- **No Revision Started**: The analysis is locked and no revision has started. The analysis is read-only for all users.
- **Revision Started**: The analysis is open for modifications because an authorized user has started a revision.
Chapter 23: Change Logs

Only the most recent version of the analysis can be edited, reported or queried against: The software does not automatically maintain a complete copy of the analysis as it was at a given time prior to subsequent modification. However, there are several ways to manually store a complete copy of the analysis if you need it. For example, you can:

- Use the Restore Points feature to store a complete backup of the project at a given time.
- Create a duplicate of the project each time a version has been completed.
- Generate a report for each completed version and either attach it to the item or save it with the project.
- Copy and paste the item within the project or to another project.

Change Log Window (for Entire Analysis)
To create and activate a change log for an FMEA, DVP&R, control plan or P-Diagram, choose [FMEA/DVP&R/Control Plan/P-Diagram] > Change Log > Activate Change Log. (In a secure database, this is available only to the project owner and users with the applicable "manage all projects" permissions.)

Once a change log is active, any project user can open the window by choosing [FMEA/DVP&R/Control Plan/P-Diagram] > Change Log > View Change Log.

Change Log Activation
The Change Log Activation area shows the date and time that the change log was activated, along with the name of the user who activated it.

- Select the Require reason for change check box if you want to require all users to justify each change made in a revision.
- Click Deactivate Change Log to deactivate the change log. This will clear both the change log and version history of the analysis, and it cannot be undone.
Version History
The Version History area allows you to start and end revisions, and also manage electronic approval tracking, if applicable. The table displays the following:

- # is the automatically generated number that uniquely identifies the version.
- Version and Comments are defined in the Version Details window.
- Initiated By is the user who activated the change log (for the original version listed in the first row) or started a revision (for each subsequent row).
- Start Date/Time and End Date/Time display the automatically recorded dates/times when the version started and ended.

If the electronic approval tracking option is being used, the table will also display information about the approver(s) who electronically "signed off" on each version.

Change Log
The Change Log table displays all modifications that were made to the analysis after the change log was activated.

- Revision displays the number of the revision in which the modification was made.
- Date/Time and User display the date and time when the modification was made, and the user who made the change.
- Change Type:
  - Add indicates that the record was added, inserted, pasted or imported.
    - If you pasted records, all items are listed.
    - If you imported existing records from the current project, the current database or another database, all items are listed.
    - If you imported data from an Excel spreadsheet, the change log lists the addition of the functions only.
  - Edit indicates that the record’s details were changed.
  - Delete indicates that the record was deleted from the analysis. Related records, if any, will also have been deleted. However, the change log lists only the deletion of the top record.
- Record Type displays the type of record (e.g., functions, failures, etc.).
- Record Description and ID display the description and unique ID of the record.
Chapter 23: Change Logs

- **Property** displays the data field that was changed, if applicable.

  **Note:** Because you can change multiple properties at the same time, each change to a property is listed separately. However, if the **Require reason for change** check box was selected when the changes were made, the same "Reason for Change" text displays for each property.

- **Value Before** and **Value After** display the values of the property before and after the change, if applicable.

- **Reason for Change** displays the justification that the user supplied when making the change. This is recorded only if the **Require reason for change** check box was selected at the time the change was made. It is displayed only if the **Require reason for change** check box is currently selected.

You can use filters at the bottom of the window to limit the list of changes displayed in the table. Click **Remove Filters** to show all records.

Click the **Export Version History** or **Export Change Log** buttons to send the data to an Excel spreadsheet.

**Starting and Ending Revisions**

When a change log is first activated, the FMEA, DVP&R, control plan or P-Diagram is automatically locked so that no changes can be made until a revision has been started. The analysis is also locked between revisions. While the analysis is locked, it is read-only for all users.

(In a secure database, the ability to start and end revisions is available only to the project owner and users with the applicable "manage all projects" permissions.)

**To start a revision:**

1. Open the **Change Log window** for the analysis.
2. Click the **Start Revision** button and specify the Version Label and comments in the **Version Details window**.

After the revision is started, all the changes made to the analysis are logged until an authorized user chooses to end the revision.

**To end a revision:**

1. Open the Change Log window for the analysis.
2. Click the **End Revision** button.
To reopen the most recent revision:

1. Open the Change Log window for the analysis.

2. Select the most recent revision in the Version History table and click the Edit Details button.

3. In the Version Details window, click the Re-Open Revision button.

Version Details Window

- **Major/Minor** allows you to specify whether the revision will be numbered as a major revision (e.g., from 1.0 to 2.0) or as a minor revision (e.g., from 1.0 to 1.1).

- **Version Label** and **Comments** are displayed in the Version History table and can be edited at a later time if necessary.

- **Assign Approvers** allows you to assign users who are required to approve the analysis before the next revision can be started. You can assign approvers to only the most recent revision.

- **Re-Open Revision** is available only for the most recent revision. It clears the end date and any existing approvals, and allows users to continue editing that version.

Record Change Log Window (for Specific Records)

To view the portion of the change log that pertains to a particular record, click the Change Log icon at the top of the record's properties window.

The Record Change Log window displays the same information that is recorded in the *Change Log window*, but shows only the modifications made to the specific record.

You can use filters at the bottom of the window to limit the list of changes displayed in the table. Click the Send to Excel button to export all of the data currently displayed in the tab to an Excel spreadsheet.

Reason for Change Window

If a *change log* is active for an *FMEA, DVP&R, control plan* or *P-Diagram* and the *Require reason for change* check box has been selected, then every time a user adds, modifies or deletes a
record in the analysis the Reason for Change window will open automatically before saving the change to the record.

Note the following.

- If you are changing more than one action or control at the same time in the Resource Manager window, then the reason for change will automatically be recorded as either "Editing Multiple Controls" or "Editing Multiple Actions." This will display only once, regardless of how many times the action or control is used in the analysis.

- If you are making changes to a mirrored cause, then the reason for change will display only once, regardless of how many times the cause is used in the analysis.

- If you are changing the analysis in the FMRA view in BlockSim, then the system will automatically record the change as being "Changed in BlockSim."

Electronic Approval Tracking
If a change log is active for an FMEA, DVP&R, control plan or P-Diagram, you have the option to store an electronic record of the user(s) who have reviewed and approved each version of the analysis.

- Use the Assign Approvers window while the version is in progress to assign the user(s) who must review and approve the analysis after it is completed.

- Use the Approve Version window to record your approval for a single analysis.

- Use the Approve Multiple Change Logs window if you need to approve multiple analyses at the same time.

Assign Approvers Window
In a secure database, the ability to assign approvers is available only to the project owner and users with the appropriate "manage all projects" permissions.

1. While the version is in progress, open the change log for the analysis.

2. Select the version in the table and click Edit Details.

3. In the Version Details window, click Assign Approvers.

4. In the Assign Approvers window, select the check box for each user who must review and approve this version of the analysis. In a secure database, this list shows all users with access to the project that have the "Approve change logs in Xfmea/RCM++/RBI" permission. If you want to shorten the list by hiding the users who are not assigned to review this version, select the Show only assigned users check box.
5. If desired, you can also specify the **Approver Role** to each user (e.g., Management, Engineering, etc.).

   ![User Approver Role Table]

6. Click **OK** to save the changes.

**Approve Version Window**

To record your approval for a single analysis:

1. Open the change log, then select the version in the table.
2. Click the **Approve Version** button, then enter any comments about your review, and click **OK**.
3. When prompted, reenter your username and password before the application saves the approval and records the approval comments in the change log.

**Approve Multiple Change Logs**

You can also approve the change logs for multiple analyses in the same project at the same time. To use this feature:

2. Select the change logs to approve, then click **OK**.
3. Enter any comments about your review, then click **OK**.
4. When prompted, reenter your username and password before the application saves the approval and records the approval comments in the change log for each analysis.
Workflow Overview for Using a Change Log

There are two general approaches to activating a change log and managing revisions, depending on whether or not you are using the electronic approval tracking feature.

Without Electronic Approval Tracking

1. Activate Change Log
2. Analysis at this point is:
   - Locked until Revision started
   - Recorded in Version History as "original" version
3. Start Revision
4. Software records any changes made to the analysis while the Revision is open. (If Request Reason for Change is selected, software also records user input for justification of change.)
5. End Revision
6. Analysis at this point is:
   - Locked until next Revision started.
   - Recorded in Version History as a revised version, identified by name and number.
7. Repeat process to add Revisions as necessary
With Electronic Approval Tracking
Chapter 23: Change Logs

Activate Change Log

Assign Approvers for "original" version

Software sends e-mail notification to Approvers.

First Revision cannot begin until all Approvers "sign off" on "original" version. (Change Log can be de-activated if changes to "original" version are necessary.)

Analysis at this point is:
Locked until Revision started
Recorded in Version History as "original" version

Approvers log in and approve "original" version

Start Revision

Assign Approvers for Revision

Software records any changes made to the analysis while the Revision is open. (If Request Reason for Change is selected, software also records user input for justification of change.)

End Revision

Software sends e-mail notification to Approvers.

Analysis is locked and next Revision cannot start until all Approvers "sign off" on this version. (Revision can be re-opened if changes are necessary.)

Analysis at this point is:
Locked until next Revision started
Recorded in Version History as a revised version, identified by name and number.

Repeat process to add Revisions with Assigned Approvers as necessary

Approvers log in and approve Revision
Chapter 24: Xfmea, RCM++ and RBI Settings

The Application Setup contains personal preferences that are stored per computer/username. These include default settings for new analyses/plots that you create from this computer, as well as personal preferences that don’t affect shared analysis data stored in the database.

In addition, note that the region and language settings will determine how dates, times, decimals, currency, etc. are displayed on your computer.

To open the Application Setup window, choose File > Application Setup.

The settings on the pages listed under Synthesis Settings are the same for all Synthesis desktop applications; the pages listed under the application name contain settings that apply only to the current applications.

Synthesis Settings

Synthesis Settings
The Synthesis Settings page of the Application Setup can be changed from within any Synthesis desktop application.

- **Interface** sets the language and the skin (color scheme) for the software interface. Selecting a skin shows you a preview of the changes in the Application Setup window. The change takes effect in the rest of the interface the next time you launch each application.

  Note that a language change will not affect applications that are currently available only in English. For a list of supported languages, see [http://www.reliasoft.com/languages/index.htm](http://www.reliasoft.com/languages/index.htm).

- **Open With** sets the Synthesis application to launch by default when you double-click an *.rsr11, *.rsf11 or *.rserp file from this computer. If you want to be prompted to choose an application each time, select Show the Synthesis Launcher.

- **Recent Repositories List** sets the maximum number of recently saved database files to be displayed in the "Recent Repositories" list in the Backstage view.
• **Auto Save** specifies when folios and diagrams will be saved automatically. The application always saves folios/diagrams upon calculate or close. If you want to also save periodically while you’re editing, specify an interval. This can be useful if you’re working across a network in an enterprise database. (This setting does not apply to Synthesis files.)

• **Other**

  • **Allow multiple projects (project explorer)** applies to Synthesis desktop applications that use the current project explorer (i.e., Weibull++, ALTA, BlockSim, RENO, RGA, and Lambda Predict). Select the check box if you want to have multiple projects open at the same time. There is a separate setting for project windows in Xfmea/RCM++/RBI. (See Working with Multiple Projects.)

  • **Show project name in opened folios** applies to Synthesis desktop applications that use the current project explorer (i.e., Weibull++, ALTA, BlockSim, RENO, RGA, and Lambda Predict). It shows the project name in [brackets] on the tab or window caption. This may be useful when you have multiple projects open at the same time.

  • **Use web-based help**. Select the check box to always make F1 and other help commands open the most up-to-date help file from the Internet when possible. If you clear this check box, they open the local help file that was installed with the software.

  • **Display ReliaSoft Online pane** shows the ReliaSoft Online pane in the Backstage view. If you do not have Internet connection or you simply want to reclaim the space allocated to these features, you can clear the check box to hide these panels.

  • **Highlight 'Active' category in ribbon** applies a highlight color to the label that shows which tabs are currently active.

  • **Use non-modal Resource Manager** locks the Resource Manager in a top window position so it can remain open while you have access to the project. If not selected, you must close the Resource Manager to return to the project.

  • **Warn when changing metric associations** shows a warning when you select an existing metric in a situation that will change the metric’s associated model. (See Showing Metrics in Folios/Diagrams.)

  • **Hide unused project folders** applies to Synthesis desktop applications that use the current project explorer (i.e., Weibull++, ALTA, BlockSim, RENO, RGA, and Lambda Predict). It hides from view all folders that do not contain any project items.
• **Highlight colors** sets the colors used to color-code values in the following analyses:
  - Results in the FMRA in **BlockSim** and **Xfmea/RCM++/RBI**
  - Certain BlockSim plots
  - BlockSim **FRED reports**
  - BlockSim **allocation analysis**
  - **Spread of failure rate contributions** in a prediction folio in Lambda Predict.

**Backup/Check Out Options**
The Backup/Check Out Options page of the Application Setup can be changed from within any Synthesis desktop application.

• **Standard Repository Maintenance** applies to standard database files (*.rsr11) only. It allows you to automatically save a backup of a database in the location you specify when you close the application. The backup file will be named after the database file with the backup date appended (e.g., RSRepository1_2016-01-15.rsr11).

  You can specify how many days of backups can be automatically saved (up to 10), but note that only one backup will be saved per day (e.g., if you open and close the same database three times in one day, only the final closing of the database will be saved in the backup folder).

  Note that you can also create backups manually at any time by choosing **File > Save As**. For more tips on keeping databases running smoothly, see **Backups and Database Maintenance: Protecting Your Data**.

• **Check In/Out** specifies the default save location for projects that you **check out** from a database.

**Other Synthesis Settings**
The Synthesis Settings > Other page of the Application Setup can be changed from within any Synthesis desktop application.

• **Model, Variable and Workbook Names** disallows spaces and special characters in the names of models (including those published from any Synthesis desktop application) and variables, and in the names of workbooks created in BlockSim/RENO. This will ensure that all models, variables and workbooks can be used in RENO equations.
Application-Specific Settings

General Settings
The Settings page of Xfmea/RCM++/RBI's Application Setup contains the following settings:

- **General**
  - Maximum number of results returned by queries sets the maximum number of results to display when you are using the Query utility.
  - Allow multiple open projects (project windows) allows you to open multiple projects simultaneously in Xfmea/RCM++/RBI. (There is a separate setting for applications that use a current project explorer. See Synthesis Settings.)
  - Hide reliability nodes on item properties hides the Operation, Reliability Policy, Reliability/Availability and Push to Metrics nodes on the Properties tab when
Chapter 24: Xfmea, RCM++ and RBI Settings

you're working in the system hierarchy. These nodes will still be displayed when you're working in the **FMRA**.

- **Enable MIL-1629A Criticality** displays the following command on the Home tab of the ribbon. This allows you to perform [criticality analysis](#) in a separate utility, rather than directly in the FMRA.

- **Use 'display name' from interface style for FMEA commands/windows** uses the display name from the interface style (which is configurable for each project), rather than the property name (which is the same for all projects) for the FMEA commands and properties windows.

- **Exponential Parameter** specifies whether to show lambda (failure rate) or mean time (1/failure rate) for the exponential distribution parameter.

- **Numeric Display** sets the math precision (number of decimal places) and the point at which the software will switch to scientific notation. For example, if the scientific notation tolerance is set to 5, then any number that is larger than 10^5 will be displayed using scientific notation.

- **Create a default function for new items** automatically adds an FMEA and creates the first function for each new item that you add to a system hierarchy.

- **Repeat data in worksheet views** populates the gray areas in analysis worksheet views with the relevant text from a prior row. For example, if there are 3 failures for the same function, the worksheet will show the function description in all 3 rows.

**System Hierarchy Settings**
The System Hierarchy page of Xfmea/RCM++/RBI's Application Setup contains your personal preferences for the columns displayed in the system hierarchy. Refer to the [System Hierarchy](#) topic for descriptions of the available columns.

The table contains the same options that are also available when you right-click inside any column heading in the system hierarchy and choose **Customize Columns**.

- To choose which columns to display, use the check boxes.

- To change the column order, use the arrow buttons to move the selected field up or down in the list. You can also drag/drop a field into the desired position.
Chapter 24: Xfmea, RCM++ and RBI Settings

- To restore the default settings for all hierarchies in the current application, you can click the Reset Application Form Settings or Reset All Settings buttons on the Reset Settings page of the Application Setup.

**Tip:** If you want to restore only the settings for one particular hierarchy without resetting any other application form settings, you can delete the specific file from C:\Users\USERNAME\AppData\Roaming\ReliaSoft\APPLICATION\TreeLists_Settings_V11, where APPLICATION is either Xfmea11, RCM11 or RBI11. For example, to reset only the system hierarchy, delete the file called frmFMEA_treeSystem.

- **Expand hierarchy to this level by default** sets the default level shown in the System panel.
- **Include change log version in analysis columns** displays the current revision version in the analysis column for those analyses that have an active change log.

**FMRA Settings**

The FMRA page of Xfmea/RCM++/RBI's Application Setup contains your personal preferences for the columns displayed in the FMRA hierarchy. Refer to the FMRA Hierarchy topic for descriptions of the available columns.

The table contains the same options that are also available when you right-click inside any column heading in the FMRA and choose Customize Columns.

- To choose which columns to display, use the check boxes.
- To change the column order, use the arrow buttons to move the selected field up or down in the list. You can also drag/drop a field into the desired position.
- To restore the default settings for all hierarchies in the current application, you can click the Reset Application Form Settings or Reset All Settings buttons on the Reset Settings page of the Application Setup.

**FMEA Hierarchy Settings**

The FMEA Hierarchy page of Xfmea/RCM++/RBI's Application Setup contains your personal preferences for the FMEA tab of the Analysis panel.

**Show Columns**

Use this area to select which columns will display in the FMEA hierarchy. Refer to the FMEA Hierarchy topic for descriptions of the available columns.
The table contains the same options that are also available when you right-click inside any column heading in the FMEA hierarchy and choose **Customize Columns**.

- To choose which columns to display, use the check boxes.
- To change the column order, use the arrow buttons to move the selected field up or down in the list. You can also drag/drop a field into the desired position.
- To restore the default settings for all hierarchies in the current application, you can click the **Reset Application Form Settings** or **Reset All Settings** buttons on the **Reset Settings** page of the Application Setup.

**Other Options**

- **Obtain XFRACAS failures observed occurrences from** is applicable only if you are working in a database that has associated XFRACAS tables and you are using the Observed Occurrences column in the FMEA hierarchy. (See **Import or Sync from XFRACAS**.)
- **Expand hierarchy to this level by default** sets the default level shown in the FMEA hierarchy.
- **Default View** sets either the hierarchy or the worksheet as the default view for editing an FMEA.
- **Hide reliability policy node** hides the Reliability Policy node in the FMEA hierarchy. The policy can still be viewed/edited from the **FMRA**.

**Reset Settings**

The Reset Settings page of the Application Setup allows you to restore some or all of the settings to their original configuration. Note that it’s recommended to close all windows before resetting settings. If the change does not take effect immediately, restart the application.

- **Reset Common Synthesis Settings** resets the settings under the **Synthesis Settings** heading in the Application Setup.
- **Reset Application Settings** resets the settings under the current application’s heading in the Application Setup. It also clears any saved default column headings in life data (Weibull++), life-stress data (ALTA) and growth data (RGA) folios.
- **Reset Application Form Settings** resets the form settings for the current application (e.g., size and location of windows).
- **Reset Plot Settings** resets the **Plot Setup** settings that are applied by default when you create a new plot in the current application.
• **Reset FIDES Settings** (Lambda Predict only) resets the predefined FIDES settings (e.g., saved pi factors, process audits, etc.) that are applied by default when you create a new repository. (See [FIDES Settings Manager](http://xfmea.reliasoft.com) in the Lambda Predict documentation.)

• **Reset Component Defaults** (Lambda Predict only) resets the component property values that are applied by default when you add a new component to a prediction. (See [Default Component Properties](http://xfmea.reliasoft.com) in the Lambda Predict documentation.)

• **Reset All Settings** resets all the saved settings for the current application. This is the same as clicking all of the individual "Reset" buttons above.

---

**Project Item Settings**

Synthesis desktop applications offer a variety of configurable settings that are stored per computer/username and managed via the [Application Setup](http://xfmea.reliasoft.com).

Your personalized application setup determines the default settings for new folios, diagrams and flowcharts that you create in Weibull++, ALTA, BlockSim, RENO and RGA. The relevant settings are also saved with each individual folio/diagram and are accessible from the Item Properties window. This makes it possible to have different settings for different analyses, and also ensures that any given analysis will be the same for all database users.

To view and edit the configurable settings in the Item Properties window, select the folio, diagram or flowchart in the current project explorer and choose **Project > Current Item > Item Properties**.

The settings are displayed on the second tab of the properties window. (In a secure database, the settings can be edited only if the user is the project owner or has the "Create/edit project items" permission.)

If you modify the settings for a particular project item, the new preferences will be saved with the folio/diagram. The default preferences for new folios/diagrams in the application setup will remain unchanged.

---

**Region and Language Settings**

The Region and Language settings for your particular computer will have some impact on the way some information is displayed in Synthesis applications.

Users with different regional and language settings can work together on the same analysis projects because, in most cases, the basic information is stored in the database and the
software simply displays it in the format preferred by each user. For example, if the date September 25, 2015 is stored in the database, User A might see it as "9/25/2015" while User B might see "25-Sep-15."

This topic first explains how to view or change the Region and Language settings on your computer and then discusses some specific considerations for Synthesis applications, including:

- Which language is selected by default when you install the software
- How dates and times will be entered and displayed
- How decimal values and currency will be entered and displayed
- Which measurement system is the default for the Page Setup window

**Viewing or Changing the Region and Language Settings for Your Computer**

To view or change the region and language settings:

- In Windows 8 or Windows 10, move the pointer to the lower left corner of the desktop, then right-click and choose **Control Panel**. Click the **Clock, Language, and Region** option then click the **Region** link.

- In Windows 7, choose **Start > Control Panel** and then click the **Region and Language** link.

As an example, the Windows 7 interface is shown here. The Windows 8 and Windows 10 versions look different but function similarly.
Other relevant settings are managed via the Customize Format window:

- In Windows 8 or Windows 10, click the **Additional settings** button.
- In Windows 7, click the **Additional settings** button.

As an example, the Windows 7 interface is shown next.
Note: To see the changed settings in the Synthesis application, you must close the application, and then restart it.

Which Language is Selected by Default When You Install the Software

The user interface for Synthesis desktop applications is available in several languages. You can change this language at any time by choosing an option from the Language drop-down list on the Synthesis Settings page of the Application Setup.
When you first install the software, it will check your computer's current language as it is set in the **Format** field in the Windows Region and Language window. If that language is supported in Synthesis, Synthesis will use those settings; however, if that language is not supported, Synthesis will use the default setting of English.

**Defining Date and Time Formats**

Dates and times appear frequently throughout the Synthesis interface, including (but not limited to):

- The dates in the plot legend area of a plot in all Synthesis applications.
- The history provided throughout Synthesis applications (e.g., for resources, FMEA records, diagrams, in history logs, etc.).
- The dates in the worksheet view and in the record properties windows in Xfmea, RCM++, RBI and MPC.
- The dates in the "dates of failure" format and "usage" format of the Weibull++ warranty folios.

The **Short date** field from the Windows Region and Language window determines how dates are displayed. You can select any standard format (e.g., M/d/yyyy, dd/MMM/yy, yy/MM/dd) or you can create your own format using the available date notations.

The **Short time** field determines how times are displayed. You can select any standard format (e.g., h:mm tt, HH:mm, HH'h'mm) or you can create your own format using the available time notations.

The Windows settings do not apply to the following items:

- Dates and times in spreadsheet utilities (e.g., a spreadsheet module in Synthesis Workbooks, General Spreadsheets, etc.).
- Dates and times displayed in the Weibull++ event log folio are created by the folio and are not affected by the computer's settings.

**Changing the Decimal Symbol, the List Separator and the Currency Symbol**

How decimal values are displayed depends on the value of the **Decimal symbol** field on the Numbers page of the Windows Customized Format window, which determines which character is used to indicate the decimal portion of a number (e.g., 85.25 or 85,25). In addition, the character used to separate the arguments in a list depends on the value of the **List separator** field. These settings affect how you enter functions in a spreadsheet module in Synthesis Workbooks or in General Spreadsheets, either manually or by using the Function Wizard.
For example, if the decimal symbol value is a comma, and the list separator value is a semicolon, you would enter a function like this:

`=RELIABILITY("Weibull!Folio1!Data 1";500;100;0,9))`. Whereas, if the decimal symbol is a period and the list separator is a comma, it would be

`=RELIABILITY("Weibull!Folio1!Data 1",500,100,0.9))`.

The currency symbol that is displayed in the software depends on the selection in the **Currency symbol** field on the Currency page of the Windows Customized Format window.

### Setting the Measurement System in the Page Setup

On the Margins tab of any Synthesis desktop application's Page Setup window (**Home > Print > Page Setup**), the **Units** field determines which unit of measure (inches [U.S.] or centimeters [Metric]) is used for the page margins on print output. The field includes the **System's default** option. Selecting this option means that the measurement system used is determined by the value of the Windows Customize Format window's **Measurement system** field, and it will change if the computer's settings change.

---

**Tip:** If you want the page margins to always be the same, you can select a specific unit of measure and not use the **System's default** option.
Chapter 25: Synthesis Platform Tools

Categories, Identifiers and Filters

Defining Categories
In all Synthesis desktop applications, you can use flexible categories and identifiers to filter and group analysis data in a way that fits your specific needs. There are two types:

- **Project Categories** can be applied to projects in all desktop applications.
- **Item Categories** can be applied to project items (e.g., folios, diagrams, system hierarchy items) and resources (e.g., models, URDs) in all desktop applications except MPC.

This topic describes how to define the categories that will be available throughout the current database. To learn how to use them to filter and group data, see Project and Item Filters. (For additional options related to categories for system hierarchy items, see Item Categories in Xfmea/RCM++/RBI in the Xfmea/RCM++/RBI documentation.)

Accessing the Project/Item Categories Window
There are two ways to access the Project/Item Categories window and specify which categories will be available throughout the current database. (In a secure database, these are available only for users with the “Manage project/item categories” permission.)

To open the window from the backstage view, choose File > Manage Repository > Project/Item Categories.

Alternatively, you can click inside any Category drop-down list (e.g., in a properties window, filter, etc.) and click the Edit Categories icon.
Adding, Renaming and Deleting Categories

- To rename an existing category, double-click inside the cell and edit the text.
- To add a new category in the same level as the one that is currently selected, click Add.
- To add a new category in the level below the one that is currently selected, click Add Below.
- To move a selected category up or down within the same level, select the row and click Up or Down.
- To move a selected category to a different level, click Promote or Demote.
- To delete a category, select the row and press the Delete key or click the icon. To delete all categories at the same time, click Clear All. There is no undo for delete.
Synthesis Identifiers

In all Synthesis desktop applications, you can use flexible identifiers and categories to filter and group analysis data in a way that fits your specific needs. The Synthesis identifiers are available for project explorer items (e.g., folios, diagrams, plots, etc.) and there is one standard set of identifier fields for all relevant locations.

<table>
<thead>
<tr>
<th>Identifiers</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category</td>
</tr>
<tr>
<td>Part Number</td>
</tr>
<tr>
<td>Version</td>
</tr>
<tr>
<td>Supplier</td>
</tr>
<tr>
<td>Application</td>
</tr>
<tr>
<td>Description</td>
</tr>
<tr>
<td>Comments</td>
</tr>
<tr>
<td>Keywords</td>
</tr>
</tbody>
</table>

This topic describes how to view and edit identifiers for each type of resource or analysis, and how existing identifiers will be converted from Version 8 or 9. To learn how to use identifiers to filter and group data, see Project and Item Filters.

For Synthesis Resources

To view and edit the identifiers for most types of Synthesis resources, you can simply open the properties window and select the Identifiers node. They can also be edited via the Batch Properties Editor. Note that:

- For published models, the identifiers are obtained from the analysis (e.g., Weibull++ folio, BlockSim diagram, etc.). To make a change, you must first edit the identifiers for the analysis and then republish the model.

- Identifiers are not applicable for the following resource types: Variables, Maintenance Groups, Mirror Groups, Actions and Controls.

For Project Explorer Items

To view and edit the identifiers for folios, diagrams, plots and other analyses in Weibull++, ALTA, BlockSim, RENO or Lambda Predict, select the item in the current project explorer and choose Project > Current Item > Item Properties.
The identifiers are always displayed on the first tab of the properties window.

When applicable, the fields are also visible on the Identifiers page of the control panel. If a folio has multiple data sheets, you can use this page to define separate identifiers for each sheet. Note that the Folio Identifiers will be used in item filters and in the Synthesis Explorer; while the Data Sheet Identifiers will be used when publishing a model.

You can use an asterisk (*) in any or all of the data sheet fields to apply the same text from the corresponding folio field. As an example, the following picture shows the identifiers for a Weibull++ life data folio that contains multiple data sheets for each design prototype of a new chandelier bulb in development. Although most of the data sheet identifiers will be the same as the folio (indicated with *), the Version and Comments fields have been modified for each data sheet. The data sheet identifiers will be used when you publish a model.

For System Hierarchy Items
To view and edit the identifiers in Xfmea, RCM++ and RBI, select an item in the system hierarchy and go to the Properties tab in the Analysis panel. The same set of identifiers will be used for all analyses associated with that item (e.g., FMEA, control plan, etc.).
The fields are grouped together under the Identifiers heading. Name, Category and Keywords will always be displayed. The remaining identifiers may be hidden or renamed based on the configurable settings for the current project. (See Configurable Settings in the Xfmea/RCM++/RBI documentation.)

For Diagram Blocks
To view and edit identifiers for diagram blocks in BlockSim, open the block properties and select the Identifiers node. The fields are also visible on the Identifiers page of the control panel when the block is selected.

You can use these identifiers in BlockSim’s Find utility and in the Batch Properties Editor.
Conversion from Version 8/9
The following table shows how the "global identifiers" from previous versions will be mapped when you convert existing data in a Version 8/9 database (where “-” indicates no change).

Project and Item Filters
In many locations throughout all Synthesis desktop applications, you can use flexible filters to limit a list of projects, project items (e.g., folios, diagrams, system hierarchy items, etc.) or resources (e.g., models, URDs, etc.).

The drop-down list contains the filters you have saved in this database, plus any filters that another user has chosen to share with other database users.
Use the drop-down list to apply an existing filter. To stop filtering the list, select **Show All** (formerly called "Default filter").

**Sharing Filters with Other Users**

To share a saved filter, open the filter's properties window and select the **Show to all repository users** check box.

In a secure database, a shared filter can be edited or deleted only by a) the user who created the filter or b) a user with the "Manage other repository settings" permission.

**Project Filters**

Project filters can be applied to lists that contain project names such as the [Project Manager](#) and [Synthesis Explorer](#). Now in Version 11, the filter can either be a query based on specified criteria, or a selected list of projects.

- **Based on Criteria.** You can match **All Criteria** (AND query) or **Any Criteria** (OR query):
  - Owner ([project owner](#))
  - Category ([project category](#))
  - Analysis/Feature (whether the project contains analyses associated with the specified application or feature)
  - Last Updated By
  - Last Updated Date

- **Based on Selected Projects.** Click the **Add** button to select the projects you want to include, or the **Remove** button to remove a selected project from view.

Clear the **Show locked projects** check box if you want to exclude **locked projects** from the results, even if they meet the criteria.

Projects are always grouped based on whether they are **public, private or reference**. For additional grouping, select the **Group by category** and/or **Group by owner** check boxes. If you select both, the results will be grouped first by project category and then by project owner. For example:
Item Filters

Item filters can be applied to lists that contain project items and resources such as the Current Project Explorer and Resource Manager.

Select whether the item must match All Criteria (AND query) or Any Criteria (OR query):

- Category (item category)
- Created By
- Last Updated By
- Last Updated Date
- Synthesis identifiers (Name, Part Number, Version, Application, Supplier, Description, Comments and Keywords)

Synthesis Explorer

The Synthesis Explorer is available in all Synthesis desktop applications except MPC. You can use this flexible tool to explore all of the different analyses that are stored in the current database.

To access the utility, choose Home > Synthesis > Synthesis Explorer.

To reduce the amount of time required to populate the grid, first use the project and item filters (discussed below) to limit your search, then click Load Data.
The analyses shown in the explorer may include:

- Project items in Weibull++, ALTA, BlockSim, RENO, RGA and Lambda Predict (e.g., folios, diagrams, plots, Synthesis Workbooks, etc.).
- Analyses that are associated with system hierarchy items in Xfmea, RCM++ or RBI (e.g., FMEAs, control plans, risk based inspection analyses, etc.).
- Project Plans that can be created for any project.

You can filter/sort/group the analyses based on Synthesis application, analysis type, analysis creator and many other properties. You can also present the information in a wide variety of dashboard charts.

This topic summarizes the tools you can use to find and organize data in the Synthesis Explorer’s flexible grid. For information about presenting the data graphically, see Synthesis Explorer Dashboards. For a list of the properties that can be used in either the grid or the dashboard, see Synthesis Explorer Properties.

Save and Apply Views
Once you have customized the Synthesis Explorer’s grid to suit a particular purpose (using the built-in find/filter, column configuration and grouping features described below), you can save the preferences as a view that can be used again whenever you need it. A view is saved in the database and available only to the user who created it.

To create a view, first configure the grid to suit your particular needs and then click Save View.

To quickly apply these same preferences again at any time, click Apply View and select one of the saved views from the list.

*Note*: The view does not affect filtering that has been applied from the Project Filter, Item Filter or Category Panel.

Project and Item Filters
The Synthesis Explorer can utilize the same project and item filters that are available in many other locations throughout Synthesis desktop applications. For example, with the custom filters shown below, the Synthesis Explorer will show only analyses performed by Department A (project filter) that were modified within the last month (item filter).
To remove either filter, select **Show All** from the drop-down list. To remove both filters at the same time, select **Data > Clear Filters**.

After you clear or change these filters, you must click **Load Data** again to update the grid.

**Category Panel**

The category panel provides a quick way to filter the data based only on item category. For example, you might use the panel to first view the analyses for Category A and then quickly switch to see the analyses for Category B.

To show or hide the panel, click **Data > Show Category Panel**.

When there are many categories, the tools at the top of the panel can help you find and select the one(s) you need.

**Built-in Find/Filter, Configuration and Grouping Tools**

The Synthesis Explorer offers the same filter, column configuration and grouping tools that are built in to other Synthesis utilities that use a similar grid (e.g., the Resource Manager). For details about how to use each feature, see:

- [Finding and Filtering Records](#)
- [Configuring Columns](#)
- [Grouping Panel](#)
Synthesis Explorer Dashboards
You can use the flexible Synthesis Dashboard utility for presenting data from the Synthesis Explorer.

As with any other Synthesis dashboard, you can use the Dashboard Viewer to select any of the layouts that have been predefined for this type of data, and you can use the Dashboard Layout Manager to create or edit layouts.

(In a secure database, the Dashboard Layout Manager is available only for users with the “Manage dashboard layouts” permission.)

Values and Arguments
When you’re creating bar charts or pie charts based on Synthesis Explorer data, note that the argument(s) determine the bars or slices shown in the chart and the value will always be the quantity of analyses that fit the specified criteria.

If you use the default Count option when specifying the value, then any of the Synthesis Explorer properties will return the same quantities. You may prefer to choose the one that gives the most appropriate chart label(s). For example, the following pie chart uses the same property (“Application Source”) for both the Value and Argument in order to display the total quantity/percentage of analyses for each Synthesis application.

Tip: Use the Design tab of the ribbon to configure the chart labels and other settings to fit your particular preferences. For example, in this chart, the Data Labels are configured to display the Argument, Value and Percent (e.g., BlockSim: 648 (23.44%).)
If there is ever a situation in which you want to show only the number of distinct values for a particular property, you can use the **Count Distinct** option instead. For example, the following pie chart uses **User Created By (Count Distinct)** for the value in order to show the number of users who created analyses with each Synthesis application.
As you can see from looking at both charts, the “Count” shows that there are 648 total BlockSim analyses; while “Count Distinct” shows that only 18 distinct users created BlockSim analyses.

**Filtering the Data**
Any filters that are currently applied in the Synthesis Explorer grid will not be reflected in the dashboard charts. However, you can incorporate filters directly into the dashboard layout. For example, if you want to show all of the Weibull++ analyses that were created by a particular user, you can create a filter like the one shown next. (See Using the Filter Editor.)

In addition (or instead), you can configure the layout with one or more master filters that allow individual users to change the filters on-the-fly in the Dashboard Viewer. As an example, the following picture shows a layout in which the user’s current selections in the two grids determine which analyses will be reflected in the pie chart at any given time. (See Configuring a Master Filter and Using Master Filters.)
Synthesis Explorer Properties
The following properties will be available when you are using either the grid or dashboard in the Synthesis Explorer.

Application
- **Application Source** is the primary Synthesis application (or product family) for viewing or editing the analysis. (Note that Project Planners and Simulation Worksheets are listed under Synthesis because they can be created/edited from more than one product family.)

- **Application Activated?** indicates whether the primary application is activated on your computer.

Project
- **Project Name** is the project in which the analysis is stored.

- **Project Type** indicates whether it is a public, private or reference project.

Analysis
- **Analysis Name** is the name of the folio, diagram, plot, system hierarchy item, etc.
• **Analysis Type** and **Variant** indicate the type of analysis. This can include project items (e.g., folios, diagrams, plots, etc.) and specific analyses that are associated with a system hierarchy item in Xfmea, RCM++ or RBI (e.g., FMEAs, risk based inspection analyses, etc.). The variant is used to distinguish:
  
  • Analytical vs. simulation RBDs and fault trees in BlockSim.
  
  • Discrete vs. continuous Markov diagrams in BlockSim.
  
  • The specific prediction standard in Lambda Predict (e.g., MIL-217, Telcordia, etc.). If the prediction folio uses more than one standard, this will show as “Multiple.” If a standard has not yet been added to the prediction folio, the variant field will be blank.

**Categories and Synthesis Identifiers**

*Note that these properties are preceded with “SI” in the Dashboard Layout Designer, so that all Synthesis identifiers can be grouped together in the data source panel.*

• **Category** is the category assigned to the analysis.

• **Name**, **Part Number**, **Version**, **Supplier**, **Application**, **Description**, **Comments** and **Keywords** are the standard Synthesis identifiers that can be defined for the analysis. Note that Xfmea/RCM++/RBI analyses use the identifiers defined for the system hierarchy item they are associated with.

**Creation and Last Update**

• **User Created** and **Date Created** indicate the database user who originally created the analysis, and the associated date/time.

• **User Updated** and **Date Updated** indicate the database user who last modified the analysis, and the associated date/time.

**Synthesis Locator Links**

Synthesis Locator Links provide quick access to specific analyses in a Synthesis repository (similar to Windows shortcuts). You can save these link files anywhere on your computer or network, e-mail to a colleague, post on the Internet or an intranet, etc.

When you double-click (open) a Synthesis Locator Link file (*.rsrl11), it will launch the appropriate Synthesis application and go directly to a specific project item (e.g., folio, diagram, plot, system hierarchy item, etc.) or FMEA record (e.g., function, failure, etc.), as long as the following conditions are met:

• The database still resides in the same location and you have access to the server.
• You have an active user account in the database.
• The required Synthesis application is activated on your computer.

**Tip:** In the case of a standard database or Synthesis file, the locator link stores the pathname/filename that was open when the *.rsll file was created. If that was a mapped network drive (e.g., P:\Synthesis\Repository1.rsrl1), the link will only work if all other users have that drive mapped to the same letter. To make sure the link works for all users, you may need to open the database from the UNC pathname (e.g., \SharedDrive\Synthesis\Repository1.rsrl1) before creating a locator link file.

### Creating a Locator Link

In an enterprise database, you can choose to either send the file by e-mail or save it to a specified location. In a standard database or Synthesis file, the only option is to save the file because it is likely that the pathname may only work on your own PC (as discussed above).

- For an item selected in a current project explorer (Weibull++/ALTA, BlockSim/RENO, RGA or Lambda Predict), choose **Project > Current Item > Save Locator Link**.
- For an item selected in an Xfmea/RCM++/RBI system hierarchy, choose **System Hierarchy > Current Item > Save Locator Link**.
- For an item, structure or zone selected in an MPC hierarchy, choose **[Systems/Structures/Zones] > Tools > Save Locator Link**.

**Note:** If you get a "Locator Link is not properly formatted" message, the locator link may be corrupted or is using old encryption. Create a new locator link using the methods described above.

### Posting Locator Links on a Web Page

Remember that Synthesis Locator Links are files that must be opened from a computer where Synthesis desktop applications are installed. If you post the *.rsrl1 as a standard link on an HTML web page, you will need to instruct users to download the file (instead of opening directly from the web browser).
**What's Changed?** In Version 10, Synthesis Locator Link files used the *.rsll extension. Note that these links are not compatible with Version 11.

### Watches and Alerts

Automated alerts can be an effective tool to facilitate communication and track the status of assigned responsibilities.

Alerts can be sent via e-mail, SMS text message and/or Synthesis portal messages, depending on the **Receive automated alerts** preference specified for your **personal user account**.

- Alerts via portal message are always available in any database.
- Alerts via e-mail or SMS are only available if they are enabled for the database, and a valid SMTP server has been defined. (See [Enable Alerts via E-mail or SMS](#).)

Alerts can now be sent for:

- Any Synthesis resource that you have personally subscribed to “watch.” (See [Subscribing to a Watch](#).)

- Action resources, under any of the following conditions:
  
  - You have personally subscribed to watch the action.
  
  - You are the action’s creator, person responsible or assigned reviewer/approver and the database has been configured to auto-subscribe a watch for that role. (See [Action Alert Preferences](#).)
  
  - You are assigned via the Action Monitors window. (See [Action and Gate Monitors](#).)

- Project Planner gates, under either of the following conditions:
  
  - You have personally subscribed to watch the gate.
  
  - You are assigned via the Gate Monitors window.

- Change logs you have been assigned to approve in Xfmea/RCM++/RBI. (See [Electronic Approval Tracking](#) in the Xfmea/RCM++/RBI documentation.)
Enable Alerts via E-mail or SMS

To configure a database to enable alerts via e-mail and/or SMS text message, choose File > Manage Repository > Repository Settings.

In a secure database, this is available only for users with the “Manage other repository settings” permission.

What’s Changed? In prior versions, similar preferences were defined in the E-mail and Other Settings window.

1. Select the Enable Alerts via E-mail or SMS check box.

2. Specify a valid SMTP port and SMTP server. (You may need to consult with the IT professionals who have configured the e-mail server used within your organization.)

<table>
<thead>
<tr>
<th>SMTP port</th>
<th>SMTP server</th>
</tr>
</thead>
<tbody>
<tr>
<td>25</td>
<td>&lt;Insert a valid SMTP address&gt;</td>
</tr>
</tbody>
</table>

3. Enter your e-mail address (or a valid SMS text messaging address if you prefer) in the Recipient address for test message field and then click Send Test Message.

   Recipient address for the test message
   YourEmail@Company.com  Send Test Message

   If the test message cannot be sent, an error will be displayed. If that happens, you can update the settings and try again until the message is delivered successfully.

Subscribing to a Watch

Users can personally subscribe to “watch” specific Synthesis resources, Project Planner gates and MPC tasks that are of particular interest to them. This generates an alert (via e-mail, SMS text message and/or Synthesis portal message) each time the record is changed.
Chapter 25: Synthesis Platform Tools

Subscribing and Unsubscribing
To personally subscribe/unsubscribe to a watch, open the resource, Project Planner gate or MPC task and select or clear the Alert me on changes to this record check box. The alert types shown for this option will depend on your alert preferences, as described in the section below.

| Watch | Alert me on changes to this record (via SMS, e-mail, portal message) |

Note that the “watch” feature is not applicable for the following types of resources: Variables, Maintenance Groups, Mirror Groups, Controls, Maintenance Templates (in BlockSim) or RENO-specific resources (Functions, Static Functions, Simulation Definitions and Tables).

Receiving Alerts
Alerts can be sent via e-mail, SMS text message and/or Synthesis portal message, depending on the Receive automated alerts preference specified in your personal user account.

- Alerts via portal message are always available in any database.
- Alerts via e-mail or SMS are only available if they are enabled for the database, and a valid SMTP server has been defined. (See Enable Alerts via E-mail or SMS.)

No Cascading Alerts
Alerts are generated only when the record you’re watching is edited directly. For example, if you are watching a universal reliability definition (URD):

- An alert will be sent if someone replaces Model A with Model B in the URD window.
- An alert will not be sent if there is a change to an existing model, crew, etc. that is already assigned to the URD, unless you have also subscribed to watch the dependent resource that was changed.

Special Considerations for Actions and Gates
For action resources only, there are some additional features designed to maintain continuity with prior versions of Synthesis and enhance the actions management functionality. Specifically:

- Action changes that are applied via the FMEA worksheet in Xfmea/RCM++/RBI will not initiate an alert. The change must be saved via the action properties window.
- The database can be configured to auto-subscribe watches for users with the following roles: Action Creator, Person Responsible or Reviewer (aka “approver”). Each user can choose to personally unsubscribe later if desired. (See Action Alert Preferences.)
- The Action Monitors window allows you to specify individual users and/or groups of users who will always receive alerts for the action, regardless of whether they have
personally subscribed to a watch. For example, this allows you to set up an alert for a user who doesn’t have access to view or modify the project (and therefore can’t personally subscribe to a watch).

A similar feature, the Gate Monitors window, is available for Project Planner gates. (See Action and Gate Monitors.)

### Action Alert Preferences

To configure the action alert preferences for the database, choose **File > Manage Repository > Repository Settings**.

In a secure database, this is available only for users with the “Manage other repository settings” permission.

**What’s Changed?** In prior versions, similar preferences were defined in the E-mail and Other Settings window.

- **Introduction to each action alert sent via e-mail.** This field allows you to specify the default text (up to 1,000 characters) that will be used at the beginning of each action alert e-mail sent from this database.

- **Automatically set ‘watch’ for.** Users can personally subscribe to “watch” specific Synthesis resources and Project Planner gates that are of particular interest to them. For action resources only, the database can also be configured to auto-subscribe watches for users that have particular roles in a given action, as shown in the picture above. Note that each user can choose to personally unsubscribe later if desired (by opening the action record and clearing the check box under the Watch heading).
**Action and Gate Monitors**

The Action Monitors window (for action resources) and the Gate Monitors heading (for Project Planner gates) allow you to specify individual users and/or groups of users who will always receive alerts for the record, regardless of whether they have personally subscribed to a “watch.”

For example, this allows you to set up an alert for a user who doesn’t have access to view or modify the project (and therefore can’t personally subscribe to a watch).

**Action Monitors**

For actions, click the **Action Monitors** icon in the action’s ribbon.

This replaces the “E-mail Notifications” feature from prior versions, and you can choose any of the **user groups** or **individual user accounts** defined in the current database.

The action will also appear under the **I am monitoring** heading in **My Portal, Actions Explorer** and **Synthesis Enterprise Portal** (along with the actions that the user has personally subscribed to watch).

![I am monitoring](image)

**Gate Monitors**

For Project Planner gates, the assigned users are listed under the **Gate Monitors** heading. Click the **Edit** icon to select the users you wish to assign.

![Gate Monitors](image)

This replaces the “Team” feature from Xfmea/RCM++/RBI Version 9, and you can choose to assign any of the individual user accounts in the database.

**What is Your SMS Address?**

If you choose to receive alerts via SMS text messaging, the address will usually be your cell phone number @ the provider’s e-mail domain. As a courtesy, the table below provides a list of domains for popular providers in the United States (as of March 2015). Of course, you may need to check with your provider to obtain the most up-to-date information.

Xfmea/RCM++/RBI 11 User’s Guide 573
For example, if you use T-Mobile in the US and your cell number is 555-123-4567, your SMS address will be 5551234567@tmomail.net.

<table>
<thead>
<tr>
<th>Provider</th>
<th>Domain</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alltel</td>
<td>@message.alltel.com</td>
</tr>
<tr>
<td>Amp'd</td>
<td>@vtext.com</td>
</tr>
<tr>
<td>Boost</td>
<td>@myboostmobile.com</td>
</tr>
<tr>
<td>AT&amp;T</td>
<td>@txt.att.net</td>
</tr>
<tr>
<td>Metrocall</td>
<td>@page.metrocall.com</td>
</tr>
<tr>
<td>Nextel</td>
<td>@messaging.nextel.com</td>
</tr>
<tr>
<td>Sprint</td>
<td>@messaging.sprintpcs.com</td>
</tr>
<tr>
<td>T-Mobile</td>
<td>@tmomail.net</td>
</tr>
<tr>
<td>US Cellular</td>
<td>@mms.uscc.net</td>
</tr>
<tr>
<td>Verizon</td>
<td>@vtext.com</td>
</tr>
<tr>
<td>Virgin (USA)</td>
<td>@vmobl.com</td>
</tr>
<tr>
<td>Windstream</td>
<td>@windstream.net</td>
</tr>
</tbody>
</table>

**History Logs**

By default, all projects and project items automatically show information about when an item was created and last updated, and by whom. For example, system hierarchy items in Xfmea/RCM++/RBI show this information under the History heading on the Properties tab, while folios and diagrams in Weibull++ and BlockSim show the information in the Item Properties window (**Project > Current Item > Item Properties**).

In addition to the basic information provided, you have the option to activate a full history log that shows more detailed information such as the type of change that was made (e.g., add, edit or delete), the record that was changed and the specific property, and the value before and after the change.
History logs will increase the size of a database and will cause a slight degradation in performance; hence, they must be activated on a per project basis. If desired, you can configure the database to automatically activate history logs for each new project by choosing File > Manage Repository > Repository Settings, and then selecting the option under the Other Settings tab in the window. (In secure databases, this is available only if the user has the "Manage other repository settings" permission.)

Once a history log is activated, the project history log shows the changes for all items in the project, and individual record history logs show the changes for selected items only.

Tip: If you want to monitor and control revisions made to FMEAs, DVP&Rs or Control Plans in Xfmea/RCM++/RBI, the use of change logs may be more appropriate. See Change Logs in the Xfmea/RCM++/RBI documentation.

**Activating a Project History Log**

To activate the history log for a project, choose Project > Management > History Log, or right click the project in the project list and choose the command on the shortcut menu. (In secure databases, this is available only if the user is the project owner, or has the applicable "manage all projects" permissions.)

In the Project History Log window that appears, click Activate.

Once the log has been activated, the database will start keeping records of all changes that are performed throughout the entire project for any of the Synthesis applications. You can filter the records by the last update date, application, user or type of change. For example, you might choose to display a list of all changes that were made by Joe User in the last week, or a list of all changes that were made by any user in Weibull++ today, and so on.

You can deactivate the history log at any time from this window. When you do this, the recorded data is retained unless you select to clear it in the confirmation message that appears.

**Creating and Managing Archives**

You can limit the amount of information that is visible in the log by archiving older entries that are no longer of interest. Entries that have been archived can still be viewed in the Project History Log window if you specifically select to view them, but they will no longer be visible in the Record History Log windows.
Archives are named based on the date they were created. For example, if you archive entries through **One week ago**, all entries in the history log that are dated as of one week ago or earlier will be stored in an archive that is named after the current date.

To view the contents of an archive, select the archive of interest from the **Archive** drop-down list in the **Filter Based On** area. To delete an archive, click the **Delete** icon that appears in the field.

**Note**: When a **restore point** is created for a project or when a project is **checked out**, all current entries in the history log are automatically archived.

**Viewing Record History Logs**

In addition to the project history log, you can view a log that shows only the changes made to a selected item (archived entries will not be shown). The History Log icon 📊 will be displayed whenever the log is available:

- For folios, diagrams, multiplots (such as overlay plots), reports and worksheets, right-click the item in the current project explorer and choose **Item Properties**, then in the window that appears, click the **History Log** icon in the Identifiers tab.
- For system hierarchy items in Xfmea/RCM++/RBI and MPC, select the item then click the **History Log** icon in the Properties panel.
- For FMEAs, DVP&Rs and other analyses in Xfmea/RCM++/RBI, right-click the analysis’s tab in the Analysis panel and choose the **History Log** command on the shortcut menu.
- For resources (e.g., models, actions, etc.), the **History Log** icon will be available when you edit the item or view its properties.

**Import, Export and Data Conversion**

Synthesis applications provide a variety of different tools for import, export and data conversion from external files and between Synthesis repositories. The options will vary depending on which application you are currently using.
In desktop applications, you can:

- Import data from an existing database when you are creating a new one.
- Convert and import data from prior version files.
- Import/export selected projects.

When applicable, you can also:

- Import/export selected project items or Synthesis resources.
- Import from an Excel spreadsheet or delimited text file into a data folio.
- Use XML files to import/export system configuration information in BlockSim or Lambda Predict.

These features can be accessed either from the Import/Export Wizard (Project > Management > Import/Export) or from the Backstage View.

In addition to the common functionality described in this chapter, some Synthesis applications provide other data transfer and import/export utilities that fit specific needs (e.g., the Import Bill of Materials feature in Lambda Predict, the Excel templates in Xfmea/RCM++/RBI, the ability to share analysis details between specific Synthesis applications.). For more information about these specialized tools, please consult the documentation for the particular application(s) involved.

**Importing from an Existing Repository**

When you are creating a new Synthesis repository, you have the option to import repository settings (e.g., user accounts, security groups, project categories, etc.) and/or entire analysis projects from another database.

If the Import from existing repository check box is selected when you start to create a new database, the Import Data from Existing Repository window will be displayed.

First, use the drop-down list or browse icon to select the database that you want to import from. This can be a standard database (*.rsr11) or an enterprise database connection file (*.rserp).

Then, use the check boxes to select the settings and/or projects you wish to import.

Finally, click OK to create the new database with the selected data imported.
Importing from Prior Version Files

There are two ways to convert and import data from project files and standard database files that were created in previous versions of the software.

- **Importing to a new standard database (File > Open Repository)**
- **Importing to an existing database and project (Import > Other file)**

The options depend on which Synthesis application you’re currently using:

- For Weibull++, ALTA, RGA and BlockSim/RENO, you can use either method.
- For Lambda Predict, Xfmea/RCM++ and MPC, you must use the File > Open Repository method to import the data into a new project in a new standard database.

Finally, for an enterprise database created in Xfmea/RCM++ 5, there is a dedicated utility that you can access from the Backstage View. (See [Converting Xfmea/RCM++ 5 Databases](http://xfmea.reliasoft.com).)

Importing to a New Standard Database (File > Open Repository)

For all Synthesis desktop applications, you can use the File > Open Repository method to import data from a project file or standard database that was created in a previous version of the software. This imports the data to a new project in a new standard database.

1. Choose **File > Open Repository**.
2. Browse for the file and click **Open**.
3. The conversion process will begin immediately for most applications. In BlockSim and MPC only, you will be prompted to specify some preferences and then click **OK** to proceed.

   - See [Converting from BlockSim 6 or 7 Files](http://xfmea.reliasoft.com).
   - See [Converting MPC 3 Databases](http://xfmea.reliasoft.com).

*Note that although the conversion of Xfmea/RCM++ 5 databases does not require any user input, the process does apply some assumptions to address changes in the functionality and data structure between versions. (See [Converting Xfmea/RCM++ 5 Databases](http://xfmea.reliasoft.com).)*
When the process completes, the original file will remain unchanged and the new standard database will be created in the same folder.

**Tip:** Once the new database has been created, you can use the Import/Export Projects feature to copy the data into an existing database, if desired.

### Importing to an Existing Database and Project (Import > Other file)

For the applications and file types shown in the following table, you can use the Import > Other file method to import data from a project file that was created in a previous version of the software. This imports the data to a selected project in an existing standard database or enterprise database.

<table>
<thead>
<tr>
<th>Weibull++/ALTA</th>
<th>RGA</th>
<th>BlockSim/RENO</th>
</tr>
</thead>
<tbody>
<tr>
<td>ReliaSoft Office 7 projects (*.rso7)</td>
<td>RGA 7 projects (*.rga7)</td>
<td>BlockSim 7 projects (*.rbp)</td>
</tr>
<tr>
<td>Weibull++ 7 projects (*.rwp)</td>
<td>RGA 6 projects (*.rga)</td>
<td>BlockSim 6 projects (*.rb6)</td>
</tr>
<tr>
<td>ALTA 7 projects (*.ralp)</td>
<td></td>
<td>RENO 1 projects (*.rnp)</td>
</tr>
<tr>
<td>Weibull++ 6 projects (*.rw6)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ALTA 6 projects (*.ra6)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DOE++ 1 projects (*.rdoe)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Do the following:

1. Create a new project or open an existing project that you want to import the data into.
2. Choose **Project > Management > Import/Export > Import**.
3. In the Import wizard, choose **Other file** and click **OK**.
4. The conversion process will begin immediately for most applications. In BlockSim only, you will be prompted to specify some preferences and then click **OK** to proceed. (See Converting from BlockSim 6 or 7 Files.)
Note that although the conversion of Xfmea/RCM++ 5 databases does not require any user input, the process does apply some assumptions to address changes in the functionality and data structure between versions. (See Converting Xfmea/RCM++ 5 Databases.)

When the process completes, the original file will remain unchanged and the converted data will be copied into the selected project.

**Converting from BlockSim 6 or 7 Files**

When you import from a BlockSim 6 (*.rb6) or BlockSim 7 (*.rbp) file, the Conversion Settings window allows you to specify:

- Whether you want the diagrams to be converted to analytical diagrams, simulation diagrams, or both.
- Whether the application will attempt to merge identical records when certain block properties are converted to Synthesis resources. For example, if the old diagram has two blocks with the same failure distribution, this can be imported as two separate but identical failure models, or as a single failure model that's linked from both blocks.

**Tip:** The default preferences for merging identical resources upon conversion are set on the Conversion page of BlockSim's Application Setup (File > Application Setup). Note that any changes you make in the Conversion Settings window will update your preferences in the Application Setup. In other words, the same options will be selected by default the next time you attempt to convert a BlockSim 6 or 7 file on this computer.

**Conversion Constraints and Differences**

Numerous improvements have been made to the modeling capabilities and underlying analysis and simulation algorithms used in the Synthesis version of BlockSim. As a result, analysis or simulation of diagrams imported from previous versions of BlockSim may yield results that differ from the results originally obtained. In particular, results may differ in the following cases and/or for the following reasons:

- **Simulation diagrams:**
  - When multiple blocks are used in conjunction with subdiagrams, the underlying order of block expansion differs between versions, so results may differ.
• In the Synthesis version, containers are treated as subdiagrams. The underlying order of block expansion differs between versions, so results may differ. However, some special cases will produce identical results. These include cases where:
  • The container is the only block in the diagram.
  • The container is at the end of the list in the original diagram (i.e., it was created last and has the highest block ID, which is automatically assigned by the software upon block creation).

• The load on contained load sharing blocks is calculated differently. Version 7 required a life-stress relationship for such configurations and based the re-calculation of load after block failure on that relationship; the Synthesis version calculates load using the weight proportionality factor as a multiplier.

• Normal/lognormal distributions have increased precision in the Synthesis version.

• Maintenance tasks that are performed at specified intervals (based on item age or calendar time) for multiple blocks are performed in a different order, producing results that are not identical, although the difference will not be statistically significant.

• Indirect cost is calculated differently. In version 7, the following was calculated at the end of the simulation:
  
  \[ \text{Indirect cost} = \text{Average stock level} \times \text{Holding cost per item} \times \text{Simulation end time} \]

  In the Synthesis version, the indirect cost is calculated for each simulation and then averaged at the end to yield the indirect cost that is shown. This is because holding cost per item may be a distribution in the Synthesis version.

• The order in which random numbers are assigned in general is by block ID. This means that if diagrams have the same blocks with the same IDs in both the previous version and the current version, the results will be identical. Standby containers represent an exception to this. In version 7, the order of blocks is overwritten by the standby priority. Therefore, results may not be identical with standby containers if the block IDs do not match the block standby priorities. The difference should not be statistically significant.

• For mirrored blocks, in version 7, the block that fails is the source and all the other mirrors are assigned these failures. In the Synthesis version, the failures are assigned to the mirrored block with the lowest block ID. If the failure source is not the block with the lowest ID, then the results will be different between versions.
Chapter 25: Synthesis Platform Tools

- Mirrored blocks inside subdiagrams are handled differently. In version 7, they were treated as different groups of mirrors; the Synthesis version treats them as the same group. This may produce results that are statistically different.

- Throughput is not available in fault trees in the Synthesis version.

- The throughput property **Send units to failed blocks** works differently for subdiagrams in the Synthesis version, in that it applies to the whole diagram. That is, if the current block is set to not send units to failed blocks and the next block is a subdiagram that is not operating, then the throughput will be re-routed if possible or the current block will accumulate backlog.

- Phases have different rules on how interrupted events are handled and may give different results when re-simulating.

- In the Synthesis version, containers do not exist in maintenance phases. Thus, the availability results for containers in phase simulation may be different than in previous versions.

**Analytical diagrams:**

- The load on contained load sharing blocks is calculated differently. Version 7 required a life-stress relationship for such configurations and based the re-calculation of load after block failure on that relationship; the Synthesis version calculates load using the weight proportionality factor as a multiplier.

- Mirrored blocks inside subdiagrams are handled differently. In version 7, they were treated as different groups of mirrors; the Synthesis version treats them as the same group. This may produce results that are statistically different.

**Other issues of interest when opening BlockSim 7 files:**

- Nodes do not have failure/maintenance properties in the Synthesis version. Therefore, if a node has failure properties in BlockSim 7, it will be imported in the current version as two blocks: a node with the *k-out-of-n* and the throughput properties (if applicable) and a block with the failure properties positioned immediately after the node. If the node does not have failure properties, a second block will not be imported.

- The load on contained load sharing blocks is calculated differently. Version 7 required a life-stress relationship for such configurations and based the re-calculation of load after block failure on that relationship; the Synthesis version calculates load using the weight proportionality factor as a multiplier. Because of this, if you convert a diagram that uses load sharing containers, you will need to manually configure the contained load sharing blocks after conversion.
• Simulation FRED reports will be imported, but cannot be restarted or have levels appended/removed until the diagram is resimulated.

In addition, certain rules apply when importing maintenance properties from BlockSim 7:

• Preventive maintenance:
  • For each preventive maintenance setting, a new task will be created. For example, if the preventive maintenance policy is set to be performed upon system down and upon system age, two tasks will be created.
  • For each task created, the duration, crews, restoration factor, etc. will be identical.

• Inspections:
  • For each inspection setting, a new task will be created. For example, if the inspection policy is set to be performed upon system down and upon system age, two tasks will be created.
  • For each task created, the duration, crews, restoration factor, etc. will be identical. Note that inspections do not use pools.
  • If a detection threshold is defined in version 7, an on condition task will be created instead of an inspection task in the Synthesis version. A threshold is defined in version 7 if a Failure Detection Threshold greater than 0 and less than 1 is specified or if a P-F Interval greater than 0 is specified.
    • The inspection properties from version 7 will be transferred to the inspection properties of the on condition task in the Synthesis version.
    • The threshold (i.e., detection) information from version 7 will be transferred to the failure detection properties of the on condition task in the Synthesis version.
    • The preventive maintenance properties from version 7 will be transferred to the on condition task (upon detection) properties of the on condition task in the Synthesis version.
  • If a detection threshold is defined in version 7 but no preventive maintenance properties are defined, then only an inspection task will be created (i.e., the threshold is ignored).
PM/Inspection based on group:

- A task will be added and assigned to the maintenance group that the block belongs to. For example, if Block 1 belongs to Item Group 1 and has an inspection policy based on group maintenance in version 7, then in the Synthesis version an inspection task will be created and will be set to be performed upon group maintenance. Maintenance Group 1 will be checked in the list of groups that will trigger a maintenance, and Block 1 will be assigned to Maintenance Group 1.

- If the block does not belong to a group, a task will not be added.

- The corrective maintenance properties will be imported as corrective tasks.

- A preventive maintenance action or an inspection based on maintenance phase and associated with a block in a standard phase will not be imported.

Converting Xfmea/RCM++ 5 Databases

This topic describes how to convert/import data from an Xfmea/RCM++ 5 database into a Synthesis repository.

For information about converting and importing data from an Xfmea/RCM++ 5 library, please consult the "Configurable Settings" chapter in the Xfmea/RCM++/RBI documentation.

Standard Databases (*.rx5)

For Xfmea/RCM++ 5 standard databases, you must convert the entire *.rx5 file to a new Synthesis standard repository. (Later, you can use the Import/Export Projects feature to copy specific projects into an existing database, if desired.)

Do the following:

1. In the Synthesis version of Xfmea, RCM++ or RBI, choose File > Open Repository.
2. Select RCM++ 5/Xfmea 5 (*.rx5) from the Files of type drop-down list.
3. Select the file you wish to convert and click Open.

The application will create a new standard database file in the same directory with the extension *.rsr11; the existing *.rx5 file will remain unchanged.

Enterprise Databases

For Xfmea/RCM++ 5 enterprise databases, you can select which analysis projects and settings you wish to import into a Synthesis enterprise repository that has already been created. You must be a member of the Admin group in the Synthesis enterprise repository to perform this task.
Do the following:

1. Connect with the enterprise database you want to import into.

2. Choose **File > Manage Repository > Import from Version 5.**

3. In the area at the top of the Import from Version 5 Enterprise Database window, enter the connection information for the Version 5 enterprise database and click **Connect.**

4. The table shows all of the data and settings in the original database. Use the check boxes to select which data you wish to import and then click **OK** to start the transfer.

**Note:** If you are importing into a SQL Server database, the **Create SQL Server login** check box will be displayed at the bottom of the window. This is applicable only if you are importing user accounts. (See **SQL Server Logins or Using Windows Impersonation**.)

**Conversion Assumptions and Tips**

When you convert data from an Xfmea/RCM++ 5 database, please consider the following assumptions and tips:

- **Conversion to Synthesis Resources**

  Certain types of information in the Version 5 projects will be converted to **resources** in the Synthesis version. This includes reliability information (which will be converted to models), controls and actions. In these cases, records that have identical properties will be merged into a single resource. For example, if there were two identical actions in the original project, a single action would be created as a resource in the Synthesis project and used in both locations.

- **Conversion to Security Groups**

  If you are working with secure databases, the access levels and access groups in Version 5 will be converted to **security groups** in Synthesis. Specifically:

  - Repository-level security: User permissions assigned by access level in Version 5 will be assigned by the corresponding security group in the Synthesis version. For example, if a user had the Admin access level in the original database, then that user will be assigned to the Admin security group in the Synthesis version. If there is no corresponding security group in the Synthesis version, the user will be imported with no security groups assigned, and a user with "Admin" access level permissions will have to manually assign security groups to the imported user.

  - Project-level security: For each access group in the Version 5 database, a security group will be created in the Synthesis repository. Because the Version 5 access
groups could have different access levels for different users in the same group, it is not possible to automatically determine which permissions should be assigned for the new security group in the Synthesis version. Therefore, these groups will initially be assigned the default permissions; you can edit the permissions via the Security Groups tab of the Users and Security window. Projects that had access limited by access group in Version 5 will continue to have their security set by the appropriate security group(s) at the project level in the Synthesis version.

- **Configurable Settings for Converted Projects**

  When you convert an existing project from Version 5, the application will add new configurable settings for new features that were added in the Synthesis version. For example, the configurable PFD Worksheet settings will be added to the interface style, the quantitative values will be added to the occurrence rating scale, etc.

  It is important to note that these default settings may need to be modified after the conversion. For details, please consult the "Configurable Settings" section in the Xfmea/RCM++/RBI documentation.

**Converting MPC 3 Databases**

If you have an existing systems and powerplant analysis that was created in MPC 3, it is easy to convert the *.rsm file into a new Synthesis repository.

Choose **File > Open Repository**, select MPC 3 (*.rsm) from the Files of type drop-down list, and then browse for the desired file.

When prompted to enter a username and password, enter the administrative login from the old *.rsm file.

*Note:* By default, a converted Version 3 database is a secure database that transfers any user accounts that were defined in the old database. After the new database has been created, the administrator should review the automatically created user accounts and update as appropriate. See Security Options for more information about database-level security.

The final step is to use the Tasks Conversion window to review the task records that will be imported and make any updates that may be needed (see details below). Once you have completed the review, click **OK** to start the import.

When the process completes, there will be a new standard database file in the same folder and with the same name as the original *.rsm file. The new file will have the extension *.rsr11 and the original *.rsm file will remain unchanged.
**Tasks Conversion Window**

The Tasks Conversion window displays a list of all of the tasks defined in the original database and allows you to review how the records will be converted upon import. For any properties that are displayed with blue text, you have the option to change the task record data before it is imported.

Some task properties are handled a bit differently in the Synthesis version than they were in Version 3. Specifically:

- Some of the **Task Types** that were combined in Version 3 are now categorized separately in the Synthesis version (e.g., Operational Check (OPC) and Visual Check (VCK) are now separate task types).

- In Version 3, the task **Interval** was always stored as a text field. In the Synthesis version, you can choose whether each task's interval will be stored as a text field or if it will instead be recorded as a number with an associated time unit (e.g., 2000 flight hours can now be stored as value=2000 and time unit = FHr). Numbers may be easier to sort and will also make it possible to perform simulation-based reliability calculations if you choose to import the analysis project to RCM++ or RBI.

- The **Zonal** field from Version 3 is called **Zonal Candidate** in the Synthesis version. This is now a yes/no field that can be set to **Yes** only if the failure effect categorization (FEC) is set to 5 or 8 (i.e., a safety issue) and the task type is "General Visual Inspection (GVI)." Also in the Synthesis version, the **Zone** field will be enabled only if Zonal Candidate is set to **Yes**.

The following subsections describe the default conversion logic for Task Type, Interval and Zone.

**Task Type**

For the **Discard** and **Restoration** task types, there is no difference between Version 3 and the Synthesis version. The text in the Task Type (New Value) column will be displayed in italics to indicate that this property cannot be changed via the Tasks Conversion window.

<table>
<thead>
<tr>
<th>Task Type (Old Value)</th>
<th>Task Type (New Value)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discard (DS)</td>
<td>Discard (DIS)</td>
</tr>
<tr>
<td>Restoration (RS)</td>
<td>Restoration (RST)</td>
</tr>
</tbody>
</table>

For the remaining task types, the software will use the logic specified below to suggest a task type, but the property will be displayed in blue text to indicate that it can be edited. If you disagree with the default selection, you can choose one of the other eligible task types from the drop-down list, as shown in the following example.
When the task type was set to **Inspection/Functional Check (IN)** in Version 3, the following logic will be applied in the specified order. For example, if the task description contains both the word "Visual" and the word "Function," the General Visual Inspection task type will be applied by default because the word "Visual" will be matched first.

<table>
<thead>
<tr>
<th>If the task description contains:</th>
<th>The default option is to import the task as:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visual</td>
<td>General Visual Inspection</td>
</tr>
<tr>
<td>Special Detail</td>
<td>Special Detailed Inspection</td>
</tr>
<tr>
<td>Health Monitor</td>
<td>Scheduled Structural Health Monitoring</td>
</tr>
<tr>
<td>Function</td>
<td>Functional Check</td>
</tr>
<tr>
<td><em>none of the words/phrases listed above</em></td>
<td>Detailed Inspection (DET)</td>
</tr>
</tbody>
</table>

When the task type was set to **Lubrication/Servicing (LU)** in Version 3, the default option is to import the task as Servicing (SVC) if the task description contains "Servic" and as Lubrication (LUB) if it does not.

When the task type was set to **Operational/Visual Check (OP)** in Version 3, the default option is to import the task as Visual Check (VCK) if the description contains "Visual" and as Operational Check (OPC) if it does not.

*Tip:* The task types in the Synthesis version of MPC are determined by the requirements of the MSG-3 guidelines and cannot be changed. However, the abbreviations can be configured to fit your particular preferences. If you want to change the default task type abbreviations (e.g., if you don't want to use DIS for Discard, RST for Restoration, etc.), click the **Task Type Abbreviations** button. The changes that you make in the Define Task Type Abbreviations window will automatically apply to all analyses in the current database. This window is also accessible from *File > Manage Repository > Task Types.*
Interval Type and Interval

Two options are displayed at the top of the Tasks Conversion window to determine how the task intervals will be imported:

- If you choose **Transfer all intervals as text**, the interval type for all imported task records will be set to **Based on Events (Text)** and the interval will be stored as a text field (just like in MPC 3). The Interval (New Value) column will be displayed in blue text to indicate that you can change the text if desired before the import.

- If you choose **Transfer intervals as numeric if possible**, the application will check to see if the original task interval begins with a number and is followed by a space and at least one text character. If it does (e.g., "2000 flt/hr"), the default option is to import it as a number with an associated time unit. If not (e.g., "Per Mfg Life Limit"), the default is to import as text. Either way, you have the option to change both the interval type and new value before the import. For example:

<table>
<thead>
<tr>
<th>Interval Type</th>
<th>Interval (Old Value)</th>
<th>Interval (New Value)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Based on Events (Text)</td>
<td>2000 flt/hr</td>
<td>2000 flt/hr</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Interval Type</th>
<th>Interval (Old Value)</th>
<th>Interval (New Value)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed (Numeric)</td>
<td>8000 flt/hr</td>
<td>Flight Hours (Hr)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Flight Cycles (C)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Landing Cycles (LDG-C)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>APU Hours (APU-H)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>APU Cycles (APU-C)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Hours (Hr)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Days (Day)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Interval Type</th>
<th>Interval (Old Value)</th>
<th>Interval (New Value)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed (Numeric)</td>
<td>8000 flt/hr</td>
<td>8000 (Hr)</td>
</tr>
</tbody>
</table>

  Tip: If you want to change the time units displayed in the drop-down list, click the **Time Units** button. The changes that you make in the **Time and Usage Units window** will apply immediately to the tasks that you are currently importing, and also to all other analyses you may later add to this database. This window is also accessible from **File > Manage Repository > Time and Usage Units**.

The Tasks Conversion window uses a variety of techniques to try to match the text field from Version 3 with one of the specified time units in the Synthesis version. There will be a match if...
the name or abbreviation of a Synthesis version time unit either starts with or contains the text in the Version 3 field. For some predefined time units, the software also recognizes other commonly used abbreviations for the time unit (e.g., the software will recognize any of the following abbreviations as flight hours: Flt/Hr, Flight H, Flt H or Flt/H).

If your data set contains a task interval that is not recognized, you can do any of the following:

- Edit the text in the **Interval (New Value)** column so it will match either the name or the abbreviation of a predefined time unit. For example, if the Version 3 task record contains a misspelling for "2000 flight hours," you can click inside the cell and remove the extra i.

- Click the **Time Units** button and define a new time unit for the database with a name or abbreviation that matches the data you want to import. For example, if the Version 3 task record has an interval of "5 Weeks," you can open the "Time and Usage Units" window and create a new time unit with the name "Weeks."

- Click **Cancel** to close the Tasks Conversion window then edit the original tasks in MPC 3 before starting the import again.

### Zonal Candidate and Zone

If all of the following conditions are met, the **Zonal Candidate (New Value)** column will be set to **Yes** by default and any information from the **Zone** field will be transferred during the import:

- The failure effect categorization (FEC) is set to 5 or 8 (i.e., it is a safety issue).
- The Task Type is set to General Visual Inspection (GVI).
- The Zonal property in the original MPC 3 analysis contains the word "Transfer."

If you don't want the task to be considered for zonal analysis even though it meets the requirements, you can click inside the Zonal Candidate (New Value) column and choose **No** from the drop-down list. If this column displays **No** in italics, this indicates that at least one of these conditions is not met and the property cannot be changed.
**Importing/Exporting Projects**

All Synthesis desktop applications make it easy to import or export selected projects from one database to another.

Note that when importing/exporting a project between databases, any resources and FMEAs used by the project will be automatically imported/exported along with the project as local resources, even if they were originally reference resources or global resources. If you do not want the reference resources to be converted to local resources, you must import the both the project and the reference project at the same time. (See [Local, Global and Reference Resources](#).)

To import a project, first choose **Project > Management > Import/Export**.

In MPC, the Import/Export window opens directly. In all other applications, a wizard displays the options that are relevant for the current application. Select **Projects** and click **OK**.

Once the Import Projects or Export Projects window is open, do the following:

1. Use the drop-down list or browse icon to select the database that you want to import from or export to.
   - This can be any existing standard database (*.rsr11) or enterprise database connection file (*.rsrep).
   - If you are exporting, you can also use the add icon to create a new standard database to export into.

2. The tree displays the projects that are available to be imported or exported. If desired, you can use the **Filter** and **Find** tools to limit the list of projects displayed. (See [Project Manager](#).)

3. Use the check boxes to select which project(s) you want to import/export then click **OK** to copy the data.
The following considerations apply:

- The names of projects must be unique within each Synthesis repository. If you attempt to import/export a project with a name that already exists in the destination database, the application will automatically increment the name. For example, if "Project1" already exists, the new project might be renamed to "Project1_1."

- If the project has a category, the application will first attempt to match it to an existing category in the destination database. If a matching category does not already exist, and you have the permission to create project categories in the destination database, it will be created automatically.

- If you select a project of a type that you don’t have permission to create in the destination database (private, public or reference), it will be converted to a type that you do have permission to create. For example, if you select to import a reference project but you don’t have the "Create and own reference projects" permission in the destination database, the project will be imported as a public or private project, and any links from other projects will be broken.

**Importing/Exporting Project Items or Resources**

When applicable, Synthesis applications make it easy to import/export selected project items (e.g., folios, diagrams, plot sheets, Synthesis Workbooks, etc.) or Synthesis resources (e.g., models, maintenance tasks, etc.) between existing projects. The projects can be in the same database or in different databases.

First, open the project you want to import to or export from. Then open the import/export window, there are two ways:

- If you have selected the Allow multiple projects option in the Synthesis Settings page of the Application Setup, you can open both projects simultaneously and then drag/drop items from one project to another.

  OR

- Choose Project > Management > Import/Export.

  ![Arrow](arrow.png)

  In the wizard, choose Items (not available for Xfmea/RCM++/RBI and MPC) or Resources (not available for MPC) and click OK.
Once the Import window or Export window is open, do the following:

1. Use the drop-down list or browse icon 📂 to select the database you want to import from or export to.
   - This can be any existing standard database (*.rsr11) or enterprise database connection file (*.rserp).
   - If you are exporting, you can create a new standard database and project by clicking the 📌 icon.

2. Use the tree in the **Source Project** or **Destination Project** area to select the project you want to import from or export to. If desired, you can use the **Filter** and **Find** tools to limit the list of projects displayed. (See **Project Manager**.)

3. Use the check boxes in the **Items to Import** or **Items to Export** area to select which project items or resources you want to import/export.
   - For project items, this area will display the same folders that appear in the current project explorer. A +/- icon next to the folder indicates that it contains at least one project item that can be imported or exported.
   - For resources, this area will display a folder for each type of Synthesis resource that exists in the selected project.

4. Click **Import** or **Export** to copy the data.

**Note:** The names of project items and resources must be unique within each Synthesis project. If you attempt to import/export something with a name that already exists in the destination project, the application will automatically increment the name. For example, if "Folio1" already exists, the new folio might be renamed to "Folio1_1," "Folio1_2," etc.

**Keeping Associated Items/Resources Together**
The application will automatically copy any item/resource that is linked to the imported or exported item, even if you did not specifically select to import/export them. Some examples:

- A multilplot, such as an overlay plot, side-by-side plot, or 3D plot, will automatically import/export a copy of the folios or diagrams that were used to generate the plot.
Chapter 25: Synthesis Platform Tools

- A **BlockSim diagram** will automatically import/export a copy of any utilized subdiagrams and resources.
- A **RENO flowchart** will automatically import/export a copy of any utilized subcharts, resources and Synthesis Workbooks.
- A **Synthesis Workbook** or special analysis folio/tool (e.g., allocation analysis, stress-strength analysis, etc.) will automatically import/export a copy of its data sources.
- A **URD** will automatically import/export a copy of the models, maintenance tasks, crews, etc. that were used to build the URD. The same applies to any resource that is built upon another resource.

Note that when importing/exporting project items between databases, the resources are imported/exported as local resources in the destination database, even if they were originally reference resources or global resources. For more information on how importing/exporting affects a resource, see [Local, Global and Reference Resources](#).

**Tip:** If you do not want a RENO flowchart to import/export an associated resource or workbook, you can enclose the resource/workbook name in single quotes to reference it by name only. For example, if you export a diagram that contains a block using the expression `'Model1'(1000)`, Model1 will not be transferred along with that diagram. If the destination project already contains a model called Model1, that model will be used in simulating the transferred diagram.

---

**Importing from Excel or Delimited Text Files into a Folio**

In Weibull++/ALTA and RGA, it is easy to import data from any of the following file types into a folio.

- Excel files (*.xls, *.xlsx)
- Tab, comma, space and semicolon delimited files (*.txt, *.csv, *.prn, *.smc)

**Tip:** Other Synthesis applications use different tools for importing/exporting via Excel (i.e., for importing Bill of Materials data in Lambda Predict and failure mode data in Xfmea/RCM++/RBI and MPC). For more information about those features, please consult the documentation for each particular application.

First, open the project that you want to import into and choose **Project > Management > Import/Export**.

---

594   http://xfmea.reliasoft.com
In the wizard, choose **Other file** and click **OK**.

Browse for the file you wish to import from and click **Open**. Note that:

- In DOE design folios, the data will be copied into a new free form folio, where you can then designate columns for factors and responses and analyze the data. If you are importing from an Excel file that has multiple worksheets, the sheet that was active the last time the file was opened will be used.

- In Weibull++/ALTA and RGA, you will need to specify which data will be imported and how it will be mapped to the columns in the particular type of data folio. The rest of this topic describes how to map the data for import into a Weibull++, ALTA or RGA data folio.

**Selecting Which Data Sheets Will Be Imported**
The left side of the utility displays the data from the Excel or delimited text file that is currently selected. If you wish to open a different source file, click **Open**.

If you are importing from an Excel file that has multiple worksheets, use the tabs at the bottom of the window to view and set the import preferences for each sheet.

Use the options at the top of the control panel for each sheet to specify whether the data will be imported.

- **Do not import sheet**: The control panel will not contain any other options and the data will not be imported.

- **Import sheet**: The control panel displays the options you need to either manually map the columns or use a template to automatically apply the same mapping that was used for another file.

**Using the Control Panel to Map the Columns That Will Be Imported**
If you are not using a template, or if you need to modify the settings after an import template has been applied, do the following:

1. Use the **Data Type** drop-down list to specify which type of folio to import into. This can be different for each sheet, and it determines which options will be available in the rest of the control panel.

2. Click inside each column that you wish to import and then click the corresponding button in the control panel to map it to a column in the data folio. This updates the column heading and maps the data to a column in the data folio.

   - If the heading displays a letter, the data in that column will not be imported.
Chapter 25: Synthesis Platform Tools

- If the heading displays a name, the data will be imported to the column associated with that name.
- To remove the column mapping, click inside the column and click the corresponding button again.

As an example, the following picture shows data that will be imported into a Weibull++ life data folio. Column A will not be imported. The rest of the data has been assigned to columns that are used in the folios.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>Number in State</th>
<th>Last Inspected</th>
<th>State F or S</th>
<th>Time</th>
<th>Subset ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>Row #</td>
<td>Qty</td>
<td>F/S</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>1</td>
<td>5</td>
<td>0</td>
<td>6.12</td>
<td>Mode 5</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>2</td>
<td>16</td>
<td>F</td>
<td>19.92</td>
<td>Mode 3</td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>3</td>
<td>12</td>
<td>F</td>
<td>29.64</td>
<td>Mode 6</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>4</td>
<td>18</td>
<td>F</td>
<td>35.4</td>
<td>Mode 6</td>
</tr>
<tr>
<td>6</td>
<td></td>
<td>5</td>
<td>18</td>
<td>F</td>
<td>39.72</td>
<td>Mode 1</td>
</tr>
<tr>
<td>7</td>
<td></td>
<td>6</td>
<td>2</td>
<td>F</td>
<td>45.24</td>
<td>Mode 2</td>
</tr>
<tr>
<td>8</td>
<td></td>
<td>7</td>
<td>17</td>
<td>F</td>
<td>52.32</td>
<td>Mode 4</td>
</tr>
<tr>
<td>9</td>
<td></td>
<td>8</td>
<td></td>
<td>F</td>
<td>63.48</td>
<td>Mode 5</td>
</tr>
<tr>
<td>10</td>
<td></td>
<td>9</td>
<td>73</td>
<td>S</td>
<td>63.48</td>
<td>End of Test</td>
</tr>
</tbody>
</table>

3. If you are importing to an ALTA life-stress data folio, use the Number of Stresses field to specify how many stress columns will be created in the new folio (maximum = 8). Note that:
   - If you enter a value that is less than the number of columns that were mapped with the Stress button, the "extra" stress column data will not be imported.
   - If the number is greater, the additional stress columns will be created in the new folio and you can enter the data later.

4. If the source file contains column headings or other introductory material that should not be imported, use the Start from Row field to specify where the actual data begins. For example, in the picture above, the first row contains heading labels so the data import should begin from Row 2.

**Setting the Import Template Directory**

If you will be importing data from multiple files that have the same structure, you can use saved template files (*.waim in Weibull++/ALTA or *.rgaim in RGA) to automatically map the columns for all other similar files that you need to import from.

By default, template files will be stored at C:\Users\<username>\AppData\Roaming\ReliaSoft\<application>\Import Templates. This

http://xfmea.reliasoft.com
directory determines which templates will be displayed in the Import Template drop-down list in the control panel. It also sets the default path for saving any new templates you create.

If you want to access templates from a different location, click the Import Template Directory button at the top of the window and select a different folder.

**Creating a New Import Template**
1. Open a data file and use the control panel buttons to map the columns.
2. Click the Save icon in the Import Template area on the control panel.
3. Specify a name and click Save.

**Applying a Saved Import Template**
1. Open the data file and select Import sheet to display the rest of the control panel options.
2. Make sure the Import Template Directory is set to the folder that contains the applicable template file(s).
3. Use the drop-down list in the Import Template area to select the template you want to apply.

The utility will automatically assign the column mappings defined in the template. If desired, you can use the control panel to make further adjustments before import.
4. When you are satisfied with the mapping, click Import to create the new folio.

**Tip:** If you make adjustments after applying the template, you have the option to click Save in the Import Template area to either replace the existing template, or create a new template with a different name.
Chapter 25: Synthesis Platform Tools

**Importing the Data**
When you are ready to import the data, click the **Import** button.

By default, the application will import the data into a new folio. The status bar will display "Import into New Folio," as shown in the following example.

If you prefer to import into an existing folio instead, click the **Import to Existing Folio** button and choose one of the available folios. When you return to the import window, the status bar will now display the name of the selected folio, as shown in the next example.

**Using XML in BlockSim and Lambda Predict**
In BlockSim and Lambda Predict, you have the option to use XML (extensible markup language) files to import or export system configuration data and item properties. XML files can be used to transfer data to/from other applications or database systems.

In BlockSim, the XML files include the block properties and information about how the blocks are connected in a reliability block diagram or fault tree diagram. They do not include visual aspects such as diagram style settings, block style settings, etc. BlockSim supports both import and export via XML.

In Lambda Predict, the XML files include the structure of the system hierarchy in a prediction folio and some of the item properties. Lambda Predict supports export to XML.

**Exporting to XML**
To create an XML file, first open the project and then choose **Project > Management > Import/Export > Export**.

In the wizard, choose **Other file** and click **OK**.

Specify the desired pathname/filename and click **Save**. This will export the relevant information for all of the diagrams or prediction folios in the current project. Other project items (such as RENO flowcharts, plots, attachments, etc.) are not included.

**Importing from XML**
There are two ways to import from an XML file.
If you want to import to a new project in a new standard database:

2. Browse for the file and click Open.

If you want to import to a selected project in an existing standard database or enterprise database:

1. Create a new project or open an existing project that you want to import into.
2. Choose Project > Management > Import/Export > Import.

   In the wizard, choose Other file and click OK.
3. Browse for the file and click Open.

Attachments

All Synthesis desktop applications allow you to attach URLs and/or files that were created in other applications. This helps you to keep supporting documentation all together in the same place with your analysis. The locations where you can attach files will vary depending on which Synthesis application you are using.

In all Synthesis desktop applications, attachments can be either linked or embedded.

- **Linked** attachments may be URLs or files. For these attachments, the software stores the path to the URL or file. This allows you to open the resource in its original location (e.g., Internet, intranet or network directory), provided that the necessary software is installed on your computer and the link is valid. The files themselves are not stored inside the database. If your organization chooses to implement a web-based Synthesis Enterprise Portal (SEP) for an enterprise database, note that File Links (i.e., stored paths to local files on your computer or network) will not be accessible in most web browsers due to security settings. When you delete a file link or URL, this simply removes the link, leaving the original file untouched.

- **Embedded** attachments are always files (i.e., you cannot embed a URL). For these attachments, the software stores a complete copy of the attached file inside the database. Please note that embedded attachments will increase the file size of the database. When you delete an embedded file, the actual file is deleted from the database and this cannot be undone (unless you happen to have a saved backup or restore point that you could roll back to).
Two windows are used to work with attachments. The Attachments window allows you to manage all of the URLs/files attached to a particular location (e.g., project, resource, hierarchy record or block).

The Add/Edit Attachment window is used to specify the details of an individual file or URL, and will be displayed whenever you choose to create or edit an attachment.

If you are attaching a file, the Address field will display a Browse icon (🔎) so you can select the file to be attached.
If you are attaching a URL, the **Name** field will be populated automatically as you type the URL into the **Address** field. This is for your convenience only and you can specify a different name if desired.

### Attachment Locations
As mentioned above, the locations where you can attach files will vary depending on which Synthesis application you are using.

*Tip*: In most cases, the caption bar in the Attachments window will provide an indication of which type of attachment you are working with. For example, when you are working with project-level attachments, the caption bar will indicate "Project:" followed by the specific name of the project.

### Project Attachments
All Synthesis desktop applications support attachments at the project level. In all applications, project attachments can be displayed/managed from the **Attachments** icon in the Project Properties window.

For most applications, project attachments can also be displayed/managed from the Attachments folder in the current project explorer.

In Xfmea, RCM++, RBI and MPC (which do not have a current project explorer), you can also access the project attachments by selecting **Project > Synthesis > Attachments**.

### Synthesis Resource Attachments
All of the applications that utilize Synthesis resources support attachments at the resource level. For example, you can attach a file to a URD, a model, etc.
To access attachments for an existing resource, you can click the **Attachments** icon in the resource's properties window.

**Hierarchy Attachments**

Some applications, including Xfmea, RCM++, RBI, Lambda Predict and MPC, support attachments for individual items or records in a system hierarchy or analysis hierarchy. For example, in Xfmea, you can create attachments for a particular item, or for a particular record in the FMEA for that item.

To access attachments for items or records in a hierarchy, you can double-click inside the Attachments column. (If this column is not displayed on your computer, right-click inside the column headings and choose **Customize Columns**.) You can also choose **Tools > Attachments** on the ribbon tab for the hierarchy that you are currently working with.

For records in an analysis hierarchy (such as FMEA or functional failure analysis), the attachment icon can also be accessed from within the record properties window.

**Block Attachments**

BlockSim supports attachments for individual blocks in a diagram. To access attachments for a block, you can click the **Attachments** icon in the Block Properties window.

**Select Existing Text Window**

The Select Existing Text window provides a list of existing descriptions that might apply to the current text field or analysis. This can help to save time on data entry, ensure consistency and facilitate brainstorming. The utility is used extensively in applications such as Xfmea, RCM++, RBI and MPC, and it is also available for certain text fields in other Synthesis desktop applications.
In Version 11, there are now two ways this utility might be used:

- **Replace or append text in the current field** - If you click the icon inside a text field, you can select one description and either replace the current text or append the new text to the end.

- **Create one or multiple new records** - If you use one of the ribbon commands in an FMEA or P-Diagram (e.g., Add Multiple Functions > Select Existing Text), you can select multiple descriptions and the utility will use your selection(s) to create new record(s).

The options will vary depending on the record/field type, and whether you are updating a single description or adding new records. The following example shows how the tool may be used to populate the function description in an FMEA.

![Example Image]

**Tip:** The descriptions are sorted alphabetically under each heading. When the table has focus, you can type a letter to move to the next description that begins with the letter.

**Project and Item Filters**

This window utilizes the same project and item filters that are available in many other locations throughout Synthesis desktop applications. For example, when searching for text for an item in the system hierarchy, you could use a Project Filter to search for analyses performed by Department A and then use an Item Filter to show only those analyses that were modified in the last month.

![Example Image]

In addition, when applicable:

- **Current Project** limits the results to data in the current project.
• **Phrase Sets Only** limits the results to entries in phrase sets.

• **Current Item** limits the results to those found in the currently selected system hierarchy item.

• **Parent Item** limits the results to those found in the parent of the currently selected system hierarchy item.

• **Current Item Branch** limits the results to those found in the current branch of the system hierarchy.

**Record Filter**
When applicable, the **Record Filter** shows the possible sources for the current record type and field that you can choose to include or exclude. The specific **record types** vary depending on the field.

**Phrase Sets**
FMEA records in Xfmea, RCM++ and RBI also have the option to include text from selected phrase sets.
**Field Text**

Use the drop-down list in the Field Text area to specify how to match the specified keywords, then type the keywords into the input box.

- **Contains** returns descriptions that contain the exact string entered.
- **Contains Any** and **Contains All** allow you to enter multiple keywords (separated by commas) and returns descriptions that contain at least one (any) or all of the keywords entered.
- **Begins With** returns descriptions where the exact string entered appears at the start of the field.
- **is** returns descriptions where the exact string entered matches the whole field.

**Record Filter Options**

When the descriptions can be obtained from more than one type of analysis (e.g., when PFMEA failures can be copied from FMEA causes, or when control plan operations can be copied from PFD Worksheet operations), the headings in the table identify the source. You can use the Record Filter to specify which source(s) to include.

**FMEAs**

<table>
<thead>
<tr>
<th>FMEA Functions</th>
<th>System Hierarchy Items</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>P-Diagram Ideal Responses</td>
</tr>
<tr>
<td></td>
<td>PFD Worksheet Operations</td>
</tr>
<tr>
<td><strong>FMEA Failures</strong></td>
<td>P-Diagram Error States</td>
</tr>
<tr>
<td></td>
<td>FMEA Causes</td>
</tr>
<tr>
<td></td>
<td>PFD Worksheet Product Characteristics</td>
</tr>
<tr>
<td><strong>FMEA Effects</strong></td>
<td><strong>FMEA Failures</strong></td>
</tr>
<tr>
<td><strong>FMEA Causes</strong></td>
<td>P-Diagram Change Over Times</td>
</tr>
<tr>
<td></td>
<td>P-Diagram Control Factors</td>
</tr>
<tr>
<td></td>
<td>P-Diagram Piece-to-Piece</td>
</tr>
<tr>
<td></td>
<td>PFD Worksheet Process Characteristics</td>
</tr>
<tr>
<td><strong>FMEA Controls</strong></td>
<td>Control Plan Methods</td>
</tr>
<tr>
<td></td>
<td>DVP&amp;R Test/Specification Methods</td>
</tr>
<tr>
<td><strong>FMEA Actions</strong></td>
<td>DVP&amp;R Test/Specification Methods</td>
</tr>
</tbody>
</table>
## P-Diagrams

<table>
<thead>
<tr>
<th>Input Signal</th>
<th>System Hierarchy Items</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control Factors</td>
<td>FMEA Causes</td>
</tr>
<tr>
<td>Error States</td>
<td>FMEA Failures</td>
</tr>
<tr>
<td>Ideal Response</td>
<td>FMEA Functions</td>
</tr>
<tr>
<td>Piece-to-Piece</td>
<td>Analysis Plan Assumptions</td>
</tr>
<tr>
<td></td>
<td>FMEA Causes</td>
</tr>
<tr>
<td></td>
<td>PFD Worksheet Product Characteristics</td>
</tr>
<tr>
<td>Usage</td>
<td>Analysis Plan Assumptions</td>
</tr>
<tr>
<td>Environment</td>
<td>Analysis Plan Assumptions</td>
</tr>
<tr>
<td>Change Over Time</td>
<td>Analysis Plan Assumptions</td>
</tr>
<tr>
<td></td>
<td>FMEA Causes</td>
</tr>
</tbody>
</table>

## Control Plans, PFD Worksheets and DVP&Rs

<table>
<thead>
<tr>
<th>Control Plan Part/Process Number</th>
<th>FMEA Functions</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>PFD Worksheet Operations</td>
</tr>
<tr>
<td>Control Plan Process Name/Operation Description</td>
<td>FMEA Functions</td>
</tr>
<tr>
<td></td>
<td>PFD Worksheet Operations</td>
</tr>
<tr>
<td>Control Plan Product Characteristic</td>
<td>PFD Worksheet Product Characteristic</td>
</tr>
<tr>
<td></td>
<td>FMEA Causes</td>
</tr>
<tr>
<td></td>
<td>FMEA Failures</td>
</tr>
<tr>
<td>Control Plan Process Characteristic</td>
<td>PFD Worksheet Process Characteristics</td>
</tr>
<tr>
<td></td>
<td>FMEA Causes</td>
</tr>
<tr>
<td>Control Plan Method</td>
<td>FMEA Controls</td>
</tr>
</tbody>
</table>
Check Spelling

Synthesis desktop applications offer the ability to check the spelling of your text. This utility is available in different places within the software. For windows that offer the spell check functionality (e.g., Project Properties window, etc.), the Check Spelling icon will be displayed within the window itself. For data sheets, spreadsheets and system hierarchies that offer the functionality, the Check Spelling icon will be available on the ribbon and you can access it by choosing **Home > Edit > Spelling**.

*Note:* In system hierarchies (Xfmea, RCM++, RBI, MPC and Lambda Predict), the utility will check the property fields of the selected item only. This means that sub-items and text in analysis tabs, such as the FMEA tab in Xfmea, are not checked.

Whenever text that is not in the application's dictionary is found, the Check Spelling window displays the text in question and offers a list of suggestions to verify the error or confirm the correction, as shown in the following example.

![Check Spelling Window](image)
• **Ignore Once** ignores the current instance of the highlighted word but continues to highlight it if the same word appears again.

• **Ignore All** ignores all instances of the word in the current form.

• **Add to Dictionary** adds the highlighted word to the dictionary on your computer so the spell checker will not treat it as a misspelling. The dictionary file is saved in the default Documents folder on your computer (e.g., My Documents\ReliaSoft\Dictionaries).

• **Change** replaces the current instance of the highlighted word with the word that is currently selected in the **Suggestions** area. If no word is selected, the first one will be used. Double-clicking a word in the **Suggestions** area is another way to change the highlighted text.

• **Change All** replaces all instances of the highlighted word with the word that is currently selected in the **Suggestions** area. If no word is selected, the first one will be used.

• **Options** opens the Spelling Options window, which provides additional settings to how the spell checker functions:
  
  - The **General options** area provides a list of the types of text that can be ignored by the spell checker (e.g., numbers, e-mail addresses, etc.). Select or clear each check box to specify how the spell checker will work on your computer.
  
  - In the **Edit custom dictionary** area, the **Edit** button opens a window that displays all of the words that you have added to the custom dictionary on your computer. You can edit the custom dictionary by adding or removing words in the list and then clicking **OK**.
  
  - **International dictionaries** allows you to choose the language of the dictionary that will be used on your computer.
  
  • **Undo Last** reverses the last change that was made.

---

**Results Window**

The Results window is used in many Synthesis applications to show detailed calculation results. From this window, you can edit the results, copy the results to the Clipboard or print the results.

• **Paste** pastes the contents of the Clipboard into the current control.

• **Cut** cuts the selected text to the Clipboard. Data stored in the Clipboard can be pasted into this and other applications.
• **Copy** copies the selected text to the Clipboard. Data stored in the Clipboard can be pasted into this and other applications.

• **Paste Special** opens the Paste Special window, which allows you to paste specific cell contents or attributes (such as formulas, formats, or comments) from the Clipboard.

• **Quick Print** sends the current document directly to the default printer without making changes.

• **Print** opens the Print window, which allows you to specify the printer and the printing options.

• **Send to Excel** allows you to save the current selection as a Microsoft Excel (*.xls) file and then opens that file in Excel, if it is installed on your computer.

Note that the Results window may contain multiple sheets, accessible via the page index tabs at the bottom of the window.

**Quick Parameter Estimator (QPE)**

The Quick Parameter Estimator (QPE) allows you to estimate the parameters of a distribution based on information you have about the reliability of a product, the probability of an event occurring or the typical duration of a task. In all Synthesis desktop applications, you can open the QPE from the Model properties window or the Model wizard by clicking the QPE icon.

In Weibull++/ALTA, it's also accessible from the Home tab of the ribbon and several analysis interfaces (including the Weibull++ life data folio, the Monte Carlo and SimuMatic utilities, and the Expected Failure Times Plot).

The QPE includes a Wizard view and an Expert view, described below. You can toggle between the different views by clicking the **Use Expert** or **Use Wizard** button at the bottom-left corner of the window.

• **The Wizard view** automatically selects a distribution and estimates that distribution's parameters based on your responses to a series of questions. The first page of the Wizard view asks you to choose among three different types of models that you can build with the QPE. Subsequent pages will ask more specific questions related to your selected model.

• **The Expert view** allows you to estimate the parameters of a distribution using either two unreliability values at specified times or one unreliability value and the other parameter(s) of the distribution. Unlike the Wizard view, you must select a distribution to solve the parameter(s) for.
Quick Parameter Estimator Wizard View

To use the Wizard view of the Quick Parameter Estimator (QPE), simply follow the prompts on each page. The first page will present and describe three different types of models that you can build with the QPE. Below are the three models and the kind of information you'll need to provide in subsequent pages.

To build a **Reliability model** you need to provide information about:

- How age affects the product's reliability.
- The product's intended design life and the estimated warranty time.
- Best-case, worst-case and most likely unreliability estimates for the product at the end of the design life and warranty time.

To build an **Event occurrence model** you need to provide information about:

- Whether age affects the probability of the event's occurrence.
- Best-case, worst-case and most likely estimates for how often the event will occur.

To build a **Task duration model** you need to provide information about:

- Best-case, worst-case and most likely estimates for how long it will take to complete the task.

The last window will display the tool's selected distribution and the calculated parameters. It will also provide one of the two options described below.

- If you opened the QPE from an analysis folio or utility, the **Update** button will be available in case you wish to update that window using the selected distribution, calculated parameters and selected time units.
- In Weibull++/ALTA, if you opened the QPE from the ribbon, the **Finish & Copy** button will be available in case you wish to copy the parameters results to the Windows Clipboard.
Quick Parameter Estimator Expert View

Follow the steps below to use the Expert view of the Quick Parameter Estimator (QPE):

- Choose a distribution from the **Distribution** drop-down list. This is the distribution that you will solve the parameter(s) for. Then choose the appropriate time units from the **Units** drop-down list.
  - If you are not sure which distribution to select, consider using the **Wizard view** of the QPE instead.
  - Your choice of time units applies to all time inputs and applicable parameters of the distribution (such as the eta parameter when the Weibull distribution is used).
- Select an appropriate option in the **Quantification Method** area.
  - The **Unreliability and a Parameter** method solves for one parameter of the distribution. It requires one unreliability point (i.e., an unreliability value at a specified time) and the values of all the parameters of the selected distribution except the parameter you will solve for.
    - If you select this method, you must then enter one unreliability point in the **Point #1** area. For example, if you believe that your product has an unreliability of 10% at 100 hours, then you would enter **100** in the **Time** field and **0.10** in the **Unreliability** field.
    - In the **Solve for Parameter** area, select the parameter that you wish to solve for. The remaining parameters in this area will have input fields enabled. Enter the known values of these parameters.
  - The **Two Unreliability Points** method solves for all the parameters of the distribution. It requires two unreliability points that you will provide in the **Point #1** and **Point #2** areas.

| **Tip:** If you are building an event occurrence or task duration model, you can treat an "unreliability" point as the probability that an event will occur or that a task will be completed by a specified time. For example, if you are modeling the probability of an event's occurrence and you believe that there is a probability of 30% that the event will occur before 150 hours, then you would enter **0.3** in the **Unreliability** field and **150** in the **Time** field.

- Click **Calculate** to solve for the unknown parameter(s).
- Click the **Update** button to update the model using the selected distribution, calculated parameters and selected time units.
Quick Parameter Estimator (ALTA)

In ALTA only, another version of the Quick Parameter Estimator (QPE) allows you to estimate the parameters of a model based on information you have about the reliability of a product at normal and accelerated stress levels. You can open the QPE from the ribbon by choosing Home > Tools > Quick Parameter Estimator (ALTA).

You can also open the ALTA QPE from the ALTA life-stress data folio (by leaving the folio’s data sheet empty and clicking Calculate), as well as the stress-dependent Monte Carlo and stress-dependent SimuMatic utilities.

Follow the steps below to use the ALTA QPE:

- The first page of the window will be used to estimate the product’s mean life under normal stress conditions.
  
  - Choose a model from the Model drop-down list. This is the model that you will solve the parameter(s) for. Then choose the appropriate time units from the Units drop-down list.
    
    - Your choice of time units applies to all time inputs and applicable parameters of the model (such as the eta parameter when the Weibull distribution is used).

- Select an appropriate option in the Quantification Method area:
  
  - The Unreliability and a Parameter method solves for one parameter of the model. It requires one unreliability point (i.e., an unreliability value at a specified time) and the values of all the parameters of the selected model except the parameter you will solve for.
    
    - If you select this method, you must then enter one unreliability point for normal use conditions in the Point #1 area. For example, if you believe that your product has an unreliability of 10% at 100 hours under normal use conditions, then you would enter 100 in the Time field and 0.10 in the Unreliability field.

- In the Solve for Parameter area, select the parameter that you wish to solve for. The remaining parameters in this area will have input fields enabled. Enter the known values of these parameters.

- The Two Unreliability Points method solves for all the parameters of the model. It requires two unreliability points under normal use conditions that you will provide in the Point #1 and Point #2 areas.
• In the **Use Stress Level** area, you must enter the stress level that the product will experience under normal conditions. In multi-stress situations, this stress level will be a combination of stress values for each stress type.

• If the **Number of Stresses** field is enabled, enter the number of stresses that will be used in your model. (Note that different models have different requirements for the number of stresses that can be used.)

• Click the arrow inside the **Use Stress Value(s)** field. In the table that appears, enter a stress value for each stress type. If there are multiple stress values, they will appear in the field separated by semicolons.

• Click **Next >** to go to the Life at Each Stress Level page. The **Use Stress Level** area of the page will display the product’s mean life at the specified use stress level based on your previous inputs. In the **Accelerated Level 1** area, you must enter the estimated mean life for the product at an accelerated stress level.

• To enter the accelerated stress level, double-click inside the **Stress Value(s)** field. In the table that appears, enter the stress value for each stress.
In the **Characteristic Life** field, enter the product's characteristic life at the associated accelerated stress level.

- For the Weibull distribution, the characteristic life is equal to the value of the eta parameter (i.e., the time at which unreliability = 63.2%).
- For the lognormal distribution, it is equal to Exp(Log-mean) (i.e., the time at which unreliability = 50%).
- For the exponential distribution, it is equal to the mean life.

**Note:** The number of accelerated stress levels you must provide life estimates for will equal the number of stresses that will be used in the selected model. For example, if the model uses two stress types, as shown above, then there will be an **Accelerated Life 2** area in which you must provide a characteristic life estimate for a second accelerated stress level.
• Click **Next >** again to see the calculated parameters.

  • If you opened the QPE from another utility, such as the ALTA Monte Carlo tool, you may click the **Update** button if you wish to update the Monte Carlo tool with the model, parameters and time units defined in the QPE.

  • If you opened the QPE from the ribbon, you may click the **Finish & Copy** button if you wish to copy the results to the Windows Clipboard.
Chapter 26: Synthesis Resources

In Synthesis applications except MPC, resources contain various types of information that can be shared between analyses. Resources may be created in one application and then shared with other Synthesis applications where they may be relevant. When the resource is updated with new information, the change is reflected in all analyses that rely upon it.

An example of a Synthesis resource is a model that represents a product's probability of operating successfully over time. The model may be defined manually or published from an application such as Weibull++/ALTA, RGA or Lambda Predict. Then it can be used in applications such as BlockSim, Xfmea, RCM++ or RBI as part of the universal reliability definition (URD) of a particular component/assembly.

**Note:** In a secure database, the ability to create, edit and delete resources is available only if the user a) is the project owner, b) has the applicable "resources" permissions, or c) has the applicable "manage all projects" permissions.

### Types of Resources

The following tables describe the types of resources that you can use in different Synthesis applications. These resources can be created while you're performing an analysis and also from the Resource Manager. (In a secure database, the ability to create, edit and delete resources is available only if the user a) is the project owner, b) has the applicable "resources" permissions, or c) has the applicable "manage all projects" permissions.)

#### Used in Multiple Applications

<table>
<thead>
<tr>
<th>Resource</th>
<th>Used In</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Universal reliability definitions (URDs)</strong> describe a set of reliability and maintenance characteristics for a particular component/assembly.</td>
<td>BlockSim, RCM++, Xfmea, RBI</td>
</tr>
<tr>
<td><strong>Variables</strong> store numerical values that can be programmatically varied during simulation.</td>
<td>BlockSim, RENO</td>
</tr>
</tbody>
</table>
## Models

Models can represent probabilities, durations or costs, either fixed or time-dependent. They are used by other resources to represent the reliability of a component, the duration of a task, the expected cost of a repair, etc.

Can be published from analyses in Weibull++, ALTA, BlockSim, RGA and Lambda Predict, or created manually.

Used in BlockSim, RENO, Xfmea, RCM++ and RBI.

## Tasks

Tasks represent maintenance activities:

- **Corrective** tasks are unplanned maintenance performed when a failure occurs.
- **Scheduled** tasks can include preventive maintenance, inspections and on condition maintenance.

BlockSim, RCM++, RBI

## Task packages

Task packages represent groups of tasks that are performed together at scheduled intervals.

BlockSim, RCM++, RBI

## Crews

Crews represent the personnel who will perform a maintenance task.

BlockSim, RCM++, RBI

## Spare part pools

Spare part pools determine whether a spare part will be available, how long it will take to obtain and how much it will cost.

BlockSim, RCM++, RBI

## Metrics

Metrics display any numerical value of interest, and track how it changes over time.

All applications except MPC via the Project Planner; analyses in Weibull++, ALTA, BlockSim, RGA, Xfmea, RCM++ and RBI

## Maintenance groups

Maintenance groups are used to model situations in which some event within the group can trigger maintenance or state changes for other components/assemblies.

BlockSim, RCM++, RBI

## Mirror groups

Mirror groups are used to represent the exact same component/event in more than one location within your analysis.

BlockSim, RCM++, Xfmea, RBI
### Actions

Actions describe specific assignments that need to be performed.

| All applications via My Portal; Project Planner and FMEAs in RCM++, RBI and Xfmea |

### Controls

Controls may be used in FMEAs and/or control plans to represent methods to reduce or eliminate the risk associated with potential failures.

| RCM++, Xfmea, RBI |

---

#### Used Only in BlockSim

<table>
<thead>
<tr>
<th>Resource</th>
<th>Used In</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Switches</strong> describe how the activity transfers between active and standby blocks in BlockSim's standby containers/gates.</td>
<td>BlockSim</td>
</tr>
<tr>
<td><strong>Maintenance templates</strong> define the activities that will be performed during a maintenance phase in a phase diagram.</td>
<td>BlockSim</td>
</tr>
</tbody>
</table>

#### Used Only in RENO

<table>
<thead>
<tr>
<th>Resource</th>
<th>Used In</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>RENO functions</strong> store equations that are evaluated based on input values passed to the function during simulation.</td>
<td>RENO</td>
</tr>
<tr>
<td><strong>RENO static functions</strong> store equations that are evaluated before simulation begins.</td>
<td>RENO</td>
</tr>
<tr>
<td><strong>RENO simulation definitions</strong> are used to trigger simulation of a BlockSim diagram from within a RENO flowchart, allowing you to use one or more results from the simulation in the flowchart.</td>
<td>RENO</td>
</tr>
<tr>
<td><strong>RENO tables</strong> store arrays of values in rows and columns.</td>
<td>RENO</td>
</tr>
</tbody>
</table>
Chapter 26: Synthesis Resources

**Used Only in ALTA**

<table>
<thead>
<tr>
<th>Resource</th>
<th>Used In</th>
</tr>
</thead>
<tbody>
<tr>
<td>Profiles</td>
<td>ALTA</td>
</tr>
</tbody>
</table>

**Profiles** represent values that vary with time. They can be used to describe stress levels under test conditions.

---

**Local, Global and Reference Resources**

There are three types of resources:

**Local resources** can be used only within the project in which they were created, and are therefore available only to users with permissions within that project.

**Reference resources** (which are resources created in a reference project) can be used in any project throughout the database. However, in a secure database, they can be created and edited only by users who have the "Create/edit/delete local resources" permission within the reference project. These resources can be selected by any user who has at least the "Read" permission in the reference project. Users without permissions in the reference project can see the reference resources wherever they are used, but they will not be able to select or modify them.

**Global resources** can be used in any project throughout the database. In a secure database, they can only be created and edited by users who have the “Create/edit/delete global resources” permission. However, they can be selected by any database user.

To make a resource global, select it in the Resource Manager and choose **Home > Actions > Make Global**.

Making a resource global cannot be undone and this option is not available for all resource types. If you make a resource global, any resources assigned to it will become global as well (e.g., if a URD has an assigned model, making that URD global will also make the model global, regardless of whether it was originally local or reference).

**Parent/Child Resource Relationships**

Certain resources can have other resources assigned to them (e.g., URDs can have models and tasks assigned to them, tasks can have models, crews and spare part pools assigned to them, etc.). This can be considered a "parent/child" relationship.
When you create a resource from within its parent, the child resource will be of the same type as its parent. For example, if you are working with a global URD and you add a model to it, the model will be global. If you are working with a reference task and you add a crew to it, the crew will be added to the reference project that contains the task.

When you assign existing resources to a parent resource, the following rules apply:

- Any resource assigned to a reference resource must be either a reference resource within the same project or a global resource (e.g., a local model cannot be assigned to a reference URD, nor can a model in "Reference Project 2" be assigned to a URD in "Reference Project 1").

- Any resource assigned to a global resource must be either a reference resource or a global resource (e.g., a local model cannot be assigned to a global URD).

**Keeping Resources Together**

The application will automatically keep copies of a project’s resources and linked FMEAs when the project is restored, checked out, imported or exported.

- When you create a **restore point**, any reference resources, global resources or linked FMEAs used in the project are converted to local resources/FMEAs and stored with the backup.

- When you **check out** a project for local editing, any reference resources, global resources or linked FMEAs used in the project are converted to local resources/FMEAs and stored with the project.

- When **importing/exporting a project item** that uses reference resources, global resources or linked FMEAs:
  - If you import/export within the same database, the references will remain unchanged.
  - If you import/export between databases, the destination project will contain local copies of the original resources/FMEAs.

- When **importing/exporting a project**:
  - If you import/export a project that uses global resources, the destination project will contain local copies of the original resources.
  - If you import/export a project that uses reference resources or linked FMEAs:
    - The references/FMEAs will be maintained if you also import/export the reference project at the same time.
• If you don’t import/export the reference project at the same time, the new project will instead contain copies of the original resources/FMEAs.

Creating and Selecting Resources
This topic describes how to use resource wizards to create and edit Synthesis resources while you’re performing an analysis or creating a URD. In addition, you may also need to:

• Use the Resource Manager to see all of the resources that are available to use in the current project. In addition to creating and editing resources, the manager also allows you to:
  • Delete resources that are no longer needed.
  • Create global resources that are available to all projects in the database.
• Publish a model that is linked to an existing analysis.

(In a secure database, the ability to create, edit and delete resources is available only if the user a) is the project owner, b) has the applicable "resources" permissions, or c) has the applicable "manage all projects" permissions.)

Opening a Resource Wizard
Throughout all Synthesis desktop applications, the availability of a resource wizard is usually indicated by an ellipsis (...) or an arrow in the resource field. Simply click twice in the field to open the wizard.
Tip: If a resource is already assigned in the field, you can edit it directly without opening the wizard by clicking the Edit icon that appears in the field.

Back Arrow and Main Page
Each wizard contains multiple pages with different options on each page. If the option you need is not immediately visible, you can click the Back arrow to see the Main page, which shows all the options that are applicable for the current situation.

As an example, the following pictures show some of the different options that will be available on the Main page for specific situations and resource types.
Chapter 26: Synthesis Resources

If a model hasn't been defined...

If a task hasn't been defined...

If a task has already been defined...

Selecting an Existing Resource

The Select page of the wizard displays a list of existing resources that meet the criteria specified on the Settings page. You can then further limit the list by typing inside the text box.

As an example, the following pictures show a situation in which the settings are configured to display up to 2,000 models (more resources take longer to load) from the current project only (called local resources), and the user has selected to see only the ones in which the name includes “bulb.”
In addition, for model resources only, you must specify whether you want to display the model parameters in the list (which also takes longer to load); and if so, the number of decimal places (called Parameter Precision) and the point at which the software will switch to scientific notation (called Parameter Tolerance).

To change the initial criteria for the list, click the Back arrow and then click the Settings button on the main page.

Alternatively, if you need more information about the available resources and/or a wider range of filtering tools, you can click the icon to open the Select Resource window.

**Creating a Resource**

In most wizards, you can click the Create New button or icon to create a new resource.

In the model wizard, click the button or icon for the type of model you want to create:

- New Constant
- New Distribution
- New Dynamic

**Editing a Resource**

If a resource has already been assigned, you can view and/or edit its properties by clicking the View/Edit button or icon in the field or in the wizard.

Any changes you make will apply everywhere that the resource is used. This includes analyses in other Synthesis applications.

**Removing a Resource**

If a resource has already been assigned, you can remove it from this location by clicking the Remove button or icon.
Chapter 26: Synthesis Resources

The resource will remain in the database for use in other locations. If you want to completely remove a resource from the database, you’ll need to use the Resource Manager or Select Resource window.

Universal Reliability Definitions (URDs)

A universal reliability definition (URD) describes a set of reliability and maintenance characteristics for a particular component/assembly. Like any other Synthesis resource, you can create or edit URDs while you’re performing a relevant analysis, and from the Resource Manager.

Note: Depending on where you are using a URD, only those properties that are relevant are applied. For example, if you apply a URD to a block in an analytical diagram in BlockSim, only the failure model associated with the URD will be applied to the block.

Naming the Resource

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the Synthesis resources you need for your analyses.

Hierarchy Tab

Use the Hierarchy tab to view and/or edit the URD's properties. You can choose or create:

- A model to describe the behavior associated with the URD. This can be a reliability model, a probability of failure model or an event occurrence model.

- A corrective task that describes the maintenance action taken to restore a failed component to operational status.

- Zero, one or many scheduled tasks that describe the preventive maintenance, inspections and/or on condition maintenance tasks. The order in which the tasks are displayed reflects the priority with which tasks that are scheduled in the same way (see Task Scheduling) will be performed; for example, if there are two tasks scheduled based on interval and they conflict, the task higher in the priority list will be performed and the lower priority task will be disregarded. You can use the up and down arrows in the cells in this column to move the tasks up and down the priority list.
Additionally, the following are shown:

- **Identifiers** contains additional identifying information that can be used to search for this resource.

- **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the resource.

- **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

## Filtered Tab

Use the Filtered tab to see the resources that are shown in the Hierarchy tab, filtered by resource type. For example, the following picture shows the crews used in this URD.

![Filtered Tab Example]

Double-click any row to view or edit the properties of the resource.

You can change the columns shown in this view by clicking the Column Chooser icon.
Chapter 26: Synthesis Resources

Trace Usage
For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

Models
In Synthesis applications, models can represent probabilities, durations or costs, either fixed or time-dependent. They are used by other resources to represent the reliability of a component, the duration of a task, the expected cost of a repair and many other characteristics.

Like any other Synthesis resource, you can create or edit models while you’re performing a relevant analysis, and from the Resource Manager. In addition, you can publish models that are based on an existing analysis (e.g., a life data analysis in Weibull++, a diagram in BlockSim, etc.).

This topic describes the properties for both types of models. The interface will vary based on the particular situation.

Naming the Resource
For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the Synthesis resources you need for your analyses.

Associated Analysis
In published models only, the Associated Analysis area identifies the analysis that the model is based on. If the published model reflects the latest analysis results, the status is "Synchronized." If the analysis has been modified since the model was last published, the status is "Out of Sync."

Tip: If you have the ability to open the original analysis (i.e., if the required Synthesis application is activated on your computer and your user account has permissions to access the analysis), the Source will be configured as a link and there will also be a Data Source button at the bottom of the window.

Model Category
The category determines where and how a model can be used. If you are using a resource wizard to create a new model, it will be assigned automatically based on what’s relevant for the
current field. If you are publishing a model or creating it from the Resource Manager, you must select the appropriate option. Once a model has been created, you cannot change its category.

- **Reliability, Probability of Failure** and **Event Occurrence** models represent a likelihood of occurrence.
- **Duration** models represent a length of time.
- **Cost per Unit Time** models are used for costs that accrue over time (e.g., the crew charges $50 per hour).
- **Cost** models are used for costs that don't depend on time (e.g., the part costs $100 or the crew charges $50 per service call in addition to their hourly rate).

### Model Type

- A **distribution** model represents behavior that varies based on factors such as time and/or applied stress. For a published model, the inputs and parameters will be specified automatically based on the associated analysis. For manually created models, you can:
  - Select a distribution from the drop-down list and then enter the required parameter(s).
  - Use the [Quick Parameter Estimator (QPE)](Quick Parameter Estimator) to estimate the parameters of a distribution based on what you know about the behavior.

**Tip:** A published model includes one additional parameter that is not relevant for manually created models. **PNZ** stands for **percent non-zero**. A value of 1 indicates that there are no zero failure times in the data set (which is the most common scenario in life data analysis). A decimal value indicates that the data set does include zero failure times (such as out-of-the-box failures, for example). In such cases, the parameters are calculated based on the non-zero failure times, and then the PNZ value is used as a multiplier when calculating certain metrics (e.g., reliability, unreliability).

- A **constant** model represents a fixed probability (e.g., 0.9), duration (e.g., 2 hours) or cost (e.g., $10 or $10 per hour).
- A **dynamic** model represents a fixed probability, duration or cost, based on a specified variable. The variable can then be programmatically varied during simulation in one of two ways, thereby changing the value of the model for successive simulation runs.
  - For RENO flowcharts, the variable can be varied using RENO’s sensitivity analysis/multiple analyses features.
  - When simulating a simulation worksheet, the values used by the variable will be specified in the worksheet.
Chapter 26: Synthesis Resources

When dynamic models are used outside of these circumstances, they are treated as constant models using the defined initial value of the variable.

**Additional Tools**

Additionally, the following are shown:

- **Identifiers** contains additional identifying information that can be used to search for this resource.

- **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the resource.

- **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

**Publishing Models**

This topic provides general information about how to create and work with published models, which are model resources that have been published from and continue to be associated with an existing analysis. For information about additional options and requirements in specific applications, see:

- "Publishing Fitted and Analytical Models" in the BlockSim documentation.
- "Publishing Models from R-DOE Results" in the Weibull++/ALTA documentation.
- "Publishing from Failure Rate Predictions" in the Lambda Predict documentation.
- "Publishing Models from Analysis Results" in the RGA documentation.

The Synthesis Platform does not automatically update the published model when something changes in the original analysis, but users have the option to republish the model at any time. For any other analysis that uses the model, the change will be reflected the next time that other analysis is recalculated/resimulated.
Publishing Tools

For most Synthesis desktop applications, the following model publishing tools are found on the Publishing page of the control panel. In Lambda Predict, they are located on the Publishing tab of the Properties panel.

- **Publish Model** publishes the analysis to a model, making it accessible to all Synthesis applications.
  - If the analysis has never been published, this will create a new model and you will be prompted to specify the name and category.
  - If the analysis has already been published, this will update the existing model and change the model's status from "Out of Sync" to "Synchronized."

- **Publish to Existing Model** allows you to select an existing model (using the Select Resource window) and replace it with an association to the current analysis.

- **Trace Usage** opens the Dependency Viewer, which allows you to see where the model is used.

- **View Model** displays the properties for the published model. This information will be available to any Synthesis user who is considering whether to use the model in a particular analysis.

- **Remove Association** removes the link between the current analysis and the published model. The model will continue to be a resource in the database but it can no longer be synchronized with the analysis.

Published Model Summary

After the model has been published, the summary table in the control panel (or Publishing tab in Lambda Predict) will display the model's name, along with the following details:

- When the **Status** changes from "Unpublished" to "Published," the label becomes a link that opens the model's properties window.

- **Linked?** indicates whether the published model has been used. If the model is in use, you can click the link in this field to open the Dependency Viewer.

- **Synchronized?** displays "Synchronized" if the published model reflects the latest results from the associated analysis. If that analysis has been modified since the model was last published (e.g., if more data has been added, an analysis setting has changed, etc.), the status will display as "Out of Sync."
• The Created By and Modified By fields display the names of the users who created and last updated the model. Click either of the links to see the dates and times.

**Model Basis and Status**
When a model has been published from an existing analysis, its properties window will include the following additional information:

- **Source** is the Synthesis analysis that the model was published from.
- **Application** is the Synthesis application that is required to view/edit the original analysis.
- **Type** is the kind of folio or diagram that the model is based on. For example, this might be a life data folio in Weibull++, an analytical diagram in BlockSim, a failure rate prediction in Lambda Predict, etc.
- **Status** displays "Synchronized" if the published model reflects the latest results from the associated analysis. If that analysis has been modified since the model was last published (e.g., if more data has been added, an analysis setting has changed, etc.), the status will display as "Out of Sync."

**Tip:** If you have the ability to view the original analysis (i.e., if the required Synthesis application is activated on your computer and your user account has permissions to access the analysis), the Source will be configured as a link and there will also be a Data Source button at the bottom of the window.

**Tasks**
To properly analyze repairable systems, we first need to understand how components in these systems are restored (i.e., the maintenance activities that are performed on the components). In general, maintenance is defined as any action that restores failed units to an operational condition or keeps non-failed units in an operational state. For repairable systems, maintenance plays a vital role in the life of a system. It affects the system's overall reliability, availability, downtime, cost of operation, etc.
In Synthesis applications, maintenance activities are represented using tasks, which are resources that can be shared among analyses and can be managed via the Resource Manager. There are two basic kinds of tasks, which comprise four task classes:

- **Corrective tasks** are the action(s) taken to restore a failed component to operational status. These cannot be scheduled, as the component's exact failure time is not known before it happens.

- **Scheduled tasks** can be performed on a known schedule, based on time, component condition or other factors. These include:
  - Preventive tasks
  - Inspection tasks
  - On condition tasks

Tasks are assigned to URDs, which are in turn used to represent a set of properties that can be applied to standard blocks in RBDs and to events in fault trees.

The Maintenance Task window allows you to create, view and edit all classes of maintenance tasks. It can be accessed by clicking the Create New or View/Edit icon in the Task wizard, which is accessed from Task fields in properties windows (e.g., the Corrective Maintenance Task field in the Universal Reliability Definition window).

It can also be accessed from the Corrective Tasks and Scheduled Tasks pages of the Resource Manager by choosing Home > Edit > New, by selecting a task and choosing Home > Edit > View or by double-clicking a task.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the Synthesis resources you need for your analyses.

The following options must be configured for all classes of tasks. Configuration options that are specific to particular task classes are presented in the corresponding sections.

- **Basic Task Properties**
  - **Task duration** allows you to assign a model, which may represent a fixed time or a distribution, to describe the duration of the task. You can choose an existing model or create a new one. If no model is assigned, it is assumed that the task has a duration of zero (i.e., immediate repair).
Chapter 26: Synthesis Resources

- **Crew for task** allows you to choose or create one or more crews that can perform the task. If multiple crews are assigned to the task and a crew is needed, they will be checked for availability in the order in which they are displayed in this list. Use the **Priority Up** and **Priority Down** arrows that appear when you click a crew name in the list to move it up and down in the list. If a crew is needed and all crews are engaged, the crew with the shortest wait time is chosen to perform the task.

If no crew is assigned, it is assumed that the work will be done by some undefined crew that is always available.

- **Restoration** These properties allow you to specify the degree to which the block will be restored after the performance of the task. In the **How much does this task restore the item?** field, you can specify that the item will be returned to as good as new condition (i.e., full repair, equal to a restoration factor of 1), to the same condition it was in when it failed (i.e., "as bad as old" or minimal repair, equal to a restoration factor of 0), or you can choose **Partial restoration**. This option provides you with the ability to model maintenance involving "used parts" or imperfect maintenance. The **Restoration amount** field will appear; you can specify the amount of restoration achieved by the task either by entering the value as a percentage or by clicking the arrow and using the slider bar that appears. If you specify anything other than 0% or 100%, you will need to specify what the restoration effect applies to (i.e., the restoration type). You can select:

  - **Only damage accumulated since last repair**: Each repair will remove only the damage since the last repair (i.e., the nth repair cannot remove the damage incurred before the (n-1)th repair). Note that in this context any task is considered a repair and any damage that has occurred since the last event (corrective task, preventive task, inspection or on condition task) will be reduced.

  - **All accumulated damage**: Each repair can reduce any damage accumulated up to that failure.

For simulation, the application uses the restoration factor to determine the new age of the block after the maintenance action.

For example, consider an automotive engine that fails after 6 years. If the engine is rebuilt and the rebuilding task has a 50% restoration factor:

- If **Only damage accumulated since last repair** is selected, the initial rebuild has the effect of rejuvenating the engine to a condition as if it were 3 years old.

  The engine fails again after 3 years (when it again reaches the effective "age" of 6 years), but the rebuild this time affects only the age accumulated after the first
rebuilt. Thus the engine has an effective age of 4.5 years after the second rebuild 
\(3 + 3 \times (1 - 0.5) = 4.5\).

After the second rebuild, the engine fails again after a period of 1.5 years (when it 
again reaches the effective age of 6 years) and a third rebuild is required. The 
effective age of the engine after the third rebuild is 5.25 years \((4.5 + 1.5 \times (1 - 0.5) = 5.25)\).

- If **All accumulated damage** is selected, the initial rebuild has the effect of 
  rejuvenating the engine to a condition as if it were 3 years old.

The engine fails again after 3 years (when it again reaches an effective age of 6 
years) and another rebuild is required. This rebuild also rejuvenates the engine by 
50\%, thus making it effectively 3 years old again.

After the second rebuild, the engine fails again after a period of 3 years (when it 
again reaches the effective age of 6 years) and a third rebuild is required. The 
effective age of the engine after the third rebuild is 3 years.

Compare the following tables to see how the two options differ.

**Only Damage Accumulated Since Last Repair**

<table>
<thead>
<tr>
<th>Time</th>
<th>Time Since Last Repair</th>
<th>Effective Age Before Repair</th>
<th>Effective Age After Repair</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start = 0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>6 years</td>
<td>6</td>
<td>6</td>
<td>3</td>
</tr>
<tr>
<td>9 years</td>
<td>3</td>
<td>6</td>
<td>4.5</td>
</tr>
<tr>
<td>10.5 years</td>
<td>1.5</td>
<td>6</td>
<td>5.25</td>
</tr>
</tbody>
</table>

**All Accumulated Damage**

<table>
<thead>
<tr>
<th>Time</th>
<th>Time Since Last Repair</th>
<th>Effective Age Before Repair</th>
<th>Effective Age After Repair</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start = 0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>6 years</td>
<td>6</td>
<td>6</td>
<td>3</td>
</tr>
</tbody>
</table>
Chapter 26: Synthesis Resources

<table>
<thead>
<tr>
<th></th>
<th>9 years</th>
<th></th>
<th></th>
<th>12 years</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>3</td>
<td>6</td>
<td>3</td>
<td>3</td>
</tr>
</tbody>
</table>

The ReliaWiki resource portal has more information on restoration factors at:

• **Additional Costs to Consider** allows you to choose or create models to represent costs that are always associated with the task. **Cost per task** uses a cost model, and **Downtime rate** uses a cost per unit time model. If no models are assigned, it is assumed that there are no additional costs.

• **Identifiers** contains additional identifying information that can be used to search for this resource.

• **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the resource.

• **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

• **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the **Dependency Viewer**.

**Corrective Tasks**
Corrective maintenance consists of the action(s) taken to restore a failed component to operational status. Corrective maintenance is performed at unpredictable intervals because a component’s failure time is not known *a priori*.

Corrective tasks:

• Always bring the block down.

• May bring the system down.

• Require spare parts.
In addition to the common task properties, the following options are used to configure corrective tasks in the Maintenance Task window:

- **Task Scheduling** allows you to specify when the corrective task will be performed.
  - If you choose Upon item failure, the task will be initiated upon failure of the component.
  - If you choose When found failed during an inspection, the task will be initiated if the component is found to be failed at the next scheduled inspection. This is useful in the case of "hidden failures" (i.e., failures that are not apparent until an inspection is performed) and in cases where the component is not considered mission critical and repair can wait until the next scheduled maintenance.
    - If a preventive task takes place before the next inspection, then preventive maintenance (not corrective maintenance) will be performed to restore the block. The downtime, etc. will depend on the preventive task properties.
    - If a corrective task is performed upon inspection and an inspection finds the block failed, then the total downtime includes the full inspection duration followed by the corrective task duration.

If you have selected to perform a corrective task upon inspection and an inspection or preventive task does not occur after the failure, then the block will never be restored. This could happen under either of the following circumstances:

- Neither an inspection nor a preventive task is specified for the block.
  and/or
- The conditions have not been met to perform an inspection or preventive task.

- **Basic Repair Properties > Spare Part Pool** allows you to choose or create a spare part pool that will be used in performing the task. If a spare part pool is not assigned, it is assumed that unlimited free spares are always immediately available.

For corrective and preventive tasks, the simulation requests a crew as soon as a task is initiated; however, the crew does not begin performing the task unless/until the spare part is available.
Chapter 26: Synthesis Resources

The total time for the task consists of:

- The time to complete corrective and preventive maintenance (based on the corrective task or preventive task properties).

PLUS

- The longer of the following times:
  - The time to obtain the spare part (based on the spare part pool).
  
  OR
  
  - The time to obtain an available crew (based on crew availability) and any logistical delay time associated with the crew.

For example, if the block fails at 10 hours (on the system clock), the corrective task will take 5 hours, the time required to obtain the spare will be 48 hours and the logistical delay time associated with the crew is 8 hours, then:

- The spare will arrive at 58 hours (on the system clock).
- The crew will be requested at 10 hours and will arrive at 18 hours (on the system clock).
- The maintenance will be completed at 63 hours (on the system clock).
- The total time for the corrective maintenance will be 53 hours (48 for the spare plus 5 for the task).
- The crew will have traveled for 8 hours, waited 40 hours for the spare part and performed the task for 5 hours for a total of 53 hours (including waiting for the spare part).

If the spare part is available without delay and all other conditions are the same, then:

- The crew will be requested at 10 hours and will arrive at 18 hours (on the system clock).
- The maintenance will be completed at 23 hours (on the system clock).
- The total time for the corrective maintenance will be 13 hours (8 for the crew plus 5 for the task).
- The crew will have traveled for 8 hours and performed the task for 5 hours for a total of 13 hours.
• **Task Consequences**

  • **Does this task bring the system down?**: By default, corrective tasks will not bring the system down unless having the block down brings the system down based on the reliability-wise configuration in the diagram. If you answer **Yes**, the task will bring the system down even if the task has a zero duration. This forces the task to be included in the count of system downing events, regardless of the task's duration.

  • **Does this task bring the item down?**: It is assumed that a block will always be down when a corrective task is performed, even a task with a zero duration; thus, this option cannot be changed.

---

**Preventive Tasks**

Preventive maintenance is the practice of repairing or replacing components or subsystems before they fail in order to promote continuous system operation or to avoid dangerous or inconvenient failures. The schedule for preventive maintenance is based on observation of past system behavior, component wearout mechanisms and knowledge of which components are vital to continued system operation. In addition, cost is always a factor in the scheduling of preventive maintenance. In many circumstances, it is financially more sensible to replace parts or components at predetermined intervals rather than to wait for a failure that may result in a costly disruption in operations.

Preventive tasks:

• Always bring the block down.

• May bring the system down.

• Require spare parts.

Only one preventive task can be performed on a block at any given time.

In addition to the **common task properties**, the following options are used to configure preventive tasks in the Maintenance Task window:

• **Task Class** allows you to specify the kind of maintenance that the task performs: preventive, inspection or on condition. The options available in the Maintenance Task window will vary depending on your choice in this field.

• **Task Scheduling** allows you to specify the circumstances under which the task will be performed. (See **Task Scheduling**.)
Chapter 26: Synthesis Resources

- **Basic Task Properties > Spare Part Pool** allows you to choose or create a [spare part pool](http://xfmea.reliasoft.com) to assign to the task. The spare part pool describes the conditions that determine whether a spare part will be available when needed and specifies the time and costs associated with obtaining the spare part. If a spare part pool is not assigned, it is assumed that unlimited free spares are always immediately available.

For corrective and preventive tasks, the simulation requests a crew as soon as a task is initiated; however, the crew does not begin performing the task unless/until the spare part is available. For a complete explanation of how this affects the total time for the task, see [Corrective Tasks](http://xfmea.reliasoft.com).

- **Task Consequences**
  - **Does this task bring the system down?**: By default, preventive tasks will not bring the system down unless having the block down brings the system down based on the reliability-wise configuration in the diagram. If you answer Yes, the task will bring the system down, even if the task has a zero duration. This forces the task to be included in the count of system downing events, regardless of the task's duration.
  - **Does this task bring the item down?**: It is assumed that a block will always be down when a preventive task is performed, even a task with a zero duration; thus, this option cannot be changed.
  - **If bringing the item down causes the system to go down, do you still perform the task?**: If you answer Yes, the task will be performed even if doing so brings the system down, either because the task itself brings the system down or because the task brings the block down and the block being down causes the system to go down. If you answer No and the task brings the system down, the task will never be performed during simulation unless the system is already down for another reason. For instance, a preventive task that is specified to be performed upon system down will be performed even if it brings the system down regardless of your answer here. This is because the system is already down, which is what triggered the task in the first place.

A preventive task that does not bring the system down at the preventive maintenance time will still be factored into the simulation even if its duration will bring the system down at a later time.

For a preventive task that is scheduled to occur based on item age and for which you have answered No to this question, if the task is going to bring the system down, then it will not take place. If, however, the block reaches the age again (after restoration by a corrective action, inspection or another type of preventive maintenance) and this time it will not bring the system down, then it will be performed.
• **Perform this task even if the item failed before this task was scheduled to occur?**: If you answer Yes, the task will be performed even if the item has already failed. In other words, the item's "clock" is not stopped upon failure, and the item's "virtual age" is used to trigger the task. This option is available only for preventive and inspection tasks that are scheduled based on item age.

• **RCM properties** are text-based properties that are used to keep track of details that may be helpful in reliability centered maintenance analysis, but are not used in reliability/maintainability simulations. These properties are shown only if they are enabled for the project via the interface style settings in RCM++/RBI.

• **Status**: The status of the task (choose from a drop-down list). This setting could be used if you want to keep track of all tasks that have been considered, regardless of whether they end up in the actual maintenance plan (e.g. recommended, rejected, assigned).

• **Proposed Interval**: The interval that was initially proposed for the task. This may be different from the interval that is actually assigned to the task. For example, you may wish to use this property if the team originally suggests a particular interval for the task (perhaps the calculated optimum interval) but then decides to assign a different interval (perhaps an interval that is more convenient for packaging a group of tasks).

• **Reference Document**: A reference to another document that provides more detailed information about the task (e.g. procedure instructions).

• **Condition**: A description of the condition that indicates that a failure will occur (e.g. a threshold for a measurement of wear, vibration, etc). Typically, this field is used for on condition maintenance tasks.

• **Zone**: The zone of the system in which the task will be performed. Typically, this field is used for aircraft MSG-3 analyses.

• **Access**: The access that will be required in order to perform the task. Typically, this field is used for aircraft MSG-3 analyses.

**Note**: A preventive task with a restoration factor of 0 will generate a new failure with the current age.

**Inspection Tasks**

Inspections are used in order to uncover hidden failures (also called "dormant failures"); they are also used as part of on condition tasks to detect impending failures so that preventive maintenance can be performed.
What's Changed? In previous versions of BlockSim, you could assign failure detection properties to an inspection task and set it to trigger a preventive task, thereby creating an on condition maintenance action. The Synthesis version of BlockSim offers on condition tasks, eliminating the need to create your own. Therefore, failure detection properties are now available only for on condition tasks, not for regular inspection tasks.

In general, no maintenance action is performed on the component during an inspection unless the component is found failed, in which case a corrective maintenance action is initiated. However, there might be cases where a partial restoration of the inspected item would be performed during an inspection. For example, when checking the motor oil in a car between scheduled oil changes, one might occasionally add some oil in order to keep it at a constant level. This sort of restoration is not considered to be preventive maintenance; the deciding factor is that inspection tasks do not use spare parts. Note that an inspection task that triggers a corrective task will not restore the failed block. Only the corrective task will restore the block.

Inspection tasks (including the inspection and associated minor work):

- May bring the block down.
- May bring the system down; if the task brings the system down, it also brings the block down.
- Do not use spare parts.

In addition to the common task properties, the following options are used to configure inspection tasks in the Maintenance Task window:

- **Task Class** allows you to specify the kind of maintenance that the task performs: preventive, inspection or on condition. The options available in the Maintenance Task window will vary depending on your choice in this field.

- **Task Scheduling** allows you to specify the circumstances under which the task will be performed. (See [Task Scheduling](#).)

- **Task Consequences**: An inspection task will not bring the block down unless one of the following options is selected.

  - **Does this task bring the system down?**: If you answer Yes, when the task is performed, the system will be down, even if the task has a zero duration. If not selected, the task will bring the system down only if it brings the block down and having the block down brings the system down based on the reliability-wise configuration in the diagram. If this option is selected, even tasks with a zero duration will bring the system down. This forces the task to be included in the count of system downing events, regardless of the task's duration.
• **Does this task bring the item down?**: If you answer *Yes*, when the task is performed, the block will be down. Even tasks with a zero duration will bring the block down in this case.

• **Perform this task even if the item failed before this task was scheduled to occur?**: If you answer *Yes*, the task will be performed even if the item has already failed. This option is available only for preventive and inspection tasks that are scheduled based on item age, including the inspection portion of on condition tasks.

• **RCM** properties are text-based properties that are used to keep track of details that may be helpful in reliability centered maintenance analysis, but are not used in reliability/maintainability simulations. These properties are shown only if they are enabled for the project via the interface style settings in RCM++/RBI.

• **Status**: The status of the task (choose from a drop-down list). This setting could be used if you want to keep track of all tasks that have been considered, regardless of whether they end up in the actual maintenance plan (e.g. recommended, rejected, assigned).

• **Proposed Interval**: The interval that was initially proposed for the task. This may be different from the interval that is actually assigned to the task. For example, you may wish to use this property if the team originally suggests a particular interval for the task (perhaps the calculated optimum interval) but then decides to assign a different interval (perhaps an interval that is more convenient for packaging a group of tasks).

• **Reference Document**: A reference to another document that provides more detailed information about the task (e.g., procedure instructions).

• **Condition**: A description of the condition that indicates that a failure will occur (*e.g.* a threshold for a measurement of wear, vibration, etc). Typically, this field is used for on condition maintenance tasks.

• **Zone**: The zone of the system in which the task will be performed. Typically, this field is used for aircraft MSG-3 analyses.

• **Access**: The access that will be required in order to perform the task. Typically, this field is used for aircraft MSG-3 analyses.

To understand how inspections work during simulation, you should be aware of the following:

• Multiple non-downing inspections cannot occur on the same block at the same time.
Chapter 26: Synthesis Resources

- A non-downing inspection with a restoration factor greater than 0 restores the block based on the age of the block at the beginning of the inspection (i.e., the task duration is not restored).

**On Condition Tasks**

On condition maintenance relies on the capability to detect failures before they happen so that preventive maintenance can be initiated. If, during an inspection, maintenance personnel can find evidence that the equipment is approaching the end of its life, then it may be possible to delay the failure, prevent it from happening or replace the equipment at the earliest convenience rather than allowing the failure to occur and possibly cause severe consequences. In BlockSim, on condition tasks consist of an inspection task that triggers a preventive task when an impending failure is detected during inspection.

For on condition tasks, the Inspection properties allow you to configure the inspection portion of the task, and the options are identical to those available for configuring inspection tasks. The On Condition Task (Upon Detection) properties allow you to configure the preventive portion of the task. The options are the same as those available for configuring preventive tasks, except that the Task Scheduling properties are not available. Instead, Failure Detection properties are used to specify the "warning period" that spans from the time when a potential failure can first be detected to the time when the failure occurs.

To define the Failure Detection properties, first specify when the task is likely to detect an imminent failure. If you choose *When a certain percentage of the life of the item has been consumed*, you must then specify the percentage of the item's life that must have elapsed in order for approaching failure to be detected. This is called the *failure detection threshold* (FDT). For example, if the FDT is 0.9 and the item will fail at 1,000 days, the approaching failure can begin to be detected at 900 days. If you choose *Within a fixed time frame prior to failure*, you must then specify the amount of time before a failure when the approaching failure can be detected by inspection. This is called the *P-F interval*. For example, if the P-F interval is 200 days and the item will fail at 1,000 days, the approaching failure can begin to be detected at 800 days.

On condition tasks can be set to perform the preventive portion of the task even if the item failed before the approaching failure could be detected. If the inspection portion of the task is scheduled based on item age, you can answer *Yes* to the *Perform this task even if the item failed before this task was scheduled to occur?* option.

Note the following simulation assumptions regarding on condition tasks:

- An inspection that finds a block at or beyond the failure detection threshold or within the range of the P-F interval will trigger the associated preventive task as long as preventive maintenance can be performed on that block.
• If a non-downing inspection triggers a preventive maintenance action because the failure detection threshold or P-F interval range was reached, no other maintenance task will be performed between the inspection and the triggered preventive task; tasks that would otherwise have happened at that time due to system age, system down or group maintenance will be ignored.

• A preventive task that would have been triggered by a non-downing inspection will not happen if the block fails during the inspection, as corrective maintenance will take place instead.

• If a failure will occur within the failure detection threshold or P-F interval set for the inspection, but the preventive task is only supposed to be performed when the system is down, the simulation waits until the requirements of the preventive task are met to perform the preventive maintenance.

• If the on condition inspection triggers the preventive maintenance part of the task, the simulation assumes that the maintenance crew will forego any routine servicing associated with the inspection part of the task. In other words, the restoration will come from the preventive maintenance, so any restoration factor defined for the inspection will be ignored in these circumstances.

**Task Scheduling**
The following information applies to the task scheduling properties for preventive tasks, inspection tasks and the inspection portion of on condition tasks.

Click the arrow in the **When is this task performed?** field to define the criteria for performing the task. The remaining fields in the task scheduling properties will depend on your selection in this field. The task can be performed:

• **At certain intervals.** If you select this option, you must then specify:
  - Whether the interval is fixed or dynamic.
  - Whether the interval is based on the item’s age or on calendar time.

• **Upon certain events.** If you select this option, you can choose for the task to be performed:
  - Whenever the system is down for any reason. No further task scheduling properties are required for this option.
  - Based on events in a maintenance group. The task will be performed when user-specified events occur in one or more user-specified maintenance groups. The
item that the task is assigned to does not need to be part of the selected maintenance group(s).

- When a maintenance phase in a phase diagram starts. Please note that if the task is selected to be performed only at the start of a maintenance phase and the item that the task is associated with is not included in the maintenance phase's associated maintenance template, the task will never be performed. No further task scheduling properties are required for this option.

The remaining task scheduling properties for each type of schedule are given next. For any interval that you specify, you will be asked to specify the time units used.

- **Fixed interval based on either item age or calendar time**: Enter the interval when the task will be performed (e.g., if you enter 100, the task will be scheduled for 100, 200, 300, etc.).

  - Item age refers to the accumulated age of the block, which gets adjusted each time the block is repaired (i.e., restored). If the block is repaired at least once during the simulation, this will be different from the elapsed simulation time. For example, if the restoration factor is 1 (i.e., "as good as new") and the assigned interval is 100 days based on item age, then the task will be scheduled to be performed for the first time at 100 days of elapsed simulation time. However, if the block fails at 85 days and it takes 5 days to complete the repair, then the block will be fully restored at 90 days and its accumulated age will be reset to 0 at that point. Therefore, if another failure does not occur in the meantime, the task will be performed for the first time 100 days later at 190 days of elapsed simulation time.

- Calendar time refers to the elapsed simulation time. If the assigned interval is 100 days based on calendar time, then the task will be performed for the first time at 100 days of elapsed simulation time, for the second time at 200 days of elapsed simulation time and so on, regardless of whether the block fails and gets repaired correctly between those times.

If the task is performed at fixed intervals, you can select the **Override task scheduling properties with a task package** option to assign the task to a task package, which is a group of tasks that are performed together at scheduled intervals. (Note that if a task has
been assigned to a task package, the task scheduling properties will be disabled and displayed in italics.)

- **Dynamic interval based on either item age or calendar time**: The task will be performed at variable user-specified intervals. This can be used, for example, to schedule maintenance to be performed with increasing frequency as an item gets older. The Dynamic intervals field shows the number of intervals specified. Click the button (...) to open the Intervals window, which allows you to enter the item age intervals when the task will be performed. The intervals are the actual time between maintenance (i.e., they are not cumulative).

- **Based on events in a maintenance group**: Specify the events that can trigger the task (i.e., a block fails; a corrective, preventive or inspection task starts; a block is restored to operation), and choose the maintenance group(s) in which the event(s) must occur in order to trigger the task.

**Note:** For preventive and inspection tasks that are scheduled based on item age, you can use the Perform this task even if the item failed before this task was scheduled to occur? property to determine whether actual age or "virtual age" is considered. If you answer Yes, the task will be performed even if the item has already failed. In other words, the item's "clock" is not stopped upon failure, and the item's virtual age is used to trigger the task.

---

**Crews**

Crews are resources that can be shared among analyses and can be managed via the Resource Manager. You can assign the crews to maintenance tasks.

The Crew window allows you to create, view and edit crews. It can be accessed by clicking the Create New or View/Edit icon in the Crew wizard, which is accessed from Crew fields in properties windows (e.g., the Crew for task field in the Maintenance Task window).

It can also be accessed from the Crews page of the Resource Manager by choosing Home > Edit > New, by selecting a crew and choosing Home > Edit > View or by double-clicking a crew.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the Synthesis resources you need for your analyses.
Chapter 26: Synthesis Resources

The following settings are available to configure the crew:

- **Crew**
  - **Direct cost** allows you to choose or create a model to represent the direct cost per unit time to engage the crew (e.g., the hourly charge for the time that the crew spends performing the task). This field uses a cost per unit time model. If no model is assigned, it is assumed that there is no cost.
  
  - **Cost per incident** allows you to choose or create a model to represent the cost per incident to engage the crew (e.g., if you have to pay a fixed fee instead of or in addition to the hourly rate). This field uses a cost model. If no model is assigned, it is assumed that there is no cost.
  
  - **Is there a limit to the number of tasks this crew can perform at the same time?:** If you answer Yes, you must specify the limit in the **Number of tasks** field. For example, if the crew can only fix 3 components at any given time and 4 components fail at the same time, then the crew will not be able to fix the fourth component until one of the other components has been restored.
  
  - **Logistic Delay** allows you to choose or create a model to describe the delay time before the crew can start the task. If no model is assigned, it is assumed that the crew can start the task immediately without any delays (i.e., immediate repair). The crew with the highest priority is always called upon first, regardless of logistic wait times for the crews. If a crew is needed and all crews are engaged, the crew with the shortest wait time is chosen to perform the task.

For a given simulation, a crew’s logistic time is constant across that one simulation for the task. It is taken randomly from its distribution or from its fixed time.

For on condition tasks, if the same crew performs the inspection and preventive maintenance and there are logistic delays associated with the crew, the logistic delays will be factored into the simulation for both parts of the task.

  - If **Include logistic delay in cost** is selected, then the time spent waiting for the crew (including logistic delay and any delay incurred due to limits on the number of tasks the crew can perform simultaneously) will be included when calculating crew costs, based on the direct cost specified for the crew.

  - If **Include part delay in cost** is selected, then the time spent by the crew waiting for spare parts will be included when calculating crew costs, based on the direct cost specified for the crew.

- **Identifiers** contains additional identifying information that can be used to search for this resource.
• **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the resource.

• **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

• **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

---

**Spare Part Pools**

Spare part pools are **resources** that can be shared among analyses and can be managed via the Resource Manager. A spare part pool describes the conditions that determine whether a spare part will be available when needed and specifies the time and costs associated with obtaining the spare part. You can assign the pools to maintenance **tasks**.

The Spare Part Pool window allows you to create, view and edit spare part pools. It can be accessed by clicking the Create New or View/Edit icon in the Spare Part Pool wizard, which is accessed from **Spare Part Pool** fields in properties windows (e.g., in the Maintenance Task window).

It can also be accessed from the Spare Part Pools page of the Resource Manager by choosing Home > Edit > New, by selecting a spare part pool and choosing Home > Edit > View or by double-clicking a spare part pool.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the Synthesis resources you need for your analyses.
The following settings are available to configure the spare part pool:

- **Spares**
  - **Direct cost per dispensed item** allows you to specify the direct cost of each spare part in the pool.
  - **Spare acquisition type**: You can select **Unlimited spares** to indicate that an unlimited number of spare parts exist in the pool (i.e., if a spare part is required, it will always be available). If you select **Limited number of spares**, the Pool Restock properties and the Emergency Spare Provisions properties will become available. In addition, you will need to define the following properties:
    - **Initial stock level** is the number of spare parts in the pool at the start of simulation.
    - **Holding Cost ($/Hour in pool)** allows you to choose or create a model to represent the cost of holding a spare part in the pool. The time unit used is the default unit for the database. This field uses a cost per unit time model. If no model is assigned, it is assumed that there is no cost. (To determine which time unit is defined as the default, you can open the Define Units window by choosing File > Manage Repository > Time and Usage Units. The default unit is the one that is selected in the Use as Default column.)
    - If you select the **Pool has maximum capacity** check box, you will need to specify the maximum number of items that can exist in the spare part pool at any given time. The restock options will add parts only up to this maximum capacity. For example, suppose that the maximum capacity is 20 units and the restock quantity is 5 units. If the current stock level is 18 when a restock is triggered (either on a scheduled interval or because the stock fell to a specified level), then only 2 units will be added to the spare part pool, even though the restock options call for the addition of 5 units at each restock.
  - If you select **Fixed probability of stockout**, the Emergency Spare Provisions properties will become available. In addition, you will need to enter the probability of running out of stock as a decimal value.
  - **Logistic Time for Spare Acquisition** allows you to choose or create a model to describe the amount of time required to obtain the part when it is required for maintenance, assuming that the part is in stock. This field uses a duration model. If no model is assigned, it is assumed that the spare part is available for use immediately.
• The **Pool Restock** properties allow you to define how the spare part pool will be restocked. These properties are available only if you have selected the **Limited number of spares** option in the **Spare acquisition type** field. You can select either or both of the following restock schemes:

  - If the **Scheduled restock** option is selected, the pool will be restocked at fixed intervals. The following properties will be available:

    • **Restock every** allows you to specify the time interval at which the pool will be restocked.
    
    • **Number added per restock** allows you to specify the number of parts that are added to the pool at every scheduled interval.
    
  - If the **Restock as needed** option is selected, the pool will be restocked when the stock drops to a specified quantity. This option is available only if the initial stock level entered is at least 1. The following properties will be available:

    • **Restock when stock drops to** allows you to specify the number of parts in the pool that will trigger the restock (e.g., when the stock drops to 5, order more parts).
    
    • **Number added per restock** allows you to specify the number of parts that are added to the pool when the restock condition has been met.
    
    • **Required time for stock arrival** allows you to choose or create a model to describe the amount of time required for the new parts to arrive after the restock has been initiated. This field uses a duration model. If no model is assigned, it is assumed that the parts arrive immediately.
    
    • **Off-site spare part pool** allows you to assign an off-site spare part pool to the current pool. If specified, this pool is considered to be the source for restocking the current pool, which allows you to describe properties for the next level of spare parts that can be accessed when needed. If no off-site spares pool is specified, the parts are assumed to be ordered and no properties are described for the source.

**Tip:** Circular references between spare part pools are not permitted. In other words, if Pool 1 calls Pool 2 as its off-site spare part pool, and Pool 2 calls Pool 1 as its off-site spare part pool, BlockSim will display a message notifying you of the problem upon simulation.

• The **Emergency Spare Provisions** properties allow you to define the circumstances when the spare part pool is empty but a spare part is required for a task. These properties are available only if you have selected either the **Limited number of spares** option or the
Fixed probability of stockout option in the Spare acquisition type field. Selecting the Can obtain emergency spares if needed option indicates that a spare part can be obtained if required and the spare part pool is empty; otherwise, the repair will be delayed until more spare parts arrive in the spare part pool. Selecting this option makes the following properties available:

- **Number added per emergency** allows you to specify the number of parts that are added to the pool when an emergency acquisition occurs.
- **Additional costs for emergency spares** allows you to choose or create a model to represent a per incident cost for emergency acquisition of spares (e.g., there is a $50 surcharge when emergency spares are required). This field uses a cost model. If no model is assigned, it is assumed that there is no cost.
- **Required time for emergency spare** allows you to choose or create a model to describe the amount of time required for the emergency spare parts to arrive after the emergency acquisition has been initiated. This field uses a duration model. If no model is assigned, it is assumed that the parts arrive immediately.
- **Off-site spare part pool** allows you to assign an emergency off-site spare part pool to the current pool. This allows you to create another level of spare parts that can be accessed for the emergency acquisition.

- **Identifiers** contains additional identifying information that can be used to search for this resource.
- **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the resource.

- **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

- **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.
Metrics

A metric is a Synthesis resource that provides a flexible way to display any numerical value of interest, and track how it changes over time. This can be used for tracking and displaying a variety of Key Performance Indicators (KPIs) and other values, including:

- Reliability metrics (e.g., reliability, BX% life, etc.) calculated from a model resource.
- Any result from a simulated BlockSim diagram.
- The completion percentage and resource usage for Project Planner gates.
- The reliability or availability calculated from an FMRA in Xfmea/RCM++/RBI.
- Any other user-defined value that you wish to display and track.

Like any other Synthesis resource, you can create or edit metrics from the Resource Manager, and while you’re performing a relevant analysis. (See Showing Metrics in Folios/Diagrams, Using Metrics in Project Planner Gates and Pushing Metrics from an FMRA.)

If your organization chooses to implement a web-based Synthesis Enterprise Portal, it’s easy to choose specific metrics that you want to access quickly from any web-enabled device.

**Note:** Metrics are always local resources. They cannot be made global. Metrics in a reference project are local to that project and can’t be selected for use in other projects.
Metric Types
The following pictures demonstrate the four basic options for specifying the value that will be displayed and tracked.

<table>
<thead>
<tr>
<th>Calculate from a model resource</th>
<th>Obtain from a BlockSim simulation diagram</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Metric Type</strong></td>
<td><strong>Metric Type</strong></td>
</tr>
<tr>
<td>Type</td>
<td>Type</td>
</tr>
<tr>
<td>Reliability Given Time</td>
<td>Simulation Result</td>
</tr>
<tr>
<td><strong>Associated Model</strong></td>
<td><strong>Associated Diagram</strong></td>
</tr>
<tr>
<td>Model</td>
<td>Diagram</td>
</tr>
<tr>
<td>Widget LDA [WBD (1.5, 1000)]</td>
<td>System RBD</td>
</tr>
<tr>
<td>Time</td>
<td>Result</td>
</tr>
<tr>
<td>100 (Hr)</td>
<td>Mean Availability</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Enter any user-defined value</th>
<th>The value is &quot;pushed&quot; from a Project Planner gate or FMRA</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Metric Type</strong></td>
<td><strong>Metric Type</strong></td>
</tr>
<tr>
<td>Type</td>
<td>Type</td>
</tr>
<tr>
<td>Constant</td>
<td>Application Driven Value</td>
</tr>
<tr>
<td><strong>Constant Value</strong></td>
<td></td>
</tr>
<tr>
<td>Value</td>
<td></td>
</tr>
<tr>
<td>100</td>
<td></td>
</tr>
</tbody>
</table>

Calculated Result and Saved Values
The **Calculated Result** field shows the latest calculated value for the metric. This will be updated automatically if the associated analysis or model changes, and the latest result will be stored in an array of saved values.

You can then click the **View Saved Values** icon to view the history of how the metric has changed over time.

If you change any of the properties that affect the way the result is calculated, you will be prompted to decide whether to clear the array of values that were saved before the change. For example:

- If you change the metric from Reliability to Probability of Failure, or from 1,000 hours to 500 hours, you will probably want to clear the array so the timeline of saved values is not misleading.

- Alternatively, if you change the metric’s associated model from prototype1 to prototype2 to prototype3 at different stages of development, you may wish to keep the
saved values after each change so the timeline shows the improvement across all three stages.

In the Metric Results Viewer, you can also choose to clear the entire history or delete only a particular saved value.

The results viewer also allows you to copy the values to the Clipboard so you can paste into another application. For example, if the metric stores the calculated reliability at different points in time, you may wish to analyze the data with a reliability growth model in RGA.

- **Copy > All rows (dates)** copies the exact dates shown in the table.
- **Copy > All rows (cumulative days)** replaces the dates with the cumulative number of days since the date of the last saved value. For example, if the first date is 1/1/2015 and the second date is 12/31/2015, the cumulative days would be 0 for the first date and 365 for the second date.

**Target Conditions and Result Indicator**

The **Target Conditions** feature color-codes the current value of the metric. If all specified conditions are met, then the metric's value will be displayed in green. If one or more conditions are not met, then it will be in red. For example, in the following pictures, the result is green if the estimated system reliability is at least 80%, and red if it is not.

![Example of Target Conditions](image)

The **Result Indicator** feature color-codes the indicator that shows whether the value has increased or decreased since the prior saved value. If the direction of the change is desirable, the indicator will be green; if it is undesirable, the indicator will be red. As an example, the following pictures are from the SEP.

![Example of Result Indicator](image)

**Identifiers, History, Watch and Trace Usage**

As with most other Synthesis resources:

- **Identifiers** contains additional identifying information that can be used to search for this resource.
Chapter 26: Synthesis Resources

- **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the resource.

- **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

- **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

**Showing Metrics in Folios/Diagrams**

The Publishing page of the control panel shows all of the metric resources that are associated with the current analysis. (The metrics can be created and edited either from the Resource Manager or the control panel.) This applies for:

- Data sheets in Weibull++, ALTA or RGA that have a published model.

- Analytical or simulation diagrams in BlockSim that have a published model for the entire system (either a fitted model or an analytical model).

- Simulation diagrams in BlockSim that have simulation results.

This makes it easy to see the metrics that have been created for each analysis (which may also be displayed in relevant Project Planner gates or in the Synthesis Enterprise Portal website) and to see the history of how the analysis results changed over time. It also provides a convenient way to create new metrics for the analysis, if desired.

As an example, the following picture shows a typical scenario for Weibull++. In Weibull++, ALTA or RGA, the control panel shows all metrics that are associated with the model published from the current data sheet. In BlockSim, it shows all metrics that are associated with a model published from the diagram and/or obtained from the diagram’s simulation results.

- Double-click a metric to see its properties and history of saved values.

- A Watch icon will be shown beside any metric for which you have subscribed to receive an alert when the resource is changed.

- Click the Metric Summary icon to see a quick report of all the metrics displayed in the current branch.
• Click the **Create New** icon to create a new metric.

**Associating Existing Metrics with a Different Data Sheet**

When an analysis changes (e.g., new data, after a design change, etc.), you may choose to simply update the existing data sheet and recalculate, or keep the original analysis unchanged and perform the updated analysis in a new data sheet.

If you decided to create a new data sheet, there are two ways to ensure that the metrics will reflect the complete history from both analyses:

**Publish to the existing model from the new data sheet**

If you want the published model to reflect the latest analysis results, you can simply transfer both the model and the associated metrics to the new data sheet. To do that:

1. Calculate the new data sheet and then go to the Publishing page of the control panel.
2. Click **Publish to Existing Model** and then select the model from the original data sheet.

**Change the model for the existing metrics**

If you want to keep the original published model associated with the original data sheet, you can publish a new model for the new data sheet and then transfer the metrics to the new model. To do that:

1. Publish a new model for the new data sheet.
2. From either the original data sheet’s control panel or the Resource Manager, open each metric that was associated with the original data sheet and change the **Associated Model**.

As a shortcut, you can click the **Select Existing** icon on the new data sheet's control panel and choose one or more existing metrics in the Select Resource window. It is important to keep in mind that when you do this, you are changing the associated model for each selected metric.

**Using Metrics in Project Planner Gates**

There are two ways to utilize metrics in a Project Planner gate:

**Relevant Metrics**

For any gate in a project plan, you can choose to display up to three metrics that are relevant to this stage of the project (e.g., the target reliability, the latest calculated reliability, etc.).

Use the fields under the **Relevant Metrics** heading to select an existing metric or create a new one.
For any gate in a project plan, you can also choose to push any of the following values to a metric resource. This makes it easy to see the history of all saved values, and enables users to subscribe to receive alerts when the metric changes. You can also choose to show this information in the Synthesis Enterprise Portal if a web-based portal is implemented for the current database.

- **Percent Completed** is the percentage of the total duration of dependent actions/gates that is complete. For example, if Action 1 (duration = 3 days) is complete and Action 2 (duration = 1 day) is incomplete, the progress is 75%.

- **Actual Man Hours %** is the percentage of planned hours that have been used to complete the gate.

- **Actual Costs %** is the percentage of the budget that has actually been used to complete the gate.

Use the fields under the **Push to Metrics** heading to create a new metric or select an existing metric that is not already assigned to receive a pushed value. (Note that only unused metrics are shown in this list.)

When you first assign a metric in one of these fields, the current value will be automatically saved to the metric. Subsequently, the value will be recalculated each time an associated action or gate is changed. If the value is found to have changed, it will be saved to the metric. To see the current saved value, click inside the field. This will also display a result indicator and the **View Saved Values** icon, which you can click to see a history of all saved values.
Pushing Metrics from an FMRA

The **Push to Metrics** fields on the Properties tab of the Analysis panel in Xfmea/RCM++/RBI enable you to “push” the reliability and availability values that were calculated/simulated from the Failure Modes and Reliability Analysis (FMRA) to Synthesis metric resources.

This makes it easy to see the history of all saved values while you’re working in the FMRA, and enables users to subscribe to receive alerts when the metric changes. If desired, you can also choose to show this information in a specific Project Planner gate (under the Relevant Metrics heading), and in the Synthesis Enterprise Portal if a web-based portal is implemented for the current database.

1. Go to the FMRA tab in the system panel. (See Enabling and Viewing the FMRA in the Xfmea/RCM++/RBI documentation.)

2. Select any item in the FMRA hierarchy and use the fields under the **Push to Metrics** heading to create a new metric or select an existing metric that is not already assigned to receive a pushed value.

3. Calculate and/or simulate the FMRA:
   a. To calculate the reliability, choose FMRA > Calculations > Calculate (Reliability).
b. To simulate the availability, choose **FMRA > Calculations > Simulate (Availability)**.

4. Each time you calculate/simulate the FMRA, the latest value(s) will be automatically saved to the metric(s). To see the history of all saved values, click **View Saved Values**.

<table>
<thead>
<tr>
<th>Reliability / Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target Reliability</td>
</tr>
<tr>
<td>Current Reliability</td>
</tr>
<tr>
<td>Target Availability</td>
</tr>
<tr>
<td>Current Availability</td>
</tr>
</tbody>
</table>

**Variables**

A variable is a **resource** that stores a numerical value and allows you to assign a name to that value. You can then use the variable name in place of the actual value in the equations that you create. You can also use variables in functions and/or as conditional output values in conditional blocks, logic gates and branch gates.

A variable starts with an assigned initial value, which may be fixed or varied during simulation. You can use variables:

- In RENO, to act as a constant (i.e., maintain a fixed numerical value during simulation).
- In RENO, to temporarily store the output value of a block during simulation. **See the next section for more information**.
- In RENO, to perform a sensitivity analysis, which involves varying the value of one or two variables between *runs* (i.e., sets of simulations). For example, if you are analyzing potential investment strategies, you may wish to vary the number of years that you will be investing and/or the percentage of your income that will be invested to see how different inputs will affect the final results.
- As the basis for a **dynamic model**, which represents a fixed probability, duration or cost. The variable can be programmatically varied during simulation, thereby changing the value of the model for successive simulation runs.
• As inputs for certain fields in BlockSim simulation RBDs via simulation worksheets, allowing programmatic variation of the field value during simulation.

What's Changed? In previous versions of RENO, variables that stored fixed values were known as constants, and variables that stored outputs were known as storage variables.

Using Variables to Store Output Values in RENO
You can use variables to hold numerical values passed to them during simulation. In RENO, the following blocks are able to store their output values in variables:

• Standard blocks
• Result storage blocks
• Flag markers
• Counter blocks

Depending on your choice in the When to Reset field of the variable's properties window, you can configure the variable to retain the value passed to it during simulation or reset the variable to its initial value at specific times. The options are:

• Reset After Each Simulation (i.e., reset after a single pass through the flowchart)
• Reset After Each Run (i.e., reset after each set of simulations)
• Reset After Analysis (i.e., reset after each set of runs)
• Never Reset

When the simulations end, the variable always returns to its initial starting value unless you have selected Never Reset. If you wish to keep the value used during simulation, you can use a result storage block to store it.

Example
The following example demonstrates two things: a) how a variable may be used to store an output value and b) how a variable may be used in an equation.

In the following configuration, the first block calculates the gross profit from a sale, and then stores its output into a variable called "Profit." The conditional block determines whether the gross profit exceeds 500. If the output is true, the third block deducts the sale's commission from the profit, and overwrites the stored value with the new output.
The following picture shows the properties window of the variable called "Profit." The initial value of this variable is set to 0.

The following picture shows the Block Properties window of the first block in the example. The output of the equation is stored in the variable.
The following picture shows the Block Properties window of the third block in the flowchart. The equation shows that the commission is deducted from the existing value in the variable, and then the variable is overwritten with the new result. At the end of the simulation, the result storage block in the flowchart stores the final value of the variable, and then the variable resets to 0.
Profiles

New in Version 11, a profile is a Synthesis resource that allows you to represent a value that varies with time. It consists of a basic pattern that either repeats as a cycle or occurs once and then continues from its last defined setting.

What's Changed? The profile resource replaces the stress profile functionality that was available in previous versions of ALTA PRO.

This topic describes how to create profiles, which can be defined by entering values manually or by importing data from nCode GlyphWorks.

To learn how to use profiles in ALTA life-stress data folios, see Time-Dependent Stress Profiles in the ALTA documentation.

Creating Profiles

Like any other Synthesis resource, you can create or edit profiles from the Resource Manager, and while you’re performing a relevant analysis. To create a profile:

1. Define a pattern for how a stress level will change over a specified period of time. The pattern you will define consists of a series of segments, where each segment has a specified duration and either:
   - a constant stress value, or
   - a function that takes a time value and returns a stress value.

These segments are defined in the spreadsheet, as shown next.

<table>
<thead>
<tr>
<th>Segment Start</th>
<th>Segment End</th>
<th>Stress S(t)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>1100</td>
<td>328</td>
</tr>
<tr>
<td>1100</td>
<td>2200</td>
<td>338</td>
</tr>
<tr>
<td>2200</td>
<td>3300</td>
<td>348</td>
</tr>
</tbody>
</table>

- **Segment Start** is calculated automatically by the software and cannot be entered manually. The first segment’s start time is always 0. For every subsequent segment, the start time is identical to the prior segment’s end time.

- **Segment End** allows you to enter the end time for each segment, which must be smaller than the end time of the next segment.

- **Stress S(t)** is the stress value or function for the segment. If the stress level will stay constant during a segment, enter a constant value (e.g., 30). If the level will
change during a segment, enter the value as a function of time (e.g., at time = 20, the function \( t + 20 \) will return a value of 40). When entering a function, you must use \( t \) or \( T \) as the time variable.

**Tip:** Because stress units (e.g., volts) and time units (e.g., hours) are not defined in the profile, it is important to apply profiles only to folios that are intended to use the same stress and time units. In the Profile window, you may want to rename column headings (by right-clicking the heading) or use the Comments page as a reminder of which units are applicable to that profile.

For example, suppose the stress unit is psi and the time unit is seconds. Now suppose you wanted to define the following 120-second pattern: a stress value of 30 psi for 60 seconds, followed by a stress value of 50 psi for 30 seconds, followed by a stress function that begins at 50 psi and gradually decreases at a rate of 1 psi per second for the remainder of the pattern. For this pattern, you could fill out the spreadsheet as follows:

<table>
<thead>
<tr>
<th>Segment Start</th>
<th>Segment End</th>
<th>Stress ( S(t) )</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>60</td>
<td>30</td>
</tr>
<tr>
<td>60</td>
<td>90</td>
<td>50</td>
</tr>
<tr>
<td>90</td>
<td>120</td>
<td>( 50 - (t - 90) )</td>
</tr>
</tbody>
</table>

Notice that the last segment of this profile uses a stress function. Since \( t \) is the test time (or, if the profile is cyclical, the time since the pattern was last restarted), \( t = 90 \) when the last segment begins. So the last segment’s stress level starts at \( 50 - (90 - 90) = 50 \). Then, at 91 seconds, the stress level will have dropped to \( 50 - (91 - 90) = 49 \). After another second it will have dropped to \( 50 - (92 - 90) = 48 \), and so on.

2. Next, choose the appropriate option in the **After Last Segment** area of the control panel. Your selection here will determine what happens after the end time of the profile’s last segment (in the above example, after time = 120).

If you select **Continue with last value**, all times after the last segment will use the value/function defined in the last segment.

If you select **Repeat cycle**, the entire pattern of segments will be treated as a repeating cycle.

For example, suppose you defined a pattern that is made up of five segments, each an hour long and increasing stepwise from the segment before. The graphs below illustrate the difference between continuing from the last stress (left) and selecting to repeat (right). In this example, the test has a duration of 20 hours, and the graphs explain what would happen through the entire duration of the test.
3. Before you can use the new profile in your analysis, you must save any changes you have made and validate the current profile settings. To do this, click the **Validate Profile** icon.

After you save the changes in your profile, the **Profile Summary** area will appear. Click the **Detailed Summary** icon to open the Results window, which shows the current profile in a worksheet that you can copy or print.

To view a stress vs. time plot of the profile, click the **Plot** icon. (See **Synthesis Plot Utilities** for general information on plots.)

**Note:** Clicking the **Validate Profile** icon will not automatically update your stress vs. time plot. To make sure your plot reflects the most recent profile information, click the **Plot** icon.

If desired, you can use the Comments page of the control panel to enter notes or other text that will be saved with the profile.

**Importing Data from nCode GlyphWorks**

New in Version 11, you can import nCode GlyphWorks time series data from .S3T files for use as stress profiles. The stress values in the .S3T file must be greater than zero in order for the data to be imported.
To import data from an nCode .S3T file, first create a new profile from the Resource Manager (Project > Synthesis > Resource Manager). In the Profile window, click the Import from GlyphWorks icon on the control panel.

This launches the import wizard, which guides you through the steps required to import data from the file. You can then edit the resulting imported data, if desired. Note that if you update the .S3T file in GlyphWorks, the associated profile in ALTA will not be updated automatically. You must re-import the data to reflect the changes.

*Tip:* Because stress and time units are not defined in the profile, it is important to apply profiles only to folios that are intended to use the same stress and time units. In the Profile window, you may want to rename column headings (by right-clicking the heading) or use the Comments page as a reminder of which units were used by the data imported from the nCode file.

### Maintenance Groups

Maintenance groups are resources that are available for use throughout the project and can be managed via the Resource Manager. A maintenance group is a set of blocks or system hierarchy items where some event within the group can trigger either maintenance or state changes for one or more blocks or items, either within the group or outside of it. You can use a maintenance group:

- In BlockSim: To turn a block on or off. State change triggers are used to activate or deactivate a block when items in one or more specified maintenance groups go down or are restored. The block whose state is being changed may or may not belong to any of the maintenance groups. This allows you to model a cold standby configuration (i.e., one where the component cannot fail when in standby) without using a standby container, which may be useful if you are using a parallel or complex configuration, as blocks can be connected only in series in standby containers.

- In BlockSim, RCM++ or RBI: To trigger a scheduled task (i.e., a preventive task, inspection or on condition task). You can set the task to be performed based on events in one or more maintenance groups. Triggering events within the maintenance group can include block/item failure; start of corrective, preventive or inspection tasks; and/or block/items restoration. The block(s)/item(s) affected by the task may or may not belong to any of the maintenance groups. For example, if you want to perform preventive maintenance on Component A every time you perform corrective maintenance on Component B, then you can assign Component B to Maintenance Group 1 and then set the preventive task assigned to Component A to be performed.
upon the start of corrective maintenance within Maintenance Group 1. See Task Scheduling for more information on how tasks can be scheduled.

**Note:** In BlockSim diagrams, blocks that belong to a maintenance group have a red circle at the upper left corner of the block. You can change the size of the indicator via the relevant Block Corner Indicators page of the Diagram Style window. You can change the color used for each maintenance group via the Maintenance Group Manager.

The Maintenance Group window allows you to create, view and edit maintenance groups. It can be accessed by clicking the Create New or View/Edit icon in the Maintenance Group wizard.

It can also be accessed from the Maintenance Groups page of the Resource Manager by choosing Home > Edit > New, by selecting a maintenance group and choosing Home > Edit > View or by double-clicking a maintenance group.

At the top of the window, you can specify the maintenance group name. You can replace the default name with your own name of up to 150 characters, if desired. To change the default names, choose File > Manage Repository > Default Name Formats. (In a secure database, this is available only to users with the "Manage other repository settings" permission.)

You can also enter comments about the maintenance group in this window.

For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

**Maintenance Group Manager**

In BlockSim only, the Maintenance Group Manager allows you to add blocks to or remove blocks from a maintenance group without having to go into each block's properties individually. This window can be accessed by choosing Project > Data Management > Maintenance Group Manager or, when you are viewing the Maintenance Groups page of the Resource Manager, by choosing Home > Actions > Maintenance Group Manager.
The Maintenance Group area allows you to choose an existing maintenance group from the drop-down list. In addition, you can click the Select Existing icon to open the Select Resource window. If there is not an existing maintenance group that meets your needs, you can create a new one by clicking the Create New icon to open a window that allows you to specify a name for the new maintenance group, as well as any comments. Click the View icon to view the characteristics of the selected maintenance group.

You can also click the Indicator Style icon to modify the appearance of the corner indicator that will appear on each block that belongs to the maintenance group, including:

- The indicator's background color, fill color and fill style. The background color is the underlying color applied to the indicator; the fill color is applied over the background color in the pattern specified by the fill style.
• The style (e.g., solid, dash, etc.), color and thickness of the indicator border.

You can change the size of the indicator via the relevant Block Corner Indicators page of the Diagram Style window.

The Blocks area displays all of the blocks in the maintenance group, in the format \[Diagram Name\] \[Block Name\].

• To add a block to the maintenance group, you can select the diagram and block in the Add Block area and click the Add to Maintenance Group button. You also can select the block(s) in the diagram, press CTRL+SHIFT and drag the block to the list in the Blocks area of the Maintenance Group Manager.

• To view a block in the maintenance group, select the block in the list and click the Select on Diagram button. The diagram will be displayed with the block selected.

• To remove a block from the maintenance group, select the block in the list and click the Remove from List button.

**Mirror Groups**

Mirror groups are resources that are available for use throughout the project and can be managed via the Resource Manager. You can use a mirror group:

• In BlockSim: To place the same block in more than one location (i.e., to represent a single component more than once in a diagram or in multiple diagrams within a project). See Mirroring (Using Blocks in Multiple Locations) in the BlockSim documentation.

• In the FMRA in BlockSim, Xfmea, RCM++ or RBI: To place the same cause in more than one location in the FMRA hierarchy, in order to consider common cause failures. See Using Mirror Groups in an FMRA in the Xfmea/RCM++/RBI documentation.

**Task Packages**

Task packages are resources that can be shared among analyses and can be managed via the Resource Manager. They represent groups of tasks that are performed together at scheduled intervals, for the most efficient allocation of resources and downtime management.
The Task Package window allows you to create, view and edit task packages. It can be accessed by clicking the Create New or View/Edit icon in the Task Package wizard, which is accessed from the Task Package field that appears when you select the Override task scheduling properties with a task package option for a preventive, inspection or on-condition task that is scheduled to be performed at fixed intervals.

It can also be accessed from the Task Packages page of the Resource Manager by choosing Home > Edit > New, by selecting a task package and choosing Home > Edit > View or by double-clicking a task package.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the Synthesis resources you need for your analyses.

The following settings are available to configure the task package:

- In the Perform every field, enter the length of the interval at which the task package will be performed. You must specify time units for this value.

- The Auto-Packaging Intervals fields allow you to specify a range of scheduled intervals that will automatically be incorporated into the task package if the user clicks the Auto-Package Tasks button at the bottom of the Maintenance Task Packaging window in RCM++/RBI. The time units for these fields are the same as those specified for the Perform every field. For example, if you enter 150 hours in the Start time field and 200 hours in the End time field, then tasks that are scheduled to be performed at fixed intervals from 150 to 200 hours can automatically be included in the task package to be performed at the scheduled time of the task package rather than at their individually scheduled times.

- Identifiers contains additional identifying information that can be used to search for this resource.

- History provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the resource.

- Watch allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.
Chapter 26: Synthesis Resources

- **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

Actions

Throughout the Synthesis Platform, your team can use actions to track specific assignments that need to be performed. These versatile Synthesis resources can be used multiple times in different locations, if appropriate. Specifically, actions can be created, displayed and/or managed:

- via [Project Plans](#) or the [Resource Manager](#) in all Synthesis desktop applications except MPC.
- via [My Portal](#) or [Actions Explorer](#) in all Synthesis desktop applications.
- via the [Synthesis Enterprise Portal](#) (if it is implemented for your database).
- via FMEAs or Test Plans in Xfmea/RCM++/RBI.

For specific instructions regarding how to create or edit an action in each location, please consult the documentation for that particular feature. This section focuses on general considerations that will be applicable regardless of where/how the action is being used.

**Tip:** If an action is used in an FMEA, the properties window will be different depending on the current context. If you’re using Xfmea/RCM++/RBI and you open the action from the FMEA or My Portal, the window includes additional features that provide quick access to associated FMEA records (failures, causes, etc.) and the FMEA change log (if activated). These features are not available if you open the action from another location (e.g., Resource Manager, Project Planner, Actions Explorer) or in another application, because the associated FMEA can’t be opened in those situations.

Actions as Resources

As with any other Synthesis resource:

- Any changes to the action properties will be reflected in all locations where the resource is used.

- If you remove an action from an FMEA or Project Plan, the resource will remain in the project unless/until an authorized user deletes it from the database (via My Portal, Resource Manager or Actions Explorer).
Note: Actions are always local resources. They cannot be made global. Actions in a reference project are local to that project and can't be selected for use in other projects.

Configurable Settings
Some properties for action records can be configured via interface style settings. See Configurable Settings.

Show/Hide Properties for Individual Records
You can also use the following ribbon commands to show/hide certain features for a particular action record.

Generic vs. Detailed: A detailed action contains additional properties for describing a specific test that needs to be performed (Specifications, Requirements and Reports). These properties are not configurable, and they can be used in the new Test Plans features in Xfmea/RCM++/RBI. (See Test Plans in the Xfmea/RCM++/RBI documentation.)

Show Resources: The resources fields (Team, Facility, Material and Additional Costs) are used for calculating costs and resource utilization. They are always enabled but you can toggle this command to hide or display them for any particular action record. The Check Utilization command provides a summary of the resources that have already been assigned. (See Costs and Man Hours.)

Show Review/Approval: If the Reviewer property is enabled in the configurable settings for the current project, you can toggle this command to hide or display these fields for any given action. The Review Action command will be enabled if you are assigned to review the action and it is ready to be reviewed. (See Review and Approve Actions.)

Priority
The color-coded Priority command provides a consistent scale for prioritizing actions across all projects in the database. (The same options are also available for gates in the Project Planner.)
This is intended to be used instead of the configurable **Action Priority** field from prior versions, which can be different for different projects. When you convert from a Version 8/9 database, the software will attempt to match any priorities that were assigned with the old configurable drop-down list. For example, if you were using the default "High," "Medium" and "Low" labels that were shipped with Version 8/9 libraries, they will automatically be mapped to the corresponding options in the new ribbon command.

**Action Status and Review Status**

The action’s status bar displays two complementary status indicators. The first one is based on the actual and expected start date and completion date. It indicates that the action is not started, in progress or complete and whether it is on time or running late. (See [Action Timeline and Status](#).)

The second one is based on whether a reviewer has been assigned in the Review/Approval section and, if so, the status of that review.

![Editing action properties](image)

**E-mail and Alerts**

The **E-mail** command will be enabled if an authorized user has defined a valid SMTP server. This allows you to manually send an e-mail containing the current action details to any valid e-mail address.

![E-mail](image)

If a valid SMTP server has been defined within the database, your team can also choose to use automated alerts (via e-mail or SMS text message). Each individual user can subscribe to “watch” specific action resources, and the database can also be configured to auto-subscribe users assigned to specific roles for the action. (See [Watches and Alerts](#).)
Chapter 26: Synthesis Resources

Click Action Monitors to specify individual users and/or groups of users who will always receive alerts for the record, regardless of whether they have personally subscribed to a “watch.” (See Action and Gate Monitors.)

Add to Outlook Calendar

The Add to Outlook Calendar command will be enabled if Microsoft Outlook is installed on your computer.

It launches Outlook’s interface for creating a new calendar event and automatically populates the subject and date. You can modify the details as needed before saving the new event to your calendar.

Note that you may need to give focus to the Outlook application in order to see the window.

Person Responsible and Resources

For each action resource, you can assign both an individual database user who is primarily responsible for completing the action and a team of users who are also involved. You also have the option to track the percentage of their available time that is planned to be utilized for the activity.

Tip: If a user is assigned as person responsible and also belongs to the team, the costs and utilization values will be summed. For example, the application assumes that the utilization is X% as person responsible plus an additional Y% as a member of the team.

Person Responsible

The Person Responsible field can be enabled or disabled, depending on the configurable settings for the current project. If you want to use personalized alerts, track resource utilization etc., you must select a database user. Alternatively, you can type a text description (up to 150 characters) that will be displayed in the FMEA spreadsheet.
Tip: If you want to change the person responsible for multiple actions simultaneously (e.g., if a user changes roles and his/her actions need to be reassigned), use the Actions Explorer.

If the Set action creator as 'Person Responsible' by default check box is selected in the Repository Settings window, then the person who created the action is automatically shown in the Person Responsible field, but that can be changed.

Resources
The Resources fields are always enabled but you can toggle the Show Resources command to hide or display them for any particular action record.

You can select from the teams, facilities and materials resources that have been predefined within the database (or create them on-the-fly if you have the required permissions). In a secure database, only users with the “Manage project planning resources and working days” permission will be able to create and edit these resources. (See Project Planning Resources.)

<table>
<thead>
<tr>
<th>Resources</th>
<th>Gizmo Design Team (5%)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Team</td>
<td></td>
</tr>
<tr>
<td>Facility</td>
<td>AES Test Lab (2%)</td>
</tr>
<tr>
<td>Material</td>
<td>N/A</td>
</tr>
<tr>
<td>Additional Costs</td>
<td>1000</td>
</tr>
</tbody>
</table>

Check Utilization
If you need to view the utilizations of users and facilities for the current action, click Check Utilization.

Action Timeline and Status
For all action resources, the status is determined automatically based on the actual and expected start(completion dates. If an action is included in the Project Planner, its expected timeline can automatically shift in response to delays in prior activities. If the action is not included in the plan, the expected dates are always identical to the originally planned dates.
Chapter 26: Synthesis Resources

The following status indicators are displayed in the status bar of the action properties window and in other relevant locations. (Note that the status bar now also displays a separate review status to indicate whether a user has been assigned to review/approve the action and, if so, the status of the review. See Review and Approve Actions.)

- **Not Started**: The action hasn't started, but it can still start on time.
- **Past Start Date**: The action hasn't started, and it is too late to start on time.
- **In Progress**: The action has started.
- **Past Due**: The action hasn't completed, and it is too late to complete on time.
- **Completed - On Time**: The action completed on time.
- **Completed - Late**: The action completed late.

**Costs and Man Hours**

For action resources, you can now track the planned vs. actual usage for both costs and man hours.

The **Planned Cost** and **Actual Cost** fields can be enabled or disabled, depending on the configurable settings for the current project. If the properties are enabled, the planned costs will always be calculated automatically based on the action duration, person responsible and project planning resources. For the actual costs, you can choose to enter manually or use the automatic calculations.

**Enter Manually**

If you prefer to enter the actual costs/hours instead of using the automatically calculated values, select Yes in the Manually enter costs/man hours? field.

<table>
<thead>
<tr>
<th>Manually enter costs/man hours?</th>
<th>No</th>
<th>Manually enter costs/man hours?</th>
<th>Yes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actual Cost</td>
<td>240.00</td>
<td>Actual Cost</td>
<td>475</td>
</tr>
<tr>
<td>Actual Man Hours</td>
<td>2.4</td>
<td>Actual Man Hours</td>
<td>5</td>
</tr>
</tbody>
</table>

**Let the software calculate**

**Enter the values yourself**

**Calculate Automatically**

The automatic calculations are based on:

- The Duration (the number of working days from the start date to the due/completion date).
• The Person Responsible and/or the Team:
  • The % utilization is set in each action record.
  • The Hours per Day and Cost Category are set in each user account record.
• The Facility (e.g., test lab or other facility needed to complete the action):
  • The % utilization is set in each action record.
  • The Max Hours per Day and Cost Category are set in each facility properties record.
• The Materials (e.g., test samples or other material needed to complete the action):
  • The Quantity and Cost Category are set in the material properties record.
• Any Additional Costs that are defined directly in each action record.

The following simple examples demonstrate how each type of cost is calculated.

**Personnel Costs**

**Action Duration:** 5 working days

**Joe Engineer:** Works 8 hours per day (5 days x 8 hours = 40 hours)

  Time is billed at $100 per hour (no “per instance” cost)

  Assigned as Person Responsible with 5% utilization (40 hours x .05 = 2 hours)

  Also belongs to the assigned Team with 1% utilization (40 hours x .01 = .4 hours)

The calculated values for Joe’s work on this action are 2.4 man hours and 2.4 x $100 = $240.

**Facilities Costs**

**Action Duration:** 5 working days

**ABC Test Lab:** Is available up to 8 hours per day (5 days x 8 hours = 40 hours)

  The utilization for this action is 20% (40 hours x .20 = 8 hours)

  Costs $500 “per instance” plus $50 per hour

The calculated cost for using this facility to complete the action is $500 + (8x$50) = $900.
Materials Costs

Gizmo Prototype: Costs $5000 to produce the batch of test units (the “per instance” cost)

The test requires 10 samples

Each unit costs $500 (the “direct cost per hour or unit”)

The calculated cost for the materials required to complete the action is $5000 + (10x$500) = $10,000.

Action Status Updates

For all action resources, the Progress (Status Updates) area displays any notes that have been added to report progress. The software automatically adds these updates under certain conditions (e.g., upon review/approval), and you can also create updates manually when needed.

To add a new note, click Add Status Update in the action’s ribbon or click the heading and then click the Add icon that becomes visible.

The type that you select in the Add Status Update window can affect the actual start and completion dates of the action, and also update the action status. (See Action Timelines and Status.)

- **Not Started** allows you to record comments without entering a start date. If an actual start date has already been entered, the update will remove the date and change the action’s status back to Not Started.

- **In Progress**
  - If an actual start date is not already defined, sets the current date as the Actual Start Date and allows you to specify the % Completed. This will change the action’s status to In Progress.
- If the action is already in progress, allows you to add another note and update the completion percentage.

- **Completed** sets the current date as the **Completion Date**. This will change the action’s status to either **Completed-On Time** or **Completed Late**.

To delete an existing note, click inside the field and then click the **Delete** icon that becomes visible. **There is no undo for delete.**

| Progress [Status Updates] | 2/3/2015 4:04 PM - Reliability Engineer - 0 %
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>In Progress</td>
<td>This is a short message to record progress for an action that is still in progress.</td>
</tr>
</tbody>
</table>

### Review and Approve Actions

**Action resources** can be marked for review and approval. If the Reviewer property is enabled in the **configurable settings for the current project**, you can click **Show Review/Approval** in the action ribbon to hide or display these fields for any given action.

(Note that if an action has been assigned for review or is already reviewed, you can no longer hide the fields.)

### Assigning a Reviewer

If an action has not yet been reviewed, any user who is able to edit the record can assign or change the reviewer at any time.

In a secure database, the Reviewer drop-down list contains all of the database users who have the **"Approve actions" permission**.

- If a user has been assigned to review the action but an actual completion date is not entered, the review status will be **Reviewer Assigned**.

- When the completion date is entered and the action is ready for review, the status will be **Pending Approval**.

**Tip:** If you want to change the assigned reviewer for multiple actions simultaneously (e.g., if a user changes roles and his/her actions need to be reassigned), use the **Actions Explorer**.
Chapter 26: Synthesis Resources

Reviewing and Approving the Action
When you are assigned to review/approve an action that has been completed, the record will be highlighted for you in My Portal (and in the Synthesis Enterprise Portal if implemented), and you may also receive automated alerts (via e-mail and/or SMS) if applicable.

To record your decision, open the action record and choose Review Action.

In the Review Action window, you can choose one of the following options:

- **Approve action** assigns the review date/time and marks the status Approved.
- **Reject and re-open action** removes the completion date and marks the status Rejected and in progress. The team can perform any rework that is needed and resubmit the action for another review.
- **Reject and close action** marks the status Rejected and closed.

You can enter your comments directly in this window, or enter/update them later in the comments field.

Configurable Settings for Actions and Controls
Some of the properties in action records and in control records are configurable via the interface style settings that have been defined for the current project. The interface style is used in Xfmea/RCM++/RBI to customize a variety of analysis fields to fit the organization’s particular preferences and needs. (See Configurable Settings in the Xfmea/RCM++/RBI documentation.)

You can view/edit the configurable settings for actions and controls from any Synthesis desktop application by clicking Configurable Settings of the action properties window or the control properties window. (In secure databases, this is available only if the user is the project owner, or has the "Edit project properties" permission.)
Any changes to these settings will apply to all records of that type in the current project.

**Actions Explorer**

The Actions Explorer is available in all Synthesis desktop applications except MPC. You can use this flexible tool to explore all of the action resources that are stored in the current database.

To access the utility, choose **Home > Synthesis > Actions Explorer**.

To reduce the amount of time required to populate the grid, first use the Project, Status, User and/or Date filters to limit your search, then click **Load Data**.

![Load Data](image)

**Add, Edit and Delete Actions**

When actions are loaded in the grid, you can use the following ribbon commands to add, edit and delete actions. (In a secure database, the ability to add or edit an action is only available for users with the "Create/edit/delete local resources" or "Create/edit/delete local resources" permission in the relevant project.)

To delete or edit multiple actions at the same time, press **CTRL** or **SHIFT** while clicking rows in the grid. Selected rows will be highlighted.

![Add Action](image)

**Add Action** creates a new action resource in the project that currently has focus.

![Edit Action](image)

**Edit Action** allows you to view and edit all of the properties of the action that is currently selected.

![Delete Action](image)

**Delete Action** deletes all of the actions that are currently selected. There is no undo for delete.

![Assign Person Responsible](image) and ![Assign Reviewer](image) allow you to set (or change) the person responsible or reviewer for all of the actions that are currently selected.

**Save and Apply Views**

Once you have customized the grid to suit a particular purpose (using the built-in filter, column configuration and grouping features described below), you can save the preferences as a view that can be used again whenever you need it. A view is saved in the database and available only to the user who created it.
Chapter 26: Synthesis Resources

To create a view, first configure the grid to suit your particular needs and then click **Save View**.

To quickly apply these same preferences again at any time, click **Apply View** and select one of the saved views from the list.

**Note:** The view does not affect filtering that has been applied from the Project, Status, User and/or Date filters, or from the Relevance Panel.

**Project, Status, User and Date Filters**
The Actions Explorer can utilize the same **project filter** that is available in many other locations throughout Synthesis desktop applications.

You can also filter by status (e.g., In Progress, Completed, etc.), user (e.g., Person Responsible or Reviewer) and date (e.g., Planned Start Date, Actual Start Date, etc.).

After you clear or change these filters, you must click **Load Data** again to update the grid.

**Relevance Panel**
The relevance panel provides a quick way to filter the actions based on how they are relevant to you (based on your personal username).

- **I am responsible for**
  - You are assigned in the **Person Responsible** field.

- **I am a team member in**
  - You belong to the team assigned in the **Team** field.

- **I need to review/approve**
  - You are assigned in the **Reviewer** field.
• I am monitoring
  • You are assigned in the Action Monitors window, or you have personally subscribed to “watch” the action.

• Other actions I created
  • You are listed in the Created By field and none of the other roles apply.

• All actions
  • Displays all actions, regardless of whether they’re relevant to you.

**Built-in Find/Filter, Configuration and Grouping Tools**
The Actions Explorer offers the same filter, column configuration and grouping tools that are built in to other Synthesis utilities that use a similar grid (e.g., the Resource Manager). For details about how to use each feature, see:

- Finding and Filtering Records
- Configuring Columns
- Grouping Panel

**Controls**
Controls are Synthesis resources used in FMEAs that are the methods or actions currently planned or already in place to reduce or eliminate risk. Controls can be managed via the Resource Manager.

As with any other Synthesis resource:

• Any changes to the control properties will be reflected in all locations where the resource is used.

• If you remove a control from an FMEA, it will remain in the project unless/until an authorized user deletes it from the database.

• If a control resource is not currently used in an FMEA, you can delete it via the Resource Manager. (In a secure database, this is possible only if the user a) is the project owner, b) is the control creator, or c) has the applicable "create/edit/delete resources" permission.)
For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

**Note:** Controls are always local resources. They cannot be made global. Controls in a reference project are local to that project and can’t be selected for use in other projects.

For specific instructions on using controls in FMEAs, see the "Controls in FMEAs" topic in the Xfmea/RCM++/RBI documentation.

### Configurable Settings

Some properties for controls can be configured via interface style settings. See Configurable Settings.

### Resource Manager

The Resource Manager allows you to create, view, edit and delete Synthesis resources. It also helps you to trace where each resource is used, and to create global resources that are available to all projects in the database.

To open the Resource Manager, choose **Project > Synthesis > Resource Manager**.

To use the utility, choose the type of resource that you want to work with in the navigation panel on the left side of the window. A table that displays the resources of the selected type will be shown on the right side of the window.

**Tip:** When you need to create or edit a large number of resources, you can also use Synthesis APIs to import the data from an Excel file or other data source. For example, the URDExample_V10.xlsm file at C:\Users\Public\Documents\ReliaSoft\Examples10\API enables you to quickly create/update multiple URDs with some basic properties (models and corrective tasks). If you have the necessary software coding experience, you can expand this tool or create your own custom applications to meet specific needs.
Resource Filter
The Resource Manager can utilize the same resource filter that is available in many other locations throughout Synthesis desktop applications.

Built-in Find/Filter, Configuration and Grouping Tools
The Resource Manager offers the same filter, column configuration and grouping tools that are built in to other Synthesis utilities that use a similar grid (e.g., the Synthesis Explorer, Actions Explorer, etc.). For details about how to use each feature, see:

- Finding and Filtering Records
- Configuring Columns
- Grouping Panel

Creating, Viewing, Editing and Deleting Resources
You can:

- Create a new resource of the selected type by choosing Home > Edit > New.

To add multiple resources at the same time, specify the quantity in the Home > Batch Add > Number to Add field and then choose Home > Batch Add > Add Items. You will specify the properties for one of the new resources, and the additional resources will be duplicates of that. You can then edit each resource individually, or you can go to the Batch Properties Editor to edit them in a spreadsheet format.

- Duplicate an existing resource by selecting the row in the table and choosing Home > Edit > Duplicate. You can choose to duplicate just the selected resource, or choose Cascade Duplicate to duplicate the resource and all resources assigned to it, at all levels (e.g., cascade duplicating a corrective task will also duplicate the task's duration model, the assigned crew and all models assigned to the crew, etc.).
Chapter 26: Synthesis Resources

- View or edit an existing resource by double-clicking the row in the table or by selecting the row and choosing Home > Edit > View.

- Delete an existing resource by selecting the row in the table and choosing Home > Edit > Delete.

You cannot delete a resource that is currently being used in any other resource or analysis.

**Note:** A published model cannot be edited or deleted from the Resource Manager. If changes are needed, you must update the original analysis and then republish the model. If you wish to delete the model, you must first remove the association with the original analysis and also make sure the model is not being used. (See [Publishing Models](http://xfmea.reliasoft.com).)

**Tracing Where Resources Are Used**

With a single resource selected, you can choose Home > Actions > Trace Usage to open the Dependency Viewer, which provides information on where the resource is used and any additional resources that the currently selected resource itself uses.

If you need to know which resources are not currently being used (e.g., because you want to delete obsolete records), choose Administration > Selection > Show Only Unused.

**Local and Global and Reference Resources**

As explained in Local, Global and Reference Resources, the availability of Synthesis resources for use is determined by their scope. Local resources are available only in the current project. Reference resources are available for any project within the database, depending on the user's permissions within the reference project. Global resources are available for use in any project in the database.

The far left column in the Resource Manager displays an icon that indicates whether each resource is local, global or a reference resource.

![Local Resource](http://xfmea.reliasoft.com)

![Global Resource](http://xfmea.reliasoft.com)

![Reference Resource](http://xfmea.reliasoft.com)
You can use the Home > Filter > [Show Local/Show Global/Show References] commands to toggle the types of resources shown in the Resource Manager.

**Exporting Information from the Resource Manager**

To print the current view of the Resource Manager, choose Home > Edit > Print.

To send the contents of the Resource Manager to Excel, or to a built-in Synthesis Workbook or spreadsheet if that's available in the current application, choose Administration > Actions > Transfer Report.

You can send either the current item (i.e., the table for the currently displayed page) or the full report (i.e., the tables for all pages in the Resource Manager).

**Finding and Filtering Records**

This topic describes the find and filter tools that are built in to the Resource Manager and other Synthesis utilities that use a similar grid. Each of these tools can be used separately, or in conjunction with the others.

**Find Panel**

The Find panel allows you to search for a word or phrase across all of the available properties. When you enter text, it will:

- Show only the rows that contain the text you specified.
- Highlight all of the locations where the matching text occurs.
Chapter 26: Synthesis Resources

To show or hide this panel, toggle the **Show Find Panel** command on the ribbon or in the shortcut menu that appears when you right-click a column heading.

To stop filtering the data, clear the text box.

**Auto Filter Row**
The Auto Filter Row allows you to automatically filter the grid by matching text in one or more columns. For example, the following grid shows only the rows in which the model name contains "Component A" and the distribution contains "Weib."

To display or hide this row, toggle the **Show Auto Filter Row** command on the ribbon or in the shortcut menu that appears when you right-click a column heading.

**Advanced Filters**
The Advanced Filters allow you to choose an automatically generated filter or create a quick custom filter. The automatically generated filters are based on the unique values that currently exist in the column.
For example, the following picture is based on a data set that contains models from three different categories. If you choose one of the automatically generated filters (e.g., "Reliability"), the grid will display only models of that one selected category.

If you want to see models from two of those categories (e.g., either "Reliability" or "Probability of Failure"), you can choose (Custom) and create a quick custom filter like this:

If a filter has been applied for a particular column, select (All) to remove it.

**Current Query Criteria**

When you are filtering the grid using the Auto Filter Row, Advanced Filters and/or Edit Filter window (described below), the current query criteria will be displayed at the bottom of the window. For example:

- Click the X to delete the current set of filter criteria.
Clear the check box to remove the current set of criteria without deleting it. Select the check box if you want to re-apply it.

Click \( \square \) to choose from a list of filter criteria that were recently applied.

**Edit Filter**
The Edit Filter window provides the most flexibility to refine and adjust a filter in either a grid or a Dashboard layout. To access the tool, click the **Edit Filter** button to the right of the current query criteria (if applicable), or choose **Edit Filter** from the shortcut menu.

As an example, the following filter from the Resource Manager will display only cost per unit time models in which the rate equals either $120 per hour or $2 per minute.

- Click a red label if you want to:
  - change the *logical operator* (And, Or, Not And, Not Or)
  - add or remove a *group*
  - add a *condition*
  - clear the entire filter

- Use the \( \bullet \) and \( \checkmark \) icons to add or remove *conditions* within an existing group.
- Click a blue label if you want to change the *property* (e.g., Model Name, Created By, etc.).
• Click a green label if you want to change the *relational operator* (e.g., Equals, Contains, Begins with, etc.).

• Click a gray or black label if you want to enter or change the *value*.

### Configuring Columns
This topic describes the capabilities for selecting, reordering, resizing and sorting columns that are built in to the Resource Manager and other Synthesis utilities that use a similar grid.

### Selecting Columns
To specify which columns will be displayed in the grid, click **Select Columns**.

In the utility's window or panel for selecting columns, use the check boxes to choose which columns will be displayed. As an example, the following pictures show the window and panel for model resources in the Resource Manager.
Chapter 26: Synthesis Resources

Reordering Columns
To change the column order, drag the column heading into the desired position.

Resizing Columns
To resize columns, you can do any of the following:

- Drag the edge of the column heading to the desired position.
- Double-click the edge of the column heading or right-click it and choose Fit This Column. This will resize the column to fit its data.
- Right-click any column heading and choose Fit All Columns. This will resize all columns to fit their own data.

Sorting Columns
To sort the grid by one column at a time, you can simply click the column heading to sort in ascending order (↑), or click it again to sort in descending order (↓).

To sort the grid by multiple columns, right-click each column in the desired order and choose Sort Ascending or Sort Descending each time. For example, the following picture shows Synthesis Explorer data sorted first by project (ascending) and then by category (descending).

To stop sorting, right-click any column heading and choose Clear All Sorting.
Grouping Panel

This topic describes the grouping panel capability that is built in to the Resource Manager and other Synthesis utilities that use a similar grid.

When you are working with a large amount of data, it may be convenient to group it based on one or more properties. For example, the following picture shows resources in the Resource Manager grouped first by keyword and then by model category.

![Grouping Panel](image)

To group the data without opening the grouping panel, right-click any column heading and choose Group By This Column. Alternatively, you can choose Show Grouping Panel to display the panel and then drag column headings into or out of the panel to configure the groups.

When the grouping panel is displayed, you can also:

- Click the column heading to change the sort order between ascending (↑) or descending (↓).
- Drag column headings within the panel to change the grouping order. For example, if you prefer to group first by model category and then by keyword, drag the column headings as shown below.
Removing Unused and Duplicate Resources

The Resource Manager provides several tools to make it easy to delete unused resources and merge duplicate resources.

Finding and Removing Unused Resources

To find unused resources of the selected type, choose Administration > Selection > Show Only Unused.

Once you have found the unused resources, you can decide which ones to delete.

You can return to viewing all resources of the selected type by choosing the Show All command.

Finding Duplicate Resources

You may sometimes have duplicate resources within a project (i.e., several models that all represent the identical distribution, several tasks that are identical, etc.) within a project. For example, this might happen if you have imported diagrams that all reference the same model, but the imports happened at separate times and therefore the model had to be imported again each time.

To find duplicate resources, choose Administration > Selection > Show Only Duplicates.

In the window that appears, select the properties that must match in order for the resources to be considered duplicates. For example, if you are looking for duplicate URDs, you might select...
to compare the model, corrective task and scheduled tasks, but not the URD name. Once you have selected the columns to compare, click OK to show the duplicate resources.

You can merge multiple resources of the same type into one resource, either automatically or manually. Note that models must be of the same category in order to be merged, and you cannot merge published models.

**IMPORTANT:** Merging cannot be undone, and only the information from the "target" resource (i.e., the resource that you merge the others into) will be retained.

### Automatically Merging Duplicates

To merge resources automatically, choose **Administration > Actions > Merge All Duplicates.**

This will find all sets of duplicates within the selected resource type (e.g., three identical Weibull models and 2 identical lognormal models); and for each set, it will merge the duplicates into the first instance found. After you confirm that this is what you want to do, you will be prompted to select the properties that must match in order for the resources to be considered duplicates. The process begins as soon as you select at least one column and click OK. It cannot be undone.

### Selecting Resources to Merge

To merge resources manually, select the resources and choose **Administration > Actions > Merge & Delete.**

The window shows a list of the resources you selected to merge and allows you to choose which one will be retained (i.e., the one that the other selected resources will be merged into). After you click OK, this resource will be used in all places where the other selected resources were previously used.

### Select Resource Window

The Select Resource window allows you to choose an existing resource to use at your current location. You will see this window in situations like the following:

- When you click the **Select Existing** icon in any resource wizard.
• When you are adding an existing action in an FMEA or in the Project Planner, or an existing control in an FMEA.

The Select Resource window is similar to the Resource Manager, but it shows only the resource type that you are currently working with. The functionality of the window will vary slightly depending on where you have opened the window from.

• If you can select only one resource (e.g., in a resource wizard), each row in the table will contain a radio button that allows you to select the resource for use. If you can select multiple resources (e.g., adding existing actions or controls in an FMEA), each row will have a check box instead.

• Actions, controls and metrics are always local, so the commands to show global or reference resources will not be available in these cases.

• The ability to apply an item filter is available only for resources that have a full set of Synthesis identifiers. This excludes actions and controls.

• Some resources may not be available for selection. For example:
  • In an FMEA, you can't select an action or control that is already assigned to the current cause.
  • In the project planner, an action cannot be added if it is already in use in the project plan or if its start date is either before or more than a year after the gate's start date.
  • A metric can't be selected to have a value pushed to it if it's already in use somewhere else, or if it's a type that is not compatible with the current use.

**Trace Usage**

**Dependency Viewer**

Because resources can be used multiple times, it is important to know where a given resource is used before making changes to it. The Dependency Viewer, which is accessed by clicking the Trace Usage icon in each resource properties window or in the Resource Manager, provides information on where the resource is used and what additional resources, if any, it uses.

The selected resource is shown in the Current Selection area in the middle of the Dependency Viewer.
Chapter 26: Synthesis Resources

The items that use the selected resource, if any, will be displayed in the **This [resource] is used by** area on the left. If it uses any resources, those resources will be displayed in the **This [resource] uses** area on the right. For example, in the picture shown next, the selected resource is a URD. It is used by Block 1 in a BlockSim diagram and by SubSystem 1 in an FMEA analysis. The URD uses an assigned model and two tasks.

![Dependency Viewer](image)

You can edit any resource shown in the Dependency Viewer by right-clicking it and choosing **Edit Item** on the shortcut menu. The resource's properties window will open.

You can double-click an item in either area to make it the current selection in the window. For example, you could double-click a task used by the URD to see the model(s), crew(s) and/or spare part pool(s) that the task uses.

As you change selected items, each previous item that you selected will be added to the “path” of recent selections at the top of the window; click **Back** to go back through the path to the previously selected items. For example, the following picture shows a path in which the user started with the URD, then proceeded to its corrective maintenance task, the crew for that task and the logistic delay for that crew (not shown in the path because it is the current selection). The button now provides a quick way to go back through those same resources in reverse order if needed.

![Path Example](image)

You can click the **Diagram View** button to open the **diagram view** of the Dependency Viewer. The currently selected item will be the main block in the diagram that is created.
Choosing What You See

In the **Current Selection** area, you can choose what is shown in the **This [resource] is used by** area. You have the option to skip the URD and/or the block that the resource is used by. For example, the image below shows the connections among analyses and resources that we have been discussing. If you have selected to show all levels, you can trace from Reliability Model to URD 1 to Block 1 to RBD 1. But if you have selected **Skip Blocks and RBDs**, it just shows that Reliability Model is used by RBD 1.

![Diagram of connections among analyses and resources](http://xfmea.reliasoft.com)

Note that blocks are always skipped in RENO flowcharts (i.e., only the flowchart will be shown as the precedent for a resource used by any block within the flowchart).

Dependency Viewer - Diagram View

The diagram view of the Dependency Viewer, which is accessed by clicking the **Diagram View** button, offers a diagram-based alternative to help you understand the connections among resources in your project.

To understand how to use this view, consider the same example shown in the **Dependency Viewer** topic. Clicking the **Diagram View** button for that example will yield a diagram view that shows only the main item (in this case, the URD), which is marked with a flag:
To view a graphical representation of the information that was shown in the Dependency Viewer, choose **Add One Level Precedents** and **Add One Level Dependents**. This will show the items that use the resource (i.e., its precedents), and the resources that it uses, if any (i.e., its dependents).
If you want to see all levels, choose Add All Precedents and Add All Dependents:

If you want to add or remove one branch at a time, click the green arrows on the sides of the blocks. Alternatively, if you want to remove one branch, select the block and choose Delete Precedents or Delete Dependents.

To set a different item as the main item in the diagram, select it and choose Set Block as Main. This serves the same purpose as changing the selected block in the Dependency Viewer.

Use the commands in the Options group of the ribbon's Home tab to specify how the diagram will be constructed:

- Select Reuse Items to show each item only once in the diagram. For example, if you are viewing a URD that is used by two blocks in the same diagram and you choose Add All Precedents, the Reuse Items command will affect the display as shown next:
This command must be selected before the diagram is created, or you must clear the current diagram to apply it.

- Use the **Show Blocks in RBDs/FTs** and **Show URDs** commands to determine whether blocks and/or URDs are shown as intermediate steps between resources and the analyses in which they are used.

- Select **Show Item ID** to display the internal ID assigned to each resource, block and/or diagram. These IDs can be used to differentiate among items that share the same name.

The Diagram tab of the ribbon offers zoom options and **printing options**, as well as the ability to copy the diagram or to export it as a graphics file.

### Batch Properties Editor

The Batch Properties Editor is designed to support batch editing of most types of local resources in the current project. In BlockSim, it also allows you to edit the blocks used in the diagrams. It enables you to edit the properties in a convenient grid, rather than opening the properties window for each individual resource/block. This utility is available for all desktop applications except MPC.

To open the Batch Properties Editor, choose **Project > Synthesis > Batch Properties Editor**.

To use the utility, choose the type of resource or diagram that you want to work with in the navigation panel on the left side of the window. The right side of the window shows the
resources or blocks you can edit. For information on configuring the table and limiting the items shown, refer to the Configuring Columns and Finding and Filtering Records topics.

**Tip:** If you change the information in one column, it may affect the information required in another column. For example, if you are editing a model and you change the Model Type column from "Weibull-2" to "Weibull-3," then the Parameter 3 column will change from "N/A" to requiring a numerical input for the third parameter for the Weibull distribution (i.e., gamma).

The changes you make in the Batch Properties Editor will be saved when you close the window. You can also choose Home > Display > Refresh to commit your changes immediately and refresh the Batch Properties Editor to display the most current information, including recent changes by other users.

Note the following:

- **Gray Background.** If the property does not apply to the corresponding resource or block, "N/A" will appear in the column and the cell will have a gray background. Properties that cannot be edited via the Batch Properties Editor, such as the model category, will also have a gray background.

- **Published Models.** Models created by publishing results from an analysis in a Synthesis application cannot be edited in the Batch Properties Editor. To edit a model that was published from an analysis, you must return to the original data source, make the necessary changes, recalculate and republish the model.

- **Model Parameters.** Since the required parameters for a model will vary depending on the model type, the way you use the parameter columns in the Batch Properties Editor will vary. The parameter columns in the Batch Properties Editor for each model type are presented in the table shown next.
Spreadsheet Editor
You can choose the Spreadsheet Editor command on the ribbon to open the Spreadsheet Editor, which displays the resources or blocks in a spreadsheet-based view. This enables you to use the capabilities inherent in a spreadsheet (e.g., batch copying, formulas, etc.) to make editing multiple items easier. When you are finished editing, choose Close > OK to save your changes and close the Spreadsheet Editor or Close > Cancel to close the Spreadsheet Editor without saving your changes.

Exporting Information from the Batch Properties Editor
To print the contents of the Batch Properties Editor, choose Administration > Output > Print command on the ribbon.

To send the contents of the Batch Properties Editor to Excel, or to a built-in Synthesis Workbook or spreadsheet if that's available in the current application, choose Administration > Output > Transfer Report.
Chapter 26: Synthesis Resources

You can send either the current item (i.e., the table for the currently displayed page) or the full report (i.e., the tables for all pages in the Batch Properties Editor).

Tip: When you need to create or edit a large number of resources, you can also use Synthesis APIs to import the data from an Excel file or other data source. For example, the URDExample_V10.xlsm file at C:\Users\Public\Documents\ReliaSoft\Examples10\API enables you to quickly create/update multiple URDs with some basic properties (models and corrective tasks). If you have the necessary software coding experience, you can expand this tool or create your own custom applications to meet specific needs.
Chapter 27: Synthesis Project Planner

The Project Planner provides extensive project planning and management capabilities, including the ability to create timelines, evaluate progress, track resource usage and estimate costs. Any project in a Synthesis repository can be associated with a project plan.

The Project Planner allows you to create, edit or view the plan in any Synthesis desktop application except MPC. If the Synthesis Enterprise Portal (SEP) has been implemented for an enterprise database, you can also access a streamlined view of the plan from any web-enabled device.

Creating a Project Plan

Each project in the database can have a project plan. To view the plan from within an open project, choose Project > Management > Project Planner. (In a secure database, any user with "read" access to the project will be able to view the plan and update any actions that are assigned to them. However, only users with the "Create/edit project plans" permission will be able to create or edit the plan.)

A blank plan will be created automatically the first time you open the Project Planner in a given project. By default, the project plan shows a sample starting gate, which records the date you opened the project plan for the first time. You can edit the sample gate and start building the plan from there.

Importing or Starting Again from a Blank Plan

Alternatively, you can start again from a blank plan or import an existing project plan from another project. In the Project Planner, choose Project Planner > Plan > Create Project Plan. (In a secure database, this command is available only to users with the "Create/edit project plans" permission.)
Then choose one of the following options. In both cases, you will need to enter the date the plan will begin in the **Set Start Date** field at the bottom of the window.

- Choose **Blank** to start again from a blank plan. This will delete all of the current gates *(there is no undo for delete)*. It will also remove any actions that are assigned to the plan. The action resources will remain in the database unless/until an authorized user deletes them from the database via My Portal, Resource Manager or Actions Explorer.

OR

- Choose **Import from another project** to import an existing plan. You can import from another project in the current database or from any other existing standard or enterprise database.

Choose a source repository and source project for the import. The **Plan Preview** area shows the gates and actions (if any) in the project that is currently selected. By default, the import includes both gates and actions. If you want to import gates only, clear the **Include actions** check box at the bottom of the window.

**Tip:** If you want to use any of the Design for Reliability (DFR) project planning “starter” templates that were installed with Xfmea/RCM++/RBI Version 9, you can either import directly from one of your own projects (converted to Version 11), or use the "Project_Planner_Templates_Rev1" database (choose **File > Help > Open Examples Folder** then open the file in the "Project Planner" folder). To preserve the integrity of this database, a copy will be created.

---

**Project Plan Hierarchy**

In the **Project Planner**, the plan consists of gates arranged in a tree-based hierarchy to represent the different phases of a process. You can also include **action resources** that represent specific assignments that need to be performed. For example, the configuration below shows a plan with five top-level gates (Concept Phase, Design Phase, etc.), where each gate has its own sub-gates and actions.
Certain properties of higher-level gates (e.g., status and dates) are determined by the properties of their dependent gates and actions. For example, the "Concept Phase" above has two direct dependents. If these are marked as complete, then "Concept Phase" is automatically marked complete. (See Gates in the Project Plan for details on how gates inherit their properties.)

In this way, the planner makes it easy for you to monitor how the progress of individual activities relates to the completion of the entire process.

**Project Planner Columns**

To hide or display Project Planner columns, right-click the column headings then click Customize Columns. (You can also change the column order by dragging and dropping column headings into the desired positions.) These settings are stored per computer/username. Any project that you open on this computer will have the same columns displayed, but other users may have different display preferences.

- **General** columns display graphics/text to summarize the status, as well as the priority level and percent completion.

- **Planned Timeline** columns display information about the original plan, including planned start/due dates and resource usage. You can also display the percentage of the budget that is allocated to different project planning resources (i.e., teams, facilities and materials).

- **Expected Timeline** columns display expected start/completion dates given any delays that may have occurred for prior activities, as well as estimates of the costs/man hours to date. (See Project Planner Timelines.)

- **Actual Timeline** columns display actual start/completion dates, as well as the costs/man hours that were used for completed gates/actions.
• **Delta Values** columns compare two different values, such as the difference between an action's actual and planned costs.

• **Relevant Metrics** display values for up to three selected metrics. (See [Using Metrics in Project Planner Gates](http://xfmea.reliasoft.com).

• **Notes** display other applicable information, including descriptions, completion notes and whether an attached file exists.

### Project Planner Timelines

For gates in the Project Planner and for any action resource that is included in a project plan, three different timelines are used to track progress:

• The **Planned** timeline consists of the originally planned start/completion dates.

• The **Actual** timeline records when a gate or action has actually started or completed.

• The **Expected** timeline shows the start/completion dates that are now expected given the current situation. For project plans that use precedents, the expected dates for an activity automatically shift in response to delays in prior activities.

All of these timelines can be shown in gate/action properties and in the Project Planner hierarchy columns. The expected dates are used to determine the status (e.g., past start date, past due, etc.) and are also shown on the summary panel.

### Planned Dates

For actions and for gates with no specified precedent, the planned start/completion dates are entered directly in the [Gate Properties window](http://xfmea.reliasoft.com).

For gates with precedents, the planned start date is automatically set to the working day following the precedent's due date (i.e., planned completion date). By using precedents in your plan, you guarantee that there will be no gaps between one gate's due date and the next one's start date.

In addition, the software uses the following rules to make sure a gate's planned timeline is consistent with that of its dependent gates and actions:

• If a gate's planned start date is changed (e.g., because of changes to a prior gate's planned duration), the planned dates of all dependents will be shifted in the same way.

• You cannot change a dependent's planned start date to precede that of its parent gate.

• If a dependent's due date is changed so that it comes after its parent gate's due date, the parent gate's due date will be changed to match it.
Actual Dates
Actual start/completion dates are entered directly for actions and for gates with no dependents. For gates that have dependents:

- The parent gate's actual start date is automatically set to match the earliest actual start date of its dependents.
- Once all the dependents have completion dates, the latest of those dates is set as the parent gate's actual completion.

Expected Dates
By default, expected start/completion dates are equal to the planned dates. However, if the gate/action is part of a plan that uses precedents, the two timelines can differ.

Specifically, when precedents are used, the expected dates will automatically shift in response to recorded delays in prior gates (while the planned dates remain unchanged). For example, if Gate A is the precedent of Gate B, and Gate A completes two days late, then the expected dates for Gate B will be its planned dates + two days. The same will apply to any other gates with precedents that trace back to Gate A.

As an example, consider the following Gantt chart for a plan that has not yet started. The planned and expected timelines (shown in gray and black, respectively) are identical at first.

However, if Gate A completes late (shown in red), the expected timeline shifts for the remaining gates. (The overall plan bars at the top also indicate that the expected duration for the entire plan has now increased by two days.)
Project Planner Gates

Each gate in the Project Planner has its own properties and a status that is determined based on its expected start/completion dates. Additional information about progress and resource usage is available in the summary panel.

To view the properties of a gate, double-click it, or select it and choose Project Planner > Gate > Edit Gate.

Gate Properties

- The Gate fields provide general information about the gate, including its Name, Description and:
  - Deliverables are what will be produced and delivered as a result of completing the gate.
  - Priority is a ranking of the gate's importance ("Low," "High," etc.).
- The Precedent Gate field identifies the gate that must be completed before the current gate can start, if any. If you choose to use precedents in a project plan:
  - The precedent gate must be on the same level in the hierarchy as the current gate. (If the Use Precedence option is selected, the precedent will be suggested automatically for each new gate you create but you can change it manually if desired.)
  - When a gate has a precedent, its planned start date will be automatically set to the working day after the precedent's due date. In addition, delays in the precedent will automatically shift the expected timeline for future gates.
- The Planned Timeline consists of the originally planned start/completion dates.
- The Expected Timeline shows the start/completion dates that are now expected given the current situation. For project plans that use precedents, the expected dates for an activity automatically shift in response to delays in prior activities. (See Project Planner Timelines.)
- The Actual Timeline records when a gate or action has actually started or completed. If the gate has dependents, these dates are automatically inherited in the following way:
  - The actual start date is the earliest actual start date from the dependents.
Chapter 27: Synthesis Project Planner

- The actual completion date is the latest actual completion date from the dependents.

- The **Relevant Metrics** fields let you display up to three relevant metrics in the gate. The **Push to Metrics** fields let you "push" the gate's percent completed and actual vs. planned resource usage to metrics so they can be tracked and displayed in other locations. (See Using Metrics in Project Planner Gates.)

- The **History** fields display information about when the gate was created and last modified. If the **history log** has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the item.

- **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the gate is changed. (See Subscribing to a Watch.)

- **Gate Monitors** allows you to specify individual users and/or groups of users who will receive alerts for the gate, regardless of whether they have personally subscribed to a watch. (See Action and Gate Monitors.)

**Gate Status**

The gate status (which is displayed in the summary panel and in the status bar) is determined based on the same logic used for action statuses, which takes into account the expected start/completion date and any actual dates. For example, a gate's status is "Past Start Date" if it hasn't started and it's too late to start by the expected date, while "Past Due" means it is too late to complete on time.

**Actions in Project Plans**

You can add actions to gates in the Project Planner in order to track specific assignments that need to be performed as part of specific phases of the plan. These are the same **action resources** that can be included in My Portal and Synthesis Enterprise Portal, as well as FMEAs or Test Plans in Xfmea/RCM++/RBI.

When you add an action to a gate in the Project Planner, the software will:

- Use **timelines** in the action that automatically shift in response to delays in prior activities, which will affect how the action's **status** is determined.

- Display the action's **plan summary** in the Action properties window.
• Use the action’s status, percent complete and resources to “roll up” to the gate it is assigned to.

**Adding Actions to the Plan**

With a gate selected in the Project Planner, choose **Project Planner > Action > Add Action**. (In a secure database, this is only available to users with the **“Create/edit project plans” permission**.)

- **Add Action** creates a new action resource.
- **Reuse Action Resources** allows you to select existing action(s) from the project that a) are not already used in the current plan and b) have dates that fit within the current gate. Specifically, the action’s start date can’t be before or more than a year after the gate’s start date. (See **Select Resource window**.)
- **Reuse FMEA Actions** allows you to select one or more Xfmea/RCM++/RBI system hierarchy items from the current project that have FMEAs. You can then select to use existing action(s) from those particular FMEAs in the project plan.

**Project Plan Summary Panel**

The project plan summary panel displays information about start/completion dates, status, progress and resource usage for an entire project plan, and for individual gates and actions.

The summary panel is accessible from multiple locations across the Synthesis Platform:

- From the **Project Planner**, you can select a gate or action in the hierarchy to view its summary, or you can select the project at the top of the hierarchy to view a summary of the entire plan.
- The gate/action properties window shows the summary for that gate/action.
- The **Plan Summary Page in My Portal** displays a summary of the entire plan for the project that currently has focus.
- These summaries are also displayed in the web-based **Synthesis Enterprise Portal (SEP)**, if it is implemented for an enterprise database.
In most cases, this shows the current date. If you are working in the Project Planner and you want to see what the statuses would be on a different date, click the green “play” arrow and then select a different date from the calendar. When you’re ready to return to the current date, click the green “pause” bars.

This bar displays the name of the project, gate or action that the summary applies to, followed by:

- The EXPECTED start date and completion date. (This will be the same as the planned dates unless a prior delay has caused the expected dates to shift.)
- The ACTUAL start date and completion date (if the action is in progress or complete).
- The current status. (See Action Timeline and Status.)

For actions, the progress bar shows the percentage entered by the user. For gates, it shows the percentage of the total duration of dependent actions/gates that is complete. For example, if Action 1 (duration = 3 days) is complete and Action 2 (duration = 1 day) is incomplete, the progress is 75%.
For resource usage, the black bars show the planned man hours and costs. The colored bars show either the expected usage to date (estimated based on the number of days in progress), or the actual usage if complete. (See Costs and Man Hours.)

- **Yellow** = In progress and usage to date is still within plan
- **Orange** = In progress and usage to date has exceeded plan
- **Green** = Complete and actual usage was within plan
- **Red** = Complete and actual usage exceeded plan

The pie chart will be visible only for projects or gates that have at least one action assigned (either directly or via dependent gates).

- **Not Started** = Actions that have not started and can complete on time
- **In Progress** = Actions that are in progress and can complete on time
- **Completed** = Actions that have a completion date
- **Past Due** = Actions that can no longer complete on time
Check Utilization

The Check Utilization window lets you examine the utilizations for individual users and facilities across one or more actions. It displays the total utilization for each resource on each specific date, so you can easily identify dates when the resource is over-utilized and make any adjustments that may be needed.

- To view utilizations for a specific action, open the action and choose Tools > Check Utilization.
- To view utilizations across multiple actions, open the Project Planner and choose Project Planner > Tools > Check Utilization.

If you open the utility from the Project Planner ribbon, there are two options. By default, it shows Only actions in this plan. Alternatively, you can choose to see utilizations from All actions in the project (even if they are not used in the plan).

Regardless of whether you’re checking a single action or the entire project plan, the utility shows All resource utilizations by default. Alternatively, you can choose to see Only utilizations over 100%.

Over-utilized resources (i.e., those with a utilization that exceeds 100%) are shown in red.

Double-click a resource to view its total utilization for each specific date, as well as the action(s) that use the resource on each date. For example, according to the window shown next, Joe Reliability's highest utilization for a single day exceeds 100%. By double-clicking his name, you can see that he is assigned to two actions that overlap on 1/6/2016, and as a result his combined utilization for that day is 105%.
Project Planner Gantt View

The Project Planner also includes a Gantt chart that makes it easy to visualize the timelines in your project and examine how different planning resources are utilized over time.

To access this view, click Gantt at the bottom of the Project Planner.

- Use the Gantt Type drop-down list on the control panel to specify what to display:
  - **Project Plan** shows timelines for gates and actions.
  - **Personnel Utilization** and **Facility Utilization** show the utilizations for the person responsible, team and/or facilities. (See Project Planning Resources.)

- In the Gantt Display area, select the part of the plan you want to view in the Filter drop-down list. For example you could view a specific gate (and its dependents) or a specific user (and all their utilizations). If you want to change the widths of columns that contain dates, use the Fit Mode.

- In the Date Selections area:
  - Select to view the entire plan or focus only on a specific date range.
  - Specify whether each column represents a specific number of Days, or Other increments such as weeks, months, quarters, etc.

- In the Date Display area:
  - If each column represents a single day, select whether to display Non-Working Days. If displayed, those columns will have a gray background. (See Working Days/Holidays.)
  - Use Show Planned, Show Expected and Show Actual to specify which timeline bars will be displayed.
    - To specify the colors that will be used in both the project plan Gantt chart and the timeline plot, choose View > Settings > Set Colors. (See Set Colors for Project Planner.)
  - For the planned and actual timeline bars in the project plan chart, you can also choose whether to Show Percent Completed.
• If you are using one of the utilization charts and the date columns each represent more than a single day, use the **Calculate Utilization As** area to specify how to calculate the utilization. This can be:
  
  - The **Max** (highest) daily utilization among all days in the interval. For example, if the interval is 3 days and the utilizations were 15%, 0% and 10%, the max will be 15%.
  - The **Average** across only the days in the interval that have utilizations. For example, if the interval is 5 days but the resource was only utilized on 3 of those days, the average will be the total utilization/3 days.
  - The **Overall Average** across all working days in the interval. For example, if the interval is 5 working days, the overall average will be the total utilization/5 days even if the resource was not utilized every day.

**Project Planner Plot View**

The **Project Planner** includes a plot view that makes it easy to visualize the timelines in your project.

To access this view, click **Plot** at the bottom of the Project Planner.

- Use the **Filter Options** area to select whether to filter the data by **Gate** or by using a **Date** range. You can also choose to view data for **Top Level Gates** only.

- In the Display Options area:
  
  - **Show Planned, Show Expected** and **Show Actual** determine which timelines will be shown in the plot.
  - To specify the colors that will be used in both the project plan Gantt chart and the plot, choose **View > Settings > Set Colors.** (See **Set Colors for Project Planner**.)
  
  - **Display Actions** shows the dependent actions for each gate.
  - **Show Project Item** shows the “project” gate at the top of the hierarchy.
  - **Show First Gate on Top** determines whether the gate with the earliest start date will show at the top or bottom of the chart.
Auto Refresh refreshes the plot automatically whenever changes have been made. If this option is cleared, you can click the Redraw Plot icon (⟳) to refresh the display.

Keep Aspect Ratio maintains the proportional relationship between the width and height of the plot image.

**Set Colors**

To open the Set Colors window for the Project Planner, choose View > Settings > Set Colors.

- The Gate and Action Options apply to the Gantt chart (if viewing the plan), plan hierarchy and plot.

- The Date Display options apply only to the Gantt chart and plot.

- The Utilization Threshold Colors apply only when using the Gantt chart to view team or facility utilization.
Project Planner Dashboards

You can use the flexible Synthesis Dashboard utility for presenting data from any Project Planner in the database.

To access this feature, open the planner and choose Project Planner > Tools > Dashboard.

As with any other Synthesis dashboard, you can use the Dashboard Viewer to select any of the layouts that have been predefined for this type of data. In a secure database, only users with the "Manage dashboard layouts" permission can use the Dashboard Manager to create or edit layouts.

Data Source Drop-Down List

When you are creating a dashboard layout based on project plan data, the drop-down list at the top of the Data Source Panel gives the following options:

- **Actions** returns data only from actions in the current plan.
- **Gates** returns data only from gates in the current plan.
- **Gates/Actions** returns data from both actions and gates.
Facilities returns data from the facilities assigned to actions.

Personnel returns data from the person responsible and/or team assigned to actions.

Each data source allows you to choose relevant fields from the record properties, summary panel and/or project plan hierarchy.

Note that all of the data fields used within a particular dashboard item must come from the same source. For example, you can’t combine fields from the “Actions” data source and the “Gates” data source in the same chart. If you want to create a chart that includes both actions and gates, use the fields from the “Gates/Actions” data source instead.

Examples for Different Field Types

The icon for each field indicates the data type: text, number or date. There are many possible ways to use these fields in your own customized dashboard layouts. The following simple examples demonstrate basic applications for each data type.

Example Using Counts

This pie chart uses the Count value for a text field to show the actions in the current project plan broken down by status. The argument determines the slices shown in the pie.

Tip: If you want to see both the quantity and the percentage, choose Design > Data Labels > Argument, Value And Percent.
Example Using Numbers
This bar chart uses the **Sum** values for two number fields to show the top 5 most costly actions in the current project plan, with comparison to the planned cost. The arguments determine how the bars are labeled, grouped and sorted.

Example Using Dates
This grid uses the **Exact Date** for two date fields to show a list of all actions in the current plan that are due in the current month. (To set the criteria that filters the records shown in the grid, right-click inside the chart and choose **Edit Filter**.)
Project Planner Ribbon

Project Planner Tab
The Project Planner tab in the Project Planner ribbon contains the following commands.

Project Planner

⚠️ **Refresh** updates the Project Planner hierarchy, if necessary. For example, if multiple users are accessing the same plan simultaneously, this will update the plan to reflect any changes made by other users.

🛠️ **Create Project Plan** opens the Create Project Plan window so you can start again from a blank plan, or import an existing plan from another project.

🗑️ **Delete Entire Plan** deletes every gate and removes every action from the plan.
Item Properties allows you to view or edit the Synthesis Identifiers defined for the current plan. These identifiers can be used in the Synthesis Explorer to explore all of the different types of analyses (including project plans) in the current database.

Clipboard

Paste pastes the contents of the Clipboard into the level below the selected gate (or on the same level of the selected action). If you want to paste gates only (without sub-gates and actions), use the Paste Without Actions command.

Cut cuts the selected gate/action and any dependents to the Clipboard. You can paste this information into another Project Planner within the same database.

Copy copies the selected gate/action and any dependents to the Clipboard. To copy everything, use the Copy Entire Plan command. You can paste this information into another Project Planner within the same database.

Delete deletes the selected gate/action and any dependents.

Gate

Add Gate

- Add Same Level Gate adds a gate on the same level as the selected gate.
- Add Next Level Gate adds a gate one level below the selected gate.
- Add Gate adds a top-level gate to the end of the plan.
- Insert Gate inserts a gate at the selected location.

Use Precedence, when selected, automatically sets a new gate's precedent to the prior gate, which allows you to take advantage of expected timelines and ensure that there are no gaps between gates. If you clear this option, the default precedent will be "None."

Edit Gate opens the Gate Properties window.

Promote and Demote moves the selected gate to the next higher or lower level in the plan. An item can be demoted only if there is another item on the same level and above the selected item that it can be demoted under.
Action

Add Action creates a new action resource.

- **Add Action** allows you to select existing action(s) from the project that a) are not already used in the current plan and b) have dates that fit within the current gate. Specifically, the action’s start date can’t be before or more than a year after the gate’s start date. (See **Select Resource window**.)

- **Reuse FMEA Actions** allows you to select one or more Xfmea/RCM++/RBI system hierarchy items from the current project that have FMEAs. You can then select to use existing action(s) from those particular FMEAs in the project plan.

Edit Action opens action properties window. (See **Actions in the Project Planner**.)

Tools

- **Remove Gaps in Dates** automatically assigns precedents to every applicable gate. This ensures that there will be no gaps in the planned or expected timelines, and it allows the expected dates for an activity to automatically shift in response to delays in prior activities. (See **Project Planner Timelines**.) You can choose to remove gaps in the Entire Plan or just for the gates that fall under the selected Branch.

- **Check Utilization** opens the Check Utilization window so you can examine the utilizations for individual users and facilities across multiple actions (e.g., is a particular user assigned to too many actions at the same time, or is a particular test facility already booked for a particular timeframe).

- **Expand All** and **Collapse All** expands or collapses the gates in the project plan hierarchy.

Dashboard

- **Dashboard Viewer** opens the Dashboard Viewer so you can view dashboards based on predefined layouts.

- **Dashboard Manager** opens the Dashboard Layout Manager so you can create, edit and delete the predefined layouts that will be available for any Synthesis user to view for any project plan in the database.
Excel Import/Export

- **Export View to Excel** exports the entire hierarchy and all displayed columns to an Excel sheet in a format that's suitable for presentation.

- **Import Hierarchy** and **Export Hierarchy** use an Excel format that's suitable for recreating the plan hierarchy in another project plan using information about precedents, outline level, etc.

**Copy Current View** copies the currently visible contents of the plan hierarchy or Gantt chart to the Clipboard as a graphic that can be pasted to other applications.

View Tab
The View tab in the Project Planner ribbon contains the following commands.

**View**

- **Color Code Deltas** applies highlight colors to any “Delta Values” columns for dates or durations that are displayed in the project plan hierarchy (e.g., the difference between the planned duration and the actual duration, or between the expected completion date and the actual completion date). Highlights are applied on a gradient from blue (ahead of schedule) to red (significant delay).

- **Fit All Columns** automatically resizes all columns to fit their own data.

**Settings**

- **Customize Columns** allows you to hide or display specific columns in the plan hierarchy.

- **Save View** and **Apply View** create or apply a view that stores your preferences for which columns to display in the plan hierarchy and which colors to use for gates, actions, timelines and utilizations. Each view is saved per computer/username.

- **Set Colors** allows you to select the colors to use for gates, actions, timelines and utilizations.

**Zoom**

- **Normal Zoom** sets the degree of magnification to 100%

- **Zoom In** and **Zoom Out** increase or decrease the font size by 25% increments.
Chapter 27: Synthesis Project Planner

Custom Zoom allows you to specify the zoom percentage.
Chapter 28: Synthesis Plot Utilities

Synthesis applications offer a variety of plotting utilities for visual presentation of your analysis results. The following topics provide general information about built-in utilities, where the types of plots/charts available are predefined based on the analysis method and type of data you are working with. For more information about specific plot types, please consult the documentation for the relevant analysis.

**Tip:** In addition to the built-in plotting utilities described here, you can also create your own custom plots/charts in the Synthesis Workbooks and Synthesis Dashboards.

### Basic Plot Features

This topic describes some basic features and capabilities that are available in most built-in plot utilities in Synthesis desktop applications (i.e., utilities where the types of plots available are predefined based on the analysis method and type of data you are working with). For information about creating your own custom charts in Synthesis Workbooks or Synthesis Dashboards, see Custom Charts or Dashboard Layout Designer.

### Redraw Plots

A plot needs to be refreshed whenever its data source has been recalculated or when its inputs or settings have been modified. This ensures that the plot reflects the most current results. In most plot sheets, the control panel displays a status light that indicates whether the plot needs to be refreshed. A green light indicates that the data and the plot are in sync, while a red light indicates that the plot is out of sync with the latest analysis.

You can manually update a plot to reflect any changes by clicking the Redraw Plot icon in the plot’s control panel.

Alternatively, a plot can be refreshed automatically whenever changes have been made by selecting the Auto Refresh check box on the plot’s control panel.
Identify a Plot’s Source Analysis

For most plots, the control panel displays a blue link that displays the plot’s source analysis, as shown in the following example for a Weibull++ plot. You can click the link to open the folio and view the data set.

In some specialty plots (side-by-side plot, life comparison tool, etc.), you can select the source analysis for the plot by clicking the icon on the plot’s control panel or ribbon.

If the plot contains results from more than one analysis (e.g., overlay plots), the control panel includes a button that allows you to add or remove analyses from the plot, as shown in the example below for Weibull++ data sheets. In addition, you can click and drag the data sheets to the desired order.

Show or Hide Plot Items

When applicable, a plot may provide options for showing or hiding certain plot items such as data points, lines, probability scales, etc. The available options depend on the plot type and analysis. To view the options for the plot you are working with, choose Plot > Actions > Show/Hide Plot Items or right-click the plot and choose Show/Hide Items on the shortcut menu.

Select the check box for each item you want to appear in the plot, or clear the item’s check box to hide the item from view.

Scaling

When applicable, the plot control panel may display X and Y scaling boxes that show the minimum and maximum values for the x- and y-axes. You can clear the check boxes and click inside the fields to manually edit the values, or select the check boxes to have the application choose the appropriate values for the range, based on the data.
The zoom function is available for plots that allow both X and Y scales to be adjusted. To zoom in or out of a plot, click inside the plot, point the mouse pointer over the area of interest, and then rotate the mouse wheel. Press ESC to return to the original scale.

For non-3D plots, you can also select a specific area to zoom in by holding the CTRL + SHIFT keys while clicking and dragging the mouse over the desired area. You can customize the color and line style of the zoom rectangle via the Zoom page of the Plot Setup.

**Aspect Ratio**

Plots are automatically resized whenever you resize the plot sheets. To maintain the proportional relationship between the width and height of the plot image, select the Keep Aspect Ratio check box on the plot’s control panel (as shown in the first example below). Clear the check box if you wish to stretch the dimensions of the plot graphic to fill the plot sheet (as shown in the second example below).
Show Coordinates

To show the coordinates for a location on a plot, press **SHIFT** and click the plot (no need to hold down the mouse button). To stop showing the coordinates and return the pointer to its normal mode, click the plot again.

To track the coordinates on a plot line, click the line. A crosshair shows the current location on the line. The crosshair will stay on the line and track the coordinates as you move the pointer.

When applicable, you can add a label that displays the coordinates of a location by pressing **CTRL + ALT** and then clicking the location you want labeled.
Add Custom Labels
When applicable, you can add a custom label to a plot by pressing \texttt{CTRL} and then clicking the plot. A label named "Default" will appear in the plot. Select the label to edit the text directly in the plot or double-click it to open the Edit Label window, which gives you the option to select a font style or format.

You can then move the label by clicking it and dragging its yellow handle to the desired location on the plot. (For more extensive annotations, see ReliaSoft Draw.)

Move Plot Items
If your plot has lines or points that are obscuring one or the other, you can move an item by pressing \texttt{ALT} and clicking the item. The Move Plot Item window will appear, giving you the option to move the selected item either to the front or back of the obscuring graphic.

Export or Copy Plot Graphics
You can save a plot graphic as a *.wmf, *.png, *.gif, or *.jpg file for use in other applications by clicking the Export Plot Graphic icon on the plot's control panel, or by choosing [Plot/3D Plot] > Actions > Export Plot Graphic if applicable.
In addition, you can save a plot graphic to the Clipboard by clicking the Copy Plot Graphic icon on the plot's control panel or by choosing [Plot/3D Plot] > Actions > Copy Plot Graphic if applicable.

When saving a 3D plot graphic to the Clipboard, the image will be in *.bmp format. For all other types of plots there are three choices: If you will be pasting copied plots into any one of the spreadsheets built in to Synthesis desktop applications (e.g., Synthesis Workbooks or General Spreadsheets), choose Metafile Optimized for Synthesis Spreadsheet. If you will be pasting them into external applications, choose Bitmap or Metafile Optimized for External Use.

Setting Confidence Bounds

If your analysis includes calculations for confidence bounds, you can display the bounds in the associated plot by clicking the Confidence Bounds link on the plot control panel or by choosing Plot > Confidence Bounds > Confidence Bounds.

Depending on the type of data you are working with, you may be presented with different options for setting up the confidence bounds on the plot. (The ReliaWiki resource portal provides information on the background theory of confidence bounds at: http://www.reliawiki.org/index.php/Confidence Bounds.)

In the Confidence Bounds Setup window, you will need to:

1. Select which lines to show on the plot (e.g., two-sided, bottom one-sided, etc.)

2. Select which type of bounds to show on the plot. This may be the bounds on the time estimate (Type I), bounds on the reliability/unreliability estimate (Type II: Reliability); or when applicable, bounds on functions such as number of failures, growth potential, etc. (Type II: Function).

3. Enter the percent confidence level.

To change the level of detail at which the bounds are plotted, adjust the Resolution slider. You can click and drag the slider or, for fine adjustments, click the slider and then use the arrow keys. The number of points plotted to create the lines is displayed next to the field name. Note that higher resolutions will take longer to plot.

To hide the confidence bounds, choose Plot > Confidence Bounds > Hide Confidence Bounds.
Setting Target Markers

When applicable, the plot control panel may display the **Target Reliability** link or the **Target MTBF/FI** link. Both give you the option to display markers for target values on the plot.

You can select to show a specified target value (displayed as a horizontal line), target time value (displayed as a vertical line), and/or insert a marker at the point where the two target values intersect. Below is an example for a plot that shows the target reliability.

Click the **Add** or **Remove** icon to manage the list of target values to be displayed. You can add up to 5 sets of target values/markers to a plot.
Chapter 28: Synthesis Plot Utilities

The Plot Setup utility provides advanced settings for customizing the look of a plot to meet your needs and preferences. It allows you to: a) make changes and apply them to the current plot; b) save the changes and use them as default settings for all new plots; c) restore previously saved default values; or c) reset all settings to the shipped defaults.

Tip: You can quickly set some basic default settings for all new plots created in the current Synthesis desktop application via the Plots page of the Application Setup (File > Application Setup). The Application Setup also allows you to set some default analysis settings that may affect the appearance of plots (varies depending on the Synthesis desktop application).

To open the Plot Setup, click the Plot Setup icon on the plot’s control panel.
Alternatively, you can double-click the item on the plot you wish to edit (e.g., points, lines, etc.) and the Plot Setup will open and display automatically the options associated with that item.

To apply your changes to the current plot, click **OK**. To save your changes as the new defaults, or restore previously saved defaults, or reset to shipped defaults, click the **Defaults** button. (See **Plot Defaults Window** for more information.)

**Plot Elements**

The Plot Setup is divided into pages that contain related settings for particular plot elements. The available pages/elements will depend on the type of plot you are working with.

As an example, the following picture identifies some of the basic plot elements that can be configured via the Plot Setup.

![Plot Setup: Plot Titles Page](image)

**Plot Setup: Plot Titles Page**

The Plot Titles page allows you to define the main, header and footer titles used in the plot and to change the text font and color.

Select or clear the **Show** check box to determine whether the title will be shown on the plot. Click the **Set Font** button next to the corresponding input box to open the Font window, which allows you to set the font type, style, size, color and text orientation.
Chapter 28: Synthesis Plot Utilities

Each asterisk (*) represents the default title text. For the main title, this is defined on the Titles Text page of the Plot Defaults window. If you type new text in an input box, either alone or in addition to the asterisk, the text you type will be displayed on the plot. For example, if you add (Helicopter) to the Main Title field, the default main title will be displayed, followed by "(Helicopter)." The changes you make will be applied regardless of plot type, so the main title of a Failure Rate vs Time plot would then be "Failure Rate vs Time (Helicopter)" and the main title of a System Failures plot would be "System Failures (Helicopter)." (This assumes that you have not changed the default main titles from the ones shipped with the application.)

You can use the ENTER key to add additional lines to the header title and the footer title.

To add an image file to the header title or footer title, click Set Image then browse for the file you want to include. Click Open. (You can select an image that uses one of the following formats: *.bmp, *.gif, *.jpg, *.jpeg, or *.ico.) The selected image appears next to the Set Image button. The image will also appear at the left side of the header or footer text. To remove the image, click Clear Image.

Plot Setup: Axis Titles/Labels Page
The Axis Titles/Labels page allows you to define the information used with the x-axis and y-axis, including the titles, axis labels and the numbers displayed in the axis labels. This page is not available when you are working with a pie chart.

The options on this page will vary depending on the plot style you are working with.

- Axis Titles
  - Select or clear the Show check box to determine whether the title will be shown on the plot. Click the Set Font button next to the corresponding input box to open the Font window, which allows you to set the font type, style, size, color and orientation of the text.

Each asterisk (*) represents the default title text. If you type new text in an input box, either alone or in addition to the asterisk, the text you type will be displayed on the plot. For example, if you add (Hours) to the Y-Axis Title field, the default y-Axis title will be displayed, followed by "(Hours)." The changes you make will be applied regardless of plot type, so the y-axis title of a Static Reliability Importance plot would then be "Static Reliability Importance (Hours)" and the y-axis title of a Throughput vs. Time plot would be "Throughput(t) (Hours)." (This assumes that you have not changed the default axis titles from the ones shipped with the application.)
• **Axis Labels**
  
  - **Axis Labels** options, when selected, displays the numerical labels for the x-axis and/or the y-axis in the plot.
  
  - If available for the plot type, click the **Custom Labels** button next to the corresponding option to open the Custom Axis Labels window, which allows you to add user-defined numerical labels to the x-axis or y-axis of the plot. Note that values outside the plot's display range are accepted but will not be shown.

  Click the **Set Font** button next to the corresponding option to open the Font window, which allows you to set the font type, style, size, color and orientation of the text.

• **Numbers in Axis Labels**

  Use the options in this area to configure the mathematical precision (number of decimal places) and scientific tolerance of the values shown on the axes.

  The scientific tolerance sets the point at which the numbers will be converted to normalized scientific notation. For example, setting the scientific tolerance to 3 means that all numbers with a value of 1,000 or more will be converted to normalized scientific notation (e.g., 1.0E+3).

  **Note:** When you are working with a bar chart, the Numbers in Axis Labels area will contain settings for only the axis representing the dependent variable. This is affected by the orientation of your bar chart; if you are using vertical bars, this area will contain settings for the y-axis, and if you are using horizontal bars, it will contain settings for the x-axis. It is important to be aware that the settings for one axis will not transfer to the other axis when you change the bar orientation. You will need to return to this page and reenter the settings.

**Plot Setup: Plot Labels Page**

The Plot Labels page allows you to customize the labels for items (e.g., bars, slices, points) shown in the plot as well as for custom labels used in the plot.

The options on this page will vary depending on the plot style you are working with. All available options are presented below.

• **Bar Labels** (available only for bar charts)

  - To display the y-axis value of each bar with the bar, select the **Show Bar Labels** check box. (You can set the bar style using the **Bar Orientation** field on the **Bars page** of the Plot Setup.)
Chapter 28: Synthesis Plot Utilities

- **Show Bar Labels Even if Zero** if selected, bars with a y-axis value of 0 will be shown with a label of "0." The number of decimal places in the label will conform to the y-axis math precision value specified on the Axis Titles/Labels page.

- **Point Labels** (available only for line plots)
  
  - To display the coordinates for each point at the lower right of the point, select the Show Point Coordinates check box. If this option is not selected, you can still display the coordinates for each point in a pop-up box by pointing to the point.
  
  - To display the point label in the same color as the border of the point itself, select the Use Point Border Color check box.
  
  - If there are overlapping points, select the Show Point Multiplier check box to display the number of points to the right of the point.

- **Slice Labels** (available only for pie charts)
  
  - To label the slices of the pie chart according to the components they represent, select the Show Slice Labels check box.
  
  - To label the slices of the pie chart with the percentage of the whole that they represent, select the Show Slice Size check box.

- **Custom Plot Labels** allows you to control the appearance of custom plot labels. You can add custom labels to your plot by pressing CTRL and clicking the plot.
  
  - **Delete Labels** deletes all custom labels on the plot.
  
  - **Reset Labels** immediately resets all custom labels on the plot to use the settings specified via the Set Font button. This allows you to apply the settings to existing custom labels rather than just new labels created after changing the settings.

- **Bar Label Position** (available only for bar charts) allows you to specify whether you want the bar labels located within the bars or outside of the bars.

For all labels, you can click the Set Font button in the section to open the Font window, which allows you to set the font type, style, size and color for labels of that type.

**Plot Setup: Legend Page**

The Legend page allows you to customize the display of the legend on the current plot.
The options on this page will vary depending on the plot style you are working with. All available options are presented below.

- To display the legend on the plot, select the **Show Legend** check box.
  - To include on the legend a color definition for each point/line/bar/slice shown in the plot, select the **Show Plot Items** check box.
  - To include lines above and below the legend and the user information, select the **Show Legend Border** check box. Use the options to the right to modify the appearance of the border. To change the color of the border, click the **Color** box to the left of the **Thickness** box. Adjust the thickness of the border by entering a positive integer in the input box. Change the style of the line (e.g., solid, dashed, etc.) by clicking the **Line Style** box to the right of the **Color** box.
  - To display the text of the legend in the same color as the lines, points, bars and/or slices on the plot, select the **Use Item Color** check box. If not selected, the text will be red.
  - **Show Analysis Information** if selected, the legend will display information about the analysis shown on the plot, including the data source and/or the settings used in the calculation, if applicable.
  - To display the plot description (including the plot type) on the plot, select the **Show Plot Description** check box.
  - To show the user display name, company and the date and time the plot was generated on the plot, select the **Show User Information** check box. (You set the display name and company using the **User Login and Contact Information Window**.)

- The legend area allows you to specify the amount of space used for the legend.
  - **Fixed Legend Width** if selected, the legend will remain the same size regardless of the information it contains. You can set the percentage of the canvas width that the legend will occupy.
  - **Maximum Legend Width** if selected, the legend will automatically recalculate its width based on the information it contains. You can set the maximum percentage of the canvas area that the legend will occupy.
Chapter 28: Synthesis Plot Utilities

Click the Set Font button next to the corresponding option to open the Font window, which allows you to set the font type, style, size and color of the text.

- For bar and pie charts in BlockSim and RENO only, Color Spectrum allows you to set the color limits for the plot.
  - You can set both lower and upper color limits by dragging the markers on the scale between 0% and 100%.
  - Show all values (0-100%) in legend if selected, the legend will show the full range of values; if not selected, the legend will show only the values between the upper and lower limits that you have specified.

The preview shows how the specified settings will appear in the legend.

Plot Setup: Canvas Page

The Canvas page allows you to customize the color, style and thickness of the plot borders and title lines, along with the appearance of the rest of the plot sheet.

- Plot Canvas and Area
  - Canvas Back Color allows you to choose the color for the area outside the plot (i.e., the area containing the titles, labels, legend, etc.).
  - Canvas Border allows you to determine if the border around the plot field will be displayed and, if so, to set the color.
  - Plot Area Back Color allows you to choose the color for the plot background.
  - Plot Area Border Lines allows you to hide or show each of the specified lines, as well as to choose a color, a thickness and a style for each. The borders referred to in this area are the borders of the plot area itself (i.e., the bottom border is the x-axis, etc.).
    - To show or hide a line, select or clear the associated check box.
    - To change the color of any of the lines, click the Color field. The drop-down list that appears allows you to choose from custom colors, web-safe colors or the colors used in the current Windows system settings. You can add colors to the Custom page by right-clicking one of the color boxes in the bottom two rows.
    - You can adjust the thickness of a line by entering a positive integer in the input box. A value of 1 will draw the thinnest possible line and other values such as 2, 3, etc. will draw thicker lines. Note that the size of the thinnest possible line is dependent upon your screen resolution.
• In addition, you can change the style of each line by clicking the Line Style box to the right of the Thickness box. A list providing line style options (e.g., solid, dashed, etc.) will appear. Choose the line style you want and it will appear in the Line Style box.

• To highlight each object (i.e., point, line, bar or slice) on the plot as you point to it, select the Highlight Selected Plot Item check box. When an object is active, you can click it to open the Plot Setup window and edit the properties specific to that object. The remaining options in this area are available only if this option is selected.

  • Fill Color allows you to specify a foreground color to be used on the highlighted active object.

  • Back Color allows you to specify a background color to be used on the highlighted active object. This color is not used if the selected fill style does not use a background color (i.e., solid or transparent fill style).

  • Fill Style allows you to select a style of hatching to be used on the highlighted active object.

Plot Setup: Grid Page
The Grid page allows you to customize the color, style and thickness of the grid lines and to set the number of axis divisions used. This page is not available when you are working with a pie chart.

The options on this page will vary depending on the plot style you are working with. All available options are presented below.

  • Axis Division Lines allows you to hide or show each of the axis division lines, as well as to choose a color, a thickness and a style for each.

    • To show or hide a line, select or clear the associated check box.

    • To change the color of any of the grid lines, click the Color box. The drop-down that appears allows you to choose from custom colors, web-safe colors or the colors used in the current Windows system settings. You can add colors to the Custom page by right-clicking one of the color boxes in the bottom two rows.

    • You can adjust the thickness of a grid line by entering a positive integer in the input box. A value of 1 will draw the thinnest possible line and other values such as 2, 3, etc. will draw thicker lines. Note that the size of the thinnest possible line is dependent upon your screen resolution.
In addition, you can change the style of each line by clicking the Line Style box to the right of the thickness box. A list providing line style options (e.g., solid, dashed, etc.) will appear. Choose the line style you want and it will appear in the Line Style box.

- **Number of Axis Divisions** allows you to set the number of major and minor divisions for each axis.

*Note:* When you are working with a bar chart, the Grid page will contain settings for only the axis representing the dependent variable. This is affected by the orientation of your bar chart; if you are using vertical bars, this area will contain settings for the y-axis, and if you are using horizontal bars, it will contain settings for the x-axis. It is important to be aware that the settings for one axis will not transfer to the other axis when you change the bar orientation. You will need to return to this page and reenter the settings.

---

**Plot Setup: Bars Page**

The Bars page allows you to customize the appearance of the bars in the plot. This page is available only when you are working with a bar chart.

- **Bar Border Lines** allows you to hide or show the border line for the bars, as well as to select a color, a thickness and a style for the border.
- **Bar Orientation** allows you to select how you want the plot laid out. You can choose to use vertical bars or horizontal bars.

---

**Plot Setup: Slices Page**

The Slices page allows you to customize the appearance of the slices in the plot. This page is available only when you are working with a pie chart.

- **Pie Settings**
  - **Rank** if selected, you can specify the ranking of the slices that you want to view. For example, entering 5 will cause only the five largest slices to be shown in the plot.
  - **Threshold** if selected, you can specify a minimum size (in percentage of the whole) for the slices that you want to view. For example, entering 0.1 will cause only slices accounting for ten percent or more of the whole to be shown in the plot.
• **Show Remaining Slices as Other** if selected, all remaining slices that do not meet the rank or threshold criterion specified will be shown in the plot as "other." This option is available only if you have specified a rank, a threshold or both.

• **Other Slice Color** allows you to choose the color used to represent "other" slices. This option is available only if you have selected the **Show Remaining Slices as Other** option.

• **Slice Border Lines** allows you to hide or show the border line for the slices, as well as to select a color, a thickness and a style for the border.

• **Chart Type** allows you to select how you want the plot laid out. You can choose to use an area chart (blocks), cake chart (layers) or pie chart (wedges).

• **Numbers in Slice Labels** allows you to set the number of decimal places to be displayed in slice labels.

### Plot Setup: Plot Items Page

The Plot Items page allows you to specify details of the appearance of the points, lines, bars and/or slices on the plot.

The options available on this page will vary depending on the plot style that you are currently working with.

The following options are available for all plot styles:

• **Choose an Item to Configure** allows you to choose which plot element the settings on this page apply to.

• **Show** allows you to select whether or not the plot element you currently chose to configure will be shown on the plot. Depending on the plot style that you are currently working with, you may select to show the bars, slice, line and/or points. This option is not available for all plots.

For bar charts and pie charts, the following option applies.

• **Area Fill Color and Style** allows you to specify the appearance of the bar or slice representing the selected item. To change the color of the bar or slice, click the **Color** box. You can select a fill style from the drop-down list.

For line plots, the following options apply:

• **Line Settings** allows you to specify the appearance of the line representing the selected item. To change the color of the line, click the **Color** box. You can adjust the thickness of a grid line by entering a positive integer in the input box. Adjust the thickness of the line...
by entering a positive integer in the input box. Change the style of each line such as solid, dashed, etc., by clicking the **Line Style** box.

- **Point Settings**
  - **Color, Shape, Size and Fill** allows you to specify the appearance of the point body. To change the color of the point, click the **Color** box. You can select a point shape from the drop-down list, select the size of the point (with 1 being the smallest point) and select a fill style from the drop-down list.
  
  - **Border Color, Thickness and Style** allows you to modify the appearance of the border of the points. To change the color of the border, click the **Color** box. Adjust the thickness of the border by entering a positive integer in the input box. Change the style of each line such as solid, dashed, etc., by clicking the **Line Style** box.

  Certain point shapes are drawn using only the border color. These include minus, pike, plus and x-cross.

---

**Plot Setup: Offsets Page**

The Offsets page allows you to specify the distance of various components from the edge of the plot area.

**Automatically calculate positions from edges of plot sheet** if selected, automatically calculates the offsets for maximum plot display and readability. If not selected, you can manually specify the offsets of the plot's left, right, top and bottom edges; the offset of the legend from the right edge of the plot area; and the offset of the main, x-axis, y-axis, header and footer titles. The offset values are set as a percentage of the canvas area.

For your reference, the following picture shows which plot elements are affected by each of the offset settings. (Note that the plot is generated from BlockSim, but the settings are the same for all Synthesis desktop applications.)
Plot Setup: Zoom Page

The Zoom page allows you to customize the options used when zooming in on a plot by using the mouse wheel. Zooming works only for plots with scales. For more information, see Basic Plot Features.

Allow Zoom if selected, allows the plot zoom feature to be used.

- **Factor** use this option to set the amount of the magnification each time you use the mouse wheel on the plot. The lower the number, the greater the increase in the magnification.

- Use the **Border Color, Thickness and Style** option to set the appearance of the zoom box. To change the color of the border, click the **Color** box to the left of the **Thickness** box. Adjust the thickness of the border by entering a positive integer in the input box. Change the style of the line (e.g., solid, dashed, etc.) by clicking the **Line Style** box to the right of the **Color** box.

- **Fill Style** allows you to select a style of hatching to be used on the zoom box.
- **Fill Color** allows you to specify a foreground color to be used on the zoom box. This color is not used if the selected fill style does not use a background color (i.e., solid or transparent fill style).

- **Background color** allows you to specify a background color to be used on the zoom box. This color is not used if the selected fill style does not use a background color (i.e., solid or transparent fill style).

### Plot Defaults Window

Each time you open the Plot Setup window, the changes that you make will apply only to the current plot unless you specify otherwise. To specify settings to be used as defaults for all subsequent plots or to re-apply default settings to the current plot, click the **Defaults** button to open the Plot Defaults window.

The Plot Defaults window gives you the flexibility to set the default settings for the three main areas of a plot: the plot titles, the plot item settings and the general display areas. You can choose to separately save, load or restore the default settings of each main area or you can set the default settings for all areas at once.

The Plot Defaults window consists of nine pages:

- **All Defaults page.** This page controls the settings for all the other plot setup pages. When you click a button on this page, the effects apply to all pages. This allows you to quickly make changes without having to individually change each of the other pages.

- **Titles Text page.** This page allows you to customize default plot titles for each plot type without having to view a plot of that type. For example, you can display a Failure Rate vs. Time plot while changing the titles for a System Failures plot.

- **Plot Items Display page.** This page allows you to customize the details of the default appearance of the lines, points, bars and/or slices of every plot type without having to individually change each plot.

- **General page.** This page controls the settings for the five section pages below it. When you click a button on this page, the effects apply to the Titles Display, Labels, Legend, Canvas and Grid and Offsets pages.

- The Titles Display, Labels, Legend, Canvas and Grid and Offsets pages control the settings of their individual sections. When you click a button on one of these pages, the effects apply only to that specific section.
Chapter 28: Synthesis Plot Utilities

Three Defaults buttons appear on every page of the Plot Defaults window. The scope of their effects differs slightly depending on the page you are working with.

- **Save Defaults** saves settings for use as the default settings for all subsequent plots. This will overwrite the previous default settings.

- **Load Defaults** enters the saved default values for the settings. You can then click OK in the Plot Setup window to apply the default settings to the current plot. This is an easy way to undo changes you have made in the Plot Setup window and re-apply default settings.

- **Restore Defaults** clears the saved default settings and restores the default values that are shipped with the application.

The scope of the Defaults buttons' effects changes as follows:

- For the Titles and Plot Item Display pages, these buttons save/load/restore the settings specified on the current page.

- For the Titles Display, Labels, Legend, Canvas and Grid and Offsets pages, these buttons save/load/restore all current settings on the corresponding page(s) of the Plot Setup window (e.g., clicking **Save Defaults** on the Canvas and grid page of the Plot Defaults window will save the settings from the Canvas, Grid, Bars and Slices pages).

  **Note:** The settings affected by the Defaults buttons on the Titles Display, Labels, Legend, Canvas and Grid and Offsets pages include all settings relevant to the section, regardless of whether they are currently available or not. For example, if you have previously specified settings for a pie chart and are now specifying settings for a bar chart, the settings that you created for the pie chart will be saved as defaults when you click **Save Defaults** and will be applied to subsequent pie charts.

- For the All Defaults and General pages, clicking these buttons is equivalent to clicking them on all of the subordinate pages.

**Plot Defaults Window: Titles Text Page**

The Titles Text page of the Plot Defaults window allows you to customize default plot titles for each plot type.

- **Titles** allows you to select the plot type that you are changing the default titles for.

- **Main** allows you to type the default main title for the plot.

- **X-Axis** allows you to type the default title for the x-axis for the plot.

- **Y-Axis** allows you to type the default title for the y-axis for the plot.
Chapter 28: Synthesis Plot Utilities

**Plot Defaults Window: Plot Items Display Page**

**Plot Item Type** allows you to select the style of plot that you want to specify default settings for. The settings you specify are retained in the background when you choose a new item in this list, so you can specify settings for each type and save all of them, if desired.

The options on this page are identical to those on the Plot Items page of the Plot Setup window for the corresponding plot style.

**ReliaSoft Draw**

ReliaSoft Draw (RS Draw) is a metafile graphics editor that allows you to annotate and customize your plots. With RS Draw, you can insert text, draw an object, mark the coordinates of a particular point or paste another picture into your plot. You can also re-arrange the objects in your plot by selecting and moving them to the positions you desire. In addition, you can save the annotated plot in one of the following formats: *.rdc, *.jpg, *.gif, *.png or *.wmf.

RS Draw is available by clicking the icon on the plot control panel.

See [ReliaSoft Draw Help](http://xfmea.reliasoft.com) for information on the features available in ReliaSoft Draw. If you do not currently have Internet access, this link will not work, but you can browse to the local copy of the help file by opening the Help\RSDraw\rsdraw.htm file in your Synthesis application directory.

**Overlay Plots**

Available in Weibull++, ALTA, BlockSim and RGA, overlay plots give you the ability to display results from multiple analyses in a single plot. This allows you to easily compare different data sets, analysis methods or distributions. For example, you may wish to show the reliability plots of two product designs in the same plot or compare a simulation-based data set with actual data obtained from fielded products.

**Creating an Overlay Plot**

Before using an overlay plot, you must first analyze the data sets (or simulate the diagrams) you wish to include in the plot. You can then add an overlay plot to the project by choosing **Insert > Reports and Plots > Overlay Plot**.
In the window that appears, select the data sheets/diagrams you want to include in the plot (up to a maximum of 20) and click OK to create the plot sheet. The plot sheet will be saved automatically under the Multiplots heading in the current project explorer.

**Tip:** In Weibull++, ALTA and RGA, you can add additional plot sheets to a folio by choosing [Life Data/Life-Stress Data/Growth Data] > Folio Sheets > Insert Additional Plot. The additional sheets can function as overlay plots to display results from multiple data sheets in the current folio on a single plot.

### Adding or Removing Analyses
To add or remove analyses from an overlay plot, click the button on the control panel, as shown in the example below for data sheets.

If you later delete an analysis that is referenced by the plot, the plot will remain available and will continue to show the results of the analysis until you redraw the plot (by clicking the Redraw Plot icon on the control panel).

Note that importing or exporting an overlay plot will automatically import/export the associated source analyses. (See Importing/Exporting Project Items or Resources.)

### Available Plot Types for Overlay Plots
The available plots depend on the analysis or type of data you are working with.

**For Weibull++/ALTA**

Probability plots, contour plots and ALTA stress plots are available only if the data sets have been calculated with the same distribution. This is because the scales or axes in those types of plots vary for different types of distributions.

In DOE design folios, plots that are intended to be viewed as singular plots will not be available for inclusion in overlay plots. These include the comparison chart, Pareto chart, interaction matrix, term effect plot, cube plot, residual histogram, residual autocorrelation plot, and Box-Cox transformation plot. In addition, only plots that are common to the type(s) of design you have selected will be available in the overlay plot. If a plot type is unavailable for any of the included design types, it will be unavailable in the overlay plot.
For BlockSim

You can compare data from analytical and simulation diagrams in the same plot, but keep in mind that analytical diagrams always show the reliability over time (does not account for repairs) while simulation diagrams always show the point reliability over time (may include repairs).

For RGA

Only plots that are common to the analyses you have selected will be available in the overlay plot. If a plot type is unavailable for any of the included analyses, it will be unavailable in the overlay plot. It is possible for the selected analyses to not have any common plot types.

Side-By-Side Plots

Available in Weibull++, ALTA and RGA, side-by-side plots give you the ability to display different plots for a single data set all in a single window for easy comparison.

To add a side-by-side plot to a project, choose Insert > Reports and Plots > Side-by-Side Plot.

In the window that appears, select the analysis/data sheet you want to plot and click OK to create the plot sheet.

To view a single plot in greater detail, double-click the plot. You can double-click the plot again to return to the side-by-side view.

Choosing Plots to Display

The control panel provides options for selecting the type of plots to display. For most analyses, the Vary area will be available, which contains two options:

- The vary Plot Types option allows you to create different plots for the same data set. For example, you might wish to display both the Reliability vs. Time plot and the Failure Rate vs. Time plot of the data set.

- The vary Distributions or Models option allows you to compare how different distributions or models fit a particular data set. For example, you might wish to display a reliability plot for different life distributions, as shown next.
3D Plots

Available in Weibull++, ALTA and for two-way sensitivity analysis in RENO, 3D plots give you the ability to graph functions with three variables, such as the reliability at a given time and stress level. In addition, Weibull++ and ALTA offer the option to create 3D overlay plots, which are similar to regular overlay plots but displayed in 3D space.

Creating 3D Plots

Before creating a plot, you must first analyze the data sets (or in RENO, you must first run the simulation for the two-way sensitivity analysis).

To add a 3D plot to the project, choose Insert > Reports and Plots > 3D Plot.

To add a 3D overlay plot to a project (Weibull++ and ALTA only), choose Insert > Reports and Plots > 3D Overlay Plot.

In both cases, the plots are automatically saved and stored in the Multiplots heading in the current project explorer.
Defining the X, Y and Z Axes

The control panel in the 3D plot folio contains basic settings for defining the X, Y and Z axes. (For advanced customization options, see 3D Plot Setup.)

The **Begin** and **End** fields, as shown next, display the minimum and maximum values for the axes. You can click inside these fields to manually edit the values, or select the **Autoscale** check box to have the application automatically choose the appropriate values for the range.

Whenever applicable, the **Parameter** fields will be displayed, as shown in the example above. Click these fields to change which parameter lies on which axis. The name of the parameter associated with the axis will be displayed next to that axis’s label.

Rotating 3D Plots

The XYZ indicator shown at the lower-left of a 3D plot represents the plot’s horizontal rotation (**azimuth**) and vertical rotation (**elevation**) in 3D space. Any changes to a plot’s rotation are reflected in the XYZ indicator, helping you to visualize the plot’s orientation on the screen.

There are several ways to rotate or manipulate a 3D plot, using the mouse, keyboard shortcuts or the view cube.
### Using a Mouse and Keyboard Shortcuts

<table>
<thead>
<tr>
<th>If you want to</th>
<th>Use a mouse</th>
<th>Use keyboard shortcuts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate the plot or change the viewing angle</td>
<td>Click anywhere in the plot area, and then press and hold the left mouse button while moving the pointer.</td>
<td>Press the Up, Down, Left or Right arrow keys.</td>
</tr>
<tr>
<td>Move the plot without changing its rotation</td>
<td>Click anywhere in the plot area, and then press and hold the right mouse button while moving the pointer.</td>
<td>Hold the SHIFT key while pressing the Up, Down, Left, or Right arrow keys.</td>
</tr>
<tr>
<td>Zoom in or out</td>
<td>Rotate the mouse wheel. Alternatively, you can choose 3D Plot &gt; Display &gt; Zoom In or Zoom out.</td>
<td>Press the W or S keys.</td>
</tr>
<tr>
<td>Automatically center the plot on canvas</td>
<td>Choose 3D Plot &gt; Display &gt; Center on Canvas.</td>
<td>N/A</td>
</tr>
</tbody>
</table>

### Using the View Cube

The View Cube helps you to easily orient a 3D plot using predefined viewpoints. The cube is located at the lower-right of the 3D plot.

The letters on the cube represent a particular viewpoint. For instance, clicking the "F" side of the cube orients the plot such that you are looking directly at the plot’s front side (e.g., Y and Z plane).

- Front
You can rotate the cube in the same way you would rotate any 3D plot (i.e., press and hold the left mouse button while moving the pointer anywhere on the screen; or press the Up, Down, Left or Right arrow keys on your keyboard).

### 3D Plot Setup

The 3D Plot Setup allows you to customize the look of 3D plots to meet your needs. It gives you full control over the settings used for individual 3D plots and the default settings for all new 3D plots.

To access the 3D Plot Setup, choose **3D Plot > Actions > 3D Plot Setup.**

Alternatively, you can double-click the item on the plot you wish to edit. This will automatically open the 3D Plot Setup and display the options associated with that item. The available options in the 3D Plot Setup will vary, depending on the plot type. You can move the mouse pointer over an option to display its definition.
To apply your changes to the current plot only, click **OK**.

To save your changes and use them as the default setting for all new 3D plots, click the **Save as Default** button. This will overwrite the previous default settings.

To restore the previously saved defaults, click the **Load Defaults** button. This is an easy way to undo changes you have made in the 3D Plot Setup and re-apply default settings.

To reset all settings to the default values that were shipped with the application, click the **Reset** button.
Chapter 29: Synthesis Workbooks

The Synthesis Workbook is a custom reporting tool that is built directly into many Synthesis applications, including Weibull++/ALTA, RGA and BlockSim. It combines two reporting modules – Spreadsheets and Word Processing – into the same flexible interface, thereby replacing the Analysis Workbook and Word Report Template functionality from prior versions.

**Tip**: If you convert a project from Synthesis 10 or earlier, any Analysis Workbooks and Word Report Templates will be automatically converted to Synthesis Workbooks.

If your organization has implemented a Synthesis Enterprise Portal (SEP) website for an enterprise database, you can choose to publish selected Synthesis Workbook reports to be accessed from any web-enabled device. See [Publishing to SEP](#).

### Synthesis Workbook Wizard

To add a new Synthesis Workbook in an existing project, choose **Insert > Reports and Plots > Synthesis Workbook**.

This launches the wizard, which gives you the opportunity to assign the first associated data source and/or select a saved template, if desired. (Note that the examples shown here are from Weibull++ but similar functionality is available in ALTA, RGA and BlockSim.)

**If you prefer to start with a blank report:**

Simply click **OK** and then click **Yes** when prompted to confirm that you want to create the report without associating a data source. (You will be able to associate data source(s) later if you wish.)

**If you want to assign the first data source:**

Click **Select** and choose one of the available analyses (i.e., a data sheet in Weibull++/ALTA and RGA, or a diagram in BlockSim). When you return to the wizard, click **OK** to create the report.

Note that you will be able to associate more data sources after the report is created, and change any of those assignments at any time. (See [Associated Data Sources](#)).
If you want to use a saved template:

Click Spreadsheet or Word Processing. Select the Based on Existing Template check box and then choose a template from either the Standard tab (templates that are installed with the software) or the User tab (templates you have saved). Then click OK to create the report. (See Synthesis Workbook Templates.)

Associated Data Sources

In Synthesis Workbooks in Weibull++/ALTA, RGA and BlockSim, you have the option to associate multiple data sources that can be used for any function that obtains data or results from an existing analysis. (To obtain results from a DOE analysis in Weibull++/ALTA, see DOE Analysis Report.)

When you create this type of function, you will have the option to use an index to specify which of the currently assigned default data sources will be used. For example, if you want to compare the reliability values calculated from two different analyses, you can use

=RELIABILITY(Default1,1000) to get the result from the first default data source, and
=RELIABILITY(Default2,1000) to get the result from the second default data source.

Although you will be prompted to associate the first data source when you create the report, you can add or change associated data sources for an existing report at any time.

Associating Data Sources

For Synthesis Workbooks, the Information panel (located on the right side of the window) shows which analyses are currently assigned as default data sources. To have the panel always display, click the pushpin icon into the vertical position.
To add or remove analyses, choose **Home > Report > Associate Data Sources** or click the icon in the Information panel.

The following picture shows the windows for Weibull++. Similar functionality is available in ALTA, RGA and BlockSim.

Note that:

- In **Weibull++/ALTA**, you can select any data sheet from a folio that contains a life data analysis:
  - Life data folio
  - Life-stress data folio
Chapter 29: Synthesis Workbooks

- Non-parametric LDA folio
- Warranty analysis folio
- Degradation analysis folios (the results shown in the report will be based on the analysis of the extrapolated failure/suspension times)

- In **RGA**, you can select any data sheet in a growth data folio.
- In **BlockSim**, you can select any analytical diagram, simulation diagram or phase diagram. The function results can either be based directly on the analyzed/simulated diagram, or based on a model that has been fitted to the diagram. You specify this preference on the diagram’s control panel, using the **Report folio model** drop-down list on the Analysis Settings page.

### Linking Multiple Data Sources with Different Time Units

In BlockSim, function results that are time-based (e.g., downtime, time to event, etc.) will be returned in the **System Base Unit (SBU)** for the repository. However, in Weibull++/ALTA or RGA, each function result is returned in the units used by its data source. If you wish to compare the results from multiple data sources that use different time units, there are two possible scenarios:

- Convert the data in the original data source. For example, if one data set is in "hours" and another is in "days," you could use the **Change Units** feature to automatically convert the data in the first analysis from "hours" to "days."

  **Tip:** If you want to keep the original analysis unchanged, you could create a copy of the data sheet, then convert the duplicate data sheet to use the new units.

- Manually adjust the functions so they return results in the same units. For example, if the data set is in "days" and you want the results to display the B10 life in "hours," you could adjust the function by adding a conversion ratio. For example, if 1 day is equivalent to 24 hours, you could edit the function as follows:

  ```
  =(TIMEATPF("Weibull!Week!Data1",0.1))*(24).
  ```

### Synthesis Workbook Templates

In Synthesis Workbooks, saved templates make it easy to reuse the same report multiple times — in different analysis projects and with different data sets.
Note: For DOE analyses, instead of saved templates for the entire workbook, you can use saved profiles in the DOE Report Generator.

In addition to the \textit{Standard} templates that are installed with the software, you can also create your own \textit{User} templates that are saved from any existing report. Note that the templates are module-specific (i.e., compatible with either the spreadsheet module or the word processing module).

\section*{Saving Your Own Templates}

It is easy to create a template from any Synthesis Workbook that is currently open.

Select either the spreadsheet or the word processing module, then choose \textbf{Document > Document > Save Template}.

You can name and store the custom templates however you wish. To share a template with other users, you can simply send them a copy of the file, or you can save the file in a shared network location that multiple users can access.

\section*{Using a Template}

You can select a template when you create a new Synthesis Workbook. (See \textit{Synthesis Workbook Wizard}.)

Alternatively, you can use the steps below to apply or change the template for an existing workbook at any time.

\textbf{IMPORTANT}: This will replace any existing content in the current module, and the change can't be undone.

1. Select either the spreadsheet or word processing module and then choose \textbf{Document > Document > Open Template}.

2. Select a template from either tab then click \textbf{OK} to apply the template to the new or existing report.
   \begin{itemize}
   \item The \textit{Standard} tab displays the templates that are installed with the software and stored in the applicable sub-folder under \texttt{C: \Users\Public\Documents\ReliaSoft\Templates}.
   \end{itemize}
The User tab displays custom templates that were saved from an existing report. These can be stored in any location that is convenient for you. If the custom template you need is not displayed, click the Open icon to browse for the desired template and add it to the list.

Spreadsheet Module
The spreadsheet module in Synthesis Workbooks provides functionality similar to Microsoft Excel (with built-in functions and complete in-cell formula support), and it can be used to integrate data and/or results from multiple analyses at the same time.

Send to Excel
To export all sheets in the spreadsheet module to a Microsoft Excel file, choose Home > Report > Send to Excel.

Inserting Functions
- To build and insert functions that utilize a referenced analysis (data source), see Function Wizard - Data Sources.
- To add math, date, logic and other functions, see Function Wizard - Formulas.

Showing Formulas
To display the formulas instead of the calculated results in the worksheet cells, choose Formulas > Formula Auditing > Show Formulas.
You can toggle the formula display on and off.

![Formula Display]

**Recalculate Formulas**

By default, the spreadsheet automatically recalculates all formulas whenever you open the workbook or when the cells that a formula depends on have changed. However, if your spreadsheet contains a large number of formulas, the recalculation process may take more time and every change may require you to wait several seconds or minutes for the application to recalculate all values. In this case, you can control when calculation occurs by changing the setting to manual calculations.

To use manual calculations, choose **Formulas > Calculation > Calculation Options**, and then choose the **Manual** option. To change the settings back to automatic calculations, choose the **Automatic** option.

![Manual Calculation]

To recalculate all formulas when in Manual mode choose **Formulas > Calculate > Calculate Now**.

![Calculate Now]

The **Calculate Now** command can also be used to refresh the spreadsheet. A spreadsheet needs to be refreshed whenever its referenced data source(s) has been recalculated. This ensures that the spreadsheet reflects the most current results.

**Adding Custom Charts**

To create your own custom chart, first select the cells that contain the relevant data, then go to **Document > Charts** and choose a chart type and style. (See **Custom Charts in Synthesis Workbooks**.)

**Defining Names**

To create variable names that reference specific spreadsheet cells, see **Defined Names**.
Word Processing Module

The word processing module in Synthesis Workbooks offers custom reporting functionality that is similar to a Microsoft Word document. You may prefer to use this tool if you want to have a more polished, professional looking report.

This module has two tabs located at the bottom of the window: Design and Review. Use the Design tab to add text, functions and plot holders. Use the Review tab to see the results before you generate the final report.

To export the report to Microsoft Word, choose Send to Word.

Using the Function Wizard

To use the Function Wizard to build and insert functions that utilize a referenced analysis (data source), choose Home > Report > Function Wizard. (See Function Wizard - Data Sources.)

Using the Plot Wizard

To use the Plot Wizard to generate a variety of plots based on a referenced analysis, choose Home > Report > Plot Wizard. These are the same types of plots that are generated in an analysis folio or diagram plot sheets. (See Plot Wizard.)

Using Spreadsheet References

To reference cells from the spreadsheet module (within the same workbook), choose Home > Report > Spreadsheet Reference and select the desired cells. The link between the word processing and spreadsheet modules is dynamic; when data in the spreadsheet is changed, the word processing module is automatically updated. (See Spreadsheet References.)

Formulas and Functions

Function Wizard - Data Sources

In both the spreadsheet module and word processing module for Synthesis Workbooks in Weibull++/ALTA, RGA and BlockSim, you can build functions that return results based on an analyzed folio or diagram.

Note: To insert math, date, logic and other functions into the spreadsheet module of a Synthesis Workbook, see Function Wizard - Formulas.
Using the Function Wizard

To open the Function Wizard in Synthesis Workbooks, choose **Home > Report > Function Wizard**.

Select a function from the navigation panel and enter any required inputs. The following picture shows the most complex configuration as an example. After entering the inputs, click **Insert** to place the function into the report at the current cursor location. You can move and/or modify the function expression after it has been inserted.

For spreadsheet functions:

- The bracketed parameters indicate that the input is optional. In the example above, the **Add Time** and **Confidence Level** parameters are optional.

- You can use cell references as inputs. For example, instead of entering 1000 for a time input, you could specify to use whatever time is currently entered into cell A10, using either the relative reference (A10) or the absolute reference ($A$10). (See **Cell References**.)

- You can use variable names as inputs. (See **Defined Names**.)

- You can type the function expressions directly in the cell once you are familiar with the syntax. For more information, see **Data Entry Tips for Functions**.

For the word processing module:

- The brackets are part of the function field and are not optional.
The functions will not return any results until you either switch to the **Review** tab or generate the report in Microsoft Word.

### Selecting a Data Source (if Applicable)

There are two ways to specify the data source:

- **Use the Data Source Name** (spreadsheets module only): This approach will return results based on a specific data sheet or diagram.

  In the Function Wizard, clear the **Use Default** check box and click the **Select** button to choose the data source, as shown next. In this example, the function will return results based on the data sheet called "Data1" in the Weibull++ life data folio called "Folio1."

![Data Source](image1.png)

- **Use a Data Source Index** (spreadsheet and word processing modules): This approach allows you to use the report as a template and return results based on a given data set.

  First, you must add data sources to the Synthesis Workbook (see **Associated Data Sources**). Then, in the Function Wizard, click the **Data Source Index** drop-down list and choose the index number of the desired data source. (In spreadsheets, select the **Use Default** check box to access the **Data Source Index** drop-down list.)

![Data Source Index](image2.png)
Function Wizard - Formulas

In the spreadsheet module for Synthesis Workbooks in Weibull++/ALTA, RGA and BlockSim, you can insert functions that perform math, date, logic and other operations.

Using the Function Library

The quickest way to add a function is to select it from the appropriate function category drop-down list, then select the cells of interest (hold down the CTRL key to select nonconsecutive cells) and press ENTER. You can move and/or modify the function expression after it has been inserted.

For example, to calculate the average reliability for the following units, you would choose Formulas > Function Library > AutoSum > Average. Select cells B3 through B9 and press ENTER. Note that the cell references can be relative (B3:B9) or absolute ($B$3:$B$9). (See Referencing a Cell.)

Using the Function Wizard

To use the Function Wizard, choose Formulas > Function Library > Insert Function.

Select a function from the drop-down list and click OK. Then in the Function Argument window, enter the input by either selecting the cells in the sheet or typing them directly into the appropriate field. For information relating to entering text as an input, cell references, and working with date and time functions, see Data Entry Tips for Functions.
Chapter 29: Synthesis Workbooks

For example, to exclude the value from unit 4 (failure due to operator error) from the average, you would select cells B3 through B5 for **Number 1**, and B7 through B9 for **Number 2**.

Data Entry Tips for Functions

This topic provides some data entry tips for using spreadsheet functions in Synthesis Workbooks and general spreadsheets. If you create the function using the Function Wizard, most of the syntax and formatting issues will be handled automatically. However, you have the option to create or modify function expressions directly in spreadsheet cells.

*Note:* For DOE design folios, you can disregard any tips related to data source functions (i.e., functions that obtain data or results from a specific data sheet or diagram). For that type of analysis, you can use the DOE Analysis Reports feature to obtain results from a design, multiple linear regression or one-way ANOVA folio, or any of the measurement systems analysis folios.

Case Sensitivity

The functions are not case sensitive.

Entering Text as an Input

When entering text as an input to a function, you must enclose it in quotation marks. This includes situations where you need to specify the data source – DISTR("Weibull!Folio1!Data1") – and situations where you need enter a time or date value in one of the accepted text formats – DAY("22-Aug-2014").
Regional Settings
If your regional settings use a comma as the decimal separator, you must use a semicolon to separate function arguments (e.g., =RELIABILITY("Weibull!Folio1!Data1";A4)).

Referencing a Cell in the Same Sheet
If you want to use another cell in the same sheet, enter the cell reference with a letter to identify the column and a number to identify the row. The cell references can be relative (e.g., B2) or absolute (e.g. $B$2).

- A relative reference points to a cell based on its relative position to the current cell (e.g., B2). When the cell containing the reference is copied, the reference is adjusted to point to a new cell with the same relative offset as the original cell.
- An absolute reference points to a cell at an exact location. Absolute references are designated by placing a dollar sign ($) in front of the row and/or column that is to be absolute. For instance, $B$2 is an absolute reference that points to the cell located in Column B, Row 2 regardless of the position of the cell containing the reference.

For example, if you want to obtain the probability of failure for the time that has been entered in cell B2, the function could be either =PROBFAIL(B2) or =PROBFAIL($B$2). You can type the cell location directly into the field or click the Function Wizard’s Insert Workbook Reference icon to insert the reference to the cell currently selected in the sheet. If you want to insert an absolute reference, press CTRL while you click the icon.

Another option is to use the Defined Names tool to assign a name to the cell and use the name in all of the function expressions that require that input. (See Defined Names.)

Referencing a Cell in a Different Sheet
To reference a cell in a different sheet from the one in which the formula is entered, use an exclamation mark (!) after the sheet name. For instance, =Sheet1!$B$2 is a reference to the cell located in Column B, Row 2 in Sheet 1. When referencing a cell in a different sheet from the one in which the formula is entered, the reference must be absolute. If the reference is not absolute, the calculations will not be carried out properly.

You can only reference sheets in the same workbook.

Referencing a Cell in a Data Source
Some functions (e.g., DATAENTRY and FMATRIX) require you to reference a particular cell in a data source. This must be defined differently than references to a cell in a spreadsheet. For data source cell references, you must identify first the row and then the column, and use a
Creating Composite Functions

It is possible to combine different types of data sources and/or functions to create a composite function. For example, in the following formula, two different data sources are used to return the difference between the reliability at 100 hours calculated from the specific Weibull++ life data folio data sheet called "Weibull!Target!Data1" and the reliability at 100 hours calculated from any given Weibull++ data sheet that is currently first in the list of associated data sources for the workbook or General Spreadsheet.

```excel
(RELIABILITY("Weibull!Target!Data1",100)) -
(RELIABILITY(Default1,100))
```

In the next example, nested functions are used to round up the returned reliability result to the nearest two decimals.

```excel
=ROUNDUP((RELIABILITY(Default1,100)),2)
```

Omitting Optional Inputs in the Middle of a Function

If you do not use an optional input in the middle of the function, the function expression must specifically indicate that the input is being omitted. For example, when using the Weibull++ reliability function `RELIABILITY(Data_Src,Age,[Add Time],[Confidence Level])`, if you want to get the confidence bound on the reliability, you must use two commas (,,) to indicate that the [Add Time] input is intentionally blank, before entering the [Confidence Level] in its usual fourth position (e.g., =RELIABILITY(Default1,1000,,0.95)).

Note that this is handled automatically if you use the Function Wizard to build and insert the function expression.

Working with Date Functions

When using one of the spreadsheet date functions (`DAY`, `DAYS360`, `MONTH`, `WEEKDAY` and `YEAR`) to enter a date, you can use one of the following accepted text formats:

- Month/Day/Year ("8/22/2014"). For example, =DAY("8/22/2014") returns 22.
- Day-Month-Year ("22-Aug-2014"). For example, =MONTH("22-Aug-2014") returns 8 (because August is the 8th month).
If you do not include the year (e.g., “8/22” or “22-Aug”), the current year is assumed.

Alternatively, you can use the date’s serial number (which is the number of elapsed days since January 1, 1900). For example, =YEAR(41873) returns 2014.

- You can obtain a date’s serial number using either of the following two functions. This may be helpful in cases where you want to filter, sort or use the date(s) in calculations.
  - The DATE function uses the inputs of other cells to obtain the serial number. For example, if you have dates specified in three cells where A2=Year, B2=Month and C2=Day, =DATE(A2, B2, C2) returns the serial number for that date.

<table>
<thead>
<tr>
<th>D2</th>
<th>=DATE(A2,B2,C2)</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>B</td>
</tr>
<tr>
<td>1</td>
<td>Year</td>
</tr>
<tr>
<td>2</td>
<td>2014</td>
</tr>
<tr>
<td>3</td>
<td></td>
</tr>
</tbody>
</table>

- The DATEVALUE function requires you to enter the date in an accepted text format. For example, =DATEVALUE("8/22/2014") returns 41873.

Finally, you can also use the results of other functions within a date function. For example:

- To return the month from today’s current date, use: =MONTH(TODAY())
- To return the day of the week for a date that is specified in three separate cells (A2=Year, B2=Month and C2=Day), use: =WEEKDAY(DATE(A2, B2, C2))

<table>
<thead>
<tr>
<th>D2</th>
<th>=WEEKDAY(DATE(A2,B2,C2))</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>B</td>
</tr>
<tr>
<td>1</td>
<td>Year</td>
</tr>
<tr>
<td>2</td>
<td>2014</td>
</tr>
<tr>
<td>3</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>(Friday is the 6th day of the week.)</td>
</tr>
<tr>
<td>5</td>
<td></td>
</tr>
</tbody>
</table>

**Working with Time Functions**

When using one of the spreadsheet time functions (HOUR, MINUTE and SECOND) to enter a time, you can use one of the following valid text formats:

- Hour:Minute[:Second] [AM/PM]. For example, =HOUR("4:48:10 PM") returns 16 (the hour using the 24 hour system).
- Month/Day/Year Hour:Minute[:Second] [AM/PM]. For example, =MINUTE("8/22/2014 4:48:10 PM") returns 48.

Xfmea/RCM++/RBI 11 User’s Guide 773
Alternatively, you can use the hour, minute or second’s serial number (which is the fractional portion of a 24 hour day). For example, `=MINUTE(0.70011574)` returns 48 (as the specified serial number represents 4:48 PM).

- You can calculate a time's serial number using either of the following two functions. This may be helpful in cases where you want to filter, sort or use the time(s) in calculations.
  
  - The `TIME` function uses the inputs of other cells to obtain the serial number. For example, if you have dates specified in three cells where A2=Hour, B2=Minute and C2=Second, `=TIME(A2,B2,C2)` returns the serial number for that time.

    | D2 =TIME(A2,B2,C2) |
    |-------------------|
    |                   |
    | A | B   | C   | D         |
    |---|-----|-----|----------|
    | 1 | Hour| Minute| Second | Serial # |
    | 2 | 16  | 48   | 10       | 0.70011574 |
    | 3 |     |      |         |          |

  
  - The `TIMEVALUE` function requires you to enter the time as text in one of the accepted text formats. For example, `=TIMEVALUE("4:48:10 PM")` returns 0.70011574.

Finally, you can also use the results of other functions within a time function. For example:

- To generate current values, you can use the `NOW` function. If the current time is 4:48 PM, then `=HOUR(NOW())` returns 16.

**Returning Confidence Bounds**

For functions in Weibull++/ALTA and RGA that return confidence bounds, note that the Function Wizard for data sources only inserts one-sided bounds. If you want to show two-sided bounds, you can insert the same function twice — once at the lower confidence bound and once at the upper confidence bound. For example, for a 90% confidence level, you would set the lower confidence bound at 5% and the upper confidence bound at 95%.
• In a spreadsheet, you can use the same function (with different input parameters) to obtain any of the three values. For example, in Weibull++:

\[
\text{=RELIABILITY(Default1,1000) returns the estimated value}
\]

\[
\text{=RELIABILITY(Default1,1000,,0.05) returns the lower one-sided bound at 5%}
\]

\[
\text{=RELIABILITY(Default1,1000,,0.95) returns the upper one-sided bound at 95%}
\]

Note that the above function expressions for the confidence bounds uses two commas (,,) to indicate that another optional input ([Add Time]) was intentionally left blank. For more information about the syntax for functions containing multiple optional inputs, see Data Entry Tips for Functions.

• In a word processing module for Synthesis Workbooks, the wizard provides separate functions for confidence bounds. For example, use the Reliability function to get the estimated value and use the Bound on Reliability function to get each one-sided confidence bound.

**Plot Wizard**

In the word processing module for Synthesis Workbooks in Weibull++/ALTA, RGA and BlockSim, you can use the Plot Wizard to generate a variety of plots based on a referenced analysis. These are the same types of plots that are generated in folio or diagram plot sheets. Although you also have the option to copy/paste a static plot graphic from any folio or diagram plot sheet into the report, using the Plot Wizard makes it easy to change the associated data source when you reuse the template and ensures that the plot in the generated report will always show the latest analysis. (For DOE designfolios, you can use the DOE Analysis Reports feature to insert plots from a design, multiple linear regression or one-way ANOVA folio, or any of the measurement systems analysis folios.)

To open the Plot Wizard, choose Home > Report > Plot Wizard.
The following picture shows the plot wizard in Weibull++. Similar functionality is available for RGA and BlockSim.

There are three steps to use this tool:

1. Select the plot type (and enter the inputs, if applicable)
2. Select the data source
3. Insert the plot holder

**Select the Plot Type**
First, select one of the available plot types from the panel on the left side. The right side of the wizard displays some information about the plot that is currently selected.

If applicable, this area also allows you to make relevant inputs (e.g., for ALTA plots that require you to select a specific stress column).

**Select the Data Source**
To specify the data source that the plot will be based on, choose a number from the Data Source Index drop-down list, as shown next. Using the index makes it easy to reuse the same template with a variety of different data sets.
Insert the Plot Holder
When the plot is fully defined, click **Insert** to place it at the current cursor location. You can move and/or resize the plot holder after it has been inserted. The plot holder shown next will return the reliability vs. time plot for whatever data source is currently second in the list of associated data sources.

Plot holders will not return any results until you view it in the Review tab or generate the report (**Home > Report > Send to Word**).
Custom Charts
In the spreadsheet module for Synthesis Workbooks, you can use the Document > Chart commands to insert your own custom charts. The charts can be placed anywhere in the spreadsheet, and are dynamic (automatically update when the data used to create the chart is changed).

Adding a Chart
1. Select the cells that contain the data of interest. In the example data below, the headings are included in the selection and will be used as the legend labels.

<table>
<thead>
<tr>
<th>Time</th>
<th>Product A</th>
<th>Product B</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>0.99996</td>
<td>0.99586</td>
</tr>
<tr>
<td>200</td>
<td>0.99920</td>
<td>0.96401</td>
</tr>
<tr>
<td>300</td>
<td>0.99506</td>
<td>0.87716</td>
</tr>
<tr>
<td>400</td>
<td>0.98217</td>
<td>0.72349</td>
</tr>
<tr>
<td>500</td>
<td>0.95220</td>
<td>0.52071</td>
</tr>
<tr>
<td>600</td>
<td>0.89495</td>
<td>0.31434</td>
</tr>
<tr>
<td>700</td>
<td>0.80119</td>
<td>0.15282</td>
</tr>
</tbody>
</table>

2. Choose Document > Charts. Choose the chart type, and then click a chart subtype that you want to use.
3. To move the chart, click and drag the chart to the desired location.

4. To resize the chart, click the chart and then drag the sizing handles to the desired size.

Changing the Data Displayed on an Axis
To change the way the data series is displayed on the axes, click the chart, then choose **Design > Data > Switch Row/Column.**

Changing the Chart Type and/or Data Set
You can change the type of chart and/or the data that is used in a chart at any time. To do this, click the chart and then:

- To change the chart type, choose **Design > Type > Change Chart Type.** Select the desired type.
To change the data set, choose **Design > Data > Select Data**. Select the cells that contain the data of interest.

### Applying a Chart Layout and/or Chart Style

- To apply a predefined chart layout, choose **Design > Chart Layouts**. As an example, the following picture shows some of the options for 2-dimensional bar charts. To see the rest, click the arrow in the bottom-right corner.

![Chart Layouts](chart_layouts.png)

If none of the predefined options are suitable for your chart, choose **Layout > Labels**, then select the option you want to customize. The following picture shows the options for the vertical axis.

![Axis Titles](axis_titles.png)

- To apply a predefined chart style, choose **Design > Chart Styles**.

![Chart Styles](chart_styles.png)

### Renaming Chart and Axes Titles

When displaying chart and/or axes titles, you can rename the titles by right-clicking the chart and selecting the appropriate title option from the shortcut menu. For example, choosing **Change Chart Title** opens the following window:
Modifying the Axes and Gridlines

To hide or display axes and/or gridlines, choose **Layout > Axes > Axes** or **Gridlines**.

- When displaying axes, you can change direction of the x-axis and/or change the scale of the y-axis.
- When displaying gridlines, you can increase or decrease the number of gridlines for both the axes.

Defined Names

In the **spreadsheet module** for Synthesis Workbooks and **general spreadsheets** in Weibull++/ALTA and RGA folios, you can create variable names that reference specific spreadsheet cells. The names can then be used in any formula or function within the same workbook.

For example, say you want to obtain the reliability of a Weibull++ data set. The operating time is stored in cell B5 of the spreadsheet:

\[
=\text{RELIABILITY}("\text{Weibull!Bulb!Data1!}$B$5))
\]

You can create a defined name for the operating time to make the formula easier to understand and maintain. In this case, the formula might be rewritten as:

\[
=\text{RELIABILITY}("\text{Weibull!Bulb!Data1!"OpTime})
\]

You can then use the defined name **OpTime** in any other formula in the workbook that requires the operating time.

Syntax Rules for Names

- The first character of a name must be a letter or an underscore. The remaining characters can be letters, numbers, periods and underscores. Names are not case sensitive.
Chapter 29: Synthesis Workbooks

- Spaces are not allowed as part of a name. An underscore ( _ ) or period ( . ) can be used as a word separator.
- Symbols, except for underscores ( _ ), periods ( . ) and backslashes ( \ ), aren’t allowed.

Managing Names
To view and manage defined names:

- In Synthesis Workbooks, choose Formula > Defined Names > Name Manager.
- In general spreadsheets, choose Sheet > Format and View > Defined Names.

You can then use the New, Edit, or Delete commands in the window to create or modify the names.

Defining Names
There are several ways to define a name.

Define a Name via the Name Manager
This method applies to both Synthesis Workbooks and general spreadsheets.

1. Select a cell or range of cells.
2. Create a new name:
   - In Synthesis Workbooks choose Formulas > Defined Names > Define Name (or choose Formulas > Defined Names > Name Manager, then click the New button in the window).
   - In general spreadsheets, choose Sheet > Format and View > Defined Names. Then in the window, click the New button.
3. Type a name into the Name field. In the Scope drop-down list, choose whether this name will be used for the entire workbook or a specific sheet. The Comment field is optional.

The selected cell/range will already be defined in the Refers to field, but you can click into the spreadsheet and select different cells, if desired.
Define a Name via the Name Box (Synthesis Workbook Only)
This method applies only to the spreadsheet module of Synthesis Workbooks. Select the cell or range of cells, click the Name box and type a name. Press Enter to create the name.

Define a Name via the Selection Command (Synthesis Workbook Only)
If the fields are already labeled in the spreadsheet, you can use them to create names.

1. Select the cells of interest (including the row or column labels), then choose Formulas > Defined Names > Create from Selection.

2. In the window, select the location of the labels. Click OK.
Spreadsheet References

In Synthesis Workbooks, the *spreadsheet reference* feature provides integration between the spreadsheet and word processing modules in the same workbook. You can insert a reference from any cell, or consecutive range of cells, from the spreadsheet into a desired location in the word processing document. If the referenced cells in the spreadsheet are changed, the word processing module is automatically updated. The changes are visible when you use the Review tab to see a preview or generate the Word report.

To insert a spreadsheet reference, place the cursor at the desired location in the word processing document and choose Home > Report > Spreadsheet Reference.

Note that you can also use the Spreadsheet Reference function in the word processing module’s Function Wizard.

The Select Cells window shows the contents of the spreadsheet module in the current workbook. Select a cell or range of consecutive cells and click OK.
For the example data shown above, the entry would look like this:

```
[TBLSSREF(Sheet1!B2:D10)]
```

**DOE Analysis Reports**

The DOE Analysis Reports feature allows you to insert selected analysis results and plots into a Synthesis Workbook. This feature is available for any analyzed response in a design, multiple linear regression, one-way ANOVA or measurement systems analysis folio. The report can display any result that's available in the folio's Analysis Summary window for the selected response, as well as any applicable plot.

This topic describes how to build and insert a DOE analysis report, and how to use saved profiles for reports that you need to generate frequently. Note that you can insert multiple reports into the same spreadsheet or word processing document, if desired. Each additional report will be appended to the end.
Inserting a DOE Analysis Report

1. Select either the spreadsheet or word processing module in a Synthesis Workbook and choose Home > Report > DOE Analysis Report.

2. In the Select Response window, choose an analyzed response to copy the results from and click OK.

3. In the DOE Analysis Report window, the Available Report Items area (left) shows all of the available results and plots for the selected response. The Selected Report Items area (middle) shows the selected results/plots, in the order in which they will appear. You can:
   a. Choose Profiles > Open Profile to apply all of the relevant selections from a saved report profile. (See Using DOE Report Profiles.)
   b. Build/modify the list using double-click, drag and drop or the Add/Remove and Up/Down buttons.

Note that you can include multiple instances of the same report item, if desired.

4. When you click each selected report item, the Item Properties area (right) allows you to view/change the name (heading) that will be used in the report, if desired.

   For plots, you can also click the Preview Plot button to see what the plot will look like in the report. Any plot settings you change in the plot preview will be used in the generated report but will not affect the folio the report is based on.


Using DOE Report Profiles

When the DOE Analysis Report window is open, you can save the current settings (i.e., report item selections), or load settings that were previously saved.

- To save all your current report settings for use in future reports, choose Profiles > Save Profile.

Then specify the name and location of the DOE report file (*.drt) that will store the settings.
• To overwrite all the settings in the DOE Analysis Report window and use the settings from a DOE report file instead, choose **Profiles > Open Profile.**

![Folder Icon]

Then select the *.drt file that has all the desired settings.

**Note:** When you load report items from a DOE report file, only the items that apply to the selected folio/response will be included in the report.
Chapter 30: Synthesis Dashboards

The dashboard is a flexible tool for graphical presentation of data. This can include bar and pie charts, gauges, maps, etc.

All Synthesis users can view dashboards based on predefined layouts (see Dashboard Viewer). The viewer is available in the following locations in Synthesis desktop applications:

- Project Planner
- Synthesis Explorer
- Simulation diagram results in BlockSim (see FMEA in the BlockSim/RENO documentation)
- FMEA and FMRA data in Xfmea/RCM++ (see FMEA Dashboards in the Xfmea/RCM++/RBI documentation)
- Synthesis Data Warehouse (SDW) data in Weibull++ and RGA

In a secure database, only users with the "Manage dashboard layouts" permission can manage and create predefined layouts (see Dashboard Layout Manager and Dashboard Layout Designer).

If your organization chooses to implement a web-based Synthesis Enterprise Portal (SEP) for an enterprise database, you can also share selected dashboards to be accessed from any web-enabled device!
Dashboard Viewer

Any user can access the Dashboard Viewer in a variety of locations throughout Synthesis desktop applications for graphical presentation of the latest analysis data.

When dashboard functionality is available for the data you’re working with (e.g., Project Planner, Synthesis Explorer, simulation diagrams in BlockSim, etc.), choose Dashboard > Dashboard Viewer to open the viewer.

Select any of the predefined dashboard layouts from the drop-down list to see the latest charts for the current data set.

Resizing Panels

To resize the dashboard items vertically and/or horizontally, click between two items and drag the resize cursor (+-) to the height and/or width you want. This option is available when a dashboard contains multiple items.
Showing Details in Charts and Pies
To see more details about the underlying data, move the mouse pointer over a bar or slice. For example, when the pointer is over a bar in a chart, the values for the x and y axes will be displayed in the tooltip.

Drill Downs and Master Filters
For information about how to use charts that have been configured for a drill down, see Viewing Drill Downs. For information about how to use charts that have been configured with master filters, see Using Master Filters.

Sorting and Filtering Data in a Grid
- To sort the data in ascending or descending order, click the column heading.
- To filter the data, click the Advanced Filter icon to see a drop-down list of filters that you can apply. The dashboard uses the same advanced filters functionality that is built in to other Synthesis utilities (e.g., Resource Manager, Synthesis Explorer, etc.). (See Finding and Filtering Records.)

Printing or Exporting the Dashboard
To print the entire dashboard, or export it as a *.pdf file or as an image, click the Export To icon.
Viewing Drill Downs

An easy way to determine if the dashboard was configured for drill down is to look for the arrow in the caption bar, if the bar is visible.

To drill down, double-click an area of interest.

To drill up, click the arrow (↑) until you have reached the desired level or right-click the chart, then choose Drill Up.

![Chandelier Drill Down](http://xfmea.reliasoft.com)
Using Master Filters
When a dashboard with master filters is created, it can be configured for single or multiple filtering. If you see either of the following, then filtering is enabled:

- **For single** filtering, the dashboard title is followed by light gray text.

- **For multiple** filtering, the **Clear Master Filter** icon displays in the caption bar, if the bar is visible.

Note that if you see both the icon and light gray text, this means that multiple filtering is enabled, but only one item in the filter is selected.

**Single Filtering**
For single filtering, you can only select one item at a time. You will not be able to clear the view, only select a different item.

**Multiple Filtering**
For multiple filtering, you can select as many filter items as you want to view. Hold down **SHIFT** while clicking to select consecutive elements or hold down **CTRL** while clicking for nonconsecutive items.

In the example shown next, the grid was set up as the master multiple filter. The chart and pie charts display the data for the four parts selected in the grid.
Chapter 30: Synthesis Dashboards

Dashboard Layout Manager

You can use the Dashboard Layout Manager to create, edit and delete the predefined dashboard layouts that will be available for any Synthesis user to view for a particular data set. (In a secure database, this is available only for users with the “Manage dashboard layouts” permission.)

To open the Dashboard Layout Manager, choose the command from any Synthesis interface that supports dashboard functionality (e.g., Project Planner, Synthesis Explorer, simulation diagrams in BlockSim, etc.). It will display only the layouts for that particular data type.
You can also open the Dashboard Layout Manager from the Backstage view (File > Manage Repository > Dashboard Manager). It will display all of the layouts for any data type. If you want to see only the layouts specific to the application you are using, select the check box.

![Show only layouts specific to the current application]

**Show in Viewer**

Use the check boxes in the Show in Viewer column to select which of the predefined layouts will be available to all database users via the Dashboard Viewer. If you clear a check box, the layout will not show in the viewer’s drop-down list but will remain in the manager’s list.

<table>
<thead>
<tr>
<th>Name</th>
<th>Show in Viewer</th>
</tr>
</thead>
<tbody>
<tr>
<td>System Dashboard</td>
<td>✔️</td>
</tr>
<tr>
<td>BlockDashboard</td>
<td>✔️</td>
</tr>
<tr>
<td>Crew Dashboard</td>
<td>☐</td>
</tr>
</tbody>
</table>

Use the up/down arrows to change the order of the layouts that are shown in the viewer’s drop-down list.

**Layout Properties**

For all dashboard layouts that are selected to show in the Dashboard Viewer, the name that will be visible in the list is set from the Layout Properties window. To view or change these properties, select a row in the table and click the Properties button (or right-click and choose Properties).

![Properties]

The description and update history are available to help you manage the layouts; that information is not visible to all database users.
Chapter 30: Synthesis Dashboards

**Importing Layouts**

It is easy to reuse dashboard layouts that were created in other databases. Click the Import button and then select the database you want to import from. If you are using the Dashboard Layout Manager in the Backstage view, you can import layouts of any type. If you’re using a manager from one of the locations where dashboards are used, you can only import layouts of the current type.

![Import button](http://xfmea.reliasoft.com)

**Dashboard Layout Designer**

You can use the Dashboard Layout Designer to create or edit each predefined dashboard layout. (In a secure database, this is available only for users with the "Manage dashboard layouts" permissions.)

To access this window, first open the Dashboard Layout Manager and then choose to either create a new layout or edit an existing one.

**Separate Layouts for Each Data Type**

Each dashboard layout is designed to be used with a specific data type, which determines which fields are available and where the dashboard can be viewed. For information about creating dashboards for each particular type of data, see:

- Project Planner Dashboards
- Synthesis Explorer Dashboards
- Simulation Diagram Dashboards (in the BlockSim/RENO documentation)
- FMEA Dashboards (in the Xfmea/RCM++/RBI documentation)
- Synthesis Data Warehouse (SDW) Dashboards (available in Weibull++/ALTA and RGA)

**Configuring a Dashboard Item**

This topic demonstrates some of the basic steps for configuring a dashboard item (bar chart, pie chart, gauges, etc.) in the Dashboard Layout Designer. The simple bar chart in this example is based on block-level simulation results from a reliability block diagram in BlockSim. The data source options will be different for other locations where dashboards are available, see Project Planner, Synthesis Explorer, Simulation Diagram Dashboards (BlockSim/RENO), FMEA Dashboards (Xfmea/RCM++/RBI) or SDW Dashboards (Weibull++/ALTA and RGA).
In a secure database, only users with the "Manage dashboard layouts" permissions can create layouts.

**Add the Chart**
Add a chart to the Layout panel by choosing Home > Insert > Chart.

**Define the Chart Data**
1. Select a data source from the drop-down list in the Data Source panel, if applicable.

2. Choose the data field (or fields) that will be displayed in the y-axis of the bar chart, then drag each field into the Values area in the DATA ITEMS panel. For this example, the chart will display total operating cost, cost from preventive maintenance and cost from corrective maintenance.

Note that when different data sources are available, all of the data fields used within a chart must come from the same source.
**Tip:** To replace a data item, drag a new field on top of the current one. To remove a field, drag it anywhere outside of the data item; and to completely clear the DATA ITEMS panel, right-click the chart and select **Remove Data Items**.

3. Use the drop-down list to see which values are available for this data field (e.g., count, sum, average, etc.) and choose one to display in the chart. Note that the same option must be selected for all values in the same chart.

Because we want the total cost from all blocks that meet the given criteria, we use the default **Sum** for this example.

4. If appropriate, use the **Rename** command to change the name that will be displayed in the chart legend, tooltip, etc.

5. Choose the data field that will be displayed in the x-axis, then drag it to the **Argument** bar.
Filter the Data
To filter the data displayed in the chart, choose Data > Filtering > Edit Filter.

Use the Filter Editor to define the criteria. For this example, we’re using the “Not And” operator to exclude any blocks with a name that contains “Hub.”

Tip: You can use hidden data items to filter based on fields that are not displayed in the chart.

Sort by “Top N”
To configure the chart to show only the top 5, bottom 10, etc., use the Top N command in the Argument data item’s drop-down list.
Chapter 30: Synthesis Dashboards

For this example, we’re showing only the Top 5 blocks, based on total operating cost. The results are displayed from highest to lowest and the order cannot be changed.

Tip: Alternatively, you could use the Sort by command to sort by the argument data item — which is labeled (Value) in this menu — or by any of the value data items. Click the Argument bar to toggle the sort between ascending and descending order.

Other Design Options
Click the Design tab on the ribbon to access other configurable options for this type of chart. For example:

1. To hide or display the caption bar above the chart, choose Show Caption.

   ![Caption Bar]

   We will keep it displayed for this example.

2. To change the title in the caption bar to something more meaningful, choose Edit Names.

   ![Edit Names]

   For this example, we will set the Dashboard item name to “Top 5 Blocks by Total Operating Cost” and clear all of the Series fields to make sure the latest data item name (set via the Rename command in the data item’s drop-down list) will always be used in the chart legend and tooltip.
3. To change the y-axis title to a more meaningful name, choose **Y-Axis Settings**.
Available Dashboard Items
The following dashboard items can be added to any layout. You can add the same type of item more than once, if desired. To insert an item, choose Home > Insert, then click one of the following options.

- **Pivot**
- **Chart**
- **Gauges**
- **Choropleth Map**
- **Range Filter**
- **Scatter Chart**
- **Grid**
- **Pies**
- **Cards**
- **Geo Point Map**
- **Text Box**
- **Image**

Data Types
There are two types of data that can be used in a dashboard item: measure or dimension.

- **Measure** data is calculated (sum, count, average, etc.). For example, the values on the y-axis of a chart, the size of a slice in a pie or a target value in a card or gauge. Values and targets are forms of measure data.

- **Dimension** data can be sorted but is not calculated. For example, the bars in chart, slices in a pie or text in a grid column. Arguments and series are forms of dimension data.

Data Shaping
You can use the Dimensions and/or Measures bars in the HIDDEN DATA ITEMS panel when you want to perform data shaping (filtering, sorting or Top N) but do not want the data to be displayed in the dashboard item. Data shaping is available for any dashboard item, except text boxes and images.

- The data fields contained in the **Dimensions** bar can be used in Filter Editor window to create filter conditions based on their values. Dimensions in this area have the same sorting functionality that is available in the argument, attribute or series DATA ITEMS area.

- The data fields contained in the **Measures** bar can be used in the Sort by submenu and in the Top N Values window for data sorting. Measures in this area have the same calculation functionality that is available in the values and target DATA ITEMS area.
Configuring a Drill Down

Drill down can be enabled for the following dashboard items:

- Grids: Specify two or more columns
- Charts and pies: Specify two or more arguments and/or series
- Gauges: Specify two or more series
- Cards: Specify two or more series

Configuring a Drill Down Sequence

1. In the Dashboard Layout Designer window, select the chart or grid you want to drill down.

2. Drag the additional data fields into the **Arguments** area in the appropriate order for the desired drill down sequence.

For example, you can use the following sequence to configure a pie chart in a Synthesis Explorer dashboard to first show analyses by application source, then drill down to analysis type.

3. Choose **Data > Filtering > Drill Down**. This command is a toggle; choose the command again to disable the drill down.

When any user views this layout in the Dashboard Viewer, he/she will be able to double-click inside the chart to drill down, and use the arrow (↑) to drill back up. (See Viewing Drill Downs.)

**Tip:** To make it easy to identify a drill down in the Dashboard Viewer, display the dashboard item’s caption bar (Design > Common > Show Caption).

Filtering

Using the Filter Editor

You can use the Filter Editor to incorporate filters into dashboard items that contain dimension data. Arguments and series are forms of dimension data.
This type of filtering only applies to the dashboard item you have selected. To filter the data across the entire dashboard, see Configuring a Master Filter.

Dimension Data Locations
Dimension data can be used in any or all of the following areas:

- Dimension bar in the HIDDEN DATA ITEMS panel.
- Dimension, argument and/or series bars in the DATA ITEMS panel.

An easy way to determine if a data field is a dimension, argument or series, is to look for the sort arrow to the left of the data field name.

Configuring a Filter
1. In the Dashboard Layout Designer window, select a dashboard item, then choose Data > Filtering > Edit Filter. This command is also available in the shortcut menu when you right-click the dashboard item.

2. In the Filter Editor window, define the criteria. The dashboard uses the same Edit Filter functionality that is built in to other Synthesis utilities (e.g., Resource Manager, Synthesis Explorer, etc.). (See Finding and Filtering Records.)

In the following example, a chart was created for data that was extracted from XFRACAS into the Synthesis Data Warehouse (SDW) in Weibull++.
Because we are interested in only the chandelier parts (not the whole unit) and data from 2010 and later, we can apply the following filter to remove the unwanted data:

**Configuring a Master Filter**

A master filter can be used to filter data across the entire dashboard. Grids, pies, charts, gauges, cards and maps dashboard items can be used as master filters.

There are two types of master filters that can be configured:

- **A Single** filter allows you to select one item at a time. You will not be able to clear the filter, only select a different item.
A Multiple filter allows you to select one or more items at a time. You can also clear the filter to view all items at any time. This is the most flexible option.

For example, suppose your layout contains a grid, a chart and a pie, and the grid is configured as the multiple master filter. When you select items in the grid, only the data for those items will display in the chart and pie.

**Configuring a Master Filter**

In the Dashboard Layout Designer window, select the dashboard item, then enable the master filtering by choosing Data > Interactivity > [Single Master Filter/Multiple Master Filter]. This command is a toggle; choose the command again to disable it.

When any user views this layout in the Dashboard Viewer, he/she can use the filter to view only the data of interest. (See Using Master Filters.)

Note that you can prevent a specific dashboard item from being affected by master filters, by selecting it in the Layout panel and then choosing Data > Interactivity settings > Ignore Master Filters. This command is a toggle; choose the command again to disable it.

**Tip:** To make it easy to identify that a dashboard item is configured for filtering in the Dashboard Viewer, display the item's caption bar (Design > Common > Show Caption).
Chapter 31: Synthesis Data Warehouse

Available in Weibull++, ALTA and RGA, the Synthesis Data Warehouse (formerly called “Reliability Data Warehouse”) enables you to access data from an XFRACAS incident tracking system for the purpose of life data analysis (in Weibull++/ALTA) or repairable system/reliability growth analysis (in RGA). You can also set up custom connections to obtain reliability-related data from external data sources (including Access, Oracle and SQL Server). You can also get data directly from your own custom reports created in ReliaSoft’s XFRACAS.

You can then transfer the data to an analysis folio in Weibull++, ALTA or RGA, or use the flexible Synthesis Dashboard utility to explore and present the data in a variety of graphical charts and grids. (See Transferring from the SDW to an Analysis Folio or SDW Dashboards.) In addition, if a Synthesis Enterprise Portal has been implemented for an enterprise database, users can also access SDW dashboards from any web-enabled device.

To open the SDW in Weibull++, ALTA or RGA, choose Home > Synthesis > Synthesis Data Warehouse.

Managing Data Sources

The available data sources are listed in the data source manager on the left side of the window. They may include:

- Static data collections that were extracted from XFRACAS at a particular point in time (and will not change if incidents are later added or updated). These can be either Weibull++/ALTA data or RGA data. (See Extracting Data from XFRACAS.)

- Custom connections that have a live link to a specified external database or to a predefined report created in XFRACAS. (See Custom Connections in the SDW.)

- Static data collections that were extracted from a custom connection at a particular point in time (and will not change if the original data source changes). (See Import to a Static Data Collection.)

If you are working with a long list of available data sources, this panel can utilize the same categories, identifiers and item filters that are available in many other locations throughout Synthesis desktop applications.

To create, delete, rename or edit the properties for these data sources, use the Manage Data Sources commands, or right-click inside the panel.
The Properties window allows you to enter identifiers for each data source, and to view its history.

**Built-in Find/Filter, Configuration and Grouping Tools**

Double-click any data source to display the data in a grid on the right side of the window. The SDW offers the same filter, column configuration and grouping tools that are built in to other Synthesis utilities that use a similar grid (e.g., the Synthesis Explorer, Actions Explorer, etc.). For details about how to use each feature, see:

- Finding and Filtering Records
- Configuring Columns
- Grouping Panel

**Building the Data Set**

The "Include in Analysis?" column shows whether each row will be included in the data set when it is transferred to Weibull++, ALTA or RGA, or viewed in a dashboard.

- **Include**: Data points that will be included in the data set are shown in green.
- **Invalid**: In XFRACAS data collections, incidents with a State Time of less than 0 are automatically set as invalid. These rows are shown in red.
- **Ignore**: In XFRACAS data collections, incidents with a State Time of 0 that are marked as suspensions in the State FS column are automatically set to be ignored. These rows are shown in gray.
- **Exclude**: Incidents that have been manually excluded are shown in blue.

By default, incidents that are marked as Invalid or Ignore will be excluded from the data set. To manually include or exclude specific data points, select the row(s) and choose **Build Data Set > Include** or **Build Data Set > Exclude**.
To view only those rows that are included, choose View > Show Only Included. You can toggle this command off to show all records.

In XFRACAS data collections, you can also select the row and choose Build Data Set > View XFRACAS Incident to open the incident in your web browser. This command is available only if you have permission to view incidents in the current XFRACAS entity (which is set via the XFRACAS administrative interface).

**Extracting Data from XFRACAS**

When you are working with an enterprise database that contains XFRACAS data, or a standard database that has a connection to external XFRACAS tables, you can use the Synthesis Data Warehouse to extract static data collections. These can be either Weibull++/ALTA data or RGA data, and the collections will not change if incidents are later added or updated in XFRACAS. (Alternatively, if you need a live link to a predefined report that has already been created in XFRACAS, see Connect to XFRACAS Report.)

To extract a static data collection from XFRACAS, first open the SDW in Weibull++, ALTA or RGA and then choose Manage Data Sources > Get XFRACAS Data.

(In a secure database, this is available only to users with the "Create/edit/delete SDW data collections" permission. Additionally, users must have the "Synthesis - Read Data" permissions for the associated XFRACAS tables.)

In the XFRACAS to SDW window, choose an Entity to import from, then select the check box for each part that you want to extract the incident (i.e., failure) data for. If needed, you can use the Auto Filter Row to filter the grid by matching text in one or more columns. (For extremely large data sets, this row will be hidden and a Filter window will be available instead.)
Chapter 31: Synthesis Data Warehouse

Click **Next**, then specify other settings or fields to import:

- **Time Metric** allows you to choose which metric to use with the data. The options are based on the metrics that your system administrator has enabled for the XFRACAS entity.

- **Incident Detail Fields** allow you to map customized detail fields from the XFRACAS incident to one of the user-defined field columns in the SDW collection. The following field types can be mapped:
  
  - **StringUDF1-3**: Alphanumeric Input Box, Check Box, Company, Contacts, Currency, Date, Numeric Input Box, Users, Yes/No Button, or the Select List, Administrative Controlled field type
  
  - **NumberUDF1-3**: Currency or Numeric Input Box
  
  - **DateUDF1-3**: Date

- In RGA, additional options are available:
  
  - **Include Non-Chargeable** extracts incidents that are marked as either chargeable or non-chargeable in XFRACAS. If you clear the check box, it will extract only chargeable incidents.
  
  - **Only System Down Events** extracts only those incidents that brought the system down.
  
  - **Filter by Date Commissioned** extracts only incidents for systems that were commissioned between the specified dates.

Click **Next**, then enter a name for the data collection and any **Synthesis identifiers** that you want to use.

When you click **OK**, the extraction process will begin. Depending on the amount of data that you are extracting, this may take some time.
You can then use the data collection to transfer data to an analysis folio or explore/present in the dashboard utility. For information about the fields that will be available either in the Build Data Set tab or in the Dashboard Designer, see Data Fields for XFRACAS Data Collections.

Data Fields for XFRACAS Data Collections

The following fields are available for use in dashboard layouts for XFRACAS data collections and for data sets created via the Synthesis API. These are the same columns available in the Build Data Set tab. The fields in custom connections will depend on the data source itself.

- **Address Location**: the location of the owner of the system. This corresponds to the Location field in the XFRACAS contact.
- **Category**: the incident category. This corresponds to the Category field in the XFRACAS incident and, in conjunction with the failure type assigned during part repair/replacement, determines whether the data row is chargeable (i.e., is considered a failure for reliability calculations) or non-chargeable (i.e., is considered a suspension). For more information, see the “Incident Disposition Area” topic in the XFRACAS documentation.
- **Chargeable**: the chargeable code value (where 0 = non-chargeable, 1 = chargeable): equivalent to the Category Chargeable and Category Non-Chargeable lists in the XFRACAS Admin List page. This is to be used to calculate the failure state (StateFS). XFRACAS categories can also be viewed within an XFRACAS incident.
- **CompanyOwner**: the owner of the system. This corresponds to the Company field in the XFRACAS contact.
- **DataID**: the database ID of the row.
- **DataSetID**: the ID of the data set that the row belongs to. This is useful if you are viewing multiple data sets at the same time.
- **DateUDF1-3**: user-defined fields for dates. You can choose up to 3 detail fields in XFRACAS incidents to import to these columns.
- **ExtractedBy, ExtractedDate** and **ExtractedName**: identify the user who extracted the data from XFRACAS, the date of extraction and the name of the SDW data collection.
- **FailureMode**: the failure mode associated with the incident. This is chosen or created in the Failure Mode field in the XFRACAS incident.
- **IncidentAction**: the action taken to address the incident (whether a part was removed or installed). This is not related to XFRACAS actions. In XFRACAS data sets, repaired and
replaced parts will be represented using two rows of data—one will be for removing the part, and one for installing it.

- **IncidentEntityDisplayID**: the incident number assigned by XFRACAS, which includes the prefix for the entity that it is associated with (e.g., E1-201).

- **IncidentID**: the database ID of the incident.

- **IncidentOccurrenceDate**: the date when the incident happened. This corresponds to the Occurrence Date field in the XFRACAS incident.

- **IncidentRepairDate**: the date that part repair or replacement was completed. This corresponds to the Completed Date field that applies to the XFRACAS incident resolution.

- **IncidentResolution**: notes regarding the resolution of the incident. This corresponds to the Incident Resolution field in the XFRACAS incident.

- **IsLRU**: indicates whether the item is a line replaceable unit (LRU). This does not correspond to an XFRACAS field; it can be used when creating data sets via the Synthesis API.

- **LastInspectedTime**: the last inspected time. For exporting XFRACAS data sets to Weibull++, this is equal to the state time for the data row. For exporting XFRACAS data sets to RGA, it is the amount of time the system has accrued at the last reported incident.

- **NumberInState**: equivalent to the Number in State column in a Weibull++ life data folio for grouped data. In data sets from XFRACAS, this value will always be 1.

- **NumberUDF1-3**: user-defined fields for numbers. You can choose up to 3 detail fields in XFRACAS incidents to import to these columns.

- **ParentPartID, ParentPartName, ParentPartNumber and ParentPartVersion**: identifiers for the "parent" of the part that the incident pertains to. If the part doesn't have a parent (i.e., it is a top level part), this information will be identical to the information for the part itself.

- **PartHID and PartID**: the part’s hierarchy identification number and database identification number. In XFRACAS, these are assigned by the system and shown in the HID and Part ID fields that are displayed for the generic part on the Template page.

- **PartName, PartNumber and PartVersion**: identifiers for the part that the incident pertains to. In XFRACAS, this information is specified for the generic part, and serialized parts based on the generic part will use the same information.
Chapter 31: Synthesis Data Warehouse

- **PartOrder**: the order in which the part was replaced. This corresponds to the order in the repair/replace table in the XFRACAS incident.

- **PartSerialHID, PartSerialMfgCode and PartSerialNumber**: relevant only if the incident was assigned to a part in a serialized system. They represent the part’s serial hierarchy identification number, manufacturing code and serial number. In XFRACAS, the PartSerialHID is assigned by the system and shown in the Serial HID field that is displayed for the serialized part on the Serialized page.

- **ReportType**: how the incident was reported. This corresponds to the type chosen in the Report Type field in the XFRACAS incident.

- **RootCause**: the root cause of the failure mode. This is chosen or created in the Root Cause field in the XFRACAS incident.

- **StateFS**: This allows the user to understand if a data row is considered a failure (F) or a suspension (S) for the purposes of reliability calculations. In XFRACAS data sets, this is based on the incident category assigned in the XFRACAS incident, in conjunction with the failure type assigned during part repair/replacement. For more information, see the “Incident Disposition Area” topic in the XFRACAS documentation.

- **StateTime**: the amount of time accrued on the part. This is based on the run hours calculated by XFRACAS.

- **StateTimeRestore**: the amount of time required for the repair. This corresponds to the Repair Duration field in the XFRACAS incident.

- **StringUDF1-3**: user-defined fields for strings. You can choose up to 3 detail fields in XFRACAS incidents to import to these columns.

- **TimeMetric**: the time metric to use for the data. The options are based on the metrics that have been enabled for the XFRACAS entity.

- **TopLevelCommissionDate**: the commission date of the top level part in the system. This corresponds to the commission date of the associated CSI in XFRACAS.

- **TopLevelPartID, TopLevelPartName, TopLevelPartNumber and TopLevelPartVersion**: identifiers for the top level part in the system that the incident pertains to.

- **TopLevelSerialHID and TopLevelSerialNumber**: relevant only if the incident was assigned to a part in a serialized system. They represent the serial hierarchy identification number and serial number of the top level part in the serialized system. This information is used by RGA and Weibull++ to distinguish the system in which the failure occurred.
Transferring from the SDW to an Analysis Folio

Follow the steps below to transfer a data set from the Synthesis Data Warehouse (SDW) to a Weibull++, ALTA or RGA analysis folio.

1. In Weibull++, ALTA or RGA, choose Home > Synthesis > Synthesis Data Warehouse.

2. In the SDW, double-click the data you want to transfer to an analysis folio.

3. In the data table, use the Include in Analysis? column to mark any data points that need to be excluded from the transfer. You can double-click the cell to toggle the options, or select the row and choose Build Data Set > Include or Exclude.

In data collections imported from XFRACAS:

- Incidents with StateTime = 0 and StateFS = S (suspension) are automatically marked Ignore.
- Incidents with StateTime < 0 are automatically marked Invalid.

4. Choose Transfer > Transfer to New Folio.
Follow the on-screen prompts to select the data type and map the SDW fields to columns in the new analysis folio.

**Tips for Mapping the Columns**

- **State F or S** (in Weibull++/ALTA) indicates whether a data point represents a failure (F) or suspension (S). If the data source field does not use the F and S codes, use the Define Values as Failures/Suspension area to specify which value(s) represents each state.

- **Event** (in RGA) indicates whether the data point represents a failure (F) that will be transferred for analysis, or some other event that will not be analyzed as a failure. When a data point is marked as a suspension (S) for transfer to RGA, it will be considered only if it affects the recorded system end time. For example, if the System End Time column indicates that the system was last inspected at 1,000 hours but there is a suspension for that system at 1,100 hours, the later time will be used in the folio.

- Time and quantity columns, such as **State End Time** and **Number in State**, can only be mapped to fields with a numeric data type (e.g., number, currency, etc.).

- **Classification** and **Mode** columns (in RGA) can be mapped to any SDW user-defined field that contains the data. (See Extracting Data from XFRACAS.)
• **Subset ID** columns (in Weibull++/ALTA) or **Comment** columns (in RGA) allow you to choose multiple SDW fields to display in the same folio column. The data from the fields will be concatenated and separated by dashes (e.g., "Report Type – Category"). Use the check boxes to select the fields and then use the arrows to specify the order.

---

**SDW Dashboards**

This topic describes how to use the **Synthesis Dashboard utility** for exploring and presenting data from the **Synthesis Data Warehouse**. If a **Synthesis Enterprise Portal** has been implemented for an enterprise database, users can also access SDW dashboards from any web-enabled device.

For static data collections, a variety of dashboard layouts can be predefined. For custom connections, there can be only one layout for each connection.

1. In Weibull++, ALTA or RGA, choose **Home > Synthesis > Synthesis Data Warehouse**.

2. Double-click the static data collection or custom connection that contains, or links to, the data you want to view in the dashboard.

3. On the Build Data Set tab, select which rows to include or exclude. (See **Building the Data Set**.)

4. If an appropriate dashboard layout has already been predefined, switch to the Dashboard Viewer tab or choose **Dashboard > Dashboard Viewer**. If multiple layouts are available, use the drop-down list at the top of the viewer to choose what to display.

5. If you need to create a new layout, choose **Dashboard > Dashboard Manager** (for a static data collection) or **Dashboard Designer** (for a custom connection).
(In a secure database, the Dashboard Layout Manager and the Dashboard Layout Designer are available only for users with the “Manage dashboard layouts” permission.)

For information on the data fields available for use in dashboard layouts for SDW data collections, see Data Fields for XFRACAS Data Collections.

Custom Connections in the SDW
The Custom Connections feature in the Synthesis Data Warehouse allows you to create a live link to an external data source (Access, Oracle or SQL Server). This enables you to get data from your own custom and third-party databases for transferring to an analysis folio in Weibull++, ALTA or RGA, or for viewing in the SDW dashboards.

You can also get data directly from your own custom reports created in XFRACAS.

A custom connection data source always shows the latest information from the original database or report and you can only create one dashboard layout per connection. You can also use these connections to import data into a static Weibull++/ALTA or RGA data collection, if desired.

Connect to an External Database
To create a live link to an external database:

1. Choose Manage Data Sources > Add Custom Connection > To External Database.

2. In the Add Custom Connection window:
   a. Enter the Display Name that will identify this custom connection in the SDW data source list.
   b. Enter the connection settings for a Microsoft SQL Server, Oracle or Access database. (See Connection Issues below for more information about the Use impersonation option for SQL Server.)
Chapter 31: Synthesis Data Warehouse

c. After you have specified the database, the **Table Name** field shows a list of the available tables. Select the main one that contains the data you want to use in the SDW.

d. If you want to create aliases for column names, build a query that combines data from multiple tables or enter your own SQL, select the **Open Query Editor/Builder** check box.

e. If you want to create the dashboard layout for this data source immediately after defining the connection/query, select the **Open Dashboard Designer** check box.

f. Click **OK** to proceed.

3. If you selected to customize the query, you can use the Query Editor to type or paste your own query, or select a stored procedure. If you need further tools, click the **Run Query Builder** button. The Query Builder can serve three purposes:

   a. The bottom-center panel shows the fields that will be included in the data set. If desired, you can use the Alias column to change the names that will be displayed in the SDW grid and dashboard layouts.

   b. If the tables are linked by foreign keys, you can use the tool to build a query that combines fields from multiple tables.

   c. You can also enter your own SQL in this tool; select the **Allow SQL Editing** check box and type or paste your own query.

When you are finished in the Query Builder, click **OK** to return to the Query Editor, where you can click **Finish** to save your changes.

4. If you selected to open the Dashboard Designer, you can use it to create a single **dashboard layout** for this data source.

If you want to change the query or create/modify the dashboard layout at a later time, select the custom connection in the data source manager and choose **Dashboard > Dashboard Designer**.

From within the Dashboard Designer window, choose **Home > Query > Edit** to customize the query.
**Connection Issues**

There will be a "connection failed" message if the database is not found at the specified name/location or if you don’t have permission to access it.

If your organization has implemented a Synthesis Enterprise Portal (SEP) website, the administrator may need to take additional steps to make the dashboards visible to all users via the SEP website. For details, consult the print-ready implementation guide (*.pdf).

- **Oracle** - the password is stored with the custom connection; therefore, both the desktop applications and SEP website will attempt to connect in the same way for all users.

- **SQL Server** - the *Use impersonation* option in the custom connection allows you to enter a login for a one-time extraction to an SDW data collection, but this login is not saved in SDW.

For subsequent attempts, the desktop applications will connect with the current user’s Windows login, whereas the SEP website will use the login that the website uses to connect with the Synthesis repository (if the Synthesis repository is SQL Server) or with the IIS "application pool identity" (if the Synthesis repository is Oracle).

- **Access** - the SDW can only connect with databases that are not password protected and must have access to the folder where the database is stored. It is recommended to use the UNC pathname (e.g., `\\servername\foldername` rather than `P:\foldername`) when you create the custom connection.

The desktop applications will attempt to access the file with the current user’s Windows login, whereas the SEP website can only access files stored directly on the web server or in a network folder that can be accessed by the website’s IIS "application pool identity."

---

**Tip:** For Access databases with the *.accdb file type, the dashboard can only be displayed if the database was created with the same version of Microsoft Office (32-bit vs. 64-bit) that is installed on each individual user’s computer (for Synthesis desktop applications) or on the web server (for SEP).

To ensure that the dashboard will display regardless of which version of Microsoft Office is installed, use the *.mdb file type instead of *.accdb.

---

**Connect to XFRACAS Report**

Creating a custom connection to a predefined XFRACAS report enables you to use the SDW to view any type of XFRACAS data (not just data collections extracted for life data or repairable systems analysis). If a Synthesis Enterprise Portal has been implemented for an enterprise
database, users can also access the dashboards created for these reports from any web-enabled device.

**Tip:** For information about creating SDW reports in XFRACAS, see the "Report Builder" topic in the XFRACAS documentation.

To create a live link to an SDW report that has already been created in XFRACAS:

1. Choose **Manage Data Sources > Add Custom Connection > To XFRACAS Report**.

2. In the Select Report window, select any of the XFRACAS SDW reports that have been predefined in the database.

3. Click **OK** to load the data.

**Import to a Static Data Collection**

In the **Synthesis Data Warehouse**, a **custom connection** provides a live link to an external database or XFRACAS report, while a static data collection stores Weibull++/ALTA or RGA data that was extracted at a particular point in time.

A static data collection can contain **data extracted directly from XFRACAS**. If desired, you can also create a static Weibull++/ALTA or RGA data collection by importing data from a custom connection. To do this:

1. Right-click the custom connection in the data source manager and choose **Import**.

2. In the Import Data from Custom Connection window:

   a. The **Map Data Source Fields to Columns** section specifies which field from the custom connection will be mapped to a column that’s available in a Weibull++/ALTA or RGA data collection.

   b. The **Define Values as Failures/Suspensions** section displays all of the unique values from the field that is currently mapped to the State FS column. Specify whether each value should be considered a failure or a suspension.

   c. The Preview tab allows you to see what the data collection will look like based on your selections.

3. Click **OK** to create the static data collection.
Chapter 32: Synthesis Enterprise Portal

If your organization chooses to implement a web-based Synthesis Enterprise Portal (SEP) for an enterprise database, the entire team – including managers and colleagues who don’t have Synthesis desktop applications installed – will have the opportunity to access key analysis and project management details from any web-enabled device.

In Version 11, the website has a completely redesigned interface with more at-a-glance summaries and better usability on mobile devices.

SEP Home

Completely redesigned in Version 11, the personalized SEP home page provides an intuitive, at-a-glance overview of the information you’re tracking via the website, such as actions, recent messages, reports, metrics and more.

For example, this panel shows the status of the gates and actions for the project plan that is currently active for you in SEP. Use the drop-down list to choose a different project or click to see the full project plan.

You can choose which panels are displayed in your own home page, and also change the order (see Customizing the SEP Home Page).
Chapter 32: Synthesis Enterprise Portal

Project Plans
The SEP website shows a streamlined view of the project plan for each project you have permission to view. Project plans are created and edited via the Synthesis desktop applications (except MPC) and the website always displays the most recent information from the plan.

New in Version 11, the "My Projects" feature makes it easy to access the projects that you frequently need to view in SEP (see My Projects in SEP).

Actions and Portal Messages
The SEP website allows you to create, view and edit the same actions and portal messages that are visible to you from the desktop applications (see Portal Messages and Managing Actions in SEP).

Redesigned in Version 11, the web interfaces now offer better display from mobile devices, and more capabilities (including links/attachments).

Project and Analysis Summaries
The SEP website shows a summary from each analysis project you have permission to view. This may include:

- The overall status of the project plan, and all of the actions (from FMEAs, the project plan or standalone) that are being tracked for the project.
- The KPIs (metric resources) that have been defined for the project.
- The analysis summaries and reports that have been published to SEP from Weibull++/ALTA, BlockSim/RENO, RGA or Lambda Predict (see Publishing to SEP).
- All of the files and website resources that have been linked or attached to the project.

http://xfmea.reliasoft.com
System Hierarchies and FMEAs
The SEP website shows the system hierarchies and FMEAs created in Xfmea/RCM++/RBI. The website always displays the most recent information from the project.

You can also access any generated reports that have been published to the website in Word, Excel, PDF or HTML format (see Save/Publish Reports in the Xfmea/RCM++/RBI documentation).

Dashboards & Reports
Redesigned in Version 11, the "Watch This Report" feature makes it easier to manage the specific dashboards and reports you want to be able to access quickly via the SEP website. This includes:

- A wide variety of graphical dashboards based on predefined layouts for different types of data (project plans, Synthesis Explorer, simulation diagram results, FMEAs or Synthesis Data Warehouse).

- A flexible, web-based "spreadsheet viewer" and "document viewer" for Synthesis Workbook reports that have been published to SEP.

For details, see Dashboards & Reports in SEP.

Metrics (Key Performance Indicators)
The SEP website shows all of the KPIs (metric resources) that have been created in desktop applications for the projects you have permission to view – no publishing required.

Redesigned in Version 11, the metrics are now easier to scan "at-a-glance" to help you monitor performance and support decision making.
Synthesis Explorer and Synthesis Data Warehouse

The SEP website shows all of the Synthesis Explorer or Synthesis Data Warehouse (SDW) dashboards that have been predefined in the desktop applications.

- **Synthesis Explorer dashboards** provide a flexible way to explore all the different analyses that are stored in the Synthesis repository (e.g., application source, analysis type, created by, last update, etc.).

- **SDW dashboards** present charts and results from any of the data collections or custom connections that have been created in Weibull++/ALTA or RGA. This can include data extracted from ReliaSoft's XFRACAS or from external databases and systems (CMMS, EAM, etc.).

XFRACAS

ReliaSoft's XFRACAS is a highly configurable web-based failure reporting, analysis and corrective action system (FRACAS) with integrated capabilities for part tracking, root cause analysis and team-based problem resolution.

If your organization implements both the SEP and XFRACAS websites for the same enterprise repository, the SEP can include links to the XFRACAS reports, charts, actions and incidents of particular interest to each user (see SEP and XFRACAS).

How to Implement the SEP

This topic provides a general overview of the steps required to implement a web-based Synthesis Enterprise Portal for your organization.

When you are ready to configure a website, the print-ready implementation guide (*.pdf) provides more detailed instructions for each step.
Establish the Database and Web Server(s)
The SEP is a web-based system based on the .NET Framework and is designed to be n-tier, scalable, distributable, robust and able to be deployed across multiple servers or on a single computer.

If you plan to host the database and website on the same server, you will need:
- Windows 2008 R2 or Windows 2012 (*Windows 2003 is not supported*)
- .NET 4.0
- IIS with support for serving ASP.NET
- SQL Server 2008 or newer OR Oracle 10g or newer (32-bit and 64-bit versions of all, full version only)

Install the Website and Connect to a Synthesis Repository
Once you have established the database and web server(s), a system administrator will need to:

1. Run the Synthesis Enterprise Portal setup to create the website.
2. Run the Product Activation tool to activate your SEP license.
3. Run the Synthesis Admin tool to either create a new Synthesis repository or connect to an existing one. You can also use this utility to create Synthesis Platform user accounts if desired.

Remember that ReliaSoft’s XFRACAS, Synthesis desktop applications and the SEP website are all designed to connect with the same data repository. If you already have a database established, you can use the admin tool to integrate it with the SEP.

Set Up Synthesis Platform User Accounts and Permissions
Once the Synthesis repository has been created, you can use the Synthesis Admin tool or any of the desktop applications to create Synthesis Platform user accounts and set access permissions. You must create an account for anyone who will be able to edit or view data in the Synthesis desktop applications or SEP website. (User accounts for the XFRACAS website are managed separately.)

If your organization uses Microsoft Active Directory, you can save time by importing user information from the directory to create the user accounts.
**Assign SEP Access to Users**

Once the Synthesis Platform user accounts have been created (via desktop application or the Admin tool), you can use the SEP website to specify which of the database users will have access to the web portal.

Click the **SEP Admin** link in the top-right corner of the website and then use the Select SEP Users section to specify which user accounts will have website access.

The counters above the user table identify how many more SEP users are allowed under your current license.

---

**Enable Publish to Synthesis Enterprise Portal**

Some SEP-related features in Synthesis desktop applications (e.g., the ability to publish analysis summaries, workbooks, reports, etc.) will be visible only if the Enable publish to Synthesis Enterprise Portal option is set to "Yes" for the database.

This can be set from the SEP Admin page in the website or from the Repository Settings window in any of the desktop applications.

---

**Configure Custom Content for Home**

The optional "Custom Content" area in the SEP home page enables your organization to integrate a banner or other custom content into the site, if desired. This can be configured from the SEP Admin page in the website.
The SEPDefault.htm file is installed in the CustomContent folder under the root directory for the SEP website. You can choose to edit this file on the web server or replace it with a URL to another web page.

Configure 'Custom Content' for the home page:

Visible: 

Height in pixels: 100

Caption: Title of the Panel in the Home Page

- Use SEPDefault.htm on the application web server
- Use a page from another website (HTTP only)

http://www.mysite.com/banner_page.htm

**Note:** If the content of the page is taller than the specified height in pixels, users with IOS devices will not be able to scroll.

**Configure URLs for Links to Actions in SEP**

When an SEP website is implemented for a Synthesis repository, the action alert e-mails and portal messages generated by any of the Synthesis applications can include links to view the action details in SEP. The applications build the links based on the settings specified on the SEP Admin page in the website. If an administrator has not specified an IIS prefix, the action alerts will not include links to SEP.

- **SEP Server - IIS Prefix:** enter the server name and folder for the website that you see in the browser’s address bar (e.g., servername/SEP).

- **Website Uses SSL (https for URLs):** select Yes if the web server has been configured with a Secure Socket Layer (SSL) certificate for the SEP website and the URLs need to start with https rather than http.

If these settings do not match your website configuration, the links attached to the action alerts will give an error message when users attempt to open the page in a web browser (e.g., "File or directory not found," "Access forbidden" or "This page can’t be displayed").
Configure Links Between XFRACAS and SEP
If your organization implements both the SEP and XFRACAS websites for the same enterprise repository, you can use the Admin Preferences page in XFRACAS (Admin > Configure > Preferences) to enable links between the two websites.

- **SEP → XFRACAS:**
  - Specify the **XFRACAS Server - IIS Prefix** (e.g., servername/XFRACAS)
- **XFRACAS → SEP:**
  - Specify the **Synthesis Enterprise Portal Server - IIS Prefix** (e.g., servername/SEP)
  - Set **Synthesis - Display Synthesis Enterprise Portal (SEP) Command** to True

Distribute SEP Website Link to All Users
Once the web portal has been implemented, users can access the site with any web browser that supports the following doctype. If the site is private (e.g., http://InternalServer/SEP), the system administrator may need to provide users with instructions for how to access the website on the internal network from their mobile devices (e.g., via VPN or some other method).

```html
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
  "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
```

Customizing the SEP Home Page
The personalized SEP home page provides an intuitive, at-a-glance overview of the information you're tracking via the website.

Custom Content
The optional "Custom Content" area enables your organization to integrate a banner or other custom content into the site if desired. This can be configured on the SEP Admin page by any user with "administrative" permissions in the repository (see [How to Implement the SEP](#)).

If the custom content is enabled for a repository, the same panel will be displayed at the top of the home page for all SEP users.

Home Page Panels
For the rest of the home page panels, each user can choose which panels are displayed, and also change the order.
To modify your personalized home page, click **Edit Home Layout** in the top-right corner of the page.

When the page is in the edit mode, the panels will have a yellow background color and a (+) or (-) icon will appear in each title bar:

- Use the title bar to drag and drop a panel into a different position on the page.
- Use the icon to hide (-) or show (+) the panel.

To save your preferences and leave the edit mode, click **Save Layout**.

**Tip**: If you click the **Restore Defaults** button on the User Preferences page, your personalized home page layout will be reset to the default.

---

**My Projects in SEP**

New in Version 11, the "My Projects" feature makes it easy to access the projects that you frequently need to view in the Synthesis Enterprise Portal (SEP) website.

For any SEP page that shows data from a particular project (e.g., project plan, project summary or any of the analysis summaries), the **Change Project** button in the top-right corner allows you to view that same type of data from another project.

The first popup provides quick access to the projects that you have personally selected for quick access in SEP.
Chapter 32: Synthesis Enterprise Portal

Click **Select Projects** to modify this list or view a project that's not already in the list.

The right side shows your list of "My Projects" (i.e., the short list of projects that will appear first whenever you click **Change Project**).

The left side shows all the projects in the database that you have permission to view. You can apply any of the project filters that were created in Synthesis desktop applications, or use the **Find** box to filter by specific text in the project name.

- **Add to My Projects**
- **View Now** (i.e., view the project without adding it to your list)
- **Remove from My Projects**
- Indicates that the project is already in your list.
Tip: If you want to have quick access to the same set of projects while working in the Synthesis desktop applications, you can create a project filter that contains the same list. Select to filter based on Selected projects in the Project Filter window.

Managing Actions in SEP

If your organization chooses to implement the Synthesis Enterprise Portal (SEP) website for an enterprise repository, the entire team can view the latest project plans and FMEAs from any web-enabled device. This includes the assigned actions that are incorporated into those analyses, as well as any other standalone actions that are being tracked through the Synthesis Platform.

With major enhancements and usability improvements in Version 11, the options for managing actions in SEP are better than ever.

My Actions Panel in SEP Home

The "My Actions" panel in the SEP home page shows actions that are relevant to you and still require action of some kind (i.e., not started, not completed or need to be reviewed). They are listed in the order of urgency, up to the maximum number that will fit in the panel.

This may include any of the actions that are eligible to be displayed for you on the Actions page of My Portal in Synthesis desktop applications. To specify your preferences for the website, click your name on the right side of the header to open the User Preferences page, and select any of the following options:

Select actions to list on the home page:
- I need to review/approve
- I am responsible for
- I am a team member in
- I am monitoring
- Other actions I created

My Actions Page

The My Actions page displays all of your actions in a flexible table that you can filter, sort and group to meet your needs. It also provides the option to create a new action directly from the website.
Chapter 32: Synthesis Enterprise Portal

Create Action
When you click the Create Action button in the top-right corner of the page, this will add a new action in the project that is currently active for you in the SEP.

If you want to create the action in a different project, click the link in the header, as shown below, to go to the Project Summary page, and then use the Change Project button to select a different project.

Filter, Sort and Group the Table
The table can display all actions that are relevant to you in some way and still require action of some kind, including actions that did not fit in your home page. You can filter, sort and group the table on-the-fly to display the actions that are of interest at any given time. These settings will be reset to the defaults when you navigate away from the page.

- **Relevance** - the check boxes at the top of the page provide a quick way to filter the table based on how the actions are relevant to you. This is independent from your settings on the User Preferences page, which only affect the SEP home page.

- **Find Panel** - when you type in the input box, the table will show the actions that contain the text in any of the visible fields, and it will highlight all locations where the matching text occurs.

- **Grouping Panel** - the grouping panel (located under the input box) determines how the actions are grouped in the table. Drag and drop column headings into or out of this panel to change the grouping.
• **Column Headings**
  
  - To change the column order, drag and drop the column headings into the desired position.
  
  - When applicable, click the ▲ con to sort the property in ascending or descending order.
  
  - When applicable, click the 👀 to apply one of the built-in filters (blanks, non-blanks or unique values).

**Actions in a Project Summary**

The Project Summary page provides a list of all the actions that have been assigned within the current project.

To access this page, select **Projects** in the SEP menu and use the **Change Project** button to specify which project summary is currently displayed.
Chapter 32: Synthesis Enterprise Portal

**Actions in a Project Plan or FMEA**
The website includes full details for any actions that are incorporated into a project plan or FMEA. If you have permission to edit an action in a desktop application, you can perform the same updates via the website.

- To access a project plan, select **Project Plans** in the SEP menu and use the **Change Project** button to specify which project’s plan you want to view. In the project plan, click an action link to view the full details.

- To access an FMEA, click **Projects** in the SEP menu and use the **Change Project** button to specify which project’s system hierarchy and FMEAs you want to view. Then click the **Xfmea/RCM++/RBI** link.

In the system hierarchy, click an action link to view the full details.
Links to SEP from Action Alert E-mails and Portal Messages
The action alert e-mails and portal messages generated by any of the Synthesis applications can include links to view the action details in the SEP. The applications build the links based on the settings specified on the SEP Admin page in the website.

If these links are not working properly for your SEP website, see How to Implement the SEP.

Publishing to SEP
The Synthesis Enterprise Portal website does not display all of the analyses that were performed in Synthesis desktop applications. Instead, your team can decide which analyses to make available via the web, and publish selected analysis summaries and reports.

These features are only available when:

- You are connected to an enterprise database that has an SEP website implemented and the Enable publish to Synthesis Enterprise Portal option is set to "Yes" for the database.
- You have the "Publish to Synthesis Enterprise Portal" permission.

<table>
<thead>
<tr>
<th>Synthesis Application</th>
<th>What can be published</th>
</tr>
</thead>
<tbody>
<tr>
<td>Weibull++/ALTA</td>
<td>• Synthesis Workbooks</td>
</tr>
<tr>
<td></td>
<td>• Life Data analyses</td>
</tr>
<tr>
<td></td>
<td>• Non-Parametric LDA analyses</td>
</tr>
<tr>
<td></td>
<td>• Parametric RDA analyses</td>
</tr>
<tr>
<td></td>
<td>• Life-Stress Data analyses</td>
</tr>
<tr>
<td></td>
<td>• DOE Designs</td>
</tr>
<tr>
<td></td>
<td>• One Way ANOVA</td>
</tr>
<tr>
<td></td>
<td>• Measurement Systems analyses</td>
</tr>
<tr>
<td></td>
<td>• Multiple Linear Regression</td>
</tr>
<tr>
<td>RGA</td>
<td>• Synthesis Workbooks</td>
</tr>
<tr>
<td></td>
<td>• Growth Data analyses</td>
</tr>
</tbody>
</table>
# Data Sheets or Diagrams

To publish an analysis summary from Weibull++/ALTA, RGA or BlockSim/RENO, open the data sheet or diagram and click **Publish SEP Summary** on the Publishing page of the control panel. (For DOE design folios, the "Data" tab with analyzed response data must be selected.)

---

**Note:** If you have published analysis summaries and you get a "Link is not properly formatted" message when you open the original analysis (e.g., "Open in Weibull++"), the link may be corrupted or is using old encryption. Republish the analysis to refresh the link.
For data sheets, this displays a preview of the spreadsheet summary. Click **Publish SEP Summary** again to complete the process.

After publishing, the panel displays "Synchronized" if the web version reflects the latest results from the analysis. If the analysis has been modified (e.g., if more data has been added, an analysis setting has changed, etc.), it displays "Out of Sync" and you will need to recalculate and republish to update the website.

To remove the summary from the website, click **Remove SEP Summary**.

**Synthesis Workbooks**

To publish a **Synthesis Workbook** from Weibull++/ALTA, RGA or BlockSim/RENO, open the module in the workbook that you want to share (spreadsheet or word processing document), then click **Home > SEP > Publish Report**.

The status bar indicates that the spreadsheet or document is visible via the SEP website, and when the web version was last updated.

If you subsequently make a change in the desktop application, you will need to republish to update the website.

If you want to remove the report from the website, open the module and click **Home > SEP > Remove Report**.

**Prediction Reports and Plots**

To publish a report or plot from Lambda Predict, select any standard item or block in the prediction folio and choose **Prediction Tools > Share > Publish SEP Summary** (or click the icon on the **Publishing** tab of the Properties panel).

Then use the Select Report window to build the report and click **OK**. (See Lambda Predict Reports in the Lambda Predict documentation.)
You can publish multiple reports from the same prediction folio, but only one report for each standard item/block. For example, the following picture shows two reports published from the same folio. If you later republish from the same standard item/block, the new report will replace what was previously published.

**Xfmea/RCM++/RBI Reports**

To publish a report generated in Xfmea/RCM++/RBI, use the Reports window to build the document, select at least one of the **Save/Publish** file formats on the ribbon (Word, Excel, or PDF) and click **Generate Report**.

To see all of the generated report documents that have been saved with the project (and therefore will be visible via SEP), click **Published Reports Manager**. You can also use the manager to edit the name and description that will show in the website.

For more information, see **Save/Publish Reports** in the Xfmea/RCM++/RBI documentation.

**Dashboards and Reports in SEP**

Dashboards and Synthesis Workbook reports are available throughout the [Synthesis Enterprise Portal (SEP) website](http://xfmea.reliasoft.com) when you view different types of data.

For example, when you view a particular project plan in the website, you can select to view the latest information from the plan in any of the **dashboard layouts** that are currently available for that type of data.

Likewise, when you review the Weibull++/ALTA, RGA or BlockSim/RENO analyses for a particular project, you can see any **Synthesis Workbook reports** (spreadsheets or documents) that were published to the website.
Save, Copy or E-mail the URL

When you view a dashboard or Synthesis Workbook in the SEP website, the link for the web page (URL) includes the identifiers required to open the same report again later if the data/report is still visible in SEP and the user has permission to view the data.

- For dashboards, this will display the latest data from the analysis using the latest version of the predefined layout.
- For Synthesis Workbooks, this will display the latest published version of the report.

You can use the Save URL, Copy URL and E-mail URL links at the top of the web page, or copy/paste the URL from the browser’s address bar.

Save URL   Copy URL   E-mail URL

Watch This Report

Redesigned in Version 11, the "Watch This Report" feature makes it easier to manage the specific dashboards and reports you want to be able to access quickly via the SEP website.

What’s Changed? This replaces the "Share" feature that was used in SEP 10. If you upgrade a Version 10 database, any dashboards and reports that were "shared" with you in Version 10 will be "watched" by you in Version 11.

To watch a report, navigate to it in the website and click the Watch button or link, then enter the name and description that will show in your personalized list of "My Dashboards & Reports."

![Watch This Report Form]

Watch This Report

Name

Widget Project Plan - Actions

Short Description

Track the status of actions assigned in the Widget project plan.

Save
Chapter 32: Synthesis Enterprise Portal

If you have an XFRACAS website that is linked to the SEP, the sites will automatically create a watch in SEP for any charts or reports that you are watching in XFRACAS. If you delete or rename the SEP watch, this will not change the original watch in XFRACAS.

Click Reports in the SEP menu to see the list of dashboards and reports you are currently watching in SEP. You can filter by name/description, project or report type.

If you want to change the sort order, first clear all the filters and then click to drag and drop the reports into the desired position.

The first 5 reports will show in your personalized SEP home page (unless you have chosen to hide the "My Dashboards & Reports" panel).

SEP and XFRACAS
ReliaSoft's XFRACAS is a highly configurable web-based failure reporting, analysis and corrective action system (FRACAS) with integrated capabilities for part tracking, root cause analysis and team-based problem resolution.

If your organization implements both the SEP and XFRACAS websites for the same enterprise repository, the SEP can include links to XFRACAS records that are of interest to the user.

Configure Links Between Websites
In order to enable links between SEP and XFRACAS, a user with administrative permissions in XFRACAS must specify the paths that will be used in URLs for each website. (See How to Implement the SEP.)

When these preferences are set, SEP's menu will include a link to XFRACAS, and XFRACAS's ribbon will include an icon for SEP.
XFRACAS Reports and Charts
The "watch" feature in XFRACAS provides a quick and convenient way to access the XFRACAS reports and charts that you use most often (e.g., incident count by responsible part, all open incidents for a particular system, etc.).

When the websites are linked, these XFRACAS reports and charts will be automatically added to the list of dashboards and reports that you are watching in SEP. If you later decide to modify or delete the duplicate watch in SEP, this will not affect your settings in XFRACAS. (See Dashboards and Reports in SEP.)

XFRACAS Actions
The actions in XFRACAS (called "XFRACAS actions") are managed separately from the actions in Synthesis desktop applications and SEP (called "Synthesis actions"). The SEP always shows the Synthesis actions that are relevant to a particular user and project (see Managing Actions in SEP.)

If you also want to see your XFRACAS actions in SEP, choose to show the "XFRACAS Actions" panel in the SEP home page. (See Customizing the SEP Home Page.)

The SEP panel shows the same XFRACAS actions that you have chosen to display under Uncompleted Actions in your XFRACAS portal. (See XFRACAS Portal in the XFRACAS documentation.)

Tip: You can also choose to show Synthesis actions in your XFRACAS Portal, if desired. Open the My Portal Preferences page in XFRACAS and configure the Display My Open Synthesis Actions option.

XFRACAS Incidents
If you want to see XFRACAS incidents in SEP, choose to show the "XFRACAS Incidents" panel in the SEP home page.

The SEP panel shows the same XFRACAS incidents that you have choose to display under Display My Unclosed Incidents in your XFRACAS Portal.

Quick Links in SEP
The Quick Links feature allows you to create your own personalized list of links within the Synthesis Enterprise Portal (SEP) website. In Version 11, these links are now visible in the SEP menu.
Chapter 32: Synthesis Enterprise Portal

**Link to a Page in SEP**
To create a link to a page in the SEP website (e.g., for quick access to a particular project summary, FMEA system hierarchy, assigned action, etc.), navigate to the page and then click the **Save URL** link at the top-right corner of the page. You will be prompted to specify the name that will show in your list of quick links.

**Link to an External Website**
To create a link to an external website (e.g., a company intranet, document management system, etc.), click the **Quick Links** heading or icon in the SEP menu to open the My Quick Links page.

Use the **Add New Link** section to specify the name and URL.

**Note:** When entering a URL link, this can only be to a web address. It cannot be to a network share path.

**Move, Rename or Remove a Link**
To move a link, change the name that shows in the menu or remove a link, click the **Quick Links** heading or icon in the SEP menu to open the My Quick Links page.

In the **Manage Current Links** section, you can change where the link displays, edit the link name or delete the link. For online links, you can also edit the URL.
SEP User Preferences
The User Preferences page in the Synthesis Enterprise Portal (SEP) allows you to manage your own personal preferences for the website.

Click your name in the top-right corner of the website to open the page.

Change interface language
Use the drop-down list to choose any of the languages that are available for Synthesis desktop applications.

This will update the interface labels, but the data and configurable settings that have been entered by users will remain in the original language. For example, this includes (but is not limited to):

- Names, descriptions, identifiers and remarks that are entered by users
- Action property labels that are configurable within each project
- Published analysis summaries and reports
- System hierarchies and FMEA data
- Etc.
When starting the SEP always load
This setting determines which project will be displayed first for SEP features that show information from a particular project (e.g., project plan, project summary or creating a new action). You can choose:

- The last project used in any Synthesis application
- The last project set/used in the SEP web interface

You can use the **Change Project** button and "My Projects" feature at any time to change the project that is currently active in SEP.

Select actions to list on the home page
This setting allows you to choose which of the actions that may be relevant to you will be shown in the "My Actions" panel on the home page. (Note that if you’re also using Synthesis desktop applications, your preferences for the **Actions page of My Portal** will be managed separately.)

- **I need to review/approve**
  - You are assigned in the **Reviewer** field.

- **I am responsible for**
  - You are assigned in the **Person Responsible** field.

- **I am a team member in**
  - You belong to the team assigned in the **Team** field.

- **I am monitoring**
  - You are assigned in the Action Monitors window, or you have personally subscribed to “watch” the action.

- **Other actions I created**
  - You are listed in the **Created By** field and none of the other roles apply.

Receive automated alerts
These are the same options that you can set from the User Login and Contact Information window in a Synthesis desktop application. (See **Watches and Alerts**.)

Note that alerts via e-mail and SMS text are available only if a valid SMTP server has been defined for the database and your user account has an e-mail address/SMS contact defined. (See **Enable Alerts via E-mail or SMS**.)
Number of decimals for metrics in SEP
This preference determines how many decimal places will be used in the metric element on SEP web pages. If you are also using Synthesis desktop applications, this may be different than your preference in the Application Setup (File > Application Setup).
End User License Agreement

Click Wrap Agreement at time of product installation

BY INSTALLING THIS SOFTWARE OR BY CLICKING THE “I ACCEPT” BUTTON AND ACCEPTING THIS LICENSE IN ACCORDANCE WITH SOFTWARE INSTALLATION AND LICENSE ACCEPTANCE PROCEDURE YOU AGREE TO THE TERMS OF THIS LICENSE WHICH WILL BIND YOU, THE COMPANY ON WHO’S BEHALF YOU ARE ENTERING INTO THIS LICENSE AGREEMENT, AND ITS EMPLOYEES, AS APPLICABLE.

THIS LICENSE AGREEMENT IS A LEGAL AGREEMENT BETWEEN HBM UNITED KINGDOM LTD A COMPANY INCORPORATED IN UNITED KINGDOM WHOSE REGISTERED NUMBER IS 1589921 AND WHOSE REGISTERED OFFICE IS AT TECHNOLOGY CENTRE, ADVANCED MANUFACTURING PARK, BRUNEL WAY, CATCLIFFE, ROTHERHAM S60 5WG (THE ‘LICENSOR’) AND THE END USER LICENSEE OR ITS REPRESENTATIVE/AGENT AUTHORISED TO BIND THE END USER LICENSEE (‘YOU’).

PLEASE READ THIS CAREFULLY BEFORE USING THE SOFTWARE PRODUCTS

A: BACKGROUND

THIS LICENSE AGREEMENT SHALL BE BETWEEN YOU AND THE LICENSOR REGARDLESS OF WHETHER YOU HAVE PURCHASED THE SOFTWARE PRODUCTS DIRECTLY FROM THE LICENSOR OR AN AUTHORISED RESELLER AS SET OUT BELOW.

THE LICENSOR APPOINTS EXPERIENCED PROVIDERS OF SOFTWARE RESALE SERVICES WHO DISTRIBUTE THE SOFTWARE PRODUCTS TO END USERS (‘AUTHORISED RESELLER’). IF YOU HAVE PURCHASED THE SOFTWARE PRODUCTS AND ANY ASSOCIATED SUPPORT AND MAINTENANCE SERVICES FROM AN AUTHORISED RESELLER, SUCH PRODUCTS AND SERVICES WILL BE PROVIDED DIRECTLY TO YOU BY THE RELEVANT AUTHORISED RESELLER AND ALL PAYMENTS SHALL BE MADE TO THE AUTHORISED RESELLER ON THE AUTHORISED RESELLER’S TERMS AND PRICES.

IF YOU HAVE PURCHASED THE SOFTWARE PRODUCT AND SUPPORT AND MAINTENANCE SERVICES DIRECTLY FROM THE LICENSOR, SUCH SUPPORT AND MAINTENANCE SERVICES WILL BE DEALT WITH IN A SEPARATE AGREEMENT BETWEEN YOU AND THE LICENSOR AND ALL PAYMENTS WILL BE MADE TO THE LICENSOR AND GOVERNED BY THE LICENSOR’S TERMS OF SALE.

B: PROPERTY OF LICENSOR

THE LICENSOR, OR, WHERE APPLICABLE, THE RELEVANT MEMBER OF THE LICENSOR’S CORPORATE GROUP, IS THE ENTIRE LEGAL AND BENEFICIAL OWNER OF CERTAIN SOFTWARE PRODUCT(S) (‘THE SOFTWARE PRODUCT’) AS SET OUT IN THE QUOTATION OF INFORMATION, WHICH SHALL ALSO INCLUDE YOUR LICENSE KEY, SENT TO YOU BY EMAIL EITHER BY THE LICENSOR OR, IF YOU HAVE PURCHASED THE SOFTWARE PRODUCTS FROM AN AUTHORISED RESELLER, BY THE AUTHORISED RESELLER (‘QUOTATION’). THE LICENSOR IS WILLING TO GRANT YOU A LICENSE TO USE THE SOFTWARE PRODUCT ONLY IF YOU ACCEPT ALL THE TERMS AND CONDITIONS SET OUT BELOW.

C: LICENSE TO BE GRANTED

THE LICENSOR IS PROPOSING TO GRANT YOU ONE OF THE FOUR FORMS OF LICENSE IN RESPECT OF THE SOFTWARE PRODUCT. DETAILS OF EACH FORM OF LICENSE ARE SET OUT IN CLAUSES 2.1 AND 3 BELOW. THE FORM OF LICENSE THAT IS PROPOSED TO BE

D: LICENSE ACCEPTANCE PROCEDURE

BY CLICKING ON THE ACCEPTANCE BUTTON WHICH FOLLOWS THIS LICENSE AGREEMENT (MARKED 'DO YOU ACCEPT THESE TERMS AND CONDITIONS?'), YOU INDICATE ACCEPTANCE OF THIS LICENSE AGREEMENT AND THE LIMITED WARRANTY AND LIMITATION OF LIABILITY SET OUT IN THIS LICENSE AGREEMENT. SUCH ACCEPTANCE IS ON YOUR OWN BEHALF, IF YOU ARE AN INDIVIDUAL AND ON BEHALF OF ANY CORPORATE ENTITY WHICH EMPLOYS YOU OR WHICH YOU REPRESENT ('CORPORATE LICENSEE') IN ENTERING INTO THIS LICENSE AND YOU WARRANT THAT YOU HAVE THE NECESSARY AUTHORITY TO BIND THE CORPORATE ENTITY IN THIS RESPECT OR THAT THE AUTHORISED REPRESENTATIVES OF THE CORPORATE ENTITY ARE AWARE OF YOUR ACCEPTANCE OF THIS AGREEMENT ON ITS BEHALF. IN THIS LICENSE AGREEMENT, ‘YOU’ REFERS TO THE LICENSEE, ANY SUCH CORPORATE LICENSEE, OR BOTH, AS A COMMON SENSE INTERPRETATION OF THE RELEVANT SECTION DICTATES.

E: LICENSE REJECTION PROCEDURE

IF YOU DO NOT ACCEPT THESE TERMS AND CONDITIONS, YOU SHOULD CLICK ON THE “I DO NOT ACCEPT” BUTTON, DELETE THE SOFTWARE PRODUCTS FROM YOUR COMPUTER AND PROMPTLY (AND IN ANY EVENT, WITHIN 14 DAYS OF RECEIPT) RETURN TO THE RESELLER (A) ANY MEDIA; AND (B) ANY OTHER ITEMS PROVIDED, THAT ARE PART OF THIS PRODUCT.

F: OTHER AGREEMENTS

IF THE LICENSOR HAS EXPRESSLY AGREED WITH YOU IN WRITING THAT YOUR USE OF THE SOFTWARE PRODUCTS IS GOVERNED BY A PRIOR EXECUTED LICENSE AGREEMENT WITH THE LICENSOR, SUCH AGREEMENT SHALL APPLY INSTEAD OF THE FOLLOWING TERMS AND CONDITIONS TO THE EXTENT THAT THEY CONFLICT.

YOU SHOULD PRINT A COPY OF THIS LICENSE AGREEMENT FOR FUTURE REFERENCE.

LICENSE AGREEMENT

1. Ownership of Software Products and Copies

1.1 The Software Products and any printed materials or electronic documentation accompanying the Software Products (‘Documentation’) are copyrighted works of authorship, and are also protected under applicable database laws. The Licensor, or, where applicable, the relevant member of the Licensor’s corporate group, retains ownership of the Software Products and all subsequent copies of the Software Products, regardless of the form in which the copies may exist. This License Agreement is not a sale of the original Software Products or any copies.

2. Commercial License

2.1 In consideration of you agreeing to abide by the terms of this License Agreement and payment of the applicable license fees either to the Licensor or, if you have purchased the Software Products from an Authorised Reseller, to the Authorised Reseller (as specified in the Quotation), the Licensor hereby grants to you a personal, non-exclusive, and (unless expressly agreed otherwise by the Licensor in accordance with
clause 5.1) non-transferable license to use the Software Products and the Documentation on the terms of this License Agreement. The license shall take one of the following forms, (and shall be set out in the Quotation):

(a) **Annual License:**
   (i) **Duration** – this License shall continue for a period of 12 months (‘Initial Period’) from the date of delivery of the Quotation (‘the Delivery Date’) and, provided that you have paid all applicable renewal fees, from year to year thereafter unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.
   
   (ii) **Termination** – you must give the Licensor 90 day’s written notice prior to the anniversary of the Delivery Date, such notice not to expire before such anniversary date.

(b) **Paid Up License:**
   (i) **Duration** – this License shall continue for a period of 25 years from the Delivery Date unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.
   
   (ii) **Conversion** - this License may be converted to a CDS (this may include CRS and CDRS which are specific variations of CDS and collectively known as CDS) License, upon application to either the Licensor or the Authorised Reseller (if you have purchased the Software Products from an Authorised Reseller), and payment of an additional fee to the Licensor or the Authorised Reseller (as applicable), which shall be additional to the fees paid or payable in respect of any maintenance and support services provided by either the Licensor or the Authorised Reseller (if you have purchased the Software Products from an Authorised Reseller). You may reverse this conversion to the same terms as agreed in the Paid Up License at the anniversary of the conversion by giving the Licensor 90 days written notice prior to the anniversary of the Delivery Date, such notice not to expire before the anniversary of the Delivery Date.

(c) **CDS/CRS/CDRS License:**
   (i) **Access** – subject to the terms and conditions of this License Agreement, you may access any of the Software Products in the Quotation at any one time and in any combination up to the number of subscriptions granting you access to the Software Products for simultaneous use by you and purchased by you pursuant to this Agreement (‘Access Credits’). In the event the number of Access Credits reaches the number of Access Credits duly paid for by you (‘Access Limit’), you may add additional Access Credits (or, alternatively, at any time during the Term) which shall be charged in accordance with either the Licensor’s prices or the Authorised Reseller’s prices (if you have purchased the Software Products from an Authorised Reseller). Such increase in Access Credits shall apply to the following 12 month period, unless you give the Licensor or the Authorised Reseller (as applicable) written notice at least 90 days in advance of the expiry of the Initial Period, that you do not wish to sustain such increase in Access Credits. You may opt to reduce the number of Access Credits with 90 days written notice in advance of the 12 month period following from the anniversary of the Delivery Date, provided that the total number of Access Credits does not fall below the minimum threshold set by the Licensor or the Authorised Reseller (as applicable) or below the initial number of Access Credits calculated at the time of conversion of any Paid Up License.
   
   (ii) **Duration** - this License shall continue for the Initial Period and, provided that you have paid for the applicable Access Credits, from year to year thereafter unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.
   
   (iii) **Reporting** – in order to serve our customers better, the Licensor needs to be able to understand how its customers use the CDS system. As a condition of your continued access to the system, you are asked to provide to the Licensor on a quarterly basis, the CDS log file. You will be provided with easy-to-follow instructions on how to do this.
(iv) Termination – you must give the Licensor 90 days written notice in advance of the expiry of the Initial Period of your intention to discontinue the CDS License, such notice not to expire before the anniversary of the Delivery Date, and you must have submitted all reports required of you in clause 2.1(c)(iii) above. Failure to provide such notice and reports will mean that the license shall automatically continue on the same terms until terminated in accordance with this clause.

2.2 As an end user licensee of the Software Products, you may, subject to the following conditions and any conditions specified in the Quotation:

(a) use and copy the Software Products only for use on any computer system that is detailed in the release notes of the respective Software Product and which is licensed, leased and/or controlled by you (the Corporate Licensee) or any member of your corporate group, which expression includes the Corporate Licensee's majority-owned subsidiaries, any parent company having a majority-owned interest in the Corporate Licensee, and such parent's majority-owned subsidiaries;

(b) load the Software Products into and use it only on computers at the locations specified in the Quotation and which are under your control;

(c) copy the Software Products only for back-up and archival purposes and make up to three copies of the Documentation, provided that the original and each copy is kept in your possession and that your installation and use of the Software Products does not exceed any restrictions contained in the Quotation.

3. Demonstration License

3.1 If the Licensor has provided you with the Software Products free of charge for evaluation purposes, this clause 3 shall apply to your use of the Software Products.

3.2 You may use the Software Product on a computer solely for the purposes of evaluating the Software Product.

3.3 The Software Product is provided to you free of charge and on an “AS IS” basis, without any technical support or warranty of any kind from us including, without limitation, a warranty of satisfactory quality, fitness for purpose and non-infringement.

3.4 This License shall continue for a period of 30 days from the Delivery Date unless terminated in accordance with any provision of clause 10 below or any other applicable clause of this License Agreement or until such License is converted into an Annual License, Paid Up License or CDS License, if earlier.

3.5 As part of the Licensor’s testing and evaluation of the Software Products, you shall share with the Licensor the input and views received and any reports and analysis produced promptly upon receipt of such feedback.

3.6 Clauses 4, 5.1(a), 6.1(b), 6.1(f), 8.1, 8.2, 8.5, 10.1(a) of this License Agreement shall not apply to a Demonstration License.

4. Delivery and Risk

4.1 The Software Products shall consist of one copy of the object code of the Software Products on machine-readable form only, on the disk, dongle or other media on which the Software Product is delivered as described in the Quotation (the “Media”). Risk in the Media shall pass to you on delivery. If any part of the Media shall thereafter be lost, damaged or destroyed, you must contact either the Licensor or the Authorised Reseller from whom you have purchased the Software Products who will arrange for a repair or replacement of such Media at a cost (if any) determined by the Licensor or the Authorised Reseller (as applicable).

5. License Restrictions

5.1 You may not nor permit others to:

(a) transfer the Software Products from one location to another, without the express written consent of the Licensor and provided such transfers do not exceed two in any twelve month period. It will be a condition of the grant of any such consent that the Software Products held on hard drives at the current location must be erased and you must enter into a new license agreement with the Licensor before a
Software Products license key is provided to you. The administration charge (currently US $1,500) will be payable by you in respect of such transfer. This charge is only applicable to end user licensees who do not have a support and maintenance services agreement with the Licensor or Authorised Reseller;

(b) exceed the number of concurrent users specified in the Quotation, if any;

(c) sub-license, sell, assign, rent, pledge, lease, transfer or otherwise dispose of the Software Products, on a temporary or permanent basis, without the prior written consent of the Licensor;

(d) translate, reverse engineer, decompile, disassemble, modify or create derivative works based on the Software Products except as permitted by law;

(e) make copies of the Software Products, in whole or part, except for back-up or archival purposes as permitted in this License Agreement;

(f) use any back-up copy of the Software Products for any purpose other than to replace the original copy in the event that it is destroyed or becomes defective;

(g) copy the Documentation (except as provided by this License Agreement);

(h) adapt, modify, delete or translate the Documentation in any way for any purpose whatsoever;

(i) vary, delete or obscure any notices of proprietary rights or any product identification or restrictions on or in the Software Products.

6. Undertakings

6.1 You undertake:

(a) to ensure that, prior to use of the Software Products by your employees or agents, all such parties are notified of this License and the terms of this License Agreement and that any such use as aforesaid is in accordance with the terms of this License Agreement;

(b) to replace the current version of the Software Product with any updated or upgraded version or new release provided by the Licensor or the Authorised Reseller (if applicable) under the terms of this License Agreement immediately on receipt of such version or release;

(c) to use the Software Products only as described in the Documentation and subject to the restrictions as set out in clause 5 (License Restrictions above);

(d) to reproduce and include the Licensor’s copyright notice (or such other party’s copyright notice as specified on the Software Products) on all and any copies of the Software Products, including any partial copies of the Software Products as permitted to be made under the terms of this License Agreement;

(e) to hold all drawings, specifications, data (including object and source codes), Software Products listings and all other information relating to the Software Products confidential and not at any time, during this License or after its expiry, disclose the same, whether directly or indirectly, to any third party without the Licensor’s consent, and

(f) to effect and maintain adequate security measures to safeguard the Software Product from access or use by any unauthorised person and indemnify the Licensor for losses flowing from your failure to do so.

7. Intellectual Property Rights

7.1 You acknowledge that all intellectual property rights in the Software Product and the Documentation throughout the world belong to the Licensor, that rights in the Software Product are licensed (not sold) to you, and that you have no rights in, or to, the Software Product or the Documentation other than the right to use them in accordance with the terms of this License Agreement.

7.2 You acknowledge that you have no right to have access to the Software Product in source code form or in unlocked coding or with comments.
The integrity of this Software Product is protected by technical protection measures ("TPM") so that the intellectual property rights, including copyright, in the software of the Licensor are not misappropriated. You must not attempt in any way to remove or circumvent any such TPM, nor to apply, manufacture for sale, hire, import, distribute, sell, nor let, offer, advertise or expose for sale or hire, nor have in your possession for private or commercial purposes, any means whose sole intended purpose is to facilitate the unauthorised removal or circumvention of such TPM.

8. **Limited Warranty**

8.1 Subject to the limitations and exclusions of liability below and providing the Software is used in accordance with the Documentation and on an operating system or computer for which it was designed, the Licensor warrants that (a) the Media on which the Software Products is furnished will be free from material defects under normal use for a period of 90 days from the date of delivery (the “Warranty Period”); and that (b) during the Warranty Period, the Software Product will, when properly used, perform substantially in accordance with the functions described in the Documentation; and (c) that the Documentation correctly describes the operation of the Software Product in all material respects.

8.2 If, within the Warranty Period, you notify the Licensor in writing of any defect or fault in the Software Product in consequence of which it fails to perform substantially in accordance with the Documentation, and such defect or fault does not result from you having amended the Software Product or used it in contravention of the terms of this License Agreement, the Licensor will, at its sole option, i) repair or replace the Software Product, provided that you make available all information that may be necessary to assist the Licensor in resolving the defect or fault, including sufficient information to enable the Licensor to recreate the defect or fault, or ii) terminate this License Agreement immediately by notice in writing to you and the Licensor will refund or if the Software Products have been purchased from an Authorised Reseller will procure that the Authorised Reseller shall refund; any of the fees paid as at the date of termination (less a reasonable sum in respect of your use of the Software Product to the date of termination) on return of the Software Product and all copies thereof. The Licensor’s obligation under this clause 8.2 is subject to your compliance with clause 6.1(b).

8.3 You acknowledge that the Software Product has not been developed to meet your individual requirements and that it is therefore your responsibility to ensure that the facilities and functions of the Software Product as described in the Documentation meet your requirements.

8.4 You acknowledge that the Software Product may not be free of bugs or errors and you agree that the existence of any minor errors shall not constitute a breach of this License Agreement.

8.5 The Licensor shall not be liable under the said warranty above if the Software Product fails to operate in accordance with the said warranty as a result of any modification, variation or addition to the Software Products not performed by the Licensor or caused by any abuse, corruption or incorrect use of the Software Products, including use of the Software Products with equipment or other software which is incompatible.

8.6 All other conditions, warranties or other terms which might have effect or be implied or incorporated into this License Agreement or any collateral contract, whether by statute, common law or otherwise, are hereby excluded, including, without limitation, the implied conditions, warranties or other terms as to satisfactory quality, fitness for purpose or the use of reasonable skill and care.

9. **Exclusion of Liability**

9.1 Nothing in this License Agreement shall limit or exclude the liability of either party for death or personal injury resulting from negligence, for fraud or for fraudulent misrepresentation.

9.2 Subject to clause 9.1, the Licensor shall have no liability for any losses or damages which may be suffered by you (or any person claiming under or through you), whether the same are suffered directly or indirectly or are immediate or consequential, and whether the same arise in contract, tort (including negligence) or otherwise howsoever, which fall within any of the following:

(a) loss of income;
(b) loss of business profits or contracts;
(c) business interruption;
(d) loss of the use of money or anticipated savings;
(e) loss of information;
(f) loss of opportunity, goodwill or reputation;
(g) loss of, damage to or corruption of data; or
(h) any indirect or consequential loss or damage of any kind howsoever arising and whether caused by tort
(including negligence), breach of contract or otherwise;

provided that this clause 9.2 shall not prevent claims for loss of or damage to your tangible property that fall
within the terms of clause 8 or a claim for a refund of the license fees paid to the Licensor or the Authorised
Reseller (as applicable) for the license of the Software Products.

9.3 Subject to clause 9.1 and clause 9.2, the Licensor's maximum aggregate liability under or in connection with
this License Agreement, or any collateral contract, whether in contract, tort (including negligence) or
otherwise, shall be limited to a sum equal to the fees paid by you to the Licensor or the Authorised Reseller
(as applicable) for the license of the Software Products.

9.4 Subject to clause 9.1, clause 9.2 and clause 9.3, the Licensor's liability for infringement of third party
intellectual property rights shall be limited to breaches of third party rights subsisting in the UK and USA.

9.5 This License Agreement sets out the full extent of the Licensor's obligations and liabilities in respect of the
supply of the Software Products and Documentation. In particular, there are no conditions, warranties,
representations or other terms, express or implied, that are binding on the Licensor except as specifically
stated in this License Agreement. Any condition, warranty, representation or other term concerning the
supply of the Software Products and Documentation which might otherwise be implied into, or incorporated
in, this License Agreement, or any collateral contract, whether by statute, common law or otherwise, is
hereby excluded to the fullest extent permitted by law.

10. Term and Termination

10.1 This License Agreement is effective for the period referred to clause 2.1 or until otherwise terminated in
accordance with that clause. The Licensor may terminate this License Agreement immediately by written
notice to you if:

(a) save in respect of a Paid Up License, if you purchase the Software Products directly from the Licensor,
you fail to pay any renewal or other fees due by you to the Licensor in respect of this License
Agreement;

(b) you fail to comply with any provisions of this License Agreement;

(c) you commit a material or persistent breach of this License Agreement which you fail to remedy (if
remediable) within 14 days after the service on you of written notice requiring you to do so; or

(d) a petition for a bankruptcy order to be made against you has been presented to the court; or

(e) where you, as the Corporate Licensee, become insolvent or unable to pay its (the company’s) debts,
enters into liquidation, whether voluntary or compulsory (other than for reasons of bona fide
amalgamation or reconstruction), passes a resolution for its winding-up, has a receiver or administrator
manager, trustee, liquidator or similar officer appointed over the whole or any part of its assets, makes
any composition or arrangement with its creditors or takes or suffers any similar action in consequence
of its debt, or becomes unable to pay its debts or ceases to trade.

10.2 In the event of termination in accordance with clause 10.1 you must immediately pay to the Licensor any
sums due to the Licensor under the License Agreement and (at the Licensor’s sole option) you must return,
deroy or delete all copies of the Software Products from all storage media in your control and, in the case of
destruction, certify to us that you have done so.
11. **Export**

11.1 You will comply with all applicable laws, rules, and regulations governing export of goods and information, including the laws of the countries in which the Software Products was created. In particular, you will not export or re-export, directly or indirectly, separately or as a part of a system, the Software Products or other information relating thereto to any country for which an export license or other approval is required, without first obtaining such license or other approval.

12. **General**

12.1 You agree that the Licensor shall have the right, after supplying undertakings as to confidentiality, to audit any computer system on which the Software Products are installed in order to verify compliance with this License Agreement.

12.2 You agree that the Licensor may use your company name in Licensor’s customer lists and other promotional materials describing your company as a customer or user of Licensor’s software or services, as applicable, unless it receives written notice from you objecting to such use.

12.3 This License Agreement, its subject matter or its formation (including non-contractual disputes or claims) shall be governed by and construed in accordance with English law and submitted to the non-exclusive jurisdiction of the English courts.

12.4 This License Agreement constitutes the complete and exclusive statement of the agreement between the Licensor and you with respect to the subject matter of this License and supersedes all proposals, representations, understandings and prior agreements, whether oral or written, and all other communications between us relating to that subject matter except for those expressly referred to in this License Agreement.

12.5 Any clause in this License Agreement that is found to be invalid or unenforceable shall be deemed deleted and the remainder of this License Agreement shall not be affected by that deletion.

12.6 Failure or neglect by either party to exercise any of its rights or remedies under this License Agreement will not be construed as a waiver of that party’s rights nor in any way affect the validity of the whole or part of this License Agreement nor prejudice that party’s right to take subsequent action.

12.7 This License Agreement is personal to you and you may not assign, transfer, sub-contract or otherwise part with this License or any right or obligation under it without the Licensor’s prior written consent.