This license agreement ("License Agreement") sets forth the terms and conditions that govern the distribution and use of the HBM UK Ltd software documentation (the "HBM Software Documentation"), including any and all derivative works. Any unauthorized distribution or use of the HBM Software Documentation is strictly prohibited.

Licensee hereby acknowledges and agrees to the following terms and conditions of this License Agreement for its use of the HBM Software Documentation:

HBM UK Ltd grants the Licensee who accepts and abides by the terms of this License Agreement a non-exclusive, non-transferable, royalty-free, and revocable license to the HBM Software Documentation. Unless otherwise indicated, all HBM Software Documentation are copyrighted and owned by HBM UK Ltd and are the property of HBM UK Ltd. They are licensed to you and for your use only as an individual who has purchased the software ("Licensee"). Notwithstanding this License Agreement, the Licensee shall not have a license to the trademarks, logos, or any other intellectual property of HBM UK Ltd and/or its affiliates or Licenseor(s).

Licensee may print a single copy of the HBM Software Documentation for his/her reference. Licensee may reprint the HBM Software Documentation, as needed, if the original printed copy is damaged and/or destroyed.

Except as provided above, no part of the HBM Software Documentation, either text or image, may be used for any purpose other than Licensee’s own personal use and reference as a learning aid. Therefore, the reproduction, modification, creation of derivative works, storage in a retrieval system, or retransmission, in any form or by any means, electronic, mechanical or otherwise, for reasons other than Licensee’s personal use, is strictly prohibited.

Certain photos and images in the HBM Software Documentation are used under non-transferable licenses obtained by HBM UK Ltd and/or its affiliates and are owned by its Licenseor(s) ("Licenseor"). Images depicting photos of actual persons are licensed to HBM UK Ltd and/or its affiliates and the signed model releases for these images are on file with the Licenseor(s). HBM UK Ltd makes no copyright claims on these images. All ownership and intellectual property rights to the HBM Software Documentation are reserved by either HBM UK Ltd and/or its affiliates or its Licenseor(s).

DISCLAIMER: THE HBM SOFTWARE DOCUMENTATION IS PROVIDED “AS IS” WITHOUT WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO: 1) ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT OF INTELLECTUAL PROPERTY; 2) ANY WARRANTY THAT THE HBM COURSE MATERIALS WILL CONFORM TO SPECIFICATIONS; 3) ANY WARRANTY THAT THE WORK WILL BE ERROR FREE OR VIRUS FREE. IN NO EVENT SHALL HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSEOR(S) BE LIABLE FOR ANY DAMAGES, INCLUDING, BUT NOT LIMITED TO, DIRECT, INDIRECT, SPECIAL OR CONSEQUENTIAL DAMAGES, ARISING OUT OF, RESULTING FROM, OR IN ANY WAY CONNECTED WITH THE HBM SOFTWARE DOCUMENTATION, WHETHER OR NOT BASED UPON WARRANTY, CONTRACT, TORT, OR OTHERWISE, WHETHER OR NOT LOSS WAS SUSTAINED FROM, OR AROSE OUT OF THE RESULTS OF, OR USE OF, THE HBM SOFTWARE DOCUMENTATION. LICENSEE AGREES TO WAIVE ANY AND ALL CLAIMS AGAINST HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSEOR(S), AND SHALL INDEMNIFY, DEFEND AND HOLD HARMLESS HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSEOR(S) FOR ANY AND ALL LIABILITIES, CLAIMS, DEMANDS, DAMAGES, EXPENSES OR LOSSES THAT MAY ARISE FROM THE LICENSEE’S USE OR DISTRIBUTION OF THE HBM SOFTWARE DOCUMENTATION, INCLUDING ANY LIABILITIES OR DAMAGES FROM DERIVATIVE WORKS OR OTHER PRODUCTS BASED ON, OR RESULTING FROM, THE USE THEREOF.

This License Agreement is subject to change without notice and does not represent any commitment on the part of HBM UK Ltd and/or its affiliates to the Licensee, including any commitment to maintain or update the HBM Software Documentation. The names of companies, products, people, characters, and/or data mentioned in the HBM Software Documentation are not intended to represent any real individual, company, product or event, unless otherwise noted. Any rights not expressly granted herein are reserved for HBM UK Ltd.

TRADEMARKS:
ReliaSoft, Synthesis Platform, Weibull++, ALTA, DOE++, RGA, BlockSim, RENO, Lambda Predict, Xfmea, RCM++ and XFRACAS are all trademarks of ReliaSoft Corporation.

GlyphWorks, VibeSys, DesignLife and the nCode logos are all trademarks of HBM UK Ltd.

Other product names and services identified in the HBM Software Documentation are trademarks belonging to their respective trademark holders, and are used for illustration purposes. Their use in no way conveys an endorsement or other affiliation with HBM UK Ltd and/or its affiliates.
# Table of Contents

Chapter 1: Getting Started.............................................................................................................. 1

Technical Support .......................................................................................................................... 1
When Requesting Tech Support .......................................................................................... 1

Chapter 2: Administrative Ribbon Tabs....................................................................................... 3

System Tab .................................................................................................................................. 3
System ..................................................................................................................................... 3
Template ................................................................................................................................. 3
Serialized ................................................................................................................................. 3
Part .......................................................................................................................................... 3

Admin Tab ................................................................................................................................... 5
Configure................................................................................................................................. 5
Tools ........................................................................................................................................ 6
Users/User Groups .................................................................................................................. 7
Contacts/Companies/Locations .............................................................................................. 7
Preferences ............................................................................................................................. 8
Diagnostics .............................................................................................................................. 8
Resource Editor ....................................................................................................................... 8
Entities .................................................................................................................................... 8
Import ..................................................................................................................................... 9
Report Viewer ........................................................................................................................... 9

Chapter 3: Managing Users........................................................................................................... 11

Managing Users ....................................................................................................................... 11
Entities and Users ................................................................................................................. 11
User/License Counts ............................................................................................................. 11
Creating a New Account ....................................................................................................... 11
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Editing a User Account</td>
<td>12</td>
</tr>
<tr>
<td>Deleting a User Account</td>
<td>12</td>
</tr>
<tr>
<td>Retiring a User Account</td>
<td>12</td>
</tr>
<tr>
<td>System Wide Information</td>
<td>13</td>
</tr>
<tr>
<td>Entity-Specific Information</td>
<td>14</td>
</tr>
<tr>
<td>Adding Users from Active Directory</td>
<td>21</td>
</tr>
<tr>
<td>Using the Active Directory Page</td>
<td>22</td>
</tr>
<tr>
<td>Managing User Categories</td>
<td>22</td>
</tr>
<tr>
<td>Managing Security Groups</td>
<td>23</td>
</tr>
<tr>
<td>Creating a Security Group</td>
<td>24</td>
</tr>
<tr>
<td>Editing a Security Group</td>
<td>24</td>
</tr>
<tr>
<td>Deleting a Security Group</td>
<td>24</td>
</tr>
<tr>
<td>Group Membership</td>
<td>24</td>
</tr>
<tr>
<td>Managing User Groups</td>
<td>25</td>
</tr>
<tr>
<td>Creating a Group</td>
<td>25</td>
</tr>
<tr>
<td>Assigning Members to a Group</td>
<td>25</td>
</tr>
<tr>
<td>Deleting a Group</td>
<td>26</td>
</tr>
<tr>
<td>Managing Applicants</td>
<td>26</td>
</tr>
<tr>
<td>Granting Access</td>
<td>26</td>
</tr>
<tr>
<td>Removing an Applicant</td>
<td>27</td>
</tr>
<tr>
<td>Chapter 4: Managing Parts and Systems</td>
<td>29</td>
</tr>
<tr>
<td>Managing System Templates</td>
<td>29</td>
</tr>
<tr>
<td>View an Existing Template</td>
<td>29</td>
</tr>
<tr>
<td>Hierarchy and Part Properties</td>
<td>30</td>
</tr>
<tr>
<td>Edit an Existing Part</td>
<td>30</td>
</tr>
<tr>
<td>Create or Associate Parts</td>
<td>30</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Adding, Editing or Deleting List Options</td>
<td>92</td>
</tr>
<tr>
<td>Editing Option Properties</td>
<td>93</td>
</tr>
<tr>
<td>Standard Lists</td>
<td>93</td>
</tr>
<tr>
<td>Managing Action Fields and Categories</td>
<td>95</td>
</tr>
<tr>
<td>Hide or Display Actions Fields</td>
<td>95</td>
</tr>
<tr>
<td>Manage the Action Categories</td>
<td>95</td>
</tr>
<tr>
<td>Chapter 7: Managing Customers</td>
<td>97</td>
</tr>
<tr>
<td>Managing Contacts</td>
<td>97</td>
</tr>
<tr>
<td>Using Contacts in CSIs, Incidents and Other Records</td>
<td>97</td>
</tr>
<tr>
<td>Creating, Editing and Deleting a Contact</td>
<td>97</td>
</tr>
<tr>
<td>Contact Properties</td>
<td>98</td>
</tr>
<tr>
<td>Managing Companies</td>
<td>98</td>
</tr>
<tr>
<td>Using Companies in CSIs and Other Records</td>
<td>99</td>
</tr>
<tr>
<td>Creating, Editing and Deleting a Company</td>
<td>99</td>
</tr>
<tr>
<td>Company Properties</td>
<td>99</td>
</tr>
<tr>
<td>Managing Locations</td>
<td>100</td>
</tr>
<tr>
<td>Using Locations in Companies and Other Records</td>
<td>101</td>
</tr>
<tr>
<td>Creating, Editing and Deleting a Location</td>
<td>101</td>
</tr>
<tr>
<td>Location Properties</td>
<td>102</td>
</tr>
<tr>
<td>Chapter 8: Managing Entities</td>
<td>103</td>
</tr>
<tr>
<td>Adding or Editing an Entity</td>
<td>103</td>
</tr>
<tr>
<td>Entity Properties</td>
<td>103</td>
</tr>
<tr>
<td>Duplication Settings</td>
<td>104</td>
</tr>
<tr>
<td>Chapter 9: Administrator Reports</td>
<td>107</td>
</tr>
<tr>
<td>Report Viewer</td>
<td>107</td>
</tr>
<tr>
<td>Administrator Reports</td>
<td>108</td>
</tr>
</tbody>
</table>
Contents

Creating an Update Script ................................................................. 119
Chapter 1: Getting Started

ReliaSoft XFRACAS by HBM Prenscia is a highly configurable, web-based Failure Reporting, Analysis and Corrective Action System (FRACAS). Depending on how your implementation is configured, this can include incident/failure reporting, failure analysis on returned parts, part tracking for serialized systems, root cause analysis, team-based problem resolution and tracking the completion of assigned actions.

The website is highly configurable and the specific features, field names and behavior will depend on the settings for your implementation.

This guide covers features that are available only to users with administrative permissions, to help you configure XFRACAS to meet your organization's specific needs. You may also need to consult:

- **User Guide** - covers features that may be available to all XFRACAS users.
- **Implementation Guide** (*.pdf) - guidance for an IT admin to prepare the database and web server(s) and install the website, and for an application admin to complete the initial configuration.

XFRACAS can also be integrated with other ReliaSoft applications, which provides intelligent integration between reliability program activities and tools while simultaneously facilitating effective information sharing and cooperation between engineering teams of any size. Other ReliaSoft software by HBM Prenscia includes: Weibull++, RGA, BlockSim, RENO, Lambda Predict, XFMEA, RCM++, RBI, MPC, and Synthesis Enterprise Portal.

Technical Support

The configurable settings for your XFRACAS implementation will be set and maintained by user(s) with administrative permissions within XFRACAS. If you have questions about these settings, the About page displays the name and e-mail address for the primary admin contact for your implementation.

For organizations with an active maintenance agreement, we provide technical support for software-related issues via a network of regional offices and partners/distributors throughout the world. To get contact details for technical support worldwide, visit [http://www.reliasoft.com/about/contact-us](http://www.reliasoft.com/about/contact-us).

When Requesting Tech Support

When you contact us to request technical support, please be prepared to provide the following information:

- Your phone number and e-mail address.
Chapter 1: Getting Started

- The Build Version of your implementation (displayed on the About page).
- The name and version of your web browser.
- What you were doing when the problem occurred and exactly what happened. Please include the specific wording of any message(s) that appeared.

Note: Technical support representatives are not reliability consultants. Their assistance is limited to technical issues that you may encounter with the software tools.
Chapter 2: Administrative Ribbon Tabs

System Tab
In the navigation ribbon, the System tab will be visible if you have either of the following permissions: ManageSerialized Systems or Manage Template Systems.

System

- **Template** opens the Template page, which allows you to view and manage generic system configurations.

- **Serialized** opens the Serialized page, which allows you to view and manage the specific parts in a particular piece of equipment.

Template

- **Create Template** allows you to create a new system template.

- **Find Template** allows you to search for an existing system template by template part name or template part number.

- **XFMEA Import** allows you to import system hierarchy data from XFMEA, RCM++, or RBI into XFRACAS. This command appears only if the current database has associated Synthesis tables that you have permission to access and has at least one project with a system hierarchy. (See Importing Systems from XFMEA.)

Serialized

- **Create System** allows you to create a serialized system based on an existing system template.

- **Find System** allows you to search for an existing serialized system.

Part
When you are working with a template, the following commands will appear:

- **Create** allows you to create a new system part under the part currently selected in the system configuration.
Chapter 2: Administrative Ribbon Tabs

- **Edit** allows you to edit the information for the part currently selected in the system configuration.

- **Delete** removes the currently selected part from the system configuration, or retires it if it is used in records within the system.

- **Associate** allows you to select one or more existing template parts to associate below the part currently selected in the system configuration.

- **Disassociate** removes the currently selected part from the system configuration and makes it a top level part.

- **Assign Owner** allows you to specify the owners who is responsible for the selected part.

- **Remove Owner** removes the owner from the selected part and clears the e-mail notification list for the part. This command is available only for parts with owners.

- **CC List** allows you to specify addition users to be included in the e-mail notification list for the selected part. This command is available only for parts with owners.

- **Sync with XFMEA** synchronizes the data in XFRACAS to reflect changes made within XFMEA, RCM++ or RBI after the part has been imported. This command is available only when you are working with a part that was imported from a desktop application.

- **Remove XFMEA Association** removes the association of the part with XFMEA. This command is available only when you are working with a part that was imported from a desktop application.

- **Export** exports the currently selected part and any children to a new *.xml file. Depending upon your permissions, this command may have a drop-down list of options. In this case, choose **Part** to export the currently selected part and any children to a new *.xml file, or choose **Master BOM** to export the entire system configuration that the currently selected part belongs to, including all details associated with all parts.

When you are working with a serialized system, the following commands will appear:

- **Create Serialized** allows you to create a new serialized part under the part currently selected in the system configuration.
**Edit Serialized** allows you to edit the information for the serialized part currently selected in the system configuration.

**Delete Serialized** removes the currently selected serialized part from the system configuration, or retires it if it is used in records within the system.

**Add Non-Serialized** allows you to select one or more existing non-serialized parts to associate below the part currently selected in the system configuration.

**Add Existing Serialized** allows you to select an existing serialized part to associate below the part currently selected in the system configuration.

**Disassociate** removes the currently selected part from the serialized system configuration and makes it a top level part.

**Export** exports the currently selected part and any children to a new * .xml file. (See Exporting to XML.)

## Admin Tab

In the navigation ribbon, the Admin tab will be visible if you have the following permission: Access Admin Tab.

The available commands will depend on your permissions for individual features.

### Configure

**Security**

- **Users** opens the Users page, which allows you to add contact and permissions information for authorized XFRACAS users and edit the properties of existing user accounts.

- **Security Groups** opens the Security Groups page, which allows you to create and edit groups of users who have the same categories and permissions.

- **User Groups** opens the User Groups page, which allows you to create and manage predefined groups of users that can quickly be added to the team for an incident, problem or project.

- **Applicants** opens the Applicants page, which allows you to add users who have requested access to XFRACAS and to set their permissions.
Chapter 2: Administrative Ribbon Tabs

Active Directory opens the Active Directory page, which allows you to add users from Microsoft Active Directory.

Manage

Contacts opens the Contacts page, which allows you to view and maintain contacts.

Companies opens the Companies page, which allows you to view and maintain companies.

Locations opens the Locations page, which allows you to view and maintain locations.

Preferences opens the Preferences page, which allows you to maintain the preferences that control various aspects of XFRACAS.

Details opens the Details page, which allows you to manage some of the fields that appear in various record types.

Lists opens the Lists page, which allows you to maintain lists of available values for user interface fields that require selection from specified values.

User Categories opens the User Categories page, which allows you to maintain the categories that users can be assigned to. These categories can be used to filter drop-down lists of users (e.g., when assigning users to failure review boards).

Action Management opens the Action Management page, which allows you to maintain the action type categories that users can select from when they create actions.

Criticality opens the Criticality page, which allows you to maintain the criticality fields that may appear in the Incident and Problem pages.

Tools

Diagnostics opens the Diagnostics page, which provides an error log for the current entity.

Resource Editor opens the Resource Editor page, which allows you to manage the text that appears in the XFRACAS interface.
Entities opens the Entities page, which allows you to manage the entities that exist in XFRACAS.

Import opens the Data Import page, which allows you to manage the process of importing data from other sources via *.xml files.

Report Viewer opens the Report Viewer page, which allows you to control the display of the standard reports, chart reports, custom reports and administrator reports.

Users/User Groups
When you are creating a new user or user group, the following commands will appear:

Create saves the user/group once you have entered all required information.

Delete deletes the applicant from the request list. This command is available only when working on the Applicants page. There is no undo for delete.

When you are working with an existing record, the following commands will appear:

Save saves the current user/group. This command is available on the Users page and the User Groups page.

New clears the user/group information from the interface so that you can create a new one. The existing user/group is unaffected. This command is available on the Users page and the User Groups page.

Duplicate duplicates the current user so that you can easily create a new user who has similar properties. This command is available only on the Users page.

Export exports the current user to a new *.xml file. This command is available only on the Users page. If you want to export multiple users simultaneously, use the Admin > Import > Export command on the Data Import page.

Delete deletes the current user/group. This command is available on the Users page and the User Groups page. There is no undo for delete.

Contacts/Companies/Locations
When you are creating a new contact, company or location, the following command will appear:

Create saves the new record once you have entered all required information.
When you are working with an existing record, the following commands will appear:

- **Save** saves the current record.

- **New** clears the current record information from the interface so that you can create a new one. The existing record is unaffected.

- **Export** exports the current record to a new *.xml file. Alternatively, if you want to export multiple records simultaneously, use the Admin > Import > Export command on the Data Import page.

- **Delete** deletes the current record. *There is no undo for delete.*

### Preferences

- **Save** saves your changes to the preferences.

### Diagnostics

- **Excel** exports the Diagnostic error log to a new *.xlsx file.

- **Delete** removes the currently selected error(s) from the Diagnostic error log. *There is no undo for delete.*

### Resource Editor

- **Find** allows you to search for the resources in the current entity that you want to work with in the Resource Editor.

- **Replace** allows you to replace all occurrences of a text string in the current entity with new text.

- **Update Script** opens the Update Script utility, which allows you to specify a range of changes that you have made in the current database and implement those changes in another database.

- **Default All** returns all resources in the current entity to the default text.

### Entities

- **Edit** opens the Entity utility, which allows you to edit the entity that is currently selected in the Entities page.
**Create** opens the Entity utility, which allows you to add a new entity to the XFRACAS database.

### Import

- **Add** opens the Add Import File utility, which allows you to specify an *.xml file to import into XFRACAS.
- **Process** causes scheduled imports to be processed immediately, rather than waiting for a scheduled import. This command will appear only if you have certain permissions.
- **Export** allows you to specify one or more records to export to an *.xml file.

### Report Viewer

- **Save** saves your changes in the Report Viewer page.
Chapter 3: Managing Users

Managing Users
Use the Users page to manage accounts for XFRACAS users. Permissions required to access this page: Access Admin Tab and Manage Users.

To open the page, choose Admin > Configure > Security > Users.

Entities and Users
If your implementation has more than one entity, the login and contact details will be the same for all entities that are assigned to the user (System Wide Information), but the permissions and other details will be managed separately for each entity (Entity Specific Information).

The drop-down list at the top of the page determines which entity-specific information is currently displayed.

User/License Counts
- **Current Entity Users** - number of user accounts assigned to the current entity
- **Current System Users** and **Remaining User Licenses** - number of user accounts across all entities and the number of additional user accounts allowed by your license
- **Current Entities** and **Remaining Entity Licenses** - number of entities and the number of additional entities allowed by your license
- **Days Remaining** - number of days until the license expires

Creating a New Account
If the Select Name to Edit list is blank, simply enter the required fields and choose Admin > Users > Create.

If you need to clear an existing user's account information before creating a new one, choose Admin > Users > New.
Chapter 3: Managing Users

If you want to start with the settings from an existing account, select it from the list and then choose Admin > Users > Duplicate.

Editing a User Account
To edit an existing user account, choose the user name from the Select Name to Edit list. Make the desired changes and then choose Admin > Users > Save.

Remember that a user can have different permissions in each entity. If you change the permission for one entity, it will not change the permissions in the other entities that the user is assigned to.

Deleting a User Account
To delete an existing user account, choose the user name from the Select Name to Edit list and then choose Admin > Users > Delete.

You can delete a user account only if no records are associated with the account. If the user account is listed as an owner, author, team member or reviewer for any record or status, choosing Delete will instead retire the user account.

Retiring a User Account
A user can be retired from a particular entity or from the entire XFRACAS website. In both cases, you can configure the account to be retired automatically on a certain date and time, or you can manually retire the account.

To retire an account from the website (all entities), use the options in the System Wide Information area.

To retire an account from a particular entity, make sure the appropriate entity is selected and then use the options in the entity-specific area.
System Wide Information
These permissions will be the same for all entities that the user can access.

- For name and address, only the **First Name** and **Last Name** are required.

- The **Time Zone** is the offset from Coordinated Universal Time (formerly known as Greenwich Mean Time) that is appropriate for this user. The default setting is specified on the Preferences page ("Default GMT Offset for New Users").

  *Tip:* If you choose the "Local Time" option, XFRACAS will detect the current time zone offset on the client device and apply that (including the effect of daylight savings time). If you select a specific time zone, daylight savings will not be considered and you must change the setting twice a year.

- **Language** sets the user's preferred language for interface text. If this field is blank, the user will see the interface text in the default language for the entity, which is specified on the Preferences page ("XFRACAS - Language").

- **E-mail Address** is required. The following preferences can be configured to autopopulate the address based on first and last name (e.g., firstname.lastname@email_suffix.com).
  - Under Boolean Preferences: "Manage User - E-mail/Login Auto Build"
  - Under E-mail Preferences: "Manage User - E-mail Suffix Used for Auto Build"

- **Login** is required. If you are using Active Directory or Windows Authentication, this is typically in the format of 'domain\username'. If you are using SSO for authentication, it would be the SSO ID passed to the application. If you are unsure what to use, ask the user to try to access the website. If the account is not recognized, the login that you need to use will be displayed in single quotes in the Unknown User page.

  Note that if the "Manage User - E-mail/Login Auto Build" preference is enabled, the website will automatically start building the login based on the user's first and last names. You can edit or replace the text that's automatically populated, or change the preference at any time.

- The **Retired User Account** and **Account Expiration Date** options in this area will retire the account for entities and the user will have no access to the website. Alternatively, if you want to retire the account only for the current entity, use the options in the entity-specific area.

- The **Default Entity** is the entity that will be selected by default when the user visits the site. This field is not displayed until the user's account is created.
• **Entities** allows you to assign or remove the user’s access to the entities in which you have the "Manage Users" permission. Click the link to change the assignments. Note that:
  
  • This utility only shows entities in which you have permission to manage users. If the user has access to other entities, they will be visible in the default entity list.
  
  • You will not be able to remove access for the user's default entity, which is displayed in square brackets.
  
  • If you remove access to an entity, all entity-specific information will be deleted. If you later add the entity back to the user’s account, you will need to re-assign groups, categories and permissions.

**Entity-Specific Information**

These settings and permissions apply only to the entity that is currently selected.

  • The **Retired User Account** and **Account Expiration Date** options in this area will retire the account only for the entity that is currently selected. Alternatively, if you want to retire the account for the entire website, use the options in the system-wide area.

  • **Security Groups** are the security group(s) that the user has been assigned to for the current entity. Each security group has certain permissions associated with it, which are managed on the [Security Groups page](http://xfracas.reliasoft.com).

**Categories**

These permissions specify which user categories, if any, the user belongs to. The available categories for each entity are managed on the [User Categories page](http://xfracas.reliasoft.com).

**Permissions**

  • **CSI – View Customer Support**: The user can view the Customer Support page.

  • **Creating Records**: These permissions enable the user to create specific record types:
    
    • **CSI – Create CSIs** (make sure the **CSI - View Customer Support** permission is also enabled)
    
    • **Incident – Create Incident Reports**
    
    • **Problem – Create Problems**
    
    • **Project – Create Projects**

  • **Editing and Re-opening Records**: The owner of an action, incident, problem or project will be able to edit the record when it is open. The owner of the parent record (incident, problem or project) can also edit open actions associated with that record. In addition:
• These permissions enable the user to edit all open incidents or problems.
  - Incident - Edit All Open Incidents
  - Problem - Edit All Open Problems

• These permissions enable the user to edit open incidents, problems or projects if the user belongs to the team.
  - Incident - Team Edit
  - Problem - Team Edit
  - Project - Team Edit

• These permissions allow the user to open a closed action, incident, problem or project if the user had permission to edit the record when it was open.
  - Action - Open a Closed Action
  - Incident - Open a Closed Incident
  - Problem - Open a Closed Problem
  - Project - Open a Closed Project

• These permissions allow the user to edit all open incidents, problems or projects, and also re-open records that are closed.
  - Incident - Edit All Incidents
  - Problem - Edit All Problems
  - Project - Edit All Projects

• These permissions allow the user to edit all customer support or failure analysis records.
  - CSI - Update/Edit Customer Support (make sure the CSI - View Customer Support permission is also enabled)
  - Failure Analysis - Edit/Update Failure Analysis

• Deleting Records: These permissions allow the user to delete records. Care should be taken when giving a user these permissions. There is no undo for delete. We recommend that users be granted these permissions only when they need to delete a record, and changing the permissions back to "No" after that is done.
  - Warning - Allow CSI Delete
Chapter 3: Managing Users

- **Warning - Allow Incident Delete**
- **Warning - Allow Problem Delete**
- **Warning - Allow Project Delete**
- **Warning - Allow Repaired/Replaced Part Row Delete**

- **Customer Support (CSIs) fields**: These permissions enable the user to change the specified field in the Customer Support page.
  - CSI – Edit Commission Date
  - CSI – Edit System Hours Report Date
  - CSI – Update Ship Date

- **Incident fields**: These permissions enable the user to change the specified field in the Incident page.
  - Incident – Change Responsible Part
  - Incident – Edit Serialized Part Information
  - Incident – Edit System Hours
  - Incident – Override Automatic Warranty Determination
  - Incident – Update Location Information

- **Incident – Allow Serialized System Modifications**: When working with a serialized incident, the user can edit the serialized system via the Repair/Replace Parts utility by choosing a replacement part from another system. The part will be added to the system template. It will not be deleted or retired from the original template.

- **Incident – Duplicate Repair/Replace Row**: The user can duplicate line items in the Repaired/Replaced Parts table on the Incident page.

- **Incident/Problem – Allows Incident/Problem Association**: The user can associate incidents with problems or problems with incidents.

- **Incident/Problem – Change Creator Name**: The user can change the name of an incident creator or problem creator.

- **Problem – Edit FRB List**: The user can edit the Failure Review Board (FRB) list for problems. The problem owner can always change the FRB list, even if this permission is "No."

- **Problem – Change Problem Owner and Priority**: The user can change the owner of a problem and the problem’s priority.
• **Problem – Close Problem**: The user can close a problem.

• **Project – Change Creator Name**: The user can change the name of the project creator.

• **Creating and Deleting Actions**: These permissions enable the user to create and delete actions for specific record types.
  
  - **Action – Create CSI Action** and **Action – Delete CSI Action**
  - **Action – Create Failure Analysis Action** and **Action – Delete Failure Analysis Action**
  - **Action – Create Incident Action** and **Action – Delete Incident Action**
  - **Action – Create Problem Action** and **Action – Delete Problem Action**
  - **Action – Create Project Action** and **Action – Delete Project Action**

• **Action – Change Action Association**: The user can change the record that an action is associated with.

• **Action – Set/Alter Action Due Dates**: The user can set and change the dates within an action. The owner of the record the action is associated with can edit the action properties, even if the permission is "No". In addition, a user who has the permission to edit all records of a given type can also edit the action properties.

• **Using Detail Fields**: These permissions set what the user can do with certain types of detail fields in any record where that type of detail is used.
  
  - **Details – Allow Issue Creation**: The user can enter new drop-down values in a "Select List" detail field that has the "Allow User Creation" option selected.
  
  - **Details – Edit All Statuses**: The user can edit statuses that have been entered, by any user, in a "Status" detail.
  
  - **Details – Overwrite Read-Only**: The user can modify detail fields that are set to "Read-Only - Always." This option is intended to be used for values that will be imported and should not be changed by users via the web interface. This permission enables the user to correct the imported values if needed.
  
  - **Details – Allow Failure Mode Creation**: The user can create failure modes.
  
  - **Details – Delete Associated File**: The user can delete files that have been uploaded/linked in an "Attachments Table" detail. **There is no undo for delete.**

• **Allow Existing Text Search** - These permissions enable the user to access the Select Existing Utility for description and status fields. (See Configuring the Select Existing Utility.)
Chapter 3: Managing Users

- Details - Allow Existing Text Search
- Action - Allow Existing Text Search
- CSI - Allow Existing Text Search
- Project - Allow Existing Text Search
- Failure Analysis - Allow Existing Text Search

Viewing Reports and Charts:

- Reports – Access Reports Page: The user can run reports.
- Charts – Access Charts Page: The user can run charts.
- Reports – My Queries Enabled: The user can view and use reports saved to the "My Reports" and "My Chart Reports" lists.
- Reports – Public Queries Enabled: The user can view and use reports saved to the "Public Reports" and "Public Chart Reports" lists.
- Report – Show Report SQL: The user can view the SQL Statement used with report results, using the Show SQL Statement icon on the Reports Toolbar.
- Allow Sending XFRACAS Data via E-mail: The user can send report results via e-mail, using the E-mail Report icon on the Reports Toolbar.

Building Reports and Charts:

- Report Builder – Access Report Builder: The user can use the Report Builder to create custom reports and charts and to modify their versions of the built-in standard reports for their personal use.
- Reports – Access Custom SQL Reports: The user can use the Report Builder to create Custom SQL Statements.
- Report Builder – Assign or Remove Public Access: The user can save reports to the "Public Reports" and "Public Chart Reports" lists. There is a separate permission for the ability to access public reports in the Reports page or Charts page ("Reports – Public Queries Enabled").
- Reports – Save Report for Another User: The user can save a report to another user's or groups' "My Reports" or "My Chart Reports" lists. If you save the report for yourself, there is a separate permission for the ability to access "my reports" in the Reports or Charts page ("Reports – My Queries Enabled"). If you save the report for someone else, you will not be able to view it again after it is saved.
Note: This also controls the ability of a user to save dashboard layouts for another user or group.

- **Reports – Serialized System Search Enabled** and **Reports – Template Part Search Enabled**: The user can see the Serialized Search and Part Search commands in the Report Builder ribbon. These enable the user to find specific part numbers and serial numbers without giving admin permissions to the part template and serialized system pages.

- **Viewing and Designing Dashboards:**
  - **Dashboard – Access Dashboard Page**: The user can view existing dashboard layouts.
  - **Dashboard Designer – Access Dashboard Designer Page**: The user can create custom dashboard layouts.
  - **Dashboard Designer – Assign or Remove Public Access**: The user can make dashboard layouts available to all users in the current entity.

- **Portal – Edit User Information**: The user can edit their own user information (Options > Settings > User Information).

- **Portal – Edit Portal Preferences**: The user can change their own Portal Preferences.

- **Portal – Set Default Portal Preferences**: The user can change the Portal preferences that are used by default for new accounts (using the "Save as application default" check box).

- **Links and Announcements**: These permissions allow the user to create and modify public links and announcements.
  - **Portal – Create Public Links and Announcements**
  - **Portal – Modify Public Links and Announcements**

- **Ribbon – Quick Search Enabled**: The user can view and use the Quick Search utility that appears at the top of many pages.

- **Synthesis – Read Failure Mode Data**: The user can import or sync failure mode data with XFMEA/RCM++/RBI. (See [Import or Sync from XFRACAS](#) in the XFMEA/RCM++/RBI documentation.)

- **Synthesis – Read Time to Event Data**: The user can export time to event data for use in Weibull++, ALTA and RGA. (See [Synthesis Data Warehouse](#) in the Weibull++/ALTA documentation.)
Chapter 3: Managing Users

Administrative Permissions
Only the administrative permissions that the logged in user has will be shown in this list (i.e., you can only give other users a permission that you have yourself).

- **Access Data Export**: The user can access the Export command in the ribbon for individual records (e.g., incidents, problems, etc.), generic templates, serialized systems and in the Import page.

- **Access Import Processing**: On the Import page, the user can cause scheduled imports to be processed immediately, rather than waiting for a scheduled import. The user must have this permission to upload and process files either through the Import page, the web service or the API.

- **Access Master BOM Export**: On the Template page, the user can export a list of the currently selected part and its child items within the template configuration that the part belongs to, including all details associated with all parts. This export is intended to allow the user to update the details, part names and part numbers for specific parts.

- **Access Admin Tab**: The user can access the Admin tab on the XFRACAS ribbon.

- These permissions enable access to parts of the administrative functionality.
  
  - Manage Action Categories
  - Manage Active Directory
  - Manage Companies
  - Manage Contacts
  - Manage Criticality
  - Manage Details
  - Manage Diagnostics Page
  - Manage Entities
  - Manage Import
  - Manage Lists
  - Manage Locations
  - Manage Part Owners
  - Manage Report Viewer
  - Manage Resource Editor
• Manage Security Groups
• Manage Serialized Systems
• Manage Template Systems
• Manage User Categories
• Manage User Groups
• Manage Users

• These permissions allow the user to manage the specific preference types on the Preferences page.
  • Manage System-Wide Preferences
  • Manage Entity Preferences

**Responsible Parts**
These are the parts that the user has been assigned as the owner of. When a user account is retired, all parts that the user is responsible for should be reassigned.

• **Reassign Owner for Selected Parts** allows you to assign a different owner for the part(s) that are currently selected.

• **Remove Owner for Selected Parts** removes the current user's ownership of the part(s). This will also clear the e-mail CC list.

**Responsible Open Items**
This area displays a count of all open incidents, problems and actions that have been assigned to the current user. Clicking each count opens a report that lists all of the records of that type. When a user is retired, all items that the user is responsible for should be reassigned.

• **Reassign Owner for Open Items** allows you to assign a different owner for all records of a particular type.

**Adding Users from Active Directory**
Use the Active Directory page to add users from Microsoft Active Directory. Permissions required to access this page: Access Admin Tab and Manage Active Directory.

To open the page, choose Admin > Configure > Security > Active Directory.
Note: This feature uses settings that are specified on the Preferences page. See Entering an ADS Path.

Using the Active Directory Page
First, use the Search Options fields to narrow the Active Directory users that will be shown:

1. Specify the Domain to search in.
2. Specify a Group Type.
3. If desired, you can enter text to search for in the Group Name field to limit the groups shown.
4. Click Load Groups to populate the Group drop-down list. Select the group of interest from the list.
5. If desired, use the Filter By fields to select a criterion to filter the users by, and to specify the text to match.

Once you have specified all of your search criteria, click the Load Users link to populate the Active Directory Users list. Any Active Directory users that already have XFRACAS accounts will be shown in the Current XFRACAS Users list.

Use the arrows to move some or all user names from the Active Directory Users list to the New XFRACAS Users list. You can then set the basic account information, user groups, categories and permissions for all of the users in the New XFRACAS Users list. (For more details on these settings, see Managing Users.) Choose Admin > Users > Create to create the accounts.

The accounts will be created, and will appear in the Current XFRACAS Users list.

Managing User Categories
Use the User Categories page to maintain categories that users can be assigned to. These categories can be used to filter drop-down lists of users (e.g., when assigning users to failure review boards). Permissions required to access this page: Access Admin Tab and Manage User Categories.

To open the page, choose Admin > Configure > User Categories.

If your implementation has more than one entity, the user categories can be configured separately for each. The drop-down list at the top of the page determines which entity's categories are currently displayed.
To create a new user category, click the Add icon, +.

To edit an existing user category, select it in the list and click the Edit icon, 🖍️. Changes will apply to all user accounts that have already been associated with that category.

To remove a user category from the current entity, select the user category in the list and click the Delete icon, ⏐️. If the category is associated with any other entities, it will still be available for those entities.

The following default categories cannot be deleted or renamed, but their display order can be changed.

- **D2 Approver - D8 Approver** each sets permission for the user to be added to a failure review board (FRB) to approve the respective step of a problem.

- **Default Problem Reviewer** sets permission for the user to be the default problem reviewer. This user will appear by default in the Selected Reviewers list when selecting an FRB.

- **FA Engineer** sets permission for the user to be assigned as a failure analysis engineer.

- **Legal Expert** sets permission for the user to be assigned as a legal expert. This category determines the list of users who can be assigned to the "Legal" role in a team. (See Assign Team Members Utility.)

- **Project Owner** sets permission for the user to be the owner of projects. The user's name will appear in the Project Owner drop-down list on the Project page.

- **Problem Owner** sets permission for the user to be the owner of problems. The user's name will appear in the Problem Owner drop-down list on the Problem page.

### Managing Security Groups

Use the Security Groups page to manage sets of permissions and categories that can be assigned to individual user accounts. The categories and permissions on this page are the same as those on the Users page. Permissions required to access this page: Access Admin Tab and Manage Security Groups.

To open the page, choose Admin > Configure > Security > Security Groups.

If your implementation has more than one entity, user permissions can be managed separately for each entity.
Chapter 3: Managing Users

Creating a Security Group
To create a new security group, you can:

- Leave the Select Group to Edit drop-down list blank. Enter the group name and description, set the permissions and then choose Admin > Security Groups > Create.

- If you are currently viewing an existing security group and want to clear the information and create a new group, choose Admin > Security Groups > New or clear the Select Group to Edit field.

You can then enter the group name and description, set the permissions and then choose Admin > Security Groups > Create.

Editing a Security Group
- To edit an existing security group, choose the group from the Select Group to Edit drop-down list. Make the desired changes and then choose Admin > Security Groups > Save.

Deleting a Security Group
- To delete an existing security group, choose the user name from the Select Group to Edit drop-down list and then choose Admin > Security Groups > Delete.

Note that this will remove any users from the group and delete the group. Any users with permissions via the group will lose those permissions.

Group Membership
Click Manage Group Membership to view or modify the users who are assigned to this security group. (Note that you can also change a particular user’s security group from the Users page.)

If your organization uses Microsoft Active Directory, you can manage the membership of any security group based on an associated Active Directory group. For example, any users assigned to the "ABC Team" or the "XYZ Team" in Active Directory can be assigned to have specific sets of permissions in the entity. If a user needs to be added or removed from a security group, the administrator can manually sync the group to the Active Directory group to reflect the changes made in Active Directory.
To associate a security group with an Active Directory group, select the **Associate Active Directory Group** check box and then specify the domain name. Click the **Load** icon, beside the **Security Group** field to load available groups, then select the group and click the **Load** icon beside the **Active Directory Users** field to load the users in the group. Click **Associate** to finalize the association.

**Managing User Groups**
Use the User Groups page to manage predefined groups of users and team roles that can be quickly assigned to teams for incidents, problems or projects. Permissions required to access this page: Access Admin Tab and Manage User Groups.

To open the page, choose **Admin > Configure > Security > User Groups**.

If your implementation has more than one entity, you must create separate user groups for each entity.

**Creating a Group**

1. Make sure the **Select Group to Edit** drop-down list is blank. If you are currently viewing another group, you can either choose the blank option from the list, or click **Admin > User Groups > New**.

2. Enter at least a **Name** for the new group.

3. Click **Admin > User Groups > Create**.

**Assigning Members to a Group**

1. Select the group from the **Select Group to Edit** drop-down list.

2. Click **Assign/Remove Members** to open the Assign Members utility.

   - To add users, select a **Team Role**, then select the user(s) who will have that role, then click **Add User(s)**. Note that only users who have the "Legal Expert" category in the Users page can be assigned to the "Legal" role on a team.

   - To remove group members, select the user(s) in the **Current Members** list and click **Remove Selected**.
Chapter 3: Managing Users

- Click Save to close the window.

Changes to group members are saved when you close the Assign/Remove Members window. If you need to save changes to the group's name or description, choose Admin > User Groups > Save.

Deleting a Group
To delete an existing user group, choose the group name from the Select Group to Edit drop-down list and then choose Admin > User Groups > Delete.

Managing Applicants
Use the Applicants page to process user account requests that have been submitted via the "Request Access" process. Permissions required to access this page: Access Admin Tab and Manage Users.

To open the page, choose Admin > Configure > Security > Applicants.

**Tip:** The process also sends an e-mail to the administrator of each entity that the user has requested to access (as specified in the "Administrator E-mail" preference). Click the link in the e-mail to open this page.

If your implementation has more than one entity, the applicants will be managed separately for each. The drop-down list at the top of the page determines which entity's applicants are currently displayed.

Granting Access
The Select Name to Edit list shows the applicants who have requested access to the current entity.

To grant access, select a name from the list and review/update the system-wide and entity-specific information. These are the same options as in the Users page. Then choose Admin > Users > Create.
Removing an Applicant
To remove an applicant, select the name from the list and choose Admin > Users > Delete.
Chapter 4: Managing Parts and Systems

Managing System Templates

Use the Template page to view and manage generic system configurations that identify the types of parts that may be included in a system (e.g., "Bill of Materials") or the steps in a process. If applicable, you can use these templates to create separate serialized configurations for the specific parts in a particular piece of equipment. Permissions required to access this page: Access Admin Tab and Manage Template Systems.

To open the page, choose System > System > Template.

If your implementation has more than one entity, the system templates are managed separately for each. The drop-down list at the top of the page determines which entity's templates you are currently managing.

Create a New Template
To create a new system template, choose System > Template > Create Template.

In the Create Template utility, enter at least the part number and part name.

To import a system configuration from XFMEA, RCM++ or RBI, choose System > Template > XFMEA Import.

This command appears only if the database has at least one desktop project that a) has a system hierarchy and b) you have permission to access. (See Importing Systems from XFMEA.)

View an Existing Template
To view or edit an existing system template, choose System > Template > Find Template.

In the Find Template utility, you can search by part name or part number. Alternatively, if you want to see a list of all system templates in the current entity, leave the value blank and click Search.
Chapter 4: Managing Parts and Systems

Hierarchy and Part Properties
When you are working with an existing system template, the left side of the page shows the hierarchical configuration and the right side shows the properties for the part that is currently selected.

If you are working with a large system configuration, the Part Search utility provides a quick way to find the part you want to view or edit. Click the Find part on system... link at the top of the hierarchy, then search based on part number, name or version.

Edit an Existing Part
To edit an existing part, select the part in the hierarchy and choose System > Part > Edit.

Create or Associate Parts
When adding parts to a template, you can create a new part (with a new unique Part ID) or add another instance of an existing part (with the exact same Part ID used multiple times in the same template and/or in multiple templates).

To add a new part, or to add an existing part when you know the part number and version, choose System > Part > Create.

In the Create Template Part utility, enter at least the part number and part name and click Save. The behavior depends on whether the Use Existing Part if Found check box is selected and whether there are any existing parts with the same part number and version:

- Not selected - creates a new part with a unique Part ID.
- Selected and no matching parts - creates a new part with a unique Part ID.
- Selected and at least one matching part - opens the Associate Template Parts utility where you can select an existing part to add.

To add an existing part when you don't know the part number and version, or to add multiple existing parts at the same time, choose System > Part > Associate.

In the Associate Template Parts utility:

- When you click a part in the Available Items List, the area at the bottom of the utility shows where that part is used, and whether it has subitems (aka "children").
The **Selected Items Lists** shows the existing part(s) that will be added to the current template when you click OK. If the **Associate Children** check box is selected, any subitems/children will also be associated at the same time. *Note that the save process may take several minutes if you are associating a large number of existing parts.*

**Delete, Retire or Disassociate a Part**

When removing parts from a template, the behavior depends on the command you choose and the location(s) where the part is used.

To remove a part that you don't want to use again, select the part in the hierarchy and choose **System > Part > Delete**.

- If the part is not used anywhere else, it will be permanently deleted.
- If the exact same Part ID is used in another location within the current template or in a different template, it will be removed from the current location and remain unchanged in the other location(s).
- If this is the only location where the part is used in a template, and the part has been used in at least one incident, problem or serialized system, it will be "retired." A retired part continues to show in the system hierarchy, identified by an icon and with the retirement date shown in brackets.

**Tip:** New in Version 2018, XFRACAS now provides a warning when you attempt to delete a part that will have to be retired because it is used in at least one incident, problem or serialized system. In addition, if a part has already been retired, the **Part in Use** area will display in the part properties panel. If you want to permanently delete the part, you must first remove it from all locations where it is used.

Also note that if a part has ever been saved as the Responsible Part for an incident, it will remain in the Responsible Part History for that record, and therefore cannot be permanently deleted.

To remove a part that may be used again in another template or in a different location in the current template, select the part and choose **System > Part > Disassociate**.

This will remove the part from the current location and create a new top-level part that you can later associate in a different location.
Define Failure Modes

The potential failure modes and root causes defined for a template part will be available for selection in failure mode detail fields (if any) in the incidents, problems or failure analysis reports.

- **Add Failure Mode** adds a new failure mode for the part.
- **Add Existing Failure Mode** copies failure mode(s) and root cause(s) that were defined for another part.
- **Add Root Cause** adds a new root cause for the selected failure mode.

To edit or delete an existing failure mode or root cause, select it and click **Edit**, or **Delete**.

If you are using ReliaSoft XFMEA, RCM++ or RBI for failure modes and effects analysis, you also have the option to import and/or synchronize system templates and failure modes. (See Importing Systems from XFMEA.)

Assign an Owner

Each template part can be associated with an owner. Parts that have an owner are indicated in the template by 🔄.

When users create new incidents, if they do not specify an incident owner, it will be set automatically to the owner of the first responsible part. Depending on the configurable settings for the entity, the incident owner may receive e-mail notifications when the incident is created, when actions are created for the incident, etc.

**Note:** If the incident page is configured to require users to select a single responsible part from a drop-down list (i.e., if the "Incident - Use Tree to Select Responsible Part" preference is false), users will not be able to create incidents until there is at least one template part with an owner assigned. The following warning will be displayed in the incident page: "Incomplete System Setup: Responsible Part not configured correctly. Please contact your XFRACAS administrator."

- To assign an owner, select the part and choose **System > Part > Assign Owner**.
- To remove the owner, select the part in the template and choose **System > Part > Remove Owner**.
• To add more users to the e-mail notification list for a part that already has an owner, select the part and choose System > Part > CC List.

Managing Serialized Systems

Use the Serialized page to view and manage serialized system configurations, which are based on generic system templates. For example, the template for Model A identifies all the parts that may be included in specific units. The serialized system identifies the parts that actually are included in a specific unit, including the unique serial numbers when applicable. Permissions required to access this page: Access Admin Tab and Manage Serialized Systems.

To open the page, choose System > System > Serialized.

If your implementation has more than one entity, the serialized systems must be configured separately for each. The drop-down list at the top of the page determines which entity's systems you are currently managing.

Creating a Serialized System

To create a serialized system, choose System > Serialized > Create System.

In the utility that appears, choose the kind of system you want to create from the Template Part drop-down list. Then enter the Serialized Part Properties.

Finding an Existing System

To work with an existing serialized system, choose System > Serialized > Find System.

In the utility that appears, you can search by system serial number or by subsystem serial number.

System Configuration

When you are creating or editing a serialized system, the system configuration is displayed on the left side of the interface. Click the plus (+) or minus (-) icons to expand or collapse a branch of the tree.

To locate a specific part, click the Find part on system link at the top of the hierarchy to search by part number or serial number.
If a part in the system configuration has been replaced, it will appear at the bottom of the hierarchy and a replacement date will appear next to it. Replaced parts are indicated by 📌.

Adding or Removing Parts
Once you have selected a system to work with, you can add new or existing parts to it and you can remove parts from the system.

- **Create Serialized** - adds a part based on the generic system template and requires you to enter a unique serial number.

- **Add Existing Serialized** - removes a part from another system and moves it to the current system.

- **Add Non-Serialized** - adds a part based on the generic system template and does not require you to enter a unique serial number.

  If you select the **Associate Children** check box, all children of each newly selected part will also be added to the list of selected items. Note that this can add a large number of parts and that, depending on the size of the tree underneath each selected part, the save process may take several minutes. To see a detailed view including child parts, click the **View Structure** link in the item hierarchy to open the full hierarchy in a new window.

- **Disassociate** - removes the selected part from the system and makes it available for future use.

- **Delete Serialized** - removes the selected part from the system, unless there are already records pertaining to the part, in which case the part is retired instead.
**Serialized Part Properties**

- The **Serial Number** and **Build Date** are required for a system while only the **Build Date** is required for parts.

- These characters are not allowed in serial numbers: @ # % & = { } " < >.

- If the part has accumulated age before being added to the system (i.e., the part is "used"), specify the **Starting Age** (e.g., "Run Hours," "Number of Starts" or "kw Run Hours"). If you extract the data to Weibull++ or RGA for reliability analysis, the starting age may be added to the part's time on the system to estimate the part's time/usage. (For example, if the part had a starting age of 100 hours when it was added to the system, the system runs for 200 hours before the next failure and you have not directly specified the part's time/usage, we assume it is 300 hours.)

If you have configured additional detail fields to meet your organization's specific needs, they will be grouped together in a separate **Details** area.
Chapter 5: Managing Preferences

Managing Preferences

Use the Preferences page to manage many of the configurable settings within XFRACAS. Permissions required to access this page: Access Admin Tab, and Manage System Wide Preferences or Manage Entity Preferences.

To open the page, choose Admin > Configure > Preferences.

Choose Admin > Preferences > Save to save any changes.

If your implementation has more than one entity, some preferences apply to the entire website (System-Wide Preferences) and the rest will be managed separately for each entity. The drop-down list at the top of the page determines which entity-specific preferences are currently displayed.

**Tip:** In the website, preferences are grouped by type (e.g., true/false, date, string, etc.) and listed alphabetically. In the documentation below, related preferences are discussed together when applicable (i.e., not always in alphabetical order).

- System-Wide Preferences
- Boolean Preferences
- Date Preferences
- Display Option Preferences
- E-mail Preferences
- Integer Preferences
- String Preferences
- Time Zone Preferences
- URL Preferences
- Target and Completed Dates
System-Wide Preferences

- **Secure Socket Layer Protection**
  - **SSL Server Mode Required**: If True, the website will use https (rather than http) when building links. Before you enable this option, make sure the IIS web server is configured properly for SSL/TLS (as discussed in the XFRACAS Implementation Guide).
  - **SSO Authentication**: XFRACAS uses Windows authentication by default. Alternatively, if your web server is set up to support SSO authentication, XFRACAS will check for the "Auth_User" variable by default. If your SSO method has been configured to use a different variable, set the following preferences:
    - **Single Sign-On (SSO) Authentication Enabled**: If True, indicates that your web server is set up for SSO authentication and uses a variable other than "Auth_User."
    - **Single Sign-On (SSO) Server Variable**: The alternative variable that XFRACAS needs to check for SSO authentication.

The admin/TESTSSO.aspx page on the website provides additional details to help with troubleshooting the configuration.

- **Location of the XFRACAS Website**
  - **XFRACAS Server - Filesystem Prefix**: The absolute path on the server where the website's IIS folder is installed (e.g., C:\inetpub\wwwroot\XFRACAS\).
  - **XFRACAS Server - IIS Prefix**: The path that can be used to build links to pages within the XFRACAS website (e.g., servername/XFRACAS or 10.0.0.2/xfracas).

- **Link to the SEP Website (if Applicable)**
  - **Synthesis - Display Synthesis Enterprise Portal (SEP) Command**: If True, the XFRACAS ribbon will include a link to your organization's SEP website.
  - **Synthesis Enterprise Portal Server - IIS Prefix**: The path that can be used to build the link to the SEP website (e.g., servername/SEP).

- **Upload Files for Attachments**
  - **Attachments - Allow Uploaded Files**: If True, the Attachments window will include the option for users to upload files. The files may be stored in the database or uploaded to a designated folder on the web server, depending on how you configure the related preferences.
• **Attachments - Store Uploaded Files in Database**: If True, files will be stored in the database. If False, files will be stored in a designated folder on the web server.

• **Attachments - Uploaded Files Filesystem Prefix**: If applicable, this is the absolute path to the folder on the web server where uploaded attachments will be stored (e.g., C:\inetpub\wwwroot\XFRACAS\uploads\ or D:\storage\xfracas) For requirements and instructions to prepare this folder, refer to the [XFRACAS Implementation Guide](#).

• **Attachments - Uploaded Files IIS Prefix**: If applicable, this is the path that will be used to build links to download files that were saved on the web server.
  - If you are using an actual file folder within the website, enter a relative path (e.g., uploads).
  - If you are using a virtual directory created in IIS, use an absolute path (e.g., http://servername/uploads).

• **SMTP Server for E-Mail Notifications**
  - **SMTP Server**: The address of the SMTP server that will be used for sending e-mails (e.g., mail.servername.com or 10.0.0.2).
  - **SMTP Port**: The port used to connect to the SMTP server. If left blank, the default SMTP port 25 will be used.
  - **SMTP Connection Timeout**: The amount of time, in seconds, before the connection to the SMTP server times out when sending e-mails.

• **Use Web-based Help**: If True, the help commands always open the most up-to-date help files from the Internet when possible. If False, they open the local help files that were installed with the software.

• **DIU Service - Generate Import Log**: If True, an import log will be generated during an import. The log will be stored with the import record.

• **Terms of Use Agreement Page Required**: If True, users will be prompted to accept an agreement the first time they access XFRACAS each day. To customize the content of the agreement, edit the files directly on the web server:
  - Agreement.aspx is stored in the website's main folder and will be displayed if the user visits any of the regular pages.
  - AdminAgreement.aspx is stored in the website's Admin folder and will be displayed if the user visits any of the admin pages.
Chapter 5: Managing Preferences

- **Unknown Users - Allow Account Request**: If True, users not already in XFRACAS can request access to the system, and users not already in an entity can request access to the entity.

- **Report Filter Display Max Rows**: Indicates the maximum number of rows that a report can return and still have filtering and grouping capabilities.

- **DB Version** and **License Number**: The database version and license number of the XFRACAS system. These are available for technical support purposes and cannot be changed.

### Boolean Preferences

- **CSI - Display CSI Wizard**: If True, the Use CSI Wizard command will be available when users are creating new Customer Support records. The wizard prompts users to enter the data one step at a time, instead of all in a single form.

- These preferences show/hide some of the fields in the Customer Support page. For information about how these fields are used, see Customer Support. To configure other fields for this record type, use the Details page.

  - **CSI - Display Shipment Date**
  - **CSI - Display Delivery Date**
  - **CSI - Display Distributor**
  - **CSI - Display MTBF**
  - **CSI - Display MTBCF**
  - **CSI - Display MTBNCF**
  - **CSI - Display MTBI**
  - **CSI - Display Chargeable Incident Count**
  - **CSI - Display Non-Chargeable Incident Count**
  - **CSI - Enable Operational Availability**
  - **CSI - Display Calculated System Downtime**
  - **CSI - Display Unit Owner Address Information**
  - **CSI - Display Contact**
  - **CSI - Display Warranty Section**
  - **CSI - Display ASP Information** (ASP and ASP Field Service Tech)
Chapter 5: Managing Preferences

- **CSI - Commission Date Required**: If True, the commission date is required in the Customer Support page. If False, the shipment date becomes a required field and will be populated based on the system build date if left blank by the user.

- **CSI - Create Incident Link Transfers Hours from CSI**: This applies when the user clicks the "Create Incident" link in the Customer Support page. If True, the time metric field(s) in the incident (e.g., System Hours) will be populated based on the latest info in the CSI. (See Time Metric Calculations.)

- **CSI - Display All Authorized Service Technicians**: This applies if the "CSI - Display ASP Information" preference is enabled. If True, all service technicians will be displayed in the drop-down list, regardless of the company they are associated with. If False, only service technicians associated with the selected company will be displayed.

- **CSI - Show All Unit Contact Names**: This applies if the "CSI - Display Contact" preference is enabled. If True, the Contact field will show all contacts available in the system. If False, the list will be filtered by unit owner.

- **CSI - Extended Warranty Purchase Anytime**: This applies if the "CSI - Display Warranty Section" preference is enabled. If False, the purchase date for the extended warranty must be within the date range of the initial warranty. (See Warranty Information Area).

- **Incident - Display Incident Wizard**: If True, the Use Incident Wizard command will be available for new Incident records. The wizard prompts users to enter the data one step at a time, instead of all in a single form.

These preferences show/hide some of the fields in the Incidents page. For information about how these fields are used, see Incidents. To configure other fields for this record type, use the Details page.

- Incident - Display Unit Location
- Incident - Display Title (and Incident - Require Title)
- Incident - Display Team Members
- Incident - Display Potential Criticality and Incident - Display Actual Criticality (see Managing Criticality Fields)
- Incident - Display Service Response Time/Date
- Incident - Display ASP Field Service Tech (and Incident - Require ASP Field Service Tech)
- Incident - Display Repair Duration
- Incident - Display Repair/Replace Parts
• **Incident - Assign Creator as Owner**: If True, the user who creates the incident will be assigned as the owner of the incident. If False, the incident owner depends upon the responsible part or the choice in the Owner field.

• **Incident - Display System Status**: If True, the System Status field will show in part incidents, for information purposes only. This field is always hidden for simple incidents and always shown for serialized incidents. When applicable, the summary area of the Customer Support page displays the current status for a particular system based on all of the serialized incident reports for that unit.

• These preferences specify whether to display calculated metrics in the summary for a serialized incident.
  - **Incident - Display Calculated Response Time**
  - **Incident - Display Calculated Downtime**

• **Incident - Auto-populate Time Metric 1**: If True, the primary time/usage metric field (e.g., hours, miles, kilometers, cycles, etc.) will be populated automatically in a serialized incident when the required inputs are available. (See [Time Metric Calculations](#).)

• These preferences specify whether to track additional time or usage metrics (e.g., hours, miles, kilometers, cycles, etc.) in the Customer Support page and Incident page for serialized incidents and part incidents. By default, these three metrics are labeled "System Hours," "Number of Starts" and "kW Run Hours" but you can use the [Resource Editor](#) to customize the labels to fit your specific needs.
  - **Incident - Display Time Metric 2**
  - **Incident - Display Time Metric 3**

• These preferences specify whether to automatically calculate the value of one time/usage metric based on the value entered for another. The behavior also depends on the "Display Time Metric" and "Time Metric Formula" preferences. (See [Time Metric Calculations](#).)
  - **Incident - Always Auto-calculate Time Metric 1**
  - **Incident - Always Auto-calculate Time Metric 2**
  - **Incident - Always Auto-calculate Time Metric 3**

• **Incident - Use Tree to Select Responsible Part**: If True, the "Responsible Part" field in the Incident page will allow users to select one or multiple parts from a tree view of all system templates. If False, users can select only one part from a drop-down list. When the tree is used, you can also specify:
• **Incident - Auto-select Responsible Part for New Incidents**: If True, the part number specified in the System/Component Information area will be selected by default in the Responsible Part tree.

• **Incident - Enable Responsible Part Filter**: If True, the Responsible Part tree will only allow users to select parts from the system specified in the System/Component Information area.

• **Incident - Defaults**: These preferences apply when the entity has only one system template defined. If True, then XFRACAS will automatically set relevant part fields when creating a new incident.
  
  • **Incident - Default Part Number**
  
  • **Incident - Default Responsible Part**

• These preferences specify whether XFRACAS will automatically set date fields in the incident based on today's date.
  
  • **Incident - Default Repair Date**
  
  • **Incident - Default Response Date**

• **Incident - Require Date Field Validation**: If True, the date in any date field on the Incident page cannot be less than the incident's creation date.

• **Incident/Problem - Display Audience Restriction** and **Incident/Problem - Require Legal Team Member**: If both of these preferences are True, the Audience Restriction field will be displayed in the Incident page and Problem page after the record is created, and if the "Attorney/Client Privilege" option is selected for a particular incident or problem, then:
  
  • Only users assigned to the team for that record will be able to view it in any form. Make sure the "Incident - Display Team Members" and "Project - Display Team Members" preferences are also enabled so users will be able to assign an appropriate team before restricting access to the record.
  
  • The team assigned to the record must have at least one user assigned to the "Legal" team role. Only users who have the "Legal Expert" category in the Users page can be assigned to this role.

• **Incident - Display Customer Requested Feedback**: If True, the "Customer Requested Feedback" check box is displayed in the Incident page and the "Report Sent to Customer" check box is displayed on the Failure Analysis page.

• **Incident - Closure**: These preferences specify the conditions that must be met to close an incident. Select all that apply.
Chapter 5: Managing Preferences

- **Incident - Closure Restriction Level 1**: All actions for the incident are completed.

- **Incident - Closure Restriction Level 2**: All failure analysis reports belonging to the incident are closed.

When an incident is closed, it no longer appears in the XFRACAS Portal under "Unclosed Incidents." Only users with the "Incident - Open a Closed Incident" or "Incident - Edit All Incidents" permissions can reopen a closed incident.

- **Incident - Disable Edit of Closed Incidents**: If True, closed incidents will be read-only and can only be edited by users with either the "Incident - Open a Closed Incident" or "Incident - Edit All Incidents" permissions.

- **Allow Cross Entity Association**: These preferences apply when assigning an incident to a problem or assigning a problem to a project. They also apply when creating an attachment to an XFRACAS record. If True, records from all entities that the user has access to will be available. If False, only records from the current entity will be available.
  
  - **Incident/Problem - Allow Cross Entity Association**
  - **Project/Problem - Allow Cross Entity Association**

- **Incident - Create Problem Link**: These preferences apply when the user clicks the "Create Problem" link in the Incident page.
  
  - **Incident - Create Problem Link Transfers Incident Description**
  - **Incident - Create Problem Link Transfers Incident Title**
  - **Incident - Create Problem Link Transfers Responsible Part** (transfers to the problem's Part Category Code field)

These preferences show/hide some of the fields in the Problem page. For information about how these fields are used, see Problems. To configure other fields for this record type, use the Details page.

- **Problem - Display Team Members**
- **Problem - Display Requested Closure Date**
- **Problem - Display Expected Closure Date**
- **Problem - Display Criticality** (see Managing Criticality Fields)
- **Problem - Display Associated Incidents**
- **Problem - Display Associated Projects**
• These preferences show/hide some of the fields in the Associated Incident Reports section on the Problem page.
  
  • **Problem - Display Incidents by Status** (open or closed)
  • **Problem - Display Incidents by Chargeability** (chargeable or non-chargeable)

• **Problem - Show Steps**: These preferences specify which of the optional steps will be displayed on the Problem page in addition to the four steps that are always displayed: *Establish the Team, Describe the Problem, Choose and Verify Permanent Corrective Actions* and *Prevent Recurrence*.
  
  • **Problem - Show Step - Implement and Verify Containment Actions**
  • **Problem - Show Step - Identify and Verify Root Cause**
  • **Problem - Show Step - Implement Permanent Corrective Actions**
  • **Problem - Show Step - Congratulate the Team**

• **Problem - Always Show All Problem Steps**: If True, after a user has entered the first step and created a new problem, the page will show all of the subsequent steps that need to be performed. If False, each subsequent step will be displayed only after the previous step is completed and saved.

• **Problem - Completed Date Warning**: If True, entering a problem completed date that is in the future will show a warning.

• **Problem - Enable Created Date Restriction**: If True, the problem's creation date must be earlier than the completion/sign-off date for any step in the problem.

• **Problem - FRB Sign-Off CC Restriction**: If True, the priority order of FRB reviewers will be enforced. Once the first reviewer signs off on the problem step, the second reviewer can then review the step. Reviewers cannot sign off out of order.

• **Problem - FRB Sign-Off Restriction**: This applies only if the "Problem – FRB Sign-Off Restriction" preference is True. If True, the review request e-mail will be sent only to the next FRB reviewer based on priority order. If False, the e-mail will be sent to all reviewers on the FRB reviewers list for the current step.

• These preferences specify the conditions that must be met before a problem step or problem can be closed. Select all that apply.
  
  • **Problem - Closure Restriction Level 1**: All actions for the problem must be completed.
  
  • **Problem - Closure Restriction Level 2**: All incidents associated with the problem must be closed.
Chapter 5: Managing Preferences

- **Problem - Closure Restriction Level 3**: All actions associated with a problem step must be completed before you can close the step.

When a problem is closed, it no longer appears in the XFRACAS Portal under "Open Problems." Only users with the "Problem - Open a Closed Problem" or "Problem - Edit All Problems" permissions can reopen a closed problem.

- These preferences show/hide some of the fields in the Project page. For information about how these fields are used, see Projects. To configure other fields for this record type, use the Details page.
  - **Project - Display Team Members**
  - **Project - Display Target Completion Date**
  - **Project - Display Revised Completion Date**
  - **Project - Display Actual Completion Date**
  - **Project - Display Scope of Project**
  - **Project - Display End Result**
  - **Project - Show Associated Problems**
  - **Project - Show Associated Incident Reports**
  - **Project - Display Associated Incidents**
  - **Project - Show Associated FA Reports**

- These preferences specify the conditions that must be met before a project can be closed. Select all that apply.
  - **Project - Closure Restriction Level 1**: The actual completion date must be set and all actions for the project must be completed.
  - **Project - Closure Restriction Level 2**: The actual completion date must be set and all problems associated with the project must be closed.

When a project is closed, it no longer appears in the XFRACAS Portal under "My Projects." Only users with the "Project - Open a Closed Project" or "Project - Edit All Projects" permissions can reopen a closed project.

- These preferences specify whether e-mails will be sent to the incident owner when a new incident is created, or when an existing incident is assigned to a new owner.
  - **E-mail - Incident Creation**
  - **E-mail - Incident Owner Reassigned**
• These preferences specify whether e-mails will be sent to the problem owner when a new problem is created and the problem owner is not the same as the problem creator, or when a problem is assigned to a new owner.
  • E-mail - Problem Creation
  • E-mail - Problem Owner Reassigned

• These preferences specify whether the Status utilities in each record type will include the E-mail Notify option.
  • E-mail - Action Status Update
  • E-Mail - Incident Status Update
  • E-Mail - FA Status Update
  • E-Mail - Problem Status Update
  • E-Mail - Project Status Update

• If e-mail notifications are enabled for new/modified statuses, these preferences specify which check boxes will be selected by default.
  • E-mail - Action Status Update Associated Owner Checked
  • E-mail - Action Status Update Creator Checked
  • E-mail - Action Status Update Team Checked
  • E-mail - Incident Status Update Creator Checked
  • E-mail - Incident Status Update Owner Checked
  • E-mail - Incident Status Update Team Checked
  • E-mail - FA Status Update Associated Owner Checked
  • E-mail - FA Status Update Creator Checked
  • E-mail - FA Status Update Team Checked
  • E-mail - Problem Status Update Creator Checked
  • E-mail - Problem Status Update Owner Checked
  • E-mail - Problem Status Update Team Checked
  • E-mail - Project Status Update Owner Checked
  • E-mail - Project Status Update Team Checked
Chapter 5: Managing Preferences

- These preferences specify whether e-mails will be sent to the action owner when an action is created or when an existing action is assigned to a new owner.
  - **E-Mail - CSI Action Creation**
  - **E-Mail - Incident Action Creation**
  - **E-Mail - FA Action Creation**
  - **E-Mail - Problem Action Creation**
  - **E-Mail - Project Action Creation**

- **E-mail - Action Associated Owner on Creation**: If True, e-mails will be sent to the owner of the parent record when an action is created. For example, creating an action associated with an incident will cause an e-mail to be sent to the incident owner.

- **E-mail - Action Owner on Update**: If True, e-mails will be sent to the action owner when the owner, descriptions, date or statuses for an action are changed.

- These preferences specify whether e-mails will be sent to the action owner when the due date is approaching or the action is past due. (See **E-mails Based on Calendar Date**.)
  - **E-mail - CSI Action Due Date**
  - **E-mail - Incident Action Due Date**
  - **E-mail - FA Action Due Date**
  - **E-mail - Problem Action Due Date**
  - **E-mail - Project Action Due Date**

- These preferences specify whether the incident or problem owner will receive a copy of action e-mails based on due date.
  - **E-mail - CC Incident Owner Action Due Date**
  - **E-mail - CC Problem Owner Action Due Date**

- **E-mail - Send Action Due Notify Once**: If True, e-mails will be sent only once when actions approach their due dates. If False, e-mails may also be sent at regular intervals when an action is past due. (See **E-mails Based on Calendar Date**.)

- **E-mail - Group Action Due Date**: If True, only one e-mail will be sent for all of a user's actions approaching their due dates. If False, an individual e-mail will be sent for each action.

- These preferences specify whether e-mails will be sent to the owner of the parent record when an action associated with that record has been closed.
• E-Mail - CSI Action Closed
• E-Mail - Incident Action Closed
• E-Mail - FA Action Closed
• E-Mail - Problem Action Closed
• E-Mail - Project Action Closed

These preferences specify when e-mails will be sent to members of the Failure Review Board (FRB) in a problem.

• E-mail - Reviewer Added to FRB: E-mails will be sent to reviewers when they assigned to an FRB.

• E-mail - Send Problem Signed Off: E-mails will be sent to the problem owner and the reviewer when an FRB reviewer signs off on a step.

• E-mail - Problem Signed Off by FRB (All): E-mails will be sent to the rest of the FRB when a reviewer signs off on a step.

• E-mail - Problem FRB Not Signed Off: E-mails will be sent to the FRB reviewers when the requested closure date is approaching or past due. (See E-mails Based on Calendar Date.)

• E-mail - Problem FRB Rejected: E-mails will be sent to the problem owner and the FRB members when a FRB reviewer has rejected closure of a problem.

• E-mail - Group Problem FRB Not Signed Off: If True, only one e-mail will be sent for all of the problems for which a user is an FRB reviewer as a reminder that they need to sign off on a problem. If False, an individual e-mail will be sent for each problem.

• E-mail - BCC Administrator on XFRACAS Data Sent: If True, the e-mail address specified in the "Administrator E-mail" preference will receive a copy of every e-mail sent that includes data from a CSI, incident, failure analysis, problem or project record (i.e., every e-mail where the printer-friendly view is included). This is a way of tracing that data from a security standpoint (such as an organization that has ITAR-related data).

• E-mail - FA SAP Work Order Request: If True, e-mails will be sent when a failure analysis report requests an SAP work order (or a similar record from another enterprise resource planning system).

• E-mail - Incident Customer Requested Feedback: If True, e-mails will be sent when a customer requests feedback on a failure analysis. The recipient is defined in the "E-mail - Customer Requested Feedback Notify To" E-mail preference.
Chapter 5: Managing Preferences

- **E-mail - RMA Received to Problem Owner**: If True, e-mails will be sent to the problem owner when a Return Materials Authorization (RMA) has been received. This only applies if the incident report that contains the RMA is associated to a problem.

- **Reports - Allow Send via E-mail**: If True, the E-mail button will be available in the Reports page.

- **Reports - BCC Administrator on Data Sent via E-mail**: If True, the e-mail address specified in the "Administrator E-mail" preference will receive a copy when report results are sent via e-mail.

- **Reports - Display Qualifiers**: If True, the "Results based on the following qualifiers" area will be displayed in report results.

- **Reports - Include End Date Matches**: If True, the end date set in a report is included in the results. For example, with a setting of True, a report of dates between Jan. 1, 2017 and Jan. 2, 2017 would include results for date matches from the entire days of Jan. 1, 2017 and Jan. 2, 2017. With a setting of False, the report would only include results from the entire day of Jan. 1, 2017. This applies if the "XFRACAS - Display Time with Date Fields" preference is set to False.

- **Action - Allow Setting Due Date Before Current Date**: If True, users can enter an action date that is earlier than the creation date. This allows you to enter historical information that did not get entered when the action was actually performed.

These settings apply when using the Synthesis Data Warehouse in Weibull++ to extract data sets for life data analysis.

- **Analysis - Fixed Daily Operating Hours**: If True, systems are considered to run constantly (i.e., 24x7). System operating time (system up hours) will be calculated based on numerous factors, including commission or shipment date, incident occurrence date, the "Incident - Max Units/Day" Integer preference and the system down time. If False, the times are those reported in either the incidents or in the CSI.

- **Analysis - Weibull++ Export Rollup**: If True, failures of child parts will be considered to also precipitate failures of parent parts. If the System Down Event incident detail is available in the current entity, then for incidents that are marked as system down events, the failure will affect all levels above the child part all the way to the top level item. For incidents that are not marked as system down events, the failure will affect all but the top level item. If False, failures of child parts will not roll up to parent parts. It is important to note that if this preference is True, the times that are exported are the times between failures, not the failure times. If you are unsure if this analysis method is appropriate for you, please contact ReliaSoft for further information.
• **Lists - Autosize List Height**: If True, the area used to display lists in the [Lists page](#) varies in height depending on the number of items in the list. If False, a scroll bar will be used to scroll through the list. Note that there is a maximum height of 300 pixels for any list, even when this preference is set to True.

• **Manage User - E-mail/Login Auto Build**: If True, the user login and e-mail address fields will automatically be assigned in the [Users page](#) based on the user’s first and last names and the "Manage User - E-mail Suffix used for Auto Build" E-mail preference.

• These preferences apply to the "data tree" on the [Template page](#) and the [Serialized page](#). They also apply to the Responsible Part in incidents (when it is used as a tree) and for the Part Category Code in problems.

  • **System - Data Tree Auto Collapse**
  
  • **System - Data Tree Sort by Part Description** (rather than part number)

• **XFRACAS - Autopopulate Associated Record Dialog**: This applies to all Assign/Find windows (e.g., when assigning an incident to a problem). If True, all records will be displayed when the window opens. If False, only currently assigned records will be displayed upon open and users can click Filter to see all records.

• **XFRACAS - Display Debug IDs**: If True, the resource IDs will be shown in square brackets beside the name for all fields. You can use this in conjunction with the [Resource Editor](#) to customize text labels displayed in the website. In addition, the Detail Type IDs will be shown in square brackets on the [Details page](#).

• **XFRACAS - Display Employee ID With User Name**: If True, the employee ID will be displayed along with the user name in locations where a user is being selected (e.g., the Assign Team Members utility, drop-down lists, etc.).

• **XFRACAS - Display Last Updated Timestamp**: If True, information on the last update of the record will be displayed in the summary area for incidents, problems, projects, failure analysis reports, CSIs and actions.

• These preferences apply to all date/time input fields. Note that there are separate preferences for dates and times displayed as regular text (the "XFRACAS - Date Format - Long" and "XFRACAS - Date Format - Short" String preferences).

  • **XFRACAS - Display Day Before Month in Date Input Fields**: If True, Date input fields will display using the day before month format (e.g., "21 March 2017").

  • **XFRACAS - Display Time with Date Fields**: If True, the Time input fields will be displayed with applicable Date fields.

  • **XFRACAS - Display Time in 24 Hour Format**: If True, the Time field will display using a 24-hour clock. If False, it will display an A.M./P.M. indicator.
Chapter 5: Managing Preferences

- **XFRACAS - Enable Header in Printed Records**: If True, the print logo and full entity name will appear in the document header when records are printed using the Print Preview command on the Home tab. To change the logo, you can replace the logopfv.gif file stored in the Images folder on the web server (e.g., C:\inetpub\wwwroot\XFRACAS\Images\logopfv.gif).

- **XFRACAS - Sort Statuses by Descending Date**: If True, the notes in the Status fields will be displayed in descending order based on creation date (i.e., the oldest note is listed first).

- **XFRACAS - Testing Mode**: If True, a "watermark" that reads "TESTING" will be placed in the background of the pages to indicate that the "testing" version of the system is distinguished from the actual "live" system.

## Date Preferences

- **Fiscal Year Begins**: The start date of the fiscal year, which is used to determine the current quarter when reporting information based on a specified date range. The value entered must be a valid date but the current year will always be assumed when calculating the date range. For example, if the fiscal year begins on January 1st, you can enter that date with any year (01/01/2005, 01/01/2020, 01/01/2015). XFRACAS will only consider the month and day.

- **Portal - What's New Modify Date**: The date of the most recent modification to the What's New page maintained by your company (i.e., the Whatsnew.html page in the main folder on the web server where XFRACAS was installed). This page is displayed if the user has not visited the website since the page was last modified.

## Display Option Preferences

- These preferences specify which type(s) of incident can be created, and which will be selected by default.

  - **Incident - Display Part Incident Type**
  - **Incident - Display Serialized Incident Type**
  - **Incident - Display Simple Incident Type**

- These preferences specify whether the Failure Review Board (FRB) will be displayed for each step in the Problem page, and whether all assigned members are required to sign off users you can move to the next step.

  - **Problem - Display FRB - Describe the Problem**
  - **Problem - Display FRB - Implement and Verify Containment Actions**
Chapter 5: Managing Preferences

- Problem - Display FRB - Identify and Verify Root Cause
- Problem - Display FRB - Choose and Verify Permanent Corrective Actions
- Problem - Display FRB - Implement Permanent Corrective Actions
- Problem - Display FRB - Prevent Recurrence
- Problem - Display FRB - Congratulate the Team

- **XFRACAS - Language**: The default language for the interface text. If the **Language** option in the user's account is blank, the interface will display in the default language. However, if the user's account specifies a language, the interface will display in the user's preferred language instead.

- **XFRACAS - Skin**: Sets the appearance of the ribbon and some other elements within the XFRACAS interface.

### E-mail Preferences

- **Administrator E-mail**: The e-mail address used for new user account requests and the place where the "**E-mail - BCC Administrator on XFRACAS Data Sent**" Boolean preference e-mails are sent.

- **E-mail - Customer Requested Feedback Notify To**: The e-mail address where the customer requests for feedback notification will be sent if the "**E-mail – Incident Customer Requested Feedback**" Boolean preference is True.

- **E-mail - Default New Incident From**: If specified, then the e-mail address on new incidents will come FROM this address. If the TO address is not valid, then the e-mails will get bounced back to this address instead of the specific user who created the incident.

- **E-mail - SAP Work Order Request To**: The e-mail address where the SAP work order request notification will be sent if the "**E-mail – FA SAP Work Order Request**" Boolean preference is True.

- **E-mail - Single From Address**: If an e-mail address is specified, then all e-mails sent from the entity will be "from" the specified address. If it is blank, the e-mails will be "from" the specific user who initiated the e-mail.

- **Manage User - E-mail Suffix Used for Auto Build**: The suffix (e.g., @company.com) to be used for the e-mail addresses automatically generated for new users if the "**Manage User - E-mail/Login Auto Build**" Boolean preference is True.
Chapter 5: Managing Preferences

Integer Preferences

- **CSI - Hours Decimal Places**: The number of decimal places displayed in time figures in the Customer Support page.

- **CSI - Operational Availability Decimal Places**: The number of decimal places that the Operational Availability percentage in the Customer Support page will be rounded to.

- **CSI - Warranty Months**: These preferences set the number of months in the warranty period in the Customer Support page, if company-specific values have not been specified on the **Companies page**.
  
  - **CSI - Warranty Months from Commission**
  
  - **CSI - Warranty Months from Shipment**

- **CSI - X Warranty Days for Repaired/Replaced Parts**: The number of parts that were repaired or replaced in the last X days. This information will display below the associated incidents on the Customer Support page.

- **Max Units/Day**: These preferences set the maximum amount of time/usage (e.g., hours, miles, kilometers, cycles, etc.) that a serialized system may accumulate in a single day. The max value for Time Metric 1 is used in the Customer Support page to make sure the "Estimated System Hours" calculation does not exceed the maximum possible per day. It is also used if you have selected to auto-populate Time Metric 1 in the Incident page for serialized systems. (See **Time Metric Calculations**.)

Note that the max values for Time Metric 2 and 3 are relevant only if you are using a custom report that requires these inputs, or a custom method for extracting reliability data for analysis in Weibull++ or RGA.

  - **Incident - Max Units/Day - Time Metric 1**
  
  - **Incident - Max Units/Day - Time Metric 2** (only for custom functionality)
  
  - **Incident - Max Units/Day - Time Metric 3** (only for custom functionality)

- **Default Due Dates and Closure Dates**: These preferences specify the number of days from today's date to set as the default due date for a new action or the default closure dates for new problems.
  
  - **Action - Default Due Date Offset by X Days**
  
  - **Problem - Expected Closure Date Offset**
  
  - **Problem - Requested Closure Date Offset**

- These preferences specify the number of business days for e-mails based on calendar date.
• **E-mail - Action Due in X Days Offset**: The number of days prior to the action due date that the e-mail reminder will be sent.

• **E-mail - Remind Action Due Every X Days**: The number of days after the first or previous reminder of an action due date that another reminder is sent.

• **E-mail - FRB After Requested Closure in X Days Offset**: The number of business days after closure has been entered on a problem that the FRB reviewers are sent an e-mail if they have not yet signed off on it.

• **E-mail - Remind FRB After Requested Closure Every X Days**: The number of days after the first or previous notification has been sent that a reminder e-mail will be sent to the problem reviewers. This applies only to the reviewers for the final step.

• These preferences set the number of days that records will be highlighted in the XFRACAS Portal.

  • **Portal - Action Due Date Highlight Offset** (days prior to the action due date)
  
  • **Portal - Incident Due Date Highlight Offset** (days after the incident occurrence date)

  • **Portal - Problem Due Date Highlight Offset** (days prior to the problem requested closure date - if the requested closure date is turned off, then the due date is calculated)

  • **Portal - Problem to Review Due Date Highlight Offset** (days prior to the problem review due date)

  • **Portal - Project Due Date Highlight Offset** (days prior to the project due date)

• **XFRACAS - Description Number of Lines Displayed**: The default height for description fields (i.e., the maximum number of lines of text that can be visible without scrolling). For descriptions that are configurable detail fields, you can override this for a specific field by setting the **Number of Lines Displayed** in the detail properties.

• **Reports - Filter Display Max Columns**: The maximum number of optional columns that a report created in the Report Builder can include.

• **XFRACAS - System Search Timeout**: The maximum amount of time, in seconds, that the application can spend searching for a part in a system.

• **Diagnostics - Number of Exception Items Displayed**: The maximum number of items the Diagnostics page can display on a single page.

• **Active Directory - Maximum Groups to Display**: The maximum number of groups that will be displayed when loading Active Directory groups.
Chapter 5: Managing Preferences

**String Preferences**

- These preferences specify information that displays on the XFRACAS About page.
  
  - Administrator Name
  - Administrator Phone
  - Company Name
  - **Company Homepage Link**: This is the anchor text for the link. The URL is specified in the "XFRACAS - Company Homepage" URL preference.

- These preferences specify the formats of e-mails sent for incidents, failure analyses and problems. (See [Configuring E-mail Message Formats](#).)
  
  - Incident - E-mail Message Format - New
  - Incident - E-mail Message Format - Customer Feedback
  - Incident - E-mail Message Format - RMA Received
  - Failure Analysis - E-mail Message Format - Work Order
  - Problem - E-mail Message Format - New
  - Problem - E-mail Message Format - Closure Requested
  - Problem - E-mail Message Format - Reject
  - Problem - E-mail Message Format - Signed Off

- These preferences specify the formats of the e-mails for new, updated and completed actions associated with each record type. (See [Configuring E-mail Message Formats](#).)
  
  - Action - E-mail Message Format - New - CSI
  - Action - E-mail Message Format - Updated - CSI
  - Action - E-mail Message Format - Complete - CSI
  - Action - E-mail Message Format - New - Incident
  - Action - E-mail Message Format - Updated - Incident
  - Action - E-mail Message Format - Complete - Incident
  - Action - E-mail Message Format - New - FA
  - Action - E-mail Message Format - Updated - FA
  - Action - E-mail Message Format - Complete - FA
• Action - E-mail Message Format - New - Problem
• Action - E-mail Message Format - Updated - Problem
• Action - E-mail Message Format - Complete - Problem
• Action - E-mail Message Format - New - Project
• Action - E-mail Message Format - Updated - Project
• Action - E-mail Message Format - Complete - Project

• These preferences specify the format of the e-mails sent from the Status utility when a user adds a new status for the specified record type. (See Configuring E-mail Message Formats.)
  • Detail Status - E-Mail Message Format - Action
  • Detail Status - E-Mail Message Format - Incident
  • Detail Status - E-Mail Message Format - FA
  • Detail Status - E-Mail Message Format - Problem
  • Detail Status - E-Mail Message Format - Project

• For fields that use drop-down lists, each issue in the list may have an e-mail address associated with it (see Managing Lists). These preferences specify the format of the e-mail sent when one of the monitored issues is selected for a particular record. (See Configuring E-mail Message Formats.)
  • Detail Drop-down - E-Mail Message Format - CSI
  • Detail Drop-down - E-Mail Message Format - Incident
  • Detail Drop-down - E-Mail Message Format - FA
  • Detail Drop-down - E-Mail Message Format - Problem
  • Detail Drop-down - E-Mail Message Format - Project

• These preferences define the formulas used to calculate the criticality metrics for an incident or problem. (See Configuring Criticality Metrics.)
  • Criticality - Incident Actual
  • Criticality - Incident Potential
  • Criticality - Problem Base CIN
  • Criticality - Problem Current CIN
Chapter 5: Managing Preferences

- These preferences specify the formulas used to calculate the value of one time/usage metric based on the value entered for another. The behavior also depends on the "Display Time Metric" and "Always Auto-calculate Time Metric" preferences, and what the user enters in the incident page. (See Time Metric Calculations.)

  - Incident - Time Metric 1 Formula
  - Incident - Time Metric 2 Formula
  - Incident - Time Metric 3 Formula

- Problem - Default Owner: The user who will be assigned by default as the owner for new problems.

- These preferences specify the formats for dates. Note that this should match the IIS culture setting on the web server in order for dates in charts to be displayed correctly.

  - XFRACAS - Date Format - Short: Displays only the date and not the time. The default format is MM/dd/yyyy (e.g., 03/01/2017).

  - XFRACAS - Date Format - Long: Displays the time along with the date when applicable. The default format is MM/dd/yyyy hh:mm tt (e.g., 03/01/2017 01:00 PM).

    - If the "XFRACAS - Display Time in 24 Hour Format" Boolean preference is True, remove the "tt" segment from the long date format (e.g., MM/dd/yyyy hh:mm will display 03/01/2017 13:00).

    - If you want to display only the date (without the time), set to the same format as the short date field (e.g., MM/dd/yyyy) or set the "XFRACAS - Display Time with Date Fields" Boolean preference to False.

- XFRACAS Decimal Separator: The text (usually a period or comma) used to indicate the decimal place in both input and output.

- XFRACAS Thousands Separator: The separator (usually a comma, period or space) used to separate groups of thousands in both input and output.

- XFRACAS - Web Page Title Suffix: The text that will be displayed at the end of the title in the browser caption bar (e.g., "Proprietary and Confidential Information").

- Exchange ADS Path: The Active Directory Services Path used for an LDAP connection to the GAL (Global Address List). (See Entering an ADS Path.)
Time Zone Preferences

- **Default GMT Offset for New Users**: The time zone, or offset from Coordinated Universal Time (formerly known as Greenwich Mean Time), that will be used when a new user is created if a different time zone is not specified for that user.

URL Preferences

- **Tips URLs**: For many fields in XFRACAS, a help icon next to the input box opens a separate HTML page designed to provide data entry tips for that particular field. You can customize the information in these pages to meet the particular needs of your organization. By default, they are installed in the "Tips" folder on the web server (e.g., C:\inetpub\wwwroot\XFRACAS\Tips), but you can change the URLs if desired.

These preferences specify the URLs for some of the fields that have tips. For other fields that are configured from the Details page (such as the Incident Description or the Problem Description), you can specify the "Tips URL" when you edit the settings for the special detail field.

- Action - Description Tips
- Action - Result Tips
- Action - Status Tips
- CSI - Installation Detail Tips
- FA - Detailed Analysis Tips
- FA - Fault Description/Troubleshooting/Rework Tips
- FA - Initial Repairs/Comments Tips
- FA - SAP Items
- FA - Visual Inspection Tips
- Incident - Actual Criticality Tips
- Incident - Potential Criticality Tips
- Problem - Criticality Tips
- Problem - FRB Rejection Description Tips
- Project - End Result Tips
- Project - Scope of Project Tips
Chapter 5: Managing Preferences

- **XSLT Style Sheet URLs**: These preferences specify the URLs for the *.xslt style sheets for pages that have a Print Preview command in the ribbon. By default, these are installed in the "XSLT" folder on the web server (e.g., C:\inetpub\wwwroot\XFRACAS\XSLT), but you can change the URLs if desired.
  - CSI - Print Preview Style Sheet
  - FA - Print Preview Style Sheet
  - Incident - Print Preview Style Sheet
  - Problem - Print Preview Style Sheet
  - Project - Print Preview Style Sheet

- **XFRACAS - Company Homepage**: The URL of your company's home page link that displays on the XFRACAS About page. The anchor text is specified in the "Company Homepage Link" string preference.

**Target and Completed Dates**
These preferences specify whether target and/or completed date fields will display in specific areas of the Incident page and Problem page.

- Incident - Description - Show Target Date
- Incident - Description - Show Completed Date
- Incident - Resolution - Show Target Date
- Incident - Resolution - Show Completed Date
- Incident - Initial Failure Analysis - Show Target Date
- Incident - Initial Failure Analysis - Show Completed Date
- Incident - Additional Comments - Show Target Date
- Incident - Additional Comments - Show Completed Date
- Problem - Problem Description - Show Target Date
- Problem - Containment Description - Show Target Date
- Problem - Root Cause Verification - Show Target Date
- Problem - Corrective Action Description - Show Target Date
- Problem - Implement Corrective Action Description - Show Target Date
- Problem - Prevent Recurrence Description - Show Target Date
Chapter 5: Managing Preferences

- Problem - Recognize Team Description - Show Target Date

Static Pages

For some features, you can customize the interface to meet your particular needs by editing files stored directly on the web server.

- **What's New page** (Whatsnew.html) is installed in the website's main folder. The "Portal - What's New Modify Date" preference defines the date of the most recent modification to the page.

- **General Error page** (GeneralError.aspx) is installed in the website's main folder.

- **Terms of Use agreement pages** (Agreement.aspx and AdminAgreement.aspx) are installed in the website's main folder (displayed when the user visits any of the regular user pages) and in the Admin folder (displayed when the user visits any of the admin pages). To enable this feature, set the "Terms of Use Agreement Page Required" preference to True.

- **Description Criteria Link pages** are installed in the website's "Tips" folder (e.g., C:\inetpub\wwwroot\XFRACAS\Tips). If you want to use a file stored in a different location instead, edit the relevant link on the Preferences page under URL Preferences (e.g., "Incident - Actual Criticality Tips," etc.).

- **Print Preview XSLT files** are installed in the website's "XSLT" folder (e.g., C:\inetpub\wwwroot\XFRACAS\Tips). These configure the "Print Preview" output for an incident, failure analysis, problem, project or CSI. If you want to use a file stored in a different location instead, edit the relevant link on the Preferences page under URL Preferences (e.g., Incident - Print Preview Style Sheet," etc.).

*Tip:* If the record has an Attachments Table detail (also called "Associated Files"), the default XSLT templates installed with XFRACAS will display any attached image files (e.g., *.jpg, *.gif, *.jpeg or *.png) as images in the print preview. If you need to change the list of file types that are treated as images, you can modify the following code in the template:

```xml
<xsl:when test="AttachmentType = 'Blob Data' and ('jpg' = substring($imageName, string-length($imageName) - string-length('jpg') +1) or 'gif' = substring($imageName, string-length($imageName) - string-length('gif') +1) or 'jpeg' = substring($imageName, string-length($imageName) - string-length('jpeg') +1) or 'png' = substring($imageName, string-length($imageName) - string-length('png') +1))">
```

XFRACAS 2018 Admin Guide 61
Chapter 5: Managing Preferences

Configuring E-mail Message Formats

The "E-mail Message Format" preferences in the String Preferences area of the Preferences page use variables to specify which information is included in each type of e-mail.

For example, this is the default format for e-mails sent when a new action is assigned from within an incident: %1|%2|%3|%4|%5|%6|%8.

It results in e-mails like the following:

```
New Action Assigned
Action ID: 2268
Action Creator: JOHN SMITH
Action Created Date/Time: 07/12/2013 08:37 AM
Action Type: Incident Action
Incident Report: E1-16118
Action Due Date: 07/20/2013
Action Description: This is a sample description.
```

You can replace the default with your own custom format that uses any of the variables that are available for incident action e-mails. For example, if you specify a custom format like this:

```
%I1 - %1|%2|%10|%6|%8|Acme Industries - Internal Use Only
```

It results e-mails like the following:

```
New Action Assigned
Incident Report: E1-16118 - Action ID: 2268
Action Creator: JOHN SMITH
Assigned To: JILL ENGINEER
Action Due Date: 07/20/2010
Action Description: This is a sample description.

Acme Industries - Internal Use Only
```

Incident E-mail Variables

These variables related to incident records can be used in any of the following e-mail formats:

- Detail Drop-down - E-mail Message Format - Incident
- Incident - E-mail Message Format - New (also used when the incident is modified)
Chapter 5: Managing Preferences

- Incident - E-mail Message Format - Customer Feedback
- Incident - E-mail Message Format - RMA Received

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Incident Entity Display ID (with link to incident)</td>
<td>Incident Report: #E1-115</td>
</tr>
<tr>
<td>%2</td>
<td>Incident Title</td>
<td>Incident Title: Part Failed</td>
</tr>
<tr>
<td>%3</td>
<td>Incident Created By (with e-mail link)</td>
<td>Incident Creator: John Smith</td>
</tr>
<tr>
<td>%4</td>
<td>Incident Created Date and Time</td>
<td>Incident Created Date &amp; Time: 07/12/2013 07:38 AM</td>
</tr>
<tr>
<td>%5</td>
<td>Assigned To</td>
<td>Incident Assigned To: Robert Jones</td>
</tr>
<tr>
<td>%6</td>
<td>Incident Part Number</td>
<td>Incident System Part Number: 1001</td>
</tr>
<tr>
<td>%7</td>
<td>Incident Serial Number</td>
<td>Incident System Serial Number: 2</td>
</tr>
<tr>
<td>%8</td>
<td>Incident Description</td>
<td>Incident Description: Some part failure occurred...</td>
</tr>
<tr>
<td>%DTX</td>
<td>Incident Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td>%CDTX</td>
<td>Incident's Associated CSI Detail Value (X represents the detail type ID)</td>
<td>Numeric Detail: 10</td>
</tr>
<tr>
<td>%DTM</td>
<td>The value of the detail that was selected (used only for detail drop-down e-mails).</td>
<td>Detail Name: Selected Value</td>
</tr>
<tr>
<td></td>
<td>New Line</td>
<td>Starts a new line in the message</td>
</tr>
</tbody>
</table>

Problem E-mail Variables

These variables related to problem records can be used in any of the following e-mail formats:

- Detail Drop-down - E-mail Message Format - Problem
Chapter 5: Managing Preferences

- Problem - E-mail Message Format - New (also used when the problem is modified)
- Problem - E-mail Message Format - Closure Requested
- Problem - E-mail Message Format - Reject
- Problem - E-mail Message Format - Signed Off

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Problem Entity Display ID (with link to problem)</td>
<td>Problem: #E1-4</td>
</tr>
<tr>
<td>%2</td>
<td>Problem Created By (with e-mail link)</td>
<td>Problem Creator: John Smith</td>
</tr>
<tr>
<td>%3</td>
<td>Problem Created Date and Time</td>
<td>Problem Created Date &amp; Time: 07/11/2013 02:23 PM</td>
</tr>
<tr>
<td>%4</td>
<td>Problem Owner (with e-mail link)</td>
<td>Owner: Tom Smith</td>
</tr>
<tr>
<td>%5</td>
<td>Problem Title</td>
<td>Problem Title: Parts</td>
</tr>
<tr>
<td>%6</td>
<td>Problem Description</td>
<td>Problem Description: Part Reports</td>
</tr>
<tr>
<td>%DTX</td>
<td>Problem Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td>%DTM</td>
<td>The value of the detail that was selected (used only for detail drop-down e-mails).</td>
<td>Detail Name: Selected Value</td>
</tr>
<tr>
<td></td>
<td>New Line</td>
<td>Starts a new line in the message</td>
</tr>
</tbody>
</table>

**Project E-mail Variables**

These variables related to project records can be used with this e-mail format:

- Detail Drop-down - E-mail Message Format - Project

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Project Entity Display ID (with link to project)</td>
<td>Project: #E1-4</td>
</tr>
</tbody>
</table>
### Chapter 5: Managing Preferences

<table>
<thead>
<tr>
<th>%2</th>
<th>Project Owner</th>
<th>Project Owner: John Smith</th>
</tr>
</thead>
<tbody>
<tr>
<td>%3</td>
<td>Project Start Date and Time</td>
<td>Project Start Date: 07/11/2013 02:23 PM</td>
</tr>
<tr>
<td>%4</td>
<td>Project Title</td>
<td>Project Title: Part Redesign</td>
</tr>
<tr>
<td>%5</td>
<td>Project Scope</td>
<td>Project Scope: To identify problems with the redesign process and implementation</td>
</tr>
<tr>
<td>%DTX</td>
<td>Project Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td>%DTM</td>
<td>The value of the detail that was selected (used only for detail drop-down e-mails).</td>
<td>Detail Name: Selected Value</td>
</tr>
<tr>
<td></td>
<td>New Line</td>
<td>Starts a new line in the message</td>
</tr>
</tbody>
</table>

**CSI E-mail Variables**

These variables related to CSI records can be used with the following e-mail format:

- **Detail Drop-down - E-mail Message Format - CSI**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Customer Support Information Entity Display ID (with link to CSI)</td>
<td>Incident Report: #E1-115</td>
</tr>
<tr>
<td>%2</td>
<td>Customer Support Information Author</td>
<td>CSI Author: Tom Smith</td>
</tr>
<tr>
<td>%3</td>
<td>Customer Support Information Shipment Date</td>
<td>Shipment Date: 05/21/2013 03:32 PM</td>
</tr>
<tr>
<td>%4</td>
<td>Customer Support Information Commission Date</td>
<td>Commission Date: 05/26/2013 09:01 AM</td>
</tr>
<tr>
<td>%5</td>
<td>Customer Support Information Decommission Date</td>
<td>Decommission Date: 07/15/2013 04:44 PM</td>
</tr>
</tbody>
</table>
### Chapter 5: Managing Preferences

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%6</td>
<td>Customer Support Information System Configuration</td>
<td>System Configuration: 867978, Part 1983 ver. 1</td>
</tr>
<tr>
<td>%DTX</td>
<td>CSI Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td>%CDTX</td>
<td>Incident's Associated CSI Detail Value (X represents the detail type ID)</td>
<td>Numeric Detail: 10</td>
</tr>
<tr>
<td>%DTM</td>
<td>The value of the detail that was selected (used only for detail drop-down e-mails).</td>
<td>Detail Name: Selected Value</td>
</tr>
<tr>
<td>1</td>
<td>New Line</td>
<td>Starts a new line in the message</td>
</tr>
</tbody>
</table>

### Failure Analysis E-mail Variables

These variables related to failure analysis records can be used in any of the following e-mail formats:

- **Detail Drop-down - E-mail Message Format - FA**
- **Failure Analysis - E-mail Message Format - Work Order**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Failure Analysis Entity Display ID (with link to failure analysis report)</td>
<td>Failure Analysis Report: #E1-9</td>
</tr>
<tr>
<td>%2</td>
<td>Failure Analysis Created By</td>
<td>Created By: John Smith</td>
</tr>
<tr>
<td>%3</td>
<td>Failure Analysis Created Date and Time</td>
<td>FA Report Open Date: 07/13/2013 01:23 PM</td>
</tr>
<tr>
<td>%4</td>
<td>Incoming Part Number</td>
<td>Incoming Part #: 5309a</td>
</tr>
<tr>
<td>%5</td>
<td>Incoming Part Description</td>
<td>Incoming Part Description: Parts</td>
</tr>
<tr>
<td>%6</td>
<td>Incoming Serial Number</td>
<td>Incoming Serial #: 867</td>
</tr>
<tr>
<td>%7</td>
<td>System Part Number</td>
<td>System Part #: 5309b</td>
</tr>
</tbody>
</table>
### System Part Description

- **System Part Description**: Parts

### System Serial Number

- **System Serial #: 1943**

### Failure Analysis Detail Value (X represents the detail type ID)

- **Text Detail: Value**

### The value of the detail that was selected (used only for detail drop-down e-mails).

- **Detail Name: Selected Value**

### New Line

- **Starts a new line in the message**

---

### Incident Action E-mail Variables

These variables related to incident action records can be used in any of the following e-mail formats:

- **Action - E-mail Message Format - New - Incident**
- **Action - E-mail Message Format - Updated - Incident**
- **Action - E-mail Message Format - Complete - Incident**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Action ID (with link to action)</td>
<td>Action ID: #128</td>
</tr>
<tr>
<td>%2</td>
<td>Action Created By Name (with e-mail link)</td>
<td>Action Creator: John Smith</td>
</tr>
<tr>
<td>%3</td>
<td>Action Created Date and Time</td>
<td>Action Created Date/Time: 07/12/2013 08:38 AM</td>
</tr>
<tr>
<td>%4</td>
<td>Action Type</td>
<td>Action Type: Incident Action</td>
</tr>
<tr>
<td>%5</td>
<td>Associated ID (with link to incident)</td>
<td>Incident Report: E1-115</td>
</tr>
<tr>
<td>%6</td>
<td>Action Due Date</td>
<td>Action Due Date: 08/12/2013</td>
</tr>
<tr>
<td>%7</td>
<td>Action Complete Date</td>
<td>Action Complete Date: 08/02/2013</td>
</tr>
<tr>
<td>%8</td>
<td>Action Description</td>
<td>Action Description: Description...</td>
</tr>
<tr>
<td>%9</td>
<td>Action Result</td>
<td>Action Result: Result description...</td>
</tr>
<tr>
<td>%10</td>
<td>Action Assigned To</td>
<td>Assigned To: John Smith</td>
</tr>
<tr>
<td>%11</td>
<td>Incident Entity Display ID (with link to incident)</td>
<td>Incident Report: #E1-115</td>
</tr>
<tr>
<td>%12</td>
<td>Incident Title</td>
<td>Incident Title: Part Failed</td>
</tr>
<tr>
<td>%13</td>
<td>Incident Created By (with e-mail link)</td>
<td>Incident Creator: John Smith</td>
</tr>
<tr>
<td>%14</td>
<td>Incident Created Date and Time</td>
<td>Incident Created Date &amp; Time: 07/12/2013 07:38 AM</td>
</tr>
<tr>
<td>%15</td>
<td>Incident Assigned To</td>
<td>Incident Assigned To: Robert Jones</td>
</tr>
<tr>
<td>%16</td>
<td>Incident Part Number</td>
<td>Incident System Part Number: 1001</td>
</tr>
<tr>
<td>%17</td>
<td>Incident Serial Number</td>
<td>Incident System Serial Number: 2</td>
</tr>
<tr>
<td>%18</td>
<td>Incident Description</td>
<td>Incident Description: Some part failure occurred...</td>
</tr>
<tr>
<td>%DTX</td>
<td>Action Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td>%IDTX</td>
<td>Incident Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td>%ICDTX</td>
<td>Incident's Associated CSI Detail Value (X represents the detail type ID)</td>
<td>Numeric Detail: 10</td>
</tr>
<tr>
<td></td>
<td>New Line</td>
<td>Starts a new line in the message</td>
</tr>
</tbody>
</table>
Problem Action E-mail Variables

These variables related to problem action records can be used in any of the following e-mail formats:

- **Action - E-mail Message Format - New - Problem**
- **Action - E-mail Message Format - Updated - Problem**
- **Action - E-mail Message Format - Complete - Problem**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Action ID (with link to action)</td>
<td>Action ID: #132</td>
</tr>
<tr>
<td>%2</td>
<td>Action Created By (with e-mail link)</td>
<td>Action Creator: John Smith</td>
</tr>
<tr>
<td>%3</td>
<td>Action Created Date and Time</td>
<td>Action Created Time/Date: 07/12/2013 10:15 AM</td>
</tr>
<tr>
<td>%4</td>
<td>Action Type</td>
<td>Action Type: Problem Action</td>
</tr>
<tr>
<td>%5</td>
<td>Associated ID (with link to problem)</td>
<td>Problem: E1-4</td>
</tr>
<tr>
<td>%6</td>
<td>Action Due Date</td>
<td>Action Due Date: 08/09/2013</td>
</tr>
<tr>
<td>%7</td>
<td>Action Complete Date</td>
<td>Action Complete Date: 08/07/2013</td>
</tr>
<tr>
<td>%8</td>
<td>Action Description</td>
<td>Action Description: Description...</td>
</tr>
<tr>
<td>%9</td>
<td>Action Result</td>
<td>Action Result: Result description...</td>
</tr>
<tr>
<td>%10</td>
<td>Action Assigned To</td>
<td>Assigned To: John Smith</td>
</tr>
<tr>
<td>%R1</td>
<td>Problem Entity Display ID (with link to problem)</td>
<td>Problem: #E1-4</td>
</tr>
<tr>
<td>%R2</td>
<td>Problem Created By (with e-mail link)</td>
<td>Created By: John Smith</td>
</tr>
<tr>
<td>%R3</td>
<td>Problem Created Date and Time</td>
<td>Problem Created Date &amp; Time: 07/11/2013 02:23 PM</td>
</tr>
<tr>
<td>%R4</td>
<td>Problem Owner (with e-mail link)</td>
<td>Owner: Tom Smith</td>
</tr>
</tbody>
</table>
Chapter 5: Managing Preferences

<table>
<thead>
<tr>
<th>%R5</th>
<th>Problem Title</th>
<th>Problem Title: Parts</th>
</tr>
</thead>
<tbody>
<tr>
<td>%R6</td>
<td>Problem Description</td>
<td>Problem Description: Part Reports</td>
</tr>
<tr>
<td>%DTX</td>
<td>Action Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td>%RDTX</td>
<td>Problem Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td></td>
<td>New Line</td>
<td>Starts a new line in the message</td>
</tr>
</tbody>
</table>

**Project Action E-mail Variables**

These variables related to project action records can be used in any of the following e-mail formats:

- **Action - E-mail Message Format - New - Project**
- **Action - E-mail Message Format - Updated - Project**
- **Action - E-mail Message Format - Complete - Project**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Action ID (with link to action)</td>
<td>Action ID: #117</td>
</tr>
<tr>
<td>%2</td>
<td>Action Created By Name (with e-mail link)</td>
<td>Action Creator: John Smith</td>
</tr>
<tr>
<td>%3</td>
<td>Action Created Date and Time</td>
<td>Action Created Time/Date: 07/12/2013 01:21 PM</td>
</tr>
<tr>
<td>%4</td>
<td>Action Type</td>
<td>Action Type: Project Action</td>
</tr>
<tr>
<td>%5</td>
<td>Associated ID (with link to project)</td>
<td>Project: E1-4</td>
</tr>
<tr>
<td>%6</td>
<td>Action Due Date</td>
<td>Action Due Date: 08/21/2013</td>
</tr>
<tr>
<td>%7</td>
<td>Action Complete Date</td>
<td>Action Complete Date: 08/13/2013</td>
</tr>
<tr>
<td>%8</td>
<td>Action Description</td>
<td>Action Description: Description...</td>
</tr>
</tbody>
</table>
### CSI Action E-mail Variables

These variables related to CSI action records can be used in any of the following e-mail formats:

- **Action - E-mail Message Format - New - CSI**
- **Action - E-mail Message Format - Updated - CSI**
- **Action - E-mail Message Format - Complete - CSI**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Action ID (with link to action)</td>
<td>Action ID: #203</td>
</tr>
<tr>
<td>%2</td>
<td>Action Created By Name (with e-mail link)</td>
<td>Action Creator: John Smith</td>
</tr>
<tr>
<td>%3</td>
<td>Action Created Date and Time</td>
<td>Action Created Time/Date: 07/16/2013 11:16 PM</td>
</tr>
<tr>
<td>%4</td>
<td>Action Type</td>
<td>Action Type: CSI Action</td>
</tr>
<tr>
<td>%5</td>
<td>Associated ID</td>
<td>Customer Support: E1-9</td>
</tr>
<tr>
<td>%6</td>
<td>Action Due Date</td>
<td>Action Due Date: 08/27/2013</td>
</tr>
<tr>
<td>%7</td>
<td>Action Complete Date</td>
<td>Action Complete Date: 08/19/2013</td>
</tr>
<tr>
<td>%8</td>
<td>Action Description</td>
<td>Action Description: Description...</td>
</tr>
<tr>
<td>%9</td>
<td>Action Result</td>
<td>Action Result: Result description...</td>
</tr>
<tr>
<td>%10</td>
<td>Action Assigned To</td>
<td>Assigned To: John Smith</td>
</tr>
<tr>
<td>%C1</td>
<td>Customer Support Information Entity Display ID</td>
<td>CSI: #E1-9</td>
</tr>
<tr>
<td>%C2</td>
<td>Customer Support Information Author</td>
<td>CSI Author: Tom Smith</td>
</tr>
<tr>
<td>%C3</td>
<td>Customer Support Information Shipment Date</td>
<td>Shipment Date: 05/21/2013 03:32 PM</td>
</tr>
<tr>
<td>%C4</td>
<td>Customer Support Information Commission Date</td>
<td>Commission Date: 05/26/2013 09:01 AM</td>
</tr>
<tr>
<td>%C5</td>
<td>Customer Support Information Decommission Date</td>
<td>Decommission Date: 07/15/2013 04:44 PM</td>
</tr>
<tr>
<td>%C6</td>
<td>Customer Support Information System Configuration</td>
<td>System Configuration: 867978, Part 1983 ver. 1</td>
</tr>
<tr>
<td>%DTX</td>
<td>Action Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td>%PDTX</td>
<td>Customer Support Information Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td></td>
<td>New Line</td>
<td>Starts a new line in the message</td>
</tr>
</tbody>
</table>
## Failure Analysis Action E-mail Variables

These variables related to failure analysis action records can be used in any of the following e-mail formats:

- **Action - E-mail Message Format - New - FA**
- **Action - E-mail Message Format - Updated - FA**
- **Action - E-mail Message Format - Complete - FA**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Action ID (with link to action)</td>
<td>Action ID: #121</td>
</tr>
<tr>
<td>%2</td>
<td>Action Created By Name (with e-mail link)</td>
<td>Action Creator: John Smith</td>
</tr>
<tr>
<td>%3</td>
<td>Action Created Date and Time</td>
<td>Action Created Time/Date: 07/12/2013 09:32 AM</td>
</tr>
<tr>
<td>%4</td>
<td>Action Type</td>
<td>Action Type: Failure Analysis Action</td>
</tr>
<tr>
<td>%5</td>
<td>Associated ID</td>
<td>Failure Analysis: E1-3</td>
</tr>
<tr>
<td>%6</td>
<td>Action Due Date</td>
<td>Action Due Date: 08/21/2013</td>
</tr>
<tr>
<td>%7</td>
<td>Action Complete Date</td>
<td>Action Complete Date: 08/13/2013</td>
</tr>
<tr>
<td>%8</td>
<td>Action Description</td>
<td>Action Description: Description...</td>
</tr>
<tr>
<td>%9</td>
<td>Action Result</td>
<td>Action Result: Result description...</td>
</tr>
<tr>
<td>%10</td>
<td>Action Assigned To</td>
<td>Assigned To: John Smith</td>
</tr>
<tr>
<td>%F1</td>
<td>Failure Analysis Entity Display ID</td>
<td>Failure Analysis Report: #E1-3</td>
</tr>
<tr>
<td>%F2</td>
<td>Failure Analysis Created By</td>
<td>Created By: John Smith</td>
</tr>
<tr>
<td>%F3</td>
<td>Failure Analysis Created Date and Time</td>
<td>FA Report Open Date: 07/13/2013 01:23 PM</td>
</tr>
</tbody>
</table>
### Status E-mail Variables

These variables (related to the status updates that users can add in incidents, actions, failure analysis, problems or projects) can be used in any of the following e-mail formats:

- **Detail Status - E-mail Message Format - Action**
- **Detail Status - E-mail Message Format - Incident**
- **Detail Status - E-mail Message Format - FA**
- **Detail Status - E-mail Message Format - Problem**
- **Detail Status - E-mail Message Format - Project**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Status Added By (with link to send e-mail to user)</td>
<td>Status Added By: John Smith</td>
</tr>
<tr>
<td>%2</td>
<td>Date and Time</td>
<td>Date &amp; Time: 07/11/2013 02:23 PM</td>
</tr>
</tbody>
</table>
E-Mails Based on Calendar Date

You can configure XFRACAS to send reminder e-mails when actions are approaching their due dates or are past due, and when Failure Review Board members need to sign off on a step in a problem.

E-mail Reminders for Actions

For actions, you set how many days prior to an action being due that the action owner will receive an e-mail. You can also configure XFRACAS to send follow-up reminders every X days until the action is completed.

Set the following preferences to send e-mails when the action's due date is approaching.

- Specify which record types to send e-mails for and define the format of the e-mails:
  - E-mail - CSI Action Due Date and Action - E-mail Message Format - Complete - CSI
  - E-mail - Incident Action Due Date and Action - E-mail Message Format - Complete - Incident
  - E-mail - FA Action Due Date and Action - E-mail Message Format - Complete - FA
  - E-mail - Problem Action Due Date and Action - E-mail Message Format - Complete - Problem
  - E-mail - Project Action Due Date and Action - E-mail Message Format - Complete - Project
  - E-mail - Action Due in X Days Offset - the number of days prior to the action due date that the e-mail will be sent.
Chapter 5: Managing Preferences

If you also want XFRACAS to continue to send follow-up reminders until the action is completed, set the following preferences:

- **E-mail - Send Action Due Notify Once** - set to False so that additional e-mails will be sent at regular intervals. (If it is set to True, then only the initial e-mail will be sent.)

- **E-mail - Remind Action Due Every X Days** - the number of days after the first or previous reminder that another e-mail will be sent.

**E-mail Reminders for Failure Review Board Members**

For a problem Failure Review Board (FRB), you set how many days after a problem step has entered a Completed Date that the FRB members will receive an e-mail. You can also configure XFRACAS to send follow-up reminders every X days until they approve the problem step.

Set the following preferences to send e-mails when a problem step is ready to be signed off.

- **E-mail - FRB After Requested Closure in X Days Offset** - the number of days after a step’s Completed Date has been entered that an e-mail will be sent to the FRB reviewers if they have not already signed off on the step.

- **E-mail - Remind FRB After Requested Closure Every X Days** - the number of days after the first or previous reminder that another e-mail will be sent.

- **Problem - E-mail Message Format - Closure Requested** - the format of the e-mails.

**Time Metric Calculations**

If you configure XFRACAS to track incidents and part repairs/replacements for specific serialized systems, you will be able to capture time/usage data that can be used for reliability data analysis.

There will always be one primary time/usage metric (Time Metric 1) and you can choose to enable up to two additional fields if desired (Time Metric 2 and Time Metric 3). By default, these fields are called "System Hours," "Number of Starts" and "kW Run Hours," but you can record any metric(s) of interest (hours, miles, kilometers, cycles, etc.) and use the Resource Manager to modify the interface labels.

**Reported System Hours**

The Customer Support page for a serialized system displays the latest reported value(s) for the time/usage metric(s) enabled for the entity. This information can be obtained from a) incidents reported for the serialized system, b) manual entry via the Customer Support interface and/or c) usage data imported from an external source.
Click the link to see the history of all usage reports for that particular system. Click + to manually enter new information.

Estimated System Hours
For the primary metric only (Metric 1), the Customer Support page also displays the estimated usage at today's date. If there are at least two reported values for the system's actual time/usage, the estimate is calculated as follows:

\[(\text{Commission Date} - \text{Today's Date}) \times \text{Average Usage per Day}\]

To estimate the average usage per day, XFRACAS fits a slope to the reported time/usage values. However, if the estimate exceeds the maximum possible per day (which is specified in the "Incident - Max Units/Day - Time Metric 1" preference), the max per day will be used instead.

This estimate is used for CSI MTBF calculations (discussed below) and may also be incorporated into custom reports and charts if applicable.

Auto-Populate Time Metric 1
By default, users will be prompted to enter the time/usage metric(s) in each incident report for a serialized system. Alternatively, you can configure XFRACAS to automatically populate the primary metric (Metric 1) when the following preferences and inputs are available:

- **Preferences:**
  - Incident - Auto-populate Time Metric 1 is True
  - Incident - Max Units/Day - Time Metric 1 is a number greater than 0

- **Incident:**
  - Serial Number has been entered
  - Occurrence Date has been entered

- **Customer Support:**
  - Commission Date has been entered and it is earlier than the incident's Occurrence Date

If the "System Down Event" field (a special Detail field for incidents) is not enabled for the entity, the calculation is as follows:

\[(\text{Commission Date} - \text{Occurrence Date}) \times \text{Max Units/Day}\]
Chapter 5: Managing Preferences

If the "System Down Event" field is enabled, the downtime is obtained from any incidents for the serialized system where this check box is selected. For each incident, the time down is the Repair Date - Occurrence Date (or if a repair has not been entered, it is Today's Date - Occurrence Date). The calculation to auto-populate Metric 1 is:

\[(\text{Commission Date} - \text{Occurrence Date} - \text{Time Down}) \times \text{Max Units/Day}\]

**Auto-Calculate Time Metric 1, 2 or 3**

You can also configure XFRACAS to automatically calculate a time metric based on the value for another metric. For example, if Metric 1 is miles, you can configure Metric 2 as kilometers and calculate it automatically based on the value entered for miles \((t1 \times 1.60934)\). The behavior depends on the following preferences and what the user enters in the incident page.

- **Incident - Display Time Metric [2/3]**
- **Incident - Always Auto-calculate Time Metric [1/2/3]**
- **Incident Time Metric [1/2/3] Formula**

**Configuring Metric Settings and Formulas**

It is important to be aware that the Preferences page does not prevent you from saving incompatible settings or invalid formulas, which may result in unexpected behavior for the metric fields in incidents. Note that:

- If the formula is blank, the field saves the entered value, regardless of whether "Auto-calculate" is true.
- If the formula is not blank and "Always Auto-calculate" is true, the field attempts to calculate the value. If the formula is invalid, the calculated value will be 0.
- If the formula is not blank and "Always Auto-calculate" is false, the field EITHER saves the entered value OR attempts to calculate if a value was not entered. For example, this configuration may be appropriate if some incidents have usage reported in Metric 1 and other incidents have usage reported in Metric 2.

Also note that:

- Operands and operators must be separated by spaces.
- Valid operators are * / + and -.
- A valid operand can be a number, a time metric field (t1, t2 or t3) or a list of parameters (e.g., \([t1,t2]\)) that will be checked in order until a parameter is found that is not 0.
  - A metric's formula should not refer to itself. For example, the formula for Metric 1 should not be \(t1 \times 20\).
• A metric's formula should not refer to a metric that is not enabled.

• A metric's formula should not refer to a metric that is already set to auto-calculate. For example, if the formula for Metric 2 is \( t_1 \times 30 \) (e.g., 30 miles for every hour), do not set the formula for Metric 3 as \( t_2 \times 1.60934 \) (e.g., 1.60934 km for every mile). Instead, set it to \( t_1 \times 48.202 \) (e.g., 48.202 km for every hour).

**MTBF, MTBCF, MTBNCF and MTBI**

The Customer Support page provides the option to display some very basic reliability metrics based only on the data from a single serialized system. If the preferences are enabled, the MTBF metrics are calculated as follows:

\[
\text{Number of Incidents ÷ Total Time/Usage}
\]

Although we recommend to use Weibull++ or RGA for more robust reliability analysis whenever possible, the CSI MTBF metrics may be used, for example, if you need to monitor a specific machine in a manufacturing line to determine whether it is meeting the contracted MTBF.

The CSI page displays two values for each metric (e.g., MTBF / MTBFE). The first is based on the reported usage for Metric 1; the second is based on the estimated usage.

Since an incident may be a "chargeable failure" or a "non-chargeable failure" depending on the Incident Category, there's a choice of four metrics that can be displayed:

- **CSI - Display MTBF** (mean time between failures) and **CSI - Display MTBCF** (mean time between chargeable failure incidents) are the same metric
- **CSI - Display MTBNCF** is the mean time between non-chargeable failure incidents
- **CSI - Display MTBI** is the mean time between incidents (both chargeable and non-chargeable)

**Extract Data for Reliability Analysis**

For more robust reliability analysis, you can use the Synthesis Data Warehouse (SDW) in ReliaSoft Weibull++/ALTA or RGA desktop applications to extract data from XFRACAS that can be used for either life data analysis or reliability growth analysis.

For information about using the desktop applications to extract the data and transfer to an analysis folio, please see Extracting Data from XFRACAS in the desktop application's help files. The extraction process for life data analysis works as follows:

1. **Select Parts** - The user selects one part or multiple parts to be analyzed together in the same data set.

2. **Get Data from Serialized Incidents**
Chapter 5: Managing Preferences

a. The SDW identifies all serialized systems that contain the specified part(s).

b. For each serialized system, the SDW finds all "serialized incidents" and orders by occurrence date to build a timeline.

   i. The SDW finds all incidents within the timeline in which the specified part(s) were repaired or replaced.

   ii. The SDW checks the "Failure Type" for the repair and the "Incident Category" for the incident:

       1. If both are chargeable (e.g., repair is "Primary Failure" and incident is "Component Failure"), then the incident is treated as a Failure (F).

       2. If one or both are non-chargeable (e.g., repair is "Primary Failure" but the incident is "ASP Error"), then the incident is treated as a Suspension (S).

3. Get Data from Part Incidents

   a. The SDW finds all "part incidents" in which the specified part(s) were repaired or replaced.

   b. The SDW checks the "Failure Type" for the repair and the "Incident Category" for the incident (as described above) to determine if the incident will be treated as a Failure (F) or Suspension (S).

Configuring Criticality Metrics

To configure a criticality formula in the String Preferences area of the Preferences page, the formula must consist of one of the following:

- A number (e.g., 7, 12.4, etc.).

- A criticality field, represented by "c" plus the field’s display order. For example, c2 or c4. The field’s display order is set and shown in the Criticality page.

- A list of numbers or criticality fields separated by commas, surrounded by brackets. For example, [c4,c3,c2] or [c7,c5,9].

Every number or criticality field (except those in brackets) must be separated by one of the following math operators: *, /, + or -.

The formula requires a space between the numbers and math operators but not between the items in brackets.
The formula is parsed from left to right with numbers or criticality fields alternating with math operators. When a bracketed list is encountered, the list is checked for any value that is not a 0. The first value that is not a 0 is the value that is used in the formula.

The default Incident Potential Criticality formula is \( c_1 \times c_2 \times c_3 \). In this formula, criticality field 1, criticality field 2 and criticality field 3 are multiplied together.

The default Problem Current CIN formula is \( c_1 \times c_2 \times c_3 \times [c_6,c_5,c_4] \times c_7 \). In this formula, criticality field 1, criticality field 2 and criticality field 3 are multiplied together. Next, criticality field 6, then criticality field 5 and then criticality field 4 are checked for 0. The first criticality field that does not contain a 0 is multiplied into the formula and the two other criticality fields are ignored. Finally, the formula is multiplied by criticality field 7.

**Entering an ADS Path**

This topic is relevant if you wish to be able to use the [Active Directory](#) page to add users from Microsoft Active directory.

The Active Directory Services (ADS) path uniquely represents each object in the Active Directory Service. This can be compared to your mailing address. If the path showed "United States, Arizona" then all addresses in the state would be displayed, while "United States, Arizona, Pima County, Tucson, Eastside Loop" would display only the addresses on that street.

To retrieve the network’s Global Address List (GAL), you can enter the correct ADS path for a Lightweight Directory Access Protocol (LDAP) connection in the Exchange ADS Path preference, which is located in the String Preferences area of the Preferences page. LDAP is a set of protocols used to access contact information from a server (in this case, a Windows Active Directory server). This path is necessary to retrieve e-mail addresses from the network's GAL. If this functionality is not necessary or not desired, the three Exchange preferences can be left blank. If your server supports CDO 1.21, the Exchange ADS Path preference can be left blank and the Exchange Profile Name and Exchange Server Name preferences can be used to access the network's GAL via a CDO connection.

The best way to determine the exact ADS path for your needs is to use Microsoft's ADSI Edit program. ADSI Edit is included with the Windows 2000 Support Tools on the Windows 2000 CD-ROM and with the Windows Support Tools on the Windows Server 2003 CD-ROM. Microsoft's [Knowledge Base article 312299](#) describes the usage of ADSI Edit.

**LDAP Connection String Examples**

While each ADS path will be unique, the following will show the general format used in an ADS path.

- A Windows NT/Exchange 5.x system might look something like this:

  LDAP://ExchangeServer/o=Organization/ou=Site/cn=Recipients
Chapter 5: Managing Preferences

- A Windows/Exchange 2000/2003/2008 system might look something like this:
  
  LDAP://YourDomain.local/CN=Users,DC=YourDomain,DC=local

- If there is a problem resolving the name, try the IP Address:

  LDAP://10.0.0.25/CN=Users,DC=YourDomain,DC=local
Chapter 6: Managing Configurable Fields

Managing Detail Fields

Use the Details page to manage configurable fields in various record types. Permissions required to access this page: Access Admin Tab and Manage Details.

To open the page, choose Admin > Configure > Details.

If your implementation has more than one entity, the detail fields can be configured separately for each. The drop-down list at the top of the page determines which entity's detail fields are currently displayed.

Types of Detail Fields

- **Action Fields** appear in the Action page.
- **Company Fields** appear in the Companies page.
- **Contact Fields** appear in the Contacts page.
- **CSI Fields** appear in the Customer Support page. You can specify the sections where the fields will appear.
- **FA Fields** appear in the Failure Analysis page. You can specify the sections where the fields will appear.
- **Incident Fields** appear in the Incident page. You can specify the sections where the fields will appear.
- **Location Fields** appear in the Locations page.
- **Part Fields** appear in the parts that are associated with system templates.
- **Problem Fields** appear in the Problem page. You can specify the sections where the fields will appear.
- **Project Fields** appear in the Project page. You can specify the sections where the fields will appear.
- **Serialized Part Fields** appear in the parts that are associated with serialized systems.

The options depend on the type of field (description, date, check box, etc.) and the type of record (incident, problem, etc.). Some of the current settings are displayed in parentheses.
under the field name. In the following example, the "Custom Text Field" will display in the first detail field position in the "Incident Details" area of the Incident page, and it will be read-only after a value is entered. The "Custom Date Field" will display in the second portion of that area, and is required (red text).

Fields identified with an asterisk (*) are referred to as "special detail fields" and can be retired but not deleted.

Adding or Editing a Field

To add a new field, click the Add icon for the relevant record type. To edit an existing field, first select the radio button to the left of the field and then click Edit.

Note that you can use the same detail field in multiple entities, if desired. The Add or Remove Entities area shows the entities that you have access to, and allows you to choose which ones will include the detail field you're currently editing. If you do not have access to all the entities where a field is used, you can add or remove it from the entities that you have access to, but you can't edit the other options.

- If applicable, select the area that the field will appear in from the Section or Step drop-down list.
- Select a Field Type from the drop-down list.
- Enter the Field Name (the label shown in the interface) and Field Description (the tip that appears when a user points to the field).
- Specify whether user input is Optional/Required. This option is not available for the following field types: Accessory; Attachments Table; Check Box; Separator; Status.
- Specify the Display Order, which determines where the field will be displayed in the page. If you don't specify a value, XFRACAS will automatically assign one. If the display order numbers are not in sequence (e.g., 1, 2, 4), then a blank space will fill that position.
- Span width of page forces the detail field to span the entire width of the area on the page. If not selected, the field will display at its default width, which varies depending on the field type.
- Specify the Default Value that will be displayed on new record creation, if applicable. This option is not available for the following field types: Accessory; Address;
Attachments Table; Company; Current System Users; Failure Mode; Separator; Status; System Contacts; Tree.

- For some detail types (e.g., select list, tree, etc.), you will need to use the Lists page to configure values that will be available to select. When you create the detail, you can choose an Existing Dropdown or leave the option blank so XFRACAS will create a new list.

- **Read-only** allows you to make the detail unavailable to edit in certain circumstances. The options depend on the field and/or record type.
  
  - **Always** - the field is always read-only in the web interface (e.g., because the value is intended to be imported). If the value is imported incorrectly, only a user with the "Details - Overwrite Read-Only" permission will be able to modify it.
  
  - **After a value is entered** - once a user enters a value in the field, it can't be changed.

- Specify the **Number of Lines Displayed**. This option is available for the Description field type only. If not specified, then the number of lines displayed is set by the XFRACAS - Description Number of Lines Displayed preference.

### Deleting or Retiring a Field

- To remove or retire a field, first select it and then click the **Delete** icon, 🗑️.
  
  - If the field is a special detail field (identified with an asterisk) or has already been used in any existing records, it will be retired for the current entity and appear grayed out.
  
  - If the field has never been used in any existing records, it will be completely removed.

- To unretire a detail field, select the field name and click the **Edit** icon, 🖊️. You will see a message confirming that you want to unretire the detail field. Click **OK** to proceed.

### Using Space and Separators

If you want to add or remove space above a particular detail, select the radio button to the left of the field and then click the **Add Space** or **Delete Space** links for the relevant record type.

If you want to add a line within an area of the space, add a "Separator" detail. The Field Description will display as a label within the page, and the Field Name will display as a tip when the user points to the separator. If you leave both fields blank, only the line will be displayed.
Chapter 6: Managing Configurable Fields

In the following example, there are 4 extra spaces between a custom description field (in position 4) and a separator (in position 9) that identifies a custom sub-section within two list fields (positions 10 and 11).

Field Types

The following types of detail fields can be created:

- **Accessory**: a drop-down list from which users can select multiple options, each of which involves a description, a part number and a serial number. The options in the list will be controlled by the users via Add, Edit and Delete icons that appear next to the list.

- **Address**: a drop-down list displaying the combinations of company and location that have been defined for your implementation.

- **Alphanumeric Input Box**: an input box in which users can enter letters and numbers. You can set a maximum length between 1 and 255 characters; the default maximum is 50 characters.

- **Attachments Table**: a table that allows users to create attachments.

- **Check Box**: a check box that users can select or clear.

- **Company**: a drop-down list displaying all companies that have been defined for your implementation.

- **Contacts**: a drop-down list displaying all contacts that have been defined for your implementation.

- **Currency**: an input box in which users can only enter numbers. The input is interpreted as currency. You can specify the number of decimal places to display, the minimum and/or maximum acceptable value that can be entered in the field and the world currency type.

- **Date**: a date field.

- **Description**: an input box in which users can enter letters and numbers. You can set a maximum length between 1 and 4,000 characters; the default maximum is 4,000 characters.
characters. You can select the Allow Existing Text Search check box to allow users to choose text that has already been used in the field in other records.

- **Failure Mode**: a field controlled by two drop-down lists from which users can select options, one for failure mode and one for root cause. The options in the lists will be determined by the failure modes and root causes of failure modes assigned to the parts on the Templates page. It is also possible to allow users to add options to the list by selecting the Allow User Creation check box. This field type is available only for the Failure Analysis, Incident and Problem pages.

- **Hyperlink**: a hyperlink that allows linking to an external site with the ability to pass variables. (See Configuring Hyperlink Details).

- **Item Category**: a field that allows users to select from the same list of item categories that are defined in the data for ReliaSoft desktop applications. This is used when importing or synchronizing parts and failure mode data from XFMEA, RCM++ or RBI. (See Import or Sync from XFMEA.)

- **Multiple List**: a list from which users can select multiple options. The options in the list will be controlled by the users via Add, Edit and Delete icons that appear next to the list.

- **Numeric Input Box**: an input box in which users can only enter numbers. You can specify the number of decimal places to display and the minimum and/or maximum acceptable value that can be entered in the field.

- **Print Preview**: a link that provides a print preview of the page, based on the *.xslt file specified for the field. This field type is available only for the CSI, Failure Analysis, Incident, Problem and Project pages.

- **Select List, Administrative Controlled**: a drop-down list from which users can select an option. The options in the list will be controlled via the Lists page. It is also possible to allow users to add options to the list by selecting the Allow User Creation check box. If you want to use the same list of values as an existing detail field within the current entity, select the name of that field from the Existing Dropdown list.

- **Select List, Administrative Controlled, Multiple**: a drop-down list from which users can select multiple options. The options in the list will be controlled via the Lists page. It is also possible to allow users to add options to the list by selecting the Allow User Creation check box. If you want to use the same list of values as an existing detail field within the current entity, select the name of that field from the Existing Dropdown list.

- **Select List, Checkbox Options, Multiple**: a list from which users can select multiple options by selecting a check box for each. Note that pointing to a selected option will display a tool tip indicating the user who checked the item and the time it was checked. The options in the list will be controlled via the Lists page. It is also possible to allow users to add options to the list by selecting the Allow User Creation check box. If you
want to use the same list of values as an existing detail field within the current entity, select the name of that field from the Existing Dropdown list.

- **Select List, User Controlled, Multiple**: a drop-down list from which users can select multiple options. The options in the list will be controlled by the users via Add, Edit and Delete icons that appear next to the list.

- **Separator**: a horizontal line. Note that the Field Name will be the tool tip that appears when a user points to the field and the Field Description will be shown as a label below the separator.

- **Status**: a status table with an Add icon that allows users to add status messages. You can select the Allow Existing Text Search check box to allow users to choose text that has already been used in the field in other records.

- **Tree**: a list of values or issues organized into a tree structure. The options in the tree will be controlled via the Lists page.

- **Users**: a drop-down list displaying all current users. You can use the User Category drop-down list to specify a single user category that will be used to filter the users list, if desired. Fields of this type will have an icon, ⤵️, that allows users to select themselves from the list with a single click.

- **Yes/No Option Buttons**: Yes and No radio buttons.

### Configuring the Select Existing Utility

The Select Existing Utility enables users to reuse text from existing description and status fields in action, customer support, failure analysis, project, incident and problem records. This can help to save time on data entry, ensure consistency and facilitate brainstorming.

When the description or status is a configurable detail field, you can choose whether the feature will be available for that particular field. You can also choose which users will be able to access the utility when it is available.

### Enable the Search Feature for Selected Detail Fields

When you create or modify a description or status field in the Details page (Admin > Configure > Details), select the Allow Existing Text Search check box to enable the feature for that field. It will be visible only to users who have the "Details - Allow Existing Text Search" permission.
Set the User Permissions
When you create or modify a user account in the Users page (Admin > Configure > Security > Users), set the following permissions to specify whether the user can access the utility when it is available.

This permission applies for detail field in any record type. This includes all of the description and status fields in incidents and problems, as well as any relevant configurable details in actions, CSIs, failure analysis reports and projects.

- **Details - Allow Existing Text Search**

These permissions apply for description and status fields that are built-in for a specific record type (e.g., action descriptions, failure analysis visual inspection, etc.).

- **Action - Allow Existing Text Search**
- **CSI - Allow Existing Text Search**
- **Failure Analysis - Allow Existing Text Search**
- **Project - Allow Existing Text Search**

Configuring Hyperlink Details
A hyperlink detail allows linking to an external site with the ability to pass variables.

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Entity Display ID (the record number, such as &quot;E1-1&quot;)</td>
</tr>
<tr>
<td>%2</td>
<td>User ID (ID of the currently logged in XFRACAS user)</td>
</tr>
</tbody>
</table>
Chapter 6: Managing Configurable Fields

<table>
<thead>
<tr>
<th>%3</th>
<th>Page ID (the internal ID of the record)</th>
</tr>
</thead>
<tbody>
<tr>
<td>%4</td>
<td>User Name (username, with domain, of the currently logged in XFRACAS user, e.g., &quot;COMPANY\USERNAME&quot;)</td>
</tr>
<tr>
<td>%5</td>
<td>Page title (title of the record)</td>
</tr>
<tr>
<td>%6</td>
<td>User Name Without Domain (username of the currently logged in XFRACAS user, but with the Windows domain stripped off. For example, &quot;COMPANY\USERNAME&quot; would be included as just &quot;USERNAME.&quot;)</td>
</tr>
<tr>
<td>%7</td>
<td>User Language Code</td>
</tr>
<tr>
<td>%DTX</td>
<td>Detail Value (X represents the detail type ID)</td>
</tr>
</tbody>
</table>

For example, the URL field for a hyperlink detail might look like this:

http://external.site.com/doStuff.cgi?record=[%1]&user=[%2]&title=[%5]&lang=[%7]

When incident E1-1, titled "Overflow," is edited by the user with ID 234, the URL generated would be:


Clicking the link opens the result in a new browser window. There is no expectation of anything being returned.

**Managing Criticality Fields**

Use the Criticality page to maintain the criticality fields that may appear in the Incident and/or Problem pages. Permissions required to access this page: Access Admin Tab and Manage Criticality.

To open the page, choose **Admin > Configure > Criticality**.

If your implementation has more than one entity, the criticality fields can be configured separately for each. The drop-down list at the top of the page determines which entity's criticality fields are currently displayed.
Using Criticality Fields

To calculate criticality metrics in the Incident page and/or the Problem page, all of the following must be configured:

- **Preferences** (See Managing Preferences)
  - Incident - Display Actual Criticality
  - Incident - Display Potential Criticality
  - Problem - Display Criticality

- **Criticality Fields and Lists**
  - Customize the fields that are installed with XFRACAS and/or create new fields to meet your particular needs.

- **Criticality Formulas** (See Configuring Criticality Metrics)
  - Customize the formula that calculates the criticality for each record based on the user's selections in the criticality fields.

Adding, Editing, Deleting or Retiring Fields

The steps to add, edit, delete or retire a criticality field are similar to managing other types of fields in the Details page. (See Managing Detail Fields.)

Note that:

- Criticality fields are automatically set to the "Select List, Administrative Controlled" field type. Use the Lists page to manage the options in the drop-down lists.

- For incident criticality fields, the Section indicates whether the field is used to calculate the potential criticality or the actual criticality. This is not relevant for problem criticality fields.

- The label under each field indicates the code that represents the field in the criticality metric formulas. For example, c2 = schedule, c3 = cost, etc.

Managing Lists

Use the Lists page to maintain the values for fields that require selection from predefined options (such as drop-down lists, trees and checkbox fields). Permissions required to access this page: Access Admin Tab and Manage Lists.

To open the page, choose Admin > Configure > Lists.
If your implementation has more than one entity, the lists can be configured separately for each, but the same list may be used in multiple entities. The drop-down list at the top of the page determines which entity's lists are currently displayed.

Some lists are defined in every XFRACAS implementation and you can configure them to meet your particular needs (see Standard Lists below). You can also create and manage custom lists that are used with certain types of configurable detail fields. Custom lists will have names like "Incident Detail - Field Name" or "Action Detail - Field Name" by default.

Editing List Properties
Each list has the following properties. The name will be the same in all entities where the list is used; the display and sort by properties, as well as the list options, may be different in each entity.

- **Name** - the label that displays on the bar in the Lists page. This may not correspond to the name of the user interface field(s) where the list is used.
- **Display** - determines whether the list will display codes, descriptions or a combination of both. For example, you could configure the list of currency types to display "USD," "US Dollars," "USD: US Dollars" or "US Dollars: USD."
- **Sort By** - determines whether the list will be sorted alphabetically or numerically, by code or description, in ascending or descending order. If you choose to sort numerically, make sure all of the options have a number in that field.

To save changes to the list's properties, click **Save**. To export the list's options to XML, click **Export**.

Adding, Editing or Deleting List Options
For each list, the table shows the options for the current entity. A check box in the last column indicates that the option will be selected by default for new records. A date in the last column indicates that the option is retired and will not be available to select for new records.

- To add a new option, click **Add**

  Tip: Some lists can have the options defined in more than one level (i.e., tree details). If an existing option is selected when you click **Add**, the new option will be added to the next level under that option. If an existing option is not selected, the new option will be added to the top level. After an option is created, you can edit the option properties to change the "parent."

- To edit an option, select it and click **Edit**
To delete or retire one or multiple options, select the option(s) and click **Delete**. If an option has never been used, it will be deleted. If it has been used, it will be retired.

To add options that have been defined for this list in another entity, click **More Issues**. In the popup window, select another entity that has the same list. The left panel shows options that are not available in the current entity, if any. To add selected options to the current entity, move them into the center panel and then click **Save**.

### Editing Option Properties

Each list option has the following properties:

- **Description** - a text label that can be up to 200 characters.
- **Code** - a number, or a shorter text label (e.g., abbreviation) that can be up to 40 characters.
- **Default** - if selected, the option will be selected by default for new records.
- **Entities** - shows the entities where the list is used. For the entities that are selected (highlighted with a gray background), this option will appear in the list in that entity.

When applicable, you may also be able to specify:

- **E-mail Address** - applies for lists used by certain types of configurable detail fields. If your implementation is configured for e-mail notifications (see **Preferences**), the application can send an e-mail when the option is selected in a record.
- **Reciprocal** - applies for the "Attachment - Record Association Type" list. It sets the options for the **Relationship Type** field in the Associated Files window. For example, if "Superseding" and "Superseded" are configured as reciprocal relationship types, users can create links between two XFRACAS records where one record is identified in the attachments table as "Superseding" and the other is identified as "Superseded."
- **Parent** - applies when options can be defined in more than one level (e.g., tree details). As discussed above, the parent is set automatically when you add a new option. You can change the parent when editing the properties for an existing option.

### Standard Lists

These lists are defined in every XFRACAS implementation:

- **Attachment – Record Association Type** - sets the options for the **Relationship Type** field in the Associated Files window. (See Attachments.)

- **Audience Restriction** - sets the options for the **Audience Restriction** field, which can be displayed in the Incident page and Problem page if the preference is enabled.
Chapter 6: Managing Configurable Fields

- **Company Sales Region** - sets the options for the Sales Region field in the Companies page. (See Managing Companies.)

- **CSI Detail - Build Designation, Market Segment, Mode of Operation and Primary Application** - sets the options for some "special detail fields" in the CSI page.

- **CSI Extended Warranty Terms** - sets the options for the Terms field in the CSI page.

- **Currency Type** - sets the options for detail fields with type = Currency.

- **FA ATP Test Result** - sets the options for the Test Results fields in the ATP / Burn-in section of the Failure Analysis page.

- **FA Customer Return Type** - sets the options for the Return Type field in the Failure Analysis page.

- **FA Status and FA Status Close** - sets the options for the FA Status field in the Failure Analysis page. The selected option determines whether a record is open or closed.

- **Incident Category Chargeable / Non-Chargeable and Incident Failure Type Chargeable / Non-Chargeable** - set the options in the Incident Category field in the Incident page and the Failure Type field in the Repair or Replace Parts utility. These determine how data are extracted for reliability analysis. (See Repairing or Replacing Parts.)

- **Incident Criticality - Cost, Criticality and Schedule** - sets the options for criticality fields in the Incident page and/or the Problem page, if the preferences are enabled. (See Managing Criticality Fields.)

- **Incident Parts Disposition** - sets the options for the Parts Disposition field in Repair or Replace Parts utility.

- **Incident Report Type** - sets the options for the Report Type field in the Incident page.

- **Incident State and Incident State Closed** - sets the options for the State field in the Incident page. The selected option determines whether a record is open or closed.

- **Incident System Status** - sets the options for the System Status field in the Incident page for serialized incidents (and for part incidents if the preference is enabled).

- **Output Record Count** - sets the options for the Records per Page field in the Output section of the Report Builder page. This determines the number of records displayed on each page of the report results.

- **Portal Link Groups** - sets the options for the Groups field in the Links panel. (See Links Panel.)
• **Problem Criticality** - Business Decision, Customer Rate, LT Rate and ST Rate - sets the options for criticality fields in the Problem page, if the preferences are enabled. (See Managing Criticality Fields.)

• **Problem Priority** - sets the options for the Priority field in the Problem page.

• **Problem Status Closed** - sets the options for the Set Close Status field that appears in the Problem page after the required number of steps have been completed.

• **Project Priority** - sets the options for the Priority field in the Project page.

• **Reporting Organization** - sets the options for the Reporting Organization field in the Users page.

• **Team Member Role** - sets the options for the Team Role field in the Assign Members utility. This may be used in the Incident, Problem and Project pages (if the preferences are enabled) and in the User Groups page. (See Assign Team Members Utility.)

### Managing Action Fields and Categories

Use the Action Management page to hide or display actions fields, and maintain the categories that users can select from when they create actions. Permissions required to access this page: Access Admin Tab and Manage Action Categories.

To open the page, choose **Admin > Configure > Action Management.**

#### Hide or Display Actions Fields

Use the **Display** option under each bar to specify whether an actions field will display in that page or section of a page. For incidents, failure analysis reports, CSIs and projects, there can be a single actions field in each type of record. For problems, there can be separate actions fields for different steps in the problem resolution process (Description, Containment, Root Cause Analysis, etc.).

#### Manage the Action Categories

Each action record has a **Category** drop-down list. The main category always indicates the actions field where the record is displayed (e.g., in an incident, in the Description step for a problem, etc.). If desired, use the table under each bar to define your own custom subcategories ("action types").

- To add a new subcategory, click the **Add** icon.
To edit an existing subcategory, select it in the list and click the **Edit** icon, 

Changes will apply to all records that have already been associated with that subcategory. Alternatively, if you do not want the changes to apply to existing records, you can retire the existing subcategory and create a new subcategory with the new label.

To delete or retire an existing subcategory, select it in the list and click the **Delete** icon, 

---

**Note:** If you attempt to duplicate an entity that has custom subcategories defined for actions, the following error message may be displayed: "An error occurred while creating <New Entity Name> from <Existing Entity Name>. Some data may not have been completely duplicated."

In such cases, the new entity will not show the custom action subcategories that were defined in the original entity. To address the issue, go to the Action Management page and select the original entity. For each custom subcategory that you want to show in the new duplicated entity, click 

In the Action Type window, make sure the new duplicated entity is selected and click **Save**.
Chapter 7: Managing Customers

Managing Contacts
Use the Contacts page to manage the list of contacts that are available to select in CSI records, Incidents or any record that includes a "Contacts" detail field. Permissions required to access this page: Access Admin Tab and Manage Contacts.

To open the page, choose Admin > Configure > Manage > Contacts.

If your implementation has more than one entity, the same set of contacts will be available in all of them.

Tip: Users can also create and edit contacts that belong to the "Unit Owner" category while working in the CSI page.

Using Contacts in CSIs, Incidents and Other Records
- In CSI records, contacts are used in the "Unit Owner" and "ASP Field Service Tech" fields.
- In Incidents, contacts are used in the "ASP Field Service Tech" field if it is enabled for the entity.
- Contacts are also used in any record that has a Detail field with type = Contacts.

Creating, Editing and Deleting a Contact
To create a new contact, make sure the Contact drop-down list is blank, enter the required fields and choose Admin > Contacts > Create.

If you need to clear an existing contact before creating a new one, choose Admin > Contacts > New.

To edit a contact, choose the name from the Contact list. Make the desired changes and then choose Admin > Contacts > Save.
To delete a contact that is not used in any records, choose the name from the Contact list and then choose Admin > Contacts > Delete.

Alternatively, if you clear all categories from the contact properties, it will remain assigned to any existing records but will not be available to assign to new records.

**Contact Properties**

- **First Name** and **Last Name** are required. **MI** (middle initial) is optional.
- **Company** and **Location** - first select the company and then select one of the locations associated with that company. (See Managing Companies and Managing Locations.)

  **Tip:** In the CSI page, the ASP Field Service Tech field displays contacts that are associated with the company that is selected in the ASP field.

- **Category:**
  - **Unit Contact** - the contact can be selected in the "Contact Name" field on the CSI page. Click the Associated Systems link to view a report of all CSIs where this contact has been selected.
  - **ASP Field Tech** - the contact can selected in the "ASP Field Service Tech" field on the CSI page or Incident page.
  - **External User** - please contact ReliaSoft for information about this option.

If you have configured additional detail fields to meet your organization's specific needs, they will be grouped together in a separate Contact Details area at the bottom of the page.

**Managing Companies**

Use the Companies page to manage the list of companies that are available to select in Contact records, CSI records or any record that includes a "Companies" detail field. Permissions required to access this page: Access Admin Tab and Manage Companies.

To open the page, choose Admin > Configure > Manage > Companies.

If your implementation has more than one entity, the same set of companies will be available in all of them.

  **Tip:** Users can also create and edit companies while editing a Contact or CSI record.
Using Companies in CSIs and Other Records

- In CSI records, companies are used in the "Distributor," "Unit Owner" and "ASP" fields.
- Each Contact record may be associated with one company and one location.
- Companies are also used in any record that has a Detail field with type = Company.

Creating, Editing and Deleting a Company

To create a new company, make sure the Company drop-down list is blank, enter the required fields and choose Admin > Companies > Create.

If you need to clear an existing company before creating a new one, choose Admin > Companies > New.

To edit a company, choose the name from the Company list. Make the desired changes and then choose Admin > Companies > Save.

To delete a company that is not used in any records, choose the name from the Company list and then choose Admin > Companies > Delete.

Alternatively, if you clear all categories from the company properties, it will remain assigned to any existing records but will not be available to assign to new records.

Company Properties

- Name is required.
- Sales Region - the options are managed under Company Sales Region on the Lists page.
- Location - the list shows the locations that are currently associated with this company. The table under the list shows the address for the location that is currently selected. Any of these locations will be available to select when the company is used in a CSI or Contact record. (See Managing Locations.)
  - To add a location to the list, click . In the Location Page window, you can either create a new location record or select an existing one. Note that a location cannot be associated with more than one company. If you select a location that
is already associated with another company, it will be removed from the other company.

- **To edit a location**, select it in the list and click 📝.

- **To remove a location**, select it in the list and click 🗑️. This will remove the association with this company, but the location will remain in the database and could be associated with another company and/or used in an incident.

**Category:**

- **Unit Owner** - the company can be selected in the "Unit Owner" field on the CSI page.

- **ASP** - the company can be selected in the "ASP" field on the CSI page.

- **Distributor** - the company can be selected in the "Distributor" field on the CSI page.

The following fields will be enabled only if the company record has been saved with the "Distributor" category selected. These are the warranty settings that will be applied when you create a new CSI record for this distributor. The default settings for a new distributor are based on the **CSI - Warranty Months** preferences, but you can change the settings for a particular distributor.

- **Warranty From Shipment** and **Warranty From Commission** - the number of months for the warranty period.

- **Initial Warranty Months** - whether the warranty period starts on the date of the shipment to the distributor or on the date of the delivery to the end-user.

If you have configured additional detail fields to meet your organization's specific needs, they will be grouped together in a separate **Company Details** area.

If the company has contacts associated with it, they will be listed in the **Associated Contacts** area at the bottom of the page.

**Managing Locations**

Use the Locations page to manage the list of locations that are available to select in Companies, Contacts, CSI records, Incidents or any record that includes an "Address" detail field.

Permissions required to access this page: Access Admin Tab and Manage Locations.

To open the page, choose **Admin > Configure > Manage > Locations**.
If your implementation has more than one entity, the same set of locations will be available in all of them.

**Tip:** Users can also create and edit locations while editing a Company, Contact or CSI record.

### Using Locations in Companies and Other Records

In XFRACAS, a company may be associated with multiple locations. When the company is used in a CSI or Contact record, users can select one of the associated locations for that particular instance. For example, if ACME Company has sites in Chicago, Dallas and Detroit, the company record shows all three locations. When ACME Company is the unit owner for a CSI, users can select one of those sites as the location for that particular unit.

- In **Company records**, the "Location" field shows all of the locations that are associated with that company.

- In **Contact records**, the "Locations" field allows users to select one of the locations associated with the company that is selected in the "Company" field.

- In CSI records, the "Location" field allows users to select one of the locations associated with the company that is selected in the "Unit Owner" field.

- In serialized and part Incidents, the "Unit Location" field allows users to select any of the locations defined in the database. If a location is associated with a company, the company name will also appear in the list (e.g., "Company - Location").

- Locations are also used in any record that has a [Detail field](#) with type = Address.

### Creating, Editing and Deleting a Location

To create a new location, make sure the **Location** drop-down list is blank, enter the required fields and choose **Admin > Locations > Create**.

If you need to clear an existing location before creating a new one, choose **Admin > Locations > New**.

To edit an existing location, choose the name from the list, make the desired changes and then choose **Admin > Locations > Save**.
To delete a location that is not associated with any records, choose the name from the list and then choose Admin > Locations > Delete.

You cannot delete a location that is being used other records.

**Location Properties**

- **Description** - required and must be unique across all location records in the database.

- **Address, Address 2 and Zip** - optional and the values are entered/edited separately for each location record. For example, if you edit the zip code in one location, any other locations with the same zip code value will not be affected.

- **City, State and Country** - optional and the same lists will be used for all locations in the database. For example, if you edit the name of a city in one location, the change will apply in all locations where that city is used.

If you have configured additional detail fields to meet your organization's specific needs, they will be grouped together in a separate Location Details area at the bottom of the page.
Chapter 8: Managing Entities

Use the Entities page to manage the entities defined for your implementation. Permissions required to access this page: Access Admin Tab and Manage Entities.

To open the page, choose Admin > Tools > Entities.

XFRACAS can be configured with a single entity (where all users share the same configuration settings and data) or with multiple entities (where each entity has its own separate permissions, settings and data. The system-wide preferences, companies, contacts and locations will be the same for all entities in the database. The user permissions, system templates, serialized systems, entity-specific preferences and configurable detail fields can be managed separately for each entity.

Your XFRACAS license determines the maximum number of active entities that can be defined for your implementation.

Adding or Editing an Entity

To add a new entity, choose Admin > Entities > Create.

In the properties window, enter the required fields (at least a long name and unique record prefixes) and click Save.

**IMPORTANT:** After you create a new entity, it can be made "inactive" but it cannot be deleted, and this could affect your ability to manage settings that are shared across multiple entities. It is recommended that you a) plan your entity configurations in advance, b) establish a "template" entity that defines settings that should be the same across all entities, and c) implement changes in a staging environment before moving to production.

To edit an existing entity, select the name and then choose Admin > Entities > Edit.

**Entity Properties**

- **Long Name** displays in the entity drop-down list at the top of many XFRACAS pages, and in other locations where the full entity name is used.
Chapter 8: Managing Entities

- **Record Prefix** for each record type. These prefixes will appear before record numbers in the entity (e.g., "ENT-I-" for incidents, "ENT-P-" for problems, etc). Record prefixes must be unique across entities in the same database and only one entity can be configured without prefixes.

- **Parent Entity** (optional) allows you to display entities in a tiered structure in the entity drop-down list. The name of the parent will be appended to the entity's name in the drop-down list (e.g., "Parent - Child"). However, there is no implied inheritance for the data or settings. For example, if you search for incidents associated with the parent entity, results will not be returned for the child entity. Likewise, the configurable settings and permissions for the parent entity may not be consistent with the settings for the child entity.

- **Entity Status** sets whether the entity is **Active** (available for use) or **Inactive** (unavailable for use). If there is only one active entity in the system, you cannot make it inactive, so this field will be disabled.

  **Tip:** In addition to using the Inactive status to retire/hide an entity that is no longer in use, it can also be used to create a tiered structure in the entity drop-down list. For example, if you have an Automotive Power Train business unit with an Engine division and a Transmission division, you could set "Automotive Power Train" as the inactive parent to the active "Engine" and "Transmission" entities. The entity drop-down list would display the active entities as "Automotive Power Train - Engine" and "Automotive Power Train - Transmission."

### Duplication Settings

When you create a new entity (or when you change the status to "active" for an entity that was "inactive" upon creation), some basic required settings will always be copied from another entity.

- **Text Resources**
- **Preferences**
- **Detail** fields that are required (e.g., Incident Description, Problem Description, etc.)
  - If you select **Copy Detail Fields**, the rest of the configurable detail fields will also be copied.
- **Lists** associated with required fields (e.g., Incident State, Problem Priority, etc.)
  - If you select **Copy Lookup Lists**, the rest of the configurable lookup lists will also be copied.
- **Action Types**
• Standard Reports and Charts

In addition, you can also choose to:

• **Copy Criticality Fields** (See Managing Criticality Fields)
• **Copy Users** (See Managing Users)
• **Copy Security Groups** (See Managing Security Groups)

For detail fields, lookup lists and action types, duplicated settings will be the same as the entity they were copied from unless you later remove the entity from each particular detail, list or type and replace it with something else. It is recommended that you establish a "template" entity that defines the settings that should be the same across all entities and use that template to copy settings for each new entity you create.

**Note:** Duplicating an entity can consume a large amount of database resources. When you are duplicating an entity, other users cannot access the Entities page; they will see a message stating that an entity is being duplicated.
Chapter 9: Administrator Reports

Report Viewer

Use the Report Viewer page to specify which of the built-in reports will be visible to users and set the display order. It also determines which options are available in the Quick Search utility. Permissions required to access this page: Access Admin Tab and Manage Report Viewer.

To open the page, choose Admin > Tools > Report Viewer.

For each category of reports in the Report Viewer, specify the display order for the reports. The reports will be displayed in the following arrangement:

1 2
3 4
5 ...

Note that skipped numbers do not leave a space in the interface. For example, if you do not have a report with a display order of 3, the ordered reports will be displayed as follows:

1 2
4 5
6 ...

To hide a report from its list, leave the display order blank.

The numbers in parentheses after the report names are the query IDs.

To save the changes you have made on the Report Viewer page, choose Admin > Report Viewer > Save.
Administrator Reports

Administrator Reports are tabular reports/queries for information managed by application admins, such as users and their permissions, options in configurable lists, and owners for template parts. Permissions required to access these reports: Access Admin Tab.

Reports Page

To use saved admin report templates, choose Home > View > Reports.

Click Administrator Reports

Reports Builder Page

To modify or create new admin report templates, choose Options > Designers > Report Builder.

In the Select Report drop-down lists, select "Administrator Reports" and then select the specific type of report.
Chapter 10: Imports/Exports

XFRACAS offers several ways to import and export XFRACAS records (e.g., incidents, system configurations, etc.) via *.xml or *.xlsx templates.

- Use the Data Import page to view and manage the import queue, the log of processed files and the log of files that could not be processed.
- Use the optional XFRACAS Data Import Utility (DIU) Windows service (running on the web server) to process the import queue on a scheduled basis.
- Use the optional XFRACAS Web Service in your own custom application to insert XML files into the import queue or insert time/usage reports for serialized systems.

If you are using ReliaSoft XFMEA, RCM++ or RBI for failure modes and effects analysis, you also have the option to import and/or synchronize system templates and failure modes. (See Importing Systems from XFMEA.)

Note that you can also use the Synthesis Data Warehouse (SDW) in Weibull++, ALTA or RGA to extract data from XFRACAS to build data sets for life data analysis or repairable system/reliability growth analysis. (See Synthesis Data Warehouse in the Weibull++/ALTA documentation.)

Data Import Page

The Data Import page allows you to import and export XFRACAS records (e.g., incidents, system configurations, etc.) using *.xml or *.xlsx templates. This page can be used in conjunction with the optional XFRACAS DIU (Windows service) and/or the XFRACAS Web Service, if applicable. Permissions required to access this page: Access Admin Tab and Manage Import.

To open the Data Import page, choose Admin > Tools > Import.

If your implementation has more than one entity, import schedules and logs are managed separately for each. The drop-down list at the top of the page determines which entity's import details are currently displayed.

XML and XLSX Templates

XFRACAS provides an XML Document Type Definition (DTD) for each type of record you can import or export. These are installed in the "DTD" folder on the web server (e.g., C:\inetpub\wwwroot\XFRACAS\ DTD). For descriptions of the XML elements and attributes, see XFRACAS XML Import Business Logic (*.pdf).
Tip: The Data Import Page topic in the XFRACAS Admin help file provides templates and examples for common import scenarios. You may be able to save time by downloading and adapting these files to import your own data.

You also have the option to import some record types from Excel.

IMPORTANT: In order to use Excel templates, the web server must be configured to recognize the *.xlsx file type. For details, please consult the XFRACAS Implementation Guide (*.pdf).

Adding Files to Import

1. Choose Admin > Import > Add.

2. In the Add Import File utility, select the import type and browse for the file.

3. Click Add to add the file to the import queue.

Note: If a record in the *.xml file has an entity display ID (e.g., ENT-I-100) that already exists, it will not be imported and it will be logged as a duplicate in the error log.

Processing Files in the Inbox

The Inbox shows all of the import tasks that are currently in the queue to be imported. Each task is an *.xml or *.xlsx file that contains data you wish to import.

If you have the "Access Import Processing" permission, you can immediately process the import queues for all entities. Click Admin > Import > Process.

Alternatively:

- If the DIU Service is running on the web server, the service will attempt to process the file(s) at the date/time specified in the Import Schedule for the relevant data type and entity.

- If you have created your own custom application using the Web Service, it includes a function to immediately process the import queues for all entities.

The Processed area shows the import tasks that have been completed successfully, while the Error area shows the files that could not be processed. The DIU Log shows all actions performed by the DIU Service (including e-mail notifications that are triggered based on calendar date).
Exporting to XML

If you have the "Access Data Export" permission, the easiest way to export a single record to XML is to open the record and click the Export command in the ribbon.

Alternatively, if you know the record ID(s), you can use the utility in the Data Import page.

1. Choose Admin > Import > Export.

2. In the Export File utility, choose the export type and specify the ID(s) to export in the ID field. This can be a single ID or a comma-delimited list.

Depending on the record type, you will need to enter either the entity display ID (i.e., the record number that is visible in XFRACAS) or the database ID (obtained from the database table).

<table>
<thead>
<tr>
<th>Export Type</th>
<th>ID to Enter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Address (i.e., location)</td>
<td>Database ID</td>
</tr>
<tr>
<td>Company</td>
<td>Database ID</td>
</tr>
<tr>
<td>Failure analysis</td>
<td>Entity display ID</td>
</tr>
<tr>
<td>Incident</td>
<td>Entity display ID</td>
</tr>
<tr>
<td>Issue</td>
<td>Database ID of the list issue type</td>
</tr>
<tr>
<td>Master BOM</td>
<td>Part ID</td>
</tr>
<tr>
<td>Problem</td>
<td>Entity display ID</td>
</tr>
<tr>
<td>Project</td>
<td>Entity display ID</td>
</tr>
<tr>
<td>System</td>
<td>HID</td>
</tr>
<tr>
<td>Unit Commissioning (i.e., CSI)</td>
<td>Entity display ID</td>
</tr>
<tr>
<td>User</td>
<td>Database ID</td>
</tr>
</tbody>
</table>
Chapter 10: Imports/Exports

3. Click **Export**.

**DIU Service**

The XFRACAS Data Import Utility (DIU) is a Windows service that must run on the web server in order to use any of the following features:

- Process files in the import queue, based on the schedule specified on the [Data Import page](http://xfracas.reliasoft.com).
- Trigger **e-mail notifications based on calendar date** (e.g., E-mail - Incident Action Due Date, etc.).

For instructions to start the DIU service, please consult the [XFRACAS Implementation Guide](http://xfracas.reliasoft.com) (*.pdf).

The current status of the DIU service will be displayed at the top of the Data Import page. This page also displays a log of actions performed by the service ([DIU Log](http://xfracas.reliasoft.com)).

**IMPORTANT:** If you have a load balanced environment with multiple web servers, the DIU service should run on only one of the servers.

**Web Service**

If you have some basic programming knowledge, you can use the XFRACAS web service in your own custom application to insert XML files into the import queue or insert time/usage reports for serialized systems.

**Tip:** The Web Service topic in the XFRACAS Admin help file enables you to download a sample application that demonstrates the basic process for using the web service.

**Using the Service**

On the web server, IIS must be configured with **HTTP Activation** enabled for the .NET Framework. See [XFRACAS Implementation Guide](http://xfracas.reliasoft.com) (*.pdf).

The following functions are available. For parameters and code examples, see [XFRACAS XML Import Business Logic](http://xfracas.reliasoft.com) (*.pdf) and the sample application.

- **ImportXML** - Inserts an XML file into the XFRACAS import queue. This is equivalent to clicking **Add** via the website. Note that:
  - The web service can insert any of the XML file types that can be uploaded manually via the [Data Import page](http://xfracas.reliasoft.com) in the XFRACAS website, such as Incident (xml) or Master BOM (xml), etc.
• The maximum size for files that can be inserted into the queue by the web service is set via the XFRACAS Admin utility on the web server (on the Settings page of the XFRACAS Configuration File window). By default, this is set to 10485760 bytes (or ~10 MB).

• The web service cannot be used to insert XLSX files into the import queue.

• **ProcessImports** - Immediately begins processing of all files in the import queue for all entities. This is equivalent to clicking **Process** via the website. To view the processing status of the files, check the **Processed** and **Error** logs on the website.

• **ImportMetrics** - Inserts up to 3 time/usage values reported on a particular date for a particular serialized system. This is equivalent to clicking **Update System Hours** in the customer support record for a serialized system. (See [Time Metric Calculations](#).)

• **GetAllXFRACASEntities** - Returns a list of entities that the user belongs to. The entity ID (eid) is a required parameter for some functions.

• **WriteExceptionToDiagnosticsLog** and **WriteMessageToDiagnosticLog** - Insert entries into the XFRACAS **Diagnostics Log**.

---

**Tip:** Although similar calls have been available in the Synthesis API, the XFRACAS API methods are planned to be deprecated in Version 2019. If you have developed any custom applications using XFRACAS API methods, it is recommended to transition to the web service instead.

---

## Import or Sync from XFMEA

If your organization uses ReliaSoft XFMEA, RCM++ or RBI for FMEAs or Reliability Centered Maintenance analysis, you can import or synchronize data for parts and failure modes that you are tracking in XFRACAS.

To use this feature, you must have the "Manage Templates" and "Synthesis - Read Failure Mode Data" permissions in XFRACAS. It also requires a user account for ReliaSoft desktop applications with access to at least one project that has FMEA/RCM data.

When a template part in XFRACAS is "associated" with an item in the desktop applications, you will be able to synchronize the following:

- Part Name
- Part Number and Version ([if enabled and populated in the desktop project](#))
- Item Category ([if the XFRACAS entity uses this type of detail field for template parts](#))
- Failure Modes and Root Causes
Note: The desktop applications provide similar options that are available to users with the required permissions. (See Import or Sync from XFRACAS in the XFMEA/RCM++/RBI documentation.) In both XFRACAS and the desktop applications, the import and sync features modify data only in the application that you are using. For example, if you want to copy the latest data from XFMEA into XFRACAS, use the commands in XFRACAS. Alternatively, if you want to copy recent changes from XFRACAS into XFMEA, use the commands in XFMEA.

**XFMEA Import**

To create a new XFRACAS template by importing items from the desktop application, choose System > Template > XFMEA Import.

In the XFMEA Import window, select the desktop analysis Project you want to import from, and a System within that project. (This can be any desktop project you have permission to edit, which contains a system hierarchy defined in XFMEA, RCM++ or RBI.)

If you want to create Failure Modes and Root Causes for the new template parts based on FMEAs performed in the desktop application, select Import failure modes with template.

**Sync with XFMEA**

When you are editing an XFRACAS template that has parts "associated" with items in the desktop applications, you can choose to update the XFRACAS data to reflect changes that have been made in the desktop applications. To do this, select the part and choose System > Part > Sync with XFMEA.

In the XFMEA Sync window, use the check boxes to specify what you want to update:

- The properties of the currently selected part
- The failure modes and root causes associated with the currently selected part
- The subcomponents of the currently selected part
- The failure modes and root causes associated with the subcomponents

This will update records that are already "associated" and import new records if applicable. It will not affect any template parts and failure modes/causes that exist only in XFRACAS and are not "associated" with records in the desktop analysis.
Remove XFMEA Association
When you are editing an XFRACAS template that has parts "associated" with items in the
desktop applications, you can choose to remove the association for a single part or for all parts
in a branch of the hierarchy. To do this, select the part and choose **System > Part > Remove
XFMEA Association**.

In the XFMEA Association window, uses the check boxes to specify which part(s) to update:

- The selected part
- All subcomponents of the currently selected part

Part Number Not Required in Desktop Applications
In ReliaSoft desktop applications, the Part Number and Version properties can be enabled or
disabled in each analysis project, and they are not required to be entered for each item.

In XFRACAS, a Part Number must be entered for each template part. When users report
incidents for a serialized system, they must enter a valid combination of Serial Number and Part
Number.

Therefore, if you will be importing desktop items into XFRACAS, we recommend to make sure
the Part Number field is enabled for the desktop analysis project(s) and populated for each item
prior to importing or synchronizing in XFRACAS.

Using the Item Category Field
In ReliaSoft desktop applications, the **Item Category** provides a way to find, filter and group
analysis data. When an organization defines item categories based on system hierarchies
defined in XFMEA, RCM++ or RBI, this enables users to apply an appropriate category for the
desktop analyses, diagrams and resources that are associated with each item. (See **Import or
Sync from XFRACAS** in the XFMEA/RCM++/RBI documentation.)

In XFRACAS, a special type of "Item Category" detail field provides the same list of item
categories that is available in desktop applications. If this field is enabled in the entity for
template parts, the categories assigned via desktop applications will be imported and
synchronized for template parts in XFRACAS. Likewise, if you edit or create new template parts
in XFRACAS that will later be imported or synchronized into the desktop analysis, you can use
this field to assign the appropriate category.
Chapter 11: Additional Tools

Diagnostics
Use the Diagnostics page to view warnings and errors that have occurred for your XFRACAS implementation. This information may be needed when you contact technical support. Permissions required to access this page: Access Admin Tab and Manage Diagnostics Page.

To open the page, choose Admin > Tools > Diagnostics.

Exporting to Excel
To export the log to an Excel file, choose Admin > Diagnostics > Excel.

Deleting Entries
To remove one or more entries from the log, select the check box for the row(s) and choose Admin > Diagnostics > Delete.

Resource Editor
Use the Resource Editor page to manage text labels that appear throughout the XFRACAS user interface. Permissions required to access this page: Access Admin Tab and Manage Resource Editor.

To open the page, choose Admin > Tools > Resource Editor.

If your implementation has more than one entity, the text resources can be configured separately for each, but the same settings may be used in multiple entities. The drop-down list at the top of the page determines which entity's text resources you are currently managing.

Finding Resources
To find specific text resources, choose Admin > Resource Editor > Find.

In the Find utility, you can search by any of the following:
Chapter 11: Additional Tools

- **Start ID** and **End ID** - specifies a range of resources based on their numerical identifiers. If you specify only a Start ID, all resources from that ID on will be displayed. If you specify only an End ID, all resources up to and including that ID will be displayed.

- **Default Text** - the labels that are shipped with XFRACAS.

- **Display Text** - custom labels, if any, that have been configured to meet your particular needs.

**Tip:** If you type an underscore ( _ ) in this field, the search will return all text resources that have custom labels.

- **Location** - the user interface page or utility where the resources are used.

- **Language** - the translation language.

Click **Find** to view all of the text resources that match the specified criteria.

**Editing Resources**

In the table of resources returned by the Find utility, click **Edit** in the row for the text you wish to modify.

In the Edit Resource window, clear the **Use Default** check box and enter your preferred label in the **Display Text** field. If applicable, select the **Entities** where the custom label will be used.

**Replacing Resources**

To find and replace all occurrences of a text string, choose **Admin > Resource Editor > Replace**.

In the Find and Replace Utility, specify the text you want to replace and click **Preview** to view all possible replacements that match the specified criteria.

In the table of possible replacements, you can clear the check boxes for any text labels you wish to leave unchanged. When you are ready to proceed, choose **Admin > Resource Editor > Save**.

**Restoring Defaults**

To return all resources in the current entity to the default text, choose **Admin > Resource Editor > Default All**.
Creating an Update Script

If you need to implement the same text changes in another database, choose Admin > Resource Editor > Update Script.

In the Update Script utility, use the Begin Date and End Date fields to specify a time period (e.g., include only changes made in the past month). Click OK to download a *.txt file that contains SQL statements that will implement the same changes in another database.
END USER LICENSE AGREEMENT

By installing this software or by clicking the “I accept” button and accepting this license in accordance with section D (license acceptance procedures) you agree to the terms of this license which will bind you, the company on whose behalf you are entering into this license agreement, and its employees, as applicable.

This license agreement is a legal agreement between HBM United Kingdom Limited (an affiliate of HBM Prenscia Inc.), a company incorporated in the United Kingdom, whose registered number is 1589921 and whose registered office is at Technology Centre, Advanced Manufacturing Park, Brunel Way, Catcliffe, Rotherham S60 5WG (the “Licenser”) and the end user licensee or its representative/agent authorised to bind the end user licensee (referred to herein as “you” or “your”).

Please read this carefully before using the software product

A: BACKGROUND

This license agreement shall be between you and the licenser regardless of whether you have purchased the software product directly from the licenser or an authorised reseller as set out below.

The licenser appoints experienced providers of software resale services who distribute the software product to end users (“authorised reseller”). If you have purchased the software product and any associated support and maintenance services from an authorised reseller, such products and services will be provided directly to you by the relevant authorised reseller and all payments shall be made to the authorised reseller on the authorised reseller’s terms and prices.

If you have purchased the software product and support and maintenance services directly from the licenser, such support and maintenance services will be dealt with in a separate agreement between you and the licenser and all payments will be made to the licenser and governed by the licenser’s terms of sale.

B: PROPERTY OF LICENSOR

The licenser, or, where applicable, the relevant member of the licenser’s corporate group, is the entire legal and beneficial owner of certain software product(s) (the “software product”) as set out in the quotation of information, which shall also include your license key, sent to you by email either by the licenser or, if you have purchased the software product from an authorised reseller, by the authorised reseller (“quotation”). The licenser is willing to grant you a license to use the software product only if you accept all the terms and conditions set out below.

C: LICENSE TO BE GRANTED

The licenser is proposing to grant you one of the four forms of licenses in respect of the software product. The details of each form of license are set out in clauses 2.1 and 3 below. The form of license that is proposed to be granted to you is set out in the quotation. The quotation forms part of the license agreement and by accepting the terms of the license you are accepting those terms in the quotation. If you have not received the
QUOTATION FROM EITHER THE LICENSOR OR FROM THE AUTHORISED RESELLER (IF YOU HAVE PURCHASED THE SOFTWARE PRODUCT FROM AN AUTHORISED RESELLER) AT THE DATE HEREOF OR IF ANY DETAILS WITHIN THE QUOTATION ARE INCORRECT THEN YOU SHOULD FOLLOW THE “LICENSE REJECTION PROCEDURES” SET OUT AT PARAGRAPH E BELOW AND IMMEDIATELY CONTACT THE LICENSOR OR THE AUTHORISED RESELLER (AS APPLICABLE).

D: LICENSE ACCEPTANCE PROCEDURES

BY CLICKING ON THE ACCEPTANCE BUTTON WHICH FOLLOWS THIS LICENSE AGREEMENT (MARKED “I ACCEPT”), YOU INDICATE ACCEPTANCE OF THIS LICENSE AGREEMENT AND THE LIMITED WARRANTY AND LIMITATION OF LIABILITY SET OUT IN THIS LICENSE AGREEMENT. SUCH ACCEPTANCE IS ON YOUR OWN BEHALF, IF YOU ARE AN INDIVIDUAL, AND ON BEHALF OF ANY CORPORATE ENTITY WHICH EMPLOYS YOU OR WHICH YOU REPRESENT (“CORPORATE LICENSEE”) IN ENTERING INTO THIS LICENSE AND YOU WARRANT THAT YOU HAVE THE NECESSARY AUTHORITY TO BIND THE CORPORATE ENTITY IN THIS RESPECT OR THAT THE AUTHORISED REPRESENTATIVES OF THE CORPORATE ENTITY ARE AWARE OF YOUR ACCEPTANCE OF THIS AGREEMENT ON ITS BEHALF. IN THIS LICENSE AGREEMENT, “YOU” REFERS TO THE LICENSEE, ANY SUCH CORPORATE LICENSEE, OR BOTH, AS A COMMON SENSE INTERPRETATION OF THE RELEVANT SECTION DICTATES.

E: LICENSE REJECTION PROCEDURES

IF YOU DO NOT ACCEPT THESE TERMS AND CONDITIONS, YOU SHOULD CLICK ON THE “I DO NOT ACCEPT” BUTTON, DELETE THE SOFTWARE PRODUCT FROM YOUR COMPUTER AND PROMPTLY (AND IN ANY EVENT, WITHIN 14 DAYS OF RECEIPT) RETURN TO THE RESELLER (A) ANY MEDIA; AND (B) ANY OTHER ITEMS PROVIDED, THAT ARE PART OF THIS PRODUCT.

F: OTHER AGREEMENTS

IF THE LICENSOR HAS EXPRESSLY AGREED WITH YOU IN WRITING THAT YOUR USE OF THE SOFTWARE PRODUCT IS GOVERNED BY A PRIOR EXECUTED LICENSE AGREEMENT WITH THE LICENSOR, SUCH AGREEMENT SHALL APPLY INSTEAD OF THE FOLLOWING TERMS AND CONDITIONS TO THE EXTENT THAT THEY CONFLICT.

YOU SHOULD PRINT A COPY OF THIS LICENSE AGREEMENT FOR FUTURE REFERENCE.

LICENSE AGREEMENT

1. Ownership of Software Product and Copies

1.1 The Software Product and any printed materials or electronic documentation accompanying the Software Product (“Documentation”) are copyrighted works of authorship, and are also protected under applicable database laws. The Licensor, or, where applicable, the relevant member of the Licensor’s corporate group, retains ownership of the Software Product and all subsequent copies of the Software Product, regardless of the form in which the copies may exist. This License Agreement is not a sale of the original Software Product or any copies.

2. Commercial License

2.1 In consideration of You agreeing to abide by the terms of this License Agreement and payment of the applicable License fees either to the Licensor or, if You have purchased the Software Product from an Authorised Reseller, to the Authorised Reseller (as specified in the Quotation), the Licensor hereby grants to You a personal, non-exclusive, and (unless expressly agreed otherwise by the Licensor in accordance with clause 5.1) non-transferable License to use the Software Product and the Documentation on the terms of this License Agreement. The License shall take one of the following forms, and shall be set out in the
Quotation:

(a) **Annual License:**

(i) Duration – this License shall continue for a period of 12 months ("Initial Period") from the date of delivery of the Quotation ("the Delivery Date") and, provided that You have paid all applicable renewal fees, from year to year thereafter unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

(ii) Termination – You must give the Licensor 90 days' written notice prior to the anniversary of the Delivery Date, such notice not to expire before such anniversary date.

(b) **Perpetual License:**

(i) Duration – this License shall continue for a period of 25 years from the Delivery Date unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

(ii) Conversion - this License may be converted to a Token Based Annual License, upon application to either the Licensor or the Authorised Reseller (if You have purchased the Software Product from an Authorised Reseller), and payment of an additional fee to the Licensor or the Authorised Reseller (as applicable), which shall be additional to the fees paid or payable in respect of any maintenance and support services provided by either by the Licensor or the Authorised Reseller (if You have purchased the Software Product from an Authorised Reseller). You may reverse this conversion to the same terms as agreed in the Perpetual License at the anniversary of the conversion by giving the Licensor 90 days' written notice prior to the anniversary of the Delivery Date, such notice not to expire before the anniversary of the Delivery Date.

(c) **Token Based Annual License (referenced in the Quotation as a Prenscia Access System, CDS, CRS, or CDRS License):**

(i) Subject to the terms and conditions of this License Agreement, You may access any of the Software Product in the Quotation at any one time and in any combination up to the number of subscriptions granting You access to the Software Product for simultaneous use by You and purchased by You pursuant to this Agreement ("Access Credits"). You may add additional Access Credits which shall be charged in accordance with either the Licensor’s prices or the Authorised Reseller’s prices (if You have purchased the Software Product from an Authorised Reseller). Such increase in Access Credits shall apply to the following 12 month period, unless You give the Licensor or the Authorised Reseller (as applicable) written notice at least 90 days in advance of the expiration of the Initial Period, that You do not wish to sustain such increase in Access Credits. You may opt to reduce the number of Access Credits with 90 days' written notice in advance of the 12 month period following from the anniversary of the Delivery Date, provided that the total number of Access Credits does not fall below the minimum threshold set by the Licensor or the Authorised Reseller (as applicable) or below the initial number of Access Credits calculated at the time of conversion of any Perpetual License.

(ii) Duration - this License shall continue for the Initial Period and, provided that You have paid for the applicable Access Credits, from year to year thereafter unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

(iii) Reporting – in order to serve the Licensor’s customers better, the Licensor needs to be able to understand how its customers use the Token Based Annual License. As a condition of Your continued access to the system, You are asked to provide to the Licensor on a quarterly basis,
the log file. You will be provided with easy-to-follow instructions on how to do this.

(iv) Termination – You must give the Licensor 90 days’ written notice in advance of the expiration of the Initial Period of Your intention to discontinue the Token Based Annual License, such notice not to expire before the anniversary of the Delivery Date, and You must have submitted all reports required of You in clause 2.1(c)(iii) above. Failure to provide such notice and reports will mean that the License shall automatically continue on the same terms until terminated in accordance with this clause.

2.2 As an end user licensee of the Software Product, You may, subject to the following conditions and any conditions specified in the Quotation:

(a) use and copy the Software Product only for use on any computer system that is detailed in the release notes of the respective Software Product and which is licensed, leased and/or controlled by You (the Corporate Licensee) or any member of Your corporate group, which expression includes the Corporate Licensee’s majority-owned subsidiaries, any parent company having a majority-owned interest in the Corporate Licensee, and such parent’s majority-owned subsidiaries;

(b) load the Software Product into and use it only on computers at the locations specified in the Quotation and which are under Your control; and

(c) copy the Software Product only for back-up and archival purposes and make up to three copies of the Documentation, provided that the original and each copy is kept in Your possession and that Your installation and use of the Software Product does not exceed any restrictions contained in the Quotation.

3. Demonstration License

3.1 If the Licensor has provided You with the Software Product free of charge for evaluation purposes, this clause 3 shall apply to Your use of the Software Product.

3.2 You may use the Software Product on a computer solely for the purposes of evaluating the Software Product.

3.3 The Software Product is provided to You free of charge and on an “AS IS” basis, without any technical support or warranty of any kind from the Licensor including, without limitation, a warranty of satisfactory quality, fitness for purpose and non-infringement.

3.4 This License shall continue for a period of 30 days from the Delivery Date unless terminated in accordance with any provision of clause 10 below or any other applicable clause of this License Agreement or until such License is converted into an Annual License, Perpetual License, or Token Based Annual License, if earlier.

3.5 As part of the Licensor’s testing and evaluation of the Software Product, You shall share with the Licensor the input and views received and any reports and analysis produced promptly upon receipt of such feedback.

3.6 Clauses 4, 5.1(a), 6.1(b), 6.1(f), 8.1, 8.2, 8.5, 10.1(a) of this License Agreement shall not apply to a Demonstration License.

4. Delivery and Risk

4.1 The Software Product shall consist of one copy of the object code of the Software Product on machine-readable form only, on the disk, dongle or other media on which the Software Product is delivered as described in the Quotation (the “Media”). Risk in the Media shall pass to You on delivery. If any part of the Media shall thereafter be lost, damaged or destroyed, You must contact either the Licensor or the Authorised Reseller from whom You have purchased the Software Product who will arrange for a repair
or replacement of such Media at a cost (if any) determined by the Licensor or the Authorised Reseller (as applicable).

5. License Restrictions

5.1 You may not nor permit others to:

(a) transfer the Software Product from one location to another, without the express written consent of the Licensor and provided such transfers do not exceed two in any twelve month period. It will be a condition of the grant of any such consent that the Software Product held on hard drives at the current location must be erased and You must enter into a new License agreement with the Licensor before a Software Product License key is provided to You. The administration charge (currently US $1,500) will be payable by You in respect of such transfer. This charge is only applicable to end user licensees who do not have a support and maintenance services agreement with the Licensor or Authorised Reseller;

(b) exceed the number of concurrent users specified in the Quotation, if any;

(c) sub-License, sell, assign, rent, pledge, lease, transfer or otherwise dispose of the Software Product, on a temporary or permanent basis, without the prior written consent of the Licensor;

(d) translate, reverse engineer, decompile, disassemble, modify or create derivative works based on the Software Product except as permitted by law;

(e) make copies of the Software Product, in whole or part, except for back-up or archival purposes as permitted in this License Agreement;

(f) use any back-up copy of the Software Product for any purpose other than to replace the original copy in the event that it is destroyed or becomes defective;

(g) copy the Documentation (except as provided by this License Agreement);

(h) adapt, modify, delete or translate the Documentation in any way for any purpose whatsoever;

(i) vary, delete or obscure any notices of proprietary rights or any product identification or restrictions on or in the Software Product.

6. Undertakings

6.1 You undertake:

(a) to ensure that, prior to use of the Software Product by Your employees or agents, all such parties are notified of this License and the terms of this License Agreement and that any such use as aforesaid is in accordance with the terms of this License Agreement;

(b) to replace the current version of the Software Product with any updated or upgraded version or new release provided by the Licensor or the Authorised Reseller (if applicable) under the terms of this License Agreement immediately on receipt of such version or release;

(c) to use the Software Product only as described in the Documentation and subject to the restrictions as set out in clause 5 (License Restrictions above);

(d) to reproduce and include the Licensor’s copyright notice (or such other party’s copyright notice as specified on the Software Product) on all and any copies of the Software Product, including any partial copies of the Software Product as permitted to be made under the terms of this License Agreement;

(e) to hold all drawings, specifications, data (including object and source codes), Software Product listings and all other information relating to the Software Product confidential and not at any time, during
this License or after its expiration, disclose the same, whether directly or indirectly, to any third party
without the Licensor’s consent and

(f) to effect and maintain adequate security measures to safeguard the Software Product from access or
use by any unauthorised person and indemnify the Licensor for losses flowing from your failure to do
so.

7. Intellectual Property Rights

7.1 You acknowledge that all intellectual property rights in the Software Product and the Documentation
throughout the world belong to the Licensor, that rights in the Software Product are licensed (not sold) to
You, and that You have no rights in, or to, the Software Product or the Documentation other than the right
to use them in accordance with the terms of this License Agreement.

7.2 You acknowledge that You have no right to have access to the Software Product in source code form or in
unlocked coding or with comments.

7.3 The integrity of this Software Product is protected by technical protection measures (“TPM”) so that the
intellectual property rights, including copyright, in the software of the Licensor are not misappropriated.
You must not attempt in any way to remove or circumvent any such TPM, nor to apply, manufacture for
sale, hire, import, distribute, sell, nor let, offer, advertise or expose for sale or hire, nor have in Y our
possession for private or commercial purposes, any means whose sole intended purpose is to facilitate the
unauthorised removal or circumvention of such TPM.

8. Limited Warranty

8.1 Subject to the limitations and exclusions of liability below and providing the Software is used in accordance
with the Documentation and on an operating system or computer for which it was designed, the Licensor
warrants that (a) the Media on which the Software Product is furnished will be free from material defects
under normal use for a period of 90 days from the date of delivery (the “Warranty Period”); and that (b)
during the Warranty Period, the Software Product will, when properly used, perform substantially in
accordance with the functions described in the Documentation; and (c) that the Documentation correctly
describes the operation of the Software Product in all material respects.

8.2 If, within the Warranty Period, You notify the Licensor in writing of any defect or fault in the Software
Product in consequence of which it fails to perform substantially in accordance with the Documentation,
and such defect or fault does not result from You having amended the Software Product or used it in
contravention of the terms of this License Agreement, the Licensor will, at its sole option, i) repair or replace
the Software Product, provided that You make available all information that may be necessary to assist the
Licensor in resolving the defect or fault, including sufficient information to enable the Licensor to recreate
the defect or fault, or ii) terminate this License Agreement immediately by notice in writing to You and the
Licensor will refund or if the Software Product has been purchased from an Authorised Reseller will procure
that the Authorised Reseller shall refund; any of the fees paid as at the date of termination (less a
reasonable sum in respect of Your use of the Software Product to the date of termination) on return of the
Software Product and all copies thereof. The Licensor’s obligation under this clause 8.2 is subject to Your
compliance with clause 6.1(b).

8.3 You acknowledge that the Software Product has not been developed to meet Your individual requirements
and that it is therefore Your responsibility to ensure that the facilities and functions of the Software Product
as described in the Documentation meet Your requirements.

8.4 You acknowledge that the Software Product may not be free of bugs or errors and You agree that the
existence of any minor errors shall not constitute a breach of this License Agreement.
8.5 The Licensor shall not be liable under the said warranty above if the Software Product fails to operate in accordance with the said warranty as a result of any modification, variation or addition to the Software Product not performed by the Licensor or caused by any abuse, corruption or incorrect use of the Software Product, including use of the Software Product with equipment or other software which is incompatible.

8.6 All other conditions, warranties or other terms which might have effect or be implied or incorporated into this License Agreement or any collateral contract, whether by statute, common law or otherwise, are hereby excluded, including, without limitation, the implied conditions, warranties or other terms as to satisfactory quality, fitness for purpose or the use of reasonable skill and care.

9. Exclusion of Liability

9.1 Nothing in this License Agreement shall limit or exclude the liability of either party for death or personal injury resulting from negligence, for fraud or for fraudulent misrepresentation.

9.2 Subject to clause 9.1, the Licensor shall have no liability for any losses or damages which may be suffered by You (or any person claiming under or through You), whether the same are suffered directly or indirectly or are immediate or consequential, and whether the same arise in contract, tort (including negligence) or otherwise howsoever, which fall within any of the following:

(a) loss of income;
(b) loss of business profits or contracts;
(c) business interruption;
(d) loss of the use of money or anticipated savings;
(e) loss of information;
(f) loss of opportunity, goodwill or reputation;
(g) loss of, damage to or corruption of data; or
(h) any indirect or consequential loss or damage of any kind howsoever arising and whether caused by tort (including negligence), breach of contract or otherwise;

provided that this clause 9.2 shall not prevent claims for loss of or damage to Your tangible property that fall within the terms of clause 8 or a claim for a refund of the License fees paid to the Licensor or the Authorised Reseller (as applicable) for the License of the Software Product.

9.3 Subject to clause 9.1 and clause 9.2, the Licensor's maximum aggregate liability under or in connection with this License Agreement, or any collateral contract, whether in contract, tort (including negligence) or otherwise, shall be limited to a sum equal to the fees paid by You to the Licensor or the Authorised Reseller (as applicable) for the License of the Software Product.

9.4 Subject to clause 9.1, clause 9.2 and clause 9.3, the Licensor's liability for infringement of third party intellectual property rights shall be limited to breaches of third party rights subsisting in the UK and USA.

9.5 This License Agreement sets out the full extent of the Licensor's obligations and liabilities in respect of the supply of the Software and Documentation. In particular, there are no conditions, warranties, representations or other terms, express or implied, that are binding on the Licensor except as specifically stated in this License Agreement. Any condition, warranty, representation or other term concerning the supply of the Software and Documentation which might otherwise be implied into, or incorporated in, this License Agreement, or any collateral contract, whether by statute, common law or otherwise, is hereby excluded to the fullest extent permitted by law.

10. Term and Termination
10.1 This License Agreement is effective for the period referred to in clause 2.1 or until otherwise terminated in accordance with that clause. The Licensor may terminate this License Agreement immediately by written notice to You if:

(a) save in respect of a Perpetual License, if You purchase the Software Product directly from the Licensor, You fail to pay any renewal or other fees due by You to the Licensor in respect of this License Agreement;
(b) You fail to comply with any provisions of this License Agreement;
(c) You commit a material or persistent breach of this License Agreement which You fail to remedy (if remediable) within 14 days after the service on You of written notice requiring You to do so;
(d) a petition for a bankruptcy order to be made against You has been presented to the court; or
(e) where You, as the Corporate Licensee, become insolvent or unable to pay its (the company’s) debts, enters into liquidation, whether voluntary or compulsory (other than for reasons of bona fide amalgamation or reconstruction), passes a resolution for its winding-up, has a receiver or administrator manager, trustee, liquidator or similar officer appointed over the whole or any part of its assets, makes any composition or arrangement with its creditors or takes or suffers any similar action in consequence of its debt, or becomes unable to pay its debts or ceases to trade.

10.2 In the event of termination in accordance with clause 10.1, You must immediately pay to the Licensor any sums due to the Licensor under the License Agreement and (at the Licensor’s sole option) You must return, destroy or delete all copies of the Software Product from all storage media in Your control and, in the case of destruction, certify to the Licensor that You have done so.

11. Export

11.1 You will comply with all applicable laws, rules, and regulations governing export of goods and information, including the laws of the countries in which the Software Product was created. In particular, You will not export or re-export, directly or indirectly, separately or as a part of a system, the Software Product or other information relating thereto to any country for which an export License or other approval is required, without first obtaining such License or other approval.

12. General

12.1 You agree that the Licensor shall have the right, after supplying undertakings as to confidentiality, to audit any computer system on which the Software Product are installed in order to verify compliance with this License Agreement.

12.2 You agree that the Licensor may use Your company name in Licensor’s customer lists and other promotional materials describing Your company as a customer or user of Licensor’s software or services, as applicable, unless it receives written notice from You objecting to such use.

12.3 This License Agreement, its subject matter or its formation (including non-contractual disputes or claims) shall be governed by and construed in accordance with English law and submitted to the non-exclusive jurisdiction of the English courts.

12.4 This License Agreement constitutes the complete and exclusive statement of the agreement between the Licensor and You with respect to the subject matter of this License and supersedes all proposals, representations, understandings, and prior agreements, whether oral or written, and all other communications between the parties relating to that subject matter except for those expressly referred to in this License Agreement.

12.5 Any clause in this License Agreement that is found to be invalid or unenforceable shall be deemed deleted and the remainder of this License Agreement shall not be affected by that deletion.
12.6 Failure or neglect by either party to exercise any of its rights or remedies under this License Agreement will not be construed as a waiver of that party’s rights nor in any way affect the validity of the whole or part of this License Agreement nor prejudice that party’s right to take subsequent action.

12.7 This License Agreement is personal to You, and You may not assign, transfer, sub-contract or otherwise part with this License or any right or obligation under it without the Licensor’s prior written consent.

**ADDENDUM TO THE END USER LICENSE AGREEMENT:**

This addendum (“Addendum”) to the end user license agreement (“Agreement”) applies only to the purchase of an Aqira® System Software Product (as referenced in the Quotation, and hereinafter, the “Aqira Software Product”), is dated as of the date You installed or accepted the Aqira Software Product according to the Agreement, and is between HBM United Kingdom Limited (the “Licensor”) and the end user licensee or its representative/agent authorized to bind the end user licensee (referenced herein as “You” or “Your”). This Addendum shall be governed by the terms of the Agreement and the terms set forth below. Capitalized terms not otherwise defined herein shall have the meaning set forth in the Agreement. If there is a direct conflict between a term in this Addendum and a term in the Agreement, the term in this Addendum shall prevail.

The Licensor and You entered into the Agreement for Your use of the Aqira Software Product, as defined under the Agreement. The Aqira Software Product contains certain technology products owned or distributed by Oracle Corporation UK Limited (including program documentation and any program updates acquired through technical support) (“Oracle Programs”). In order for the license granted to You for the Aqira Software Product under the Agreement to be valid, You must hereby agree to Oracle’s third party terms and conditions for the use of the Oracle Programs. Therefore, the parties acknowledge and agree that this Addendum is incorporated into and made a part of the Agreement, the terms and provisions of which, except as expressly modified in this Addendum, are hereby affirmed and ratified by the parties and remain in full force and effect. You are hereby notified, understand and agree that Your use of the Oracle Programs shall be subject to certain terms and conditions, as follows, and You agree to abide by the following terms and conditions:

(a) You shall limit the use of the Oracle Programs to the legal entity that either executed or entered into and accepted the Agreement;

(b) You shall restrict use of the Oracle Programs to the scope of the Aqira Software Product and to Your internal business operations. You shall be responsible for Your employees, agents, contractors, outsourcers, customers, and suppliers use of the Aqira Software Product and compliance with the Agreement.

(c) Oracle or its licensors retain all ownership and intellectual property rights to the Oracle Programs.

(d) You are prohibited from: (i) transferring the Oracle Programs, except for a temporary transfer in the event of computer malfunction if the Aqira Software Product embeds the Oracle Programs in a physical device; and (ii) assigning, giving, or transferring the Oracle Programs ordered or an interest in them to another individual or entity (in the event You grant a security interest in the Oracle Programs, the secured party has no right to use or transfer the Oracle Programs).

(e) You are prohibited from: (i) using the Oracle Programs for rental, timesharing, subscription service, hosting, or outsourcing; (ii) the removal or modification of any Oracle Program markings or any notice
of Oracle’s or its licensors’ proprietary rights; (iii) making the Oracle Programs available in any manner to any third party for use in the third party’s business operations; and (iv) passing title to the Oracle Programs from You to any other party.

(f) You are prohibited from: (i) reverse engineering, disassembly, or decompilation of the Oracle Programs (the foregoing prohibition includes but is not limited to review of data structures or similar materials produced by the Oracle Programs); (ii) duplicating the Oracle Programs, except for a sufficient number of copies of each Oracle Program for Your licensed use and one copy of each Oracle Program media.

(g) You agree to hereby disclaim, to the extent permitted by applicable law, Oracle’s liability for: (i) any damages, whether direct, indirect, incidental, special, punitive or consequential; and (ii) any loss of profits, revenue, data or data usage, arising from the use of the Oracle Programs.

(h) You agree to prohibit publication of any results of benchmark tests run on the Oracle Programs.

(i) You agree to comply fully with all relevant export laws and regulations of the United States and other applicable export and import laws to assure that neither the Oracle Programs, nor any direct product thereof, are exported, directly or indirectly, in violation of applicable laws.

(j) You are hereby notified, understand, and agree that the Oracle Programs are subject to a restricted license and can only be used in conjunction with the Aqira Software Product and that You are not permitted to modify the Oracle Programs.

(k) You agree to not require that Oracle perform any obligations or incur any liability which has not been previously agreed to between you and Oracle.

(l) You agree to: (i) permit Licensor to audit Your use of the Oracle Programs; (ii) provide reasonable assistance and access to information in the course of such audit; and (iii) permit Licensor to report the audit results to Oracle or allow Licensor to assign to Oracle its audits rights under this Addendum. You agree that Oracle will not be responsible for any of Your costs incurred in cooperating with the audit.

(m) You agree that Oracle is a third party beneficiary of the Agreement.

(n) You are hereby notified that some Oracle Programs may include source code that Oracle may provide as part of the standard shipment of such Oracle Programs; such source code shall be governed by the terms of the Agreement.

(o) You are hereby notified that third party technology that may be appropriate or necessary for use with some Oracle Programs is specified in the Aqira Software Product Documentation or as otherwise notified by the Licensor. Such third party technology is licensed to You only for use with the Aqira Software Product under the terms of the third party license agreement specified in the Aqira Software Product Documentation or as otherwise notified by the Licensor and not under the terms of the Agreement.