XFRACAS 11 Administrative User’s Guide

© 1992-2017 HBM United Kingdom Limited ("HBM UK Ltd"), at Technology Centre, Advanced Manufacturing Park, Brunel Way, Catcliffe, Rotherham S60 5WG. HBM UK Ltd is an affiliate of ReliaSoft Corporation. ALL RIGHTS RESERVED.

This license agreement ("License Agreement") sets forth the terms and conditions that govern the distribution and use of the HBM UK Ltd software documentation (the "HBM Software Documentation"), including any and all derivative works. Any unauthorized distribution or use of the HBM Software Documentation is strictly prohibited.

Licensee hereby acknowledges and agrees to the following terms and conditions of this License Agreement for its use of the HBM Software Documentation:

HBM UK Ltd grants the Licensee who accepts and abides by the terms of this License Agreement a non-exclusive, non-transferable, royalty-free, and revocable license to the HBM Software Documentation. Unless otherwise indicated, all HBM Software Documentation are copyrighted and owned by HBM UK Ltd and are the property of HBM UK Ltd. They are licensed to you and for your use only as an individual who has purchased the software ("Licensee"). Notwithstanding this License Agreement, the Licensee shall not have a license to the trademarks, logos, or any other intellectual property of HBM UK Ltd and/or its affiliates or Licensor(s).

Licensee may print a single copy of the HBM Software Documentation for his/her reference. Licensee may reprint the HBM Software Documentation, as needed, if the original printed copy is damaged and/or destroyed.

Except as provided above, no part of the HBM Software Documentation, either text or image, may be used for any purpose other than Licensee’s own personal use and reference as a learning aid. Therefore, the reproduction, modification, creation of derivative works, storage in a retrieval system, or retransmission, in any form or by any means, electronic, mechanical or otherwise, for reasons other than Licensee’s personal use, is strictly prohibited.

Certain photos and images in the HBM Software Documentation are used under non-transferable licenses obtained by HBM UK Ltd and/or its affiliates and are owned by its Licensor(s) ("Licensor"). Images depicting photos of actual persons are licensed to HBM UK Ltd and/or its affiliates and the signed model releases for these images are on file with the Licensor(s). HBM UK Ltd makes no copyright claims on these images. All ownership and intellectual property rights to the HBM Software Documentation are reserved by either HBM UK Ltd and/or its affiliates or its Licensor(s).

DISCLAIMER: THE HBM SOFTWARE DOCUMENTATION IS PROVIDED “AS IS” WITHOUT WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO: 1) ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT OF INTELLECTUAL PROPERTY; 2) ANY WARRANTY THAT THE HBM COURSE MATERIALS WILL CONFORM TO SPECIFICATIONS; 3) ANY WARRANTY THAT THE WORK WILL BE ERROR FREE OR VIRUS FREE. IN NO EVENT SHALL HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSOR(S) BE LIABLE FOR ANY DAMAGES, INCLUDING, BUT NOT LIMITED TO, DIRECT, INDIRECT, SPECIAL OR CONSEQUENTIAL DAMAGES, ARISING OUT OF, RESULTING FROM, OR IN ANY WAY CONNECTED WITH THE HBM SOFTWARE DOCUMENTATION, WHETHER OR NOT BASED UPON WARRANTY, CONTRACT, TORT, OR OTHERWISE, WHETHER OR NOT LOSS WAS SUSTAINED FROM, OR AROSE OUT OF THE RESULTS OF, OR USE OF, THE HBM SOFTWARE DOCUMENTATION. LICENSEES AGREE TO WAIVE ANY AND ALL CLAIMS AGAINST HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSOR(S), AND SHALL INDEMNIFY, DEFEND AND HOLD HARMLESS HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSOR(S) FOR ANY AND ALL LIABILITIES, CLAIMS, DEMANDS, DAMAGES, EXPENSES OR LOSSES THAT MAY ARISE FROM THE LICENSEE’S USE OR DISTRIBUTION OF THE HBM SOFTWARE DOCUMENTATION, INCLUDING ANY LIABILITIES OR DAMAGES FROM DERIVATIVE WORKS OR OTHER PRODUCTS BASED ON, OR RESULTING FROM, THE USE THEREOF.

This License Agreement is subject to change without notice and does not represent any commitment on the part of HBM UK Ltd and/or its affiliates to the Licensee, including any commitment to maintain or update the HBM Software Documentation. The names of companies, products, people, characters, and/or data mentioned in the HBM Software Documentation are not intended to represent any real individual, company, product or event, unless otherwise noted. Any rights not expressly granted herein are reserved for HBM UK Ltd.

TRADEMARKS:
ReliaSoft, Synthesis Platform, Weibull++, ALTA, DOE++, RGA, BlockSim, RENO, Lambda Predict, Xfmea, RCM++ and XFRACAS are all trademarks of ReliaSoft Corporation.

GlyphWorks, VibeSys, DesignLife and the nCode logos are all trademarks of HBM UK Ltd.

Other product names and services identified in the HBM Software Documentation are trademarks belonging to their respective trademark holders, and are used for illustration purposes. Their use in no way conveys an endorsement or other affiliation with HBM UK Ltd and/or its affiliates.
Table of Contents

Chapter 1: Getting Started .............................................................................................................. 1
  Technical Support ....................................................................................................................... 1
  Reliability Consulting................................................................................................................... 1

Chapter 2: Administrative Ribbon Tabs .......................................................................................... 3
  System Tab .................................................................................................................................. 3
    System ..................................................................................................................................... 3
    Template ................................................................................................................................. 3
    System Tab .............................................................................................................................. 3

Chapter 2: Administrative Ribbon Tabs .......................................................................................... 1

Chapter 3: Managing Users........................................................................................................... 11
  Managing Users ........................................................................................................................ 11
    Entities and Users ................................................................................................................. 11
    User/License Counts ............................................................................................................. 11
    Creating a New Account ....................................................................................................... 11

Chapter 3: Managing Users........................................................................................................... 10
  Report Viewer .......................................................................................................................... 10
  Import Entities ......................................................................................................................... 6
  Resource Editor ......................................................................................................................... 6
  Diagnostics ................................................................................................................................ 6
  Preferences ................................................................................................................................ 8
  Contacts/Companies/Locations .............................................................................................. 7
  Users/User Groups .................................................................................................................. 7
  Tools ........................................................................................................................................ 7
  Configure ................................................................................................................................... 5
  Admin Tab ................................................................................................................................... 5
  Part ........................................................................................................................................ 4
  Serialized Entities ................................................................................................................... 3
  Template .................................................................................................................................... 3
  System Tab .................................................................................................................................. 3

Chapter 1: Getting Started .............................................................................................................. 1
  Technical Support ....................................................................................................................... 1
  Reliability Consulting................................................................................................................... 1
  Technical Support ...................................................................................................................... 1

Table of Contents

Contents
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Editing a User Account</td>
<td>12</td>
</tr>
<tr>
<td>Deleting a User Account</td>
<td>12</td>
</tr>
<tr>
<td>Retiring a User Account</td>
<td>12</td>
</tr>
<tr>
<td>System Wide Information</td>
<td>13</td>
</tr>
<tr>
<td>Entity-Specific Information</td>
<td>14</td>
</tr>
<tr>
<td>Adding Users from Active Directory</td>
<td>21</td>
</tr>
<tr>
<td>Using the Active Directory Page</td>
<td>21</td>
</tr>
<tr>
<td>Managing User Categories</td>
<td>22</td>
</tr>
<tr>
<td>Managing Security Groups</td>
<td>23</td>
</tr>
<tr>
<td>Creating a Security Group</td>
<td>24</td>
</tr>
<tr>
<td>Editing a Security Group</td>
<td>24</td>
</tr>
<tr>
<td>Deleting a Security Group</td>
<td>24</td>
</tr>
<tr>
<td>Group Membership</td>
<td>24</td>
</tr>
<tr>
<td>Managing User Groups</td>
<td>25</td>
</tr>
<tr>
<td>Creating a Group</td>
<td>25</td>
</tr>
<tr>
<td>Assigning Members to a Group</td>
<td>25</td>
</tr>
<tr>
<td>Deleting a Group</td>
<td>26</td>
</tr>
<tr>
<td>Managing Applicants</td>
<td>26</td>
</tr>
<tr>
<td>Chapter 4: Managing Parts and Systems</td>
<td>29</td>
</tr>
<tr>
<td>Managing Generic System Configurations</td>
<td>29</td>
</tr>
<tr>
<td>Finding an Existing System Template</td>
<td>30</td>
</tr>
<tr>
<td>Adding a Part to the System Template</td>
<td>30</td>
</tr>
<tr>
<td>Editing a Part in the System Template</td>
<td>31</td>
</tr>
<tr>
<td>Removing a Part from the System Template</td>
<td>31</td>
</tr>
<tr>
<td>Specifying Failure Modes for Parts</td>
<td>31</td>
</tr>
<tr>
<td>Assigning Responsibility</td>
<td>32</td>
</tr>
</tbody>
</table>
Managing Serialized Systems .................................................................................................... 33
Creating a System Configuration .......................................................................................... 34
Finding an Existing System Configuration ............................................................................. 34
Adding a Part to the System Configuration ........................................................................... 34
Editing a Part in the System Configuration ......................................................................... 34
Removing a Part from the System Configuration ................................................................. 35
Chapter 5: Managing Preferences ............................................................................................ 37
Managing Preferences .............................................................................................................. 37
System-Wide Preferences ..................................................................................................... 38
Boolean Preferences ............................................................................................................. 40
Date Preferences ................................................................................................................... 52
Display Option Preferences .................................................................................................. 52
E-mail Preferences ................................................................................................................ 53
Integer Preferences ............................................................................................................... 53
String Preferences ................................................................................................................. 55
Time Zone Preferences ........................................................................................................ 59
URL Preferences .................................................................................................................... 59
Target and Completed Dates ................................................................................................. 60
Static Pages ............................................................................................................................... 61
Configuring E-mail Message Formats ....................................................................................... 62
E-Mails Based on Calendar Date ........................................................................................... 75
E-mail Reminders for Actions ................................................................................................. 75
E-mail Reminders for Failure Review Board Members ......................................................... 76
Time Metric Calculations ........................................................................................................ 76
Reported System Hours ......................................................................................................... 76
Estimated System Hours ........................................................................................................ 77
Contents

Auto-Populate Time Metric 1 ........................................................................................................ 77
Auto-Calculate Time Metric 1, 2 or 3 ......................................................................................... 78
MTBF, MTBCF, MTBNCF and MTBI .......................................................................................... 79
Extract Data for Reliability Analysis ......................................................................................... 79
Configuring Criticality Metrics ................................................................................................. 80
Entering an ADS Path .................................................................................................................. 81
LDAP Connection String Examples .......................................................................................... 81
Chapter 6: Managing Configurable Fields.................................................................................. 83
Managing Detail Fields .............................................................................................................. 83
Types of Detail Fields ................................................................................................................ 83
Adding or Editing a Field ......................................................................................................... 84
Deleting or Retiring a Field ....................................................................................................... 85
Using Space and Separators ..................................................................................................... 85
Field Types ................................................................................................................................ 86
Configuring the Select Existing Utility .................................................................................... 88
Enable the Search Feature for Selected Detail Fields .............................................................. 89
Set the User Permissions ........................................................................................................ 89
Configuring Hyperlink Details ................................................................................................. 90
Managing Criticality Fields ...................................................................................................... 90
Using the Criticality Page ......................................................................................................... 91
Managing Lists ........................................................................................................................ 92
Lists ....................................................................................................................................... 94
Issue Utility .............................................................................................................................. 95
Managing Actions ..................................................................................................................... 96
Chapter 7: Managing Customers ............................................................................................... 99
Managing Contacts .................................................................................................................... 99
Creating a New Contact ........................................................................................................ 99
Editing a Contact................................................................................................................... 99
Deleting a Contact ............................................................................................................... 100
Contact Properties .............................................................................................................. 100
Managing Companies ............................................................................................................. 100
Creating a New Company ................................................................................................... 101
Editing a Company .............................................................................................................. 101
Deleting a Company ............................................................................................................ 101
Company Properties ........................................................................................................... 101
Managing Locations ................................................................................................................ 102
Creating a New Location ..................................................................................................... 103
Editing a Location ................................................................................................................ 103
Deleting a Location ............................................................................................................. 103
Location Properties ............................................................................................................. 103
Chapter 8: Managing Entities ..................................................................................................... 105
Adding or Editing an Entity ..................................................................................................... 105
Entity Properties ..................................................................................................................... 105
Duplication Settings ................................................................................................................ 106
Chapter 9: Administrator Reports .............................................................................................. 109
Managing Reports ................................................................................................................... 109
Chapter 10: Imports/Exports ...................................................................................................... 111
Data Import Page .................................................................................................................... 111
XML and XLSX Templates .................................................................................................... 111
Adding Files to Import ......................................................................................................... 112
Processing Files in the Inbox ............................................................................................... 112
Exporting to XML.................................................................................................................... 113
## Contents

- DIU Service .............................................................................................................................. 114
- Web Service ............................................................................................................................ 114
- Using the Service ................................................................................................................. 114
- Importing Systems from Xfmea .............................................................................................. 115
- Association with Xfmea ....................................................................................................... 115

### Chapter 11: Additional Tools ...................................................................................................... 117

- Diagnostics .............................................................................................................................. 117
- Resource Editor ....................................................................................................................... 117

http://xfracas.reliasoft.com
Chapter 1: Getting Started

This guide presents detailed documentation of the features available in ReliaSoft XFRACAS administrative interface. The administrative utilities allow you to configure XFRACAS to meet your company’s particular needs. The system administrator maintains all text strings via the Resource Editor; therefore, the names of your pages may be different from the ones presented here. However, the underlying functionality of the pages is the same.

Additional materials that may be of interest include:

- The user help file - also accessible from within the XFRACAS interface by choosing Options > Help > Contents.
- The XFRACAS Implementation Guide - how to set up the website and connect it to a Synthesis repository, and a summary of the initial configuration decisions (such as whether to use SSL, the size limit for uploaded attached files and where to store them, etc.).

Technical Support

If you have a question or experience a problem with XFRACAS, contact the system administrator or ReliaSoft technical support staff for help.

You can contact us directly via phone, e-mail or mail. To find the office that serves your region, visit http://www.reliasoft.com/contact.htm.

Reliability Consulting

If your organization does not have sufficient time, expertise or objectivity in-house to accomplish specific reliability goals, turning to ReliaSoft expert reliability consultants can prove to be the most effective and economical solution. Whether you need a quick statistical analysis, a complete assessment of your reliability program plan or something in between, Reliability Consulting Services (RCS) is ready to help.

- Our reliability consulting services team has combined expertise in almost all areas of reliability and quality engineering with experience that spans a broad spectrum of product types, from micro-electronics and appliances to advanced weapons systems and off-shore oil well drilling equipment.
- Unlike engaging a consultant who works independently, RCS consultants have direct access to all of ReliaSoft global resources, expertise and contacts.
- Our team-based approach to consulting, combined with ReliaSoft global reliability engineering organization, allows us to provide you with reliability consultants who
understand your culture and speak your language while ensuring that the appropriate reliability expertise can be applied to each and every project.

- RCS is structured to **accommodate requests of any size or complexity**, from short telephone consultations to multiple experts at a client's site for an extended time period.

Please visit [http://consulting.reliasoft.com](http://consulting.reliasoft.com) for a published list of commonly requested services, answers to frequently asked questions, and other useful information about this service.
Chapter 2: Administrative Ribbon Tabs

System Tab

The System tab contains commands related to working with system configurations and is available only to administrators. This tab will be visible to you if you have the "Manage Serialized Systems" permission or the "Manage Template Systems" permission.

Please refer to the user help for information on the commands on the Home and Options tabs.

System

- **Template** opens the Template page, which allows you to view and manage system templates.
- **Serialized** opens the Serialized page, which allows you to view and manage serialized system configurations.

Template

- **Create Template** opens the Create Template Part utility, allowing you to create a new system template.
- **Find Template** opens the Find Template utility, which allows you to search for an existing system template by template part name or template part number.
- **Xfmea Import** opens the Xfmea Import utility, which allows you to import system hierarchy data from Xfmea/RCM++ into XFRACAS. This command appears only if the current database has associated Synthesis tables that you have permission to access and has at least one project with a system hierarchy.

Serialized

- **Create System** opens the Create Serialized Part utility, allowing you to create a serialized system based on an existing system template.
- **Find System** opens the Find System utility, which allows you to search for an existing serialized system by the system serial number, subsystem serial number, subcomponent part name or subcomponent part number.
Part
The commands in the Part group will vary depending on whether you are working with templates or serialized systems.

When you are working with a template, the following commands will appear.

- **Create** opens the Create Template Part utility, allowing you to create a new system part under the part currently selected in the system configuration.
- **Edit** allows you to edit the information for the part currently selected in the system configuration.
- **Delete** removes the currently selected part from the system configuration, or retires it if it is used in records within the system.
- **Associate** opens the Associate Template Parts utility, which allows you to select one or more existing template parts to associate below the part currently selected in the system configuration.
- **Disassociate** removes the currently selected part from the system configuration and makes it a top level part.
- **Assign Owner** opens the Assign Template Part Owner utility, which allows you to specify the owners who is responsible for the selected part.
- **Remove Owner** removes the owner from the selected part and clears the e-mail notification list for the part. This command is available only for parts with owners.
- **CC List** opens the Assign E-mail Notification List utility, which allows you to specify addition users to be included in the e-mail notification list for the selected part. This command is available only for parts with owners.
- **Sync with Xfmea** synchronizes the data in XFRACAS to reflect changes made within Xfmea after the part has been imported. This command is available only when you are working with a part that was imported from Xfmea.
- **Export** exports the currently selected part and any children to a new *.xml file. Depending upon your permissions, this command may have a drop-down list of options. In this case, choose **Part** to export the currently selected part and any children to a new *.xml file, or choose **Master BOM** to export the entire system configuration that the currently selected part belongs to, including all details associated with all parts.
Chapter 2: Administrative Ribbon Tabs

When you are working with a serialized system, the following commands will appear.

- **Create Serialized** opens the Create Serialized Part utility, allowing you to create a new serialized part under the part currently selected in the system configuration.

- **Edit Serialized** allows you to edit the information for the serialized part currently selected in the system configuration.

- **Delete Serialized** removes the currently selected serialized part from the system configuration, or retires it if it is used in records within the system.

- **Add Non-Serialized** opens the Add Non-Serialized Parts utility, which allows you to select one or more existing non-serialized parts to associate below the part currently selected in the system configuration.

- **Add Existing Serialized** opens the Add Existing Serialized Parts utility, which allows you to select an existing serialized part to associate below the part currently selected in the system configuration.

- **Disassociate** removes the currently selected part from the serialized system configuration and makes it a top level part.

- **Export** exports the currently selected part and any children to a new *.xml file.

**Admin Tab**

The Admin tab contains commands related to performing administrative tasks and is available only to administrators. You must have the "Access Admin Tab" permission to view this tab. The contents available to you within the tab will depend on your permissions for individual features.

Please refer to the user help for information on the commands on the Home and Options tabs.

**Configure**

- **Security**

**What's Changed?** In Version 11, the term "User Group" now refers to a new feature that allows administrators to create predefined groups of users that can quickly be added to the team for an incident, problem or project. The term "Security Group" refers to a group of users who have the same categories and permissions.
Chapter 2: Administrative Ribbon Tabs

- **Users** opens the [Users page](http://xfracas.reliasoft.com), which allows you to add contact and permissions information for authorized XFRACAS users and edit the properties of existing user accounts.

- **Security Groups** opens the [Security Groups page](http://xfracas.reliasoft.com), which allows you to create and edit groups of users who have the same categories and permissions.

- **User Groups** opens the [User Groups page](http://xfracas.reliasoft.com), which allows you to create and manage predefined groups of users that can quickly be added to the team for an incident, problem or project.

- **Applicants** opens the [Applicants page](http://xfracas.reliasoft.com), which allows you to add users who have requested access to the system and set their permissions.

- **Active Directory** opens the [Active Directory page](http://xfracas.reliasoft.com), which allows you to add users from Microsoft Active Directory.

**Manage**

- **Contacts** opens the [Contacts page](http://xfracas.reliasoft.com), which allows you to view and maintain contact information in the system.

- **Companies** opens the [Companies page](http://xfracas.reliasoft.com), which allows you to view and maintain the companies that contacts can be associated with and that users can select from when they create CSI records.

- **Locations** opens the [Locations page](http://xfracas.reliasoft.com), which allows you to view and maintain the locations that can be assigned to companies and to customer support information and incident report records.

- **Preferences** opens the [Preferences page](http://xfracas.reliasoft.com), which allows you to maintain the system preferences that control various aspects of XFRACAS.

- **Details** opens the [Details page](http://xfracas.reliasoft.com), which allows you to manage some of the fields that appear in various record types.

- **Lists** opens the [Lists page](http://xfracas.reliasoft.com), which allows you to maintain lists of available values for user interface fields that require selection from specified values.
**Chapter 2: Administrative Ribbon Tabs**

- **User Categories** opens the User Categories page, which allows you to maintain the categories that users can be assigned to. These categories can be used to filter drop-down lists of users (e.g., when assigning users to failure review boards).

- **Action Management** opens the Action Management page, which allows you to maintain the action type categories that users can select from when they create actions.

- **Criticality** opens the Criticality page, which allows you to maintain the criticality fields that may appear in the Incident and Problem pages.

**Tools**

- **Diagnostics** opens the Diagnostics page, which provides an error log for the current entity.

- **Resource Editor** opens the Resource Editor page, which allows you to manage the text that appears in the XFRACAS interface.

- **Entities** opens the Entities page, which allows you to manage the entities that exist in XFRACAS.

- **Import** opens the Data Import page, which allows you to manage the process of importing data from other sources via *.xml files.

- **Report Viewer** opens the Report Viewer page, which allows you to control the display of the standard reports, chart reports, custom reports and administrator reports.

The following groups appear only when you are working on the relevant pages.

**Users/User Groups**

When you are working with user accounts, including users, user groups and applicants, the Admin tab will contain a group of commands appropriate to the record type. The commands in this group will vary depending on whether you are creating a user/group or working with an existing user/group.

When you are creating a user/group (including when you are working with an applicant), the following commands will appear.

- **Create** saves the user/group once you have entered all required information.

- **Delete** deletes the applicant from the request list. This command is available only when working on the Applicants page. **There is no undo for delete.**
Chapter 2: Administrative Ribbon Tabs

When you are working with an existing user/group, the following commands will appear.

- **Save** saves the current user/group. This command is available on the Users page and the User Groups page.

- **New** clears the user/group information from the interface so that you can create a new one. The existing user/group is unaffected. This command is available on the Users page and the User Groups page.

- **Duplicate** duplicates the current user so that you can easily create a new user who has similar properties. This command is available only on the Users page.

- **Export** exports the current user to a new *.xml file. This command is available only on the Users page. If you want to export multiple users simultaneously, use the **Admin > Import > Export** command on the Data Import page.

- **Delete** deletes the current user/group. This command is available on the Users page and the User Groups page. **There is no undo for delete.**

**Contacts/Companies/Locations**

When you are working with external contact information, including contacts, companies and locations, the Admin tab will contain a group of commands appropriate to the record type. The commands in this group will vary depending on whether you are creating a record or working with an existing record.

When you are creating a record, the following command will appear.

- **Create** saves the new record once you have entered all required information.

When you are working with an existing record, the following commands will appear.

- **Save** saves the current record.

- **New** clears the current record information from the interface so that you can create a new one. The existing record is unaffected.

- **Export** exports the current record to a new *.xml file. If you want to export multiple records simultaneously, use the **Admin > Import > Export** command on the Data Import page.

- **Delete** deletes the current record. **There is no undo for delete.**
Preferences

- **Save** saves your changes to the preferences.

Diagnostics

- **Excel** exports the Diagnostic error log to a new *.xlsx file.
- **Delete** removes the currently selected error(s) from the Diagnostic error log. There is no undo for delete.

Resource Editor

- **Find** opens the Find utility, which allows you to search for the resources in the current entity that you want to work with in the Resource Editor.
- **Replace** opens the Find and Replace utility, which allows you to replace all occurrences of a text string in the current entity with new text.
- **Update Script** opens the Update Script utility, which allows you to specify a range of changes that you have made in the current database and implement those changes in another database.
- **Default All** returns all resources in the current entity to the default text.

Entities

- **Edit** opens the Entity utility, which allows you to edit the entity that is currently selected in the Entities page.
- **Create** opens the Entity utility, which allows you to add a new entity to the XFRACAS database.

Import

- **Add** opens the Add Import File utility, which allows you to specify an *.xml file to import into XFRACAS.
- **Process** causes scheduled imports to be processed immediately, rather than waiting for a scheduled import. This command will appear only if you have certain permissions.
Chapter 2: Administrative Ribbon Tabs

Export opens the Export File utility, which allows you to specify one or more records to export to an *.xml file.

Report Viewer

Save saves your changes in the Report Viewer page.
Chapter 3: Managing Users

Managing Users
The Users page allows you to manage user accounts for XFRACAS. Permissions required to access this page: Access Admin Tab and Manage Users.

To open the Users page, choose Admin > Configure > Security > Users.

Entities and Users
If your XFRACAS website has more than one Entity, the login and contact details will be the same for all entities that are assigned to the user (System Wide Information), but the permissions and other details will be managed separately for each entity (Entity Specific Information).

The drop-down list at the top of the page determines which entity-specific information is currently displayed.

User/License Counts
- **Current Entity Users** - number of user accounts assigned to the current entity
- **Current System Users** and **Remaining User Licenses** - number of user accounts across all entities and the number of additional user accounts allowed by your license
- **Current Entities** and **Remaining Entity Licenses** - number of entities and the number of additional entities allowed by your license
- **Days Remaining** - number of days until the license expires

Creating a New Account
If the Select Name to Edit list is blank, simply enter the required fields and choose Admin > Users > Create.

If you need to clear an existing user's account information before creating a new one, choose Admin > Users > New.
Chapter 3: Managing Users

If you want to start with the settings from an existing account, select it from the list and then choose **Admin > Users > Duplicate**.

**Editing a User Account**

To edit an existing user account, choose the user name from the **Select Name to Edit** list. Make the desired changes and then choose **Admin > Users > Save**.

Remember that a user can have different permissions in each entity. If you change the permission for one entity, it will not change the permissions in the other entities that the user is assigned to.

**Deleting a User Account**

To delete an existing user account, choose the user name from the **Select Name to Edit** list and then choose **Admin > Users > Delete**.

You can delete a user account only if no records are associated with the account. If the user account is listed as an owner, author, team member or reviewer for any record or status, choosing **Delete** will instead retire the user account.

**Retiring a User Account**

A user can be retired from a particular entity or from the entire XFRACAS website. In both cases, you can configure the account to be retired automatically on a certain date and time, or you can manually retire the account.

To retire an account from the website (all entities), use the options in the **System Wide Information** area.

To retire an account from a particular entity, make sure the appropriate entity is selected and then use the options in the entity-specific area.
System Wide Information
These permissions will be the same for all entities that the user can access.

- For name and address, only the First Name and Last Name are required.

- The Time Zone is the offset from Coordinated Universal Time (formerly known as Greenwich Mean Time) that is appropriate for this user. The default setting is specified on the Preferences page ("Default GMT Offset for New Users").

  Tip: If you choose the "Local Time" option, XFRACAS will detect the current time zone offset on the client device and apply that (including the effect of daylight savings time). If you select a specific time zone, daylight savings will not be considered and you must change the setting twice a year.

- Language sets the user's preferred language for interface text. If this field is blank, the user will see the interface text in the default language for the entity, which is specified on the Preferences page ("XFRACAS - Language").

- E-mail Address is required. The following preferences can be configured to autopopulate the address based on first and last name (e.g., firstname.lastname@email_suffix.com).
  - Under Boolean Preferences: "Manage User - E-mail/Login Auto Build"
  - Under E-mail Preferences: "Manage User - E-mail Suffix Used for Auto Build"

- Login is required. If you are using Active Directory or Windows Authentication, this is typically in the format of "domain\username". If you are using SSO for authentication, it would be the SSO ID passed to the application. If you are unsure what to use, ask the user to try to access the website. If the account is not recognized, the login that you need to use will be displayed in single quotes in the Unknown User page.

  Note that if the "Manage User - E-mail/Login Auto Build" preference is enabled, the website will automatically start building the login based on the user's first and last names. You can edit or replace the text that's automatically populated, or change the preference at any time.

- The Retired User Account and Account Expiration Date options in this area will retire the account for entities and the user will have no access to the website. Alternatively, if you want to retire the account only for the current entity, use the options in the entity-specific area.

- The Default Entity is the entity that will be selected by default when the user logs in. This field is not displayed until the record is created.
Chapter 3: Managing Users

- **Entities** are the entities that the current user can access. Click the link to add or remove entities.
  - There may be entities that the user has access to that you do not. In this case, you will not be able to manage access to those entities for the user.
  - You will not be able to remove access to the user's default entity (displayed in square brackets).
  - If you remove access to an entity, all entity-specific information will be deleted. If you later add the entity back to the user's account, you will need to re-assign groups, categories and permissions.

**Entity-Specific Information**
These settings and permissions apply only to the entity that is currently selected.

- The **Retired User Account** and **Account Expiration Date** options in this area will retire the account only for the entity that is currently selected. Alternatively, if you want to retire the account for the entire website, use the options in the system-wide area.

- **Security Groups** are the security group(s) that the user has been assigned to for the current entity. Each security group has certain permissions associated with it, which are managed on the [Security Groups page](http://xfracas.reliasoft.com).

**Categories**
These permissions specify which user categories, if any, the user belongs to. The available categories for each entity are managed on the [User Categories page](http://xfracas.reliasoft.com).

**Permissions**

- **Creating Records**: These permissions enable the user to create specific record types:
  - CSI – Create CSIs
  - Incident – Create Incident Reports
  - Problem – Create Problems
  - Project – Create Projects

- **Editing and Re-opening Records** - The owner of an action, incident, problem or project will be able to edit the record when it is open. The owner of the parent record (incident, problem or project) can also edit open actions associated with that record. In addition:
  - These permissions enable the user to edit all open incidents or problems.
    - **Incident - Edit All Open Incidents**
• **Problem - Edit All Open Problems**

These permissions enable the user to edit open incidents, problems or projects if the user belongs to the team.

• **Incident - Team Edit**

• **Problem - Team Edit**

• **Project - Team Edit**

These permissions allow the user to open a closed action, incident, problem or project if the user had permission to edit the record when it was open.

• **Action - Open a Closed Action**

• **Incident - Open a Closed Incident**

• **Problem - Open a Closed Problem**

• **Project - Open a Closed Project**

These permissions allow the user to edit all open incidents, problems or projects, and also re-open records that are closed.

• **Incident - Edit All Incidents**

• **Problem - Edit All Problems**

• **Project - Edit All Projects**

These permissions allow the user to edit all customer support or failure analysis records.

• **CSI - Update/Edit Customer Support**

• **Failure Analysis - Edit/Update Failure Analysis**

• **Deleting Records**: These permissions allow the user to delete records. Care should be taken when giving a user these permissions. *There is no undo for delete*. We recommend that users be granted these permissions only when they need to delete a record, and changing the permissions back to "No" after that is done.

• **Warning - Allow CSI Delete**

• **Warning - Allow Incident Delete**

• **Warning - Allow Problem Delete**

• **Warning - Allow Project Delete**
• **Warning - Allow Repaired/Replaced Part Row Delete**

• **Customer Support (CSIs) fields:** These permissions enable the user to change the specified field in the Customer Support page.
  
  • **CSI – Edit Commission Date**
  
  • **CSI – Edit System Hours Report Date**

• **Incident fields:** These permissions enable the user to change the specified field in the Incident page.
  
  • **Incident – Change Responsible Part**
  
  • **Incident – Edit Serialized Part Information**
  
  • **Incident – Edit System Hours**
  
  • **Incident – Override Automatic Warranty Determination**
  
  • **Incident – Update Location Information**

• **Incident – Allow System Template Modifications:** When working with a serialized incident, the user can edit the serialized system via the Repair/Replace Parts utility by choosing a replacement part from another system. The part will be added to the system template. It will not be deleted or retired from the original template.

• **Incident – Duplicate Repair/Replace Row:** The user can duplicate line items in the Repaired/Replaced Parts table on the Incident page.

• **Incident/Problem – Allows Incident/Problem Association:** The user can associate incidents with problems or problems with incidents.

• **Incident/Problem – Change Creator Name:** The user can change the name of an incident creator or problem creator.

• **Problem – Edit FRB List:** The user can edit the Failure Review Board (FRB) list for problems. The problem owner can always change the FRB list, even if this permission is "No."

• **Problem – Change Problem Owner and Priority:** The user can change the owner of a problem and the problem’s priority.

• **Problem – Close Problem:** The user can close a problem.

• **Project – Change Creator Name:** The user can change the name of the project creator.
• **Creating and Deleting Actions**: These permissions enable the user to create and delete actions for specific record types.
  - Action – Create CSI Action and Action – Delete CSI Action
  - Action – Create Failure Analysis Action and Action – Delete Failure Analysis Action
  - Action – Create Incident Action and Action – Delete Incident Action
  - Action – Create Problem Action and Action – Delete Problem Action
  - Action – Create Project Action and Action – Delete Project Action

• **Action – Change Action Association**: The user can change the record that an action is associated with.

• **Action – Set/Alter Action Due Dates**: The user can set and change the dates within an action. The owner of the record the action is associated with can edit the action properties, even if the permission is "No." In addition, a user who has the permission to edit all records of a given type can also edit the action properties.

• **Using Detail Fields**: These permissions set what the user can do with certain types of Detail fields in any record where that type of detail is used.
  - Details – Allow Issue Creation: The user can enter new drop-down values in a "Select List" detail field that has the "Allow User Creation" option selected.
  - Details – Edit All Statuses: The user can edit statuses that have been entered, by any user, in a "Status" detail.
  - Details – Overwrite Read-Only: The user can modify detail fields that are set to "Read-Only - Always." This option is intended to be used for values that will be imported and should not be changed by users via the web interface. This permission enables the user to correct the imported values if needed.
  - Details – Allow Failure Mode Creation: The user can create failure modes.
  - Details – Delete Associated File: The user can delete files that have been uploaded/linked in an "Attachments Table" detail. *There is no undo for delete.*

• **Allow Existing Text Search** - These permissions enable the user to access the Select Existing Utility for description and status fields. (See [Configuring the Select Existing Utility](#).)
  - Details - Allow Existing Text Search
  - Action - Allow Existing Text Search
Chapter 3: Managing Users

- CSI - Allow Existing Text Search
- Project - Allow Existing Text Search
- Failure Analysis - Allow Existing Text Search

Viewing Reports and Charts:

- **Reports – Access Reports Page**: The user can run reports.
- **Charts – Access Charts Page**: The user can run charts.
- **Reports – My Queries Enabled**: The user can view and use reports saved to the "My Reports" and "My Chart Reports" lists.
- **Reports – Public Queries Enabled**: The user can view and use reports saved to the "Public Reports" and "Public Chart Reports" lists.
- **Report – Show Report SQL**: The user can view the SQL Statement used with report results, using the Show SQL Statement icon on the Reports Toolbar.
- **Allow Sending XFRACAS Data via E-mail**: The user can send report results via e-mail, using the E-mail Report icon on the Reports Toolbar.

Building Reports and Charts:

- **Report Builder – Access Report Builder**: The user can use the Report Builder to create custom reports and charts and to modify their versions of the built-in standard reports for their personal use.
- **Reports – Access Custom SQL Reports**: The user can use the Report Builder to create Custom SQL Statements.
- **Report Builder – Assign or Remove Public Access**: The user can save reports to the "Public Reports" and "Public Chart Reports" lists. There is a separate permission for the ability to access public reports in the Reports page or Charts page ("Reports – Public Queries Enabled").
- **Reports – Save Report for Another User**: The user can save a report to another user's or groups' "My Reports" or "My Chart Reports" lists. If you save the report for yourself, there is a separate permission for the ability to access "my reports" in the Reports or Charts page ("Reports – My Queries Enabled"). If you save the report for someone else, you will not be able to view it again after it is saved.

**Note**: This also controls the ability of a user to save dashboard layouts for another user or group.
• **Reports – Serialized System Search Enabled** and **Reports – Template Part Search Enabled**: The user can see the Serialized Search and Part Search commands in the Report Builder ribbon. These enable the user to find specific part numbers and serial numbers without giving admin permissions to the part template and serialized system pages.

• **Viewing and Designing Dashboards:**
  - **Dashboard – Access Dashboard Page**: The user can view existing dashboard layouts.
  - **Dashboard Designer – Access Dashboard Designer Page**: The user can create custom dashboard layouts.
  - **Dashboard Designer – Assign or Remove Public Access**: The user can make dashboard layouts available to all users in the current entity.

• **Portal – Edit User Information**: The user can edit their own user information (**Options > Settings > User Information**).

• **Portal – Edit Portal Preferences**: The user can change their own Portal Preferences.

• **Portal – Set Default Portal Preferences**: The user can change the Portal preferences that are used by default for new accounts (using the "Save as application default" check box).

• **Links and Announcements**: These permissions allow the user to create and modify public links and announcements.
  - **Portal – Create Public Links and Announcements**
  - **Portal – Modify Public Links and Announcements**

• **Ribbon – Quick Search Enabled**: The user can view and use the Quick Search utility that appears at the top of many pages.

• **Synthesis – Read Failure Mode Data** makes failure mode data readable to Xfmea/RCM++/RBI.

• **Synthesis – Read Time to Event Data** makes time to event data readable to Weibull++, ALTA and RGA through the Synthesis Data Warehouse.

**Administrative Permissions**

Only the administrative permissions that the logged in user has will be shown in this list (i.e., you can only give other users a permission that you have yourself).

• **Access Data Export**: The user can access the Export command in the ribbon for individual records (e.g., incidents, problems, etc.), generic templates, serialized systems and in the Import page.
Chapter 3: Managing Users

- **Access Import Processing**: On the Import page, the user can cause scheduled imports to be processed immediately, rather than waiting for a scheduled import. The user must have this permission to upload and process files either through the Import page, the web service or the API.

- **Access Master BOM Export**: On the Template page, the user can export a list of the currently selected part and its child items within the template configuration that the part belongs to, including all details associated with all parts. This export is intended to allow the user to update the details, part names and part numbers for specific parts.

- **Access Admin Tab**: The user can access the Admin tab on the XFRACAS ribbon.

These permissions enable access to parts of the administrative functionality.

- Manage Action Categories
- Manage Active Directory
- Manage Companies
- Manage Contacts
- Manage Criticality
- Manage Details
- Manage Diagnostics Page
- Manage Entities
- Manage Import
- Manage Lists
- Manage Locations
- Manage Part Owners
- Manage Report Viewer
- Manage Resource Editor
- Manage Security Groups
- Manage Serialized Systems
- Manage Template Systems
- Manage User Categories
- Manage User Groups
• **Manage Users**

  • These permissions allow the user to manage the specific preference types on the Preferences page.

  • **Manage System-Wide Preferences**

  • **Manage Entity Preferences**

**Responsible Parts**

These are the parts that the user has been assigned as the owner of. When a user account is retired, all parts that the user is responsible for should be reassigned.

  • ![Reassign Owner for Selected Parts] allows you to assign a different owner for the part(s) that are currently selected.

  • ![Remove Owner for Selected Parts] removes the current user’s ownership of the part(s). This will also clear the e-mail CC list.

**Responsible Open Items**

This area displays a count of all open incidents, problems and actions that have been assigned to the current user. Clicking each count opens a report that lists all of the records of that type. When a user is retired, all items that the user is responsible for should be reassigned.

  • **Reassign Owner for Open Items** allows you to assign a different owner for all records of a particular type.

**Adding Users from Active Directory**

The Active Directory page allows you to add users from Microsoft Active Directory. Permissions required to access this page: Access Admin Tab and Manage Active Directory.

To open the Active Directory page, choose Admin > Configure > Security > Active Directory.

![User Icon] The number of current entity users, current system users, current entities in the system and remaining days in the software license are displayed at the top of the page. The rest of the page allows you to search Active Directory and specify account information and permissions for the users that you will create.

**Using the Active Directory Page**

First, use the Search Options fields to narrow the Active Directory users that will be shown:

  • Specify the Domain to search in.
Chapter 3: Managing Users

- Specify a Group Type.
- If desired, you can enter text to search for in the Group Name field to limit the groups shown.
- Click Load Groups () to populate the Group drop-down list. Select the group of interest from the list.
- If desired, use the Filter By fields to select a criterion to filter the users by, and to specify the text to match.

Once you have specified all of your search criteria, click the Load Users link to populate the Active Directory Users list. Any Active Directory users that already have XFRACAS accounts will be shown in the Current XFRACAS Users list.

Use the arrows to move some or all user names from the Active Directory Users list to the New XFRACAS Users list. You can then set the basic account information, user groups, categories and permissions for all of the users in the New XFRACAS Users list. (For more details on these settings, see Managing Users.) Choose Admin > Users > Create to create the accounts.

The accounts will be created, and will appear in the Current XFRACAS Users list.

Managing User Categories

The User Categories page allows you to maintain the categories that users can be assigned to. These categories can be used to filter drop-down lists of users (e.g., when assigning users to failure review boards). Permissions required to access this page: Access Admin Tab and Manage User Categories.

To open the User Categories page, choose Admin > Configure > User Categories.

If your XFRACAS website has more than one Entity, the user categories can be configured separately for each. The drop-down list at the top of the page determines which entity's categories are currently displayed.

- To create a new user category, click the Add icon, .
- To edit an existing user category, select it in the list and click the Edit icon, . Changes will apply to all user accounts that have already been associated with that category.

http://xfracas.reliasoft.com
To remove a user category from the current entity, select the user category in the list and click the **Delete** icon. If the category is associated with any other entities, it will still be available for those entities.

The following default categories cannot be deleted or renamed, but their display order can be changed.

- **D2 Approver - D8 Approver** each sets permission for the user to be added to a failure review board (FRB) to approve the respective step of a problem.
- **Default Problem Reviewer** sets permission for the user to be the default problem reviewer. This user will appear by default in the **Selected Reviewers** list when selecting an FRB.
- **FA Engineer** sets permission for the user to be assigned as a failure analysis engineer.
- **Legal Expert** sets permission for the user to be assigned as a legal expert. This category determines the list of users who can be assigned to the "Legal" role in a team. (See [Assign Team Members Utility](#).)
- **Project Owner** sets permission for the user to be the owner of projects. The user's name will appear in the **Project Owner** drop-down list on the Project page.
- **Problem Owner** sets permission for the user to be the owner of problems. The user's name will appear in the **Problem Owner** drop-down list on the Problem page.

## Managing Security Groups

The Security Groups page allows you to manage sets of permissions and categories that can be assigned to individual user accounts. The categories and permissions on this page are the same as those on the [Users page](#). Permissions required to access this page: Access Admin Tab and Manage Security Groups.

What's Changed? In versions prior to 11, security groups were called "user groups." That term now applies to a group of users that can be quickly assigned to work together on a team for an incident, problem or project.

To manage security groups, choose **Admin > Configure > Security > Security Groups**.

If your XFRACAS website has more than one **Entity**, user permissions can be managed separately for each entity.
Chapter 3: Managing Users

Creating a Security Group
To create a new security group, you can:

- Leave the Select Group to Edit drop-down list blank. Enter the group name and description, set the permissions and then choose Admin > Security Groups > Create.

- If you are currently viewing an existing security group and want to clear the information and create a new group, choose Admin > Security Groups > New or clear the Select Group to Edit field.

You can then enter the group name and description, set the permissions and then choose Admin > Security Groups > Create.

Editing a Security Group
To edit an existing security group, choose the group from the Select Group to Edit drop-down list. Make the desired changes and then choose Admin > Security Groups > Save.

Deleting a Security Group
To delete an existing security group, choose the user name from the Select Group to Edit drop-down list and then choose Admin > Security Groups > Delete.

Note that this will remove any users from the group and delete the group. Any users with permissions via the group will lose those permissions.

Group Membership
Click Manage Group Membership to view or modify the users who are assigned to this security group. (Note that you can also change a particular user's security group from the Users page.)

If your organization uses Microsoft Active Directory, you can manage the membership of any security group based on an associated Active Directory group. For example, any users assigned to the "ABC Team" or the "XYZ Team" in Active Directory can be assigned to have specific sets of permissions in the entity. If a user needs to be added or removed from a security group, the administrator can manually sync the group to the Active Directory group to reflect the changes made in Active Directory.
To associate a security group with an Active Directory group, select the **Associate Active Directory Group** check box and then specify the domain name. Click the **Load** icon, beside the **Security Group** field to load available groups, then select the group and click the **Load** icon beside the **Active Directory Users** field to load the users in the group. Click **Associate** to finalize the association.

### Managing User Groups

New in Version 11, a user group is a predefined group of users and team roles that can be quickly assigned to teams for incidents, problems or projects. Permissions required to access this page: Access Admin Tab and Manage User Groups.

**What’s Changed?** In Version 11, the term "Security Group" refers to a group of users who have the same categories and permissions.

To manage user groups, choose **Admin > Configure > Security > User Groups**.

If your XFRACAS website has more than one **Entity**, you must create separate user groups for each entity.

### Creating a Group

1. Make sure the **Select Group to Edit** drop-down list is blank. If you are currently viewing another group, you can either choose the blank option from the list, or click **Admin > User Groups > New**.

2. Enter at least a **Name** for the new group.

3. Click **Admin > User Groups > Create**.

### Assigning Members to a Group

1. Select the group from the **Select Group to Edit** drop-down list.

2. Click **Assign/Remove Members** to open the Assign Members utility.
Chapter 3: Managing Users

- To add users, select a Team Role, then select the user(s) who will have that role, then click Add User(s). Note that only users who have the "Legal Expert" category in the Users page can be assigned to the "Legal" role on a team.

- To remove group members, select the user(s) in the Current Members list and click Remove Selected.

- Click Save to close the window.

Changes to group members are saved when you close the Assign/Remove Members window. If you need to save changes to the group’s name or description, choose Admin > User Groups > Save.

Deleting a Group
To delete an existing user group, choose the group name from the Select Group to Edit dropdown list and then choose Admin > User Groups > Delete.

Managing Applicants
When a user requests access to XFRACAS via the Request Access page, an e-mail notice containing a list of requested entities is sent to the administrator of each entity that the user requests access to. This is controlled by the "Administrator E-mail" preference. Clicking the Applicant Information for... link in the e-mail will open the Applicants page, where you can set the permissions for the applicant and then add him or her as a user to the system. You can also open the page by choosing Admin > Configure > Security > Applicants.

Permissions required to access this page: Access Admin Tab and Manage Users.

The Select Name to Edit drop-down list allows you to choose an applicant to edit. The names that appear in this list will be those users who have requested access to the current entity. To give an applicant access to the system, select the applicant from the drop-down list, enter any relevant information including entities and permissions and then choose Admin > Users > Create.
If you want to remove the applicant instead of adding them to the system, choose Admin > Users > Delete.

**There is no undo for deleting an applicant.**

The fields in the System Wide Information area and the Entity-Specific Information area are the same as those in the Users page.

If a user has entered location information that does not already exist in the system, you will be prompted to add, edit or cancel these entries. If a user has requested access to several entities, the administrator can add them only to those entities for which the administrator has permissions. Access to the remaining entities can be granted by the administrators of those entities. When they attempt to add the new user, they will be shown a prompt stating that the user already exists, and asking if they would like to add the user to the selected entities. Clicking OK will add the existing user to any selected entities they are not already a member of. If one administrator has created the user and provided access to all requested entities, when another administrator then opens the link, an error message saying "Applicant has already been processed or deleted" will appear.
Chapter 4: Managing Parts and Systems

Managing Generic System Configurations

XFRACAS includes both generic and serialized system configuration information.

- The generic system configurations are the basic "system templates" that describe the parts that are included in all systems of a specific type or model. For example, the template for the model A system includes the part numbers for all parts included in all model A units.

- The serialized system configurations include the part numbers and serial numbers (when applicable) for the parts that are included in a specific serialized unit. For example, the serialized system configuration for a specific model A unit includes the part numbers for all parts that are included in the specific model A unit and the serial numbers for the serialized parts that are included in the unit.

The Template page allows you to view and manage system templates. Permissions required to access this page: Access Admin Tab and Manage Template Systems.

To open the Template page, choose System > System > Template.

All activities performed on this page pertain only to the current entity.

The system configuration for the selected system for the current entity is displayed on the left side of the interface. The part number, part description and version for each part in the configuration are displayed. Click the plus (+) or minus (-) to the left of a part number to hide or display the parts below this part in the hierarchy. To locate a specific part, click the Find part on system link at the top of the hierarchy to search by part number or part description. If a part in the system configuration has been replaced, it will appear at the bottom of the hierarchy and a retired date will appear next to it. Retired parts are indicated by 📷.

Creating a System Template

- To create a system template, choose System > Template > Create Template.

In the Create Template Part utility that appears, enter the part number and part name, along with any other desired information.
• To import a system configuration from Xfmea, choose System > Template > Xfmea Import.

This command appears only if the current database has associated Synthesis tables that you have permission to access and has at least one project with a system hierarchy. For details on importing from Xfmea, see Importing Systems from Xfmea.

Finding an Existing System Template
To work with an existing system template, choose System > Template > Find Template.

In the Find Template utility that appears, you can search by template part name or template part number.

Adding a Part to the System Template
Once you have selected a system template to work with, you can add new parts or existing part to it. To do this, select the parent part (i.e., the part under which you would like to add a part) and do one of the following:

• To create a new template part, choose System > Part > Create.

In the Create Template Part utility that appears, enter the part number and part name, along with any other desired information. When you save the part, XFRACAS will check for parts that match the specified properties. If you have selected the Use Existing Part if Found check box, then if a match is found, that part will be added to the system template. If this check box is not selected and a match is found, you will see a message informing you that the part already exists.

• To add an existing template part to the system template, choose System > Part > Associate.

In the Associate Template Parts utility that appears, you can use the Add (>), Remove (<), Add All (>>) and Remove All (<<) buttons to move parts between the Available Items List and the Selected Items List.

• To search for an item in the Available Items List, click the Find Available Items link to open the Find Part utility, which allows you to search by part name, number and/or version in one or more entities.
• If you select the **Associate Children** check box, all children of each newly selected part will also be added to the list of selected items. Note that this can add a large number of parts and that, depending on the size of the tree underneath each selected part, the save process may take several minutes. To see the children of an item in the Available Items List, select the item and click the **Show Item Hierarchy** link to display the item hierarchy at the bottom of the utility. For a more detailed view including child parts, you can click the **View Structure** link in the item hierarchy to open the full hierarchy in a new window.

### Editing a Part in the System Template

You can edit information for any part in the system template by selecting the part and choosing **System > Part > Edit.**

### Removing a Part from the System Template

There are two options when removing a part from a system template. You can either remove the part from the system template but leave the part in existence for possible future use (i.e., disassociate the part) or you can remove the part from the system and remove the part record entirely (i.e., delete the part).

- To disassociate a part from a template, select the part in the template and choose **System > Part > Disassociate.**

  This removes the part from the system and makes it a top level part.

- To delete a part, select the part in the template and choose **System > Part > Delete.**

  This removes the part from the system, unless there are already records pertaining to the part, in which case the part is retired instead.

### Specifying Failure Modes for Parts

You can specify potential failure modes and associated root causes for template parts. These failure modes and root causes may be available for selection in failure mode **detail fields** in the Failure Analysis, Incident and/or Problem pages.

- To add a failure mode for the currently selected part, click the **Add Failure Mode** icon, and type the failure mode name in the New Failure Mode utility that appears.
• To copy an existing failure mode from another part, click the Add Existing Failure Mode icon, 🌋. In the Existing Failure Mode utility that appears, you can use the Add (＞), Remove (＜), Add All (＞＞) and Remove All (＜＜) buttons to move parts between the Available Failure Modes list and the Selected Failure Modes list.

• To search for an item in the Parts list, click the Find Available Items link to open the Find Part utility, which allows you to search by part name, number and/or version in one or more entities.

• Once you have added a failure mode, you can add a root cause for the failure mode by selecting the failure mode, clicking the Add Root Cause icon, 🌋, and typing the root cause name in the New Root Cause utility that appears.

• To edit an existing failure mode or root cause, select it and click the Edit icon, 🌋. To delete an existing failure mode or root cause, select it and click the Delete icon, 🗑️.

Assigning Responsibility
When you are working with templates, you can specify owners who are responsible for parts and define the e-mail notification list for incidents related to those parts. These associations will determine who receives e-mail notifications from the system when an incident is created. If a part has an owner, the part will be available in the Responsible Part drop-down list on the Incident page. Therefore, if the Responsible Part field is a drop-down list, at least one owner must be specified for the system in order to create an incident report since the Responsible Part field is required for creating an incident report. Note that the Responsible Part field may also be a tree, depending on the settings chosen by the system administrator, and that parts without an owner are available from the tree.

You must have at least one owner assigned in the entity in order to be able to create incidents.

• To assign an owner for a part, select the part in the template and choose System > Part > Assign Owner.

In the Assign Template Part Owner utility that appears, select the owner from the list. If an owner has already been assigned, the new owner will replace the old owner.

• To remove the owner from a part, select the part in the template and choose System > Part > Remove Owner.

This will leave the part without an owner and will clear the e-mail notification list.
• To add more users to the e-mail notification list, select the part in the template and choose **System > Part > CC List**.

In the Assign E-mail Notification List utility that appears, select the name(s) to be included in the e-mail notification list for the selected part. The available system users will be based on those users that have access to the current entity. An e-mail notification list cannot be specified unless a responsible individual has been specified for the part.

Parts that have an owner are indicated in the template by 🐦.

**Note:** Instead of using system templates, which are also used to report incidents against, you can use a "generic" responsibility system. For example, you can create a generic system template called "Responsibility" with parts that include your different functional groups that should be assigned incidents, such as Engines, Transmissions, Suspension, etc. Next, assign one user as the owner for each of these groups. The responsibility system does not need to be used for creating serialized systems or for reporting incidents against.

**Managing Serialized Systems**

XFRACAS includes both generic and serialized system configuration information.

- The generic system configurations are the basic "system templates" that describe the parts that are included in all systems of a specific type or model. For example, the template for the model A system includes the part numbers for all parts included in all model A units.

- The serialized system configurations include the part numbers and serial numbers (when applicable) for the parts that are included in a specific serialized unit. For example, the serialized system configuration for a specific model A unit includes the part numbers for all parts that are included in the specific model A unit and the serial numbers for the serialized parts that are included in the unit.

The Serialized page allows you to view and manage serialized system configurations. Permissions required to access this page: Access Admin Tab and Manage Serialized Systems.

To open the Serialized page, choose **System > System > Serialized**.

All activities performed on this page pertain only to the current entity.

The system configuration for the selected system for the current entity is displayed on the left side of the interface. The part number, part description, version and serial number for each part...
in the configuration are displayed. Click the plus (+) or minus (-) to the left of a part number to hide or display the parts below this part in the hierarchy. To locate a specific part, click the Find part on system link at the top of the hierarchy to search by part number, part description or serial number. If a part in the system configuration has been replaced, it will appear at the bottom of the hierarchy and a retired date will appear next to it. Retired parts are indicated by

Creating a System Configuration
To create a serialized system, choose System > Serialized > Create System.

In the Create Serialized Part utility that appears, choose the kind of part you want to create from the Template Part drop-down list. Then enter the serial number and the build date, along with any other desired information. The following characters are not allowed in serial numbers:
@ # % & = { } " < >

Finding an Existing System Configuration
To work with an existing serialized system, choose System > Serialized > Find System.

In the Find System utility that appears, you can search by the system serial number, subsystem serial number, subcomponent part name or subcomponent part number.

Adding a Part to the System Configuration
Once you have selected a system configuration to work with, you can add new parts or existing part to it. To do this, select the parent part (i.e., the part under which you would like to add a part) and do one of the following:

- To create a new serialized part, choose System > Part > Create Serialized.

In the Create Serialized Part utility that appears, choose the kind of part you want to create from the Template Part drop-down list. Then enter the serial number and the build date, along with any other desired information.

- To add an existing serialized part to the serialized system, choose System > Part > Add Existing Serialized.
In the Add Existing Serialized Parts utility that appears, choose the item type from the Available Items drop-down list. You can enter part or all of the serial number, if known. Click the Find Available Items link to show all matching serialized parts.

- To add an existing non-serialized part to the serialized system, choose System > Part > Add Non-Serialized.

In the Add Non-Serialized Parts utility that appears, you can use the Add (>), Remove (<), Add All (>>) and Remove All (<<) buttons to move parts between the Available Items List and the Selected Items List.

- To search for an item in the Available Items List, click the Find Available Items link to open the Find Part utility, which allows you to search by part name, number and/or version in one or more entities.

- If you select the Associate Children check box, all children of each newly selected part will also be added to the list of selected items. Note that this can add a large number of parts and that, depending on the size of the tree underneath each selected part, the save process may take several minutes. To see the children of an item in the Available Items List, select the item and click the Show Item Hierarchy link to display the item hierarchy at the bottom of the utility. For a more detailed view including child parts, you can click the View Structure link in the item hierarchy to open the full hierarchy in a new window.

**Editing a Part in the System Configuration**

You can edit information for any part in the system configuration by selecting the part and choosing System > Part > Edit Serialized.

**Removing a Part from the System Configuration**

There are two options when removing a part from a system configuration. You can either remove the part from the system configuration but leave the part in existence for possible future use (i.e., disassociate the part) or you can remove the part from the system and remove the part record entirely (i.e., delete the part).

- To disassociate a part from a serialized system, select the part in the system configuration and choose System > Part > Disassociate.

This removes the part from the system and makes it a top level part.
Chapter 4: Managing Parts and Systems

- To delete a part, select the part in the system configuration and choose **System > Part > Delete Serialized**.

This removes the part from the system, unless there are already records pertaining to the part, in which case the part is retired instead.
Chapter 5: Managing Preferences

Managing Preferences

The Preferences page allows you to manage many of the configurable settings within XFRACAS. Permissions required to access this page: Access Admin Tab, and Manage System Wide Preferences or Manage Entity Preferences.

To open the page, choose Admin > Configure > Preferences.

Choose Admin > Preferences > Save to save any changes.

If your XFRACAS website has more than one Entity, some preferences apply to the entire website (System-Wide Preferences) and the rest will be managed separately for each entity. The drop-down list at the top of the page determines which entity-specific preferences are currently displayed.

In the website, preferences are grouped by type (e.g., true/false, date, string, etc.) and listed alphabetically. In the documentation below, related preferences are discussed together when applicable (i.e., not always in alphabetical order).

- System-Wide Preferences
- Boolean Preferences
- Date Preferences
- Display Option Preferences
- E-mail Preferences
- Integer Preferences
- String Preferences
- Time Zone Preferences
- URL Preferences
- Target and Completed Dates
Chapter 5: Managing Preferences

System-Wide Preferences

- Secure Socket Layer Protection
  
  - SSL Server Mode Required: If True, the website will use https (rather than http) when building links. Before you enable this option, make sure the IIS web server is configured properly for SSL/TLS (as discussed in the XFRACAS Implementation Guide).
  
  - SSO Authentication - XFRACAS uses Windows authentication by default. Alternatively, if your web server is set up to support SSO authentication, XFRACAS will check for the "Auth_User" variable by default. If your SSO method has been configured to use a different variable, set the following preferences:
    
    - Single Sign-On (SSO) Authentication Enabled: If True, indicates that your web server is set up for SSO authentication and uses a variable other than "Auth_User."
    
    - Single Sign-On (SSO) Server Variable: The alternative variable that XFRACAS needs to check for SSO authentication.

The admin/TESTSSO.aspx page on the website provides additional details to help with troubleshooting the configuration.

- Location of the XFRACAS Website
  
  - XFRACAS Server - Filesystem Prefix: The absolute path on the server where the website's IIS folder is installed (e.g., C:\inetpub\wwwroot\XFRACAS\).
  
  - XFRACAS Server - IIS Prefix: The path that can be used to build links to pages within the XFRACAS website (e.g., servername/XFRACAS or 10.0.0.2/xfracas).

- Link to the SEP Website (if Applicable)
  
  - Synthesis - Display Synthesis Enterprise Portal (SEP) Command: If True, the XFRACAS ribbon will include a link to your organization's SEP website.
  
  - Synthesis Enterprise Portal Server - IIS Prefix: The path that can be used to build the link to the SEP website (e.g., servername/SEP).

- Upload Files for Attachments
  
  - Attachments - Allow Uploaded Files: If True, the Attachments window will include the option for users to upload files. The files may be stored in the database or uploaded to a designated folder on the web server, depending on how you configure the related preferences.
• **Attachments - Store Uploaded Files in Database**: If True, files will be stored in the database. If False, files will be stored in a designated folder on the web server.

• **Attachments - Uploaded Files Filesystem Prefix**: If applicable, this is the absolute path to the folder on the web server where uploaded attachments will be stored (e.g., C:\inetpub\wwwroot\XFRACAS\uploads\ or D:\storage\xfracas). For requirements and instructions to prepare this folder, refer to the [XFRACAS Implementation Guide](#).

• **Attachments - Uploaded Files IIS Prefix**: If applicable, this is the path that will be used to build links to download files that were saved on the web server.
  - If you are using an actual file folder within the website, enter a relative path (e.g., uploads).
  - If you are using a virtual directory created in IIS, use an absolute path (e.g., http://servername/uploads).

• **SMTP Server for E-Mail Notifications**
  - **SMTP Server**: The address of the SMTP server that will be used for sending e-mails (e.g., mail.servername.com or 10.0.0.2).
  - **SMTP Port**: The port used to connect to the SMTP server. If left blank, the default SMTP port 25 will be used.
  - **SMTP Connection Timeout**: The amount of time, in seconds, before the connection to the SMTP server times out when sending e-mails.

• **Use Web-based Help**: If True, the help commands always open the most up-to-date help files from the Internet when possible. If False, they open the local help files that were installed with the software. This preference is available starting in Version 11.1.1.

• **DIU Service - Generate Import Log**: If True, an import log will be generated during an import. The log will be stored with the import record.

• **Terms of Use Agreement Page Required**: If True, users will be prompted to accept an agreement the first time they access XFRACAS each day. To customize the content of the agreement, edit the files directly on the web server:
  - Agreement.aspx is stored in the website's main folder and will be displayed if the user visits any of the regular pages.
  - AdminAgreement.aspx is stored in the website's Admin folder and will be displayed if the user visits any of the admin pages.
Chapter 5: Managing Preferences

- **Unknown Users - Allow Account Request**: If True, users not already in XFRACAS can request access to the system, and users not already in an entity can request access to the entity.

- **Report Filter Display Max Rows**: Indicates the maximum number of rows that a report can return and still have filtering and grouping capabilities.

- **DB Version** and **License Number**: The database version and license number of the XFRACAS system. These are available for technical support purposes and cannot be changed.

### Boolean Preferences

- **CSI - Display CSI Wizard**: If True, the Use CSI Wizard command will be available when users are creating new Customer Support records. The wizard prompts users to enter the data one step at a time, instead of all in a single form.

- These preferences show/hide some of the fields in the Customer Support page. For information about how these fields are used, see Customer Support. To configure other fields for this record type, use the **Details** page.
  
  - **CSI - Display Shipment Date**
  - **CSI - Display Delivery Date**
  - **CSI - Display Distributor**
  - **CSI - Display MTBF**
  - **CSI - Display MTBCF**
  - **CSI - Display MTBNCF**
  - **CSI - Display MTBI**
  - **CSI - Display Chargeable Incident Count**
  - **CSI - Display Non-Chargeable Incident Count**
  - **CSI - Enable Operational Availability**
  - **CSI - Display Calculated System Downtime**
  - **CSI - Display Unit Owner Address Information**
  - **CSI - Display Contact**
  - **CSI - Display Warranty Section**
  - **CSI - Display ASP Information** (ASP and ASP Field Service Tech)
• **CSI - Commission Date Required**: If True, the commission date is required in the Customer Support page. If False, the shipment date becomes a required field and will be populated based on the system build date if left blank by the user.

• **CSI - Create Incident Link Transfers Hours from CSI**: This applies when the user clicks the "Create Incident" link in the Customer Support page. If True, the time metric field(s) in the incident (e.g., System Hours) will be populated based on the latest info in the CSI. (See Time Metric Calculations.)

• **CSI - Display All Authorized Service Technicians**: This applies if the "CSI - Display ASP Information" preference is enabled. If True, all service technicians will be displayed in the drop-down list, regardless of the company they are associated with. If False, only service technicians associated with the selected company will be displayed.

• **CSI - Show All Unit Contact Names**: This applies if the "CSI - Display Contact" preference is enabled. If True, the Contact field will show all contacts available in the system. If False, the list will be filtered by unit owner.

• **CSI - Extended Warranty Purchase Anytime**: This applies if the "CSI - Display Warranty Section" preference is enabled. If False, the purchase date for the extended warranty must be within the date range of the initial warranty. (See Warranty Information Area).

• **Incident - Display Incident Wizard**: If True, the Use Incident Wizard command will be available for new Incident records. The wizard prompts users to enter the data one step at a time, instead of all in a single form.

• These preferences show/hide some of the fields in the Incidents page. For information about how these fields are used, see Incidents. To configure other fields for this record type, use the Details page.

  • **Incident - Display Unit Location**
  • **Incident - Display Calculated Downtime**
  • **Incident - Display Title** (and **Incident - Require Title**)
  • **Incident - Display Team Members**
  • **Incident - Display Potential Criticality** and **Incident - Display Actual Criticality** (see Managing Criticality Fields)
  • **Incident - Display Service Response Time/Date** and **Incident - Display Calculated Response Time**
  • **Incident - Display ASP Field Service Tech** (and **Incident - Require ASP Field Service Tech**)
  • **Incident - Display Repair Duration**
• Incident - Display Repair/Replace Parts

• Incident - Assign Creator as Owner: If True, the user who creates the incident will be assigned as the owner of the incident. If False, the incident owner depends upon the responsible part or the choice in the Owner field.

• Incident - Auto-populate Time Metric 1: If True, the primary time/usage metric field (e.g., hours, miles, kilometers, cycles, etc.) will be populated automatically in a serialized incident when the required inputs are available. (See Time Metric Calculations.)

• These preferences specify whether to track additional time or usage metrics (e.g., hours, miles, kilometers, cycles, etc.) in the Customer Support page and Incident page for serialized incidents and part incidents. By default, these metrics are labeled "System Hours," "Number of Starts" and "kW Run Hours" but you can use the Resource Editor to customize the labels to fit your specific needs.

• Incident - Display Time Metric 2

• Incident - Display Time Metric 3

• These preferences specify whether to automatically calculate the value of one time/usage metric based on the value entered for another. The behavior also depends on the "Display Time Metric" and "Time Metric Formula" preferences. (See Time Metric Calculations.)

• Incident - Always Auto-calculate Time Metric 1

• Incident - Always Auto-calculate Time Metric 2

• Incident - Always Auto-calculate Time Metric 3

• Incident - Use Tree to Select Responsible Part: If True, the "Responsible Part" field in the Incident page will allow users to select one or multiple parts from a tree view of all system templates. If False, users can select only one part from a drop-down list. When the tree is used, you can also specify:

• Incident - Auto-select Responsible Part for New Incidents: If True, the part number specified in the System/Component Information area will be selected by default in the Responsible Part tree.

• Incident - Enable Responsible Part Filter: If True, the Responsible Part tree will only allow users to select parts from the system specified in the System/Component Information area.

• Incident - Defaults: These preferences apply when the entity has only one system template defined. If True, then XFRACAS will automatically set relevant part fields when creating a new incident.
Chapter 5: Managing Preferences

- **Incident - Default Part Number**
- **Incident - Default Responsible Part**

These preferences specify whether XFRACAS will automatically set date fields in the incident based on today's date.

- **Incident - Default Repair Date**
- **Incident - Default Response Date**

- **Incident - Require Date Field Validation**: If True, the date in any date field on the Incident page cannot be less than the incident's creation date.

- **Incident/Problem - Display Audience Restriction** and **Incident/Problem - Require Legal Team Member**: If both of these preferences are True, the Audience Restriction field will be displayed in the Incident page and Problem page after the record is created, and if the "Attorney/Client Privilege" option is selected for a particular incident or problem, then:
  
  - Only users assigned to the team for that record will be able to view it in any form. Make sure the "Incident - Display Team Members" and "Project - Display Team Members" preferences are also enabled so users will be able to assign an appropriate team before restricting access to the record.
  
  - The team assigned to the record must have at least one user assigned to the "Legal" team role. Only users who have the "Legal Expert" category in the Users page can be assigned to this role.

- **Incident - Display Customer Requested Feedback**: If True, the "Customer Requested Feedback" check box is displayed in the Incident page and the "Report Sent to Customer" check box is displayed on the Failure Analysis page.

- **Incident - Closure**: These preferences specify the conditions that must be met to close an incident. Select all that apply.
  
  - **Incident - Closure Restriction Level 1**: All actions for the incident are completed.
  
  - **Incident - Closure Restriction Level 2**: All failure analysis reports belonging to the incident are closed.

  When an incident is closed, it no longer appears in the XFRACAS Portal under "Unclosed Incidents." Only users with the "Incident - Open a Closed Incident" or "Incident - Edit All Incidents" permissions can reopen a closed incident.

- **Incident - Disable Edit of Closed Incidents**: If True, closed incidents will be read-only and can only be edited by users with either the "Incident - Open a Closed Incident" or "Incident - Edit All Incidents" permissions.
Chapter 5: Managing Preferences

- **Allow Cross Entity Association**: These preferences apply when assigning an incident to a problem or assigning a problem to a project. They also apply when creating an attachment to an XFRACAS record. If True, records from all entities that the user has access to will be available. If False, only records from the current entity will be available.
  - Incident/Problem - Allow Cross Entity Association
  - Project/Problem - Allow Cross Entity Association

- **Incident - Create Problem Link**: These preferences apply when the user clicks the "Create Problem" link in the Incident page.
  - Incident - Create Problem Link Transfers Incident Description
  - Incident - Create Problem Link Transfers Incident Title
  - Incident - Create Problem Link Transfers Responsible Part (transfers to the problem's Part Category Code field)

- These preferences show/hide some of the fields in the Problem page. For information about how these fields are used, see Problems. To configure other fields for this record type, use the Details page.
  - Problem - Display Team Members
  - Problem - Display Requested Closure Date
  - Problem - Display Expected Closure Date
  - Problem - Display Criticality (see Managing Criticality Fields)
  - Problem - Display Associated Incidents
  - Problem - Display Associated Projects

- These preferences show/hide some of the fields in the Associated Incident Reports section on the Problem page.
  - Problem - Display Incidents by Status (open or closed).
  - Problem - Display Incidents by Chargeability (chargeable or non-chargeable)

- **Problem - Show Steps**: These preferences specify which of the optional steps will be displayed on the Problem page in addition to the four steps that are always displayed: Establish the Team, Describe the Problem, Choose and Verify Permanent Corrective Actions and Prevent Recurrence.
  - Problem - Show Step - Implement and Verify Containment Actions
  - Problem - Show Step - Identify and Verify Root Cause
• Problem - Show Step - Implement Permanent Corrective Actions

• Problem - Show Step - Congratulate the Team

• **Problem - Always Show All Problem Steps**: If True, after a user has entered the first step and created a new problem, the page will show all of the subsequent steps that need to be performed. If False, each subsequent step will be displayed only after the previous step is completed and saved.

• **Problem - Completed Date Warning**: If True, entering a problem completed date that is in the future will show a warning.

• **Problem - Enable Created Date Restriction**: If True, the problem's creation date must be earlier than the completion/sign-off date for any step in the problem.

• **Problem - FRB Sign-Off CC Restriction**: If True, the priority order of FRB reviewers will be enforced. Once the first reviewer signs off on the problem step, the second reviewer can then review the step. Reviewers cannot sign off out of order.

• **Problem - FRB Sign-Off Restriction**: This applies only if the "Problem – FRB Sign-Off Restriction" preference is True. If True, the review request e-mail will be sent only to the next FRB reviewer based on priority order. If False, the e-mail will be sent to all reviewers on the FRB reviewers list for the current step.

• **Problem - Closure**: These preferences specify the conditions that must be met before a problem step or problem can be closed. Select all that apply.
  
  • **Problem - Closure Restriction Level 1**: All actions for the problem must be completed.

  • **Problem - Closure Restriction Level 2**: All incidents associated with the problem must be closed.

  • **Problem - Closure Restriction Level 3**: All actions associated with a problem step must be completed before you can close the step.

  When a problem is closed, it no longer appears in the XFRACAS Portal under "Open Problems." Only users with the "Problem - Open a Closed Problem" or "Problem - Edit All Problems" permissions can reopen a closed problem.

• These preferences show/hide some of the fields in the Project page. For information about how these fields are used, see Projects. To configure other fields for this record type, use the [Details page](#).

  • **Project - Display Team Members**

  • **Project - Display Target Completion Date**
Chapter 5: Managing Preferences

- Project - Display Revised Completion Date
- Project - Display Actual Completion Date
- Project - Display Scope of Project
- Project - Display End Result
- Project - Show Associated Problems
- Project - Show Associated Incident Reports
- Project - Display Associated Incidents
- Project - Show Associated FA Reports

- **Project - Closure**: These preferences specify the conditions that must be met before a project can be closed. Select all that apply.
  - Project - Closure Restriction Level 1: The actual completion date must be set and all actions for the project must be completed.
  - Project - Closure Restriction Level 2: The actual completion date must be set and all problems associated with the project must be closed.

When a project is closed, it no longer appears in the XFRACAS Portal under "My Projects." Only users with the "Project - Open a Closed Project" or "Project - Edit All Projects" permissions can reopen a closed project.

- **E-mail - New Incident or Owner Reassigned**: These preferences specify whether e-mails will be sent to the incident owner when a new incident is created, or when an existing incident is assigned to a new owner.
  - E-mail - Incident Creation
  - E-mail - Incident Owner Reassigned

- **E-mail - New Problem or Owner Reassigned**: These preferences specify whether e-mails will be sent to the problem owner when a new problem is created and the problem owner is not the same as the problem creator, or when a problem is assigned to a new owner.
  - E-mail - Problem Creation
  - E-mail - Problem Owner Reassigned

- **E-mail Status Update**: These preferences specify whether the Status utilities in each record type will include the E-mail Notify option.
  - E-mail - Action Status Update
• E-Mail - Incident Status Update
• E-Mail - FA Status Update
• E-Mail - Problem Status Update
• E-Mail - Project Status Update

• If e-mail notifications are enabled for new/modified statuses, these check boxes specify which check boxes will be selected by default.
  • E-mail - Action Status Update Associated Owner Checked
  • E-mail - Action Status Update Creator Checked
  • E-mail - Action Status Update Team Checked
  • E-mail - Incident Status Update Creator Checked
  • E-mail - Incident Status Update Owner Checked
  • E-mail - Incident Status Update Team Checked
  • E-mail - FA Status Update Associated Owner Checked
  • E-mail - FA Status Update Creator Checked
  • E-mail - FA Status Update Team Checked
  • E-mail - Problem Status Update Creator Checked
  • E-mail - Problem Status Update Owner Checked
  • E-mail - Problem Status Update Team Checked
  • E-mail - Project Status Update Owner Checked
  • E-mail - Project Status Update Team Checked

• E-mail - Action Creation: These preferences specify whether e-mails will be sent to the action owner when an action is created or when an existing action is assigned to a new owner.
  • E-Mail - CSI Action Creation
  • E-Mail - Incident Action Creation
  • E-Mail - FA Action Creation
  • E-Mail - Problem Action Creation
• **E-Mail - Project Action Creation**

• **E-mail - Action Associated Owner on Creation**: If True, e-mails will be sent to the owner of the parent record when an action is created. For example, creating an action associated with an incident will cause an e-mail to be sent to the incident owner.

• **E-mail - Action Owner on Update**: If True, e-mails will be sent to the action owner when the owner, descriptions, date or statuses for an action are changed.

• **E-mail - Action Due Date**: These preferences specify whether e-mails will be sent to the action owner when the due date is approaching or the action is past due. (See **E-mails Based on Calendar Date**.)
  - **E-mail - CSI Action Due Date**
  - **E-mail - Incident Action Due Date**
  - **E-mail - FA Action Due Date**
  - **E-mail - Problem Action Due Date**
  - **E-mail - Project Action Due Date**

• These preferences specify whether the incident or problem owner will receive a copy of action e-mails based on due date.
  - **E-mail - CC Incident Owner Action Due Date**
  - **E-mail - CC Problem Owner Action Due Date**

• **E-mail - Send Action Due Notify Once**: If True, e-mails will be sent only once when actions approach their due dates. If False, e-mails may also be sent at regular intervals when an action is past due. (See **E-mails Based on Calendar Date**.)

• **E-mail - Group Action Due Date**: If True, only one e-mail will be sent for all of a user's actions approaching their due dates. If False, an individual e-mail will be sent for each action.

• **E-mail - Action Closed**: These preferences specify whether e-mails will be sent to the owner of the parent record when an action associated with that record has been closed.
  - **E-Mail - CSI Action Closed**
  - **E-Mail - Incident Action Closed**
  - **E-Mail - FA Action Closed**
  - **E-Mail - Problem Action Closed**
  - **E-Mail - Project Action Closed**
• **E-mail - Failure Review Board**: These preferences specify when e-mails will be sent to members of the Failure Review Board (FRB) in a problem.

  • **E-mail - Reviewer Added to FRB**: E-mails will be sent to reviewers when they assigned to an FRB.
  
  • **E-mail - Send Problem Signed Off**: E-mails will be sent to the problem owner and the reviewer when an FRB reviewer signs off on a step.
  
  • **E-mail - Problem Signed Off by FRB (All)**: E-mails will be sent to the rest of the FRB when a reviewer signs off on a step.

  • **E-mail - Problem FRB Not Signed Off**: E-mails will be sent to the FRB reviewers when the requested closure date is approaching or past due. (See [E-mails Based on Calendar Date](#).)

  • **E-mail - Problem FRB Rejected**: E-mails will be sent to the problem owner and the FRB members when a FRB reviewer has rejected closure of a problem.

• **E-mail - Group Problem FRB Not Signed Off**: If True, only one e-mail will be sent for all of the problems for which a user is an FRB reviewer as a reminder that they need to sign off on a problem. If False, an individual e-mail will be sent for each problem.

• **E-mail - BCC Administrator on XFRACAS Data Sent**: If True, the system administrator will receive a copy of every e-mail sent that includes data from a CSI, incident, failure analysis, problem or project record (i.e., every e-mail where the printer-friendly view is included). This is a way of tracing that data from a security standpoint (such as an organization that has ITAR-related data).

• **E-mail - FA SAP Work Order Request**: If True, e-mails will be sent when a failure analysis report requests an SAP work order (or a similar record from another enterprise resource planning system).

• **E-mail - Incident Customer Requested Feedback**: If True, e-mails will be sent when a customer requests feedback on a failure analysis. The recipient is defined in the "[E-mail - Customer Requested Feedback Notify To](#)" E-mail preference.

• **E-mail - RMA Received to Problem Owner**: If True, e-mails will be sent to the problem owner when a Return Materials Authorization (RMA) has been received. This only applies if the incident report that contains the RMA is associated to a problem.

• **Reports - Allow Send via E-mail**: If True, the E-mail button will be available in the Reports page.

• **Reports - BCC Administrator on Data Sent via E-mail**: If True, the system administrator will receive a copy when report results are sent via e-mail.
• **Reports - Display Qualifiers**: If True, the "Results based on the following qualifiers" area will be displayed in report results.

• **Reports - Include End Date Matches**: If True, the end date set in a report is included in the results. For example, with a setting of True, a report of dates between Jan. 1, 2017 and Jan. 2, 2017 would include results for date matches from the entire days of Jan. 1, 2017 and Jan. 2, 2017. With a setting of False, the report would only include results from the entire day of Jan. 1, 2017. This applies if the "XFRACAS - Display Time with Date Fields" preference is set to False.

• **Action - Allow Setting Due Date Before Current Date**: If True, users can enter an action date that is earlier than the creation date. This allows you to enter historical information that did not get entered when the action was actually performed.

• These settings apply when using the Synthesis Data Warehouse in Weibull++ to extract data sets for life data analysis.
  
  • **Analysis - Fixed Daily Operating Hours**: If True, systems are considered to run constantly (i.e., 24x7). System operating time (system up hours) will be calculated based on numerous factors, including commission or shipment date, incident occurrence date, the "Incident - Max Units/Day" Integer preference and the system down time. If False, the times are those reported in either the incidents or in the CSI.

  • **Analysis - Weibull++ Export Rollup**: If True, failures of child parts will be considered to also precipitate failures of parent parts. If the System Down Event incident detail is available in the current entity, then for incidents that are marked as system down events, the failure will affect all levels above the child part all the way to the top level item. For incidents that are not marked as system down events, the failure will affect all but the top level item. If False, failures of child parts will not roll up to parent parts. It is important to note that if this preference is True, the times that are exported are the times between failures, not the failure times. If you are unsure if this analysis method is appropriate for you, please contact ReliaSoft for further information.

  • **Lists - Autosize List Height**: If True, the area used to display lists in the Lists page varies in height depending on the number of items in the list. If False, a scroll bar will be used to scroll through the list. Note that there is a maximum height of 300 pixels for any list, even when this preference is set to True.

  • **Manage User - E-mail/Login Auto Build**: If True, the user login and e-mail address fields will automatically be assigned in the Users page based on the user’s first and last names and the "Manage User - E-mail Suffix used for Auto Build" E-mail preference.
Chapter 5: Managing Preferences

- These preferences apply to the "data tree" on the Template page and the Serialized page. They also apply to the responsible part when it is used as a tree and with the Part Category Code popup window.
  
  - **System - Data Tree Auto Collapse**
  
  - **System - Data Tree Sort by Part Description** (rather than part number)

- **XFRACAS - Autopopulate Associated Record Dialog**: This applies to all Assign/Find windows (e.g., when assigning an incident to a problem). If True, all records will be displayed when the window opens. If False, only currently assigned records will be displayed upon open and users can click **Filter** to see all records.

- **XFRACAS - Display Debug IDs**: If True, the resource IDs will be shown in square brackets beside the name for all fields. You can use this in conjunction with the Resource Editor to customize text labels displayed in the website. In addition, the Detail Type IDs will be shown in square brackets on the Details page.

- **XFRACAS - Display Employee ID With User Name**: If True, the employee ID will be displayed along with the user name in locations where a user is being selected (e.g., the Assign Team Members utility, drop-down lists, etc.).

- **XFRACAS - Display Last Updated Timestamp**: If True, information on the last update of the record will be displayed in the summary area for incidents, problems, projects, failure analysis reports, CSIs and actions.

- These preferences apply to all date/time input fields. Note that there are separate preferences for dates and times displayed as regular text (the "XFRACAS - Date Format - Long" and "XFRACAS - Date Format - Short" String preferences).
  
  - **XFRACAS - Display Day Before Month in Date Input Fields**: If True, Date input fields will display using the day before month format (e.g., "21 March 2017").
  
  - **XFRACAS - Display Time with Date Fields**: If True, the Time input fields will be displayed with applicable Date fields.
  
  - **XFRACAS - Display Time in 24 Hour Format**: If True, the Time field will display using a 24-hour clock. If False, it will display an A.M./P.M. indicator.

- **XFRACAS - Enable Header in Printed Records**: If True, the print logo and full entity name will appear in the document header when records are printed using the Print Preview command on the Home Tab. To change the logo, you can replace the logopfv.gif file stored in the Images folder on the web server (e.g., C:\inetpub\wwwroot\XFRACAS\Images\logopfv.gif).
**Chapter 5: Managing Preferences**

- **XFRACAS - Sort Statuses by Descending Date:** If True, the notes in the Status fields will be displayed in descending order based on creation date (i.e., the oldest note is listed first).

- **XFRACAS - Testing Mode:** If True, a "watermark" that reads "TESTING" will be placed in the background of the pages to indicate that the "testing" version of the system is distinguished from the actual "live" system.

**Date Preferences**

- **Fiscal Year Begins:** The start date of the fiscal year, which is used to determine the current quarter when reporting information based on a specified date range. The value entered must be a valid date but the current year will always be assumed when calculating the date range. For example, if the fiscal year begins on January 1st, you can enter that date with any year (01/01/2005, 01/01/2020, 01/01/2015). XFRACAS will only consider the month and day.

- **Portal - What's New Modify Date:** The date of the most recent modification to the What's New page maintained by your company (i.e., the Whatsnew.html page in the main folder on the web server where XFRACAS was installed). This page is displayed if the user has not visited the website since the page was last modified.

**Display Option Preferences**

- **Incident Types:** These preferences specify whether the specific type(s) of incident can be created. There are three options: "Not Displayed," "Displayed" and "Displayed (Default)."
  
  - Incident - Display Part Incident Type
  - Incident - Display Serialized Incident Type
  - Incident - Display Simple Incident Type

- **Problem - Display FRB:** These preferences specify whether the Failure Review Board (FRB) will be displayed for each step in the Problem page. If displayed and required, the FRB must be set up and the members must sign off before the step is considered complete. If they are set to just display, then they are not required to have sign off to move to the next step unless you assign someone to the FRB.
  
  - Problem - Display FRB - Describe the Problem
  - Problem - Display FRB - Implement and Verify Containment Actions
  - Problem - Display FRB - Identify and Verify Root Cause
  - Problem - Display FRB - Choose and Verify Permanent Corrective Actions
Chapter 5: Managing Preferences

- Problem - Display FRB - Implement Permanent Corrective Actions
- Problem - Display FRB - Prevent Recurrence
- Problem - Display FRB - Congratulate the Team

- XFRACAS - Language: The default language for the interface text. If the Language option in the user's account is blank, the interface will display in the default language. However, if the user's account specifies a language, the interface will display in the user’s preferred language instead.

- XFRACAS - Skin: Sets the appearance of the ribbon and some other elements within the XFRACAS interface.

E-mail Preferences

- Administrator E-mail: The system administrator’s e-mail address, used for requests for new user accounts and the place where the "E-mail - BCC Administrator on XFRACAS Data Sent" Boolean preference e-mails are sent to.

- E-mail - Customer Requested Feedback Notify To: The e-mail address where the customer requests for feedback notification will be sent if the "E-mail – Incident Customer Requested Feedback" Boolean preference is True.

- E-mail - Default New Incident From: If specified, then the e-mail address on new incidents will come FROM this address. If the TO address is not valid, then the e-mails will get bounced back to this address instead of the specific user who created the incident.

- E-mail - SAP Work Order Request To: The e-mail address where the SAP work order request notification will be sent if the "E-mail – FA SAP Work Order Request" Boolean preference is True.

- E-mail - Single From Address: If an e-mail address is specified, then all e-mails sent from the entity will be "from" the specified address. If it is blank, the e-mails will be "from" the specific user who initiated the e-mail. This preference is available starting in Version 11.1.1.

- Manage User - E-mail Suffix Used for Auto Build: The suffix (e.g., @company.com) to be used for the e-mail addresses automatically generated for new users if the "Manage User - E-mail/Login Auto Build" Boolean preference is True.

Integer Preferences

- CSI - Hours Decimal Places: The number of decimal places displayed in time figures in the Customer Support page.
Chapter 5: Managing Preferences

- **CSI - Operational Availability Decimal Places**: The number of decimal places that the Operational Availability percentage in the Customer Support page will be rounded to.

- **CSI - Warranty Months**: These preferences set the number of months in the warranty period in the Customer Support page, if company-specific values have not been specified on the [Companies page](http://xfracas.reliasoft.com).
  - **CSI - Warranty Months from Commission**
  - **CSI - Warranty Months from Shipment**

- **CSI - X Warranty Days for Repaired/Replaced Parts**: The number of parts that were repaired or replaced in the last X days. This information will display below the associated incidents on the Customer Support page.

- **Max Units/Day**: These preferences set the maximum amount of time/usage (e.g., hours, miles, kilometers, cycles, etc.) that a serialized system may accumulate in a single day. The max value for Time Metric 1 is used in the Customer Support page to make sure the "Estimated System Hours" calculation does not exceed the maximum possible per day. It is also used if you have selected to auto-populate Time Metric 1 in the Incident page for serialized systems. (See [Time Metric Calculations](http://xfracas.reliasoft.com).)

  Note that the max values for Time Metric 2 and 3 are relevant only if you are using a custom report that requires these inputs, or a custom method for extracting reliability data for analysis in Weibull++ or RGA.

  - **Incident - Max Units/Day - Time Metric 1**
  - **Incident - Max Units/Day - Time Metric 2** (only for custom functionality)
  - **Incident - Max Units/Day - Time Metric 3** (only for custom functionality)

- **Default Due Dates and Closure Dates**: These preferences specify the number of days from today's date to set as the default due date for a new action or the default closure dates for new problems.
  - **Action - Default Due Date Offset by X Days**
  - **Problem - Expected Closure Date Offset**
  - **Problem - Requested Closure Date Offset**

- **E-mail - X Days Offset**: These preferences specify the number of business days for e-mails based on calendar date.
  - **E-mail - Action Due in X Days Offset**: The number of days prior to the action due date that the e-mail reminder will be sent.
• **E-mail - Remind Action Due Every X Days**: The number of days after the first or previous reminder of an action due date that another reminder is sent.

• **E-mail - FRB After Requested Closure in X Days Offset**: The number of business days after closure has been entered on a problem that the FRB reviewers are sent an e-mail if they have not yet signed off on it.

• **E-mail - Remind FRB After Requested Closure Every X Days**: The number of days after the first or previous notification has been sent that a reminder e-mail will be sent to the problem reviewers. This applies only to the reviewers for the final step.

• **Portal - Highlight Offset**: These preferences set the number of days that records will be highlighted in the XFRACAS Portal.
  - **Portal - Action Due Date Highlight Offset** (days prior to the action due date)
  - **Portal - Incident Due Date Highlight Offset** (days after the incident occurrence date)
  - **Portal - Problem Due Date Highlight Offset** (days prior to the problem requested closure date - if the requested closure date is turned off, then the due date is calculated)
  - **Portal - Problem to Review Due Date Highlight Offset** (days prior to the problem review due date)
  - **Portal - Project Due Date Highlight Offset** (days prior to the project due date)

• **XFRACAS - Description Number of Lines Displayed**: The maximum number of lines the description fields will display.

• **Reports - Filter Display Max Columns**: The maximum number of optional columns that a report created in the Report Builder can include.

• **XFRACAS - System Search Timeout**: The maximum amount of time, in seconds, that the application can spend searching for a part in a system.

• **Diagnostics - Number of Exception Items Displayed**: The maximum number of items the Diagnostics page can display on a single page.

• **Active Directory - Maximum Groups to Display**: The maximum number of groups that will be displayed when loading Active Directory groups.

**String Preferences**

• **About Page**: These preferences specify information that displays on the XFRACAS About page.
Chapter 5: Managing Preferences

- Administrator Name
- Administrator Phone
- Company Name

- **Company Homepage Link:** This the name of your company’s home page. Use the "XFRACAS - Company Homepage" URL preference to specify the link to the website.

- **E-mail Message Formats - Incidents, Failure Analyses and Problems:** These preferences specify the formats of e-mails sent for incidents, failure analyses and problems. (See Configuring E-mail Message Formats.)
  - Incident - E-mail Message Format - New
  - Incident - E-mail Message Format - Customer Feedback
  - Incident - E-mail Message Format - RMA Received
  - Failure Analysis - E-mail Message Format - Work Order
  - Problem - E-mail Message Format - New
  - Problem - E-mail Message Format - Closure Requested
  - Problem - E-mail Message Format - Reject
  - Problem - E-mail Message Format - Signed Off

- **E-mail Message Formats - Actions:** These preferences specify the formats of the e-mails for new, updated and completed actions associated with each record type. (See Configuring E-mail Message Formats.)
  - Action - E-mail Message Format - New - CSI
  - Action - E-mail Message Format - Updated - CSI
  - Action - E-mail Message Format - Complete - CSI
  - Action - E-mail Message Format - New - Incident
  - Action - E-mail Message Format - Updated - Incident
  - Action - E-mail Message Format - Complete - Incident
  - Action - E-mail Message Format - New - FA
  - Action - E-mail Message Format - Updated - FA
  - Action - E-mail Message Format - Complete - FA
Chapter 5: Managing Preferences

- Action - E-mail Message Format - New - Problem
- Action - E-mail Message Format - Updated - Problem
- Action - E-mail Message Format - Complete - Problem
- Action - E-mail Message Format - New - Project
- Action - E-mail Message Format - Updated - Project
- Action - E-mail Message Format - Complete - Project

- **Status Updates - E-mail Message Format**: These preferences specify the format of the e-mails sent from the Status utility when a user adds a new status for the specified record type. (See Configuring E-mail Message Formats.)
  - Detail Status - E-Mail Message Format - Action
  - Detail Status - E-Mail Message Format - Incident
  - Detail Status - E-Mail Message Format - FA
  - Detail Status - E-Mail Message Format - Problem
  - Detail Status - E-Mail Message Format - Project

- **Detail Drop-down - E-mail Message Format**: For fields that use drop-down lists, each issue in the list may have an e-mail address associated with it (see Managing Lists). These preferences specify the format of the e-mail sent when one of the monitored issues is selected for a particular record. (See Configuring E-mail Message Formats.)
  - Detail Drop-down - E-Mail Message Format - CSI
  - Detail Drop-down - E-Mail Message Format - Incident
  - Detail Drop-down - E-Mail Message Format - FA
  - Detail Drop-down - E-Mail Message Format - Problem
  - Detail Drop-down - E-Mail Message Format - Project

- **Criticality Formulas**: These preferences define the formula used to calculate the criticality metrics for an incident or problem. (See Configuring Criticality Metrics.)
  - Criticality - Incident Actual
  - Criticality - Incident Potential
  - Criticality - Problem Base CIN
  - Criticality - Problem Current CIN
Chapter 5: Managing Preferences

- **Time Metric Formulas**: These preferences specify the formula used to calculate the value of one time/usage metric based on the value entered for another. The behavior also depends on the "Display Time Metric" and "Always Auto-calculate Time Metric" preferences, and what the user enters in the incident page. (See Time Metric Calculations.)
  
  - Incident - Time Metric 1 Formula
  - Incident - Time Metric 2 Formula
  - Incident - Time Metric 3 Formula

- **Problem - Default Owner**: The user who will be assigned by default as the owner for new problems.

- **Date Formats**: These preferences specify the formats for dates. Note that this should match the IIS culture setting on the web server in order for dates in charts to be displayed correctly.
  
  - **XFRACAS - Date Format - Short**: Displays only the date and not the time. The default format is MM/dd/yyyy (e.g., 03/01/2017).
  - **XFRACAS - Date Format - Long**: Displays the time along with the date when applicable. The default format is MM/dd/yyyy hh:mm tt (e.g., 03/01/2017 01:00 PM).

  - If the "XFRACAS - Display Time in 24 Hour Format" Boolean preference is True, remove the "tt" segment from the long date format (e.g., MM/dd/yyyy hh:mm will display 03/01/2017 13:00).

  - If you want to display only the date (without the time), set to the same format as the short date field (e.g., MM/dd/yyyy) or set the "XFRACAS - Display Time with Date Fields" Boolean preference to False.

- **XFRACAS Decimal Separator**: The text (usually a period or comma) used to indicate the decimal place in both input and output.

- **XFRACAS Thousands Separator**: The separator (usually a comma, period or space) used to separate groups of thousands in both input and output.

- **XFRACAS - Web Page Title Suffix**: The text that will be displayed at the end of the title in the browser caption bar (e.g., "Proprietary and Confidential Information").

- **Exchange ADS Path**: The Active Directory Services Path used for an LDAP connection to the GAL (Global Address List). (See Entering an ADS Path.)
Chapter 5: Managing Preferences

Time Zone Preferences

- **Default GMT Offset for New Users**: The time zone, or offset from Coordinated Universal Time (formerly known as Greenwich Mean Time), that will be used when a new user is created if a different time zone is not specified for that user.

URL Preferences

- **Tips URLs**: For many fields in XFRACAS, a help icon next to the input box opens a separate HTML page designed to provide data entry tips for that particular field. You can customize the information in these pages to meet the particular needs of your organization. By default, they are installed in the "Tips" folder on the web server (e.g., C:\inetpub\wwwroot\XFRACAS\Tips), but you can change the URLs if desired.

These preferences specify the URLs for some of the fields that have tips. For other fields that are configured from the Details page (such as the Incident Description or the Problem Description), you can specify the "Tips URL" when you edit the settings for the special detail field.

- Action - Description Tips
- Action - Result Tips
- Action - Status Tips
- CSI - Installation Detail Tips
- FA - Detailed Analysis Tips
- FA - Fault Description/Troubleshooting/Rework Tips
- FA - Initial Repairs/Comments Tips
- FA - SAP Items
- FA - Visual Inspection Tips
- Incident - Actual Criticality Tips
- Incident - Potential Criticality Tips
- Problem - Criticality Tips
- Problem - FRB Rejection Description Tips
- Project - End Result Tips
- Project - Scope of Project Tips
Chapter 5: Managing Preferences

- **XSLT Style Sheet URLs**: These preferences specify the URLs for the *.xslt style sheets for pages that have a Print Preview command in the ribbon. By default, these are installed in the "XSLT" folder on the web server (e.g., C:\inetpub\wwwroot\XFRACAS\XSLT), but you can change the URLs if desired.
  - CSI - Print Preview Style Sheet
  - FA - Print Preview Style Sheet
  - Incident - Print Preview Style Sheet
  - Problem - Print Preview Style Sheet
  - Project - Print Preview Style Sheet

- **XFRACAS - Company Homepage**: The URL of your company's home page link that displays on the XFRACAS About page.

**Target and Completed Dates**
These preferences specify whether target and/or completed date fields will display in specific areas of the Incident page and Problem page.

  - Incident - Description - Show Target Date
  - Incident - Description - Show Completed Date
  - Incident - Resolution - Show Target Date
  - Incident - Resolution - Show Completed Date
  - Incident - Initial Failure Analysis - Show Target Date
  - Incident - Initial Failure Analysis - Show Completed Date
  - Incident - Additional Comments - Show Target Date
  - Incident - Additional Comments - Show Completed Date
  - Problem - Problem Description - Show Target Date
  - Problem - Containment Description - Show Target Date
  - Problem - Root Cause Verification - Show Target Date
  - Problem - Corrective Action Description - Show Target Date
  - Problem - Implement Corrective Action Description - Show Target Date
  - Problem - Prevent Recurrence Description - Show Target Date
Chapter 5: Managing Preferences

Static Pages

For some features, you can customize the interface to meet your particular needs by editing files stored directly on the web server.

- **What's New page** (Whatsnew.html) is installed in the website's main folder. The "Portal - What's New Modify Date" preference defines the date of the most recent modification to the page.

- **General Error page** (GeneralError.aspx) is installed in the website's main folder.

- **Terms of Use agreement pages** (Agreement.aspx and AdminAgreement.aspx) are installed in the website's main folder (displayed when the user visits any of the regular user pages) and in the Admin folder (displayed when the user visits any of the admin pages). To enable this feature, set the "Terms of Use Agreement Page Required" preference to True.

- **Description Criteria Link pages** are installed in the website's "Tips" folder (e.g., C:\inetpub\wwwroot\XFRACAS\Tips). If you want to use a file stored in a different location instead, edit the relevant link on the Preferences page under URL Preferences (e.g., "Incident - Actual Criticality Tips," etc.).

- **Print Preview XSLT files** are installed in the website's "XSLT" folder (e.g., C:\inetpub\wwwroot\XFRACAS\Tips). These configure the "Print Preview" output for an incident, failure analysis, problem, project or CSI. If you want to use a file stored in a different location instead, edit the relevant link on the Preferences page under URL Preferences (e.g., Incident - Print Preview Style Sheet," etc.).

**Tip:** Starting in Version 11.1.3, if the record has an Attachments Table detail (also called "Associated Files"), the default XSLT templates installed with XFRACAS will display any attached image files (e.g., *.jpg, *.gif, *.jpeg or *.png) as images in the print preview. If you need to change the list of file types that are treated as images, you can modify the following code in the template:

```xml
<xsl:when test="AttachmentType = 'Blob Data' and ('jpg' = substring($imageName,string-length($imageName) - string-length('jpg') +1) or 'gif' = substring($imageName,string-length($imageName) - string-length('gif') +1) or 'jpeg' = substring($imageName,string-length($imageName) - string-length('jpeg') +1) or 'png' = substring($imageName,string-length($imageName) - string-length('png') +1))">``
Configuring E-mail Message Formats

The "E-mail Message Format" preferences in the String Preferences area of the Preferences page use variables to specify which information is included in each type of e-mail.

For example, this is the default format for e-mails sent when a new action is assigned from within an incident: %1|%2|%3|%4|%5|%6|%8.

It results in e-mails like the following:

New Action Assigned
Action ID: 2268
Action Creator: JOHN SMITH
Action Created Date/Time: 07/12/2013 08:37 AM
Action Type: Incident Action
Incident Report: E1-16118
Action Due Date: 07/20/2013
Action Description: This is a sample description.

You can replace the default with your own custom format that uses any of the variables that are available for incident action e-mails. For example, if you specify a custom format like this:

%I1 - %1|%2|%10|%6|%8|Acme Industries - Internal Use Only

It results e-mails like the following:

New Action Assigned
Incident Report: E1-16118 - Action ID: 2268
Action Creator: JOHN SMITH
Assigned To: JILL ENGINEER
Action Due Date: 07/20/2010
Action Description: This is a sample description.

Acme Industries - Internal Use Only

Incident E-mail Variables

These variables related to incident records can be used in any of the following e-mail formats:

- Detail Drop-down - E-mail Message Format - Incident
- Incident - E-mail Message Format - New (also used when the incident is modified)
Chapter 5: Managing Preferences

- Incident - E-mail Message Format - Customer Feedback
- Incident - E-mail Message Format - RMA Received

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Incident Entity Display ID (with link to incident)</td>
<td>Incident Report: #E1-115</td>
</tr>
<tr>
<td>%2</td>
<td>Incident Title</td>
<td>Incident Title: Part Failed</td>
</tr>
<tr>
<td>%3</td>
<td>Incident Created By (with e-mail link)</td>
<td>Incident Creator: John Smith</td>
</tr>
<tr>
<td>%4</td>
<td>Incident Created Date and Time</td>
<td>Incident Created Date &amp; Time: 07/12/2013 07:38 AM</td>
</tr>
<tr>
<td>%5</td>
<td>Assigned To</td>
<td>Incident Assigned To: Robert Jones</td>
</tr>
<tr>
<td>%6</td>
<td>Incident Part Number</td>
<td>Incident System Part Number: 1001</td>
</tr>
<tr>
<td>%7</td>
<td>Incident Serial Number</td>
<td>Incident System Serial Number: 2</td>
</tr>
<tr>
<td>%8</td>
<td>Incident Description</td>
<td>Incident Description: Some part failure occurred...</td>
</tr>
<tr>
<td>%DTX</td>
<td>Incident Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td>%CDTX</td>
<td>Incident's Associated CSI Detail Value (X represents the detail type ID)</td>
<td>Numeric Detail: 10</td>
</tr>
<tr>
<td>%DTM</td>
<td>The value of the detail that was selected (used only for detail drop-down e-mails).</td>
<td>Detail Name: Selected Value</td>
</tr>
<tr>
<td>!</td>
<td>New Line</td>
<td>Starts a new line in the message</td>
</tr>
</tbody>
</table>

Problem E-mail Variables

These variables related to problem records can be used in any of the following e-mail formats:

- Detail Drop-down - E-mail Message Format - Problem
• **Problem - E-mail Message Format - New** (also used when the problem is modified)
• **Problem - E-mail Message Format - Closure Requested**
• **Problem - E-mail Message Format - Reject**
• **Problem - E-mail Message Format - Signed Off**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Problem Entity Display ID (with link to problem)</td>
<td>Problem: #E1-4</td>
</tr>
<tr>
<td>%2</td>
<td>Problem Created By (with e-mail link)</td>
<td>Problem Creator: John Smith</td>
</tr>
<tr>
<td>%3</td>
<td>Problem Created Date and Time</td>
<td>Problem Created Date &amp; Time: 07/11/2013 02:23 PM</td>
</tr>
<tr>
<td>%4</td>
<td>Problem Owner (with e-mail link)</td>
<td>Owner: Tom Smith</td>
</tr>
<tr>
<td>%5</td>
<td>Problem Title</td>
<td>Problem Title: Parts</td>
</tr>
<tr>
<td>%6</td>
<td>Problem Description</td>
<td>Problem Description: Part Reports</td>
</tr>
<tr>
<td>%DTX</td>
<td>Problem Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td>%DTM</td>
<td>The value of the detail that was selected (used only for detail drop-down e-mails).</td>
<td>Detail Name: Selected Value</td>
</tr>
<tr>
<td></td>
<td>New Line</td>
<td>Starts a new line in the message</td>
</tr>
</tbody>
</table>

**Project E-mail Variables**

These variables related to project records can be used with this e-mail format:

• **Detail Drop-down - E-mail Message Format - Project**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Project Entity Display ID (with link to project)</td>
<td>Project: #E1-4</td>
</tr>
<tr>
<td>%2</td>
<td>Project Owner</td>
<td>Project Owner: John Smith</td>
</tr>
<tr>
<td>-----</td>
<td>---------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>%3</td>
<td>Project Start Date and Time</td>
<td>Project Start Date: 07/11/2013 02:23 PM</td>
</tr>
<tr>
<td>%4</td>
<td>Project Title</td>
<td>Project Title: Part Redesign</td>
</tr>
<tr>
<td>%5</td>
<td>Project Scope</td>
<td>Project Scope: To identify problems with the redesign process and implementation</td>
</tr>
<tr>
<td>%DTX</td>
<td>Project Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td>%DTM</td>
<td>The value of the detail that was selected (used only for detail drop-down e-mails).</td>
<td>Detail Name: Selected Value</td>
</tr>
<tr>
<td>1</td>
<td>New Line</td>
<td>Starts a new line in the message</td>
</tr>
</tbody>
</table>

**CSI E-mail Variables**

These variables related to CSI records can be used with the following e-mail format:

- **Detail Drop-down - E-mail Message Format - CSI**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Customer Support Information Entity Display ID (with link to CSI)</td>
<td>Incident Report: #E1-115</td>
</tr>
<tr>
<td>%2</td>
<td>Customer Support Information Author</td>
<td>CSI Author: Tom Smith</td>
</tr>
<tr>
<td>%3</td>
<td>Customer Support Information Shipment Date</td>
<td>Shipment Date: 05/21/2013 03:32 PM</td>
</tr>
<tr>
<td>%4</td>
<td>Customer Support Information Commission Date</td>
<td>Commission Date: 05/26/2013 09:01 AM</td>
</tr>
<tr>
<td>%5</td>
<td>Customer Support Information Decommission Date</td>
<td>Decommission Date: 07/15/2013 04:44 PM</td>
</tr>
</tbody>
</table>
### Chapter 5: Managing Preferences

<table>
<thead>
<tr>
<th>%6</th>
<th>Customer Support Information System Configuration</th>
<th>System Configuration: 867978, Part 1983 ver. 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>%DTX</td>
<td>CSI Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td>%CDTX</td>
<td>Incident's Associated CSI Detail Value (X represents the detail type ID)</td>
<td>Numeric Detail: 10</td>
</tr>
<tr>
<td>%DTM</td>
<td>The value of the detail that was selected (used only for detail drop-down e-mails).</td>
<td>Detail Name: Selected Value</td>
</tr>
<tr>
<td></td>
<td>New Line</td>
<td>Starts a new line in the message</td>
</tr>
</tbody>
</table>

**Failure Analysis E-mail Variables**

These variables related to failure analysis records can be used in any of the following e-mail formats:

- **Detail Drop-down - E-mail Message Format - FA**
- **Failure Analysis - E-mail Message Format - Work Order**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Failure Analysis Entity Display ID (with link to failure analysis report)</td>
<td>Failure Analysis Report: #E1-9</td>
</tr>
<tr>
<td>%2</td>
<td>Failure Analysis Created By</td>
<td>Created By: John Smith</td>
</tr>
<tr>
<td>%3</td>
<td>Failure Analysis Created Date and Time</td>
<td>FA Report Open Date: 07/13/2013 01:23 PM</td>
</tr>
<tr>
<td>%4</td>
<td>Incoming Part Number</td>
<td>Incoming Part #: 5309a</td>
</tr>
<tr>
<td>%5</td>
<td>Incoming Part Description</td>
<td>Incoming Part Description: Parts</td>
</tr>
<tr>
<td>%6</td>
<td>Incoming Serial Number</td>
<td>Incoming Serial #: 867</td>
</tr>
<tr>
<td>%7</td>
<td>System Part Number</td>
<td>System Part #: 5309b</td>
</tr>
<tr>
<td>%8</td>
<td>System Part Description</td>
<td>System Part Description: Parts</td>
</tr>
</tbody>
</table>
Chapter 5: Managing Preferences

<table>
<thead>
<tr>
<th>%9</th>
<th>System Serial Number</th>
<th>System Serial #: 1943</th>
</tr>
</thead>
<tbody>
<tr>
<td>%DTX</td>
<td>Failure Analysis Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td>%DTM</td>
<td>The value of the detail that was selected (used only for detail drop-down e-mails).</td>
<td>Detail Name: Selected Value</td>
</tr>
<tr>
<td>|</td>
<td>New Line</td>
<td>Starts a new line in the message</td>
</tr>
</tbody>
</table>

Incident Action E-mail Variables

These variables related to incident action records can be used in any of the following e-mail formats:

- **Action - E-mail Message Format - New - Incident**
- **Action - E-mail Message Format - Updated - Incident**
- **Action - E-mail Message Format - Complete - Incident**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Action ID (with link to action)</td>
<td>Action ID: #128</td>
</tr>
<tr>
<td>%2</td>
<td>Action Created By Name (with e-mail link)</td>
<td>Action Creator: John Smith</td>
</tr>
<tr>
<td>%3</td>
<td>Action Created Date and Time</td>
<td>Action Created Date/Time: 07/12/2013 08:38 AM</td>
</tr>
<tr>
<td>%4</td>
<td>Action Type</td>
<td>Action Type: Incident Action</td>
</tr>
<tr>
<td>%5</td>
<td>Associated ID (with link to incident)</td>
<td>Incident Report: E1-115</td>
</tr>
<tr>
<td>%6</td>
<td>Action Due Date</td>
<td>Action Due Date: 08/12/2013</td>
</tr>
<tr>
<td>%7</td>
<td>Action Complete Date</td>
<td>Action Complete Date: 08/02/2013</td>
</tr>
<tr>
<td>%8</td>
<td>Action Description</td>
<td>Action Description: Description...</td>
</tr>
<tr>
<td>%9</td>
<td>Action Result</td>
<td>Action Result: Result description...</td>
</tr>
</tbody>
</table>
# Problem Action E-mail Variables

These variables related to problem action records can be used in any of the following e-mail formats:

<table>
<thead>
<tr>
<th>%10</th>
<th>Action Assigned To</th>
<th>Assigned To: John Smith</th>
</tr>
</thead>
<tbody>
<tr>
<td>%I1</td>
<td>Incident Entity Display ID (with link to incident)</td>
<td>Incident Report: #E1-115</td>
</tr>
<tr>
<td>%I2</td>
<td>Incident Title</td>
<td>Incident Title: Part Failed</td>
</tr>
<tr>
<td>%I3</td>
<td>Incident Created By (with e-mail link)</td>
<td>Incident Creator: John Smith</td>
</tr>
<tr>
<td>%I4</td>
<td>Incident Created Date and Time</td>
<td>Incident Created Date &amp; Time: 07/12/2013 07:38 AM</td>
</tr>
<tr>
<td>%I5</td>
<td>Incident Assigned To</td>
<td>Incident Assigned To: Robert Jones</td>
</tr>
<tr>
<td>%I6</td>
<td>Incident Part Number</td>
<td>Incident System Part Number: 1001</td>
</tr>
<tr>
<td>%I7</td>
<td>Incident Serial Number</td>
<td>Incident System Serial Number: 2</td>
</tr>
<tr>
<td>%I8</td>
<td>Incident Description</td>
<td>Incident Description: Some part failure occurred...</td>
</tr>
<tr>
<td>%DTX</td>
<td>Action Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td>%IDTX</td>
<td>Incident Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td>%ICDTX</td>
<td>Incident’s Associated CSI Detail Value (X represents the detail type ID)</td>
<td>Numeric Detail: 10</td>
</tr>
<tr>
<td></td>
<td>New Line</td>
<td>Starts a new line in the message</td>
</tr>
</tbody>
</table>
• Action - E-mail Message Format - New - Problem
• Action - E-mail Message Format - Updated - Problem
• Action - E-mail Message Format - Complete - Problem

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Action ID (with link to action)</td>
<td>Action ID: #132</td>
</tr>
<tr>
<td>%2</td>
<td>Action Created By (with e-mail link)</td>
<td>Action Creator: John Smith</td>
</tr>
<tr>
<td>%3</td>
<td>Action Created Date and Time</td>
<td>Action Created Time/Date: 07/12/2013 10:15 AM</td>
</tr>
<tr>
<td>%4</td>
<td>Action Type</td>
<td>Action Type: Problem Action</td>
</tr>
<tr>
<td>%5</td>
<td>Associated ID (with link to problem)</td>
<td>Problem: E1-4</td>
</tr>
<tr>
<td>%6</td>
<td>Action Due Date</td>
<td>Action Due Date: 08/09/2013</td>
</tr>
<tr>
<td>%7</td>
<td>Action Complete Date</td>
<td>Action Complete Date: 08/07/2013</td>
</tr>
<tr>
<td>%8</td>
<td>Action Description</td>
<td>Action Description: Description...</td>
</tr>
<tr>
<td>%9</td>
<td>Action Result</td>
<td>Action Result: Result description...</td>
</tr>
<tr>
<td>%10</td>
<td>Assigned To</td>
<td>Assigned To: John Smith</td>
</tr>
<tr>
<td>%R1</td>
<td>Problem Entity Display ID (with link to problem)</td>
<td>Problem: #E1-4</td>
</tr>
<tr>
<td>%R2</td>
<td>Problem Created By (with e-mail link)</td>
<td>Created By: John Smith</td>
</tr>
<tr>
<td>%R3</td>
<td>Problem Created Date and Time</td>
<td>Problem Created Date &amp; Time: 07/11/2013 02:23 PM</td>
</tr>
<tr>
<td>%R4</td>
<td>Problem Owner (with e-mail link)</td>
<td>Owner: Tom Smith</td>
</tr>
<tr>
<td>%R5</td>
<td>Problem Title</td>
<td>Problem Title: Parts</td>
</tr>
<tr>
<td>%R6</td>
<td>Problem Description</td>
<td>Problem Description: Part Reports</td>
</tr>
</tbody>
</table>
Chapter 5: Managing Preferences

<table>
<thead>
<tr>
<th>%DTX</th>
<th>Action Detail Value (X represents the detail type ID)</th>
<th>Text Detail: Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>%RDTX</td>
<td>Problem Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td></td>
<td>New Line</td>
<td>Starts a new line in the message</td>
</tr>
</tbody>
</table>

Project Action E-mail Variables

These variables related to project action records can be used in any of the following e-mail formats:

- **Action - E-mail Message Format - New - Project**
- **Action - E-mail Message Format - Updated - Project**
- **Action - E-mail Message Format - Complete - Project**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Action ID (with link to action)</td>
<td>Action ID: #117</td>
</tr>
<tr>
<td>%2</td>
<td>Action Created By Name (with e-mail link)</td>
<td>Action Creator: John Smith</td>
</tr>
<tr>
<td>%3</td>
<td>Action Created Date and Time</td>
<td>Action Created Time/Date: 07/12/2013 01:21 PM</td>
</tr>
<tr>
<td>%4</td>
<td>Action Type</td>
<td>Action Type: Project Action</td>
</tr>
<tr>
<td>%5</td>
<td>Associated ID (with link to project)</td>
<td>Project: E1-4</td>
</tr>
<tr>
<td>%6</td>
<td>Action Due Date</td>
<td>Action Due Date: 08/21/2013</td>
</tr>
<tr>
<td>%7</td>
<td>Action Complete Date</td>
<td>Action Complete Date: 08/13/2013</td>
</tr>
<tr>
<td>%8</td>
<td>Action Description</td>
<td>Action Description: Description...</td>
</tr>
<tr>
<td>%9</td>
<td>Action Result</td>
<td>Action Result: Result description...</td>
</tr>
<tr>
<td>%10</td>
<td>Action Assigned To</td>
<td>Assigned To: John Smith</td>
</tr>
</tbody>
</table>
### Chapter 5: Managing Preferences

<table>
<thead>
<tr>
<th>%P1</th>
<th>Project Entity Display ID (with link to project)</th>
<th>Project: #E1-4</th>
</tr>
</thead>
<tbody>
<tr>
<td>%P2</td>
<td>Problem Owner (with e-mail link)</td>
<td>Project Owner: John Smith</td>
</tr>
<tr>
<td>%P3</td>
<td>Project Start Date and Time</td>
<td>Project Start Date: 07/11/2013 02:23 PM</td>
</tr>
<tr>
<td>%P4</td>
<td>Project Title</td>
<td>Project Title: Part Redesign</td>
</tr>
<tr>
<td>%P5</td>
<td>Project Scope</td>
<td>Project Scope: To identify problems with the redesign process and implementation</td>
</tr>
<tr>
<td>%DTX</td>
<td>Action Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td>%PDTX</td>
<td>Problem Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td></td>
<td>New Line</td>
<td>Starts a new line in the message</td>
</tr>
</tbody>
</table>

### CSI Action E-mail Variables

These variables related to CSI action records can be used in any of the following e-mail formats:

- **Action - E-mail Message Format - New - CSI**
- **Action - E-mail Message Format - Updated - CSI**
- **Action - E-mail Message Format - Complete - CSI**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Action ID (with link to action)</td>
<td>Action ID: #203</td>
</tr>
<tr>
<td>%2</td>
<td>Action Created By Name (with e-mail link)</td>
<td>Action Creator: John Smith</td>
</tr>
<tr>
<td>%3</td>
<td>Action Created Date and Time</td>
<td>Action Created Time/Date: 07/16/2013 11:16 PM</td>
</tr>
<tr>
<td>%4</td>
<td>Action Type</td>
<td>Action Type: CSI Action</td>
</tr>
</tbody>
</table>
### Chapter 5: Managing Preferences

| %5  | Associated ID       | Customer Support: E1-9                      |
| %6  | Action Due Date     | Action Due Date: 08/27/2013                  |
| %7  | Action Complete Date| Action Complete Date: 08/19/2013              |
| %8  | Action Description  | Action Description: Description...           |
| %9  | Action Result       | Action Result: Result description...         |
| %10 | Action Assigned To  | Assigned To: John Smith                      |
| %C1 | Customer Support Information Entity Display ID | CSI: #E1-9 |
| %C2 | Customer Support Information Author | CSI Author: Tom Smith |
| %C3 | Customer Support Information Shipment Date | Shipment Date: 05/21/2013 03:32 PM |
| %C4 | Customer Support Information Commission Date | Commission Date: 05/26/2013 09:01 AM |
| %C5 | Customer Support Information Decommission Date | Decommission Date: 07/15/2013 04:44 PM |
| %C6 | Customer Support Information System Configuration | System Configuration: 867978, Part 1983 ver. 1 |
| %DTX| Action Detail Value (X represents the detail type ID) | Text Detail: Value |
| %PDTX| Customer Support Information Detail Value (X represents the detail type ID) | Text Detail: Value |
| | New Line | Starts a new line in the message |

http://xfracas.reliasoft.com
Failure Analysis Action E-mail Variables

These variables related to failure analysis action records can be used in any of the following e-mail formats:

- **Action - E-mail Message Format - New - FA**
- **Action - E-mail Message Format - Updated - FA**
- **Action - E-mail Message Format - Complete - FA**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Action ID (with link to action)</td>
<td>Action ID: #121</td>
</tr>
<tr>
<td>%2</td>
<td>Action Created By Name (with e-mail link)</td>
<td>Action Creator: John Smith</td>
</tr>
<tr>
<td>%3</td>
<td>Action Created Date and Time</td>
<td>Action Created Time/Date: 07/12/2013 09:32 AM</td>
</tr>
<tr>
<td>%4</td>
<td>Action Type</td>
<td>Action Type: Failure Analysis Action</td>
</tr>
<tr>
<td>%5</td>
<td>Associated ID</td>
<td>Failure Analysis: E1-3</td>
</tr>
<tr>
<td>%6</td>
<td>Action Due Date</td>
<td>Action Due Date: 08/21/2013</td>
</tr>
<tr>
<td>%7</td>
<td>Action Complete Date</td>
<td>Action Complete Date: 08/13/2013</td>
</tr>
<tr>
<td>%8</td>
<td>Action Description</td>
<td>Action Description: Description...</td>
</tr>
<tr>
<td>%9</td>
<td>Action Result</td>
<td>Action Result: Result description...</td>
</tr>
<tr>
<td>%10</td>
<td>Action Assigned To</td>
<td>Assigned To: John Smith</td>
</tr>
<tr>
<td>%F1</td>
<td>Failure Analysis Entity Display ID</td>
<td>Failure Analysis Report: #E1-3</td>
</tr>
<tr>
<td>%F2</td>
<td>Failure Analysis Created By</td>
<td>Created By: John Smith</td>
</tr>
<tr>
<td>%F3</td>
<td>Failure Analysis Created Date and Time</td>
<td>FA Report Open Date: 07/13/2013 01:23 PM</td>
</tr>
<tr>
<td>%F4</td>
<td>Failure Analysis Incoming Part Number</td>
<td>Incoming Part #: 5309a</td>
</tr>
</tbody>
</table>
Chapter 5: Managing Preferences

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%F5</td>
<td>Failure Analysis Incoming Part Name</td>
<td>Incoming Part Description: Parts</td>
</tr>
<tr>
<td>%F6</td>
<td>Failure Analysis Incoming Serial Number</td>
<td>Incoming Serial #: 867</td>
</tr>
<tr>
<td>%F7</td>
<td>Failure Analysis System Part Number</td>
<td>System Part #: 5309b</td>
</tr>
<tr>
<td>%F8</td>
<td>Failure Analysis System Part Name</td>
<td>System Part Description: Parts</td>
</tr>
<tr>
<td>%F9</td>
<td>Failure Analysis System Serial Number</td>
<td>System Serial #: 1943</td>
</tr>
<tr>
<td>%DTX</td>
<td>Action Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td>%PDTX</td>
<td>Failure Analysis Detail Value (X represents the detail type ID)</td>
<td>Text Detail: Value</td>
</tr>
<tr>
<td></td>
<td>New Line</td>
<td>Starts a new line in the message</td>
</tr>
</tbody>
</table>

**Status E-mail Variables**

These variables (related to the status updates that users can add in incidents, actions, failure analysis, problems or projects) can be used in any of the following e-mail formats:

- **Detail Status - E-mail Message Format - Action**
- **Detail Status - E-mail Message Format - Incident**
- **Detail Status - E-mail Message Format - FA**
- **Detail Status - E-mail Message Format - Problem**
- **Detail Status - E-mail Message Format - Project**

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Status Added By (with link to send e-mail to user)</td>
<td>Status Added By: John Smith</td>
</tr>
<tr>
<td>%2</td>
<td>Date and Time</td>
<td>Date &amp; Time: 07/11/2013 02:23 PM</td>
</tr>
<tr>
<td>%3</td>
<td>Associated Record</td>
<td>Associated Incident: E1-103</td>
</tr>
</tbody>
</table>
E-Mails Based on Calendar Date

You can configure XFRACAS to send reminder e-mails when actions are approaching their due dates or are past due, and when Failure Review Board members need to sign off on a step in a problem.

E-mail Reminders for Actions

For actions, you set how many days prior to an action being due that the action owner will receive an e-mail. You can also configure XFRACAS to send follow-up reminders every X days until the action is completed.

Set the following preferences to send e-mails when the action's due date is approaching.

- Specify which record types to send e-mails for and define the format of the e-mails:
  - E-mail - CSI Action Due Date and Action - E-mail Message Format - Complete - CSI
  - E-mail - Incident Action Due Date and Action - E-mail Message Format - Complete - Incident
  - E-mail - FA Action Due Date and Action - E-mail Message Format - Complete - FA
  - E-mail - Problem Action Due Date and Action - E-mail Message Format - Complete - Problem
  - E-mail - Project Action Due Date and Action - E-mail Message Format - Complete - Project
  - E-mail - Action Due in X Days Offset - the number of days prior to the action due date that the e-mail will be sent.

If you also want XFRACAS to continue to send follow-up reminders until the action is completed, set the following preferences:
Chapter 5: Managing Preferences

- **E-mail - Send Action Due Notify Once** - set to False so that additional e-mails will be sent at regular intervals. (If it is set to True, then only the initial e-mail will be sent.)

- **E-mail - Remind Action Due Every X Days** - the number of days after the first or previous reminder that another e-mail will be sent.

### E-mail Reminders for Failure Review Board Members

For a problem Failure Review Board (FRB), you set how many days after a problem step has entered a Completed Date that the FRB members will receive an e-mail. You can also configure XFRACAS to send follow-up reminders ever X days until they approve the problem step.

Set the following preferences to send e-mails when a problem step is ready to be signed off.

- **E-mail - FRB After Requested Closure in X Days Offset** - the number of days after a step’s Completed Date has been entered that an e-mail will be sent to the FRB reviewers if they have not already signed off on the step.

- **E-mail - Remind FRB After Requested Closure Every X Days** - the number of days after the first or previous reminder that another e-mail will be sent.

- **Problem - E-mail Message Format - Closure Requested** - the format of the e-mails.

### Time Metric Calculations

If you configure XFRACAS to track incidents and part repairs/replacements for specific serialized systems, you will be able to capture time/usage data that can be used for reliability data analysis.

There will always be one primary time/usage metric (Time Metric 1) and you can choose to enable up to two additional fields if desired (Time Metric 2 and Time Metric 3). By default, these fields are called "System Hours," "Number of Starts" and "kW Run Hours," but you can record any metric(s) of interest (hours, miles, kilometers, cycles, etc.) and use the **Resource Manager** to modify the interface labels.

### Reported System Hours

The Customer Support page for a serialized system displays the latest reported value(s) for the time/usage metric(s) enabled for the entity. This information can be obtained from a) incidents reported for the serialized system, b) manual entry via the Customer Support interface and/or c) usage data imported from an external source.

Click the link to see the history of all usage reports for that particular system. Click to manually enter new information.
Estimated System Hours
For the primary metric only (Metric 1), the Customer Support page also displays the estimated usage at today's date. If there are at least two reported values for the system's actual time/usage, the estimate is calculated as follows:

\[(\text{Commission Date} - \text{Today's Date}) \times \text{Average Usage per Day}\]

To estimate the average usage per day, XFRACAS fits a slope to the reported time/usage values. However, if the estimate exceeds the maximum possible per day (which is specified in the "Incident - Max Units/Day - Time Metric 1" preference), the max per day will be used instead.

This estimate is used for CSI MTBF calculations (discussed below) and may also be incorporated into custom reports and charts if applicable.

Auto-Populate Time Metric 1
By default, users will be prompted to enter the time/usage metric(s) in each incident report for a serialized system. Alternatively, you can configure XFRACAS to automatically populate the primary metric (Metric 1) when the following preferences and inputs are available:

- **Preferences:**
  - Incident - Auto-populate Time Metric 1 is True
  - Incident - Max Units/Day - Time Metric 1 is a number greater than 0

- **Incident:**
  - Serial Number has been entered
  - Occurrence Date has been entered

- **Customer Support:**
  - Commission Date has been entered and it is earlier than the incident's Occurrence Date

If the "System Down Event" field (a special Detail field for incidents) is not enabled for the entity, the calculation is as follows:

\[(\text{Commission Date} - \text{Occurrence Date}) \times \text{Max Units/Day}\]

If the "System Down Event" field is enabled, the downtime is obtained from any incidents for the serialized system where this check box is selected. For each incident, the time down is the Repair Date - Occurrence Date (or if a repair has not been entered, it is Today's Date - Occurrence Date). The calculation to auto-populate Metric 1 is:

\[(\text{Commission Date} - \text{Occurrence Date} - \text{Time Down}) \times \text{Max Units/Day}\]
Auto-Calculate Time Metric 1, 2 or 3
You can also configure XFRACAS to automatically calculate a time metric based on the value for another metric. For example, if Metric 1 is miles, you can configure Metric 2 as kilometers and calculate it automatically based on the value entered for miles (t1 * 1.60934). The behavior depends on the following preferences and what the user enters in the incident page.

- Incident - Display Time Metric [2/3]
- Incident - Always Auto-calculate Time Metric [1/2/3]
- Incident Time Metric [1/2/3] Formula

Configuring Metric Settings and Formulas
It is important to be aware that the Preferences page does not prevent you from saving incompatible settings or invalid formulas, which may result in unexpected behavior for the metric fields in incidents. Note that:

- If the formula is blank, the field saves the entered value, regardless of whether "Auto-calculate" is true.
- If the formula is not blank and "Always Auto-calculate" is true, the field attempts to calculate the value. If the formula is invalid, the calculated value will be 0.
- If the formula is not blank and "Always Auto-calculate" is false, the field EITHER saves the entered value OR attempts to calculate if a value was not entered. For example, this configuration may be appropriate if some incidents have usage reported in Metric 1 and other incidents have usage reported in Metric 2.

Also note that:

- Operands and operators must be separated by spaces.
- Valid operators are * / + and -.
- A valid operand can be a number, a time metric field (t1, t2 or t3) or a list of parameters (e.g., [t1,t2]) that will be checked in order until a parameter is found that is not 0.
  - A metric's formula should not refer to itself. For example, the formula for Metric 1 should not be t1 * 20.
  - A metric's formula should not refer to a metric that is not enabled.
  - A metric's formula should not refer to a metric that is already set to auto-calculate. For example, if the formula for Metric 2 is t1 * 30 (e.g., 30 miles for every hour), do not set the formula for Metric 3 as t2 * 1.60934 (e.g., 1.60934 km for every mile). Instead, set it to t1 * 48.202 (e.g., 48.202 km for every hour).
**MTBF, MTBCF, MTBNCF and MTBI**
The Customer Support page also provides the option to display some very basic reliability metrics based only on the data from a single serialized system. If the preferences are enabled, the MTBF metrics are calculated as follows:

\[
\text{Number of Incidents ÷ Total Time/Usage}
\]

Although we recommend to use Weibull++ or RGA for more robust reliability analysis whenever possible, the CSI MTBF metrics may be used, for example, if you need to monitor a specific machine in a manufacturing line to determine whether it is meeting the contracted MTBF.

The CSI page displays two values for each metric (e.g., MTBF / MTBFE). The first is based on the reported time/usage for Metric 1; the second is based on the estimated time/usage.

Since an incident may be a "chargeable failure" or a "non-chargeable failure" depending on the Incident Category, there's a choice of four metrics that can be displayed:

- **CSI - Display MTBF** (mean time between failures) and **CSI - Display MTBCF** (mean time between chargeable failure incidents) are the same metric
- **CSI - Display MTBNCF** is the mean time between non-chargeable failure incidents
- **CSI - Display MTBI** is the mean time between incidents (both chargeable and non-chargeable)

**Extract Data for Reliability Analysis**
For more robust reliability analysis, you can use the Synthesis Data Warehouse (SDW) in ReliaSoft Weibull++/ALTA or RGA desktop applications to extract data from XFRACAS that can be used for either life data analysis or reliability growth analysis.

For information about using the desktop applications to extract the data and transfer to an analysis folio, please see Extracting Data from XFRACAS in the desktop application's help files. The extraction process for life data analysis works as follows:

1. **Select Parts** - The user selects one part or multiple parts to be analyzed together in the same data set.

2. **Get Data from Serialized Incidents**
   a. The SDW identifies all serialized systems that contain the specified part(s).
   b. For each serialized system, the SDW finds all "serialized incidents" and orders by occurrence date to build a timeline.
      i. The SDW finds all incidents within the timeline in which the specified part(s) were repaired or replaced.
Chapter 5: Managing Preferences

ii. The SDW checks the "Failure Type" for the repair and the "Incident Category" for the incident:

1. If both are chargeable (e.g., repair is "Primary Failure" and incident is "Component Failure"), then the incident is treated as a Failure (F).

2. If one or both are non-chargeable (e.g., repair is "Primary Failure" but the incident is "ASP Error"), then the incident is treated as a Suspension (S).

3. Get Data from Part Incidents

   a. The SDW finds all "part incidents" in which the specified part(s) were repaired or replaced.

   b. The SDW checks the "Failure Type" for the repair and the "Incident Category" for the incident (as described above) to determine if the incident will be treated as a Failure (F) or Suspension (S).

Configuring Criticality Metrics

To configure a criticality formula in the String Preferences area of the Preferences page, the formula must consist of one of the following:

- A number (e.g., 7, 12.4, etc.).
- A criticality field, represented by "c" plus the field’s display order. For example, c2 or c4. The field’s display order is set and shown in the Criticality page.
- A list of numbers or criticality fields separated by commas, surrounded by brackets. For example, [c4,c3,c2] or [c7,c5,9].

Every number or criticality field (except those in brackets) must be separated by one of the following math operators: *, /, + or -. The formula requires a space between the numbers and math operators but not between the items in brackets.

The formula is parsed from left to right with numbers or criticality fields alternating with math operators. When a bracketed list is encountered, the list is checked for any value that is not a 0. The first value that is not a 0 is the value that is used in the formula.

The default Incident Potential Criticality formula is $c_1 \times c_2 \times c_3$. In this formula, criticality field 1, criticality field 2 and criticality field 3 are multiplied together.

The default Problem Current CIN formula is $c_1 \times c_2 \times c_3 \times [c_6, c_5, c_4] \times c_7$. In this formula, criticality field 1, criticality field 2 and criticality field 3 are multiplied together. Next, criticality...
field 6, then criticality field 5 and then criticality field 4 are checked for 0. The first criticality 
field that does not contain a 0 is multiplied into the formula and the two other criticality fields 
are ignored. Finally, the formula is multiplied by criticality field 7.

**Note:** Time metric formulas are formatted in the same way as criticality formulas, using a “t” 
placeholder instead of a “c” (i.e., t1, t2, t3, etc.). See Auto-Calculate Time Metric 1, 2 or 3.

### Entering an ADS Path

The Active Directory Services (ADS) path uniquely represents each object in the Active Directory 
Service. This can be compared to your mailing address. If the path showed "United States, 
Arizona" then all addresses in the state would be displayed, while "United States, Arizona, Pima 
County, Tucson, Eastside Loop" would display only the addresses on that street.

To retrieve the network’s Global Address List (GAL), you can enter the correct ADS path for a 
Lightweight Directory Access Protocol (LDAP) connection in the Exchange ADS Path preference, 
which is located in the String Preferences area of the Preferences page. LDAP is a set of 
protocols used to access contact information from a server (in this case, a Windows Active 
Directory server). This path is necessary to retrieve e-mail addresses from the network's GAL. If 
this functionality is not necessary or not desired, the three Exchange preferences can be left 
blank. If your server supports CDO 1.21, the Exchange ADS Path preference can be left blank 
and the Exchange Profile Name and Exchange Server Name preferences can be used to access 
the network's GAL via a CDO connection.

The best way to determine the exact ADS path for your needs is to use Microsoft's ADSI Edit 
program. ADSI Edit is included with the Windows 2000 Support Tools on the Windows 2000 CD-
ROM and with the Windows Support Tools on the Windows Server 2003 CD-ROM. Microsoft's 
Knowledge Base article 312299 describes the usage of ADSI Edit.

### LDAP Connection String Examples

While each ADS path will be unique, the following will show the general format used in an ADS 
path.

- A Windows NT/Exchange 5.x system might look something like this: 
  
  LDAP://ExchangeServer/o=Organization/ou=Site/cn=Recipients

- A Windows/Exchange 2000/2003/2008 system might look something like this: 
  
  LDAP://YourDomain.local/CN=Users,DC=YourDomain,DC=local

- If there is a problem resolving the name, try the IP Address: 
  
  LDAP://10.0.0.25/CN=Users,DC=YourDomain,DC=local
Chapter 6: Managing Configurable Fields

Managing Detail Fields
The Details page allows you to manage configurable fields in various record types. Permissions required to access this page: Access Admin Tab and Manage Details.

To open the Details page, choose **Admin > Configure > Details**.

If your XFRACAS website has more than one Entity, the detail fields can be configured separately for each. The drop-down list at the top of the page determines which entity's detail fields are currently displayed.

Types of Detail Fields
- **Action Fields** appear in the Action page.
- **Company Fields** appear in the [Companies page](#).
- **Contact Fields** appear in the [Contacts page](#).
- **CSI Fields** appear in the Customer Support page. You can specify the sections where the fields will appear.
- **FA Fields** appear in the Failure Analysis page. You can specify the sections where the fields will appear.
- **Incident Fields** appear in the Incident page. You can specify the sections where the fields will appear.
- **Location Fields** appear in the [Locations page](#).
- **Part Fields** appear in the parts that are associated with system templates and serialized systems.
- **Problem Fields** appear in the Problem page. You can specify the sections where the fields will appear.
- **Project Fields** appear in the Project page. You can specify the sections where the fields will appear.

The options depend on the type of field (description, date, check box, etc.) and the type of record (incident, problem, etc.). Some of the current settings are displayed in parentheses
under the field name. In the following example, the "Custom Text Field" will display in the first detail field position in the "Incident Details" area of the Incident page, and it will be read-only after a value is entered. The "Custom Date Field" will display in the second portion of that area, and is required (red text).

Fields identified with an asterisk (*) are referred to as "special detail fields" and can be retired but not deleted.

**Adding or Editing a Field**

To add a new field, click the Add icon for the relevant record type. To edit an existing field, first select the radio button to the left of the field and then click Edit.

Note that you can use the same detail field in multiple entities, if desired. The Add or Remove Entities area shows the entities that you have access to, and allows you to choose which ones will include the detail field you're currently editing. If you do not have access to all the entities where a field is used, you can add or remove it from the entities that you have access to, but you can't edit the other options.

- If applicable, select the area that the field will appear in from the Section or Step dropdown list.
- Select a Field Type from the drop-down list.
- Enter the Field Name (the label shown in the interface) and Field Description (the tip that appears when a user points to the field).
- Specify whether user input is Optional/Required. This option is not available for the following field types: Accessory; Attachments Table; Check Box; Separator; Status.
- Specify the Display Order, which determines where the field will be displayed in the page. If you don't specify a value, XFRACAS will automatically assign one. If the display order numbers are not in sequence (e.g., 1, 2, 4), then a blank space will fill that position.
- Span width of page forces the detail field to span the entire width of the area on the page. If not selected, the field will display at its default width, which varies depending on the field type.
- Specify the Default Value that will be displayed on new record creation, if applicable. This option is not available for the following field types: Accessory; Address;
Attachments Table; Company; Current System Users; Failure Mode; Separator; Status; System Contacts; Tree.

- For some detail types (e.g., select list, tree, etc.), you will need to use the Lists page to configure values that will be available to select. When you create the detail, you can choose an Existing Dropdown or leave the option blank so XFRACAS will create a new list.

- **Read-only** allows you to make the detail unavailable to edit in certain circumstances. The options depend on the field and/or record type.
  - **Always** - the field is always read-only in the web interface (e.g., because the value is intended to be imported). If the value is imported incorrectly, only a user with the "Details - Overwrite Read-Only" permission will be able to modify it.
  - **After a value is entered** - once a user enters a value in the field, it can't be changed.

### Deleting or Retiring a Field

- To remove or retire a field, first select it and then click the Delete icon, 🗑️.
  - If the field is a special detail field (identified with an asterisk) or has already been used in any existing records, it will be retired for the current entity and appear grayed out.
  - If the field has never been used in any existing records, it will be completely removed from the system.

- To unretire a detail field, select the field name and click the Edit icon, 📝. You will see a message confirming that you want to unretire the detail field. Click OK to proceed.

### Using Space and Separators

If you want to add or remove space above a particular detail, select the radio button to the left of the field and then click the Add Space or Delete Space links for the relevant record type.

If you want to add a line within an area of the space, add a "Separator" detail. The Field Description will display as a label within the page, and the Field Name will display as a tip when the user points to the separator. If you leave both fields blank, only the line will be displayed.
In the following example, there are 4 extra spaces between a custom description field (in position 4) and a separator (in position 9) that identifies a custom sub-section within two list fields (positions 10 and 11).

**Field Types**

The following types of detail fields can be created:

- **Accessory**: a drop-down list from which users can select multiple options, each of which involves a description, a part number and a serial number. The options in the list will be controlled by the system users via Add, Edit and Delete icons that appear next to the list.

- **Address**: a drop-down list displaying the combinations of company and location that have been defined in the system.

- **Alphanumeric Input Box**: an input box in which users can enter letters and numbers. You can set a maximum length between 1 and 255 characters; the default maximum is 50 characters.

- **Attachments Table**: a table that allows users to create attachments.

- **Check Box**: a check box that users can select or clear.

- **Company**: a drop-down list displaying all companies that have been defined in the system.

- **Contacts**: a drop-down list displaying all system contacts. The user can select one name.

- **Currency**: an input box in which users can only enter numbers. The input is interpreted as currency. You can specify the number of decimal places to display, the minimum and/or maximum acceptable value that can be entered in the field and the world currency type.

- **Date**: a date field.

- **Description**: an input box in which users can enter letters and numbers. You can set a maximum length between 1 and 4,000 characters; the default maximum is 4,000...
characters. You can select the Allow Existing Text Search check box to allow users to choose text that has already been used in the field in other records.

- **Failure Mode**: a field controlled by two drop-down lists from which users can select options, one for failure mode and one for root cause. The options in the lists will be determined by the failure modes and root causes of failure modes assigned to the parts on the Templates page. It is also possible to allow users to add options to the list by selecting the Allow User Creation check box. This field type is available only for the Failure Analysis, Incident and Problem pages.

- **Hyperlink**: a hyperlink that allows linking to an external system with the ability to pass information to that system. See Configuring Hyperlink Details for details on how to configure hyperlink details.

- **Item Category**: a list of item category values from which users can select multiple options. The options in the list are brought in when parts are imported from Xfmea/RCM++/RBI.

- **Multiple List**: a list from which users can select multiple options. The options in the list will be controlled by the system users via Add, Edit and Delete icons that appear next to the list.

- **Numeric Input Box**: an input box in which users can only enter numbers. You can specify the number of decimal places to display and the minimum and/or maximum acceptable value that can be entered in the field.

- **Print Preview**: a link that provides a print preview of the page, based on the *.xslt file specified for the field. This field type is available only for the CSI, Failure Analysis, Incident, Problem and Project pages.

- **Select List, Administrative Controlled**: a drop-down list from which users can select an option. The options in the list will be controlled by the system administrators via the Lists page. It is also possible to allow users to add options to the list by selecting the Allow User Creation check box. If you want to use the same list of values as an existing detail field within the current entity, select the name of that field from the Existing Dropdown list.

- **Select List, Administrative Controlled, Multiple**: a drop-down list from which users can select multiple options. The options in the list will be controlled by the system administrators via the Lists page. It is also possible to allow users to add options to the list by selecting the Allow User Creation check box. If you want to use the same list of values as an existing detail field within the current entity, select the name of that field from the Existing Dropdown list.

- **Select List, Checkbox Options, Multiple**: a list from which users can select multiple options by selecting a check box for each. Note that pointing to a selected option will
display a tool tip indicating the user who checked the item and the time it was checked. The options in the list will be controlled by the system administrators via the Lists page. It is also possible to allow users to add options to the list by selecting the Allow User Creation check box. If you want to use the same list of values as an existing detail field within the current entity, select the name of that field from the Existing Dropdown list.

- **Select List, User Controlled, Multiple**: a drop-down list from which users can select multiple options. The options in the list will be controlled by the system users via Add, Edit and Delete icons that appear next to the list.

- **Separator**: a horizontal line. Note that the Field Name will be the tool tip that appears when a user points to the field and the Field Description will be shown as a label below the separator.

- **Status**: a status table with an Add icon that allows users to add status messages. You can select the Allow Existing Text Search check box to allow users to choose text that has already been used in the field in other records.

- **Tree**: a list of values or issues organized into a tree structure. The options in the tree will be controlled by the system administrators via the Lists page.

- **Users**: a drop-down list displaying all current system users. You can use the User Category drop-down list to specify a single user category that will be used to filter the system users list, if desired. Fields of this type will have an icon, , that allows the user to select themself from the list with a single click.

- **Yes/No Option Buttons**: Yes and No radio buttons.

### Configuring the Select Existing Utility

The Select Existing Utility enables users to reuse text from existing description and status fields in action, customer support, failure analysis, project, incident and problem records. This can help to save time on data entry, ensure consistency and facilitate brainstorming.

When the description or status is a configurable detail field, you can choose whether the feature will be available for that particular field. You can also choose which users will be able to access the utility when it is available.
Enable the Search Feature for Selected Detail Fields
When you create or modify a description or status field in the Details page (Admin > Configure > Details), select the Allow Existing Text Search check box to enable the feature for that field. It will be visible only to users who have the "Details - Allow Existing Text Search" permission.

Set the User Permissions
When you create or modify a user account in the Users page (Admin > Configure > Security > Users), set the following permissions to specify whether the user can access the utility when it is available.

This permission applies for detail field in any record type. This includes all of the description and status fields in incidents and problems, as well as any relevant configurable details in actions, CSIs, failure analysis reports and projects.

- Details - Allow Existing Text Search

These permissions apply for description and status fields that are built-in for a specific record type (e.g., action descriptions, failure analysis visual inspection, etc.).

- Action - Allow Existing Text Search
- CSI - Allow Existing Text Search
- Failure Analysis - Allow Existing Text Search
- Project - Allow Existing Text Search
Configuring Hyperlink Details
A hyperlink detail allows linking to an external system with the ability to pass information to that system. It can include specific variables used to pass information from XFRACAS to the external system. The variables available for use are shown next.

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>%1</td>
<td>Entity Display ID (the record number, such as &quot;E1-1&quot;)</td>
</tr>
<tr>
<td>%2</td>
<td>User ID (ID of the currently logged in XFRACAS user)</td>
</tr>
<tr>
<td>%3</td>
<td>Page ID (the internal ID of the record)</td>
</tr>
<tr>
<td>%4</td>
<td>User Name (username, with domain, of the currently logged in XFRACAS user, e.g., &quot;COMPANY\USERNAME&quot;)</td>
</tr>
<tr>
<td>%5</td>
<td>Page title (title of the record)</td>
</tr>
<tr>
<td>%6</td>
<td>User Name Without Domain (username of the currently logged in XFRACAS user, but with the Windows domain stripped off. For example, &quot;COMPANY\USERNAME&quot; would be included as just &quot;USERNAME.&quot;)</td>
</tr>
<tr>
<td>%7</td>
<td>User Language Code</td>
</tr>
<tr>
<td>%DTX</td>
<td>Detail Value (X represents the detail type ID)</td>
</tr>
</tbody>
</table>

For example, the URL field for a hyperlink detail might look like this:

```
http://external.site.com/doStuff.cgi?record=%1&user=%2&title=%5&lang=%7
```

When incident E1-1, titled "Overflow," is edited by the user with ID 234, the URL generated would be:

```
```

Clicking the link opens the result in a new browser window. There is no expectation of anything being returned.

Managing Criticality Fields
The Criticality page allows you to maintain the criticality fields that may appear in the Incident and Problem pages. (Whether the criticality fields appear on those pages is controlled by the
system preferences Incident - Display Actual Criticality, Incident - Display Potential Criticality and Problem - Display Criticality.) Permissions required to access this page: Access Admin Tab and Manage Criticality.

To open the Criticality page, choose Admin > Configure > Criticality.

This page displays a separate bar for each of the pages that you can manage criticality field names for. Click a bar to hide or display the field names for that page.

Below each incident criticality field, the type of criticality field will appear in parentheses (e.g., Potential, c3). This indicates whether the criticality field is a potential criticality field or an actual criticality field and specifies a variable name that helps determine how the criticality field is calculated, as specified in the String Preferences area of the Preferences page.

Below each problem criticality field, the area in the Problem page that the criticality field appears in will appear in parentheses. For example, Problem Step 2, c3 indicates that the criticality field appears in the second step of the Problem page. Note that this is essentially a reminder, as problem criticality fields can appear only in step 2.

The field that appears next to each criticality field displays the field type. All criticality fields are automatically set by the system to the Select List, Administrative Controlled field type, which is a drop-down list from which users can select an option. The options in the drop-down list will be controlled by the system administrators via the Lists page.

Using the Criticality Page

- To add a new criticality field to a page for the current entity, click the Add icon, in the corresponding area. In the Criticality Field utility that appears, do the following:
  - If you are adding an incident criticality field, choose whether the field is a potential criticality field or an actual criticality field from the Section drop-down list.
  - Enter the Field Name, Field Description and Display Order in the corresponding input boxes. The field description will be the tool tip that appears when a user points to the field.
  - Specify other field properties:
    - Span width of page forces the field to span the entire width of the page. If you do not select this check box, the field will display at its default width, which varies depending on the field type.
    - Default Value allows you to choose the value that will be selected by default for the field. This list will be populated only if you have specified
available values for the criticality field. During field creation, this can be done using the Existing Dropdown list, provided a list with the appropriate values for the criticality field already exists. If no list exists, you can create the field, use the Lists page to create the list and then return to edit the criticality field.

- Select the Entities that you want the field to be associated with. You can associate the field only with entities that you have access to.

- Click Save.

- To edit an existing field that appears in a page for the current entity, select the field and click the Edit icon. In the Criticality Field utility that appears, make the desired changes and then click Save. Note that the changes will apply to all existing incidents and problems for the selected entities. In addition, you can edit a field only if you have access to all the entities that the field is associated with. If you do not have access to all the entities, you will only be able to associate it with or disassociate it from the entities that you have access to.

- To remove or retire an existing field from a page for the current entity, select the field and click the Delete icon. You will see a message confirming that you want to delete the field. Click OK to delete the field. If the deleted field was used within the system, it will be retired and will now appear greyed out, which indicates that it will no longer be displayed in the page for the current entity. However, this field can be displayed again at any time by unretiring it. The field will be deleted, and its associated values deleted from the Lists page, if neither it nor its values were used within the system.

- To display a retired detail field, select the field name and click the Edit icon. You will see a message confirming that you want to unretire the detail field. Click OK to proceed.

Managing Lists

The Lists page allows you to maintain lists of available values for user interface fields that require selection from specified values, or "issues." Permissions required to access this page: Access Admin Tab and Manage Lists.

To open the Lists page, choose Admin > Configure > Lists.

What’s Changed? In previous versions, lists were called "lookup lists."

This interface displays a separate bar for each type of information that you can maintain. Click a bar to hide or display the issues that have already been defined for that field. You can also click
the pushpin at the right end of a bar if you want to "lock" the bar so the information remains displayed while you click other bars. Click the pushpin again to remove the lock on the bar.

For each list, you can configure the following:

- The list name.

- How the issues will be displayed in the drop-down list: by code, by description or with a combination of the two.

- How the issues will be sorted when displayed in the drop-down list. You can sort the issues by description or by code, as strings or as numbers in either case. For each type of sorting, you can also specify the order of sorting (ascending or descending).

- The issues in the list.

The description and code/name for each issue in the list will be displayed for the current entity. A check box will appear next to the issue that is set as the default item, if any, and the issue will appear in blue text. In addition, the retired date will appear next to an issue once it is deleted. Please note that only issues that were used in the system can be retired. Items that were not used in the system will be deleted.

- To add a new issue, click the Add icon, to open the Issue utility for that list type.
  - For tree details, you can select an existing issue and then click the Add icon to add a child issue.

- To edit an existing issue or to associate additional part numbers with an existing issue, select the issue and click the Edit icon, .

- Select one or more items in the list of associated parts and click the Delete icon, , to delete the existing issue(s) or to remove the association between a part number and an existing issue for the current entity. You will be prompted to confirm that you wish to delete the item and then it will be deleted or retired. If the item was never used in the current entity, it will be deleted from the current entity. If the current entity is the last or only entity in which the item exists, and the item was never used in the entity, it will be deleted from XFRACAS. If the item was used in the current entity, then it will be retired for the entity. If an item is retired, it will no longer be available to assign to an XFRACAS record for the current entity. However, it will continue to be associated with any existing records. In addition, if the item is associated with any other entities, it will still be available for those entities.

More Issues opens the Edit Issue List utility, which allows you to access all issues of the current issue type from other entities and select them for use in the current entity (i.e., use the same issues across multiple entities).
Lists
You can use the Lists page to manage standard lists and any lists that were added to the current entity via the Details page. Therefore, the lists that appear in your system may vary. Note also that some of the issues are required in XFRACAS. If you attempt to delete them, you will receive an error from XFRACAS and will not be able to delete them. Selected information about some of the standard lists is given next.

- The Attachment – Record Association Type list defines the relationships that can be assigned when attaching an XFRACAS record to another XFRACAS record via the Attachment Information utility. You cannot delete these issues.
- The FA ATP Test Result list defines the Acceptance Test Procedure (ATP) test results that can be assigned to a failure analysis report.
- The Incident Category Chargeable list defines the chargeable (reliability-wise) incident categories that can be assigned to an incident report. These categories, along with the Incident Category Non-Chargeable categories, will appear in the Incident Category drop-down list and will help determine if the failure is treated as a failure or as a suspension for reliability calculations. Note the interaction between the incident category and the failure type:
  - If the incident category is non-chargeable, the incident is non-chargeable.
  - If the incident category is chargeable, then:
    - If at least one repaired/replaced part in the Incident Repair Information area has a chargeable failure type, the incident is chargeable.
    - If all repaired/replaced parts in the Incident Repair Information area have non-chargeable failure types, the incident is non-chargeable.
Examples of chargeable incident categories might include component failure (i.e., the part simply stops working), design issue or production error (i.e., the part was not built correctly or assembled correctly by the manufacturer). Examples of non-chargeable incident categories might include installation issue, operator error, software configuration problem or end of useful life.
- The Incident Failure Type Chargeable list defines the failure types that represent chargeable part failures that can be assigned to an incident report. These failure types, along with the Incident Failure Type Non-Chargeable failure types, will appear in the Failure Type drop-down list in the Replace Part utility and Repair Part utility. Note the interaction between incident category and incident failure type listed above. Primary failure is considered a chargeable failure type. Primary suspension, collateral failure and collateral suspension are considered non-chargeable failure types.
• The **Incident Parts Disposition** list defines the part disposition classifications that can be assigned to describe the disposition of a replaced or failed part via the Replace/Repair Parts utility.

• The **Incident System Status** list defines the system statuses that can be assigned to a serialized system on the Incident page.

• The **Output Record Count** list defines the number of records that can be selected in the Report Builder's **Records per Page** field, which determines the number of records that are displayed on each page of the report results.

### Issue Utility

The changes made in the Issue utility will apply to all records that have already been associated with that issue. If you do not want the changes to apply to existing records, you can retire the existing issue and create a new issue with the new information, which allows you to add a new issue or a new issue with associated parts to the list or to associate additional part number(s) with an existing issue for the current entity or for other entities that you have access to.

The appearance of this utility will vary depending on whether the issue is associated with parts. For issues not associated with parts, you can specify the following:

• The issue **Description** is the text that will be displayed in the list in the user interface. You cannot edit the description if the issue is used in an entity you do not have access to.

• The issue **Code** indicates the issue’s priority in relation to the other issues in the list.

• If you select the **Default** check box, the issue will be set as the default item and will be displayed by default in the list in the user interface. Please note that the issue will then be removed from all other entities. The **Default** check box will be unavailable if the issue is used in an entity you do not have access to.

• If you enter an E-mail Address, an e-mail will be sent to that address when the issue is selected. This option is available only for drop-down field issues.

• The **Entities** that you want the issue to be associated with.

• Additional fields may be available depending on the field type that you are working with:
  
  • For "Attachment - Record Association Type" issues, you can select an issue from the **Reciprocal** drop-down list to create a link between the two issues. When attaching an XFRACAS record to another XFRACAS record, if the selected relationship type has a reciprocal, then any reciprocal attachment created by the user will automatically be of that reciprocal type. For example, let’s say a user is working with incident E1-1 and wants to attach incident E1-17 as a superseding
incident. If the "superseding" issue is set up to have the "superseded" issue as its reciprocal and the user specifies a **Reciprocal Section**, then incident E1-17 will be attached to E1-1 as a superseding incident and E1-1 will be attached to E1-17 as a superseded incident.

- For issues associated with fields using drop-down lists, you can enter an **E-mail Address** for the issue. When the issue is selected, the e-mail address will receive an e-mail with a link, stating that the recipient should review the page.

- For tree issues, **Parent** allows you to change the parent of an issue, including the ability to make a child issue into a top-level issue or vice versa. This option is available only when you are editing an existing issue; the initial position of an issue is determined by whether you had an existing issue selected when adding it (in which case the new issue is added as a child issue) or not (in which case it is added as a top level issue).

**Save** saves the issue properties and closes the window. If you are editing a retired issue, this button will change to **Un-Retire**. Note that when you return to the Lists page, the issues for the list you have just saved will refresh, but the rest of the utility will not refresh.

### Managing Actions

The Action Management page allows you to maintain the action type categories that users can select from when they create actions.

To open the Action Management page, choose **Admin > Configure > Action Management**.

Action categories consist of a main category and a subcategory. The main category indicates the interface and/or section where the action is displayed. The Action Management page displays a separate bar for each of the main categories. Click a bar to hide or display the information for that category. You can also click the pushpin at the right end of a bar if you want to "lock" the bar so the information remains displayed while you click other bars. Click the pushpin again to remove the lock on the bar.

- Use the **Display** settings to specify whether the action category will be shown in the interface at all.

- To create a new subcategory, click the **Add** icon, `+`. The Action Type utility will appear, allowing you to specify the subcategory’s description, the order in which it will be displayed in the category list and the entity or entities where it will be available (based on the entities you have access to).
• To edit an existing subcategory, select the subcategory in the list and click the Edit icon. Changes that you make in the Action Type utility will apply to all records that have already been associated with that action subcategory. If you do not want the changes to apply to existing records, you can retire the existing subcategory and create a new subcategory with the new information.

• Select a subcategory and click the Delete icon, to delete the subcategory from the current entity. You will be prompted to confirm that you wish to delete the subcategory and then it will be deleted or retired. If the subcategory was never used in the system, it will be deleted from XFRACAS. If the subcategory was used in the system, then it will be retired. If a subcategory is retired, it will no longer be available to assign to an XFRACAS record for the current entity. However, it will continue to be associated with any existing records. In addition, if the sub-category is associated with any other entities, it will still be available for those entities.
Chapter 7: Managing Customers

Managing Contacts
The Contacts page allows you to view and maintain contact information for XFRACAS. Permissions required to access this page: Access Admin Tab and Manage Contacts.

If your XFRACAS website has more than one Entity, the same set of contacts will be available in all of them.

For Customer Support Information records, contacts are used to identify the primary contact to communicate with regarding the serialized system. They are also used to identify the field service tech who performed the installation/commissioning.

For Incidents, contacts are used to identify the field service tech who assisted with the resolution of the incident.

Contacts can also be used as Detail fields.

To open the Contacts page, choose Admin > Configure > Manage > Contacts.

Creating a New Contact
If the Contact drop-down list is blank, enter the required fields and choose Admin > Contacts > Create.

If you need to clear an existing contact before creating a new one, choose Admin > Contacts > New.

Editing a Contact
To edit a contact, choose the name from the Contact drop-down list. Make the desired changes and then choose Admin > Contacts > Save.
Chapter 7: Managing Customers

Deleting a Contact
To delete a contact that is not associated with any records, choose the name from the Contact drop-down list and then choose Admin > Contacts > Delete.

Alternatively, you can edit the contact record and clear all categories that are assigned to it. The contact will remain assigned to any existing records but will not be available to be assigned to new records.

Contact Properties
- Only the First Name and Last Name are required.
- Choose an existing Company from the list, or click the Add icon, , to create a new one. (See Managing Companies.)
- Choose an existing Location from the list, or click the Add icon, , to create a new one. (See Managing Locations.)
- Category:
  - **Unit Contact** - the contact can be assigned in the CSI page as the primary customer contact for a serialized system. The Associated Systems link opens a report of all records that the contact is assigned to.
  - **ASP Field Tech** - the contact can be assigned as the field technician in the CSI page or Incident page.

  For information about the External User option, please contact ReliaSoft technical support.

If the system administrator has configured additional fields to meet your organization's specific needs, they will be grouped together in a separate Contact Details area at the bottom of the page.

Managing Companies
The Companies page allows you to view and maintain company information in XFRACAS. Permissions required to access this page: Access Admin Tab and Manage Companies.

If your XFRACAS website has more than one Entity, the same set of companies will be available in all of them.

For Customer Support Information records, companies are used to identify the owner, the distributor and the authorized service provider who installed the serialized system.
Companies can also be used as Detail fields.

To open the Companies page, choose Admin > Configure > Manage > Companies.

**Creating a New Company**
If the Company drop-down list is blank, enter the required fields and choose Admin > Companies > Create.

If you need to clear an existing company before creating a new one, choose Admin > Companies > New.

**Editing a Company**
To edit an existing company, choose the name from the Company drop-down list. Make the desired changes and then choose Admin > Companies > Save.

**Deleting a Company**
To delete a company that is not associated with any records, choose the name from the Company drop-down list and then choose Admin > Companies > Delete.

Alternatively, you can edit the company record and clear all categories that are assigned to it. The company will remain assigned to any existing records but will not be available to be assigned to new records.

**Company Properties**
- Only the Name is required.
- Choose an existing Location from the list, or click the Add icon, +, to create a new one. (See Managing Locations.)
- Category:
  - Unit Owner - the company can be assigned on the CSI page as the owner of the unit.
Chapter 7: Managing Customers

- **ASP** - the company can be assigned on the CSI page as the authorized service provider who performed the installation/commissioning.

- **Distributor** - the company can be assigned on the CSI page as the distributor for the unit.

- If the company is a Distributor, then after you save the record you can specify the initial warranty duration that will be applied when you create a new CSI record for this distributor. By default, these will be set based on the **CSI - Warranty Months** preferences, but you can change the durations for a particular distributor.

  - **Warranty From Shipment** and **Initial Warranty Months** - the number of months from the date of shipment (if you select **To Distributor**) or from the date of delivery (if you select **To End User**).

  - **Warranty From Commission** - the number of months from the date of commissioning.

If the system administrator has configured additional fields to meet your organization's specific needs, they will be grouped together in a separate **Company Details** area.

If the company has contacts associated with it, they will be listed in the **Associated Contacts** area at the bottom of the page.

### Managing Locations

The Locations page allows you to manage location information in XFRACAS. Permissions required to access this page: Access Admin Tab and Manage Locations.

If your XFRACAS website has more than one **Entity**, the same set of locations will be available in all of them.

For Customer Support Information records, locations are used to record information about where the unit is located.

For Incidents, locations are used to record the location of the system at the time the incident occurred.

Locations can also be used as **Detail fields**.

To open the Locations page, choose **Admin > Configure > Manage > Locations**.
Creating a New Location
If the Location drop-down list is blank, enter the required fields and choose Admin > Locations > Create.

If you need to clear an existing location before creating a new one, choose Admin > Locations > New.

Editing a Location
To edit an existing location, choose the name from the Location drop-down list. Make the desired changes and then choose Admin > Locations > Save.

Deleting a Location
To delete a location that is not associated with any records, choose the name from the Location drop-down list and then choose Admin > Locations > Delete.

You cannot delete a location that is being used other records. You must first change those records and then delete the location.

Location Properties
• Only the Description is required.

If the system administrator has configured additional fields to meet your organization's specific needs, they will be grouped together in a separate Location Details area at the bottom of the page.
Chapter 8: Managing Entities

The Entities page allows you to manage the entities defined for your implementation. Permissions required to access this page: Access Admin Tab and Manage Entities.

To open the Entities page, choose Admin > Tools > Entities.

XFRACAS can be configured with a single entity (where all users share the same configuration settings and data) or with multiple entities (where each entity has its own separate permissions, settings and data. The system-wide preferences, companies, contacts and locations will be the same for all entities in the database. The user permissions, system templates, serialized systems, entity-specific preferences and configurable detail fields can be managed separately for each entity.

Your XFRACAS license determines the maximum number of active entities that can be defined for your implementation.

Adding or Editing an Entity

To add a new entity, choose Admin > Entities > Create.

In the properties window, enter the required fields (at least a long name and unique record prefixes) and click Save.

**IMPORTANT:** After you create a new entity, it can be made "inactive" but it cannot be deleted, and this could affect your ability to manage settings that are shared across multiple entities. It is recommended that you a) plan your entity configurations in advance, b) establish a "template" entity that defines settings that should be the same across all entities, and c) implement changes in a staging environment before moving to production.

To edit an existing entity, select the name and then choose Admin > Entities > Edit.

**Entity Properties**

- **Long Name** displays in the entity drop-down list at the top of many XFRACAS pages, and in other locations where the full entity name is used.
Chapter 8: Managing Entities

- **Record Prefix** for each record type. These prefixes will appear before record numbers in the entity (e.g., "ENT-I-" for incidents, "ENT-P-" for problems, etc). Record prefixes must be unique across entities in the same database and only one entity can be configured without prefixes.

  **IMPORTANT:** The prefix must not contain any of the following characters, : & = / ?

- **Parent Entity** (optional) allows you to display entities in a tiered structure in the entity drop-down list. The name of the parent will be appended to the entity's name in the drop-down list (e.g., "Parent - Child"). However, there is no implied inheritance for the data or settings. For example, if you search for incidents associated with the parent entity, results will not be returned for the child entity. Likewise, the configurable settings and permissions for the parent entity may not be consistent with the settings for the child entity.

- **Entity Status** sets whether the entity is **Active** (available for use) or **Inactive** (unavailable for use). If there is only one active entity in the system, you cannot make it inactive, so this field will be disabled.

  **Tip:** In addition to using the Inactive status to retire/hide an entity that is no longer in use, it can also be used to create a tiered structure in the entity drop-down list. For example, if you have an Automotive Power Train business unit with an Engine division and a Transmission division, you could set "Automotive Power Train" as the inactive parent to the active "Engine" and "Transmission" entities. The entity drop-down list would display the active entities as "Automotive Power Train - Engine" and "Automotive Power Train - Transmission."

### Duplication Settings

When you create a new entity (or when you change the status to "active" for an entity that was "inactive" upon creation), some basic required settings will always be copied from another entity.

- **Text Resources**
- **Preferences**
- **Detail** fields that are required (e.g., Incident Description, Problem Description, etc.)
  - If you select **Copy Detail Fields**, the rest of the configurable detail fields will also be copied.
- **Lists** associated with required fields (e.g., Incident State, Problem Priority, etc.)
  - If you select **Copy Lookup Lists**, the rest of the configurable lookup lists will also be copied.
- **Action Types**
- **Standard Reports and Charts**

In addition, you can also choose to:

- **Copy Criticality Fields** (See [Managing Criticality Fields](#))
- **Copy Users** (See [Managing Users](#))
- **Copy Security Groups** (See [Managing Security Groups](#))

For detail fields, lookup lists and action types, duplicated settings will be the same as the entity they were copied from unless you later remove the entity from each particular detail, list or type and replace it with something else. It is recommended that you establish a "template" entity that defines the settings that should be the same across all entities and use that template to copy settings for each new entity you create.

**Note:** Duplicating an entity can consume a large amount of database resources. When you are duplicating an entity, other users cannot access the Entities page; they will see a message stating that an entity is being duplicated.
Chapter 9: Administrator Reports

To access XFRACAS reports, choose **Home > View > Reports**.

In addition to the five types of tabular reports that may be available to non-administrative users of the system, administrator reports will be available to those users with administrative permissions. Click the icon associated with each report type to view a list of available reports of that type. In each list, you can click any report name to generate the report.

- **Watched Reports** are reports that you have selected as being of specific interest to you.
- **Standard Reports** are reports that are included by default with XFRACAS.
- **My Reports** are reports that you have customized via the Report Builder and saved for your own personal use.
- **Public Reports** are reports that have been customized via the Report Builder and saved for all users to use.
- **Custom Reports** are reports that have been created by ReliaSoft for use in the current entity.
- **Administrator Reports** relate to the management tools available in the XFRACAS administrative interface.

For more information about using reports, refer to the **Reports** topic in the User Help file.

Managing Reports

The Report Viewer page allows you to control the display of the standard reports, chart reports, custom reports and **administrator reports**. Permissions required to access this page: Access Admin Tab and Manage Report Viewer.

To open the Report Viewer page, choose **Admin > Tools > Report Viewer**.

For each category of reports in the ReportViewer, specify the display order for the reports. The reports will be displayed in the following arrangement:

1 2
Chapter 9: Administrator Reports

3  4
5  ...

Note that skipped numbers do not leave a space in the interface. For example, if you do not have a report with a display order of 3, the ordered reports will be displayed as follows:

1  2
4  5
6  ...

To hide a report from its list, leave the display order blank.

The numbers in parentheses after the report names are the query IDs.

To save the changes you have made on the Report Viewer page, choose Admin > Report Viewer > Save.
Chapter 10: Imports/Exports

XFRACAS offers several ways to import and export XFRACAS records (e.g., incidents, system configurations, etc.) via *.xml or *.xlsx templates.

- Use the Data Import page to view and manage the import queue, the log of processed files and the log of files that could not be processed.
- Use the optional XFRACAS Data Import Utility (DIU) Windows service (running on the web server) to process the import queue on a scheduled basis.
- Use the optional XFRACAS Web Service in your own custom application to insert XML files into the import queue or insert time/usage reports for serialized systems.

If you are using ReliaSoft Xfmea, RCM++ or RBI for failure modes and effects analysis, you also have the option to import and/or synchronize system templates and failure modes. (See Importing Systems from Xfmea.)

Note that you can also use the Synthesis Data Warehouse (SDW) in Weibull++, ALTA or RGA to extract data from XFRACAS to build data sets for life data analysis or repairable system/reliability growth analysis. (See Synthesis Data Warehouse in the Weibull++/ALTA documentation.)

Data Import Page

The Data Import page allows you to import and export XFRACAS records (e.g., incidents, system configurations, etc.) using *.xml or *.xlsx templates. This page can be used in conjunction with the optional XFRACAS DIU (Windows service) and/or the XFRACAS Web Service, if applicable. Permissions required to access this page: Access Admin Tab and Manage Import.

To open the Data Import page, choose Admin > Tools > Import.

If your implementation has more than one Entity, import schedules and logs are mapped separately for each. The drop-down list at the top of the page determines which entity's import details are currently displayed.

XML and XLSX Templates

XFRACAS provides an XML Document Type Definition (DTD) for each type of record you can import or export. These are installed in the "DTD" folder on the web server (e.g., C:\inetpub\wwwroot\XFRACAS\DTD\). For descriptions of the XML elements and attributes, see XFRACAS XML Import Business Logic (*.pdf).
Tip: The Data Import Page topic in the XFRACAS Admin help file provides templates and examples for common import scenarios. You may be able to save time by downloading and adapting these files to import your own data.

You also have the option to import some record types from Excel.

IMPORTANT: In order to use Excel templates, the web server must be configured to recognize the *.xlsx file type. For details, please consult the XFRACAS Implementation Guide (*.pdf).

Adding Files to Import

1. Choose Admin > Import > Add.

2. In the Add Import File utility, select the import type and browse for the file.

3. Click Add to add the file to the import queue.

Note: If the imported *.xml file contains an entity display ID that already exists in the XFRACAS database (i.e., the record number, such as E1-1), the record will not be imported.

Processing Files in the Inbox

The Inbox shows all of the import tasks that are currently in the queue to be imported. Each task is an *.xml or *.xlsx file that contains data you wish to import.

If you have the "Access Import Processing" permission, you can process the Inbox immediately. Click Admin > Import > Process.

Alternatively:

- If the DIU Service is running on the web server, the service will attempt to process the file(s) at the date/time specified in the Import Schedule for the relevant data type.

- If you have created your own custom application using the Web Service, it includes a function to immediately process all files in the import queue.

The Processed area shows the import tasks that have been completed successfully, while the Error area shows the files that could not be processed. The DIU Log shows all actions performed by the DIU Service (including e-mail notifications that are triggered based on calendar date).
Chapter 10: Imports/Exports

Exporting to XML

If you have the "Access Data Export" permission, the easiest way to export a single record to XML is to open the record and click the Export command in the ribbon.

Alternatively, if you know the record ID(s), you can use the utility in the Data Import page.

1. Choose Admin > Import > Export.

2. In the Export File utility, choose the export type and specify the ID(s) to export in the ID field. This can be a single ID or a comma-delimited list.

Depending on the record type, you will need to enter either the entity display ID (i.e., the record number that is visible in XFRACAS) or the database ID (obtained from the database table).

<table>
<thead>
<tr>
<th>Export Type</th>
<th>ID to Enter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Address (i.e., location)</td>
<td>Database ID</td>
</tr>
<tr>
<td>Company</td>
<td>Database ID</td>
</tr>
<tr>
<td>Failure analysis</td>
<td>Entity display ID</td>
</tr>
<tr>
<td>Incident</td>
<td>Entity display ID</td>
</tr>
<tr>
<td>Issue</td>
<td>Database ID of the list issue type</td>
</tr>
<tr>
<td>Master BOM</td>
<td>Part ID</td>
</tr>
<tr>
<td>Problem</td>
<td>Entity display ID</td>
</tr>
<tr>
<td>Project</td>
<td>Entity display ID</td>
</tr>
<tr>
<td>System</td>
<td>HID</td>
</tr>
<tr>
<td>Unit Commissioning (i.e., CSI)</td>
<td>Entity display ID</td>
</tr>
<tr>
<td>User</td>
<td>Database ID</td>
</tr>
</tbody>
</table>
Chapter 10: Imports/Exports

3. Click Export.

DIU Service
The XFRACAS Data Import Utility (DIU) is a Windows service that must run on the web server in order to use any of the following features:

- Process files in the import queue, based on the schedule specified on the Data Import page.
- Trigger e-mail notifications based on calendar date (e.g., E-mail - Incident Action Due Date, etc.).

For instructions to start the DIU service, please consult the XFRACAS Implementation Guide (*.pdf).

The current status of the DIU service will be displayed at the top of the Data Import page. This page also displays a log of actions performed by the service (DIU Log).

**IMPORTANT:** If you have a load balanced environment with multiple web servers, the DIU service should run on only one of the servers.

Web Service
If you have some basic programming knowledge, you can use the XFRACAS web service in your own custom application to insert XML files into the import queue or insert time/usage reports for serialized systems.

**Tip:** The Web Service topic in the XFRACAS Admin help file enables you to download a sample application that demonstrates the basic process for using the web service.

Using the Service
On the web server, IIS must be configured with HTTP Activation enabled for the .NET Framework. (See XFRACAS Implementation Guide (*.pdf).

The following functions are available. For parameters and code examples, see XFRACAS XML Import Business Logic (*.pdf) and the sample application.

- **ImportXML** - Inserts an XML file into the XFRACAS import queue. This is equivalent to clicking Add via the website. Note that:
  - The web service can insert any of the XML file types that can be uploaded manually via the Data Import page in the XFRACAS website, such as Incident (xml) or Master BOM (xml), etc.
• The web service cannot be used to insert XLSX files into the import queue.

• **ProcessImports** - Immediately begins processing of all files in the import queue for all entities. This is equivalent to clicking **Process** via the website. To view the processing status of the files, check the **Processed** and **Error** logs on the website.

*Note:* In Version 11, the ProcessImports function does not have a parameter for entity ID. If your implementation has more than one entities, it will process the queue for the entity that is currently set as the default for the user that the application is running as. You can change the user’s default entity at any time via the XFRACAS website. Alternatively, you can process the import queue by manually clicking the **Process** command in the website or by configuring the [XFRACAS DIU](#) to process the queue for each entity on a scheduled basis.

---

**Importing Systems from Xfmea**

To import data from Xfmea, choose **System > Template > Xfmea Import**.

*Note:* These instructions refer to Xfmea, but they also apply to RCM++ and RBI.

XFRACAS data is stored in a set of tables within a Synthesis enterprise database. All projects that you have access to within the current database will be shown in the **Project** drop-down list in the Xfmea Import utility. Choose the project that you want to import from, and the system within that project.

If you want to import the failure modes from Xfmea, select the **Import failure modes with template** check box.

The system and all of its subsystems and/or components will be imported as a system template. If you have selected to import the failure modes, then for each imported item that has an associated FMEA, failures will be imported to XFRACAS as failure modes and causes as XFRACAS root causes.

A system can be re-imported from Xfmea to XFRACAS to create additional templates.

**Association with Xfmea**

Items imported from Xfmea maintain an association with the items within Xfmea. This relationship goes in one direction only-- changes made in Xfmea can be brought into XFRACAS, but changes made in XFRACAS cannot be brought into Xfmea. (If you want to maintain an association in the other direction instead, so that changes made in XFRACAS can be brought into Xfmea, you should import the data from XFRACAS into Xfmea. See **Import or Sync from XFRACAS** in the Xfmea/RCM++/RBI documentation.)
Chapter 10: Imports/Exports

Updating does not happen automatically. To update the data in XFRACAS with changes made to the system and/or associated FMEAs in Xfmea, select the part of interest and choose System > Part > Sync with Xfmea.

In the Xfmea Sync utility that appears, use the check boxes to specify exactly what you want to update:

- The currently selected part
- The failure modes/root causes associated with the currently selected part
- The subcomponents of the currently selected part
- The failure modes/root causes associated with the subcomponents

If you have made changes to the system template in XFRACAS and then you sync with Xfmea, the Xfmea values will override XFRACAS values (including failure modes/root causes) for parts that exist in both applications. Items and/or failure modes/root causes that exist only in XFRACAS and have no association with the FMEA will not be deleted or modified.

You can remove the association with the items within Xfmea by choosing System > Part > Remove Xfmea Association.
Chapter 11: Additional Tools

Diagnostics
The Diagnostics page provides an error log for the current entity. In general, this information is provided for use when contacting technical support.

To access the Diagnostics page, choose Admin > Tools > Diagnostics.

To export the error(s) to an Excel file, choose Admin > Diagnostics > Excel.

You can select the check box for any error(s) and choose Admin > Diagnostics > Delete to remove the error(s) from the log.

Resource Editor
The Resource Editor allows you to manage the XFRACAS resources (the text that appears in the XFRACAS interface). Permissions required to access this page: Access Admin Tab and Manage Resource Editor.

To access the Resource Editor page, choose Admin > Tools > Resource Editor.

To find resources in the current entity to work with, choose Admin > Resource Editor > Find.

In the Find utility that appears, you can search in a number of ways. You can use one or more of the following for any given search:

- Specify a range of resources to work with by numeric identifiers. To do this, enter a Start ID and an End ID. If you specify only a Start ID, all resources from that ID on will be displayed. Similarly, if you specify only an End ID, all resources up to and including that ID will be displayed.

- Search by Default Text, which is the text that will appear by default in the location(s) where the resource is used. Enter the desired text, and the resources that contain that string in their default text will be displayed.
Chapter 11: Additional Tools

- Search by **Display Text**, which is the text, if any, that has been entered to use instead of the default text each time the resource is used in the currently selected entity. Enter the desired text, and the resources that contain that string in their display text will be displayed.

- Search by **Location** in the interface where the resources are used.

- Specify the **Language** of the resources.

To edit a resource, click the **Edit** icon, associated with the resource. The Edit Resource utility that appears will display the resource ID and language in the caption bar at the top. The resource’s default text will be shown at the top of the utility, and the locations where the resource is used will be shown at the bottom of the utility. To change the text used in one or more entities, clear the **Use Default** check box and enter the desired text in the **Display Text** field. Select the entities where you want the changes to apply; you can select the **All Entities** check box if you want the new text used in all entities.

You can replace all occurrences of a text string with new text using the Find and Replace utility, accessed by choosing **Admin > Resource Editor > Replace**.

Enter the text to search for in the **Find What** field and the replacement text in the **Replace With** field. Specify the language in which you are making the replacement, then select the entities where you want the changes to apply; you can select the **All Entities** check box if you want the new text used in all entities. Click Preview to view the replacement in all of the affected resources. If you are satisfied, select the check box for each resource where you want to confirm the replacement and choose **Admin > Resource Editor > Save**.

Note that you can select or clear the check box in the header to select or clear the check boxes for all resources.

To return all resources in the current entity to the default text, choose **Admin > Resource Editor > Default All**.

You will be asked to specify the language in which to make the change and confirm that you want to proceed.
If you have made resource changes in the current database and need to implement those changes in another database, you can choose Admin > Resource Editor > Update Script to generate a SQL script that can be run against the other database.

In the Update Script utility that appears, use the Begin Date and End Date fields to specify the time period for which you want to include changes (e.g., include only changes made in the past month). Use the Entities field to specify the entities from which you want to take changes; you can select the All Entities check box to include changes from all entities that you have access to. When you click OK, the script will be generated and can be opened or saved.
End User License Agreement

Click Wrap Agreement at time of product installation

BY INSTALLING THIS SOFTWARE OR BY CLICKING THE “I ACCEPT” BUTTON AND ACCEPTING THIS LICENSE IN ACCORDANCE WITH SOFTWARE INSTALLATION AND LICENSE ACCEPTANCE PROCEDURE YOU AGREE TO THE TERMS OF THIS LICENSE WHICH WILL BIND YOU, THE COMPANY ON WHO’S BEHALF YOU ARE ENTERING INTO THIS LICENSE AGREEMENT, AND ITS EMPLOYEES, AS APPLICABLE.

THIS LICENSE AGREEMENT IS A LEGAL AGREEMENT BETWEEN HBM UNITED KINGDOM LTD A COMPANY INCORPORATED IN UNITED KINGDOM WHOSE REGISTERED NUMBER IS 1589921 AND WHOSE REGISTERED OFFICE IS AT TECHNOLOGY CENTRE, ADVANCED MANUFACTURING PARK, BRUNEL WAY, CATCLIFFE, ROTHERHAM S60 5WG (THE ‘LICENSOR’) AND THE END USER LICENSEE OR ITS REPRESENTATIVE/AGENT AUTHORISED TO BIND THE END USER LICENSEE (‘YOU’).

PLEASE READ THIS CAREFULLY BEFORE USING THE SOFTWARE PRODUCTS

A: BACKGROUND

THIS LICENSE AGREEMENT SHALL BE BETWEEN YOU AND THE LICENSOR REGARDLESS OF WHETHER YOU HAVE PURCHASED THE SOFTWARE PRODUCTS DIRECTLY FROM THE LICENSOR OR AN AUTHORISED RESELLER AS SET OUT BELOW.

THE LICENSOR APPOINTS EXPERIENCED PROVIDERS OF SOFTWARE RESALE SERVICES WHO DISTRIBUTE THE SOFTWARE PRODUCTS TO END USERS (‘AUTHORISED RESELLER’). IF YOU HAVE PURCHASED THE SOFTWARE PRODUCTS AND ANY ASSOCIATED SUPPORT AND MAINTENANCE SERVICES FROM AN AUTHORISED RESELLER, SUCH PRODUCTS AND SERVICES WILL BE PROVIDED DIRECTLY TO YOU BY THE RELEVANT AUTHORISED RESELLER AND ALL PAYMENTS SHALL BE MADE TO THE AUTHORISED RESELLER ON THE AUTHORISED RESELLER’S TERMS AND PRICES.

IF YOU HAVE PURCHASED THE SOFTWARE PRODUCT AND SUPPORT AND MAINTENANCE SERVICES DIRECTLY FROM THE LICENSOR, SUCH SUPPORT AND MAINTENANCE SERVICES WILL BE DEALT WITH IN A SEPARATE AGREEMENT BETWEEN YOU AND THE LICENSOR AND ALL PAYMENTS WILL BE MADE TO THE LICENSOR AND GOVERNED BY THE LICENSOR’S TERMS OF SALE.

B: PROPERTY OF LICENSOR

THE LICENSOR, OR, WHERE APPLICABLE, THE RELEVANT MEMBER OF THE LICENSOR’S CORPORATE GROUP, IS THE ENTIRE LEGAL AND BENEFICIAL OWNER OF CERTAIN SOFTWARE PRODUCT(S) (‘THE SOFTWARE PRODUCT’) AS SET OUT IN THE QUOTATION OF INFORMATION, WHICH SHALL ALSO INCLUDE YOUR LICENSE KEY, SENT TO YOU BY EMAIL EITHER BY THE LICENSOR OR, IF YOU HAVE PURCHASED THE SOFTWARE PRODUCTS FROM AN AUTHORISED RESELLER, BY THE AUTHORISED RESELLER (‘QUOTATION’). THE LICENSOR IS WILLING TO GRANT YOU A LICENSE TO USE THE SOFTWARE PRODUCT ONLY IF YOU ACCEPT ALL THE TERMS AND CONDITIONS SET OUT BELOW.

C: LICENSE TO BE GRANTED

THE LICENSOR IS PROPOSING TO GRANT YOU ONE OF THE FOUR FORMS OF LICENSE IN RESPECT OF THE SOFTWARE PRODUCT. DETAILS OF EACH FORM OF LICENSE ARE SET OUT IN CLAUSES 2.1 AND 3 BELOW. THE FORM OF LICENSE THAT IS PROPOSED TO BE

D: LICENSE ACCEPTANCE PROCEDURE

BY CLICKING ON THE ACCEPTANCE BUTTON WHICH Follows THIS LICENSE AGREEMENT (MARKED ‘DO YOU ACCEPT THESE TERMS AND CONDITIONS?’), YOU INDICATE ACCEPTANCE OF THIS LICENSE AGREEMENT AND THE LIMITED WARRANTY AND LIMITATION OF LIABILITY SET OUT IN THIS LICENSE AGREEMENT. SUCH ACCEPTANCE IS ON YOUR OWN BEHALF, IF YOU ARE AN INDIVIDUAL AND ON BEHALF OF ANY CORPORATE ENTITY WHICH EMPLOYS YOU OR WHICH YOU REPRESENT (“CORPORATE LICENSEE”) IN ENTERING INTO THIS LICENSE AND YOU WARRANT THAT YOU HAVE THE NECESSARY AUTHORITY TO BIND THE CORPORATE ENTITY IN THIS RESPECT OR THAT THE AUTHORISED REPRESENTATIVES OF THE CORPORATE ENTITY ARE AWARE OF YOUR ACCEPTANCE OF THIS AGREEMENT ON ITS BEHALF. IN THIS LICENSE AGREEMENT, ‘YOU’ REFERS TO THE LICENSEE, ANY SUCH CORPORATE LICENSEE, OR BOTH, AS A COMMON SENSE INTERPRETATION OF THE RELEVANT SECTION DICTATES.

E: LICENSE REJECTION PROCEDURE

IF YOU DO NOT ACCEPT THESE TERMS AND CONDITIONS, YOU SHOULD CLICK ON THE “I DO NOT ACCEPT” BUTTON, DELETE THE SOFTWARE PRODUCTS FROM YOUR COMPUTER AND PROMPTLY (AND IN ANY EVENT, WITHIN 14 DAYS OF RECEIPT) RETURN TO THE RESELLER (A) ANY MEDIA; AND (B) ANY OTHER ITEMS PROVIDED, THAT ARE PART OF THIS PRODUCT.

F: OTHER AGREEMENTS

IF THE LICENSOR HAS EXPRESSLY AGREED WITH YOU IN WRITING THAT YOUR USE OF THE SOFTWARE PRODUCTS IS GOVERNED BY A PRIOR EXECUTED LICENSE AGREEMENT WITH THE LICENSOR, SUCH AGREEMENT SHALL APPLY INSTEAD OF THE FOLLOWING TERMS AND CONDITIONS TO THE EXTENT THAT THEY CONFLICT.

YOU SHOULD PRINT A COPY OF THIS LICENSE AGREEMENT FOR FUTURE REFERENCE.

LICENSE AGREEMENT

1. Ownership of Software Products and Copies

1.1 The Software Products and any printed materials or electronic documentation accompanying the Software Products (‘Documentation’) are copyrighted works of authorship, and are also protected under applicable database laws. The Licensor, or, where applicable, the relevant member of the Licensor’s corporate group, retains ownership of the Software Products and all subsequent copies of the Software Products, regardless of the form in which the copies may exist. This License Agreement is not a sale of the original Software Products or any copies.

2. Commercial License

2.1 In consideration of you agreeing to abide by the terms of this License Agreement and payment of the applicable license fees either to the Licensor or, if you have purchased the Software Products from an Authorised Reseller, to the Authorised Reseller (as specified in the Quotation), the Licensor hereby grants to you a personal, non-exclusive, and (unless expressly agreed otherwise by the Licensor in accordance with
clause 5.1) non-transferable license to use the Software Products and the Documentation on the terms of this License Agreement. The license shall take one of the following forms, (and shall be set out in the Quotation):

(a) **Annual License:**

(i) Duration – this License shall continue for a period of 12 months (‘Initial Period’) from the date of delivery of the Quotation (‘the Delivery Date’) and, provided that you have paid all applicable renewal fees, from year to year thereafter unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

(ii) Termination – you must give the Licensor 90 day’s written notice prior to the anniversary of the Delivery Date, such notice not to expire before such anniversary date.

(b) **Paid Up License:**

(i) Duration – this License shall continue for a period of 25 years from the Delivery Date unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

(ii) Conversion - this License may be converted to a CDS (this may include CRS and CDRS which are specific variations of CDS and collectively known as CDS) License, upon application to either the Licensor or the Authorised Reseller (if you have purchased the Software Products from an Authorised Reseller), and payment of an additional fee to the Licensor or the Authorised Reseller (as applicable), which shall be additional to the fees paid or payable in respect of any maintenance and support services provided by either the Licensor or the Authorised Reseller (if you have purchased the Software Products from an Authorised Reseller). You may reverse this conversion to the same terms as agreed in the Paid Up License at the anniversary of the conversion by giving the Licensor 90 days written notice prior to the anniversary of the Delivery Date, such notice not to expire before the anniversary of the Delivery Date.

(c) **CDS/CRS/CDRS License:**

(i) Access – subject to the terms and conditions of this License Agreement, you may access any of the Software Products in the Quotation at any one time and in any combination up to the number of subscriptions granting you access to the Software Products for simultaneous use by you and purchased by you pursuant to this Agreement (‘Access Credits’). In the event the number of Access Credits reaches the number of Access Credits duly paid for by you (‘Access Limit’), you may add additional Access Credits (or, alternatively, at any time during the Term) which shall be charged in accordance with either the Licensor’s prices or the Authorised Reseller’s prices (if you have purchased the Software Products from an Authorised Reseller). Such increase in Access Credits shall apply to the following 12 month period, unless you give the Licensor or the Authorised Reseller (as applicable) written notice at least 90 days in advance of the expiry of the Initial Period, that you do not wish to sustain such increase in Access Credits. You may opt to reduce the number of Access Credits with 90 days written notice in advance of the 12 month period following from the anniversary of the Delivery Date, provided that the total number of Access Credits does not fall below the minimum threshold set by the Licensor or the Authorised Reseller (as applicable) or below the initial number of Access Credits calculated at the time of conversion of any Paid Up License.

(ii) Duration - this License shall continue for the Initial Period and, provided that you have paid for the applicable Access Credits, from year to year thereafter unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

(iii) Reporting – in order to serve our customers better, the Licensor needs to be able to understand how its customers use the CDS system. As a condition of your continued access to the system, you are asked to provide to the Licensor on a quarterly basis, the CDS log file. You will be provided with easy-to-follow instructions on how to do this.
(iv) Termination – you must give the Licensor 90 days written notice in advance of the expiry of the Initial Period of your intention to discontinue the CDS License, such notice not to expire before the anniversary of the Delivery Date, and you must have submitted all reports required of you in clause 2.1(c)(iii) above. Failure to provide such notice and reports will mean that the license shall automatically continue on the same terms until terminated in accordance with this clause.

2.2 As an end user licensee of the Software Products, you may, subject to the following conditions and any conditions specified in the Quotation:

(a) use and copy the Software Products only for use on any computer system that is detailed in the release notes of the respective Software Product and which is licensed, leased and/or controlled by you (the Corporate Licensee) or any member of your corporate group, which expression includes the Corporate Licensee's majority-owned subsidiaries, any parent company having a majority-owned interest in the Corporate Licensee, and such parent's majority-owned subsidiaries;

(b) load the Software Products into and use it only on computers at the locations specified in the Quotation and which are under your control;

(c) copy the Software Products only for back-up and archival purposes and make up to three copies of the Documentation, provided that the original and each copy is kept in your possession and that your installation and use of the Software Products does not exceed any restrictions contained in the Quotation.

3. Demonstration License

3.1 If the Licensor has provided you with the Software Products free of charge for evaluation purposes, this clause 3 shall apply to your use of the Software Products.

3.2 You may use the Software Product on a computer solely for the purposes of evaluating the Software Product.

3.3 The Software Product is provided to you free of charge and on an “AS IS” basis, without any technical support or warranty of any kind from us including, without limitation, a warranty of satisfactory quality, fitness for purpose and non-infringement.

3.4 This License shall continue for a period of 30 days from the Delivery Date unless terminated in accordance with any provision of clause 10 below or any other applicable clause of this License Agreement or until such License is converted into an Annual License, Paid Up License or CDS License, if earlier.

3.5 As part of the Licensor’s testing and evaluation of the Software Products, you shall share with the Licensor the input and views received and any reports and analysis produced promptly upon receipt of such feedback.

3.6 Clauses 4, 5.1(a), 6.1(b), 6.1(f), 8.1, 8.2, 8.5, 10.1(a) of this License Agreement shall not apply to a Demonstration License.

4. Delivery and Risk

4.1 The Software Products shall consist of one copy of the object code of the Software Products on machine-readable form only, on the disk, dongle or other media on which the Software Product is delivered as described in the Quotation (the “Media”). Risk in the Media shall pass to you on delivery. If any part of the Media shall thereafter be lost, damaged or destroyed, you must contact either the Licensor or the Authorised Reseller from whom you have purchased the Software Products who will arrange for a repair or replacement of such Media at a cost (if any) determined by the Licensor or the Authorised Reseller (as applicable).

5. License Restrictions

5.1 You may not nor permit others to:

(a) transfer the Software Products from one location to another, without the express written consent of the Licensor and provided such transfers do not exceed two in any twelve month period. It will be a condition of the grant of any such consent that the Software Products held on hard drives at the current location must be erased and you must enter into a new license agreement with the Licensor before a
Software Products license key is provided to you. The administration charge (currently US $1,500) will be payable by you in respect of such transfer. This charge is only applicable to end user licensees who do not have a support and maintenance services agreement with the Licensor or Authorised Reseller;

(b) exceed the number of concurrent users specified in the Quotation, if any;
(c) sub-license, sell, assign, rent, pledge, lease, transfer or otherwise dispose of the Software Products, on a temporary or permanent basis, without the prior written consent of the Licensor;
(d) translate, reverse engineer, decompile, disassemble, modify or create derivative works based on the Software Products except as permitted by law;
(e) make copies of the Software Products, in whole or part, except for back-up or archival purposes as permitted in this License Agreement;
(f) use any back-up copy of the Software Products for any purpose other than to replace the original copy in the event that it is destroyed or becomes defective;
(g) copy the Documentation (except as provided by this License Agreement);
(h) adapt, modify, delete or translate the Documentation in any way for any purpose whatsoever;
(i) vary, delete or obscure any notices of proprietary rights or any product identification or restrictions on or in the Software Products.

6. Undertakings

6.1 You undertake:
(a) to ensure that, prior to use of the Software Products by your employees or agents, all such parties are notified of this License and the terms of this License Agreement and that any such use as aforesaid is in accordance with the terms of this License Agreement;
(b) to replace the current version of the Software Product with any updated or upgraded version or new release provided by the Licensor or the Authorised Reseller (if applicable) under the terms of this License Agreement immediately on receipt of such version or release;
(c) to use the Software Products only as described in the Documentation and subject to the restrictions as set out in clause 5 (License Restrictions above);
(d) to reproduce and include the Licensor’s copyright notice (or such other party’s copyright notice as specified on the Software Products) on all and any copies of the Software Products, including any partial copies of the Software Products as permitted to be made under the terms of this License Agreement;
(e) to hold all drawings, specifications, data (including object and source codes), Software Products listings and all other information relating to the Software Products confidential and not at any time, during this License or after its expiry, disclose the same, whether directly or indirectly, to any third party without the Licensor’s consent, and
(f) to effect and maintain adequate security measures to safeguard the Software Product from access or use by any unauthorised person and indemnify the Licensor for losses flowing from your failure to do so.

7. Intellectual Property Rights

7.1 You acknowledge that all intellectual property rights in the Software Product and the Documentation throughout the world belong to the Licensor, that rights in the Software Product are licensed (not sold) to you, and that you have no rights in, or to, the Software Product or the Documentation other than the right to use them in accordance with the terms of this License Agreement.

7.2 You acknowledge that you have no right to have access to the Software Product in source code form or in unlocked coding or with comments.
7.3 The integrity of this Software Product is protected by technical protection measures ("TPM") so that the intellectual property rights, including copyright, in the software of the Licensor are not misappropriated. You must not attempt in any way to remove or circumvent any such TPM, nor to apply, manufacture for sale, hire, import, distribute, sell, nor let, offer, advertise or expose for sale or hire, nor have in your possession for private or commercial purposes, any means whose sole intended purpose is to facilitate the unauthorised removal or circumvention of such TPM.

8. Limited Warranty

8.1 Subject to the limitations and exclusions of liability below and providing the Software is used in accordance with the Documentation and on an operating system or computer for which it was designed, the Licensor warrants that (a) the Media on which the Software Products is furnished will be free from material defects under normal use for a period of 90 days from the date of delivery (the "Warranty Period"); and that (b) during the Warranty Period, the Software Product will, when properly used, perform substantially in accordance with the functions described in the Documentation; and (c) that the Documentation correctly describes the operation of the Software Product in all material respects.

8.2 If, within the Warranty Period, you notify the Licensor in writing of any defect or fault in the Software Product in consequence of which it fails to perform substantially in accordance with the Documentation, and such defect or fault does not result from you having amended the Software Product or used it in contravention of the terms of this License Agreement, the Licensor will, at its sole option, i) repair or replace the Software Product, provided that you make available all information that may be necessary to assist the Licensor in resolving the defect or fault, including sufficient information to enable the Licensor to recreate the defect or fault, or ii) terminate this License Agreement immediately by notice in writing to you and the Licensor will refund or if the Software Products have been purchased from an Authorised Reseller will procure that the Authorised Reseller shall refund; any of the fees paid as at the date of termination (less a reasonable sum in respect of your use of the Software Product to the date of termination) on return of the Software Product and all copies thereof. The Licensor's obligation under this clause 8.2 is subject to your compliance with clause 6.1(b).

8.3 You acknowledge that the Software Product has not been developed to meet your individual requirements and that it is therefore your responsibility to ensure that the facilities and functions of the Software Product as described in the Documentation meet your requirements.

8.4 You acknowledge that the Software Product may not be free of bugs or errors and you agree that the existence of any minor errors shall not constitute a breach of this License Agreement.

8.5 The Licensor shall not be liable under the said warranty above if the Software Product fails to operate in accordance with the said warranty as a result of any modification, variation or addition to the Software Products not performed by the Licensor or caused by any abuse, corruption or incorrect use of the Software Products, including use of the Software Products with equipment or other software which is incompatible.

8.6 All other conditions, warranties or other terms which might have effect or be implied or incorporated into this License Agreement or any collateral contract, whether by statute, common law or otherwise, are hereby excluded, including, without limitation, the implied conditions, warranties or other terms as to satisfactory quality, fitness for purpose or the use of reasonable skill and care.

9. Exclusion of Liability

9.1 Nothing in this License Agreement shall limit or exclude the liability of either party for death or personal injury resulting from negligence, for fraud or for fraudulent misrepresentation.

9.2 Subject to clause 9.1, the Licensor shall have no liability for any losses or damages which may be suffered by you (or any person claiming under or through you), whether the same are suffered directly or indirectly or are immediate or consequential, and whether the same arise in contract, tort (including negligence) or otherwise howsoever, which fall within any of the following:

(a) loss of income;

(b) loss of business profits or contracts;
(c) business interruption;
(d) loss of the use of money or anticipated savings;
(e) loss of information;
(f) loss of opportunity, goodwill or reputation;
(g) loss of, damage to or corruption of data; or
(h) any indirect or consequential loss or damage of any kind howsoever arising and whether caused by tort
(including negligence), breach of contract or otherwise;

provided that this clause 9.2 shall not prevent claims for loss of or damage to your tangible property that fall
within the terms of clause 8 or a claim for a refund of the license fees paid to the Licensor or the Authorised
Reseller (as applicable) for the license of the Software Products.

9.3 Subject to clause 9.1 and clause 9.2, the Licensor's maximum aggregate liability under or in connection with
this License Agreement, or any collateral contract, whether in contract, tort (including negligence) or
otherwise, shall be limited to a sum equal to the fees paid by you to the Licensor or the Authorised Reseller
(as applicable) for the license of the Software Products.

9.4 Subject to clause 9.1, clause 9.2 and clause 9.3, the Licensor's liability for infringement of third party
intellectual property rights shall be limited to breaches of third party rights subsisting in the UK and USA.

9.5 This License Agreement sets out the full extent of the Licensor's obligations and liabilities in respect of the
supply of the Software Products and Documentation. In particular, there are no conditions, warranties,
representations or other terms, express or implied, that are binding on the Licensor except as specifically
stated in this License Agreement. Any condition, warranty, representation or other term concerning the
supply of the Software Products and Documentation which might otherwise be implied into, or incorporated
in, this License Agreement, or any collateral contract, whether by statute, common law or otherwise, is
hereby excluded to the fullest extent permitted by law.

10. Term and Termination

10.1 This License Agreement is effective for the period referred to clause 2.1 or until otherwise terminated in
accordance with that clause. The Licensor may terminate this License Agreement immediately by written
notice to you if:

(a) save in respect of a Paid Up License, if you purchase the Software Products directly from the Licensor,
you fail to pay any renewal or other fees due by you to the Licensor in respect of this License
Agreement;

(b) you fail to comply with any provisions of this License Agreement;

(c) you commit a material or persistent breach of this License Agreement which you fail to remedy (if
remediable) within 14 days after the service on you of written notice requiring you to do so; or

(d) a petition for a bankruptcy order to be made against you has been presented to the court; or

(e) where you, as the Corporate Licensee, become insolvent or unable to pay its (the company’s) debts,
enters into liquidation, whether voluntary or compulsory (other than for reasons of bona fide
amalgamation or reconstruction), passes a resolution for its winding-up, has a receiver or administrator
manager, trustee, liquidator or similar officer appointed over the whole or any part of its assets, makes
any composition or arrangement with its creditors or takes or suffers any similar action in consequence
of its debt, or becomes unable to pay its debts or ceases to trade.

10.2 In the event of termination in accordance with clause 10.1 you must immediately pay to the Licensor any
sums due to the Licensor under the License Agreement and (at the Licensor’s sole option) you must return,
destroy or delete all copies of the Software Products from all storage media in your control and, in the case of
destruction, certify to us that you have done so.
11. **Export**

11.1 You will comply with all applicable laws, rules, and regulations governing export of goods and information, including the laws of the countries in which the Software Products was created. In particular, you will not export or re-export, directly or indirectly, separately or as a part of a system, the Software Products or other information relating thereto to any country for which an export license or other approval is required, without first obtaining such license or other approval.

12. **General**

12.1 You agree that the Licensor shall have the right, after supplying undertakings as to confidentiality, to audit any computer system on which the Software Products are installed in order to verify compliance with this License Agreement.

12.2 You agree that the Licensor may use your company name in Licensor’s customer lists and other promotional materials describing your company as a customer or user of Licensor’s software or services, as applicable, unless it receives written notice from you objecting to such use.

12.3 This License Agreement, its subject matter or its formation (including non-contractual disputes or claims) shall be governed by and construed in accordance with English law and submitted to the non-exclusive jurisdiction of the English courts.

12.4 This License Agreement constitutes the complete and exclusive statement of the agreement between the Licensor and you with respect to the subject matter of this License and supersedes all proposals, representations, understandings and prior agreements, whether oral or written, and all other communications between us relating to that subject matter except for those expressly referred to in this License Agreement.

12.5 Any clause in this License Agreement that is found to be invalid or unenforceable shall be deemed deleted and the remainder of this License Agreement shall not be affected by that deletion.

12.6 Failure or neglect by either party to exercise any of its rights or remedies under this License Agreement will not be construed as a waiver of that party’s rights nor in any way affect the validity of the whole or part of this License Agreement nor prejudice that party’s right to take subsequent action.

12.7 This License Agreement is personal to you and you may not assign, transfer, sub-contract or otherwise part with this License or any right or obligation under it without the Licensor’s prior written consent.