This license agreement ("License Agreement") sets forth the terms and conditions that govern the distribution and use of the HBM UK Ltd software documentation (the "HBM Software Documentation"), including any and all derivative works. Any unauthorized distribution or use of the HBM Software Documentation is strictly prohibited.

Licensee hereby acknowledges and agrees to the following terms and conditions of this License Agreement for its use of the HBM Software Documentation:

HBM UK Ltd grants the Licensee who accepts and abides by the terms of this License Agreement a non-exclusive, non-transferable, royalty-free, and revocable license to the HBM Software Documentation. Unless otherwise indicated, all HBM Software Documentation are copyrighted and owned by HBM UK Ltd and are the property of HBM UK Ltd. They are licensed to you and for your use only as an individual who has purchased the software ("Licensee"). Notwithstanding this License Agreement, the Licensee shall not have a license to the trademarks, logos, or any other intellectual property of HBM UK Ltd and/or its affiliates or Licensor(s).

Licensee may print a single copy of the HBM Software Documentation for his/her reference. Licensee may reprint the HBM Software Documentation, as needed, if the original printed copy is damaged and/or destroyed.

Except as provided above, no part of the HBM Software Documentation, either text or image, may be used for any purpose other than Licensee's own personal use and reference as a learning aid. Therefore, the reproduction, modification, creation of derivative works, storage in a retrieval system, or retransmission, in any form or by any means, electronic, mechanical or otherwise, for reasons other than Licensee's personal use, is strictly prohibited.

Certain photos and images in the HBM Software Documentation are used under non-transferable licenses obtained by HBM UK Ltd and/or its affiliates and are owned by its Licensor(s) ("Licensor"). Images depicting photos of actual persons are licensed to HBM UK Ltd and/or its affiliates and the signed model releases for these images are on file with the Licensor(s). HBM UK Ltd makes no copyright claims on these images. All ownership and intellectual property rights to the HBM Software Documentation are reserved by either HBM UK Ltd and/or its affiliates or its Licensor(s).

DISCLAIMER: THE HBM SOFTWARE DOCUMENTATION IS PROVIDED "AS IS" WITHOUT WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO: 1) ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NONINFRINGEMENT OF INTELLECTUAL PROPERTY; 2) ANY WARRANTY THAT THE HBM COURSE MATERIALS WILL CONFORM TO SPECIFICATIONS; 3) ANY WARRANTY THAT THE WORK WILL BE ERROR FREE OR VIRUS FREE. IN NO EVENT SHALL HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSOR(S) BE LIABLE FOR ANY DAMAGES, INCLUDING, BUT NOT LIMITED TO, DIRECT, INDIRECT, SPECIAL OR CONSEQUENTIAL DAMAGES, ARISING OUT OF, RESULTING FROM, OR IN ANY WAY CONNECTED WITH THE HBM SOFTWARE DOCUMENTATION, WHETHER OR NOT BASED UPON WARRANTY, CONTRACT, TORT, OR OTHERWISE, WHETHER OR NOT LOSS WAS SUSTAINED FROM, OR AROSE OUT OF THE RESULTS OF, OR USE OF, THE HBM SOFTWARE DOCUMENTATION. LICENSEE AGREES TO WAIVE ANY AND ALL CLAIMS AGAINST HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSOR(S), AND SHALL INDEMNIFY, DEFEND AND HOLD HARMLESS HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSOR(S) FOR ANY AND ALL LIABILITIES, CLAIMS, DEMANDS, DAMAGES, EXPENSES OR LOSSES THAT MAY ARISE FROM THE LICENSEE’S USE OR DISTRIBUTION OF THE HBM SOFTWARE DOCUMENTATION, INCLUDING ANY LIABILITIES OR DAMAGES FROM DERIVATIVE WORKS OR OTHER PRODUCTS BASED ON, OR RESULTING FROM, THE USE THEREOF.

This License Agreement is subject to change without notice and does not represent any commitment on the part of HBM UK Ltd and/or its affiliates to the Licensee, including any commitment to maintain or update the HBM Software Documentation. The names of companies, products, people, characters, and/or data mentioned in the HBM Software Documentation are not intended to represent any real individual, company, product or event, unless otherwise noted. Any rights not expressly granted herein are reserved for HBM UK Ltd.

TRADEMARKS:
ReliaSoft, Synthesis Platform, Weibull++, ALTA, DOE++, RGA, BlockSim, RENO, Lambda Predict, Xfmea, RCM++ and XFRACAS are all trademarks of ReliaSoft Corporation.

GlyphWorks, VibeSys, DesignLife and the nCode logos are all trademarks of HBM UK Ltd.

Other product names and services identified in the HBM Software Documentation are trademarks belonging to their respective trademark holders, and are used for illustration purposes. Their use in no way conveys an endorsement or other affiliation with HBM UK Ltd and/or its affiliates.
# Table of Contents

Chapter 1: Getting Started .............................................................................................................. 1

Technical Support ....................................................................................................................... 1

   When Requesting Support .................................................................................................. 2

Reliability Consulting ................................................................................................................. 2

Install and License ...................................................................................................................... 3

   System Requirements ....................................................................................................... 3

   Installation and Licensing ................................................................................................. 4

   License Manager ............................................................................................................... 8

   Borrowing Licenses .......................................................................................................... 9

Chapter 2: Repositories and Projects ........................................................................................... 13

Synthesis Repositories .............................................................................................................. 13

   Database Types ............................................................................................................... 13

   Standard Repositories ................................................................................................... 14

   Synthesis Files ................................................................................................................. 15

   Enterprise Repositories ................................................................................................. 16

Projects ..................................................................................................................................... 27

   Creating and Managing Projects ................................................................................... 27

   Project Properties ........................................................................................................... 29

   Project Owner .................................................................................................................. 32

   Public, Private and Reference Projects .......................................................................... 33

   Locked and Unlocked Projects ....................................................................................... 35

   Check In and Check Out Projects .................................................................................. 36

   Manage Projects Window ............................................................................................... 38

   Recycle Bin ...................................................................................................................... 40

   Security ............................................................................................................................ 41
## Contents

- Applying Login Security ................................................................. 41
- Planning Your Security Approach .................................................... 42
- User Accounts ................................................................................. 48
- Managing Security Groups ............................................................... 55
- Associating Security Groups with Active Directory ....................... 64
- Setting Item Permissions ................................................................. 66
- Status Indicators ............................................................................. 67
- Reset "In Use" Flags .......................................................................... 69
- Repository Logins ............................................................................ 70
- Repository Settings ......................................................................... 70
- E-mail Settings Page ........................................................................ 71
- Other Settings Page .......................................................................... 71
- Unit Settings .................................................................................... 71
- Default Name Formats ...................................................................... 73
- Project Planning Resources ............................................................... 75
- Working Days/Holidays ................................................................. 76
- XFRACAS Connection ..................................................................... 77
- Managing and Restoring Data ......................................................... 78
- Enterprise Database Maintenance .................................................... 78
- Standard Database Maintenance .................................................... 79
- Restore Points .................................................................................. 81
- Chapter 3: Desktop Application Interfaces ....................................... 83
- Ribbon and Backstage View ............................................................ 83
- Project Manager and My Portal ...................................................... 83
- Status Bar ....................................................................................... 84
- Show, Tile, Dock and Pin Panels ..................................................... 84
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show or Hide</td>
<td>84</td>
</tr>
<tr>
<td>Tile or View One Page at a Time</td>
<td>84</td>
</tr>
<tr>
<td>Dock or Float</td>
<td>86</td>
</tr>
<tr>
<td>Pinned or Unpinned</td>
<td>88</td>
</tr>
<tr>
<td>Project Manager</td>
<td>89</td>
</tr>
<tr>
<td>Opening a Project</td>
<td>89</td>
</tr>
<tr>
<td>Filtering the List of Projects</td>
<td>89</td>
</tr>
<tr>
<td>Searching for a Particular Project</td>
<td>90</td>
</tr>
<tr>
<td>Current Project Explorer</td>
<td>90</td>
</tr>
<tr>
<td>Working with Multiple Projects</td>
<td>92</td>
</tr>
<tr>
<td>My Portal</td>
<td>93</td>
</tr>
<tr>
<td>Portal Messages</td>
<td>94</td>
</tr>
<tr>
<td>Actions in My Portal</td>
<td>95</td>
</tr>
<tr>
<td>Repository Users List</td>
<td>98</td>
</tr>
<tr>
<td>Project Plan Summary in My Portal</td>
<td>99</td>
</tr>
<tr>
<td>Folios</td>
<td>101</td>
</tr>
<tr>
<td>Data Sheets</td>
<td>101</td>
</tr>
<tr>
<td>Change Units</td>
<td>104</td>
</tr>
<tr>
<td>General Spreadsheets</td>
<td>105</td>
</tr>
<tr>
<td>Control Panels</td>
<td>107</td>
</tr>
<tr>
<td>Switching Between Pages</td>
<td>108</td>
</tr>
<tr>
<td>Hiding or Displaying a Control Panel</td>
<td>108</td>
</tr>
<tr>
<td>Identifiers Page</td>
<td>109</td>
</tr>
<tr>
<td>Publishing Page</td>
<td>109</td>
</tr>
<tr>
<td>Notifications Page</td>
<td>110</td>
</tr>
<tr>
<td>Utilized Resources Page</td>
<td>110</td>
</tr>
<tr>
<td>Contents</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>System Panel and Analysis Panel</td>
<td>111</td>
</tr>
<tr>
<td>Change Orientation</td>
<td>111</td>
</tr>
<tr>
<td>Resize a Panel</td>
<td>111</td>
</tr>
<tr>
<td>Hide a Panel</td>
<td>112</td>
</tr>
<tr>
<td>Expand or Collapse Nodes</td>
<td>112</td>
</tr>
<tr>
<td>Selecting Which Columns to Display</td>
<td>113</td>
</tr>
<tr>
<td>Printing</td>
<td>113</td>
</tr>
<tr>
<td>Data Sheets and Diagrams</td>
<td>113</td>
</tr>
<tr>
<td>Plots</td>
<td>113</td>
</tr>
<tr>
<td>Synthesis Workbooks</td>
<td>113</td>
</tr>
<tr>
<td>Reports Generated in Word or Excel</td>
<td>113</td>
</tr>
<tr>
<td>Other Features</td>
<td>113</td>
</tr>
<tr>
<td>Page Setup - Plots and Diagrams</td>
<td>114</td>
</tr>
<tr>
<td>Page Setup - Data Sheets</td>
<td>115</td>
</tr>
<tr>
<td>Page Setup - Word Processing Module</td>
<td>118</td>
</tr>
<tr>
<td>Chapter 4: Lambda Predict Ribbon</td>
<td>121</td>
</tr>
<tr>
<td>Quick Access Toolbar</td>
<td>121</td>
</tr>
<tr>
<td>Backstage View (File Tab)</td>
<td>122</td>
</tr>
<tr>
<td>Manage Repository</td>
<td>123</td>
</tr>
<tr>
<td>Help Center</td>
<td>125</td>
</tr>
<tr>
<td>Home Tab</td>
<td>127</td>
</tr>
<tr>
<td>Clipboard</td>
<td>127</td>
</tr>
<tr>
<td>Templates</td>
<td>127</td>
</tr>
<tr>
<td>Insert</td>
<td>127</td>
</tr>
<tr>
<td>Hierarchy</td>
<td>127</td>
</tr>
<tr>
<td>Synthesis</td>
<td>128</td>
</tr>
<tr>
<td>Contents</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>My Portal Tab</td>
<td>128</td>
</tr>
<tr>
<td>Messages</td>
<td>128</td>
</tr>
<tr>
<td>Actions</td>
<td>129</td>
</tr>
<tr>
<td>Users</td>
<td>129</td>
</tr>
<tr>
<td>Project Tab</td>
<td>129</td>
</tr>
<tr>
<td>Management</td>
<td>130</td>
</tr>
<tr>
<td>E-mail Project</td>
<td>131</td>
</tr>
<tr>
<td>Security</td>
<td>132</td>
</tr>
<tr>
<td>Current Item</td>
<td>132</td>
</tr>
<tr>
<td>Data Management</td>
<td>133</td>
</tr>
<tr>
<td>Reports</td>
<td>133</td>
</tr>
<tr>
<td>View Tab</td>
<td>134</td>
</tr>
<tr>
<td>Refresh</td>
<td>134</td>
</tr>
<tr>
<td>Project Manager</td>
<td>134</td>
</tr>
<tr>
<td>My Portal</td>
<td>134</td>
</tr>
<tr>
<td>Workspace Layout</td>
<td>134</td>
</tr>
<tr>
<td>Expand/Collapse</td>
<td>135</td>
</tr>
<tr>
<td>Zoom</td>
<td>136</td>
</tr>
<tr>
<td>Window</td>
<td>136</td>
</tr>
<tr>
<td>FMRA</td>
<td>136</td>
</tr>
<tr>
<td>Show</td>
<td>137</td>
</tr>
<tr>
<td>Active Tabs</td>
<td>137</td>
</tr>
<tr>
<td>System Hierarchy Tab</td>
<td>137</td>
</tr>
<tr>
<td>Prediction Tab</td>
<td>139</td>
</tr>
<tr>
<td>Prediction Tools Tab</td>
<td>140</td>
</tr>
<tr>
<td>Chapter 5: Prediction Folios</td>
<td>143</td>
</tr>
</tbody>
</table>
Contents

Creating a Prediction Folio................................................................. 143
Building a System Configuration...................................................... 143
Adding Standard Items ................................................................. 144
Adding Blocks and Components .................................................... 145
Changing the Component Type ....................................................... 146
Deleting Items .............................................................................. 146
Moving Items ................................................................................ 146
Cutting/Copying and Pasting Items ................................................. 147
Select a Component Window .......................................................... 147
Linked Blocks .............................................................................. 149
Defining Item Properties ............................................................... 150
    Tree View and Pi Factor View .................................................. 151
    Common Properties ................................................................ 154
Adjustment Factor ...................................................................... 155
Default Component Properties ..................................................... 156
Global Edit .................................................................................... 158
Status Flags ................................................................................ 160
Highlight ...................................................................................... 160
Update Modes ............................................................................. 161
Redundancy ................................................................................. 163
Results ......................................................................................... 164
    System Hierarchy Panel ........................................................ 164
Calculation Information Window .................................................. 166
Reports ......................................................................................... 166
Prediction Plots ........................................................................... 166
    Selecting the Plot Data .......................................................... 167
Contents

Plot Types in MIL-217 and Bellcore/Telcordia Predictions .................................................. 167
Plot Types in NSWC Predictions .......................................................................................... 169
Plots Types in FIDES Predictions ....................................................................................... 170
Plot Types in Siemens Predictions ...................................................................................... 170
Mission Phase Plots .............................................................................................................. 171
Publishing Models from Failure Rate Predictions ............................................................... 172
Publishing Models for an Entire System Configuration or Assembly ................................. 173
Building RBDs from Lambda Predict .................................................................................. 174
Importing from Lambda Predict to Xfmea/RCM++/RBI ...................................................... 179
Chapter 6: MIL-217 Predictions ............................................................................................. 181
Using the Parts Count Method ............................................................................................. 181
Parts Count Library File ....................................................................................................... 181
Example ............................................................................................................................... 182
MIL-217 Custom Connections ............................................................................................... 186
Custom Connection Types .................................................................................................. 186
Non-Operational Properties ................................................................................................. 187
Analysis Results for Non-Operating Conditions ................................................................. 189
Chapter 7: Bellcore/Telcordia Predictions .............................................................................. 191
Early Life Factor .................................................................................................................... 191
Bellcore/Telcordia Prediction Methods .................................................................................. 192
Chapter 8: NSWC Predictions ............................................................................................... 195
Predefined Assemblies ......................................................................................................... 195
Chapter 9: FIDES Predictions ............................................................................................... 197
Defining the Life Profile ....................................................................................................... 197
Specifying Different Phases for Different Levels in the System Hierarchy ......................... 197
Viewing and Selecting the Item Phases ................................................................................ 199
Contents

Select Pi Factor ........................................................................................................................ 201
Update Factors ........................................................................................................................ 202
Process Contributions ............................................................................................................. 203
Manage FIDES Settings ........................................................................................................... 204
Import FIDES Settings ......................................................................................................... 205
Default FIDES Settings for New Databases ......................................................................... 206
Manage FIDES Categories ................................................................................................... 208
Life Profile Phases ............................................................................................................... 209
Pi Factors ............................................................................................................................. 212

Chapter 10: Siemens Predictions ............................................................................................ 225

Chapter 11: Allocation ............................................................................................................ 227
Control Panel ........................................................................................................................... 228
Equal Allocation Model ........................................................................................................ 228
About the Equal Allocation Model ...................................................................................... 229
AGREE Allocation Model ..................................................................................................... 229
About the AGREE Allocation Model .................................................................................... 230
Feasibility of Objectives Allocation Model .......................................................................... 231
About the Feasibility of Objectives Allocation Model ........................................................ 233
ARINC Allocation Model ...................................................................................................... 234
About the ARINC Allocation Model .................................................................................... 235
Repairable Systems Allocation Model .................................................................................. 236
About the Repairable Systems Allocation Model ............................................................... 236
Allocation Plots ....................................................................................................................... 237

Chapter 12: Derating Analysis .................................................................................................. 239
Applying a Derating Standard ............................................................................................... 240
Defining Component Derating Properties ............................................................................ 240
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Derating Analysis Results</td>
<td>241</td>
</tr>
<tr>
<td>System Hierarchy Panel</td>
<td>241</td>
</tr>
<tr>
<td>Component Derating Window</td>
<td>241</td>
</tr>
<tr>
<td>Creating Custom Derating Standards</td>
<td>245</td>
</tr>
<tr>
<td>Creating/Editing the Derating Models in a Custom Standard</td>
<td>245</td>
</tr>
<tr>
<td>Importing and Exporting Custom Derating Standards</td>
<td>247</td>
</tr>
<tr>
<td>Importing a Custom Derating Standard</td>
<td>247</td>
</tr>
<tr>
<td>Exporting a Custom Derating Standard</td>
<td>247</td>
</tr>
<tr>
<td>Chapter 13: Reports</td>
<td>249</td>
</tr>
<tr>
<td>Select to Generate or Publish a Report</td>
<td>249</td>
</tr>
<tr>
<td>Select What to Include in the Report</td>
<td>250</td>
</tr>
<tr>
<td>Creating and Editing Report Templates</td>
<td>251</td>
</tr>
<tr>
<td>Creating or Editing a Template</td>
<td>251</td>
</tr>
<tr>
<td>Building the Template</td>
<td>253</td>
</tr>
<tr>
<td>Formatting the Template</td>
<td>254</td>
</tr>
<tr>
<td>Chapter 14: Import Bill of Materials</td>
<td>257</td>
</tr>
<tr>
<td>Preparing to Import</td>
<td>257</td>
</tr>
<tr>
<td>Using the Import BOM Wizard</td>
<td>257</td>
</tr>
<tr>
<td>BOM Import Templates</td>
<td>260</td>
</tr>
<tr>
<td>Creating an Import Template</td>
<td>260</td>
</tr>
<tr>
<td>Tools</td>
<td>261</td>
</tr>
<tr>
<td>Automatic Mapping for Excel Files</td>
<td>262</td>
</tr>
<tr>
<td>Creating an Import template via Automatic Mapping</td>
<td>262</td>
</tr>
<tr>
<td>Manual Mapping for Excel or Text Files</td>
<td>264</td>
</tr>
<tr>
<td>Creating an Import Template via Manual Mapping</td>
<td>264</td>
</tr>
<tr>
<td>Preparing Delimited Text Files for Import</td>
<td>265</td>
</tr>
</tbody>
</table>
Contents

Preparing the Data .................................................................................................................. 266
Customize Categories .............................................................................................................. 266
Chapter 15: Import Predefined Components ............................................................................. 269
Importing Local Components ............................................................................................... 269
Using Custom Library Files .................................................................................................. 271
   Adding Components to a Library File ................................................................................. 272
   Importing Components from a Library File .......................................................................... 272
   Updating the Properties of Existing Components ............................................................ 273
Managing Custom Library Files ............................................................................................ 273
   Creating a New Library File ............................................................................................... 274
   Viewing/Managing Security Settings for a Library File .................................................... 274
   Viewing/Editing the Properties of Existing Components ................................................. 275
   Deleting Components from a Library File .......................................................................... 276
Importing from PartLibraries.org .......................................................................................... 276
   Importing Components ..................................................................................................... 277
   Updating the General and Physical Properties of Existing Components ........................ 279
Chapter 16: Lambda Predict Settings ....................................................................................... 281
   Synthesis Settings ............................................................................................................ 281
      Synthesis Settings ......................................................................................................... 281
      Backup/Check Out Options ......................................................................................... 283
      Other Synthesis Settings .............................................................................................. 283
   Application-Specific Settings ............................................................................................ 284
      System Hierarchy Settings ......................................................................................... 284
   Properties Settings ......................................................................................................... 285
   Calculations Settings ....................................................................................................... 286
   Plot Settings .................................................................................................................... 286
<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Subscribing to a Watch</td>
<td>312</td>
</tr>
<tr>
<td>Action Alert Preferences</td>
<td>314</td>
</tr>
<tr>
<td>Action and Gate Monitors</td>
<td>315</td>
</tr>
<tr>
<td>What is Your SMS Address?</td>
<td>315</td>
</tr>
<tr>
<td>History Logs</td>
<td>316</td>
</tr>
<tr>
<td>Activating a Project History Log</td>
<td>317</td>
</tr>
<tr>
<td>Viewing Record History Logs</td>
<td>318</td>
</tr>
<tr>
<td>Import, Export and Data Conversion</td>
<td>319</td>
</tr>
<tr>
<td>Importing from an Existing Repository</td>
<td>319</td>
</tr>
<tr>
<td>Importing from Prior Version Files</td>
<td>320</td>
</tr>
<tr>
<td>Importing/Exporting Projects</td>
<td>333</td>
</tr>
<tr>
<td>Importing/Exporting Project Items or Resources</td>
<td>334</td>
</tr>
<tr>
<td>Importing from Excel or Delimited Text Files into a Folio</td>
<td>336</td>
</tr>
<tr>
<td>Using XML in BlockSim and Lambda Predict</td>
<td>340</td>
</tr>
<tr>
<td>Attachments</td>
<td>341</td>
</tr>
<tr>
<td>Attachment Locations</td>
<td>343</td>
</tr>
<tr>
<td>Select Existing Text Window</td>
<td>344</td>
</tr>
<tr>
<td>Project and Item Filters</td>
<td>345</td>
</tr>
<tr>
<td>Record Filter</td>
<td>346</td>
</tr>
<tr>
<td>Phrase Sets</td>
<td>346</td>
</tr>
<tr>
<td>Field Text</td>
<td>346</td>
</tr>
<tr>
<td>Record Filter Options</td>
<td>347</td>
</tr>
<tr>
<td>Check Spelling</td>
<td>349</td>
</tr>
<tr>
<td>Results Window</td>
<td>350</td>
</tr>
<tr>
<td>Quick Parameter Estimator (QPE)</td>
<td>351</td>
</tr>
<tr>
<td>Quick Parameter Estimator Wizard View</td>
<td>351</td>
</tr>
</tbody>
</table>

http://predict.reliasoft.com
Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Model Type</td>
<td>369</td>
</tr>
<tr>
<td>Additional Tools</td>
<td>370</td>
</tr>
<tr>
<td>Publishing Models</td>
<td>370</td>
</tr>
<tr>
<td>Tasks</td>
<td>372</td>
</tr>
<tr>
<td>Corrective Tasks</td>
<td>376</td>
</tr>
<tr>
<td>Preventive Tasks</td>
<td>379</td>
</tr>
<tr>
<td>Inspection Tasks</td>
<td>381</td>
</tr>
<tr>
<td>On Condition Tasks</td>
<td>384</td>
</tr>
<tr>
<td>Task Scheduling</td>
<td>385</td>
</tr>
<tr>
<td>Crews</td>
<td>387</td>
</tr>
<tr>
<td>Spare Part Pools</td>
<td>389</td>
</tr>
<tr>
<td>Metrics</td>
<td>393</td>
</tr>
<tr>
<td>Metric Types</td>
<td>394</td>
</tr>
<tr>
<td>Calculated Result and Saved Values</td>
<td>394</td>
</tr>
<tr>
<td>Target Conditions and Result Indicator</td>
<td>395</td>
</tr>
<tr>
<td>Identifiers, History, Watch and Trace Usage</td>
<td>395</td>
</tr>
<tr>
<td>Showing Metrics in Folios/Diagrams</td>
<td>396</td>
</tr>
<tr>
<td>Using Metrics in Project Planner Gates</td>
<td>398</td>
</tr>
<tr>
<td>Pushing Metrics from an FMRA</td>
<td>400</td>
</tr>
<tr>
<td>Variables</td>
<td>401</td>
</tr>
<tr>
<td>Using Variables to Store Output Values in RENO</td>
<td>402</td>
</tr>
<tr>
<td>Profiles</td>
<td>405</td>
</tr>
<tr>
<td>Creating Profiles</td>
<td>405</td>
</tr>
<tr>
<td>Importing Data from nCode GlyphWorks</td>
<td>408</td>
</tr>
<tr>
<td>Maintenance Groups</td>
<td>408</td>
</tr>
<tr>
<td>Maintenance Group Manager</td>
<td>409</td>
</tr>
</tbody>
</table>
Contents

Finding and Filtering Records ........................................................................................................ 429
Configuring Columns .................................................................................................................. 433
Grouping Panel ....................................................................................................................... 435
Removing Unused and Duplicate Resources .............................................................................. 436
Select Resource Window ........................................................................................................... 437
Trace Usage ............................................................................................................................... 438
Dependency Viewer .................................................................................................................. 438
Dependency Viewer - Diagram View .......................................................................................... 440
Batch Properties Editor .......................................................................................................... 443
Spreadsheet Editor .................................................................................................................. 445
Exporting Information from the Batch Properties Editor ......................................................... 445

Chapter 19: Project Planner ........................................................................................................ 447
Creating a Project Plan ................................................................................................................. 447
   Importing or Starting Again from a Blank Plan ....................................................................... 447
Project Plan Hierarchy .............................................................................................................. 448
   Project Planner Columns ........................................................................................................ 449
Project Planner Timelines .......................................................................................................... 450
   Planned Dates ....................................................................................................................... 450
   Actual Dates ....................................................................................................................... 451
   Expected Dates .................................................................................................................. 451
Project Planner Gates ............................................................................................................... 452
   Gate Properties .................................................................................................................. 452
   Gate Status ....................................................................................................................... 453
Actions in Project Plans ............................................................................................................. 453
   Adding Actions to the Plan ............................................................................................... 454
Project Plan Summary Panel ...................................................................................................... 454
Contents

Plot Setup: Plot Titles Page ........................................................................................................ 477
Plot Setup: Axis Titles/Labels Page .......................................................................................... 478
Plot Setup: Plot Labels Page .................................................................................................. 479
Plot Setup: Legend Page ......................................................................................................... 480
Plot Setup: Canvas Page ........................................................................................................ 482
Plot Setup: Grid Page ............................................................................................................. 483
Plot Setup: Bars Page ............................................................................................................. 484
Plot Setup: Slices Page ........................................................................................................... 484
Plot Setup: Plot Items Page .................................................................................................... 485
Plot Setup: Offsets Page ......................................................................................................... 486
Plot Setup: Zoom Page ........................................................................................................... 487
Plot Defaults Window ............................................................................................................. 488
Plot Defaults Window: Titles Text Page ................................................................................ 489
Plot Defaults Window: Plot Items Display Page .................................................................... 490
ReliaSoft Draw ......................................................................................................................... 490
Overlay Plots ............................................................................................................................. 490
Creating an Overlay Plot ......................................................................................................... 490
Adding or Removing Analyses ............................................................................................... 491
Available Plot Types for Overlay Plots .................................................................................. 491
Side-By-Side Plots .................................................................................................................... 492
Choosing Plots to Display ...................................................................................................... 492
3D Plots .................................................................................................................................... 493
Creating 3D Plots .................................................................................................................... 493
Defining the X, Y and Z Axes ................................................................................................. 494
Rotating 3D Plots ...................................................................................................................... 494
3D Plot Setup ........................................................................................................................... 496
Chapter 21: Synthesis Workbooks ......................................................................................... 499

Synthesis Workbook Wizard ............................................................................................... 499

If you prefer to start with a blank report: ........................................................................ 499

If you want to assign the first data source: ...................................................................... 499

If you want to use a saved template: ............................................................................... 500

Associated Data Sources ................................................................................................. 500

Associating Data Sources ............................................................................................... 500

Linking Multiple Data Sources with Different Time Units ............................................. 502

Synthesis Workbook Templates ....................................................................................... 502

Saving Your Own Templates .......................................................................................... 503

Using a Template .......................................................................................................... 503

Spreadsheet Module ....................................................................................................... 504

Send to Excel ............................................................................................................... 504

Inserting Functions ...................................................................................................... 504

Showing Formulas ........................................................................................................ 504

Recalculate Formulas .................................................................................................... 505

Adding Custom Charts ................................................................................................. 505

Defining Names ............................................................................................................ 505

Word Processing Module ............................................................................................... 506

Using the Function Wizard ......................................................................................... 506

Using the Plot Wizard .................................................................................................. 506

Using Spreadsheet References ...................................................................................... 506

Formulas and Functions ............................................................................................... 506

Function Wizard - Data Sources .................................................................................. 506

Function Wizard - Formulas ........................................................................................ 509

Data Entry Tips for Functions ...................................................................................... 510
Contents

Returning Confidence Bounds ................................................................. 514
Plot Wizard .............................................................................................. 515
Select the Plot Type ............................................................................. 516
Select the Data Source ......................................................................... 516
Insert the Plot Holder ......................................................................... 517
Custom Charts ....................................................................................... 518
Adding a Chart .................................................................................... 518
Changing the Data Displayed on an Axis ............................................ 519
Changing the Chart Type and/or Data Set ......................................... 519
Applying a Chart Layout and/or Chart Style ...................................... 520
Renaming Chart and Axes Titles ......................................................... 520
Modifying the Axes and Gridlines ..................................................... 521
Defined Names ..................................................................................... 521
Syntax Rules for Names ...................................................................... 521
Managing Names ................................................................................ 522
Defining Names .................................................................................. 522
Spreadsheet References ..................................................................... 524
DOE Analysis Reports ......................................................................... 525
Inserting a DOE Analysis Report ....................................................... 526
Using DOE Report Profiles ............................................................... 526
Chapter 22: Synthesis Dashboards ..................................................... 529
Dashboard Viewer ................................................................................ 530
Resizing Panels .................................................................................. 530
Showing Details in Charts and Pies .................................................... 531
Drill Downs and Master Filters ........................................................... 531
Sorting and Filtering Data in a Grid ...................................................... 531
<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Printing or Exporting the Dashboard</td>
<td>531</td>
</tr>
<tr>
<td>Viewing Drill Downs</td>
<td>532</td>
</tr>
<tr>
<td>Using Master Filters</td>
<td>533</td>
</tr>
<tr>
<td>Dashboard Layout Manager</td>
<td>534</td>
</tr>
<tr>
<td>Show in Viewer</td>
<td>535</td>
</tr>
<tr>
<td>Layout Properties</td>
<td>535</td>
</tr>
<tr>
<td>Importing Layouts</td>
<td>536</td>
</tr>
<tr>
<td>Dashboard Layout Designer</td>
<td>536</td>
</tr>
<tr>
<td>Separate Layouts for Each Data Type</td>
<td>536</td>
</tr>
<tr>
<td>Configuring a Dashboard Item</td>
<td>537</td>
</tr>
<tr>
<td>Available Dashboard Items</td>
<td>543</td>
</tr>
<tr>
<td>Configuring a Drill Down</td>
<td>544</td>
</tr>
<tr>
<td>Filtering</td>
<td>545</td>
</tr>
<tr>
<td>Chapter 23: Synthesis Data Warehouse</td>
<td>549</td>
</tr>
<tr>
<td>Managing Data Sources</td>
<td>549</td>
</tr>
<tr>
<td>Built-in Find/Filter, Configuration and Grouping Tools</td>
<td>550</td>
</tr>
<tr>
<td>Building the Data Set</td>
<td>550</td>
</tr>
<tr>
<td>Extracting Data from XFRACAS</td>
<td>551</td>
</tr>
<tr>
<td>Data Fields for XFRACAS Data Collections</td>
<td>553</td>
</tr>
<tr>
<td>Transferring from the SDW to an Analysis Folio</td>
<td>556</td>
</tr>
<tr>
<td>Tips for Mapping the Columns</td>
<td>557</td>
</tr>
<tr>
<td>SDW Dashboards</td>
<td>558</td>
</tr>
<tr>
<td>Custom Connections in the SDW</td>
<td>559</td>
</tr>
<tr>
<td>Connect to an External Database</td>
<td>559</td>
</tr>
<tr>
<td>Connection Issues</td>
<td>561</td>
</tr>
<tr>
<td>Connect to XFRACAS Report</td>
<td>561</td>
</tr>
</tbody>
</table>
## Contents

Import to a Static Data Collection........................................................................................................... 562

Chapter 24: Synthesis Enterprise Portal........................................................................................................ 563

SEP Home...................................................................................................................................................... 563

Actions and Portal Messages ........................................................................................................................ 563

Project Summary, Analysis Summaries and Project Plan ........................................................................ 563

System Hierarchies and FMEAs .................................................................................................................. 563

Dashboards and Reports .............................................................................................................................. 564

Metrics (Key Performance Indicators) .......................................................................................................... 564

SEP and XFRACAS ...................................................................................................................................... 564

Implementing an SEP Website...................................................................................................................... 564

- Establish the Database and Web Server(s).............................................................................................. 565
- Install the Website and Connect to a Synthesis Repository ....................................................................... 565
- Set Up Synthesis Platform User Accounts and Permissions ...................................................................... 565
- Assign SEP Access to Users .................................................................................................................... 566
- Enable Publish to Synthesis Enterprise Portal ........................................................................................ 566
- Configure Custom Content for Home ...................................................................................................... 566
- Configure URLs for Links to Actions in SEP .......................................................................................... 567
- Configure the Synthesis Service for Alerts Based on Calendar Date ......................................................... 567
- Configure Links Between XFRACAS and SEP .......................................................................................... 568
- Allow Aqira Users to Access SEP ........................................................................................................... 568
- Configure Remote ReliaSoft...................................................................................................................... 568
- Distribute SEP Website Link to All Users .................................................................................................. 569

Customizing the SEP Home Page ............................................................................................................... 569

- Custom Content ...................................................................................................................................... 569
- Home Page Panels .................................................................................................................................. 569
- Actions and Messages in SEP ................................................................................................................... 570
My Actions (Home Panel and Page)................................................................. 570
Messages (Home Panel and Page)................................................................. 571
Actions in a Project Summary, Project Plan or FMEA..................................... 572
Links to SEP from Action Alert E-mails and Portal Messages ....................... 573
Projects in SEP ............................................................................................... 573
Change Project and My Projects ................................................................. 573
Publishing to SEP .......................................................................................... 575
Data Sheets or Diagrams ................................................................................ 577
Synthesis Workbooks .................................................................................... 577
Prediction Reports and Plots ........................................................................ 578
Xfmea/RCM++/RBI Reports .......................................................................... 579
FMEAs in SEP ................................................................................................. 579
Hierarchy View ............................................................................................. 580
Published Reports ........................................................................................ 582
Dashboards .................................................................................................... 582
FMEA Queries .............................................................................................. 582
Observed Occurrences in XFRACAS ............................................................ 583
FMEA Stats (Web Summary) ........................................................................ 584
Current Item and/or Sub-Items ..................................................................... 584
Change Log Version and Status ................................................................. 585
% Analyzed or Completed ........................................................................... 585
Top Failure Causes ....................................................................................... 585
Recommended Actions ................................................................................ 586
Dashboards and Reports in SEP ................................................................. 586
Save, Copy or E-mail the URL ...................................................................... 586
Watch This Report ....................................................................................... 587
Contents

Quick Links in SEP .................................................................................................................... 588
  Link to a Page in SEP ........................................................................................................... 588
  Link to an External Website ............................................................................................... 588
  Remove or Rename a Link ................................................................................................. 589
SEP User Preferences .............................................................................................................. 589
  Interface Language ............................................................................................................. 589
  First Active Project ............................................................................................................. 590
  Actions on Home Page ....................................................................................................... 590
  Receive automated alerts ................................................................................................... 590
  Number of Decimals for Metrics ......................................................................................... 591
  'Open' Buttons .................................................................................................................... 591
SEP and XFRACAS .................................................................................................................... 591
  Configure Links Between Websites .................................................................................... 592
  XFRACAS Reports and Charts ............................................................................................ 592
  XFRACAS Actions ............................................................................................................... 592
  XFRACAS Incidents ............................................................................................................. 593
  Links from FMEAs ............................................................................................................... 593
Chapter 1: Getting Started

When actual product life data is not available, standards based reliability prediction may be used to evaluate design feasibility, compare design alternatives, trade-off system design factors and track reliability improvement.

ReliaSoft Lambda Predict by HBM Prenscia supports failure rate and MTBF predictions based on the major reliability prediction standards, including MIL-HDBK-217, Bellcore/Telcordia, FIDES, NSWC Mechanical and Siemens SN 29500.* The software offers a full set of supporting tools, including easy-to-use component library functionality, a reliability allocation utility and derating analysis.

Lambda Predict is also part of the Synthesis Platform, which provides intelligent integration between reliability program activities and tools, while simultaneously facilitating effective information sharing and cooperation between engineering teams of any size. For information about features that are shared by all (or most) of the ReliaSoft desktop applications, see the Repositories and Projects, Desktop Application Interfaces and ReliaSoft Common Tools chapters.

Other ReliaSoft software by HBM Prenscia includes: Weibull++, ALTA, RGA, BlockSim, RENO, Xfmea, RCM++, RBI, MPC, Synthesis Enterprise Portal and XFRACAS.

* Disclaimer: The Lambda Predict software is intended to facilitate the widely used methods that are described in published reliability prediction standards. The software was not developed in cooperation with or endorsed by the organizations that developed and published these standards. The software has been validated against the standards themselves but any issues with the methods described within a standard should be directed to the publishing organization so the feedback may be considered in a future update to the guideline.

Technical Support

ReliaSoft reliability software products are renowned for their ease of use and unparalleled after sale support. For users with an active maintenance agreement, we provide technical support for software-related issues via a network of regional offices and partners/distributors throughout the world.

You can request assistance directly from within the software by choosing File > Help > E-mail Support. This creates an e-mail message that is pre-populated with information about your license and operating system, which the technical support representative will need for troubleshooting the issue.
To get contact details for technical support worldwide, choose File > Help > Contact Technical Support or visit https://support.hbmprenscia.com.

**When Requesting Support**

When you contact us to request technical support, please be prepared to provide the following information:

- Your phone number and e-mail address.
- The product name and the Compile Release Version number of your application. To determine the Compile Release Version (CRV) of the application on your computer, choose File > Help. The CRV is displayed in the About area. Note that the CRV will also indicate whether you are running the 32-Bit version or the 64-Bit version of the software.
- Your product license key.
  - To determine the license for the application on your computer, you can choose File > Application Setup and click any of the main headings in the Application Setup window.
- The operating system (e.g., Windows 7), RAM and hard disk space on your computer.
- Describe what you were doing when the problem occurred and exactly what happened. Please include the specific wording of any message(s) that appeared.

**Note:** Technical support representatives are not reliability consultants, and their assistance is limited to technical issues that you may encounter with the software tools. To get assistance with your analysis from a subject matter expert, please contact Reliability Consulting Services. HBM Prenscia also offers a comprehensive selection of training courses that cover both the underlying principles and theory, as well as the applicable software tools. For details, visit http://www.reliasoft.com/services/training-courses.

**Reliability Consulting**

If your organization does not have sufficient time, expertise or objectivity in-house to accomplish specific reliability goals, turning to our expert reliability consultants can prove to be the most effective and economical solution. Whether you need a quick statistical analysis, a complete assessment of your reliability program plan or something in between, Reliability Consulting Services (RCS) is ready to help.

- Our reliability consulting services team has combined expertise in almost all areas of reliability and quality engineering with experience that spans a broad spectrum of
product types, from micro-electronics and appliances to advanced weapons systems and off-shore oil well drilling equipment.

- Unlike engaging a consultant who works independently, RCS consultants have direct access to all of ReliaSoft global resources, expertise and contacts.

- Our team-based approach to consulting, combined with ReliaSoft global reliability engineering organization, allows us to provide you with reliability consultants who understand your culture and speak your language while ensuring that the appropriate reliability expertise can be applied to each and every project.

- RCS is structured to accommodate requests of any size or complexity, from short telephone consultations to multiple experts at a client's site for an extended time period.

Please visit [http://www.reliasoft.com/services/consulting](http://www.reliasoft.com/services/consulting) for more information.

## Install and License

### System Requirements

In addition to the information below, we provide an automated tool that determines whether your computer and Internet connection meet the requirements for running and activating ReliaSoft desktop applications. It will also determine whether you could install the 64-bit version of these applications, if desired. [Download Requirements and Compatibility Test Tool...](#)

### Operating Systems

32- and 64-bit versions are supported, except where noted. [See our 32-bit vs. 64-bit FAQ...](#)

- Microsoft Windows® 7 with Service Pack 1, Windows 8, Windows 8.1 or Windows 10.

- Microsoft Windows Server 2008 R2 SP1 (64-bit version) or newer. (Requires a license that specifically allows server installations/deployments.)

**Note:** Upgrading your operating system after your ReliaSoft software has already been installed can cause issues with the activation. To prevent this, it is recommended to uninstall ReliaSoft 2018 prior to upgrading your operating system and then reinstall it after the upgrade. For other options, and for information about how to handle the "activated license is corrupt" message that may appear if you upgrade your operating system with live activations, please refer to [http://www.reliasoft.com/windows10-reactivation](http://www.reliasoft.com/windows10-reactivation).
Chapter 1: Getting Started

Minimum Hardware Requirements
- RAM: 2 GB or more
- Hard disk space: 1 GB (minimum) free space available
- Screen resolution: 1024 x 768 or higher

Additional Software
- Microsoft Office 2010 or higher (Excel®, Word and Outlook®) for automated exports, report generation and e-mail/calendar integration.

Enterprise Database Platforms
32- and 64-bit versions are supported.
- SQL Server® 2008 - 2016
- SQL Server Express Edition 2008 - 2016
- Oracle® 10g - 12c

Although the enterprise database platform (Microsoft SQL Server or Oracle) could be installed on the same computer where the ReliaSoft applications reside, most organizations will choose to set up a separate server to host the database. Both the 32-bit and 64-bit versions of the applications will work with either the 32-bit or 64-bit versions of a back-end database/server. The minimum hardware/software requirements for each server hosting the database should be obtained directly from the selected database vendor (i.e., Microsoft or Oracle). In general, we recommend a minimum CPU speed of 2 GHz and 4 GB of RAM.

Installation and Licensing
There are two alternative ways that ReliaSoft desktop applications may be licensed on your computer:
- If you received a license file (*.lic) and/or a license settings file (*.prnrsl), see Locally Hosted Licensing
- If you received only a license key (a 32-digit alphanumeric code), see ReliaSoft-Hosted Licensing

One or both methods can be used on the same computer. For example, if you have your own single-user license for BlockSim and will share your department’s new multi-user (floating) license for Weibull++/ALTA, you will receive a license key for BlockSim and a license settings file for Weibull++/ALTA.

http://predict.reliasoft.com
If you will use both types of licensing on the same computer, use the instructions for locally hosted licenses. When you launch any of the applications that aren’t included in your license settings file, the ReliaSoft License Manager will allow you to perform the activation of your ReliaSoft-hosted license(s) using a product license key.

**Requirements for All Installations**

- Before running the installation program, make sure your computer meets the system requirements for ReliaSoft desktop applications.
- You must be logged in with a user account that has administrative rights.
- It is strongly recommended that you close all other applications during the installation.

**Locally Hosted Licensing**

If you received a license file (*.lic) or license settings file (*.prnrsl), you will be using locally hosted licensing. This allows you to manage available license seats or CRS units in-house without the requirement to connect to the ReliaSoft external license server.

The first step is for a license administrator to configure your organization’s license server and provide each individual user with a) the path to the license server/host (e.g., 6220@servername) and a license settings file (*.prnrsl) that specifies which ReliaSoft applications on your computer will use locally hosted licensing. (For detailed instructions, see [http://www.reliasoft.com/locally-hosted-licensing](http://www.reliasoft.com/locally-hosted-licensing)).

Once the license server has been set up, perform the following steps for each client installation. If you have previously connected the client computer to the appropriate license server, you can start at step 4.

1. Open the ReliaSoft ePack and decompress the *.zip archive in the Locally Hosted Licensing Utility folder
2. Install the HBM Prenscia Licensing Administration utility by double-clicking licinst.exe and following the prompts. The utility will start as soon as installation is complete.
3. On the Client tab of the license admin utility, click **Set Client License Path** and then click **Add Network Host** or enter the license path directly in the window (use the network host format; e.g., port@serverhostname).

   The client computer will check for available license seats in the specified order (i.e., it will go to the top server listed and if no license seat is available there, it will check the next server down, and so on).

   Note that you can delete a license location by highlighting the line and deleting it.
4. Install the ReliaSoft desktop applications by double-clicking the installation program from the ePack (e.g., ReliaSoft2018.exe) and following the prompts.
Chapter 1: Getting Started


The first time you launch an application, you may be asked to provide your name and basic contact information. This is required to be eligible for technical support.

Note: Applications using locally hosted licensing must have an active connection to the license server unless you have borrowed a license. If you see a message that indicates that a license could not be obtained, this could be for a variety of reasons (e.g., you are not connected to the license server, the license server is down or there are no seats or CRS units available for the license). In addition, if you lose connection to the license server while you are using an application, you will see a message warning you to save your work before the application closes.

ReliaSoft-Hosted Licensing

If you are requesting a demo or have already received a license key (a 32-digit alphanumeric code), you will be using ReliaSoft-hosted licensing.

If your computer has an active Internet connection and your firewall allows the software to access the ReliaSoft secure external license server at https://validate.reliasoft.org, only a few simple steps are required for activation:

1. Install the ReliaSoft desktop applications by double-clicking the installation program from the ePack (e.g., ReliaSoft2018.exe) and following the prompts.
2. The first time you launch an application, the activation wizard will appear. On the first page, select whether you want to activate a license or request a free demo license.
3. On the next page, enter a valid e-mail address to serve as your ReliaSoft ID. This is the e-mail address where you will receive confirmation e-mails from the ReliaSoft License Server. This must be your company e-mail address — not gmail, hotmail, etc.
   - Name and Contact Info: If this is the first time that you have registered a ReliaSoft desktop application on this computer with this e-mail address, the next page will request your name and basic contact information.
   - Demo License: If you need a demo license, most requests will be addressed immediately during normal business hours; for some locations, please allow up to 2 business days.
4. On the next page, enter the product license key provided to you. Tip: If you are able to copy the key from a product delivery e-mail, the Paste icon saves time by automatically entering each section into the appropriate input box.
Confirmation Codes: If your license type requires a confirmation code, the next page requires you to copy/paste a code that you will receive via e-mail. Tip: If the e-mail does not appear in your Inbox within a few minutes, check your Junk mail or SPAM folders.

Activate Multiple Applications: If your license key includes other ReliaSoft desktop applications that have not yet been activated on this computer, the next page gives you the opportunity to activate any or all of them at the same time.

5. When you see the “Your product has been activated” message, click Finish to start using the software.

If the computer does not have an active Internet connection, or if you encounter issues with the firewall, there are other ways to complete the activation. Please visit http://www.reliasoft.com/reliasoft-hosted-licensing for details. And, of course, you can always contact us for assistance (https://support.hbmprenscia.com).

Uninstalling ReliaSoft 2018
If you wish to stop using all of the ReliaSoft desktop applications on this computer, you can perform the following steps to uninstall ReliaSoft 2018:

1. Make sure you do not have any ReliaSoft desktop applications currently open.

2. For locally hosted licenses, if you are uninstalling permanently (i.e., if you are not doing this as part of an uninstall/reinstall), open the Import/Export License Settings utility by choosing ReliaSoft 2018 > ReliaSoft 2018 License Settings Import-Export (Windows 8 and 10) or ReliaSoft 2018 > Additional Tools > ReliaSoft 2018 License Settings Import-Export (Windows 7) in the Windows Start menu. Follow the on-screen instructions to delete the license settings file.

3. Open the Windows Control Panel and click Programs and Features (or use the search box in the Windows Start menu to find and select Add or Remove Programs).

4. In the Uninstall or change a program window, double-click ReliaSoft 2018 and follow the prompts.

5. If you have installed the HBM Prenscia Licensing Administration tool, you can follow similar steps to uninstall it.
Tip: If you are using ReliaSoft-hosted licensing (i.e., if you received a license key and activated specific application(s) on your computer), you also have the option to deactivate one or more applications without performing a complete uninstall. For instructions, see http://www.reliasoft.com/deactivating-applications.

License Manager

The License Manager allows you to view and manage license-related details for the ReliaSoft desktop applications that are currently activated on your computer. You can use this interface to:

- View and, for ReliaSoft-hosted licenses, edit the contact information that is on file with us or change the password associated with your ReliaSoft ID. [Learn more…]
- For ReliaSoft-hosted licenses, deactivate the current application (if you don't plan to continue to use it on this computer or for this user). [Learn more…]
- For ReliaSoft-hosted floating licenses, check out or check in a license. [Learn more…]

To open the License Manager, choose File > Help and click the License Manager link in the Licensing section.

You may be prompted to enter the password that was sent via e-mail when you first registered your ReliaSoft ID. This password is required if you want to modify your contact information. For everything else, you can click Cancel to proceed without it. (If you forgot your password, you can request to have the information sent to the e-mail address on file for your registration by clicking E-mail my password to me.)

Contact Information and Password

The Contact Information page displays the name, phone number and other details that are on file with ReliaSoft. For locally hosted licenses, this information is read-only and can only be edited by uninstalling and reinstalling the software. For ReliaSoft-hosted licenses:

- If you need to download the latest information from the license server, click Synchronize.
- If you want to change your password or any of the current contact information, type the new information into the fields on this page and then click Update Information on Server.

Both actions require authentication. If you have not already entered the current password that's associated with your ReliaSoft ID, you will be prompted again to enter it.
Deactivate the Current Application
For ReliaSoft-hosted licenses, if you don't plan to continue to use the current ReliaSoft application on a particular computer (or for a particular user), you can use the License Manager to deactivate it. This does not require authentication; you can proceed with the deactivation even if you have not entered your password.

Click the **Deactivate** button in the current product area on the **Products** page.

![Deactivate button](image)

The application will shut down immediately after you deactivate, so you will be prompted to confirm that you're ready to continue. If you later try to access this application again for this computer/user, you will be prompted to repeat the activation process.

Borrowing Licenses
For certain license types, your computer must be able to connect to a license server to determine whether shared license seats (or, for token-based licenses, the required number of CRS units) are available when you attempt to launch a ReliaSoft application.

If you need to use the application(s) when your computer is not connected to the license server, you can either "borrow" or "check out" the licenses (depending on the license type). This reduces the number of seats (or CRS units) available to other users until the licenses are returned. (For ReliaSoft-hosted licenses, you can also use this feature to make sure a license seat will be available when you need it.)

Borrowing Locally Hosted Licenses
If you have a locally hosted license, you can use the ReliaSoft License Borrowing utility to borrow licenses for selected product(s) for a specified duration.

**IMPORTANT:** If at least one ReliaSoft product with a locally hosted license is borrowed, you will only be able to use the product(s) that are borrowed and only when the computer is not connected to the license server. All desired products must be borrowed or returned at the same time.

If any of the ReliaSoft applications on your computer use a ReliaSoft-hosted license (i.e., a license key
Chapter 1: Getting Started

rather than a license settings file), they will be unaffected by locally hosted license borrowing. For those products, see Checking Out ReliaSoft-Hosted Licenses below.

Borrow License(s)
Before attempting to borrow licenses, first make sure that your computer is connected to the license server and shut down all ReliaSoft desktop applications.


2. The window shows all of the ReliaSoft desktop applications on your computer that use locally hosted licensing. Specify the borrow duration and select which product(s) you want to borrow. (Remember that all desired products must be borrowed or returned at the same time.)

3. Click Borrow Selected Licenses.

4. Close the window.

You will only be able to use the product(s) that are borrowed, and only when the computer is not connected to the license server. If you need to change which products are borrowed, you can reconnect to the license server and repeat the same steps again (this will restart the borrow duration for all selected products). If you need to be able to use the applications while connected to the server, you can return the licenses as described below.

Return License(s)
Before attempting to return licenses, shut down all ReliaSoft desktop applications and reconnect your computer to the license server.

1. Open the ReliaSoft License Borrowing utility.

2. Click Return All Licenses.

3. Close the window.

Note: You can borrow licenses only while your license is valid (e.g., if the annual expiration date of your locally hosted license is 2 days from now, you cannot borrow a license for a duration of 3 days). In addition, you cannot borrow licenses during the 24 hours prior to annual license expiration.

Checking Out ReliaSoft-Hosted Licenses
If you have a ReliaSoft-hosted floating license, you can use the ReliaSoft License Manager to reserve a license.

1. Open the ReliaSoft application.
2. Open the License Manager by choosing **File > Help** and clicking the **License Manager** link in the Licensing section.

3. In the current product area on the **Products** page, click **Check Out** or **Check In**.
Chapter 2: Repositories and Projects

With integration into the Synthesis Platform, the ReliaSoft desktop applications have transitioned from a standalone document/file format to a multi-user, database-driven approach. This offers enormous potential to integrate reliability program activities and tools, while simultaneously facilitating effective information sharing and cooperation between engineering teams of any size.

The experience of working in a database-driven, multi-user environment will be a bit different than using prior versions of ReliaSoft applications (Version 7 or older) and other document-centered applications such as Microsoft Excel. For example, your organization (or team) will need to choose the most appropriate database type and security, implement shared settings that will effectively facilitate project management, and establish adequate backups and database maintenance to protect against data loss. In addition, individual users must be aware that changes are saved automatically as they work (except with the Synthesis file type *.rsf18), and become familiar with the features that facilitate simultaneous access by multiple users.

This chapter discusses some of the basic requirements for using Synthesis repositories and projects. For information about other features, see ReliaSoft Common Tools.

Synthesis Repositories

Database Types
ReliaSoft desktop applications offer three types of databases for storing projects and analysis data. The type of database you choose will depend on the requirements of your organization.

- **Standard repositories** (*.rsr18) are basic database files for single- or multi-user environments. Implementation of a database server is not required; however, there are limits on the amount of data and the number of simultaneous users.

- **Synthesis files** (*.rsf18) are similar to standard repositories except that they can only be used by one person at a time, and changes are not saved until you choose File > Save or Save As. This type of database is therefore best for individual users who are working alone in a single ReliaSoft desktop application and prefer to be able to close a file without saving changes.

- **Enterprise repositories** require implementation and support of Oracle or Microsoft SQL Server, but they are a more robust platform that can store much more analysis information in the same database and support access by many more simultaneous users.
ReliaSoft applications are compatible with Microsoft SQL Server 2008 or later and Oracle 10g or later (including the free Express editions of all of these). They can be accessed via an enterprise repository connection file with the extension *.rserp.

Standard Repositories
A standard repository is a basic database file for single- or multi-user environments. Implementation of a database server is not required; however, there are limits on the amount of data and the number of simultaneous users. (If you prefer to use a more robust Oracle or SQL Server database, see Enterprise Repositories. If you plan to work alone and don’t want changes to be saved automatically, see Synthesis Files.)

Creating a New Standard Repository
To create a new standard database, choose File > New > Standard Repository.

In the Repository name field, specify the filename for the new *.rsr18 file. The path where the file will be saved is shown below this field; to change the location, click the browse icon in the field.

The following options are available when you create a new standard database:

- **Apply login security** configures the new database to be login secure. You can then select the Open security window upon creation check box if you want to add user accounts as part of the database creation process. Note that you cannot automatically remove security from a database once it has been enabled. However, you can create a new non-secure database and use the Import from existing repository check box to automatically import all of the data from the secure database to the non-secure one.

- **Import from existing repository** imports entire projects and other data from an existing database, after the new database is created.

Opening an Existing Standard Repository
If you have opened the file recently, choose File > Recent and then select the file in the Recent Repositories list.

Otherwise, choose File > Open Repository and then browse for the *.rsr18 file.

If the repository has login security enabled and you are unable to connect, you may be encountering one of the following issues:

- **No access to the repository.** If you have not been given access to the repository, you will see a message stating that your account in the repository is not active or not
assigned to at least one security group. You will need assistance from someone who can create and update user accounts (see Managing User Accounts).

- **Windows authentication failed.** If your Windows login (domain and username) is different from what was specified for your user account, you will see a message to connect using alternative credentials. You will need assistance from someone who can enable the use of alternative credentials for your user account.

### Synthesis Files
Synthesis files (*.rsf18) are similar to standard repositories except that they can only be used by one person at a time, and changes are not saved until you choose File > Save or Save As. This type of database is therefore best for individual users who are working alone in a single ReliaSoft desktop application and prefer to be able to close a file without saving changes. If your workflow demands simultaneous access by multiple users, we recommend that you use either a standard database or enterprise database.

Note that if you have the same Synthesis file open simultaneously in two different ReliaSoft applications on the same computer (this situation is not common), saving changes in any of the open applications will save all changes up to that point.

### Creating a New Synthesis File
To create a new Synthesis file, choose File > New > Synthesis File.

In the Repository name field, specify the filename for the new *.rsf18 file. The path where the file will be saved is shown below this field; to change the location, click the browse icon in the field.

The following options are available when you create a new Synthesis file:

- **Apply login security** configures the new database to be login secure. Note that:
  - If you do not apply login security, any database user will be able to access and edit your Synthesis file, so long as the file is saved in a location that the user has read/write access to (e.g., a shared network folder).
  - If you apply login security, only you will have access to the file; however, you can grant other database users the permissions to view/edit your file, if desired. Select the Open security window upon creation check box if you want to add user accounts to the file as part of the database creation process. (For complete instructions on implementing security settings, see Security Options.)
Chapter 2: Repositories and Projects

Note that you cannot automatically remove security from a Synthesis file once it has been enabled. However, you can create a new Synthesis file and use the Import from existing repository check box to automatically import all of the data from the secure file to the non-secure one.

- Import from existing repository imports entire projects and other data from an existing database, after the new file is created.

Opening an Existing Synthesis File

If you have opened the file recently, choose File > Recent and then select the file in the Recent Repositories list.

Otherwise, choose File > Open Repository and then browse for the *.rsf18 file.

If you are unable to open a Synthesis file, you may be encountering one of the following issues:

- File is in use. Synthesis files can only be used by one person at a time; therefore, it is automatically locked to the first user who has it open. You will not be able to open nor view the contents of the file until the other user closes the file.

- If the Synthesis file has login security enabled, you may also encounter the following issues:
  - No access to the repository. If you have not been given access to the repository, you will see a message stating that your account in the repository is not active or not assigned to at least one security group. You will need assistance from someone who can create and update user accounts (see Managing User Accounts).
  - Windows authentication failed. If your Windows login (domain and username) is different from what was specified for your user account, you will see a message to connect using alternative credentials. You will need assistance from someone who can enable the use of alternative credentials for your user account.

Enterprise Repositories

Unlike standard repositories or Synthesis files, enterprise repositories require an established database server with Oracle or Microsoft SQL Server. This allows you to store more analysis information in the same repository and support access by many more simultaneous users. ReliaSoft applications are compatible with Microsoft SQL Server 2008 or later and Oracle 10g or later (including the free Express editions of all of these).

To establish a database server, you will need to purchase an appropriate license package from Oracle or Microsoft. The license, as well the IT maintenance and support needed to establish
the database server, is separate from the license agreement for ReliaSoft software and must be negotiated directly with Oracle or Microsoft.

As an alternative, you may choose to use the free versions of Oracle or SQL Server if the expected load for the database fits within the limited capabilities of the Express edition (as specified by Oracle/Microsoft). With the free editions, you can establish a functioning enterprise database on your own without making a large investment of time and resources. If your organization's needs grow beyond the capabilities of the Express edition, you can then upgrade to a more robust version with the appropriate IT infrastructure and support.

**Tip:** Although we cannot provide full documentation and support for third-party database platforms, we do provide a limited number of resources as a convenience for users who wish to explore the possibilities of an enterprise database implementation. For resources on SQL Server (including instructions for configuring the Express edition), see [http://www.reliasoft.com/using-sql-enterprise-databases](http://www.reliasoft.com/using-sql-enterprise-databases). For resources on Oracle, see [http://www.reliasoft.com/using-oracle-enterprise-databases](http://www.reliasoft.com/using-oracle-enterprise-databases).

The following topics will be of interest to database administrators:

- Creating a New Enterprise Repository
- SQL Server Logins or Impersonation
- Upgrading an Enterprise Repository from a Previous Version
- ReliaSoft Admin Tool

The following topics will be of interest to all enterprise repository users:

- Creating an Enterprise Repository Connection File (*.rserp)
- Monitoring Connection Speed

**Creating a New Enterprise Repository**

If your organization already has established a database server with Oracle or Microsoft SQL Server and you have the permissions necessary to create databases on the server, you can create a new enterprise repository by choosing **File > Manage Repository > New Enterprise Repository**.

**Tip:** If you need to be able to create an enterprise database without using a ReliaSoft desktop application (i.e., without taking up one of the available license seats), you can access this same feature from the [ReliaSoft Admin tool](http://www.reliasoft.com/using-sql-enterprise-databases).
You can choose to create the new database in either Oracle or Microsoft SQL Server.

If you choose **SQL Server**, you will be required to enter:

- **Server Name**: The name of the Microsoft SQL Server implementation where the new database will be created. Note that if you are using SQL Server Express, the server name is usually your login for that computer followed by \SQLEXPRESS (e.g., Username\SQLEXPRESS).
- **Database Name**: The name of the new database that will be created.
- **Options**:
  - **Encrypt communication** secures the connection information between the ReliaSoft application and the enterprise database.
  - **Trust server certificate**. Select this option if the server has a self-signed certificate.

If you choose **Oracle**, you will be required to enter:

- **Port, Host**, and **Service** identifiers for the Oracle server where the new database will be created.
- The **Schema** of the new Enterprise database.
- The **Password** for the new enterprise database schema. If you are including special characters in the password, you must include quotes around each special character when entering the password.
- The administrative username and password for the Oracle server (entered in the **Admin Information** area).

For either server type, select the **Import from existing repository** check box if you want to import entire projects and other data from an existing database.

Click **OK** to create the database. The database will not open automatically; you must connect to it. (See [Connecting to an Existing Enterprise Repository](#).)

---

**Connecting to an Existing Enterprise Repository**

If your organization has already [created an enterprise database](#) on Oracle or SQL Server and you have an active user account, you can use an enterprise repository connection file (*rserp*) to connect with the database. You can create this file yourself or use a file that has been created by someone else.
Creating a Connection File
To create a connection file, choose File > New > Enterprise Repository Connection File.

This command creates an enterprise repository connection file (*.rserp) that is stored locally on your computer; the file contains all of the necessary information for connecting to the enterprise database.

Enter a name for the connection file, then choose the database type and version.

- For a SQL Server database:
  - Select Encrypt communication if you want to encrypt the connection between the application and the database
  - Select Trust server certificate if the server has a self-signed certificate.
  - Select Use impersonation if you want the connection file to impersonate a Windows user account with a SQL Server login that can be shared by multiple users. This connection file can then be distributed to any user who does not have his/her own individual SQL Server login and is not part of a Microsoft Active Directory® group that has a login. (See SQL Server Logins or Using Windows Impersonation.)

- For an Oracle database, enter the port, host and service identifiers, the database schema and the password for the enterprise database schema.
  - If you are including special characters in the password, you must include quotes around each special character when entering the password.

Note: If you want to encrypt the connection for an Oracle implementation, you must set the encryption type to either "requested" or "required" for the Oracle database. For more information, please consult the Oracle documentation (e.g., https://docs.oracle.com/cd/B19306_01/network.102/b14268/asoconfg.htm#i1007808).

Using an *.rserp File to Connect to an Enterprise Repository
If you have used the connection file recently, choose File > Recent and then select the file in the Recent Repositories list.

Otherwise, choose File > Open Repository and then browse for the *.rserp file.
If you are unable to connect to an enterprise repository, you may be encountering any of the following issues:

- **No access to the repository.** If you have not been given access to the repository, you will see a message stating that your account in the repository is not active or not assigned to at least one security group. You will need assistance from someone who can create and update user accounts (see Managing User Accounts).

- **Windows authentication failed.** If your Windows login (domain and username) is different from what was specified for your user account, you will see a message to connect using alternative credentials. You will need assistance from someone who can enable the use of alternative credentials for your user account.

- **Cannot connect to the server or login failed.** Server-related issues may occur for several reasons, and you may see various messages pertaining to the situation. Common issues are:
  
  - You do not have a network connection or you may have entered the incorrect database name or server name in the connection file.
  
  - The SQL Server database resides in a different domain than the one you have used to log in to Windows and your network cannot recognize the domain name you have entered. Depending on your network configuration, you may be able to connect using either the "fully qualified domain name" (FQDN) or the IP address for the server.
  
  - In SQL Server databases, a login issue may occur if your username is not associated with a SQL Server Login. (See SQL Server Logins or Using Windows Impersonation.)
  
  - The server is not configured to allow remote connections, has certain firewall settings or is experiencing other issues.

**Note:** If you get an "error occurred when reading the connection file" message, the connection file may be corrupted or is using old encryption. You can create a new connection file by choosing File > New > Enterprise Repository Connection File.
Chapter 2: Repositories and Projects

SQL Server Logins or Using Windows Impersonation
Connecting with a SQL Server database via Windows authentication requires a "SQL Server login" that allows the database platform to recognize the user and gives access to the Synthesis repository. There are three ways that a user account may be recognized by SQL Server:

- **Individual Login**: The user has an individual SQL Server login that is associated directly with his/her Windows username.

- **Group Login**: The user belongs to an Active Directory group that has a SQL Server login shared by all members of the group.

- **Use Impersonation for Connection File**: The user does not have an individual or group login but he/she connects to the database with an enterprise connection file (*.rserp) that impersonates another Windows user account that does have a SQL Server login.

Your organization may choose to use any or all of these methods for your implementation (e.g., some users may have their own individual logins, while other users connect using Windows identity impersonation). This document provides an overview of all three options.

**Option 1: Creating Individual SQL Server Logins**
If you choose to create individual SQL Server logins for some or all of the user accounts, you have two options. (For details and instructions on performing these tasks in SQL Server, see [http://www.reliasoft.com/using-sql-enterprise-databases](http://www.reliasoft.com/using-sql-enterprise-databases).)

1. A database administrator for SQL Server can create SQL Server logins in advance for every potential user and give the logins access to the application database (at least the db_datareader and db_datawriter roles are required). This would be performed directly in SQL Server (not via one of the ReliaSoft applications).

2. A database administrator for SQL Server can grant the appropriate level of database authority for creating SQL Server logins and database roles (e.g., securityadmin or sysadmin) to any user who has the ability to create user accounts in the Synthesis repository. The additional authority would be added directly in SQL Server. Then, when any of these administrative users creates a new user account via the ReliaSoft application, the required SQL Server login can be created and the application database roles can be assigned automatically at the same time.

If you are using the first approach, clear the **Create SQL Server login** check box that is displayed when you are adding or importing a user account. If you are using the second approach, you must select this check box.
Tip: If the user already has a SQL Server login and access to the application database, it does not matter whether you select or clear the Create SQL Server login check box because the application attempts to create the login only if one does not already exist.

Furthermore, if the user who is creating the user account does not have the necessary level of database authority in SQL Server, the login will not be created even if the check box is selected.

Option 2: Using a Group Login
If the user belongs to an Active Directory group that has a SQL Server login shared by all members of the group and that group has access to the application database, you can clear the Create SQL Server login check box that is displayed when you are adding or importing a user account.
For example, base installations of Microsoft SQL Server Express 2008 include the "Builtin\Users" Active Directory group as a SQL Server login by default. This means all users with a Windows account for that domain will be able to log in to the enterprise database with no need to create individual SQL Server logins in SQL Server Express. However, it will still be necessary to grant access for this group login to the application database (at least the db_datareader and db_datawriter roles are required).

**Option 3: Using Windows Impersonation for the Connection File**

If you choose to have some (or all) users connect to the SQL Server database with a connection file that impersonates a shared Windows user account that has a SQL Server login, you must do the following:

- A Windows network administrator must establish the shared user account on Windows.
- A database administrator for SQL Server must create a SQL Server login for the shared Windows user account and grant this login access to the application database (at least the db_datareader and db_datawriter roles are required).
- A user must create an enterprise repository connection file that impersonates the shared Windows user account:
  1. Choose **File > New** then click **Enterprise Repository Connection File**.
  2. Under **Repository Connection Settings**, select **Microsoft SQL Server (2008 or later)** from the drop-down list and then select the **Use impersonation** check box.
  3. Enter the server and database name for the SQL Server database, then enter the domain, username and password for the shared Windows account that users will need to impersonate.
  4. Click **OK** to create the connection file (*.rserp). It will be stored in the location specified under **Connection File Name**. Note that the default filename will be “SQL_(Server Name)_(Database Name),” but you can assign any name that fits the process your organization will use for distributing the file to users. (Note that while the window shown next is for Weibull++, the settings are the same for all ReliaSoft applications.)
Once you have created a connection file that impersonates the shared Windows user account, you can distribute the file to any user who needs it. To connect to the repository using this file, the user can:

1. Choose **File > Open Repository** and browse for the connection file.
2. Click **Open** to connect with the repository.

After the first connection, this *.rserp file will be saved in the list of recent repositories, which can be accessed by choosing **File > Recent**.
**Note:** For the purpose of being recognized by SQL Server and accessing the application database, the user will be impersonating the shared Windows login. For the purpose of performing actions via the ReliaSoft applications, the user’s actions will be governed by his/her own user account in Synthesis. In other words, multiple users can connect with the database using the same enterprise connection file, but their activities within the ReliaSoft applications will be governed by the permissions established in their own individual user accounts, and any changes made to the analysis data will be recorded in the application under their own usernames.

### Enterprise Repository Connection Speed
If the ReliaSoft desktop application is exhibiting slow performance when you’re connected to an enterprise repository, the issue may be related to your network connection. The MDI status bar displays a connection speed indicator on the lower right side of the window.

The following icons are used to indicate the connection speed. In cases of poor network performance, you will need to request assistance from the IT support group responsible for the server.

- 🟠< 30 ms: Good (acceptable performance)
- 🟢30 - 70 ms: OK (may exhibit some delays in operations, opening/closing windows, etc.)
- 🟡70 - 110 ms: Slow (will exhibit some delays in operations, opening/closing windows, etc.)
- ⚠️110 - 150 ms: Very slow (will exhibit significant delays in operations, opening/closing windows, etc.)
- 🔴> 150 ms: Extremely slow (will result in unacceptable performance and usability)

### Upgrading an Enterprise Repository from a Previous Version
If you have an existing enterprise database that was created in Version 8 or later of the ReliaSoft applications, you can transfer or convert all of the existing data into a new database that is compatible with the latest version.

All of the same requirements for creating a new enterprise database apply here (e.g., you must have an established database server and the necessary permissions to create a database on the server). In addition, you must be a member of the Admin group in the database to perform the task.
Chapter 2: Repositories and Projects

**Tip:** If you need to be able to upgrade an enterprise database without using a ReliaSoft desktop application (i.e., without taking up one of the available license seats), you can access this same feature from the ReliaSoft Admin tool.

### Upgrading from Version 9 or Above

It is strongly recommended that you create a backup of the enterprise repository to be upgraded. The upgrade process converts the database itself to the latest version. This change cannot be undone.

To upgrade the database, choose File > Manage Repository > Upgrade Enterprise Repository.

In the window, specify the enterprise database that you wish to upgrade. Click OK to start the process.

### Upgrading from Version 8

You do not need to create a backup before upgrading a Version 8 enterprise repository. The upgrade process does not involve a direct conversion of data, but rather copies over all existing data into a new database. This complete switch to a new database is required in order to support the exclusive features in the latest version.

To upgrade the database, open the latest version of the ReliaSoft application and choose File > Manage Repository > Upgrade Version 8 Repository.

Use the left side of the window to specify the Version 8 enterprise database that you wish to upgrade. Use the right side of the window to define the new Version 2018 enterprise database that the existing data will be copied into. Click OK to start the upgrade.

### ReliaSoft Admin Tool

The Synthesis Platform includes an admin tool that allows a database administrator to set up and manage enterprise databases without requiring a software user license or an activated ReliaSoft desktop application.

To use the ReliaSoft Admin tool, your organization must have already established a database server with Oracle or Microsoft SQL Server, and you must have the permissions necessary to create databases on the server.
To access the tool, open the Windows Start menu and choose **ReliaSoft 2018 > Additional Tools > ReliaSoft 2018 Admin** from the programs list. Alternatively, you can open the Windows Start menu and type **ReliaSoft 2018 Admin** in the search bar.

The following features from the ReliaSoft desktop applications are available in the admin tool.

- Creating a new enterprise repository
- Upgrading an enterprise repository from a previous version
- Manage user accounts:
  - Adding and editing user accounts
  - Importing users from Active Directory
  - Creating alternative credentials
  - Editing user login and contact info
  - Managing security groups
- Configuring the XFRACAS or Synthesis Enterprise Portal (SEP) applications on a web server. For details, please consult the implementation guides for those web applications.

**Projects**

In Synthesis repositories, *projects* serve as a way to keep related analyses together. Each project can contain analyses (e.g., folios, diagrams, plots, FMEAs, etc.), a **Project Planner**, **resources** that can be shared between analyses (e.g., models, tasks, actions, etc.) and **attachments**.

Any project can be opened in any ReliaSoft application; however, application-specific analyses (e.g., folios in Weibull++, diagrams in BlockSim, etc.) are visible only in the application(s) that can edit them.

**Creating and Managing Projects**

This topic describes how to create and manage the projects that are accessible to you via the **project list** (**View > Project Manager > Show Project Manager**). This depends on your permissions in the database and any security that has been defined at the project level.
Chapter 2: Repositories and Projects

There are three types of projects: private, public or reference. In addition, a project may be locked or checked out at any given time. Each type of project is displayed under the appropriate heading in the project list:

Tip: The Manage Projects window (Project > Management > Manage Projects) allows you to perform administrative tasks for multiple projects all at once, and to manage the private projects of other users. (See Manage Projects Window.)

Creating a New Project

When you create a new project, you must specify whether it will be public, private or reference. Select or right-click the appropriate heading in the project list and (i.e., Private, Public or Reference), and then choose Project > Management > Create Project.

The selected project type will be displayed at the bottom of the Project Properties window. If desired, you can change the selection before clicking OK to create the project.
Tip: If you later need to change the project type, select the project and choose Project > Security > [Make Private, Make Public, or Make Reference]. The same commands are also available in the Manage Projects window.

Duplicating Projects
To duplicate an existing project, select it and choose Project > Management > Duplicate Project.

This command will create an exact duplicate of the original project with a name that contains an increment number (e.g., Project_1, Project_2, etc.). Note that duplicate projects do not retain the security settings of the original project.

Deleting Projects
To delete a project, select it and press DELETE or choose Project > Management > Delete Project.

To make sure that your analysis information is not deleted by mistake, you will always be prompted to confirm before proceeding. By default, the project will be moved to the recycle bin, which will give you a chance to recover it later if needed. If you want to permanently delete the project now (no way to undo unless you have a backup or restore point), clear the Send project to recycle bin check box in the confirmation window.

Note: You cannot delete a reference project if any of its resources are in use, including by projects in the recycle bin.

Project Properties
The Project Properties window will be displayed when you create a new project or when you choose Project > Management > Edit Project Properties.

The options available in this window will vary depending on which application you are using and whether the database has login security enabled. For MPC, see MPC's Project Properties (below). For all other ReliaSoft desktop applications, this may include:

- General Tab
Chapter 2: Repositories and Projects

- **Security Tab** (available only for public/reference projects in secure databases)
- **Configurable Settings Tab** (only in Xfmea/RCM++/RBI)

In addition, the status bar at the bottom of the window always displays the following information:

**Project Owner**: The user who has been identified as the project owner. In a secure database, the ability to edit the project properties is restricted to the **project owner** and to users with the relevant **“manage all projects” permissions**.

**Last Update**: The time and date the project was last changed/updated, and the user who made the change. This considers any change to any of the analysis data in the project (not just the project properties).

**General Tab**
The General tab contains the following options:

- **Name** is the identifier for the project that will appear in the current project explorer and in many other windows and reports throughout the software. This field is required and cannot contain any of the following characters: \\/:*?<> |.

- **Description** and **Remarks** can contain more detailed notes or information about the project.

- **Proprietary Label** can contain a copyright or distribution statement, if desired. This label may appear in the footer of some reports generated in Xfmea/RCM++/RBI or MPC.

- **Project Category** allows you to assign a **project category** that can be used to filter the projects displayed in the **project list** and in many other windows throughout the software.

In Xfmea/RCM++/RBI, this tab also contains:

- **FMEA Structure** determines how the software will display the effect and cause records in the FMEA hierarchy. This is applicable only in Xfmea/RCM++/RBI. (See **Choosing the FMEA Structure** in the Xfmea/RCM++/RBI documentation.)

- **Select Profile from Library** displays a list of all profiles that have been defined in the active library. When you choose a profile from the list, all of the configurable settings for the project will be set/reset based on the settings that have been predefined for that profile. If you are editing a project, the current profile is shown in brackets. (In a secure database, the ability to add and edit a profile is available only for users with the **“Manage profiles and templates in Xfmea/RCM++/RBI” permission.”**)
Security Tab
The Security tab is available only when you are working with a public or reference project in a secure database. For a full discussion on how to use these settings, see Planning Your Security Approach.

For quick access to the Security tab, you can select the project in the project list and choose Project > Security > Project Security.

Configurable Settings Tab
The Configurable Settings tab is available for Xfmea/RCM++/RBI only. It provides access to all of the configurable settings that have been defined for the current project, based on the profile that was selected on the General tab.

This tab allows you to make specific changes that will apply to the current project only. For example, if you are using a predefined profile but want to make a change to the interface style for this particular project only, you could click the Edit icon associated with the Interface Style drop-down list in the Interface Settings area.

It is important to note that any change to the Configurable Settings page will update the settings for the current project, but it will not alter the original profile. If you want the project’s current settings to be available as a new profile in the active library, click the Send Settings to Library button and then type the name and description for the new profile that will be created.

In the Enable Legacy Analyses section, you can choose whether to allow users to create and use DVP&R or DRBFM analyses in the project. These settings are not part of the profile and may be different for each project. (See Design Verification Plans (DVP&Rs) and Design Reviews Based on Failure Mode (DRBFMs) in the Xfmea/RCM++/RBI documentation.)

MPC’s Project Properties
For users of MPC, the interface has been customized to display only the information that is directly relevant for MSG-3 analyses. This includes the Name, Description, Remarks and Project Category. In addition, you will be able to define the following:

- **Short Description** appears in the header of the Standard report template. It is not applicable for Dassault or Sukhoi reports.
• Proprietary Label appears in the footer of the Standard report template. It is not applicable for Dassault or Sukhoi reports.

• MSG-3 Guidelines displays a list of the available MSG-3 guidelines that can be used for the systems and powerplant analysis.
  • In most cases, the version that you select will not have any impact on the MSG-3 logic displayed in the interface and print-ready reports.
  • The only substantive difference occurs when you select MSG-3 Revision 2002.1 because this older version of the guideline uses slightly different titles for two of the maintenance significant item (MSI) questions, and lists the questions in a different order.

• Model/Equipment/Effectivity allows you to enter the information that will appear on the title page of the Dassault and Sukhoi templates.

Project Owner
For each project in a Synthesis repository, one user will be assigned as the project owner. By default, the owner will be the user who created the project, but this can be changed when needed.

In a secure database, being the project owner means that you have full permissions over the project. This includes the ability to edit the project properties, add/edit/delete project items and resources, lock and unlock, set security settings, create restore points and delete the project. These permissions are always in effect regardless of the project security settings or item permissions that may be in place.

Changing the Project Owner
To change the owner, select the project in the project list and choose Project > Security > Change Owner.

In a secure database, this is available only for users with the applicable "manage all projects" permissions.

Identifying the Project Owner
There are three ways to identify the current owner of a project:

• Use the filters in the project list to filter and/or group projects based on the project owner. For example:
Chapter 2: Repositories and Projects

Public, Private and Reference Projects
In Synthesis repositories, there are three types of projects you can create:

- A **public** project may be accessible to any user who has access to the database, depending on the **security settings** that have been implemented.

- A **private** project can be viewed and edited only by the **project owner**. The **project list** shows only your own private projects, while the **Manage Projects window** provides the
ability to manage all users’ private projects (including delete, lock/unlock or changing the project type).

- **A reference** project is like any regular public project, except that you can share its resources and FMEAs with other projects in the database. This gives you a pool of resources that can be used throughout the database by specified users (based on the security settings for the reference project), while allowing you to maintain fully functional analyses within the reference project itself. (For more information, see Local, Global and Reference Resources, and Linked FMEAs in the Xfmea/RCM++/RBI documentation.)

In the project list, each type of project is displayed under the appropriate heading, as shown in the following example.

![Project List](image)

**Note:** In MPC, the Reference heading will appear only if reference projects already exist in the database (created by another ReliaSoft desktop application). You cannot create a new reference project or convert an existing project into a reference project in MPC.

**Setting the Initial Project Type**

When you create a new project, you must specify whether it will be public, private or reference. Select or right-click the appropriate heading in the project list and (i.e., Private, Public or Reference), and then choose **Project > Management > Create Project**.
The selected project type will be displayed at the bottom of the Project Properties window. If desired, you can change the selection before clicking OK to create the project.

**Changing the Project Type**

To change the project type for one project, select it in the project list and choose Project > Security and then one of the following options:

- Make Private
- Make Public
- Make Reference

To change the project type for multiple projects simultaneously, use the Manage Projects window instead.

**Locked and Unlocked Projects**

In all Synthesis repositories, a project can be locked to prevent users from editing the data. If a project is locked, it will be moved to the Locked heading in the project list and it cannot be edited by any database user unless it is unlocked again.

In a secure database, locking and unlocking a project are available only if the user a) is the project owner, b) has the "Lock or check out project" permission for the project or c) has the applicable "manage all projects" permissions.

**Locking a Project**

To lock a project, select it in the project list and choose Project > Security > Lock Project.

When a project is locked, all database users (including the user who locked the project) will have read-only access to the project. In addition, a locked project cannot be deleted or have its properties and public/private/reference status edited.
Unlocking a Project
To unlock a project, select it in the project list and choose Project > Security > Unlock Project.

Tip: The Manage Projects window allows you to select multiple projects and lock or unlock them all at once.

Check In and Check Out Projects
In all Synthesis repositories, both private and public projects can be checked out to temporarily allow one particular user to work on a project independently for a period of time and/or to work on a computer that is not connected to the network where the shared database resides (e.g., if you need to work on the project while you’re out of the office). When a project is checked out, two things happen:

• An editable copy of the project will be saved into a standard database (*.rsr18) in the specified "Checked Out" folder on your local computer. This database will have the same name as the project.

• The original project will be set to read-only and moved under the Checked Out heading in the project list. This allows other users who would normally be able to access the project to see that it is currently being edited exclusively by one particular user. It also provides read-only access to the latest version of the project at the time it was checked out so those users can query, copy data, etc. while you’re editing the project "offline."

You can then edit the project as needed in the standard database and check the project back in when you’re finished.

IMPORTANT: If the project uses resources or FMEAs from a reference project (e.g., linked FMEAs, models, URDs) the links won’t be maintained when you check out the project. Any linked resources/FMEAs will be replaced with local copies of the resources/FMEAs and stored directly within the project. See also Local, Global and Reference Resources.

Specifying the "Checked Out" Folder
By default, projects will be checked out to the default Documents folder on your computer (e.g., My Documents\ReliaSoft\Files\Checked Out).

To change this location, open the Backup/Check Out Options page of the Application Setup window and browse for a new default path under Check In/Out. Keep in mind that anyone who has access to the folder will have full access to the checked out project; however, only the user who has the project checked out will have the ability to check in the project.
Chapter 2: Repositories and Projects

Tip: If you need to work on the project from a different computer after it has been checked out to the local folder, you will simply need to make sure that the latest copy of the standard database file is saved back to the exact same check-out location and filename before you check the project back in.

Checking Out a Project
To check out a project, select it in the project list then choose Project > Management > Check In/Out > Check Out.

In a secure database, this is available only if the user a) is the project owner, b) has the "Lock or check out project" permission for the project or c) has the applicable "manage all projects" permissions.

Checking in a Project
To check in a project, select it under the Checked Out heading in the project list and choose Project > Management > Check In/Out > Check In.

Note that when you check in a project, the software creates a restore point, which is an exact replica (i.e., a backup) of the project before it was checked out. This allows you to restore the project to its prior state when and if needed. The restore point will include a description of the user who checked out the project, as well as the date and time of the check out. (See Restore Points.)

Undo Check Out
To discard changes and restore the project to the state it was in before it was checked out, select the project under the Checked Out heading in the project list and choose Project > Management > Check In/Out > Undo Check Out.

In a secure database, this is available only if the user a) is the user who checked out the project, b) is the project owner or c) has the applicable “manage all projects" permissions.
Chapter 2: Repositories and Projects

Manage Projects Window
The Manage Project window displays a list of all the projects that currently exist for the
database and allows you to perform administrative tasks for multiple projects all at once. If you
have created custom project filters, you can apply those same filters in this window.

To open the Manage Projects window, choose Project > Management > Manage Projects.

In a secure database, this is available only to users with the applicable "manage all projects"
permissions. Only the type of project that you have permissions for will be displayed. Projects
that are under the Locked, Checked Out and Recycle Bin headings will be visible only if you have
permissions for all three project types.

Tasks You Can Perform
Some of the tasks you can perform in this window include:

- See a list of private projects created by other users (and perform any administrative
tasks that may be needed for those projects).
- Change multiple public projects to private all at once, and vice versa.
- Change the owner for multiple projects all at once.
- Apply the same changes to the project properties for multiple projects all at once.
- Review and edit the security settings (if applicable) for multiple projects all at once.
- Delete, restore, lock and unlock, or undo check out for multiple projects all at once.
- Review and sort projects based on the user who made the last change to a project, the
date/time of the last change and the last application that was used to make the change.

Tip: The Manage Projects window allows you to edit the properties of a project that is currently open or
in use. When you make a change, the user who has the project open will see the change you have made
when the database refreshes (the refresh happens automatically whenever the user makes a change,
such as closing a window, selecting a different item, etc.).

Tools
The Manage Project window contains the following commands:

Project

Palette Close closes the Manage Projects window.
Edit Project Properties allows you to view and edit the properties of the selected project(s).

Delete Project permanently deletes the selected project(s) and bypasses the recycle bin. There is no undo for delete unless you have a stored backup or restore point.

Restore Project is available only when you have selected project(s) under the Recycle Bin heading. Each selected project will be recovered from the recycle bin and restored to its original location in the project list.

Security

Change Owner assigns a different database user to be the owner for the selected project(s). (See Project Owner.)

Project Security is available only for public and reference projects in secure databases. It opens the Project Properties window with the Security tab active, where you can specify the user accounts that can view/modify the selected project. (See Planning Your Security Approach.)

Lock Project moves the selected project(s) into the Locked heading of the project list. When a project is locked, all database users (including the user who locked the project) will have read-only access to the project. In addition, a locked project cannot be deleted or have its properties and public/private/reference status edited. To unlock project(s), choose Unlock Project. (See Locked and Unlocked Projects.)

Make Private moves the selected project(s) into the Private heading of the project list. To move private project(s) to the Public heading, choose Make Public. (See Public, Private and Reference Projects.)

Make Reference moves the selected project(s) into the Reference heading of the project list. To move reference project(s) to the Public heading, choose Make Public.

Check Out

Undo Check Out discards all changes made to a checked out project and restores it to the state it was in at the time it was checked out. (See Check In and Check Out Projects.)

Excel

Send to Excel exports the data currently displayed in the Manage Projects window to an Excel spreadsheet.
Recycle Bin
The recycle bin is a temporary storage location for projects that have been deleted. It gives you a chance to restore the deleted project to its original location, if needed. Projects in the recycle bin are stored until you either empty the recycle bin or delete each individual project from the recycle bin.

Sending Projects to the Recycle Bin
Whenever you delete a project from a database, a confirmation window like the one shown next will appear.

If you want to move the project to the recycle bin, make sure the Send project to recycle bin check box is selected. If you want to immediately and permanently delete the project, clear the check box. Remember that once you empty or delete a particular project from the recycle bin, there will be no way to get it back unless you have previously created a backup or restore point.

Restoring and Deleting Projects from the Recycle Bin
In a secure database, the ability to restore and delete projects from the recycle bin is available only if the user a) is the project owner, b) has the "Delete project" permission, or c) has the applicable "manage all projects" permissions.

To restore a project from the recycle bin, select it and choose Project > Management > Recycle Bin > Restore Project.

To permanently delete a project in the recycle bin (no way to undo unless you have a backup or restore point), select it in the recycle bin and choose Project > Management > Recycle Bin > Delete Project.
To permanently delete all projects currently in the recycle bin (no way to undo unless you have a backup or restore point), select the Recycle Bin heading in the project list and choose Project > Management > Recycle Bin > Empty Recycle Bin.

Security

All enterprise databases use login security, meaning that the ReliaSoft applications use Windows authentication (or alternative credentials) to identify each user and control the user’s access via security groups. For a standard database or Synthesis file, you can choose whether to apply login security; if you don’t, any user who has read/write access to the file will have full permissions throughout the database.

By default, each user in a secure database will have the same set of permissions for every public/reference project in the database (e.g., Jane Engineer has read-write access to all projects, Bill User has read-only access to all projects, and so on). Alternatively, you can configure the database to provide different permissions for different public/reference projects, if desired (e.g., Jane Engineer has read-write access to all of Department A’s projects, but she has read-only access to other projects). With either approach, you also have the option to further limit access for specific project items (e.g., folios, diagrams, system hierarchy items, etc.) if needed. There are many different ways these options can be configured depending on your organization’s particular needs.

Tip: If you need to be able to manage an enterprise database without using a ReliaSoft desktop application (i.e., without taking up one of the available license seats), you can access the same security features from the ReliaSoft Admin tool.

Applying Login Security

All enterprise databases use login security. For standard databases or Synthesis files, there are two ways to apply login security if desired:

- Upon creating a new standard database or Synthesis file (File > New), you can make it login secure by selecting the Apply login security check box.
For an existing standard database, you can apply login security at any time by choosing File > Manage Repository > Users and Security and then clicking the Apply Login Security button at the lower left corner of the window.

When you create an enterprise database or apply login security to a standard database or Synthesis file, you will automatically be a member of the Admin security group, which has full permissions throughout the database. You can then use the Users and Security window to add/edit/delete other user accounts and assign them to appropriate security groups.

Note: You cannot automatically remove security from a database once it has been enabled. However, you can create a new non-secure database and use the Import from existing repository check box to automatically import all of the data from the secure database to the non-secure one.

Planning Your Security Approach

In secure databases, there are two basic factors that determine what a typical user can see and do in the database: the security group(s) that the user account belongs to and the public/reference project security settings.

This topic discusses two general approaches you can use to configure the security groups and project security settings to fit your organization’s specific needs:

- Same permissions for all public/reference projects
- Different permissions for different public/reference projects
Tip: In addition to these considerations, it is also important to note the following: a) Users with the applicable "manage all projects" permissions (in any of the security groups that they belong to) will always have full project-level permissions for all public or reference projects in the database; b) The project owner will always have full project-level permissions within that particular project; and c) The item permissions can be used to further limit access to specific items within a project (e.g., folios, diagrams, system hierarchy items, etc.).

**Same Permissions for All Public/Reference Projects**

If you want each user to have the same set of permissions for all public/reference projects in the database (e.g., Jane Engineer has read-write access to all projects, Bill User has read-only access to all projects, and so on), follow these steps:

1. **User Accounts and Security Groups**: Assign each user account to an appropriate security group. This can be one of the four security groups that are created by default in each new Synthesis repository — Admin, Power, User (Read/Write) or View (Read-Only) — or you can configure new or existing security groups to meet your particular needs.

   Select or clear the **Allow access to projects with repository-level security** check box. If some of the projects in the database will continue to use repository-level security, this allows you to specify whether each user will be able to access those projects.

   - If the option is selected (default), the user will be able to access any public/reference project that is set to use repository-level security, with the combined permissions from any of the assigned security groups.

   - If the option is cleared, the user will only be able to access a project if it is specifically assigned to a security group that he/she belongs to, or if the user account is specifically assigned to the project.
2. **Project Security**: Accept the default option on the Security tab of the Project Properties for all public and reference projects (**Project > Security > Project Security**). Note that if a user belongs to more than one security group (and the **Allow access to projects with repository-level security** check box is selected for his/her user account), that user will have the combined permissions of those groups in any project that is set to repository-level security.
Different Permissions for Different Public/Reference Projects

If you want the same user to have different permissions for different public/reference projects (e.g., Jane Engineer has read-write access to all of Department A’s projects, but she has read-only access to other projects), follow these steps:

1. **Security Groups**: Create a security group for each distinct type of access that users might need in any particular public/reference project. Here’s a simple example:
2. **User Accounts:** Assign the appropriate security group(s) to each user account. For the example shown below, the user will have read/write permissions in projects that are assigned to "Department A," and read-only access in projects that are assigned to "Read-Only."

If some of the projects in the database will continue to use repository-level security, the **Allow access to projects with repository-level security** check box gives you the option to decide whether each user will be able to access those projects.

- If the option is selected (default), the user will be able to access any public/reference project that is set to use repository-level security, with the combined permissions from any of the assigned security groups.
• If the option is cleared, the user will only be able to access a project if it is specifically assigned to a security group that he/she belongs to, or if the user account is specifically assigned to the project.

3. **Project Security**: Assign the appropriate security group(s) and/or specific user(s) for every public/reference project in the database.

• When you assign a security group, every user who belongs to that group will be able to access the project with the permissions that are specified in the group.

• When you assign a specific user, the combined permissions from all of the security groups that the user belongs to will be displayed. Use the check boxes to select which of those permissions will be in effect for that user in this particular project.

For the example shown below, users from Department A will have read/write access (because they belong to the "Department A" security group), users from Departments B and C will have read-only access (because they belong to the "Read-Only" security group) and Fred Consultant will have read/write access (because he belongs to the "Consultants" security group and has been specifically assigned to have those permissions in this project).
User Accounts

Every person who will access a Synthesis repository, be assigned to some role in an assigned action, and/or receive alerts via e-mail or SMS message must have a personalized user account in the database.

- **In non-secure databases**, the software automatically creates an account for anyone who opens the file. Every user has full permissions throughout the database, including the ability to create, edit or delete other user accounts (e.g., so you can modify contact information or send alerts to someone who has not yet had an account created automatically).

- **In secure databases**, the accounts must be created and managed by users with the "Manage users and logins" permission. The security group(s) assigned to each account determines what the user can see and do in the database.

To view and manage the user accounts in a database, choose **File > Manage Repository > Users and Security**.
This topic describes how to use the Users and Security window to create, edit or delete/deactivate user accounts. The same window can also be used to enable login security for a standard database or Synthesis file, and to manage security groups (permissions) for a secure database.

**Built-in Find/Filter, Configuration and Grouping Tools**

The Users tab of the Users and Security window offers the same filter, column configuration and grouping tools that are built in to other utilities that use a similar grid (e.g., the Synthesis Explorer, Actions Explorer, etc.). For details about how to use each feature, see:

- Finding and Filtering Records
- Configuring Columns
- Grouping Panel

**Creating and Editing User Accounts**

The Users tab of the Users and Security window displays a table of all user accounts that have been created in the database. You can use the Add or Edit buttons below the table to create or modify individual accounts.

You can also import user accounts from Microsoft Active Directory by clicking the Active Directory button. (See Importing Users from Active Directory.)

Keep in mind the following requirements when creating new user accounts for a secure database:

- In order to use Windows authentication, the user must be logged in to a computer with the same domain/username that is defined in the user account. If a user needs to connect to a database from a different domain, you can set up alternative credentials that will allow access without domain authentication. (See Creating Alternative Credentials.)

- In order to access the database, the user account must be assigned to at least one security group. (If you simply wish to send e-mail alerts to the user, a security group is not required.)

- For SQL Server databases, the username must be associated with a "SQL Server Login" that allows the database platform to recognize the user and give access to the application database. This can be accomplished with an individual login, a group login or Windows impersonation. (See SQL Server Logins or Using Windows Impersonation.)

The Run As button below the table allows you to change your current connection to run as the user currently selected in the table. This allows you to test that user's permissions to be sure that they are set as you intended. Depending on the permissions that user has, you may have to close the repository and reconnect to it in order to change back to your own account.
Deleting or Deactivating User Accounts

If an account has never been used and you want to permanently remove it, select the account name from the list and click **Delete**.

If an account has already been logged in at least once (the **Last Login** column shows this information), attempting to delete the account will deactivate it instead. A deactivated account will not have access to the database.

You can manually deactivate an account by clearing the check box in the **Active** column for the account. To reactivate the account and give the user access to the database again, select the check box in the **Active** column.

User Login and Contact Information

The User Login and Contact Information window contains the contact information, alerts preferences and action resource details for an individual user. In a secure database, it also includes access settings (security groups and alternative credentials).

To view or edit your own user account, double-click your name in the MDI status bar or choose **My Portal > Users > My Profile**.

To view or edit any user account in the database, choose **File > Manage Repository > Users and Security**, then double-click any row in the Users table. (In a secure database, this is available only for users with the **Manage users and logins permission**.)
All of the user account options are described below. Some of these settings cannot be modified when you are editing your own profile.

**User Info Tab**

- **Domain** and **Username** contain the credentials used by Windows authentication to identify the user and give him/her access to the database.

- **Contact Details**. Each user can update his/her own contact details, if desired. Note that the Display Name will appear in all projects, analyses and plots you create or modify in the database. Click the **Active Directory** button to update the contact details based on information stored in Active Directory.

- **User Image**. Each user can save a profile photo, which will appear in locations such as the **User Page** of My Portal. Saved images are resized to 100 x 100 pixels.

- **Security Groups** control the user's access to the database. (See [Managing Security Groups](#).)

- **Allow access to projects with repository-level security**
  - If the option is selected (default), the user will be able to access any public/reference project that is set to use repository-level security, with the combined permissions from any of the assigned security groups.
  - If the option is cleared, the user will only be able to access a project if it is specifically assigned to a security group that he/she belongs to, or if the user account is specifically assigned to the project.

  For more information, see [Planning Your Security Approach](#).

- **Update security groups upon login (if associated with Active Directory)**
  - If the option is selected (default), the user's security groups will be assigned automatically based on his/her security group in Active Directory. (See [Associating Security Groups with Active Directory](#).)
  - If the option is cleared, the user can be manually assigned to any of the available security groups.

- **Active**. Clear or select the check box to deactivate or activate the account. A deactivated account will not have access to the database.

**Alerts/Actions Tab**

- **Receive automated alerts**. Each user can choose to receive alerts via e-mail, SMS text message or ReliaSoft portal messages. (See [Watches and Alerts](#) and [What is Your SMS Address?](#)) Note that alerts via e-mail and SMS text are available only if a valid SMTP
server has been defined for the database and the user account has an e-mail address/SMS contact defined.

- **When assigned to actions.** When a user account is assigned to an action (either as the Person Responsible or as part of the Team resource), the **Cost Category** and **Hours per Day** are used to calculate resource utilization and costs. (See [Costs and Man Hours](#).)

**Alternative Credentials Tab**
The Alternative Credentials tab is available only for secure databases. Select the check box to allow the user to bypass Windows authentication and connect to the database using an alternative username and password. (See [Creating Alternative Credentials](#).)

**Importing Users from Active Directory**
If your organization uses Microsoft Active Directory, this topic explains how to import username and contact information from the directory to create new user accounts in the Synthesis repository. (If you also wish to use Active Directory to manage the membership in security groups, see [Associating Security Groups with Active Directory](#).)

To import users from Active Directory, choose **File > Manage Repository > Users and Security**, click the **Active Directory** button, and then follow these steps:

1. Enter or select the domain name in the **Domains** field. If your organization’s directory is large, you may also choose to limit the search to specific groups by clicking **Load Groups** and then choosing an option from the drop-down list. You can also use the **Filter By** field to further limit the search. When you have specified the desired filters, click **Load Users** to update the table.

2. In the table of user accounts that match the filter criteria, select the check box for each user you want to create an account for. (The names of users who already have an account in the current database will appear grayed out.)
3. For secure databases only, use the **Import as Members Of** field to select the security group(s) that will be assigned to the new user account(s). If you skip this option now, you can assign security groups later for each individual account. (See [Managing Security Groups](#).)

4. For SQL Server databases only, select the **Create SQL Server login** check box if you want to create an individual SQL Server login for each new user account. (See [SQL Server Logins or Using Windows Impersonation](#).)

5. Click **Import** to create the account(s). After the process completes, the window will remain open to allow you to import additional users, if desired.

### Creating Alternative Credentials

**Secure databases** use Windows authentication by default. This means that users must be logged in to a computer using the same domain and username specified for their user accounts. You can, however, allow specific users to bypass Windows authentication as needed. This may be useful for situations where:

- A user needs to work on a copy of a secure standard database or Synthesis file on a computer that is not connected to the company's network.

- A user needs to connect to an enterprise database from a different domain.

For these situations, you can set up alternative credentials for a user’s account that will allow that user to access the database without domain authentication. These credentials must be set up in advance, before the user attempts the connection.

If you have the "Manage users and logins" permission, you can create alternative credentials for a user account by following these steps:

1. Open the Users and Security window (File > Manage Repository > Users and Security). On the Users tab, select the account name from the list and click **Edit**.

2. In the User Login and Contact Information window, click the **Alternative Credentials** tab and then select the check box to enable alternative credentials.
Chapter 2: Repositories and Projects

3. With the setting enabled, create an alternative username and password for the account. The username and password must be unique within the database, and the password is Case Sensitive.

![Alternative Credentials](image)

Once you have created the credentials, instruct the user to enter this login whenever the database prompts for it. The database will ask for the alternative credentials whenever the user account cannot be matched based on domain authentication.

*Tip:* The first time you connect to a database using alternative credentials, the application will automatically remember the login information on your computer. If you wish to clear the saved login, you can click the **Clear Alternative Credentials** link on the **Other Synthesis Settings page** of the Application Setup.

**User Groups**

The User Groups window (formerly called “Notification Groups”) allows you to create and manage groups of users that can be assigned throughout the current database for:

- Recipients for **portal messages**
- Monitors for **assigned actions**
- Team members in the **Project Planning Resources**

To access the window, choose **File > Manage Repository > User Groups**.

In a secure database, this is available only for users with the **“Manage users and logins”** permission.

**Adding or Editing a Group**

The table displays a list of the user groups that have already been defined in the current database.

To add a new group, click **Add**.
To view or edit an existing group, double-click the row or select the row and click **Edit**.

The **Available Users** list shows all of the user accounts in the current database that are not yet assigned to the group. Double-click or use the buttons to move at least one user into the **Selected Users** list.

**Deleting a Group**

To delete an existing group, select a row and click **Delete** or press the **DELETE** key.

If the user group has been assigned to any existing actions, messages or project planning teams, the group will be removed automatically and those users will no longer be assigned in the affected records. **There is no undo for delete.**

**Managing Security Groups**

In a secure database, *security groups* control what users can see and do in the database. By default, the software includes four predefined security groups: Admin, Power, User and View. The Admin group, which has full permissions throughout the database, can neither be deleted nor have its permissions modified. For the other predefined groups, you can edit their permissions or replace them with new groups that fit the specific way the database will be used.

As discussed in **Planning Your Security Approach**, there are two basic approaches you can use:

- **Same permissions for all public/reference projects** – each user account is assigned to one security group and all public/reference projects use the default security option (repository-level security).

- **Different permissions for different public/reference projects** – each user account may be assigned to multiple security groups and each public/reference project may be accessed only by specific security groups and/or users.

**Note:** New in Version 2018, if your organization has implemented a Synthesis Enterprise Portal (SEP) website for an enterprise repository and the site is configured to enable access by nCode Aqira users, a special "Aqira" security group will be created. This security group cannot be deleted, but you can modify the permissions that will be available to Aqira users. (See [Allow Aqira Users to Access SEP](#).)

**Creating, Editing or Deleting Security Groups**

You can manage the security groups by choosing **File > Manage Repository > Users and Security**. (In a secure database, this is available only to users with the "Manage users and logins" permission.)
Chapter 2: Repositories and Projects

In the Users and Security window, click the Security tab to see all the security groups that have been created in the database. Use the Add, Edit or Delete buttons below the table to manage the groups.

When you edit a security group, the left side of the Security Group window allows you to choose the permissions, while the right side shows all the users currently assigned to the group.

If you have selected to Associate this security group with an Active Directory group, the list of assigned users can be updated automatically, or you will only be able to manually import/assign users who belong to the designated Active Directory group. (See Associating Security Groups with Active Directory.)

Permissions
Here is a summary of all the permissions that can be granted to a particular security group.
**Basic permissions throughout repository**
These permissions apply throughout the database if they are in any of the security groups that the user belongs to. These permissions do not depend on the security settings for a particular project.

<table>
<thead>
<tr>
<th>Permission Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create and own private projects</td>
<td>You can create and own private projects in the database that are accessible only to you. (Users with the &quot;Manage all private projects&quot; permission can still perform administrative tasks on all private projects, such as editing their properties, locking them, converting them to public projects, etc.)</td>
</tr>
<tr>
<td>Create and own public projects</td>
<td>You can create and own public projects that other users can view and edit (depending on the project security settings).</td>
</tr>
<tr>
<td>Create and own reference projects</td>
<td>You can create and own reference projects for sharing resources and FMEAs with other projects in the database (depending on the project security settings).</td>
</tr>
<tr>
<td>Create portal messages</td>
<td>You can create new messages, and edit or delete the messages you have personally created via the Messages page in My Portal.</td>
</tr>
<tr>
<td>Publish to Synthesis Enterprise Portal</td>
<td>You can publish your progress, results and analyses from a given project to the Synthesis Enterprise Portal (SEP), making the information accessible from any web-enabled device.</td>
</tr>
<tr>
<td>Create/edit/delete SDW data collections</td>
<td>You can create, edit and delete data collections in the Synthesis Data Warehouse (SDW). This includes data extraction from XFRACAS as well as custom connections, and confers the ability to create dashboard layouts for custom connections.</td>
</tr>
</tbody>
</table>
Basic and advanced permissions at project level
A user can have these permissions in some projects but not others, depending on the project security settings. Regardless of the project security settings, these permissions are always automatically granted to the current project owner and anyone else that can manage the project.

<table>
<thead>
<tr>
<th>Permission</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read</td>
<td>You can perform tasks that do not modify the data in the project (e.g., view the analysis, calculate metrics in a Quick Calculation Pad, export data, etc.).</td>
</tr>
<tr>
<td>Create/edit project items</td>
<td>You can create and edit items in a given project such as folios in Weibull++/ALTA, diagrams in BlockSim, system hierarchy items in Xfmea/RCM++/RBI, etc., as well as update the item properties.</td>
</tr>
<tr>
<td>Create/edit/delete own resources</td>
<td>You can create resources (e.g., URDs, models, etc.) and edit or delete any existing resources you have created.</td>
</tr>
<tr>
<td>Delete project items</td>
<td>You can delete any item in a given project (e.g., folios in Weibull++/ALTA, diagrams in BlockSim, system hierarchy items in Xfmea/RCM++/RBI, etc.). This permission cannot be assigned unless you also have the &quot;Create/edit project items&quot; permission.</td>
</tr>
<tr>
<td>Create/edit project plans</td>
<td>You can create and edit project plans for a given project.</td>
</tr>
<tr>
<td>Create/edit/delete local resources</td>
<td>You can create, edit and delete any local resources in the project (not just the ones that you created).</td>
</tr>
<tr>
<td>Set project security</td>
<td>You can control who can view and edit a given project. This permission allows you to configure both project security settings and item permissions.</td>
</tr>
<tr>
<td>Edit project properties</td>
<td>You can use the Project Properties window to edit the name, description, category and other settings of a given project.</td>
</tr>
<tr>
<td>Lock or check out project</td>
<td>You can:</td>
</tr>
<tr>
<td></td>
<td>• <a href="http://predict.reliasoft.com">Lock and unlock</a> a given project.</td>
</tr>
<tr>
<td></td>
<td>• <a href="http://predict.reliasoft.com">Check in and check out</a> a given project.</td>
</tr>
<tr>
<td><strong>Create restore points</strong></td>
<td>You can utilize <a href="#">restore points</a> for a given project, which are exact replicas of the project at a particular point in time (i.e., backups).</td>
</tr>
<tr>
<td><strong>Delete project</strong></td>
<td>You can delete a given project.</td>
</tr>
<tr>
<td><strong>Manage change logs in Xfmea/RCM++/RBI</strong></td>
<td>You can enable and manage change logs within a given project. Change logs can be created for FMEAs, DVP&amp;R, Control Plan and P-Diagram analyses in Xfmea, RCM++ and RBI. See <a href="#">Change Logs</a> in the Xfmea/RCM++/RBI documentation.</td>
</tr>
<tr>
<td><strong>Approve change logs in Xfmea/RCM++/RBI</strong></td>
<td>You can implement electronic approval tracking for change logs within a given project. See <a href="#">Electronic Approval Tracking</a> in the Xfmea/RCM++/RBI documentation.</td>
</tr>
</tbody>
</table>
**Chapter 2: Repositories and Projects**

**Administrative permissions throughout repository**
These permissions apply throughout the database if they are in any of the security groups that the user belongs to. These permissions do not depend on the security settings for a particular project.

<table>
<thead>
<tr>
<th>Manage users and logins</th>
<th>You can:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>- Use the <a href="http://predict.reliasoft.com">Users and Security window</a> to add user accounts to the database and define security groups, as well as create <a href="http://predict.reliasoft.com">alternative credentials</a> for user accounts.</td>
</tr>
<tr>
<td></td>
<td>- Use the <a href="http://predict.reliasoft.com">User Groups window</a> to add and manage distribution groups for e-mail alerts, portal messages, action alerts and projecting planning resources.</td>
</tr>
<tr>
<td></td>
<td>- Use the <a href="http://predict.reliasoft.com">Repository Logins window</a> to view and export a history of database logins.</td>
</tr>
<tr>
<td></td>
<td>- Use the <a href="http://predict.reliasoft.com">Reset &quot;In Use&quot; Flags window</a> to clear the &quot;in use&quot; status for selected database users (not just your own).</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Manage project planning resources and working days</th>
<th>You can:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>- Use the <a href="http://predict.reliasoft.com">Project Planning Resources window</a> to manage the cost categories, teams, materials and facilities that are used for tracking resource utilization in Project Planner gates and actions.</td>
</tr>
<tr>
<td></td>
<td>- Use the <a href="http://predict.reliasoft.com">Working Days/Holidays window</a> to specify the business days that will be used for Project Planner gates and actions.</td>
</tr>
</tbody>
</table>

| Manage project/item categories | You can use the [Project/Item Categories window](http://predict.reliasoft.com) to define the project and item categories that can be used for grouping and filtering projects and items in the database. |
## Manage other repository settings

You can:

- Use the [Unit Settings window](#) to define the unit and measurement settings available for use in any project within the database.
- Use the [Default Name Formats window](#) to specify how default names for resources and blocks are created.
- Use the Task Types window in RCM++, RBI and MPC.
  - In RCM++ and RBI, you can map the task types that are used only in RCM++/RBI to the task classes in the universal reliability definition (URD). See [Task Types in RCM++/RBI](#) in the RCM++/RBI documentation.
  - In MPC, you can modify the abbreviations used for MSG-3 task types. See [Task Type Abbreviations in MPC](#) in the MPC documentation.
- Use the [Repository Settings window](#) to set some default settings for existing and new databases. This includes enabling e-mail alerts for the database, activating history logs, etc.
- Set up [XFRACAS connection settings](#) that allow ReliaSoft desktop applications to access the XFRACAS data stored in the database. This is available only for standard databases (*.rsr18).

## Create/edit/delete global resources

You can create, edit and delete any [global resources](#) in the project (not just the ones that you created). In addition, you can transfer data from [XFRACAS to the SDW](#).

## Approve actions

You can review and approve [actions](#), which are resources that allow you to track progress made in a project.

## Manage all portal messages

You can edit or delete any messages that are visible to you via the Messages page in [My Portal](#). This includes any messages for which you are the creator or one of the recipients.

## Manage dashboard layouts

You can create and save layouts for use in the [Dashboard Viewer](#) in Weibull++, BlockSim and RGA.
### Manage profiles and templates in Xfmea/RCM++/RBI

This permission is available only in enterprise databases. You can:

- Use the Profiles/Library Manager window in Xfmea/RCM++/RBI to configure the predefined settings stored in the active library of the enterprise database. See Profiles/Library Manager in the Xfmea/RCM++/RBI documentation.

- Use the Templates Manager window in Xfmea/RCM++/RBI to configure report templates stored in the enterprise database. See Templates Manager in the Xfmea/RCM++/RBI documentation.

### Manage Lambda Predict repository settings

You can:

- Use the FIDES Settings Manager window in Lambda Predict to configure the FIDES-related settings stored in the database. This applies to the FIDES prediction standard only (see FIDES Settings Manager in the Lambda Predict documentation).

- Use the Custom Derating Standards Manager window in Lambda Predict to create, edit or delete user-defined derating standards stored in the database. See Creating Custom Derating Standards in the Lambda Predict documentation.

- Use the MIL-217 Custom Connections window in Lambda Predict to define failure rates for user-defined connectors stored in the database. This applies to the MIL-217 prediction standard only. See MIL-217 Custom Connection Types in the Lambda Predict documentation.
## Chapter 2: Repositories and Projects

### Manage MPC Settings

You can:

- Use the Manage ATA Chapters window in MPC to define the systems and subsystems that are available for use in the database. See Managing ATA Chapters in the MPC documentation.

- Use the Manage Major Zones window in MPC to define the zones and major sub-zones that are available for use in the database. See Managing Major Zones in the MPC documentation.

- Use the Configurable Options for Systems and Powerplant Analysis window in MPC to enable or disable the display of some item properties and task properties fields. See Configurable Options for Systems and Powerplant Analysis in the MPC documentation.

- Use the Configurable Options for Structural Analysis window in MPC to customize the settings for environmental deterioration (ED) and accidental damage (AD) analyses that can be performed for any structural item in MPC Plus. See Configurable Options for Structural Analysis in the MPC documentation.

- Use the Configurable Options for Zonal and L/HIRF Analysis window in MPC to customize the settings for the standard zonal, enhanced zonal and L/HIRF analyses that can be performed for any zonal item in MPC Plus. See Configurable Options for Zonal and L/HIRF Analysis in the MPC documentation.

### Manage all public projects

You have all the basic and advanced project-level permissions for public projects in the database. You can also change the project owner for any public project in the database.

### Manage all reference projects

You have all the basic and advanced project-level permissions for reference projects in the database. You can also change the project owner for any reference project in the database.

### Manage all private projects

You have all the basic and advanced project-level permissions for private projects in the database. You can also change the project owner for any private project in the database.
Associating Security Groups with Active Directory

If your organization uses Microsoft Active Directory (AD), you can give an AD group a specific set of permissions in the Synthesis repository. The members of the AD group can then access the database based on the set of permissions associated with the group.

In addition, the software offers the option to automatically update the permissions of a user whenever that user is added or removed from an AD group. For example, if a user is moved from AD group A to AD group B, his/her user account can be automatically updated with the permissions associated with AD group B. The changes will take effect the next time the user connects to the database via any of the ReliaSoft desktop applications. (Note that for users who will connect only via the Synthesis Enterprise Portal (SEP) website, you’ll need to update their permissions manually either via a desktop application or the ReliaSoft Admin tool on the web server.)

Tip: Multiple security groups can be assigned to the same user account, if appropriate. For example, a user can be assigned to the "ABC Team" group (which is associated with Active Directory) and the "Read-Only" group (which is not). (See Planning Your Security Approach.)

Assigning Permissions to an Active Directory Group

To associate a security group with an Active Directory group, choose File > Manage Repository > Users and Security and click the Security tab. Then double-click the security group you want to edit.

In the Edit Security Group window, select the Associate this security group with Active Directory check box, and then specify the domain name and Active Directory group to use. There are two additional options, which apply only when users log in from a ReliaSoft desktop application:

- **Automatically update this security group's members.** If a user is added to the AD group, his/her user account will automatically have this set of permissions the next time the user logs in to the database via any of the ReliaSoft desktop applications. Likewise, if the user leaves the AD group, his/her user account will no longer have this set of permissions.

  If you do not want the changes in Active Directory to be automatically applied to a particular user, clear the Update security groups upon login check box in that user's account in the Synthesis repository.

- **Automatically create new user accounts on first login.** If a member of the AD group does not already have a user account, it will be created automatically (and assigned to
this security group) the first time he/she tries to connect via any of the ReliaSoft desktop applications.

Creating/Updating Accounts Now
If you don’t want to wait for all users to log in before creating/updating their user accounts, click the Assign button at the bottom of the window.

- To create new accounts, choose **Import users who are members of this Active Directory group**. This opens the Import Users from Active Directory window, but you can only choose users from the associated Active Directory group.

- To update the security groups for existing accounts, choose **Assign existing repository users who are members of this Active Directory group**. This shows a list of existing users who also belong to the associated Active Directory group; you can select to update any or all of their accounts.
Setting Item Permissions

In a secure database, all project items (e.g., folios, diagrams, system hierarchy items, etc.) are, by default, set to inherit their permissions from the project. This means that if a user has the "Create/edit items" permission for the project, he or she will be able to edit all of the items by default. If you want to prevent some or all of those users from editing a particular item (i.e., lock or limit access to the item), you can use the Item Permissions window.

The window functions a little differently depending on whether you’re working with items in a project explorer (e.g., folios, diagrams, etc.) or items in a system hierarchy.

Project Explorer Items

In Weibull++, ALTA, BlockSim, RENO, RGA or Lambda Predict, select the item in the current project explorer and choose Project > Current Item > Item Properties. (In a secure database, this is available only if the user a) is the project owner, b) has the "Set project security" permission, or c) has the applicable "manage all projects" permissions.)

The settings are displayed on the Permissions tab of the properties window.

In the Item Permissions window, select the **Restrict editing to selected project users** option and then select which specific users will be able to edit this particular item. All others can view, but not edit, the item. Only users with editing rights to the project will appear in the list.

To remove item permissions and change the security settings back to the defaults, select the **Inherit from project** option.

System Hierarchy Items

In Xfmea, RCM++ or RBI, select the item and choose System Hierarchy > Current Item > Item Permissions. In MPC, select an item and choose [Systems/Structures/Zones] > Security > Item Permissions. (In a secure database, this is available only if the user a) is the project owner, b) has the "Set project security" permission, or c) has the applicable "manage all projects" permissions.)

In the Item Permissions window, you can choose to:

- Define the permissions for the item by selecting the **Restrict editing to selected project users** option and then selecting which specific users will be able to edit this particular item. All others can view, but not edit, the item. Only users with editing rights to the project will appear in the list.
- Set the item to inherit the same permissions as the next item above it in the system hierarchy by selecting the **Inherit from parent item** option.
- Remove item permissions and change the security settings back to the defaults by selecting the Inherit from project option.

If you select the Apply to all dependents check box, the software will automatically set the permissions for all next-level items in this branch of the hierarchy to match the item you are currently editing. For example, consider a case where each item in an Xfmea system hierarchy has different permissions, as shown next.

For a quick way to reset all of the item permissions to the defaults, you can open the Item Permissions window for SubSystem 1, set to Inherit from parent item and select the Apply to all dependents check box. The resulting system hierarchy is shown next.

### Status Indicators
ReliaSoft desktop applications include status indicators that tell you which project items (e.g., folios, diagrams, system hierarchy items, etc.) are in use or restricted.

When you encounter an item that is read-only (e.g., OK button is disabled in the window or you are unable to type in the cells of a worksheet or table), you can check the status of the item to see if it is currently in use (i.e., you can’t edit the item until the user closes the folio/diagram...
or selects a different item in the hierarchy) or restricted (i.e., you don’t have permissions to edit the item). If the item is in use, move the pointer over the icon to identify the user.

The location of these status icons will vary depending on which ReliaSoft application you are using:

- In projects that use a current project explorer to manage analysis data, the status icons are displayed next to the item’s name in the current project explorer, as in the example shown next.

![Project Explorer Example](image)

- In projects that use hierarchical trees to manage analysis data (as seen in the Xfmea, RCM++, RBI and MPC applications), the status icons are displayed in the User Access column of the system hierarchy. (To hide or display columns, right-click the column headings, then click Customize Columns to select which columns you want to display.)

![Hierarchical Tree Example](image)

**Tip:** The application interface refreshes automatically whenever you make a change (e.g., close a project, create a resource, select a different item, etc.). If your computer will not let you edit an item that is in fact not currently being edited by another user, it could be because your computer has not been recently refreshed with the latest changes made by other database users. You can initiate the
refresh manually by choosing View > Refresh.

In addition, the software employs “in use” flags within the database to record when an analysis is currently being edited by a particular user. If the refresh still does not show that the item has been released, then something might have occurred to prevent the flags from being reset correctly (e.g., a network interruption or if the software closes unexpectedly). Refer to the Reset “In Use” Flags topic for instructions on how to reset the flags throughout the database if this problem occurs.

Reset "In Use" Flags

Because Synthesis repositories allow simultaneous access by multiple users, it is necessary to store “in use” flags within the database to indicate when a particular portion of the analysis is currently being edited by a particular user. There are some circumstances when these flags might not be reset correctly when a user stops editing an analysis (e.g., if there is a network interruption or if the software closes unexpectedly). If that occurs, then the analysis will be locked for editing because the software receives an erroneous indication that it is still in use by another user.

To correct the problem, it is necessary to reset some or all of the “in use” flags within the database. To reset the flags, choose File > Manage Repository > Reset 'In Use' Flags.

(In a secure database, this is available only for users with the "Manage users and logins" permission.)

This opens the Reset 'In Use' Flags window, which shows all users who have an account in the database. (If you are working in a non-secure database, any user who has ever opened the database will have an account created automatically and will be shown in this list.) A status light is displayed for each user; if it is "lit up" (i.e., green), the user is currently logged in to the database. In addition, the Connections column shows the ReliaSoft application(s) that the user currently has connected to the database. You can select the check box for each user for whom you want to reset "in use" flags, then click OK to reset the flags.

**IMPORTANT:** It is important to make sure that no selected user is currently logged in to the database when you use this command. Users currently logged into the database can be viewed on the Users Page of My Portal.
Chapter 2: Repositories and Projects

Repository Logins
The Repository Logins window displays a record of the date and time the users in the database logged in. To open the Repository Logins window, choose File > Manage Repository > Repository Logins. (In a secure database, this is available only for users with the "Manage users and logins" permission.)

The following options are available:

- Use the Most Recent filter to display in the table the last 10; 100; 10,00 or 10,000 users who logged in to the database.
- Use the User filter to specify whether the table will display the logs for all users or display only the logs for a selected database user.
- Click the Send to Excel button to export the data currently displayed in the table to an Excel spreadsheet.
- Click the Clear Logins button to clear the entire history of users who logged in to the database. Since this action cannot be undone, you will be prompted to confirm that you want to proceed before the records are erased.

Users currently logged into the database can be viewed on the Users page of My Portal.

Repository Settings
The Repository Settings window contains settings that are shared by all users and analysis projects in the database. To access this window, choose File > Manage Repository > Repository Settings. (In a secure database, this is available only for users with the “Manage other repository settings” permission.)

In a standard database or Synthesis file, you can save the current settings as the default for each new standard database/Synthesis file that you create from this computer by clicking the Set as Default button at the bottom of the window.

What’s Changed? In prior versions, these preferences were defined in the E-mail and Other Settings window.
Chapter 2: Repositories and Projects

**E-mail Settings Page**

- **Enable Alerts via E-mail or SMS** configures the database to enable alerts via e-mail or SMS text message. (See [Enable Alerts via E-mail or SMS](#).)

- **Action Alerts** apply to action resources. The database can be configured to auto-subscribe a "watch" for users based on their role(s) for a particular action. You can also specify the default text that will be used at the beginning of each action alert. (See [Action Alert Preferences](#).)

**Other Settings Page**

- **FMEA Structure (Xfmea/RCM++/RBI)** allows you to select the default FMEA structure for new projects created in the database, which determines how the software will display the effect and cause records in the FMEAs. If you don't specify a default, users will be prompted to select the structure for each new project they create in Xfmea/RCM++/RBI. (See [Choosing the FMEA Structure](#) in the Xfmea/RCM++/RBI documentation.)

- **History Logs** allows you to turn the log on (or off) for all active projects, and stores a preference for whether the log should be activated by default for each new project. (See [History Logs](#).)

- **Actions** allows you to automatically set the person who created an action to be the person responsible for it. (See [Person Responsible and Resources](#).)

- **Enable publish to Synthesis Enterprise Portal** is available only in enterprise databases. If your organization has established a web-based Synthesis Enterprise Portal (SEP) for the current database, select this check box to enable users to publish analysis summaries, Synthesis Workbooks and other information to the portal.

- **Delete Portal Messages** deletes all portal messages for all users in the database. *There is no undo for deleting portal messages.*

**Unit Settings**

Synthesis repositories are pre-configured with a set of units for use with any analysis in any project within the repository. The conversion factors are predefined, allowing you to easily express results in terms of other units. For example, you can enter data into a Weibull++ data sheet in terms of hours and then obtain results from the QCP in terms of years. Similarly, in RCM++, RBI or BlockSim, you can define the duration of a maintenance task in terms of hours and specify the total operating time of a system in terms of months. In MPC, the units can be used to define task intervals.
**IMPORTANT:** Making changes to the existing units can have implications for all analyses throughout the database; therefore, it is best to set up units once, upon creation of the database.

To define units, choose **File > Manage Repository > Unit Settings.** (In a secure database, this is available only to users with the "Manage other repository settings" permission.)

If you're working in Weibull++, the Warranty Units tab will be available. It allows you to specify which of the configurable repository units are equivalent to the built-in (not configurable) "warranty time units" used in some warranty folio formats. For details, see **Manage Warranty Units** in the Weibull++/ALTA documentation.

**Setting SBU Equivalencies**

The conversion factor of a unit is defined in relation to a system base unit (SBU). A base unit is a standard unit of measurement upon which other units can be based. Base units always have a conversion factor of 1. All other related units are converted back to the base unit.

For example, say that we choose kilograms (kg) as our SBU for mass. The conversion factor of related units, such as pounds (lb) and metric tons (T), must be entered in terms of the SBU:

<table>
<thead>
<tr>
<th>Unit</th>
<th>SBU Equivalency (using kg as the base unit)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 kg</td>
<td>1 kg</td>
</tr>
<tr>
<td>1 lb</td>
<td>0.4536 kg</td>
</tr>
<tr>
<td>1 T</td>
<td>1000 kg</td>
</tr>
</tbody>
</table>

Similarly, if we change the base unit to pounds (lb), the conversion factors must reflect the change:

<table>
<thead>
<tr>
<th>Unit</th>
<th>SBU Equivalency (using lb as the base unit)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 kg</td>
<td>2.2046 lb</td>
</tr>
<tr>
<td>1 lb</td>
<td>1 lb</td>
</tr>
<tr>
<td>1 T</td>
<td>2204.62 lb</td>
</tr>
</tbody>
</table>
By default, Synthesis repositories use hours (hr) as the SBU for time, and miles (mi) as the SBU for length. To ensure that you obtain correct results when converting units, it is recommended that you set an SBU for each type of measurement (e.g., time, length, frequency, force, etc.) and define the conversion factors of all other units in terms of the relevant SBU.

**Changing the Default Unit**
You can set any unit as the default by selecting it in the **Use as Default** column. The software will automatically use the new default unit when you create a new analysis or resource in any project in the repository. The change will not affect existing analyses and resources.

**Creating and Deleting Units**
To add a new unit, click the **Add** button below the table and follow the on-screen prompts to create the unit. The wizard will automatically calculate and apply the appropriate SBU equivalency based on your inputs.

To delete a unit, click the **Delete** button below the table. **There is no undo for delete.**

**Editing Existing Units**
Click a cell to edit a unit’s name, abbreviation, SBU equivalency and category. To apply your changes, click the **Save** button at the bottom of the window.

Note that if you will be using the usage format of the Weibull++ warranty folio, only the units assigned to the Usage category will be available for those analyses; units assigned in the Time category are not available in the warranty usage format.

**Built-in Find/Filter, Configuration and Grouping Tools**
You can move a unit up or down its current position by dragging the row to the desired position, or by selecting it and using the **Move Up** or **Move Down** buttons.

To show more tools, right-click any column header. The window offers the same filter, column configuration and grouping tools that are built in to other utilities that use a similar grid (e.g., the Resource Manager). For details about each feature, see:

- Finding and Filtering Records
- Configuring Columns
- Grouping Panel

**Default Name Formats**
In all ReliaSoft desktop applications except MPC, the Default Name Formats window specifies the default names for new resources, as well as new blocks in BlockSim RBDs, fault trees and
Chapter 2: Repositories and Projects

phase diagrams. For example, when you create a new model, the default name will be the word "Model" plus an increment to make the name unique (e.g., "Model," "Model_1," etc.). You can configure the database to use a different default name format if desired.

To open the window, choose File > Manage Repository > Default Name Formats. (In a secure database, this is available only for users with the "Manage other repository settings" permission.)

The Resource Name column displays the basic name label for each type of resource or block. This will be represented by the \N code in the name format.

The Name Format column allows you to use any of the following elements to define the default name format for each type of resource or block:

- \N returns the label from the Resource Name column plus an increment to make the name unique (e.g., "Model," "Model_1," etc.).
- \U returns the name of the user who created the resource or block.
- \D returns the date when the resource or block was created.
- \S adds a sequential number that reflects the order in which the resource/block was added to the database.
- \T returns the ReliaSoft application ("tool") used to create the resource or block.
- \F returns the contents of all of the identifier fields except the category and comments fields.
- \G returns a summary of the properties of the resource or block. For example, for a node in a BlockSim diagram, \G returns the "k out of n" paths that are required.
- \I is only applicable for resources. It functions the same as \N unless there is another window, resource or analysis that it can "inherit" part of the name from. Some examples:
  - If you create a URD from BlockSim’s block properties window, the default name will be "[Block Name]_URD."
  - If you create a metric based on a model, the default name will be "[Model Name]_Metric."
  - If you push a metric from a Project Planner gate, the default name will be "[Gate Name]_[Property Name]_Metric."
Tip: In BlockSim diagrams, you can use an asterisk (*) to insert the default block name. For example, if you enter *System for the block name, the diagram will display the default name for the block followed by the word "System." The asterisk also allows the block name to be updated dynamically when relevant properties change.

Project Planning Resources

In all ReliaSoft desktop applications except MPC, project planning resources can be assigned to actions in order to track the required costs and time in the Project Planner and anywhere else that actions are used. Because project planning resources are shared throughout the database, any change made to one is automatically applied to all actions in the database that use it.

- **Cost Categories** specify direct and/or per instance costs that can be assigned to any team member, facility or material.
- **Teams** identify groups of users who will work together on any given action.
- **Facilities** specify the cost and maximum utilization for facilities (e.g., test lab) or other resources for which the cost depends on the duration of use (e.g., rented test equipment).
- **Materials** specify the cost and quantity for materials (e.g., test units) or other resources for which the cost depends on the amount used rather than the duration (e.g., purchased usage data).

To open the Project Planning Resources window, choose File > Manage Repository > Project Planning Resources. (In a secure database, only users with the “Manage project planning resources and working days” permission will be able to create and edit these resources; other users can select from the resources that have already been predefined.)

Cost Categories

Cost categories can be created from the Project Planning Resources window, or when you are creating/editing a facility, material or individual user account. Enter the Currency Symbol to use for displayed costs at the bottom of the window.

- The **Direct Cost per Hour or Unit** is the per-hour cost when assigned to a team member or facility, or the per-unit cost when assigned to a material (e.g., the cost of a single light bulb).
- The **Cost per Instance** is a one-time cost that applies every time a team, facility or material is used.
Chapter 2: Repositories and Projects

Teams
Teams can be created from the Project Planning Resources window, or when you are defining an action. A team can include:

- Individual Users who have active user accounts in the database.
- Groups of active user accounts that have been predefined in the database.

Note that you cannot assign a cost category directly to a team. Instead, the team's cost/utilization is based on the cost category and maximum hours per day for each team member. Both of these properties are set on the Alerts/Actions tab of the User Login and Contact Information window.

Facilities
Facilities can be created from the Project Planning Resources window, or when you are defining an action.

- The Cost Category specifies the facility's hourly and/or per-use costs.
- The Max Hours Per Day is the number of hours of use if the facility is set to be 100% utilized for a given action (as specified in the action properties).

Materials
Materials can be created from the Project Planning Resources window, or when you are defining an action.

- The Cost Category specifies the cost per unit (e.g., the cost for each test prototype), as well as any additional fixed cost (e.g., the cost for manufacturing a sufficient number of test prototypes).
- The Quantity that will be used (e.g., 100 light bulbs).

Working Days/Holidays
In all ReliaSoft desktop applications except MPC, actions and Project Planner gates contain important dates like start dates and due dates. You can specify which dates will be considered working days for all actions and gates in the repository. This way, an action's cost/time estimates, as well as its duration, will be based solely on working days.

To define the working days for the repository, choose File > Manage Repository > Working Days/Holidays. (In a secure database, this is available only for users with the "Manage project planning resources and working days" permission.)
In the window that appears, use the Define Work Week area on the left side to specify which days of the week will be considered regular working days (e.g., Monday-Friday).

Define Holidays
On the Define Holidays tab, you can define three different types of holidays.

- **Fixed Date - Recurring** holidays occur every year on the same calendar date (e.g., New Year’s Day is always January 1).
- **Variable Date - Recurring** holidays occur every year, but not always on the same date (e.g., Thanksgiving is always the fourth Thursday of November).
- **Fixed Date - Non-recurring** holidays occur once and do not happen again. For example, a specific Monday could become a non-working day due to weather conditions.

In the Holiday Properties window, select Move to adjacent working day if necessary to make sure the holiday will be observed when a) it occurs outside the work week, but b) there is a regular working day immediately before/after it. In this case, the holiday is observed on the nearest working day. (If there is a working day immediately before and after the holiday, it is observed on the following day.)

View Observed Holidays
The View Observed Holidays tab allows you to easily examine the names and dates of all holidays that will be observed during the work week, and can also help you make sure your working days/holidays settings are correct. Specify the years you want to view in the Displayed Range in Years area.

XFRACAS Connection
XFRACAS is a web-based, closed-loop, incident (failure) reporting, analysis and corrective action system designed for the acquisition, management and analysis of product quality and reliability data from multiple sources. There are several ways in which you might wish to share data between XFRACAS and the analyses that you perform in ReliaSoft desktop applications:

- Use the Synthesis Data Warehouse in Weibull++/ALTA or RGA to extract data from XFRACAS incidents. (See Synthesis Data Warehouse.)
- Share system configuration and failure mode data between XFRACAS and Xfmea/RCM++/RBI. (See Import or Sync from XFRACAS in the Xfmea/RCM++/RBI documentation.)

When you are working with an enterprise database, the data from XFRACAS and ReliaSoft desktop applications can be stored in the same SQL Server or Oracle database.
When you are working with a standard database (*.rsr18) or Synthesis file (*.rsf18), you will need to establish a connection to an enterprise database that contains XFRACAS data. To do this, choose File > Manage Repository > XFRACAS Connection. (In a secure database, this is available only for users with the "Manage other repository settings" permission.)

In the XFRACAS Connection Settings Window, select Connect to an enterprise repository with XFRACAS data then choose Microsoft SQL Server or Oracle.

- For a SQL Server database, enter the server name and database name.
  - **Encrypt communication.** Secures the connection information between the ReliaSoft application and the enterprise database.
  - **Trust server certificate.** Select this option if the server has a self-signed certificate.
  - **Use impersonation.** Configures the connection setting to impersonate a Windows user account with a SQL Server login that is shared by multiple users. (See SQL Server Logins or Using Windows Impersonation.) If you do not use impersonation, then each user who uses the features that utilize XFRACAS must have an account in the external database that contains the XFRACAS data.

- For an Oracle database, enter the port, host and service identifiers and the database schema. Your Windows login credentials are used for access to the database; enter your Windows password.

## Managing and Restoring Data

Since each database may contain a large amount of valuable information that would be difficult to re-create, it is essential to make sure that you are diligent about storing adequate backups and performing the necessary maintenance activities to keep the database operating smoothly. The necessary procedures vary depending on the type of database.

### Enterprise Database Maintenance

When you choose to store analysis information in an enterprise database, a database administrator must perform backups and database maintenance activities using the data management tools that are packaged with and/or designed for the database platform (e.g., SQL Server Enterprise Manager for SQL Server). Each individual organization typically establishes its own procedures for protecting the data stored in the Oracle or SQL Server databases. As a convenience for users who wish to explore the possibilities of an enterprise database implementation without making a large investment of time and resources, instructions on how
to perform the minimum database maintenance recommendations are posted on the ReliaSoft website:


**Standard Database Maintenance**

When you choose to store analysis information in a standard database, it will be subject to the same limitations and vulnerabilities as any other file that uses the Microsoft Access® database file format. For example, the maximum file size is ~ 2GB, maximum number of concurrent users is 255, etc. In addition, some specific database vulnerabilities are discussed in a Microsoft publication at [http://support.microsoft.com/kb/283849/EN-US/](http://support.microsoft.com/kb/283849/EN-US/). As this publication states:

> "Microsoft Jet, the database engine that is used in Microsoft Access, is a file sharing database system. When Microsoft Jet is used in a multi-user environment, multiple client processes are using file read, write, and locking operations on a shared database. Because multiple client processes are reading and writing to the same database and because Jet does not use a transaction log (as do the more advanced database systems, such as SQL Server), it is not possible to reliably prevent any and all database corruption." [emphasis added]

Although our developers have made every effort to reduce or eliminate the possibility that the software will induce a database error, there is no way to absolutely prevent corruption that might be caused by other factors, such as faulty network hardware, an unexpected "crash" on your PC or a network interruption. Therefore, this section provides some recommendations for standard precautions that all users can take to protect the data in their standard databases from this type of corruption and reduce the impact of the data loss if corruption is unavoidable.

1. **Create backups regularly.** As with any resource that contains a large amount of valuable information that would be difficult to re-create, it is essential to make sure that you are diligent about creating and storing backup files. There are a number of ways this can be accomplished:

   - If you select **Automatically back up database upon closing** from the **Backup/Check Out Options page** of the Application Setup, the ReliaSoft desktop application that you use to open the database will back up the database every time you close the file.
   - If you have a database open and choose **File > Save As**, the application will create a copy of the database to a pathname/filename of your choosing.
   - If you browse to the database file (*.rsr18) in one of the Windows file management tools (such as My Computer or Windows Explorer), you can copy and paste the database file as needed.
2. **Compact and repair regularly.** Using the "Compact and Repair" feature will help to reduce the size of the database file and help to protect against problems with the operation of the database. If you have the database open and it is not currently in use by another user, you can initiate the process by at any time by choosing **File > Manage Repository > Compact and Repair.**

3. **Do not store the database in a shared network location if you suspect that your network connection and/or hardware may be unreliable.** According to Microsoft, faulty network hardware is one of the main reasons why a file that uses the Microsoft Access database file format may become corrupted. As the Microsoft publication at [http://support.microsoft.com/kb/283849/EN-US/](http://support.microsoft.com/kb/283849/EN-US/) states:

   "The cause can be one or more links in the hardware chain between the computer that the database resides on and the computer that has the database open. This list includes, but is not limited to, network interface cards, network cabling, routers, and hubs.

   Hardware-based corruption is typically indicated by .mdb files that cannot be restored through the use of compacting, repairing, or Jetcomp. **Hardware corruption will typically recur until the responsible hardware is repaired or replaced.**" [emphasis added]

   If you have experienced this type of corruption for a standard database file, it is recommended that you take steps to correct the network problem or refrain from accessing database files over the network. In such cases, you may choose to use an enterprise database instead (i.e., Oracle or SQL Server), which would be less vulnerable to network interruptions. Alternatively, you could keep multiple analysis projects together in a single shared standard database file but ask users to export the analysis to a separate "working" database on their own computers when there is a need to make substantial modifications. Users could then import the data back into the shared database after the modifications have been completed.

4. **Do not allow the file size of the database to grow too large.** Performance will be affected by the size of the database and the number of simultaneous users. Therefore, it is important for users to monitor the sizes of their database files and take steps to export the data into several smaller and more manageable files if they become too large. Please be aware of the following factors, which can lead to very large database files:

   - Failure to compact and repair the database on a regular basis.
• Using a very large number of attached documents. In some cases, using a link instead of an attachment may provide equivalent functionality with a much smaller impact on the size of the database file.

If you try to open a standard database via the software and receive a message that says "Unable to open the database," this is an indication that the database file may have become corrupted. Please contact Technical Support and provide as much information as possible about exactly what you were doing when the corruption occurred. Whenever possible, please provide a copy of the corrupted file. In some cases, we may be able to provide assistance with salvaging some or all of the affected data. However, in many cases, the best recourse may be to restore the latest backup from before the corruption occurred.

**Restore Points**

In all ReliaSoft desktop applications, you can create and manage *restore points* (formerly called "project baselines") for any analysis project. Within the context of these applications, the phrase "restore point" refers to an exact replica of the project at a particular point in time (i.e., a backup) that can be restored when and if it is needed. A restore point will include all the data that the project contained at the time the restore point was created, including information about the project properties, security settings and project owner.

There are a variety of ways that this functionality could be used, depending on your particular analysis process and data management requirements. For example, if you are about to begin a major revision to an existing project, you could choose to archive the original version as a restore point and then proceed with updating the project. This would ensure that the active projects in the database contain only the most recent information but also provide easy access to a fully editable copy of the previous version of the analysis if it is ever needed.

**Create a Restore Point**

You can create a restore point for a project at any time by choosing *Project* > *Management* > *Restore Point* > *Create Restore Point* or by right-clicking the name of the project in the project list and choosing the command on the shortcut menu.

In a secure database, this is available only if the user is the project owner or has the "Create restore points" permission.

**IMPORTANT:** When you create a restore point, any global, reference and FMEA resources used in the project are converted to local resources and stored with the backup. This ensures that you will have access to these resources upon restoration, regardless of what may have happened to those resources in the interim.
Chapter 2: Repositories and Projects

**Restore a Project**
To restore all data from an existing restore point, use the **Restore Project** command. This opens the Restore Project window, which displays a list of all existing restore points for the project, if any. You have two options:

- **Overwrite existing project** uses the restore point to roll back the current project to the earlier state. The restore process will complete as long as the project is not currently in use by another user. There is no undo for project overwrites. Therefore, it would be prudent to create a new restore point for the project before you overwrite it with one of the older restore points.

- **Create new project** uses the restore point to create a new project. You may enter a unique name for the new project. When the restore process completes, the new project will be accessible from the project list.

**Manage all Restore Points in the Database**
To manage all the restore points that have been created in the database, choose **File > Manage Repository > Restore Points**. (In a secure database, this is available only for users who have all three "manage all projects" permissions.)

This opens the Restore Points window, which displays the details for each of the restore points.

- To create a new restore point, click the **Create** button then select the project you want to back up. Enter any notes that are appropriate to describe the purpose or the circumstances of the restore point and click **OK**.

- To delete an existing restore point, select the row and click the **Delete** button or press **DELETE**. **There is no undo for delete.**

- To create a new project that restores all of the data from an existing restore point, select the row and click the **Restore Project** button. You will be prompted to specify a unique name for the new project.
Chapter 3: Desktop Application Interfaces

Most ReliaSoft desktop applications have their own Multiple Document Interfaces (MDIs) that provide full-featured support for the relevant analysis methods. (The exceptions are Weibull++/ALTA and BlockSim/RENO, which can display both applications in a shared MDI.)

When you are using multiple ReliaSoft applications simultaneously, different applications will open in separate MDIs but they can all connect to the same database, and even to the same analysis project.

All ReliaSoft MDIs share a common structure, which includes the following elements.

Ribbon and Backstage View

The ribbon at the top of the MDI replaces the toolbars and menus of previous versions of the software. The ribbon is divided into tabs that organize commands into logical groups. Some tabs will always be available (such as File, Home, etc.) while others are contextual and will appear only when you are working on a particular task.

The first tab, the File tab, provides access to a special type of interface called the Backstage view. This is where you will create and open databases, manage settings that apply to the entire database, access the Help Center, etc.

Project Manager and My Portal

The Project Manager allows you to manage the projects within the current database and, for many ReliaSoft applications, it also allows you to manage all of the folios, diagrams, reports, attachments, etc. in the currently open project(s). This panel is docked on the left side of the MDI and pinned by default. ("Pinned" means that the entire panel is always visible unless you decide to hide or "unpin" it.)

My Portal provides quick access to messages, assigned actions and other information that may be of personal interest to you while working in the Synthesis Platform. This panel is docked on the right side of the MDI and unpinned by default. ("Unpinned" means that only a small tab will be visible in the interface unless you move the pointer over the tab to make the entire panel visible.)

For both of these MDI features, you can decide whether the panel will be visible and how it will be positioned in the interface. (See Show, Tile, Dock and Pin Panels.)

Lambda Predict 2018 User's Guide
Tip: If desired, you can change the overall color scheme used in the MDIs for all ReliaSoft desktop applications on your computer. Use the Skins drop-down list on the Synthesis Settings page of the Application Setup to select the style you prefer.

Status Bar
As an example, the following picture shows the status bar at the bottom of the MDI for an enterprise database:

For more information about the connection speed indicator, see Enterprise Repository Connection Speed.

If working with a Synthesis file, the status bar also displays a reminder that you will need to save any changes before closing.

Show, Tile, Dock and Pin Panels
In all ReliaSoft desktop applications, the MDI includes a Project Manager panel and a My Portal panel. You can decide whether each panel will be displayed and how it will be positioned in the interface at any given time.

Show or Hide
To show or hide the Project Manager panel, choose View > Project Manager and toggle the Show Project Manager command on or off.


You can also hide either panel by clicking the X at the top of the window.

Tile or View One Page at a Time
In all ReliaSoft desktop applications, My Portal consists of four pages. You have the option to view one page at a time (and use large buttons or small icons at the bottom of the panel to
switch between pages) or tile the pages so that more than one page can be visible at the same time. To specify your preference, choose View > My Portal and toggle the Tile My Portal command on or off.

When applicable, these same options are available for the Project Manager panel. Choose View > Project Manager and toggle the Tile Project Manager command on or off. (This command is not available in applications such as Xfmea, RCM++, RBI and MPC, which have only a single page in the Project Manager.)

As an example, the first picture shows the My Portal panel when it is not tiled. The second picture shows the tiled panel, with two of the four pages expanded to be visible at the same time.

When the panel is not tiled, you can drag the horizontal splitter bar up to display large buttons or down to display small icons.
Chapter 3: Desktop Application Interfaces

When the panel is tiled, you can use the handle buttons to expand or collapse each page.

Dock or Float

For both panels, you have the option to dock the panel on the left, right, top or bottom side of the MDI. When the panel is docked, it cannot be moved but you can change the width (if docked left or right) or height (if docked top or bottom) by dragging the edge to the desired position.

Alternatively, you can choose to float the panel as a window that can be resized and dragged to any location on the desktop.

There are several ways to set the docking position:

- Choose View > Project Manager > Dock Project Manager and then choose the desired option.

The same options are available when you choose View > My Portal > Dock My Portal.

- If the panel is currently floating:
  
  - Double-click the window's title bar to return it to the most recent docked position.

  OR

  - Click the window's title bar and drag it onto one of the location icons that become visible while you are moving the window. When the window is correctly positioned, blue shading will show where the window will be docked when you release the mouse button. (Note that the window's title bar must be exactly positioned above one of these location icons before the blue shading appears. If you don’t see blue shading, the panel will not be docked when you release the mouse button.)
If you prefer to float the window, you can:

- Choose either:
  - View > Project Manager > Dock Project Manager > Floating Project Manager
  or
- Double-click the title bar of the docked panel.
Pinned or Unpinned
When docked, both panels can also be toggled between pinned and unpinned states by clicking the pushpin icon in the panel's title bar. When the pushpin in the icon is vertical 🔄, the panel is pinned and will be displayed at all times.

When the pushpin is horizontal 📦, the panel is unpinned. A tab will be displayed at the docking location for each unpinned panel.

The behavior for unpinned panels is as follows:

- If you point to the tab, the panel displays only until you point to something else.
- If you click the tab, the panel stays displayed until you click something else.
- When a panel is unpinned, it cannot be undocked or moved.

As an example, the following picture shows the Project Manager panel docked on the left side of the MDI, unpinned and hidden, while the My Portal panel is docked on the right side of the MDI, unpinned and visible (either because the user moved the pointer over or clicked the tab).
Project Manager

The Project Manager provides the tools you need to browse or search for a particular project or analysis folio in a Synthesis repository. Depending on the application, the Project Manager consists of either one or two pages:

- In all ReliaSoft desktop applications, the project list displays all the projects in the current database. (For Xfmea, RCM++, RBI and MPC, this is the only page available in the Project Manager).

- In Weibull++, ALTA, BlockSim, RENO, RGA and Lambda Predict, the Open Project(s) page of the Project Manager (i.e., the current project explorer) displays all the analysis folios, reports and other items in the current project(s) that apply to the software you are using.

There may be up to five nodes in the project list, indicating the sharing status of the projects: Private, Public or Reference projects, Locked projects and Checked Out projects. Additionally, the Recycle Bin is shown in the project list.

Each node may be further broken down by project category and/or by project owner. This ensures that projects will be organized in a logical, manageable way within the project list.

Opening a Project

To open an existing project, double-click the project name or select the project and choose Project > Management > Open Project.

**Note:** Remember that each project may contain items from any ReliaSoft application but you will see only the items that are relevant for the application you are currently working with (e.g., Weibull++ analysis folios are visible only when the project is opened in Weibull++). Common items, such as project attachments, are visible from all applications.

Filtering the List of Projects

The project list can utilize the same project filters that are available in many other locations throughout ReliaSoft desktop applications. For example, with the filter shown below, the project list will show only projects belonging to Department B.

```
<table>
<thead>
<tr>
<th>Department B</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find:</td>
</tr>
</tbody>
</table>
```
This feature might be particularly useful for an enterprise database that may be used to store analysis projects for the entire organization in a single centralized location. In such cases, the number of projects displayed in the project list could become overwhelming and these filters provide the ability to display only those projects that are of interest to you at any given time.

To remove the filter, select **Show All** from the drop-down list.

**Searching for a Particular Project**

You can also search for projects by entering text in the **Find** field. The project list updates dynamically to show only the projects with names that contain the text that you have entered. As an example, the following picture shows a quick way to find all of the projects for a particular product line by using the project names instead of predefined categories or other filter criteria.

![Project Search Example](image)

**Current Project Explorer**

In all ReliaSoft desktop applications except Xfmea, RCM++, RBI and MPC (which use the system hierarchy to manage all of the different analyses in a given project), the Open Project(s) page of the Project Manager allows you to manage all of the relevant project items (e.g., folios, diagrams, etc.) in the project(s) that are currently open.

Applications that use the current project explorer can have multiple projects open at the same time. (See [Working with Multiple Projects](#).)

**Note:** Remember that each project may contain items from any ReliaSoft desktop application but you will see only the items that are relevant for the application you are currently working with (e.g., Weibull++ analysis folios are visible only when the project is opened in Weibull++). Common items, such as project attachments, are visible from all applications.
Filtering the Project Items
The current project explorer can utilize the same item filters that are now available in many other locations throughout ReliaSoft desktop applications. (This provides more flexibility than the Filter based on creator feature in prior versions.)

For example, with the filter shown below, the current project explorer will show only items created by Joe User and updated within the current month.

To remove the filter, select Show All from the drop-down list.

Opening Items
Double-click an item to open that item in the MDI or to bring that item to the front of the MDI if it is already open. (Note that if you double-click an attachment that appears in the current project explorer, it will open in its corresponding application, as long as that application is installed on your computer.)

Tip: In all ReliaSoft applications, projects can be shared by multiple users and the current project explorer may display an "in-use" icon to indicate the status of an item that can't be edited because it is currently locked or being edited by another user. (See Status Indicators.)

Adding Items
You can add items to the project by right-clicking the relevant folder and choose an appropriate command on the shortcut menu that appears.

Editing, Renaming, Duplicating or Deleting Items
To manage existing items within the project (i.e., Edit Item, Rename Item, Duplicate Item and Delete Item), right-click the item and choose a command from the shortcut menu or select the item and use the commands in the Current Item group on the Project tab of the ribbon.
Sub-Folders and Drag and Drop
In addition to the top-level folders that are fixed for each application, you also have the ability to create your own custom sub-folders to organize project items (the exception being the Attachments folder, which you cannot add sub-folders to). To add a custom sub-folder, right click any existing folder and choose Add Folder on the shortcut menu.

You can also arrange custom sub-folders and project items by dragging them to the desired location. Dragging a folder or project item onto a folder will place it into the bottom of that folder. Dragging a folder or project item onto a project item will place it in the same level above that item.

Working with Multiple Projects
ReliaSoft desktop applications that use the current project explorer (i.e., Weibull++, ALTA, BlockSim, RENO, RGA and Lambda Predict) can have multiple projects open at the same time. To enable this functionality, select the Allow multiple projects (project explorer) check box on the Synthesis Settings page of the Application Setup.

**Tip:** There is a separate setting that controls the ability to have multiple projects open in Xfmea/RCM++/RBI.

When you have more than one project open, the projects will be shown in the current project explorer with the most recently opened project at the top. Note that the icon shown beside each project indicates whether it is a public, private or reference project and, when applicable, whether it is locked or checked out.

<table>
<thead>
<tr>
<th></th>
<th>Unlocked, Not Checked Out</th>
<th>Locked</th>
<th>Checked Out</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Public Project</strong></td>
<td><img src="image" alt="Icon" /></td>
<td><img src="image" alt="Icon" /></td>
<td><img src="image" alt="Icon" /></td>
</tr>
<tr>
<td><strong>Private Project</strong></td>
<td><img src="image" alt="Icon" /></td>
<td><img src="image" alt="Icon" /></td>
<td><img src="image" alt="Icon" /></td>
</tr>
<tr>
<td><strong>Reference Project</strong></td>
<td><img src="image" alt="Icon" /></td>
<td><img src="image" alt="Icon" /></td>
<td>N/A</td>
</tr>
</tbody>
</table>
In addition to the convenience of being able to view analyses from multiple projects, having multiple projects open allows you to transfer data between the projects quickly and easily. Specifically:

- For any item that can be imported/exported between projects, you can simply drag the item (analysis, multiplot, report, etc.) from the source project to the appropriate folder in the destination project. This opens the Export window, where you can just click Export to finish the export, or add more items to export before you finish the process.

- In Weibull++, ALTA and RGA, data can be copied from an analysis in one project and pasted to an analysis in another project.

- In BlockSim and RENO, blocks can be copied from a diagram in one project and pasted to a diagram in another project, according to the following rules:
  - If the block uses resources that are local to the source project, they will also be copied and added to the destination project.
    - If a resource of the same name exists in the destination project, the name of the copy will be incremented (e.g., if "Model1" already exists, the new copy might be renamed to "Model1_1").
    - If a model is associated with a data source (e.g., a model published from a Weibull++ folio), the model is copied into the destination project as a model with the association removed.
  - If the block uses resources that are global or in a reference project, they will not be duplicated. They will retain their original reference to that global/reference resource.
  - Subdiagram blocks cannot be copied and pasted across projects.

Note: The FMRA view is not available in BlockSim when you have multiple projects open.

My Portal

In all ReliaSoft desktop applications, My Portal provides quick access to messages, assigned actions and other information that may be of personal interest to you while working in the Synthesis Platform. (When you first activate the software, My Portal will be "docked" on the right side of the MDI and "unpinned." Move your mouse pointer over the tab to make the panel visible at any time. For other options, see Show, Tile, Dock and Pin Panels.)
If your organization chooses to implement a web-based Synthesis Enterprise Portal (SEP) for an enterprise database, you can also access many of these same features – as well as selected metrics, reports and other details from specific analyses – from any web-enabled device.

**Portal Messages**
The Synthesis Platform’s messages feature provides a convenient way to communicate with other database users. Messages are displayed in a "timeline" format similar to social media websites like Facebook®.

These messages are displayed both in My Portal (in any ReliaSoft desktop application) and in the Synthesis Enterprise Portal (if it is implemented for your database).

All database users will be able to view their own messages. In a secure database, the following permissions are required to create, edit or delete messages:

- **Create portal messages** allows you to create new messages, and edit or delete the messages you have personally created.

- **Manage all portal messages** allows you to edit or delete any messages that are visible to you. This includes any message for which you are the creator or one of the recipients.

**Message Display Options**
The messages timeline will display all messages that were created by or addressed to you. You can sort the message threads in two ways:

- **Newest Active** considers the dates/times of both the main messages and the replies.

- **Newest Message** considers only the dates/times of the main messages.

**Create, Edit, Delete or Reply to Messages**
In ReliaSoft desktop applications, you can access the message commands from the My Portal tab of the ribbon, and by right-clicking inside the Messages page of the panel.
Note that the purpose of the **Refresh Messages** command is to update the display with any new messages that were recently added or changed by another database user.

**Message Recipients**
You can specify whether a message will be visible to all database users or only to specific users or groups. If you select Selected Groups/Users, you can choose from two lists: user groups that have been predefined in the database and/or individual user accounts.

![Image of Message Recipients](image)

If a valid SMTP server has been defined for the database, you can select the **Also send this via e-mail** check box to send an e-mail copy of the message to the recipient(s). (See [Enable Alerts via E-mail or SMS](#).)

**Actions in My Portal**
Throughout the Synthesis Platform, your team can use actions to track specific assignments that need to be performed. These versatile resources can be used multiple times in different locations, if appropriate. This may include actions in Project Plans, FMEAs or Test Plans, as well as actions that are independent of any particular analysis or plan.

This topic discusses how to view and manage actions via My Portal (in any ReliaSoft desktop application). If you want to view/manage all action records, see [Actions Explorer](#) or [Resource Manager](#). For information about the action properties and other general considerations that apply wherever the action may be used, see [Action Resources](#).

**Actions Displayed in My Portal**
The Actions page in My Portal (and in the Synthesis Enterprise Portal) display action records that:

- Need to be reviewed by you.
Chapter 3: Desktop Application Interfaces

- Are relevant to you in some way and are:
  - **Past Due** – the completion date has passed.
  - **Due Next 7 Days** – the completion date occurs within the next 7 days.
  - **Past Start Date** – the start date has passed.
  - **Start Today** – the start date is today.
  - **Start Tomorrow** – the start date is tomorrow.
  - **Start Next 7 Days** – the start date occurs within the next 7 days.
  - **In Progress** – the actual start date has been entered and the action is not yet "Past Due" or "Due Next 7 Days."

If the action is not used in the Project Planner, this will be based on the *planned* start/completion dates. But if the action is used in a plan, it’s based on the *expected* dates (which can shift automatically if there are recorded delays in prior gates/actions).

Also note that if an action fits under more than one heading, it will display under the more urgent one. For example, if the action is both due in the next 7 days and past the planned start date, it will show under "Due Next 7 Days."

**Create, Edit or Delete Actions from My Portal**

In ReliaSoft desktop applications, you can access the portal actions commands from the *My Portal* tab of the ribbon, and by right-clicking inside the *Actions* page of the panel.

![Actions](image)

*Tip:* If an action doesn’t fit the My Portal display criteria for your computer/username (see details below), the new record won’t be displayed in your portal after you create or edit it. In such cases, you can use the *Actions Explorer* or *Resource Manager* to access the record.
Add to Outlook Calendar
The Add to Outlook Calendar command will be enabled if Microsoft Outlook is installed on your computer.

It launches Outlook’s interface for creating a new calendar event and automatically populates the subject and date. You can modify the details as needed before saving the new event to your calendar.

Note that you may need to give focus to the Outlook application in order to see the window.

Refresh Actions
The Refresh Actions command updates the display with any new actions that were recently added or changed by another database user.

Action Display Settings
To specify your personal preferences for displaying actions in My Portal (stored per computer/username), right-click inside the panel and choose Action Display Settings.

If you select the Display ‘Show Actions’ labels in portal check box, the panel will also include headings that indicate how the action is relevant to you:

- I am responsible for
  - You are assigned in the Person Responsible field.
- I am a team member in
  - You belong to the team assigned in the Team field.
- I need to review/approve
  - You are assigned in the Reviewer field.
- I am monitoring
  - You are assigned in the Action Monitors window, or you have personally subscribed to “watch” the action.
- Other actions I created
  - You are listed in the Created By field and none of the other roles apply.
Finally, you can choose to **Sort by Start Date** or **Sort by Due Date** within each node of the display.

**Action Explorer**

The **Action Explorer** command opens a flexibility utility that allows you to explore all of the action resources that are stored in the current database. You can use it to filter, sort, add, edit or delete actions. (See [Actions Explorer](#).)

Note that when you return to the Actions page in My Portal, you will need to use the **Refresh Actions** command to view any changes.

**Repository Users List**

The repository users list shows all active user accounts in the database, and identifies which of those users are currently connected to the database with any of the ReliaSoft applications.

This list is displayed both in **My Portal** (in any ReliaSoft desktop application) and in the **Synthesis Enterprise Portal** (if it is implemented for your database).

In ReliaSoft desktop applications, you can access the users list commands from the **My Portal** tab of the ribbon, and by right-clicking inside the **Users** page of the panel. Similar commands are available in the web-based Synthesis Enterprise Portal, if applicable.
My Profile opens the User Login and Contact Information window, which allows you to edit the contact information associated with your user account.

Refresh Users updates the list to reflect any recent changes in user activity.

Project Plan Summary in My Portal
In all ReliaSoft desktop applications except MPC, the Project Plan Summary page in My Portal provides a summary of the plan for the current project, if applicable.

The summary in My Portal always reflects the entire plan for the current project, based on the actual date/time from your computer. If you want to see the summary for a particular gate or action, or to estimate what the statuses would be for a different date, you must use the Project Planner window.

- Choose Project > Management > Project Planner.
- Click the link in the project name bar at the top of the summary in My Portal.
How to Read the Summary
The plan summary in My Portal provides the following information at-a-glance. (For details, see Project Plan Summary Panel.)

By default, this shows the current date, which is used to determine the status (e.g., "Missed Start Date"), resource usage to date, etc. Use Refresh to obtain the latest information from the Project Planner.

The top bar displays name of the project that the summary applies to. Click the link to open the project in the Project Planner.

The next two rows show the expected dates and any actual dates, and the last row shows the status.

This is the percentage of the total duration of dependent actions/gates that is complete. For example, if Action 1 (duration = 3 days) is complete and Action 2 (duration = 1 day) is incomplete, the progress is 75%.

For resource usage, the black bars show the planned man hours and costs. The colored bars show either the expected usage to date (estimated based on the number of days in progress), or the actual usage if complete. (See Costs and Man Hours.)

- Yellow = In progress and usage to date is still within plan
- Orange = In progress and usage to date has exceeded plan
- Green = Complete and actual usage was within plan
- Red = Complete and actual usage exceeded plan
Displays only if actions have been assigned to the project or gate (either directly or via dependent gates).

- **Not Started** = Actions that have not started and can complete on time
- **In Progress** = Actions that are in progress and can complete on time
- **Completed** = Completed actions that have been approved, or don't require approval
- **Past Due** = Actions that have not completed and can no longer complete on time

### Folios

#### Data Sheets

The data sheets in Weibull++/ALTA and RGA folios share some common components and features. The following picture shows the basic components of a data sheet using one particular format as an example.
**Chapter 3: Desktop Application Interfaces**

- **Caption** shows the name of the folio and the name of the sheet that is currently displayed.

- **Name Box** shows the location of the currently selected cell by listing the column letter and row number that intersect at the cell's location.

- **Data Entry Bar** shows the contents of the selected cell, which may be text, a numerical value or a formula. For text or numerical values, you can enter/edit the information directly inside the cell or inside the data entry bar. For a formula, you must use the data entry bar for editing; the cell will display only the calculated value.

- **Row Headings** identify the row numbers. Each data sheet contains up to 65,536 rows. The application's speed of execution is inversely proportional to the number of data rows in the current data set.

- **Column Headings** indicate the titles of the columns. To rename a heading, right-click it and choose **Rename Column**. When applicable, you can save the column titles and use them as the default headings for all new data sheets of the current type. (See **Default Column Headings**.)

- **Sheet Tabs** represent the different sheets within the folio. To rename a sheet, double-click the tab. The number of folios that can be opened at once depends on the amount of memory of your system (up to a maximum of 256 for some folio types).

**Default Column Headings**

In life data (Weibull++), life-stress (ALTA) and growth data (RGA) folios, creating a new data sheet automatically applies default column headings that are generally appropriate for the...
analysis. If there are certain types of data that you frequently use (e.g., miles-to-failure, cycles-to-failure, etc.), you can customize the column headings to always use your preferred column titles.

To modify the defaults for a particular data type, first rename the column headings in an existing data sheet. Right-click the heading and choose Rename Column on the shortcut menu. Then save the new titles as the defaults. In Weibull++, choose Life Data > Format and View > Set Headers as Default. (In ALTA, the command is in the Life-Stress Data tab; in RGA, it's in the Growth tab.)

These preferences are saved for the current computer/username, and will be applied the next time you create a new data sheet for that particular data type.

To apply the new default headings to an existing analysis, open the data sheet and choose [Life Data/Life-Stress Data/Growth Data] > Format and View > Apply Default Headers.

If you ever need to restore the default column headings back to the shipped settings, choose File > Application Setup, then click Reset Application Settings or Reset All Settings on the Reset Settings page.

Resizing Columns
Column widths are set to span evenly by default. If you want to resize and have the changes saved with the folio, right-click a column heading and choose Column Width Style > Default.

To resize a column, drag the edge of the heading to the desired position, or right-click it and choose Column Width.

Entering Formulas in the Data Sheet
Data sheets in Weibull++, ALTA and RGA allow you to enter formulas in columns that do not require entries to be dates, times or text (e.g., you cannot use formulas in the State F or S column in a Weibull++ life data folio, or in the Classification column in an RGA growth data folio). For example, in a Weibull++ life data folio, if you have a data set where the units were inspected every 24 hours, you can speed up data entry by creating a formula to add 24 hours to the previous inspection time, as shown next.
There are two types of cell references (locations) when inputting a formula: absolute and relative. By default, the cell reference is relative, meaning that as a formula is copied and pasted to other cells, the cell references in the formula will be adjusted to reflect the new relative location. In the previous figure, the formula in cell C2 is copied and pasted into cell C4. This changes the cell reference in the formula from ";=C1+24" to ";=C3+24"; therefore, the time value in C4 is 72+24 = 96.

In contrast, an absolute reference does not change when the formula is copied to other cells. Absolute references are designated by placing a dollar sign ($) in front of the row and/or column to be made absolute. If the formula in the example were rewritten to ";=$C$1+24", then copying the formula to cell C4 would retain the cell reference to C1 and the time value in C4 would be 24+24 = 48.

**Change Units**

In Weibull++, ALTA and RGA, you have the ability to define the units used for the data set and calculations. For example, if your data set contains failure times in hours, you now have the option to perform calculations using different time units such as years, months, days, etc. The software performs the unit conversion automatically. Authorized users can define the units that will be available for use in any project within the database and set up the conversion factors.

The units are displayed in the heading of the relevant column in the data sheet. If you wish to change the units of an existing data sheet, click the Change Units icon on the Main page of the control panel.
In the Change Units window, the units that are currently being used in the data sheet will be displayed at the top of the window. In the **Change Units To** field, you can choose any other defined unit to be used in the data sheet. In the **Conversion Options** area, specify what will happen when the units are changed:

- You can convert the existing data to the new units. For example, if you had a time of 10 in a data sheet that was using hours, that time would become 600 if you converted the data to minutes (10 hours x 60 minutes per hour = 600 minutes). For Weibull++ life data, ALTA life-stress data and RGA growth data folios, when this option is selected, you can select whether you want to copy the data to a new sheet in the folio and then perform the conversion, leaving the original data sheet unchanged, or convert the data in the current sheet.

- You can leave the data unchanged and just apply the new units. This would be appropriate if, for example, you had entered all of your data and then realized that the data sheet was using different units from the original units in which the times were measured.

**General Spreadsheets**

General Spreadsheets can be inserted into a Weibull++ life data folio, ALTA life-stress data folio or RGA growth data folio. They provide the same spreadsheet capabilities that are available in the spreadsheet module in *Synthesis Workbooks*, but are stored together with an analysis folio. You may prefer to use this reporting tool if you are performing custom calculations based on the data sheets in the same folio and you wish to keep the analyses together with their source data.

To add a General Spreadsheet to a folio, right-click the data sheet tab area (the area at the bottom of the window that shows the name of the data sheets in the folio) and choose **Insert General Spreadsheet** on the shortcut menu. This command also appears on the ribbon tab for the particular type of data folio. For example, to insert a general spreadsheet into a Weibull++ life data folio, you can choose **Life Data > Folio Sheets > Insert General Spreadsheet**.

**Inserting Data Source Functions**

To build and insert functions that utilize a referenced analysis (data source), click a cell in the general spreadsheet and choose **Sheet > Sheet Actions > Function Wizard**.
For the function arguments:

- Brackets [ ] indicate that the input is optional.
- You can use cell references as inputs. For example, instead of entering 1000 for the Age input, you could specify to use whatever time is currently entered into cell A10, using either the relative reference (A10) or the absolute reference ($A$10). (See Cell References.)
- You can also use variable names as inputs. (See Defined Names.)

For the data source:

- Click the Select button and then select which data sheet in the folio to use as the data source.
- Any time you make changes to the data source, the general spreadsheet will need to be recalculated to reflect the most current results. Choose Sheet > Format and View > More Settings > Recalculate Formulas. The general spreadsheet may return "N/C" if the data source needs to be recalculated.
Inserting Math Functions
To add math, date, logic and other functions, click a cell in the general spreadsheet and choose Sheet > Sheet Actions > Insert Function.

Select a function from the drop-down list and click OK. You can enter inputs for the function arguments by either selecting the cells in the sheet or typing them directly into the appropriate field.

Referencing a Data Source
Some functions (e.g., AMEAN, D_COUNT, etc.) require you to reference a particular data source.

To reference a data source, use the following syntax, with the quotes and exclamation marks (!). You can only reference sheets in the same folio.

"Application!Folio!DataSheet"

In the following example, the data source is a data sheet called "Data1" in the Weibull++ folio called "Folio1".

Control Panels
Many of the analysis folios, diagram sheets and other interfaces in ReliaSoft desktop applications utilize a control panel that allows you to make required inputs, initiate the desired analysis or simulation and view/access applicable results. This topic describes some features that are common to most control panels. (For Xfmea, RCM++, RBI, MPC and Lambda Predict, see System Panel and Analysis panel instead.)
Switching Between Pages
Many control panels and navigation panels contain multiple pages that vary depending on the type of analysis. You can switch between pages by clicking either the large buttons or the small icons at the bottom of the panel.

If you drag the horizontal splitter bar to the bottom of the control panel, all of the pages will be accessed by small icons. If you drag it as far up as it will go, all of the pages will be accessed by large buttons.

Hiding or Displaying a Control Panel
The control panel can be toggled between hidden and displayed states by clicking the Hide or Show icon in its title bar.

When the control panel is hidden, only the title bar and page icons will be visible on the right side of the window (as shown next using a Weibull++ folio as an example). When you click the bar, the active page will be displayed temporarily. When you click anywhere outside of the control panel page, it will be automatically hidden again.
Identifiers Page

The Identifiers page of the control panel allows you to enter identifying details (e.g., category, name, part number, etc.) that will be associated with the analysis and any models or SEP summaries that are published from the analysis. This will help you to find, filter and group analyses and resources throughout the repository.

In folios that can have multiple data sheets, the Folio Identifiers are edited via the Item Properties window, and the Data Sheet Identifiers can be entered directly in the control panel. Use an asterisk (*) if you want the data sheet’s identifiers to be the same as the folio’s (see Identifiers).

Publishing Page

The Publishing page allows you to view and manage information from the current analysis that is shared throughout the Synthesis Platform.

- **Model/Fitted Model** – publishes a model based on the current analysis. See Publishing Models.
Chapter 3: Desktop Application Interfaces

- **SEP Summary** – publishes a summary of the current analysis to the Synthesis Enterprise portal website. This is visible only if the enterprise database is configured for SEP and you have the "Publish to Synthesis Enterprise Portal" permission. See [Publishing to SEP](http://predict.reliasoft.com).

- **Metrics** – shows all of the metric resources that are associated with the current analysis. See [Showing Metrics in Folios/Diagrams](http://predict.reliasoft.com).

**Notifications Page**

When applicable, the Notifications page provides information on the **Current Status** of the analysis, along with any warnings or errors. A green light indicates that the folio has been analyzed, and a red light indicates that the folio has not been analyzed since changes were last made. The **Latest Notifications** area displays any warnings and errors generated during analysis.

![Notifications Page](image)

**Utilized Resources Page**

In BlockSim only, the Utilized Resources page displays a grouped list of all of the **resources** that are used directly by blocks in the diagram (i.e., not applied via any other resource or tool).

For example, a **URD** that is assigned to a block will be displayed in this list, but the **model** assigned to the URD will not be shown, nor will any **tasks** assigned to the URD. Similarly, if a block belongs to a maintenance group, that maintenance group will be shown in the list. However, if a block has a state change trigger, the maintenance group(s) used for that trigger will not be shown unless some block in the diagram belongs to them.

This list is not updated automatically; if you have made changes to the diagram, click the **Refresh** icon to update the list.
Double-click a resource in the list to open its properties window for viewing or editing. Click the Resource Manager icon to view/manage all of the resources available in the project.

**System Panel and Analysis Panel**

Some ReliaSoft applications use two convenient panels to manage all of the analysis information in a particular project (Xfmea, RCM++, RBI and MPC) or in a particular prediction folio within the project (Lambda Predict).

The first panel (called the System panel or the System Hierarchy panel) allows you to build simple or complex multi-level configurations that contain the items you plan to analyze. The second panel (called the Analysis panel or the Properties panel) contains all of the properties and analyses for the item that is currently selected.

This topic discusses the ways in which you can configure the layout of these two panels to fit your particular workspace preferences.

**Change Orientation**

You can display the panels side-by-side or with one panel above the other.

To switch between layouts, choose View > Workspace Layout > Change Orientation.

**Resize a Panel**

You can resize the panels by dragging and dropping the vertical (or horizontal) separator into the desired position.
Hide a Panel
You can also completely hide either panel so that the other can fill the available space. Choose View > Workspace Layout > Hide [System Panel/System Hierarchy] or [Analysis Panel/Properties].

When you wish to return to the two-panel layout, choose the Split Panels command.

Expand or Collapse Nodes
When the panel presents data in a hierarchical tree configuration (e.g., the system hierarchy, FMEA hierarchy, etc.), the View tab provides several flexible options for expanding and collapsing the nodes (branches) that are currently displayed.

To expand or collapse all branches at the same time, choose Expand Tree or Collapse Tree.

To expand or collapse a specific branch, you can click the + or - icons, or select the item and choose Expand Node or Collapse Node.

To collapse all branches in the tree to a specific level, select any item at the desired level and choose Collapse to Level.

As an example, the following pictures show how the hierarchy collapses to the second (subsystem) level.
Selecting Which Columns to Display
When applicable, you can hide, display or reorder the columns shown in a particular type of hierarchy by right-clicking any column heading and choosing Customize Columns. These settings are stored per computer/username, and different users may have different display preferences without affecting the stored data. The same preferences can also be managed from the relevant page of the Application Setup.

Printing
ReliaSoft desktop applications offer different printing utilities for data sheets, diagrams, plots and Synthesis Workbooks.

Data Sheets and Diagrams
To print a data sheet or diagram, choose File > Print or press CTRL+P on the keyboard.
To print an Xfmea, RCM++ or RBI diagram (e.g., FMEA block diagrams, etc.), choose Home > Print > Print.

Plots
To print a plot, choose File > Print or press CTRL+P on the keyboard.
To print a plot displayed in the Plot Viewer (as seen in Xfmea, RCM++, RBI and Lambda Predict), click the Print icon on the plot control panel.

Synthesis Workbooks
To print Synthesis Workbooks, choose View > Print > Print Preview. For more printing options, you can send the report to Microsoft Word or Excel and use the print utilities in those applications. Choose Home > Report > Send to Excel or Send to Word.

Reports Generated in Word or Excel
In Xfmea, RCM++, RBI, MPC and Lambda Predict, reports are generated in Microsoft Word or Excel. You will need to use the print utilities built in to those applications.

Other Features
For other features that offer the print functionality (e.g., RS Draw, Resource Manager, etc.), the Print icon will be displayed in the window itself.
Page Setup - Plots and Diagrams
The Page Setup for plots and diagrams is accessible via the print window (see Printing).

Maximize Printing Space
The following options are available on the Page tab or Margins tab of the Page Setup.

- **Orientation.** The Portrait orientation works best for small charts and diagrams. If the image is wider than it is tall (which is the case for most plots), select the Landscape orientation.

- **Keep aspect ratio** (available for plots). Select this option to maintain the proportional relationship between the width and height of the image. Clear the check box if you want to stretch the image to fill the paper.

- **Scaling** (available for diagrams) allows you to shrink or enlarge a diagram to fit a specified number of pages. For example, to print a diagram to four pages in a rectangle, you would enter the values 2 by 2 pages. The software will automatically adjust the size of the diagram image to fit to the specified pages.
  
  - **Print without margins** removes the borders or white edges of the image for printing. Recommended if you plan to print the image to multiple pages and then assemble the pages into a whole picture.
  
  - **Print empty pages** prints any blank pages within the print area; otherwise, the blank pages are omitted from the printout.

- **Margins.** By default, the margins will be printed based on the **System’s default** option, which is the measurement system specified in your computer’s [region and language settings](http://predict.reliasoft.com). You can change the unit to inches or centimeters as desired.

Headers/Footers
To add custom headers/footers for printing, click the **Header/Footer** tab of the Page Setup.

To insert variable information such as date, time, number of pages, etc., use the command icons in the window to insert the appropriate field codes (or use the codes shown in the table below).

<table>
<thead>
<tr>
<th>Field Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;A</td>
<td>Inserts the sheet name. (Does not apply to plots in Xfmea, RCM++, RBI and Lambda Predict.)</td>
</tr>
<tr>
<td>&amp;D</td>
<td>Inserts the current date.</td>
</tr>
</tbody>
</table>
Page Setup - Data Sheets
The Page Setup for data sheets is accessible via the print window (see Printing). For the spreadsheet module in Synthesis Workbooks, choose View > Print > Page Setup.

Maximize Printing Space
The following options are available on the Page tab or Margins tab of the Page Setup.

- **Orientation.** The Portrait orientation works best when the data has more rows than columns. If the data sheet is wider than it is tall, select the Landscape orientation.

- **Scaling** allows you to shrink the font size by a certain percentage to fit the data sheet into one page, or enlarge it to span the data sheet across multiple pages.

- **Paper size** and **Print quality.** The options depend on the type of printer you use.

- **First page number** allows you to specify any number to be the starting page number.

- **Margins** adjusts the widths of the margins on the paper.

- **Center on page** allows you to center the data sheet in the printout horizontally, vertically or both.
Chapter 3: Desktop Application Interfaces

Print Order and Other Options
The Sheet tab of the Page Setup provides more printing options:

- **Print area** allows to specify a range of cells to print. Recommended if you want to print only a specific selection of data and not the entire data sheet. For example, you could enter the range A1:B10 to print only cells A1 through B10. To print the entire data sheet, clear this field.

- **Print titles**. If your data sheet is more than one page long, you can repeat row or column titles on each printed page to make it easier to read your data. For example, to repeat the column titles of a data table that has several rows spanning multiple pages, you could enter the range $1:$1 into the **Rows to repeat at top** field, where $1:$1 is the location of the column title in the table.

- **Gridlines** prints the gridlines of a data sheet.

- **Draft quality** prints the data sheet at a lower quality for faster printing.

- **Row and column headings** prints the row numbers and column headings of the data sheet.

- **Comments**. If you’ve added comments to the data sheet, you can choose to print them along with the data sheet. Choose whether to print the comments at the end of the sheet or as they are displayed in the sheet.

- **Cell errors as** allows you to specify how any cell errors in the data sheet should be displayed in the printouts. Choose whether to print them as displayed, <blank>, dashes (--) or as #/NA

- **Page order**. If your data sheet spans multiple pages, you can specify the order in which the pages are numbered and printed.
  - **Down, then over** prints from the top down, then left to right.
  - **Over, then down** prints from left to right, then from the top down.

Headers/Footer
The Header/Footer tab of the Page Setup provides several options for adding custom headers/footers to the printed page.

- **Header** and **Footer** drop-down lists allow you to select a predefined header/footer format. The software includes several predefined formats to choose from.

- **Different odd and even pages** and **Different first page** gives you the option to apply different headers/footers for odd and even pages, or choose to apply a different header/footer to the first page only. Select the check box for the desired option and then click the **Custom Header/Footer** button to edit the headers (see the section [here](http://predict.reliasoft.com)).
below). To apply the same header/footer to all pages in the document, clear the check boxes for both options.

- **Scale with document** auto-adjusts the font size to scale with the data sheet.
- **Align with page margins** auto-adjust the position of the header/footer to be consistent with the page margins.

**Edit the Headers/Footers**

You can edit the headers/footers for the current printing session. Note that the edits are discarded when you switch to different header/footer format or when you exit the print preview.

To edit an existing header/footer, choose it from the drop-down list and click the **Custom Header/Footer** button. Alternatively, you can select **none** from the drop-down list and then click the button.

To insert variable information such as date, time, number of pages, etc., use the command icons in the window to insert the appropriate field codes (or use the codes shown in the table below).

<table>
<thead>
<tr>
<th>Format Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;[Page]</td>
<td>Inserts the page number.</td>
</tr>
<tr>
<td>&amp;[Pages]</td>
<td>Inserts the number of pages.</td>
</tr>
<tr>
<td>&amp;[Date]</td>
<td>Inserts date.</td>
</tr>
<tr>
<td>&amp;[Time]</td>
<td>Inserts time.</td>
</tr>
<tr>
<td>&amp;[Path]&amp;[File]</td>
<td>Inserts the file path.</td>
</tr>
<tr>
<td>&amp;[File]</td>
<td>Inserts the file name.</td>
</tr>
<tr>
<td>&amp;[Tab]</td>
<td>Inserts the sheet name.</td>
</tr>
<tr>
<td>&amp;[Picture]</td>
<td>Inserts a selected picture. Click the <strong>Format Picture</strong> icon on the Header/Footer window to set the image size and other properties.</td>
</tr>
</tbody>
</table>
Page Setup - Word Processing Module
To access the Page Setup for the word processing module in Synthesis Workbooks, choose View > Print > Page Setup.

Maximize Printing Space
The following options are available on the Margins tab or Paper tab of the Page Setup.

- **Margins** adjusts the widths of the margins on the paper.
- **Orientation.** The Portrait orientation works best when the data has more rows than columns. If the data sheet is wider than it is tall, select the Landscape orientation.
- **Paper size.** The options depend on the type of printer you use.

Layout
The Layout tab of the Print Setup provides more printing options:

- **Section** divides the report into several sections, where each section can have different formatting elements such as the page orientation, margins, headers/footers, etc. The easiest way to insert section breaks is to exit the Page Setup and choose Page Layout > Page Setup > Breaks.

- **Headers and footers.** You can choose to apply different headers/footers for odd and even pages, or choose to apply a different header/footer to the first page only. To apply the same header/footer to all pages in the document, clear the check boxes for both options.

To configure and save header/footer information into the report, exit the Page Setup and choose Document > Header & Footer > Header or Footer.

To set up a header/footer that applies only to the current printing session (i.e., the information will be lost when you exit the preview), exit the Page Setup and choose View > Print > Print Preview. In the preview window, click the Header/Footer icon on the ribbon. To insert variable information such as date, time, number of pages, etc., use the command icons in the window to insert the appropriate field codes (or use the codes shown in the table below).

<table>
<thead>
<tr>
<th>Format Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Page #]</td>
<td>Inserts the page number.</td>
</tr>
<tr>
<td>[Pages #]</td>
<td>Inserts the number of pages.</td>
</tr>
<tr>
<td>[Page # of Pages#]</td>
<td>Inserts date.</td>
</tr>
<tr>
<td>Insert</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>[Date Printed]</td>
<td>Inserts the current date.</td>
</tr>
<tr>
<td>[Time Printed]</td>
<td>Inserts the current time.</td>
</tr>
<tr>
<td>[User Name]</td>
<td>Inserts the username of the current user.</td>
</tr>
</tbody>
</table>
Chapter 4: Lambda Predict Ribbon

In ReliaSoft desktop applications, the ribbon replaces the toolbars and menus used in older software. The ribbon is divided into tabs that relate to a task or activity, such as managing the projects in a database or performing a specific type of analysis. Depending on the current activity, some commands may appear dimmed or will not appear at all.

Note that many features in the application also have a shortcut menu (accessed by right-clicking) that gives access to commands that are commonly used for that feature. All commands available in the shortcut menus are also available on the ribbon.

To minimize the ribbon and maximize your workspace, click the arrow on the right-side of the ribbon (labeled "Minimize Ribbon" in the picture below). The ribbon will be expanded when you click a tab and then minimized after you click a command.

Quick Access Toolbar

The Quick Access Toolbar is a customizable feature of the ribbon that allows you to access frequently used commands without changing tabs.

To add your favorite ribbon commands to the Quick Access Toolbar, right-click the command and select Add to Quick Access Toolbar.

To remove a command from the Quick Access Toolbar, right-click the command and select Remove from Quick Access Toolbar, or click the Customize Quick Access Toolbar icon and clear the check box for the command.

To reposition the Quick Access Toolbar, click the Customize Quick Access Toolbar icon and select to show it either below the ribbon or above the ribbon.

To reset the Quick Access Toolbar to default settings, click the Reset All Settings button in the Application Setup (File > Application Setup).
Chapter 4: Lambda Predict Ribbon

Backstage View (File Tab)

The Backstage view (File tab) is the first view you will see when you start a ReliaSoft desktop application.

Save (available only when a Synthesis file is currently open) saves all recent changes to the Synthesis file (*.rsf18). This command is not applicable in a standard or enterprise database, because the changes are saved automatically as you work.

Save As (available only when a standard database or Synthesis file is currently open) saves a copy of the standard database or Synthesis file to another pathname/filename and/or file type. You can save the file as a new standard database (*.rsr18), Synthesis file (*.rsf18) or compressed standard database (*.rsgz18).

Pack and E-mail (available only when a standard database or Synthesis file is currently open) sends a compressed version of the standard database or Synthesis file via e-mail.

Open Repository opens an existing standard database (*.rsr18), enterprise database (*.rserp), Synthesis file (*.rsf18) or a compressed standard database (*.rsgz18).

Close Repository closes the database. You also can close the database by opening another database or by exiting the application.

Recent shows a list of recently opened database files (*.rsr18, *.rserp and *.rsf18) and a list of recently accessed locations. Clicking a database will open it, and clicking a location will allow you to browse for databases in that location. The number of items in these lists is set in the Synthesis Settings page of the Application Setup. You can pin items to a list by clicking the pushpin icon associated with the item; when the pin is vertical, the item will not roll off the list.

New allows you to create a new standard database (*.rsr18), Synthesis file (*.rsf18) or connection file for access to an enterprise database (*.rserp).

Manage Repository provides a variety of tools and configurable settings for the repository. The settings are shared by all users and all analysis projects in a database.

Print (available only in Weibull++, ALTA, RGA, BlockSim and RENO) generates a print preview of the current data sheet, diagram or plot, and sends it to the printer.

Help provides a variety of resources to help you use the application more effectively. In addition, it displays information about the application, including the Compile Release Version (CRV) and License information.
**Application Setup** allows you to set your personal preferences for working with analyses, such as the math precision, default plot settings and the like. The settings apply only to the current computer/username, and they do not affect the results of the analyses.

**Exit** closes the current database (if any) and shuts down the application.

**Manage Repository**

The Manage Repository section of the Backstage View contains the following commands. The available commands depend on the current application and the database type.

**Users**

- **Users and Security** controls which users can access the repository and their permissions.
- **User Groups** create and manage groups of users that can be assigned to actions, messages, etc. throughout the current database.
- **Repository Logins** displays a list of users who have connected to the repository and allows you to export this information to Excel.
- **Reset "In Use" Flags** allows you to reset the flags that indicate the "in use" status of projects or items within a project.

**Lambda Predict Repository Settings**

Available only in Lambda Predict:

- **FIDES Settings Manager** defines the settings related to the FIDES prediction standard such as process audits, pi factors, categories, etc. (See FIDES Settings Manager in the Lambda Predict documentation.)

- **Custom Derating Standards Manager** allows you to add, edit, delete or import/export custom derating standards. (See Creating Custom Derating Standards in the Lambda Predict documentation.)

- **MIL-217 Custom Connections** defines custom connection types for use with the MIL-HDBK-217F prediction standard. (See MIL-217 Custom Connection Types in the Lambda Predict documentation.)
Xfmea/RCM++/RBI Libraries
Available only in Xfmea, RCM++ and RBI:

Profiles/Library Manager configures the predefined settings of the profiles stored in the software library. Profiles allow you to customize the look, drop-down lists, rating scales and other settings of a particular project in order to fit the needs of the analysis. (See Profiles/Library Manager in the Xfmea/RCM++/RBI documentation.)

Templates Manager allows you to manage the configurable templates that can be used for customized reports, saved queries or importing/exporting data via Excel. (See Templates Manager in the Xfmea/RCM++/RBI documentation.)

Settings and Predefined Options

Repository Settings allows you to enable alerts via e-mail or SMS, activate history logs, and other settings.

Unit Settings defines the unit and measurement settings that will be available for use in any project within the database.

Project/Item Categories defines the categories that can be used to filter and group data throughout the database.

Default Name Formats (not applicable for MPC) specifies the default names for new resources, as well as new blocks in BlockSim RBDs, fault trees and phase diagrams.

Project Planning Resources (not applicable for MPC) defines the cost categories, teams, materials and facilities that are used for tracking costs, man hours and resource utilization in actions and Project Planner gates.

Working Days/Holidays (not applicable for MPC) specifies the business days when project planning resources can be utilized.

Dashboard Layout Manager (not applicable for MPC) shows all of the predefined dashboard layouts that will be available for any user to view for a particular data set.

Task Types (applicable only in RCM++, RBI and MPC) maps the task types used in RCM++ and RBI (e.g., Restoration, Failure Finding, etc.) to the corresponding task classes in the universal reliability definition (e.g., Preventive, Inspection, etc.) so that simulation and cost calculation results are accurate. (See Task Types in RCM++/RBI in the Xfmea/RCM++/RBI documentation.) In MPC, it allows you to modify the abbreviations...
used for the MSG-3 task types. (See Task Type Abbreviations in MPC in the MPC documentation.)

**XFRACAS Connection** is available only for standard databases (*.rsr18) or Synthesis files (*.rsf18) in Weibull++/ALTA, RGA, and Xfmea/RCM++/RBI. It allows you to define connection settings for an enterprise repository.

### Database Tools

- **New Enterprise Repository** opens a wizard that leads you through the steps to create a new enterprise repository (SQL Server or Oracle database). To use this option, you must have access to a server with a supported version of SQL Server or Oracle and you must have the appropriate permissions to create a new database on the server.

- **Upgrade Enterprise Repository** converts an existing Version 9 or later enterprise database to a Version 2018 enterprise database. *This cannot be undone.* It is recommended that you create a backup of the database before performing the upgrade.

- **Upgrade Version 8 Repository** copies all of the existing data from a Version 8 enterprise database to a new Version 2018 enterprise database.

- **Restore Points** manages all of the project backups that are stored in the current database.

- **Compact and Repair** is available only in a standard database (*.rsr18) or Synthesis file (*.rsf18). It helps to reduce the size of the database and protect against data loss and corruption. (See Backups and Database Maintenance.)

- **Import from Version 5** is available only in Xfmea, RCM++ and RBI. It allows you to import data from a Version 5 Xfmea/RCM++ database. This command is available only when you are connected to an enterprise database and have the "Manage users and logins" permission and the applicable "manage all projects" permissions.

### Help Center

The Help Center, which is part of the Backstage view, is intended to help you use the application more effectively by providing quick access to a variety of support tools. To access the Help Center, choose File > Help.
Chapter 4: Lambda Predict Ribbon

**Using This Application**

- **Help File** opens the application's help file. If you have an active Internet connection, the help topics that you see will always be the most up-to-date versions available. If you do not have an active Internet connection, the help topics that you see will be the local copy that was installed on your machine.

- **User Guide** opens the application's *User's Guide* (in PDF format) if you have an active Internet connection.

**Online Resources**

- **reliasoft.com** opens the main page of the [Reliasoft website](http://predict.reliasoft.com).

- **weibull.com** opens the [Weibull website](http://predict.reliasoft.com), which is devoted entirely to the topic of reliability engineering, reliability theory and reliability data analysis and modeling.

- **reliawiki.org** opens the [ReliaWiki website](http://predict.reliasoft.com), which is both a resource portal and a wiki for professionals in reliability engineering and related fields.

**Examples**

- **Open Examples Folder** provides access to a set of example projects that are designed to help you explore various software features.

**Technical Support**

- **E-mail Support** generates an e-mail to request technical support. The e-mail is pre-populated with information about your license and operating system, which the technical support representative will need for troubleshooting the issue.

- **Contact Technical Support** provides the contact information you will need to obtain technical support.

- **Check for Update** allows you to download the latest free service release for the software.

- **Licensing** displays your license and registration details. To view or edit additional information, click **License Manager**. The **License Manager** displays additional information about which products you have currently registered and/or your contact information on file with us.

- **About** displays the application's Compile Release Version (CRV) (sometimes called a "build number"), which allows you to determine whether you have the latest version of the software.
Home Tab
The Home tab contains the following commands:

Clipboard
- **Paste** pastes the contents of the Clipboard into the desired level in the current system hierarchy. Choose **Paste as Same Level Item** to paste the item at the same level as the currently selected item. Choose **Paste As Next Level Item** to paste the item under the currently selected item.

- **Cut** cuts the selected text or graphic to the Clipboard. Data stored on the Clipboard can be pasted into this and other applications.

- **Copy** copies the selected text or graphic to the Clipboard. Data stored on the Clipboard can be pasted into this and other applications. If you are copying a plot, the way the plot is copied will depend on your selection in the **Copy Plot Graphic** setting in the Application Setup window.

Templates
- **Report Templates** allows you to create a custom report template.

- **Import Templates** opens an import template that is used for importing "bill of materials" (BOM) files into Lambda Predict.

Insert
- **Prediction Folio** adds a new prediction folio to the project.

- **Plot** opens the Plot Viewer, which allows you to create graphical charts based on the selected source data. (See Prediction Plots.)

- **Attachment** adds linked or attached files to the project.

Hierarchy
- **Delete** deletes the selected item or record and all associated data. *There is no undo for delete.*
Chapter 4: Lambda Predict Ribbon

**Find** searches the current system hierarchy for specified text/values. You can select whether to limit the result to text that have the same case (Match case) and/or limit the results to text that are identical to the search term (Match whole field only).

**Move Up** moves the currently selected record up within the system hierarchy.

**Move Down** moves the currently selected record down within the system hierarchy.

**Synthesis**

**Resource Manager** opens the Resource Manager window, which allows you to view and edit all of the resources (URDs, models, tasks, etc.) available to the selected project. This command is not available in MPC.

**Synthesis Explorer** allows you to explore all of the different analyses that are stored in the current database. You can filter, group and sort the analyses in a flexible grid, and also present the information in a wide variety of dashboard charts. (See Synthesis Explorer.)

**Actions Explorer** allows you to explore all of the action resources that are stored in the current database. You can filter and sort by date, status, person responsible, relevancy to you, etc. (See Actions Explorer.)

**Batch Properties Editor** opens the Batch Properties Editor, which allows you to perform batch editing of most types of local resources in the current project. In BlockSim, it also allows you to edit the blocks used in the diagrams. This command is not available in MPC.

**Launch Application** provides a drop-down list of the other ReliaSoft desktop applications that are installed on your computer. When you click an icon, the same database will be opened automatically in the new application.

**My Portal Tab**

**Messages**

**Create Message** opens the Message window, which allows you to compose and send messages within the database.
Edit Message opens the Message window, which allows you to view and edit all of the properties of the message.

Reply to Message opens the Message Reply window, which allows you to respond to a message sent to you.

Delete Message deletes the current message.

**Actions**

Create Action opens the Action window and adds an action to the project.

Edit Action opens the Action window, which allows you to view and edit all of the properties of the action record.

Delete Action deletes the current action record.

Add to Outlook Calendar adds an event, on the Action's due date, to your Outlook calendar.

**Users**

My Profile opens the User Login and Contact Information window where you change your contact details for your user account in the current database.

**Project Tab**

Unless otherwise indicated, these commands apply to the project that is currently selected in the project list. There are three ways to select a project and apply a command:

- By right-clicking the project in the project list and choosing the command from the shortcut menu.
- By selecting the project in the project list and then clicking the command on the ribbon.
- By clicking anywhere inside the project that is currently open/visible and then clicking the command on the ribbon.

*Note:* For secure databases, access to the commands on this tab may be restricted based on the permissions assigned to the user account.
Chapter 4: Lambda Predict Ribbon

Management

Create Project adds a new project to the current database. At a minimum, you must specify the project name.

Open Project opens the selected project.

Close Project closes the project that is currently open/visible and all of the analyses it contains.

Edit Project Properties allows you to view and edit the properties of the selected project.

Duplicate Project creates a copy of the selected project. The new project will have the same name as the original with an increment number added to the end (e.g., Project_1, Project_2, etc.).

Delete Project moves the selected project to the recycle bin.

Transfer Project is available only in Xfmea/RCM++/RBI. It allows you to create a new project with data transferred from the selected project. (See Transfer Projects in the Xfmea/RCM++/RBI documentation.)

Task Numbering is available only in MPC. It allows you to specify whether or not you want to reuse task numbers within the project. (See Task Numbering in MPC in the MPC documentation.)

Manage Projects opens the Manage Projects window, which allows you to edit the security settings and properties of all projects in the database in one location.

Import/Export gives you the option to open either the Import or Export wizard. The Import wizard allows you to import projects, resources or items from an existing database into the current database, while the Export wizard allows you to export to a new or existing database. (See Import, Export and Data Conversion.)

Configurable Settings is available only in Xfmea/RCM++/RBI. It allows you to view/modify the configurable settings for the current project. (See Configurable Settings in the Xfmea/RCM++/RBI documentation.)

Restore Point gives you the option to utilize restore points, which are exact replicas of the project at a particular point in time (i.e., backups). To create a restore point for the
selected project, use the **Create Restore Point** command. To restore all data from an existing restore point, use the **Restore Project** command.

**Check In/Out** allows you to check out the selected project and make it available for editing only to you, while all other users in the database have read-only access to the project. No other user can edit the project unless you check in the project or undo the check out.

**Recycle Bin**

**Empty Recycle Bin** permanently deletes all projects under the **Recycle Bin** heading in the project list. ***There is no undo for emptying the recycle bin.***

**Restore Project** is available only when you have selected a project under the Recycle Bin heading. The selected project will be recovered from the recycle bin and restored to its original location in the project list.

**Delete Project** permanently deletes the selected project. ***There is no undo for delete*** unless you have a stored backup or restore point.

**History Log** is available only if you are the **project owner** or have the applicable "**manage all projects**" permissions. It opens the **Project History Log window**, which allows you to activate and deactivate the history log for the project and, if the history log is currently activated, to view changes that have been performed throughout the entire project, with any ReliaSoft application.

**Project Planner** opens the **Project Planner**, which provides full project planning and management capabilities for the current project. This command is not available in MPC.

**Attachments** is available only in Xfmea/RCM++/RBI and MPC. It adds linked or attached files to the selected project. In other ReliaSoft desktop applications, attachments commands are available in the current project explorer.

**E-mail Project**

**Pack and E-mail** compresses a copy of the selected project to a *.rsgz18 file and attaches it to a new e-mail message. If no e-mail program is installed or no default e-mail program is defined on the computer, a message notifying you of this will be shown.
Chapter 4: Lambda Predict Ribbon

Security

pherd Project Security is available only for public projects in secure databases. It opens the Project Properties window with the Security tab active, where you can specify the user accounts that can view/modify the selected project.

pherd Change Owner allows you to assign a different database user to be the owner for the selected project.

pherd Lock Project moves the project into the Locked heading of the project list. When a project is locked, all database users (including the user who locked the project) will have read-only access to the project. In addition, a locked project cannot be deleted or have its properties and public/private status edited. To unlock a project, choose Unlock Project. (See Locked and Unlocked Projects.)

pherd Make Private moves the selected public project into the Private heading of the project list. (See Public, Private and Reference Projects.)

pherd Make Public moves the selected private or reference project into the Public heading of the project list.

pherd Make Reference moves the selected public project into the Reference heading of the project list. This command is not available in MPC.

Current Item

The following commands are available when you select a specific item (a diagram, report, multiplot, etc.) in the current project explorer. This group is not available in Xfmea/RCM++/RBI or in MPC.

pherd Edit brings the selected item to the front of the windows and activates it as the current control. If an attachment is selected, the command opens the attachment in the appropriate application, if that application is installed on your computer.

pherd Rename allows you to rename the selected item.

pherd Duplicate creates a copy of the selected item within the project. The duplicate will have the same name as the original with an increment number added to the end (e.g., RBD1_1, RBD1_2, etc.). In BlockSim, you can choose to Duplicate With Resources, which also creates duplicate resources in the Resource Manager window.

pherd Delete deletes the selected item. There is no undo for delete.
Item Properties is available only for project explorer items (e.g., folios, diagrams, plots, etc.). It opens the Item Properties window, which allows you to view and edit the item's Identifiers, item settings (if applicable) and item permissions (in secure databases).

Save Locator Link is a link file (similar to a Windows shortcut) that provides quick access to the specific analysis. In an enterprise database, you can choose to Save or E-mail the file. In a standard database or Synthesis file, the only option is to save the file. In Xfmea/RCM++/RBI, these commands are available in the System Hierarchy tab. In MPC, they are in the Systems, Structures or Zones tab.

Data Management
The following commands are available only in BlockSim.

Mirror Group Manager opens the Mirror Group Manager window, which allows you to add, view and edit groups of mirrored blocks within the project that is currently open/visible. (See Mirroring (Using Blocks in Multiple Locations) in the BlockSim documentation.)

Maintenance Group Manager opens the Maintenance Group Manager window, which allows you to add, view and edit the maintenance task groups available to the project that is currently open/visible. (See Maintenance Groups.)

Flow Group Manager opens the Flow Group Manager window, which allows you to add, view and edit the flow groups available to the project that is currently open/visible. (See Flow Groups in the BlockSim documentation.)

Reports
MRBR is available only in MPC. It allows you to generate a maintenance review board report in Microsoft Word. (See Maintenance Review Board Reports in the MPC documentation.)
Chapter 4: Lambda Predict Ribbon

**View Tab**
The View tab contains commands related to configuring the layout of the application's interface.

**Refresh**

Refresh refreshes the display in the Project window. If multiple users are accessing the same project simultaneously, this command will refresh your screen with any changes made by other users. When you make a change to the project, your window will be refreshed automatically.

**Project Manager**

Show Project Manager brings the Project Manager into focus. If the Project Manager is unpinned and hidden, choosing this command will display it.

Tile Project Manager tiles the project list and current project explorer so they are both displayed simultaneously in the Project Manager panel. This command is not available in Xfmea, RCM++, RBI or MPC.

Dock Project Manager opens a submenu that allows you to choose the desired position for the Project Manager: Dock Left, Dock Right, Dock Top, Dock Bottom or Floating.

**My Portal**

Show My Portal opens the My Portal window, which provides information relevant to your work within the database, such as messages from other users, recommended actions for a particular project item, status of other users logged in to the database and other information.

Tile My Portal tiles the Messages, Actions and Users pages so they are all displayed simultaneously within the My Portal panel.

Dock My Portal opens a submenu that allows you to choose the desired position for the Portal: Dock Left, Dock Right, Dock Top, Dock Bottom or Floating.

**Workspace Layout**
The commands in this group are available only in Xfmea, RCM++, RBI, MPC and Lambda Predict.
Chapter 4: Lambda Predict Ribbon

Change Orientation toggles between the two possible orientations for the System panel and the Analysis/Properties panel. These panels can be side-by-side or one on top of the other.

Hide System [Panel/Hierarchy] hides the System panel in the Project window. When you want to show the panel again, choose View > Workspace Layout > Split Panels.

Hide [Analysis Panel/Properties] hides the Analysis/Properties panel in the Project window. When you want to show the panel again, choose View > Workspace Layout > Split Panels.

Split Panels splits the Project window into two equal panels, with 50% of the available space used for the System panel and 50% of the available space used for the Analysis/Properties panel.

Properties View is available only in Lambda Predict.

Tree View organizes the properties depending on whether they are physical properties (e.g., part quality level, case type, etc.) or application properties (e.g., ambient temperature, applied voltage, etc.). Depending on the prediction standard and component you are working with, the properties may also be organized according to failure mechanisms or type of data.

Pi Factor View organizes the item properties based on the pi factors that they contribute to so you can see how the values affect the failure rate calculations. The relevant pi factors will vary depending on the item's failure rate model. (See the Tree View and Pi Factor View topic in the Lambda Predict documentation.)

Expand/Collapse

The commands in this group apply to the hierarchical view that currently has focus. Depending on the application, this can be the project list, the current project explorer, the System panel, the Properties panel (Lambda Predict only) or the Analysis panel if it is using a hierarchical view.

Expand Tree expands the entire tree in the hierarchical view.

Collapse Tree collapses the entire tree in the hierarchical view.

Expand Node expands the selected branch in the hierarchical view.

Collapse Node collapses the selected branch in the hierarchical view.
Chapter 4: Lambda Predict Ribbon

Collapse to Level collapses the hierarchical view to the level of the item that is currently selected. For example, if you have selected a cause in the FMEA hierarchy view and choose this command, all branches in the FMEA hierarchy view will be collapsed to the cause level and the nodes for controls and actions will be hidden.

**Zoom**

- **Normal Zoom** sets the degree of magnification to 100%.
- **Zoom In** increases the degree of magnification.
- **Zoom Out** decreases the degree of magnification.
- **Custom Zoom** allows you to specify the degree of magnification.

**Window**

- **Use Tabbed MDI** maximizes the windows to fill the full space available in the MDI and shows a tab for each open window. If you clear this command, the open windows will be displayed as separate windows that can be resized and moved around within the MDI.

- **Cascade** cascades all open project windows inside the MDI.
- **Tile Horizontally** horizontally tiles all open project windows inside the MDI.
- **Tile Vertically** vertically tiles all open project windows inside the MDI.

The **Windows** drop-down list displays a list of all project windows currently open inside the MDI. You can make any of the open project windows active by clicking its name in this ribbon.

- **Close All Windows** closes all open project windows inside the MDI, leaving only the Project Manager and My Portal panels open (if they were selected to be shown).

**FMRA**

The commands in this group are available only in BlockSim. (See Failure Modes and Reliability Analysis (FMRA) in the BlockSim documentation.)
Show FMRA opens the FMRA view, which displays the FMRA (failures modes and reliability analysis) hierarchy that is associated with the project.

Disassociate FMRA deletes all of the diagrams and blocks associated with the current FMRA hierarchy and closes the FMRA view.

Show

The commands in this group are available only in Xfmea, RCM++ and RBI.

Show FMRA enables/disables the FMRA tab in the System panel.

Show Test Plan opens the Test Plan tab in the analysis panel, which displays a list of actions that describe specific tests that need to be performed. (See the Test Plans topic in the Xfmea/RCM++/RBI documentation.)

Active Tabs

System Hierarchy Tab

The System Hierarchy tab contains commands related to working in the System Hierarchy panel.

Add Item

Import BOM launches the Import BOM Wizard, which helps you import system configuration data from an external "bill of materials" (BOM) data file.

Add Top Level Item allows you to add a system or assembly that will be analyzed using one prediction standard. Note that the prediction standards that are not included in your license are available in demo mode only. For information about upgrading your license to use a particular standard, please contact ReliaSoft. (To view the contact information in Lambda Predict, choose File > Help, and then select the Contact Global Support Center link.)

Add Next Level Item and Add Same Level Item allow you to add blocks or components in the next level under a selected item or to the same level as the selected item.

- Block adds a generic block that can be used to group components and/or other blocks into any type of assembly.
Chapter 4: Lambda Predict Ribbon

- **Component/Block** opens the Select a Component window, which displays a list of all the components and blocks that apply to the prediction standard you are working with.

- **Import from PartLibraries.org** allows you to search for and import components from the web-based PartLibraries.org database. This library provides free access to the integrated circuit (IC) component definitions published in MIL-M-38510, the electronic component failure rates published in EPRD-97 (Electronic Parts Reliability Data) and the mechanical, electrical and electromechanical component failure rates published in NPRD-95 (Nonelectronic Parts Reliability Data). In addition, if you want access to more than 300,000 commercial components with reliability prediction parameters predefined based on the published manufacturer spec sheets, you can purchase a yearly subscription that offers unlimited access to the full parts data library. (See Import from PartLibraries.org.)

- **Import Local Components** allows you to import any component saved in the current folio, current database, another database or custom library file. (See Import Local Components.)

**PartLibraries.org**

- **Import from PartLibraries.org** imports component data from PartLibraries.org. (See Import from PartLibraries.org.)

- **Update Branch** automatically updates the physical and general properties of all sub-items of a selected standard item or block based on data from PartLibraries.org. This will overwrite any existing data in those fields and **cannot be undone**.

- **Update Item** automatically updates the physical and general properties of a selected component based on data from PartLibraries.org. This will overwrite any existing data in those fields and **cannot be undone**.

**Local Components**

- **Add to Library** is available only if both the Name and Part Number properties of a selected component are defined. It allows you to add the selected component to a custom library file. (See Using Custom Library Files.)

- **Manage Library** opens the Manage Library window, which allows you to add or edit custom library files.

- **Import Local Components** opens the Import Local Components window, which allows you to import components that have already been defined in an existing analysis
(the current prediction folio, current database or another database) or from a custom library file (*.lplib18).

Update Branch updates the physical and general properties of all sub-items of a standard item or block based on data from a library file. This will overwrite any existing data in those fields and cannot be undone.

Update Item updates the physical and general properties of a selected component based on data from a library file. This will overwrite any existing data in those fields and cannot be undone.

**Status Flag**

- Clear removes the status flag from the selected record.
- In Progress displays a yellow flag for the selected record.
- Complete displays a green flag for the selected record.
- Incomplete displays a red flag for the selected record.

**Tools**

- Attachments allows you to manage the linked or attached files for the selected item.
- Highlight uses red, green and yellow colors to highlight automatically the failure rate of the components based on their contributions to the overall failure rate of their parent system/assembly. (See Highlight.)
- Suspend Auto Calculate allows you to turn off the failure rate calculations that Lambda Predict performs every time you make a change in the analysis data. This is useful when working in very large predictions where every change requires you to wait several seconds or minutes for the application to recalculate all values. When you are finished updating the data, turn calculations back on (by clicking the command again) to recalculate the failure rates and associated contributions.

**Prediction Tab**
The Prediction tab contains commands related to performing a prediction analysis.
Chapter 4: Lambda Predict Ribbon

**Component**

- **Global Edit** opens the [Global Edit window](http://predict.reliasoft.com), which allows you to apply changes to the properties of multiple items all at once.

- **Change Type** opens the [Select a Component window](http://predict.reliasoft.com), which allows you to replace any existing component in the system hierarchy with a different component.

- **Link Block** opens the [Link Block window](http://predict.reliasoft.com), which allows you to change the block or system represented by the selected linked block.

**Component Defaults**

- **Save as Default** saves the existing property values of a selected component as the default values, so that when you add the component to a system hierarchy, the component's properties will be automatically populated with the saved values.

- **Set to Default** allows you to apply the saved default values to any other component of the same type.

**MIL-217**

- **Non-Operational** applies only to item analyzed with the MIL-HDBK-217F prediction standard. It opens the [MIL-217 Non-Operational window](http://predict.reliasoft.com), which allows you to specify the properties of a block or component during a non-operational phase.

**FIDES**

- **Item Phases** opens the [Item Phases window](http://predict.reliasoft.com), which displays the phases that will be used in the calculations for all the components under the selected block or FIDES standard item.

- **Update Factors** automatically updates the values of all pi factors that are based on saved evaluations. This command affects all the FIDES analyses in the current prediction folio. (See [Update Factors](http://predict.reliasoft.com).)

- **Process Contribution** opens the [Process Contributions window](http://predict.reliasoft.com), which allows you to adjust the weights used in the current prediction folio to calculate a value for the process audit.

**Prediction Tools Tab**

The Prediction Tools tab contains the following commands:
Data Views

- Calculation Information opens the Calculation Information window, which displays a report of the failure rate and pi factors for the item that is currently selected in the system hierarchy, and allows you to export the information to Excel.

- Plot Viewer creates a plot for any standard item (i.e., ML, BL, TL, MC, FE, SN or G) or block (or F) selected in the system hierarchy. Plots created in this way can be saved with the project by clicking the Save icon. If you do not save the plot manually it will not be saved.

- Report opens the Select Report window which allows you to create a template-based report for your predictions.

Allocation

- Allocation opens the Allocation window, which allows you to use any of five allocation models to determine the reliability requirements for individual assemblies that would be needed to achieve an overall reliability goal.

Derating

- Apply Derating opens the Apply Derating Standard window, which allows you to choose a standard, either published or user-defined, to apply to the selected standard item (i.e., ML, BL, TL, MC, FE, SN or G). From this window, you can also create or edit custom derating standards by clicking the Add or Edit icons.

- Remove Derating removes the applied derating standard from the selected standard item.

- View Component Derating opens the Component Derating window, which plots the derating curves of the selected component, if available.

Share

The following commands allow you to use the results of the prediction analysis as a resource object and make them available for unlimited use anywhere within the project, in any ReliaSoft application that has a need for that type of object. (See Publishing Models from Failure Rate Predictions.)

- Publish Branch publishes the failure rate models of all sub-items of a standard item or block. This includes the supplemental models of any sub-blocks.
Chapter 4: Lambda Predict Ribbon

**Publish Item Model** publishes the failure rate of a selected item as a model resource, making it accessible to all ReliaSoft applications.

**Publish Block Supplemental Model** publishes a failure rate model that represents the portion of the assembly's failure rate that is calculated at the block level, if any (e.g., interconnection failure rates for a MIL-217 analysis, modified failure rates for a Bellcore/Telcordia analysis, etc.).

**Publish SEP Summary** publishes a summary of the current analysis to the Synthesis Enterprise portal website. This is visible only if the enterprise database is configured for SEP and you have the “Publish to Synthesis Enterprise Portal” permission (see Publishing to SEP).
Chapter 5: Prediction Folios

The Lambda Predict prediction folio is the main window you will use to perform your standards based reliability predictions. Note that in addition to standards based reliability predictions, the prediction folio also supports two other types of analyses: reliability allocation and derating.

Creating a Prediction Folio

To create a new prediction folio, choose Home > Insert > Prediction Folio or right-click the Prediction Folios folder in the current project explorer and choose Add Prediction Folio on the shortcut menu.

The setup window offers a choice of how you want to start the folio. The choices are:

- **Start with an empty system hierarchy** creates a new, blank prediction folio.
- **Select standard(s) to be added** allows you to select one or more prediction standards to start with. The new prediction folio will include a standard item for each prediction standard that you select. (Note that there are two types of folios for MIL-217 predictions: part stress and parts count. See Using the Parts Count Method.)
- **Import bill of materials (BOM)** helps you to import system configuration data from an external "bill of materials" (BOM) data file. Your BOM may be in an Excel worksheet or a delimited text file. Select the prediction standard you want to use and then click OK to open the Import BOM Wizard. To learn more about the import process, see Import Bill of Materials.

Click OK to create the prediction folio.

Building a System Configuration

The System Hierarchy panel of the prediction folio is where you define the assemblies and components that you wish to analyze. It uses a tree-based structure of blocks and components to represent the system configuration. To build a system configuration, you can either manually define all the blocks and components, or you can import some or all of the data.

This topic focuses on the tools available to build and manage the system configuration manually. For information on importing component/assembly data from another analysis or
from a part library, see Import Predefined Components. For information on importing an existing system configuration from an Excel file or delimited text file, see Import Bill of Materials.

### Adding Standard Items

In Lambda Predict, a *standard item* represents a system or assembly that is analyzed using a particular reliability prediction standard (except in the case of generic items, which are discussed below). The most common way to add a standard item to a prediction folio is to choose **System Hierarchy > Add Item > Add Top Level Item**, and then select the prediction standard you wish to use. (For MIL-217 parts count analysis, see Using the Parts Count Method.)

Similar commands will also be available when you have selected another standard item and choose **Add Same Level Item**, or when you have selected a generic standard item and choose **Add Next Level Item**.

![Add Top Level Item](image)

**Note:** Only the items for the prediction standards that are included in your Lambda Predict license will be displayed. To expand your license, please contact ReliaSoft. (To view the contact information in Lambda Predict, choose File > Help, and then select the Contact Global Support Center link.)

The generic standard item  provides a way to combine the results from different prediction standards. For example, you can use a generic item to analyze an electromechanical system, where the mechanical components are analyzed with the NSWC standard and the electronic components are analyzed with the Bellcore standard.
In such cases, the failure rates calculated by each prediction standard will be displayed in the units that are typical for that standard, while the combined results for the generic item are automatically converted to the units you specify. You can make this units selection on the Other Settings page of the Application Setup.

For example, in the picture above, the NSWC failure rate is shown in FPMH and the Bellcore failure rate is shown in FITS. Since the user has selected to show generic item results in FPMH, Lambda Predict automatically converts the FITS result (~39 failures per million hours = ~0.039 failures per billion hours) in order to calculate the combined results for both types of components (~4.4381 + ~0.039 = ~4.4771 FPMH).

### Adding Blocks and Components

A component represents an individual device at the lowest level in the system configuration, such as a fuse, capacitor, spring, etc., while a block can represent any type of assembly. Each block or component has properties that are based on the prediction standard you are working with.

To add a block or component in the next level under a selected item, choose System Hierarchy > Add Item > Add Next Level Item.

To add a block or component to the same level as the selected item, choose System Hierarchy > Add Item > Add Same Level Item.

There are four choices of items you can add:

- **Block** adds a generic block that can be used to group components and/or other blocks into any type of assembly.

- **Component/Block** opens the Select a Component window, which displays a list of all the components and blocks that apply to the prediction standard you are working with.

- **Import from PartLibraries.org** allows you to search for and import components from the web-based PartLibraries.org database. This library provides free access to the integrated circuit (IC) component definitions published in MIL-M-38510, the electronic...
component failure rates published in EPRD-97 (Electronic Parts Reliability Data) and the mechanical, electrical and electromechanical component failure rates published in NPRD-95 (Nonelectronic Parts Reliability Data). In addition, if you want access to more than 300,000 commercial components with reliability prediction parameters predefined based on the published manufacturer spec sheets, you can purchase a yearly subscription that offers unlimited access to the full parts data library. (See Importing from PartLibraries.org.)

Import Local Components allows you to import any component saved in the current folio, current database, another database or custom library file. (See Importing Local Components.)

Changing the Component Type
You can replace any existing component in the system hierarchy with a different component. Doing so retains all the general properties, such as name, part number, description, etc., that you may have already defined for the component. To replace a component, select the component in the system hierarchy and choose Prediction > Component > Change Type.

In the Select a Component window, select the component you wish to use and click OK. The new component replaces the currently selected item, and the prediction results are updated to account for the failure rate of the new item.

Deleting Items
To delete an item from the system hierarchy, select the item and press DELETE. The item will be deleted, along with all its sub-items and associated attachments. There is no undo for deleting an item in the system hierarchy.

You can also delete an item by selecting it in the system hierarchy and choosing Home > Hierarchy > Delete, or by right-clicking the item and choosing Delete on the shortcut menu.

Moving Items
You can move items within the system hierarchy by dragging them to the desired location. When you move a block that has sub-items, all its sub-items will also be moved.

You can also move an item up or down its current position by selecting the item and choosing Home > Hierarchy > Move Up or Move Down, or by right-clicking the item and choosing those options on the shortcut menu.
Cutting/Copying and Pasting Items

You can cut or copy items in the system hierarchy and paste them to the same project or to another project within the same database. (Please note that if you want to share items between different databases, you must use the Import or Export Wizard. See Import, Export and Data Conversion)

You can use the standard keyboard shortcuts for cut/copy (CTRL+X or CTRL+C) or you can choose Home > Clipboard > Cut or Copy. When an item is cut or copied, all its sub-items will also be cut or copied. You can then paste the item to the desired level in the hierarchy:

- Choose Home > Clipboard > Paste > Paste as Same Level Item or press CTRL+V.
- Choose Home > Clipboard > Paste > Paste as Next Level Item or press CTRL+SHIFT+V.

Note that you will not be able to cut or copy an item in a project that is locked by another user.

Select a Component Window

You can add specific components and blocks to a prediction analysis by choosing System Hierarchy > Add Item > Add [Next/Same] Level Item > Component/Block.

This opens the Select a Component window, which presents a list of items you can add to the system hierarchy. This list will vary depending on the standard you are working with because it reflects the failure rate calculation models available in the particular prediction standard. As an example, the following picture shows some of the blocks and components that are available for a MIL-217 part stress prediction. (If you are using a MIL-217 parts count analysis folio, you can only add blocks and external components. See Using the Parts Count Method.)
As you can see, this list includes some individual components and some specialized blocks that represent specific types of assemblies that are directly addressed by the standard. For example, the IA, Plated Through Holes and IA, Surface Mount Tech blocks facilitate the specific failure rate models from MIL-217 for those types of printed circuit boards.

In addition to the components and specialized blocks that have been designed to fit the specific calculations supported by the current prediction standard, Lambda Predict includes three items that are available regardless of which prediction standard is being used:

- A generic Block can be used to group components into systems or assemblies (if none of the specialized blocks are more appropriate). The properties of a generic block depend on the prediction standard being used, but it also includes properties that are available for all prediction standards, including: Update Modes and Redundancy.

- An External component represents an item that is not covered by the prediction standard being used. Because no failure rate model is provided, you will need to define its failure rate.

- A Linked Block can be used to represent the same system or assembly in more than one location within the system hierarchy. When the analysis for the original (source) system/assembly is updated, any linked blocks are updated automatically. (See Linked Blocks.)
To add multiple items at once, hold the **CTRL** key while clicking all the items in the list you wish to add. To select multiple items that are adjacent, click the first item and then hold the **SHIFT** key while you click the last item. This will select all the items between the first and last.

To add multiple instances of the same type of item, enter the desired value (1-100) in the **Number of Duplicate Items** field at the bottom of the window. Each item will be added in an individual row in the system hierarchy.

**Tip:** If multiple identical items are all subjected to identical stress conditions (e.g., they have the same operating environment, applied voltages, etc.), you can speed up data entry by adding a single instance of the item to the system hierarchy and then using the property called **Quantity** in the item’s Properties panel to specify the number of identical items it represents. All identical items are assumed to be in a reliability-wise series configuration unless you specify redundancy. (See [Redundancy](#).)

### Linked Blocks

A linked block 🖋 can be used to represent the same system or assembly in more than one location within the system hierarchy. When the analysis for the original (source) system/assembly is updated, any linked blocks are updated automatically.

Linked blocks are available regardless of which prediction standard is being used. You can add this block via the [Select a Component window](#).

When you create a new linked block (or double-click an existing one), the Link Block windows allows you to view/select the source that it represents. The source for a linked block can be any standard item (i.e., 🌈, 🌈, 🌈, 🌈, 🌈 or 🌈) or block (i.e., 🌈 or 🌈) in the same prediction folio. As shown next, the label `<None>` indicates that a source has not yet been selected, and the drop-down list can display the names or the part numbers of the eligible source items, depending on your selection.
The source and failure rate for a linked block will also be identified in the Properties panel, as shown next. If you click the **Link Source Name** (which is a hyperlink), the source item will be selected automatically so you can view/edit its properties.

<table>
<thead>
<tr>
<th>Link Source Name</th>
<th>Assembly 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link Source Failure Rate</td>
<td>11835.4305540036</td>
</tr>
<tr>
<td>Link Source ID</td>
<td>5</td>
</tr>
</tbody>
</table>

**Defining Item Properties**

The Properties panel of the prediction folio is where you will view and edit the properties of the item that is currently selected in the system hierarchy.

Some properties are the same for any item (Identifiers, General and History), and the rest are determined by the specific inputs that are required by the specific reliability prediction standard to calculate the failure rate for the particular type of component/block.

The following topics provide general information about using the Properties panel that apply regardless of which method or prediction standard is being used.

For specific information about the features that apply only to a particular prediction standard, you can go directly to the topic of interest:

- **MIL-217 Predictions**
- **Bellcore/Telcordia Predictions**
- **NSWC (Mechanical) Predictions**
- **FIDES Predictions**
- **Siemens Predictions**
Tree View and Pi Factor View

There are two different ways that you can view the information in the Properties panel. To switch between views, choose View > Workspace Layout > Properties View and select one of the following options:

- Tree View
- Pi Factor View

The properties of an item do not change when you switch the view. The view changes only the way the properties are grouped.

While the Tree View organizes the properties under general categories such as Application, Physical, etc., the Pi Factor View organizes the properties based on the pi factors (referred to as multiplying factors in the NSWC standard) in the failure rate model that they contribute to. This makes it possible to directly see how the inputs affect the failure rate calculations.

Tip: You can also display the values of the pi factors in a report view that can be exported to a Microsoft Excel worksheet. To do this, select the item in the system hierarchy and then choose Prediction Tools > Data Views > Calculation Information.

MIL-217, Bellcore/Telcordia, NSWC and Siemens Predictions

The Pi Factor View works in a similar manner for all types of items in MIL-217, Bellcore/Telcordia, NSWC and Siemens. For example, the MIL-217 standard provides the following failure rate model for a discrete semiconductor (e.g., diodes, transistors, etc.):

$$\lambda_p = \lambda_b \pi_T \pi_S \pi_C \pi_Q \pi_E$$

As shown next, the Pi Factor View for this type of component will display a separate group for each term in the equation, where Base Failure Rate = $\lambda_b$, Temperature Factor = $\pi_T$, and so on. Properties that do not directly contribute to any of the pi factors in the model, but may still contribute to the item's overall failure rate, are grouped under the Other Factors heading (e.g., in the MIL-217 standard, the Connection Type and Number of Pins properties are used to take into account the failure rate of the component’s physical connection to a circuit board).
FIDES Predictions
For FIDES predictions, the Pi Factor View shows the properties that affect the base failure rate and/or pi factor for the physical stresses (e.g., thermal, relative humidity, mechanical) that are considered by the model. For example, the standard provides the following model for a discrete semiconductor:

$$\lambda = \lambda_{\text{Physical}} \pi_{PM} \pi_{Process}$$
where:

\[ \lambda_{\text{physical}} = \sum_{i} \left( \frac{t_{\text{annual}}}{8760} \right) \left( \lambda_{0TH} \pi_{\text{Thermal}} + \lambda_{0TcyCase} \pi_{TcyCase} + \lambda_{0TcySolderJoints} \pi_{TcySolderJoints} + \lambda_{0RH} \pi_{RH} + \lambda_{0Mech} \pi_{Mech} \right) (\pi_{\text{induced}})_i \]

As shown next, the Pi Factor View for this type of component will display a separate group for each physical stress, where Mechanical contains the properties that will affect \( \lambda_{0Mech} \), Thermal contains the properties that will affect \( \lambda_{0TH} \) and \( \pi_{\text{Thermal}} \), and so on. All other properties and pi factors (such as Pi Part Manufacturing, Pi Ruggedizing, etc.) are grouped under the Other Factors heading.
Common Properties

There are two kinds of item properties: properties that depend on the prediction standard you are working with (e.g., quality level, voltage stress, etc.) and common properties that are available for all items regardless of which prediction standard is being used. This topic describes these common properties, which include the Identifiers and General sections.

The common properties can be displayed in the System Hierarchy panel and/or the Properties panel:

- To choose which properties will be displayed in the system hierarchy, select the options in the System Hierarchy page of the Application Setup, or right-click anywhere in the system hierarchy and click Customize Columns.

- To choose which properties will be hidden or displayed in the Properties panel, select the options in the Properties page of the Application Setup, or right-click the property name and choose the option on the shortcut menu. The only exceptions are Name, Quantity, Mission Time, Redundancy and Quantity Required. Those five properties must always be displayed.

Your preferences are stored per computer/username, so any project that you open on this computer will have the same properties displayed.

The following properties apply to all items:

- Identifiers
  - **Name** is the name or other identifying label.
  - The remaining fields in this section correspond to the Synthesis identifiers and will appear on models published from the prediction.

- General
  - **Quantity** specifies whether the item represents multiple identical items that are all subjected to identical stress conditions (e.g., they have the same operating environment, applied voltages, etc.). This speeds up data entry by allowing you to add/edit only a single instance of the item. By default, the identical items are assumed to be reliability-wise connected in series. However, if the Redundancy property is set to True, the quantity indicates the number of items in a reliability-wise parallel configuration.
  - **ID** is an identifier for the item. This is user-defined and does not have to be unique.
  - **Alternate Part Number** is the alternate part number or other identifying label.
  - **LCN** is the location control number or other identifying label.
• **Reference Designator** is a string indicating the item's position in its parent structure.

• **Function Description** is a description of the item's function in the system or assembly.

• **Analyst** is the person who performed the analysis for the item.

• **Compiled By** is the person who selected to include the item in the current prediction.

• **Approved By** is the person who approved the analysis for the item and/or its usage in the current prediction.

The following properties apply only to generic blocks:

• **Update Children** and **Update Temperature Mode** specify whether and how certain stress values (e.g., temperature, voltage, etc.) should be synchronized for all components in the same assembly. (See Update Modes.)

• **Redundancy**, **Quantity Required** and **Mission Time** are properties for considering redundancy (i.e., components organized in a reliability-wise parallel configuration) for some calculations. (See Redundancy.)

### Adjustment Factor

For all components and blocks (regardless of which prediction standard you are using), Lambda Predict provides an Adjustment Factor that allows you to tweak an item's calculated failure rate by a specified value. In the Tree View, this factor is displayed under the **Application** heading. In the Pi Factor View, it is displayed under **Other Base Factors**.

For example, if you have reason to believe that the actual failure rate of a component will be half of the rate calculated by the prediction standard, you change the adjustment factor from 1 (the default) to 0.5. If you expect that the failure rate will be twice what would be calculated by the standard, change it to 2. And so on.

The following picture demonstrates this example using three instances of the same component. The first shows the full calculated failure rate (Adjustment Factor = 1), the second shows half the calculated rate (Adjustment Factor = 0.5) and the third shows twice the calculated rate (Adjustment Factor = 2).
Chapter 5: Prediction Folios

Default Component Properties
When you manually add a component to the system hierarchy, that component's properties are automatically populated with default values. The default values that are originally set in the software do not represent actual data for the component; you will need to specify the appropriate value of each property using information from a manufacturer's data sheet or parts list to ensure accurate predictions.

If there are certain components that you frequently use in your analysis, you can customize the default values of those components. This way, when you add the component to the system hierarchy, the component's properties will be automatically populated with your preferred values. Note that the default values are stored on your computer, and they are different for each user.

Tip: If you wish to maintain the same set of default values for different database users and/or use those values across several prediction folios or projects, we recommend that you create a library file for those components instead. (See Using Custom Library Files.)

Modifying the Default Values
To modify the default values, first specify the values for the component in any prediction folio, and then save those values as the defaults by choosing Prediction > Component Defaults > Save as Default.
You can then apply the saved values to any component of the same category type and prediction standard by clicking the component in the system hierarchy and choosing Prediction > Component Defaults > Set to Default.

Note that this will replace the component's existing properties. *There is no undo for resetting a component's properties to the default values.*

**Restoring Defaults**

To reset all the default values to the settings shipped with the software, click the **Reset Component Defaults** button on the **Reset Settings page** of the Application Setup. Note that the default values are stored on your computer. This means that resetting your default values will not affect the default values set by another user.

**Displaying Notifications When Components Use Default Values**

Whenever you open a prediction folio, Lambda Predict checks the property values of all the components in the folio against the current default values on your computer. If any component uses all the current default property values (i.e., if none of the component’s properties have been changed from the current defaults), the application displays a warning message. This can be useful for helping you find and update the properties of components that are still using the default values originally set by the software. However, if you have saved customized defaults for components that you frequently use in your analyses, you may choose to disable/hide the warning.

The warning message can be displayed in the System Hierarchy panel and whenever you open a prediction folio that contains components using the current default property values.

- In the System Hierarchy panel, the "Default (Not Set)" column may display any of the following icons (to hide or display columns, right-click anywhere in the system hierarchy, and then click **Customize Columns** to select which columns you want to display):
  - A red icon indicates that all the properties of a component are using the current default values.
  - A yellow icon indicates that some properties are using the current default values. Double click the icon to see a list of those properties.

- If you wish to see/hide the warning message when you open a prediction folio that contains components using the current default property values, select or clear the **Default Component Warning** check box on the **Other page** of the Application Setup.
Global Edit
You can use the Global Edit feature to apply changes to the properties of multiple items all at once. There are two ways to use global edit:

- If you have selected a block (i.e., or ) or standard item (i.e., , , , , or ), global edit will apply the same edit(s) to all its sub-items, if those sub-items have those properties.
- If you have selected multiple components and/or blocks, global edit will apply the same edit(s) to the current selection.

Once you have selected the item(s) you wish to edit, choose Prediction > Component > Global Edit.

In the Global Edit window, select the check box next to each property that you want to edit, and then select or enter the desired setting. Click Apply if you want to save the changes but leave the window open; click OK to save all changes and close the window. If any of the fields contain invalid values, a warning message will appear and the fields in question will be marked with a red X. Point to the X to view the allowable value range, as shown next.
Note that when selecting items to edit:

- If you select a block that has sub-items, the changes will be applied to the sub-items as well as to the block itself. This is true regardless of the setting in the Update Children property of any affected blocks. In other words, even if the block's Update Children property is set to Never, the changes made in the Global Edit window WILL be applied to the components under that block.

- Global edit does not affect properties that have been automatically calculated by Lambda Predict. For example, the value of a capacitor's "Voltage Stress" property can either be automatically calculated (from its Rated Voltage and Applied Voltage properties) or entered directly into the field (by setting both the Rated Voltage and Applied Voltage properties to zero). If the capacitor's "Voltage Stress" property contains a calculated value, then any changes made to the same property in the Global Edit window will not affect that calculated value.

- You can select multiple items at once by holding the CTRL key while clicking all the items in the system hierarchy you wish to edit. To select multiple items that are adjacent, click the first item and then hold the SHIFT key while you click the last item. This will select all the items between the first and last.

- You can only select items that are analyzed with the same prediction standard. For the purposes of global edit, all Bellcore/Telcordia versions are considered to be a single standard.

In the Global Edit window, note the following exceptions:

**For the MIL-217 standard**

The Ambient Temperature and Case Temperature properties cannot be changed during the same global edit process because in certain cases, case temperature is a function of ambient temperature. Thus, you must choose one type of temperature from the drop-down list. If you need to change both types, change the first type, click Apply and then change the other type.

The Quality property consists of two parts. In the first drop-down list, select the quality type that you want to work with. In the second list, select the desired value. The change will be applied only to those components with a quality type that matches your selection in the first drop-down list. If you need to make changes to multiple quality types, click Apply after each change and then make changes to the next type.

**For the MIL-217 and Bellcore/Telcordia standards**

The children of hybrid blocks have special temperatures properties; thus, temperature updates made via the Global Edit window stop at the hybrid block level and do not apply to the sub-items of the hybrid block.
For the FIDES standard

Use the Component Type drop-down field to specify which of the selected items or block sub-items to edit. The changes will be applied only to those components with the type that matches your selection. If you need to make changes to multiple component types, click Apply after each change and then make changes to the next type.

You can click the Select Existing icon in the pi factor fields to view a list of existing values that might apply to the item.

Status Flags
Status flags allow you to flag any item in the system hierarchy to indicate whether its properties are incomplete, in progress or complete. To flag an item, select it in the system hierarchy and then choose System Hierarchy > Status Flags > [In Progress/Complete/Incomplete].

The flag will appear in the Status Flag column in the system hierarchy. (To hide or display the columns in the system hierarchy, right-click the column headers, and then click Customize Columns to select which columns you want to display. These settings are stored per computer/username on the System Hierarchy page of the Application Setup, so any project that you open on this computer will have the same columns displayed.)

To remove a status flag from an item, select it in the system hierarchy, and then choose System Hierarchy > Status Flags > Clear.

Highlight
The Highlight tool uses colors to visually describe how each component contributes to the failure rate of its parent system/assembly. To use this tool, choose System Hierarchy > Tools > Highlight.

The value range of each color is based on the spread of failure rate values. By default, red indicates the highest contributors, yellow indicates less significant contributors and green indicates the lowest contributors. You can change the default colors via the Synthesis Settings page of the Application Setup (File > Application Setup).

http://predict.reliasoft.com
Example
As an example, the following picture shows the contribution of each component to a fictional power supply module. The main components are: AC circuit breaker, power transformer and a printed circuit board (PCB). The Contribution column shows that the PCB accounts for 95.95% of the power supply's overall failure rate. Compared to the contributions of the AC circuit breaker and power transformer, this value is very high; therefore the PCB's failure rate is highlighted in red.

In the PCB assembly, the filter capacitor accounts for 75.21% of the PCB's overall failure rate. This number is high compared to the contributions of the other components in the same PCB assembly; therefore, the filter capacitor's failure rate is also highlighted in red.

Update Modes
Update Modes is a group of properties found only in generic blocks. They serve as a quick way to coordinate some of the application and physical properties of components that are part of the same assembly. For example, if you wish to apply the same temperature value to all
components in an assembly that have that property, you can do so by editing the temperature mode of the block that represents the assembly.

**Tip:** If you wish to apply the same edit on multiple blocks or on the same type of component across different blocks, the Global Edit function may be more appropriate.

Starting in Version 2018, the properties that can be passed down to children are displayed separately in the Properties panel. In the Tree View, these properties are shown in the Application – Inherited and Physical – Inherited sections. In the Pi Factor view, they are shown in the Factor – Inherited section.

The Update Modes group is located under the General heading in both Tree and Pi Factor Views.

- In the Update Children field (available for all prediction standards):
  - Select **Always** to apply any edits made to the block to all the sub-items under the block, if those sub-items have those properties. The properties that are available will depend on the prediction standard that you are working with. For example, in a MIL-217 prediction, if you edit the "Quality, Capacitors" property, it will apply the same edit to all the capacitors below the block, but will not affect other components that do not use that property.
  - Select **Never** if you want to set the properties of the sub-items independently from the block properties.
  - Select **On Matching** to apply changes made to a given property only if the value in the sub-item matched the value in the block prior to the update. For example, if you change the temperature value of a block from 30 to 40, the change will be applied to all components within that block that had a temperature value of 30 before the block was updated. Any components that did not have a value of 30 will not be affected.

- In the Update Temperature Mode field (available for all prediction standards except FIDES):
  - Select **Absolute** to replace the temperature in the sub-items with the exact value used in the parent block.
  - Select **Increment** to increase the value of the temperature in the sub-items by the same amount that you increased the temperature in the block. For example, if you change the temperature value of a block from 30 to 40, that is an increase of 10 degrees. Therefore, the temperature value in the sub-items will be also be increased by 10 degrees.
In the **Update Component Type** field (available only for the FIDES standard), choose a specific component type to apply the changes to, or choose All to apply changes to all component types that use the affected properties.

**IMPORTANT:** For FIDES predictions, if there are assessments or audits associated with a sub-item’s factors, they are cleared if the factor changes.

The Update Modes functionality does not affect properties that have been automatically calculated by Lambda Predict. For example, the value of a capacitor’s "Voltage Stress" property can either be automatically calculated (from its Rated Voltage and Applied Voltage properties) or entered directly into the field (by setting both the Rated Voltage and Applied Voltage properties to zero). If the capacitor's "Voltage Stress" property contains a calculated value, then any changes made to the same property in the parent block will not affect that calculated value, even if the block's **Update Children** property is set to Always.

### Redundancy

Lambda Predict makes it easy to explore whether you can meet your MTBF/failure rate target by adding redundancy (i.e., using a reliability-wise parallel configuration). This option is available for standard items (i.e., ML, BL, TL, MC, F, SN or G) and generic blocks.

To use this feature, you must:

- Set the **Redundancy** property to True.
- Use the **Quantity** field to specify the total number of redundant items.
- Use the **Quantity Required** field to specify how many of the redundant items must be operational for the system/assembly to succeed.
- Specify the **Mission Time** (in hours) at which to calculate the time-dependent failure rate and/or unreliability. This time must be the same for all redundancy calculations in the same prediction and therefore it can only be specified at the standard item level (i.e., ML, BL, TL, MC, F, SN or G).

The results that consider redundancy will be displayed in the **Mission Time**, **Failure Rate(t)** and **Unreliability(t)** columns in the system hierarchy. (To hide or display the columns in the system hierarchy, right-click the column headings, and then click **Customize Columns** to select which columns you want to display. These settings are stored per computer/username on the **System Hierarchy page** of the Application Setup, so any project that you open on this computer will have the same columns displayed.)

For example, the following picture shows the properties and results for two "System A" assemblies in a parallel (redundant) configuration. The **Failure Rate (t=INF)** column displays the
steady-state failure rate for a single assembly (i.e., the constant failure rate as the mission time approaches infinity), while the Failure Rate(t) column displays the failure rate at the specified Mission Time of 8,760 hours for two assemblies in a redundancy configuration.

Results

After you have added components to the system hierarchy, Lambda Predict automatically calculates results, such as failure rate and MTBF, for the individual items. The final calculated prediction results are based on the roll-up of all the individual block and component failure rates. The results can be displayed in the following areas:

- System Hierarchy panel
- Calculation Information window
- Reports

You can also create plots of the results. See Prediction Plots.

System Hierarchy Panel

Most results are displayed in the System Hierarchy panel in individual columns. (To hide or display columns, right-click anywhere in the system hierarchy, and then click Customize Columns to select which columns you want to display. These settings are stored per computer/username on the System Hierarchy page of the Application Setup, so any project that you open on this computer will have the same columns displayed.)
The following calculated results can be displayed:

- **Failure Rate**(t=INF) is the steady-state failure rate (i.e., the constant failure rate at time = infinity)
- **MTBF** is the mean time between failures, expressed in hours.
- **Contribution** is the contribution made by the item to the failure rate of its direct parent. For example, a value of 0.5 in this column indicates that the item accounts for 50% of the failure rate of its direct parent. (See Highlight.)

For Bellcore/Telcordia predictions, the following results are also available:

- **Early Life Factor** (also known as the *first-year multiplier*) is the ratio of the component's first-year failure rate to its steady-state failure rate.
- **Standard Deviation**(t=INF) is the standard deviation at time = infinity (applies to Telcordia SR-332 Issues 2 and 3 only).
- **Failure Rate Upper Bound** (t=INF) is the upper confidence bound for the steady-state failure rate (applies to Telcordia SR-332 Issues 2 and 3 only).

For MIL-217 predictions, the following results are also available:

- **Connection Failure Rate** is the calculated failure rate due to the physical connections of components to a printed circuit board (PCB) or hybrid device. (See Custom Connection Types.)
- The following results are available for MIL-217 predictions that specify non-operational phases:
  - **Non-Operational Failure Rate** is the steady-state failure rate during the non-operational phase.
  - **Non-Operational MTBF** is the mean time between failures, expressed in hours, during the non-operational phase.
  - **Non-Operational Contribution** is the contribution made by the item to the failure rate of its direct parent, during the non-operational phase.

For blocks that use redundancy, the following results are also available:

- **Mission Time** is the mission duration, expressed in hours.
- **Failure Rate**(t) is the expected failure rate at the specified mission time.
- **Unreliability**(t) is the probability of failure at the specified mission time.
Chapter 5: Prediction Folios

Calculation Information Window
The Calculation Information window displays a report of the failure rate and pi factors for the item that is currently selected in the system hierarchy, and allows you to export the information to Excel. To view the report for a selected item, choose Prediction Tools > Data Views > Calculation Information.

This window can remain open while you click other items in the System Hierarchy panel; the results will be updated automatically to represent the current selection. If you make changes to an item’s properties while the window is open, click the Refresh View icon to update the values.

The pi factors that are displayed in this window are the same pi factors that can be displayed in the Pi Factor View.

Reports
You can generate template-based reports for your predictions. A basic report template is provided for each reliability prediction standard that is included with your license, as well as one for generic systems. You can also create your own custom report templates to meet specific needs. Reports are generated in Microsoft Excel, which provides maximum flexibility for additional post-generation edits and distribution.

To generate a report, select a standard item in the system hierarchy and choose Prediction Tools > Data Views > Report.

Select the check box of the template you wish to use for the report and click OK to generate the report. You can customize the appearance of the predefined report templates and also build and manage your own custom report templates. (See Creating and Editing Report Templates.)

Prediction Plots
In Lambda Predict, there are two ways to create plot sheets:

- To create an ad hoc plot for a single standard item (i.e., □, ■, □, □, □, □, or □) or block (i.e., ■ or □), choose Prediction Tools > Data Views > Plot Viewer.
You can then opt to save the plot with the project by clicking the **Save** icon on the control panel. The plot will be saved under the **Stored Plots** heading in the current project explorer. Any changes you later make to the stored plot will be saved automatically.

- To create a plot that includes data from more than one prediction standard or block, choose **Home > Insert > Plot**. This type of plot is automatically saved with the project.

Note that if you delete a prediction that is referenced by a stored plot, the plot will remain available but you will not be able to make any changes to it.

The following sections describe the plots that can be created in Lambda Predict. For general information on working with plots, see [ReliaSoft Plot Utilities](#).

### Selecting the Plot Data

To plot data, select at least one of the following options in the control panel: **Include Top Level**, **Include Blocks** and/or **Include Components**. If selecting to include blocks or components, verify whether the plotted system/assembly contains those sub-items; otherwise, the software will have insufficient data to create a plot.

By default, each item on the plot is shown in a different color. When applicable, you can choose to color-code items based on their Category, LCN, Part Number or Reference Designator. For example, if you select to color-code by category, all capacitors will be shown in the same color, all resistors will be shown in a different color, and so on.

In addition to the group colors, you can choose which group of items to hide or display on the plot. For example, if grouping by category, you can choose to hide all capacitors from the plot.

### Plot Types in MIL-217 and Bellcore/Telcordia Predictions

For MIL-217 and Bellcore/Telcordia predictions, the available plots are:

- The **Failure Rate** plot compares the failure rate of all sub-items in the selected standard item or block.
Chapter 5: Prediction Folios

- The **MTBF** plot compares the MTBF of all sub-items in the selected standard item or block.

- The **Unreliability** plot compares the unreliability value of all sub-items in the selected standard item or block.

- The **Mission Phase** plot allows you to compare a metric of interest across two or more mission phases. For example, if you choose to plot the failure rate for three mission phases, the plot will compare the failure rates of all sub-items in the system in each mission phase. You can define up to ten mission phases to plot. (See [Mission Phase Plots](http://predict.reliasoft.com).)

In addition, you can plot any of the metrics above (except mission phase) against any of the following stress factors:

- Temperature
- Temperature Delta
- Environment
- Current, Power or Voltage Stress

When plotting a metric against a stress factor, you will need to enter/select the value of the stress factor in the plot sheet's control panel. For instance, when plotting against environment, click the **Environment** button on the control panel to specify which environments will be included or excluded in the plot.

To plot against temperature, you will need to specify a minimum and maximum range for the temperature, as well as the number of points (or steps) to display on the plot. For example, the following picture shows a failure rate vs. temperature plot where the temperature range is from 50 to 100 ºC and the number of steps is set to 10.
Plot Types in NSWC Predictions
For NSWC predictions, the available plots are:

- The **Failure Rate** plot compares the failure rate of all sub-items in the selected standard item or block.
- The **MTBF** plot compares the MTBF of all sub-items in the selected standard item or block.
- The **Unreliability** plot compares the unreliability value of all sub-items in the selected standard item or block.

In addition, you can plot any of these metrics against temperature or temperature (Delta). Similar to what was described above for MIL-217/Bellcore and Telcordia plots, you will need to specify a minimum and maximum range for the temperature, as well as the number of points (or steps) to display on the graph.
Plots Types in FIDES Predictions
For FIDES predictions, the available plots are:

- The **Failure Rate** plot compares the failure rate of all sub-items in the selected standard item or block.
- The **Contribution** plot compares the contribution made by all sub-items to the failure rate of the selected standard item or block.
- The **MTBF** plot compares the MTBF of all sub-items in the selected standard item or block.
- The **Factor Contribution by Component** block compares the contribution made by each sub-item to the acceleration factors (e.g., thermal cycling factor, mechanical factor, chemical factor, etc.).
- The **Factor** plot compares the failure rate of each sub-item based on the acceleration factors (e.g., thermal cycling factor, mechanical factor, chemical factor, etc.).
- The **Failure Rate per Phase** plot compares the failure rate of the standard item or block in all phases in the life profile.
- The **Factor per Phase** plot compares the contribution made by each phase to the acceleration factors (e.g., thermal cycling factor, mechanical factor, chemical factor, etc.)
- The **Lambda Phase by Component** plot compares the contribution made by each phase to the component's failure rate. This plot is unavailable when the system contains no components with phase-dependent failure rates.
- The **Unreliability** plot compares the unreliability value of all sub-items in the selected standard item or block.

Plot Types in Siemens Predictions
For Siemens predictions, the available plots are:

- The **Failure Rate** plot compares the failure rate of all sub-items in the selected standard item or block.
- The **MTBF** plot compares the MTBF of all sub-items in the selected standard item or block.
- The **Unreliability** plot compares the unreliability value of all sub-items in the selected standard item or block.
In addition, you can plot any of these metrics against temperature or temperature (Delta). Similar to what was described above for MIL-217/Bellcore and Telcordia plots, you will need to specify a minimum and maximum range for the temperature, as well as the number of points (or steps) to display on the graph.

**Mission Phase Plots**

The Mission Phase plot is available for MIL-217 and Bellcore/Telcordia predictions. It allows you to compare a metric of interest across two or more mission phases. For example, if you choose to plot the failure rate for three mission phases, the plot will compare the failure rates of all items in the system in each mission phase. You can define up to ten mission phases to plot.

The first time you create the plot, the Mission Phase window will be displayed automatically. Select a metric of interest (i.e., failure rate, contribution, MTBF or unreliability), and then define the conditions of each mission phase. For each phase, enter the mission duration in hours, choose an environment and enter the temperature in degrees Celsius. If desired, you can also specify the title that will be displayed on the x-axis of the plot for each phase. If you do not specify titles, the default titles (i.e., "Phase 1," "Phase 2," etc.) will be used.

Once you have created the plot, you can return to the Mission Phase window and edit the conditions of the mission phases at any time by clicking the Mission Phase button on the plot sheet control panel.

The following example shows that the failure rate of a system will be compared across three mission phases. The resulting plot will show the failure rate of all sub-items in each mission phase.
Publishing Models from Failure Rate Predictions

You can publish any failure rate that's been calculated in Lambda Predict as a reliability model resource that can be shared among analyses. In standards based reliability prediction, the failure rate is assumed to be constant; therefore, models published from Lambda Predict will be defined with a 1-parameter exponential distribution.

The tools for publishing a model are the same as in other ReliaSoft applications, except that in Lambda Predict, these tools appear on the ribbon and on the Publishing tab of the Properties panel. For example, to publish a reliability model for a block or component, select the item in the system hierarchy and then choose Prediction Tools > Share > Publish Item Model or click the icon in the Publishing tab of the Properties panel.

For a description of all common tools for working with published models, see Publishing Models.
Models published from Lambda Predict can be used in other ReliaSoft applications just like any other published model. In addition, some applications have built-in functionality for integration with Lambda Predict. Specifically:

- In BlockSim, you can automatically build reliability block diagrams (RBDs) for the entire configuration based on the models published from Lambda Predict. For specific instructions, see Building RBDs from Lambda Predict.

- In Xfmea, RCM++ and RBI, you can automatically import a system configuration from any Lambda Predict prediction folio. This includes the option to automatically define the reliability policies for the imported items based on the failure rate models published from Lambda Predict. For specific instructions, see Importing from Lambda Predict to Xfmea/RCM++/RBI.

Tip: The Model column in the system hierarchy displays an icon to indicate that the item's failure rate has been published as a model. You can double-click this icon to view the properties of the published model. (To hide or display columns, right-click anywhere in the system hierarchy, and then click Customize Columns to select which columns you want to display. These settings are stored per computer/username on the System Hierarchy page of the Application Setup, so any project that you open on this computer will have the same columns displayed.)

Publishing Models for an Entire System Configuration or Assembly

In some cases, you may wish to publish the reliability models of all the items in a system configuration or assembly all at once. You might use the models to perform advanced system reliability analysis in BlockSim, for instance, or for Failure Modes and Reliability Analysis (FMRA) in Xfmea.

For many of the reliability prediction standards in Lambda Predict, a portion of the assembly's failure rate is calculated at the block level. This block-level portion of the failure rate is called the block's supplemental model. For example, in MIL-217 analyses, the failure rate for a printed circuit board (PCB) assembly is a summation of the individual failure rates of its components plus the failure rate due to the physical connection of the components to the board. If you wish to create a diagram for this PCB in BlockSim, you will need the reliability models of all the components plus a supplemental model that reflects the failure rate due to the connections.

In a MIL-217 prediction, the supplemental model is applicable for any type of block. In Bellcore/Telcordia, it is applicable for hybrid blocks and blocks that use the "Method II – Unit" or "Method III – Unit" prediction methods. In FIDES, it is applicable only for COTS Board and Hybrid/Multi Chip Module (H&M) blocks. Supplemental models are not applicable for NSWC analyses.
Chapter 5: Prediction Folios

To publish all the models available for an assembly, select the standard item (i.e., G, ML, BL, TL, MC, SN or E) or block (i.e., or ) and choose Prediction Tools > Share > Publish Branch.

Note that for blocks, the Publish Branch command publishes both an item model (which reflects the failure rate predicted for the entire assembly) and a supplemental model (if applicable). The following example shows the Publishing tab of a block that has both its item model and supplemental model published.

For applicable blocks, you can publish the block's supplemental model only, if desired, by selecting the block and choosing Prediction Tools > Share > Publish Block Supplemental Model or by clicking the icon in the Block Supplemental Model area of the Publishing tab.

Building RBDs from Lambda Predict

You can use the system configuration and failure rate predictions from Lambda Predict as a starting point for creating RBDs in BlockSim. As more information becomes available, you can then replace the predicted failure rate models with new models that are based on Weibull++ analyses and other sources.
Chapter 5: Prediction Folios

Importing the system configuration data from Lambda Predict is a two-step process:

1. First, you must publish the failure rates calculated in Lambda Predict as reliability models. To do this, open the project in Lambda Predict. In the prediction folio, select the standard item (i.e., C, ML, BL, TL, MC, SN, or F) or assembly (i.e., or ) that you want to create the RBD for, and then choose Prediction Tools > Share > Publish Branch.

   Once the models are published, you can close the project in Lambda Predict if desired.

2. Open the project in BlockSim, and then choose Home > Insert Build RBDs and FTs from Synthesis.

   When the window opens, specify that you want to use Lambda Predict as the data source in the Synthesis Element to Build From area. The utility will provide the following options:

   - **Simulation** or **Analytical** - use the drop-down list to specify whether the new RBD(s) will be analytical diagrams or simulation diagrams.

   - **Create Folders** - select this check box if you want the new diagram(s) to be organized into a separate folder in BlockSim's current project explorer. (Note that selecting this option can make it easier to delete and recreate the diagrams if you need to. You can delete the entire folder instead of deleting each diagram individually.)

   - **Create subdiagrams for blocks** - in this context, the term "blocks" refers to the assemblies in Lambda Predict. For each block in the prediction folio, you can:

     - Use a single RBD block to represent the reliability of the entire assembly. This treats the assembly as a "black box" in the RBD, using the item model that was published for the block.

     - Use a subdiagram in the RBD to represent the assembly. This allows you to consider the separate failure rates for all of the components that make up the assembly.

   **Note:** For many of the reliability prediction standards available in Lambda Predict, a portion of the assembly's failure rate may be calculated at the block level. In Lambda Predict, this portion is called the block's supplemental model. For example, in MIL-217 analyses, the failure rate for a printed circuit board (PCB) assembly is a summation of the individual failure rates of its components plus the failure rate due to the physical connection of the components to the board. If you have chosen to create subdiagrams for
such assemblies, the diagrams will contain the reliability models of all the components in
the assembly plus the supplemental model that represents the failure rate due to the
connections.

After you have specified your preferences, click Next to see the failure rate models that
were published from Lambda Predict. As an example, the following pictures show two
ways that models published from the same MIL-217 prediction might be displayed,
depending on whether the Create subdiagrams for blocks option was selected.

In the first scenario, the Create subdiagrams for blocks option was selected; therefore,
the utility displays all the assemblies and components in the system configuration.
The window also displays the supplemental model for each assembly and the item
model for each component, as shown next. (Note that the supplemental model icon
will be displayed only if it's applicable for the particular assembly and the model has been
published from Lambda Predict.)

If you select all of the items shown in this hierarchy and click OK, BlockSim will create a
diagram for the "MIL-217 System" that links to one subdiagram for Assembly A and
another for Assembly B, as shown next.
In the second scenario, the **Create subdiagrams for blocks** option was not selected; therefore, the utility displays only the assemblies. In this case, the item model 🏬 that represents the failure rate calculated for each assembly will be used.
If you select all of the items shown in this hierarchy and click **OK**, BlockSim will create one diagram for the "MIL-217 System" that includes a single block for each assembly, as shown next.

Note the following:

- If you have made changes to the analysis in Lambda Predict since the last time you published the models, it is recommended to use the Publish Branch
command to publish them again. If an item does not have a published model, it will not be included in the BlockSim diagram.

- Components with a value greater than 1 in their quantity field in Lambda Predict are represented by multi blocks.
- Parallel configurations at the assembly level, which Lambda Predict models using redundancy, are modeled in BlockSim using nodes.
- Component adjustment factors defined in Lambda Predict will be imported as block duty cycles. Adjustment factors for assemblies are not imported.

### Importing from Lambda Predict to Xfmea/RCM++/RBI

Although the system hierarchy that you work with in Lambda Predict is independent from the system hierarchy that you work with in Xfmea/RCM++/RBI, the Synthesis Platform makes it easy to import items from a prediction folio into a hierarchy that will be used for FMEA, RCM or RBI analysis. The original system configuration in the prediction folio will remain unchanged, and new (independent) records will be created in Xfmea/RCM++/RBI.

To use this feature, open the project in Xfmea, RCM++ or RBI and choose **System Hierarchy > Add Items > Import > Lambda Predict Items.**

The left side of the window displays all of the prediction folios that have been created in the current project using Lambda Predict. The right side of the window displays the system hierarchy from the prediction folio that is currently selected. Use the check boxes to select which items will be imported.

Any item properties in Lambda Predict that have an equivalent field in Xfmea/RCM++/RBI analyses (such as Part Number, Supplier, Item Description, etc.) will be imported.

There are two additional options:

**Create URDs from published prediction models**

The Synthesis Platform makes it possible to publish any failure rate calculated in a Lambda Predict prediction folio as a model resource that may be used in other ReliaSoft applications.

If you are importing prediction items that have been used to publish models and you wish to use these published models to automatically define the reliability policies for the new items...
that will be created in Xfmea/RCM++/RBI, select the **Create URD from published prediction models** check box.

As an example, the following picture shows the reliability policy for an item imported from a MIL-217 prediction.

Create FMEA functions from the 'Function Description' field

If you are importing prediction items that have text in the "Function Description" field of the Lambda Predict item properties and you wish to use this text to automatically create the first FMEA functions for the new items that will be created in Xfmea/RCM++/RBI, select the **Create FMEA functions from 'Function Description' field** check box.

As an example, the following picture shows the function description for an item in Lambda Predict. This can be used to create the first function in the FMEA for the new item that is imported to the Xfmea/RCM++/RBI system hierarchy.
Chapter 6: MIL-217 Predictions

This chapter focuses on the software features that apply specifically to using the MIL-217 prediction standard. For general information about using the prediction folio for any type of standard (e.g., how to create folios, build system configurations, etc.), see Prediction Folios.

The MIL-HDBK-217F standard (Reliability Prediction of Electronic Equipment) was published by the US Department of Defense in 1991. It provides reliability prediction models for electronic components in commercial and military applications. Lambda Predict supports both the part stress and parts count calculation methods defined in the prediction standard.

Using the Parts Count Method

In addition to providing full support for the MIL-217 part stress calculation method, Lambda Predict can also be used to create a MIL-217 parts count prediction. This analysis approach may be applicable during bid proposals and early design phases when sufficient information is not available to use the part stress method.

In a parts count folio, you can build the system configuration only by importing components from Lambda Predict's "PartsCount.lplib18" library file, and you can only edit the properties that are relevant for the parts count method. This restricts your analysis to the rules of parts count prediction, helping you to eliminate potential errors that may occur as a result of mixing part stress and parts count components.

For parts count analyses that were created in previous versions of Lambda Predict, we recommend rebuilding the prediction in a new parts count folio. If you want to keep the analysis in the standard prediction folio, see Performing a Parts Count Analysis in a Standard Prediction Folio.

Tip: You can use the Import Local Components command to import individual components from a parts count folio into a standard prediction folio for part stress analysis, if desired. Alternatively, you can export the entire system hierarchy to an Excel worksheet (see Creating Reports), and then import the data into a standard prediction folio (see Import Bill of Materials).

Parts Count Library File

Lambda Predict’s "PartsCount.lplib18" library file is installed with the software and saved in the default documents folder for your computer (e.g., My Documents\ReliaSoft\Lambda Predict 18\Libraries). It contains the default failure rates for the MIL-217 components covered in Appendix A of the MIL-HDBK-217F handbook. For identification purposes, each component in
Chapter 6: MIL-217 Predictions

the library file is identified by a part number that includes a component number, a short
description of the component and an environment designation. For example, the library file
uses the following part number for a bipolar gate/logic array with 4,000 gates:

004 IC, Dig. Herm. G_M

where:

- 004 represents the component number. This number is unique for each component
type in the library file.
- IC, Dig. Herm is short for "Integrated Circuit, Digital. Hermetic."
- G_M stands for "Ground, Mobile" environment.

This component corresponds to the item described in Section 5.1 of Appendix A, as shown
below.

Example

Assume you have four digital bipolar gate/logic arrays with 4,000 gates of Class S quality that
have been in production for one year and will be operating in a Ground, Mobile environment.

To import this component for use with the parts count method, follow these steps:

1. Create a MIL-217 parts count analysis folio by choosing Home > Insert > Prediction
   Folio, and then selecting the MIL-HDBK-217F (Parts Count) standard in the setup
   window.

2. In the prediction folio, select the MIL-217 standard item , and then choose System
   Hierarchy > Local Components > Import Local Components.
3. In the Import Local Components window, select the **Library** option and make sure that the **PartsCount.lplib18** library file is selected. Enter the search criteria as shown in the following picture (the search is not case sensitive), and then click the **Search** button.

In the table of results, select the component and then click **Add** to import it into the current prediction folio. Click **Close** to return to the folio.

4. In the prediction folio, update the value of the following component properties:
   - **Quantity** = 4
   - **Quality** = **Class S**
   - **Number of Years in Production** = 1

The system hierarchy shows that the calculated failure rate for the component, based on the parts count method, is 0.3324 FPMH, as shown next.
Performing a Parts Count Analysis in a Standard Prediction Folio
Although we recommend using the new parts count folio for parts count analysis, it is still possible to perform the analysis in a standard prediction folio. This allows you to continue
working with existing parts count analyses that were imported from previous versions of Lambda Predict.

There are two things to keep in mind when performing parts count analysis in a standard prediction folio:

- The parts count prediction method is based on the generic failure rates of components that were calculated using certain default parameter values. Based on this rule, only the following information may be modified for each component you import from the parts count library file. If you edit the value of any fields other than those listed below, the analysis will be treated as a part stress prediction rather than a parts count prediction.
  - Quantity
  - Part type
  - Part quality level
  - Equipment environment
  - Number of years in production (for microcircuits only)

- Coils and mechanical relays use different quality factors in a parts count analysis compared to the values used for a parts stress analysis. If you are performing the parts count analysis in a standard prediction folio, you must use the Adjustment Factor field instead of the Quality field for those components.

For coils, use the following values for the adjustment factor:

<table>
<thead>
<tr>
<th>MIL-217 Quality</th>
<th>Set the Adjustment Factor to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Established Reliability</td>
<td>0.25</td>
</tr>
<tr>
<td>MIL-SPEC</td>
<td>1.0</td>
</tr>
<tr>
<td>Non-MIL (low quality)</td>
<td>3.0</td>
</tr>
</tbody>
</table>

For mechanical relays, use the following values:

<table>
<thead>
<tr>
<th>MIL-217 Quality</th>
<th>Set the Adjustment Factor to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Established Reliability</td>
<td>0.6</td>
</tr>
<tr>
<td>MIL-SPEC (non-established reliability)</td>
<td>1.5</td>
</tr>
<tr>
<td>Non-MIL (commercial or unknown)</td>
<td>2.9</td>
</tr>
</tbody>
</table>
Chapter 6: MIL-217 Predictions

MIL-217 Custom Connections

In the MIL-217 standard, the physical connections (e.g., crimps, welds, solder connections, etc.) of components assembled into printed circuit boards (PCBs) or hybrid constructions contribute to the overall failure rate of the assembly. Lambda Predict provides three specialized block types that are designed to support the specific failure rate models that are provided in MIL-217 for certain types of PCBs and hybrid constructions:

- For circuit boards using plated-through-hole technology (PTH), use the **IA, Plated Through Holes** block type.
- For circuit boards using surface mount technology (SMT), use the **IA, Surface Mount Tech** block type.
- For hybrid constructions, use the **Hybrid** block type.

For any other type of assembly, use a generic block 📌.

Lambda Predict will calculate the block's failure rate as a summation of the individual failure rates of the components. It then calculates the failure rate of each component's connection to the block (based on the **Number of Pins** and **Connection Type** properties of each component), and adds them to the block's failure rate to obtain the overall failure rate for the assembly.

Custom Connection Types

The software supports the connection types specified in the MIL-217 standard (e.g., Reflow Solder, Crimp, etc.) and also allows you to define up to 10 custom connection types for use in the **Connection Type** property. The same custom connections are shared by all users for all MIL-217 analyses within the current database. In a secure database, the ability to create custom connections is accessible only if you have the "Manage Lambda Predict repository settings" permission.

To create custom connections, choose **File > Manage Repository > MIL-217 Custom Connections**.

In the Custom Connection window, enter a connection description and base failure rate for any of the 10 user-defined fields. By default, two custom connection types are provided by Lambda Predict, as shown below. You may choose to keep these connection types or replace them with something else.

**IMPORTANT:** If you edit the name or failure rate of a custom connection, the change will affect all analyses where the connection is used.
The custom connection types that are defined in this window will be displayed in each Connection Type drop-down list, as shown next.

### Non-Operational Properties

The MIL-217 standard assumes that all the items in the analysis are operating under normal conditions (i.e., with the power on and performing its intended function). There are, however, systems and assemblies in which the non-operating time represents a significant portion of the useful life (e.g., missiles, fuses, projectiles, etc.).

Lambda Predict provides an optional tool that allows you to obtain the non-operating failure rate. This tool is based on the technical report, RADC-TR-85-91 (*Impact of Non-Operating Periods on Equipment Reliability*), which was produced in 1985 for the U.S. Air Force. The non-operating failure rate models provided by the report are patterned after the failure rate models in the MIL-217 standard, and can be used to separately predict the non-operating failure rates of components or to complement the MIL-217 analysis.

To access the tool, select the item in the system hierarchy and choose **Prediction > MIL-217 > Non-Operational.**
Chapter 6: MIL-217 Predictions

The **Factors** area contains the properties that must be defined to calculate the non-operating failure rate. The list of properties varies depending on the item being analyzed. If a property is unavailable, this indicates that the property is specified at another level. For example, for a capacitor, the **Temperature** property will be unavailable because this property needs to be specified at the block level (or ).

Lambda Predict also includes two properties that are available regardless of which item is being analyzed:

- **User Base Failure Rate** allows you to directly enter the non-operating base failure rate of the item. This is useful for analyzing specific items that are not covered by the RADC report.

- **Adjustment Factor** allows you to tweak an item's calculated non-operating failure rate by a specified value. For example, if you have reason to believe that the non-operating failure rate of a component will be half of the rate calculated by the application, change the adjustment factor from 1 (the default) to 0.5. If you expect that the failure rate will be twice what would be calculated by the application, change it to 2, and so on. Assuming that the calculated non-operating failure rate is 0.1544, the software would display 0.0772 with an adjustment factor of 0.05, or 0.3087 with an adjustment factor of 2.

The **Results** area displays the calculated pi factors of the item's non-operating failure rate model. This makes it possible to directly see how the inputs affect the calculations. For example, if you are working with a capacitor, the RADC report provides the following non-operating failure rate model:

$$\lambda_p = \lambda_{NB} \pi_{NE} \pi_{NQ} \pi_{CYC}$$

As shown next, the **Results** area calculates the pi factors based on your inputs, where **Lambda Base** = , **Pi Environment** = , and so on. If you edit the inputs, you can click in any other field to recalculate the results. Click **OK** to save the changes. Note that some calculations for the non-operating pi factors, such as the capacitor's Pi Quality (π_{NQ}), are based on information found in the item's **Properties panel**.
If you are working with a block, the Update Dependents check box will be available. Select this check box to apply the same non-operating environment, temperature and mean time between power cycles properties to the block's sub-items. Note that any subordinate blocks are not updated until you click OK, so the values shown in the Results area do not yet take into account the effect of the change that will be applied to the sub-items.

**Analysis Results for Non-Operating Conditions**

When you specify non-operational phases, you can display the following results in the system hierarchy. (To hide or display the columns in the system hierarchy, right-click the column headings, and then click Customize Columns to select which columns you want to display. These settings are stored per computer/username on the System Hierarchy page of the Application Setup, so any project that you open on this computer will have the same columns displayed.)

- Non-Operational Failure Rate
- Non-Operational MTBF
- Non-Operational Contribution
Chapter 7: Bellcore/Telcordia Predictions

This chapter focuses on the software features that apply specifically to using the Bellcore/Telcordia standards. For general information about using the prediction folio for any type of standard (e.g., how to create folios, build system configurations, etc.), see Prediction Folios.

The Bellcore/Telcordia standards provide reliability prediction models for electronic components in commercial applications. Lambda Predict supports the following versions of the standard:

- SR-332 Issue 3 (Telcordia Technologies, 2011)
- SR-332 Issue 2 (Telcordia Technologies, 2006)
- TR-332 Issue 6 (Bell Communications Research, 1997)

All four versions are very similar, except for the updated base failure rates in the newer issues and other minor changes. Calculations for standard deviation and upper confidence bounds are available in Issues 2 and 3 only.

The Bellcore/Telcordia standards provide three methods for performing reliability predictions: Method I, Method II and Method III. The method you select determines the model (i.e., equation) used for calculating the failure rate of components (called devices) and blocks (called units).

Early Life Factor

For each block and component, the Early Life Data heading in the Properties panel includes the burn-in properties used to obtain the early life factor (also known as first-year multiplier) described in the Bellcore/Telcordia standards. Burn-in may be performed at the system or assembly level — represented in Lambda Predict by a standard item (이나) or block (이나) — or on the individual component. Therefore, the factor is calculated separately for each item in the system hierarchy. To indicate no burn-in, enter a value = 0 in the Early Life Burn-in Time property.
The early life factor is defined as the ratio of the component's first-year failure rate to its steady-state failure rate. The calculated value of the early life factor is displayed in the Early Life Factor column in the system hierarchy, along with the calculated value of the steady-state failure rate in the Failure Rate (t=INF) column. You can easily obtain the value of a component's first-year failure rate by taking the product of these two values. (To hide or display columns, right-click anywhere in the system hierarchy, and then click Customize Columns to select which columns you want to display. These settings are stored per computer/username on the System Hierarchy page of the Application Setup, so any project that you open on this computer will have the same columns displayed.)

Bellcore/Telcordia Prediction Methods

Lambda Predict supports the three methods described in the Bellcore/Telcordia standards for predicting the steady-state failure rate of an item. In the application, you use the Method properties of a block (▃) to specify which method to use.

- **Method I** (also known as the Black Box method) uses the generic failure rates defined by the Bellcore/Telcordia standard.
- **Method II** allows you to supplement Method I with real data that you've obtained from testing.
• **Method III** allows you to supplement Method I with real data that you’ve obtained from an identical or similar item operating in the field. In Lambda Predict, this method is broken down into the following cases:

  • **Method III (a)** indicates that the item in the prediction folio and the fielded item are identical, and are used under the same environmental conditions.
  
  • **Method III (b)** indicates that the item in the prediction folio and the fielded item are identical, but are used under different environmental conditions.
  
  • **Method III (c)** indicates that the item in the prediction folio and the fielded item are similar, not identical. You will be required to define the failure rate of the fielded item.

If you use Method II or Method III, you have to specify whether the test/field data were collected for the entire assembly (unit) or for the individual component (devices). The application will enable the appropriate [Lab Test Data](#) or [Field Data](#) properties based on your selection. For example, if you select the "Method II-Unit" option, the Lab Test Data properties will be enabled only for the block, but if you select the "Method II-Devices" option, those properties will be enabled only for the components under the block.

---

**Note:** A component that does not belong to a block always uses Method I (i.e., the Lab Test Data and Field Data properties are unavailable).
### Chapter 7: Bellcore/Telcordia Predictions

![Prediction 1](http://predict.reliasoft.com)

<table>
<thead>
<tr>
<th>Properties</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td></td>
</tr>
<tr>
<td>Application</td>
<td></td>
</tr>
<tr>
<td>Method</td>
<td>Method II - Unit</td>
</tr>
<tr>
<td>Early Life Data</td>
<td></td>
</tr>
<tr>
<td>Early Life Burn-in Time (hrs)</td>
<td>Method I</td>
</tr>
<tr>
<td>Early Life Burn-in Temperature</td>
<td>Method II - Devices</td>
</tr>
<tr>
<td>Lab Test Data</td>
<td></td>
</tr>
<tr>
<td>Lab Test Time (hrs)</td>
<td>Method III (a) - Devices</td>
</tr>
<tr>
<td>Lab Test Temperature (°C)</td>
<td>Method III (a) - Unit</td>
</tr>
<tr>
<td>Number of Lab Test Failures</td>
<td>Method III (b) - Devices</td>
</tr>
<tr>
<td>Number on Lab Test</td>
<td>Method III (b) - Unit</td>
</tr>
<tr>
<td>Lab Average Burn-in Time (hrs)</td>
<td>0</td>
</tr>
<tr>
<td>Lab Average Burn-in Temperature</td>
<td>40</td>
</tr>
<tr>
<td>Field Data</td>
<td></td>
</tr>
<tr>
<td>Field Time (hrs)</td>
<td>0</td>
</tr>
<tr>
<td>Number of Field Failures</td>
<td>0</td>
</tr>
<tr>
<td>Field Temperature (°C)</td>
<td>40</td>
</tr>
<tr>
<td>Field Failure Rate (FIT)</td>
<td>0</td>
</tr>
</tbody>
</table>
Chapter 8: NSWC Predictions

This chapter focuses on the software features that apply specifically to using the NSWC standard. For general information about using the prediction folio for any type of standard (e.g., how to create folios, build system configurations, etc.), see Prediction Folios.

The *Handbook of Reliability Prediction Procedures for Mechanical Equipment*, issued by the Naval Surface Warfare Center, provides reliability prediction models for mechanical components, such as seals, springs, pumps, valves, brakes and more. Lambda Predict supports both the NSWC-07 (published in 2007) and NSWC-11 (updated in 2011) versions of the standard. Both versions are very similar, except for the updated base failure rates and the addition of new devices in the newer issue.

Predefined Assemblies

Many of the failure rate models described in the NSWC standard are in fact assemblies that are composed of several subcomponents. In Lambda Predict, you can add these assemblies via the Select a Component window. When you add an assembly to the system hierarchy, the relevant components are also automatically added. The following list itemizes the components that are included in each assembly:

- **Accumulator [Assembly]** includes the seal, spring, actuator, valve and cylinder wall components.
- **Brake [Assembly]** includes the bearing, actuator, brake friction lining, seal, spring and housing or casing components.
- **Clutch [Assembly]** includes the bearing, actuator, clutch friction lining, seal and spring components.
- **Compressor [Assembly]** includes the pump shaft, bearing, valve, seal and compressor fluid driver components.
- **Coupling [Assembly]** includes the seal, gear and housing or casing components.
- **Motor [Assembly]** includes the bearing, motor, motor brush, motor winding, shaft, gear, and housing or casing components.
- **Pump [Assembly]** includes the seal, pump shaft, bearing, housing or casing and pump fluid driver components.
- **Slider Crank Mechanism [Assembly]** includes the bearing, static seal, shaft, actuator and dynamic seal components.
• Universal Joint [Assembly] includes the gear, seal, bearing and fastener components.

• Valve [Assembly] includes the valve, seal, spring, solenoid and housing or casing components.
Chapter 9: FIDES Predictions

This chapter focuses on the software features that apply specifically to using the FIDES reliability prediction standard. For general information about using the prediction folio for any type of analysis (e.g., how to create folios, build system configurations, etc.), see Prediction Folios.

The FIDES Guide was produced in 2004 (UTE-C 80811) and updated in 2009 by the FIDES group — a consortium of leading French international aeronautical and defense companies, under the supervision of the DGA (Délégation Générale pour l'Armement - French Ministry of Defense). It provides a reliability prediction methodology based on physics of failure, and provides failure rate models for electrical, electronic and electromagnetic components, as well as for commercial-off-the-shelf (COTS) board assemblies.

Defining the Life Profile

For any FIDES analysis, you will be able to specify different phases that a system or assembly experiences during operation (i.e., define the item's life profile). Some of the component properties (such as applied voltage or power dissipated) can then be defined separately for different phases. The phases themselves also have various properties that will affect the failure rate calculations (such as ambient temperature and environmental pollution).

This topic describes how to use the Item Phases window, Select Phases window and Select Phase Set window to specify which phases will be used when performing a FIDES analysis for a particular system or assembly. For information about managing the list of all phases and phase sets in the current database, see Manage Repository Phases and Manage Phase Sets.

**Tip:** Any changes to a saved phase record will be applied automatically to every FIDES analysis where that phase is being used. This is different from using saved pi factor assessments, where the change does not take effect until you take a specific action to update the analysis (see Update Factors).

Specifying Different Phases for Different Levels in the System Hierarchy

When the configuration that you have defined in the System Hierarchy panel contains multiple levels, you can either use the same phases for all levels, or you can specify different phases for any particular branch. For example, the following picture shows a simplified configuration in which the FIDES standard item represents a system and the blocks represent three different subsystems.
Inherit from Parent
If all of the subsystems will experience the same operating phases, you can specify the phases at the top level (the FIDES standard item) and allow each block to inherit its phases from the parent item.

If the Define At This Level command is enabled, the block is set to use the same phases as the parent item. All of the remaining ribbon commands (Select Phases, Remove Phase, etc.) will be disabled and you will not be able to modify the list of phases that are applicable for the current block. The table will display the same phase information that was defined for the higher level.

Define At This Level
Alternatively, if any of the subsystems will experience different operating phases, you can choose to define the phases for one or more individual blocks.

If the Define At This Level command is disabled, the block is set to use different phases than its parent item. The remaining ribbon commands (Select Phases, Remove Phase, etc.) will be enabled and you will be able to modify the list of phases that will be applicable for the current block.
Chapter 9: FIDES Predictions

Changing the Selection

By default, each new block that you create in a FIDES branch of the system hierarchy will be configured to use the same phases as the parent item. To change that, open the Item Phases window and click the Define At This Level command.

If you have defined different phases for a particular block, but you wish to go back to using the same phases as the parent item, click the Inherit from Parent command.

Viewing and Selecting the Item Phases

To access the Item Phases window, select an item in the system hierarchy and then choose Prediction > FIDES > Item Phases.

This command will be enabled only if you have selected a FIDES standard item or a block that belongs to a FIDES standard item. Note that this also includes all of the specialized block types that are used in FIDES analyses (COTS Board and Hybrid/Multi Chip Module).

The Item Phases window displays the phases that will be used in the calculations for all components in the next level below the selected item. If there are any blocks in the next level, you can choose whether their components will inherit the same phases as the parent item, or specify different phases for that branch, as described above.

All of the phases that you use in a FIDES analysis must have been predefined in the list of phases that are saved in the database. If a saved phase is modified at any time, the changes will be applied automatically to any FIDES analysis that uses the phase.
Chapter 9: FIDES Predictions

The purpose of the Item Phases window is to:

- Select which of the saved phases or phase sets are applicable.
- Specify "local" titles that reflect how each predefined phase is being used in the analysis for this particular item. This is set in the Title (for this item) column and the names must be unique for the item.
- Specify the order in which the phases occur for the particular item.

Note that the local title and the order do not have any effect on the calculations but they will determine how phased component properties are displayed in the Properties panel.

For example, both pictures below show a situation where you can set a different applied voltage for each different operating phase in an aircraft’s mission. The phase labels (Pre-Flight Taxi, Takeoff, etc.) come from the Title (for this item) column in the Item Phases window. The "Pre-Flight Taxi" and "Post-Flight Taxi" phases are linked to the exact same saved phase, but they have different local titles to reflect their purpose in the analysis.

The Grouped phase properties option on the Other Settings page of the Application Setup determines how these phase labels are displayed in the Properties panel. The picture on the left shows how the properties are displayed when the option is selected; the picture on the right shows how the properties are displayed when the option is cleared.
The ribbon in the Item Phases window provides the following commands:

- **Inherit from Parent** or **Define at This Level** will be enabled only if you are viewing the phases for a block. You can use them to specify that the block will inherit the same phases as the parent item or that you will specify a different set of phases for that branch, as described above.

- **Select Phases** and **Select Phase Set** allow you to select any of the phases or phase sets that have been saved in the database. If you want to use both, first select the phase set and then append individual phases at the end of the list.

- **Duplicate Phase** creates another instance of the same phase in the list for the current item. This will be convenient if the assembly experiences the same phase more than once in a single mission. For example, an aircraft goes through the taxi phase at both the beginning and the end of a mission.

- **Remove Phase** removes the selected phase from the list for the current item. (Note that the saved phase record will still be available for other FIDES analyses in the current database. If you wish to permanently delete the phase, use the Delete Phase command in the Manage Repository Phases window.)

- **Move Up** and **Move Down** move the selected phase up or down in the list. The phase order does not impact the calculations; it simply determines how phased properties are organized in the Properties panel.

- **Manage Repository Phases** allows users with the "Manage Lambda Predict repository settings" permission to manage all of the phases that have been saved in the database. This will be convenient if you want to assign a new phase that has not yet been defined in the database or if you need to change the properties for any of the saved phases. The command opens the same Manage Repository Phases window that is accessible from the FIDES Settings Manager window.

- **Send to Excel** exports the current table to a new Excel spreadsheet.

### Select Pi Factor

For some of the pi factors that must be defined for assemblies, components and phases in FIDES analyses (such as Pi Ruggedizing, Pi Application, etc.), the FIDES standard provides specific assessment criteria that can be used to calculate the pi factor value. When you have
used the FIDES criteria to perform an assessment for a particular situation, the responses can be stored and used again to determine the values for other analysis properties when applicable.

This topic describes how to use a saved pi factor assessment to set the value for a particular property in a FIDES analysis. For information about how to manage the list of all saved pi factors that are available in the current database, see Manage Pi Factors.

For any FIDES analysis property that can be set by a saved pi factor assessment, you have the option to enter the value directly or click inside the field and then click the Select Pi Factor icon.

In the Select Pi Factor window, the table displays a list of all saved pi factor assessments of the current type that are already saved in the database. Double-click any row to use that saved assessment to set the value for the current property. In addition, users with the "Manage Lambda Predict repository settings" permission can use the icons at the bottom of the window to:

- **Add** a new pi factor. For all pi factor types except Pi Process, the windows used to define or modify the saved assessment will function in a similar manner (see Saved Pi Factor Assessments). For Pi Process factors, the Process Audits window will be displayed.
- **Edit** the pi factor that is currently selected (or simply view its properties).
- **Delete** the pi factor that is currently selected.

**Tip:** When a saved pi factor has been used to set a property in a FIDES analysis, the value in the analysis will not be updated automatically if you later delete or modify the saved factor. However, you can use the Update Factors command to initiate an update if desired. (See Update Factors.)

**Update Factors**

When you have used a saved pi factor assessment to set a property for a particular item in a FIDES analysis, the name will be displayed in brackets in the item properties.

If any authorized user later deletes the saved assessment (i.e., users with the "Manage Lambda Predict repository settings" permission):
The label will be removed the next time the item properties table is refreshed, but the value will remain unchanged. In other words, the property will no longer be associated with a saved assessment but the calculated value will continue to be used in the analysis unless/until you specifically change it.

**If any authorized user later modifies the saved assessment:**

The value in the FIDES analysis will not be updated unless you specifically choose to update it. There are two ways to do this:

- If you want to automatically update all properties in the current prediction folio that were set based on a saved pi factor assessment, choose **Prediction > FIDES > Update Factors**.

- If you want to update only a particular property, click inside the field and click the **Select Pi Factor** icon.

Then select the same saved assessment again to re-assign it using the latest value.

---

**Process Contributions**

As discussed in **Pi Process Factors: Entity and Process Audits**, when you use a saved process audit to set a Pi Process factor in a FIDES analysis, the calculation will be based on the process contribution weights that have been defined for the particular prediction folio. The weights recommended by the FIDES standard will be defined by default for each new prediction folio that you create; however, it is possible to adjust the weights for a particular prediction folio if desired.
To view/edit the weights that are currently in effect for any particular prediction folio, open the folio and then choose **Prediction > FIDES > Process Contributions**.

Click inside the **Contribution** column to edit the weights. The sum of all weights will be displayed in the last row. If this value does not equal 100%, you won’t be able to save the changes.

If you want to reset the percentages to the default values that are recommended by the FIDES standard (i.e., the same process contributions that are used to calculate the grade in the Process Audit window), click **Reset**.

**Note:** After you have used a saved process audit to set a Pi Process factor in a FIDES analysis, the value in the prediction will not be updated automatically if you later modify the process audit and/or the process contribution weights that are defined in the prediction folio. To update the value, you must either reset the property (by selecting the saved process audit again) or use the Update Factors command to update all calculated values in the current folio. (See **Update Factors**.)

**Manage FIDES Settings**

The FIDES Settings Manager window allows authorized users to manage all of the predefined FIDES settings that are saved in the current database. These settings are shared by all users for all FIDES analyses in all projects within the current database. In a secure database, the ability to manage the settings will be accessible only if you have the "Manage Lambda Predict repository settings" permission.

To access the window, choose **File > Manage Repository > FIDES Settings Manager**.

The FIDES Settings Manager window provides a separate button for each type of FIDES setting that can be saved in the database. The options for managing these saved settings are discussed in the following sections.

**Tip:** Authorized users can also modify these settings while working on a particular FIDES analysis in the prediction folio. For example, when you use the Select Pi Factor window to set a particular property in a FIDES analysis (and only if you have the "Manage other repository settings" permission), you will have the opportunity to add, edit or delete any of the saved pi factors of that particular type. Likewise, you can access the Manage Repository Phases window when you’re using the Item Phases and Select Phases windows to select the phases that will be used to define the life profile of a particular system or assembly.
If you wish to use some or all of the same saved FIDES settings in multiple databases, there are two options:

- Click the **Import** button to use the **Import FIDES Settings window** to copy specific settings from another existing database at any time.
- Click the **Save as Default** button to save the settings from the current database to a separate resource file (*.lpd) so they will be copied over each time you create a new database from this computer. (See [Default FIDES Settings for New Databases](#).)

In both cases, it’s important to remember that the settings are copied between files but not linked, and therefore it does not automatically ensure that the settings in different databases will remain synchronized after changes are applied. If you wish to keep the settings synchronized among multiple databases, you will need to apply the changes in one database and then import them into all other applicable databases. If you’re using an *.lpd file to automatically populate the settings in each new database that you create, you will also need to save the latest settings into the active resource file.

### Import FIDES Settings

The Import FIDES Settings window makes it easy to import saved FIDES settings from another existing database at any time.

To access this window, first choose **File > Manage Repository > FIDES Settings Manager**, then click the **Import** button at the bottom of the **FIDES Settings Manager window**.

In the Import FIDES Settings window, use the **Select Repository to Import From** area to specify the database that contains the settings you wish to copy. Click the arrow to select from a list of recently accessed databases or click the browse button (…) to select any standard database (*.rsr18) or enterprise database connection file (*.rserp). The tree under **Select Settings to Import** will display all of the saved FIDES settings that are stored in the selected database, as shown next.
Select the check boxes for the settings you want to copy, and then click Import. Note that this is a one-time transfer of data from one database to another. If you later modify the settings in the original database; the changes will not affect any settings that have already been copied into other database(s).

*Tip:* You also have the option to maintain a collection of saved FIDES settings that will be populated automatically in each new database that you create. For details, see Default FIDES Settings for New Databases.

Default FIDES Settings for New Databases

If you wish to use some or all of the same saved FIDES settings in multiple databases, you have the option to maintain a collection of saved settings that will be populated automatically in each new database that you create. These settings are stored in a separate resource file so they can be copied over each time you create a new database.

The **Settings Path** field on the Other Settings page of the Application Setup displays the pathname/filename for the resource file that will be used the next time you create a new database from this computer.
By default, this file is stored at C:\Users\username\My Documents\ReliaSoft\Lambda Predict 18\LP_Defaults.lpd and it does not contain any saved FIDES settings. In other words, if you do nothing, then each new database that you create from this computer will start without any saved FIDES settings and you can create or import them as needed in each new database.

But if desired, you also have the option to:

- **Load the same set of FIDES settings into each new database.**
- **Share the same default FIDES settings with multiple users.**
- **Restore the original default FIDES settings for your computer.**

### Load the same set of FIDES settings into each new database:

1. Choose **File > Application Setup**. On the Lambda Predict > Other page, make sure the appropriate *.lpd file is selected (i.e., active for this computer) for the Settings Path.

   **Tip:** If you are working alone and always want to use the same settings, it may be easiest to just update the LP_Defaults.lpd file that is installed with the software. If you are sharing data with other users and/or you want to manage different sets of saved FIDES settings, you can copy the default *.lpd file to any other pathname(s)/filename(s) that suit your needs.

2. Open a database that contains the saved FIDES settings that you wish to use by default in each new database.

3. Choose **File > Manage Repository > FIDES Settings Manager** to open the FIDES Settings Manager window. Click the **Save as Default** button at the bottom of the window to copy the settings from the current database to the active resource file.

The next time you create a new database while the specified *.lpd file is active on your computer, these settings will be automatically copied into the new database. Note that this is always a one-time transfer of data. If you later modify the *.lpd file, the changes will not affect any settings that have already been copied into other database(s).

### Share the same default FIDES settings with multiple users:

1. Use the steps described above to prepare the *.lpd file that all users will share.

2. Place the file into a shared network location that will be accessible to all users.

3. Instruct all users to choose **File > Application Setup**. On the Lambda Predict > Other page, click the browse (…) button for the Settings Path and select the shared file.

The next time that any of these users creates a new database while the shared *.lpd file is active on his/her computer, the settings will be automatically copied into the new database.
Likewise, if any of these users clicks the Save as Default button from the FIDES Settings Manager window, this will modify the settings that are shared by all users.

**Restore the original default FIDES settings for your computer:**

1. Choose File > Application Setup and go to the Reset Settings page.
2. Click the Reset FIDES Settings button.
3. Restart the application.

This will have two effects. First, the FIDES Settings Path on the Other Settings page of the Application Setup will be reset to the default \(C:\Users\username\My Documents\ReliaSoft\Lambda Predict 18\LP_Defaults.lpd\). Second, the LP_Defaults.lpd file in that location will be reset to its default state without any saved FIDES settings.

This means that, if you have been saving your own custom settings to the default pathname/filename, clicking the reset button will restore that file to its original condition and any modifications will be lost. However, if you have been saving settings in a file that resides in a different location or has a different name, clicking the reset button will restore the default pathname/filename for the active resource file on your computer, but the custom file will remain unchanged and you can later make it active again if desired.

**Manage FIDES Categories**

You can use customized categories to sort and filter the saved FIDES settings that are available in the current database. These categories are optional, and they’re intended to provide a flexible way to organize the FIDES settings so they are easier to find when needed.

For maximum flexibility, the categories are defined separately for each type of saved FIDES setting. For example, you may wish to use one set of categories to organize the saved phases, and different sets of categories to manage different types of pi factors.

These categories will then be available when applicable throughout the interface to help you filter or sort lists of saved FIDES settings. For example, when you create a new pi factor assessment, you can use the Category drop-down list to assign any of the applicable categories. Then later when you select a saved pi factor to set the value for a particular property in a FIDES analysis, you will be able to sort the list by category in order to make it easier to find the information you need.

To view or edit the categories that are defined in the current database, choose File > Manage Repository > FIDES Settings Manager, then click the Categories button.
In the Manage FIDES Categories window, use the Select Category Type drop-down list to select which type of setting you want to manage (e.g., Phase, Pi Ruggedizing, Pi Part Manufacturing, etc.). The table displays the categories, if any, that have been defined for the selected type. Use the icons at the bottom of the window to:

- **Add** a new row at the bottom of the list.
- **Insert** a new row above the row that is currently selected.
- **Delete** the row that is currently selected.
- **Move Up** and **Move Down** the selected row up or down in the list.

Click **OK** to save your changes or **Cancel** to close the window without saving any changes.

### Life Profile Phases

#### Manage Repository Phases

For any FIDES analysis, you will be able to specify different phases that a system or assembly experiences during operation (i.e., define the item’s *life profile*). Some of the component properties (such as applied voltage or power dissipated) can then be defined separately for different phases. The phases themselves also have various properties that will affect the failure rate calculations (such as ambient temperature and environmental pollution).

**Tip:** Any changes to a saved phase record will be applied automatically to every FIDES analysis where that phase is being used. This is different from using saved pi factor assessments, where the change does not take effect until you take a specific action to update the analysis. (See [Update Factors](#)).

This topic describes how to use the Manage Repository Phases window to maintain the list of all phases that are available to be used for any FIDES analysis in the current database. For information about grouping selected phases to specify a life profile, see [Manage Phase Sets](#). For information on using life profiles for each particular system or assembly in a FIDES analysis, see [Defining Life Profiles](#).

To open the Manage Repository Phases window, choose **File > Manage Repository > FIDES Settings Manager** then click the **Phases** button.
Tip: Note that you can also access this window while working on a particular FIDES analysis in a prediction folio. Click Manage Repository Phases in the Item Phases or Select Phases window.

In the Manage Repository Phases window, each row in the table describes the operating conditions and other details for a particular phase. In most cases, the column name is self-explanatory (e.g., the Ambient Temperature (°C) column allows you to enter the surrounding temperature that the assembly will experience during the given phase). Note the following:

- If you select the check box in the Default column, the phase will be assigned by default to each new FIDES standard item that you create in this database.

- The Calendar Time (Hrs) is the amount of time that the assembly will operate in the phase during a single year. When you specify the life profile for a particular system or assembly, it is recommended that the calendar times of all phases sum to 8,760 hours. If the sum of the calendar times for all phases is less than 8,760 hours, the model assumes that there is no damage to the component due to any type of stress for the time equal to the difference between 8,760 hours and the sum of the calendar times for all phases.

- The On/Off column indicates whether the assembly is operating (on) or dormant (off) during the phase.

- According to the FIDES standard, the Pi Application factor "represents the influence of the usage environment for application of the product containing the item. For example, exposure to a mechanical overstress is a priori more important in electronics integrated into a mobile system than in a fixed station system. This factor is variable depending on the life profile phase."
  
  - This must be a number between 0 and 10, where a higher value indicates more unfavorable conditions.

  - You can enter the value directly or click the Select Pi Factor icon to link this phase with a saved pi factor assessment. (See Select Pi Factor.)

The ribbon at the top of the window provides the following commands:

- Add Phase adds a new row to the bottom of the table so you can set the properties for a new phase.

- Duplicate Phase creates an exact copy of the phase that is currently selected.

- Delete Phase deletes the phase that is currently selected, if it has not already been assigned to any FIDES system or assembly in the database. If a phase is already in use, it cannot be deleted.
**Import Phases** allows you to import phases from another database. (See **Import Phases**.)

**Send to Excel** exports the current table to a new Excel spreadsheet.

**Category** allows you to filter the list to display only the phases that are assigned to the selected category. (See **Manage FIDES Categories**.)

### Manage Phase Sets

For FIDES predictions, the ability to use predefined phase records saves time when you’re defining the life profile for a system or assembly. You can group the individual records together into predefined phase sets, which make it even easier to create the profile for a particular item.

To open the Manage Phase Sets window, choose **File > Manage Repository > FIDES Settings Manager** then click the **Phase Sets** button.

---

**Tip:** Note that you can also access this window while working on a particular FIDES analysis in a prediction folio by clicking **Select Phase Set** in the Item Phases window.

The table displays all of the saved phase sets in the current database, if any. Double-click any row to view/edit the properties for that phase set. In addition, you can use the icons on the ribbon to:

- **Add** opens the Phase Set properties window, which allows you add phases to the set. Click the **Select Phases** command in the window to select which of the saved repository phases will be added to the set. The phases you have selected will appear in the **Phase Name** area. You can then use the **Move Up** and **Move Down** commands to arrange the phases in the desired order. (The phase order does not impact the calculations.)

- **Edit** (or simply view) the selected phase set.

- **Delete** the selected phase set.

- **Refresh** the list of saved phase sets to display the latest information stored in the database. This is useful if multiple users are accessing the database simultaneously.
Chapter 9: FIDES Predictions

Import Phases
The Import Phases window allows you to import phases that have already been defined in another database. Note that you can also use the Import FIDES Settings window to import phases, if desired. The difference is that the Import Phases window allows you to see the full details for the phases that can be imported; whereas the Import FIDES Settings window displays only the names.

To access the Import Phases window, open the Manage Repository Phases window then click the Import Phases icon.

A bar near the top of the window allows you to specify the database that contains the settings you wish to copy. Click the arrow to select from a list of recently accessed databases or click the browse button (…) to select any standard database (*.rsr18) or enterprise database connection file (*.rserp). The table under this bar will display all of the saved FIDES phases that are stored in the selected database.

Select the check boxes for the phases you want to copy, and then click OK. Note that this is a one-time transfer of data from one database to another. If you later modify the settings in the original database; the changes will not affect any settings that have already been copied into other database(s).

Pi Factors

For some of the pi factors that must be defined for assemblies, components and phases in FIDES analyses (such as Pi Ruggedizing, Pi Application, etc.), the FIDES standard provides specific assessment criteria that can be used to calculate the pi factor value. When you have used the FIDES criteria to perform an assessment for a particular situation, the responses can be stored and used again to determine the values for other analysis properties when applicable.

This topic describes how to use the Manage Pi Factors window to maintain the list of all saved pi factor assessments that are available in the current database. Saved pi factor assessments are used to set a particular property (pi factor value) in a FIDES analysis. For information about selecting which of those assessments will be used to set the value for a particular property in a FIDES analysis, see Select Pi Factor.

To open the Manage Pi Factors window, choose File > Manage Repository > FIDES Settings Manager then click the Pi Factors button.
The table displays all of the saved pi factor assessments in the current database. By default, the factors will be sorted by Factor Type (i.e., Pi Ruggedizing, Pi Application, etc.), but you can click the heading for any column to sort the list by that property (and click again to reverse the sort order).

Double-click any row to view/edit the properties for that pi factor. In addition, you can use the icons at the bottom of the window to:

- **Add** a new saved pi factor that can be used for any FIDES analysis in the current repository. The Add Pi Factor window will prompt you to select which type of pi factor you want to create. Note that the **Component Type** drop-down list in this window is applicable only when you are creating a new Pi Part Manufacturing factor; otherwise, it will be disabled.

- **Edit** the pi factor that is currently selected.

- **Delete** the pi factor that is currently selected.

**Tip:** When a saved pi factor has been used to set a property in a FIDES analysis, the value in the analysis will not be updated automatically if you later delete or modify the saved factor. However, you can use the **Update Factors** command to initiate an update if desired. (See **Update Factors**.)

For all pi factor types except Pi Process, the windows used to define or modify the saved assessment will function in a similar manner. (See **Saved Pi Factor Assessments**.)

For information about defining and modifying saved Pi Process factors, see **Pi Process Factors: Entity and Process Audits**.
Pi Factor Assessments That Can Be Saved
The types of FIDES pi factor assessments that can be saved are as follows (with definitions quoted from the FIDES standard):

- The **Pi Ruggedizing** factor "represents the influence of the policy for taking account of overstresses in the product development." This must be a number from 1 to 2.1.

- The **Pi Application** factor "represents the influence of the usage environment for application of the product containing the item. For example, exposure to a mechanical overstress is a priori more important in electronics integrated into a mobile system than in a fixed station system. This factor is variable depending on the life profile phase." This must be a number between 0 and 10.

- The **Pi Part Manufacturing** factor "represents the item quality. The evaluation method varies depending on the nature of the item considered (EEE electronic component, board assemblies, other subassemblies). The evaluation method takes account of the manufacturer's quality assurance (QMmanufacturer) criteria, item quality assurance (QAitem) criteria and also the item purchaser's experience with his supplier (ε)." This must be a number from 0.5 to 2.0.

- The **Pi Process** factor "represents the quality and technical control over reliability in the product life cycle. Its purpose is to globally evaluate the maturity of the manufacturer on the control over his reliability engineering process." This must be a number from 1 to 8.

There are also three saved pi factor assessments that contain additional process audit questions that are applicable only for specific types of components.

- **Pi Process, ASIC** applies to application-specific integrated circuit (ASIC) components.

- **Pi Process, RF HF** applies to high radio frequency (RF HF) components including RF HF Discrete Semiconductor, RF HF Inductor, RF HF Integrated Circuit, RF HF Passive, RF HF SMD Capacitor and RF HF SMD Resistor.

- **Pi Process, H&M** applies to Hybrid/Multi Chip Module (H & M) blocks.

Saved Pi Factor Assessments
This topic describes how to define or modify the properties for most types of saved FIDES pi factor assessments (including Pi Ruggedizing, Pi Application, Pi Part Manufacturing, Pi Process, ASIC, Pi Process, RF HF and Pi Process, HM). For information about using entity audits and process audits to calculate Pi Process factors, see Pi Process Factors: Entity and Process Audits.

There are two ways to access a saved pi factor assessment window:
• Double-click a row or click the Add or Edit icon in the Manage Pi Factors window.
• Click the Add or Edit icon in the Select Pi Factor window.

For all windows of this type, most of the fields at the top are intended to help you determine when it is appropriate to use this saved factor in a particular FIDES analysis. Only the Name and Value are required.

There are two options for setting the value:

Option 1: Calculate the value based on responses to FIDES assessment criteria

By default, the middle area displays the assessment criteria specified in the FIDES standard for the particular pi factor type. Each question/recommendation from the standard is associated with a drop-down list that presents the possible responses.

When you select a response from the drop-down list, Lambda Predict updates the calculated Value displayed at the top of the window.

Option 2: Enter the value directly

If you prefer to enter the pi factor value directly (i.e., without recording responses for the FIDES assessment criteria), select the Enter value instead of calculating from responses check box at the bottom of the window. The assessment criteria will become disabled and you can enter a number (within the allowable range for that factor) into the Value field.

Tip: When you use a saved pi factor assessment to set a property in a FIDES analysis, the name will be displayed in [brackets] in the item properties, as shown below. If you later delete or modify the saved pi factor assessment, the particular item property will not be updated automatically. However, you can use the Update Factors command to initiate an update if desired. (See Update Factors.)

Pi Ruggedizing [Saved Assessment] 2.0138 ...

Pi Process Factors: Entity and Process Audits

Unlike other types of saved FIDES pi factor assessments that can be performed in a single window (see Saved Pi Factor Assessments), three integrated steps are involved with using the FIDES assessment criteria to calculate Pi Process factors:

1. Perform an audit for each company, division, department or other entity that is responsible for one or more stages in the product life cycle. This generates a calculated grade for that entity’s processes in each stage. (See Entity Audits.)

   • For an entity audit, a higher value indicates that better processes are in place. For example, if the entity achieves Level 4 (best processes in place) for all audit
questions, a grade of 1.000 will be assigned. If the entity achieves Level 3, a grade of 0.6667 will be assigned. And so on.

- It is also important to note that the process audit calculations will be based on the grade(s) for the specific life cycle stage(s) that the entity is responsible for (not the overall grade for the entity). You don’t have to answer the audit questions for a stage that the entity is never responsible for.

2. Specify which entities are responsible for seven specific stages in the overall product life cycle. (See Process Audits.)

- For a process audit, a higher value indicates that worse processes are in place. For example, if a company with the highest possible entity audit grade of 1.000 (Level 4) is responsible for all seven stages in the product life cycle, this will yield the lowest possible process audit grade of 1.000. Whereas, if a company with a lower entity audit grade of 0.6667 (Level 3) is responsible for all stages, the process audit grade will be higher, 1.9997.

3. Use the process contribution weights to calculate an overall grade for the entire process. The calculation is as follows:

\[
\text{Process Grade} = \sum_{j=1}^{7} \text{Contribution}_j \cdot \text{Process Grade}_j
\]

\[
\Pi_{\text{Process}} = e^{2.079 \cdot (1 - \text{Process Grade})}
\]

where the default process contribution weights recommended by the FIDES standard are:

<table>
<thead>
<tr>
<th>Stage</th>
<th>Contribution (%)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specification</td>
<td>8</td>
</tr>
<tr>
<td>Design</td>
<td>16</td>
</tr>
<tr>
<td>Manufacturing of Board or Subassembly</td>
<td>20</td>
</tr>
<tr>
<td>Integration Into Equipment</td>
<td>10</td>
</tr>
<tr>
<td>Integration Into System</td>
<td>10</td>
</tr>
<tr>
<td>Operation and Maintenance</td>
<td>18</td>
</tr>
<tr>
<td>Support Activities</td>
<td>18</td>
</tr>
</tbody>
</table>

These default weights will be used to calculate the grade for the process audits that are saved in the database. When you use a saved process audit to set the Pi Process factor in a particular FIDES analysis, the weights that are currently defined for the prediction folio will be used.
Chapter 9: FIDES Predictions

The weights recommended by the FIDES standard will be defined by default for each new prediction folio that you create; however, it is possible to adjust the weights for a particular prediction folio if desired. Choose Prediction > FIDES > Process Contributions to view/edit the weights that are currently in effect for any particular prediction folio. (See Process Contributions Window.)

Entity Audits
In FIDES analyses, entity audits allow you to calculate a grade for each company, division, department or other entity that is responsible for one or more stages in the product life cycle for a system or assembly. These entity grades are then used in process audits to calculate an overall grade for the processes that are in place throughout the entire product life cycle. This overall process grade can be used to set Pi Process factors in FIDES analyses. (See Pi Process Factors: Entity and Process Audits.)

Manage Entity Audits
The Manage Entity Audits window displays a list of all saved entity audits that are available to be used in any process audit in the current database.

To access the window, choose File > Manage Repository > FIDES Settings Manager then click the Entity Audits button.

For convenience, it is also accessible from the ribbon in the Process Audit Properties window.

Double-click any row to view/edit the properties for that audit. In addition, you can use the icons on the ribbon to:

- Add a new audit.
- Edit (or simply view) the audit that is currently selected.
- Delete the audit that is currently selected.
- Refresh the list of saved audits to display the latest information stored in the database. This is useful if multiple users are accessing the database simultaneously.

Tip: When a saved process audit has been used to set a Pi Process factor in a FIDES analysis, the value in the analysis will not be updated automatically if you later delete or modify the saved audit. However, you can use the Update Factors command to initiate an update if desired. (See Update Factors.)


**Entity Audit Properties**

The Entity Audit properties window will be displayed whenever you have selected to create or edit an entity audit (either from the Manage Entity Audits window or the Process Audit Properties window).

The properties at the top of the window are intended to help you determine when it is appropriate to use this entity in a particular process audit. Only the Name is required.

**Recording your responses**

The left panel displays all of the audit questions recommended by the FIDES standard, grouped into separate headings that represent the seven life cycle stages (Specification, Design, etc.). Note that:

- It is not necessary to answer all of the questions if the entity is not responsible for the processes in all stages. For example, if ACME Inc. is responsible only for the Specifications and Design stages, you can answer only the questions under those two headings and leave the rest blank.

- Some questions may be applicable in more than one life cycle stage. When that occurs, the analysis assumes that your answers will reflect the processes in each particular stage. In other words, it is possible to record different answers for the same question if the entity's processes are different in different life cycle stages.

When you click a question, the panel on the right displays the full audit question and five possible responses. Select the option that best describes this entity's procedures in the particular life cycle stage.

The left most column indicates what response has been recorded for each question, if any. For example, in the following picture, the red, orange, blue and green numbers indicate which levels have been assigned for the first four questions, while the black NA indicates that the fifth question has been marked "not applicable" (and will not have any impact on the calculated grade). Answers have not been recorded for the remaining questions; therefore, the grade for this stage has not yet been calculated and the overall grade for the entity has also not been updated (i.e., the field in the top right corner still shows the default 0.3300).
Viewing a summary for each life cycle stage

When you click one of the seven life cycle stage headings in the left panel (e.g., Specification, Design, etc.), the right panel displays a summary of the responses for that stage. Remember that the grade cannot be calculated until you have answered all of the questions for the stage. For example, the following picture shows the summary for the Specification stage after all 18 questions have been answered.

There is a check mark next to the "Specification" heading, the calculated **Stage Grade** is shown in the right panel and the overall calculated grade for the entity has been updated.
Calculating the grades

After you have answered all of the questions for a particular life cycle stage, Lambda Predict calculates a grade for that stage and also updates the overall grade for the entity, which is displayed in the top right corner.

However, it is important to note that the process audit calculations are based on the stage grades (and not the overall grade).

For example, suppose that ACME Inc. receives a grade of 1.000 for the Specification stage (Level 4 processes), 0.6667 for the Design stage (Level 3 processes) and none of the questions are answered for the other stages that ACME is never responsible for. This results in an overall grade of 0.4307. When you later create a process audit in which ACME Inc. is responsible for those two stages of a particular product’s life cycle, the calculation will use 1.000 when ACME Inc. is responsible for the Specification stage and 0.6667 when it is responsible for the Design stage.

Process Audits

In FIDES analyses, process audits allow you to specify which companies, divisions, departments or other entities are responsible for each stage in the overall product life cycle for a particular system or assembly. The stage grades from the applicable entity audits are then used to calculate an overall grade for the processes that are in place throughout the entire life cycle.
This overall process grade can be used to set Pi Process factors in FIDES analyses. (See Pi Process Factors: Entity and Process Audits.)

Manage Process Audits
The Manage Process Audits window displays a list of all saved process audits that are available to be used to set the Pi Process factor for any FIDES standard item or block in the current database.

To access the window, choose File > Manage Repository > FIDES Settings Manager then click the Process Audits button.

Double-click any row to view/edit the properties for that audit. In addition, you can use the icons on the ribbon to:

- Add a new audit.
- Edit (or simply view) the audit that is currently selected.
- Delete the audit that is currently selected.
- Refresh the list of saved audits to display the latest information stored in the database. This is useful if multiple users are accessing the database simultaneously.

Tip: When a saved process audit has been used to set a Pi Process factor in a FIDES analysis, the value in the analysis will not be updated automatically if you later delete or modify the saved audit. However, you can use the Update Factors command to initiate an update if desired. (See Update Factors.)

Process Audit Properties
The Process Audit Properties window will be displayed whenever you have selected to create or edit a process audit (either from the Manage Process Audits window or the Select Pi Factor window).

The properties at the top of the window are intended to help you determine when it is appropriate to use this saved audit to set a particular property in a FIDES analysis. Only the Name and Value are required.

There are two options for setting the value:

Option 1: Calculate the value based on the assigned entities
The value can be calculated automatically based on the entities that you have assigned to the seven product life cycle stages. You can assign zero, one or multiple entities per stage.
Chapter 9: FIDES Predictions

Remember that a higher entity audit grade indicates that better processes are in place; whereas a higher process audit grade indicates worse processes (and higher failure rates). If you assign more than one entity to the same life cycle stage, the calculation will use the lowest entity grade (worst processes), which will then yield the higher overall process grade.

The overall process grade calculation is also based on the process contribution weights that are specified by the FIDES standard (e.g., the grade for the "Manufacturing of Board or Subassembly" stage – 20% -- will have a bigger impact than the grade for the "Specifications" stage – 8%). For details, see Pi Process Factors: Entity and Process Audits.

Assigning entities

To assign an entity to a particular stage in the product life cycle, click twice inside the Grade column. The list displays all of the entity audits in the current database that have not yet been assigned to this particular stage. Select an entity from the list and click OK.

If an audit has not yet been created for the responsible entity, click the Add icon to create one.

If the list is very long, you can use the Search box to filter the list. For example, in the following picture, the list shows only the entities that have the word "Company" in the name.

![Select Entity Audit](image)

Note: The grades displayed in each list are the "Stage Grades" from the entity audit (not the overall grade calculated for the entity). For example, if ACME Inc. received a grade of 1.000 for the Specification stage (Level 4 processes) and 0.6667 for the Design stage (Level 3 processes), those individual grades will be used in a process audit (not the combined grade of 0.4307).

Removing entities

There are two ways to remove entities that have already been assigned in the process audit.

To remove all entities at the same time (i.e., completely reset the process audit to start over from the beginning), click the Remove All Entities icon.
To remove one entity at a time, select the row and click the Remove icon \( \times \), as shown next. This will not delete the saved entity audit from the database; it simply removes the association with this particular stage of this particular process audit.

Option 2: Enter the value directly

If you prefer to enter the process audit value directly, select the **Enter value instead of calculating from responses** check box at the bottom of the window. The life cycle stages area will become disabled and you can enter a number (within the allowable range for that factor) into the **Value** field.

*Tip:* When you use a saved process audit to set a property in a FIDES analysis, the name will be displayed in [brackets] in the item properties, as shown below. If you later delete or modify the saved process audit, the particular item property will not be updated automatically. However, you can use the **Update Factors** command to initiate an update if desired. (See **Update Factors**.)
Chapter 10: Siemens Predictions

For general information about using the prediction folio for any type of standard (e.g., how to create folios, build system configurations, etc.), see Prediction Folios.

The Siemens SN 29500 standard provides reliability prediction models for electronic and electromechanical components. It consists of 12 sections, which provide expected values as follows:

- Section 1: General (issued January 2004)
- Section 2: Integrated circuits (issued September 2010)
- Section 3: Discrete semiconductors (issued June 2009)
- Section 4: Passive components (issued March 2004)
- Section 5: Electrical connections, electrical connectors and sockets (issued June 2004)
- Section 7: Relays (issued November 2005)
- Section 9: Switches and buttons (issued November 2005)
- Section 10: Signal and pilot lamps (issued December 2005)
- Section 11: Contactors (issued April 2015)
- Section 12: Optical components (issued February 2008)
- Section 15: Electromechanical protection devices in low voltage networks (issued October 2014)
- Section 16: Electromechanical pushbuttons, signaling devices and position switches in low voltage networks (issued August 2010)
Chapter 11: Allocation

Lambda Predict’s allocation analysis tool can help you determine the reliability requirements for individual assemblies that would be needed to achieve an overall reliability goal. The allocation is performed at the block level, so to perform the analysis, you will first select a standard item (i.e., ML, BL, TL, MC, LE, SN or G) or a hybrid block or a generic block that contains at least one block in the next level below.

With the item selected, open the Allocation window by choosing Prediction Tools > Allocation > Allocation.

In the Allocation window, use the Allocation Type drop-down list on the control panel to select the desired allocation model. The available types include:

- Equal
- AGREE
- Feasibility of Objectives
- ARINC
- Repairable Systems

Once you have selected an allocation model, select the check box for each block you want to include in the allocation. Note that in order to analyze a dependent block, you must select its parent block. Enter the reliability goal and other required information (descriptions of the required fields for each allocation model are presented in the topic relating to the model), and then click the Calculate icon to calculate the reliability allocation.

The table is updated to show the results of the analysis. To view a plot of the analysis, click Plot on the control panel. To export the analysis to a Microsoft Excel file or delimited text file, click Export.

**Tip:** Although the Allocation window shows the inputs and results for only one analysis at a time, the last inputs and results from other allocation types are stored in the utility. This means that you can switch back and forth between allocation types without losing any data, and that you can view plots for any of the allocation types that have at least one block included in the analysis.
Control Panel

The control panel displays the input fields that are applicable for the analysis type that is currently selected in the Allocation Type drop-down list. See the topic relating to the allocation model for details.

- **Calculate** performs the allocation analysis based on the current settings.
- **Plot** switches to the plot sheet, which allows you to view plots for any of the allocation types that have at least one block selected to be included in the analysis.
- **Select All** selects all of the items to be included in the allocation analysis.
- **Clear All** clears the check boxes for all of the items, so you can then select only specific items to be included in the allocation analysis.
- **Export** exports the allocation analysis to an Excel file or delimited text file.

Equal Allocation Model

When you select the Equal allocation model in the Allocation utility, the Elements field in the control panel will update automatically to display the number of blocks that you have selected to include in the analysis (i.e., the number of check boxes that are selected in the Include column of the table).

In the **Reliability Goal** field in the control panel, enter the desired overall reliability for the system (expressed as a decimal from 0 to 1, excluding 0). In the **Operating Time** field, enter the length of time the system will operate (in hours). Click the **Calculate** icon on the control panel to obtain the results.

The following results will be displayed in the table for each block selected to be included in the analysis:

- **Reliability Allocated** is the reliability goal for the block, expressed as a decimal value from 0 to 1, excluding 0.
- **Allocated Failure Rate** is the recommended failure rate for the block, based on the allocation analysis. This calculated result is expressed in failures per million hours (FPMH) for MIL-217 and NSWC, and in failures per billion hours (FITS) for Bellcore/Telcordia and FIDES.
- **Allocated MTBF (hrs)** is the recommended mean time between failures for the block, based on the allocation analysis. This calculated result is always expressed in hours.
• **Current Failure Rate** is the current failure rate for the block based on the current reliability prediction so you can compare with the recommended value.

### About the Equal Allocation Model

**Description:**

- Assumes a series of $n$ sub-elements, each of which is assigned the same reliability figure of merit.
- The weakness is that the elements are not assigned reliability design goals in accordance with the degree of difficulty associated with achieving the goal.

**Model:**

\[
R_{product} = \prod_{i=1}^{n} \hat{R}_i
\]

or:

\[
\hat{R}_i = \left(R_{product}\right)^{1/n}
\]

where:

- $R_{product}$ = Product reliability requirement/goal.
- $\hat{R}$ = Reliability allocated to the $i$th element.
- $i = 1, 2, ..., n$ elements.

where $\lambda$ can be obtained by:

\[
\hat{R}_i = e^{-\lambda t}
\]

\[
\lambda = \frac{\ln(R)}{t} \quad \text{(failures per hour)}
\]

### AGREE Allocation Model

When you select the AGREE allocation model in the **Allocation utility**, the **Elements** field in the control panel will update automatically to display the number of blocks that you have selected.
to include in the analysis (i.e., the number of check boxes that are selected in the Include column of the table).

In the **Reliability Goal** field in the control panel, enter the desired overall reliability for the system (expressed as a decimal from 0 to 1, excluding 0). Then enter the following information for each selected block in the table:

- **The Operating Time** is the length of time, in hours, over which the reliability is calculated.

- **The Importance Factor** is an indication of how critical the block is to the overall system operation, expressed as a decimal from 0 to 1, where 0 indicates that the block's failure will not cause any problems for the system and where 1 indicates that the block's failure will definitely cause system failure.

- **The Number of Sub-Elements** is the number of the block's components to be considered in the analysis. This can be either the same number as in the analysis, or a different number for experimental purposes.

Once you have entered all required information, click the **Calculate** icon. The following results will be displayed in the table for each block selected to be included in the analysis:

- **Reliability Allocated** is the reliability goal for the block, expressed as a decimal value from 0 to 1, excluding 0.

- **Allocated Failure Rate** is the recommended failure rate for the block, based on the allocation analysis. This calculated result is expressed in failures per million hours (FPMH) for MIL-217 and NSWC, and in failures per billion hours (FITS) for Bellcore/Telcordia and FIDES.

- **Allocated MTBF (hrs)** is the recommended mean time between failures for the block, based on the allocation analysis. This calculated result is always expressed in hours.

- **Current Failure Rate** is the current failure rate for the block based on the current reliability prediction so you can compare with the recommended value.

**About the AGREE Allocation Model**

**Description:**

- Developed by the Advisory Group on Reliability of Electronic Equipment (AGREE).
- Technique includes both the complexity and the importance of each element.
- Assumption is that it should be used for series elements with exponential failure distributions.
- Model is based on Mean Time Between Failure (MTBF).
• The importance factors are based on the estimated probability of product failure as a result of element failure. The steps are as follows:
  • Determine the probability of each element causing product failure.
  • Calculate the MTBF of each element.
  • Calculate the allocated reliability of each element.

Model:

\[ MTBF_i = \frac{N w_i t_i}{n_i \ln R(t)} \]

and:

\[ R_i(t) = e^{- \frac{t_i}{MTBF_i}} \]

where:

• \( i = 1, 2, ..., n \) elements.
• \( t = \) product operating time.
• \( t_i = \) element \( i \) operating time. Must be > 0.
• \( w_i = \) importance factor for element \( i \).
• \( n_i = \) number of sub-elements \( i \). Must be > 0.
• \( R(t) = \) product reliability.
• \( R_i(t) = \) allocated reliability for each element \( i \).
• \( MTBF_i = \) allocated MTBF for the element.
• \( N = \sum_{i=1}^{k} n_i = \) total sub-elements.

**Feasibility of Objectives Allocation Model**

When you select the Feasibility of Objectives allocation model in the Allocation utility, the Elements field in the control panel will update automatically to display the number of blocks that you have selected to include in the analysis (i.e., the number of check boxes that are selected in the Include column of the table).
Chapter 11: Allocation

In the **Reliability Goal** field in the control panel, enter the desired overall reliability for the system (expressed as a decimal from 0 to 1, excluding 0). Then enter the following information for each selected block in the table:

- **The Intricacy Factor** represents how intricate the element is, expressed as a number from 1 to 10 where 1 is simple and 10 is very complex.
- **The State of the Art** factor represents how technologically up-to-date the element is, expressed as a number from 1 to 10 where 1 is mature and 10 is new.
- **The Operating Time Index** factor represents how continuously the element is in operation, expressed as a number from 1 to 10 where 1 is a low duty cycle and 10 is continuous operation.
- **The Environment** factor represents how harsh the element's environment is, expressed as a number from 1 to 10 where 1 is benign and 10 is severe.

Once you have entered all required information, click the **Calculate** icon. The control panel displays the following totals calculated for all blocks in the analysis:

- **Failure Rate** displays the total failure rate, expressed in failures per million hours (FPMH) for MIL-217 and NSWC, and in failures per billion hours (FITs) for Bellcore/Telcordia and FIDES.
- **MTBF** displays the total MTBF, expressed in hours.
- **Composite Rating (Wfk)** displays the total weighting factor.

In addition, the following results will be displayed in the table for each block selected to be included in the analysis:

- **The Weighting Factor** is the calculated weighting factor for the block, which is the product of the four input factors (i.e., Intricacy Factor, State of the Art, Operating Time Index and Environment).
- **The Percent Ck** is the normalized weight for the block, based on the weighting factors for all blocks in the analysis.
- **Allocated Failure Rate** is the recommended failure rate for the block, based on the allocation analysis. This calculated result is expressed in failures per million hours (FPMH) for MIL-217 and NSWC, and in failures per billion hours (FITs) for Bellcore/Telcordia and FIDES.
- **Allocated MTBF (hrs)** is the recommended mean time between failures for the block, based on the allocation analysis. This calculated result is always expressed in hours.
- **Current Failure Rate** is the current failure rate for the block based on the current reliability prediction so you can compare with the recommended value.
About the Feasibility of Objectives Allocation Model

Description:

- Does not require detailed failure history of product elements.
- Applicable to all repairable electromechanical products.
- Element allocation factors are computed as a function of numerical rating of:
  - Product complexity (1 - simple to 10 - very complex)
  - State-of-the-art (1 - mature to 10 - new)
  - Operating time (1 - low duty cycle to 10 - continuous operation)
  - Environment (1 - benign to 10 - severe)
- The four criteria ratings are multiplied together to get an overall weighting and normalized so that the product sum is 1.
- The element allocation is then based on the normalized part of the product reliability goal.

Model:

\[ \lambda_s T = \sum \lambda_k T \]

and:

\[ \lambda_k = C_k \lambda_s \]

where:

- \( C_k \) = normalized weight of element:

\[ C_k' = \frac{W_{f_k}}{\sum W_{f_k}} \]

- \( W_{f_k} \) = composite rating for element \( k \)
and where:

\[ W_{f,k} = r_{1k} \times r_{2k} \times r_{3k} \times r_{4k} \]

\[ W_f = \sum_{k=1}^{N} W_{f,k} \]

- \( \lambda_s \) = Product failure rate.
- \( T \) = Operating duration.
- \( \lambda_k \) = Allocated element \( k \) failure rate.
- \( N \) = Number of elements.
- \( r_{ik} \) = \( i \)th rating result for a factor for element \( k \).

### ARINC Allocation Model

When you select the ARINC allocation model in the Allocation utility, the Elements field in the control panel will update automatically to display the number of blocks that you have selected to include in the analysis (i.e., the number of check boxes that are selected in the Include column of the table).

In the Reliability Goal field in the control panel, enter the desired overall reliability for the system (expressed as a decimal from 0 to 1, excluding 0). In the Operating Time field, enter the length of time the system will operate, in hours. Click the Calculate icon on the control panel to obtain the results.

The following results will be displayed in the table for each block selected to be included in the analysis:

- **Present Failure Rate** is the block’s failure rate that will be used in the allocation analysis. If you have selected the Use failure rate from current prediction check box in the control panel, the application will automatically populate this column based on the current prediction and it will be the same as the Current Failure Rate value. If you clear the check box, you can enter values for the blocks you have selected to include in the analysis.

- **Allocated Failure Rate** is the recommended failure rate for the block, based on the allocation analysis. This calculated result is expressed in failures per million hours (FPMH) for MIL-217 and NSWC, and in failures per billion hours (FITS) for Bellcore/Telcordia and FIDES.
• **Allocated MTBF (hrs)** is the recommended mean time between failures for the block, based on the allocation analysis. This calculated result is always expressed in hours.

• **Current Failure Rate** is the current failure rate for the block based on the current reliability prediction so you can compare with the recommended value.

### About the ARINC Allocation Model

**Description:**

- Developed by ARINC Research Corporation, a subsidiary of Aeronautical Radio, Inc.
- Assumes all subsystems are in series and have constant failure rates.
- Allocates improved subsystem failure rates based on weighing factors, derived from the present allocation of the subsystem, that satisfy the expression:

\[
\sum_{i=1}^{n} \lambda_i' \leq \lambda
\]

where:

- \( n = \) Number of subsystems.
- \( \lambda_i = \) Failure rate allocated to subsystem \( i \).
- \( \lambda = \) Required system failure rate.

The steps are as follows:

- Determine the present system failure rate.
- Compute a weighting factor for each subsystem using the expression:

\[
W_i = \frac{\lambda_i}{\sum_{i=1}^{n} \lambda_i}
\]

- Allocate the new subsystem failure rates using the expression:

\[
\lambda_i' = W_i \lambda
\]

where \( \lambda \) can be obtained by:

\[
R(t) = e^{-\lambda t}
\]
Chapter 11: Allocation

where:

- \( R(t) \) = Reliability goal.
- \( t \) = Operating time.

**Repairable Systems Allocation Model**

When you select the Repairable Systems allocation model in the Allocation utility, the Elements field in the control panel will update automatically to display the number of blocks that you have selected to include in the analysis (i.e., the number of check boxes that are selected in the Include column of the table).

In the **Availability Goal** field in the control panel, enter the desired overall availability for the system, expressed as a decimal from 0 to 1, excluding 0. Then click **Calculate** to obtain the results.

The following results will be displayed in the table for each block selected to be included in the analysis:

- **MTTR** is the mean time between repairs, expressed in hours.

- **Allocated Failure Rate** is the recommended failure rate for the block, based on the allocation analysis. This calculated result is expressed in failures per million hours (FPMH) for MIL-217 and NSWC, and in failures per billion hours (FITS) for Bellcore/Telcordia and FIDES.

- **Allocated MTBF (hrs)** is the recommended mean time between failures for the block, based on the allocation analysis. This calculated result is always expressed in hours.

- **Current Failure Rate** is the current failure rate for the block based on the current reliability prediction so you can compare with the recommended value.

**About the Repairable Systems Allocation Model**

**Description:**

- Allocates failure rates to subsystems in series with constant failure rates.
- The allocated subsystem failure rates allow the system to meet an availability objective.
- Assumes that all subsystems are identical and have a constant repair rate.
Chapter 11: Allocation

The steps are as follows:

- Determine the steady-state availability for each subsystem using the expression:

\[ A_i = \left( A \right)^{\frac{1}{k}} \]

where:
- \( A \) = Required system availability.
- \( k \) = Number of subsystems.

- Determine the ratio of the allocated failure rate to the repair rate for each subsystem using the expression:

\[ \theta_i = \frac{1}{A_i} - 1 \]

- Determine the failure rate allocated to each subsystem with the expression:

\[ \hat{\lambda}_i = \theta_i \mu_i \]

where \( \mu_i \) = Repair rate for each subsystem.

Allocation Plots

In the Plot page of the Allocation window, you can create plots for any of the allocation types that have at least one block selected to be included in the analysis. In other words, even though the Allocation page shows the inputs and results for only one allocation analysis at a time, the last inputs/results from other allocation types are stored in the utility and those results can be displayed on the Plot page, if desired.

To access the Allocation window's plot sheet, click the **Plot** icon on the control panel.

The control panel tools include the following options:

- The **Allocation Type** drop-down list allows you to choose which type of allocation analysis to view. If the plot cannot be generated, a message will appear in the plot area and you will need to return to the Allocation page and make sure that at least one block is selected to be included in the analysis for the selected allocation type. You may need to redraw the plot when you return to the plot sheet.
Chapter 11: Allocation

- The following options are available in the **Plot Type** drop-down list:
  - **Allocated vs. Current**: For each block included in the allocation analysis, the allocated failure rate and the current failure rate are displayed side-by-side as vertical bars.
  - **Difference**: For each block included in the allocation analysis, the plot displays the difference, in failures per million hours, between the allocated failure rate and the current failure rate as a vertical bar.

- **Auto Refresh** automatically redraws the plot when something changes. If not selected, you must click the **Redraw Plot** icon to refresh the display.

- **Keep Aspect Ratio** maintains the ratio of the horizontal size to the vertical size of the plot graphic when you resize the plot sheet.

- For the x-axis labels, choose to display either the **Name** or **Part Number**.

- In the **Scaling** area, the X and Y Scaling boxes show the minimum and maximum values for the x- and y-axes. You can change these values if the check box beside the value range is not selected. If it is selected, the application will automatically choose appropriate values for the range.

The plot tools are arranged on the left side of the control panel:

- **Redraw Plot** updates the plot to reflect any changes that have been made.

- **Plot Setup** opens the **Plot Setup window**, which allows you to customize most aspects of the plot including the titles, colors, sizes, etc.

- **RS Draw** launches **ReliaSoft Draw**, which allows you to view the plot in greater detail, add annotations and modify selected plot elements.

- **Copy Plot Graphic** copies the plot to the Clipboard. You can then paste the graphic into another application. The way the plot is copied will depend on your selection in the **Plot Copy Type** field in the **Other Synthesis Settings** page of the Application Setup.

- **Export Plot Graphic** saves the plot as a graphic in *wmf, *.png, *.gif or *.jpg format. You will be able to use the exported graphic in any application, provided that the application supports the file format.
Chapter 12: Derating Analysis

Derating is the selection and application of parts and materials so that the applied stress is less than rated for a specific application. To use derating analysis in Lambda Predict, you will first apply a derating standard to a selected standard item in the system hierarchy (you can select any except the NSWC standard item, the Siemens standard item or the MIL-217 Parts Count standard item). The selected derating standard will be applied automatically to all the components under that item. You can define your own custom derating standard or select from any of the following published derating standards:


- **MIL-STD-975M: NASA Standard Electrical, Electronic, and Electromechanical (EEE) Parts List**, issued by the U.S. National Aeronautics and Space Administration in 1994. This standard provides part selection information and derating curves for electrical, electronic and electromechanical parts used in the design and construction of space flight hardware in space missions, as well as essential ground support equipment (GSE).

- **MIL-STD-1547A: Electronic Parts, Materials, and Processes for Space and Launch Vehicles**, issued by the U.S. Department of Defense in November 1998. This standard provides part selection information and derating curves for electronics parts, materials and processes used in the design, development and fabrication of space and launch vehicles.

- **NAVSEA-TE000-AB-GTP-010: Parts Derating Requirements and Application Manual for Navy Electronic Equipment** (Rev. 1 with Change A), issued by the Naval Sea Systems Command in March 1991. This standard provides derating curves for the ten most commonly used electrical and electronic parts.

- **ECSS-Q-30-11-A: Space Product Assurance**, issued by the European Cooperation for Space Standardization in April, 2006. This standard provides derating requirements for electronic, electrical and electromechanical components used for space projects and applications.

Once a derating standard has been applied, you will need to define the derating properties of each component that will be analyzed. The application will then automatically evaluate each component to determine whether it meets the derating requirements provided by the standard you are working with. Any components of types not specified in the derating standard are not considered in the derating analysis.
Applying a Derating Standard

To use derating analysis, select a standard item in the system hierarchy (you can select any except the NSWC standard item or the MIL-217 Parts Count standard item), and then choose Prediction Tools > Derating > Apply Derating.

In the Apply Derating Standard window, use the drop-down list to select the derating standard that you want to apply to all the components under the selected item. This list includes all of the published derating standards that are supported by the software, as well as any custom (user-defined) standards that are saved in the current database.

From this window, you can also create or edit custom derating standards by clicking the Add or Edit icon in the window, as shown next. (See Creating Custom Derating Standards.)

To remove derating, click the standard item in the system hierarchy and choose Prediction Tools > Derating > Remove Derating.

Defining Component Derating Properties

Typically, only components with stress-dependent failure rates can be derated. Each component that can be derated by the standard you are working with displays a Derating tab in the Properties panel. The derating properties are automatically populated by the software with likely values, but these defaults do not represent actual data for the component. You will need information from the manufacturer's specification sheet to define the appropriate value for each property.

When a component has properties that will affect both its failure rate and derating (e.g., ambient temperature, applied voltage, etc.), those properties continue to be displayed/edited on the Properties tab. The Derating tab displays only the additional properties that apply to derating analysis.
Derating Analysis Results
Once you have applied a derating standard and defined the derating properties of each component, Lambda Predict automatically evaluates each component to determine whether it meets the derating requirements provided by the standard you are working with. The results can be displayed in both the System Hierarchy panel and in the Component Derating window.

System Hierarchy Panel
The system hierarchy includes two columns that show derating information. (To hide or display columns, right-click anywhere in the system hierarchy, and then click Customize Columns to select which columns you want to display. These settings are stored per computer/username on the System Hierarchy page of the Application Setup, so any project that you open on this computer will have the same columns displayed.)

- The Derating column displays two types of information, depending on the item. For standard items (i.e., 🏁, 🏁, 🏁, 🏁, or 🏁), it displays the name of the derating standard that is applied to all the components under that item. For components, it shows the derating status (i.e., not stressed, exceeded nominal values or stressed). Note that a component with no derating status indicates that either the derating properties of the component have not yet been updated or the component is not included in the derating standard.

- The Derating Status column may display any of the following icons to indicate the derating status of a component:
  - Not Stressed. A green icon indicates that the component meets the requirements of the derating standard.
  - Exceeds Nominal. A blue icon indicates that the component does not meet the requirements of the derating standard, but it is not overstressed (i.e., is less than the worst case values).
  - Stressed. A red icon indicates that the component is overstressed according to the requirements of the derating standard.

Component Derating Window
In addition to the derating status indicators displayed in the system hierarchy, you can view the derating curves of a component by either double-clicking its derating status icon, or by selecting it and choosing Prediction Tools > Derating > View Component Derating.
Chapter 12: Derating Analysis

The Component Derating window may include the following pages: Derating, Parametric Curve and Other Derating Criteria.

**Derating Page**

The Derating page displays a plot of the component's derating curves provided by the derating standard that you are working with. The nominal case curve is displayed in green and the worst case curve is displayed in red. The blue dot on the plot shows the component's working temperature and stress ratio. The location of the blue dot on the plot indicates the component's derating status:

- If the blue dot is within the nominal curve, the component is not stressed.
- If the blue dot is between the nominal and worst case curves, then the component exceeds nominal values, but is not overstressed.
- If the blue dot is outside the worst case curve, the component is overstressed.

For example, the following plot shows a situation where the component exceeds the nominal values, but is not stressed.
Chapter 12: Derating Analysis

The control panel shows the values used to create the nominal and worst case curves. This information is provided by the derating standard you are working with, based on the type of stress that is chosen in the Stress area in the control panel.

The color of the icon in the Stress area indicates the derating status of the component. It uses the same color indicators that are used in the Derating Status column in the system hierarchy (i.e., green means not stressed, blue means exceeds nominal and red means overstressed).

**Parametric Curve Page**
The Parametric Curve page is available only for MIL-217 and Bellcore/Telcordia components. It allows you to analyze the effects of stress and temperature on the component's failure rate. To use the plot:

1. Use the Stress area on the control panel to select which type of stress ratio to use in the plot. Different components will have different types of stress ratios available.
2. Use the Factor area to specify which factor to hold constant. This can be the temperature, or the stress ratio that was specified in the Stress area.
3. If desired, you can manually define the range of the plot axes by clearing the Automatic Range check box on the control panel and entering values in the Min and Max fields.
4. Finally, use the table to enter the value(s) for the selected factor.

The following example shows a plot for a particular component. In this example, the analyst wishes to evaluate how the failure rate of the component varies over increasing temperatures, based on a particular voltage stress ratio. The Stresses table on the control panel shows the component's actual voltage stress ratio (0.25) and two other voltage stress ratios that the analyst wishes to consider (0.5 and 0.625). This puts three curves on the plot, one for each voltage stress ratio, plotted against temperature (x-axis) and the component's failure rate (y-axis).
Other Derating Criteria
The Other Derating Criteria page provides information on other derating requirements that are not related to the temperature curves. This information is provided by the derating standard you are working with, and will be displayed only for applicable components. The color of the icon next to each criteria indicates whether the component meets that requirement. It uses the same color indicators that are used in the Derating Status column in the system hierarchy (i.e., green means not stressed, blue means exceeds nominal and red means overstressed).

The following example shows the derating requirements of one particular component. In this case, the "Set Up and Hold Time" property of the component exceeds the derating requirement, which is less than or equal to 200 minutes. Therefore, that criteria shows a red icon next to it, indicating that the component is overstressed.
Creating Custom Derating Standards
Lambda Predict includes a utility that allows you to define your own derating requirements or combine models from any of the published standards with your own. These custom standards are stored within the database, and they are available for any project that you open or create in the database.

In a non-secure database, there are two ways you can create/edit custom derating standards:

- You can open the Apply Derating Standard window and create a new standard by clicking the Add button, or edit an existing custom standard by selecting it from the list and clicking the Edit button.

- You can manage all the custom derating standards available in the database by choosing File > Manage Repository > Custom Derating Standards Manager.

In the Custom Derating Standards Manager window, use the Add or Edit buttons to create/edit the custom standards, or use the Delete button to remove the selected standard from the database. **There is no undo for delete.** You can also use the Import or Export buttons to import/export custom derating standards to another database. (See Importing and Exporting Custom Derating Standards.)

In a secure database, the ability to create/edit custom standards is restricted to users with the "Manage Lambda Predict repository settings" permission. All other users that do not have the permission can use, but not modify, any existing custom standard stored in the database.

Creating/Editing the Derating Models in a Custom Standard
When you add or edit a custom derating standard, the Custom Derating Standard window appears. This window allows you to edit the name and description of the custom standard, as well as manage its derating models.

The Models area on the left side of the window displays a tree-like structure with the name of the custom standard in the heading followed by the names of the derating models that have been added to the standard, as shown in the following example.
You can add a new derating model to the standard by clicking the Add Model icon or delete an existing model by clicking the Delete Model icon. The Sort icon allows you to alphabetically sort the model names.

Each custom derating standard can contain user-defined models (where you define the nominal and worst case curves for the component) and/or models that have been defined in any of the published derating standards that are supported by the software (where the nominal and worst case curves are set automatically from the standard and can’t be edited).

**To add a user-defined model to a custom derating standard, follow these steps:**

1. In the **Model Name** field, enter a name for the model, if desired.
2. In the **Derating Model** drop-down list, choose **User-Defined**.
3. Use the **Model Type**, **Category**, **Subtype** and **Style** drop-down lists to specify which component the model applies to. Note that:
   - If the component has any subtypes (e.g., a Bellcore analog IC may be bipolar, CMOS or NMOS), you can select the **Include all subtypes** check box to apply your model to all subtypes of that component.
   - If the component has different styles (e.g., a Bellcore analog IC may have a hermetic or non-hermetic packaging style), you can select the **Include all styles** check box to apply your model to all styles of that component.
4. In the **Stress** drop-down list, choose a stress type, and then use the **Nominal Case** and **Worst Case** tables on the right side of the window to enter the derating requirements for that stress. Repeat the process until you have defined curves for all of the stress types that are applicable for this component.
5. Use the **Description** and **Notes** fields to enter any additional information about the model, if desired.
To add a published model to a custom derating standard:
To add a model from a published derating standard to your custom standard, select any of the
published derating standards in the Derating Model drop-down list, and then use the Model
Type, Category, Subtype and Style drop-down lists to specify which component you wish to
add. The Nominal Case and Worst Case tables on the right side of the window will show the
derating requirements of the component as defined by the selected published standard. These
values are read-only.

Tip: You can also use the Copy and Paste icons in the tables to copy the values, paste the data
into a table for a user-defined model and then modify the values as needed.

Importing and Exporting Custom Derating Standards
When you create a custom derating standard, that standard is automatically saved within the
database. You can then use the import and export features to create copies of the standard
among databases, if desired.

To access the import or export windows, open the Custom Derating Standards Manager
window (File > Manage Repository > Custom Derating Standards Manager), and then click
either the Import icon or the Export icon.

Importing a Custom Derating Standard
In the Import Derating Standard window, you can select to either import from another
database (*.rsr18 or *.rserp) or import a derating standard file from an older version of Lambda
Predict (*.lp3ds).

If you select to import from another database, the next window will display a list of all the
custom derating standards available in that database. Select the standard(s) you wish to import
and then click Next to complete the import process.

In both cases, a copy of each selected derating standard will be imported and saved within the
current database. You can then edit the imported standard by adding new models, as well as
editing or deleting existing models. Any changes you make will apply only to the copy of the
standard saved with the current database. It will not affect the *.lp3ds files or derating
standards saved in other databases.

Exporting a Custom Derating Standard
In the Export Derating Standard window, select a destination database (*.rsr18 or *.rserp) from
the drop-down list or click the Browse icon to browse for the database.
Chapter 12: Derating Analysis

When you click **Next**, the window displays a list of the custom derating standards available in the current database. Select the standard(s) you wish to export and click **Next**. A copy of each selected derating standard will be exported and saved within the destination database.
Chapter 13: Reports

In Lambda Predict, you can create template-based reports that summarize the key results of your analyses. Each reliability prediction standard that is included in your license comes with a basic report template. If desired, you can customize the appearance of the basic report templates, as well as manage and build your own custom report templates. (See Creating and Editing Report Templates.)

Select to Generate or Publish a Report

Reports can be generated in Microsoft Word and/or Excel. If you have an enterprise database that utilizes the Synthesis Enterprise Portal (SEP), you can also publish reports to the SEP, where they can be accessed from any web-enabled device.

Select a standard item (i.e., C, ML, BL, TL, MC, L or SN) or block then:

- To generate a Word or Excel report, choose Prediction Tools > Data Views > Report.

- To publish an Excel report to the SEP, choose Prediction Tools > Share > Publish SEP Summary or click the icon on the Publishing tab of the Properties panel. (Both are visible only to users with the "Publish to Synthesis Enterprise Portal" permission.)

Both commands open the Select Report window. Select whether to create an Excel spreadsheet or Word document. (If publishing to the SEP, only the Excel format will be available.)
Select What to Include in the Report

- **Defined Templates** are report templates that have been saved to the default report template location (C:\Users\[user name]\My Documents\ReliaSoft\Lambda Predict 18\Reports) or recently opened from the current computer.

  To edit or delete an existing template, click the **Edit** or **Delete** icons that appear when you point the cursor to the template.

  To create new or add other existing templates to the list, click the **Add** or **Import** icons at the bottom of the window. (See [Creating and Editing Report Templates](http://predict.reliasoft.com).)

  If desired, use the **Sort Field** and **Sort Type** columns to specify the sort order.

- **Default Reports** are "canned" reports that are built-in to Lambda Predict.

  - The "Calculation Information" report is also available when you choose **Prediction Tools > Data Views > Calculation Information**.

  - The "FIDES Phases" report (available for FIDES standard items only) is also available when you choose **Prediction > FIDES > Item Phases**.

- **Plots** are the same list of stored plots that is visible in the current project explorer.
Click **OK** to create the report. If publishing to the SEP, the report will open in the website's spreadsheet viewer.

**Tip**: If the report does not appear to generate, check for any installed Microsoft Office add-ins that may have interrupted the command. In such cases, the prompt may appear behind other windows. Report generation will show as "In Progress" until you locate the window and provide the input required. Press **ALT + Tab** to browse through all of the windows that are currently open on your computer. For future reports, consider disabling the add-in temporarily before report generation.

---

**Creating and Editing Report Templates**

In addition to the basic report templates that are included with Lambda Predict, you can create, manage and share your own custom report templates.

The report templates are saved as *.lp18r files and are always associated with a particular reliability prediction standard (e.g., a template created for the MIL-217 standard cannot be used to generate a report for a Telcordia analysis). To use the templates to generate or publish a report, see [Lambda Predict Reports](#).

---

**Creating or Editing a Template**

To create a new report template, choose **Home > Templates > Report Templates**.

Alternatively, you can choose to create or edit a template during the report generation/publishing process by clicking the **Add** or **Edit** icon in the Select Report window, as shown next.
This opens the Report Template window, which contains the following commands:

- **New** resets the interface so you can build a new template (*.lp18r). Note that the file is not created until you save the template.

- **Open** opens an existing *.lp18r file or files from previous versions of Lambda Predict (*.lp11r, *.lp10r or *.lp9r) for editing. Note that the file does not get updated until you save the changes.

- **Save** saves the template so it can be used in the future for generating or publishing any other reports. If you are editing a template from a previous version of Lambda Predict (*.lp11r, *.lp10r, *.lp9r), the template will be saved in the *.lp18r format. By default, import templates are saved in the default documents folder for your computer (e.g., My Documents\ReliaSoft\Lambda Predict 18\Reports), but you can choose to save the file to any location you desire.

- **Save As** saves the existing template using a different file name and/or to a different location.
Building the Template

Follow these steps to build or edit the template.

1. Click the **Standard** drop-down list to choose a reliability prediction standard. Your choice will determine which data fields are available to be included in the report. (If editing an existing template, you will not be able to change the selected prediction standard.)

2. Click the **Data Range** drop-down list and choose to include data from **Blocks Only**, **Components Only**, or from both **Blocks and Components**.

3. Build and organize the header and the body of the report by moving the fields of interest from the **Available Fields** area to the **Selected Fields** area. The fields in the header area provide information on the standard item or block for which the report is generated (i.e., the item that was selected when the Select Report window was opened). The fields in the body area provide information on the sub-items of that selected item, as specified in the Data Range drop-down list.

To move a field, you can:

- Double-click the field
- Click and drag the field to the desired location
- Select it and then click the arrow buttons

To select multiple fields at once, hold the **CTRL** key while clicking all the fields you wish to move. To select multiple items that are adjacent, click the first field and then hold the **SHIFT** key while you click the last field. This will select all the fields between the first and last.

4. Customize the field headings, cell colors, header and/or footer as desired (see **Formatting the Template**). At any time, you can click the **Preview** tab to see how the report will look when it is generated.

5. (Optional) To add bar charts or pie charts to the report, click the **Plot** icon at the bottom of the control panel.

6. Click **Save** or **Save As**. The template file will be stored in the location you specify and will be accessible each time you generate a new report from this computer.
Formatting the Template

The following picture shows the parts of the report that can be customized:

Field Headings

In the Body tab, select a field from the **Selected Fields** area. The selected field will appear in the **Field Headings** area of the control panel.

From here, you can:

- Change the font style of the selected field by clicking the **Set Font** icon in the **Field Heading** area.
- Rename the selected field by typing over its name as it appears in the **Field Heading** area. The field’s new name will be displayed in the generated report.
- Adjust the column width of the selected field by choosing one of the options in the **Field Width and Font** drop-down list. For example, if you choose the **Fit Heading/Data**
option, the column width in the generated report will be adjusted automatically to have the same width as the heading or data, whichever is wider.

- Change the font style of the data that will appear under the selected field by clicking the Set Font icon in the Field Width and Font area.

**Tip:** To select multiple fields and apply the same formatting all at once, hold down the CTRL key while clicking each field of interest, and then click the Set Font icons or the Field Width and Font drop-down list.

### Cell Colors
Click the Body tab, then on the control panel, use the Colors area to select the desired colors for the cells. You can change the colors for all field headings, data cells and border lines.

![Colors](image)

### Header
To add text and/or graphics that will be displayed at the top of the report in printouts, click the Header tab or click the icon on the control panel.

Similar to building the body of the report, add the data fields that you want to appear in the header by moving the fields of interest from the Available Fields area to the Selected Fields area.

Additional options are available on the control panel of the Header tab:

- **Report Title** allows you to rename the report title and/or change the font.

- **Header Options** sets the text alignment, font and background color of the header. You can specify whether to include the date/time the report was generated and whether to display the header on top of every page of the report.

- **Image** allows you to add images, such as company logos, to the report. To use the Lambda Predict logo, click the Default button.

### Footer
To add a footer that will be displayed at the bottom of the report in printouts, click the Footer icon on the control panel.
Chapter 13: Reports

Enter the text you wish to display in the footer region of the report. To display page numbers in the report, select the \textbf{Include page numbers} check box.
Chapter 14: Import Bill of Materials

Lambda Predict includes an Import BOM Wizard, which helps you import system configuration data from an external "bill of materials" data file (BOM). Your BOM may be in a Microsoft Excel worksheet or a delimited text file.

Preparing to Import

Before you start the import process, you must first create an import template and, if needed, a category map:

- An import template matches the parts data in your BOM file to the properties defined in the prediction standard you are working with, so that your data are imported into the correct fields. (See BOM Import Templates.)

- A category map matches the component categories used in your BOM file to the categories used in the prediction standard. For example, if the "Diode, High Frequency" component in the MIL-217 standard is referred to in your BOM file as "HF Diode," then you will need to tell Lambda Predict that these two categories are one and the same; otherwise, the component will be imported as an external component (i.e., a component that is not covered by the prediction standard and is therefore defined only by its failure rate). (See Customize Categories.)

Using the Import BOM Wizard

Once you have created the required import template and category map, follow these four steps:

1. Examine your BOM file:
   - For Excel files, note the name of the Excel worksheet that contains the data and the row number where the actual data starts. The first row of a worksheet typically contains the column names and the subsequent rows contain the actual data.
   - For delimited text files, note the delimiter character used to separate the fields (this may be a comma, tab, space, semicolon or carat) and the line number where the actual data starts. The first line typically contains the field names and the subsequent lines contain the actual data.

2. Access the Import BOM Wizard. There are two ways:
   - To import components upon creating a new prediction folio (Insert > Project Item > Prediction Folio), select the Import bill of materials (BOM) option in the
Chapter 14: Import Bill of Materials

setup window. Choose the prediction standard you wish to use and click OK. The Import BOM Wizard will appear automatically.

- To import components into an existing system hierarchy, click the standard item (i.e., ML, BL, TL, MK, L, SN or G) or block (F or B) you would like the components to be inserted under, and then choose System Hierarchy > Add Item > Import BOM.

3. In the Import BOM Wizard, enter the following information:

   - In the Import Template field, choose the import template you've created for the BOM file or browse for it. If you haven't already created a template, click the Add (+) icon to create a new one.

   ![Create a new template](http://predict.reliasoft.com)

   - In the File Type field, specify whether your BOM file is an Excel file or a text file.

   - In the Source File field, click Browse to search for your BOM file.

     - For Excel files, use the information from Step 1 to populate the Worksheet and Starting Row fields.

     - For text files, use the information from Step 1 to populate the Delimiter and Starting Row fields.

   - In the Import Options area:

     - If you select the Import as new option, all the data contained in the BOM file will be imported into the prediction folio.

     - If you select the Update existing and append new option, Lambda Predict will compare the part number, category and hierarchy level of each component in the BOM file to the components that already exist in the prediction folio. If there is a match, the application will automatically replace the properties of the component in the prediction folio with the properties found in the BOM file. If the component in the BOM file does not have a match, it will be imported as a new component. When you preview the resulting system hierarchy (in Step 4), the matching components will be highlighted in yellow while new components will be highlighted in green.
Optional settings:

- If you select the **Log import results** check box, a record of the import will be appended to the import_wizard.log file that resides in the default documents folder for your computer (e.g., My Documents\ReliaSoft\Lambda Predict18\ImportTemplates).

- If you select the **Part Number Lookup** check box, Lambda Predict will compare each part number in the BOM file against the components in the data sources that you specify. If there is a match, the application will check for component properties that have no values. If the BOM file does not have a value for a particular property, the software will copy the value defined in the first data source that has the information. The copied value won’t appear in the preview (described in Step 4), but will be applied after the data are imported.

The allowed data sources, in order of priority, are **selected libraries**, the current project, and/or [PartLibraries.org](http://PartLibraries.org).

If you choose to match components against selected libraries, you can use the **Add** and **Remove** buttons on the right to specify which library file(s) to use. The software will check the libraries sequentially, based on the order the libraries were added. The software copies the missing value only from the first library that provides the information. When matching against libraries, the supplier is also considered; if a component’s supplier is specified in the BOM file (i.e., is non-blank) and does not match the supplier specified in the library, the component is not considered a match.

If you choose to match against the current project, the software copies the missing value from the first matching component that contains the information.

4. Click **Next** to preview the data that will be imported. Verify that the columns headings and data displayed in the window match the setup in your BOM file. Click **Next** again to preview the resulting system hierarchy. If you find errors, click **Back** to edit your choices and/or the BOM import template as necessary before attempting the import again; otherwise, click **Finish** to immediately import the data.
BOM Import Templates

BOM import templates are used for importing "bill of materials" (BOM) files into Lambda Predict. They allow you to match the parts data in your BOM files to the properties defined in the prediction standard you are working with, so that your data are imported into the correct fields. Each template is associated with a particular standard. If all your BOM files use the same consistent format, you will need to create only one import template per prediction standard.

Creating an Import Template

To create an import template, choose Home > Templates > Import Template.

Alternatively, you can choose to create the template during the import process by clicking the Add icon in the Import BOM window, as shown next.
This opens the Import Templates window, which allows you to start building the template. There are two ways to do this: If your BOM data are in an Excel file, you can use the automatic mapping method to easily map all fields in your file. If you want to map only a few selected fields from the Excel file, or your data are in a delimited text file, then you may prefer to use the manual mapping method.

During this process, it is important be aware of the kinds of fields you are importing to. When you are importing to a field that uses a drop-down list, the field in the BOM must be formatted as text, and the text must match an option in the list exactly to be imported properly. For example, consider a drop-down list field with options of 0.80, 0.90, 1.00 and 1.10, where 1.00 is the default option for the field. If the BOM contains 0.8, Lambda Predict will not use the 0.80 option; instead, it will select the default option of 1.00. It is strongly recommended to always log your import results (using the Log import results check box in the Import BOM Wizard), and to check the log to ensure that all fields were imported as intended.

Tools
The Import Template window contains the following commands:

- **New** resets the interface so you can build a new import template (*.lp18im). Note that the file is not created until you save the template.

- **Open** opens an existing *.lp18im file or files from previous versions of Lambda Predict (e.g., *.lp11im, *.lp10im, *.lp9im) for editing. Note that the file does not get updated until you save the changes.

- **Save** saves the template so it can be used in the future for importing any other BOM files. If you are editing a template from a previous version of Lambda Predict, the template will be saved in the *.lp18im format. By default, import templates are saved in the default documents folder for your computer (e.g., My Documents\ReliaSoft\Lambda Predict 18\ImportTemplates), but you can choose to save the file to any location you desire.

- **Save As** saves the existing template using a different file name and/or to a different location.

- **Add Ignore Column** adds the [Ignore Column] field to the template, allowing you to indicate which field(s) in the BOM file should be excluded from the import process. See Manual Mapping for Excel or Text Files.

- **Automated Mapping** applies to Excel files only. It automatically builds a template based on the column headings of an Excel file. See Automatic Mapping for Excel Files.
Standard allow you to choose which prediction standard to associate with the template. (Note that only the prediction standards that are included in your Lambda Predict license will be available.) The Available Fields area will display the properties used in the chosen standard. If you have accessed the Import Template window by clicking the Add icon in the Import BOM window, the prediction standard you are currently working with will be selected automatically.

Automatic Mapping for Excel Files

If your "bill of materials" (BOM) files are in Excel format, you can use the automatic mapping method to easily build a template based on the column headings.

In the following example, you can follow along by using a copy of your own BOM file or by using the sample file that is shipped with the software.

Sample BOM files are available in the example database installed with the software (called "Lambda_Predict18_Examples.rsgz18"). To access this database, choose File > Help, click Open Examples Folder, then browse for the file in the Lambda Predict sub-folder.

The name of the project is "Import Bill of Materials." Note that the examples were designed for the MIL-217 prediction standard. If that standard is not included in your software license you can use any other standard available to you, but keep in mind that only the first eight data fields in the file can be mapped correctly. The rest of the fields may not have appropriate matches in the standard you are working with.

Creating an Import template via Automatic Mapping

1. Examine your BOM file and take note of the name of the Excel worksheet that contains the data and the row number where the column header names are stored.

2. Create an import template by choosing Home > Templates > Import Templates. In the Import Templates window, use the Standard drop-down list to specify which prediction standard you want to associate with the template. The Available Fields area will display the properties used in the selected standard. (If you are creating a template from within the Import BOM Wizard, the standard type will already be selected.)

3. Click the Automatic Mapping icon. In the Automatic Mapping window, click the Browse button to search for the BOM file, and then use the information from Step 1 to populate the Worksheet and Column Header Row fields. If you are working with the example BOM file, choose Sheet1 and then enter 1 for the column header row, as shown in the following example. Click OK.
4. Lambda Predict will attempt to match the column header names found in the Excel file to the fields used in the selected prediction standard. The results will be displayed in the **Selected Fields** area. Any column header names that do not have a match will be displayed in red text with an Info icon next to it.

For example, the following picture shows a template where the column name “location control number” is not recognized. To fix this, click and drag the corresponding field name from the **Available Fields** area (in this case, "LCN") and drop it on top of the unrecognized column name to create a match; otherwise, the data in the "location control number" column will be excluded from the import process.

5. Click **Save** or **Save As** to save your template so you can use it to import any BOM file that has the same structure.
Manual Mapping for Excel or Text Files

If your "bill of materials" (BOM) files are in Excel or delimited-text format and you want to import only a few fields from the file, you may prefer to use the manual mapping method for creating a BOM import template.

In the following example, you can follow along by using a copy of your own BOM file or by using the sample files that are shipped with the software.

Sample BOM files are available in the example database installed with the software (called "Lambda_Predict18_Examples.rsgz18"). To access this database, choose File > Help, click Open Examples Folder, then browse for the file in the Lambda Predict sub-folder.

The name of the project is "Import Bill of Materials." Note that the examples were designed for the MIL-217 prediction standard. If that standard is not included in your software license you can use any other standard available to you, but keep in mind that only the first eight data fields in the file can be mapped correctly. The rest of the fields may not have appropriate matches in the standard you are working with.

Creating an Import Template via Manual Mapping

1. Examine your BOM file and note the order of the columns (Excel file) or the sequence of the fields (delimited text file). You can leave the BOM file open for easy reference.

2. Create an import templates by choosing Home > Templates > Import Templates. In the Import Template window, use the Standard drop-down list to specify which prediction standard you want to associate with the template. The Available Fields area will display the properties used in the selected standard. (If you are creating a template from within the Import BOM Wizard, the standard type will already be selected.)

3. Associate each field in the BOM file with a corresponding field in the prediction standard, or specify that the field should be ignored. For example, the following picture shows a template where the fields in the Selected Fields area are arranged in the same order as the column headers in the sample BOM Excel file. It also shows that the data in the 4th column of the BOM file will be excluded from the import process.
To build this template, select a field in the Available Fields area, and then click the arrow buttons to add it to the Selected Fields area. You can also double-click or drag a field to add it.

To exclude a field from the import process, insert the [Ignore Column] property by clicking the Add Ignore Column icon. You can then drag the [Ignore Column] field to the desired order, or use the arrows to move it up or down one position.

Note that the field names in the BOM file do not have to match the names of their corresponding fields in the prediction standard. The important thing is to make sure that the order of the fields shown in the Selected Fields area matches the order of the fields in the BOM file.

4. Once you have mapped all the fields in the BOM file, click Save or Save As to save your template so you can use it to import any BOM file that has the same structure.

Preparing Delimited Text Files for Import

BOM data saved in a delimited text file can have a wide variety of formats and may contain irrelevant information such as page numbers, header lines, etc. You may need to edit or organize your data prior to import to Lambda Predict.
Preparing the Data

One way to prepare your data for import is to convert the delimited text file into an Excel file. Once you have organized your data in Excel, you can then use the automatic mapping method to build the import template, or use the manual mapping method if you plan to import a few fields only.

Alternatively, you may prefer to edit the text file itself and import directly from it. Here are some general guidelines for preparing the file:

- The data must be a sequence of fields, where each field is separated by a delimiter character. You can use a comma, tab, space, semicolon or carat as the delimiter. If you're using commas as the field separator, for example, and one of the field names contains an actual comma, you can use double quotes to prevent the comma in the field from being interpreted as a field separator (e.g., "Diode,Low Frequency").

- Enter only one component record per line and remove any empty lines.

- Each line of data must have the same sequence of fields.

Once you have organized your data in the text file, you can then build an import template using the manual mapping method. Make sure that the order of the properties shown in the Selected Fields area matches the sequence of the fields in the text file.

Sample BOM files are available in the example database installed with the software (called "Lambda_Predict18_Examples.rsgz18"). To access this database, choose File > Help, click Open Examples Folder, then browse for the file in the Lambda Predict sub-folder.

The name of the project is "Import Bill of Materials." Note that the examples were designed for the MIL-217 prediction standard. If that standard is not included in your software license you can use any other standard available to you, but keep in mind that only the first eight data fields in the file can be mapped correctly. The rest of the fields may not have appropriate matches in the standard you are working with.

Customize Categories

The Customize Categories window is used for importing "bill of materials" (BOM) files to Lambda Predict. It allows you to match the component categories used in your BOM file to the categories used in the selected prediction standard. For example, if the "Diode, High Frequency" component in the MIL-217 standard is referred to in your BOM file as "HF Diode," then you will need to tell Lambda Predict that these two categories are one and the same; otherwise, the component will be imported as an external component (i.e., a component that is not covered by the prediction standard and is therefore defined only by its failure rate).
To create a category map, click the **Customize Categories** button at the bottom of the Import BOM window (**System Hierarchy > Add Item > Import BOM**).

In the Customize Categories window, use the **Custom Category Name** column to type the category name used in the BOM file. Use the **Standard** column to choose the prediction standard that the mapping applies to, and then use the **Standard Category Name** column to choose the equivalent category. The following picture shows an example of a partial category map.

![Customize Categories window](image)

You can use the **Add**, **Delete**, and **Reset** buttons below the table to manage the category map.

The category map is stored with the database, so any project that you open or create in the database will use the same map whenever you import a BOM file. You can use the import and export commands if you wish to create copies of the category map among databases.

- Click the **Import** button to import an existing category map from another database and append the information to the current map. You can also directly import a category map from previous versions of Lambda Predict.
- Click the **Export** button to export a copy of the category map for use in another database.

**Tip:** For your reference, an Excel file that contains a list of all the component category names used in each prediction standard supported by Lambda Predict is saved in the default documents folder for your computer (e.g., My Documents\ReliaSoft\Lambda Predict 18\Libraries). The file name is "Categories.xlsx."
Chapter 15: Import Predefined Components

Lambda Predict provides easy-to-use utilities that allow you to search for existing component data and import them into your analysis. You can import component data from an existing analysis (whether from the current prediction folio, current database or in another database) or from custom library files.

Custom library files are database files that are saved on your computer or network. You can create custom library files to build lists of components that you frequently use in your analyses. They can be a great way to share knowledge, ensure consistency and save time on data entry.

If you have an active Internet connection, Lambda Predict also offers access to the PartLibraries.org database, which is a web-based library of commercial parts with properties that have been predefined by the manufacturer or supplier. You can search by category, part number, supplier, part name and/or part description, and then import the records that you need.

Importing Local Components

The Import Local Components window allows you to import components that have already been defined in an existing analysis (the current prediction folio, current database or another database) or from a custom library file (*.lplib18).

There are two ways to import existing component data into the system hierarchy:

- When you add an item to the system hierarchy, you are given the option to import local components (e.g., System Hierarchy > Add Next Level Item > Import Local Components, etc.)

- You can import components into a block (i.e., or ) or standard item (i.e., , , , , , or ) at any time by selecting the block/standard item and choosing System Hierarchy > Local Components > Import Local Components.
Chapter 15: Import Predefined Components

In the Import Local Components window, use the search function to look for and select the component(s) you wish to import. You can follow these steps to use the search function:

1. In the **Where do you want to search?** area, select the source for the component(s) you wish to import:
   - The **Current folio**.
   - The **Current Database**. This includes components from all the projects in the database you are currently working in.
   - From **Another Database**. You must have access to that database to import its data.
   - From a custom **Library** file.

   If you select the **Other Database** or **Library** options, an address bar with a Browse button will be displayed. Click **Browse** to browse for the desired database or library file. Once you have made a selection, the file name will be displayed in the address bar.

2. Specify the search criteria. (Note that you can also view all the components stored in the selected source by leaving the search criteria blank and clicking the **Search** button. A maximum of 1,000 results will be returned at any given search.) You can limit the search by up to three item properties. These include:
   - Name
   - Part Number
   - Supplier
   - Description
   - Category
   - Alternate Part Number
   - LCN (Location Control Number)

   Select the property from the drop-down list and then type the text to search for. The search is not case sensitive. To search by more than one criterion, select the appropriate Boolean operator (AND, OR) from the drop-down list next to the field and then specify the next property type and search term, as shown in the following example. Note that you can search by more than one property type and/or by more than one search term in the same property type.
The Boolean Operator **AND** searches for the items that match both the first and second requirements. For example, in the first criteria box, if you select Name and enter "Capacitor," and in the second criteria box, you select Part Number and enter "CB-1-15," then the search will return only those components with "Capacitor" anywhere within the Name field and "CB-1-5" anywhere within the Part Number field.

The Boolean Operator **OR** searches for the items that match either the first or second requirement. Using the same example for "Capacitor" and "CB-1-5", the search will return only those components with "Capacitor" anywhere in the Name field, "CB-1-5" anywhere in the Part Number field, or both.

Note that only the components in the prediction standard you are working with will be considered in the search (e.g., if you are currently working with a MIL-217 prediction, only components from the MIL-217 standard will appear in the search results). You can sort the results by any column by clicking the column heading. Clicking again will reverse the direction of the sort.

3. In the table of results, select the check box of the component(s) you want to add to the system hierarchy, and then click **Add** to import the component into the current prediction folio.

**Using Custom Library Files**

Custom library database files provide a flexible way for you to store and easily access the properties for components that you frequently use in your reliability predictions. The following
Chapter 15: Import Predefined Components

information describes how to add or replace components in an existing library file and how you can use the stored library data while working on a particular analysis. For information about how to create, manage or delete data from your own custom library files, see Managing Custom Library Files.

Adding Components to a Library File

The application uses the prediction standard, component type, name and part number to match items between libraries and prediction folios. Therefore, the Name and Part Number properties must be defined if you wish to add a component to a library.

To add a component to your custom library (or if your user account has the necessary permission to add components to another user's custom library), select the component and choose System Hierarchy > Local Components > Add to Library.

In the Add to Library window, click the Browse button to browse for the library file, and then select which property categories you wish to include (either the physical and general properties only, or all properties). Click OK to add the component to that library.

Note that if the library file already contains a component that has the same part number as the component you are trying to add, a confirmation message will ask whether you want to replace the existing component with the current selection.

New in Version 2018, you can select a block or a standard to add to a library file. This is a shortcut that adds all valid components (i.e., those that have names and part numbers defined) at all levels below the selected block or standard to the library. The block or standard itself will not appear in the library. This functionality is available only if the block or standard has valid components below it.

Note: It is strongly suggested that you save your component data to your own custom libraries, rather than making additions to the libraries that are installed with Lambda Predict. Personal data entered in the installed libraries will be lost if the software is reinstalled or if the libraries are updated in subsequent releases.

Importing Components from a Library File

You can use the Import Local Components window to find and import components from a selected library file. When you want to use this utility to import from a custom library, do the following:

1. Select a block (i.e., or ) or standard item (i.e., , , , , , , , or ), and then choose System Hierarchy > Local Components > Import Local Components.
2. In the Import Local Components window, select the **Library** option and browse for the *.lplib18 file that contains the data.

Where do you want to search?

- Current Folio
- Current Database
- Other Database
- Library

C:\Users\username\Documents\ReliaSoft\Lambda Predict 18\Libraries\CustomLibrary.lplib18

3. Search for and select the desired components, and then click **Add** to import the data into the current prediction folio. Note that only the components in the prediction standard you are working with will be considered in the search (e.g., if you are currently working with a MIL-217 prediction, only components from the MIL-217 standard will appear in the search results).

**Updating the Properties of Existing Components**

You can also update the properties for components that already exist in a prediction folio by matching the name, type and part number against the components that have been predefined in a selected library. Note that updating the properties will overwrite any existing data in those properties and **cannot be undone**.

To update the properties of all the sub-items under a block (i.e., ☐ or ☐) or standard item (i.e., ☐, ☐, ☐, ☐, ☐ or ☐), select the block/standard item and choose **System Hierarchy > Local Components > Update Branch**.

To update the properties of a component, select the component and choose **System Hierarchy > Local Components > Update Item**.

In both cases, you will be asked to browse for the library file from which to import the properties and to choose whether to update just the physical and general properties, or all properties.

**Managing Custom Library Files**

The following information describes how to create, manage, edit or delete data from your own custom library files. For information on how to add components to a library and how to use the stored library data while working on a particular analysis, see **Using Custom Library Files**.
Chapter 15: Import Predefined Components

Note: Lambda Predict comes with two installed library files for your reference: PartsCount.lplib18, which is used for MIL-217 parts count predictions (see Using the Parts Count Method); and Library.lplib18, which contains component data that are available from your free access to PartLibraries.org (see Importing from PartLibraries.org). These two files are saved in the default documents folder for your computer (e.g., My Documents\ReliaSoft\Lambda Predict 18\Libraries).

Creating a New Library File
To open the Manage Library window, choose System Hierarchy > Local Components > Manage Library.

In the Manage Library window, the address bar at the top of the window shows the location and name of the last library file that was accessed. You can use the icons in the field to browse for a different file or create a new library file (*.lplib18), as shown in the following picture. You can also open a file from a previous version of Lambda Predict (*.lplib).

By default, new library files are saved in the default documents folder for your computer (e.g., My Documents\ReliaSoft\Lambda Predict 18\Libraries), but you can choose to save the file to any location you desire.

Viewing/Managing Security Settings for a Library File
The functions that you can perform in a library file depend on whether security has been enabled. If you created the library file, your account will be identified as that file's Admin account and you can enable or disable the security setting of the file at any time by clicking the Enable Security or Disable Security button at the bottom of the window. Note that:

- If you do not enable security, any database user can add/edit/delete/import component data from your file, so long as the file is saved in a location that they have read/write access to.

- If you enable security, you can specify which user accounts can add/edit/delete component data from your library file. You can also give the role of Admin to other users. All other user accounts that do not have permissions for the file can still import component data from it so long as the file is saved in a location that they have read/write access to, but they will not be able to modify the contents of the file.
When you enable security, the **User** tab, which shows the list of authorized users for the library file, will be available, as shown in the following example.

![User tab example](image)

You can use the **Add**, **Edit** and **Delete** buttons below the table to manage the user accounts. If your organization uses Microsoft Active Directory, you can also click the **Active Directory** button to import user accounts.

**Note:** Library files can be used with any Lambda Predict database. This means that as long as the files are saved in a location that a user has access to, that user can import data (or modify the file if he has the permissions) from any database that he has access to. In addition, the library file security permissions are not related to the security permissions that might be set up in the database that you are working in. For instance, if you add a user account for a library file, that account has permissions for that library file only; it does not mean that the account gains access to the folio, project or database you are working in. (See [Security Options](#) for more information about database-level security.)

**Viewing/Editing the Properties of Existing Components**

To view or edit the properties of a component that already exists in a library file, click the **Component** tab in the Manage Library window. Use the **Component Type** and/or **Part Number** search criteria to find the component you wish to edit, and then click the **Search** button, as shown in the following example.
In the search results, select the component of interest and click the Properties button at the bottom of the window. The component’s property fields will be displayed in the Properties tab. You can then edit any of the properties shown in the Properties tab, except for Part Number and Supplier, which are used to identify the component.

Deleting Components from a Library File

To delete a component from your custom library (or if your user account has the necessary permission to delete components from another user's custom library), use the Component tab to search for and select the component you wish to delete. In the search results, select the component of interest and then click the Delete button. There is no undo for deleting a component.

Importing from PartLibraries.org

PartLibraries.org is a web-based portal that contains an extensive library of component data for use in standards based reliability predictions and other reliability analyses. There are two types of access to this online library:

- All Lambda Predict users receive free access to the integrated circuit (IC) component definitions published in MIL-M-38510, the electronic component failure rates published in EPRD-97 (Electronic Parts Reliability Data) and the mechanical, electrical and electromechanical component failure rates published in NPRD-95 (Nonelectronic Parts Reliability Data).

- The paid subscription service gives you unlimited access to the full parts data repository that includes more than 300,000 commercial components with reliability prediction parameters predefined based on published manufacturer specification sheets. For more information about this service, please visit http://predict.reliasoft.com
Chapter 15: Import Predefined Components

http://www.reliasoft.com/predict/part_libraries.htm or contact ReliaSoft. (To view the contact information from Lambda Predict, choose File > Help, and then select the Contact ReliaSoft USA link.)

The paid subscription is recommended only for users of MIL-217 or Bellcore/Telcordia. The part records that are applicable for NSWC, FIDES and Siemens analyses are available to all Lambda Predict users without subscription.

Tip: Lambda Predict needs an active Internet connection to access the PartLibraries.org database. If your computer uses a proxy server to connect to the Internet, you can configure those settings on the PartLibraries.org page of the Application Setup.

If you do not have Internet access, you can import parts data from the Library.lplib18 database file, which is a library file that is installed with Lambda Predict and saved in the default documents folder for your computer (e.g., My Documents\ReliaSoft\Lambda Predict 18\Libraries). This file contains a copy of the component data that are available from your free access to PartLibraries.org. (See Importing Local Components for instructions on how to import data from a library file.)

Importing Components

There are two ways to import components from PartLibraries.org:

- You can import components into a block (i.e., 🌋 or 🏪) or standard item (i.e., ⚔️, 🏻, 🎧, ⚡️, 🍽️, 🍐 or 🍊) by right-clicking the block/standard item and choosing [Add Next Level Item/Add Same Level Item] > Import from PartLibraries.org on the shortcut menu.

- You can also import components at any time by choosing System Hierarchy > PartLibraries.org > Import from PartLibraries.org.

In the window, use the search function to find the component(s) you wish to import. The following picture shows an example of a search.
You can use any or all of the following criteria to narrow your search results:

- **The Part Number and/or Part Name fields** allow you to narrow your search to a specific component. Click the drop-down arrow in the field to select whether you want to search for an exact match (indicated by = in the field) or a partial match (indicated by % in the field).

- **Supplier** allows you to choose a specific supplier from the drop-down list, which is populated based on the options available at PartLibraries.org.

- **Description** allows you to enter text to search in the Description fields of the components at PartLibraries.org. This search is always for partial matches.

- **Generic Category** allows you to choose a generic category that is not specific to any prediction standard. It displays the main categories and their subcategories in a tree view. If you choose a main category, all of its subcategories are included in the search.

- **Category** allows you to choose a component category that is based on the prediction standard you are working with. If you have used the Generic Category field, the Category field will be limited to showing only those choices that are available within the selected generic category.

- **Subscription** allows you to limit your search to those libraries that a) offer free access, b) require a paid subscription, or c) results from all libraries on PartLibraries.org.

- **Max Results** allows you to specify the maximum number of results returned for your search.

In the table of results, select the check box in the Include column for each component that you want to add to the system hierarchy, and then click **Add** to add the selected components.
The **Update Search Parameters** button at the bottom of the table allows you to refresh the available search terms in the **Supplier**, **Generic Category** and **Category** drop-down lists. This will ensure that any new search terms added to PartLibraries.org since you last ran a search will be available for your use.

### Updating the General and Physical Properties of Existing Components

You can also update the general and physical properties for components that already exist in a prediction folio by matching the name, type and part number against the components that have been predefined in PartLibraries.org. Note that updating the properties will overwrite any existing data in those properties and **cannot be undone**.

To update the properties of all the sub-items under a block (i.e., ![block_icon] or ![block_icon]) or standard item (i.e., ![item_icon] or ![item_icon]), ![item_icon] or ![item_icon]), select the block/standard item and choose **System Hierarchy > PartLibraries.org > Update Branch**.

To update the properties of a single component, select the component and choose **System Hierarchy > PartLibraries.org > Update Item**.
Chapter 16: Lambda Predict Settings

The Application Setup contains personal preferences that are stored per computer/username. These include default settings for new analyses/plots that you create from this computer, as well as personal preferences that don’t affect shared analysis data stored in the database.

In addition, note that the region and language settings will determine how dates, times, decimals, currency, etc. are displayed on your computer.

To open the Application Setup window, choose File > Application Setup.

The settings on the pages listed under Synthesis Settings are the same for all ReliaSoft desktop applications; the pages listed under the application name contain settings that apply only to the current applications.

Synthesis Settings

The Synthesis Settings page of the Application Setup can be changed from within any ReliaSoft desktop application.

- **Interface** sets the language and the skin (color scheme) for the software interface. Selecting a skin shows you a preview of the changes in the Application Setup window. The change takes effect in the rest of the interface the next time you launch each application.

  Note that a language change will not affect applications that are currently available only in English.

- **Open With** sets the ReliaSoft application to launch by default when you double-click an *.rsr18, *.rsf18 or *.rserp file from this computer. If you want to be prompted to choose an application each time, select Show the ReliaSoft Launcher.

- **Recent Repositories List** sets the maximum number of recently saved database files to be displayed in the "Recent Repositories" list in the Backstage view.

- **Auto Save** specifies when folios and diagrams will be saved automatically. The application always saves folios/diagrams upon calculate or close. If you want to also save periodically while you're editing, specify an interval. This can be useful if you're...
Chapter 16: Lambda Predict Settings

working across a network in an enterprise database. (This setting does not apply to Synthesis files.)

• **Other**

  • **Allow multiple projects (project explorer)** applies to ReliaSoft desktop applications that use the current project explorer (i.e., Weibull++, ALTA, BlockSim, RENO, RGA, and Lambda Predict). Select the check box if you want to have multiple projects open at the same time. There is a separate setting for project windows in Xfmea/RCM++/RBI. (See Working with Multiple Projects.)

  • **Show project name in opened folios** applies to ReliaSoft desktop applications that use the current project explorer (i.e., Weibull++, ALTA, BlockSim, RENO, RGA, and Lambda Predict). It shows the project name in [brackets] on the tab or window caption. This may be useful when you have multiple projects open at the same time.

  • **Use web-based help.** Select the check box to always make F1 and other help commands open the most up-to-date help file from the Internet when possible. If you clear this check box, they open the local help file that was installed with the software.

  • **Highlight 'Active' category in ribbon** applies a highlight color to the label that shows which tabs are currently active.

  • **Use non-modal Resource Manager** locks the Resource Manager in a top window position so it can remain open while you have access to the project. If not selected, you must close the Resource Manager to return to the project.

  • **Warn when changing metric associations** shows a warning when you select an existing metric in a situation that will change the metric's associated model. (See Showing Metrics in Folios/Diagrams.)

  • **Hide unused project folders** applies to ReliaSoft desktop applications that use the current project explorer (i.e., Weibull++, ALTA, BlockSim, RENO, RGA, and Lambda Predict). It hides from view all folders that do not contain any project items.

  • **Highlight colors** sets the colors used to color-code values in the following analyses:
    - Results in the FMRA in BlockSim and Xfmea/RCM++/RBI
    - Certain BlockSim plots
    - BlockSim FRED reports
    - BlockSim allocation analysis
• Spread of failure rate contributions in a prediction folio in Lambda Predict.

Backup/Check Out Options
The Backup/Check Out Options page of the Application Setup can be changed from within any ReliaSoft desktop application.

• Standard Repository Maintenance applies to standard database files (*.rsr18) only. It allows you to automatically save a backup of a database in the location you specify when you close the application. The backup file will be named after the database file with the backup date appended (e.g., RSRepository1_2018-01-15.rsr18).

You can specify how many days of backups can be automatically saved (up to 10), but note that only one backup will be saved per day (e.g., if you open and close the same database three times in one day, only the final closing of the database will be saved in the backup folder).

Note that you can also create backups manually at any time by choosing File > Save As. For more tips on keeping databases running smoothly, see Backups and Database Maintenance: Protecting Your Data.

• Check In/Out specifies the default save location for projects that you check out from a database.

Other Synthesis Settings
The Synthesis Settings > Other page of the Application Setup can be changed from within any ReliaSoft desktop application.

• Model, Variable and Workbook Names disallows spaces and special characters in the names of models (including those published from any ReliaSoft desktop application) and variables, and in the names of workbooks created in BlockSim/RENO. This will ensure that all models, variables and workbooks can be used in RENO equations.

• Display Object IDs. Select the check box to always display the unique object identifier (object ID) of each project and resource in the repository. The project IDs will be displayed in the Manage Projects window and in the Edit Project Properties window, while the resource IDs will be displayed in the Resource Manager.

• Copy Plot Graphic sets the default file type to use when copying a plot to the Clipboard as an image. If you will be pasting copied plots into Synthesis Workbooks, choose Metafile for Synthesis use. If you will be pasting them into external applications, choose Bitmap or Metafile for external use.
Chapter 16: Lambda Predict Settings

- This default setting is used when you copy a plot using Home > Copy or CTRL+C. If you want to choose the graphic on the spot, you can do so by right-clicking the plot and choosing the Copy Plot Graphic command on the shortcut menu.

- **Hierarchical Trees** sets the maximum number of lines for displaying names and descriptions in any of the hierarchical tree interfaces used in Xfmea, RCM++, RBI, Lambda Predict and MPC.

- **Alternative Credentials** applies to secure databases. It allows you to either save your alternative credentials (so your account is automatically logged in whenever you open a secure database from a different domain) or clear the credentials from this computer.

- **Diagram Skins Utility** converts diagram skins created in Version 9 to the latest version. Click the Convert link, and in the window that opens, select the name of the skin(s) that you wish to convert. You will need to close and re-launch the application to use the converted skin(s). (See "Converting Version 9 Skins" in the BlockSim, Weibull++/ALTA or Xfmea/RCM++/RBI documentation.)

**Application-Specific Settings**

**System Hierarchy Settings**

The System Hierarchy page of Lambda Predict’s Application Setup contains default settings that will be applied to the system hierarchy when you create a new prediction folio.

The table contains the same options that are also available when you right-click inside any column heading in the hierarchy and choose Customize Columns.

- To choose which columns to display, use the check boxes.
- To change the column order, use the arrow buttons to move the selected field up or down in the list. You can also drag/drop a field into the desired position.
- To restore the default settings for all hierarchies in the current application, click the Reset Application Form Settings or Reset All Settings buttons on the Reset Settings page of the Application Setup.

**Tip:** If you want to restore only the settings for one particular hierarchy without resetting any other application form settings, you can delete the specific file from C:\Users\<your USERNAME>\AppData\Roaming\ReliaSoft\Lambda Predict 18\TreeLists_Settings_V18. For example, to reset only the system hierarchy, delete the file called frmPrediction_treeSystems.

Select the **Collapse system hierarchy tree by default** check box if you want the system hierarchy to display only the top-level items each time you open a prediction folio. You can
then use the +/- icons to expand/collapse specific branches, as desired. If you clear the check box, all branches in the hierarchy will be expanded by default when you open a prediction folio.

Properties Settings

The Properties page of Lambda Predict's Application Setup contains default settings that will be applied to the Identifiers and General headings in the Properties panel when you create a new prediction folio.

These headings include those properties that are used to identify a particular item (e.g., name, part number, etc.), as well as block properties that affect the entire system configuration (e.g., redundancy, mission time, etc.). These properties are available for all items regardless of which prediction standard is being used for the analysis. Other properties that are specific to a particular prediction standard and component type are not affected by the settings on this page.

- To choose which properties to display, use the check boxes.
- To change the order of the properties, use the arrow buttons to move the selected field up or down in the list. You can also drag/drop a field into the desired position. Identifier fields cannot be re-ordered.
- To restore the default settings in the current application, click the Reset Application Form Settings or Reset All Settings buttons on the Reset Settings page of the Application Setup.

Tip: If you want to restore only the settings for one particular hierarchy without resetting any other application form settings, you can delete the specific file from C:\Users\<your USERNAME>\AppData\Roaming\ReliaSoft\Lambda Predict 18\TreeLists_Settings_V18. For example, to reset only the properties, delete the file called frmPrediction_treeProperties.

Note that if you are working in the Properties panel, you can quickly hide any of the properties under the General heading by right-clicking the property name and choosing Hide on the shortcut menu. The only exceptions are Name, Quantity, Mission Time, Redundancy and Quantity Required. Those five properties must always be displayed.
Chapter 16: Lambda Predict Settings

Calculations Settings
The Calculations page of Lambda Predict's Application Setup contains default settings that will be applied to calculated results when you create a new prediction folio.

- **Precision to be Displayed on Calculations** sets the math precision (number of decimal places) and the point at which the software will switch to scientific notation. For example, if the scientific notation tolerance is set to 5, then any number that is larger than $10^5$ will be displayed using scientific notation.

- **Precision for Convergence Criteria** sets the tolerance that will be used as the convergence limit (degree of accuracy) for mathematical iterations. For example, a value of 4 indicates $1E-4$ tolerance. This setting is used in redundancy calculations (e.g., systems with parallel reliability-wise configurations). See [Redundancy](http://predict.reliasoft.com).

Plot Settings
The Plot page of Lambda Predict's Application Setup contains default settings that will be applied when you create a new plot sheet. Note that some of the configurable settings that are saved with the plot can still be modified from the Plot Viewer's control panel and others can be modified via the [Plot Setup](http://predict.reliasoft.com).

- **Settings for Numbers in Axis Labels** sets the math precision (number of decimal places) and the point at which the software will switch to scientific notation for the X- and Y-axis labels.

- **Settings for Plot Sheets**
  - **Enable auto refresh** activates the auto refresh option.
  - **Show legends on plots** displays information about the objects shown on the plot.
  - **Show user, date and time** displays the user name, date and time on plots. The user information comes from your user account in the current database (see User Login and Contact Information window) and is displayed at the bottom right corner of the plot.
  - **Show program ID on plots** displays the software name and URL in the Header Title section of the plot (e.g., Lambda Predict - www.ReliaSoft.com).
  - **Show outline on plots** displays the canvas border on the plot.
Other Settings
The Lambda Predict > Other page of Lambda Predict’s Application Setup contains default settings that will be applied when you create a new prediction folio.

- **Preferences.** Select the check box if you want to launch the Project Item Wizard whenever you create a new prediction folio. The wizard helps you select the first new folio to create in a project. If not selected, the new project will be blank.

- **Units.** Analyses that are based on one particular prediction standard will return the calculated failure rate in the units preferred by the standard (e.g., FPMH for MIL-217, FITS for Bellcore/Telcordia, etc.). However, when you use a generic standard item to combine the results from more than one prediction standard or when you create an overlay plot that includes data from more than one prediction standard, you will need to choose a preferred unit for calculating the failure rates. The software will convert the data automatically based on your selection.
  - FPH (failures per hour)
  - FPMH (failures per million hours)
  - FITS (failures per billion hours)

- **Stress Upper Range Override** allows calculations for stress values that exceed the upper limit defined in the standard that you are working with. Care should be taken to ensure the accuracy of the models beyond the stated limits. For example, for a MIL-217 capacitor, the upper limit of the voltage stress ratio is equal to 1 and, by default, the application will prevent you from entering any greater value. If you select the check box, Lambda Predict will allow you to enter values greater than 1.

- **Default Component Warning** displays a warning when you open a prediction that contains components that use default values for the component properties. This may indicate that the data for the components have not yet been reviewed or updated.

- **FIDES**
  - **Grouped phase properties** groups together the properties of each phase for FIDES predictions. If you clear the check box, the phase will be identified in parentheses after the property name. For example, the picture on the left shows the properties grouped by phase, and the picture on the right shows the same properties, but with no grouping.
Settings Path specifies the resource file that will be used to define the FIDES settings in each new database you create. For specific instructions on using the resource file, see Default FIDES Settings for New Databases.

PartLibraries.org Settings
PartLibraries.org is a web-based portal that contains an extensive library of component data for use in standards based reliability predictions and other reliability analyses. It allows you to search and import parts data from MIL-M-38510, EPRD-97 or NPRD-95 (free to all users) as well as from a library of more than 300,000 specific commercial electronic components (yearly subscription required). See Importing from PartLibraries.org.

Lambda Predict needs an active Internet connection to access the PartLibraries.org database. If your computer needs to use a proxy server to connect to the Internet, the PartLibraries.org page of Lambda Predict’s Application Setup allows you to set the connection information. You will need to contact the administrator of the proxy server or your network's IT support group to obtain the required information.
Reset Settings

The Reset Settings page of the Application Setup allows you to restore some or all of the settings to their original configuration. Note that it’s recommended to close all windows before resetting settings. If the change does not take effect immediately, restart the application.

- **Reset Common Synthesis Settings** resets the settings under the Synthesis Settings heading in the Application Setup.

- **Reset Application Settings** resets the settings under the current application's heading in the Application Setup. It also clears any saved default column headings in life data (Weibull++), life-stress data (ALTA) and growth data (RGA) folios.

- **Reset Application Form Settings** resets the form settings for the current application (e.g., size and location of windows).

- **Reset Plot Settings** resets the Plot Setup settings that are applied by default when you create a new plot in the current application.

- **Reset FIDES Settings** (Lambda Predict only) resets the predefined FIDES settings (e.g., saved pi factors, process audits, etc.) that are applied by default when you create a new repository. (See FIDES Settings Manager in the Lambda Predict documentation.)

- **Reset Component Defaults** (Lambda Predict only) resets the component property values that are applied by default when you add a new component to a prediction. (See Default Component Properties in the Lambda Predict documentation.)

- **Reset All Settings** resets all the saved settings for the current application. This is the same as clicking all of the individual "Reset" buttons above.

Project Item Settings

ReliaSoft desktop applications offer a variety of configurable settings that are stored per computer/username and managed via the Application Setup.

Your personalized application setup determines the default settings for new folios, diagrams and flowcharts that you create in Weibull++, ALTA, BlockSim, RENO and RGA. The relevant settings are also saved with each individual folio/diagram and are accessible from the Item Properties window. This makes it possible to have different settings for different analyses, and also ensures that any given analysis will be the same for all database users.
To view and edit the configurable settings in the Item Properties window, select the folio, diagram or flowchart in the current project explorer and choose Project > Current Item > Item Properties.

The settings are displayed on the second tab of the properties window. (In a secure database, the settings can be edited only if the user is the project owner or has the "Create/edit project items" permission.)

If you modify the settings for a particular project item, the new preferences will be saved with the folio/diagram. The default preferences for new folios/diagrams in the application setup will remain unchanged.

Region and Language Settings
The Region and Language settings for your particular computer will have some impact on the way some information is displayed in ReliaSoft applications.

Users with different regional and language settings can work together on the same analysis projects because, in most cases, the basic information is stored in the database and the software simply displays it in the format preferred by each user. For example, if the date September 25, 2015 is stored in the database, User A might see it as "9/25/2015" while User B might see "25-Sep-15."

This topic first explains how to view or change the Region and Language settings on your computer and then discusses some specific considerations for ReliaSoft applications, including:

- Which language is selected by default when you install the software
- How dates and times will be entered and displayed
- How decimal values and currency will be entered and displayed

Viewing or Changing the Region and Language Settings for Your Computer
To view or change the region and language settings:

- In Windows 8 or Windows 10, move the pointer to the lower left corner of the desktop, then right-click and choose Control Panel. Click the Clock, Language, and Region option then click the Region link.

- In Windows 7, choose Start > Control Panel and then click the Region and Language link.
As an example, the Windows 7 interface is shown here. The Windows 8 and Windows 10 versions look different but function similarly.

Other relevant settings are managed via the Customize Format window:

- In Windows 8 or Windows 10, click the **Additional settings** button.
- In Windows 7, click the **Additional settings** button.

As an example, the Windows 7 interface is shown next.
Chapter 16: Lambda Predict Settings

Note: To see the changed settings in the ReliaSoft application, you must close the application, and then restart it.

Which Language is Selected by Default When You Install the Software

The user interface for ReliaSoft desktop applications is available in several languages. You can change this language at any time by choosing an option from the Language drop-down list on the Synthesis Settings page of the Application Setup.
When you first install the software, it will check your computer's current language as it is set in the **Format** field in the Windows Region and Language window. If that language is supported in the ReliaSoft applications, they will use those settings; however, if that language is not supported, they will use the default setting of English.

**Defining Date and Time Formats**

Dates and times appear frequently throughout the ReliaSoft interface, including (but not limited to):

- The dates in the plot legend area of a plot in all ReliaSoft applications.
- The history provided throughout ReliaSoft applications (e.g., for resources, FMEA records, diagrams, in history logs, etc.).
- The dates in the worksheet view and in the record properties windows in Xfmea, RCM++, RBI and MPC.
- The dates in the "dates of failure" format and "usage" format of the Weibull++ warranty folios.

The **Short date** field from the Windows Region and Language window determines how dates are displayed. You can select any standard format (e.g., M/d/yyyy, dd/MMM/yy, yy/MM/dd) or you can create your own format using the available date notations.

The **Short time** field determines how times are displayed. You can select any standard format (e.g., h:mm tt, HH:mm, HH'h'mm) or you can create your own format using the available time notations.

The Windows settings do not apply to the following items:

- Dates and times in spreadsheet utilities (e.g., a spreadsheet module in Synthesis Workbooks, General Spreadsheets, etc.).
- Dates and times displayed in the Weibull++ event log folio are created by the folio and are not affected by the computer's settings.

**Changing the Decimal Symbol, the List Separator and the Currency Symbol**

How decimal values are displayed depends on the value of the **Decimal symbol** field on the Numbers page of the Windows Customized Format window, which determines which character is used to indicate the decimal portion of a number (e.g., 85.25 or 85,25). In addition, the character used to separate the arguments in a list depends on the value of the **List separator** field. These settings affect how you enter functions in a spreadsheet module in Synthesis Workbooks or in General Spreadsheets, either manually or by using the Function Wizard.
For example, if the decimal symbol value is a comma, and the list separator value is a semicolon, you would enter a function like this:

=RELIABILITY("Weibull!Folio1!Data 1";500;100;0,9)). Whereas, if the decimal symbol is a period and the list separator is a comma, it would be

=RELIABILITY("Weibull!Folio1!Data 1",500,100,0.9)).

The currency symbol that is displayed in the software depends on the selection in the Currency symbol field on the Currency page of the Windows Customized Format window.
Chapter 17: ReliaSoft Common Tools

Categories, Identifiers and Filters

Defining Categories
In all ReliaSoft desktop applications, you can use flexible categories and identifiers to filter and group analysis data in a way that fits your specific needs. There are two types:

- **Project Categories** can be applied to projects in all desktop applications.
- **Item Categories** can be applied to project items (e.g., folios, diagrams, system hierarchy items) and resources (e.g., models, URDs) in all desktop applications except MPC.

This topic describes how to define the categories that will be available throughout the current database. To learn how to use them to filter and group data, see Project and Item Filters. (For additional options related to categories for system hierarchy items, see Item Categories in Xfmea/RCM++/RBI in the Xfmea/RCM++/RBI documentation.)

Accessing the Project/Item Categories Window
There are two ways to access the Project/Item Categories window and specify which categories will be available throughout the current database. (In a secure database, these are available only for users with the “Manage project/item categories” permission.)

To open the window from the backstage view, choose File > Manage Repository > Project/Item Categories.

Alternatively, you can click inside any Category drop-down list (e.g., in a properties window, filter, etc.) and click the Edit Categories icon.
Adding, Renaming and Deleting Categories

- To rename an existing category, double-click inside the cell and edit the text.

- To add a new category in the same level as the one that is currently selected, click Add.

- To add a new category in the level below the one that is currently selected, click Add Below.

- To move a selected category up or down within the same level, select the row and click Up or Down.

- To move a selected category to a different level, click Promote or Demote.

- To delete a category, select the row and press the Delete key or click the icon. To delete all categories at the same time, click Clear All. There is no undo for delete.
Identifiers
In all ReliaSoft desktop applications, you can use flexible identifiers and categories to filter and group analysis data in a way that fits your specific needs. The identifiers are available for project explorer items (e.g., folios, diagrams, plots, etc.) and there is one standard set of identifier fields for all relevant locations.

This topic describes how to view and edit identifiers for each type of resource or analysis, and how existing identifiers will be converted from Version 8 or 9. To learn how to use identifiers to filter and group data, see Project and Item Filters.

For Resources
To view and edit the identifiers for most types of resources, you can simply open the properties window and select the Identifiers node. They can also be edited via the Batch Properties Editor.

Note that:

- For published models, the identifiers are obtained from the analysis (e.g., Weibull++ folio, BlockSim diagram, etc.). To make a change, you must first edit the identifiers for the analysis and then republish the model.

- Identifiers are not applicable for the following resource types: Variables, Maintenance Groups, Mirror Groups, Actions, Controls and Profiles.

For Project Explorer Items
To view and edit the identifiers for folios, diagrams, plots and other analyses in Weibull++, ALTA, RGA, BlockSim, RENO or Lambda Predict, select the item in the current project explorer and choose Project > Current Item > Item Properties.
The identifiers are always displayed on the first tab of the properties window.

When applicable, the fields are also visible on the Identifiers page of the control panel. If a folio has multiple data sheets, you can use this page to define separate identifiers for each sheet. Note that the Folio Identifiers will be used in item filters and in the Synthesis Explorer; while the Data Sheet Identifiers will be used when publishing a model.

You can use an asterisk (*) in any or all of the data sheet fields to apply the same text from the corresponding folio field. As an example, the following picture shows the identifiers for a Weibull++ life data folio that contains multiple data sheets for each design prototype of a new chandelier bulb in development. Although most of the data sheet identifiers will be the same as the folio (indicated with *), the Version and Comments fields have been modified for each data sheet. The data sheet identifiers will be used when you publish a model.

For System Hierarchy Items
To view and edit the identifiers in Lambda Predict, Xfmea, RCM++ and RBI, select an item in the system hierarchy and go to the Properties tab in the Analysis panel.
The fields are grouped together under the Identifiers heading.

- In Lambda Predict, Name will always be displayed. The remaining identifiers may be hidden or displayed via the Application Setup. (See Properties Settings in the Lambda Predict documentation.)

- In Xfmea, RCM++ and RBI, Name, Category and Keywords will always be displayed. The remaining identifiers may be hidden or renamed based on the configurable settings for the current project. (See Configurable Settings in the Xfmea/RCM++/RBI documentation.)

In Xfmea, RCM++ and RBI, the same set of identifiers will be used for all analyses associated with a given system hierarchy item (e.g., FMEA, control plan, etc.).

**For Diagram Blocks**

To view and edit identifiers for diagram blocks in BlockSim, open the block properties and select the Identifiers node. The fields are also visible on the Identifiers page of the control panel when the block is selected.

You can use these identifiers in BlockSim’s Find utility and in the Batch Properties Editor.
Conversion from Version 8/9
The following table shows how the "global identifiers" from previous versions will be mapped when you convert existing data in a Version 8/9 database (where “ - “ indicates no change).

Project and Item Filters
In many locations throughout all ReliaSoft desktop applications, you can use flexible filters to limit a list of projects, project items (e.g., folios, diagrams, system hierarchy items, etc.) or resources (e.g., models, URDs, etc.).

The drop-down list contains the filters you have saved in this database, plus any filters that another user has chosen to share with other database users.
Use the drop-down list to apply an existing filter. To stop filtering the list, select Show All (formerly called "Default filter").

**Sharing Filters with Other Users**
To share a saved filter, open the filter's properties window and select the **Show to all repository users** check box.

In a secure database, a shared filter can be edited or deleted only by a) the user who created the filter or b) a user with the "Manage other repository settings" permission.

**Project Filters**
Project filters can be applied to lists that contain project names such as the Project Manager and Synthesis Explorer. The filter can either be a query based on specified criteria, or a selected list of projects.

- **Based on Criteria.** You can match **All Criteria** (AND query) or **Any Criteria** (OR query):
  - Owner ([project owner](#))
  - Category ([project category](#))
  - Analysis/Feature (whether the project contains analyses associated with the specified application or feature)
  - Last Updated By
  - Last Updated Date

- **Based on Selected Projects.** Click the **Add** button to select the projects you want to include, or the **Remove** button to remove a selected project from view.

Clear the **Show locked projects** check box if you want to exclude locked projects from the results, even if they meet the criteria.

Projects are always grouped based on whether they are **public, private or reference**. For additional grouping, select the **Group by category** and/or **Group by owner** check boxes. If you select both, the results will be grouped first by project category and then by project owner. For example:
Item Filters

Item filters can be applied to lists that contain project items and resources such as the Current Project Explorer and Resource Manager.

Select whether the item must match All Criteria (AND query) or Any Criteria (OR query):

- Category (item category)
- Created By
- Last Updated By
- Last Updated Date
- Identifiers (Name, Part Number, Version, Application, Supplier, Description, Comments and Keywords)

Synthesis Explorer

The Synthesis Explorer is available in all ReliaSoft desktop applications except MPC. You can use this flexible tool to explore all of the different analyses that are stored in the current database.

To access the utility, choose Home > Synthesis > Synthesis Explorer.

To reduce the amount of time required to populate the grid, first use the project and item filters (discussed below) to limit your search, then click Load Data.

The analyses shown in the explorer may include:

- Project items in Weibull++, ALTA, BlockSim, RENO, RGA and Lambda Predict (e.g., folios, diagrams, plots, Synthesis Workbooks, etc.).
• Analyses that are associated with system hierarchy items in Xfmea, RCM++ or RBI (e.g., FMEAs, control plans, risk based inspection analyses, etc.).

• Project Plans that can be created for any project.

You can filter/sort/group the analyses based on ReliaSoft application, analysis type, analysis creator and many other properties. You can also present the information in a wide variety of dashboard charts.

This topic summarizes the tools you can use to find and organize data in the Synthesis Explorer’s flexible grid. For information about presenting the data graphically, see Synthesis Explorer Dashboards. For a list of the properties that can be used in either the grid or the dashboard, see Synthesis Explorer Properties.

Save and Apply Views

Once you have customized the Synthesis Explorer’s grid to suit a particular purpose (using the built-in find/filter, column configuration and grouping features described below), you can save the preferences as a view that can be used again whenever you need it. A view is saved in the database and available only to the user who created it.

To create a view, first configure the grid to suit your particular needs and then click Save View.

To quickly apply these same preferences again at any time, click Apply View and select one of the saved views from the list.

Note: The view does not affect filtering that has been applied from the Project Filter, Item Filter or Category Panel.

Project and Item Filters

The Synthesis Explorer can utilize the same project and item filters that are available in many other locations throughout ReliaSoft desktop applications. For example, with the custom filters shown below, the Synthesis Explorer will show only analyses performed by Department A (project filter) that were modified within the last month (item filter).
To remove either filter, select Show All from the drop-down list. To remove both filters at the same time, select Clear Filters.

After you clear or change these filters, you must click Load Data again to update the grid.

**Category Panel**
The category panel provides a quick way to filter the data based only on item category. For example, you might use the panel to first view the analyses for Category A and then quickly switch to see the analyses for Category B.

To show or hide the panel, click Show Category Panel.

When there are many categories, the tools at the top of the panel can help you find and select the one(s) you need.

**Built-in Find/Filter, Configuration and Grouping Tools**
The Synthesis Explorer offers the same filter, column configuration and grouping tools that are built in to other utilities that use a similar grid (e.g., the Resource Manager). For details about how to use each feature, see:

- Finding and Filtering Records
- Configuring Columns
- Grouping Panel
Synthesis Explorer Dashboards

You can use the flexible Synthesis Dashboard utility for presenting data from the Synthesis Explorer.

As with any other Synthesis dashboard, you can use the Dashboard Viewer to select any of the layouts that have been predefined for this type of data, and you can use the Dashboard Layout Manager to create or edit layouts.

(In a secure database, the Dashboard Layout Manager is available only for users with the “Manage dashboard layouts” permission.)

Values and Arguments

When you’re creating bar charts or pie charts based on Synthesis Explorer data, note that the argument(s) determine the bars or slices shown in the chart and the value will always be the quantity of analyses that fit the specified criteria.

If you use the default Count option when specifying the value, then any of the Synthesis Explorer properties will return the same quantities. You may prefer to choose the one that gives the most appropriate chart label(s). For example, the following pie chart uses the same property (“Application Source”) for both the Value and Argument in order to display the total quantity/percentage of analyses for each ReliaSoft application.

Tip: Use the Design tab of the ribbon to configure the chart labels and other settings to fit your particular preferences. For example, in this chart, the Data Labels are configured to display the Argument, Value and Percent (e.g., BlockSim: 648 (23.44%).)
If there is ever a situation in which you want to show only the number of distinct values for a particular property, you can use the **Count Distinct** option instead. For example, the following pie chart uses **User Created By (Count Distinct)** for the value in order to show the number of users who created analyses with each ReliaSoft application.
As you can see from looking at both charts, the “Count” shows that there are 648 total BlockSim analyses; while “Count Distinct” shows that only 18 distinct users created BlockSim analyses.

**Filtering the Data**

Any filters that are currently applied in the Synthesis Explorer grid will not be reflected in the dashboard charts. However, you can incorporate filters directly into the dashboard layout. For example, if you want to show all of the Weibull++ analyses that were created by a particular user, you can create a filter like the one shown next. (See Using the Filter Editor.)

In addition (or instead), you can configure the layout with one or more *master filters* that allow individual users to change the filters on-the-fly in the Dashboard Viewer. As an example, the following picture shows a layout in which the user’s current selections in the two grids determine which analyses will be reflected in the pie chart at any given time. (See Configuring a Master Filter and Using Master Filters.)
Synthesis Explorer Properties

The following properties will be available when you are using either the grid or dashboard in the Synthesis Explorer.

**Application**
- **Application Source** is the primary ReliaSoft application (or product family) for viewing or editing the analysis. (Note that Project Planners and Simulation Worksheets are listed under Synthesis because they can be created/edited from more than one product family.)
- **Application Activated?** indicates whether the primary application is activated on your computer.

**Project**
- **Project Name** is the project in which the analysis is stored.
- **Project Type** indicates whether it is a public, private or reference project.

**Analysis**
- **Analysis Name** is the name of the folio, diagram, plot, system hierarchy item, etc.
• **Analysis Type** and **Variant** indicate the type of analysis. This can include project items (e.g., folios, diagrams, plots, etc.) and specific analyses that are associated with a system hierarchy item in Xfmea, RCM++ or RBI (e.g., FMEAs, risk based inspection analyses, etc.). The variant is used to distinguish:

  • Analytical vs. simulation RBDs and fault trees in BlockSim.
  
  • Discrete vs. continuous Markov diagrams in BlockSim.
  
  • The specific prediction standard in Lambda Predict (e.g., MIL-217, Telcordia, etc.). If the prediction folio uses more than one standard, this will show as “Multiple.” If a standard has not yet been added to the prediction folio, the variant field will be blank.

**Categories and Identifiers**

*Note that these properties are preceded with “SI” in the Dashboard Layout Designer, so that all identifiers can be grouped together in the data source panel.*

• **Category** is the category assigned to the analysis.

• **Name**, **Part Number**, **Version**, **Supplier**, **Application**, **Description**, **Comments** and **Keywords** are the standard identifiers that can be defined for the analysis. Note that Xfmea/RCM++/RBI analyses use the identifiers defined for the system hierarchy item they are associated with.

**Creation and Last Update**

• **User Created** and **Date Created** indicate the database user who originally created the analysis, and the associated date/time.

• **User Updated** and **Date Updated** indicate the database user who last modified the analysis, and the associated date/time.

**ReliaSoft Locator Links**

ReliaSoft Locator Links provide quick access to specific analyses in a repository (similar to Windows shortcuts). You can save these link files anywhere on your computer or network, e-mail to a colleague, post on the Internet or an intranet, etc.

When you double-click (open) a ReliaSoft Locator Link file (*.rsrl18), it will launch the appropriate ReliaSoft application and go directly to a specific project item (e.g., folio, diagram, plot, system hierarchy item, etc.) or FMEA record (e.g., function, failure, etc.), as long as the following conditions are met:

• The database still resides in the same location and you have access to the server.
Chapter 17: ReliaSoft Common Tools

- You have an active user account in the database.
- The required ReliaSoft application is activated on your computer.

**Tip:** In the case of a standard database or Synthesis file, the locator link stores the pathname/filename that was open when the *.rsl8 file was created. If that was a mapped network drive (e.g., P:\ReliaSoft\Repository1.rsr18), the link will only work if all other users have that drive mapped to the same letter. To make sure the link works for all users, you may need to open the database from the UNC pathname (e.g., \SharedDrive\ReliaSoft\Repository1.rsrl18) before creating a locator link file.

### Creating a Locator Link

In an enterprise database, you can choose to either send the file by e-mail or save it to a specified location. In a standard database or Synthesis file, the only option is to save the file because it is likely that the pathname may only work on your own PC (as discussed above).

- For an item selected in a current project explorer (Weibull++/ALTA, BlockSim/RENO, RGA or Lambda Predict), choose **Project > Current Item > Save Locator Link**.
- For an item selected in an Xfmea/RCM++/RBI system hierarchy, choose **System Hierarchy > Current Item > Save Locator Link**.
- For an item, structure or zone selected in an MPC hierarchy, choose **[Systems/Structures/Zones] > Tools > Save Locator Link**.

**Note:** If you get a "Locator Link is not properly formatted" message, the locator link may be corrupted or is using old encryption. Create a new locator link using the methods described above.

### Posting Locator Links on a Web Page

Remember that ReliaSoft Locator Links are files that must be opened from a computer where ReliaSoft desktop applications are installed. If you post the *.rsrl18 as a standard link on an HTML web page, you will need to instruct users to download the file (instead of opening directly from the web browser).
What's Changed? In Version 10, Synthesis Locator Link files used the *.rsll extension. Note that these links are not compatible with Versions 11 and 2018.

Watches and Alerts

Automated alerts can be an effective tool to facilitate communication and track the status of assigned responsibilities.

Alerts can be sent via e-mail, SMS text message and/or ReliaSoft portal messages, depending on the Receive automated alerts preference specified for your personal user account.

- Alerts via portal message are always available in any database.
- Alerts via e-mail or SMS are only available if they are enabled for the database, and a valid SMTP server has been defined. (See Enable Alerts via E-mail or SMS.)

Alerts can now be sent for:

- Any resource that you have personally subscribed to “watch.” (See Subscribing to a Watch.)
- Action resources, under any of the following conditions:
  - You have personally subscribed to watch the action.
  - You are the action’s creator, person responsible or assigned reviewer/approver and the database has been configured to auto-subscribe a watch for that role. (See Action Alert Preferences.)
  - You are assigned via the Action Monitors window. (See Action and Gate Monitors.)
- Project Planner gates, under either of the following conditions:
  - You have personally subscribed to watch the gate.
  - You are assigned via the Gate Monitors window.
- Change logs you have been assigned to approve in Xfmea/RCM++/RBI. (See Electronic Approval Tracking in the Xfmea/RCM++/RBI documentation.)
Enable Alerts via E-mail or SMS
To configure a database to enable alerts via e-mail and/or SMS text message, choose File > Manage Repository > Repository Settings.

In a secure database, this is available only for users with the “Manage other repository settings” permission.

What’s Changed? In prior versions, similar preferences were defined in the E-mail and Other Settings window.

1. Select the Enable Alerts via E-mail or SMS check box.

2. Specify a valid SMTP port and SMTP server. (You may need to consult with the IT professionals who have configured the e-mail server used within your organization.)

<table>
<thead>
<tr>
<th>SMTP port</th>
<th>SMTP server</th>
</tr>
</thead>
<tbody>
<tr>
<td>25</td>
<td>&lt;Insert a valid SMTP address&gt;</td>
</tr>
</tbody>
</table>

3. Enter your e-mail address (or a valid SMS text messaging address if you prefer) in the Recipient address for test message field and then click Send Test Message.

If the test message cannot be sent, an error will be displayed. If that happens, you can update the settings and try again until the message is delivered successfully.

Subscribing to a Watch
Users can personally subscribe to “watch” specific resources, Project Planner gates and MPC tasks that are of particular interest to them. This generates an alert (via e-mail, SMS text message and/or ReliaSoft portal message) each time the record is changed.
Chapter 17: ReliaSoft Common Tools

Subscribing and Unsubscribing
To personally subscribe/unsubscribe to a watch, open the resource, Project Planner gate or MPC task and select or clear the Alert me on changes to this record check box. The alert types shown for this option will depend on your alert preferences, as described in the section below.

| Watch | Alert me on changes to this record (via SMS, e-mail, portal message) |

Note that the “watch” feature is not applicable for the following types of resources: Variables, Profiles, Maintenance Groups, Mirror Groups, Controls, Maintenance Templates (in BlockSim) or RENO-specific resources (Functions, Static Functions, Simulation Definitions and Tables).

Receiving Alerts
Alerts can be sent via e-mail, SMS text message and/or ReliaSoft portal message, depending on the Receive automated alerts preference specified in your personal user account.

- Alerts via portal message are always available in any database.
- Alerts via e-mail or SMS are only available if they are enabled for the database, and a valid SMTP server has been defined. (See Enable Alerts via E-mail or SMS.)

No Cascading Alerts
Alerts are generated only when the record you’re watching is edited directly. For example, if you are watching a universal reliability definition (URD):

- An alert will be sent if someone replaces Model A with Model B in the URD window.
- An alert will not be sent if there is a change to an existing model, crew, etc. that is already assigned to the URD, unless you have also subscribed to watch the dependent resource that was changed.

Special Considerations for Actions and Gates
For action resources only, there are some additional features designed to maintain continuity with prior versions and enhance the actions management functionality. Specifically:

- Action changes that are applied via the FMEA worksheet in Xfmea/RCM++/RBI will not initiate an alert. The change must be saved via the action properties window.
- The database can be configured to auto-subscribe watches for users with the following roles: Action Creator, Person Responsible or Reviewer (aka “approver”). Each user can choose to personally unsubscribe later if desired. (See Action Alert Preferences.)
- The Action Monitors window allows you to specify individual users and/or groups of users who will always receive alerts for the action, regardless of whether they have personally subscribed to a watch. For example, this allows you to set up an alert for a
user who doesn’t have access to view or modify the project (and therefore can’t personally subscribe to a watch).

A similar feature, the Gate Monitors window, is available for Project Planner gates. (See Action and Gate Monitors.)

Action Alert Preferences
To configure the action alert preferences for the database, choose File > Manage Repository > Repository Settings.

In a secure database, this is available only for users with the "Manage other repository settings" permission.

What’s Changed? In prior versions, similar preferences were defined in the E-mail and Other Settings window.

• Introduction to each action alert sent via e-mail. This field allows you to specify the default text (up to 1,000 characters) that will be used at the beginning of each action alert e-mail sent from this database.

• Automatically set 'watch' for. Users can personally subscribe to “watch” specific resources and Project Planner gates that are of particular interest to them. For action resources only, the database can also be configured to auto-subscribe watches for users that have particular roles in a given action, as shown in the picture above. Note that each user can choose to personally unsubscribe later if desired (by opening the action record and clearing the check box under the Watch heading).
Chapter 17: ReliaSoft Common Tools

Action and Gate Monitors
The Action Monitors window (for action resources) and the Gate Monitors heading (for Project Planner gates) allow you to specify individual users and/or groups of users who will always receive alerts for the record, regardless of whether they have personally subscribed to a “watch.”

For example, this allows you to set up an alert for a user who doesn’t have access to view or modify the project (and therefore can’t personally subscribe to a watch).

Action Monitors
For actions, click the Action Monitors icon in the action’s ribbon.

This replaces the “E-mail Notifications” feature from prior versions, and you can choose any of the user groups or individual user accounts defined in the current database.

The action will also appear under the I am monitoring heading in My Portal, Actions Explorer and Synthesis Enterprise Portal (along with the actions that the user has personally subscribed to watch).

Gate Monitors
For Project Planner gates, the assigned users are listed under the Gate Monitors heading. Click the Edit icon to select the users you wish to assign.

This replaces the “Team” feature from Xfmea/RCM++/RBI Version 9, and you can choose to assign any of the individual user accounts in the database.

What is Your SMS Address?
If you choose to receive alerts via SMS text messaging, the address will usually be your cell phone number @ the provider’s e-mail domain. As a courtesy, the table below provides a list of domains for popular providers in the United States (as of March 2015). Of course, you may need to check with your provider to obtain the most up-to-date information.
For example, if you use T-Mobile in the US and your cell number is 555-123-4567, your SMS address will be 5551234567@tmomail.net.

<table>
<thead>
<tr>
<th>Provider</th>
<th>Domain</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alltel</td>
<td>@message.alltel.com</td>
</tr>
<tr>
<td>Amp'd</td>
<td>@vtext.com</td>
</tr>
<tr>
<td>Boost</td>
<td>@myboostmobile.com</td>
</tr>
<tr>
<td>AT&amp;T</td>
<td>@txt.att.net</td>
</tr>
<tr>
<td>Metrocall</td>
<td>@page.metrocall.com</td>
</tr>
<tr>
<td>Nextel</td>
<td>@messaging.nextel.com</td>
</tr>
<tr>
<td>Sprint</td>
<td>@messaging.sprintpcs.com</td>
</tr>
<tr>
<td>T-Mobile</td>
<td>@tmomail.net</td>
</tr>
<tr>
<td>US Cellular</td>
<td>@mms.uscc.net</td>
</tr>
<tr>
<td>Verizon</td>
<td>@vtext.com</td>
</tr>
<tr>
<td>Virgin (USA)</td>
<td>@vmobl.com</td>
</tr>
<tr>
<td>Windstream</td>
<td>@windstream.net</td>
</tr>
</tbody>
</table>

**History Logs**

By default, all projects and project items automatically show information about when an item was created and last updated, and by whom. For example, system hierarchy items in Xfmea/RCM+/RBI show this information under the History heading on the Properties tab, while folios and diagrams in Weibull++ and BlockSim show the information in the Item Properties window (Project > Current Item > Item Properties).

In addition to the basic information provided, you have the option to activate a full history log that shows more detailed information such as the type of change that was made (e.g., add, edit or delete), the record that was changed and the specific property, and the value before and after the change.
History logs will increase the size of a database and will cause a slight degradation in performance; hence, they must be activated on a per project basis. If desired, you can configure the database to automatically activate history logs for each new project by choosing **File > Manage Repository > Repository Settings**, and then selecting the option under the Other Settings tab in the window. (In secure databases, this is available only if the user has the "Manage other repository settings" permission.)

Once a history log is activated, the **project history log** shows the changes for all items in the project, and individual **record history logs** show the changes for selected items only.

**Tip:** If you want to monitor and control revisions made to FMEAs, DVP&Rs or Control Plans in Xfmea/RCM++/RBI, the use of change logs may be more appropriate. See [Change Logs](#) in the Xfmea/RCM++/RBI documentation.

### Activating a Project History Log

To activate the history log for a project, choose **Project > Management > History Log**, or right click the project in the project list and choose the command on the shortcut menu. (In secure databases, this is available only if the user is the **project owner**, or has the applicable "manage all projects" permissions.)

In the Project History Log window that appears, click **Activate**.

Once the log has been activated, the database will start keeping records of all changes that are performed throughout the entire project for any of the ReliaSoft applications. You can filter the records by the last update date, application, user or type of change. For example, you might choose to display a list of all changes that were made by Joe User in the last week, or a list of all changes that were made by any user in Weibull++ today, and so on.

You can deactivate the history log at any time from this window. When you do this, the recorded data is retained unless you select to clear it in the confirmation message that appears.

### Creating and Managing Archives

You can limit the amount of information that is visible in the log by archiving older entries that are no longer of interest. Entries that have been archived can still be viewed in the Project History Log window if you specifically select to view them, but they will no longer be visible in the Record History Log windows.
Archives are named based on the date they were created. For example, if you archive entries through **One week ago**, all entries in the history log that are dated as of one week ago or earlier will be stored in an archive that is named after the current date.

To view the contents of an archive, select the archive of interest from the **Archive** drop-down list in the **Filter Based On** area. To delete an archive, click the **Delete** icon that appears in the field.

**Note**: When a **restore point** is created for a project or when a project is **checked out**, all current entries in the history log are automatically archived.

### Viewing Record History Logs

In addition to the project history log, you can view a log that shows only the changes made to a selected item (archived entries will not be shown). The History Log icon 📚 will be displayed whenever the log is available:

- For folios, diagrams, multiplots (such as overlay plots), reports and worksheets, right-click the item in the current project explorer and choose **Item Properties**, then in the window that appears, click the **History Log** icon in the Identifiers tab.

- For system hierarchy items in Xfmea/RCM++/RBI and MPC, select the item then click the **History Log** icon in the Properties panel.

- For FMEAs, DVP&Rs and other analyses in Xfmea/RCM++/RBI, right-click the analysis’s tab in the Analysis panel and choose the **History Log** command on the shortcut menu.

- For resources (e.g., models, actions, etc.), the **History Log** icon will be available when you edit the item or view its properties.
Import, Export and Data Conversion

ReliaSoft applications provide a variety of different tools for import, export and data conversion from external files and between Synthesis repositories. The options will vary depending on which application you are currently using.

In desktop applications, you can:

- Import data from an existing database when you are creating a new one.
- Convert and import data from prior version files.
- Import/export selected projects.

When applicable, you can also:

- Import/export selected project items or resources.
- Import from an Excel spreadsheet or delimited text file into a data folio.
- Use XML files to import/export system configuration information in BlockSim or Lambda Predict.

These features can be accessed either from the Import/Export Wizard (Project > Management > Import/Export) or from the Backstage View.

In addition to the common functionality described in this chapter, some ReliaSoft applications provide other data transfer and import/export utilities that fit specific needs (e.g., the Import Bill of Materials feature in Lambda Predict, the Excel templates in Xfmea/RCM++/RBI, the ability to share analysis details between specific ReliaSoft applications.). For more information about these specialized tools, please consult the documentation for the particular application(s) involved.

Importing from an Existing Repository

When you are creating a new Synthesis repository, you have the option to import repository settings (e.g., user accounts, security groups, project categories, etc.) and/or entire analysis projects from another database.

If the Import from existing repository check box is selected when you start to create a new database, the Import Data from Existing Repository window will be displayed.

First, use the drop-down list or browse icon to select the database that you want to import from. This can be a standard database (*.rsr18) or an enterprise database connection file (*.rserp).
Then, use the check boxes to select the settings and/or projects you wish to import.

Finally, click OK to create the new database with the selected data imported.

Note: If you are creating a new enterprise database on SQL Server, the Create SQL Server login check box will be displayed at the bottom of the window. (See SQL Server Logins or Using Windows Impersonation.)

Importing from Prior Version Files

There are two ways to convert and import data from project files and standard database files that were created in previous versions of the software.

- Importing to a new standard database (File > Open Repository)
- Importing to an existing database and project (Import > Other file)

The options depend on which ReliaSoft application you're currently using:

- For Weibull++, ALTA, RGA and BlockSim/RENO, you can use either method.
- For Lambda Predict, Xfmea/RCM++ and MPC, you must use the File > Open Repository method to import the data into a new project in a new standard database.

Finally, for an enterprise database created in Xfmea/RCM++ 5, there is a dedicated utility that you can access from the Backstage View. (See Converting Xfmea/RCM++ 5 Databases.)

Importing to a New Standard Database (File > Open Repository)

For all ReliaSoft desktop applications, you can use the File > Open Repository method to import data from a project file or standard database that was created in a previous version of the software. This imports the data to a new project in a new standard database.

2. Browse for the file and click Open.
3. The conversion process will begin immediately for most applications. In BlockSim and MPC only, you will be prompted to specify some preferences and then click OK to proceed.
   - See Converting from BlockSim 6 or 7 Files.
   - See Converting MPC 3 Databases.

   Note that although the conversion of Xfmea/RCM++ 5 databases does not require any user input, the process does apply some assumptions to address changes in the
functionality and data structure between versions. (See Converting Xfmea/RCM++ 5 Databases.)

When the process completes, the original file will remain unchanged and the new standard database will be created in the same folder.

Tip: Once the new database has been created, you can use the Import/Export Projects feature to copy the data into an existing database, if desired.

Importing to an Existing Database and Project (Import > Other file)

For the applications and file types shown in the following table, you can use the Import > Other file method to import data from a project file that was created in a previous version of the software. This imports the data to a selected project in an existing standard database or enterprise database.

<table>
<thead>
<tr>
<th>Weibull++/ALTA</th>
<th>RGA</th>
<th>BlockSim/RENO</th>
</tr>
</thead>
<tbody>
<tr>
<td>ReliaSoft Office 7 projects (*.rso7)</td>
<td>RGA 7 projects (*.rga7)</td>
<td>BlockSim 7 projects (*.rbp)</td>
</tr>
<tr>
<td>Weibull++ 7 projects (*.rwp)</td>
<td>RGA 6 projects (*.rga)</td>
<td>BlockSim 6 projects (*.rb6)</td>
</tr>
<tr>
<td>ALTA 7 projects (*.ralp)</td>
<td></td>
<td>RENO 1 projects (*.rnp)</td>
</tr>
<tr>
<td>Weibull++ 6 projects (*.rw6)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ALTA 6 projects (*.ra6)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DOE++ 1 projects (*.rdoe)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Do the following:
1. Create a new project or open an existing project that you want to import the data into.
2. Choose Project > Management > Import/Export > Import.
3. In the Import wizard, choose Other file and click OK.
4. The conversion process will begin immediately for most applications. In BlockSim only, you will be prompted to specify some preferences and then click OK to proceed. (See Converting from BlockSim 6 or 7 Files.)
Note that although the conversion of Xfmea/RCM++ 5 databases does not require any user input, the process does apply some assumptions to address changes in the functionality and data structure between versions. (See Converting Xfmea/RCM++ 5 Databases.)

When the process completes, the original file will remain unchanged and the converted data will be copied into the selected project.

Converting from BlockSim 6 or 7 Files
When you import from a BlockSim 6 (*.rb6) or BlockSim 7 (*.rbp) file, the Conversion Settings window allows you to specify:

- Whether you want the diagrams to be converted to analytical diagrams, simulation diagrams, or both.
- Whether the application will attempt to merge identical records when certain block properties are converted to resources. For example, if the old diagram has two blocks with the same failure distribution, this can be imported as two separate but identical failure models, or as a single failure model that's linked from both blocks.

Tip: The default preferences for merging identical resources upon conversion are set on the Conversion page of BlockSim's Application Setup (File > Application Setup). Note that any changes you make in the Conversion Settings window will update your preferences in the Application Setup. In other words, the same options will be selected by default the next time you attempt to convert a BlockSim 6 or 7 file on this computer.

Conversion Constraints and Differences
Numerous improvements have been made to the modeling capabilities and underlying analysis and simulation algorithms used in BlockSim. As a result, analysis or simulation of diagrams imported from previous versions of BlockSim may yield results that differ from the results originally obtained. In particular, results may differ in the following cases and/or for the following reasons:

- Simulation diagrams:
  - When multiple blocks are used in conjunction with subdiagrams, the underlying order of block expansion differs between versions, so results may differ.
• Starting in Version 8, containers are treated as subdiagrams. The underlying order of block expansion differs between versions, so results may differ. However, some special cases will produce identical results. These include cases where:
  • The container is the only block in the diagram.
  • The container is at the end of the list in the original diagram (i.e., it was created last and has the highest block ID, which is automatically assigned by the software upon block creation).

• The load on contained load sharing blocks is calculated differently. Version 7 required a life-stress relationship for such configurations and based the re-computation of load after block failure on that relationship; subsequent versions calculates load using the weight proportionality factor as a multiplier.

• Normal/lognormal distributions have increased precision starting in Version 8.

• Maintenance tasks that are performed at specified intervals (based on item age or calendar time) for multiple blocks are performed in a different order, producing results that are not identical, although the difference will not be statistically significant.

• Indirect cost is calculated differently. In Version 7, the following was calculated at the end of the simulation:

\[
\text{Indirect cost} = \text{Average stock level} \times \text{Holding cost per item} \times \text{Simulation end time}
\]

In subsequent versions, the indirect cost is calculated for each simulation and then averaged at the end to yield the indirect cost that is shown. This is because holding cost per item may be a distribution.

• The order in which random numbers are assigned in general is by block ID. This means that if diagrams have the same blocks with the same IDs in both the previous version and the current version, the results will be identical. Standby containers represent an exception to this. In Version 7, the order of blocks is overwritten by the standby priority. Therefore, results may not be identical with standby containers if the block IDs do not match the block standby priorities. The difference should not be statistically significant.

• For mirrored blocks, in Version 7, the block that fails is the source and all the other mirrors are assigned these failures. In subsequent versions, the failures are assigned to the mirrored block with the lowest block ID. If the failure source is not the block with the lowest ID, then the results will be different between versions.
Chapter 17: ReliaSoft Common Tools

- Mirrored blocks inside subdiagrams are handled differently. In Version 7, they were treated as different groups of mirrors; subsequent versions treat them as the same group. This may produce results that are statistically different.

- Throughput is not available in fault trees starting in Version 8.

- The throughput property **Send units to failed blocks** works differently for subdiagrams in versions after Version 7, in that it applies to the whole diagram. That is, if the current block is set to not send units to failed blocks and the next block is a subdiagram that is not operating, then the throughput will be re-routed if possible or the current block will accumulate backlog.

- Phases have different rules on how interrupted events are handled and may give different results when re-simulating.

- Starting in Version 8, containers do not exist in maintenance phases. Thus, the availability results for containers in phase simulation may be different than in previous versions.

- **Analytical diagrams:**
  - The load on contained load sharing blocks is calculated differently. Version 7 required a life-stress relationship for such configurations and based the re-calculation of load after block failure on that relationship; subsequent versions calculate load using the weight proportionality factor as a multiplier.

- Mirrored blocks inside subdiagrams are handled differently. In Version 7, they were treated as different groups of mirrors; subsequent versions treat them as the same group. This may produce results that are statistically different.

- **Other issues of interest when opening BlockSim 7 files:**
  - Nodes do not have failure/maintenance properties starting in Version 8. Therefore, if a node has failure properties in BlockSim 7, it will be imported in the current version as two blocks: a node with the $k$-out-of-$n$ and the throughput properties (if applicable) and a block with the failure properties positioned immediately after the node. If the node does not have failure properties, a second block will not be imported.

  - The load on contained load sharing blocks is calculated differently. Version 7 required a life-stress relationship for such configurations and based the re-calculation of load after block failure on that relationship; subsequent versions calculate load using the weight proportionality factor as a multiplier. Because of this, if you convert a diagram that uses load sharing containers, you will need to manually configure the contained load sharing blocks after conversion.
Simulation FRED reports will be imported, but cannot be restarted or have levels appended/removed until the diagram is resimulated.

In addition, certain rules apply when importing maintenance properties from BlockSim 7:

- Preventive maintenance:
  
  - For each preventive maintenance setting, a new task will be created. For example, if the preventive maintenance policy is set to be performed upon system down and upon system age, two tasks will be created.
  
  - For each task created, the duration, crews, restoration factor, etc. will be identical.

- Inspections:
  
  - For each inspection setting, a new task will be created. For example, if the inspection policy is set to be performed upon system down and upon system age, two tasks will be created.
  
  - For each task created, the duration, crews, restoration factor, etc. will be identical. Note that inspections do not use pools.
  
  - If a detection threshold is defined in Version 7, an on condition task will be created instead of an inspection task in subsequent versions. A threshold is defined in Version 7 if a Failure Detection Threshold greater than 0 and less than 1 is specified or if a P-F Interval greater than 0 is specified.
    
    - The inspection properties from Version 7 will be transferred to the inspection properties of the on condition task in subsequent versions.
    
    - The threshold (i.e., detection) information from Version 7 will be transferred to the failure detection properties of the on condition task in subsequent versions.
    
    - The preventive maintenance properties from Version 7 will be transferred to the on condition task (upon detection) properties of the on condition task in subsequent versions.
  
  - If a detection threshold is defined in Version 7 but no preventive maintenance properties are defined, then only an inspection task will be created (i.e., the threshold is ignored).
• PM/Inspection based on group:
  • A task will be added and assigned to the maintenance group that the block belongs to. For example, if Block 1 belongs to Item Group 1 and has an inspection policy based on group maintenance in Version 7, then in subsequent versions an inspection task will be created and will be set to be performed upon group maintenance. Maintenance Group 1 will be checked in the list of groups that will trigger a maintenance, and Block 1 will be assigned to Maintenance Group 1.
  • If the block does not belong to a group, a task will not be added.
  • The corrective maintenance properties will be imported as corrective tasks.
  • A preventive maintenance action or an inspection based on maintenance phase and associated with a block in a standard phase will not be imported.

Converting Xfmea/RCM++ 5 Databases
This topic describes how to convert/import data from an Xfmea/RCM++ 5 database into a Synthesis repository.

For information about converting and importing data from an Xfmea/RCM++ 5 library, please consult the "Configurable Settings" chapter in the Xfmea/RCM++/RBI documentation.

Standard Databases (*.rx5)
For Xfmea/RCM++ 5 standard databases, you must convert the entire *.rx5 file to a new standard repository. (Later, you can use the Import/Export Projects feature to copy specific projects into an existing database, if desired.)

Do the following:

1. In the current version of Xfmea, RCM++ or RBI, choose File > Open Repository.
2. Select RCM++ 5/Xfmea 5 (*.rx5) from the Files of type drop-down list.
3. Select the file you wish to convert and click Open.

The application will create a new standard database file in the same directory with the extension *.rsr18; the existing *.rx5 file will remain unchanged.

Enterprise Databases
For Xfmea/RCM++ 5 enterprise databases, you can select which analysis projects and settings you wish to import into a enterprise repository that has already been created. You must be a member of the Admin group in the Synthesis enterprise repository to perform this task.
Do the following:

1. Connect with the enterprise database you want to import into.

2. Choose File > Manage Repository > Import from Version 5.

3. In the area at the top of the Import from Version 5 Enterprise Database window, enter the connection information for the Version 5 enterprise database and click Connect.

4. The table shows all of the data and settings in the original database. Use the check boxes to select which data you wish to import and then click OK to start the transfer.

*Note:* If you are importing into a SQL Server database, the Create SQL Server login check box will be displayed at the bottom of the window. This is applicable only if you are importing user accounts. (See SQL Server Logins or Using Windows Impersonation.)

**Conversion Assumptions and Tips**

When you convert data from an Xfmea/RCM++ 5 database, please consider the following assumptions and tips:

- **Conversion to Resources**

  Certain types of information in the Version 5 projects will be converted to resources in the current version. This includes reliability information (which will be converted to models), controls and actions. In these cases, records that have identical properties will be merged into a single resource. For example, if there were two identical actions in the original project, a single action would be created as a resource in the project and used in both locations.

- **Conversion to Security Groups**

  If you are working with secure databases, the access levels and access groups in Version 5 will be converted to security groups in the current version. Specifically:

  - Repository-level security: User permissions assigned by access level in Version 5 will be assigned by the corresponding security group in the current version. For example, if a user had the Admin access level in the original database, then that user will be assigned to the Admin security group in the current version. If there is no corresponding security group in the current version, the user will be imported with no security groups assigned, and a user with "Admin" access level permissions will have to manually assign security groups to the imported user.

  - Project-level security: For each access group in the Version 5 database, a security group will be created in the Synthesis repository. Because the Version 5 access
groups could have different access levels for different users in the same group, it is not possible to automatically determine which permissions should be assigned for the new security group in the current version. Therefore, these groups will initially be assigned the default permissions; you can edit the permissions via the Security Groups tab of the Users and Security window. Projects that had access limited by access group in Version 5 will continue to have their security set by the appropriate security group(s) at the project level in the current version.

- **Configurable Settings for Converted Projects**

When you convert an existing project from Version 5, the application will add new configurable settings for new features that were added in the current version. For example, the configurable PFD Worksheet settings will be added to the interface style, the quantitative values will be added to the occurrence rating scale, etc.

It is important to note that these default settings may need to be modified after the conversion. For details, please consult the "Configurable Settings" section in the Xfmea/RCM++/RBI documentation.

**Converting MPC 3 Databases**

If you have an existing systems and powerplant analysis that was created in MPC 3, it is easy to convert the *.rsm file into a new Synthesis repository.

Choose **File > Open Repository**, select MPC 3 (*.rsm) from the **Files of type** drop-down list, and then browse for the desired file.

When prompted to enter a username and password, enter the administrative login from the old *.rsm file.

**Note:** By default, a converted Version 3 database is a secure database that transfers any user accounts that were defined in the old database. After the new database has been created, the administrator should review the automatically created user accounts and update as appropriate. See **Security Options** for more information about database-level security.

The final step is to use the Tasks Conversion window to review the task records that will be imported and make any updates that may be needed (see details below). Once you have completed the review, click **OK** to start the import.

When the process completes, there will be a new standard database file in the same folder and with the same name as the original *.rsm file. The new file will have the extension *.rsr18 and the original *.rsm file will remain unchanged.
Tasks Conversion Window

The Tasks Conversion window displays a list of all of the tasks defined in the original database and allows you to review how the records will be converted upon import. For any properties that are displayed with blue text, you have the option to change the task record data before it is imported.

Some task properties are handled a bit differently starting in Version 9 than they were in Version 3. Specifically:

- Some of the **Task Types** that were combined in Version 3 are now categorized separately (e.g., Operational Check (OPC) and Visual Check (VCK) are now separate task types).

- In Version 3, the task **Interval** was always stored as a text field. Now, you can choose whether each task's interval will be stored as a text field or if it will instead be recorded as a number with an associated unit (e.g., 2000 flight hours can now be stored as value=2000 and unit = FHr). Numbers may be easier to sort and will also make it possible to perform simulation-based reliability calculations if you choose to import the analysis project to RCM++ or RBI.

- The **Zonal** field from Version 3 is called **Zonal Candidate** in the current version. This is now a yes/no field that can be set to **Yes** only if the failure effect categorization (FEC) is set to 5 or 8 (i.e., a safety issue) and the task type is "General Visual Inspection (GVI)." Also in the current version, the **Zone** field will be enabled only if Zonal Candidate is set to **Yes**.

The following subsections describe the default conversion logic for Task Type, Interval and Zone.

Task Type

For the **Discard** and **Restoration** task types, there is no difference between Version 3 and subsequent versions. The text in the Task Type (New Value) column will be displayed in italics to indicate that this property cannot be changed via the Tasks Conversion window.

<table>
<thead>
<tr>
<th>Task Type (Old Value)</th>
<th>Task Type (New Value)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discard (DS)</td>
<td>Discard (DIS)</td>
</tr>
<tr>
<td>Restoration (RS)</td>
<td>Restoration (RST)</td>
</tr>
</tbody>
</table>

For the remaining task types, the software will use the logic specified below to suggest a task type, but the property will be displayed in blue text to indicate that it can be edited. If you disagree with the default selection, you can choose one of the other eligible task types from the drop-down list, as shown in the following example.
• When the task type was set to **Inspection/Functional Check (IN)** in Version 3, the following logic will be applied in the specified order. For example, if the task description contains both the word "Visual" and the word "Function," the General Visual Inspection task type will be applied by default because the word "Visual" will be matched first.

<table>
<thead>
<tr>
<th>If the task description contains:</th>
<th>The default option is to import the task as:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visual</td>
<td>General Visual Inspection</td>
</tr>
<tr>
<td>Special Detail</td>
<td>Special Detailed Inspection</td>
</tr>
<tr>
<td>Health Monitor</td>
<td>Scheduled Structural Health Monitoring</td>
</tr>
<tr>
<td>Function</td>
<td>Functional Check</td>
</tr>
<tr>
<td>none of the words/phrases listed above</td>
<td>Detailed Inspection (DET)</td>
</tr>
</tbody>
</table>

• When the task type was set to **Lubrication/Servicing (LU)** in Version 3, the default option is to import the task as Servicing (SVC) if the task description contains "Servic" and as Lubrication (LUB) if it does not.

• When the task type was set to **Operational/Visual Check (OP)** in Version 3, the default option is to import the task as Visual Check (VCK) if the description contains "Visual" and as Operational Check (OPC) if it does not.

**Tip:** The task types in Version 9 and later of MPC are determined by the requirements of the MSG-3 guidelines and cannot be changed. However, the abbreviations can be configured to fit your particular preferences. If you want to change the default task type abbreviations (e.g., if you don't want to use DIS for Discard, RST for Restoration, etc.), click the **Task Type Abbreviations** button. The changes that you make in the Define Task Type Abbreviations window will automatically apply to all analyses in the current database. This window is also accessible from **File > Manage Repository > Task Types.**
Interval Type and Interval

Two options are displayed at the top of the Tasks Conversion window to determine how the task intervals will be imported:

- If you choose **Transfer all intervals as text**, the interval type for all imported task records will be set to **Based on Events (Text)** and the interval will be stored as a text field (just like in MPC 3). The Interval (New Value) column will be displayed in blue text to indicate that you can change the text if desired before the import.

<table>
<thead>
<tr>
<th>Interval Type (New Field)</th>
<th>Interval (Old Value)</th>
<th>Interval (New Value)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Based on Events (Text)</td>
<td>2000 ft/hr</td>
<td>2000 ft/hr</td>
</tr>
</tbody>
</table>

- If you choose **Transfer intervals as numeric if possible**, the application will check to see if the original task interval begins with a number and is followed by a space and at least one text character. If it does (e.g., "2000 flt/hr"), the default option is to import it as a number with an associated unit. If not (e.g., "Per Mfg Life Limit"), the default is to import as text. Either way, you have the option to change both the interval type and new value before the import. For example:

<table>
<thead>
<tr>
<th>Interval Type (New Field)</th>
<th>Interval (Old Value)</th>
<th>Interval (New Value)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed (Numeric)</td>
<td>8000 ft/hr</td>
<td>Flight...</td>
</tr>
</tbody>
</table>

**Tip:** If you want to change the units displayed in the drop-down list, click the **Units** button. The changes that you make in the **Unit Settings window** will apply immediately to the tasks that you are currently importing, and also to all other analyses you may later add to this database. This window is also accessible from **File > Manage Repository > Unit Settings**.

The Tasks Conversion window uses a variety of techniques to try to match the text field from Version 3 with one of the specified units in subsequent versions. There will be a match if the
name or abbreviation of a current version unit either starts with or contains the text in the Version 3 field. For some predefined units, the software also recognizes other commonly used abbreviations for the unit (e.g., the software will recognize any of the following abbreviations as flight hours: Flt/Hr, Flight H, Flt H or Flt/H).

If your data set contains a task interval that is not recognized, you can do any of the following:

- Edit the text in the Interval (New Value) column so it will match either the name or the abbreviation of a predefined unit. For example, if the Version 3 task record contains a misspelling for "2000 flight hours," you can click inside the cell and remove the extra i.

- Click the Units button and define a new unit for the database with a name or abbreviation that matches the data you want to import. For example, if the Version 3 task record has an interval of "5 Weeks," you can open the "Unit Settings" window and create a new unit with the name "Weeks."

- Click Cancel to close the Tasks Conversion window then edit the original tasks in MPC 3 before starting the import again.

**Zonal Candidate and Zone**

If all of the following conditions are met, the Zonal Candidate (New Value) column will be set to Yes by default and any information from the Zone field will be transferred during the import:

- The failure effect categorization (FEC) is set to 5 or 8 (i.e., it is a safety issue).
- The Task Type is set to General Visual Inspection (GVI).
- The Zonal property in the original MPC 3 analysis contains the word "Transfer."

If you don’t want the task to be considered for zonal analysis even though it meets the requirements, you can click inside the Zonal Candidate (New Value) column and choose No from the drop-down list. If this column displays No in italics, this indicates that at least one of these conditions is not met and the property cannot be changed.
Importing/Exporting Projects

All ReliaSoft desktop applications make it easy to import or export selected projects from one database to another.

Note that when importing/exporting a project between databases, any resources and FMEAs used by the project will be automatically imported/exported along with the project as local resources, even if they were originally reference resources or global resources. If you do not want the reference resources to be converted to local resources, you must import the both the project and the reference project at the same time. (See Local, Global and Reference Resources.)

To import a project, first choose Project > Management > Import/Export.

In MPC, the Import/Export window opens directly. In all other applications, a wizard displays the options that are relevant for the current application. Select Projects and click OK.

Once the Import Projects or Export Projects window is open, do the following:

1. Use the drop-down list or browse icon to select the database that you want to import from or export to.
   - This can be any existing standard database (*.rsr18) or enterprise database connection file (*.rserp).
   - If you are exporting, you can also use the add icon to create a new standard database to export into.

2. The tree displays the projects that are available to be imported or exported. If desired, you can use the Filter and Find tools to limit the list of projects displayed. (See Project Manager.)

3. Use the check boxes to select which project(s) you want to import/export then click OK to copy the data.
The following considerations apply:

- The names of projects must be unique within each Synthesis repository. If you attempt to import/export a project with a name that already exists in the destination database, the application will automatically increment the name. For example, if "Project1" already exists, the new project might be renamed to "Project1_1."

- If the project has a category, the application will first attempt to match it to an existing category in the destination database. If a matching category does not already exist, and you have the permission to create project categories in the destination database, it will be created automatically.

- If you select a project of a type that you don't have permission to create in the destination database (private, public or reference), it will be converted to a type that you do have permission to create. For example, if you select to import a reference project but you don’t have the "Create and own reference projects" permission in the destination database, the project will be imported as a public or private project, and any links from other projects will be broken.

**Importing/Exporting Project Items or Resources**

When applicable, ReliaSoft applications make it easy to import/export selected project items (e.g., folios, diagrams, plot sheets, Synthesis Workbooks, etc.) or resources (e.g., models, maintenance tasks, etc.) between existing projects. The projects can be in the same database or in different databases.

First, open the project you want to import to or export from. Then open the import/export window, there are two ways:

- If you have selected the **Allow multiple projects** option in the **Synthesis Settings page** of the Application Setup, you can open both projects simultaneously and then drag/drop items from one project to another.

  OR

- Choose **Project > Management > Import/Export**.

  ![Drag and Drop Icon]

  In the wizard, choose **Items** (not available for Xfmea/RCM++/RBI and MPC) or **Resources** (not available for MPC) and click **OK**.
Once the Import window or Export window is open, do the following:

1. Use the drop-down list or browse icon to select the database you want to import from or export to.
   - This can be any existing standard database (*.rsr18) or enterprise database connection file (*.rserp).
   - If you are exporting, you can create a new standard database and project by clicking the icon.

2. Use the tree in the Source Project or Destination Project area to select the project you want to import from or export to. If desired, you can use the Filter and Find tools to limit the list of projects displayed. (See Project Manager.)

3. Use the check boxes in the Items to Import or Items to Export area to select which project items or resources you want to import/export.
   - For project items, this area will display the same folders that appear in the current project explorer. A +/- icon next to the folder indicates that it contains at least one project item that can be imported or exported.
   - For resources, this area will display a folder for each type of resource that exists in the selected project.

4. Click Import or Export to copy the data.

Note: The names of project items and resources must be unique within each project. If you attempt to import/export something with a name that already exists in the destination project, the application will automatically increment the name. For example, if "Folio1" already exists, the new folio might be renamed to "Folio1_1," "Folio1_2," etc.

Keeping Associated Items/Resources Together

The application will automatically copy any item/resource that is linked to the imported or exported item, even if you did not specifically select to import/export them. Some examples:

- A multilplot, such as an overlay plot, side-by-side plot, or 3D plot, will automatically import/export a copy of the folios or diagrams that were used to generate the plot.
Chapter 17: ReliaSoft Common Tools

- A **BlockSim diagram** will automatically import/export a copy of any utilized subdiagrams and resources.
- A **RENO flowchart** will automatically import/export a copy of any utilized subcharts, resources and Synthesis Workbooks.
- A **Synthesis Workbook** or special analysis folio/tool (e.g., allocation analysis, stress-strength analysis, etc.) will automatically import/export a copy of its data sources.
- A **URD** will automatically import/export a copy of the models, maintenance tasks, crews, etc. that were used to build the URD. The same applies to any resource that is built upon another resource.

Note that when importing/exporting project items between databases, the resources are imported/exported as local resources in the destination database, even if they were originally reference resources or global resources. For more information on how importing/exporting affects a resource, see [Local, Global and Reference Resources](#).

**Tip:** If you do not want a RENO flowchart to import/export an associated resource or workbook, you can enclose the resource/workbook name in single quotes to reference it by name only. For example, if you export a diagram that contains a block using the expression 'Model1'(1000), Model1 will not be transferred along with that diagram. If the destination project already contains a model called Model1, that model will be used in simulating the transferred diagram.

### Importing from Excel or Delimited Text Files into a Folio

In Weibull++/ALTA and RGA, it is easy to import data from any of the following file types into a folio.

- Excel files (*.xls, *.xlsx)
- Tab, comma, space and semicolon delimited files (*.txt, *.csv, *.prn, *.smc)

**Tip:** Other ReliaSoft applications use different tools for importing/exporting via Excel (i.e., for importing Bill of Materials data in Lambda Predict and failure mode data in Xfmea/RCM++/RBI and MPC). For more information about those features, please consult the documentation for each particular application.

First, open the project that you want to import into and choose **Project > Management > Import/Export.**
In the wizard, choose **Other file** and click **OK**.

Browse for the file you wish to import from and click **Open**. Note that:

- In DOE design folios, the data will be copied into a new free form folio, where you can then designate columns for factors and responses and analyze the data. If you are importing from an Excel file that has multiple worksheets, the sheet that was active the last time the file was opened will be used.

- In Weibull++/ALTA and RGA, you will need to specify which data will be imported and how it will be mapped to the columns in the particular type of data folio. The rest of this topic describes how to map the data for import into a Weibull++, ALTA or RGA data folio.

**Selecting Which Data Sheets Will Be Imported**

The left side of the utility displays the data from the Excel or delimited text file that is currently selected. If you wish to open a different source file, click **Open**.

If you are importing from an Excel file that has multiple worksheets, use the tabs at the bottom of the window to view and set the import preferences for each sheet.

Use the options at the top of the control panel for each sheet to specify whether the data will be imported.

- **Do not import sheet**: The control panel will not contain any other options and the data will not be imported.

- **Import sheet**: The control panel displays the options you need to either manually map the columns or use a template to automatically apply the same mapping that was used for another file.

**Using the Control Panel to Map the Columns That Will Be Imported**

If you are not using a template, or if you need to modify the settings after an import template has been applied, do the following:

1. Use the **Data Type** drop-down list to specify which type of folio to import into. This can be different for each sheet, and it determines which options will be available in the rest of the control panel.

2. Click inside each column that you wish to import and then click the corresponding button in the control panel to map it to a column in the data folio. This updates the column heading and maps the data to a column in the data folio.

   - If the heading displays a letter, the data in that column will not be imported.
• If the heading displays a name, the data will be imported to the column associated with that name.

• To remove the column mapping, click inside the column and click the corresponding button again.

As an example, the following picture shows data that will be imported into a Weibull++ life data folio. Column A will not be imported. The rest of the data has been assigned to columns that are used in the folios.

3. If you are importing to an ALTA life-stress data folio, use the **Number of Stresses** field to specify how many stress columns will be created in the new folio (maximum = 8). Note that:

   • If you enter a value that is less than the number of columns that were mapped with the **Stress** button, the "extra" stress column data will not be imported.

   • If the number is greater, the additional stress columns will be created in the new folio and you can enter the data later.

4. If the source file contains column headings or other introductory material that should not be imported, use the **Start from Row** field to specify where the actual data begins. For example, in the picture above, the first row contains heading labels so the data import should begin from Row 2.

**Setting the Import Template Directory**

If you will be importing data from multiple files that have the same structure, you can use saved template files (*.waim in Weibull++/ALTA or *.rgaim in RGA) to automatically map the columns for all other similar files that you need to import from.

By default, template files will be stored at C:\Users\<username>\AppData\Roaming\ReliaSoft\<application>\Import Templates. This
directory determines which templates will be displayed in the **Import Template** drop-down list in the control panel. It also sets the default path for saving any new templates you create.

If you want to access templates from a different location, click the **Import Template Directory** button at the top of the window and select a different folder.

### Creating a New Import Template

1. Open a data file and use the control panel buttons to map the columns.
2. Click the **Save** icon in the **Import Template** area on the control panel.
3. Specify a name and click **Save**.

### Applying a Saved Import Template

1. Open the data file and select **Import sheet** to display the rest of the control panel options.
2. Make sure the **Import Template Directory** is set to the folder that contains the applicable template file(s).
3. Use the drop-down list in the **Import Template** area to select the template you want to apply.

The utility will automatically assign the column mappings defined in the template. If desired, you can use the control panel to make further adjustments before import.

4. When you are satisfied with the mapping, click **Import** to create the new folio.

**Tip:** If you make adjustments after applying the template, you have the option to click **Save** in the **Import Template** area to either replace the existing template, or create a new template with a different name.
Importing the Data
When you are ready to import the data, click the **Import** button.

By default, the application will import the data into a new folio. The status bar will display "Import into New Folio," as shown in the following example.

If you prefer to import into an existing folio instead, click the **Import to Existing Folio** button and choose one of the available folios. When you return to the import window, the status bar will now display the name of the selected folio, as shown in the next example.

Using XML in BlockSim and Lambda Predict
In BlockSim and Lambda Predict, you have the option to use XML (extensible markup language) files to import or export system configuration data and item properties. XML files can be used to transfer data to/from other applications or database systems.

In BlockSim, the XML files include the block properties and information about how the blocks are connected in a reliability block diagram or fault tree diagram. They do not include visual aspects such as diagram style settings, block style settings, etc. BlockSim supports both import and export via XML.

In Lambda Predict, the XML files include the structure of the system hierarchy in a prediction folio and some of the item properties. Lambda Predict supports export to XML.

Exporting to XML
To create an XML file, first open the project and then choose **Project > Management > Import/Export > Export**.

In the wizard, choose **Other file** and click **OK**.

Specify the desired pathname/filename and click **Save**. This will export the relevant information for all of the diagrams or prediction folios in the current project. Other project items (such as RENO flowcharts, plots, attachments, etc.) are not included.

Importing from XML
There are two ways to import from an XML file.
If you want to import to a new project in a new standard database:

2. Browse for the file and click Open.

If you want to import to a selected project in an existing standard database or enterprise database:

1. Create a new project or open an existing project that you want to import into.
2. Choose Project > Management > Import/Export > Import.

   ![Diagram]

   In the wizard, choose Other file and click OK.
3. Browse for the file and click Open.

**Attachments**

All ReliaSoft desktop applications allow you to attach URLs and/or files that were created in other applications. This helps you to keep supporting documentation all together in the same place with your analysis. The locations where you can attach files will vary depending on which application you are using.

In all desktop applications, attachments can be either linked or embedded.

- **URL** and **File Link** attachments store the path to a web page or file. This allows you to open the resource in its original location (e.g., Internet, intranet or network directory), provided that the necessary software is installed on your computer and the link is valid. The files themselves are not stored inside the database. When you delete a file link or URL, this simply removes the link, leaving the original file untouched.

  **Note:** If your organization has implemented a Synthesis Enterprise Portal (SEP) website for an enterprise database, note that file link attachments (i.e., stored paths to local files on your computer or network) cannot be created, opened or saved within the SEP due to browser security.

- **Embedded** attachments are always files. For these attachments, the software stores a complete copy of the file inside the database. When you delete an embedded file, the actual file is deleted from the database and this cannot be undone (unless you happen to have a saved backup or restore point that you could roll back to).
The Attachments window manages all of the URLs/files attached to a particular location (e.g., project, resource, hierarchy record or block).

The Add/Edit Attachment window specifies the details of an individual file or URL, and will be displayed whenever you choose to create or edit an attachment.

If you are attaching a file, the Address field will display a Browse icon (裒) so you can select the file to be attached.
If you are attaching a URL, the Name field will be populated automatically as you type the URL into the Address field. This is for your convenience only and you can specify a different name if desired.

**Attachment Locations**

As mentioned above, the locations where you can attach files will vary depending on which application you are using.

*Tip:* In most cases, the caption bar in the Attachments window will provide an indication of which type of attachment you are working with. For example, when you are working with project-level attachments, the caption bar will indicate "Project:" followed by the specific name of the project.

**Project Attachments**

All ReliaSoft desktop applications support attachments at the project level. In all applications, project attachments can be displayed/managed from the Attachments icon in the Project Properties window.

For most applications, project attachments can also be displayed/managed from the Attachments folder in the current project explorer.

In Xfmea, RCM++, RBI and MPC (which do not have a current project explorer), you can also access the project attachments by selecting **Project > Management > Attachments**.

**Resource Attachments**

All of the applications that utilize resources support attachments at the resource level. For example, you can attach a file to a URD, a model, etc.
To access attachments for an existing resource, you can click the **Attachments** icon in the resource’s properties window.

### Hierarchy Attachments

Some applications, including Xfmea, RCM++, RBI, Lambda Predict and MPC, support attachments for individual items or records in a system hierarchy or analysis hierarchy. For example, in Xfmea, you can create attachments for a particular item, or for a particular record in the FMEA for that item.

To access attachments for items or records in a hierarchy, you can double-click inside the Attachments column. (If this column is not displayed on your computer, right-click inside the column headings and choose **Customize Columns**.) You can also choose **Tools > Attachments** on the ribbon tab for the hierarchy that you are currently working with.

For records in an analysis hierarchy (such as FMEA or functional failure analysis), the attachment icon can also be accessed from within the record properties window.

### Block Attachments

BlockSim supports attachments for individual blocks in a diagram. To access attachments for a block, you can click the **Attachments** icon in the Block Properties window.

### Select Existing Text Window

The Select Existing Text window provides a list of existing descriptions that might apply to the current text field or analysis. This can help to save time on data entry, ensure consistency and facilitate brainstorming. The utility is used extensively in applications such as Xfmea, RCM++, RBI and MPC, and it is also available for certain text fields in other ReliaSoft desktop applications.
Chapter 17: ReliaSoft Common Tools

There are two ways this utility might be used:

- **Replace or append text in the current field** - If you click the icon inside a text field, you can select one description and either replace the current text or append the new text to the end.

- **Create one or multiple new records** - If you use one of the ribbon commands in an FMEA or P-Diagram (e.g., Add Multiple Functions > Select Existing Text), you can select multiple descriptions and the utility will use your selection(s) to create new record(s).

The options will vary depending on the record/field type, and whether you are updating a single description or adding new records. The following example shows how the tool may be used to populate the function description in an FMEA.

**Tip:** The descriptions are sorted alphabetically under each heading. When the table has focus, you can type a letter to move to the next description that begins with the letter.

**Project and Item Filters**

This window utilizes the same project and item filters that are available in many other locations throughout ReliaSoft desktop applications. For example, when searching for text for an item in the system hierarchy, you could use a Project Filter to search for analyses performed by Department A and then use an Item Filter to show only those analyses that were modified in the last month.

In addition, when applicable:

- **Current Project** limits the results to data in the current project.
Chapter 17: ReliaSoft Common Tools

- **Current Item Branch** limits the results to those found in the current branch of the system hierarchy.

**Record Filter**
When applicable, the **Record Filter** shows the possible sources for the current record type and field that you can choose to include or exclude. The specific **record types** vary depending on the field.

**Phrase Sets**
FMEA records in Xfmea, RCM++ and RBI also have the option to include text from selected phrase sets.

**Field Text**
Use the drop-down list in the **Field Text** area to specify how to match the specified keywords, then type the keywords into the input box.

- **Contains** returns descriptions that contain the exact string entered.
- **Contains Any** and **Contains All** allow you to enter multiple keywords (separated by commas) and returns descriptions that contain at least one (any) or all of the keywords entered.
• **Begins With** returns descriptions where the exact string entered appears at the start of the field.

• **is** returns descriptions where the exact string entered matches the whole field.

**Record Filter Options**
When the descriptions can be obtained from more than one type of analysis (e.g., when PFMEA failures can be copied from FMEA causes, or when control plan operations can be copied from PFD Worksheet operations), the headings in the table identify the source. You can use the Record Filter to specify which source(s) to include.

### FMEAs

<table>
<thead>
<tr>
<th>FMEA Functions</th>
<th>System Hierarchy Items</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>P-Diagram Ideal Responses</td>
</tr>
<tr>
<td></td>
<td>PFD Worksheet Operations</td>
</tr>
<tr>
<td>FMEA Failures</td>
<td>P-Diagram Error States</td>
</tr>
<tr>
<td></td>
<td>FMEA Causes</td>
</tr>
<tr>
<td></td>
<td>PFD Worksheet Product Characteristics</td>
</tr>
<tr>
<td>FMEA Effects</td>
<td>FMEA Failures</td>
</tr>
<tr>
<td>FMEA Causes</td>
<td>P-Diagram Change Over Times</td>
</tr>
<tr>
<td></td>
<td>P-Diagram Control Factors</td>
</tr>
<tr>
<td></td>
<td>P-Diagram Piece-to-Piece</td>
</tr>
<tr>
<td></td>
<td>PFD Worksheet Process Characteristics</td>
</tr>
<tr>
<td>FMEA Controls</td>
<td>Control Plan Methods</td>
</tr>
<tr>
<td></td>
<td>DVP&amp;R Test/Specification Methods</td>
</tr>
<tr>
<td>FMEA Actions</td>
<td>DVP&amp;R Test/Specification Methods</td>
</tr>
</tbody>
</table>

### P-Diagrams

<table>
<thead>
<tr>
<th>Input Signal</th>
<th>System Hierarchy Items</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control Factors</td>
<td>FMEA Causes</td>
</tr>
<tr>
<td>Error States</td>
<td>FMEA Failures</td>
</tr>
</tbody>
</table>
### Ideal Response

<table>
<thead>
<tr>
<th></th>
<th>FMEA Functions</th>
</tr>
</thead>
</table>

### Piece-to-Piece

| Analysis Plan Assumptions | FMEA Causes | PFD Worksheet Product Characteristics |

### Usage

| Analysis Plan Assumptions |

### Environment

| Analysis Plan Assumptions |

### Change Over Time

| Analysis Plan Assumptions | FMEA Causes |

---

### Control Plans, PFD Worksheets and DVP&Rs

<table>
<thead>
<tr>
<th>Control Plan Part/Process Number</th>
<th>FMEA Functions</th>
<th>PFD Worksheet Operations</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Control Plan Process Name/Operation Description</th>
<th>FMEA Functions</th>
<th>PFD Worksheet Operations</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Control Plan Product Characteristic</th>
<th>PFD Worksheet Product Characteristic</th>
<th>FMEA Causes</th>
<th>FMEA Failures</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Control Plan Process Characteristic</th>
<th>PFD Worksheet Process Characteristics</th>
<th>FMEA Causes</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Control Plan Method</th>
<th>FMEA Controls</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>PFD Worksheet Operation Description</th>
<th>System Hierarchy Items</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>DVP&amp;R Test/Specification Method</th>
<th>FMEA Controls</th>
<th>FMEA Actions</th>
</tr>
</thead>
</table>

---
Check Spelling

ReliaSoft desktop applications offer the ability to check the spelling of your text. This utility is available in different places within the software. For windows that offer the spell check functionality (e.g., Project Properties window, etc.), the Check Spelling icon will be displayed within the window itself. For data sheets, spreadsheets and system hierarchies that offer the functionality, the Check Spelling icon will be available on the ribbon and you can access it by choosing **Home > Edit > Spelling**.

**Note:** In system hierarchies (Xfmea, RCM++, RBI, MPC and Lambda Predict), the utility will check the property fields of the selected item only. This means that sub-items and text in analysis tabs, such as the FMEA tab in Xfmea, are not checked.

Whenever text that is not in the application's dictionary is found, the Check Spelling window displays the text in question and offers a list of suggestions to verify the error or confirm the correction, as shown in the following example.

- **Ignore Once** ignores the current instance of the highlighted word but continues to highlight it if the same word appears again.
- **Ignore All** ignores all instances of the word in the current form.
- **Add to Dictionary** adds the highlighted word to the dictionary on your computer so the spell checker will not treat it as a misspelling. The dictionary file is saved in the default Documents folder on your computer (e.g., My Documents\ReliaSoft\Dictionaries).
- **Change** replaces the current instance of the highlighted word with the word that is currently selected in the **Suggestions** area. If no word is selected, the first one will be...
used. Double-clicking a word in the Suggestions area is another way to change the highlighted text.

- **Change All** replaces all instances of the highlighted word with the word that is currently selected in the Suggestions area. If no word is selected, the first one will be used.

- **Options** opens the Spelling Options window, which provides additional settings to how the spell checker functions:
  
  - The **General options** area provides a list of the types of text that can be ignored by the spell checker (e.g., numbers, e-mail addresses, etc.). Select or clear each check box to specify how the spell checker will work on your computer.
  
  - In the **Edit custom dictionary** area, the **Edit** button opens a window that displays all of the words that you have added to the custom dictionary on your computer. You can edit the custom dictionary by adding or removing words in the list and then clicking **OK**.
  
  - **International dictionaries** allows you to choose the language of the dictionary that will be used on your computer.

  - **Undo Last** reverses the last change that was made.

**Results Window**

The Results window is used in many ReliaSoft applications to show detailed calculation results. From this window, you can edit the results, copy the results to the Clipboard or print the results.

- **Paste** pastes the contents of the Clipboard into the current control.

- **Cut** cuts the selected text to the Clipboard. Data stored in the Clipboard can be pasted into this and other applications.

- **Copy** copies the selected text to the Clipboard. Data stored in the Clipboard can be pasted into this and other applications.

- **Paste Special** opens the Paste Special window, which allows you to paste specific cell contents or attributes (such as formulas, formats, or comments) from the Clipboard.

- **Quick Print** sends the current document directly to the default printer without making changes.

- **Print** opens the Print window, which allows you to specify the printer and the printing options.
• **Send to Excel** allows you to save the current selection as a Microsoft Excel (*.xls) file and then opens that file in Excel, if it is installed on your computer.

Note that the Results window may contain multiple sheets, accessible via the page index tabs at the bottom of the window.

**Quick Parameter Estimator (QPE)**

The Quick Parameter Estimator (QPE) allows you to estimate the parameters of a distribution based on information you have about the reliability of a product, the probability of an event occurring or the typical duration of a task. In all ReliaSoft desktop applications, you can open the QPE from the Model properties window or the Model wizard by clicking the QPE icon.

In Weibull++/ALTA, it's also accessible from the Home tab of the ribbon and several analysis interfaces (including the Weibull++ life data folio, the Monte Carlo and SimuMatic utilities, and the Expected Failure Times Plot).

The QPE includes a Wizard view and an Expert view, described below. You can toggle between the different views by clicking the Use Expert or Use Wizard button at the bottom-left corner of the window.

• **The Wizard view** automatically selects a distribution and estimates that distribution's parameters based on your responses to a series of questions. The first page of the Wizard view asks you to choose among three different types of models that you can build with the QPE. Subsequent pages will ask more specific questions related to your selected model.

• **The Expert view** allows you to estimate the parameters of a distribution using either two unreliability values at specified times or one unreliability value and the other parameter(s) of the distribution. Unlike the Wizard view, you must select a distribution to solve the parameter(s) for.

**Quick Parameter Estimator Wizard View**

To use the Wizard view of the Quick Parameter Estimator (QPE), simply follow the prompts on each page. The first page will present and describe three different types of models that you can build with the QPE. Below are the three models and the kind of information you'll need to provide in subsequent pages.
To build a **Reliability model** you need to provide information about:

- How age affects the product's reliability.
- The product's intended design life and the estimated warranty time.
- Best-case, worst-case and most likely unreliability estimates for the product at the end of the design life and warranty time.

To build an **Event occurrence model** you need to provide information about:

- Whether age affects the probability of the event's occurrence.
- Best-case, worst-case and most likely estimates for how often the event will occur.

To build a **Task duration model** you need to provide information about:

- Best-case, worst-case and most likely estimates for how long it will take to complete the task.

The last window will display the tool's selected distribution and the calculated parameters. It will also provide one of the two options described below.

- If you opened the QPE from an analysis folio or utility, the **Update** button will be available in case you wish to update that window using the selected distribution, calculated parameters and selected units.
- In Weibull++/ALTA, if you opened the QPE from the ribbon, the **Finish & Copy** button will be available in case you wish to copy the parameters results to the Windows Clipboard.

### Quick Parameter Estimator Expert View

Follow the steps below to use the Expert view of the Quick Parameter Estimator (QPE):

- Choose a distribution from the **Distribution** drop-down list. This is the distribution that you will solve the parameter(s) for. Then choose the appropriate time units from the **Units** drop-down list.
  - If you are not sure which distribution to select, consider using the **Wizard view** of the QPE instead.
  - Your choice of time units applies to all time inputs and applicable parameters of the distribution (such as the eta parameter when the Weibull distribution is used).
• Select an appropriate option in the **Quantification Method** area.
  
  • The **Unreliability and a Parameter** method solves for one parameter of the distribution. It requires one unreliability point (i.e., an unreliability value at a specified time) and the values of all the parameters of the selected distribution except the parameter you will solve for.

  • If you select this method, you must then enter one unreliability point in the **Point #1** area. For example, if you believe that your product has an unreliability of 10% at 100 hours, then you would enter **100** in the **Time** field and **0.10** in the **Unreliability** field.

  • In the **Solve for Parameter** area, select the parameter that you wish to solve for. The remaining parameters in this area will have input fields enabled. Enter the known values of these parameters.

  • The **Two Unreliability Points** method solves for all the parameters of the distribution. It requires two unreliability points that you will provide in the **Point #1** and **Point #2** areas.

    **Tip:** If you are building an event occurrence or task duration model, you can treat an "unreliability" point as the probability that an event will occur or that a task will be completed by a specified time. For example, if you are modeling the probability of an event's occurrence and you believe that there is a probability of 30% that the event will occur before 150 hours, then you would enter **0.3** in the **Unreliability** field and **150** in the **Time** field.

• Click **Calculate** to solve for the unknown parameter(s).

• Click the **Update** button to update the model using the selected distribution, calculated parameters and selected time units.

---

**Quick Parameter Estimator (ALTA)**

In ALTA only, another version of the **Quick Parameter Estimator (QPE)** allows you to estimate the parameters of a model based on information you have about the reliability of a product at normal and accelerated stress levels. You can open the QPE from the ribbon by choosing **Home > Synthesis > Quick Tools > Quick Parameter Estimator (ALTA)**.

You can also open the ALTA QPE from the ALTA life-stress data folio (by leaving the folio's data sheet empty and clicking **Calculate**), as well as the stress-dependent Monte Carlo and stress-dependent SimuMatic utilities.
Follow the steps below to use the ALTA QPE:

- The first page of the window will be used to estimate the product's mean life under normal stress conditions.
  - Choose a model from the Model drop-down list. This is the model that you will solve the parameter(s) for. Then choose the appropriate time units from the Units drop-down list.
    - Your choice of time units applies to all time inputs and applicable parameters of the model (such as the eta parameter when the Weibull distribution is used).
  - Select an appropriate option in the Quantification Method area:
    - The Unreliability and a Parameter method solves for one parameter of the model. It requires one unreliability point (i.e., an unreliability value at a specified time) and the values of all the parameters of the selected model except the parameter you will solve for.
      - If you select this method, you must then enter one unreliability point for normal use conditions in the Point #1 area. For example, if you believe that your product has an unreliability of 10% at 100 hours under normal use conditions, then you would enter 100 in the Time field and 0.10 in the Unreliability field.
      - In the Solve for Parameter area, select the parameter that you wish to solve for. The remaining parameters in this area will have input fields enabled. Enter the known values of these parameters.
    - The Two Unreliability Points method solves for all the parameters of the model. It requires two unreliability points under normal use conditions that you will provide in the Point #1 and Point #2 areas.
  - In the Use Stress Level area, you must enter the stress level that the product will experience under normal conditions. In multi-stress situations, this stress level will be a combination of stress values for each stress type.
    - If the Number of Stresses field is enabled, enter the number of stresses that will be used in your model. (Note that different models have different requirements for the number of stresses that can be used.)
    - Click the arrow inside the Use Stress Value(s) field. In the table that appears, enter a stress value for each stress type. If there are multiple stress values, they will appear in the field separated by semicolons.
• Click **Next >** to go to the Life at Each Stress Level page. The **Use Stress Level** area of the page will display the product’s mean life at the specified use stress level based on your previous inputs. In the **Accelerated Level 1** area, you must enter the estimated mean life for the product at an accelerated stress level.

• To enter the accelerated stress level, double-click inside the **Stress Value(s)** field. In the table that appears, enter the stress value for each stress.
In the **Characteristic Life** field, enter the product’s characteristic life at the associated accelerated stress level.

- For the Weibull distribution, the characteristic life is equal to the value of the eta parameter (i.e., the time at which unreliability = 63.2%).
- For the lognormal distribution, it is equal to Exp(Log-mean) (i.e., the time at which unreliability = 50%).
- For the exponential distribution, it is equal to the mean life.

**Note:** The number of accelerated stress levels you must provide life estimates for will equal the number of stresses that will be used in the selected model. For example, if the model uses two stress types, as shown above, then there will be an Accelerated Life 2 area in which you must provide a characteristic life estimate for a second accelerated stress level.

- Click **Next >** again to see the calculated parameters.
  - If you opened the QPE from another utility, such as the ALTA Monte Carlo tool, you may click the **Update** button if you wish to update the Monte Carlo tool with the model, parameters and time units defined in the QPE.
  - If you opened the QPE from the ribbon, you may click the **Finish & Copy** button if you wish to copy the results to the Windows Clipboard.
Chapter 18: Resources

In ReliaSoft applications except MPC, resources contain various types of information that can be shared between analyses. Resources may be created in one application and then shared with other ReliaSoft applications where they may be relevant. When the resource is updated with new information, the change is reflected in all analyses that rely upon it.

An example of a resource is a model that represents a product's probability of operating successfully over time. The model may be defined manually or published from an application such as Weibull++/ALTA, RGA or Lambda Predict. Then it can be used in applications such as BlockSim, Xfmea, RCM++ or RBI as part of the universal reliability definition (URD) of a particular component/assembly.

**Note:** In a secure database, the ability to create, edit and delete resources is available only if the user a) is the project owner, b) has the applicable "resources" permissions, or c) has the applicable "manage all projects" permissions.

Types of Resources

The following tables describe the types of resources that you can use in different ReliaSoft applications. These resources can be created while you're performing an analysis and also from the Resource Manager. (In a secure database, the ability to create, edit and delete resources is available only if the user a) is the project owner, b) has the applicable "resources" permissions, or c) has the applicable "manage all projects" permissions.)

### Used in Multiple Applications

<table>
<thead>
<tr>
<th>Resource</th>
<th>Used In</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Universal reliability definitions (URDs)</strong></td>
<td>BlockSim, RCM++,</td>
</tr>
<tr>
<td></td>
<td>Xfmea, RBI</td>
</tr>
<tr>
<td><strong>Variables</strong></td>
<td>BlockSim, RENO</td>
</tr>
<tr>
<td>store numerical values that can be</td>
<td></td>
</tr>
<tr>
<td>programmatically varied during simulation.</td>
<td></td>
</tr>
</tbody>
</table>
Models can represent probabilities, durations or costs, either fixed or time-dependent. They are used by other resources to represent the reliability of a component, the duration of a task, the expected cost of a repair, etc.

Can be published from analyses in Weibull++, ALTA, BlockSim, RGA and Lambda Predict, or created manually. Used in BlockSim, RENO, Xfmea, RCM++ and RBI.

Tasks represent maintenance activities:
- **Corrective** tasks are unplanned maintenance performed when a failure occurs.
- **Scheduled** tasks can include preventive maintenance, inspections and on condition maintenance.

Tasks can be used in BlockSim, RCM++, RBI.

Task packages represent groups of tasks that are performed together at scheduled intervals.

Task packages can be used in BlockSim, RCM++, RBI.

Crews represent the personnel who will perform a maintenance task.

Crews can be used in BlockSim, RCM++, RBI.

Spare part pools determine whether a spare part will be available, how long it will take to obtain and how much it will cost.

Spare part pools can be used in BlockSim, RCM++, RBI.

Metrics display any numerical value of interest, and track how it changes over time.

Metrics can be used in all applications except MPC via the Project Planner; analyses in Weibull++, ALTA, BlockSim, RGA, Xfmea, RCM++ and RBI.

Maintenance groups are used to model situations in which some event within the group can trigger maintenance or state changes for other components/assemblies.

Maintenance groups can be used in BlockSim, RCM++, RBI.

Mirror groups are used to represent the exact same component/event in more than one location within your analysis.

Mirror groups can be used in BlockSim, RCM++, Xfmea, RBI.
### Actions

Describe specific assignments that need to be performed.  

All applications via [My Portal](#): [Project Planner](#) and FMEAs in RCM++, RBI and Xfmea.

### Controls

May be used in FMEAs and/or control plans to represent methods to reduce or eliminate the risk associated with potential failures.

RCM++, Xfmea, RBI

### Profiles

Represent values that vary with time. They can be used in ALTA to describe stress levels under test conditions, or in BlockSim process flow simulation diagrams (if supported by your license) to describe patterns of throughput.

ALTA, BlockSim

---

### Used Only in BlockSim

<table>
<thead>
<tr>
<th>Resource</th>
<th>Used In</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Switches</strong></td>
<td>BlockSim</td>
</tr>
<tr>
<td>Describe how the activity transfers between active and standby blocks in BlockSim's standby containers/gates.</td>
<td></td>
</tr>
<tr>
<td><strong>Maintenance templates</strong></td>
<td>BlockSim</td>
</tr>
<tr>
<td>Define the activities that will be performed during a maintenance phase in a phase diagram.</td>
<td></td>
</tr>
<tr>
<td><strong>Flow groups</strong></td>
<td>BlockSim</td>
</tr>
<tr>
<td>Are used to model situations in which meeting a particular flow threshold can trigger maintenance tasks. These groups are used only in BlockSim process flow simulation diagrams (if supported by your license).</td>
<td></td>
</tr>
</tbody>
</table>

### Used Only in RENO

<table>
<thead>
<tr>
<th>Resource</th>
<th>Used In</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>RENO functions</strong></td>
<td>RENO</td>
</tr>
<tr>
<td>Store equations that are evaluated based on input values passed to the function during simulation.</td>
<td></td>
</tr>
<tr>
<td><strong>RENO static functions</strong></td>
<td>RENO</td>
</tr>
<tr>
<td>Store equations that are evaluated before simulation begins.</td>
<td></td>
</tr>
</tbody>
</table>
**RENO simulation definitions** are used to trigger simulation of a BlockSim diagram from within a RENO flowchart, allowing you to use one or more results from the simulation in the flowchart.

**RENO tables** store arrays of values in rows and columns.

---

## Local, Global and Reference Resources

There are three types of **resources**:

- **Local resources** can be used only within the project in which they were created, and are therefore available only to users with permissions within that project.

- **Reference resources** (which are resources created in a reference project) can be used in any project throughout the database. However, in a secure database, they can be created and edited only by users who have the **"Create/edit/delete local resources" permission** within the reference project. These resources can be selected by any user who has at least the "Read" permission in the reference project. Users without permissions in the reference project can see the reference resources wherever they are used, but they will not be able to select or modify them.

- **Global resources** can be used in any project throughout the database. In a secure database, they can only be created and edited by users who have the “Create/edit/delete global resources” permission. However, they can be selected by any database user.

To make a resource global, select it in the Resource Manager and choose **Home > Actions > Make Global**.

Making a resource global cannot be undone and this option is not available for all resource types. If you make a resource global, any resources assigned to it will become global as well (e.g., if a URD has an assigned model, making that URD global will also make the model global, regardless of whether it was originally local or reference).

## Parent/Child Resource Relationships

Certain resources can have other resources assigned to them (e.g., URDs can have models and tasks assigned to them, tasks can have models, crews and spare part pools assigned to them, etc.). This can be considered a "parent/child" relationship.
When you create a resource from within its parent, the child resource will be of the same type as its parent. For example, if you are working with a global URD and you add a model to it, the model will be global. If you are working with a reference task and you add a crew to it, the crew will be added to the reference project that contains the task.

When you assign existing resources to a parent resource, the following rules apply:

- Any resource assigned to a reference resource must be either a reference resource within the same project or a global resource (e.g., a local model cannot be assigned to a reference URD, nor can a model in "Reference Project 2" be assigned to a URD in "Reference Project 1").

- Any resource assigned to a global resource must be either a reference resource or a global resource (e.g., a local model cannot be assigned to a global URD).

**Keeping Resources Together**

The application will automatically keep copies of a project's resources and linked FMEAs when the project is restored, checked out, imported or exported.

- When you create a **restore point**, any reference resources, global resources or linked FMEAs used in the project are converted to local resources/FMEAs and stored with the backup.

- When you **check out** a project for local editing, any reference resources, global resources or linked FMEAs used in the project are converted to local resources/FMEAs and stored with the project.

- When **importing/exporting a project item** that uses reference resources, global resources or linked FMEAs:
  - If you import/export within the same database, the references will remain unchanged.
  - If you import/export between databases, the destination project will contain local copies of the original resources/FMEAs.

- When **importing/exporting a project**:
  - If you import/export a project that uses global resources, the destination project will contain local copies of the original resources.
  - If you import/export a project that uses reference resources or linked FMEAs:
    - The references/FMEAs will be maintained if you also import/export the reference project at the same time.
If you don’t import/export the reference project at the same time, the new project will instead contain copies of the original resources/FMEAs.

Creating and Selecting Resources
This topic describes how to use resource wizards to create and edit resources while you’re performing an analysis or creating a URD. In addition, you may also need to:

- Use the Resource Manager to see all of the resources that are available to use in the current project. In addition to creating and editing resources, the manager also allows you to:
  - Delete resources that are no longer needed.
  - Create global resources that are available to all projects in the database.
- Publish a model that is linked to an existing analysis.

(In a secure database, the ability to create, edit and delete resources is available only if the user a) is the project owner, b) has the applicable "resources" permissions, or c) has the applicable "manage all projects" permissions.)

Opening a Resource Wizard
Throughout all ReliaSoft desktop applications, the availability of a resource wizard is usually indicated by an ellipsis (...) or an arrow in the resource field. Simply click twice in the field to open the wizard.
Tip: If a resource is already assigned in the field, you can edit it directly without opening the wizard by clicking the Edit icon that appears in the field.

Back Arrow and Main Page
Each wizard contains multiple pages with different options on each page. If the option you need is not immediately visible, you can click the Back arrow to see the Main page, which shows all the options that are applicable for the current situation.

As an example, the following pictures show some of the different options that will be available on the Main page for specific situations and resource types.
Chapter 18: Resources

If a model hasn't been defined...

If a task hasn't been defined...

If a task has already been defined...

Selecting an Existing Resource

The Select page of the wizard displays a list of existing resources that meet the criteria specified on the Settings page. You can then further limit the list by typing inside the text box.

As an example, the following pictures show a situation in which the settings are configured to display up to 2,000 models (more resources take longer to load) from the current project only (called local resources), and the user has selected to see only the ones in which the name includes “bulb.”
In addition, for model resources only, you must specify whether you want to display the model parameters in the list (which also takes longer to load); and if so, the number of decimal places (called Parameter Precision) and the point at which the software will switch to scientific notation (called Parameter Tolerance).

To change the initial criteria for the list, click the Back arrow and then click the Settings button on the main page.

Alternatively, if you need more information about the available resources and/or a wider range of filtering tools, you can click the icon to open the Select Resource window.

Creating a Resource
In most wizards, you can click the Create New button or icon to create a new resource.

In the model wizard, click the button or icon for the type of model you want to create:

- New Constant
- New Distribution
- New Dynamic

Editing a Resource
If a resource has already been assigned, you can view and/or edit its properties by clicking the View/Edit button or icon in the field or in the wizard.

Any changes you make will apply everywhere that the resource is used. This includes analyses in other ReliaSoft applications.

Removing a Resource
If a resource has already been assigned, you can remove it from this location by clicking the Remove button or icon.
The resource will remain in the database for use in other locations. If you want to completely remove a resource from the database, you’ll need to use the Resource Manager or Select Resource window.

**Universal Reliability Definitions (URDs)**

A universal reliability definition (URD) describes a set of reliability and maintenance characteristics for a particular component/assembly. Like any other resource, you can create or edit URDs while you're performing a relevant analysis, and from the Resource Manager.

**Note:** Depending on where you are using a URD, only those properties that are relevant are applied. For example, if you apply a URD to a block in an analytical diagram in BlockSim, only the failure model associated with the URD will be applied to the block.

**Naming the Resource**

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the resources you need for your analyses.

**Hierarchy Tab**

Use the Hierarchy tab to view and/or edit the URD's properties. You can choose or create:

- A **model** to describe the behavior associated with the URD. This can be a reliability model, a probability of failure model or an event occurrence model.

- A **corrective task** that describes the maintenance action taken to restore a failed component to operational status.

- Zero, one or many **scheduled tasks** that describe the preventive maintenance, inspections and/or on condition maintenance tasks. The order in which the tasks are displayed reflects the priority with which tasks that are scheduled in the same way (see Task Scheduling) will be performed; for example, if there are two tasks scheduled based on interval and they conflict, the task higher in the priority list will be performed and the lower priority task will be disregarded. You can use the up and down arrows in the cells in this column to move the tasks up and down the priority list.
Additionally, the following are shown:

- **Identifiers** contains additional identifying information that can be used to search for this resource.
- **History** provides information about when the record was created and last updated. If the [history log](#) has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the record.
- **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

### Filtered Tab

Use the Filtered tab to see the resources that are shown in the Hierarchy tab, filtered by resource type. For example, the following picture shows the crews used in this URD.

Double-click any row to view or edit the properties of the resource.

You can change the columns shown in this view by clicking the **Column Chooser** icon.
Chapter 18: Resources

**Trace Usage**
For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

**Models**
In ReliaSoft applications, *models* can represent probabilities, durations or costs, either fixed or time-dependent. They are used by other resources to represent the reliability of a component, the duration of a task, the expected cost of a repair and many other characteristics.

Like any other resource, you can create or edit models while you’re performing a relevant analysis, and from the Resource Manager. In addition, you can publish models that are based on an existing analysis (e.g., a life data analysis in Weibull++, a diagram in BlockSim, etc.).

This topic describes the properties for both types of models. The interface will vary based on the particular situation.

**Naming the Resource**
For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the resources you need for your analyses.

**Associated Analysis**
In published models only, the Associated Analysis area identifies the analysis that the model is based on. If the published model reflects the latest analysis results, the status is "Synchronized." If the analysis has been modified since the model was last published, the status is "Out of Sync."

*Tip:* If you have the ability to open the original analysis (i.e., if the required ReliaSoft application is activated on your computer and your user account has permissions to access the analysis), the Source will be configured as a link and there will also be a Data Source button at the bottom of the window.

**Model Category**
The category determines where and how a model can be used. If you are using a resource wizard to create a new model, it will be assigned automatically based on what’s relevant for the
current field. If you are publishing a model or creating it from the Resource Manager, you must select the appropriate option. Once a model has been created, you cannot change its category.

- **Reliability, Probability of Failure** and **Event Occurrence** models represent a likelihood of occurrence.

- **Duration** models represent a length of time.

- **Cost per Unit Time** models are used for costs that accrue over time (e.g., the crew charges $50 per hour).

- **Cost** models are used for costs that don't depend on time (e.g., the part costs $100 or the crew charges $50 per service call in addition to their hourly rate).

**Model Type**

- **A distribution** model represents behavior that varies based on factors such as time and/or applied stress. For a published model, the inputs and parameters will be specified automatically based on the associated analysis. For manually created models, you can:
  
  - Select a distribution from the drop-down list and then enter the required parameter(s).
  
  - Use the **Quick Parameter Estimator (QPE)** to estimate the parameters of a distribution based on what you know about the behavior.

**Tip:** A published model includes one additional parameter that is not relevant for manually created models. **PNZ** stands for **percent non-zero**. A value of 1 indicates that there are no zero failure times in the data set (which is the most common scenario in life data analysis). A decimal value indicates that the data set does include zero failure times (such as out-of-the-box failures, for example). In such cases, the parameters are calculated based on the non-zero failure times, and then the PNZ value is used as a multiplier when calculating certain metrics (e.g., reliability, unreliability).

- **A constant** model represents a fixed probability (e.g., 0.9), duration (e.g., 2 hours) or cost (e.g., $10 or $10 per hour).

- **A dynamic** model represents a fixed probability, duration or cost, based on a specified variable. The variable can then be programmatically varied during simulation in one of two ways, thereby changing the value of the model for successive simulation runs.
  
  - For RENO flowcharts, the variable can be varied using RENO’s sensitivity analysis/multiple analyses features.
When simulating a simulation worksheet, the values used by the variable will be specified in the worksheet.

When dynamic models are used outside of these circumstances, they are treated as constant models using the defined initial value of the variable.

**Additional Tools**
Additionally, the following are shown:

- **Identifiers** contains additional identifying information that can be used to search for this resource.

- **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the record.

- **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

**Publishing Models**
This topic provides general information about how to create and work with published models, which are model resources that have been published from and continue to be associated with an existing analysis. For information about additional options and requirements in specific applications, see:

- "Publishing Fitted and Analytical Models" in the BlockSim documentation.
- "Publishing Models from R-DOE Results" in the Weibull++/ALTA documentation.
- "Publishing from Failure Rate Predictions" in the Lambda Predict documentation.
- "Publishing Models from Analysis Results" in the RGA documentation.

The Synthesis Platform does not automatically update the published model when something changes in the original analysis, but users have the option to republish the model at any time. For any other analysis that uses the model, the change will be reflected the next time that other analysis is recalculated/resimulated.
Publishing Tools

For most ReliaSoft desktop applications, the following model publishing tools are found on the Publishing page of the control panel. In Lambda Predict, they are located on the Publishing tab of the Properties panel.

- **Publish Model** publishes the analysis to a model, making it accessible to all ReliaSoft applications.
  - If the analysis has never been published, this will create a new model and you will be prompted to specify the name and category.
  - If the analysis has already been published, this will update the existing model and change the model's status from "Out of Sync" to "Synchronized."

- **Publish to Existing Model** allows you to select an existing model (using the Select Resource window) and replace it with an association to the current analysis.

- **Trace Usage** opens the Dependency Viewer, which allows you to see where the model is used.

- **View Model** displays the properties for the published model. This information will be available to any user who is considering whether to use the model in a particular analysis.

- **Remove Association** removes the link between the current analysis and the published model. The model will continue to be a resource in the database but it can no longer be synchronized with the analysis.

Published Model Summary

After the model has been published, the summary table in the control panel (or Publishing tab in Lambda Predict) will display the model's name, along with the following details:

- When the **Status** changes from "Unpublished" to "Published," the label becomes a link that opens the model's properties window.

- **Linked?** indicates whether the published model has been used. If the model is in use, you can click the link in this field to open the Dependency Viewer.

- **Synchronized?** displays "Synchronized" if the published model reflects the latest results from the associated analysis. If that analysis has been modified since the model was last published (e.g., if more data has been added, an analysis setting has changed, etc.), the status will display as "Out of Sync."

- The **Created By** and **Modified By** fields display the names of the users who created and last updated the model. Click either of the links to see the dates and times.
Model Basis and Status

When a model has been published from an existing analysis, its properties window will include the following additional information:

<table>
<thead>
<tr>
<th>Model Name</th>
<th>Weibull_Folio1_Data1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td>Folio1/Data1</td>
</tr>
<tr>
<td>Application</td>
<td>Weibull++</td>
</tr>
<tr>
<td>Type</td>
<td>Standard Folio</td>
</tr>
<tr>
<td>Status</td>
<td>Synchronized</td>
</tr>
</tbody>
</table>

- **Source** is the ReliaSoft analysis that the model was published from.
- **Application** is the ReliaSoft application that is required to view/edit the original analysis.
- **Type** is the kind of folio or diagram that the model is based on. For example, this might be a life data folio in Weibull++, an analytical diagram in BlockSim, a failure rate prediction in Lambda Predict, etc.
- **Status** displays "Synchronized" if the published model reflects the latest results from the associated analysis. If that analysis has been modified since the model was last published (e.g., if more data has been added, an analysis setting has changed, etc.), the status will display as "Out of Sync."

**Tip:** If you have the ability to view the original analysis (i.e., if the required ReliaSoft application is activated on your computer and your user account has permissions to access the analysis), the **Source** will be configured as a link and there will also be a **Data Source** button at the bottom of the window.

Tasks

To properly analyze repairable systems, we first need to understand how components in these systems are restored (i.e., the maintenance activities that are performed on the components). In general, maintenance is defined as any action that restores failed units to an operational condition or keeps non-failed units in an operational state. For repairable systems, maintenance plays a vital role in the life of a system. It affects the system’s overall reliability, availability, downtime, cost of operation, etc.
In ReliaSoft applications, maintenance activities are represented using tasks, which are resources that can be shared among analyses and can be managed via the Resource Manager. There are two basic kinds of tasks, which comprise four task classes:

- **Corrective tasks** are the action(s) taken to restore a failed component to operational status. These cannot be scheduled, as the component's exact failure time is not known before it happens.
- **Scheduled tasks** can be performed on a known schedule, based on time, component condition or other factors. These include:
  - Preventive tasks
  - Inspection tasks
  - On condition tasks

Tasks are assigned to URDs, which are in turn used to represent a set of properties that can be applied to standard blocks in RBDs and to events in fault trees.

The Maintenance Task window allows you to create, view and edit all classes of maintenance tasks. It can be accessed by clicking the Create New or View/Edit icon in the Task wizard, which is accessed from Task fields in properties windows (e.g., the Corrective Maintenance Task field in the Universal Reliability Definition window).

It can also be accessed from the Corrective Tasks and Scheduled Tasks pages of the Resource Manager by choosing Home > Edit > Add, by selecting a task and choosing Home > Edit > View or by double-clicking a task.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the resources you need for your analyses.

The following options must be configured for all classes of tasks. Configuration options that are specific to particular task classes are presented in the corresponding sections.

- **Basic Task Properties**
  - **Task duration** allows you to assign a model, which may represent a fixed time or a distribution, to describe the duration of the task. You can choose an existing model or create a new one. If no model is assigned, it is assumed that the task has a duration of zero (i.e., immediate repair).
- **Crew for task** allows you to choose or create one or more crews that can perform the task. If multiple crews are assigned to the task and a crew is needed, they will be checked for availability in the order in which they are displayed in this list. Use the Priority Up and Priority Down arrows that appear when you click a crew name in the list to move it up and down in the list. If a crew is needed and all crews are engaged, the crew with the shortest wait time is chosen to perform the task.

If no crew is assigned, it is assumed that the work will be done by some undefined crew that is always available.

- **Restoration** These properties allow you to specify the degree to which the block will be restored after the performance of the task. In the **How much does this task restore the item?** field, you can specify that the item will be returned to as good as new condition (i.e., full repair, equal to a restoration factor of 1), to the same condition it was in when it failed (i.e., "as bad as old" or minimal repair, equal to a restoration factor of 0), or you can choose **Partial restoration**. This option provides you with the ability to model maintenance involving "used parts" or imperfect maintenance. The **Restoration amount** field will appear; you can specify the amount of restoration achieved by the task either by entering the value as a percentage or by clicking the arrow and using the slider bar that appears. If you specify anything other than 0% or 100%, you will need to specify what the restoration effect applies to (i.e., the restoration type). You can select:

  - **Only damage accumulated since last repair**: Each repair will remove only the damage since the last repair (i.e., the nth repair cannot remove the damage incurred before the (n-1)th repair). Note that in this context any task is considered a repair and any damage that has occurred since the last event (corrective task, preventive task, inspection or on condition task) will be reduced.

  - **All accumulated damage**: Each repair can reduce any damage accumulated up to that failure.

For simulation, the application uses the restoration factor to determine the new age of the block after the maintenance action.

For example, consider an automotive engine that fails after 6 years. If the engine is rebuilt and the rebuilding task has a 50% restoration factor:

  - If **Only damage accumulated since last repair** is selected, the initial rebuild has the effect of rejuvenating the engine to a condition as if it were 3 years old.

The engine fails again after 3 years (when it again reaches the effective "age" of 6 years), but the rebuild this time affects only the age accumulated after the first
rebuild. Thus the engine has an effective age of 4.5 years after the second rebuild 
\((3 + 3 \times (1 - 0.5) = 4.5)\).

After the second rebuild, the engine fails again after a period of 1.5 years (when it 
again reaches the effective age of 6 years) and a third rebuild is required. The 
effective age of the engine after the third rebuild is 5.25 years \((4.5 + 1.5 \times (1 - 0.5) =
5.25)\).

- If **All accumulated damage** is selected, the initial rebuild has the effect of 
rejuvenating the engine to a condition as if it were 3 years old.

The engine fails again after 3 years (when it again reaches an effective age of 6 
years) and another rebuild is required. This rebuild also rejuvenates the engine by 
50%, thus making it effectively 3 years old again.

After the second rebuild, the engine fails again after a period of 3 years (when it 
again reaches the effective age of 6 years) and a third rebuild is required. The 
effective age of the engine after the third rebuild is 3 years.

Compare the following tables to see how the two options differ.

**Only Damage Accumulated Since Last Repair**

<table>
<thead>
<tr>
<th>Time</th>
<th>Time Since Last Repair</th>
<th>Effective Age Before Repair</th>
<th>Effective Age After Repair</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start = 0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>6 years</td>
<td>6</td>
<td>6</td>
<td>3</td>
</tr>
<tr>
<td>9 years</td>
<td>3</td>
<td>6</td>
<td>4.5</td>
</tr>
<tr>
<td>10.5 years</td>
<td>1.5</td>
<td>6</td>
<td>5.25</td>
</tr>
</tbody>
</table>

**All Accumulated Damage**

<table>
<thead>
<tr>
<th>Time</th>
<th>Time Since Last Repair</th>
<th>Effective Age Before Repair</th>
<th>Effective Age After Repair</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start = 0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>6 years</td>
<td>6</td>
<td>6</td>
<td>3</td>
</tr>
</tbody>
</table>
The ReliaWiki resource portal has more information on restoration factors at: http://www.reliawiki.org/index.php/Repairable_Systems_Analysis_Through_Simulation.

- **Additional Costs to Consider** allows you to choose or create models to represent costs that are always associated with the task. **Cost per task** uses a cost model, and **Downtime rate** uses a cost per unit time model. If no models are assigned, it is assumed that there are no additional costs.

- **Identifiers** contains additional identifying information that can be used to search for this resource.

- **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the record.

- **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

- **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the **Dependency Viewer**.

## Corrective Tasks
Corrective maintenance consists of the action(s) taken to restore a failed component to operational status. Corrective maintenance is performed at unpredictable intervals because a component’s failure time is not known *a priori*.

Corrective tasks:

- Always bring the block down.
- May bring the system down.
- Require spare parts.
In addition to the common task properties, the following options are used to configure corrective tasks in the Maintenance Task window:

- **Task Scheduling** allows you to specify when the corrective task will be performed.
  - If you choose **Upon item failure**, the task will be initiated upon failure of the component.
  - If you choose **When found failed during an inspection**, the task will be initiated if the component is found to be failed at the next scheduled inspection. This is useful in the case of "hidden failures" (i.e., failures that are not apparent until an inspection is performed) and in cases where the component is not considered mission critical and repair can wait until the next scheduled maintenance.
    - If a preventive task takes place before the next inspection, then preventive maintenance (not corrective maintenance) will be performed to restore the block. The downtime, etc. will depend on the preventive task properties.
    - If a corrective task is performed upon inspection and an inspection finds the block failed, then the total downtime includes the full inspection duration followed by the corrective task duration.

If you have selected to perform a corrective task upon inspection and an inspection or preventive task does not occur after the failure, then the block will never be restored. This could happen under either of the following circumstances:

- Neither an inspection nor a preventive task is specified for the block.
  and/or
- The conditions have not been met to perform an inspection or preventive task.

- **Basic Repair Properties > Spare Part Pool** allows you to choose or create a spare part pool that will be used in performing the task. If a spare part pool is not assigned, it is assumed that unlimited free spares are always immediately available.

For corrective and preventive tasks, the simulation requests a crew as soon as a task is initiated; however, the crew does not begin performing the task unless/until the spare part is available.
Chapter 18: Resources

The total time for the task consists of:

- The time to complete corrective and preventive maintenance (based on the corrective task or preventive task properties).

PLUS

- The longer of the following times:
  - The time to obtain the spare part (based on the spare part pool).
  
  OR

  - The time to obtain an available crew (based on crew availability) and any logistical delay time associated with the crew.

For example, if the block fails at 10 hours (on the system clock), the corrective task will take 5 hours, the time required to obtain the spare will be 48 hours and the logistical delay time associated with the crew is 8 hours, then:

- The spare will arrive at 58 hours (on the system clock).
- The crew will be requested at 10 hours and will arrive at 18 hours (on the system clock).
- The maintenance will be completed at 63 hours (on the system clock).
- The total time for the corrective maintenance will be 53 hours (48 for the spare plus 5 for the task).
- The crew will have traveled for 8 hours, waited 40 hours for the spare part and performed the task for 5 hours for a total of 53 hours (including waiting for the spare part).

If the spare part is available without delay and all other conditions are the same, then:

- The crew will be requested at 10 hours and will arrive at 18 hours (on the system clock).
- The maintenance will be completed at 23 hours (on the system clock).
- The total time for the corrective maintenance will be 13 hours (8 for the crew plus 5 for the task).
- The crew will have traveled for 8 hours and performed the task for 5 hours for a total of 13 hours.
• Task Consequences

  • Does this task bring the system down?: By default, corrective tasks will not bring the system down unless having the block down brings the system down based on the reliability-wise configuration in the diagram. If you answer Yes, the task will bring the system down even if the task has a zero duration. This forces the task to be included in the count of system downing events, regardless of the task's duration.

  • Does this task bring the item down?: It is assumed that a block will always be down when a corrective task is performed, even a task with a zero duration; thus, this option cannot be changed.

Preventive Tasks

Preventive maintenance is the practice of repairing or replacing components or subsystems before they fail in order to promote continuous system operation or to avoid dangerous or inconvenient failures. The schedule for preventive maintenance is based on observation of past system behavior, component wearout mechanisms and knowledge of which components are vital to continued system operation. In addition, cost is always a factor in the scheduling of preventive maintenance. In many circumstances, it is financially more sensible to replace parts or components at predetermined intervals rather than to wait for a failure that may result in a costly disruption in operations.

Preventive tasks:

  • Always bring the block down.
  • May bring the system down.
  • Require spare parts.

There are restrictions on the tasks that can be performed simultaneously on the same block. Please refer to Multiple Tasks on the Same Block in the BlockSim/RENO documentation.

In addition to the common task properties, the following options are used to configure preventive tasks in the Maintenance Task window:

  • Task Class allows you to specify the kind of maintenance that the task performs: preventive, inspection or on condition. The options available in the Maintenance Task window will vary depending on your choice in this field.

  • Task Scheduling allows you to specify the circumstances under which the task will be performed. (See Task Scheduling.)
• **Basic Task Properties > Spare Part Pool** allows you to choose or create a spare part pool to assign to the task. The spare part pool describes the conditions that determine whether a spare part will be available when needed and specifies the time and costs associated with obtaining the spare part. If a spare part pool is not assigned, it is assumed that unlimited free spares are always immediately available.

For corrective and preventive tasks, the simulation requests a crew as soon as a task is initiated; however, the crew does not begin performing the task unless/until the spare part is available. For a complete explanation of how this affects the total time for the task, see **Corrective Tasks**.

• **Task Consequences**

  • **Does this task bring the system down?** By default, preventive tasks will not bring the system down unless having the block down brings the system down based on the reliability-wise configuration in the diagram. If you answer **Yes**, the task will bring the system down, even if the task has a zero duration. This forces the task to be included in the count of system downing events, regardless of the task's duration.

  • **Does this task bring the item down?** It is assumed that a block will always be down when a preventive task is performed, even a task with a zero duration; thus, this option cannot be changed.

  • **If bringing the item down causes the system to go down, do you still perform the task?** If you answer **Yes**, the task will be performed even if doing so brings the system down, either because the task itself brings the system down or because the task brings the block down and the block being down causes the system to go down. If you answer **No** and the task brings the system down, the task will never be performed during simulation unless the system is already down for another reason. For instance, a preventive task that is specified to be performed upon system down will be performed even if it brings the system down regardless of your answer here. This is because the system is already down, which is what triggered the task in the first place.

A preventive task that does not bring the system down at the preventive maintenance time will still be factored into the simulation even if its duration will bring the system down at a later time.

For a preventive task that is scheduled to occur based on item age and for which you have answered **No** to this question, if the task is going to bring the system down, then it will not take place. If, however, the block reaches the age again (after restoration by a corrective action, inspection or another type of preventive maintenance) and this time it will not bring the system down, then it will be performed.
• **Perform this task even if the item failed before this task was scheduled to occur?** If you answer Yes, the task will be performed even if the item has already failed. In other words, the item's "clock" is not stopped upon failure, and the item's "virtual age" is used to trigger the task. This option is available only for preventive and inspection tasks that are scheduled based on item age.

• **RCM properties** are text-based properties that are used to keep track of details that may be helpful in reliability centered maintenance analysis, but are not used in reliability/maintainability simulations. These properties are shown only if they are enabled for the project via the interface style settings in RCM++/RBI.

• **Status**: The status of the task (choose from a drop-down list). This setting could be used if you want to keep track of all tasks that have been considered, regardless of whether they end up in the actual maintenance plan (e.g. recommended, rejected, assigned).

• **Proposed Interval**: The interval that was initially proposed for the task. This may be different from the interval that is actually assigned to the task. For example, you may wish to use this property if the team originally suggests a particular interval for the task (perhaps the calculated optimum interval) but then decides to assign a different interval (perhaps an interval that is more convenient for packaging a group of tasks).

• **Reference Document**: A reference to another document that provides more detailed information about the task (e.g. procedure instructions).

• **Condition**: A description of the condition that indicates that a failure will occur (e.g. a threshold for a measurement of wear, vibration, etc). Typically, this field is used for on condition maintenance tasks.

• **Zone**: The zone of the system in which the task will be performed. Typically, this field is used for aircraft MSG-3 analyses.

• **Access**: The access that will be required in order to perform the task. Typically, this field is used for aircraft MSG-3 analyses.

**Note**: A preventive task with a restoration factor of 0 will generate a new failure with the current age.

---

**Inspection Tasks**

Inspections are used in order to uncover hidden failures (also called "dormant failures"); they are also used as part of on condition tasks to detect impending failures so that preventive maintenance can be performed.
Chapter 18: Resources

**What's Changed?** In BlockSim 6 and 7, you could assign failure detection properties to an inspection task and set it to trigger a preventive task, thereby creating an on condition maintenance action. BlockSim now offers on condition tasks, eliminating the need to create your own. Therefore, failure detection properties are now available only for on condition tasks, not for regular inspection tasks.

In general, no maintenance action is performed on the component during an inspection unless the component is found failed, in which case a corrective maintenance action is initiated. However, there might be cases where a partial restoration of the inspected item would be performed during an inspection. For example, when checking the motor oil in a car between scheduled oil changes, one might occasionally add some oil in order to keep it at a constant level. This sort of restoration is not considered to be preventive maintenance; the deciding factor is that inspection tasks do not use spare parts. Note that an inspection task that triggers a corrective task will not restore the failed block. Only the corrective task will restore the block.

Inspection tasks (including the inspection and associated minor work):

- May bring the block down.
- May bring the system down; if the task brings the system down, it also brings the block down.
- Do not use spare parts.

In addition to the common task properties, the following options are used to configure inspection tasks in the Maintenance Task window:

- **Task Class** allows you to specify the kind of maintenance that the task performs: preventive, inspection or on condition. The options available in the Maintenance Task window will vary depending on your choice in this field.

- **Task Scheduling** allows you to specify the circumstances under which the task will be performed. (See Task Scheduling.)

- **Task Consequences**: An inspection task will not bring the block down unless one of the following options is selected.
  - **Does this task bring the system down?**: If you answer Yes, when the task is performed, the system will be down, even if the task has a zero duration. If not selected, the task will bring the system down only if it brings the block down and having the block down brings the system down based on the reliability-wise configuration in the diagram. If this option is selected, even tasks with a zero duration will bring the system down. This forces the task to be included in the count of system downing events, regardless of the task's duration.
• **Does this task bring the item down?:** If you answer *Yes*, when the task is performed, the block will be down. Even tasks with a zero duration will bring the block down in this case.

• **Perform this task even if the item failed before this task was scheduled to occur?:** If you answer *Yes*, the task will be performed even if the item has already failed. This option is available only for preventive and inspection tasks that are scheduled based on item age, including the inspection portion of on condition tasks.

• **RCM** properties are text-based properties that are used to keep track of details that may be helpful in reliability centered maintenance analysis, but are not used in reliability/maintainability simulations. These properties are shown only if they are enabled for the project via the interface style settings in RCM++/RBI.

• **Status:** The status of the task (choose from a drop-down list). This setting could be used if you want to keep track of all tasks that have been considered, regardless of whether they end up in the actual maintenance plan (e.g. recommended, rejected, assigned).

• **Proposed Interval:** The interval that was initially proposed for the task. This may be different from the interval that is actually assigned to the task. For example, you may wish to use this property if the team originally suggests a particular interval for the task (perhaps the calculated optimum interval) but then decides to assign a different interval (perhaps an interval that is more convenient for packaging a group of tasks).

• **Reference Document:** A reference to another document that provides more detailed information about the task (e.g., procedure instructions).

• **Condition:** A description of the condition that indicates that a failure will occur (*e.g.* a threshold for a measurement of wear, vibration, etc). Typically, this field is used for on condition maintenance tasks.

• **Zone:** The zone of the system in which the task will be performed. Typically, this field is used for aircraft MSG-3 analyses.

• **Access:** The access that will be required in order to perform the task. Typically, this field is used for aircraft MSG-3 analyses.

To understand how inspections work during simulation, you should be aware of the following:

• Multiple non-downing inspections cannot occur on the same block at the same time.
- A non-downing inspection with a restoration factor greater than 0 restores the block based on the age of the block at the beginning of the inspection (i.e., the task duration is not restored).

**On Condition Tasks**

On condition maintenance relies on the capability to detect failures before they happen so that preventive maintenance can be initiated. If, during an inspection, maintenance personnel can find evidence that the equipment is approaching the end of its life, then it may be possible to delay the failure, prevent it from happening or replace the equipment at the earliest convenience rather then allowing the failure to occur and possibly cause severe consequences. In BlockSim, on condition tasks consist of an inspection task that triggers a preventive task when an impending failure is detected during inspection.

For on condition tasks, the Inspection properties allow you to configure the inspection portion of the task, and the options are identical to those available for configuring inspection tasks. The On Condition Task (Upon Detection) properties allow you to configure the preventive portion of the task. The options are the same as those available for configuring preventive tasks, except that the Task Scheduling properties are not available. Instead, Failure Detection properties are used to specify the "warning period" that spans from the time when a potential failure can first be detected to the time when the failure occurs.

To define the Failure Detection properties, first specify when the task is likely to detect an imminent failure. If you choose *When a certain percentage of the life of the item has been consumed*, you must then specify the percentage of the item's life that must have elapsed in order for approaching failure to be detected. This is called the *failure detection threshold* (FDT). For example, if the FDT is 0.9 and the item will fail at 1,000 days, the approaching failure can begin to be detected at 900 days. If you choose *Within a fixed time frame prior to failure*, you must then specify the amount of time before a failure when the approaching failure can be detected by inspection. This is called the *P-F interval*. For example, if the P-F interval is 200 days and the item will fail at 1,000 days, the approaching failure can begin to be detected at 800 days.

On condition tasks can be set to perform the preventive portion of the task even if the item failed before the approaching failure could be detected. If the inspection portion of the task is scheduled based on item age, you can answer **Yes** to the **Perform this task even if the item failed before this task was scheduled to occur?** option.

Note the following simulation assumptions regarding on condition tasks:

- An inspection that finds a block at or beyond the failure detection threshold or within the range of the P-F interval will trigger the associated preventive task as long as preventive maintenance can be performed on that block.
• If a non-downing inspection triggers a preventive maintenance action because the failure detection threshold or P-F interval range was reached, no other maintenance task will be performed between the inspection and the triggered preventive task; tasks that would otherwise have happened at that time due to system age, system down or group maintenance will be ignored.

• A preventive task that would have been triggered by a non-downing inspection will not happen if the block fails during the inspection, as corrective maintenance will take place instead.

• If a failure will occur within the failure detection threshold or P-F interval set for the inspection, but the preventive task is only supposed to be performed when the system is down, the simulation waits until the requirements of the preventive task are met to perform the preventive maintenance.

• If the on condition inspection triggers the preventive maintenance part of the task, the simulation assumes that the maintenance crew will forego any routine servicing associated with the inspection part of the task. In other words, the restoration will come from the preventive maintenance, so any restoration factor defined for the inspection will be ignored in these circumstances.

Task Scheduling
The following information applies to the task scheduling properties for preventive tasks, inspection tasks and the inspection portion of on condition tasks.

Click the arrow in the When is this task performed? field to define the criteria for performing the task. The remaining fields in the task scheduling properties will depend on your selection in this field. The task can be performed:

• **At certain intervals.** If you select this option, you must then specify:
  • Whether the interval is fixed or dynamic.
  • Whether the interval is based on the item’s age or on calendar time.

• **Upon certain events.** If you select this option, you can choose for the task to be performed:
  • Whenever the system is down for any reason. No further task scheduling properties are required for this option.
  • Based on events in a maintenance group. The task will be performed when user-specified events occur for either some or all blocks in one or more user-specified
maintenance groups. The item that the task is assigned to does not need to be part of the selected maintenance group(s).

- When a maintenance phase in a phase diagram starts. Please note that if the task is selected to be performed only at the start of a maintenance phase and the item that the task is associated with is not included in the maintenance phase's associated maintenance template, the task will never be performed. No further task scheduling properties are required for this option.

- Based on events in a flow group (see Flow Groups in the BlockSim documentation). This setting is appropriate only for tasks used in BlockSim process flow simulation diagrams. The task will be performed when flow either reaches/exceeds its threshold or drops to or below its threshold in one or more user-specified flow groups. The block(s)/item(s) affected by the task may or may not belong to any of the flow groups.

The remaining task scheduling properties for each type of schedule are given next. For any interval that you specify, you will be asked to specify the units used.

- **Fixed interval based on either item age or calendar time**: Enter the interval when the task will be performed (e.g., if you enter 100, the task will be scheduled for 100, 200, 300, etc.).

  - Item age refers to the accumulated age of the block, which gets adjusted each time the block is repaired (i.e., restored). If the block is repaired at least once during the simulation, this will be different from the elapsed simulation time. For example, if the restoration factor is 1 (i.e., "as good as new") and the assigned interval is 100 days based on item age, then the task will be scheduled to be performed for the first time at 100 days of elapsed simulation time. However, if the block fails at 85 days and it takes 5 days to complete the repair, then the block will be fully restored at 90 days and its accumulated age will be reset to 0 at that point. Therefore, if another failure does not occur in the meantime, the task will be performed for the first time 100 days later at 190 days of elapsed simulation time.

- Calendar time refers to the elapsed simulation time. If the assigned interval is 100 days based on calendar time, then the task will be performed for the first time at 100 days of elapsed simulation time, for the second time at 200 days of elapsed simulation time and so on, regardless of whether the block fails and gets repaired correctly between those times.
If the task is performed at fixed intervals, you can select the **Override task scheduling properties with a task package** option to assign the task to a **task package**, which is a group of tasks that are performed together at scheduled intervals. (Note that if a task has been assigned to a task package, the task scheduling properties will be disabled and displayed in italics.)

- **Dynamic interval based on either item age or calendar time**: The task will be performed at variable user-specified intervals. This can be used, for example, to schedule maintenance to be performed with increasing frequency as an item gets older. The **Dynamic intervals** field shows the number of intervals specified. Click the button (...) to open the Intervals window, which allows you to enter the item age intervals when the task will be performed. The intervals are the actual time between maintenance (i.e., they are not cumulative).

- **Based on events in a maintenance group**: Specify the events that can trigger the task (i.e., a block fails; a corrective, preventive or inspection task starts; a block is restored to operation), and choose the maintenance group(s) in which the event(s) must occur in order to trigger the task.

- **Based on events in a flow group**: Specify the events that can trigger the task (i.e., flow rate through any connector exceeds or drops below a certain level), and choose the flow group(s) in which the event(s) must occur in order to trigger the task.

**Note:** For preventive and inspection tasks that are scheduled based on item age, you can use the **Perform this task even if the item failed before this task was scheduled to occur?** property to determine whether actual age or "virtual age" is considered. If you answer **Yes**, the task will be performed even if the item has already failed. In other words, the item's "clock" is not stopped upon failure, and the item's virtual age is used to trigger the task.

### Crews

Crews are resources that can be shared among analyses and can be managed via the **Resource Manager**. You can assign the crews to maintenance **tasks**.

The Crew window allows you to create, view and edit crews. It can be accessed by clicking the **Create New** or **View/Edit** icon in the Crew wizard, which is accessed from **Crew** fields in properties windows (e.g., the **Crew for task** field in the **Maintenance Task window**).
Chapter 18: Resources

It can also be accessed from the Crews page of the Resource Manager by choosing **Home > Edit > Add**, by selecting a crew and choosing **Home > Edit > View** or by double-clicking a crew.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the resources you need for your analyses.

The following settings are available to configure the crew:

- **Crew**

  - **Direct cost** allows you to choose or create a [model](#) to represent the direct cost per unit time to engage the crew (e.g., the hourly charge for the time that the crew spends performing the task). This field uses a cost per unit time model. If no model is assigned, it is assumed that there is no cost.

  - **Cost per incident** allows you to choose or create a model to represent the cost per incident to engage the crew (e.g., if you have to pay a fixed fee instead of or in addition to the hourly rate). This field uses a cost model. If no model is assigned, it is assumed that there is no cost.

  - **Is there a limit to the number of tasks this crew can perform at the same time?** If you answer *Yes*, you must specify the limit in the **Number of tasks** field. For example, if the crew can only fix 3 components at any given time and 4 components fail at the same time, then the crew will not be able to fix the fourth component until one of the other components has been restored.

  - **Logistic Delay** allows you to choose or create a model to describe the delay time before the crew can start the task. If no model is assigned, it is assumed that the crew can start the task immediately without any delays (i.e., immediate repair). The crew with the highest priority is always called upon first, regardless of logistic wait times for the crews. If a crew is needed and all crews are engaged, the crew with the shortest wait time is chosen to perform the task.

For a given simulation, a crew’s logistic time is constant across that one simulation for the task. It is taken randomly from its distribution or from its fixed time.

For on condition tasks, if the same crew performs the inspection and preventive maintenance and there are logistic delays associated with the crew, the logistic delays will be factored into the simulation for both parts of the task.
If Include logistic delay in cost is selected, then the time spent waiting for the crew (including logistic delay and any delay incurred due to limits on the number of tasks the crew can perform simultaneously) will be included when calculating crew costs, based on the direct cost specified for the crew.

If Include part delay in cost is selected, then the time spent by the crew waiting for spare parts will be included when calculating crew costs, based on the direct cost specified for the crew.

- **Identifiers** contains additional identifying information that can be used to search for this resource.
- **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the record.

- **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.
- **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

## Spare Part Pools
Spare part pools are resources that can be shared among analyses and can be managed via the Resource Manager. A spare part pool describes the conditions that determine whether a spare part will be available when needed and specifies the time and costs associated with obtaining the spare part. You can assign the pools to maintenance tasks.

The Spare Part Pool window allows you to create, view and edit spare part pools. It can be accessed by clicking the Create New or View/Edit icon in the Spare Part Pool wizard, which is accessed from Spare Part Pool fields in properties windows (e.g., in the Maintenance Task window).

It can also be accessed from the Spare Part Pools page of the Resource Manager by choosing Home > Edit > Add, by selecting a spare part pool and choosing Home > Edit > View or by double-clicking a spare part pool.
For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the resources you need for your analyses.

The following settings are available to configure the spare part pool:

- **Spares**
  - **Direct cost per dispensed item** allows you to specify the direct cost of each spare part in the pool.
  - **Spare acquisition type**: You can select **Unlimited spares** to indicate that an unlimited number of spare parts exist in the pool (i.e., if a spare part is required, it will always be available). If you select **Limited number of spares**, the Pool Restock properties and the Emergency Spare Provisions properties will become available. In addition, you will need to define the following properties:
    - **Initial stock level** is the number of spare parts in the pool at the start of simulation.
    - **Holding Cost ($/Hour in pool)** allows you to choose or create a model to represent the cost of holding a spare part in the pool. The unit used is the default unit for the database. This field uses a cost per unit time model. If no model is assigned, it is assumed that there is no cost. (To determine which unit is defined as the default, choose File > Manage Repository > Unit Settings. The default unit is the one that is selected in the Use as Default column.)
    - If you select the **Pool has maximum capacity** check box, you will need to specify the maximum number of items that can exist in the spare part pool at any given time. The restock options will add parts only up to this maximum capacity. For example, suppose that the maximum capacity is 20 units and the restock quantity is 5 units. If the current stock level is 18 when a restock is triggered (either on a scheduled interval or because the stock fell to a specified level), then only 2 units will be added to the spare part pool, even though the restock options call for the addition of 5 units at each restock.
  - **Logistic Time for Spare Acquisition** allows you to choose or create a model to describe the amount of time required to obtain the part when it is required for
maintenance, assuming that the part is in stock. This field uses a duration model. If no model is assigned, it is assumed that the spare part is available for use immediately.

- The **Pool Restock** properties allow you to define how the spare part pool will be restocked. These properties are available only if you have selected the **Limited number of spares** option in the **Spare acquisition type** field. You can select either or both of the following restock schemes:
  - If the **Scheduled restock** option is selected, the pool will be restocked at fixed intervals. The following properties will be available:
    - **Restock every** allows you to specify the time interval at which the pool will be restocked.
    - **Number added per restock** allows you to specify the number of parts that are added to the pool at every scheduled interval.
  - If the **Restock as needed** option is selected, the pool will be restocked when the stock drops to a specified quantity. This option is available only if the initial stock level entered is at least 1. The following properties will be available:
    - **Restock when stock drops to** allows you to specify the number of parts in the pool that will trigger the restock (e.g., when the stock drops to 5, order more parts).
    - **Number added per restock** allows you to specify the number of parts that are added to the pool when the restock condition has been met.
    - **Required time for stock arrival** allows you to choose or create a model to describe the amount of time required for the new parts to arrive after the restock has been initiated. This field uses a duration model. If no model is assigned, it is assumed that the parts arrive immediately.
    - **Off-site spare part pool** allows you to assign an off-site spare part pool to the current pool. If specified, this pool is considered to be the source for restocking the current pool, which allows you to describe properties for the next level of spare parts that can be accessed when needed. If no off-site spares pool is specified, the parts are assumed to be ordered and no properties are described for the source.

*Tip:* Circular references between spare part pools are not permitted. In other words, if Pool 1 calls Pool 2 as its off-site spare part pool, and Pool 2 calls Pool 1 as its off-site spare part pool, BlockSim will display a message notifying you of the problem upon simulation.
Chapter 18: Resources

- The **Emergency Spare Provisions** properties allow you to define the circumstances when the spare part pool is empty but a spare part is required for a task. These properties are available only if you have selected either the **Limited number of spares** option or the **Fixed probability of stockout** option in the **Spare acquisition type** field. Selecting the **Can obtain emergency spares if needed** option indicates that a spare part can be obtained if required and the spare part pool is empty; otherwise, the repair will be delayed until more spare parts arrive in the spare part pool. Selecting this option makes the following properties available:

- **Number added per emergency** allows you to specify the number of parts that are added to the pool when an emergency acquisition occurs.

- **Additional costs for emergency spares** allows you to choose or create a model to represent a per incident cost for emergency acquisition of spares (e.g., there is a $50 surcharge when emergency spares are required). This field uses a cost model. If no model is assigned, it is assumed that there is no cost.

- **Required time for emergency spare** allows you to choose or create a model to describe the amount of time required for the emergency spare parts to arrive after the emergency acquisition has been initiated. This field uses a duration model. If no model is assigned, it is assumed that the parts arrive immediately.

- **Off-site spare part pool** allows you to assign an emergency off-site spare part pool to the current pool. This allows you to create another level of spare parts that can be accessed for the emergency acquisition.

- **Identifiers** contains **additional identifying information** that can be used to search for this resource.

- **History** provides information about when the record was created and last updated. If the **history log** has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the record.

- **Watch** allows each individual user to **subscribe to receive an alert** (via e-mail, SMS text message or portal message) when the resource is changed.

- **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the **Dependency Viewer**.

  Used by 1 item
Metrics

A *metric* is a *resource* that provides a flexible way to display any numerical value of interest, and track how it changes over time. This can be used for tracking and displaying a variety of Key Performance Indicators (KPIs) and other values, including:

- Reliability metrics (e.g., reliability, BX% life, etc.) calculated from a model resource.
- Any result from a simulated BlockSim diagram.
- The completion percentage and resource usage for Project Planner gates.
- The reliability or availability calculated from an FMRA in Xfmea/RCM++/RBI.
- Any other user-defined value that you wish to display and track.

Like any other resource, you can create or edit metrics from the *Resource Manager*, and while you’re performing a relevant analysis. (See *Showing Metrics in Folios/Diagrams*, *Using Metrics in Project Planner Gates* and *Pushing Metrics from an FMRA*.)

If your organization chooses to implement a web-based *Synthesis Enterprise Portal*, it's easy to choose specific metrics that you want to access quickly from any web-enabled device.

**Note:** Metrics are always local resources. They cannot be made global. Metrics in a reference project are local to that project and can't be selected for use in other projects.
Metric Types

The following pictures demonstrate the four basic options for specifying the value that will be displayed and tracked.

<table>
<thead>
<tr>
<th>Calculate from a model resource</th>
<th>Obtain from a BlockSim simulation diagram</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Metric Type</strong></td>
<td><strong>Metric Type</strong></td>
</tr>
<tr>
<td>Type</td>
<td>Type</td>
</tr>
<tr>
<td>Reliability Given Time</td>
<td>Simulation Result</td>
</tr>
<tr>
<td><strong>Associated Model</strong></td>
<td><strong>Associated Diagram</strong></td>
</tr>
<tr>
<td>Model</td>
<td>Diagram</td>
</tr>
<tr>
<td>Widget LDA [WB2 (1.5, 1000)]</td>
<td>System RBD</td>
</tr>
<tr>
<td>Time</td>
<td>Result</td>
</tr>
<tr>
<td>100 (Hr)</td>
<td>Mean Availability</td>
</tr>
</tbody>
</table>

Enter any user-defined value

<table>
<thead>
<tr>
<th><strong>Metric Type</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
</tr>
<tr>
<td>Constant</td>
</tr>
</tbody>
</table>

| **Constant Value**           |
| Value                         |
| 100                           |

Calculated Result and Saved Values

The **Calculated Result** field shows the latest calculated value for the metric. This will be updated automatically if the associated analysis or model changes, and the latest result will be stored in an array of saved values.

You can then click the **View Saved Values** icon to view the history of how the metric has changed over time.

If you change any of the properties that affect the way the result is calculated, you will be prompted to decide whether to clear the array of values that were saved before the change. For example:

- If you change the metric from Reliability to Probability of Failure, or from 1,000 hours to 500 hours, you will probably want to clear the array so the timeline of saved values is not misleading.

- Alternatively, if you change the metric’s associated model from prototype1 to prototype2 to prototype3 at different stages of development, you may wish to keep the
saved values after each change so the timeline shows the improvement across all three stages.

In the Metric Results Viewer, you can also choose to clear the entire history or delete only a particular saved value.

The results viewer also allows you to copy the values to the Clipboard so you can paste into another application. For example, if the metric stores the calculated reliability at different points in time, you may wish to analyze the data with a reliability growth model in RGA.

- **Copy > All rows (dates)** copies the exact dates shown in the table.
- **Copy > All rows (cumulative days)** replaces the dates with the cumulative number of days since the date of the last saved value. For example, if the first date is 1/1/2015 and the second date is 12/31/2015, the cumulative days would be 0 for the first date and 365 for the second date.

**Target Conditions and Result Indicator**

The **Target Conditions** feature color-codes the current value of the metric. If all specified conditions are met, then the metric's value will be displayed in green. If one or more conditions are not met, then it will be in red. For example, in the following pictures, the result is green if the estimated system reliability is at least 80%, and red if it is not.

<table>
<thead>
<tr>
<th>Calculated Result</th>
<th>0.049721070105</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Target Conditions (All True)</strong></td>
<td>Condition 1</td>
</tr>
</tbody>
</table>

The **Result Indicator** feature color-codes the indicator that shows whether the value has increased or decreased since the prior saved value. If the direction of the change is desirable, the indicator will be green; if it is undesirable, the indicator will be red. As an example, the following pictures are from the SEP.

<table>
<thead>
<tr>
<th>Reliability @ 1500 Hr</th>
<th>97.98% (9/2018)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Increasing reliability is good</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Probability of Failure @ 1500 Hr</th>
<th>0.02 (9/2018)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decreasing unreliability is good</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Reliability @ 2000 Hr</th>
<th>97.29% (9/2018)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decreasing reliability is bad</td>
<td></td>
</tr>
</tbody>
</table>

**Identifiers, History, Watch and Trace Usage**

As with most other resources:

- **Identifiers** contains [additional identifying information](#) that can be used to search for this resource.
Chapter 18: Resources

- **History** provides information about when the record was created and last updated. If the **history log** has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the record.

- **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

- **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the **Dependency Viewer.**

### Showing Metrics in Folios/Diagrams

The Publishing page of the control panel shows all of the metric resources that are associated with the current analysis. (The metrics can be created and edited either from the Resource Manager or the control panel.) This applies for:

- Data sheets in Weibull++, ALTA or RGA that have a published model.
- Analytical or simulation diagrams in BlockSim that have a published model for the entire system (either a fitted model or an analytical model).
- Simulation diagrams in BlockSim that have simulation results.

This makes it easy to see the metrics that have been created for each analysis (which may also be displayed in relevant Project Planner gates or in the Synthesis Enterprise Portal website) and to see the history of how the analysis results changed over time. It also provides a convenient way to create new metrics for the analysis, if desired.

As an example, the following picture shows a typical scenario for Weibull++. In Weibull++, ALTA or RGA, the control panel shows all metrics that are associated with the model published from the current data sheet. In BlockSim, it shows all metrics that are associated with a model published from the diagram and/or obtained from the diagram’s simulation results.

- Double-click a metric to see its properties and history of saved values.
- A **Watch** icon will be shown beside any metric for which you have subscribed to receive an alert when the resource is changed.
- Click the **Metric Summary** icon to see a quick report of all the metrics displayed in the current branch.
• Click the Create New icon to create a new metric.

**Associating Existing Metrics with a Different Data Sheet**

When an analysis changes (e.g., new data, after a design change, etc.), you may choose to simply update the existing data sheet and recalculate, or keep the original analysis unchanged and perform the updated analysis in a new data sheet.

If you decided to create a new data sheet, there are two ways to ensure that the metrics will reflect the complete history from both analyses:

**Publish to the existing model from the new data sheet**

If you want the published model to reflect the latest analysis results, you can simply transfer both the model and the associated metrics to the new data sheet. To do that:

1. Calculate the new data sheet and then go to the Publishing page of the control panel.
2. Click **Publish to Existing Model** and then select the model from the original data sheet.

**Change the model for the existing metrics**

If you want to keep the original published model associated with the original data sheet, you can publish a new model for the new data sheet and then transfer the metrics to the new model. To do that:

1. Publish a new model for the new data sheet.
2. From either the original data sheet’s control panel or the Resource Manager, open each metric that was associated with the original data sheet and change the **Associated Model**.

As a shortcut, you can click the **Select Existing** icon on the new data sheet’s control panel and choose one or more existing metrics in the Select Resource window. It is important to keep in mind that when you do this, you are changing the associated model for each selected metric.

**Using Metrics in Project Planner Gates**

There are two ways to utilize metrics in a Project Planner gate:

**Relevant Metrics**

For any gate in a project plan, you can choose to display up to three metrics that are relevant to this stage of the project (e.g., the target reliability, the latest calculated reliability, etc.).

Use the fields under the **Relevant Metrics** heading to select an existing metric or create a new one.
Push to Metrics

For any gate in a project plan, you can also choose to push any of the following values to a metric resource. This makes it easy to see the history of all saved values, and enables users to subscribe to receive alerts when the metric changes. You can also choose to show this information in the Synthesis Enterprise Portal if a web-based portal is implemented for the current database.

- **Percent Completed** is the percentage of the total duration of dependent actions/gates that is complete. For example, if Action 1 (duration = 3 days) is complete and Action 2 (duration = 1 day) is incomplete, the progress is 75%.

- **Actual Man Hours %** is the percentage of planned hours that have been used to complete the gate.

- **Actual Costs %** is the percentage of the budget that has actually been used to complete the gate.

Use the fields under the **Push to Metrics** heading to create a new metric or select an existing metric that is not already assigned to receive a pushed value. (Note that only unused metrics are shown in this list.)

When you first assign a metric in one of these fields, the current value will be automatically saved to the metric. Subsequently, the value will be recalculated each time an associated action or gate is changed. If the value is found to have changed, it will be saved to the metric. To see the current saved value, click inside the field. This will also display a **result indicator** and the **View Saved Values** icon, which you can click to see a history of all saved values.
Chapter 18: Resources

Pushing Metrics from an FMRA

The Push to Metrics fields on the Properties tab of the Analysis panel in Xfmea/RCM++/RBI enable you to "push" the reliability and availability values that were calculated/simulated from the Failure Modes and Reliability Analysis (FMRA) to metric resources.

This makes it easy to see the history of all saved values while you’re working in the FMRA, and enables users to subscribe to receive alerts when the metric changes. If desired, you can also choose to show this information in a specific Project Planner gate (under the Relevant Metrics heading), and in the Synthesis Enterprise Portal if a web-based portal is implemented for the current database.

1. Go to the FMRA tab in the system panel. (See Enabling and Viewing the FMRA in the Xfmea/RCM++/RBI documentation.)

2. Select any item in the FMRA hierarchy and use the fields under the Push to Metrics heading to create a new metric or select an existing metric that is not already assigned to receive a pushed value.

3. Calculate and/or simulate the FMRA:
   a. To calculate the reliability, choose FMRA > Calculations > Calculate (Reliability).
b. To simulate the availability, choose **FMRA > Calculations > Simulate (Availability)**.

4. Each time you calculate/simulate the FMRA, the latest value(s) will be automatically saved to the metric(s). To see the history of all saved values, click **View Saved Values**.

<table>
<thead>
<tr>
<th>Reliability / Availability</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target Reliability</td>
<td>0.99</td>
</tr>
<tr>
<td>Current Reliability</td>
<td>0.99</td>
</tr>
<tr>
<td>Target Availability</td>
<td>0.99</td>
</tr>
<tr>
<td>Current Availability</td>
<td>0.99</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Push to Metrics</th>
<th>Metric Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Push Current Reliability</td>
<td>System 1_Rel_Metric</td>
</tr>
<tr>
<td>Push Current Availability</td>
<td>System 1_Avail_Metric</td>
</tr>
</tbody>
</table>

**Variables**

A variable is a **resource** that stores a numerical value and allows you to assign a name to that value. You can then use the variable name in place of the actual value in the equations that you create. You can also use variables in functions and/or as conditional output values in conditional blocks, logic gates and branch gates.

A variable starts with an assigned initial value, which may be fixed or varied during simulation. You can use variables:

- In RENO, to act as a constant (i.e., maintain a fixed numerical value during simulation).
- In RENO, to temporarily store the output value of a block during simulation. See the next section for more information.
- In RENO, to perform a sensitivity analysis, which involves varying the value of one or two variables between runs (i.e., sets of simulations). For example, if you are analyzing potential investment strategies, you may wish to vary the number of years that you will be investing and/or the percentage of your income that will be invested to see how different inputs will affect the final results.
- As the basis for a **dynamic model**, which represents a fixed probability, duration or cost. The variable can be programmatically varied during simulation, thereby changing the value of the model for successive simulation runs.
In BlockSim process flow simulation diagrams, to define a throughput amount.

As inputs for certain fields in BlockSim simulation RBDs via simulation worksheets, allowing programmatic variation of the field value during simulation.

What's Changed? In previous versions of RENO, variables that stored fixed values were known as constants, and variables that stored outputs were known as storage variables.

Using Variables to Store Output Values in RENO
You can use variables to hold numerical values passed to them during simulation. In RENO, the following blocks are able to store their output values in variables:

- Standard blocks
- Result storage blocks
- Flag markers
- Counter blocks

Depending on your choice in the When to Reset field of the variable's properties window, you can configure the variable to retain the value passed to it during simulation or reset the variable to its initial value at specific times. The options are:

- **Reset After Each Simulation** (i.e., reset after a single pass through the flowchart)
- **Reset After Each Run** (i.e., reset after each set of simulations)
- **Reset After Analysis** (i.e., reset after each set of runs)
- **Never Reset**

When the simulations end, the variable always returns to its initial starting value unless you have selected Never Reset. If you wish to keep the value used during simulation, you can use a result storage block to store it.

Example
The following example demonstrates two things: a) how a variable may be used to store an output value and b) how a variable may be used in an equation.

In the following configuration, the first block calculates the gross profit from a sale, and then stores its output into a variable called "Profit." The conditional block determines whether the gross profit exceeds 500. If the output is true, the third block deducts the sale's commission from the profit, and overwrites the stored value with the new output.
The following picture shows the properties window of the variable called "Profit." The initial value of this variable is set to 0.

The following picture shows the Block Properties window of the first block in the example. The output of the equation is stored in the variable.
The following picture shows the Block Properties window of the third block in the flowchart. The equation shows that the commission is deducted from the existing value in the variable, and then the variable is overwritten with the new result. At the end of the simulation, the result storage block in the flowchart stores the final value of the variable, and then the variable resets to 0.
Profiles

A profile is a resource that allows you to represent a value that varies with time. It consists of a basic pattern that either repeats as a cycle or occurs once and then continues from its last defined setting. Profiles can be either stress profiles, which are used in ALTA life-stress data folios, or throughput profiles, which are used in BlockSim process flow simulation (PFS) diagrams (if supported by your license).

What's Changed? The profile resource replaces the stress profile functionality that was available in previous versions of ALTA PRO.

This topic describes how to create profiles, which can be defined by entering values manually or by importing data from nCode GlyphWorks.

To learn how to use stress profiles in ALTA life-stress data folios, see Time-Dependent Stress Profiles in the ALTA documentation.

To learn how to use throughput profiles in BlockSim PFS diagrams, see BlockSim Process Flow Simulation Diagrams in the BlockSim documentation.

Creating Profiles

Like any other resource, you can create or edit profiles from the Resource Manager, or while you’re performing a relevant analysis. To create a profile:

1. Specify the type of profile that you are creating. If your license does not support BlockSim PFS diagrams, this step is unavailable.

2. Define a pattern for how a stress level will change over a specified period of time. The pattern you will define consists of a series of segments, where each segment has a specified duration is either:
   - a constant stress or throughput value, or
   - a function that takes a time value and returns a stress or throughput value.

These segments are defined in the spreadsheet, as shown next.

<table>
<thead>
<tr>
<th>Segment Start</th>
<th>Segment End</th>
<th>Stress S(t)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>1100</td>
<td>328</td>
</tr>
<tr>
<td>1100</td>
<td>2200</td>
<td>338</td>
</tr>
<tr>
<td>2200</td>
<td>3300</td>
<td>348</td>
</tr>
</tbody>
</table>
• **Segment Start** is calculated automatically by the software and cannot be entered manually. The first segment's start time is always 0. For every subsequent segment, the start time is identical to the prior segment's end time.

• **Segment End** allows you to enter the end time for each segment, which must be smaller than the end time of the next segment.

• **Stress \( S(t) \) or Throughput \( T(t) \)** is the stress or throughput value or function for the segment. If the stress or throughput level will stay constant during a segment, enter a constant value (e.g., 30). If the level will change during a segment, enter the value as a function of time (e.g., at time = 20, the function \( t + 20 \) will return a value of 40). When entering a function, you must use \( t \) or \( T \) as the time variable.

**Tip:** Because stress units (e.g., volts), throughput units (e.g., kilograms) and time units (e.g., hours) are not defined in the profile, it is important to apply profiles only to folios that are intended to use the same stress/throughput and time units. In the Profile window, you may want to rename column headings (by right-clicking the heading) or use the Comments page as a reminder of which units are applicable to that profile.

For example, suppose the stress unit is psi and the time unit is seconds. Now suppose you wanted to define the following 120-second pattern: a stress value of 30 psi for 60 seconds, followed by a stress value of 50 psi for 30 seconds, followed by a stress function that begins at 50 psi and gradually decreases at a rate of 1 psi per second for the remainder of the pattern. For this pattern, you could fill out the spreadsheet as follows:

<table>
<thead>
<tr>
<th>Segment Start</th>
<th>Segment End</th>
<th>Stress ( S(t) )</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>60</td>
<td>30</td>
</tr>
<tr>
<td>60</td>
<td>90</td>
<td>50</td>
</tr>
<tr>
<td>90</td>
<td>120</td>
<td>50 - (t - 90)</td>
</tr>
</tbody>
</table>

Notice that the last segment of this profile uses a stress function. Since \( t \) is the test time (or, if the profile is cyclical, the time since the pattern was last restarted), \( t = 90 \) when the last segment begins. So the last segment’s stress level starts at 50 - (90 - 90) = 50. Then, at 91 seconds, the stress level will have dropped to 50 - (91 - 90) = 49. After another second it will have dropped to 50 - (92 - 90) = 48, and so on.

3. Next, choose the appropriate option in the **After Last Segment** area of the control panel. Your selection here will determine what happens after the end time of the profile’s last segment (in the above example, after time = 120).

If you select **Continue with last value**, all times after the last segment will use the value/function defined in the last segment.
If you select **Repeat cycle**, the entire pattern of segments will be treated as a repeating cycle.

For example, suppose you defined a pattern that is made up of five segments, each an hour long and increasing stepwise from the segment before. The graphs below illustrate the difference between continuing from the last stress (left) and selecting to repeat (right). In this example, the test has a duration of 20 hours, and the graphs explain what would happen through the entire duration of the test.

4. Before you can use the new profile in your analysis, you must save any changes you have made and validate the current profile settings. To do this, click the **Validate Profile** icon.

After you save the changes in your profile, the **Profile Summary** area will appear. Click the **Detailed Summary** icon to open the Results window, which shows the current profile in a worksheet that you can copy or print.

To view a stress vs. time plot of the profile, click the **Plot** icon. (See ReliaSoft Plot Utilities for general information on plots.)

**Note:** Clicking the **Validate Profile** icon will not automatically update your stress vs. time plot. To make sure your plot reflects the most recent profile information, click the **Plot** icon.

If desired, you can use the Comments page of the control panel to enter notes or other text that will be saved with the profile.

5. **Click OK** to save your changes.
Chapter 18: Resources

Importing Data from nCode GlyphWorks

You can import nCode GlyphWorks time series data from .S3T files for use as stress profiles. The stress values in the .S3T file must be greater than zero in order for the data to be imported.

To import data from an nCode .S3T file, first create a new profile from the Resource Manager (Home > Synthesis > Resource Manager). In the Profile window, click the Import from GlyphWorks icon on the control panel.

This launches the import wizard, which guides you through the steps required to import data from the file. You can then edit the resulting imported data, if desired. Note that if you update the .S3T file in GlyphWorks, the associated profile in ALTA will not be updated automatically. You must re-import the data to reflect the changes.

**Tip:** Because stress units (e.g., volts), throughput units (e.g., kilograms) and time units (e.g., hours) are not defined in the profile, it is important to apply profiles only to folios that are intended to use the same stress/throughput and time units. In the Profile window, you may want to rename column headings (by right-clicking the heading) or use the Comments page as a reminder of which units are applicable to that profile.

Maintenance Groups

Maintenance groups are resources that are available for use throughout the project and can be managed via the Resource Manager. A maintenance group is a set of blocks or system hierarchy items where some event within the group can trigger either maintenance or state changes for one or more blocks or items, either within the group or outside of it. You can use a maintenance group:

- **In BlockSim:** To turn a block on or off. State change triggers are used to activate or deactivate a block when items in one or more specified maintenance groups go down or are restored. The block whose state is being changed may or may not belong to any of the maintenance groups. This allows you to model a cold standby configuration (i.e., one where the component cannot fail when in standby) without using a standby container, which may be useful if you are using a parallel or complex configuration, as blocks can be connected only in series in standby containers.

  - **In BlockSim, RCM++, or RBI:** To trigger a scheduled task (i.e., a preventive task, inspection or on condition task). You can set the task to be performed based on events in one or more maintenance groups. Triggering events within the maintenance group
can include block/item failure; start of corrective, preventive or inspection tasks; and/or block/items restoration. The block(s)/item(s) affected by the task may or may not belong to any of the maintenance groups. For example, if you want to perform preventive maintenance on Component A every time you perform corrective maintenance on Component B, then you can assign Component B to Maintenance Group 1 and then set the preventive task assigned to Component A to be performed upon the start of corrective maintenance within Maintenance Group 1. See Task Scheduling for more information on how tasks can be scheduled.

**Note:** In BlockSim diagrams, blocks that belong to a maintenance group have a red circle at the upper left corner of the block. You can change the size of the indicator via the relevant Block Corner Indicators page of the Diagram Style window. You can change the color used for each maintenance group via the Maintenance Group Manager.

The Maintenance Group window allows you to create, view and edit maintenance groups. It can be accessed by clicking the Create New or View/Edit icon in the Maintenance Group wizard.

It can also be accessed from the Maintenance Groups page of the Resource Manager by choosing Home > Edit > New, by selecting a maintenance group and choosing Home > Edit > View or by double-clicking a maintenance group.

At the top of the window, you can specify the maintenance group name. You can replace the default name with your own name of up to 150 characters, if desired. To change the default names, choose File > Manage Repository > Default Name Formats. (In a secure database, this is available only to users with the "Manage other repository settings" permission.)

You can also enter comments about the maintenance group in this window.

For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

### Maintenance Group Manager

In BlockSim only, the Maintenance Group Manager allows you to add blocks to or remove blocks from a maintenance group without having to go into each block’s properties individually. This window can be accessed by choosing Project > Data Management > Maintenance Group Manager or, when you are viewing the Maintenance Groups page of the Resource Manager, by choosing Home > Actions > Maintenance Group Manager.
The **Maintenance Group** area allows you to choose an existing maintenance group from the drop-down list. In addition, you can click the **Select Existing** icon to open the **Select Resource window**. If there is not an existing maintenance group that meets your needs, you can create a new one by clicking the **Create New** icon to open a window that allows you to specify a name for the new maintenance group, as well as any comments. Click the **View** icon to view the characteristics of the selected maintenance group.
You can also click the **Indicator Style** icon to modify the appearance of the corner indicator that will appear on each block that belongs to the maintenance group, including:

- The indicator's background color, fill color and fill style. The background color is the underlying color applied to the indicator; the fill color is applied over the background color in the pattern specified by the fill style.
- The style (e.g., solid, dash, etc.), color and thickness of the indicator border.

You can change the size of the indicator via the relevant Block Corner Indicators page of the Diagram Style window.

The **Blocks** area displays all of the blocks in the maintenance group, in the format [Diagram Name]\[Block Name].

- To add a block to the maintenance group, you can select the diagram and block in the Add Block area and click the **Add to Maintenance Group** button. You also can select the block(s) in the diagram, press **CTRL+SHIFT** and drag the block to the list in the **Blocks** area of the Maintenance Group Manager.
- To view a block in the maintenance group, select the block in the list and click the **Select on Diagram** button. The diagram will be displayed with the block selected.
- To remove a block from the maintenance group, select the block in the list and click the **Remove from List** button.

**Mirror Groups**

Mirror groups are resources that are available for use throughout the project and can be managed via the **Resource Manager**. You can use a mirror group:

- In BlockSim: To place the same block in more than one location (i.e., to represent a single component more than once in a diagram or in multiple diagrams within a project). See **Mirroring (Using Blocks in Multiple Locations)** in the BlockSim documentation.
- In the FMRA in BlockSim, Xfmea, RCM++ or RBI: To place the same cause in more than one location in the FMRA hierarchy, in order to consider common cause failures. See **Using Mirror Groups in an FMRA** in the Xfmea/RCM++/RBI documentation.
Task Packages

Task packages are resources that can be shared among analyses and can be managed via the Resource Manager. They represent groups of tasks that are performed together at scheduled intervals, for the most efficient allocation of resources and downtime management.

The Task Package window allows you to create, view and edit task packages. It can be accessed by clicking the Create New or View/Edit icon in the Task Package wizard, which is accessed from the Task Package field that appears when you select the Override task scheduling properties with a task package option for a preventive, inspection or on-condition task that is scheduled to be performed at fixed intervals.

It can also be accessed from the Task Packages page of the Resource Manager by choosing Home > Edit > Add, by selecting a task package and choosing Home > Edit > View or by double-clicking a task package.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the resources you need for your analyses.

The following settings are available to configure the task package:

- In the Perform every field, enter the length of the interval at which the task package will be performed. You must specify units for this value.

- The Auto-Packaging Intervals fields allow you to specify a range of scheduled intervals that will automatically be incorporated into the task package if the user clicks the Auto-Packaging Tasks button at the bottom of the Maintenance Task Packaging window in RCM++/RBI. The units for these fields are the same as those specified for the Perform every field. For example, if you enter 150 hours in the Start time field and 200 hours in the End time field, then tasks that are scheduled to be performed at fixed intervals from 150 to 200 hours can automatically be included in the task package to be performed at the scheduled time of the task package rather than at their individually scheduled times.

- Identifiers contains additional identifying information that can be used to search for this resource.

- History provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the record.
• **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

• **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

### Actions

Throughout the Synthesis Platform, your team can use actions to track specific assignments that need to be performed. These versatile resources can be used multiple times in different locations, if appropriate. Specifically, actions can be created, displayed and/or managed:

- via **Project Plans** or the **Resource Manager** in all ReliaSoft desktop applications except MPC.
- via **My Portal** or **Actions Explorer** in all ReliaSoft desktop applications.
- via the **Synthesis Enterprise Portal** (if it is implemented for your database).
- via FMEAs or test plans in Xfmea/RCM++/RBI.

For specific instructions regarding how to create or edit an action in each location, please consult the documentation for that particular feature. This section focuses on general considerations that will be applicable regardless of where/how the action is being used.

**Tip:** If an action is used in an FMEA, the properties window will be different depending on the current context. If you’re using Xfmea/RCM++/RBI and you open the action from the FMEA or My Portal, the window includes additional features that provide quick access to associated FMEA records (failures, causes, etc.) and the FMEA change log (if activated). These features are not available if you open the action from another location (e.g., Resource Manager, Project Planner, Actions Explorer) or in another application, because the associated FMEA can’t be opened in those situations.

### Actions as Resources

As with any other resource:

- Any changes to the action properties will be reflected in all locations where the resource is used.
Chapter 18: Resources

- If you remove an action from an FMEA, a test plan or a Project Plan, the resource will remain in the project unless/until an authorized user deletes it from the database (via My Portal, Resource Manager or Actions Explorer).

**Note:** Actions are always local resources. They cannot be made global. Actions in a reference project are local to that project and can’t be selected for use in other projects.

### Configurable Settings

Some properties for action records can be configured via interface style settings. See **Configurable Settings**.

### Show/Hide Properties for Individual Records

You can also use the following ribbon commands to show/hide certain features for a particular action record.

- **Generic vs. Detailed:** A detailed action contains additional properties for describing a specific test that needs to be performed (Specifications, Requirements and Reports). These properties are not configurable; they may be of interest in test plans in Xfmea/RCM++/RBI. (See Test Plans in the Xfmea/RCM++/RBI documentation.) Most actions, unless they are used in test plans, do not need to display these fields.

- **Show Resources:** The resources fields (Team, Facility, Material and Additional Costs) are used for calculating costs and resource utilization. They are always enabled but you can toggle this command to hide or display them for any particular action record. The **Check Utilization** command provides a summary of the resources that have already been assigned. (See Costs and Man Hours.)

- **Show Review/Approval:** If the Reviewer property is enabled in the configurable settings for the current project, you can toggle this command to hide or display these fields for any given action. The **Review Action** command will be enabled if you are assigned to review the action and it is ready to be reviewed. (See Review and Approve Actions.)

### Priority

The color-coded **Priority** command provides a consistent scale for prioritizing actions across all projects in the database. (The same options are also available for gates in the Project Planner.)
This is intended to be used instead of the configurable **Action Priority** field from prior versions, which can be different for different projects. When you convert from a Version 8/9 database, the software will attempt to match any priorities that were assigned with the old configurable drop-down list. For example, if you were using the default "High," "Medium" and "Low" labels that were shipped with Version 8/9 libraries, they will automatically be mapped to the corresponding options in the new ribbon command.

**Action Status and Review Status**
The action’s status bar displays two complementary status indicators. The first one is based on the actual and expected start date and completion date. It indicates that the action is not started, in progress or complete and whether it is on time or running late. (See **Action Timeline and Status**.)

The second one is based on whether a reviewer has been assigned in the Review/Approval section and, if so, the status of that review.

**E-mail and Alerts**
The **E-mail** command will be enabled if an authorized user has defined a valid SMTP server. This allows you to manually send an e-mail containing the current action details to any valid e-mail address.

If a valid SMTP server has been defined within the database, your team can also choose to use automated alerts (via e-mail or SMS text message). Each individual user can subscribe to “watch” specific action resources, and the database can also be configured to auto-subscribe users assigned to specific roles for the action. (See **Watches and Alerts**.)
Chapter 18: Resources

Click Action Monitors to specify individual users and/or groups of users who will always receive alerts for the record, regardless of whether they have personally subscribed to a “watch.” (See Action and Gate Monitors.)

Add to Outlook Calendar

The Add to Outlook Calendar command will be enabled if Microsoft Outlook is installed on your computer.

It launches Outlook’s interface for creating a new calendar event and automatically populates the subject and date. You can modify the details as needed before saving the new event to your calendar.

Note that you may need to give focus to the Outlook application in order to see the window.

Person Responsible and Resources

For each action resource, you can assign both an individual database user who is primarily responsible for completing the action and a team of users who are also involved. You also have the option to track the percentage of their available time that is planned to be utilized for the activity.

Tip: If a user is assigned as person responsible and also belongs to the team, the costs and utilization values will be summed. For example, the application assumes that the utilization is X% as person responsible plus an additional Y% as a member of the team.

Person Responsible

The Person Responsible field can be enabled or disabled, depending on the configurable settings for the current project. If you want to use personalized alerts, track resource utilization etc., you must select a database user. Alternatively, you can type a text description (up to 150 characters) that will be displayed in the FMEA spreadsheet.
Tip: If you want to change the person responsible for multiple actions simultaneously (e.g., if a user changes roles and his/her actions need to be reassigned), use the Actions Explorer.

If the Set action creator as 'Person Responsible' by default check box is selected in the Repository Settings window, then the person who created the action is automatically shown in the Person Responsible field, but that can be changed.

Resources
The Resources fields are always enabled but you can toggle the Show Resources command to hide or display them for any particular action record.

You can select from the teams, facilities and materials resources that have been predefined within the database (or create them on-the-fly if you have the required permissions). In a secure database, only users with the “Manage project planning resources and working days” permission will be able to create and edit these resources. (See Project Planning Resources.)

<table>
<thead>
<tr>
<th>Resources</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Team</td>
<td>Gizmo Design Team (5%)</td>
</tr>
<tr>
<td>Facility</td>
<td>AES Test Lab (2%)</td>
</tr>
<tr>
<td>Material</td>
<td>N/A</td>
</tr>
<tr>
<td>Additional Costs</td>
<td>1000</td>
</tr>
</tbody>
</table>

Check Utilization
If you need to view the utilizations of users and facilities for the current action, click Check Utilization.

Action Timeline and Status
For all action resources, the status is determined automatically based on the actual and expected start/completion dates. If an action is included in the Project Planner, its expected timeline can automatically shift in response to delays in prior activities. If the action is not included in the plan, the expected dates are always identical to the originally planned dates.
The following status indicators are displayed in the status bar of the action properties window and in other relevant locations. (Note that the status bar now also displays a separate review status to indicate whether a user has been assigned to review/approve the action and, if so, the status of the review. See Review and Approve Actions.)

- **Not Started**: The action hasn’t started, but it can still start on time.
- **Past Start Date**: The action hasn’t started, and it is too late to start on time.
- **In Progress**: The action has started.
- **Past Due**: The action hasn’t completed, and it is too late to complete on time.
- **Completed - On Time**: The action completed on time.
- **Completed - Late**: The action completed late.

**Costs and Man Hours**
For action resources, you can now track the planned vs. actual usage for both costs and man hours.

The **Planned Cost** and **Actual Cost** fields can be enabled or disabled, depending on the configurable settings for the current project. If the properties are enabled, the planned costs will always be calculated automatically based on the action duration, person responsible and project planning resources. For the actual costs, you can choose to enter manually or use the automatic calculations.

**Enter Manually**
If you prefer to enter the actual costs/hours instead of using the automatically calculated values, select **Yes** in the **Manually enter costs/man hours?** field.

<table>
<thead>
<tr>
<th>Manually enter costs/man hours?</th>
<th>No</th>
<th>Manually enter costs/man hours?</th>
<th>Yes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actual Cost</td>
<td>240.00</td>
<td>Actual Cost</td>
<td>475</td>
</tr>
<tr>
<td>Actual Man Hours</td>
<td>2.4</td>
<td>Actual Man Hours</td>
<td>5</td>
</tr>
</tbody>
</table>

Let the software calculate       Enter the values yourself

**Calculate Automatically**
The automatic calculations are based on:

- The Duration (the number of working days from the start date to the due/completion date).
• The Person Responsible and/or the Team:
  • The % utilization is set in each action record.
  • The Hours per Day and Cost Category are set in each user account record.

• The Facility (e.g., test lab or other facility needed to complete the action):
  • The % utilization is set in each action record.
  • The Max Hours per Day and Cost Category are set in each facility properties record.

• The Materials (e.g., test samples or other material needed to complete the action):
  • The Quantity and Cost Category are set in the material properties record.

• Any Additional Costs that are defined directly in each action record.

The following simple examples demonstrate how each type of cost is calculated.

**Personnel Costs**

**Action Duration:** 5 working days

**Joe Engineer:** Works 8 hours per day (5 days x 8 hours = 40 hours)

Time is billed at $100 per hour (no “per instance” cost)

Assigned as **Person Responsible** with 5% utilization (40 hours x .05 = 2 hours)

Also belongs to the assigned **Team** with 1% utilization (40 hours x .01 = .4 hours)

The calculated values for Joe’s work on this action are 2.4 man hours and 2.4 x $100 = $240.

**Facilities Costs**

**Action Duration:** 5 working days

**ABC Test Lab:** Is available up to 8 hours per day (5 days x 8 hours = 40 hours)

The utilization for this action is 20% (40 hours x .20 = 8 hours)

Costs $500 “per instance” plus $50 per hour

The calculated cost for using this facility to complete the action is $500 + (8x$50) = $900.
Chapter 18: Resources

Materials Costs
Gizmo Prototype: Costs $5000 to produce the batch of test units (the “per instance” cost)

The test requires 10 samples

Each unit costs $500 (the “direct cost per hour or unit”)

The calculated cost for the materials required to complete the action is $5000 + (10x$500) = $10,000.

Action Status Updates
For all action resources, the Progress (Status Updates) area displays any notes that have been added to report progress. The software automatically adds these updates under certain conditions (e.g., upon review/approval), and you can also create updates manually when needed.

To add a new note, click Add Status Update in the action’s ribbon or click the heading and then click the Add icon that becomes visible.

The type that you select in the Add Status Update window can affect the actual start and completion dates of the action, and also update the action status. (See Action Timelines and Status.)

- **Not Started** allows you to record comments without entering a start date. If an actual start date has already been entered, the update will remove the date and change the action’s status back to Not Started.

- **In Progress**
  - If an actual start date is not already defined, sets the current date as the Actual Start Date and allows you to specify the % Completed. This will change the action’s status to In Progress.
• If the action is already in progress, allows you to add another note and update the completion percentage.

• **Completed** sets the current date as the **Completion Date**. This will change the action’s status to either **Completed-On Time** or **Completed Late**.

To delete an existing note, click inside the field and then click the **Delete** icon that becomes visible. **There is no undo for delete.**

---

### Review and Approve Actions

**Action resources** can be marked for review and approval. If the Reviewer property is enabled in the **configurable settings for the current project**, you can click **Show Review/Approval** in the action ribbon to hide or display these fields for any given action.

(Note that if an action has been assigned for review or is already reviewed, you cannot no longer hide the fields.)

**Assigning a Reviewer**

If an action has not yet been reviewed, any user who is able to edit the record can assign or change the reviewer at any time.

In a secure database, the Reviewer drop-down list contains all of the database users who have the **"Approve actions" permission**.

* • If a user has been assigned to review the action but an actual completion date is not entered, the review status will be **Reviewer Assigned**.

* • When the completion date is entered and the action is ready for review, the status will be **Pending Approval**.

**Tip:** If you want to change the assigned reviewer for multiple actions simultaneously (e.g., if a user changes roles and his/her actions need to be reassigned), use the **Actions Explorer**.
Chapter 18: Resources

Reviewing and Approving the Action
When you are assigned to review/approve an action that has been completed, the record will be highlighted for you in My Portal (and in the Synthesis Enterprise Portal if implemented), and you may also receive automated alerts (via e-mail and/or SMS) if applicable.

To record your decision, open the action record and choose Review Action.

In the Review Action window, you can choose one of the following options:

- **Approve action** assigns the review date/time and marks the status Approved.

- **Reject and re-open action** removes the completion date and marks the status Rejected and in progress. The team can perform any rework that is needed and resubmit the action for another review.

- **Reject and close action** marks the status Rejected and closed.

You can enter your comments directly in this window, or enter/update them later in the comments field.

Configurable Settings for Actions and Controls
Some of the properties in action records and in control records are configurable via the interface style settings that have been defined for the current project. The interface style is used in Xfmea/RCM++/RBI to customize a variety of analysis fields to fit the organization’s particular preferences and needs. (See Configurable Settings in the Xfmea/RCM++/RBI documentation.)

You can view/edit the configurable settings for actions and controls from any ReliaSoft desktop application by clicking Configurable Settings of the action properties window or the control properties window. (In secure databases, this is available only if the user is the project owner, or has the "Edit project properties" permission.)
Any changes to these settings will apply to all records of that type in the current project.

**Actions Explorer**

The Actions Explorer is available in all ReliaSoft desktop applications except MPC. You can use this flexible tool to explore all of the action resources that are stored in the current database.

To access the utility, choose **Home > Synthesis > Actions Explorer**.

To reduce the amount of time required to populate the grid, first use the Project, Status, User and/or Date filters to limit your search, then click **Load Data**.

**Add, Edit and Delete Actions**

When actions are loaded in the grid, you can use the following ribbon commands to add, edit and delete actions. (In a secure database, the ability to add or edit an action is only available for users with the "Create/edit/delete local resources" or "Create/edit/delete local resources" permission in the relevant project.)

To delete or edit multiple actions at the same time, press **CTRL** or **SHIFT** while clicking rows in the grid. Selected rows will be highlighted.

- **Add Action** creates a new action resource in the project that currently has focus.
- **Edit Action** allows you to view and edit all of the properties of the action that is currently selected.
- **Delete Action** deletes all of the actions that are currently selected. *There is no undo for delete.*

- **Assign Person Responsible** and **Assign Reviewer** allow you to set (or change) the person responsible or reviewer for all of the actions that are currently selected.

**Save and Apply Views**

Once you have customized the grid to suit a particular purpose (using the built-in filter, column configuration and grouping features described below), you can save the preferences as a view that can be used again whenever you need it. A view is saved in the database and available only to the user who created it.
To create a view, first configure the grid to suit your particular needs and then click **Save View**.

To quickly apply these same preferences again at any time, click **Apply View** and select one of the saved views from the list.

---

**Note:** The view does not affect filtering that has been applied from the Project, Status, User and/or Date filters, or from the Relevance Panel.

---

### Project, Status, User and Date Filters

The Actions Explorer can utilize the same project filter that is available in many other locations throughout ReliaSoft desktop applications.

You can also filter by status (e.g., In Progress, Completed, etc.), user (e.g., Person Responsible or Reviewer) and date (e.g., Planned Start Date, Actual Start Date, etc.).

After you clear or change these filters, you must click **Load Data** again to update the grid.

### Relevance Panel

The relevance panel provides a quick way to filter the actions based on how they are relevant to you (based on your personal username).

- **I am responsible for**
  - You are assigned in the **Person Responsible** field.

- **I am a team member in**
  - You belong to the team assigned in the **Team** field.

- **I need to review/approve**
  - You are assigned in the **Reviewer** field.
• **I am monitoring**
  - You are assigned in the Action Monitors window, or you have personally ** subscribed to “watch”** the action.

• **Other actions I created**
  - You are listed in the **Created By** field and none of the other roles apply.

• **All actions**
  - Displays all actions, regardless of whether they’re relevant to you.

**Built-in Find/Filter, Configuration and Grouping Tools**
The Actions Explorer offers the same filter, column configuration and grouping tools that are built in to other utilities that use a similar grid (e.g., the **Resource Manager**). For details about how to use each feature, see:

  • **Finding and Filtering Records**
  • **Configuring Columns**
  • **Grouping Panel**

**Controls**
Controls are **resources** used in FMEAs that are the methods or actions currently planned or already in place to reduce or eliminate risk. Controls can be managed via the **Resource Manager**.

As with any other resource:

  • Any changes to the control properties will be reflected in all locations where the resource is used.
  
  • If you remove a control from an FMEA, it will remain in the project unless/until an authorized user deletes it from the database.
  
  • If a control resource is not currently used in an FMEA, you can delete it via the Resource Manager. (In a secure database, this is possible only if the user a) is the **project owner**, b) is the control creator, or c) has the applicable "create/edit/delete resources" permission.)
Chapter 18: Resources

For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

Note: Controls are always local resources. They cannot be made global. Controls in a reference project are local to that project and can't be selected for use in other projects.

For specific instructions on using controls in FMEAs, see the "Controls in FMEAs" topic in the Xfmea/RCM++/RBI documentation.

Configurable Settings
Some properties for controls can be configured via interface style settings. See Configurable Settings.

Resource Manager
The Resource Manager allows you to create, view, edit and delete resources. It also helps you to trace where each resource is used, and to create global resources that are available to all projects in the database.

To open the Resource Manager, choose Home > Synthesis > Resource Manager.

To use the utility, choose the type of resource that you want to work with in the navigation panel on the left side of the window. A table that displays the resources of the selected type will be shown on the right side of the window.

Tip: When you need to create or edit a large number of resources, you can also use Synthesis APIs to import the data from an Excel file or other data source. For example, the URDExample.xlsm file at C:\Users\Public\Documents\ReliaSoft\Examples18\API enables you to quickly create/update multiple URDs with some basic properties (models and corrective tasks). If you have the necessary software coding experience, you can expand this tool or create your own custom applications to meet specific needs.
Resource Filter

The Resource Manager can utilize the same resource filter that is available in many other locations throughout ReliaSoft desktop applications.

Built-in Find/Filter, Configuration and Grouping Tools

The Resource Manager offers the same filter, column configuration and grouping tools that are built in to other utilities that use a similar grid (e.g., the Synthesis Explorer, Actions Explorer, etc.). For details about how to use each feature, see:

- Finding and Filtering Records
- Configuring Columns
- Grouping Panel

Creating, Viewing, Editing and Deleting Resources

You can:

- Create a new resource of the selected type by choosing Home > Edit > Add.

To add multiple resources at the same time, specify the quantity in the Home > Edit > Number to Add field and then choose Home > Edit > Batch Add. You will specify the properties for one of the new resources, and the additional resources will be duplicates of that. You can then edit each resource individually, or you can go to the Batch Properties Editor to edit them in a spreadsheet format.

- Duplicate an existing resource by selecting the row in the table and choosing Home > Edit > Duplicate. You can choose to duplicate just the selected resource, or choose Cascade Duplicate to duplicate the resource and all resources assigned to it, at all levels (e.g., cascade duplicating a corrective task will also duplicate the task's duration model, the assigned crew and all models assigned to the crew, etc.).
Chapter 18: Resources

- View or edit an existing resource by double-clicking the row in the table or by selecting the row and choosing Home > Edit > View.

- Delete an existing resource by selecting the row in the table and choosing Home > Edit > Delete.

You cannot delete a resource that is currently being used in any other resource or analysis.

**Note:** A published model cannot be edited or deleted from the Resource Manager. If changes are needed, you must update the original analysis and then republish the model. If you wish to delete the model, you must first remove the association with the original analysis and also make sure the model is not being used. (See Publishing Models.)

**Tracing Where Resources Are Used**

With a single resource selected, you can choose Home > Selected Resource > Trace Usage to open the Dependency Viewer, which provides information on where the resource is used and any additional resources that the currently selected resource itself uses.

If you need to know which resources are not currently being used (e.g., because you want to delete obsolete records), choose Home > Display > Show Only Unused.

**Local and Global and Reference Resources**

As explained in Local, Global and Reference Resources, the availability of resources for use is determined by their scope. Local resources are available only in the current project. Reference resources are available for any project within the database, depending on the user's permissions within the reference project. Global resources are available for use in any project in the database.

The far left column in the Resource Manager displays an icon that indicates whether each resource is local, global or a reference resource.

| Local Resource | Global Resource | Reference Resource |

http://predict.reliasoft.com
You can use the **Home > Display > [Show Local/Show Global/Show References]** commands to toggle the types of resources shown in the Resource Manager.

**Exporting Information from the Resource Manager**

To send the contents of the Resource Manager to Excel, or to a built-in [Synthesis Workbook] or spreadsheet if that's available in the current application, choose **Administration > Output > Transfer Report**.

You can send either the current item (i.e., the table for the currently displayed page) or the full report (i.e., the tables for all pages in the Resource Manager).

**Finding and Filtering Records**

This topic describes the find and filter tools that are built in to the Resource Manager and other utilities that use a similar grid. Each of these tools can be used separately, or in conjunction with the others.

**Find Panel**

The Find panel allows you to search for a word or phrase across all of the available properties. To show or hide this panel, toggle the **Show Find Panel** command on the ribbon or in the shortcut menu that appears when you right-click a column heading.
Chapter 18: Resources

When you enter text into the Find panel, it will return only the fields that contain the text you specified, as well as highlight all of the locations where the matching text occurs.

To stop filtering the data, clear the text box.

![Auto Filter Row](image.png)

**Auto Filter Row**

The Auto Filter Row allows you to filter the grid based on a selected filter operator.

To display or hide this row, toggle the **Show Auto Filter Row** command on the ribbon or in the shortcut menu that appears when you right-click a column heading.

Click the selector icon in the auto filter row and then enter the search text or value against which column will be filtered, as shown below. The set of filter operators available for a column depends on the type of data the column displays.

For example, the following filter shows only the rows in which the model name contains "Component A" and the distribution contains "Weib."

![Auto Filter Row Example](image.png)
Advanced Filters
The Advanced Filters allow you to choose an automatically generated filter or create a quick custom filter. The automatically generated filters are based on the unique values that currently exist in the column.

For example, the following picture is based on a data set that contains models from three different categories. If you choose one of the automatically generated filters (e.g., "Reliability"), the grid will display only models of that one selected category.

If you want to see models from two of those categories (e.g., either "Reliability" or "Probability of Failure"), you can choose [Custom] and create a quick custom filter like this:

If a filter has been applied for a particular column, select [All] to remove it.

Current Query Criteria
When you are filtering the grid using the Auto Filter Row, Advanced Filters and/or Edit Filter window (described below), the current query criteria will be displayed at the bottom of the window. For example:
Chapter 18: Resources

- Click the X to delete the current set of filter criteria.
- Clear the check box to remove the current set of criteria without deleting it. Select the check box if you want to re-apply it.
- Click \( \checkmark \) to choose from a list of filter criteria that were recently applied.

**Edit Filter**

The Edit Filter window provides the most flexibility to refine and adjust a filter in either a grid or a Dashboard layout. To access the tool, click the **Edit Filter** button to the right of the current query criteria (if applicable), or choose **Edit Filter** from the shortcut menu.

As an example, the following filter from the Resource Manager will display only cost per unit time models in which the rate equals either $120 per hour or $2 per minute.

- Click a red label if you want to:
  - change the *logical operator* (And, Or, Not And, Not Or)
  - add or remove a *group*
  - add a *condition*
  - clear the entire filter
• Use the ◉ and ◉ icons to add or remove conditions within an existing group.
• Click a blue label if you want to change the property (e.g., Model Name, Created By, etc.).
• Click a green label if you want to change the relational operator (e.g., Equals, Contains, Begins with, etc.).
• Click a gray or black label if you want to enter or change the value.

**Configuring Columns**
This topic describes the capabilities for selecting, reordering, resizing and sorting columns that are built in to the Resource Manager and other utilities that use a similar grid.

**Selecting Columns**
To specify which columns will be displayed in the grid, click **Select Columns**.

In the utility's window or panel for selecting columns, use the check boxes to choose which columns will be displayed. As an example, the following pictures show the window and panel for model resources in the Resource Manager.
Reordering Columns
To change the column order, drag the column heading into the desired position.

Resizing Columns
To resize columns, you can do any of the following:

- Drag the edge of the column heading to the desired position.
- Double-click the edge of the column heading or right-click it and choose **Fit This Column**. This will resize the column to fit its data.
- Right-click any column heading and choose **Fit All Columns**. This will resize all columns to fit their own data.

Sorting Columns
To sort the grid by one column at a time, you can simply click the column heading to sort in ascending order (↑), or click it again to sort in descending order (↓).

To sort the grid by multiple columns, right-click each column in the desired order and choose **Sort Ascending** or **Sort Descending** each time. For example, the following picture shows Synthesis Explorer data sorted first by project (ascending) and then by category (descending).

To stop sorting, right-click any column heading and choose **Clear All Sorting**.
Grouping Panel

This topic describes the grouping panel capability that is built in to the Resource Manager and other utilities that use a similar grid.

When you are working with a large amount of data, it may be convenient to group it based on one or more properties. For example, the following picture shows resources in the Resource Manager grouped first by keyword and then by model category.

To group the data without opening the grouping panel, right-click any column heading and choose Group By This Column. Alternatively, you can choose Show Grouping Panel to display the panel and then drag column headings into or out of the panel to configure the groups.

When the grouping panel is displayed, you can also:

- Click the column heading to change the sort order between ascending (↑) or descending (↓).
- Drag column headings within the panel to change the grouping order. For example, if you prefer to group first by model category and then by keyword, drag the column headings as shown below.
Removing Unused and Duplicate Resources

The Resource Manager provides several tools to make it easy to delete unused resources and merge duplicate resources.

Finding and Removing Unused Resources
To find unused resources of the selected type, choose Home > Display > Show Only Unused.

Once you have found the unused resources, you can decide which ones to delete. You can return to viewing all resources of the selected type by choosing the Show All command.

Finding Duplicate Resources
You may sometimes have duplicate resources within a project (i.e., several models that all represent the identical distribution, several tasks that are identical, etc.) within a project. For example, this might happen if you have imported diagrams that all reference the same model, but the imports happened at separate times and therefore the model had to be imported again each time.

To find duplicate resources, choose Home > Display > Show Only Duplicates.

In the window that appears, select the properties that must match in order for the resources to be considered duplicates. For example, if you are looking for duplicate URDs, you might select
to compare the model, corrective task and scheduled tasks, but not the URD name. Once you have selected the columns to compare, click OK to show the duplicate resources.

You can merge multiple resources of the same type into one resource, either automatically or manually. Note that models must be of the same category in order to be merged, and you cannot merge published models.

**IMPORTANT:** Merging cannot be undone, and only the information from the "target" resource (i.e., the resource that you merge the others into) will be retained.

### Automatically Merging Duplicates
To merge resources automatically, choose Administration > Cleanup > Merge All Duplicates.

This will find all sets of duplicates within the selected resource type (e.g., three identical Weibull models and 2 identical lognormal models); and for each set, it will merge the duplicates into the first instance found. After you confirm that this is what you want to do, you will be prompted to select the properties that must match in order for the resources to be considered duplicates. The process begins as soon as you select at least one column and click OK. It cannot be undone.

### Selecting Resources to Merge
To merge resources manually, select the resources and choose Administration > Cleanup > Merge & Delete.

The window shows a list of the resources you selected to merge and allows you to choose which one will be retained (i.e., the one that the other selected resources will be merged into). After you click OK, this resource will be used in all places where the other selected resources were previously used.

### Select Resource Window
The Select Resource window allows you to choose an existing resource to use at your current location. You will see this window in situations like the following:

- When you click the Select Existing icon in any resource wizard.
• When you are adding an existing action in an FMEA or in the Project Planner, or an existing control in an FMEA.

The Select Resource window is similar to the Resource Manager, but it shows only the resource type that you are currently working with. The functionality of the window will vary slightly depending on where you have opened the window from.

• If you can select only one resource (e.g., in a resource wizard), each row in the table will contain a radio button that allows you to select the resource for use. If you can select multiple resources (e.g., adding existing actions or controls in an FMEA), each row will have a check box instead.

• Actions, controls and metrics are always local, so the commands to show global or reference resources will not be available in these cases.

• The ability to apply an item filter is available only for resources that have a full set of identifiers. This excludes actions and controls.

• Some resources may not be available for selection. For example:
  • In an FMEA, you can't select an action or control that is already assigned to the current cause.
  • In the project planner, an action cannot be added if it is already in use in the project plan or if its start date is either before or more than a year after the gate's start date.
  • A metric can't be selected to have a value pushed to it if it's already in use somewhere else, or if it's a type that is not compatible with the current use.

Trace Usage

Dependency Viewer
Because resources can be used multiple times, it is important to know where a given resource is used before making changes to it. The Dependency Viewer, which is accessed by clicking the Trace Usage icon in each resource properties window or in the Resource Manager, provides information on where the resource is used and what additional resources, if any, it uses.

The selected resource is shown in the Current Selection area in the middle of the Dependency Viewer.
The items that use the selected resource, if any, will be displayed in the **This [resource] is used by** area on the left. If it uses any resources, those resources will be displayed in the **This [resource] uses** area on the right. For example, in the picture shown next, the selected resource is a URD. It is used by Block 1 in a BlockSim diagram and by SubSystem 1 in an FMEA analysis. The URD uses an assigned model and two tasks.

You can edit any resource shown in the Dependency Viewer by right-clicking it and choosing **Edit Item** on the shortcut menu. The resource's properties window will open.

You can double-click an item in either area to make it the current selection in the window. For example, you could double-click a task used by the URD to see the model(s), crew(s) and/or spare part pool(s) that the task uses.

As you change selected items, each previous item that you selected will be added to the “path” of recent selections at the top of the window; click **Back** to go back through the path to the previously selected items. For example, the following picture shows a path in which the user started with the URD, then proceeded to its corrective maintenance task, the crew for that task and the logistic delay for that crew (not shown in the path because it is the current selection).

The button now provides a quick way to go back through those same resources in reverse order if needed.

You can click the **Diagram View** button to open the diagram view of the Dependency Viewer. The currently selected item will be the main block in the diagram that is created.
Choosing What You See

In the Current Selection area, you can choose what is shown in the This [resource] is used by area. You have the option to skip the URD and/or the block that the resource is used by. For example, the image below shows the connections among analyses and resources that we have been discussing. If you have selected to show all levels, you can trace from Reliability Model to URD 1 to Block 1 to RBD 1. But if you have selected Skip Blocks and RBDs, it just shows that Reliability Model is used by RBD 1.

![Diagram showing connections among analyses and resources]

Note that blocks are always skipped in RENO flowcharts (i.e., only the flowchart will be shown as the precedent for a resource used by any block within the flowchart).

Dependency Viewer - Diagram View

The diagram view of the Dependency Viewer, which is accessed by clicking the Diagram View button, offers a diagram-based alternative to help you understand the connections among resources in your project.

To understand how to use this view, consider the same example shown in the Dependency Viewer topic. Clicking the Diagram View button for that example will yield a diagram view that shows only the main item (in this case, the URD), which is marked with a flag:
To view a graphical representation of the information that was shown in the Dependency Viewer, choose **Add One Level Precedents** and **Add One Level Dependents**. This will show the items that use the resource (i.e., its precedents), and the resources that it uses, if any (i.e., its dependents).
If you want to see all levels, choose **Add All Precedents** and **Add All Dependents**:

![Diagram of a reliability diagram with blocks and arrows connecting them.]

If you want to add or remove one branch at a time, click the green arrows on the sides of the blocks. Alternatively, if you want to remove one branch, select the block and choose **Delete Precedents** or **Delete Dependents**.

To set a different item as the main item in the diagram, select it and choose **Set Block as Main**. This serves the same purpose as changing the selected block in the Dependency Viewer.

Use the commands in the Options group of the ribbon's Home tab to specify how the diagram will be constructed:

- Select **Reuse Items** to show each item only once in the diagram. For example, if you are viewing a URD that is used by two blocks in the same diagram and you choose **Add All Precedents**, the Reuse Items command will affect the display as shown next:
This command must be selected before the diagram is created, or you must clear the current diagram to apply it.

- Use the **Show Blocks in RBDs/FTs** and **Show URDs** commands to determine whether blocks and/or URDs are shown as intermediate steps between resources and the analyses in which they are used.

- Select **Show Item ID** to display the internal ID assigned to each resource, block and/or diagram. These IDs can be used to differentiate among items that share the same name.

The Diagram tab of the ribbon offers zoom options and [printing options](#), as well as the ability to copy the diagram or to export it as a graphics file.

**Batch Properties Editor**

The Batch Properties Editor is designed to support batch editing of most types of local resources in the current project. In BlockSim, it also allows you to edit the blocks used in the diagrams. It enables you to edit the properties in a convenient grid, rather than opening the properties window for each individual resource/block. This utility is available for all desktop applications except MPC.

To open the Batch Properties Editor, choose **Home > Synthesis > Batch Properties Editor**.

To use the utility, choose the type of resource or diagram that you want to work with in the navigation panel on the left side of the window. The right side of the window shows the
resources or blocks you can edit. For information on configuring the table and limiting the items shown, refer to the Configuring Columns and Finding and Filtering Records topics.

**Tip:** If you change the information in one column, it may affect the information required in another column. For example, if you are editing a model and you change the Model Type column from "Weibull-2" to "Weibull-3," then the Parameter 3 column will change from "N/A" to requiring a numerical input for the third parameter for the Weibull distribution (i.e., gamma).

The changes you make in the Batch Properties Editor will be saved when you close the window. You can also choose Home > Display > Refresh to commit your changes immediately and refresh the Batch Properties Editor to display the most current information, including recent changes by other users.

Note the following:

- **Gray Background.** If the property does not apply to the corresponding resource or block, "N/A" will appear in the column and the cell will have a gray background. Properties that cannot be edited via the Batch Properties Editor, such as the model category, will also have a gray background.

- **Published Models.** Models created by publishing results from an analysis in a ReliaSoft application cannot be edited in the Batch Properties Editor. To edit a model that was published from an analysis, you must return to the original data source, make the necessary changes, recalculate and republish the model.

- **Model Parameters.** Since the required parameters for a model will vary depending on the model type, the way you use the parameter columns in the Batch Properties Editor will vary. The parameter columns in the Batch Properties Editor for each model type are presented in the table shown next.
Spreadsheet Editor

You can choose the **Spreadsheet Editor** command on the ribbon to open the Spreadsheet Editor, which displays the resources or blocks in a spreadsheet-based view. This enables you to use the capabilities inherent in a spreadsheet (e.g., batch copying, formulas, etc.) to make editing multiple items easier. When you are finished editing, choose Close > OK to save your changes and close the Spreadsheet Editor or Close > Cancel to close the Spreadsheet Editor without saving your changes.

Exporting Information from the Batch Properties Editor

To print the contents of the Batch Properties Editor, choose Administration > Output > Print command on the ribbon.

To send the contents of the Batch Properties Editor to Excel, or to a built-in Synthesis Workbook or spreadsheet if that's available in the current application, choose Administration > Output > Transfer Report.
You can send either the current item (i.e., the table for the currently displayed page) or the full report (i.e., the tables for all pages in the Batch Properties Editor).

**Tip:** When you need to create or edit a large number of resources, you can also use Synthesis APIs to import the data from an Excel file or other data source. For example, the URDExample_V10.xlsm file at C:\Users\Public\Documents\ReliaSoft\Examples10\API enables you to quickly create/update multiple URDs with some basic properties (models and corrective tasks). If you have the necessary software coding experience, you can expand this tool or create your own custom applications to meet specific needs.
Chapter 19: Project Planner

The Project Planner provides extensive project planning and management capabilities, including the ability to create timelines, evaluate progress, track resource usage and estimate costs. Any project in a Synthesis repository can be associated with a project plan.

The Project Planner allows you to create, edit or view the plan in any ReliaSoft desktop application except MPC. If the Synthesis Enterprise Portal (SEP) has been implemented for an enterprise database, you can also access a streamlined view of the plan from any web-enabled device.

Creating a Project Plan
Each project in the database can have a project plan. To view the plan from within an open project, choose Project > Management > Project Planner. (In a secure database, any user with "read" access to the project will be able to view the plan and update any actions that are assigned to them. However, only users with the “Create/edit project plans” permission will be able to create or edit the plan.)

A blank plan will be created automatically the first time you open the Project Planner in a given project. By default, the project plan shows a sample starting gate, which records the date you opened the project plan for the first time. You can edit the sample gate and start building the plan from there.

Importing or Starting Again from a Blank Plan
Alternatively, you can start again from a blank plan or import an existing project plan from another project. In the Project Planner, choose Project Planner > Plan > Create Project Plan. (In a secure database, this command is available only to users with the “Create/edit project plans” permission.)
Then choose one of the following options. In both cases, you will need to enter the date the plan will begin in the **Set Start Date** field at the bottom of the window.

- **Choose Blank** to start again from a blank plan. This will delete all of the current gates (*there is no undo for delete*). It will also remove any actions that are assigned to the plan. The action resources will remain in the database unless/until an authorized user deletes them from the database via **My Portal**, **Resource Manager** or **Actions Explorer**.

OR

- **Choose Import from another project** to import an existing plan. You can import from another project in the current database or from any other existing standard or enterprise database.

Choose a source repository and source project for the import. The **Plan Preview** area shows the gates and actions (if any) in the project that is currently selected. By default, the import includes both gates and actions. If you want to import gates only, clear the **Include actions** check box at the bottom of the window.

**Tip:** If you want to use any of the Design for Reliability (DFR) project planning “starter” templates that were installed with Xfmea/RCM++/RBI Version 9, you can either import directly from one of your own projects (converted to Version 2018), or use the "Project_Planner_Templates_Rev1" database (choose **File > Help > Open Examples Folder** then open the file in the "Project Planner" folder). To preserve the integrity of this database, a copy will be created.

**Project Plan Hierarchy**

In the **Project Planner**, the plan consists of gates arranged in a tree-based hierarchy to represent the different phases of a process. You can also include **action resources** that represent specific assignments that need to be performed. For example, the configuration below shows a plan with five top-level gates (Concept Phase, Design Phase, etc.), where each gate has its own sub-gates and actions.
Certain properties of higher-level gates (e.g., status and dates) are determined by the properties of their dependent gates and actions. For example, the "Concept Phase" above has two direct dependents. If these are marked as complete, then "Concept Phase" is automatically marked complete. (See Gates in the Project Plan for details on how gates inherit their properties.)

In this way, the planner makes it easy for you to monitor how the progress of individual activities relates to the completion of the entire process.

**Project Planner Columns**

To hide or display Project Planner columns, right-click the column headings then click Customize Columns. (You can also change the column order by dragging and dropping column headings into the desired positions.) These settings are stored per computer/username. Any project that you open on this computer will have the same columns displayed, but other users may have different display preferences.

- **General** columns display graphics/text to summarize the status, as well as the priority level and percent completion.

- **Planned Timeline** columns display information about the original plan, including planned start/due dates and resource usage. You can also display the percentage of the budget that is allocated to different project planning resources (i.e., teams, facilities and materials).

- **Expected Timeline** columns display expected start/completion dates given any delays that may have occurred for prior activities, as well as estimates of the costs/man hours to date. (See Project Planner Timelines.)

- **Actual Timeline** columns display actual start/completion dates, as well as the costs/man hours that were used for completed gates/actions.
• **Delta Values** columns compare two different values, such as the difference between an action's actual and planned costs.

• **Relevant Metrics** display values for up to three selected metrics. (See [Using Metrics in Project Planner Gates](#).)

• **Notes** display other applicable information, including descriptions, completion notes and whether an attached file exists.

**Project Planner Timelines**

For gates in the Project Planner, and for any action resource that is included in a project plan, three different timelines are used to track progress:

• The **Planned** timeline consists of the originally planned start/completion dates.

• The **Actual** timeline records when a gate or action has actually started or completed.

• The **Expected** timeline shows the start/completion dates that are now expected given the current situation. For project plans that use precedents, the expected dates for an activity automatically shift in response to delays in prior activities.

All of these timelines can be shown in gate/action properties and in the Project Planner hierarchy columns. The expected dates are used to determine the status (e.g., past start date, past due, etc.) and are also shown on the summary panel.

**Planned Dates**

For actions and for gates with no specified precedent, the planned start/completion dates are entered directly in the Gate Properties window.

For gates with precedents, the planned start date is automatically set to the working day following the precedent's due date (i.e., planned completion date). By using precedents in your plan, you guarantee that there will be no gaps between one gate's due date and the next one's start date.

In addition, the software uses the following rules to make sure a gate's planned timeline is consistent with that of its dependent gates and actions:

• If a gate's planned start date is changed (e.g., because of changes to a prior gate's planned duration), the planned dates of all dependents will be shifted in the same way.

• You cannot change a dependent's planned start date to precede that of its parent gate.

• If a dependent's due date is changed so that it comes after its parent gate's due date, the parent gate's due date will be changed to match it.
Actual Dates
Actual start/completion dates are entered directly for actions and for gates with no dependents. For gates that have dependents:

- The parent gate's actual start date is automatically set to match the earliest actual start date of its dependents.
- Once all the dependents have completion dates, the latest of those dates is set as the parent gate's actual completion.

Expected Dates
By default, expected start/completion dates are equal to the planned dates. However, if the gate/action is part of a plan that uses precedents, the two timelines can differ.

Specifically, when precedents are used, the expected dates will automatically shift in response to recorded delays in prior gates (while the planned dates remain unchanged). For example, if Gate A is the precedent of Gate B, and Gate A completes two days late, then the expected dates for Gate B will be its planned dates + two days. The same will apply to any other gates with precedents that trace back to Gate A.

As an example, consider the following Gantt chart for a plan that has not yet started. The planned and expected timelines (shown in gray and black, respectively) are identical at first.

However, if Gate A completes late (shown in red), the expected timeline shifts for the remaining gates. (The overall plan bars at the top also indicate that the expected duration for the entire plan has now increased by two days.)
Project Planner Gates

Each gate in the Project Planner has its own properties and a status that is determined based on its expected start/completion dates. Additional information about progress and resource usage is available in the summary panel.

To view the properties of a gate, double-click it, or select it and choose Project Planner > Gate > Edit Gate.

Gate Properties

- The Gate fields provide general information about the gate, including its Name, Description and:
  - Deliverables are what will be produced and delivered as a result of completing the gate.
  - Priority is a ranking of the gate's importance ("Low," "High," etc.).

- The Precedent Gate field identifies the gate that must be completed before the current gate can start, if any. If you choose to use precedents in a project plan:
  - The precedent gate must be on the same level in the hierarchy as the current gate. (If the Use Precedence option is selected, the precedent will be suggested automatically for each new gate you create but you can change it manually if desired.)
  - When a gate has a precedent, its planned start date will be automatically set to the working day after the precedent's due date. In addition, delays in the precedent will automatically shift the expected timeline for future gates.

- The Planned Timeline consists of the originally planned start/completion dates.

- The Expected Timeline shows the start/completion dates that are now expected given the current situation. For project plans that use precedents, the expected dates for an activity automatically shift in response to delays in prior activities. (See Project Planner Timelines.)

- The Actual Timeline records when a gate or action has actually started or completed. If the gate has dependents, these dates are automatically inherited in the following way:
  - The actual start date is the earliest actual start date from the dependents.
• The actual completion date is the latest actual completion date from the dependents.

• The **Relevant Metrics** fields let you display up to three relevant metrics in the gate. The **Push to Metrics** fields let you "push" the gate's percent completed and actual vs. planned resource usage to metrics so they can be tracked and displayed in other locations. (See [Using Metrics in Project Planner Gates](#).)

• The **History** fields display information about when the gate was created and last modified. If the **history log** has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the item.

• **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the gate is changed. (See [Subscribing to a Watch](#).)

• **Gate Monitors** allows you to specify individual users and/or groups of users who will receive alerts for the gate, regardless of whether they have personally subscribed to a watch. (See [Action and Gate Monitors](#).)

**Gate Status**

The gate status (which is displayed in the summary panel and in the status bar) is determined based on the same logic used for action statuses, which takes into account the expected start/completion date and any actual dates. For example, a gate's status is "Past Start Date" if it hasn't started and it's too late to start by the expected date, while "Past Due" means it is too late to complete on time.

**Actions in Project Plans**

You can add actions to gates in the **Project Planner** in order to track specific assignments that need to be performed as part of specific phases of the plan. These are the same **action resources** that can be included in **My Portal** and **Synthesis Enterprise Portal**, as well as FMEAs or Test Plans in Xfmea/RCM++/RBI.

When you add an action to a gate in the Project Planner, the software will:

• Use **timelines** in the action that automatically shift in response to delays in prior activities, which will affect how the action's **status** is determined.

• Display the action's **plan summary** in the Action properties window.
• Use the action’s status, percent complete and resources to “roll up” to the gate it is assigned to.

Adding Actions to the Plan
With a gate selected in the Project Planner, choose Project Planner > Action > Add Action. (In a secure database, this is only available to users with the “Create/edit project plans” permission.)

- Add Action creates a new action resource.
- Reuse Action Resources allows you to select existing action(s) from the project that a) are not already used in the current plan and b) have dates that fit within the current gate. Specifically, the action’s start date can’t be before or more than a year after the gate’s start date. (See Select Resource window.)
- Reuse FMEA Actions allows you to select one or more Xfmea/RCM++/RBI system hierarchy items from the current project that have FMEAs. You can then select to use existing action(s) from those particular FMEAs in the project plan.

Project Plan Summary Panel
The project plan summary panel displays information about start/completion dates, status, progress and resource usage for an entire project plan, and for individual gates and actions.

The summary panel is accessible from multiple locations across the Synthesis Platform:

- From the Project Planner, you can select a gate or action in the hierarchy to view its summary, or you can select the project at the top of the hierarchy to view a summary of the entire plan.
- The gate/action properties window shows the summary for that gate/action.
- The Plan Summary Page in My Portal displays a summary of the entire plan for the project that currently has focus.
- These summaries are also displayed in the web-based Synthesis Enterprise Portal (SEP), if it is implemented for an enterprise database.
In most cases, this shows the current date. If you are working in the Project Planner and you want to see what the statuses would be on a different date, click the green “play” arrow (▶) and then select a different date from the calendar. When you’re ready to return to the current date, click the green “pause” bars (■).

This bar displays the name of the project, gate or action that the summary applies to, followed by:

- The EXPECTED start date and completion date. (This will be the same as the planned dates unless a prior delay has caused the expected dates to shift.)
- The ACTUAL start date and completion date (if the action is in progress or complete).
- The current status. (See Action Timeline and Status.)

For actions, the progress bar shows the percentage entered by the user. For gates, it shows the percentage of the total duration of dependent actions/gates that is complete. For example, if Action 1 (duration = 3 days) is complete and Action 2 (duration = 1 day) is incomplete, the progress is 75%.
For resource usage, the black bars show the planned man hours and costs. The colored bars show either the expected usage to date (estimated based on the number of days in progress), or the actual usage if complete. (See Costs and Man Hours.)

- Yellow = In progress and usage to date is still within plan
- Orange = In progress and usage to date has exceeded plan
- Green = Complete and actual usage was within plan
- Red = Complete and actual usage exceeded plan

The pie chart will be visible only for projects or gates that have at least one action assigned (either directly or via dependent gates).

- Not Started = Actions that have not started and can complete on time
- In Progress = Actions that are in progress and can complete on time
- Completed = Actions that have a completion date
- Past Due = Actions that can no longer complete on time
Check Utilization

The Check Utilization window lets you examine the utilizations for individual users and facilities across one or more actions. It displays the total utilization for each resource on each specific date, so you can easily identify dates when the resource is over-utilized and make any adjustments that may be needed.

- To view utilizations for a specific action, open the action and choose **Tools > Check Utilization**.
- To view utilizations across multiple actions, open the **Project Planner** and choose **Project Planner > Tools > Check Utilization**.

If you open the utility from the Project Planner ribbon, there are two options. By default, it shows **Only actions in this plan**. Alternatively, you can choose to see utilizations from **All actions in the project** (even if they are not used in the plan).

Regardless of whether you’re checking a single action or the entire project plan, the utility shows **All resource utilizations** by default. Alternatively, you can choose to see **Only utilizations over 100%**.

Over-utilized resources (i.e., those with a utilization that exceeds 100%) are shown in red.

Double-click a resource to view its total utilization for each specific date, as well as the action(s) that use the resource on each date. For example, according to the window shown next, Joe Reliability's highest utilization for a single day exceeds 100%. By double-clicking his name, you can see that he is assigned to two actions that overlap on 1/6/2016, and as a result his combined utilization for that day is 105%.
Project Planner Gantt View

The Project Planner also includes a Gantt chart that makes it easy to visualize the timelines in your project and examine how different planning resources are utilized over time.

To access this view, click Gantt at the bottom of the Project Planner.

- Use the Gantt Type drop-down list on the control panel to specify what to display:
  - Project Plan shows timelines for gates and actions.
  - Personnel Utilization and Facility Utilization show the utilizations for the person responsible, team and/or facilities. (See Project Planning Resources.)
- In the Gantt Display area, select the part of the plan you want to view in the Filter drop-down list. For example you could view a specific gate (and its dependents) or a specific user (and all their utilizations). If you want to change the widths of columns that contain dates, use the Fit Mode.
- In the Date Selections area:
  - Select to view the entire plan or focus only on a specific date range.
  - Specify whether each column represents a specific number of Days, or Other increments such as weeks, months, quarters, etc.
- In the Date Display area:
  - If each column represents a single day, select whether to display Non-Working Days. If displayed, those columns will have a gray background. (See Working Days/Holidays.)
  - Use Show Planned, Show Expected and Show Actual to specify which timeline bars will be displayed.
    - To specify the colors that will be used in both the project plan Gantt chart and the timeline plot, choose View > Settings > Set Colors. (See Set Colors for Project Planner.)
    - For the planned and actual timeline bars in the project plan chart, you can also choose whether to Show Percent Completed.
• If you are using one of the utilization charts and the date columns each represent more than a single day, use the **Calculate Utilization As** area to specify how to calculate the utilization. This can be:

  • The **Max** (highest) daily utilization among all days in the interval. For example, if the interval is 3 days and the utilizations were 15%, 0% and 10%, the max will be 15%.

  • The **Average** across only the days in the interval that have utilizations. For example, if the interval is 5 days but the resource was only utilized on 3 of those days, the average will be the total utilization/3 days.

  • The **Overall Average** across all working days in the interval. For example, if the interval is 5 working days, the overall average will be the total utilization/5 days even if the resource was not utilized every day.

### Project Planner Plot View

The **Project Planner** includes a plot view that makes it easy to visualize the **timelines** in your project.

To access this view, click **Plot** at the bottom of the Project Planner.

- Use the **Filter Options** area to select whether to filter the data by **Gate** or by using a **Date** range. You can also choose to view data for **Top Level Gates** only.

- In the **Display Options** area:
  
  • **Show Planned, Show Expected** and **Show Actual** determine which timelines will be shown in the plot.

    • To specify the colors that will be used in both the project plan Gantt chart and the plot, choose **View > Settings > Set Colors**. (See **Set Colors for Project Planner**.)

  • **Display Actions** shows the dependent actions for each gate.

  • **Show Project Item** shows the “project” gate at the top of the hierarchy.

  • **Show First Gate on Top** determines whether the gate with the earliest start date will show at the top or bottom of the chart.
• **Auto Refresh** refreshes the plot automatically whenever changes have been made. If this option is cleared, you can click the **Redraw Plot** icon (🎉) to refresh the display.

• **Keep Aspect Ratio** maintains the proportional relationship between the width and height of the plot image.

### Set Colors

To open the Set Colors window for the Project Planner, choose **View > Settings > Set Colors**.

- **The Gate and Action Options** apply to the Gantt chart (if viewing the plan), plan hierarchy and plot.

- **The Date Display** options apply only to the Gantt chart and plot.

- **The Utilization Threshold Colors** apply only when using the Gantt chart to view team or facility utilization.
Project Planner Dashboards
You can use the flexible Synthesis Dashboard utility for presenting data from any Project Planner in the database.

To access this feature, open the planner and choose Project Planner > Tools > Dashboard.

As with any other Synthesis dashboard, you can use the Dashboard Viewer to select any of the layouts that have been predefined for this type of data. In a secure database, only users with the "Manage dashboard layouts" permission can use the Dashboard Manager to create or edit layouts.

Data Source Drop-Down List
When you are creating a dashboard layout based on project plan data, the drop-down list at the top of the Data Source Panel gives the following options:

- **Actions** returns data only from actions in the current plan.
- **Gates** returns data only from gates in the current plan.
- **Gates/Actions** returns data from both actions and gates.
Facilities returns data from the facilities assigned to actions.

Personnel returns data from the person responsible and/or team assigned to actions.

Each data source allows you to choose relevant fields from the record properties, summary panel and/or project plan hierarchy.

Note that all of the data fields used within a particular dashboard item must come from the same source. For example, you can’t combine fields from the “Actions” data source and the “Gates” data source in the same chart. If you want to create a chart that includes both actions and gates, use the fields from the “Gates/Actions” data source instead.

Examples for Different Field Types

The icon for each field indicates the data type: 🔗 text, 📊 number or 🕒 date. There are many possible ways to use these fields in your own customized dashboard layouts. The following simple examples demonstrate basic applications for each data type.

Example Using Counts

This pie chart uses the Count value for a text field to show the actions in the current project plan broken down by status. The argument determines the slices shown in the pie.

Tip: If you want to see both the quantity and the percentage, choose Design > Data Labels > Argument, Value And Percent.
Example Using Numbers
This bar chart uses the Sum values for two number fields to show the top 5 most costly actions in the current project plan, with comparison to the planned cost. The arguments determine how the bars are labeled, grouped and sorted.

Example Using Dates
This grid uses the Exact Date for two date fields to show a list of all actions in the current plan that are due in the current month. (To set the criteria that filters the records shown in the grid, right-click inside the chart and choose Edit Filter.)
Project Planner Ribbon

Project Planner Tab
The Project Planner tab in the Project Planner ribbon contains the following commands.

Project Planner

ıp Refresh updates the Project Planner hierarchy, if necessary. For example, if multiple users are accessing the same plan simultaneously, this will update the plan to reflect any changes made by other users.

Create Project Plan opens the Create Project Plan window so you can start again from a blank plan, or import an existing plan from another project.

Delete Entire Plan deletes every gate and removes every action from the plan.
**Item Properties** allows you to view or edit the **Identifiers** defined for the current plan. These identifiers can be used in the **Synthesis Explorer** to explore all of the different types of analyses (including project plans) in the current database.

**Clipboard**

- **Paste** pastes the contents of the Clipboard into the level below the selected gate (or on the same level of the selected action). If you want to paste gates only (without sub-gates and actions), use the **Paste Without Actions** command.
- **Cut** cuts the selected gate/action and any dependents to the Clipboard. You can paste this information into another Project Planner within the same database.
- **Copy** copies the selected gate/action and any dependents to the Clipboard. To copy everything, use the **Copy Entire Plan** command. You can paste this information into another Project Planner within the same database.
- **Delete** deletes the selected gate/action and any dependents.

**Gate**

- **Add Gate**
  - **Add Same Level Gate** adds a gate on the same level as the selected gate.
  - **Add Next Level Gate** adds a gate one level below the selected gate.
  - **Add Gate** adds a top-level gate to the end of the plan.
  - **Insert Gate** inserts a gate at the selected location.
- **Use Precedence**, when selected, automatically sets a new gate's precedent to the prior gate, which allows you to take advantage of expected timelines and ensure that there are no gaps between gates. If you clear this option, the default precedent will be "None."
- **Edit Gate** opens the **Gate Properties window**.
- **Promote** and **Demote** moves the selected gate to the next higher or lower level in the plan. An item can be demoted only if there is another item on the same level and above the selected item that it can be demoted under.
Chapter 19: Project Planner

**Action**

- **Add Action** creates a new action resource.

- **Reuse Action Resources** allows you to select existing action(s) from the project that a) are not already used in the current plan and b) have dates that fit within the current gate. Specifically, the action’s start date can’t be before or more than a year after the gate’s start date. (See Select Resource window.)

- **Reuse FMEA Actions** allows you to select one or more Xfmea/RCM++/RBI system hierarchy items from the current project that have FMEAs. You can then select to use existing action(s) from those particular FMEAs in the project plan.

- **Edit Action** opens action properties window. (See Actions in the Project Planner.)

**Tools**

- **Remove Gaps in Dates** automatically assigns precedents to every applicable gate. This ensures that there will be no gaps in the planned or expected timelines, and it allows the expected dates for an activity to automatically shift in response to delays in prior activities. (See Project Planner Timelines.) You can choose to remove gaps in the Entire Plan or just for the gates that fall under the selected Branch.

- **Check Utilization** opens the Check Utilization window so you can examine the utilizations for individual users and facilities across multiple actions (e.g., is a particular user assigned to too many actions at the same time, or is a particular test facility already booked for a particular timeframe).

- **Expand All** and **Collapse All** expands or collapses the gates in the project plan hierarchy.

- **Dashboard**

  - **Dashboard Viewer** opens the Dashboard Viewer so you can view dashboards based on predefined layouts.

  - **Dashboard Manager** opens the Dashboard Layout Manager so you can create, edit and delete the predefined layouts that will be available for any user to view for any project plan in the database.
Excel Import/Export

- **Export View to Excel** exports the entire hierarchy and all displayed columns to an Excel sheet in a format that's suitable for presentation.

- **Import Hierarchy** and **Export Hierarchy** use an Excel format that's suitable for recreating the plan hierarchy in another project plan using information about precedents, outline level, etc.

**Copy Current View** copies the currently visible contents of the plan hierarchy or Gantt chart to the Clipboard as a graphic that can be pasted to other applications.

### View Tab
The View tab in the Project Planner ribbon contains the following commands.

**View**

- **Color Code Deltas** applies highlight colors to any “Delta Values” columns for dates or durations that are displayed in the project plan hierarchy (e.g., the difference between the planned duration and the actual duration, or between the expected completion date and the actual completion date). Highlights are applied on a gradient from blue (ahead of schedule) to red (significant delay).

- **Fit All Columns** automatically resizes all columns to fit their own data.

**Settings**

- **Customize Columns** allows you to hide or display specific columns in the plan hierarchy.

- **Save View** and **Apply View** create or apply a view that stores your preferences for which columns to display in the plan hierarchy and which colors to use for gates, actions, timelines and utilizations. Each view is saved per computer/username.

- **Set Colors** allows you to select the colors to use for gates, actions, timelines and utilizations.

**Zoom**

- **Normal Zoom** sets the degree of magnification to 100%

- **Zoom In** and **Zoom Out** increase or decrease the font size by 25% increments.
Custom Zoom allows you to specify the zoom percentage.
Chapter 20: ReliaSoft Plot Utilities

ReliaSoft applications offer a variety of plotting utilities for visual presentation of your analysis results. The following topics provide general information about built-in utilities, where the types of plots/charts available are predefined based on the analysis method and type of data you are working with. For more information about specific plot types, please consult the documentation for the relevant analysis.

Tip: In addition to the built-in plotting utilities described here, you can also create your own custom plots/charts in the Synthesis Workbooks and Synthesis Dashboards.

Basic Plot Features

This topic describes some basic features and capabilities that are available in most built-in plot utilities in ReliaSoft desktop applications (i.e., utilities where the types of plots available are predefined based on the analysis method and type of data you are working with). For information about creating your own custom charts in Synthesis Workbooks or Synthesis Dashboards, see Custom Charts or Dashboard Layout Designer.

Redraw Plots

A plot needs to be refreshed whenever its data source has been recalculated or when its inputs or settings have been modified. This ensures that the plot reflects the most current results. In most plot sheets, the control panel displays a status light that indicates whether the plot needs to be refreshed. A green light indicates that the data and the plot are in sync, while a red light indicates that the plot is out of sync with the latest analysis.

You can manually update a plot to reflect any changes by clicking the Redraw Plot icon in the plot’s control panel.

Alternatively, a plot can be refreshed automatically whenever changes have been made by selecting the Auto Refresh check box on the plot’s control panel.
Identify a Plot’s Source Analysis
For most plots, the control panel displays a blue link that displays the plot’s source analysis, as shown in the following example for a Weibull++ plot. You can click the link to open the folio and view the data set.

In some specialty plots (side-by-side plot, life comparison tool, etc.), you can select the source analysis for the plot by clicking the icon on the plot’s control panel or ribbon.

If the plot contains results from more than one analysis (e.g., overlay plots), the control panel includes a button that allows you to add or remove analyses from the plot, as shown in the example below for Weibull++ data sheets. In addition, you can click and drag the data sheets to the desired order.

Show or Hide Plot Items
When applicable, a plot may provide options for showing or hiding certain plot items such as data points, lines, probability scales, etc. The available options depend on the plot type and analysis. To view the options for the plot you are working with, choose Plot > Actions > Show/Hide Plot Items or right-click the plot and choose Show/Hide Items on the shortcut menu.

Select the check box for each item you want to appear in the plot, or clear the item’s check box to hide the item from view.

Scaling
When applicable, the plot control panel may display X and Y scaling boxes that show the minimum and maximum values for the x- and y-axes. You can clear the check boxes and click inside the fields to manually edit the values, or select the check boxes to have the application choose the appropriate values for the range, based on the data.
Zoom

The zoom function is available for plots that allow both X and Y scales to be adjusted. To zoom in or out of a plot, click inside the plot, point the mouse pointer over the area of interest, and then rotate the mouse wheel. Press ESC to return to the original scale.

For non-3D plots, you can also select a specific area to zoom in by holding the CTRL + SHIFT keys while clicking and dragging the mouse over the desired area. You can customize the color and line style of the zoom rectangle via the Zoom page of the Plot Setup.

Aspect Ratio

Plots are automatically resized whenever you resize the plot sheets. To maintain the proportional relationship between the width and height of the plot image, select the Keep Aspect Ratio check box on the plot’s control panel (as shown in the first example below). Clear the check box if you wish to stretch the dimensions of the plot graphic to fill the plot sheet (as shown in the second example below).
Show Coordinates

To show the coordinates for a location on a plot, press **SHIFT** and click the plot (no need to hold down the mouse button). To stop showing the coordinates and return the pointer to its normal mode, click the plot again.

To track the coordinates on a plot line, click the line. A crosshair shows the current location on the line. The crosshair will stay on the line and track the coordinates as you move the pointer.

When applicable, you can add a label that displays the coordinates of a location by pressing **CTRL + ALT** and then clicking the location you want labeled.
**Add Custom Labels**

When applicable, you can add a custom label to a plot by pressing **CTRL** and then clicking the plot. A label named "Default" will appear in the plot. Select the label to edit the text directly in the plot or double-click it to open the Edit Label window, which gives you the option to select a font style or format.

You can then move the label by clicking it and dragging its yellow handle to the desired location on the plot. (For more extensive annotations, see ReliaSoft Draw.)

**Move Plot Items**

If your plot has lines or points that are obscuring one or the other, you can move an item by pressing **ALT** and clicking the item. The Move Plot Item window will appear, giving you the option to move the selected item either to the front or back of the obscuring graphic.

**Export or Copy Plot Graphics**

You can save a plot graphic as a *.wmf, *.png, *.gif, or *.jpg file for use in other applications by clicking the Export Plot Graphic icon on the plot's control panel, or by choosing [Plot/3D Plot] > Actions > Export Plot Graphic if applicable.
In addition, you can save a plot graphic to the Clipboard by clicking the Copy Plot Graphic icon on the plot's control panel or by choosing [Plot/3D Plot] > Actions > Copy Plot Graphic if applicable.

When saving a 3D plot graphic to the Clipboard, the image will be in *.bmp format. For all other types of plots there are three choices: If you will be pasting copied plots into any one of the spreadsheets built in to ReliaSoft desktop applications (e.g., Synthesis Workbooks or General Spreadsheets), choose Metafile Optimized for Synthesis Spreadsheet. If you will be pasting them into external applications, choose Bitmap or Metafile Optimized for External Use.

### Setting Confidence Bounds

If your analysis includes calculations for confidence bounds, you can display the bounds in the associated plot by clicking the Confidence Bounds link on the plot control panel or by choosing Plot > Confidence Bounds > Confidence Bounds.

Depending on the type of data you are working with, you may be presented with different options for setting up the confidence bounds on the plot. (The ReliaWiki resource portal provides information on the background theory of confidence bounds at: [http://www.reliawiki.org/index.php/Confidence Bounds](http://www.reliawiki.org/index.php/Confidence Bounds).)

In the Confidence Bounds Setup window, you will need to:

1. Select which lines to show on the plot (e.g., two-sided, bottom one-sided, etc.)
2. Select which type of bounds to show on the plot. This may be the bounds on the time estimate (Type I), bounds on the reliability/unreliability estimate (Type II: Reliability); or when applicable, bounds on functions such as number of failures, growth potential, etc. (Type II: Function).
3. Enter the percent confidence level.

To change the level of detail at which the bounds are plotted, adjust the Resolution slider. You can click and drag the slider or, for fine adjustments, click the slider and then use the arrow keys. The number of points plotted to create the lines is displayed next to the field name. Note that higher resolutions will take longer to plot.

To hide the confidence bounds, choose Plot > Confidence Bounds > Hide Confidence Bounds.
Setting Target Markers

When applicable, the plot control panel may display the Target Reliability link or the Target MTBF/FI link. Both give you the option to display markers for target values on the plot.

You can select to show a specified target value (displayed as a horizontal line), target time value (displayed as a vertical line), and/or insert a marker at the point where the two target values intersect. Below is an example for a plot that shows the target reliability.

Click the Add or Remove icon to manage the list of target values to be displayed. You can add up to 5 sets of target values/markers to a plot.
Chapter 20: ReliaSoft Plot Utilities

The Plot Setup utility provides advanced settings for customizing the look of a plot to meet your needs and preferences. It allows you to: a) make changes and apply them to the current plot; b) save the changes and use them as default settings for all new plots; c) restore previously saved default values; or c) reset all settings to the shipped defaults.

**Tip:** You can quickly set some basic default settings for all new plots created in the current ReliaSoft desktop application via the Plots page of the Application Setup (File > Application Setup). The Application Setup also allows you to set some default analysis settings that may affect the appearance of plots (varies depending on the ReliaSoft desktop application).

To open the Plot Setup, click the **Plot Setup** icon on the plot’s control panel.

http://predict.reliasoft.com
Alternatively, you can double-click the item on the plot you wish to edit (e.g., points, lines, etc.) and the Plot Setup will open and display automatically the options associated with that item.

To apply your changes to the current plot, click **OK**. To save your changes as the new defaults, or restore previously saved defaults, or reset to shipped defaults, click the **Defaults** button. (See **Plot Defaults Window** for more information.)

**Plot Elements**

The Plot Setup is divided into pages that contain related settings for particular plot elements. The available pages/elements will depend on the type of plot you are working with.

As an example, the following picture identifies some of the basic plot elements that can be configured via the Plot Setup.

![Plot Setup: Plot Titles Page](image)

**Plot Setup: Plot Titles Page**

The Plot Titles page allows you to define the main, header and footer titles used in the plot and to change the text font and color.

Select or clear the **Show** check box to determine whether the title will be shown on the plot. Click the **Set Font** button next to the corresponding input box to open the Font window, which allows you to set the font type, style, size, color and text orientation.
Each asterisk (*) represents the default title text. For the main title, this is defined on the Titles Text page of the Plot Defaults window. If you type new text in an input box, either alone or in addition to the asterisk, the text you type will be displayed on the plot. For example, if you add (Helicopter) to the Main Title field, the default main title will be displayed, followed by "(Helicopter)." The changes you make will be applied regardless of plot type, so the main title of a Failure Rate vs Time plot would then be "Failure Rate vs Time (Helicopter)" and the main title of a System Failures plot would be "System Failures (Helicopter)." (This assumes that you have not changed the default main titles from the ones shipped with the application.)

You can use the ENTER key to add additional lines to the header title and the footer title.

To add an image file to the header title or footer title, click Set Image then browse for the file you want to include. Click Open. (You can select an image that uses one of the following formats: *.bmp, *.gif, *.jpg, *.jpeg, or *.ico.) The selected image appears next to the Set Image button. The image will also appear at the left side of the header or footer text. To remove the image, click Clear Image.

**Plot Setup: Axis Titles/Labels Page**

The Axis Titles/Labels page allows you to define the information used with the x-axis and y-axis, including the titles, axis labels and the numbers displayed in the axis labels. This page is not available when you are working with a pie chart.

The options on this page will vary depending on the plot style you are working with.

- **Axis Titles**
  - Select or clear the Show check box to determine whether the title will be shown on the plot. Click the Set Font button next to the corresponding input box to open the Font window, which allows you to set the font type, style, size, color and orientation of the text.

Each asterisk (*) represents the default title text. If you type new text in an input box, either alone or in addition to the asterisk, the text you type will be displayed on the plot. For example, if you add (Hours) to the Y-Axis Title field, the default y-Axis title will be displayed, followed by "(Hours)." The changes you make will be applied regardless of plot type, so the y-axis title of a Static Reliability Importance plot would then be "Static Reliability Importance (Hours)" and the y-axis title of a Throughput vs. Time plot would be "Throughput(t) (Hours)." (This assumes that you have not changed the default axis titles from the ones shipped with the application.)
• **Axis Labels**

  • **Axis Labels** options, when selected, displays the numerical labels for the x-axis and/or the y-axis in the plot.

  • If available for the plot type, click the **Custom Labels** button next to the corresponding option to open the Custom Axis Labels window, which allows you to add user-defined numerical labels to the x-axis or y-axis of the plot. Note that values outside the plot's display range are accepted but will not be shown.

  Click the **Set Font** button next to the corresponding option to open the Font window, which allows you to set the font type, style, size, color and orientation of the text.

• **Numbers in Axis Labels**

Use the options in this area to configure the mathematical precision (number of decimal places) and scientific tolerance of the values shown on the axes.

The scientific tolerance sets the point at which the numbers will be converted to normalized scientific notation. For example, setting the scientific tolerance to 3 means that all numbers with a value of 1,000 or more will be converted to normalized scientific notation (e.g., 1.0E+3).

  **Note:** When you are working with a bar chart, the **Numbers in Axis Labels** area will contain settings for only the axis representing the dependent variable. This is affected by the orientation of your bar chart; if you are using vertical bars, this area will contain settings for the y-axis, and if you are using horizontal bars, it will contain settings for the x-axis. It is important to be aware that the settings for one axis will not transfer to the other axis when you change the bar orientation. You will need to return to this page and reenter the settings.

---

**Plot Setup: Plot Labels Page**

The Plot Labels page allows you to customize the labels for items (e.g., bars, slices, points) shown in the plot as well as for custom labels used in the plot.

The options on this page will vary depending on the plot style you are working with. All available options are presented below.

• **Bar Labels** (available only for bar charts)

  • To display the y-axis value of each bar with the bar, select the **Show Bar Labels** check box. (You can set the bar style using the **Bar Orientation** field on the **Bars page** of the Plot Setup.)
• **Show Bar Labels Even if Zero** if selected, bars with a y-axis value of 0 will be shown with a label of "0." The number of decimal places in the label will conform to the y-axis math precision value specified on the [Axis Titles/Labels page](http://predict.reliasoft.com).

• **Point Labels** (available only for line plots)
  - To display the coordinates for each point at the lower right of the point, select the **Show Point Coordinates** check box. If this option is not selected, you can still display the coordinates for each point in a pop-up box by pointing to the point.
  - To display the point label in the same color as the border of the point itself, select the **Use Point Border Color** check box.
  - If there are overlapping points, select the **Show Point Multiplier** check box to display the number of points to the right of the point.

• **Slice Labels** (available only for pie charts)
  - To label the slices of the pie chart according to the components they represent, select the **Show Slice Labels** check box.
  - To label the slices of the pie chart with the percentage of the whole that they represent, select the **Show Slice Size** check box.

• **Custom Plot Labels** allows you to control the appearance of custom plot labels. You can add custom labels to your plot by pressing **CTRL** and clicking the plot.
  - **Delete Labels** deletes all custom labels on the plot.
  - **Reset Labels** immediately resets all custom labels on the plot to use the settings specified via the **Set Font** button. This allows you to apply the settings to existing custom labels rather than just new labels created after changing the settings.

• **Bar Label Position** (available only for bar charts) allows you to specify whether you want the bar labels located within the bars or outside of the bars.

For all labels, you can click the **Set Font** button in the section to open the Font window, which allows you to set the font type, style, size and color for labels of that type.

**Plot Setup: Legend Page**
The Legend page allows you to customize the display of the legend on the current plot.
The options on this page will vary depending on the plot style you are working with. All available options are presented below.

- To display the legend on the plot, select the **Show Legend** check box.
  - To include on the legend a color definition for each point/line/bar/slice shown in the plot, select the **Show Plot Items** check box.
  - To include lines above and below the legend and the user information, select the **Show Legend Border** check box. Use the options to the right to modify the appearance of the border. To change the color of the border, click the **Color** box to the left of the **Thickness** box. Adjust the thickness of the border by entering a positive integer in the input box. Change the style of the line (e.g., solid, dashed, etc.) by clicking the **Line Style** box to the right of the **Color** box.
  - To display the text of the legend in the same color as the lines, points, bars and/or slices on the plot, select the **Use Item Color** check box. If not selected, the text will be red.
  - **Show Analysis Information** if selected, the legend will display information about the analysis shown on the plot, including the data source and/or the settings used in the calculation, if applicable.
  - To display the plot description (including the plot type) on the plot, select the **Show Plot Description** check box.
  - To show the user display name, company and the date and time the plot was generated on the plot, select the **Show User Information** check box. (You set the display name and company using the User Login and Contact Information Window.)

- The legend area allows you to specify the amount of space used for the legend.
  - **Fixed Legend Width** if selected, the legend will remain the same size regardless of the information it contains. You can set the percentage of the canvas width that the legend will occupy.
  - **Maximum Legend Width** if selected, the legend will automatically recalculate its width based on the information it contains. You can set the maximum percentage of the canvas area that the legend will occupy.
Click the **Set Font** button next to the corresponding option to open the Font window, which allows you to set the font type, style, size and color of the text.

- For bar and pie charts in BlockSim and RENO only, **Color Spectrum** allows you to set the color limits for the plot.
  - You can set both lower and upper color limits by dragging the markers on the scale between 0% and 100%.
  - **Show all values (0-100%) in legend** if selected, the legend will show the full range of values; if not selected, the legend will show only the values between the upper and lower limits that you have specified.
- The preview shows how the specified settings will appear in the legend.

**Plot Setup: Canvas Page**

The Canvas page allows you to customize the color, style and thickness of the plot borders and title lines, along with the appearance of the rest of the plot sheet.

- **Plot Canvas and Area**
  - **Canvas Back Color** allows you to choose the color for the area outside the plot (i.e., the area containing the titles, labels, legend, etc.).
  - **Canvas Border** allows you to determine if the border around the plot field will be displayed and, if so, to set the color.
  - **Plot Area Back Color** allows you to choose the color for the plot background.
- **Plot Area Border Lines** allows you to hide or show each of the specified lines, as well as to choose a color, a thickness and a style for each. The borders referred to in this area are the borders of the plot area itself (i.e., the bottom border is the x-axis, etc.).
  - To show or hide a line, select or clear the associated check box.
  - To change the color of any of the lines, click the **Color** field. The drop-down list that appears allows you to choose from custom colors, web-safe colors or the colors used in the current Windows system settings. You can add colors to the Custom page by right-clicking one of the color boxes in the bottom two rows.
  - You can adjust the thickness of a line by entering a positive integer in the input box. A value of 1 will draw the thinnest possible line and other values such as 2, 3, etc. will draw thicker lines. Note that the size of the thinnest possible line is dependent upon your screen resolution.
• In addition, you can change the style of each line by clicking the **Line Style** box to the right of the **Thickness** box. A list providing line style options (e.g., solid, dashed, etc.) will appear. Choose the line style you want and it will appear in the **Line Style** box.

• To highlight each object (i.e., point, line, bar or slice) on the plot as you point to it, select the **Highlight Selected Plot Item** check box. When an object is active, you can click it to open the Plot Setup window and edit the properties specific to that object. The remaining options in this area are available only if this option is selected.

  • **Fill Color** allows you to specify a foreground color to be used on the highlighted active object.

  • **Back Color** allows you to specify a background color to be used on the highlighted active object. This color is not used if the selected fill style does not use a background color (i.e., solid or transparent fill style).

  • **Fill Style** allows you to select a style of hatching to be used on the highlighted active object.

### Plot Setup: Grid Page

The Grid page allows you to customize the color, style and thickness of the grid lines and to set the number of axis divisions used. This page is not available when you are working with a pie chart.

The options on this page will vary depending on the plot style you are working with. All available options are presented below.

  • **Axis Division Lines** allows you to hide or show each of the axis division lines, as well as to choose a color, a thickness and a style for each.

    • To show or hide a line, select or clear the associated check box.

    • To change the color of any of the grid lines, click the **Color** box. The drop-down that appears allows you to choose from custom colors, web-safe colors or the colors used in the current Windows system settings. You can add colors to the Custom page by right-clicking one of the color boxes in the bottom two rows.

    • You can adjust the thickness of a grid line by entering a positive integer in the input box. A value of 1 will draw the thinnest possible line and other values such as 2, 3, etc. will draw thicker lines. Note that the size of the thinnest possible line is dependent upon your screen resolution.
• In addition, you can change the style of each line by clicking the Line Style box to the right of the thickness box. A list providing line style options (e.g., solid, dashed, etc.) will appear. Choose the line style you want and it will appear in the Line Style box.

• **Number of Axis Divisions** allows you to set the number of major and minor divisions for each axis.

**Note:** When you are working with a bar chart, the Grid page will contain settings for only the axis representing the dependent variable. This is affected by the orientation of your bar chart; if you are using vertical bars, this area will contain settings for the y-axis, and if you are using horizontal bars, it will contain settings for the x-axis. It is important to be aware that the settings for one axis will not transfer to the other axis when you change the bar orientation. You will need to return to this page and reenter the settings.

**Plot Setup: Bars Page**
The Bars page allows you to customize the appearance of the bars in the plot. This page is available only when you are working with a bar chart.

• **Bar Border Lines** allows you to hide or show the border line for the bars, as well as to select a color, a thickness and a style for the border.

• **Bar Orientation** allows you to select how you want the plot laid out. You can choose to use vertical bars or horizontal bars.

**Plot Setup: Slices Page**
The Slices page allows you to customize the appearance of the slices in the plot. This page is available only when you are working with a pie chart.

• **Pie Settings**
  
  • **Rank** if selected, you can specify the ranking of the slices that you want to view. For example, entering 5 will cause only the five largest slices to be shown in the plot.

  • **Threshold** if selected, you can specify a minimum size (in percentage of the whole) for the slices that you want to view. For example, entering 0.1 will cause only slices accounting for ten percent or more of the whole to be shown in the plot.
• **Show Remaining Slices as Other** if selected, all remaining slices that do not meet the rank or threshold criterion specified will be shown in the plot as "other." This option is available only if you have specified a rank, a threshold or both.

• **Other Slice Color** allows you to choose the color used to represent "other" slices. This option is available only if you have selected the **Show Remaining Slices as Other** option.

• **Slice Border Lines** allows you to hide or show the border line for the slices, as well as to select a color, a thickness and a style for the border.

• **Chart Type** allows you to select how you want the plot laid out. You can choose to use an area chart (blocks), cake chart (layers) or pie chart (wedges).

• **Numbers in Slice Labels** allows you to set the number of decimal places to be displayed in slice labels.

**Plot Setup: Plot Items Page**

The Plot Items page allows you to specify details of the appearance of the points, lines, bars and/or slices on the plot.

The options available on this page will vary depending on the plot style that you are currently working with.

The following options are available for all plot styles:

• **Choose an Item to Configure** allows you to choose which plot element the settings on this page apply to.

• **Show** allows you to select whether or not the plot element you currently chose to configure will be shown on the plot. Depending on the plot style that you are currently working with, you may select to show the bars, slice, line and/or points. This option is not available for all plots.

For bar charts and pie charts, the following option applies.

• **Area Fill Color and Style** allows you to specify the appearance of the bar or slice representing the selected item. To change the color of the bar or slice, click the **Color** box. You can select a fill style from the drop-down list.

For line plots, the following options apply:

• **Line Settings** allows you to specify the appearance of the line representing the selected item. To change the color of the line, click the **Color** box. You can adjust the thickness of a grid line by entering a positive integer in the input box. Adjust the thickness of the line
by entering a positive integer in the input box. Change the style of each line such as solid, dashed, etc., by clicking the Line Style box.

- **Point Settings**
  - **Color, Shape, Size and Fill** allows you to specify the appearance of the point body. To change the color of the point, click the Color box. You can select a point shape from the drop-down list, select the size of the point (with 1 being the smallest point) and select a fill style from the drop-down list.
  - **Border Color, Thickness and Style** allows you to modify the appearance of the border of the points. To change the color of the border, click the Color box. Adjust the thickness of the border by entering a positive integer in the input box. Change the style of each line such as solid, dashed, etc., by clicking the Line Style box.

Certain point shapes are drawn using only the border color. These include minus, pike, plus and x-cross.

### Plot Setup: Offsets Page
The Offsets page allows you to specify the distance of various components from the edge of the plot area.

**Automatically calculate positions from edges of plot sheet** if selected, automatically calculates the offsets for maximum plot display and readability. If not selected, you can manually specify the offsets of the plot's left, right, top and bottom edges; the offset of the legend from the right edge of the plot area; and the offset of the main, x-axis, y-axis, header and footer titles. The offset values are set as a percentage of the canvas area.

For your reference, the following picture shows which plot elements are affected by each of the offset settings. (Note that the plot is generated from BlockSim, but the settings are the same for all ReliaSoft desktop applications.)
Plot Setup: Zoom Page

The Zoom page allows you to customize the options used when zooming in on a plot by using the mouse wheel. Zooming works only for plots with scales. For more information, see Basic Plot Features.

Allow Zoom if selected, allows the plot zoom feature to be used.

- **Factor** use this option to set the amount of the magnification each time you use the mouse wheel on the plot. The lower the number, the greater the increase in the magnification.

- Use the **Border Color, Thickness and Style** option to set the appearance of the zoom box. To change the color of the border, click the **Color** box to the left of the **Thickness** box. Adjust the thickness of the border by entering a positive integer in the input box. Change the style of the line (e.g., solid, dashed, etc.) by clicking the **Line Style** box to the right of the **Color** box.

- **Fill Style** allows you to select a style of hatching to be used on the zoom box.
Chapter 20: ReliaSoft Plot Utilities

- **Fill Color** allows you to specify a foreground color to be used on the zoom box. This color is not used if the selected fill style does not use a background color (i.e., solid or transparent fill style).

- **Background color** allows you to specify a background color to be used on the zoom box. This color is not used if the selected fill style does not use a background color (i.e., solid or transparent fill style).

**Plot Defaults Window**

Each time you open the Plot Setup window, the changes that you make will apply only to the current plot unless you specify otherwise. To specify settings to be used as defaults for all subsequent plots or to re-apply default settings to the current plot, click the **Defaults** button to open the Plot Defaults window.

The Plot Defaults window gives you the flexibility to set the default settings for the three main areas of a plot: the plot titles, the plot item settings and the general display areas. You can choose to separately save, load or restore the default settings of each main area or you can set the default settings for all areas at once.

The Plot Defaults window consists of nine pages:

- **All Defaults page.** This page controls the settings for all the other plot setup pages. When you click a button on this page, the effects apply to all pages. This allows you to quickly make changes without having to individually change each of the other pages.

- **Titles Text page.** This page allows you to customize default plot titles for each plot type without having to view a plot of that type. For example, you can display a Failure Rate vs. Time plot while changing the titles for a System Failures plot.

- **Plot Items Display page.** This page allows you to customize the details of the default appearance of the lines, points, bars and/or slices of every plot type without having to individually change each plot.

- **General page.** This page controls the settings for the five section pages below it. When you click a button on this page, the effects apply to the Titles Display, Labels, Legend, Canvas and Grid and Offsets pages.

- The Titles Display, Labels, Legend, Canvas and Grid and Offsets pages control the settings of their individual sections. When you click a button on one of these pages, the effects apply only to that specific section.
Three Defaults buttons appear on every page of the Plot Defaults window. The scope of their effects differs slightly depending on the page you are working with.

- **Save Defaults** saves settings for use as the default settings for all subsequent plots. This will overwrite the previous default settings.

- **Load Defaults** enters the saved default values for the settings. You can then click **OK** in the Plot Setup window to apply the default settings to the current plot. This is an easy way to undo changes you have made in the Plot Setup window and re-apply default settings.

- **Restore Defaults** clears the saved default settings and restores the default values that are shipped with the application.

The scope of the Defaults buttons' effects changes as follows:

- For the Titles and Plot Item Display pages, these buttons save/load/restore the settings specified on the current page.

- For the Titles Display, Labels, Legend, Canvas and Grid and Offsets pages, these buttons save/load/restore all current settings on the corresponding page(s) of the Plot Setup window (e.g., clicking **Save Defaults** on the Canvas and grid page of the Plot Defaults window will save the settings from the Canvas, Grid, Bars and Slices pages).

**Note:** The settings affected by the Defaults buttons on the Titles Display, Labels, Legend, Canvas and Grid and Offsets pages include all settings relevant to the section, regardless of whether they are currently available or not. For example, if you have previously specified settings for a pie chart and are now specifying settings for a bar chart, the settings that you created for the pie chart will be saved as defaults when you click **Save Defaults** and will be applied to subsequent pie charts.

- For the All Defaults and General pages, clicking these buttons is equivalent to clicking them on all of the subordinate pages.

### Plot Defaults Window: Titles Text Page

The Titles Text page of the Plot Defaults window allows you to customize default plot titles for each plot type.

- **Titles** allows you to select the plot type that you are changing the default titles for.

- **Main** allows you to type the default main title for the plot.

- **X-Axis** allows you to type the default title for the x-axis for the plot.

- **Y-Axis** allows you to type the default title for the y-axis for the plot.
Chapter 20: ReliaSoft Plot Utilities

**Plot Defaults Window: Plot Items Display Page**

*Plot Item Type* allows you to select the style of plot that you want to specify default settings for. The settings you specify are retained in the background when you choose a new item in this list, so you can specify settings for each type and save all of them, if desired.

The options on this page are identical to those on the *Plot Items page* of the Plot Setup window for the corresponding plot style.

**ReliaSoft Draw**

ReliaSoft Draw (RS Draw) is a metafile graphics editor that allows you to annotate and customize your plots. With RS Draw, you can insert text, draw an object, mark the coordinates of a particular point or paste another picture into your plot. You can also re-arrange the objects in your plot by selecting and moving them to the positions you desire. In addition, you can save the annotated plot in one of the following formats: *.rdc, *.jpg, *.gif, *.png or *.wmf.

RS Draw is available by clicking the icon on the plot control panel.

See [ReliaSoft Draw Help](http://predict.reliasoft.com) for information on the features available in ReliaSoft Draw. If you do not currently have Internet access, this link will not work, but you can browse to the local copy of the help file by opening the Help\RSDraw\rsdraw.htm file in your ReliaSoft application directory.

**Overlay Plots**

Available in Weibull++, ALTA, BlockSim and RGA, overlay plots give you the ability to display results from multiple analyses in a single plot. This allows you to easily compare different data sets, analysis methods or distributions. For example, you may wish to show the reliability plots of two product designs in the same plot or compare a simulation-based data set with actual data obtained from fielded products.

**Creating an Overlay Plot**

Before using an overlay plot, you must first analyze the data sets (or simulate the diagrams) you wish to include in the plot. Then to add an overlay plot to the project, choose Home > Insert > Overlay Plot.
In the window that appears, select the data sheets/diagrams you want to include in the plot (up to a maximum of 20) and click OK to create the plot sheet. The plot sheet will be saved automatically under the Multiplots heading in the current project explorer.

**Tip:** In Weibull++, ALTA and RGA, you can add additional plot sheets to a folio by choosing [Life Data/Life-Stress Data/Growth Data] > Folio Sheets > Insert Additional Plot. The additional sheets can function as overlay plots to display results from multiple data sheets in the current folio on a single plot.

**Adding or Removing Analyses**

To add or remove analyses from an overlay plot, click the button on the control panel, as shown in the example below for data sheets.

If you later delete an analysis that is referenced by the plot, the plot will remain available and will continue to show the results of the analysis until you redraw the plot (by clicking the Redraw Plot icon on the control panel).

Note that importing or exporting an overlay plot will automatically import/export the associated source analyses. (See Importing/Exporting Project Items or Resources.)

**Available Plot Types for Overlay Plots**

The available plots depend on the analysis or type of data you are working with.

**For Weibull++/ALTA**

Probability plots, contour plots and ALTA stress plots are available only if the data sets have been calculated with the same distribution. This is because the scales or axes in those types of plots vary for different types of distributions.

In DOE design folios, plots that are intended to be viewed as singular plots will not be available for inclusion in overlay plots. These include the comparison chart, Pareto chart, interaction matrix, term effect plot, cube plot, residual histogram, residual autocorrelation plot, and Box-Cox transformation plot. In addition, only plots that are common to the type(s) of design you have selected will be available in the overlay plot. If a plot type is unavailable for any of the included design types, it will be unavailable in the overlay plot.
Chapter 20: ReliaSoft Plot Utilities

**For BlockSim**

You can compare data from analytical and simulation diagrams in the same plot, but keep in mind that analytical diagrams always show the reliability over time (does not account for repairs) while simulation diagrams always show the point reliability over time (may include repairs).

**For RGA**

Only plots that are common to the analyses you have selected will be available in the overlay plot. If a plot type is unavailable for any of the included analyses, it will be unavailable in the overlay plot. It is possible for the selected analyses to not have any common plot types.

**Side-By-Side Plots**

Available in Weibull++, ALTA and RGA, side-by-side plots give you the ability to display different plots for a single data set all in a single window for easy comparison.

To add a side-by-side plot to a project, choose **Home > Insert > Side-by-Side Plot**.

In the window that appears, select the analysis/data sheet you want to plot and click **OK** to create the plot sheet.

To view a single plot in greater detail, double-click the plot. You can double-click the plot again to return to the side-by-side view.

**Choosing Plots to Display**

The control panel provides options for selecting the type of plots to display. For most analyses, the **Vary** area will be available, which contains two options:

- The vary **Plot Types** option allows you to create different plots for the same data set. For example, you might wish to display both the Reliability vs. Time plot and the Failure Rate vs. Time plot of the data set.

- The vary **Distributions** or **Models** option allows you to compare how different distributions or models fit a particular data set. For example, you might wish to display a reliability plot for different life distributions, as shown next.
3D Plots

Available in Weibull++, ALTA and for two-way sensitivity analysis in RENO, 3D plots give you the ability to graph functions with three variables, such as the reliability at a given time and stress level. In addition, Weibull++ and ALTA offer the option to create 3D overlay plots, which are similar to regular overlay plots but displayed in 3D space.

Creating 3D Plots

Before creating a plot, you must first analyze the data sets (or in RENO, you must first run the simulation for the two-way sensitivity analysis).

To add 3D plots to a project, right-click the Multiplots folder in the current project explorer and choose the type of plot:

- 3D Plot
- 3D Overlay Plot (Weibull++ and ALTA only)

In both cases, the plots are automatically saved and stored in the Multiplots heading in the current project explorer.
Defining the X, Y and Z Axes
The control panel in the 3D plot folio contains basic settings for defining the X, Y and Z axes. (For advanced customization options, see 3D Plot Setup.)

The Begin and End fields, as shown next, display the minimum and maximum values for the axes. You can click inside these fields to manually edit the values, or select the Autoscale check box to have the application automatically choose the appropriate values for the range.

Whenever applicable, the Parameter fields will be displayed, as shown in the example above. Click these fields to change which parameter lies on which axis. The name of the parameter associated with the axis will be displayed next to that axis’s label.

Rotating 3D Plots
The XYZ indicator shown at the lower-left of a 3D plot represents the plot’s horizontal rotation (azimuth) and vertical rotation (elevation) in 3D space. Any changes to a plot’s rotation are reflected in the XYZ indicator, helping you to visualize the plot’s orientation on the screen.

There are several ways to rotate or manipulate a 3D plot, using the mouse, keyboard shortcuts or the view cube.
### Using a Mouse and Keyboard Shortcuts

<table>
<thead>
<tr>
<th>If you want to</th>
<th>Use a mouse</th>
<th>Use keyboard shortcuts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate the plot or change the viewing</td>
<td>Click anywhere in the plot area, and then press and hold the left mouse button while moving the pointer.</td>
<td>Press the Up, Down, Left or Right arrow keys.</td>
</tr>
<tr>
<td>angle</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Move the plot without changing its</td>
<td>Click anywhere in the plot area, and then press and hold the right mouse button while moving the pointer.</td>
<td>Hold the SHIFT key while pressing the Up, Down, Left, or Right arrow keys.</td>
</tr>
<tr>
<td>rotation</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Zoom in or out</td>
<td>Rotate the mouse wheel. Alternatively, you can choose 3D Plot &gt; Display &gt; Zoom In or Zoom out.</td>
<td>Press the W or S keys.</td>
</tr>
<tr>
<td></td>
<td>✈️ or ⬇️</td>
<td></td>
</tr>
<tr>
<td>Automatically center the plot on canvas</td>
<td>Choose 3D Plot &gt; Display &gt; Center on Canvas.</td>
<td>N/A</td>
</tr>
</tbody>
</table>

### Using the View Cube

The View Cube helps you to easily orient a 3D plot using predefined viewpoints. The cube is located at the lower-right of the 3D plot.

The letters on the cube represent a particular viewpoint. For instance, clicking the "F" side of the cube orients the plot such that you are looking directly at the plot’s front side (e.g., Y and Z plane).

- Front
You can rotate the cube in the same way you would rotate any 3D plot (i.e., press and hold the left mouse button while moving the pointer anywhere on the screen; or press the Up, Down, Left or Right arrow keys on your keyboard).

3D Plot Setup
The 3D Plot Setup allows you to customize the look of 3D plots to meet your needs. It gives you full control over the settings used for individual 3D plots and the default settings for all new 3D plots.

To access the 3D Plot Setup, choose 3D Plot > Actions > Plot Setup.

Alternatively, you can double-click the item on the plot you wish to edit. This will automatically open the 3D Plot Setup and display the options associated with that item. The available options in the 3D Plot Setup will vary, depending on the plot type. You can move the mouse pointer over an option to display its definition.
To apply your changes to the current plot only, click **OK**.

To save your changes and use them as the default setting for all new 3D plots, click the **Save as Default** button. This will overwrite the previous default settings.

To restore the previously saved defaults, click the **Load Defaults** button. This is an easy way to undo changes you have made in the 3D Plot Setup and re-apply default settings.

To reset all settings to the default values that were shipped with the application, click the **Reset** button.
Chapter 21: Synthesis Workbooks

The Synthesis Workbook is a custom reporting tool that is built directly in to many ReliaSoft applications, including Weibull++/ALTA, RGA and BlockSim. It combines two reporting modules – Spreadsheets and Word Processing – into the same flexible interface, thereby replacing the Analysis Workbook and Word Report Template functionality from prior versions.

Tip: If you convert a project from Version 10 or earlier, any Analysis Workbooks and Word Report Templates will be automatically converted to Synthesis Workbooks.

If your organization has implemented a Synthesis Enterprise Portal (SEP) website for an enterprise database, you can choose to publish selected Synthesis Workbook reports to be accessed from any web-enabled device. See Publishing to SEP.

Synthesis Workbook Wizard
To add a new Synthesis Workbook in an existing project, choose Home > Insert > Synthesis Workbook.

This launches the wizard, which gives you the opportunity to assign the first associated data source and/or select a saved template, if desired. (Note that the examples shown here are from Weibull++ but similar functionality is available in ALTA, RGA and BlockSim.)

If you prefer to start with a blank report:
Simply click OK and then click Yes when prompted to confirm that you want to create the report without associating a data source. (You will be able to associate data source(s) later if you wish.)

If you want to assign the first data source:
Click Select and choose one of the available analyses (i.e., a data sheet in Weibull++/ALTA and RGA, or a diagram in BlockSim). When you return to the wizard, click OK to create the report.

Note that you will be able to associate more data sources after the report is created, and change any of those assignments at any time. (See Associated Data Sources.)
If you want to use a saved template:
Click Spreadsheet or Word Processing. Select the Based on Existing Template check box and then choose a template from either the Standard tab (templates that are installed with the software) or the User tab (templates you have saved). Then click OK to create the report. (See Synthesis Workbook Templates.)

Associated Data Sources
In Synthesis Workbooks in Weibull++/ALTA, RGA and BlockSim, you have the option to associate multiple data sources that can be used for any function that obtains data or results from an existing analysis. (To obtain results from a DOE analysis in Weibull++/ALTA, see DOE Analysis Report.)

When you create this type of function, you will have the option to use an index to specify which of the currently assigned default data sources will be used. For example, if you want to compare the reliability values calculated from two different analyses, you can use

=RELIABILITY(Default1,1000) to get the result from the first default data source, and
=RELIABILITY(Default2,1000) to get the result from the second default data source.

Although you will be prompted to associate the first data source when you create the report, you can add or change associated data sources for an existing report at any time.

Associating Data Sources
For Synthesis Workbooks, the Information panel (located on the right side of the window) shows which analyses are currently assigned as default data sources. To have the panel always display, click the pushpin icon into the vertical position.
To add or remove analyses, choose **Home > Report > Associate Data Sources** or click the icon in the Information panel.

The following picture shows the windows for Weibull++. Similar functionality is available in ALTA, RGA and BlockSim.

Note that:

- In **Weibull++/ALTA**, you can select any data sheet from a folio that contains a life data analysis:
  - Life data folio
  - Life-stress data folio
Chapter 21: Synthesis Workbooks

- Non-parametric LDA folio
- Warranty analysis folio
- Degradation analysis folios (the results shown in the report will be based on the analysis of the extrapolated failure/suspension times)

- In **RGA**, you can select any data sheet in a growth data folio.
- In **BlockSim**, you can select any analytical diagram, simulation diagram or phase diagram. The function results can either be based directly on the analyzed/simulated diagram, or based on a model that has been fitted to the diagram. You specify this preference on the diagram’s control panel, using the **Report folio model** drop-down list on the Analysis Settings page.

### Linking Multiple Data Sources with Different Time Units

In BlockSim, function results that are time-based (e.g., downtime, time to event, etc.) will be returned in terms of the **System Base Unit (SBU)** for the repository. However, in Weibull++/ALTA or RGA, each function result is returned in the units used by its data source. If you wish to compare the results from multiple data sources that use different time units, there are two possible scenarios:

- **Convert the data in the original data source.** For example, if one data set is in "hours" and another is in "days," you could use the **Change Units** feature to automatically convert the data in the first analysis from "hours" to "days."

  **Tip:** If you want to keep the original analysis unchanged, you could create a copy of the data sheet, then convert the duplicate data sheet to use the new units.

- **Manually adjust the functions so they return results in the same units.** For example, if the data set is in "days" and you want the results to display the B10 life in "hours," you could adjust the function by adding a conversion ratio. For example, if 1 day is equivalent to 24 hours, you could edit the function as follows:
  
  \[ (\text{TIMEATPF("Weibull!Week!Data1", 0.1)}) \times (24). \]

### Synthesis Workbook Templates

In Synthesis Workbooks, saved templates make it easy to reuse the same report multiple times — in different analysis projects and with different data sets.
Note: For DOE analyses, instead of saved templates for the entire workbook, you can use saved profiles in the DOE Report Generator.

In addition to the Standard templates that are installed with the software, you can also create your own User templates that are saved from any existing report. Note that the templates are module-specific (i.e., compatible with either the spreadsheet module or the word processing module).

**Saving Your Own Templates**

It is easy to create a template from any Synthesis Workbook that is currently open.

Select either the spreadsheet or the word processing module, then choose Document > Save Template.

You can name and store the custom templates however you wish. To share a template with other users, you can simply send them a copy of the file, or you can save the file in a shared network location that multiple users can access.

**Using a Template**

You can select a template when you create a new Synthesis Workbook. (See Synthesis Workbook Wizard.)

Alternatively, you can use the steps below to apply or change the template for an existing workbook at any time.

*IMPORTANT:* This will replace any existing content in the current module, and the change can’t be undone.

1. Select either the spreadsheet or word processing module and then choose Document > Open Template.

2. Select a template from either tab then click OK to apply the template to the new or existing report.

   - The Standard tab displays the templates that are installed with the software and stored in the applicable sub-folder under C:\Users\Public\Documents\ReliaSoft\Templates.
Chapter 21: Synthesis Workbooks

- The User tab displays custom templates that were saved from an existing report. These can be stored in any location that is convenient for you. If the custom template you need is not displayed, click the Open icon to browse for the desired template and add it to the list.

Spreadsheet Module

The spreadsheet module in Synthesis Workbooks provides functionality similar to Microsoft Excel (with built-in functions and complete in-cell formula support), and it can be used to integrate data and/or results from multiple analyses at the same time.

Send to Excel

To export all sheets in the spreadsheet module to a Microsoft Excel file, choose Home > Report > Send to Excel.

Inserting Functions

- To build and insert functions that utilize a referenced analysis (data source), see Function Wizard - Data Sources.
- To add math, date, logic and other functions, see Function Wizard - Formulas.

Showing Formulas

To display the formulas instead of the calculated results in the worksheet cells, choose Formulas > Formula Auditing > Show Formulas.
You can toggle the formula display on and off.

![Image of spreadsheet cells with formulas]

**Recalculate Formulas**

By default, the spreadsheet automatically recalculates all formulas whenever you open the workbook or when the cells that a formula depends on have changed. However, if your spreadsheet contains a large number of formulas, the recalculation process may take more time and every change may require you to wait several seconds or minutes for the application to recalculate all values. In this case, you can control when calculation occurs by changing the setting to manual calculations.

To use manual calculations, choose **Formulas > Calculation > Calculation Options**, and then choose the **Manual** option. To change the settings back to automatic calculations, choose the **Automatic** option.

![Calculator icon]

To recalculate all formulas when in Manual mode, choose **Formulas > Calculate > Calculate Now**.

![Calculate Now icon]

The **Calculate Now** command can also be used to refresh the spreadsheet. A spreadsheet needs to be refreshed whenever its referenced data source(s) has been recalculated. This ensures that the spreadsheet reflects the most current results.

**Adding Custom Charts**

To create your own custom chart, first select the cells that contain the relevant data, then go to **Document > Charts** and choose a chart type and style. (See **Custom Charts in Synthesis Workbooks**.)

**Defining Names**

To create variable names that reference specific spreadsheet cells, see **Defined Names**.
Word Processing Module

The word processing module in Synthesis Workbooks offers custom reporting functionality that is similar to a Microsoft Word document. You may prefer to use this tool if you want to have a more polished, professional looking report.

This module has two tabs located at the bottom of the window: Design and Review. Use the Design tab to add text, functions and plot holders. Use the Review tab to see the results before you generate the final report.

To export the report to Microsoft Word, choose Send to Word.

Using the Function Wizard

To use the Function Wizard to build and insert functions that utilize a referenced analysis (data source), choose Home > Report > Function Wizard. (See Function Wizard - Data Sources.)

Using the Plot Wizard

To use the Plot Wizard to generate a variety of plots based on a referenced analysis, choose Home > Report > Plot Wizard. These are the same types of plots that are generated in an analysis folio or diagram plot sheets. (See Plot Wizard.)

Using Spreadsheet References

To reference cells from the spreadsheet module (within the same workbook), choose Home > Report > Spreadsheet Reference and select the desired cells. The link between the word processing and spreadsheet modules is dynamic; when data in the spreadsheet is changed, the word processing module is automatically updated. (See Spreadsheet References.)

Formulas and Functions

Function Wizard - Data Sources

In both the spreadsheet module and word processing module for Synthesis Workbooks in Weibull++/ALTA, RGA and BlockSim, you can build functions that return results based on an analyzed folio or diagram.

Note: To insert math, date, logic and other functions into the spreadsheet module of a Synthesis Workbook, see Function Wizard - Formulas.
Using the Function Wizard
To open the Function Wizard in Synthesis Workbooks, choose Home > Report > Function Wizard.

Select a function from the navigation panel and enter any required inputs. The following picture shows the most complex configuration as an example. After entering the inputs, click Insert to place the function into the report at the current cursor location. You can move and/or modify the function expression after it has been inserted.

For spreadsheet functions:

- The bracketed parameters indicate that the input is optional. In the example above, the Add Time and Confidence Level parameters are optional.

- You can use cell references as inputs. For example, instead of entering 1000 for a time input, you could specify to use whatever time is currently entered into cell A10, using either the relative reference (A10) or the absolute reference ($A$10). (See Cell References.)

- You can use variable names as inputs. (See Defined Names.)

- You can type the function expressions directly in the cell once you are familiar with the syntax. For more information, see Data Entry Tips for Functions.

For the word processing module:

- The brackets are part of the function field and are not optional.
The functions will not return any results until you either switch to the **Review** tab or generate the report in Microsoft Word.

**Selecting a Data Source (if Applicable)**

There are two ways to specify the data source:

- **Use the Data Source Name** (spreadsheets module only): This approach will return results based on a specific data sheet or diagram.

  In the Function Wizard, clear the **Use Default** check box and click the **Select** button to choose the data source, as shown next. In this example, the function will return results based on the data sheet called "Data1" in the Weibull++ life data folio called "Folio1."

- **Use a Data Source Index** (spreadsheet and word processing modules): This approach allows you to use the report as a template and return results based on a given data set.

  First, you must add data sources to the Synthesis Workbook (see **Associated Data Sources**). Then, in the Function Wizard, click the **Data Source Index** drop-down list and choose the index number of the desired data source. (In spreadsheets, select the **Use Default** check box to access the **Data Source Index** drop-down list.)
Function Wizard - Formulas

In the spreadsheet module for Synthesis Workbooks in Weibull++/ALTA, RGA and BlockSim, you can insert functions that perform math, date, logic and other operations.

Using the Function Library

The quickest way to add a function is to select it from the appropriate function category drop-down list, then select the cells of interest (hold down the CTRL key to select nonconsecutive cells) and press ENTER. You can move and/or modify the function expression after it has been inserted.

For example, to calculate the average reliability for the following units, you would choose Formulas > Function Library > AutoSum > Average. Select cells B3 through B9 and press ENTER. Note that the cell references can be relative (B3:B9) or absolute ($B$3:$B$9). (See Referencing a Cell.)

![Spreadsheet Table]

Using the Function Wizard

To use the Function Wizard, choose Formulas > Function Library > Insert Function.

Select a function from the drop-down list and click OK. Then in the Function Argument window, enter the input by either selecting the cells in the sheet or typing them directly into the appropriate field. For information relating to entering text as an input, cell references, and working with date and time functions, see Data Entry Tips for Functions.
For example, to exclude the value from unit 4 (failure due to operator error) from the average, you would select cells B3 through B5 for **Number 1**, and B7 through B9 for **Number 2**.

### Data Entry Tips for Functions

This topic provides some data entry tips for using spreadsheet functions in Synthesis Workbooks and general spreadsheets. If you create the function using the Function Wizard, most of the syntax and formatting issues will be handled automatically. However, you have the option to create or modify function expressions directly in spreadsheet cells.

*Note:* For DOE design folios, you can disregard any tips related to *data source functions* (i.e., functions that obtain data or results from a specific data sheet or diagram). For that type of analysis, you can use the **DOE Analysis Reports** feature to obtain results from a design, multiple linear regression or one-way ANOVA folio, or any of the measurement systems analysis folios.

### Case Sensitivity

The functions are not case sensitive.

### Entering Text as an Input

When entering text as an input to a function, you must enclose it in quotation marks. This includes situations where you need to specify the data source – DISTR("Weibull!Folio1!Data1") – and situations where you need enter a time or date value in one of the accepted text formats – DAY("22-Aug-2014").
Regional Settings
If your regional settings use a comma as the decimal separator, you must use a semicolon to separate function arguments (e.g., =RELIABILITY("Weibull!Folio1!Data1";A4)).

Referencing a Cell in the Same Sheet
If you want to use another cell in the same sheet, enter the cell reference with a letter to identify the column and a number to identify the row. The cell references can be relative (e.g., B2) or absolute (e.g. $B$2).

- A relative reference points to a cell based on its relative position to the current cell (e.g., B2). When the cell containing the reference is copied, the reference is adjusted to point to a new cell with the same relative offset as the original cell.

- An absolute reference points to a cell at an exact location. Absolute references are designated by placing a dollar sign ($) in front of the row and/or column that is to be absolute. For instance, $B$2 is an absolute reference that points to the cell located in Column B, Row 2 regardless of the position of the cell containing the reference.

For example, if you want to obtain the probability of failure for the time that has been entered in cell B2, the function could be either =PROBFAIL(B2) or =PROBFAIL($B$2). You can type the cell location directly into the field or click the Function Wizard’s Insert Workbook Reference icon to insert the reference to the cell currently selected in the sheet. If you want to insert an absolute reference, press CTRL while you click the icon.

Another option is to use the Defined Names tool to assign a name to the cell and use the name in all of the function expressions that require that input. (See Defined Names.)

Referencing a Cell in a Different Sheet
To reference a cell in a different sheet from the one in which the formula is entered, use an exclamation mark (!) after the sheet name. For instance, =Sheet1!$B$2 is a reference to the cell located in Column B, Row 2 in Sheet 1. When referencing a cell in a different sheet from the one in which the formula is entered, the reference must be absolute. If the reference is not absolute, the calculations will not be carried out properly.

You can only reference sheets in the same workbook.

Referencing a Cell in a Data Source
Some functions (e.g., DATAENTRY and FMATRIX) require you to reference a particular cell in a data source. This must be defined differently than references to a cell in a spreadsheet. For data source cell references, you must identify first the row and then the column, and use a
number rather than a letter to represent the column (e.g., A=1, B=2, C=3 and so on). For example:

- \text{=DATAENTRY(Default1,2,1)}\) returns the value that was entered into cell A2 in the Weibull++, ALTA or RGA folio that is the data source for this function.

- \text{=FMATRIX(Default1,2,1)}\) returns the value from the second row in the first column of the Fisher variance/covariance matrix that was calculated for that data source.

Creating Composite Functions

It is possible to combine different types of data sources and/or functions to create a composite function. For example, in the following formula, two different data sources are used to return the difference between the reliability at 100 hours calculated from the specific Weibull++ life data folio data sheet called "Weibull!Target!Data1" and the reliability at 100 hours calculated from any given Weibull++ data sheet that is currently first in the list of associated data sources for the workbook or General Spreadsheet.

\[=(\text{RELIABILITY}("\text{Weibull!Target!Data1"},100))-(\text{RELIABILITY}(\text{Default1},100))\]

In the next example, nested functions are used to round up the returned reliability result to the nearest two decimals.

\[=\text{ROUNDUP}(\text{RELIABILITY}(\text{Default1},100),2)\]

Omitting Optional Inputs in the Middle of a Function

If you do not use an optional input in the middle of the function, the function expression must specifically indicate that the input is being omitted. For example, when using the Weibull++ reliability function \text{RELIABILITY(Data\_Src,\text{Age},[Add\_Time],[Confidence\_Level])}, if you want to get the confidence bound on the reliability, you must use two commas (,,) to indicate that the [Add Time] input is intentionally blank, before entering the [Confidence Level] in its usual fourth position (e.g., \text{=RELIABILITY(\text{Default1},1000,,0.95})\). Note that this is handled automatically if you use the Function Wizard to build and insert the function expression.

Working with Date Functions

When using one of the spreadsheet date functions (\text{DAY}, \text{DAYS360}, \text{MONTH}, \text{WEEKDAY} and \text{YEAR}) to enter a date, you can use one of the following accepted text formats:

- Month/Day/Year ("8/22/2014"). For example, \text{=DAY("8/22/2014")} returns 22.

- Day-Month-Year ("22-Aug-2014"). For example, \text{=MONTH("22-Aug-2014")} returns 8 (because August is the 8th month).
If you do not include the year (e.g., “8/22” or “22-Aug”), the current year is assumed.

Alternatively, you can use the date’s serial number (which is the number of elapsed days since January 1, 1900). For example, \( \text{\texttt{YEAR(41873)}} \) returns 2014.

- You can obtain a date’s serial number using either of the following two functions. This may be helpful in cases where you want to filter, sort or use the date(s) in calculations.
  - The \texttt{DATE} function uses the inputs of other cells to obtain the serial number. For example, if you have dates specified in three cells where \( A2=\text{Year}, B2=\text{Month} \) and \( C2=\text{Day} \), \( \text{\texttt{DATE(A2, B2, C2)}} \) returns the serial number for that date.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>Year</td>
<td>Month</td>
<td>Day</td>
<td>Serial #</td>
<td></td>
</tr>
<tr>
<td>2014</td>
<td>8</td>
<td>22</td>
<td>41873</td>
<td></td>
</tr>
</tbody>
</table>

- The \texttt{DATEVALUE} function requires you to enter the date in an accepted text format. For example, \( \text{\texttt{DATEVALUE(“8/22/2014”)}} \) returns 41873.

Finally, you can also use the results of other functions within a date function. For example:

- To return the month from today’s current date, use: \( \text{\texttt{MONTH(TODAY())}} \)

- To return the day of the week for a date that is specified in three separate cells (\( A2=\text{Year}, B2=\text{Month} \) and \( C2=\text{Day} \)), use: \( \text{\texttt{WEEKDAY(DATE(A2, B2, C2))}} \)

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>Year</td>
<td>Month</td>
<td>Day</td>
<td>Weekday</td>
<td></td>
</tr>
<tr>
<td>2014</td>
<td>8</td>
<td>22</td>
<td>6</td>
<td></td>
</tr>
</tbody>
</table>

**Working with Time Functions**

When using one of the spreadsheet time functions (\texttt{HOUR}, \texttt{MINUTE} and \texttt{SECOND}) to enter a time, you can use one of the following valid text formats:

- Hour:Minute[:Second] [AM/PM]. For example, \( \text{\texttt{HOUR(“4:48:10 PM”)}} \) returns 16 (the hour using the 24 hour system).

- Month/Day/Year Hour:Minute[:Second] [AM/PM]. For example, \( \text{\texttt{MINUTE("8/22/2014 4:48:10 PM")}} \) returns 48.
Alternatively, you can use the hour, minute or second’s serial number (which is the fractional portion of a 24 hour day). For example, =MINUTE(0.70011574) returns 48 (as the specified serial number represents 4:48 PM).

- You can calculate a time’s serial number using either of the following two functions. This may be helpful in cases where you want to filter, sort or use the time(s) in calculations.
  - The TIME function uses the inputs of other cells to obtain the serial number. For example, if you have dates specified in three cells where A2=Hour, B2=Minute and C2=Second, =Time(A2, B2, C2) returns the serial number for that time.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>Hour</td>
<td>Minute</td>
<td>Second</td>
</tr>
<tr>
<td>2</td>
<td>16</td>
<td>48</td>
<td>10</td>
<td>0.70011574</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- The TIMEVALUE function requires you to enter the time as text in one of the accepted text formats. For example, =TIMEVALUE("4:48:10 PM") returns 0.70011574.

Finally, you can also use the results of other functions within a time function. For example:

- To generate current values, you can use the NOW function. If the current time is 4:48 PM, then =HOUR(NOW()) returns 16.

**Returning Confidence Bounds**

For functions that return confidence bounds, note that the **Function Wizard** for data sources only inserts one-sided bounds. If you want to show two-sided bounds, you can insert the same function twice — once at the lower confidence bound and once at the upper confidence bound. For example, for a 90% confidence level, you would set the lower confidence bound at 5% and the upper confidence bound at 95%.
• In a spreadsheet, you can use the same function (with different input parameters) to obtain any of the three values. For example, in Weibull++:

\[ \text{RELIABILITY}(\text{Default1}, 1000) \text{ returns the estimated value} \]
\[ \text{RELIABILITY}(\text{Default1}, 1000,, 0.05) \text{ returns the lower one-sided bound at 5\%} \]
\[ \text{RELIABILITY}(\text{Default1}, 1000,, 0.95) \text{ returns the upper one-sided bound at 95\%} \]

Note that the above function expressions for the confidence bounds uses two commas (,,) to indicate that another optional input ([Add Time]) was intentionally left blank. For more information about the syntax for functions containing multiple optional inputs, see Data Entry Tips for Functions.

• In a word processing module for Synthesis Workbooks, the wizard provides separate functions for confidence bounds. For example, use the Reliability function to get the estimated value and use the Bound on Reliability function to get each one-sided confidence bound.

**Plot Wizard**

In the word processing module for Synthesis Workbooks in Weibull++/ALTA, RGA and BlockSim, you can use the Plot Wizard to generate a variety of plots based on a referenced analysis. These are the same types of plots that are generated in folio or diagram plot sheets. Although you also have the option to copy/paste a static plot graphic from any folio or diagram plot sheet into the report, using the Plot Wizard makes it easy to change the associated data source when you reuse the template and ensures that the plot in the generated report will always show the latest analysis. (For DOE design folios, you can use the DOE Analysis Reports feature to insert plots from a design, multiple linear regression or one-way ANOVA folio, or any of the measurement systems analysis folios.)

To open the Plot Wizard, choose Home > Report > Plot Wizard.
Chapter 21: Synthesis Workbooks

The following picture shows the plot wizard in Weibull++. Similar functionality is available for RGA and BlockSim.

There are three steps to use this tool:

1. Select the plot type (and enter the inputs, if applicable)
2. Select the data source
3. Insert the plot holder

**Select the Plot Type**

First, select one of the available plot types from the panel on the left side. The right side of the wizard displays some information about the plot that is currently selected.

If applicable, this area also allows you to make relevant inputs (e.g., for ALTA plots that require you to select a specific stress column).

**Select the Data Source**

To specify the data source that the plot will be based on, choose a number from the Data Source Index drop-down list, as shown next. Using the index makes it easy to reuse the same template with a variety of different data sets.
Insert the Plot Holder

When the plot is fully defined, click Insert to place it at the current cursor location. You can move and/or resize the plot holder after it has been inserted. The plot holder shown next will return the reliability vs. time plot for whatever data source is currently second in the list of associated data sources.

Plot holders will not return any results until you view it in the Review tab or generate the report (Home > Report > Send to Word).
Custom Charts

In the spreadsheet module for Synthesis Workbooks, you can use the Document > Chart commands to insert your own custom charts. The charts can be placed anywhere in the spreadsheet, and are dynamic (automatically update when the data used to create the chart is changed).

Adding a Chart

1. Select the cells that contain the data of interest. In the example data below, the headings are included in the selection and will be used as the legend labels.

<table>
<thead>
<tr>
<th>Time</th>
<th>Product A</th>
<th>Product B</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>0.99996</td>
<td>0.99586</td>
</tr>
<tr>
<td>200</td>
<td>0.99920</td>
<td>0.96401</td>
</tr>
<tr>
<td>300</td>
<td>0.99506</td>
<td>0.87716</td>
</tr>
<tr>
<td>400</td>
<td>0.98217</td>
<td>0.72349</td>
</tr>
<tr>
<td>500</td>
<td>0.95220</td>
<td>0.52071</td>
</tr>
<tr>
<td>600</td>
<td>0.89495</td>
<td>0.31434</td>
</tr>
<tr>
<td>700</td>
<td>0.80119</td>
<td>0.15282</td>
</tr>
</tbody>
</table>

2. Choose Document > Charts. Choose the chart type, and then click a chart subtype that you want to use.
3. To move the chart, click and drag the chart to the desired location.

4. To resize the chart, click the chart and then drag the sizing handles to the desired size.

Changing the Data Displayed on an Axis
To change the way the data series is displayed on the axes, click the chart, then choose **Design > Data > Switch Row/Column.**

Changing the Chart Type and/or Data Set
You can change the type of chart and/or the data that is used in a chart at any time. To do this, click the chart and then:

- To change the chart type, choose **Design > Type > Change Chart Type.** Select the desired type.
To change the data set, choose **Design > Data > Select Data**. Select the cells that contain the data of interest.

**Applying a Chart Layout and/or Chart Style**

- To apply a predefined chart layout, choose **Design > Chart Layouts**. As an example, the following picture shows some of the options for 2-dimensional bar charts. To see the rest, click the arrow in the bottom-right corner.

If none of the predefined options are suitable for your chart, choose **Layout > Labels**, then select the option you want to customize. The following picture shows the options for the vertical axis.

- To apply a predefined chart style, choose **Design > Chart Styles**.

**Renaming Chart and Axes Titles**

When displaying chart and/or axes titles, you can rename the titles by right-clicking the chart and selecting the appropriate title option from the shortcut menu. For example, choosing **Change Chart Title** opens the following window:
Modifying the Axes and Gridlines
To hide or display axes and/or gridlines, choose Layout > Axes > Axes or Gridlines.

- When displaying axes, you can change direction of the x-axis and/or change the scale of the y-axis.
- When displaying gridlines, you can increase or decrease the number of gridlines for both the axes.

Defined Names
In the spreadsheet module for Synthesis Workbooks and general spreadsheets in Weibull++/ALTA and RGA folios, you can create variable names that reference specific spreadsheet cells. The names can then be used in any formula or function within the same workbook.

For example, say you want to obtain the reliability of a Weibull++ data set. The operating time is stored in cell B5 of the spreadsheet:

=RELIABILITY(“Weibull!Bulb!Data1!”$B$5))

You can create a defined name for the operating time to make the formula easier to understand and maintain. In this case, the formula might be rewritten as:

=RELIABILITY(“Weibull!Bulb!Data1!”OpTime)

You can then use the defined name OpTime in any other formula in the workbook that requires the operating time.

Syntax Rules for Names
- The first character of a name must be a letter or an underscore. The remaining characters can be letters, numbers, periods and underscores. Names are not case sensitive.
• Spaces are not allowed as part of a name. An underscore ( _ ) or period ( . ) can be used as a word separator.
• Symbols, except for underscores ( _ ), periods ( . ) and backslashes ( \ ), aren't allowed.

Managing Names
To view and manage defined names:

• In Synthesis Workbooks, choose Formula > Defined Names > Name Manager.
• In general spreadsheets, choose Sheet > Format and View > Defined Names.

You can then use the New, Edit, or Delete commands in the window to create or modify the names.

Defining Names
There are several ways to define a name.

Define a Name via the Name Manager
This method applies to both Synthesis Workbooks and general spreadsheets.

1. Select a cell or range of cells.
2. Create a new name:
   • In Synthesis Workbooks choose Formulas > Defined Names > Define Name (or choose Formulas > Defined Names > Name Manager, then click the New button in the window).
   • In general spreadsheets, choose Sheet > Format and View > Defined Names. Then in the window, click the New button.
3. Type a name into the Name field. In the Scope drop-down list, choose whether this name will be used for the entire workbook or a specific sheet. The Comment field is optional.

The selected cell/range will already be defined in the Refers to field, but you can click into the spreadsheet and select different cells, if desired.
Define a Name via the Name Box (Synthesis Workbook Only)
This method applies only to the spreadsheet module of Synthesis Workbooks. Select the cell or range of cells, click the Name box and type a name. Press Enter to create the name.

Define a Name via the Selection Command (Synthesis Workbook Only)
If the fields are already labeled in the spreadsheet, you can use them to create names.

1. Select the cells of interest (including the row or column labels), then choose Formulas > Defined Names > Create from Selection.

2. In the window, select the location of the labels. Click OK.
Spreadsheet References

In Synthesis Workbooks, the *spreadsheet reference* feature provides integration between the spreadsheet and word processing modules in the same workbook. You can insert a reference from any cell, or consecutive range of cells, from the spreadsheet into a desired location in the word processing document. If the referenced cells in the spreadsheet are changed, the word processing module is automatically updated. The changes are visible when you use the Review tab to see a preview or generate the Word report.

To insert a spreadsheet reference, place the cursor at the desired location in the word processing document and choose *Home > Report > Spreadsheet Reference.*

Note that you can also use the *Spreadsheet Reference* function in the word processing module’s *Function Wizard.*

The Select Cells window shows the contents of the spreadsheet module in the current workbook. Select a cell or range of consecutive cells and click *OK.*
DOE Analysis Reports

The DOE Analysis Reports feature allows you to insert selected analysis results and plots into a Synthesis Workbook.

This feature is available for any analyzed response in a design, multiple linear regression, one-way ANOVA or measurement systems analysis folio. The report can display any result that's available in the folio's Analysis Summary window for the selected response, as well as any applicable plot.

This topic describes how to build and insert a DOE analysis report, and how to use saved profiles for reports that you need to generate frequently. Note that you can insert multiple reports into the same spreadsheet or word processing document, if desired. Each additional report will be appended to the end.

For the example data shown above, the entry would look like this:

[TBLSSREF(Sheet1!B2:D10)]
Inserting a DOE Analysis Report

1. Select either the spreadsheet or word processing module in a Synthesis Workbook and choose Home > Report > DOE Analysis Report.

2. In the Select Response window, choose an analyzed response to copy the results from and click OK.

3. In the DOE Analysis Report window, the Available Report Items area (left) shows all of the available results and plots for the selected response. The Selected Report Items area (middle) shows the selected results/plots, in the order in which they will appear. You can:
   - Choose Profiles > Open Profile to apply all of the relevant selections from a saved report profile. (See Using DOE Report Profiles.)
   - Build/modify the list using double-click, drag and drop or the Add/Remove and Up/Down buttons.

   Note that you can include multiple instances of the same report item, if desired.

4. When you click each selected report item, the Item Properties area (right) allows you to view/change the name (heading) that will be used in the report, if desired.

   For plots, you can also click the Preview Plot button to see what the plot will look like in the report. Any plot settings you change in the plot preview will be used in the generated report but will not affect the folio the report is based on.


Using DOE Report Profiles

When the DOE Analysis Report window is open, you can save the current settings (i.e., report item selections), or load settings that were previously saved.

- To save all your current report settings for use in future reports, choose Profiles > Save Profile.

Then specify the name and location of the DOE report file (*.drt) that will store the settings.
To overwrite all the settings in the DOE Analysis Report window and use the settings from a DOE report file instead, choose Profiles > Open Profile.

Then select the *.drt file that has all the desired settings.

Note: When you load report items from a DOE report file, only the items that apply to the selected folio/response will be included in the report.
Chapter 22: Synthesis Dashboards

The dashboard is a flexible tool for graphical presentation of data. This can include bar and pie charts, gauges, maps, etc.

All users can view dashboards based on predefined layouts (see Dashboard Viewer). The viewer is available in the following locations in ReliaSoft desktop applications:

- **Project Planner**
- **Synthesis Explorer**
- Simulation diagram results in BlockSim (see FMEA in the BlockSim/RENO documentation)
- FMEA and FMRA data in Xfmea/RCM++ (see FMEA Dashboards in the Xfmea/RCM++/RBI documentation)
- **Synthesis Data Warehouse** (SDW) data in Weibull++ and RGA

In a secure database, only users with the "Manage dashboard layouts" permission can manage and create predefined layouts (see Dashboard Layout Manager and Dashboard Layout Designer).

If your organization chooses to implement a web-based Synthesis Enterprise Portal (SEP) for an enterprise database, you can also share selected dashboards to be accessed from any web-enabled device!
Dashboard Viewer

Any user can access the Dashboard Viewer in a variety of locations throughout ReliaSoft desktop applications for graphical presentation of the latest analysis data.

When dashboard functionality is available for the data you’re working with (e.g., Project Planner, Synthesis Explorer, simulation diagrams in BlockSim, etc.), choose Dashboard > Dashboard Viewer to open the viewer.

Select any of the predefined dashboard layouts from the drop-down list to see the latest charts for the current data set.

Resizing Panels

To resize the dashboard items vertically and/or horizontally, click between two items and drag the resize cursor (↔) to the height and/or width you want. This option is available when a dashboard contains multiple items.
Showing Details in Charts and Pies
To see more details about the underlying data, move the mouse pointer over a bar or slice. For example, when the pointer is over a bar in a chart, the values for the x and y axes will be displayed in the tooltip.

Drill Downs and Master Filters
For information about how to use charts that have been configured for a drill down, see Viewing Drill Downs. For information about how to use charts that have been configured with master filters, see Using Master Filters.

Sorting and Filtering Data in a Grid
- To sort the data in ascending or descending order, click the column heading.
- To filter the data, click the Advanced Filter icon to see a drop-down list of filters that you can apply. The dashboard uses the same advanced filters functionality that is built in to other utilities (e.g., Resource Manager, Synthesis Explorer, etc.). (See Finding and Filtering Records.)

Printing or Exporting the Dashboard
To print the entire dashboard, or export it as a *.pdf file or as an image, click the Export To icon.
Viewing Drill Downs

An easy way to determine if the dashboard was configured for drill down is to look for the arrow in the caption bar, if the bar is visible.

To drill down, double-click an area of interest.

To drill up, click the arrow (↑) until you have reached the desired level or right-click the chart, then choose Drill Up.
Using Master Filters

When a dashboard with master filters is created, it can be configured for single or multiple filtering. If you see either of the following, then filtering is enabled:

- For **single** filtering, the dashboard title is followed by light gray text.

  ![Dashboard Server 1](image)

- For **multiple** filtering, the **Clear Master Filter** icon displays in the caption bar, if the bar is visible.

  ![Component](image)
Note that if you see both the icon and light gray text, this means that multiple filtering is enabled, but only one item in the filter is selected.

**Single Filtering**
For single filtering, you can only select one item at a time. You will not be able to clear the view, only select a different item.

**Multiple Filtering**
For multiple filtering, you can select as many filter items as you want to view. Hold down **SHIFT** while clicking to select consecutive elements or hold down **CTRL** while clicking for nonconsecutive items.

In the example shown next, the grid was set up as the master multiple filter. The chart and pie charts display the data for the four parts selected in the grid.

To reset the view, click the **Clear Master Filter** icon or right-click, then choose **Clear Master Filter**.

**Dashboard Layout Manager**
You can use the Dashboard Layout Manager to create, edit and delete the predefined dashboard layouts that will be available for any user to view for a particular data set. (In a
secure database, this is available only for users with the “Manage dashboard layouts” permission.

To open the Dashboard Layout Manager, choose the command from any interface that supports dashboard functionality (e.g., Project Planner, Synthesis Explorer, simulation diagrams in BlockSim, etc.). It will display only the layouts for that particular data type.

You can also open the Dashboard Layout Manager from the Backstage view (File > Manage Repository > Dashboard Layout Manager). It will display all of the layouts for any data type. If you want to see only the layouts specific to the application you are using, select the check box.

Show in Viewer
Use the check boxes in the Show in Viewer column to select which of the predefined layouts will be available to all database users via the Dashboard Viewer. If you clear a check box, the layout will not show in the viewer’s drop-down list but will remain in the manager’s list.

Use the up/down arrows to change the order of the layouts that are shown in the viewer’s drop-down list.

Layout Properties
For all dashboard layouts that are selected to show in the Dashboard Viewer, the name that will be visible in the list is set from the Layout Properties window. To view or change these properties, select a row in the table and click the Properties button (or right-click and choose Properties).

The description and update history are available to help you manage the layouts; that information is not visible to all database users.
Chapter 22: Synthesis Dashboards

Importing Layouts

It is easy to reuse dashboard layouts that were created in other databases. Click the Import button and then select the database you want to import from. If you are using the Dashboard Layout Manager in the Backstage view, you can import layouts of any type. If you’re using a manager from one of the locations where dashboards are used, you can only import layouts of the current type.

Dashboard Layout Designer

You can use the Dashboard Layout Designer to create or edit each predefined dashboard layout. (In a secure database, this is available only for users with the "Manage dashboard layouts" permissions.)

To access this window, first open the Dashboard Layout Manager and then choose to either create a new layout or edit an existing one.

Separate Layouts for Each Data Type

Each dashboard layout is designed to be used with a specific data type, which determines which fields are available and where the dashboard can be viewed. For information about creating dashboards for each particular type of data, see:

- **Project Planner Dashboards**
- **Synthesis Explorer Dashboards**
- **Simulation Diagram Dashboards** (in the BlockSim/RENO documentation)
- **FMEA Dashboards** (in the Xfmea/RCM++/RBI documentation)
- **Synthesis Data Warehouse (SDW) Dashboards** (available in Weibull++/ALTA and RGA)

**Tip:** For dashboards that are intended to be viewed in both desktop applications and the Synthesis Enterprise Portal (SEP), it is recommended to use the Local Colors option on the Design tab of the Dashboard Layout Designer to save your preferred colors with the layout. The global colors definition may not be the same in both web and desktop.
Configuring a Dashboard Item

This topic demonstrates some of the basic steps for configuring a dashboard item (bar chart, pie chart, gauges, etc.) in the Dashboard Layout Designer. The simple bar chart in this example is based on block-level simulation results from a reliability block diagram in BlockSim. The data source options will be different for other locations where dashboards are available, see Project Planner, Synthesis Explorer, Simulation Diagram Dashboards (BlockSim/RENO), FMEA Dashboards (Xfmea/RCM++/RBI) or SDW Dashboards (Weibull++/ALTA and RGA).

In a secure database, only users with the "Manage dashboard layouts" permissions can create layouts.

Add the Chart

Add a chart to the Layout panel by choosing Home > Insert > Chart.

Define the Chart Data

1. Select a data source from the drop-down list in the Data Source panel, if applicable.

2. Choose the data field (or fields) that will be displayed in the y-axis of the bar chart, then drag each field into the Values area in the DATA ITEMS panel. For this example, the chart will display total operating cost, cost from preventive maintenance and cost from corrective maintenance.

Note that when different data sources are available, all of the data fields used within a chart must come from the same source.
Chapter 22: Synthesis Dashboards

Tip: To replace a data item, drag a new field on top of the current one. To remove a field, drag it anywhere outside of the data item; and to completely clear the DATA ITEMS panel, right-click the chart and select Remove Data Items.

3. Use the drop-down list to see which values are available for this data field (e.g., count, sum, average, etc.) and choose one to display in the chart. Note that the same option must be selected for all values in the same chart.

Because we want the total cost from all blocks that meet the given criteria, we use the default Sum for this example.
4. If appropriate, use the **Rename** command to change the name that will be displayed in the chart legend, tooltip, etc.

5. Choose the data field that will be displayed in the x-axis, then drag it to the **Argument** bar.
Filter the Data
To filter the data displayed in the chart, choose Data > Filtering > Edit Filter.

Use the Filter Editor to define the criteria. For this example, we’re using the “Not And” operator to exclude any blocks with a name that contains “Hub.”

Tip: You can use hidden data items to filter based on fields that are not displayed in the chart.

Sort by “Top N”
To configure the chart to show only the top 5, bottom 10, etc., use the Top N command in the Argument data item’s drop-down list.

For this example, we’re showing only the Top 5 blocks, based on total operating cost. The results are displayed from highest to lowest and the order cannot be changed.
Tip: Alternatively, you could use the Sort by command to sort by the argument data item — which is labeled (Value) in this menu — or by any of the value data items. Click the Argument bar to toggle the sort between ascending and descending order.

Other Design Options
Click the Design tab on the ribbon to access other configurable options for this type of chart. For example:

1. To hide or display the caption bar above the chart, choose Show Caption.

We will keep it displayed for this example.

2. To change the title in the caption bar to something more meaningful, choose Edit Names.

For this example, we will set the Dashboard item name to “Top 5 Blocks by Total Operating Cost” and clear all of the Series fields to make sure the latest data item name (set via the Rename command in the data item’s drop-down list) will always be used in the chart legend and tooltip.
3. To change the y-axis title to a more meaningful name, choose **Y-Axis Settings**.
Available Dashboard Items
The following dashboard items can be added to any layout. You can add the same type of item more than once, if desired. To insert an item, choose Home > Insert, then click one of the following options.

- Pivot
- Chart
- Gauges
- Choropleth Map
- Range Filter
- Scatter Chart
- Grid
- Pies
- Cards
- Geo Point Map
- Text Box
- Image

Data Types
There are two types of data that can be used in a dashboard item: measure or dimension.

- **Measure** data is calculated (sum, count, average, etc.). For example, the values on the y-axis of a chart, the size of a slice in a pie or a target value in a card or gauge. Values and targets are forms of measure data.

- **Dimension** data can be sorted but is not calculated. For example, the bars in chart, slices in a pie or text in a grid column. Arguments and series are forms of dimension data.

Data Shaping
You can use the Dimensions and/or Measures bars in the HIDDEN DATA ITEMS panel when you want to perform data shaping (filtering, sorting or Top N) but do not want the data to be displayed in the dashboard item. Data shaping is available for any dashboard item, except text boxes and images.

- The data fields contained in the **Dimensions** bar can be used in Filter Editor window to create filter conditions based on their values. Dimensions in this area have the same sorting functionality that is available in the argument, attribute or series DATA ITEMS area.

- The data fields contained in the **Measures** bar can be used in the Sort by submenu and in the Top N Values window for data sorting. Measures in this area have the same calculation functionality that is available in the values and target DATA ITEMS area.
Chapter 22: Synthesis Dashboards

Configuring a Drill Down
Drill down can be enabled for the following dashboard items:

- Grids: Specify two or more columns
- Charts and pies: Specify two or more arguments and/or series
- Gauges: Specify two or more series
- Cards: Specify two or more series

Configuring a Drill Down Sequence
1. In the Dashboard Layout Designer window, select the chart or grid you want to drill down.
2. Drag the additional data fields into the Arguments area in the appropriate order for the desired drill down sequence.

For example, you can use the following sequence to configure a pie chart in a Synthesis Explorer dashboard to first show analyses by application source, then drill down to analysis type.

3. Choose Data > Filtering > Drill Down. This command is a toggle; choose the command again to disable the drill down.

When any user views this layout in the Dashboard Viewer, he/she will be able to double-click inside the chart to drill down, and use the arrow (↑) to drill back up. (See Viewing Drill Downs.)

Tip: To make it easy to identify a drill down in the Dashboard Viewer, display the dashboard item's caption bar (Design > Common > Show Caption).
Filtering

Using the Filter Editor
You can use the Filter Editor to incorporate filters into dashboard items that contain dimension data. Arguments and series are forms of dimension data.

This type of filtering only applies to the dashboard item you have selected. To filter the data across the entire dashboard, see Configuring a Master Filter.

Dimension Data Locations
Dimension data can be used in any or all of the following areas:

- Dimension bar in the HIDDEN DATA ITEMS panel.
- Dimension, argument and/or series bars in the DATA ITEMS panel.

An easy way to determine if a data field is a dimension, argument or series, is to look for the sort arrow to the left of the data field name.

Configuring a Filter
1. In the Dashboard Layout Designer widow, select a dashboard item, then choose Data > Filtering > Edit Filter. This command is also available in the shortcut menu when you right-click the dashboard item.

2. In the Filter Editor window, define the criteria. The dashboard uses the same Edit Filter functionality that is built in to other utilities (e.g., Resource Manager, Synthesis Explorer, etc.). (See Finding and Filtering Records.)
In the following example, a chart was created for data that was extracted from XFRACAS into the Synthesis Data Warehouse (SDW) in Weibull++.

Because we are interested in only the chandelier parts (not the whole unit) and data from 2010 and later, we can apply the following filter to remove the unwanted data:

**Configuring a Master Filter**

A master filter can be used to filter data across the entire dashboard. Grids, pies, charts, gauges, cards and maps dashboard items can be used as master filters.
There are two types of master filters that can be configured:

- **A Single** filter allows you to select one item at a time. You will not be able to clear the filter, only select a different item.

- **A Multiple** filter allows you to select one or more items at a time. You can also clear the filter to view all items at any time. This is the most flexible option.

For example, suppose your layout contains a grid, a chart and a pie, and the grid is configured as the multiple master filter. When you select items in the grid, only the data for those items will display in the chart and pie.

**Configuring a Master Filter**

In the Dashboard Layout Designer window, select the dashboard item, then enable the master filtering by choosing **Data > Interactivity > [Single Master Filter/Multiple Master Filter]**. This command is a toggle; choose the command again to disable it.

When any user views this layout in the Dashboard Viewer, he/she can use the filter to view only the data of interest. (See **Using Master Filters**.)

Note that you can prevent a specific dashboard item from being affected by master filters, by selecting it in the Layout panel and then choosing **Data > Interactivity settings > Ignore Master Filters**. This command is a toggle; choose the command again to disable it.

**Tip**: To make it easy to identify that a dashboard item is configured for filtering in the Dashboard Viewer, display the item's caption bar (**Design > Common > Show Caption**).
Chapter 23: Synthesis Data Warehouse

Available in Weibull++, ALTA and RGA, the Synthesis Data Warehouse (formerly called “Reliability Data Warehouse”) enables you to access data from an XFRACAS failure reporting system for the purpose of life data analysis (in Weibull++/ALTA) or repairable system/reliability growth analysis (in RGA). You can also set up custom connections to obtain reliability-related data from external data sources (including Access, Oracle and SQL Server). You can also get data directly from custom reports created in XFRACAS.

You can then transfer the data to an analysis folio in Weibull++, ALTA or RGA, or use the flexible Synthesis Dashboard utility to explore and present the data in a variety of graphical charts and grids. (See Transferring from the SDW to an Analysis Folio or SDW Dashboards.) In addition, if a Synthesis Enterprise Portal website has been implemented for an enterprise database, users can also access SDW dashboards from any web-enabled device.

To open the SDW in Weibull++, ALTA or RGA, choose Home > Synthesis > Synthesis Data Warehouse.

Managing Data Sources

The available data sources are listed in the data source manager on the left side of the window. They may include:

- Static data collections that were extracted from XFRACAS at a particular point in time (and will not change if incidents are later added or updated). These can be either Weibull++/ALTA data or RGA data. (See Extracting Data from XFRACAS.)

- Custom connections that have a live link to a specified external database or to a predefined report created in XFRACAS. (See Custom Connections in the SDW.)

- Static data collections that were extracted from a custom connection at a particular point in time (and will not change if the original data source changes). (See Import to a Static Data Collection.)

If you are working with a long list of available data sources, this panel can utilize the same categories, identifiers and item filters that are available in many other locations throughout ReliaSoft desktop applications.

To create, delete, rename or edit the properties for these data sources, use the Manage Data Sources commands, or right-click inside the panel.
The Properties window allows you to enter identifiers for each data source, and to view its history.

**Built-in Find/Filter, Configuration and Grouping Tools**

Double-click any data source to display the data in a grid on the right side of the window. The SDW offers the same filter, column configuration and grouping tools that are built in to other utilities that use a similar grid (e.g., the Synthesis Explorer, Actions Explorer, etc.). For details about how to use each feature, see:

- Finding and Filtering Records
- Configuring Columns
- Grouping Panel

**Building the Data Set**

The "Include in Analysis?" column shows whether each row will be included in the data set when it is transferred to Weibull++, ALTA or RGA.

- **Include**: Data points that will be included in the analysis are shown in green.
- **Invalid**: In XFRACAS data collections, incidents with a State Time of less than 0 are automatically set to invalid and will not be included in the analysis. These rows are shown in red.
- **Ignore**: In XFRACAS data collections, incidents with a State Time of 0 that are marked as suspensions in the State FS column are automatically set to ignore and will not be included in the analysis. These rows are shown in gray.
- **Exclude**: Data points that have been manually set to exclude from the analysis are shown in blue.

To view only those rows that will be transferred to a folio, choose **View > Show Only Included**. You can toggle this command off to show all records.
To change the status for a specific data point before transferring data to a folio, select the row and choose **Build Data Set > Include** or **Build Data Set > Exclude**.

![Include]

![Exclude]

**Note:** Changes to the "Include in Analysis?" indicator will not be saved with the data source. If you close the data source and open it again later, and if you view a dashboard in the **Synthesis Enterprise Portal**, the data will not reflect changes that were applied manually.

In XFRACAS data collections, and only if you have permission to view incidents in the XFRACAS entity that the data were extracted from, you can select a row and choose **Build Data Set > View XFRACAS Incident** to open the incident in your web browser.

### Extracting Data from XFRACAS

When you are working with an enterprise database that contains XFRACAS data, or a standard database that has a connection to external XFRACAS tables, you can use the **Synthesis Data Warehouse** to extract static data collections. These can be either Weibull++/ALTA data or RGA data, and the collections will not change if incidents are later added or updated in XFRACAS. (Alternatively, if you need a live link to a predefined report that has already been created in XFRACAS, see **Connect to XFRACAS Report**.)

To extract a static data collection from XFRACAS, first open the SDW in Weibull++, ALTA or RGA and then choose **Manage Data Sources > Get XFRACAS Data**.

![Folder]

(In a secure database, this is available only to users with the "Create/edit/delete SDW data collections" permission. Additionally, users must have the "Synthesis - Read Data" permissions for the associated XFRACAS tables.)

In the XFRACAS to SDW window, choose an **Entity** to import from, then select the check box for each part that you want to extract the incident (i.e., failure) data. If needed, you can use the Auto Filter Row to filter the grid by matching text in one or more columns. (For extremely large data sets, this row will be hidden and a Filter window will be available instead.)
Click **Next**, then specify other settings or fields to import:

- **Time Metric** allows you to choose which metric to use with the data. The options are based on the metrics that your system administrator has enabled for the XFRACAS entity.

- **Incident Detail Fields** allow you to map customized detail fields from the XFRACAS incident to one of the user-defined field columns in the SDW collection. The following field types can be mapped:
  
  - **StringUDF1-3**: Alphanumeric Input Box, Check Box, Company, Contacts, Currency, Date, Numeric Input Box, Users, Yes/No Button, or the Select List, Administrative Controlled field type
  
  - **NumberUDF1-3**: Currency or Numeric Input Box
  
  - **DateUDF1-3**: Date

- In RGA, additional options are available:
  
  - **Include non-chargeable** extracts incidents that are marked as either chargeable or non-chargeable in XFRACAS. If you clear the check box, it will extract only chargeable incidents.
  
  - **Only system down events** extracts only those incidents that brought the system down.
  
  - **Filter by date commissioned** extracts only incidents for systems that were commissioned between the specified dates.

Click **Next**, then enter a name for the data collection and any **Identifiers** that you want to use.

When you click **OK**, the extraction process will begin. Depending on the amount of data that you are extracting, this may take some time.
You can then use the data collection to transfer data to an analysis folio or explore/present in the dashboard utility. For information about the fields that will be available either in the Build Data Set tab or in the Dashboard Designer, see Data Fields for XFRACAS Data Collections.

Data Fields for XFRACAS Data Collections

The following fields are available for use in dashboard layouts for XFRACAS data collections and for data sets created via the Synthesis API. These are the same columns available in the Build Data Set tab. The fields in custom connections will depend on the data source itself.

- **Address Location**: the location of the owner of the system. This corresponds to the Location field in the XFRACAS contact.

- **Category**: the incident category. This corresponds to the Category field in the XFRACAS incident and, in conjunction with the failure type assigned during part repair/replacement, determines whether the data row is chargeable (i.e., is considered a failure for reliability calculations) or non-chargeable (i.e., is considered a suspension). For more information, see the “Incident Disposition Area” topic in the XFRACAS documentation.

- **Chargeable**: the chargeable code value (where 0 = non-chargeable, 1 = chargeable): equivalent to the Category Chargeable and Category Non-Chargeable lists in the XFRACAS Admin List page. This is to be used to calculate the failure state (StateFS). XFRACAS categories can also be viewed within an XFRACAS incident.

- **CompanyOwner**: the owner of the system. This corresponds to the Company field in the XFRACAS contact.

- **DataID**: the database ID of the row.

- **DataSetID**: the ID of the data set that the row belongs to. This is useful if you are viewing multiple data sets at the same time.

- **DateUDF1-3**: user-defined fields for dates. You can choose up to 3 detail fields in XFRACAS incidents to import to these columns.

- **ExtractedBy, ExtractedDate and ExtractedName**: identify the user who extracted the data from XFRACAS, the date of extraction and the name of the SDW data collection.

- **FailureMode**: the failure mode associated with the incident. This is chosen or created in the Failure Mode field in the XFRACAS incident.

- **IncidentAction**: the action taken to address the incident (whether a part was removed or installed). This is not related to XFRACAS actions. In XFRACAS data sets, repaired and
replaced parts will be represented using two rows of data—one will be for removing the part, and one for installing it.

- **IncidentEntityDisplayID**: the incident number assigned by XFRACAS, which includes the prefix for the entity that it is associated with (e.g., E1-201).
- **IncidentID**: the database ID of the incident.
- **IncidentOccurrenceDate**: the date when the incident happened. This corresponds to the Occurrence Date field in the XFRACAS incident.
- **IncidentRepairDate**: the date that part repair or replacement was completed. This corresponds to the Completed Date field that applies to the XFRACAS incident resolution.
- **IncidentResolution**: notes regarding the resolution of the incident. This corresponds to the Incident Resolution field in the XFRACAS incident.
- **IsLRU**: indicates whether the item is a line replaceable unit (LRU). This does not correspond to an XFRACAS field; it can be used when creating data sets via the Synthesis API.
- **LastInspectedTime**: the last inspected time. For exporting XFRACAS data sets to Weibull++, this is equal to the state time for the data row. For exporting XFRACAS data sets to RGA, it is the amount of time the system has accrued at the last reported incident.
- **NumberInState**: equivalent to the Number in State column in a Weibull++ life data folio for grouped data. In data sets from XFRACAS, this value will always be 1.
- **NumberUDF1-3**: user-defined fields for numbers. You can choose up to 3 detail fields in XFRACAS incidents to import to these columns.
- **ParentPartID, ParentPartName, ParentPartNumber** and **ParentPartVersion**: identifiers for the "parent" of the part that the incident pertains to. If the part doesn’t have a parent (i.e., it is a top level part), this information will be identical to the information for the part itself.
- **PartHID** and **PartID**: the part’s hierarchy identification number and database identification number. In XFRACAS, these are assigned by the system and shown in the HID and Part ID fields that are displayed for the generic part on the Template page.
- **PartName, PartNumber** and **PartVersion**: identifiers for the part that the incident pertains to. In XFRACAS, this information is specified for the generic part, and serialized parts based on the generic part will use the same information.
• **PartOrder**: the order in which the part was replaced. This corresponds to the order in the repair/replace table in the XFRACAS incident.

• **PartSerialHID**, **PartSerialMfgCode** and **PartSerialNumber**: relevant only if the incident was assigned to a part in a serialized system. They represent the part’s serial hierarchy identification number, manufacturing code and serial number. In XFRACAS, the PartSerialHID is assigned by the system and shown in the Serial HID field that is displayed for the serialized part on the Serialized page.

• **ReportType**: how the incident was reported. This corresponds to the type chosen in the Report Type field in the XFRACAS incident.

• **RootCause**: the root cause of the failure mode. This is chosen or created in the Root Cause field in the XFRACAS incident.

• **StateFS**: This allows the user to understand if a data row is considered a failure (F) or a suspension (S) for the purposes of reliability calculations. In XFRACAS data sets, this is based on the incident category assigned in the XFRACAS incident, in conjunction with the failure type assigned during part repair/replacement. For more information, see the “Incident Disposition Area” topic in the XFRACAS documentation.

• **StateTime**: the amount of time accrued on the part. This is based on the run hours calculated by XFRACAS.

• **StateTimeRestore**: the amount of time required for the repair. This corresponds to the Repair Duration field in the XFRACAS incident.

• **StringUDF1-3**: user-defined fields for strings. You can choose up to 3 detail fields in XFRACAS incidents to import to these columns.

• **TimeMetric**: the time metric to use for the data. The options are based on the metrics that have been enabled for the XFRACAS entity.

• **TopLevelCommissionDate**: the commission date of the top level part in the system. This corresponds to the commission date of the associated CSI in XFRACAS.

• **TopLevelPartID**, **TopLevelPartName**, **TopLevelPartNumber** and **TopLevelPartVersion**: identifiers for the top level part in the system that the incident pertains to.

• **TopLevelSerialHID** and **TopLevelSerialNumber**: relevant only if the incident was assigned to a part in a serialized system. They represent the serial hierarchy identification number and serial number of the top level part in the serialized system. This information is used by RGA and Weibull++ to distinguish the system in which the failure occurred.
Transferring from the SDW to an Analysis Folio

Follow the steps below to transfer a data set from the Synthesis Data Warehouse (SDW) to a Weibull++, ALTA or RGA analysis folio.

1. In Weibull++, ALTA or RGA, choose Home > Synthesis > Synthesis Data Warehouse.

2. In the SDW, double-click the data you want to transfer to an analysis folio.

3. In the data table, use the Include in Analysis? column to mark any data points that need to be excluded from the transfer. You can double-click the cell to toggle the options, or select the row and choose Build Data Set > Include or Exclude.

In data collections imported from XFRACAS:

- Incidents with StateTime = 0 and StateFS = S (suspension) are automatically marked Ignore.
- Incidents with StateTime < 0 are automatically marked Invalid.

<table>
<thead>
<tr>
<th>Include in Analysis?</th>
<th>StateTime</th>
<th>StateFS</th>
<th>LastInspectedTime</th>
</tr>
</thead>
<tbody>
<tr>
<td>Invalid</td>
<td>-10</td>
<td>S</td>
<td>-10</td>
</tr>
<tr>
<td>Include</td>
<td>121</td>
<td>F</td>
<td>121</td>
</tr>
<tr>
<td>Ignore</td>
<td>0</td>
<td>S</td>
<td>0</td>
</tr>
<tr>
<td>Include</td>
<td>1000</td>
<td>S</td>
<td>1000</td>
</tr>
<tr>
<td>Include</td>
<td>131</td>
<td>S</td>
<td>131</td>
</tr>
<tr>
<td>Ignore</td>
<td>0</td>
<td>S</td>
<td>0</td>
</tr>
<tr>
<td>Exclude</td>
<td>1000</td>
<td>S</td>
<td>1000</td>
</tr>
<tr>
<td>Include</td>
<td>2160.02</td>
<td>S</td>
<td>2160.02</td>
</tr>
<tr>
<td>Ignore</td>
<td>0</td>
<td>S</td>
<td>0</td>
</tr>
<tr>
<td>Exclude</td>
<td>1000</td>
<td>S</td>
<td>1000</td>
</tr>
<tr>
<td>Include</td>
<td>2160.02</td>
<td>S</td>
<td>2160.02</td>
</tr>
</tbody>
</table>

4. Choose Transfer > Transfer to New Folio.
Follow the on-screen prompts to select the data type and map the SDW fields to columns in the new analysis folio.

**Tips for Mapping the Columns**

- **State F or S** (in Weibull++/ALTA) indicates whether a data point represents a failure (F) or suspension (S). If the data source field does not use the F and S codes, use the **Define Values as Failures/Suspension** area to specify which value(s) represents each state.

- **Event** (in RGA) indicates whether the data point represents a failure (F) that will be transferred for analysis, or some other event that will not be analyzed as a failure. When a data point is marked as a suspension (S) for transfer to RGA, it will be considered only if it affects the recorded system end time. For example, if the System End Time column indicates that the system was last inspected at 1,000 hours but there is a suspension for that system at 1,100 hours, the later time will be used in the folio.

- Time and quantity columns, such as **State End Time** and **Number in State**, can only be mapped to fields with a numeric data type (e.g., number, currency, etc.).

- **Classification** and **Mode** columns (in RGA) can be mapped to any SDW user-defined field that contains the data. (See [Extracting Data from XFRACAS](#).)
Chapter 23: Synthesis Data Warehouse

- **Subset ID** columns (in Weibull++/ALTA) or **Comment** columns (in RGA) allow you to choose multiple SDW fields to display in the same folio column. The data from the fields will be concatenated and separated by dashes (e.g., "Report Type – Category"). Use the check boxes to select the fields and then use the arrows to specify the order.

![Set Subset ID Column 1](image)

**SDW Dashboards**

This topic describes how to use the **Synthesis Dashboard utility** for exploring and presenting data from the **Synthesis Data Warehouse**. If a **Synthesis Enterprise Portal** website has been implemented for an enterprise database, users can also access SDW dashboards from any web-enabled device.

For static data collections, a variety of dashboard layouts can be predefined. For custom connections, there can be only one layout for each connection.

1. In Weibull++, ALTA or RGA, choose **Home > Synthesis > Synthesis Data Warehouse**.

2. Double-click the static data collection or custom connection that contains, or links to, the data you want to view in the dashboard.

3. On the Build Data Set tab, select which rows to include or exclude. (See **Building the Data Set**.)

4. If an appropriate dashboard layout has already been predefined, switch to the Dashboard Viewer tab or choose **Dashboard > Dashboard Viewer**. If multiple layouts are available, use the drop-down list at the top of the viewer to choose what to display.

5. If you need to create a new layout, choose **Dashboard > Dashboard Manager** (for a static data collection) or **Dashboard Designer** (for a custom connection).
(In a secure database, the Dashboard Layout Manager and the Dashboard Layout Designer are available only for users with the “Manage dashboard layouts” permission.)

For information on the data fields available for use in dashboard layouts for SDW data collections, see Data Fields for XFRACAS Data Collections.

**Tip**: For dashboards that are intended to be viewed in both desktop applications and the Synthesis Enterprise Portal (SEP), it is recommended to use the Local Colors option on the Design tab of the Dashboard Layout Designer to save your preferred colors with the layout. The global colors definition may not be the same in both web and desktop.

---

**Custom Connections in the SDW**

The Custom Connections feature in the Synthesis Data Warehouse allows you to create a live link to an external data source (Access, Oracle or SQL Server). This enables you to get data from your own custom and third-party databases for transferring to an analysis folio in Weibull++, ALTA or RGA, or for viewing in the SDW dashboards.

You can also get data directly from your own custom reports created in XFRACAS.

A custom connection data source always shows the latest information from the original database or report and you can only create one dashboard layout per connection. You can also use these connections to import data into a static Weibull++/ALTA or RGA data collection, if desired.

**Connect to an External Database**

To create a live link to an external database:

1. Choose Manage Data Sources > Add Custom Connection > To External Database.

2. In the Add Custom Connection window:
   a. Enter the Display Name that will identify this custom connection in the SDW data source list.
b. Enter the connection settings for a **Microsoft SQL Server**, **Oracle** or **Access** database. (See [Connection Issues](#) below for more information about the **Use impersonation** option for SQL Server.)

c. After you have specified the database, the **Table Name** field shows a list of the available tables. Select the main one that contains the data you want to use in the SDW.

d. If you want to create aliases for column names, build a query that combines data from multiple tables or enter your own SQL, select the **Open Query Editor/Builder** check box.

e. If you want to create the dashboard layout for this data source immediately after defining the connection/query, select the **Open Dashboard Designer** check box.

f. Click **OK** to proceed.

3. If you selected to customize the query, you can use the Query Editor to type or paste your own query, or select a stored procedure. If you need further tools, click the **Run Query Builder** button. The Query Builder can serve three purposes:

   a. The bottom-center panel shows the fields that will be included in the data set. If desired, you can use the Alias column to change the names that will be displayed in the SDW grid and dashboard layouts.

   b. If the tables are linked by foreign keys, you can use the tool to build a query that combines fields from multiple tables.

   c. You can also enter your own SQL in this tool; select the **Allow SQL Editing** check box and type or paste your own query.

   When you are finished in the Query Builder, click **OK** to return to the Query Editor, where you can click **Finish** to save your changes.

4. If you selected to open the Dashboard Designer, you can use it to create a single dashboard layout for this data source.

If you want to change the query or create/modify the dashboard layout at a later time, select the custom connection in the data source manager and choose **Dashboard > Dashboard Designer**.

From within the Dashboard Designer window, choose **Home > Query > Edit** to customize the query.
Connection Issues
There will be a "connection failed" message if the database is not found at the specified name/location or if you don’t have permission to access it.

If your organization has implemented a Synthesis Enterprise Portal (SEP) website, the administrator may need to take additional steps to make the dashboards visible to all users via the SEP website. For details, consult the print-ready implementation guide (*.pdf).

- **Oracle** - the password is stored with the custom connection; therefore, both the desktop applications and SEP website will attempt to connect in the same way for all users.

- **SQL Server** - the **Use impersonation** option in the custom connection allows you to enter a login for a one-time extraction to an SDW data collection, but this login is not saved in SDW.

  For subsequent attempts, the desktop applications will connect with the current user’s Windows login, whereas the SEP website will use the login that the website uses to connect with the Synthesis repository (if the Synthesis repository is SQL Server) or with the IIS "application pool identity" (if the Synthesis repository is Oracle).

- **Access** - the SDW can only connect with databases that are not password protected and must have access to the folder where the database is stored. It is recommended to use the UNC pathname (e.g., `\\servername\foldername` rather than `P:\foldername`) when you create the custom connection.

  The desktop applications will attempt to access the file with the current user’s Windows login, whereas the SEP website can only access files stored directly on the web server or in a network folder that can be accessed by the website’s IIS "application pool identity."

  **Tip:** For Access databases with the *.accdb file type, the dashboard can only be displayed if the database was created with the same version of Microsoft Office (32-bit vs. 64-bit) that is installed on each individual user’s computer (for ReliaSoft desktop applications) or on the web server (for SEP).

  To ensure that the dashboard will display regardless of which version of Microsoft Office is installed, use the *.mdb file type instead of *.accdb.

Connect to XFRACAS Report
Creating a custom connection to a predefined XFRACAS report enables you to use the SDW to view any type of XFRACAS data (not just data collections extracted for life data or repairable systems analysis). If a Synthesis Enterprise Portal has been implemented for an enterprise
database, users can also access the dashboards created for these reports from any web-enabled device.

**Tip:** For information about creating SDW reports in XFRACAS, see the "Report Builder" topic in the XFRACAS documentation.

To create a live link to an SDW report that has already been created in XFRACAS:

1. Choose **Manage Data Sources > Add Custom Connection > To XFRACAS Report**.

2. In the Select Report window, select any of the XFRACAS SDW reports that have been predefined in the database.

3. Click **OK** to load the data.

**Import to a Static Data Collection**

In the **Synthesis Data Warehouse**, a **custom connection** provides a live link to an external database or XFRACAS report, while a static data collection stores Weibull++/ALTA or RGA data that was extracted at a particular point in time.

A static data collection can contain **data extracted directly from XFRACAS**. If desired, you can also create a static Weibull++/ALTA or RGA data collection by importing data from a custom connection. To do this:

1. Right-click the custom connection in the data source manager and choose **Import**.

2. In the Import Data from Custom Connection window:
   a. The **Map Data Source Fields to Columns** section specifies which field from the custom connection will be mapped to a column that’s available in a Weibull++/ALTA or RGA data collection.
   b. The **Define Values as Failures/Suspensions** section displays all of the unique values from the field that is currently mapped to the State FS column. Specify whether each value should be considered a failure or a suspension.
   c. The Preview tab allows you to see what the data collection will look like based on your selections.

3. Click **OK** to create the static data collection.
Chapter 24: Synthesis Enterprise Portal

If your organization implements a Synthesis Enterprise Portal (SEP) website for an enterprise database, the entire team – including managers and colleagues who don't have ReliaSoft desktop applications installed – can access key analysis and project management details from any web-enabled device.

This topic provides an overview of what the site offers in Version 2018. For information about what's required to set up a web portal for your organization, see Implementing an SEP Website.

SEP Home
The personalized home page provides an intuitive, at-a-glance overview of the information you’re tracking via SEP, such as actions, recent messages, reports, metrics and more. You can choose which panels are displayed in your own home page, and also change the order. (See Customizing the SEP Home Page.)

Actions and Portal Messages
You can use SEP to create, view and edit the same actions and portal messages that are visible to you from the desktop applications. The website also allows colleagues who don't use the desktop applications to stay up-to-date on assignments and team communication. (See Messages and Actions in SEP.)

Project Summary, Analysis Summaries and Project Plan
For each analysis project that you have permission to view, SEP provides a web summary that includes metrics, assigned actions, attachments and other project details. The website also displays summaries, plots and reports for selected analyses published to SEP from Weibull++/ALTA, BlockSim/RENO, RGA and Lambda Predict.

If your team is using the Project Planner in desktop applications, SEP shows a streamlined view of the plan that users can access via the web and also update their progress for assigned actions. (See Projects in SEP.)

System Hierarchies and FMEAs
SEP enables users throughout your organization to view FMEAs, queries and reports that were created in Xfmea, RCM++ or RBI. This provides managers and others throughout your organization with convenient web-based access to the wealth of lessons learned and troubleshooting recommendations from your investment in these
analyses.

Version 2018 offers many new and enhanced features that make SEP more useful than ever for FMEA users. This includes a new web summary of key statistics and charts from any FMEA, access to your own custom queries and the ability for managers to approve change log versions from any web-enabled device. (See FMEAs in SEP.)

**Dashboards and Reports**

SEP can display a wide variety of graphical dashboards and customized reports based on analysis data from desktop applications. The "Watch" feature makes it easy to manage the specific dashboards and reports you want to be able to access quickly. (See Dashboards and Reports in SEP.)

**Metrics (Key Performance Indicators)**

SEP shows all of the KPIs (metric resources) that have been created in desktop applications for the projects you have permission to view – no publishing required. The web display provides quick visual indicators to help you monitor performance and support decision making.

**SEP and XFRACAS**

ReliaSoft XFRACAS by HBM Prenscia is a highly configurable web-based failure reporting, analysis and corrective action system (FRACAS) with integrated capabilities for part tracking, root cause analysis and team-based problem resolution.

If your organization implements both websites for the same enterprise repository, SEP can include links to the XFRACAS reports, charts, actions and incidents of particular interest to each user. (See SEP and XFRACAS.)

**Implementing an SEP Website**

This topic provides a general overview of the steps required to implement a web-based Synthesis Enterprise Portal for your organization.
When you are ready to configure a website, the print-ready implementation guide (*.pdf) provides more detailed instructions for each step.

**Establish the Database and Web Server(s)**

SEP is a web-based system based on the .NET Framework and is designed to be n-tier, scalable, distributable, robust and able to be deployed across multiple servers or on a single computer.

If you plan to host the database and website on the same server, you will need:

- Windows 2008 R2 or newer
- .NET 4.6
- IIS with support for serving ASP.NET
- SQL Server 2008 or newer OR Oracle 10g or newer (32-bit and 64-bit versions of all, full version only)

**Install the Website and Connect to a Synthesis Repository**

Once you have established the database and web server(s), a system administrator will need to:

1. Run the **Synthesis Enterprise Portal setup** to create the website.
2. Run the **Product Activation tool** to activate your SEP license.
3. Run the **ReliaSoft Admin tool** to either create a new database or connect to an existing one. You can also use this utility to create Synthesis Platform user accounts if desired.

Remember that XFRACAS, ReliaSoft desktop applications and SEP are all designed to connect with the same data repository. If you already have a database established, you can use the admin tool to integrate it with SEP.

**Set Up Synthesis Platform User Accounts and Permissions**

Once the database has been created, you can use the **ReliaSoft Admin tool** or any of the desktop applications to create Synthesis Platform user accounts and set access permissions. You must create an account for anyone who will be able to edit or view data in the ReliaSoft desktop applications or SEP website. (User accounts for the XFRACAS website are managed separately.)

If your organization uses Microsoft Active Directory, you can save time by importing user information from the directory to create the user accounts.
Assign SEP Access to Users
Once the Synthesis Platform user accounts have been created (via desktop application or the Admin tool), you can use the SEP website to specify which of the database users will have access to the web portal.

Click the SEP Admin link in the top-right corner of the website and then use the Select SEP Users section to specify which user accounts will have website access.

The counters above the user table identify how many more SEP users are allowed under your current license.

Enable Publish to Synthesis Enterprise Portal
Some SEP-related features in ReliaSoft desktop applications (e.g., the ability to publish analysis summaries, workbooks, reports, etc.) will be visible only if the Enable publish to Synthesis Enterprise Portal option is set to "Yes" for the database.

This can be set from the SEP Admin page in the website or from the Repository Settings window in any of the desktop applications.

Configure Custom Content for Home
The optional "Custom Content" area in the SEP home page enables your organization to integrate a banner or other custom content into the site. This can be configured from the SEP Admin page in the website.

The SEPDefault.htm file is installed in the CustomContent folder under the root directory for the SEP website. You can choose to edit this file on the web server or replace it with a URL to another web page.
Chapter 24: Synthesis Enterprise Portal

Configure URLs for Links to Actions in SEP
When an SEP website is implemented for an enterprise database, the action alert e-mails and portal messages generated by any of the ReliaSoft applications can include links to view the action details in SEP. The applications build the links based on the settings specified on the SEP Admin page in the website. If an administrator has not specified an IIS prefix, the action alerts will not include links to SEP.

- **SEP Server - IIS Prefix** – enter the server name and folder for the website that you see in the browser’s address bar (e.g., servername/SEP).

- **Website Uses SSL (https for URLs)** – select Yes if the web server has been configured with a Secure Socket Layer (SSL) certificate for the SEP website and the URLs need to start with https rather than http.

If these settings do not match your website configuration, the links attached to the action alerts will give an error message when users attempt to open the page in a web browser (e.g., "File or directory not found," "Access forbidden" or "This page can’t be displayed").

Configure the Synthesis Service for Alerts Based on Calendar Date
Any Synthesis database can be configured to send alerts when a Synthesis Platform action is created, modified or ready to be reviewed. These alerts are sent to any user who is subscribed to "watch" the action, and they can be delivered via e-mail, SMS text message or Synthesis Platform message, depending on each user’s preference. (See Watches and Alerts.)

New in Version 2018, the Synthesis Service allows you to send additional alerts based on calendar date. If the service is running on the SEP web server, you can use the SEP Admin page to specify when the service will trigger "Action Due" alerts.

- **Service Status** – indicates whether the service was Running, Not Running or Not Found at the time when the page loaded.

- **Alert when action is due in X days** – if selected, enter the number of days before the action completion date (due date) to send the first alert.
  - **Remind every X days until the action is complete** – If selected, the service will continue to send reminders until the action is complete. Enter the number of days between alerts.
For example, if this is set to 21 days and 7 days, the service will send the first reminder 3 weeks before the due date and then continue to send reminders every week until the action is completed.

- **From Address for E-mail Alerts** – e-mail alerts sent by the service will be "from" this address.

### Configure Links Between XFRACAS and SEP

If your organization implements both the SEP and XFRACAS websites for the same enterprise repository, you can use the Admin Preferences page in XFRACAS (Admin > Configure > Preferences) to enable links between the two websites.

- **SEP → XFRACAS:**
  - Specify the XFRACAS Server - IIS Prefix (e.g., servername/XFRACAS)

- **XFRACAS → SEP:**
  - Specify the Synthesis Enterprise Portal Server - IIS Prefix (e.g., servername/SEP)
  - Set Synthesis - Display Synthesis Enterprise Portal (SEP) Command to True

### Allow Aqira Users to Access SEP

nCode Aqira by HBM Prenscia allows your organization to manage and share nCode fatigue and durability analyses via the web. New in Version 2018, Aqira users are entitled to access the Synthesis Enterprise Portal without requiring an SEP license seat. For details on how to enable this access, please consult the SEP Implementation Guide.

When the feature is enabled, SEP’s menu will include a link to the Aqira login page. In addition, when an active Aqira user attempts to access SEP, the application will check for a Synthesis Platform user account:

- If an account does not exist, it will be created automatically with the “Aqira” security group. (This group will always have at least “read” access to projects that use “repository-level security.” Any user with permission to edit security groups in ReliaSoft desktop applications can change these permissions to fit your needs.)

- If an account exists and is active, the user can access SEP with the permissions specified for the existing account.

- If an account exists but is inactive, the user cannot access SEP.

### Configure Remote ReliaSoft

When users view published analysis summaries and FMEAs in SEP, the Open buttons make it easy to open the full analysis in a relevant desktop application. New in Version 2018, you can
configure SEP to be able to run the applications on a remote server without having to install and update software on each client PC.

For requirements and details on how to configure Remote ReliaSoft, please consult the SEP Implementation Guide.

If Remote ReliaSoft is enabled for your implementation, each user can choose whether to launch the applications remotely or locally. (See SEP User Preferences.)

Distribute SEP Website Link to All Users
Once the web portal has been implemented, users can access the site with any web browser that supports the following doctype. If the site is private (e.g., http://InternalServer/SEP), the system administrator may need to provide users with instructions for how to access the website on the internal network from their mobile devices (e.g., via VPN or some other method).

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

Customizing the SEP Home Page
The personalized SEP home page provides an intuitive, at-a-glance overview of the information you're tracking via the website.

Custom Content
The optional "Custom Content" area enables your organization to integrate a banner or other custom content into the site if desired. This can be configured on the SEP Admin page by any user with "administrative" permissions (see Implementing an SEP Website).

If the custom content is enabled for a database, the same panel will be displayed at the top of the home page for all SEP users.

Home Page Panels
For the rest of the home page panels, each user can choose which panels are displayed, and also change the order.

To modify your personalized home page, click Edit Home Layout in the top-right corner of the page.
When the page is in the edit mode, the panels will have a yellow background color and a (+) or (-) icon will appear in each title bar:

- Use the title bar to drag and drop a panel into a different position on the page.
- Use the icon to hide (-) or show (+) the panel.

To save your preferences and leave the edit mode, click **Save Layout**.

**Tip:** If you click the **Restore Defaults** button on the User Preferences page, your personalized home page layout will be reset to the default.

---

**Actions and Messages in SEP**

The **Synthesis Enterprise Portal** (SEP) enables you to create, view and edit the same actions and portal messages that are visible to you from ReliaSoft desktop applications. The website also allow colleagues who don't use the desktop applications to stay up-to-date on assignments and team communication.

**My Actions (Home Panel and Page)**

The My Actions home panel and page show actions that are relevant to you and still require action of some kind (i.e., not started, not completed or need to be reviewed). They do not show actions that are already complete.

These are the same actions that you can view in My Portal in the desktop applications. (See **Actions in My Portal**.)

**Home Panel**

You can choose which types of actions to view in your home panel based on how they are relevant to you: creator, person responsible, team member, monitoring or assigned to review/approve. (See **SEP User Preferences**.)
Page

The **Relevance** check box on the My Actions page are independent of your preferences for the home panel. You can change these on the fly based on your interest at any given time.

You can also filter, sort and group the table. (See Using Tables in SEP.)

All of these settings will be reset to the defaults when you navigate away from the page.

<table>
<thead>
<tr>
<th>Status: Pending Approval</th>
</tr>
</thead>
<tbody>
<tr>
<td>Relevance: I need to review/approve</td>
</tr>
<tr>
<td>Widget PN12345</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Status: Due Next 7 Days</th>
</tr>
</thead>
<tbody>
<tr>
<td>Relevance: I am responsible for</td>
</tr>
<tr>
<td>Saturn Prototype</td>
</tr>
<tr>
<td>Saturn Prototype</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Status: Past Due</th>
</tr>
</thead>
<tbody>
<tr>
<td>Relevance: Other actions I created</td>
</tr>
<tr>
<td>Widget PN12345</td>
</tr>
</tbody>
</table>

**Create Action**

To add a new action in the project that is currently active for you in SEP, navigate to the My Actions page and click **Create Action**.

To create an action for a different project, you must first navigate to that project in SEP and then return to My Actions. (See **Projects in SEP**.)

**Messages (Home Panel and Page)**

The Recent Messages home panel and Messages page show ReliaSoft portal messages that are relevant to you, sent to you, sent to a user group that you belong to or sent to all users.

These are the same messages that you can view in My Portal in the desktop applications. (See **Portal Messages**.)

In the Messages page:

- To send a new message, click **Create Message**.
- To reply to an existing message (if applicable), click **Reply**.
Actions in a Project Summary, Project Plan or FMEA

The Project Summary, Project Plan and FMEA pages show actions from the project that is currently active for you in SEP. Unlike the My Actions page/panel, this may include actions that are not directly relevant to you, as well as actions that are complete.

The Project Summary page displays all actions in the project. Click a row to view the action details.

<table>
<thead>
<tr>
<th>Person Responsible</th>
<th>Action</th>
<th>Planned Start Date</th>
<th>Planned Completion Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jill Engineer</td>
<td>This is an action from an FMEA.</td>
<td>8/30/2016</td>
<td>8/31/2016</td>
</tr>
<tr>
<td>Jane Manager</td>
<td>This is a standalone action.</td>
<td>6/1/2016</td>
<td>6/13/2016</td>
</tr>
<tr>
<td>Joe Engineer</td>
<td>This is an action in a project plan.</td>
<td>6/1/2016</td>
<td>6/13/2016</td>
</tr>
</tbody>
</table>

The Project Plan page shows all actions used in the plan. Click a link (blue text) to view the action details.

<table>
<thead>
<tr>
<th>Name</th>
<th>Planned Start Date</th>
<th>Actual Start Date</th>
<th>Planned Completion Date</th>
<th>Actual Completion Date</th>
<th>Planned Cost</th>
<th>Actual Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Titan Prototype</td>
<td>8/19/2016</td>
<td>8/22/2016</td>
<td>7/14/2017</td>
<td>8/31/2017</td>
<td>$40,000.00</td>
<td>$37,100.00</td>
</tr>
<tr>
<td>Design Phase</td>
<td>8/19/2016</td>
<td>8/22/2016</td>
<td>11/18/2016</td>
<td>11/4/2016</td>
<td>$5,000.00</td>
<td>$5,125.00</td>
</tr>
<tr>
<td>Development Phase</td>
<td>.11/7/2015</td>
<td>11/11/2016</td>
<td>3/3/2017</td>
<td>11/31/2017</td>
<td>$25,000.00</td>
<td>$31,275.00</td>
</tr>
<tr>
<td>Manufacturing Phase</td>
<td>3/3/2017</td>
<td>3/3/2017</td>
<td>5/12/2017</td>
<td>4/27/2017</td>
<td>$10,000.00</td>
<td>$0.00</td>
</tr>
<tr>
<td>Test &amp; Validation Phase</td>
<td>4/28/2017</td>
<td>7/13/2017</td>
<td></td>
<td></td>
<td>$0.00</td>
<td>$0.00</td>
</tr>
</tbody>
</table>

The FMEA hierarchy shows all actions used in an FMEA. Click ☰ to view the action details.
Links to SEP from Action Alert E-mails and Portal Messages

The action alert e-mails and portal messages generated by ReliaSoft applications can include links to view the action details in SEP.

If these links are not working properly for your website, see Implementing an SEP Website

Projects in SEP

In the Synthesis Enterprise Portal (SEP), some pages - such as My Actions or My Dashboards & Reports - can show data from any project that you have permission to view. Other pages can display data only from a single analysis project that is currently action for you in the website. This includes:

- Project Summary
- Published Analyses (from Weibull++/ALTA, BlockSim/RENO, RGA or Lambda Predict)
- Project Plan
- FMEAs

Change Project and My Projects

For any SEP page that shows data from a particular project, the Change Project button allows you to view that same type of data from another project.

When you click the button, the first popup lists the projects that you have personally selected for quick access in SEP (called "My Projects").
To modify this list or view a project that's not in the list, click **Select Projects**. In the second popup:

- The right side shows your list of "My Projects".
- The left side shows all the projects that you have permission to view. You can apply any of the project filters that were created in ReliaSoft desktop applications, or use the **Find** box to filter by specific text in the project name. Use the icons to add a project to your list or just view it now.

  **Add to My Projects**

  **View Now** (i.e., view the project without adding it to your list)

  Indicates that the project is already in your list.

  **Remove from My Projects**
Tip: If you want to have quick access to the same set of projects while working in ReliaSoft desktop applications, you can create a project filter that filters based on Selected projects.

Publishing to SEP

The Synthesis Enterprise Portal website does not display all of the analyses that were performed in ReliaSoft desktop applications. Instead, your team can decide which analyses to make available via the web, and publish selected analysis summaries and reports.

These features are only available when:

- You are connected to an enterprise database that has an SEP website implemented and the Enable publish to Synthesis Enterprise Portal option is set to "Yes" for the database.
- You have the "Publish to Synthesis Enterprise Portal" permission.
<table>
<thead>
<tr>
<th>ReliaSoft Application</th>
<th>What can be published</th>
</tr>
</thead>
<tbody>
<tr>
<td>Weibull++/ALTA</td>
<td>• Life Data</td>
</tr>
<tr>
<td></td>
<td>• Non-Parametric LDA</td>
</tr>
<tr>
<td></td>
<td>• Life-Stress Data</td>
</tr>
<tr>
<td></td>
<td>• Weibull Degradation</td>
</tr>
<tr>
<td></td>
<td>• ALTA Degradation</td>
</tr>
<tr>
<td></td>
<td>• Parametric RDA</td>
</tr>
<tr>
<td></td>
<td>• Standard Design, Robust Design, Mixture Design, Free Form Design</td>
</tr>
<tr>
<td></td>
<td>• One Way ANOVA</td>
</tr>
<tr>
<td></td>
<td>• Linearity &amp; Bias, Gage R&amp;R, Gage Agreement</td>
</tr>
<tr>
<td></td>
<td>• Multiple Linear Regression</td>
</tr>
<tr>
<td></td>
<td>• Synthesis Workbook</td>
</tr>
<tr>
<td>RGA</td>
<td>• Growth Data</td>
</tr>
<tr>
<td></td>
<td>• Synthesis Workbook</td>
</tr>
<tr>
<td>BlockSim/RENO</td>
<td>• Analytical RBD, Simulation RBD</td>
</tr>
<tr>
<td></td>
<td>• Analytical Fault Tree, Simulation RBD</td>
</tr>
<tr>
<td></td>
<td>• Phase Diagram</td>
</tr>
<tr>
<td></td>
<td>• RENO Flowchart</td>
</tr>
<tr>
<td></td>
<td>• Continuous Markov, Discrete Markov</td>
</tr>
<tr>
<td></td>
<td>• Synthesis Workbooks</td>
</tr>
<tr>
<td>Lambda Predict</td>
<td>• Reports</td>
</tr>
<tr>
<td></td>
<td>• Stored Plots</td>
</tr>
</tbody>
</table>
Xfmea, RCM++ and RBI

- Reports (saved with the project)
- *System hierarchy and FMEAs are also visible on the website — no publishing required*

**Note:** If you have published analysis summaries and you get a "Link is not properly formatted" message when you attempt to open the original analysis from SEP, the link may be corrupted or is using old encryption. Republish the analysis to refresh the link.

### Data Sheets or Diagrams

To publish an analysis summary from Weibull++/ALTA, RGA or BlockSim/RENO, open the data sheet or diagram and click **Publish SEP Summary** on the Publishing page of the control panel. (For DOE design folios, the "Data" tab with analyzed response data must be selected.)

For data sheets, this displays a preview of the spreadsheet summary. Click **Publish SEP Summary** again to complete the process.

After publishing, the panel displays "Synchronized" if the web version reflects the latest results from the analysis. If the analysis has been modified (e.g., if more data has been added, an analysis setting has changed, etc.), it displays "Out of Sync" and you will need to recalculate and republish to update the website.

To remove the summary from the website, click **Remove SEP Summary**.

### Synthesis Workbooks

To publish a **Synthesis Workbook** from Weibull++/ALTA, RGA or BlockSim/RENO, open the module in the workbook that you want to share (spreadsheet or word processing document), then click **Home > SEP > Publish Report**.
Chapter 24: Synthesis Enterprise Portal

The status bar indicates that the spreadsheet or document is visible via the SEP website, and when the web version was last updated.

If you subsequently make a change in the desktop application, you will need to republish to update the website.

If you want to remove the report from the website, open the module and click Home > SEP > Remove Report.

**Prediction Reports and Plots**

To publish a report for a standard item or block in Lambda Predict, select the item/block and choose Prediction Tools > Share > Publish SEP Summary.

In the Select Report window, select what to include in the report (e.g., template-based reports, default reports or plots) and click OK. (See Lambda Predict Reports in the Lambda Predict documentation.) There can be only one published report for each item/block. If you publish again for the same item, it will replace the report that was previously published.

To publish a stored plot from Lambda Predict, open the plot, then click the Publish SEP Summary icon on the Publishing page of the plot control panel.

The following example shows two published reports from the Power Amplifier Circuit folio and one published plot.

To remove a report from the website, select the standard item or block, then open the Publishing tab of the Properties panel and click Remove SEP Summary.
To remove a plot from the website, open the plot, then click the **Remove SEP Summary** icon on the Publishing page of the plot control panel.

### Xfmea/RCM++/RBI Reports

To publish a report generated in Xfmea/RCM++/RBI, use the Reports window to build the document, select at least one of the **Save/Publish** file formats on the ribbon (Word, Excel, or PDF) and click **Generate Report**.

![Published Reports Manager](image)

To see all of the generated report documents that have been saved with the project (and therefore will be visible via SEP), click **Published Reports Manager**. You can also use the manager to edit the name and description that will show in the website.

For more information, see **Save/Publish Reports** in the Xfmea/RCM++/RBI documentation.

### FMEAs in SEP

The **Synthesis Enterprise Portal** (SEP) allows users throughout your organization to view FMEAs and published reports that were created in ReliaSoft Xfmea/RCM++/RBI - without having the desktop applications installed. With many new and enhanced features in Version 2018, it's more convenient than ever for managers and stakeholders to access key FMEA details from any web-enabled device.

The **FMEAs** link in the menu opens the FMEAs page for the project that is currently active for you in SEP. This link also appears in the Project Summary page if the project contains FMEA data.
Chapter 24: Synthesis Enterprise Portal

Use the main tabs at the top of the page to navigate between the Hierarchy View, Published Reports, Dashboards and Queries for the current project.

In the Hierarchy View, select an item in the system hierarchy (left/top) and use the sub-tabs (right/bottom) to navigate between the item properties, FMEA stats and FMEA hierarchy for that item.

If you want to view the FMEAs from a different project, click the Change Project button at the top of the FMEAs page.

If you want to view the full analysis in a desktop application, click Open.

Hierarchy View
The Hierarchy View tab shows the system hierarchy, item properties and any FMEAs that have been created in the desktop applications. (See System Hierarchy and FMEA Analysis in the Xfmea/RCM++/RBI documentation.)

The item properties are always displayed in the Properties tab. When an item has an FMEA, the icon displays in the system hierarchy and you can view the summary report on the FMEA Stats tab or the full analysis on the FMEA tab.

FMEA Stats
The FMEA Stats report provides a quick at-a-glance summary of key statistics and charts for the item that is currently selected in the system hierarchy. If you select an item that has both a system FMEA and component FMEAs, you can view a report for the system FMEA only or a report that combines the data from all component FMEAs. (See FMEA Stats in SEP.)
**FMEA Hierarchy**

The FMEA hierarchy displays the full analysis for the item that is selected in the system hierarchy. To specify which columns display for any FMEA that you view in SEP, click 📒. In the Customize FMEA Columns window:

- Columns that are not enabled in the current project are shown in gray text.
- Select the **Enable Priority Highlights** check box if you wish to use color to highlight issues based on priority. This feature uses configurable logic that is saved with each project. (See FMEA > RPNs in the Xfmea/RCM++/RBI documentation.) In SEP, the colors can be displayed in the FMEA hierarchy and in query results for effects and causes (if the relevant column(s) are displayed).

To view the full properties for a record in the FMEA hierarchy, click 📒.

**Change Log**

The FMEA change log is an optional feature that can be activated and managed via the desktop applications. (See Change Logs and Electronic Approval Tracking in the Xfmea/RCM++/RBI documentation.)

If a change log has been activated for an FMEA, the name of the current version will show in the SEP's system hierarchy. This is visible to all users.

If you are an assigned approver for the current version and it is ready for you to review and approve, this is a link (blue text) that opens a window where you can electronically record your approval.
Published Reports

The Published Reports tab displays the reports generated in desktop applications that have been saved with the project (in Word, Excel or PDF format). This allows both desktop and SEP users to view/print the same report documents. (See Save/Publish Reports in the Xfmea/RCM++/RBI documentation.)

Dashboards

The Dashboards tab displays the dashboard layouts that have been predefined in desktop applications for FMEA data. Each dashboard can include data from all FMEAs in the current project. (See FMEA Dashboards in the Xfmea/RCM++/RBI documentation.)

FMEA Queries

The Queries tab allows you to run queries that have been predefined in desktop applications for item properties and FMEA data. This provides a quick way to get customized output based on the latest data from any analysis, such as a list of actions that are not complete, failure modes with high PRNs, and more. (See Query Templates in the Xfmea/RCM++/RBI documentation.)

You can select to run:

- Private query templates that you personally saved.
• Public query templates that are available to all database users.

Note that the SEP only displays query templates for items and FMEA data. It does not display queries for other types of analyses that are not visible in SEP, such as control plans or p-diagrams.

Select the item(s) that contain the data you want to query (on the left/top), select a saved template (on the right/bottom), then click Run Query.

In the Results page, the top section displays a summary of the criteria that were defined in the query template.

• **Criteria match all rows** is an "AND" query that returns records that match all criteria.

• **Criteria match any row** - an "OR" query that returns records that match any of the specified criteria.

Click inside a column header to sort by that field.

If you want to save or share these results with others, use the Save URL, Copy URL and E-mail URL links at the top of the web page, or copy/paste the URL from the browser's address bar.

**Observed Occurrences in XFRACAS**

In an enterprise database that has an XFRACAS website, users with required permissions can "associate" items and failure modes in Xfmea/RCM++/RBI with template parts and failure modes in XFRACAS. (See Import or Sync from XFRACAS in the Xfmea/RCM++/RBI documentation.)

The icon in the system hierarchy indicates that the item is associated with an XFRACAS template part. In such cases:

• To view all XFRACAS incidents, problems or failure analyses that have been reported for an item, click the icon in the system hierarchy. A record will appear in this list if the
part is identified as the "Responsible Part" for an incident, the "Part Category" for a problem or the "Repaired/Replaced Part" for a failure analysis.

- To view the quantity of XFRACAS records that have been reported for an item and failure, make sure the **Observed Occurrences** column is displayed in the FMEA hierarchy. If records have been reported for a particular failure, click inside the cell to view the specific record IDs.

<table>
<thead>
<tr>
<th>Description</th>
<th>Observed Occurrences</th>
</tr>
</thead>
<tbody>
<tr>
<td>Function description</td>
<td></td>
</tr>
</tbody>
</table>
| Failure description | Incidents = 1
Problems = 1
Failure Analyses = 1 |

**Note:** The XFRACAS reports displayed in SEP are generated based on the standard report templates defined in XFRACAS for incidents, problems or failure analysis reports, with query criteria added "on the fly" to return results for a particular item and/or failure mode. Since the criteria is not saved with the template, you will not be able to "watch" the report. Likewise, you will not be able to use the URL that is visible in the results page to generate the exact same results again. To see the results again, you must click the link generated within SEP.

### FMEA Stats (Web Summary)

Available only in the **Synthesis Enterprise Portal** (SEP), the FMEA Stats report provides a quick at-a-glance summary of key statistics and charts for an FMEA or a group of FMEAs that were created in desktop applications.

To navigate to this report from within SEP, go to the FMEAs page for the project and, on the **Hierarchy View** tab, select an item in the web system hierarchy. If the report is not displayed by default, click the **FMEA Stats** tab.

To get a link to this report from within Xfmea/RCM++/RBI, select an item in the desktop system hierarchy and choose **System Hierarchy > Current Item > Web Summary > Open in SEP or E-mail SEP Link.**

### Current Item and/or Sub-Items

Depending on the item that is selected in the system hierarchy, you may be able to select one or both of these check boxes:

- **Current Item** shows data from the selected item's FMEA.
• **Sub-Items** shows data from the FMEAs for the selected item's sub-items.

For example, if there is both a system FMEA and component FMEAs, you can review a report for the system FMEA only or a report that combines the data from all of the component FMEAs.

**Change Log Version and Status**

If you select to show data from the current item only (not sub-items) and a change log has been activated for the FMEA, the report displays the name of the current version and one of the following statuses:

• **In Progress** - a revision to the analysis is currently in progress.

• **Locked** - the analysis is locked for editing and there are no assigned approvers.

• **Awaiting Approval** - the analysis is locked for editing and one or more assigned approvers still need to review.

• **Approved** - the analysis is locked for editing and all of the assigned approvers have electronically recorded their approval.

**% Analyzed or Completed**

The large numbers display the quantity for each record type and, when applicable, the percentage of those records that are analyzed or completed. In this report, **Analyzed** means that the branch has at least one function, failure, effect and cause, and ratings are assigned to the effects and causes, if applicable.

For example, if the project is configured to calculate both initial and revised RPNs, a failure is "analyzed" if it has at least one effect and at least one cause, all of its effects have both initial and revised severity, and all of its causes have both initial and revised occurrence and detection.

For actions, **Completed** means that an actual completion date has been entered.

**Top Failure Causes**

If the project is configured to use RPN metrics, the report will display the top failure causes. Use the check boxes to specify whether you want to view a pareto (bar) chart based on **RPN**, **SxO** or both.
Chapter 24: Synthesis Enterprise Portal

Recommended Actions
If the project is configured to include actions in the FMEAs, the report will display a list of the FMEA actions along with:

- **Completion Status** pie chart based on the number of actions that are completed, in progress, not started or past due.

- **Progress** bar based on the total planned duration, the actual duration for closed actions and the percent completed for open actions. For example, if Action 1 (duration = 3 days) is complete and Action 2 (duration = 2 days) is still in progress but marked 50% complete, the overall progress is 80% (4 out of 5 days).

Dashboards and Reports in SEP
Dashboards and Synthesis Workbook reports are available throughout the Synthesis Enterprise Portal (SEP) website when you view different types of data.

For example, when you view a particular project plan in the website, you can select to view the latest information from the plan in any of the dashboard layouts that are currently available for that type of data.

Likewise, when you review the Weibull++/ALTA, RGA or BlockSim/RENO analyses for a particular project, you can see any Synthesis Workbook reports (spreadsheets or documents) that were published to the website.

Save, Copy or E-mail the URL
When you view a dashboard or Synthesis Workbook in the SEP website, the link for the web page (URL) includes the identifiers required to open the same report again later if the data/report is still visible in SEP and the user has permission to view the data.

- For dashboards, this will display the latest data from the analysis using the latest version of the predefined layout.

- For Synthesis Workbooks, this will display the latest published version of the report.

You can use the Save URL, Copy URL and E-mail URL links at the top of the web page, or copy/paste the URL from the browser’s address bar.

[Save URL] [Copy URL] [E-mail URL]
Watch This Report

The "Watch This Report" feature makes it easier to manage the specific dashboards and reports you want to be able to access quickly via the SEP website.

To watch an SEP dashboard or report, navigate to it in the website and click the Watch button or link, then enter the name and description that will show in your personalized list of "My Dashboards & Reports."

![Watch This Report dialog box](image)

Click Reports in the SEP menu to see the list of dashboards and reports you are currently watching in SEP. You can filter by name/description, project or report type.

![Dashboard list](image)

If you want to change the sort order, first clear all the filters and then click to drag and drop the reports into the desired position.

The first 5 reports will show in your personalized SEP home page (unless you have chosen to hide the "My Dashboards & Reports" panel).

Note: If you have an XFRACAS website that is linked to SEP, the application will automatically create a watch in SEP for any reports or charts that you choose to watch in XFRACAS. The XFRACAS and SEP
watches are not synchronized after the original creation. If you later delete the watch in XFRACAS, it will not change the watch in SEP. Likewise, if you later delete or rename the watch in SEP, it will not change the original watch in XFRACAS.

**Quick Links in SEP**

The Quick Links feature allows you to create your own personalized list of links within the Synthesis Enterprise Portal (SEP) website.

**Link to a Page in SEP**

To create a link to a page in the SEP website (e.g., for quick access to a particular project summary, FMEA system hierarchy, assigned action, etc.), navigate to the page and then click the *Save URL* link at the top-right corner of the page. You will be prompted to specify the name that will show in your list of quick links.

**Link to an External Website**

To create a link to an external website (e.g., a company intranet, document management system, etc.), click the *Quick Links* heading or icon in the SEP menu to open the My Quick Links page.

Use the *Add New Link* section to specify the name and URL.

*Note:* When entering a URL link, this can only be to a web address. It cannot be to a network share path.
Remove or Rename a Link

To remove a link or change the name that shows in the menu, click the Quick Links heading or icon in the SEP menu to open the My Quick Links page.

In the Manage Current Links section, you can change where the link displays, edit the link name or delete the link. For online links, you can also edit the URL.

<table>
<thead>
<tr>
<th>Manage Current Links</th>
</tr>
</thead>
<tbody>
<tr>
<td>📦 Widget Project Summary</td>
</tr>
<tr>
<td>🔄 Widget Design FMEAs</td>
</tr>
<tr>
<td>🌐 Acme Intranet</td>
</tr>
</tbody>
</table>

SEP User Preferences

The User Preferences page in the Synthesis Enterprise Portal (SEP) allows you to manage your own personal preferences for the website.

Click your name in the top-right corner of the website to open the page.

![Joe Reliability SEP Admin]

Interface Language

Use the drop-down list to choose any of the languages that are available for ReliaSoft desktop applications.

This will update the interface labels, but the data and configurable settings that have been entered by users will remain in the original language. For example, this includes (but is not limited to):

- Names, descriptions, identifiers and remarks that are entered by users
- Action property labels that are configurable within each project
Chapter 24: Synthesis Enterprise Portal

- Published analysis summaries and reports
- System hierarchies and FMEA data

**First Active Project**
This setting determines which project will be displayed first for SEP features that show information from a particular project (e.g., project plan, project summary or creating a new action). You can choose:

- The last project used in any ReliaSoft application
- The last project set/used in the SEP web interface

You can use the **Change Project** button and "My Projects" feature at any time to change the project that is currently active in SEP.

**Actions on Home Page**
This setting allows you to choose which of the actions that may be relevant to you will be shown in the "My Actions" panel on the home page. (Note that if you’re also using ReliaSoft desktop applications, your preferences for the Actions page of My Portal will be managed separately.)

- **I need to review/approve**
  - You are assigned in the **Reviewer** field.

- **I am responsible for**
  - You are assigned in the **Person Responsible** field.

- **I am a team member in**
  - You belong to the team assigned in the **Team** field.

- **I am monitoring**
  - You are assigned in the Action Monitors window, or you have personally subscribed to “watch” the action.

- **Other actions I created**
  - You are listed in the **Created By** field and none of the other roles apply.

**Receive automated alerts**
These are the same options that you can set from the User Login and Contact Information window in a ReliaSoft desktop application. (See [Watches and Alerts](http://predict.reliasoft.com).)
Note that alerts via e-mail and SMS text are available only if a valid SMTP server has been defined for the database and your user account has an e-mail address/SMS contact defined. (See Enable Alerts via E-mail or SMS.)

**Number of Decimals for Metrics**
This preference determines how many decimal places will be used in the metric element on SEP web pages. If you are also using ReliaSoft desktop applications, this may be different than your preference in the Application Setup (File > Application Setup).

![Reliability Graph](image)

**'Open' Buttons**
When you view published analysis summaries and FMEAs in SEP, the Open buttons make it easy to open the full analysis in a relevant desktop application. New in Version 2018, if the Remote ReliaSoft feature is enabled for your implementation, each user can choose whether to launch the applications remotely or locally. (See Configure Remote ReliaSoft.)

- **Remote ReliaSoft** launches applications that are installed and activated on a remote server. *Tip: To reduce the number of prompts, you can configure your web browser to always open *.rdp files with the ReliaSoft Launcher and to remember your login credentials for the remote server.*

- **ReliaSoft Locator Links** generates link files that you can either save or open if the application is installed and activated on your computer.

**SEP and XFRACAS**
XFRACAS is a highly configurable web-based failure reporting, analysis and corrective action system (FRACAS) with integrated capabilities for part tracking, root cause analysis and team-based problem resolution.

If your organization implements both the SEP and XFRACAS websites for the same enterprise repository, the SEP can include links to XFRACAS records that are of interest to the user.
Configure Links Between Websites
In order to enable links between SEP and XFRACAS, a user with administrative permissions in XFRACAS must specify the paths that will be used in URLs for each website. (See Implementing an SEP Website.)

When these preferences are set, SEP's menu will include a link to XFRACAS, and XFRACAS's ribbon will include an icon for SEP.

XFRACAS Reports and Charts
The watch feature in XFRACAS provides a quick and convenient way to access the XFRACAS reports and charts that you use most often (e.g., incident count by responsible part, all open incidents for a particular system, etc.).

When the websites are linked, the application will automatically create a watch in SEP for any reports or charts that you choose to watch in XFRACAS. The watches are not synchronized after the original creation. If you later delete the watch in XFRACAS, it will not change the watch in SEP. Likewise, if you later delete or rename the watch in SEP, it will not change the original watch in XFRACAS. (See Dashboards and Reports in SEP.)

XFRACAS Actions
The actions in XFRACAS (called "XFRACAS actions") are managed separately from the actions in ReliaSoft desktop applications and SEP (called "Synthesis actions"). The SEP always shows the Synthesis actions that are relevant to a particular user and project (see Managing Actions in SEP.)

If you also want to see your XFRACAS actions in SEP, choose to show the "XFRACAS Actions" panel in the SEP home page. (See Customizing the SEP Home Page.)

The SEP panel shows the same XFRACAS actions that you have chosen to display under Uncompleted Actions in your XFRACAS portal. (See XFRACAS Portal in the XFRACAS documentation.)

Tip: You can also choose to show Synthesis actions in your XFRACAS Portal, if desired. Open the My Portal Preferences page in XFRACAS and configure the Display My Open Synthesis Actions option.
XFRACAS Incidents
If you want to see XFRACAS incidents in SEP, choose to show the "XFRACAS Incidents" panel in the SEP home page.

The SEP panel shows the same XFRACAS incidents that you have choose to display under Display My Unclosed Incidents in your XFRACAS Portal.

Links from FMEAs
If your organization chooses to associate template parts and failure modes in XFRACAS with items and failure modes in Xfmea/RCM++/RBI, then you can see additional information about that association in SEP. For more information, see Observed Occurrences in XFRACAS.
End User License Agreement

Click Wrap Agreement at time of product installation

BY INSTALLING THIS SOFTWARE OR BY CLICKING THE “I ACCEPT” BUTTON AND ACCEPTING THIS LICENSE IN ACCORDANCE WITH SOFTWARE INSTALLATION AND LICENSE ACCEPTANCE PROCEDURE YOU AGREE TO THE TERMS OF THIS LICENSE WHICH WILL BIND YOU, THE COMPANY ON WHO’S BEHALF YOU ARE ENTERING INTO THIS LICENSE AGREEMENT, AND ITS EMPLOYEES, AS APPLICABLE.

THIS LICENSE AGREEMENT IS A LEGAL AGREEMENT BETWEEN HBM UNITED KINGDOM LTD A COMPANY INCORPORATED IN UNITED KINGDOM WHOSE REGISTERED NUMBER IS 1589921 AND WHOSE REGISTERED OFFICE IS AT TECHNOLOGY CENTRE, ADVANCED MANUFACTURING PARK, BRUNEL WAY, CATCLIFFE, ROTHERHAM S60 5WG (THE ‘LICENSOR’) AND THE END USER LICENSEE OR ITS REPRESENTATIVE/AGENT AUTHORISED TO BIND THE END USER LICENSEE (‘YOU’).

PLEASE READ THIS CAREFULLY BEFORE USING THE SOFTWARE PRODUCTS

A: BACKGROUND

THIS LICENSE AGREEMENT SHALL BE BETWEEN YOU AND THE LICENSOR REGARDLESS OF WHETHER YOU HAVE PURCHASED THE SOFTWARE PRODUCTS DIRECTLY FROM THE LICENSOR OR AN AUTHORIZED RESELLER AS SET OUT BELOW.

THE LICENSOR APPOINTS EXPERIENCED PROVIDERS OF SOFTWARE RESALE SERVICES WHO DISTRIBUTE THE SOFTWARE PRODUCTS TO END USERS (‘AUTHORISED RESELLER’). IF YOU HAVE PURCHASED THE SOFTWARE PRODUCTS AND ANY ASSOCIATED SUPPORT AND MAINTENANCE SERVICES FROM AN AUTHORISED RESELLER, SUCH PRODUCTS AND SERVICES WILL BE PROVIDED DIRECTLY TO YOU BY THE RELEVANT AUTHORISED RESELLER AND ALL PAYMENTS SHALL BE MADE TO THE AUTHORISED RESELLER ON THE AUTHORISED RESELLER’S TERMS AND PRICES.

IF YOU HAVE PURCHASED THE SOFTWARE PRODUCT AND SUPPORT AND MAINTENANCE SERVICES DIRECTLY FROM THE LICENSOR, SUCH SUPPORT AND MAINTENANCE SERVICES WILL BE DEALT WITH IN A SEPARATE AGREEMENT BETWEEN YOU AND THE LICENSOR AND ALL PAYMENTS WILL BE MADE TO THE LICENSOR AND GOVERNED BY THE LICENSOR’S TERMS OF SALE.

B: PROPERTY OF LICENSOR

THE LICENSOR, OR, WHERE APPLICABLE, THE RELEVANT MEMBER OF THE LICENSOR’S CORPORATE GROUP, IS THE ENTIRE LEGAL AND BENEFICIAL OWNER OF CERTAIN SOFTWARE PRODUCT(S) (‘THE SOFTWARE PRODUCT’) AS SET OUT IN THE QUOTATION OF INFORMATION, WHICH SHALL ALSO INCLUDE YOUR LICENSE KEY, SENT TO YOU BY EMAIL EITHER BY THE LICENSOR OR, IF YOU HAVE PURCHASED THE SOFTWARE PRODUCTS FROM AN AUTHORISED RESELLER, BY THE AUTHORISED RESELLER (‘QUOTATION’). THE LICENSOR IS WILLING TO GRANT YOU A LICENSE TO USE THE SOFTWARE PRODUCT ONLY IF YOU ACCEPT ALL THE TERMS AND CONDITIONS SET OUT BELOW.

C: LICENSE TO BE GRANTED

THE LICENSOR IS PROPOSING TO GRANT YOU ONE OF THE FOUR FORMS OF LICENSE IN RESPECT OF THE SOFTWARE PRODUCT. DETAILS OF EACH FORM OF LICENSE ARE SET OUT IN CLAUSES 2.1 AND 3 BELOW. THE FORM OF LICENSE THAT IS PROPOSED TO BE

D: LICENSE ACCEPTANCE PROCEDURE

BY CLICKING ON THE ACCEPTANCE BUTTON WHICH FOLLOWS THIS LICENSE AGREEMENT (MARKED 'DO YOU ACCEPT THESE TERMS AND CONDITIONS?'), YOU INDICATE ACCEPTANCE OF THIS LICENSE AGREEMENT AND THE LIMITED WARRANTY AND LIMITATION OF LIABILITY SET OUT IN THIS LICENSE AGREEMENT. SUCH ACCEPTANCE IS ON YOUR OWN BEHALF, IF YOU ARE AN INDIVIDUAL AND ON BEHALF OF ANY CORPORATE ENTITY WHICH EMPLOYS YOU OR WHICH YOU REPRESENT ('CORPORATE LICENSEE') IN ENTERING INTO THIS LICENSE AND YOU WARRANT THAT YOU HAVE THE NECESSARY AUTHORITY TO BIND THE CORPORATE ENTITY IN THIS RESPECT OR THAT THE AUTHORISED REPRESENTATIVES OF THE CORPORATE ENTITY ARE AWARE OF YOUR ACCEPTANCE OF THIS AGREEMENT ON ITS BEHALF. IN THIS LICENSE AGREEMENT, ‘YOU’ REFERS TO THE LICENSEE, ANY SUCH CORPORATE LICENSEE, OR BOTH, AS A COMMON SENSE INTERPRETATION OF THE RELEVANT SECTION DICTATES.

E: LICENSE REJECTION PROCEDURE

IF YOU DO NOT ACCEPT THESE TERMS AND CONDITIONS, YOU SHOULD CLICK ON THE “I DO NOT ACCEPT” BUTTON, DELETE THE SOFTWARE PRODUCTS FROM YOUR COMPUTER AND PROMPTLY (AND IN ANY EVENT, WITHIN 14 DAYS OF RECEIPT) RETURN TO THE RESELLER (A) ANY MEDIA; AND (B) ANY OTHER ITEMS PROVIDED, THAT ARE PART OF THIS PRODUCT.

F: OTHER AGREEMENTS

IF THE LICENSOR HAS EXPRESSLY AGREED WITH YOU IN WRITING THAT YOUR USE OF THE SOFTWARE PRODUCTS IS GOVERNED BY A PRIOR EXECUTED LICENSE AGREEMENT WITH THE LICENSOR, SUCH AGREEMENT SHALL APPLY INSTEAD OF THE FOLLOWING TERMS AND CONDITIONS TO THE EXTENT THAT THEY CONFLICT.

YOU SHOULD PRINT A COPY OF THIS LICENSE AGREEMENT FOR FUTURE REFERENCE.

LICENSE AGREEMENT

1. Ownership of Software Products and Copies

1.1 The Software Products and any printed materials or electronic documentation accompanying the Software Products (‘Documentation’) are copyrighted works of authorship, and are also protected under applicable database laws. The Licensor, or, where applicable, the relevant member of the Licensor’s corporate group, retains ownership of the Software Products and all subsequent copies of the Software Products, regardless of the form in which the copies may exist. This License Agreement is not a sale of the original Software Products or any copies.

2. Commercial License

2.1 In consideration of you agreeing to abide by the terms of this License Agreement and payment of the applicable license fees either to the Licensor or, if you have purchased the Software Products from an Authorised Reseller, to the Authorised Reseller (as specified in the Quotation), the Licensor hereby grants to you a personal, non-exclusive, and (unless expressly agreed otherwise by the Licensor in accordance with
Clause 5.1: A non-transferable license to use the Software Products and the Documentation on the terms of this License Agreement. The license shall take one of the following forms, and shall be set out in the Quotation:

(a) **Annual License:**

   (i) **Duration** – this License shall continue for a period of 12 months (‘Initial Period’) from the date of delivery of the Quotation (‘the Delivery Date’) and, provided that you have paid all applicable renewal fees, from year to year thereafter unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

   (ii) **Termination** – you must give the Licensor 90 day’s written notice prior to the anniversary of the Delivery Date, such notice not to expire before such anniversary date.

(b) **Paid Up License:**

   (i) **Duration** – this License shall continue for a period of 25 years from the Delivery Date unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

   (ii) **Conversion** – this License may be converted to a CDS (this may include CRS and CDRS which are specific variations of CDS and collectively known as CDS) License, upon application to either the Licensor or the Authorised Reseller (if you have purchased the Software Products from an Authorised Reseller), and payment of an additional fee to the Licensor or the Authorised Reseller (as applicable), which shall be additional to the fees paid or payable in respect of any maintenance and support services provided by either the Licensor or the Authorised Reseller (if you have purchased the Software Products from an Authorised Reseller). You may reverse this conversion to the same terms as agreed in the Paid Up License at the anniversary of the conversion by giving the Licensor 90 day’s written notice prior to the anniversary of the Delivery Date, such notice not to expire before the anniversary of the Delivery Date.

(c) **CDS/CRS/CDRS License:**

   (i) **Access** – subject to the terms and conditions of this License Agreement, you may access any of the Software Products in the Quotation at any one time and in any combination up to the number of subscriptions granting you access to the Software Products for simultaneous use by you and purchased by you pursuant to this Agreement (‘Access Credits’). In the event the number of Access Credits reaches the number of Access Credits duly paid for by you (‘Access Limit’), you may add additional Access Credits (or, alternatively, at any time during the Term) which shall be charged in accordance with either the Licensor’s prices or the Authorised Reseller’s prices (if you have purchased the Software Products from an Authorised Reseller). Such increase in Access Credits shall apply to the following 12 month period, unless you give the Licensor or the Authorised Reseller (as applicable) written notice at least 90 days in advance of the expiry of the Initial Period, that you do not wish to sustain such increase in Access Credits. You may opt to reduce the number of Access Credits with 90 days written notice in advance of the 12 month period following from the anniversary of the Delivery Date, provided that the total number of Access Credits does not fall below the minimum threshold set by the Licensor or the Authorised Reseller (as applicable) or below the initial number of Access Credits calculated at the time of conversion of any Paid Up License.

   (ii) **Duration** – this License shall continue for the Initial Period and, provided that you have paid for the applicable Access Credits, from year to year thereafter unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

   (iii) **Reporting** – in order to serve our customers better, the Licensor needs to be able to understand how its customers use the CDS system. As a condition of your continued access to the system, you are asked to provide to the Licensor on a quarterly basis, the CDS log file. You will be provided with easy-to-follow instructions on how to do this.
(iv) Termination – you must give the Licensor 90 days written notice in advance of the expiry of the Initial Period of your intention to discontinue the CDS License, such notice not to expire before the anniversary of the Delivery Date, and you must have submitted all reports required of you in clause 2.1(c)(iii) above. Failure to provide such notice and reports will mean that the license shall automatically continue on the same terms until terminated in accordance with this clause.

2.2 As an end user licensee of the Software Products, you may, subject to the following conditions and any conditions specified in the Quotation:

(a) use and copy the Software Products only for use on any computer system that is detailed in the release notes of the respective Software Product and which is licensed, leased and/or controlled by you (the Corporate Licensee) or any member of your corporate group, which expression includes the Corporate Licensee's majority-owned subsidiaries, any parent company having a majority-owned interest in the Corporate Licensee, and such parent's majority-owned subsidiaries;

(b) load the Software Products into and use it only on computers at the locations specified in the Quotation and which are under your control;

(c) copy the Software Products only for back-up and archival purposes and make up to three copies of the Documentation, provided that the original and each copy is kept in your possession and that your installation and use of the Software Products does not exceed any restrictions contained in the Quotation.

3. Demonstration License

3.1 If the Licensor has provided you with the Software Products free of charge for evaluation purposes, this clause 3 shall apply to your use of the Software Products.

3.2 You may use the Software Product on a computer solely for the purposes of evaluating the Software Product.

3.3 The Software Product is provided to you free of charge and on an “AS IS” basis, without any technical support or warranty of any kind from us including, without limitation, a warranty of satisfactory quality, fitness for purpose and non-infringement.

3.4 This License shall continue for a period of 30 days from the Delivery Date unless terminated in accordance with any provision of clause 10 below or any other applicable clause of this License Agreement or until such License is converted into an Annual License, Paid Up License or CDS License, if earlier.

3.5 As part of the Licensor’s testing and evaluation of the Software Products, you shall share with the Licensor the input and views received and any reports and analysis produced promptly upon receipt of such feedback.

3.6 Clauses 4, 5.1(a), 6.1(b), 6.1(f), 8.1, 8.2, 8.5, 10.1(a) of this License Agreement shall not apply to a Demonstration License.

4. Delivery and Risk

4.1 The Software Products shall consist of one copy of the object code of the Software Products on machine-readable form only, on the disk, dongle or other media on which the Software Product is delivered as described in the Quotation (the “Media”). Risk in the Media shall pass to you on delivery. If any part of the Media shall thereafter be lost, damaged or destroyed, you must contact either the Licensor or the Authorised Reseller from whom you have purchased the Software Products who will arrange for a repair or replacement of such Media at a cost (if any) determined by the Licensor or the Authorised Reseller (as applicable).

5. License Restrictions

5.1 You may not nor permit others to:

(a) transfer the Software Products from one location to another, without the express written consent of the Licensor and provided such transfers do not exceed two in any twelve month period. It will be a condition of the grant of any such consent that the Software Products held on hard drives at the current location must be erased and you must enter into a new license agreement with the Licensor before a
Software Products license key is provided to you. The administration charge (currently US $1,500) will be payable by you in respect of such transfer. This charge is only applicable to end user licensees who do not have a support and maintenance services agreement with the Licensor or Authorised Reseller;

(b) exceed the number of concurrent users specified in the Quotation, if any;

c) sub-license, sell, assign, rent, pledge, lease, transfer or otherwise dispose of the Software Products, on a temporary or permanent basis, without the prior written consent of the Licensor;

(d) translate, reverse engineer, decompile, disassemble, modify or create derivative works based on the Software Products except as permitted by law;

(e) make copies of the Software Products, in whole or part, except for back-up or archival purposes as permitted in this License Agreement;

(f) use any back-up copy of the Software Products for any purpose other than to replace the original copy in the event that it is destroyed or becomes defective;

(g) copy the Documentation (except as provided by this License Agreement);

(h) adapt, modify, delete or translate the Documentation in any way for any purpose whatsoever;

(i) vary, delete or obscure any notices of proprietary rights or any product identification or restrictions on or in the Software Products.

6. Undertakings

6.1 You undertake:

(a) to ensure that, prior to use of the Software Products by your employees or agents, all such parties are notified of this License and the terms of this License Agreement and that any such use as aforesaid is in accordance with the terms of this License Agreement;

(b) to replace the current version of the Software Product with any updated or upgraded version or new release provided by the Licensor or the Authorised Reseller (if applicable) under the terms of this License Agreement immediately on receipt of such version or release;

(c) to use the Software Products only as described in the Documentation and subject to the restrictions as set out in clause 5 (License Restrictions above);

(d) to reproduce and include the Licensor’s copyright notice (or such other party’s copyright notice as specified on the Software Products) on all and any copies of the Software Products, including any partial copies of the Software Products as permitted to be made under the terms of this License Agreement;

(e) to hold all drawings, specifications, data (including object and source codes), Software Products listings and all other information relating to the Software Products confidential and not at any time, during this License or after its expiry, disclose the same, whether directly or indirectly, to any third party without the Licensor’s consent, and

(f) to effect and maintain adequate security measures to safeguard the Software Product from access or use by any unauthorised person and indemnify the Licensor for losses flowing from your failure to do so.

7. Intellectual Property Rights

7.1 You acknowledge that all intellectual property rights in the Software Product and the Documentation throughout the world belong to the Licensor, that rights in the Software Product are licensed (not sold) to you, and that you have no rights in, or to, the Software Product or the Documentation other than the right to use them in accordance with the terms of this License Agreement.

7.2 You acknowledge that you have no right to have access to the Software Product in source code form or in unlocked coding or with comments.
7.3 The integrity of this Software Product is protected by technical protection measures ("TPM") so that the intellectual property rights, including copyright, in the software of the Licensor are not misappropriated. You must not attempt in any way to remove or circumvent any such TPM, nor to apply, manufacture for sale, hire, import, distribute, sell, nor let, offer, advertise or expose for sale or hire, nor have in your possession for private or commercial purposes, any means whose sole intended purpose is to facilitate the unauthorised removal or circumvention of such TPM.

8. **Limited Warranty**

8.1 Subject to the limitations and exclusions of liability below and providing the Software is used in accordance with the Documentation and on an operating system or computer for which it was designed, the Licensor warrants that (a) the Media on which the Software Products is furnished will be free from material defects under normal use for a period of 90 days from the date of delivery (the “Warranty Period”); and that (b) during the Warranty Period, the Software Product will, when properly used, perform substantially in accordance with the functions described in the Documentation; and (c) that the Documentation correctly describes the operation of the Software Product in all material respects.

8.2 If, within the Warranty Period, you notify the Licensor in writing of any defect or fault in the Software Product in consequence of which it fails to perform substantially in accordance with the Documentation, and such defect or fault does not result from you having amended the Software Product or used it in contravention of the terms of this License Agreement, the Licensor will, at its sole option, i) repair or replace the Software Product, provided that you make available all information that may be necessary to assist the Licensor in resolving the defect or fault, including sufficient information to enable the Licensor to recreate the defect or fault, or ii) terminate this License Agreement immediately by notice in writing to you and the Licensor will refund or if the Software Products have been purchased from an Authorised Reseller will procure that the Authorised Reseller shall refund; any of the fees paid as at the date of termination (less a reasonable sum in respect of your use of the Software Product to the date of termination) on return of the Software Product and all copies thereof. The Licensor’s obligation under this clause 8.2 is subject to your compliance with clause 6.1(b).

8.3 You acknowledge that the Software Product has not been developed to meet your individual requirements and that it is therefore your responsibility to ensure that the facilities and functions of the Software Product as described in the Documentation meet your requirements.

8.4 You acknowledge that the Software Product may not be free of bugs or errors and you agree that the existence of any minor errors shall not constitute a breach of this License Agreement.

8.5 The Licensor shall not be liable under the said warranty above if the Software Product fails to operate in accordance with the said warranty as a result of any modification, variation or addition to the Software Products not performed by the Licensor or caused by any abuse, corruption or incorrect use of the Software Products, including use of the Software Products with equipment or other software which is incompatible.

8.6 All other conditions, warranties or other terms which might have effect or be implied or incorporated into this License Agreement or any collateral contract, whether by statute, common law or otherwise, are hereby excluded, including, without limitation, the implied conditions, warranties or other terms as to satisfactory quality, fitness for purpose or the use of reasonable skill and care.

9. **Exclusion of Liability**

9.1 Nothing in this License Agreement shall limit or exclude the liability of either party for death or personal injury resulting from negligence, for fraud or for fraudulent misrepresentation.

9.2 Subject to clause 9.1, the Licensor shall have no liability for any losses or damages which may be suffered by you (or any person claiming under or through you), whether the same are suffered directly or indirectly or are immediate or consequential, and whether the same arise in contract, tort (including negligence) or otherwise howsoever, which fall within any of the following:

(a) loss of income;

(b) loss of business profits or contracts;
(c) business interruption;
(d) loss of the use of money or anticipated savings;
(e) loss of information;
(f) loss of opportunity, goodwill or reputation;
(g) loss of, damage to or corruption of data; or
(h) any indirect or consequential loss or damage of any kind howsoever arising and whether caused by tort
(including negligence), breach of contract or otherwise;

provided that this clause 9.2 shall not prevent claims for loss of or damage to your tangible property that fall
within the terms of clause 8 or a claim for a refund of the license fees paid to the Licensor or the Authorised
Reseller (as applicable) for the license of the Software Products.

9.3 Subject to clause 9.1 and clause 9.2, the Licensor's maximum aggregate liability under or in connection with
this License Agreement, or any collateral contract, whether in contract, tort (including negligence) or
otherwise, shall be limited to a sum equal to the fees paid by you to the Licensor or the Authorised Reseller
(as applicable) for the license of the Software Products.

9.4 Subject to clause 9.1, clause 9.2 and clause 9.3, the Licensor's liability for infringement of third party
intellectual property rights shall be limited to breaches of third party rights subsisting in the UK and USA.

9.5 This License Agreement sets out the full extent of the Licensor's obligations and liabilities in respect of the
supply of the Software Products and Documentation. In particular, there are no conditions, warranties,
representations or other terms, express or implied, that are binding on the Licensor except as specifically
stated in this License Agreement. Any condition, warranty, representation or other term concerning the
supply of the Software Products and Documentation which might otherwise be implied into, or incorporated
in, this License Agreement, or any collateral contract, whether by statute, common law or otherwise, is
hereby excluded to the fullest extent permitted by law.

10. Term and Termination

10.1 This License Agreement is effective for the period referred to clause 2.1 or until otherwise terminated in
accordance with that clause. The Licensor may terminate this License Agreement immediately by written
notice to you if:

(a) save in respect of a Paid Up License, if you purchase the Software Products directly from the Licensor,
you fail to pay any renewal or other fees due by you to the Licensor in respect of this License
Agreement;

(b) you fail to comply with any provisions of this License Agreement;

(c) you commit a material or persistent breach of this License Agreement which you fail to remedy (if
remediable) within 14 days after the service on you of written notice requiring you to do so; or

(d) a petition for a bankruptcy order to be made against you has been presented to the court; or

(e) where you, as the Corporate Licensee, become insolvent or unable to pay its (the company’s) debts,
enters into liquidation, whether voluntary or compulsory (other than for reasons of bona fide
amalgamation or reconstruction), passes a resolution for its winding-up, has a receiver or administrator
manager, trustee, liquidator or similar officer appointed over the whole or any part of its assets, makes
any composition or arrangement with its creditors or takes or suffers any similar action in consequence
of its debt, or becomes unable to pay its debts or ceases to trade.

10.2 In the event of termination in accordance with clause 10.1 you must immediately pay to the Licensor any
sums due to the Licensor under the License Agreement and (at the Licensor’s sole option) you must return,
destroy or delete all copies of the Software Products from all storage media in your control and, in the case of
destruction, certify to us that you have done so.
11. Export

11.1 You will comply with all applicable laws, rules, and regulations governing export of goods and information, including the laws of the countries in which the Software Products was created. In particular, you will not export or re-export, directly or indirectly, separately or as a part of a system, the Software Products or other information relating thereto to any country for which an export license or other approval is required, without first obtaining such license or other approval.

12. General

12.1 You agree that the Licensor shall have the right, after supplying undertakings as to confidentiality, to audit any computer system on which the Software Products are installed in order to verify compliance with this License Agreement.

12.2 You agree that the Licensor may use your company name in Licensor’s customer lists and other promotional materials describing your company as a customer or user of Licensor’s software or services, as applicable, unless it receives written notice from you objecting to such use.

12.3 This License Agreement, its subject matter or its formation (including non-contractual disputes or claims) shall be governed by and construed in accordance with English law and submitted to the non-exclusive jurisdiction of the English courts.

12.4 This License Agreement constitutes the complete and exclusive statement of the agreement between the Licensor and you with respect to the subject matter of this License and supersedes all proposals, representations, understandings and prior agreements, whether oral or written, and all other communications between us relating to that subject matter except for those expressly referred to in this License Agreement.

12.5 Any clause in this License Agreement that is found to be invalid or unenforceable shall be deemed deleted and the remainder of this License Agreement shall not be affected by that deletion.

12.6 Failure or neglect by either party to exercise any of its rights or remedies under this License Agreement will not be construed as a waiver of that party’s rights nor in any way affect the validity of the whole or part of this License Agreement nor prejudice that party’s right to take subsequent action.

12.7 This License Agreement is personal to you and you may not assign, transfer, sub-contract or otherwise part with this License or any right or obligation under it without the Licensor’s prior written consent.