MPC 2019 User’s Guide

© 1992-2019 HBM United Kingdom Limited ("HBM UK Ltd"), at Technology Centre, Advanced Manufacturing Park, Brunel Way, Catcliffe, Rotherham S60 5WG. HBM UK Ltd is an affiliate of HBM Prenscia Inc. ALL RIGHTS RESERVED.

This license agreement ("License Agreement") sets forth the terms and conditions that govern the distribution and use of the HBM UK Ltd software documentation (the "HBM Software Documentation"), including any and all derivative works. Any unauthorized distribution or use of the HBM Software Documentation is strictly prohibited.

Licensee hereby acknowledges and agrees to the following terms and conditions of this License Agreement for its use of the HBM Software Documentation:

HBM UK Ltd grants the Licensee who accepts and abides by the terms of this License Agreement a non-exclusive, non-transferable, royalty-free, and revocable license to the HBM Software Documentation. Unless otherwise indicated, all HBM Software Documentation are copyrighted and owned by HBM UK Ltd and are the property of HBM UK Ltd. They are licensed to you and for your use only as an individual who has purchased the software ("Licensee"). Notwithstanding this License Agreement, the Licensee shall not have a license to the trademarks, logos, or any other intellectual property of HBM UK Ltd and/or its affiliates or Licensor(s).

Licensee may print a single copy of the HBM Software Documentation for his/her reference. Licensee may reprint the HBM Software Documentation, as needed, if the original printed copy is damaged and/or destroyed.

Except as provided above, no part of the HBM Software Documentation, either text or image, may be used for any purpose other than Licensee’s own personal use and reference as a learning aid. Therefore, the reproduction, modification, creation of derivative works, storage in a retrieval system, or retransmission, in any form or by any means, electronic, mechanical or otherwise, for reasons other than Licensee's personal use, is strictly prohibited.

Certain photos and images in the HBM Software Documentation are used under non-transferable licenses obtained by HBM UK Ltd and/or its affiliates and are owned by its Licensor(s) ("Licensor"). Images depicting photos of actual persons are licensed to HBM UK Ltd and/or its affiliates and the signed model releases for these images are on file with the Licensor(s). HBM UK Ltd makes no copyright claims on these images. All ownership and intellectual property rights to the HBM Software Documentation are reserved by either HBM UK Ltd and/or its affiliates or its Licensor(s).

DISCLAIMER: THE HBM SOFTWARE DOCUMENTATION IS PROVIDED "AS IS" WITHOUT WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO: 1) ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT OF INTELLECTUAL PROPERTY; 2) ANY WARRANTY THAT THE HBM COURSE MATERIALS WILL CONFORM TO SPECIFICATIONS; 3) ANY WARRANTY THAT THE WORK WILL BE ERROR FREE OR VIRUS FREE. IN NO EVENT SHALL HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSOR(S) BE LIABLE FOR ANY DAMAGES, INCLUDING, BUT NOT LIMITED TO, DIRECT, INDIRECT, SPECIAL OR CONSEQUENTIAL DAMAGES, ARISING OUT OF, RESULTING FROM, OR IN ANY WAY CONNECTED WITH THE HBM SOFTWARE DOCUMENTATION, WHETHER OR NOT BASED UPON WARRANTY, CONTRACT, TORT, OR OTHERWISE, WHETHER OR NOT LOSS WAS SUSTAINED FROM, OR AROSE OUT OF THE RESULTS OF, OR USE OF, THE HBM SOFTWARE DOCUMENTATION. LICENSEES AGREE TO WAIVE ANY AND ALL CLAIMS AGAINST HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSOR(S), AND SHALL INDEMNIFY, DEFEND AND HOLD HARMLESS HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSOR(S) FOR ANY AND ALL LIABILITIES, CLAIMS, DEMANDS, DAMAGES, EXPENSES OR LOSSES THAT MAY ARISE FROM THE LICENSEE'S USE OR DISTRIBUTION OF THE HBM SOFTWARE DOCUMENTATION, INCLUDING ANY LIABILITIES OR DAMAGES FROM DERIVATIVE WORKS OR OTHER PRODUCTS BASED ON, OR RESULTING FROM, THE USE THEREOF.

This License Agreement is subject to change without notice and does not represent any commitment on the part of HBM UK Ltd and/or its affiliates to the Licensee, including any commitment to maintain or update the HBM Software Documentation. The names of companies, products, people, characters, and/or data mentioned in the HBM Software Documentation are not intended to represent any real individual, company, product or event, unless otherwise noted. Any rights not expressly granted herein are reserved for HBM UK Ltd.

TRADEMARKS:
ReliaSoft, Synthesis Platform, Weibull++, ALTA, DOE++, RGA, BlockSim, RENO, Lambda Predict, XFMEA, RCM++ and XFRACAS are all trademarks of HBM Prenscia Inc.

GlyphWorks, VibeSys, DesignLife and the nCode logos are all trademarks of HBM UK Ltd.

Other product names and services identified in the HBM Software Documentation are trademarks belonging to their respective trademark holders, and are used for illustration purposes. Their use in no way conveys an endorsement or other affiliation with HBM UK Ltd and/or its affiliates.
Table of Contents

Chapter 1: Getting Started .............................................................................................................. 1
  Intro to MPC ................................................................................................................................ 1
  Technical Support ....................................................................................................................... 1
    When Requesting Support ...................................................................................................... 2
  Reliability Consulting ............................................................................................................. 2
  Install and License ....................................................................................................................... 3
    System Requirements ............................................................................................................. 3
    Installation and Licensing ....................................................................................................... 4
    License Manager ..................................................................................................................... 8
    Borrowing Licenses ............................................................................................................... 9

Chapter 2: Repositories and Projects ........................................................................................... 13
  Synthesis Repositories .............................................................................................................. 13
    Database Types ..................................................................................................................... 13
    Standard Repositories ........................................................................................................... 14
    Enterprise Repositories ......................................................................................................... 15
  Projects ..................................................................................................................................... 26
    Creating and Managing Projects ........................................................................................... 26
    Project Properties ................................................................................................................. 28
    Project Owner ....................................................................................................................... 31
    Public, Private and Reference Projects ................................................................................... 32
    Locked and Unlocked Projects .............................................................................................. 34
    Check In and Check Out Projects .......................................................................................... 35
    Manage Projects Window ..................................................................................................... 37
    Recycle Bin ............................................................................................................................ 39
    Security ..................................................................................................................................... 40
Contents

Applying Login Security ......................................................................................................... 40
Planning Your Security Approach ......................................................................................... 41
User Accounts ....................................................................................................................... 47
Managing Security Groups ....................................................................................................... 54
Associating Security Groups with Active Directory .............................................................. 63
Setting Item Permissions ...................................................................................................... 64
Status Indicators ................................................................................................................... 66
Reset "In Use" Flags .............................................................................................................. 68
Repository Logins .................................................................................................................. 68
Repository Settings ................................................................................................................ 69
E-mail Settings Page .............................................................................................................. 69
Other Settings Page .............................................................................................................. 70
Unit Settings .......................................................................................................................... 70
Default Name Formats .......................................................................................................... 72
Project Planning Resources ................................................................................................... 74
Working Days/Holidays ......................................................................................................... 75
XFRACAS Connection ............................................................................................................ 76
Managing and Restoring Data ............................................................................................... 77
Enterprise Database Maintenance ....................................................................................... 77
Standard Database Maintenance ......................................................................................... 78
Restore Points ....................................................................................................................... 80
Chapter 3: Desktop Application Interfaces ............................................................................... 83
Ribbon and Backstage View .................................................................................................. 83
Project Manager and My Portal ............................................................................................. 83
Status Bar .............................................................................................................................. 84
Show, Tile, Dock and Pin Panels ........................................................................................... 84
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show or Hide</td>
<td>84</td>
</tr>
<tr>
<td>Tile or View One Page at a Time</td>
<td>84</td>
</tr>
<tr>
<td>Dock or Float</td>
<td>86</td>
</tr>
<tr>
<td>Pinned or Unpinned</td>
<td>88</td>
</tr>
<tr>
<td>Project Manager</td>
<td>89</td>
</tr>
<tr>
<td>Opening a Project</td>
<td>89</td>
</tr>
<tr>
<td>Filtering the List of Projects</td>
<td>89</td>
</tr>
<tr>
<td>Searching for a Particular Project</td>
<td>90</td>
</tr>
<tr>
<td>Current Project Explorer</td>
<td>90</td>
</tr>
<tr>
<td>Working with Multiple Projects</td>
<td>92</td>
</tr>
<tr>
<td>My Portal</td>
<td>93</td>
</tr>
<tr>
<td>Portal Messages</td>
<td>94</td>
</tr>
<tr>
<td>Actions in My Portal</td>
<td>95</td>
</tr>
<tr>
<td>Repository Users List</td>
<td>98</td>
</tr>
<tr>
<td>Project Plan Summary in My Portal</td>
<td>99</td>
</tr>
<tr>
<td>Folios</td>
<td>101</td>
</tr>
<tr>
<td>Data Sheets</td>
<td>101</td>
</tr>
<tr>
<td>Change Units</td>
<td>104</td>
</tr>
<tr>
<td>General Spreadsheets</td>
<td>105</td>
</tr>
<tr>
<td>Control Panels</td>
<td>107</td>
</tr>
<tr>
<td>Switching Between Pages</td>
<td>108</td>
</tr>
<tr>
<td>Hiding or Displaying a Control Panel</td>
<td>108</td>
</tr>
<tr>
<td>Identifiers Page</td>
<td>109</td>
</tr>
<tr>
<td>Publishing Page</td>
<td>109</td>
</tr>
<tr>
<td>Notifications Page</td>
<td>110</td>
</tr>
<tr>
<td>Utilized Resources Page</td>
<td>110</td>
</tr>
</tbody>
</table>
Contents

System Panel and Analysis Panel........................................................................................................ 111
  Change Orientation.................................................................................................................... 111
  Resize a Panel........................................................................................................................ 111
  Hide a Panel .......................................................................................................................... 112
  Expand or Collapse Nodes .................................................................................................... 112
  Selecting Which Columns to Display................................................................................... 113
Printing........................................................................................................................................ 113
  Data Sheets and Diagrams .................................................................................................... 113
Plots.......................................................................................................................................... 114
Synthesis Workbooks .............................................................................................................. 114
Reports Generated in Word or Excel ..................................................................................... 114
Other Features ........................................................................................................................ 114
  Page Setup - Plots and Diagrams ......................................................................................... 114
  Page Setup - Data Sheets ..................................................................................................... 116
  Page Setup - Word Processing Module ............................................................................... 118
Chapter 4: MPC Ribbons ............................................................................................................. 121
  Quick Access Toolbar ........................................................................................................... 121
  Backstage View (File Tab) ..................................................................................................... 122
    Manage Repository ............................................................................................................ 123
    Help Center ......................................................................................................................... 125
  Home Tab ............................................................................................................................... 127
    Clipboard ............................................................................................................................. 127
    Edit ................................................................................................................................... 127
    Working Group ................................................................................................................... 128
    Hierarchy Defaults ............................................................................................................. 128
    Synthesis ............................................................................................................................. 128
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>My Portal Tab</td>
<td>128</td>
</tr>
<tr>
<td>Messages</td>
<td>128</td>
</tr>
<tr>
<td>Actions</td>
<td>128</td>
</tr>
<tr>
<td>Users</td>
<td>129</td>
</tr>
<tr>
<td>Project Tab</td>
<td>129</td>
</tr>
<tr>
<td>Management</td>
<td>129</td>
</tr>
<tr>
<td>E-mail Project</td>
<td>131</td>
</tr>
<tr>
<td>Security</td>
<td>131</td>
</tr>
<tr>
<td>Current Item</td>
<td>132</td>
</tr>
<tr>
<td>Data Management</td>
<td>132</td>
</tr>
<tr>
<td>Reports</td>
<td>133</td>
</tr>
<tr>
<td>View Tab</td>
<td>133</td>
</tr>
<tr>
<td>Refresh</td>
<td>133</td>
</tr>
<tr>
<td>Project Manager</td>
<td>133</td>
</tr>
<tr>
<td>My Portal</td>
<td>134</td>
</tr>
<tr>
<td>Workspace Layout</td>
<td>134</td>
</tr>
<tr>
<td>Expand/Collapse</td>
<td>135</td>
</tr>
<tr>
<td>Zoom</td>
<td>135</td>
</tr>
<tr>
<td>Window</td>
<td>135</td>
</tr>
<tr>
<td>FMRA</td>
<td>136</td>
</tr>
<tr>
<td>Show</td>
<td>136</td>
</tr>
<tr>
<td>Active Tabs</td>
<td>136</td>
</tr>
<tr>
<td>F-F-E-C Tab</td>
<td>137</td>
</tr>
<tr>
<td>L/HIRF Tab</td>
<td>138</td>
</tr>
<tr>
<td>Structures Tab</td>
<td>140</td>
</tr>
<tr>
<td>Systems Tab</td>
<td>142</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Building the System Hierarchy</td>
<td>166</td>
</tr>
<tr>
<td>System Item Properties</td>
<td>169</td>
</tr>
<tr>
<td>MSI Selection Questions</td>
<td>172</td>
</tr>
<tr>
<td>Importing MPC Systems Into XFMEA, RCM++ or RBI</td>
<td>174</td>
</tr>
<tr>
<td>Functional Failure Analysis (F-F-E-C)</td>
<td>175</td>
</tr>
<tr>
<td>Two Views of the F-F-E-C</td>
<td>176</td>
</tr>
<tr>
<td>Functional Failure Analysis Hierarchy View</td>
<td>176</td>
</tr>
<tr>
<td>Functional Failure Analysis Filtered View</td>
<td>177</td>
</tr>
<tr>
<td>F-F-E-C Records</td>
<td>178</td>
</tr>
<tr>
<td>Import F-F-E-C from Excel</td>
<td>182</td>
</tr>
<tr>
<td>Applying the MSG-3 Logic</td>
<td>184</td>
</tr>
<tr>
<td>Failure Effect Categorization (FEC)</td>
<td>184</td>
</tr>
<tr>
<td>Task Selection Questions</td>
<td>185</td>
</tr>
<tr>
<td>Systems and Powerplant Analysis Tasks</td>
<td>187</td>
</tr>
<tr>
<td>Select Existing Tasks Window</td>
<td>190</td>
</tr>
<tr>
<td>Managing Default Responses</td>
<td>191</td>
</tr>
<tr>
<td>Reports</td>
<td>192</td>
</tr>
<tr>
<td>Systems and Powerplant Analysis Reports</td>
<td>192</td>
</tr>
<tr>
<td>Check MSI Analysis</td>
<td>192</td>
</tr>
<tr>
<td>Description and Operation (D&amp;O) Documents</td>
<td>194</td>
</tr>
<tr>
<td>MSI Report Window</td>
<td>195</td>
</tr>
<tr>
<td>Chapter 7: Structural Analysis</td>
<td>197</td>
</tr>
<tr>
<td>Structural Hierarchy</td>
<td>197</td>
</tr>
<tr>
<td>Building the Structural Hierarchy</td>
<td>197</td>
</tr>
<tr>
<td>Structural Item Properties</td>
<td>201</td>
</tr>
<tr>
<td>Performing Structural Analysis</td>
<td>202</td>
</tr>
</tbody>
</table>
Zonal and L/HIRF Analysis Reports ................................................................. 243
Zonal Analysis Reports .................................................................................... 243
L/HIRF Reports ................................................................................................. 244
Select Items ........................................................................................................ 244
Select Report Forms ......................................................................................... 244
Report Settings ................................................................................................. 245
Generate Report ................................................................................................. 246
Chapter 9: Custom Reports ................................................................................. 247
Select Items ....................................................................................................... 247
Selected Report Forms ..................................................................................... 247
Report Settings ................................................................................................. 248
Templates Manager ......................................................................................... 248
Generate Report ................................................................................................. 248
Tips .................................................................................................................... 248
Report Customization/Settings Window .......................................................... 249
   Font Size and Style Considerations ............................................................... 250
MPC Templates Manager .................................................................................. 250
   Active File and Reset Templates ................................................................. 250
   Import Templates ......................................................................................... 251
Custom Report Templates ............................................................................... 251
   Fields .......................................................................................................... 251
   Column Header Customization ..................................................................... 252
   Repeat Column Headers in Word ............................................................... 252
Chapter 10: Query Utility ................................................................................ 255
Specify the Data Source .................................................................................. 255
Specify the Query Criteria .............................................................................. 256

MPC 2019 User's Guide ix
Contents

Synthesis Explorer ................................................................................................................... 278
Save and Apply Views ............................................................................................................... 279
Project and Item Filters ......................................................................................................... 279
Category Panel ....................................................................................................................... 280
Built-in Find/Filter, Configuration and Grouping Tools .......................................................... 280
Synthesis Explorer Dashboards .............................................................................................. 281
Synthesis Explorer Properties ............................................................................................... 283
ReliaSoft Locator Links ........................................................................................................... 285
Creating a Locator Link .......................................................................................................... 285
Posting Locator Links on a Web Page ..................................................................................... 286
Watches and Alerts .................................................................................................................. 286
Enable Alerts via E-mail or SMS ............................................................................................ 287
Subscribing to a Watch ............................................................................................................ 288
Action Alert Preferences ......................................................................................................... 289
Action and Gate Monitors .................................................................................................... 290
What is Your SMS Address? .................................................................................................. 291
History Logs ............................................................................................................................ 292
Activating a Project History Log ............................................................................................ 292
Viewing Record History Logs ............................................................................................... 293
Import, Export and Data Conversion ...................................................................................... 294
Importing from an Existing Repository .................................................................................. 294
Importing from Prior Version Files ....................................................................................... 295
Importing/Exporting Projects ............................................................................................... 308
Importing/Exporting Project Items or Resources .................................................................. 309
Importing from Excel or Delimited Text Files into a Folio ...................................................... 311
Using XML in BlockSim and Lambda Predict .......................................................................... 315
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attachments</td>
<td>316</td>
</tr>
<tr>
<td>Attachment Locations</td>
<td>318</td>
</tr>
<tr>
<td>Select Existing Text Window</td>
<td>320</td>
</tr>
<tr>
<td>Project and Item Filters</td>
<td>321</td>
</tr>
<tr>
<td>Record Filter</td>
<td>321</td>
</tr>
<tr>
<td>Phrase Sets</td>
<td>322</td>
</tr>
<tr>
<td>Field Text</td>
<td>322</td>
</tr>
<tr>
<td>Record Filter Options</td>
<td>323</td>
</tr>
<tr>
<td>Check Spelling</td>
<td>325</td>
</tr>
<tr>
<td>Results Window</td>
<td>326</td>
</tr>
<tr>
<td>Quick Parameter Estimator (QPE)</td>
<td>327</td>
</tr>
<tr>
<td>Quick Parameter Estimator Wizard View</td>
<td>327</td>
</tr>
<tr>
<td>Quick Parameter Estimator Expert View</td>
<td>328</td>
</tr>
<tr>
<td>Quick Parameter Estimator (ALTA)</td>
<td>329</td>
</tr>
<tr>
<td>Chapter 13: Resources</td>
<td>335</td>
</tr>
<tr>
<td>Types of Resources</td>
<td>335</td>
</tr>
<tr>
<td>Used in Multiple Applications</td>
<td>335</td>
</tr>
<tr>
<td>Used Only in BlockSim</td>
<td>337</td>
</tr>
<tr>
<td>Used Only in RENO</td>
<td>337</td>
</tr>
<tr>
<td>Local, Global and Reference Resources</td>
<td>338</td>
</tr>
<tr>
<td>Parent/Child Resource Relationships</td>
<td>339</td>
</tr>
<tr>
<td>Keeping Resources Together</td>
<td>339</td>
</tr>
<tr>
<td>Creating and Selecting Resources</td>
<td>340</td>
</tr>
<tr>
<td>Opening a Resource Wizard</td>
<td>340</td>
</tr>
<tr>
<td>Back Arrow and Main Page</td>
<td>341</td>
</tr>
<tr>
<td>Selecting an Existing Resource</td>
<td>342</td>
</tr>
</tbody>
</table>
Contents

Using Metrics in Project Planner Gates ................................................................. 377
Pushing Metrics from an FMRA ............................................................................. 379
Variables ........................................................................................................... 380
Using Variables to Store Output Values in RENO .............................................. 381
Profiles .............................................................................................................. 384
Creating Profiles Manually (All Types) ............................................................... 385
Importing Data from nCode GlyphWorks to Create Stress Profiles ................. 387
Maintenance Groups ......................................................................................... 388
Maintenance Group Manager ............................................................................ 389
Mirror Groups ................................................................................................... 391
Task Packages .................................................................................................... 391
Actions .............................................................................................................. 393
Actions as Resources ......................................................................................... 393
Configurable Settings ......................................................................................... 394
Show/Hide Properties for Individual Records .................................................. 394
Priority ............................................................................................................ 394
Action Status and Review Status ....................................................................... 395
E-mail and Alerts ............................................................................................... 395
Add to Outlook Calendar ................................................................................... 396
Person Responsible and Resources .................................................................. 396
Action Timeline and Status ............................................................................... 397
Costs and Man Hours ......................................................................................... 398
Action Status Updates ....................................................................................... 400
Review and Approve Actions ........................................................................... 401
Configurable Settings for Actions and Controls ............................................... 402
Actions Explorer ............................................................................................... 403

http://mpc.reliasoft.com
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controls</td>
<td>405</td>
</tr>
<tr>
<td>Configurable Settings</td>
<td>406</td>
</tr>
<tr>
<td>Resource Manager</td>
<td>406</td>
</tr>
<tr>
<td>Resource Filter</td>
<td>407</td>
</tr>
<tr>
<td>Built-in Find/Filter, Configuration and Grouping Tools</td>
<td>407</td>
</tr>
<tr>
<td>Creating, Viewing, Editing and Deleting Resources</td>
<td>407</td>
</tr>
<tr>
<td>Tracing Where Resources Are Used</td>
<td>408</td>
</tr>
<tr>
<td>Local and Global and Reference Resources</td>
<td>408</td>
</tr>
<tr>
<td>Exporting Information from the Resource Manager</td>
<td>409</td>
</tr>
<tr>
<td>Finding and Filtering Records</td>
<td>409</td>
</tr>
<tr>
<td>Configuring Columns</td>
<td>413</td>
</tr>
<tr>
<td>Grouping Panel</td>
<td>415</td>
</tr>
<tr>
<td>Removing Unused and Duplicate Resources</td>
<td>416</td>
</tr>
<tr>
<td>Select Resource Window</td>
<td>417</td>
</tr>
<tr>
<td>Trace Usage</td>
<td>418</td>
</tr>
<tr>
<td>Dependency Viewer</td>
<td>418</td>
</tr>
<tr>
<td>Dependency Viewer - Diagram View</td>
<td>420</td>
</tr>
<tr>
<td>Batch Properties Editor</td>
<td>423</td>
</tr>
<tr>
<td>Spreadsheet Editor</td>
<td>425</td>
</tr>
<tr>
<td>Exporting Information from the Batch Properties Editor</td>
<td>425</td>
</tr>
<tr>
<td>Chapter 14: Project Planner</td>
<td>427</td>
</tr>
<tr>
<td>Creating a Project Plan</td>
<td>427</td>
</tr>
<tr>
<td>Importing or Starting Again from a Blank Plan</td>
<td>427</td>
</tr>
<tr>
<td>Project Plan Hierarchy</td>
<td>428</td>
</tr>
<tr>
<td>Project Planner Columns</td>
<td>429</td>
</tr>
<tr>
<td>Project Planner Timelines</td>
<td>430</td>
</tr>
</tbody>
</table>
## Contents

Planned Dates ..................................................................................................................... 430  
Actual Dates ........................................................................................................................ 431  
Expected Dates ................................................................................................................... 431  
Project Planner Gates ............................................................................................................. 432  
Gate Properties ................................................................................................................... 432  
Gate Status .......................................................................................................................... 433  
Actions in Project Plans ......................................................................................................... 433  
Adding Actions to the Plan ................................................................................................. 434  
Project Plan Summary Panel .............................................................................................. 434  
Check Utilization ................................................................................................................ 437  
Project Planner Gantt View .................................................................................................. 438  
Project Planner Plot View .................................................................................................... 439  
Set Colors .......................................................................................................................... 440  
Project Planner Dashboards .............................................................................................. 441  
  Data Source Drop-Down List ........................................................................................... 441  
  Examples for Different Field Types .................................................................................. 442  
Project Planner Ribbon ....................................................................................................... 444  
  Project Planner Tab .......................................................................................................... 444  
  View Tab ......................................................................................................................... 447  
Chapter 15: ReliaSoft Plot Utilities ...................................................................................... 449  
  Basic Plot Features ......................................................................................................... 449  
  Redraw Plots .................................................................................................................. 449  
  Identify a Plot’s Source Analysis ...................................................................................... 450  
  Show or Hide Plot Items ................................................................................................. 450  
  Scaling .............................................................................................................................. 450  
  Zoom ............................................................................................................................... 451
Contents

Aspect Ratio ........................................................................................................................ 451
Show Coordinates ............................................................................................................... 452
Add Custom Labels .............................................................................................................. 453
Move Plot Items .................................................................................................................. 453
Export or Copy Plot Graphics .............................................................................................. 453
Export or Copy Plot Data ..................................................................................................... 454
Setting Confidence Bounds ..................................................................................................... 454
Setting Target Markers ........................................................................................................... 456
Plot Setup ................................................................................................................................ 457
Importing and Exporting Plot Settings ................................................................................ 457
Plot Elements ...................................................................................................................... 457
Plot Setup: Plot Titles Page ................................................................................................. 458
Plot Setup: Axis Titles/Labels Page ..................................................................................... 459
Plot Setup: Plot Labels Page ................................................................................................ 460
Plot Setup: Legend Page ..................................................................................................... 462
Plot Setup: Canvas Page ...................................................................................................... 463
Plot Setup: Grid Page .......................................................................................................... 464
Plot Setup: Bars Page .......................................................................................................... 465
Plot Setup: Slices Page ........................................................................................................ 465
Plot Setup: Plot Items Page ................................................................................................. 466
Plot Setup: Offsets Page ...................................................................................................... 467
Plot Setup: Zoom Page ........................................................................................................ 468
Plot Defaults Window ......................................................................................................... 469
Plot Defaults Window: Titles Text Page .............................................................................. 470
Plot Defaults Window: Plot Items Display Page ................................................................. 471
ReliaSoft Draw ......................................................................................................................... 471
Contents

Recalculate Formulas .......................................................................................................... 485
Adding Custom Charts ........................................................................................................ 485
Defining Names ................................................................................................................... 485
Word Processing Module ........................................................................................................ 486
Using the Function Wizard .................................................................................................. 486
Using the Plot Wizard ......................................................................................................... 486
Using Spreadsheet References ........................................................................................... 486
Formulas and Functions .......................................................................................................... 486
Function Wizard - Data Sources .......................................................................................... 486
Function Wizard - Formulas ................................................................................................ 489
Data Entry Tips for Functions .............................................................................................. 490
Returning Confidence Bounds ............................................................................................ 494
Plot Wizard .............................................................................................................................. 495
Select the Plot Type ............................................................................................................ 496
Select the Data Source ........................................................................................................ 496
Insert the Plot Holder .......................................................................................................... 497
Custom Charts ......................................................................................................................... 498
Adding a Chart .................................................................................................................... 498
Changing the Data Displayed on an Axis ............................................................................ 499
Changing the Chart Type and/or Data Set .......................................................................... 499
Applying a Chart Layout and/or Chart Style ....................................................................... 500
Renaming Chart and Axes Titles .......................................................................................... 500
Modifying the Axes and Gridlines ..................................................................................... 501
Defined Names ...................................................................................................................... 501
Syntax Rules for Names ...................................................................................................... 501
Managing Names .................................................................................................................. 502
Contents

Defining Names.......................................................................................................................... 502
Spreadsheet References ........................................................................................................... 504
DOE Analysis Reports ............................................................................................................ 505
  Inserting a DOE Analysis Report ......................................................................................... 506
  Using DOE Report Profiles ............................................................................................... 506
Chapter 17: Synthesis Dashboards ......................................................................................... 509
  Dashboard Viewer ............................................................................................................... 510
  Resizing Panels ................................................................................................................... 510
  Showing Details in Charts and Pies .................................................................................... 511
  Drill Downs and Master Filters ......................................................................................... 511
  Sorting and Filtering Data in a Grid .................................................................................... 511
  Printing or Exporting the Dashboard .................................................................................. 512
  Viewing Drill Downs ............................................................................................................ 512
  Using Master Filters ........................................................................................................... 513
Dashboard Layout Manager .................................................................................................... 514
  Show in Viewer .................................................................................................................. 515
  Layout Properties ............................................................................................................... 515
  Importing Layouts .............................................................................................................. 516
Dashboard Layout Designer .................................................................................................... 516
  Separate Layouts for Each Data Type .............................................................................. 516
  Configuring a Dashboard Item ........................................................................................... 517
  Available Dashboard Items ............................................................................................... 523
  Configuring a Drill Down ................................................................................................... 524
  Filtering ............................................................................................................................... 525
Chapter 18: Synthesis Data Warehouse .................................................................................. 529
  Managing Data Sources ...................................................................................................... 529
## Contents

Built-in Find/Filter, Configuration and Grouping Tools .......................................................... 530

Building the Data Set .............................................................................................................. 530

Extracting Data from XFRACAS ............................................................................................... 531

Data Fields for XFRACAS Data Collections .............................................................................. 533

Transferring from the SDW to an Analysis Folio........................................................................ 536
  Tips for Mapping the Columns............................................................................................... 537

SDW Dashboards..................................................................................................................... 538

Custom Connections in the SDW ............................................................................................ 539
  Connect to an External Database ....................................................................................... 539
  Connection Issues ............................................................................................................... 541
  Connect to XFRACAS Report ............................................................................................... 541

Import to a Static Data Collection............................................................................................ 542

Chapter 19: SEP Web Portal ........................................................................................................ 543

SEP Dashboards....................................................................................................................... 543

Actions and Portal Messages .................................................................................................. 543

Project Summary, Analysis Summaries and Project Plan ....................................................... 543

System Hierarchies and FMEAs .............................................................................................. 543

Metrics (Key Performance Indicators) .................................................................................... 544

Monitored Reports ................................................................................................................. 544

SEP Dashboards....................................................................................................................... 544
  Default Dashboard ............................................................................................................... 544
  Add, Delete, Move or Resize a Tile ..................................................................................... 545
  Tile Settings ......................................................................................................................... 545
  Working with Grid Tile Columns ......................................................................................... 548
  Tiles ..................................................................................................................................... 550

Actions and Messages in SEP ................................................................................................. 563
## Contents

- My Actions Page .................................................................................................................. 563
- Messages Page .................................................................................................................... 564
- Projects in SEP ......................................................................................................................... 565
- Select or Change Projects ................................................................................................... 565
- Publishing to SEP .................................................................................................................... 566
- Data Sheets or Diagrams ..................................................................................................... 567
- Synthesis Workbooks .......................................................................................................... 568
- Prediction Reports and Plots .............................................................................................. 568
- XFMEA/RCM++/RBI Reports ............................................................................................... 569
- FMEAs in SEP ........................................................................................................................... 570
- Viewing FMEAs in SEP ......................................................................................................... 570
- FMEA Stats (Web Summary) ............................................................................................... 572
- FMEA Reports, Dashboards and Queries ............................................................................ 573
- FMEA Web Data Source ...................................................................................................... 575
- FMEA Change Logs .............................................................................................................. 578
- Reports in SEP ......................................................................................................................... 579
- View Desktop Dashboards and Reports ............................................................................. 580
- Watch This Report .............................................................................................................. 580
- XFRACAS .............................................................................................................................. 581
- Quick Links in SEP .................................................................................................................... 581
- Link to a Page in SEP ........................................................................................................... 581
- Link to an External Website ................................................................................................ 581
- Remove or Rename a Link .................................................................................................. 582
- SEP and XFRACAS .................................................................................................................... 583
- XFRACAS Actions and Incidents .......................................................................................... 583
- Field Failure Reports (Observed Occurrences) .................................................................... 584
XFRACAS Reports and Charts ........................................................................................................ 585
Configure SEP ............................................................................................................................ 585
SEP Admin Page ....................................................................................................................... 585
SEP User Preferences .............................................................................................................. 590
Chapter 1: Getting Started

Intro to MPC

ReliaSoft MPC by HBM Prenscia is an MSG-3 compliant maintenance program creator for the aircraft / aerospace industry. The software has been designed to assist MSG-3 working groups to perform Systems and Powerplant Analysis, Structural Analysis, Zonal Analysis and/or L/HIRF Analysis in accordance with the MSG-3: Operator/Manufacturer Scheduled Maintenance Development guidelines.

MPC facilitates the analysis process, provides flexible data management capabilities and offers automated report generation in templates that have been accepted for submission to the aircraft industry maintenance review board. The features that are available on your computer will depend on your license.

- This graphic indicates that a feature is available only for users with an MPC Plus license.
  
  🏷️ MPC Plus Only

This application is also part of the Synthesis Platform, which provides intelligent integration between reliability program activities and tools, while simultaneously facilitating effective information sharing and cooperation between engineering teams of any size. For information about features that are shared by all (or most) of the ReliaSoft desktop applications, see the Repositories and Projects, Desktop Application Interfaces and ReliaSoft Common Tools chapters.

Other ReliaSoft software by HBM Prenscia includes: Weibull++, ALTA, RGA, BlockSim, RENO, Lambda Predict, XFMEA, RCM++, RBI, SEP web portal and XFRACAS.

Technical Support

ReliaSoft reliability software products are renowned for their ease of use and unparalleled after sale support. For users with an active maintenance agreement, we provide technical support for software-related issues via a network of regional offices and partners/distributors throughout the world.

You can request assistance directly from within the software by choosing File > Help > E-mail Support. This creates an e-mail message that is pre-populated with information about your license and operating system, which the technical support representative will need for troubleshooting the issue.
Chapter 1: Getting Started

To get contact details for technical support worldwide, choose File > Help > Contact Technical Support or visit https://support.hbmprenscia.com.

When Requesting Support
When you contact us to request technical support, please be prepared to provide the following information:

- Your phone number and e-mail address.
- The product name and the Compile Release Version number of your application. To determine the Compile Release Version (CRV) of the application on your computer, choose File > Help. The CRV is displayed in the About area. Note that the CRV will also indicate whether you are running the 32-Bit version or the 64-Bit version of the software.
- Your product license key.
  - To determine the license for the application on your computer, you can choose File > Application Setup and click any of the main headings in the Application Setup window.
- The operating system (e.g., Windows 7), RAM and hard disk space on your computer.
- Describe what you were doing when the problem occurred and exactly what happened. Please include the specific wording of any message(s) that appeared.

Note: Technical support representatives are not reliability consultants, and their assistance is limited to technical issues that you may encounter with the software tools. To get assistance with your analysis from a subject matter expert, please contact Reliability Consulting Services. HBM Prenscia also offers a comprehensive selection of training courses that cover both the underlying principles and theory, as well as the applicable software tools. For details, visit https://www.reliasoft.com/services/training-courses.

Reliability Consulting
If your organization does not have sufficient time, expertise or objectivity in-house to accomplish specific reliability goals, turning to our expert reliability consultants can prove to be the most effective and economical solution. Whether you need a quick statistical analysis, a complete assessment of your reliability program plan or something in between, Reliability Consulting Services (RCS) is ready to help.

- Our reliability consulting services team has combined expertise in almost all areas of reliability and quality engineering with experience that spans a broad spectrum of
product types, from micro-electronics and appliances to advanced weapons systems and off-shore oil well drilling equipment.

• Unlike engaging a consultant who works independently, RCS consultants have direct access to all of ReliaSoft global resources, expertise and contacts.

• Our team-based approach to consulting, combined with ReliaSoft global reliability engineering organization, allows us to provide you with reliability consultants who understand your culture and speak your language while ensuring that the appropriate reliability expertise can be applied to each and every project.

• RCS is structured to accommodate requests of any size or complexity, from short telephone consultations to multiple experts at a client’s site for an extended time period.

Please visit https://www.reliasoft.com/services/consulting for more information.

Install and License

System Requirements
In addition to the information below, we provide an automated tool that determines whether your computer and Internet connection meet the requirements for running and activating ReliaSoft desktop applications. It will also determine whether you could install the 64-bit version of these applications, if desired. [Download Requirements and Compatibility Test Tool...]

Operating Systems
32- and 64-bit versions are supported, except where noted. [See our 32-bit vs. 64-bit FAQ...]

• Microsoft Windows® 7 with Service Pack 1, Windows 8, Windows 8.1 or Windows 10.

• Microsoft Windows Server 2008 R2 SP1 (64-bit version) or newer. (Requires a license that specifically allows server installations/deployments.)

Note: Upgrading your operating system after your ReliaSoft software has already been installed can cause issues with the activation. To prevent this, it is recommended to uninstall ReliaSoft 2019 prior to upgrading your operating system and then reinstall it after the upgrade. For other options, and for information about how to handle the "activated license is corrupt" message that may appear if you upgrade your operating system with live activations, please refer to https://www.reliasoft.com/windows10-reactivation.
Minimum Hardware Requirements
- RAM: 2 GB or more
- Hard disk space: 1 GB (minimum) free space available
- Screen resolution: 1024 x 768 or higher

Additional Software Requirements
- .NET Framework 4.6.1
- Microsoft Office (Excel®, Word and Outlook®) 2010 or higher (non-subscription-based) for automated exports, report generation and e-mail/calendar integration.

Enterprise Database Platforms
32- and 64-bit versions are supported.
- SQL Server® 2008 - 2016
- SQL Server Express Edition 2008 - 2016
- Oracle® 10g - 12c

Although the enterprise database platform (Microsoft SQL Server or Oracle) could be installed on the same computer where the ReliaSoft applications reside, most organizations will choose to set up a separate server to host the database. Both the 32-bit and 64-bit versions of the applications will work with either the 32-bit or 64-bit versions of a back-end database/server. The minimum hardware/software requirements for each server hosting the database should be obtained directly from the selected database vendor (i.e., Microsoft or Oracle). In general, we recommend a minimum CPU speed of 2 GHz and 4 GB of RAM.

Installation and Licensing
There are two alternative ways that ReliaSoft desktop applications may be licensed on your computer:
- If you received a license file (*.lic) and/or a license settings file (*.prnrsl), see Locally Hosted Licensing
- If you received only a license key (a 32-digit alphanumeric code), see ReliaSoft-Hosted Licensing

One or both methods can be used on the same computer. For example, if you have your own single-user license for BlockSim and will share your department’s new multi-user (floating) license for Weibull++/ALTA, you will receive a license key for BlockSim and a license settings file for Weibull++/ALTA.
If you will use both types of licensing on the same computer, use the instructions for locally hosted licenses. When you launch any of the applications that aren’t included in your license settings file, the ReliaSoft License Manager will allow you to perform the activation of your ReliaSoft-hosted license(s) using a product license key.

Requirements for All Installations

- Before running the installation program, make sure your computer meets the system requirements for ReliaSoft desktop applications.
- You must be logged in with a user account that has administrative rights.
- It is strongly recommended that you close all other applications during the installation.

Locally Hosted Licensing

If you received a license file (*.lic) or license settings file (*.prnrsl), you will be using locally hosted licensing. This allows you to manage available license seats or CRS units in-house without the requirement to connect to the ReliaSoft external license server.

The first step is for a license administrator to configure your organization’s license server and provide each individual user with the path to the license server/host (e.g., 6220@servername) and, in some cases, a license settings file (*.prnrsl) that specifies which ReliaSoft applications on your computer will use locally hosted licensing. (For detailed instructions, see https://www.reliasoft.com/locally-hosted-licensing.)

Once the license server has been set up, perform the following steps for each client installation. If you have previously connected the client computer to the appropriate license server, you can start at step 4.

1. Open the ReliaSoft ePack and decompress the *.zip archive in the Locally Hosted Licensing Utility folder
2. Install the HBM Prenscia Licensing Administration utility by double-clicking licinst.exe and following the prompts. The utility will start as soon as installation is complete.
3. On the Client tab of the license admin utility, click Set Client License Path and then click Add Network Host or enter the license path directly in the window (use the network host format; e.g., port@serverhostname).

   The client computer will check for available license seats in the specified order (i.e., it will go to the top server listed and if no license seat is available there, it will check the next server down, and so on).

   Note that you can delete a license location by highlighting the line and deleting it.
4. Install the ReliaSoft desktop applications by double-clicking the installation program from the ePack (e.g., ReliaSoft2019.exe) and following the prompts.
5. If you were provided with a *.prnrl file, open the Import/Export License Settings utility by choosing ReliaSoft 2019 > ReliaSoft 2019 License Settings Import-Export (Windows 8 and 10) or ReliaSoft 2019 > Additional Tools > ReliaSoft 2019 License Settings Import-Export (Windows 7) in the Windows Start menu. Follow the on-screen instructions to import the *.prnrl file.

The first time you launch an application, you may be asked to provide your name and basic contact information. This is required to be eligible for technical support.

**Note:** Applications using locally hosted licensing must have an active connection to the license server unless you have borrowed a license. If you see a message that indicates that a license could not be obtained, this could be for a variety of reasons (e.g., you are not connected to the license server, the license server is down or there are no seats or CRS units available for the license). In addition, if you lose connection to the license server while you are using an application, you will see a message warning you to save your work before the application closes.

### ReliaSoft-Hosted Licensing

If you are requesting a demo or have already received a license key (a 32-digit alphanumeric code), you will be using ReliaSoft-hosted licensing.

If your computer has an active Internet connection and your firewall allows the software to access the ReliaSoft secure external license server at https://validate.reliasoft.org, only a few simple steps are required for activation:

1. Install the ReliaSoft desktop applications by double-clicking the installation program from the ePack (e.g., ReliaSoft2019.exe) and following the prompts.

2. The first time you launch an application, the activation wizard will appear. On the first page, select whether you want to activate a license or request a free demo license.

3. On the next page, enter a valid e-mail address to serve as your ReliaSoft ID. This is the e-mail address where you will receive confirmation e-mails from the ReliaSoft License Server. This must be your company e-mail address — not gmail, hotmail, etc.

   - **Name and Contact Info:** If this is the first time that you have registered a ReliaSoft desktop application on this computer with this e-mail address, the next page will request your name and basic contact information.

   - **Demo License:** If you need a demo license, most requests will be addressed immediately during normal business hours; for some locations, please allow up to 2 business days.

4. On the next page, enter the product license key provided to you. *Tip: If you are able to copy the key from a product delivery e-mail, the Paste icon saves time by automatically entering each section into the appropriate input box.*
Chapter 1: Getting Started

- **Confirmation Codes**: If your license type requires a confirmation code, the next page requires you to copy/paste a code that you will receive via e-mail. *Tip: If the e-mail does not appear in your Inbox within a few minutes, check your Junk mail or SPAM folders.*

- **Activate Multiple Applications**: If your license key includes other ReliaSoft desktop applications that have not yet been activated on this computer, the next page gives you the opportunity to activate any or all of them at the same time.

5. When you see the “Your product has been activated” message, click Finish to start using the software.

If the computer does not have an active Internet connection, or if you encounter issues with the firewall, there are other ways to complete the activation. Please visit https://www.reliasoft.com/reliasoft-hosted-licensing for details. And, of course, you can always contact us for assistance (https://support.hbmprenscia.com).

**Uninstalling ReliaSoft 2019**

If you wish to stop using all of the ReliaSoft desktop applications on this computer, you can perform the following steps to uninstall ReliaSoft 2019:

1. Make sure you do not have any ReliaSoft desktop applications currently open.

2. For locally hosted licenses, if you are uninstalling permanently (i.e., if you are not doing this as part of an uninstall/reinstall), open the Import/Export License Settings utility by choosing ReliaSoft 2019 > ReliaSoft 2019 License Settings Import-Export (Windows 8 and 10) or ReliaSoft 2019 > Additional Tools > ReliaSoft 2019 License Settings Import-Export (Windows 7) in the Windows Start menu. Follow the on-screen instructions to delete the license settings file.

3. Open the Windows Control Panel and click Programs and Features (or use the search box in the Windows Start menu to find and select Add or Remove Programs).

4. In the Uninstall or change a program window, double-click ReliaSoft 2019 and follow the prompts.

5. If you have installed the HBM Prenscia Licensing Administration tool, you can follow similar steps to uninstall it.
Tip: If you are using ReliaSoft-hosted licensing (i.e., if you received a license key and activated specific application(s) on your computer), you also have the option to deactivate one or more applications without performing a complete uninstall. For instructions, see https://www.reliasoft.com/deactivating-applications.

License Manager
The License Manager allows you to view and manage license-related details for the ReliaSoft desktop applications that are currently activated on your computer. You can use this interface to:

- View and, for ReliaSoft-hosted licenses, edit the contact information that is on file with us or change the password associated with your ReliaSoft ID. [Learn more...]
- For ReliaSoft-hosted licenses, deactivate the current application (if you don't plan to continue to use it on this computer or for this user). [Learn more...]
- For ReliaSoft-hosted floating licenses, check out or check in a license. [Learn more...]

To open the License Manager, choose File > Help and click the License Manager link in the Licensing section.

You may be prompted to enter the password that was sent via e-mail when you first registered your ReliaSoft ID. This password is required if you want to modify your contact information. For everything else, you can click Cancel to proceed without it. (If you forgot your password, you can request to have the information sent to the e-mail address on file for your registration by clicking E-mail my password to me.)

Contact Information and Password
The Contact Information page displays the name, phone number and other details that are on file with ReliaSoft. For locally hosted licenses, this information is read-only and can only be edited by uninstalling and reinstalling the software. For ReliaSoft-hosted licenses:

- If you need to download the latest information from the license server, click Synchronize.
- If you want to change your password or any of the current contact information, type the new information into the fields on this page and then click Update Information on Server.

Both actions require authentication. If you have not already entered the current password that's associated with your ReliaSoft ID, you will be prompted again to enter it.
Deactivate the Current Application
For ReliaSoft-hosted licenses, if you don't plan to continue to use the current ReliaSoft application on a particular computer (or for a particular user), you can use the License Manager to deactivate it. This does not require authentication; you can proceed with the deactivation even if you have not entered your password.

Click the **Deactivate** button in the current product area on the **Products** page.

<table>
<thead>
<tr>
<th>Product Name</th>
<th>Edition</th>
<th>Type</th>
<th>Expiration Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>BlockSim 9</td>
<td>Multi-threaded</td>
<td>Single User License - Perpetual</td>
<td>None</td>
</tr>
</tbody>
</table>

The application will shut down immediately after you deactivate, so you will be prompted to confirm that you're ready to continue. If you later try to access this application again for this computer/user, you will be prompted to repeat the activation process.

Borrowing Licenses
For certain license types, your computer must be able to connect to a license server to determine whether shared license seats (or, for token-based licenses, the required number of CRS units) are available when you attempt to launch a ReliaSoft application.

If you need to use the application(s) when your computer is not connected to the license server, you can either "**borrow**" or "**check out**" the licenses (depending on the **license type**). This reduces the number of seats (or CRS units) available to other users until the licenses are returned. (For ReliaSoft-hosted licenses, you can also use this feature to make sure a license seat will be available when you need it.)

Borrowing Locally Hosted Licenses
If you have a locally hosted license, you can use the ReliaSoft License Borrowing utility to borrow licenses for selected product(s) for a specified duration.

**IMPORTANT:** If at least one ReliaSoft product with a locally hosted license is borrowed, you will only be able to start the product(s) that are borrowed. All desired products must be borrowed or returned at the same time. Note that in versions prior to 18.0.3, you must also be disconnected from the license server to use the borrowed product(s).

If any of the ReliaSoft applications on your computer use a ReliaSoft-hosted license (i.e., a license key
rather than a license settings file), they will be unaffected by locally hosted license borrowing. For those products, see Checking Out ReliaSoft-Hosted Licenses below.

**Borrow License(s)**

Before attempting to borrow licenses, first make sure that your computer is connected to the license server and shut down all ReliaSoft desktop applications.


2. The window shows all of the ReliaSoft desktop applications on your computer that use locally hosted licensing. Specify the borrow duration and select which product(s) you want to borrow. (Remember that all desired products must be borrowed or returned at the same time.)

3. Click **Borrow Selected Licenses**.

4. Close the window.

You will only be able to use the product(s) that are borrowed. Additionally, for versions prior to 18.0.3, you can use the borrowed products only when the computer is not connected to the license server. If you need to change which products are borrowed, you can reconnect to the license server (if necessary) and repeat the same steps again (this will restart the borrow duration for all selected products). If you need to be able to use other (unborrowed) applications, you can return the licenses as described below.

**What’s Changed?** Starting in version 18.0.3, you can use the products you have borrowed while you are connected to the license server.

**Return License(s)**

Before attempting to return licenses, shut down all ReliaSoft desktop applications and make sure your computer is connected to the license server.

1. Open the ReliaSoft License Borrowing utility.

2. Click **Return All Licenses**.

3. Close the window.

**Note:** Failure to shut down all ReliaSoft desktop applications prior to borrowing or returning licenses may result in unexpected behavior, such as inability to borrow, applications quitting unexpectedly or double use of license credits.
You can borrow licenses only while your license is valid (e.g., if the annual expiration date of your locally hosted license is 2 days from now, you cannot borrow a license for a duration of 3 days). In addition, you cannot borrow licenses during the 24 hours prior to annual license expiration.

**Checking Out ReliaSoft-Hosted Licenses**

If you have a ReliaSoft-hosted floating license, you can use the ReliaSoft [License Manager](https://www.efa.com) to reserve a license.

1. Open the ReliaSoft application.
2. Open the License Manager by choosing *File > Help* and clicking the *License Manager* link in the Licensing section.
3. In the current product area on the *Products* page, click *Check Out* or *Check In*. 


Chapter 2: Repositories and Projects

With integration into the Synthesis Platform, the ReliaSoft desktop applications have transitioned from a standalone document/file format to a multi-user, database-driven approach. This offers enormous potential to integrate reliability program activities and tools, while simultaneously facilitating effective information sharing and cooperation between engineering teams of any size.

The experience of working in a database-driven, multi-user environment will be a bit different than using prior versions of ReliaSoft applications (Version 7 or older) and other document-centered applications such as Microsoft Excel. For example, your organization (or team) will need to choose the most appropriate database type and security, implement shared settings that will effectively facilitate project management, and establish adequate backups and database maintenance to protect against data loss. In addition, individual users must be aware that changes are saved automatically as they work, and become familiar with the features that facilitate simultaneous access by multiple users.

This chapter discusses some of the basic requirements for using Synthesis repositories and projects. For information about other features, see ReliaSoft Common Tools.

Synthesis Repositories

Database Types
ReliaSoft desktop applications offer two types of databases for storing projects and analysis data. The type of database you choose will depend on the requirements of your organization.

- **Standard repositories** (*.rsr19) are basic database files for single- or multi-user environments. Implementation of a database server is not required; however, there are limits on the amount of data and the number of simultaneous users.

- **Enterprise repositories** require implementation and support of Oracle or Microsoft SQL Server, but they are a more robust platform that can store much more analysis information in the same database and support access by many more simultaneous users. ReliaSoft applications are compatible with Microsoft SQL Server 2008 or later and Oracle 10g or later (including the free Express editions of all of these). They can be accessed via an enterprise repository connection file with the extension *.rserp.
Chapter 2: Repositories and Projects

What's Changed? Starting in Version 2019, Synthesis files (*.rsf) can no longer be created but you can still open Synthesis files created in prior versions. Such files will be converted to standard repositories upon opening.

Standard Repositories
A standard repository is a basic database file for single- or multi-user environments. Implementation of a database server is not required; however, there are limits on the amount of data and the number of simultaneous users. (If you prefer to use a more robust Oracle or SQL Server database, see Enterprise Repositories.)

Creating a New Standard Repository
To create a new standard database, choose File > New > Standard Repository.

In the Repository name field, specify the filename for the new *.rsr19 file. The path where the file will be saved is shown below this field; to change the location, click the browse icon in the field.

The following options are available when you create a new standard database:

- **Apply login security** configures the new database to be login secure. You can then select the Open security window upon creation check box if you want to add user accounts as part of the database creation process. Note that you cannot automatically remove security from a database once it has been enabled. However, you can create a new non-secure database and use the Import from existing repository check box to automatically import all of the data from the secure database to the non-secure one.

- **Import from existing repository** imports entire projects and other data from an existing database, after the new database is created.

Opening an Existing Standard Repository
If you have opened the file recently, choose File > Recent and then select the file in the Recent Repositories list.

Otherwise, choose File > Open Repository and then browse for the *.rsr19 file.

If the repository has login security enabled and you are unable to connect, you may be encountering one of the following issues:

- **No access to the repository.** If you have not been given access to the repository, you will see a message stating that your account in the repository is not active or not
assigned to at least one security group. You will need assistance from someone who can create and update user accounts (see Managing User Accounts).

- **Windows authentication failed.** If your Windows login (domain and username) is different from what was specified for your user account, you will see a message to connect using alternative credentials. You will need assistance from someone who can enable the use of alternative credentials for your user account.

### Upgrading a Standard Repository from a Previous Version

If you have a standard repository that was created in a previous version of the software, you can simply open it like any other standard database (File > Open Database). An upgraded copy will be created, with "_V19" appended to the filename. For example, if you open "MyDatabase.rsr10," the Version 2019 database that is created will be called "MyDatabase_V19.rsr19."

It is important to remember that upgrading a standard repository will not automatically upgrade any library or template files that you may have been using in conjunction with that database, as these file types are stored separately. Please refer to the documentation on those files for information on upgrading them.

### Enterprise Repositories

Unlike standard repositories, enterprise repositories require an established database server with Oracle or Microsoft SQL Server. This allows you to store more analysis information in the same repository and support access by many more simultaneous users. ReliaSoft applications are compatible with Microsoft SQL Server 2008 or later and Oracle 10g or later (including the free Express editions of all of these).

To establish a database server, you will need to purchase an appropriate license package from Oracle or Microsoft. The license, as well the IT maintenance and support needed to establish the database server, is separate from the license agreement for ReliaSoft software and must be negotiated directly with Oracle or Microsoft.

As an alternative, you may choose to use the free versions of Oracle or SQL Server if the expected load for the database fits within the limited capabilities of the Express edition (as specified by Oracle/Microsoft). With the free editions, you can establish a functioning enterprise database on your own without making a large investment of time and resources. If your organization's needs grow beyond the capabilities of the Express edition, you can then upgrade to a more robust version with the appropriate IT infrastructure and support.

**Tip:** Although we cannot provide full documentation and support for third-party database platforms, we do provide a limited number of resources as a convenience for users who wish to explore the
Chapter 2: Repositories and Projects

possibilities of an enterprise database implementation. For resources on SQL Server (including instructions for configuring the Express edition), see https://www.reliasoft.com/using-sql-enterprise-databases. For resources on Oracle, see https://www.reliasoft.com/using-oracle-enterprise-databases.

The following topics will be of interest to database administrators:

- Creating a New Enterprise Repository
- SQL Server Logins or Impersonation
- Upgrading an Enterprise Repository from a Previous Version
- ReliaSoft Admin Tool

The following topics will be of interest to all enterprise repository users:

- Creating an Enterprise Repository Connection File (*.rserp)
- Monitoring Connection Speed

Creating a New Enterprise Repository

If your organization already has established a database server with Oracle or Microsoft SQL Server and you have the permissions necessary to create databases on the server, you can create a new enterprise repository by choosing File > Manage Repository > New Enterprise Repository.

Tip: If you need to be able to create an enterprise database without using a ReliaSoft desktop application (i.e., without taking up one of the available license seats), you can access this same feature from the ReliaSoft Admin tool.

You can choose to create the new database in either Oracle or Microsoft SQL Server.

If you choose SQL Server, you will be required to enter:

- **Server Name:** The name of the Microsoft SQL Server implementation where the new database will be created. Note that if you are using SQL Server Express, the server name is usually your login for that computer followed by \SQLEXPRESS (e.g., Username\SQLEXPRESS).

- **Database Name:** The name of the new database that will be created.

- Options:
• **Encrypt communication** secures the connection information between the ReliaSoft application and the enterprise database.

• **Trust server certificate.** Select this option if the server has a self-signed certificate.

If you choose **Oracle**, you will be required to enter:

• **Port, Host** and **Service** identifiers for the Oracle server where the new database will be created.

• The **Schema** of the new Enterprise database.

• The **Password** for the new enterprise database schema. If you are including special characters in the password, you must include quotes around each special character when entering the password.

• The administrative username and password for the Oracle server (entered in the **Admin Information** area).

For either server type, select the **Import from existing repository** check box if you want to import entire projects and other data from an existing database.

Click **OK** to create the database. The database will not open automatically; you must connect to it. (See **Connecting to an Existing Enterprise Repository**.)

---

**Connecting to an Existing Enterprise Repository**

If your organization has already **created an enterprise database** on Oracle or SQL Server and you have an active user account, you can use an enterprise repository connection file (*.rserp) to connect with the database. You can create this file yourself or use a file that has been created by someone else.

**Creating a Connection File**

To create a connection file, choose **File > New > Enterprise Repository Connection File**.

This command creates an enterprise repository connection file (*.rserp) that is stored locally on your computer; the file contains all of the necessary information for connecting to the enterprise database.

Enter a name for the connection file, then choose the database type and version.

• For a SQL Server database:
Chapter 2: Repositories and Projects

- Select **Encrypt communication** if you want to encrypt the connection between the application and the database.

- Select **Trust server certificate** if the server has a self-signed certificate.

- Select **Use impersonation** if you want the connection file to impersonate a Windows user account with a SQL Server login that can be shared by multiple users. This connection file can then be distributed to any user who does not have his/her own individual SQL Server login and is not part of a Microsoft Active Directory® group that has a login. (See [SQL Server Logins or Using Windows Impersonation](https://docs.oracle.com/cd/B19306_01/network.102/b14268/asoconfg.htm#i1007808).)

- For an Oracle database, enter the port, host and service identifiers, the database schema and the password for the enterprise database schema.

- If you are including special characters in the password, you must include quotes around each special character when entering the password.

**Note:** If you want to encrypt the connection for an Oracle implementation, you must set the encryption type to either "requested" or "required" for the Oracle database. For more information, please consult the Oracle documentation (e.g., https://docs.oracle.com/cd/B19306_01/network.102/b14268/asoconfg.htm#i1007808).

**Using an *.rserp File to Connect to an Enterprise Repository**

If you have used the connection file recently, choose **File > Recent** and then select the file in the Recent Repositories list.

Otherwise, choose **File > Open Repository** and then browse for the *.rserp file.

If you are unable to connect to an enterprise repository, you may be encountering any of the following issues:

- **No access to the repository.** If you have not been given access to the repository, you will see a message stating that your account in the repository is not active or not assigned to at least one security group. You will need assistance from someone who can create and update user accounts (see [Managing User Accounts](https://docs.oracle.com/cd/B19306_01/network.102/b14268/asoconfg.htm#i1007808)).

- **Windows authentication failed.** If your Windows login (domain and username) is different from what was specified for your user account, you will see a message to connect using alternative credentials. You will need assistance from someone who can enable the use of alternative credentials for your user account.
• **Cannot connect to the server or login failed.** Server-related issues may occur for several reasons, and you may see various messages pertaining to the situation. Common issues are:
  
  • You do not have a network connection or you may have entered the incorrect database name or server name in the connection file.
  
  • The SQL Server database resides in a different domain than the one you have used to log in to Windows and your network cannot recognize the domain name you have entered. Depending on your network configuration, you may be able to connect using either the "fully qualified domain name" (FQDN) or the IP address for the server.
  
  • In SQL Server databases, a login issue may occur if your username is not associated with a SQL Server Login. (See [SQL Server Logins or Using Windows Impersonation](#).)
  
  • The server is not configured to allow remote connections, has certain firewall settings or is experiencing other issues.

  **Note:** If you get an "error occurred when reading the connection file" message, the connection file may be corrupted or is using old encryption. You can create a new connection file by choosing **File > New > Enterprise Repository Connection File.**

### SQL Server Logins or Using Windows Impersonation
Connecting with a SQL Server database via Windows authentication requires a "SQL Server login" that allows the database platform to recognize the user and gives access to the Synthesis repository. There are three ways that a user account may be recognized by SQL Server:

• **Individual Login:** The user has an individual SQL Server login that is associated directly with his/her Windows username.

• **Group Login:** The user belongs to an Active Directory group that has a SQL Server login shared by all members of the group.

• **Use Impersonation for Connection File:** The user does not have an individual or group login but he/she connects to the database with an enterprise connection file (*.rserp) that impersonates another Windows user account that does have a SQL Server login.

Your organization may choose to use any or all of these methods for your implementation (e.g., some users may have their own individual logins, while other users connect using Windows identity impersonation). This document provides an overview of all three options.
Chapter 2: Repositories and Projects

Option 1: Creating Individual SQL Server Logins
If you choose to create individual SQL Server logins for some or all of the user accounts, you have two options. (For details and instructions on performing these tasks in SQL Server, see https://www.reliasoft.com/using-sql-enterprise-databases.)

1. A database administrator for SQL Server can create SQL Server logins in advance for every potential user and give the logins access to the application database (at least the db_datareader and db_datawriter roles are required). This would be performed directly in SQL Server (not via one of the ReliaSoft applications).

2. A database administrator for SQL Server can grant the appropriate level of database authority for creating SQL Server logins and database roles (e.g., securityadmin or sysadmin) to any user who has the ability to create user accounts in the Synthesis repository. The additional authority would be added directly in SQL Server. Then, when any of these administrative users creates a new user account via the ReliaSoft application, the required SQL Server login can be created and the application database roles can be assigned automatically at the same time.

If you are using the first approach, clear the Create SQL Server login check box that is displayed when you are adding or importing a user account. If you are using the second approach, you must select this check box.
Tip: If the user already has a SQL Server login and access to the application database, it does not matter whether you select or clear the Create SQL Server login check box because the application attempts to create the login only if one does not already exist.

Furthermore, if the user who is creating the user account does not have the necessary level of database authority in SQL Server, the login will not be created even if the check box is selected.

Option 2: Using a Group Login
If the user belongs to an Active Directory group that has a SQL Server login shared by all members of the group and that group has access to the application database, you can clear the Create SQL Server login check box that is displayed when you are adding or importing a user account.
For example, base installations of Microsoft SQL Server Express 2008 include the "Builtin\Users" Active Directory group as a SQL Server login by default. This means all users with a Windows account for that domain will be able to log in to the enterprise database with no need to create individual SQL Server logins in SQL Server Express. However, it will still be necessary to grant access for this group login to the application database (at least the db_datareader and db_datawriter roles are required).

**Option 3: Using Windows Impersonation for the Connection File**

If you choose to have some (or all) users connect to the SQL Server database with a connection file that impersonates a shared Windows user account that has a SQL Server login, you must do the following:

- A Windows network administrator must establish the shared user account on Windows.
- A database administrator for SQL Server must create a SQL Server login for the shared Windows user account and grant this login access to the application database (at least the db_datareader and db_datawriter roles are required).
- A user must create an enterprise repository connection file that impersonates the shared Windows user account:
  1. Choose **File > New** then click **Enterprise Repository Connection File**.
  2. Under **Repository Connection Settings**, select **Microsoft SQL Server (2008 or later)** from the drop-down list and then select the **Use impersonation** check box.
  3. Enter the server and database name for the SQL Server database, then enter the domain, username and password for the shared Windows account that users will need to impersonate.
  4. Click **OK** to create the connection file (*.rserp). It will be stored in the location specified under **Connection File Name**. Note that the default filename will be “SQL_(Server Name)_ (Database Name),” but you can assign any name that fits the process your organization will use for distributing the file to users. (Note that while the window shown next is for Weibull++, the settings are the same for all ReliaSoft applications.)
Once you have created a connection file that impersonates the shared Windows user account, you can distribute the file to any user who needs it. To connect to the repository using this file, the user can:

1. Choose **File > Open Repository** and browse for the connection file.
2. Click **Open** to connect with the repository.

After the first connection, this *.rserp file will be saved in the list of recent repositories, which can be accessed by choosing **File > Recent**.
Chapter 2: Repositories and Projects

**Note:** For the purpose of being recognized by SQL Server and accessing the application database, the user will be impersonating the shared Windows login. For the purpose of performing actions via the ReliaSoft applications, the user’s actions will be governed by his/her own user account in Synthesis. In other words, multiple users can connect with the database using the same enterprise connection file, but their activities within the ReliaSoft applications will be governed by the permissions established in their own individual user accounts, and any changes made to the analysis data will be recorded in the application under their own usernames.

**Enterprise Repository Connection Speed**

If the ReliaSoft desktop application is exhibiting slow performance when you’re connected to an enterprise repository, the issue may be related to your network connection. The MDI status bar displays a connection speed indicator on the lower right side of the window.

The following icons are used to indicate the connection speed. In cases of poor network performance, you will need to request assistance from the IT support group responsible for the server.

- < 30 ms: Good (acceptable performance)
- 30 - 70 ms: OK (may exhibit some delays in operations, opening/closing windows, etc.)
- 70 - 110 ms: Slow (will exhibit some delays in operations, opening/closing windows, etc.)
- 110 - 150 ms: Very slow (will exhibit significant delays in operations, opening/closing windows, etc.)
- > 150 ms: Extremely slow (will result in unacceptable performance and usability)

**Upgrading an Enterprise Repository from a Previous Version**

If you have an existing enterprise database that was created in Version 8 or later of the ReliaSoft applications, you can transfer or convert all of the existing data into a new database that is compatible with the latest version.

All of the same requirements for creating a new enterprise database apply here (e.g., you must have an established database server and the necessary permissions to create a database on the server). In addition, you must be a member of the Admin group in the database to perform the task.
Upgrading an enterprise repository will also upgrade any library files and/or templates that are stored within that database.

**Tip:** If you need to be able to upgrade an enterprise database without using a ReliaSoft desktop application (i.e., without taking up one of the available license seats), you can access this same feature from the [ReliaSoft Admin tool](#).

### Upgrading from Version 9 or Above

It is strongly recommended that you create a backup of the enterprise repository to be upgraded. The upgrade process converts the database itself to the latest version. *This change cannot be undone.*

To upgrade the database, choose File > Manage Repository > Upgrade Enterprise Repository.

In the window, specify the enterprise database that you wish to upgrade. Click OK to start the process.

### Upgrading from Version 8

You do not need to create a backup before upgrading a Version 8 enterprise repository. The upgrade process does not involve a direct conversion of data, but rather copies over all existing data into a new database. This complete switch to a new database is required in order to support the exclusive features in the latest version.

To upgrade the database, open the latest version of the ReliaSoft application and choose File > Manage Repository > Upgrade Version 8 Repository.

Use the left side of the window to specify the Version 8 enterprise database that you wish to upgrade. Use the right side of the window to define the new Version 2019 enterprise database that the existing data will be copied into. Click OK to start the upgrade.

### ReliaSoft Admin Tool

The Synthesis Platform includes an admin tool that allows a database administrator to set up and manage enterprise databases without requiring a software user license or an activated ReliaSoft desktop application.

To use the ReliaSoft Admin tool, your organization must have already established a database server with Oracle or Microsoft SQL Server, and you must have the permissions necessary to create databases on the server.
To access the tool, open the Windows Start menu and choose ReliaSoft 2019 > Additional Tools > ReliaSoft 2019 Admin from the programs list. Alternatively, you can open the Windows Start menu and type ReliaSoft 2019 Admin in the search bar.

The following features from the ReliaSoft desktop applications are available in the admin tool.

- Creating a new enterprise repository
- Upgrading an enterprise repository from a previous version
- Manage user accounts:
  - Adding and editing user accounts
  - Importing users from Active Directory
  - Creating alternative credentials
  - Editing user login and contact info
  - Managing security groups
- Configuring the XFRACAS or SEP applications on a web server. For details, please consult the implementation guides for those web applications.

Projects

In Synthesis repositories, projects serve as a way to keep related analyses together. Each project can contain analyses (e.g., folios, diagrams, plots, FMEAs, etc.), a Project Planner, resources that can be shared between analyses (e.g., models, tasks, actions, etc.) and attachments.

Any project can be opened in any ReliaSoft application; however, application-specific analyses (e.g., folios in Weibull++, diagrams in BlockSim, etc.) are visible only in the application(s) that can edit them.

Creating and Managing Projects

This topic describes how to create and manage the projects that are accessible to you via the project list (View > Project Manager > Show Project Manager). This depends on your permissions in the database and any security that has been defined at the project level.
There are three types of projects: private, public or reference. In addition, a project may be locked or checked out at any given time. Each type of project is displayed under the appropriate heading in the project list:

Tip: The Manage Projects window (Project > Management > Manage Projects) allows you to perform administrative tasks for multiple projects all at once, and to manage the private projects of other users. (See Manage Projects Window.)

Creating a New Project

When you create a new project, you must specify whether it will be public, private or reference. Select or right-click the appropriate heading in the project list and (i.e., Private, Public or Reference), and then choose Project > Management > Create Project.

The selected project type will be displayed at the bottom of the Project Properties window. If desired, you can change the selection before clicking OK to create the project.
Chapter 2: Repositories and Projects

Tip: If you later need to change the project type, select the project and choose Project > Security > [Make Private, Make Public, or Make Reference]. The same commands are also available in the Manage Projects window.

Duplicating Projects
To duplicate an existing project, select it and choose Project > Management > Duplicate Project.

This command will create an exact duplicate of the original project with a name that contains an increment number (e.g., Project_1, Project_2, etc.). Note that duplicate projects do not retain the security settings of the original project.

Deleting Projects
To delete a project, select it and press DELETE or choose Project > Management > Delete Project.

To make sure that your analysis information is not deleted by mistake, you will always be prompted to confirm before proceeding. By default, the project will be moved to the recycle bin, which will give you a chance to recover it later if needed. If you want to permanently delete the project now (no way to undo unless you have a backup or restore point), clear the Send project to recycle bin check box in the confirmation window.

Note: You cannot delete a reference project if any of its resources are in use, including by projects in the recycle bin.

Project Properties
The Project Properties window will be displayed when you create a new project or when you choose Project > Management > Edit Project Properties.

The options available in this window will vary depending on which application you are using and whether the database has login security enabled. For MPC, see MPC's Project Properties (below). For all other ReliaSoft desktop applications, this may include:

- General Tab
• **Security Tab** (available only for public/reference projects in secure databases)

• **Configurable Settings Tab** (only in XFMEA/RCM++/RBI)

In addition, the status bar at the bottom of the window always displays the following information:

**Project Owner**: The user who has been identified as the project owner. In a secure database, the ability to edit the project properties is restricted to the project owner and to users with the relevant "manage all projects" permissions.

**Last Update**: The time and date the project was last changed/updated, and the user who made the change. This considers any change to any of the analysis data in the project (not just the project properties).

**General Tab**
The General tab contains the following options:

• **Name** is the identifier for the project that will appear in the current project explorer and in many other windows and reports throughout the software. This field is required and cannot contain any of the following characters: \ / : " * ? < > |.

• **Description** and **Remarks** can contain more detailed notes or information about the project.

• **Proprietary Label** can contain a copyright or distribution statement, if desired. This label may appear in the footer of some reports generated in XFMEA/RCM++/RBI or MPC.

• **Project Category** allows you to assign a project category that can be used to filter the projects displayed in the project list and in many other windows throughout the software.

In XFMEA/RCM++/RBI, this tab also contains:

• **FMEA Structure** determines how the software will display the effect and cause records in the FMEA hierarchy. This is applicable only in XFMEA/RCM++/RBI. (See Choosing the FMEA Structure in the XFMEA/RCM++/RBI documentation.)

• **Select Profile from Library** displays a list of all profiles that have been defined in the active library. When you choose a profile from the list, all of the configurable settings for the project will be set/reset based on the settings that have been predefined for that profile. If you are editing a project, the current profile is shown in brackets. (In a secure database, the ability to add and edit a profile is available only for users with the "Manage profiles and templates in XFMEA/RCM++/RBI" permission.)
Chapter 2: Repositories and Projects

Security Tab
The Security tab is available only when you are working with a public or reference project in a secure database. For a full discussion on how to use these settings, see Planning Your Security Approach.

For quick access to the Security tab, you can select the project in the project list and choose Project > Security > Project Security.

Configurable Settings Tab
The Configurable Settings tab is available for XFMEA/RCM++/RBI only. It provides access to all of the configurable settings that have been defined for the current project, based on the profile that was selected on the General tab.

This tab allows you to make specific changes that will apply to the current project only. For example, if you are using a predefined profile but want to make a change to the interface style for this particular project only, you could click the Edit icon associated with the Interface Style drop-down list in the Interface Settings area.

It is important to note that any change to the Configurable Settings page will update the settings for the current project, but it will not alter the original profile. If you want the project’s current settings to be available as a new profile in the active library, click the Send Settings to Library button and then type the name and description for the new profile that will be created.

In the Enable Legacy Analyses section, you can choose whether to allow users to create and use DVP&R or DRBFM analyses in the project. These settings are not part of the profile and may be different for each project. (See Design Verification Plans (DVP&Rs) and Design Reviews Based on Failure Mode (DRBFMs) in the XFMEA/RCM++/RBI documentation.)

MPC’s Project Properties
For users of MPC, the interface has been customized to display only the information that is directly relevant for MSG-3 analyses. This includes the Name, Description, Remarks and Project Category. In addition, you will be able to define the following:

- Short Description appears in the header of the Standard report template. It is not applicable for Dassault or Sukhoi reports.
• **Proprietary Label** appears in the footer of the Standard report template. It is not applicable for Dassault or Sukhoi reports.

• **MSG-3 Guidelines** displays a list of the available MSG-3 guidelines that can be used for the systems and powerplant analysis.
  
  • In most cases, the version that you select will not have any impact on the MSG-3 logic displayed in the interface and print-ready reports.
  
  • The only substantive difference occurs when you select MSG-3 Revision 2002.1 because this older version of the guideline uses slightly different titles for two of the maintenance significant item (MSI) questions, and lists the questions in a different order.

• **Model/Equipment/Effectivity** allows you to enter the information that will appear on the title page of the Dassault and Sukhoi templates.

---

**Project Owner**

For each project in a Synthesis repository, one user will be assigned as the *project owner*. By default, the owner will be the user who created the project, but this can be changed when needed.

In a **secure database**, being the project owner means that you have full permissions over the project. This includes the ability to edit the project properties, add/edit/delete project items and resources, lock and unlock, set security settings, create restore points and delete the project. These permissions are always in effect regardless of the project security settings or item permissions that may be in place.

**Changing the Project Owner**

To change the owner, select the project in the project list and choose **Project > Security > Change Owner**.

In a secure database, this is available only for users with the applicable "manage all projects" permissions.

**Identifying the Project Owner**

There are three ways to identify the current owner of a project:

• Use the filters in the **project list** to filter and/or group projects based on the project owner. For example:
Chapter 2: Repositories and Projects

- The Project Properties window (Project > Management > Edit Project Properties) displays the name of the current owner in the status bar at the bottom of the window.

- The Manage Projects window (Project > Management > Manage Projects) displays a list of all projects and their owners in a table format. You can use custom filters to filter, sort and/or group the list based on the project owner.

Public, Private and Reference Projects
In Synthesis repositories, there are three types of projects you can create:

- A public project may be accessible to any user who has access to the database, depending on the security settings that have been implemented.

- A private project can be viewed and edited only by the project owner. The project list shows only your own private projects, while the Manage Projects window provides the
ability to manage all users’ private projects (including delete, lock/unlock or changing the project type).

- A **reference** project is like any regular public project, except that you can share its resources and FMEAs with other projects in the database. This gives you a pool of resources that can be used throughout the database by specified users (based on the security settings for the reference project), while allowing you to maintain fully functional analyses within the reference project itself. (For more information, see Local, Global and Reference Resources, and Linked FMEAs in the XFMEA/RCM++/RBI documentation.)

In the project list, each type of project is displayed under the appropriate heading, as shown in the following example.

![Project List](image)

**Note:** In MPC, the Reference heading will appear only if reference projects already exist in the database (created by another ReliaSoft desktop application). You cannot create a new reference project or convert an existing project into a reference project in MPC.

**Setting the Initial Project Type**

When you create a new project, you must specify whether it will be public, private or reference. Select or right-click the appropriate heading in the project list and (i.e., Private, Public or Reference), and then choose **Project > Management > Create Project**.
Chapter 2: Repositories and Projects

The selected project type will be displayed at the bottom of the Project Properties window. If desired, you can change the selection before clicking OK to create the project.

| Public Project | Private Project | Public Project | Reference Project |

**Changing the Project Type**
To change the project type for one project, select it in the project list and choose **Project > Security** and then one of the following options:

- **Make Private**
- **Make Public**
- **Make Reference**

To change the project type for multiple projects simultaneously, use the **Manage Projects window** instead.

**Locked and Unlocked Projects**
In all Synthesis repositories, a project can be locked to prevent users from editing the data. If a project is locked, it will be moved to the Locked heading in the project list and it cannot be edited by any database user unless it is unlocked again.

In a secure database, locking and unlocking a project are available only if the user a) is the project owner, b) has the "Lock or check out project" permission for the project or c) has the applicable "manage all projects" permissions.

**Locking a Project**
To lock a project, select it in the project list and choose **Project > Security > Lock Project**.

When a project is locked, all database users (including the user who locked the project) will have read-only access to the project. In addition, a locked project cannot be deleted or have its properties and public/private/reference status edited.
Unlocking a Project
To unlock a project, select it in the project list and choose Project > Security > Unlock Project.

Tip: The Manage Projects window allows you to select multiple projects and lock or unlock them all at once.

Check In and Check Out Projects
In all Synthesis repositories, both private and public projects can be checked out to temporarily allow one particular user to work on a project independently for a period of time and/or to work on a computer that is not connected to the network where the shared database resides (e.g., if you need to work on the project while you’re out of the office). When a project is checked out, two things happen:

- An editable copy of the project will be saved into a standard database (*.rsr19) in the specified "Checked Out" folder on your local computer. This database will have the same name as the project.
- The original project will be set to read-only and moved under the Checked Out heading in the project list. This allows other users who would normally be able to access the project to see that it is currently being edited exclusively by one particular user. It also provides read-only access to the latest version of the project at the time it was checked out so those users can query, copy data, etc. while you’re editing the project "offline."

You can then edit the project as needed in the standard database and check the project back in when you’re finished.

IMPORTANT: If the project uses resources or FMEAs from a reference project (e.g., linked FMEAs, models, URDs) the links won’t be maintained when you check out the project. Any linked resources/FMEAs will be replaced with local copies of the resources/FMEAs and stored directly within the project. See also Local, Global and Reference Resources.

Specifying the "Checked Out" Folder
By default, projects will be checked out to the default Documents folder on your computer (e.g., My Documents\ReliaSoft\Files\Checked Out).

To change this location, open the Backup/Check Out Options page of the Application Setup window and browse for a new default path under Check In/Out. Keep in mind that anyone who
has access to the folder will have full access to the checked out project; however, only the user who has the project checked out will have the ability to check in the project.

Tip: If you need to work on the project from a different computer after it has been checked out to the local folder, you will simply need to make sure that the latest copy of the standard database file is saved back to the exact same check-out location and filename before you check the project back in.

Checking Out a Project
To check out a project, select it in the project list then choose Project > Management > Check In/Out > Check Out.

In a secure database, this is available only if the user a) is the project owner, b) has the "Lock or check out project" permission for the project or c) has the applicable "manage all projects" permissions.

Checking in a Project
To check in a project, select it under the Checked Out heading in the project list and choose Project > Management > Check In/Out > Check In.

Note that when you check in a project, the software creates a restore point, which is an exact replica (i.e., a backup) of the project before it was checked out. This allows you to restore the project to its prior state when and if needed. The restore point will include a description of the user who checked out the project, as well as the date and time of the check out. (See Restore Points.)

Undo Check Out
To discard changes and restore the project to the state it was in before it was checked out, select the project under the Checked Out heading in the project list and choose Project > Management > Check In/Out > Undo Check Out.

In a secure database, this is available only if the user a) is the user who checked out the project, b) is the project owner or c) has the applicable “manage all projects” permissions.
Manage Projects Window
The Manage Project window displays a list of all the projects that currently exist for the
database and allows you to perform administrative tasks for multiple projects all at once. If you
have created custom project filters, you can apply those same filters in this window.

To open the Manage Projects window, choose Project > Management > Manage Projects.

In a secure database, this is available only to users with the applicable "manage all projects"
permissions. Only the type of project that you have permissions for will be displayed. Projects
that are under the Locked, Checked Out and Recycle Bin headings will be visible only if you have
permissions for all three project types.

Tasks You Can Perform
Some of the tasks you can perform in this window include:

- See a list of private projects created by other users (and perform any administrative
tasks that may be needed for those projects).
- Change multiple public projects to private all at once, and vice versa.
- Change the owner for multiple projects all at once.
- Apply the same changes to the project properties for multiple projects all at once.
- Review and edit the security settings (if applicable) for multiple projects all at once.
- Delete, restore, lock and unlock, or undo check out for multiple projects all at once.
- Review and sort projects based on the user who made the last change to a project, the
date/time of the last change and the last application that was used to make the change.

Tip: The Manage Projects window allows you to edit the properties of a project that is currently open or
in use. When you make a change, the user who has the project open will see the change you have made
when the database refreshes (the refresh happens automatically whenever the user makes a change,
such as closing a window, selecting a different item, etc.).

Tools
The Manage Project window contains the following commands:

Project

- Close closes the Manage Projects window.
Edit Project Properties allows you to view and edit the properties of the selected project(s).

Delete Project permanently deletes the selected project(s) and bypasses the recycle bin. There is no undo for delete unless you have a stored backup or restore point.

Restore Project is available only when you have selected project(s) under the Recycle Bin heading. Each selected project will be recovered from the recycle bin and restored to its original location in the project list.

Security

Change Owner assigns a different database user to be the owner for the selected project(s). (See Project Owner.)

Project Security is available only for public and reference projects in secure databases. It opens the Project Properties window with the Security tab active, where you can specify the user accounts that can view/modify the selected project. (See Planning Your Security Approach.)

Lock Project moves the selected project(s) into the Locked heading of the project list. When a project is locked, all database users (including the user who locked the project) will have read-only access to the project. In addition, a locked project cannot be deleted or have its properties and public/private/reference status edited. To unlock project(s), choose Unlock Project. (See Locked and Unlocked Projects.)

Make Private moves the selected project(s) into the Private heading of the project list. To move private project(s) to the Public heading, choose Make Public. (See Public, Private and Reference Projects.)

Make Reference moves the selected project(s) into the Reference heading of the project list. To move reference project(s) to the Public heading, choose Make Public.

Check Out

Undo Check Out discards all changes made to a checked out project and restores it to the state it was in at the time it was checked out. (See Check In and Check Out Projects.)

Excel

Send to Excel exports the data currently displayed in the Manage Projects window to an Excel spreadsheet.
Recycle Bin
The recycle bin is a temporary storage location for projects that have been deleted. It gives you a chance to restore the deleted project to its original location, if needed. Projects in the recycle bin are stored until you either empty the recycle bin or delete each individual project from the recycle bin.

Sending Projects to the Recycle Bin
Whenever you delete a project from a database, a confirmation window like the one shown next will appear.

If you want to move the project to the recycle bin, make sure the Send project to recycle bin check box is selected. If you want to immediately and permanently delete the project, clear the check box. Remember that once you empty or delete a particular project from the recycle bin, there will be no way to get it back unless you have previously created a backup or restore point.

Restoring and Deleting Projects from the Recycle Bin
In a secure database, the ability to restore and delete projects from the recycle bin is available only if the user a) is the project owner, b) has the "Delete project" permission, or c) has the applicable "manage all projects" permissions.

To restore a project from the recycle bin, select it and choose Project > Management > Recycle Bin > Restore Project.

To permanently delete a project in the recycle bin (no way to undo unless you have a backup or restore point), select it in the recycle bin and choose Project > Management > Recycle Bin > Delete Project.
To permanently delete all projects currently in the recycle bin (no way to undo unless you have a backup or restore point), select the Recycle Bin heading in the project list and choose Project > Management > Recycle Bin > Empty Recycle Bin.

Security

All enterprise databases use login security, meaning that the ReliaSoft applications use Windows authentication (or alternative credentials) to identify each user and control the user’s access via security groups. For a standard database, you can choose whether to apply login security; if you don’t, any user who has read/write access to the file will have full permissions throughout the database.

By default, each user in a secure database will have the same set of permissions for every public/reference project in the database (e.g., Jane Engineer has read-write access to all projects, Bill User has read-only access to all projects, and so on). Alternatively, you can configure the database to provide different permissions for different public/reference projects, if desired (e.g., Jane Engineer has read-write access to all of Department A’s projects, but she has read-only access to other projects). With either approach, you also have the option to further limit access for specific project items (e.g., folios, diagrams, system hierarchy items, etc.) if needed. There are many different ways these options can be configured depending on your organization’s particular needs.

**Tip:** If you need to be able to manage an enterprise database without using a ReliaSoft desktop application (i.e., without taking up one of the available license seats), you can access the same security features from the ReliaSoft Admin tool.

Applying Login Security

All enterprise databases use login security. For standard databases, there are two ways to apply login security if desired:

- Upon creating a new standard database (File > New), you can make it login secure by selecting the Apply login security check box.
For an existing standard database, you can apply login security at any time by choosing File > Manage Repository > Users and Security and then clicking the Apply Login Security button at the lower left corner of the window.

When you create an enterprise database or apply login security to a standard database, you will automatically be a member of the Admin security group, which has full permissions throughout the database. You can then use the Users and Security window to add/edit/delete other user accounts and assign them to appropriate security groups.

Note: You cannot automatically remove security from a database once it has been enabled. However, you can create a new non-secure database and use the Import from existing repository check box to automatically import all of the data from the secure database to the non-secure one.

Planning Your Security Approach

In secure databases, there are two basic factors that determine what a typical user can see and do in the database: the security group(s) that the user account belongs to and the public/reference project security settings.

This topic discusses two general approaches you can use to configure the security groups and project security settings to fit your organization’s specific needs:

- Same permissions for all public/reference projects
- Different permissions for different public/reference projects
Tip: In addition to these considerations, it is also important to note the following: a) Users with the applicable "manage all projects" permissions (in any of the security groups that they belong to) will always have full project-level permissions for all public or reference projects in the database; b) The project owner will always have full project-level permissions within that particular project; and c) The item permissions can be used to further limit access to specific items within a project (e.g., folios, diagrams, system hierarchy items, etc.).

**Same Permissions for All Public/Reference Projects**

If you want each user to have the same set of permissions for all public/reference projects in the database (e.g., Jane Engineer has read-write access to all projects, Bill User has read-only access to all projects, and so on), follow these steps:

1. **User Accounts and Security Groups**: Assign each user account to an appropriate security group. This can be one of the four security groups that are created by default in each new Synthesis repository — Admin, Power, User (Read/Write) or View (Read-Only) — or you can configure new or existing security groups to meet your particular needs.

   Select or clear the Allow access to projects with repository-level security check box. If some of the projects in the database will continue to use repository-level security, this allows you to specify whether each user will be able to access those projects.

   - If the option is selected (default), the user will be able to access any public/reference project that is set to use repository-level security, with the combined permissions from any of the assigned security groups.

   - If the option is cleared, the user will only be able to access a project if it is specifically assigned to a security group that he/she belongs to, or if the user account is specifically assigned to the project.
2. **Project Security**: Accept the default option on the Security tab of the Project Properties for all public and reference projects (**Project > Security > Project Security**). Note that if a user belongs to more than one security group (and the **Allow access to projects with repository-level security** check box is selected for his/her user account), that user will have the combined permissions of those groups in any project that is set to repository-level security.
Different Permissions for Different Public/Reference Projects

If you want the same user to have different permissions for different public/reference projects (e.g., Jane Engineer has read-write access to all of Department A’s projects, but she has read-only access to other projects), follow these steps:

1. **Security Groups**: Create a security group for each distinct type of access that users might need in any particular public/reference project. Here’s a simple example:
2. **User Accounts**: Assign the appropriate security group(s) to each user account. For the example shown below, the user will have read/write permissions in projects that are assigned to "Department A," and read-only access in projects that are assigned to "Read-Only."

If some of the projects in the database will continue to use repository-level security, the **Allow access to projects with repository-level security** check box gives you the option to decide whether each user will be able to access those projects.

- If the option is selected (default), the user will be able to access any public/reference project that is set to use repository-level security, with the combined permissions from any of the assigned security groups.
• If the option is cleared, the user will only be able to access a project if it is specifically assigned to a security group that he/she belongs to, or if the user account is specifically assigned to the project.

3. **Project Security**: Assign the appropriate security group(s) and/or specific user(s) for every public/reference project in the database.

• When you assign a security group, every user who belongs to that group will be able to access the project with the permissions that are specified in the group.

• When you assign a specific user, the combined permissions from all of the security groups that the user belongs to will be displayed. Use the check boxes to select which of those permissions will be in effect for that user in this particular project.

For the example shown below, users from Department A will have read/write access (because they belong to the "Department A" security group), users from Departments B and C will have read-only access (because they belong to the "Read-Only" security group) and Fred Consultant will have read/write access (because he belongs to the "Consultants" security group and has been specifically assigned to have those permissions in this project).
Chapter 2: Repositories and Projects

User Accounts

Every person who will access a Synthesis repository, be assigned to some role in an assigned action, and/or receive alerts via e-mail or SMS message must have a personalized user account in the database.

- **In non-secure databases**, the software automatically creates an account for anyone who opens the file. Every user has full permissions throughout the database, including the ability to create, edit or delete other user accounts (e.g., so you can modify contact information or send alerts to someone who has not yet had an account created automatically).

- **In secure databases**, the accounts must be created and managed by users with the "Manage users and logins" permission. The security group(s) assigned to each account determines what the user can see and do in the database.

To view and manage the user accounts in a database, choose **File > Manage Repository > Users and Security**.
This topic describes how to use the Users and Security window to create, edit or delete/deactivate user accounts. The same window can also be used to enable login security for a standard database, and to manage security groups (permissions) for a secure database.

**Built-in Find/Filter, Configuration and Grouping Tools**
The Users tab of the Users and Security window offers the same filter, column configuration and grouping tools that are built in to other utilities that use a similar grid (e.g., the Synthesis Explorer, Actions Explorer, etc.). For details about how to use each feature, see:

- Finding and Filtering Records
- Configuring Columns
- Grouping Panel

**Creating and Editing User Accounts**
The Users tab of the Users and Security window displays a table of all user accounts that have been created in the database. You can use the Add or Edit buttons below the table to create or modify individual accounts.

You can also import user accounts from Microsoft Active Directory by clicking the Active Directory button. (See Importing Users from Active Directory.)

Keep in mind the following requirements when creating new user accounts for a secure database:

- In order to use Windows authentication, the user must be logged in to a computer with the same domain/username that is defined in the user account. If a user needs to connect to a database from a different domain, you can set up alternative credentials that will allow access without domain authentication. (See Creating Alternative Credentials.)

- In order to access the database, the user account must be assigned to at least one security group. (If you simply wish to send e-mail alerts to the user, a security group is not required.)

- For SQL Server databases, the username must be associated with a "SQL Server Login" that allows the database platform to recognize the user and give access to the application database. This can be accomplished with an individual login, a group login or Windows impersonation. (See SQL Server Logins or Using Windows Impersonation.)

The Run As button below the table allows you to change your current connection to run as the user currently selected in the table. This allows you to test that user's permissions to be sure
that they are set as you intended. Depending on the permissions that user has, you may have to close the repository and reconnect to it in order to change back to your own account.

**Deleting or Deactivating User Accounts**

If an account has never been used and you want to permanently remove it, select the account name from the list and click **Delete**.

If an account has already been logged in at least once (the **Last Login** column shows this information), attempting to delete the account will deactivate it instead. A deactivated account will not have access to the database.

You can manually deactivate an account by clearing the check box in the **Active** column for the account. To reactivate the account and give the user access to the database again, select the check box in the **Active** column.

![Image of Users and Security window]

**User Login and Contact Information**

The User Login and Contact Information window contains the contact information, alerts preferences and action resource details for an individual user. In a secure database, it also includes access settings (security groups and alternative credentials).

To view or edit your own user account, double-click your name in the MDI status bar or choose **My Portal > Users > My Profile**.
Chapter 2: Repositories and Projects

To view or edit any user account in the database, choose File > Manage Repository > Users and Security, then double-click any row in the Users table. (In a secure database, this is available only for users with the "Manage users and logins permission.")

All of the user account options are described below. Some of these settings cannot be modified when you are editing your own profile.

User Info Tab
- **Domain** and **Username** contain the credentials used by Windows authentication to identify the user and give him/her access to the database.

- **Contact Details**. Each user can update his/her own contact details, if desired. Note that the Display Name will appear in all projects, analyses and plots you create or modify in the database. Click the **Active Directory** button to update the contact details based on information stored in Active Directory.

- **User Image**. Each user can save a profile photo, which will appear in locations such as the **User Page** of My Portal. Saved images are resized to 100 x 100 pixels.

- **Security Groups** control the user’s access to the database. (See Managing Security Groups.)

- **Allow access to projects with repository-level security**
  - If the option is selected (default), the user will be able to access any public/reference project that is set to use repository-level security, with the combined permissions from any of the assigned security groups.
  - If the option is cleared, the user will only be able to access a project if it is specifically assigned to a security group that he/she belongs to, or if the user account is specifically assigned to the project.

For more information, see Planning Your Security Approach.

- **Update security groups upon login (if associated with Active Directory)**
  - If the option is selected (default), the user’s security groups will be assigned automatically based on his/her security group in Active Directory. (See Associating Security Groups with Active Directory.)
  - If the option is cleared, the user can be manually assigned to any of the available security groups.

- **Active**. Clear or select the check box to deactivate or activate the account. A deactivated account will not have access to the database.
Chapter 2: Repositories and Projects

Alerts/Actions Tab

- **Receive automated alerts.** Each user can choose to receive alerts via e-mail, SMS text message or ReliaSoft portal messages. (See [Watches and Alerts](#) and [What is Your SMS Address?](#)) Note that alerts via e-mail and SMS text are available only if a valid SMTP server has been defined for the database and the user account has an e-mail address/SMS contact defined.

- **When assigned to actions.** When a user account is assigned to an action (either as the Person Responsible or as part of the Team resource), the **Cost Category** and **Hours per Day** are used to calculate resource utilization and costs. (See [Costs and Man Hours](#).)

Alternative Credentials Tab

The Alternative Credentials tab is available only for secure databases. Select the check box to allow the user to bypass Windows authentication and connect to the database using an alternative username and password. (See [Creating Alternative Credentials](#).)

Importing Users from Active Directory

If your organization uses Microsoft Active Directory, this topic explains how to import username and contact information from the directory to create new user accounts in the Synthesis repository. (If you also wish to use Active Directory to manage the membership in security groups, see [Associating Security Groups with Active Directory](#).)

To import users from Active Directory, choose **File > Manage Repository > Users and Security**, click the **Active Directory** button, and then follow these steps:

1. Enter or select the domain name in the **Domains** field. If your organization’s directory is large, you may also choose to limit the search to specific groups by clicking **Load Groups** and then choosing an option from the drop-down list. You can also use the **Filter By** field to further limit the search. When you have specified the desired filters, click **Load Users** to update the table.

![Search Options](#)
2. In the table of user accounts that match the filter criteria, select the check box for each user you want to create a account for. (The names of users who already have an account in the current database will appear grayed out.)

3. For secure databases only, use the Import as Members Of field to select the security group(s) that will be assigned to the new user account(s). If you skip this option now, you can assign security groups later for each individual account. (See Managing Security Groups.)

4. For SQL Server databases only, select the Create SQL Server login check box if you want to create an individual SQL Server login for each new user account. (See SQL Server Logins or Using Windows Impersonation.)

5. Click Import to create the account(s). After the process completes, the window will remain open to allow you to import additional users, if desired.

Creating Alternative Credentials

Secure databases use Windows authentication by default. This means that users must be logged in to a computer using the same domain and username specified for their user accounts. You can, however, allow specific users to bypass Windows authentication as needed. This may be useful for situations where:

- A user needs to work on a copy of a secure standard database on a computer that is not connected to the company’s network.
- A user needs to connect to an enterprise database from a different domain.

For these situations, you can set up alternative credentials for a user’s account that will allow that user to access the database without domain authentication. These credentials must be set up in advance, before the user attempts the connection.

If you have the "Manage users and logins" permission, you can create alternative credentials for a user account by following these steps:

1. Open the Users and Security window (File > Manage Repository > Users and Security). On the Users tab, select the account name from the list and click Edit.
2. In the User Login and Contact Information window, click the **Alternative Credentials** tab and then select the check box to enable alternative credentials.

3. With the setting enabled, create an alternative username and password for the account. The username and password must be unique within the database, and the password is **CaSe SeNsITiVe**.

Once you have created the credentials, instruct the user to enter this login whenever the database prompts for it. The database will ask for the alternative credentials whenever the user account cannot be matched based on domain authentication.

**Tip:** The first time you connect to a database using alternative credentials, the application will automatically remember the login information on your computer. If you wish to clear the saved login, you can click the **Clear Alternative Credentials** link on the **Other Synthesis Settings page** of the Application Setup.

### User Groups

The User Groups window (formerly called “Notification Groups”) allows you to create and manage groups of users that can be assigned throughout the current database for:

- Recipients for [portal messages](#)
- Monitors for [assigned actions](#)
- Team members in the [Project Planning Resources](#)

To access the window, choose **File > Manage Repository > User Groups**.

In a secure database, this is available only for users with the **“Manage users and logins” permission**.
Chapter 2: Repositories and Projects

Adding or Editing a Group
The table displays a list of the user groups that have already been defined in the current database.

To add a new group, click Add.

To view or edit an existing group, double-click the row or select the row and click Edit.

The Available Users list shows all of the user accounts in the current database that are not yet assigned to the group. Double-click or use the buttons to move at least one user into the Selected Users list.

Deleting a Group
To delete an existing group, select a row and click Delete or press the DELETE key.

If the user group has been assigned to any existing actions, messages or project planning teams, the group will be removed automatically and those users will no longer be assigned in the affected records. There is no undo for delete.

Managing Security Groups
In a secure database, security groups control what users can see and do in the database. By default, the software includes four predefined security groups: Admin, Power, User and View. The Admin group, which has full permissions throughout the database, can neither be deleted nor have its permissions modified. For the other predefined groups, you can edit their permissions or replace them with new groups that fit the specific way the database will be used.

As discussed in Planning Your Security Approach, there are two basic approaches you can use:

- **Same permissions for all public/reference projects** – each user account is assigned to one security group and all public/reference projects use the default security option (repository-level security).

- **Different permissions for different public/reference projects** – each user account may be assigned to multiple security groups and each public/reference project may be accessed only by specific security groups and/or users.

Note: If your organization has implemented an SEP web portal for an enterprise repository and the site is configured to enable access by nCode Aqira users, a special "Aqira" security group will be created. This security group cannot be deleted, but you can modify the permissions that will be available to Aqira users. (See Allow Aqira Users to Access SEP.)
Creating, Editing or Deleting Security Groups
You can manage the security groups by choosing File > Manage Repository > Users and Security. (In a secure database, this is available only to users with the "Manage users and logins" permission.)

In the Users and Security window, click the Security Groups tab to see all the security groups that have been created in the database. Use the Add, Edit or Delete buttons below the table to manage the groups.

When you edit a security group, the left side of the Security Group window allows you to choose the permissions, while the right side shows all the users currently assigned to the group.

If you have selected to Associate this security group with an Active Directory group, the list of assigned users can be updated automatically, or you will only be able to manually import/assign users who belong to the designated Active Directory group. (See Associating Security Groups with Active Directory.)
Permissions
Here is a summary of all the permissions that can be granted to a particular security group.

Basic permissions throughout repository
These permissions apply throughout the database if they are in any of the security groups that the user belongs to. These permissions do not depend on the security settings for a particular project.

<table>
<thead>
<tr>
<th>Permission</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Create and own private projects</strong></td>
<td>You can create and own <em>private</em> projects in the database that are accessible only to you. (Users with the &quot;Manage all private projects&quot; permission can still perform administrative tasks on all private projects, such as editing their properties, locking them, converting them to public projects, etc.)</td>
</tr>
<tr>
<td><strong>Create and own public projects</strong></td>
<td>You can create and own <em>public</em> projects that other users can view and edit (depending on the project security settings).</td>
</tr>
<tr>
<td><strong>Create and own reference projects</strong></td>
<td>You can create and own <em>reference</em> projects for sharing resources and FMEAs with other projects in the database (depending on the project security settings).</td>
</tr>
<tr>
<td><strong>Create portal messages</strong></td>
<td>You can create new messages and edit or delete the messages you have personally created via the Messages page in My Portal.</td>
</tr>
<tr>
<td><strong>Export to another repository</strong></td>
<td>You can export projects from the current repository as new projects in another repository.</td>
</tr>
<tr>
<td><strong>Publish to SEP web portal</strong></td>
<td>You can publish your progress, results and analyses from a given project to the SEP web portal, making the information accessible from any web-enabled device.</td>
</tr>
<tr>
<td><strong>Open desktop apps from SEP web portal</strong></td>
<td>You can use the Open buttons on the FMEAs and analysis summary pages in the SEP web portal to open those applications using Remote ReliaSoft.</td>
</tr>
<tr>
<td><strong>Create/edit/delete SDW data collections</strong></td>
<td>You can create, edit and delete data collections in the Synthesis Data Warehouse (SDW). This includes data extraction from XFRACAS as well as custom connections, and confers the ability to create dashboard layouts for custom connections.</td>
</tr>
</tbody>
</table>
Basic and advanced permissions at project level

A user can have these permissions in some projects but not others, depending on the project security settings. Regardless of the project security settings, these permissions are always automatically granted to the current project owner and anyone else that can manage the project.

<table>
<thead>
<tr>
<th>Permission</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Read</strong></td>
<td>You can perform tasks that do not modify the data in the project (e.g., view the analysis, calculate metrics in a Quick Calculation Pad, export data, etc.).</td>
</tr>
<tr>
<td><strong>Create/edit project items</strong></td>
<td>You can create and edit items in a given project such as folios in Weibull++/ALTA, diagrams in BlockSim, system hierarchy items in XFMEA/RCM++/RBI, etc., as well as update the item properties.</td>
</tr>
<tr>
<td><strong>Create/edit/delete own resources</strong></td>
<td>You can create resources (e.g., URDs, models, etc.) and edit or delete any existing resources you have created.</td>
</tr>
</tbody>
</table>
| **Delete project items** | You can delete any item in a given project (e.g., folios in Weibull++/ALTA, diagrams in BlockSim, system hierarchy items in XFMEA/RCM++/RBI, etc.).

This permission cannot be assigned unless you also have the "Create/edit project items" permission. |
| **Create/edit project plans** | You can create and edit project plans for a given project. |
| **Create/edit/delete local resources** | You can create, edit and delete any local resources in the project (not just the ones that you created). |
| **Set project security** | You can control who can view and edit a given project. This permission allows you to configure both project security settings and item permissions. |
| **Edit project properties** | You can use the Project Properties window to edit the name, description, category and other settings of a given project. |
| **Lock or check out project** | You can:
  - Lock and unlock a given project.
  - Check in and check out a given project. |
## Chapter 2: Repositories and Projects

<table>
<thead>
<tr>
<th><strong>Create restore points</strong></th>
<th>You can utilize restore points for a given project, which are exact replicas of the project at a particular point in time (i.e., backups).</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Delete project</strong></td>
<td>You can delete a given project.</td>
</tr>
<tr>
<td><strong>Manage change logs in XFMEA/RCM++/RBI</strong></td>
<td>You can enable and manage change logs within a given project. Change logs can be created for FMEAs, DVP&amp;R, Control Plan and P-Diagram analyses in XFMEA, RCM++ and RBI. See Change Logs in the XFMEA/RCM++/RBI documentation.</td>
</tr>
<tr>
<td><strong>Review change logs in XFMEA/RCM++/RBI</strong></td>
<td>You can implement electronic approval tracking for change logs within a given project. See Electronic Approval Tracking in the XFMEA/RCM++/RBI documentation.</td>
</tr>
</tbody>
</table>
Administrative permissions throughout repository
These permissions apply throughout the database if they are in any of the security groups that the user belongs to. These permissions do not depend on the security settings for a particular project.

<table>
<thead>
<tr>
<th>Manage users and logins</th>
<th>You can:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Use the Users and Security window to add user accounts to the database and define security groups, as well as create alternative credentials for user accounts.</td>
</tr>
<tr>
<td></td>
<td>• Use the User Groups window to add and manage distribution groups for e-mail alerts, portal messages, action alerts and projecting planning resources.</td>
</tr>
<tr>
<td></td>
<td>• Use the Repository Logins window to view and export a history of database logins.</td>
</tr>
<tr>
<td></td>
<td>• Use the Reset &quot;In Use&quot; Flags window to clear the &quot;in use&quot; status for selected database users (not just your own).</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Manage project planning resources and working days</th>
<th>You can:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Use the Project Planning Resources window to manage the cost categories, teams, materials and facilities that are used for tracking resource utilization in Project Planner gates and actions.</td>
</tr>
<tr>
<td></td>
<td>• Use the Working Days/Holidays window to specify the business days that will be used for Project Planner gates and actions.</td>
</tr>
</tbody>
</table>

| Manage project/item categories | You can use the Project/Item Categories window to define the project and item categories that can be used for grouping and filtering projects and items in the database. |
## Manage other repository settings

You can:

- Use the [Unit Settings window](http://mpc.reliasoft.com) to define the unit and measurement settings available for use in any project within the database.

- Use the [Default Name Formats window](http://mpc.reliasoft.com) to specify how default names for resources and blocks are created.

- Use the Task Types window in RCM++, RBI and MPC.
  - In RCM++ and RBI, you can map the task types that are used only in RCM++/RBI to the task classes in the universal reliability definition (URD). See [Task Types in RCM++/RBI](http://mpc.reliasoft.com) in the RCM++/RBI documentation.
  - In MPC, you can modify the abbreviations used for MSG-3 task types. See [Task Type Abbreviations in MPC](http://mpc.reliasoft.com) in the MPC documentation.

- Use the [Repository Settings window](http://mpc.reliasoft.com) to set some default settings for existing and new databases. This includes enabling e-mail alerts for the database, activating history logs, etc.

- Set up [XFRACAS connection settings](http://mpc.reliasoft.com) that allow ReliaSoft desktop applications to access the XFRACAS data stored in the database. This is available only for standard databases (*.rsr19).

## Create/edit/delete global resources

You can create, edit and delete any [global resources](http://mpc.reliasoft.com) in the project (not just the ones that you created). In addition, you can transfer data from [XFRACAS to the SDW](http://mpc.reliasoft.com).

## Approve actions

You can review and approve [actions](http://mpc.reliasoft.com), which are resources that allow you to track progress made in a project.

## Manage all portal messages

You can edit or delete any messages that are visible to you via the Messages page in [My Portal](http://mpc.reliasoft.com). This includes any messages for which you are the creator or one of the recipients.

## Manage dashboard layouts

You can create and save layouts for use in the [Dashboard Viewer](http://mpc.reliasoft.com) in Weibull++, BlockSim and RGA.
### Chapter 2: Repositories and Projects

<table>
<thead>
<tr>
<th>Manage profiles and templates in XFMEA/RCM++/RBI</th>
<th>This permission is available only in enterprise databases. You can:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Use the Profiles/Library Manager window in XFMEA/RCM++/RBI to configure the predefined settings stored in the active library of the enterprise database. See Profiles/Library Manager in the XFMEA/RCM++/RBI documentation.</td>
<td></td>
</tr>
<tr>
<td>• Use the Templates Manager window in XFMEA/RCM++/RBI to configure report templates stored in the enterprise database. See Templates Manager in the XFMEA/RCM++/RBI documentation.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Manage Lambda Predict repository settings</th>
<th>You can:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Use the FIDES Settings Manager window in Lambda Predict to configure the FIDES-related settings stored in the database. This applies to the FIDES prediction standard only (see FIDES Settings Manager in the Lambda Predict documentation).</td>
<td></td>
</tr>
<tr>
<td>• Use the Custom Derating Standards Manager window in Lambda Predict to create, edit or delete user-defined derating standards stored in the database. See Creating Custom Derating Standards in the Lambda Predict documentation.</td>
<td></td>
</tr>
<tr>
<td>• Use the MIL-217 Custom Connections window in Lambda Predict to define failure rates for user-defined connectors stored in the database. This applies to the MIL-217 prediction standard only. See MIL-217 Custom Connection Types in the Lambda Predict documentation.</td>
<td></td>
</tr>
</tbody>
</table>
### Manage MPC Settings

You can:

- Use the Manage ATA Chapters window in MPC to define the systems and subsystems that are available for use in the database. See [Managing ATA Chapters](http://mpc.reliasoft.com) in the MPC documentation.

- Use the Manage Major Zones window in MPC to define the zones and major sub-zones that are available for use in the database. See [Managing Major Zones](http://mpc.reliasoft.com) in the MPC documentation.

- Use the Configurable Options for Systems and Powerplant Analysis window in MPC to enable or disable the display of some item properties and task properties fields. See [Configurable Options for Systems and Powerplant Analysis](http://mpc.reliasoft.com) in the MPC documentation.

- Use the Configurable Options for Structural Analysis window in MPC to customize the settings for environmental deterioration (ED) and accidental damage (AD) analyses that can be performed for any structural item in MPC Plus. See [Configurable Options for Structural Analysis](http://mpc.reliasoft.com) in the MPC documentation.

- Use the Configurable Options for Zonal and L/HIRF Analysis window in MPC to customize the settings for the standard zonal, enhanced zonal and L/HIRF analyses that can be performed for any zonal item in MPC Plus. See [Configurable Options for Zonal and L/HIRF Analysis](http://mpc.reliasoft.com) in the MPC documentation.

### Manage all public projects

You have all the basic and advanced project-level permissions for public projects in the database. You can also change the [project owner](http://mpc.reliasoft.com) for any public project in the database.

### Manage all reference projects

You have all the basic and advanced project-level permissions for reference projects in the database. You can also change the [project owner](http://mpc.reliasoft.com) for any reference project in the database.

### Manage all private projects

You have all the basic and advanced project-level permissions for private projects in the database. You can also change the [project owner](http://mpc.reliasoft.com) for any private project in the database.
Associating Security Groups with Active Directory

If your organization uses Microsoft Active Directory (AD), you can give an AD group a specific set of permissions in the Synthesis repository. The members of the AD group can then access the database based on the set of permissions associated with the group.

In addition, the software offers the option to automatically update the permissions of a user whenever that user is added or removed from an AD group. For example, if a user is moved from AD group A to AD group B, his/her user account can be automatically updated with the permissions associated with AD group B. The changes will take effect the next time the user connects to the database via any of the ReliaSoft desktop applications. (Note that for users who will connect only via the SEP web portal, you’ll need to update their permissions manually either via a desktop application or the ReliaSoft Admin tool on the web server.)

Tip: Multiple security groups can be assigned to the same user account, if appropriate. For example, a user can be assigned to the "ABC Team" group (which is associated with Active Directory) and the "Read-Only" group (which is not). (See Planning Your Security Approach.)

Assigning Permissions to an Active Directory Group

To associate a security group with an Active Directory group, choose File > Manage Repository > Users and Security and click the Security tab. Then double-click the security group you want to edit.

In the Edit Security Group window, select the Associate this security group with Active Directory check box, and then specify the domain name and Active Directory group to use. There are two additional options, which apply only when users log in from a ReliaSoft desktop application:

- **Automatically update this security group's members.** If a user is added to the AD group, his/her user account will automatically have this set of permissions the next time the user logs in to the database via any of the ReliaSoft desktop applications. Likewise, if the user leaves the AD group, his/her user account will no longer have this set of permissions.

  If you do not want the changes in Active Directory to be automatically applied to a particular user, clear the Update security groups upon login check box in that user's account in the Synthesis repository.

- **Automatically create new user accounts on first login.** If a member of the AD group does not already have a user account, it will be created automatically (and assigned to this security group) the first time he/she tries to connect via any of the ReliaSoft desktop applications.
Creating/Updating Accounts Now
If you don’t want to wait for all users to log in before creating/updating their user accounts, click the Assign button at the bottom of the window.

- To create new accounts, choose **Import users who are members of this Active Directory group**. This opens the **Import Users from Active Directory window**, but you can only choose users from the associated Active Directory group.

- To update the security groups for existing accounts, choose **Assign existing repository users who are members of this Active Directory group**. This shows a list of existing users who also belong to the associated Active Directory group; you can select to update any or all of their accounts.

Setting Item Permissions
In a secure database, all project items (e.g., folios, diagrams, system hierarchy items, etc.) are, by default, set to inherit their permissions from the project. This means that if a user has the
"Create/edit items" permission for the project, he or she will be able to edit all of the items by default. If you want to prevent some or all of those users from editing a particular item (i.e., lock or limit access to the item), you can use the Item Permissions window.

The window functions a little differently depending on whether you’re working with items in a project explorer (e.g., folios, diagrams, etc.) or items in a system hierarchy.

**Project Explorer Items**
In Weibull++, ALTA, BlockSim, RENO, RGA or Lambda Predict, select the item in the current project explorer and choose **Project > Current Item > Item Properties**. (In a secure database, this is available only if the user a) is the **project owner**, b) has the "Set project security" permission, or c) has the applicable "manage all projects" permissions.)

The settings are displayed on the Permissions tab of the properties window.

In the Item Permissions window, select the **Restrict editing to selected project users** option and then select which specific users will be able to edit this particular item. All others can view, but not edit, the item. Only users with editing rights to the project will appear in the list.

To remove item permissions and change the security settings back to the defaults, select the **Inherit from project** option.

**System Hierarchy Items**
In XFMEA, RCM++ or RBI, select the item and choose **System Hierarchy > Current Item > Item Permissions**. In MPC, select an item and choose **Security > Item Permissions** on the relevant ribbon tab. (In a secure database, this is available only if the user a) is the **project owner**, b) has the "Set project security" permission, or c) has the applicable "manage all projects" permissions.)

In the Item Permissions window, you can choose to:

- Define the permissions for the item by selecting the **Restrict editing to selected project users** option and then selecting which specific users will be able to edit this particular item. All others can view, but not edit, the item. Only users with editing rights to the project will appear in the list.

- Set the item to inherit the same permissions as the next item above it in the system hierarchy by selecting the **Inherit from parent item** option.

- Remove item permissions and change the security settings back to the defaults by selecting the **Inherit from project** option.
If you select the **Apply to all dependents** check box, the software will automatically set the permissions for all next-level items in this branch of the hierarchy to match the item you are currently editing. For example, consider a case where each item in an XFMEA system hierarchy has different permissions, as shown next.

For a quick way to reset all of the item permissions to the defaults, you can open the Item Permissions window for SubSystem 1, set to **Inherit from parent item** and select the **Apply to all dependents** check box. The resulting system hierarchy is shown next.

**Status Indicators**
ReliaSoft desktop applications include status indicators that tell you which project items (e.g., folios, diagrams, system hierarchy items, etc.) are in use or restricted.

When you encounter an item that is read-only (e.g., OK button is disabled in the window or you are unable to type in the cells of a worksheet or table), you can check the status of the item to see if it is currently **in use** (i.e., you can’t edit the item until the user closes the folio/diagram or selects a different item in the hierarchy) or **restricted** (i.e., you don’t have permissions to edit the item). If the item is in use, move the pointer over the icon to identify the user.
The location of these status icons will vary depending on which ReliaSoft application you are using:

- In projects that use a current project explorer to manage analysis data, the status icons are displayed next to the item’s name in the current project explorer, as in the example shown next.

![Current Project Explorer Example](image)

- In projects that use hierarchical trees to manage analysis data (as seen in the XFMEA, RCM++, RBI and MPC applications), the status icons are displayed in the User Access column of the system hierarchy. (To hide or display columns, right-click the column headings, then click **Customize Columns** to select which columns you want to display.)

![Hierarchical Tree Example](image)

**Tip:** The application interface refreshes automatically whenever you make a change (e.g., close a project, create a resource, select a different item, etc.). If your computer will not let you edit an item that is in fact not currently being edited by another user, it could be because your computer has not been recently refreshed with the latest changes made by other database users. You can initiate the refresh manually by choosing **View > Refresh**.

In addition, the software employs "in use" flags within the database to record when an analysis is
current being edited by a particular user. If the refresh still does not show that the item has been released, then something might have occurred to prevent the flags from being reset correctly (e.g., a network interruption or if the software closes unexpectedly). Refer to the Reset “In Use” Flags topic for instructions on how to reset the flags throughout the database if this problem occurs.

### Reset "In Use" Flags

Because Synthesis repositories allow simultaneous access by multiple users, it is necessary to store “in use” flags within the database to indicate when a particular portion of the analysis is currently being edited by a particular user. There are some circumstances when these flags might not be reset correctly when a user stops editing an analysis (e.g., if there is a network interruption or if the software closes unexpectedly). If that occurs, then the analysis will be locked for editing because the software receives an erroneous indication that it is still in use by another user.

To correct the problem, it is necessary to reset some or all of the “in use” flags within the database. To reset the flags, choose File > Manage Repository > Reset ‘In Use’ Flags.

(In a secure database, this is available only for users with the "Manage users and logins" permission.)

This opens the Reset 'In Use' Flags window, which shows all users who have an account in the database. (If you are working in a non-secure database, any user who has ever opened the database will have an account created automatically and will be shown in this list.) A status light is displayed for each user; if it is "lit up" (i.e., green), the user is currently logged in to the database. In addition, the Connections column shows the ReliaSoft application(s) that the user currently has connected to the database. You can select the check box for each user for whom you want to reset "in use" flags, then click OK to reset the flags.

**IMPORTANT:** It is important to make sure that no selected user is currently logged in to the database when you use this command. Users currently logged into the database can be viewed on the Users Page of My Portal.

### Repository Logins

The Repository Logins window displays a record of the date and time the users in the database logged in. To open the Repository Logins window, choose File > Manage Repository > Repository Logins. (In a secure database, this is available only for users with the "Manage users and logins" permission.)

http://mpc.reliasoft.com
The following options are available:

- Use the **Most Recent** filter to display in the table the last 10; 100; 10,00 or 10,000 users who logged in to the database.

- Use the **User** filter to specify whether the table will display the logs for all users or display only the logs for a selected database user.

- Click the **Send to Excel** button to export the data currently displayed in the table to an Excel spreadsheet.

- Click the **Clear Logins** button to clear the entire history of users who logged in to the database. Since this action cannot be undone, you will be prompted to confirm that you want to proceed before the records are erased.

Users currently logged into the database can be viewed on the **Users page** of My Portal.

## Repository Settings

The Repository Settings window contains settings that are shared by all users and analysis projects in the database. To access this window, choose **File > Manage Repository > Repository Settings**. (In a secure database, this is available only for users with the "Manage other repository settings" permission.)

In a standard database, you can save the current settings as the default for each new standard database that you create from this computer by clicking the **Set as Default** button at the bottom of the window.

*What’s Changed?* In prior versions, these preferences were defined in the E-mail and Other Settings window.

### E-mail Settings Page

- **Enable Alerts via E-mail or SMS** configures the database to enable alerts via e-mail or SMS text message. (See [Enable Alerts via E-mail or SMS](#).)

- **Action Alerts** apply to action resources. The database can be configured to auto-subscribe a "watch" for users based on their role(s) for a particular action. You can also specify the default text that will be used at the beginning of each action alert. (See [Action Alert Preferences](#).)
Other Settings Page

- **FMEA Structure (XFMEA/RCM++/RBI)** allows you to select the default FMEA structure for new projects created in the database, which determines how the software will display the effect and cause records in the FMEAs. If you don't specify a default, users will be prompted to select the structure for each new project they create in XFMEA/RCM++/RBI. (See Choosing the FMEA Structure in the XFMEA/RCM++/RBI documentation.)

- **History Logs** allows you to turn the log on (or off) for all active projects, and stores a preference for whether the log should be activated by default for each new project. (See History Logs.)

- **Actions** allows you to automatically set the person who created an action to be the person responsible for it. (See Person Responsible and Resources.)

- **Enable publish to SEP web portal** is available only in enterprise databases. If your organization has established an SEP web portal for the current database, select this check box to enable users to publish analysis summaries, Synthesis Workbooks and other information to the portal.

- **Delete Portal Messages** deletes all portal messages for all users in the database. *There is no undo for deleting portal messages.*

Unit Settings

Synthesis repositories are pre-configured with a set of units for use with any analysis in any project within the repository. The conversion factors are predefined, allowing you to easily express results in terms of other units. For example, you can enter data into a Weibull++ data sheet in terms of hours and then obtain results from the QCP in terms of years. Similarly, in RCM++, RBI or BlockSim, you can define the duration of a maintenance task in terms of hours and specify the total operating time of a system in terms of months. In MPC, the units can be used to define task intervals.

*IMPORTANT:* Making changes to the existing units can have implications for all analyses throughout the database; therefore, it is best to set up units once, upon creation of the database.

To define units, choose **File > Manage Repository > Unit Settings.** (In a secure database, this is available only to users with the "Manage other repository settings" permission.)

If you're working in Weibull++, the Warranty Units tab will be available. It allows you to specify which of the configurable repository units are equivalent to the built-in (not configurable)
"warranty time units" used in some warranty folio formats. For details, see Manage Warranty Units in the Weibull++/ALTA documentation.

**Setting SBU Equivalencies**

The conversion factor of a unit is defined in relation to a system base unit (SBU). A base unit is a standard unit of measurement upon which other units can be based. Base units always have a conversion factor of 1. All other related units are converted back to the base unit.

For example, say that we choose kilograms (kg) as our SBU for mass. The conversion factor of related units, such as pounds (lb) and metric tons (T), must be entered in terms of the SBU:

<table>
<thead>
<tr>
<th>Unit</th>
<th>SBU Equivalency (using kg as the base unit)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 kg</td>
<td>1 kg</td>
</tr>
<tr>
<td>1 lb</td>
<td>0.4536 kg</td>
</tr>
<tr>
<td>1 T</td>
<td>1000 kg</td>
</tr>
</tbody>
</table>

Similarly, if we change the base unit to pounds (lb), the conversion factors must reflect the change:

<table>
<thead>
<tr>
<th>Unit</th>
<th>SBU Equivalency (using lb as the base unit)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 kg</td>
<td>2.2046 lb</td>
</tr>
<tr>
<td>1 lb</td>
<td>1 lb</td>
</tr>
<tr>
<td>1 T</td>
<td>2204.62 lb</td>
</tr>
</tbody>
</table>

By default, Synthesis repositories use hours (hr) as the SBU for time, and miles (mi) as the SBU for length. To ensure that you obtain correct results when converting units, it is recommended that you set an SBU for each type of measurement (e.g., time, length, frequency, force, etc.) and define the conversion factors of all other units in terms of the relevant SBU.
Chapter 2: Repositories and Projects

Changing the Default Unit
You can set any unit as the default by selecting it in the Use as Default column. The software will automatically use the new default unit when you create a new analysis or resource in any project in the repository. The change will not affect existing analyses and resources.

Creating and Deleting Units
To add a new unit, click the Add button below the table and follow the on-screen prompts to create the unit. The wizard will automatically calculate and apply the appropriate SBU equivalency based on your inputs.

To delete a unit, click the Delete button below the table. There is no undo for delete.

Editing Existing Units
Click a cell to edit a unit’s name, abbreviation, SBU equivalency and category. To apply your changes, click the Save button at the bottom of the window.

Note that if you will be using the usage format of the Weibull++ warranty folio, only the units assigned to the Usage category will be available for those analyses; units assigned in the Time category are not available in the warranty usage format.

Built-in Find/Filter, Configuration and Grouping Tools
You can move a unit up or down its current position by dragging the row to the desired position, or by selecting it and using the Move Up or Move Down buttons.

To show more tools, right-click any column heading. The window offers the same filter, column configuration and grouping tools that are built in to other utilities that use a similar grid (e.g., the Resource Manager). For details about each feature, see:

- Finding and Filtering Records
- Configuring Columns
- Grouping Panel

Default Name Formats
In all ReliaSoft desktop applications except MPC, the Default Name Formats window specifies the default names for new resources, as well as new blocks in BlockSim RBDs, fault trees, phase diagrams and PFS diagrams. For example, when you create a new model, the default name will be the word "Model" plus an increment to make the name unique (e.g., "Model," "Model_1," etc.). You can configure the database to use a different default name format if desired.
To open the window, choose **File > Manage Repository > Default Name Formats**. (In a secure database, this is available only for users with the "Manage other repository settings" permission.)

The **Item Name** column displays the basic name label for each type of resource or block. This will be represented by the \N code in the name format.

The **Name Format** column allows you to use any of the following elements to define the default name format for each type of resource or block:

- \N returns the label from the Resource Name column plus an increment to make the name unique (e.g., "Model," "Model_1," etc.).
- \U returns the name of the user who created the resource or block.
- \D returns the date when the resource or block was created.
- \S adds a sequential number that reflects the order in which the resource/block was added to the database.
- \T returns the ReliaSoft application ("tool") used to create the resource or block.
- \F returns the contents of all of the **identifier fields** except the category and comments fields.
- \G returns a summary of the properties of the resource or block. For example, for a node in a BlockSim diagram, \G returns the "k out of n" paths that are required.
- \I is only applicable for resources. It functions the same as \N unless there is another window, resource or analysis that it can "inherit" part of the name from. Some examples:
  - If you create a URD from BlockSim’s block properties window, the default name will be "[Block Name]_URD."
  - If you create a metric based on a model, the default name will be "[Model Name]_Metric."
  - If you push a metric from a Project Planner gate, the default name will be "[Gate Name]_[Property Name]_Metric."

**Tip:** In BlockSim diagrams, you can use an asterisk (*) to insert the default block name. For example, if you enter *System for the block name, the diagram will display the default name for the block followed by the word "System." The asterisk also allows the block name to be updated dynamically when relevant properties change.
Project Planning Resources

In all ReliaSoft desktop applications except MPC, *project planning resources* can be assigned to actions in order to track the required costs and time in the Project Planner and anywhere else that actions are used. Because project planning resources are shared throughout the database, any change made to one is automatically applied to all actions in the database that use it.

- **Cost Categories** specify direct and/or per instance costs that can be assigned to any team member, facility or material.
- **Teams** identify groups of users who will work together on any given action.
- **Facilities** specify the cost and maximum utilization for facilities (e.g., test lab) or other resources for which the cost depends on the duration of use (e.g., rented test equipment).
- **Materials** specify the cost and quantity for materials (e.g., test units) or other resources for which the cost depends on the amount used rather than the duration (e.g., purchased usage data).

To open the Project Planning Resources window, choose **File > Manage Repository > Project Planning Resources**. (In a secure database, only users with the "Manage project planning resources and working days" permission will be able to create and edit these resources; other users can select from the resources that have already been predefined.)

Cost Categories

Cost categories can be created from the Project Planning Resources window, or when you are creating/editing a facility, material or individual user account. Enter the **Currency Symbol** to use for displayed costs at the bottom of the window.

- The **Direct Cost per Hour or Unit** is the per-hour cost when assigned to a team member or facility, or the per-unit cost when assigned to a material (e.g., the cost of a single light bulb).
- The **Cost per Instance** is a one-time cost that applies every time a team, facility or material is used.

Teams

Teams can be created from the Project Planning Resources window, or when you are defining an action. A team can include:

- Individual **Users** who have active user accounts in the database.
• **Groups** of active user accounts that have been predefined in the database.

Note that you cannot assign a cost category directly to a team. Instead, the team's cost/utilization is based on the cost category and maximum hours per day for each team member. Both of these properties are set on the **Alerts/Actions** tab of the **User Login and Contact Information** window.

**Facilities**

Facilities can be created from the Project Planning Resources window, or when you are defining an action.

• The **Cost Category** specifies the facility's hourly and/or per-use costs.

• The **Max Hours Per Day** is the number of hours of use if the facility is set to be 100% utilized for a given action (as specified in the action properties).

**Materials**

Materials can be created from the Project Planning Resources window, or when you are defining an action.

• The **Cost Category** specifies the cost per unit (e.g., the cost for each test prototype), as well as any additional fixed cost (e.g., the cost for manufacturing a sufficient number of test prototypes).

• The **Quantity** that will be used (e.g., 100 light bulbs).

**Working Days/Holidays**

In all ReliaSoft desktop applications except MPC, actions and **Project Planner gates** contain important dates like start dates and due dates. You can specify which dates will be considered working days for all actions and gates in the repository. This way, an action's cost/time estimates, as well as its duration, will be based solely on working days.

To define the working days for the repository, choose **File > Manage Repository > Working Days/Holidays**. (In a secure database, this is available only for users with the "Manage project planning resources and working days" permission.)

In the window that appears, use the **Define Work Week** area on the left side to specify which days of the week will be considered regular working days (e.g., Monday-Friday).
Define Holidays
On the Define Holidays tab, you can define three different types of holidays.

- **Fixed Date - Recurring** holidays occur every year on the same calendar date (e.g., New Year's Day is always January 1).
- **Variable Date - Recurring** holidays occur every year, but not always on the same date (e.g., Thanksgiving is always the fourth Thursday of November).
- **Fixed Date - Non-recurring** holidays occur once and do not happen again. For example, a specific Monday could become a non-working day due to weather conditions.

In the Holiday Properties window, select **Move to adjacent working day if necessary** to make sure the holiday will be observed when a) it occurs outside the work week, but b) there is a regular working day immediately before/after it. In this case, the holiday is observed on the nearest working day. (If there is a working day immediately before and after the holiday, it is observed on the following day.)

View Observed Holidays
The View Observed Holidays tab allows you to easily examine the names and dates of all holidays that will be observed during the work week, and can also help you make sure your working days/holidays settings are correct. Specify the years you want to view in the Displayed Range in Years area.

**XFRACAS Connection**
XFRACAS is a web-based, closed-loop, incident (failure) reporting, analysis and corrective action system designed for the acquisition, management and analysis of product quality and reliability data from multiple sources. There are several ways in which you might wish to share data between XFRACAS and the analyses that you perform in ReliaSoft desktop applications:

- Use the Synthesis Data Warehouse in Weibull++/ALTA or RGA to extract data from XFRACAS incidents. (See Synthesis Data Warehouse.)
- Share system configuration and failure mode data between XFRACAS and XFMEA/RCM++/RBI. (See Import or Sync from XFRACAS in the XFMEA/RCM++/RBI documentation.)

When you are working with an enterprise database, the data from XFRACAS and ReliaSoft desktop applications can be stored in the same SQL Server or Oracle database.

When you are working with a standard database (*.rsl9), you will need to establish a connection to an enterprise database that contains XFRACAS data. To do this, choose File >
Manage Repository > XFRACAS Connection. (In a secure database, this is available only for users with the "Manage other repository settings" permission.)

In the XFRACAS Connection Settings Window, select Connect to an enterprise repository with XFRACAS data then choose Microsoft SQL Server or Oracle.

- For a SQL Server database, enter the server name and database name.
  - Encrypt communication. Secures the connection information between the ReliaSoft application and the enterprise database.
  - Trust server certificate. Select this option if the server has a self-signed certificate.
  - Use impersonation. Configures the connection setting to impersonate a Windows user account with a SQL Server login that is shared by multiple users. (See SQL Server Logins or Using Windows Impersonation.) If you do not use impersonation, then each user who uses the features that utilize XFRACAS must have an account in the external database that contains the XFRACAS data.

- For an Oracle database, enter the port, host and service identifiers and the database schema. Your Windows login credentials are used for access to the database; enter your Windows password.

Managing and Restoring Data

Since each database may contain a large amount of valuable information that would be difficult to re-create, it is essential to make sure that you are diligent about storing adequate backups and performing the necessary maintenance activities to keep the database operating smoothly. The necessary procedures vary depending on the type of database.

Enterprise Database Maintenance

When you choose to store analysis information in an enterprise database, a database administrator must perform backups and database maintenance activities using the data management tools that are packaged with and/or designed for the database platform (e.g., SQL Server Enterprise Manager for SQL Server). Each individual organization typically establishes its own procedures for protecting the data stored in the Oracle or SQL Server databases. As a convenience for users who wish to explore the possibilities of an enterprise database implementation without making a large investment of time and resources, instructions on how to perform the minimum database maintenance recommendations are posted on the ReliaSoft website:
Chapter 2: Repositories and Projects


See https://www.reliasoft.com/using-oracle-enterprise-databases for Oracle.

Standard Database Maintenance

When you choose to store analysis information in a standard database, it will be subject to the same limitations and vulnerabilities as any other file that uses the Microsoft Access® database file format. For example, the maximum file size is ~ 2GB, maximum number of concurrent users is 255, etc. In addition, some specific database vulnerabilities are discussed in a Microsoft publication at http://support.microsoft.com/kb/283849/EN-US/. As this publication states:

"Microsoft Jet, the database engine that is used in Microsoft Access, is a file sharing database system. When Microsoft Jet is used in a multi-user environment, multiple client processes are using file read, write, and locking operations on a shared database. Because multiple client processes are reading and writing to the same database and because Jet does not use a transaction log (as do the more advanced database systems, such as SQL Server), it is not possible to reliably prevent any and all database corruption." [emphasis added]

Although our developers have made every effort to reduce or eliminate the possibility that the software will induce a database error, there is no way to absolutely prevent corruption that might be caused by other factors, such as faulty network hardware, an unexpected "crash" on your computer or a network interruption. Therefore, this section provides some recommendations for standard precautions that all users can take to protect the data in their standard databases from this type of corruption and reduce the impact of the data loss if corruption is unavoidable.

1. **Create backups regularly.** As with any resource that contains a large amount of valuable information that would be difficult to re-create, it is essential to make sure that you are diligent about creating and storing backup files. There are a number of ways this can be accomplished:

   - If you select **Automatically back up database upon closing** from the Backup/Check Out Options page of the Application Setup, the ReliaSoft desktop application that you use to open the database will back up the database every time you close the file.
   - If you have a database open and choose **File > Save As**, the application will create a copy of the database to a pathname/filename of your choosing.
   - If you browse to the database file (*.rsr19) in one of the Windows file management tools (such as My Computer or Windows Explorer), you can copy and paste the database file as needed.
2. **Compact and repair regularly.** Using the "Compact and Repair" feature will help to reduce the size of the database file and help to protect against problems with the operation of the database. If you have the database open and it is not currently in use by another user, you can initiate the process by at any time by choosing **File > Manage Repository > Compact and Repair.**

3. **Do not store the database in a shared network location if you suspect that your network connection and/or hardware may be unreliable.** According to Microsoft, faulty network hardware is one of the main reasons why a file that uses the Microsoft Access database file format may become corrupted. As the Microsoft publication at [http://support.microsoft.com/kb/283849/EN-US/](http://support.microsoft.com/kb/283849/EN-US/) states:

   "The cause can be one or more links in the hardware chain between the computer that the database resides on and the computer that has the database open. This list includes, but is not limited to, network interface cards, network cabling, routers, and hubs.

   Hardware-based corruption is typically indicated by .mdb files that cannot be restored through the use of compacting, repairing, or Jetcomp. **Hardware corruption will typically recur until the responsible hardware is repaired or replaced.**" [emphasis added]

   If you have experienced this type of corruption for a standard database file, it is recommended that you take steps to correct the network problem or refrain from accessing database files over the network. In such cases, you may choose to use an enterprise database instead (i.e., Oracle or SQL Server), which would be less vulnerable to network interruptions. Alternatively, you could keep multiple analysis projects together in a single shared standard database file but ask users to export the analysis to a separate "working" database on their own computers when there is a need to make substantial modifications. Users could then import the data back into the shared database after the modifications have been completed.

4. **Do not allow the file size of the database to grow too large.** Performance will be affected by the size of the database and the number of simultaneous users. Therefore, it is important for users to monitor the sizes of their database files and take steps to export the data into several smaller and more manageable files if they become too large. Please be aware of the following factors, which can lead to very large database files:

   - Failure to compact and repair the database on a regular basis.
Using a very large number of attached documents. In some cases, using a link instead of an attachment may provide equivalent functionality with a much smaller impact on the size of the database file.

If you try to open a standard database via the software and receive a message that says "Unable to open the database," this is an indication that the database file may have become corrupted. Please contact Technical Support and provide as much information as possible about exactly what you were doing when the corruption occurred. Whenever possible, please provide a copy of the corrupted file. In some cases, we may be able to provide assistance with salvaging some or all of the affected data. However, in many cases, the best recourse may be to restore the latest backup from before the corruption occurred.

**Restore Points**

In all ReliaSoft desktop applications, you can create and manage *restore points* (formerly called "project baselines") for any analysis project. Within the context of these applications, the phrase "restore point" refers to an exact replica of the project at a particular point in time (i.e., a backup) that can be restored when and if it is needed. A restore point will include all the data that the project contained at the time the restore point was created, including information about the project properties, security settings and project owner.

There are a variety of ways that this functionality could be used, depending on your particular analysis process and data management requirements. For example, if you are about to begin a major revision to an existing project, you could choose to archive the original version as a restore point and then proceed with updating the project. This would ensure that the active projects in the database contain only the most recent information but also provide easy access to a fully editable copy of the previous version of the analysis if it is ever needed.

**Create a Restore Point**

You can create a restore point for a project at any time by choosing **Project > Management > Restore Point > Create Restore Point** or by right-clicking the name of the project in the **project list** and choosing the command on the shortcut menu.

In a secure database, this is available only if the user is the **project owner** or has the "Create restore points" permission.

*IMPORTANT*: When you create a restore point, any global, reference and FMEA resources used in the project are converted to local resources and stored with the backup. This ensures that you will have access to these resources upon restoration, regardless of what may have happened to those resources in the interim.
Chapter 2: Repositories and Projects

**Restore a Project**
To restore all data from an existing restore point, use the *Restore Project* command. This opens the Restore Project window, which displays a list of all existing restore points for the project, if any. You have two options:

- **Overwrite existing project** uses the restore point to roll back the current project to the earlier state. The restore process will complete as long as the project is not currently in use by another user. There is no undo for project overwrites. Therefore, it would be prudent to create a new restore point for the project before you overwrite it with one of the older restore points.

- **Create new project** uses the restore point to create a new project. You may enter a unique name for the new project. When the restore process completes, the new project will be accessible from the project list.

**Manage all Restore Points in the Database**
To manage all the restore points that have been created in the database, choose *File > Manage Repository > Restore Points*. (In a secure database, this is available only for users who have all three "manage all projects" permissions.)

This opens the Restore Points window, which displays the details for each of the restore points.

- To create a new restore point, click the *Create* button then select the project you want to back up. Enter any notes that are appropriate to describe the purpose or the circumstances of the restore point and click *OK*.

- To delete an existing restore point, select the row and click the *Delete* button or press DELETE. *There is no undo for delete.*

- To create a new project that restores all of the data from an existing restore point, select the row and click the *Restore Project* button. You will be prompted to specify a unique name for the new project.
Chapter 3: Desktop Application Interfaces

Most ReliaSoft desktop applications have their own Multiple Document Interfaces (MDIs) that provide full-featured support for the relevant analysis methods. (The exceptions are Weibull++/ALTA and BlockSim/RENO, which can display both applications in a shared MDI.)

When you are using multiple ReliaSoft applications simultaneously, different applications will open in separate MDIs but they can all connect to the same database, and even to the same analysis project.

All ReliaSoft MDIs share a common structure, which includes the following elements.

Ribbon and Backstage View

The ribbon at the top of the MDI replaces the toolbars and menus of previous versions of the software. The ribbon is divided into tabs that organize commands into logical groups. Some tabs will always be available (such as File, Home, etc.) while others are contextual and will appear only when you are working on a particular task.

The first tab, the File tab, provides access to a special type of interface called the Backstage view. This is where you will create and open databases, manage settings that apply to the entire database, access the Help Center, etc.

Project Manager and My Portal

The Project Manager allows you to manage the projects within the current database and, for many ReliaSoft applications, it also allows you to manage all of the folios, diagrams, reports, attachments, etc. in the currently open project(s). This panel is docked on the left side of the MDI and pinned by default. ("Pinned" means that the entire panel is always visible unless you decide to hide or "unpin" it.)

My Portal provides quick access to messages, assigned actions and other information that may be of personal interest to you while working in the Synthesis Platform. This panel is docked on the right side of the MDI and unpinned by default. ("Unpinned" means that only a small tab will be visible in the interface unless you move the pointer over the tab to make the entire panel visible.)

For both of these MDI features, you can decide whether the panel will be visible and how it will be positioned in the interface. (See Show, Tile, Dock and Pin Panels.)
Tip: If desired, you can change the overall color scheme used in the MDIs for all ReliaSoft desktop applications on your computer. Use the Skins drop-down list on the Synthesis Settings page of the Application Setup to select the style you prefer.

Status Bar
As an example, the following picture shows the status bar at the bottom of the MDI for an enterprise database:

For more information about the connection speed indicator, see Enterprise Repository Connection Speed.

Show, Tile, Dock and Pin Panels
In all ReliaSoft desktop applications, the MDI includes a Project Manager panel and a My Portal panel. You can decide whether each panel will be displayed and how it will be positioned in the interface at any given time.

Show or Hide
To show or hide the Project Manager panel, choose View > Project Manager and toggle the Show Project Manager command on or off.


You can also hide either panel by clicking the X at the top of the window.

Tile or View One Page at a Time
In all ReliaSoft desktop applications, My Portal consists of four pages. You have the option to view one page at a time (and use large buttons or small icons at the bottom of the panel to switch between pages) or tile the pages so that more than one page can be visible at the same time. To specify your preference, choose View > My Portal and toggle the Tile My Portal command on or off.
When applicable, these same options are available for the Project Manager panel. Choose **View > Project Manager** and toggle the **Tile Project Manager** command on or off. (This command is not available in applications such as XFMEA, RCM++, RBI and MPC, which have only a single page in the Project Manager.)

As an example, the first picture shows the My Portal panel when it is not tiled. The second picture shows the tiled panel, with two of the four pages expanded to be visible at the same time.

When the panel is not tiled, you can drag the horizontal splitter bar up to display large buttons or down to display small icons.

When the panel is tiled, you can use the handle buttons to expand or collapse each page.
Dock or Float
For both panels, you have the option to dock the panel on the left, right, top or bottom side of the MDI. When the panel is docked, it cannot be moved but you can change the width (if docked left or right) or height (if docked top or bottom) by dragging the edge to the desired position.

Alternatively, you can choose to float the panel as a window that can be resized and dragged to any location on the desktop.

There are several ways to set the docking position:

- Choose View > Project Manager > Dock Project Manager and then choose the desired option.

The same options are available when you choose View > My Portal > Dock My Portal.

- If the panel is currently floating:
  - Double-click the window's title bar to return it to the most recent docked position.
  
  OR

  - Click the window's title bar and drag it onto one of the location icons that become visible while you are moving the window. When the window is correctly positioned, blue shading will show where the window will be docked when you release the mouse button. (Note that the window's title bar must be exactly positioned above one of these location icons before the blue shading appears. If you don't see blue shading, the panel will not be docked when you release the mouse button.)
If you prefer to float the window, you can:

- Choose either:
  - View > Project Manager > Dock Project Manager > Floating Project Manager
- Double-click the title bar of the docked panel.
Pinned or Unpinned
When docked, both panels can also be toggled between pinned and unpinned states by clicking the pushpin icon in the panel's title bar. When the pushpin in the icon is vertical , the panel is pinned and will be displayed at all times.

When the pushpin is horizontal , the panel is unpinned. A tab will be displayed at the docking location for each unpinned panel.

The behavior for unpinned panels is as follows:

- If you point to the tab, the panel displays only until you point to something else.
- If you click the tab, the panel stays displayed until you click something else.
- When a panel is unpinned, it cannot be undocked or moved.

As an example, the following picture shows the Project Manager panel docked on the left side of the MDI, unpinned and hidden, while the My Portal panel is docked on the right side of the MDI, unpinned and visible (either because the user moved the pointer over or clicked the tab).
Project Manager

The Project Manager provides the tools you need to browse or search for a particular project or analysis folio in a Synthesis repository. Depending on the application, the Project Manager consists of either one or two pages:

- In all ReliaSoft desktop applications, the project list displays all the projects in the current database. (For XFMEA, RCM++, RBI and MPC, this is the only page available in the Project Manager).

- In Weibull++, ALTA, BlockSim, RENO, RGA and Lambda Predict, the Open Project(s) page of the Project Manager (i.e., the current project explorer) displays all the analysis folios, reports and other items in the current project(s) that apply to the software you are using.

There may be up to five nodes in the project list, indicating the sharing status of the projects: **Private**, **Public** or **Reference** projects, **Locked** projects and **Checked Out** projects. Additionally, the **Recycle Bin** is shown in the project list.

Each node may be further broken down by **project category** and/or by project owner. This ensures that projects will be organized in a logical, manageable way within the project list.

**Opening a Project**

To open an existing project, double-click the project name or select the project and choose **Project > Management > Open Project**.

**Note:** Remember that each project may contain items from any ReliaSoft application but you will see only the items that are relevant for the application you are currently working with (e.g., Weibull++ analysis folios are visible only when the project is opened in Weibull++). Common items, such as **project attachments**, are visible from all applications.

**Filtering the List of Projects**

The project list can utilize the same **project filters** that are available in many other locations throughout ReliaSoft desktop applications. For example, with the filter shown below, the project list will show only projects belonging to Department B.

<table>
<thead>
<tr>
<th>Project List</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Department B</td>
<td></td>
</tr>
<tr>
<td>Find:</td>
<td></td>
</tr>
</tbody>
</table>
Chapter 3: Desktop Application Interfaces

This feature might be particularly useful for an enterprise database that may be used to store analysis projects for the entire organization in a single centralized location. In such cases, the number of projects displayed in the project list could become overwhelming and these filters provide the ability to display only those projects that are of interest to you at any given time.

To remove the filter, select Show All from the drop-down list.

**Searching for a Particular Project**

You can also search for projects by entering text in the Find field. The project list updates dynamically to show only the projects with names that contain the text that you have entered. As an example, the following picture shows a quick way to find all of the projects for a particular product line by using the project names instead of predefined categories or other filter criteria.

![Current Project Explorer](image.png)

**Current Project Explorer**

In all ReliaSoft desktop applications except XFMEA, RCM++, RBI and MPC (which use the system hierarchy to manage all of the different analyses in a given project), the Open Project(s) page of the Project Manager allows you to manage all of the relevant project items (e.g., folios, diagrams, etc.) in the project(s) that are currently open.

Applications that use the current project explorer can have multiple projects open at the same time. (See Working with Multiple Projects.)

*Note:* Remember that each project may contain items from any ReliaSoft desktop application but you will see only the items that are relevant for the application you are currently working with (e.g., Weibull++ analysis folios are visible only when the project is opened in Weibull++). Common items, such as project attachments, are visible from all applications.
Filtering the Project Items
The current project explorer can utilize the same item filters that are now available in many other locations throughout ReliaSoft desktop applications. (This provides more flexibility than the Filter based on creator feature in prior versions.)

For example, with the filter shown below, the current project explorer will show only items created by Joe User and updated within the current month.

To remove the filter, select Show All from the drop-down list.

Opening Items
Double-click an item to open that item in the MDI or to bring that item to the front of the MDI if it is already open. (Note that if you double-click an attachment that appears in the current project explorer, it will open in its corresponding application, as long as that application is installed on your computer.)

Tip: In all ReliaSoft applications, projects can be shared by multiple users and the current project explorer may display an "in-use" icon to indicate the status of an item that can't be edited because it is currently locked or being edited by another user. (See Status Indicators.)

Adding Items
You can add items to the project by right-clicking the relevant folder and choose an appropriate command on the shortcut menu that appears.

Editing, Renaming, Duplicating or Deleting Items
To manage existing items within the project (i.e., Edit Item, Rename Item, Duplicate Item and Delete Item), right-click the item and choose a command from the shortcut menu or select the item and use the commands in the Current Item group on the Project tab of the ribbon.
Sub-Folders and Drag and Drop
In addition to the top-level folders that are fixed for each application, you also have the ability to create your own custom sub-folders to organize project items (the exception being the Attachments folder, which you cannot add sub-folders to). To add a custom sub-folder, right click any existing folder and choose Add Folder on the shortcut menu.

You can also arrange custom sub-folders and project items by dragging them to the desired location. Dragging a folder or project item onto a folder will place it into the bottom of that folder. Dragging a folder or project item onto a project item will place it in the same level above that item.

Working with Multiple Projects
ReliaSoft desktop applications that use the current project explorer (i.e., Weibull++, ALTA, BlockSim, RENO, RGA and Lambda Predict) can have multiple projects open at the same time. To enable this functionality, select the Allow multiple projects (project explorer) check box on the Synthesis Settings page of the Application Setup.

Tip: There is a separate setting that controls the ability to have multiple projects open in XFMEA/RCM++/RBI.

When you have more than one project open, the projects will be shown in the current project explorer with the most recently opened project at the top. Note that the icon shown beside each project indicates whether it is a public, private or reference project and, when applicable, whether it is locked or checked out.

<table>
<thead>
<tr>
<th></th>
<th>Unlocked, Not Checked Out</th>
<th>Locked</th>
<th>Checked Out</th>
</tr>
</thead>
<tbody>
<tr>
<td>Public Project</td>
<td>![Icon]</td>
<td>![Icon]</td>
<td>![Icon]</td>
</tr>
<tr>
<td>Private Project</td>
<td>![Icon]</td>
<td>![Icon]</td>
<td>![Icon]</td>
</tr>
<tr>
<td>Reference Project</td>
<td>![Icon]</td>
<td>![Icon]</td>
<td>N/A</td>
</tr>
</tbody>
</table>
In addition to the convenience of being able to view analyses from multiple projects, having multiple projects open allows you to transfer data between the projects quickly and easily. Specifically:

- For any item that can be imported/exported between projects, you can simply drag the item (analysis, multiplot, report, etc.) from the source project to the appropriate folder in the destination project. This opens the Export window, where you can just click Export to finish the export, or add more items to export before you finish the process.
- In Weibull++, ALTA and RGA, data can be copied from an analysis in one project and pasted to an analysis in another project.
- In BlockSim and RENO, blocks can be copied from a diagram in one project and pasted to a diagram in another project, according to the following rules:
  - If the block uses resources that are local to the source project, they will also be copied and added to the destination project.
  - If a resource of the same name exists in the destination project, the name of the copy will be incremented (e.g., if "Model1" already exists, the new copy might be renamed to "Model1_1").
  - If a model is associated with a data source (e.g., a model published from a Weibull++ folio), the model is copied into the destination project as a model with the association removed.
  - If the block uses resources that are global or in a reference project, they will not be duplicated. They will retain their original reference to that global/reference resource.
  - Subdiagram blocks cannot be copied and pasted across projects.

**Note:** The FMRA view is not available in BlockSim when you have multiple projects open.

### My Portal

In all ReliaSoft desktop applications, *My Portal* provides quick access to messages, assigned actions and other information that may be of personal interest to you while working in the Synthesis Platform. (When you first activate the software, My Portal will be "docked" on the right side of the MDI and "unpinned." Move your mouse pointer over the tab to make the panel visible at any time. For other options, see Show, Tile, Dock and Pin Panels.)
If your organization chooses to implement a web-based SEP portal for an enterprise database, you can also access many of these same features — as well as selected metrics, reports and other details from specific analyses — from any web-enabled device.

**Portal Messages**

The Synthesis Platform’s messages feature provides a convenient way to communicate with other database users. Messages are displayed in a "timeline" format similar to social media websites like Facebook®.

These messages are displayed both in My Portal (in any ReliaSoft desktop application) and in the SEP web portal (if it is implemented for your database).

All database users will be able to view their own messages. In a secure database, the following permissions are required to create, edit or delete messages:

- **Create portal messages** allows you to create new messages, and edit or delete the messages you have personally created.

- **Manage all portal messages** allows you to edit or delete any messages that are visible to you. This includes any message for which you are the creator or one of the recipients.

**Message Display Options**

The messages timeline will display all messages that were created by or addressed to you. You can sort the message threads in two ways:

- **Newest Active** considers the dates/times of both the main messages and the replies.

- **Newest Message** considers only the dates/times of the main messages.

**Create, Edit, Delete or Reply to Messages**

In ReliaSoft desktop applications, you can access the message commands from the My Portal tab of the ribbon, and by right-clicking inside the Messages page of the panel.
Note that the purpose of the **Refresh Messages** command is to update the display with any new messages that were recently added or changed by another database user.

**Message Recipients**
You can specify whether a message will be visible to all database users or only to specific users or groups. If you select Selected Groups/Users, you can choose from two lists: user groups that have been predefined in the database and/or individual user accounts.

If a valid SMTP server has been defined for the database, you can select the **Also send this via e-mail** check box to send an e-mail copy of the message to the recipient(s). (See **Enable Alerts via E-mail or SMS**.)

**Actions in My Portal**
Your team can use actions to track specific assignments that need to be performed. These versatile resources can be used multiple times in different locations, if appropriate. This may include actions in Project Plans, FMEAs or Test Plans, as well as actions that are independent of any particular analysis or plan.

This topic discusses how to view and manage actions via My Portal in any ReliaSoft desktop application. If you want to view/manage all action records, see **Actions Explorer** or **Resource Manager**. For information about the action properties and other general considerations that apply wherever the action may be used, see **Action Resources**.

**Actions Displayed in My Portal**
The Actions page in **My Portal** (and in the **SEP** web portal) display action records that:

- Need to be reviewed by you.
• Are relevant to you in some way and are:
  • **Past Due** – the completion date has passed.
  • **Due Next 7 Days** – the completion date occurs within the next 7 days.
  • **Past Start Date** – the start date has passed.
  • **Start Today** – the start date is today.
  • **Start Tomorrow** – the start date is tomorrow.
  • **Start Next 7 Days** – the start date occurs within the next 7 days.
  • **In Progress** – the actual start date has been entered and the action is not yet "Past Due" or "Due Next 7 Days."

If the action is not used in the Project Planner, this will be based on the planned start/completion dates. But if the action is used in a plan, it’s based on the expected dates (which can shift automatically if there are recorded delays in prior gates/actions).

Also note that if an action fits under more than one heading, it will display under the more urgent one. For example, if the action is both due in the next 7 days and past the planned start date, it will show under "Due Next 7 Days."

**Create, Edit or Delete Actions from My Portal**
In ReliaSoft desktop applications, you can access the portal actions commands from the **My Portal** tab of the ribbon, and by right-clicking inside the **Actions** page of the panel.

**Tip:** If an action doesn’t fit the My Portal display criteria for your computer/username (see details below), the new record won’t be displayed in your portal after you create or edit it. In such cases, you can use the **Actions Explorer** or **Resource Manager** to access the record.
Add to Outlook Calendar
The Add to Outlook Calendar command will be enabled if Microsoft Outlook is installed on your computer.

It launches Outlook’s interface for creating a new calendar event and automatically populates the subject and date. You can modify the details as needed before saving the new event to your calendar.

Note that you may need to give focus to the Outlook application in order to see the window.

Refresh Actions
The Refresh Actions command updates the display with any new actions that were recently added or changed by another database user.

Action Display Settings
To specify your personal preferences for displaying actions in My Portal (stored per computer/username), right-click inside the panel and choose Action Display Settings.

An action may be relevant to you in one or more of the following ways. Use Show Actions to specify which actions to display.

- I am responsible for
  - You are assigned in the Person Responsible field.

- I am a team member in
  - You belong to the team assigned in the Team field.

- I need to review/approve
  - You are assigned in the Reviewer field.

- I am monitoring
  - You are assigned in the Action Monitors window, or you have personally subscribed to “watch” the action.

- I am the creator
  - You are listed in the Created By field.
Chapter 3: Desktop Application Interfaces

If you select **Display ‘Show Actions’ labels in portal**, the panel will also include headings that indicate how the action is relevant to you.

```
<table>
<thead>
<tr>
<th>I am responsible for</th>
</tr>
</thead>
<tbody>
<tr>
<td>Past Due</td>
</tr>
<tr>
<td>Action that is overdue.</td>
</tr>
</tbody>
</table>
```
```
<table>
<thead>
<tr>
<th>Past Due</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action that is overdue.</td>
</tr>
</tbody>
</table>
```

Finally, you can choose to **Sort by Start Date** or **Sort by Due Date** within each node of the display.

**Tip:** If an action is relevant to you in more than one way, it will display if any applicable relevance check box is selected. If you are using relevance headings, the action will display under the first selected heading that fits. For example, if you are both the person responsible and the creator, and all relevance options are selected, the action will display under "I am responsible for." Alternatively, if only the creator relevance is selected, it will display under "I am the creator."

**Action Explorer**
The **Action Explorer** command opens a flexibility utility that allows you to explore all of the action resources that are stored in the current database. You can use it to filter, sort, add, edit or delete actions. (See [Action Explorer](http://mpc.reliasoft.com).)

Note that when you return to the Actions page in My Portal, you will need to use the **Refresh Actions** command to view any changes.

**Repository Users List**
The repository users list shows all active user accounts in the database, and identifies which of those users are currently connected to the database with any of the ReliaSoft applications.

This list is displayed both in **My Portal** (in any ReliaSoft desktop application) and in the **SEP web portal** (if it is implemented for your database).

In ReliaSoft desktop applications, you can access the users list commands from the **My Portal** tab of the ribbon, and by right-clicking inside the **Users** page of the panel. Similar commands are available in the SEP web portal, if applicable.
My Profile opens the User Login and Contact Information window, which allows you to edit the contact information associated with your user account.

Refresh Users updates the list to reflect any recent changes in user activity.

Project Plan Summary in My Portal
In all ReliaSoft desktop applications except MPC, the Project Plan Summary page in My Portal provides a summary of the plan for the current project, if applicable.

The summary in My Portal always reflects the entire plan for the current project, based on the actual date/time from your computer. If you want to see the summary for a particular gate or action, or to estimate what the statuses would be for a different date, you must use the Project Planner window.

- Choose Project > Management > Project Planner.

- Click the link in the project name bar at the top of the summary in My Portal.
How to Read the Summary
The plan summary in My Portal provides the following information at-a-glance. (For details, see Project Plan Summary Panel.)

<table>
<thead>
<tr>
<th>Project Current Date</th>
<th>By default, this shows the current date, which is used to determine the status (e.g., “Missed Start Date”), resource usage to date, etc. Use Refresh to obtain the latest information from the Project Planner.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto Tuesday, March 24, 2015</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>FMEA (Chandelier)</th>
<th>The top bar displays name of the project that the summary applies to. Click the link to open the project in the Project Planner. The next two rows show the expected dates and any actual dates, and the last row shows the status.</th>
</tr>
</thead>
<tbody>
<tr>
<td>EXPECTED 3/23/2015 4/10/2015</td>
<td></td>
</tr>
<tr>
<td>ACTUAL 3/23/2015 -</td>
<td></td>
</tr>
<tr>
<td>In Progress</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Progress</th>
<th>This is the percentage of the total duration of dependent actions/gates that is complete. For example, if Action 1 (duration = 3 days) is complete and Action 2 (duration = 1 day) is incomplete, the progress is 75%.</th>
</tr>
</thead>
<tbody>
<tr>
<td>33%</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Resource Usage</th>
<th>For resource usage, the black bars show the planned man hours and costs. The colored bars show either the expected usage to date (estimated based on the number of days in progress), or the actual usage if complete. (See Costs and Man Hours.)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Man Hours</td>
<td>Planned: 112.0 34.0</td>
</tr>
<tr>
<td>Costs</td>
<td>Planned: $5,500.00 $2,300.00</td>
</tr>
</tbody>
</table>

- Yellow = In progress and usage to date is still within plan
- Orange = In progress and usage to date has exceeded plan
- Green = Complete and actual usage was within plan
- Red = Complete and actual usage exceeded plan
Chapter 3: Desktop Application Interfaces

Displays only if actions have been assigned to the project or gate (either directly or via dependent gates).

- **Not Started** = Actions that have not started and can complete on time
- **In Progress** = Actions that are in progress and can complete on time
- **Completed** = Completed actions that have been approved, or don't require approval
- **Past Due** = Actions that have not completed and can no longer complete on time

**Folios**

**Data Sheets**

The data sheets in Weibull++/ALTA and RGA folios share some common components and features. The following picture shows the basic components of a data sheet using one particular format as an example.
Chapter 3: Desktop Application Interfaces

- **Caption** shows the name of the folio and the name of the sheet that is currently displayed.

- **Name Box** shows the location of the currently selected cell by listing the column letter and row number that intersect at the cell's location.

- **Data Entry Bar** shows the contents of the selected cell, which may be text, a numerical value or a formula. For text or numerical values, you can enter/edit the information directly inside the cell or inside the data entry bar. For a formula, you must use the data entry bar for editing; the cell will display only the calculated value.

- **Row Headings** identify the row numbers. Each data sheet contains up to 65,536 rows. The application's speed of execution is inversely proportional to the number of data rows in the current data set.

- **Column Headings** indicate the titles of the columns. To rename a heading, right-click it and choose **Rename Column**. When applicable, you can save the column titles and use them as the default headings for all new data sheets of the current type. (See **Default Column Headings**.)

- **Sheet Tabs** represent the different sheets within the folio. To rename a sheet, double-click the tab. The number of folios that can be opened at once depends on the amount of memory of your system (up to a maximum of 256 for some folio types).

**Default Column Headings**

In life data (Weibull++), life-stress (ALTA) and growth data (RGA) folios, creating a new data sheet automatically applies default column headings that are generally appropriate for the
analysis. If there are certain types of data that you frequently use (e.g., miles-to-failure, cycles-
to-failure, etc.), you can customize the column headings to always use your preferred column
titles.

To modify the defaults for a particular data type, first rename the column headings in an
existing data sheet. Right-click the heading and choose Rename Column on the shortcut menu.
Then save the new titles as the defaults. In Weibull++, choose Life Data > Format and View >
Set Headers as Default. (In ALTA, the command is in the Life-Stress Data tab; in RGA, it's in the
Growth tab.)

These preferences are saved for the current computer/username, and will be applied the next
time you create a new data sheet for that particular data type.

To apply the new default headings to an existing analysis, open the data sheet and choose [Life
Data/Life-Stress Data/Growth Data] > Format and View > Apply Default Headers.

If you ever need to restore the default column headings back to the shipped settings, choose
File > Application Setup, then click Reset Application Settings or Reset All Settings on the Reset
Settings page.

**Resizing Columns**

Column widths are set to span evenly by default. If you want to resize and have the changes
saved with the folio, right-click a column heading and choose Column Width Style > Default.

To resize a column, drag the edge of the heading to the desired position, or right-click it and
choose Column Width.

**Entering Formulas in the Data Sheet**

Data sheets in Weibull++, ALTA and RGA allow you to enter formulas in columns that do not
require entries to be dates, times or text (e.g., you cannot use formulas in the State F or S
column in a Weibull++ life data folio, or in the Classification column in an RGA growth data
folio). For example, in a Weibull++ life data folio, if you have a data set where the units were
inspected every 24 hours, you can speed up data entry by creating a formula to add 24 hours to
the previous inspection time, as shown next.
There are two types of cell references (locations) when inputting a formula: absolute and relative. By default, the cell reference is relative, meaning that as a formula is copied and pasted to other cells, the cell references in the formula will be adjusted to reflect the new relative location. In the previous figure, the formula in cell C2 is copied and pasted into cell C4. This changes the cell reference in the formula from "=C1+24" to "=C3+24"; therefore, the time value in C4 is 72+24 = 96.

In contrast, an absolute reference does not change when the formula is copied to other cells. Absolute references are designated by placing a dollar sign ($) in front of the row and/or column to be made absolute. If the formula in the example were rewritten to "=$C$1+24", then copying the formula to cell C4 would retain the cell reference to C1 and the time value in C4 would be 24+24 = 48.

**Change Units**

In Weibull++, ALTA and RGA, you have the ability to define the units used for the data set and calculations. For example, if your data set contains failure times in hours, you now have the option to perform calculations using different time units such as years, months, days, etc. The software performs the unit conversion automatically. Authorized users can define the units that will be available for use in any project within the database and set up the conversion factors.

The units are displayed in the heading of the relevant column in the data sheet. If you wish to change the units of an existing data sheet, click the Change Units icon on the Main page of the control panel.
In the Change Units window, the units that are currently being used in the data sheet will be displayed at the top of the window. In the **Change Units To** field, you can choose any other defined unit to be used in the data sheet. In the **Conversion Options** area, specify what will happen when the units are changed:

- You can convert the existing data to the new units. For example, if you had a time of 10 in a data sheet that was using hours, that time would become 600 if you converted the data to minutes (10 hours x 60 minutes per hour = 600 minutes). For Weibull++ life data, ALTA life-stress data and RGA growth data folios, when this option is selected, you can select whether you want to copy the data to a new sheet in the folio and then perform the conversion, leaving the original data sheet unchanged, or convert the data in the current sheet.

- You can leave the data unchanged and just apply the new units. This would be appropriate if, for example, you had entered all of your data and then realized that the data sheet was using different units from the original units in which the times were measured.

### General Spreadsheets

General Spreadsheets can be inserted into a Weibull++ life data folio, ALTA life-stress data folio or RGA growth data folio. They provide the same spreadsheet capabilities that are available in the spreadsheet module in [Synthesis Workbooks](#), but are stored together with an analysis folio. You may prefer to use this reporting tool if you are performing custom calculations based on the data sheets in the same folio and you wish to keep the analyses together with their source data.

To add a General Spreadsheet to a folio, right-click the data sheet tab area (the area at the bottom of the window that shows the name of the data sheets in the folio) and choose **Insert General Spreadsheet** on the shortcut menu. This command also appears on the ribbon tab for the particular type of data folio. For example, to insert a general spreadsheet into a Weibull++ life data folio, you can choose **Life Data > Folio Sheets > Insert General Spreadsheet**.

### Inserting Data Source Functions

To build and insert functions that utilize a referenced analysis (data source), click a cell in the general spreadsheet and choose **Sheet > Sheet Actions > Function Wizard**.
Chapter 3: Desktop Application Interfaces

The following picture shows the most complex configuration as an example:

For the function arguments:

- Brackets [ ] indicate that the input is optional.
- You can use cell references as inputs. For example, instead of entering 1000 for the Age input, you could specify to use whatever time is currently entered into cell A10, using either the relative reference (A10) or the absolute reference ($A$10). (See Cell References.)
- You can also use variable names as inputs. (See Defined Names.)

For the data source:

- Click the Select button and then select which data sheet in the folio to use as the data source.
- Any time you make changes to the data source, the general spreadsheet will need to be recalculated to reflect the most current results. Choose Sheet > Format and View > More Settings > Recalculate Formulas. The general spreadsheet may return "N/C" if the data source needs to be recalculated.
**Inserting Math Functions**

To add math, date, logic and other functions, click a cell in the general spreadsheet and choose **Sheet > Sheet Actions > Insert Function**.

![Function Arguments](image)

Select a function from the drop-down list and click **OK**. You can enter inputs for the function arguments by either selecting the cells in the sheet or typing them directly into the appropriate field.

**Referencing a Data Source**

Some functions (e.g., `AMEAN`, `D_COUNT`, etc.) require you to reference a particular data source.

To reference a data source, use the following syntax, with the quotes and exclamation marks (!). You can only reference sheets in the same folio.

"Application!Folio!DataSheet"

In the following example, the data source is a data sheet called "Data1" in the Weibull++ folio called "Folio1".

**Control Panels**

Many of the analysis folios, diagram sheets and other interfaces in ReliaSoft desktop applications utilize a control panel that allows you to make required inputs, initiate the desired analysis or simulation and view/access applicable results. This topic describes some features that are common to most control panels. (For XFMEA, RCM++, RBI, MPC and Lambda Predict, see **System Panel and Analysis panel** instead.)
Switching Between Pages
Many control panels and navigation panels contain multiple pages that vary depending on the type of analysis. You can switch between pages by clicking either the large buttons or the small icons at the bottom of the panel.

If you drag the horizontal splitter bar to the bottom of the control panel, all of the pages will be accessed by small icons. If you drag it as far up as it will go, all of the pages will be accessed by large buttons.

Hiding or Displaying a Control Panel
The control panel can be toggled between hidden and displayed states by clicking the Hide or Show icon in its title bar.

When the control panel is hidden, only the title bar and page icons will be visible on the right side of the window (as shown next using a Weibull++ folio as an example). When you click the bar, the active page will be displayed temporarily. When you click anywhere outside of the control panel page, it will be automatically hidden again.
Identifiers Page
The Identifiers page of the control panel allows you to enter identifying details (e.g., category, name, part number, etc.) that will be associated with the analysis and any models or SEP summaries that are published from the analysis. This will help you to find, filter and group analyses and resources throughout the repository.

In folios that can have multiple data sheets, the Folio Identifiers are edited via the Item Properties window, and the Data Sheet Identifiers can be entered directly in the control panel. Use an asterisk (*) if you want the data sheet’s identifiers to be the same as the folio’s (see Identifiers).

Publishing Page
The Publishing page allows you to view and manage information from the current analysis that is shared throughout the Synthesis Platform.

- **Model/Fitted Model** – publishes a model based on the current analysis. See Publishing Models.
Chapter 3: Desktop Application Interfaces

- **SEP Summary** – publishes a summary of the current analysis to the SEP web portal. This is visible only if the enterprise database is configured for SEP and you have the "Publish to SEP web portal" permission. See [Publishing to SEP](http://mpc.reliasoft.com).

- **Metrics** – shows all of the metric resources that are associated with the current analysis. See [Showing Metrics in Folios/Diagrams](http://mpc.reliasoft.com).

**Notifications Page**

When applicable, the Notifications page provides information on the **Current Status** of the analysis, along with any warnings or errors. A green light indicates that the folio has been analyzed, and a red light indicates that the folio has not been analyzed since changes were last made. The **Latest Notifications** area displays any warnings and errors generated during analysis.

**Utilized Resources Page**

In BlockSim only, the Utilized Resources page displays a grouped list of all of the **resources** that are used directly by blocks in the diagram (i.e., not applied via any other resource or tool).

For example, a **URD** that is assigned to a block will be displayed in this list, but the **model** assigned to the URD will not be shown, nor will any **tasks** assigned to the URD. Similarly, if a block belongs to a maintenance group, that maintenance group will be shown in the list. However, if a block has a state change trigger, the maintenance group(s) used for that trigger will not be shown unless some block in the diagram belongs to them.

This list is not updated automatically; if you have made changes to the diagram, click the **Refresh** icon to update the list.
Double-click a resource in the list to open its properties window for viewing or editing. Click the Resource Manager icon to view/manage all of the resources available in the project.

System Panel and Analysis Panel
Some ReliaSoft applications use two convenient panels to manage all of the analysis information in a particular project (XFMEA, RCM++, RBI and MPC) or in a particular prediction folio within the project (Lambda Predict).

The first panel (called the System panel or the System Hierarchy panel) allows you to build simple or complex multi-level configurations that contain the items you plan to analyze. The second panel (called the Analysis panel or the Properties panel) contains all of the properties and analyses for the item that is currently selected.

This topic discusses the ways in which you can configure the layout of these two panels to fit your particular workspace preferences.

Change Orientation
You can display the panels side-by-side or with one panel above the other.

To switch between layouts, choose View > Workspace Layout > Change Orientation.

Resize a Panel
You can resize the panels by dragging and dropping the vertical (or horizontal) separator into the desired position.
 Hide a Panel
You can also completely hide either panel so that the other can fill the available space. Choose View > Workspace Layout > Hide [System Panel/System Hierarchy] or [Analysis Panel/Properties].

When you wish to return to the two-panel layout, choose the Split Panels command.

Expand or Collapse Nodes
When the panel presents data in a hierarchical tree configuration (e.g., the system hierarchy, FMEA hierarchy, etc.), the View tab provides several flexible options for expanding and collapsing the nodes (branches) that are currently displayed.

To expand or collapse all branches at the same time, choose Expand Tree or Collapse Tree.

To expand or collapse a specific branch, you can click the + or - icons, or select the item and choose Expand Node or Collapse Node.

To collapse all branches in the tree to a specific level, select any item at the desired level and choose Collapse to Level.
As an example, the following pictures show how the hierarchy collapses to the second (subsystem) level.

![Subsystem Diagram](image)

**Selecting Which Columns to Display**

When applicable, you can hide, display or reorder the columns shown in a particular type of hierarchy by right-clicking any column heading and choosing `Customize Columns`. These settings are stored per computer/username, and different users may have different display preferences without affecting the stored data. The same preferences can also be managed from the relevant page of the Application Setup.

**Printing**

ReliaSoft desktop applications offer different printing utilities for data sheets, diagrams, plots and Synthesis Workbooks.

**Data Sheets and Diagrams**

To print a data sheet or diagram, choose `File > Print` or press `CTRL+P` on the keyboard. You will see a preview of the printed page, and can choose to print or to access page setup options.

When printing an RBD or fault tree in BlockSim, clicking the `Print` button on this page will open the Print Diagrams window, where you will be able to choose whether to print only the `Current` diagram (and possibly its subdiagrams on separate pages) or to choose multiple diagrams from the current project to print. If you choose to print the current diagram and its subdiagrams, you can select `Print subdiagram page number` to include the starting page number for each subdiagram in the caption of the relevant subdiagram block.

To print an XFMEA, RCM++ or RBI diagram (e.g., FMEA block diagrams, etc.), choose `Home > Print > Print`. 
Chapter 3: Desktop Application Interfaces

Plots
To print a plot, choose File > Print or press CTRL+P on the keyboard.

To print a plot displayed in the Plot Viewer (as seen in XFMEA, RCM++, RBI and Lambda Predict), click the Print icon on the plot control panel.

Synthesis Workbooks
To print Synthesis Workbooks, choose View > Print > Print Preview. For more printing options, you can send the report to Microsoft Word or Excel and use the print utilities in those applications. Choose Home > Report > Send to Excel or Send to Word.

Reports Generated in Word or Excel
In XFMEA, RCM++, RBI, MPC and Lambda Predict, reports are generated in Microsoft Word or Excel. You will need to use the print utilities built in to those applications.

Other Features
For other features that offer the print functionality (e.g., RS Draw, Resource Manager, etc.), the Print icon will be displayed in the window itself.

Page Setup - Plots and Diagrams
The Page Setup for plots and diagrams is accessible via the print window (see Printing).

Maximize Printing Space
The following options are available on the Page tab or Margins tab of the Page Setup.

- **Orientation.** The Portrait orientation works best for small charts and diagrams. If the image is wider than it is tall (which is the case for most plots), select the Landscape orientation.

- **Keep aspect ratio** (available for plots). Select this option to maintain the proportional relationship between the width and height of the image. Clear the check box if you want to stretch the image to fill the paper.

- **Scaling** (available for diagrams) allows you to shrink or enlarge a diagram to fit a specified number of pages. For example, to print a diagram to four pages in a rectangle, you would enter the values 2 by 2 pages. The software will automatically adjust the size of the diagram image to fit to the specified pages.

- **Print without interior margins** is used for printing images that span multiple pages, so that the pages can be assembled into a whole picture. It removes as
much margin space as possible from the interior edges of each page, where it
meets the other pages.

- **Print empty pages** prints any blank pages within the print area; otherwise, the
  blank pages are omitted from the printout.

- **Margins.** By default, the margins will be printed based on the **System’s default** option,
  which is the measurement system specified in your computer’s **region and language
  settings**. You can change the unit to inches or centimeters as desired.

### Headers/Footers

To add custom headers/footers for printing, click the **Header/Footer** tab of the Page Setup.

To insert variable information such as date, time, number of pages, etc., use the command
icons in the window to insert the appropriate field codes (or use the codes shown in the table
below).

<table>
<thead>
<tr>
<th>Field Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;A</td>
<td>Inserts the sheet name. (Does not apply to plots in XFMEA, RCM++, RBI and Lambda Predict.)</td>
</tr>
<tr>
<td>&amp;D</td>
<td>Inserts the current date.</td>
</tr>
<tr>
<td>&amp;T</td>
<td>Inserts the current time.</td>
</tr>
<tr>
<td>&amp;P</td>
<td>Inserts the page number.</td>
</tr>
<tr>
<td>&amp;N</td>
<td>Inserts the total number of pages.</td>
</tr>
<tr>
<td>&amp;ZA</td>
<td>Inserts the name of the application (e.g., Weibull++).</td>
</tr>
<tr>
<td>&amp;ZC</td>
<td>Inserts the company name.</td>
</tr>
<tr>
<td>&amp;ZU</td>
<td>Inserts the user name.</td>
</tr>
<tr>
<td>&amp;ZP</td>
<td>Inserts the project name.</td>
</tr>
<tr>
<td>&amp;ZI</td>
<td>Inserts the name of the item. (Does not apply to plots in XFMEA, RCM++, RBI and Lambda Predict.)</td>
</tr>
<tr>
<td>&amp;ZL</td>
<td>Inserts the path to the current repository.</td>
</tr>
</tbody>
</table>
Page Setup - Data Sheets
The Page Setup for data sheets is accessible via the print window (see Printing). For the spreadsheet module in Synthesis Workbooks, choose View > Print > Page Setup.

Maximize Printing Space
The following options are available on the Page tab or Margins tab of the Page Setup.

- **Orientation**. The Portrait orientation works best when the data has more rows than columns. If the data sheet is wider than it is tall, select the Landscape orientation.

- ** Scaling** allows you to shrink the font size by a certain percentage to fit the data sheet into one page, or enlarge it to span the data sheet across multiple pages.

- **Paper size** and **Print quality**. The options depend on the type of printer you use.

- **First page number** allows you to specify any number to be the starting page number.

- **Margins** adjusts the widths of the margins on the paper.

- **Center on page** allows you to center the data sheet in the printout horizontally, vertically or both.

Print Order and Other Options
The Sheet tab of the Page Setup provides more printing options:

- **Print area** allows to specify a range of cells to print. Recommended if you want to print only a specific selection of data and not the entire data sheet. For example, you could enter the range A1:B10 to print only cells A1 through B10. To print the entire data sheet, clear this field.

- **Print titles**. If your data sheet is more than one page long, you can repeat row or column titles on each printed page to make it easier to read your data. For example, to repeat the column titles of a data table that has several rows spanning multiple pages, you could enter the range $1:$1 into the **Rows to repeat at top** field, where $1:$1 is the location of the column title in the table.

- **Gridlines** prints the gridlines of a data sheet.

- **Draft quality** prints the data sheet at a lower quality for faster printing.

- **Row and column headings** prints the row numbers and column headings of the data sheet.
Chapter 3: Desktop Application Interfaces

- **Comments.** If you’ve added comments to the data sheet, you can choose to print them along with the data sheet. Choose whether to print the comments at the end of the sheet or as they are displayed in the sheet.

- **Cell errors as** allows you to specify how any cell errors in the data sheet should be displayed in the printouts. Choose whether to print them as displayed, <blank>, dashes (--) or as #/NA

- **Page order.** If your data sheet spans multiple pages, you can specify the order in which the pages are numbered and printed.
  - **Down, then over** prints from the top down, then left to right.
  - **Over, then down** prints from left to right, then from the top down.

**Headers/Footers**
The Header/Footer tab of the Page Setup provides several options for adding custom headers/footers to the printed page.

- **Header** and **Footer** drop-down lists allow you to select a predefined header/footer format. The software includes several predefined formats to choose from.

- **Different odd and even pages** and **Different first page** gives you the option to apply different headers/footers for odd and even pages, or choose to apply a different header/footer to the first page only. Select the check box for the desired option and then click the **Custom Header/Footer** button to edit the headers (see the section below). To apply the same header/footer to all pages in the document, clear the check boxes for both options.

- **Scale with document** auto-adjusts the font size to scale with the data sheet.

- **Align with page margins** auto-adjust the position of the header/footer to be consistent with the page margins.

**Edit the Headers/Footers**
You can edit the headers/footers for the current printing session. Note that the edits are discarded when you switch to different header/footer format or when you exit the print preview.

To edit an existing header/footer, choose it from the drop-down list and click the **Custom Header/Footer** button. Alternatively, you can select **none** from the drop-down list and then click the button.

To insert variable information such as date, time, number of pages, etc., use the command icons in the window to insert the appropriate field codes (or use the codes shown in the table below).
### Format Code

<table>
<thead>
<tr>
<th>Format Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;[Page]</td>
<td>Inserts the page number.</td>
</tr>
<tr>
<td>&amp;[Pages]</td>
<td>Inserts the number of pages.</td>
</tr>
<tr>
<td>&amp;[Date]</td>
<td>Inserts date.</td>
</tr>
<tr>
<td>&amp;[Time]</td>
<td>Inserts time.</td>
</tr>
<tr>
<td>&amp;[Path]&amp;[File]</td>
<td>Inserts the file path.</td>
</tr>
<tr>
<td>&amp;[File]</td>
<td>Inserts the file name.</td>
</tr>
<tr>
<td>&amp;[Tab]</td>
<td>Inserts the sheet name.</td>
</tr>
<tr>
<td>&amp;[Picture]</td>
<td>Inserts a selected picture. Click the <strong>Format Picture</strong> icon on the Header/Footer window to set the image size and other properties.</td>
</tr>
</tbody>
</table>

### Page Setup - Word Processing Module

To access the Page Setup for the word processing module in Synthesis Workbooks, choose **View > Print > Page Setup**.

#### Maximize Printing Space

The following options are available on the Margins tab or Paper tab of the Page Setup:

- **Margins** adjusts the widths of the margins on the paper.
- **Orientation**. The Portrait orientation works best when the data has more rows than columns. If the data sheet is wider than it is tall, select the Landscape orientation.
- **Paper size**. The options depend on the type of printer you use.

#### Layout

The Layout tab of the Print Setup provides more printing options:

- **Section** divides the report into several sections, where each section can have different formatting elements such as the page orientation, margins, headers/footers, etc. The easiest way to insert section breaks is to exit the Page Setup and choose **Page Layout > Page Setup > Breaks**.
• **Headers and footers.** You can choose to apply different headers/footers for odd and even pages, or choose to apply a different header/footer to the first page only. To apply the same header/footer to all pages in the document, clear the check boxes for both options.

To configure and save header/footer information into the report, exit the Page Setup and choose **Document > Header & Footer > Header or Footer.**

To set up a header/footer that applies only to the current printing session (i.e., the information will be lost when you exit the preview), exit the Page Setup and choose **View > Print > Print Preview.** In the preview window, click the **Header/Footer** icon on the ribbon. To insert variable information such as date, time, number of pages, etc., use the command icons in the window to insert the appropriate field codes (or use the codes shown in the table below).

<table>
<thead>
<tr>
<th>Format Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Page #]</td>
<td>Inserts the page number.</td>
</tr>
<tr>
<td>[Pages #]</td>
<td>Inserts the number of pages.</td>
</tr>
<tr>
<td>[Page # of Pages#]</td>
<td>Inserts date.</td>
</tr>
<tr>
<td>[Date Printed]</td>
<td>Inserts the current date.</td>
</tr>
<tr>
<td>[Time Printed]</td>
<td>Inserts the current time.</td>
</tr>
<tr>
<td>[User Name]</td>
<td>Inserts the username of the current user.</td>
</tr>
</tbody>
</table>
Chapter 4: MPC Ribbons

In ReliaSoft desktop applications, the ribbon replaces the toolbars and menus used in older software. The ribbon is divided into tabs that relate to a task or activity, such as managing the projects in a database or performing a specific type of analysis. Depending on the current activity, some commands may appear dimmed or will not appear at all.

Note that many features in the application also have a shortcut menu (accessed by right-clicking) that gives access to commands that are commonly used for that feature. All commands available in the shortcut menus are also available on the ribbon.

To minimize the ribbon and maximize your workspace, click the arrow on the right-side of the ribbon (labeled "Minimize Ribbon" in the picture below). The ribbon will be expanded when you click a tab and then minimized after you click a command.

Quick Access Toolbar
The Quick Access Toolbar is a customizable feature of the ribbon that allows you to access frequently used commands without changing tabs.

To add your favorite ribbon commands to the Quick Access Toolbar, right-click the command and select Add to Quick Access Toolbar.

To remove a command from the Quick Access Toolbar, right-click the command and select Remove from Quick Access Toolbar, or click the Customize Quick Access Toolbar icon and clear the check box for the command.

To reposition the Quick Access Toolbar, click the Customize Quick Access Toolbar icon and select to show it either below the ribbon or above the ribbon.

To reset the Quick Access Toolbar to default settings, click the Reset All Settings button in the Application Setup (File > Application Setup).
Chapter 4: MPC Ribbons

Backstage View (File Tab)

The Backstage view (File tab) is the first view you will see when you start a ReliaSoft desktop application.

Save As (available only when a standard database is currently open) saves a copy of the standard database to another pathname/filename and/or file type. You can save the file as a new standard database (*.rsr19) or compressed standard database (*.rsgz19).

Pack and E-mail (available only when a standard database is currently open) sends a compressed version of the standard database via e-mail.

Open Repository opens an existing standard database, enterprise database or compressed standard database, from the current version or any previous version. You can also open even earlier file types, depending on the application you are currently using.

Close Repository closes the database. You also can close the database by opening another database or by exiting the application.

Recent shows a list of recently opened database files (*.rsr19 and *.rserp) and a list of recently accessed locations. Clicking a database will open it, and clicking a location will allow you to browse for databases in that location. The number of items in these lists is set in the Synthesis Settings page of the Application Setup. You can pin items to a list by clicking the pushpin icon associated with the item; when the pin is vertical, the item will not roll off the list.

New allows you to create a new standard database (*.rsr19) or connection file for access to an enterprise database (*.rserp).

Manage Repository provides a variety of tools and configurable settings for the repository. The settings are shared by all users and all analysis projects in a database.

Print (available only in Weibull++, ALTA, RGA, BlockSim and RENO) generates a print preview of the current data sheet, diagram or plot, and sends it to the printer.

Help provides a variety of resources to help you use the application more effectively. In addition, it displays information about the application, including the Compile Release Version (CRV) and License information.

Application Setup allows you to set your personal preferences for working with analyses, such as the math precision, default plot settings and the like. The settings apply
only to the current computer/username, and they do not affect the results of the analyses.

Exit closes the current database (if any) and shuts down the application.

Manage Repository
The Manage Repository section of the Backstage View contains the following commands. The available commands depend on the current application and the database type.

Users
- **Users and Security** controls which users can access the repository and their permissions.
- **User Groups** create and manage groups of users that can be assigned to actions, messages, etc. throughout the current database.
- **Repository Logins** displays a list of users who have connected to the repository and allows you to export this information to Excel.
- **Reset "In Use" Flags** allows you to reset the flags that indicate the "in use" status of projects or items within a project.

Lambda Predict Repository Settings
Available only in Lambda Predict:

- **FIDES Settings Manager** defines the settings related to the FIDES prediction standard such as process audits, pi factors, categories, etc. (See [FIDES Settings Manager](#) in the Lambda Predict documentation.)

- **Custom Derating Standards Manager** allows you to add, edit, delete or import/export custom derating standards. (See [Creating Custom Derating Standards](#) in the Lambda Predict documentation.)

- **MIL-217 Custom Connections** defines custom connection types for use with the MIL-HDBK-217F prediction standard. (See [MIL-217 Custom Connection Types](#) in the Lambda Predict documentation.)
Chapter 4: MPC Ribbons

**XFMEA/RCM++/RBI Libraries**
Available only in XFMEA, RCM++ and RBI:

- **Profiles/Library Manager** configures the predefined settings of the profiles stored in the software library. Profiles allow you to customize the look, drop-down lists, rating scales and other settings of a particular project in order to fit the needs of the analysis. (See Profiles/Library Manager in the XFMEA/RCM++/RBI documentation.)

- **Templates Manager** allows you to manage the configurable templates that can be used for customized reports, saved queries or importing/exporting data via Excel. (See Templates Manager in the XFMEA/RCM++/RBI documentation.)

### Settings and Predefined Options

- **Repository Settings** allows you to enable alerts via e-mail or SMS, activate history logs, and other settings.

- **Unit Settings** defines the unit and measurement settings that will be available for use in any project within the database.

- **Project/Item Categories** defines the categories that can be used to filter and group data throughout the database.

- **Default Name Formats** (not applicable for MPC) specifies the default names for new resources, as well as new blocks in BlockSim RBDs, fault trees and phase diagrams.

- **Project Planning Resources** (not applicable for MPC) defines the cost categories, teams, materials and facilities that are used for tracking costs, man hours and resource utilization in actions and Project Planner gates.

- **Working Days/Holidays** (not applicable for MPC) specifies the business days when project planning resources can be utilized.

- **Dashboard Layout Manager** (not applicable for MPC) shows all of the predefined dashboard layouts that will be available for any user to view for a particular data set.

- **Task Types** (applicable only in RCM++, RBI and MPC) maps the task types used in RCM++ and RBI (e.g., Restoration, Failure Finding, etc.) to the corresponding task classes in the universal reliability definition (e.g., Preventive, Inspection, etc.) so that simulation and cost calculation results are accurate. (See Task Types in RCM++/RBI in the XFMEA/RCM++/RBI documentation.) In MPC, it allows you to modify the abbreviations...
used for the MSG-3 task types. (See Task Type Abbreviations in MPC in the MPC documentation.)

XFRACAS Connection is available only for standard databases (*.rsr19) in Weibull++/ALTA, RGA, and XFMEA/RCM++/RBI. It allows you to define connection settings for an enterprise repository.

Database Tools

New Enterprise Repository opens a wizard that leads you through the steps to create a new enterprise repository (SQL Server or Oracle database). To use this option, you must have access to a server with a supported version of SQL Server or Oracle and you must have the appropriate permissions to create a new database on the server.

Upgrade Enterprise Repository converts an existing Version 9 or later enterprise database to a Version 2019 enterprise database. This cannot be undone. It is recommended that you create a backup of the database before performing the upgrade.

Upgrade Version 8 Repository copies all of the existing data from a Version 8 enterprise database to a new Version 2019 enterprise database.

Restore Points manages all of the project backups that are stored in the current database.

Compact and Repair is available only in a standard database (*.rsr19). It helps to reduce the size of the database and protect against data loss and corruption. (See Backups and Database Maintenance.)

Import from Version 5 is available only in XFMEA, RCM++ and RBI. It allows you to import data from a Version 5 XFMEA/RCM++ database. This command is available only when you are connected to an enterprise database and have the "Manage users and logins" permission and the applicable "manage all projects" permissions.

Help Center

The Help Center, which is part of the Backstage view, is intended to help you use the application more effectively by providing quick access to a variety of support tools. To access the Help Center, choose File > Help.
Chapter 4: MPC Ribbons

Using This Application

Help File opens the application's help file. If you have an active Internet connection, the help topics that you see will always be the most up-to-date versions available. If you do not have an active Internet connection, the help topics that you see will be the local copy that was installed on your computer.

User Guide opens the application's User's Guide (in PDF format) if you have an active Internet connection.

Quick Tour opens the Quick Tour within the application's help file. The Quick Tour provides a brief overview of the application's features, including basic steps for performing the most common analysis types. This command is available only if the current application offers a Quick Tour.

Online Resources

reliasoft.com opens the main page of the reliasoft.com website.

weibull.com opens the weibull.com website, which is devoted entirely to the topic of reliability engineering, reliability theory and reliability data analysis and modeling.

reliawiki.org opens the ReliaWiki website, which is both a resource portal and a wiki for professionals in reliability engineering and related fields.

Examples

Open Examples Folder provides access to a set of example projects that are designed to help you explore various software features.

Technical Support

E-mail Support generates an e-mail to request technical support. The e-mail is pre-populated with information about your license and operating system, which the technical support representative will need for troubleshooting the issue.

Contact Technical Support provides the contact information you will need to obtain technical support.

Check for Update allows you to download the latest free service release for the software.

- Licensing displays your license and registration details. To view or edit additional information, click License Manager. The License Manager displays additional
information about which products you have currently registered and/or your contact information on file with us.

- **About** displays the application's Compile Release Version (CRV) (sometimes called a "build number"), which allows you to determine whether you have the latest version of the software.

## Home Tab
The Home tab contains the following commands:

### Clipboard
As with most Windows-based applications, data stored on the Clipboard can be pasted into this and other applications.

- **Paste** pastes the contents of the Clipboard into the current item or record.
- **Cut** cuts the selected text to the Clipboard.
- **Copy** copies the selected text to the Clipboard.
- **Copy Analysis** and **Paste Analysis** allow you to copy and paste the analysis (functional failure analysis, structural analysis or zonal analysis) that currently has focus in the Analysis panel.
- **Delete Analysis** deletes the analysis that currently has focus in the Analysis panel. *There is no undo for delete.*

### Edit

- **Delete** deletes the selected item or record and all associated data. *There is no undo for delete.*
- **Spelling** allows you to automatically spell check the properties of the item that is currently selected in the system/structural/zonal hierarchy. If you want to use spell check for the records in the F-F-E-C hierarchy, use the command that appears in each separate record properties window.
- **Find and Replace** allows you to find or replace specified text within the current project.
Chapter 4: MPC Ribbons

Working Group

- **Current Session Stamp** opens the Current Session Working Group Stamp window where you can view/modify the working group information that will be applied automatically to any item that you edit during the current session.

Hierarchy Defaults

- **Manage ATA Chapters** opens the Manage ATA Chapters window where you can define the systems and subsystems that are available for use in the database.
- **Manage Major Zones** is available only in MPC Plus. It opens the Manage Major Zones window where you define the zones and major sub-zones that are available for use in the database.

Synthesis

- **Launch Application** provides a drop-down list of the other ReliaSoft desktop applications that are installed on your computer. When you click an icon, the same database will automatically be opened in the new application.

My Portal Tab


Messages

- **Create Message** opens the Message window, which allows you to compose and send messages within the database.
- **Edit Message** opens the Message window, which allows you to view and edit all of the properties of the message.
- **Reply to Message** opens Message Reply window, which allows you to respond to a message sent to you.
- **Delete Message** deletes the current message.

Actions

- **Create Action** opens the Action window and adds an action to the project.
Edit Action opens the Action window, which allows you to view and edit all of the properties of the action record.

Delete Action deletes the current action record.

Add to Outlook Calendar adds an event, on the Action’s due date, to your Outlook calendar.

Users

My Profile opens the User Login and Contact Information window where you change your contact details for your user account in the current database.

Project Tab

Unless otherwise indicated, these commands apply to the project that is currently selected in the project list. There are three ways to select a project and apply a command:

- By right-clicking the project in the project list and choosing the command from the shortcut menu.
- By selecting the project in the project list and then clicking the command on the ribbon.
- By clicking anywhere inside the project that is currently open/visible and then clicking the command on the ribbon.

Note: For secure databases, access to the commands on this tab may be restricted based on the permissions assigned to the user account.

Management

Create Project adds a new project to the current database. At a minimum, you must specify the project name.

Open Project opens the selected project.

Close Project closes the project that is currently open/visible and all of the analyses it contains.

Edit Project Properties allows you to view and edit the properties of the selected project.
Chapter 4: MPC Ribbons

- **Duplicate Project** creates a copy of the selected project. The new project will have the same name as the original with an increment number added to the end (e.g., Project_1, Project_2, etc.).

- **Delete Project** moves the selected project to the recycle bin.

- **Transfer Project** is available only in XFMEA/RCM++/RBI. It allows you to create a new project with data transferred from the selected project. (See Transfer Projects in the XFMEA/RCM++/RBI documentation.)

- **Task Numbering** is available only in MPC. It allows you to specify whether or not you want to reuse task numbers within the project. (See Task Numbering in MPC in the MPC documentation.)

- **Manage Projects** opens the Manage Projects window, which allows you to edit the security settings and properties of all projects in the database in one location.

- **Import/Export** gives you the option to open either the Import or Export wizard. The Import wizard allows you to import projects, resources or items from an existing database into the current database, while the Export wizard allows you to export to a new or existing database. (See Import, Export and Data Conversion.)

- **Configurable Settings** is available only in XFMEA/RCM++/RBI. It allows you to view/modify the configurable settings for the current project. (See Configurable Settings in the XFMEA/RCM++/RBI documentation.)

- **Restore Point** gives you the option to utilize restore points, which are exact replicas of the project at a particular point in time (i.e., backups). To create a restore point for the selected project, use the Create Restore Point command. To restore all data from an existing restore point, use the Restore Project command.

- **Check In/Out** allows you to check out the selected project and make it available for editing only to you, while all other users in the database have read-only access to the project. No other user can edit the project unless you check in the project or undo the check out.

- **Recycle Bin**

  - **Empty Recycle Bin** permanently deletes all projects under the Recycle Bin heading in the project list. There is no undo for emptying the recycle bin.
Chapter 4: MPC Ribbons

**Restore Project** is available only when you have selected a project under the Recycle Bin heading. The selected project will be recovered from the recycle bin and restored to its original location in the project list.

**Delete Project** permanently deletes the selected project. *There is no undo for delete* unless you have a stored backup or restore point.

**History Log** is available only if you are the project owner or have the applicable "manage all projects" permissions. It opens the Project History Log window, which allows you to activate and deactivate the history log for the project and, if the history log is currently activated, to view changes that have been performed throughout the entire project, with any ReliaSoft application.

**Project Planner** opens the Project Planner, which provides full project planning and management capabilities for the current project. This command is not available in MPC.

**Attachments** is available only in XFMEA/RCM++/RBI and MPC. It adds linked or attached files to the selected project. In other ReliaSoft desktop applications, attachments commands are available in the current project explorer.

**E-mail Project**

**Pack and E-mail** compresses a copy of the selected project to a *.rsgz19 file and attaches it to a new e-mail message. If no e-mail program is installed or no default e-mail program is defined on the computer, a message notifying you of this will be shown.

**Security**

**Project Security** is available only for public projects in secure databases. It opens the Project Properties window with the Security tab active, where you can specify the user accounts that can view/modify the selected project.

**Change Owner** allows you to assign a different database user to be the owner for the selected project.

**Lock Project** moves the project into the Locked heading of the project list. When a project is locked, all database users (including the user who locked the project) will have read-only access to the project. In addition, a locked project cannot be deleted or have its properties and public/private status edited. To unlock a project, choose Unlock Project. (See Locked and Unlocked Projects.)
Chapter 4: MPC Ribbons

Make Private moves the selected public project into the Private heading of the project list. (See Public, Private and Reference Projects.)

Make Public moves the selected private or reference project into the Public heading of the project list.

Make Reference moves the selected public project into the Reference heading of the project list. This command is not available in MPC.

Current Item
The following commands are available when you select a specific item (a diagram, report, multiplot, etc.) in the current project explorer. This group is not available in XFMEA/RCM++/RBI or in MPC.

Edit brings the selected item to the front of the windows and activates it as the current control. If an attachment is selected, the command opens the attachment in the appropriate application, if that application is installed on your computer.

Rename allows you to rename the selected item.

Duplicate creates a copy of the selected item within the project. The duplicate will have the same name as the original with an increment number added to the end (e.g., RBD1_1, RBD1_2, etc.). In BlockSim, you can choose to Duplicate With Resources, which also creates duplicate resources in the Resource Manager window.

Delete deletes the selected item. There is no undo for delete.

Item Properties is available only for project explorer items (e.g., folios, diagrams, plots, etc.). It opens the Item Properties window, which allows you to view and edit the item's Identifiers, item settings (if applicable) and item permissions (in secure databases).

Save Locator Link is a link file (similar to a Windows shortcut) that provides quick access to the specific analysis. In an enterprise database, you can choose to Save or E-mail the file. In a standard database, the only option is to save the file. In XFMEA/RCM++/RBI, these commands are available in the System Hierarchy tab. In MPC, they are in the Systems, Structures or Zones tab.

Data Management
The following commands are available only in BlockSim.
Mirror Group Manager opens the Mirror Group Manager window, which allows you to add, view and edit groups of mirrored blocks within the project that is currently open/visible. (See Mirroring (Using Blocks in Multiple Locations) in the BlockSim documentation.)

Maintenance Group Manager opens the Maintenance Group Manager window, which allows you to add, view and edit the maintenance task groups available to the project that is currently open/visible. (See Maintenance Groups.)

Flow Group Manager opens the Flow Group Manager window, which allows you to add, view and edit the flow groups available to the project that is currently open/visible. (See Flow Groups in the BlockSim documentation.)

Reports

MRBR is available only in MPC. It allows you to generate a maintenance review board report in Microsoft Word. (See Maintenance Review Board Reports in the MPC documentation.)

View Tab

The View tab contains commands related to configuring the layout of the application's interface.

Refresh

Refresh refreshes the display in the Project window. If multiple users are accessing the same project simultaneously, this command will refresh your screen with any changes made by other users. When you make a change to the project, your window will be refreshed automatically.

Project Manager

Show Project Manager brings the Project Manager into focus. If the Project Manager is unpinned and hidden, choosing this command will display it.

Tile Project Manager tiles the project list and current project explorer so they are both displayed simultaneously in the Project Manager panel. This command is not available in XFMEA, RCM++, RBI or MPC.
Dock Project Manager opens a submenu that allows you to choose the desired position for the Project Manager: Dock Left, Dock Right, Dock Top, Dock Bottom or Floating.

My Portal

Show My Portal opens the My Portal window, which provides information relevant to your work within the database, such as messages from other users, recommended actions for a particular project item, status of other users logged in to the database and other information.

Tile My Portal tiles the Messages, Actions and Users pages so they are all displayed simultaneously within the My Portal panel.

Dock My Portal opens a submenu that allows you to choose the desired position for the Portal: Dock Left, Dock Right, Dock Top, Dock Bottom or Floating.

Workspace Layout

The commands in this group are available only in XFMEA, RCM++, RBI, MPC and Lambda Predict.

Change Orientation toggles between the two possible orientations for the System panel and the Analysis/Properties panel. These panels can be side-by-side or one on top of the other.

Hide System [Panel/Hierarchy] hides the System panel in the Project window. When you want to show the panel again, choose View > Workspace Layout > Split Panels.

Hide [Analysis Panel/Properties] hides the Analysis/Properties panel in the Project window. When you want to show the panel again, choose View > Workspace Layout > Split Panels.

Split Panels splits the Project window into two equal panels, with 50% of the available space used for the System panel and 50% of the available space used for the Analysis/Properties panel.

Properties View is available only in Lambda Predict.

Tree View organizes the properties depending on whether they are physical properties (e.g., part quality level, case type, etc.) or application properties (e.g., ambient temperature, applied voltage, etc.). Depending on the prediction standard
and component you are working with, the properties may also be organized according to failure mechanisms or type of data.

\[\pi\] **Pi Factor View** organizes the item properties based on the pi factors that they contribute to so you can see how the values affect the failure rate calculations. The relevant pi factors will vary depending on the item's failure rate model. (See the [Tree View and Pi Factor View](#) topic in the Lambda Predict documentation.)

**Expand/Collapse**

The commands in this group apply to the hierarchical view that currently has focus. Depending on the application, this can be the project list, the current project explorer, the System panel, the Properties panel (Lambda Predict only) or the Analysis panel if it is using a hierarchical view.

- **Expand Tree** expands the entire tree in the hierarchical view.
- **Collapse Tree** collapses the entire tree in the hierarchical view.
- **Expand Node** expands the selected branch in the hierarchical view.
- **Collapse Node** collapses the selected branch in the hierarchical view.
- **Collapse to Level** collapses the hierarchical view to the level of the item that is currently selected. For example, if you have selected a cause in the FMEA hierarchy view and choose this command, all branches in the FMEA hierarchy view will be collapsed to the cause level and the nodes for controls and actions will be hidden.

**Zoom**

- **Normal Zoom** sets the degree of magnification to 100%.
- **Zoom In** increases the degree of magnification.
- **Zoom Out** decreases the degree of magnification.
- **Custom Zoom** allows you to specify the degree of magnification.

**Window**

- **Use Tabbed MDI** maximizes the windows to fill the full space available in the MDI and shows a tab for each open window. If you clear this command, the open windows will be displayed as separate windows that can be resized and moved around within the MDI.
Chapter 4: MPC Ribbons

Window

- **Cascade** cascades all open project windows inside the MDI.
- **Tile Horizontally** horizontally tiles all open project windows inside the MDI.
- **Tile Vertically** vertically tiles all open project windows inside the MDI.

The **Windows** drop-down list displays a list of all project windows currently open inside the MDI. You can make any of the open project windows active by clicking its name in this ribbon.

- **Close All Windows** closes all open project windows inside the MDI, leaving only the Project Manager and My Portal panels open (if they were selected to be shown).

FMRA

The commands in this group are available only in BlockSim. (See **Failure Modes and Reliability Analysis (FMRA)** in the BlockSim documentation.)

- **Show FMRA** opens the FMRA view, which displays the FMRA (failures modes and reliability analysis) hierarchy that is associated with the project.
- **Disassociate FMRA** deletes all of the diagrams and blocks associated with the current FMRA hierarchy and closes the FMRA view.

Show

The commands in this group are available only in XFMEA, RCM++, and RBI.

- **Show FMRA** enables/disables the FMRA tab in the System panel.
- **Show Test Plan** opens the Test Plan tab in the analysis panel, which displays a list of actions that describe specific tests that need to be performed. (See the **Test Plans** topic in the XFMEA/RCM+/RBI documentation.)

Active Tabs
F-F-E-C Tab
The F-F-E-C tab is visible when you are working on a functional failure analysis.

Function
- **Add Function** adds a function to the functional failure analysis.
- **Insert Function** inserts a function above the one that is currently selected.
- **Edit Function** opens the Function Properties window, which allows you to view and edit all of the properties of the selected function record.

Failure
- **Add Failure** adds a failure to the functional failure analysis.
- **Insert Failure** inserts a failure above the one that is currently selected.
- **Edit Failure** opens the Failure Properties window, which allows you to view and edit all of the properties of the selected failure record.

Effect
- **Add Effect** adds an effect to the functional failure analysis.
- **Insert Effect** inserts an effect above the one that is currently selected.
- **Edit Effect** opens the Effect Properties window, which allows you to view and edit all of the properties of the effect record.
- **Categorization** opens the Failure Effect Categorization window, which allows you to identify and evaluate the effects of the selected functional failure.

Cause
- **Add Cause** adds a cause to the functional failure analysis.
- **Insert Cause** inserts a cause above the one that is currently selected.
- **Edit Cause** opens the Cause Properties window, which allows you to view and edit all of the properties of the selected cause record.
Task Manager opens the Task Selection window, which allows you to choose an appropriate maintenance strategy for the current failure cause.

Excel
Import FFEC from Excel allows you to import F-F-E-C data from an Excel spreadsheet.

Move
Up and Down move the selected record up or down in the functional failure analysis hierarchy view.

L/HIRF Tab
MPC Plus Only
The L/HIRF tab is visible when you are working on an L/HIRF analysis in an LHSI project (i.e., a project using one of the MSG-3 guidelines that support identification of L/HIRF Significant Items).

Add
Add System(s) opens the Select System(s) window where you select which of the predefined systems to add to the system configuration.

Add SubSystem(s) opens the Select SubSystem(s) window where you select which of the predefined subsystems to add under the system that is currently selected.

Add LHSI adds a new L/HIRF Significant Item to the item that is currently selected.

Import Systems opens the Import L-HIRF Hierarchy Items window where you can copy items from the current database or from another database into the current project.

Move
Up and Down move the selected item up or down in the L/HIRF hierarchy.

Security
Item Permissions is available only for secure databases. It allows you to prevent specific users from editing the item and its related analyses. (See Item Permissions,)
Chapter 4: MPC Ribbons

Tools

Renumber Items allows you to renumber the ATA numbers for the LHSIs to start from 1 either for all LHSIs below the selected system or for all LHSIs in the current hierarchy.

Attachments allows you to manage the linked or attached files for the selected item. This includes any Description & Operation (D&O) documents that you want to integrate into generated reports.

Configurable Options opens the Configurable Options window where you can customize some of the settings for the standard zonal, enhanced zonal and L/HIRF analyses that you can perform in this database.

Status Updates allows you to record additional information about the item that can be accessed during the analysis but will not appear in the report output (e.g., reasons for certain decisions, status of the analysis, etc.).

History Log is available only if a history log has been activated at the project level. It opens the Record History Log window for the current item and displays changes that have been performed for the item.

Save Locator Link creates a link file (similar to a Windows shortcut) that provides quick access to a specific item.

Reports

Reports allows you to generate predefined L/HIRF analysis reports in Microsoft Word.

Analyses

Add ED/AD Analysis adds a lightning/high intensity radiated field (L/HIRF) Environmental Damage/Accidental Damage (ED/AD) analysis to the currently selected LHSI.

Delete Analysis deletes the analysis tab that currently has focus in the Analysis panel. There is no undo for delete.

Tasks

Add Task adds a new L/HIRF analysis task.
Chapter 4: MPC Ribbons

- **Edit Task** allows you to change the properties of the currently selected L/HIRF analysis task.

- **Delete Task** deletes the currently selected task. *There is no undo for delete.*

**Structures Tab**

➤ **MPC Plus Only**

The Structures tab is visible when you are working on a structural analysis.

**Add**

- **Add Structure(s)** opens the **Select Structure(s) window** where you select which of the predefined structures to add.

- **Add SubStructure(s)** opens the **Select SubStructure(s) window** where you select which of the predefined substructures to add under the structure that is currently selected.

- **Add SubSubStructure** adds a new sub-substructure to the substructure that is currently selected.

- **Add Structural Item** adds a new structural item.

- **Import Structures** opens the **Import Structural Hierarchy Items window** where you can copy items from the current database or from another database into the current project.

**Move**

- **Up** and **Down** move the selected structural item up or down in the structural hierarchy.

**Security**

- **Item Permissions** is available only for secure databases. It allows you to prevent specific users from editing the item and its related analyses. (See **Item Permissions**.)
Tools

**Attachments** allows you to manage the linked or attached files for the selected item. This includes any Description & Operation (D&O) documents that you want to integrate into generated reports.

**Configurable Options** opens the Configurable Options window where you can customize some of the settings for the environmental deterioration (ED) and accidental damage (AD) analyses that you can perform in this database.

**Status Updates** allows you to record additional information about the item that can be accessed during the analysis but will not appear in the report output (e.g., reasons for certain decisions, status of the analysis, etc.).

**History Log** is available only if a history log has been activated at the project level. It opens the Record History Log window for the current item and displays changes that have been performed for the item.

**Save Locator Link** creates a link file (similar to a Windows shortcut) that provides quick access to a specific item.

Reports

**Reports** allows you to generate predefined structural analysis reports in Microsoft Word.

**Custom Reports** allows you to generate predefined reports in Microsoft Word or Excel for any of the structural analyses in the current project.

**Queries** allows you to search the project or database for the records that meet your specific query criteria. The results can be exported to Excel and you also have the option to save and reuse queries.

Analyses

**Add ED (Metals)** and **Add ED (Non-Metals)** add an Environmental Deterioration analysis to the currently selected SSI.

**Add AD Analysis, Add AD (Metals)** and **Add AD (Non-Metals)** add an Accidental Damage analysis to the currently selected SSI. The project configuration determines whether the project will evaluate metallic and non-metallic materials in the same analysis or evaluate them separately.
Chapter 4: MPC Ribbons

**Add FD/SL Analysis** adds a Fatigue Damage analysis to the currently selected SSI.

**Delete Analysis** deletes the analysis tab that currently has focus in the Analysis panel. *There is no undo for delete.*

**Materials**

**Add New Material** adds a new material to the currently selected ED (Metals) analysis or ED (Non-Metals) analysis.

**Add Existing Materials** allows you to copy the properties from, or link directly to, an existing material.

**Edit Material** allows you to change the properties of the currently selected material.

**Delete Material** deletes the currently selected material. *There is no undo for delete.*

**Tasks**

**Add Task** adds a new structural analysis task.

**Add Existing Tasks** allows you to copy the properties from existing tasks in the current project.

**Edit Task** allows you to change the properties of the currently selected structural analysis task.

**Delete Task** deletes the currently selected task. *There is no undo for delete.*

**Systems Tab**

The Systems tab is visible when you are working on a systems and powerplant analysis.

**Add**

**Add System(s)** opens the Select System(s) window where you select which of the predefined systems to add to the system configuration.

**Add SubSystem(s)** opens the Select SubSystem(s) window where you select which of the predefined subsystems to add under the system that is currently selected.
**Add SubSubSystem** adds a new sub-subsystem to the subsystem that is currently selected.

**Add Part** adds a new part to the item that is currently selected.

**Import Systems** opens the [Import System Hierarchy Items window](#) where you can copy items from the current database or from another database into the current project.

**Move**

![Up and Down](image)

**Move** **Up** and **Down** move the selected part up or down in the system hierarchy.

**Security**

**Item Permissions** is available only for secure databases. It allows you to prevent specific users from editing the item and its related analyses. (See [Item Permissions](#).)

**Tools**

**Renumber Parts** allows you to renumber the ATA numbers for parts to start from 1 either for all parts below the selected item or for all parts in the current hierarchy.

**Attachments** allows you to manage the linked or attached files for the selected item. This includes any Description & Operation (D&O) documents that you want to integrate into generated reports.

**Check MSI Analysis** opens the [Check MSI Analysis window](#) where you can compare the answers to the maintenance significant item (MSI) selection questions against the failure effect categorizations (FECs).

**Configurable Options** opens the [Configurable Options window](#) where you can enable/disable some of the item properties and task properties fields. Note that disabling the fields only makes them invisible in the interface; those fields are still displayed in the report templates.

**Status Updates** allows you to record additional information about the item that can be accessed during the analysis but will not appear in the report output (e.g., reasons for certain decisions, status of the analysis, etc.).

**History Log** is available only if a history log has been activated at the project level. It opens the [Record History Log window](#) for the current item and displays changes that have been performed for the item.
Save Locator Link creates a link file (similar to a Windows shortcut) that provides quick access to a specific item.

Reports

MSI Report allows you to generate a print-ready report in Microsoft Word for one selected maintenance significant item (MSI).

Custom Reports allows you to generate predefined reports in Microsoft Word or Excel for any of the systems and powerplant analyses in the current project.

Queries allows you to search the project or database for the records that meet your specific query criteria. The results can be exported to Excel and you also have the option to save and reuse queries.

Zones Tab

The Zones tab is visible when you are working on a zonal analysis. The commands available in the Zones tab will vary depending on whether you are working with an LHSI project (i.e., a project using one of the MSG-3 guidelines that support identification of L/HIRF Significant Items) or a non-LHSI project (i.e., a project using one of the MSG-3 guidelines that do not support identification of L/HIRF Significant Items).

Add

Add Major Zone(s) opens the Select Major Zones window where you select which zones to add.

Add Major Sub-Zone(s) opens the Select Major Sub-Zones window where you select which sub-zones to include under the major zone that is currently selected.

Add Zone adds a new zonal item.

Import Zones opens the Import Zones window where you can copy items from the current database or from another database into the current project.

Security

Item Permissions is available only for secure databases. It allows you to prevent specific users from editing the item and its related analyses.
Tools

Attachments allows you to manage the linked or attached files for the selected item. This includes any Description & Operation (D&O) documents that you want to integrate into generated reports.

Configurable Options opens the Configurable Options window where you can customize some of the settings for the standard zonal, enhanced zonal and L/HIRF analyses that you can perform in this database.

Status Updates allows you to record additional information about the item that can be accessed during the analysis but will not appear in the report output (e.g., reasons for certain decisions, status of the analysis, etc.).

History Log is available only if a history log has been activated at the project level. It opens the Record History Log window for the current item and displays changes that have been performed for the item.

Save Locator Link creates a link file (similar to a Windows shortcut) that provides quick access to a specific item.

Reports

Reports allows you to generate predefined zonal analysis reports in Microsoft Word.

Custom Reports allows you to generate predefined reports in Microsoft Word or Excel for any of the zonal analyses in the current project.

Queries allows you to search the project or database for the records that meet your specific query criteria. The results can be exported to Excel and you also have the option to save and reuse queries.

Analyses

Add Standard Zonal Analysis adds a standard zonal analysis to the currently selected zone.

Add Enhanced Zonal Analysis adds an enhanced zonal analysis to the currently selected zone.

Add L/HIRF Analysis is available only for non-LHSI projects. It adds a lightning/high intensity radiated field (L/HIRF) analysis to the currently selected zone.
**Delete Analysis** deletes the analysis tab that currently has focus in the Analysis panel. *There is no undo for delete.*

**L/HIRF Protection**
These commands are available only for non-LHSI projects.

- **Add Protection System** adds a new protection system to the L/HIRF analysis.
- **Edit Protection System** allows you to change the properties of the currently selected protection system.
- **Delete Protection Systems** deletes the currently selected protection system. *There is no undo for delete.*

**Tasks**
- **Add Task** adds a new zonal analysis task.
- **Edit Task** allows you to change the properties of the currently selected zonal analysis task.
- **Delete Task** deletes the currently selected task. *There is no undo for delete.*
- **Transfer Zonal Candidate Tasks** allows you to copy the properties from existing GVI tasks in the current project that have been marked as ZIP candidates.
Chapter 5: All MSG-3 Analyses

This chapter discusses several common features that are similar in all MSG-3 analyses and/or must be determined up-front for the entire database.

For features that are specific to a particular type of analysis, see Systems and Powerplant Analysis, Structural Analysis or Zonal and L/HIRF Analysis.

Time Units

In MPC, the units (defined in the Unit Settings window) can be used in the Interval field for maintenance task records, if desired. Some of the reasons why you might choose to define the task interval with a number and unit (instead of a text field that places no constraints on how users type information):

- May increase the likelihood that task intervals will be defined consistently (i.e., if users always enter a value and select the units from a drop-down list, it will be less likely to have inconsistent abbreviations for entered data – 100 flight hours, 100 flt/hrs, 100 flight hrs., etc.).
- Makes it easier to sort tasks by interval.
- Gives you the ability to import the analysis project into RCM++ or RBI so that you can perform more flexible, data-based maintenance analysis.

Tip: When you convert an existing analysis project from MPC 3, the Tasks Conversion window allows you to decide whether the imported tasks will continue to define the intervals in text fields or if you prefer to convert the existing records to use numerical values with predefined time units.

Task Type Abbreviations in MPC

In MPC, the task types defined for the database must be consistent with the task selection logic specified in the MSG-3 guidelines. This means that it is not possible to add or delete task types, nor can the names be changed. However, because there is some variability among MSG-3 practitioners regarding the abbreviations used, the software does provide the option to modify the abbreviations, if desired.

To define the task type abbreviations, choose File > Manage Repository > Task Types.
Managing ATA Chapters

When you add a system/subsystem for systems and powerplant analysis or L/HIRF analysis, or a structure/substructure for structural analysis, you will be prompted to select from a predefined list. This ensures that the maintenance significant item (MSI) and structural significant item (SSI) numbers used in each analysis comply with the numbering scheme established by the Airlines for America (A4A).

The software provides a predefined list of chapters (aka systems or structures) and sections (aka subsystems or substructures) that are based on the latest iSpec 2200: Aircraft Systems document published by the Airlines for America. In a secure database, only users with the "Manage MPC settings" permission have the ability to modify this list for the current database. Any changes to this master list will apply to all analysis projects in the same database.

To open the Manage ATA Chapters window, choose Home > Hierarchy Defaults > Manage ATA Chapters.

The left panel shows the list systems/structures, while the right panel shows the subsystems or substructures for the one that's currently selected.

Each item is defined by an ATA # and a Description. For chapters, the check marks indicate which type(s) of analyses can be performed. Specifically:

- If a check mark appears in the Systems Analysis column, the item will be included in the list when users build the system hierarchy for aircraft systems and powerplant analysis and the L/HIRF hierarchy for L/HIRF ED/AD analysis in LHSI projects.
- If a check mark appears in the Structural Analysis column, the item will be available when users build the structural hierarchy for aircraft structural analysis.
To edit the properties for an existing item, double-click the row or select the row and click the corresponding **Edit** button. To add a new item, click the **Add** button. To delete an existing item, select the row and press **Delete** or click the **Delete** button.

**What's Changed?** In MPC 3, the ATA numbers for subsystems had to be identified in multiples of 10 (i.e., 10, 20, 30, 40, etc.). In the current version, the software allows you to use any number. However, if you add a subsystem/substructure number that is not a multiple of 10, you will not be able to add sub-subsystems or sub-substructures in that branch of the hierarchy. In other words, if you enter 15, the application treats this as a sub-subsystem/sub-substructure, even if it is located in the second level of the tree.

If you click the **Set as default for future repositories** button, the application will save the settings to the MPCDefaults.mpd19 file on your computer (C:\User\USERNAME\My Documents\ReliaSoft\MPC19). Any new databases that you create from this computer will use these saved customized settings by default.

**ATA Numbers**

The traditional ATA numbering scheme requires that second level numbers be entered in multiples of 10. In addition, the third level numbers are defined within the range specified by its parent (e.g., for the subsystem/substructure with the number 10, the numbers 11 through 19 are valid for the sub-subsystems/sub-substructures).

The ATA Number used in reports consists of at least four numbers, where the first two numbers are determined by the system/structure, the third number is determined by the subsystem/substructure and the fourth number is determined by the sub-subsystem/sub-substructure. For example, ATA # 231500 represents the following configuration:

- **System** = 23 Communications
- **Subsystem** = 10 Speech Communications
- **Sub-subsystem** = 15 SATCOM

You can also use the extended format, where the first two numbers are determined by the system/structure, the third and fourth numbers are determined by the subsystem/substructure and the fifth and sixth numbers are determined by the sub-subsystem/sub-substructure. For the example given above, this would be 231015. Specify which format you want to use in the MPC Application Setup.
Managing Major Zones

Managing Major Zones

When you add a major zone or major sub-zone for zonal lightning/high intensity radiated field (L/HIRF) analysis, you will be prompted to select from a predefined list. This ensures that the zonal numbers used in each analysis comply with the numbering scheme established by the Airlines for America (A4A), where the numbering scheme requires that the major zones be numbered 100 to 900 and that the major sub-zones be numbered X10 to X90 (i.e., 110 to 190, 210 to 290, etc.)

The software provides a predefined list of zones and major sub-zones that are based on the latest iSpec 2200: Aircraft Systems document published by the Airlines for America. In a secure database, only users with the "Manage MPC settings" permission have the ability to modify this list for the current database. Any changes to this master list will apply to all analysis projects in the same database.

To open the Manage Major Zones window, choose Home > Hierarchy Defaults > Manage Major Zones.

The left panel shows the list of major zones, while the right panel shows the major sub-zones for the one that’s currently selected.

Each item is defined by a Zone # and a Description.

To edit the properties for an existing item, double-click the row or select the row and click the corresponding Edit button. To add a new item, click the Add button. To delete an existing item, select the row and press Delete or click the Delete button.

If you click the Set as default for future repositories button, the application will save the settings to the MPCDefaults.mpd19 file on your computer (C:\User\USERNAME\My Documents\ReliaSoft\MPC19). Any new databases that you create from this computer will use these saved customized settings by default.

Configurable Options

Configurable Options for Systems and Powerplant Analysis

For some of the item and task properties in aircraft systems and powerplant analysis, you have the option to decide whether the field will be displayed in the interface.
To open the Configurable Options for Systems and Powerplant Analysis window, make sure the System Hierarchy tab has focus then choose **Systems > Tools > Configurable Options**.

(In a secure database, this option is only available for users with the "Manage MPC settings" permission.)

In the Visible column for each property, click inside the cell to toggle between Yes and No.

*Note:* If a property that is hidden in the interface appears in one of the predefined report formats (e.g., Standard, Dassault or Sukhoi), the label will still appear in the report but it will not contain any data.

Select the **Require time units for 'MTBF' and 'MTBUR' properties** check box if you want to enter **time units** with the historical and predicted MTBF (mean time before/between failure) and MTBUR (mean time between unscheduled removals) fields. This makes it easier to review and sort the data in the reports.

If you click the **Set as default for future repositories** button, the application will save the settings to the MPCDefaults.mpd19 file on your computer (C: \ User \ USERNAME \ My Documents \ ReliaSoft \ MPC19). Any new databases that you create from this computer will use these saved customized settings by default.

**Configurable Options for Structural Analysis**

*MP Plus Only*

The Configurable Options for Structural Analysis window allows you to customize some of the settings for the environmental deterioration (ED), accidental damage (AD) and fatigue damage (FD) analyses that you can perform for any structural item. These preferences apply to all **aircraft structural analyses** in the current database.

To access the window, make sure the Structural Hierarchy tab has focus and choose **Structures > Tools > Configurable Options**.

(In a secure database, this option is only available for users with the "Manage MPC settings" permission.)
Chapter 5: All MSG-3 Analyses

Ratings Page
The options on this page allow you to configure the damage types, rating scales and score matrices used for each type of structural analysis. For environmental deterioration analysis, there are different options for metal vs. non-metal ("composite") materials.

For accidental damage analysis, the same damage types and rating scales are used for types of materials. The AD analysis always covers the Possibility of Damage and the Visibility of Damage. An option on the Settings page specifies whether to also consider the Residual Strength and Sensitivity to Damage Growth.

As an example, to configure the basic options for AD analysis without residual strength and damage growth:

- **Accidental Damage Types** sets the list of accidental damage types that users will be asked to rate for any AD analysis performed in the current database.

- **Possibility of Damage** and **Visibility of Damage** set the labels that will be used in the rating scales. (An option on the Settings page determines whether the rating scales will have three or four points.)

- **Overall AD Rating** sets the matrix that will be used to convert these ratings into an overall score. For example, with the settings shown next, the matrix assigns a score of 6 if both the possibility of damage and visibility of damage are assigned to the lowest ratings. You can change the score labels to fit the particular rating system used by your organization.
Settings Page

Type of Accidental Damage (AD) Analysis

Perform a common AD analyses for all materials - there will be one tab (and one ribbon command) for accidental damage (AD) analysis in the current database.

Perform separate AD analyses for metals and non-metals - there will be two tabs (and two ribbon commands).

Even if you decide to separate the analysis for metals vs. non-metals, the damage types, rating scales and scoring matrix will be the same in both tabs (as specified on the Ratings page).

Number of Rating Points

Your selection determines whether the rating scales used in the environmental deterioration (ED) and accidental damage (AD) analyses will be configured to provide three or four ratings in each drop-down list and scoring matrix.

Other Settings

You can choose whether to hide/display some additional analysis options that are available.

Enable Fatigue Damage analysis - shows the Add FD/SL Analysis command in the Structures ribbon. See Fatigue Damage Analysis.

Each of the following options shows/hides an additional rating and scoring matrix for a particular type of environmental deterioration (ED) or accidental damage (AD) analysis. If the option is selected, you can configure the relevant labels and scores on the Ratings page.

- Require 'Detectability Rating' when performing ED analysis for metal materials
- Require 'Composition Rating' when performing ED analysis for composite materials
- Require 'Residual Strength Rating' and 'Damage Growth Rating' when performing AD analysis

Properties Page

For some of the structural and task properties you have the option to decide whether the field will be visible in the interface.

In the Visible column for each property, click inside the cell to toggle between Yes and No.
Set Defaults for Future Repositories

If you click the Set as default for future repositories button, the application will save the settings to the MPCDefaults.mpd19 file on your computer (C:\User\USERNAME\My Documents\ReliaSoft\MPC19). Any new databases that you create from this computer will use these saved customized settings by default.

Configurable Options for Zonal and L/HIRF Analysis

The Configurable Options window for zonal and L/HIRF analyses allows you to customize settings that apply to all zonal analyses and/or L/HIRF analyses in the current database.

To access the window in a non-LHSI project (i.e., a project using one of the MSG-3 guidelines that do not support identification of L/HIRF Significant Items), make sure the zonal hierarchy has focus and choose Zones > Tools > Configurable Options.

In an LHSI project (i.e., a project using one of the MSG-3 guidelines that support identification of L/HIRF Significant Items), the options for zonal analyses are configured separately from the options for L/HIRF analyses. To access the window for zonal analyses, make sure the Zonal hierarchy has focus and choose Zones > Tools > Configurable Options. To access it for L/HIRF analyses, make sure the L/HIRF hierarchy has focus and choose L/HIRF > Tools > Configurable Options.

(In a secure database, these commands are available only for users with the "Manage MPC settings" permission.)

Ratings Page

Equipment Installed sets the list of options for the drop-down list on the Zonal item properties.

The remaining options allow you to configure the damage types, rating scales and score matrices used for each type of zonal or L/HIRF analysis.

As an example, to configure the options for L/HIRF analysis in a non-LHSI project:

- **Susceptibility to Damage Types** and **Hostility of Environment Types** set the lists of damage/hostility types that users will be asked to rate for any L/HIRF analysis performed in the current database.

- **Susceptibility to Damage** and **Hostility of Environment** set the labels that will be used in the rating scales. (An option on the Settings page determines whether the rating scales will have three or four points.)
• **Hostility of Environment/Susceptibility to Damage** sets the matrix that will be used to convert the ratings into an overall score for the L/HIRF analysis. For example, with the settings shown next, the matrix assigns a score of 3 if both the susceptibility to damage and hostility of environment are assigned to the lowest ratings. You can change the score labels to fit the particular rating system used by your organization.

![Susceptibility to Damage Matrix](image)

**Settings Page**

**Tasks Numbering**
You can choose whether to prefix the zonal task numbers with additional values.

- **Prefix Task # with ATA #, Major Zone # and Zonal Inspection #, if applicable (e.g., 53-100-01-141-001)** - Includes information from the zonal properties with the Task # in reports.

- **Prefix Transfer Reference Task # with MSI, SSI, L/HIRF or EZAP (e.g., SSI 53-40-04-002)** - Includes information about the source of a task that has been transferred to a standard zonal analysis in the Transfer Reference # field.

**Tasks Numbering Sequence**
Your selection determines whether the task numbers will be based on the zone number only without regards to the analysis type or on the zone number and the analysis type.

**Standard Analysis Number of Rating Points**
Your selection determines whether the rating scales used in the standard zonal analysis will be configured to provide three or four ratings in each drop-down list and scoring matrix.

**Enhanced Analysis Number of Rating Points**
Your selection determines whether the rating scales used in the enhanced zonal analysis will be configured to provide three or four ratings in each drop-down list and scoring matrix.
Chapter 5: All MSG-3 Analyses

**L/HIRF Analysis Number of Rating Points**
This option is available only in non-LHSI projects. Your selection determines whether the rating scales used in the L/HIRF analysis will be configured to provide three or four ratings in each drop-down list and scoring matrix.

**Properties Page**
For some of the item and task properties you have the option to decide whether the field will be visible in the interface.

In the Visible column for each property, click inside the cell to toggle between Yes and No.

**Set Defaults for Future Repositories**
If you click the *Set as default for future repositories* button, the application will save the settings to the MPCDefaults.mpd19 file on your computer (C:\User\USERNAME\My Documents\ReliaSoft\MPC19). Any new databases that you create from this computer will use these saved customized settings by default.

**Working Group Stamps**
A working group stamp will be stored for every item in the system, structural, zonal or L/HIRF hierarchy. It is intended to contain information about the most recent working group that performed analysis for that item and the date of the last update. This information will be displayed in the Properties tab.

*Tip:* The working group stamp can be modified by the user and therefore it may not reflect the actual history of when the items were last edited in the database. For that purpose, use the History properties that are recorded automatically (and individually) for every hierarchy item and every record in the F-F-E-C.

The following picture shows how the working group information is displayed in the Properties tab for a selected hierarchy item.
There are two ways to update the working group stamps that are stored for individual items:

- The application will update the stamp automatically for a particular item when you make a change to any part of the analysis associated with the item. The changes applied to the item's stamp will be determined based on the information that is currently defined in the Current Session Working Group Stamp window.

- You can use the Current Item Working Group Stamp window to manually update the data stored for selected items.

Regardless of whether you are editing the Current Session Working Group Stamp or the Current Item Working Group Stamp, the properties are the same:

- Use the Working Group and Working Group Date fields to enter the working group name and the date they are working on the project.

- When applicable, use the ISC Approval and ISC Approval Date fields to enter the name of the Industry Steering Committee (ISC) that approved the analysis and the date they approved it.

- Specify the database version information in the Revision/Issue field. This can be either a number (e.g., "1") or text (e.g., "DRAFT").

- Use the Current Analyst field to specify the user who is currently making the changes and the Date field to record when the changes were applied. In the "Current Session" window, these properties will be set automatically based on your database login and the current date. When you are using the "Current Item" window to manually edit the details for a particular item, you can specify the user name and date.

  Starting in Version 2018, only active users are shown in this list. If a saved user is currently inactive, that user will also be shown in the list.

Starting in Version 2018, you can remove items from the drop-down lists for the Working Group, ISC Approval and Revision/Issue fields by selecting the unwanted item and clicking the X icon. You must have the relevant "Manage all projects" permissions to remove items from the lists.

**Current Session Working Group Stamp - Automatic Updates**

If the Show working group stamp window upon open option is selected in the MPC Application Setup, then each time you create or open a database in MPC, you will be prompted to define the working group stamp for the current session.

By default, the Current Session Working Group Stamp window will contain the information that was defined the last time you used MPC on this computer. You can make any changes that may
be appropriate for the current session and then these properties will be applied automatically to any hierarchy item that you add or edit while that stamp is active. The automatic update will be triggered by any change to the item properties.

If the option is not selected, the information stored in the "Working Group Info" section will be the same as that from the last time the information was updated. Note that if you update a record, the Analyst and Data fields will be updated, regardless of this option's setting.

**Tip:** If you want to change the stamp for the current session without closing and reopening the database, simply choose Home > Working Group > Current Session Stamp. The new properties will then be applied automatically to any hierarchy item that you edit after the new stamp became active.

**Current Item Working Group Stamp - Manual Updates**

You also have the option to manually change the working group stamp that has been recorded for any hierarchy item. Select the item then click the Edit icon next to the Working Group Info header in the Properties tab.

The Current Item Working Group Stamp window displays the properties that are currently recorded for the selected item. The Apply changes to area at the bottom of the window allows you to specify which items in the project should have the same change.

- **Current item** changes the stamp only for the selected item.

- **Current item and dependents** changes the stamp for the selected item and all dependent items in the current hierarchy (i.e., all other items in the same branch below the selected item).

- **All items in the current hierarchy** changes the stamp for all items in the current hierarchy. For example, if you select this option on an item in the system hierarchy, the stamps will be updated for all other systems, subsystems, sub-subsystems and parts in the current hierarchy, but the structural, zonal and L/HIRF hierarchies will not be affected.

**Status Updates**

The Status Updates window allows you to record additional information for any record in the system, structural, zonal or L/HIRF hierarchy. These notes can be accessed by the users who are performing the analysis, but they will not appear in the report output. For example, you can use this feature to record reasons for certain analysis decisions, the current status of the analysis for a particular item, questions that still need to be addressed, etc.
To view or manage the notes for a particular item, structure or zone, select the record in the hierarchy and then choose **Tools > Status Updates** on the relevant ribbon tab.

In the hierarchy, the 📒 icon indicates that at least one status note exists for the item.

**Importing MPC Hierarchies Between Projects**

For all tabs in the System panel, it is easy to import an entire hierarchy (or selected branches) from any project in the same database or another selected database.

When you are working with the system hierarchy, choose **Systems > Add > Import Systems.**

When you are working with the structural hierarchy, choose **Structures > Add > Import Structures.**

When you are working with the zonal hierarchy, choose **Zones > Add > Import Zones.**

When you are working with the L/HIRF hierarchy, choose **Systems > Add > Import Systems.**

As an example, the following picture shows the window for system hierarchy items. The windows for the structural, zonal and L/HIRF hierarchies function in a similar manner.
In the **Select Repository** area, select the data source. You can import records from the current database or a selected database. (Of course, if you have selected to import from the **Current Repository**, this list excludes the project that you are currently working with because MPC cannot permit duplicate records in the same hierarchy.) The panel on the left side of the window displays a list of all the projects in the Synthesis repository that is currently selected.

When you select a project, the panel on the right displays the hierarchy from that project. Use the check boxes to select which items you want to copy over, then click **OK** to start the import.

**Note:** If you select an item that already exists in the current hierarchy, you will be prompted to confirm that you want to overwrite the existing version with the imported material.

---

**Maintenance Review Board Reports**

For each type of analysis in MPC and MPC Plus, there is a dedicated reporting utility that generates the applicable reports. (See [Systems and Powerplant Analysis Reports](#), [Structural Analysis Reports](#) and [Zonal and L/HIRF Analysis Reports](#).)

You can also generate a report that shows all tasks in the project from all analysis types, along with a list of the affected maintenance significant items, structural significant items, zonal significant items and/or L/HIRF significant items in the project. You can also include an attached introduction document, if desired.

To generate the Maintenance Review Board Report, choose **Project > Reports > MRBR**.

Set the report options:

- **Report Logo** will display in the document header, if specified.
  
  - **Select Logo** allows you to import a *.bmp, *.dib, *.gif, *.jpg, *.wmf, *.emf, *.ico or *.cur graphic. Note that the logo will be scaled down to a maximum size of 150 x 75.
  
  - **No Report Logo** displays no logo on the printed report.
  
  - **Default Logo** displays the default MPC graphic that was shipped with the application.

- **Paper Size** specifies whether the documents will be configured for U.S. Letter or A4-sized paper.
• **Sort Tasks By** allows you to sort tasks by number, type (e.g., LUB, SVC, etc.) or interval (with most frequent tasks listed first).

• Use the **Attach doc for report intro** area to attach a Word document to the report. Each project can include one document, and that document is saved with the MRBR. When generating the report, this document is included at the beginning of the report and you can specify whether you want that document to use its own page margin settings or use the same page margin settings as the rest of the report. Note that unlike regular project attachments, you can only attach or remove the document from this window.

• **Footer Text** sets the text displayed in the footer of the report.

• Use the **Tasks options** area to select which additional fields you want included in the appropriate places in the report.

• **Use name (not abbreviation) for time units** specifies how the units for task intervals will be displayed in the report (e.g., 1000 Flight Hours or 1000 FHR).

When you click **Generate Report**, specify the pathname/filename where the report file will be saved, and then click **Save**.

### Task Numbering in MPC

Task numbers in MPC are assigned in sequential order. The first task in a particular analysis is assigned number 1, the second task is assigned number 2, and so on.

The Task Numbering window determines whether task numbers from deleted tasks will be reused within the project.

To open the window, choose **Project > Management > Task Numbering**.

### Reuse Task Numbers

By default, the **Reuse task numbers** check box will be selected. This means that:

- When you delete a task, MPC renumbers all subsequent tasks in the analysis. For example, if you have five tasks and you delete the third one, MPC renumbers the task #4 to be task #3 and renumbers task #5 to be task #4.

- MPC also reuses the task numbers from previously deleted tasks, if applicable, when you create a new task. (This is only relevant if the project was previously configured to not reuse task numbers and there are "gaps" in the sequence from tasks that were deleted under the prior setting.)
Chapter 5: All MSG-3 Analyses

Do Not Reuse Task Numbers
If the check box is cleared:

- When you delete a task, MPC does not renumber subsequent tasks.
- When you create a new task, MPC always uses the next number in the sequence. It does not reuse the numbers from previously deleted tasks.

Copy/Paste/Delete Analyses
MPC makes it easy to copy and paste analyses both within a project and between projects in the same database. This applies for functional failure analyses (F-F-E-C tab), structural analyses (ED, AD and FD/SL tabs) and zonal analyses (Zonal and L/HIRF tabs).

Copy/Paste an Analysis
To copy an analysis, open the analysis and choose Home > Clipboard > Copy Analysis.

To paste the analysis for a different item, select the item and choose Home > Clipboard > Paste Analysis.
Functional Failure Analyses (F-F-E-C Tab)
- The item must either be an MSI or be eligible to be marked as an MSI to be eligible to paste a copied analysis.
- Pasting appends the copied F-F-E-C records to the existing F-F-E-C records, if any exist.

Structural Analyses (ED, AD and FD/SL Tabs)
- The structural item must have at least one SSI selection question set to “Yes” to be eligible to paste a copied analysis.
- If an analysis of a given type already exists for the structural item, then you cannot paste another analysis of the same type.

Zonal Analyses (Zonal and L/HIRF Tabs)
- You can paste a standard zonal analysis to any zonal item.
- The zonal item must have the appropriate zonal analysis recommendation to be eligible to paste a copied enhanced zonal analysis or L/HIRF analysis.
- If an analysis of a given type already exists for the zonal item, then you cannot paste another analysis of the same type.

Delete an Analysis
To delete an analysis, right-click the tab in the Analysis panel and choose Delete Analysis. *(Remember there is no undo for delete.)*

Find and Replace
In MPC, the Find and Replace tool allows you to search and replace text records within a specified project in the current database.

You can access the tool by choosing **Home** > **Edit** > **Find and Replace**.

To use the tool, follow these steps:

1. Use the **Search** area to specify which project, analyses and/or record properties to search. If you want to search all data in the current project, choose the **All Analyses** option.
2. In the **Find Text** area choose the criterion for the match **[Contains, Begins With, is, is empty]** and enter the search text.

   As an option, you can select the **CaSe SeNsITiVe** check box to limit the results to text that have the same case. For example, the search term "teXt" will not find "Text" because the case does not match.

3. In the **Replace With** area, specify the text that will be used to replace the existing data for any matches that you select. **[Optional]**

4. Click the **Find** button. The **Matches Found** area will display a list of any records that match your search criteria. To view the details of a record, double-click it, or select the record and click the **Go To** button. The project will open with the matching record selected.

   To replace the existing text with the text that you have specified in the **Replace With** area, select the check box for each record and click the **Replace** button. To select all matched records for replacement, click the check box in the table heading.
Chapter 6: Systems and Powerplant Analysis

This chapter discusses how to record the results of an aircraft systems and powerplant analysis based on the ATA Operator/Manufacturer Schedule Maintenance Development (MSG-3) guidelines. This type of analysis uses the System Hierarchy tab on the System panel, which can be displayed on the left side or the top side of the Project window. To change the location of the panel, choose View > Workspace Layout > Change Orientation.

The steps involved for an aircraft systems and powerplant analysis include:

- **Building the relevant hierarchy** (systems, subsystems, sub-subsystems and parts) in the System Hierarchy tab.
- Using the MSI selection questions to identify the maintenance significant items (MSIs).
- **Defining the F-F-E-C** (functions, failures, effects and causes) for each MSI.
- Applying the MSG-3 logic to set the failure effect categorization (FEC) and selecting/defining the recommended maintenance tasks.
- **Generating a report** of the analysis results.

You may also wish to review information about setting the configurable options for system and powerplant analysis, managing ATA chapters (i.e., systems and subsystems) and managing working group stamps (for display in report output).

For information about aircraft structural analysis, see Structural Analysis. For zonal analysis and lightning/high intensity radiated field (L/HIRF) analysis, see Zonal and L/HIRF Analysis.

**Tip:** Although the system hierarchy and F-F-E-C that you create in MPC for an aircraft systems and powerplant analysis has many similarities with the FMEA and RCM analyses that can perform in XFMEA, RCM++ or RBI, the analysis in MPC is designed specifically for the needs of the aircraft industry and is subject to certain logic constraints and restrictions imposed by the MSG-3 guidelines.

Therefore, each application must store and manage the analysis data independently. However, it is easy to copy any system from the MPC systems and powerplant analysis into the more flexible XFMEA/RCM++/RBI system hierarchy in the same project. (See Importing MPC Systems Into XFMEA, RCM++ or RBI.)
Chapter 6: Systems and Powerplant Analysis

System Hierarchy

Building the System Hierarchy
The items that you add to an MPC project for aircraft systems and powerplant analysis are arranged in a tree-based system configuration called the *system hierarchy*. To access the configuration, click the System Hierarchy tab on the *System panel*.

The System Hierarchy tab in MPC works in a manner similar to other ReliaSoft applications (such as XFMEA, RCM++ or RBI) except that there can be no more than four levels in the hierarchy (system, subsystem, sub-subsystem and part), and the first two levels must be selected from a predefined list of *ATA chapters (systems) and sections (subsystems)* that are stored in the database.

Each item has properties associated with it, which are viewed and edited on the *Properties tab* of the Analysis panel when the item is selected.

Available Columns
The following columns are displayed in the system hierarchy:

- **ATA #** displays the item number. For systems and subsystems, this is the ATA-assigned number. For sub-subsystems and parts, this is the value given in the item properties.

- **Description** displays the item name and/or description of the system or part.

- **MSI** displays an MSI icon if the item has been identified as a *maintenance significant item* that requires functional failure analysis. According to the MSG-3 guidelines, an item will be marked as an MSI under the following conditions:
  - It is a system, subsystem or sub-subsystem. (Parts cannot be flagged as MSIs.)
  - It is the lowest level (above part) in its branch of the system hierarchy that has a *Yes* answer to at least one of the MSI selection questions.

  *Note*: If you select the *Flag parts with 'yes' answer(s) for MSI questions* option in the *MPC Application Setup*, then the column will display a square icon, for each part that has answered "Yes" to at least one MSI question. This makes it easier to see which parts may need extra attention.

- **Status Updates** displays if the item contains any *status update notes*.

- **Attachment** displays a paper clip icon if one or more files or URLs have been attached to the corresponding item. It displays if a *Description and Operation (D&O)* document is one of the attached files.
• **Flag** displays a flag for the item, if desired. The available flags are: Complete (indicated by a green flag), In Progress (indicated by a yellow flag) and Incomplete (indicated by a red flag). In all ReliaSoft applications, flags are displayed in the interface only and do not affect analysis results or reports.

• **User Access** displays an icon when the item is inaccessible. (See [Status Indicators](#).)
  - If the item is in use by another user, an in use icon 🔒 will be displayed. Point to the icon to display the name of the user who is accessing the item.
  - If you do not have the item permissions needed to edit the item, a restricted access icon ⚰️ will be displayed.

• **F-F-E-C Analysis** displays ✅ if a functional failure analysis has been created for the MSI.

### Adding Systems and Subsystems
For compliance with the ATA numbering guidelines, the available system and subsystems have been predefined for the database. (See [Managing ATA Chapters](#).)

- To add a new system, choose **Systems > Add > Add System(s)**.
  ![Add System](image)

- To add a new subsystem, select a system and then choose **Systems > Add > Add SubSystem(s)**.
  ![Add SubSystem](image)

Both commands open windows that display the list of systems/subsystems that have been predefined for this database. Use the check boxes to select one or more items to add to the system configuration and click **OK**.

Note that each system/subsystem can be used only once per project. So if the item already exists in the current system configuration, the text will be grayed out and you will not be able to select it.

### Adding Sub-subsystems and Parts
Sub-subsystems and parts are not predefined for the database. Instead, you have the flexibility to create these records as needed for your particular analysis.

- To add a new sub-subsystem, select a subsystem and choose **Systems > Add > Add SubSubSystem**.
  ![Add SubSubSystem](image)
Chapter 6: Systems and Powerplant Analysis

- To add a new part, select the parent item (can be a system, subsystem or sub-subsystem depending on which level will be defined as the MSI) and choose **Systems > Add > Add Part.**

Note the following:

- The command(s) to add subsystems and/or sub-subsystems will be disabled if:
  - At least one part has already been defined for the parent item. Parts can be added under any type of record (system, subsystem or sub-subsystem), but they must always be the lowest level in any particular branch of the hierarchy.
  - You have answered "Yes" to at least one MSI selection question for the parent item or you have defined at least one function in the F-F-E-C for the parent item. Both of these actions signal that the parent item is an MSI.
  - Because of the ATA numbering guidelines, you cannot add more than 9 sub-subsystems for the same parent. The ATA numbers for all sub-subsystems must begin with the same number as the parent. For example, if the subsystem’s ATA number is 10, you can define sub-subsystems with any or all of the following numbers: 11, 12, 13, 15, 16, 17, 18 or 19.
  - There is no limit to the number of parts that you can add for the same parent, and you can use any number for the # field as long as it is unique among the parts associated with that item.

Deleting
To delete an item from any MPC hierarchy, select the hierarchy item and press **DELETE.** The hierarchy item will be deleted, along with all dependents and all associated attachments. **There is no undo for deleting an item or the entire hierarchy.**

Cutting/Copying
You can cut or copy items in any MPC hierarchy and paste them to the same project or to another project within the same database. (Please note that if you want to share hierarchy items between different databases, you must use the import/export functionality instead.) To select multiple hierarchy items for cut or copy:

- Click the first hierarchy item and then press **CTRL** and click additional hierarchy items at the same level of the hierarchy.

  or

- Click the first hierarchy item, then press **SHIFT** and click another hierarchy item to select all hierarchy items at the same level of the hierarchy between and including the two.
After you select the hierarchy items, you can use the standard keyboard shortcuts for cut/copy (CTRL+X and CTRL+C) or you can choose Home > Clipboard > Cut and Home > Clipboard > Copy. When a hierarchy item is cut or copied, all dependents will also be cut or copied, along with any attachments.

**Pasting**
To paste items that you have cut or copied from any MPC hierarchy, press CTRL+V or choose Home > Clipboard > Paste. Note the following:

- For the top two levels in the hierarchy (i.e., systems/subsystems, structures/substructures or major zones/major sub-zones), each item can be used only once per project. If an item with the same number already exists within the project you are pasting to, you will be prompted to decide if you want to replace the existing hierarchy item or cancel.

- If a hierarchy item is cut or copied but then deleted from the project, the copied data will also be deleted from the Clipboard. In addition, once a hierarchy item has been cut or copied, any edits that are made to the original will also be applied to its copy in the Clipboard. In other words, if there are changes to the original hierarchy items after you cut/copy them but before you paste them somewhere else, this will affect the data that can be pasted. Also note that you will not be able to cut or copy a hierarchy item in a project that is locked by another user.

**Importing**
It is easy to import any entire hierarchy (or selected items) from any project in the same database or another selected database. (See Importing MPC Hierarchies Between Projects.)

**System Item Properties**
When an item is selected in the system hierarchy, you can view and edit this information on the Properties tab in the Analysis panel. The following fields may appear.

*Note:* The fields that are enabled in the Properties tab will depend on the settings that have been defined for the database. You can choose Systems > Tools > Configurable Options to open the Configurable Options for Systems and Powerplant Analysis window and change the settings for the current database.

- **General**
  - **ATA #:** The item number. For systems and subsystems, this is the ATA-assigned number and cannot be changed from the Properties tab. For sub-subsystems, the number must begin with the same number as the subsystem (e.g., if the
subsystem’s number is 10, you can define sub-subsystems with any or all of the following numbers: 11, 12, 13, 14, 15, 16, 17, 18 or 19). For parts, the only limitation is that the numbers must be between 1 and 9999 and they must be unique for all the parts that are associated with the same item.

- **Item Description**: The name and/or description of the system or part.
- **Part Number**: The part number of the item.

- **Life Limit Info**
  - These fields refer to the maximum possible time interval during which the part may be used on the aircraft. This information will be displayed in the "Component Data" section of the Dassault template for MSI reports. It is not displayed in the Standard or Sukhoi templates.
  - **For Type**:
    - Select **Fixed (Numerical)** if you want the interval to be recorded as a number with an associated unit (e.g., 2,000 flight hours can be stored as value=2000 and unit = Fhr).
    - Select **Based on Events (Text)** if you want the interval to be stored in a text field, which can contain any combination of letters or numbers (e.g., “Per Mfr Recommendation”).
  - **For Life Limit**:
    - If you choose to enter a number, the field will be split into two sections so you can enter the time and then select the units from the drop-down list.
    - If you choose to store the interval as text, you can type up to 100 characters into the field.

**Tip**: The options in the units drop-down list are set via the Unit Settings window (choose File > Manage Repository > Unit Settings).

- **Reference Inputs**

The following fields are used in all three report templates for aircraft systems and powerplant analysis (Standard, Dassault and Sukhoi):

- **Zone**: Which aircraft zone the item belongs to. While you can use the same numbers as used in the zonal analysis, this is not required.
• **Access**: The type of access that is required in order to perform inspections on the item.

• The **Qty Per Aircraft** field refers to the total quantity of this item within the entire aircraft, while the **Qty Per Unit** field refers to the quantity in a single assembly. For example, if there are six turbine engine sections per engine and the aircraft has four engines, the *quantity per unit* is 6 and the *quantity per aircraft* is 24. Only the Qty Per Aircraft is displayed in the aircraft systems and powerplant analysis reports.

• When applicable, you can use the **Similar To** field to record information about a similar item that is operated in a similar environment and was used as a baseline to design this item.

• Use the **Supplier** field to record information about the manufacturer or distributor of the component.

• When applicable, you can record the:
  
  - **Historical MTBF** and **Predicted MTBF** - mean time before/between failure.
  
  - **Historical MTBUR** and **Predicted MTBUR** - mean time between unscheduled removal.

You can configure the database to require time units for these values, if desired. (See [Configurable Options for Systems and Powerplant Analysis](#).)

• When applicable, you can use the **MMEL** to indicate if the item is included in the *Master Minimum Equipment List*, which is a categorized list of items that may be inoperative for flight while still maintaining an acceptable level of safety.

• Any information that you enter in the **Remarks** field will be displayed in the "MSI Selection Questions" section of the systems and powerplant analysis report.

This field is used only in the Standard report template:

• **Reference**: Any additional information that is relevant to the maintainability and reliability data that has been entered (e.g., information about how the results were obtained).

The following fields are used only in the Dassault report template:

• **Functional Index**: Any information on the component.

• **Redundancies**: Any additional information on the equipment that is used to provide a standard/backup function.
• **Experience**: Any additional information based on previous experiences (e.g., other aircraft parts).

• The **Working Group Info** area displays information about the most recent working group that performed analysis for the current hierarchy item. It is updated automatically when you add an item or change an item property, and is based on the current working group session stamp. If desired, you can also update it manually (e.g., to force all of the items to show the latest working group information before you generate a report). Click the **Edit** icon, ![Edit icon](edit_icon.png), to open the **Current Item Working Group Stamp window**.

• The **History** fields display information about when the item was created and last modified. These details are recorded automatically by the application. If the **history log** has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the item.

**MSI Selection Questions**

The MSG-3 guideline for aircraft systems and powerplant analysis includes four questions that are used to determine which items in the system configuration require functional failure analysis, failure effect categorization and maintenance task selection. These items are called **maintenance significant items** (MSIs) and they are identified in the system hierarchy with the following icon:

![MSI icon](msi_icon.png)

An item will be marked as an MSI under the following conditions:

• It is a system, subsystem or sub-subsystem. Parts cannot be flagged as MSIs.

• It is the lowest level (above part) in its branch of the system hierarchy that has a "Yes" answer to at least one of the MSI selection questions.

The MSI selection questions for each item are displayed in the bottom panel of the **Item Properties tab**, as shown next.
You can answer the questions only for the lowest level item(s) in each branch of the hierarchy and then the answers automatically roll up to the higher level items. For example, the following picture shows a simplified configuration for an engine fire extinguishing subassembly.

With this configuration, you would be able to answer the MSI questions for the five parts defined in the lowest level of the hierarchy for the branch. Any "Yes" answers that you record for any of the parts will be automatically applied to the sub-subsystem, subsystem and system that they belong to. For example, if one part has a "Yes" answer for the "Operational" question and another part has a "Yes" answer for the "Economic" question, both questions will automatically be set to "Yes" for the sub-subsystem that both parts belong to.

**Tip:** If you want to see a quick visual indication of which parts have at least one "Yes" answer to the MSI selection questions, you can select the Flag parts with 'yes' answer(s) for MSI questions option in the MPC Application Setup.
Importing MPC Systems Into XFMEA, RCM++ or RBI

Although the system hierarchy and F-F-E-C that you create in MPC for an aircraft systems and powerplant analysis has many similarities with the FMEA and RCM analyses that you can perform in XFMEA, RCM++ or RBI, some key differences are that:

- The analysis in MPC is designed specifically for the needs of the aircraft industry and is subject to certain logic constraints and restrictions imposed by the MSG-3 guidelines.
- XFMEA/RCM++/RBI provide more flexibility and more options for data-driven system analyses (such as the ability to use failure mode and/or component data to estimate the reliability/availability for higher-level assemblies and systems).

Therefore, each application must store and manage the analysis data independently. In other words, if you are accessing the same project with both applications, the system hierarchy that you work with in MPC is independent from the system hierarchy that you work with in XFMEA/RCM++/RBI.

However, it is easy to copy any system from the MPC systems and powerplant analysis into the more flexible XFMEA/RCM++/RBI system hierarchy in the same project. The original system hierarchy in MPC will remain unchanged, and new (independent) records will be created in XFMEA/RCM++/RBI.

To use this feature, open the project in XFMEA, RCM++ or RBI and choose System Hierarchy > Add Items > Import > Import MPC Systems.

The window displays a list of the systems, if any, that have been defined in the MPC system hierarchy for the current project. Use the check boxes to select the MPC systems you wish to copy and click OK.

This process will automatically convert all of the relevant analysis information into the applicable feature(s) in XFMEA/RCM++/RBI.

If you are working with RCM++/RBI and you wish to see the MSI selection questions, failure effect categorization and task selection responses for the systems you import from MPC, make sure that the configurable project properties in RCM++/RBI are consistent with the MSG-3 guidelines. The easiest way to do this is to open the Project Properties in RCM++/RBI (Project > Management > Edit Project Properties) and check to make sure that the configurable settings are based on the MSG-3 profile from the default library installed with the software.
Functional Failure Analysis (F-F-E-C)

When you select an item in the system hierarchy, the F-F-E-C tab will be displayed in the Analysis panel if:

- The item has already been defined as a maintenance significant item (MSI) or
- The item is eligible to be marked as an MSI.

You will use this tab to record the functions, failures, effects and causes that have been identified for the item (functional failure analysis), and then perform the failure effect categorization and the maintenance task selection.
Two Views of the F-F-E-C

The F-F-E-C tab in the Analysis panel offers two complementary views of the information contained in your functional failure analysis. It is easy to switch back and forth between the views so you can choose the display that is best suited for a specific task.

- The **hierarchy** view, which displays the analysis records in a hierarchical tree, tends to be good for viewing a lot of information in a small amount of space. It can be especially useful when copying and pasting data or when scanning the analysis to find a particular section of the functional failure analysis.

- The **filtered** view presents a sortable list of all records of a particular type. For example, you can view a list of all effects sorted by failure effect categorization (FEC) or a list of maintenance tasks sorted by interval. This view allows you to generate these lists on-the-fly as you work on the analysis.

Functional Failure Analysis Hierarchy View

To view the Functional Failure Analysis in a hierarchical format, click the **Hierarchy** tab at the bottom of the Analysis panel.

This view, which is the default view of the functional failure analysis, displays the functions, failures, effects, causes and tasks at-a-glance in a hierarchical tree structure.

*Note:* If you do not want to see the tasks in the hierarchy view, you can clear the **Show tasks in the F-F-E-C Hierarchy** check box in the MPC Application Setup.

Using the Hierarchy View

The hierarchy view allows you to add, insert, edit, copy and paste the records in your functional failure analysis. You cannot edit text directly in this view. Instead, all editing is done via properties windows that you can access by double-clicking a row in the hierarchy or by right-clicking a row and choosing **Edit** from the shortcut menu.

You can move the records in the hierarchy view up and down by using the **Up** and **Down** icons on the F-F-E-C tab of the ribbon.

These commands move the selected record up or down the list of records of the same type that are associated with the same record (e.g., move a failure up or down within the list of failures that have been defined for the same function).
Available Columns
The view contains the following columns:

- **#** displays the record position number assigned by MPC based on the position of the record in the functional failure analysis hierarchy. For example, if you insert a new function above an existing function, then the new function will take the number of the existing function and all functions below it will be renumbered. Likewise, if you delete a function, all functions below it will be renumbered automatically.

- **Description** displays the description of the record.

- **Flag** displays a flag for the record, if applicable. To insert a flag, right-click inside this column and select a flag from the shortcut menu that appears. The available flags are: Complete (indicated by a green flag), In Progress (indicated by a yellow flag) and Incomplete (indicated by a red flag). In all ReliaSoft applications, flags are displayed in the interface only and do not affect analysis results or reports.

- **FEC** displays the number for the effect category that has been selected in the Failure Effect Categorization window. Double-clicking inside this column for an effect record opens the window so you can view/edit this portion of the analysis.

- **Tasks** displays the number of tasks associated with each cause. Double-clicking inside this column for a cause record opens the Task Selection window so you can view/edit this portion of the analysis.

Functional Failure Analysis Filtered View
When working in the Functional Failure Analysis, you can use the filtered view to show only records of a specific type (e.g., functions, failures, etc.). To use the filtered view, click the Filtered tab at the bottom of the Analysis panel. You can then choose the record type that you want to view from the Filter By drop-down list in the upper right corner. The Analysis panel will change to display only the records of the specified type, as shown next for tasks sorted by interval.
The columns that are displayed in the filtered view will depend on the record type you selected in the drop-down list.

You can sort the records that appear in this view by clicking the column heading.

When you are in the filtered view, you can easily edit many of the descriptions and settings by double-clicking inside the cell. The properties window for the corresponding record will appear, allowing you to make any necessary changes. You cannot create new records or change the sequence of the records in the filtered view.

**F-F-E-C Records**

When you are working on a functional failure analysis in the F-F-E-C tab of the Analysis panel, a properties window will be displayed when you create a new record or when you edit an existing one.

Once the window has been opened, you can click other records to view/edit their properties without having to close the window each time.

When you open a properties window from the hierarchy view, a ribbon is displayed at the top of the window, which contains two tabs:

- **The Home tab** provides commands for adding records, with the available options depending on which functional failure analysis record is currently selected. When applicable, it also provides the following tools:
  - **Spelling** checks the spelling of the text fields within the window.
  - **Effect Categorization** is available only in an Effect Properties or Cause Properties window. It opens the Failure Effect Categorization window, which allows you to evaluate the effects of the functional failure.

http://mpc.reliasoft.com
Task Manager is available only in a Cause Properties window. It opens the Task Selection window, which allows you to answer the maintenance task selection questions that are applicable based on the failure effect categorization and then create/edit the applicable maintenance task records.

- The Navigate tab allows you to quickly switch to another record in the F-F-E-C hierarchy. For example, if you want to quickly scan through the properties for all of the functions, you can open the properties window for the first one and then keep clicking the Next Function command until you reach the bottom of the list. The commands enabled will depend on the record that is currently displayed in the properties window.

The properties for the current record are displayed first and the fields will vary depending on which type of record you are viewing.

Next, the Associated Records area displays the analysis context for the record. For example, in an Effect Properties window, this displays the specific failure, function and MSI that the current effect is associated with.

Finally, the History area displays the date/time when the record was created and when it was last updated. The user(s) who performed these actions are also displayed. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the record.

Functions
To add a function to the Functional Failure Analysis, choose F-F-E-C > Function > Add Function.

To insert a new function above the selected function, choose F-F-E-C > Function > Insert Function.

To edit an existing function in the functional failure analysis, use the properties window. To open the properties window, select the function and choose F-F-E-C > Function > Edit Function or double-click the function in the hierarchy or filtered view.

In addition to the options and fields common to all record properties windows, the specific function properties (in the Function area at the top of the list) are as follows:

- The Function # field contains a number that is automatically assigned by the software based on the current position of the function in the current F-F-E-C hierarchy.
Chapter 6: Systems and Powerplant Analysis

- **The Function** field allows you to type up to 255 characters to describe a function that the item is intended to perform, along with any specific performance requirements.

**Tip:** For any properties window, blue text indicates that you can edit the field, italic gray text indicate that the information is automatically populated by the software. When you click inside any editable text field, the Select Existing icon displays a list of the unique text descriptions that have already been entered for this field.

Failures
To add a failure to the Functional Failure Analysis, choose F-F-E-C > Failure > Add Failure.

To insert a new failure above the selected failure, choose F-F-E-C > Failure > Insert Failure.

To edit an existing failure in the functional failure analysis, use the properties window. To open the properties window, select the failure and choose F-F-E-C > Failure > Edit Failure or double-click the failure in the hierarchy or filtered view.

In addition to the options and fields common to all record properties windows, the specific failure properties (in the Failure area at the top of the list) are as follows:

- **The Failure #** field contains a capital letter that is automatically assigned by the software based on the current position of the failure in the current F-F-E-C hierarchy.

- **The Functional Failure** field allows you to type up to 255 characters to describe a way that the item may fail to perform each intended function within the specified limits. This may include total failure to perform the function, poor performance of the function, performing an unintended function, etc.

**Tip:** For any properties window, blue text indicates that you can edit the field, italic gray text indicate that the information is automatically populated by the software. When you click inside any editable text field, the Select Existing icon displays a list of the unique text descriptions that have already been entered for this field.
**Effects**

To add an effect to the [Functional Failure Analysis](#), choose **F-F-E-C > Effect > Add Effect**.

To insert a new effect above the selected effect, choose **F-F-E-C > Effect > Insert Effect**.

To edit an existing effect in the functional failure analysis, use the properties window. To open the properties window, select the effect and choose **F-F-E-C > Effect > Edit Effect** or double-click the effect in the hierarchy or filtered view.

In addition to the options and fields common to all record properties windows, the specific effect properties (in the Effect area at the top of the list) are as follows:

- The **Effect #** field contains a number that is automatically assigned by the software based on the current position of the effect in the current F-F-E-C hierarchy.

- The **Failure Effect** field allows you to type up to 255 characters to describe effect of the failure on the top level item or system.

- The **Category** field displays the failure effect categorization (FEC). If the FEC has not yet been defined, click the icon to open the Failure Effect Categorization window. If an FEC has already been defined, click the icon to view and/or change the analysis.

**Tip:** For any properties window, blue text indicates that you can edit the field, italic gray text indicates that the information is automatically populated by the software. When you click inside any editable text field, the **Select Existing** icon displays a list of the unique text descriptions that have already been entered for this field.

**Causes**

To add a cause to the [Functional Failure Analysis](#), choose **F-F-E-C > Cause > Add Cause**.

To insert a new cause above the selected cause, choose **F-F-E-C > Cause > Insert Cause**.
Chapter 6: Systems and Powerplant Analysis

To edit an existing cause in the functional failure analysis, use the properties window. To open the properties window, select the cause and choose **F-F-E-C > Cause > Edit Cause** or double-click the cause in the hierarchy or filtered view.

In addition to the options and fields common to all record properties windows, the specific cause properties (in the **Cause** area at the top of the list) are as follows:

- **The Cause #** field contains a lower-case letter that is automatically assigned by the software based on the current position of the cause in the current F-F-E-C hierarchy.
- **The Failure Cause** field allows you to type up to 255 characters to describe the potential cause(s) for each failure. This should be the actionable level of the analysis, which is the level of causation at which corrective actions and/or controls could be applied effectively.
- **To open the Task Selection window**, you can view or edit the maintenance tasks that have been defined for this cause, click the **Task Manager** command on the Home tab of the ribbon.

**Tip:** For any properties window, blue text indicates that you can edit the field, italic gray text indicate that the information is automatically populated by the software. When you click inside any editable text field, the **Select Existing** icon displays a list of the unique text descriptions that have already been entered for this field.

**Import F-F-E-C from Excel**

When you are working on an aircraft systems and powerplant analysis, the Import F-F-E-C window makes it easy for you to import functional failure analysis data from an external data file.

To access the window from within the F-F-E-C tab for an MSI in the System Hierarchy, choose **F-F-E-C > Excel > Import FFEC from Excel**.

The top part of the window allows you to browse for an Excel file (*.xls or *.xlsx) and select which worksheet contains the data.
Then you can use the table to specify the row in the selected Excel worksheet that contains the first function description you want to import, as well as the column number for each type of record that can be imported. For example, in the following pictures, the Excel worksheet called "FMEA PN12345" contains data that can be imported into the F-F-E-C tab in MPC. The first function description is in Column A, Row 4 (Starting Row = 4 and Function Column Index = 1.) The failure descriptions are in Column B (Failure Column Index = 2), the effect descriptions are in Column C (Effect Column Index = 3), the FECs are in Column D (Effect Category Column Index = 4) and the cause descriptions are in Column E (Cause Column Index = 5).

![Excel Sheet](image1.png)

Select Replace if you want to delete all of the records from the current F-F-E-C hierarchy and replace with the data you imported from Excel. Select Append if you simply want to add the new data to the bottom of the current hierarchy.

Click Next to see a preview of the data that will be copied over and then click Finish to start the import process.

**Tip:** The values in the Effect Category Column must correspond to the FEC categories that are used in MPC (i.e., any number from 5 to 9, where 5 = Evident Safety, 6 = Evident Operational, etc.). Any other values in this column will be ignored during the import.
Applying the MSG-3 Logic

Failure Effect Categorization (FEC)
The Failure Effect Categorization window allows you to use the logic diagram from the MSG-3 guidelines to evaluate and categorize the consequences of each functional failure.

There are several ways to access the Failure Effect Categorization window. You can:

- Select an existing effect and choose F-F-E-C > Effect > Categorization.
- Double-click inside the FEC column for a specific effect in the F-F-E-C hierarchy or filtered view.
- Click Effect Categorization on the ribbon at the top of the Effect Properties window, Cause Properties window or Task Selection window.

If you already know which category is appropriate for the effect, you can choose it from the Category drop-down list in the bottom-right corner of the window. If not, begin working through the logic diagram by selecting the Yes or No option to answer Question 1. After doing so, the Answer 1 field on the right side of the window becomes available. You can use this field to document the reasons why the team chose the answer they did.

Tip: To save time and ensure consistency, each MPC database stores default text that can be used to automatically populate the Answer fields on the right side of the FEC window. Each time you answer one of these questions, you may choose whether to use the default text or replace it with something that is more appropriate for the current situation. (See Managing Default Responses.) Even if you choose not to accept the default text, you still have the option to reuse any answer that has already been set for another similar record in the database. To view a list of previously defined answers, click the Select Existing button next to the input field to open the Select Existing Text window.

Your answer to a question determines which of the subsequent questions must be answered. Continue answering the rest of the applicable questions by selecting the Yes or No option and documenting the reasons in the Answer fields, if desired. After you have answered the last question, the FEC category will be highlighted at the bottom of the window.

In the Remarks field, you can enter any additional remarks about the failure effect categorization. This information will be displayed in the Standard report template. It is not displayed in the Dassault or Sukhoi templates.

In the MMEL Ref field, you can specify the conditions under which the aircraft may be operated with failed equipment while still maintaining an acceptable level of safety. This information is
displayed in the Standard and Sukhoi report templates and is not applicable for the Dassault template.

Clear All: Clears all entries and selections made in the window.

Spelling: Checks the spelling of the text in all input boxes within the window.

Two buttons will be displayed under the diagram (called Manage Default Responses and Set Current Responses as Default) that allow the user to manage the default text that is used to populate the answer fields. (See Managing Default Responses.)

The status bar at the bottom of the window displays the date/time of the last change to the failure effect categorization and the user who made the change.

Task Selection Questions
The Task Selection window allows you to answer the MSG-3 maintenance task selection questions that are applicable for the current cause based on the failure effect categorization, and then create/edit the applicable maintenance task records.

To open the Task Selection window from the F-F-E-C hierarchy, double-click the relevant cause or right-click the cause and choose Task Manager from the shortcut menu. This command also appears on the ribbon in the Cause Properties window.

The FEC for the associated effect must be determined before you can open the Task Selection window. If the effect has not yet been categorized, you will be prompted to open the Failure Effect Categorization window before proceeding to the task selection.

When the Task Selection window opens, the associated records will be displayed at the top, followed by the FEC for the failure effect. To view or change this categorization, click Effect Categorization on the ribbon.

The middle section of the window displays the task selection questions from the MSG-3 guidelines. If the question is not applicable for the current FEC, it will show in light gray text and the Yes/No field will be disabled.
Chapter 6: Systems and Powerplant Analysis

**Table 7 - Evident Economic**

<table>
<thead>
<tr>
<th>#</th>
<th>Question</th>
<th>Yes/No</th>
<th>Response Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Is a Lubrication or Servicing Task Applicable and Effective?</td>
<td>No</td>
<td>No, a lubrication or servicing task will not be applicable and effective.</td>
</tr>
<tr>
<td>B</td>
<td>Is an Operational or Visual Check to Detect Hidden Failure Applicable and Effective?</td>
<td>No</td>
<td>Question is not applicable for Category 7</td>
</tr>
<tr>
<td>C</td>
<td>Is an Inspection or Functional Check to Detect Degradation of Function Applicable and Effective?</td>
<td>No</td>
<td>No, an inspection or functional check to detect degradation of the function will not be applicable.</td>
</tr>
<tr>
<td>D</td>
<td>Is a Restoration Task to Reduce Failure Rate Applicable and Effective?</td>
<td>No</td>
<td>No, a restoration task to reduce the failure rate will not be applicable and effective.</td>
</tr>
<tr>
<td>E</td>
<td>Is a Discard Task to Avoid Failures or to Reduce the Failure Rate Applicable and Effective?</td>
<td>No</td>
<td>No, a discard task to avoid failures or to reduce the failure rate will not be applicable and effective.</td>
</tr>
<tr>
<td>F</td>
<td>Is there a Task or Combination of Tasks Applicable and Effective?</td>
<td>No</td>
<td>Question is not applicable for Category 7</td>
</tr>
</tbody>
</table>

It is recommended to answer the applicable questions in the specified order until the team has identified the maintenance task(s) that will be applicable and effective to address the current issue. Click inside the Yes/No column to toggle between the two options. If desired, you can use the **Explanation** column to document the reasons why the team chose each answer.

**Tip:** To save time and ensure consistency, each MPC database stores default text that can be used to automatically populate the explanation fields in the Task Selection window. Each time you answer one of these questions, you may choose whether to use the default text or replace it with something that is more appropriate for the current situation (see *Managing Default Responses*). Even if you choose not to accept the default text, you still have the option to reuse any explanation that has already been set for another similar record in the database. To view a list of previously defined explanations, click the **Select Existing** button next to the input field to open the **Select Existing Text window**.

Finally, the bottom section of the window allows you to add or edit the scheduled maintenance task(s) that will be recommended to address the current issue. To view or edit an existing task, double-click the row or select it and choose **Edit Task**.

To delete a task, select the row and press **Delete** or choose **Delete Task**.

**Note:** Because tasks can be used in multiple places in a project, deleting a task from one place does not delete it from the project unless it is the only instance of that task in the project. In which case, deleting the task removes it from the database.

When adding tasks, you have the option to a) create a completely new task, b) create a new task with properties **copied** from another existing one or c) link to the **exact same task** that has
already been defined for another issue associated with the same MSI (i.e., the same task record appears in more than one location within the analysis). Specifically:

- To add a completely new task, choose Add Task or click the icon.

- To copy or link to an existing task, choose Add Existing Task or click the icon.

This opens the Select Existing Tasks window which gives three options:

- Choose Link to existing task to display a list of the eligible tasks that have already been assigned to other failure causes for the same MSI. When you link to an existing task, the exact same record is used in more than one location within the analysis (i.e., it has identical properties and the exact same task number). Any future change to the properties of this task will automatically be applied to all instances of the task.

- Choose Copy existing task properties to display a list all systems and powerplant analysis tasks within the current project. When you select to copy existing task properties, the software creates a new record that has identical properties but a different task number. The new record is independent from the original so any future changes to the properties will apply only to the current record.

- Choose Copy existing SSI task properties to display a list of all structural analysis (SSI) tasks within the current project. When you select one or more tasks and click OK, the properties will be copied from the original task record to create a new (completely independent) task. The original task will remain unchanged.

**Tip:** MPC uses built-in logic to ensure that the maintenance tasks that you define in this window are consistent with the answers recorded for the task selection questions. For example, if you have answered Yes to the question about whether a lubrication or servicing task will be applicable, you won’t be able to leave the Task Selection window until you have either assigned a task of the Lubrication (LUB) or Servicing (SVC) type, or changed the Yes answer back to No.

### Systems and Powerplant Analysis Tasks

The Task Properties window allows you to view/edit all of the properties for a particular maintenance task. For aircraft systems and powerplant analysis, there are several ways to access this window:

- Double-click a task record in the F-F-E-C hierarchy or filtered view.
Open the Task Selection window for a particular failure cause and then either double-click one of the records in the Assigned Tasks table or click Edit Task on the ribbon.

The following properties are available for tasks that are recommended based on a systems and powerplant analysis:

- Together, the Group # and # fields form the unique identification number for the task. You have the option to organize tasks into up to ten groups, and when you select a group number from the drop-down list, the # field will be set automatically to the next number in the sequence for the selected group. For example, if the new task belongs to Group 3 and two other tasks have already been created for Group 3, the unique identification number for the new task will be Group 3, Task 3. If you do not want to organize tasks by group, you can simply accept the default group number for all new tasks (which is set in the MPC Application Setup).

- The Task Title field allows you to provide more information about the task. This field is used only in the Standard report template.

- The Task Type field allows you to specify the type of maintenance task by choosing from a drop-down list. This cannot be changed after you have saved the task. Note the following:
  - Although the options in the drop-down list are determined by the requirements of the MSG-3 guidelines, the abbreviations can be modified, if desired. (See Task Type Abbreviations in MPC.)
  - If no other tasks have been defined for the current cause, the No Task Selected (NTS) option will appear at the bottom of the drop-down list. When you select this option, all of the task properties (except the Task drop-down list) will be disabled. You will not be able to add any other maintenance tasks for this cause without first deleting the NTS record.
  - When you attempt to close the Task Selection window, MPC will check to make sure that the assigned tasks are consistent with the answers for the MSG-3 task...
selection questions (e.g., if you answered Yes to the first question, a task with the Lubrication or Service task type must be assigned).

- The **Task Description** field allows you to provide more information about what the task is designed to do. Note that if the Task Type is "No Task Selected" then the field becomes a drop-down list where you can select an option that explains why no task has been selected for this cause.

- **Interval Info**

  - **For Sources of Information**, you can select one or more of the predefined options from the drop-down list and the **Interval Comments** field allows you to record any additional notes about the source. This information is displayed in the "Interval Substantiation" section of the Dassault report template and is not applicable for the Standard or Sukhoi templates.

  - **For Interval Type**:  
    - Select **Fixed (Numerical)** if you want to the interval to be recorded as a number with an associated unit (e.g., 2,000 flight hours can be stored as value = 2000 and unit = Fhr). Numbers may be easier to sort and will also make it possible to perform simulation-based reliability calculations if you choose to import the analysis project to RCM++/RBI.
    
    - Select **Based on Events (Text)** if you want the interval to be stored in a text field, which can contain any combination of letters or numbers (e.g., "Per Mfr Recommendation").

  - **For Interval**:  
    - If you choose to enter a number, the field will be split into two sections so you can enter the time and then select the units from the drop-down list. The options in the drop-down list can be modified. (See **Unit Settings**.)
      
    - If you choose to store the interval as text, you can type up to 100 characters into the field.

- **Zonal**

  - **ZIP Candidate** allows you to select (Yes or No) whether the task should be considered for transfer into the zonal inspection plan (ZIP). If "Yes" the task will be available for a standard zonal analysis using the Transfer Zonal Candidate Tasks feature.

This field is available only if the failure effect categorization (FEC) value is 5 or 8 (i.e., a safety issue) and the task type is "General Visual Inspection (GVI)".
• **Zone** allows you to specify where in the aircraft the relevant part is located (i.e., the zone where the task will occur). While you can use the same numbers as used in the zonal analysis, this is not required.

• **Other**

The following fields are used only in the Standard report template:

- Use the **Manual Reference** field to record additional information about the task, such as where in your maintenance procedures the task is described.

- Use the **Remarks** field to record any additional the remarks about the task.

The following fields are used only in the Standard and Dassault report templates:

- Use the **Effectivity** field to record additional information about the task, such as how effective the task is designed to be when performed.

- Use the **Access** field to record the type of access that will be required in order to perform the task.

The following fields are used only in the Dassault report template:

- Use the **Ground Support** field to record any additional information about the ground support requirements associated with the task.

- Use the **Procedure** field to record additional information about the procedure used to complete the task.

• The **Associated Records** area displays the analysis context for the record. In the Task Properties window, this includes the specific cause, effect, failure, function and MSI that the task is associated with.

• **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the record.

• **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

**Select Existing Tasks Window**

The Select Existing Tasks window will be displayed when you choose **Add Existing Tasks** or click the icon in the **Task Selection window** in a systems and powerplant analysis.
To use this window, first select whether you want to link directly to an existing task or simply copy the properties from an existing task to create a new task record:

- **Choose Link to existing task** to display a list of the eligible tasks that have already been assigned to other failure causes for the same MSI. When you select to link to an existing task, the exact same record is used in more than one location within the analysis (i.e., it has identical properties and the exact same task number). Any future change to the properties of this task will automatically be applied to all instances of the task.

- **Choose Copy existing task properties** to display a list of all systems and powerplant analysis tasks within the current project. When you select to copy existing task properties, the software creates a new record that has identical properties but a different task number. The new record is independent from the original so any future changes to the properties will apply only to the current record.

- **Choose Copy existing SSI task properties** to display a list of all structural analysis (SSI) tasks within the current project. When you select one or more tasks and click **OK**, the properties will be copied from the original task record to create a new (completely independent) task. The original task will remain unchanged.

The table displays a list of the tasks that fit the criteria for the option you have selected. If desired, you can click the column headers to sort by any of the task properties displayed in the table. Use the check boxes to select one or more tasks and click **OK**.

Note that if any of the tasks in the list have already been assigned to the current failure cause, the text will be in gray and you will not be able to select it again.

**Managing Default Responses**

In both the Failure Effect Categorization window and the Task Selection window, users have the option to enter text that describes why they answered **Yes** or **No** to each question. To save time and ensure consistency, each MPC database stores default text that can be used to automatically populate these response fields, if desired. Each time a user answers one of these questions, he/she may choose whether to accept the default text or replace it with something that is more appropriate to the situation.

The Manage Default Responses window allows authorized users to view and manage the default responses that will be available for all analyses in the current database. To open the window, click the Manage Default Responses button in the Failure Effect Categorization window or click the ribbon command in the Task Selection window.
In the Select Questions area, choose which set of questions (FEC or task selection) you wish to display and manage.

In the table, the questions are displayed in the first column. This text cannot be edited. The default responses for Yes and No answers are displayed in the second and third columns. Click inside a cell to edit the text. You can leave the cell blank if you do not want to include a default response.

If you have the applicable "manage all projects" permissions, you can also change the default responses for the current project, the current database and/or all future repositories by selecting either the To all MSIs in this project check box, the To all new MSIs in this repository check box and/or the In all future repositories check box.

Reports

Systems and Powerplant Analysis Reports
The following topics discuss the options for generating reports for your systems and powerplant analysis.

In addition to the functionality covered here, you can also:

- Use the Custom MSI Reports window to generate your own custom reports in either Microsoft Word or Excel using any of the data from a systems and powerplant analysis.

- Generate a report that shows all tasks in the project from all three analysis types - systems and powerplant, structural and zonal. (See Maintenance Review Board Reports.)

Tip: For all predefined Word document reports, the information displayed in the footer of the print-ready report documents comes from the Working Group Stamp stored for the item.

Check MSI Analysis
The Check MSI Analysis window compares the answers to the maintenance significant item (MSI) selection questions against the failure effect categorizations (FECs). If the analysis contains answers/categories that are incompatible, the utility provides a warning so that you can review the analysis and perform any updates that may be appropriate before you generate the print-ready report.

To open the Check MSI Analysis window, choose Systems > Tools > Check MSI Analysis or right-click an item in the System Hierarchy tab and choose Check MSI Analysis. This window can also
be accessed right before you generate a report by clicking the **Check MSI Analysis** button in the **MSI Report window**.

The top panel allows you to specify which of the maintenance significant items (MSIs) in the project you want to check. (Remember that in order to be flagged as an MSI, the item must be at the lowest level in the hierarchy above any parts, and at least one of the equipment selection questions must be set to **Yes**.)

After you click **Check**, the bottom panel displays the analysis check results for the selected item(s). If desired, you can click the **Copy Text** button to copy the results to the Windows Clipboard so they can be pasted into another document.

Any of the following warnings may be reported:

- **An effect categorized as 5 or 8 was expected but not found.**
  - There is a **Yes** answer to the MSI selection question called **Safety** but none of the failure effects have an FEC of 5 (Evident Safety) or 8 (Hidden Safety).

- **An effect categorized as 5 was found but not expected.**
  - There is a **No** answer to the MSI selection question called **Safety** but one or more of the failure effects have an FEC of 5 (Evident Safety):

- **An effect categorized as 8 or 9 was expected but not found.**
  - There is a **Yes** answer to the MSI selection question called **Detectability** but none of the failure effects have an FEC of 8 (Hidden Safety) or 9 (Hidden Non-Safety).

- **An effect categorized as 9 was found but not expected.**
  - There is a **No** answer to the MSI selection question called **Detectability** but one or more of the failure effects have an FEC of 9 (Hidden Non-Safety).

- **An effect categorized as 6 was expected but not found.**
  - There is a **Yes** answer to the MSI selection question called **Operational** but none of the failure effects have an FEC of 6 (Evident Operational).

- **An effect categorized as 6 was found but not expected.**
  - There is a **No** answer to the MSI selection question called **Operational** but one or more of the failure effects have an FEC of 6 (Evident Operational).
Chapter 6: Systems and Powerplant Analysis

- **An effect categorized as 7 or 9 was expected but not found.**
  - There is a **Yes** answer to the MSI selection question called **Economic** but none of the failure effects have an FEC of 7 (Evident Economic) or 9 (Hidden Non-Safety).

- **An effect categorized as 7 was found but not expected.**
  - There is a **No** answer to the MSI selection question called **Economic** but one or more of the failure effects have an FEC of 7 (Evident Economic).

- **An effect categorized as 8 was found but not expected.**
  - There is a **No** answer to one or both of the MSI selection questions called **Safety** and **Detectability** but one or more of the failure effects have an FEC of 8 (Hidden Safety).

- **A sub-subsystem has the same condensed MSI number as another subsystem.**
  - A sub-subsystem of one subsystem uses an item number that has resulted in its MSI number being the same as that of another subsystem in the system.

**Description and Operation (D&O) Documents**

You can attach a Description and Operation (D&O) to any item in the system hierarchy, the structural hierarchy, the zonal hierarchy or the L/HIRF hierarchy. These documents typically contain diagrams and other descriptive information about the item (normally one that has been flagged as an MSI item in a systems and powerplant analysis or as an SSI item in a structural analysis) which can be integrated directly into the reports.

**What’s changed?** In MPC 3, D&O documents were the only files that could be attached to items. In the current version, MPC provides the same flexible links and attachments capabilities that are available in all ReliaSoft applications.

To attach a D&O document to an item, select the item and choose **Tools > Attachments** on the relevant ribbon tab.

In the Attachments window, click the **Add** icon, then in the Add Attachment window, select **Report Word Doc** for the attachment type and browse for the file, as shown next.
Click **OK** to upload a copy of the file into the database.

When you generate a report for the item, the software will automatically integrate the "Report Word Doc" attachments in the order they are listed in the Attachments window.

**Important:** In **MSI reports** for systems and powerplant analysis, the report will include the attachments for the currently selected item only and will not include the attachments for any selected sub-items.

---

**MSI Report Window**

For systems and powerplant analysis, MPC gives a choice of three different reporting formats that are commonly used in industry for the systems and powerplant analysis reports that can be submitted to the ATA Maintenance Review Board (MRB): Standard, Dassault and Sukhoi.

To open the MSI Report window, select one maintenance significant item (MSI) in the system hierarchy and then choose **Systems > Reports > MSI Report**.

**Select Report Format**

Choose one of the three predefined report formats: **Standard**, **Dassault** or **Sukhoi**. In addition,

- **Create Tasks report only** generates a report that only shows a summary of the maintenance tasks.
• Include MSG Revision in Headers shows the MSG-3 Guidelines version (selected in the Project Properties) in the report header. This only applies for the Standard and Sukhoi templates.

**Standard Format Options**
These options are applicable only when using the Standard report format.

• Create List of Effective Pages report includes a page at the beginning of the report that lists all the forms in the report and the pages they start on.

• Create Task Data Sheet report (One per Task) includes the full task details for each task at the end of the report.

**Dassault Report Format**
These options are applicable only when using the Dassault report format.

• Use standard format logo displays the standard MPC logo on the reports instead of the Dassault logo in the Dassault report.

• Use Reference field value instead of ATA number on Data Sheet A uses an item's Reference field value instead of its ATA number in the Dassault report's Data Sheet A.

**Standard and Dassault Format Logo**
These options display a logo in the document header when using either the Standard or the Dassault report format.

• Select Logo allows you to import a *.bmp, *dib, *.gif, *.jpg, *.wmf, *.emf, *.ico or *.cur graphic. Note that the logo will be scaled down to a maximum size of 150 x 75.

• No Report Logo displays no logo on the printed report.

• Default Logo displays the default MPC graphic that was shipped with the application.

When you click Generate Report, specify the pathname/filename where the report file will be saved, and then click Save.
Chapter 7: Structural Analysis

This chapter discusses how to record the results of an aircraft structural analysis based on the ATA Operator/Manufacturer Schedule Maintenance Development (MSG-3) guidelines.

This type of analysis uses the Structural Hierarchy tab on the System panel, which can be displayed on the left side or the top side of the Project window. To change the location of the panel, choose View > Workspace Layout > Change Orientation.

For information about aircraft systems and powerplant analysis, see Systems and Powerplant Analysis. For zonal analysis and lightning/high intensity radiated field (L/HIRF) analysis, see Zonal and L/HIRF Analysis.

Note: The structural, zonal and L/HIRF analysis functionality is available only in MPC Plus. If you are an MPC Standard user, please contact ReliaSoft for information about upgrading to MPC Plus.

Structural Hierarchy

Building the Structural Hierarchy

The structures that you add to an MPC project for aircraft structural analysis are arranged in a tree-based structural configuration called the structural hierarchy. To access the configuration, click the Structural Hierarchy tab on the System panel.

In the Structural Hierarchy tab, there can be no more than four levels in the hierarchy (structure, substructure, sub-substructure and structural item), and the first two levels must be selected from a predefined list of ATA chapters (systems) and sections (subsystems) that are stored in the database.

Each item has properties associated with it, which are viewed and edited on the Properties tab of the Analysis panel when the item is selected.
Available Columns

The following columns are displayed in the structural hierarchy:

- **ATA #** displays the item number. For structures and substructures, this is the ATA-assigned number. For sub-substructures and parts, this is the value given in the item properties.

- **Description** displays the name and/or description of the structure or structural item.

- **SSI** displays an SSI icon if the structural item is considered to be a *structurally significant item* (SSI) that requires accidental damage (AD) and/or environmental deterioration (ED) analyses. (See SSI Selection Questions.)

- **Status Updates** displays if the item contains any status update notes.

- **Attachment** displays a paper clip icon if one or more files or URLs have been attached to the corresponding item. It displays if a Description and Operation (D&O) document is one of the attached files.

- **Flag** displays a flag for the structure/structural item, if desired. The available flags are: Complete (indicated by a green flag), In Progress (indicated by a yellow flag) and Incomplete (indicated by a red flag). In all ReliaSoft applications, flags are displayed in the interface only and do not affect analysis results or reports.

- **User Access** displays an icon when the item is inaccessible. (See Status Indicators.)
  - If the item is in use by another user, an in use icon will be displayed. Point to the in-use icon to display the name of the user who is accessing the item.
  - If you do not have the item permissions needed to edit the item, a restricted access icon will be displayed.

- Depending on the setting in the Configurable Options for Structural Analysis window, there will be three or four columns that display icons to indicated which environmental deterioration (ED), accidental damage (AD) and/or fatigue damage (FD) analyses have been created for each structural item. The icons are:
  - indicates an environmental deterioration (ED) analysis for metallic materials.
  - indicates an environmental deterioration (ED) analysis for non-metallic materials.
  - indicates an accidental damage (AD) analysis for metallic materials (or for any type of material of you have selected to not perform separate analyses).
  - indicates an accidental damage (AD) analysis for non-metallic materials.
**Adding Structures and Substructures**

For compliance with the ATA numbering guidelines, the available structures and substructures have been predefined for the database. (See Managing ATA Chapters.)

- To add a new top-level structure, choose **Structures > Add > Add Structure(s).**
- To add a new substructure, select the structure and then choose **Structures > Add > Add SubStructure(s).**

Both commands open windows that display the list of structures/substructures that have been predefined for this database. Use the check boxes to select one or more items to add to the structural configuration and click **OK.**

Note that each structure/substructure can be used only once per project. So if the item already exists in the current system configuration, the text will be grayed out and you will not be able to select it.

**Adding Sub-substructures and Structural Items**

Sub-substructures and structural items have not been predefined for the database. Instead, you have the flexibility to create these records as needed for your particular analysis.

- To add a new sub-substructure, select the substructure and choose **Structures > Add > Add SubSubStructure.**
- To add a new structural item, select any item and choose **Structures > Add > Add Structural Item.**

Note the following:

- The command(s) to add substructures and/or sub-substructures will be disabled if:
  - At least one structural item has already been defined for the parent item. Structural items can be added under any type of record (structure, substructure or sub-substructure), but they must always be the lowest level in any particular branch of the hierarchy.
• You have answered "Yes" to at least one SSI selection question for the parent item. This action signals that the parent item is an SSI.

• Because of the ATA numbering guidelines, you cannot add more than 9 sub-substructures for the same parent. The ATA numbers for all sub-substructures must begin with the same number as the parent. For example, if the substructure’s ATA number is 10, you can define sub-substructures with any or all of the following numbers: 11, 12, 13, 15, 15, 16, 17, 18 or 19.

• There is no limit to the number of structural items that you can add for the same parent, and you can use any number for the # field as long as it is unique among the structural items associated with that item.

Deleting
To delete an item from any MPC hierarchy, select the hierarchy item and press DELETE. The hierarchy item will be deleted, along with all dependents and all associated attachments. There is no undo for deleting an item or the entire hierarchy.

Cutting/Copying
You can cut or copy items in any MPC hierarchy and paste them to the same project or to another project within the same database. (Please note that if you want to share hierarchy items between different databases, you must use the import/export functionality instead.) To select multiple hierarchy items for cut or copy:

• Click the first hierarchy item and then press CTRL and click additional hierarchy items at the same level of the hierarchy.

or

• Click the first hierarchy item, then press SHIFT and click another hierarchy item to select all hierarchy items at the same level of the hierarchy between and including the two.

After you select the hierarchy items, you can use the standard keyboard shortcuts for cut/copy (CTRL+X and CTRL+C) or you can choose Home > Clipboard > Cut and Home > Clipboard > Copy. When a hierarchy item is cut or copied, all dependents will also be cut or copied, along with any attachments.

Pasting
To paste items that you have cut or copied from any MPC hierarchy, press CTRL+V or choose Home > Clipboard > Paste. Note the following:

• For the top two levels in the hierarchy (i.e., systems/subsystems, structures/substructures or major zones/major sub-zones), each item can be used only once per project. If an item with the same number already exists within the project you
are pasting to, you will be prompted to decide if you want to replace the existing hierarchy item or cancel.

- If a hierarchy item is cut or copied but then deleted from the project, the copied data will also be deleted from the Clipboard. In addition, once a hierarchy item has been cut or copied, any edits that are made to the original will also be applied to its copy in the Clipboard. In other words, if there are changes to the original hierarchy items after you cut/copy them but before you paste them somewhere else, this will affect the data that can be pasted. Also note that you will not be able to cut or copy a hierarchy item in a project that is locked by another user.

**Importing**

It is easy to import any entire hierarchy (or selected items) from any project in the same database or another selected database. (See Importing MPC Hierarchies Between Projects.)

**Structural Item Properties**

*MPC Plus Only*

When an item is selected in the structural hierarchy, you can view and edit its properties on the Properties tab in the Analysis panel. The following fields are available.

- **General**
  - **#:** The item number. For structures and substructures, this is the ATA-assigned number and cannot be changed from the Properties tab. For sub-substructures, the # must begin with the same number as the parent (e.g., if the substructure’s # is 10, you can define sub-substructures with any or all of the following numbers: 11, 12, 13, 14, 15, 16, 17, 18 or 19). For structural items, the only limitation is that the numbers must be between 1 and 9999 and they must be unique for all the structural items that are associated with the same parent.
  - **Description:** The name and/or description of the structure or structural item.
  - **Location:** The physical place on the aircraft where the item is located.
  - **Zone:** Which aircraft zone the item belongs to. While you can use the same numbers as used in the Zonal analysis, this is not required.
  - **Access:** The type of access that is required in order to perform inspections on the structure.
  - **Part Number:** The part number of the item.
  - **Drawing Number:** An identifying number for engineering design drawings.
Chapter 7: Structural Analysis

- **Reference Inputs**
  - **Environmental Conditions**: A description of the environmental conditions that the structure will be exposed to.
  - Any information that you enter in the Remarks field will be displayed in the Remarks section of the Item Properties Summary report.

- The **Working Group Info** area displays information about the most recent working group that performed analysis for the current hierarchy item. It is updated automatically when you add an item or change an item property, and is based on the current working group session stamp. If desired, you can also update it manually (e.g., to force all of the items to show the latest working group information before you generate a report). Click the **Edit** icon, to open the Current Item Working Group Stamp window.

- The **History** fields display information about when the item was created and last modified. These details are recorded automatically by the application. If the history log has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the item.

### Performing Structural Analysis

#### SSI Selection Questions

- **MPC  Plus Only**

The MGS-3 guideline for aircraft structural analysis describes several criteria to identify a *structural significant item* (SSI). It says:

"A Structural Significant Item (SSI) is any detail, element or assembly, which contributes significantly to carrying flight, ground, pressure or control loads, and whose failure could affect the structural integrity necessary for the safety of the aircraft."

In MPC, these items are identified in the structural hierarchy with the following icon:

A structural item will be marked as an SSI if you answer "Yes" to any of the SSI selection questions displayed in the bottom panel of the Structural Item Properties tab, as shown next:
Although the answers to these questions are displayed for all levels in the structural hierarchy, they can only be answered at the lowest (structural item) level. The answers displayed at higher levels show the combined responses from all the structural items in that branch of the hierarchy.

### Environmental Deterioration (ED) Analysis

**MPC Plus Only**

You can perform environmental deterioration (ED) analysis for any structural item that has been marked as a structural significant item (SSI). The rating system varies depending on whether the materials are metallic or non-metallic, but both ED analyses tabs function in a similar manner. This topic describes how to use either tab.

Note that these rating systems are configurable at the database level. (See Configurable Options for Structural Analysis.)

**Adding or Deleting an Analysis**

To add a new ED analysis tab, select an SSI in the structural hierarchy and choose Structures > Analyses > [Add ED (Metals)/Add ED (Non-Metals)].

To delete an analysis, select a tab in the Analysis panel and then choose Structures > Analyses > Delete Analysis. (Remember there is no undo for delete.)
Using the ED Analysis Tab

Top Section: Materials
The top section of the ED analysis tab allows you to perform a separate evaluation for each material that the structural item is composed of.

To add a new material evaluation, choose Structures > Materials > Add New Material.

To view or edit the complete evaluation for one of the materials in the list, select the row and double-click or choose Structures > Materials > Edit Material.

Tip: If you want to copy or link to a material evaluation that has already been performed for another SSI, choose Structures > Materials > Add Existing Materials. (See Select Existing Materials.)

The evaluation criteria displayed in the Materials Properties window will vary depending on whether the material is metallic or non-metallic. Furthermore, these rating systems are configurable at the database level. (See Configurable Options for Structural Analysis.)

Middle Section: Calculated Ratings/Properties
The middle section of the ED analysis tab displays the combined results from all of the materials that were analyzed.

Each combined rating will be the worst rating that has been assigned to any of the materials. For example, if there are two materials and one has a Protection rating of 3 - Special but the other has a rating of 1 - Limited, the worst rating (limited protection) will be used for the combined analysis.

For each overall rating, you can click the icon to see the matrix that was used to determine the score. For example, the Environmental/Protection score reflects the adversity (or corrosiveness) of the environment balanced against the degree to which the structural item is protected from that environment. The following picture shows the default matrix used to obtain this score. In this case, the item is exposed to an adverse (or corrosive) environment (Environmental Rating = 1) and has limited protection from the environment (Protection Rating = 1), resulting in the worst possible overall score of 1.
Bottom Section: Tasks
The bottom section of the ED analysis tab allows you to define any maintenance tasks that are recommended based on the environmental deterioration analysis.

To add a new task, choose Structures > Tasks > Add Task.

To view or edit the properties of an existing task, select the task and choose Structures > Tasks > Edit Task.

For information about the task properties, see Structural Analysis Tasks.

Rating System for Metallic Materials
For metallic materials, the evaluation considers:

- **Corrosion**
  - **Potential Corrosion**: A set of ratings are used to classify the material’s sensitivity to a list of potential corrosion types (e.g., pitting, erosion, etc.). The PCT Rating for the material will be the worst rating that has been assigned to any of the corrosion types.
Chapter 7: Structural Analysis

- **Stress Corrosion Cracking:** A single SCC Rating classifies the material's sensitivity to stress corrosion cracking.

  The Overall Corrosion score is assigned based on a scoring matrix that considers the PCT Rating and the SCC Rating.

  **Note:** If the material does not have an SCC rating defined, then its Overall Corrosion score is the same as its PCT Rating.

The following rating is displayed only if the "Require 'Detectability Rating' when performing ED analysis for metal materials" option is selected on the Configurable Options for Structural Analysis window.

- **Detectability Rating:** A single Detectability Rating classifies how easy it is to detect the damage to the material.

  The Corrosion/Detectability score is assigned based on a scoring matrix that considers the Overall Corrosion Rating and the Detectability Rating.

- **Environmental and Protection**
  - **Environmental:** A single rating classifies the materials potential exposure to corrosive substances.
  - **Protection:** A single rating classifies the degree to which the material might be protected from damage due to exposure to corrosive substances.

  The Environmental/Protection rating is based on a scoring matrix that considers the Environmental rating and Protection rating.

  The Overall score is assigned based on a scoring matrix that considers the Overall Corrosion score (or the Corrosion/Detectability score) and the Environmental/Protection score.

**Rating System for Non-Metallic Materials**
For non-metallic materials, the evaluation considers:

- **Damage**
  - **Potential Damage:** A set of ratings are used to classify the material's sensitivity to a list of potential sources of environmental damage (e.g., humidity, lightning, etc.). The overall PD Rating for the material will be the worst rating that has been assigned to any of the sources.
  - **Damage Detectability:** A single DDR Rating classifies the likelihood that environmental damage will be detected.
The Overall Damage score is assigned based on a scoring matrix that considers the PD Rating and the DDR Rating.

The following rating is displayed only if the "Require 'Composition Rating' when performing ED analysis for composite materials" option is selected on the Configurable Options for Structural Analysis window.

- **Composition Rating**: A single Composition Rating classifies the skin of the material.

The Damage/Composition score is assigned based on a scoring matrix that considers the Overall Damage Rating and the Composition Rating.

- **Environmental and Protection**
  - **Environmental**: A single rating classifies the materials' potential exposure to an adverse environment.
  - **Protection**: A single rating classifies the degree to which the materials might be protected from damage due to exposure to an adverse environment.

The overall Environmental/Protection rating is assigned based on a scoring matrix that considers the Environmental rating and Protection rating.

The Overall score is assigned based on a scoring matrix that considers the Overall Damage score (or the Damage/Composition score) and the Environmental/Protection score.

---

**Materials Properties Window**

When you perform an environmental deterioration (ED) analysis for a structural item, you can use the Material Properties window to perform a new evaluation for each material that will be considered. (For information about how to copy or link to a material evaluation that has already been performed for another SSI, see Select Existing Materials.)

To access the Material Properties window from an ED (Metals) or ED (Non-Metals) analysis, choose Structures > Materials > Add New Material.

The following properties are available:

- Use the fields in the General area to provide basic information about the material. Note that the Heat Treatment field is available only for metallic material properties.
The next several areas present the rating system for either metallic or non-metallic materials. As discussed in Environmental Deterioration (ED) Analysis:

- For metals, you will rate the material's sensitivity to Potential Corrosion Types (PCT) such as pitting, fretting, erosion, etc. You will also rate the sensitivity to Stress Corrosion Cracking (SCC), how easy it is to detect the damage, the level of exposure to corrosive substances in the environment, and the degree of protection against those substances.

- For non-metals, you will rate the material's sensitivity to different Potential Environmental Damage Types (PED) such as humidity, solar, lightning, etc., as well as the ability to detect such damage. You will also rate the composition of the skin, the level of exposure to an adverse environment and the degree of protection from that environment.

**Note:** The values used in the rating systems are configurable at the database level. (See Configurable Options for Structural Analysis.)

**History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the record.

### Select Existing Materials

When you perform an environmental deterioration (ED) analysis for a structural item, you can use the Select Existing Materials window to either copy or link to a material evaluation that has already been performed for another SSI. (For information about how to perform a new evaluation, see Materials Properties Window.)

To access the Select Existing Materials window from an ED (Metals) or ED (Non-Metals) analysis, choose Structures > Materials > Add Existing Materials.

To use the window:

- Select the data source. You can select a material evaluation from the current project, another project in the current database or another project in a different database.
If you are selecting from a different database, an address bar will become enabled. Click the arrow to select from a list of recently accessed databases or click the browse button (browse button) to select any standard database (*.rsr19) or enterprise database connection file (*.rserp).

If you are not selecting from the current project, use the Select Project drop-down list to select the project that contains the material evaluation you wish to copy or link to.

The Search Criteria area allows you to choose one of the material evaluation's general properties (Name, Heat Treatment, Specification or Surface Finish) to filter by.

- The first drop-down list allows you to choose which property.
- The second drop-down list displays the options that will determine a match (e.g., contains, begins with, etc.).

If you are selecting from the current project or from another project in the same database, the Copy or Link area provides two choices:

- Select Copy material properties if you want to create a new (independent) evaluation that has all the same properties as the existing one. If you later make a change to either evaluation, the other will not be affected.
- Select Link to existing material if you want to link directly to the existing material evaluation. If you later make a change to the original evaluation, any other analyses that link to this material will be updated automatically.

Accidental Damage (AD) Analysis

You can perform accidental damage (AD) analysis for any structural item that has been marked as a structural significant item (SSI).

The rating system is configurable at the database level (see Configurable Options for Structural Analysis.) Depending on these database settings, there may be a single AD Analysis tab or two.
tabs called AD (Metals) and AD (Non-Metals). However, all three tabs function in a similar manner and this topic describes how to use any of them.

**Adding or Deleting an Analysis**

To add a new AD analysis tab, select an SSI in the structural hierarchy and choose **Structures > Analyses [Add AD Analysis/Add AD (Metals)/Add AD (Non-Metals)].**

To delete an analysis, select a tab in the Analysis panel and then choose **Structures > Analyses > Delete Analysis.** (Remember there is no undo for delete.)

**Using the AD Analysis Tab**

**Top Section: Damage Sources Evaluation**

The top section of the AD analysis tab contains a list of the potential sources of accidental damage that may be considered. If you select "Yes" in the Likely column, you will be able to:

- Use the **Possibility Rating** column to rate the likelihood that this type of accidental damage might occur.
- Use the **Visibility Rating** column to rate the likelihood that the damage would be detected.

If you have selected the "**Require 'Residual Strength Rating' and 'Damage Growth Rating' when performing AD analysis**" option on the Configurable Options for Structural Analysis window, then you will also be able to:

- Use the **Residual Strength Rating** column to rate how strong the item will be after being damaged.
- Use the **Damage Growth Sensitivity Rating** column to rate how sensitive the item will be to future damage.

You can also use the **Remarks/Damage** column to record any notes related to the ratings that the team has assigned.

**Middle Section: Combined Results from All Rated Damage Sources**

The middle section of the AD analysis tab displays the combined results from all of the potential sources of accidental damage that were analyzed.

- If you are not using the additional columns, then the combined analysis score will be based on the worst ratings that have been assigned for all potential sources of
accidental damage. For example, if you have indicated that two sources of accidental damage are likely and one has a Possibility rating of 3 - Low but the other has a rating of 1 - High, the worst rating (high possibility of damage) will be used for the combined analysis.

- If you are using the additional columns, then the **Possibility/Residual Strength** score will be based on the worst ratings for the Possibility of Damage and Residual Strength ratings while the **Visibility/Damage Growth** score will be based on the worst ratings for the Damage Growth Sensitivity and Visibility ratings. In this case, the **Overall AD Rating** score will be based on the combined Possibility/Residual Strength and Visibility/Damage Growth scores.

For the **Overall AD Rating** you can click the [ ] icon to see the matrix that was used to determine the score. For example, the following picture shows the default scoring matrix. In this case, at least one potential damage source has a high possibility of occurring (Possibility of Damage = 1) but all of the likely damage sources have a high probability of the damage being detected (Visibility of Damage = 3), resulting in a moderate overall score of 2.

---

**Bottom Section: Tasks**

The bottom section of the AD analysis tab allows you to define any maintenance tasks that are recommended based on the accidental damage analysis.

To add a new task, choose **Structures > Tasks > Add Task**.
Chapter 7: Structural Analysis

To view or edit the properties of an existing task, select the task and choose Structures > Tasks > Edit Task.

For information about the task properties, see Structural Analysis Tasks.

Fatigue Damage Analysis

You can perform fatigue damage/safe life analysis for any structural analysis that has been marked as a structural significant item (SSI).

*Note:* This analysis is only available if you have selected the Enable Fatigue Damage analysis option on the Settings page of the Configurable Options for Structural Analysis window.

Adding or Deleting an Analysis

To add a new fatigue analysis tab, select an SSI in the structural hierarchy and choose Structures > Analyses > Add FD/SL Analysis.

To delete an analysis, select a tab in the Analysis panel and then choose Structures > Analyses > Delete Analysis. (Remember there is no undo for delete.)

Using the FD/SL Analysis Tab

**Top Section: Fatigue Damage Analysis**

Do the following:

- If the item does not require any inspections for fatigue damage, then clear the Is SSI Damage Tolerant? option and enter the maximum safe life of the item and any associated remarks.

- If analysis tasks are not applicable, clear the Is Fatigue Related Task Required? option, and then enter the reason why tasks are not needed.

- Otherwise, use the Analysis Properties section to enter the details about the analysis.
Bottom Section: Tasks
The bottom section of the FD/SL analysis tab allows you to define any maintenance tasks that are recommended based on the fatigue damage analysis.

To add a new task, choose Structures > Tasks > Add Task.

To view or edit the properties of an existing task, select the task and choose Structures > Tasks > Edit Task.

For information about the task properties, see Structural Analysis Tasks.

Structural Analysis Tasks

The Task Properties window allows you to view/edit all of the properties for a particular maintenance task.

To add a new task for an aircraft structural analysis, choose Structures > Tasks > Add Task.

To view or edit the properties of an existing task, select the task and choose Structures > Tasks > Edit Task.

The following properties are available for tasks that are recommended based on an environmental deterioration, accidental damage or fatigue damage analysis for a structural significant item (SSI):

- Together, the Group # and # fields form the unique identification number for the task. You have the option to organize tasks into up to ten groups, and when you select a group number from the drop-down list, the # field will be set automatically to the next number in the sequence for the selected group. For example, if the new task belongs to Group 3 and two other tasks have already been created for Group 3, the unique identification number for the new task will be Group 3, Task 3. If you do not want to organize tasks by group, you can simply accept the default group number for all new tasks (which is set in the MPC Application Setup).
Chapter 7: Structural Analysis

- **The Task Type** field allows you to specify the type of maintenance task by choosing from a drop-down list. This cannot be changed after you have saved the task. Note that although the options in the drop-down list are determined by the requirements of the ATA guidelines, the abbreviations can be modified, if desired. (See Task Type Abbreviations in MPC.)

- **The Task Title** field allows you to provide more information about the task.

- **The Task Description** field allows you to provide more information about what the task is designed to do.

- **Initial Interval** and **Repeat Interval**
  
  - **For Interval Type:**
    
    - Select **Fixed (Numerical)** if you want the interval to be recorded as a number with an associated unit (e.g., 2,000 flight hours can be stored as value = 2000 and unit = FHr). Numbers may be easier to sort.
    
    - Select **Based on Events (Text)** if you want the interval to be stored in a text field, which can contain any combination of letters or numbers (e.g., “Per Mfr Recommendation”).

  - **For Interval:**
    
    - If you choose to enter a number, the field will be split into two sections so you can enter the time and then select the units from the drop-down list. The options in the drop-down list can be modified. (See Unit Settings.)
    
    - If you choose to store the interval as text, you can type up to 100 characters into the field.

- **Zonal**
  
  - **ZIP Candidate** allows you to select (Yes or No) whether the task should be considered for transfer into the zonal inspection plan (ZIP). This field is enabled only if the task type is "General Visual Inspection (GVI)". These tasks will be available for the Transfer Zonal Candidate Tasks feature in a standard zonal analysis.

  - **Zone** allows you to specify where in the aircraft the relevant part is located (i.e., the zone where the task will occur). While you can use the same numbers as used in the zonal analysis, this is not required.
Other

- Use the **Manual Reference** field to record additional information about the task, such as where in your maintenance procedures the task is described.
- Use the **Effectivity** field to record additional information about the task, such as how effective the task is designed to be when performed.
- Use the **Access** field to record the type of access that will be required in order to perform the task.
- For tasks used with environmental deterioration (ED) metals analyses only, use the **CPCP** drop-down list to indicate whether the task is part of a corrosion prevention and control program.
- Use the **Procedure** field to record additional information about the procedure used to complete the task.
- Use the **Remarks** field to record additional information about the task.

**History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the record.

**Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

Select Existing Structural Tasks

**MPC Plus Only**

When you are working with a structural analysis, you have the option to copy properties from existing tasks in the current project that can also be used as structural tasks. To do this, choose **Structures > Tasks > Add Existing Tasks**.

The Select Existing Tasks window displays a list of the tasks in the current project that are available for use with structural analyses: General Visual Inspection, Detailed Inspection, Special Detailed Inspection or Scheduled Structural Health Monitoring.

In the **Options** area, specify whether you want to copy existing SSI task properties or copy existing MSI task properties from within the same project.
Chapter 7: Structural Analysis

When you select one or more tasks and click OK, the properties will be copied from the original task record to create a new (completely independent) task. The original task will remain unchanged.

**Structural Analysis Reports**

**MPC Plus Only**

For aircraft structural analysis, MPC provides a set of predefined report forms that you can generate in Microsoft Word. This includes:

- A summary of your answers to the SSI Selection questions for all selected structural items.
- A summary of the item properties for all selected structural items.
- The ability to insert any D&O documents that have been attached to selected structural items.
- A summary of each Environmental Deterioration (ED), Accidental Damage (AD) and Fatigue Damage (FD) analysis that was performed for each selected structural item.
- A summary of all maintenance tasks that were defined for the selected structural items.
- The full details for each maintenance task.

You can also generate a report that shows all tasks in the project from all three analysis types - systems and powerplant, structural and zonal. (See Maintenance Review Board Reports.)

To open the report generation window, make sure the Structural Hierarchy tab has focus, then choose Structures > Reports > Reports.

**Select Items**

In the Select Items area, specify the items from the structural hierarchy that will be included in the report. You can generate a report that contains data from a single analysis or from multiple analyses together.

**Select Report Forms**

The Available Reports area displays all of the available report forms that are not yet selected. This list includes the standard report forms that are shipped with the software, as well as any custom report templates that you have created.
The **Selected Reports** area displays the forms that have been selected for inclusion in the generated report, in the order in which they will appear. You can drag and drop the selected forms into the desired position or use the **Up/Down** icons.

You can double-click a report or use the **Include/Exclude** icons to move the report between the areas.

Drag and drop the selected forms into the desired position or use the **Up/Down** icons.

Use the **Sort Tasks By** are to set the sort order for tasks: by number, by type (e.g., LUB, SVC, etc.) or by interval (with most frequent tasks listed first).

**Report Settings**

If you want to customize any of the report settings (e.g., font, paper size, add a logo, etc.), click the **Report Settings** button to open the Report Settings window, then adjust any of the following settings before generating the report:

- **Report Logo** will display in the document header, if specified.
  - **Select Logo** allows you to import a *.bmp, *.dib, *.gif, *.jpg, *.wmf, *.emf, *.ico or *.cur graphic. Note that the logo will be scaled down to a maximum size of 150 x 75.
  - **No Report Logo** displays no logo on the printed report.
  - **Default Logo** displays the default MPC graphic that was shipped with the application.
- **Paper Size** specifies whether the documents will be configured for U.S. Letter or A4-sized paper.
- **Description and operation documents page settings** specifies whether included Description & Operation (D&O) documents will maintain their own page margin settings or use the generated report margin settings.
- **Order for pages that are printed multiple times** sets the order the pages will be printed in.
- **Use name (not abbreviation) for time units** displays the full name of all time units on reports (e.g., 1000 Flight Hours or 1000 FHR).
- **Include 'Task Title' field** displays the task title with the other task details.
- **Include 'Analysis Type' field in 'Tasks Summary (Detailed)' report** displays the type of analysis the task is associated with in that report.
Generate Report

When you click **Generate Report**, you will be prompted to specify the pathname/filename for the new Word document that will be created.

**Tip:** For all predefined Word document reports, the information displayed in the footer of the print-ready report documents comes from the **Working Group Stamp** stored for the item.
Chapter 8: Zonal and L/HIRF Analysis

This chapter discusses how to record the results of zonal analysis and lightning/high intensity radiated field (L/HIRF) analysis based on the ATA Operator/Manufacturer Schedule Maintenance Development (MSG-3) guidelines.

Starting in Version 2019, the way you perform L/HIRF analysis depends on the MSG-3 guidelines that you have selected for the project in the Project Properties.

- New in Version 2019, you can use versions of Revision 2015 Vol 1 and Vol 2 that support identifying L/HIRF Significant Items (LHSIs); if your project uses one of these versions, L/HIRF analyses are performed for the LHSIs identified for the ATA systems and/or sections. Zonal analysis is performed using the Zonal Hierarchy tab on the System panel and L/HIRF analysis is performed using the L/HIRF Hierarchy tab.

- Previously, L/HIRF analyses in MPC were performed for zones defined and selected within the zonal hierarchy. This methodology continues to be supported for all versions of the guidelines that do not support LHSI identification. In projects using these guidelines, you will use the Zonal-L/HIRF Hierarchy tab on the System panel for both zonal and L/HIRF analyses.

For convenience, this help file refers to projects using the MSG-3 guideline versions that support LHSI identification as LHSI projects, and to projects using all other guideline versions as non-LHSI projects.

The tabs used for zonal and L/HIRF analyses can be displayed on the left side or the top side of the Project window. To change the location of the panel, choose View > Workspace Layout > Change Orientation.

For information about aircraft systems and powerplant analysis, see Systems and Powerplant Analysis. For information about aircraft structural analysis, see Structural Analysis.

Note: The structural, zonal and L/HIRF analysis functionality is available only in MPC Plus. If you are an MPC Standard user, please contact ReliaSoft for information about upgrading to MPC Plus.
Performing Zonal Analysis

Building the Zonal Hierarchy

The zones that you add to an MPC project for zonal analyses are arranged in a tree-based structural configuration called the zonal hierarchy. To access the configuration in LHSI projects (i.e., projects using one of the MSG-3 guidelines that support identification of L/HIRF Significant Items), click the Zonal Hierarchy tab on the System panel; in non-LHSI projects (i.e., projects using one of the MSG-3 guidelines that do not support identification of L/HIRF Significant Items), click the Zonal-L/HIRF Hierarchy tab.

There can be no more than three levels in the zonal hierarchy (major zone, major sub-zone and zone), and the first two levels must be selected from a predefined list of major zones and major sub-zones that are stored in the database.

Each item has properties associated with it, which are viewed and edited on the Properties tab of the Analysis panel when the zone is selected in the hierarchy.

Available Columns

The following columns are displayed in the zonal hierarchy:

- **Zone #** displays the zone number. This will be assigned automatically for major zones and major sub-zones. For zones, you can select an acceptable number from the drop-down list.

- **Description** displays the name and/or description of the zone.

- **Status Updates** displays if the item contains any status update notes.

- **Attachment** displays a paper clip icon if one or more files or URLs have been attached to the corresponding item. It displays if a Description and Operation (D&O) document is one of the attached files.

- **Flag** displays a flag for the item, if desired. The available flags are: Complete (indicated by a green flag), In Progress (indicated by a yellow flag) and Incomplete (indicated by a red flag). In all ReliaSoft applications, flags are displayed in the interface only and do not affect analysis results or reports.

- **User Access** displays an icon when the item is inaccessible. (See Status Indicators.)
  - If the item is in use by another user, an in use icon will be displayed. Point to the in-use icon to display the name of the user who is accessing the item.
Chapter 8: Zonal and L/HIRF Analysis

- If you do not have the item permissions needed to edit the item, a restricted access icon will be displayed.

- **Standard Zonal Analysis** displays if a standard zonal analysis has been created for the zone.

- **Enhanced Zonal Analysis** displays if an enhanced zonal analysis has been created for the zone.

- **L/HIRF Analysis** is shown only in non-LHSI projects. If shown, this column displays if a lightning/high intensity radiated field (L/HIRF) analysis has been created for the zone.

### Adding Major Zones and Major Sub-Zones

For compliance with the ATA numbering guidelines, the available major zones and major sub-zones have been predefined for the database. (See Managing Major Zones.)

- To add a new major zone, choose Zones > Add > Add Major Zone(s).

- To add a new major sub-zone, select the major zone and then choose Zones > Add > Add Major Sub-Zone(s).

Both command open windows that display the list of major zones/major sub-zones that have been predefined for this database. Use the check boxes to select one or more items to add to the zonal hierarchy and click **OK**.

Note that each major zone/sub-zone can be used only once per project. So if the item already exists in the current system configuration, the text will be grayed out and you will not be able to select it.

### Adding Zones

Zones have not been predefined for the database. Instead, you have the flexibility to create these records as needed for your particular analysis.

- To add a new zone, select a major sub-zone and choose Zones > Add > Add Zone.

Because of the ATA numbering guidelines, you cannot add more than 9 zones for the same major sub-zone. For example, if the major zone number is 100 and the major sub-zone is 110, you can add zones with any of the following numbers: 111, 112, 113, 114, 115, 116, 117, 118 or 119.
Deleting
To delete an item from any MPC hierarchy, select the hierarchy item and press DELETE. The hierarchy item will be deleted, along with all dependents and all associated attachments. There is no undo for deleting an item or the entire hierarchy.

Cutting/Copying
You can cut or copy items in any MPC hierarchy and paste them to the same project or to another project within the same database. (Please note that if you want to share hierarchy items between different databases, you must use the import/export functionality instead.) To select multiple hierarchy items for cut or copy:

- Click the first hierarchy item and then press CTRL and click additional hierarchy items at the same level of the hierarchy.

  or

- Click the first hierarchy item, then press SHIFT and click another hierarchy item to select all hierarchy items at the same level of the hierarchy between and including the two.

After you select the hierarchy items, you can use the standard keyboard shortcuts for cut/copy (CTRL+X and CTRL+C) or you can choose Home > Clipboard > Cut and Home > Clipboard > Copy. When a hierarchy item is cut or copied, all dependents will also be cut or copied, along with any attachments.

Pasting
To paste items that you have cut or copied from any MPC hierarchy, press CTRL+V or choose Home > Clipboard > Paste. Note the following:

- For the top two levels in the hierarchy (i.e., systems/subsystems, structures/substructures or major zones/major sub-zones), each item can be used only once per project. If an item with the same number already exists within the project you are pasting to, you will be prompted to decide if you want to replace the existing hierarchy item or cancel.

- If a hierarchy item is cut or copied but then deleted from the project, the copied data will also be deleted from the Clipboard. In addition, once a hierarchy item has been cut or copied, any edits that are made to the original will also be applied to its copy in the Clipboard. In other words, if there are changes to the original hierarchy items after you cut/copy them but before you paste them somewhere else, this will affect the data that can be pasted. Also note that you will not be able to cut or copy a hierarchy item in a project that is locked by another user.
Importing

It is easy to import any entire hierarchy (or selected items) from any project in the same database or another selected database. (See Importing MPC Hierarchies Between Projects.)

Zonal Item Properties

When a zone is selected in the zonal hierarchy, you can view and edit its properties on the Properties tab in the Analysis panel. The following fields are available.

- **General**
  - #: The zone number. This will be assigned automatically for major zones and major sub-zones. For zones, you can select an acceptable number from the drop-down list.
  - **Description**: The name and/or description of the zone.
  - **ATA #**: The ATA number the zone is associated with.
  - **Zonal Inspection #**: The inspection number used for the zone. It can be any integer value from 1 to 100.

- **Zone Details**
  - **Boundaries (Location)**: A description of the zone boundaries and location in the aircraft.
  - **Access**: Information about how the zone will be accessed for maintenance inspections.
  - **Equipment Installed**: A summary of the types of systems and components installed in the zone.
  - **Structures**: A summary of the structures contained in the zone.
  - **Remarks**: Any additional comments about the analysis.

- The **Working Group Info** area displays information about the most recent working group that performed analysis for the current hierarchy item. It is updated automatically when you add an item or change an item property, and is based on the current working group session stamp. If desired, you can also update it manually (e.g., to force all of the items to show the latest working group information before you generate a report). Click the **Edit** icon, to open the Current Item Working Group Stamp window.
Chapter 8: Zonal and L/HIRF Analysis

- The History fields display information about when the item was created and last modified. These details are recorded automatically by the application. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the item.

**Selecting Zonal Analyses**

When you select a zone in the zonal hierarchy, a panel at the bottom of the Properties tab displays the questions that will determine which type(s) of analysis are recommended. This is based on the "Typical Zonal Analysis Procedure" flowchart from the MSG-3 guidelines. Based on your answers, the analysis recommendations are displayed at the bottom of the panel, and the applicable analysis commands will become enabled on the ribbon.

For non-LHSI projects (i.e., projects using one of the MSG-3 guidelines that do not support identification of L/HIRF Significant Items), the final question in the Properties tab is used to determine whether L/HIRF analysis is appropriate. This question is not present in LHSI projects; instead, you will use the L/HIRF hierarchy to identify L/HIRF Significant Items and then use LHSI selection questions to determine the LHSIs for which L/HIRF analysis should be performed.

As an example, the following picture shows the responses in a non-LHSI project that will result in a recommendation to perform both types of zonal analysis (standard and enhanced) as well as L/HIRF analysis.

<table>
<thead>
<tr>
<th>Question</th>
<th>Response</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Does Zone contain only Structure?</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Does Zone contain Wiring?</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Are combustible materials in Zone?</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Is wiring close to both primary and back-up hydraulic, mechanical, or electrical flight controls?</td>
<td>N/A</td>
<td>Not Applicable</td>
</tr>
<tr>
<td>Is there an effective task to significantly reduce the likelihood of accumulation of combustible materials?</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Does Zone contain L/HIRF protection?</td>
<td>Yes</td>
<td></td>
</tr>
</tbody>
</table>

**Recommendation:** Perform Standard, Enhanced and L/HIRF analyses

To answer a question, click inside the Response column to toggle between Yes and No.
If desired, you can use the Comments fields to record additional information about the answer selected.

**Standard Zonal Analysis**

You can perform a standard zonal analysis for any zone in the zonal hierarchy. (The standard analysis will always be an option, regardless of how you answer the zonal analysis selection questions.)

The rating system is configurable at the database level. (See Configurable Options for Zonal and L/HIRF Analysis.)

**Adding or Deleting an Analysis**

To add a new standard zonal analysis tab, select a zone in the zonal hierarchy and choose **Zones > Analyses > Add Standard Zonal Analysis**.

To delete an analysis, select a tab in the Analysis panel and then choose **Zones > Analyses > Delete Analysis**. (Remember there is no undo for delete.)

**Using the Zonal (Standard) Tab**

**Top Section: Properties/Ratings**

The top section of the standard zonal analysis tab contains the following rating system.

- **Density/Accidental Damage**
  - **Density**: A single rating that classifies the density of the equipment in the zone.
  - **Likelihood of Accidental Damage**: A set of ratings that are used to classify the likelihood of accidental damage due to a variety of factors (such as ground/cargo handling, weather, runway debris, etc.).

The **Density/Accidental Damage** score is assigned based on a scoring matrix that considers the density rating and the worst accidental damage rating for any of the damage types. You can click the icon to see the matrix.

- **Hostility of Environment**: A set of ratings that are used to classify a variety of factors that could lead to environmental deterioration (such as exposure to corrosive products, condensation, etc.).
Chapter 8: Zonal and L/HIRF Analysis

The **Overall** score is assigned based on a scoring matrix that considers the combined density/accidental damage score and the worst rating for any of the environmental hostility types. You can click the [icon](http://mpc.reliasoft.com) to see the matrix.

**Bottom Section: Tasks**
The bottom section of the tab allows you to define any maintenance tasks that are recommended based on the standard zonal analysis.

To add a new task, choose **Zones > Tasks > Add Task**.

To view or edit the properties of an existing task, select the task and choose **Zones > Tasks > Edit Task**.

You also have the option to copy the properties from an existing task in the current project that has been marked a zonal inspection program (ZIP) candidate. To do this, choose **Zones > Tasks > Transfer Zonal Candidate Tasks**.

For information about the task properties, see [Zonal Analysis Tasks](http://mpc.reliasoft.com). For information about transferring ZIP candidate task properties, see [Transfer Zonal Candidate GVI Tasks](http://mpc.reliasoft.com).

**Enhanced Zonal Analysis**

You can perform an enhanced zonal analysis for zones that both contain electrical wiring and have potential for combustible material being present. The command will be available if you have answered "Yes" for both of these conditions in the zonal analysis selection questions.

The rating system is configurable at the database level. (See [Configurable Options for Zonal and L/HIRF Analysis](http://mpc.reliasoft.com).)

**Adding or Deleting an Analysis**
To add a new enhanced zonal analysis tab, select an eligible zone in the zonal hierarchy (based on your answers for the zonal analysis selection questions) and choose **Zones > Analyses > Add Enhanced Zonal Analysis**.
To delete an analysis, select a tab in the Analysis panel and then choose Zonal > Analyses > Delete Analysis. (Remember there is no undo for delete.)

**Using the Zonal (Enhanced) Tab**

**Top Section: Wiring Inspection**

The top section of the enhanced zonal analysis tab contains the following rating system designed to help you determine appropriate inspection tasks to detect deterioration of installed wiring and electrical wiring interconnection systems (EWIS), and to minimize contamination by combustible materials. There are three sets of ratings/inputs:

- **Inspection Level Definition**

  The first set of ratings are used to determine the inspection level by considering (per the MSG-3 guidelines) "the potential effects of fire caused by a wiring/EWIS failure on adjacent wiring systems (e.g., the risk to aircraft controllability), the size of the zone and the density of the installed equipment."

  - **Density/Size:**
    - **Density**: A single rating that classifies the density of the equipment in the zone.
    - **Size**: A single rating that classifies the size of the zone.

    The Density/Size score is assigned based on a scoring matrix that considers both ratings. You can click the [matrix] icon to see the matrix.

  - **Fire Effects (Criticality)**: A single rating that classifies the effects of fire.

    The Density/Size and Fire Effects score is assigned based on a scoring matrix that considers the density/size score, and the fire effects criticality rating.

- **Inspection Level Verification**

  The second set of inputs allow the team to indicate which type of inspection tasks are recommended and why. In these questions, GVI = general visual inspection and DET = detailed inspection.
Finally, the last set of ratings allows you to consider the likelihood of accidental damage and the hostility of the environment in order to determine the appropriate inspection interval(s).

- **Hostility of Environment**: A set of ratings that are used to classify a variety of environmental factors (such as vibration, humidity, contamination, etc.).

- **Likelihood of Accidental Damage**: A set of ratings that are used to classify the likelihood or accidental damage due to a variety of factors (such as ground/cargo handling, weather, runway debris, etc.).

The **Hostility of Environment/Accidental Damage** score is assigned based on a scoring matrix that considers the worst rating for any of the environmental hostility types and the worst rating for any of the accidental damage types. You can click the icon to see the matrix.

**Bottom Section: Tasks**
The bottom section of the tab allows you to define any maintenance tasks that are recommended based on the enhanced zonal analysis.

To add a new task, choose **Zones > Tasks > Add Task**.

To view or edit the properties of an existing task, select the task and choose **Zones > Tasks > Edit Task**.

For information about the task properties, see **Zonal Analysis Tasks**.
Zonal Analysis Tasks

MPC Plus Only

The Task Properties window allows you to view/edit all of the properties for a particular maintenance task.

To add a new task for a zonal analysis, choose **Zones > Tasks > Add Task**.

To view or edit the properties of an existing task, select the task and choose **Zones > Tasks > Edit Task**.

The following properties are available for tasks that are recommended based on a standard or enhanced zonal analysis for a particular zone:

- Together, the **Group #** and **#** fields form the unique identification number for the task. You have the option to organize tasks into up to ten groups, and when you select a group number from the drop-down list, the # field will be set automatically to the next number in the sequence for the selected group. For example, if the new task belongs to Group 3 and two other tasks have already been created for Group 3, the unique identification number for the new task will be Group 3, Task 3. If you do not want to organize tasks by group, you can simply accept the default group number for all new tasks (which is set in the MPC Application Setup).

- The **Task Type** field allows you to specify the type of maintenance task by choosing from a drop-down list. This cannot be changed after you have saved the task. Note that although the options in the drop-down list are determined by the requirements of the ATA guidelines, the abbreviations can be modified, if desired. (See **Task Type Abbreviations in MPC**.)

For enhanced zonal analysis only, if no other tasks have been defined for the current analysis, the No Task Selected (NTS) option will appear at the bottom of the drop-down list. When you select this option, all of the task properties (except the Task Description field) will be disabled. You will not be able to add any other maintenance tasks for this analysis without first deleting the NTS record.

- The **Task Title** field allows you to provide more information about the task.

- The **Task Description** field allows you to provide more information about what the task is designed to do. Note that if the Task Type is "No Task Selected" then the field
becomes a drop-down list where you can select an option that explains why no task has been selected for this analysis.

- **Interval Info**
  - **For Interval Type:**
    - Select **Fixed (Numerical)** if you want to the interval to be recorded as a number with an associated unit (e.g., 2,000 flight hours can be stored as value = 2000 and unit = FHr). Numbers may be easier to sort.
    - Select **Based on Events (Text)** if you want the interval to be stored in a text field, which can contain any combination of letters or numbers (e.g., “Per Mfr Recommendation”).
  - **For Interval:**
    - If you choose to enter a number, the field will be split into two sections so you can enter the time and then select the units from the drop-down list. The options in the drop-down list can be modified. (See **Unit Settings**.)
    - If you choose to store the interval as text, you can type up to 100 characters into the field.

- The **Zonal** group is available only for enhanced zonal analysis.
  - **ZIP Candidate** allows you to select (**Yes** or **No**) whether the task should be considered for transfer into the zonal inspection plan (ZIP). This field is enabled only if the task type is "General Visual Inspection (GVI)". These tasks will be available for the **Transfer Zonal Candidate Tasks** feature in a **standard zonal analysis**.

- **Other**
  - Use the **Manual Reference** field to record additional information about the task, such as where in your maintenance procedures the task is described.
  - Use the **Effectivity** field to record additional information about the task, such as how effective the task is designed to be when performed.
  - Use the **Access** field to record the type of access that will be required in order to perform the task.
  - Use the **Procedure** field to record additional information about the procedure used to complete the task.
  - Use the **Remarks** field to record additional information about the task.
• **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the record.

• **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

### Transfer Zonal Candidate GVI Tasks

**MPC** Plus Only

When you are working with a standard zonal analysis, you have the option to copy properties from an existing task in the current project that has been marked as a zonal inspection program (ZIP) candidate. To do this, choose Zones > Tasks > Transfer Zonal Candidate Tasks.

The Transfer Zonal Candidate GVI Tasks window displays a list of general visual inspection (GVI) tasks in the current project that have been marked as "Yes" for the ZIP Candidate property. If desired, you can use the options at the top of the window to filter the list as follows:

- **MSI Analysis**: Only show tasks from an aircraft systems and powerplant analysis.
- **SSI Analysis**: Only show tasks from an aircraft structural analysis.
- **EZAP Analysis**: Only show tasks from an enhanced zonal analysis.
- **L/HIRF Analysis**: Only show tasks from a lightning/high intensity radiated field (L/HIRF) analysis. This option is available only in non-LHSI projects (i.e., projects using one of the MSG-3 guidelines that do not support identification of L/HIRF Significant Items). In LHSI projects, it is expected that L/HIRF analysis will be performed after zonal analysis, so L/HIRF tasks are not candidates for transfer.
- **All Analyses**: Show applicable tasks from any of the above.

Use the options in the Available Zones to choose from area to specify whether you want to choose tasks from the current zone only or from all zones. Note that this does not apply to L/HIRF and EZAP analyses where you can import tasks from the current zone only.

When you select one or more tasks and click OK, the properties will be copied from the original task record to create a new (completely independent) task. The original task will remain unchanged.
Performing L/HIRF Analysis

L/HIRF Analysis in Non-LHSI Projects

MPC  Plus Only

Projects that use MSG-3 guidelines that do not support identification of L/HIRF Significant Items — i.e., guidelines other than Revision 2015 Vol 1 (LHSI Identification) or Revision 2015 Vol 2 (LHSI Identification) — are considered non-LHSI projects. In these projects, you can perform lightning/high intensity radiated field analysis for zones that have L/HIRF protection. The command will be available if you have answered "Yes" for this condition in the zonal analysis selection questions.

The rating system is configurable at the database level. (See Configurable Options for Zonal and L/HIRF Analysis.)

Adding or Deleting an Analysis

To add a new L/HIRF analysis tab, select an eligible zone in the zonal hierarchy (based on your answers for the zonal analysis selection questions) and choose Zones > Analyses > Add L/HIRF Analysis.

To delete an analysis, select a tab in the Analysis panel and then choose Zones > Analyses > Delete Analysis. (Remember there is no undo for delete.)

Using the L/HIRF Tab

Top Section: Protection Systems
The top section of the L/HIRF analysis tab allows you to list and describe all of the L/HIRF protection systems in the zone.

To add a new protection system description, choose Zones > L/HIRF Protection > Add Protection System.

To view or edit the complete description for one of the protection systems in the list, select the row and double-click or choose Zones > L/HIRF Protection > Edit Protection System.
Middle Section: Ratings
The middle section of the L/HIRF analysis tab allows you to perform the L/HIRF environmental damage/accidental damage (ED/AD) analysis, using the following rating system:

- **Hostility of Environment**: A set of ratings that are used to classify a variety of environmental factors (such as exposure to corrosive products, condensation, etc.).
- **Susceptibility to Damage**: A set of ratings that are used to classify the likelihood of damage during manufacturing, operation of the aircraft or maintenance practices.

The **Hostility of Environment/Susceptibility to Damage** score is assigned based on a scoring matrix that considers the worst rating for any of the hostile environment factors and the worst rating for any of the accidental damage types. You can click the [123] icon to see the matrix.

Bottom Section: Tasks
The bottom section of the tab allows you to define any maintenance tasks that are recommended based on the ED/AD analysis.

To add a new task, choose **Zones > Tasks > Add Task**.

To view or edit the properties of an existing task, select the task and choose **Zones > Tasks > Edit Task**.

For information about the task properties, see **L/HIRF Analysis Tasks**.

L/HIRF Protection System Properties

In non-LHSI projects (i.e., projects using one of the MSG-3 guidelines that do not support identification of L/HIRF Significant Items), the L/HIRF Protection System Properties window allows you describe an L/HIRF protection system used in the zone. These systems help to avoid, eliminate or reduce the consequences of a lightning/high intensity radiated field (L/HIRF) event.

To add a new protection system description, choose **Zones > L/HIRF Protection > Add Protection System**.

The following fields are available:

- **General**
Chapter 8: Zonal and L/HIRF Analysis

- **Description**: The name and/or description of the protection system.
- **Ref #**: The protection system's reference number.
- **Location**: The physical place on the aircraft where the protection system is located.

**Components**

- **Internal LRU Components**: The internal LRU components (line replaceable units) that are part of the protection system.
- **External Components**: The external components that are part of the protection system.

**Protection Characteristics**

- **Characteristics**: The protection system's characteristics that might be susceptible to environmental deterioration and accidental damage.
- **Degradation**: The ways that the protection system could be degraded and how the factors that could cause degradation might be detected.

**Other**

- **Remarks**: Any additional comments about the protection system.
- **History** provides information about when the record was created and last updated. If the **history log** has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the record.

### L/HIRF Analysis in LHSI Projects

#### Building the L/HIRF Hierarchy

**MPC Plus Only**

Projects that use MSG-3 guidelines that support identification of L/HIRF Significant Items (LHSIs) — i.e., Revision 2015 Vol 1 (LHSI Identification) or Revision 2015 Vol 2 (LHSI Identification) — are considered LHSI projects. If your project uses one of these guideline versions, there will be a separate L/HIRF hierarchy, which allows you to identify LHSIs for ATA systems and/or subsystems; L/HIRF environmental damage/accidental damage (ED/AD) analyses can be performed for these LHSIs. To access the L/HIRF hierarchy, click the L/HIRF Hierarchy tab on the **System panel**.
In the L/HIRF Hierarchy tab, there can be no more than three levels in the hierarchy (system, subsystem and LHSI), and the first two levels must be selected from a predefined list of ATA chapters (systems) and sections (subsystems) that are stored in the database.

Each item has properties associated with it, which are viewed and edited on the Properties tab of the Analysis panel when the item is selected.

Available Columns
The following columns are displayed in the L/HIRF hierarchy:

- **ATA #** displays the item number. For systems and subsystems, this is the ATA-assigned number. For LHSIs, this is the value given in the item properties.

- **Description** displays the name and/or description of the system or item.

- **Status Updates** displays a paper clip icon if the item contains any status update notes.

- **Attachment** displays a paper clip icon if one or more files or URLs have been attached to the corresponding item. It displays a Description and Operation (D&O) document is one of the attached files.

- **Flag** displays a flag for the item, if desired. The available flags are: Complete (indicated by a green flag), In Progress (indicated by a yellow flag) and Incomplete (indicated by a red flag). In all ReliaSoft applications, flags are displayed in the interface only and do not affect analysis results or reports.

- **User Access** displays an icon when the item is inaccessible. (See Status Indicators.)
  
  - If the item is in use by another user, an in use icon will be displayed. Point to the in-use icon to display the name of the user who is accessing the item.
  
  - If you do not have the item permissions needed to edit the item, a restricted access icon will be displayed.

- **Environmental/Accidental Damage Analysis** displays a paper clip icon if an environmental damage/accidental damage (ED/AD) analysis has been created for the LHSI.

Adding Systems and Subsystems
For compliance with the ATA numbering guidelines, the available system and subsystems have been predefined for the database. (See Managing ATA Chapters.)

- To add a new system, choose L/HIRF > Add > Add System(s).

- To add a new subsystem, select a system and then choose Systems > Add > Add SubSystem(s).
Both commands open windows that display the list of systems/subsystems that have been predefined for this database. Use the check boxes to select one or more items to add to the hierarchy and click OK.

Note that each system/subsystem can be used only once per project. So if the item already exists in the current system configuration, the text will be grayed out and you will not be able to select it.

The command to add subsystems will be disabled if at least one LHSI has already been defined for the parent item. LHSIs can be added under any type of record (system or subsystem), but they must always be the lowest level in any particular branch of the hierarchy.

Adding L/HIRF Significant Items
LHSIs are not predefined for the database. Instead, you have the flexibility to create these records as needed for your particular analysis.

- To add a new LHSI, select the parent item (must be a subsystem) and choose Systems > Add > Add LHSI.

There is no limit to the number of LHSIs that you can add for the same subsystem, and you can use any number for the # field as long as it is unique among the LHSIs associated with that item.

Deleting
To delete an item from any MPC hierarchy, select the hierarchy item and press DELETE. The hierarchy item will be deleted, along with all dependents and all associated attachments. **There is no undo for deleting an item or the entire hierarchy.**

Cutting/Copying
You can cut or copy items in any MPC hierarchy and paste them to the same project or to another project within the same database. (Please note that if you want to share hierarchy items between different databases, you must use the import/export functionality instead.) To select multiple hierarchy items for cut or copy:

- Click the first hierarchy item and then press CTRL and click additional hierarchy items at the same level of the hierarchy.

  or

- Click the first hierarchy item, then press SHIFT and click another hierarchy item to select all hierarchy items at the same level of the hierarchy between and including the two.
After you select the hierarchy items, you can use the standard keyboard shortcuts for cut/copy (CTRL+X and CTRL+C) or you can choose Home > Clipboard > Cut and Home > Clipboard > Copy. When a hierarchy item is cut or copied, all dependents will also be cut or copied, along with any attachments.

**Pasting**
To paste items that you have cut or copied from any MPC hierarchy, press CTRL+V or choose Home > Clipboard > Paste. Note the following:

- For the top two levels in the hierarchy (i.e., systems/subsystems, structures/substructures or major zones/major sub-zones), each item can be used only once per project. If an item with the same number already exists within the project you are pasting to, you will be prompted to decide if you want to replace the existing hierarchy item or cancel.

- If a hierarchy item is cut or copied but then deleted from the project, the copied data will also be deleted from the Clipboard. In addition, once a hierarchy item has been cut or copied, any edits that are made to the original will also be applied to its copy in the Clipboard. In other words, if there are changes to the original hierarchy items after you cut/copy them but before you paste them somewhere else, this will affect the data that can be pasted. Also note that you will not be able to cut or copy a hierarchy item in a project that is locked by another user.

**Importing**
It is easy to import any entire hierarchy (or selected items) from any project in the same database or another selected database. (See Importing MPC Hierarchies Between Projects.)

**L/HIRF Item Properties**

* MPC  Plus Only

When an item is selected in the L/HIRF hierarchy, you can view and edit its properties on the Properties tab in the Analysis panel. The following fields are available.

- **General**
  - **ATA #**: The item number. For systems and subsystems, this is the ATA-assigned number and cannot be changed from the Properties tab. For LHSIs, the only limitation is that the numbers must be between 1 and 9999 and they must be unique for all the LHSIs that are associated with the same item.
  - **Description**: The name and/or description of the item.
Chapter 8: Zonal and L/HIRF Analysis

- **Zone:** Which aircraft zone the item belongs to. While you can use the same numbers as used in the Zonal analysis, this is not required.

- **Access:** The type of access that is required in order to perform inspections on the structure.

- **Part Number:** The part number of the item.

- Any information that you enter in the Remarks field will be displayed in the Remarks section of the Item Properties Summary report.

- The **Working Group Info** area displays information about the most recent working group that performed analysis for the current hierarchy item. It is updated automatically when you add an item or change an item property, and is based on the current working group session stamp. If desired, you can also update it manually (e.g., to force all of the items to show the latest working group information before you generate a report). Click the **Edit** icon, to open the Current Item Working Group Stamp window.

- The **History** fields display information about when the item was created and last modified. These details are recorded automatically by the application. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the item.

**LHSI Selection Questions**  
☑ MPC Plus Only

When you select an LHSI in the L/HIRF hierarchy, a panel at the bottom of the Properties tab displays questions that will allow you to determine whether L/HIRF environmental damage/accidental damage (ED/AD) analysis is needed for the LHSI.
To answer a question, click inside the Response column to toggle between Yes and No. A "Yes" answer to any of the questions will enable the **L/HIRF > Analysis > Add ED/AD Analysis** command on the ribbon.

If desired, you can use the Comments fields to record additional information about the answer selected.

---

**L/HIRF ED/AD Analysis**

MPC Plus Only

You can perform L/HIRF environmental damage/accidental damage (ED/AD) analysis for any L/HIRF Significant Item (LHSI) that has a "Yes" answer to any of the LHSI selection questions.

The rating system is configurable at the database level. (See [Configurable Options for Zonal and L/HIRF Analysis](#).) This topic describes:

- How to [add or delete an ED/AD analysis](#).
- How to [use the ED/AD Analysis tab](#).

**Adding or Deleting an Analysis**

To add a new ED/AD Analysis tab, select an LHSI in the L/HIRF and choose **L/HIRF > Analysis > Add ED/AD Analysis**.
Chapter 8: Zonal and L/HIRF Analysis

To delete an analysis, select a tab in the Analysis panel and then choose L/HIRF > Analysis > Delete Analysis. (Remember there is no undo for delete.)

Using the ED/AD Analysis Tab

Top Section: Ratings

The top section of the ED/AD Analysis tab contains the following rating system:

- **Hostility of Environment/Material Ratings**
  - **Hostility of Environment**: A set of ratings that are used to classify a variety of environmental factors (such as exposure to corrosive products, condensation, etc.).
  - **Material**: A set of ratings that are used to classify various material characteristics and their susceptibility to damage.

  The **Hostility of Environment/Material** score is assigned based on a scoring matrix that considers the worst rating for any of the hostile environment factors and the worst rating for any of the material types. You can click the icon to see the matrix.

- **Likelihood of Accidental Damage**: A set of ratings that are used to classify the likelihood of accidental damage during manufacturing, operation of the aircraft or maintenance practices.

- **ED/AD Overall Rating**
  - The **Likelihood of Accidental Damage/Environmental Damage Susceptibility** score is assigned based on a scoring matrix that considers the environmental damage susceptibility (i.e., the Hostility of Environment/Material score) and the worst rating for any of the accidental damage types. You can click the icon to see the matrix.

Bottom Section: Tasks

The bottom section of the tab allows you to define any maintenance tasks that are recommended based on the ED/AD analysis.

To add a new task, choose L/HIRF > Tasks > Add Task.

To view or edit the properties of an existing task, select the task and choose L/HIRF > Tasks > Edit Task.
For information about the task properties, see L/HIRF Analysis Tasks.

L/HIRF Analysis Tasks

The Task Properties window allows you to view/edit all of the properties for a particular maintenance task.

To add a new task for an L/HIRF analysis, choose L/HIRF > Tasks > Add Task (in an LHSI project) or Zones > Tasks > Add Task (in a non-LHSI project).

To view or edit the properties of an existing task, select the task and choose L/HIRF > Tasks > Edit Task (in an LHSI project) or Zones > Tasks > Edit Task (in a non-LHSI project).

The following properties are available for tasks that are recommended based on an L/HIRF analysis:

- Together, the **Group #** and # fields form the unique identification number for the task; for L/HIRF tasks, all task identification numbers have an "L" appended to the end. You have the option to organize tasks into up to ten groups, and when you select a group number from the drop-down list, the # field will be set automatically to the next number in the sequence for the selected group. For example, if the new task belongs to Group 3 and two other tasks have already been created for Group 3, the unique identification number for the new task will be Group 3, Task 3. If you do not want to organize tasks by group, you can simply accept the default group number for all new tasks (which is set in the MPC Application Setup).

- The **Task Type** field allows you to specify the type of maintenance task by choosing from a drop-down list. This cannot be changed after you have saved the task. Note that although the options in the drop-down list are determined by the requirements of the ATA guidelines, the abbreviations can be modified, if desired. (See Task Type Abbreviations in MPC.)

If no other tasks have been defined for the current analysis, the **No Task Selected (NTS)** option will appear at the bottom of the drop-down list. When you select this option, all of the task properties (except the Task Description field) will be disabled. You will not be
able to add any other maintenance tasks for this analysis without first deleting the NTS record.

- The **Task Title** field allows you to provide more information about the task.

- The **Task Description** field allows you to provide more information about what the task is designed to do. Note that if the Task Type is "No Task Selected" then the field becomes a drop-down list where you can select an option that explains why no task has been selected for this analysis.

**Interval Info**

- For **Interval Type**:
  
  - Select **Fixed (Numerical)** if you want to the interval to be recorded as a number with an associated unit (e.g., 2,000 flight hours can be stored as value = 2000 and unit = FHr). Numbers may be easier to sort.
  
  - Select **Based on Events (Text)** if you want the interval to be stored in a text field, which can contain any combination of letters or numbers (e.g., “Per Mfr Recommendation”).

- For **Interval**:
  
  - If you choose to enter a number, the field will be split into two sections so you can enter the time and then select the units from the drop-down list. The options in the drop-down list can be modified. (See [Unit Settings](#)).
  
  - If you choose to store the interval as text, you can type up to 100 characters into the field.

**Zone**

- **Zone** is available only in LHSI projects. This field allows you to specify where in the aircraft the relevant part is located (i.e., the zone where the task will occur). While you can use the same numbers as used in the zonal analysis, this is not required.

**Other**

- Use the **Manual Reference** field to record additional information about the task, such as where in your maintenance procedures the task is described.

- Use the **Effectivity** field to record additional information about the task, such as how effective the task is designed to be when performed.
• Use the **Access** field to record the type of access that will be required in order to perform the task.

• Use the **Procedure** field to record additional information about the procedure used to complete the task.

• Use the **Remarks** field to record additional information about the task.

• **History** provides information about when the record was created and last updated. If the [history log](#) has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the record.

• **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

---

**Zonal and L/HIRF Analysis Reports**

MPC Plus Only

For zonal and L/HIRF analyses, MPC provides a set of predefined report forms that you can generate in Microsoft Word.

In LHSI projects (i.e., projects using one of the MSG-3 guidelines that support identification of L/HIRF Significant Items), the reports are separated according to analysis type. For zonal analysis reports, choose **Zones > Reports > Reports**; for L/HIRF analysis reports, choose **L/HIRF > Reports > Reports**.

In non-LHSI projects, both zonal and L/HIRF analysis reports are available by choosing **Zones > Reports > Reports**.

You can also generate a report that shows all tasks in the project from all analysis types - systems and powerplant, structural, zonal and L/HIRF. (See **Maintenance Review Board Reports**.)

**Zonal Analysis Reports**
The available zonal analysis reports include:

• Summaries (basic and detailed) of the item properties for all selected zones.
Chapter 8: Zonal and L/HIRF Analysis

- The full details for each selected zone.
- The ability to insert any D&O documents that have been attached to selected zones.
- A summary of each standard zonal and enhanced zonal analysis that was performed for the selected zones.
- A summary of the standard zonal analysis tasks and the enhanced zonal analysis tasks that were defined for the selected zones.
- A summary of all maintenance tasks that were defined for the selected items.
- The full details for each maintenance task.

L/HIRF Reports
In LHSI projects, the available L/HIRF analysis reports include:

- A summary of the item properties for all selected items.
- A summary of the LHSI questions for the selected items.
- The details of the LHSI questions for each selected item.
- The ability to insert any D&O documents that have been attached to selected items.
- A summary of each Environmental Damage/Accidental Damage (ED/AD) analysis that was performed for the selected items.
- A summary of the L/HIRF analysis tasks that were defined for the selected items.
- The full details for each maintenance task.

In non-LHSI projects, the available analysis reports include:

- A summary of each L/HIRF ED/AD analysis that was performed for the selected zones.
- A summary of the L/HIRF analysis tasks that were defined for the selected zones.

Select Items
In the Select Items area, specify the items from the hierarchy that will be included in the report. You can generate a report that contains data from a single analysis or from multiple analyses together.

Select Report Forms
The Available Reports area displays all of the available report forms that are not yet selected. This list includes the standard report forms that are shipped with the software, as well as any custom report templates that you have created.
The **Selected Reports** area displays the forms that have been selected for inclusion in the generated report, in the order in which they will appear. You can drag and drop the selected forms into the desired position or use the **Up/Down** icons.

You can double-click a report or use the **Include/Exclude** icons to move the report between the areas.

Drag and drop the selected forms into the desired position or use the **Up/Down** icons.

Use the **Sort Tasks By** area to set the sort order for tasks: by number, by type (e.g., LUB, SVC, etc.) or by repeat interval (with most frequent tasks listed first).

**Report Settings**

If you want to customize any of the report settings (e.g., font, paper size, add a logo, etc.), click the **Report Settings** button to open the Report Settings window, then adjust any of the following settings before generating the report:

- **Report Logo** will display in the document header, if specified.
  - **Select Logo** allows you to import a *.bmp, *.dib, *.gif, *.jpg, *.wmf, *.emf, *.ico or *.cur graphic. Note that the logo will be scaled down to a maximum size of 150 x 75.
  - **No Report Logo** displays no logo on the printed report.
  - **Default Logo** displays the default MPC graphic that was shipped with the application.

- **Paper Size** specifies whether the documents will be configured for U.S. Letter or A4-sized paper.

- **Description and operation documents page settings** specifies whether included Description & Operation (D&O) documents will maintain their own page margin settings or use the generated report margin settings.

- **Order for pages that are printed multiple times** sets the order the pages will be printed in.

- **Use name (not abbreviation) for time units** displays the full name of all time units on reports (e.g., 1000 Flight Hours or 1000 FHR).

- **Include 'Task Title' field** displays the task title with the other task details.
Generate Report
When you click Generate Report, you will be prompted to specify the pathname/filename for the new Word document that will be created.

*Tip:* For all predefined Word document reports, the information displayed in the footer of the print-ready report documents comes from the Working Group Stamp stored for the item.
Chapter 9: Custom Reports

The custom reports window allows you to build your own report templates for systems and powerplant analysis, structural analysis and zonal analysis.

(If you want to generate one of the predefined reports that are specifically designed for submission to the ATA Maintenance Review Board, use the MSI Report Window, Structural Reports Window or Zonal Reports Window instead.)

To open the custom reports window, make sure the appropriate hierarchy tab has focus, then choose Reports > Custom Reports on the relevant ribbon tab.

Select Items

In the Select Items area, specify the items, structures or zones that will be included in the report. You can generate a report that contains data from a single analysis or from multiple analyses together.

Selected Report Forms

The Available Reports area displays all of the available report forms that are not yet selected. This includes all of the available report forms that are shipped with the software as well as any custom report templates and custom queries that you have created.

The Selected Reports area displays the forms that have been selected for inclusion in the generated report, in the order in which they will appear.

You can double-click a form or use the Include (>, >>) or Exclude (<, <<) icons to move the form between the areas.

Drag and drop the selected forms into the desired position or use the Up/Down icons.

For tabular report forms, use the Sort By and Ascending columns to specify how to sort the data. For example, you can generate an MSI Tasks (Detailed) report that sorts by Task Description in ascending order of their descriptions.
Chapter 9: Custom Reports

Report Settings
If you want to customize any of the report settings (e.g., font, paper size, add a logo, etc.), click the Report Settings button to open the Report Customization/Settings window.

Templates Manager
If you want to create or edit any of the custom report forms, click the Templates Manager button to open the Report Templates Manager.

In a secure database, only users with the "Manage MPC settings" permission have the ability to modify or delete report templates.

Generate Report
Before generating the report, make sure the desired output type is selected (Word Document or Excel Spreadsheet) and then click Generate Report.

For custom MSI reports and custom SSI reports, if any of the selected forms contain task information, when you click Generate Report you will be prompted to select exactly which task types to include in the report and whether each selected task type will begin on a new page.

Tips
- If you have set your computer to use large fonts, you will need to set your screen display to at least 1152x864 for all forms to display correctly. If you have set your computer to use small fonts, you will need to set your screen display to 600x800.

- If you have enabled the "Check spelling as you type" and "Check grammar as you type" options in Microsoft Word and you have a very large number of spelling/grammar issues in your data set, then Microsoft Word may stop responding during report generation, resulting in a blank document and possibly error messages such as "RPC Server Unavailable." If this occurs, you can temporarily disable these options in Word and regenerate the report.

- The regional settings for Windows and Microsoft Office (Word and/or Excel) must be compatible when generating reports in MPC.

- The number of forms in your report cannot exceed the maximum supported by Microsoft Excel. Generated reports will include as many forms as possible up to the limit, which will vary depending on the version of Excel that you are using, and will omit the rest.
Report Customization/Settings Window

The Report Customization/Settings window allows you to establish your preferences for configurable reporting options, such as the logo to be displayed in report documents, the font style and size, etc.

To open the utility, click the Report Settings button in the Custom Reports window.

- **Report Font, Header Font** and **Footer Font** set the font and size for the text in the body, header and footer of the reports that you generate from your computer. Please note that there are specific limitations for some fonts and sizes, as discussed in **Font Size and Style Considerations** below.

- **Logo for Printed Reports** will display in the document header, if specified.
  - **Select Logo** allows you to import a *.bmp, *dib, *.gif, *.jpg, *.wmf, *.emf, *.ico or *.cur graphic. Note that the logo will be scaled down to a maximum size of 150 x 75.
  - **No Report Logo** displays no logo on the printed report.
  - **Default Logo** displays the default MPC graphic that was shipped with the application.

- **Paper Size for Reports** specifies whether the documents will be configured for U.S. Letter or A4-sized paper.

- **Other**
  - **Display column headers on every page for Excel reports** repeats the rows up to and including the column headers on every page of reports generated in Excel.
  - **Set generated report files as read-only** sets the generated Word and Excel documents to "Read-only" on the General page of the document Properties window.
  - **Use name (not abbreviation) for time units** displays the full name of all time units on reports (e.g., 1000 Flight Hours or 1000 FHR).
  - **Repeat data in spreadsheet reports** ensures that each row in a F-F-E-C Spreadsheet report will contain all F-F-E-C information related to that row, even if some of the information is repeated from the row above and would otherwise have been "merged" within the table. For example, if there are two causes for the same failure, then the report will display the same function, failure and effect data in both rows. This option is useful if, for instance, you need to be able to sort the rows in the generated report or if you need to copy a single line of the report for external use. This option is available only for custom MSI reports.
Chapter 9: Custom Reports

- **Merge cells in spreadsheet reports** merges the blank cells below a record in a column with that cell. This option is available only for custom MSI reports.

- **Footer**
  - **Footer for Printed Reports** allows you to specify the text displayed in the footer of all reports.

**Font Size and Style Considerations**
Please note that the software allows you to select a font size as small as 6 pt even though Excel may be unable to properly render certain fonts at sizes that small. This limitation tends to apply to more ornate fonts (e.g., Lucida Calligraphy). If you encounter a situation where the report generated by the software does not display in the font that you have selected, it is recommended to increase the font size to 8 pt or higher and generate the report again.

**MPC Templates Manager**
In MPC, the Templates Manager allows you to manage the configurable templates for customized reports or saved queries. If you are working with an enterprise database, the templates will be stored directly within the enterprise database, and therefore the same custom report forms and queries will be available to all database users (if the creator selected the **Show to all repository users** check box when creating the template).

If you are working with a standard database (*.rsr19), the templates will be stored in the standalone template file (*.mprt19) that is currently active on your computer. If multiple users need to share the same custom report forms, you can store this file in a shared network location that is accessible to all users. Each person can use the address bar at the top of the Templates Manager window to specify which *.mprt19 file is currently active for his/her computer.

To open the utility click **Templates Manger** in either the Custom Reports window or the Select Existing Query window.

The utility has two tabs: one for **report templates** and one for **query templates**.

**Active File and Reset Templates**
When you are using a standalone template file, you can use the **Reset Templates** button if you want to restore a copy of the original MPRUT.mprt19 file that was installed with the software.

This action will not override any custom report templates that you might have created in the original MPRUT.mprt19 file. Rather it will create a new standard templates file in the ReliaSoft folder under My Documents on your computer (e.g., C:\Users\<your USERNAME>\My
Chapter 9: Custom Reports

Documents\ReliaSoft\MPC19). If a file with the same name already exists in this location, then the new filename will have an increment at the end (e.g., MPRUT1.mprt19).

Import Templates
To import existing templates, select the tab for the type of template you want to import (Report or Query) and then click the Import button.

In the Import Templates window, select the Standard template (*.mprt19) or enterprise database (*.rserp) that the template will be imported from.

The table displays a list of the templates that have been defined in the selected file or database. Select the templates that you want to import, and then click OK to start the import.

Custom Report Templates
If you have reporting needs that are not met by the standard reports forms included in the Custom Reports window in MPC, you can create your own custom report templates. They will be shown in the list of available report forms in the Custom Reports window and can be included in your generated reports. The available reports are specific to each analysis type.

To open the Reports Template window, click the Add button or the Edit button on the Report Templates tab of the MPC Templates Manager.

- The Fields tab allows you to choose and configure the fields to be shown in the body of the report.
- The Column Header Customization tab allows you to configure the column headers shown in the report.
- The Preview tab displays an approximate preview of the template incorporating the settings you have specified on the other two tabs.

Fields
On the Fields tab of the Report Template window, the Available Fields area displays all of the properties available to use that are not yet selected.

The Selected Fields area displays the properties that have been selected for inclusion in the template, in the order in which they will appear. You can drag and drop the selected properties into the desired position or use the Up/Down icons.

You can double-click a property or use the Include/Exclude icons to move the property between the areas.
Column Header Customization
Each field that you have selected for inclusion in the report template on the Fields tab will appear in the table on the Column Header Customization tab.

There are four options for column width:

- **Fit Header** will size to fit the text in the column header (i.e., the column name).
- **Fit Data** will size to fit the widest data text in the column (i.e., all of the rows below the column name).
- **Fit Header/Data** will size to fit the widest text in the column, regardless of whether it is the column name or the data.
- **User Defined** allows you to specify the exact column width (number of characters).

By default, the column headings will use the names shown in the Property Name column. You can overwrite that by entering text in the Overwrite Default Header Text column.

Once you have configured all options to suit your needs, you can go to the Preview tab to see what the report template looks like. You can also click OK to save the report template.

Repeat Column Headers in Word
If you generate a report in Microsoft Word, you may have cases where a report table splits across multiple pages. By default, Word does not repeat the header rows at the top of every page. However, you can force Word to do so by using the following instructions.

The following instructions are for Word 2010; if you are using another version of Word, the options may vary.

- Generate the report in Word.
- On the first page of the table, select the column headings and then choose Layout > Data > Repeat Header Rows.

If you experience problems with the bottom border not displaying properly for a row that spans across two pages, then you can do the following:

- Generate the report in Word.
- Select the first data row in the spreadsheet table then choose Layout > Rows & Columns > Insert Above. This row is going to be used to assure that there is always a bottom border for the heading rows, even if the data rows span across pages.
• Select this row and the rows above (i.e., the column headings) and choose Layout > Data > Repeat Header Rows.

• Select the row that you inserted and choose Layout > Table > Properties.

• On the Row tab, specify 0.001 and Exactly for the Row Height, then click OK.
Chapter 10: Query Utility

The Query utility is a powerful tool that makes it easy to find and open specific sections of an analysis. It is also a flexible reporting tool that allows you to create and manage saved queries that meet your particular presentation requirements.

To open the Query utility, make sure the appropriate hierarchy tab has focus, then choose [Systems/Structures/Zones] > Reports > Queries.

Use the left panel to specify the data source (either the current project or selected projects from the entire database). Use the right panel to choose the type of query (items, F-F-E-C causes, etc.) and specify the criteria/output preferences. Then click Run Query to view and use the results.

Specify the Data Source

Use the panel on the left side of the Query window to specify the data source for the query. This can be either the current project or selected project(s) from the entire database.

The Query window can utilize the same project filters that are available in many other locations throughout ReliaSoft desktop applications.

This feature might be particularly useful for an enterprise database that may be used to store analysis projects for the entire organization in a single centralized location. In such cases, the number of projects displayed in the project list could become overwhelming and these filters provide the ability to display only those projects that are of interest to you at any given time.

To remove the filter, select Show All from the drop-down list.

Use the check boxes to select the specific projects to run the query against.
Chapter 10: Query Utility

Specify the Query Criteria

After you have selected the data source in the left panel of the Query window, you can use the right panel to specify the query criteria and output preferences.

First, use the drop-down list at the top of the panel to choose which type of record you wish to query (items, F-F-E-C causes, etc.). This will automatically update the Criteria tab to display all of the relevant properties of the selected record type.

Then specify whether the query results will match the conditions from All rows in which criteria are specified (i.e., AND) or from Any row in which a criterion is specified (i.e., OR).

Then use the table to enter the criteria and choose which columns will be displayed in the results.

As an example, the following picture shows a query for system hierarchy items where the Item Description contains "Wiring Harness" AND the Supplier contains either "CYTA" OR "ACME JTE."
The Item Description, Part Number and Supplier columns will be included in the results.
Customize the Column Headers

After you have specified the query criteria in the Query window, you can use the Headers Customization tab to determine how the selected properties will be displayed in the query results.

Use the up and down arrows to set the desired column order.

There are four options for the column width:

- fit the label in the column heading
- fit the widest label in the column data
- fit the widest label in either the heading or data
- use a fixed width (as specified in the User-Defined Column Width (Characters) column)

By default, the column headings will use the names shown in the Property Name column. You can overwrite that by entering text in the Overwrite Default Header Text column.

For example, the following picture shows a query where the Part Number column will be exactly 10 characters wide while the Item Description and Supplier columns will be as wide as the heading text. In addition, the heading of the supplier column will display as "Manufacturer."
View and Use the Query Results

Once you have configured the query criteria and the column headings to suit your needs, click Run Query to display the results on the Results tab.

To go to a specific record, either double-click the record in the table or select the record and click the Go To icon.

The Query utility will remain open, but the focus will change to the Project window and the record will be selected in the System panel or in the Analysis panel.

You can also click the Send to Excel icon to save the results table to an Excel spreadsheet.

Special Considerations for MSI Task Query Results

Because an MSI task may be used in multiple locations within an MSI analysis, the same task may be repeated in the query results, if applicable. Specifically:

- If you have considered only the MSI Task properties, each unique task will be displayed only once in the results (even though it is used in multiple locations in the F-F-E-C).
- However, if you have considered other properties from any of the parent records (e.g., causes, items, etc.), the results will include a separate row for each relevant instance.

For example, the following picture shows query results from a situation in which the same MSI task is used in two locations within a particular F-F-E-C. The record is shown twice in the results because the query has been configured to include details about where the task is used (in this case, Failure Cause and Item Description).
Query Templates

Query templates allow you to save a great deal of time if you have particular queries that you run repeatedly. Saved query templates are also listed in the **Available Reports** area of the Custom Reports window for the particular analysis and can be included in generated reports.

If a standard database (*.rsr19) is open when you save a query, it will be stored in the standalone template file (*.xrt19) that is active for your computer. If an enterprise database (SQL Server or Oracle) is open, then the query will be stored within the enterprise database itself.

**Using a Saved Template in the Query Utility**

To use a saved template in the Query window, click the **Open Saved Query** icon.

The Select Existing Query window will display all saved template files for the type of query that was selected in the Query window (items, Functional Failures, etc.). If you want to search for a different record type, use the drop-down list to update the table.

To select a template, double-click the row or select it and click **OK**.

The settings on the Criteria and Headers Customization tabs of the query utility will change to reflect the settings used in the saved query.

If you change the criteria in the Query utility after applying a template, your changes will not affect the saved template. (If you want to update an existing query, use the **Edit** command in the Templates Manager, or simply delete the old template and replace it with a new one.)

**Saving New Templates from the Query Utility**

To create a template from within the Query utility, configure all of the desired options on the Criteria and Headers Customization tabs and then click the **Save Query** icon.
The saved template includes all of the settings specified on the Criteria and Headers Customization tabs. It can then be applied to any data source.

**Adding and Editing Templates via the Query Template Window**

You can also create or edit query templates from the [Templates Manager](http://mpc.reliasoft.com). To open the manager, click the **Open Saved Query** icon, then click **Templates Manager**.

Click either the **Add** or the **Edit** button on the Query Templates tab. The Query Template window works in the same way as the [Query utility](http://mpc.reliasoft.com), with the following exceptions:

- You cannot specify the data source, as the query template can be used with any data source.
- On the panel on the left side of the window, you must specify a name and, if desired, a description of the query template.
- Instead of a Results tab, the Query Template window has a Preview tab that shows the columns you have selected to include in the results.
Chapter 11: MPC Settings

The Application Setup contains personal preferences that are stored per computer/username. These include default settings for new analyses/plots that you create from this computer, as well as personal preferences that don’t affect shared analysis data stored in the database.

In addition, note that the region and language settings will determine how dates, times, decimals, currency, etc. are displayed on your computer.

To open the Application Setup window, choose File > Application Setup.

The settings on the pages listed under Synthesis Settings are the same for all ReliaSoft desktop applications; the pages listed under the application name contain settings that apply only to the current applications.

Synthesis Settings

- **Interface** sets the language and the skin (color scheme) for the software interface. Selecting a skin shows you a preview of the changes in the Application Setup window. The change takes effect in the rest of the interface the next time you launch each application.
  
  Note that a language change will not affect applications that are currently available only in English.

- **Open With** sets the ReliaSoft application to launch by default when you double-click an *.rsr19 or *.rserp file from this computer. If you want to be prompted to choose an application each time, select Show the ReliaSoft Launcher.

- **Recent Repositories List** sets the maximum number of recently saved database files to be displayed in the "Recent Repositories" list in the Backstage view.

- **Auto Save** specifies when folios and diagrams will be saved automatically. The application always saves folios/diagrams upon calculate or close. If you want to also
save periodically while you're editing, specify an interval. This can be useful if you're working across a network in an enterprise database.

- **Other**
  - **Allow multiple projects (project explorer)** applies to ReliaSoft desktop applications that use the current project explorer (i.e., Weibull++, ALTA, BlockSim, RENO, RGA, and Lambda Predict). Select the check box if you want to have multiple projects open at the same time. There is a separate setting for project windows in XFMEA/RCM++/RBI. (See [Working with Multiple Projects](#).)
  
  - **Show project name in opened folios** applies to ReliaSoft desktop applications that use the current project explorer (i.e., Weibull++, ALTA, BlockSim, RENO, RGA, and Lambda Predict). It shows the project name in [brackets] on the tab or window caption. This may be useful when you have multiple projects open at the same time.

- **Use web-based help.** Select the check box to always make F1 and other help commands open the most up-to-date help file from the Internet when possible. If you clear this check box, they open the local help file that was installed with the software.

- **Highlight 'Active' category in ribbon** applies a highlight color to the label that shows which tabs are currently active.

- **Use non-modal Resource Manager** locks the Resource Manager in a top window position so it can remain open while you have access to the project. If not selected, you must close the Resource Manager to return to the project.

- **Warn when changing metric associations** shows a warning when you select an existing metric in a situation that will change the metric's associated model. (See [Showing Metrics in Folios/Diagrams](#).)

- **Hide unused project folders** applies to ReliaSoft desktop applications that use the current project explorer (i.e., Weibull++, ALTA, BlockSim, RENO, RGA, and Lambda Predict). It hides from view all folders that do not contain any project items.

- **Highlight colors** sets the colors used to color-code values in the following analyses:
  - Results in the FMRA in BlockSim and XFMEA/RCM++/RBI
  - Certain BlockSim plots
  - BlockSim [FRED reports](#)
  - BlockSim [allocation analysis](#)
• Spread of failure rate contributions in a prediction folio in Lambda Predict.

Backup/Check Out Options
The Backup/Check Out Options page of the Application Setup can be changed from within any ReliaSoft desktop application.

• **Standard Repository Maintenance** applies to standard database files (*.rsr19) only. It allows you to automatically save a backup of a database in the location you specify when you close the application. The backup file will be named after the database file with the backup date appended (e.g., RSRepository1_2019-01-15.rsr19).

You can specify how many days of backups can be automatically saved (up to 10), but note that only one backup will be saved per day (e.g., if you open and close the same database three times in one day, only the final closing of the database will be saved in the backup folder).

Note that you can also create backups manually at any time by choosing File > Save As. For more tips on keeping databases running smoothly, see Backups and Database Maintenance: Protecting Your Data.

• **Check In/Out** specifies the default save location for projects that you check out from a database.

Other Synthesis Settings
The Synthesis Settings > Other page of the Application Setup can be changed from within any ReliaSoft desktop application.

• **Model, Variable and Workbook Names** disallows spaces and special characters in the names of models (including those published from any ReliaSoft desktop application) and variables, and in the names of workbooks created in BlockSim/RENO. This will ensure that all models, variables and workbooks can be used in RENO equations.

• **Display Object IDs**. Select the check box to always display the unique object identifier (object ID) of each project and resource in the repository. The project IDs will be displayed in the Manage Projects window and in the Edit Project Properties window, while the resource IDs will be displayed in the Resource Manager. In BlockSim, diagram IDs and block IDs will be shown in the control panel and, starting in Version 19.0.2, in the Block Details simulation results worksheet.

• **Copy Plot Graphic** sets the default file type to use when copying a plot to the Clipboard as an image. If you will be pasting copied plots into Synthesis Workbooks, choose
Chapter 11: MPC Settings

**Metafile for Synthesis use.** If you will be pasting them into external applications, choose Bitmap or Metafile for external use.

- This default setting is used when you copy a plot using Home > Copy or CTRL+C. If you want to choose the graphic on the spot, you can do so by right-clicking the plot and choosing the Copy Plot Graphic command on the shortcut menu.

- **Hierarchical Trees** sets the maximum number of lines for displaying names and descriptions in any of the hierarchical tree interfaces used in XFMEA, RCM++, RBI, Lambda Predict and MPC.

- **Alternative Credentials** applies to secure databases. It allows you to either save your alternative credentials (so your account is automatically logged in whenever you open a secure database from a different domain) or clear the credentials from this computer.

- **Diagram Skins Utility** converts diagram skins created in Version 9 to the latest version. Click the Convert link, and in the window that opens, select the name of the skin(s) that you wish to convert. You will need to close and re-launch the application to use the converted skin(s). (See "Converting Version 9 Skins" in the BlockSim, Weibull++/ALTA or XFMEA/RCM++/RBI documentation.)

### Application-Specific Settings

#### Properties Settings

The Settings page allows you to set your preferences for certain MPC features.

**General**

- **Show working group stamp window upon open** shows the Working Group Stamp window each time you open a database.

- **Flag parts with 'yes' answer(s) for MSI questions** displays a visual indicator in the system hierarchy if the part has at least one 'Yes' answer to any of the MSI selection questions.

- **Include tasks when pasting functions, failures, causes** includes associated tasks when you copy and paste records in the F-F-E-C tab for an aircraft systems and powerplant analysis.

- **Show tasks in F-F-E-C tab** shows tasks in the F-F-E-C tab for an aircraft systems and powerplant analysis (in addition to the Task Selection window).

- **Default task group number** sets the default 'Group #' for each new task that you create. You can change this number for any given task by editing the task properties.
MSI/SSI Number Format
This option specifies how MSI and SSI numbers will be displayed in reports (condensed or extended). (See Managing ATA Chapters.)

For example, System = 26, Subsystem =20 and Sub-Subsystem = 21 can be displayed as 262100 (condensed) or 262021 (extended).

Expand to this level by default
Sets the default levels shown in the system hierarchy and F-F-E-C hierarchy. You can choose to expand all branches, or collapse the branches under a specified level.

Reset Settings
The Reset Settings page of the Application Setup allows you to restore some or all of the settings to their original configuration. Note that it’s recommended to close all windows before resetting settings. If the change does not take effect immediately, restart the application.

- **Reset Common Synthesis Settings** resets the settings under the Synthesis Settings heading in the Application Setup.

- **Reset Application Settings** resets the settings under the current application’s heading in the Application Setup. It also clears any saved default column headings in life data (Weibull++), life-stress data (ALTA) and growth data (RGA) folios.

- **Reset Application Form Settings** resets the form settings for the current application (e.g., size and location of windows).

- **Reset Plot Settings** resets the Plot Setup settings that are applied by default when you create a new plot in the current application.

- **Reset FIDES Settings** (Lambda Predict only) resets the predefined FIDES settings (e.g., saved pi factors, process audits, etc.) that are applied by default when you create a new repository. (See FIDES Settings Manager in the Lambda Predict documentation.)

- **Reset Component Defaults** (Lambda Predict only) resets the component property values that are applied by default when you add a new component to a prediction. (See Default Component Properties in the Lambda Predict documentation.)

- **Reset All Settings** resets all the saved settings for the current application. This is the same as clicking all of the individual "Reset" buttons above.
Chapter 11: MPC Settings

Project Item Settings
ReliaSoft desktop applications offer a variety of configurable settings that are stored per computer/username and managed via the Application Setup.

Your personalized application setup determines the default settings for new folios, diagrams and flowcharts that you create in Weibull++, ALTA, BlockSim, RENO and RGA. The relevant settings are also saved with each individual folio/diagram and are accessible from the Item Properties window. This makes it possible to have different settings for different analyses, and also ensures that any given analysis will be the same for all database users.

To view and edit the configurable settings in the Item Properties window, select the folio, diagram or flowchart in the current project explorer and choose Project > Current Item > Item Properties.

The settings are displayed on the second tab of the properties window. (In a secure database, the settings can be edited only if the user is the project owner or has the "Create/edit project items" permission.)

If you modify the settings for a particular project item, the new preferences will be saved with the folio/diagram. The default preferences for new folios/diagrams in the application setup will remain unchanged.

Region and Language Settings
The Region and Language settings for your particular computer will have some impact on the way some information is displayed in ReliaSoft applications.

Users with different regional and language settings can work together on the same analysis projects because, in most cases, the basic information is stored in the database and the software simply displays it in the format preferred by each user. For example, if the date September 25, 2019 is stored in the database, User A might see it as "9/25/2019" while User B might see "25-Sep-19."

This topic first explains how to view or change the Region and Language settings on your computer and then discusses some specific considerations for ReliaSoft applications, including:

- Which language is selected by default when you install the software
- How dates and times will be entered and displayed
- How decimal values and currency will be entered and displayed
Viewing or Changing the Region and Language Settings for Your Computer

To view or change the region and language settings:

- In Windows 8 or Windows 10, move the pointer to the lower left corner of the desktop, then right-click and choose **Control Panel**. Click the **Clock, Language, and Region** option then click the **Region** link.

- In Windows 7, choose **Start > Control Panel** and then click the **Region and Language** link.

As an example, the Windows 7 interface is shown here. The Windows 8 and Windows 10 versions look different but function similarly.
Chapter 11: MPC Settings

Other relevant settings are managed via the Customize Format window:

- In Windows 8 or Windows 10, click the **Additional settings** button.
- In Windows 7, click the **Additional settings** button.

As an example, the Windows 7 interface is shown next.

![Customize Format window](image)

**Note:** To see the changed settings in the ReliaSoft application, you must close the application, and then restart it.
Which Language is Selected by Default When You Install the Software

The user interface for ReliaSoft desktop applications is available in several languages. You can change this language at any time by choosing an option from the Language drop-down list on the Synthesis Settings page of the Application Setup.

When you first install the software, it will check your computer's current language as it is set in the Format field in the Windows Region and Language window. If that language is supported in the ReliaSoft applications, they will use those settings; however, if that language is not supported, they will use the default setting of English.

Defining Date and Time Formats

Dates and times appear frequently throughout the ReliaSoft interface, including (but not limited to):

- The dates in the plot legend area of a plot in all ReliaSoft applications.
- The history provided throughout ReliaSoft applications (e.g., for resources, FMEA records, diagrams, in history logs, etc.).
- The dates in the worksheet view and in the record properties windows in XFMEA, RCM++, RBI and MPC.
- The dates in the "dates of failure" format and "usage" format of the Weibull++ warranty folios.

The Short date field from the Windows Region and Language window determines how dates are displayed. You can select any standard format (e.g., M/d/yyyy, dd/MMM/yy, yy/MM/dd) or you can create your own format using the available date notations.

The Short time field determines how times are displayed. You can select any standard format (e.g., h:mm tt, HH:mm, HH'h'mm) or you can create your own format using the available time notations.

The Windows settings do not apply to the following items:

- Dates and times in spreadsheet utilities (e.g., a spreadsheet module in Synthesis Workbooks, General Spreadsheets, etc.).
- Dates and times displayed in the Weibull++ event log folio are created by the folio and are not affected by the computer’s settings.
Changing the Decimal Symbol, the List Separator and the Currency Symbol

How decimal values are displayed depends on the value of the **Decimal symbol** field on the Numbers page of the Windows Customized Format window, which determines which character is used to indicate the decimal portion of a number (e.g., 85.25 or 85,25). In addition, the character used to separate the arguments in a list depends on the value of the **List separator** field. These settings affect how you enter functions in a spreadsheet module in Synthesis Workbooks or in General Spreadsheets, either manually or by using the Function Wizard.

For example, if the decimal symbol value is a comma, and the list separator value is a semicolon, you would enter a function like this:

```
=RELIABILITY("Weibull!Folio1!Data 1";500;100;0,9)).
```

Whereas, if the decimal symbol is a period and the list separator is a comma, it would be

```
=RELIABILITY("Weibull!Folio1!Data 1",500,100,0.9)).
```

The currency symbol that is displayed in the software depends on the selection in the **Currency symbol** field on the Currency page of the Windows Customized Format window.
Chapter 12: ReliaSoft CommonTools

Categories, Identifiers and Filters

Defining Categories

In all ReliaSoft desktop applications, you can use flexible categories and identifiers to filter and group analysis data in a way that fits your specific needs. There are two types:

- **Project Categories** can be applied to projects in all desktop applications.
- **Item Categories** can be applied to project items (e.g., folios, diagrams, system hierarchy items) and resources (e.g., models, URDs) in all desktop applications except MPC.

This topic describes how to define the categories that will be available throughout the current database. To learn how to use them to filter and group data, see Project and Item Filters. (For additional options related to categories for system hierarchy items, see Item Categories in XFMEA/RCM++/RBI in the XFMEA/RCM++/RBI documentation.)

Accessing the Project/Item Categories Window

There are two ways to access the Project/Item Categories window and specify which categories will be available throughout the current database. (In a secure database, these are available only for users with the "Manage project/item categories" permission.)

To open the window from the backstage view, choose File > Manage Repository > Project/Item Categories.

Alternatively, you can click inside any Category drop-down list (e.g., in a properties window, filter, etc.) and click the Edit Categories icon.
Adding, Renaming and Deleting Categories

- To rename an existing category, double-click inside the cell and edit the text.

- To add a new category in the same level as the one that is currently selected, click Add.

- To add a new category in the level below the one that is currently selected, click Add Below.

- To move a selected category up or down within the same level, select the row and click Up or Down.

- To move a selected category to a different level, click Promote or Demote.

- To delete a category, select the row and press the Delete key or click the icon. To delete all categories at the same time, click Clear All. There is no undo for delete.
Identifiers

In all ReliaSoft desktop applications, you can use flexible identifiers and categories to filter and group analysis data in a way that fits your specific needs. The identifiers are available for project explorer items (e.g., folios, diagrams, plots, etc.) and there is one standard set of identifier fields for all relevant locations.

This topic describes how to view and edit identifiers for each type of resource or analysis, and how existing identifiers will be converted from Version 8 or 9. To learn how to use identifiers to filter and group data, see Project and Item Filters.

For Resources

To view and edit the identifiers for most types of resources, you can simply open the properties window and select the Identifiers node. They can also be edited via the Batch Properties Editor.

Note that:

- For published models, the identifiers are obtained from the analysis (e.g., Weibull++ folio, BlockSim diagram, etc.). To make a change, you must first edit the identifiers for the analysis and then republish the model.

- Identifiers are not applicable for the following resource types: Variables, Maintenance Groups, Mirror Groups, Actions, Controls and Profiles.

For Project Explorer Items

To view and edit the identifiers for folios, diagrams, plots and other analyses in Weibull++, ALTA, RGA, BlockSim, RENO or Lambda Predict, select the item in the current project explorer and choose Project > Current Item > Item Properties.
The identifiers are always displayed on the first tab of the properties window.

When applicable, the fields are also visible on the Identifiers page of the control panel. If a folio has multiple data sheets, you can use this page to define separate identifiers for each sheet. Note that the Folio Identifiers will be used in item filters and in the Synthesis Explorer; while the Data Sheet Identifiers will be used when publishing a model.

You can use an asterisk (*) in any or all of the data sheet fields to apply the same text from the corresponding folio field. As an example, the following picture shows the identifiers for a Weibull++ life data folio that contains multiple data sheets for each design prototype of a new chandelier bulb in development. Although most of the data sheet identifiers will be the same as the folio (indicated with *), the Version and Comments fields have been modified for each data sheet. The data sheet identifiers will be used when you publish a model.

For System Hierarchy Items
To view and edit the identifiers in Lambda Predict, XFMEA, RCM++ and RBI, select an item in the system hierarchy and go to the Properties tab in the Analysis panel.
The fields are grouped together under the Identifiers heading.

- In Lambda Predict, Name will always be displayed. The remaining identifiers may be hidden or displayed via the Application Setup. (See Properties Settings in the Lambda Predict documentation.)

- In XFMEA, RCM++, and RBI, Name, Category, and Keywords will always be displayed. The remaining identifiers may be hidden or renamed based on the configurable settings for the current project. (See Configurable Settings in the XFMEA/RCM++/RBI documentation.)

![Identifiers Table]

In XFMEA, RCM++, and RBI, the same set of identifiers will be used for all analyses associated with a given system hierarchy item (e.g., FMEA, control plan, etc.).

**For Diagram Blocks**

To view and edit identifiers for diagram blocks in BlockSim, open the block properties and select the Identifiers node. The fields are also visible on the Identifiers page of the control panel when the block is selected.

You can use these identifiers in BlockSim’s Find utility and in the Batch Properties Editor.
Conversion from Version 8/9
The following table shows how the "global identifiers" from previous versions will be mapped when you convert existing data in a Version 8/9 database (where “-” indicates no change).

Project and Item Filters
In many locations throughout all ReliaSoft desktop applications, you can use flexible filters to limit a list of projects, project items (e.g., folios, diagrams, system hierarchy items, etc.) or resources (e.g., models, URDs, etc.).

The drop-down list contains the filters you have saved in this database, plus any filters that another user has chosen to share with other database users.
Use the drop-down list to apply an existing filter. To stop filtering the list, select **Show All** (formerly called "Default filter").

**Sharing Filters with Other Users**

To share a saved filter, open the filter's properties window and select the **Show to all repository users** check box.

In a secure database, a shared filter can be edited or deleted only by a) the user who created the filter or b) a user with the "Manage other repository settings" permission.

**Project Filters**

Project filters can be applied to lists that contain project names such as the **Project Manager** and **Synthesis Explorer**. The filter can either be a query based on specified criteria, or a selected list of projects.

- **Based on Criteria.** You can match **All Criteria** (AND query) or **Any Criteria** (OR query):
  - Owner ([project owner](#))
  - Category ([project category](#))
  - Analysis/Feature (whether the project contains analyses associated with the specified application or feature)
  - Last Updated By
  - Last Updated Date

- **Based on Selected Projects.** Click the **Add** button to select the projects you want to include, or the **Remove** button to remove a selected project from view.

Clear the **Show locked projects** check box if you want to exclude **locked projects** from the results, even if they meet the criteria.

Projects are always grouped based on whether they are **public, private or reference**. For additional grouping, select the **Group by category** and/or **Group by owner** check boxes. If you select both, the results will be grouped first by project category and then by project owner. For example:
Item Filters
Item filters can be applied to lists that contain project items and resources such as the Current Project Explorer and Resource Manager.

Select whether the item must match All Criteria (AND query) or Any Criteria (OR query):

- Category (item category)
- Created By
- Last Updated By
- Last Updated Date
- Identifiers (Name, Part Number, Version, Application, Supplier, Description, Comments and Keywords)

Synthesis Explorer

The Synthesis Explorer is available in all ReliaSoft desktop applications except MPC. You can use this flexible tool to explore all of the different analyses that are stored in the current database.

To access the utility, choose Home > Synthesis > Synthesis Explorer.

To reduce the amount of time required to populate the grid, first use the project and item filters (discussed below) to limit your search, then click Load Data.
The analyses shown in the explorer may include:

- Project items in Weibull++, ALTA, BlockSim, RENO, RGA and Lambda Predict (e.g., folios, diagrams, plots, Synthesis Workbooks, etc.).
- Analyses that are associated with system hierarchy items in XFMEA, RCM++ or RBI (e.g., FMEAs, control plans, risk based inspection analyses, etc.).
- Project Plans that can be created for any project.

You can filter/sort/group the analyses based on ReliaSoft application, analysis type, analysis creator and many other properties. You can also present the information in a wide variety of dashboard charts.

This topic summarizes the tools you can use to find and organize data in the Synthesis Explorer’s flexible grid. For information about presenting the data graphically, see Synthesis Explorer Dashboards. For a list of the properties that can be used in either the grid or the dashboard, see Synthesis Explorer Properties.

**Save and Apply Views**

Once you have customized the Synthesis Explorer’s grid to suit a particular purpose (using the built-in find/filter, column configuration and grouping features described below), you can save the preferences as a view that can be used again whenever you need it. A view is saved in the database and available only to the user who created it.

To create a view, first configure the grid to suit your particular needs and then click **Save View**.

To quickly apply these same preferences again at any time, click **Apply View** and select one of the saved views from the list.

*Note:* The view does not affect filtering that has been applied from the Project Filter, Item Filter or Category Panel.

**Project and Item Filters**

The Synthesis Explorer can utilize the same project and item filters that are available in many other locations throughout ReliaSoft desktop applications. For example, with the custom filters shown below, the Synthesis Explorer will show only analyses performed by Department A (project filter) that were modified within the last month (item filter).
To remove either filter, select Show All from the drop-down list. To remove both filters at the same time, select Clear Filters.

After you clear or change these filters, you must click Load Data again to update the grid.

**Category Panel**
The category panel provides a quick way to filter the data based only on item category. For example, you might use the panel to first view the analyses for Category A and then quickly switch to see the analyses for Category B.

To show or hide the panel, click Show Category Panel.

When there are many categories, the tools at the top of the panel can help you find and select the one(s) you need.

**Built-in Find/Filter, Configuration and Grouping Tools**
The Synthesis Explorer offers the same filter, column configuration and grouping tools that are built in to other utilities that use a similar grid (e.g., the Resource Manager). For details about how to use each feature, see:

- Finding and Filtering Records
- Configuring Columns
- Grouping Panel
Synthesis Explorer Dashboards

You can use the flexible Synthesis Dashboard utility for presenting data from the Synthesis Explorer.

As with any other Synthesis dashboard, you can use the Dashboard Viewer to select any of the layouts that have been predefined for this type of data, and you can use the Dashboard Layout Manager to create or edit layouts.

(In a secure database, the Dashboard Layout Manager is available only for users with the "Manage dashboard layouts" permission.)

Values and Arguments

When you’re creating bar charts or pie charts based on Synthesis Explorer data, note that the argument(s) determine the bars or slices shown in the chart and the value will always be the quantity of analyses that fit the specified criteria.

If you use the default Count option when specifying the value, then any of the Synthesis Explorer properties will return the same quantities. You may prefer to choose the one that gives the most appropriate chart label(s). For example, the following pie chart uses the same property (“Application Source”) for both the Value and Argument in order to display the total quantity/percentage of analyses for each ReliaSoft application.

**Tip:** Use the Design tab of the ribbon to configure the chart labels and other settings to fit your particular preferences. For example, in this chart, the Data Labels are configured to display the Argument, Value and Percent (e.g., BlockSim: 648 (23.44%).
If there is ever a situation in which you want to show only the number of distinct values for a particular property, you can use the **Count Distinct** option instead. For example, the following pie chart uses **User Created By (Count Distinct)** for the value in order to show the number of users who created analyses with each ReliaSoft application.
As you can see from looking at both charts, the "Count" shows that there are 648 total BlockSim analyses; while "Count Distinct" shows that only 18 distinct users created BlockSim analyses.

**Filtering the Data**

Any filters that are currently applied in the Synthesis Explorer grid will not be reflected in the dashboard charts. However, you can incorporate filters directly into the dashboard layout. For example, if you want to show all of the Weibull++ analyses that were created by a particular user, you can create a filter like the one shown next. (See Using the Filter Editor.)

In addition (or instead), you can configure the layout with one or more master filters that allow individual users to change the filters on-the-fly in the Dashboard Viewer. (See Configuring a Master Filter and Using Master Filters.)

**Synthesis Explorer Properties**

The following properties will be available when you are using either the grid or dashboard in the Synthesis Explorer.

**Application**

- **Application Source** is the primary ReliaSoft application (or product family) for viewing or editing the analysis. (Note that Project Planners and Simulation Worksheets are listed under Synthesis because they can be created/edited from more than one product family.)
• Application Activated? indicates whether the primary application is activated on your computer.

Project
• Project Name is the project in which the analysis is stored.
• Project Type indicates whether it is a public, private or reference project.

Analysis
• Analysis Name is the name of the folio, diagram, plot, system hierarchy item, etc.
• Analysis Type and Variant indicate the type of analysis. This can include project items (e.g., folios, diagrams, plots, etc.) and specific analyses that are associated with a system hierarchy item in XFMEA, RCM++ or RBI (e.g., FMEAs, risk based inspection analyses, etc.). The variant is used to distinguish:
  • Analytical vs. simulation RBDs and fault trees in BlockSim.
  • Discrete vs. continuous Markov diagrams in BlockSim.
  • The specific prediction standard in Lambda Predict (e.g., MIL-217, Telcordia, etc.). If the prediction folio uses more than one standard, this will show as "Multiple." If a standard has not yet been added to the prediction folio, the variant field will be blank.

Categories and Identifiers
Note that these properties are preceded with "SI" in the Dashboard Layout Designer, so that all identifiers can be grouped together in the data source panel.

• Category is the category assigned to the analysis.

• Name, Part Number, Version, Supplier, Application, Description, Comments and Keywords are the standard identifiers that can be defined for the analysis. Note that XFMEA/RCM++/RBI analyses use the identifiers defined for the system hierarchy item they are associated with.

Creation and Last Update
• User Created and Date Created indicate the database user who originally created the analysis, and the associated date/time.

• User Updated and Date Updated indicate the database user who last modified the analysis, and the associated date/time.
ReliaSoft Locator Links

ReliaSoft Locator Links provide quick access to specific analyses in a repository (similar to Windows shortcuts). You can save these link files anywhere on your computer or network, e-mail to a colleague, post on the Internet or an intranet, etc.

When you double-click (open) a ReliaSoft Locator Link file (*.rsllx), it will launch the appropriate ReliaSoft application and go directly to a specific project item (e.g., folio, diagram, plot, system hierarchy item, etc.) or FMEA record (e.g., function, failure, etc.), as long as the following conditions are met:

- The database still resides in the same location and you have access to the server.
- You have an active user account in the database.
- The required ReliaSoft application is activated on your computer.

**Tip:** In the case of a standard database, the locator link stores the pathname/filename that was open when the *.rsllx file was created. If that was a mapped network drive (e.g., P:\ReliaSoft\Repository1.rsr19), the link will only work if all other users have that drive mapped to the same letter. To make sure the link works for all users, you may need to open the database from the UNC pathname (e.g., \SharedDrive\ReliaSoft\Repository1.rsr19) before creating a locator link file.

Starting in Version 2019, ReliaSoft Locator Links created in Version 2019 or later do not include the software version information as part of the link. When you open a link, the software will attempt to connect to the database, regardless of the database’s version. If you attempt to open a standard database that was created in an earlier version, the software will automatically convert it to the latest version. If you attempt to open an enterprise database that was created in an earlier version, the software will display a message; you must then upgrade the enterprise database to the later version.

Creating a Locator Link

In an enterprise database, you can choose to either send the file by e-mail or save it to a specified location. In a standard database, the only option is to save the file because it is likely that the pathname may only work on your own computer (as discussed above).
• For an item selected in a current project explorer (Weibull++/ALTA, BlockSim/RENO, RGA or Lambda Predict), choose **Project > Current Item > Save Locator Link.**

• For an item selected in an XFMEA/RCM++/RBI system hierarchy, choose **System Hierarchy > Current Item > Save Locator Link.**

• For an item, structure or zone selected in an MPC hierarchy, choose **Tools > Save Locator Link** on the relevant ribbon tab.

**Note:** If you get a "Locator Link is not properly formatted" message, the locator link may be corrupted or is using old encryption. Create a new locator link using the methods described above.

**Posting Locator Links on a Web Page**

Remember that ReliaSoft Locator Links are files that must be opened from a computer where ReliaSoft desktop applications are installed. If you post the *.rsllx as a standard link on an HTML web page, you will need to instruct users to download the file (instead of opening directly from the web browser).

**What's Changed?** In prior versions, ReliaSoft Locator Links were version-specific and were not compatible with other versions.

**Watches and Alerts**

Automated alerts can be an effective tool to facilitate communication and track the status of assigned responsibilities.

Alerts can be sent via e-mail, **SMS text message** and/or **ReliaSoft portal messages**, depending on the **Receive automated alerts** preference specified for your **personal user account**.

• Alerts via portal message are always available in any database.

• Alerts via e-mail or SMS are only available if they are enabled for the database, and a valid SMTP server has been defined. (See **Enable Alerts via E-mail or SMS**.)

Alerts can be sent for:

• Any resource that you have personally subscribed to “watch.” (See **Subscribing to a Watch**.)

• Action resources, under any of the following conditions:
  • You have personally subscribed to watch the action.
• You are the action’s creator, person responsible or assigned reviewer/approver and the database has been configured to auto-subscribe a watch for that role. (See Action Alert Preferences.)

• You are assigned via the Action Monitors window. (See Action and Gate Monitors.)

• Project Planner gates, under either of the following conditions:
  • You have personally subscribed to watch the gate.
  • You are assigned via the Gate Monitors window.

• Change logs you have been assigned to approve in XFMEA/RCM++/RBI. (See Electronic Approval Tracking in the XFMEA/RCM++/RBI documentation.)

Enable Alerts via E-mail or SMS

To configure a database to enable alerts via e-mail and/or SMS text message, choose File > Manage Repository > Repository Settings.

In a secure database, this is available only for users with the "Manage other repository settings" permission.

What’s Changed? In prior versions, similar preferences were defined in the E-mail and Other Settings window.

1. Select the Enable Alerts via E-mail or SMS check box.

2. Specify a valid SMTP port and SMTP server. (You may need to consult with the IT professionals who have configured the e-mail server used within your organization.)

3. Enter your e-mail address (or a valid SMS text messaging address if you prefer) in the Recipient address for test message field and then click Send Test Message.
If the test message cannot be sent, an error will be displayed. If that happens, you can update the settings and try again until the message is delivered successfully.

**Subscribing to a Watch**

Users can personally subscribe to "watch" specific resources, Project Planner gates and MPC tasks that are of particular interest to them. This generates an alert (via e-mail, SMS text message and/or ReliaSoft portal message) each time the record is changed.

**Subscribing and Unsubscribing**

To personally subscribe/unsubscribe to a watch, open the resource, Project Planner gate or MPC task and select or clear the **Alert me on changes to this record** check box. The alert types shown for this option will depend on your alert preferences, as described in the section below.

![Watch](image)

Note that the “watch” feature is not applicable for the following types of resources: Variables, Profiles, Maintenance Groups, Mirror Groups, Controls, Maintenance Templates (in BlockSim) or RENO-specific resources (Functions, Static Functions, Simulation Definitions and Tables).

**Receiving Alerts**

Alerts can be sent via e-mail, **SMS text message** and/or **ReliaSoft portal message**, depending on the **Receive automated alerts** preference specified in your personal [user account](http://mpc.reliasoft.com).

- Alerts via portal message are always available in any database.
- Alerts via e-mail or SMS are only available if they are enabled for the database, and a valid SMTP server has been defined. (See [Enable Alerts via E-mail or SMS](http://mpc.reliasoft.com).)

**No Cascading Alerts**

Alerts are generated only when the record you’re watching is edited directly. For example, if you are watching a universal reliability definition (URD):

- An alert will be sent if someone replaces Model A with Model B in the URD window.
- An alert will not be sent if there is a change to an existing model, crew, etc. that is already assigned to the URD, unless you have also subscribed to watch the dependent resource that was changed.
Special Considerations for Actions and Gates
For action resources only, there are some additional features designed to maintain continuity with prior versions and enhance the actions management functionality. Specifically:

- Action changes that are applied via the FMEA worksheet in XFMEA/RCM++/RBI will not initiate an alert. The change must be saved via the action properties window.

- The database can be configured to auto-subscribe watches for users with the following roles: Action Creator, Person Responsible or Reviewer (aka "approver"). Each user can choose to personally unsubscribe later if desired. (See Action Alert Preferences.)

- The Action Monitors window allows you to specify individual users and/or groups of users who will always receive alerts for the action, regardless of whether they have personally subscribed to a watch. For example, this allows you to set up an alert for a user who doesn’t have access to view or modify the project (and therefore can’t personally subscribe to a watch).

A similar feature, the Gate Monitors window, is available for Project Planner gates. (See Action and Gate Monitors.)

Action Alert Preferences
To configure the action alert preferences for the database, choose File > Manage Repository > Repository Settings.

In a secure database, this is available only for users with the "Manage other repository settings" permission.

What's Changed? In prior versions, similar preferences were defined in the E-mail and Other Settings window.
Chapter 12: ReliaSoft CommonTools

- **Introduction to each action alert sent via e-mail.** This field allows you to specify the default text (up to 1,000 characters) that will be used at the beginning of each action alert e-mail sent from this database.

- **Automatically set 'watch' for.** Users can personally subscribe to "watch" specific resources and Project Planner gates that are of particular interest to them. For action resources only, the database can also be configured to auto-subscribe watches for users that have particular roles in a given action, as shown in the picture above. Note that each user can choose to personally unsubscribe later if desired (by opening the action record and clearing the check box under the Watch heading).

### Action and Gate Monitors

The Action Monitors window (for action resources) and the Gate Monitors heading (for Project Planner gates) allow you to specify individual users and/or groups of users who will always receive alerts for the record, regardless of whether they have personally subscribed to a "watch."

For example, this allows you to set up an alert for a user who doesn’t have access to view or modify the project (and therefore can’t personally subscribe to a watch).

#### Action Monitors

For actions, click the **Action Monitors** icon in the action’s ribbon.

This replaces the "E-mail Notifications" feature from prior versions, and you can choose any of the user groups or individual user accounts defined in the current database.

The action will also appear under the **I am monitoring** heading in My Portal, Actions Explorer and SEP web portal (along with the actions that the user has personally subscribed to watch).

#### Gate Monitors

For Project Planner gates, the assigned users are listed under the **Gate Monitors** heading. Click the **Edit** icon to select the users you wish to assign.
This replaces the "Team" feature from XFMEA/RCM++/RBI Version 9, and you can choose to assign any of the individual user accounts in the database.

### What is Your SMS Address?

If you choose to receive alerts via SMS text messaging, the address will usually be your cell phone number @ the provider’s e-mail domain. As a courtesy, the table below provides a list of domains for popular providers in the United States (as of March 2015). Of course, you may need to check with your provider to obtain the most up-to-date information.

For example, if you use T-Mobile in the US and your cell number is 555-123-4567, your SMS address will be 5551234567@tmomail.net.

<table>
<thead>
<tr>
<th>Provider</th>
<th>Domain</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alltel</td>
<td>@message.alltel.com</td>
</tr>
<tr>
<td>Amp'd</td>
<td>@vtext.com</td>
</tr>
<tr>
<td>Boost</td>
<td>@myboostmobile.com</td>
</tr>
<tr>
<td>AT&amp;T</td>
<td>@txt.att.net</td>
</tr>
<tr>
<td>Metrocall</td>
<td>@page.metrocall.com</td>
</tr>
<tr>
<td>Nextel</td>
<td>@messaging.nextel.com</td>
</tr>
<tr>
<td>Sprint</td>
<td>@messaging.sprintpcs.com</td>
</tr>
<tr>
<td>T-Mobile</td>
<td>@tmomail.net</td>
</tr>
<tr>
<td>US Cellular</td>
<td>@mms.uscc.net</td>
</tr>
<tr>
<td>Verizon</td>
<td>@vtext.com</td>
</tr>
<tr>
<td>Virgin (USA)</td>
<td>@vmobl.com</td>
</tr>
<tr>
<td>Windstream</td>
<td>@windstream.net</td>
</tr>
</tbody>
</table>
History Logs

By default, all projects and project items automatically show information about when an item was created and last updated, and by whom. For example, system hierarchy items in XFMEA/RCM++/RBI show this information under the History heading on the Properties tab, while folios and diagrams in Weibull++ and BlockSim show the information in the Item Properties window (Project > Current Item > Item Properties).

In addition to the basic information provided, you have the option to activate a full history log that shows more detailed information such as the type of change that was made (e.g., add, edit or delete), the record that was changed and the specific property, and the value before and after the change.

History logs will increase the size of a database and will cause a slight degradation in performance; hence, they must be activated on a per project basis. If desired, you can configure the database to automatically activate history logs for each new project by choosing File > Manage Repository > Repository Settings, and then selecting the option under the Other Settings tab in the window. (In secure databases, this is available only if the user has the "Manage other repository settings" permission.)

Once a history log is activated, the project history log shows the changes for all items in the project, and individual record history logs show the changes for selected items only.

Tip: If you want to monitor and control revisions made to FMEAs, DVP&Rs, control plans, P-Diagrams or test plans in XFMEA/RCM++/RBI, the use of change logs may be more appropriate. See Change Logs in the XFMEA/RCM++/RBI documentation.

Activating a Project History Log

To activate the history log for a project, choose Project > Management > History Log, or right click the project in the project list and choose the command on the shortcut menu. (In secure databases, this is available only if the user is the project owner, or has the applicable "manage all projects" permissions.)

In the Project History Log window that appears, click Activate.

Once the log has been activated, the database will start keeping records of all changes that are performed throughout the entire project for any of the ReliaSoft applications. You can filter the records by the last update date, application, user or type of change. For example, you might choose to display a list of all changes that were made by Joe User in the last week, or a list of all changes that were made by any user in Weibull++ today, and so on.
You can deactivate the history log at any time from this window. When you do this, the recorded data is retained unless you select to clear it in the confirmation message that appears.

**Creating and Managing Archives**

You can limit the amount of information that is visible in the log by archiving older entries that are no longer of interest. Entries that have been archived can still be viewed in the Project History Log window if you specifically select to view them, but they will no longer be visible in the Record History Log windows.

![Archive Current Entries Through](image)

Archives are named based on the date they were created. For example, if you archive entries through **One week ago**, all entries in the history log that are dated as of one week ago or earlier will be stored in an archive that is named after the current date.

To view the contents of an archive, select the archive of interest from the **Archive** drop-down list in the **Filter Based On** area. To delete an archive, click the **Delete** icon that appears in the field.

*Note:* When a **restore point** is created for a project or when a project is **checked out**, all current entries in the history log are automatically archived.

**Viewing Record History Logs**

In addition to the project history log, you can view a log that shows only the changes made to a selected item (archived entries will not be shown). The History Log icon 📐 will be displayed whenever the log is available:

- For folios, diagrams, multiplots (such as overlay plots), reports and worksheets, right-click the item in the current project explorer and choose **Item Properties**, then in the window that appears, click the **History Log** icon in the Identifiers tab.

- For system hierarchy items in XFMEA/RCM++/RBI and MPC, select the item then click the **History Log** icon in the Properties panel.

- For FMEAs, DVP&Rs and other analyses in XFMEA/RCM++/RBI, right-click the analysis’s tab in the Analysis panel and choose the **History Log** command on the shortcut menu.
For resources (e.g., models, actions, etc.), the **History Log** icon will be available when you edit the item or view its properties.

## Import, Export and Data Conversion

ReliaSoft applications provide a variety of different tools for import, export and data conversion from external files and between Synthesis repositories. The options will vary depending on which application you are currently using.

In desktop applications, you can:

- Import data from an existing database [when you are creating a new one](http://mpc.reliasoft.com).
- Convert and import data from [prior version files](http://mpc.reliasoft.com).
- Import/export selected [projects](http://mpc.reliasoft.com).

When applicable, you can also:

- Import/export selected [project items or resources](http://mpc.reliasoft.com).
- Import from an [Excel spreadsheet or delimited text file](http://mpc.reliasoft.com) into a data folio.
- Use [XML files](http://mpc.reliasoft.com) to import/export system configuration information in BlockSim or Lambda Predict.

These features can be accessed either from the Import/Export Wizard ([Project > Management > Import/Export](http://mpc.reliasoft.com)) or from the [Backstage View](http://mpc.reliasoft.com).

In addition to the common functionality described in this chapter, some ReliaSoft applications provide other data transfer and import/export utilities that fit specific needs (e.g., the Import Bill of Materials feature in Lambda Predict, the Excel templates in XFMEA/RCM++/RBI, the ability to share analysis details between specific ReliaSoft applications.). For more information about these specialized tools, please consult the documentation for the particular application(s) involved.

## Importing from an Existing Repository

When you are creating a new Synthesis repository, you have the option to import repository settings (e.g., user accounts, security groups, project categories, etc.) and/or entire analysis projects from another database.

If the **Import from existing repository** check box is selected when you start to create a new [database](http://mpc.reliasoft.com), the Import Data from Existing Repository window will be displayed.
First, use the drop-down list or browse icon to select the database that you want to import from. This can be a standard database (*.rsr19) or an enterprise database connection file (*.rserp).

Then, use the check boxes to select the settings and/or projects you wish to import.

Finally, click OK to create the new database with the selected data imported.

**Note:** If you are creating a new enterprise database on SQL Server, the Create SQL Server login check box will be displayed at the bottom of the window. (See SQL Server Logins or Using Windows Impersonation.)

## Importing from Prior Version Files

There are two ways to convert and import data from project files and standard database files that were created in previous versions of the software.

- Importing to a new standard database (File > Open Repository)
- Importing to an existing database and project (Import > Other file)

The options depend on which ReliaSoft application you're currently using:

- For Weibull++, ALTA, RGA and BlockSim/RENO, you can use either method.
- For Lambda Predict, XFMEA/RCM++ and MPC, you must use the File > Open Repository method to import the data into a new project in a new standard database.

Finally, for an enterprise database created in XFMEA/RCM++ 5, there is a dedicated utility that you can access from the Backstage View. (See Converting XFMEA/RCM++ 5 Databases.)

### Importing to a New Standard Database (File > Open Repository)

For all ReliaSoft desktop applications, you can use the File > Open Repository method to import data from a project file or standard database that was created in a previous version of the software. This imports the data to a new project in a new standard database.

2. Browse for the file and click Open.
3. The conversion process will begin immediately for most applications. In BlockSim and MPC only, you will be prompted to specify some preferences and then click OK to proceed.
   - See Converting from BlockSim 6 or 7 Files.
Chapter 12: ReliaSoft CommonTools

- See Converting MPC 3 Databases.

Note that although the conversion of XFMEA/RCM++ 5 databases does not require any user input, the process does apply some assumptions to address changes in the functionality and data structure between versions. (See Converting XFMEA/RCM++ 5 Databases.)

When the process completes, the original file will remain unchanged and the new standard database will be created in the same folder.

Tip: Once the new database has been created, you can use the Import/Export Projects feature to copy the data into an existing database, if desired.

Importing to an Existing Database and Project (Import > Other file)

For the applications and file types shown in the following table, you can use the Import > Other file method to import data from a project file that was created in a previous version of the software. This imports the data to a selected project in an existing standard database or enterprise database.

<table>
<thead>
<tr>
<th>Weibull++/ALTA</th>
<th>RGA</th>
<th>BlockSim/RENO</th>
</tr>
</thead>
<tbody>
<tr>
<td>ReliaSoft Office 7 projects (*.rso7)</td>
<td>RGA 7 projects (*.rga7)</td>
<td>BlockSim 7 projects (*.rbp)</td>
</tr>
<tr>
<td>Weibull++ 7 projects (*.rwp)</td>
<td>RGA 6 projects (*.rga)</td>
<td>BlockSim 6 projects (*.rb6)</td>
</tr>
<tr>
<td>ALTA 7 projects (*.ralp)</td>
<td></td>
<td>RENO 1 projects (*.rnp)</td>
</tr>
<tr>
<td>Weibull++ 6 projects (*.rw6)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ALTA 6 projects (*.ra6)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DOE++ 1 projects (*.rdoe)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Do the following:

1. Create a new project or open an existing project that you want to import the data into.
2. Choose Project > Management > Import/Export > Import.
3. In the Import wizard, choose Other file and click OK.
4. The conversion process will begin immediately for most applications. In BlockSim only, you will be prompted to specify some preferences and then click OK to proceed. (See Converting from BlockSim 6 or 7 Files.)

*Note that although the conversion of XFMEA/RCM++ 5 databases does not require any user input, the process does apply some assumptions to address changes in the functionality and data structure between versions. (See Converting XFMEA/RCM++ 5 Databases.)*

When the process completes, the original file will remain unchanged and the converted data will be copied into the selected project.

**Converting from BlockSim 6 or 7 Files**

When you import from a BlockSim 6 (*.rb6) or BlockSim 7 (*.rbp) file, the Conversion Settings window allows you to specify:

- Whether you want the diagrams to be converted to analytical diagrams, simulation diagrams, or both.
- Whether the application will attempt to merge identical records when certain block properties are converted to resources. For example, if the old diagram has two blocks with the same failure distribution, this can be imported as two separate but identical failure models, or as a single failure model that’s linked from both blocks.

**Tip:** The default preferences for merging identical resources upon conversion are set on the Conversion page of BlockSim’s Application Setup (File > Application Setup). Note that any changes you make in the Conversion Settings window will update your preferences in the Application Setup. In other words, the same options will be selected by default the next time you attempt to convert a BlockSim 6 or 7 file on this computer.

**Conversion Constraints and Differences**

Numerous improvements have been made to the modeling capabilities and underlying analysis and simulation algorithms used in BlockSim. As a result, analysis or simulation of diagrams imported from previous versions of BlockSim may yield results that differ from the results originally obtained. In particular, results may differ in the following cases and/or for the following reasons:

- **Simulation diagrams:**
  - When multiple blocks are used in conjunction with subdiagrams, the underlying order of block expansion differs between versions, so results may differ.
• Starting in Version 8, containers are treated as subdiagrams. The underlying order of block expansion differs between versions, so results may differ. However, some special cases will produce identical results. These include cases where:
  • The container is the only block in the diagram.
  • The container is at the end of the list in the original diagram (i.e., it was created last and has the highest block ID, which is automatically assigned by the software upon block creation).

• The load on contained load sharing blocks is calculated differently. Version 7 required a life-stress relationship for such configurations and based the re-calculation of load after block failure on that relationship; subsequent versions calculates load using the weight proportionality factor as a multiplier.

• Normal/lognormal distributions have increased precision starting in Version 8.

• Maintenance tasks that are performed at specified intervals (based on item age or calendar time) for multiple blocks are performed in a different order, producing results that are not identical, although the difference will not be statistically significant.

• Indirect cost is calculated differently. In Version 7, the following was calculated at the end of the simulation:

\[
\text{Indirect cost} = \text{Average stock level} \times \text{Holding cost per item} \times \text{Simulation end time}
\]

In subsequent versions, the indirect cost is calculated for each simulation and then averaged at the end to yield the indirect cost that is shown. This is because holding cost per item may be a distribution.

• The order in which random numbers are assigned in general is by block ID. This means that if diagrams have the same blocks with the same IDs in both the previous version and the current version, the results will be identical. Standby containers represent an exception to this. In Version 7, the order of blocks is overwritten by the standby priority. Therefore, results may not be identical with standby containers if the block IDs do not match the block standby priorities. The difference should not be statistically significant.

• For mirrored blocks, in Version 7, the block that fails is the source and all the other mirrors are assigned these failures. In subsequent versions, the failures are assigned to the mirrored block with the lowest block ID. If the failure source is not the block with the lowest ID, then the results will be different between versions.
• Mirrored blocks inside subdiagrams are handled differently. In Version 7, they were treated as different groups of mirrors; subsequent versions treat them as the same group. This may produce results that are statistically different.

• Throughput is not available in fault trees starting in Version 8.

• The throughput property **Send units to failed blocks** works differently for subdiagrams in versions after Version 7, in that it applies to the whole diagram. That is, if the current block is set to not send units to failed blocks and the next block is a subdiagram that is not operating, then the throughput will be re-routed if possible or the current block will accumulate backlog.

• Phases have different rules on how interrupted events are handled and may give different results when re-simulating.

• Starting in Version 8, containers do not exist in maintenance phases. Thus, the availability results for containers in phase simulation may be different than in previous versions.

• **Analytical diagrams:**
  - The load on contained load sharing blocks is calculated differently. Version 7 required a life-stress relationship for such configurations and based the recalculation of load after block failure on that relationship; subsequent versions calculate load using the weight proportionality factor as a multiplier.
  - Mirrored blocks inside subdiagrams are handled differently. In Version 7, they were treated as different groups of mirrors; subsequent versions treat them as the same group. This may produce results that are statistically different.

• **Other issues of interest when opening BlockSim 7 files:**
  - Nodes do not have failure/maintenance properties starting in Version 8. Therefore, if a node has failure properties in BlockSim 7, it will be imported in the current version as two blocks: a node with the \( k\text{-out-of-}n \) and the throughput properties (if applicable) and a block with the failure properties positioned immediately after the node. If the node does not have failure properties, a second block will not be imported.
  - The load on contained load sharing blocks is calculated differently. Version 7 required a life-stress relationship for such configurations and based the recalculation of load after block failure on that relationship; subsequent versions calculate load using the weight proportionality factor as a multiplier. Because of this, if you convert a diagram that uses load sharing containers, you will need to manually configure the contained load sharing blocks after conversion.
Chapter 12: ReliaSoft CommonTools

- Simulation FRED reports will be imported, but cannot be restarted or have levels appended/removed until the diagram is resimulated.

In addition, certain rules apply when importing maintenance properties from BlockSim 7:

- Preventive maintenance:
  - For each preventive maintenance setting, a new task will be created. For example, if the preventive maintenance policy is set to be performed upon system down and upon system age, two tasks will be created.
  - For each task created, the duration, crews, restoration factor, etc. will be identical.

- Inspections:
  - For each inspection setting, a new task will be created. For example, if the inspection policy is set to be performed upon system down and upon system age, two tasks will be created.
  - For each task created, the duration, crews, restoration factor, etc. will be identical. Note that inspections do not use pools.
  - If a detection threshold is defined in Version 7, an on condition task will be created instead of an inspection task in subsequent versions. A threshold is defined in Version 7 if a Failure Detection Threshold greater than 0 and less than 1 is specified or if a P-F Interval greater than 0 is specified.
    - The inspection properties from Version 7 will be transferred to the inspection properties of the on condition task in subsequent versions.
    - The threshold (i.e., detection) information from Version 7 will be transferred to the failure detection properties of the on condition task in subsequent versions.
    - The preventive maintenance properties from Version 7 will be transferred to the on condition task (upon detection) properties of the on condition task in subsequent versions.
  - If a detection threshold is defined in Version 7 but no preventive maintenance properties are defined, then only an inspection task will be created (i.e., the threshold is ignored).
• PM/Inspection based on group:
  
  • A task will be added and assigned to the maintenance group that the block belongs to. For example, if Block 1 belongs to Item Group 1 and has an inspection policy based on group maintenance in Version 7, then in subsequent versions an inspection task will be created and will be set to be performed upon group maintenance. Maintenance Group 1 will be checked in the list of groups that will trigger a maintenance, and Block 1 will be assigned to Maintenance Group 1.
  
  • If the block does not belong to a group, a task will not be added.

  • The corrective maintenance properties will be imported as corrective tasks.

  • A preventive maintenance action or an inspection based on maintenance phase and associated with a block in a standard phase will not be imported.

Converting XFMEA/RCM++ 5 Databases
This topic describes how to convert/import data from an XFMEA/RCM++ 5 database into a Synthesis repository.

For information about converting and importing data from an XFMEA/RCM++ 5 library, please consult the "Configurable Settings" chapter in the XFMEA/RCM++/RBI documentation.

**Standard Databases (*.rx5)**
For XFMEA/RCM++ 5 standard databases, you must convert the entire *.rx5 file to a new standard repository. (Later, you can use the Import/Export Projects feature to copy specific projects into an existing database, if desired.)

Do the following:

1. In the current version of XFMEA, RCM++ or RBI, choose File > Open Repository.
2. Select RCM++ 5/XFMEA 5 (*.rx5) from the Files of type drop-down list.
3. Select the file you wish to convert and click Open.

The application will create a new standard database file in the same directory with the extension *.rsr19; the existing *.rx5 file will remain unchanged.

**Enterprise Databases**
For XFMEA/RCM++ 5 enterprise databases, you can select which analysis projects and settings you wish to import into a enterprise repository that has already been created. You must be a member of the Admin group in the Synthesis enterprise repository to perform this task.
Chapter 12: ReliaSoft CommonTools

Do the following:

1. Connect with the enterprise database you want to import into.

2. Choose File > Manage Repository > Import from Version 5.

3. In the area at the top of the Import from Version 5 Enterprise Database window, enter the connection information for the Version 5 enterprise database and click Connect.

4. The table shows all of the data and settings in the original database. Use the check boxes to select which data you wish to import and then click OK to start the transfer.

**Note:** If you are importing into a SQL Server database, the Create SQL Server login check box will be displayed at the bottom of the window. This is applicable only if you are importing user accounts. (See SQL Server Logins or Using Windows Impersonation.)

**Conversion Assumptions and Tips**

When you convert data from an XFMEA/RCM++ 5 database, please consider the following assumptions and tips:

- **Conversion to Resources**
  
  Certain types of information in the Version 5 projects will be converted to resources in the current version. This includes reliability information (which will be converted to models), controls and actions. In these cases, records that have identical properties will be merged into a single resource. For example, if there were two identical actions in the original project, a single action would be created as a resource in the project and used in both locations.

- **Conversion to Security Groups**
  
  If you are working with secure databases, the access levels and access groups in Version 5 will be converted to security groups in the current version. Specifically:

  - Repository-level security: User permissions assigned by access level in Version 5 will be assigned by the corresponding security group in the current version. For example, if a user had the Admin access level in the original database, then that user will be assigned to the Admin security group in the current version. If there is no corresponding security group in the current version, the user will be imported with no security groups assigned, and a user with "Admin" access level permissions will have to manually assign security groups to the imported user.
• Project-level security: For each access group in the Version 5 database, a security group will be created in the Synthesis repository. Because the Version 5 access groups could have different access levels for different users in the same group, it is not possible to automatically determine which permissions should be assigned for the new security group in the current version. Therefore, these groups will initially be assigned the default permissions; you can edit the permissions via the Security Groups tab of the Users and Security window. Projects that had access limited by access group in Version 5 will continue to have their security set by the appropriate security group(s) at the project level in the current version.

• Configurable Settings for Converted Projects

When you convert an existing project from Version 5, the application will add new configurable settings for new features that were added in the current version. For example, the configurable PFD Worksheet settings will be added to the interface style, the quantitative values will be added to the occurrence rating scale, etc.

It is important to note that these default settings may need to be modified after the conversion. For details, please consult the "Configurable Settings" section in the XFMEA/RCM++/RBI documentation.

Converting MPC 3 Databases

If you have an existing systems and powerplant analysis that was created in MPC 3, it is easy to convert the *.rsm file into a new Synthesis repository.

Choose File > Open Repository, select MPC 3 (*.rsm) from the Files of type drop-down list, and then browse for the desired file.

When prompted to enter a username and password, enter the administrative login from the old *.rsm file.

**Note:** By default, a converted Version 3 database is a secure database that transfers any user accounts that were defined in the old database. After the new database has been created, the administrator should review the automatically created user accounts and update as appropriate. See Security Options for more information about database-level security.

The final step is to use the Tasks Conversion window to review the task records that will be imported and make any updates that may be needed (see details below). Once you have completed the review, click OK to start the import.

When the process completes, there will be a new standard database file in the same folder and with the same name as the original *.rsm file. The new file will have the extension *.rsr19 and the original *.rsm file will remain unchanged.
Tasks Conversion Window
The Tasks Conversion window displays a list of all of the tasks defined in the original database and allows you to review how the records will be converted upon import. For any properties that are displayed with blue text, you have the option to change the task record data before it is imported.

Some task properties are handled a bit differently starting in Version 9 than they were in Version 3. Specifically:

- Some of the Task Types that were combined in Version 3 are now categorized separately (e.g., Operational Check (OPC) and Visual Check (VCK) are now separate task types).

- In Version 3, the task Interval was always stored as a text field. Now, you can choose whether each task's interval will be stored as a text field or if it will instead be recorded as a number with an associated unit (e.g., 2000 flight hours can now be stored as value=2000 and unit = FHr). Numbers may be easier to sort and will also make it possible to perform simulation-based reliability calculations if you choose to import the analysis project to RCM++ or RBI.

- The Zonal field from Version 3 is called Zonal Candidate in the current version. This is now a yes/no field that can be set to Yes only if the failure effect categorization (FEC) is set to 5 or 8 (i.e., a safety issue) and the task type is "General Visual Inspection (GVI)." Also in the current version, the Zone field will be enabled only if Zonal Candidate is set to Yes.

The following subsections describe the default conversion logic for Task Type, Interval and Zone.

Task Type
For the Discard and Restoration task types, there is no difference between Version 3 and subsequent versions. The text in the Task Type (New Value) column will be displayed in italics to indicate that this property cannot be changed via the Tasks Conversion window.

<table>
<thead>
<tr>
<th>Task Type (Old Value)</th>
<th>Task Type (New Value)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discard (DS)</td>
<td>Discard (DIS)</td>
</tr>
<tr>
<td>Restoration (RS)</td>
<td>Restoration (RST)</td>
</tr>
</tbody>
</table>

For the remaining task types, the software will use the logic specified below to suggest a task type, but the property will be displayed in blue text to indicate that it can be edited. If you disagree with the default selection, you can choose one of the other eligible task types from the drop-down list, as shown in the following example.
When the task type was set to **Inspection/Functional Check (IN)** in Version 3, the following logic will be applied in the specified order. For example, if the task description contains both the word "Visual" and the word "Function," the General Visual Inspection task type will be applied by default because the word "Visual" will be matched first.

<table>
<thead>
<tr>
<th>If the task description contains:</th>
<th>The default option is to import the task as:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visual</td>
<td>General Visual Inspection</td>
</tr>
<tr>
<td>Special Detail</td>
<td>Special Detailed Inspection</td>
</tr>
<tr>
<td>Health Monitor</td>
<td>Scheduled Structural Health Monitoring</td>
</tr>
<tr>
<td>Function</td>
<td>Functional Check</td>
</tr>
<tr>
<td><em>none of the words/phrases listed above</em></td>
<td>Detailed Inspection (DET)</td>
</tr>
</tbody>
</table>

When the task type was set to **Lubrication/Servicing (LU)** in Version 3, the default option is to import the task as Servicing (SVC) if the task description contains "Servic" and as Lubrication (LUB) if it does not.

When the task type was set to **Operational/Visual Check (OP)** in Version 3, the default option is to import the task as Visual Check (VCK) if the description contains "Visual" and as Operational Check (OPC) if it does not.

**Tip:** The task types in Version 9 and later of MPC are determined by the requirements of the MSG-3 guidelines and cannot be changed. However, the abbreviations can be configured to fit your particular preferences. If you want to change the default task type abbreviations (e.g., if you don't want to use DIS for Discard, RST for Restoration, etc.), click the **Task Type Abbreviations** button. The changes that you make in the Define Task Type Abbreviations window will automatically apply to all analyses in the current database. This window is also accessible from **File > Manage Repository > Task Types**.
Interval Type and Interval

Two options are displayed at the top of the Tasks Conversion window to determine how the task intervals will be imported:

- If you choose **Transfer all intervals as text**, the interval type for all imported task records will be set to **Based on Events (Text)** and the interval will be stored as a text field (just like in MPC 3). The Interval (New Value) column will be displayed in blue text to indicate that you can change the text if desired before the import.

![Interval Type and Interval example](image1)

- If you choose **Transfer intervals as numeric if possible**, the application will check to see if the original task interval begins with a number and is followed by a space and at least one text character. If it does (e.g., "2000 flt/hr"), the default option is to import it as a number with an associated unit. If not (e.g., "Per Mfg Life Limit"), the default is to import as text. Either way, you have the option to change both the interval type and new value before the import. For example:

![Interval Type and Interval example](image2)

**Tip:** If you want to change the units displayed in the drop-down list, click the **Units** button. The changes that you make in the **Unit Settings window** will apply immediately to the tasks that you are currently importing, and also to all other analyses you may later add to this database. This window is also accessible from **File > Manage Repository > Unit Settings**.
The Tasks Conversion window uses a variety of techniques to try to match the text field from Version 3 with one of the specified units in subsequent versions. There will be a match if the name or abbreviation of a current version unit either starts with or contains the text in the Version 3 field. For some predefined units, the software also recognizes other commonly used abbreviations for the unit (e.g., the software will recognize any of the following abbreviations as flight hours: Flt/Hr, Flight H, Flt H or Flt/H).

If your data set contains a task interval that is not recognized, you can do any of the following:

- Edit the text in the **Interval (New Value)** column so it will match either the name or the abbreviation of a predefined unit. For example, if the Version 3 task record contains a misspelling for "2000 fliight hours," you can click inside the cell and remove the extra i.

- Click the **Units** button and define a new unit for the database with a name or abbreviation that matches the data you want to import. For example, if the Version 3 task record has an interval of "5 Weeks," you can open the "Unit Settings" window and create a new unit with the name "Weeks."

- Click **Cancel** to close the Tasks Conversion window then edit the original tasks in MPC 3 before starting the import again.

**Zonal Candidate and Zone**

If all of the following conditions are met, the **Zonal Candidate (New Value)** column will be set to **Yes** by default and any information from the **Zone** field will be transferred during the import:

- The failure effect categorization (FEC) is set to 5 or 8 (i.e., it is a safety issue).
- The Task Type is set to General Visual Inspection (GVI).
- The Zonal property in the original MPC 3 analysis contains the word "Transfer."

If you don't want the task to be considered for zonal analysis even though it meets the requirements, you can click inside the Zonal Candidate (New Value) column and choose No from the drop-down list. If this column displays No in italics, this indicates that at least one of these conditions is not met and the property cannot be changed.
Importing/Exporting Projects
All ReliaSoft desktop applications make it easy to import or export selected projects from one database to another.

Note that when importing/exporting a project between databases, any resources and FMEAs used by the project will be automatically imported/exported along with the project as local resources, even if they were originally reference resources or global resources. If you do not want the reference resources to be converted to local resources, you must import the both the project and the reference project at the same time. (See Local, Global and Reference Resources.)

To import a project, first choose Project > Management > Import/Export.

In MPC, the Import/Export window opens directly. In all other applications, a wizard displays the options that are relevant for the current application. Select Projects and click OK.

Once the Import Projects or Export Projects window is open, do the following:

1. Use the drop-down list or browse icon to select the database that you want to import from or export to.
   - This can be any existing standard database (*.rsr19) or enterprise database connection file (*.rserp).
   - If you are exporting, you can also use the add icon to create a new standard database to export into.

2. The tree displays the projects that are available to be imported or exported. If desired, you can use the Filter and Find tools to limit the list of projects displayed. (See Project Manager.)

3. Use the check boxes to select which project(s) you want to import/export then click OK to copy the data.
Chapter 12: ReliaSoft CommonTools

The following considerations apply:

- The names of projects must be unique within each Synthesis repository. If you attempt to import/export a project with a name that already exists in the destination database, the application will automatically increment the name. For example, if "Project1" already exists, the new project might be renamed to "Project1_1."

- If the project has a category, the application will first attempt to match it to an existing category in the destination database. If a matching category does not already exist, and you have the permission to create project categories in the destination database, it will be created automatically.

- If you select a project of a type that you don’t have permission to create in the destination database (private, public or reference), it will be converted to a type that you do have permission to create. For example, if you select to import a reference project but you don’t have the "Create and own reference projects" permission in the destination database, the project will be imported as a public or private project, and any links from other projects will be broken.

Importing/Exporting Project Items or Resources

When applicable, ReliaSoft applications make it easy to import/export selected project items (e.g., folios, diagrams, plot sheets, Synthesis Workbooks, etc.) or resources (e.g., models, maintenance tasks, etc.) between existing projects. The projects can be in the same database or in different databases.

First, open the project you want to import to or export from. Then open the import/export window, there are two ways:

- If you have selected the Allow multiple projects option in the Synthesis Settings page of the Application Setup, you can open both projects simultaneously and then drag/drop items from one project to another.

  OR

- Choose Project > Management > Import/Export.

  ![Drag/drop icon]

  In the wizard, choose Items (not available for XFMEA/RCM++/RBI and MPC) or Resources (not available for MPC) and click OK.
Chapter 12: ReliaSoft CommonTools

Once the Import window or Export window is open, do the following:

1. Use the drop-down list or browse icon to select the database you want to import from or export to.
   - This can be any existing standard database (*.rsr19) or enterprise database connection file (*.rserp).
   - If you are exporting, you can create a new standard database and project by clicking the icon.

2. Use the tree in the **Source Project** or **Destination Project** area to select the project you want to import from or export to. If desired, you can use the Filter and Find tools to limit the list of projects displayed. (See **Project Manager**.)

3. Use the check boxes in the **Items to Import** or **Items to Export** area to select which project items or resources you want to import/export.
   - For project items, this area will display the same folders that appear in the current project explorer. A +/- icon next to the folder indicates that it contains at least one project item that can be imported or exported.
   - For resources, this area will display a folder for each type of resource that exists in the selected project.

4. Click **Import** or **Export** to copy the data.

**Note:** The names of project items and resources must be unique within each project. If you attempt to import/export something with a name that already exists in the destination project, the application will automatically increment the name. For example, if "Folio1" already exists, the new folio might be renamed to "Folio1_1," "Folio1_2," etc.

**Keeping Associated Items/Resources Together**
The application will automatically copy any item/resource that is linked to the imported or exported item, even if you did not specifically select to import/export them. Some examples:

- A multilplot, such as an overlay plot, side-by-side plot, or 3D plot, will automatically import/export a copy of the folios or diagrams that were used to generate the plot.
• A BlockSim diagram will automatically import/export a copy of any utilized subdiagrams and resources.

• A RENO flowchart will automatically import/export a copy of any utilized subcharts, resources and Synthesis Workbooks.

• A Synthesis Workbook or special analysis folio/tool (e.g., allocation analysis, stress-strength analysis, etc.) will automatically import/export a copy of its data sources.

• A URD will automatically import/export a copy of the models, maintenance tasks, crews, etc. that were used to build the URD. The same applies to any resource that is built upon another resource.

Note that when importing/exporting project items between databases, the resources are imported/exported as local resources in the destination database, even if they were originally reference resources or global resources. For more information on how importing/exporting affects a resource, see Local, Global and Reference Resources.

**Tip:** If you do not want a RENO flowchart to import/export an associated resource or workbook, you can enclose the resource/workbook name in single quotes to reference it by name only. For example, if you export a diagram that contains a block using the expression ‘Model1'(1000), Model1 will not be transferred along with that diagram. If the destination project already contains a model called Model1, that model will be used in simulating the transferred diagram.

---

**Importing from Excel or Delimited Text Files into a Folio**

In Weibull++/ALTA and RGA, it is easy to import data from any of the following file types into a folio.

- Excel files (*.xls, *.xlsx)
- Tab, comma, space and semicolon delimited files (*.txt, *.csv, *.prn, *.smc)

**Tip:** Other ReliaSoft applications use different tools for importing/exporting via Excel (i.e., for importing Bill of Materials data in Lambda Predict and failure mode data in XFMEA/RCM++/RBI and MPC). For more information about those features, please consult the documentation for each particular application.

First, open the project that you want to import into and choose **Project > Management > Import/Export.**
In the wizard, choose Other file and click OK.

Browse for the file you wish to import from and click Open. Note that:

- In DOE design folios, the data will be copied into a new free form folio, where you can then designate columns for factors and responses and analyze the data. If you are importing from an Excel file that has multiple worksheets, the sheet that was active the last time the file was opened will be used.

- In Weibull++/ALTA and RGA, you will need to specify which data will be imported and how it will be mapped to the columns in the particular type of data folio. The rest of this topic describes how to map the data for import into a Weibull++, ALTA or RGA data folio.

### Selecting Which Data Sheets Will Be Imported

The left side of the utility displays the data from the Excel or delimited text file that is currently selected. If you wish to open a different source file, click Open.

If you are importing from an Excel file that has multiple worksheets, use the tabs at the bottom of the window to view and set the import preferences for each sheet.

Use the options at the top of the control panel for each sheet to specify whether the data will be imported.

- **Do not import sheet**: The control panel will not contain any other options and the data will not be imported.

- **Import sheet**: The control panel displays the options you need to either manually map the columns or use a template to automatically apply the same mapping that was used for another file.

### Using the Control Panel to Map the Columns That Will Be Imported

If you are not using a template, or if you need to modify the settings after an import template has been applied, do the following:

1. Use the Data Type drop-down list to specify which type of folio to import into. This can be different for each sheet, and it determines which options will be available in the rest of the control panel.
2. Click inside each column that you wish to import and then click the corresponding button in the control panel to map it to a column in the data folio. This updates the column heading and maps the data to a column in the data folio.

- If the heading displays a letter, the data in that column will not be imported.
- If the heading displays a name, the data will be imported to the column associated with that name.
- To remove the column mapping, click inside the column and click the corresponding button again.

As an example, the following picture shows data that will be imported into a Weibull++ life data folio. Column A will not be imported. The rest of the data has been assigned to columns that are used in the folios.

3. If you are importing to an ALTA life-stress data folio, use the **Number of Stresses** field to specify how many stress columns will be created in the new folio (maximum = 8). Note that:

- If you enter a value that is less than the number of columns that were mapped with the **Stress** button, the "extra" stress column data will not be imported.
- If the number is greater, the additional stress columns will be created in the new folio and you can enter the data later.

4. If the source file contains column headings or other introductory material that should not be imported, use the **Start from Row** field to specify where the actual data begins. For example, in the picture above, the first row contains heading labels so the data import should begin from Row 2.
Setting the Import Template Directory
If you will be importing data from multiple files that have the same structure, you can use saved template files (*.waim in Weibull++/ALTA or *.rgaim in RGA) to automatically map the columns for all other similar files that you need to import from.

By default, template files will be stored at C:\Users\<username>\AppData\Roaming\ReliaSoft\<application>\Import Templates. This directory determines which templates will be displayed in the Import Template drop-down list in the control panel. It also sets the default path for saving any new templates you create.

If you want to access templates from a different location, click the Import Template Directory button at the top of the window and select a different folder.

Creating a New Import Template
1. Open a data file and use the control panel buttons to map the columns.
2. Click the Save icon in the Import Template area on the control panel.
3. Specify a name and click Save.

Applying a Saved Import Template
1. Open the data file and select Import sheet to display the rest of the control panel options.
2. Make sure the Import Template Directory is set to the folder that contains the applicable template file(s).
3. Use the drop-down list in the Import Template area to select the template you want to apply.

The utility will automatically assign the column mappings defined in the template. If desired, you can use the control panel to make further adjustments before import.
4. When you are satisfied with the mapping, click Import to create the new folio.
Tip: If you make adjustments after applying the template, you have the option to click Save in the Import Template area to either replace the existing template, or create a new template with a different name.

Importing the Data
When you are ready to import the data, click the Import button.

By default, the application will import the data into a new folio. The status bar will display "Import into New Folio," as shown in the following example.

![Import Template Directory: C:\Users\username\AppData\Roaming\ReliaSoft\APPLICATION\Import Templates Import into New Folio]

If you prefer to import into an existing folio instead, click the Import to Existing Folio button and choose one of the available folios. When you return to the import window, the status bar will now display the name of the selected folio, as shown in the next example.

![Import Template Directory: C:\Users\username\AppData\Roaming\ReliaSoft\APPLICATION\Import Templates Import into Folio: Folio 1]

Using XML in BlockSim and Lambda Predict
In BlockSim and Lambda Predict, you have the option to use XML (extensible markup language) files to import or export system configuration data and item properties. XML files can be used to transfer data to/from other applications or database systems.

In BlockSim, the XML files include the block properties and information about how the blocks are connected in a reliability block diagram or fault tree diagram. They do not include visual aspects such as diagram style settings, block style settings, etc. BlockSim supports both import and export via XML.

In Lambda Predict, the XML files include the structure of the system hierarchy in a prediction folio and some of the item properties. Lambda Predict supports export to XML.

Exporting to XML
To create an XML file, first open the project and then choose Project > Management > Import/Export > Export.

In the wizard, choose Other file and click OK.
Specify the desired pathname/filename and click Save. This will export the relevant information for all of the diagrams or prediction folios in the current project. Other project items (such as RENO flowcharts, plots, attachments, etc.) are not included.

Importing from XML
There are two ways to import from an XML file.

If you want to import to a new project in a new standard database:

2. Browse for the file and click Open.

If you want to import to a selected project in an existing standard database or enterprise database:

1. Create a new project or open an existing project that you want to import into.
2. Choose Project > Management > Import/Export > Import.

In the wizard, choose Other file and click OK.
3. Browse for the file and click Open.

Attachments
All ReliaSoft desktop applications allow you to attach URLs and/or files that were created in other applications. This helps you to keep supporting documentation all together in the same place with your analysis. The locations where you can attach files will vary depending on which application you are using.

In all desktop applications, attachments can be either linked or embedded.

- URL and File Link attachments store the path to a web page or file. This allows you to open the resource in its original location (e.g., Internet, intranet or network directory), provided that the necessary software is installed on your computer and the link is valid. The files themselves are not stored inside the database. When you delete a file link or URL, this simply removes the link, leaving the original file untouched.

Note: If your organization has implemented an SEP web portal for an enterprise database, note that file link attachments (i.e., stored paths to local files on your computer or network) cannot be created, opened or saved within the SEP due to browser security.
**Embedded** attachments are always files. For these attachments, the software stores a complete copy of the file inside the database. When you delete an embedded file, the actual file is deleted from the database and this cannot be undone (unless you happen to have a saved backup or restore point that you could roll back to).

The Attachments window manages all of the URLs/files attached to a particular location (e.g., project, resource, hierarchy record or block).

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Extension</th>
<th>Address</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attachment1.docx</td>
<td>Embedded File</td>
<td>.docx</td>
<td></td>
</tr>
<tr>
<td>Attachment2.pdf</td>
<td>File Link</td>
<td>.pdf</td>
<td>\NetworkDrive\CurrentProject\Attachment2.pdf</td>
</tr>
</tbody>
</table>

The Add/Edit Attachment window specifies the details of an individual file or URL, and will be displayed whenever you choose to create or edit an attachment.
If you are attaching a file, the Address field will display a Browse icon (.folded paper) so you can select the file to be attached.

If you are attaching a URL, the Name field will be populated automatically as you type the URL into the Address field. This is for your convenience only and you can specify a different name if desired.

**Attachment Locations**

As mentioned above, the locations where you can attach files will vary depending on which application you are using.

*Tip*: In most cases, the caption bar in the Attachments window will provide an indication of which type of attachment you are working with. For example, when you are working with project-level attachments, the caption bar will indicate "Project:" followed by the specific name of the project.

**Project Attachments**

All ReliaSoft desktop applications support attachments at the project level. In all applications, project attachments can be displayed/managed from the Attachments icon in the Project Properties window.
For most applications, project attachments can also be displayed/managed from the Attachments folder in the current project explorer.

In XFMEA, RCM++, RBI and MPC (which do not have a current project explorer), you can also access the project attachments by selecting Project > Management > Attachments.

Resource Attachments
All of the applications that utilize resources support attachments at the resource level. For example, you can attach a file to a URD, a model, etc.

To access attachments for an existing resource, you can click the Attachments icon in the resource's properties window.

Hierarchy Attachments
Some applications, including XFMEA, RCM++, RBI, Lambda Predict and MPC, support attachments for individual items or records in a system hierarchy or analysis hierarchy. For example, in XFMEA, you can create attachments for a particular item, or for a particular record in the FMEA for that item.

To access attachments for items or records in a hierarchy, you can double-click inside the Attachments column. (If this column is not displayed on your computer, right-click inside the column headings and choose Customize Columns.) You can also choose Tools > Attachments on the ribbon tab for the hierarchy that you are currently working with.
For records in an analysis hierarchy (such as FMEA or functional failure analysis), the attachment icon can also be accessed from within the record properties window.

**Block Attachments**

BlockSim supports attachments for individual blocks in a diagram. To access attachments for a block, you can click the **Attachments** icon in the Block Properties window.

**Select Existing Text Window**

The Select Existing Text window provides a list of existing descriptions that might apply to the current text field or analysis. This can help to save time on data entry, ensure consistency and facilitate brainstorming. The utility is used extensively in applications such as XFMEA, RCM++, RBI and MPC, and it is also available for certain text fields in other ReliaSoft desktop applications.

There are two ways this utility might be used:

- **Replace or append text in the current field** - If you click the **icon inside a text field, you can select text and either replace the current text or append the new text to the end. Starting in Version 2019, many text fields in XFMEA/RCM++/RBI allow selection of multiple descriptions, which will be concatenated in the order in which they were selected using the separator specified in the **Separator** field. Available separators include commas, periods, semicolons, dashes and, for multi-line text fields, new lines.

  When you are using the utility in this way, the **New Text Preview** area shows how the selected text will appear, and provides information on how many characters out of the character limit are being used (e.g., 45 characters out of a possible 2000 in the example below). If you exceed the text field’s character limit, your text will be truncated.

- **Create one or multiple new records** - If you use one of the ribbon commands in an FMEA or P-Diagram (e.g., **Functions > Select Existing Text**), you can select multiple descriptions and the utility will use your selection(s) to create new record(s).
The options will vary depending on the record/field type, and whether you are updating a single description or adding new records. The following example shows how the tool may be used to populate the function description in an FMEA.

**Tip:** The descriptions are sorted alphabetically under each heading. When the table has focus, you can type a letter to move to the next description that begins with the letter.

### Project and Item Filters
This window utilizes the same project and item filters that are available in many other locations throughout ReliaSoft desktop applications. For example, when searching for text for an item in the system hierarchy, you could use a Project Filter to search for analyses performed by Department A and then use an Item Filter to show only those analyses that were modified in the last month.

In addition, when applicable:

- **Current Project** limits the results to data in the current project.
- **Current Item Branch** limits the results to those found in the current branch of the system hierarchy.

### Record Filter
When applicable, the Record Filter shows the possible sources for the current record type and field that you can choose to include or exclude. The specific record types vary depending on the field.
Phrase Sets
FMEA records in XFMEA, RCM++ and RBI also have the option to include text from selected phrase sets.

Field Text
Use the drop-down list in the Field Text area to specify how to match the specified keywords, then type the keywords into the input box.

- **Contains** returns descriptions that contain the exact string entered.
- **Contains Any** and **Contains All** allow you to enter multiple keywords (separated by commas) and returns descriptions that contain at least one (any) or all of the keywords entered.
- **Begins With** returns descriptions where the exact string entered appears at the start of the field.
- **is** returns descriptions where the exact string entered matches the whole field.
Record Filter Options

When the descriptions can be obtained from more than one type of analysis (e.g., when PFMEA failures can be copied from FMEA causes, or when control plan operations can be copied from PFD Worksheet operations), the headings in the table identify the source. You can use the Record Filter to specify which source(s) to include.

### FMEAs

<table>
<thead>
<tr>
<th>FMEA Functions</th>
<th>System Hierarchy Items</th>
<th>P-Diagram Ideal Responses</th>
<th>PFD Worksheet Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>FMEA Failures</td>
<td>P-Diagram Error States</td>
<td>FMEA Causes</td>
<td>PFD Worksheet Product Characteristics</td>
</tr>
<tr>
<td>FMEA Effects</td>
<td>FMEA Failures</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FMEA Causes</td>
<td>P-Diagram Change Over Times</td>
<td>P-Diagram Control Factors</td>
<td>P-Diagram Piece-to-Piece</td>
</tr>
<tr>
<td>FMEA Controls</td>
<td>Control Plan Methods</td>
<td>DVP&amp;R Test/Specification Methods</td>
<td></td>
</tr>
<tr>
<td>FMEA Actions</td>
<td>DVP&amp;R Test/Specification Methods</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### P-Diagrams

<table>
<thead>
<tr>
<th>Input Signal</th>
<th>System Hierarchy Items</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control Factors</td>
<td>FMEA Causes</td>
</tr>
<tr>
<td>Error States</td>
<td>FMEA Failures</td>
</tr>
<tr>
<td>Ideal Response</td>
<td>FMEA Functions</td>
</tr>
</tbody>
</table>
### Chapter 12: ReliaSoft CommonTools

<table>
<thead>
<tr>
<th>Piece-to-Piece</th>
<th>Analysis Plan Assumptions</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>FMEA Causes</td>
</tr>
<tr>
<td></td>
<td>PFD Worksheet Product Characteristics</td>
</tr>
<tr>
<td>Usage</td>
<td>Analysis Plan Assumptions</td>
</tr>
<tr>
<td>Environment</td>
<td>Analysis Plan Assumptions</td>
</tr>
<tr>
<td>Change Over Time</td>
<td>Analysis Plan Assumptions</td>
</tr>
<tr>
<td></td>
<td>FMEA Causes</td>
</tr>
</tbody>
</table>

## Control Plans, PFD Worksheets and DVP&Rs

<table>
<thead>
<tr>
<th>Control Plan Part/Process Number</th>
<th>FMEA Functions</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>PFD Worksheet Operations</td>
</tr>
<tr>
<td>Control Plan Process Name/Operation Description</td>
<td>FMEA Functions</td>
</tr>
<tr>
<td></td>
<td>PFD Worksheet Operations</td>
</tr>
<tr>
<td>Control Plan Product Characteristic</td>
<td>PFD Worksheet Product Characteristic</td>
</tr>
<tr>
<td></td>
<td>FMEA Causes</td>
</tr>
<tr>
<td></td>
<td>FMEA Failures</td>
</tr>
<tr>
<td>Control Plan Process Characteristic</td>
<td>PFD Worksheet Process Characteristics</td>
</tr>
<tr>
<td></td>
<td>FMEA Causes</td>
</tr>
<tr>
<td>Control Plan Method</td>
<td>FMEA Controls</td>
</tr>
<tr>
<td>PFD Worksheet Operation Description</td>
<td>System Hierarchy Items</td>
</tr>
<tr>
<td>DVP&amp;R Test/Specification Method</td>
<td>FMEA Controls</td>
</tr>
<tr>
<td></td>
<td>FMEA Actions</td>
</tr>
</tbody>
</table>
Check Spelling

ReliaSoft desktop applications offer the ability to check the spelling of your text. This utility is available in different places within the software. For windows that offer the spell check functionality (e.g., Project Properties window, etc.), the Check Spelling icon will be displayed within the window itself. For data sheets, spreadsheets and system hierarchies that offer the functionality, the Check Spelling icon will be available on the ribbon and you can access it by choosing **Home > Edit > Spelling**.

*Note:* In system hierarchies (XFMEA, RCM++, RBI, MPC and Lambda Predict), the utility will check the property fields of the selected item only. This means that sub-items and text in analysis tabs, such as the FMEA tab in XFMEA, are not checked.

Whenever text that is not in the application's dictionary is found, the Check Spelling window displays the text in question and offers a list of suggestions to verify the error or confirm the correction, as shown in the following example.

- **Ignore Once** ignores the current instance of the highlighted word but continues to highlight it if the same word appears again.
- **Ignore All** ignores all instances of the word in the current form.
- **Add to Dictionary** adds the highlighted word to the dictionary on your computer so the spell checker will not treat it as a misspelling. The dictionary file is saved in the default Documents folder on your computer (e.g., My Documents\ReliaSoft\Dictionaries).
• **Change** replaces the current instance of the highlighted word with the word that is currently selected in the **Suggestions** area. If no word is selected, the first one will be used. Double-clicking a word in the **Suggestions** area is another way to change the highlighted text.

• **Change All** replaces all instances of the highlighted word with the word that is currently selected in the **Suggestions** area. If no word is selected, the first one will be used.

• **Options** opens the Spelling Options window, which provides additional settings to how the spell checker functions:
  
  • The **General options** area provides a list of the types of text that can be ignored by the spell checker (e.g., numbers, e-mail addresses, etc.). Select or clear each check box to specify how the spell checker will work on your computer.
  
  • In the **Edit custom dictionary** area, the **Edit** button opens a window that displays all of the words that you have added to the custom dictionary on your computer. You can edit the custom dictionary by adding or removing words in the list and then clicking **OK**.
  
  • **International dictionaries** allows you to choose the language of the dictionary that will be used on your computer.
  
  • **Undo Last** reverses the last change that was made.

**Results Window**

The Results window is used in many ReliaSoft applications to show detailed calculation results. From this window, you can edit the results, copy the results to the Clipboard or print the results.

• **Paste** pastes the contents of the Clipboard into the current control.

• **Cut** cuts the selected text to the Clipboard. Data stored in the Clipboard can be pasted into this and other applications.

• **Copy** copies the selected text to the Clipboard. Data stored in the Clipboard can be pasted into this and other applications.

• **Paste Special** opens the Paste Special window, which allows you to paste specific cell contents or attributes (such as formulas, formats, or comments) from the Clipboard.

• **Quick Print** sends the current document directly to the default printer without making changes.
• **Print** opens the Print window, which allows you to specify the printer and the printing options.

• **Send to Excel** allows you to save the current selection as a Microsoft Excel (*.xls or *.xlsx) file and then opens that file in Excel, if it is installed on your computer.

Note that the Results window may contain multiple sheets, accessible via the page index tabs at the bottom of the window.

### Quick Parameter Estimator (QPE)

The Quick Parameter Estimator (QPE) allows you to estimate the parameters of a distribution based on information you have about the reliability of a product, the probability of an event occurring or the typical duration of a task. In all ReliaSoft desktop applications, you can open the QPE from the Model properties window or the Model wizard by clicking the QPE icon.

In Weibull++/ALTA, it's also accessible from the Home tab of the ribbon and several analysis interfaces (including the Weibull++ life data folio, the Monte Carlo and SimuMatic utilities, and the Expected Failure Times Plot).

The QPE includes a Wizard view and an Expert view, described below. You can toggle between the different views by clicking the **Use Expert** or **Use Wizard** button at the bottom-left corner of the window.

- **The Wizard view** automatically selects a distribution and estimates that distribution's parameters based on your responses to a series of questions. The first page of the Wizard view asks you to choose among three different types of models that you can build with the QPE. Subsequent pages will ask more specific questions related to your selected model.

- **The Expert view** allows you to estimate the parameters of a distribution using either two unreliability values at specified times or one unreliability value and the other parameter(s) of the distribution. Unlike the Wizard view, you must select a distribution to solve the parameter(s) for.

### Quick Parameter Estimator Wizard View

To use the Wizard view of the Quick Parameter Estimator (QPE), simply follow the prompts on each page. The first page will present and describe three different types of models that you can
build with the QPE. Below are the three models and the kind of information you'll need to provide in subsequent pages.

To build a **Reliability model** you need to provide information about:

- How age affects the product's reliability.
- The product's intended design life and the estimated warranty time.
- Best-case, worst-case and most likely unreliability estimates for the product at the end of the design life and warranty time.

To build an **Event occurrence model** you need to provide information about:

- Whether age affects the probability of the event's occurrence.
- Best-case, worst-case and most likely estimates for how often the event will occur.

To build a **Task duration model** you need to provide information about:

- Best-case, worst-case and most likely estimates for how long it will take to complete the task.

The last window will display the tool's selected distribution and the calculated parameters. It will also provide one of the two options described below.

- If you opened the QPE from an analysis folio or utility, the **Update** button will be available in case you wish to update that window using the selected distribution, calculated parameters and selected units.
- In Weibull++/ALTA, if you opened the QPE from the ribbon, the **Finish & Copy** button will be available in case you wish to copy the parameters results to the Windows Clipboard.

**Quick Parameter Estimator Expert View**

Follow the steps below to use the Expert view of the Quick Parameter Estimator (QPE):

- Choose a distribution from the **Distribution** drop-down list. This is the distribution that you will solve the parameter(s) for. Then choose the appropriate time units from the **Units** drop-down list.
  - If you are not sure which distribution to select, consider using the **Wizard view** of the QPE instead.
• Your choice of time units applies to all time inputs and applicable parameters of the distribution (such as the eta parameter when the Weibull distribution is used).

• Select an appropriate option in the Quantification Method area.

• The Unreliability and a Parameter method solves for one parameter of the distribution. It requires one unreliability point (i.e., an unreliability value at a specified time) and the values of all the other parameters of the selected distribution except the parameter you will solve for.

  • If you select this method, you must then enter one unreliability point in the Point #1 area. For example, if you believe that your product has an unreliability of 10% at 100 hours, then you would enter 100 in the Time field and 0.10 in the Unreliability field.

  • In the Solve for Parameter area, select the parameter that you wish to solve for. The remaining parameters in this area will have input fields enabled. Enter the known values of these parameters.

• The Two Unreliability Points method solves for all the parameters of the distribution. It requires two unreliability points that you will provide in the Point #1 and Point #2 areas.

  Tip: If you are building an event occurrence or task duration model, you can treat an "unreliability" point as the probability that an event will occur or that a task will be completed by a specified time. For example, if you are modeling the probability of an event's occurrence and you believe that there is a probability of 30% that the event will occur before 150 hours, then you would enter 0.3 in the Unreliability field and 150 in the Time field.

• Click Calculate to solve for the unknown parameter(s).

• Click the Update button to update the model using the selected distribution, calculated parameters and selected time units.

Quick Parameter Estimator (ALTA)

In ALTA only, another version of the Quick Parameter Estimator (QPE) allows you to estimate the parameters of a model based on information you have about the reliability of a product at normal and accelerated stress levels. You can open the QPE from the ribbon by choosing Home > Synthesis > Quick Tools > Quick Parameter Estimator (ALTA).
Follow the steps below to use the ALTA QPE:

- The first page of the window will be used to estimate the product's mean life under normal stress conditions.
  - Choose a model from the **Model** drop-down list. This is the model that you will solve the parameter(s) for. Then choose the appropriate time units from the **Units** drop-down list.
    - Your choice of time units applies to all time inputs and applicable parameters of the model (such as the eta parameter when the Weibull distribution is used).
  - Select an appropriate option in the **Quantification Method** area:
    - The **Unreliability and a Parameter** method solves for one parameter of the model. It requires one unreliability point (i.e., an unreliability value at a specified time) and the values of all the parameters of the selected model except the parameter you will solve for.
      - If you select this method, you must then enter one unreliability point for normal use conditions in the **Point #1** area. For example, if you believe that your product has an unreliability of 10% at 100 hours under normal use conditions, then you would enter 100 in the **Time** field and 0.10 in the **Unreliability** field.
      - In the **Solve for Parameter** area, select the parameter that you wish to solve for. The remaining parameters in this area will have input fields enabled. Enter the known values of these parameters.
    - The **Two Unreliability Points** method solves for all the parameters of the model. It requires two unreliability points under normal use conditions that you will provide in the **Point #1** and **Point #2** areas.
  - In the **Use Stress Level** area, you must enter the stress level that the product will experience under normal conditions. In multi-stress situations, this stress level will be a combination of stress values for each stress type.
    - If the **Number of Stresses** field is enabled, enter the number of stresses that will be used in your model. (Note that different models have different requirements for the number of stresses that can be used.)
• Click the arrow inside the **Use Stress Value(s)** field. In the table that appears, enter a stress value for each stress type. If there are multiple stress values, they will appear in the field separated by semicolons.

![Use Stress Level Table]

• Click **Next >** to go to the Life at Each Stress Level page. The **Use Stress Level** area of the page will display the product's mean life at the specified use stress level based on your previous inputs. In the **Accelerated Level 1** area, you must enter the estimated mean life for the product at an accelerated stress level.

  • To enter the accelerated stress level, double-click inside the **Stress Value(s)** field. In the table that appears, enter the stress value for each stress.
In the **Characteristic Life** field, enter the product's characteristic life at the associated accelerated stress level.

- For the Weibull distribution, the characteristic life is equal to the value of the eta parameter (i.e., the time at which unreliability = 63.2%).
- For the lognormal distribution, it is equal to $\text{Exp(Log-mean)}$ (i.e., the time at which unreliability = 50%).
- For the exponential distribution, it is equal to the mean life.

**Note:** The number of accelerated stress levels you must provide life estimates for will equal the number of stresses that will be used in the selected model. For example, if the model uses two stress types, as shown above, then there will be an **Accelerated Life 2** area in which you must provide a characteristic life estimate for a second accelerated stress level.
• Click **Next >** again to see the calculated parameters.

  • If you opened the QPE from another utility, such as the ALTA Monte Carlo tool, you may click the **Update** button if you wish to update the Monte Carlo tool with the model, parameters and time units defined in the QPE.

  • If you opened the QPE from the ribbon, you may click the **Finish & Copy** button if you wish to copy the results to the Windows Clipboard.
Chapter 13: Resources

In ReliaSoft applications except MPC, resources contain various types of information that can be shared between analyses. Resources may be created in one application and then shared with other ReliaSoft applications where they may be relevant. When the resource is updated with new information, the change is reflected in all analyses that rely upon it.

An example of a resource is a model that represents a product's probability of operating successfully over time. The model may be defined manually or published from an application such as Weibull++/ALTA, RGA or Lambda Predict. Then it can be used in applications such as BlockSim, XFMEA, RCM++ or RBI as part of the universal reliability definition (URD) of a particular component/assembly.

Note: In a secure database, the ability to create, edit and delete resources is available only if the user a) is the project owner, b) has the applicable "resources" permissions, or c) has the applicable "manage all projects" permissions.

Types of Resources

The following tables describe the types of resources that you can use in different ReliaSoft applications. These resources can be created while you're performing an analysis and also from the Resource Manager. (In a secure database, the ability to create, edit and delete resources is available only if the user a) is the project owner, b) has the applicable "resources" permissions, or c) has the applicable "manage all projects" permissions.)

Used in Multiple Applications

<table>
<thead>
<tr>
<th>Resource</th>
<th>Used In</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Universal reliability definitions (URDs)</strong></td>
<td>BlockSim, RCM++, XFMEA, RBI</td>
</tr>
<tr>
<td><strong>Variables</strong></td>
<td>BlockSim, RENO</td>
</tr>
</tbody>
</table>

- **Universal reliability definitions (URDs)** describe a set of reliability and maintenance characteristics for a particular component/assembly.
- **Variables** store numerical values that can be programmatically varied during simulation.
**Models** can represent probabilities, durations or costs, either fixed or time-dependent. They are used by other resources to represent the reliability of a component, the duration of a task, the expected cost of a repair, etc.

Can be **published** from analyses in Weibull++, ALTA, BlockSim, RGA and Lambda Predict, or created manually.  
Used in BlockSim, RENO, XFMEA, RCM++ and RBI.

<table>
<thead>
<tr>
<th><strong>Tasks</strong> represent maintenance activities:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• <strong>Corrective</strong> tasks are unplanned maintenance performed when a failure occurs.</td>
</tr>
<tr>
<td>• <strong>Scheduled</strong> tasks can include preventive maintenance, inspections and on condition maintenance.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Task packages</strong> represent groups of tasks that are performed together at scheduled intervals.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th><strong>Crews</strong> represent the personnel who will perform a maintenance task.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th><strong>Spare part pools</strong> determine whether a spare part will be available, how long it will take to obtain and how much it will cost.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th><strong>Metrics</strong> display any numerical value of interest, and track how it changes over time.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th><strong>Maintenance groups</strong> are used to model situations in which some event within the group can trigger maintenance or state changes for other components/assemblies.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th><strong>Mirror groups</strong> are used to represent the exact same component/event in more than one location within your analysis.</th>
</tr>
</thead>
</table>
### Used Only in BlockSim

<table>
<thead>
<tr>
<th>Resource</th>
<th>Used In</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Switches</strong></td>
<td>BlockSim</td>
</tr>
<tr>
<td>describe how the activity</td>
<td></td>
</tr>
<tr>
<td>transfers between active and</td>
<td></td>
</tr>
<tr>
<td>standby blocks in BlockSim’s</td>
<td></td>
</tr>
<tr>
<td>standby containers/gates.</td>
<td></td>
</tr>
<tr>
<td><strong>Maintenance templates</strong></td>
<td>BlockSim</td>
</tr>
<tr>
<td>define the activities that</td>
<td></td>
</tr>
<tr>
<td>will be performed during a</td>
<td></td>
</tr>
<tr>
<td>maintenance phase in a phase</td>
<td></td>
</tr>
<tr>
<td>diagram.</td>
<td></td>
</tr>
<tr>
<td><strong>Flow groups</strong></td>
<td>BlockSim</td>
</tr>
<tr>
<td>are used to model situations</td>
<td></td>
</tr>
<tr>
<td>in which meeting a particular</td>
<td></td>
</tr>
<tr>
<td>flow threshold can trigger</td>
<td></td>
</tr>
<tr>
<td>maintenance tasks. These</td>
<td></td>
</tr>
<tr>
<td>groups are used only in</td>
<td></td>
</tr>
<tr>
<td>BlockSim process flow</td>
<td></td>
</tr>
<tr>
<td>simulation diagrams (if</td>
<td></td>
</tr>
<tr>
<td>supported by your license).</td>
<td></td>
</tr>
</tbody>
</table>

### Used Only in RENO

<table>
<thead>
<tr>
<th>Resource</th>
<th>Used In</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>RENO functions</strong></td>
<td>RENO</td>
</tr>
<tr>
<td>store equations</td>
<td></td>
</tr>
<tr>
<td>that are evaluated</td>
<td></td>
</tr>
<tr>
<td>based on input</td>
<td></td>
</tr>
<tr>
<td>values passed to</td>
<td></td>
</tr>
<tr>
<td>the function</td>
<td></td>
</tr>
<tr>
<td>during simulation.</td>
<td></td>
</tr>
</tbody>
</table>
**RENO static functions** store equations that are evaluated before simulation begins.

**RENO simulation definitions** are used to trigger simulation of a BlockSim diagram from within a RENO flowchart, allowing you to use one or more results from the simulation in the flowchart.

**RENO tables** store arrays of values in rows and columns.

### Local, Global and Reference Resources

There are three types of resources:

- **Local resources** can be used only within the project in which they were created, and are therefore available only to users with permissions within that project.

- **Reference resources** (which are resources created in a reference project) can be used in any project throughout the database. However, in a secure database, they can be created and edited only by users who have the "Create/edit/delete local resources" permission within the reference project. These resources can be selected by any user who has at least the "Read" permission in the reference project. Users without permissions in the reference project can see the reference resources wherever they are used, but they will not be able to select or modify them.

- **Global resources** can be used in any project throughout the database. In a secure database, they can only be created and edited by users who have the “Create/edit/delete global resources” permission. However, they can be selected by any database user.

To make a resource global, select it in the Resource Manager and choose **Home > Actions > Make Global**.

Making a resource global cannot be undone and this option is not available for all resource types. If you make a resource global, any resources assigned to it will become global as well (e.g., if a URD has an assigned model, making that URD global will also make the model global, regardless of whether it was originally local or reference).
Parent/Child Resource Relationships

Certain resources can have other resources assigned to them (e.g., URDs can have models and tasks assigned to them, tasks can have models, crews and spare part pools assigned to them, etc.). This can be considered a "parent/child" relationship.

When you create a resource from within its parent, the child resource will be of the same type as its parent. For example, if you are working with a global URD and you add a model to it, the model will be global. If you are working with a reference task and you add a crew to it, the crew will be added to the reference project that contains the task.

When you assign existing resources to a parent resource, the following rules apply:

- Any resource assigned to a reference resource must be either a reference resource within the same project or a global resource (e.g., a local model cannot be assigned to a reference URD, nor can a model in "Reference Project 2" be assigned to a URD in "Reference Project 1").

- Any resource assigned to a global resource must be either a reference resource or a global resource (e.g., a local model cannot be assigned to a global URD).

Keeping Resources Together

The application will automatically keep copies of a project’s resources and linked FMEAs when the project is restored, checked out, imported or exported.

- When you create a restore point, any reference resources, global resources or linked FMEAs used in the project are converted to local resources/FMEAs and stored with the backup.

- When you check out a project for local editing, any reference resources, global resources or linked FMEAs used in the project are converted to local resources/FMEAs and stored with the project.

- When importing/exporting a project item that uses reference resources, global resources or linked FMEAs:
  - If you import/export within the same database, the references will remain unchanged.
  - If you import/export between databases, the destination project will contain local copies of the original resources/FMEAs.

- When importing/exporting a project:
  - If you import/export a project that uses global resources, the destination project will contain local copies of the original resources.
• If you import/export a project that uses reference resources or linked FMEAs:
  • The references/FMEAs will be maintained if you also import/export the reference project at the same time.
  • If you don’t import/export the reference project at the same time, the new project will instead contain copies of the original resources/FMEAs.

Creating and Selecting Resources
This topic describes how to use resource wizards to create and edit resources while you’re performing an analysis or creating a URD. In addition, you may also need to:

• Use the Resource Manager to see all of the resources that are available to use in the current project. In addition to creating and editing resources, the manager also allows you to:
  • Delete resources that are no longer needed.
  • Create global resources that are available to all projects in the database.
  • Publish a model that is linked to an existing analysis.

(In a secure database, the ability to create, edit and delete resources is available only if the user a) is the project owner, b) has the applicable "resources" permissions, or c) has the applicable "manage all projects" permissions.)

Opening a Resource Wizard
Throughout all ReliaSoft desktop applications, the availability of a resource wizard is usually indicated by an ellipsis (...) or an arrow in the resource field. Simply click twice in the field to open the wizard.
Tip: If a resource is already assigned in the field, you can edit it directly without opening the wizard by clicking the Edit icon that appears in the field.

Back Arrow and Main Page
Each wizard contains multiple pages with different options on each page. If the option you need is not immediately visible, you can click the Back arrow to see the Main page, which shows all the options that are applicable for the current situation.

As an example, the following pictures show some of the different options that will be available on the Main page for specific situations and resource types.
Selecting an Existing Resource

The Select page of the wizard displays a list of existing resources that meet the criteria specified on the Settings page. You can then further limit the list by typing inside the text box.

As an example, the following pictures show a situation in which the settings are configured to display up to 2,000 models (more resources take longer to load) from the current project only (called local resources), and the user has selected to see only the ones in which the name includes “bulb.”
In addition, for model resources only, you must specify whether you want to display the model parameters in the list (which also takes longer to load).

To change the initial criteria for the list, click the Back arrow and then click the Settings button on the main page.

Alternatively, if you need more information about the available resources and/or a wider range of filtering tools, you can click the icon to open the Select Resource window.

Creating a Resource
In most wizards, you can click the Create New button or icon to create a new resource.

In the model wizard, click the button or icon for the type of model you want to create:

- New Constant
- New Distribution
- New Dynamic
- New Profile (available only when creating a cost or duration model for use in a spare part pool)

Editing a Resource
If a resource has already been assigned, you can view and/or edit its properties by clicking the View/Edit button or icon in the field or in the wizard.

Any changes you make will apply everywhere that the resource is used. This includes analyses in other ReliaSoft applications.

Removing a Resource
If a resource has already been assigned, you can remove it from this location by clicking the Remove button or icon.
Chapter 13: Resources

The resource will remain in the database for use in other locations. If you want to completely remove a resource from the database, you’ll need to use the Resource Manager or Select Resource window.

Universal Reliability Definitions (URDs)

A universal reliability definition (URD) describes a set of reliability and maintenance characteristics for a particular component/assembly. Like any other resource, you can create or edit URDs while you’re performing a relevant analysis, and from the Resource Manager.

Note: Depending on where you are using a URD, only those properties that are relevant are applied. For example, if you apply a URD to a block in an analytical diagram in BlockSim, only the failure model associated with the URD will be applied to the block.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the resources you need for your analyses.

When editing the URD’s properties, you can choose or create:

- A model to describe the behavior associated with the URD. This can be a reliability model, a probability of failure model or an event occurrence model.

- A corrective task that describes the maintenance action taken to restore a failed component to operational status.

- Zero, one or many scheduled tasks that describe the preventive maintenance, inspections and/or on condition maintenance tasks. The order in which the tasks are displayed reflects the priority with which tasks that are scheduled in the same way (see Task Scheduling) will be performed; for example, if there are two tasks scheduled based on interval and they conflict, the task higher in the priority list will be performed and the lower priority task will be disregarded. You can use the up and down arrows in the cells in this column to move the tasks up and down the priority list.

Additionally, the following are shown:

- Identifiers contains additional identifying information that can be used to search for this resource.
• **History** provides information about when the record was created and last updated. If the **history log** has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the record.

• **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

**Trace Usage**
For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the **Dependency Viewer**.

**Models**
In ReliaSoft applications, **models** can represent probabilities, durations or costs, either fixed or time-dependent. They are used by other resources to represent the reliability of a component, the duration of a task, the expected cost of a repair and many other characteristics.

Like any other resource, you can create or edit models while you’re performing a relevant analysis, and from the **Resource Manager**. In addition, you can publish models that are based on an existing analysis (e.g., a life data analysis in Weibull++, a diagram in BlockSim, etc.).

This topic describes the properties for both types of models. The interface will vary based on the particular situation.

**Naming the Resource**
For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see **Default Name Formats window**). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the resources you need for your analyses.

**Associated Analysis**
In published models only, the **Associated Analysis** area identifies the analysis that the model is based on. If the published model reflects the latest analysis results, the status is "Synchronized." If the analysis has been modified since the model was last published, the status is "Out of Sync."
Chapter 13: Resources

Tip: If you have the ability to open the original analysis (i.e., if the required ReliaSoft application is activated on your computer and your user account has permissions to access the analysis), the Source will be configured as a link and there will also be a Data Source button at the bottom of the window.

Model Category
The category determines where and how a model can be used. If you are using a resource wizard to create a new model, it will be assigned automatically based on what’s relevant for the current field. If you are publishing a model or creating it from the Resource Manager, you must select the appropriate option. Once a model has been created, you cannot change its category.

- **Reliability**, **Probability of Failure** and **Event Occurrence** models represent a likelihood of occurrence.
- **Duration** models represent a length of time.
- **Cost per Unit Time** models are used for costs that accrue over time (e.g., the crew charges $50 per hour).
- **Cost** models are used for costs that don't depend on time (e.g., the part costs $100 or the crew charges $50 per service call in addition to their hourly rate).

Model Type

- **A distribution** model represents behavior that varies based on factors such as time and/or applied stress. For a published model, the inputs and parameters will be specified automatically based on the associated analysis. For manually created models, you can:
  - Select a distribution from the drop-down list and then enter the required parameter(s).
  - Use the **Quick Parameter Estimator (QPE)** to estimate the parameters of a distribution based on what you know about the behavior.

Tip: A published model includes one additional parameter that is not relevant for manually created models. **PNZ** stands for percent non-zero. A value of 1 indicates that there are no zero failure times in the data set (which is the most common scenario in life data analysis). A decimal value indicates that the data set does include zero failure times (such as out-of-the-box failures, for example). In such cases, the parameters are calculated based on the non-zero failure times, and then the PNZ value is used as a multiplier when calculating certain metrics (e.g., reliability, unreliability).
• A constant model represents a fixed probability (e.g., 0.9), duration (e.g., 2 hours) or cost (e.g., $10 or $10 per hour).

• A dynamic model represents a fixed probability, duration or cost, based on a specified variable. The variable can then be programatically varied during simulation in one of two ways, thereby changing the value of the model for successive simulation runs.
  
  • For RENO flowcharts, the variable can be varied using RENO’s sensitivity analysis/multiple analyses features.
  
  • When simulating a simulation worksheet, the values used by the variable will be specified in the worksheet.

When dynamic models are used outside of these circumstances, they are treated as constant models using the defined initial value of the variable.

• New in Version 2019, a profile model represents a changing duration or cost over time, based on a specified profile. Profile models are available only for the cost and duration model categories. The cost or duration of the model will be programatically varied based on an input time parameter used in the profile. When creating a profile model, you must specify a time unit; this will be used for the profile’s segment times and, if applicable, for the profile’s output duration.

Profile models can be used for all direct costs and acquisition times for spare part pools. The execution time of the task using the spare part pool will be used as the input time parameter for the profile. Profile models are not available for selection anywhere other than in the relevant fields within spare part pools.

Note that models that are in use cannot be changed to profile models.

**Additional Tools**

Additionally, the following are shown:

• Identifiers contains additional identifying information that can be used to search for this resource.

• History provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the record.
• **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the [Dependency Viewer](http://mpc.reliasoft.com).

### Publishing Models

This topic provides general information about how to create and work with published models, which are model resources that have been published from and continue to be associated with an existing analysis. For information about additional options and requirements in specific applications, see:

- "[Publishing Fitted and Analytical Models](http://mpc.reliasoft.com)" in the BlockSim documentation.
- "[Publishing Models from R-DOE Results](http://mpc.reliasoft.com)" in the Weibull++/ALTA documentation.
- "[Publishing from Failure Rate Predictions](http://mpc.reliasoft.com)" in the Lambda Predict documentation.
- "[Publishing Models from Analysis Results](http://mpc.reliasoft.com)" in the RGA documentation.

The Synthesis Platform does not automatically update the published model when something changes in the original analysis, but users have the option to republish the model at any time. For any other analysis that uses the model, the change will be reflected the next time that other analysis is recalculated/resimulated.

### Publishing Tools

For most ReliaSoft desktop applications, the following model publishing tools are found on the Publishing page of the control panel. In Lambda Predict, they are located on the Publishing tab of the Properties panel.

- **Publish Model** publishes the analysis to a model, making it accessible to all ReliaSoft applications.
  - If the analysis has never been published, this will create a new model and you will be prompted to specify the name and category.
  - If the analysis has already been published, this will update the existing model and change the model's status from "Out of Sync" to "Synchronized."

- **Publish to Existing Model** allows you to select an existing model (using the Select Resource window) and replace it with an association to the current analysis.
Trace Usage opens the Dependency Viewer, which allows you to see where the model is used.

View Model displays the properties for the published model. This information will be available to any user who is considering whether to use the model in a particular analysis.

Remove Association removes the link between the current analysis and the published model. The model will continue to be a resource in the database but it can no longer be synchronized with the analysis.

Published Model Summary
After the model has been published, the summary table in the control panel (or Publishing tab in Lambda Predict) will display the model's name, along with the following details:

- When the Status changes from "Unpublished" to "Published," the label becomes a link that opens the model's properties window.
- Linked? indicates whether the published model has been used. If the model is in use, you can click the link in this field to open the Dependency Viewer.
- Synchronized? displays "Synchronized" if the published model reflects the latest results from the associated analysis. If that analysis has been modified since the model was last published (e.g., if more data has been added, an analysis setting has changed, etc.), the status will display as "Out of Sync."
- The Created By and Modified By fields display the names of the users who created and last updated the model. Click either of the links to see the dates and times.

Model Basis and Status
When a model has been published from an existing analysis, its properties window will include the following additional information:

| Associated Analysis |
|----------------------|----------------|
| Model Name           | Weibull_Folio1_Data1 |
| Source               | Folio1/Data1 |
| Application          | Weibull++ |
| Type                 | Standard Folio |
| Status               | Synchronized |

- Source is the ReliaSoft analysis that the model was published from.
- Application is the ReliaSoft application that is required to view/edit the original analysis.
Chapter 13: Resources

- **Type** is the kind of folio or diagram that the model is based on. For example, this might be a life data folio in Weibull++, an analytical diagram in BlockSim, a failure rate prediction in Lambda Predict, etc.

- **Status** displays "Synchronized" if the published model reflects the latest results from the associated analysis. If that analysis has been modified since the model was last published (e.g., if more data has been added, an analysis setting has changed, etc.), the status will display as "Out of Sync."

**Tip:** If you have the ability to view the original analysis (i.e., if the required ReliaSoft application is activated on your computer and your user account has permissions to access the analysis), the Source will be configured as a link and there will also be a Data Source button at the bottom of the window.

## Tasks

To properly analyze repairable systems, we first need to understand how components in these systems are restored (i.e., the maintenance activities that are performed on the components). In general, maintenance is defined as any action that restores failed units to an operational condition or keeps non-failed units in an operational state. For repairable systems, maintenance plays a vital role in the life of a system. It affects the system’s overall reliability, availability, downtime, cost of operation, etc.

In ReliaSoft applications, maintenance activities are represented using tasks, which are resources that can be shared among analyses and can be managed via the Resource Manager. There are two basic kinds of tasks, which comprise four task classes:

- **Corrective tasks** are the action(s) taken to restore a failed component to operational status. These cannot be scheduled, as the component’s exact failure time is not known before it happens.

- **Scheduled tasks** can be performed on a known schedule, based on time, component condition or other factors. These include:
  - Preventive tasks
  - Inspection tasks
  - On condition tasks

Tasks are assigned to URDs, which are in turn used to represent a set of properties that can be applied to standard blocks in RBDs and to events in fault trees.
**What’s Changed?** Starting in Version 2019, crews are assigned to tasks as part of teams. This allows you to require multiple crews to complete a task (e.g., if a task requires both a mechanic and an electrician).

The Maintenance Task window allows you to create, view and edit all classes of maintenance tasks. It can be accessed by clicking the Create New or View/Edit icon in the Task wizard, which is accessed from Task fields in properties windows (e.g., the Corrective Maintenance Task field in the Universal Reliability Definition window).

It can also be accessed from the Corrective Tasks and Scheduled Tasks pages of the Resource Manager by choosing Home > Edit > Add, by selecting a task and choosing Home > Edit > View or by double-clicking a task.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the resources you need for your analyses.

The following options must be configured for all classes of tasks. Configuration options that are specific to particular task classes are presented in the corresponding sections.

- **Basic Task Properties**

  - **Task duration** allows you to assign a model, which may represent a fixed time or a distribution, to describe the duration of the task. You can choose an existing model or create a new one. If no model is assigned, it is assumed that the task has a duration of zero (i.e., immediate repair).

  - **Teams for task** allows you to choose or create one or more teams that can perform the task. Each team is made up of one or more crews; all crews assigned to the team are considered to be required (i.e., if any one of the crews assigned to a team is unavailable, the team is unavailable). You can add, remove or edit the crews assigned to any team. You can also remove a team from the task, thereby quickly removing all of its crew associations. An empty team is available at the end of the team list, allowing you to define a new team.

If multiple teams are assigned to the task and a team is needed, they will be checked for availability in the order in which they are displayed in this list. Use the Priority Up and Priority Down arrows that appear when you click a team name in the list to move it up and down in the list. If a team is needed and all teams are engaged, the team with the shortest wait time (based on the longest wait time of its constituent crews) is chosen to perform the task.
If no team is assigned, it is assumed that the work will be done by some undefined team that is always available.

- **Restoration** These properties allow you to specify the degree to which the block will be restored after the performance of the task. In the **How much does this task restore the item?** field, you can specify that the item will be returned to as good as new condition (i.e., full repair, equal to a restoration factor of 1), to the same condition it was in when it failed (i.e., "as bad as old" or minimal repair, equal to a restoration factor of 0), or you can choose **Partial restoration**. This option provides you with the ability to model maintenance involving "used parts" or imperfect maintenance. The **Restoration amount** field will appear; starting in Version 2019, you can specify the amount of restoration achieved by the task by entering the value as a decimal from 0 to 1. If you specify anything other than 0 (0%) or 1 (100%), you will need to specify what the restoration effect applies to (i.e., the restoration type). You can select:

  - **Only damage accumulated since last repair**: Each repair will remove only the damage since the last repair (i.e., the nth repair cannot remove the damage incurred before the (n-1)th repair). Note that in this context any task is considered a repair and any damage that has occurred since the last event (corrective task, preventive task, inspection or on condition task) will be reduced.

  - **All accumulated damage**: Each repair can reduce any damage accumulated up to that failure.

For simulation, the application uses the restoration factor to determine the new age of the block after the maintenance action.

For example, consider an automotive engine that fails after 6 years. If the engine is rebuilt and the rebuilding task has a 50% restoration factor:

- If **Only damage accumulated since last repair** is selected, the initial rebuild has the effect of rejuvenating the engine to a condition as if it were 3 years old.

  The engine fails again after 3 years (when it again reaches the effective "age" of 6 years), but the rebuild this time affects only the age accumulated after the first rebuild. Thus the engine has an effective age of 4.5 years after the second rebuild ($3 + 3 \times (1 - 0.5) = 4.5$).

  After the second rebuild, the engine fails again after a period of 1.5 years (when it again reaches the effective age of 6 years) and a third rebuild is required. The effective age of the engine after the third rebuild is $5.25$ years ($4.5 + 1.5 \times (1 - 0.5) = 5.25$).
• If **All accumulated damage** is selected, the initial rebuild has the effect of rejuvenating the engine to a condition as if it were 3 years old.

The engine fails again after 3 years (when it again reaches an effective age of 6 years) and another rebuild is required. This rebuild also rejuvenates the engine by 50%, thus making it effectively 3 years old again.

After the second rebuild, the engine fails again after a period of 3 years (when it again reaches the effective age of 6 years) and a third rebuild is required. The effective age of the engine after the third rebuild is 3 years.

Compare the following tables to see how the two options differ.

### Only Damage Accumulated Since Last Repair

<table>
<thead>
<tr>
<th>Time</th>
<th>Time Since Last Repair</th>
<th>Effective Age Before Repair</th>
<th>Effective Age After Repair</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start = 0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>6 years</td>
<td>6</td>
<td>6</td>
<td>3</td>
</tr>
<tr>
<td>9 years</td>
<td>3</td>
<td>6</td>
<td>4.5</td>
</tr>
<tr>
<td>10.5 years</td>
<td>1.5</td>
<td>6</td>
<td>5.25</td>
</tr>
</tbody>
</table>

### All Accumulated Damage

<table>
<thead>
<tr>
<th>Time</th>
<th>Time Since Last Repair</th>
<th>Effective Age Before Repair</th>
<th>Effective Age After Repair</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start = 0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>6 years</td>
<td>6</td>
<td>6</td>
<td>3</td>
</tr>
<tr>
<td>9 years</td>
<td>3</td>
<td>6</td>
<td>3</td>
</tr>
<tr>
<td>12 years</td>
<td>3</td>
<td>6</td>
<td>3</td>
</tr>
</tbody>
</table>
What’s Changed? In versions prior to 2019, the Restoration amount was specified as a percentage rather than a decimal, and was entered either manually or using a slider bar.

- Additional Costs to Consider allows you to choose or create models to represent costs that are always associated with the task. Cost per task uses a cost model, and Downtime rate uses a cost per unit time model. If no models are assigned, it is assumed that there are no additional costs.

- Identifiers contains additional identifying information that can be used to search for this resource.

- History provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the record.

- Watch allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

- Trace Usage. For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

Corrective Tasks
Corrective maintenance consists of the action(s) taken to restore a failed component to operational status. Corrective maintenance is performed at unpredictable intervals because a component's failure time is not known a priori.

Corrective tasks:

- Always bring the block down.
- May bring the system down.
- Require spare parts.
In addition to the common task properties, the following options are used to configure corrective tasks in the Maintenance Task window:

- **Task Scheduling** allows you to specify when the corrective task will be performed.
  
  - If you choose **Upon item failure**, the task will be initiated upon failure of the component.
  
  - If you choose **When found failed during an inspection**, the task will be initiated if the component is found to be failed at the next scheduled inspection. This is useful in the case of "hidden failures" (i.e., failures that are not apparent until an inspection is performed) and in cases where the component is not considered mission critical and repair can wait until the next scheduled maintenance.
    
    - If a preventive task takes place before the next inspection, then preventive maintenance (not corrective maintenance) will be performed to restore the block. The downtime, etc. will depend on the preventive task properties.
    
    - If a corrective task is performed upon inspection and an inspection finds the block failed, then the total downtime includes the full inspection duration followed by the corrective task duration.

If you have selected to perform a corrective task upon inspection and an inspection or preventive task does not occur after the failure, then the block will never be restored. This could happen under either of the following circumstances:

- Neither an inspection nor a preventive task is specified for the block.
  
  and/or

- The conditions have not been met to perform an inspection or preventive task.

- **Basic Repair Properties > Spare Part Pool** allows you to choose or create the spare part pool(s) that will be used in performing the task. A spare part pool describes the conditions that determine whether a spare part will be available when needed and specifies the time and costs associated with obtaining the spare part. If a spare part pool is not assigned, it is assumed that unlimited free spares are always immediately available.

In Version 2019, the following enhancements have been added:
For each task, you now need to specify a quantity of parts requested from the pool by the task. The default value in the **Quantity requested by task** field is 1.

You can assign multiple spare part pools to a task. In this case, the task is assumed to require all requested parts from all requested pools. In other words, the pools are in an AND relationship, not an OR relationship.

For corrective and preventive tasks, the simulation requests a team as soon as a task is initiated; however, the team does not begin performing the task unless/until all required spare parts are available.

The total time for the task consists of:

- The time to complete corrective and preventive maintenance (based on the corrective task or preventive task properties).

**PLUS**

- The longer of the following times:
  - The time to obtain all spare parts (based on the spare part pools).

  **OR**

  - The time to obtain an available crew (based on crew availability) and any logistical delay time associated with the crew.

For example, consider a block that fails at 10 hours (on the system clock). Its corrective task will take 5 hours, the time required to obtain all spares will be 48 hours and the team consists of a single crew with a logistical delay time of 8 hours. In this case:

- All spares will arrive by 58 hours (on the system clock).
- The team will be requested at 10 hours and will arrive at 18 hours (on the system clock).
- The maintenance will be completed at 63 hours (on the system clock).
- The total time for the corrective maintenance will be 53 hours (48 for the spares plus 5 for the task).
- The team's crew will have traveled for 8 hours, waited 40 hours for the spare parts and performed the task for 5 hours for a total of 53 hours (including waiting for the spare parts).
If the spare parts are available without delay and all other conditions are the same, then:

- The team will be requested at 10 hours and will arrive at 18 hours (on the system clock).
- The maintenance will be completed at 23 hours (on the system clock).
- The total time for the corrective maintenance will be 13 hours (8 for the team plus 5 for the task).
- The team's crew will have traveled for 8 hours and performed the task for 5 hours, for a total of 13 hours.

- **Task Consequences**

  - **Does this task bring the system down?**: By default, corrective tasks will not bring the system down unless having the block down brings the system down based on the reliability-wise configuration in the diagram. If you answer Yes, the task will bring the system down even if the task has a zero duration. This forces the task to be included in the count of system downing events, regardless of the task's duration.

  - **Does this task bring the item down?**: It is assumed that a block will always be down when a corrective task is performed, even a task with a zero duration; thus, this option cannot be changed.

### Preventive Tasks

Preventive maintenance is the practice of repairing or replacing components or subsystems before they fail in order to promote continuous system operation or to avoid dangerous or inconvenient failures. The schedule for preventive maintenance is based on observation of past system behavior, component wearout mechanisms and knowledge of which components are vital to continued system operation. In addition, cost is always a factor in the scheduling of preventive maintenance. In many circumstances, it is financially more sensible to replace parts or components at predetermined intervals rather than to wait for a failure that may result in a costly disruption in operations.

Preventive tasks:

- Always bring the block down.
- May bring the system down.
- Require spare parts.
There are restrictions on the tasks that can be performed simultaneously on the same block. Please refer to Multiple Tasks on the Same Block in the BlockSim/RENO documentation.

In addition to the common task properties, the following options are used to configure preventive tasks in the Maintenance Task window:

- **Task Class** allows you to specify the kind of maintenance that the task performs: preventive, inspection or on condition. The options available in the Maintenance Task window will vary depending on your choice in this field.

- **Task Scheduling** allows you to specify the circumstances under which the task will be performed. (See Task Scheduling.)

- **Basic Task Properties > Spare Part Pool** allows you to choose or create the spare part pool(s) that will be used in performing the task. A spare part pool describes the conditions that determine whether a spare part will be available when needed and specifies the time and costs associated with obtaining the spare part. If a spare part pool is not assigned, it is assumed that unlimited free spares are always immediately available.

In Version 2019, the following enhancements have been added:

- For each task, you now need to specify a quantity of parts requested from the pool by the task. The default value in the Quantity requested by task field is 1.

- You can assign multiple spare part pools to a task. In this case, the task is assumed to require all requested parts from all requested pools. In other words, the pools are in an AND relationship, not an OR relationship.

For corrective and preventive tasks, the simulation requests a team as soon as a task is initiated; however, the team does not begin performing the task unless/until all required spare parts are available. For a complete explanation of how this affects the total time for the task, see Corrective Tasks.

- **Task Consequences**

  - **Does this task bring the system down?:** By default, preventive tasks will not bring the system down unless having the block down brings the system down based on the reliability-wise configuration in the diagram. If you answer Yes, the task will bring the system down, even if the task has a zero duration. This forces the task to be included in the count of system downing events, regardless of the task's duration.

  - **Does this task bring the item down?:** It is assumed that a block will always be down when a preventive task is performed, even a task with a zero duration; thus, this option cannot be changed.
• **If bringing the item down causes the system to go down, do you still perform the task?:** If you answer Yes, the task will be performed even if doing so brings the system down, either because the task itself brings the system down or because the task brings the block down and the block being down causes the system to go down. If you answer No and the task brings the system down, the task will never be performed during simulation unless the system is already down for another reason. For instance, a preventive task that is specified to be performed upon system down will be performed even if it brings the system down regardless of your answer here. This is because the system is already down, which is what triggered the task in the first place.

A preventive task that does not bring the system down at the preventive maintenance time will still be factored into the simulation even if its duration will bring the system down at a later time.

For a preventive task that is scheduled to occur based on item age and for which you have answered No to this question, if the task is going to bring the system down, then it will not take place. If, however, the block reaches the age again (after restoration by a corrective action, inspection or another type of preventive maintenance) and this time it will not bring the system down, then it will be performed.

• **Perform this task even if the item failed before this task was scheduled to occur?:** If you answer Yes, the task will be performed even if the item has already failed. This option is available only for the following tasks:
  
  • Preventive tasks and inspection tasks (including the inspection portion of on condition tasks) that are scheduled based on item age. In this case, the item's "clock" is not stopped upon failure, and the item's "virtual age" is used to trigger the task.
  
  • Inspection tasks (including the inspection portion of on condition tasks) that are scheduled upon system down or events in a maintenance group.
  
  • The inspection portion of on condition tasks scheduled based on calendar age.

Note that this setting is not relevant when a task is scheduled to be performed as part of a maintenance phase in a phase diagram; all such tasks are performed regardless of whether the item has failed.
- **RCM** properties are text-based properties that are used to keep track of details that may be helpful in reliability centered maintenance analysis, but are not used in reliability/maintainability simulations. These properties are shown only if they are enabled for the project via the interface style settings in RCM++/RBI.

- **Status**: The status of the task (choose from a drop-down list). This setting could be used if you want to keep track of all tasks that have been considered, regardless of whether they end up in the actual maintenance plan (e.g., recommended, rejected, assigned).

- **Proposed Interval**: The interval that was initially proposed for the task. This may be different from the interval that is actually assigned to the task. For example, you may wish to use this property if the team originally suggests a particular interval for the task (perhaps the calculated optimum interval) but then decides to assign a different interval (perhaps an interval that is more convenient for packaging a group of tasks).

- **Reference Document**: A reference to another document that provides more detailed information about the task (e.g., procedure instructions).

- **Condition**: A description of the condition that indicates that a failure will occur (e.g., a threshold for a measurement of wear, vibration, etc). Typically, this field is used for on condition maintenance tasks.

- **Zone**: The zone of the system in which the task will be performed. Typically, this field is used for aircraft MSG-3 analyses.

- **Access**: The access that will be required in order to perform the task. Typically, this field is used for aircraft MSG-3 analyses.

Note: A preventive task with a restoration factor of 0 will generate a new failure with the current age.

**Inspection Tasks**

Inspections are used in order to uncover hidden failures (also called "dormant failures"); they are also used as part of on condition tasks to detect impending failures so that preventive maintenance can be performed.

In general, no maintenance action is performed on the component during an inspection unless the component is found failed, in which case a corrective maintenance action is initiated. However, there might be cases where a partial restoration of the inspected item would be performed during an inspection. For example, when checking the motor oil in a car between scheduled oil changes, one might occasionally add some oil in order to keep it at a constant
level. This sort of restoration is not considered to be preventive maintenance; the deciding factor is that inspection tasks do not use spare parts. Note that an inspection task that triggers a corrective task will not restore the failed block. Only the corrective task will restore the block.

Inspection tasks (including the inspection and associated minor work):

- May bring the block down.
- May bring the system down; if the task brings the system down, it also brings the block down.
- Do not use spare parts.

In addition to the common task properties, the following options are used to configure inspection tasks in the Maintenance Task window:

- **Task Class** allows you to specify the kind of maintenance that the task performs: preventive, inspection or on condition. The options available in the Maintenance Task window will vary depending on your choice in this field.

- **Task Scheduling** allows you to specify the circumstances under which the task will be performed. (See Task Scheduling.)

- **Task Consequences**: An inspection task will not bring the block down unless one of the following options is selected.
  
  - **Does this task bring the system down?**: If you answer Yes, when the task is performed, the system will be down, even if the task has a zero duration. If not selected, the task will bring the system down only if it brings the block down and having the block down brings the system down based on the reliability-wise configuration in the diagram. If this option is selected, even tasks with a zero duration will bring the system down. This forces the task to be included in the count of system downing events, regardless of the task's duration.

  - **Does this task bring the item down?**: If you answer Yes, when the task is performed, the block will be down. Even tasks with a zero duration will bring the block down in this case.

  - **Perform this task even if the item failed before this task was scheduled to occur?**: If you answer Yes, the task will be performed even if the item has already failed. This option is available only for the following tasks:

    - Preventive tasks and inspection tasks (including the inspection portion of on condition tasks) that are scheduled based on item age. In this case, the item's "clock" is not stopped upon failure, and the item's "virtual age" is used to trigger the task.
• Inspection tasks (including the inspection portion of on condition tasks) that are scheduled upon system down or events in a maintenance group.

• The inspection portion of on condition tasks scheduled based on calendar age.

Note that this setting is not relevant when a task is scheduled to be performed as part of a maintenance phase in a phase diagram; all such tasks are performed regardless of whether the item has failed.

• RCM properties are text-based properties that are used to keep track of details that may be helpful in reliability centered maintenance analysis, but are not used in reliability/maintainability simulations. These properties are shown only if they are enabled for the project via the interface style settings in RCM++/RBI.

• Status: The status of the task (choose from a drop-down list). This setting could be used if you want to keep track of all tasks that have been considered, regardless of whether they end up in the actual maintenance plan (e.g., recommended, rejected, assigned).

• Proposed Interval: The interval that was initially proposed for the task. This may be different from the interval that is actually assigned to the task. For example, you may wish to use this property if the team originally suggests a particular interval for the task (perhaps the calculated optimum interval) but then decides to assign a different interval (perhaps an interval that is more convenient for packaging a group of tasks).

• Reference Document: A reference to another document that provides more detailed information about the task (e.g., procedure instructions).

• Condition: A description of the condition that indicates that a failure will occur (e.g., a threshold for a measurement of wear, vibration, etc). Typically, this field is used for on condition maintenance tasks.

• Zone: The zone of the system in which the task will be performed. Typically, this field is used for aircraft MSG-3 analyses.

• Access: The access that will be required in order to perform the task. Typically, this field is used for aircraft MSG-3 analyses.

To understand how inspections work during simulation, you should be aware of the following:

• Multiple non-downing inspections cannot occur on the same block at the same time.

• A non-downing inspection with a restoration factor greater than 0 restores the block based on the age of the block at the beginning of the inspection (i.e., the task duration is not restored).
On Condition Tasks

On condition maintenance relies on the capability to detect failures before they happen so that preventive maintenance can be initiated. If, during an inspection, maintenance personnel can find evidence that the equipment is approaching the end of its life, then it may be possible to delay the failure, prevent it from happening or replace the equipment at the earliest convenience rather than allowing the failure to occur and possibly cause severe consequences.

In BlockSim, on condition tasks consist of an inspection task that triggers a preventive task when an impending failure is detected during inspection.

For on condition tasks, the Inspection properties allow you to configure the inspection portion of the task, and the options are identical to those available for configuring inspection tasks. The On Condition Task (Upon Detection) properties allow you to configure the preventive portion of the task. The options are the same as those available for configuring preventive tasks, except that the Task Scheduling properties are not available. Instead, Failure Detection properties are used to specify the "warning period" that spans from the time when a potential failure can first be detected to the time when the failure occurs.

To define the Failure Detection properties, first specify when the task is likely to detect an imminent failure. If you choose When a certain percentage of the life of the item has been consumed, you must then specify the percentage of the item's life that must have elapsed in order for approaching failure to be detected. This is called the failure detection threshold (FDT). For example, if the FDT is 0.9 and the item will fail at 1,000 days, the approaching failure can begin to be detected at 900 days. If you choose Within a fixed time frame prior to failure, you must then specify the amount of time before a failure when the approaching failure can be detected by inspection. This is called the P-F interval. For example, if the P-F interval is 200 days and the item will fail at 1,000 days, the approaching failure can begin to be detected at 800 days.

On condition tasks can be set to perform the preventive portion of the task even if the item failed before the approaching failure could be detected. If the inspection portion of the task is scheduled based on item age, you can answer Yes to the Perform this task even if the item failed before this task was scheduled to occur? option. (For more about this option, see Inspection Tasks.)

Note the following simulation assumptions regarding on condition tasks:

- An inspection that finds a block at or beyond the failure detection threshold or within the range of the P-F interval will trigger the associated preventive task as long as preventive maintenance can be performed on that block.

- If a non-downing inspection triggers a preventive maintenance action because the failure detection threshold or P-F interval range was reached, no other maintenance
task will be performed between the inspection and the triggered preventive task; tasks that would otherwise have happened at that time due to system age, system down or group maintenance will be ignored.

- A preventive task that would have been triggered by a non-downing inspection will not happen if the block fails during the inspection, as corrective maintenance will take place instead.

- If a failure will occur within the failure detection threshold or P-F interval set for the inspection, but the preventive task is only supposed to be performed when the system is down, the simulation waits until the requirements of the preventive task are met to perform the preventive maintenance.

- If the on condition inspection triggers the preventive maintenance part of the task, the simulation assumes that the maintenance team will forego any routine servicing associated with the inspection part of the task. In other words, the restoration will come from the preventive maintenance, so any restoration factor defined for the inspection will be ignored in these circumstances.

**Task Scheduling**

The following information applies to the task scheduling properties for preventive tasks, inspection tasks and the inspection portion of on condition tasks.

Click the arrow in the **When is this task performed?** field to define the criteria for performing the task. The remaining fields in the task scheduling properties will depend on your selection in this field. The task can be performed:

- **At certain intervals.** If you select this option, you must then specify:
  - Whether the interval is fixed or dynamic.
  - Whether the interval is based on the item’s age (taking duty cycle into account) or on calendar time.

- **Upon certain events.** If you select this option, you can choose for the task to be performed:
  - Whenever the system is down for any reason. No further task scheduling properties are required for this option.
  - Based on events in a **maintenance group.** The task will be performed when user-specified events occur for either some or all blocks in one or more user-specified maintenance groups. The item that the task is assigned to does not need to be part of the selected maintenance group(s).
• When a maintenance phase in a phase diagram starts. Please note that if the task is selected to be performed only at the start of a maintenance phase and the item that the task is associated with is not included in the maintenance phase's associated maintenance template, the task will never be performed. No further task scheduling properties are required for this option.

• Based on events in a flow group (see Flow Groups in the BlockSim documentation). This setting is appropriate only for tasks used in BlockSim process flow simulation diagrams. The task will be performed when flow either reaches/exceeds its threshold or drops to or below its threshold in one or more user-specified flow groups. The block(s)/item(s) affected by the task may or may not belong to any of the flow groups.

The remaining task scheduling properties for each type of schedule are given next. For any interval that you specify, you will be asked to specify the units used.

• **Fixed interval based on either item age or calendar time**: Enter the interval when the task will be performed (e.g., if you enter 100, the task will be scheduled for 100, 200, 300, etc.).

  • Item age refers to the accumulated age of the block, which gets adjusted each time the block is repaired (i.e., restored). If the block is repaired at least once during the simulation, this will be different from the elapsed simulation time. For example, if the restoration factor is 1 (i.e., "as good as new") and the assigned interval is 100 days based on item age, then the task will be scheduled to be performed for the first time at 100 days of elapsed simulation time. However, if the block fails at 85 days and it takes 5 days to complete the repair, then the block will be fully restored at 90 days and its accumulated age will be reset to 0 at that point. Therefore, if another failure does not occur in the meantime, the task will be performed for the first time 100 days later at 190 days of elapsed simulation time.

  • Calendar time refers to the elapsed simulation time. If the assigned interval is 100 days based on calendar time, then the task will be performed for the first time at 100 days of elapsed simulation time, for the second time at 200 days of elapsed simulation time and so on, regardless of whether the block fails and gets repaired correctively between those times.
If the task is performed at fixed intervals, you can select the **Override task scheduling properties with a task package** option to assign the task to a **task package**, which is a group of tasks that are performed together at scheduled intervals. (Note that if a task has been assigned to a task package, the task scheduling properties will be disabled and displayed in italics.)

- **Dynamic interval based on either item age or calendar time**: The task will be performed at variable user-specified intervals. This can be used, for example, to schedule maintenance to be performed with increasing frequency as an item gets older. The **Dynamic intervals** field shows the number of intervals specified. Click the button (...) to open the Intervals window, which allows you to enter the item age intervals when the task will be performed. The intervals are the actual time between maintenance (i.e., they are not cumulative). Note that the last value entered in the Intervals window will repeat, if necessary, until the end of the simulation time.

- **Based on events in a maintenance group**: Specify the events that can trigger the task (i.e., a block fails; a corrective, preventive or inspection task starts; a block is restored to operation), and choose the maintenance group(s) in which the event(s) must occur in order to trigger the task.

- **Based on events in a flow group**: Specify the events that can trigger the task (i.e., flow rate through any connector exceeds or drops below a certain level), and choose the flow group(s) in which the event(s) must occur in order to trigger the task.

**Note**: For preventive and inspection tasks that are scheduled based on item age, the **Perform this task even if the item failed before this task was scheduled to occur?** property determines whether actual age or "virtual age" is considered. If you answer **Yes**, the task will be performed even if the item has already failed. In other words, the item's "clock" is not stopped upon failure, and the item's virtual age is used to trigger the task. (For more about this option, see [Preventive Tasks](http://mpc.reliasoft.com).)

**Crews**

Crews are resources that can be shared among analyses and can be managed via the **Resource Manager**. You can assign the crews to maintenance **tasks**. Starting in Version 2019, crews are assigned to maintenance tasks as part of teams. This allows you to require multiple crews to complete a task (e.g., if a task requires both a mechanic and an electrician). A team can also consist of a single crew.

The Crew window allows you to create, view and edit crews. It can be accessed by clicking the **Create New** or **View/Edit** icon in the Crew wizard, which is accessed from **Crew** fields in properties windows (e.g., under **Teams for task** in the **Maintenance Task window**).
It can also be accessed from the Crews page of the Resource Manager by choosing **Home > Edit > Add**, by selecting a crew and choosing **Home > Edit > View** or by double-clicking a crew.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see **Default Name Formats window**). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the resources you need for your analyses.

The following settings are available to configure the crew:

- **Crew**
  - **Direct cost** allows you to choose or create a **model** to represent the direct cost per unit time to engage the crew (e.g., the hourly charge for the time that the crew spends performing the task). This field uses a cost per unit time model. If no model is assigned, it is assumed that there is no cost.
  
  - **Cost per incident** allows you to choose or create a model to represent the cost per incident to engage the crew (e.g., if you have to pay a fixed fee instead of or in addition to the hourly rate). This field uses a cost model. If no model is assigned, it is assumed that there is no cost.
  
  - **Is there a limit to the number of tasks this crew can perform at the same time?**
    If you answer **Yes**, you must specify the limit in the **Number of tasks** field. For example, if the crew can only fix 3 components at any given time and 4 components fail at the same time, then the crew will not be able to fix the fourth component until one of the other components has been restored.
  
  - **Logistic Delay** allows you to choose or create a model to describe the delay time before the crew can start the task. If no model is assigned, it is assumed that the crew can start the task immediately without any delays (i.e., immediate repair). The team with the highest priority is always called upon first, regardless of logistic wait times for the team's crews. If a team is needed and all teams are engaged, the team with the shortest wait time (based on the longest wait time of its constituent crews) is chosen to perform the task.

For a given simulation, a crew's logistic time is constant across that one simulation for the task. It is taken randomly from its distribution or from its fixed time.

For on condition tasks, if the same crew performs the inspection and preventive maintenance and there are logistic delays associated with the crew, the logistic delays will be factored into the simulation for both parts of the task.
• If **Include logistic delay in cost** is selected, then the time spent waiting for the crew (including logistic delay and any delay incurred due to limits on the number of tasks the crew can perform simultaneously) will be included when calculating crew costs, based on the direct cost specified for the crew.

• If **Include part delay in cost** is selected, then the time spent by the crew waiting for spare parts will be included when calculating crew costs, based on the direct cost specified for the crew.

**Identifiers** contains additional identifying information that can be used to search for this resource.

**History** provides information about when the record was created and last updated. If the **history log** has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the record.

**Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

**Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

---

**Spare Part Pools**

Spare part pools are **resources** that can be shared among analyses and can be managed via the **Resource Manager**. A spare part pool describes the conditions that determine whether a spare part will be available when needed and specifies the time and costs associated with obtaining the spare part. You can assign the pools to maintenance **tasks**.

**What's Changed?** Starting in Version 2019, tasks can request multiple spare parts from a pool. All requested parts must be delivered before the task can be performed.

In addition, multiple spare part pools can be assigned to tasks. In this case, the task is assumed to require all requested parts from all requested pools.

The Spare Part Pool window allows you to create, view and edit spare part pools. It can be accessed by clicking the **Create New** or **View/Edit** icon in the Spare Part Pool wizard, which is
accessed from **Spare Part Pool** fields in properties windows (e.g., in the **Maintenance Task window**).

It can also be accessed from the Spare Part Pools page of the Resource Manager by choosing **Home > Edit > Add**, by selecting a spare part pool and choosing **Home > Edit > View** or by double-clicking a spare part pool.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see **Default Name Formats window**). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the resources you need for your analyses.

The following settings are available to configure the spare part pool:

Tip: New in Version 2019, **profile models** can be used to define any acquisition time and non-holding costs. This new model type allows you to model changes in cost and duration over time. You can also still use all other model types for these fields.

- **Spares**
  - **Direct cost per dispensed item** allows you to specify the direct cost of each spare part in the pool.
  - **Spare acquisition type**: You can select **Unlimited spares** to indicate that an unlimited number of spare parts exist in the pool (i.e., if a spare part is required, it will always be available). If you select **Limited number of spares**, the Pool Restock properties and the Emergency Spare Provisions properties will become available. In addition, you will need to define the following properties:
    - **Initial stock level** is the number of spare parts in the pool at the start of simulation.
    - **Holding Cost ($/Hour in pool)** allows you to choose or create a model to represent the cost of holding a spare part in the pool. The unit used is the default unit for the database. This field uses a cost per unit time model. If no model is assigned, it is assumed that there is no cost. (To determine which unit is defined as the default, choose **File > Manage Repository > Unit Settings**. The default unit is the one that is selected in the Use as Default column.)
    - If you select the **Pool has maximum capacity** check box, you will need to specify the maximum number of items that can exist in the spare part...
pool at any given time. The restock options will add parts only up to this maximum capacity. For example, suppose that the maximum capacity is 20 units and the restock quantity is 5 units. If the current stock level is 18 when a restock is triggered (either on a scheduled interval or because the stock fell to a specified level), then only 2 units will be added to the spare part pool, even though the restock options call for the addition of 5 units at each restock.

If you select **Fixed probability of stockout**, the Emergency Spare Provisions properties will become available. In addition, you will need to enter the probability of running out of stock as a decimal value.

- **Logistic Time for Spare Acquisition** allows you to choose or create a model to describe the amount of time required to obtain the part when it is required for maintenance, assuming that the part is in stock. This field uses a duration model. If no model is assigned, it is assumed that the spare part is available for use immediately.

- **The Pool Restock** properties allow you to define how the spare part pool will be restocked. These properties are available only if you have selected the **Limited number of spares** option in the **Spare acquisition type** field. You can select either or both of the following restock schemes:
  
  - If the **Scheduled restock** option is selected, the pool will be restocked at fixed intervals. The following properties will be available:
    
    - **Restock every** allows you to specify the time interval at which the pool will be restocked.
    
    - **Number added per restock** allows you to specify the number of parts that are added to the pool at every scheduled interval.

  - If the **Restock as needed** option is selected, the pool will be restocked when the stock drops to a specified quantity. This option is available only if the initial stock level entered is at least 1. The following properties will be available:
    
    - **Restock when stock drops to** allows you to specify the number of parts in the pool that will trigger the restock (e.g., when the stock drops to 5, order more parts).
    
    - **Number added per restock** allows you to specify the number of parts that are added to the pool when the restock condition has been met.
    
    - **Required time for stock arrival** allows you to choose or create a model to describe the amount of time required for the new parts to arrive after
the restock has been initiated. This field uses a duration model. If no model is assigned, it is assumed that the parts arrive immediately.

- **Off-site spare part pool** allows you to assign an off-site spare part pool to the current pool. If specified, this pool is considered to be the source for restocking the current pool, which allows you to describe properties for the next level of spare parts that can be accessed when needed. If no off-site spares pool is specified, the parts are assumed to be ordered and no properties are described for the source.

  **Tip:** Circular references between spare part pools are not permitted. In other words, if Pool 1 calls Pool 2 as its off-site spare part pool, and Pool 2 calls Pool 1 as its off-site spare part pool, BlockSim will display a message notifying you of the problem upon simulation.

- The **Emergency Spare Provisions** properties allow you to define the circumstances when the spare part pool is empty but a spare part is required for a task. These properties are available only if you have selected either the **Limited number of spares** option or the **Fixed probability of stockout** option in the **Spare acquisition type** field. Selecting the **Can obtain emergency spares if needed** option indicates that a spare part can be obtained if required and the spare part pool is empty; otherwise, the repair will be delayed until more spare parts arrive in the spare part pool. Selecting this option makes the following properties available:

  - **Number added per emergency** allows you to specify the number of parts that are added to the pool when an emergency acquisition occurs.

  - **Additional costs for emergency spares** allows you to choose or create a model to represent a per incident cost for emergency acquisition of spares (e.g., there is a $50 surcharge when emergency spares are required). This field uses a cost model. If no model is assigned, it is assumed that there is no cost.

  - **Required time for emergency spare** allows you to choose or create a model to describe the amount of time required for the emergency spare parts to arrive after the emergency acquisition has been initiated. This field uses a duration model. If no model is assigned, it is assumed that the parts arrive immediately.

  - **Off-site spare part pool** allows you to assign an emergency off-site spare part pool to the current pool. This allows you to create another level of spare parts that can be accessed for the emergency acquisition.

  - **Identifiers** contains [additional identifying information](#) that can be used to search for this resource.
Chapter 13: Resources

- **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the record.

- **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

- **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

## Metrics

A metric is a resource that provides a flexible way to display any numerical value of interest, and track how it changes over time. This can be used for tracking and displaying a variety of Key Performance Indicators (KPIs) and other values, including:

- Reliability metrics (e.g., reliability, BX% life, etc.) calculated from a model resource.
- Any result from a simulated BlockSim diagram.
- The completion percentage and resource usage for Project Planner gates.
- The reliability or availability calculated from an FMRA in XFMEA/RCM++/RBI.
- Any other user-defined value that you wish to display and track.

Like any other resource, you can create or edit metrics from the Resource Manager, and while you’re performing a relevant analysis. (See Showing Metrics in Folios/Diagrams, Using Metrics in Project Planner Gates and Pushing Metrics from an FMRA.)

If your organization chooses to implement an SEP web portal, it's easy to choose specific metrics that you want to access quickly from any web-enabled device.

**Note:** Metrics are always local resources. They cannot be made global. Metrics in a reference project are local to that project and can't be selected for use in other projects.
**Metric Types**

The following pictures demonstrate the four basic options for specifying the value that will be displayed and tracked.

<table>
<thead>
<tr>
<th>Metric Type</th>
<th>Calculate from a model resource</th>
<th>Obtain from a BlockSim simulation diagram</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Reliability Given Time</td>
<td>Simulation Result</td>
</tr>
<tr>
<td>Associated Model</td>
<td>Widget LDA [WB2 (1.5, 1000)]</td>
<td>System RBD</td>
</tr>
<tr>
<td>Time</td>
<td>100 (Hr)</td>
<td>Mean Availability</td>
</tr>
</tbody>
</table>

**Enter any user-defined value**

<table>
<thead>
<tr>
<th>Metric Type</th>
<th>The value is &quot;pushed&quot; from a Project Planner gate or FMRA</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Constant</td>
</tr>
<tr>
<td>Value</td>
<td>100</td>
</tr>
</tbody>
</table>

**Calculated Result and Saved Values**

The **Calculated Result** field shows the latest calculated value for the metric. This will be updated automatically if the associated analysis or model changes, and the latest result will be stored in an array of saved values.

You can then click the **View Saved Values** icon to view the history of how the metric has changed over time.

If you change any of the properties that affect the way the result is calculated, you will be prompted to decide whether to clear the array of values that were saved before the change. For example:

- If you change the metric from Reliability to Probability of Failure, or from 1,000 hours to 500 hours, you will probably want to clear the array so the timeline of saved values is not misleading.
Alternatively, if you change the metric’s associated model from prototype1 to prototype2 to prototype3 at different stages of development, you may wish to keep the saved values after each change so the timeline shows the improvement across all three stages.

In the Metric Results Viewer, you can also choose to clear the entire history or delete only a particular saved value.

The results viewer also allows you to copy the values to the Clipboard so you can paste into another application. For example, if the metric stores the calculated reliability at different points in time, you may wish to analyze the data with a reliability growth model in RGA.

- **Copy > All rows (dates)** copies the exact dates shown in the table.
- **Copy > All rows (cumulative days)** replaces the dates with the cumulative number of days since the date of the last saved value. For example, if the first date is 1/1/2015 and the second date is 12/31/2015, the cumulative days would be 0 for the first date and 365 for the second date.

### Target Conditions and Result Indicator

The **Target Conditions** feature color-codes the current value of the metric. If all specified conditions are met, then the metric’s value will be displayed in green. If one or more conditions are not met, then it will be in red. For example, in the following pictures, the result is green if the estimated system reliability is at least 80%, and red if it is not.

The **Result Indicator** feature color-codes the indicator that shows whether the value has increased or decreased since the prior saved value. If the direction of the change is desirable, the indicator will be green; if it is undesirable, the indicator will be red. As an example, the following pictures are from the SEP.
Identifiers, History, Watch and Trace Usage

As with most other resources:

- **Identifiers** contains additional identifying information that can be used to search for this resource.

- **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the record.

- **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

- **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

Showing Metrics in Folios/Diagrams

The Publishing page of the control panel shows all of the metric resources that are associated with the current analysis. (The metrics can be created and edited either from the Resource Manager or the control panel.) This applies for:

- Data sheets in Weibull++, ALTA or RGA that have a published model.

- Analytical or simulation diagrams in BlockSim that have a published model for the entire system (either a fitted model or an analytical model).

- Simulation diagrams in BlockSim that have simulation results.

This makes it easy to see the metrics that have been created for each analysis (which may also be displayed in relevant Project Planner gates or in the SEP web portal) and to see the history of how the analysis results changed over time. It also provides a convenient way to create new metrics for the analysis, if desired.

As an example, the following picture shows a typical scenario for Weibull++. In Weibull++, ALTA or RGA, the control panel shows all metrics that are associated with the model published from the current data sheet. In BlockSim, it shows all metrics that are associated with a model published from the diagram and/or obtained from the diagram’s simulation results.

- Double-click a metric to see its properties and history of saved values.
• A **Watch** icon will be shown beside any metric for which you have subscribed to receive an alert when the resource is changed.

• Click the **Metric Summary** icon to see a quick report of all the metrics displayed in the current branch.

• Click the **Create New** icon to create a new metric.

---

**Associating Existing Metrics with a Different Data Sheet**

When an analysis changes (e.g., new data, after a design change, etc.), you may choose to simply update the existing data sheet and recalculate, or keep the original analysis unchanged and perform the updated analysis in a new data sheet.

If you decided to create a new data sheet, there are two ways to ensure that the metrics will reflect the complete history from both analyses:
Publish to the existing model from the new data sheet
If you want the published model to reflect the latest analysis results, you can simply transfer both the model and the associated metrics to the new data sheet. To do that:

1. Calculate the new data sheet and then go to the Publishing page of the control panel.
2. Click **Publish to Existing Model** and then select the model from the original data sheet.

Change the model for the for the existing metrics
If you want to keep the original published model associated with the original data sheet, you can publish a new model for the new data sheet and then transfer the metrics to the new model. To do that:

1. Publish a new model for the new data sheet.
2. From either the original data sheet’s control panel or the Resource Manager, open each metric that was associated with the original data sheet and change the **Associated Model**.

As a shortcut, you can click the **Select Existing** icon on the new data sheet's control panel and choose one or more existing metrics in the Select Resource window. It is important to keep in mind that when you do this, you are changing the associated model for each selected metric.

Using Metrics in Project Planner Gates
There are two ways to utilize **metrics** in a **Project Planner** gate:
Chapter 13: Resources

Relevant Metrics
For any gate in a project plan, you can choose to display up to three metrics that are relevant to this stage of the project (e.g., the target reliability, the latest calculated reliability, etc.).

Use the fields under the Relevant Metrics heading to select an existing metric or create a new one.

Push to Metrics
For any gate in a project plan, you can also choose to push any of the following values to a metric resource. This makes it easy to see the history of all saved values, and enables users to subscribe to receive alerts when the metric changes. You can also choose to show this information in the SEP web portal if it is implemented for the current database.

- **Percent Completed** is the percentage of the total duration of dependent actions/gates that is complete. For example, if Action 1 (duration = 3 days) is complete and Action 2 (duration = 1 day) is incomplete, the progress is 75%.

- **Actual Man Hours %** is the percentage of planned hours that have been used to complete the gate.

- **Actual Costs %** is the percentage of the budget that has actually been used to complete the gate.

Use the fields under the Push to Metrics heading to create a new metric or select an existing metric that is not already assigned to receive a pushed value. (Note that only unused metrics are shown in this list.)

When you first assign a metric in one of these fields, the current value will be automatically saved to the metric. Subsequently, the value will be recalculated each time an associated action or gate is changed. If the value is found to have changed, it will be saved to the metric. To see the current saved value, click inside the field. This will also display a result indicator and the View Saved Values icon, which you can click to see a history of all saved values.
Pushing Metrics from an FMRA

The **Push to Metrics** fields on the Properties tab of the Analysis panel in XFMEA/RCM++/RBI enable you to "push" the reliability and availability values that were calculated/simulated from the Failure Modes and Reliability Analysis (FMRA) to **metric resources**.

This makes it easy to see the history of all saved values while you’re working in the FMRA, and enables users to subscribe to receive alerts when the metric changes. If desired, you can also choose to show this information in a specific **Project Planner gate** (under the Relevant Metrics heading), and in the SEP web portal if it is implemented for the current database.

1. Go to the FMRA tab in the system panel. (See Enabling and Viewing the FMRA in the XFMEA/RCM++/RBI documentation.)

2. Select any item in the FMRA hierarchy and use the fields under the **Push to Metrics** heading to create a new metric or select an existing metric that is not already assigned to receive a pushed value.

3. Calculate and/or simulate the FMRA:
   a. To calculate the reliability, choose **FMRA > Calculations > Calculate (Reliability)**.
b. To simulate the availability, choose **FMRA > Calculations > Simulate (Availability)**.

4. Each time you calculate/simulate the FMRA, the latest value(s) will be automatically saved to the metric(s). To see the history of all saved values, click **View Saved Values**.

### Variables

A variable is a **resource** that stores a numerical value and allows you to assign a name to that value. You can then use the variable name in place of the actual value in the equations that you create. You can also use variables in functions and/or as conditional output values in conditional blocks, logic gates and branch gates.

A variable starts with an assigned initial value, which may be fixed or varied during simulation. You can use variables:

- In RENO, to act as a constant (i.e., maintain a fixed numerical value during simulation).
- In RENO, to temporarily store the output value of a block during simulation. See the next section for more information.
- In RENO, to perform a sensitivity analysis, which involves varying the value of one or two variables between *runs* (i.e., sets of simulations). For example, if you are analyzing potential investment strategies, you may wish to vary the number of years that you will be investing and/or the percentage of your income that will be invested to see how different inputs will affect the final results.
• As the basis for a dynamic model, which represents a fixed probability, duration or cost. The variable can be programmatically varied during simulation, thereby changing the value of the model for successive simulation runs.

• In BlockSim process flow simulation diagrams, to define a throughput amount.

• As inputs for certain fields in BlockSim simulation RBDs via simulation worksheets, allowing programmatic variation of the field value during simulation.

What’s Changed? In previous versions of RENO, variables that stored fixed values were known as constants, and variables that stored outputs were known as storage variables.

Using Variables to Store Output Values in RENO

You can use variables to hold numerical values passed to them during simulation. In RENO, the following blocks are able to store their output values in variables:

• Standard blocks
• Result storage blocks
• Flag markers
• Counter blocks

Depending on your choice in the When to Reset field of the variable's properties window, you can configure the variable to retain the value passed to it during simulation or reset the variable to its initial value at specific times. The options are:

• Reset After Each Simulation (i.e., reset after a single pass through the flowchart)
• Reset After Each Run (i.e., reset after each set of simulations)
• Reset After Analysis (i.e., reset after each set of runs)
• Never Reset

When the simulations end, the variable always returns to its initial starting value unless you have selected Never Reset. If you wish to keep the value used during simulation, you can use a result storage block to store it.

Example

The following example demonstrates two things: a) how a variable may be used to store an output value and b) how a variable may be used in an equation.

In the following configuration, the first block calculates the gross profit from a sale, and then stores its output into a variable called "Profit." The conditional block determines whether the
gross profit exceeds 500. If the output is true, the third block deducts the sale's commission from the profit, and overwrites the stored value with the new output.

The following picture shows the properties window of the variable called "Profit." The initial value of this variable is set to 0.

The following picture shows the Block Properties window of the first block in the example. The output of the equation is stored in the variable.
The following picture shows the Block Properties window of the third block in the flowchart. The equation shows that the commission is deducted from the existing value in the variable, and then the variable is overwritten with the new result. At the end of the simulation, the result storage block in the flowchart stores the final value of the variable, and then the variable resets to 0.
Profiles

A profile is a resource that allows you to represent a value that varies with time. It consists of a basic pattern that either repeats as a cycle or occurs once and then continues from its last defined setting.

There are several types of profiles:

- Stress profiles are used in ALTA life-stress data folios. These profiles can be created manually, or by importing data from nCode GlyphWorks. For information about how to use stress profiles, see Time-Dependent Stress Profiles in the ALTA documentation.

- Throughput profiles are used in BlockSim process flow simulation (PFS) diagrams (if supported by your license). For information about how to use throughput profiles, see BlockSim Process Flow Simulation Diagrams in the BlockSim documentation.

- New in Version 2019, cost profiles and duration profiles are used in profile models, which are available for use in spare part pools.
Creating Profiles Manually (All Types)

Like any other resource, you can create or edit profiles from the Resource Manager, or while you’re performing a relevant analysis. To create a profile:

1. Specify the type of profile that you are creating.

2. Define a pattern for how the stress, throughput level, cost or amount of time (i.e., duration) will change over a specified period of time. The pattern you will define consists of a series of segments, where each segment has a specified duration and a value expressed in one of two ways:
   - a constant stress, throughput, cost or duration value, or
   - a function that takes a time value and returns a stress, throughput, cost or duration value.

These segments are defined in the spreadsheet, as shown next.

<table>
<thead>
<tr>
<th>Segment Start</th>
<th>Segment End</th>
<th>Stress S(t)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>1100</td>
<td>328</td>
</tr>
<tr>
<td>1100</td>
<td>2200</td>
<td>338</td>
</tr>
<tr>
<td>2200</td>
<td>3300</td>
<td>348</td>
</tr>
</tbody>
</table>

- **Segment Start** is calculated automatically by the software and cannot be entered manually. The first segment's start time is always 0. For every subsequent segment, the start time is identical to the prior segment's end time.

- **Segment End** allows you to enter the end time for each segment, which must be smaller than the end time of the next segment.

- **Stress S(t), Throughput T(t), Cost C(t) or Duration D(t)** is the value or function for the segment. If the stress, throughput level, cost or duration will stay constant during a segment, enter a constant value (e.g., 30). If the value will change during a segment, enter the it as a function of time (e.g., at time = 20, the function \( t + 20 \) will return a value of 40). When entering a function, you must use \( t \) or \( T \) as the time variable.

**Tip:** Because units are not defined in the profile, it is important to apply stress and throughput profiles only to folios or diagrams that are intended to use the same stress/throughput and time units. In the Profile window, you may want to use the Comments page as a reminder of which units are applicable to that profile.

For cost and duration profiles, the time units are defined within the model where the profile is applied.
used. This setting applies to the time segments within the profile and, for duration profiles, to the duration values.

For example, suppose you are creating a stress profile where the stress unit is psi and the time unit is seconds. Now suppose you wanted to define the following 120-second pattern: a stress value of 30 psi for 60 seconds, followed by a stress value of 50 psi for 30 seconds, followed by a stress function that begins at 50 psi and gradually decreases at a rate of 1 psi per second for the remainder of the pattern. For this pattern, you could fill out the spreadsheet as follows:

<table>
<thead>
<tr>
<th>Segment Start (sec)</th>
<th>Segment End (sec)</th>
<th>Stress ( S(t) ) (psi)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>60</td>
<td>30</td>
</tr>
<tr>
<td>60</td>
<td>90</td>
<td>50</td>
</tr>
<tr>
<td>90</td>
<td>120</td>
<td>( 50 - (t - 90) )</td>
</tr>
</tbody>
</table>

Notice that the last segment of this profile uses a function. Since \( t \) is the test time (or, if the profile is cyclical, the time since the pattern was last restarted), \( t = 90 \) when the last segment begins. So the last segment’s stress level starts at \( 50 - (90 - 90) = 50 \). Then, at 91 seconds, the stress level will have dropped to \( 50 - (91 - 90) = 49 \). After another second it will have dropped to \( 50 - (92 - 90) = 48 \), and so on.

Note, too, that the columns have been renamed to reflect the units for the profile.

3. Next, choose the appropriate option in the After Last Segment area of the control panel. Your selection here will determine what happens after the end time of the profile’s last segment (in the above example, after time \( = 120 \)).

   If you select **Continue with last value**, all times after the last segment will use the value/function defined in the last segment.

   If you select **Repeat cycle**, the entire pattern of segments will be treated as a repeating cycle.

For example, suppose you defined a stress pattern that is made up of five segments, each an hour long and increasing stepwise from the segment before. The graphs below illustrate the difference between continuing from the last stress (left) and selecting to repeat (right). In this example, the test has a duration of 20 hours, and the graphs explain what would happen through the entire duration of the test.
4. Before you can use the new profile in your analysis, you must save any changes you have made and validate the current profile settings. To do this, click the **Validate Profile** icon.

After you save the changes in your profile, the **Profile Summary** area will appear. Click the **Detailed Summary** icon to open the Results window, which shows the current profile in a worksheet that you can copy or print.

To view a stress vs. time or throughput vs. time plot of the profile, click the **Plot** icon. (See **ReliaSoft Plot Utilities** for general information on plots.)

**Note:** Clicking the **Validate Profile** icon will not automatically update your plot. To make sure your plot reflects the most recent profile information, click the **Plot** icon.

If desired, you can use the Comments page of the control panel to enter notes or other text that will be saved with the profile.

5. Click **OK** to save your changes.

### Importing Data from nCode GlyphWorks to Create Stress Profiles

You can import **nCode GlyphWorks** time series data from .S3T files for use as stress profiles. The stress values in the .S3T file must be greater than zero in order for the data to be imported.
To import data from an nCode .S3T file, first create a new profile from the Resource Manager (Home > Synthesis > Resource Manager). In the Profile window, click the Import from GlyphWorks icon on the control panel.

This launches the import wizard, which guides you through the steps required to import data from the file. You can then edit the resulting imported data, if desired. Note that if you update the .S3T file in GlyphWorks, the associated profile in ALTA will not be updated automatically. You must re-import the data to reflect the changes.

**Tip:** Because stress units (e.g., volts) and time units (e.g., hours) are not defined in the profile, it is important to apply profiles only to folios that are intended to use the same stress and time units. In the Profile window, you may want to use the Comments page as a reminder of which units are applicable to that profile.

### Maintenance Groups

Maintenance groups are resources that are available for use throughout the project and can be managed via the Resource Manager. A maintenance group is a set of blocks or system hierarchy items where some event within the group can trigger either maintenance or state changes for one or more blocks or items, either within the group or outside of it. You can use a maintenance group:

- **In BlockSim:** To turn a block on or off. State change triggers are used to activate or deactivate a block when items in one or more specified maintenance groups go down or are restored. The block whose state is being changed may or may not belong to any of the maintenance groups. This allows you to model a cold standby configuration (i.e., one where the component cannot fail when in standby) without using a standby container, which may be useful if you are using a parallel or complex configuration, as blocks can be connected only in series in standby containers.

- **In BlockSim, RCM++ or RBI:** To trigger a scheduled task (i.e., a preventive task, inspection or on condition task). You can set the task to be performed based on events in one or more maintenance groups. Triggering events within the maintenance group can include block/item failure; start of corrective, preventive or inspection tasks; and/or block/items restoration. The block(s)/item(s) affected by the task may or may not belong to any of the maintenance groups. For example, if you want to perform preventive maintenance on Component A every time you perform corrective maintenance on Component B, then you can assign Component B to Maintenance
Group 1 and then set the preventive task assigned to Component A to be performed upon the start of corrective maintenance within Maintenance Group 1. See Task Scheduling for more information on how tasks can be scheduled.

*Note:* In BlockSim diagrams, blocks that belong to a maintenance group have a red circle at the upper left corner of the block. You can change the size of the indicator via the relevant Block Corner Indicators page of the Diagram Style window. You can change the color used for each maintenance group via the Maintenance Group Manager.

The Maintenance Group window allows you to create, view and edit maintenance groups. It can be accessed by clicking the Create New or View/Edit icon in the Maintenance Group wizard.

It can also be accessed from the Maintenance Groups page of the Resource Manager by choosing Home > Edit > New, by selecting a maintenance group and choosing Home > Edit > View or by double-clicking a maintenance group.

At the top of the window, you can specify the maintenance group name. You can replace the default name with your own name of up to 150 characters, if desired. To change the default names, choose File > Manage Repository > Default Name Formats. (In a secure database, this is available only to users with the "Manage other repository settings" permission.)

You can also enter comments about the maintenance group in this window.

For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

**Maintenance Group Manager**

In BlockSim only, the Maintenance Group Manager allows you to add blocks to or remove blocks from a maintenance group without having to go into each block's properties individually. This window can be accessed by choosing Project > Data Management > Maintenance Group Manager or, when you are viewing the Maintenance Groups page of the Resource Manager, by choosing Home > Actions > Maintenance Group Manager.
The **Maintenance Group** area allows you to choose an existing maintenance group from the drop-down list. In addition, you can click the **Select Existing** icon to open the Select Resource window. If there is not an existing maintenance group that meets your needs, you can create a new one by clicking the **Create New** icon to open a window that allows you to specify a name for the new maintenance group, as well as any comments. Click the **View** icon to view the characteristics of the selected maintenance group.

You can also click the **Indicator Style** icon to modify the appearance of the corner indicator that will appear on each block that belongs to the maintenance group, including:

- The indicator's background color, fill color and fill style. The background color is the underlying color applied to the indicator; the fill color is applied over the background color in the pattern specified by the fill style.
• The style (e.g., solid, dash, etc.), color and thickness of the indicator border.

You can change the size of the indicator via the relevant Block Corner Indicators page of the Diagram Style window.

The **Blocks** area displays all of the blocks in the maintenance group, in the format [Diagram Name]\[Block Name].

• To add a block to the maintenance group, you can select the diagram and block in the **Add Block** area and click the **Add to Maintenance Group** button. You also can select the block(s) in the diagram, press **CTRL+SHIFT** and drag the block to the list in the **Blocks** area of the Maintenance Group Manager.

• To view a block in the maintenance group, select the block in the list and click the **Select on Diagram** button. The diagram will be displayed with the block selected.

• To remove a block from the maintenance group, select the block in the list and click the **Remove from List** button.

**Mirror Groups**

Mirror groups are resources that are available for use throughout the project and can be managed via the **Resource Manager**. You can use a mirror group:

• In BlockSim: To place the same block in more than one location (i.e., to represent a single component more than once in a diagram or in multiple diagrams within a project). See **Mirroring (Using Blocks in Multiple Locations)** in the BlockSim documentation.

• In the FMRA in BlockSim, XFMEA, RCM++ or RBI: To place the same cause in more than one location in the FMRA hierarchy, in order to consider common cause failures. See **Using Mirror Groups in an FMRA** in the XFMEA/RCM++/RBI documentation.

**Task Packages**

Task packages are resources that can be shared among analyses and can be managed via the **Resource Manager**. They represent groups of tasks that are performed together at scheduled intervals, for the most efficient allocation of resources and downtime management.
The Task Package window allows you to create, view and edit task packages. It can be accessed by clicking the Create New or View/Edit icon in the Task Package wizard, which is accessed from the Task Package field that appears when you select the Override task scheduling properties with a task package option for a preventive, inspection or on-condition task that is scheduled to be performed at fixed intervals.

It can also be accessed from the Task Packages page of the Resource Manager by choosing Home > Edit > Add, by selecting a task package and choosing Home > Edit > View or by double-clicking a task package.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the resources you need for your analyses.

The following settings are available to configure the task package:

- **In the Perform every field**, enter the length of the interval at which the task package will be performed. You must specify units for this value.

- **The Auto-Packaging Intervals fields** allow you to specify a range of scheduled intervals that will automatically be incorporated into the task package if the user clicks the Auto-Package Tasks button at the bottom of the Maintenance Task Packaging window in RCM++/RBI. The units for these fields are the same as those specified for the Perform every field. For example, if you enter 150 hours in the Start time field and 200 hours in the End time field, then tasks that are scheduled to be performed at fixed intervals from 150 to 200 hours can automatically be included in the task package to be performed at the scheduled time of the task package rather than at their individually scheduled times.

- **Identifiers** contains additional identifying information that can be used to search for this resource.

- **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the record.

- **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.
• **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

### Actions

Throughout the Synthesis Platform, your team can use actions to track specific assignments that need to be performed. These versatile resources can be used multiple times in different locations, if appropriate. Specifically, actions can be created, displayed and/or managed:

- via **Project Plans** or the **Resource Manager** in all ReliaSoft desktop applications except MPC.
- via **My Portal** or **Actions Explorer** in all ReliaSoft desktop applications.
- via the **SEP web portal** (if it is implemented for your database).
- via FMEAs or test plans in XFMEA/RCM++/RBI.

For specific instructions regarding how to create or edit an action in each location, please consult the documentation for that particular feature. This section focuses on general considerations that will be applicable regardless of where/how the action is being used.

**Tip:** If an action is used in an FMEA, the properties window will be different depending on the current context. If you’re using XFMEA/RCM++/RBI and you open the action from the FMEA or My Portal, the window includes additional features that provide quick access to associated FMEA records (failures, causes, etc.) and the FMEA change log (if activated). These features are not available if you open the action from another location (e.g., Resource Manager, Project Planner, Actions Explorer) or in another application, because the associated FMEA can’t be opened in those situations.

### Actions as Resources

As with any other resource:

- Any changes to the action properties will be reflected in all locations where the resource is used.

**Tip:** If you remove an action from an FMEA, a test plan or a Project Plan, the resource will remain in the project unless/until an authorized user deletes it from the database (via My Portal, Resource Manager or Actions Explorer).
Chapter 13: Resources

*Note:* Actions are always local resources. They cannot be made global. Actions in a reference project are local to that project and can't be selected for use in other projects.

### Configurable Settings

Some properties for action records can be configured via interface style settings. See [Configurable Settings](#).

### Show/Hide Properties for Individual Records

You can also use the following ribbon commands to show/hide certain features for a particular action record.

- **Generic vs. Detailed:** A detailed action contains additional properties for describing a specific test that needs to be performed (Specifications, Requirements and Reports). These properties are not configurable; they may be of interest in test plans in XFMEA/RCM++/RBI. (See Test Plans in the XFMEA/RCM++/RBI documentation.) Most actions, unless they are used in test plans, do not need to display these fields.

- **Show Resources:** The resources fields (Team, Facility, Material and Additional Costs) are used for calculating costs and resource utilization. They are always enabled but you can toggle this command to hide or display them for any particular action record. The **Check Utilization** command provides a summary of the resources that have already been assigned. (See Costs and Man Hours.)

- **Show Review/Approval:** If the Reviewer property is enabled in the configurable settings for the current project, you can toggle this command to hide or display these fields for any given action. The **Review Action** command will be enabled if you are assigned to review the action and it is ready to be reviewed. (See Review and Approve Actions.)

### Priority

The color-coded **Priority** command provides a consistent scale for prioritizing actions across all projects in the database. (The same options are also available for gates in the Project Planner.)
This is intended to be used instead of the configurable **Action Priority** field from prior versions, which can be different for different projects. When you convert from a Version 8/9 database, the software will attempt to match any priorities that were assigned with the old configurable drop-down list. For example, if you were using the default "High," "Medium" and "Low" labels that were shipped with Version 8/9 libraries, they will automatically be mapped to the corresponding options in the new ribbon command.

**Action Status and Review Status**

The action’s status bar displays two complementary status indicators. The first one is based on the actual and expected start date and completion date. It indicates that the action is not started, in progress or complete and whether it is on time or running late. (See [Action Timeline and Status](#).)

The second one is based on whether a reviewer has been assigned in the Review/Approval section and, if so, the status of that review.

**E-mail and Alerts**

The **E-mail** command will be enabled if an authorized user has defined a valid SMTP server. This allows you to manually send an e-mail containing the current action details to any valid e-mail address.

If a valid SMTP server has been defined within the database, your team can also choose to use automated alerts (via e-mail or SMS text message). Each individual user can subscribe to "watch" specific action resources, and the database can also be configured to auto-subscribe users assigned to specific roles for the action. (See [Watches and Alerts](#).)
Chapter 13: Resources

Click **Action Monitors** to specify individual users and/or groups of users who will always receive alerts for the record, regardless of whether they have personally subscribed to a “watch.” (See **Action and Gate Monitors**.)

---

**Add to Outlook Calendar**

The **Add to Outlook Calendar** command will be enabled if Microsoft Outlook is installed on your computer.

It launches Outlook’s interface for creating a new calendar event and automatically populates the subject and date. You can modify the details as needed before saving the new event to your calendar.

Note that you may need to give focus to the Outlook application in order to see the window.

---

**Person Responsible and Resources**

For each **action resource**, you can assign both an individual database user who is primarily responsible for completing the action and a team of users who are also involved. You also have the option to track the percentage of their available time that is planned to be utilized for the activity.

**Tip**: If a user is assigned as person responsible and also belongs to the team, the costs and utilization values will be summed. For example, the application assumes that the utilization is X% as person responsible plus an additional Y% as a member of the team.

---

**Person Responsible**

The **Person Responsible** field can be enabled or disabled, depending on the configurable settings for the current project. If you want to use personalized alerts, track resource utilization etc., you must select a database user. Alternatively, you can type a text description (up to 150 characters) that will be displayed in the FMEA spreadsheet.
Tip: If you want to change the person responsible for multiple actions simultaneously (e.g., if a user changes roles and his/her actions need to be reassigned), use the Actions Explorer.

If the Set action creator as 'Person Responsible' by default check box is selected in the Repository Settings window, then the person who created the action is automatically shown in the Person Responsible field, but that can be changed.

Resources
The Resources fields are always enabled but you can toggle the Show Resources command to hide or display them for any particular action record.

You can select from the teams, facilities and materials resources that have been predefined within the database (or create them on-the-fly if you have the required permissions). In a secure database, only users with the "Manage project planning resources and working days" permission will be able to create and edit these resources. (See Project Planning Resources.)

<table>
<thead>
<tr>
<th>Resources</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Team</td>
<td>Gizmo Design Team (5%)</td>
</tr>
<tr>
<td>Facility</td>
<td>A65 Test Lab (2%)</td>
</tr>
<tr>
<td>Material</td>
<td>NJA</td>
</tr>
<tr>
<td>Additional Costs</td>
<td>1000</td>
</tr>
</tbody>
</table>

Check Utilization
If you need to view the utilizations of users and facilities for the current action, click Check Utilization.

Action Timeline and Status
For all action resources, the status is determined automatically based on the actual and expected start/completion dates. If an action is included in the Project Planner, its expected timeline can automatically shift in response to delays in prior activities. If the action is not included in the plan, the expected dates are always identical to the originally planned dates.
Chapter 13: Resources

The following status indicators are displayed in the status bar of the action properties window and in other relevant locations. (Note that the status bar now also displays a separate review status to indicate whether a user has been assigned to review/approve the action and, if so, the status of the review. See Review and Approve Actions.)

- **Not Started**: The action hasn't started, but it can still start on time.
- **Past Start Date**: The action hasn't started, and it is too late to start on time.
- **In Progress**: The action has started.
- **Past Due**: The action hasn't completed, and it is too late to complete on time.
- **Completed - On Time**: The action completed on time.
- **Completed - Late**: The action completed late.

### Costs and Man Hours

For action resources, you can now track the planned vs. actual usage for both costs and man hours.

The **Planned Cost** and **Actual Cost** fields can be enabled or disabled, depending on the configurable settings for the current project. If the properties are enabled, the planned costs will always be calculated automatically based on the action duration, person responsible and project planning resources. For the actual costs, you can choose to enter manually or use the automatic calculations.

#### Enter Manually

If you prefer to enter the actual costs/hours instead of using the automatically calculated values, select **Yes** in the **Manually enter costs/man hours?** field.

<table>
<thead>
<tr>
<th>Manually enter costs/man hours?</th>
<th>No</th>
<th>Manually enter costs/man hours?</th>
<th>Yes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actual Cost</td>
<td>240.00</td>
<td>Actual Cost</td>
<td>475</td>
</tr>
<tr>
<td>Actual Man Hours</td>
<td>2.4</td>
<td>Actual Man Hours</td>
<td>5</td>
</tr>
</tbody>
</table>

**Let the software calculate** | **Enter the values yourself**

#### Calculate Automatically

The automatic calculations are based on:

- The Duration (the number of working days from the start date to the due/completion date).
The Person Responsible and/or the Team:

- The % utilization is set in each action record.
- The Hours per Day and Cost Category are set in each user account record.

The Facility (e.g., test lab or other facility needed to complete the action):

- The % utilization is set in each action record.
- The Max Hours per Day and Cost Category are set in each facility properties record.

The Materials (e.g., test samples or other material needed to complete the action):

- The Quantity and Cost Category are set in the material properties record.

Any Additional Costs that are defined directly in each action record.

The following simple examples demonstrate how each type of cost is calculated.

**Personnel Costs**

**Action Duration:** 5 working days

**Joe Engineer:** Works 8 hours per day (5 days x 8 hours = 40 hours)

Time is billed at $100 per hour (no "per instance" cost)

Assigned as **Person Responsible** with 5% utilization (40 hours x .05 = 2 hours)

Also belongs to the assigned **Team** with 1% utilization (40 hours x .01 = .4 hours)

The calculated values for Joe’s work on this action are 2.4 man hours and 2.4 x $100 = $240.

**Facilities Costs**

**Action Duration:** 5 working days

**ABC Test Lab:** Is available up to 8 hours per day (5 days x 8 hours = 40 hours)

The utilization for this action is 20% (40 hours x .20 = 8 hours)

Costs $500 "per instance" plus $50 per hour

The calculated cost for using this facility to complete the action is $500 + (8x$50) = $900.
Materials Costs
Gizmo Prototype: Costs $5000 to produce the batch of test units (the "per instance" cost)

The test requires 10 samples

Each unit costs $500 (the "direct cost per hour or unit")

The calculated cost for the materials required to complete the action is $5000 + (10x$500) = $10,000.

Action Status Updates
For all action resources, the Progress (Status Updates) area displays any notes that have been added to report progress. The software automatically adds these updates under certain conditions (e.g., upon review/approval), and you can also create updates manually when needed.

To add a new note, click Add Status Update in the action’s ribbon or click the heading and then click the Add icon that becomes visible.

The type that you select in the Add Status Update window can affect the actual start and completion dates of the action, and also update the action status. (See Action Timelines and Status.)

- **Not Started** allows you to record comments without entering a start date. If an actual start date has already been entered, the update will remove the date and change the action’s status back to Not Started.

- **In Progress**
  - If an actual start date is not already defined, sets the current date as the Actual Start Date and allows you to specify the % Completed. This will change the action’s status to In Progress.
• If the action is already in progress, allows you to add another note and update the completion percentage.

• **Completed** sets the current date as the **Completion Date**. This will change the action’s status to either **Completed-On Time** or **Completed Late**.

To delete an existing note, click inside the field and then click the **Delete** icon that becomes visible. **There is no undo for delete.**

---

### Review and Approve Actions

**Action resources** can be marked for review and approval. If the Reviewer property is enabled in the [configurable settings for the current project](#), you can click **Show Review/Approval** in the action ribbon to hide or display these fields for any given action.

(Note that if an action has been assigned for review or is already reviewed, you can no longer hide the fields.)

#### Assigning a Reviewer

If an action has not yet been reviewed, any user who is able to edit the record can assign or change the reviewer at any time.

In a secure database, the Reviewer drop-down list contains all of the database users who have the "Approve actions" permission.

• If a user has been assigned to review the action but an actual completion date is not entered, the review status will be **Reviewer Assigned**.

• When the completion date is entered and the action is ready for review, the status will be **Pending Approval**.

**Tip:** If you want to change the assigned reviewer for multiple actions simultaneously (e.g., if a user changes roles and his/her actions need to be reassigned), use the **Actions Explorer**.
Chapter 13: Resources

Reviewing and Approving the Action
When you are assigned to review/approve an action that has been completed, the record will be highlighted for you in My Portal (and in the SEP web portal if implemented), and you may also receive automated alerts (via e-mail and/or SMS) if applicable.

To record your decision, open the action record and choose Review Action.

In the Review Action window, you can choose one of the following options:

- **Approve action** assigns the review date/time and marks the status Approved.
- **Reject and re-open action** removes the completion date and marks the status Rejected and in progress. The team can perform any rework that is needed and resubmit the action for another review.
- **Reject and close action** marks the status Rejected and closed.

You can enter your comments directly in this window, or enter/update them later in the comments field.

![Review/Approval window](image)

Configurable Settings for Actions and Controls
Some of the properties in action records and in control records are configurable via the interface style settings that have been defined for the current project. The interface style is used in XFMEA/RCM++/RBI to customize a variety of analysis fields to fit the organization’s particular preferences and needs. (See Configurable Settings in the XFMEA/RCM++/RBI documentation.)

You can view/edit the configurable settings for actions and controls from any ReliaSoft desktop application by clicking Configurable Settings of the action properties window or the control properties window. (In secure databases, this is available only if the user is the project owner, or has the "Edit project properties" permission.)
Any changes to these settings will apply to all records of that type in the current project.

**Actions Explorer**

The Actions Explorer is available in all ReliaSoft desktop applications except MPC. You can use this flexible tool to explore all of the action resources that are stored in the current database.

To access the utility, choose **Home > Synthesis > Actions Explorer**.

To reduce the amount of time required to populate the grid, first use the Project, Status, User and/or Date filters to limit your search, then click **Load Data**.

**Add, Edit and Delete Actions**

When actions are loaded in the grid, you can use the following ribbon commands to add, edit and delete actions. (In a secure database, the ability to add or edit an action is only available for users with the "Create/edit/delete local resources" or "Create/edit/delete local resources" permission in the relevant project.)

To delete or edit multiple actions at the same time, press **CTRL** or **SHIFT** while clicking rows in the grid. Selected rows will be highlighted.

- **Add Action** creates a new action resource in the project that currently has focus.
- **Edit Action** allows you to view and edit all of the properties of the action that is currently selected.
- **Delete Action** deletes all of the actions that are currently selected. **There is no undo for delete.**

- **Assign Person Responsible** and **Assign Reviewer** allow you to set (or change) the person responsible or reviewer for all of the actions that are currently selected.

**Save and Apply Views**

Once you have customized the grid to suit a particular purpose (using the built-in filter, column configuration and grouping features described below), you can save the preferences as a view that can be used again whenever you need it. A view is saved in the database and available only to the user who created it.
Chapter 13: Resources

To create a view, first configure the grid to suit your particular needs and then click **Save View**.

To quickly apply these same preferences again at any time, click **Apply View** and select one of the saved views from the list.

**Note**: The view does not affect filtering that has been applied from the Project, Status, User and/or Date filters, or from the Relevance Panel.

### Project, Status, User and Date Filters
The Actions Explorer can utilize the same project filter that is available in many other locations throughout ReliaSoft desktop applications.

You can also filter by status (e.g., In Progress, Completed, etc.), user (e.g., Person Responsible or Reviewer) and date (e.g., Planned Start Date, Actual Start Date, etc.).

After you clear or change these filters, you must click **Load Data** again to update the grid.

### Relevance Panel
The relevance panel provides a quick way to filter the actions based on how they are relevant to you (based on your personal username).

- **I am responsible for**
  - You are assigned in the **Person Responsible** field.

- **I am a team member in**
  - You belong to the team assigned in the **Team** field.

- **I need to review/approve**
  - You are assigned in the **Reviewer** field.
• **I am monitoring**
  - You are assigned in the Action Monitors window, or you have personally subscribed to “watch” the action.

• **I am the creator**
  - You are listed in the Created By field.

• **All actions**
  - Displays all actions, regardless of whether they’re relevant to you.

**Tip:** If an action is relevant to you in more than one way, it will display if any applicable relevance check box is selected. For example, if you are both the person responsible and the creator, the action will display if you have selected "I am responsible for", "I am the creator" or "All actions."

**Built-in Find/Filter, Configuration and Grouping Tools**
The Actions Explorer offers the same filter, column configuration and grouping tools that are built in to other utilities that use a similar grid (e.g., the Resource Manager). For details about how to use each feature, see:

- Finding and Filtering Records
- Configuring Columns
- Grouping Panel

**Controls**
Controls are resources used in FMEAs that are the methods or actions currently planned or already in place to reduce or eliminate risk. Controls can be managed via the Resource Manager.

As with any other resource:

- Any changes to the control properties will be reflected in all locations where the resource is used.
- If you remove a control from an FMEA, it will remain in the project unless/until an authorized user deletes it from the database.
- If a control resource is not currently used in an FMEA, you can delete it via the Resource Manager. (In a secure database, this is possible only if the user a) is the project owner,
Chapter 13: Resources

b) is the control creator, or c) has the applicable "create/edit/delete resources" permission.)

For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

Note: Controls are always local resources. They cannot be made global. Controls in a reference project are local to that project and can't be selected for use in other projects.

For specific instructions on using controls in FMEAs, see the "Controls in FMEAs" topic in the XFMEA/RCM++/RBI documentation.

Configurable Settings

Some properties for controls can be configured via interface style settings. See Configurable Settings.

Resource Manager

The Resource Manager allows you to create, view, edit and delete resources. It also helps you to trace where each resource is used, and to create global resources that are available to all projects in the database.

To open the Resource Manager, choose Home > Synthesis > Resource Manager.

To use the utility, choose the type of resource that you want to work with in the navigation panel on the left side of the window. A table that displays the resources of the selected type will be shown on the right side of the window.

Tip: When you need to create or edit a large number of resources, you can also use ReliaSoft APIs to import the data from an Excel file or other data source. For example, the URDEExample.xlsm file at C:\Users\Public\Documents\ReliaSoft\Examples18\API enables you to quickly create/update multiple URDs with some basic properties (models and corrective tasks). If you have the necessary software coding experience, you can expand this tool or create your own custom applications to meet specific needs.
Resource Filter
The Resource Manager can utilize the same resource filter that is available in many other locations throughout ReliaSoft desktop applications.

Built-in Find/Filter, Configuration and Grouping Tools
The Resource Manager offers the same filter, column configuration and grouping tools that are built in to other utilities that use a similar grid (e.g., the Synthesis Explorer, Actions Explorer, etc.). For details about how to use each feature, see:

- Finding and Filtering Records
- Configuring Columns
- Grouping Panel

Creating, Viewing, Editing and Deleting Resources
You can:

- Create a new resource of the selected type by choosing Home > Edit > Add.

To add multiple resources at the same time, specify the quantity in the Home > Edit > Number to Add field and then choose Home > Edit > Batch Add. You will specify the properties for one of the new resources, and the additional resources will be duplicates of that. You can then edit each resource individually, or you can go to the Batch Properties Editor to edit them in a spreadsheet format.

- Duplicate an existing resource by selecting the row in the table and choosing Home > Edit > Duplicate. You can choose to duplicate just the selected resource, or choose Cascade Duplicate to duplicate the resource and all resources assigned to it, at all levels (e.g., cascade duplicating a corrective task will also duplicate the task's duration model, the assigned crew and all models assigned to the crew, etc.).
• View or edit an existing resource by double-clicking the row in the table or by selecting the row and choosing Home > Edit > View.

• Delete an existing resource by selecting the row in the table and choosing Home > Edit > Delete.

You cannot delete a resource that is currently being used in any other resource or analysis.

Note: A published model cannot be edited or deleted from the Resource Manager. If changes are needed, you must update the original analysis and then republish the model. If you wish to delete the model, you must first remove the association with the original analysis and also make sure the model is not being used. (See Publishing Models.)

Tracing Where Resources Are Used
With a single resource selected, you can choose Home > Selected Resource > Trace Usage to open the Dependency Viewer, which provides information on where the resource is used and any additional resources that the currently selected resource itself uses.

If you need to know which resources are not currently being used (e.g., because you want to delete obsolete records), choose Home > Display > Show Only Unused.

Local and Global and Reference Resources
As explained in Local, Global and Reference Resources, the availability of resources for use is determined by their scope. Local resources are available only in the current project. Reference resources are available for any project within the database, depending on the user's permissions within the reference project. Global resources are available for use in any project in the database.

The far left column in the Resource Manager displays an icon that indicates whether each resource is local, global or a reference resource.
You can use the **Home > Display > [Show Local/Show Global/Show References]** commands to toggle the types of resources shown in the Resource Manager.

**Exporting Information from the Resource Manager**
To send the contents of the Resource Manager to Excel, or to a built-in **Synthesis Workbook** or spreadsheet if that’s available in the current application, choose **Administration > Output > Transfer Report**.

You can send either the current item (i.e., the table for the currently displayed page) or the full report (i.e., the tables for all pages in the Resource Manager).

**Finding and Filtering Records**
This topic describes the find and filter tools that are built in to the Resource Manager and other utilities that use a similar grid. Each of these tools can be used separately, or in conjunction with the others.

**Find Panel**
The Find panel allows you to search for a word or phrase across all of the available properties. To show or hide this panel, toggle the **Show Find Panel** command on the ribbon or in the shortcut menu that appears when you right-click a column heading.
Chapter 13: Resources

When you enter text into the Find panel, it will return only the fields that contain the text you specified, as well as highlight all of the locations where the matching text occurs.

To stop filtering the data, clear the text box.

![Auto Filter Row](image)

**Auto Filter Row**
The Auto Filter Row allows you to filter the grid based on a selected filter operator.

To display or hide this row, toggle the **Show Auto Filter Row** command on the ribbon or in the shortcut menu that appears when you right-click a column heading.

Click the selector icon in the auto filer row and then enter the search text or value against which column will be filtered, as shown below. The set of filter operators available for a column depends on the type of data the column displays.

For example, the following filter shows only the rows in which the model name contains "Component A" and the distribution contains "Weib."

![Example Filter](image)
**Advanced Filters**
The Advanced Filters allow you to choose an automatically generated filter or create a quick custom filter. The automatically generated filters are based on the unique values that currently exist in the column.

For example, the following picture is based on a data set that contains models from three different categories. If you choose one of the automatically generated filters (e.g., "Reliability"), the grid will display only models of that one selected category.

If you want to see models from two of those categories (e.g., either "Reliability" or "Probability of Failure"), you can choose [Custom] and create a quick custom filter like this:

![Custom AutoFilter dialog](image)

If a filter has been applied for a particular column, select [All] to remove it.

**Current Query Criteria**
When you are filtering the grid using the Auto Filter Row, Advanced Filters and/or Edit Filter window (described below), the current query criteria will be displayed at the bottom of the window. For example:
Chapter 13: Resources

- Click the X to delete the current set of filter criteria.
- Clear the check box to remove the current set of criteria without deleting it. Select the check box if you want to re-apply it.
- Click to choose from a list of filter criteria that were recently applied.

**Edit Filter**
The Edit Filter window provides the most flexibility to refine and adjust a filter in either a grid or a Dashboard layout. To access the tool, click the Edit Filter button to the right of the current query criteria (if applicable), or choose Edit Filter from the shortcut menu.

As an example, the following filter from the Resource Manager will display only cost per unit time models in which the rate equals either $120 per hour or $2 per minute.

- Click a red label if you want to:
  - change the *logical operator* (And, Or, Not And, Not Or)
  - add or remove a *group*
  - add a *condition*
  - clear the entire filter
• Use the and icons to add or remove conditions within an existing group.

• Click a blue label if you want to change the property (e.g., Model Name, Created By, etc.).

• Click a green label if you want to change the relational operator (e.g., Equals, Contains, Begins with, etc.).

• Click a gray or black label if you want to enter or change the value.

Configuring Columns
This topic describes the capabilities for selecting, reordering, resizing and sorting columns that are built in to the Resource Manager and other utilities that use a similar grid.

Selecting Columns
To specify which columns will be displayed in the grid, click Select Columns.

In the utility's window or panel for selecting columns, use the check boxes to choose which columns will be displayed. As an example, the following pictures show the window and panel for model resources in the Resource Manager.
Chapter 13: Resources

Reordering Columns
To change the column order, drag the column heading into the desired position.

Resizing Columns
To resize columns, you can do any of the following:

- Drag the edge of the column heading to the desired position.
- Double-click the edge of the column heading or right-click it and choose Fit This Column. This will resize the column to fit its data.
- Right-click any column heading and choose Fit All Columns. This will resize all columns to fit their own data.

Sorting Columns
To sort the grid by one column at a time, you can simply click the column heading to sort in ascending order (↑), or click it again to sort in descending order (↓).

To sort the grid by multiple columns, right-click each column in the desired order and choose Sort Ascending or Sort Descending each time. For example, the following picture shows Synthesis Explorer data sorted first by project (ascending) and then by category (descending).

To stop sorting, right-click any column heading and choose Clear All Sorting.
Grouping Panel

This topic describes the grouping panel capability that is built in to the Resource Manager and other utilities that use a similar grid.

When you are working with a large amount of data, it may be convenient to group it based on one or more properties. For example, the following picture shows resources in the Resource Manager grouped first by keyword and then by model category.

To group the data without opening the grouping panel, right-click any column heading and choose Group By This Column. Alternatively, you can choose Show Grouping Panel to display the panel and then drag column headings into or out of the panel to configure the groups.

When the grouping panel is displayed, you can also:

- Click the column heading to change the sort order between ascending (↑) or descending (↓).
- Drag column headings within the panel to change the grouping order. For example, if you prefer to group first by model category and then by keyword, drag the column headings as shown below.
To stop grouping the data, drag all column headings out of the panel or choose Clear All Grouping.

**Removing Unused and Duplicate Resources**

The Resource Manager provides several tools to make it easy to delete unused resources and merge duplicate resources.

**Finding and Removing Unused Resources**

To find unused resources of the selected type, choose Home > Display > Show Only Unused.

Once you have found the unused resources, you can decide which ones to delete.

You can return to viewing all resources of the selected type by choosing the Show All command.

**Finding Duplicate Resources**

You may sometimes have duplicate resources within a project (i.e., several models that all represent the identical distribution, several tasks that are identical, etc.) within a project. For example, this might happen if you have imported diagrams that all reference the same model, but the imports happened at separate times and therefore the model had to be imported again each time.

To find duplicate resources, choose Home > Display > Show Only Duplicates.

In the window that appears, select the properties that must match in order for the resources to be considered duplicates. For example, if you are looking for duplicate URDs, you might select
to compare the model, corrective task and scheduled tasks, but not the URD name. Once you have selected the columns to compare, click OK to show the duplicate resources.

You can merge multiple resources of the same type into one resource, either automatically or manually. Note that models must be of the same category in order to be merged, and you cannot merge published models. When you merge resources, any folios that you may have open will be closed prior to the merge in order to prevent data inconsistencies.

**IMPORTANT:** Merging cannot be undone, and only the information from the "target" resource (i.e., the resource that you merge the others into) will be retained.

### Automatically Merging Duplicates

To merge resources automatically, choose **Administration > Cleanup > Merge All Duplicates**.

This will find all sets of duplicates within the selected resource type (e.g., three identical Weibull models and 2 identical lognormal models); and for each set, it will merge the duplicates into the first instance found. After you confirm that this is what you want to do, you will be prompted to select the properties that must match in order for the resources to be considered duplicates. The process begins as soon as you select at least one column and click OK. It cannot be undone.

### Selecting Resources to Merge

To merge resources manually, select the resources and choose **Administration > Cleanup > Merge & Delete**.

The window shows a list of the resources you selected to merge and allows you to choose which one will be retained (i.e., the one that the other selected resources will be merged into). After you click OK, this resource will be used in all places where the other selected resources were previously used.

### Select Resource Window

The Select Resource window allows you to choose an existing resource to use at your current location. You will see this window in situations like the following:

- When you click the **Select Existing** icon in any resource wizard.
Chapter 13: Resources

- When you are adding an existing action in an FMEA or in the Project Planner, or an existing control in an FMEA.

The Select Resource window is similar to the Resource Manager, but it shows only the resource type that you are currently working with. The functionality of the window will vary slightly depending on where you have opened the window from.

- If you can select only one resource (e.g., in a resource wizard), each row in the table will contain a radio button that allows you to select the resource for use. If you can select multiple resources (e.g., adding existing actions or controls in an FMEA), each row will have a check box instead.

- Actions, controls and metrics are always local, so the commands to show global or reference resources will not be available in these cases.

- The ability to apply an item filter is available only for resources that have a full set of identifiers. This excludes actions and controls.

- Some resources may not be available for selection. For example:
  - In an FMEA, you can't select an action or control that is already assigned to the current cause.
  - In the project planner, an action cannot be added if it is already in use in the project plan or if its start date is either before or more than a year after the gate's start date.
  - A metric can't be selected to have a value pushed to it if it's already in use somewhere else, or if it's a type that is not compatible with the current use.

**Trace Usage**

**Dependency Viewer**

Because resources can be used multiple times, it is important to know where a given resource is used before making changes to it. The Dependency Viewer, which is accessed by clicking the Trace Usage icon in each resource properties window or in the Resource Manager, provides information on where the resource is used and what additional resources, if any, it uses.

The selected resource is shown in the Current Selection area in the middle of the Dependency Viewer.
Chapter 13: Resources

The items that use the selected resource, if any, will be displayed in the **This [resource] is used by** area on the left. If it uses any resources, those resources will be displayed in the **This [resource] uses** area on the right. For example, in the picture shown next, the selected resource is a URD. It is used by Block 1 in a BlockSim diagram and by SubSystem 1 in an FMEA analysis. The URD uses an assigned model and two tasks.

You can edit any resource shown in the Dependency Viewer by right-clicking it and choosing **Edit Item** on the shortcut menu. The resource's properties window will open.

You can double-click an item in either area to make it the current selection in the window. For example, you could double-click a task used by the URD to see the model(s), crew(s) and/or spare part pool(s) that the task uses.

As you change selected items, each previous item that you selected will be added to the "path" of recent selections at the top of the window; click **Back** to go back through the path to the previously selected items. For example, the following picture shows a path in which the user started with the URD, then proceeded to its corrective maintenance task, the crew for that task and the logistic delay for that crew (not shown in the path because it is the current selection). The button now provides a quick way to go back through those same resources in reverse order if needed.

You can click the **Diagram View** button to open the **diagram view** of the Dependency Viewer. The currently selected item will be the main block in the diagram that is created.
Choosing What You See

In the **Current Selection** area, you can choose what is shown in the **This [resource] is used by** area. You have the option to skip the URD and/or the block that the resource is used by. For example, the image below shows the connections among analyses and resources that we have been discussing. If you have selected to show all levels, you can trace from Reliability Model to URD 1 to Block 1 to RBD 1. But if you have selected **Skip Blocks and RBDs**, it just shows that Reliability Model is used by RBD 1.

Note that blocks are always skipped in RENO flowcharts (i.e., only the flowchart will be shown as the precedent for a resource used by any block within the flowchart).

Dependency Viewer - Diagram View

The diagram view of the Dependency Viewer, which is accessed by clicking the **Diagram View** button, offers a diagram-based alternative to help you understand the connections among resources in your project.

To understand how to use this view, consider the same example shown in the **Dependency Viewer** topic. Clicking the **Diagram View** button for that example will yield a diagram view that shows only the main item (in this case, the URD), which is marked with a flag:
To view a graphical representation of the information that was shown in the Dependency Viewer, choose **Add One Level Precedents** and **Add One Level Dependents**. This will show the items that use the resource (i.e., its precedents), and the resources that it uses, if any (i.e., its dependents).
If you want to see all levels, choose **Add All Precedents** and **Add All Dependents**:

If you want to add or remove one branch at a time, click the green arrows on the sides of the blocks. Alternatively, if you want to remove one branch, select the block and choose **Delete Precedents** or **Delete Dependents**.

To set a different item as the main item in the diagram, select it and choose **Set Block as Main**. This serves the same purpose as changing the selected block in the Dependency Viewer.

Use the commands in the Options group of the ribbon's Home tab to specify how the diagram will be constructed:

- Select **Reuse Items** to show each item only once in the diagram. For example, if you are viewing a URD that is used by two blocks in the same diagram and you choose **Add All Precedents**, the Reuse Items command will affect the display as shown next:
This command must be selected before the diagram is created, or you must clear the current diagram to apply it.

- Use the **Show Blocks in RBDs/FTs** and **Show URDs** commands to determine whether blocks and/or URDs are shown as intermediate steps between resources and the analyses in which they are used.

- Select **Show Item ID** to display the internal ID assigned to each resource, block and/or diagram. These IDs can be used to differentiate among items that share the same name.

The Diagram tab of the ribbon offers zoom options and [printing options](#), as well as the ability to copy the diagram or to export it as a graphics file.

**Batch Properties Editor**

The Batch Properties Editor is designed to support batch editing of most types of local resources in the current project. In BlockSim, it also allows you to edit the blocks used in the diagrams. It enables you to edit the properties in a convenient grid, rather than opening the properties window for each individual resource/block. This utility is available for all desktop applications except MPC.

To open the Batch Properties Editor, choose **Home > Synthesis > Batch Properties Editor**.

To use the utility, choose the type of resource or diagram that you want to work with in the navigation panel on the left side of the window. The right side of the window shows the
resources or blocks you can edit. For information on configuring the table and limiting the items shown, refer to the Configuring Columns and Finding and Filtering Records topics.

Tip: If you change the information in one column, it may affect the information required in another column. For example, if you are editing a model and you change the Model Type column from "Weibull-2" to "Weibull-3," then the Parameter 3 column will change from "N/A" to requiring a numerical input for the third parameter for the Weibull distribution (i.e., gamma).

The changes you make in the Batch Properties Editor will be saved when you close the window. You can also choose Home > Display > Refresh to commit your changes immediately and refresh the Batch Properties Editor to display the most current information, including recent changes by other users.

Note the following:

- **Gray Background.** If the property does not apply to the corresponding resource or block, "N/A" will appear in the column and the cell will have a gray background. Properties that cannot be edited via the Batch Properties Editor, such as the model category, will also have a gray background.

- **Required Properties.** Depending on the type of item you are editing, certain properties may be required (e.g., if you are editing a model using a 2-parameter distribution, both parameters must be populated). In these cases, you can edit the properties, but you cannot delete them. This also means that the Cut command will function as a Copy command for these cells.

- **Published Models.** Models created by publishing results from an analysis in a ReliaSoft application cannot be edited in the Batch Properties Editor. To edit a model that was published from an analysis, you must return to the original data source, make the necessary changes, recalculate and republish the model.

- **Model Parameters.** Since the required parameters for a model will vary depending on the model type, the way you use the parameter columns in the Batch Properties Editor will vary. The parameter columns in the Batch Properties Editor for each model type are presented in the table shown next.
You can choose the **Spreadsheet Editor** command on the ribbon to open the Spreadsheet Editor, which displays the resources or blocks in a spreadsheet-based view. This enables you to use the capabilities inherent in a spreadsheet (e.g., batch copying, formulas, etc.) to make editing multiple items easier. When you are finished editing, choose **Close > OK** to save your changes and close the Spreadsheet Editor or **Close > Cancel** to close the Spreadsheet Editor without saving your changes.

**Exporting Information from the Batch Properties Editor**

To print the contents of the Batch Properties Editor, choose **Administration > Output > Print** command on the ribbon.

To send the contents of the Batch Properties Editor to Excel, or to a built-in **Synthesis Workbook** or spreadsheet if that's available in the current application, choose **Administration > Output > Transfer Report**.
You can send either the current item (i.e., the table for the currently displayed page) or the full report (i.e., the tables for all pages in the Batch Properties Editor).

**Tip:** When you need to create or edit a large number of resources, you can also use ReliaSoft APIs to import the data from an Excel file or other data source. For example, the URDEexample_V10.xlsm file at C:\Users\Public\Documents\ReliaSoft\Examples10\API enables you to quickly create/update multiple URDs with some basic properties (models and corrective tasks). If you have the necessary software coding experience, you can expand this tool or create your own custom applications to meet specific needs.
Chapter 14: Project Planner

The Project Planner provides extensive project planning and management capabilities, including the ability to create timelines, evaluate progress, track resource usage and estimate costs. Any project in a Synthesis repository can be associated with a project plan.

The Project Planner allows you to create, edit or view the plan in any ReliaSoft desktop application except MPC. If the SEP web portal has been implemented for an enterprise database, you can also access a streamlined view of the plan from any web-enabled device.

Creating a Project Plan

Each project in the database can have a project plan. To view the plan from within an open project, choose Project > Management > Project Planner. (In a secure database, any user with "read" access to the project will be able to view the plan and update any actions that are assigned to them. However, only users with the "Create/edit project plans" permission will be able to create or edit the plan.)

A blank plan will be created automatically the first time you open the Project Planner in a given project. By default, the project plan shows a sample starting gate, which records the date you opened the project plan for the first time. You can edit the sample gate and start building the plan from there.

Importing or Starting Again from a Blank Plan

Alternatively, you can start again from a blank plan or import an existing project plan from another project. In the Project Planner, choose Project Planner > Plan > Create Project Plan. (In a secure database, this command is available only to users with the “Create/edit project plans” permission.)
Then choose one of the following options. In both cases, you will need to enter the date the plan will begin in the *Set Start Date* field at the bottom of the window.

- **Choose Blank** to start again from a blank plan. This will delete all of the current gates (*there is no undo for delete*). It will also remove any actions that are assigned to the plan. The action resources will remain in the database unless/until an authorized user deletes them from the database via My Portal, Resource Manager or Actions Explorer.

OR

- **Choose Import from another project** to import an existing plan. You can import from another project in the current database or from any other existing standard or enterprise database.

Choose a source repository and source project for the import. The **Plan Preview** area shows the gates and actions (if any) in the project that is currently selected. By default, the import includes both gates and actions. If you want to import gates only, clear the **Include actions** check box at the bottom of the window.

*Tip:* If you want to use any of the Design for Reliability (DFR) project planning "starter" templates that were installed with XFMEA/RCM++/RBI Version 9, you can either import directly from one of your own projects (converted to Version 2019), or use the "Project_Planner_Templates_Rev1" database (choose *File > Help > Open Examples Folder* then open the file in the "Project Planner" folder). To preserve the integrity of this database, a copy will be created.

**Project Plan Hierarchy**

In the **Project Planner**, the plan consists of gates arranged in a tree-based hierarchy to represent the different phases of a process. You can also include action resources that represent specific assignments that need to be performed. For example, the configuration below shows a plan with five top-level gates (Concept Phase, Design Phase, etc.), where each gate has its own sub-gates and actions.
Certain properties of higher-level gates (e.g., status and dates) are determined by the properties of their dependent gates and actions. For example, the "Concept Phase" above has two direct dependents. If these are marked as complete, then "Concept Phase" is automatically marked complete. (See Gates in the Project Plan for details on how gates inherit their properties.)

In this way, the planner makes it easy for you to monitor how the progress of individual activities relates to the completion of the entire process.

**Project Planner Columns**

To hide or display Project Planner columns, right-click the column headings then click Customize Columns. (You can also change the column order by dragging and dropping column headings into the desired positions.) These settings are stored per computer/username. Any project that you open on this computer will have the same columns displayed, but other users may have different display preferences.

- **General** columns display graphics/text to summarize the status, as well as the priority level and percent completion.

- **Planned Timeline** columns display information about the original plan, including planned start/due dates and resource usage. You can also display the percentage of the budget that is allocated to different project planning resources (i.e., teams, facilities and materials).

- **Expected Timeline** columns display expected start/completion dates given any delays that may have occurred for prior activities, as well as estimates of the costs/man hours to date. (See Project Planner Timelines.)

- **Actual Timeline** columns display actual start/completion dates, as well as the costs/man hours that were used for completed gates/actions.
• Delta Values columns compare two different values, such as the difference between an action's actual and planned costs.

• Relevant Metrics display values for up to three selected metrics. (See Using Metrics in Project Planner Gates.)

• Notes display other applicable information, including descriptions, completion notes and whether an attached file exists.

Project Planner Timelines
For gates in the Project Planner, and for any action resource that is included in a project plan, three different timelines are used to track progress:

• The Planned timeline consists of the originally planned start/completion dates.

• The Actual timeline records when a gate or action has actually started or completed.

• The Expected timeline shows the start/completion dates that are now expected given the current situation. For project plans that use precedents, the expected dates for an activity automatically shift in response to delays in prior activities.

All of these timelines can be shown in gate/action properties and in the Project Planner hierarchy columns. The expected dates are used to determine the status (e.g., past start date, past due, etc.) and are also shown on the summary panel.

Planned Dates
For actions and for gates with no specified precedent, the planned start/completion dates are entered directly in the Gate Properties window.

For gates with precedents, the planned start date is automatically set to the working day following the precedent's due date (i.e., planned completion date). By using precedents in your plan, you guarantee that there will be no gaps between one gate's due date and the next one's start date.

In addition, the software uses the following rules to make sure a gate's planned timeline is consistent with that of its dependent gates and actions:

• If a gate's planned start date is changed (e.g., because of changes to a prior gate's planned duration), the planned dates of all dependents will be shifted in the same way.

• You cannot change a dependent's planned start date to precede that of its parent gate.

• If a dependent's due date is changed so that it comes after its parent gate's due date, the parent gate's due date will be changed to match it.
**Actual Dates**

Actual start/completion dates are entered directly for actions and for gates with no dependents. For gates that have dependents:

- The parent gate's actual start date is automatically set to match the earliest actual start date of its dependents.
- Once all the dependents have completion dates, the latest of those dates is set as the parent gate's actual completion.

**Expected Dates**

By default, expected start/completion dates are equal to the planned dates. However, if the gate/action is part of a plan that uses precedents, the two timelines can differ.

Specifically, when precedents are used, the expected dates will automatically shift in response to recorded delays in prior gates (while the planned dates remain unchanged). For example, if Gate A is the precedent of Gate B, and Gate A completes two days late, then the expected dates for Gate B will be its planned dates + two days. The same will apply to any other gates with precedents that trace back to Gate A.

As an example, consider the following Gantt chart for a plan that has not yet started. The planned and expected timelines (shown in gray and black, respectively) are identical at first.

![Gantt chart example](image)

However, if Gate A completes late (shown in red), the expected timeline shifts for the remaining gates. (The overall plan bars at the top also indicate that the expected duration for the entire plan has now increased by two days.)

![Gantt chart with delay example](image)
Project Planner Gates

Each gate in the Project Planner has its own properties and a status that is determined based on its expected start/completion dates. Additional information about progress and resource usage is available in the summary panel.

To view the properties of a gate, double-click it, or select it and choose Project Planner > Gate > Edit Gate.

Gate Properties

- The Gate fields provide general information about the gate, including its Name, Description and:
  - Deliverables are what will be produced and delivered as a result of completing the gate.
  - Priority is a ranking of the gate's importance ("Low," "High," etc.).
- The Precedent Gate field identifies the gate that must be completed before the current gate can start, if any. If you choose to use precedents in a project plan:
  - The precedent gate must be on the same level in the hierarchy as the current gate. (If the Use Precedence option is selected, the precedent will be suggested automatically for each new gate you create but you can change it manually if desired.)
  - When a gate has a precedent, its planned start date will be automatically set to the working day after the precedent's due date. In addition, delays in the precedent will automatically shift the expected timeline for future gates.
- The Planned Timeline consists of the originally planned start/completion dates.
- The Expected Timeline shows the start/completion dates that are now expected given the current situation. For project plans that use precedents, the expected dates for an activity automatically shift in response to delays in prior activities. (See Project Planner Timelines.)
- The Actual Timeline records when a gate or action has actually started or completed. If the gate has dependents, these dates are automatically inherited in the following way:
  - The actual start date is the earliest actual start date from the dependents.
• The actual completion date is the latest actual completion date from the dependents.

• The **Relevant Metrics** fields let you display up to three relevant metrics in the gate. The **Push to Metrics** fields let you "push" the gate's percent completed and actual vs. planned resource usage to metrics so they can be tracked and displayed in other locations. (See [Using Metrics in Project Planner Gates](#).)

• The **History** fields display information about when the gate was created and last modified. If the history log has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the item.

• **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the gate is changed. (See [Subscribing to a Watch](#).)

• **Gate Monitors** allows you to specify individual users and/or groups of users who will receive alerts for the gate, regardless of whether they have personally subscribed to a watch. (See [Action and Gate Monitors](#).)

---

**Gate Status**

The gate status (which is displayed in the summary panel and in the status bar) is determined based on the same logic used for action statuses, which takes into account the expected start/completion date and any actual dates. For example, a gate's status is "Past Start Date" if it hasn't started and it's too late to start by the expected date, while "Past Due" means it is too late to complete on time.

---

**Actions in Project Plans**

You can add actions to gates in the Project Planner in order to track specific assignments that need to be performed as part of specific phases of the plan. These are the same action resources that can be included in My Portal and SEP web portal, as well as FMEAs or Test Plans in XFMEA/RCM++/RBI.

When you add an action to a gate in the Project Planner, the software will:

- Use **timelines** in the action that automatically shift in response to delays in prior activities, which will affect how the action's **status** is determined.

- Display the action's **plan summary** in the Action properties window.
Chapter 14: Project Planner

- Use the action’s status, percent complete and resources to "roll up" to the gate it is assigned to.

**Adding Actions to the Plan**

With a gate selected in the Project Planner, choose **Project Planner > Action > Add Action**. (In a secure database, this is only available to users with the "Create/edit project plans" permission.)

- **Add Action** creates a new action resource.
- **Reuse Action Resources** allows you to select existing action(s) from the project that a) are not already used in the current plan and b) have dates that fit within the current gate. Specifically, the action’s start date can’t be before or more than a year after the gate’s start date. (See **Select Resource window**.)
- **Reuse FMEA Actions** allows you to select one or more XFMEA/RCM++/RBI system hierarchy items from the current project that have FMEAs. You can then select to use existing action(s) from those particular FMEAs in the project plan.

**Project Plan Summary Panel**

The project plan summary panel displays information about start/completion dates, status, progress and resource usage for an entire project plan, and for individual gates and actions.

The summary panel is accessible from multiple locations across the Synthesis Platform:

- From the **Project Planner**, you can select a gate or action in the hierarchy to view its summary, or you can select the project at the top of the hierarchy to view a summary of the entire plan.
- The gate/action properties window shows the summary for that gate/action.
- The **Plan Summary Page in My Portal** displays a summary of the entire plan for the project that currently has focus.
- These summaries are also displayed in the **SEP web portal**, if it is implemented for an enterprise database.
In most cases, this shows the current date. If you are working in the Project Planner and you want to see what the statuses would be on a different date, click the green "play" arrow (▶️) and then select a different date from the calendar. When you’re ready to return to the current date, click the green "pause" bars (pause).

This bar displays the name of the project, gate or action that the summary applies to, followed by:

- The EXPECTED start date and completion date. (This will be the same as the planned dates unless a prior delay has caused the expected dates to shift.)
- The ACTUAL start date and completion date (if the action is in progress or complete).
- The current status. (See Action Timeline and Status.)

For actions, the progress bar shows the percentage entered by the user. For gates, it shows the percentage of the total duration of dependent actions/gates that is complete. For example, if Action 1 (duration = 3 days) is complete and Action 2 (duration = 1 day) is incomplete, the progress is 75%.
For resource usage, the black bars show the planned man hours and costs. The colored bars show either the expected usage to date (estimated based on the number of days in progress), or the actual usage if complete. (See Costs and Man Hours.)

- Yellow = In progress and usage to date is still within plan
- Orange = In progress and usage to date has exceeded plan
- Green = Complete and actual usage was within plan
- Red = Complete and actual usage exceeded plan

The pie chart will be visible only for projects or gates that have at least one action assigned (either directly or via dependent gates).

- Not Started = Actions that have not started and can complete on time
- In Progress = Actions that are in progress and can complete on time
- Completed = Actions that have a completion date
- Past Due = Actions that can no longer complete on time
Check Utilization

The Check Utilization window lets you examine the utilizations for individual users and facilities across one or more actions. It displays the total utilization for each resource on each specific date, so you can easily identify dates when the resource is over-utilized and make any adjustments that may be needed.

- To view utilizations for a specific action, open the action and choose Tools > Check Utilization.
- To view utilizations across multiple actions, open the Project Planner and choose Project Planner > Tools > Check Utilization.

If you open the utility from the Project Planner ribbon, there are two options. By default, it shows Only actions in this plan. Alternatively, you can choose to see utilizations from All actions in the project (even if they are not used in the plan).

Regardless of whether you’re checking a single action or the entire project plan, the utility shows All resource utilizations by default. Alternatively, you can choose to see Only utilizations over 100%.

Over-utilized resources (i.e., those with a utilization that exceeds 100%) are shown in red.

Double-click a resource to view its total utilization for each specific date, as well as the action(s) that use the resource on each date. For example, according to the window shown next, Joe Reliability's highest utilization for a single day exceeds 100%. By double-clicking his name, you can see that he is assigned to two actions that overlap on 1/6/2016, and as a result his combined utilization for that day is 105%.
Project Planner Gantt View

The Project Planner also includes a Gantt chart that makes it easy to visualize the timelines in your project and examine how different planning resources are utilized over time.

To access this view, click Gantt at the bottom of the Project Planner.

- Use the Gantt Type drop-down list on the control panel to specify what to display:
  - Project Plan shows timelines for gates and actions.
  - Personnel Utilization and Facility Utilization show the utilizations for the person responsible, team and/or facilities. (See Project Planning Resources.)

- In the Gantt Display area, select the part of the plan you want to view in the Filter drop-down list. For example, you could view a specific gate (and its dependents) or a specific user (and all their utilizations). If you want to change the widths of columns that contain dates, use the Fit Mode.

- In the Date Selections area:
  - Select to view the entire plan or focus only on a specific date range.
  - Specify whether each column represents a specific number of Days, or Other increments such as weeks, months, quarters, etc.

- In the Date Display area:
  - If each column represents a single day, select whether to display Non-Working Days. If displayed, those columns will have a gray background. (See Working Days/Holidays.)
  - Use Show Planned, Show Expected and Show Actual to specify which timeline bars will be displayed.
    - To specify the colors that will be used in both the project plan Gantt chart and the timeline plot, choose View > Settings > Set Colors. (See Set Colors for Project Planner.)
  - For the planned and actual timeline bars in the project plan chart, you can also choose whether to Show Percent Completed.
If you are using one of the utilization charts and the date columns each represent more than a single day, use the Calculate Utilization As area to specify how to calculate the utilization. This can be:

- The Max (highest) daily utilization among all days in the interval. For example, if the interval is 3 days and the utilizations were 15%, 0% and 10%, the max will be 15%.
- The Average across only the days in the interval that have utilizations. For example, if the interval is 5 days but the resource was only utilized on 3 of those days, the average will be the total utilization/3 days.
- The Overall Average across all working days in the interval. For example, if the interval is 5 working days, the overall average will be the total utilization/5 days even if the resource was not utilized every day.

**Project Planner Plot View**

The Project Planner includes a plot view that makes it easy to visualize the timelines in your project.

To access this view, click Plot at the bottom of the Project Planner.

- Use the Filter Options area to select whether to filter the data by Gate or by using a Date range. You can also choose to view data for Top Level Gates only.
- In the Display Options area:
  - Show Planned, Show Expected and Show Actual determine which timelines will be shown in the plot.
  - To specify the colors that will be used in both the project plan Gantt chart and the plot, choose View > Settings > Set Colors. (See Set Colors for Project Planner.)
  - Display Actions shows the dependent actions for each gate.
  - Show Project Item shows the “project” gate at the top of the hierarchy.
  - Show First Gate on Top determines whether the gate with the earliest start date will show at the top or bottom of the chart.
• **Auto Refresh** refreshes the plot automatically whenever changes have been made. If this option is cleared, you can click the **Redraw Plot** icon (✓) to refresh the display.

• **Keep Aspect Ratio** maintains the proportional relationship between the width and height of the plot image.

### Set Colors

To open the Set Colors window for the [Project Planner](http://mpc.reliasoft.com), choose **View > Settings > Set Colors**.

![Gate and Action Options](image)

- The **Gate and Action Options** apply to the Gantt chart (if viewing the plan), plan hierarchy and plot.

![Date Display](image)

- The **Date Display** options apply only to the Gantt chart and plot.

![Utilization Threshold Colors](image)

- The **Utilization Threshold Colors** apply only when using the Gantt chart to view team or facility utilization.
Project Planner Dashboards

You can use the flexible Synthesis Dashboard utility for presenting data from any Project Planner in the database.

To access this feature, open the planner and choose Project Planner > Tools > Dashboard.

As with any other Synthesis dashboard, you can use the Dashboard Viewer to select any of the layouts that have been predefined for this type of data. In a secure database, only users with the "Manage dashboard layouts" permission can use the Dashboard Manager to create or edit layouts.

Data Source Drop-Down List

When you are creating a dashboard layout based on project plan data, the drop-down list at the top of the Data Source Panel gives the following options:

- **Actions** returns data only from actions in the current plan.
- **Gates** returns data only from gates in the current plan.
- **Gates/Actions** returns data from both actions and gates.
Facilities returns data from the facilities assigned to actions.

Personnel returns data from the person responsible and/or team assigned to actions.

Each data source allows you to choose relevant fields from the record properties, summary panel and/or project plan hierarchy.

Note that all of the data fields used within a particular dashboard item must come from the same source. For example, you can’t combine fields from the “Actions” data source and the "Gates" data source in the same chart. If you want to create a chart that includes both actions and gates, use the fields from the "Gates/Actions" data source instead.

Examples for Different Field Types

The icon for each field indicates the data type: text, number or date. There are many possible ways to use these fields in your own customized dashboard layouts. The following simple examples demonstrate basic applications for each data type.

Example Using Counts

This pie chart uses the Count value for a text field to show the actions in the current project plan broken down by status. The argument determines the slices shown in the pie.

Tip: If you want to see both the quantity and the percentage, choose Design > Data Labels > Argument, Value And Percent.
Example Using Numbers
This bar chart uses the **Sum** values for two number fields to show the top 5 most costly actions in the current project plan, with comparison to the planned cost. The arguments determine how the bars are labeled, grouped and sorted.

Example Using Dates
This grid uses the **Exact Date** for two date fields to show a list of all actions in the current plan that are due in the current month. (To set the criteria that filters the records shown in the grid, right-click inside the chart and choose **Edit Filter**.)
Project Planner Ribbon

Project Planner Tab
The Project Planner tab in the Project Planner ribbon contains the following commands.

Project Planner

- **Refresh** updates the Project Planner hierarchy, if necessary. For example, if multiple users are accessing the same plan simultaneously, this will update the plan to reflect any changes made by other users.

- **Create Project Plan** opens the Create Project Plan window so you can start again from a blank plan, or import an existing plan from another project.

- **Delete Entire Plan** deletes every gate and removes every action from the plan.
Item Properties allows you to view or edit the Identifiers defined for the current plan. These identifiers can be used in the Synthesis Explorer to explore all of the different types of analyses (including project plans) in the current database.

**Clipboard**

- **Paste** pastes the contents of the Clipboard into the level below the selected gate (or on the same level of the selected action). If you want to paste gates only (without sub-gates and actions), use the Paste Without Actions command.

- **Cut** cuts the selected gate/action and any dependents to the Clipboard. You can paste this information into another Project Planner within the same database.

- **Copy** copies the selected gate/action and any dependents to the Clipboard. To copy everything, use the Copy Entire Plan command. You can paste this information into another Project Planner within the same database.

- **Delete** deletes the selected gate/action and any dependents.

**Gate**

- **Add Gate**
  - **Add Same Level Gate** adds a gate on the same level as the selected gate.
  - **Add Next Level Gate** adds a gate one level below the selected gate.
  - **Add Gate** adds a top-level gate to the end of the plan.
  - **Insert Gate** inserts a gate at the selected location.

- **Use Precedence**, when selected, automatically sets a new gate's precedent to the prior gate, which allows you to take advantage of expected timelines and ensure that there are no gaps between gates. If you clear this option, the default precedent will be "None."

- **Edit Gate** opens the Gate Properties window.

- **Promote** and **Demote** moves the selected gate to the next higher or lower level in the plan. An item can be demoted only if there is another item on the same level and above the selected item that it can be demoted under.
Chapter 14: Project Planner

Action

Add Action

- **Add Action** creates a new action resource.
- **Reuse Action Resources** allows you to select existing action(s) from the project that a) are not already used in the current plan and b) have dates that fit within the current gate. Specifically, the action’s start date can’t be before or more than a year after the gate’s start date. (See Select Resource window.)
- **Reuse FMEA Actions** allows you to select one or more XFMEA/RCM++/RBI system hierarchy items from the current project that have FMEAs. You can then select to use existing action(s) from those particular FMEAs in the project plan.

Edit Action opens action properties window. (See Actions in the Project Planner.)

Tools

Remove Gaps in Dates automatically assigns precedents to every applicable gate. This ensures that there will be no gaps in the planned or expected timelines, and it allows the expected dates for an activity to automatically shift in response to delays in prior activities. (See Project Planner Timelines.) You can choose to remove gaps in the Entire Plan or just for the gates that fall under the selected Branch.

Check Utilization opens the Check Utilization window so you can examine the utilizations for individual users and facilities across multiple actions (e.g., is a particular user assigned to too many actions at the same time, or is a particular test facility already booked for a particular timeframe).

Expand All and Collapse All expands or collapses the gates in the project plan hierarchy.

Dashboard

- **Dashboard Viewer** opens the Dashboard Viewer so you can view dashboards based on predefined layouts.
- **Dashboard Manager** opens the Dashboard Layout Manager so you can create, edit and delete the predefined layouts that will be available for any user to view for any project plan in the database.
Chapter 14: Project Planner

Excel Import/Export

- **Export View to Excel** exports the entire hierarchy and all displayed columns to an Excel sheet in a format that's suitable for presentation.
- **Import Hierarchy** and **Export Hierarchy** use an Excel format that's suitable for recreating the plan hierarchy in another project plan using information about precedents, outline level, etc.

**Copy Current View** copies the currently visible contents of the plan hierarchy or Gantt chart to the Clipboard as a graphic that can be pasted to other applications.

**View Tab**
The View tab in the **Project Planner** ribbon contains the following commands.

**View**

- **Color Code Deltas** applies highlight colors to any "Delta Values" columns for dates or durations that are displayed in the project plan hierarchy (e.g., the difference between the planned duration and the actual duration, or between the expected completion date and the actual completion date). Highlights are applied on a gradient from blue (ahead of schedule) to red (significant delay).

- **Fit All Columns** automatically resizes all columns to fit their own data.

**Settings**

- **Customize Columns** allows you to hide or display specific columns in the plan hierarchy.
- **Save View** and **Apply View** create or apply a view that stores your preferences for which columns to display in the plan hierarchy and which colors to use for gates, actions, timelines and utilizations. Each view is saved per computer/username.
- **Set Colors** allows you to **select the colors** to use for gates, actions, timelines and utilizations.

**Zoom**

- **Normal Zoom** sets the degree of magnification to 100%
Zoom In and Zoom Out increase or decrease the font size by 25% increments.

Custom Zoom allows you to specify the zoom percentage.
Chapter 15: ReliaSoft Plot Utilities

ReliaSoft applications offer a variety of plotting utilities for visual presentation of your analysis results. The following topics provide general information about built-in utilities, where the types of plots/charts available are predefined based on the analysis method and type of data you are working with. For more information about specific plot types, please consult the documentation for the relevant analysis.

Tip: In addition to the built-in plotting utilities described here, you can also create your own custom plots/charts in the Synthesis Workbooks and Synthesis Dashboards.

Basic Plot Features
This topic describes some basic features and capabilities that are available in most built-in plot utilities in ReliaSoft desktop applications (i.e., utilities where the types of plots available are predefined based on the analysis method and type of data you are working with). For information about creating your own custom charts in Synthesis Workbooks or Synthesis Dashboards, see Custom Charts or Dashboard Layout Designer.

Redraw Plots
A plot needs to be refreshed whenever its data source has been recalculated or when its inputs or settings have been modified. This ensures that the plot reflects the most current results. In most plot sheets, the control panel displays a status light that indicates whether the plot needs to be refreshed. A green light indicates that the data and the plot are in sync, while a red light indicates that the plot is out of sync with the latest analysis.

![Redraw Plots](image)

You can manually update a plot to reflect any changes by clicking the Redraw Plot icon in the plot’s control panel.

Alternatively, a plot can be refreshed automatically whenever changes have been made by selecting the Auto Refresh check box on the plot’s control panel.
Identify a Plot’s Source Analysis
For most plots, the control panel displays a blue link that displays the plot’s source analysis, as shown in the following example for a Weibull++ plot. You can click the link to open the folio and view the data set.

In some specialty plots (side-by-side plot, life comparison tool, etc.), you can select the source analysis for the plot by clicking the icon on the plot’s control panel or ribbon.

If the plot contains results from more than one analysis (e.g., overlay plots), the control panel includes a button that allows you to add or remove analyses from the plot, as shown in the example below for Weibull++ data sheets. In addition, you can click and drag the data sheets to the desired order.

Show or Hide Plot Items
When applicable, a plot may provide options for showing or hiding certain plot items such as data points, lines, probability scales, etc. The available options depend on the plot type and analysis. To view the options for the plot you are working with, choose Plot > Actions > Show/Hide Plot Items or right-click the plot and choose Show/Hide Items on the shortcut menu.

Select the check box for each item you want to appear in the plot, or clear the item’s check box to hide the item from view.

Scaling
When applicable, the plot control panel may display X and Y scaling boxes that show the minimum and maximum values for the x- and y-axes. You can clear the check boxes and click inside the fields to manually edit the values, or select the check boxes to have the application choose the appropriate values for the range, based on the data.
Zoom

The zoom function is available for plots that allow both X and Y scales to be adjusted. To zoom in or out of a plot, click inside the plot, point the mouse pointer over the area of interest, and then rotate the mouse wheel. Press ESC to return to the original scale.

For non-3D plots, you can also select a specific area to zoom in by holding the CTRL + SHIFT keys while clicking and dragging the mouse over the desired area. You can customize the color and line style of the zoom rectangle via the Zoom page of the Plot Setup.

Aspect Ratio

Plots are automatically resized whenever you resize the plot sheets. To maintain the proportional relationship between the width and height of the plot image, select the Keep Aspect Ratio check box on the plot’s control panel (as shown in the first example below). Clear the check box if you wish to stretch the dimensions of the plot graphic to fill the plot sheet (as shown in the second example below).
Show Coordinates
To show the coordinates for a location on a plot, press **SHIFT** and click the plot (no need to hold down the mouse button). To stop showing the coordinates and return the pointer to its normal mode, click the plot again.

To track the coordinates on a plot line, click the line. A crosshair shows the current location on the line. The crosshair will stay on the line and track the coordinates as you move the pointer.

When applicable, you can add a label that displays the coordinates of a location by pressing **CTRL + ALT** and then clicking the location you want labeled.
Add Custom Labels
When applicable, you can add a custom label to a plot by pressing CTRL and then clicking the plot. A label named "Default" will appear in the plot. Select the label to edit the text directly in the plot or double-click it to open the Edit Label window, which gives you the option to select a font style or format.

You can then move the label by clicking it and dragging its yellow handle to the desired location on the plot. (For more extensive annotations, see ReliaSoft Draw.)

Move Plot Items
If your plot has lines or points that are obscuring one or the other, you can move an item by pressing ALT and clicking the item. The Move Plot Item window will appear, giving you the option to move the selected item either to the front or back of the obscuring graphic.

Export or Copy Plot Graphics
You can save a plot graphic as a *.wmf, *.png, *.gif, or *.jpg file for use in other applications by clicking the Export Plot Graphic icon on the plot's control panel, or by choosing [Plot/3D Plot] > Actions > Export Plot Graphic if applicable.
Chapter 15: ReliaSoft Plot Utilities

In addition, you can save a plot graphic to the Clipboard by clicking the Copy Plot Graphic icon on the plot's control panel or by choosing [Plot/3D Plot] > Actions > Copy Plot Graphic if applicable.

When saving a 3D plot graphic to the Clipboard, the image will be in *.bmp format. For all other types of plots there are three choices: If you will be pasting copied plots into any one of the spreadsheets built in to ReliaSoft desktop applications (e.g., Synthesis Workbooks or General Spreadsheets), choose Metafile Optimized for Synthesis Spreadsheet. If you will be pasting them into external applications, choose Bitmap or Metafile Optimized for External Use.

**Export or Copy Plot Data**

You can export the data from a plot to the Clipboard so that you can paste it into another application. The information depends on the plot type and on the application you are using.

- In Weibull++, ALTA, RGA, BlockSim or RENO, choose Plot > Actions > Copy Plot Data.

- In XFMEA, RCM++, RBI or Lambda Predict, click the Copy Plot Data icon on the plot's control panel.

**Setting Confidence Bounds**

If your analysis includes calculations for confidence bounds, you can display the bounds in the associated plot by clicking the Confidence Bounds link on the plot control panel or by choosing Plot > Confidence Bounds > Confidence Bounds.

Depending on the type of data you are working with, you may be presented with different options for setting up the confidence bounds on the plot. (The ReliaWiki resource portal provides information on the background theory of confidence bounds at: [http://www.reliawiki.org/index.php/Confidence_Bounds](http://www.reliawiki.org/index.php/Confidence_Bounds).)

In the Confidence Bounds Setup window, you will need to:

1. Select which lines to show on the plot (e.g., two-sided, bottom one-sided, etc.)
2. Select which type of bounds to show on the plot. This may be the bounds on the time estimate (Type I), bounds on the reliability/unreliability estimate (Type II: Reliability); or
when applicable, bounds on functions such as number of failures, growth potential, etc. (Type II: Function).

3. Enter the percent confidence level.

To change the level of detail at which the bounds are plotted, adjust the Resolution slider. You can click and drag the slider or, for fine adjustments, click the slider and then use the arrow keys. The number of points plotted to create the lines is displayed next to the field name. Note that higher resolutions will take longer to plot.

To hide the confidence bounds, choose **Plot > Confidence Bounds > Hide Confidence Bounds**.
Chapter 15: ReliaSoft Plot Utilities

Setting Target Markers
When applicable, the plot control panel may display the **Target Reliability** link or the **Target MTBF/FI** link. Both give you the option to display markers for target values on the plot.

You can select to show a specified target value (displayed as a horizontal line), target time value (displayed as a vertical line), and/or insert a marker at the point where the two target values intersect. Below is an example for a plot that shows the target reliability.

Click the **Add** or **Remove** icon to manage the list of target values to be displayed. You can add up to 5 sets of target values/markers to a plot.
Plot Setup

The Plot Setup utility provides advanced settings for customizing the look of a plot to meet your needs and preferences. It allows you to: a) make changes and apply them to the current plot; b) save the changes and use them as default settings for all new plots; c) restore previously saved default values; or c) reset all settings to the shipped defaults.

**Tip:** You can quickly set some basic default settings for all new plots created in the current ReliaSoft desktop application via the Plots page of the Application Setup (File > Application Setup). The Application Setup also allows you to set some default analysis settings that may affect the appearance of plots (varies depending on the ReliaSoft desktop application).

To open the Plot Setup, click the **Plot Setup** icon on the plot’s control panel.

Alternatively, you can double-click the item on the plot you wish to edit (e.g., points, lines, etc.) and the Plot Setup will open and display automatically the options associated with that item.

To apply your changes to the current plot, click **OK**. To save your changes as the new defaults, or restore previously saved defaults, or reset to shipped defaults, click the **Defaults** button. (See **Plot Defaults Window** for more information.)

**What's Changed?** Starting in Version 2019, many plot options that had also been available from the Application Setup window are now available only with the Plot Setup utility.

**Importing and Exporting Plot Settings**

Starting in Version 2019, you have the option to import and export plot settings to an XML file. This allows you to define the settings for one plot and then use them in other plots.

- To export the current settings, click **Export**.
- To import settings from an XML file, click **Import**.

**Plot Elements**

The Plot Setup is divided into pages that contain related settings for particular plot elements. The available pages/elements will depend on the type of plot you are working with.
Chapter 15: ReliaSoft Plot Utilities

As an example, the following picture identifies some of the basic plot elements that can be configured via the Plot Setup.

![Plot Setup: Plot Titles Page](image)

**Plot Setup: Plot Titles Page**

The Plot Titles page allows you to define the main, header and footer titles used in the plot and to change the text font and color.

Select or clear the Show check box to determine whether the title will be shown on the plot. Click the Set Font button next to the corresponding input box to open the Font window, which allows you to set the font type, style, size, color and text orientation.

Each asterisk (*) represents the default title text. For the main title, this is defined on the Titles Text page of the Plot Defaults window. If you type new text in an input box, either alone or in addition to the asterisk, the text you type will be displayed on the plot. For example, if you add *(Helicopter)* to the Main Title field, the default main title will be displayed, followed by "(Helicopter)." The changes you make will be applied regardless of plot type, so the main title of a Failure Rate vs Time plot would then be "Failure Rate vs Time (Helicopter)" and the main title of a System Failures plot would be "System Failures (Helicopter)." (This assumes that you have not changed the default main titles from the ones shipped with the application.)

You can use the ENTER key to add additional lines to the header title and the footer title.
To add an image file to the header title or footer title, click **Set Image** then browse for the file you want to include. Click **Open**. (You can select an image that uses one of the following formats: *.bmp, *.gif, *.jpg, *.jpeg, or *.ico.) The selected image appears next to the **Set Image** button. The image will also appear at the left side of the header or footer text. To remove the image, click **Clear Image**.

**Plot Setup: Axis Titles/Labels Page**

The Axis Titles/Labels page allows you to define the information used with the x-axis and y-axis, including the titles, axis labels and the numbers displayed in the axis labels. This page is not available when you are working with a pie chart.

The options on this page will vary depending on the plot style you are working with.

- **Axis Titles**
  - Select or clear the **Show** check box to determine whether the title will be shown on the plot. Click the **Set Font** button next to the corresponding input box to open the Font window, which allows you to set the font type, style, size, color and orientation of the text.

  Each asterisk (*) represents the default title text. If you type new text in an input box, either alone or in addition to the asterisk, the text you type will be displayed on the plot. For example, if you add **(Hours)** to the **Y-Axis Title** field, the default y-Axis title will be displayed, followed by "(Hours)." The changes you make will be applied regardless of plot type, so the y-axis title of a Static Reliability Importance plot would then be "Static Reliability Importance (Hours)" and the y-axis title of a Throughput vs. Time plot would be "Throughput(t) (Hours)." (This assumes that you have not changed the default axis titles from the ones shipped with the application.)

- **Axis Labels**
  - **Axis Labels** options, when selected, displays the numerical labels for the x-axis and/or the y-axis in the plot.
  
  If available for the plot type, click the **Custom Labels** button next to the corresponding option to open the Custom Axis Labels window, which allows you to add user-defined numerical labels to the x-axis or y-axis of the plot. Note that values outside the plot’s display range are accepted but will not be shown.

  Click the **Set Font** button next to the corresponding option to open the Font window, which allows you to set the font type, style, size, color and orientation of the text.
• **Numbers in Axis Labels**

Use the options in this area to configure the display of numerical values shown on the axes. The available options depend on the setting of the **Use Significant Figure Formatting** check box.

If selected:

Use the significant figures fields to set the maximum number of digits that are displayed (e.g., the number 1.23456789 displays as 1 with 1 significant figure while it displays as 1.23457 with 6 significant figures). If the value is large and contains more significant figures than the set value, then the number is simply rounded to the nearest whole number.

If not selected:

The mathematical precision sets the number of decimal places that a number will display. The scientific tolerance sets the point at which the numbers will be converted to normalized scientific notation. For example, setting the scientific tolerance to 3 means that all numbers with a value greater than 1,000 will be converted to normalized scientific notation (e.g., 1.0E+3).

*Note:* When you are working with a bar chart, the Numbers in Axis Labels area will contain settings for only the axis representing the dependent variable. This is affected by the orientation of your bar chart; if you are using vertical bars, this area will contain settings for the y-axis, and if you are using horizontal bars, it will contain settings for the x-axis. It is important to be aware that the settings for one axis will not transfer to the other axis when you change the bar orientation. You will need to return to this page and reenter the settings.

---

**Plot Setup: Plot Labels Page**

The Plot Labels page allows you to customize the labels for items (e.g., bars, slices, points) shown in the plot as well as for custom labels used in the plot.

The options on this page will vary depending on the plot style you are working with. All available options are presented below.

• **Bar Labels** (available only for bar charts)

  • To display the y-axis value of each bar with the bar, select the **Show Bar Labels** check box. (You can set the bar style using the **Bar Orientation** field on the Bars page of the Plot Setup.)
• **Show Bar Labels Even if Zero** if selected, bars with a y-axis value of 0 will be shown with a label of "0." The number of decimal places in the label will conform to the y-axis math precision value specified on the [Axis Titles/Labels page](#).

• **Point Labels** (available only for line plots)
  
  - To display the coordinates for each point at the lower right of the point, select the **Show Point Coordinates** check box. If this option is not selected, you can still display the coordinates for each point in a pop-up box by pointing to the point.
  
  - To display the point label in the same color as the border of the point itself, select the **Use Point Border Color** check box.
  
  - If there are overlapping points, select the **Show Point Multiplier** check box to display the number of points to the right of the point.

• **Slice Labels** (available only for pie charts)
  
  - To label the slices of the pie chart according to the components they represent, select the **Show Slice Labels** check box.
  
  - To label the slices of the pie chart with the percentage of the whole that they represent, select the **Show Slice Size** check box.

• **Custom Plot Labels** allows you to control the appearance of custom plot labels. You can add custom labels to your plot by pressing **CTRL** and clicking the plot.
  
  - **Delete Labels** deletes all custom labels on the plot.
  
  - **Reset Labels** immediately resets all custom labels on the plot to use the settings specified via the **Set Font** button. This allows you to apply the settings to existing custom labels rather than just new labels created after changing the settings.

• **Bar Label Position** (available only for bar charts) allows you to specify whether you want the bar labels located within the bars or outside of the bars.

For all labels, you can click the **Set Font** button in the section to open the Font window, which allows you to set the font type, style, size and color for labels of that type.
Plot Setup: Legend Page

The Legend page allows you to customize the display of the legend on the current plot.

The options on this page will vary depending on the plot style you are working with. All available options are presented below.

- To display the legend on the plot, select the **Show Legend** check box.

  - To include on the legend a color definition for each point/line/bar/slice shown in the plot, select the **Show Plot Items** check box.

  - To include lines above and below the legend and the user information, select the **Show Legend Border** check box. Use the options to the right to modify the appearance of the border. To change the color of the border, click the **Color** box to the left of the **Thickness** box. Adjust the thickness of the border by entering a positive integer in the input box. Change the style of the line (e.g., solid, dashed, etc.) by clicking the **Line Style** box to the right of the **Color** box.

  - To display the text of the legend in the same color as the lines, points, bars and/or slices on the plot, select the **Use Item Color** check box. If not selected, the text will be red.

  - **Show Analysis Information** if selected, the legend will display information about the analysis shown on the plot, including the data source and/or the settings used in the calculation, if applicable.

  - To display the plot description (including the plot type) on the plot, select the **Show Plot Description** check box.

  - To show the user display name, company and the date and time the plot was generated on the plot, select the **Show User Information** check box. (You set the display name and company using the **User Login and Contact Information Window**.)

- The legend area allows you to specify the amount of space used for the legend.

  - **Fixed Legend Width** if selected, the legend will remain the same size regardless of the information it contains. You can set the percentage of the canvas width that the legend will occupy.

  - **Maximum Legend Width** if selected, the legend will automatically recalculate its width based on the information it contains. You can set the maximum percentage of the canvas area that the legend will occupy.
Click the **Set Font** button next to the corresponding option to open the Font window, which allows you to set the font type, style, size and color of the text.

- For bar and pie charts in BlockSim and RENO only, **Color Spectrum** allows you to set the color limits for the plot.
  - You can set both lower and upper color limits by dragging the markers on the scale between 0% and 100%.
  - **Show all values (0-100%) in legend** if selected, the legend will show the full range of values; if not selected, the legend will show only the values between the upper and lower limits that you have specified.
- The preview shows how the specified settings will appear in the legend.

**Plot Setup: Canvas Page**

The Canvas page allows you to customize the color, style and thickness of the plot borders and title lines, along with the appearance of the rest of the plot sheet.

- **Plot Canvas and Area**
  - **Canvas Back Color** allows you to choose the color for the area outside the plot (i.e., the area containing the titles, labels, legend, etc.).
  - **Canvas Border** allows you to determine if the border around the plot field will be displayed and, if so, to set the color.
  - **Plot Area Back Color** allows you to choose the color for the plot background.
- **Plot Area Border Lines** allows you to hide or show each of the specified lines, as well as to choose a color, a thickness and a style for each. The borders referred to in this area are the borders of the plot area itself (i.e., the bottom border is the x-axis, etc.).
  - To show or hide a line, select or clear the associated check box.
  - To change the color of any of the lines, click the **Color** field. The drop-down list that appears allows you to choose from custom colors, web-safe colors or the colors used in the current Windows system settings. You can add colors to the Custom page by right-clicking one of the color boxes in the bottom two rows.
  - You can adjust the thickness of a line by entering a positive integer in the input box. A value of 1 will draw the thinnest possible line and other values such as 2, 3, etc. will draw thicker lines. Note that the size of the thinnest possible line is dependent upon your screen resolution.
In addition, you can change the style of each line by clicking the **Line Style** box to the right of the **Thickness** box. A list providing line style options (e.g., solid, dashed, etc.) will appear. Choose the line style you want and it will appear in the **Line Style** box.

To highlight each object (i.e., point, line, bar or slice) on the plot as you point to it, select the **Highlight Selected Plot Item** check box. When an object is active, you can click it to open the Plot Setup window and edit the properties specific to that object. The remaining options in this area are available only if this option is selected.

- **Fill Color** allows you to specify a foreground color to be used on the highlighted active object.
- **Back Color** allows you to specify a background color to be used on the highlighted active object. This color is not used if the selected fill style does not use a background color (i.e., solid or transparent fill style).
- **Fill Style** allows you to select a style of hatching to be used on the highlighted active object.

**Plot Setup: Grid Page**

The Grid page allows you to customize the color, style and thickness of the grid lines and to set the number of axis divisions used. This page is not available when you are working with a pie chart.

The options on this page will vary depending on the plot style you are working with. All available options are presented below.

- **Axis Division Lines** allows you to hide or show each of the axis division lines, as well as to choose a color, a thickness and a style for each.
  - To show or hide a line, select or clear the associated check box.
  - To change the color of any of the grid lines, click the **Color** box. The drop-down that appears allows you to choose from custom colors, web-safe colors or the colors used in the current Windows system settings. You can add colors to the Custom page by right-clicking one of the color boxes in the bottom two rows.
  - You can adjust the thickness of a grid line by entering a positive integer in the input box. A value of 1 will draw the thinnest possible line and other values such as 2, 3, etc. will draw thicker lines. Note that the size of the thinnest possible line is dependent upon your screen resolution.
• In addition, you can change the style of each line by clicking the Line Style box to the right of the thickness box. A list providing line style options (e.g., solid, dashed, etc.) will appear. Choose the line style you want and it will appear in the Line Style box.

• **Number of Axis Divisions** allows you to set the number of major and minor divisions for each axis.

---

**Note:** When you are working with a bar chart, the Grid page will contain settings for only the axis representing the dependent variable. This is affected by the orientation of your bar chart; if you are using vertical bars, this area will contain settings for the y-axis, and if you are using horizontal bars, it will contain settings for the x-axis. It is important to be aware that the settings for one axis will not transfer to the other axis when you change the bar orientation. You will need to return to this page and reenter the settings.

---

**Plot Setup: Bars Page**

The Bars page allows you to customize the appearance of the bars in the plot. This page is available only when you are working with a bar chart.

• **Bar Border Lines** allows you to hide or show the border line for the bars, as well as to select a color, a thickness and a style for the border.

• **Bar Orientation** allows you to select how you want the plot laid out. You can choose to use vertical bars or horizontal bars.

---

**Plot Setup: Slices Page**

The Slices page allows you to customize the appearance of the slices in the plot. This page is available only when you are working with a pie chart or tableau plot.

• **Pie Settings**
  
  • **Rank** if selected, you can specify the ranking of the slices that you want to view. For example, entering 5 will cause only the five largest slices to be shown in the plot.

  • **Threshold** if selected, you can specify a minimum size (in percentage of the whole) for the slices that you want to view. For example, entering 0.1 will cause only slices accounting for ten percent or more of the whole to be shown in the plot.
• **Show Remaining Slices as Other** if selected, all remaining slices that do not meet the rank or threshold criterion specified will be shown in the plot as "other." This option is available only if you have specified a rank, a threshold or both.

• **Other Slice Color** allows you to choose the color used to represent "other" slices. This option is available only if you have selected the **Show Remaining Slices as Other** option.

• **Slice Border Lines** allows you to hide or show the border line for the slices, as well as to select a color, a thickness and a style for the border.

• **Chart Type** allows you to select how you want the plot laid out. You can choose to use an area chart (blocks), cake chart (layers) or pie chart (wedges).

**Plot Setup: Plot Items Page**

The Plot Items page allows you to specify details of the appearance of the points, lines, bars and/or slices on the plot.

The options available on this page will vary depending on the plot style that you are currently working with.

The following options are available for all plot styles:

• **Choose an Item to Configure** allows you to choose which plot element the settings on this page apply to.

• **Show** allows you to select whether or not the plot element you currently chose to configure will be shown on the plot. Depending on the plot style that you are currently working with, you may select to show the bars, slice, line and/or points. This option is not available for all plots.

For bar charts and pie charts, the following option applies.

• **Area Fill Color and Style** allows you to specify the appearance of the bar or slice representing the selected item. To change the color of the bar or slice, click the **Color** box. You can select a fill style from the drop-down list.

For line plots, the following options apply:

• **Line Settings** allows you to specify the appearance of the line representing the selected item. To change the color of the line, click the **Color** box. You can adjust the thickness of a grid line by entering a positive integer in the input box. Adjust the thickness of the line by entering a positive integer in the input box. Change the style of each line such as solid, dashed, etc., by clicking the **Line Style** box.
• **Point Settings**

  • **Color, Shape, Size and Fill** allows you to specify the appearance of the point body. To change the color of the point, click the Color box. You can select a point shape from the drop-down list, select the size of the point (with 1 being the smallest point) and select a fill style from the drop-down list.

  • **Border Color, Thickness and Style** allows you to modify the appearance of the border of the points. To change the color of the border, click the Color box. Adjust the thickness of the border by entering a positive integer in the input box. Change the style of each line such as solid, dashed, etc., by clicking the Line Style box.

    Certain point shapes are drawn using only the border color. These include minus, pike, plus and x-cross.

---

**Plot Setup: Offsets Page**

The Offsets page allows you to specify the distance of various components from the edge of the plot area.

*Automatically calculate positions from edges of plot sheet* if selected, automatically calculates the offsets for maximum plot display and readability. If not selected, you can manually specify the offsets of the plot's left, right, top and bottom edges; the offset of the legend from the right edge of the plot area; and the offset of the main, x-axis, y-axis, header and footer titles. The offset values are set as a percentage of the canvas area.

For your reference, the following picture shows which plot elements are affected by each of the offset settings. (Note that the plot is generated from BlockSim, but the settings are the same for all ReliaSoft desktop applications.)
Plot Setup: Zoom Page
The Zoom page allows you to customize the options used when zooming in on a plot by using the mouse wheel. Zooming works only for plots with scales. For more information, see Basic Plot Features.

Allow Zoom if selected, allows the plot zoom feature to be used.

- **Factor** use this option to set the amount of the magnification each time you use the mouse wheel on the plot. The lower the number, the greater the increase in the magnification.

- Use the **Border Color, Thickness and Style** option to set the appearance of the zoom box. To change the color of the border, click the Color box to the left of the Thickness box. Adjust the thickness of the border by entering a positive integer in the input box. Change the style of the line (e.g., solid, dashed, etc.) by clicking the Line Style box to the right of the Color box.

- **Fill Style** allows you to select a style of hatching to be used on the zoom box.
• **Fill Color** allows you to specify a foreground color to be used on the zoom box. This color is not used if the selected fill style does not use a background color (i.e., solid or transparent fill style).

• **Background color** allows you to specify a background color to be used on the zoom box. This color is not used if the selected fill style does not use a background color (i.e., solid or transparent fill style).

**Plot Defaults Window**

Each time you open the Plot Setup window, the changes that you make will apply only to the current plot unless you specify otherwise. To specify settings to be used as defaults for all subsequent plots or to re-apply default settings to the current plot, click the **Defaults** button to open the Plot Defaults window.

The Plot Defaults window gives you the flexibility to set the default settings for the three main areas of a plot: the plot titles, the plot item settings and the general display areas. You can choose to separately save, load or restore the default settings of each main area or you can set the default settings for all areas at once.

The Plot Defaults window consists of nine pages:

• **All Defaults page.** This page controls the settings for all the other plot setup pages. When you click a button on this page, the effects apply to all pages. This allows you to quickly make changes without having to individually change each of the other pages.

• **Titles Text page.** This page allows you to customize default plot titles for each plot type without having to view a plot of that type. For example, you can display a Failure Rate vs. Time plot while changing the titles for a System Failures plot.

• **Plot Items Display page.** This page allows you to customize the details of the default appearance of the lines, points, bars and/or slices of every plot type without having to individually change each plot.

• **General page.** This page controls the settings for the five section pages below it. When you click a button on this page, the effects apply to the Titles Display, Labels, Legend, Canvas and Grid and Offsets pages.

• The Titles Display, Labels, Legend, Canvas and Grid and Offsets pages control the settings of their individual sections. When you click a button on one of these pages, the effects apply only to that specific section.
Three Defaults buttons appear on every page of the Plot Defaults window. The scope of their effects differs slightly depending on the page you are working with.

- **Save Defaults** saves settings for use as the default settings for all subsequent plots. This will overwrite the previous default settings.

- **Load Defaults** enters the saved default values for the settings. You can then click **OK** in the Plot Setup window to apply the default settings to the current plot. This is an easy way to undo changes you have made in the Plot Setup window and re-apply default settings.

- **Restore Defaults** clears the saved default settings and restores the default values that are shipped with the application.

The scope of the Defaults buttons’ effects changes as follows:

- For the Titles and Plot Item Display pages, these buttons save/load/restore the settings specified on the current page.

- For the Titles Display, Labels, Legend, Canvas and Grid and Offsets pages, these buttons save/load/restore all current settings on the corresponding page(s) of the Plot Setup window (e.g., clicking **Save Defaults** on the Canvas and grid page of the Plot Defaults window will save the settings from the Canvas, Grid, Bars and Slices pages).

  **Note:** The settings affected by the Defaults buttons on the Titles Display, Labels, Legend, Canvas and Grid and Offsets pages include all settings relevant to the section, regardless of whether they are currently available or not. For example, if you have previously specified settings for a pie chart and are now specifying settings for a bar chart, the settings that you created for the pie chart will be saved as defaults when you click **Save Defaults** and will be applied to subsequent pie charts.

- For the All Defaults and General pages, clicking these buttons is equivalent to clicking them on all of the subordinate pages.

**Plot Defaults Window: Titles Text Page**

The Titles Text page of the Plot Defaults window allows you to customize default plot titles for each plot type.

- **Titles** allows you to select the plot type that you are changing the default titles for.
- **Main** allows you to type the default main title for the plot.
- **X-Axis** allows you to type the default title for the x-axis for the plot.
- **Y-Axis** allows you to type the default title for the y-axis for the plot.
Plot Defaults Window: Plot Items Display Page

**Plot Item Type** allows you to select the style of plot that you want to specify default settings for. The settings you specify are retained in the background when you choose a new item in this list, so you can specify settings for each type and save all of them, if desired.

The options on this page are identical to those on the Plot Items page of the Plot Setup window for the corresponding plot style.

ReliaSoft Draw

ReliaSoft Draw (RS Draw) is a metafile graphics editor that allows you to annotate and customize your plots. With RS Draw, you can insert text, draw an object, mark the coordinates of a particular point or paste another picture into your plot. You can also re-arrange the objects in your plot by selecting and moving them to the positions you desire. In addition, you can save the annotated plot in one of the following formats: *.rdc, *.jpg, *.gif, *.png or *.wmf.

RS Draw is available by clicking the icon on the plot control panel.

See [ReliaSoft Draw Help](#) for information on the features available in ReliaSoft Draw. If you do not currently have Internet access, this link will not work, but you can browse to the local copy of the help file by opening the Help\RSDraw\rsdraw.htm file in your ReliaSoft application directory.

Overlay Plots

Available in Weibull++, ALTA, BlockSim and RGA, overlay plots give you the ability to display results from multiple analyses in a single plot. This allows you to easily compare different data sets, analysis methods or distributions. For example, you may wish to show the reliability plots of two product designs in the same plot or compare a simulation-based data set with actual data obtained from fielded products.

Creating an Overlay Plot

Before using an overlay plot, you must first analyze the data sets (or simulate the diagrams) you wish to include in the plot. Then to add an overlay plot to the project, choose **Home > Insert > Overlay Plot**.
In the window that appears, select the data sheets/diagrams you want to include in the plot (up to a maximum of 20) and click OK to create the plot sheet. The plot sheet will be saved automatically under the Multiplots heading in the current project explorer.

**Tip:** In Weibull++, ALTA and RGA, you can add additional plot sheets to a folio by choosing [Life Data/Life-Stress Data/Growth Data] > Folio Sheets > Insert Additional Plot. The additional sheets can function as overlay plots to display results from multiple data sheets in the current folio on a single plot.

### Adding or Removing Analyses

To add or remove analyses from an overlay plot, click the button on the control panel, as shown in the example below for data sheets.

If you later delete an analysis that is referenced by the plot, the plot will remain available and will continue to show the results of the analysis until you redraw the plot (by clicking the Redraw Plot icon on the control panel).

Note that importing or exporting an overlay plot will automatically import/export the associated source analyses. (See Importing/Exporting Project Items or Resources.)

### Available Plot Types for Overlay Plots

The available plots depend on the analysis or type of data you are working with.

**For Weibull++/ALTA**

Probability plots, contour plots and ALTA stress plots are available only if the data sets have been calculated with the same distribution. This is because the scales or axes in those types of plots vary for different types of distributions.

In DOE design folios, plots that are intended to be viewed as singular plots will not be available for inclusion in overlay plots. These include the comparison chart, Pareto chart, interaction matrix, term effect plot, cube plot, residual histogram, residual autocorrelation plot, and Box-Cox transformation plot. In addition, only plots that are common to the type(s) of design you have selected will be available in the overlay plot. If a plot type is unavailable for any of the included design types, it will be unavailable in the overlay plot.
For BlockSim

You can compare data from analytical and simulation diagrams in the same plot, but keep in mind that analytical diagrams always show the reliability over time (does not account for repairs) while simulation diagrams always show the point reliability over time (may include repairs).

For RGA

Only plots that are common to the analyses you have selected will be available in the overlay plot. If a plot type is unavailable for any of the included analyses, it will be unavailable in the overlay plot. It is possible for the selected analyses to not have any common plot types.

Side-By-Side Plots

Available in Weibull++, ALTA and RGA, side-by-side plots give you the ability to display different plots for a single data set all in a single window for easy comparison.

To add a side-by-side plot to a project, choose **Home > Insert > Side-by-Side Plot**.

In the window that appears, select the analysis/data sheet you want to plot and click **OK** to create the plot sheet.

To view a single plot in greater detail, double-click the plot. You can double-click the plot again to return to the side-by-side view.

Choosing Plots to Display

The control panel provides options for selecting the type of plots to display. For most analyses, the **Vary** area will be available, which contains two options:

- The vary **Plot Types** option allows you to create different plots for the same data set. For example, you might wish to display both the Reliability vs. Time plot and the Failure Rate vs. Time plot of the data set.

- The vary **Distributions** or **Models** option allows you to compare how different distributions or models fit a particular data set. For example, you might wish to display a reliability plot for different life distributions, as shown next.
3D Plots

Available in Weibull++, ALTA and for two-way sensitivity analysis in RENO, 3D plots give you the ability to graph functions with three variables, such as the reliability at a given time and stress level. In addition, Weibull++ and ALTA offer the option to create 3D overlay plots, which are similar to regular overlay plots but displayed in 3D space.

Creating 3D Plots

Before creating a plot, you must first analyze the data sets (or in RENO, you must first run the simulation for the two-way sensitivity analysis).

To add 3D plots to a project, right-click the Multiplots folder in the current project explorer and choose the type of plot:

- 3D Plot
- 3D Overlay Plot (Weibull++ and ALTA only)

In both cases, the plots are automatically saved and stored in the Multiplots heading in the current project explorer.
Defining the X, Y and Z Axes
The control panel in the 3D plot folio contains basic settings for defining the X, Y and Z axes. (For advanced customization options, see 3D Plot Setup.)

The **Begin** and **End** fields, as shown next, display the minimum and maximum values for the axes. You can click inside these fields to manually edit the values, or select the **Autoscale** check box to have the application automatically choose the appropriate values for the range.

Whenever applicable, the **Parameter** fields will be displayed, as shown in the example above. Click these fields to change which parameter lies on which axis. The name of the parameter associated with the axis will be displayed next to that axis’s label.

Rotating 3D Plots
The XYZ indicator shown at the lower-left of a 3D plot represents the plot’s horizontal rotation (**azimuth**) and vertical rotation (**elevation**) in 3D space. Any changes to a plot’s rotation are reflected in the XYZ indicator, helping you to visualize the plot’s orientation on the screen.

There are several ways to rotate or manipulate a 3D plot, using the mouse, keyboard shortcuts or the view cube.
### Using a Mouse and Keyboard Shortcuts

<table>
<thead>
<tr>
<th>If you want to</th>
<th>Use a mouse</th>
<th>Use keyboard shortcuts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate the plot or change the viewing angle</td>
<td>Click anywhere in the plot area, and then press and hold the left mouse button while moving the pointer.</td>
<td>Press the Up, Down, Left or Right arrow keys.</td>
</tr>
<tr>
<td>Move the plot without changing its rotation</td>
<td>Click anywhere in the plot area, and then press and hold the right mouse button while moving the pointer.</td>
<td>Hold the SHIFT key while pressing the Up, Down, Left, or Right arrow keys.</td>
</tr>
<tr>
<td>Zoom in or out</td>
<td>Rotate the mouse wheel. Alternatively, you can choose 3D Plot &gt; Display &gt; Zoom In or Zoom out.</td>
<td>Press the W or S keys.</td>
</tr>
<tr>
<td>Automatically center the plot on canvas</td>
<td>Choose 3D Plot &gt; Display &gt; Center on Canvas.</td>
<td>N/A</td>
</tr>
</tbody>
</table>

### Using the View Cube

The View Cube helps you to easily orient a 3D plot using predefined viewpoints. The cube is located at the lower-right of the 3D plot.

The letters on the cube represent a particular viewpoint. For instance, clicking the "F" side of the cube orients the plot such that you are looking directly at the plot’s front side (e.g., Y and Z plane).

- Front
You can rotate the cube in the same way you would rotate any 3D plot (i.e., press and hold the left mouse button while moving the pointer anywhere on the screen; or press the Up, Down, Left or Right arrow keys on your keyboard).

**3D Plot Setup**

The 3D Plot Setup allows you to customize the look of 3D plots to meet your needs. It gives you full control over the settings used for individual 3D plots and the default settings for all new 3D plots.

To access the 3D Plot Setup, choose **3D Plot > Actions > Plot Setup**.

Alternatively, you can double-click the item on the plot you wish to edit. This will automatically open the 3D Plot Setup and display the options associated with that item. The available options in the 3D Plot Setup will vary, depending on the plot type. You can move the mouse pointer over an option to display its definition.
To apply your changes to the current plot only, click **OK**.

To save your changes and use them as the default setting for all new 3D plots, click the **Save as Default** button. This will overwrite the previous default settings.

To restore the previously saved defaults, click the **Load Defaults** button. This is an easy way to undo changes you have made in the 3D Plot Setup and re-apply default settings.

To reset all settings to the default values that were shipped with the application, click the **Reset** button.
Chapter 16: Synthesis Workbooks

The Synthesis Workbook is a custom reporting tool that is built directly into many ReliaSoft applications, including Weibull++/ALTA, RGA and BlockSim. It combines two reporting modules – Spreadsheets and Word Processing – into the same flexible interface, thereby replacing the Analysis Workbook and Word Report Template functionality from prior versions.

**Tip:** If you convert a project from Version 10 or earlier, any Analysis Workbooks and Word Report Templates will be automatically converted to Synthesis Workbooks.

If your organization has implemented an SEP web portal for an enterprise database, you can choose to publish selected Synthesis Workbook reports to be accessed from any web-enabled device. See [Publishing to SEP](#).

### Synthesis Workbook Wizard

To add a new Synthesis Workbook in an existing project, choose **Home > Insert > Synthesis Workbook**.

This launches the wizard, which gives you the opportunity to assign the first associated data source and/or select a saved template, if desired. (Note that the examples shown here are from Weibull++ but similar functionality is available in ALTA, RGA and BlockSim.)

**If you prefer to start with a blank report:**

Simply click **OK** and then click **Yes** when prompted to confirm that you want to create the report without associating a data source. (You will be able to associate data source(s) later if you wish.)

**If you want to assign the first data source:**

Click **Select** and choose one of the available analyses (i.e., a data sheet in Weibull++/ALTA and RGA, or a diagram in BlockSim). When you return to the wizard, click **OK** to create the report.

Note that you will be able to associate more data sources after the report is created, and change any of those assignments at any time. (See [Associated Data Sources](#).)
If you want to use a saved template:

Click Spreadsheet or Word Processing. Select the Based on Existing Template check box and then choose a template from either the Standard tab (templates that are installed with the software) or the User tab (templates you have saved). Then click OK to create the report. (See Synthesis Workbook Templates.)

Associated Data Sources

In Synthesis Workbooks in Weibull++/ALTA, RGA and BlockSim, you have the option to associate multiple data sources that can be used for any function that obtains data or results from an existing analysis. (To obtain results from a DOE analysis in Weibull++/ALTA, see DOE Analysis Report.)

When you create this type of function, you will have the option to use an index to specify which of the currently assigned default data sources will be used. For example, if you want to compare the reliability values calculated from two different analyses, you can use

=RELIABILITY(Default1, 1000) to get the result from the first default data source, and

=RELIABILITY(Default2, 1000) to get the result from the second default data source.

Although you will be prompted to associate the first data source when you create the report, you can add or change associated data sources for an existing report at any time.

Associating Data Sources

For Synthesis Workbooks, the Information panel (located on the right side of the window) shows which analyses are currently assigned as default data sources. To have the panel always display, click the pushpin icon into the vertical position.
To add or remove analyses, choose **Home > Report > Associate Data Sources** or click the icon in the Information panel.

The following picture shows the windows for Weibull++. Similar functionality is available in ALTA, RGA and BlockSim.

Note that:

- In **Weibull++/ALTA**, you can select any data sheet from a folio that contains a life data analysis:
  - Life data folio
  - Life-stress data folio
Chapter 16: Synthesis Workbooks

- Non-parametric LDA folio
- Warranty analysis folio
- Degradation analysis folios (the results shown in the report will be based on the analysis of the extrapolated failure/suspension times)

- In RGA, you can select any data sheet in a growth data folio.
- In BlockSim, you can select any analytical diagram, simulation diagram or phase diagram. The function results can either be based directly on the analyzed/simulated diagram, or based on a model that has been fitted to the diagram. You specify this preference on the diagram’s control panel, using the Report folio model drop-down list on the Analysis Settings page.

Linking Multiple Data Sources with Different Time Units

In BlockSim, function results that are time-based (e.g., downtime, time to event, etc.) will be returned in terms of the System Base Unit (SBU) for the repository. However, in Weibull++/ALTA or RGA, each function result is returned in the units used by its data source. If you wish to compare the results from multiple data sources that use different time units, there are two possible scenarios:

- Convert the data in the original data source. For example, if one data set is in "hours" and another is in "days," you could use the Change Units feature to automatically convert the data in the first analysis from "hours" to "days."

  **Tip:** If you want to keep the original analysis unchanged, you could create a copy of the data sheet, then convert the duplicate data sheet to use the new units.

- Manually adjust the functions so they return results in the same units. For example, if the data set is in "days" and you want the results to display the B10 life in "hours," you could adjust the function by adding a conversion ratio. For example, if 1 day is equivalent to 24 hours, you could edit the function as follows:
  \[(\text{TIMEATPF}("\text{Weibull!Week!Data1", 0.1)}) \times (24))\].

Synthesis Workbook Templates

In Synthesis Workbooks, saved templates make it easy to reuse the same report multiple times — in different analysis projects and with different data sets.
Note: For DOE analyses, instead of saved templates for the entire workbook, you can use saved profiles in the DOE Report Generator.

In addition to the Standard templates that are installed with the software, you can also create your own User templates that are saved from any existing report. Note that the templates are module-specific (i.e., compatible with either the spreadsheet module or the word processing module).

Saving Your Own Templates
It is easy to create a template from any Synthesis Workbook that is currently open.

Select either the spreadsheet or the word processing module, then choose Document > Save Template.

You can name and store the custom templates however you wish. To share a template with other users, you can simply send them a copy of the file, or you can save the file in a shared network location that multiple users can access.

Using a Template
You can select a template when you create a new Synthesis Workbook. (See Synthesis Workbook Wizard.)

Alternatively, you can use the steps below to apply or change the template for an existing workbook at any time.

IMPORTANT: This will replace any existing content in the current module, and the change can’t be undone.

1. Select either the spreadsheet or word processing module and then choose Document > Open Template.

2. Select a template from either tab then click OK to apply the template to the new or existing report.
   - The Standard tab displays the templates that are installed with the software and stored in the applicable sub-folder under C:\Users\Public\Documents\ReliaSoft\Templates.
• The **User** tab displays custom templates that were saved from an existing report. These can be stored in any location that is convenient for you. If the custom template you need is not displayed, click the **Open** icon to browse for the desired template and add it to the list.

![Open Template](image)

### Spreadsheet Module
The spreadsheet module in Synthesis Workbooks provides functionality similar to Microsoft Excel (with built-in functions and complete in-cell formula support), and it can be used to integrate data and/or results from multiple analyses at the same time.

### Send to Excel
To export all sheets in the spreadsheet module to a Microsoft Excel file, choose **Home > Report > Send to Excel**.

### Inserting Functions
- To build and insert functions that utilize a referenced analysis (data source), see **Function Wizard - Data Sources**.
- To add math, date, logic and other functions, see **Function Wizard - Formulas**.

### Showing Formulas
To display the formulas instead of the calculated results in the worksheet cells, choose **Formulas > Formula Auditing > Show Formulas**.
You can toggle the formula display on and off.

Recalculate Formulas

By default, the spreadsheet automatically recalculates all formulas whenever you open the workbook or when the cells that a formula depends on have changed. However, if your spreadsheet contains a large number of formulas, the recalculation process may take more time and every change may require you to wait several seconds or minutes for the application to recalculate all values. In this case, you can control when calculation occurs by changing the setting to manual calculations.

To use manual calculations, choose Formulas > Calculation > Calculation Options, and then choose the Manual option. To change the settings back to automatic calculations, choose the Automatic option.

To recalculate all formulas when in Manual mode, choose Formulas > Calculate > Calculate Now.

The Calculate Now command can also be used to refresh the spreadsheet. A spreadsheet needs to be refreshed whenever its referenced data source(s) has been recalculated. This ensures that the spreadsheet reflects the most current results.

Adding Custom Charts

To create your own custom chart, first select the cells that contain the relevant data, then go to Document > Charts and choose a chart type and style. (See Custom Charts in Synthesis Workbooks.)

Defining Names

To create variable names that reference specific spreadsheet cells, see Defined Names.
Word Processing Module

The word processing module in Synthesis Workbooks offers custom reporting functionality that is similar to a Microsoft Word document. You may prefer to use this tool if you want to have a more polished, professional looking report.

This module has two tabs located at the bottom of the window: Design and Review. Use the Design tab to add text, functions and plot holders. Use the Review tab to see the results before you generate the final report.

To export the report to Microsoft Word, choose Send to Word.

Using the Function Wizard

To use the Function Wizard to build and insert functions that utilize a referenced analysis (data source), choose Home > Report > Function Wizard. (See Function Wizard - Data Sources.)

Using the Plot Wizard

To use the Plot Wizard to generate a variety of plots based on a referenced analysis, choose Home > Report > Plot Wizard. These are the same types of plots that are generated in an analysis folio or diagram plot sheets. (See Plot Wizard.)

Using Spreadsheet References

To reference cells from the spreadsheet module (within the same workbook), choose Home > Report > Spreadsheet Reference and select the desired cells. The link between the word processing and spreadsheet modules is dynamic; when data in the spreadsheet is changed, the word processing module is automatically updated. (See Spreadsheet References.)

Formulas and Functions

Function Wizard - Data Sources

In both the spreadsheet module and word processing module for Synthesis Workbooks in Weibull++/ALTA, RGA and BlockSim, you can build functions that return results based on an analyzed folio or diagram.

Note: To insert math, date, logic and other functions into the spreadsheet module of a Synthesis Workbook, see Function Wizard - Formulas.
Using the Function Wizard
To open the Function Wizard in Synthesis Workbooks, choose **Home > Report > Function Wizard**.

Select a function from the navigation panel and enter any required inputs. The following picture shows the most complex configuration as an example. After entering the inputs, click **Insert** to place the function into the report at the current cursor location. You can move and/or modify the function expression after it has been inserted.

For spreadsheet functions:

- The bracketed parameters indicate that the input is optional. In the example above, the **Add Time** and **Confidence Level** parameters are optional.
- You can use cell references as inputs. For example, instead of entering 1000 for a time input, you could specify to use whatever time is currently entered into cell A10, using either the relative reference (A10) or the absolute reference ($A$10). (See **Cell References**.)
- You can use variable names as inputs. (See **Defined Names**.)
- You can type the function expressions directly in the cell once you are familiar with the syntax. For more information, see **Data Entry Tips for Functions**.

For the word processing module:

- The brackets are part of the function field and are not optional.
The functions will not return any results until you either switch to the **Review** tab or **generate the report in Microsoft Word**.

### Selecting a Data Source (if Applicable)

There are two ways to specify the data source:

- **Use the Data Source Name** (spreadsheets module only): This approach will return results based on a specific data sheet or diagram.

  In the Function Wizard, clear the **Use Default** check box and click the **Select** button to choose the data source, as shown next. In this example, the function will return results based on the data sheet called "Data1" in the Weibull++ life data folio called "Folio1."

- **Use a Data Source Index** (spreadsheet and word processing modules): This approach allows you to use the report as a template and return results based on a given data set.

  First, you must add data sources to the Synthesis Workbook (see **Associated Data Sources**). Then, in the Function Wizard, click the **Data Source Index** drop-down list and choose the index number of the desired data source. (In spreadsheets, select the **Use Default** check box to access the **Data Source Index** drop-down list.)
Function Wizard - Formulas
In the spreadsheet module for Synthesis Workbooks in Weibull++/ALTA, RGA and BlockSim, you can insert functions that perform math, date, logic and other operations.

Using the Function Library
The quickest way to add a function is to select it from the appropriate function category dropdown list, then select the cells of interest (hold down the CTRL key to select nonconsecutive cells) and press ENTER. You can move and/or modify the function expression after it has been inserted.

For example, to calculate the average reliability for the following units, you would choose Formulas > Function Library > AutoSum > Average. Select cells B3 through B9 and press ENTER. Note that the cell references can be relative (B3:B9) or absolute ($B$3:$B$9). (See Referencing a Cell.)

Using the Function Wizard
To use the Function Wizard, choose Formulas > Function Library > Insert Function.

Select a function from the drop-down list and click OK. Then in the Function Argument window, enter the input by either selecting the cells in the sheet or typing them directly into the appropriate field. For information relating to entering text as an input, cell references, and working with date and time functions, see Data Entry Tips for Functions.
For example, to exclude the value from unit 4 (failure due to operator error) from the average, you would select cells B3 through B5 for **Number 1**, and B7 through B9 for **Number 2**.

---

**Data Entry Tips for Functions**

This topic provides some data entry tips for using spreadsheet functions in Synthesis Workbooks and general spreadsheets. If you create the function using the Function Wizard, most of the syntax and formatting issues will be handled automatically. However, you have the option to create or modify function expressions directly in spreadsheet cells.

*Note:* For DOE design folios, you can disregard any tips related to **data source functions** (i.e., functions that obtain data or results from a specific data sheet or diagram). For that type of analysis, you can use the **DOE Analysis Reports** feature to obtain results from a design, multiple linear regression or one-way ANOVA folio, or any of the measurement systems analysis folios.

**Case Sensitivity**

The functions are not case sensitive.

**Entering Text as an Input**

When entering text as an input to a function, you must enclose it in quotation marks. This includes situations where you need to specify the data source – `DISTR("Weibull!Folio1!Data1")` – and situations where you need enter a time or date value in one of the accepted text formats – `DAY("22-Aug-2019")`. 
Regional Settings
If your regional settings use a comma as the decimal separator, you must use a semicolon to separate function arguments (e.g., =RELIABILITY("Weibull!Folio1!Data1";A4)).

Referencing a Cell in the Same Sheet
If you want to use another cell in the same sheet, enter the cell reference with a letter to identify the column and a number to identify the row. The cell references can be relative (e.g., B2) or absolute (e.g., $B$2).

- A relative reference points to a cell based on its relative position to the current cell (e.g., B2). When the cell containing the reference is copied, the reference is adjusted to point to a new cell with the same relative offset as the original cell.

- An absolute reference points to a cell at an exact location. Absolute references are designated by placing a dollar sign ($) in front of the row and/or column that is to be absolute. For instance, $B$2 is an absolute reference that points to the cell located in Column B, Row 2 regardless of the position of the cell containing the reference.

For example, if you want to obtain the probability of failure for the time that has been entered in cell B2, the function could be either =PROBFAIL(B2) or =PROBFAIL($B$2). You can type the cell location directly into the field or click the Function Wizard's Insert Workbook Reference icon to insert the reference to the cell currently selected in the sheet. If you want to insert an absolute reference, press CTRL while you click the icon.

Another option is to use the Defined Names tool to assign a name to the cell and use the name in all of the function expressions that require that input. (See Defined Names.)

Referencing a Cell in a Different Sheet
To reference a cell in a different sheet from the one in which the formula is entered, use an exclamation mark (!) after the sheet name. For instance, =Sheet1!$B$2 is a reference to the cell located in Column B, Row 2 in Sheet 1. When referencing a cell in a different sheet from the one in which the formula is entered, the reference must be absolute. If the reference is not absolute, the calculations will not be carried out properly.

You can only reference sheets in the same workbook.

Referencing a Cell in a Data Source
Some functions (e.g., DATAENTRY and FMATRIX) require you to reference a particular cell in a data source. This must be defined differently than references to a cell in a spreadsheet. For data source cell references, you must identify first the row and then the column, and use a
number rather than a letter to represent the column (e.g., A=1, B=2, C=3 and so on). For example:

- `=DATAENTRY(Default1, 2, 1)` returns the value that was entered into cell A2 in the Weibull++, ALTA or RGA folio that is the data source for this function.
- `=FMATRIX(Default1, 2, 1)` returns the value from the second row in the first column of the Fisher variance/covariance matrix that was calculated for that data source.

**Creating Composite Functions**

It is possible to combine different types of data sources and/or functions to create a composite function. For example, in the following formula, two different data sources are used to return the difference between the reliability at 100 hours calculated from the specific Weibull++ life data folio data sheet called "Weibull!Target!Data1" and the reliability at 100 hours calculated from any given Weibull++ data sheet that is currently first in the list of associated data sources for the workbook or General Spreadsheet.

\[
= (\text{RELIABILITY}("\text{Weibull!Target!Data1}\), 100)) - \\
(\text{RELIABILITY}(\text{Default1}, 100))
\]

In the next example, nested functions are used to round up the returned reliability result to the nearest two decimals.

\[
= \text{ROUNDUP}((\text{RELIABILITY}(\text{Default1}, 100)), 2)
\]

**Omitting Optional Inputs in the Middle of a Function**

If you do not use an optional input in the middle of the function, the function expression must specifically indicate that the input is being omitted. For example, when using the Weibull++ reliability function `\text{RELIABILITY(Data\_Src, Age, [Add\ Time], [Confidence\ Level])}`), if you want to get the confidence bound on the reliability, you must use two commas (,) to indicate that the [Add Time] input is intentionally blank, before entering the [Confidence Level] in its usual fourth position (e.g., `=\text{RELIABILITY(\text{Default1},1000, ), 0.95}`).

Note that this is handled automatically if you use the Function Wizard to build and insert the function expression.

**Working with Date Functions**

When using one of the spreadsheet date functions (`\text{DAY}, \text{DAYS360}, \text{MONTH}, \text{WEEKDAY} and \text{YEAR}`) to enter a date, you can use one of the following accepted text formats:

- Month/Day/Year ("8/22/2014"). For example, `=\text{DAY("8/22/2014")}` returns 22.
- Day-Month-Year ("22-Aug-2014"). For example, `=\text{MONTH("22-Aug-2014")}` returns 8 (because August is the 8th month).
If you do not include the year (e.g., “8/22” or “22-Aug”), the current year is assumed.

Alternatively, you can use the date’s serial number (which is the number of elapsed days since January 1, 1900). For example, =YEAR(41873) returns 2014.

- You can obtain a date’s serial number using either of the following two functions. This may be helpful in cases where you want to filter, sort or use the date(s) in calculations.
  - The DATE function uses the inputs of other cells to obtain the serial number. For example, if you have dates specified in three cells where A2=Year, B2=Month and C2=Day, =DATE (A2, B2, C2) returns the serial number for that date.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>Serial #</th>
</tr>
</thead>
<tbody>
<tr>
<td>Year</td>
<td>Month</td>
<td>Day</td>
<td>41873</td>
</tr>
</tbody>
</table>

- The DATEVALUE function requires you to enter the date in an accepted text format. For example, =DATEVALUE("8/22/2014") returns 41873.

Finally, you can also use the results of other functions within a date function. For example:

- To return the month from today’s current date, use: =MONTH (TODAY ()

- To return the day of the week for a date that is specified in three separate cells (A2=Year, B2=Month and C2=Day), use: =WEEKDAY (DATE (A2, B2, C2))

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>Year</td>
<td>Month</td>
<td>Day</td>
<td>Weekday</td>
</tr>
<tr>
<td>2014</td>
<td>8</td>
<td>22</td>
<td>6</td>
</tr>
</tbody>
</table>

Working with Time Functions

When using one of the spreadsheet time functions (HOUR, MINUTE and SECOND) to enter a time, you can use one of the following valid text formats:

- Hour:Minute[:Second] [AM/PM]. For example, =HOUR ("4:48:10 PM") returns 16 (the hour using the 24 hour system).

- Month/Day/Year Hour:Minute[:Second] [AM/PM]. For example, =MINUTE("8/22/2019 4:48:10 PM") returns 48.
Alternatively, you can use the hour, minute or second’s serial number (which is the fractional portion of a 24 hour day). For example, =MINUTE(0.70011574) returns 48 (as the specified serial number represents 4:48 PM).

- You can calculate a time’s serial number using either of the following two functions. This may be helpful in cases where you want to filter, sort or use the time(s) in calculations.
  - The `TIME` function uses the inputs of other cells to obtain the serial number. For example, if you have dates specified in three cells where A2=Hour, B2=Minute and C2=Second, =TIME(A2,B2,C2) returns the serial number for that time.

```
D2 =TIME(A2,B2,C2)
```

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>16</td>
<td>48</td>
<td>10</td>
<td>0.70011574</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- The `TIMEVALUE` function requires you to enter the time as text in one of the accepted text formats. For example, =TIMEVALUE("4:48:10 PM") returns 0.70011574.

Finally, you can also use the results of other functions within a time function. For example:

- To generate current values, you can use the `NOW` function. If the current time is 4:48 PM, then =HOUR(NOW()) returns 16.

### Returning Confidence Bounds
For functions that return confidence bounds, note that the **Function Wizard** for data sources only inserts one-sided bounds. If you want to show two-sided bounds, you can insert the same function twice — once at the lower confidence bound and once at the upper confidence bound. For example, for a 90% confidence level, you would set the lower confidence bound at 5% and the upper confidence bound at 95%.
• In a spreadsheet, you can use the same function (with different input parameters) to obtain any of the three values. For example, in Weibull++:

=RELIABILITY(Default1,1000) returns the estimated value
=RELIABILITY(Default1,1000,,0.05) returns the lower one-sided bound at 5%
=RELIABILITY(Default1,1000,,0.95) returns the upper one-sided bound at 95%

Note that the above function expressions for the confidence bounds uses two commas (,,) to indicate that another optional input ([Add Time]) was intentionally left blank. For more information about the syntax for functions containing multiple optional inputs, see Data Entry Tips for Functions.

• In a word processing module for Synthesis Workbooks, the wizard provides separate functions for confidence bounds. For example, use the Reliability function to get the estimated value and use the Bound on Reliability function to get each one-sided confidence bound.

Plot Wizard

In the word processing module for Synthesis Workbooks in Weibull++/ALTA, RGA and BlockSim, you can use the Plot Wizard to generate a variety of plots based on a referenced analysis. These are the same types of plots that are generated in folio or diagram plot sheets. Although you also have the option to copy/paste a static plot graphic from any folio or diagram plot sheet into the report, using the Plot Wizard makes it easy to change the associated data source when you reuse the template and ensures that the plot in the generated report will always show the latest analysis. (For DOE design folios, you can use the DOE Analysis Reports feature to insert plots from a design, multiple linear regression or one-way ANOVA folio, or any of the measurement systems analysis folios.)

To open the Plot Wizard, choose Home > Report > Plot Wizard.
Chapter 16: Synthesis Workbooks

The following picture shows the plot wizard in Weibull++. Similar functionality is available for RGA and BlockSim.

There are three steps to use this tool:

1. Select the plot type (and enter the inputs, if applicable)
2. Select the data source
3. Insert the plot holder

Select the Plot Type
First, select one of the available plot types from the panel on the left side. The right side of the wizard displays some information about the plot that is currently selected.

If applicable, this area also allows you to make relevant inputs (e.g., for ALTA plots that require you to select a specific stress column).

Select the Data Source
To specify the data source that the plot will be based on, choose a number from the Data Source Index drop-down list, as shown next. Using the index makes it easy to reuse the same template with a variety of different data sets.
Insert the Plot Holder
When the plot is fully defined, click Insert to place it at the current cursor location. You can move and/or resize the plot holder after it has been inserted. The plot holder shown next will return the reliability vs. time plot for whatever data source is currently second in the list of associated data sources.

Plot holders will not return any results until you view it in the Review tab or generate the report (Home > Report > Send to Word).
Custom Charts

In the spreadsheet module for Synthesis Workbooks, you can use the Document > Chart commands to insert your own custom charts. The charts can be placed anywhere in the spreadsheet, and are dynamic (automatically update when the data used to create the chart is changed).

Adding a Chart

1. Select the cells that contain the data of interest. In the example data below, the headings are included in the selection and will be used as the legend labels.

2. Choose Document > Charts. Choose the chart type, and then click a chart subtype that you want to use.
3. To move the chart, click and drag the chart to the desired location.

4. To resize the chart, click the chart and then drag the sizing handles to the desired size.

**Changing the Data Displayed on an Axis**
To change the way the data series is displayed on the axes, click the chart, then choose Design > Data > Switch Row/Column.

**Changing the Chart Type and/or Data Set**
You can change the type of chart and/or the data that is used in a chart at any time. To do this, click the chart and then:

- To change the chart type, choose Design > Type > Change Chart Type. Select the desired type.
To change the data set, choose Design > Data > Select Data. Select the cells that contain the data of interest.

**Applying a Chart Layout and/or Chart Style**

- To apply a predefined chart layout, choose Design > Chart Layouts. As an example, the following picture shows some of the options for 2-dimensional bar charts. To see the rest, click the arrow in the bottom-right corner.

If none of the predefined options are suitable for your chart, choose Layout > Labels, then select the option you want to customize. The following picture shows the options for the vertical axis.

- To apply a predefined chart style, choose Design > Chart Styles.

**Renaming Chart and Axes Titles**

When displaying chart and/or axes titles, you can rename the titles by right-clicking the chart and selecting the appropriate title option from the shortcut menu. For example, choosing Change Chart Title opens the following window:
Modifying the Axes and Gridlines
To hide or display axes and/or gridlines, choose Layout > Axes > Axes or Gridlines.

- When displaying axes, you can change direction of the x-axis and/or change the scale of the y-axis.
- When displaying gridlines, you can increase or decrease the number of gridlines for both the axes.

Defined Names
In the spreadsheet module for Synthesis Workbooks and general spreadsheets in Weibull++/ALTA and RGA folios, you can create variable names that reference specific spreadsheet cells. The names can then be used in any formula or function within the same workbook.

For example, say you want to obtain the reliability of a Weibull++ data set. The operating time is stored in cell B5 of the spreadsheet:

\[ \text{=RELIABILITY(“Weibull!Bulb!Data1!”$B$5)} \]

You can create a defined name for the operating time to make the formula easier to understand and maintain. In this case, the formula might be rewritten as:

\[ \text{=RELIABILITY(“Weibull!Bulb!Data1!”OpTime)} \]

You can then use the defined name OpTime in any other formula in the workbook that requires the operating time.

Syntax Rules for Names
- The first character of a name must be a letter or an underscore. The remaining characters can be letters, numbers, periods and underscores. Names are not case sensitive.
• Spaces are not allowed as part of a name. An underscore ( _ ) or period ( . ) can be used as a word separator.

• Symbols, except for underscores ( _ ), periods ( . ) and backslashes ( \ ), aren't allowed.

Managing Names
To view and manage defined names:

• In Synthesis Workbooks, choose Formula > Defined Names > Name Manager.

• In general spreadsheets, choose Sheet > Format and View > Defined Names.

You can then use the New, Edit, or Delete commands in the window to create or modify the names.

Defining Names
There are several ways to define a name.

Define a Name via the Name Manager
This method applies to both Synthesis Workbooks and general spreadsheets.

1. Select a cell or range of cells.

2. Create a new name:
   • In Synthesis Workbooks choose Formulas > Defined Names > Define Name (or choose Formulas > Defined Names > Name Manager, then click the New button in the window).
   • In general spreadsheets, choose Sheet > Format and View > Defined Names. Then in the window, click the New button.

3. Type a name into the Name field. In the Scope drop-down list, choose whether this name will be used for the entire workbook or a specific sheet. The Comment field is optional.

   The selected cell/range will already be defined in the Refers to field, but you can click into the spreadsheet and select different cells, if desired.
Define a Name via the Name Box (Synthesis Workbook Only)
This method applies only to the spreadsheet module of Synthesis Workbooks. Select the cell or range of cells, click the Name box and type a name. Press Enter to create the name.

Define a Name via the Selection Command (Synthesis Workbook Only)
If the fields are already labeled in the spreadsheet, you can use them to create names.

1. Select the cells of interest (including the row or column labels), then choose Formulas > Defined Names > Create from Selection.

2. In the window, select the location of the labels. Click OK.
Spreadsheet References

In Synthesis Workbooks, the spreadsheet reference feature provides integration between the spreadsheet and word processing modules in the same workbook. You can insert a reference from any cell, or consecutive range of cells, from the spreadsheet into a desired location in the word processing document. If the referenced cells in the spreadsheet are changed, the word processing module is automatically updated. The changes are visible when you use the Review tab to see a preview or generate the Word report.

To insert a spreadsheet reference, place the cursor at the desired location in the word processing document and choose Home > Report > Spreadsheet Reference.

Note that you can also use the Spreadsheet Reference function in the word processing module’s Function Wizard.

The Select Cells window shows the contents of the spreadsheet module in the current workbook. Select a cell or range of consecutive cells and click OK.
For the example data shown above, the entry would look like this:

```
[TBLSSREF(Sheet1!B2:D10)]
```

**DOE Analysis Reports**

The DOE Analysis Reports feature allows you to insert selected analysis results and plots into a Synthesis Workbook.

This feature is available for any analyzed response in a design, multiple linear regression, one-way ANOVA or measurement systems analysis folio. The report can display any result that's available in the folio's Analysis Summary window for the selected response, as well as any applicable plot.

This topic describes how to build and insert a DOE analysis report, and how to use saved profiles for reports that you need to generate frequently. Note that you can insert multiple reports into the same spreadsheet or word processing document, if desired. Each additional report will be appended to the end.
Inserting a DOE Analysis Report

1. Select either the spreadsheet or word processing module in a Synthesis Workbook and choose **Home > Report > DOE Analysis Report**.

2. In the Select Response window, choose an analyzed response to copy the results from and click **OK**.

3. In the DOE Analysis Report window, the **Available Report Items** area (left) shows all of the available results and plots for the selected response. The **Selected Report Items** area (middle) shows the selected results/plots, in the order in which they will appear. You can:
   a. Choose **Profiles > Open Profile** to apply all of the relevant selections from a saved report profile. (See Using DOE Report Profiles.)
   b. Build/modify the list using double-click, drag and drop or the **Add/Remove** and **Up/Down** buttons.

   Note that you can include multiple instances of the same report item, if desired.

4. When you click each selected report item, the **Item Properties** area (right) allows you to view/change the name (heading) that will be used in the report, if desired.

   For plots, you can also click the **Preview Plot** button to see what the plot will look like in the report. Any plot settings you change in the plot preview will be used in the generated report but will not affect the folio the report is based on.

5. Choose **Actions > Generate Report**.

Using DOE Report Profiles

When the DOE Analysis Report window is open, you can save the current settings (i.e., report item selections), or load settings that were previously saved.

- To save all your current report settings for use in future reports, choose **Profiles > Save Profile**.

Then specify the name and location of the DOE report file (*.drt) that will store the settings.
• To overwrite all the settings in the DOE Analysis Report window and use the settings from a DOE report file instead, choose *Profiles > Open Profile*.

Then select the *.drt* file that has all the desired settings.

**Note:** When you load report items from a DOE report file, only the items that apply to the selected folio/response will be included in the report.
Chapter 17: Synthesis Dashboards

The dashboard is a flexible tool for graphical presentation of data. This can include bar and pie charts, gauges, maps, etc.

All users can view dashboards based on predefined layouts (see Dashboard Viewer). The viewer is available in the following locations in ReliaSoft desktop applications:

- Project Planner
- Synthesis Explorer
- Simulation diagram results in BlockSim (see Simulation Diagram Dashboards in the BlockSim/RENO documentation)
- FMEA and FMRA data in XFMEA/RCM++ (see FMEA Dashboards in the XFMEA/RCM++/RBI documentation)
- Synthesis Data Warehouse (SDW) data in Weibull++ and RGA

In a secure database, only users with the "Manage dashboard layouts" permission can manage and create predefined layouts (see Dashboard Layout Manager and Dashboard Layout Designer).

If your organization chooses to implement an SEP web portal for an enterprise database, you can also share selected dashboards to be accessed from any web-enabled device!
Dashboard Viewer

Any user can access the Dashboard Viewer in a variety of locations throughout ReliaSoft desktop applications for graphical presentation of the latest analysis data.

When dashboard functionality is available for the data you’re working with (e.g., Project Planner, Synthesis Explorer, simulation diagrams in BlockSim, etc.), choose Dashboard > Dashboard Viewer to open the viewer.

Select any of the predefined dashboard layouts from the drop-down list to see the latest charts for the current data set.

Resizing Panels
To resize the dashboard items vertically and/or horizontally, click between two items and drag the resize cursor (++) to the height and/or width you want. This option is available when a dashboard contains multiple items.
Showing Details in Charts and Pies
To see more details about the underlying data, move the mouse pointer over a bar or slice. For example, when the pointer is over a bar in a chart, the values for the x and y axes will be displayed in the tooltip.

Drill Downs and Master Filters
For information about how to use charts that have been configured for a drill down, see Viewing Drill Downs. For information about how to use charts that have been configured with master filters, see Using Master Filters.

Sorting and Filtering Data in a Grid
- To sort the data in ascending or descending order, click the column heading.
- To filter the data, click the Advanced Filter icon to see a drop-down list of filters that you can apply. The dashboard uses the same advanced filters functionality that is built in to other utilities (e.g., Resource Manager, Synthesis Explorer, etc.). (See Finding and Filtering Records.)
Printing or Exporting the Dashboard

To print the entire dashboard, or export it as a *.pdf file, an image or an Excel file, click the Export To icon.

Viewing Drill Downs

An easy way to determine if the dashboard was configured for drill down is to look for the arrow in the caption bar, if the bar is visible.

To drill down, double-click an area of interest.

To drill up, click the arrow (▲) until you have reached the desired level or right-click the chart, then choose Drill Up.
Using Master Filters
When a dashboard with master filters is created, it can be configured for single or multiple filtering. If you see either of the following, then filtering is enabled:

- For **single** filtering, the dashboard title is followed by light gray text.

  ![Dashboard](image)

- For **multiple** filtering, the **Clear Master Filter** icon displays in the caption bar, if the bar is visible.

  ![Component](image)
Note that if you see both the icon and light gray text, this means that multiple filtering is enabled, but only one item in the filter is selected.

**Single Filtering**
For single filtering, you can only select one item at a time. You will not be able to clear the view, only select a different item.

**Multiple Filtering**
For multiple filtering, you can select as many filter items as you want to view. Hold down SHIFT while clicking to select consecutive elements or hold down CTRL while clicking for nonconsecutive items.

In the example shown next, the grid was set up as the master multiple filter. The chart and pie charts display the data for the four parts selected in the grid.

To reset the view, click the **Clear Master Filter** icon or right-click, then choose **Clear Master Filter**.

**Dashboard Layout Manager**
You can use the Dashboard Layout Manager to create, edit and delete the predefined dashboard layouts that will be available for any user to view for a particular data set. (In a
secure database, this is available only for users with the "Manage dashboard layouts" permission.)

To open the Dashboard Layout Manager, choose the command from any interface that supports dashboard functionality (e.g., Project Planner, Synthesis Explorer, simulation diagrams in BlockSim, etc.). It will display only the layouts for that particular data type.

You can also open the Dashboard Layout Manager from the Backstage view (File > Manage Repository > Dashboard Layout Manager). It will display all of the layouts for any data type. If you want to see only the layouts specific to the application you are using, select the check box.

Show in Viewer
Use the check boxes in the Show in Viewer column to select which of the predefined layouts will be available to all database users via the Dashboard Viewer. If you clear a check box, the layout will not show in the viewer’s drop-down list but will remain in the manager’s list.

Use the up/down arrows to change the order of the layouts that are shown in the viewer’s drop-down list.

Layout Properties
For all dashboard layouts that are selected to show in the Dashboard Viewer, the name that will be visible in the list is set from the Layout Properties window. To view or change these properties, select a row in the table and click the Properties button (or right-click and choose Properties).
Chapter 17: Synthesis Dashboards

The description and update history are available to help you manage the layouts; that information is not visible to all database users.

**Importing Layouts**

It is easy to reuse dashboard layouts that were created in other databases. Click the **Import** button and then select the database you want to import from. If you are using the Dashboard Layout Manager in the Backstage view, you can import layouts of any type. If you’re using a manager from one of the locations where dashboards are used, you can only import layouts of the current type.

**Dashboard Layout Designer**

You can use the Dashboard Layout Designer to create or edit each predefined dashboard layout. (In a secure database, this is available only for users with the "Manage dashboard layouts" permissions.)

To access this window, first open the Dashboard Layout Manager and then choose to either create a new layout or edit an existing one.

**Separate Layouts for Each Data Type**

Each dashboard layout is designed to be used with a specific data type, which determines which fields are available and where the dashboard can be viewed. For information about creating dashboards for each particular type of data, see:

- **Project Planner Dashboards**
- **Synthesis Explorer Dashboards**
- **Simulation Diagram Dashboards** (in the BlockSim/RENO documentation)
- **FMEA Dashboards** (in the XFMEA/RCM++/RBI documentation)
- **Synthesis Data Warehouse (SDW) Dashboards** (available in Weibull++/ALTA and RGA)

**Tip:** For dashboards that are intended to be viewed in both desktop applications and the SEP web portal, it is recommended to use the **Local Colors** option on the Design tab of the Dashboard Layout Designer to save your preferred colors with the layout. The global colors definition may not be the same in both web and desktop.
Configuring a Dashboard Item
This topic demonstrates some of the basic steps for configuring a dashboard item (bar chart, pie chart, gauges, etc.) in the Dashboard Layout Designer. The simple bar chart in this example is based on block-level simulation results from a reliability block diagram in BlockSim. The data source options will be different for other locations where dashboards are available, see Project Planner, Synthesis Explorer, Simulation Diagram Dashboards (BlockSim/RENO), FMEA Dashboards (XFMEA/RCM++/RBI) or SDW Dashboards (Weibull++/ALTA and RGA).

In a secure database, only users with the "Manage dashboard layouts" permissions can create layouts.

Add the Chart
Add a chart to the Layout panel by choosing Home > Insert > Chart.

Define the Chart Data
1. Select a data source from the drop-down list in the Data Source panel, if applicable.

2. Choose the data field (or fields) that will be displayed in the y-axis of the bar chart, then drag each field into the Values area in the DATA ITEMS panel. For this example, the chart will display total operating cost, cost from preventive maintenance and cost from corrective maintenance.

Note that when different data sources are available, all of the data fields used within a chart must come from the same source.
Tip: To replace a data item, drag a new field on top of the current one. To remove a field, drag it anywhere outside of the data item; and to completely clear the DATA ITEMS panel, right-click the chart and select Remove Data Items.

3. Use the drop-down list to see which values are available for this data field (e.g., count, sum, average, etc.) and choose one to display in the chart. Note that the same option must be selected for all values in the same chart.

Because we want the total cost from all blocks that meet the given criteria, we use the default Sum for this example.
4. If appropriate, use the **Rename** command to change the name that will be displayed in the chart legend, tooltip, etc.

5. Choose the data field that will be displayed in the x-axis, then drag it to the **Argument** bar.
Chapter 17: Synthesis Dashboards

**Filter the Data**
To filter the data displayed in the chart, choose Data > Filtering > Edit Filter.

Use the Filter Editor to define the criteria. For this example, we’re using the "Not And" operator to exclude any blocks with a name that contains "Hub."

![Filter Editor Example](image)

**Tip**: You can use hidden data items to filter based on fields that are not displayed in the chart.

**Sort by “Top N”**
To configure the chart to show only the top 5, bottom 10, etc., use the Top N command in the Argument data item’s drop-down list.

For this example, we’re showing only the Top 5 blocks, based on total operating cost. The results are displayed from highest to lowest and the order cannot be changed.
Tip: Alternatively, you could use the Sort by command to sort by the argument data item — which is labeled (Value) in this menu — or by any of the value data items. Click the Argument bar to toggle the sort between ascending and descending order.

Other Design Options
Click the Design tab on the ribbon to access other configurable options for this type of chart. For example:

1. To hide or display the caption bar above the chart, choose Show Caption.

   ![Show Caption]

   We will keep it displayed for this example.

2. To change the title in the caption bar to something more meaningful, choose Edit Names.

   ![Edit Names]

   For this example, we will set the Dashboard item name to “Top 5 Blocks by Total Operating Cost” and clear all of the Series fields to make sure the latest data item name (set via the Rename command in the data item’s drop-down list) will always be used in the chart legend and tooltip.
3. To change the y-axis title to a more meaningful name, choose **Y-Axis Settings**.
Available Dashboard Items

The following dashboard items can be added to any layout. You can add the same type of item more than once, if desired. To insert an item, choose **Home > Insert**, then click one of the following options.

<table>
<thead>
<tr>
<th>Pivot</th>
<th>Chart</th>
<th>Gauges</th>
<th>Choropleth Map</th>
<th>Range Filter</th>
<th>Scatter Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Grid</td>
<td>Pies</td>
<td>Cards</td>
<td>Geo Point Map</td>
<td>Text Box</td>
<td>Image</td>
</tr>
</tbody>
</table>

Data Types

There are two types of data that can be used in a dashboard item: measure or dimension.

- **Measure** data is calculated (sum, count, average, etc.). For example, the values on the y-axis of a chart, the size of a slice in a pie or a target value in a card or gauge. Values and targets are forms of measure data.

- **Dimension** data can be sorted but is not calculated. For example, the bars in chart, slices in a pie or text in a grid column. Arguments and series are forms of dimension data.

Data Shaping

You can use the Dimensions and/or Measures bars in the HIDDEN DATA ITEMS panel when you want to perform data shaping (filtering, sorting or Top N) but do not want the data to be displayed in the dashboard item. Data shaping is available for any dashboard item, except text boxes and images.

- The data fields contained in the **Dimensions** bar can be used in the Filter Editor window to create filter conditions based on their values. Dimensions in this area have the same sorting functionality that is available in the argument, attribute or series DATA ITEMS area.

- The data fields contained in the **Measures** bar can be used in the Sort by submenu and in the Top N Values window for data sorting. Measures in this area have the same calculation functionality that is available in the values and target DATA ITEMS area.
Chapter 17: Synthesis Dashboards

**Configuring a Drill Down**

Drill down can be enabled for the following dashboard items:

- Grids: Specify two or more columns
- Charts and pies: Specify two or more arguments and/or series
- Gauges: Specify two or more series
- Cards: Specify two or more series

**Configuring a Drill Down Sequence**

1. In the Dashboard Layout Designer window, select the chart or grid you want to drill down.
2. Drag the additional data fields into the Arguments area in the appropriate order for the desired drill down sequence.

For example, you can use the following sequence to configure a pie chart in a Synthesis Explorer dashboard to first show analyses by application source, then drill down to analysis type.

3. Choose Data > Filtering > Drill Down. This command is a toggle; choose the command again to disable the drill down.

When any user views this layout in the Dashboard Viewer, he/she will be able to double-click inside the chart to drill down, and use the arrow (↑) to drill back up. (See Viewing Drill Downs.)

**Tip:** To make it easy to identify a drill down in the Dashboard Viewer, display the dashboard item's caption bar (Design > Common > Show Caption).
Filtering

Using the Filter Editor
You can use the Filter Editor to incorporate filters into dashboard items that contain dimension data. Arguments and series are forms of dimension data.

This type of filtering only applies to the dashboard item you have selected. To filter the data across the entire dashboard, see Configuring a Master Filter.

**Tip:** While you cannot use the Filter Editor to sort non-dimension data, users can apply filters to such data fields within dashboard grids. See Sorting and Filtering Data in a Grid.

### Dimension Data Locations
Dimension data can be used in any or all of the following areas:

- Dimension bar in the HIDDEN DATA ITEMS panel.
- Dimension, argument and/or series bars in the DATA ITEMS panel.

An easy way to determine if a data field is a dimension, argument or series, is to look for the sort arrow to the left of the data field name.

#### Configuring a Filter
1. In the Dashboard Layout Designer window, select a dashboard item, then choose Data > Filtering > Edit Filter. This command is also available in the shortcut menu when you right-click the dashboard item.
2. In the Filter Editor window, define the criteria. The dashboard uses the same Edit Filter functionality that is built into other utilities (e.g., Resource Manager, Synthesis Explorer, etc.). (See Finding and Filtering Records.)

In the following example, a chart was created for data that was extracted from XFRACAS into the Synthesis Data Warehouse (SDW) in Weibull++.

Because we are interested in only the chandelier parts (not the whole unit) and data from 2010 and later, we can apply the following filter to remove the unwanted data:
Chapter 17: Synthesis Dashboards

Configuring a Master Filter
A master filter can be used to filter data across the entire dashboard. Grids, pies, charts, gauges, cards and maps dashboard items can be used as master filters.

There are two types of master filters that can be configured:

- **A Single** filter allows you to select one item at a time. You will not be able to clear the filter, only select a different item.

- **A Multiple** filter allows you to select one or more items at a time. You can also clear the filter to view all items at any time. This is the most flexible option.

For example, suppose your layout contains a grid, a chart and a pie, and the grid is configured as the multiple master filter. When you select items in the grid, only the data for those items will display in the chart and pie.

Configuring a Master Filter
In the **Dashboard Layout Designer window**, select the dashboard item, then enable the master filtering by choosing **Data > Interactivity > [Single Master Filter/Multiple Master Filter]**. This command is a toggle; choose the command again to disable it.

When any user views this layout in the **Dashboard Viewer**, he/she can use the filter to view only the data of interest. (See **Using Master Filters**.)

Note that you can prevent a specific dashboard item from being affected by master filters, by selecting it in the Layout panel and then choosing **Data > Interactivity settings > Ignore Master Filters**. This command is a toggle; choose the command again to disable it.

**Tip:** To make it easy to identify that a dashboard item is configured for filtering in the Dashboard Viewer, display the item's caption bar (**Design > Common > Show Caption**).
Chapter 18: Synthesis Data Warehouse

Available in Weibull++, ALTA and RGA, the Synthesis Data Warehouse (formerly called "Reliability Data Warehouse") enables you to access data from an XFRACAS failure reporting system for the purpose of life data analysis (in Weibull++/ALTA) or repairable system/reliability growth analysis (in RGA). You can also set up custom connections to obtain reliability-related data from external data sources (including Access, Oracle and SQL Server). You can also get data directly from custom reports created in XFRACAS.

You can then transfer the data to an analysis folio in Weibull++, ALTA or RGA, or use the flexible Synthesis Dashboard utility to explore and present the data in a variety of graphical charts and grids. (See Transferring from the SDW to an Analysis Folio or SDW Dashboards.) In addition, if an SEP web portal has been implemented for an enterprise database, users can also access SDW dashboards from any web-enabled device.

To open the SDW in Weibull++, ALTA or RGA, choose Home > Synthesis > Synthesis Data Warehouse.

Managing Data Sources

The available data sources are listed in the data source manager on the left side of the window. They may include:

- Static data collections that were extracted from XFRACAS at a particular point in time (and will not change if incidents are later added or updated). These can be either Weibull++/ALTA data or RGA data. (See Extracting Data from XFRACAS.)

- Custom connections that have a live link to a specified external database or to a predefined report created in XFRACAS. (See Custom Connections in the SDW.)

- Static data collections that were extracted from a custom connection at a particular point in time (and will not change if the original data source changes). (See Import to a Static Data Collection.)

If you are working with a long list of available data sources, this panel can utilize the same categories, identifiers and item filters that are available in many other locations throughout ReliaSoft desktop applications.

To create, delete, rename or edit the properties for these data sources, use the Manage Data Sources commands, or right-click inside the panel.
Chapter 18: Synthesis Data Warehouse

The Properties window allows you to enter identifiers for each data source, and to view its history.

**Built-in Find/Filter, Configuration and Grouping Tools**

Double-click any data source to display the data in a grid on the right side of the window. The SDW offers the same filter, column configuration and grouping tools that are built in to other utilities that use a similar grid (e.g., the Synthesis Explorer, Actions Explorer, etc.). For details about how to use each feature, see:

- Finding and Filtering Records
- Configuring Columns
- Grouping Panel

**Building the Data Set**

The "Include in Analysis?" column shows whether each row will be included in the data set when it is transferred to Weibull++, ALTA or RGA.

- **Include**: Data points that will be included in the analysis are shown in green.
- **Invalid**: In XFRACAS data collections, incidents with a State Time of less than 0 are automatically set to invalid and will not be included in the analysis. These rows are shown in red.
- **Ignore**: In XFRACAS data collections, incidents with a State Time of 0 that are marked as suspensions in the State FS column are automatically set to ignore and will not be included in the analysis. These rows are shown in gray.
- **Exclude**: Data points that have been manually set to exclude from the analysis are shown in blue.

To view only those rows that will be transferred to a folio, choose View > Show Only Included. You can toggle this command off to show all records.
To change the status for a specific data point before transferring data to a folio, select the row and choose Build Data Set > Include or Build Data Set > Exclude.

Note: Changes to the "Include in Analysis?" indicator will not be saved with the data source. If you close the data source and open it again later, and if you view a dashboard in the SEP web portal, the data will not reflect changes that were applied manually.

In XFRACAS data collections, and only if you have permission to view incidents in the XFRACAS entity that the data were extracted from, you can select a row and choose Build Data Set > View XFRACAS Incident to open the incident in your web browser.

Extracting Data from XFRACAS

When you are working with an enterprise database that contains XFRACAS data, or a standard database that has a connection to external XFRACAS tables, you can use the Synthesis Data Warehouse to extract static data collections. These can be either Weibull++/ALTA data or RGA data, and the collections will not change if incidents are later added or updated in XFRACAS. (Alternatively, if you need a live link to a predefined report that has already been created in XFRACAS, see Connect to XFRACAS Report.)

To extract a static data collection from XFRACAS, first open the SDW in Weibull++, ALTA or RGA and then choose Manage Data Sources > Get XFRACAS Data.

(In a secure database, this is available only to users with the "Create/edit/delete SDW data collections" permission. Additionally, users must have the "Synthesis - Read Data" permissions for the associated XFRACAS tables.)

In the XFRACAS to SDW window, choose an Entity to import from, then select the check box for each part that you want to extract the incident (i.e., failure) data. If needed, you can use the Auto Filter Row to filter the grid by matching text in one or more columns. (For extremely large data sets, this row will be hidden and a Filter window will be available instead.)
Click Next, then specify other settings or fields to import:

- **Time Metric** allows you to choose which metric to use with the data. The options are based on the metrics that your system administrator has enabled for the XFRACAS entity.

- **Incident Detail Fields** allow you to map customized detail fields from the XFRACAS incident to one of the user-defined field columns in the SDW collection. The following field types can be mapped:
  - **StringUDF1-3**: Alphanumeric Input Box, Check Box, Company, Contacts, Currency, Date, Numeric Input Box, Users, Yes/No Button, or the Select List, Administrative Controlled field type
  - **NumberUDF1-3**: Currency or Numeric Input Box
  - **DateUDF1-3**: Date

- In RGA, additional options are available:
  - **Include non-chargeable** extracts incidents that are marked as either chargeable or non-chargeable in XFRACAS. If you clear the check box, it will extract only chargeable incidents.
  - **Only system down events** extracts only those incidents that brought the system down.
  - **Filter by date commissioned** extracts only incidents for systems that were commissioned between the specified dates.

Click Next, then enter a name for the data collection and any identifiers that you want to use.

When you click OK, the extraction process will begin. Depending on the amount of data that you are extracting, this may take some time.
You can then use the data collection to transfer data to an analysis folio or explore/present in the dashboard utility. For information about the fields that will be available either in the Build Data Set tab or in the Dashboard Designer, see Data Fields for XFRACAS Data Collections.

Data Fields for XFRACAS Data Collections

The following fields are available for use in dashboard layouts for XFRACAS data collections and for data sets created via the Synthesis API. These are the same columns available in the Build Data Set tab. The fields in custom connections will depend on the data source itself.

- **Address Location**: the location of the owner of the system. This corresponds to the Location field in the XFRACAS contact.
- **Category**: the incident category. This corresponds to the Category field in the XFRACAS incident and, in conjunction with the failure type assigned during part repair/replacement, determines whether the data row is chargeable (i.e., is considered a failure for reliability calculations) or non-chargeable (i.e., is considered a suspension). For more information, see the “Incident Disposition Area” topic in the XFRACAS documentation.
- **Chargeable**: the chargeable code value (where 0 = non-chargeable, 1 = chargeable): equivalent to the Category Chargeable and Category Non-Chargeable lists in the XFRACAS Admin List page. This is to be used to calculate the failure state (StateFS). XFRACAS categories can also be viewed within an XFRACAS incident.
- **CompanyOwner**: the owner of the system. This corresponds to the Company field in the XFRACAS contact.
- **DataID**: the database ID of the row.
- **DataSetID**: the ID of the data set that the row belongs to. This is useful if you are viewing multiple data sets at the same time.
- **DateUDF1-3**: user-defined fields for dates. You can choose up to 3 detail fields in XFRACAS incidents to import to these columns.
- **ExtractedBy, ExtractedDate and ExtractedName**: identify the user who extracted the data from XFRACAS, the date of extraction and the name of the SDW data collection.
- **FailureMode**: the failure mode associated with the incident. This is chosen or created in the Failure Mode field in the XFRACAS incident.
- **IncidentAction**: the action taken to address the incident (whether a part was removed or installed). This is not related to XFRACAS actions. In XFRACAS data sets, repaired and
replaced parts will be represented using two rows of data—one will be for removing the part, and one for installing it.

- **IncidentEntityDisplayID**: the incident number assigned by XFRACAS, which includes the prefix for the entity that it is associated with (e.g., E1-201).
- **IncidentID**: the database ID of the incident.
- **IncidentOccurrenceDate**: the date when the incident happened. This corresponds to the Occurrence Date field in the XFRACAS incident.
- **IncidentRepairDate**: the date that part repair or replacement was completed. This corresponds to the Completed Date field that applies to the XFRACAS incident resolution.
- **IncidentResolution**: notes regarding the resolution of the incident. This corresponds to the Incident Resolution field in the XFRACAS incident.
- **IsLRU**: indicates whether the item is a line replaceable unit (LRU). This does not correspond to an XFRACAS field; it can be used when creating data sets via the Synthesis API.
- **LastInspectedTime**: the last inspected time. For exporting XFRACAS data sets to Weibull++, this is equal to the state time for the data row. For exporting XFRACAS data sets to RGA, it is the amount of time the system has accrued at the last reported incident.
- **NumberInState**: equivalent to the Number in State column in a Weibull++ life data folio for grouped data. In data sets from XFRACAS, this value will always be 1.
- **NumberUDF1-3**: user-defined fields for numbers. You can choose up to 3 detail fields in XFRACAS incidents to import to these columns.
- **ParentPartID, ParentPartName, ParentPartNumber, ParentPartVersion** and **ParentPartSerialNumber**: identifiers for the "parent" of the part that the incident pertains to. If the part doesn’t have a parent (i.e., it is a top level part), this information will be identical to the information for the part itself.
- **PartHID** and **PartID**: the part’s hierarchy identification number and database identification number. In XFRACAS, these are assigned by the system and shown in the HID and Part ID fields that are displayed for the generic part on the Template page.
- **PartName, PartNumber** and **PartVersion**: identifiers for the part that the incident pertains to. In XFRACAS, this information is specified for the generic part, and serialized parts based on the generic part will use the same information.
- **PartOrder**: the order in which the part was replaced. This corresponds to the order in the repair/replace table in the XFRACAS incident.

- **PartSerialHID, PartSerialMfgCode and PartSerialNumber**: relevant only if the incident was assigned to a part in a serialized system. They represent the part’s serial hierarchy identification number, manufacturing code and serial number. In XFRACAS, the PartSerialHID is assigned by the system and shown in the Serial HID field that is displayed for the serialized part on the Serialized page.

- **ReportType**: how the incident was reported. This corresponds to the type chosen in the Report Type field in the XFRACAS incident.

- **RootCause**: the root cause of the failure mode. This is chosen or created in the Root Cause field in the XFRACAS incident.

- **StateFS**: This allows the user to understand if a data row is considered a failure (F) or a suspension (S) for the purposes of reliability calculations. In XFRACAS data sets, this is based on the incident category assigned in the XFRACAS incident, in conjunction with the failure type assigned during part repair/replacement. For more information, see the “Incident Disposition Area” topic in the XFRACAS documentation.

- **StateTime**: the amount of time accrued on the part. This is based on the run hours calculated by XFRACAS.

- **StateTimeRestore**: the amount of time required for the repair. This corresponds to the Repair Duration field in the XFRACAS incident.

- **StringUDF1-3**: user-defined fields for strings. You can choose up to 3 detail fields in XFRACAS incidents to import to these columns.

- **TimeMetric**: the time metric to use for the data. The options are based on the metrics that have been enabled for the XFRACAS entity.

- **TopLevelCommissionDate**: the commission date of the top level part in the system. This corresponds to the commission date of the associated CSI in XFRACAS.

- **TopLevelPartID, TopLevelPartName, TopLevelPartNumber and TopLevelPartVersion**: identifiers for the top level part in the system that the incident pertains to.

- **TopLevelSerialHID and TopLevelSerialNumber**: relevant only if the incident was assigned to a part in a serialized system. They represent the serial hierarchy identification number and serial number of the top level part in the serialized system. This information is used by RGA and Weibull++ to distinguish the system in which the failure occurred.
Transferring from the SDW to an Analysis Folio

Follow the steps below to transfer a data set from the Synthesis Data Warehouse (SDW) to a Weibull++, ALTA or RGA analysis folio.

1. In Weibull++, ALTA or RGA, choose Home > Synthesis > Synthesis Data Warehouse.

2. In the SDW, double-click the data you want to transfer to an analysis folio.

3. In the data table, use the Include in Analysis? column to mark any data points that need to be excluded from the transfer. You can double-click the cell to toggle the options, or select the row and choose Build Data Set > Include or Exclude.

   In data collections imported from XFRACAS:

   - Incidents with StateTime = 0 and StateFS = S (suspension) are automatically marked Ignore.
   - Incidents with StateTime < 0 are automatically marked Invalid.

4. Choose Transfer > Transfer to New Folio.
Follow the on-screen prompts to select the data type and map the SDW fields to columns in the new analysis folio.

**Tips for Mapping the Columns**

- **State F or S** (in Weibull++/ALTA) indicates whether a data point represents a failure (F) or suspension (S). If the data source field does not use the F and S codes, use the **Define Values as Failures/Suspension** area to specify which value(s) represents each state.

- **Event** (in RGA) indicates whether the data point represents a failure (F) that will be transferred for analysis, or some other event that will not be analyzed as a failure. When a data point is marked as a suspension (S) for transfer to RGA, it will be considered only if it affects the recorded system end time. For example, if the System End Time column indicates that the system was last inspected at 1,000 hours but there is a suspension for that system at 1,100 hours, the later time will be used in the folio.

- Time and quantity columns, such as **State End Time** and **Number in State**, can only be mapped to fields with a numeric data type (e.g., number, currency, etc.).

- **Classification** and **Mode** columns (in RGA) can be mapped to any SDW user-defined field that contains the data. (See [Extracting Data from XFRACAS](#).)
Chapter 18: Synthesis Data Warehouse

- **Subset ID** columns (in Weibull++/ALTA) or **Comment** columns (in RGA) allow you to choose multiple SDW fields to display in the same folio column. The data from the fields will be concatenated and separated by dashes (e.g., "Report Type – Category"). Use the check boxes to select the fields and then use the arrows to specify the order.

![Subset ID columns](image)

**SDW Dashboards**

This topic describes how to use the **Synthesis Dashboard utility** for exploring and presenting data from the **Synthesis Data Warehouse**. If an **SEP** web portal has been implemented for an enterprise database, users can also access SDW dashboards from any web-enabled device.

For static data collections, a variety of dashboard layouts can be predefined. For custom connections, there can be only one layout for each connection.

1. In Weibull++, ALTA or RGA, choose **Home > Synthesis > Synthesis Data Warehouse**.

2. Double-click the static data collection or custom connection that contains, or links to, the data you want to view in the dashboard.

3. On the Build Data Set tab, select which rows to include or exclude. (See **Building the Data Set**.)

4. If an appropriate dashboard layout has already been predefined, switch to the Dashboard Viewer tab or choose **Dashboard > Dashboard Viewer**. If multiple layouts are available, use the drop-down list at the top of the viewer to choose what to display.

5. If you need to create a new layout, choose **Dashboard > Dashboard Manager** (for a static data collection) or **Dashboard Designer** (for a custom connection).
(In a secure database, the Dashboard Layout Manager and the Dashboard Layout Designer are available only for users with the "Manage dashboard layouts" permission.)

For information on the data fields available for use in dashboard layouts for SDW data collections, see Data Fields for XFRACAS Data Collections.

**Tip:** For dashboards that are intended to be viewed in both desktop applications and the SEP web portal, it is recommended to use the Local Colors option on the Design tab of the Dashboard Layout Designer to save your preferred colors with the layout. The global colors definition may not be the same in both web and desktop.

### Custom Connections in the SDW

The Custom Connections feature in the Synthesis Data Warehouse allows you to create a live link to an external data source (Access, Oracle or SQL Server). This enables you to get data from your own custom and third-party databases for transferring to an analysis folio in Weibull++, ALTA or RGA, or for viewing in the SDW dashboards.

You can also get data directly from your own custom reports created in XFRACAS.

A custom connection data source always shows the latest information from the original database or report and you can only create one dashboard layout per connection. You can also use these connections to import data into a static Weibull++/ALTA or RGA data collection, if desired.

### Connect to an External Database

To create a live link to an external database:

1. Choose Manage Data Sources > Add Custom Connection > To External Database.

2. In the Add Custom Connection window:
   a. Enter the Display Name that will identify this custom connection in the SDW data source list.
b. Enter the connection settings for a **Microsoft SQL Server**, **Oracle** or **Access** database. (See [Connection Issues](#) below for more information about the **Use impersonation** option for SQL Server.)

c. After you have specified the database, the **Table Name** field shows a list of the available tables. Select the main one that contains the data you want to use in the SDW.

d. If you want to create aliases for column names, build a query that combines data from multiple tables or enter your own SQL, select the **Open Query Editor/Builder** check box.

e. If you want to create the dashboard layout for this data source immediately after defining the connection/query, select the **Open Dashboard Designer** check box.

f. Click **OK** to proceed.

3. If you selected to customize the query, you can use the Query Editor to type or paste your own query, or select a stored procedure. If you need further tools, click the **Run Query Builder** button. The Query Builder can serve three purposes:

   a. The bottom-center panel shows the fields that will be included in the data set. If desired, you can use the Alias column to change the names that will be displayed in the SDW grid and dashboard layouts.

   b. If the tables are linked by foreign keys, you can use the tool to build a query that combines fields from multiple tables.

   c. You can also enter your own SQL in this tool; select the **Allow SQL Editing** check box and type or paste your own query.

   When you are finished in the Query Builder, click **OK** to return to the Query Editor, where you can click **Finish** to save your changes.

4. If you selected to open the Dashboard Designer, you can use it to create a single **dashboard layout** for this data source.

If you want to change the query or create/modify the dashboard layout at a later time, select the custom connection in the data source manager and choose **Dashboard > Dashboard Designer**.

From within the Dashboard Designer window, choose **Home > Query > Edit** to customize the query.
Chapter 18: Synthesis Data Warehouse

Connection Issues
There will be a "connection failed" message if the database is not found at the specified name/location or if you don’t have permission to access it.

If your organization has implemented an SEP web portal, the administrator may need to take additional steps to make the dashboards visible to all users via the portal. For details, consult the print-ready implementation guide (*.pdf).

- **Oracle** - the password is stored with the custom connection; therefore, both the desktop applications and SEP web portal will attempt to connect in the same way for all users.

- **SQL Server** - the **Use impersonation** option in the custom connection allows you to enter a login for a one-time extraction to an SDW data collection, but this login is not saved in SDW.

  For subsequent attempts, the desktop applications will connect with the current user’s Windows login, whereas SEP will use the login that it uses to connect with the Synthesis repository (if the Synthesis repository is SQL Server) or with the IIS "application pool identity" (if the Synthesis repository is Oracle).

- **Access** - the SDW must have access to the folder where the database is stored. It is recommended to use the UNC pathname (e.g., \servername\foldername rather than P:\foldername) when you create the custom connection.

  The desktop applications will attempt to access the file with the current user’s Windows login, whereas SEP can only access files stored directly on the web server or in a network folder that can be accessed by its IIS "application pool identity."

Tip: For Access databases with the *.accdb file type, the dashboard can only be displayed if the database was created with the same version of Microsoft Office (32-bit vs. 64-bit) that is installed on each individual user's computer (for ReliaSoft desktop applications) or on the web server (for SEP).

To ensure that the dashboard will display regardless of which version of Microsoft Office is installed, use the *.mdb file type instead of *.accdb.

Connect to XFRACAS Report
Creating a custom connection to a predefined XFRACAS report enables you to use the SDW to view any type of XFRACAS data (not just data collections extracted for life data or repairable systems analysis). If an SEP web portal has been implemented for an enterprise database, users can also access the dashboards created for these reports from any web-enabled device.
Chapter 18: Synthesis Data Warehouse

Tip: For information about creating SDW reports in XFRACAS, see the "Report Builder" topic in the XFRACAS documentation.

To create a live link to an SDW report that has already been created in XFRACAS:

1. Choose Manage Data Sources > Add Custom Connection > To XFRACAS Report.

2. In the Select Report window, select any of the XFRACAS SDW reports that have been predefined in the database.

3. Click OK to load the data.

Import to a Static Data Collection

In the Synthesis Data Warehouse, a custom connection provides a live link to an external database or XFRACAS report, while a static data collection stores Weibull++/ALTA or RGA data that was extracted at a particular point in time.

A static data collection can contain data extracted directly from XFRACAS. If desired, you can also create a static Weibull++/ALTA or RGA data collection by importing data from a custom connection. To do this:

1. Right-click the custom connection in the data source manager and choose Import.

2. In the Import Data from Custom Connection window:
   a. The Map Data Source Fields to Columns section specifies which field from the custom connection will be mapped to a column that’s available in a Weibull++/ALTA or RGA data collection.
   b. The Define Values as Failures/Suspensions section displays all of the unique values from the field that is currently mapped to the State FS column. Specify whether each value should be considered a failure or a suspension.
   c. The Preview tab allows you to see what the data collection will look like based on your selections.

3. Click OK to create the static data collection.
Chapter 19: SEP Web Portal

If your organization implements an SEP web portal for an enterprise database, the entire team — including managers and colleagues who don't have ReliaSoft desktop applications installed — can access key analysis and project details from any web-enabled device.

SEP Dashboards
The personalized home page provides an intuitive, at-a-glance overview of the information you’re tracking via SEP, such as FMEA stats, actions, recent messages, reports, metrics and more. You can choose which tiles appear on your dashboard and change their order and settings. (See SEP Dashboards.)

Actions and Portal Messages
You can use SEP to create, view and edit the same actions and portal messages that are visible to you from the desktop applications. SEP also allows colleagues who don't use the desktop applications to stay up-to-date on assignments and team communication. (See Actions and Messages in SEP.)

Project Summary, Analysis Summaries and Project Plan
For each analysis project that you have permission to view, SEP provides a summary that includes metrics, assigned actions, attachments and other project details. It also displays summaries, plots and reports for selected analyses published to SEP from Weibull++/ALTA, BlockSim/RENO, RGA and Lambda Predict.

If your team is using the Project Planner in desktop applications, SEP shows a streamlined view of the project plan. Users can access this plan in SEP and update their progress for assigned actions. (See Projects in SEP.)

System Hierarchies and FMEAs
SEP enables users throughout your organization to view FMEAs, queries and reports that were created in XFMEA, RCM++ or RBI. This provides managers and others throughout your organization with convenient web-based access to the wealth of lessons learned and troubleshooting recommendations from your investment in these analyses. (See FMEAs in SEP.)
Chapter 19: SEP Web Portal

Metrics (Key Performance Indicators)
SEP shows all of the KPIs (metric resources) that have been created in desktop applications for the projects you have permission to view; no publishing is required. Quick visual indicators help you monitor performance and support decision making.

Monitored Reports
SEP can display a variety of custom reports and dashboards created in desktop applications. The "Watch" feature makes it easy to manage the specific reports you want to access quickly. (See Monitored Reports in SEP.)

SEP also shows all of the Synthesis Explorer or Synthesis Data Warehouse (SDW) dashboards that have been predefined in the desktop applications.

SEP Dashboards
The SEP home page features a dashboard that consists of a flexible layout of customizable “tiles.” These tiles provide convenient, personalized access to key information that you’re tracking in a variety of graphical and tabular formats.

New in Version 2019, the SEP dashboard offers many new types of tiles — and even more customization options.

Default Dashboard
The first time you open SEP, you'll see a dashboard that has been preconfigured with a default layout and tile settings — either the dashboard that ships with SEP or one that has been customized specifically for your organization. This becomes your own personal dashboard, which you can customize for your needs. After you open SEP the first time, you'll no longer have access to your organization's default.

Note: SEP Admin Page outlines the procedure that admin users can follow to create a custom dashboard for their organization.

To customize your dashboard, you can add, delete, move or resize tiles (see below) and/or change their settings (see Tile Settings).
Add, Delete, Move or Resize a Tile
Any changes you make are saved automatically.

Add a Tile
To add a tile to your dashboard:

1. Click the Add Tile button to open a popup window showing the available tile types.
2. Select one or more tile types.
3. Click Add.

You can filter the available tile types by category or use the search tool to find a tile based on its title or description.

Delete a Tile
To delete a tile from your dashboard, click the Delete icon.

Move or Resize a Tile
When you move or resize a tile, it “snaps” to the underlying grid, displacing other tiles as needed.

- To move a tile, drag and drop it onto a different position using the title bar.
- To resize a tile, click and drag one of its bottom corners.

Tile Settings
Each tile features a title bar that includes a set of icons:

- The Settings icon, , opens a dialog box where you can configure the settings that apply to the tile.
- The Maximize icon, , opens a popup window that contains an enlarged version of the tile.
- The Delete icon, , removes a tile from the dashboard.
- The Open Page icon, , is available for many types of tiles (e.g., My Actions and Recent Messages). Click this icon to open related SEP pages (e.g., My Actions and Messages).

The title bar also shows the tile's title (e.g., "My Actions"), which you can configure using the Settings dialog box.
Chapter 19: SEP Web Portal

Data Sources
Depending on its type, a tile may display:

- Data that's relevant to you and independent of any project (e.g., Recent Messages, My Projects).
- Data that originates from one or more specified desktop projects or XFRACAS entities.

**Tip:** My Projects includes all of the projects you have currently selected. (See Projects in SEP.)

For the following cases, the data source(s) will appear in parentheses in the tile's title bar:

- If the tile has a single data source (project or entity), it shows the name of this source.
- If the tile has multiple data sources that you have selected, it displays the number of sources (e.g., "3 projects").

**Tip:** To see a list of these sources, toggle a popup box by moving your cursor over the title bar.

- If the tile includes data from multiple sources that are relevant only to you, it displays "All projects," "All my entities," "My metrics," etc.

The title bar does not include a data source if it is not applicable for the tile type (e.g., Recent Messages, My Reports, My Projects).

Active and Selected Projects
Many tiles give you the option to display data for “active” or “selected” projects.

- The active project is the one that is currently selected on the Project Summary, Project Plan and FMEAs pages. Use the Change Project button on one of these pages to activate a project (see Projects in SEP). You can also "activate" a project by clicking its link in the My Projects tile, if this tile is included in your dashboard (see Projects Tiles).
- To display data for “selected” projects:

  a. Open the Settings dialog box and choose the Selected option from the Project drop-down list.
b. Click the Add button to display a list of projects that you have permission to view.

c. Select the desired project(s) and click OK.

To find projects more easily, you can use the search tool or apply any project filters that you have created in the desktop applications (see Project and Item Filters).

**Grid Tile Columns**
Use the Columns button to add or remove columns from grid tiles.

![Columns button](image)

See Working with Grid Tile Columns to learn how to move, resize, sort, filter and group columns.

**Selecting a Date Range**
Some tiles allow you to display data for a specified date range. For these tiles, the Settings dialog box provides options for selecting "custom" and "preset" date ranges.

**Custom Date Ranges**
The Custom option allows you to use the calendar tool to select start (From) and end (To) dates. Alternatively, you can type dates into these fields in the month/day/year format — e.g., 1/2/2019.

![Custom settings](image)

This option will display the data that is available for all dates within the selected range, including the start and end dates.

**Preset Date Ranges**
The Preset option allows you to display data for a specified number of past (Last) or future (Next) “calendar” periods — days, weeks, months, quarters and years. You can also select to display data for the current (This) calendar period.

- Weeks start on Sunday.
- Months start on the first and end on the last day — e.g., May 1–31.
- Quarters run from January 1 – March 31, April 1 – June 30, July 1 – September 30 and October 1 – December 31.
Chapter 19: SEP Web Portal

- Years cover the period from January 1 through December 31. For the number of periods, you must specify an integer ranging from 1 to 10000.

This displays data that is available for the current calendar period. For example, if today’s date is February 14:

- Selecting This and Month will show results for February; in this case, the results will cover the period from February 1–14 and include the current day.

- Selecting This and Year will show results for January and part of February. Note that selecting This automatically forces the number field to 1.

Last allows you to specify a past time interval. Choose the Last + Current option to include the current day, week, month, etc., in your results. For example, if today’s date is February 14:

- Selecting Last 2 Months will return results for the previous December and January.

- Selecting Last + Current 2 Months will return results for January and February.

- Selecting Last 3 Weeks will return results for the last full 3 weeks preceding the 14th.

- Selecting Last + Current 3 Weeks will return results for the last full 2 weeks preceding the 14th, plus the week that contains the 14th.

Next allows you to specify a future time interval and follows the same logic as the Last option. Choose the Next + Current option to include the current day, week, month, etc., in your results.

Tip: The tile will show the actual date(s) corresponding to your selection (e.g., "01-Jan-2019 to 31-Jan-2019," "From 01-Jan-2019," etc.).

Working with Grid Tile Columns
Starting in Version 19.0.2, SEP provides additional ways to sort, filter, and group columns in grid tiles.

Move or Resize Columns
- To move a column, drag and drop it into position using its heading.

- To resize a column, click and drag the right border of its heading.
Sort Columns

- To sort by a column, right-click its heading and select Sort Ascending or Sort Descending in the pop-up box that appears. Alternatively, you can click the column heading to sort in the descending direction. To reverse the sort order, click again.

- To clear a sort, right-click the column heading and select Clear in the pop-up box.

Filter by Columns

1. Click the Filter icon, , in the column heading. This opens a pop-up box with a list of all entries in the column.

2. Select one or more entries from the list by clicking the appropriate check box(es). You can also choose Select All or use the search tool to find items.

3. Click OK. The Filter icon, , will now change to a darker gray to indicate that one or more filters have been applied for that column.

Group by Columns

- Right-click the column header and select Group by This Column in the pop-up box.

- To undo the grouping, click the heading row within the grid and select either Ungroup or Ungroup All in the pop-up box. Alternatively, you can right-click any other column heading and select Ungroup All.
View Cell Content
Content that is too long to fit into a grid cell will be truncated, as indicated by an ellipsis. To view this content in its entirety, move your mouse over the cell to reveal a tooltip.

Tiles

Actions and Messages Tiles

Actions Tiles

My Actions Tile

The My Actions tile displays actions that are relevant to you and that are pending within the next 7 days, past due or ready for review. (See Action and Messages in SEP for a list of relevance categories.) These actions are grouped under headings that you can collapse or expand:

- Pending Approval
- Past Due
- Due Next 7 Days
- In Progress
- Past Start Date
Chapter 19: SEP Web Portal

- Start Today
- Start Tomorrow
- Start in Next 7 Days

To open the Edit Action page from the tile, click the description (blue link).

To specify which relevance categories to show and whether to display actions for active, selected or all projects, use the **Settings** dialog box.

To open the My Actions page, click the **Open Page** icon, 📚.

**Actions Grid Tile**

New in Version 2019, the Actions Grid tile displays a list of actions for one or more projects. You can apply various filters to these actions:

- **Project** - Options include **All, Active** or **Selected**. (See **Tile Settings**).
- **Person Responsible** - By default, this is set to **Any**, but you can click the text box to display a menu that allows you to select any or all of the people in the list, including yourself (**Me**). The **Unassigned** option is for actions that have not been assigned to anyone (the **Person Responsible** field was left empty in the desktop application or the Create Actions page in SEP).
- **Analysis** - By default, all options are selected, but you can choose **None, Project Plan** and/or **FMEA**. Select **None** for analyses that were created via SEP, My Portal or Resource Manager and have not been used in a project plan or an FMEA.
- **Planned Completion** - Select starting and ending dates to show only actions within that range. If you do not specify a date range, the grid will include actions for all dates.
- **Status** - Choose from **Past Due, In Progress, Not Started** and/or **Completed**.

You can also choose which columns to include in the grid and you can sort, move or resize them if desired. (See **Grid Tile Columns**.)

The project (if displayed) and action description appear in the tile grid as blue links; these links open the Project Summary and Edit Action pages.

**Note:** The Actions Grid and Actions Pie tiles can display a maximum of 50,000 records (the same number as the ReliaSoft desktop applications). If you are experiencing exceptionally long load times or time-outs, we recommend using the filters in the **Settings** dialog box to limit the number of results.
Chapter 19: SEP Web Portal

**Actions Pie Tile**

New in Version 2019, the Action Pie tile is a chart that displays the number and relative percentage of actions by:

- Status
- Person Responsible
- Project

The Settings dialog box provides options to filter these results by project, person responsible, analysis, planned completion date and status.

Note that the legend will only include persons or projects *without* actions if you filter by one or more specific persons or projects. For example, if you choose **Project** from the **Display By** dropdown list and then select **All** projects, the legend shows only those with actions. However, if you filter by one or more specific projects without actions, they appear in the legend as 0%. The same logic applies for the **Person Responsible** and **Status** options.

*Tip:* To highlight a pie "slice," move your pointer over a label in the legend.

**Recent Messages Tile**

This tile shows a specified quantity of the most recent messages from your Messages page. It includes the subject of the message, its author and the date created.

To view the message contents, move your cursor over the message to display a popup box. (See **Actions and Messages in SEP**.)

To open the Messages page, click the **Open Page** icon, ![Open Page](http://mpc.reliasoft.com).

**FMEA Tiles**

Starting in Version 19.0.2, the SEP dashboard now offers convenient tiles for viewing FMEA data. They help you monitor the potential failure causes identified in your FMEAs and track the progress of actions that are being taken to reduce risk. These tiles include:

- **Failure Causes Grid tile**
- **FMEA Stats tile**
- **FMEA Stats Grid tile**
Choose FMEAs to Display
You can configure tiles to show data from all FMEAs in a given project, or you can show data from one or more selected FMEAs.

1. Open the **Settings** dialog box and select a project:
   a. Choose **Active** or **Selected** from the **Project** drop-down list.
   b. If you choose the **Selected** option, click the **Add** icon, +, to select a project. (See **Tile Settings**.)

2. Select one or more FMEAs:
   a. Choose **Selected** from the FMEA drop-down list.
   b. Click the **Add** icon, +.
   c. In the **Add FMEA** dialog box, select the FMEAs you wish to display from the hierarchy.

   *Note:* Only parts or processes with FMEAs will have check boxes.

3. Click **OK** and **OK** again to save your configuration.

Choose Stats to Display
For some FMEA tiles, you must select which stats to display and specify their order.

1. Open the **Settings** dialog box.

2. In the **Stats to show** area, click the **Add** icon, +.

3. Select the stats you wish to display.
   a. If applicable, enable the **Show trend** option and specify a date range. (See **Selecting a Date Range**.)
To change the order of the stats, drag them to the desired position using the handle, 
.

4. Click OK to close the Add Stat dialog box. The stats should now appear in the Settings dialog box.

5. Click OK to save all your changes and close the Settings dialog box.

**Failure Causes Grid Tile**

This tile allows you to view a prioritized list of potential failure causes, along with the controls and actions that will mitigate the risks associated with these causes.

By default, the Failure Causes Grid tile displays data for all FMEAs in the active project. You can change the project and/or select one or more FMEAs via the Settings dialog box. (See Choose FMEAs to Display.)

**Choose Columns to Display**

This tile provides options for displaying ratings and/or metrics that have been enabled for the project.

To specify which fields to display, click the Columns button in the Settings dialog box to open the Column Chooser. If you choose to display the Cause, Actions or Project columns, the tile will include links that provide access to the following pages in SEP:

- **Cause** - opens the full FMEA, with that cause highlighted. Clicking the link in the FMEA opens a page showing the details of the cause. (See FMEAs in SEP.)

- **Action** - opens the Edit Action page. (See Actions and Messages in SEP.)

- **Project** - opens the Project Summary page. (See Projects in SEP.)

The Column Chooser also allows you to select which ratings and/or metrics to display — for example, initial or revised RPN (RPNi, RPNr), severity (Si, Sr), occurrence (Oi, Or), detection (Di, Dr), etc. (See RPNs and Related Metrics in the XFMEA/RCM++/RBI help to learn more about ratings and metrics.)

**Tip:** Only the ratings / metrics that have been enabled for the project will be "selectable"; all others will be grayed out.

**Show or Hide Priority Highlights**

To display the priority highlight colors that have been defined for the project, enable the Show priority highlights option in the Settings dialog box. (See Viewing FMEAs in SEP to learn more about priority highlights.)
The example below shows RPNs (initial and revised) with priority highlights.

<table>
<thead>
<tr>
<th>Cause</th>
<th>Controls</th>
<th>RPN</th>
<th>Actions</th>
<th>RPNr</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insufficient friction delivered by hand brake subsystem</td>
<td>All-Terrain braking system...</td>
<td>350</td>
<td>Develop analytical model...</td>
<td>80</td>
</tr>
<tr>
<td></td>
<td>All-Terrain bicycle stop...</td>
<td></td>
<td>Add rigorous tire durability...</td>
<td></td>
</tr>
<tr>
<td>Tire rupturing</td>
<td>Bicycle system durability...</td>
<td>343</td>
<td>Add tire reliability and durability...</td>
<td>210</td>
</tr>
<tr>
<td>Brake cable misadjusted by bicycle user</td>
<td>Bicycle system durability...</td>
<td>300</td>
<td>Revise the bicycle durability...</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Revise the design review...</td>
<td></td>
</tr>
<tr>
<td>Cable breaks</td>
<td>Cable material selection...</td>
<td>240</td>
<td>Require cable DFMEA analysis...</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>Bicycle system durability...</td>
<td></td>
<td>Based on results of Cable...</td>
<td></td>
</tr>
<tr>
<td>Excessive brake wear</td>
<td>Design review of brake system durability</td>
<td>210</td>
<td>Redesign brake lever to...</td>
<td>70</td>
</tr>
<tr>
<td>Wheel cross section too thin for anticipated impact load</td>
<td>No controls currently planned...</td>
<td>200</td>
<td>Perform wheel cross section analysis...</td>
<td>120</td>
</tr>
<tr>
<td>Corrosion of cable wiring due to wrong material selection</td>
<td>Cable material selection...</td>
<td>200</td>
<td>Perform a thorough review...</td>
<td>20</td>
</tr>
</tbody>
</table>

**FMEA Stats Tile**

This tile provides at-a-glance metrics for a single FMEA or a combined group of FMEAs. These metrics may include record counts and % analyzed, risk profiles and % reduction in RPN and new risks and actions incurred within a specified time period, among others.

- To change the project and/or select different FMEAs, use the **Settings** dialog box. (See [Choose FMEAs to Display](#).)

- To open the FMEA page for the selected project, click the **Open Page** icon, 

**Note:** All stats are calculated based on unique records within the given data set. If the same control, action and/or task resource appears multiple times in the selected FMEA(s), each unique record is counted only once. This also applies to records from linked FMEAs. (See [Resources](#) and [Linked FMEAs](#) in the XFMEA/RCM++/RBI help.)

**Failure Causes**

This stat is a count of the unique failure causes in the selected FMEA(s).
% Analyzed

This stat is the percentage of unique failure causes in the selected FMEA(s) that have been "analyzed." A cause is considered analyzed if it meets these conditions:

- It can be assigned to a risk priority level.
- Values have been assigned to all O and/or D ratings that have been enabled.
- All enabled risk metrics (RPN, SxO, SOD and/or SD) have been calculated. (See Interface Styles in the XFMEA/RCM++/RBI documentation.)
- If the FMEA structure is “causes before effects,” its effect has been defined and analyzed.

The percentage is calculated by summing all of the failure causes that meet these criteria and then dividing by the sum of all failure causes. (See FMEA Stats (Web Summary) for more information.)

Controls / Actions

This stat lists the number of unique controls and actions in the selected FMEA(s).

All Records

This stat is a simple count of the numbers of each type of record in the selected FMEA(s).

% Reduction in Total RPN

This stat indicates how much the risk priority number (RPN) for all failure causes in the selected FMEAs has decreased. Because the percentage will increase as you mitigate the risks in your design, the % reduction in the total RPN allows you to track the progress and effectiveness of your team’s actions.

It will only display if both the initial and revised RPN have been enabled for the project.
The % reduction in the total RPN is calculated as follows:

\[
\frac{\text{Sum of initial RPNs for all causes} - \text{Sum of current RPNs for all causes}}{\text{Sum of initial RPNs for all causes}} \times 100
\]

**Note**: "Current" always represents the most recently calculated metric for the failure cause. If a revised RPN is not calculated, the initial RPN is used to represent the "current" risk.

For example, if your selected FMEA contains three failure causes with the following RPNs, the % reduction would be calculated as follows: \((792 - 520) / 792 \times 100 = 34.3\%\)

<table>
<thead>
<tr>
<th>Cause</th>
<th>Initial RPN</th>
<th>Current RPN</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>512</td>
<td>240</td>
</tr>
<tr>
<td>2</td>
<td>216</td>
<td>216</td>
</tr>
<tr>
<td>3</td>
<td>64</td>
<td>64</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td><strong>792</strong></td>
<td><strong>520</strong></td>
</tr>
</tbody>
</table>
Chapter 19: SEP Web Portal

Causes are assigned to risk levels according to the "Highlight Priority Based On" setting in the project’s interface style. A priority of "unknown" indicates that a relevant risk ranking, rating or metric has not been defined for the cause. See Viewing FMEAs in SEP and RPNs and Related Metrics in the XFMEA/RCM++/RBI help.

To see the change between the initial and the revised / current values, enable the Show trend option.

Risk Profile with Action Status

This matrix provides an alternative to the Risk Profile stats.

- **Causes (Initial)** - the number of causes with an initial risk that falls within each risk priority level.

- **At Least 1 Action** - the percentage of causes in each risk level with at least one assigned action.

- **Actions Closed** - the percentage of actions assigned to causes in each risk level that are closed (completed and not pending approval). If this is not 100%, the tile also displays the planned completion date for the last open action.

- **Causes (Revised/Current)** - the number of causes where the revised / current risk falls within each risk priority level, along with the percent change from the initial risk. The arrow indicates whether this change represents an increase or decrease.

Risks and Actions by Period

This stat allows you to monitor risks and actions for a specified date range.
Chapter 19: SEP Web Portal

01-Jan-2019 to 30-Jun-2019

<table>
<thead>
<tr>
<th>New Causes</th>
<th>New Actions</th>
<th>Actions Due/Overdue</th>
<th>Actions Closed</th>
</tr>
</thead>
<tbody>
<tr>
<td>23</td>
<td>42</td>
<td></td>
<td>9</td>
</tr>
</tbody>
</table>

- **New Causes** - the number of failure causes with a “created date” that falls within the period.
- **New Actions** - the number of actions with a “created date” that falls within the period.
- **Actions Due/Overdue** - the number of actions with a planned completion date that falls within the period (“due”) or earlier (“overdue”) and no actual completion date.
- **Actions Closed** - the number of actions with an actual completion date that falls within the period and that are not “Pending Approval.” (See Review and Approve Actions in the help for the desktop applications.)

To select a period, use the **Custom** or **Preset** option in the date range chooser (see Selecting a Date Range).

If you are using the **Preset** option to specify a date range, you can choose to show the change since the last period by enabling the **Show trend** option in the **Settings** dialog box.

**Note:** The “last period” for the trend covers the same interval as the one you specify in the date range chooser. For example, if you specify a date range of “last 2 months” (such as May–June), the tile will show the change in risks and actions since the prior 2 month period (in this case, March–April). The **Show trend** option does not apply when you select “custom” dates such as 1-Oct-2018 to 31-Dec-2018.

---

**FMEA Stats Grid Tile**

The FMEA Stats Grid allows you to monitor selected stats for multiple FMEAs in a project within a single tile. It offers the same stats that are available in the FMEA Stats tile (except for "Risk Profile with Actions") but breaks them down by individual FMEA.

**All FMEAs Combined**

The row at the bottom of the grid shows the stats for All FMEAs Combined. Note that these combined stats consider unique records (see FMEA Stats tile). If the same resources and/or linked FMEAs appear multiple times within the combined data set, the values in this row will differ from the sum of the stats for the individual FMEAs. For example, in the grid shown below, “Assembly A” and “Assembly B” each include three causes from the same linked FMEA. Since these causes are counted only once, the value shown for the combined data set is 12, not 15.

---

01-Jan-2019 to 30-Jun-2019

<table>
<thead>
<tr>
<th>New Causes</th>
<th>New Actions</th>
<th>Actions Due/Overdue</th>
<th>Actions Closed</th>
</tr>
</thead>
<tbody>
<tr>
<td>23</td>
<td>42</td>
<td></td>
<td>9</td>
</tr>
</tbody>
</table>

- **New Causes** - the number of failure causes with a “created date” that falls within the period.
- **New Actions** - the number of actions with a “created date” that falls within the period.
- **Actions Due/Overdue** - the number of actions with a planned completion date that falls within the period (“due”) or earlier (“overdue”) and no actual completion date.
- **Actions Closed** - the number of actions with an actual completion date that falls within the period and that are not “Pending Approval.” (See Review and Approve Actions in the help for the desktop applications.)

To select a period, use the **Custom** or **Preset** option in the date range chooser (see Selecting a Date Range).

If you are using the **Preset** option to specify a date range, you can choose to show the change since the last period by enabling the **Show trend** option in the **Settings** dialog box.

**Note:** The “last period” for the trend covers the same interval as the one you specify in the date range chooser. For example, if you specify a date range of “last 2 months” (such as May–June), the tile will show the change in risks and actions since the prior 2 month period (in this case, March–April). The **Show trend** option does not apply when you select “custom” dates such as 1-Oct-2018 to 31-Dec-31-2018.

---

**FMEA Stats Grid Tile**

The FMEA Stats Grid allows you to monitor selected stats for multiple FMEAs in a project within a single tile. It offers the same stats that are available in the FMEA Stats tile (except for "Risk Profile with Actions") but breaks them down by individual FMEA.

**All FMEAs Combined**

The row at the bottom of the grid shows the stats for All FMEAs Combined. Note that these combined stats consider unique records (see FMEA Stats tile). If the same resources and/or linked FMEAs appear multiple times within the combined data set, the values in this row will differ from the sum of the stats for the individual FMEAs. For example, in the grid shown below, “Assembly A” and “Assembly B” each include three causes from the same linked FMEA. Since these causes are counted only once, the value shown for the combined data set is 12, not 15.
Chapter 19: SEP Web Portal

To select a different project and/or FMEAs, see Choose FMEAs to Display.

To select stats, see Choose Stats to Display.

**Note**: For this tile, you must specify the order of the columns in the Settings dialog box.

### % Reduction in RPN

If you choose to display **% Reduction in RPN**, the tile will include three columns — Total Initial RPN, Total Current RPN and % Reduction in RPN — assuming both the initial and revised RPN options have been enabled for the project. Dashes appear in grid cells in cases where no value has been assigned or when the % reduction cannot be calculated. See % Reduction in Total RPN in the FMEA Stats tile topic for more information about this stat.
Chapter 19: SEP Web Portal

Risk Profile

If you choose to display Risk Profile (Revised / Current), you can enable the Show trend option to show the changes from the initial risk rankings in the All FMEAs Combined row. (See Risk Profiles — Initial and Revised / Current in the FMEA Stats Tile topic for more information.)

Metrics and Reports Tiles

Metrics Tile
The Metrics tile allows you to monitor metrics that have been created in ReliaSoft desktop applications. (See Metrics.)

Use the Settings dialog box to specify one or more data sources:

- **My metrics** displays the metrics that you have selected to appear on your My Metrics page.
- **Active project** displays the metrics for the project that is currently active in SEP.
- **Selected projects** displays the metrics for one or more projects that you select.

You can also use the Settings dialog box to specify how many metrics to display in the tile.

To open a popup window that shows additional details such as a plot, calculated values and identifiers, click the name of the metric (blue hyperlink).

To open the My Metrics page, click the Open Page icon, in the title bar.

My Reports Tile
The My Reports tile displays links to reports that you are “watching” in SEP (via the My Reports page) and XFRACAS. For each report, the tile shows the name of the watch, a short description and, if applicable, the project and application names.

Use the Settings dialog box to specify one or more data sources:

- **My reports** displays all of your watched reports in SEP and XFRACAS.
- **Active project** displays your watched reports for the currently active project in SEP.
- **Selected projects** displays your watched reports for one or more projects that you select.

Choose from any or all of the following report types:

- **Dashboards**, which include FMEA, BlockSim simulation, project plan, Synthesis Explorer and Data Warehouse dashboards.
Chapter 19: SEP Web Portal

- **Spreadsheets**, which may be published from a Synthesis Workbook or from Lambda Predict or which may be the summary of an analysis published from Weibull++, ALTA or RGA.

- **Documents**, which are published from a Synthesis Workbook.

- **XFRACAS Reports and Charts**, if your XFRACAS and SEP sites are linked. (See SEP and XFRACAS to learn how these applications work together.)

You can also use the Settings dialog box to specify the how many reports to display in the tile. To open the report in a new browser tab, click the name of the watch (blue link).

To open the My Reports page, click the Open Page icon, in title bar.

**FRACAS Tiles**
If you use ReliaSoft XFRACAS, the SEP dashboard offers a convenient way to access information that's relevant to you. (See SEP and XFRACAS.)

**FRACAS Actions Grid Tile**
XFRACAS actions are managed separately from those originating from ReliaSoft desktop applications.

The FRACAS Actions grid lists open XFRACAS actions that you own.

New in Version 2019, you can now configure FRACAS Actions tile to display data for all of the entities that you have permission to view. You can also choose which columns to include in the grid (Entity, ID, Description, Due Date) and sort, move or resize them if necessary. (See Grid Tile Columns.)

To open an action in XFRACAS, click its description (blue link).

**FRACAS Incidents Grid Tile**
The FRACAS Incidents tile shows open XFRACAS incidents that you own.

You can choose to display incidents for just your default entity or for all of the entities that you have permission to view. You can also choose which columns to include in the grid (Entity, ID, Title, Description, Occurrence Date) and sort, move or resize them if necessary.

To open an incident in XFRACAS, click its description (blue link).
Projects Tiles

My Projects Tile
The My Projects tile displays a list of projects that you have selected for quick access in SEP. To modify this list, click the Change Project button on the Project Summary, Project Plan, or FMEAs page (see Projects in SEP).

Tip: Clicking a project name in this tile opens the Project Summary page in a new browser tab and makes that project "active" for other SEP tiles and pages.

Project Plan Tile
This tile summarizes the plan for either the active project or for one or more projects that you select. It displays:

- Plan status (past due, not started, in progress or complete)
- Start and end dates (planned or actual, depending on the data)
- A pie chart of actions, if any

Tip: To highlight a pie "slice," move your pointer over a label in the legend.

Actions and Messages in SEP
SEP lets you create, view and edit the same actions and messages that are visible to you from ReliaSoft desktop applications in My Portal. It also allows colleagues who do not use the desktop applications to stay up to date on assignments and team communication.

Tip: The action alert e-mails and portal messages generated by ReliaSoft applications can include links to view the action details in SEP. If these links are not working properly for your web portal, see SEP Admin Page.

My Actions Page
The My Actions page shows actions that are pending and are relevant to you for any of the following reasons:

- You need to review or approve the action.
- You are responsible for the action.
- You are a member of the team that is assigned to the action.
Chapter 19: SEP Web Portal

• You are monitoring the action.
• You created the action.

Working with the Actions Table
• To filter actions, type text into the Find box and press Enter. The table will populate with actions that contain this text in the visible fields.
• To group actions by a column, drag and drop the column heading onto the shaded panel.
• To change the column order, drag and drop the column heading into the desired position.
• To sort in ascending or descending order, click the Sort icon, ▲ .
• To apply a built-in filter (blanks, non-blanks or unique values), click the Filter icon, ☑.

Creating a New Action
• To add a new action in the project that is currently active, click Create Action.
• To create an action for a different project, you must first navigate to that project in SEP and then return to My Actions. (See Projects in SEP.)

Tip: The Project Summary, Project Plan and FMEAs pages also show actions for the active project; however, they include actions that are not directly relevant to you or that have already been completed.

Messages Page
The Messages page shows ReliaSoft portal messages that are relevant to you, sent to you, sent to a user group that you belong to or sent to all users. These are the same messages that you can view in My Portal in the desktop applications. (See Portal Messages.)

• To send a new message, click Create Message.
• To reply to an existing message (if applicable), click Reply.

Tip: You can also create a dashboard tile that shows a specified quantity of your most recent messages. (See Recent Messages Tile.)

http://mpc.reliasoft.com
Projects in SEP

In SEP, some pages, such as My Actions and My Reports, show data from any project that you have permission to view. Other pages display data only from the project that is currently active for you. These pages include:

- Project Summary
- Project Plan
- FMEAs

Select or Change Projects

For any page that shows data from a particular project, the Change Project button allows you to view that same type of data from another project. This button opens a popup box with a list of projects that you previously selected for quick access in SEP.

Tip: These projects also appear in the My Projects tile in the SEP dashboard.

To add or remove projects from this list, click Select Projects. In the Select Projects popup window, the right side shows your list of projects and the left side shows all the projects that you have permission to view.
You can apply any project filters that were created in ReliaSoft desktop applications or use the Find tool to search by project name.

Use the icons to add, remove or simply view projects:

- **Add to My Projects**
- **View Now** (i.e., view the project without adding it to your list)
- **Indicates that the project is already in your list.**
- **Remove from My Projects**

**Tip**: If you want to have quick access to the same set of projects while working in ReliaSoft desktop applications, you can create a project filter that filters based on Selected projects.

### Publishing to SEP

SEP does not display all of the analyses that were performed in ReliaSoft desktop applications. Instead, your team can decide which analyses to make available and publish selected analysis summaries and reports.

In the desktop applications, these features are only available when:

- You are connected to an enterprise database that has an SEP web portal implemented and the "Enable publish to SEP web portal" option is set to "Yes" for the database.
- You have the "Publish to SEP web portal" permission.
The types of data and analyses that can be published vary for each ReliaSoft application:

**Weibull++/ALTA**
- Life Data
- Non-Parametric LDA
- Life-Stress Data
- Weibull Degradation
- ALTA Degradation
- Parametric RDA
- Standard / Robust / Mixture / Free Form Design
- One Way ANOVA
- Linearity & Bias, Gage R&R, Gage Agreement
- Multiple Linear Regression
- Synthesis Workbooks

**RGA**
- Growth Data
- Synthesis Workbooks

**BlockSim/RENO**
- Analytical RBD, Simulation RBD
- Analytical Fault Tree, Simulation RBD
- Phase Diagram
- RENO Flowchart
- Continuous Markov, Discrete Markov
- Synthesis Workbooks

**Lambda Predict**
- Reports
- Stored Plots

**XFMEA, RCM++ and RBI***
- Reports (saved with the project)

*System hierarchy and FMEAs are also visible in SEP — no publishing is required.*

**Note:** If you have published analysis summaries and you see a "Link is not properly formatted" message when you attempt to open the original analysis from SEP, the link may be corrupted or using old encryption. Republish the analysis to refresh the link.

**Data Sheets or Diagrams**

To publish an analysis summary from Weibull++/ALTA, RGA or BlockSim/RENO, open the data sheet or diagram and click **Publish SEP Summary** on the Publishing page of the control panel. (For DOE design folios, the Data tab with analyzed response data must be selected.)
To publish a data sheet, you must also click **Publish SEP Summary** again in the preview of the spreadsheet summary.

After publishing, the panel displays "Synchronized" if the web version reflects the latest results from the analysis. If the analysis has been modified (e.g., if more data has been added, an analysis setting has changed, etc.), it displays "Out of Sync" and you will need to recalculate and republish to update the web portal.

To remove the summary from the web portal, click **Remove SEP Summary**.

**Synthesis Workbooks**

To publish a Synthesis Workbook from Weibull++/ALTA, RGA or BlockSim/RENO, open the module in the workbook that you want to share (spreadsheet or word processing document) and then click **Home > SEP > Publish Report**.

The status bar shows that the spreadsheet or document is visible via SEP and indicates when the web version was last updated.

If you subsequently make a change in the desktop application, you will need to republish to update the web portal.

If you want to remove the report from the web portal, open the module and click **Home > SEP > Remove Report**.

**Prediction Reports and Plots**

To publish a report for a standard item or block in Lambda Predict, select the item/block and choose **Prediction Tools > Share > Publish SEP Summary**.

In the Select Report window, select what to include in the report (e.g., template-based reports, default reports or plots) and click **OK**. (See **Lambda Predict Reports** in the Lambda Predict
There can be only one published report for each item/block. If you publish again for the same item, it will replace the report that was previously published.

To publish a stored plot from Lambda Predict, open the plot, then click the **Publish SEP Summary** icon on the **Publishing** page of the plot control panel.

The following example shows two published reports from the Power Amplifier Circuit folio and one published plot.

To remove a report from the web portal, select the standard item or block, then open the Publishing tab of the Properties panel and click **Remove SEP Summary**.

To remove a plot from the web portal, open the plot, then click the **Remove SEP Summary** icon on the Publishing page of the plot control panel.

**XFMEA/RCM++/RBI Reports**

To publish a report generated in XFMEA/RCM++/RBI, use the Reports window to build the document, select at least one of the **Save/Publish** file formats on the ribbon (Word, Excel, or PDF) and click **Generate Report**.
Chapter 19: SEP Web Portal

To see all of the generated report documents that have been saved with the project (and therefore will be visible via SEP), click Published Reports Manager. You can also use the manager to edit the name and description that will show in the web portal.

For more information, see Save/Publish Reports in the XFMEA/RCM++/RBI documentation.

FMEAs in SEP

SEP allows users throughout your organization to view FMEAs and published reports that were created in ReliaSoft XFMEA/RCM++/RBI — even if they don’t have the desktop applications installed. It includes convenient features that allow managers and stakeholders to track key FMEA details from any web-enabled device.

The FMEAs link in the menu opens the FMEAs page for the project that is currently active for you in SEP. This link also appears in the Project Summary page if the project contains FMEA data.

To view the FMEAs from a different project, click the Change Project button at the top of the FMEAs page.

Viewing FMEAs in SEP

On SEP’s FMEAs page, the Hierarchy View tab displays the system hierarchy in the left pane. The properties for the item selected in the hierarchy appear in the right pane, along with
FMEAs and FMEA statistics, if applicable. (See System Hierarchy and FMEA Analysis in the XFMEA/RCM++/RBI documentation.)

- The icon indicates that the item has an FMEA. If a change log has been activated for the FMEA, the name and status of the current version will appear in the system hierarchy, and the icon will indicate the state of the change log. (See FMEA Change Logs.)

- The icon indicates that the item is associated with an XFRACAS template part. (See SEP and XFRACAS to learn how these applications interact.)

To view the full analysis in a desktop application, click Open.

**Note:** Starting in Version 2019, the Open buttons are now only visible to users who have the "Open desktop apps from SEP web portal" permission (see Managing Security Groups).

**FMEA Stats**

The FMEA Stats sub-tab provides a quick, at-a-glance summary of key statistics and charts for the item that is currently selected in the system hierarchy. If you select an item that has both a system FMEA and component FMEAs, you can view a report that shows data for the system FMEA only or a report that combines data from all component FMEAs.

To learn more about this feature, see FMEA Stats (Web Summary).

**FMEAs**

The FMEA sub-tab displays the full analysis for the item that is selected in the system hierarchy.

- To view the full properties for a record in the FMEA hierarchy, click the link (blue text).

- To specify which columns appear for any FMEA that you view in SEP, click . This opens the Customize FMEA Columns dialog box. You can also specify the column order.

**Tip:** Gray text indicates that a column is unavailable for the current project.

SEP can display colors to highlight issues based on their priority. When enabled, these colors appear in the FMEA hierarchy and in query results for effects and causes (assuming the relevant column(s) are displayed). This feature uses configurable logic that is saved with each project. (See FMEA > RPNs in the XFMEA/RCM++/RBI documentation.)

To display the color highlights, select Enable priority highlights in the Customize FMEA Columns dialog box and click OK.
FMEA Stats (Web Summary)

The FMEA Stats report provides a summary of key statistics and charts for a single FMEA or a group of FMEAs that were created in the desktop applications.

To view this report, navigate to the FMEAs page for the project, click the Hierarchy View tab (if necessary) and select an item. If the report does not appear by default, click the FMEA Stats tab.

Tip: To get a link to this report from within XFMEA/RCM++ or RBI, select an item in the desktop system hierarchy and choose System Hierarchy > Current Item > Web Summary > Open in SEP or E-mail SEP Link.

Depending on the item, you may be able to select either or both of the following options using the check boxes in the FMEA Stats view:

- **Current Item** shows data from the selected item's FMEA.
- **Sub-Items** shows data from the FMEAs for the selected item's sub-items.

For example, if both system FMEA and component FMEAs are available, you can review a report for the system FMEA only or a report that combines the data from all of the component FMEAs.

FMEA Stats

The large numbers in the FMEA stats section indicate the quantity of each record type. When applicable, the stats also show the percentage of those records that have been "analyzed" or "completed."

Note: If a change log has been activated for an FMEA, the name and status of the current version will appear at the top of the FMEA Stats section. (See FMEA Change Logs.)

% Analyzed

The logic for calculating this stat depends on the project's configurable settings; however, in general, to be considered "analyzed," the FMEA branch must have at least one function, failure, effect and cause, with ratings assigned to the all metrics that have been enabled for the project. In addition, each cause must be able to have a risk priority assigned.

For example, if the project is configured to calculate both initial and revised RPN, a failure is considered analyzed if all of the following conditions are met:

- It has at least one effect and at least one cause.
• All of its effects have both initial and revised S.
• All of its causes have both initial and revised O and D.

See FMEA Stats Tile and FMEA Stats Grid Tile for more information about % Analyzed for failure causes.

*Note:* Starting in Version 19.0.2, % Analyzed is now calculated based on all possible risk ranking methods (except for QCPN) that have been enabled for the project — not just RPN.

**% Completed**
This stat applies to actions and indicates that an actual completion date has been entered.

**Top Failure Causes**
If the project is configured to use RPN and/or SxO, the report will display the top failure causes. Use the check boxes to specify whether you want to view a pareto (bar) chart based on RPN, SxO or both.

**Recommended Actions**
If the project is configured to include actions in the FMEAs, the report will display a list of the FMEA actions along with the following:

• A **Completion Status** pie chart based on the number of actions that are completed, in progress, not started or past due.

• A **Progress** bar based on the total planned duration, the actual duration for closed actions and the percent completed for open actions. For example, if Action 1 (duration = 3 days) is complete and Action 2 (duration = 2 days) is still in progress but marked 50% complete, the overall progress is 80% (4 out of 5 days).

**FMEA Reports, Dashboards and Queries**
SEP’s FMEAs page provides convenient access to published reports, dashboards and queries that have been generated in ReliaSoft desktop applications. (See FMEAs in SEP.)

**Published Reports**
The **Published Reports** tab displays reports (in Word, Excel or PDF format) that have been generated in desktop applications and saved with the project. This allows both desktop and SEP users to view and print the same report documents. (See Save/Publish Reports in the XFMEA/RCM++/RBI documentation.)
Chapter 19: SEP Web Portal

Dashboards
The Dashboards tab displays the dashboard layouts that have been predefined in desktop applications for FMEA data. Each dashboard can include data from all FMEAs in the current project. (See FMEA Dashboards in the XFMEA/RCM++/RBI documentation.)

To create a watch in SEP for a dashboard, click the Watch button. This adds the dashboard to the Reports page. (See Reports in SEP.)

Queries
The Queries & Data tab allows you to run queries that have been predefined in the desktop applications for item properties and FMEA data. It provides a way to quickly retrieve customized output — such as a list of incomplete actions, failure modes with high PRNs and more — based on the latest data from any analysis. (See Query Templates in the XFMEA/RCM++/RBI documentation.)

To filter the list of available query templates that SEP displays for the active project, use the Query Type and/or User drop-down lists.

- Public Queries shows only templates that are available to all database users.
- My Private Queries shows only templates that you personally saved.

Note: SEP only displays templates for items and FMEA data. It does not display queries for other types of analyses that are not visible in SEP, such as control plans or p-diagrams.

To run a query:

1. In the system hierarchy, select the item(s) that contain the data you want to query.
2. Identify the template you wish to use and click the Run button.
On the Results page, the top section displays a summary of the criteria that were defined in the query template.

- **Criteria match all rows** - an "AND" query that returns records that match all criteria
- **Criteria match any row** - an "OR" query that returns records that match any of the specified criteria

To sort by a field, click inside its column heading.

To save or share these results with others, use the **Save URL**, **Copy URL** and **E-mail URL** links at the top of the web page, or copy/paste the URL from the browser’s address bar.

**Export Query Results to Excel**
Starting in Version 19.0.2, you can export your query results to Excel. After you run your query, click **Export to Excel** on the Query Results page to download a file that you can open in Excel.

**FMEA Web Data Source**
Starting in Version 19.0.2, you can now use SEP as a web data source in an external reporting tool such as Excel or Power BI or in your own custom application. This service is designed for those who have specialized reporting needs that are not directly supported in SEP.

The FMEA web data source links to the fields, ratings and metrics that have been defined as part of the “interface style” for a project. (See **Interface Styles** in the XFMEA/RCM++/RBI help.)
Chapter 19: SEP Web Portal

1. In the **Queries & Data** tab on SEP’s FMEAs page, change the project (if necessary) and then select the FMEAs that you wish to include in your data set. You can select individual FMEAs from the hierarchy or use the **Select All** option to select all FMEAs in the project.

   **Note**: The number of FMEAs you can select is limited by the length of the generated link, which cannot exceed 2000 characters. If an error message appears indicating that you have selected too many items, try using the **Select All** option instead.

2. In the **Web Data Source** area, click either the **XML** or **JSON** button. This will open a pop-up box displaying the URL.

   - **XML** is the preferred method if you plan to use the data in a tool such as Power BI or Excel. Since these tools recognize XML data formats and relationships automatically, no additional steps will be required to prepare your data for reporting or visualization.
   - **JSON** may be preferable for certain custom programming applications.

4. Right-click to display a shortcut menu and click **Copy** to copy the URL for use in your reporting / visualization tool.

**Example: Using XML Data in Power BI**

Power BI is just one of the many tools that can use SEP as a web data source. In the following example, copy the link as described above and perform the steps listed below; this process is also similar for Excel.

1. Open Power BI and click **Get Data**.

2. In the **Get Data** dialog box, select **Other > Web** and click **Connect**.
3. In the **From Web** dialog box, paste the URL you copied from SEP and click **OK**.

4. Expand each of the tables you wish to include in your data set, select them and click **Load**.
5. Use the data to perform analyses and create visualizations.

6. Save your project so you can access this data later.

FMEA Change Logs
The FMEA change log is an optional feature that can be activated and managed via the desktop applications. (See Change Logs and Electronic Approval Tracking in the XFMEA/RCM++/RBI documentation.) If a change log has been activated for an FMEA, the name of the current version will show in SEP's system hierarchy, along with its status:

- **In Progress** - a revision to the analysis is currently in progress.
- **Locked** - the analysis is locked for editing and there are no assigned approvers.
- **Awaiting Review** - the analysis is locked for editing and one or more assigned reviewers still need to approve.
- **Approved** - the analysis is locked for editing and all of the assigned approvers have electronically recorded their approval.
• **Rejected** - the analysis is locked for editing and has been rejected by at least one assigned reviewer.

This information is visible to all users.

If you are an assigned reviewer for the current version and it is ready for you to review, the version name and status will appear as a link (blue text) that opens a dialog box where you can record your comments.

The FMEA icon will indicate the state of the change log:

- 🔄 An authorized user has started a revision.
- ⚒ The analysis is locked, and no revision has started.

**Reports in SEP**

SEP's My Reports page makes it easy to monitor selected dashboards and reports from ReliaSoft desktop applications and XFRACAS.
Tip: You can also configure the My Reports tile to display reports in your SEP dashboard. (See My Reports Tile.)

View Desktop Dashboards and Reports
SEP gives you access to custom dashboards and Synthesis Workbook reports for different types of data. For example, you can view the latest information from a particular project plan in any of the dashboard layouts that are currently available for that type of data. Likewise, when you review the Weibull++/ALTA, RGA or BlockSim/RENO analyses for a particular project, you can see any Synthesis Workbook reports (spreadsheets or documents) that were published to SEP.

Note: You can save, copy, or e-mail the URL for a desktop report that you are viewing in SEP using the links at the top of the page. These links allow you (or another user who has permission to view the data) to reopen it later. For desktop dashboards, the URL will display the latest data from the analysis using the latest version of the predefined layout. For workbook reports, it will display the latest published version of the report. (See Quick Links in SEP.)

Watch This Report
The "Watch This Report" feature makes it easier to manage the specific reports you want to access quickly.

To watch a report, navigate to it in SEP and click the Watch button or link, and then enter the name and description that will appear in your personalized list of "My Reports."

To see the list of reports you are currently watching in SEP, click Reports in the menu.
You can filter by name/description, project or report type.

To change the sort order:

1. Clear all filters.
2. Click to drag and drop the reports into the desired position.
3. Click Save.

**XFRACAS**

If your XFRACAS and SEP sites are linked, any reports you choose to watch in XFRACAS will also appear in SEP. The XFRACAS and SEP watches are not synchronized after they are created, so deleting the watch in one application will not affect it in the other. (See SEP and XFRACAS.)

**Quick Links in SEP**

The Quick Links feature allows you to create your own personalized list of links within SEP.

**Link to a Page in SEP**

To create a link to a page in SEP (for quick access to a particular project summary, FMEA system hierarchy, assigned action, report, etc.), navigate to the page and then click the Save URL link at the top-right corner of the page. You will be prompted to specify the name that will appear in your list of quick links.

You can also use the Copy URL and E-mail URL links or copy/paste the URL from the browser’s address bar.

**Link to an External Website**

To create a link to an external website (e.g., a company intranet, document management system, etc.):
Chapter 19: SEP Web Portal

1. Click **Quick Links** in the SEP menu to open the Quick Links page.
2. In the **Add New Link** section, specify the name and URL.
3. Click **Save**.

![Add New Link](image)

*Note: URL links can only point to a web address — not a network share path.*

**Remove or Rename a Link**

To remove a link or change the name that appears in the menu:

1. Click **Quick Links** in the SEP menu to open the Quick Links page.
2. In the **Manage Current Links** section, change display order, edit the link name or delete the link. For online links, you can also edit the URL.
3. Click **Save**.
SEP and XFRACAS

XFRACAS is a highly configurable, web-based, failure reporting, analysis and corrective action system (FRACAS) with integrated capabilities for part tracking, root cause analysis and team-based problem resolution. If your organization implements both the SEP and XFRACAS websites for the same enterprise repository, SEP can include links to the following types of XFRACAS records:

- **Actions and incidents** that you “own”
- **Observed occurrences** of incidents, failure analysis reports and/or problems that are associated with an item or failure mode in an FMEA
- **Reports and charts** that you have selected to “watch” in XFRACAS

**Tip:** The links between SEP and XFRACAS must be configured in XFRACAS by an admin user (Admin > Configure > Preferences). In the System-Wide Preferences section, set the **Synthesis - Display Synthesis Enterprise Portal (SEP) Command** to TRUE and specify two servers: **XFRACAS Server - IIS Prefix** (e.g., servername/XFRACAS) and **Synthesis Enterprise Portal Server - IIS Prefix** (e.g., servername/SEP).

XFRACAS Actions and Incidents

Two SEP dashboard tiles — the FRACAS Actions Grid and the FRACAS Incidents Grid — allow you to view the XFRACAS actions and incidents that you own. (See FRACAS Tiles.)

**Tip:** You can also show ReliaSoft desktop actions in your XFRACAS portal, if desired. Open the Portal Preferences page in XFRACAS and configure the **Display My Open Synthesis Actions** option.
Field Failure Reports (Observed Occurrences)
SEP’s FMEAs page provides convenient access to field failure reports from XFRACAS. (See FMEAs in SEP). If your organization chooses to associate template parts and failure modes in XFRACAS with items and failure modes in XFMEA/RCM++/RBI, SEP will display the following:

- All FRACAS records that are relevant for a given part
- Quantities of “observed occurrences” for failure modes that correspond to specific parts

See Import or Sync from XFRACAS in the XFMEA/RCM++/RBI documentation for information on creating associations for parts and failure modes.

View All Records for an Item
To view all XFRACAS incidents, problems or failure analyses that have been reported for a specific item:

1. Navigate to the FMEAs page and select the Hierarchy View tab (if necessary).
2. Click the icon next to the item in the system hierarchy.

This opens a pop-up box showing all XFRACAS records for items that are identified as the "Responsible Part" for an incident, the "Part Category" for a problem or the "Repaired/Replaced Part" for a failure analysis.

- Click the record number to open the incident, problem or failure analysis in XFRACAS.
- Click View Report to open the report in XFRACAS.
Note: The XFRACAS reports that you open from SEP are based on the standard templates defined in XFRACAS for incidents, problems and failure analyses. However, SEP adds query criteria to retrieve results for a particular item and/or failure mode. Since these criteria are not saved with the template, you cannot "watch" the report, nor can you use the URL for the results page to regenerate the same results; instead, you must click the link within SEP.

View Records for a Failure Mode
To view the quantity of XFRACAS records that have been reported for a failure for a specific item, make sure the Observed Occurrences column is displayed in the FMEA hierarchy. (See FMEAs.)

![Table with columns: Description, Observed Occurrences, Incidents = 1, Problems = 1, Failure Analyses = 1]

To open a pop-up box that contains links to the records and reports for a particular failure, click the Observed Occurrences links.

XFRACAS Reports and Charts
The watch feature in XFRACAS provides a quick, convenient way to access the XFRACAS reports and charts that you use most often (e.g., incident count by responsible part, all open incidents for a particular system, etc.).

When SEP and XFRACAS are linked, watches are created automatically in SEP for any reports or charts that you choose to watch in XFRACAS; however, these watches are not synchronized after the original creation. If you later delete the watch in XFRACAS, it will not update in SEP. Likewise, if you later delete or rename the watch in SEP, it will not change the original watch in XFRACAS.

Configure SEP

SEP Admin Page
The SEP Admin page allows you to enable and configure options for your organization’s SEP implementation. To access this page, click the SEP Admin link in the top-right corner of the portal.
Chapter 19: SEP Web Portal

**Note:** To learn what’s required to set up an SEP web portal, consult the print-ready Implementation Guide (*.pdf). It describes how to perform many tasks that require IT expertise, including how to establish database and web server(s), install the website, connect to a ReliaSoft database and create user accounts. These tasks should be completed before you make changes to the SEP Admin page.

Be sure to click the **Save** button, whenever you make changes on the SEP Admin page. This button is located in the upper-right corner of the page.

**Enable Publish to SEP Web Portal**
Some SEP-related features in ReliaSoft desktop applications (e.g., the ability to publish analysis summaries, workbooks, reports, etc.) will be visible only if the Enable publish to SEP web portal option is enabled for the database. You can set this from the SEP Admin page or from the Repository Settings window in any ReliaSoft desktop application.

**Configure Custom Content for the Home Page**
Use the optional "custom content" feature to integrate a banner or other content into your organization's SEP home page. If custom content is enabled for a database, it will be visible to all SEP users. There are two ways to implement this feature:

- Edit the SEPDefault.htm file, which is installed in the CustomContent folder under the root directory for the website. In this case, you must enable the Use SEPDefault.htm on the application server option.

- Enable the Use a page from another website (HTTP only) option and specify a URL.

**Note:** If the content of the page exceeds the specified height in pixels, users with iOS devices will not be able to scroll.

**Customize a Default Dashboard for New Users**
SEP ships with a default dashboard that you can customize for new users in your organization by modifying the layout and tile settings. This allows you to give users access to meaningful data the first time they open SEP. Once the user opens the dashboard, they no longer have access to the original one that you created.

1. Under **Configure the default dashboard**, select Default dashboard for new users in the Currently active on your home page drop-down list and click the **Save** button.

2. Navigate to the SEP Home page, where you should see a note confirming that you are editing the default dashboard for new users.

3. Modify the tile settings and layout to create the custom dashboard. (See SEP Dashboards). Note that dashboard changes are saved automatically.
4. Navigate back to the SEP Admin page.

5. Under **Configure the default dashboard**, select **Your personal dashboard** in the **Currently active on your home page** drop-down list and then click the **Save** button.

**Allow Aqira Users to Access SEP**

nCode Aqira by HBM Prenscia allows your organization to manage and share nCode fatigue and durability analyses via the web. Aqira users are entitled to access the SEP web portal without requiring an SEP license seat. To provide this access:

1. Enable **Allow Aqira users to log in to SEP**.

2. Under **nCode Aqira**, specify:

   • **Aqira URL** (e.g., http://servername/aqira/)
   • **Aqira admin username**
   • **Aqira admin password**

3. Click the **Test Aqira Login** button. If the settings are valid, the page will display “Success” after the test completes.

When this feature is enabled, SEP’s menu will include a link to the Aqira login page. In addition, when an active Aqira user attempts to access SEP, the application will check for a ReliaSoft user account.

- If an account does not exist, it will be created automatically with the “Aqira” security group. (This group will always have at least “read” access to projects that use “repository-level security.” Any user with permission to edit security groups in ReliaSoft desktop applications can change these permissions to fit your needs.)

- If an account exists and is active, the user can access SEP with the permissions specified for the existing account.

- If an account exists but is inactive, the user cannot access SEP.

**Configure URLs for Links to Actions in SEP**

ReliaSoft applications generate action alert e-mails and portal messages that can include links to view the action details in SEP. They build these links based on the settings specified on the SEP Admin page.

- **SEP server - IIS prefix** - enter the server name and folder that you see in the browser’s address bar (e.g., servername/SEP).

- **Website uses SSL (https for URLs)** - select **Yes** if the web server has been configured with a Secure Socket Layer (SSL) certificate and the URLs need to start with "https" rather than "http."
Chapter 19: SEP Web Portal

If an administrator has not specified an IIS prefix, the alerts will not include links to SEP.

If these settings are incorrect, the links attached to the action alerts will give an error message when users click them to open the page in a web browser (e.g., "File or directory not found," "Access forbidden" or "This page can't be displayed").

**Configure the Service for Alerts**

Any ReliaSoft database can be configured to send alerts when an action is created, modified or ready for review. These alerts, which are sent to any user who is subscribed to "watch" the action, can be delivered via e-mail, SMS text message or portal message, depending on the user's preference. (See [Watches and Alerts](#).)

If an optional service is running on the SEP web server, you can send additional alerts based on calendar date. This service must be started by an IT admin using the procedure outlined in the Implementation Guide.

- To check the current status of the service, go to the **Send action alerts based on calendar date** section of the SEP Admin page. The **Service Status** indicates whether the service was Running, Not Running or Not Found at the time when the page loaded.

- To configure the service, do the following:
  1. Enable the **Alert when action is due in X days** option and enter the number of days before the action completion date (due date) to send the first alert.
  2. Specify a **From address for e-mail alerts**.

- To send regular reminders, enable the **Remind every X days until the action is complete** option and enter the number of days between alerts.

**Configure the Open Buttons**

**Configure the Database Connection**

When users view published analysis summaries and FMEAs in SEP, the **Open** buttons make it easy for them to open the full analysis in a relevant desktop application.

If your applications connect to an Oracle database, the **Open** buttons use the same connection as the SEP portal.

If your applications connect to a SQL Server database, you can choose one of the following options under the **Database connection for Open buttons (SQL Server only)** section:

- **No impersonation** - the buttons will attempt to connect using the domain\username that is currently logged in to Windows. This requires an individual or group login. (See [SQL Server Logins or Using Windows Impersonation](#).)
• **Same as SEP configuration file** - the buttons will use the same impersonation account as the web portal. (See “Establish a Service Account for the Application” in the Implementation Guide.)

• **Specify impersonation account for Open buttons** - the buttons will use the impersonation account that you specify. In this case, you must provide a domain name, user name and password for the account.

**Note**: Starting in Version 2019, these buttons are now only visible to users who have the "Open desktop apps from SEP web portal" permission. (See [Managing Security Groups](#).)

---

**Enable Remote ReliaSoft**

Remote ReliaSoft allows ReliaSoft desktop applications to run on a remote server, eliminating the need to install and update software on client computers. If Remote ReliaSoft is enabled for your implementation, users can choose whether to launch desktop applications remotely or locally when they click **Open** buttons. (See [SEP User Preferences](#).)

Remote ReliaSoft must be configured for your organization by an IT admin who has experience using Microsoft Remote Desktop Services (RDS). The IT admin must also create an RDP template and make this available to you. Instructions for these tasks are provided in the Implementation Guide.

Once Remote ReliaSoft has been configured, you can enable it on the SEP Admin page:

1. Under **Remote ReliaSoft**, click **Browse** to find the RDP template and then click the **Save** button to upload it to the database.

2. Click **Test Remote ReliaSoft**. Depending on your browser settings, this will either download or open an *.rdp file or prompt you to choose. When you open the file, the ReliaSoft Launcher should run on the remote server.

3. After you confirm that the template is working properly, enable the **Open applications via Remote Desktop Services (RemoteApp)** option.

4. Click the **Save** button again.

**SEP Error Log**

This utility allows you to export an error log in *.csv format for troubleshooting and maintenance purposes.

**Assign SEP Access to Users**

Once user accounts have been created for the desktop application(s), you can use the SEP Admin page to specify who can access the web portal. (See [Managing User Accounts](#).) Scroll down to the **Select SEP Users** section and select any user accounts that will have access to SEP.
Check the counters above the user table to determine how many more SEP users are allowed under your current license.

<table>
<thead>
<tr>
<th>Show All</th>
<th>Show SEP Only</th>
<th>Show non-SEP</th>
<th>Find</th>
</tr>
</thead>
</table>

Your SEP license allows up to 100 website users. Current number of SEP users: 23

**SEP User Preferences**
The User Preferences page in SEP allows you to manage your own personal preferences.

Click your name in the top-right corner of the portal to open the page.

**Interface Language**
Use the drop-down list to choose any of the languages that are available for ReliaSoft desktop applications. This will update the interface labels, but the data and configurable settings that have been entered by users will remain in the original language — for example, this includes (but is not limited to):

- Names, descriptions, identifiers and remarks that are entered by users
- Action property labels that are configurable within each project
- Published analysis summaries and reports
- System hierarchies and FMEA data

**First Active Project**
This setting determines which project will be displayed first for SEP features that show information from a particular project (e.g., project plan, project summary, FMEAs or new actions). You can choose:

- The last project used in any ReliaSoft application
- The last project set/used in the SEP web interface

You can use the **Change Project** button and "My Projects" feature any time to change the project that is currently active in SEP.
Chapter 19: SEP Web Portal

**Receive Automated Alerts**
These are the same options that you can set from the User Login and Contact Information window in a ReliaSoft desktop application. (See *Watches and Alerts*.)

Note that alerts via e-mail and SMS text are available only if a valid SMTP server has been defined for the database and your user account has an e-mail address/SMS contact defined. (See *Enable Alerts via E-mail or SMS*.)

**Number of Decimals for Metrics**
This preference determines how many decimal places will be used in the metric element on SEP web pages. If you are also using ReliaSoft desktop applications, this may be different than your preference in the Application Setup (*File > Application Setup*).

**Open Buttons**
When you view published analysis summaries and FMEAs in SEP, the **Open** buttons make it easy to open the full analysis in a relevant desktop application. Starting in Version 2019, these buttons will display only if you have the required permission.

If the Remote ReliaSoft feature is enabled for your implementation, you can choose whether to launch the applications remotely or locally. (See *Configure Remote ReliaSoft*.)

- **Remote ReliaSoft** launches applications that are installed and activated on a remote server.
- **ReliaSoft Locator Links** generates link files that you can either save or open if the application is installed and activated on your computer.

*Tip:* To reduce the number of prompts, you can configure your web browser to always open *.rdp* files with the ReliaSoft Launcher and to remember your login credentials for the remote server.
END USER LICENSE AGREEMENT

Click Wrap Agreement at time of product installation

BY INSTALLING THIS SOFTWARE OR BY CLICKING THE “I ACCEPT” BUTTON AND ACCEPTING THIS LICENSE IN ACCORDANCE WITH SECTION D (LICENSE ACCEPTANCE PROCEDURES) YOU AGREE TO THE TERMS OF THIS LICENSE WHICH WILL BIND YOU, THE COMPANY ON WHOSE BEHALF YOU ARE ENTERING INTO THIS LICENSE AGREEMENT, AND ITS EMPLOYEES, AS APPLICABLE.

THIS LICENSE AGREEMENT IS A LEGAL AGREEMENT BETWEEN HBM UNITED KINGDOM LIMITED (AN AFFILIATE OF HBM PRENSCIA INC.), A COMPANY INCORPORATED IN THE UNITED KINGDOM, WHOSE REGISTERED NUMBER IS 1589921 AND WHOSE REGISTERED OFFICE IS AT TECHNOLOGY CENTRE, ADVANCED MANUFACTURING PARK, BRUNEL WAY, CATCLIFFE, ROTHERHAM S60 5WG (THE “LICENSOR”) AND THE END USER LICENSSEE OR ITS REPRESENTATIVE/AGENT AUTHORIZED TO BIND THE END USER LICENSSEE (REFERENCED HEREIN AS “YOU” OR “YOUR”).

PLEASE READ THIS CAREFULLY BEFORE USING THE SOFTWARE PRODUCT

A: BACKGROUND
   
   THIS LICENSE AGREEMENT SHALL BE BETWEEN YOU AND THE LICENSOR REGARDLESS OF WHETHER YOU HAVE PURCHASED THE SOFTWARE PRODUCT DIRECTLY FROM THE LICENSOR OR AN AUTHORIZED RESELLER AS SET OUT BELOW.

   THE LICENSOR APPOINTS EXPERIENCED PROVIDERS OF SOFTWARE RESALE SERVICES WHO DISTRIBUTE THE SOFTWARE PRODUCT TO END USERS (“AUTHORISED RESELLER”). IF YOU HAVE PURCHASED THE SOFTWARE PRODUCT AND ANY ASSOCIATED SUPPORT AND MAINTENANCE SERVICES FROM AN AUTHORIZED RESELLER, SUCH PRODUCTS AND SERVICES WILL BE PROVIDED DIRECTLY TO YOU BY THE RELEVANT AUTHORIZED RESELLER AND ALL PAYMENTS SHALL BE MADE TO THE AUTHORIZED RESELLER ON THE AUTHORIZED RESELLER’S TERMS AND PRICES.

   IF YOU HAVE PURCHASED THE SOFTWARE PRODUCT AND SUPPORT AND MAINTENANCE SERVICES DIRECTLY FROM THE LICENSOR, SUCH SUPPORT AND MAINTENANCE SERVICES WILL BE DEALT WITH IN A SEPARATE AGREEMENT BETWEEN YOU AND THE LICENSOR AND ALL PAYMENTS WILL BE MADE TO THE LICENSOR AND GOVERNED BY THE LICENSOR’S TERMS OF SALE.

B: PROPERTY OF LICENSOR

   THE LICENSOR, OR, WHERE APPLICABLE, THE RELEVANT MEMBER OF THE LICENSOR’S CORPORATE GROUP, IS THE ENTIRE LEGAL AND BENEFICIAL OWNER OF CERTAIN SOFTWARE PRODUCT(S) (THE “SOFTWARE PRODUCT”) AS SET OUT IN THE QUOTATION OF INFORMATION, WHICH SHALL ALSO INCLUDE YOUR LICENSE KEY, SENT TO YOU BY EMAIL EITHER BY THE LICENSOR OR, IF YOU HAVE PURCHASED THE SOFTWARE PRODUCT FROM AN AUTHORIZED RESELLER, BY THE AUTHORIZED RESELLER (“QUOTATION”). THE LICENSOR IS WILLING TO GRANT YOU A LICENSE TO USE THE SOFTWARE PRODUCT ONLY IF YOU ACCEPT ALL THE TERMS AND CONDITIONS SET OUT BELOW.

C: LICENSE TO BE GRANTED

   THE LICENSOR IS PROPOSING TO GRANT YOU ONE OF THE FOUR FORMS OF LICENSES IN RESPECT OF THE SOFTWARE PRODUCT. THE DETAILS OF EACH FORM OF LICENSE ARE SET OUT IN CLAUSES 2.1 AND 3 BELOW. THE FORM OF LICENSE THAT IS PROPOSED TO BE GRANTED TO YOU IS SET OUT IN THE QUOTATION. THE QUOTATION FORMS PART OF THE LICENSE AGREEMENT AND BY ACCEPTING THE TERMS OF THE LICENSE YOU ARE ACCEPTING THOSE TERMS IN THE QUOTATION. IF YOU HAVE NOT RECEIVED THE
QUOTATION FROM EITHER THE LICENSOR OR FROM THE AUTHORISED RESELLER (IF YOU HAVE PURCHASED THE SOFTWARE PRODUCT FROM AN AUTHORISED RESELLER) AT THE DATE HEREOF OR IF ANY DETAILS WITHIN THE QUOTATION ARE INCORRECT THEN YOU SHOULD FOLLOW THE "LICENSE REJECTION PROCEDURES" SET OUT AT PARAGRAPH E BELOW AND IMMEDIATELY CONTACT THE LICENSOR OR THE AUTHORISED RESELLER (AS APPLICABLE).

D: LICENSE ACCEPTANCE PROCEDURES

BY CLICKING ON THE ACCEPTANCE BUTTON WHICH FOLLOWS THIS LICENSE AGREEMENT (MARKED “I ACCEPT”), YOU INDICATE ACCEPTANCE OF THIS LICENSE AGREEMENT AND THE LIMITED WARRANTY AND LIMITATION OF LIABILITY SET OUT IN THIS LICENSE AGREEMENT. SUCH ACCEPTANCE IS ON YOUR OWN BEHALF, IF YOU ARE AN INDIVIDUAL, AND ON BEHALF OF ANY CORPORATE ENTITY WHICH EMPLOYS YOU OR WHICH YOU REPRESENT (“CORPORATE LICENSEE”) IN ENTERING INTO THIS LICENSE AND YOU WARRANT THAT YOU HAVE THE NECESSARY AUTHORITY TO BIND THE CORPORATE ENTITY IN THIS RESPECT OR THAT THE AUTHORISED REPRESENTATIVES OF THE CORPORATE ENTITY ARE AWARE OF YOUR ACCEPTANCE OF THIS AGREEMENT ON ITS BEHALF. IN THIS LICENSE AGREEMENT, “YOU” REFERS TO THE LICENSEE, ANY SUCH CORPORATE LICENSEE, OR BOTH, AS A COMMON SENSE INTERPRETATION OF THE RELEVANT SECTION DICTATES.

E: LICENSE REJECTION PROCEDURES

IF YOU DO NOT ACCEPT THESE TERMS AND CONDITIONS, YOU SHOULD CLICK ON THE “I DO NOT ACCEPT” BUTTON, DELETE THE SOFTWARE PRODUCT FROM YOUR COMPUTER AND PROMPTLY (AND IN ANY EVENT, WITHIN 14 DAYS OF RECEIPT) RETURN TO THE RESELLER (A) ANY MEDIA; AND (B) ANY OTHER ITEMS PROVIDED, THAT ARE PART OF THIS PRODUCT.

F: OTHER AGREEMENTS

IF THE LICENSOR HAS EXPRESSLY AGREED WITH YOU IN WRITING THAT YOUR USE OF THE SOFTWARE PRODUCT IS GOVERNED BY A PRIOR EXECUTED LICENSE AGREEMENT WITH THE LICENSOR, SUCH AGREEMENT SHALL APPLY INSTEAD OF THE FOLLOWING TERMS AND CONDITIONS TO THE EXTENT THAT THEY CONFLICT.

YOU SHOULD PRINT A COPY OF THIS LICENSE AGREEMENT FOR FUTURE REFERENCE.

LICENSE AGREEMENT

1. Ownership of Software Product and Copies

1.1 The Software Product and any printed materials or electronic documentation accompanying the Software Product ("Documentation") are copyrighted works of authorship, and are also protected under applicable database laws. The Licensor, or, where applicable, the relevant member of the Licensor's corporate group, retains ownership of the Software Product and all subsequent copies of the Software Product, regardless of the form in which the copies may exist. This License Agreement is not a sale of the original Software Product or any copies.

2. Commercial License

2.1 In consideration of You agreeing to abide by the terms of this License Agreement and payment of the applicable License fees either to the Licensor or, if You have purchased the Software Product from an Authorised Reseller, to the Authorised Reseller (as specified in the Quotation), the Licensor hereby grants to You a personal, non-exclusive, and (unless expressly agreed otherwise by the Licensor in accordance with clause 5.1) non-transferable License to use the Software Product and the Documentation on the terms of this License Agreement. The License shall take one of the following forms, and shall be set out in the
Quotation:

(a) Annual License:

(i) Duration – this License shall continue for a period of 12 months (“Initial Period”) from the date of delivery of the Quotation (“the Delivery Date”) and, provided that You have paid all applicable renewal fees, from year to year thereafter unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

(ii) Termination – You must give the Licensor 90 days’ written notice prior to the anniversary of the Delivery Date, such notice not to expire before such anniversary date.

(b) Perpetual License:

(i) Duration – this License shall continue for a period of 25 years from the Delivery Date unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

(ii) Conversion - this License may be converted to a Token Based Annual License, upon application to either the Licensor or the Authorised Reseller (if You have purchased the Software Product from an Authorised Reseller), and payment of an additional fee to the Licensor or the Authorised Reseller (as applicable), which shall be additional to the fees paid or payable in respect of any maintenance and support services provided by either by the Licensor or the Authorised Reseller (if You have purchased the Software Product from an Authorised Reseller). You may reverse this conversion to the same terms as agreed in the Perpetual License at the anniversary of the conversion by giving the Licensor 90 days’ written notice prior to the anniversary of the Delivery Date, such notice not to expire before the anniversary of the Delivery Date.

(c) Token Based Annual License (referenced in the Quotation as a Prenscia Access System, CDS, CRS, or CDRS License):

(i) Subject to the terms and conditions of this License Agreement, You may access any of the Software Product in the Quotation at any one time and in any combination up to the number of subscriptions granting You access to the Software Product for simultaneous use by You and purchased by You pursuant to this Agreement (“Access Credits”). You may add additional Access Credits which shall be charged in accordance with either the Licensor’s prices or the Authorised Reseller’s prices (if You have purchased the Software Product from an Authorised Reseller). Such increase in Access Credits shall apply to the following 12 month period, unless You give the Licensor or the Authorised Reseller (as applicable) written notice at least 90 days in advance of the expiration of the Initial Period, that You do not wish to sustain such increase in Access Credits. You may opt to reduce the number of Access Credits with 90 days’ written notice in advance of the 12 month period following from the anniversary of the Delivery Date, provided that the total number of Access Credits does not fall below the minimum threshold set by the Licensor or the Authorised Reseller (as applicable) or below the initial number of Access Credits calculated at the time of conversion of any Perpetual License.

(ii) Duration - this License shall continue for the Initial Period and, provided that You have paid for the applicable Access Credits, from year to year thereafter unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

(iii) Reporting – in order to serve the Licensor’s customers better, the Licensor needs to be able to understand how its customers use the Token Based Annual License. As a condition of Your continued access to the system, You are asked to provide to the Licensor on a quarterly basis,
the log file. You will be provided with easy-to-follow instructions on how to do this.

(iv) Termination – You must give the Licensor 90 days’ written notice in advance of the expiration of the Initial Period of Your intention to discontinue the Token Based Annual License, such notice not to expire before the anniversary of the Delivery Date, and You must have submitted all reports required of You in clause 2.1(c)(iii) above. Failure to provide such notice and reports will mean that the License shall automatically continue on the same terms until terminated in accordance with this clause.

2.2 As an end user licensee of the Software Product, You may, subject to the following conditions and any conditions specified in the Quotation:

(a) use and copy the Software Product only for use on any computer system that is detailed in the release notes of the respective Software Product and which is licensed, leased and/or controlled by You (the Corporate Licensee) or any member of Your corporate group, which expression includes the Corporate Licensee’s majority-owned subsidiaries, any parent company having a majority-owned interest in the Corporate Licensee, and such parent’s majority-owned subsidiaries;

(b) load the Software Product into and use it only on computers at the locations specified in the Quotation and which are under Your control; and

(c) copy the Software Product only for back-up and archival purposes and make up to three copies of the Documentation, provided that the original and each copy is kept in Your possession and that Your installation and use of the Software Product does not exceed any restrictions contained in the Quotation.

3. Demonstration License

3.1 If the Licensor has provided You with the Software Product free of charge for evaluation purposes, this clause 3 shall apply to Your use of the Software Product.

3.2 You may use the Software Product on a computer solely for the purposes of evaluating the Software Product.

3.3 The Software Product is provided to You free of charge and on an “AS IS” basis, without any technical support or warranty of any kind from the Licensor including, without limitation, a warranty of satisfactory quality, fitness for purpose and non-infringement.

3.4 This License shall continue for a period of 30 days from the Delivery Date unless terminated in accordance with any provision of clause 10 below or any other applicable clause of this License Agreement or until such License is converted into an Annual License, Perpetual License, or Token Based Annual License, if earlier.

3.5 As part of the Licensor’s testing and evaluation of the Software Product, You shall share with the Licensor the input and views received and any reports and analysis produced promptly upon receipt of such feedback.

3.6 Clauses 4, 5.1(a), 6.1(b), 6.1(f), 8.1, 8.2, 8.5, 10.1(a) of this License Agreement shall not apply to a Demonstration License.

4. Delivery and Risk

4.1 The Software Product shall consist of one copy of the object code of the Software Product on machine-readable form only, on the disk, dongle or other media on which the Software Product is delivered as described in the Quotation (the “Media”). Risk in the Media shall pass to You on delivery. If any part of the Media shall thereafter be lost, damaged or destroyed, You must contact either the Licensor or the Authorised Reseller from whom You have purchased the Software Product who will arrange for a repair
or replacement of such Media at a cost (if any) determined by the Licensor or the Authorised Reseller (as applicable).

5. License Restrictions

5.1 You may not nor permit others to:

(a) transfer the Software Product from one location to another, without the express written consent of the Licensor and provided such transfers do not exceed two in any twelve month period. It will be a condition of the grant of any such consent that the Software Product held on hard drives at the current location must be erased and You must enter into a new License agreement with the Licensor before a Software Product License key is provided to You. The administration charge (currently US $1,500) will be payable by You in respect of such transfer. This charge is only applicable to end user licensees who do not have a support and maintenance services agreement with the Licensor or Authorised Reseller;

(b) exceed the number of concurrent users specified in the Quotation, if any;

(c) sub-License, sell, assign, rent, pledge, lease, transfer or otherwise dispose of the Software Product, on a temporary or permanent basis, without the prior written consent of the Licensor;

(d) translate, reverse engineer, decompile, disassemble, modify or create derivative works based on the Software Product except as permitted by law;

(e) make copies of the Software Product, in whole or part, except for back-up or archival purposes as permitted in this License Agreement;

(f) use any back-up copy of the Software Product for any purpose other than to replace the original copy in the event that it is destroyed or becomes defective;

(g) copy the Documentation (except as provided by this License Agreement);

(h) adapt, modify, delete or translate the Documentation in any way for any purpose whatsoever;

(i) vary, delete or obscure any notices of proprietary rights or any product identification or restrictions on or in the Software Product.

6. Undertakings

6.1 You undertake:

(a) to ensure that, prior to use of the Software Product by Your employees or agents, all such parties are notified of this License and the terms of this License Agreement and that any such use as aforesaid is in accordance with the terms of this License Agreement;

(b) to replace the current version of the Software Product with any updated or upgraded version or new release provided by the Licensor or the Authorised Reseller (if applicable) under the terms of this License Agreement immediately on receipt of such version or release;

(c) to use the Software Product only as described in the Documentation and subject to the restrictions as set out in clause 5 (License Restrictions above);

(d) to reproduce and include the Licensor’s copyright notice (or such other party’s copyright notice as specified on the Software Product) on all and any copies of the Software Product, including any partial copies of the Software Product as permitted to be made under the terms of this License Agreement;

(e) to hold all drawings, specifications, data (including object and source codes), Software Product listings and all other information relating to the Software Product confidential and not at any time, during
this License or after its expiration, disclose the same, whether directly or indirectly, to any third party without the Licensor’s consent and 

(f) to effect and maintain adequate security measures to safeguard the Software Product from access or use by any unauthorised person and indemnify the Licensor for losses flowing from your failure to do so.

7. Intellectual Property Rights

7.1 You acknowledge that all intellectual property rights in the Software Product and the Documentation throughout the world belong to the Licensor, that rights in the Software Product are licensed (not sold) to You, and that You have no rights in, or to, the Software Product or the Documentation other than the right to use them in accordance with the terms of this License Agreement.

7.2 You acknowledge that You have no right to have access to the Software Product in source code form or in unlocked coding or with comments.

7.3 The integrity of this Software Product is protected by technical protection measures (“TPM”) so that the intellectual property rights, including copyright, in the software of the Licensor are not misappropriated. You must not attempt in any way to remove or circumvent any such TPM, nor to apply, manufacture for sale, hire, import, distribute, sell, nor let, offer, advertise or expose for sale or hire, nor have in Your possession for private or commercial purposes, any means whose sole intended purpose is to facilitate the unauthorised removal or circumvention of such TPM.

8. Limited Warranty

8.1 Subject to the limitations and exclusions of liability below and providing the Software is used in accordance with the Documentation and on an operating system or computer for which it was designed, the Licensor warrants that (a) the Media on which the Software Product is furnished will be free from material defects under normal use for a period of 90 days from the date of delivery (the “Warranty Period”); and that (b) during the Warranty Period, the Software Product will, when properly used, perform substantially in accordance with the functions described in the Documentation; and (c) that the Documentation correctly describes the operation of the Software Product in all material respects.

8.2 If, within the Warranty Period, You notify the Licensor in writing of any defect or fault in the Software Product in consequence of which it fails to perform substantially in accordance with the Documentation, and such defect or fault does not result from You having amended the Software Product or used it in contravention of the terms of this License Agreement, the Licensor will, at its sole option, i) repair or replace the Software Product, provided that You make available all information that may be necessary to assist the Licensor in resolving the defect or fault, including sufficient information to enable the Licensor to recreate the defect or fault, or ii) terminate this License Agreement immediately by notice in writing to You and the Licensor will refund or if the Software Product has been purchased from an Authorised Reseller will procure that the Authorised Reseller shall refund; any of the fees paid as at the date of termination (less a reasonable sum in respect of Your use of the Software Product to the date of termination) on return of the Software Product and all copies thereof. The Licensor’s obligation under this clause 8.2 is subject to Your compliance with clause 6.1(b).

8.3 You acknowledge that the Software Product has not been developed to meet Your individual requirements and that it is therefore Your responsibility to ensure that the facilities and functions of the Software Product as described in the Documentation meet Your requirements.

8.4 You acknowledge that the Software Product may not be free of bugs or errors and You agree that the existence of any minor errors shall not constitute a breach of this License Agreement.
8.5 The Licensor shall not be liable under the said warranty above if the Software Product fails to operate in accordance with the said warranty as a result of any modification, variation or addition to the Software Product not performed by the Licensor or caused by any abuse, corruption or incorrect use of the Software Product, including use of the Software Product with equipment or other software which is incompatible.

8.6 All other conditions, warranties or other terms which might have effect or be implied or incorporated into this License Agreement or any collateral contract, whether by statute, common law or otherwise, are hereby excluded, including, without limitation, the implied conditions, warranties or other terms as to satisfactory quality, fitness for purpose or the use of reasonable skill and care.

9. **Exclusion of Liability**

9.1 Nothing in this License Agreement shall limit or exclude the liability of either party for death or personal injury resulting from negligence, for fraud or for fraudulent misrepresentation.

9.2 Subject to clause 9.1, the Licensor shall have no liability for any losses or damages which may be suffered by You (or any person claiming under or through You), whether the same are suffered directly or indirectly or are immediate or consequential, and whether the same arise in contract, tort (including negligence) or otherwise howsoever, which fall within any of the following:

(a) loss of income;
(b) loss of business profits or contracts;
(c) business interruption;
(d) loss of the use of money or anticipated savings;
(e) loss of information;
(f) loss of opportunity, goodwill or reputation;
(g) loss of, damage to or corruption of data; or
(h) any indirect or consequential loss or damage of any kind howsoever arising and whether caused by tort (including negligence), breach of contract or otherwise;

provided that this clause 9.2 shall not prevent claims for loss of or damage to Your tangible property that fall within the terms of clause 8 or a claim for a refund of the License fees paid to the Licensor or the Authorised Reseller (as applicable) for the License of the Software Product.

9.3 Subject to clause 9.1 and clause 9.2, the Licensor's maximum aggregate liability under or in connection with this License Agreement, or any collateral contract, whether in contract, tort (including negligence) or otherwise, shall be limited to a sum equal to the fees paid by You to the Licensor or the Authorised Reseller (as applicable) for the License of the Software Product.

9.4 Subject to clause 9.1, clause 9.2 and clause 9.3, the Licensor's liability for infringement of third party intellectual property rights shall be limited to breaches of third party rights subsisting in the UK and USA.

9.5 This License Agreement sets out the full extent of the Licensor's obligations and liabilities in respect of the supply of the Software and Documentation. In particular, there are no conditions, warranties, representations or other terms, express or implied, that are binding on the Licensor except as specifically stated in this License Agreement. Any condition, warranty, representation or other term concerning the supply of the Software and Documentation which might otherwise be implied into, or incorporated in, this License Agreement, or any collateral contract, whether by statute, common law or otherwise, is hereby excluded to the fullest extent permitted by law.

10. **Term and Termination**
10.1 This License Agreement is effective for the period referred to in clause 2.1 or until otherwise terminated in accordance with that clause. The Licensor may terminate this License Agreement immediately by written notice to You if:

(a) save in respect of a Perpetual License, if You purchase the Software Product directly from the Licensor, You fail to pay any renewal or other fees due by You to the Licensor in respect of this License Agreement;

(b) You fail to comply with any provisions of this License Agreement;

(c) You commit a material or persistent breach of this License Agreement which You fail to remedy (if remediable) within 14 days after the service on You of written notice requiring You to do so;

(d) a petition for a bankruptcy order to be made against You has been presented to the court; or

(e) where You, as the Corporate Licensee, become insolvent or unable to pay its (the company’s) debts, enters into liquidation, whether voluntary or compulsory (other than for reasons of bona fide amalgamation or reconstruction), passes a resolution for its winding-up, has a receiver or administrator manager, trustee, liquidator or similar officer appointed over the whole or any part of its assets, makes any composition or arrangement with its creditors or takes or suffers any similar action in consequence of its debt, or becomes unable to pay its debts or ceases to trade.

10.2 In the event of termination in accordance with clause 10.1, You must immediately pay to the Licensor any sums due to the Licensor under the License Agreement and (at the Licensor’s sole option) You must return, destroy or delete all copies of the Software Product from all storage media in Your control and, in the case of destruction, certify to the Licensor that You have done so.

11. Export

11.1 You will comply with all applicable laws, rules, and regulations governing export of goods and information, including the laws of the countries in which the Software Product was created. In particular, You will not export or re-export, directly or indirectly, separately or as a part of a system, the Software Product or other information relating thereto to any country for which an export License or other approval is required, without first obtaining such License or other approval.

12. General

12.1 You agree that the Licensor shall have the right, after supplying undertakings as to confidentiality, to audit any computer system on which the Software Product are installed in order to verify compliance with this License Agreement.

12.2 You agree that the Licensor may use Your company name in Licensor’s customer lists and other promotional materials describing Your company as a customer or user of Licensor’s software or services, as applicable, unless it receives written notice from You objecting to such use.

12.3 This License Agreement, its subject matter or its formation (including non-contractual disputes or claims) shall be governed by and construed in accordance with English law and submitted to the non-exclusive jurisdiction of the English courts.

12.4 This License Agreement constitutes the complete and exclusive statement of the agreement between the Licensor and You with respect to the subject matter of this License and supersedes all proposals, representations, understandings, and prior agreements, whether oral or written, and all other communications between the parties relating to that subject matter except for those expressly referred to in this License Agreement.

12.5 Any clause in this License Agreement that is found to be invalid or unenforceable shall be deemed deleted and the remainder of this License Agreement shall not be affected by that deletion.
12.6 Failure or neglect by either party to exercise any of its rights or remedies under this License Agreement will not be construed as a waiver of that party’s rights nor in any way affect the validity of the whole or part of this License Agreement nor prejudice that party’s right to take subsequent action.

12.7 This License Agreement is personal to You, and You may not assign, transfer, sub-contract or otherwise part with this License or any right or obligation under it without the Licensor’s prior written consent.

**ADDENDUM TO THE END USER LICENSE AGREEMENT:**

This addendum (“Addendum”) to the end user license agreement (“Agreement”) applies only to the purchase of an Aqira® System Software Product (as referenced in the Quotation, and hereinafter, the “Aqira Software Product”), is dated as of the date You installed or accepted the Aqira Software Product according to the Agreement, and is between HBM United Kingdom Limited (the “Licensor”) and the end user licensee or its representative/agent authorized to bind the end user licensee (referenced herein as “You” or “Your”). This Addendum shall be governed by the terms of the Agreement and the terms set forth below. Capitalized terms not otherwise defined herein shall have the meaning set forth in the Agreement. If there is a direct conflict between a term in this Addendum and a term in the Agreement, the term in this Addendum shall prevail.

The Licensor and You entered into the Agreement for Your use of the Aqira Software Product, as defined under the Agreement. The Aqira Software Product contains certain technology products owned or distributed by Oracle Corporation UK Limited (including program documentation and any program updates acquired through technical support) (“Oracle Programs”). In order for the license granted to You for the Aqira Software Product under the Agreement to be valid, You must hereby agree to Oracle’s third party terms and conditions for the use of the Oracle Programs. Therefore, the parties acknowledge and agree that this Addendum is incorporated into and made a part of the Agreement, the terms and provisions of which, except as expressly modified in this Addendum, are hereby affirmed and ratified by the parties and remain in full force and effect. You are hereby notified, understand and agree that Your use of the Oracle Programs shall be subject to certain terms and conditions, as follows, and You agree to abide by the following terms and conditions:

1. You shall limit the use of the Oracle Programs to the legal entity that either executed or entered into and accepted the Agreement;

2. You shall restrict use of the Oracle Programs to the scope of the Aqira Software Product and to Your internal business operations. You shall be responsible for Your employees, agents, contractors, outsoercers, customers, and suppliers use of the Aqira Software Product and compliance with the Agreement.

3. Oracle or its licensors retain all ownership and intellectual property rights to the Oracle Programs.

4. You are prohibited from: (i) transferring the Oracle Programs, except for a temporary transfer in the event of computer malfunction if the Aqira Software Product embeds the Oracle Programs in a physical device; and (ii) assigning, giving, or transferring the Oracle Programs ordered or an interest in them to another individual or entity (in the event You grant a security interest in the Oracle Programs, the secured party has no right to use or transfer the Oracle Programs).

5. You are prohibited from: (i) using the Oracle Programs for rental, timesharing, subscription service, hosting, or outsourcing; (ii) the removal or modification of any Oracle Program markings or any notice
of Oracle’s or its licensors’ proprietary rights; (iii) making the Oracle Programs available in any manner
to any third party for use in the third party’s business operations; and (iv) passing title to the Oracle
Programs from You to any other party.

(f) You are prohibited from:  (i) reverse engineering, disassembly, or decompilation of the Oracle
Programs (the foregoing prohibition includes but is not limited to review of data structures or similar
materials produced by the Oracle Programs); (ii) duplicating the Oracle Programs, except for a
sufficient number of copies of each Oracle Program for Your licensed use and one copy of each Oracle
Program media.

(g) You agree to hereby disclaim, to the extent permitted by applicable law, Oracle’s liability for: (i) any
damages, whether direct, indirect, incidental, special, punitive or consequential; and (ii) any loss of
profits, revenue, data or data usage, arising from the use of the Oracle Programs.

(h) You agree to prohibit publication of any results of benchmark tests run on the Oracle Programs.

(i) You agree to comply fully with all relevant export laws and regulations of the United States and other
applicable export and import laws to assure that neither the Oracle Programs, nor any direct product
thereof, are exported, directly or indirectly, in violation of applicable laws.

(j) You are hereby notified, understand, and agree that the Oracle Programs are subject to a restricted
license and can only be used in conjunction with the Aqira Software Product and that You are not
permitted to modify the Oracle Programs.

(k) You agree to not require that Oracle perform any obligations or incur any liability which has not been
previously agreed to between you and Oracle.

(l) You agree to: (i) permit Licensor to audit Your use of the Oracle Programs; (ii) provide reasonable
assistance and access to information in the course of such audit; and (iii) permit Licensor to report the
audit results to Oracle or allow Licensor to assign to Oracle its audits rights under this Addendum. You
agree that Oracle will not be responsible for any of Your costs incurred in cooperating with the audit.

(m) You agree that Oracle is a third party beneficiary of the Agreement.

(n) You are hereby notified that some Oracle Programs may include source code that Oracle may provide
as part of the standard shipment of such Oracle Programs; such source code shall be governed by the
terms of the Agreement.

(o) You are hereby notified that third party technology that may be appropriate or necessary for use with
some Oracle Programs is specified in the Aqira Software Product Documentation or as otherwise
notified by the Licensor. Such third party technology is licensed to You only for use with the Aqira
Software Product under the terms of the third party license agreement specified in the Aqira Software
Product Documentation or as otherwise notified by the Licensor and not under the terms of the
Agreement.