BlockSim/RENO 11 User’s Guide

© 1992-2017 HBM United Kingdom Limited ("HBM UK Ltd"), at Technology Centre, Advanced Manufacturing Park, Brunel Way, Catcliffe, Rotherham S60 5WG. HBM UK Ltd is an affiliate of ReliaSoft Corporation. ALL RIGHTS RESERVED.

This license agreement ("License Agreement") sets forth the terms and conditions that govern the distribution and use of the HBM UK Ltd software documentation (the "HBM Software Documentation"), including any and all derivative works. Any unauthorized distribution or use of the HBM Software Documentation is strictly prohibited.

Licensee hereby acknowledges and agrees to the following terms and conditions of this License Agreement for its use of the HBM Software Documentation:

HBM UK Ltd grants the Licensee who accepts and abides by the terms of this License Agreement a non-exclusive, non-transferable, royalty-free, and revocable license to the HBM Software Documentation. Unless otherwise indicated, all HBM Software Documentation are copyrighted and owned by HBM UK Ltd and are the property of HBM UK Ltd. They are licensed to you and for your use only as an individual who has purchased the software ("Licensee"). Notwithstanding this License Agreement, the Licensee shall not have a license to the trademarks, logos, or any other intellectual property of HBM UK Ltd and/or its affiliates or Licensor(s).

Licensee may print a single copy of the HBM Software Documentation for his/her reference. Licensee may reprint the HBM Software Documentation, as needed, if the original printed copy is damaged and/or destroyed.

Except as provided above, no part of the HBM Software Documentation, either text or image, may be used for any purpose other than Licensee’s own personal use and reference as a learning aid. Therefore, the reproduction, modification, creation of derivative works, storage in a retrieval system, or retransmission, in any form or by any means, electronic, mechanical or otherwise, for reasons other than Licensee’s personal use, is strictly prohibited.

Certain photos and images in the HBM Software Documentation are used under non-transferable licenses obtained by HBM UK Ltd and/or its affiliates and are owned by its Licensor(s) ("Licensor"). Images depicting photos of actual persons are licensed to HBM UK Ltd and/or its affiliates and the signed model releases for these images are on file with the Licensor(s). HBM UK Ltd makes no copyright claims on these images. All ownership and intellectual property rights to the HBM Software Documentation are reserved by either HBM UK Ltd and/or its affiliates or its Licensor(s).

DISCLAIMER: THE HBM SOFTWARE DOCUMENTATION IS PROVIDED “AS IS” WITHOUT WARRANTIES OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO: 1) ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT OF INTELLECTUAL PROPERTY; 2) ANY WARRANTY THAT THE HBM COURSE MATERIALS WILL CONFORM TO SPECIFICATIONS; 3) ANY WARRANTY THAT THE WORK WILL BE ERROR FREE OR VIRUS FREE. IN NO EVENT SHALL HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSOR(S) BE LIABLE FOR ANY DAMAGES, INCLUDING, BUT NOT LIMITED TO, DIRECT, INDIRECT, SPECIAL OR CONSEQUENTIAL DAMAGES, ARISING OUT OF, RESULTING FROM, OR IN ANY WAY CONNECTED WITH THE HBM SOFTWARE DOCUMENTATION, WHETHER OR NOT BASED UPON WARRANTY, CONTRACT, TORT, OR OTHERWISE, WHETHER OR NOT LOSS WAS SUSTAINED FROM, OR AROSE OUT OF THE RESULTS OF, OR USE OF, THE HBM SOFTWARE DOCUMENTATION. LICENSEE AGREES TO WAIVE ANY AND ALL CLAIMS AGAINST HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSOR(S), AND SHALL INDEMNIFY, DEFEND AND HOLD HARMLESS HBM UK LTD, ITS AFFILIATES, DISTRIBUTORS, CONTRACTORS, AGENTS, AND ITS LICENSOR(S) FOR ANY AND ALL LIABILITIES, CLAIMS, DEMANDS, DAMAGES, EXPENSES OR LOSSES THAT MAY ARISE FROM THE LICENSEE’S USE OR DISTRIBUTION OF THE HBM SOFTWARE DOCUMENTATION, INCLUDING ANY LIABILITIES OR DAMAGES FROM DERIVATIVE WORKS OR OTHER PRODUCTS BASED ON, OR RESULTING FROM, THE USE THEREOF.

This License Agreement is subject to change without notice and does not represent any commitment on the part of HBM UK Ltd and/or its affiliates to the Licensee, including any commitment to maintain or update the HBM Software Documentation. The names of companies, products, people, characters, and/or data mentioned in the HBM Software Documentation are not intended to represent any real individual, company, product or event, unless otherwise noted. Any rights not expressly granted herein are reserved for HBM UK Ltd.

TRADEMARKS:
ReliaSoft, Synthesis Platform, Weibull++, ALTA, DOE++, RGA, BlockSim, RENO, Lambda Predict, Xfmea, RCM++ and XFRACAS are all trademarks of ReliaSoft Corporation.

GlyphWorks, VibeSys, DesignLife and the nCode logos are all trademarks of HBM UK Ltd.

Other product names and services identified in the HBM Software Documentation are trademarks belonging to their respective trademark holders, and are used for illustration purposes. Their use in no way conveys an endorsement or other affiliation with HBM UK Ltd and/or its affiliates.
# Table of Contents

Chapter 1: Getting Started.............................................................................................................. 1

Intro to BlockSim and RENO ....................................................................................................... 1

New in Version 11: BlockSim and RENO ..................................................................................... 1

Fault Tree Tracer..................................................................................................................... 1

Block Explorer ......................................................................................................................... 2

Improved Cut Sets ................................................................................................................... 2

More Flexible Simulation Worksheets .................................................................................... 2

Improved FRED Reports .......................................................................................................... 2

More Realistic Phase Diagrams ............................................................................................... 2

Configure Color Spectrum....................................................................................................... 2

Preview Subdiagrams.............................................................................................................. 3

Insert Blocks More Easily ........................................................................................................ 3

Save Your Diagram Anytime ................................................................................................... 3

Set Item Quantities in FMRA................................................................................................... 3

RENO: Fully Integrated Synthesis Workbooks ........................................................................ 3

RENO: Interval Simulation of BlockSim Diagrams ................................................................ 3

More Flexibility in Project Manager ....................................................................................... 4

Major Interface Updates for the Synthesis Enterprise Portal (SEP) ....................................... 4

Quick Tour ................................................................................................................................... 4

Quick Tour of BlockSim and RENO.......................................................................................... 4

Using Repositories and Projects ............................................................................................. 6

Using Simulation RBDs ........................................................................................................... 8

Using RENO Flowcharts......................................................................................................... 13

More Analyses and Tools ...................................................................................................... 31

Technical Support ..................................................................................................................... 36

When Requesting Support .................................................................................................... 37
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting Item Permissions</td>
<td>100</td>
</tr>
<tr>
<td>Status Indicators</td>
<td>101</td>
</tr>
<tr>
<td>Reset &quot;In Use&quot; Flags</td>
<td>103</td>
</tr>
<tr>
<td>Repository Logins</td>
<td>104</td>
</tr>
<tr>
<td>Repository Settings</td>
<td>104</td>
</tr>
<tr>
<td>E-mail Settings Page</td>
<td>105</td>
</tr>
<tr>
<td>Other Settings Page</td>
<td>105</td>
</tr>
<tr>
<td>Time and Usage Units</td>
<td>105</td>
</tr>
<tr>
<td>Default Name Formats</td>
<td>106</td>
</tr>
<tr>
<td>Project Planning Resources</td>
<td>108</td>
</tr>
<tr>
<td>Working Days/Holidays</td>
<td>109</td>
</tr>
<tr>
<td>XFRACAS Connection</td>
<td>110</td>
</tr>
<tr>
<td>Managing and Restoring Data</td>
<td>111</td>
</tr>
<tr>
<td>Enterprise Database Maintenance</td>
<td>111</td>
</tr>
<tr>
<td>Standard Database Maintenance</td>
<td>112</td>
</tr>
<tr>
<td>Restore Points</td>
<td>114</td>
</tr>
<tr>
<td>Chapter 3: Desktop Application Interfaces</td>
<td>117</td>
</tr>
<tr>
<td>Ribbon and Backstage View</td>
<td>117</td>
</tr>
<tr>
<td>Project Manager and My Portal</td>
<td>117</td>
</tr>
<tr>
<td>Status Bar</td>
<td>118</td>
</tr>
<tr>
<td>Show, Tile, Dock and Pin Panels</td>
<td>118</td>
</tr>
<tr>
<td>Show or Hide</td>
<td>118</td>
</tr>
<tr>
<td>Tile or View One Page at a Time</td>
<td>118</td>
</tr>
<tr>
<td>Dock or Float</td>
<td>120</td>
</tr>
<tr>
<td>Pinned or Unpinned</td>
<td>122</td>
</tr>
<tr>
<td>Project Manager</td>
<td>123</td>
</tr>
<tr>
<td>Opening a Project</td>
<td>123</td>
</tr>
</tbody>
</table>
Filtering the List of Projects ................................................................. 123
Searching for a Particular Project .......................................................... 124
Current Project Explorer ...................................................................... 124
Working with Multiple Projects ............................................................ 126
My Portal ............................................................................................. 127
Portal Messages .................................................................................. 128
Actions in My Portal .......................................................................... 129
Repository Users List ......................................................................... 132
Project Plan Summary in My Portal ...................................................... 133
Folios .................................................................................................. 135
Data Sheets ....................................................................................... 135
Change Units .................................................................................... 138
General Spreadsheets ...................................................................... 139
Control Panels .................................................................................. 141
Switching Between Pages .................................................................. 142
Hiding or Displaying a Control Panel .................................................. 142
Identifiers Page ................................................................................ 143
Publishing Page ............................................................................... 143
Notifications Page .......................................................................... 144
Utilized Resources Page ................................................................. 144
System Panel and Analysis Panel ...................................................... 145
Change Orientation .......................................................................... 145
Resize a Panel ................................................................................ 145
Hide a Panel ................................................................................... 146
Expand or Collapse Nodes ............................................................... 146
Selecting Which Columns to Display ................................................ 147
Printing ............................................................................................ 147
Wizard ................................................................................................................................. 168
Diagrams .................................................................................................................................. 168
Tools ......................................................................................................................................... 168
Build from Synthesis ................................................................................................................ 168
Reports and Plots ....................................................................................................................... 169
Attachments ............................................................................................................................. 169
Simulation Worksheets ............................................................................................................. 169
View Tab ................................................................................................................................... 169
Refresh ..................................................................................................................................... 169
Project Manager ........................................................................................................................ 170
My Portal .................................................................................................................................... 170
Workspace Layout ..................................................................................................................... 170
Expand/Collapse ....................................................................................................................... 171
Zoom ....................................................................................................................................... 171
Window .................................................................................................................................... 172
FMRA ....................................................................................................................................... 172
Show ....................................................................................................................................... 172
Active Tabs ............................................................................................................................... 173
3D Plot Tab ............................................................................................................................... 173
Allocation Tab ......................................................................................................................... 174
Analysis Tab ............................................................................................................................. 174
Diagram Tab ............................................................................................................................. 175
Fault Tree Tab .......................................................................................................................... 180
Flowchart Tab .......................................................................................................................... 185
FMRA Tab ................................................................................................................................. 188
Format Tab ............................................................................................................................... 191
FRED Tab ................................................................................................................................. 192
Flag Marker and Go-to-Flag Blocks ................................................................. 478
Stop Flags ........................................................................................................... 482
Counter Blocks .................................................................................................. 482
Reset Blocks ...................................................................................................... 484
UI Blocks ............................................................................................................. 485
Subchart Blocks ................................................................................................. 488
RENO Resources ............................................................................................... 490
Naming RENO Resources .................................................................................. 490
RENO Functions and Static Functions ............................................................... 491
RENO Simulation Definitions ............................................................................ 495
RENO Tables ...................................................................................................... 499
Function Selector and Equation Editor ............................................................. 501
Function Selector ............................................................................................... 501
Equation Editor .................................................................................................. 503
RENO Standard and Special Operators ............................................................. 503
Flowchart Configurations and Execution ......................................................... 505
Example 1: Blocks with Multiple Outgoing Paths ........................................... 506
Example 2: Blocks that Require a Certain Number of Inputs ......................... 508
Example 3: Flowchart with Multiple Starting Paths ....................................... 509
Debugging a Flowchart ...................................................................................... 510
Flowchart Control Panel ................................................................................... 511
Control Panel Simulation Page .......................................................................... 511
Flowchart Simulation ........................................................................................ 514
RENO Simulation Window ................................................................................ 514
RENO Simulation Status Display ...................................................................... 518
Available Results ............................................................................................... 519
Flowchart Simulation Results ........................................................................... 519
Project and Item Filters ....................................................................................................... 641
Record Filter ........................................................................................................................ 642
Phrase Sets .......................................................................................................................... 642
Field Text ............................................................................................................................. 642
Record Filter Options .......................................................................................................... 643
Check Spelling ......................................................................................................................... 645
Results Window ...................................................................................................................... 646
Quick Parameter Estimator (QPE) .......................................................................................... 647
Quick Parameter Estimator Wizard View ........................................................................... 647
Quick Parameter Estimator Expert View ............................................................................ 648
Quick Parameter Estimator (ALTA) ..................................................................................... 649

Chapter 19: Synthesis Resources .......................................................................................... 653
Types of Resources ............................................................................................................... 653
Used in Multiple Applications ............................................................................................. 653
Used Only in BlockSim ......................................................................................................... 655
Used Only in RENO .............................................................................................................. 655
Used Only in ALTA ............................................................................................................... 656
Local, Global and Reference Resources ............................................................................. 656
Parent/Child Resource Relationships ................................................................................. 656
Keeping Resources Together .............................................................................................. 657
Creating and Selecting Resources ..................................................................................... 658
Opening a Resource Wizard ............................................................................................... 658
Back Arrow and Main Page ................................................................................................. 659
Selecting an Existing Resource ......................................................................................... 660
Creating a Resource ............................................................................................................ 661
Editing a Resource ............................................................................................................... 661
Removing a Resource .......................................................................................................... 661
Project Planner Gates ............................................................................................................. 748
   Gate Properties ........................................................................................................................ 748
   Gate Status ............................................................................................................................... 749
Actions in Project Plans ............................................................................................................ 749
   Adding Actions to the Plan ...................................................................................................... 750
Project Plan Summary Panel ...................................................................................................... 750
Check Utilization ......................................................................................................................... 753
Project Planner Gantt View ....................................................................................................... 754
Project Planner Plot View .......................................................................................................... 755
Set Colors ..................................................................................................................................... 756
Project Planner Dashboards ....................................................................................................... 757
   Data Source Drop-Down List ................................................................................................. 757
   Examples for Different Field Types ...................................................................................... 758
Project Planner Ribbon ............................................................................................................. 760
   Project Planner Tab .................................................................................................................. 760
   View Tab .................................................................................................................................. 763
Chapter 21: Synthesis Plot Utilities ........................................................................................... 765
   Basic Plot Features .................................................................................................................. 765
      Redraw Plots .......................................................................................................................... 765
      Identify a Plot’s Source Analysis .......................................................................................... 766
      Show or Hide Plot Items ....................................................................................................... 766
      Scaling .................................................................................................................................. 766
      Zoom .................................................................................................................................. 767
      Aspect Ratio ........................................................................................................................ 767
      Show Coordinates ................................................................................................................. 768
      Add Custom Labels .............................................................................................................. 769
      Move Plot Items ................................................................................................................... 769
My Actions Panel in SEP Home .......................................................... 867
My Actions Page .............................................................................. 867
Actions in a Project Summary .......................................................... 869
Actions in a Project Plan or FMEA ................................................. 870
Links to SEP from Action Alert E-mails and Portal Messages .......... 871
Publishing to SEP ........................................................................... 871
Data Sheets or Diagrams ............................................................... 872
Synthesis Workbooks ................................................................. 873
Prediction Reports and Plots .......................................................... 873
Xfmea/RCM++/RBI Reports ............................................................ 874
Dashboards and Reports in SEP .................................................... 874
Save, Copy or E-mail the URL ....................................................... 875
Watch This Report ........................................................................ 875
SEP and XFRACAS ........................................................................ 876
Configure Links Between Websites .............................................. 876
XFRACAS Reports and Charts ....................................................... 877
XFRACAS Actions ................................................................. 877
XFRACAS Incidents ................................................................. 877
Quick Links in SEP ........................................................................ 877
Link to a Page in SEP ................................................................... 878
Link to an External Website ........................................................ 878
Move, Rename or Remove a Link ................................................. 878
SEP User Preferences ................................................................... 879
Change interface language ......................................................... 879
When starting the SEP always load ............................................. 880
Select actions to list on the home page ....................................... 880
Receive automated alerts ............................................................. 880
Number of decimals for metrics in SEP ................................................................. 881
Chapter 1: Getting Started

Intro to BlockSim and RENO

ReliaSoft’s BlockSim provides a comprehensive platform for system reliability, availability, maintainability and related analyses. Our RENO software tool is a powerful and user-friendly platform for building and running complex analyses for any probabilistic or deterministic scenario using an intuitive flowchart modeling approach and simulation.

Both applications are integrated into a single user interface with the ability to save both types of analyses together in the same project. This user's guide provides detailed documentation for both products. The features that are available on your computer will depend on the license that you have purchased from ReliaSoft.

- This graphic indicates that a feature is available only for users with a BlockSim license.

- This graphic indicates that a feature is available only for users with a RENO license.

These applications are also part of the Synthesis Platform, which provides intelligent integration between reliability program activities and tools, while simultaneously facilitating effective information sharing and cooperation between engineering teams of any size. For information about features that are shared by all (or most) of the Synthesis desktop applications, see the Repositories and Projects, Desktop Application Interfaces and Synthesis Platform Tools chapters.

To get started learning about BlockSim and RENO, see New in Version 11: BlockSim and RENO or use the Contents to navigate to a specific topic.

New in Version 11: BlockSim and RENO

Here’s a quick overview of the main new and improved features in BlockSim and RENO Version 11.

Fault Tree Tracer

The fault tree tracer provides a way to visualize how fault tree subdiagrams fit into a parent fault tree. It can help you make sense of complex or deeply nested diagram. For example, if your team works on a particular assembly, you can use the tracer to
see how it relates to the fault tree for the overall system.

**Block Explorer**

The [Block Explorer](http://blocksim.reliasoft.com) is a convenient new tool that allows you to view, filter, sort and search the blocks in RBDs and fault trees throughout the current database. For instance, you might be looking for an RBD that models a particular standby configuration. You could filter the list to show only standby container blocks, making it much easier to find the diagram you're looking for.

**Improved Cut Sets**

When calculating [minimal cut sets](http://blocksim.reliasoft.com) for an analytical diagram, you now have the option to include blocks that don't have reliability models assigned to them. This allows you to calculate cut sets before you have all of your reliability information in place.

**More Flexible Simulation Worksheets**

Simulation worksheets allow you to vary values that are used when simulating a BlockSim RBD or a RENO flowchart. This allows you to investigate the effect of one or more settings on the simulation results.

In Version 11, you can now vary the current age in standard blocks, and duty cycles in non-phase diagrams. Additionally, you can now vary the simulation end time for the simulation worksheet, allowing you to obtain results as a function of time.

**Improved FRED Reports**

[FRED reports](http://blocksim.reliasoft.com) provide an intuitive graphical presentation of key reliability metrics, with color-coding to identify the ones that may be critical for system improvement. In Version 11, you can select a wider variety of metrics, providing a clearer picture of each block's reliability or availability. You can even specify which metric is the "primary" one, upon which the color-coding will be based.

**More Realistic Phase Diagrams**

For blocks that have [state change triggers](http://blocksim.reliasoft.com), the block state now continues across phases, instead of being reset to its initial state at the beginning of each phase.

**Configure Color Spectrum**

For features in BlockSim, Lambda Predict and Xfmea/RCM++/RBI that use a color spectrum to highlight results of high, medium or low concern, the Application Setup now provides the option to select the color that will be used for each range.
In BlockSim, these colors are used:

- In **FRED reports**, to highlight blocks that need improvement in the reliability metric you've chosen
- In **allocation analysis**, to describe the importance of the blocks to the system reliability
- In the **FMRA**, to highlight blocks that need improvement in each calculated result column
- In certain plots, to display an additional metric (e.g., in the Static RI plot, bar size indicates reliability importance and bar color indicates reliability)

**Preview Subdiagrams**

Select any subdiagram block and press **SPACE** or choose the **Selection > Quick View** command in the relevant ribbon tab to get a quick preview of the subdiagram without actually opening it.

**Insert Blocks More Easily**

You can now **insert a block** into the flow of the diagram without having to delete and add connectors. Simply drag an unconnected block onto an existing connector.

**Save Your Diagram Anytime**

Diagrams are always saved upon calculation or close. Now, you can also use the **Save Diagram** command to save your diagram at any time. This, combined with the new **Auto Save** setting in the **Application Setup**, helps safeguard your work in the event of network instability.

**Set Item Quantities in FMRA**

You can now define an item as representing multiple copies of the same item when working with its **properties** in Xfmea/RCM++/RBI, instead of having to create individual items (e.g., the tires on a car). This will cause the item to be represented in the **FMRA Diagram** as a multi block. The FMRA will take this value into account in the calculations.

**RENO: Fully Integrated Synthesis Workbooks**

**Synthesis workbooks** are now fully integrated for RENO flowcharts. This means that you can use them in any expression where you would previously have used analysis workbooks.

**RENO: Interval Simulation of BlockSim Diagrams**
Chapter 1: Getting Started

You can now specify a start time for simulating a BlockSim diagram via simulation definition, allowing you to simulate the diagram over a particular interval of time.

More Flexibility in Project Manager
For all Synthesis desktop applications, the project filter now gives the option to select specific projects (instead of only filtering by specific criteria such as "Project Owner"). If you’re working in an enterprise repository with many projects, this makes it easier for you to quickly access the specific projects of interest to you.

For applications that use a current project explorer, we’ve also added the option to hide empty or unused folders to minimize clutter.

Major Interface Updates for the Synthesis Enterprise Portal (SEP)
If your organization chooses to implement a web-based Synthesis Enterprise Portal (SEP) for an enterprise database, the entire team – including managers and colleagues who don’t have Synthesis desktop applications installed – will be able to access key analysis and project management details from any web-enabled device.

In Version 11, the SEP has a fresh new look with responsive design for better performance on mobile devices and more control for quickly accessing the information that’s of interest to you. The website provides at-a-glance summaries of the project plans, actions, messages, metrics, dashboards and reports that you need to stay on top of, and makes it easy to drill down for more detail. It also allows users throughout your organization to view the FMEAs and published reports created in ReliaSoft’s Xfmea/RCM++/RBI without having the desktop application installed.

Quick Tour

Quick Tour of BlockSim and RENO
BlockSim supports a wide variety of system reliability, availability and related analyses using reliability block diagrams (RBDs), fault trees (FTA) and/or Markov analysis. It’s also packed with tools for related analyses, such as reliability allocation, optimum replacement and inspection, reliability importance measures and throughput analysis.

RENO uses flowcharts and Monte Carlo simulation to model and analyze even the most complex probabilistic or deterministic scenarios.
You can use these applications to answer a wide variety of questions, such as:

- What is the expected reliability of the system? What are the most critical components? What component reliabilities are required to meet the system reliability goal?

- What is the expected availability (uptime) or throughput? Where are the critical components or bottlenecks? What changes are needed to meet the operational goals?

- What is the optimum maintenance strategy? When is the best time for scheduled maintenance? How many spares should we keep on hand? Is crew capacity sufficient?

- How much will it cost to operate the system? How will a change in the design or operating conditions affect costs? Which components are the most costly?

- What is the risk of catastrophic failure? Which components or failure modes pose the greatest risk? How will a change in the design or operating conditions affect safety?

- How does the system perform across different operational phases?

- What is the effect of variability on performance? How will the outcome be affected by changes in specific inputs? What are the probabilities of different possible outcomes?
Using Repositories and Projects

File Menu
Use commands on the File menu (New, Recent or Open Repository) to create or open a Synthesis repository (database). (See Database Types.)

Each database supports simultaneous access by multiple users. If you have admin permissions, use File > Manage Repository to control user access and manage configurable settings that apply throughout the database. (See Security Options and Backstage View.)

Use File > Help to access online help and shipped examples.

Project List
Each database can contain multiple projects. Use the project list to create or open a Synthesis project. (See Project Manager.)

If you have a lot of projects:
- Use the project filter to limit what’s displayed.
• Use the **project category** to group projects within the list.

**Current Project Explorer**

Use the **current project explorer** to create or open analyses and reports. (See [Current Project Explorer](#).)

You can open the same project in any Synthesis desktop application. Analyses and reports are visible only in the application(s) that can edit them:

- Life data folios are only visible in Weibull++
- Fault trees are only visible in BlockSim
- FMEAs are only visible in Xfmea, RCM++ or RBI
- Etc.
Common features such as **project plans**, **Synthesis resources** and **project attachments** are visible in all Synthesis desktop applications.

**Using Simulation RBDs**

A **reliability block diagram** (RBD) is a graphical representation of how the components of a system are reliability-wise connected. BlockSim's RBDs can be configured as **analytical diagrams** (which use the exact algebraic equation for the system model but impose limitations on what can be modeled and what results can be obtained) or **simulation diagrams** (which provide more modeling options and results but must be analyzed with discrete event simulation).

The basic steps for using a simulation RBD are:

1. **Add diagram**
   
   Right-click the RBDs folder in the current project explorer and choose **Add Simulation RBD**.

2. **Add blocks**
   
   Right-click inside the diagram and choose the type of block to add. (See **RBD Block Types**.)
3. **Connect blocks**

   Hold down the ALT key, click the source block and drag a line to the destination block.

4. **Set block properties**

   To edit a block's properties, right-click it and choose **Block Properties**. Use a *universal reliability definition* (URD) to specify the reliability properties. (See **Creating and Selecting Resources**.)
   
   - To select an existing URD, click inside the **URD** field.
   - To create a new URD, click inside the **Model - Reliability** field and follow the wizard. You can create a new model (left) or select an existing model (right). Existing models may have been manually created, or may have been published from other analyses in BlockSim, Weibull++, ALTA, RGA or Lambda Predict.

5. **Simulate the diagram**

   Click the **Simulate** icon on the control panel.
Chapter 1: Getting Started

Specify the simulation settings and click **Simulate**. (See [Maintainability/Availability Simulation Window](http://blocksim.reliasoft.com).)
6. **View the simulation results**

From within the Maintainability/Availability Simulation window, click **Details**. If you have closed the window, click the **Results valid as of** field on the control panel. (See **Results Explorer** for available results.)
Chapter 1: Getting Started

7. **Calculate metrics**

   Click the **QCP** icon on the control panel to open the Quick Calculation Pad. (See [Simulation QCP](http://blocksim.reliasoft.com) for available calculations.)

![Quick Calculation Pad](QCP.png)
8. **View plots**

Click the **Plot** icon on the control panel to open the plot sheet. (See [Simulation Plots](#) for available plot types.)

---

**Using RENO Flowcharts**

RENO flowcharts are used to build models of probabilistic or deterministic problems, processes or scenarios in order to help you understand and/or quantify them. The flowchart is a graphical representation of the mathematical process of predicting an outcome.
Chapter 1: Getting Started

The example that follows demonstrates some of the basic techniques used in working with RENO flowcharts. This simple flowchart generates failure times for 10 items.

1. **Add diagram**

   Right-click the RENO Flowcharts folder in the current project explorer and choose **Add RENO Flowchart**.

2. Define resources

   a. **Create a variable**

      *This resource will control the number of items to generate failure times for.*

      Choose **Project > Synthesis > Resource Manager**.

   ![Diagram of Project 1 with RENO Flowcharts folder expanded]
In the Resource Manager, choose Variables and then choose Home > Edit > Add.
Define the variable properties. (See Variables.)

b. Create a model

This resource will define the model used to generate the failure times.

In the Resource Manager, choose Models and then choose Home > Edit > Add.
Define the model properties. (See Models.)

3. Add blocks (See Flowchart Block Types.)
   a. Add a standard block (to increment the variable)

   *This block will increment the value of the Number_of_Items variable.*
Right-click inside the diagram and choose to add a standard block. (See Flowchart Standard Blocks.)

To edit the block's properties, right-click it and choose Block Properties.
Click inside the **Equation** field and type **Number_of_Items + 1**. (For additional tools to assist with building equations, see **Function Selector and Equation Editor**.)
Click inside the **Storage Variable** field and select the **Number_of_Items** variable.

b. **Add a conditional block (i.e., create an IF statement)**

   *This block will determine the simulation path based on whether the item count has reached 10.*

   Right-click inside the diagram and choose to add a conditional block. (See **Conditional Blocks**.)
In the block's properties window, specify that if the incoming value is less than or equal to 10, a value of 0 will be passed on the "true" path. Otherwise, a value of 0 will be passed on the "false" path.

c. **Add a standard block (to generate the failure times)**

   *This block will generate a failure time by returning a random value based on the Item_Failure_Distribution model.*
In the block's properties window, right-click inside the **Equation** field, choose **Show Function Selector** then choose **RENO Internal Functions** from the dropdown list. Double-click the **rvm** function.
In the Enter Parameters window that appears, right-click in the Model field and open the Function Selector. Double-click the Item_Failure_Distribution model.

![Function Selector](Image)

**d. Add a result storage block**

*This block will store an array of the failure times generated by the standard block.*

Right-click inside the diagram and choose to add a result storage block. (See Result Storage Blocks.)
In the block's properties window, specify that it will store an array of results.

![Block Properties Window](http://blocksim.reliasoft.com)

**Properties**

- **Block (Result Storage)**
  - **Block Name**: Array_of_Failure_Times

**Store**

- **Array of Results**
  - **Required Number of Executed**
    - **Incoming Paths**
      - **Storage Variable**: Array of Results
        - **Identifiers**
          - **Comments**
            - **Active Block**: Result Storage

**e. Create a FOR loop**

*These blocks will form a loop that will cycle through the flowchart until the variable value reaches 10.*

Add a flag marker block, a go-to-flag block and a stop block.
Define the properties. (See Flag Marker and Go-to-Flag Blocks and Stop Flags.)
4. **Connect blocks**

Connect the blocks as shown below. To create each connection, hold down the **ALT** key, click the source block and drag a line to the destination block.

The first connector you create from the conditional block will be marked as the "true" path and the second as the "false" path. If necessary, you can switch these designations by right-clicking the connector and choosing **Set to Failure** or **Set to Success** on the shortcut menu.
5. **Simulate the flowchart**

Click the **Simulate** icon on the control panel.

Specify to run a single simulation with a seed of 1 and click **Simulate**. (See RENO Simulation Window.)
6. **View the simulation results**

From within the RENO Simulation Window, click **Details**. If you have closed the window, click the **Results valid as of** field on the diagram control panel.

To view the failure times generated during the simulation, click the result storage block in the navigation panel.
7. **View plots**

Click the **Plot** icon on the diagram control panel to open the plot sheet. (See **Flowchart Plots** for available plot types.)

On the plot sheet control panel, choose the plot type, then select the result storage block(s) to show in the plot.
Chapter 1: Getting Started

![Probability Plot](http://blocksim.reliasoft.com)
More Analyses and Tools

Phase Diagrams

Reliability phase diagrams represent scenarios in which a system may undergo changes over time.
Chapter 1: Getting Started

**Markov Diagrams**

Markov diagrams model the behavior of systems based on memoryless transitions between states, allowing you to look at partial or degraded working states, and to start analysis in varying states.
Reliability Allocation

The allocation analysis tool helps determine the reliability requirements for individual components/assemblies that would be needed to achieve an overall reliability goal.
Chapter 1: Getting Started

**FRED Reports**

*FRED reports* provide a graphical demonstration of the reliability and maintainability/availability characteristics of the components in a system and help to identify the components that may require improvement.
Optimum Replacement

The Optimum replacement tool helps to determine the best time to inspect and/or replace components, based on the costs for planned and unplanned maintenance.
Chapter 1: Getting Started

Simulation Worksheets

Simulation worksheets can vary values that are used when simulating an RBD or a flowchart, allowing you to investigate the effect of various factors on the simulation results (e.g., how the restocking interval and initial quantity in a spare part pool affect the cost of maintaining a system). The values can be entered manually, or can be transferred from an experiment design folio in Weibull++/ALTA. After simulation, you can transfer the results into the design folio in Weibull++/ALTA for analysis and/or optimization.

Technical Support

ReliaSoft reliability software products are renowned for their ease of use and unparalleled after sale support. For users with an active maintenance agreement, we provide technical support for software-related issues via a network of regional offices and partners/distributors throughout the world.

You can request assistance directly from within the software by choosing **File > Help > E-mail Support**. This option creates an e-mail message that is pre-populated with information about your license and operating system, which the technical support representative will need for troubleshooting the issue.
You can also contact us directly via phone, e-mail or mail. To find the office that serves your region, choose File > Help > Contact Global Support Center or visit http://www.reliasoft.com/contact.htm.

**When Requesting Support**
When you contact ReliaSoft to request technical support, please be prepared to provide the following information:

- Your phone number and e-mail address.
- The product name and the Compile Release Version number of your application. To determine the Compile Release Version (CRV) of the application on your computer, choose File > Help. The CRV is displayed in the About area. Note that the CRV will also indicate whether you are running the 32-Bit version or the 64-Bit version of the software.
- Your product license key.
  - To determine the license for the application on your computer, you can choose File > Application Setup and click any of the main headings in the Application Setup window.
- The operating system (e.g., Windows 7), RAM and hard disk space on your computer.
- Describe what you were doing when the problem occurred and exactly what happened. Please include the specific wording of any message(s) that appeared.

**Note:** ReliaSoft technical support representatives are not reliability consultants, and their assistance is limited to technical issues that you may encounter with the software tools. To get assistance with your analysis from a subject matter expert, please contact Reliability Consulting Services. ReliaSoft also offers a comprehensive selection of training courses that cover both the underlying principles and theory, as well as the applicable software tools. For details, visit http://seminars.reliasoft.com/.

**Reliability Consulting**
If your organization does not have sufficient time, expertise or objectivity in-house to accomplish specific reliability goals, turning to ReliaSoft expert reliability consultants can prove to be the most effective and economical solution. Whether you need a quick statistical analysis, a complete assessment of your reliability program plan or something in between, Reliability Consulting Services (RCS) is ready to help.

- Our reliability consulting services team has combined expertise in almost all areas of reliability and quality engineering with experience that spans a broad spectrum of
product types, from micro-electronics and appliances to advanced weapons systems and off-shore oil well drilling equipment.

- Unlike engaging a consultant who works independently, RCS consultants have direct access to all of ReliaSoft global resources, expertise and contacts.
- Our team-based approach to consulting, combined with ReliaSoft global reliability engineering organization, allows us to provide you with reliability consultants who understand your culture and speak your language while ensuring that the appropriate reliability expertise can be applied to each and every project.
- RCS is structured to accommodate requests of any size or complexity, from short telephone consultations to multiple experts at a client's site for an extended time period.

Please visit http://consulting.reliasoft.com for a published list of commonly requested services, answers to frequently asked questions, and other useful information about this service.

Install and License

System Requirements
In addition to the information below, ReliaSoft provides an automated tool that determines whether your computer and Internet connection meet the requirements for running and activating Synthesis. It will also determine whether you could install the 64-bit version of Synthesis, if desired. [Download Requirements and Compatibility Test Tool...]

Operating Systems
32- and 64-bit versions are supported, except where noted. [See our 32-bit vs. 64-bit FAQ...]

- Microsoft Windows Server 2008 with Service Pack 2, Windows Server 2008 R2 (64-bit version), or newer. (Requires a license that specifically allows server installations/deployments.)

Note: Upgrading your operating system after Synthesis has already been installed can cause issues with the activation. To prevent this, it is recommended to uninstall Synthesis prior to upgrading your operating system and then reinstall it after the upgrade. For other options, and for information about how to handle the "activated license is corrupt" message that may appear if you upgrade your operating system with live activations, please refer to http://www.reliasoft.com/support/rs20025.htm.
Chapter 1: Getting Started

Minimum Hardware Requirements

- Intel Pentium® processor; 1.5 GHz or faster processor
- 2 GB of RAM for the 32-bit version of Windows; 8 GB of RAM for the 64-bit version.
- Display: 1024 x 768 or higher resolution at 96 dpi, with 24-bit color and 64 MB of dedicated VRAM.
- 1 GB of free disk space for install; minimum of 500 MB swap space.
- Internet connection is required to use the License Manager and the internet-enabled features in the software interface.

Additional Software

- Microsoft Office 2000 or higher (Excel®, Word and Outlook®) are required for automated exports, report generation and e-mail/calendar integration. ReliaSoft recommends Microsoft Office 2010.

Enterprise Database Platforms

32- and 64-bit versions are supported.

- SQL Server® 2008 or newer
- SQL Server Express Edition 2008 or newer
- Oracle® 10g or newer
- Oracle Express 11g or newer

Although the enterprise database platform (Microsoft SQL Server or Oracle) could be installed on the same computer where the Synthesis applications reside, most organizations will choose to set up a separate server to host the database. Both the 32-bit and 64-bit versions of the Synthesis-enabled applications will work with either the 32-bit or 64-bit versions of a back-end database/server. The minimum hardware/software requirements for each server hosting the database should be obtained directly from the selected database vendor (i.e., Microsoft or Oracle). In general, ReliaSoft recommends a minimum CPU speed of 2 GHz and 4 GB of RAM.

Tip: If you're considering the option to use the free "Express" edition of Microsoft SQL Server, the document at [http://www.reliasoft.com/synthesis/sql_express.htm](http://www.reliasoft.com/synthesis/sql_express.htm) provides some information that may help you to get started.
Synthesis Installation and Licensing

There are two alternative ways that Synthesis desktop applications may be licensed on your computer. The installation process depends on the type of licensing.

- **Locally Hosted Licensing**
  - You received a license file (*.lic) and/or a license settings file (*.prnrsl)
  - Allows your organization to manage license seats or, for token-based licenses, CRS units in-house without the requirement to connect with ReliaSoft’s external license server

- **ReliaSoft-Hosted Licensing**
  - You received only a license key (a 32-digit alphanumeric code)
  - Requires you to connect with ReliaSoft’s secure external license server to activate/deactivate licenses and to control access for multi-user (floating) license seats

One or both methods can be used on the same computer. For example, if you have your own single-user license for BlockSim and will share your department’s new multi-user (floating) license for Weibull++/ALTA, you will receive a license key for BlockSim and a license settings file for Weibull++/ALTA.

If you will use both types of licensing on the same computer, use the install instructions for locally hosted licenses. When you launch any of the applications that aren’t included in your license settings file, the ReliaSoft License Manager will allow you to perform the activation of your ReliaSoft-hosted license(s) using a product license key.

Your license information, along with the name and contact information that you provide during the activation process or upon first launching an application, can be viewed by clicking any of the main headings in the Application Setup or by going to the Contact Information tab of the License Manager (File > Help > License Manager).

The contact information used elsewhere in the software (such as in plots, report output, e-mail alerts, etc.) is stored in the database and managed via the User Login and Contact Information window (My Portal > Users > My Profile). If you need to change your contact information, you must apply the same change(s) to each database that you work with.
Requirements for All Synthesis Installations

- Before running the installation program, make sure your computer meets the system requirements for Synthesis.
- You must be logged in with a user account that has administrative rights.
- It is strongly recommended that you close all other applications during the installation.

Installing Using Locally Hosted Licensing

If you received a license file (*.lic) or license settings file (*.prnrsl), you will be using locally hosted licensing. This allows you to manage available license seats or CRS units in-house without the requirement to connect to ReliaSoft’s external license server.

**IMPORTANT:** The first step is for a license administrator to configure your organization’s license server and provide each individual user with a) the path to the license server/host (e.g., 6220@servername) and a license settings file (*.prnrsl) that specifies which ReliaSoft products on your computer will use locally hosted licensing. For detailed instructions, see http://www.synthesisplatform.net/licensing_locally_hosted.htm.

Perform the following steps for each client installation. If you have previously connected the client computer to the appropriate license server, you can start at step 4.

1. Open the Synthesis ePack and decompress the *.zip archive in the Locally Hosted Licensing Utility folder
2. Install the HBM Prenscia Licensing Administration utility by double-clicking licinst.exe and following the prompts. The utility will start as soon as installation is complete.
3. On the Client tab of the Licensing Administration utility, click Set Client License Path and enter the path to the license server (e.g., 6220@servername).
4. Install the Synthesis desktop applications by double-clicking the installation program from the ePack (e.g., Synthesis11_1.exe) and following the prompts.
5. Open the Import/Export License Settings utility by choosing ReliaSoft > Synthesis 11 > Additional Tools > Synthesis 11 License Settings Import-Export in the Windows Start menu. Follow the on-screen instructions to import the license settings file.

The first time you launch an application, you may be asked to provide your name and basic contact information. This is required to be eligible for technical support.

**Note:** Applications using locally hosted licensing must have an active connection to the license server unless you have borrowed a license. If you see a message that indicates that a license could not be obtained, this could be for a variety of reasons (e.g., you are not connected to the license server, the license server is down or there are no seats or CRS units available for the license). In addition, if you lose
connection to the license server while you are using an application, you will see a message warning you to save your work before the application closes.

**Installing and Activating Using ReliaSoft-Hosted Licensing**

If you are requesting a demo or have already received a license key (a 32-digit alphanumeric code), you will be using ReliaSoft-hosted licensing. With this type of licensing, you must be able to connect with ReliaSoft’s secure external license server to register and activate or deactivate the application(s). This external server also controls access for multi-user (floating) licenses.

If your computer has an active Internet connection and your firewall allows the software to access the secure ReliaSoft License Server at https://Validate.ReliaSoft.org, only a few simple steps are required for activation:

1. Install the Synthesis desktop applications by double-clicking the installation program from the ePack (e.g., Synthesis11_1.exe) and following the prompts.

2. The first time you launch an application, the activation wizard will appear. On the first page, select whether you want to activate a license or request a free demo license.

3. On the next page, enter a valid e-mail address to serve as your **ReliaSoft ID**. This is the e-mail address where you will receive confirmation e-mails from the ReliaSoft License Server. This must be your company e-mail address — not gmail, hotmail, etc.
   - **Name and Contact Info**: If this is the first time that you have registered a Synthesis application on this computer with this e-mail address, the next page will request your name and basic contact information.
   - **Demo License**: If you need a demo license, most requests will be addressed immediately during normal business hours; for some locations, please allow up to 2 business days.

4. On the next page, enter the product license key provided by ReliaSoft. **Tip**: If you are able to copy the key from a product delivery e-mail, the Paste icon saves time by automatically entering each section into the appropriate input box.

   - **Confirmation Codes**: If your license type requires a confirmation code, the next page requires you to copy/paste a code that you will receive from ReliaSoft via e-mail. **Tip**: If the e-mail does not appear in your Inbox within a few minutes, check your Junk mail or SPAM folders.
• **Activate Multiple Applications:** If your license key includes other Synthesis applications that have not yet been activated on this computer, the next page gives you the opportunity to activate any or all of them at the same time.

5. When you see the “Your product has been activated” message, click **Finish** to start using the software.

If the computer does not have an active Internet connection, or if you encounter issues with the firewall, there are other ways to complete the activation. Please visit [http://www.synthesisplatform.net/licensing.htm](http://www.synthesisplatform.net/licensing.htm) for details. And, of course, you can always contact ReliaSoft for assistance ([http://www.reliasoft.com/contact.htm](http://www.reliasoft.com/contact.htm)).

### Uninstalling Synthesis

If you wish to stop using all of the Synthesis desktop applications on this computer, you can perform the following steps to uninstall Synthesis:

**Tip:** If you are using ReliaSoft-hosted licensing (i.e., if you received a license key and activated specific application(s) on your computer), you also have the option to deactivate one or more applications without performing a complete uninstall. For instructions, see [http://www.synthesisplatform.net/license_deactivation.htm](http://www.synthesisplatform.net/license_deactivation.htm).

1. Make sure you do not have any Synthesis applications currently open.

2. For locally hosted licenses, if you are uninstalling permanently (i.e., if you are not doing this as part of an uninstall/reinstall), open the Import/Export License Settings utility by choosing **ReliaSoft > Synthesis 11 > Additional Tools > Synthesis 11 License Settings Import-Export** in the Windows Start menu. Follow the on-screen instructions to delete the license settings file.

3. Open the Windows Control Panel and click **Programs and Features** (or use the search box in the Windows Start menu to find and select **Add or Remove Programs**).

4. In the Uninstall or change a program window, double-click **ReliaSoft Synthesis 11** and follow the prompts.

5. If you have installed the HBM Prenscia Licensing Administration tool, you can follow similar steps to uninstall it.
Chapter 1: Getting Started

License Manager
The License Manager allows you to view and manage license-related details for the Synthesis desktop applications that are currently activated on your computer. You can use this interface to:

- View and, for ReliaSoft-hosted licenses, edit the contact information that is on file with ReliaSoft or change the password associated with your ReliaSoft ID. [Learn more...]
- For ReliaSoft-hosted licenses, deactivate the current application (if you don't plan to continue to use it on this computer or for this user). [Learn more...]
- For ReliaSoft-hosted floating licenses, check out or check in a license. [Learn more...]

To open the License Manager, click the License Manager link in the Help Center or choose Help > Updates & Licensing > License Manager.

You may be prompted to enter the password that was sent via e-mail when you first registered your ReliaSoft ID. This password is required if you want to modify your contact information. For everything else, you can click Cancel to proceed without it. (If you forgot your password, you can request to have the information sent to the e-mail address on file for your registration by clicking E-mail my password to me.)

Contact Information and Password
The Contact Information page displays the name, phone number and other details that are on file with ReliaSoft. For locally hosted licenses, this information is read-only and can only be edited by uninstalling and reinstalling the software. For ReliaSoft-hosted licenses:

- If you need to download the latest information from the license server, click Synchronize.
- If you want to change your password or any of the current contact information, type the new information into the fields on this page and then click Update Information on Server.

Both actions require authentication. If you have not already entered the current password that's associated with your ReliaSoft ID, you will be prompted again to enter it.

Deactivate the Current Application
For ReliaSoft-hosted licenses, if you don't plan to continue to use the current Synthesis application on a particular computer (or for a particular user), you can use the License Manager to deactivate it. This does not require authentication; you can proceed with the deactivation even if you have not entered your password.
Click the **Deactivate** button in the current product area on the **Products** page.

![Image of the Deactivate button](image)

The application will shut down immediately after you deactivate, so you will be prompted to confirm that you're ready to continue. If you later try to access this application again for this computer/user, you will be prompted to repeat the activation process.

**Borrowing Licenses**

For certain license types, your computer must be able to connect to a license server to determine whether shared license seats (or, for token-based licenses, the required number of CRS units) are available when you attempt to launch a Synthesis application.

If you need to use the application(s) when your computer is not connected to the license server, you can either "borrow" or "check out" the licenses (depending on the license type). This reduces the number of seats (or CRS units) available to other users until the licenses are returned. (For ReliaSoft-hosted licenses, you can also use this feature to make sure a license seat will be available when you need it.)

**Borrowing Locally Hosted Licenses**

If you have a locally hosted license, you can use the ReliaSoft License Borrowing utility to borrow licenses for selected product(s) for a specified duration.

**IMPORTANT:** If at least one ReliaSoft product with a locally hosted license is borrowed, you will only be able to use the product(s) that are borrowed and only when the computer is not connected to the license server. All desired products must be borrowed or returned at the same time.

If any of the Synthesis applications on your computer use a ReliaSoft-hosted license (i.e., a license key rather than a license settings file), they will be unaffected by locally hosted license borrowing. For those products, see **Checking Out ReliaSoft-Hosted Licenses** below.
Chapter 1: Getting Started

**Borrow License(s)**
Before attempting to borrow licenses, first make sure that your computer is connected to the license server and shut down all Synthesis desktop applications.

1. To open the ReliaSoft License Borrowing utility, navigate to the ReliaSoft > Synthesis 11 > Additional Tools folder in the Windows Start menu and click ReliaSoft License Borrowing 11.
2. The window shows all of the Synthesis desktop applications on your computer that use locally hosted licensing. Specify the borrow duration and select which product(s) you want to borrow. (Remember that all desired products must be borrowed or returned at the same time.)
3. Click Borrow Selected Licenses.
4. Close the window.

You will only be able to use the product(s) that are borrowed, and only when the computer is not connected to the license server. If you need to change which products are borrowed, you can reconnect to the license server and repeat the same steps again (this will restart the borrow duration for all selected products). If you need to be able to use the applications while connected to the server, you can return the licenses as described below.

**Return License(s)**
Before attempting to return licenses, shut down all Synthesis desktop applications and reconnect your computer to the license server.

1. Open the ReliaSoft License Borrowing utility.
2. Click Return All Licenses.
3. Close the window.

*Note:* You can borrow licenses only while your license is valid (e.g., if the annual expiration date of your locally hosted license is 2 days from now, you cannot borrow a license for a duration of 3 days). In addition, you cannot borrow licenses during the 24 hours prior to annual license expiration.

**Checking Out ReliaSoft-Hosted Licenses**
If you have a ReliaSoft-hosted floating license, you can use ReliaSoft's License Manager to reserve a license.

1. Open the Synthesis application.
2. Open the License Manager by clicking the **License Manager** link in the [Help Center](#) or choosing **Help > Updates & Licensing > License Manager**.

3. In the current product area on the **Products** page, click **Check Out** or **Check In**.
Chapter 2: Repositories and Projects

With integration into the Synthesis Platform, ReliaSoft's desktop applications have transitioned from a standalone document/file format to a multi-user, database-driven approach. This offers enormous potential to integrate reliability program activities and tools, while simultaneously facilitating effective information sharing and cooperation between engineering teams of any size.

The experience of working in a database-driven, multi-user environment will be a bit different than using prior versions of ReliaSoft’s applications (Version 7 or older) and other document-centered applications such as Microsoft Excel. For example, your organization (or team) will need to choose the most appropriate database type and security, implement shared settings that will effectively facilitate project management, and establish adequate backups and database maintenance to protect against data loss. In addition, individual users must be aware that changes are saved automatically as they work (except with the Synthesis file type *.rsr11), and become familiar with the features that facilitate simultaneous access by multiple users.

This chapter discusses some of the basic requirements for using Synthesis repositories and projects. For information about other features, see Synthesis Platform Tools.

Synthesis Repositories

Database Types

Synthesis desktop applications offer three types of databases for storing projects and analysis data. The type of database you choose will depend on the requirements of your organization.

- **Standard repositories** (*.rsr11) are basic database files for single- or multi-user environments. Implementation of a database server is not required; however, there are limits on the amount of data and the number of simultaneous users.

- **Synthesis files** (*.rsf11) are similar to standard repositories except that they can only be used by one person at a time, and changes are not saved until you choose File > Save or Save As. This type of database is therefore best for individual users who are working alone in a single Synthesis desktop application and prefer to be able to close a file without saving changes.

- **Enterprise repositories** require implementation and support of Oracle or Microsoft SQL Server, but they are a more robust platform that can store much more analysis information in the same database and support access by many more simultaneous users.
Chapter 2: Repositories and Projects

Synthesis applications are compatible with Microsoft SQL Server 2008 or later and Oracle 10g or later (including the free Express editions of all of these). They can be accessed via an enterprise repository connection file with the extension *.rserp.

**Standard Repositories**

A standard repository is a basic database file for single- or multi-user environments. Implementation of a database server is not required; however, there are limits on the amount of data and the number of simultaneous users. (If you prefer to use a more robust Oracle or SQL Server database, see Enterprise Repositories. If you plan to work alone and don’t want changes to be saved automatically, see Synthesis Files.)

**Creating a New Standard Repository**

To create a new standard database, choose File > New > Standard Repository.

In the Repository name field, specify the filename for the new *.rsr11 file. The path where the file will be saved is shown below this field; to change the location, click the browse icon in the field.

The following options are available when you create a new standard database:

- Select the Apply login security check box if you want the new database to be login secure. You can then select the Open security window upon creation check box if you want to add user accounts as part of the database creation process. Note that you cannot automatically remove security from a database once it has been enabled. However, you can create a new non-secure database and use the Import from existing repository check box to automatically import all of the data from the secure database to the non-secure one.

- Select the Import from existing repository check box if you want to import entire projects and other data from an existing database, after the new database is created.

**Opening an Existing Standard Repository**

If you have opened the file recently, choose File > Recent and then select the file in the Recent Repositories list.

Otherwise, choose File > Open Repository and then browse for the *.rsr11 file.
If the repository has login security enabled and you are unable to connect, you may be encountering one of the following issues:

- **No access to the repository.** If you have not been given access to the repository, you will see a message stating that your account in the repository is not active or not assigned to at least one security group. You will need assistance from someone who can create and update user accounts (see Managing User Accounts).

- **Windows authentication failed.** If your Windows login (domain and username) is different from what was specified for your user account, you will see a message to connect using alternative credentials. You will need assistance from someone who can enable the use of alternative credentials for your user account.

### Synthesis Files

Synthesis files (*.rsf11) are similar to standard repositories except that they can only be used by one person at a time, and changes are not saved until you choose File > Save or Save As. This type of database is therefore best for individual users who are working alone in a single Synthesis desktop application and prefer to be able to close a file without saving changes. If your workflow demands simultaneous access by multiple users, we recommend that you use either a standard database or enterprise database.

Note that if you have the same Synthesis file open simultaneously in two different Synthesis applications on the same computer (this situation is not common), saving changes in any of the open applications will save all changes up to that point.

### Creating a New Synthesis File

To create a new Synthesis file, choose File > New > Synthesis File.

In the Repository name field, specify the filename for the new *.rsf11 file. The path where the file will be saved is shown below this field; to change the location, click the browse icon in the field.

The following options are available when you create a new Synthesis file:

- Select the Apply login security check box if you want the new database to be login secure. Note that:
  - If you do not apply login security, any database user will be able to access and edit your Synthesis file, so long as the file is saved in a location that the user has read/write access to (e.g., a shared network folder).
Chapter 2: Repositories and Projects

- If you apply login security, only you will have access to the file; however, you can grant other database users the permissions to view/edit your file, if desired. Select the Open security window upon creation check box if you want to add user accounts to the file as part of the database creation process. (For complete instructions on implementing security settings, see Security Options.)

Note that you cannot automatically remove security from a Synthesis file once it has been enabled. However, you can create a new Synthesis file and use the Import from existing repository check box to automatically import all of the data from the secure file to the non-secure one.

- Select the Import from existing repository check box if you want to import entire projects and other data from an existing database, after the new file is created.

Opening an Existing Synthesis File
If you have opened the file recently, choose File > Recent and then select the file in the Recent Repositories list.

Otherwise, choose File > Open Repository and then browse for the *.rsf11 file.

If you are unable to open a Synthesis file, you may be encountering one of the following issues:

- File is in use. Synthesis files can only be used by one person at a time; therefore, it is automatically locked to the first user who has it open. You will not be able to open nor view the contents of the file until the other user closes the file.

- If the Synthesis file has login security enabled, you may also encounter the following issues:
  
  - No access to the repository. If you have not been given access to the repository, you will see a message stating that your account in the repository is not active or not assigned to at least one security group. You will need assistance from someone who can create and update user accounts (see Managing User Accounts).

  - Windows authentication failed. If your Windows login (domain and username) is different from what was specified for your user account, you will see a message to connect using alternative credentials. You will need assistance from someone who can enable the use of alternative credentials for your user account.

Enterprise Repositories

Unlike standard repositories or Synthesis files, enterprise repositories require an established database server with Oracle or Microsoft SQL Server. This allows you to store more analysis information in the same repository and support access by many more simultaneous users.
Synthesis applications are compatible with Microsoft SQL Server 2008 or later and Oracle 10g or later (including the free Express editions of all of these).

To establish a database server, you will need to purchase an appropriate license package from Oracle or Microsoft. The license, as well the IT maintenance and support needed to establish the database server, is separate from the ReliaSoft license agreement and must be negotiated directly with Oracle or Microsoft.

As an alternative, you may choose to use the free versions of Oracle or SQL Server if the expected load for the database fits within the limited capabilities of the Express edition (as specified by Oracle/Microsoft). With the free editions, you can establish a functioning enterprise database on your own without making a large investment of time and resources. If your organization's needs grow beyond the capabilities of the Express edition, you can then upgrade to a more robust version with the appropriate IT infrastructure and support.

**Tip:** Although ReliaSoft cannot provide full documentation and support for third-party database platforms, we do provide a limited number of resources as a convenience for users who wish to explore the possibilities of an enterprise database implementation. For resources on SQL Server (including instructions for configuring the Express edition), see [http://synthesis.reliasoft.com/sql_server.htm](http://synthesis.reliasoft.com/sql_server.htm). For resources on Oracle, see [http://synthesis.reliasoft.com/oracle.htm](http://synthesis.reliasoft.com/oracle.htm).

The following topics will be of interest to database administrators:

- Creating a New Enterprise Repository
- SQL Server Logins or Impersonation
- Upgrading an Enterprise Repository (from Version 8, 9 or 10)
- Synthesis Admin Tool

The following topics will be of interest to all enterprise repository users:

- Creating an Enterprise Repository Connection File (*.rserp)
- Monitoring Connection Speed

**Creating a New Enterprise Repository**

If your organization already has established a database server with Oracle or Microsoft SQL Server and you have the permissions necessary to create databases on the server, you can create a new Synthesis enterprise repository by choosing **File > Manage Repository > New Enterprise Repository**.
Tip: If you need to be able to create an enterprise database without using a Synthesis desktop application (i.e., without taking up one of the available license seats), you can access this same feature from the Synthesis Admin tool.

You can choose to create the new database in either Oracle or Microsoft SQL Server.

If you choose **SQL Server**, you will be required to enter:

- **Server Name**: The name of the Microsoft SQL Server implementation where the new database will be created. Note that if you are using SQL Server Express, the server name is usually your login for that computer followed by \\SQLEXPRESS (e.g., Username\SQLEXPRESS).

- **Database Name**: The name of the new database that will be created.

If you choose **Oracle**, you will be required to enter:

- **Port**, **Host** and **Service** identifiers for the Oracle server where the new database will be created.

- The **Schema** of the new Enterprise database.

- The **Password** for the new enterprise database schema.

- The administrative username and password for the Oracle server (entered in the Admin Information area).

For either server type, select the **Import from existing repository** check box if you want to import entire projects and other data from an existing database.

Click **OK** to create the database. The database will not open automatically; you must connect to it. (See **Connecting to an Existing Enterprise Repository**.)

**Connecting to an Existing Enterprise Repository**

If your organization has already created an enterprise database on Oracle or Microsoft SQL Server and you have an active user account, you can use an enterprise repository connection file (*.rserp) to connect with it. You can create this file yourself or use a file that has been created by someone else. Once this file is created, it can be used to connect to the database and to import from or export to the database.

**Creating a Connection File**

To create a connection file, choose **File > New > Enterprise Repository Connection File**.
Chapter 2: Repositories and Projects

This command creates a Synthesis repository connection file (*.rserp) that is stored locally on your computer; the file contains all of the necessary information for connecting to the enterprise database.

Enter a name for the connection file, then choose the database type and version (i.e., Microsoft SQL Server 2008 or later, or Oracle 10 or later).

- For SQL Server databases, enter the server name and database name. Select the Use impersonation check box if you want the new connection file to impersonate a Windows user account with a SQL Server login that can be shared by multiple users. This connection file can then be distributed to any user who does not have his/her own individual SQL Server login and is not part of a Microsoft Active Directory® group that has a login. (See SQL Server Logins or Using Windows Impersonation.)

- For Oracle databases, enter the port, host and service identifiers and the database schema. Your Windows login credentials are used for access to the database; enter your Windows password.

Using an *.rserp File to Connect to an Enterprise Repository

If you have used the connection file recently, choose File > Recent and then select the file in the Recent Repositories list.

Otherwise, choose File > Open Repository and then browse for the *.rserp file.

If you are unable to connect to an enterprise repository, you may be encountering any of the following issues:

- **No access to the repository.** If you have not been given access to the repository, you will see a message stating that your account in the repository is not active or not assigned to at least one security group. You will need assistance from someone who can create and update user accounts (see Managing User Accounts).

- **Windows authentication failed.** If your Windows login (domain and username) is different from what was specified for your user account, you will see a message to connect using alternative credentials. You will need assistance from someone who can enable the use of alternative credentials for your user account.

- **Cannot connect to the server or login failed.** Server-related issues may occur for several reasons, and you may see various messages pertaining to the situation. Common issues are:
  - You do not have a network connection or you may have entered the incorrect database name (i.e., Synthesis repository name) or server name in the connection file.
Chapter 2: Repositories and Projects

- The server may not be configured to allow remote connections, has certain firewall settings or is experiencing other issues. In this case, you will need to contact the IT support group responsible for the server.

- In SQL Server databases, a login issue may occur if your username is not associated with a SQL Server Login. (See SQL Server Logins or Using Windows Impersonation.)

Note: If you get an "error occurred when reading the connection file" message, the connection file may be corrupted or is using old encryption. You can create a new connection file by choosing File > New > Enterprise Repository Connection File.

SQL Server Logins or Using Windows Impersonation
Connecting with a SQL Server database via Windows authentication requires a "SQL Server login" that allows the database platform to recognize the user and gives access to the Synthesis repository. There are three ways that a Synthesis user account may be recognized by SQL Server:

- **Individual Login**: The user has an individual SQL Server login that is associated directly with his/her Windows username.

- **Group Login**: The user belongs to an Active Directory group that has a SQL Server login shared by all members of the group.

- **Use Impersonation for Connection File**: The user does not have an individual or group login but he/she connects to the database with an enterprise connection file (*.rserp) that impersonates another Windows user account that does have a SQL Server login.

Your organization may choose to use any or all of these methods for your Synthesis implementation (e.g., some users may have their own individual logins, while other users connect using Windows identity impersonation). This document provides an overview of all three options.

**Option 1: Creating Individual SQL Server Logins**
If you choose to create individual SQL Server logins for some or all of the Synthesis user accounts, you have two options. (For details and instructions on performing these tasks in SQL Server, see http://www.reliasoft.com/synthesis/sql_server.htm.)

1. A database administrator for SQL Server can create SQL Server logins in advance for every potential user and give the logins access to the application database (at least the db_datareader and db_datawriter roles are required). This would be performed directly in SQL Server (not via one of the Synthesis applications).
2. A database administrator for SQL Server can grant the appropriate level of database authority for creating SQL Server logins and database roles (e.g., securityadmin or sysadmin) to any user who has the ability to create user accounts in the Synthesis repository. The additional authority would be added directly in SQL Server. Then, when any of these administrative users creates a new user account via the Synthesis application, the required SQL Server login can be created and the application database roles can be assigned automatically at the same time.

If you are using the first approach, clear the **Create SQL Server login** check box that is displayed when you are adding or importing a user account. If you are using the second approach, you must select this check box.
**Tip:** If the user already has a SQL Server login and access to the application database, it does not matter whether you select or clear the **Create SQL Server login** check box because the application attempts to create the login only if one does not already exist.

Furthermore, if the user who is creating the user account does not have the necessary level of database authority in SQL Server, the login will not be created even if the check box is selected.

### Option 2: Using a Group Login

If the user belongs to an Active Directory group that has a SQL Server login shared by all members of the group and that group has access to the application database, you can clear the **Create SQL Server login** check box that is displayed when you are adding or importing a user account.

For example, base installations of Microsoft SQL Server Express 2008 include the "Builtin\Users" Active Directory group as a SQL Server login by default. This means all users with a Windows account for that domain will be able to log in to the enterprise database with no need to create individual SQL Server logins in SQL Server Express. However, it will still be necessary to grant access for this group login to the application database (at least the db_datareader and db_datawriter roles are required).

### Option 3: Using Windows Impersonation for the Connection File

If you choose to have some (or all) users connect to the SQL Server database with a connection file that impersonates a shared Windows user account that has a SQL Server login, you must do the following:

- A Windows network administrator must establish the shared user account on Windows.
- A database administrator for SQL Server must create a SQL Server login for the shared Windows user account and grant this login access to the application database (at least the db_datareader and db_datawriter roles are required).
- A Synthesis user must create an enterprise repository connection file that impersonates the shared Windows user account:
  1. Choose **File > New** then click **Enterprise Repository Connection File**.
  2. Under **Repository Connection Settings**, select **Microsoft SQL Server (2008 or later)** from the drop-down list and then select the **Use impersonation** check box.
  3. Enter the server and database name for the SQL Server database, then enter the domain, username and password for the shared Windows account that users will need to impersonate.
  4. Click **OK** to create the connection file (*.rserp). It will be stored in the location specified under **Connection File Name**. Note that the default filename will be...
“SQL_(Server Name)_(Database Name),” but you can assign any name that fits the process your organization will use for distributing the file to users. (Note that while the window shown next is for Weibull++, the settings are the same for all Synthesis applications.)

Once you have created a connection file that impersonates the shared Windows user account, you can distribute the file to any Synthesis user who needs it. To connect to the repository using this file, the user can:

1. Choose **File > Open Repository** and browse for the connection file.
2. Click **Open** to connect with the repository.
Chapter 2: Repositories and Projects

After the first connection, this *.rserp file will be saved in the list of recent repositories, which can be accessed by choosing **File > Recent**.

**Note:** For the purpose of being recognized by SQL Server and accessing the application database, the user will be impersonating the shared Windows login. For the purpose of performing actions via the Synthesis applications, the user’s actions will be governed by his/her own user account in Synthesis. In other words, multiple users can connect with the database using the same enterprise connection file, but their activities within the Synthesis applications will be governed by the permissions established in their own individual Synthesis user accounts, and any changes made to the analysis data will be recorded in Synthesis under their own usernames.

---

**Enterprise Repository Connection Speed**

If the Synthesis desktop application is exhibiting slow performance when you’re connected to an enterprise repository, the issue may be related to your network connection. The MDI status bar displays a connection speed indicator on the lower right side of the window.

The following icons are used to indicate the connection speed. In cases of poor network performance, you will need to request assistance from the IT support group responsible for the server.

- 🔄 < 30 ms: Good (acceptable performance)
- 🔄 30 - 70 ms: OK (may exhibit some delays in operations, opening/closing windows, etc.)
- 🔄 70 - 110 ms: Slow (will exhibit some delays in operations, opening/closing windows, etc.)
- 🔄 110 - 150 ms: Very slow (will exhibit significant delays in operations, opening/closing windows, etc.)
- 🔄 > 150 ms: Extremely slow (will result in unacceptable performance and usability)

**Upgrading an Enterprise Repository from a Previous Version**

If you have an existing enterprise database that was created with any of the Version 8, Version 9 or Version 10 Synthesis applications, you can transfer or convert all of the existing data into a new database that is compatible with the latest version.

All of the same requirements for [creating a new enterprise database](http://blocksim.reliasoft.com) apply here (e.g., you must have an established database server and the necessary permissions to create a database on the...
server). In addition, you must be a member of the Admin group in the database to perform the task.

**Tip:** If you need to be able to upgrade an enterprise database without using a Synthesis desktop application (i.e., without taking up one of the available license seats), you can access this same feature from the Synthesis Admin tool.

### Upgrading from Version 9 or 10
It is strongly recommended that you create a backup of the Version 9/10 enterprise repository. The upgrade process converts the database itself to the latest version. This change cannot be undone.

To upgrade the database, choose **File > Manage Repository > Upgrade Version 9/10 Repository**.

In the window, specify the Version 9/10 enterprise database that you wish to upgrade. Click **OK** to start the process.

### Upgrading from Version 8
You do not need to create a backup before upgrading a Version 8 enterprise repository. The upgrade process does not involve a direct conversion of data, but rather copies over all existing data into a new database. This complete switch to a new database is required in order to support the exclusive features in the latest version.

To upgrade the database, open any Version 11 Synthesis application and choose **File > Manage Repository > Upgrade Version 8 Repository**.

Use the left side of the window to specify the Version 8 enterprise database that you wish to upgrade. Use the right side of the window to define the new Version 11 enterprise database that the existing data will be copied into. Click **OK** to start the upgrade.

### Synthesis Admin Tool
The Synthesis Platform includes an admin tool that allows a database administrator to set up and manage enterprise databases without requiring a software user license or an activated Synthesis desktop application.
Chapter 2: Repositories and Projects

To use the Synthesis Admin tool, your organization must have already established a database server with Oracle or Microsoft SQL Server, and you must have the permissions necessary to create databases on the server.

To access the tool, open the Windows Start menu and choose ReliaSoft > Synthesis 11 > Additional Tools > Synthesis 11 Admin from the programs list. Alternatively, you can open the Windows Start menu and type Synthesis 11 Admin in the search bar.

The following features from the Synthesis desktop applications are available in the admin tool.

- Creating a new enterprise repository
- Upgrading a Version 10, Version 9 or Version 8 enterprise repository
- Manage Synthesis user accounts:
  - Adding and editing user accounts
  - Importing users from Active Directory
  - Creating alternative credentials
  - Editing user login and contact info
  - Managing security groups
- Configuring the XFRACAS or Synthesis Enterprise Portal (SEP) applications on a web server. For details, please consult the implementation guides for those web applications.

Projects

In Synthesis repositories, projects serve as a way to keep related analyses together. Each project can contain analyses (e.g., folios, diagrams, plots, FMEAs, etc.), a Project Planner, resources that can be shared between analyses (e.g., models, tasks, actions, etc.) and attachments.

Any project can be opened in any Synthesis application; however, application-specific analyses (e.g., folios in Weibull++, diagrams in BlockSim, etc.) are visible only in the application(s) that can edit them.
Creating and Managing Projects

This topic describes how to create and manage the projects that are accessible to you via the project list (View > Project Manager > Show Project Manager). This depends on your permissions in the database and any security that has been defined at the project level.

There are three types of projects: private, public or reference. In addition, a project may be locked or checked out at any given time. Each type of project is displayed under the appropriate heading in the project list:

![Project List Diagram]

Tip: The Manage Projects window (Project > Management > Manage Projects) allows you to perform administrative tasks for multiple projects all at once, and to manage the private projects of other users. (See Manage Projects Window.)

Creating a New Project

When you create a new project, you must specify whether it will be public, private or reference. Select or right-click the appropriate heading in the project list and (i.e., Private, Public or Reference), and then choose Project > Management > Create Project.

The selected project type will be displayed at the bottom of the Project Properties window. If desired, you can change the selection before clicking OK to create the project.
Tip: If you later need to change the project type, select the project and choose Project > Security > [Make Private, Make Public, or Make Reference]. The same commands are also available in the Manage Projects window.

Duplicating Projects
To duplicate an existing project, select it and choose Project > Management > Duplicate Project.

This command will create an exact duplicate of the original project with a name that contains an increment number (e.g., Project_1, Project_2, etc.). Note that duplicate projects do not retain the security settings of the original project.

Deleting Projects
To delete a project, select it and press DELETE or choose Project > Management > Delete Project.

To make sure that your analysis information is not deleted by mistake, you will always be prompted to confirm before proceeding. By default, the project will be moved to the recycle bin, which will give you a chance to recover it later if needed. If you want to permanently delete the project now (no way to undo unless you have a backup or restore point), clear the Send project to recycle bin check box in the confirmation window.

Note: You cannot delete a reference project if any of its resources are in use, including by projects in the recycle bin.

Project Properties
The Project Properties window will be displayed when you create a new project or when you choose Project > Management > Edit Project Properties.
Chapter 2: Repositories and Projects

The options available in this window will vary depending on which application you are using and whether the database has login security enabled. For MPC, see MPC's Project Properties (below). For all other Synthesis desktop applications, this may include:

- **General Tab**
- **Security Tab** (available only for public/reference projects in secure databases)
- **Configurable Settings Tab** (only in Xfmea/RCM++/RBI)

In addition, the status bar at the bottom of the window always displays the following information:

**Project Owner:** The user who has been identified as the project owner. In a secure database, the ability to edit the project properties is restricted to the project owner and to users with the relevant "manage all projects" permissions.

**Last Update:** The time and date the project was last changed/updated, and the user who made the change. This considers any change to any of the analysis data in the project (not just the project properties).

**General Tab**
The General tab contains the following options:

- **Name** is the identifier for the project that will appear in the current project explorer and in many other windows and reports throughout the software. This field is required and cannot contain any of the following characters: \ / : " * ? < > |.

- **Description** and **Remarks** can contain more detailed notes or information about the project.

- **Proprietary Label** can contain a copyright or distribution statement, if desired. This label may appear in the footer of some reports generated in Xfmea/RCM++/RBI or MPC.

- **Project Category** allows you to assign a project category that can be used to filter the projects displayed in the project list and in many other windows throughout the software.

In Xfmea/RCM++/RBI, this tab also contains:

- **FMEA Structure** determines how the software will display the effect and cause records in the FMEA hierarchy. This is applicable only in Xfmea/RCM++/RBI. (See Choosing the FMEA Structure in the Xfmea/RCM++/RBI documentation.)

- **Select Profile from Library** displays a list of all profiles that have been defined in the active library. When you choose a profile from the list, all of the configurable settings for the project will be set/reset based on the settings that have been predefined for that
profile. If you are editing a project, the current profile is shown in brackets. (In a secure database, the ability to add and edit a profile is available only for users with the "Manage profiles and templates in Xfmea/RCM++/RBI" permission.)

Security Tab
The Security tab is available only when you are working with a public or reference project in a secure database. For a full discussion on how to use these settings, see Planning Your Security Approach.

For quick access to the Security tab, you can select the project in the project list and choose Project > Security > Project Security.

Configurable Settings Tab
The Configurable Settings tab is available for Xfmea/RCM++/RBI only. It provides access to all of the configurable settings that have been defined for the current project, based on the profile that was selected on the General tab.

This tab allows you to make specific changes that will apply to the current project only. For example, if you are using a predefined profile but want to make a change to the interface style for this particular project only, you could click the Edit icon associated with the Interface Style drop-down list in the Interface Settings area.

It is important to note that any change to the Configurable Settings page will update the settings for the current project, but it will not alter the original profile. If you want the project’s current settings to be available as a new profile in the active library, click the Send Settings to Library button and then type the name and description for the new profile that will be created.

In the Enable Legacy Analyses section, you can choose whether to allow users to create and use DVP&R or DRBFM analyses in the project. These settings are not part of the profile and may be different for each project. (See Design Verification Plans (DVP&Rs) and Design Reviews Based on Failure Mode (DRBFMs) in the Xfmea/RCM++/RBI documentation.)
MPC’s Project Properties
For users of MPC, the interface has been customized to display only the information that is directly relevant for MSG-3 analyses. This includes the Name, Description, Remarks, and Project Category. In addition, you will be able to define the following:

- **Short Description** appears in the header of the Standard report template. It is not applicable for Dassault or Sukhoi reports.
- **Proprietary Label** appears in the footer of the Standard report template. It is not applicable for Dassault or Sukhoi reports.
- **MSG-3 Guidelines** displays a list of the available MSG-3 guidelines that can be used for the systems and powerplant analysis.
  - In most cases, the version that you select will not have any impact on the MSG-3 logic displayed in the interface and print-ready reports.
  - The only substantive difference occurs when you select MSG-3 Revision 2002.1 because this older version of the guideline uses slightly different titles for two of the maintenance significant item (MSI) questions, and lists the questions in a different order.
- **Model/Equipment/Effectivity** allows you to enter the information that will appear on the title page of the Dassault and Sukhoi templates.

Project Owner
For each project in a Synthesis repository, one user will be assigned as the project owner. By default, the owner will be the user who created the project, but this can be changed when needed.

In a secure database, being the project owner means that you have full permissions over the project. This includes the ability to edit the project properties, add/edit/delete project items and resources, lock and unlock, set security settings, create restore points and delete the project. These permissions are always in effect regardless of the project security settings or item permissions that may be in place.

Changing the Project Owner
To change the owner, select the project in the project list and choose Project > Security > Change Owner.
In a secure database, this is available only for users with the applicable "manage all projects" permissions.

Identifying the Project Owner
There are three ways to identify the current owner of a project:

- Use the filters in the project list to filter and/or group projects based on the project owner. For example:

  ![Project List Example]

- The Project Properties window (Project > Management > Edit Project Properties) displays the name of the current owner in the status bar at the bottom of the window.

- The Manage Projects window (Project > Management > Manage Projects) displays a list of all projects and their owners in a table format. You can use custom filters to filter, sort and/or group the list based on the project owner.

  ![Manage Projects Window Example]
Public, Private and Reference Projects

In Synthesis repositories, there are three types of projects you can create:

- A **public** project may be accessible to any user who has access to the database, depending on the **security settings** that have been implemented.

- A **private** project can be viewed and edited only by the **project owner**. The **project list** shows only your own private projects, while the **Manage Projects window** provides the ability to manage all users’ private projects (including delete, lock/unlock or changing the project type).

- A **reference** project is like any regular public project, except that you can share its **resources** and FMEAs with other projects in the database. This gives you a pool of resources that can be used throughout the database by specified users (based on the security settings for the reference project), while allowing you to maintain fully functional analyses within the reference project itself. (For more information, see **Local, Global and Reference Resources**, and **Linked FMEAs** in the Xfmea/RCM++/RBI documentation.)

In the project list, each type of project is displayed under the appropriate heading, as shown in the following example.

![Project List Image]

**Note:** In MPC, the Reference heading will appear only if reference projects already exist in the database (created by another Synthesis desktop application). You cannot create a new reference project or convert an existing project into a reference project in MPC.
Chapter 2: Repositories and Projects

Setting the Initial Project Type
When you create a new project, you must specify whether it will be public, private or reference. Select or right-click the appropriate heading in the project list and (i.e., Private, Public or Reference), and then choose Project > Management > Create Project.

The selected project type will be displayed at the bottom of the Project Properties window. If desired, you can change the selection before clicking OK to create the project.

Changing the Project Type
To change the project type for one project, select it in the project list and choose Project > Security and then one of the following options:

- Make Private
- Make Public
- Make Reference

To change the project type for multiple projects simultaneously, use the Manage Projects window instead.

Locked and Unlocked Projects
In all Synthesis repositories, a project can be locked to prevent users from editing the data. If a project is locked, it will be moved to the Locked heading in the project list and it cannot be edited by any database user unless it is unlocked again.

In a secure database, locking and unlocking a project are available only if the user a) is the project owner, b) has the "Lock or check out project" permission for the project or c) has the applicable "manage all projects" permissions.

Locking a Project
To lock a project, select it in the project list and choose Project > Security > Lock Project.
When a project is locked, all database users (including the user who locked the project) will have read-only access to the project. In addition, a locked project cannot be deleted or have its properties and public/private/reference status edited.

**Unlocking a Project**

To unlock a project, select it in the project list and choose **Project > Security > Unlock Project**.

*Tip:* The Manage Projects window allows you to select multiple projects and lock or unlock them all at once.

---

**Check In and Check Out Projects**

In all Synthesis repositories, both private and public projects can be checked out to temporarily allow one particular user to work on a project independently for a period of time and/or to work on a computer that is not connected to the network where the shared database resides (e.g., if you need to work on the project while you’re out of the office). When a project is checked out, two things happen:

- An editable copy of the project will be saved into a standard database (*.rsr11) in the specified "Checked Out" folder on your local computer. This database will have the same name as the project.

- The original project will be set to read-only and moved under the **Checked Out** heading in the project list. This allows other users who would normally be able to access the project to see that it is currently being edited exclusively by one particular user. It also provides read-only access to the latest version of the project at the time it was checked out so those users can query, copy data, etc. while you’re editing the project "offline."

You can then edit the project as needed in the standard database and check the project back in when you’re finished.

*IMPORTANT:* If the project uses resources or FMEAs from a reference project (e.g., linked FMEAs, models, URDs) the links won’t be maintained when you check out the project. Any linked resources/FMEAs will be replaced with local copies of the resources/FMEAs and stored directly within the project. See also Local, Global and Reference Resources.

---

**Specifying the "Checked Out" Folder**

By default, projects will be checked out to the default Documents folder on your computer (e.g., My Documents\ReliaSoft\Files\Checked Out).
Chapter 2: Repositories and Projects

To change this location, open the Backup/Check Out Options page of the Application Setup window and browse for a new default path under Check In/Out. Keep in mind that anyone who has access to the folder will have full access to the checked out project; however, only the user who has the project checked out will have the ability to check in the project.

Tip: If you need to work on the project from a different computer after it has been checked out to the local folder, you will simply need to make sure that the latest copy of the standard database file is saved back to the exact same check-out location and filename before you check the project back in.

Checking Out a Project
To check out a project, select it in the project list then choose Project > Management > Check In/Out > Check Out.

In a secure database, this is available only if the user a) is the project owner, b) has the "Lock or check out project" permission for the project or c) has the applicable "manage all projects" permissions.

Checking in a Project
To check in a project, select it under the Checked Out heading in the project list and choose Project > Management > Check In/Out > Check In.

Note that when you check in a project, the software creates a restore point, which is an exact replica (i.e., a backup) of the project before it was checked out. This allows you to restore the project to its prior state when and if needed. The restore point will include a description of the user who checked out the project, as well as the date and time of the check out. (See Restore Points.)

Undo Check Out
To discard changes and restore the project to the state it was in before it was checked out, select the project under the Checked Out heading in the project list and choose Project > Management > Check In/Out > Undo Check Out.

In a secure database, this is available only if the user a) is the user who checked out the project, b) is the project owner or c) has the applicable “manage all projects” permissions.
Manage Projects Window

The Manage Project window displays a list of all the projects that currently exist for the database and allows you to perform administrative tasks for multiple projects all at once. If you have created custom project filters, you can apply those same filters in this window.

To open the Manage Projects window, choose Project > Management > Manage Projects.

In a secure database, this is available only to users with the applicable "manage all projects" permissions. Only the type of project that you have permissions for will be displayed. Projects that are under the Locked, Checked Out and Recycle Bin headings will be visible only if you have permissions for all three project types.

Tasks You Can Perform

Some of the tasks you can perform in this window include:

- See a list of private projects created by other users (and perform any administrative tasks that may be needed for those projects).
- Change multiple public projects to private all at once, and vice versa.
- Change the owner for multiple projects all at once.
- Apply the same changes to the project properties for multiple projects all at once.
- Review and edit the security settings (if applicable) for multiple projects all at once.
- Delete, restore, lock and unlock, or undo check out for multiple projects all at once.
- Review and sort projects based on the user who made the last change to a project, the date/time of the last change and the last application that was used to make the change.

Tip: The Manage Projects window allows you to edit the properties of a project that is currently open or in use. When you make a change, the user who has the project open will see the change you have made when the database refreshes (the refresh happens automatically whenever the user makes a change, such as closing a window, selecting a different item, etc.).

Tools

The Manage Project window contains the following commands:

Project

Folder Close closes the Manage Projects window.
Chapter 2: Repositories and Projects

**Edit Project Properties** allows you to view and edit the properties of the selected project(s).

**Delete Project** permanently deletes the selected project(s) and bypasses the recycle bin. *There is no undo for delete* unless you have a stored backup or restore point.

**Restore Project** is available only when you have selected project(s) under the Recycle Bin heading. Each selected project will be recovered from the recycle bin and restored to its original location in the project list.

**Security**

**Lock Project** moves the selected project(s) into the Locked heading of the project list. When a project is locked, all database users (including the user who locked the project) will have read-only access to the project. In addition, a locked project cannot be deleted or have its properties and public/private/reference status edited. To unlock project(s), choose **Unlock Project**. (See Locked and Unlocked Projects.)

**Make Private** moves the selected project(s) into the Private heading of the project list. To move private project(s) to the Public heading, choose **Make Public**. (See Public, Private and Reference Projects.)

**Change Owner** assigns a different database user to be the owner for the selected project(s). (See Project Owner.)

**Project Security** is available only for public and reference projects in secure databases. It opens the Project Properties window with the Security tab active, where you can specify the user accounts that can view/modify the selected project. (See Planning Your Security Approach.)

**Check Out**

**Undo Check Out** discards all changes made to a checked out project and restores it to the state it was in at the time it was checked out. (See Check In and Check Out Projects.)

**Excel**

**Send to Excel** exports the data currently displayed in the Manage Projects window to an Excel spreadsheet.
Recycle Bin

The recycle bin is a temporary storage location for projects that have been deleted. It gives you a chance to restore the deleted project to its original location, if needed. Projects in the recycle bin are stored until you either empty the recycle bin or delete each individual project from the recycle bin.

Sending Projects to the Recycle Bin

Whenever you delete a project from a database, a confirmation window like the one shown next will appear.

![Confirmation Window]

If you want to move the project to the recycle bin, make sure the **Send project to recycle bin** check box is selected. If you want to immediately and permanently delete the project, clear the check box. **Remember that once you empty or delete a particular project from the recycle bin, there will be no way to get it back unless you have previously created a backup or restore point.**

Restoring and Deleting Projects from the Recycle Bin

In a secure database, the ability to restore and delete projects from the recycle bin is available only if the user a) is the **project owner**, b) has the "Delete project" permission, or c) has the applicable "manage all projects" permissions).

To restore a project from the recycle bin, select it and choose **Project > Management > Recycle Bin > Restore Project.**

To permanently delete a project in the recycle bin (no way to undo unless you have a backup or restore point), select it in the recycle bin and choose **Project > Management > Recycle Bin > Delete Project.**
Chapter 2: Repositories and Projects

To permanently delete all projects currently in the recycle bin (no way to undo unless you have a backup or restore point), select the Recycle Bin heading in the project list and choose Project > Management > Recycle Bin > Empty Recycle Bin.

Security

All enterprise databases use login security, meaning that the Synthesis applications use Windows authentication (or alternative credentials) to identify each user and control the user’s access via security groups. For a standard database or Synthesis file, you can choose whether to apply login security; if you don’t, any user who has read/write access to the file will have full permissions throughout the database.

By default, each user in a secure database will have the same set of permissions for every public/reference project in the database (e.g., Jane Engineer has read-write access to all projects, Bill User has read-only access to all projects, and so on). Alternatively, you can configure the database to provide different permissions for different public/reference projects, if desired (e.g., Jane Engineer has read-write access to all of Department A’s projects, but she has read-only access to other projects). With either approach, you also have the option to further limit access for specific project items (e.g., folios, diagrams, system hierarchy items, etc.) if needed. There are many different ways these options can be configured depending on your organization’s particular needs.

Tip: If you need to be able to manage an enterprise database without using a Synthesis desktop application (i.e., without taking up one of the available license seats), you can access the same security features from the Synthesis Admin tool.

Applying Login Security

All enterprise databases use login security. For standard databases or Synthesis files, there are two ways to apply login security if desired:

- Upon creating a new standard database or Synthesis file (File > New), you can make it login secure by selecting the Apply login security check box.
For an existing standard database, you can apply login security at any time by choosing File > Manage Repository > Users and Security and then clicking the Apply Login Security button at the lower left corner of the window.

When you create an enterprise database or apply login security to a standard database or Synthesis file, you will automatically be a member of the Admin security group, which has full permissions throughout the database. You can then use the Users and Security window to add/edit/delete other user accounts and assign them to appropriate security groups.

Note: You cannot automatically remove security from a database once it has been enabled. However, you can create a new non-secure database and use the Import from existing repository check box to automatically import all of the data from the secure database to the non-secure one.

Planning Your Security Approach

In secure databases, there are two basic factors that determine what a typical user can see and do in the database: the security group(s) that the user account belongs to and the public/reference project security settings.

This topic discusses two general approaches you can use to configure the security groups and project security settings to fit your organization’s specific needs:

- **Same permissions for all public/reference projects**
- **Different permissions for different public/reference projects**

Tip: In addition to these considerations, it is also important to note the following: a) Users with the applicable "manage all projects" permissions (in any of the security groups that they belong to) will always have full project-level permissions for all public or reference projects in the database; b) The
Chapter 2: Repositories and Projects

**Project owner** will always have full project-level permissions within that particular project; and c) The **item permissions** can be used to further limit access to specific items within a project (e.g., folios, diagrams, system hierarchy items, etc.).

**Same Permissions for All Public/Reference Projects**

If you want each user to have the same set of permissions for all public/reference projects in the database (e.g., Jane Engineer has read-write access to all projects, Bill User has read-only access to all projects, and so on), follow these steps:

1. **User Accounts and Security Groups**: Assign each user account to an appropriate security group. This can be one of the four security groups that are created by default in each new Synthesis repository — Admin, Power, User (Read/Write) or View (Read-Only) — or you can configure new or existing security groups to meet your particular needs. Select or clear the **Allow access to projects with repository-level security** check box. If some of the projects in the database will continue to use repository-level security, this allows you to specify whether each user will be able to access those projects.

   - If the option is selected (default), the user will be able to access any public/reference project that is set to use repository-level security, with the combined permissions from any of the assigned security groups.
   - If the option is cleared, the user will only be able to access a project if it is specifically assigned to a security group that he/she belongs to, or if the user account is specifically assigned to the project.
2. **Project Security**: Accept the default option on the **Security** tab of the Project Properties for all public and reference projects (**Project > Security > Project Security**). Note that if a user belongs to more than one security group (and the **Allow access to projects with repository-level security** check box is selected for his/her user account), that user will have the combined permissions of those groups in any project that is set to repository-level security.
Different Permissions for Different Public/Reference Projects

If you want the same user to have different permissions for different public/reference projects (e.g., Jane Engineer has read-write access to all of Department A’s projects, but she has read-only access to other projects), follow these steps:

1. **Security Groups**: Create a security group for each distinct type of access that users might need in any particular public/reference project. Here’s a simple example:
2. **User Accounts**: Assign the appropriate security group(s) to each user account. For the example shown below, the user will have read/write permissions in projects that are assigned to "Department A," and read-only access in projects that are assigned to "Read-Only."

If some of the projects in the database will continue to use repository-level security, the **Allow access to projects with repository-level security** check box gives you the option to decide whether each user will be able to access those projects.

- If the option is selected (default), the user will be able to access any public/reference project that is set to use repository-level security, with the combined permissions from any of the assigned security groups.
Chapter 2: Repositories and Projects

- If the option is cleared, the user will only be able to access a project if it is specifically assigned to a security group that he/she belongs to, or if the user account is specifically assigned to the project.

3. **Project Security**: Assign the appropriate security group(s) and/or specific user(s) for every public/reference project in the database.

   - When you assign a security group, every user who belongs to that group will be able to access the project with the permissions that are specified in the group.

   - When you assign a specific user, the combined permissions from all of the security groups that the user belongs to will be displayed. Use the check boxes to select which of those permissions will be in effect for that user in this particular project.

For the example shown below, users from Department A will have read/write access (because they belong to the "Department A" security group), users from Departments B and C will have read-only access (because they belong to the "Read-Only" security group) and Fred Consultant will have read/write access (because he belongs to the "Consultants" security group and has been specifically assigned to have those permissions in this project).
User Accounts

Every person who will access a Synthesis repository, be assigned to some role in an assigned action, and/or receive alerts via e-mail or SMS message must have a personalized user account in the database.

- **In non-secure databases**, the software automatically creates an account for anyone who opens the file. Every user has full permissions throughout the database, including the ability to create, edit or delete other user accounts (e.g., so you can modify contact information or send alerts to someone who has not yet had an account created automatically).

- **In secure databases**, the accounts must be created and managed by users with the "Manage users and logins" permission. The security group(s) assigned to each account determines what the user can see and do in the database.

To view and manage the user accounts in a database, choose **File > Manage Repository > Users and Security**.
Chapter 2: Repositories and Projects

This topic describes how to use the Users and Security window to create, edit or delete/deactivate user accounts. The same window can also be used to enable login security for a standard database or Synthesis file, and to manage security groups (permissions) for a secure database.

**Built-in Find/Filter, Configuration and Grouping Tools**
The Users tab of the Users and Security window offers the same filter, column configuration and grouping tools that are built in to other Synthesis utilities that use a similar grid (e.g., the Synthesis Explorer, Actions Explorer, etc.). For details about how to use each feature, see:

- Finding and Filtering Records
- Configuring Columns
- Grouping Panel

**Creating and Editing User Accounts**
The Users tab of the Users and Security window displays a table of all user accounts that have been created in the database. You can use the Add or Edit buttons below the table to create or modify individual accounts.

You can also import user accounts from Microsoft Active Directory by clicking the Active Directory button. (See Importing Users from Active Directory.)

Keep in mind the following requirements when creating new user accounts for a secure database:

- In order to use Windows authentication, the user must be logged in to a computer with the same domain/username that is defined in the Synthesis user account. If a user needs to connect to a database from a different domain, you can set up alternative credentials that will allow access without domain authentication. (See Creating Alternative Credentials.)

- In order to access the database, the user account must be assigned to at least one security group. (If you simply wish to send e-mail alerts to the user, a security group is not required.)

- For SQL Server databases, the username must be associated with a "SQL Server Login" that allows the database platform to recognize the user and give access to the application database. This can be accomplished with an individual login, a group login or Windows impersonation. (See SQL Server Logins or Using Windows Impersonation.)

**Deleting or Deactivating User Accounts**
If an account has never been used and you want to permanently remove it, select the account name from the list and click Delete.
If an account has already been logged in at least once (the **Last Login** column shows this information), attempting to delete the account will deactivate it instead. A deactivated account will not have access to the database.

You can manually deactivate an account by clearing the check box in the **Active** column for the account. To reactivate the account and give the user access to the database again, select the check box in the **Active** column.

**User Login and Contact Information**

The User Login and Contact Information window contains the contact information, alerts preferences and action resource details for an individual Synthesis user. In a secure database, it also includes access settings (security groups and alternative credentials).

To view or edit your own user account, double-click your name in the MDI status bar or choose **My Portal > Users > My Profile**.

To view or edit any user account in the database, choose **File > Manage Repository > Users and Security**, then double-click any row in the Users table. (In a secure database, this is available only for users with the **Manage users and logins permission**.)
Chapter 2: Repositories and Projects

All of the user account options are described below. Some of these settings cannot be modified when you are editing your own profile.

User Info Tab

- **Domain** and **Username** contain the credentials used by Windows authentication to identify the user and give him/her access to the database.

- **Contact Details**. Each user can update his/her own contact details, if desired. Note that the Display Name will appear in all projects, analyses and plots you create or modify in the database. Click the **Active Directory** button to update the contact details based on information stored in Active Directory.

- **User Image**. Each user can save a profile photo, which will appear in locations such as the **User Page** of My Portal. Saved images are resized to 100 x 100 pixels.

- **Security Groups** control the user’s access to the database. (See **Managing Security Groups**.)

- **Allow access to projects with repository-level security**
  - If the option is selected (default), the user will be able to access any public/reference project that is set to use repository-level security, with the combined permissions from any of the assigned security groups.
  
  - If the option is cleared, the user will only be able to access a project if it is specifically assigned to a security group that he/she belongs to, or if the user account is specifically assigned to the project.

For more information, see **Planning Your Security Approach**.

- **Update security groups upon login (if associated with Active Directory)**
  - If the option is selected (default), the user’s security groups will be assigned automatically based on his/her security group in Active Directory. (See **Associating Security Groups with Active Directory**.)
  
  - If the option is cleared, the user can be manually assigned to any of the available security groups.

  - **Active**: Clear or select the check box to deactivate or activate the account. A deactivated account will not have access to the database.

Alerts/Actions Tab

- **Receive automated alerts**. Each user can choose to receive alerts via e-mail, SMS text message or Synthesis portal messages. (See **Watches and Alerts** and **What is Your SMS Address?**). Note that alerts via e-mail and SMS text are available only if a valid SMTP
server has been defined for the database and the user account has an e-mail address/SMS contact defined.

- **When assigned to actions.** When a user account is assigned to an action (either as the Person Responsible or as part of the Team resource), the **Cost Category** and **Hours per Day** are used to calculate resource utilization and costs. (See Costs and Man Hours.)

**Alternative Credentials Tab**
The Alternative Credentials tab is available only for secure databases. Select the check box to allow the user to bypass Windows authentication and connect to the database using an alternative username and password. (See Creating Alternative Credentials.)

**Importing Users from Active Directory**
If your organization uses Microsoft Active Directory, this topic explains how to import username and contact information from the directory to create new user accounts in the Synthesis repository. (If you also wish to use Active Directory to manage the membership in Synthesis security groups, see Associating Security Groups with Active Directory.)

To import users from Active Directory, choose File > Manage Repository > Users and Security, click the **Active Directory** button, and then follow these steps:

1. Enter or select the domain name in the **Domains** field. If your organization’s directory is large, you may also choose to limit the search to specific groups by clicking **Load Groups** and then choosing an option from the drop-down list. You can also use the **Filter By** field to further limit the search. When you have specified the desired filters, click **Load Users** to update the table.

   ![Search Options](image)

2. In the table of user accounts that match the filter criteria, select the check box for each user you want to create a Synthesis account for. (The names of users who already have an account in the current database will appear grayed out.)
3. For secure databases only, use the **Import as Members Of** field to select the security group(s) that will be assigned to the new user account(s). If you skip this option now, you can assign security groups later for each individual account. (See [Managing Security Groups](#).)

4. For SQL Server databases only, select the **Create SQL Server login** check box if you want to create an individual SQL Server login for each new Synthesis user account. (See [SQL Server Logins or Using Windows Impersonation](#).)

5. Click **Import** to create the account(s). After the process completes, the window will remain open to allow you to import additional users, if desired.

### Creating Alternative Credentials

Secure databases use Windows authentication by default. This means that users must be logged in to a computer using the same domain and username specified for their Synthesis user accounts. You can, however, allow specific users to bypass Windows authentication as needed. This may be useful for situations where:

- A user needs to work on a copy of a secure standard database or Synthesis file on a computer that is not connected to the company's network.
- A user needs to connect to an enterprise database from a different domain.

For these situations, you can set up alternative credentials for a user’s account that will allow that user to access the database without domain authentication. These credentials must be set up in advance, before the user attempts the connection.

If you have the **Manage users and logins** permission, you can create alternative credentials for a user account by following these steps:

1. Open the Users and Security window (File > Manage Repository > Users and Security). On the Users tab, select the account name from the list and click **Edit**.

2. In the User Login and Contact Information window, click the **Alternative Credentials** tab and then select the check box to enable alternative credentials.
3. With the setting enabled, create an alternative username and password for the account. The username and password must be unique within the database, and the password is Case Sensitive.

![Alternative Credentials](image)

Once you have created the credentials, instruct the user to enter this login whenever the database prompts for it. The database will ask for the alternative credentials whenever the user account cannot be matched based on domain authentication.

**Tip:** The first time you connect to a database using alternative credentials, the application will automatically remember the login information on your computer. If you wish to clear the saved login, you can click the Clear Alternative Credentials link on the Other Synthesis Settings page of the Application Setup.

**User Groups**
The User Groups window (formerly called “Notification Groups”) allows you to create and manage groups of users that can be assigned throughout the current database for:

- Recipients for portal messages
- Monitors for assigned actions
- Team members in the Project Planning Resources

To access the window, choose File > Manage Repository > User Groups.

In a secure database, this is available only for users with the Manage users and logins permission.

**Adding or Editing a Group**
The table displays a list of the user groups that have already been defined in the current database.

To add a new group, click Add.
Chapter 2: Repositories and Projects

To view or edit an existing group, double-click the row or select the row and click Edit.

The Available Users list shows all of the user accounts in the current database that are not yet assigned to the group. Double-click or use the buttons to move at least one user into the Selected Users list.

Deleting a Group
To delete an existing group, select a row and click Delete or press the DELETE key.

If the user group has been assigned to any existing actions, messages or project planning teams, the group will be removed automatically and those users will no longer be assigned in the affected records. There is no undo for delete.

Managing Security Groups
In a secure database, Synthesis security groups control what users can see and do in the database. By default, the software includes four predefined security groups: Admin, Power, User and View. The Admin group, which has full permissions throughout the database, can neither be deleted nor have its permissions modified. For the other predefined groups, you can edit their permissions or replace them with new groups that fit the specific way the database will be used. As discussed in Planning Your Security Approach, there are two basic approaches you can use:

- **Same permissions for all public/reference projects** – each user account is assigned to one security group and all public/reference projects use the default security option (repository-level security).

- **Different permissions for different public/reference projects** – each user account may be assigned to multiple security groups and each public/reference project may be accessed only by specific security groups and/or users.

Creating, Editing or Deleting Security Groups
You can manage the security groups by choosing File > Manage Repository > Users and Security. (In a secure database, this is available only to users with the "Manage users and logins" permission.)

In the Users and Security window, click the Security tab to see all the security groups that have been created in the database. Use the Add, Edit or Delete buttons below the table to manage the groups.

When you edit a security group, the left side of the Security Group window allows you to choose the permissions, while the right side shows all the users currently assigned to the group.
If you have selected to **Associate this security group with an Active Directory group**, the list of assigned users can be updated automatically, or you will only be able to manually import/assign users who belong to the designated Active Directory group. (See [Associating Security Groups with Active Directory](#).)

**Synthesis Permissions**
Here is a summary of all the permissions that can be granted to a particular security group.

**Basic permissions throughout repository**
These permissions apply throughout the database if they are in any of the security groups that the user belongs to. These permissions do not depend on the security settings for a particular project.

| Create and own private projects | You can create and own *private* projects in the database that are accessible only to you. (Users with the "Manage all private projects" permission can still perform administrative tasks on all private projects, such as editing their properties, locking them, converting them to public projects, etc.) |

---
Chapter 2: Repositories and Projects

<table>
<thead>
<tr>
<th>Create and own public projects</th>
<th>You can create and own public projects that other users can view and edit (depending on the project security settings).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create and own reference projects</td>
<td>You can create and own reference projects for sharing resources and FMEAs with other projects in the database (depending on the project security settings).</td>
</tr>
<tr>
<td>Create portal messages</td>
<td>You can create new messages, and edit or delete the messages you have personally created via the Messages page in My Portal.</td>
</tr>
<tr>
<td>Publish to Synthesis Enterprise Portal</td>
<td>You can publish your progress, results and analyses from a given project to the Synthesis Enterprise Portal (SEP), making the information accessible from any web-enabled device.</td>
</tr>
<tr>
<td>Create/edit/delete SDW data collections</td>
<td>You can create, edit and delete data collections in the Synthesis Data Warehouse (SDW). This includes data extraction from XFRACAS as well as custom connections, and confers the ability to create dashboard layouts for custom connections.</td>
</tr>
</tbody>
</table>

Basic and advanced permissions at project level
A user can have these permissions in some projects but not others, depending on the project security settings. Regardless of the project security settings, these permissions are always automatically granted to the current project owner.

| Read | You can perform tasks that do not modify the data in the project (e.g., view the analysis, calculate metrics in a Quick Calculation Pad, export data, etc.). |
| Create/edit project items | You can create and edit items in a given project such as folios in Weibull++/ALTA, diagrams in BlockSim, system hierarchy items in Xfmea/RCM++/RBI, etc., as well as update the item properties. |
| Create/edit/delete own resources | You can create Synthesis resources (e.g., URDs, models, etc.) and edit or delete any existing resources you have created. |
## Chapter 2: Repositories and Projects

<table>
<thead>
<tr>
<th>Permission</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Delete project items</strong></td>
<td>You can delete any item in a given project (e.g., folios in Weibull++/ALTA, diagrams in BlockSim, system hierarchy items in Xfmea/RCM++/RBI, etc.). This permission cannot be assigned unless you also have the &quot;Create/edit project items&quot; permission.</td>
</tr>
<tr>
<td><strong>Create/edit project plans</strong></td>
<td>You can create and edit project plans for a given project.</td>
</tr>
<tr>
<td><strong>Create/edit/delete local resources</strong></td>
<td>You can create, edit and delete any local resources in the project (not just the ones that you created).</td>
</tr>
<tr>
<td><strong>Set project security</strong></td>
<td>You can control who can view and edit a given project. This permission allows you to configure both project security settings and item permissions.</td>
</tr>
<tr>
<td><strong>Edit project properties</strong></td>
<td>You can use the Project Properties window to edit the name, description, category and other settings of a given project.</td>
</tr>
</tbody>
</table>
| **Lock or check out project** | You can:  
- Lock and unlock a given project.  
- Check in and check out a given project. |
| **Create restore points** | You can utilize restore points for a given project, which are exact replicas of the project at a particular point in time (i.e., backups). |
| **Delete project** | You can delete a given project. |
| **Manage change logs in Xfmea/RCM++/RBI** | You can enable and manage change logs within a given project. Change logs can be created for FMEAs, DVP&R, Control Plan and P-Diagram analyses in Xfmea, RCM++ and RBI. See Change Logs in the Xfmea/RCM++/RBI documentation. |
| **Approve change logs in Xfmea/RCM++/RBI** | You can implement electronic approval tracking for change logs within a given project. See Electronic Approval Tracking in the Xfmea/RCM++/RBI documentation. |
Chapter 2: Repositories and Projects

Administrative permissions throughout repository
These permissions apply throughout the database if they are in any of the security groups that the user belongs to. These permissions do not depend on the security settings for a particular project.

<table>
<thead>
<tr>
<th>Manage users and logins</th>
<th>You can:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Use the Users and Security window to add user accounts to the database and define security groups, as well as create alternative credentials for user accounts.</td>
<td></td>
</tr>
<tr>
<td>• Use the User Groups window to add and manage distribution groups for e-mail alerts, portal messages, action alerts and projecting planning resources.</td>
<td></td>
</tr>
<tr>
<td>• Use the Repository Logins window to view and export a history of database logins.</td>
<td></td>
</tr>
<tr>
<td>• Use the Reset &quot;In Use&quot; Flags window to clear the &quot;in use&quot; status for selected database users (not just your own).</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Manage project planning resources and working days</th>
<th>You can:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Use the Project Planning Resources window to manage the cost categories, teams, materials and facilities that are used for tracking resource utilization in Project Planner gates and actions.</td>
<td></td>
</tr>
<tr>
<td>• Use the Working Days/Holidays window to specify the business days that will be used for Project Planner gates and actions.</td>
<td></td>
</tr>
</tbody>
</table>

<p>| Manage project/item categories | You can use the Project/Item Categories window to define the project and item categories that can be used for grouping and filtering projects and items in the database. |</p>
<table>
<thead>
<tr>
<th>Manage other repository settings</th>
<th>You can:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Use the <a href="#">Time and Usage Units window</a> to define the time units available for use in any project within the database.</td>
</tr>
<tr>
<td></td>
<td>• Use the <a href="#">Default Name Formats window</a> to specify how default names for resources and blocks are created.</td>
</tr>
<tr>
<td></td>
<td>• Use the Task Types window in RCM++, RBI and MPC.</td>
</tr>
<tr>
<td></td>
<td>• In RCM++ and RBI, you can map the task types that are used only in RCM++/RBI to the task classes in the universal reliability definition (URD). See <a href="#">Task Types in RCM++/RBI</a> in the RCM++/RBI documentation.</td>
</tr>
<tr>
<td></td>
<td>• In MPC, you can modify the abbreviations used for MSG-3 task types. See <a href="#">Task Type Abbreviations in MPC</a> in the MPC documentation.</td>
</tr>
<tr>
<td></td>
<td>• Use the <a href="#">Repository Settings window</a> to set some default settings for existing and new databases. This includes enabling e-mail alerts for the database, activating history logs, etc.</td>
</tr>
<tr>
<td></td>
<td>• Set up <a href="#">XFRACAS connection settings</a> that allow Synthesis desktop applications to access the XFRACAS data stored in the database. This is available only for standard databases (*.rsr11).</td>
</tr>
</tbody>
</table>

| Create/edit/delete global resources | You can create, edit and delete any [global resources](#) in the project (not just the ones that you created). In addition, you can transfer data from [XFRACAS to the SDW](#). |

| Approve actions | You can review and approve [actions](#), which are Synthesis resources that allow you to track progress made in a project. |

| Manage all portal messages | You can edit or delete any messages that are visible to you via the Messages page in [My Portal](#). This includes any messages for which you are the creator or one of the recipients. |

| Manage dashboard layouts | You can create and save layouts for use in the [Dashboard Viewer](#) in Weibull++, BlockSim and RGA. |
### Manage profiles and templates in Xfmea/RCM++/RBI

This permission is available only in enterprise databases. You can:

- Use the Profiles/Library Manager window in Xfmea/RCM++/RBI to configure the predefined settings stored in the active library of the enterprise database. See [Profiles/Library Manager](http://blocksim.reliasoft.com) in the Xfmea/RCM++/RBI documentation.

- Use the Templates Manager window in Xfmea/RCM++/RBI to configure report templates stored in the enterprise database. See [Templates Manager](http://blocksim.reliasoft.com) in the Xfmea/RCM++/RBI documentation.

### Manage Lambda Predict repository settings

You can:

- Use the FIDES Settings Manager window in Lambda Predict to configure the FIDES-related settings stored in the database. This applies to the FIDES prediction standard only (see [FIDES Settings Manager](http://blocksim.reliasoft.com) in the Lambda Predict documentation).

- Use the Custom Derating Standards Manager window in Lambda Predict to create, edit or delete user-defined derating standards stored in the database. See [Creating Custom Derating Standards](http://blocksim.reliasoft.com) in the Lambda Predict documentation.

- Use the MIL-217 Custom Connections window in Lambda Predict to define failure rates for user-defined connectors stored in the database. This applies to the MIL-217 prediction standard only. See [MIL-217 Custom Connection Types](http://blocksim.reliasoft.com) in the Lambda Predict documentation.
### Manage MPC Settings

You can:

- Use the Manage ATA Chapters window in MPC to define the systems and subsystems that are available for use in the database. See [Managing ATA Chapters](#) in the MPC documentation.

- Use the Manage Major Zones window in MPC to define the zones and major sub-zones that are available for use in the database. See [Managing Major Zones](#) in the MPC documentation.

- Use the Configurable Options for Systems and Powerplant Analysis window in MPC to enable or disable the display of some item properties and task properties fields. See [Configurable Options for Systems and Powerplant Analysis](#) in the MPC documentation.

- Use the Configurable Options for Structural Analysis window in MPC to customize the settings for environmental deterioration (ED) and accidental damage (AD) analyses that can be performed for any structural item in MPC Plus. See [Configurable Options for Structural Analysis](#) in the MPC documentation.

- Use the Configurable Options for Zonal and L/HIRF Analysis window in MPC to customize the settings for the standard zonal, enhanced zonal and L/HIRF analyses that can be performed for any zonal item in MPC Plus. See [Configurable Options for Zonal and L/HIRF Analysis](#) in the MPC documentation.

<table>
<thead>
<tr>
<th>Manage all public projects</th>
<th>You have all the basic and advanced project-level permissions for public projects in the database. You can also change the <a href="#">project owner</a> for any public project in the database.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage all reference projects</td>
<td>You have all the basic and advanced project-level permissions for reference projects in the database. You can also change the <a href="#">project owner</a> for any reference project in the database.</td>
</tr>
<tr>
<td>Manage all private projects</td>
<td>You have all the basic and advanced project-level permissions for private projects in the database. You can also change the <a href="#">project owner</a> for any private project in the database.</td>
</tr>
</tbody>
</table>
Associating Security Groups with Active Directory

If your organization uses Microsoft Active Directory (AD), you can give an AD group a specific set of permissions in the Synthesis repository. The members of the AD group can then access the database based on the set of permissions associated with the group.

In addition, the software offers the option to automatically update the permissions of a user whenever that user is added or removed from an AD group. For example, if a user is moved from AD group A to AD group B, his/her Synthesis user account can be automatically updated with the permissions associated with AD group B. The changes will take effect the next time the user connects to the database via any of the Synthesis desktop applications. (Note that for users who will connect only via the Synthesis Enterprise Portal (SEP) website, you’ll need to update their permissions manually either via a desktop application or the Synthesis Admin tool on the web server.)

Tip: Multiple security groups can be assigned to the same user account, if appropriate. For example, a user can be assigned to the "ABC Team" group (which is associated with Active Directory) and the "Read-Only" group (which is not). (See Planning Your Security Approach.)

Assigning Permissions to an Active Directory Group

To associate a Synthesis security group with an Active Directory group, choose File > Manage Repository > Users and Security and click the Security tab. Then double-click the security group you want to edit.

In the Edit Security Group window, select the Associate this security group with Active Directory check box, and then specify the domain name and Active Directory group to use.

There are two additional options, which apply only when users log in from a Synthesis desktop application:

- **Automatically update this security group's members.** If a user is added to the AD group, his/her Synthesis user account will automatically have this set of permissions the next time the user logs in to the database via any of the Synthesis desktop applications. Likewise, if the user leaves the AD group, his/her Synthesis user account will no longer have this set of permissions.

  If you do not want the changes in Active Directory to be automatically applied to a particular user, clear the Update security groups upon login check box in that user's account in the Synthesis repository.

- **Automatically create new user accounts on first login.** If a member of the AD group does not already have a Synthesis user account, it will be created automatically (and
assigned to this security group) the first time he/she tries to connect via any of the Synthesis desktop applications.

Creating/Updating Accounts Now
If you don’t want to wait for all users to log in before creating/updating their Synthesis user accounts, click the Assign button at the bottom of the window.

- To create new accounts, choose Import users who are members of this Active Directory group. This opens the Import Users from Active Directory window, but you can only choose users from the associated Active Directory group.

- To update the security groups for existing accounts, choose Assign existing repository users who are members of this Active Directory group. This shows a list of existing Synthesis users who also belong to the associated Active Directory group; you can select to update any or all of their accounts.
Chapter 2: Repositories and Projects

Setting Item Permissions

In a secure database, all project items (e.g., folios, diagrams, system hierarchy items, etc.) are, by default, set to inherit their permissions from the project. This means that if a user has the "Create/edit items" permission for the project, he or she will be able to edit all of the items by default. If you want to prevent some or all of those users from editing a particular item (i.e., lock or limit access to the item), you can use the Item Permissions window.

The window functions a little differently depending on whether you’re working with items in a project explorer (e.g., folios, diagrams, etc.) or items in a system hierarchy.

Project Explorer Items

In Weibull++, ALTA, BlockSim, RENO, RGA or Lambda Predict, select the item in the current project explorer and choose Project > Current Item > Item Properties. (In a secure database, this is available only if the user a) is the project owner, b) has the "Set project security" permission, or c) has the applicable "manage all projects" permissions.)

The settings are displayed on the Permissions tab of the properties window.

In the Item Permissions window, select the Restrict editing to selected project users option and then select which specific users will be able to edit this particular item. All others can view, but not edit, the item. Only users with editing rights to the project will appear in the list.

To remove item permissions and change the security settings back to the defaults, select the Inherit from project option.

System Hierarchy Items

In Xfmea, RCM++ or RBI, select the item and choose System Hierarchy > Current Item > Item Permissions. In MPC, select an item and choose [Systems/Structures/Zones] > Security > Item Permissions. (In a secure database, this is available only if the user a) is the project owner, b) has the "Set project security" permission, or c) has the applicable "manage all projects" permissions.)

In the Item Permissions window, you can choose to:

- Define the permissions for the item by selecting the Restrict editing to selected project users option and then selecting which specific users will be able to edit this particular item. All others can view, but not edit, the item. Only users with editing rights to the project will appear in the list.

- Set the item to inherit the same permissions as the next item above it in the system hierarchy by selecting the Inherit from parent item option.
• Remove item permissions and change the security settings back to the defaults by selecting the **Inherit from project** option.

If you select the **Apply to all dependents** check box, the software will automatically set the permissions for all next-level items in this branch of the hierarchy to match the item you are currently editing. For example, consider a case where each item in an Xfmea system hierarchy has different permissions, as shown next.

For a quick way to reset all of the item permissions to the defaults, you can open the Item Permissions window for SubSystem 1, set to **Inherit from parent item** and select the **Apply to all dependents** check box. The resulting system hierarchy is shown next.

**Status Indicators**

Synthesis desktop applications include status indicators that tell you which project items (e.g., folios, diagrams, system hierarchy items, etc.) are in use or restricted.

When you encounter an item that is read-only (e.g., OK button is disabled in the window or you are unable to type in the cells of a worksheet or table), you can check the status of the item to see if it is currently **in use** (i.e., you can’t edit the item until the user closes the folio/diagram...
or selects a different item in the hierarchy) or restricted (i.e., you don’t have permissions to edit the item). If the item is in use, move the pointer over the icon to identify the user.

The location of these status icons will vary depending on which Synthesis application you are using:

- In projects that use a current project explorer to manage analysis data, the status icons are displayed next to the item’s name in the current project explorer, as in the example shown next.

- In projects that use hierarchical trees to manage analysis data (as seen in the Xfmea, RCM++, RBI and MPC applications), the status icons are displayed in the User Access column of the system hierarchy. (To hide or display columns, right-click the column headings, then click Customize Columns to select which columns you want to display.)

Tip: The application interface refreshes automatically whenever you make a change (e.g., close a project, create a resource, select a different item, etc.). If your computer will not let you edit an item that is in fact not currently being edited by another user, it could be because your computer has not been recently refreshed with the latest changes made by other database users. You can initiate the
refresh manually by choosing View > Refresh.

In addition, the software employs “in use” flags within the database to record when an analysis is currently being edited by a particular user. If the refresh still does not show that the item has been released, then something might have occurred to prevent the flags from being reset correctly (e.g., a network interruption or if the software closes unexpectedly). Refer to the Reset “In Use” Flags topic for instructions on how to reset the flags throughout the database if this problem occurs.

**Reset "In Use" Flags**

Because Synthesis repositories allow simultaneous access by multiple users, it is necessary to store “in use” flags within the database to indicate when a particular portion of the analysis is currently being edited by a particular user. There are some circumstances when these flags might not be reset correctly when a user stops editing an analysis (e.g., if there is a network interruption or if the software closes unexpectedly). If that occurs, then the analysis will be locked for editing because the software receives an erroneous indication that it is still in use by another user.

To correct the problem, it is necessary to reset some or all of the “in use” flags within the database. To reset the flags, choose File > Manage Repository > Reset ‘In Use’ Flags.

(In a secure database, this is available only for users with the "Manage users and logins" permission.)

This opens the Reset 'In Use' Flags window, which shows all users who have an account in the database. (If you are working in a non-secure database, any user who has ever opened the database will have an account created automatically and will be shown in this list.) A status light is displayed for each user; if it is "lit up" (i.e., green), the user is currently logged in to the database. In addition, the Connections column shows the Synthesis application(s) that the user currently has connected to the database. You can select the check box for each user for whom you want to reset "in use" flags, then click OK to reset the flags.

**IMPORTANT:** It is important to make sure that no selected user is currently logged in to the database when you use this command. Users currently logged into the database can be viewed on the Users Page of My Portal.
Chapter 2: Repositories and Projects

Repository Logins

The Repository Logins window displays a record of the date and time the users in the database logged in. To open the Repository Logins window, choose File > Manage Repository > Repository Logins. (In a secure database, this is available only for users with the "Manage users and logins" permission.)

The following options are available:

- Use the Most Recent filter to display in the table the last 10; 100; 10,00 or 10,000 users who logged in to the database.
- Use the User filter to specify whether the table will display the logs for all users or display only the logs for a selected database user.
- Click the Send to Excel button to export the data currently displayed in the table to an Excel spreadsheet.
- Click the Clear Logins button to clear the entire history of users who logged in to the database. Since this action cannot be undone, you will be prompted to confirm that you want to proceed before the records are erased.

Users currently logged into the database can be viewed on the Users page of My Portal.

Repository Settings

The Repository Settings window contains settings that are shared by all users and analysis projects in the database. To access this window, choose File > Manage Repository > Repository Settings. (In a secure database, this is available only for users with the “Manage other repository settings” permission.)

In a standard database or Synthesis file, you can save the current settings as the default for each new standard database/Synthesis file that you create from this computer by clicking the Set as Default button at the bottom of the window.

What’s Changed? In prior versions, these preferences were defined in the E-mail and Other Settings window.
E-mail Settings Page

- **Enable Alerts via E-mail or SMS** configures the database to enable alerts via e-mail or SMS text message. (See Enable Alerts via E-mail or SMS.)

- **Action Alerts** apply to action resources. The database can be configured to auto-subscribe a "watch" for users based on their role(s) for a particular action. You can also specify the default text that will be used at the beginning of each action alert. (See Action Alert Preferences.)

Other Settings Page

- **FMEA Structure (Xfmea/RCM++/RBI)** allows you to select the default FMEA structure for new projects created in the database, which determines how the software will display the effect and cause records in the FMEAs. If you don't specify a default, users will be prompted to select the structure for each new project they create in Xfmea/RCM++/RBI. (See Choosing the FMEA Structure in the Xfmea/RCM++/RBI documentation.)

- **History Logs** allows you to turn the log on (or off) for all active projects, and stores a preference for whether the log should be activated by default for each new project. (See History Logs.)

- **Actions** allows you to automatically sets the person who created an action to be the person responsible for it. (See Person Responsible and Resources.)

- **Enable publish to Synthesis Enterprise Portal** is available only in enterprise databases. If your organization has established a web-based Synthesis Enterprise Portal (SEP) for the current database, select this check box to enable users to publish analysis summaries, Synthesis Workbooks and other information to the portal.

- **Delete Portal Messages** deletes all portal messages for all users in the database. *There is no undo for deleting portal messages.*

Time and Usage Units

The Time and Usage Units window defines the time units that will be available for use in any project within the database. This allows users to work with time-based inputs and results in the units that are appropriate for the situation. For example, you can enter data into a Weibull++ life data folio data sheet in hours and then obtain results from the QCP in terms of years. Similarly, in RCM++, RBI or BlockSim, you can define the duration of a maintenance task in terms of hours and specify the total operating time of a system in terms of months.
**Chapter 2: Repositories and Projects**

**IMPORTANT:** It is important to realize that making changes to the existing units can have implications for all analyses throughout the database; therefore, it is best to set up units once, upon creation of the database.

To define time units, choose **File > Manage Repository > Time and Usage Units**. (In a secure database, this is available only to users with the "Manage other repository settings" permission.)

The units are defined in relation to a common, or "base," unit so that the software can convert data from one unit to another. For example, the units defined by default assign a conversion factor of 1 to the Hour unit, which indicates that an hour is equal to 1 System Base Unit (SBU); the Year unit has a conversion factor of 8760, which indicates that a year is equal to 8,760 SBUs (i.e., 8.760 hours). Note, however, that the SBU does not have to be hours. You could consider days to be your base unit and define all other units in relation to a day (e.g., an hour would be 1/24th of a base unit, with a conversion factor of 0.04167). The SBU does not have to be the default unit either; you can set any unit as the default by selecting it in the **Default** column; the default unit will be used automatically each time the software requires a unit.

Each unit must have a name, an abbreviation of up to three characters and a conversion factor. In addition, each unit must be assigned to any one of the two available categories: Time or Usage. (If you will be using the usage format of the Weibull++ warranty folio, only the units assigned to the Usage category will be available for those analyses; units assigned in the Time category are not available in the warranty usage format.)

Use the **Delete** and **Insert** buttons below the window to manage the list of units. You can also move a unit up or down its current position by selecting it and using the **Move Up** or **Move Down** buttons.

**Note:** In Weibull++, you can specify which of the configurable repository time units are equivalent to the built-in (not configurable) "warranty time units" used in some warranty folio formats. For details, see **Manage Warranty Units** in the Weibull++/ALTA documentation.

**Default Name Formats**

In all Synthesis desktop applications except MPC, the Default Name Formats window specifies the default names for new Synthesis resources, as well as new blocks in BlockSim RBDs, fault trees and phase diagrams. For example, when you create a new model, the default name will be the word "Model" plus an increment to make the name unique (e.g., "Model," "Model_1," etc.). You can configure the database to use a different default name format if desired.
To open the window, choose File > Manage Repository > Default Name Formats. (In a secure database, this is available only for users with the "Manage other repository settings" permission.)

The Resource Name column displays the basic name label for each type of resource or block. This will be represented by the \N code in the name format.

The Name Format column allows you to use any of the following elements to define the default name format for each type of resource or block:

- \N returns the label from the Resource Name column plus an increment to make the name unique (e.g., "Model," "Model_1," etc.).
- \U returns the name of the user who created the resource or block.
- \D returns the date when the resource or block was created.
- \S adds a sequential number that reflects the order in which the resource/block was added to the database.
- \T returns the Synthesis application ("tool") used to create the resource or block.
- \F returns the contents of all of the identifier fields except the category and comments fields.
- \G returns a summary of the properties of the resource or block. For example, for a node in a BlockSim diagram, \G returns the "k out of n" paths that are required.
- \I is only applicable for resources. It functions the same as \N unless there is another window, resource or analysis that it can "inherit" part of the name from. Some examples:
  - If you create a URD from BlockSim’s block properties window, the default name will be "[Block Name]_URD."
  - If you create a metric based on a model, the default name will be "[Model Name]_Metric."
  - If you push a metric from a Project Planner gate, the default name will be "[Gate Name]_[Property Name]_Metric."

**Tip:** In BlockSim diagrams, you can use an asterisk (*) to insert the default block name. For example, if you enter *System for the block name, the diagram will display the default name for the block followed by the word "System." The asterisk also allows the block name to be updated dynamically when relevant properties change.
Project Planning Resources

In all Synthesis desktop applications except MPC, *project planning resources* can be assigned to actions in order to track the required costs and time in the Project Planner and anywhere else that actions are used. Because project planning resources are shared throughout the database, any change made to one is automatically applied to all actions in the database that use it.

- **Cost Categories** specify direct and/or per instance costs that can be assigned to any team member, facility or material.
- **Teams** identify groups of users who will work together on any given action.
- **Facilities** specify the cost and maximum utilization for facilities (e.g., test lab) or other resources for which the cost depends on the duration of use (e.g., rented test equipment).
- **Materials** specify the cost and quantity for materials (e.g., test units) or other resources for which the cost depends on the amount used rather than the duration (e.g., purchased usage data).

To open the Project Planning Resources window, choose File > Manage Repository > Project Planning Resources. (In a secure database, only users with the “Manage project planning resources and working days” permission will be able to create and edit these resources; other users can select from the resources that have already been predefined.)

**Cost Categories**

Cost categories can be created from the Project Planning Resources window, or when you are creating/editing a facility, material or individual user account. Enter the Currency Symbol to use for displayed costs at the bottom of the window.

- The **Direct Cost per Hour or Unit** is the per-hour cost when assigned to a team member or facility, or the per-unit cost when assigned to a material (e.g., the cost of a single light bulb).
- The **Cost per Instance** is a one-time cost that applies every time a team, facility or material is used.
Teams
Teams can be created from the Project Planning Resources window, or when you are defining an action. A team can include:

- Individual **Users** who have active user accounts in the database.
- **Groups** of active user accounts that have been predefined in the database.

Note that you cannot assign a cost category directly to a team. Instead, the team's cost/utilization is based on the cost category and maximum hours per day for each team member. Both of these properties are set on the **Alerts/Actions** tab of the **User Login and Contact Information window**.

Facilities
Facilities can be created from the Project Planning Resources window, or when you are defining an action.

- The **Cost Category** specifies the facility's hourly and/or per-use costs.
- The **Max Hours Per Day** is the number of hours of use if the facility is set to be 100% utilized for a given action (as specified in the action properties).

Materials
Materials can be created from the Project Planning Resources window, or when you are defining an action.

- The **Cost Category** specifies the cost per unit (e.g., the cost for each test prototype), as well as any additional fixed cost (e.g., the cost for manufacturing a sufficient number of test prototypes).
- The **Quantity** that will be used (e.g., 100 light bulbs).

Working Days/Holidays
In all Synthesis desktop applications except MPC, **actions** and **Project Planner gates** contain important dates like start dates and due dates. You can specify which dates will be considered working days for all actions and gates in the repository. This way, an action's cost/time estimates, as well as its duration, will be based solely on working days.

To define the working days for the repository, choose **File > Manage Repository > Working Days/Holidays**. (In a secure database, this is available only for users with the "Manage project planning resources and working days" permission.)
In the window that appears, use the **Define Work Week** area on the left side to specify which days of the week will be considered regular working days (e.g., Monday-Friday).

**Define Holidays**

On the **Define Holidays** tab, you can define three different types of holidays.

- **Fixed Date - Recurring** holidays occur every year on the same calendar date (e.g., New Year’s Day is always January 1).
- **Variable Date - Recurring** holidays occur every year, but not always on the same date (e.g., Thanksgiving is always the fourth Thursday of November).
- **Fixed Date - Non-recurring** holidays occur once and do not happen again. For example, a specific Monday could become a non-working day due to weather conditions.

In the Holiday Properties window, select **Move to adjacent working day if necessary** to make sure the holiday will be observed when a) it occurs outside the work week, but b) there is a regular working day immediately before/after it. In this case, the holiday is observed on the nearest working day. (If there is a working day immediately before and after the holiday, it is observed on the following day.)

**View Observed Holidays**

The **View Observed Holidays** tab allows you to easily examine the names and dates of all holidays that will be observed during the work week, and can also help you make sure your working days/holidays settings are correct. Specify the years you want to view in the **Displayed Range in Years** area.

**XFRACAS Connection**

ReliaSoft’s XFRACAS is a web-based, closed-loop, incident (failure) reporting, analysis and corrective action system designed for the acquisition, management and analysis of product quality and reliability data from multiple sources. There are several ways in which you might wish to share data between XFRACAS and the analyses that you perform in Synthesis desktop applications:

- Use the Synthesis Data Warehouse in Weibull++/ALTA or RGA to extract data from XFRACAS incidents. (See [Synthesis Data Warehouse](#).)
- Share system configuration and failure mode data between XFRACAS and Xfmea/RCM++/RBI. (See [Import or Sync from XFRACAS](#) in the Xfmea/RCM++/RBI documentation.)

When you are working with an enterprise database, the data from XFRACAS and Synthesis desktop applications can be stored in the same SQL Server or Oracle database.
When you are working with a standard database (*.rsr11) or Synthesis file (*.rsf11), you will need to establish a connection to an enterprise database that contains XFRACAS data. To do this, choose File > Manage Repository > XFRACAS Connection. (In a secure database, this is available only for users with the "Manage other repository settings" permission.)

In the XFRACAS Connection Settings Window, select **Connect to an enterprise repository with XFRACAS data** then choose Microsoft SQL Server or Oracle.

- For a SQL Server database, enter the server name and database name.
  - Select the **Use impersonation** check box if you want the connection settings to impersonate a Windows user account with a SQL Server login that is shared by multiple users. (See SQL Server Logins or Using Windows Impersonation.) If you do not use impersonation, then each user who uses the features that utilize XFRACAS must have an account in the external database that contains the XFRACAS data.

- For an Oracle database, enter the port, host and service identifiers and the database schema. Your Windows login credentials are used for access to the database; enter your Windows password.

### Managing and Restoring Data

Since each database may contain a large amount of valuable information that would be difficult to re-create, it is essential to make sure that you are diligent about storing adequate backups and performing the necessary maintenance activities to keep the database operating smoothly. The necessary procedures vary depending on the type of database.

### Enterprise Database Maintenance

When you choose to store analysis information in an enterprise database, a database administrator must perform backups and database maintenance activities using the data management tools that are packaged with and/or designed for the database platform (e.g., SQL Server Enterprise Manager for SQL Server). Each individual organization typically establishes its own procedures for protecting the data stored in the Oracle or SQL Server databases. As a convenience for users who wish to explore the possibilities of an enterprise database implementation without making a large investment of time and resources, instructions on how to perform ReliaSoft’s minimum database maintenance recommendations are posted on the ReliaSoft website:

Standard Database Maintenance

When you choose to store analysis information in a standard database, it will be subject to the same limitations and vulnerabilities as any other file that uses the Microsoft Access® database file format. For example, the maximum file size is ~ 2GB, maximum number of concurrent users is 255, etc. In addition, some specific database vulnerabilities are discussed in a Microsoft publication at http://support.microsoft.com/kb/283849/EN-US/. As this publication states:

"Microsoft Jet, the database engine that is used in Microsoft Access, is a file sharing database system. When Microsoft Jet is used in a multi-user environment, multiple client processes are using file read, write, and locking operations on a shared database. Because multiple client processes are reading and writing to the same database and because Jet does not use a transaction log (as do the more advanced database systems, such as SQL Server), **it is not possible to reliably prevent any and all database corruption.**" [emphasis added]

Although ReliaSoft’s developers have made every effort to reduce or eliminate the possibility that the software will induce a database error, there is no way to absolutely prevent corruption that might be caused by other factors, such as faulty network hardware, an unexpected "crash" on your PC or a network interruption. Therefore, this section provides some recommendations for standard precautions that all users can take to protect the data in their standard databases from this type of corruption and reduce the impact of the data loss if corruption is unavoidable.

1. **Create backups regularly.** As with any resource that contains a large amount of valuable information that would be difficult to re-create, it is essential to make sure that you are diligent about creating and storing backup files. There are a number of ways this can be accomplished:

   - If you select **Automatically back up database upon closing** from the **Backup/Check Out Options page** of the Application Setup, the Synthesis desktop application that you use to open the database will back up the database every time you close the file.
   
   - If you have a database open and choose **File > Save As**, the application will create a copy of the database to a pathname/filename of your choosing.
   
   - If you browse to the database file (*.rsr11) in one of the Windows file management tools (such as My Computer or Windows Explorer), you can copy and paste the database file as needed.
2. **Compact and repair regularly.** Using the "Compact and Repair" feature will help to reduce the size of the database file and help to protect against problems with the operation of the database. If you have the database open and it is not currently in use by another user, you can initiate the process by at any time by choosing **File > Manage Repository > Compact and Repair.**

3. **Do not store the database in a shared network location if you suspect that your network connection and/or hardware may be unreliable.** According to Microsoft, faulty network hardware is one of the main reasons why a file that uses the Microsoft Access database file format may become corrupted. As the Microsoft publication at [http://support.microsoft.com/kb/283849/EN-US/](http://support.microsoft.com/kb/283849/EN-US/) states:

   "The cause can be one or more links in the hardware chain between the computer that the database resides on and the computer that has the database open. This list includes, but is not limited to, network interface cards, network cabling, routers, and hubs.

   Hardware-based corruption is typically indicated by .mdb files that cannot be restored through the use of compacting, repairing, or Jetcomp. **Hardware corruption will typically recur until the responsible hardware is repaired or replaced.**" [emphasis added]

If you have experienced this type of corruption for a standard database file, it is recommended that you take steps to correct the network problem or refrain from accessing database files over the network. In such cases, you may choose to use an enterprise database instead (i.e., Oracle or SQL Server), which would be less vulnerable to network interruptions. Alternatively, you could keep multiple analysis projects together in a single shared standard database file but ask users to export the analysis to a separate "working" database on their own computers when there is a need to make substantial modifications. Users could then import the data back into the shared database after the modifications have been completed.
4. **Do not allow the file size of the database to grow too large.** Performance will be affected by the size of the database and the number of simultaneous users. Therefore, it is important for users to monitor the sizes of their database files and take steps to export the data into several smaller and more manageable files if they become too large. Please be aware of the following factors, which can lead to very large database files:

   - Failure to compact and repair the database on a regular basis.
   - Using a very large number of attached documents. In some cases, using a link instead of an attachment may provide equivalent functionality with a much smaller impact on the size of the database file.

If you try to open a standard database via the software and receive a message that says "Unable to open the database," this is an indication that the database file may have become corrupted. Please contact ReliaSoft’s [Technical Support](http://blocksim.reliasoft.com) and provide as much information as possible about exactly what you were doing when the corruption occurred. Whenever possible, please provide a copy of the corrupted file. In some cases, ReliaSoft may be able to provide assistance with salvaging some or all of the affected data. However, in many cases, the best recourse may be to restore the latest backup from before the corruption occurred.

**Restore Points**

In all Synthesis desktop applications, you can create and manage _restore points_ (formerly called "project baselines") for any analysis project. Within the context of Synthesis, the phrase "restore point" refers to an exact replica of the project at a particular point in time (i.e., a backup) that can be restored when and if it is needed. A restore point will include all the data that the project contained at the time the restore point was created, including information about the project properties, security settings and project owner.

There are a variety of ways that this functionality could be used, depending on your particular analysis process and data management requirements. For example, if you are about to begin a major revision to an existing project, you could choose to archive the original version as a restore point and then proceed with updating the project. This would ensure that the active projects in the database contain only the most recent information but also provide easy access to a fully editable copy of the previous version of the analysis if it is ever needed.

**Create a Restore Point**

You can create a restore point for a project at any time by choosing **Project > Management > Restore Point > Create Restore Point** or by right-clicking the name of the project in the **project list** and choosing the command on the shortcut menu.
In a secure database, this is available only if the user is the project owner or has the "Create restore points" permission.

**IMPORTANT:** When you create a restore point, any global, reference and FMEA resources used in the project are converted to local resources and stored with the backup. This ensures that you will have access to these resources upon restoration, regardless of what may have happened to those resources in the interim.

### Restore a Project

To restore all data from an existing restore point, use the **Restore Project** command. This opens the Restore Project window, which displays a list of all existing restore points for the project, if any. You have two options:

- **Overwrite existing project** uses the restore point to roll back the current project to the earlier state. The restore process will complete as long as the project is not currently in use by another user. There is no undo for project overwrites. Therefore, it would be prudent to create a new restore point for the project before you overwrite it with one of the older restore points.

- **Create new project** uses the restore point to create a new project. You may enter a unique name for the new project. When the restore process completes, the new project will be accessible from the project list.

### Manage all Restore Points in the Database

To manage all the restore points that have been created in the database, choose **File > Manage Repository > Restore Points**. (In a secure database, this is available only for users who have all three "manage all projects" permissions.)

This opens the Restore Points window, which displays the details for each of the restore points.

- To create a new restore point, click the **Create** button then select the project you want to back up. Enter any notes that are appropriate to describe the purpose or the circumstances of the restore point and click **OK**.

- To delete an existing restore point, select the row and click the **Delete** button or press **DELETE. There is no undo for delete.**

- To create a new project that restores all of the data from an existing restore point, select the row and click the **Restore Project** button. You will be prompted to specify a unique name for the new project.
Chapter 3: Desktop Application Interfaces

Most Synthesis desktop applications have their own Multiple Document Interfaces (MDIs) that provide full-featured support for the relevant analysis methods. (The exceptions are Weibull++/ALTA and BlockSim/RENO, which can display both applications in a shared MDI.)

When you are using multiple Synthesis applications simultaneously, different applications will open in separate MDIs but they can all connect to the same database, and even to the same analysis project.

All Synthesis MDIs share a common structure, which includes the following elements.

**Ribbon and Backstage View**

The ribbon at the top of the MDI replaces the toolbars and menus of previous versions of the software. The ribbon is divided into tabs that organize commands into logical groups. Some tabs will always be available (such as File, Home, etc.) while others are contextual and will appear only when you are working on a particular task.

The first tab, the File tab, provides access to a special type of interface called the Backstage view. This is where you will create and open databases, manage settings that apply to the entire database, access the Help Center, etc.

**Project Manager and My Portal**

The Project Manager allows you to manage the projects within the current database and, for many Synthesis applications, it also allows you to manage all of the folios, diagrams, reports, attachments, etc. in the currently open project(s). This panel is docked on the left side of the MDI and pinned by default. ("Pinned" means that the entire panel is always visible unless you decide to hide or "unpin" it.)

My Portal provides quick access to messages, assigned actions and other information that may be of personal interest to you while working in the Synthesis Platform. This panel is docked on the right side of the MDI and unpinned by default. ("Unpinned" means that only a small tab will be visible in the interface unless you move the pointer over the tab to make the entire panel visible.)

For both of these MDI features, you can decide whether the panel will be visible and how it will be positioned in the interface. (See Show, Tile, Dock and Pin Panels.)
Chapter 3: Desktop Application Interfaces

Tip: If desired, you can change the overall color scheme used in the MDIs for all Synthesis desktop applications on your computer. Use the Skins drop-down list on the Synthesis Settings page of the Application Setup to select the style you prefer.

Status Bar
As an example, the following picture shows the status bar at the bottom of the MDI for an enterprise database:

For more information about the connection speed indicator, see Enterprise Repository Connection Speed.

If working with a Synthesis file, the status bar also displays a reminder that you will need to save any changes before closing.

Show, Tile, Dock and Pin Panels
In all Synthesis desktop applications, the MDI includes a Project Manager panel and a My Portal panel. You can decide whether each panel will be displayed and how it will be positioned in the interface at any given time.

Show or Hide
To show or hide the Project Manager panel, choose View > Project Manager and toggle the Show Project Manager command on or off.


You can also hide either panel by clicking the X at the top of the window.

Tile or View One Page at a Time
In all Synthesis desktop applications, My Portal consists of four pages. You have the option to view one page at a time (and use large buttons or small icons at the bottom of the panel to
switch between pages) or tile the pages so that more than one page can be visible at the same time. To specify your preference, choose View > My Portal and toggle the Tile My Portal command on or off.

When applicable, these same options are available for the Project Manager panel. Choose View > Project Manager and toggle the Tile Project Manager command on or off. (This command is not available in applications such as Xfmea, RCM++, RBI and MPC, which have only a single page in the Project Manager.)

As an example, the first picture shows the My Portal panel when it is not tiled. The second picture shows the tiled panel, with two of the four pages expanded to be visible at the same time.

When the panel is not tiled, you can drag the horizontal splitter bar up to display large buttons or down to display small icons.
Chapter 3: Desktop Application Interfaces

When the panel is tiled, you can use the handle buttons to expand or collapse each page.

![Click to Expand]

Dock or Float

For both panels, you have the option to dock the panel on the left, right, top or bottom side of the MDI. When the panel is docked, it cannot be moved but you can change the width (if docked left or right) or height (if docked top or bottom) by dragging the edge to the desired position.

Alternatively, you can choose to float the panel as a window that can be resized and dragged to any location on the desktop.

There are several ways to set the docking position:

- Choose View > Project Manager > Dock Project Manager and then choose the desired option.

![Dock Project Manager]

The same options are available when you choose View > My Portal > Dock My Portal.

- If the panel is currently floating:
  
  - Double-click the window’s title bar to return it to the most recent docked position.

  OR

  - Click the window’s title bar and drag it onto one of the location icons that become visible while you are moving the window. When the window is correctly positioned, blue shading will show where the window will be docked when you release the mouse button. (Note that the window’s title bar must be exactly positioned above one of these location icons before the blue shading appears. If you don’t see blue shading, the panel will not be docked when you release the mouse button.)
If you prefer to float the window, you can:

- Choose either:
  - View > Project Manager > Dock Project Manager > Floating Project Manager
  or
- Double-click the title bar of the docked panel.
Pinned or Unpinned

When docked, both panels can also be toggled between pinned and unpinned states by clicking the pushpin icon in the panel's title bar. When the pushpin in the icon is vertical, the panel is pinned and will be displayed at all times.

When the pushpin is horizontal, the panel is unpinned. A tab will be displayed at the docking location for each unpinned panel.

The behavior for unpinned panels is as follows:

- If you point to the tab, the panel displays only until you point to something else.
- If you click the tab, the panel stays displayed until you click something else.
- When a panel is unpinned, it cannot be undocked or moved.

As an example, the following picture shows the Project Manager panel docked on the left side of the MDI, unpinned and hidden, while the My Portal panel is docked on the right side of the MDI, unpinned and visible (either because the user moved the pointer over or clicked the tab).
Project Manager

The Project Manager provides the tools you need to browse or search for a particular project or analysis folio in a Synthesis repository. Depending on the application, the Project Manager consists of either one or two pages:

- In all Synthesis desktop applications, the project list displays all the projects in the current database. (For Xfmea, RCM++, RBI and MPC, this is the only page available in the Project Manager).

- In Weibull++, ALTA, BlockSim, RENO, RGA and Lambda Predict, the Open Project(s) page of the Project Manager (i.e., the current project explorer) displays all the analysis folios, reports and other items in the current project(s) that apply to the software you are using.

There may be up to five nodes in the project list, indicating the sharing status of the projects: Private, Public or Reference projects, Locked projects and Checked Out projects. Additionally, the Recycle Bin is shown in the project list.

Each node may be further broken down by project category and/or by project owner. This ensures that projects will be organized in a logical, manageable way within the project list.

Opening a Project

To open an existing project, double-click the project name or select the project and choose Project > Management > Open Project.

Note: Remember that each project may contain items from any Synthesis application but you will see only the items that are relevant for the application you are currently working with (e.g., Weibull++ analysis folios are visible only when the project is opened in Weibull++). Common items, such as project attachments, are visible from all applications.

Filtering the List of Projects

The project list can utilize the same project filters that are available in many other locations throughout Synthesis desktop applications. For example, with the filter shown below, the project list will show only projects belonging to Department B.

<table>
<thead>
<tr>
<th>Project List</th>
</tr>
</thead>
<tbody>
<tr>
<td>Department B</td>
</tr>
<tr>
<td>Find:</td>
</tr>
</tbody>
</table>

BlockSim/RENO 11 User’s Guide
This feature might be particularly useful for an enterprise database that may be used to store analysis projects for the entire organization in a single centralized location. In such cases, the number of projects displayed in the project list could become overwhelming and these filters provide the ability to display only those projects that are of interest to you at any given time.

To remove the filter, select Show All from the drop-down list.

**Searching for a Particular Project**

You can also search for projects by entering text in the Find field. The project list updates dynamically to show only the projects with names that contain the text that you have entered. As an example, the following picture shows a quick way to find all of the projects for a particular product line by using the project names instead of predefined categories or other filter criteria.

![Find Projects](image)

**Current Project Explorer**

In all Synthesis desktop applications except Xfmea, RCM++, RBI and MPC (which use the system hierarchy to manage all of the different analyses in a given project), the Open Project(s) page of the Project Manager allows you to manage all of the relevant project items (e.g., folios, diagrams, etc.) in the project(s) that are currently open.

Applications that use the current project explorer can have multiple projects open at the same time. (See Working with Multiple Projects.)

*Note:* Remember that each project may contain items from any Synthesis desktop application but you will see only the items that are relevant for the application you are currently working with (e.g., Weibull++ analysis folios are visible only when the project is opened in Weibull++). Common items, such as project attachments, are visible from all applications.
Filtering the Project Items
The current project explorer can utilize the same item filters that are now available in many other locations throughout Synthesis desktop applications. (This provides more flexibility than the Filter based on creator feature in prior versions.)

For example, with the filter shown below, the current project explorer will show only items created by Joe User and updated within the current month.

To remove the filter, select Show All from the drop-down list.

Opening Items
Double-click an item to open that item in the MDI or to bring that item to the front of the MDI if it is already open. (Note that if you double-click an attachment that appears in the current project explorer, it will open in its corresponding application, as long as that application is installed on your computer.)

Tip: In all Synthesis applications, projects can be shared by multiple users and the current project explorer may display an "in-use" icon to indicate the status of an item that can't be edited because it is currently locked or being edited by another user. (See Status Indicators.)

Adding Items
You can add items to the project by choosing the relevant command on the Insert tab of the ribbon. You can also right-click the relevant folder and choose an appropriate command on the shortcut menu that appears.
Chapter 3: Desktop Application Interfaces

Editing, Renaming, Duplicating or Deleting Items
To manage existing items within the project (i.e., Edit Item, Rename Item, Duplicate Item and Delete Item), right-click the item and choose a command from the shortcut menu or select the item and use the commands in the Current Item group on the Project tab of the ribbon.

Sub-Folders and Drag and Drop
In addition to the top-level folders that are fixed for each application, you also have the ability to create your own custom sub-folders to organize project items (the exception being the Attachments folder, which you cannot add sub-folders to). To add a custom sub-folder, right click any existing folder and choose Add Folder on the shortcut menu.

You can also arrange custom sub-folders and project items by dragging them to the desired location. Dragging a folder or project item onto a folder will place it into the bottom of that folder. Dragging a folder or project item onto a project item will place it in the same level above that item.

Working with Multiple Projects
Synthesis desktop applications that use the current project explorer (i.e., Weibull++, ALTA, BlockSim, RENO, RGA and Lambda Predict) can have multiple projects open at the same time. To enable this functionality, select the Allow multiple projects (project explorer) check box on the Synthesis Settings page of the Application Setup.

Tip: There is a separate setting that controls the ability to have multiple projects open in Xfmea/RCM++/RBI.

When you have more than one project open, the projects will be shown in the current project explorer with the most recently opened project at the top. Note that the icon shown beside each project indicates whether it is a public, private or reference project and, when applicable, whether it is locked or checked out.

<table>
<thead>
<tr>
<th></th>
<th>Unlocked, Not Checked Out</th>
<th>Locked</th>
<th>Checked Out</th>
</tr>
</thead>
<tbody>
<tr>
<td>Public Project</td>
<td>![icon]</td>
<td>![icon]</td>
<td>![icon]</td>
</tr>
<tr>
<td>Private Project</td>
<td>![icon]</td>
<td>![icon]</td>
<td>![icon]</td>
</tr>
<tr>
<td>Reference Project</td>
<td>![icon]</td>
<td>![icon]</td>
<td>N/A</td>
</tr>
</tbody>
</table>
In addition to the convenience of being able to view analyses from multiple projects, having multiple projects open allows you to transfer data between the projects quickly and easily. Specifically:

- For any item that can be imported/exported between projects, you can simply drag the item (analysis, multiplot, report, etc.) from the source project to the appropriate folder in the destination project. This opens the Export window, where you can just click Export to finish the export, or add more items to export before you finish the process.

- In Weibull++, ALTA and RGA, data can be copied from an analysis in one project and pasted to an analysis in another project.

- In BlockSim and RENO, blocks can be copied from a diagram in one project and pasted to a diagram in another project, according to the following rules:
  - If the block uses resources that are local to the source project, they will also be copied and added to the destination project.
    - If a resource of the same name exists in the destination project, the name of the copy will be incremented (e.g., if "Model1" already exists, the new copy might be renamed to "Model1_1").
    - If a model is associated with a data source (e.g., a model published from a Weibull++ folio), the model is copied into the destination project as a model with the association removed.
  - If the block uses resources that are global or in a reference project, they will not be duplicated. They will retain their original reference to that global/reference resource.
  - Subdiagram blocks cannot be copied and pasted across projects.

**Note:** The FMRA view is not available in BlockSim when you have multiple projects open.

### My Portal

In all Synthesis desktop applications, *My Portal* provides quick access to messages, assigned actions and other information that may be of personal interest to you while working in the Synthesis Platform. (When you first activate the software, My Portal will be "docked" on the right side of the MDI and "unpinned." Move your mouse pointer over the tab to make the panel visible at any time. For other options, see [Show, Tile, Dock and Pin Panels](#).)
Chapter 3: Desktop Application Interfaces

If your organization chooses to implement a web-based *Synthesis Enterprise Portal (SEP)* for an enterprise database, you can also access many of these same features – as well as selected metrics, reports and other details from specific analyses – from any web-enabled device.

**Portal Messages**
The Synthesis Platform’s messages feature provides a convenient way to communicate with other database users. Messages are displayed in a "timeline" format similar to social media websites like Facebook®.

These messages are displayed both in *My Portal* (in any Synthesis desktop application) and in the *Synthesis Enterprise Portal* (if it is implemented for your database).

All database users will be able to view their own messages. In a secure database, the following **permissions** are required to create, edit or delete messages:

- **Create portal messages** allows you to create new messages, and edit or delete the messages you have personally created.
- **Manage all portal messages** allows you to edit or delete any messages that are visible to you. This includes any message for which you are the creator or one of the recipients.

**Message Display Options**
The messages timeline will display all messages that were created by or addressed to you. You can sort the message threads in two ways:

- **Newest Active** considers the dates/times of both the main messages and the replies.
- **Newest Message** considers only the dates/times of the main messages.

**Create, Edit, Delete or Reply to Messages**
In Synthesis desktop applications, you can access the message commands from the *My Portal* tab of the ribbon, and by right-clicking inside the Messages page of the panel.
Note that the purpose of the **Refresh Messages** command is to update the display with any new messages that were recently added or changed by another database user.

**Message Recipients**
You can specify whether a message will be visible to all database users or only to specific users or groups. If you select Selected Groups/ Users, you can choose from two lists: user groups that have been predefined in the database and/or individual user accounts.

If a valid SMTP server has been defined for the database, you can select the **Also send this via e-mail** check box to send an e-mail copy of the message to the recipient(s). (See [Enable Alerts via E-mail or SMS](#).)

**Actions in My Portal**
Throughout the Synthesis Platform, your team can use actions to track specific assignments that need to be performed. These versatile Synthesis resources can be used multiple times in different locations, if appropriate. This may include actions in Project Plans, FMEAs or Test Plans, as well as actions that are independent of any particular analysis or plan.

This topic discusses how to view and manage actions via My Portal (in any Synthesis desktop application). If you want to view/manage all action records, see [Actions Explorer](#) or [Resource Manager](#). For information about the action properties and other general considerations that apply wherever the action may be used, see [Action Resources](#).

**Actions Displayed in My Portal**
The Actions page in [My Portal](#) (and in the [Synthesis Enterprise Portal](#)) display action records that:

- Need to be reviewed by you.
• Are relevant to you in some way and are:
  • **Past Due** – the completion date has passed.
  • **Due Next 7 Days** – the completion date occurs within the next 7 days.
  • **Past Start Date** – the start date has passed.
  • **Start Today** – the start date is today.
  • **Start Tomorrow** – the start date is tomorrow.
  • **Start Next 7 Days** – the start date occurs within the next 7 days.
  • **In Progress** – the actual start date has been entered and the action is not yet "Past Due" or "Due Next 7 Days."

If the action is not used in the Project Planner, this will be based on the planned start/completion dates. But if the action is used in a plan, it’s based on the expected dates (which can shift automatically if there are recorded delays in prior gates/actions).

Also note that if an action fits under more than one heading, it will display under the more urgent one. For example, if the action is both due in the next 7 days and past the planned start date, it will show under "Due Next 7 Days."

### Create, Edit or Delete Actions from My Portal
In Synthesis desktop applications, you can access the portal actions commands from the My Portal tab of the ribbon, and by right-clicking inside the Actions page of the panel.

![Actions Menu](image)

**Tip:** If an action doesn’t fit the My Portal display criteria for your computer/username (see details below), the new record won’t be displayed in your portal after you create or edit it. In such cases, you can use the Actions Explorer or Resource Manager to access the record.
Add to Outlook Calendar

The Add to Outlook Calendar command will be enabled if Microsoft Outlook is installed on your computer.

It launches Outlook's interface for creating a new calendar event and automatically populates the subject and date. You can modify the details as needed before saving the new event to your calendar.

Note that you may need to give focus to the Outlook application in order to see the window.

Refresh Actions

The Refresh Actions command updates the display with any new actions that were recently added or changed by another database user.

Action Display Settings

To specify your personal preferences for displaying actions in My Portal (stored per computer/username), right-click inside the panel and choose Action Display Settings.

If you select the Display ‘Show Actions’ labels in portal check box, the panel will also include headings that indicate how the action is relevant to you:

- I am responsible for
  - You are assigned in the Person Responsible field.

- I am a team member in
  - You belong to the team assigned in the Team field.

- I need to review/approve
  - You are assigned in the Reviewer field.

- I am monitoring
  - You are assigned in the Action Monitors window, or you have personally subscribed to “watch” the action.

- Other actions I created
  - You are listed in the Created By field and none of the other roles apply.
Finally, you can choose to **Sort by Start Date** or **Sort by Due Date** within each node of the display.

**Action Explorer**
The **Action Explorer** command opens a flexibility utility that allows you to explore all of the action resources that are stored in the current database. You can use it to filter, sort, add, edit or delete actions. (See [Action Explorer](#).)

Note that when you return to the Actions page in My Portal, you will need to use the **Refresh Actions** command to view any changes.

**Repository Users List**
The repository users list shows all active user accounts in the database, and identifies which of those users are currently connected to the database with any of the Synthesis applications.

This list is displayed both in [My Portal](#) (in any Synthesis desktop application) and in the [Synthesis Enterprise Portal](#) (if it is implemented for your database).

In Synthesis desktop applications, you can access the users list commands from the **My Portal** tab of the ribbon, and by right-clicking inside the **Users** page of the panel. Similar commands are available in the web-based Synthesis Enterprise Portal, if applicable.
My Profile opens the User Login and Contact Information window, which allows you to edit the contact information associated with your user account.

Refresh Users updates the list to reflect any recent changes in user activity.

Project Plan Summary in My Portal
In all Synthesis desktop applications except MPC, the Project Plan Summary page in My Portal provides a summary of the plan for the current project, if applicable.

The summary in My Portal always reflects the entire plan for the current project, based on the actual date/time from your computer. If you want to see the summary for a particular gate or action, or to estimate what the statuses would be for a different date, you must use the Project Planner window.

- Choose Project > Management > Project Planner.
- Click the link in the project name bar at the top of the summary in My Portal.
How to Read the Summary
The plan summary in My Portal provides the following information at-a-glance. (For details, see Project Plan Summary Panel.)

By default, this shows the current date, which is used to determine the status (e.g., "Missed Start Date"), resource usage to date, etc.

Use Refresh to obtain the latest information from the Project Planner.

The top bar displays name of the project that the summary applies to. Click the link to open the project in the Project Planner.

The next two rows show the expected dates and any actual dates, and the last row shows the status.

This is the percentage of the total duration of dependent actions/gates that is complete. For example, if Action 1 (duration = 3 days) is complete and Action 2 (duration = 1 day) is incomplete, the progress is 75%.

For resource usage, the black bars show the planned man hours and costs. The colored bars show either the expected usage to date (estimated based on the number of days in progress), or the actual usage if complete. (See Costs and Man Hours.)

- Yellow = In progress and usage to date is still within plan
- Orange = In progress and usage to date has exceeded plan
- Green = Complete and actual usage was within plan
- Red = Complete and actual usage exceeded plan
Displays only if actions have been assigned to the project or gate (either directly or via dependent gates).

- **Not Started** = Actions that have not started and can complete on time
- **In Progress** = Actions that are in progress and can complete on time
- **Completed** = Completed actions that have been approved, or don't require approval
- **Past Due** = Actions that have not completed and can no longer complete on time

### Folios

### Data Sheets

The data sheets in Weibull++/ALTA and RGA folios share some common components and features. The following picture shows the basic components of a data sheet using one particular format as an example.
Chapter 3: Desktop Application Interfaces

- **Caption** shows the name of the folio and the name of the sheet that is currently displayed.

- **Name Box** shows the location of the currently selected cell by listing the column letter and row number that intersect at the cell's location.

- **Data Entry Bar** shows the contents of the selected cell, which may be text, a numerical value or a formula. For text or numerical values, you can enter/edit the information directly inside the cell or inside the data entry bar. For a formula, you must use the data entry bar for editing; the cell will display only the calculated value.

- **Row Headings** identify the row numbers. Each data sheet contains up to 65,536 rows. The application's speed of execution is inversely proportional to the number of data rows in the current data set.

- **Column Headings** indicate the titles of the columns. To rename a heading, right-click it and choose **Rename Column**. When applicable, you can save the column titles and use them as the default headings for all new data sheets of the current type. (See **Default Column Headings**.)

- **Sheet Tabs** represent the different sheets within the folio. To rename a sheet, double-click the tab. The number of folios that can be opened at once depends on the amount of memory of your system (up to a maximum of 256 for some folio types).

**Default Column Headings**

In life data (Weibull++), life-stress (ALTA) and growth data (RGA) folios, creating a new data sheet automatically applies default column headings that are generally appropriate for the
analysis. If there are certain types of data that you frequently use (e.g., miles-to-failure, cycles-to-failure, etc.), you can customize the column headings to always use your preferred column titles.

To modify the defaults for a particular data type, first rename the column headings in an existing data sheet. Right-click the heading and choose Rename Column on the shortcut menu. Then save the new titles as the defaults. In Weibull++, choose Life Data > Format and View > Set Headers as Default. (In ALTA, the command is in the Life-Stress Data tab; in RGA, it's in the Growth tab.)

These preferences are saved for the current computer/username, and will be applied the next time you create a new data sheet for that particular data type.

To apply the new default headings to an existing analysis, open the data sheet and choose [Life Data/Life-Stress Data/Growth Data] > Format and View > Apply Default Headers.

If you ever need to restore the default column headings back to the shipped settings, choose File > Application Setup, then click Reset Application Settings or Reset All Settings on the Reset Settings page.

Resizing Columns
Column widths are set to span evenly by default. If you want to resize and have the changes saved with the folio, right-click a column heading and choose Column Width Style > Default.

To resize a column, drag the edge of the heading to the desired position, or right-click it and choose Column Width.

Entering Formulas in the Data Sheet
Data sheets in Weibull++, ALTA and RGA allow you to enter formulas in columns that do not require entries to be dates, times or text (e.g., you cannot use formulas in the State F or S column in a Weibull++ life data folio, or in the Classification column in an RGA growth data folio). For example, in a Weibull++ life data folio, if you have a data set where the units were inspected every 24 hours, you can speed up data entry by creating a formula to add 24 hours to the previous inspection time, as shown next.
There are two types of cell references (locations) when inputting a formula: absolute and relative. By default, the cell reference is relative, meaning that as a formula is copied and pasted to other cells, the cell references in the formula will be adjusted to reflect the new relative location. In the previous figure, the formula in cell C2 is copied and pasted into cell C4. This changes the cell reference in the formula from "=C1+24" to "=C3+24"; therefore, the time value in C4 is 72+24 = 96.

In contrast, an absolute reference does not change when the formula is copied to other cells. Absolute references are designated by placing a dollar sign ($) in front of the row and/or column to be made absolute. If the formula in the example were rewritten to "=$C$1+24", then copying the formula to cell C4 would retain the cell reference to C1 and the time value in C4 would be 24+24 = 48.

**Change Units**

In Weibull++, ALTA and RGA, you have the ability to define the time units used for the data set and calculations. For example, if your data set contains failure times in hours, you now have the option to perform calculations using different time units such as years, months, days, etc. The software performs the unit conversion automatically. Authorized users can define the time units that will be available for use in any project within the database and set up the conversion factors.

The units are displayed in the heading of the relevant column in the data sheet. If you wish to change the time units of an existing data sheet, click the Change Units icon on the Main page of the control panel.

In the Change Units window, the units that are currently being used in the data sheet will be displayed at the top of the window. In the Change Units To field, you can choose any other
defined time unit to be used in the data sheet. In the **Conversion Options** area, specify what will happen when the units are changed:

- You can convert the existing data to the new units. For example, if you had a time of 10 in a data sheet that was using hours, that time would become 600 if you converted the data to minutes (10 hours x 60 minutes per hour = 600 minutes). For Weibull++ life data, ALTA life-stress data and RGA growth data folios, when this option is selected, you can select whether you want to copy the data to a new sheet in the folio and then perform the conversion, leaving the original data sheet unchanged, or convert the data in the current sheet.
- You can leave the data unchanged and just apply the new units. This would be appropriate if, for example, you had entered all of your data and then realized that the data sheet was using different units from the original units in which the times were measured.

### General Spreadsheets

General Spreadsheets can be inserted into a Weibull++ life data folio, ALTA life-stress data folio or RGA growth data folio. They provide the same spreadsheet capabilities that are available in the spreadsheet module in *Synthesis Workbooks*, but are stored together with an analysis folio. You may prefer to use this reporting tool if you are performing custom calculations based on the data sheets in the same folio and you wish to keep the analyses together with their source data.

To add a General Spreadsheet to a folio, right-click the data sheet tab area (the area at the bottom of the window that shows the name of the data sheets in the folio) and choose **Insert General Spreadsheet** on the shortcut menu. This command also appears on the ribbon tab for the particular type of data folio. For example, to insert a general spreadsheet into a Weibull++ life data folio, you can choose **Life Data > Folio Sheets > Insert General Spreadsheet**.

### Inserting Data Source Functions

To build and insert functions that utilize a referenced analysis (data source), click a cell in the general spreadsheet and choose **Sheet > Sheet Actions > Function Wizard**.
Chapter 3: Desktop Application Interfaces

The following picture shows the most complex configuration as an example:

For the function arguments:

- Brackets [ ] indicate that the input is optional.
- You can use cell references as inputs. For example, instead of entering 1000 for the Age input, you could specify to use whatever time is currently entered into cell A10, using either the relative reference (A10) or the absolute reference ($A$10). (See Cell References.)
- You can also use variable names as inputs. (See Defined Names.)

For the data source:

- Click the Select button and then select which data sheet in the folio to use as the data source.
- Any time you make changes to the data source, the general spreadsheet will need to be recalculated to reflect the most current results. Choose Sheet > Format and View > More Settings > Recalculate Formulas. The general spreadsheet may return "N/C" if the data source needs to be recalculated.
**Inserting Math Functions**

To add math, date, logic and other functions, click a cell in the general spreadsheet and choose **Sheet > Sheet Actions > Insert Function**.

![fx](image)

Select a function from the drop-down list and click **OK**. You can enter inputs for the function arguments by either selecting the cells in the sheet or typing them directly into the appropriate field.

**Referencing a Data Source**

Some functions (e.g., `AMEAN`, `D_COUNT`, etc.) require you to reference a particular data source.

To reference a data source, use the following syntax, with the quotes and exclamation marks (!). You can only reference sheets in the same folio.

```
"Application!Folio!DataSheet"
```

In the following example, the data source is a data sheet called "Data1" in the Weibull++ folio called "Folio1".

![Function Arguments](image)

### Control Panels

Many of the analysis folios, diagram sheets and other interfaces in Synthesis desktop applications utilize a control panel that allows you to make required inputs, initiate the desired analysis or simulation and view/access applicable results. This topic describes some features that are common to most control panels. (For Xfmea, RCM++, RBI, MPC and Lambda Predict, see [System Panel and Analysis panel](#) instead.)
Switching Between Pages

Many control panels and navigation panels contain multiple pages that vary depending on the type of analysis. You can switch between pages by clicking either the large buttons or the small icons at the bottom of the panel.

If you drag the horizontal splitter bar to the bottom of the control panel, all of the pages will be accessed by small icons. If you drag it as far up as it will go, all of the pages will be accessed by large buttons.

Hiding or Displaying a Control Panel

The control panel can be toggled between hidden and displayed states by clicking the Hide or Show icon in its title bar.

When the control panel is hidden, only the title bar and page icons will be visible on the right side of the window (as shown next using a Weibull++ folio as an example). When you click the bar, the active page will be displayed temporarily. When you click anywhere outside of the control panel page, it will be automatically hidden again.
Identifiers Page

The Identifiers page of the control panel allows you to enter identifying details (e.g., category, name, part number, etc.) that will be associated with the analysis and any models or SEP summaries that are published from the analysis. This will help you to find, filter and group analyses and resources throughout the repository.

In folios that can have multiple data sheets, the Folio Identifiers are edited via the Item Properties window, and the Data Sheet Identifiers can be entered directly in the control panel. Use an asterisk (*) if you want the data sheet’s identifiers to be the same as the folio’s (see Synthesis Identifiers).

Publishing Page

The Publishing page allows you to view and manage information from the current analysis that is shared throughout the Synthesis Platform.

- **Model/Fitted Model** – publishes a model based on the current analysis. See Publishing Models.
Chapter 3: Desktop Application Interfaces

- **SEP Summary** – publishes a summary of the current analysis to the Synthesis Enterprise portal website. This is visible only if the enterprise database is configured for SEP and you have the "Publish to Synthesis Enterprise Portal" permission. See [Publishing to SEP](http://blocksim.reliasoft.com).

- **Metrics** – shows all of the metric resources that are associated with the current analysis. See [Showing Metrics in Folios/Diagrams](http://blocksim.reliasoft.com).

**Notifications Page**
When applicable, the Notifications page provides information on the **Current Status** of the analysis, along with any warnings or errors. A green light indicates that the folio has been analyzed, and a red light indicates that the folio has not been analyzed since changes were last made. The **Latest Notifications** area displays any warnings and errors generated during analysis.

![Notifications Page](http://blocksim.reliasoft.com)

**Utilized Resources Page**
In BlockSim only, the Utilized Resources page displays a grouped list of all of the **resources** that are used directly by blocks in the diagram (i.e., not applied via any other resource or tool).

For example, a **URD** that is assigned to a block will be displayed in this list, but the **model** assigned to the URD will not be shown, nor will any **tasks** assigned to the URD. Similarly, if a block belongs to a maintenance group, that maintenance group will be shown in the list. However, if a block has a state change trigger, the maintenance group(s) used for that trigger will not be shown unless some block in the diagram belongs to them.

This list is not updated automatically; if you have made changes to the diagram, click the **Refresh** icon to update the list.
Double-click a resource in the list to open its properties window for viewing or editing. Click the Resource Manager icon to view/manage all of the resources available in the project.

System Panel and Analysis Panel
Some Synthesis applications use two convenient panels to manage all of the analysis information in a particular project (Xfmea, RCM++, RBI and MPC) or in a particular prediction folio within the project (Lambda Predict).

The first panel (called the System panel or the System Hierarchy panel) allows you to build simple or complex multi-level configurations that contain the items you plan to analyze. The second panel (called the Analysis panel or the Properties panel) contains all of the properties and analyses for the item that is currently selected.

This topic discusses the ways in which you can configure the layout of these two panels to fit your particular workspace preferences.

Change Orientation
You can display the panels side-by-side or with one panel above the other.

To switch between layouts, choose View > Workspace Layout > Change Orientation.

Resize a Panel
You can resize the panels by dragging and dropping the vertical (or horizontal) separator into the desired position.
Chapter 3: Desktop Application Interfaces

**Hide a Panel**
You can also completely hide either panel so that the other can fill the available space. Choose View > Workspace Layout > Hide [System Panel/System Hierarchy] or [Analysis Panel/Properties].

When you wish to return to the two-panel layout, choose the **Split Panels** command.

**Expand or Collapse Nodes**
When the panel presents data in a hierarchical tree configuration (e.g., the system hierarchy, FMEA hierarchy, etc.), the View tab provides several flexible options for expanding and collapsing the nodes (branches) that are currently displayed.

To expand or collapse all branches at the same time, choose **Expand Tree** or **Collapse Tree**.

To expand or collapse a specific branch, you can click the + or - icons, or select the item and choose **Expand Node** or **Collapse Node**.

To collapse all branches in the tree to a specific level, select any item at the desired level and choose **Collapse to Level**.

As an example, the following pictures show how the hierarchy collapses to the second (subsystem) level.
Selecting Which Columns to Display

When applicable, you can hide, display or reorder the columns shown in a particular type of hierarchy by right-clicking any column heading and choosing **Customize Columns**. These settings are stored per computer/username, and different users may have different display preferences without affecting the stored data. The same preferences can also be managed from the relevant page of the Application Setup.

Printing

Synthesis desktop applications use different windows (Print, Page Setup and Print Preview) for different types of features.

- **Printing Plots and Diagrams**
- **Printing Data Sheets and Synthesis Workbooks**

When a report is generated in Microsoft Word or Microsoft Excel (Xfmea, RCM++, RBI, MPC and Lambda Predict), you will need to use the utilities built in to those applications.

Printing a plot from within **RS Draw** uses the commands specific to it.

Plots and Diagrams

To print a plot in Xfmea, RCM++, RBI or Lambda Predict, click the **Print** icon on the plot control panel. To print a diagram in Xfmea, RCM++ or RBI, or a diagram or plot in Weibull++, ALTA, BlockSim, RENO or RGA, choose **Home > Print > Print**.

Specify the properties, then print the plot or diagram.

When printing a plot, you can open the **Print Preview window** to preview the plot before sending it to the printer. Closing the Print Preview window will return you to the plot, not the Print window.

Printing Diagrams in BlockSim

When printing a diagram in BlockSim, you must first choose whether to print only the **Current** diagram (and possibly its subdiagrams on separate pages) or **Choose Multiple** diagrams from the current project to print.
Considerations for Printing Plots

- In Xfmea/RCM++/RBI and Lambda Predict, when printing Pareto (bar) charts or matrix charts, set the orientation of the printed page to landscape for best results. When the orientation is set to portrait, the chart may appear stretched.

- When printing pie charts with the orientation set to portrait, the pie details, legend and user information may be cut off on the printed page because the chart is too wide to fit the page. If this occurs, change the orientation to landscape or use the Plot Setup window to remove the details or the legend/user information from the plot.

Print Preview - Plots and Diagrams

To preview how a plot or diagram will look on the printed page before printing it, click Preview in the Print window; click the Print Preview icon on the plot control panel or choose Home > Print > Print Preview.

Use the toolbar icons to set how many pages to display. You can open the Page Setup window to specify the printing options.

Print Layout

For diagrams in Weibull++, ALTA, BlockSim, RENO, Xfmea, RCM++ and RBI, the Print Layout option allows you to view how a diagram will appear on the printed page. The page orientation (i.e., portrait or landscape) depends on the orientation selected in the Page Setup window. To display the page boundary lines, choose Home > Print > Print Layout.

Everything within the boundary lines will appear on the printed page. Use this to make any necessary adjustments before printing the diagram.

To exit the print layout mode, choose Home > Print > Print Layout.

Page Setup - Plots and Diagrams

The Page Setup window allows you to make selections for how the page(s) will be printed. You can open it from the Print Preview window. For diagrams and plots in Weibull++, ALTA, BlockSim, RENO and RGA, or a diagram in Xfmea, RCM++ or RBI, you can also choose Home > Print > Page Setup.
Chapter 3: Desktop Application Interfaces

**Page Tab**
Use the Page tab to set the layout, scaling and other options.

**Margins Tab**
Use the Margins tab to set the margins.

Use the **Units** drop-down list to specify the units in which the margins will be printed. The options are **System's default** (which uses the units used by your computer), **Inches** or **Centimeters**.

**Header/Footer Tab**
Use the Header/Footer tab to set the header and footer formats.

Use the toolbar on the tab to quickly insert **common format codes** into the selected section of the header or footer.

**Header/Footer Format Codes - Plots and Diagrams**
Use these format codes for printing the headers and footers in **plots and diagrams**.

By default, text will be centered in the headers/footers unless otherwise specified. Please note that the alignment codes (i.e., &L, &C, &R) restart each format code section. For example, in the format code &L&P &R&ZI, the page number will be left aligned and the sheet name will be right aligned. Unless otherwise stated, all format codes can be used by all items.

<table>
<thead>
<tr>
<th>Format Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;L</td>
<td>Left aligns the item.</td>
</tr>
<tr>
<td>&amp;C</td>
<td>Center aligns the item.</td>
</tr>
<tr>
<td>&amp;R</td>
<td>Right aligns the item.</td>
</tr>
<tr>
<td>&amp;A</td>
<td>Prints the sheet name.</td>
</tr>
<tr>
<td></td>
<td>(For plots in Xfmea, RCM++, RBI and Lambda Predict, nothing is printed.)</td>
</tr>
<tr>
<td>&amp;D</td>
<td>Prints the current date.</td>
</tr>
<tr>
<td>&amp;T</td>
<td>Prints the current time.</td>
</tr>
<tr>
<td>&amp;P</td>
<td>Prints the page number.</td>
</tr>
</tbody>
</table>
Chapter 3: Desktop Application Interfaces

<table>
<thead>
<tr>
<th>&amp;P+number (e.g., &amp;P+2)</th>
<th>Prints the page number plus the specified number.</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;P-number (e.g., &amp;P-2)</td>
<td>Prints the page number minus the specified number.</td>
</tr>
<tr>
<td>&amp;&amp;</td>
<td>Prints an ampersand.</td>
</tr>
<tr>
<td>&amp;N</td>
<td>Prints the total number of pages.</td>
</tr>
<tr>
<td>&amp;ZA</td>
<td>Prints the name of the application (e.g., Weibull++).</td>
</tr>
<tr>
<td>&amp;ZC</td>
<td>Prints the company name.</td>
</tr>
<tr>
<td>&amp;ZU</td>
<td>Prints the user name.</td>
</tr>
<tr>
<td>&amp;ZP</td>
<td>Prints the project name.</td>
</tr>
</tbody>
</table>
| &ZI | Prints the name of the item. 
(For plots in Xfmea, RCM++, RBI and Lambda Predict, nothing is printed.) |
| &ZL | Print the path to the current repository. |

Data Sheets and Synthesis Workbooks

To print a data sheet in Weibull++, ALTA or RGA, choose **Home > Print > Print**. To print a Synthesis Workbook in Weibull++, ALTA, BlockSim, RENO or RGA, choose **Print > Print** in the **Preview window**.

Specify the properties, then print the data sheet or Synthesis Workbook.

**Print Preview - Data Sheets and Synthesis Workbooks**

To preview how a data sheet will look on the printed page before printing it, choose **Home > Print > Print Preview**. For Synthesis Workbooks, choose **View > Print > Print Preview**.

150 | http://blocksim.reliasoft.com
You can open the Page Setup window to specify the printing options.

**Page Setup - Data Sheets and Synthesis Workbooks**
The Page Setup window allows you to make selections for how the page(s) will be printed. For data sheets, you can open it either from the Print Preview window or by choosing Home > Print > Page Setup. For Synthesis Workbooks, choose View > Print > Page Setup.

**Spreadsheet Module**

**Page Tab**
Use the Page tab to set the orientation, scaling and other printer options.

**Margins Tab**
Use the Margins tab to set the margins.

**Header/Footer Tab**
Use the Header/Footer tab to set the header and footer formats.

Click Custom Header/Footer to open the Header/Footer window and define the format - use the specific format codes for data sheets and Synthesis Workbooks. If you choose to use different values for the first page and/or for odd and even pages, the window includes separate tabs where you define the individual formats.

**Sheet Tab**
Use the Sheet tab to specify how the pages will print and in what order they will print.

If desired, use the Print area field to limit the printed material to either a selected cell range or to a defined name.

**Word Processing Module**

**Margins Tab**
Use the Margins tab to set the margins.

**Paper Tab**
Use the Paper tab to set the paper size.
Chapter 3: Desktop Application Interfaces

Layout Tab

Use the Layout tab to see the header and footer options.

**Header/Footer Format Codes - Data Sheets and Synthesis Workbooks**

Use these format codes for printing the headers and footers in **data sheets and Synthesis Workbooks**.

<table>
<thead>
<tr>
<th>Format Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;[Page]</td>
<td>Prints the page number.</td>
</tr>
<tr>
<td>&amp;[Pages]</td>
<td>Prints the number of pages.</td>
</tr>
<tr>
<td>&amp;[Date]</td>
<td>Prints the date.</td>
</tr>
<tr>
<td>&amp;[Time]</td>
<td>Prints the time.</td>
</tr>
<tr>
<td>&amp;[Path]&amp;[File]</td>
<td>Prints the file path.</td>
</tr>
<tr>
<td>&amp;[File]</td>
<td>Prints the file name.</td>
</tr>
<tr>
<td>&amp;[Tab]</td>
<td>Prints the sheet name.</td>
</tr>
<tr>
<td>&amp;[Picture]</td>
<td>Prints a selected picture.</td>
</tr>
</tbody>
</table>

Click the **Format Picture** icon on the Header/Footer window to set the image size and other properties.
Chapter 4: BlockSim and RENO Ribbon

In Synthesis desktop applications, the *ribbon* replaces the toolbars and menus used in older software. The ribbon is divided into tabs that relate to a task or activity, such as managing the projects in a database or performing a specific type of analysis. Depending on the current activity, some commands may appear dimmed or will not appear at all.

Note that many features in the application also have a shortcut menu (accessed by right-clicking) that gives access to commands that are commonly used for that feature. All commands available in the shortcut menus are also available on the ribbon. In addition, the ribbon includes a customizable *Quick Access Toolbar* that allows you to display frequently used commands.

**Tip:** To maximize your workspace, you can choose to automatically minimize the ribbon and display only the tab names. To do this, click the arrow on the right-side of the ribbon (labeled "Minimize Ribbon" in the picture below). The ribbon will be expanded when you click a tab and then minimized after you click a command.

Quick Access Toolbar
The Quick Access Toolbar is a customizable feature of the ribbon that allows you to access frequently used commands without changing the tabs.

- To add your favorite commands to the Quick Access Toolbar, right-click the command on the ribbon and select *Add to Quick Access Toolbar*.
- To remove a command from the toolbar, right-click the command on the ribbon or on the Quick Access Toolbar and select *Remove from Quick Access Toolbar*.
- Right-clicking anywhere within the Quick Access Toolbar also gives you the following commands:
Chapter 4: BlockSim and RENO Ribbon

- **Show Quick Access Toolbar Below the Ribbon** or **Show Quick Access Toolbar Above the Ribbon**. The command that appears depends on where the toolbar is currently displayed on the ribbon.

- **Minimize the Ribbon** maximizes your workspace by allowing you to display only the tab names on the ribbon. The ribbon will be expanded when you click a tab and then minimized after you click a command. To keep the ribbon always expanded, clear the check box.

**Backstage View (File Tab)**

The **Backstage view** (File tab) is the first view you will see when you start a Synthesis desktop application. This topic provides a summary of the commands available in the **Tab Pane** on the left side. For information about the right side, see ReliaSoft Online Pane.

- **Save** (available only when a Synthesis file is currently open) saves all recent changes to the Synthesis file (*.rsf11). This command is not applicable in a standard or enterprise database, because the changes are saved automatically as you work.

- **Save As** (available only when a standard database or Synthesis file is currently open) saves a copy of the standard database or Synthesis file to another pathname/filename and/or file type. You can save the file as a new standard database (*.rsr11), Synthesis file (*.rsf11) or compressed standard database (*.rsgz11).

- **Pack and E-mail** (available only when a standard database or Synthesis file is currently open) sends a compressed version of the standard database or Synthesis file via e-mail.

- **Open Repository** opens an existing standard database (*.rsr11), enterprise database (*.rserp), Synthesis file (*.rsf11) or a compressed standard database (*.rsgz11).

- **Close Repository** closes the database. You also can close the database by opening another database or by exiting the application.

- **Recent** shows a list of recently opened database files (*.rsr11, *.rserp and *.rsf11) and a list of recently accessed locations. Clicking a database will open it, and clicking a location will allow you to browse for databases in that location. The number of items in these lists is set in the **Synthesis Settings page** of the Application Setup. You can pin items to a list by clicking the pushpin icon associated with the item; when the pin is vertical, the item will not roll off the list.
New allows you to create a new standard database (*.rsr11), Synthesis file (*.rsf11) or connection file for access to an enterprise database (*.rserp).

Launch Application provides quick launch icons for other Synthesis desktop applications that are installed on your computer. If you are currently connected to a database when you click one of these icons, the same database will be opened automatically in the new application.

Manage Repository provides a variety of tools and configurable settings for the repository. The settings are shared by all users and all analysis projects in a database.

Help Center provides a variety of resources to help you use the application more effectively. In addition, the Help Center displays information about the application, including the Compile Release Version (CRV) and License information.

Application Setup allows you to set your personal preferences for working with analyses, such as the math precision, default plot settings and the like. The settings apply only to the current computer/username, and they do not affect the results of the analyses.

Exit closes the current database (if any) and shuts down the application.

Manage Repository
The Manage Repository section of the Backstage View contains the following commands. The available commands depend on the current application and the database type.

Users

- Users and Security controls which users can access the repository and their permissions.
- User Groups create and manage groups of users that can be assigned to actions, messages, etc. throughout the current database.
- Repository Logins displays a list of users who have connected to the repository and allows you to export this information to Excel.
- Reset "In Use" Flags allows you to reset the flags that indicate the "in use" status of projects or items within a project.
Chapter 4: BlockSim and RENO Ribbon

**Lambda Predict Repository Settings**
Available only in Lambda Predict:

- **FIDES Settings Manager** defines the settings related to the FIDES prediction standard such as process audits, pi factors, categories, etc. (See [FIDES Settings Manager](http://blocksim.reliasoft.com) in the Lambda Predict documentation.)

- **Custom Derating Standards Manager** allows you to add, edit, delete or import/export custom derating standards. (See [Creating Custom Derating Standards](http://blocksim.reliasoft.com) in the Lambda Predict documentation.)

- **MIL-217 Custom Connections** defines custom connection types for use with the MIL-HDBK-217F prediction standard. (See [MIL-217 Custom Connection Types](http://blocksim.reliasoft.com) in the Lambda Predict documentation.)

**Xfmea/RCM++/RBI Libraries**
Available only in Xfmea, RCM++ and RBI:

- **Profiles/Library Manager** configures the predefined settings of the profiles stored in the software library. Profiles allow you to customize the look, drop-down lists, rating scales and other settings of a particular project in order to fit the needs of the analysis. (See [Profiles/Library Manager](http://blocksim.reliasoft.com) in the Xfmea/RCM++/RBI documentation.)

- **Templates Manager** allows you to manage the configurable templates that can be used for customized reports, saved queries or importing/exporting data via Excel. (See [Templates Manager](http://blocksim.reliasoft.com) in the Xfmea/RCM++/RBI documentation.)

**Settings and Predefined Options**

- **Repository Settings** allows you to enable alerts via e-mail or SMS, activate history logs, and other settings.

- **Time and Usage Units** defines the time units that will be available for use in any project within the database. This allows users to work with time-based inputs and results in the units that are appropriate for the situation.

- **Project/Item Categories** defines the categories that can be used to filter and group data throughout the database.

- **Default Name Formats** (not applicable for MPC) specifies the default names for new Synthesis resources, as well as new blocks in BlockSim RBDs, fault trees and phase diagrams.
Project Planning Resources (not applicable for MPC) defines the cost categories, teams, materials and facilities that are used for tracking costs, man hours and resource utilization in actions and Project Planner gates.

Working Days/Holidays (not applicable for MPC) specifies the business days when project planning resources can be utilized.

Dashboard Layout Manager (not applicable for MPC) shows all of the predefined dashboard layouts that will be available for any Synthesis user to view for a particular data set.

Task Types (applicable only in RCM++, RBI and MPC) maps the task types used in RCM++ and RBI (e.g., Restoration, Failure Finding, etc.) to the corresponding task classes in the universal reliability definition (e.g., Preventive, Inspection, etc.) so that simulation and cost calculation results are accurate. (See Task Types in RCM++/RBI in the Xfmea/RCM++/RBI documentation.) In MPC, it allows you to modify the abbreviations used for the MSG-3 task types. (See Task Type Abbreviations in MPC in the MPC documentation.)

XFRACAS Connection is available only for standard databases (*.rsr11) or Synthesis files (*.rsf11) in Weibull++/ALTA, RGA, and Xfmea/RCM++/RBI. It allows you to define connection settings for an enterprise repository.

Database Tools

New Enterprise Repository opens a wizard that leads you through the steps to create a new enterprise repository (SQL Server or Oracle database). To use this option, you must have access to a server with a supported version of SQL Server or Oracle and you must have the appropriate permissions to create a new database on the server.

Upgrade Version 9/10 Repository converts an existing Version 9 or Version 10 enterprise database to a Version 11 enterprise database. This cannot be undone. It is recommended that you create a backup of the Version 9/10 database before performing the upgrade.

Upgrade Version 8 Repository copies all of the existing data from a Version 8 enterprise database to a new Version 11 enterprise database.

Restore Points manages all of the project backups that are stored in the current database.
Compact and Repair is available only in a standard database (*.rsr11) or Synthesis file (*.rsf11). It helps to reduce the size of the database and protect against data loss and corruption. (See Backups and Database Maintenance.)

Import from Version 5 is available only in Xfmea, RCM++ and RBI. It allows you to import data from a Version 5 Xfmea/RCM++ database. This command is available only when you are connected to an enterprise database and have the "Manage users and logins" permission and the applicable "manage all projects" permissions.

ReliaSoft Online Pane
On the Backstage view, the area on the right side is called the ReliaSoft Online Pane. There are three pages available in this pane, accessed by the icons at the top of the pane:

- The ReliaSoft Online Home page displays software tips, announcements and upcoming training seminars for this application.
- The Latest News page displays recent announcements about ReliaSoft’s reliability software and services.
- The Synthesis Platform page displays tips and announcements related to the entire Synthesis Platform.

Note that an active Internet connection is required to see this information.

This pane can be hidden by clearing the Display ReliaSoft Online pane check box on the Synthesis Settings page of the Application Setup.

Help Center (File > Help) and Help Tab
The Help Center, which is part of the Backstage view, is intended to help you use the application more effectively by providing quick access to a variety of support tools. To access the Help Center, choose File > Help. For your convenience, the same commands are also available 's Help tab.

Using This Application
- Online Help File opens the application's help file. If you have an active Internet connection, the help topics that you see will always be the most up-to-date versions available. If you do not have an active Internet connection, the help topics that you see will be the local copy that was installed on your machine.
**Online Resources**

- **ReliaSoft.com** opens the main page of [the reliasoft.com website](https://www.reliasoft.com).
- **Weibull.com** opens the [weibull.com website](https://www.weibull.com), which is devoted entirely to the topic of reliability engineering, reliability theory and reliability data analysis and modeling.
- **ReliaWiki.org** opens the [ReliaWiki website](https://www.reliawiki.org), which is both a resource portal and a wiki for professionals in reliability engineering and related fields.
- **Reliability Discussion Forum** opens the [Reliability Discussion Forum website](https://www.reliabulletin.com), which is designed to facilitate communication within the reliability engineering field. These forums are open to everyone and no password is required. ReliaSoft personnel monitor and participate in the discussions.
- **ReliaSoft.tv** opens the [ReliaSoft TV website](https://www.reliasoft.tv).

**Examples**

- **Open Examples Folder** provides access to a set of example projects that are designed to help you explore various software features.

**Technical Support**

- **E-mail Support** generates an e-mail to request technical support. The e-mail is pre-populated with information about your license and operating system, which the technical support representative will need for troubleshooting the issue.
- **Contact USA Office** provides the contact information you will need to obtain technical support.
- **Contact Global Support Center** helps you find your localized support center.
- **Check for Update** allows you to download the latest free service release for the software.

- **Licensing** displays your license and registration details. To view or edit additional information, click **License Manager**. The **License Manager** displays additional information about which products you have currently registered and/or your contact information on file with ReliaSoft.
• **About** displays the application's Compile Release Version (CRV) (sometimes called a "build number"), which allows you to determine whether you have the latest version of the software.

### Home Tab

The Home tab contains the following commands:

#### Clipboard

- **Paste** pastes the contents of the Clipboard into the current diagram. Choosing **Paste With Duplicate Resources** allows you to create an exact duplicate of the pasted block's resources. The duplicate universal reliability definition (URD) of the pasted block will have the same name as the original URD with an increment number added to the end (e.g., URD1_1, URD1_2, etc.). The duplicate resource will also appear in the Resource Manager window.

- **Cut** cuts the selected text or graphic to the Clipboard. Data stored on the Clipboard can be pasted into this and other applications.

- **Copy** copies the selected text or graphic to the Clipboard. Data stored on the Clipboard can be pasted into this and other applications. If you are copying a plot, the way the plot is copied will depend on your selection in the Copy Plot Graphic setting in the Application Setup window.

- **Format Painter** allows you to copy the block properties from one block and apply them to another block in the current diagram or to copy the format properties of text in a spreadsheet and apply it to other text.

  - To use the Format Painter in a diagram, select the block with the properties that are to be copied and then select **Format Painter**. The pointer will turn into a pointing hand. Next, click the block to which the properties are to be applied. The Format Painter Settings window will appear, which allows you to select the properties of the source block that you want to be applied to the destination block.

  - To use the Format Painter in a spreadsheet, select the text with the format properties that are to be copied and then select **Format Painter**. Next, click the text to which the format properties are to be applied.
Edit

- **Redo** reapplies the previously canceled action. You can redo multiple actions by choosing Redo again.

- **Undo** cancels the last editing change you made.

- **Delete** deletes the selected blocks.

- **Clear**
  - **Clear All** deletes the contents and format of the selected cell(s), but does not delete the actual cell(s).
  - **Clear Values** deletes only the contents of the selected cell(s). The format will be retained.
  - **Clear Formats** deletes only the format of the selected cell(s). The contents will be retained.

- **Select All** selects all of the blocks in the diagram.

- **Find** allows you to quickly find text/values in the active diagram. You can limit your search to within a particular block property (e.g., block caption, block description, etc.), and select whether to limit the result to text that have the same case (**Match case**) and/or limit the results to text/values that are identical to the search term (**Find whole field only**).

- **Spelling** activates the **Spell Check utility**, which allows you to check the spelling within the current sheet.

Print

- **Print** sends the current diagram to the printer.

- **Print Preview** opens the **Print Preview window**, which allows you to view how the current diagram or sheet will appear on the printed page.

- **Page Setup** opens the **Page Setup window**, which allows you to specify printing options.
Print Layout displays the page boundary lines on the diagram. Everything within the boundary lines will appear on the printed page and this view allows you to make any necessary adjustments to the final look of the diagram before sending it to the printer.

Launch

Another Synthesis Application provides a drop-down list of the other Synthesis applications that are installed on your computer. When you click an icon, the same database will automatically be opened in the new application.

Synthesis

Synthesis Explorer allows you to explore all of the different analyses that are stored in the current database. You can filter, group and sort the analyses in a flexible grid, and also present the information in a wide variety of dashboard charts. (See Synthesis Explorer.)

Actions Explorer allows you to explore all of the action resources that are stored in the current database. You can filter and sort by date, status, person responsible, relevancy to you, etc. (See Actions Explorer.)

Block Explorer allows you to explore all of the blocks that are used in RBDs or fault trees in the current database. You can filter, group and sort the blocks by project, diagram, block, analysis creator, etc. (See Block Explorer.)

My Portal Tab


Messages

Create Message opens the Message window, which allows you to compose and send messages within the database.

Edit Message opens the Message window, which allows you to view and edit all of the properties of the message.

Reply to Message opens Message Reply window, which allows you to respond to a message sent to you.
Delete Message deletes the current message.

**Actions**

Create Action opens the Action window and adds an action to the project.

Edit Action opens the Action window, which allows you to view and edit all of the properties of the action record.

Delete Action deletes the current action record.

Add Action to Outlook adds an event, on the Action's due date, to your Outlook calendar.

**Users**

My Profile opens the User Login and Contact Information window where you change your contact details for your user account in the current database.

**Project Tab**

Unless otherwise indicated, these commands apply to the project that is currently selected in the project list. There are three ways to select a project and apply a command:

- By right-clicking the project in the project list and choosing the command from the shortcut menu.
- By selecting the project in the project list and then clicking the command on the ribbon.
- By clicking anywhere inside the project that is currently open/visible and then clicking the command on the ribbon.

*Note:* For secure databases, access to the commands on this tab may be restricted based on the permissions assigned to the user account.

**Management**

Create Project adds a new project to the current database. At a minimum, you must specify the project name.

Open Project opens the selected project.
Close Project closes the project that is currently open/visible and all of the analyses it contains.

Edit Project Properties allows you to view and edit the properties of the selected project.

Duplicate Project creates a copy of the selected project. The new project will have the same name as the original with an increment number added to the end (e.g., Project_1, Project_2, etc.).

Delete Project moves the selected project to the recycle bin.

Transfer Project is available only in Xfmea/RCM++/RBI. It allows you to create a new project with data transferred from the selected project. (See Transfer Projects in the Xfmea/RCM++/RBI documentation.)

Task Numbering is available only in MPC. It allows you to specify whether or not you want to reuse task numbers within the project. (See Task Numbering in MPC in the MPC documentation.)

Manage Projects opens the Manage Projects window, which allows you to edit the security settings and properties of all projects in the database in one location.

Import/Export gives you the option to open either the Import or Export wizard. The Import wizard allows you to import projects, resources or items from an existing database into the current database, while the Export wizard allows you to export to a new or existing database. (See Import, Export and Data Conversion.)

Configurable Settings is available only in Xfmea/RCM++/RBI. It allows you to view/modify the configurable settings for the current project. (See Configurable Settings in the Xfmea/RCM++/RBI documentation.)

Restore Points gives you the option to utilize restore points, which are exact replicas of the project at a particular point in time (i.e., backups). To create a restore point for the selected project, use the Create Restore Point command. To restore all data from an existing restore point, use the Restore Project command.

Check In/Out allows you to check out the selected project and make it available for editing only to you, while all other users in the database have read-only access to the project. No other user can edit the project unless you check in the project or undo the check out.
Recycle Bin

Empty Recycle Bin permanently deletes all projects under the Recycle Bin heading in the project list. There is no undo for emptying the recycle bin.

Restore Project is available only when you have selected a project under the Recycle Bin heading. The selected project will be recovered from the recycle bin and restored to its original location in the project list.

Delete Project permanently deletes the selected project. There is no undo for delete unless you have a stored backup or restore point.

History Log is available only if you are the project owner or have the applicable "manage all projects" permissions. It opens the Project History Log window, which allows you to activate and deactivate the history log for the project and, if the history log is currently activated, to view changes that have been performed throughout the entire project, with any Synthesis application.

Project Planner opens the Project Planner, which provides full project planning and management capabilities for the current project. This command is not available in MPC.

E-mail Project

Pack and E-mail compresses a copy of the selected project to a *.rsgz11 file and attaches it to a new e-mail message. If no e-mail program is installed or no default e-mail program is defined on the computer, a message notifying you of this will be shown.

Security

Project Security is available only for public projects in secure databases. It opens the Project Properties window with the Security tab active, where you can specify the user accounts that can view/modify the selected project.

Change Owner allows you to assign a different database user to be the owner for the selected project.

Lock Project moves the project into the Locked heading of the project list. When a project is locked, all database users (including the user who locked the project) will have read-only access to the project. In addition, a locked project cannot be deleted or have its properties and public/private status edited. To unlock a project, choose Unlock Project. (See Locked and Unlocked Projects.)
Chapter 4: BlockSim and RENO Ribbon

**Make Private** moves the selected public project into the Private heading of the project list. (See *Public, Private and Reference Projects*.)

**Make Public** moves the selected private or reference project into the Public heading of the project list.

**Make Reference** moves the selected public project into the Reference heading of the project list. This command is not available in MPC.

### Current Item

The following commands are available when you select a specific item (a diagram, report, multiplot, etc.) in the current project explorer. This group is not available in Xfmea/RCM++/RBI or in MPC.

- **Edit** brings the selected item to the front of the windows and activates it as the current control. If an attachment is selected, the command opens the attachment in the appropriate application, if that application is installed on your computer.

- **Rename** allows you to rename the selected item.

- **Duplicate** creates a copy of the selected item within the project. The duplicate will have the same name as the original with an increment number added to the end (e.g., RBD1_1, RBD1_2, etc.). In BlockSim, you can choose to **Duplicate With Resources**, which also creates duplicate resources in the **Resource Manager** window.

- **Delete** deletes the selected item. *There is no undo for delete.*

- **Item Properties** is available only for project explorer items (e.g., folios, diagrams, plots, etc.). It opens the Item Properties window, which allows you to view and edit the item's **Synthesis identifiers**, **item settings** (if applicable) and **item permissions** (in secure databases).

- **Locator Link** is a link file (similar to a Windows shortcut) that provides quick access to the specific analysis. In an enterprise database, you can choose to **Save** or **E-mail** the file. In a standard database or Synthesis file, the only option is to save the file. In Xfmea/RCM++/RBI, these commands are available in the System Hierarchy tab. In MPC, they are in the Systems, Structures or Zones tab.
Synthesis

_resource manager_ opens the Resource Manager window, which allows you to view and edit all of the resources (URDs, models, tasks, etc.) available to the selected project. This command is not available in MPC.

_batch properties editor_ opens the Batch Properties Editor, which allows you to perform batch editing of most types of local resources in the current project. In BlockSim, it also allows you to edit the blocks used in the diagrams. This command is not available in MPC.

_attachments_ is available only in Xfmea/RCM++/RBI and MPC. It adds linked or attached files to the selected project. In other Synthesis desktop applications, attachments commands are available in the current project explorer, and in the Insert tab of the ribbon.

Data Management

The following commands are available only in BlockSim.

_mirror group manager_ opens the Mirror Group Manager window which allows you to add, view and edit groups of mirrored blocks within the project that is currently open/visible. (See Mirroring (Using Blocks in Multiple Locations) in the BlockSim documentation.)

_maintenance group manager_ opens the Maintenance Group Manager window, which allows you to add, view and edit the maintenance task groups available to the project that is currently open/visible. (See Maintenance Groups.)

Reports

_MRBR_ is available only in MPC. It allows you to generate a maintenance review board report in Microsoft Word. (See Maintenance Review Board Reports in the MPC documentation.)
Insert Tab
The Insert tab contains the following commands:

Wizard

- **Project Item Wizard** opens the Project Item Wizard, which provides information about all the analyses that you could add to the project and guides you through any steps required to configure the analysis that you have selected.

Diagrams

- **Analytical RBD** adds an analytical reliability block diagram to the project.
- **Analytical Fault Tree** adds an analytical fault tree to the project.
- **Simulation RBD** adds a simulation reliability block diagram to the project.
- **Simulation Fault Tree** adds a simulation fault tree to the project.
- **Phase Diagram** adds a phase diagram to the project.
- **RENO Flowchart** adds a RENO flowchart to the project.
- **Markov - Continuous** adds a continuous Markov diagram to the project.
- **Markov - Discrete** adds a discrete Markov diagram to the project.

Tools

- **Allocation Analysis** adds an allocation analysis tool to the project.

Build from Synthesis

- **Build RBDs and FTs from Synthesis** opens a setup window that allows you to create diagrams based on items imported from Xfmea, RCM++, or RBI or on items imported from Lambda Predict.
- **Build Effect FTs from Synthesis** opens a setup window that allows you to create fault trees based on effects.
Reports and Plots

- **FRED Report** adds a [FRED report](#) to the project.
- **Fault Tree Tracer** adds a [fault tree tracer](#) to the project. This tool provides a way to visualize how fault tree subdiagrams fit into a parent fault tree.
- **Synthesis Workbook** adds a Synthesis Workbook to the project. A Synthesis Workbook is a custom reporting tool that contains both spreadsheet and word processing modules.
- **Overlay Plot** adds an [overlay plot](#) to the project that allows you to display in a single plot results from multiple diagrams. This provides an easy visual method to compare analyses. For example, you may wish to show the reliability plots of two product designs in the same plot.
- **3D Plot** adds a [3D plot](#) to the project. 3D plots can be based only on RENO flowcharts.

Attachments

- **Attachment** adds linked or attached files to the project.

Simulation Worksheets

- **Add Simulation Worksheet** adds a [simulation worksheet](#) to the project that allow you to vary values that are used in simulating a simulation RBD or a RENO flowchart. This allows you to investigate the effect of one or more settings on the simulation results.

View Tab

The View tab contains commands related to configuring the layout of the application's interface.

Refresh

- **Refresh** refreshes the display in the Project window. If multiple users are accessing the same project simultaneously, this command will refresh your screen with any changes made by other users. When you make a change to the project, your window will be refreshed automatically.
Chapter 4: BlockSim and RENO Ribbon

Project Manager

Show Project Manager brings the Project Manager into focus. If the Project Manager is unpinned and hidden, choosing this command will display it.

Tile Project Manager tiles the project list and current project explorer so they are both displayed simultaneously in the Project Manager panel. This command is not available in Xfmea, RCM++, RBI or MPC.

Dock Project Manager opens a submenu that allows you to choose the desired position for the Project Manager: Dock Left, Dock Right, Dock Top, Dock Bottom or Floating.

My Portal

Show My Portal opens the My Portal window, which provides information relevant to your work within the database, such as messages from other users, recommended actions for a particular project item, status of other users logged in to the database and other information.

Tile My Portal tiles the Messages, Actions and Users pages so they are all displayed simultaneously within the My Portal panel.

Dock My Portal opens a submenu that allows you to choose the desired position for the Portal: Dock Left, Dock Right, Dock Top, Dock Bottom or Floating.

Workspace Layout

The commands in this group are available only in Xfmea, RCM++, RBI, MPC and Lambda Predict.

Change Orientation toggles between the two possible orientations for the System panel and the Analysis/Properties panel. These panels can be side-by-side or one on top of the other.

Hide System [Panel/Hierarchy] hides the System panel in the Project window. When you want to show the panel again, choose View > Workspace Layout > Split Panels.

Hide [Analysis Panel/Properties] hides the Analysis/Properties panel in the Project window. When you want to show the panel again, choose View > Workspace Layout > Split Panels.
Split Panels splits the Project window into two equal panels, with 50% of the available space used for the System panel and 50% of the available space used for the Analysis/Properties panel.

Properties View. These commands are available only in Lambda Predict.

Tree View organizes the properties depending on whether they are physical properties (e.g., part quality level, case type, etc.) or application properties (e.g., ambient temperature, applied voltage, etc.). Depending on the prediction standard and component you are working with, the properties may also be organized according to failure mechanisms or type of data.

Pi Factor View organizes the item properties based on the pi factors that they contribute to so you can see how the values affect the failure rate calculations. The relevant pi factors will vary depending on the item's failure rate model. (See the Tree View and Pi Factor View topic in the Lambda Predict documentation.)

Expand/Collapse
The commands in this group apply to the hierarchical view that currently has focus. Depending on the application, this can be the project list, the current project explorer, the System panel, the Properties panel (Lambda Predict only) or the Analysis panel if it is using a hierarchical view.

Expand Tree expands the entire tree in the hierarchical view.

Collapse Tree collapses the entire tree in the hierarchical view.

Expand Node expands the selected branch in the hierarchical view.

Collapse Node collapses the selected branch in the hierarchical view.

Collapse to Level collapses the hierarchical view to the level of the item that is currently selected. For example, if you have selected a cause in the FMEA hierarchy view and choose this command, all branches in the FMEA hierarchy view will be collapsed to the cause level and the nodes for controls and actions will be hidden.

Zoom
Normal Zoom sets the degree of magnification to 100%.

Zoom In increases the degree of magnification.
Chapter 4: BlockSim and RENO Ribbon

Zoom Out decreases the degree of magnification.

Custom Zoom allows you to specify the degree of magnification.

**Window**

Use Tabbed MDI maximizes the windows to fill the full space available in the MDI and shows a tab for each open window. If you clear this command, the open windows will be displayed as separate windows that can be resized and moved around within the MDI.

Cascade cascades all open project windows inside the MDI.

Tile Horizontally horizontally tiles all open project windows inside the MDI.

Tile Vertically vertically tiles all open project windows inside the MDI.

The Windows drop-down list displays a list of all project windows currently open inside the MDI. You can make any of the open project windows active by clicking its name in this ribbon.

Close All Windows closes all open project windows inside the MDI, leaving only the Project Manager and My Portal panels open (if they were selected to be shown).

**FMRA**

The commands in this group are available only in BlockSim. (See Failure Modes and Reliability Analysis (FMRA) in the BlockSim documentation.)

Show FMRA opens the FMRA view, which displays the FMRA (failures modes and reliability analysis) hierarchy that is associated with the project.

Disassociate FMRA deletes all of the diagrams and blocks associated with the current FMRA hierarchy and closes the FMRA view.

**Show**

The commands in this group are available only in Xfmea, RCM++ and RBI.

Show FMRA enables/disables the FMRA tab in the System panel.
Show Test Plan opens the Test Plan tab in the analysis panel, which displays a list of actions that describe specific tests that need to be performed. (See the Test Plans topic in the Xfmea/RCM++/RBI documentation.)

Active Tabs

3D Plot Tab
The 3D Plot tab is visible when you view a 3D plot sheet.

Plot
- Redraw Plot updates the plot to reflect any changes that have been made.
- Select Diagram opens a window that allows you to select the diagram to plot.

Actions
- Copy Plot Graphic copies the current plot to the Clipboard as a bitmap (*.bmp) graphic.
- 3D Plot Setup opens the 3D Plot Setup, which offers several options for customizing the 3D plot, such as editing axis titles, line styles, grid lines, etc.
- Export Plot Graphic opens the Save As window, which allows you to save the current plot graphic as a *.jpg, *.gif, or *.png.

Display
- Show Legend displays information about the objects shown on the plot.
- Center on Canvas centers the 3D plot horizontally and vertically on the plot sheet.
- Auto Spin auto-rotates the plot horizontally.
- Zoom In and Zoom Out increase or decrease the degree of magnification.

Print
- Print sends the current plot to the printer.
Chapter 4: BlockSim and RENO Ribbon

Print Preview opens the Print Preview window, which shows you how the current plot will appear on the printed page.

Page Setup opens the Page Setup window, which allows you to specify printing options.

Allocation Tab
The Allocation tab is visible when you are working with the allocation analysis tool.

Analysis
Optimize calculates the reliability allocation and displays the results.

Transfer
Export Data to Workbook saves the results in a Synthesis Workbook.

Send to Excel sends the results to an Excel worksheet.

Transfer Target Reliability to FMRA is available when you are working in the Tabs view of an allocation analysis that is associated with an FMRA. This command transfers the calculated target reliability values for each block to the associated FMRA item in Xfmea/RCM++/RBI.

Analysis Tab
The Analysis tab is visible when you are working with an analytical diagram or a Markov diagram.

Analysis
Analyze analyzes the relationships of the components in the diagram and puts the reliability-wise configuration into a mathematical formula.

Analytical Plot creates a plot based on the analysis results. Clicking Analytical Plot before the diagram has been analyzed will automatically perform the analysis and then plot the data.

Analytical QCP opens the analytical Quick Calculation Pad (QCP). The QCP allows you to obtain reliability results based on the algebraic solution for the currently active
diagram. Clicking the **Analytical QCP** icon before the diagram has been analyzed will automatically perform the analysis and then open the QCP.

**Tools**

*Show Algebraic Solution* is available when you are working with an analytical diagram. It generates the algebraic solution for the diagram (i.e., a mathematical representation of the reliability-wise configuration of the diagram) and opens the [Equation Viewer](#).

*Show Cut Sets* is available when you are working with an analytical diagram. It opens the [Cut Sets window](#), which allows you to determine what are all the unique combinations of component failures that can cause system failure.

*Show Analysis Results* is available when you are working with a Markov diagram. It displays the most recently generated simulation results in the [Results Explorer](#).

**Share**

The Publish commands allow you to publish the diagram results as a model for use throughout the project, in any Synthesis application where models are used. **Publish Analytical Model** publishes the analytical solution of the diagram, which is essentially a direct reference to the diagram itself. **Publish Fitted Model** creates a model based on the distribution that has been fitted to the analyzed diagram, which is an approximation of the entire diagram and its subdiagrams. For more on publishing, refer to the [Publishing Models](#) topic.

**Publish SEP Summary** publishes a summary of the current analysis to the Synthesis Enterprise portal website. This is visible only if the enterprise database is configured for SEP and you have the “Publish to Synthesis Enterprise Portal” permission (see [Publishing to SEP](#)).

**Diagram Tab**

The Diagram tab is visible when you are working with an analytical RBD or a simulation RBD.

**Blocks**

*Add Block* adds a new standard block to the current diagram.

*Add Subdiagram* adds a new subdiagram block to the current diagram. When this command is selected, the Select Diagram for the Block window will appear, which allows
you to select a diagram or fault tree that exists in the current project to be represented by the subdiagram block.

- **Add Node** adds a new node to the current diagram.

- **Add Standby Container** adds a new standby container block to the current diagram.

- **Add Load Sharing Container** adds a new load sharing container block to the current diagram.

- **Auto Arrange** automatically arranges the blocks in the diagram so that all blocks are evenly spaced and centered.

- **Auto Fit Width** automatically arranges the blocks in the diagram to fit the width of the diagram window.

**Settings**

- **Connect Blocks** allows you to create connectors between blocks in the current diagram. When this command is selected, click the source block, hold down the left mouse button and drag a line from the source block to the destination block. When the crosshairs are located above the destination block, release the mouse button to create a connector. To stop adding connectors and return to the normal mode, right-click the diagram or clear the Connect Blocks option (i.e., by choosing the command again).

- **Save Diagram** The application always saves the diagram upon calculate or close. This command provides the option to manually save the diagram at any time while you’re editing. This can be useful if you're working across a network in an enterprise database. (This command does not apply to Synthesis files.)

- **Drag and Drop Blocks** toggles drag-and-drop mode on and off for the current diagram. When drag-and-drop mode is off, you can drag blocks to new locations within the current diagram. When drag-and-drop mode is on, you can drag blocks from the current diagram to another diagram of the same type. If you are using the tabbed MDI view, drag the block to another diagram tab to change the focus to that diagram, then drop the block in the diagram area.

- **Block Painter** allows you to copy the block properties from one block and apply them to another block in the current diagram.

- **Style** copies only the block style (i.e., appearance) settings, including the picture on the block if desired.
**Chapter 4: BlockSim and RENO Ribbon**

- **Properties** copies only the block properties, as defined in the Block Properties window, including any attachments if desired.

- **Style and Properties** allows you to copy the block style and/or properties in a single operation.

- **Copy Diagram Graphic** allows you to copy either the entire diagram or just the selected components of the diagram.

- **Copy Diagram as Graphic** copies the current diagram to the Clipboard. The diagram can then be pasted into other documents as an enhanced metafile (*.emf) graphic.

- **Copy Block(s) as Graphic** copies the blocks and connectors that are currently selected in the diagram to the Clipboard. The selected material can then be pasted into other documents as an *.emf graphic.

- **Add Annotation** adds a new annotation to the current diagram. You can edit the text that appears in the annotation by double-clicking it to open the Edit Annotation window.

- **Set Block as Failed** indicates that the block is "off" and the block will be considered to be failed, inactive or absent from the system for reliability calculations. An X will appear on the block to indicate that the block is failed. If de-selected, the block will be considered active for reliability calculations.

- **Set Block Flag** allows you to display or remove a red, yellow or green flag above the selected block. These flags have no effect on the analysis or simulation so you can use them for any purpose of interest to you. For example, each flag color could represent a level of analysis that has been completed.

**Properties**

- **Block Properties** opens the Block Properties window, which allows you to define the failure, maintenance, optimization, throughput and other characteristics of the selected block. If an annotation is selected, this command opens the Edit Annotation window, which allows you to edit the text for the annotation.

- **Line Bend** alters the bend style of the selected connectors. If a custom style is used, the options for removing bend points will become available.
**Standby Settings** apply only to blocks in *standby containers*.

**Set Block to Active (Not Standby)** changes the status of the selected block in a standby container in a diagram from standby to active. Clear this option to change the status of the selected block to standby. This option is available only when a block in a standby container is selected or when a dependent event block (i.e., an event block that is connected to a standby container gate block) is selected.

**Set Standby Order** opens the Standby Blocks Order window where you specify the order in which the standby blocks are used.

**Selection**

**Diagram Actions**

**Refresh Diagram** updates the diagram to show any changes.

**Change Diagram Type** opens the Change Diagram Type window, which allows you to change the current diagram to the opposite diagram type (i.e., you can change the current analytical diagram to a simulation diagram, or the current simulation diagram to an analytical diagram). In this window, you have the following options:

- Select **Duplicate using the new type** option to create a new diagram using the new type. The new diagram will be named "Copy of [original diagram name]." If you do not select this option, the original diagram itself will be changed to the new type.

- Select **Perform the same change to any subdiagrams** to change any subdiagrams to the new diagram type. Note that if you select both this and the **Duplicate using the new type** check box, new subdiagrams will be created along with the new main diagram.

**Note:** If you create an analytical diagram from a simulation diagram, by either duplication or conversion, the maintenance and throughput characteristics defined in the simulation diagram will not be displayed in the analytical diagram, as they are not relevant to the analysis. However, the properties are not lost, and if you then create a simulation diagram from that analytical diagram, all original properties will be retained.

**Show Block Details** opens the **Block Details window**, which displays the details of the blocks and resources in the current diagram.
Diagram Style opens the Diagram Style window, which allows you to edit the appearance of the diagram.

Open Subdiagram opens the diagram that the selected subdiagram block represents. This option is only available when a subdiagram block is selected.

Open Parent Diagram opens a sub-menu that allows you to select a parent diagram (i.e. a diagram that contains a subdiagram block representing the current diagram) to open.

Export Graphic saves the diagram as a graphic in one of the following formats: *.wmf, *.png, *.gif or *.jpg. You will be able to use the exported graphic in any application, provided that the application supports the file format.

Set Block Order allows you to specify the order in which the diagram’s blocks will be displayed in associated allocation analyses, the Optimum Replacement window and, for simulation diagrams, in simulation results and plots.

Cascade Select selects all the blocks that are connected from the selected block, including the selected block itself. This allows you to easily select all blocks that are connected to a block.

Trace Path traces the path of the selected block. Click another block or the diagram to remove the traced path. The color of the traced path is the same as the color for a selected connector and can be set in the Diagram Style window. The thickness of a traced path can also be set in the Diagram Style window, independent of the properties of a selected connector.

Quick View shows a preview of the diagram referenced by the currently selected subdiagram block.

Calculation

Optimum Replacement opens the Optimum Replacement window, which allows you to define the cost of planned and unplanned replacements for selected block(s) and calculate the optimum replacement time, as well as the cost per unit time at that replacement time.
Fault Tree Tab
The Diagram tab is visible when you are working with an analytical fault tree or a simulation fault tree.

Gates and Events

Add Gate allows you to select a new gate block to add to the current fault tree. When adding blocks to a fault tree, they will automatically be connected to the currently selected block, if any.

- **Add AND Gate** adds a new AND gate block to the current fault tree.
- **Add OR Gate** adds a new OR gate block to the current fault tree.
- **Add NOT Gate** adds a new NOT gate to the current fault tree.
- **Add NAND Gate** adds a new NAND gate to the current fault tree.
- **Add NOR Gate** adds a new NOR gate to the current fault tree.
- **Add Voting Gate** adds a new voting gate block to the current fault tree.
- **Add Inhibit Gate** adds a new inhibit gate block to the current fault tree.
- **Add Standby Gate** adds a new standby container gate block to the current fault tree.
- **Add Load Sharing Gate** adds a new load sharing container gate block to the current fault tree.
- **Add PAND Gate** adds a new PAND (priority AND) gate to the current fault tree.
- **Add SEQ Gate** adds a new SEQ gate to the current fault tree.

Add Event allows you to select a new event block to add to the current fault tree. When adding blocks to a fault tree, they will automatically be connected to the currently selected block, if any.

- **Basic Event** adds a basic event block to the current fault tree.
- **Undeveloped Event** adds an undeveloped event block to the current fault tree.
- **Trigger Event** adds a trigger event block to the current fault tree.
- **Resultant Event** adds a resultant event block to the current fault tree.
- **Conditional Event** adds a conditional event block to the current fault tree.

http://blocksim.reliasoft.com
Add Subdiagram adds a new subdiagram block to the current fault tree. When this menu item is selected, the Select Diagram for the Block window will appear, which allows you to select a diagram sheet or fault tree sheet that exists in the current project to be represented by the subdiagram block.

Auto Arrange automatically arranges the blocks in the diagram so that all blocks are evenly spaced and centered.

Settings

Connect Blocks allows you to create connectors between blocks in the current diagram. When this command is selected, click the source block, hold down the left mouse button and drag a line from the source block to the destination block. When the crosshairs are located above the destination block, release the mouse button to create a connector. To stop adding connectors and return to the normal mode, right-click the diagram or clear the Connect Blocks option (i.e., by choosing the command again).

Save Diagram The application always saves the diagram upon calculate or close. This command provides the option to manually save the diagram at any time while you’re editing. This can be useful if you’re working across a network in an enterprise database. (This command does not apply to Synthesis files.)

Drag and Drop Blocks toggles drag-and-drop mode on and off for the current diagram. When drag-and-drop mode is off, you can drag blocks to new locations within the current diagram. When drag-and-drop mode is on, you can drag blocks from the current diagram to another diagram of the same type. If you are using the tabbed MDI view, drag the block to another diagram tab to change the focus to that diagram, then drop the block in the diagram area.

Block Painter allows you to copy the block properties from one block and apply them to another block in the current diagram.

Style copies only the block style (i.e., appearance) settings, including the picture on the block if desired.

Properties copies only the block properties, as defined in the Block Properties window, including any attachments if desired.

Style and Properties allows you to copy the block style and/or properties in a single operation.
**Chapter 4: BlockSim and RENO Ribbon**

- **Copy Diagram Graphic** allows you to copy either the entire diagram or just the selected components of the diagram.

- **Copy Diagram as Graphic** copies the current diagram to the Clipboard. The diagram can then be pasted into other documents as an enhanced metafile (*.emf) graphic.

- **Copy Block(s) as Graphic** copies the blocks and connectors that are currently selected in the diagram to the Clipboard. The selected material can then be pasted into other documents as an *.emf graphic.

- **Add Annotation** adds a new annotation to the current diagram. You can edit the text that appears in the annotation by double-clicking it to open the Edit Annotation window.

- **Set Block as Failed** indicates that the block is "off" and the block will be considered to be failed, inactive or absent from the system for reliability calculations. An X will appear on the block to indicate that the block is failed. If de-selected, the block will be considered active for reliability calculations.

- **Set Block Flag** allows you to display or remove a red, yellow or green flag above the selected block. These flags have no effect on the analysis or simulation so you can use them for any purpose of interest to you. For example, each flag color could represent a level of analysis that has been completed.

**Conversion**

- **Convert Block To** allows you to convert the selected block in a fault tree to another event or gate.

- **Create RBD** creates a reliability block diagram that is equivalent to the current fault tree.

- **Create Transfer Gate** creates a subdiagram that contains the selected gate and all of the gates/event under it, and then replaces the selected gate with a subdiagram block.

**Properties**

- **Block Properties** opens the Block Properties window, which allows you to define the failure, maintenance, optimization, throughput and other characteristics of the selected block. If an annotation is selected, this command opens the Edit Annotation window, which allows you to edit the text for the annotation.
Line Bend alters the bend style of the selected connectors. If a custom style is used, the options for removing bend points will become available.

Standby Settings apply only to blocks in standby containers.

Set Block to Active (Not Standby) changes the status of the selected block in a standby container in a diagram from standby to active. Clear this option to change the status of the selected block to standby. This option is available only when a block in a standby container is selected or when a dependent event block (i.e., an event block that is connected to a standby container gate block) is selected.

Set Standby Order opens the Standby Blocks Order window where you specify the order in which the standby blocks are used.

Selection

Diagram Actions

Refresh Diagram updates the diagram to show any changes.

Change Diagram Type opens the Change Diagram Type window, which allows you to change the current diagram to the opposite diagram type (i.e., you can change the current analytical diagram to a simulation diagram, or the current simulation diagram to an analytical diagram). In this window, you have the following options:

- Select Duplicate using the new type option to create a new diagram using the new type. The new diagram will be named "Copy of [original diagram name]." If you do not select this option, the original diagram itself will be changed to the new type.
- Select Perform the same change to any subdiagrams to change any subdiagrams to the new diagram type. Note that if you select both this and the Duplicate using the new type check box, new subdiagrams will be created along with the new main diagram.

Note: If you create an analytical diagram from a simulation diagram, by either duplication or conversion, the maintenance and throughput characteristics defined in the simulation diagram will not be displayed in the analytical diagram, as they are not relevant to the analysis. However, the properties are not lost, and if you then create a simulation diagram from that analytical diagram, all original properties will be retained.
Chapter 4: BlockSim and RENO Ribbon

Show Block Details opens the Block Details window, which displays the details of the blocks and resources in the current diagram.

Diagram Style opens the Diagram Style window, which allows you to edit the appearance of the diagram.

Open Subdiagram opens the diagram that the selected subdiagram block represents. This option is only available when a subdiagram block is selected.

Open Parent Diagram opens a sub-menu that allows you to select a parent diagram (i.e. a diagram that contains a subdiagram block representing the current diagram) to open.

Export Graphic saves the diagram as a graphic in one of the following formats: *.wmf, *.png, *.gif or *.jpg. You will be able to use the exported graphic in any application, provided that the application supports the file format.

Set Block Order allows you to specify the order in which the diagram's blocks will be displayed in associated allocation analyses, the Optimum Replacement window and, for simulation diagrams, in simulation results and plots.

Cascade Select selects all the blocks that are connected from the selected block, including the selected block itself. This allows you to easily select all blocks that are connected to a block.

Trace Path traces the path of the selected block. Click another block or the diagram to remove the traced path. The color of the traced path is the same as the color for a selected connector and can be set in the Diagram Style window. The thickness of a traced path can also be set in the Diagram Style window, independent of the properties of a selected connector.

Quick View shows a preview of the diagram referenced by the currently selected subdiagram block.

Calculation

Optimum Replacement opens the Optimum Replacement window, which allows you to define the cost of planned and unplanned replacements for selected block(s) and calculate the optimum replacement time, as well as the cost per unit time at that replacement time.
Flowchart Tab
The Flowchart tab is visible when you are working with a RENO flowchart.

Blocks
For all blocks, you set the block properties in the Block Properties window.

- **Add Standard Block** adds a new [standard block](#) to the current flowchart.
- **Add Result Storage** adds a new [result storage block](#) to the current flowchart.
- **Add Conditional Block** adds a new [conditional block](#) to the current flowchart.
- **Add Binary Node** adds a new [binary node](#) to the current flowchart.
- **Add Logic Gate** adds a new [logic gate](#) to the current flowchart.
- **Add Branch Gate** adds a new [branch gate](#) to the current flowchart.
- **Add Summing Gate** adds a new [summing gate](#) to the current flowchart.
- **Add Flag Marker** adds a new [flag marker](#) to the current flowchart.
- **Add GoTo Flag** adds a new [go-to-flag block](#) to the current flowchart.
- **Add Counter Block** adds a new [counter block](#) to the current flowchart.
- **Add Reset Block** adds a new [reset block](#) to the current flowchart.
- **Add Stop Flag** adds a new [stop flag](#) to the current flowchart.
- **Add UI Block** adds a new [UI block](#) to the current flowchart.
- **Add Subchart** adds a new [subchart block](#) to the current flowchart. When this menu item is selected, the Select Diagram for the Block window will appear, which allows you to select a flowchart that exists in the current project to be represented by the subchart block.

- **Auto Arrange** automatically arranges the blocks in the diagram so that all blocks are evenly spaced and centered.
**Auto Fit Width** automatically arranges the blocks in the diagram to fit the width of the diagram window.

**Settings**

**Connect Blocks** allows you to create connectors between blocks in the current diagram. When this command is selected, click the source block, hold down the left mouse button and drag a line from the source block to the destination block. When the crosshairs are located above the destination block, release the mouse button to create a connector. To stop adding connectors and return to the normal mode, right-click the diagram or clear the **Connect Blocks** option (i.e., by choosing the command again).

**Save Diagram** The application always saves the diagram upon calculate or close. This command provides the option to manually save the diagram at any time while you're editing. This can be useful if you're working across a network in an enterprise database. (This command does not apply to **Synthesis files**.)

**Drag and Drop Blocks** toggles drag-and-drop mode on and off for the current diagram. When drag-and-drop mode is off, you can drag blocks to new locations within the current diagram. When drag-and-drop mode is on, you can drag blocks from the current diagram to another diagram of the same type. If you are using the tabbed MDI view, drag the block to another diagram tab to change the focus to that diagram, then drop the block in the diagram area.

**Block Painter** allows you to copy the block properties from one block and apply them to another block in the current diagram.

- **Style** copies only the block style (i.e., appearance) settings, including the picture on the block if desired.
- **Properties** copies only the block properties, as defined in the Block Properties window, including any attachments if desired.
- **Style and Properties** allows you to copy the block style and/or properties in a single operation.
Copy Diagram Graphic allows you to copy either the entire diagram or just the selected components of the diagram.

Copy Diagram as Graphic copies the current diagram to the Clipboard. The diagram can then be pasted into other documents as an enhanced metafile (*.emf) graphic.

Copy Block(s) as Graphic copies the blocks and connectors that are currently selected in the diagram to the Clipboard. The selected material can then be pasted into other documents as an *.emf graphic.

Add Annotation adds a new annotation to the current diagram. You can edit the text that appears in the annotation by double-clicking it to open the Edit Annotation window.

Block Properties opens the Block Properties window, which allows you to define the characteristics of the selected block. If an annotation is selected, this command opens the Edit Annotation window, which allows you to edit the text for the annotation.

Set Block Flag allows you to display or remove a red, yellow or green flag above the selected block. These flags have no effect on the analysis or simulation so you can use them for any purpose of interest to you. For example, each flag color could represent a level of analysis that has been completed.

Selection

Diagram Actions

Refresh Diagram updates the diagram to show any changes.

Diagram Style opens the Diagram Style window, which allows you to edit the appearance of the diagram.

Open Flowchart opens the flowchart that the selected subchart block represents. This option is only available when a subchart block is selected.

Open Parent Diagram opens a sub-menu that allows you to select a parent flowchart (i.e., a flowchart that contains a subchart block representing the current flowchart) to open.

Export Graphic saves the diagram as a graphic in one of the following formats: *.wmf, *.png, *.gif or *.jpg. You will be able to use the exported graphic in any application, provided that the application supports the file format.
Chapter 4: BlockSim and RENO Ribbon

**Cascade Select** selects all the blocks that are connected from the selected block, including the selected block itself. This allows you to easily select all blocks that are connected to a block.

**Trace Path** traces the path of the selected block. Click another block or the diagram to remove the traced path. The color of the traced path is the same as the color for a selected connector and can be set in the Diagram Style window. The thickness of a traced path can also be set in the Diagram Style window, independent of the properties of a selected connector.

**Connector Priority** allows you to change the order of execution of outgoing paths from a block. Note that you can display connector priorities by selecting the **Show Connector Priorities** check box in the diagram’s control panel.

**Quick View** shows a preview of the diagram referenced by the currently selected subdiagram block.

**FMRA Tab**
The FMRA tab is available when working with a [Failure Modes and Reliability analysis (FMRA)](http://blocksim.reliasoft.com) diagram.

**Refresh**

**Synchronize FMRA** allows you to copy any changes you make in the Xfmea/RCM++/RBI analysis to the BlockSim FMRA. Changes that are made in BlockSim are synchronized and propagated to Xfmea/RCM++/RBI automatically, although you may need to refresh the view to see them (View > Refresh).

**Add System Items**

**Add System** adds a new top level (system) item to the FMRA hierarchy. The new item will be added to the bottom of the hierarchy list.

**Add Next Level Item** adds a new item to the next level below the item that is currently selected in the FMRA hierarchy, and adds a block to the corresponding diagram. The new item will be added to the bottom of the hierarchy list for that level.

**Add Same Level Item** adds a new item to the same level as the item that is currently selected in the FMRA hierarchy, and adds a block to the corresponding diagram. The new item will be added to the bottom of the hierarchy list for that level.
Add FMEA Items

Add Function adds a function to a selected record and a block to the corresponding diagram. The new function will be added to the bottom of the hierarchy list.

Add Failure adds a failure mode to a selected function and a block to the corresponding diagram. The new failure will be added to the bottom of the hierarchy list for that level.

Add Cause adds a cause to a selected failure and a block to the corresponding diagram. The new cause will be added to the bottom of the hierarchy list for that level.

Diagram

Connect Blocks allows you to create connectors between blocks in the current diagram. When this command is selected, click the source block, hold down the left mouse button and drag a line from the source block to the destination block. When the crosshairs are located above the destination block, release the mouse button to create a connector. To stop adding connectors and return to the normal mode, right-click the diagram or clear the Connect Blocks option (i.e., by choosing the command again).

Add Node adds a new node to the current diagram.

Auto Arrange automatically arranges the blocks in the diagram so that all blocks are evenly spaced and centered.

Block Properties opens the Block Properties window, which allows you to define the failure, maintenance, optimization, throughput and other characteristics of the selected block. If an annotation is selected, this command opens the Edit Annotation window, which allows you to edit the text for the annotation.

Line Bend alters the bend style of the selected connectors. If a custom style is used, the options for removing bend points will become available.

Diagram Actions

Refresh Diagram updates the diagram to show any changes.

Show Block Details opens the Block Details window, which displays the details of the blocks and resources in the current diagram.
Diagram Style opens the Diagram Style window, which allows you to edit the appearance of the diagram.

Open Subdiagram opens the diagram that the selected subdiagram block represents. This option is only available when a subdiagram block is selected.

Open Parent Diagram opens a sub-menu that allows you to select a parent diagram (i.e. a diagram that contains a subdiagram block representing the current diagram) to open.

Export Graphic saves the diagram as a graphic in one of the following formats: *.wmf, *.png, *.gif or *.jpg. You will be able to use the exported graphic in any application, provided that the application supports the file format.

Set Block Order allows you to specify the order in which the diagram's blocks will be displayed in associated allocation analyses, the Optimum Replacement window and, for simulation diagrams, in simulation results and plots.

Inheritance

If the Inherit command is unavailable, then this indicates that the reliability definition of the selected block is based on the reliability of its lower-level records.

If the Define at this Level command is unavailable, then this indicates that the reliability definition of the selected block is based on that block's universal reliability definition (URD).

System Settings opens the System Settings window, which allows you to edit the item name and operation time of the system.

Toggle Diagram Type allows you to select the opposite diagram type (i.e., you can select to change the current FMRA analytical diagrams to FMRA simulation diagrams, or the current FMRA simulation diagrams to FMRA analytical diagrams). Note that the change affects all of the diagrams in the FMRA.

Calculations

Calculate (Reliability) calculates the reliability of each record in the FMRA hierarchy. This command is available only when working with FMRA analytical diagrams. If there are multiple branches in the FMRA hierarchy, you will be given the option to calculate the entire hierarchy or only the current branch. The reliability for each record will appear in the Reliability column of the FMRA (if it is shown). If the Reliability column is not visible in
the FMRA, right-click the column headers, then click **Customize Columns** to open a window and select the **Reliability** check box.

**Simulate (Availability)** opens the [Batch Mode Simulation window](#), which allows you to select the systems to include in the simulation run. This command is available only when working with FMRA simulation diagrams. If the simulation settings for the selected system(s) have not yet been defined, you will be given the option to configure the settings before starting the simulation.

**Highlight** applies a color-coding gradient to the results shown in each column, from the least "desirable" result to the most "desirable" result. This command toggles highlighting on and off. The colors for highlighting are specified on the **Synthesis Settings** page of the Application Setup.

**Optimum Replacement** opens the [Optimum Replacement window](#), which allows you to define the cost of planned and unplanned replacements for selected block(s) and calculate the optimum replacement time, as well as the cost per unit time at that replacement time.

**Allocation Analysis** adds an [allocation analysis tool](#) for the selected diagram. This command is available for any analytical FMRA diagram that inherits its reliability from its dependents.

**FRED Report** adds a [FRED report](#) for the selected diagram. This command is available for any FMRA diagram that inherits its reliability from its dependents.

**Mirror Groups**

**Mirrors** gives you the option to add the selected cause to a [mirror group](#) or remove it from the group.

**Format Tab**

The Format tab is visible when you are working with a diagram.

**Format**

**Select Font** opens the font window, which allows you to set the font properties for the selected blocks.

**Font Color** opens the Color Palette, which allows you to set the font color for the selected text.
Chapter 4: BlockSim and RENO Ribbon

Fill Color opens the Color Palette, which allows you to set the fill color for the selected text.

Styles

Diagram Style opens the Diagram Style window, which allows you to customize the appearance of the current diagram and set the default properties for connectors and new blocks that are added to the diagram.

Block Style opens the Block Style window, which allows you to customize the appearance of the selected block or annotation.

Connector Style opens the Connector Style window, where you can customize the appearance of the selected connectors.

Alignment and Spacing

Align Blocks allows you to easily adjust the position of multiple blocks. The selected blocks will be aligned with the first block selected, except for Align to Grid, which moves each selected block to its nearest point on the grid. (See Arranging and Resizing Blocks.)

Make Spacing Equal allows you to easily adjust the spacing between multiple blocks. The selected blocks will be moved so that they are equally spaced over the original size of horizontal and/or vertical area. (See Arranging and Resizing Blocks.)

Make Same Size allows you to resize multiple blocks of different sizes. The selected blocks will be resized to match the height and/or width of the first block selected. See Arranging and Resizing Blocks.

Bring to Front moves the currently selected block(s) or connector(s) in front of other objects on the diagram.

Send to Back moves the currently selected block(s) or connector(s) behind other objects on the diagram.

FRED Tab
The FRED tab is visible when you are working with a FRED report.
Levels

�� Append Level Below adds a row below the selected item that shows the blocks in the subdiagram.

�� Remove Level(s) Below removes any rows that have been appended to the selected block.

�� Restart FRED Report clears all levels of the FRED report except the original diagram so that you can restart the report creation.

�� Auto Arrange automatically arranges the blocks in the report so that all blocks are evenly spaced and centered.

�� Auto Expand expands the FRED report to show all subdiagrams and blocks.

Options

 trừ Diagram Style opens the Diagram Style window, which allows you to edit the appearance of the FRED report.

 trừ Block Style opens the Block Style window, which allows you to customize the appearance of the selected block.

 trừ Change Block Color opens the Color Palette, which allows you to select a different color for the selected block.

 trừ Set Color Limits opens the Set Color Limits window, which allows you to set the color limits for the blocks in FRED Reports.

 trừ Export Graphic allows you to save the FRED Report diagram in one of the following formats: *.wmf, *.png, *.gif or *.jpg. You will be able to use the exported graphic in any application, provided that the application supports the file format.

 trừ Cascade Select selects all the blocks that are connected from the selected block, including the selected block itself. This allows you to easily select all blocks that are connected to a block.

 trừ Trace Path traces the path of the selected block. Click another block or the diagram to remove the traced path. The color of the traced path is the same as the color for a selected connector and can be set in the Diagram Style window. The thickness of a traced
path can also be set in the Diagram Style window, independent of the properties of a selected connector.

Export Data to Workbook opens the Select Workbook window, which allows you to select a Synthesis Workbook in the current project or to create a new workbook to export the FRED data to.

Markov Tab
The Markov tab is visible when you are working with a Markov diagram.

Blocks
- Add State adds a new state block to the current diagram. You can define the properties of the new block using the Block Properties window.
- Auto Arrange automatically arranges the blocks in the diagram so that all blocks are evenly spaced and centered.

Settings
- Connect Blocks allows you to create transitions between state blocks in the current diagram. When this command is selected, click the source block, hold down the left mouse button and drag a line from the source block to the destination block. When the crosshairs are located above the destination block, release the mouse button to create a transition. To stop adding transitions and return to the normal mode, right-click the diagram or clear the Connect Blocks option (i.e., by choosing the command again).
- Save Diagram The application always saves the diagram upon calculate or close. This command provides the option to manually save the diagram at any time while you're editing. This can be useful if you're working across a network in an enterprise database. (This command does not apply to Synthesis files.)
- Drag and Drop Blocks toggles drag-and-drop mode on and off for the current diagram. When drag-and-drop mode is off, you can drag blocks to new locations within the current diagram. When drag-and-drop mode is on, you can drag blocks from the current diagram to another diagram of the same type. If you are using the tabbed MDI view, drag the block to another diagram tab to change the focus to that diagram, then drop the block in the diagram area.
Block Painter allows you to copy the block properties from one block and apply them to another block in the current diagram.

Style copies only the block style (i.e., appearance) settings, including the picture on the block if desired.

Properties copies only the block properties, as defined in the Block Properties window, including any attachments if desired.

Style and Properties allows you to copy the block style and/or properties in a single operation.

Copy Diagram Graphic allows you to copy either the entire diagram or just the selected components of the diagram.

Copy Diagram as Graphic copies the current diagram to the Clipboard. The diagram can then be pasted into other documents as an enhanced metafile (*.emf) graphic.

Copy Block(s) as Graphic copies the blocks and connectors that are currently selected in the diagram to the Clipboard. The selected material can then be pasted into other documents as an *.emf graphic.

Add Annotation adds a new annotation to the current diagram. You can edit the text that appears in the annotation by double-clicking it to open the Edit Annotation window.

Set Block Flag allows you to display or remove a red, yellow or green flag above the selected block. These flags have no effect on the analysis or simulation so you can use them for any purpose of interest to you. For example, each flag color could represent a level of analysis that has been completed.

Properties

Block Properties opens the Block Properties window, which allows you to define the initial probability that the system will be in the state, along with other properties depending on whether you are working with a discrete Markov diagram or a continuous Markov diagram. If an annotation is selected, this command opens the Edit Annotation window, which allows you to edit the text for the annotation.

Transition Properties opens the Transition Properties window, which allows you to define the conditions under which the system moves from the source state to the target state.
Line Bend alters the bend style of the selected connectors. If a custom style is used, the options for removing bend points will become available.

Selection

Diagram Actions

Refresh Diagram updates the diagram to show any changes.

Change Diagram Type opens the Change Diagram Type window, which allows you to change the current diagram to the opposite diagram type (i.e., you can change the current discrete diagram to a continuous diagram, or the current continuous diagram to a discrete diagram). In this window, you can select Duplicate using the new type option to create a new diagram using the new type. The new diagram will be named "Copy of [original diagram name]." If you do not select this option, the original diagram itself will be changed to the new type.

Diagram Style opens the Diagram Style window, which allows you to edit the appearance of the diagram.

Phase Properties allows you to specify how long the current phase will run. This will be the number of steps for a discrete diagram, or the length of time for a continuous diagram. You can also change the phase name in this window.

Export Graphic saves the diagram as a graphic in one of the following formats: *.wmf, *.png, *.gif or *.jpg. You will be able to use the exported graphic in any application, provided that the application supports the file format.

Cascade Select selects all the blocks that are connected from the selected block, including the selected block itself. This allows you to easily select all blocks that are connected to a block.

Trace Path traces the path of the selected block. Click another block or the diagram to remove the traced path. The color of the traced path is the same as the color for a selected connector and can be set in the Diagram Style window. The thickness of a traced path can also be set in the Diagram Style window, independent of the properties of a selected connector.

Set Initial State sets the currently selected state block as the initial state for the system. This sets the initial probability value for the selected state to 1, and the initial probability values for all other state blocks to 0.
**Make Transition Angles Even** allows you to specify the angle of the curve used in the transitions. If multiple transitions are selected, this command applies only to the selected transitions. If no transitions are selected, it applies to all transitions in the diagram.

**Adjust Angle in Opposite Transitions** when this command is selected, if two state blocks are connected to each other with two opposite transitions, changing the angle of the curve of one transition will change the other transition to mirror it.

---

**Phase Tab**

The Phase tab is visible when you are working with a phase diagram.

**Phase**

- **Add Operational Phase** adds a new operational phase to the current phase diagram.

- **Add Maintenance Phase** adds a new maintenance phase to the current phase diagram.

- **Add Node** adds a new node to the current phase diagram.

- **Add Stop Block** to indicate that the simulation of the mission ends. A new simulation may then begin, if applicable.

- **Add Subdiagram Phase** adds a new subdiagram block to the current phase diagram. When this menu item is selected, the Select Diagram for the Block window will appear, which allows you to select a phase diagram that exists in the current project to be represented by the subdiagram block.

- **Auto Arrange** automatically arranges the blocks in the diagram so that all blocks are evenly spaced and centered.

- **Auto Fit Width** automatically arranges the blocks in the diagram to fit the width of the diagram window.

**Settings**

- **Connect Blocks** allows you to create connectors between blocks in the current diagram. When this command is selected, click the source block, hold down the left mouse button and drag a line from the source block to the destination block. When the crosshairs are located above the destination block, release the mouse button to create a...
connector. To stop adding connectors and return to the normal mode, right-click the diagram or clear the Connect Blocks option (i.e., by choosing the command again).

**Save Diagram** The application always saves the diagram upon calculate or close. This command provides the option to manually save the diagram at any time while you’re editing. This can be useful if you’re working across a network in an enterprise database. (This command does not apply to Synthesis files.)

**Drag and Drop Blocks** toggles drag-and-drop mode on and off for the current diagram. When drag-and-drop mode is off, you can drag blocks to new locations within the current diagram. When drag-and-drop mode is on, you can drag blocks from the current diagram to another diagram of the same type. If you are using the tabbed MDI view, drag the block to another diagram tab to change the focus to that diagram, then drop the block in the diagram area.

**Block Painter** allows you to copy the block properties from one block and apply them to another block in the current diagram.

**Style** copies only the block style (i.e., appearance) settings, including the picture on the block if desired.

**Properties** copies only the block properties, as defined in the Block Properties window, including any attachments if desired.

**Style and Properties** allows you to copy the block style and/or properties in a single operation.

**Copy Diagram Graphic** allows you to copy either the entire diagram or just the selected components of the diagram.

**Copy Diagram as Graphic** copies the current diagram to the Clipboard. The diagram can then be pasted into other documents as an enhanced metafile (*.emf) graphic.

**Copy Block(s) as Graphic** copies the blocks and connectors that are currently selected in the diagram to the Clipboard. The selected material can then be pasted into other documents as an *.emf graphic.

**Add Annotation** adds a new annotation to the current diagram. You can edit the text that appears in the annotation by double-clicking it to open the Edit Annotation window.
Block Properties opens the Block Properties window, which allows you to define the failure, maintenance, optimization, throughput and other characteristics of the selected block. If an annotation is selected, this command opens the Edit Annotation window, which allows you to edit the text for the annotation.

Set Block Flag allows you to display or remove a red, yellow or green flag above the selected block. These flags have no effect on the analysis or simulation so you can use them for any purpose of interest to you. For example, each flag color could represent a level of analysis that has been completed.

Selection

Diagram Actions

Refresh Diagram updates the phase diagram to show any changes.

Show Block Details opens the Block Details window, which displays the details of the blocks and resources in the current phase diagram.

Diagram Style opens the Diagram Style window, which allows you to edit the appearance of the phase diagram.

Open Diagram opens the diagram that the selected subdiagram block represents. This option is only available when a subdiagram block is selected.

Open Parent Diagram opens a sub-menu that allows you to select a parent diagram (i.e., a diagram that contains a subdiagram block representing the current diagram) to open.

Export Graphic saves the diagram as a graphic in one of the following formats: *.wmf, *.png, *.gif or *.jpg. You will be able to use the exported graphic in any application, provided that the application supports the file format.

Cascade Select selects all the blocks that are connected from the selected block, including the selected block itself. This allows you to easily select all blocks that are connected to a block.

Trace Path traces the path of the selected block. Click another block or the diagram to remove the traced path. The color of the traced path is the same as the color for a selected connector and can be set in the Diagram Style window. The thickness of a traced path can also be set in the Diagram Style window, independent of the properties of a selected connector.
Quick View shows a preview of the diagram referenced by the currently selected subdiagram block.

**Plot Tab**
The Plot tab is visible when you view a plot sheet.

**Plot**

- **Redraw Plot** updates the plot to reflect the changes that have been made.

- **Analytical QCP** is available only for analytical diagrams. It opens the analytical Quick Calculation Pad (QCP). The QCP allows you to obtain reliability results based on the algebraic solution for the currently active diagram.

- **Simulation QCP** is available only for simulation diagrams. It opens the simulation Quick Calculation Pad (QCP). The QCP allows you to obtain reliability, maintainability and availability metrics based on the simulation results.

- **3D Plot** is available only for RENO flowcharts. It adds a 3D plot based on the flowchart to the project.

**Actions**

- **Copy Plot Graphic** copies the plot to the Clipboard as a graphic. If you will be pasting copied plots into any one of the spreadsheets built in to Synthesis applications (e.g., Synthesis Workbooks or General Spreadsheets), choose Metafile Optimized for Synthesis Spreadsheet. If you will be pasting them into external applications, choose Bitmap or Metafile Optimized for External Use.

- **Plot Setup** opens the Plot Setup window, which offers several options for customizing a plot, such as editing axis titles, line styles, grid lines, etc.

- **RS Draw** launches ReliaSoft Draw, which is a graphics editor that offers advanced options for annotating, inserting images, drawing images on a plot, and more.

- **Export Plot Graphic** opens the Save As window, which allows you to save the current plot graphic as a *.wmf, *.png, *.gif, or *.jpg file.
**Show/Hide Plot Items** opens the Show/Hide Plot Items window, which provides options for displaying or hiding from view certain plot items such as data points, lines, probability scales, etc.

**Confidence Bounds**

Confidence bounds are available only for analytical diagrams. They can be shown for the Unreliability vs. Time, Reliability vs. Time and Failure Rate vs. Time plots in cases where all blocks that can fail in the diagram use models that have Fisher matrix bounds. To have Fisher matrix bounds, a model must have been created by publishing from a data source, such as a Weibull++ or ALTA data sheet, that was calculated using Fisher matrix bounds. Additionally, bounds are not available if the diagram has containers, subdiagrams or mirrored blocks.

**Confidence Bounds** is available if the associated analysis includes calculations for confidence bounds. It opens the Confidence Bounds Setup window, which provides options for defining the properties of the bounds that will be displayed on the plot.

**Hide Confidence Bounds** removes the line(s) depicting the confidence bounds from the current plot.

**Sheet Tab**

The Sheet tab is visible when you are working with a simulation worksheet.

**Format and View**

**Format Cells** opens the Format Cells window, which provides several ways to change the way data are displayed in a cell or range of cells:

- **Number tab** - sets the numbering format of a cell. Anything you type in the cell will be automatically formatted based on your selection. For example, if you select the number format and specify 3 decimal places, typing the value 1.2 in the cell will automatically display it as 1.200.

- **Alignment tab** - sets the horizontal, vertical alignment and indentation text in a cell. Includes text control options such as wrap text, shrink to fit, merge cells, as well as text direction.

- **Font tab** - sets the font, style, color, size and effects of the selected text.

- **Border tab** - applies borders around the selected cell(s) and controls the line style, thickness and color of the border lines.
• **Fill tab** - sets the background color of the selected cell(s). You can also apply a pattern style and choose a pattern color.

![Recalculate Formulas](image) **Recalculate Formulas** forces a recalculation of all formulas in the spreadsheet.

![Defined Names](image) **Defined Names** allows you to create and manage variable names that can be referenced in any function. You can define a name for any cell, data source or function. Names can help make formulas in the sheet easier to understand and maintain.

**Sheet Actions**

![Function Wizard](image) **Function Wizard** opens the Function Wizard, which helps you to build functions that return results ranging from mathematical values (e.g., sine, pi or averages).

![Chart Wizard](image) **Chart Wizard** allows you to create new plots and charts based on the current spreadsheet. To use, select a range of cells for which you would like to create a chart, then click **Chart Wizard** and select the area where you want to place the chart.

![AutoSum](image) **AutoSum** allows you to compute the sum of the values in a range of selected cells. If a cell range is not selected, the command computes the sum of the values in the cells directly above the current cursor location.

![Sort](image) **Sort** allows you to reorder the selected data either in ascending or descending order. Note that you may need to be careful when sorting certain types of data in order to prevent errors in analysis.

- If your analysis takes into account the order position of a data point (1st, 2nd, 3rd, etc. position), sorting may result in an inaccurate analysis.
- If the range of cells that you wish to sort contains blank cells, the blank cells may be put in the first position (ascending order) or the last position (descending order).
- If the values in two or more columns are related, sorting only one column may result in errors. In that situation, use the **Custom Sort** command.

**Rows/Columns**

![Delete](image) **Delete** deletes the selected cells and moves the remaining cells based on the specified direction. Note that when the cells are deleted, the information inside the cells is also deleted.
Insert inserts new cells at the current cursor location and moves the existing cells based on the specified direction. If a range of cells is selected in the sheet, then the same number of cells will be inserted.

Transfer Data
Send to Excel exports all sheets to an Excel file.
Send to Word exports the current sheet to a Word file.

Simulation Tab
The Simulation tab is visible when you are working with a simulation diagram, a phase diagram or a RENO flowchart.

Simulation
Simulate opens the Maintainability/Availability Simulation window, for simulation and phase diagrams, or the RENO Simulation window, for flowcharts. These windows allow you to specify simulation settings for the current diagram and run the simulation.

Simulation Plot creates a plot based on the simulation results. Clicking Simulation Plot before the diagram has been simulated will automatically perform the simulation and then plot the data.

Simulation QCP is available only when working with simulation diagrams and phase diagrams. It opens the simulation Quick Calculation Pad (QCP). The QCP allows you to obtain reliability, maintainability and availability metrics based on the simulation results. Clicking the QCP icon before the diagram has been simulated will automatically perform the simulation and then open the QCP.

Debug is available only when working with RENO flowcharts. It opens the RENO Simulation Debugger, which allows you to trace and examine the output of a flowchart by running a step-by-step simulation through each block.

Tools
Show Simulation Details displays the most recently generated simulation results in the Results Explorer.

Check Analysis is available only when working with simulation diagrams and phase diagrams. It allows you to check for inconsistencies in the simulation diagram, such as a
block with a corrective task but no failure model, or a block with scheduled tasks but no corrective task.

**Batch Mode** is available only when working with simulation diagrams and phase diagrams. It opens the Batch Mode Simulation window, which allows you to simulate multiple diagrams consecutively, without user input in between simulation.

**Share**

- **Publish Fitted Model** is available only when working with simulation diagrams. It allows you to publish the distribution that has been fitted to the simulated diagram as a model for use throughout the project, in any Synthesis application where models are used. For more on publishing, refer to the Publishing Models topic.

- **Publish SEP Summary** publishes a summary of the current analysis to the Synthesis Enterprise portal website. This is visible only if the enterprise database is configured for SEP and you have the “Publish to Synthesis Enterprise Portal” permission (see Publishing to SEP).

**Dashboard**

- **Dashboard Viewer** is available only when working with simulation diagrams and phase diagrams. It opens the Dashboard Viewer, which allows you to view the results from the current simulation in any of the dashboard layouts that have been predefined in this database for this type of data.

- **Dashboard Manager** is available only when working with simulation diagrams and phase diagrams, and only if you have permission to create dashboard layouts. It opens the Dashboard Manager, which allows you to create and manage the dashboard layouts that will be available for BlockSim simulation results.

**Tracer Tab**

The Tracer tab is visible when you are working with a fault tree tracer.

**Datasource**

- **Select Data Sources** opens the Select Data Sources window, which allows you to select a top level diagram and a subdiagram of interest.

- **Refresh** updates the tracer diagram to reflect any changes that have been made in the source diagrams since the tracer was last updated.
Blocks

- **Auto Arrange** automatically arranges the blocks in the diagram so that all blocks are evenly spaced and centered.

- **Copy Diagram Graphic** allows you to copy either the entire diagram or just the selected components of the diagram.

- **Copy Diagram as Graphic** copies the current diagram to the Clipboard. The diagram can then be pasted into other documents as an enhanced metafile (*.emf) graphic.

- **Copy Block(s) as Graphic** copies the blocks and connectors that are currently selected in the diagram to the Clipboard. The selected material can then be pasted into other documents as an *.emf graphic.

- **Add Annotation** adds a new annotation to the current diagram. You can edit the text that appears in the annotation by double-clicking it to open the Edit Annotation window.

Selection

- **Cascade Select** selects all the blocks that are connected from the selected block, including the selected block itself. This allows you to easily select all blocks that are connected to a block.

- **Trace Path** traces the path of the selected block. Click another block or the diagram to remove the traced path. The color of the traced path is the same as the color for a selected connector and can be set in the Diagram Style window. The thickness of a traced path can also be set in the Diagram Style window, independent of the properties of a selected connector.
Chapter 5: Building and Customizing Diagrams

BlockSim and RENO both use diagrams of various types. These diagrams differ in terms of their purposes and capabilities, but all of the diagram types have underlying similarities in how they are created and configured.

The topics in this section provide general information about the diagrams and the tools available for creating them.

More specific information about the individual diagram types is available in other sections of the help.

- If you're interested in using reliability block diagrams and/or fault trees:
  - The BlockSim RBDs and Fault Trees section discusses the tools that are common for both analytical and simulation diagrams (such as block types, configuration types, tools for managing the properties for all blocks within a particular diagram, etc.).
  - The BlockSim Analytical Diagrams section discusses the analysis results and plots that are available for analytical RBDs or fault trees.
  - The BlockSim Simulation Diagrams section discusses the analysis results and plots that are available for simulation RBDs or fault trees.

- If you're interested in phase diagrams, see BlockSim Phase Diagrams.

- If you're interested in Markov diagrams, see BlockSim Markov Diagrams.

- If you’re interested in using flowcharts for probabilistic event and risk analysis, see RENO Flowcharts.

Block Properties

The Block Properties window allows you to configure the functional properties of any block selected in a diagram. Double-click the block or choose [Diagram/Fault Tree] > Properties > Block Properties or [Phase/Flowchart] > Settings > Block Properties, depending on the type of diagram you are working with, to open the Block Properties window.
You can also define the properties for multiple blocks simultaneously by selecting the blocks and then opening the Block Properties window. If different types of blocks are selected (e.g., standard and node), only the properties that apply to all selected blocks will be available in the Block Properties window. You cannot open the Block Properties window if there is an ambiguous selection (e.g., if you selected both standard blocks and containers).

*Note:* Double-clicking a subdiagram or subchart block will open the subdiagram that the block is based on. Open the Block Properties window for a subdiagram or subchart block by selecting the block and choosing the command on the ribbon or pressing **CTRL+E**.

Regardless of the type of block you are working with, the Block Properties window always has the elements described next. The other properties available will vary depending on the type of block you are working with. Consequently, these properties are documented in the sections relating to the block types.

- **Name and Description:** Each block is given a default name that is determined based on the block type's default name format. You can type new text either instead of or in addition to the default name. The Name field must be populated. Description text is optional.

  Note that in BlockSim diagrams an asterisk is used (*) to represent default block names. The block name that is displayed in the diagram will replace the asterisk with the block's default name; this allows the block name to be updated dynamically. The way each block type is named by default is specified in the Default Name Formats window.

  For example, by default a node's default name indicates its $k$-$out$-$of$-$n$ value. If you change the value in the node's Number of Paths Required field, the node's name will automatically update when you close the Block Properties window.

- **Identifiers:** These fields allow you to enter additional information about the block. For some block types, this is limited to comments; others may have the full set of identifiers.

- **Active Block:** This drop-down list at the bottom of the Block Properties window allows you to specify another block in the diagram that you want to set the block properties for. This allows you to set the properties for multiple blocks without having to open and close the Block Properties window for each block. When you change the active block, if you have made changes to the current block's properties, a window may appear asking if you want to apply the changes you made. This window will appear only if the Ask to apply changes when selecting different block in Properties window option is selected on the Other Settings page of the Application Setup.

- **Style** opens the Block Style window, which allows you to customize the appearance of the active block.
Chapter 5: Building and Customizing Diagrams

- **Attachments** in BlockSim RBDs and fault trees only, this allows you to attach related files to the block. Clicking this icon opens the **Attachments window**.

### Building Diagrams

To add a **diagram** to a project, choose **Insert > Diagrams > [Diagram Type]**.

To add blocks of any type (e.g., standard blocks, node blocks, fault tree gates, etc.) to a diagram, choose the applicable **Add** command on the [Diagram/Fault Tree/Phase/Flowchart] tab of the ribbon. For example, to add a standard block to a reliability block diagram, choose **Diagram > Blocks > Add Block**.

To add an AND gate to a fault tree, choose **Fault Tree > Gates and Events > Add Gate > Add AND Gate**.

**Note:** If a gate is currently selected in the fault tree when you add an item, the new item will be added below the selected gate and connected to it. If an event is currently selected in the fault tree when you add a gate, the new gate will be added above the selected event and connected either to the event or, if there is a gate above the event, to that gate. If an event is currently selected in the fault tree when you add another event, the new event will not be connected to the original selected event.

You also can cut or copy existing blocks (in the current diagram or in any other diagram of the same type) and paste them into the diagram using the **Cut**, **Copy** and **Paste** commands on the Home tab of the ribbon. Blocks created in this manner will possess the same style and properties as the original block.

To select an individual block, click it. There are several ways to select multiple blocks:

- Hold down the **CTRL** key and click the blocks.
- Click in the diagram and drag the selection area to include the blocks you want to select.
- Choose **Home > Edit > Select All** to select all blocks in the current diagram.

- Click a block and then choose **[Diagram/Fault Tree/Phase/Flowchart] > Selection > Cascade Select** to select all blocks that are connected to that block, either before it or after it and including the selected block itself.
What's Changed? In previous versions of BlockSim and RENO, Templates were used to store reusable blocks that could be dragged into diagrams. In the Synthesis version, the reusability of resources makes this functionality unnecessary.

Connecting Blocks
Connectors represent the flow of the process or system being diagrammed, and the lines contain information about the relationship between the specific source and destination blocks that they connect.

Adding Connectors
To add a connector between blocks, you can:

- Right-click the diagram (not blocks) and choose Connect Blocks.
- Hold down the ALT key.

In both methods, the pointer will change to display small crosshairs. Click the source block, hold down the left mouse button and drag a line from the source block to the destination block. When the crosshairs are located over the connection point box, release the mouse button to create a connector.

Note that existing connectors can be dragged to different destination blocks, if needed. Also note that the curved, custom curve and custom angled connector types give you the option to connect to the top or bottom of a block, if desired. When this option is available, the blocks will show additional connection point boxes when you create or move a connector.
**Stop Adding Connectors**
To stop adding connectors and return the pointer to its normal mode, release the ALT key or click inside the diagram.

*Tip:* If you do not click the diagram or clear the Connect Blocks option to return the pointer to its normal mode, you will not be able to perform certain other activities, such as moving or deleting blocks. If you are experiencing difficulties with the application, make sure that the pointer is in its normal mode.

**Inserting Blocks/Splitting Connectors**
Starting in Version 11, RBDs and Markov diagrams allow you to insert a block into the flow of the diagram without having to delete and add connectors. Simply drag an unconnected block onto an existing connector. When the pointer changes to a double-headed arrow, drop the block to split the existing connector and insert the block.

**Connector Types**
There are several types of connector that can be used in a diagram. The simplest is a straight line but there are options for adding line bends to create curved or angled lines. For details about available connector styles and defining preferences, see Connector Style Settings.
Using Curved, Custom Curve or Angle Connectors
When using curved, custom curve or custom angle connectors, you can choose the location where they connect to the blocks (top, middle or bottom) and add one or more bends to the line. These options can be used separately or in combination.

To add or modify line bends:

- **Curved connectors** have a single bend point in the center of the connector. To change the angle, click and drag the point to the desired location.

```
\begin{center}
\includegraphics[width=0.3\textwidth]{curved_connector.png}
\end{center}
```

- For **custom curve and custom angle connectors**, add line bend(s) by clicking anywhere on the connector and dragging the selected point to the desired location.

```
\begin{center}
\includegraphics[width=0.6\textwidth]{custom_curves_angles.png}
\end{center}
```

These custom bends can be removed by right-clicking the connector and choosing **Remove all Bend Points** or, to remove a single bend point, by right-clicking the bend point and choosing **Remove Bend Point**.

Arranging and Resizing Blocks
There are a number of commands that can be used to arrange and resize the blocks in a diagram. They can be used separately or in combination.

- To select multiple blocks, select the first block and then hold down the **CTRL** key while clicking each of the other blocks.

- If you apply a command and don’t like the result, you can use **CTRL+Z** to return to the original layout.
**Align Blocks**
To align the blocks (align by center, top, bottom, left, etc.), select the block you want to use as the reference alignment position then select the other blocks. Right-click inside one of the blocks and choose **Align Blocks** then the desired alignment style.

The selected blocks will be aligned with the first block selected. For example, if you choose **Align Middles**, the blocks will be aligned to the vertical center of the first selected block, as shown next.

![First block selected](image)

**Resize**
Select the block then click one of the sizing handles and drag it to the desired size.

![Sizing handles](image)

**Make Same Size**
To make the blocks the same size, select the block that has the desired dimension(s) then select the other blocks that you want to resize. Right-click inside one of the blocks and choose **Make Same Size** then choose to match the width and/or height of the first selected block.

For example, if you choose **Height**, the blocks will be resized to the same height as the first selected block.

![First block selected](image)
Chapter 5: Building and Customizing Diagrams

**Make Spacing Equal**
To adjust the spacing between blocks, select the blocks that will be affected (the selection order does not matter). Right-click inside one of the blocks and choose Make Spacing Equal then the desired direction.

The selected blocks will be moved so that they are equally spaced over the original size of horizontal and/or vertical area.

![Diagram showing Make Spacing Equal](image)

**Auto Arrange**
To automatically arrange the blocks in the diagram so that all blocks are placed in logical order depending on their connections, right-click the diagram (not blocks) and choose Auto Arrange.

Note that for Markov diagrams in BlockSim/RENO, you also need to select the starting block that is going to be the top left block in the diagram.

The space between blocks depends on the settings specified in the Background and Grid page of the Diagram Style window.

**Auto Fit Width**
In some BlockSim/RENO diagrams, you can also choose Auto Fit Width to automatically arrange the blocks in the diagram to fit evenly spaced within the width of the diagram window.

![Diagram showing Auto Fit Width](image)
Adding Annotations

Annotations are blocks that can be added to a diagram and can contain notes, comments or any other information that you want to appear with your diagram. Annotations are not taken into consideration when the diagram is analyzed but will be saved with the project.

To add an annotation, right-click the diagram (not blocks) and choose Add Annotation.

The annotation block will appear in the diagram.

By default, the text "Annotation" will appear in the block. You can change this text in the Edit Annotation window, which is accessed by double-clicking the annotation block.

In BlockSim diagrams, you can click the Function Wizard icon to insert a function that provides information about the diagram.
Chapter 5: Building and Customizing Diagrams

If you are working with an analytical diagram, you can insert:

- General Functions, which return basic information about the database and project, such as the project name or the current date.
- Data Source Functions, which return information based on the model used with the specified data source, such as the acceleration factor or the reliability at given time.

If you are working with a simulation diagram, you can insert:

- General Functions, which return basic information about the database and project, such as the project name or the current date.
- Simulation Functions, which return information about the simulation results and settings.

Note that if you want to add additional functions to the same annotation box, click the Function Wizard icon, again.

**Keyboard and Mouse Combinations**
This topic describes the various keyboard and mouse key combinations that you can use while working with diagrams.

Note the following:

- A unit is equal to either 1 millimeter or 0.1 inches, depending on the system setting.
- When selecting multiple objects, you can select either blocks or connectors. A selection cannot include both blocks and connectors. Note that while you can include Standby Containers and Load Sharing Containers in a selection, any changes you make, such as resizing the containers, do not apply to the blocks or connectors in the containers. If you start a selection inside a container, that selection can include only those blocks and connectors within that container.

<table>
<thead>
<tr>
<th>Selecting Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select a block or connector</td>
</tr>
<tr>
<td>Select multiple blocks or connectors</td>
</tr>
<tr>
<td>Select a group of blocks</td>
</tr>
<tr>
<td>------------------------</td>
</tr>
<tr>
<td>Add additional blocks or connectors to the currently selected group</td>
</tr>
<tr>
<td>Select all blocks in the diagram</td>
</tr>
<tr>
<td>Clear all selections in the diagram</td>
</tr>
<tr>
<td>Switch the status of a block or connector from selected to not selected or from not selected to selected.</td>
</tr>
</tbody>
</table>

### Moving Objects

<table>
<thead>
<tr>
<th>Move a block</th>
<th>Click the block and drag to the desired location.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move multiple blocks</td>
<td>Select the blocks then click any block within the selection and drag the selection to the desired location.</td>
</tr>
<tr>
<td>Move block(s) by 1-unit increments</td>
<td>Select the block(s) then press the desired arrow key.</td>
</tr>
<tr>
<td>Move block(s) the distance of 1 grid line</td>
<td>Select the block(s) then press <code>CTRL</code> + the desired arrow key. If only one block is selected, this shortcut will first align the block to the grid and then each subsequent use of the shortcut will move the block by one grid line.</td>
</tr>
</tbody>
</table>

### Resizing Objects

<table>
<thead>
<tr>
<th>Resize a block</th>
<th>Select the block then click one of the sizing handles and drag it to the desired size.</th>
</tr>
</thead>
</table>
# Chapter 5: Building and Customizing Diagrams

| Resize block(s) by 1-unit increments | Select the block(s) then press **SHIFT** and the desired arrow key. The up and down arrow keys move the bottom edge of each selected block by a single unit; the right and left arrow keys move the right edge of each selected block by a single unit. |
| Resize block(s) by 5-unit increments | Select the block(s) then press **CTRL + SHIFT** + the desired arrow key. The up and down arrow keys move the bottom edge of each selected block by 5 units; the right and left arrow keys move the right edge of each selected block by 5 units. |

## Connectors

| Add a new connector | Press **ALT** and drag the connector from the source block to the destination block. |
| Change a connector's source or destination | Select the connector then drag the appropriate connection handle to the new source or destination block. |
| Add a bending point to a connector. Note that the connector must use the Custom style. To set the style, refer to the [Connector Style Settings](#) topic. | Click the connector and drag the bending point to the desired location. |

## Scrolling

| Scroll vertically | Rotate the mouse wheel. |
| Scroll horizontally | Press **SHIFT** and rotate the mouse wheel. |
| Scroll in any direction | With nothing selected, press the desired arrow key. |
| Scroll horizontally to the far left | Press **HOME**. |
| Scroll horizontally to the far right | Press **END**. |
### Scroll to the upper left corner of the diagram
Press **CTRL+HOME** or **CTRL+PAGE UP**.

### Scroll to the lower right corner of the diagram
Press **CTRL+END** or **CTRL+PAGE DOWN**.

### Scroll by the size of the visible area of the diagram
With nothing selected, press **CTRL +** the desired arrow key. For vertical scrolling, you can also press **PAGE UP** and **PAGE DOWN**.

### Move the diagram in any direction
Press **SHIFT**, click the diagram and drag. This is like dragging the diagram sheet itself (e.g., to see objects lower in the diagram, you would drag the diagram upward).

### Other

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in or out</td>
<td>Press <strong>CTRL</strong> and rotate the mouse wheel.</td>
</tr>
<tr>
<td>Exit the Format Painter or Connect Blocks modes</td>
<td>Press <strong>ESC</strong>.</td>
</tr>
<tr>
<td>Create a copy of a block and move the copy to the desired location</td>
<td>Press <strong>CTRL+SHIFT</strong> and click the block then drag to the desired location.</td>
</tr>
<tr>
<td>Add blocks to the mirror group currently shown in the Mirror Group Manager window</td>
<td>Press <strong>CTRL+SHIFT</strong> and drag the block from the diagram into the Mirrored Blocks area of the Mirror Group Manager.</td>
</tr>
</tbody>
</table>

### Skins & Appearance Settings

Most of the appearance settings in a diagram can be customized to meet your particular preferences.

**Diagram Skin** – sets (or resets) all of the settings in the Diagram Style for a particular diagram.

**Diagram Style** – contains all of the style settings for the current diagram (e.g., background color and grid style) as well as default settings for the blocks and connectors within this diagram.
Chapter 5: Building and Customizing Diagrams

**Block Style** and **Connector Style** – allow you to override the default settings for specific blocks or connectors, if desired.

For consistency and ease of use, the simplest option is to choose a preferred skin and set it as the default for your computer. Each new diagram you create will have the preferred settings applied automatically. If desired, you also have the option to change settings for a particular diagram, and/or for particular blocks or connectors.

**Tip:** If you use the Block Style or Connector Style windows to modify the settings for specific blocks or connectors, those settings will no longer be linked to the default settings in the Diagram Style and they won’t be updated if you change the skin. If you want the block/connector settings to be determined by the diagram style/skin, make sure they are set to "Diagram Default."

---

**Using Diagram Skins**

A diagram skin provides a quick and easy way to set (or reset) all of the settings in the Diagram Style for a particular diagram.

Diagram skins are universal across all Synthesis applications. This means that a single skin can contain the appearance settings for all types of diagrams in BlockSim/RENO, Weibull++/ALTA and Xfmea/RCM++/RBI. However, you will only be able to see/modify the settings for the type of diagram that you are currently working with.

The new universal skins are stored with a *.dskin* extension at C:\Users\Public\Public Documents\ReliaSoft\Skins. If you have already customized skins from a prior version, see [Converting Version 9 Skins](#).

In order to create, modify or manage the skins on your computer, you must first open a diagram then right-click and choose **Diagram Style**.

The commands that you will use are located in the lower-left corner of the window.

---

**Select Skin**

To apply an existing skin to the current diagram:

1. Click the **Select Skin** (✓) icon.
2. Choose a skin from the list and click **OK**. The name of the selected skin will be displayed in Skin field.

3. Click **OK** to close the Diagram Style window and apply the relevant settings to the diagram.

If you don’t like the result, you can undo the action by pressing **CTRL+Z**, or simply return to the Diagram Style window and select a different skin.

**Modifying or Creating a Skin**

1. Open a diagram that has the settings you want to reuse or create the diagram. Open the Diagram Style window.

2. Make your changes. For details on the settings that can be changed, see the **Diagram Style Settings**.

3. Click the **Save as Skin** (+) icon. Enter a name for the skin and click **OK**. If you specify a name that already exists, you’ll be asked to confirm that you want to replace the settings for this particular diagram type.

   **Note:** Skin names cannot contain the following characters: < > | / \ ; ? : * or quotes. The names are not case sensitive.

Skins are stored with a *.dskin extension in the Skins folder (C:\Users\Public\Public Documents\ReliaSoft\Skins).

**Save as Skin**

To use the settings in the current diagram to create a new skin, or to update an existing skin:

1. Click the **Save as Skin** (+) icon.

2. Enter a name for the skin and click **OK**. If you specify a name that already exists, you’ll be asked to confirm that you want to replace the settings in the existing skin for this particular diagram type. (The settings that are specific to other diagram types will remain unchanged.)

   **Note:** Skin names cannot contain the following characters: < > | / \ ; ? : * or quotes.

**Manage Skins**

To view or manage the skins that are available to use on your computer, click the **Manage Skins** (...) icon. From here you can:
Chapter 5: Building and Customizing Diagrams

- Click **Import** to browse for *.dskin files in another location (e.g., skins that were created by another user or on a different computer) and copy them into the designated folder for your computer.

  **Tip:** You can also copy/paste *.dskin files directly into the C:\Users\Public\Public Documents\ReliaSoft\Skins folder. However, they won’t appear in the skins list until you restart the application.

- Select a skin and click **Rename**, then specify a new name. This will change the name of the *.dskin file in the designated folder for your computer.

- Select a skin and click **Delete**. This will remove the *.dskin file from the designated folder on your computer and cannot be undone.

- Click **Set Defaults** and then specify which skin will be used by default for each new diagram you create.

Converting Version 9 Skins

Starting in Version 10, diagram skins are universal to all Synthesis applications that use diagrams. This means that a single skin can contain the appearance settings for all types of diagrams in BlockSim/RENO, Weibull++/ALTA and Xfmea/RCM++/RBI.

Many of the predefined skins installed with Version 9 applications have already been merged and converted into universal skins that are ready to use in any diagram type in later versions. For example, the new White.dskin replaces the old RBDWhite.dskinrbd, FTDWhite.dskinftd, etc.

If you created your own customized skins in Version 9, this topic explains how to convert them for use in later versions.

Preparing the Version 9 Skins Folders

The conversion utility considers the old Version 9 skins that are stored in the following locations:

- C:\Users\Public\Public Documents\ReliaSoft\Skins\BlockSim9
- C:\Users\Public\Public Documents\ReliaSoft\Skins\Xfmea9
- C:\Users\Public\Public Documents\ReliaSoft\Skins\RCM9
- C:\Users\Public\Public Documents\ReliaSoft\Skins\Weibull9

Before running the utility, you can:
1. Delete any Version 9 skins that you don’t wish to use or convert. (This is not required but it may help to avoid confusion when you run the conversion utility.)

2. For any Version 9 skins that you wish to combine into the same universal skin, rename them to the same filename (while still retaining the different file extensions).

   For example, if you want to combine RBDCustom.dskinrbd and FTDCustom.dskinftd into the same universal skin, you could rename the files to Custom.dskinrbd and Custom.dskinftd.

**Running the Conversion Utility**

After you have prepared the Version 9 skins folders as described above:

1. Choose File > Application Setup.

2. On the Synthesis Settings > Other page, click Convert.

3. The Convert Skins window will display all of the unique filenames that remain in the Version 9 skins folders. (If you want to combine multiple skins into the same new universal skin, make sure you have already renamed the files as described above.) Select the skins you want to use in later versions and click Convert.

4. Close the application so the skin(s) will be added to the Skins folder.

The new file(s) are stored at C:\Users\Public\Public Documents\ReliaSoft\Skins with a *.dskin extension and “_V9” appended to the name.

**A Note about Diagram Backgrounds**

Universal skins contain appearance settings for diagram background and grid, and connector and block handles that are applied to all diagram types. When you create a universal skin from individual skins with different background/grid/handle settings, only one set of these appearance settings will be stored in the skin. The settings that are saved into the universal skin are from the last skin that was merged. If these are not the settings you desire, you can use the Diagram Style window to change them.

**Diagram Style Settings**

In the Diagram Style window, you can define diagram-level appearance settings, and default settings for the blocks and connectors within the diagram. These settings can be saved in a diagram skin and reused with other diagrams.
Chapter 5: Building and Customizing Diagrams

To open the Diagram Style window, right-click the diagram (not blocks) and choose **Diagram Style**.

This window consists of multiple pages. The number and type of pages depend on the type of diagram that you are working with. Settings that can be defined are divided into two groups: Diagram and Defaults.

- At the diagram level, you can define the appearance of the diagram sheet and those aspects of the appearance of diagram components (i.e., blocks and connectors) that cannot be configured at the individual component level.

- You can define the default appearance settings for diagram components (i.e., connectors, blocks and annotations). See **Defaults for Blocks and Connectors**.

**Background and Grid**
You can customize the background and grid appearance of the diagram.

- **Grid Style**: Whether to display grid lines and, if so, the style of the lines (e.g. solid, dash, etc.).

- **Grid Spacing**: The size (width and height) of the grid squares, in inches.

- **Shadow**: The size and color of the shadow "cast" by blocks in the diagram. Note that this applies to all block types, but the shadow will be shown only if the **Show Shadow** check box is selected on the **Defaults > General** page for that block type.

- **Colors**: The colors used for the background, grid lines and page separator lines. Page separator lines appear in the Print Layout view and indicate the boundaries of each printed page. You can display this view by choosing **Home > Print > Print Layout**.

- **Auto Arrange**: The horizontal and vertical spacing between blocks, in inches, that will be used if you choose the **Auto Arrange** ribbon command.

For fault trees in BlockSim, you can also select the **Always Auto Arrange** check box to turn on Auto Arrange by default.

- **Block Caption ID**: Whether to display the block ID, which is an internal ID number assigned to each block when it is created. You can choose not to display the ID or to display it in decimal or hexadecimal format. If it is displayed, it will appear directly below the block name (i.e., its location, alignment and font will be dictated by the properties that are specified for the block caption).
**Connector Handles and Indicators**

You can customize the following diagram-level connector properties. These settings apply to all connectors of all types within the diagram and cannot be overridden at the connector level.

- If you select **Show Connectors Over Blocks**, any connectors that cross blocks will be shown over (i.e., in front of) those blocks. Otherwise, the blocks will be displayed on top.

- Where connectors attach to blocks if the blocks are not in direct horizontal or vertical alignment. If the **Automatic Connection Preference** field is set to **Left-Right**, the connector will attach to the sides of the blocks; if it is set to **Top-Bottom**, the connector will attach to the top and bottom of the blocks. If **No Preference** is chosen, the connector will attach to the closest edges.

- The **colors** used for:
  - All connector handles and selected connectors.
  - Connectors to/from highlighted blocks (i.e., blocks that are part of a multiple selection).
  - Connectors leading to or from a selected block. This can be helpful in visualizing how a block is connected within a complex diagram.

- The **size of the arrow head**, in inches.

**Block Handles and General Indicators**

You can customize the following diagram-level block properties. These settings apply to all blocks of all types within the diagram and cannot be overridden at the block level.

- The **colors** used for the handles that appear when you are resizing a block or connecting blocks.
  - The properties for a **highlighted block**, including:
    - The colors used for the caption, border and fill (i.e., the area background).
  - The fill style (i.e., how the color is applied to the area).

- **Flag settings**:

  In BlockSim/RENO, can be used to indicate anything you want. For example, each flag could represent a level of analysis that has been completed. These flags are not used by BlockSim for analyses or simulations.
In Weibull++/ALTA, the block flags are used to mark blocks that represent a data sheet that has been changed and has not been calculated or a data sheet that has since been deleted.

- **Block flag size**: Block flags, which are added by selecting one or more blocks, right-clicking one of the blocks and choosing **Set Block Flag**.

- **Block flag borders**: The style (e.g., solid, dash, etc.), color and thickness of the border for block flags.

- **Cross out lines for blocks**: In BlockSim diagrams, the style, color and thickness of the line that is used to cross out blocks that are set as failed. Blocks can be set as failed by selecting the **Set block as failed** option in the **Block Properties window**. You can also set this option by right-clicking the block and choosing **Set Block as Failed**.

**Block Corner Indicators (BlockSim/RENO Only)**
The Block Corner Indicators pages allow you to customize the appearance of status indicators that are displayed at the corners of blocks. Such indicators include the colored shapes that are used to indicate certain block and text labels that may appear independently or in conjunction with a shape. The available Block Corner Indicators pages will vary depending on the type of diagram that you are working with.

**Defaults for Blocks and Connectors**
Default appearance settings can be defined for diagram components (i.e., connectors, blocks and annotations. A diagram skin can hold the appearance settings for all diagram types (e.g., RBD, fault tree, process flow, etc.); however, you can only modify the settings for the diagram type you are working with. To define these settings, see:

- **Block style settings**

- **Connector style settings**

**Block Style Settings**
The block style settings can be defined at the diagram level in the Diagram Style window or at the block level in the Block Style window. The block-specific settings defined in the Block Style window have priority over the default settings defined in the Diagram Style window for the diagram you are working with. For details on how the diagram-level and connector-level settings relate to each other, see **Appearance Settings**.
Diagram Level

To open the Diagram Style window, right-click the diagram (not blocks) and choose Diagram Style.

Block Level

To open the Block Style window, select one or more blocks, right-click one of the blocks then choose Block Style.

Note that if you are using this window, you must clear the various Use Default check boxes in order to modify some settings.

General Properties

Block Properties

- **Shape and shadow:** The options available in the Shape drop-down list depend on the block type. You can change the shape of standard blocks in RBDs, events in fault trees and all blocks in process flow and cause/effect diagrams; all other block types have permanently assigned shapes. You can add a shadow to any available shape.

- **Size:** Unlike the other options on this page, changes to this setting made at the diagram level will apply only to blocks subsequently added to the diagram.

- **Color and style:** The background color is the underlying color applied to the block; the fill color is applied over the background color in the pattern specified by the fill style.

Caption Properties

The caption text comes from a block name in BlockSim/RENO, folio name in Weibull++/ALTA or property name in Xfmea/RCM++/RBI.

- **Location and Horizontal Alignment:** Specify where the caption will be displayed (e.g., under the block, inside the block, etc.) and whether it will be left aligned, center aligned or right aligned.
  
  - If you choose to place the caption to the left, right or inside the block, you can also specify the **Vertical Alignment** (i.e., at the top, center or bottom of the block).

  - If you choose to hide the caption, the Alignment fields will not be available.

- **The width and height** of the area used for the text. You can enter a fixed value for either or both of these. If Block Width is selected in the Width field, the caption text will wrap, if necessary, up to the vertical limit set in the Height field. If Auto Height is selected in the Height field, no limit is placed on the height of the text area.

  - The **color** and **font** used for the text.
Chapter 5: Building and Customizing Diagrams

Description Box Properties
These properties are available for BlockSim/RENO blocks only.

The description box displays the text entered in the Description field of the Block Properties window.

![Properties Table]

Description Box Properties
- **Box width** and **height**: You can enter a fixed value for either or both of these or you can set them to be the same as the settings used for the caption area.
  - If **Block Width** is selected in the Width field, the description text will wrap, if necessary, up to the vertical limit set in the Height field.
  - If **Auto Height** is selected in the Height field, no limit is placed on the height of the text area.
- **Box color** and **style**: The background color is the underlying color applied to the description box; the fill color is applied over the background color in the pattern specified by the fill style.

Description Text Properties
- **Text Location** and **Horizontal Alignment** allow you to specify where the description area will be displayed (i.e., above the block, inside the block or hidden) and whether it will be left aligned, center aligned or right aligned.
  - If you choose to place the caption inside the block, you can also specify the **Vertical Alignment** (i.e., at the top, center or bottom of the block).
  - If you choose to hide the description area, the Alignment fields will not be available.

Note that if you place the description inside the block, only the description text will be shown. The settings for the surrounding area (i.e., background color, fill color and border properties) will not be used. The properties for the background color fill color and fill style of the block will be used instead.

- The **color** and **font** used for the text.
Using the Same Location Settings for Captions and Descriptions
Block captions and descriptions both have the option to place the text above or inside the block. If you choose the same location for both, the description text will display under the caption text.

Images
To load an image:

1. Clear Use default image, if applicable.
2. Click Load, and browse for and select the desired image file.
3. Use the Position drop-down list to specify how the image will be placed on the block (e.g., stretched to fit inside the block's current dimensions, centered, etc.). If you select stretched, you can also define the margins you want.
4. Select the Transparency Mask Color check box to choose a color that will be shown as transparent when the image is displayed on the block.

   Note: If you choose to use an image that is larger than 800x600 pixels, you will be given the option to down sample the image in order to reduce its size and alleviate possible delays related to database size.

5. Click the Clear button to remove the loaded image and use no image at all.

Returning Block-Level Settings to Diagram Defaults
To use the diagram style settings again, in the Block Style window, choose Diagram Default from the drop-down lists and select the Use Default check boxes.

Connector Style Settings
The connector style settings can be defined at the diagram level in the Diagram Style window or the connector level in the Connector Style window. The connector-specific settings defined in the Connector Style window have priority over the default settings defined in the Diagram Style window.
window for the diagram you are working with. For details on how the diagram-level and connector-level settings relate to each other, see Appearance Settings.

**Diagram Level**

To open the Diagram Style window, right-click the diagram (not blocks) and choose **Diagram Style**.

**Connector Level**

To open the Connector Style window, select one or more connectors, right-click one of the connectors then choose **Connector Style**.

Note that if you are using the this window, you must clear the **Use Default** check boxes in order to modify some settings.

**Line Settings**

- **Line Settings**: Specify the connector's line style (e.g., solid, dash, etc.), thickness and color.

- **Line Bend and Arrows**: Use the **Line Bend** drop-down list to specify the kind of bend that you want in the lines. Note that if you select **Angle** or **Right Angle**, the **Line Bend %** field will be enabled. This field allows you to specify the point, in percent, at which the line will bend. For example, if you enter **0.5** (50%), an angle (bend) will appear in the line at the horizontal halfway point.
The available bend styles are shown next.

**Caption Settings**
Specify the location, text color and font used for the caption. The caption text for a connector is entered in the Connector Style window.

Note that in BlockSim/RENO, you cannot enter caption text for connectors used in phase diagrams, RENO flowcharts and Markov diagrams.

**Returning Connector-Level Settings to Diagram Defaults**
To use the diagram style settings again, in the Connector Style window, choose Diagram Default from the drop-down lists and select the Use Default check boxes.
Chapter 6: BlockSim RBDs and Fault Trees

Analyses in BlockSim are based on two basic diagram types: reliability block diagrams (RBDs) and fault trees. These are both symbolic logic diagrams that can be applied to analyze system reliability and related characteristics. Either type can be configured as an analytical diagram (which uses the exact algebraic equation for the system model but imposes limitations on what can be modeled and what results can be obtained) or a simulation diagram (which provides more modeling options and results but must be analyzed with discrete event simulation).

Reliability Block Diagrams (RBDs)

A reliability block diagram (RBD) is a graphical representation of how the components of a system are reliability-wise connected. Building RBDs in BlockSim involves adding blocks to a diagram and then arranging and connecting the blocks so that they represent the reliability-wise configuration of a system or process. Each block represents a component of the overall system or process that is represented by the RBD. You can define individual blocks with the reliability and other characteristics of the components they represent, and also customize the appearance of each block to enhance the presentation of your diagrams.

Note: An RBD is used to analyze the reliability of a system with a fixed configuration. In some cases, however, a single, fixed configuration does not accurately represent the system's performance over the course of a mission. Aspects of the system may change over time, including the system's reliability configuration; the resources available to the system; or the failure, maintenance and/or throughput properties of its individual components. A phase diagram can be used to represent/analyze such a system.

RBD Block Types

In order to provide the flexibility required to create RBDs that model actual systems as realistically as possible, there are several different types of blocks that you can use in your diagrams. For the different types of blocks, the appearance and options available in the Block Properties window will vary. This section is intended to help you identify the basic types of blocks found in RBDs.

Note: The shapes, colors and locations shown here represent the default settings. For information on modifying appearance settings, see Diagram Skins and Appearance Settings.
### Chapter 6: BlockSim RBDs and Fault Trees

<table>
<thead>
<tr>
<th><strong>Standard Block</strong></th>
<th>Standard blocks represent some functional portion of the system, such as a component, subsystem, assembly or failure mode.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Node Block</strong></td>
<td>A block that is circular in shape is a node block. Node blocks allow you to construct $k$-out-of-$n$ configurations. In these configurations, a specified number of paths must reach the node without failing in order for the system to be successful.</td>
</tr>
<tr>
<td><strong>Subdiagram Block</strong></td>
<td>A block that is in the shape of a folder indicates that the block represents an existing diagram.</td>
</tr>
<tr>
<td><strong>Standby Container/Contained Standby Blocks</strong></td>
<td>A block that is gray and has an opening in its border is a standby container, which allows you to identify blocks that operate in a standby configuration. The blocks inside the container describe the characteristics of the items that operate together in the standby configuration.</td>
</tr>
<tr>
<td><strong>Load Sharing Container/Contained Load Sharing Blocks</strong></td>
<td>A block that is gray and has a solid border is a load sharing container, which allows you to identify blocks that operate in a load sharing configuration. The blocks inside the container describe the characteristics of the items that operate together in the load sharing configuration.</td>
</tr>
</tbody>
</table>

For standard blocks, there are several status indicators that may appear on the block. Although each status is presented individually for demonstration purposes, a single block can be defined with more than one type of status.
### Inactive Block

An X through the block indicates that the block is inactive for reliability calculations (i.e., set to "off"). This is done by selecting the **Set block as failed** option in the Block Properties window or by selecting the block in the diagram and choosing **[Diagram/Fault Tree] > Settings > Set Block as Failed**. This option can be used for "what-if" analyses to investigate the impact of a block on system metrics such as reliability, availability, throughput, etc.

### Block Belongs to a Maintenance Group

A red circle in the upper left corner indicates that the block belongs to a maintenance group. A maintenance group is a set of blocks where some event within the group can trigger either maintenance or state changes for one or more blocks, either within the group or outside of it. Clicking the indicator opens the **Maintenance Group Manager**.

You can change the size of the indicator via the relevant Block Corner Indicators page of the **Diagram Style window**. You can change the color used for each maintenance group via the Maintenance Group Manager.

### Mirrored Block

A gray box in the lower left corner indicates that the block is a mirrored block. The mirror group to which it belongs is displayed beside the box. All blocks in the mirror group represent the same component in more than one location. Clicking the indicator opens the **Mirror Group Manager**.

You can change the size of the indicator and the appearance of the text via the relevant Block Corner Indicators pages of the **Diagram Style window**. You can change the color used for each mirror group via the Mirror Group Manager.
A blue diamond in the lower right corner indicates that the block has state change triggers enabled. State change triggers allow you to specify events that will activate and/or deactivate the block during simulation.

You can change the size and color of the indicator via the relevant Block Corner Indicators page of the Diagram Style window.

A block that appears to be a stack of blocks indicates that the block represents more than one block with the same properties. These blocks can be configured in series or parallel. The settings are specified by selecting the **Represents multiple blocks** option in the Block Properties window.

---

### RBD Configurations and Constraints

BlockSim allows you to create an extensive array of RBD configurations. These can be as simple as units arranged in a pure series or parallel configuration. There can also be systems of combined series/parallel configurations or "complex" systems that cannot be decomposed into groups of series and parallel configurations. The supported configurations include:

- **Series configurations, parallel configurations and combined (series and parallel) configurations**.
- **Complex configurations**.
- **k-out-of-n parallel configurations**.
- **Configurations with inherited subdiagrams**.
- **Standby redundancy configurations**.
- **Load sharing configurations**.
- **Configurations with mirrored blocks**.

In order to perform analysis, all RBDs created in BlockSim must conform to the following constraints:

- A diagram must contain at least one block.
- If a diagram contains more than one block, all blocks in the diagram must be joined with connectors.
• Diagrams must contain a single starting block and a single ending block, as shown next.

![Diagram](image1)

**Analysis is impossible**

If a diagram consists of only one block, that block represents both the starting and ending block. Starting and/or ending blocks that possess no reliability or maintenance characteristics can be defined by making sure no URD is assigned in the Block Properties window. This indicates that the block cannot fail and that the reliability of the component at all times is considered to be 1 or 100%.

• Circular references, as shown below, are not allowed. There must be a clear path towards the end of the RBD and the RBD cannot loop back on itself.

![Diagram](image2)

**Analysis is impossible**

• A standby container must contain at least one active block and one standby block.

• A load sharing container must contain at least one block.
Standard Blocks and Basic Configurations

Standard blocks represent some functional portion of the system, such as a component, subsystem, assembly or failure mode. Using only standard blocks, you can define series configurations, parallel configurations and combinations of the two, as well as complex configurations.

In a **series configuration**, all items must work for the system to work. In the RBD shown next, the system fails if either Block A, Block B or Block C fails.

![Series Configuration Diagram]

The ReliaWiki resource portal has more information on series configurations at: [http://www.reliawiki.org/index.php/RBDs_and_Analytical_System_Reliability](http://www.reliawiki.org/index.php/RBDs_and_Analytical_System_Reliability).

In a **parallel configuration**, items are considered to be redundant. In the RBD shown next, the system will continue to function if either Block D or Block B fails.

![Parallel Configuration Diagram]

The ReliaWiki resource portal has more information on parallel configurations at: [http://www.reliawiki.org/index.php/RBDs_and_Analytical_System_Reliability](http://www.reliawiki.org/index.php/RBDs_and_Analytical_System_Reliability).

You can combine series and parallel configurations in a single RBD, as shown next.
You can also use BlockSim to create "complex" block diagrams. **Complex configurations** cannot be expressed as a simple combination of series and/or parallel configurations and thus require a more advanced analytical treatment. A complex reliability block diagram is shown next.

Multiple analytical methods exist for obtaining the reliability of a complex system, such as:

- Bayes' theorem method
- Boolean truth table method
- Probability maps method
- Logic diagrams method
- Decomposition method
- Event space method
- Path-tracing method
Solution using these methods is cumbersome and time consuming. BlockSim uses a proprietary method that employs a combination of several of these methods, saving the user time and effort.

The ReliaWiki resource portal has more information on complex configurations at: http://www.reliawiki.org/index.php/RBDs_and_Analytical_System_Reliability.

The properties available for configuring a standard block will vary depending on whether it is in an analytical RBD or a simulation RBD. In addition to the common block properties, you will need to describe how the block behaves.

An analytical diagram does not take into account any repair or maintenance information, so you can configure a standard block in this type of diagram by defining only the reliability characteristics and basic operational properties. In a simulation diagram, you can also define maintenance activities (i.e., a corrective task and/or scheduled tasks), a maintenance group and throughput information. A maintenance group is a set of blocks that can all be maintained at the same time. The throughput properties define the amount of output that can be processed by the block in a given period of time.

The Block Properties window for a standard block is divided into two areas: the Universal Reliability Definition area allows you to define the block's reliability and maintenance characteristics, while the Properties area allows you to define all remaining block properties. By default, the Properties area is on the left side of the window and the Universal Reliability Definition area is on the right side. You can click the Change Orientation icon to toggle the orientation of the areas between horizontal and vertical.

You can also display only one of the areas or both of the areas by using the following icons to move the splitter all the way to the left/top, to the center, or all the way to the right/bottom.

Reliability and maintenance characteristics are defined by assigning a universal reliability definition (URD) in the Universal Reliability Definition area. URDs are resources that can be shared among analyses. Each one includes a model (either a reliability model, a probability of failure model or an event occurrence model) and may also include a corrective task and/or scheduled tasks. When you assign a URD to a block, only those characteristics that are relevant to the block are used. Thus, you could use a URD that includes tasks for a block in either an analytical or a simulation diagram. For the block in the analytical diagram, only the model would be relevant, and all maintenance information would be ignored during analysis. For the block in the simulation diagram, the model and the tasks would be relevant, and all properties would be considered during simulation.
**Note:** Applying a model that uses a fixed probability to a block causes the block to be considered "static." A static block can be interpreted either as a block with a reliability value that is known only at a given time (but the block’s entire failure distribution is unknown) or as a block with a fixed reliability (i.e., a reliability that is constant over time). Systems can contain static blocks, time-dependent blocks or a mixture of the two.

To assign a URD to a block, you can either select an existing URD or create a new one. Click the **URD** field and then click the arrow to display the **URD wizard**. In the wizard, you can click **Select Existing URD** to display a list of the available URDs. You can also click **Create New URD** to open the **Universal Reliability Definition window**; in this window, specify the failure model and, if you are working with a simulation diagram, any associated tasks, then click **OK** to create the new URD and apply it to the block.

Once a URD has been assigned to the block, you can view and/or edit its properties from the URD wizard by clicking the **View/Edit** icon.

You can remove the URD from the block by clicking the **Remove** icon in the URD wizard.

You can also add, change or edit the components of the URD (i.e., the model, corrective task and/or scheduled tasks) directly from the **URD** area. Be aware that any changes you make here will apply everywhere that the URD is used.

If no URD is assigned to the block, you can create a new model for the block by clicking the **Model** field and then clicking the arrow. This opens the Model wizard, which allows you to define a model for the block; this has the effect of automatically creating a new URD that uses the new model and assigning it to the block.

The additional options available to configure the block, located in the **Properties** area, include:

- **Set block as failed** if selected, indicates that the block is "off" or absent from the system. An X will be displayed on the block to indicate that it is failed. The block will be considered to be failed throughout the entire analysis/simulation and no maintenance actions will be performed (i.e., any failure and maintenance properties will be ignored). This option can be used for "what-if" analyses to investigate the impact of a block on system metrics such as reliability, availability, throughput, etc. You can also set this option by selecting the block in the diagram and choosing **Diagram > Settings > Set Block as Failed**.
When this option is selected, no other properties will be available for the block; note, however, that any properties you have already specified are simply hidden because they are not relevant. The settings will reappear if you clear the **Set block as failed** option.

- **Represents multiple blocks** if selected, indicates that the block represents more than one block with the same properties. This can save time in defining and updating block properties, and also save space within the diagram.

When this option is selected, you can enter the number of components represented by the block and specify whether they are connected in series or in parallel. If they are connected in parallel, you can also specify how many of the items are required to be functioning in order for the multi block to be functioning. The images shown next provide the equivalent configurations for multi blocks representing three blocks in series, three blocks in parallel and three blocks where at least two of the three must be functioning.
**IMPORTANT:** When a block represents multiple identical blocks, although the components represented by the multi block have the same reliability, maintenance and other characteristics, they are considered separate blocks in analytical diagrams. They will behave comparably over the course of the simulation of a simulation diagram, but not identically at any given time during simulation. For instance, if one of the components fails, the others may continue to function, which can affect when maintenance is performed, costs associated with the block, etc. This is in contrast to the functionality of **mirrored blocks**. Blocks that belong to a mirror group are multiple instances of a single block. Mathematically, they are considered to be a single block in analytical diagrams. When a simulation diagram with mirrored blocks is simulated, every event associated with one block in a mirror group will also apply to all other blocks in the mirror group.

- **Current Age** defines the age of the block at the start of the analysis. This allows you to define blocks that have already accumulated age (i.e., "used" components). This field requires that you specify a time unit.

- **Duty Cycle** allows you to model situations where the actual usage of a block during system operation is not identical to the usage for which you have data (either from testing or from the field). This can include situations where the item:
  - Does not operate continuously (e.g., a DVD drive that was tested in continuous operation, but in actual use within a computer accumulates only 18 minutes of usage for every hour the computer operates).
  - Is subjected to loads that are greater than or less than the rated loads (e.g., a motor that is rated to operate at 1,000 rpm but is being used at 800 rpm).
  - Is affected by changes in environmental stress (e.g., a laptop computer that is typically used indoors at room temperature, but is being used outdoors in tropical conditions).

In these cases, continuous operation at the rated load is considered to be a duty cycle of 1. Any other level of usage is expressed as a percentage of the rated load value or operating time. For example, consider the DVD drive mentioned above; its duty cycle value would be 18 min / 60 min = 0.3. A duty cycle value higher than 1 indicates a load in excess of the rated value.


- **Consequential Costs** allows you to choose or create models to represent costs that are always associated with the block. **Cost per Failure** uses a cost model, and **Downtime Rate** uses a cost per unit time model. If no models are assigned, it is assumed that there are no additional costs.
The following additional options are available only when you are working with a simulation diagram:

- **Operates even if system is down** indicates that the block continues to operate even if the system is down (and will continue to accumulate age).

- **Belongs to a maintenance group** if selected, you can specify the maintenance group that the block belongs to.

- **Enable state change triggers (SCT)** allows you to specify the starting state of the block (i.e., off or on) and its state upon repair, then specify events that will activate and/or deactivate the block during simulation. You can choose to activate or deactivate the block when items in specified maintenance groups go down or are restored. The current block does not need to be part of the specified maintenance group to use this functionality. This allows you to model a cold standby configuration (i.e., one where the component cannot fail when in standby) without using a standby container, which may be useful if you are using a parallel or complex configuration, as blocks can be connected only in series in standby containers.

To add a state change trigger, click the **Add** icon in the **Add a State Change Trigger** field. The **State Change Trigger window** will appear, allowing you to define the trigger. Each trigger that you add will then be displayed in the Block Properties window. To edit an existing state change trigger, click the **Edit** icon for the state change trigger to open the State Change Trigger window.

- **Throughput properties** define the amount of output that can be processed by the block in a given period of time.

Once the block is configured, you can click the **Optimum Replacement** icon in the **Properties** area to open the **Optimum Replacement window** for the current block; this window allows you to determine the most cost-effective time to replace the component based on costs for planned (i.e., preventive) and unplanned (i.e., corrective) replacement.

### State Change Triggers

State change triggers (SCT) allow you to specify the starting state of a block (i.e., off or on) and its state upon repair, then specify events that will activate and/or deactivate the block during simulation. This allows you to model a cold standby configuration (i.e., one where the component cannot fail when in standby) without using a standby container, which may be useful if you are using a parallel or complex configuration, as blocks can be connected only in series in standby containers. State change triggers are available for standard blocks in simulation RBDs and for events in simulation fault trees.
The State Change Trigger window is where you specify the events that will activate and/or deactivate the block. It is accessed from the Block Properties window by clicking the **Add** icon in the **Add a State Change Trigger** field or the **Edit** icon for an existing state change trigger.

The state change trigger can either activate or deactivate the block when items in specified maintenance groups go down or are restored. To define the state change trigger, specify the triggering event (i.e., an item goes down or an item is restored), the state change (i.e., the block is activated or deactivated) and the maintenance group(s) in which the triggering event must happen in order to trigger the state change.

The current block does not need to be part of the specified maintenance group(s) to use this functionality.

**Tip:** Blocks that have state change triggers enabled have a diamond at the lower right corner of the block. You can change the size and color of the indicator via the relevant Block Corner Indicators page of the **Diagram Style window**.

---

**Node Blocks and k-out-of-n Configurations**

Node blocks allow you to specify a form of redundancy known as *k-out-of-n* redundancy. A *k-out-of-n* node can have *n* paths leading into it and requires that *k* out of *n* paths must function for the system to function.

The configuration in the figure shown next displays a *k-out-of-n* configuration where either Block B, Block C or Block D can fail without causing system failure, but if any two of the blocks fail, the system will fail.
The figure shown next displays another \( k\text{-out-of-}n \) node, this time used in a complex configuration. If more than three of the five blocks (blocks C, E, F, G and H) leading to the node fail, the system will fail.

To configure a node block, in addition to the common block properties, you will need to specify the number of paths that must reach the node in the **Number of Paths Required** field. If the required number of paths does not succeed, then the node is considered to be failed.
For node blocks in simulation diagrams, you can also specify throughput properties, which define the amount of output that can be processed by the block in a given period of time.

**Subdiagrams**

Subdiagram blocks represent other diagrams within the project. Using subdiagram blocks allows you to maintain separate diagrams for portions of a system and to incorporate those diagrams as components of another diagram. This also allows you to generate and analyze extremely complex diagrams representing many subsystems, subsubsystems, etc.

*Note:* Double-clicking a subdiagram block will open the subdiagram that the block is based on. Open the Block Properties window for a subdiagram block by selecting the block and choosing the command on the ribbon or pressing **CTRL+E**. To get a quick preview of the subdiagram without actually opening it, select the block and either press **SPACE** or choose [Diagram/Fault Tree/Phase] > Selection > Quick View.

**Subdiagram Block vs. Using a Fitted Model**

It is appropriate to use a subdiagram block when you want to take into consideration all properties of all individual blocks in the subdiagram. If you are interested only in the outcome of the subdiagram as a whole (i.e., its fitted distribution and/or system reliability equation), you can create a URD that uses the subdiagram's published results as its failure model; you can then represent the subdiagram within the current diagram by creating a standard block using that URD. You might do this:
Chapter 6: BlockSim RBDs and Fault Trees

- When the subdiagram is a lowest replaceable unit (LRU). That is, when the subdiagram fails, the entire assembly that it represents will be replaced (e.g., a motherboard in a computer).

- In order to represent an analytical subdiagram within a simulation diagram or to represent a simulation subdiagram within an analytical diagram.

- In order to use complex diagrams inside container blocks.

- If your diagram is extremely complex, in order to streamline simulation so that it takes less time.

It is important to remember that in all of these cases, the subdiagram will be treated as an LRU and no results will be available for anything within it.

Selecting the Diagram
To configure a subdiagram block, in addition to the common block properties, you will need to specify the diagram that the subdiagram block represents. You will be prompted for this information when you add the subdiagram block. If you are working with an analytical diagram, only analytical diagrams will be shown in this list; if you are working with a simulation diagram, only simulation diagrams will be available. If the diagram that the subdiagram block will represent has not yet been created, click Create New RBD or Create New Fault Tree.

When you are viewing or editing the subdiagram properties in the Block Properties window, you can change the diagram that it represents by choosing an existing diagram from the Based on Diagram drop-down list.

Additional Properties
- **Represents multiple blocks** if selected, indicates that the block represents more than one subdiagrams with the same properties. This can save time in defining and updating block properties, and also save space within the diagram. When this option is selected, you can enter the number of subdiagrams represented by the block and specify whether they are connected in series or in parallel. If they are connected in parallel, you can also specify how many of the items are required to be functioning in order for the multi block to be functioning. (For details, refer to Standard Blocks: Represents Multiple Blocks.) In analytical diagrams, multiple subdiagram blocks cannot refer to diagrams that contain mirrored blocks.

- **A maintenance group** is a set of blocks where some event within the group can trigger either maintenance or state changes for one or more blocks, either within the group or outside of it. This property applies only in simulation diagrams.
• **A Duty Cycle** allows you to model situations where the actual usage of the assembly represented by the subdiagram during system operation is not identical to the usage for which you have data. Continuous operation at the rated load is considered to be a duty cycle of 1. Any other level of usage is expressed as a percentage of the rated load value or operating time. (For more information, see Standard Blocks: Duty Cycle.)

If a duty cycle is specified for the subdiagram block and there are also duty cycles specified for blocks within the diagram that it represents, their effects are compounded. For instance, if the subdiagram block has a duty cycle of 1.5 and one of the blocks in the diagram that it represents has a duty cycle of 0.75, the effective duty cycle for that block within the subdiagram would be 1.5 x 0.75 = 1.125.

• **Throughput properties** define the amount of output that can be processed by the block in a given period of time. This property applies only in simulation diagrams.

**Standby Configurations**

**Standby Containers**
Standby containers allow you to identify blocks or paths that operate in a standby redundancy configuration. Each path in the container consists of one or more blocks (connected in series if there is more than one block in the path); one or more of the paths in the container are active while one or more paths are dormant (i.e., standby or quiescent). The dormant paths are available to become active under specified circumstances. In BlockSim, the standby container can also be configured to represent a switch that must be triggered in order to transfer the activity to the standby path (and then back to the original active path, if the standby path later fails or if the original active path is set to be reactivated after repair). Therefore, the standby container can also have an assigned switch that describes the reliability characteristics for the switch (i.e., the probability that the switch will function properly when it is needed) and any maintenance activities that apply to the switch.

For example, suppose that a system contains two batteries but requires only one functioning battery in order for the system to succeed. At any given time, one battery operates while the other waits in a standby state. In addition, the success of the system depends on the successful switch from the active battery to the standby battery, when required. If the active battery fails and there is a successful switch from one battery to the other, then the standby battery becomes active and the system continues to operate. If the switch fails, then the system fails. The system will also fail if the switch is successful but the standby battery has failed while in a standby state.

**Note:** When analyzing diagrams with containers, the analysis and throughput results are presented at the container level. In addition, optimization via allocation analysis is performed at the container level.
The figure shown next includes a standby container with three items in standby redundancy configuration where one component is active and the other two components are on standby. In this configuration, one block in the container must be operating or, because the container is part of a series configuration, the system will fail.

The container has properties that describe the way the container behaves. A block inside a container, a contained block, also has its own block properties.

To configure a standby container, in addition to the common block properties, you will need to specify the **Number of Active Paths Required**, which is the number of active paths within the container that must succeed in order for the container to succeed. If the required number of paths does not succeed, then the container is considered to be failed.

Additional options are available for the standby container, including:

- **Set block as failed** if selected, indicates that the container is failed (i.e., the block is "off" or absent from the system). An X will be displayed on the container to indicate that it is failed. The block will be considered to be failed throughout the entire analysis/simulation and no maintenance actions will be performed (i.e., any failure and maintenance properties will be ignored). This option can be used for "what-if" analyses to investigate the impact of a block on system metrics such as reliability, availability, throughput, etc. You can also set this option by selecting the block in the diagram and choosing **Diagram > Settings > Set Block as Failed**.
When this option is selected, no other properties will be available for the block; note, however, that any properties you have already specified are simply hidden because they are not relevant. The settings will reappear if you clear the Set block as failed option.

- **Adjust Numerical Convergence Settings** opens the Algorithm Setup window, which allows you to modify the parameters of the numerical integration that is used in analyzing the container, as well as to specify a level of accuracy that should be reached during calculations. This option is available only for analytical diagrams.

- The Switch field allows you to create or select a switch resource, which defines the standby container as a switch that is necessary to transfer the activity from active to standby blocks. The switch resource includes information on the reliability of the switch itself and of the switch action, any restarts and any maintenance tasks that apply to the switch.

For standby containers in simulation diagrams, you can also specify throughput properties, which define the amount of output that can be processed by the block in a given period of time.

If a standby container has more than one contained block in a standby state, you can specify the order in which the standby blocks are used. To do this, select the standby container and choose Diagram > Properties > Standby Settings > Set Standby Orders or click the Set Standby Orders icon in the Block Properties window for the standby container.

In the Standby Blocks Order window that appears, the standby blocks are displayed in the order in which they will be used. Select a block and use the up and down arrows that appear in its order number cell to move the block up and down the list. For example, in the window shown next, you would click the down arrow once to move Block 5 down one position; the result would be that Block 4 would be used first, then Block 5, then Block 3.
Contained Standby Blocks
Add a contained block to a container by selecting the container and then choosing Diagram > Blocks > Add Block.

The properties available for configuring a contained standby block will vary depending on whether it is in an analytical RBD or a simulation RBD. In addition to the common block properties, you will need to describe how the block behaves.

The first step is to assign a URD for the block when it is in an active state and one for when it is in a standby state (i.e., quiescent or dormant). As explained in the topic on standard blocks, each URD uses a failure model to describe the block’s reliability characteristics; for blocks in simulation diagrams, the corrective task and/or scheduled tasks associated with the URD are also applied to the block.

**Note:** In the case that both quiescent and active failure models are the same, the units are in a simple parallel configuration (also called a hot standby configuration). When the probability of failure of the standby component is less in the quiescent state than in the active state, that is called a warm standby configuration. Lastly, when the probability of failure of the standby component is zero in the quiescent state (i.e., the component cannot fail when in standby), that is called a cold standby configuration.

The following options may be available for contained standby blocks in both analytical and simulation diagrams:

- **Duty Cycle** allows you to model situations where the actual usage of a block during system operation is not identical to the usage for which you have data. Continuous operation at the rated load is considered to be a duty cycle of 1. Any other level of usage is expressed as a percentage of the rated load value or operating time. (For more information, see Standard Blocks: Duty Cycle.)

- **Active/Standby** allows you to specify whether the block is in an active or standby state at the beginning of the simulation.

**Tip:** You can quickly change a block’s state by selecting or clearing the Diagram > Properties > Standby Settings > Set Block to Active (Not Standby) command.

- **Consequential Costs** allows you to choose or create models to represent costs that are always associated with the block. Cost per Failure uses a cost model, and Downtime Rate uses a cost per unit time model. If no models are assigned, it is assumed that there are no additional costs.
The following options are available only for contained standby blocks in simulation diagrams:

- **Reactivate After Repair** if selected, the block will return to the active state immediately after it has been repaired. Otherwise, the block will remain in the standby state after it has been repaired and will be switched back to the active state only if and when the contained standby block that was activated in the initial switch fails. This option is available only if the active state is selected.

- **Operates even if system is down** if selected, indicates that the block continues to operate even if the system is not operating. If it is not selected, the block does not continue to accumulate age when the system is down.

In a simulation diagram, you can also assign a maintenance group for the contained standby block. A maintenance group is a set of blocks where some event within the group can trigger either maintenance or state changes for one or more blocks, either within the group or outside of it.

Once the block is configured, you can click the **Optimum Replacement** icon in the Properties area to open the Optimum Replacement window for the current block; this window allows you to determine the most cost-effective time to replace the component based on costs for planned (i.e., preventive) and unplanned (i.e., corrective) replacement.

---

**Switches**

In BlockSim, a standby container, priority AND gate or sequence enforcing gate can be configured as a switch that is necessary to transfer the activity from the active block to a standby block (and then back to the original active block, if the standby block later fails or if the original active block is set to be reactivated after repair). To do this, assign a switch resource to the container or gate. Switches are resources that can be shared among analyses and can be managed via the Resource Manager.

To assign a switch to a container or gate, you can either select an existing switch or create a new one. Click the **Switch** field and then click the arrow to display the Quick Switch Action Wizard. In the wizard, you can click **Select Existing Switch** to display a list of the available switches. You can also click **Create New Switch** to open the Switch window; in this window, define the properties of the switch, then click **OK** to create the new switch and apply it to the block.

Once a switch has been assigned to the block, you can view and/or edit its properties from the Switch Action Wizard by clicking the **View/Edit** icon.
You can remove the switch from the block by clicking the **Remove** icon in the Switch Action Wizard.

You can also add, change or edit the components of the switch (i.e., the model, corrective task, scheduled tasks and/or maintenance group) directly from the **Switch** field's subfields. Be aware that any changes you make here will apply everywhere that the switch is used.

**Switch Window**
The Switch window is divided into two areas: the **Resources** area allows you to define the switch's reliability and maintenance characteristics, while the **Properties** area allows you to define all remaining switch properties. By default, the **Properties** area is on the left side of the window and the **Resources** area is on the right side. You can click the **Change Orientation** icon to toggle the orientation of the areas between horizontal and vertical.

You can also display only one of the areas or both of the areas by using the following icons to move the splitter all the way to the left/top, to the center, or all the way to the right/bottom.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see **Default Name Formats window**). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the Synthesis resources you need for your analyses.

In the **Properties** area, the following properties are available to configure the switch:

- **Switch Action**
  - **Probability per Request** allows you to specify the probability that the switch action will succeed the first time it is needed. This also applies to the switch back to the original active block, if any.
  - **Delay Time** allows you to specify the amount of time it takes to perform the switch each time it happens. This includes the time for the first switch and any restarts, if applicable. You must specify the units used.
Chapter 6: BlockSim RBDs and Fault Trees

- **Allow Restarts** if selected, indicates that if the switch fails on the first start, there will be attempts to restart the switch. If this option is selected, you must specify the **Number of Restarts** allowed. If the switch is not successful by the last specified restart, then it is considered to be failed. In the **Switch Restart Probability** field, specify the likelihood that the switch will succeed when you attempt to restart after an initial failure. This value is specified as a decimal, where 1 indicates a 100% probability of success.

- **Switch operates even if the system is down** if selected, indicates that the switch continues to operate even if the system is not operating. If not selected, indicates that the switch will not continue to accumulate age.

- **Identifiers** contains additional identifying information that can be used to search for this resource.

- **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the record.

- **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the **Dependency Viewer**.

The **Resources** area allows you to specify the reliability and maintenance properties of the switch, including the model that represents the reliability of the switch itself (either a reliability model, a probability of failure model or an event occurrence model), any tasks that apply to the switch and the maintenance group that it is associated with, if any. The maintenance information in this area is applicable only when the switch is used in a simulation diagram. If the Switch window is accessed from within an analytical diagram, the maintenance-related fields (i.e., those pertaining to tasks and to maintenance groups) will not appear even if the switch has maintenance properties.

**Standby Configurations Without Containers**

If you need to use a parallel or complex configuration as a path within a container, you can do the following: Create a diagram that models the required path configuration and analyze or simulate the diagram, then publish the results as a model. Create a URD that uses the model. In the container, add a contained block and assign the URD that you just created to it. Note that when you do this, results for the components within the path will not be available in your final results; only the fitted model is used.
You can also model a cold standby configuration (i.e., one where the component cannot fail when in standby) without using a standby container by using the **Enable State Change Triggers** option in the Block Properties window. This option allows you to specify the starting state of the block (i.e., off or on) and then specify events that will activate and/or deactivate the block during simulation. You can choose to activate or deactivate the block when items in specified maintenance groups go down or are restored. The current block does not need to be part of the specified maintenance group to use this functionality.

### Container Algorithm Setup

Load sharing and standby redundancy configurations in BlockSim’s analytical diagrams are analyzed using numerical integration routines based on the Gaussian quadratures method. As with any numerical analysis routine, the solution error depends on the number of iterations performed, the step size chosen and related factors, plus the behavior of the underlying function. By default, BlockSim has a certain set of preset factors that it uses. In general, these defaults are sufficient for most problems. If a higher precision is required or if you want to verify the precision for the specific container, open the container block’s Block Properties window and click the **Algorithm Setup** icon in the Adjust numerical convergence settings field.

The Algorithm Setup window for a standby container is shown next, with the default settings. This window works in the same way for load sharing containers.

![Algorithm Setup Window](image)

In this case, the **Check accuracy** check box is selected, which means that when the diagram is analyzed, BlockSim will perform integrations for this container until the desired accuracy is achieved.

- The **Accuracy** field specifies the acceptable bounds for calculation results. For example, if you are considering a reliability result, allowable values would fall in the range of
Reliability(1 – accuracy) to Reliability(1 + accuracy). Thus, smaller accuracy values indicate narrower bounds (i.e., a greater precision); the trade-off is that the greater the precision, the longer the calculation will take.

- The **Baseline quadratures** field specifies the number of points to be used in the first integration.
- The **Point multiplier** field specifies the multiplier applied to the quadratures for each subsequent integration.
- The **Maximum number of iterations** field specifies the maximum number of integrations that will be performed.

In the default settings shown above, we have specified that we want results within a range of +/- 0.001. To get that, BlockSim starts with 10 quadratures (i.e., points) in the first integration. Then for the second integration, it will use 10 x 1.5 = 15 quadratures. For the third integration, it will use 15 x 1.5 = 22 quadratures. And so on, until the desired accuracy is reached, or until the maximum number of iterations (i.e., integrations) is reached, whichever comes first.

**Using the Container Integration Parameters Wizard**

Checking a container for accuracy each time it is calculated can be time-consuming. To minimize the time that analysis takes, you would aim for the number of iterations to be 1. The Container Integration Parameters Wizard can help you determine the number of quadratures you will need to achieve the desired accuracy in a single integration. You can then clear the **Check Accuracy** check box and simply use the recommended number of quadratures.

To open the Container Integration Parameters Wizard, click the **Wizard** button.

**Note:** The calculations performed in the Container Integration Parameters Wizard are dependent upon the configuration of the container. Therefore, you should have all contained blocks/dependent events created and configured before working with the container’s algorithm setup. At minimum, you must have at least two blocks in the container (or, in fault trees, at least two dependent events connected to the standby or load sharing gate) to use the Container Integration Parameters Wizard; for standby containers, at least one of the blocks must be in standby mode.

To use the Container Integration Parameters Wizard, enter all of the inputs in the **Input Parameters** area and the **Time** area.

- The input parameters work in the same way as the parameters in the Algorithm Setup window.
- The time parameters specify the time frame at which the container will be calculated. Enter the **Start time** and the **End time** for the integration, then specify the length of the intervals into which the integration will be divided in the Interval field. The shorter the interval, the greater the number of points that will be calculated during each
integration. Shorter intervals may yield greater precision, but the calculation will take longer.

Once you have entered all required inputs, click **Calculate**. The wizard will perform multiple integrations, up to the specified maximum number of iterations. During calculation, the **Calculate** button will become a **Stop** button, allowing you to abort the calculation. The following results will be returned:

- The **Suggested Parameters** area gives you the number of quadrature points that should be used to achieve the desired accuracy within a single iteration.
- In the **Results** area, the **Calculated accuracy** displays the maximum calculated accuracy value found in the final integration (i.e., at the selected number of quadratures).
- The table displays the analysis accuracy at each interval for each integration. Each row in the table gives results for a single integration, with the first column displaying the number of quadratures used and each subsequent column displaying the calculated accuracy for the given interval. The software performs this calculation for each interval in an integration, and finds the interval where the calculated accuracy exceeds the required accuracy. That interval is then used as the starting point for the next integration. When all calculated accuracy values for an integration are less than the required accuracy, the calculation ends and that number of quadratures is chosen.

The Container Integration Parameters Wizard shown next uses the default settings we have been examining for its input parameters, over a time range from 100 to 1,000 in intervals of 100 (i.e., 10 intervals).

As you can see, two integrations were performed. The first used 10 quadratures and the second used 15 quadratures. The calculations yielded an accuracy of 0.000547. The wizard indicates
that, in order to reach the desired accuracy of 0.001 in a single iteration, 15 quadratures should be used.

Click **Update** to accept the values in the **Suggested Parameters** area and apply these values to the Algorithm Setup window.

## Load Sharing Configurations

### Load Sharing Containers

Load sharing containers allow you to identify blocks that are in load sharing redundancy. This indicates that two or more blocks in the container share the responsibility for keeping the system running properly; if one of them fails, the other(s) can take on an increased "load" so the system can continue to operate. Therefore, load sharing components exhibit different failure characteristics when one or more fail.

For example, suppose that two heat dissipation devices operate in a load sharing configuration and together they are expected to provide dissipation for a temperature difference of 100 K of heat. When both units are operating, they share the load and each dissipates 50% of the heat. If one unit fails, then the load on the other unit is increased to 100% of the heat.

In the figure shown next, Blocks 1, 2 and 3 are in a load sharing container and have their own failure characteristics. If the container's properties specify that only one contained block must succeed in order for the container to succeed, then all three contained blocks must fail for the container to fail. However, as individual contained blocks fail, the failure characteristics of the remaining contained blocks change because they now have to carry a higher load to compensate for the failed ones.
The container has properties that describe the way the container behaves. A block inside a container, a contained block, also has its own block properties.

To configure a load sharing container, in addition to the common block properties, you will need to specify the **Number of Paths Required**, which is the number of active blocks/paths within the container that must succeed in order for the container to succeed. If the required number of blocks/paths does not succeed, then the container is considered to be failed. The contained blocks must be within the load sharing container, but they do not need to be connected to each other.

Additional options are available for the load sharing container, including:

- **Set block as failed** if selected, indicates that the container is failed (i.e., the block is "off" or absent from the system). An X will be displayed on the container to indicate that it is failed. The block will be considered to be failed throughout the entire analysis/simulation and no maintenance actions will be performed (i.e., any failure and maintenance properties will be ignored). This option can be used for "what-if" analyses to investigate the impact of a block on system metrics such as reliability, availability, throughput, etc. You can also set this option by selecting the block in the diagram and choosing **Diagram > Settings > Set Block as Failed**.

When this option is selected, no other properties will be available for the block; note, however, that any properties you have already specified are simply hidden because they are not relevant. The settings will reappear if you clear the **Set block as failed** option.
• Adjust Numerical Convergence Settings opens the Algorithm Setup window, which allows you to modify the parameters of the numerical integration that is used in analyzing the container, as well as to specify a level of accuracy that should be reached during calculations. This option is available only for analytical diagrams.

For load sharing containers in simulation diagrams, you can also specify throughput properties, which define the amount of output that can be processed by the block in a given period of time.

What's Changed? The load on contained load sharing blocks is calculated differently in the Synthesis version of BlockSim. Version 7 required a life-stress relationship for such configurations and based the re-calculation of load after block failure on that relationship; the Synthesis version calculates load using the weight proportionality factor as a multiplier. Because of this, if you convert a diagram that uses load sharing containers, you will need to manually configure the contained load sharing blocks after conversion.

The ReliaWiki resource portal has more information on load sharing configurations at: http://www.reliawiki.org/index.php/Time-Dependent_System_Reliability_(Analytical).

Contained Load Sharing Blocks
Add a contained block to a container by selecting the container and then choosing Diagram > Blocks > Add Block.

The properties available for configuring a contained load sharing block will vary depending on whether it is in an analytical RBD or a simulation RBD. In addition to the common block properties, you will need to describe how the block behaves.

The first step is to assign a URD for the block. As explained in the topic on standard blocks, the URD uses a failure model to describe the block's reliability characteristics; for blocks in simulation diagrams, the corrective task and/or scheduled tasks associated with the URD are also applied to the block.

What's Changed? The load on contained load sharing blocks is calculated differently in the Synthesis version of BlockSim. Version 7 required a life-stress relationship for such configurations and based the re-calculation of load after block failure on that relationship; the Synthesis version calculates load using the weight proportionality factor as a multiplier. Because of this, if you convert a diagram that uses load sharing containers, you will need to manually configure the contained load sharing blocks after conversion.

The following options may be available for contained load sharing blocks in both analytical and simulation diagrams:
• **Weight Proportionality Factor** is compared against the factors in the other blocks in the load sharing container to determine how the load will be shared. For example, if the container holds two blocks and one has a factor of 3 while the other has a factor of 9, then the first block will receive 25% of the load (3/12) and the second block will receive 75% of the load (9/12). Alternatively, if the factor for both blocks is set to 9, then both blocks will receive 50% of the load (9/18).

• **Duty Cycle** allows you to model situations where the actual usage of a block during system operation is not identical to the usage for which you have data. Continuous operation at the rated load is considered to be a duty cycle of 1. Any other level of usage is expressed as a percentage of the rated load value or operating time. (For more information, see [Standard Blocks: Duty Cycle](http://blocksim.reliasoft.com).

• **Consequential Costs** allows you to choose or create models to represent costs that are always associated with the block. **Cost per Failure** uses a cost model, and **Downtime Rate** uses a cost per unit time model. If no models are assigned, it is assumed that there are no additional costs.

When you are working with a simulation diagram, the following options are also available:

• **Operates even if system is down** indicates that the block continues to operate even if the system is not operating. If it is not selected, the block does not continue to accumulate age when the system is down.

• **Belongs to a maintenance group** if selected, you can specify the maintenance group that the block belongs to.

Once the block is configured, you can click the **Optimum Replacement** icon in the **Properties** area to open the **Optimum Replacement window** for the current block; this window allows you to determine the most cost-effective time to replace the component based on costs for planned (i.e., preventive) and unplanned (i.e., corrective) replacement.

### Fault Trees

A fault tree diagram follows a top-down structure and represents a graphical model of the pathways within a system that can lead to a foreseeable, undesirable loss event (or a failure). The pathways connect contributory events and conditions using standard logic symbols.

Fault tree diagrams consist of gates and events connected with lines. The AND and OR gates are the two most commonly used gates in a fault tree. To illustrate the use of these gates, consider two events (called *input events*) that can lead to another event (called the *output event*). If the occurrence of either input event causes the output event to occur, then these input events are
connected using an OR gate. Alternatively, if both input events must occur in order for the output event to occur, then they are connected by an AND gate. The next figure shows a simple fault tree diagram in which either A or B must occur in order for the output event to occur.

In this diagram, the two events are connected to an OR gate. If the output event is system failure and the two input events are component failures, then this fault tree indicates that the failure of A or B causes the system to fail. The RBD equivalent for this configuration is a simple series system with two blocks, as shown next.

In fault tree analysis, a fault tree diagram is always drawn top-down with the lowest item being an event.

**Relationship Between RBDs and Fault Trees**

The most fundamental difference between fault tree diagrams and RBDs is that you work in the "success space" in an RBD while you work in the "failure space" in a fault tree. In other words, the RBD looks at success combinations while the fault tree looks at failure combinations. In addition, fault trees have traditionally been used to analyze fixed probabilities (i.e., each event that composes the tree has a fixed probability of occurring) while RBDs may include time-varying distributions for the blocks' success or failure, as well as for other properties such as repair/restoration distributions.

Although the symbols and structures of the two diagram types differ, most of the logical constructions in a fault tree diagram can also be modeled with an RBD. In general, a fault tree can be easily converted to an RBD. It is generally more difficult to convert an RBD into a fault tree, especially if one allows for highly complex configurations.

In BlockSim, you can choose **Fault Tree > Conversion > Create RBD** to create a reliability block diagram that is equivalent to the current fault tree. In addition, you can create hybrid analyses by linking fault trees as subdiagrams to RBDs and vice versa.
**Fault Tree Block Types**

This section is intended to help you identify the basic types of blocks found in fault trees.

*Note: The shapes, colors and locations shown here represent the default settings. For information on modifying appearance settings, see [Diagram Skins and Appearance Settings](http://blocksim.reliasoft.com).*

<table>
<thead>
<tr>
<th>Block Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>AND</strong></td>
<td>In an AND gate, the output event occurs if all input events occur.</td>
</tr>
<tr>
<td><strong>OR</strong></td>
<td>In an OR gate, the output event occurs if at least one of the input events occurs.</td>
</tr>
<tr>
<td><strong>NOT</strong></td>
<td>In a NOT gate, the output event occurs if the input event does not occur, and vice versa. This gate performs inversion. NOT gates are available only in analytical fault trees.</td>
</tr>
<tr>
<td><strong>NAND</strong></td>
<td>In a NAND gate, the output event occurs if any one of the input events does not occur. NAND gates are available only in analytical fault trees.</td>
</tr>
<tr>
<td><strong>NOR</strong></td>
<td>In a NOR gate, the output event occurs only if none of the input events occur. NOR gates are available only in analytical fault trees.</td>
</tr>
<tr>
<td><strong>Voting</strong></td>
<td>In a Voting OR gate, the output event occurs if some quantity (k) or more of the input events occur. The voting gate is visually distinguished from the OR gate by diagonal lines and the (k/n) value displayed on it.</td>
</tr>
<tr>
<td><strong>Inhibit</strong></td>
<td>In an Inhibit gate, the output event occurs if all input events occur and an additional conditional event occurs.</td>
</tr>
</tbody>
</table>
### Standby Gate
A standby gate allows you to identify events that operate in a standby configuration. Events that are below a standby gate are **dependent events**, which describe the characteristics of the items that operate together in the standby configuration.

### Load Sharing Gate
A load sharing gate allows you to identify events that operate in a load sharing configuration. Events that are below a load sharing gate are dependent events, which describe characteristics of the items that operate together in the load sharing configuration.

### Priority AND Gate
In a priority AND (PAND) gate, the output event occurs if all input events occur in a specific sequence.

### Sequence Enforcing Gate
In a sequence enforcing (SEQ) gate, events are constrained to occur in a specified sequence and the output event occurs if all input events occur in that specified sequence.

### Basic Event

### Undeveloped Event
Events are simply representations of some occurrence, typically a failure or error.

### Trigger Event
Different shapes are used to represent different types of events. These shapes convey additional visual information for the analysis but all event types are handled in the same way during analysis or simulation. For information on how these event types are often used, see the topic on **fault tree events**.

### Resultant Event

### Conditional Event

### Subdiagram
A block that is in the shape of a folder indicates that the block represents an existing diagram. Subdiagrams can be used in fault trees in the same way they are used in RBDs.
For event blocks, there are several status indicators that may appear on the block. Although each status is presented individually for demonstration purposes, a single block can be defined with more than one type of status.

<table>
<thead>
<tr>
<th>Status Indicator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Inactive Block" /></td>
<td>An X through the block indicates that the block is inactive for reliability calculations (i.e., set to &quot;off&quot;). This is done by selecting the <strong>Set block as failed</strong> option in the Block Properties window or by selecting the block in the diagram and choosing [Diagram/Fault Tree] &gt; <strong>Settings</strong> &gt; <strong>Set Block as Failed</strong>. This option can be used for &quot;what-if&quot; analyses to investigate the impact of a block on system metrics such as reliability, availability, throughput, etc.</td>
</tr>
<tr>
<td><img src="image" alt="Block Belongs to a Maintenance Group" /></td>
<td>A red circle in the upper left corner indicates that the block belongs to a maintenance group. A maintenance group is a set of blocks where some event within the group can trigger either maintenance or state changes for one or more blocks, either within the group or outside of it. Clicking the indicator opens the <strong>Maintenance Group Manager</strong>. You can change the size of the indicator via the relevant Block Corner Indicators page of the Diagram Style window. You can change the color used for each maintenance group via the Maintenance Group Manager.</td>
</tr>
<tr>
<td><img src="image" alt="Mirrored Block" /></td>
<td>A gray box in the lower left corner indicates that the block is a mirrored block. The mirror group to which it belongs is displayed beside the box. All blocks in the mirror group represent the same component in more than one location. Clicking the indicator opens the <strong>Mirror Group Manager</strong>. You can change the size of the indicator and the appearance of the text via the relevant Block Corner Indicators pages of the Diagram Style window. You can change the color used for each mirror group via the Mirror Group Manager.</td>
</tr>
</tbody>
</table>
A blue diamond in the lower right corner indicates that the block has state change triggers enabled. State change triggers allow you to specify events that will activate and/or deactivate the block during simulation.

You can change the size and color of the indicator via the relevant Block Corner Indicators page of the Diagram Style window.

**Fault Tree Analysis Constraints**

In order to permit analysis, all fault tree diagrams created in BlockSim must conform to the following constraints:

- A diagram must contain a top gate and at least one event.
- All blocks in the diagram must be connected.
- An event can have only one output event, and no input events or gates.
- Additional gates are not allowed below a load sharing gate or standby gate.
- The inputs to negative gates (i.e., NOT, NAND and NOR gates) must be fixed probabilities, or evaluate to fixed probabilities; this is checked at analysis, and any input that evaluates to a time-varying model will result in an error.

**Fault Tree Gates**

**AND Gates**

AND gates allow you to represent a scenario in which the output event occurs if all input events occur. In system reliability, this implies that both components must fail (input) in order for the system to fail (output). In a reliability block diagram, this is equivalent to a simple parallel configuration.

The next two figures show both the fault tree diagram and reliability block diagram representation of a system with two components, A and B, in which the system fails if both A and B fail. In a fault tree, this is modeled using the AND gate.
Chapter 6: BlockSim RBDs and Fault Trees

In an RBD, it is a parallel configuration.

To configure an AND gate, only the **common block properties** are available. No further configuration of the gate is necessary.

**OR Gates**

OR gates allow you to represent a scenario in which the output event occurs if at least one of the input events occurs. In system reliability, this implies that if any component fails (input event), the system will fail (output event). In a reliability block diagram, this is equivalent to a series configuration.

The next two figures show both the fault tree diagram and reliability block diagram representation of a system with three components, A, B and C, in which the system fails if A, B or C fails. In a fault tree, this is modeled using the OR gate.
Chapter 6: BlockSim RBDs and Fault Trees

In an RBD, it is a series configuration.

```
  A -- B -- C
```

To configure an OR gate, only the common block properties are available. No further configuration of the gate is necessary.

**NOT Gates**
The NOT gate functions as an inverter; the output event is the inverse of the input event. Thus, in cases where you are dealing with true/false values, a false input event will lead to a true output event, and vice versa (i.e., the output occurs when the input event does not occur, and vice versa).

```
   TRUE
     \  / NOT
      \//      FALSE
```

In cases dealing with probabilities and/or reliability calculations, the output is equal to 1-input.

NOT gates are available only in analytical fault trees. There is no equivalent configuration in reliability block diagrams. The inputs to a NOT gate must be fixed probabilities, or evaluate to fixed probabilities; this is checked at analysis, and any input that evaluates to a time-varying model will result in an error.

To configure a NOT gate, only the common block properties are available. No further configuration of the gate is necessary.

**NAND Gates**
A NAND gate has a true output only if all input events are false; it has a false output event when any input event is true. In other words, if any of the input events occurs, then the output event will not occur. This is logically equivalent to using an AND gate followed by a NOT gate.
NAND gates are available only in analytical fault trees. There is no equivalent configuration in reliability block diagrams. The inputs to a NOT gate must be fixed probabilities, or evaluate to fixed probabilities; this is checked at analysis, and any input that evaluates to a time-varying model will result in an error.

To configure a NAND gate, only the common block properties are available. No further configuration of the gate is necessary.

**NOR Gates**

A NOR gate has a true output event when all input events are false. In other words, if none of the input events occur, then the output event will occur. This is logically equivalent to using an OR gate followed by a NOT gate.

NOR gates are available only in analytical fault trees. There is no equivalent configuration in reliability block diagrams. The inputs to a NOT gate must be fixed probabilities, or evaluate to fixed probabilities; this is checked at analysis, and any input that evaluates to a time-varying model will result in an error.

To configure a NOR gate, only the common block properties are available. No further configuration of the gate is necessary.
Voting Gates
Voting gates allow you to represent a scenario in which the output event occurs if some quantity \((k)\) or more of the input events occur. In system reliability, this implies that if any \(k\)-\emph{out-of-}n components fail (input events), the system will fail (output event). In a reliability block diagram, this is similar to a \(k\)-\emph{out-of-}n parallel configuration. That is, a fault tree looks at the \(k\)-\emph{out-of-}n failures for the system failure while an RBD looks at the \(k\)-\emph{out-of-}n successes for system success.

The next two figures show both the fault tree diagram and reliability block diagram representation of a system with four components, A, B, C and D, in which the system fails if any two of the components fail. In a fault tree, this is modeled using a voting gate with a vote number of 2.

This is represented by the RBD shown next. In this configuration, the system will not fail if three out of four components are operating, but will fail if more than one fails.

To configure a voting gate, in addition to the common block properties, you will need to use the **Vote number** field to specify the number of input events required to trigger the output event.
Inhibit Gates

Inhibit gates allow you to represent a scenario in which the output event occurs if all input events occur and an additional conditional event (typically an event external to the configuration represented by the fault tree) also occurs. An inhibit gate is basically an AND gate with an additional event. An inhibit gate does not really provide any additional modeling capabilities, but is used to illustrate the fact that an additional event must also occur.

The next figures show fault tree diagram representations of a system in which events A and B must occur as well as a third event, C (the "conditional event"), in order for the system to fail. Traditional fault tree diagrams have the conditional event drawn to the side and the AND gate drawn as a hexagon, as shown next.

![Inhibit Gate Diagram](image)

The following figure uses an AND gate with three events, A, B and C. Note that analytically, this representation does not differ from the first figure.

![AND Gate Diagram](image)

The next figure shows the reliability block diagram representation of the previous fault tree diagrams.
To configure an inhibit gate, in addition to the common block properties, you will need to specify the conditional event. The Conditional event field provides a drop-down list that contains all of the events that are connected to the inhibit gate. You can select which of the events is the additional conditional event (typically an event external to the configuration represented by the fault tree). When you specify the conditional event, it will automatically be moved to the side of the inhibit gate, as shown in the first configuration depicted above.

**Standby Gates**

Standby gates in fault trees behave just like standby containers in RBDs. The blocks connected to a standby gate are called dependent events and are similar to contained standby blocks in an RBD in that one or more of the dependent events are active while one or more are dormant (i.e., standby or quiescent). Also, just like standby containers, standby gates act as switches that can fail and define the number of active blocks whose failures would cause system failure (or the active vote number required). Additional gates are not allowed below a standby gate.

The next two figures show both the fault tree diagram and reliability block diagram representation of a system with two units, A and B, in a standby configuration where unit A is active and unit B is in a standby state.
To configure a standby gate, in addition to the common block properties, you will need to specify the Active Vote Number, which is the number of events leading to the gate that must succeed in order for the gate to succeed. If the required number of events does not succeed, then the gate is considered to be failed.

Additional options are available for the standby gate, including:

- **Set block as failed** if selected, indicates that the gate is failed (i.e., the block is "off" or absent from the system). An X will be displayed on the block to indicate that it is failed. The block will be considered to be failed throughout the entire analysis/simulation and no maintenance actions will be performed (i.e., any failure and maintenance properties will be ignored). This option can be used for "what-if" analyses to investigate the impact of a block on system metrics such as reliability, availability, throughput, etc. You can also set this option by selecting the block in the diagram and choosing **Fault Tree > Settings > Set Block as Failed**.

When this option is selected, no other properties will be available for the block; note, however, that any properties you have already specified are simply hidden because they are not relevant. The settings will reappear if you clear the **Set block as failed** option.

- **Adjust numerical convergence settings** opens the Algorithm Setup window, which allows you to modify the parameters of the numerical integration that is used in analyzing the gate, as well as to specify a level of accuracy that should be reached during calculations. This option is available only for analytical diagrams.

- The **Switch** field allows you to create or select a switch resource, which defines the standby gate as a switch that is necessary to transfer the activity from active to standby blocks. The switch resource includes information on the reliability of the switch itself and of the switch action, any restarts and any maintenance tasks that apply to the switch.

If a standby gate has more than one dependent event in a standby state, you can specify the order in which the standby events are used. To do this, select the standby gate and choose **Fault Tree > Properties > Standby Settings > Set Standby Orders** or click the **Set Standby Orders** icon in the Block Properties window for the standby gate.
In the Standby Blocks Order window that appears, the standby events are displayed in the order in which they will be used. Select an event and use the up and down arrows that appear in its order number cell to move the event up and down the list. For example, in the window shown next, you would click the down arrow once to move Event 5 down one position; the result would be that Event 4 would be used first, then Event 5, then Event 3.

![Standby Blocks Order Window](image)

**Load Sharing Gates**

Load sharing gates behave just like load sharing containers in that they define the load and the number of paths required (\(k\)-out-of-\(n\) vote). The blocks connected to a load sharing gate are called **dependent events** and are similar to **contained load sharing blocks** in an RBD. Additional gates are not allowed below a load sharing gate.

The next two figures show a fault tree diagram using a load sharing gate and the equivalent reliability block diagram. To understand these diagrams, remember that the fault tree looks at failure combinations while the RBD looks at success combinations. Thus, the fault tree shows a system that will fail if component A fails, component C fails or three out of the three B components fail.
In the case of the RBD, the system will succeed if component A functions, at least one of the three B components functions and component C functions.

To configure a load sharing gate, in addition to the common block properties, you will need to specify the **Vote number**, which is the number of events that lead to the gate that must succeed in order for the gate to succeed. If the number of events does not succeed, then the gate is considered to be failed.

Additional options are available for the load sharing container, including:

- **Set block as failed** if selected, indicates that the gate is failed (i.e., the block is "off" or absent from the system). An X will be displayed on the block to indicate that it is failed. The block will be considered to be failed throughout the entire analysis/simulation and no maintenance actions will be performed (i.e., any failure and maintenance properties will be ignored). This option can be used for "what-if" analyses to investigate the impact of a block on system metrics such as reliability, availability, throughput, etc. You can also...
set this option by selecting the block in the diagram and choosing **Fault Tree > Settings > Set Block as Failed**.

When this option is selected, no other properties will be available for the block; note, however, that any properties you have already specified are simply hidden because they are not relevant. The settings will reappear if you clear the **Set block as failed** option.

- **Adjust numerical convergence settings** opens the **Algorithm Setup window**, which allows you to modify the parameters of the numerical integration that is used in analyzing the gate, as well as to specify a level of accuracy that should be reached during calculations. This option is available only for analytical diagrams.

**Priority AND (PAND) Gates**

With a priority AND (PAND) gate, the output event occurs if all input events occur in a specific sequence. This differs from the **sequence enforcing gate** in the fact that the input events can occur out of sequence (i.e., they are not constrained to occur in a specific sequence), but the output event only occurs if the sequence is followed. This would be equivalent to an RBD configuration using a standby container where the standby units have a quiescent failure distribution (most often the same as the active failure distribution) and/or there is a probability of failure for the switch. Note that it is most common for the switch to be considered 100% reliable, which is the default configuration in BlockSim.

To illustrate this, consider the case of two motors in a standby configuration with motor A being the primary motor and motor B in standby. If motor A fails, then the switch (which can also fail) activates motor B. Thus, the system will fail if motor A fails and the switch fails to switch, or if the switch succeeds but motor B fails subsequent to the switching action. In this scenario, the events must occur in the order noted; however, it is possible for the switch or motor B to fail (in a quiescent mode) without causing a system failure, if A never fails.

The blocks connected to a priority AND gate are called **dependent events** and are similar to **contained standby blocks** in an RBD in that one or more of the dependent events are active while one or more are dormant (i.e., standby or quiescent). Also, just like standby containers, priority AND gates act as switches that can fail and define the number of active blocks whose failures would cause system failure (or the active vote number required). Additional gates are not allowed below a sequence enforcing gate.

To configure a priority AND gate, in addition to the **common block properties**, you will need to specify the **Active vote number**, which is the number of events leading to the gate that must succeed in order for the gate to succeed. If the required number of events does not succeed, then the gate is considered to be failed.
Additional options are available for the priority AND gate, including:

- **Set block as failed** if selected, indicates that the gate is failed (i.e., the block is "off" or absent from the system). An X will be displayed on the block to indicate that it is failed. The block will be considered to be failed throughout the entire analysis/simulation and no maintenance actions will be performed (i.e., any failure and maintenance properties will be ignored). This option can be used for "what-if" analyses to investigate the impact of a block on system metrics such as reliability, availability, throughput, etc. You can also set this option by selecting the block in the diagram and choosing **Fault Tree > Settings > Set Block as Failed**.

  When this option is selected, no other properties will be available for the block; note, however, that any properties you have already specified are simply hidden because they are not relevant. The settings will reappear if you clear the **Set block as failed** option.

- **The Switch** field allows you to create or select a **switch** resource, which defines the standby gate as a switch that is necessary to transfer the activity from active to standby blocks. The switch resource includes information on the reliability of the switch itself and of the switch action, any restarts and any maintenance tasks that apply to the switch.

  If a priority AND gate has more than one dependent event in a standby state, you can specify the order in which the standby events are used. To do this, select the gate and choose **Fault Tree > Properties > Standby Settings > Set Standby Orders** or click the **Set Standby Orders** icon in the Block Properties window for the gate.

  In the Standby Blocks Order window that appears, the standby events are displayed in the order in which they will be used. Select an event and use the up and down arrows that appear in its order number cell to move the event up and down the list. For example, in the window shown next, you would click the down arrow once to move Event 5 down one position; the result would be that Event 4 would be used first, then Event 5, then Event 3.
Sequence Enforcing (SEQ) Gates

A sequence enforcing (SEQ) gate indicates that component failures can occur only in the order specified by its input events. It is a variation of an AND gate in which each item must happen in sequence. In other words, events are constrained to occur in a specific sequence and the output event occurs if all input events occur in that specified sequence. This is identical to a cold standby configuration (i.e., \( k \) units in standby with no quiescent failure distribution and no switch failure probability).

The blocks connected to a sequence enforcing gate are called dependent events and are similar to contained standby blocks in an RBD in that one or more of the dependent events are active while one or more are dormant (i.e., standby or quiescent). Also, just like standby containers, sequence enforcing gates act as switches that can fail and define the number of active blocks whose failures would cause system failure (or the active vote number required). Additional gates are not allowed below a sequence enforcing gate.

To configure a sequence enforcing gate, in addition to the common block properties, you will need to specify the Active vote number, which is the number of events leading to the gate that must succeed in order for the gate to succeed. If the required number of events does not succeed, then the gate is considered to be failed.

Additional options are available for the sequence enforcing gate, including:

- **Set block as failed** if selected, indicates that the gate is failed (i.e., the block is "off" or absent from the system). An X will be displayed on the block to indicate that it is failed. The block will be considered to be failed throughout the entire analysis/simulation and no maintenance actions will be performed (i.e., any failure and maintenance properties will be ignored). This option can be used for "what-if" analyses to investigate the impact
of a block on system metrics such as reliability, availability, throughput, etc. You can also set this option by selecting the block in the diagram and choosing Fault Tree > Settings > Set Block as Failed.

When this option is selected, no other properties will be available for the block; note, however, that any properties you have already specified are simply hidden because they are not relevant. The settings will reappear if you clear the Set block as failed option.

- The Switch field allows you to create or select a switch resource, which defines the standby gate as a switch that is necessary to transfer the activity from active to standby blocks. The switch resource includes information on the reliability of the switch itself and of the switch action, any restarts and any maintenance tasks that apply to the switch.

If a sequence enforcing gate has more than one dependent event in a standby state, you can specify the order in which the standby events are used. To do this, select the gate and choose Fault Tree > Properties > Standby Settings > Set Standby Orders or click the Set Standby Orders icon in the Block Properties window for the gate.

In the Standby Blocks Order window that appears, the standby events are displayed in the order in which they will be used. Select an event and use the up and down arrows that appear in its order number cell to move the event up and down the list. For example, in the window shown next, you would click the down arrow once to move Event 5 down one position; the result would be that Event 4 would be used first, then Event 5, then Event 3.
Fault Tree Events

In traditional fault trees, different shapes are used to represent different types of events. These shapes convey additional visual information for the analysis. However, unlike gates, each type of event in a fault tree is treated the same way analytically. Thus, BlockSim does not distinguish between event types during analysis or simulation; the types are purely informational.

In BlockSim, all events can be assigned properties via URDs, just like blocks in reliability block diagrams. This is an enhancement to traditional fault tree events, which generally include only a fixed probability of occurrence and/or a constant failure rate.

BlockSim provides the following event blocks to fit the conventions that are followed in most traditional fault trees. It should be noted that the analysis method is the same for all events; therefore, if you wish to include additional event shapes that are not available, you can use the Block Style window to change the appearance of a block to illustrate a different type of event.

<table>
<thead>
<tr>
<th>Event Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Event</td>
<td>A basic event (or failure event) is identical to a standard block in a reliability block diagram. Traditionally, a basic event is represented by a circle.</td>
</tr>
<tr>
<td>Undeveloped Event</td>
<td>The diamond representation indicates that the event could have been developed further (i.e., expanded into a separate fault tree), but that it was chosen not to do so for the analysis.</td>
</tr>
<tr>
<td>Trigger Event</td>
<td>A trigger event is an event that can be set to occur or not occur (i.e., it usually has a fixed probability of 0 or 1). It is usually used to turn paths on or off or to make paths of a tree functional or non-functional. Furthermore, the terms failed house and working house have been used to signify probabilities of 0 and 1, respectively. In BlockSim, a trigger event has the same properties as a basic event. To use the block to turn the path off, select the Set block as failed option in the Block Properties window. You can also set this option by selecting the block in the diagram and choosing Fault Tree &gt; Settings &gt; Set Block as Failed. To use the block to turn the path on, make sure no URD is assigned; this means that the block cannot fail.</td>
</tr>
</tbody>
</table>
Chapter 6: BlockSim RBDs and Fault Trees

<table>
<thead>
<tr>
<th>Event Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resultant Event</td>
<td>A resultant event is represented by a square and specifies a result in a fault tree diagram.</td>
</tr>
<tr>
<td>Conditional Event</td>
<td>A conditional event is represented by a rounded square and specifies a condition in a fault tree diagram (i.e., an event, possibly external to the configuration represented by the fault tree, that must take place for the gate to succeed). It can be applied to any gate. For example, this symbol would be appropriate to use for the event that is specified in the <strong>Conditional Event</strong> drop-down list in the Block Properties window for an inhibit gate.</td>
</tr>
<tr>
<td>Subdiagram</td>
<td>A block that is in the shape of a folder indicates that the block represents an existing diagram. Subdiagrams can be used in fault trees in the same way they are used in RBDs.</td>
</tr>
</tbody>
</table>

All events have the same properties available for configuration, with the exception of dependent events. In addition to the common block properties, you will need to describe how the event behaves. These properties are the same as those available for configuring standard blocks in RBDs except that you cannot define throughput properties, as throughput is not calculated in fault trees.

An event can have only one output event, and no input events or gates.

### Dependent Events

A dependent event is any event that leads to a standby, load sharing, priority AND or sequence enforcing gate. A dependent event has the appearance of the original event. For example, if you connect a conditional event to a load sharing gate, it will have the appearance of a conditional event. The only change will be the properties that are available in the Block Properties window.

For a dependent event leading to a standby, priority AND or sequence enforcing gate, the reliability/maintenance characteristics correspond to those of the contained standby block in an RBD. For a dependent event leading to a load sharing gate, the reliability/maintenance characteristics correspond to those of the contained load sharing block in an RBD.
Fault Tree Tracer

New in Version 11, the fault tree tracer provides a way to visualize how fault tree subdiagrams fit into a parent fault tree. This may be helpful if, for example, your team works on an assembly represented by a particular fault tree, and you need to know how it relates to the overall system.

*Note:* This tool is exclusively for use with fault trees. Any RBDs used as subdiagrams within the parent fault tree will not be available for selection as subdiagrams of interest, and will not be available for expansion within the tracer report.

Create a Fault Tree Tracer

To create a fault tree tracer, choose **Insert > Reports and Plots > Fault Tree Tracer**.

In the Select Data Sources window, first select a parent fault tree from the **Top Level Diagram** list. The **Available Subdiagrams** list will then show all of the fault tree subdiagrams referenced by the top level diagram or any of its subdiagrams. Select the subdiagram(s) that you are interested in and click **OK** to create the report.

- **Hierarchical** arranges the lists as they are shown in the current project explorer.
- **Alphabetical** sorts them alphabetically.

If you apply an **item filter**, only fault trees that fit the criteria will be shown in the **Top Level Diagram** list.

*Tip:* Depending on the size of the diagrams you're working with, this can be a memory-intensive process. On the **Calculations page** of the Application Setup, you can set the maximum number of blocks to read and maximum percentage of memory to be consumed by the fault tree tracer. If the process exceeds the values specified for these options, a partial tracer will be shown, with an annotation indicating the limit that has been exceeded.

Change or Refresh the Diagrams

If any of the diagrams within the tracer has changed since the report was created, the status light in the control panel will be red. To update the tracer with the most current information, choose **Tracer > Data Source > Refresh** or click the icon on the control panel.

If you later need to change the top level diagram and/or the subdiagram(s) of interest, choose **Tracer > Data Source > Select Data Sources** or click the icon on the control panel.
Chapter 6: BlockSim RBDs and Fault Trees

View the Tracer
The Diagram panel at the bottom of the report shows thumbnails of the tracer reports for the top level diagram and each subdiagram of interest. Use this panel to select which diagram will be displayed at full size in the tracer report.

To open any of the fault tree diagrams, double-click the subdiagram block or click the link in the control panel.

By default, each tracer diagram shows only the subdiagrams of interest (displayed as subdiagram blocks) and their direct paths to the top gate of the parent fault tree. The lowest level tracer subdiagram(s) (i.e., those that do not contain any subdiagrams of interest) will show all blocks they contain. Use the check boxes in the control panel to change what is shown.

- **Show Parent Diagram Names:** Shows the name of the diagram where each block is located (displayed at the upper right of each block). You can change the appearance of the text via the relevant Block Corner Indicators page of the Diagram Style window.

- **Auto Refresh:** Automatically rebuilds the fault tree tracer when either of the two options below is selected or cleared. If this option is not selected, click the Refresh icon to rebuild.

- **Expand Subdiagrams:** Shows all blocks in the direct paths within all subdiagrams.

- **Show Blocks Outside of Path:** Includes any blocks that are not found in the path between the top gate and the subdiagram(s) of interest.

Choose **Tracer > Selection > Trace Path of Interest** or click the button on the control panel to select all subdiagrams of interest and highlight the paths from them to the top gate of the parent fault tree.

For example, let's say that you are interested in the potential failure of a brake mechanism within a system. You create a fault tree tracer:
Initially, the tracer shows just the direct path between the subdiagram of interest (Brake) and the top of the top level diagram (Robot Manipulator).
If you select the **Show Blocks Outside of Path** and **Show Parent Diagram Names** options on the control panel and click **Trace Path of Interest**, the tracer looks like this.
The appearance of the traced path can be modified in the **Diagram Style** window.
Mirroring (Using Blocks in Multiple Locations)

Mirrored blocks allow you to place the same block in more than one location. In other words, mirrored blocks allow you to represent a single component more than once in a diagram or in multiple diagrams within a project. This is useful, for example, when simulating bi-directional paths within the diagram or if the same item performs more than one function and each function has a different reliability-wise impact on the system. The ability to mirror across diagrams allows you to represent situations where a single component's failure affects multiple subsystems that are represented in separate subdiagrams.

**Note:** For information about using mirror groups for common cause failures in FMRAs, see Add to Mirror Group Window (FMRA).

Mirroring is accomplished by adding blocks to a mirror group. Mirror groups are resources that can be shared among analyses and can be managed via the Resource Manager. The mirrored blocks are treated as fully equivalent multiple instances of a single block, rather than considered as an original and copies.

**What's Changed?** In BlockSim 7, mirroring was accomplished by choosing one block as the original (or "target") and pointing all of the copies (or "mirrored") blocks to that original block. The mirror groups used in the Synthesis version simplify management of mirrored blocks by allowing you to see all instances of the block in the Mirror Group Manager.

Any changes made to the properties of a block in a mirror group will apply to all other blocks in the mirror group. For analytical diagrams, mirrored blocks have a significant effect on the system reliability equation. Consider a simple RBD like the one shown next.

![Block Diagram](http://blocksim.reliasoft.com)

The system reliability equation for this diagram is shown next.
If, however, the two blocks in the RBD belong to the same mirror group, they are actually a single block. The diagram and system reliability equation are shown next.

$$R_{\text{System}} = R_{\text{Block 1}} + R_{\text{Block 2}}$$

When a diagram with mirrored blocks is simulated, every event associated with one block in a mirror group will also apply to all other blocks in the mirror group.

**Tip:** Blocks that belong to a mirror group have a square at the lower left corner of the block. You can change the size of the indicator and the appearance of the text via the relevant Block Corner Indicators page of the **Diagram Style window**. You can change the color used for each mirror group via the **Mirror Group Manager**.

The Mirror Group window allows you to create, view and edit mirror groups. It can be accessed from the Mirror Groups page of the Resource Manager by choosing **Home > Edit > New**, by selecting a mirror group and choosing **Home > Edit > View** or by double-clicking a mirror group.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see **Default Name Formats window**). You can replace this...
with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the Synthesis resources you need for your analyses.

You can also enter comments about the mirror group in this window.

For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

**Mirror Group Manager**

To add blocks to a mirror group, choose Project > Data Management > Mirror Group Manager.

The Mirror Group Manager will appear, as shown next.
The **Mirror Group** area allows you to choose an existing mirror group from the drop-down list. In addition, you can click the **Select Existing** icon to open the **Select Resource window**. If there is not an existing mirror group that meets your needs, you can create a new one by clicking the **Create New** icon to open a window that allows you to specify a name for the new mirror group, as well as any comments. Click the **View** icon to view the characteristics of the selected mirror group.

You can also click the **Indicator Style** icon to modify the appearance of the corner indicator that will appear on each block that belongs to the mirror group, including:

- The indicator's background color, fill color and fill style. The background color is the underlying color applied to the indicator; the fill color is applied over the background color in the pattern specified by the fill style.
Chapter 6: BlockSim RBDs and Fault Trees

- The style (e.g., solid, dash, etc.), color and thickness of the indicator border.

You can change the size of the indicator via the relevant Block Corner Indicators page of the Diagram Style window.

The **Mirrored Blocks** area displays all of the blocks in the mirror group, in the format [Diagram Name]\[Block Name].

- To add a block to the mirror group, you can select the diagram and block in the **Add Block** area and click the **Add to Mirror Group** button. You also can select the block(s) in the diagram, press **CTRL+SHIFT** and drag the block to the list in the **Mirrored Blocks** area of the Mirror Group Manager.

- To view a mirrored block, select the block in the list and click the **Select on Diagram** button. The diagram will be displayed with the block selected.

- To remove a block from the mirror group, select the block in the list and click the **Remove from List** button. The block's properties will not change, but it will no longer be part of the mirror group. Subsequent changes to, or simulation of, other blocks in the mirror group will not affect it.

**Note:** Adding blocks to or removing blocks from a mirror group changes the configuration of the diagram(s) in which the blocks are located, necessitating reanalysis or resimulation.

By default, a mirrored block in a diagram is identified by a gray box at the lower left corner of the block, and the name of the mirror group is displayed by the box. These settings may be changed via the Block Corner Indicators pages of the Diagram Style window.

**Block Details**

The Block Details window displays the details of the blocks and resources in the current RBD, fault tree or phase diagram. To access the Block Details window from within a diagram, choose [Diagram/Fault Tree/Phase] > Selection > Diagram Actions > Show Block Details.

Click an item in the navigation panel on the left to display a complete hierarchical list of its properties in the area on the right. When a resource is shown in the area on the right (i.e., when a resource is part of the properties of the item that is currently selected in the navigation panel), you can click the + beside it to view its properties.
You can collapse or expand all nodes in the properties hierarchy using the **Collapse All** and **Expand All** icons.

You can select the **Show resources only** check box at the bottom of the window to hide all properties except for the resources. In the case of blocks, this hides all block properties except for the resources that the block uses; for resources, it hides the identifier fields.

You can click the **Send to Workbook** icon to add a new **Synthesis Workbook** to the project and save the results in it.

You can click the **Send to Excel** icon to save the results as an Excel file.

### Block Explorer

New in Version 11, the Block Explorer is a convenient tool that allows you to explore the blocks in RBDs and fault trees throughout the current database. It works very much like the **Synthesis Explorer**, so if you're experienced with that tool, you can use the Block Explorer right away.

To access the utility, choose **Home > Synthesis > Block Explorer**.

To reduce the amount of time required to populate the grid, first use the project and item filters (discussed below) to limit your search, then click **Load Data**.

You can filter/sort/group the blocks based on project, diagram, block, analysis creator and many other properties.

This topic summarizes the tools you can use to find and organize data in the Block Explorer’s flexible grid.

### Save and Apply Views

Once you have customized the Block Explorer’s grid to suit a particular purpose (using the built-in find/filter, column configuration and grouping features described below), you can save the preferences as a view that can be used again whenever you need it. A view is saved in the database and available only to the user who created it.
Chapter 6: BlockSim RBDs and Fault Trees

To create a view, first configure the grid to suit your particular needs and then click **Save View**.

To quickly apply these same preferences again at any time, click **Apply View** and select one of the saved views from the list.

*Note*: The view does not affect filtering that has been applied from the Project Filter, Item Filter or Category Panel.

**Project and Item Filters**

The Block Explorer can utilize the same **project and item filters** that are available in many other locations throughout Synthesis desktop applications. For example, with the custom filters shown below, the Block Explorer will show only blocks in analyses performed by Department A (project filter) that were modified within the last month (item filter).

<table>
<thead>
<tr>
<th>Project Filter</th>
<th>Department A</th>
<th></th>
<th></th>
<th></th>
<th>Item Filter</th>
<th>Last Month</th>
<th></th>
</tr>
</thead>
</table>

To remove either filter, select **Show All** from the drop-down list. To remove both filters at the same time, select **Data > Clear Filters**.

After you clear or change these filters, you must click **Load Data** again to update the grid.

When working with item filters in the Block Explorer:

- The **Name** field refers to the block name. Blocks that use the default block name (i.e., that have an asterisk in their **Name** field) will not be matched to any entry in this field. That is, if you have an item filter that requires a Name of "Block_1," only blocks that you have manually named "Block_1" will be returned. Any blocks that use the asterisk to generate "Block_1" for display in the diagram will not be returned.

- Information on item creation and update is not applicable, because this information is not tracked for blocks.

**Built-in Find/Filter, Configuration and Grouping Tools**

The Block Explorer offers the same filter, column configuration and grouping tools that are built in to other Synthesis utilities that use a similar grid (e.g., the Resource Manager). For details about how to use each feature, see:

- **Finding and Filtering Records**
Quick Calculation Pad (QCP)

The Quick Calculation Pad (QCP) provides a convenient way of calculating a variety of useful metrics. You can access the tool by clicking the QCP icon on the Analytical or Simulation page of the diagram control panel.

The following example shows the QCP for analytical diagrams.

This topic provides a general description of the QCP and how to use it in most analyses. For more focused information about the types of calculations that can be performed for an analytical diagram, see Analytical Quick Calculation Pad. For information about the types of calculations available for simulation diagrams and phase diagrams, see Simulation Quick Calculation Pad. For information about the types of calculations available for Markov diagrams, see Markov Quick Calculation Pad.

How to Use the QCP

To use the QCP, do the following:

- Choose a metric in the Calculate area.
• If applicable, use the **Units** drop-down list to specify the **units for time values** that are entered as inputs and/or displayed as results. The units in the QCP can be different from the units that were used for the diagram. For example, you could enter the age of the block in hours but then calculate the reliability for 1 year of operation — the application will convert the times automatically based on the conversion factors specified for the database.

• For analytical diagrams, use the **Bounds** drop-down list to specify what type of confidence bounds to calculate. The following graphics illustrate the types. The ReliaWiki resource portal provides more information on the background theory of confidence bounds at: [http://www.reliawiki.org/index.php/Confidence_Bounds](http://www.reliawiki.org/index.php/Confidence_Bounds).

If you select **Both One-Sided**, the QCP will calculate both the lower one-sided bound and the upper one-sided bound.

**Note:** Confidence bounds are available only in cases where all blocks that can fail in the analytical diagram use models that have Fisher matrix bounds. To have Fisher matrix bounds, a model must have been created by **publishing** from a data source, such as a Weibull++ or ALTA data sheet, that was calculated using Fisher matrix bounds. Additionally, bounds are not available if the diagram has containers, subdiagrams or mirrored blocks, or if any block uses the cumulative damage model.

• Make any required inputs in the **Input** area.

• Click **Calculate**. The calculated value(s) will always be displayed in the results area at the top of the window, and clicking the **Report** button displays a summary of the current calculation input/output in the **Results window**. You can also use the **Options** drop-down list to configure other settings, including:
  
  • **Precision** sets the number of decimal places displayed in the results.
  
  • **Scientific Notation** sets the point at which numbers will be converted to normalized scientific notation. For example, setting this to 3 means that all
numbers with a value of 1,000 or more will be converted to normalized scientific notation (e.g., 1.0E+3).

- **Set Display Font** allows you to change the font style and size that is used to display the calculated value(s) in the results.

- Select *Captions* if you want additional information to be displayed in the results area along with the values (a green light in the button indicates that this option is selected). For example, if you have selected to calculate the reliability for a given period of time, the first picture shows the display with captions and the second picture shows without.

  ![QCP with captions on.](image1)

  ![QCP with captions off.](image2)

- Select *Show Calculation Log* if you want to display a log on the right side of the window that records some or all of the calculations performed during this QCP session (a green light in the button indicates that this option is selected).
  - If *Auto Print Results* is selected under *Options*, all results will be automatically printed to the log each time you perform a calculation.
  - Otherwise, you can choose which results to add to the log by using the *Print* button at the bottom of the log display.

Under the log display, you can also click *Feed* to "advance the tape" or *Clear* to delete all data from the current log. If you click inside the log, you can copy some or all of the text to the Clipboard.

- Select *Non-Modal QCP* to lock the QCP in a top window position so it can remain open while you have access to all diagrams. The calculations performed in the
QCP will be based on the currently active diagram. If this option is not selected, you will need to close the QCP to access any diagram. This setting can also be changed using the **While QCP is open, have access to all folios** option on the Other Settings page of the Application Setup.

## Publishing Fitted and Analytical Models

To publish the results of a simulation diagram as a model, you must first fit a distribution to the simulation results. The published model will always be based on the fitted distribution. For an analytical diagram, however, you can publish models based on the analytical solution and/or the fitted distribution.

- **An analytical model** is based on the analytical solution. This is essentially a single reliability model object that references all items in the diagram, as well as their dependents. Each reference to a model like this is really a reference to the diagram and its subdiagrams, and uses resources accordingly. The benefit to this approach is that no approximation is needed and any changes made to the models or dependencies of the blocks within it will be automatically incorporated in the model. The drawback is that such models are complex and consume computer memory and resources.

- **A fitted model** is based on the fitted distribution, and yields an approximation of the entire diagram (and its subdiagrams). This results in a significant reduction of complexity, as the entire diagram and its dependents no longer need to be used for any calculations. The drawback is that any changes that are subsequently made to the diagram and/or its dependents are not reflected unless the distribution is refitted and then republished.

Each type of model has its own area, with all associated tools for publishing the model and viewing its properties, on the Publishing page of the analytical diagram control panel.

## Removing Associations for Analytical Models

For all published models, you can remove the association between the current analysis and the published model by clicking the Remove Association icon.

When you do this, the model will continue to be a resource in the database but it can no longer be synchronized with the original analysis. However, in the case of a published analytical model, removing the association with the diagram would actually remove the model itself, because it is a direct reference to the diagram. Therefore, to remove the association for published analytical models, you must specify a replacement model. If a fitted model exists for the diagram, it will
be used as the replacement. If no fitted model exists, you will be prompted to specify the properties for a replacement model.

Similarly, if you delete an analytical diagram with a published analytical model, you must specify a replacement model. In this case, a fitted model must not only exist but also have been published in order to be used as the replacement. If no fitted model has been published, you will be prompted to specify the properties for a replacement model.

### Creating Diagrams from Synthesis Data

The integration of the Synthesis applications makes it easy for you to import data from your analyses in the Synthesis versions of Xfmea, RCM++, RBI or Lambda Predict and create RBDs and/or fault trees that allow you to perform more in-depth calculations. Two possibilities exist:

- You can import items from analyses in other Synthesis applications in the current project, along with their reliability data, and create diagrams that reflect the items' reliability-wise relationships.
  - When importing from Xfmea/RCM++/RBI, you can create either fault trees or RBDs.
  - When importing from Lambda Predict, you can create RBDs.
- You can import records to create a fault tree based on the effects in analyses performed in other Synthesis applications in the current project.

**IMPORTANT:** These tools are intended to provide a quick and easy way to bring data from other Synthesis applications into BlockSim, and to create diagrams that can be used as starting points for analyses within BlockSim. BlockSim is capable of modeling very complex configurations, and you may wish to make changes to the diagrams before analyzing or simulating them in BlockSim so that your results more accurately represent the real-world configuration of your systems. For example, the FMRA in Xfmea, RCM++ and RBI assumes that all items are in series configurations, so all diagrams created using these tools represent series configurations unless you subsequently modify them.

**Note:** For blocks and diagrams representing FMEA records (i.e., functions, failures or causes), the names.descriptions are based on the **Short Description** field for the record.
Building RBDs and Fault Trees from Xfmea/RCM++/RBI

You can create RBDs that represent items from analyses performed in the current project in Xfmea/RCM++/RBI in order to perform system maintainability and availability analysis for these items. To do this, choose Insert > Build from Synthesis > Build RBDs and FTs from Synthesis.

The Build RBDs and FTs from Synthesis window consists of two steps. When the window opens, you will see the Options step. Specify that you want to use RCM++/Xfmea/RBI as the data source in the Synthesis Element to Build From area. (You can use data from the Synthesis versions of RCM++, Xfmea or RBI.)

In the Diagram Type area:

- Specify whether you want to represent the imported items' reliability-wise relationships using fault trees, RBDs or a hybrid of the two. If you choose the Hybrid option, all systems will be imported as RBDs, while FMEA information will be imported as fault trees.

- Choose whether you want the new diagrams to be analytical diagrams or simulation diagrams.

- If you select the Create folders check box in this area, each diagram will be added to the current project explorer within its own folder under the Fault Trees or RBDs folder. The new folders will be arranged hierarchically in the same way as the information in the original analysis, thus making their hierarchical relationship visually apparent within the current project explorer.

The reliability information for each branch of the FMRA hierarchy is taken from the highest-level item for which reliability is specifically defined, rather than inherited. For example, imagine that you are importing from the following hierarchy and creating fault trees from the information:
Chapter 6: BlockSim RBDs and Fault Trees

If a URD is assigned to the Automobile item, then only the following diagram will be created:

![Simulation Fault Tree: Automobile]

If a URD is assigned to the Body Closures item and the Automobile item is set to inherit its reliability characteristics from that, then the following diagram will be created:

![Simulation Fault Tree: Body Closures]

If a URD is assigned to the Body Closures item and the Automobile item is set to inherit its reliability characteristics from that, then the following diagram will be created:
If a URD is assigned to the Front Door L.H. item and the Automobile and Body Closures items are set to inherit their reliability characteristics, then the following diagrams will be created:
Finally, if all items are set to inherit their reliability characteristics and URDs are assigned only to the causes in the FMEA for the Front Door L.H. item, then the following diagrams will be created:
If you are creating RBDs or a hybrid of RBDs and fault trees, the **Subdiagram Grouping** area will be available. The options in this area allow you to control which levels of analysis will be represented by subdiagrams. For example, consider the final case above, where all system hierarchy items are set to inherit their reliability characteristics and URDs are assigned only to the causes in the FMEA for the Front Door L.H. item.

- If you are creating RBDs, your choices in the **Subdiagram Grouping** area will determine how the system and reliability information is represented across diagrams, as follows:
  - If you select **Create system-level diagrams**, then a diagram will be created for each item in the system hierarchy. The top level (i.e., Automobile) diagram will contain a subdiagram block representing the next level item (i.e., Body Closures) and so on. The diagram representing the lowest level in the system hierarchy (i.e., Front Door L.H.) will contain the FMEA information. This may be shown as...
causes or additional levels of subdiagrams may be included to represent the function and/or failure, depending on your choices for the next two options.

- If you select **Create subdiagrams for functions**, then the function level of the FMEA will be represented by a diagram. Note that if you select this check box but do not choose to create subdiagrams for items in the system hierarchy, then the function diagram will be the top level diagram.

- If you select **Create subdiagrams for failures**, then the failure level of the FMEA will be represented by a diagram. Note that if you select this check box but do not choose to create subdiagrams for items in the system hierarchy, then the failure diagram will be the top level diagram.

By combining these options, you can control the levels that are represented in the RBD(s) created. Bear in mind that, as with fault trees, the reliability information for each branch of the FMRA hierarchy is taken from the highest-level item for which reliability is specifically defined, rather than inherited. This is true not only for system hierarchy items, but also for FMEA records. For example, if reliability is defined for a function, that function will be shown as a block in the resulting RBD and no subdiagram will be created for it (i.e., any failures and causes assigned to the functions will not be imported, as they are not relevant to the reliability).

The **Create subdiagrams for functions** and **Create subdiagrams for failures** check boxes control only how information is organized, not what information is imported. All items with reliability information defined will be imported, regardless of your selections for these check boxes. For example, consider a component with an FMEA that includes three functions, each of which has a failure and a cause defined. Its FMRA is shown next.

<table>
<thead>
<tr>
<th>Name</th>
<th>Record Type</th>
<th>Reliability Policy</th>
</tr>
</thead>
<tbody>
<tr>
<td>Component</td>
<td>Item</td>
<td>Inherit</td>
</tr>
<tr>
<td>Function 1</td>
<td>Function</td>
<td>Function 1_URD</td>
</tr>
<tr>
<td>Function 2</td>
<td>Function</td>
<td>Inherit</td>
</tr>
<tr>
<td>Failure 2</td>
<td>Failure</td>
<td>Failure 2_URD</td>
</tr>
<tr>
<td>Function 3</td>
<td>Function</td>
<td>Inherit</td>
</tr>
<tr>
<td>Failure 3</td>
<td>Failure</td>
<td>Inherit</td>
</tr>
<tr>
<td>Cause 3</td>
<td>Cause</td>
<td>Cause 3_URD</td>
</tr>
</tbody>
</table>

As you can see, the reliability is defined at the function level for Function 1, at the failure level for Failure 2 and at the cause level for Cause 3. If you imported this configuration with both the **Create subdiagrams for functions** and **Create subdiagrams for failures** check boxes selected, you would get the diagrams shown next.
On the other hand, if you imported the same configuration with neither of the two check boxes selected, you would get the following diagram:

- If you are creating a hybrid of RBDs and fault trees, only the Create subdiagrams for functions check box will be available. In this case, system-level diagrams are always created. Your selection in this area determines whether the fault trees are created at the function level or at the failure level.

When creating either fault trees or RBDs, you can use the Overridden Items area to import items that would normally not be imported.

- Select the Import items even though overridden by higher level definition check box to allow you to import lower-level items even if a higher-level item has defined reliability characteristics. Selecting this option causes the reliability of the higher-level item(s) to be set to inherit from the lower-level item(s) for the purposes of the import. The settings will not be changed in the original analysis.

- Select the Import items regardless of reliability policy check box to allow you to import items even if they are set to inherit their reliability characteristics and no reliability
Chapter 6: BlockSim RBDs and Fault Trees

characteristics are defined for any item below them. Selecting this option can cause empty diagrams to be created.

Click the **Next** button to view the Hierarchical Representation step, which displays a hierarchical view that corresponds to the diagram(s) that will be created. You can select or clear items in this tree to specify whether they will be included in the diagram(s). If the tree does not correspond to the diagram(s) you have in mind, you can click the **Back** button to return to the Options step and try again. Otherwise, click **OK** to create the diagram(s).

**Building RBDs from Lambda Predict**

You can use the system configuration and failure rate predictions from Lambda Predict as a starting point for creating RBDs in BlockSim. As more information becomes available, you can then replace the predicted failure rate models with new models that are based on Weibull++ analyses and other sources.

Importing the system configuration data from Lambda Predict is a two-step process:

1. First, you must publish the failure rates calculated in Lambda Predict as reliability models. To do this, open the project in Lambda Predict. In the prediction folio, select the standard item (i.e., $G$, $ML$, $BL$, $TL$, $MC$, $SN$ or $F$) or assembly (i.e., $G$ or $F$) that you want to create the RBD for, and then choose **Prediction Tools > Share > Publish Branch**.

Once the models are published, you can close the project in Lambda Predict if desired. (For more general information on publishing failure rate models in Lambda Predict, see "Publishing Models from Failure Rate Predictions" in the Lambda Predict help file.)

2. Open the project in BlockSim, and then choose **Insert > Build from Synthesis > Build RBDs and FTs from Synthesis**.

When the window opens, specify that you want to use Lambda Predict as the data source in the **Synthesis Element to Build From** area. The utility will provide the following options:

- **Simulation or Analytical** - use the drop-down list to specify whether the new RBD(s) will be analytical diagrams or simulation diagrams.

- **Create Folders** - select this check box if you want the new diagram(s) to be organized into a separate folder in BlockSim's current project explorer. (Note that selecting this option can make it easier to delete and recreate the diagrams.
if you need to. You can delete the entire folder instead of deleting each diagram individually.)

- **Create subdiagrams for blocks** - in this context, the term "blocks" refers to the assemblies in Lambda Predict. For each block in the prediction folio, you can:
  
  - Use a single RBD block to represent the reliability of the entire assembly. This treats the assembly as a "black box" in the RBD, using the item model that was published for the block.
  
  - Use a subdiagram in the RBD to represent the assembly. This allows you to consider the separate failure rates for all of the components that make up the assembly.

**Note:** For many of the reliability prediction standards available in Lambda Predict, a portion of the assembly's failure rate may be calculated at the block level. In Lambda Predict, this portion is called the block's **supplemental model**. For example, in MIL-217 analyses, the failure rate for a printed circuit board (PCB) assembly is a summation of the individual failure rates of its components plus the failure rate due to the physical connection of the components to the board. If you have chosen to create subdiagrams for such assemblies, the diagrams will contain the reliability models of all the components in the assembly plus the supplemental model that represents the failure rate due to the connections.

After you have specified your preferences, click **Next** to see the failure rate models that were published from Lambda Predict. As an example, the following pictures show two ways that models published from the same MIL-217 prediction might be displayed, depending on whether the **Create subdiagrams for blocks** option was selected.

In the first scenario, the **Create subdiagrams for blocks** option was selected; therefore, the utility displays all the assemblies and components in the system configuration. The window also displays the supplemental model for each assembly and the item model for each component, as shown next. (Note that the supplemental model icon will be displayed only if it's applicable for the particular assembly and the model has been published from Lambda Predict.)
If you select all of the items shown in this hierarchy and click **OK**, BlockSim will create a diagram for the "MIL-217 System" that links to one subdiagram for Assembly A and another for Assembly B, as shown next.
In the second scenario, the **Create subdiagrams for blocks** option was not selected; therefore, the utility displays only the assemblies. In this case, the item model 📋 that represents the failure rate calculated for each assembly will be used.
If you select all of the items shown in this hierarchy and click OK, BlockSim will create one diagram for the "MIL-217 System" that includes a single block for each assembly, as shown next.

Note the following:

- If you have made changes to the analysis in Lambda Predict since the last time you published the models, it is recommended to use the Publish Branch
components with a value greater than 1 in their quantity field in Lambda Predict are represented by **multi blocks**.

- Parallel configurations at the assembly level, which Lambda Predict models using redundancy, are modeled in BlockSim using nodes.

- Component adjustment factors defined in Lambda Predict will be imported as block duty cycles. Adjustment factors for assemblies are not imported.

### Building Effect Fault Trees from Synthesis

To create a fault tree based on one or more effects in analyses performed in other Synthesis applications in the current project, choose **Insert > Build from Synthesis > Build Effect FTs from Synthesis**.

In the window that appears, you can search for and select the effects that you want to use as the top level in the fault tree.

In the **Criteria to Filter Effects** area, choose the text field that you want to search for each effect record. Supply the desired text that you are searching for in the text box, and specify the desired type of match in the middle drop-down list. For example:

- If you specify that the **Short Description** field **contains** the term **fire**, the search will return all effects whose short description contains the string "fire" in any FMEA within the current project. This is a string search, rather than a complete word search, so the search will also return effects containing words such as "fired" and "misfire."

- If you specify that the **Short Description** field **contains any** of the terms **fire**, **spark**, the search will return all effects whose short description contains the string "fire" or the string "spark."

- If you specify that the **Short Description** field **contains all** of the terms **fire**, **spark**, the search will return all effects whose short description contains both the string "fire" and the string "spark."

- If you specify that the **Short Description** field **begins with** the string **corro**, the search will return all effects whose short description begins with that string. This search would return effects such as "Corroded panel" or "Corrosion of panel" but not "Panel is corroded."
Chapter 6: BlockSim RBDs and Fault Trees

- If you specify that the **Short Description** field is the term **endangers operator**, the search will return all effects whose short description contains only that exact string.

Note that none of these searches is case sensitive.

The **Select Effects** table updates dynamically to show only the effects that meet the search criteria you have specified. Select the check box for each effect that you would like to include as part of the top level item in the fault tree. You can select or clear the check box in the header area to select or clear the check boxes for all effects in the table.

Click the **Next** button to view a hierarchical representation of the fault tree, which displays the group of effects selected for inclusion with their associated failures and the causes associated with each failure. You can select or clear items in this tree to specify whether they will be included in the fault tree. If the tree does not correspond to the fault tree you have in mind, you can click the **Back** button to return to the Select Effects table and try again. Otherwise, click **OK** to create the fault tree.

The fault tree shows the causes as events, with associated reliability information if it was specified in the original analysis. The cause events are connected to OR gates that represent the failures associated with the causes; these OR gates are connected to the top OR gate, which represents the selected effect(s).
Note: Reliability information for fault trees created in this way is based on the reliability defined at the cause level. Any reliability information defined for items, functions or failures is ignored.
Chapter 7: BlockSim Analytical Diagrams

BlockSim's reliability block diagrams and fault trees can be configured as analytical diagrams (which use the exact algebraic equation for the model but impose limitations on what can be modeled and what results can be obtained) or as simulation diagrams (which provide more modeling options and results but must be analyzed with discrete event simulation).

In the analytical (or algebraic analysis) approach, the system's pdf is obtained analytically from each component's failure distribution using probability theory. In other words, the analytical approach involves the determination of a mathematical expression that describes the reliability of the system in terms of the reliabilities of its components. Once the system's reliability function has been determined, other calculations can then be performed to obtain metrics of interest for the system. There are several kinds of results available for analytical diagrams:

- The algebraic solution for the diagram (i.e., a mathematical representation of the reliability-wise configuration of the diagram) can be viewed in the Equation Viewer.
- The minimal cut sets, or the unique combinations of component failures that can cause system failure, can be viewed in the Cut Sets window.
- The analytical Quick Calculation Pad (QCP) provides quick access to some of the most frequently requested reliability results. These include standard and conditional reliability/probability of failure, failure rate, warranty time, BX information and mean time to failure.
- A wide variety of plots help you to visualize the analytical results. These include plots pertaining to the system and to the blocks, offering information about reliability/unreliability, failure rate, pdf and reliability importance.

In addition, allocation analysis can be performed based on the results from analytical diagrams. Allocation analysis helps to decide how the system's reliability can best be improved, based on the reliability importance of the blocks selected for consideration.

Analytical diagrams are appropriate when one is performing "reliability analysis." In the context of BlockSim, we use the term "reliability analysis" to refer to all analyses that do not include repairs or restorations of the component. When considering only the failure characteristics of the components, the analytical approach can be used. However, when both failure and maintenance characteristics need to be considered, the simulation method must be used to take into account the additional events.
Chapter 7: BlockSim Analytical Diagrams

Analytical Diagram Control Panel

The control panel associated with BlockSim analytical diagrams and fault trees consists of multiple pages, each containing options for performing particular tasks. This topic focuses on the Analytical, Analysis Settings and Drag & Drop URDs pages of the analytical diagram control panel, which contain most of the tools you will need to build and analyze a diagram. For more information about the control panel in general, see Control Panels.

Control Panel Analytical Page

The Analytical page of the control panel for analytical diagrams and fault trees contains the following options:

- **The Analytical area** displays the status and results of the analysis.

  ![Analytical Panel](image)

  - **Status** If the light is green, then the diagram has been analyzed. If the light is red, then the diagram has not been analyzed. An analyzed diagram will remain in the analyzed state unless a change is made to the diagram (e.g., a block is added, a connector is removed, a model is changed, etc.).

  - **Show Algebraic Solution (...)** displays the algebraic solution for the diagram in the Equation Viewer.

  - **Distribution fit** displays the distribution that has been fitted to the analytical results. Click the button (...) to open the Distribution Estimator to fit a distribution and/or for information on the fitted distribution parameters. The fitted distribution can be used to describe the overall behavior of the system and can be published for use as a model elsewhere in the project.

  - **Show Results** if selected, results at the event or gate level will be displayed at the upper right of each block in the diagram. This option is available only for fault trees. (You can change the appearance of the text via the relevant Block Corner Indicators page of the Diagram Style window.) Select to display the results as reliability or unreliability values and specify the time at which the results should be calculated. The units for the time are the default units, as specified in the Units window.
Click the **Update** icon to update the results shown in the diagram without reanalyzing the diagram.

You can click the **Spreadsheet View** icon to view the results for all gates and events in a spreadsheet-style report in the Results window.

**What's Changed?** Starting in Version 11, these results are displayed in decimal format, instead of percentage.

- The **Information** area displays information about the diagram or the currently selected block. If no block is selected in the diagram, the **Information** area displays the number of blocks in the diagram and information about the diagram creation and last modification; in addition, if the diagram results have been published as a model, the name of the model will appear as a link allowing you to view the model in the Synthesis Viewer window. If a block is selected in the diagram, it displays a subset of the properties found in the Block Properties window. Items in the table that are resources (e.g., models, switches, etc.) are links; you can click such items to view and/or edit their properties. In both cases, this area also offers a **Comments** field; click the field heading to enter comments. For blocks, these comments are also accessible in the Identifiers properties in the Block Properties window.

- The **Tools** area gives you quick access to the tools you will need to analyze the diagram and generate additional results.

  - **Analyze** analyzes the relationships of the components in the diagram and puts the reliability-wise configuration into a mathematical formula.
  
  - **Plot** creates a plot based on the analysis results. Clicking the **Plot** icon before the diagram has been analyzed will automatically perform the analysis and then plot the data.
QCP opens the analytical Quick Calculation Pad (QCP). The QCP allows you to obtain reliability results based on the algebraic solution for the currently active diagram. Clicking the QCP icon before the diagram has been analyzed will automatically perform the analysis and then open the QCP.

Change Diagram Type changes the current diagram to the opposite diagram type (i.e., changes the current analytical diagram to a simulation diagram, or the current simulation diagram to an analytical diagram). Note the following:

- Your most recent selection for the **Perform the same change to any subdiagrams** option in the Change Diagram Type window (Diagram > Diagram Actions > Change Diagram Type) will be used in this change.

- If you create an analytical diagram from a simulation diagram, by either duplication or conversion, the maintenance and throughput characteristics defined in the simulation diagram will not be displayed in the analytical diagram, as they are not relevant to the analysis. However, the properties are not lost, and if you then create a simulation diagram from that analytical diagram, all original properties will be retained.

- If you prefer to create a new diagram using the new type, use the Change Diagram Type window instead.

**Control Panel Analysis Settings Page**

The Analysis Settings page of the control panel for analytical diagrams and fault trees contains the following options:

- **Use IBS**: if selected, the software looks for blocks with identical failure characteristics and attempts to simplify the equation, if possible, when analyzing the diagram (i.e., identical block simplification). This is useful when analyzing large diagrams that contain a lot of the same blocks. However, using this option means that more types of changes to the diagram will invalidate the mathematical equation that describes the reliability-wise configuration of the diagram and will require that the diagram be reanalyzed. If you select or clear this check box after you have already analyzed the diagram, you will have to reanalyze it.

- **Report Settings: Report folio model** allows you to specify the results model that will be used when the diagram is used as the default data source for a Synthesis Workbook. You can choose to use either the analytical results or the fitted model.

**Control Panel Drag & Drop URDs Page**

The Drag & Drop URDs page is available in the control panel for analytical and simulation diagrams, including fault trees. It provides a list of the URDs that are available for use by blocks.
in the diagram. Drag a URD into the diagram to create a standard block/event that uses the URD.

The list of URDs can be filtered using the same resource filter that is available in many other locations throughout Synthesis desktop applications.

Distribution Estimator

Once a diagram has been analyzed or simulated, the results can be fitted to a distribution, which can be used to describe the overall behavior of the system. The fitted distribution may then be published for use as a model elsewhere in the project. For simulation diagrams and continuous Markov diagrams, the distribution is based on the results shown on the System Point Results report in the Results Explorer.

The Distribution Estimator allows you to specify the distribution used and to view the parameters of the fitted distribution. It is accessed by clicking the (...) button in the Distribution Fit field in the control panel. When the window is opened, the current distribution, if any, is displayed in the Distribution area and the calculated parameters are displayed in the Fitted Parameters area.
To calculate the parameters for a different distribution, choose the distribution in the **Distribution** area and specify the time units in the **Units** area, then click **Compute**. BlockSim will use the Weibull++ life data analysis engine to calculate the distribution parameters based on the diagram.

If you select the **Use Distribution Wizard** check box and click **Compute**, BlockSim uses Weibull++’s Distribution Wizard to select the distribution that best fits your data and then calculates the fitted parameters.

If you select the **Create Weibull++ data set** check box and click **Compute**, a Weibull++ life data folio containing a free-from data sheet will be created in the project and the data points used in fitting the distribution will be entered into the data sheet. If Weibull++ is installed on your computer, it will automatically be opened.

For analytical RBDs and fault trees, the **Number of sampling points** field allows you to specify how many data points are generated in order to fit the distribution to the diagram results. (For simulation diagrams and continuous Markov diagrams, the diagram results are used for this purpose.) While a higher number of sampling points will result in a more accurate fitted distribution, it can also slow down the calculation.

To apply the specified distribution and parameters to the diagram and close the Distribution Estimator, click **Update**. To close the Distribution Estimator without applying changes, click **Cancel**.
Available Results

Equation Viewer
The Equation Viewer shows the algebraic equation for the system reliability, \( pdf \) and failure rate as a function of the component reliabilities.

To open the Equation Viewer, choose **Analysis > Tools > Show Algebraic Solution**.

or click the **Show Algebraic Solution** icon (…) on the control panel.

There are two ways to view the system reliability equation: as a symbolic equation or as the complete equation. When you are using the symbolic equation view, you can choose to view the reliability equation, the \( pdf \) equation or the failure rate equation for the system. The symbolic equation uses tokens to represent portions of the equation. If you use the symbolic equation view, you should read the solution from the bottom up, replacing any occurrences of a particular token with its definition. For example, consider the RBD shown next.

![RBD Diagram](image)

When this diagram is analyzed (without using identical block simplification), the symbolic reliability equation is:
Chapter 7: BlockSim Analytical Diagrams

We begin with Eqn. (3). This equation contains the token D1, which is defined in Eqn. (2). This is then substituted into Eqn. (3), yielding:

$$I_D = -R_B \cdot R_C + R_B + R_C$$  \hspace{1cm} (1)

$$D_1 = +R_A \cdot R_D \cdot I_D$$  \hspace{1cm} (2)

$$R_{System} = +R_E \cdot R_F \cdot D_1$$  \hspace{1cm} (3)

When you use the complete equation view, BlockSim automatically performs all token substitutions. In this view, you can view only the system reliability equation; the pdf equation and the failure rate equation are not available. You should be aware that in some cases, BlockSim may not be able to render the complete equation in the Equation Viewer even though it has internally computed it. This could happen if the memory available on your computer is...
insufficient and is therefore unable to construct the equation algebraically. This usually does not happen unless there are over one million terms.

**Note:** Due to the complexity of equations representing standby and load sharing configurations, BlockSim returns a single token for the reliability or failure rate of blocks in these configurations regardless of whether you are using the symbolic equation view or the complete equation view.

Select **Show Legend** to display the reliability characteristics for each block within the analyzed diagram. Select **Show Colors** to use color-coding in the window to make the equations easier to view. If you have made changes to these settings, click **Refresh** to update the contents of the window.

You can click **Add Equation to Attachments** to save the equation to the project attachments as an embedded *.rtf file.

## Cut Sets

Minimal cut sets are all the unique combinations of component failures that can cause system failure. Specifically, a cut set is said to be a minimal cut set if, when any basic event is removed from the set, the remaining events collectively are no longer a cut set. [Kececioglu, D., *Reliability Engineering Handbook*, Volume 2, Prentice Hall, Inc., New Jersey, 1991.]

Minimal cut sets have traditionally been used to obtain an estimate of reliability for complex RBDs or fault trees that cannot be simplified by a combination of the simple constructs (parallel, series, $k$-out-of-$n$). BlockSim has the capability to derive an exact analytical solution to complex diagrams and therefore does not utilize the cut sets methodology. Nevertheless, cut sets are provided in BlockSim for interested users.

Minimal cut sets can be used to understand the structural vulnerability of a system. The longer a minimal cut set is, the less vulnerable the system is to that combination of events. Also, numerous cut sets indicate higher vulnerability. Cut sets can also be used to discover single point failures (one independent element of a system that causes an immediate hazard to occur and/or causes the whole system to fail).

As an example, consider the fault tree shown next.
The system will fail if \{1, 2, 3 and 4 fail\} or \{1, 2 and 3 fail\} or \{1, 2 and 4 fail\}. All of these are cut sets. However, the one including all components is not a minimal cut set because, if 3 or 4 is removed, the remaining events are also a cut set. Therefore, the minimal cut sets for this configuration are \{1, 2, 3\} or \{1, 2, 4\}. This may be more evident by examining the RBD equivalent of the fault tree, as shown next.
As you can see, BlockSim considers this to be a single set with two subsets, each of which contains three blocks.

You can view the cut sets for an analytical diagram by choosing **Analysis > Tools > Show Cut Sets**.

The Cut Sets Setup window will appear, as shown next.

In the **Sort By** area, select the criterion you want to sort the cut sets by. You can select:

- **Size**: Cut sets will be shown in ascending order based on the number of blocks they contain.
Chapter 7: BlockSim Analytical Diagrams

- **Reliability** or **Unreliability**: Cut sets will be shown in ascending order of reliability or unreliability. Reliability is the probability that at least one block in the cut set survives. Unreliability is the probability that all blocks in the cut set fail. If you select either of these options, you must specify a time at which the reliability or unreliability is calculated and the units used for the time.

In the **Number of Cut Sets to Display** area, you can select to display all cut sets or specify the number of cut sets that will be shown.

In the **Other Options** area:

- **Show settings summary**: If selected, the diagram name and a summary of the settings chosen in the Cut Set Setup window will appear at the top of the cut sets display.

- **Show number of blocks in cut sets**: If selected, the number of blocks in each cut set will be shown in parentheses after the set number.

- **Include blocks without reliability models**: If selected, all blocks are assumed to be able to fail and are considered in cut sets. If not selected, it is assumed that any block without a reliability model assigned cannot fail and, as such, is excluded from consideration in cut sets.

Click **OK** to accept your selections and display the minimal cut sets in the Cut Sets window.

In addition to standard commands for cut, copy, paste and print, the toolbar in the Cut Sets window also provides the **Change Settings** button, which reopens the setup window so you can change the settings and regenerate the display.

**Analytical Quick Calculation Pad (QCP)**

BlockSim includes a Quick Calculation Pad (QCP) for computing useful metrics. You can access the QCP by choosing **Analysis > Analysis > Analytical QCP** or by clicking its icon on the Analytical page of the diagram control panel.

To perform a calculation, select the appropriate option and enter any required inputs in the **Input** area, then click **Calculate**. For more detailed information on how to use the QCP in general, see **Quick Calculation Pad (QCP)**.

The following calculations are available for analytical diagrams:
Chapter 7: BlockSim Analytical Diagrams

- **Probability**

  **Reliability**

  Calculates the probability that a new system will operate without failure for a given period of time. Enter the time at which you wish to calculate the reliability in the **Mission End Time** field. The mission is assumed to start at time \( t = 0 \).

  For example, a reliability of 90% for a mission end time of 3 years means that if 100 identical systems are fielded, then 90 of them will still be operating at the end of 3 years.

  **Note:** Reliability calculations are available even when the linked RBD or fault tree contains static blocks. If the diagram contains one or more static blocks (i.e., blocks that use a constant model), the mission end time for the static blocks is assumed to be equal to the time for which the fixed reliability value has been defined.

  **Probability of Failure**

  Calculates the probability that a new system will be failed in a given period of time. Enter the time at which you wish to calculate the probability of failure in the **Mission End Time** field. The mission is assumed to start at time \( t = 0 \).

  Probability of failure is also known as unreliability and it is the inverse of the reliability. For example, a probability of failure of 10% for a mission end time of 3 years is equivalent to a 90% reliability.

  **Conditional Reliability**

  Calculates the probability that a system will successfully operate at a specific time interval given that it has operated successfully up to a specified time. Enter the start time of the interval in the **Mission Start Time** field and enter the duration of the interval in the **Mission Additional Time** field.

  For example, a system may have a reliability of 90% for 3 years. If the system has operated for 2 years without failure, the conditional reliability for an additional year (for a total of 3 years of operation) may be 95%.

  **Note:** This assumes that all components start with the same accumulated age; that is, all components start life at 0 and age to the **Mission Start Time** value. It is possible to consider an individual component that has already accumulated some age (i.e., a used component) in the same formulation by changing the block's **Current Age** value in the Block Properties window.
Chapter 7: BlockSim Analytical Diagrams

**Conditional Probability of Failure**

Calculates the probability that a system will be failed at a specific time interval given that it has not failed up to a specified time. Enter the start time of the interval in the **Mission Start Time** field and enter the duration of the interval in the **Mission Additional Time** field.

For example, a product may have a 10% probability of failure for 3 years. If the product has operated for 2 years without failure, the conditional probability of failure for an additional year (for a total of 3 years of operation) may be 5%.

- **Life**

  **Reliable Life**

  Calculates the estimated time at which a specified reliability value will be achieved. Enter the reliability goal in the **Required Reliability** field. For example, a goal of 90% reliability with a reliable life of 4 years means that if 100 identical systems are fielded, then 90 of them will be still be operating at the end of 4 years.

  **What's Changed?** In previous versions of BlockSim, this calculation was called "Warranty Time."

  **BX% Life**

  Calculates the estimated time at which a specified probability of failure will be achieved. Enter the probability of failure in the **BX% Information At** field. For example, a B10 life of 4 years means that the system has a 10% probability of failure in 4 years of operation (note that this is equivalent to a 90% reliability with a reliable life of 4 years).

  **Note:** In the early days of reliability engineering, bearing manufacturers used the term "B10 life" to refer to the time by which 10% of the components would fail. Keeping with tradition, ReliaSoft retained this nomenclature but replaced "10" with "X," since the software allows you to get this information at any percentage point and not just at 10% (e.g., B1, B5, etc.).

  **Mean Life**

  Calculates the mean time to failure for the non-repairable system in the diagram.

  **Note:** The mean life is a performance index and does not provide any information about the behavior of the failure distribution of the system.
• **Rate**

  **Failure Rate**

  Calculates the instantaneous number of failures per unit time that can be expected at a certain time given that the system survives to that age. Enter the time at which you wish to calculate the failure rate in the **Time** field.

  For example, a failure rate of 0.01 at 100 hours means that a system that survives to 100 hours has approximately a 1% probability of failure in the next hour.

**Analytical Plots**

Plots can be created and viewed by clicking the **Plot** icon located on the Analytical page of the control panel for each diagram.

If you click the **Plot** icon before the diagram has been analyzed, it will automatically be analyzed and then the data will be plotted in the plot sheet. (Note that the **Plot** icon on the Plot sheet control panel refreshes the plot. If data or analysis settings have been changed since the diagram was last analyzed, you must reanalyze the data before refreshing the plot.)

You can add additional plot sheets to the diagram by right-clicking the sheet index tabs at the bottom of the window and choosing **Insert Analytical Plot** on the shortcut menu. You can delete a plot sheet from the diagram by selecting the plot sheet, right-clicking and choosing **Delete Plot**.

The plots available for analytical diagrams fall into three types:

**System Plots**

System plots display information about the entire system.

- **Unreliability vs. Time** shows the unreliability of the system over time. The unreliability value provides the probability that the event (failure) will occur by a specific time.

- **Reliability vs. Time** shows the reliability of the system over time.

- **pdf Plot** shows the system's probability density function, which illustrates the behavior of the life distribution function. Direct probability or reliability values cannot be read from this plot. The area below the plotted line, starting at time zero and ending at the value on the x-axis, is the probability of failure by that time.

- **Failure Rate vs. Time** shows the system's failure rate over time. The failure rate is the number of failures occurring per unit time.
Metrics Plots

Metrics plots display information about the reliability importance of the blocks in the system.

- **RI vs. Time** shows the reliability importance of the blocks in the system over time. Reliability importance is a measure of the relative importance of each component in a system with respect to the overall reliability of the system.

- **Static RI** shows the static reliability importance and the reliability of a specified number of blocks in the system at a specific time. To view this plot, you must specify the time at which the reliability values are calculated and the number of blocks to display. The plot will show the blocks with the highest reliability importance (e.g., if you specify to show five blocks, the plot will show the five blocks with the highest reliability importance). Bar size indicates reliability importance; bar color indicates reliability, as shown in the legend. Point to a bar to view the block's name, reliability and calculated importance.

- **Static RI Tableau** shows the static reliability importance of the blocks in the system at a specific time in tableau format, along with each block's reliability. To view this plot, you must specify the time at which the reliability values are calculated. The block name appears on each area of the plot. The largest sections represent the blocks with the highest reliability importance; section color indicates block reliability, as shown in the legend. Point to a plot section to view the block's name, reliability and calculated importance.

Blocks Plots

Blocks plots display information about the individual blocks that make up the system.

For blocks plots, when you first select the plot, you must specify which blocks to include by using the **Available Blocks** area of the control panel to select which blocks to view. You can also view the corresponding system values by selecting the **Show System** check box.

- **Block Unreliability** shows the unreliability of the selected blocks plotted against time. The unreliability value provides the probability that the event (failure) will occur by a specific time.

- **Block Reliability** shows the reliability of the selected blocks plotted against time.

- **Block pdf** shows the probability density function of the selected blocks plotted against time.

- **Block Failure Rate** shows the failure rate over time of the selected blocks plotted against time. The failure rate is the number of failures occurring per unit time.

Note that confidence bounds are available for the Unreliability vs. Time, Reliability vs. Time and Failure Rate vs. Time plots in cases where all blocks that can fail in the diagram use models that have Fisher matrix bounds. To have Fisher matrix bounds, a model must have been created by...
publishing from a data source, such as a Weibull++ or ALTA data sheet, that was calculated using Fisher matrix bounds. Additionally, bounds are not available if the diagram has containers, subdiagrams or mirrored blocks, or if any block uses the cumulative damage model. Where applicable, you can add confidence bounds to a plot by choosing **Plot > Confidence Bounds > Confidence Bounds**.
Chapter 8: BlockSim Simulation Diagrams

In contrast to analytical diagrams, simulation diagrams can take into account repair and restoration actions, including behaviors of crews, spare part pools, throughput, etc. These actions mean that the age of system components is no longer uniform nor is the operation time of the system continuous. If one includes information on the repair and maintenance characteristics of the components and resources available in the system, other information can also be analyzed/obtained, such as system availability, throughput, spare parts utilization, life cycle costs etc. This can be accomplished through discrete event simulation.

In simulation, random failure times are generated from each component's failure distribution. These failure times are then considered in accordance with the way the components are reliability-wise arranged within the system. The overall results are analyzed in order to determine the behavior of the entire system.

The advantages of the simulation approach are:

- It can be used for highly complex scenarios involving a multitude of probabilistic events, such as corrective maintenance, preventive maintenance, inspections, imperfect repairs, crew response times, spare part availability, etc. When events such as these are considered, analytical solutions may become impossible when dealing with complex systems.

- Discrete event simulation also has the capability of:
  - Examining resource utilization, efficiency and costs.
  - Optimizing procedures and resource allocation.
  - Analyzing relationships between systems and components.
  - Maximizing throughput.
  - Minimizing work downtimes.

The disadvantages of the simulation approach are:

- It can be time-consuming.
- The results are dependent on the number of simulations.
- There is a lack of repeatability in the results due to the random nature of data generation.
For these reasons, if your scenario and/or results of interest do not require you to use a simulation diagram, it is recommended that you use an analytical diagram.

**Available Analyses**

Repairable system analysis via simulation focuses on maintainability/availability analysis. Additional related analyses made possible by using simulation include throughput analysis and life cycle cost analysis.

Results relevant to these analyses are available in several different locations:

- The [Results Explorer](http://blocksim.reliasoft.com) provides a comprehensive set of metrics on the system, blocks, crews and spare part pools, including results relevant to maintainability/availability, costs and throughput.

- The [simulation Quick Calculation Pad (QCP)](http://blocksim.reliasoft.com) provides quick access to some of the most frequently requested reliability results. These include mean and point availability/unavailability, point reliability/probability of failure, mean time to first failure and time at which a certain availability or reliability will be shown.

- A wide variety of [plots](http://blocksim.reliasoft.com) help you to visualize the simulation results. These include plots pertaining to the system, blocks, crews and spare part pools, offering information about maintainability/availability, costs, throughput and resource utilization.

**Maintainability/Availability Analysis**

Maintainability is defined as the probability of performing a successful repair action within a given time. In other words, maintainability measures the ease and speed with which a system can be restored to operational status after a failure occurs. For example, if it is said that a particular component has a 90% maintainability in one hour, this means that there is a 90% probability that the component will be repaired within an hour. In maintainability, the random variable is time-to-repair, in the same manner as time-to-failure is the random variable in reliability.

Availability is a performance criterion for repairable systems that accounts for both the reliability and maintainability properties of a component or system. It is defined as the probability that the system is operating properly when it is requested for use. That is, availability is the probability that a system is not failed or undergoing a repair action when it needs to be used.

Throughput Analysis

Throughput is the amount of output that can be processed in a given period of time. Please refer to the Throughput Analysis topic for more information.

Life Cycle Cost Analysis

A life cycle cost analysis examines the costs incurred by a system or a component over its entire life span. Typical costs for a system may include:

- Acquisition costs (or design and development costs).
- Operating costs:
  - Cost of failures (e.g., contractually-specified penalties, risk of damage to equipment or people, etc.)
  - Cost of repairs.
  - Cost for spares.
  - Downtime costs (e.g., contractually-specified restitution).
  - Loss of production.
- Disposal costs.

A complete life cycle cost (LCC) analysis may also include other costs (such as the initial costs of land, equipment and/or installation), as well as other accounting/financial elements (such as discount rates, interest rates, depreciation, present value of money, etc.). With respect to the cost inputs for such an analysis, the costs involved are either deterministic (such as acquisition costs, disposal costs, etc.) or probabilistic (such as cost of failures, repairs, spares, downtime, etc.). Most of the probabilistic costs are directly related to the reliability and maintainability characteristics of the system. To perform life cycle cost analysis in BlockSim, you will need to provide cost information in all relevant fields. Additional inputs relating to downtime may also be required, depending on your system. The ReliaWiki resource portal has more information on life cycle cost analysis at:

http://www.reliawiki.org/index.php/Additional_Analyses#Life_Cycle_Cost_Analysis.

Throughput Analysis

Throughput is the amount of output that can be processed in a given period of time. To understand system throughput, consider this example: Assume that each component in the system processes (or makes) something while operating. The RBD shown next contains two components in series, each processing/producing 10 and 20 items per unit time (for explanation purposes, we will call that "ipu") respectively.
In this case, the system configuration is not only the system's reliability-wise configuration but also its production/processing sequence. In other words, the first component processes/produces 10 ipu and the second component can process/produce up to 20 ipu. However, a block can only process/produce items it receives from the blocks before it. Therefore, the second component in this case is only receiving 10 ipu from the block before it. If we assume that neither component can fail, then the maximum items processed from this configuration would be 10 ipu. If the system were to operate for 100 time units, then the throughput of this system would be 1,000 items, or (100 x 10).

Throughput analysis can be performed for simulation RBDs. Results are available at the block and system levels, taking into account the reliability and maintenance properties of the blocks and the system. In order to perform throughput analysis, you must specify throughput properties in the Block Properties window for the relevant blocks and select the Run Throughput Simulation option on the Analysis Settings page of the diagram's control panel.

Note: While throughput analysis is not available for fault trees, fault trees may be used as subdiagrams for simulation RBDs. To perform throughput analysis in this case, you would define throughput properties for the subdiagram in the Block Properties window for the subdiagram block. In simulation, the fault tree is simulated and determined to be up or down. If it is down, no throughput is passed to the next block in the RBD; if it is up, then the throughput properties defined for the subdiagram block determine the amount of throughput passed to the next block.

In many real-world cases, throughput can change over time (i.e., throughput through a component is not a constant, but a function of time). You can model variable throughput using phase diagrams.

Throughput and Mirrored Blocks
Simulations that contain both mirrored blocks and throughput analysis behave in the following way:

- **System availability**: All blocks within a mirror group will be considered the same block for system uptime/downtime analysis. This means that if the block fails, it will be considered a downed block everywhere that the mirrored block is found.

- **System throughput**: The mirrored block throughput is NOT divided between each of the locations within the system diagram. Each instance of the mirrored block can process the amount of throughput assigned to the block.
**Example**
Imagine a system where block A and block C each have a throughput of 300 units/hour, while block B (mirrored block) and block D each have a throughput of 100 units/hour.

If all the blocks are operating, then the system throughput is 300 units/hour, as each instance of block B is able to handle 100 units/hour.

If block B is down, then the system throughput becomes 100 units/hour, as block B is considered down at both locations.

**Block Throughput Properties**
The Throughput properties are available in the Block Properties window for all block types in simulation RBDs except contained blocks. These fields allow you to define the characteristics of the block that pertain to analyzing the throughput, which is the amount of output the block can process in a given period of time.
The **Throughput** field allows you to enter the quantity of output and the units used for time. In addition, the **Allocation** field allows you to specify how that output is routed if multiple outgoing paths from the block exist:

- **If Weighted allocation across paths** is selected, the allocation will be weighted according to the capacity of each block if there is more than one block that can receive the units. The software calculates the total capacity of all possible paths and then determines the percentage of the total capacity represented by each block. It then sends that percentage of the "stream" to each block. For example, if 3 blocks can receive 9 units and Block A can process 5 units, Block B can process 5 units and Block C can process 10 units, then Block A receives 25% \((5 + 5 + 10 = 20 \text{ and } 5/20 = 0.25)\) of the stream \((9 * 0.25 = 2.25)\), Block B receives 25% \((5/20 = 0.25)\) of the stream \((2.25)\) and Block C receives 50% \((10/20 = 0.5)\) of the stream \((4.5)\).

- **If Allocate equal share to all paths** is selected, an equal share of units will be allocated to each of the blocks if there is more than one block that can receive the units. In the example described above, each of the 3 blocks would receive 1/3 of the stream, or 3 units. This option may result in a backlog if any blocks cannot process their entire allocation.

If there is more than one block that can receive units and one of those blocks has failed, the units will form a backlog for the failed block if the **Send units to failed blocks** option is selected. If it is not selected, the failed block will not receive any of the units and the entire stream will be distributed among the unfailed blocks. For example, in the first scenario, if Block B fails and the user has not selected to send units to failed blocks, then Blocks A and C will both receive 4.5. If this option is selected, then all three blocks will receive 3 units and a backlog will begin to build up for Block B.

Units that a block cannot process, either because it is failed or because the units are in excess of its processing capacity, are kept in backlog. The **Process/ignore backlog** field allows you to specify whether backlogged units, if any, are processed or ignored. The **Ignore backlog** option is appropriate for modeling a configuration where backlog cannot accumulate, whereas the **Process backlog** option models a configuration where backlog may accumulate.

The use of these options interacts with certain other settings. Specifically:

- **If the block is set to process backlog, then backlog is accumulated in two cases:**
  1. All outgoing blocks are failed and the block itself does not have the **Send units to failed blocks** option selected.
  2. The block receives more units than it can process, either because it receives more than its capacity or because it is failed and the previous block sends throughput to failed blocks.
• If the block is set to ignore backlog, and one of the two cases above is true, then the throughput will still technically be stored as backlog but will never be processed. In practical terms this is equivalent to ignoring backlog.

If you have selected to process backlog, you can select the **Limited backlog** option to place a limit on the number of units that can be stored in the backlog. Once the limit that you specify is reached, no additional units are added to the backlog.

For subdiagram blocks, the **Throughput properties** field allows you to specify how you want throughput for the block determined in simulation. You can choose to use the throughput properties defined in the subdiagram that the block represents or to use throughput properties defined on this page. This option is available only if the subdiagram is an RBD, because fault trees do not have throughput properties. If you select the **Use throughput properties as defined at this level** option, the **Throughput**, **Allocation** and **Send units to failed blocks** fields will appear.

---

**Universal Reliability Definitions (URDs) in Simulation Diagrams**

In simulation diagrams, the **universal reliability definitions** (URDs) assigned to blocks define reliability and maintenance characteristics. Each URD is a resource that can be shared among analyses and can include two other types of resources:

• **Models** are resources that represent behavior over time. In URDs, they are used to define failure behavior.

• **Tasks** describe the conditions that determine when maintenance actions will be performed on a block. Tasks specify the logistical time and costs associated with those actions as well as their anticipated effectiveness (i.e., how much the component will be restored). Tasks may be configured to use three other types of resources:
  
  • Tasks use models to describe how long the task takes.
  
  • **Crews** describe the conditions that determine when personnel will be available to perform specific tasks. These resources also specify the logistical time and costs associated with engaging the crew.
  
  • **Spare part pools** describe the conditions that determine whether a spare part will be available when needed. These resources also specify the logistical time and costs associated with obtaining the spare part.

A URD can have one corrective task and/or one or more scheduled tasks. Scheduled tasks are displayed in their priority order, which is the order in which they will be performed;
you can use the up and down arrows in the cells in this column to move the task up and down the priority list.

**Multiple Tasks on the Same Block**

Certain additional simulation assumptions apply when multiple tasks (i.e., corrective, preventive, inspection and/or on condition tasks) apply to the same block:

- Downing events cannot overlap. For example, if a component is down due to preventive maintenance and a trigger suggests another preventive task, the suggestion is ignored.

- Non-downing events can overlap with Downing events if they start at different times, provided that the non-downing event starts first. If the Downing event starts first, then the non-downing event is ignored. If they start concurrently, the task with the highest priority will be performed.

- Preventive tasks and inspections cannot occur at exactly the time that the block or system comes up from another preventive task or inspection.

- If multiple tasks are scheduled to occur at the same time for a block, only one of the tasks will be performed and the others will be ignored. Tasks are prioritized as follows:

  1. Tasks based on events in a maintenance group, where the triggering event applies to a block
  2. Tasks based on system down
  3. Tasks based on events in a maintenance group, where the triggering event applies to a subdiagram

If there is also a task based on interval scheduled to occur at the same time, the interval-based task OR the task highest in this priority list may be performed.

- If a failure or preventive task occurs during a non-downing inspection, and the corrective task or the preventive task has a restoration factor, and the inspection task has a restoration factor, then both restoration factors are used (compounded).

- If a corrective task is scheduled to be performed upon inspection and a preventive task occurs first, the preventive task will restore the block.

- If a corrective task is scheduled to be performed upon inspection and a failure or preventive task occurs during a non-downing inspection, the restoration is compounded.
Spare Part Pools - Simulation Assumptions

The underlying simulation assumptions for spare parts are:

- Spare parts are always required for corrective and preventive tasks.
- If a spare part pool has not been assigned to the task, then it is assumed that unlimited free spares are always available.
- Spare parts are never required for inspection tasks.
- All restocking that occurs during simulation is based on the settings of the spare part pools.
- If the **Restock as needed** check box is selected, a restock will be triggered every time a part is taken from the spare part pool and the number of items in the pool drops below the limit specified in the **Restock when stock drops to** field.
- If the **Scheduled Restock** and **Restock as needed** check boxes are selected, then if a spare part from a scheduled restock can arrive before a spare part from an on condition restock, the spare part from the on condition restock will be ordered but will not be used in the maintenance task.
- A block that triggers an emergency restock is charged for the additional emergency cost, even if it did not use the restock part(s) (e.g., another part became available from a scheduled restock first).
- The average stock level (ASL) metric in the simulation results is based on how many times the stock level was determined (e.g., every time a request is made, whether it is rejected or accepted, etc.). The average stock level is recorded at the beginning and at the end of each simulation.
- Off-site spare parts are ordered regardless of whether they will arrive before the simulation end time. This means:
  - When a block orders a spare part from an off-site pool, the part is ordered (and the block is charged for it) without regard to arrival time.
  - Off-site emergency spare parts will be ordered by both on-site and off-site pools without regard to arrival time.
  - On condition restock from off-site pools will be performed without regard to arrival time.
Chapter 8: BlockSim Simulation Diagrams

Simulation Diagram Control Panel
The control panel associated with BlockSim simulation diagrams consists of multiple pages, each containing options for performing particular tasks. This topic focuses on the Simulation, Analysis Settings and Drag & Drop URDs pages of the simulation diagram control panel, which contain most of the tools you will need to build and simulate a diagram. For more information about the control panel in general, see Control Panels.

Control Panel Simulation Page
The Simulation page of the control panel for simulation diagrams contains the following options:

- **The Simulation area** displays the status and results of the simulation.

- **Status** If the light is green, then the simulation has been performed. If the light is red, then the simulation has not been performed. A simulated diagram will remain in the simulated state unless a change is made to the diagram (e.g., a block is added, a connector is removed, a model is changed, etc.).

- **Show Simulation Details (...)** displays the most recently generated simulation results in the Results Explorer.

- **Distribution fit** displays the distribution that has been fitted to the simulation results. Click the button (...) to open the Distribution Estimator to fit a distribution and/or for information on the fitted distribution parameters. The fitted distribution can be used to describe the overall behavior of the system and can be published for use as a model elsewhere in the project.

- **The Information area** displays information about the diagram or the currently selected block. If no block is selected in the diagram, the Information area displays the number of blocks in the diagram and information about the diagram creation and last modification; in addition, if the diagram results have been published as a model, the name of the model will appear as a link allowing you to view the model in the Synthesis Viewer window. If a block is selected in the diagram, it displays a subset of the properties found in the Block Properties window. Items in the table that are resources (e.g., models, switches, etc.) are links; you can click such items to view and/or edit their properties. In both cases, this area also offers a Comments field; click the field heading...
to enter comments. For blocks, these comments are also accessible in the Identifiers properties in the Block Properties window.

- The **Tools** area on the left side of the control panel gives you quick access to the tools you will need to analyze the diagram and generate additional results.

  - **Simulate** opens the Maintainability/Availability Simulation window, which allows you to obtain reliability, maintainability, availability and throughput results from simulations.

  - **Plot** creates a plot based on the simulation results. Clicking the **Plot** icon before the diagram has been simulated will automatically perform the simulation and then plot the data.

  - **Simulation QCP** opens the simulation Quick Calculation Pad (QCP). The QCP allows you to obtain reliability, maintainability and availability metrics based on the simulation results. Clicking the **QCP** icon before the diagram has been simulated will automatically perform the simulation and then open the QCP.

  - **Change Diagram Type** changes the current diagram to the opposite diagram type (i.e., changes the current analytical diagram to a simulation diagram, or the current simulation diagram to an analytical diagram). Note the following:

    - Your most recent selection for the **Perform the same change to any subdiagrams** option in the Change Diagram Type window (Diagram > Diagram Actions > Change Diagram Type) will be used in this change.

    - If you create an analytical diagram from a simulation diagram, by either duplication or conversion, the maintenance and throughput characteristics defined in the simulation diagram will not be displayed in the analytical diagram, as they are not relevant to the analysis. However, the properties are not lost, and if you then create a simulation diagram from that analytical diagram, all original properties will be retained.

    - If you prefer to create a new diagram using the new type, use the Change Diagram Type window instead.
Control Panel Analysis Settings Page
The Analysis Settings page of the control panel for simulation diagrams contains the following options:

- **Analysis Settings**
  - Select **Report subdiagram results** to provide calculated results for subdiagram blocks in the Results Explorer and certain plots. If this check box is not selected, subdiagram blocks will not appear in the results.
  - **Use system downtime threshold** allows you to specify a minimum amount of time that the system must be down in order for it to count toward critical downtime metrics.
  - Select **Run throughput simulation** to perform the throughput simulation, which allows you to perform analyses on the number of units that can be processed by the system in the diagram during the simulation time. If you select to run a throughput simulation, you can select **Report throughput point results** to include throughput results in the System Point Results worksheet, which provides results at specified points in time. If this check box is not selected, only the throughput results for the system at the simulation end time will be reported.

- **Report Settings**
  - **Report folio model** allows you to specify the results model that will be used when the diagram is used as the default data source for a Synthesis Workbook. You can choose to use either the simulation results or the fitted model.
  - **Max RDA data** allows you to specify the maximum number of events that can be shown in the RDA Data worksheet in the Results Explorer. The contents of the RDA Data worksheet can be transferred to a parametric RDA folio in Weibull++ for further analysis.

- **System Level Costs**
  - **Cost per System Downing Event** allows you to specify, for every event that brings the system down, a cost per incident at the system level (i.e., an additional cost that is not accounted for by any of the block level costs).
  - **System Downtime Rate** allows you to specify a cost per unit time for downtime at the system level (i.e., an additional cost that is not accounted for by any of the block level costs).
• **System Level Revenue**
  
  • **Revenue per [Unit] of Uptime** allows you to specify an amount of revenue that is brought in by the system for each unit of uptime. This can then be accounted for as a loss when the system is down.
  
  • **Revenue per Unit Produced** allows you to specify an amount of revenue that is brought in for each unit produced. This can then be accounted for as a loss when the system is down. This option is available only when you have selected the **Run throughput simulation** option in the **Analysis Settings** area of this control panel page.

**Control Panel Drag & Drop URDs Page**

The Drag & Drop URDs page is available in the control panel for analytical and simulation diagrams, including fault trees. It provides a list of the **URDs** that are available for use by blocks in the diagram. Drag a URD into the diagram to create a standard block/event that uses the URD.

The list of URDs can be filtered using the same **resource filter** that is available in many other locations throughout Synthesis desktop applications.

**Maintainability/Availability Simulation**

BlockSim's simulations are based on the component characteristics and the reliability-wise system configuration of the diagram. To simulate a diagram, choose **Simulation > Simulation > Simulate** or click the **Simulate** icon.

The Maintainability/Availability Simulation window will open.

The Maintainability/Availability Simulation window allows you to specify the settings to be used in simulating an RBD or fault tree. In addition, it displays the progress of the simulation in the area at the top of the window.
There are two basic types of simulation that you can perform: **standard simulations** and **log of simulations**.

- When you perform standard simulations, the metrics in the Results Explorer are obtained by calculating the average of the results from all of the simulation runs.

- Saving a log of simulations, on the other hand, provides a set of individual simulation results that can be used to analyze variability within the simulation results and a set of average results in the Results Explorer.

For more information about how you might use the log of simulations, please read "An Application of BlockSim's Log of Simulations" at: [http://www.weibull.com/hotwire/issue97/relbasics97.htm](http://www.weibull.com/hotwire/issue97/relbasics97.htm). (Note that this article uses BlockSim 7, but the theory remains the same.)

In addition to having different purposes, the simulations are based on different randomly generated numbers. To understand this, suppose you are interested in the reliability/maintainability performance for a system and you want to use simulation to estimate useful metrics, such as the mean availability and the total expected downtime after 1,000 hours of operation.

Assume that you run 100 simulations for the 1,000 hour mission time using standard simulations and a seed of 1. In this case, the simulation routine will draw from a single stream of randomly generated numbers, generated using the seed of 1, for the series of 100 simulations. Therefore, the results will be **reproducible** if you perform the exact same set of simulations again, using the same seed, for the exact same diagram.

Now suppose that you want to perform a more in-depth exploration that will help you to analyze the variability within the simulation results. For that purpose, let's assume that you select to save a log of simulations using 100 seeds with a starting seed of 1. BlockSim will perform one simulation using the seed of 1, then will increment the seed by 1 and perform a second simulation using a seed of 2 (1 + 1 = 2), and so on until the utility has performed 100 separate simulations. In this case, each simulation draws from a separate stream of randomly generated numbers. The first simulation will utilize a stream with seed = 1, the second simulation will utilize a stream with seed = 2, and so on. Because of this, the average results that are shown in the Results Explorer when you have selected to save a log of simulations will not be the same as those that are shown when you have performed basic simulation.

To perform each of these types of simulation, select the simulation type in the **Advanced Options** drop-down and then do the following:

- For all simulation types:
  - Enter the **Simulation End Time**. Specify the time and the units of time used. Unless you have selected the **Standard Simulations - Interval** simulation type,
simulations begin at time = 0. In these cases, the simulation end time is equivalent to the duration of the simulation.

- In the **Point Results Every** field, specify the frequency at which the simulation will return results. For example, if you have entered **100 hours** in the **Simulation End Time** field and you enter **10 hours** in the **Point Results Every** field, the simulation will run from 0 to 100 hours and point results will be available at 10 hours, 20 hours, 30 hours and so on.

In addition:

- For standard simulations with a fixed number of simulations:
  - Enter the **Number of Simulations** to be performed.
  - If you need your results to be repeatable, select the **Use a Seed** check box in the **Advanced Options** drop-down and enter a seed, which specifies a starting point from which the random numbers used in simulation will be generated. The same random numbers and, therefore, the same simulation results will be generated when the same seed value is used.

- For standard simulations with a variable number of simulations:
  - Specify the **Maximum Number of Simulations** to be performed.
  - In the **Convergence Criteria** field, specify the standard deviation for a key simulation result. The simulation will continue until this standard deviation target is reached in the simulation results or until the maximum number of simulations have been performed, whichever comes first.
  - If you need your results to be repeatable, select the **Use a Seed** check box in the **Advanced Options** drop-down and enter a seed, which specifies a starting point from which the random numbers used in simulation will be generated. The same random numbers and, therefore, the same simulation results will be generated when the same seed value is used.

- For standard simulations over a specified interval of time:
  - Enter the **Simulation Start Time**. Specify the time and the units of time used. The simulation duration will be equal to **Simulation End Time - Simulation Start Time**.
  - Enter the **Number of Simulations** to be performed.
  - If you need your results to be repeatable, select the **Use a Seed** check box in the **Advanced Options** drop-down and enter a seed, which specifies a starting point from which the random numbers used in simulation will be generated. The same
random numbers and, therefore, the same simulation results will be generated when the same seed value is used.

- For log of simulations:
  - Specify the **Number of Seeds** to be used (i.e., the number of simulations).
  - Clicking the **Select Results** link opens the Select Results window, which allows you to select the items you want to log individual simulation results for and select which results for those items you want to save in the log.

In the **Options** area, you can select or clear individual results or select/clear the check box for a result category to select/clear all of the results in that category. You also can select or clear all results by selecting/clearing the Options check box.

In the lower left corner of the window, click the button corresponding to the desired item type to open a window that allows you to select the items of that type for which results will be saved in the log. For example, click **Select Blocks** to open the Select Blocks window. To select a block so that results for it will be saved in the log, select the box next to the block’s name and click **OK**. Selecting or clearing the check box beside the category name will select or clear all of the items.
Chapter 8: BlockSim Simulation Diagrams

If you have selected to save a block result, crew result or pool result, you must specify at least one item of the corresponding type to save results for. For example, if you have selected to save block downtime results but have not selected any blocks to save results for, a warning message will appear telling you that there are no results to be displayed. Click OK and select a block.

- In the **Log of Simulations Results** area, select whether you want the log sent to Excel or saved as a tab-delimited text file. If you save the log as a tab-delimited text file, you can choose to save it as an embedded attachment within the project or you can click **Browse** to specify an external location and filename for the file.

- If you need your results to be repeatable, select the **Use Starting Seed** check box in the **Advanced Options** drop-down and enter the seed to be used for the first simulation. This specifies a starting point from which the random numbers used in the simulation will be generated. The same random numbers and, therefore, the same simulation results will be generated when the same seed value is used. BlockSim will perform one simulation using the starting seed, then will increment the seed by 1 and perform a second simulation using that seed and so on until the utility has performed the number of simulations specified in the **Number of Seeds** field.

For any simulation type, you can run simulations in multiple threads, which may improve performance and save time when simulating complex diagrams. The **Number of Threads** field in the **Advanced Options** drop-down allows you to specify the number of threads to use for simulation. In general, using twice as many threads as the number of cores in your computer is appropriate; a ratio of threads to cores greater than this 2:1 ratio is likely to degrade performance. To have the application automatically determine the number of cores in your system and set the number of threads accordingly, click the **Calculate** icon beside the **Number of Threads** field.

The number of threads you use affects repeatability of results. In order for your results to be repeatable, you must use the same number of threads and the same seed each time you simulate the diagram. When you are using multithreading, the seed that you specify in the **Advanced Options** drop-down is the seed for the first thread; seeds for additional threads are sequential (e.g., if you are using 3 threads and your starting seed is 7, the threads will use 7, 8 and 9 as the starting points for random number generation).

The **Analysis Settings** link at the bottom of the Maintainability/Availability Simulation window displays a message that shows the settings you have specified on the **Analysis Settings page** of the diagram's control panel. These settings determine whether subdiagram results will be included in the results; whether a throughput simulation will be performed and, if so, whether
point results will be reported; and whether a system downtime threshold has been specified. You can edit these settings via the diagram's control panel.

The area at the top of the Maintainability/Availability Simulation window displays the status of the simulation.

During simulation, you can click Cancel to stop the simulation at the current point. The results will be provided for the simulations (if any) that were completed before you stopped the process. When simulation is complete, you can click the Details button to view the results of the simulation in the Results Explorer. Click the Simulate button to re-run the simulation.

**Note:** Once you have simulated a diagram, the settings you have specified in the Maintainability/Availability Simulation window are saved along with the diagram so that you or another user can easily simulate the diagram again using the same settings. The first time you simulate a diagram, the settings default to the settings used for the last simulation that was performed on your computer.

## Simulation Status Display

The area at the top of the Maintainability/Availability Simulation window displays the status of the simulation.

The following numerical information is always shown:

- **Seed Value** displays the seed value used or, for log of simulations, the starting seed value.
- **ETC** displays the expected date and time of completion for the simulation.
- **Current** displays the current date and time during the simulation. Once all simulations have been performed, this value will display the actual time of completion.

In addition, the current mean availability is shown at the top of the simulation status display. The current number of simulations performed out of the total number of simulations scheduled.
to be performed (or, in the case of a variable number of simulations, the maximum number of simulations) is shown at the bottom of the simulation status display (e.g., 10 out of 100 simulations).

If you have selected **Full Display** in the **Display Options** drop-down, a plot will also be shown in the simulation status display. This plot shows, for each simulation, the difference between the previous mean availability and the current mean availability, as a percentage of the current mean availability. For example, consider the following table:

<table>
<thead>
<tr>
<th>Current Simulation</th>
<th>Availability in Current Simulation</th>
<th>Mean Availability Through Current Simulation</th>
<th>Value Shown in Simulation Convergence Plot</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.8</td>
<td>0.8</td>
<td>-</td>
</tr>
<tr>
<td>2</td>
<td>0.9</td>
<td>0.85</td>
<td>0.059</td>
</tr>
<tr>
<td>3</td>
<td>0.8</td>
<td>0.833</td>
<td>-0.02</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>0.875</td>
<td>0.048</td>
</tr>
<tr>
<td>5</td>
<td>0.8</td>
<td>0.86</td>
<td>-0.017</td>
</tr>
<tr>
<td>6</td>
<td>0.6</td>
<td>0.817</td>
<td>-0.053</td>
</tr>
<tr>
<td>7</td>
<td>0.7</td>
<td>0.8</td>
<td>-0.021</td>
</tr>
<tr>
<td>8</td>
<td>0.9</td>
<td>0.813</td>
<td>0.015</td>
</tr>
<tr>
<td>9</td>
<td>1</td>
<td>0.833</td>
<td>0.025</td>
</tr>
<tr>
<td>10</td>
<td>0.7</td>
<td>0.82</td>
<td>-0.016</td>
</tr>
</tbody>
</table>

To understand how these values are obtained, we can look at simulation 3 as an example. The mean availability at the end of simulation 3 is the average of the availability in simulation 1, simulation 2 and simulation 3, or (0.8 + 0.9 + 0.8) / 3 = 0.833. The value shown in the convergence plot is obtained by subtracting the previous mean availability from the current mean availability and then dividing that number by the current mean availability: (0.833 - 0.850) / 0.833. In this case, this yields a negative value, because the current mean availability is less than the previous mean availability.
The table above would result in the following convergence plot:

As additional simulations are performed, the general pattern is that the mean availability values start to converge, and the line in the convergence plot stabilizes to a straight line. After this point, additional simulations are not especially beneficial.

You can use the Resolution field in the Display Options drop-down to specify the scaling of the convergence plot. The larger the number, the greater the range of values shown on the y-axis of the plot. The Update Increments field specifies how many times the label below the plot, reflecting the current number of simulations performed out of the total number of simulations, will be updated during the simulation process.

The following additional information is also displayed when Full Display is selected:

- **Std** shows the current value in the convergence plot (i.e., the value obtained by subtracting the previous mean availability from the current mean availability and then dividing that number by the current mean availability).

- **Resolution** shows your choice for the scaling of the plot.

A Note About Repeatability of Results Under Simulation

Results obtained through repeated simulations of the same diagram will exhibit some variability because they depend on the randomly generated numbers that are selected for any given simulation run. The use of a seed in simulation forces the software to use the same sequence of random numbers in each simulation, resulting in repeatability. However, you need to be aware
that when you use a seed, the same stream of random numbers is utilized, but the order of the
utilizations of the stream may differ. This is dependent on the way the diagram was constructed
and, for RENO flowcharts, the order in which RENO functions and static functions were created.
The random numbers are assigned based on an internal ID number assigned to each block or
resource when it was created. For blocks, you can display these internal IDs in the diagram by
choosing a display format for the Block ID option on the Background and Grid page of the
Diagram Style Window.

For example, two people may have projects containing identical diagrams using blocks A and B.
If in one diagram, A was created before B, A will take the first random value from the stream
and B will take the second. If the other person (in the other project) created the same diagram
but created B before A, B will take the first random value from the stream and A will take the
second, thus yielding potentially different answers, even though both analysts may have used
the same seed in simulation. Note that as the number of simulations increases, this difference
will be less significant.

Simulation Batch Mode
BlockSim offers a simulation batch mode, which allows you to simulate multiple diagrams
consecutively, without user input in between simulations. This enables you to set up a series of
simulations and then turn your attention elsewhere, which may be particularly helpful when
you need to simulate several very large diagrams.

To use the simulation batch mode, choose Simulation > Tools > Batch Mode.

The Batch Mode Simulation window appears; this window displays a list of the available
simulation diagrams in the current project (i.e., simulation RBDs, simulation fault trees and
phase diagrams). Select the diagrams that you want to simulate; you can select the check box in
the Available Diagrams header to select all diagrams.

Each diagram that is selected for simulation in batch mode must have its own simulation
settings defined, including:

- The settings specified on the Analysis Settings page of the diagram's control panel.
  These settings determine whether subdiagram results will be included in the results;
  whether a throughput simulation will be performed and, if so, whether point results will
  be reported; whether a system downtime threshold has been specified; and additional
  system level costs and revenue values.

- The settings specified in the Maintainability/Availability Simulation window. These
  settings include the simulation end time, point results intervals, the number of
  simulations to be performed, repeatability options and multithreading options.
Chapter 8: BlockSim Simulation Diagrams

For diagrams that have previously been simulated, the most recent simulation settings are retained. For diagrams that have not yet been simulated, you will need to define these settings. A status light is shown for each available diagram. If the light is green, simulation settings have been defined for the diagram. If it is red, settings have not yet been defined or are not compatible with batch mode (e.g., the last simulation run was a log of simulations, which is not available in batch mode). To define the simulation settings for one or more diagrams, highlight the diagram row(s) and then click the **Edit Simulation Settings** button at the bottom of the window.

The Batch Mode Simulation Settings window will appear, allowing you to define the settings (this window is a shortened version of the Maintainability/Availability Simulation window, lacking the simulation status display). The settings you define here will be applied to all of the diagrams that were highlighted in the Batch Mode Simulation window. If you want to apply the settings to all of the diagrams that are selected to be run in the batch simulation (i.e., the "checked" diagrams), select the **Apply settings to all highlighted and selected diagrams** check box. Click **OK** to save the settings for the diagram and return to the Batch Mode Simulation window. If you need to adjust the settings specified on the **Analysis Settings page** of the diagram's control panel, you must exit the Batch Mode Simulation window and adjust the settings for the diagram. Note that if you do not define simulation settings for all diagrams selected to be run in the batch simulation, then when you begin to run the simulations, the Batch Mode Simulation Settings window will be shown for each diagram that needs simulation settings.

**Note:** The log of simulations simulation type is not available in batch mode.

Click **Run** to run the simulations. The Batch Mode Simulation window will change to show the status of the simulations, as shown next. While simulation is in progress, you can click **Skip** to stop simulating the current diagram and move on to the next one or **Cancel** to stop the simulations entirely.
Once the simulations have been completed, you can click Back to return to the original view of the Batch Mode Simulation window, where you can select different diagrams or change simulation settings, or Run to run the batch simulation process again with the same settings.

You will not be able to perform other operations in the software while the simulations are being performed.

**Available Results**

**Results Explorer**

After a simulation diagram, Markov diagram or RENO flowchart has been simulated, you can view the results in the Results Explorer. To access these results from the Maintainability/Availability Simulation window or the RENO Simulation window, click the Details button. To access from within any simulation diagram, click the Show Simulation Details (...) icon on the control panel or choose Simulation > Tools > Show Simulation Details.

To access the results from a Markov diagram, choose Analysis > Tools > Show Analysis Results.
The navigation panel on the left side of the window shows which results are available from the current simulation or analysis. Click any node to display those specific results in the worksheet on the right.

Note the following:

- New results replace all previous results and only the most recent results are saved with the diagram. If you wish to store the current results and then resimulate/reanalyze, you can use the Transfer Report command to send the results to a Synthesis Workbook or to Excel before you start the next analysis.

- For simulation diagrams, if you selected to perform multiple simulations, some of the results (e.g., expected number of failures, etc.) will be decimals because they are averaged across all simulations. If you selected to perform one simulation, those results will be whole numbers.

- Time Units:
  - For simulation diagrams and continuous Markov diagrams, results that are time-based (e.g., downtime, time to event, time spent in state, etc.) are given in terms of the time unit that is specified in the Unit group of the ribbon. You can select a different time unit from this drop-down list at any time and the results will automatically be converted to the new time unit.
  - For RENO flowcharts, all results are given in terms of the system base unit (SBU). (See Using Time Units in RENO.)
**Ribbon Commands**

In addition to standard commands for cut, copy, paste, clear and print, the ribbon in the Results Explorer also provides the following, depending on the diagram type you are working with:

**View**

- **Show Expanded Block Name** applies only for subdiagram blocks. It displays the name of the diagram represented by a subdiagram block in the Block Name column.

- **Show Block Description** displays the description of the block, as defined in the Block Properties window.

- **Freeze Block Name Column** is available only for simulation diagrams and RENO flowcharts. It freezes the Block Name column in the worksheet so that it remains visible as you scroll to the right to view additional columns. If not selected, the Block Name column may not remain visible, depending on your screen resolution and the sizing of the window.

**Sheet**

- **Set Colors** opens the Set Report Colors window, which allows you to set the fill and colors for worksheet elements such as column titles, sub-headings, etc. These settings are defined separately for each diagram type, and apply to all diagrams of that type.

- **Transfer Report** allows you to send the contents of the Results Explorer to a Synthesis Workbook or to Excel. In the Transfer Report window that appears, "current item" refers to the simulation results worksheet that is currently selected, "current view" refers to all worksheets that are currently open and "full report" refers to all worksheets in the Results Explorer. If you have simulated a phase diagram, the results that are transferred for "current item" or "current phase" are based on your selection in the Phase group of the ribbon, while "full report" refers to all phases.

- **Full Report** opens all of the currently available worksheets in separate tabs in the Results Explorer. You can then use either the navigation panel or the tabs to switch between worksheets.

- **Send Selection to Weibull++** is available only for simulation diagrams and RENO flowcharts. It sends the selected data to a life data folio in Weibull++. You must have Weibull++ activated on your computer in order to view the resulting folio. To use this functionality, one or two columns of data must be selected in the worksheet.

- **Send RDA Results to Weibull++** is available only for simulation diagrams. It transfers the data in the RDA Data worksheet to a Weibull++ parametric RDA folio within the
current project. If Weibull++ is installed on your computer, you can then perform parametric recurrent event data analysis on the data set. The parametric RDA folio uses the General Renewal Process (GRP) model to analyze the failure behavior of a repairable system. The GRP analysis method takes into account the effectiveness of repairs on the condition of the system, and models the cumulative number of failures over time.

Send RGA Results to RGA is available only for simulation diagrams. It transfers the data in the RGA Data worksheet to an RGA folio using the Multiple Systems - Concurrent Operating Times data type within the current project. If RGA is installed on your computer, you can then perform reliability growth analysis on the data set.

Units
For BlockSim diagrams only, the units drop-down list allows you to specify the time units used for the results. When you choose a new time unit, the software performs the unit conversion automatically. Authorized users can define the time units that will be available in the database and set up the conversion factors.

Phase
For phase diagrams only, the phase drop-down list allows you to select the phase that you want to view simulation results for. You can select an individual phase or select Overall to view results for all phases.

Set Report Colors Window
The Set Report Colors window allows you to set the fill and text colors for worksheet elements such as column titles, sub-headings, etc. in the worksheets in the Results Explorer. This window can be opened by choosing Home > Sheet > Set Colors in the Results Explorer.

The Preview area on the left side of the window displays the colors set for the report. The color boxes on the right side of the window allow you to change the corresponding fill and text colors. Click the corresponding color box to open the color palette, which allows you to set the color.

- Title displays the fill and text color for the titles in the Results Explorer worksheets.
- Heading displays the fill and text color for the headings in the Results Explorer worksheets.
- Odd Column displays the fill and text color for the odd columns in the Results Explorer worksheets.
• **Even Column** displays the fill and text color for the even columns in the Results Explorer worksheets.

• **Reset** resets the report colors to the default colors that were shipped with the application.

These settings are defined separately for BlockSim diagrams and for RENO flowcharts, and apply to all diagrams of that type.

**General Summary Results**
The General Summary worksheet in the Results Explorer presents an overview of the simulation settings and total results generated for the system, the blocks, the crews and the spare part pools.

• **Simulation Summary** displays the same information that is displayed in the Simulation Summary worksheet.

• **System Overview** displays the same information that is displayed in the System Overview worksheet.

• **Individual Block Summary** displays the same information that is displayed in the Block Summary worksheet.

• **Crew Summary** displays the same information that is displayed in the Crew Summary worksheet.

• **Spare Part Pool Summary** displays the same information that is displayed in the Spare Part Pool Summary worksheet.

**System Results**

**System Overview**
The System Overview worksheet in the Results Explorer presents an overview of the calculations performed for the entire system. The values shown are averages of the results of all of the simulations.

• **General Information**
  
  • **Mean Availability (All Events):** Includes all system downing events during the time of the simulation. The standard deviation of this value is provided in the **Std Deviation (Mean Availability)** field.
• **Mean Availability (w/o PM, OC & Inspection):** Includes all downing events, but not preventive, on condition or inspection tasks, during the time of the simulation.

• **Point Availability (All Events) at [Time]:** The point availability of the system, including all downing events, at the simulation end time.

• **Reliability ([Time]):** The reliability of the system at the simulation end time.

• **Uptime:** The total amount of time that the system was up (i.e., operational) during the simulation.

• **Total Downtime:** The total amount of time that the system was down (i.e., not operational) during the simulation.

• **Metrics**

  • **MTTFF:** The mean time to first failure for the system.

  • **MTBF (Total Time):** The mean time between failures for the system, based on the total simulation time and including all system failures. This is calculated by dividing the simulation run time by the number of system failures.

  • **MTBF (Uptime):** The mean time between failures for the system, considering only the time that the system was up. This is calculated by dividing system uptime by the number of system failures.

  • **MTBE (Total Time):** The mean time between all downing events for the system, based on the total simulation time and including all system downing events. This is calculated by dividing the simulation run time by the number of downing events.

  • **MTBE (Uptime):** The mean time between all downing events for the system, considering only the time that the system was up. This is calculated by dividing system uptime by the number of downing events.

**Note:** To better understand the difference between total and uptime consider the case of a system that has two time reading displays. One display is based on the actual system run hours (like a Hobbs meter – or time-on meter) and the other is a real-time chronograph recording the true time elapsed. As the system goes up and down, the two will no longer be in sync. For example, imagine that the system had two failures and the real time display reads 1,000 hours elapsed time while the Hobbs meter reads 500 hours. The MTBF based on total time would be $1,000/2 = 500$ hours, while the MTBF based on uptime would be $500/2 = 250$ hours.
• **MTTM**: The mean time to maintain for the system. This is calculated by dividing the total downtime by the number of downing events (i.e., the mean duration of downtime events for the system during the simulation.)

• **MTTR**: The mean time to repair for the system. This is calculated by dividing the total downtime associated with corrective tasks by the number of failures.

• **Downtime Summary**: For phase diagrams, when you are viewing overall results for all phases, the information in this section will be shown for all phases, for operational phases and for maintenance phases.

  • **Waiting Downtime (Hr)**: The total amount of time that the system was down and no task that would restore it was in progress. Note that wait times inherent in tasks (e.g., logistic delays for crews and/or parts) are excluded from this metric.

  • **Critical Downtime**: The total amount of time that the system was down where the length of the downtime met or exceeded the system downtime threshold, as specified on the Analysis Settings page of the diagram's control panel.

• **Event Count Summary** displays information for all events associated with system downtime that occurred during the simulation. Note that events with zero duration will appear in this section only if the task properties specify that the task brings the system down or if the task properties specify that the task brings the item down and the item's failure brings the system down. For phase diagrams, when you are viewing overall results for all phases, the information in this section will be shown for all phases, for operational phases and for maintenance phases.

• **System Failures**

  • **Expected Number of Failures**: The total number of failures expected to occur during the simulation for the system. The standard deviation of this value is provided in the Std Deviation (Number of Failures) field.

  • For each of the four classes of tasks (i.e., corrective, inspection, preventive and on condition), the following information is presented with regard to tasks performed during the simulation time:

    • **Number of [Task Class]**: The total number of tasks of this class performed on the system during the simulation.

    • **[Task Class] Downtime**: The total amount of time that the system was down (i.e., not operational) due to tasks of this class during the simulation.
Chapter 8: BlockSim Simulation Diagrams

- Triggers
  - **Number of OFF Events by Trigger**: The total number of events where the system is turned off by state change triggers. An OFF event is not a system failure but it may be included in system reliability calculations.

- Total
  - **Total Events**: The total number of system downing events that occurred during the simulation time.

- Cost Summary. For phase diagrams, when you are viewing overall results for all phases, the information in this section will be shown for all phases, for operational phases and for maintenance phases.

- Opportunity Costs
  - **Opportunity Cost (Total)**: Potential system revenue lost as a result of system downtime. This is based on the lost revenue per hour of uptime during system downtime plus the lost revenue per unit produced (if a throughput simulation has been run). Both Revenue per Hour of Uptime and Revenue per Unit Produced are specified on the Analysis Settings page of the diagram control panel.

- Total Costs
  - **System Total Cost**: The total costs that accrued for the system during the simulation time, which is based on the costs for tasks, crews and spare part pools.

- Revenue
  - **Total Revenue**: The total system revenue, including uptime revenue and throughput revenue (if a throughput simulation has been run), based on the System Level Revenue settings on the Analysis Settings page of the diagram control panel.

- Throughput Analysis Summary: Throughput results will be calculated only if you selected to run a throughput simulation on the Analysis Settings page of the diagram control panel.

- Throughput
  - **Total Throughput**: The total number of units that were processed/produced by the system during the simulation time.
**Chapter 8: BlockSim Simulation Diagrams**

- **Throughput Metrics**
  - **Maximum Capacity**: The maximum number of units the system could have processed/produced during the total simulation time if no downtime was considered.
  - **Actual Utilization**: The ratio of actual units produced (Total Throughput) to the maximum that could have been produced (Max. Capacity), expressed as a percent (i.e., Total/Max).

**System Point Results**
The System Point Results worksheet in the Results Explorer displays a table of the point reliability and availability results for the system, including all system downing events that occurred up to the specified points in time.

*Note:* For phase diagrams, this worksheet is available only when you have selected Overall from the Phase drop-down list in the ribbon.

- **Time**: The time for each corresponding point availability and reliability value. The points are determined based on the interval specified in the Point Results Every field in the Maintainability/Availability Simulation window. The number of points is determined by dividing the simulation time according to that increment, up to the end time you specified in the window.
- **A(t)**: The point availability of the system. This is displayed as a decimal.
- **R(t)**: The point reliability of the system. This is computed based on the first system failure and is displayed as a decimal.
- **(1-A(t))%**: The point unavailability of the system. This is displayed as a percentage.
- **(1-R(t))%**: The point unreliability of the system. This is displayed as a percentage.
- **Labor Cost(t)**: The cost associated with crews at the corresponding system time. This is based on the direct cost per unit time and cost per incident, as specified in the Crew window.
- **Part Cost(t)**: The cost associated with spare parts at the corresponding system time. This is based on the direct cost per item as specified in the Spare Part Pool window, as well as any indirect costs (e.g., holding costs, costs associated with restocking, etc.).
- **Cost(t)**: The cost at the corresponding system time, based on the miscellaneous costs and costs for spare parts and crews.
• **Mean $A(t)$**: The mean availability of the system up to the corresponding time.

• **Mean $A(t[i] - t[i-1])$**: The mean point availability of the system during the most recent interval (i.e., the interval between the last specified time and the current specified time).

• **System Failures**($t$): The number of system failures that occurred by the corresponding system time.

• **System Off Events by Trigger**($t$): The number of events where the system is turned off by state change triggers that occurred by the corresponding time. An OFF event is not a system failure but it may be included in system reliability calculations.

• **Throughput**($t$): The number of units that were processed/produced by the system by the corresponding system time. This will be calculated only if you selected to run a throughput simulation and selected to report throughput point results on the Analysis Settings page of the diagram control panel.

**System Costs**
The System Costs worksheet in the Results Explorer displays the costs that accrued during the simulation time.

For each of the four classes of tasks (i.e., corrective, preventive, on condition and inspection), the following information is presented with regard to costs that accrued during the simulation time:

• **Misc. Costs**: The miscellaneous costs associated with the task class. This is based on the cost per task and downtime rate, specified in the Maintenance Task window.

• **Costs for Parts**: The cost for spare parts due to tasks of this class. This is based on the direct cost per item as specified in the Spare Part Pool window, as well as any indirect costs (e.g., holding costs, costs associated with restocking, etc.). Note that this value is not available for inspection tasks, as inspections do not use spare parts.

• **Costs for Crews**: The cost for crews due to tasks of this class. This is based on the direct cost per unit time and cost per incident, as specified in the Crew window.

• **Total Costs**: The total cost for maintenance of this type, based on the miscellaneous costs and costs for spare parts and crews.
In addition, the following values are calculated:

- **Block Consequential Costs**
  - **Total Block Consequential Costs**: The sum of all individual consequential block costs. Consequential costs are specified in the Block Properties window both for each unit of downtime and for each failure event.

- **Indirect Pool Costs**
  - **Total Pool Holding Costs**: The indirect costs of maintaining the spare part in the pool over time. For example, if it costs $20 per month to keep the part available in the pool and the part remains in the pool for 3 months, then $60 of indirect costs have accumulated for the item.

- **Additional System Level Costs**
  - **System Level Failure Cost (CM)**: The costs associated with system failure events based on the cost per system failure, as specified on the Analysis Settings page of the diagram control panel.
  - **System Level Downtime Costs (CM)**: The total costs associated with system level downtime events due to corrective tasks only. Downtime due to other non-failure events, such as preventive, inspection or on condition tasks, is not included. This is based on the system downtime rate, as specified on the Analysis Settings page of the diagram control panel.
  - **System Level Total Costs (CM)**: The sum of the System Level Failure Costs (CM) and System Level Downtime Costs (CM).
  - **System Level Failure Cost (Total)**: The costs associated with system downing events based on the cost per system failure, as specified on the Analysis Settings page of the diagram control panel.
  - **System Level Downtime Costs (Total)**: The total costs associated with all system level downtime events. This is based on the system downtime rate, as specified on the Analysis Settings page of the diagram control panel.
  - **System Level Total Costs (Total)**: The sum of the System Level Failure Costs (Total) and System Level Downtime Costs (Total).

- **Total Costs**
  - **Total Costs**: The total cost that accrued during the system simulation time, based on all of the costs shown in the worksheet.
• Opportunity Costs
  • **Opportunity Costs**: Potential system revenue lost as a result of downtime. This is based on the lost revenue per hour of uptime plus the lost revenue per unit produced (if a throughput simulation has been run). Both are specified on the Analysis Settings page of the diagram control panel.

• System Revenue Summary
  • **Uptime Revenue**: The system revenue based on the revenue per unit of uptime, as specified on the Analysis Settings page of the diagram control panel.
  • **Throughput Revenue**: The system revenue based on the revenue per unit of throughput (if a throughput simulation has been run), as specified on the Analysis Settings page of the diagram control panel.
  • **Total Revenue**: The sum of the Uptime Revenue and Throughput Revenue.

**System Throughput**
The System Throughput worksheet will appear in the Results Explorer only if you selected to run a throughput simulation on the Analysis Settings page of the diagram control panel.

  • **Total Throughput**: The total number of units that were processed/produced by the system during the simulation time.
  • **Block Name**: The name of each block in the diagram.
  • **Uptime Utilization**: The percentage of the block's processing/production capacity while up that it actually processed/produced (i.e. the ratio of the block throughput to the block uptime capacity).

**Blocks Results**

**Block Summary**
The Block Summary worksheet in the Results Explorer displays a summary of the simulation results for each block.

*Note:* You can customize the order in which the blocks are displayed in the simulation results by right-clicking inside the diagram sheet and choosing Set Block Order on the shortcut menu. You will need to resimulate the diagram for the new block order to be shown in the results.

  • **Block Name**: The name of each block in the diagram.
• **Block Description**: The description of each block in the diagram. This is displayed only if Show Block Description is selected on the ribbon.

• **RS FCI**: The ReliaSoft Failure Criticality Index for each block. This is a relative index showing the percentage of times that a failure of the block caused a system failure (i.e., the number of system failures caused by the block divided by the total number of system failures). Note that this relates only to failures; it does not include every event that could bring the system down (such as routine maintenance).

• **RS DECI**: The ReliaSoft Downing Event Criticality Index for each block. This is a relative index showing the percentage of times that a downing event of the block caused the system to go down (i.e., the number of system downing events caused by the block divided by the total number of system downing events).

• **RS DTCI**: The ReliaSoft Downtime Criticality Index for each block. This is a relative index showing the contribution of each block to the system's downtime (i.e., the system downtime caused by a particular block divided by the total system downtime).

• **Mean Av. (All Events)**: The mean availability of all downing events for each block during the simulation.

• **Mean Av. (w/o PM, OC & Insp.)**: The mean availability of all downing events for each block, not including preventive or inspection tasks, during the simulation.

• **Expected # of Failures**: The total number of failures expected to occur during the simulation for each block.

• **Expected # of OFF Events by Trigger**: The total number of events where the block is turned off by state change triggers. An OFF event is not a failure but it may be included in system reliability calculations.

• **System Downing Events**: The number of events for each block that caused the system to go down during the simulation.

• **Block Downtime**: The total amount of time that each block was down (i.e., not operational) during the simulation.

• **Block Uptime**: The total amount of time that each block was up (i.e., operational) during the simulation.

• **Number of CMs**: The total number of corrective tasks performed on each block during the simulation.

• **CM Downtime**: The total amount of time that each block was down (i.e., not operational) due to corrective maintenance during the simulation.
Chapter 8: BlockSim Simulation Diagrams

- **Number of Inspections**: The total number of inspections performed on each block during the simulation.
- **Inspection Downtime**: The total amount of time that each block was down (i.e., not operational) due to an inspection during the simulation.
- **Number of PMs**: The total number of preventive tasks performed on each block during the simulation.
- **PM Downtime**: The total amount of time that each block was down (i.e., not operational) due to a preventive task during the simulation.
- **Number of OCs**: The total number of on condition tasks performed on each block during the simulation.
- **OC Downtime**: The total amount of time that each block was down (i.e., not operational) due to an on condition task during the simulation.
- **Throughput**: The total number of units that were processed/produced by each block during the simulation time. The throughput will be calculated only if you selected to run a throughput simulation on the Analysis Settings page of the diagram control panel.
- **Total Cost**: The total cost for each block, which is based on the task, crew and spare part pool costs.

**Block Costs**
The Block Costs worksheet in the Results Explorer displays the costs that accrued during the simulation time for each block.

*Note*: You can customize the order in which the blocks are displayed in the simulation results by right-clicking inside the diagram sheet and choosing *Set Block Order* on the shortcut menu. You will need to resimulate the diagram for the new block order to be shown in the results.

- **Block Name**: The name of each block in the diagram.
- **Block Description**: The description of each block in the diagram. This is displayed only if Show Block Description is selected on the ribbon.
- **Total Cost**: The total cost that accrued during the simulation time for each block, which is based on the task, crew and spare part pool costs.
- **CM Misc**: The miscellaneous costs associated with corrective tasks that accrued during the simulation time. This is based on the cost per task and downtime rate, specified in the Maintenance Task window.
• **CM Part**: The cost for spare parts due to corrective tasks that accrued during the simulation time. This is based on the direct cost per item as specified in the Spare Part Pool window, as well as any indirect costs (e.g., holding costs, costs associated with restocking, etc.).

• **CM Crew**: The cost for crews due to corrective tasks that accrued during the simulation time. This is based on the direct cost per unit time and cost per incident, as specified in the Crew window.

• **PM Misc**: The miscellaneous costs associated with preventive tasks that accrued during the simulation time. This is based on the cost per task and downtime rate, specified in the Maintenance Task window.

• **PM Part**: The cost for spare parts due to preventive tasks that accrued during the simulation time. This is based on the direct cost per item as specified in the Spare Part Pool window, as well as any indirect costs (e.g., holding costs, costs associated with restocking, etc.).

• **PM Crew**: The cost for crews due to preventive tasks that accrued during the simulation time. This is based on the direct cost per unit time and cost per incident, as specified in the Crew window.

• **OC Misc**: The miscellaneous costs associated with on condition tasks that accrued during the simulation time. This is based on the cost per task and downtime rate, specified in the Maintenance Task window.

• **OC Part**: The cost for spare parts due to on condition tasks that accrued during the simulation time. This is based on the direct cost per item as specified in the Spare Part Pool window, as well as any indirect costs (e.g., holding costs, costs associated with restocking, etc.).

• **OC Crew**: The cost for crews due to on condition tasks that accrued during the simulation time. This is based on the direct cost per unit time and cost per incident, as specified in the Crew window.

• **IN Misc**: The miscellaneous costs associated with inspection tasks that accrued during the simulation time. This is based on the cost per task and downtime rate, specified in the Maintenance Task window.

• **IN Crew**: The cost for crews that accrued during the simulation time due to inspection tasks. This is based on the direct cost per unit time and cost per incident, as specified in the Crew window.

• **DT Cost**: The costs associated with downtime that accrued during the simulation time. This is based on the block consequential costs, as specified in the Block Properties.
window (i.e., the block's downtime multiplied by its downtime rate, and its number of failures multiplied by its cost per failure).

**Block Throughput**
The Block Throughput worksheet displays the throughput for each block during the simulation time. This worksheet will appear in the Results Explorer only if you selected to run a throughput simulation on the Analysis Settings page of the diagram control panel.

*Note:* You can customize the order in which the blocks are displayed in the simulation results by right-clicking inside the diagram sheet and choosing Set Block Order on the shortcut menu. You will need to resimulate the diagram for the new block order to be shown in the results.

- **Block Name:** The name of each block in the diagram.
- **Block Description:** The description of each block in the diagram. This is displayed only if Show Block Description is selected on the ribbon.
- **Throughput:** The total number of units that were processed/produced by each block during the simulation.
- **Throughput Importance:** The relative importance of each block to the system throughput.
- **Excess Capacity:** The additional number of units each block could have processed/produced during the simulation.
- **Backlog:** The total number of backlogged units (i.e., units waiting to be processed/produced) for each block at the end of the simulation. This is based on whether the block can accept a backlog and how the backlog units were allocated, as specified in the Block Properties window.
- **Backlog Processed:** The total number of units that were backlogged but eventually processed/produced by each block during the simulation.
- **Excess Backlog:** The number of backlogged units that were rejected (i.e., not processed/produced) by each block during the simulation. Backlogged units will be rejected if the block has a limited backlog (i.e., a limit to the number of units that can be stored in the backlog).
- **Uptime Utilization:** The percent of units the block actually produced/processed of what it could have processed/produced while it was up during the simulation. (i.e., the ratio of the block throughput and the block uptime capacity.)
**Block Details**

The Block Details worksheets in the **Results Explorer** display the details for each block, or component, in the system. Click the name of the block in the navigation panel to display the block details for that block on a separate worksheet.

**Note:** You can customize the order in which the blocks are displayed in the simulation results by right-clicking inside the diagram sheet and choosing **Set Block Order** on the shortcut menu. You will need to resimulate the diagram for the new block order to be shown in the results.

- **General Information**
  - **Mean Availability (All Events):** The mean availability of the block during the simulation.
  - **Mean Availability (w/o PM, OC & Inspection):** The mean availability of all downing events for the block, not including preventive, on condition or inspection tasks, during the simulation.
  - **Block Uptime:** The total amount of time that the block was up (i.e., operational) during the simulation.
  - **Block Downtime:** The total amount of time that the block was down (i.e., not operational) during the simulation.

- **Metrics**
  - **RS Criticality Indices**
    - **RS FCI:** The ReliaSoft Failure Criticality Index for the block. This is a relative index showing the percentage of times that a failure of the block caused a system failure (i.e., the number of system failures caused by the block divided by the total number of system failures). Note that this relates only to failures; it does not include every event that could bring the system down (such as routine maintenance).
    - **RS DECI:** The ReliaSoft Downing Event Criticality Index for the block. This is a relative index showing the percentage of times that a downing event of the block caused the system to go down (i.e., the number of system downing events caused by the block divided by the total number of system downing events).
    - **RS DTCI:** The ReliaSoft Downtime Criticality Index for the block. This is a relative index showing the contribution of the block to the system's downtime (i.e., the system downtime caused by the block divided by the total system downtime).
• **RS BCCI**: The ReliaSoft Block Cost Criticality Index for the block. This is a relative index showing the contribution of the block to the total costs (i.e., the total block costs divided by the total costs).

• **Block Downtime Contribution Index** This is an index showing the factors contributing to the block downtime. Both a crew and a spare part pool must be defined for this to return meaningful results.

• **Non-Waiting Time CI**: A relative index showing the contribution of repair times to the block's total downtime (the ratio of the time that the crew is actively working on the item to the total down time).

• **Total Waiting Time CI**: A relative index showing the contribution of wait factor times to the block's total downtime. Wait factors include crew conflict times, crew wait times and spare part wait times. (The ratio of downtime not including corrective repair time to the total down time.)

• **Waiting for Opportunity/Maximum Wait Time Ratio**: A relative index showing the contribution of crew conflict times. This is the ratio of the time spent waiting for the crew to respond (not including crew logistic delays) to the total wait time (not including the active repair time).

• **Crew/Part Wait Ratio**: The ratio of the crew and part delays. A value of 100% means that both waits are equal. A value greater than 100% indicates that the crew delay was in excess of the part delay. For example, a value of 200% would indicate that the wait for the crew is two times greater than the wait for the part.

• **Part/Crew Wait Ratio**: The ratio of the part and crew delays. A value of 100% means that both waits are equal. A value greater than 100% indicates that the part delay was in excess of the crew delay. For example, a value of 200% would indicate that the wait for the part is two times greater than the wait for the crew.

• **Summary Metrics**

• **MTBF (Total Time)**: The mean time between failures for the block during the simulation. This is calculated by dividing the simulation run time by the block’s number of failures.

• **MTBF (Uptime)**: The mean time between failures for the block considering only the block uptime. This is calculated by dividing the block’s uptime by the number of failures.
• **MTBE (Total Time):** The mean time between downing events for the block during the simulation. This is calculated by dividing the simulation run time by the block’s number of downing events.

• **MTBE (Uptime):** The mean time between downing events for the block considering only the block uptime. This is calculated by dividing the block’s uptime by the number of downing events.

• **MTTM:** The mean time to maintain for the block. This is calculated by dividing the block's downtime by the number of downing events (i.e., the mean duration of downtime events for the block during the simulation).

• **MTTR:** The mean time to repair for the block. This is calculated by dividing the total downtime associated with corrective tasks for the block by the number of failures.

• **Downtime Summary**
  
  • **Non-Waiting Time:** Time that the block was undergoing active maintenance/inspection.

  • **Waiting for Opportunity:** The total downtime for the block due to crew conflicts (i.e., time spent waiting for a crew while the crew is busy with another task). If no crew is defined, then this will return zero.

  • **Waiting for Crew:** The total downtime for the block due to crew wait times (i.e., time spent waiting for a crew due to logistical delay). If no crew is defined, then this will return zero.

  • **Waiting for Parts:** The total downtime for the block due to spare part wait times. If no spare part pool is defined then this will return zero.

• **Event Count Summary**

  • **Block Failures**

    • **Number of Failures:** The total number of failures that occurred during the simulation for the block.

    • **Number of System Downing Failures:** The number of failures for the block that caused the system to go down during the simulation.

    • For each of the four classes of tasks (i.e., corrective, preventive, on condition and inspection), the following information is presented with regard to tasks performed during the simulation time:

      • **Number of [Task Class]:** The total number of tasks of this class performed on the block during the simulation.
• **[Task Class] Downtime:** The total amount of time that the block was
down (i.e., not operational) due to tasks of this class during the
simulation.

• **Triggers**
  
  • **Number of OFF Events by Trigger:** The total number of events where the
  block is turned off by state change triggers. An OFF event is not a failure
  but it may be included in system reliability calculations.

• **Total**
  
  • **Number of Block Downing Events:** The total number of downing events
  that occurred during the system simulation time for the block.
  
  • **Number of System Downing Events:** The number of events for the block
  that caused the system to go down during the simulation.

• **Cost Summary**
  
  • For each of the four classes of tasks (i.e., corrective, preventive, on condition and
    inspection), the following information is presented with regard to costs that
    accrued during the simulation time:

  • **Misc. Costs:** The miscellaneous costs associated with the task class. This
    is based on the cost per task and downtime rate, specified in the
    Maintenance Task window.

  • **Costs for Parts:** The cost for spare parts due to tasks of this class. This is
    based on the direct cost per item as specified in the Spare Part Pool
    window, as well as any indirect costs (e.g., holding costs, costs associated
    with restocking, etc.). Note that this value is not available for inspection
    tasks, as inspections do not use spare parts.

  • **Costs for Crews:** The cost for crews due to tasks of this class. This is based
    on the direct cost per unit time and cost per incident, as specified in the
    Crew window.

• **Costs (Consequential)**
  
  • **Block Failure Cost:** The block failure costs that accrued during the
    simulation time. This is based on the block's number of failures multiplied
    by its cost per failure, as specified in the Block Properties window.

  • **Block Downtime Cost:** The block downtime costs that accrued during the
    simulation time. This is based on the block's downtime multiplied by its
downtime rate, as specified in the Block Properties window.
• **Total Block Downtime Cost**: The block's total costs associated with downtime (i.e., the sum of the Block Failure Cost and the Block Downtime Cost).

• **System Level Contribution**

  • **System Level Failure Cost (CM)**: The contribution of this block to the system level failure costs due to failure events. This is calculated using the overall system level failure costs (CM) multiplied by the ratio of the number of times this block caused a system failure to the total number of system failures.

  • **System Level Downtime Cost (CM)**: The contribution of this block to the system level downtime costs. This is calculated using the overall system level downtime costs (CM) multiplied by the ratio of the system downtime caused by this block to the total system downtime.

  • **System Level Total Costs (CM)**: The sum of the System Level Failure Cost (CM) and the System Level Downtime Cost (CM).

  • **System Level Failure Cost (Total)**: The contribution of this block to the system level failure costs due to downing events. This is calculated using the overall system level failure costs (total) multiplied by the ratio of the number of times this block caused a system failure to the total number of system failures.

  • **System Level Downtime Cost (Total)**: The contribution of this block to the system level downtime costs due to downing events. This is calculated using the overall system level downtime costs (total) multiplied by the ratio of the system downtime caused by this block to the total system downtime.

  • **System Level Total Costs (Total)**: The sum of the System Level Failure Cost (Total) and the System Level Downtime Cost (Total).

• **Block Opportunity Costs**

  • **Block Opportunity Cost (CM)**: The loss of throughput and revenue attributed directly to this block due to failure events. This is calculated by multiplying the system opportunity costs for corrective maintenance (shown in the System Costs worksheet) by the block DTCI.

  • **Block Opportunity Cost (Total)**: The loss of throughput and revenue attributed directly to this block due to downing events. This is calculated by multiplying the total system opportunity costs (shown in the System Costs worksheet) by the block DTCI.


- **Block Total Costs**
  - **Block Total Cost:** The total cost associated with the block, including all costs for all task types, the Total Block Downtime Cost and the System Level Total Costs. Note that the Block Opportunity Cost is not included in this value.

- **Throughput Analysis Summary:** Throughput results will be calculated only if you selected to run a throughp**ut** simulation on the Analysis Settings page of the diagram control panel.

- **Throughput**
  - **Throughput:** The total number of units that were processed/produced by the block during the simulation time.
  
  - **Excess Capacity:** The additional number of units the block could have processed/produced during the simulation.
  
  - **Backlog:** The total number of units that were backlogged (i.e., waiting to be processed) for the block at the end of the simulation. This is based on whether the block can accept a backlog and how the units were allocated, as specified in the Block Properties window.
  
  - **Backlog Processed:** The total number of units that were backlogged but eventually processed by the block during the simulation time.

- **Throughput Metrics**
  - **Maximum Uptime Capacity:** The maximum number of units the block could have processed/produced while it was up during the simulation.
  
  - **Uptime Utilization:** The percent of units the block actually produced/processed of what it could have processed/produced while it was up during the simulation. (i.e., the ratio of the block throughput and the block maximum uptime capacity.)
  
  - **Maximum Capacity:** The maximum capacity of the block, which is the maximum number of units the block could have processed/produced during the simulation.
  
  - **Actual Utilization:** The percent of units the block actually produced/processed of what it could have produced/processed (i.e., the ratio of the block throughput and the block maximum capacity).
Chapter 8: BlockSim Simulation Diagrams

Last Run Details
The Last Run Details worksheets in the Results Explorer display the details of the last simulation for the selected block. Note that if you are working with a BlockSim 6 file, these details are available only when a single simulation was run. If multiple simulations were run, you must resimulate in the current version in order for these details to be available.

Note: You can customize the order in which the blocks are displayed in the simulation results by right-clicking inside the diagram sheet and choosing Set Block Order on the shortcut menu. You will need to resimulate the diagram for the new block order to be shown in the results.

- **ENUM**: The index number for each event. This is an identifier that indicates the order in which the events occurred.
- **Time to Event**: The time to each event.
- **Waiting for Opportunity**: The time the block was waiting for an opportunity, which is the time associated with the waiting for a crew that is working on another repair.
- **Waiting for Crew**: The time the block was waiting for a crew, which is the time associated with the logistic delay of the crew.
- **Waiting for Spare Part**: The time the block was waiting for a spare part.
- **Under Repair**: The time the block was under repair (i.e., maintenance duration).
- **Event Type**: The type of event. Possible values include:
  - CM: corrective maintenance
  - PM: preventive maintenance
  - I: inspection
  - NDI: non-downing inspection
  - OC: on condition task
  - OFF: block turned off by state change trigger
  - F: block failure, no maintenance

Crews Results

Crew Summary
The Crew Summary worksheet in the Results Explorer displays a summary of the crews.

- **Crew**: The name of each crew assigned to the blocks in the diagram.
• **Calls**: The number of times each crew was called upon to perform maintenance during the simulation time.

• **Accepted**: The number of calls that were accepted during the simulation time by each crew.

• **Percent Accepted**: The percentage of calls that were accepted by each crew during the simulation time.

• **Rejected**: The number of calls that were rejected during the simulation time by each crew. A call may be rejected because the crew is not able to perform simultaneous tasks, it is already performing its maximum number of tasks, etc.

• **Percent Rejected**: The percentage of calls that were rejected by the crew during the simulation time.

• **Time Used**: The total time each crew spent performing maintenance tasks during the simulation time, including delays.

• **Crew Delay Time**: The total delay time before each crew started tasks, based on the logistic delay time defined in the crew properties.

• **Spare Delay Time**: The total delay time for spare parts for each crew, based on the logistic delay time defined in the spare part pool properties.

• **Repair Time**: The total active time each crew spent performing maintenance tasks during the simulation time.

• **Direct Costs**: The total direct costs associated with maintenance tasks for each crew, based on the direct costs defined in the crew properties.

• **Incident Costs**: The total incident costs associated with maintenance tasks for each crew, based on the cost per incident defined in the crew properties.

• **Cost**: The total costs associated with each crew during the simulation time, based on the direct and indirect costs.

**Crew Details**
The Crew Details worksheets in the Results Explorer display the details for each crew assigned to perform tasks on the system. Click the name of the crew in the navigation panel to display the crew details on a separate worksheet.

• **Call Summary**
  
  • **Calls Received**: The number of times the crew was called upon to perform maintenance during the simulation time.
• **Accepted Calls**: The number of calls that were accepted during the simulation time by the crew.

• **Percent Accepted**: The percentage of calls that were accepted by the crew during the simulation time.

• **Rejected Calls**: The number of calls that were rejected by the crew during the simulation time. A call may be rejected because the crew may not be able to perform simultaneous tasks, it is already performing its maximum number of tasks, etc.

• **Percent Rejected**: The percentage of calls that were rejected by the crew during the simulation time.

• **Utilization**

  • **Total Utilization**: The total time spent by the crew performing maintenance tasks during the simulation time.

  • **Average Call Duration**: The average duration of the tasks (corrective, preventive or inspection) performed by the crew during the simulation.

  • **Total Wait Time**: The total delay time spent waiting for the crew after the call was made and before the crew was sent to the block. This delay applies only to events where the crew was busy performing maintenance on another item (i.e., it does not include the logistic delay specified in the Crew window).

  • **Total Crew Delay Time**: The total delay time before the crew started tasks, based on the logistic delay time defined in the crew properties.

  • **Total Spare Delay Time**: The total delay time for spare parts for the crew, based on the logistic delay time defined in the spare part pool properties.

  • **Total Repair Time**: The total active time the crew spent performing maintenance tasks during the simulation time.

• **Costs**

  • **Direct Costs**: The total direct costs associated with maintenance tasks for the crew, based on the direct costs defined in the crew properties.

  • **Indirect Costs**: The total incident costs associated with maintenance tasks for the crew, based on the cost per incident defined in the crew properties.

  • **Total Crew Costs**: The total crew-related costs for the crew during the simulation time, based on the direct and indirect costs.
• **Average Cost per Call**: The average cost per call made to the crew during the simulation time.

### Spare Part Pools Results

#### Spare Part Pool Summary

The Spare Part Pool Summary worksheet in the **Results Explorer** displays a summary of the spare part pools.

- **Pool**: The name of each spare part pool.
- **Avg. Stock Level**: The average number of spare parts in each spare part pool during simulation time.
- **Parts Dispensed**: The number of spare parts in each spare part pool that were dispensed during the simulation time. Spares are required for corrective, preventive and on condition tasks.
- **Avg. Time to Dispense**: The average time it took to dispense the spare parts from each spare part pool during the simulation time. This is based on the logistic time for spare acquisition.
- **Rejected Requests**: The number of spares that were required for corrective or preventive maintenance but were unavailable in the spare part pool. Therefore, no maintenance action was performed.
- **Emergency Spares Dispensed**: The number of emergency spare parts that were used from each spare part pool during the simulation time. Emergency acquisitions are initiated when the spare part pool is empty but a spare part is required for a task.
- **Cost per Part**: The direct cost per dispensed item for each spare part pool, as specified in the Spare Part Pool window.
- **Total Cost**: The total cost for spare parts that were dispensed from each spare part pool during the simulation time.

#### Spare Part Pool Details

The Spare Part Pool Details worksheets in the **Results Explorer** display the details for each spare part pool assigned to the blocks in the diagram. Click the name of the spare part pool in the control panel to display the corresponding spare part pool details on a separate worksheet.
• **Dispensed**
  - **Parts Dispensed:** The number of spare parts in the spare part pool that were dispensed during the simulation. Spares are required for corrective, preventive and on condition tasks.
  - **Total Time to Dispense:** The total time it took to dispense the spare parts from the spare part pool during the simulation. This is based on the logistic time for spare acquisition.
  - **Average Time to Dispense:** The average time it took to dispense the spare parts from the spare part pool during the simulation. This is based on the logistic time for spare acquisition.

• **Rejected & Emergency**
  - **Number of Emergency Requests:** The number of emergency spare parts that were used from each spare part pool during the simulation time. Emergency acquisitions are initiated when the spare part pool is empty but a spare part is required for a task.
  - **Rejected Requests:** The number of spares required for corrective or preventive maintenance that were unavailable in the spare part pool. Therefore, no maintenance was performed.

• **Restock Details**
  - **Initial Stock Level:** The number of spare parts that were in the pool at the beginning of the simulation.
  - **Parts Restocked:** The number of spare parts that were restocked in the pool during the simulation.
  - **Average Stock Level:** The average number of spare parts that were in the pool during the simulation.
  - **Current Stock Level:** The number of spare parts that were in the spare part pool at the end of the simulation.

• **Pool Costs**
  - **Total Pool Costs:** The total cost for the spare part pool that was used during the simulation.
  - **Indirect Pool Costs:** The indirect costs of maintaining the spare parts in the pool over time. For example, if it costs $20 per month to keep each part available in the pool and the part remains in the pool for 3 months, then $60 of indirect costs have accumulated for the item.
• **Direct Pool Costs**: The total direct cost for all spare parts dispensed from the spare part pool during the simulation.

• **Pool Costs per Part**
  - **Total Cost per Part**: The total direct and indirect cost per part for the spare part pool over the duration of the simulation.
  - **Indirect Cost per Part**: The indirect cost per part of maintaining the spare parts in the pool over the duration of the simulation.
  - **Direct Cost per Part**: The direct cost per part for all spare parts dispensed from the pool over the duration of the simulation.

**Simulation Results**

**Simulation Summary**
The Simulation Summary worksheet in the [Results Explorer](http://blocksim.reliasoft.com) displays the details of the simulation.

- **Diagram**: The name of the diagram that was simulated.
- **Simulation Start Time**: The date and time that the simulation process began.
- **Simulation Duration**: The total amount of time that the simulation process took.
- **Start Time**: The simulation start time, as defined in the Maintainability/Availability Simulation window. This field is available only for interval simulations.
- **End Time**: The simulation end time, as defined in the Maintainability/Availability Simulation window.
- **Run Options**: The type of simulation that was run (i.e., standard simulations or log of simulations).
- **Number of Simulations**: The total number of simulations that were performed on the system, as defined in the Maintainability/Availability Simulation window.
- **Seed Value**: The seed value, if any, as defined in the Maintainability/Availability Simulation window.
- **Number of Threads**: The number of threads used during the simulation.
The following worksheets in the Results Explorer provide additional reports on the simulation results for the system and individual blocks.

- **The Block Failure Criticality Ranking** worksheet ranks each block by its value for ReliaSoft's failure criticality index (RS FCI). This is a relative index showing the percentage of times that a failure of the block caused a system failure (i.e., the number of system failures caused by the block divided by the total number of system failures). Note that this relates only to failures; it does not include every event that could bring the system down (such as routine maintenance).

- **The Block Downtime Criticality Ranking** worksheet ranks each block by its value for ReliaSoft's downtime criticality index for each block in the diagram. This is a relative index showing the contribution of the block to the system's downtime (i.e., the system downtime caused by the block divided by the total system downtime).

- **The Block Availability Ranking** worksheet ranks each block by its availability during the simulation, from highest to lowest.

- **The Block Failures Ranking** worksheet ranks each block by its expected number of failures during the simulation, from highest to lowest.

- **The Block System Downing Failures** worksheet ranks each block by the number of failures of the block that resulted in the downing of the system, from highest to lowest.

- **The Block Downtime Ranking** worksheet ranks each block based on the total amount of time that the block was down (i.e., not operational) during the simulation, from highest to lowest.

- **The Block Uptime Ranking** worksheet ranks each block based on the total amount of time that the block was up (i.e., operational) during the simulation, from highest to lowest.

- **The Block Inspection Count Ranking** worksheet ranks each block based on the total number of inspections performed on the block during the simulation, from highest to lowest.

- **The Block Inspection Downtime Ranking** worksheet ranks each block based on the total amount of time that the block was down (i.e., not operational) during the simulation due to an inspection, from highest to lowest.

- **The Block PM Count Ranking** worksheet ranks each block based on the total number of preventive tasks performed on the block during the simulation, from highest to lowest.

- **The Block PM Downtime Ranking** worksheet ranks each block based on the total amount of time that the block was down (i.e., not operational) during the simulation due to preventive maintenance, from highest to lowest.
The **Block OC Count Ranking** worksheet ranks each block based on the total number of on condition tasks performed on the block during the simulation, from highest to lowest.

The **Block OC Downtime Ranking** worksheet ranks each block based on the total amount of time that the block was down (i.e., not operational) during the simulation due to on condition tasks, from highest to lowest.

The **Block Throughput Ranking** worksheet ranks each block based on the total number of units that were processed/produced by the block during the simulation time, from highest to lowest. This worksheet will appear only if you selected to run a throughput simulation on the **Analysis Settings** page of the diagram control panel.

The **Block Cost Ranking** worksheet ranks each block based on the total cost that accrued for the block during the simulation, based on the task, crew and spare part pool costs, from highest to lowest.

The **System Event Log** worksheet displays information about each system event that occurred during the last simulation. Note that if you are working with a BlockSim 6 file, this worksheet is available only when a single simulation was run. If multiple simulations were run, you must re-simulate in the current version in order for this worksheet to be available.

- **Event #** displays a sequential number for each system event that occurred during the simulation.
- **Time-to-Event**: The time-to-event for each system event.
- **Repair Duration**: The repair duration for each system event.

The **System Failure Event Log** worksheet displays information about each system failure that occurred during the last simulation. Note that if you are working with a BlockSim 6 file, this worksheet is available only when a single simulation was run. If multiple simulations were run, you must re-simulate in the current version in order for this worksheet to be available.

- **Failure #** displays a sequential number for each system failure that occurred during the simulation.
- **Time-to-Failure**: The time for each system failure.
- **Repair Duration**: The repair duration for each system failure.

**RDA Data** displays system up/down data for each simulation. You can click **Send RDA Results to Weibull++** to transfer the data to a Weibull++ parametric RDA folio within the current project. If Weibull++ is installed on your computer, you can then perform parametric recurrent event data analysis on the data set. The parametric RDA folio uses
the General Renewal Process (GRP) model to analyze the failure behavior of a repairable system. The GRP analysis method takes into account the effectiveness of repairs on the condition of the system, and models the cumulative number of failures over time.

- **System ID** identifies the system that experienced an event. Here, each individual simulation is denoted by a separate system ID.
- **Event F or E** describes the type of event. An F indicates a failure event and an E indicates that the observation period has ended.
- **Time to Event** indicates the age of the system when the event occurred.

You can set the maximum number of events that can be shown in this worksheet using the **Max RDA Data** field on the **Analysis Settings page** of the simulation diagram control panel.

- **System Downtime Durations** shows the duration of every system downtime during all of the simulations, as well as the part responsible for the downtime.
- **RGA Data** displays system up/down data for each simulation, including start, failure and end events. You can click **Send RGA Results to RGA** to transfer the data to an RGA folio using the Multiple Systems - Concurrent Operating Times data type within the current project. If RGA is installed on your computer, you can then perform reliability growth analysis on the data set.

- **System ID** identifies the system that experienced an event. Here, each individual simulation is denoted by a separate system ID.
- **Event F or E** describes the type of event. An S denotes the system start time, an F indicates a failure event and an E indicates that the observation period has ended.
- **Time to Event** indicates the age of the system when the event occurred.
- **Responsible Part** identifies the block that was responsible for each failure event.

The maximum number of events that can be shown in this worksheet is controlled by the **Max RDA Data** field on the Analysis Settings page of the simulation diagram control panel.

### Simulation Quick Calculation Pad (QCP)

BlockSim includes a Quick Calculation Pad (QCP) for computing useful metrics. You can access the QCP by choosing **Simulation > Simulation > Simulation QCP** or by clicking its icon on the Simulation page of the diagram control panel.
Chapter 8: BlockSim Simulation Diagrams

To perform a calculation, select the appropriate option and enter any required inputs in the Input area, then click Calculate. For more detailed information on how to use the QCP in general, see Quick Calculation Pad (QCP).

The following calculations are available for simulation diagrams and phase diagrams:

- **Probability**
  - **Point Availability**
    Calculates the probability that the system is operational (not failed or undergoing repair) when it is requested for use at a certain point in time. Enter the time at which you wish to calculate the point availability in the Mission End Time field. The mission is assumed to start at time = 0.

    For example, a system with a point availability of 90% for a mission end time of 100 hours means that the system is expected to be available for use 90% of the time for a period of 100 hours. In other words, the system is up and running 90 times out of 100.

  - **Point Unavailability**
    Calculates the probability that the system will be failed or undergoing repair when it is requested for use at a certain point in time. Enter the time at which you wish to calculate the point unavailability in the Mission End Time field. The mission is assumed to start at time = 0.

    The point unavailability is the inverse of the point availability. For example, a 10% point unavailability is equivalent to a 90% point availability.

  - **Point Reliability**
    Calculates the probability that the system will operate without failure for a given period of time. Note that this is similar to point availability except that it is assumed that the system has not had a single failure. Other (non-failure) downtime events are also ignored. Enter the time at which you wish to calculate the point reliability in the Mission End Time field. The mission is assumed to start at time = 0.

    For example, a reliability of 90% for a mission end time of 3 years means that if 100 identical systems are fielded, then 90 of them will still be operating at the end of 3 years.
**Point Probability of Failure**

Calculates the probability that a system will be failed in a given period of time. Enter the time at which you wish to calculate the probability of failure in the **Mission End Time** field. The mission is assumed to start at time = 0.

Probability of failure is also known as unreliability and it is the inverse of the reliability. For example, a point probability of failure of 10% for a mission end time of 3 years is equivalent to a 90% reliability.

**Mean Availability**

Calculates the average availability (i.e., uptime divided by operating time) of the system at the specified time. This metric reflects the average probability, up to that point in time, that the system is operational (not failed or undergoing repair) when it is requested for use during the simulation. Enter the time at which you wish to calculate the mean availability in the **Mission End Time** field. The mission is assumed to start at time = 0.

**Mean Unavailability**

Calculates the average probability, up to the specified time, that the system will be failed or undergoing repair when it is requested for use during the simulation. It is the inverse of the mean availability. Enter the time at which you wish to calculate the mean unavailability in the **Mission End Time** field. The mission is assumed to start at time = 0.

- **Time**
  - **Time for Availability**
    
    Calculates the time at which a specified availability value will be achieved. Enter the availability goal in the **Required Availability** field.
  
  - **Time for Reliability**
    
    Calculates the time at which a specified reliability value will be achieved. Enter the reliability goal in the **Required Reliability** field.

- **Life**
  - **MTTFF**
    
    Calculates the mean time to first failure for the repairable system in the diagram. This is the average of the times at which the first system failure occurred for each simulation. Note that when the simulation end time is much less than the time to first failure for the system or when no system failures are observed, the calculation assumes a constant failure rate in order to obtain the MTTFF. If the system does
not have a constant failure rate, the simulation end time should be set to a value that is well beyond the MTTF (mean time to failure, as computed analytically) of the system in order to obtain a realistic estimate. As a general rule, the simulation end time should be at least three times larger than the MTTF of the system.

**Note:** The mean time to first failure is a performance index and does not provide any information about the behavior of the failure distribution of the system.

Simulation Plots
Plots can be created and viewed by clicking the **Plot** icon located on the Simulation page of the control panel for each diagram.

If you click the **Plot** icon before the diagram has been simulated, you will be prompted to simulate the diagram and then the data will be plotted in the plot sheet. (Note that the **Plot** icon on the Plot sheet control panel refreshes the plot. If data or settings have been changed since the diagram was last simulated, you must resimulate the data before refreshing the plot.)

You can add additional plot sheets to the diagram by right-clicking the sheet index tabs at the bottom of the window and choosing **Insert Simulation Plot** on the shortcut menu. You can delete a plot sheet from the diagram by selecting the plot sheet, right-clicking and choosing **Delete Plot**.

The plots available for simulation diagrams fall into five types:

**System Plots**
System plots display information about the entire system. These plots are available for all simulation diagrams.

- **Point Availability** shows the system’s point availability over time. The point availability is the probability that a system (or component) will be operational (up and running) at any random time, t. Note that unlike reliability plots for analytical systems, the point availability measure incorporates maintainability information.

- **Point Reliability** shows the system’s point reliability over time. The point reliability is the probability that the system has not failed by time t. This is similar to point availability with the major exception that it looks only at the probability that the system did not have a single failure. Other (non-failure) downing events are ignored. It is very important to note that this value is not always the same as the reliability computed
using the analytical methods, depending on the redundancy present. The reason that it may differ is best explained by the following scenario:

Assume two units in parallel. The analytical system reliability, which does not account for repairs, is the probability that both units fail. In this case, when one unit goes down, it does not get repaired and the system fails after the second unit fails. In the case of repairs, however, it is possible for one of the two units to fail and get repaired before the second unit fails. Thus, when the second unit fails, the system will still be up due to the fact that the first unit was repaired.

- **Both Point A & R** shows the system's point availability over time and the system's point reliability over time on the same plot.

- **Cost** shows the system's cost over time. If there are costs associated with crews and with spare part pools, these are also displayed.

- **Mean Availability** shows the system's mean availability over time, which is the proportion of time during a mission or time period that the system is available for use.

- **System Failures** shows the system's failures over time.

- **Throughput** shows the system's throughput over time.

- **System Up/Down** shows the system's uptimes and downtimes over the course of the simulation. Please note that System Up/Down Plots are designed for only one simulation (i.e., 1 must be entered for the Number of Simulations in the Maintainability/Availability Simulation window). If you run multiple simulations, the plot shows the results for the last simulation only.

- **Block Up/Down** shows each block's uptimes and downtimes over the course of the simulation. Please note that Block Up/Down Plots are designed for only one simulation (i.e., 1 must be entered for the Number of Simulations in the Maintainability/Availability Simulation window). If you run multiple simulations, the plot shows the results for the last simulation only. You can specify which blocks to include in the plot by using the Available Blocks area of the control panel.

### Metrics Plots

Metrics plots display information about the contributions that individual blocks make to failure and downing events for the entire system. If your diagram contains subdiagrams and you have selected the Report subdiagram results check box on the Analysis Settings page of the diagram control panel, you can also get results at the subdiagram level. These plots are available for all simulation diagrams.

- **RS FCI** shows the ReliaSoft Failure Criticality Index and the availability for each block. RS FCI is a relative index showing the percentage of times that a failure of the block caused
a system failure (i.e., the number of system failures caused by the block divided by the total number of system failures). Note that this relates only to failures; it does not include every event that could bring the system down (such as routine maintenance). You can specify which blocks to include in the plot by using the **Available Blocks** area of the control panel. Bar size indicates RS FCI; bar color indicates availability, as shown in the legend. Point to a bar to view the block's name, availability and RS FCI.

- **RS FCI Tableau** shows the ReliaSoft Failure Criticality Index in tableau format, along with each block's availability. The block name appears on each section of the plot. The largest sections represent the blocks with the highest RS FCI value. Section color indicates availability, as shown in the legend. Point to a plot section to view the block's name, availability and RS FCI.

- **RS DECI** shows the ReliaSoft Downing Event Criticality Index and the availability for each block. RS DECI is a relative index showing the percentage of times that a downing event of the block caused the system to go down (i.e., the number of system downing events caused by the block divided by the total number of system downing events). You can specify which blocks to include in the plot by using the **Available Blocks** area of the control panel. Bar size indicates RS DECI; bar color indicates availability, as shown in the legend. Point to a bar to view the block's name, availability and RS DECI.

- **RS DECI Tableau** shows the ReliaSoft Downing Event Criticality Index for each block in tableau format, along with each block's availability. The block name appears on each section of the plot. The largest sections represent the blocks with the highest RS DECI value. Section color indicates availability, as shown in the legend. Point to a plot section to view the block's name, availability and RS DECI.

- **RS DTCI** shows the ReliaSoft Downtime Criticality Index and the availability for each block. RS DTCI is a relative index showing the contribution of each block to the system's downtime (i.e., the system downtime caused by a particular block divided by the total system downtime). You can specify which blocks to include in the plot by using the **Available Blocks** area of the control panel. Bar size indicates RS DTCI; bar color indicates availability, as shown in the legend. Point to a bar to view the block's name, availability and RS DTCI.

- **RS DTCI Tableau** shows the ReliaSoft Downtime Criticality Index for each block in tableau format, along with each block's availability. The block name appears on each section of the plot. The largest sections represent the blocks with the highest RS DTCI value. Section color indicates availability, as shown in the legend. Point to a plot section to view the block's name, availability and RS DTCI.

**Blocks Plots**

Blocks plots display information about the individual blocks that make up the system. These plots are available for all simulation diagrams.
For blocks plots, specify which blocks to include by using the Available Blocks area of the control panel. If your diagram contains subdiagrams and you have selected the Report subdiagram results check box on the Analysis Settings page of the diagram control panel, you can also get results at the subdiagram level. Note that if your simulation does not include throughput then no information will be displayed for those plots.

- **Block Availability** shows the percent of time that each block is available during the simulation, indicated by bar size, and each block's RS DECI value, indicated by the colors shown in the legend. Point to a bar to view the block's name, RS DECI value and availability percentage.

- **Block Costs** shows the cost of each block during the simulation, indicated by bar size, and each block's RS DECI value, indicated by the colors shown in the legend. Point to a bar to view the block's name, RS DECI value and total costs.

- **Block Downtime** shows the amount of time each block is down during the simulation, indicated by bar size, and each block's RS DECI value, indicated by the colors shown in the legend. Point to a bar to view the block's name, RS DECI value and total downtime.

- **Block Expected Failures** shows the expected number of failures for each block during the simulation, indicated by bar size, and each block's RS FCI value, indicated by the colors shown in the legend. Point to a bar to view the block's name, RS FCI value and expected number of failures.

- **Block Expected Downing Events** shows the expected number of downing events for each block during the simulation, indicated by bar size, and each block's RS DECI value, indicated by the colors shown in the legend. Point to a bar to view the block's name, RS DECI value and expected number of downing events.

- **Block Throughput** shows the total number of units processed/produced by each block during the simulation time, indicated by bar size, and each block’s utilization percentage, indicated by the colors shown in the legend. Point to a bar to view the block's name, utilization percentage and throughput values.

- **Block Excess Capacity** shows the additional number of units each block could have processed/produced during the simulation, indicated by bar size, and each block’s utilization percentage, indicated by the colors shown in the legend. Point to a bar to view the block's name, utilization percentage and excess capacity values.

- **Block Backlog** shows the total number of units that were backlogged (i.e., waiting to be processed) for each block at the end of the simulation time, indicated by bar size, and each block’s utilization percentage, indicated by the colors shown in the legend. Point to a bar to view the block's name, utilization percentage and backlog values.

- **Block Backlog Processed** shows the total number of units that were backlogged but eventually processed by each block during the simulation time, indicated by bar size,
and each block’s utilization percentage, indicated by the colors shown in the legend. Point to a bar to view the block’s name, utilization percentage and backlog processed values.

- **Block Bubble Plot** allows you to specify three result types to be plotted against each other for each block. Select one result type for the x-axis and one result type for the y-axis. Select a third result type that will dictate the size of the scatter point for each block; the radius of the point will be proportional to the size of the result value. You can use the slider bar at the bottom of the Available Results area on the control panel to set the maximum point size. Point to a data point to view the three selected metrics for the block.

The following result types are available for use in the plot.

- **Uptime**: The total amount of time that the block was up (i.e., operational) during the simulation.
- **Downtime**: The total amount of time that the block was down (i.e., not operational) during the simulation.
- **Active Downtime**: For contained standby blocks, the amount of time that the block was down while in an active state during the simulation.
- **Quiescent Downtime**: For contained standby blocks, the amount of time that the block was down while in a quiescent (i.e., standby) state during the simulation.
- **Mean Downtime per Event**: The mean duration of downtime events for the block during the simulation.
- **RS DECI**: The ReliaSoft Downing Event Criticality Index for the block. This is a relative index showing the percentage of times that a downing event of the block caused the system to go down (i.e., the number of system downing events caused by the block divided by the total number of system downing events).
- **MTBDE**: The mean time between downing events for the block during the simulation.
- **RS FCI**: The ReliaSoft Failure Criticality Index for the block. This is a relative index showing the percentage of times that a failure of the block caused a system failure (i.e., the number of system failures caused by the block divided by the total number of system failures). Note that this relates only to failures; it does not include every event that could bring the system down (such as routine maintenance).
- **MTBF**: The mean time between failures for the block during the simulation.
• **RS DTCl**: The ReliaSoft Downtime Criticality Index for the block. This is a relative index showing the contribution of the block to the system's downtime (i.e., the system downtime caused by a particular block divided by the total system downtime).

• **Number of CMs**: The total number of corrective tasks performed on the block during the simulation.

• **CM Downtime**: The total amount of time that the block was down (i.e., not operational) due to corrective maintenance during the simulation.

• **Number of Inspections**: The total number of inspections performed on the block during the simulation.

• **Inspection Downtime**: The total amount of time that the block was down (i.e., not operational) due to an inspection during the simulation.

• **Number of PMs**: The total number of preventive tasks performed on the block during the simulation.

• **PM Downtime**: The total amount of time that the block was down (i.e., not operational) due to a preventive task during the simulation.

• **Number of OCs**: The total number of on condition tasks performed on the block during the simulation.

• **OC Downtime**: The total amount of time that the block was down (i.e., not operational) due to an on condition task during the simulation.

• **Number of OFFs**: The total number of times that the block was turned off due to state change triggers during the simulation.

• **OFF Downtime**: The total amount of time that the block was off due to state change triggers during the simulation.

• **Total Cost CM**: The total costs due to corrective tasks that accrued during the simulation time. This includes costs associated with the crews and spare part pools used for the tasks, as well as any downtime costs and additional per-task costs.

• **Total Cost IN**: The total costs due to inspection tasks that accrued during the simulation time. This includes costs associated with the crews used for the tasks, as well as any downtime costs and additional per-task costs.

• **Total Cost PM**: The total costs due to preventive tasks that accrued during the simulation time. This includes costs associated with the crews and spare part...
pools used for the tasks, as well as any downtime costs and additional per-task costs.

- **Total Cost OC**: The total costs due to on condition tasks that accrued during the simulation time. This includes costs associated with the crews and spare part pools used for the tasks, as well as any downtime costs and additional per-task costs.

- **Total Cost**: The total cost that accrued during the simulation time for the block, which is based on the maintenance properties, policies, crews and spare part pools costs.

- **Throughput Excess Capacity**: The additional number of units the block could have processed/produced during the simulation. The excess capacity will be calculated only if you selected to run a throughput simulation in the Maintainability/Availability Simulation window.

- **Throughput Backlog**: The total number of backlogged units (i.e., units waiting to be processed/produced) for the block at the end of the simulation. This is based on whether the block can accept a backlog and how the backlog units were allocated, as specified in the Block Properties window and Maintainability/Availability Simulation window.

- **Throughput Backlog Processed**: The total number of units that were backlogged but eventually processed/produced by the block during the simulation.

- **Throughput Backlog Excess**: The number of backlogged units that were rejected (i.e., not processed/produced) by the block during the simulation. Backlogged units will be rejected if the block has a limited backlog (i.e., a limit to the number of units that can be stored in the backlog).

- **Throughput Max Uptime Capacity**: The maximum number of units the block could have processed/produced while it was up during the simulation.

- **Throughput Uptime Utilization**: The percent of units the block actually produced/processed of what it could have processed/produced while it was up during the simulation. (i.e., the ratio of the block throughput and the block uptime capacity.)

- **Throughput Max Capacity**: The maximum capacity of the block, which is the maximum number of units the block could have processed/produced during the simulation.

- **Throughput Actual Utilization**: The percent of units the block actually produced/processed of what it could have produced/processed (i.e., the ratio of the block throughput and the block maximum capacity).
Chapter 8: BlockSim Simulation Diagrams

Crews Plots

Crews plots display information about the crews that are used in simulation of the system. These plots are available only if your analysis includes maintenance tasks that use defined crews.

For crews plots, specify which crews to include by using the Available Crews area of the control panel.

- **Crew Accepted Calls** shows the total number of calls that each crew accepted during the simulation time, indicated by bar size, and the percentage of calls each crew accepted, indicated by the colors shown in the legend. Point to a bar to view the crew's name, percentage of calls accepted and number of accepted calls.

- **Crew Rejected Calls** shows the total number of calls that each crew rejected during the simulation time, indicated by bar size, and the percentage of calls each crew accepted, indicated by the colors shown in the legend. Point to a bar to view the crew's name, percentage of calls accepted and number of rejected calls.

- **Crew Costs** shows the costs incurred by each crew during the simulation time, indicated by bar size, and the percentage of calls each crew accepted, indicated by the colors shown in the legend. Point to a bar to view the crew's name, percentage of calls accepted and total costs.

- **Crew Time Used** shows the amount of time used by each crew during the simulation time, indicated by bar size, and the percentage of calls each crew accepted, indicated by the colors shown in the legend. Point to a bar to view the crew's name, percentage of calls accepted and time used.

Spare Part Pools Plots

Spare part pools plots display information about the spare part pools that are used in simulation of the system. These plots are available only if your analysis includes maintenance tasks that use defined spare part pools.

For spare part pools plots, specify which pools to include by using the Available Pools area of the control panel to select which pools to view.

- **Pool Average Stock Level** shows the average number of spare parts in the pool during the simulation time. Point to a bar to view the pool name and average stock level.

- **Pool Items Dispensed** shows the average amount of spare parts dispensed during the simulation time. Point to a bar to view the pool name and number of items dispensed.

- **Pool Average Time to Dispense** shows the average amount of time taken to dispense items during the simulation time. Point to a bar to view the pool name and average time to dispense items.
Chapter 8: BlockSim Simulation Diagrams

- **Pool Rejected Calls** shows the average number of calls rejected by the pool during the simulation time. Point to a bar to view the pool name and number of rejected calls.

- **Pool Emergency Calls** shows the average number of emergency restock calls by the pool during the simulation time. Point to a bar to view the pool name and number of emergency calls.

- **Pool Costs** shows the average cost of the pools during the simulation time. Point to a bar to view the pool name and pool cost.

- **Pool Cost Per Item** shows the average cost of the items in each pool during the simulation time. Point to a bar to view the pool name and cost per item.

### Simulation Diagram Dashboards

You can use the flexible Dashboard utility for presenting results from simulation diagrams. To access this feature, choose Simulation > Dashboard.

As with any other Synthesis dashboard, you can use the Dashboard Viewer to select any of the layouts that have been predefined for this type of data. The Dashboard Manager is used to create or edit layouts. (In a secure database, this is available only to users with the "Manage dashboard layouts" permission.)

### Data Source Drop-Down List

When you are creating a dashboard layout based on simulation results, the drop-down list at the top of the Data Source panel gives four options.

- **System** returns system-level simulation results. **Blocks**, **Crews** and **Pools** return results for the blocks, crews and spare part pools in the diagram.
Note that when different data sources are available, all of the data fields used within a dashboard item must come from the same source. For example, you cannot include fields pertaining to blocks and fields pertaining to crews in the same chart.

**Simulation Diagram Dashboard Data Fields**

Many of the simulation results available in the Results Explorer are available as data fields for use in simulation diagram dashboard layouts. For detailed explanations of the data fields, refer to the following topics:

- **System data fields**: See the System Overview worksheet and the System Costs worksheet.
- **Blocks data fields**: See the Block Details worksheet.
- **Crews data fields**: See the Crew Details worksheet.
- **Pools data fields**: See the Spare Part Pool Details worksheet.
Chapter 9: BlockSim Phase Diagrams

A phase diagram, or more specifically a reliability phase diagram, is an extension of the reliability block diagram (RBD) approach. While an RBD is used for a system with a fixed configuration throughout the entire period of operation, a phase diagram can be used to represent scenarios in which a system may undergo changes over time to one or more of the following:

- Its reliability configuration
- The available repair resources
- The failure, maintenance or throughput properties of its individual components.

For example, a manufacturing company's production may be lower during the night shift than during the day shift. Or a system may use different components during different stages of operation, such as an aircraft during taxiing, takeoff, cruising and landing. In these and many other situations, a phase diagram can be configured so that the simulation will account for the differences in the system during different time periods.

Introduction to Phase Diagrams

In BlockSim, phase diagrams are built using phase blocks arranged chronologically to represent each sequential stage in the operation of the system. In much the same way that a subdiagram block within an RBD represents another diagram in the current project, operational phase blocks are linked to simulation RBDs that represent the reliability-wise configuration of the system during each operational phase, while maintenance phase blocks are linked to maintenance templates that describe tasks that need to be completed at some point during the system's operation.

As an example, consider an aircraft with three engines and three landing gear assemblies. The aircraft undergoes five operational phases every time it flies: taxiing, take-off, cruising, landing and taxiing. Each phase is modeled using a simulation RBD.

In a typical mission, the airplane taxies for 15 minutes, takes off for 30 seconds, cruises for 4 hours, lands for 30 seconds and taxies for another 10 minutes. Assume that when a critical failure (system failure) occurs during taxiing, the airplane does not take off and is sent for maintenance instead. However, when a critical failure occurs during take-off, cruising or landing, the system is assumed to be lost.
Chapter 9: BlockSim Phase Diagrams

The phase diagram for this aircraft's mission might be configured as shown in the following picture, where each phase block is linked to the RBD that describes the reliability-wise configuration of the aircraft during that activity.

Each of the operational phases in this diagram has two paths leading from it: a success path and a failure path. This graphically illustrates the consequences in each case. For instance, if the first taxiing phase is successful, the airplane will proceed to the take-off phase; if it is unsuccessful, the airplane will be sent for maintenance. The failure paths for the take-off, cruising and landing phases point to **stop blocks**, which indicate that the simulation of the mission ends. For the final taxiing phase, both the success and failure paths lead to the maintenance path; the **node block** allows you to model this type of shared outcome.

**What's Changed?** In BlockSim 7, there was only one path from each phase. The failure outcome for each phase was defined via a drop-down list. The success and failure paths used in the Synthesis version of BlockSim make it easy to see what will happen upon success or failure for each block. They also allow you to create more complex phase diagrams, in which success and failure may lead to entirely different sets of phases. In addition, they offer an additional possible outcome of failure. Previously, the outcome of failure could be maintenance, stopping the simulation or continuing the simulation; now, another possible outcome of failure can be continuing simulation on a different path.


The following table summarizes the operational phases and their properties. By applying a duty cycle of 1.5, the take-off and landing phases show that the system will operate at a 50% greater rate than the taxiing and cruising phases. (For more information, see Operational Phase Blocks: Duty Cycles.) The On System Failure column shows what will happen if a failure occurs during that phase. For example, if there is a system failure during the take-off, the simulation will end (indicating that the system will be lost) and a new simulation will begin. Whereas, if the system failure occurs during the taxiing phase, the system will enter a maintenance phase and may be able to resume the mission when the repairs are complete.
### Phase Name | Duration | Duty Cycle | On System Failure
--- | --- | --- | ---
Taxiing | 15 minutes | 1 | Go to the maintenance phase
Take-off | 30 seconds | 1.5 | End current simulation, start new simulation if applicable
Cruising | 4 hours | 1 | End current simulation, start new simulation if applicable
Landing | 30 seconds | 1.5 | End current simulation, start new simulation if applicable
Taxiing | 10 minutes | 1 | Go to the maintenance phase

When you simulate the phase diagram, the software will simulate the RBD linked to the Taxiing phase block for the specified period of time and then simulate the RBD linked to the Take-off phase, and so on according to the instructions in the phase diagram.

Most of the techniques for working with objects in a phase diagram, such as selecting blocks within the diagram, copying/pasting blocks and arranging blocks, are the same as the options described for RBDs and fault trees. For information on modifying appearance settings, see Diagram Skins and Appearance Settings.

The ReliaWiki resource portal has more information on phase diagrams at: [http://www.reliawiki.org/index.php/Reliability_Phase_Diagrams_(RPDs)](http://www.reliawiki.org/index.php/Reliability_Phase_Diagrams_(RPDs)). For additional information on how you might use phase diagrams, please read "Reliability Phase Diagram Analysis" at: [http://www.reliasoft.com/newsletter/v8i1/phases.htm](http://www.reliasoft.com/newsletter/v8i1/phases.htm). (Note that this article uses BlockSim 7, but the theory remains the same.)

### Phase Diagram Control Panel

The control panel associated with BlockSim phase diagrams consists of multiple pages, each containing options for performing particular tasks. This topic focuses on the Simulation page and Analysis Settings page of the phase diagram control panel, which contain most of the tools you will need to simulate a diagram. For more information about the control panel in general, see Control Panels.
Control Panel Simulation Page

The Simulation page of the control panel for phase diagrams contains the following options:

- **The Simulation** area displays the status and results of the simulation.

  ![Simulation](image)

  - **Status** If the light is green, then the simulation has been performed. If the light is red, then the simulation has not been performed. A simulated diagram will remain in the simulated state unless a change is made to the structure of the diagram (e.g., a block is added, a connector is removed, etc.).

  - **Show Simulation Details** (...) displays the most recently generated simulation results in the Results Explorer.

  - **Distribution fit** displays the distribution that has been fitted to the simulation results. Click the button (...) to open the Distribution Estimator to fit a distribution and/or for information on the fitted distribution parameters. The fitted distribution can be used to describe the overall behavior of the system and can be published for use as a model elsewhere in the project.

- **The Information** area displays information about the diagram or the currently selected block. If no block is selected in the diagram, the Information area displays the number of operational phase and maintenance phase blocks in the diagram, the total duration of all phases in the diagram and information about the diagram creation and last modification. If a block is selected in the diagram, it displays a subset of the properties found in the Block Properties window. In both cases, this area also offers a Comments field; click the field heading to enter comments. For blocks, these comments are also accessible in the Identifiers properties in the Block Properties window.

- **The Tools** area on the left side of the control panel gives you quick access to the tools you will need to analyze the diagram and generate additional results.

  - **Simulate** opens the Maintainability/Availability Simulation window, which allows you to obtain reliability, maintainability, availability and throughput results from simulations.

  - **Plot** creates a plot based on the simulation results. Clicking the Plot icon before the diagram has been simulated will automatically perform the simulation and then plot the data.
Simulation QCP opens the simulation Quick Calculation Pad (QCP). The QCP allows you to obtain reliability, maintainability and availability metrics based on the simulation results. Clicking the QCP icon before the diagram has been simulated will automatically perform the simulation and then open the QCP.

**Control Panel Analysis Settings Page**

The Analysis Settings page of the control panel for phase diagrams contains the following options:

- **Analysis Settings**
  - Select **Report subdiagram results** to provide calculated results for subdiagram blocks in the Results Explorer and certain plots. If this check box is not selected, subdiagram blocks will not appear in the results.

  - **Use system downtime threshold** allows you to specify a minimum amount of time that the system must be down in order for it to count toward critical downtime metrics.

  - Select **Run throughput simulation** to perform the throughput simulation, which allows you to perform analyses on the number of units that can be processed by the system in the diagram during the simulation time. If you select to run a throughput simulation, you can select **Report throughput point results** to include throughput results in the System Point Results worksheet, which provides results at specified points in time. If this check box is not selected, only the throughput results for the system at the simulation end time will be reported.

- **Report Settings**
  - **Report folio model** allows you to specify the results model that will be used when the diagram is used as the default data source for a Synthesis Workbook. You can choose to use either the simulation results or the fitted model.

  - **Max RDA data** allows you to specify the maximum number of events that can be shown in the RDA Data worksheet in the Results Explorer. The contents of the RDA Data worksheet can be transferred to a parametric RDA folio in Weibull++ for further analysis.

- **System Level Costs**
  - **Cost per System Failure** allows you to specify a failure cost per incident at the system level (i.e., an additional cost that is not accounted for by any of the block level costs).
**System Downtime Rate** allows you to specify a cost per unit time for downtime at the system level (i.e., an additional cost that is not accounted for by any of the block level costs).

**System Level Revenue**

- **Revenue per [Unit] of Uptime** allows you to specify an amount of revenue that is brought in by the system for each unit of uptime. This can then be accounted for as a loss when the system is down.

- **Revenue per Unit Produced** allows you to specify an amount of revenue that is brought in for each unit produced. This can then be accounted for as a loss when the system is down. This option is available only when you have selected the **Run throughput simulation** option in the **Analysis Settings** area of this control panel page.

### Operational Phase Blocks

In phase diagrams, operational phase blocks are used to represent any stage of the system's mission that is not dedicated exclusively to the execution of maintenance tasks. Operational phases are always defined by (linked to) a simulation RBD in the current project. Each operational phase has a fixed, predefined duration unless a failure occurs during the phase and then it depends on how the properties of the phase block have been configured.

Operational phase blocks can have unlimited incoming connections and up to two outgoing connections, which may include one success path and one failure path. The success path and the failure path must be different; if both success and failure of the block actually lead to the same outcome, there are two ways to model this:

- If the operational phase stops upon failure of the block and the simulation moves to the next phase along the success path, you can use a node block to model this configuration (i.e., the success path links directly to the next phase, and the failure path leads to a node block, which then links to the next phase).

- If the operational phase continues for the specified duration despite failure and the simulation then moves to the next phase along the success path, do not create a failure path.

By default, the first connection that you create from an operational phase block is the success path and the second is the failure path. You can right-click either connector and choose **Set to Success** or **Set to Failure** to swap the two paths.

You can add an operational phase block to a phase diagram by choosing **Phase > Phase > Add Operational Phase**.
The Select Diagram for the Block window will appear. The list of available diagrams will show the simulation RBDs in the project. You can use the View area to sort the list hierarchically or alphabetically. The Filter field allows you to enter text to search for in the names of the available diagrams. If the diagram that the operational phase block will be linked to does not yet exist, click the Add RBD icon to add a new diagram to the project.

To open an operational phase block that already appears in the phase diagram, double-click the block or choose Phase > Settings > Block Properties to open the Phase Properties window.

The following properties are available to configure an operational phase block:

- **Phase name** and **Description**: By default, operational phase blocks are named according to the name of the diagram they represent. You can type new text either instead of or in addition to the default name. You can change the default names by choosing File > Manage Repository > Default Name Formats.

  The **Phase name** field must be populated. Description text is optional. Note that an asterisk is used (*) to represent default block names. The block name that is displayed in the diagram will replace the asterisk with the block's default name; this allows the block name to be updated dynamically.

- **Phase Properties**
  
  - **Diagram** allows you to select a simulation RBD in the current project that you want the phase block to represent. Note that common components across different RBDs are identified by name. In other words, a component with the exact same name in two RBDs is assumed to be the same component working in two different phases.

  - **Phase duration** allows you to specify how long the system will operate in the configuration defined for this phase. If a failure has not occurred by the end of the specified phase duration, the simulation will proceed along the success path leading from the phase block. If a failure occurs, the simulation will proceed along the failure path leading from the phase block.

  - **Phase duty cycle** allows you to specify a common duty cycle value for the entire RBD that the phase represents, thereby modeling situations where the actual usage of the RBD during system operation is not identical to the usage for which
you have data. Continuous operation at the rated load is considered to be a duty cycle of 1. Any other level of usage is expressed as a percentage of the rated load value or operating time. (For more information, see Standard Blocks: Duty Cycle.)

If a duty cycle is specified for the phase and there are also duty cycles specified for blocks within the RBD, their effects are compounded. For example, if the landing gear is only in use 30% of the time during an aircraft’s take-off phase (block duty cycle = .3) and the entire system experiences 1.5 times the normal stress during take-off (phase duty cycle = 1.5) then the effective duty cycle for the landing gear during take-off would be .3 x 1.5 = 0.45.

- **Phase Throughput** properties allow you to specify the maximum output that the entire system can process during the particular phase. (See Throughput Analysis with Phase Diagrams.)
- **Identifiers**: The Comments field allows you to enter additional information about the block.

The Active Phase drop-down list at the bottom of the window allows you to choose another phase that you want to edit without the need to close and reopen the Phase Properties window. This option works in exactly the same way as the Active Block feature in the Block Properties window.

### Maintenance Phase Blocks

A maintenance phase represents the portion of the overall mission time when the system is down and maintenance actions are being performed on some or all of its components. A maintenance phase block is defined by (linked to) a maintenance template. This template can be thought of as a list of the specific components (blocks) that are designated to undergo inspection, repair or replacement during the maintenance phase, along with their maintenance priority order. For example, if blocks A, B and C are to undergo maintenance during a specific phase, they are placed in a maintenance template in a sequence that defines the priority for completing each task. If three repair crews and three spare parts are available at the same time, the tasks on A, B and C will be carried out simultaneously. However, if only one crew is available, the tasks will be carried out based on the priority order defined in the template.

**Note:** Maintenance tasks defined in the RBDs represented by operational phase blocks may also be carried out. (See Maintenance Phases and Maintenance Tasks in Diagrams.)

Given that many aspects of maintenance can be probabilistically defined (e.g., the time to repair, the time to obtain a spare part, etc.), the duration of a maintenance phase is not fixed;
the phase lasts as long as it takes to complete all of the tasks specified in the maintenance template.

Maintenance phase blocks can have unlimited incoming connections and a single outgoing connection.

You can add a maintenance phase block to a phase diagram by choosing Phase > Phase > Add Maintenance Phase.

Tip: Maintenance phase blocks have a square at the upper left corner of the block. You can change the size and color of the indicator via the relevant Block Corner Indicators page of the Diagram Style window.

To open a maintenance phase block that already appears in the phase diagram, double-click the block or choose Phase > Settings > Block Properties to open the Phase Properties window.

The following properties are available to configure a maintenance phase block:

- **Phase name and Description**: Each block is given a default name that is determined based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired.

  The Name field must be populated. Description text is optional. Note that an asterisk is used (*) to represent default block names. The block name that is displayed in the diagram will replace the asterisk with the block's default name; this allows the block name to be updated dynamically.

- **Phase Properties**

  - **Maintenance Template** allows you to select a maintenance template from the current project that you want the phase to represent. Once you have assigned a maintenance template, the number of blocks in the maintenance template is also shown.

  - **Interval maintenance threshold** allows you to specify the age interval when preventive or inspection tasks based on system or item age intervals (fixed or dynamic) will be performed. This can help you optimize the resources allocated to repair the system during a maintenance phase by performing preventive maintenance or inspections when the system is already down.
in a maintenance phase. This property provides the ability to add some flexibility to the timing of scheduled preventive maintenance actions and/or inspections.

For example, imagine that a preventive maintenance action is scheduled for a car (e.g., an oil change, tire rotation, etc.) at 60,000 miles, but a system downing event occurs at 55,000 miles. The Interval Maintenance Threshold allows you to stipulate that the preventive task will be performed upon a system downing event as long as a specified percentage of that 60,000 miles has passed. If, in this case, you specify an Interval Maintenance Threshold of 0.9, the preventive task will be performed if a system downing event occurs after at least 54,000 miles (60,000 miles x 0.9 = 54,000 miles). Thus, the downing event at 55,000 miles will trigger the preventive task. On the other hand, if you were to specify an Interval Maintenance Threshold of 0.95, the preventive task would not be performed upon the system downing event at 55,000, because that event preceded the threshold age of 57,000 miles (60,000 miles x 0.95 = 57,000 miles).

- **Identifiers**: The Comments field allows you to enter additional information about the block.

The Active Phase drop-down list at the bottom of the window allows you to specify another phase block that you want to edit without the need to close and reopen the Phase Properties window. This option works in exactly the same way as the Active Block feature in the Block Properties window.

**Note**: A maintenance phase will not end until all components are restored. Therefore, if any failed block does not have a task that restores it, the maintenance phase will not end.

**Maintenance Phases and Maintenance Tasks in Diagrams**

Not all maintenance performed during simulation of a phase diagram is necessarily performed during maintenance phases. There may also be tasks assigned to the blocks within a simulation RBD represented by an operational phase block.

- Scheduled tasks that are assigned to blocks within the simulation RBD are performed as defined, even if they bring the system down.

- For a block that does not bring the system down when it fails, the assigned corrective task (if any) is also performed as defined.

- If the block failure brings the system down, then the connections in the phase diagram determine what happens:
• If a failure path is defined, the current phase is interrupted and the phase linked to the failure path begins. (This could be a maintenance or another operational phase.) Maintenance properties defined in this new phase now apply. For the block that just failed, the new corrective maintenance properties apply. For other blocks with maintenance in progress, the rules for interrupted maintenances apply.

• If no failure path is defined, then the phase continues until its specified duration is completed. In this case, the tasks apply as defined in the RBD.

### Maintenance Templates

Maintenance templates are resources that serve as the basis for maintenance phases in phase diagrams. The templates contain the repairable blocks of a system that will need maintenance during the phase.

**What's Changed?** In BlockSim 7, a maintenance template was a separate collection of blocks not associated with any specific diagram. When a template was used in a maintenance phase, the maintenance tasks for each block would apply to any diagram that contained blocks with the same name. In the Synthesis version, the maintenance tasks for each block will apply only to blocks in the diagrams used to create that template. If two blocks in a diagram have the same name, the phase simulation will not run.

To create a new maintenance template, click the Create New Maintenance Template icon in the Maintenance Template wizard, which is accessed from the Maintenance Template field in the Phase Properties window, or, on the Maintenance Templates page of the Resource Manager, choose Main > Resource > New. In the Select Diagrams window, select the RBD(s) that the template will pull information from. After you have selected at least one diagram, the Maintenance Template window will open with a row for each block that appears in the selected diagram(s).
For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the Synthesis resources you need for your analyses.

The following settings are available to configure the template:

- **Maintenance Template Tab**
  - **Order** allows you to rearrange the priorities for performing maintenance on the blocks listed in the template. Clicking inside a cell in this column will cause an up arrow and a down arrow to appear; you can use these arrows to move the block to the desired priority order, or you can drag the row to the desired location.

- **Corrective Task** allows you to apply a corrective maintenance task to a block. You can choose an existing task from the drop-down list. In addition, you can click the **Select Existing** icon to open the Select Resource window. If there is not an existing task that meets your needs, you can create a new one by clicking the **Create New** icon. Click the **View/Edit** icon to view the characteristics of the selected task.
• **Other Tasks** allows you to apply preventive, on condition and/or inspection tasks to each block (multiple tasks can be applied).

• **Maintenance Group** allows you to identify each block as part of a maintenance group. Events within *maintenance groups* may trigger maintenance or state changes for other blocks.

• **In Diagrams** shows where the block appears (i.e., in which of the diagrams that the template pulls information from).

It is important to note that the settings specified here override those specified via the Block Properties window. Therefore, any tasks or maintenance groups that are assigned directly to a block via the Block Properties window will be ignored when the diagram is simulated as part of the simulation of a phase diagram. Only those tasks and maintenance groups specified in the maintenance template will be used under these circumstances.

• **Comments Tab** allows you to enter comments about the maintenance template.

• **Select Diagrams** allows you to change which RBD(s) the template pulls information from.

• **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the *Dependency Viewer*.

Once you have created a maintenance template, you will be able to include a maintenance phase in a phase diagram simulation.

**Note:** If multiple blocks have the same name in a given diagram, a message will be displayed to notify you of this problem. Although you can still create the maintenance template, you will not be able to simulate a phase diagram that uses the maintenance template until you have renamed the blocks in the RBD to avoid duplicate block names.

---

**Subdiagram Phase Blocks**

Subdiagram phase blocks represent other phase diagrams within the project. Using subdiagram phase blocks allows you to incorporate phase diagrams as phases within other phase diagrams. This allows you to break down extremely complex configurations into smaller diagrams, increasing understandability and ease of use and avoiding unnecessary repetition of elements.
Chapter 9: BlockSim Phase Diagrams

Subdiagram phase blocks can have unlimited incoming connections and up to two outgoing connections, which may include one success path and one failure path. The success path and the failure path must be different; if both success and failure of the block actually lead to the same outcome, you can use a node block to model this configuration.

You can add a subdiagram phase block to a phase diagram by choosing Phase > Phase > Add Subdiagram Phase.

The Select Diagram for the Block window will appear. The list of available diagrams will show the phase diagrams in the project. You can use the View area to sort the list hierarchically or alphabetically. The Filter field allows you to enter text to search for in the names of the available diagrams. If the diagram that the subdiagram phase block will be linked to does not yet exist, click the Add Phase Diagram icon to add a new diagram to the project.

To open a subdiagram phase block that already appears in the phase diagram, double-click the block or choose Phase > Settings > Block Properties to open the Phase Properties window.

To get a quick preview of the subdiagram without actually opening it, select the block and choose Phase > Selection > Quick View.

The following properties are available to configure a subdiagram phase block:

- **Phase name and Description**: Each block is given a default name that is determined based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired.

  The Name field must be populated. Description text is optional. Note that an asterisk is used (*) to represent default block names. The block name that is displayed in the diagram will replace the asterisk with the block's default name; this allows the block name to be updated dynamically.

- **Phase Properties**
  - **Phase Diagram** allows you to select a phase diagram in the current project that you want the block to represent.
  - **Identifiers**: The Comments field allows you to enter additional information about the block.
The **Active Phase** drop-down list at the bottom of the window allows you to choose another phase that you want to edit without the need to close and reopen the Phase Properties window. This option works in exactly the same way as the **Active Block** feature in the [Block Properties window](#).

## Node Blocks and Stop Blocks

In the Synthesis version of BlockSim, the two possible outcomes of an operational phase block are modeled using success and failure paths. Where previously a failure outcome was defined as part of the operational phase block's properties, it is now graphically represented within the diagram. Node blocks and stop blocks are provided to allow you to build configurations that are both accurate and readable.

### Node Blocks

The purpose of a node block is simply to enable configurations that would otherwise not be possible due to limitations on connecting blocks. For example, consider an instance where maintenance is scheduled to be performed after the operational phase has completed successfully, and if a failure occurs during simulation, that maintenance will take place upon failure. In this case, the operational phase block's success and failure outcomes are identical. Success paths and failure paths cannot be identical in phase diagrams, however, so you would model this configuration in one of two ways:

- If the operational phase stops upon failure of the block and the simulation moves to the next phase along the success path, you would use a node block to model this configuration, as shown next.

![Node Block Diagram](image)

- If the operational phase continues for the specified duration despite failure and the simulation then moves to the next phase along the success path, you would simply not create a failure path. If there is only a success path, then upon system failure during this phase, the corrective maintenance specified begins and the time to restore the system is part of the operational phase's time. In other words, the repairs continue in the operational phase until the system is up again. If the repairs are not completed before the phase ends, the repairs continue into the next phase. Thus, in this case, the duration...
of an operational phase is not affected by a system failure. For example, consider a production line operating in two phases: a day shift and a night shift. A failure occurs in the day shift that renders the production line non-operational. Repair of the production line begins immediately and continues beyond the day shift. The production line is back up after midnight. In this case, the repair of the production line exhausts all of the duration of the day shift phase from the time of the failure to the end of the phase. Some part of the night shift phase is also exhausted.

Node blocks can have unlimited incoming connections and a single outgoing connection. Node blocks have no properties other than their block name. Each block is given a default name that is determined based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired.

**Stop Blocks**
Stop blocks indicate that the simulation of the mission ends. A new simulation may then begin, if applicable. This is useful in situations where maintenance is not possible upon failure.

Stop blocks can have unlimited incoming connections. No outgoing connections can be defined for stop blocks.

**Simulation Assumptions for Phase Diagrams**
The underlying assumptions when performing simulations are:

- Phase duration is based on calendar time.
- Age is carried over from phase to phase.
• All identically-named blocks of a given block type, across all diagrams and subdiagrams, refer to the same item, and results for these blocks are combined. The phases cannot contain identically-named blocks of different types (e.g., standard blocks and contained blocks). Note, however, that contained blocks are underlyingly named in the format ContainerName:BlockName, so a standard block named "MyBlock" and a contained block named "MyBlock" inside a container named "MyContainer" are not identically named and do not refer to the same item.

Maintenance Tasks in Operational Phases
Maintenance tasks in progress during one operational phase can be interrupted if that phase ends before the repair is completed. For example, a crew delay or spare parts order may extend the duration of a repair beyond the duration of the phase. As described next, the software handles these interruptions differently, based on the stage in which the repair was interrupted and whether or not the failed block is present in the next contiguous phase.

• If a phase ends during the repair of a failed block and the block is present in the next contiguous phase:
  • If the same task is present in both phases, then the task will continue as-is in the next phase. This is considered an uninterrupted event, and counts as a single unique event at both the block and the system level.
  • If the interrupted task is not used in the next phase, then the task is canceled and new tasks are applied as needed. In this case, all crew calls are canceled and spare parts are restocked.
    • If the repair has started or the crew is delayed (crew logistic delay), the call will be assumed accepted and the component will be charged for it. If the crew was occupied with another component's repair, the call will be assumed rejected and hence not charged to the component.
    • If the call for spare parts incurred emergency charges, those are charged to the block; otherwise, there are no other charges to the block.
• If a phase ends during the repair of a failed block and the block is not present in the next contiguous phase, then the task is canceled and new tasks are applied as needed. All crew calls are canceled and spare parts are restocked.
  • If the repair has started or the crew is delayed (crew logistic delay), the call will be assumed accepted and the component will be charged for it. If the crew was occupied with another component's repair, the call will be assumed rejected and hence not charged to the component.
  • If the call for spare parts incurred emergency charges, those are charged to the block; otherwise, there are no other charges to the block.
Chapter 9: BlockSim Phase Diagrams

- Discontinuous events are counted as two distinct events at both the block and the system level.
- When the system fails in a phase that has a failure path leading to a stop block, the system will remain down for the remainder of the simulation. From that point on, the blocks that are down are assumed unavailable and the blocks that are up are assumed operational for availability calculations.

**Maintenance Phases**

A system is considered down and unavailable during the execution of a maintenance phase and remains down until all components have been repaired or maintained according to the properties specified for the maintenance phase. A maintenance phase is executed when the simulation reaches the phase while progressing through the phase diagram, either following a success path or a failure path. The following assumptions apply to both cases.

- When a component enters a maintenance phase in a down state, the following rules apply:
  - If a task is in progress for this component, the event will transfer to the maintenance phase provided that the same task is present in the maintenance phase. The rules for interrupted tasks apply as noted above.
  - If the component is failed but no corrective maintenance is in progress (either because the component was non-repairable in the phase where it failed or because it had a task scheduled to be executed upon inspection and was waiting for an inspection), a repair is initiated according to the corrective maintenance properties specified for the component in the maintenance phase.
  - Failed components are fixed in the order in which they failed.
  - If a block does not have a corrective task in the maintenance phase but does have an on condition task, the preventive portion of the on condition task is triggered immediately in order to restore the block.

- When a component enters a maintenance phase in an operating state, the following rules apply:
  - Maintenance will be scheduled as follows:
    1. Tasks based on intervals or upon start of a maintenance phase
    2. Tasks based on events in a maintenance group, where the triggering event applies to a block
    3. Tasks based on system down
4. Tasks based on events in a maintenance group, where the triggering event applies to a subdiagram

Within these categories, order is determined according to the priorities specified in the maintenance template (i.e., the higher the task is on the list, the higher the priority).

- An inspection or preventive task may be initiated, if applicable, with inspections taking precedence over preventive tasks. Inspections and/or preventive tasks are initiated if one of the following applies:
  - Upon certain events:
    - The task is set to be performed when a maintenance phase starts.
    - The policy is set to be performed based on events in a maintenance group and one of those events occurs within the one of the specified maintenance groups. Note that such a triggered maintenance does not follow the priorities specified in the maintenance template, but is sent to the end of the queue for repair.
    - The task is set to be performed whenever the system is down.
  - At certain intervals:
    - The task is set to be performed at a fixed time interval, based on either item age or calendar time, and the maintenance falls within the maintenance threshold specified in the maintenance phase.

If the inspection task is not set to bring either the item or the system down, the inspection will still be considered a downing inspection.

**State Change Triggers and Phase Diagrams**

Starting in Version 11, the on/off state of a block with state change triggers is maintained across phases (i.e., it is not reset from any previous phase). In previous versions, the state was determined at the beginning of each phase based on the initial state specified in the block’s properties.
Chapter 9: BlockSim Phase Diagrams

Results and Plots

The results available for phase diagrams, including those available in the Results Explorer and those available in the simulation QCP, are identical to the results available for simulation diagrams.

The plots available for phase diagrams are the same as the simulation diagram plots, with the exception that there are also system-phases plots available. In addition, for certain plots, you must specify which phase(s) you want to show in the plot.

- **Available Phases** allows you to specify which phases to display on the plot. To select all phases, click the check box in the table header. To select individual phases, click the check box in each row.

  The **Available Phases** option is available for all system-phases plots, metrics plots and blocks plots (other than the Block Backlog plot, which provides information about the backlog at the end of the simulation time, and the Block Bubble plot). It is also available for all crews plots and spare part pools plots if your analysis includes those items.

  The system-phases plots display information about the individual phases that make up the phase diagram.

- **Availability - All Events** shows the percent of time that the system is available during the simulation, taking into account all system downing events, and the phase RS DECI (i.e., the number of system downing events in that phase divided by the total number of system...
downing events across all phases). Bar size indicates system availability during the phase; bar color indicates the RS DECI value of the phase, as shown in the legend. Point to a bar to view the system availability during that phase.

- **Availability w/o PM, OC & Insp** shows the percent of time that the system is available during the phase, taking into account all downing events, but not preventive, on condition or inspection tasks, and the system RS DECI (i.e., the number of system downing events in that phase divided by the total number of system downing events across all phases). Bar size indicates system availability during the phase; bar color indicates the RS DECI value of the phase, as shown in the legend. Point to a bar to view the system availability during that phase.

- **Costs** shows the system costs and the system availability during the simulation. Bar size indicates system costs during the phase; bar color indicates system availability during the phase, as shown in the legend. Point to a bar to view the system availability and costs accrued during that phase.

- **Downtime** shows the amount of time the system is down and the system availability during the simulation. Bar size indicates system downtime during the phase; bar color indicates system availability during the phase, as shown in the legend. Point to a bar to view the system availability and downtime during that phase.

- **Expected Failures** shows the expected number of failures for the system and the system availability during the simulation. Bar size indicates the expected number of failures during the phase; bar color indicates system availability during the phase, as shown in the legend. Point to a bar to view the system availability and expected number of failures during that phase.

- **Expected Downing Events** shows the expected number of downing events for the system and the system availability during the simulation. Bar size indicates the expected number of downing events during the phase; bar color indicates system availability during the phase, as shown in the legend. Point to a bar to view the system availability and expected number of downing events during that phase.

- **Throughput** shows the number of units processed/produced by the system and the system availability during the simulation. Bar size indicates system throughput during the phase; bar color indicates system availability during the phase, as shown in the legend. Point to a bar to view the system availability and throughput during that phase. If your simulation does not include throughput then no information will be displayed for this plot.

### Throughput Analysis with Phase Diagrams

If you are performing throughput analysis for a phase diagram, you will need to specify, for each operational phase, how its possible throughput is calculated. The phase throughput
properties in the Phase Properties window allow you to specify the maximum throughput that the entire system can process during the particular phase. (For a detailed discussion of throughput at the block level, see the Throughput Analysis topic.)

A phase's throughput can be thought of as the initial throughput that enters the system modeled in the linked RBD. For example, imagine a textile factory that receives different quantities of raw materials during different seasons. These seasons could be treated as different phases. In this case a phase may be seen as sending a certain quantity of units to the first component of the system (the textile factory in this case). Depending on the capacity and availability of the factory, these units may be all processed or a backlog may accumulate.

Phase throughput can be one of the following:

- **Unrestricted throughput** specifies that the amount of output the system can process during the phase will be equal to the amount that the linked diagram can process during the specified phase duration.

- **Constant throughput** allows you to specify an amount of throughput per unit time that is the same throughout the entire simulation.

- **Variable throughput** allows you to specify an amount of throughput per unit time that varies over the course of the simulation. For example, the flow of oil from a well may drop over time as the oil reserves are depleted so the amount of throughput per unit time will decrease as the simulation time increases. If you select this option you must also specify the following:
  - **Throughput model** allows you to choose the model that describes the change in throughput, \(y\), as a linear function of time, \(x\). You can choose from three general models for this purpose:
    - Linear
    - Exponential
    - Power

  The parameters, \(a\) and \(b\), for each of these models are chosen by the user based on engineering judgment and on any previous data.

- **Maximum throughput capacity** allows you to specify the maximum throughput capacity of the phase. Once this maximum throughput capacity value is reached, the throughput per unit time becomes constant and equal in value to the maximum throughput capacity specified by the user. In this situation, the variable throughput model would then act as a constant throughput model. For example, suppose a machine has a constant throughput when functioning normally. When an outage happens, it takes about 12 days to restore the
machine. Every time the machine fails, it is repaired and then the throughput goes through a warm up period of 5 days until it reaches normal production capacity again. During this warm up period, the machine is not operating at its maximum level, but after the warm up period and the machine returns to its normal function and achieves its maximum and constant throughput.

Even though only three models are available, they provide considerable modeling flexibility. This flexibility is achieved by using the functions as building blocks for more complex functions. As an example, you can create a step model by using multiple phases that each have a constant throughput. A ramp model would use phases with linearly increasing functions in conjunction with constant phases, and so forth.
Chapter 10: BlockSim Markov Diagrams

Markov diagrams allow you to model the behavior of systems based on transitions between states, where the next state that the system enters is dependent only upon the current state (and not affected by any previous states). This gives you the ability to look at partial or degraded working states, and to start analysis in varying states.

Markov diagrams may be:

- **Discrete** - At the end of a given step, the system will transition to another state (or remain in the current state), based on fixed probabilities. Appropriate for general probabilities, genetics, physics, etc.

- **Continuous** - The time of state transition is unknown; therefore, the rate is determined from exponential probability models. Appropriate for examining system reliability.

In both discrete and continuous diagrams, you can use phases to represent situations where the transitions between states change over time.

*Note:* Markov diagrams are available only if supported by your license.

Building a Markov Diagram - An Overview

The basic steps for creating a Markov diagram that is ready for analysis are as follows:

1. Add a state block for each possible state.
2. Define the initial probability that the system will be in each state at the start of analysis. The sum of the initial probabilities for all states must equal 1.
3. Connect the blocks to show the possible transitions between states.
4. For each transition, define the conditions under which the system moves from the source state to the target state (fixed probability of occurrence for a discrete diagram, exponential distribution representing the rate at which the change happens for a continuous diagram).
5. Specify how long the analysis will run (number of steps for a discrete diagram, length of time for a continuous diagram).
6. If you are using phases:
   - A. Create a diagram for each additional phase.
   - B. Specify the order of the phases.
C. Specify the overall length of the analysis.

Most of the techniques for working with objects in a Markov diagram, such as selecting blocks within the diagram, copying/pasting blocks and arranging blocks, are the same as the options described for RBDs and fault trees. For information on modifying appearance settings, see Diagram Skins and Appearance Settings.

For more detailed information on using each diagram type, see Discrete Markov Diagrams and Continuous Markov Diagrams. For information about using phases, see Phases in Markov Diagrams.

Discrete Markov Diagrams

In discrete Markov diagrams, the system moves from state to state in steps. These steps are not necessarily time-based; although they can represent a fixed period of time, they can also represent distance or any other measurement. At each step, there is a fixed probability of the system transitioning to another state.

This topic describes how to create a discrete Markov diagram that is ready for analysis. For information about analysis results, see Markov Diagram Results and Markov Diagram Plots.

Define the States

Add a state block to represent each state that the system can be in.

To configure a state block in a discrete Markov diagram, you will need to specify the probability that the system will be in that state during the first step of the analysis in the Initial Probability field. The sum of the initial probability values for all of the state blocks in the diagram must be equal to 1.

The state block may be configured to store the mean probability of the state at the end of the analysis in a variable. The Storage Variable field displays the name of the variable, if any.

Define the Transitions

Connect the state blocks in the diagram to show the possible transitions between states. Once you have drawn each transition, double-click it to open the Transition Properties window. Define the probability of the system moving from the source state to the target state by assigning a constant model for the Transition Probability.

For any state, the sum of the probabilities of the outgoing transitions must be less than or equal to 1. If it is less than 1, the probability of the system remaining in the state is equal to (1 - the sum of the probabilities of the outgoing transitions).
Note that if a state does not have any outgoing transitions, then once the system enters that state, it cannot leave it. This kind of state is called a *sink*. 

### Specify the Analysis Length

In the **Number of Steps** field on the control panel, specify the number of steps to be performed when analyzing the diagram. At each step, the probability of being in a particular state is calculated based on the current probability of being in a particular state and the specified transition probability values. After a certain number of steps, the diagram will reach a steady state, meaning that calculations beyond that point offer no additional information.

### Discrete Markov Diagram Example

To demonstrate the use of discrete Markov diagrams with a very simple example, let's assume that a day can be either sunny or rainy, and that today is sunny. You want to look at the chances of sun and rain for the next 20 days.

When a day is sunny, there is a 55% chance that the next day will be rainy and a 45% chance that the next day will be sunny. When a day is rainy, there is an 85% chance that the next day will be sunny and a 15% chance that the next day will be rainy. This can be represented by the following *transition matrix*:

<table>
<thead>
<tr>
<th>FROM</th>
<th>Sunny Day</th>
<th>Rainy Day</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sunny Day</td>
<td>0.45</td>
<td>0.55</td>
</tr>
<tr>
<td>Rainy Day</td>
<td>0.85</td>
<td>0.15</td>
</tr>
</tbody>
</table>

You create a discrete Markov diagram and add the following:

- A state block called "Sunny Day" with an initial probability value of 1. This reflects the fact that today is sunny (i.e., there is a 100% chance of a sunny day).
- A state block called "Rainy Day" with an initial probability of 0.

You then connect the blocks. For the transition from "Sunny Day" to "Rainy Day," you use a constant model equal to 0.55. For the transition from "Rainy Day" to "Sunny Day," you use a constant model equal to 0.85.

The Markov diagram is shown next, with all associated block and transition properties windows.
Note that when it is a sunny day, the probability of it remaining in that state the next day is 0.45 (1.00 - the 0.55 probability of a rainy day), as shown at the upper left corner of the "Sunny Day" block. Similarly, when it is a rainy day, the probability of the next day being rainy is 0.15 (1.00 - 0.85), as shown for the "Rainy Day" block.

You then click the **Diagram Properties** icon on the control panel and enter 20 in the **Length (Steps)** field. Then you click **Calculate** to analyze the diagram.

A variety of results will be available in the **plot sheet**, **QCP** and **Results Explorer**.

For example, you click **Show Results** to open the explorer.

![Diagram Image]
On the Result Summary page, you can see that the mean probability of the system being in the "Sunny Day" state is approximately 0.602, and the mean probability of the system being in the "Rainy Day" state is approximately 0.398, as shown next.

<table>
<thead>
<tr>
<th>State Name</th>
<th>Initial Probability</th>
<th>Mean Probability</th>
<th>Point Probability</th>
<th>Steps Spent in State</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sunny Day</td>
<td>1</td>
<td>0.601531</td>
<td>0.607143</td>
<td>12.030612</td>
</tr>
<tr>
<td>Rainy Day</td>
<td>0</td>
<td>0.398469</td>
<td>0.392557</td>
<td>7.969388</td>
</tr>
</tbody>
</table>

### Continuous Markov Diagrams

In *continuous* Markov diagrams, the system does not proceed according to fixed steps. Instead, the rates at which the system's states transition are determined from exponential distributions.

This topic describes how to create a continuous Markov diagram that is ready for analysis. For information about analysis results, see [Markov Diagram Results](#) and [Markov Diagram Plots](#).

#### Define the States

Add a state block to represent each state that the system can be in.

To configure a state block in a continuous Markov diagram, you will need to specify the following:

- In the **State Type** field, specify whether the system is available or unavailable when in that state. Unavailable states are indicated within the diagram by a red triangle at the lower right corner of the block.

- In the **Initial Probability** field, enter the probability that the system will be in that state at time equal to 0. The sum of the initial probability values for all of the state blocks in the diagram must be equal to 1.

- In the **Cost** field, enter the cost per unit time, if any, associated with the system being in that state. Note that you can specify a negative cost, which is a profit.

The state block may be configured to store the mean availability of that state at the end of the analysis in a variable. The **Storage Variable** field displays the name of the variable, if any.

#### Define the Transitions

Connect the state blocks in the diagram to show the possible transitions between states. Once you have drawn each transition, double-click it to open the Transition Properties window.

Assign a 1-parameter exponential model for the **Transition Probability**. This model represents the time at which the system moves from the source state to the target state.
Note that if a state does not have any outgoing transitions, then once the system enters that state, it cannot leave it. This kind of state is called a sink.

**Specify the Analysis Length**
In the Operating Time field on the control panel, specify the length of time to be considered when analyzing the diagram.

**Continuous Markov Diagram Example**
To demonstrate the use of continuous Markov diagrams with a very simple example, let's assume that you have a system with two pumps, A and B. At any given time, the system may be in one of 5 states:

1. B is active, A is in standby. Both are in working condition. This is the state in which you want analysis to start.
2. A is active, B is in standby. Both are in working condition.
3. B fails. A is active and B is undergoing repair.
4. A fails. B is active while A is undergoing repair.
5. Both pumps are undergoing repair.

A pump that is active fails according to a 1-parameter exponential distribution with a mean time of 100 hours. A pump that is in standby fails according to a 1-parameter exponential distribution with a mean time of 200 hours. Repair time is described by a 1-parameter exponential distribution with a mean time of 20 hours.

You create a continuous Markov diagram and add the following:

- A state block called "State 1" with an initial probability value of 1 and a state type of available.
• 3 state blocks, "State 2," "State 3" and "State 4," each with an initial probability value of 0 and a state type of available.

• A state block called "State 5" with an initial probability value of 0 and a state type of unavailable.
You then create models to represent the failure rate of active pumps, the failure rate of standby pumps and the repair time. You use these models to define the state transitions. The Markov diagram is shown next.
The Result Summary table is shown next.

<table>
<thead>
<tr>
<th>State Name</th>
<th>Initial Probability</th>
<th>Mean Probability</th>
<th>Point Probability (Av)</th>
<th>Point Probability (Rel)</th>
<th>Time Spent in State</th>
<th>Cost, $</th>
</tr>
</thead>
<tbody>
<tr>
<td>State 1</td>
<td>1</td>
<td>0.403563</td>
<td>0.37594</td>
<td>0.05228</td>
<td>403.563293</td>
<td>0</td>
</tr>
<tr>
<td>State 2</td>
<td>0</td>
<td>0.352365</td>
<td>0.37594</td>
<td>0.05228</td>
<td>352.364859</td>
<td>0</td>
</tr>
<tr>
<td>State 3</td>
<td>0</td>
<td>0.113214</td>
<td>0.112782</td>
<td>0.013534</td>
<td>113.213546</td>
<td>0</td>
</tr>
<tr>
<td>State 4</td>
<td>0</td>
<td>0.108873</td>
<td>0.112782</td>
<td>0.013534</td>
<td>108.873197</td>
<td>0</td>
</tr>
<tr>
<td>State 5</td>
<td>0</td>
<td>0.021985</td>
<td>0.022556</td>
<td>0.868373</td>
<td>21.985109</td>
<td>0</td>
</tr>
</tbody>
</table>
Phases in Markov Diagrams

In much the same way that you can use phase diagrams to represent systems that change over time, you can use phases in Markov diagrams to represent situations where the transitions between states change over time.

To enable phases in any Markov diagram, select the Use phases check box in the control panel. The Phases panel will appear at the bottom of the diagram, and the current diagram will be shown as Phase 1 in the panel.

To add another phase, click the Add Phase icon in the Phase panel.

A new phase will be added to the end of the phase list. Each new phase is created as a copy of the phase that is currently selected in the Phase panel; you can then edit the phase as desired. The panel shows a thumbnail of each phase. To see a larger view of any phase that is not currently selected, move the pointer over the thumbnail.

To delete a phase, select it in the Phase panel and click the Delete Phase icon.

The order in which the phases are shown in the Phase panel dictates the order in which they will be performed during analysis. You can change the order of the phases by clicking the Phase Order icon.

To change the phase name or specify how long the phase will run (number of steps for a discrete diagram, length of time for a continuous diagram), click the Phase Properties icon.

Specifying the Analysis Length

The total length of the analysis is, by default, equal to the sum of the lengths of all phases; this is considered to be "one cycle." For example, if you are working with a continuous Markov diagram that has 3 phases, where Phase 1 has a duration of 100 hours, Phase 2 has a duration of 50 hours and Phase 3 has a duration of 25 hours, then one cycle for the analysis will be 175 hours.

You can change the analysis length by specifying a new Operating Time (for continuous diagrams) or Number of Steps (for discrete diagrams) on the control panel. For instance, in the case mentioned here, if you specify an operating time of 200 hours, then Phase 1 will run for
Chapter 10: BlockSim Markov Diagrams

100 hours, Phase 2 for 50 hours, Phase 3 for 25 hours and then Phase 1 will run again for the remaining 25 hours.

If the analysis length that you have specified is not equal to one cycle, you can reset the value to one cycle by clicking the **Set to One Cycle** icon.

---

**Markov Diagram Control Panel**

This topic focuses on the Analytical page of the Markov diagram control panel, which contains most of the tools you will need to analyze a Markov diagram. For more information about the control panel in general, see Control Panels.

**Analytical Area**

The Analytical area displays the status and results of the analysis.

- **Status** If the light is green, then the diagram has been analyzed. If the light is red, then the diagram has not been analyzed. An analyzed diagram will remain in the analyzed state unless a change is made to the diagram (e.g., a block is added, a transition is removed, a phase is added, etc.).

- **Show Results** (...) displays the most recently generated analysis results in the Results Explorer.

- **Distribution fit** is available only for continuous Markov diagrams. It displays the distribution that has been fitted to the analytical results. Click the button (...) to open the Distribution Estimator to fit a distribution and/or for on the fitted distribution parameters. The fitted distribution can be used to describe the overall behavior of the system and can be published for use as a model elsewhere in the project.

- **Number of Steps** is available only for discrete diagrams. It allows you to specify the number of steps to be performed when analyzing the diagram. If the **Use phases** check
box is selected below, phases will be enabled in the diagram and this value will represent the total length of the analysis (i.e., the sum of the lengths of all phases).

- **Operating Time** is available only for continuous diagrams. It allows you to specify the length of time to be considered when analyzing the diagram. If the **Use phases** check box is selected below, phases will be enabled in the diagram and this value will represent the total length of the analysis.)

**Information Area**

If nothing is selected in the diagram, the **Information** area displays basic information about the diagram (or the phase that is currently selected). If a block or transition is selected, it displays a subset of the properties found in the properties window.

**Tools Area**

The **Tools** area gives you quick access to the tools you will need to analyze the diagram and generate additional results.

- **Analyze** analyzes the diagram.

- **Plot** creates a plot based on the analysis results. Clicking the **Plot** icon before the diagram has been analyzed will automatically perform the analysis and then plot the data.

- **QCP** opens the **Markov Quick Calculation Pad** (QCP). The QCP allows you to obtain metrics of interest based on the analyzed diagram.

- **Change Diagram Type** changes the current diagram to the opposite diagram type (i.e., changes the current discrete diagram to a continuous diagram, or the current continuous diagram to a discrete diagram). If you prefer to create a new diagram using the new type, use the Change Diagram Type window (**Markov > Selection > Diagram Actions > Change Diagram Type**) instead.

**Available Results**

**Markov Diagram Results**

Results from discrete and continuous Markov diagrams are shown in worksheets in the **Results Explorer**. To access the results, click the **Show Results (...)** icon on the control panel or choose **Analysis > Tools > Show Analysis Results**.
Analysis Summary Worksheet

Diagrams Without Phases

Analysis Summary

- **Date & Time of Analysis**: The date and time that analysis was performed.
- **Analysis Type**: The kind of analysis that was performed, discrete time or continuous time.
- **Length** (discrete diagrams) or **Duration** (continuous diagrams): The number of steps or length of time for which the analysis ran.
- **Number of States**: The number of state blocks in the diagram.
- **Initial State**: The state in which analysis started.
- **Mean Availability** and **Mean Reliability**: Continuous diagrams only. The availability includes return from unavailable states. The reliability assumes no return from unavailable states.
- **Cost**: Continuous diagrams only. The total costs accrued during analysis, based on the costs specified for each state block.

Diagrams with Phases

Analysis Summary

- **Date & Time of Analysis**: The date and time that analysis was performed.
- **Analysis Type**: The kind of analysis that was performed, discrete time or continuous time.

All Phases

- **Analysis Length** (discrete diagrams) or **Operating Time** (continuous diagrams): The total number of steps or total length of time for which the analysis ran.
- **Number of Phases**: The number of phases defined.
- **Total Length** (discrete diagrams) or **Total Duration** (continuous diagrams): One cycle, or the sum of the lengths of all phases, in number of steps or in time units.
Chapter 10: BlockSim Markov Diagrams

- **Analysis Cycles**: Total length of analysis divided by one cycle. For discrete diagrams, this is equal to Analysis Length/Total Length. For continuous diagrams, it is equal to Operating Time/Total Duration.

- **Total Number of States**: The total number of unique states defined across all phases.

- **Initial State**: The state in which analysis started.

- **Mean Availability** and **Mean Reliability**: Continuous diagrams only. The availability includes return from unavailable states. The reliability assumes no return from unavailable states.

- **Cost**: Continuous diagrams only. The total costs accrued during analysis, based on the costs specified for each state block.

**[Phase Name]**

- **Phase Length** (discrete diagrams) or **Phase Duration** (continuous diagrams): The number of steps or the length of time defined as a single cycle for the phase.

- **Phase [Length/Duration] Portion**: The portion of one cycle of the diagram that is accounted for by the phase. This is equal to Phase Length/Duration divided by Total Length/Duration.

- **Number of States**: The number of state blocks used in the phase.

**Result Summary Worksheet**

In diagrams using phases, the results in the Result Summary worksheet are calculated at the end of the analysis, not at the end of a single cycle.

- **State Name**: The name of the state block.

- **Initial Probability**: The initial probability value specified for the state block (i.e., the probability that the system will be in the state at the start of the analysis).

- **Mean Probability**: The mean probability of the system being in the state over the course of the analysis.

- **Point Probability**: Discrete diagrams only. The probability of the system being in the state at the end of the analysis.

- **Point Probability (Av)** and **Point Probability (Rel)**: Continuous diagrams only. The probability that the system is in this state at the end of the analysis. (Av) includes return from unavailable states. (Rel) assumes no return from unavailable states.

- **Steps Spent in State** (discrete diagrams) or **Time Spent in State** (continuous diagrams): The number of steps or the amount of time during which the system was in this state.
• **Cost**: Continuous diagrams only. The costs accrued during analysis, based on the cost specified for just this state block.

**Transition Probability/Rate Matrix Worksheet**
The Transition Matrix worksheet provides information on the transitions in the Markov diagram in a tabular format, as shown next.

<table>
<thead>
<tr>
<th>Diagram Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>FROM &gt; TO</td>
</tr>
<tr>
<td>State 1</td>
</tr>
<tr>
<td>State 2</td>
</tr>
<tr>
<td>State 3</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>State 1</th>
<th>State 2</th>
<th>State 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>remain in State 1</td>
<td>from State 1 to State 2</td>
<td>from State 1 to State 3</td>
</tr>
<tr>
<td>from State 2 to State 1</td>
<td>remain in State 2</td>
<td>from State 2 to State 3</td>
</tr>
<tr>
<td>from State 3 to State 1</td>
<td>from State 3 to State 2</td>
<td>remain in State 3</td>
</tr>
</tbody>
</table>

For discrete diagrams, the values in the matrix are probabilities. For continuous diagrams, they are failure rates; consequently, no values are given for remaining in the same state.

In diagrams using phases, one matrix is shown for each phase, in the order in which the phases were analyzed.

**System Point Results Worksheet**
The System Point Results worksheet is available only for continuous Markov diagrams. If the diagram uses phases, the worksheet will present a separate table for each phase, in the order in which the phases were analyzed. If a given phase is performed (in whole or in part) more than once, an additional table will be provided for each time it is performed.

• **Calculation Point**: The index number for the step.

• **Time**: The step size (time) for the analysis is determined iteratively as the analysis is performed.

• **A(t) and (1-A(t))**: The point availability and point unavailability of the system at the given time.

• **R(t) and (1-R(t))**: The point reliability and point unreliability of the system at the given time.

**State Point Results Worksheet**
If the diagram uses phases, the State Point Results worksheet will present a separate table for each phase, in the order in which the phases were analyzed. If a given phase is performed (in
whole or in part) more than once, an additional table will be provided for each time it is performed.

Discrete:
- **Step**: The index number for the step.
- **P(t)**: The point probability of being in the state at that step.
- **1-P(t)**: The point probability of not being in the state at that step.

Continuous:
- **Calculation Point**: The index number for the step.
- **Time**: The step size (time) for the analysis is determined iteratively as the analysis is performed.
- **Point Probability(Av)(t) and 1-Point Probability(Av)(t)**: The probability of being in the state, and of not being in the state, at the given time, when return from unavailable states is considered.
- **Point Probability(Rel)(t) and 1-Point Probability(Rel)(t)**: The probability of being in the state, and of not being in the state, at the given time, when return from unavailable states is ignored.

**Markov Quick Calculation Pad**
BlockSim includes a Quick Calculation Pad (QCP) for computing useful metrics. You can access the QCP by choosing **Analysis > Analysis > Analytical QCP** or by clicking its icon on the Analytical page of the diagram control panel.

To perform a calculation, select the appropriate option and enter any required inputs in the **Input** area, then click **Calculate**. For more detailed information on how to use the QCP in general, see **Quick Calculation Pad (QCP)**.

The following calculations are available for discrete Markov diagrams:
- **State-Level Results**
  - **Point Probability**
    Calculates the probability of the system being in a given state at a given step. Enter the step at which you wish to calculate the point probability in the **Mission End Time** field and choose the state of interest in the **State** field.
**Point Probability Complement**

Calculates the probability of the system not being in a given state at a given step. Enter the step at which you wish to calculate the point probability complement in the **Mission End Time** field and choose the state of interest in the **State** field.

**Mean Probability**

Calculates the overall mean probability of the system being in a given state during the entire analysis. Choose the state of interest in the **State** field.

**Steps Spent in State**

Calculates the overall number of steps that the system spends in a given state during the entire analysis (mean probability * number of steps in the analysis). Choose the state of interest in the **State** field.

The following calculations are available for continuous Markov diagrams:

- **System-Level Results**

  **Point Availability**

  Calculates the probability that the system will be in an available state at a certain point in time, when return from unavailable states is considered. Enter the time at which you wish to calculate the point availability in the **Mission End Time** field. The mission is assumed to start at time = 0.

  **Point Unavailability**

  Calculates the probability that the system will be in an unavailable state at a certain point in time. Enter the time at which you wish to calculate the point unavailability in the **Mission End Time** field. The mission is assumed to start at time = 0.

  The point unavailability is the inverse of the point availability. For example, a 10% point unavailability is equivalent to a 90% point availability.

  **Point Reliability**

  Calculates the probability that the system will be in an available state, without ever having entered an unavailable state, at a certain point in time. Enter the time at which you wish to calculate the point reliability in the **Mission End Time** field. The mission is assumed to start at time = 0.

  **Point Prob. of Failure**

  Calculates the probability that the system has at some point entered an unavailable state by a certain point in time. Enter the time at which you wish to calculate the
probability of failure in the Mission End Time field. The mission is assumed to start at time = 0.

Probability of failure is also known as unreliability and it is the complement of the reliability. For example, a point probability of failure of 10% for a mission end time of 3 years is equivalent to a 90% reliability.

• State-Level Results

Point Probability (Av)
Calculates the probability that the system will be in a given state at a given time, when return from unavailable states is considered. Enter the time at which you wish to calculate the probability in the Mission End Time field. The mission is assumed to start at time = 0. Choose the state of interest in the State field.

1 - Point Probability (Av)
Calculates the probability that the system will not be in a given state at a given time, when return from unavailable states is considered. Enter the time at which you wish to calculate the probability in the Mission End Time field. The mission is assumed to start at time = 0. Choose the state of interest in the State field.

Point Probability (Rel)
Calculates the probability that the system will be in a given state at a given time, when return from unavailable states is ignored. Enter the time at which you wish to calculate the probability in the Mission End Time field. The mission is assumed to start at time = 0. Choose the state of interest in the State field.

1 - Point Probability (Rel)
Calculates the probability that the system will not be in a given state at a given time, when return from unavailable states is ignored. Enter the time at which you wish to calculate the probability in the Mission End Time field. The mission is assumed to start at time = 0. Choose the state of interest in the State field.

Markov Diagram Plots
You can create and view plots for Markov diagrams by clicking the Plot icon located on the Analytical page of the control panel.

If you click the Plot icon before the diagram has been analyzed, it will automatically be analyzed and then the data will be plotted in the plot sheet. (Note that the Plot icon on the Plot sheet
control panel refreshes the plot. If data or analysis settings have been changed since the
diagram was last analyzed, you must reanalyze before refreshing the plot.)

You can add additional plot sheets to the diagram by right-clicking the sheet index tabs at the
bottom of the window and choosing Insert Analytical Plot on the shortcut menu. You can
delete a plot sheet from the diagram by selecting the plot sheet, right-clicking and choosing Delete Plot.

The plots available for Markov diagrams depend on whether the diagram is discrete or continuous.

**Discrete Markov Diagrams**
- **State Mean Probability** shows the mean probability of the system being in each state.
- **State Point Probability** shows the probability of the system being in each state at each
given step. When you first select the plot, you must specify which states to include by using the Available States area of the control panel.

**Continuous Markov Diagrams**
- **System Plots**
  - **Point Availability** shows the system's point availability over time. The point availability is the probability that the system will be operational (in an available state) at any given time. This measure includes return from unavailable states.
  - **Point Reliability** shows the system's point reliability over time. The point reliability is the probability that the system has not failed (i.e., has never entered an unavailable state) by a given time. This measure assumes no return from unavailable states.
  - **Both Point A and R** shows the system's point availability over time and the system's point reliability over time on the same plot.
- **State Plots**
  - **State Mean Probability** shows the mean probability of the system being in each state and the cost accrued due to the system being in each state. Bar size indicates the state mean probability; bar color indicates state cost, as shown in the legend. Point to a bar to view the state's name, normalized cost and probability.
  - **State Cost** shows the cost accrued due to the system being in each state and the mean probability of the system being in each state. Bar size indicates the state cost; bar color indicates state mean probability, as shown in the legend. Point to a bar to view the state's name, probability and cost.
- **State Point Probability (Av)** shows the probability over time of the system being in each state when all transitions are considered. When you first select the plot, you must specify which states to include by using the *Available States* area of the control panel.

- **State Point Probability (Rel)** shows the probability over time of the system being in each state when transitions from unavailable states are ignored. When you first select the plot, you must specify which states to include by using the *Available States* area of the control panel.

- **State Point P (Av) and P (Rel)** Shows the point probability both with and without return from unavailable states on the same plot. When you first select the plot, you must specify which states to include by using the *Available States* area of the control panel.
Chapter 11: RENO Flowcharts

RENO flowcharts are used to build models of probabilistic or deterministic problems, processes or scenarios in order to help you understand and/or quantify them. The flowchart is a graphical representation of the mathematical process of predicting an outcome. Possible applications include risk and safety analysis, complex reliability modeling, decision making, maintenance planning, optimization, operational research, financial analysis and much more.

A RENO flowchart consists of various types of blocks that are connected in order to model the scenario. In addition, RENO resources serve to store or generate values used in the flowchart. Resources cannot be placed directly into the flowchart; instead, they are referenced or called by the blocks.

Using Time Units in RENO

For each database, authorized users can configure which time units will be available for time-related inputs and results, and they can define conversion factors that allow the software to automatically convert data from one time unit to another (see Time and Usage Units window).

In RENO, this means three things:

- Results are always given in terms of the system base unit (SBU).

- Resources that do not require you to define a time unit (e.g., RENO tables, variables, cost models, etc.) are assumed to be in terms of the base unit. This also applies to all constants and parameters used in equations, RENO predefined functions and RENO internal functions.

- Resources that require you to define a time unit (e.g., reliability models, duration models, etc.) will have their values automatically converted to the base unit during simulation. For example, let's assume that in your database, an hour is equal to 1 SBU. Now suppose your model is a Weibull distribution that is defined in terms of minutes, as shown next.
Chapter 11: RENO Flowcharts

The following flowchart shows a block that obtains a random value from this model.

![Flowchart Diagram]

If \( rvm(\text{Model}) = 60 \) minutes, then the output of the model in a RENO flowchart would be 1 hour (automatically converted from 60 minutes).

**Tip:** Whenever you don’t want the software to convert the value obtained by RENO from a model resource, make sure the model uses a unit that is defined as equal to 1 SBU. To view the conversion factors for the units, open the Time and Usage Units window by choosing File > Manage Repository > Time and Usage Units.

For an example, you can open the "Snow Blower" project in the RENO9_Examples.rsgz9 database that is installed with the software. In this analysis, the "Depth" model describes snow depth (in inches) and the "Area" model describes the area that needs to be cleared (in square feet). These models use the "Hour" unit, with SBU = 1, to ensure that values obtained from the models do not get converted.
## Flowchart Block Types

In order to provide the flexibility required to create flowcharts that model scenarios as realistically as possible, there are several different types of blocks. For the different types of blocks, the appearance and options available in the Block Properties window will vary. This section is intended to help you identify the basic types of blocks found in flowcharts.

**Note:** The shapes, colors and locations shown here represent the default settings. For information on modifying appearance settings, see [Diagram Skins and Appearance Settings](#).

<table>
<thead>
<tr>
<th>Block Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Flowchart Standard Block</strong></td>
<td>A flowchart standard block evaluates a mathematical expression, and then passes the result (output value) of the expression to the next block(s) in the flowchart.</td>
</tr>
<tr>
<td><strong>Result Storage Block</strong></td>
<td>A result storage block stores numerical values passed to it during simulations, and then computes or holds a result.</td>
</tr>
<tr>
<td><strong>Conditional Block</strong></td>
<td>A conditional block functions as an &quot;if&quot; statement. It checks the incoming value against a conditional expression, with possible outcomes of true and false.</td>
</tr>
<tr>
<td><strong>Binary Node</strong></td>
<td>A binary node takes an incoming value and multiplies it by a specified value. The resulting value is passed down the &quot;true&quot; path. The value passed down the &quot;false&quot; path is the incoming value multiplied by (1 minus the specified value). Binary nodes are primarily intended to facilitate building decision trees.</td>
</tr>
<tr>
<td><strong>Logic Gate</strong></td>
<td>A logic gate checks multiple incoming values against a conditional expression, with possible outcomes of true and false. It determines the overall block outcome based on the gate type, which specifies how many of the incoming values must meet the condition in order for the outcome to be true.</td>
</tr>
<tr>
<td><strong>Branch Gate</strong></td>
<td>A branch gate functions as a &quot;switch&quot; statement. It checks the incoming value against a number of cases, and passes different outputs depending on which case or branch evaluates to true.</td>
</tr>
</tbody>
</table>
Chapter 11: RENO Flowcharts

<table>
<thead>
<tr>
<th>Block</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Summing Gate" /></td>
<td><strong>Summing Gate</strong> A summing gate performs a simple mathematical operation on all incoming values (addition, subtraction, multiplication, division, averaging incoming values or finding the maximum or minimum of the incoming values), and returns a single value to all outgoing paths.</td>
</tr>
<tr>
<td><img src="image" alt="Flag Marker and Go-to-Flag Blocks" /></td>
<td><strong>Flag Marker and Go-to-Flag Blocks</strong> Flag markers and go-to-flags are used to build subroutines and loops that repeat steps in a flowchart until a certain condition is reached. The flag marker marks a spot in the path of the flowchart, and the go-to-flag transfers the flow of execution to that spot.</td>
</tr>
<tr>
<td><img src="image" alt="Stop Flag" /></td>
<td><strong>Stop Flag</strong> A stop flag halts the simulation process when it is encountered. No further simulations, runs or analyses will be performed until you next simulate the flowchart.</td>
</tr>
<tr>
<td><img src="image" alt="Counter Block" /></td>
<td><strong>Counter Block</strong> A counter block records the number of times the simulation has passed through it, and then passes the recorded value to the next block in the flowchart.</td>
</tr>
<tr>
<td><img src="image" alt="Reset Block" /></td>
<td><strong>Reset Block</strong> A reset block forces RENO to generate new values for all <strong>static functions</strong> in the flowchart while simulation is in progress.</td>
</tr>
<tr>
<td><img src="image" alt="UI Block" /></td>
<td><strong>UI Block</strong> A UI block pauses flowchart simulation until the user provides some form of input.</td>
</tr>
<tr>
<td><img src="image" alt="Subchart Block" /></td>
<td><strong>Subchart Block</strong> Subchart blocks represent other flowcharts within the project. Subchart blocks are generally used to break down a larger flowchart into simpler steps to reduce complexity and improve traceability.</td>
</tr>
</tbody>
</table>

**What’s Changed?** In previous versions of the software, the blocks used in RENO flowcharts were known as constructs.

http://blocksim.reliasoft.com
Flowchart Standard Blocks

A standard block evaluates a mathematical expression, and then passes the result (output value) of the expression to the next block(s) in the flowchart. For example, the following configuration shows two standard blocks in a flowchart. The direction of the arrow indicates that the output of Block A is passed to Block B.

![Diagram of Block A and Block B]

The following picture shows the Block Properties window of Block A. The **Equation** field contains the expression that the block evaluates. In this case, the expression is A+B+C.

![Block Properties window for Block A]

The following picture shows the Block Properties window of Block B. In this block, the output of the expression in Block A (represented by the RENO internal function in) is multiplied by 5.

![Block Properties window for Block B]
Standard blocks may accept up to one incoming path (input value), and may have multiple outgoing paths (i.e., the same output value is passed to more than one block). In addition to passing the output to the next block(s) in the flowchart, the standard block may be configured to store its output in a variable. The Storage Variable field in the Block Properties window of the block displays the name of the variable, if any.

The expression in the standard block can include:

- Numerical values
- **Standard and special operators**
- Predefined mathematical functions (exp, log, sin, etc.)
- RENO internal functions
- **RENO resources**
- References to any Synthesis Workbooks

You can enter the equation manually, or you can use the function selector or the equation editor to assist you.

RENO resources, Synthesis Workbooks and internal functions are automatically color-coded to assist in reading the equation. When the cursor is positioned on one of these items, a preview area appears and displays a summary of the item. If the item is a resource, you can click the View icon in the Preview area to open that resource's properties window.
You can enclose a resource name in single quotes to reference it by name. When the item using the expression is transferred to another project or database, any resource referenced by name will not be transferred along with it. If the destination project contains a resource with the same name as the one referenced by name, that resource will be used during simulation of the transferred item. For example, if you export a diagram that contains a block using the expression 'Model1'(1000) from Project1 to Project2, Model1 will not be transferred along with that diagram. If Project2 already contains a model called Model1, that model will be used in simulating the transferred diagram. You can also reference Synthesis Workbooks by name.

**IMPORTANT:** All values and results are assumed to be in terms of the default unit specified for the database. See *Using Time Units in RENO* for details on how this may affect your analysis.

### Result Storage Blocks

A result storage block stores numerical values passed to it during simulations, and then computes or holds a result based on one of the following options:

- **Average of Results** computes the average value of the numbers that were passed to the result storage block. Each time a new value is passed to the block, the average is recomputed. If the block is called during simulation, it will return the latest average of the values.

- **Sum of Results** computes the sum of the numbers that were passed to the result storage block. The total sum is recalculated with each new value that is passed to the block. If the block is called during simulation, it will return the latest sum of the values.

- **Array of Results** allows the result storage block to hold an array of values. These values may be used to perform various statistical calculations, such as calculating the variance, standard deviation, etc. If the block is called during simulation, it will return only the most recent value that was added to the array. The values stored in the block are displayed in the Results Explorer. If you have selected a result storage block of type array in a simulated flowchart, you can click the Transfer Data to Weibull++ icon in the Information area of the control panel to create a Weibull++ life data folio containing the stored values.
Chapter 11: RENO Flowcharts

- **Minimum of Results** holds the smallest numerical value that was passed to the result storage block. Each new value that is passed to the block is compared to the value that is currently stored. If the new value is less than the stored value, the block discards the stored value and replaces it with the new value; otherwise, the new value is discarded.

- **Maximum of Results** holds the largest numerical value that was passed to the result storage block. Each new value that is passed to the block is compared to the value that is currently stored. If the new value is greater than the stored value, the block discards the stored value and replaces it with the new value; otherwise, the new value is discarded.

- **Last Value** holds only the latest value that was passed to the result storage block. Each new value that is passed to the block replaces the old value.

- **Normalized Sum of Results** adds the values that were passed to the result storage block and divides by the number of simulations. If the block is called during simulation, it will return the summed value currently stored divided by the total number of simulations to be performed.

For example, if you select the **Average of Results** option, and then run 100 simulations on the following configuration (a single simulation is a single pass through the flowchart), then the block that generates a random number will pass a total of 100 random values to the result storage block, which will compute the average value of the numbers as they come in.

The following picture shows the Block Properties window of the result storage block in the example. The **Store** field allows you to select the output of the block. In this case, it stores the average of results.
A result storage block can have any number of incoming paths and any number of outgoing paths (i.e., the same output value is passed to more than one block). In addition to storing the results, the block may be configured to store the output in a variable. The Storage Variable field in the Block Properties window of the block displays the name of the variable, if any. If the result storage block is holding an array of results, only the most recent value that was added to the array will be stored in the variable.

**Advanced Configurations**

- If your block has multiple incoming paths, you can configure the block to not pass an output or compute a result until the block has received a certain number of inputs. This allows you to control the number of inputs that the block processes at any given time. To do this, enter a value in the Required Number of Executed Incoming Paths field in the Block Properties window. Note that this value simply refers to how many inputs are required, and does not distinguish based on which path(s) the inputs come from. For example, if there are three incoming paths and three required inputs, one input from each path would trigger the block, but so would three inputs from the first path. An asterisk (*) in this field means that the required number of inputs is equal to the number of paths into the block. See Flowchart Configurations and Execution for an example.

**Conditional Formatting**

Conditional formatting allows you to mark the result storage block with a corner indicator in a particular color when it meets a certain condition. For instance, you might wish to mark the block with red if the computed result is less than a particular value. The conditional formatting
corner indicator appears at the upper left corner of the block. To apply conditional formatting, select the result storage block(s) and choose Format > Styles > Conditional Formatting or right-click the result storage block(s) and select Conditional Formatting on the shortcut menu.

There are two types of conditional formatting that you can apply in the Conditional Formatting window:

- You can click the Set of Conditions button to define conditions and specify the color of the block under each condition. To enable each condition, select the Use this condition check box. The fields directly below will be enabled, allowing you to select the conditional operator, enter the value(s) against which the value of the result storage block will be checked and specify a color to be used when the value meets the condition. Available conditional operators are:

  - = (equal to)
  - <> (not equal to)
  - <= (less than or equal to)
  - < (less than)
  - >= (greater than or equal to)
  - > greater than
  - Between
  - Not between

You can define up to six conditions, and can enable and disable them with the Use this condition check boxes. The conditions you have defined will be saved even when disabled. Enabled conditions do not need to be immediately consecutive. Keep in mind, however, that the conditions are evaluated in the order in which they are displayed in this window and that if a result storage block meets more than one condition, the first true condition will be applied.
You can click the **Color Limits** button to define a range of values across which the range of colors from red to green will be applied. Result storage blocks with values close to the specified lower limit will be marked with red corner indicators; those with values close to the specified upper limit will be marked with green corner indicators.
In both types, for the value(s) against which the result storage block is checked, the expression can include:

- Numerical values
- **Standard and special operators**
- Predefined mathematical functions (exp, log, sin, etc.)
- RENO internal functions
- RENO resources
- References to any Synthesis Workbooks

You can enter the equation manually, or you can use the function selector or the equation editor to assist you.

RENO resources, Synthesis Workbooks and internal functions are automatically color-coded to assist in reading the equation. When the cursor is positioned on one of these items, a preview area appears and displays a summary of the item. If the item is a resource, you can click the View icon in the Preview area to open that resource's properties window.
You can enclose a resource name in single quotes to reference it by name. When the item using the expression is transferred to another project or database, any resource referenced by name will not be transferred along with it. If the destination project contains a resource with the same name as the one referenced by name, that resource will be used during simulation of the transferred item. For example, if you export a diagram that contains a block using the expression 'Model1'(1000) from Project1 to Project2, Model1 will not be transferred along with that diagram. If Project2 already contains a model called Model1, that model will be used in simulating the transferred diagram. You can also reference Synthesis Workbooks by name.

**IMPORTANT:** All values and results are assumed to be in terms of the default unit specified for the database. See Using Time Units in RENO for details on how this may affect your analysis.

You can click the No Formatting button to turn off conditional formatting for the selected block(s).

Note that for result storage blocks of type array, the conditional formatting will be based on the most recent value. The size of the conditional formatting corner indicators can be changed via the Block Corner Indicators pages of the Diagram Style window.

**Conditional Blocks**

A conditional block functions as an "if" statement. It checks the incoming value against a conditional expression, with possible outcomes of true and false. A conditional block accepts one incoming path and may have one or two outgoing paths.

For example, in the configuration shown next, the conditional block evaluates the output from Block 1 against a conditional expression. If the outcome is true, then an output is passed down the "true" (T) path to Block 2, but if the outcome is false, an output is passed down the "false" (F) path to Block 3.
Tip: RENO designates the first connector drawn from a conditional block, binary node or logic gate as the "true" path and the second connector as the "false" path. You can switch these designations by right-clicking the connector and choosing Set to Failure or Set to Success on the shortcut menu.

The following picture shows the Block Properties window of the conditional block in the example. In this case, if the output of Block 1 is greater than or equal to 0, then the value "1" is passed down the "true" path. However, if the output of Block 1 is less than 0, then the value 0 is passed down the "false" path.

The Condition and Condition Value fields allow you to configure the conditional expression of the block. The drop-down list in the Condition field includes the following relational signs:

- = equal to
- <= less than or equal to
- < less than
- => greater than or equal to
- > greater than
FP<=% a special case where the conditional block itself draws a random number uniformly distributed from 0 to 100, and then evaluates whether the number is less than or equal to the condition value.

<> not equal to

For the condition value, as well as the outgoing "true" and "false" values, the expression can include:

- Numerical values
- Standard and special operators
- Predefined mathematical functions (exp, log, sin, etc.)
- RENO internal functions
- RENO resources
- References to any Synthesis Workbooks

You can enter the equation manually, or you can use the function selector or the equation editor to assist you.

RENO resources, Synthesis Workbooks and internal functions are automatically color-coded to assist in reading the equation. When the cursor is positioned on one of these items, a preview area appears and displays a summary of the item. If the item is a resource, you can click the View icon in the Preview area to open that resource’s properties window.

You can enclose a resource name in single quotes to reference it by name. When the item using the expression is transferred to another project or database, any resource referenced by name will not be transferred along with it. If the destination project contains a resource with the same name as the one referenced by name, that resource will be used during simulation of the transferred item. For example, if you export a diagram that contains a block using the expression 'Model1'(1000) from Project1 to Project2, Model1 will not be transferred along with that diagram. If Project2 already contains a model called Model1, that model will be used in simulating the transferred diagram. You can also reference Synthesis Workbooks by name.

**IMPORTANT:** All values and results are assumed to be in terms of the default unit specified for the database. See Using Time Units in RENO for details on how this may affect your analysis.
Advanced Configurations

- You can configure the conditional block to have only one outgoing path. This is useful for situations where you want the simulation to end based on a certain condition so that the next simulation, if any, can begin. For example, in the following configuration, if the condition evaluates to true, then the simulation will continue down the "true" path, but if the condition evaluates to false, then the simulation will end because no "false" path exists.

- By default, if the condition evaluates to true, then the specified value will be passed down the "true" path and nothing will be passed down the "false" path. Similarly, if the condition evaluates to false, a value will be passed down the "false" path only. If you wish to pass a value down both paths regardless of the outcome of the evaluation, select the **Continue Execution on Both Paths** check box. This allows you to specify the values to pass to the opposite paths in each case.

In the example shown next, if the incoming value is greater than or equal to zero, the value 1 will be passed down the "true" path and the value 10 will be passed down the "false" path. Similarly, if the condition evaluates to false, the value 0 is will be passed down the "false" path and the value 5 will be passed down the "true" path. (See also Flowchart Configurations and Execution for a discussion on how flowcharts are executed.)
Binary Nodes

A binary node takes an incoming value and multiplies it by the number specified in the node. The resulting value is passed down the "true" path. The value passed down the "false" path is the incoming value multiplied by (1 minus the specified value). In this case, "true" and "false" are simply the names of the paths, and do not indicate anything other than how the values passed down them are computed. Note that both the incoming value and the number specified in the node are intended to represent probabilities $0 < P < 1$, although RENO places no constraints on the values entered.

Each binary node accepts one incoming path and may have one or two outgoing paths.

**Tip:** RENO designates the first connector drawn from a conditional block, binary node or logic gate as the "true" path and the second connector as the "false" path. You can switch these designations by right-clicking the connector and choosing **Set to Failure** or **Set to Success** on the shortcut menu.

In the example shown next, a meteorologist predicts that there is a 70% chance of rain tomorrow. If it doesn't rain, there is a 65% chance that the day will be cloudy and windy, and a
35% chance that the day will be sunny and calm. The flowchart below shows the probability of each outcome.

Here, the first block in the example has a value of 100, representing the 100% probability that the day will have weather of some sort. This value is passed to the Rain? binary node, shown next.
The incoming value of 100 is multiplied by the value in the Condition is TRUE - T Path field (i.e., 0.7) and the resulting value of 70 is passed to the "true" path. This results in a 70% chance that tomorrow will be rainy. The Rain? binary node then multiplies the incoming value of 100 by (1 minus the value in the Condition is TRUE - T Path field) (i.e., 1 - 0.7 = 0.3) and passes the resulting value of 30 to the "false" path.

The Windy? binary node performs a similar operation, but this time, it multiplies the incoming value (30) by the probability of a cloudy and windy day (0.65). This results in the conclusion that there will be a 19.5% chance that it will be cloudy and windy, and a 10.5% chance of a sunny, calm day.

For the Condition is TRUE - T Path value, the expression can include:

- Numerical values
- Standard and special operators
- Predefined mathematical functions (exp, log, sin, etc.)
- RENO internal functions
- RENO resources
References to any Synthesis Workbooks

You can enter the equation manually, or you can use the function selector or the equation editor to assist you.

RENO resources, Synthesis Workbooks and internal functions are automatically color-coded to assist in reading the equation. When the cursor is positioned on one of these items, a preview area appears and displays a summary of the item. If the item is a resource, you can click the View icon in the Preview area to open that resource's properties window.

You can enclose a resource name in single quotes to reference it by name. When the item using the expression is transferred to another project or database, any resource referenced by name will not be transferred along with it. If the destination project contains a resource with the same name as the one referenced by name, that resource will be used during simulation of the transferred item. For example, if you export a diagram that contains a block using the expression 'Model1'(1000) from Project1 to Project2, Model1 will not be transferred along with that diagram. If Project2 already contains a model called Model1, that model will be used in simulating the transferred diagram. You can also reference Synthesis Workbooks by name.

**IMPORTANT:** All values and results are assumed to be in terms of the default unit specified for the database. See Using Time Units in RENO for details on how this may affect your analysis.

Advanced Configurations

- You can configure the binary node to have only one outgoing path (i.e., only a "true" path). This is a shortcut for having a "false" path terminated by a stop flag.

Logic Gates

A logic gate is similar to a conditional block in that it checks incoming values against a conditional expression, with possible outcomes of true and false, and can have one or two outgoing paths. It differs, however, in that it accepts multiple incoming paths and determines the overall block outcome based on the gate type, which specifies how many of the incoming values must meet the condition in order for the outcome to be true.

For example, in the configuration shown next, the logic gate evaluates the outputs of Blocks 1, 2 and 3 against a conditional expression, and then evaluates the overall outcome based on the gate type. If the outcome is true, then an output is passed down the "true" (T) path to Block 4, but if the outcome is false, an output is passed down the "false" (F) path to Block 5.
Tip: RENO designates the first connector drawn from a conditional block, binary node or logic gate as the "true" path and the second connector as the "false" path. You can switch these designations by right-clicking the connector and choosing Set to Failure or Set to Success on the shortcut menu.

The following picture shows the Block Properties window of the logic gate in the example. In this case, the logic gate is an AND gate, meaning that all incoming paths must meet the condition in order for the block outcome to be true. If the outputs of Blocks 1, 2 and 3 are all greater than or equal to 0, then the block outcome is true and the value "1" is passed down the "true" path. However, if one of the outputs is less than 0, then the block outcome is false and the value 0 is passed down the "false" path.
The logic gate can be configured for any of the following gate types:

- **AND**: If all incoming paths meet the condition, then the block outcome is true; otherwise, it is false.

- **OR**: If at least one incoming path meets the condition, then the block outcome is true; otherwise, it is false.

- **XOR**: If one, and only one, of the incoming paths meets the condition, then the block outcome is true. If more than one incoming path meets the condition, then the block outcome is false. This gate is also known as an exclusive OR.

- **K-out-of-N**: If \( k \) out of \( n \) incoming paths (e.g., 2 out of 3 incoming paths) meet the condition, then the block outcome is true; otherwise, it is false. When you select this gate type, the **Required Number of Paths** field will appear, allowing you to specify the value of \( k \).

The **Condition** and **Condition Value** fields allow you to configure the conditional expression of the block. The drop-down list in the Condition field includes the following relational signs:

- \( = \) equal to
FP\leq a special case where the conditional block itself draws a random number uniformly distributed from 0 to 100, and then evaluates whether the number is less than or equal to the condition value.

<> not equal to

For the condition value, as well as the outgoing "true" and "false" values, the expression can include:

- Numerical values
- Standard and special operators
- Predefined mathematical functions (exp, log, sin, etc.)
- RENO internal functions
- RENO resources
- References to any Synthesis Workbooks

You can enter the equation manually, or you can use the function selector or the equation editor to assist you.

RENO resources, Synthesis Workbooks and internal functions are automatically color-coded to assist in reading the equation. When the cursor is positioned on one of these items, a preview area appears and displays a summary of the item. If the item is a resource, you can click the View icon in the Preview area to open that resource’s properties window.

You can enclose a resource name in single quotes to reference it by name. When the item using the expression is transferred to another project or database, any resource referenced by name will not be transferred along with it. If the destination project contains a resource with the same name as the one referenced by name, that resource will be used during simulation of the transferred item. For example, if you export a diagram that contains a block using the expression ‘Model1’(1000) from Project1 to Project2, Model1 will not be transferred along with that diagram. If Project2 already contains a model called Model1, that model will be used in simulating the transferred diagram. You can also reference Synthesis Workbooks by name.
Chapter 11: RENO Flowcharts

**IMPORTANT:** All values and results are assumed to be in terms of the default unit specified for the database. See [Using Time Units in RENO](http://blocksim.reliasoft.com) for details on how this may affect your analysis.

**Advanced Configurations**

- By default, if the condition evaluates to true, then the specified value will be passed down the "true" path and nothing will be passed down the "false" path. Similarly, if the condition evaluates to false, a value will be passed down the "false" path only. If you wish to pass a value down both paths regardless of the outcome of the evaluation, select the **Continue Execution on Both Paths** check box. This allows you to specify the values to pass to the opposite paths in each case.

In the example shown next, if the outcome is true, then the value "1" will be passed down the "true" path and the value 10 will be passed down the "false" path. Similarly, if the outcome is false, then the value 0 is will be passed down the "false" path and the value 5 will be passed down the "true" path.
• If your block has multiple incoming paths, you can configure the block to not pass an output or compute a result until the block has received a certain number of inputs. This allows you to control the number of inputs that the block processes at any given time. To do this, enter a value in the Required Number of Executed Incoming Paths field in the Block Properties window. Note that this value simply refers to how many inputs are required, and does not distinguish based on which path(s) the inputs come from. For example, if there are three incoming paths and three required inputs, one input from each path would trigger the block, but so would three inputs from the first path. An asterisk (*) in this field means that the required number of inputs is equal to the number of paths into the block. See Flowchart Configurations and Execution for an example.

Branch Gates
A branch gate functions as a "switch" statement. It checks the incoming value against a number of cases and passes different outputs depending on which case or branch evaluates to true. It has one incoming path and multiple outgoing paths.

A branch gate may be used in place of a series of conditional blocks. For example, the flowchart on the left, as shown next, has three conditional blocks that evaluate an automobile's mileage. If the first condition is met, the value is passed to the "true" (T) path to "Result Storage A," but if the condition is not met, the value is passed down the "false" (F) path to the next conditional block for evaluation. The evaluation continues until all paths end. The flowchart on the right shows an example of how a branch gate may be used to replace the conditional blocks.
The following picture shows the Block Properties window of the branch gate in the example. The branch gate checks the incoming value against each branch sequentially, based on the order shown in the Block Properties window (you can move a block up or down in priority by clicking the arrows that appear next to the block's name). The branch gate then passes only the output of the first branch that evaluates to true.
The **Condition** and **Condition Value** fields allow you to configure the conditional expression of the block. The drop-down list in the Condition field includes the following relational signs:

- `=` equal to
- `<=` less than or equal to
- `<` less than
- `>=` greater than or equal to
greater than

FP\leq a special case where the conditional block itself draws a random number uniformly distributed from 0 to 100, and then evaluates whether the number is less than or equal to the condition value.

not equal to

For the condition value, as well as the outgoing values, the expression can include:

- Numerical values
- Standard and special operators
- Predefined mathematical functions (exp, log, sin, etc.)
- RENO internal functions
- RENO resources
- References to any Synthesis Workbooks

You can enter the equation manually, or you can use the function selector or the equation editor to assist you.

RENO resources, Synthesis Workbooks and internal functions are automatically color-coded to assist in reading the equation. When the cursor is positioned on one of these items, a preview area appears and displays a summary of the item. If the item is a resource, you can click the View icon in the Preview area to open that resource's properties window.

You can enclose a resource name in single quotes to reference it by name. When the item using the expression is transferred to another project or database, any resource referenced by name will not be transferred along with it. If the destination project contains a resource with the same name as the one referenced by name, that resource will be used during simulation of the transferred item. For example, if you export a diagram that contains a block using the expression 'Model1'(1000) from Project1 to Project2, Model1 will not be transferred along with that diagram. If Project2 already contains a model called Model1, that model will be used in simulating the transferred diagram. You can also reference Synthesis Workbooks by name.

**IMPORTANT:** All values and results are assumed to be in terms of the default unit specified for the database. See Using Time Units in RENO for details on how this may affect your analysis.
Advanced Configurations

- If you wish to have the branch gate pass an output when a branch evaluates to false, select the **Continue Execution on FALSE Branch** check box and enter a value in the **Condition is FALSE** field that appears, as shown next. In this example, if the incoming value is 6,000, then the branch gate will pass two outputs: the value 10 to the "Result Storage A" branch, and the value 2 to the "Result Storage B" branch.

- By default, the branch gate passes only the output of the first branch that evaluates to true. You can configure the branch gate to pass the output of **every** branch that
evaluates to true by selecting the **Check Condition on Every Branch** check box. With this setting, the order of the branches does not affect the output of the branch gate.

In the following example, if the incoming value is 50, then the branch gate will pass two outputs: the value 1 to the "Result Storage A" branch and the value 2 to the "Result Storage B" branch.
**Summing Gates**

A summing gate is a block that performs a simple mathematical operation on the incoming values and returns a single value to all outgoing paths. These operations include addition, subtraction, multiplication or division, as well as averaging incoming values and finding the maximum or minimum of the incoming values. For example, the following configuration shows three blocks that pass their output values to a summing gate.

![Summing Gate Diagram](image)

If you select to perform addition or multiplication, the values can be passed to the summing gate in any order without affecting the result (i.e., the gate follows the associative and commutative properties of addition and multiplication). The order of incoming values is also not relevant when averaging the values or finding the maximum or minimum value.

If you select to perform subtraction or division, you can define the appropriate order of operation by using the **Precedence** area of the gate's Block Properties window. For example, the following picture shows that the order of subtraction will be: \((A - C) - B\). To move a block up or down in priority, click the arrows that appear next to the block's name.

The **Required Number of Executed Incoming Paths** field allows you to control the number of inputs that the summing gate processes at any given time. Note that this value simply refers to how many inputs are required, and does not distinguish based on which path(s) the inputs come from. For example, if there are three incoming paths and three required inputs, one input from each path would trigger the block, but so would three inputs from the first path. An asterisk (*) in this field means that the required number of inputs is equal to the number of paths into the block. See **Flowchart Configurations and Execution** for an example on how this block setting affects the results of a flowchart.
Flag Marker and Go-to-Flag Blocks

Flag markers and go-to-flags are blocks that are used to build subroutines and loops that repeat steps in a flowchart until a certain condition is reached. The flag marker marks a spot in the path of the flowchart, and the go-to-flag transfers the flow of execution to that spot. A flag maker can have any number of incoming and outgoing paths. A go-to-flag can have any number of incoming paths, and no outgoing paths. The flow of execution will always go from the go-to-flag to the designated flag marker.

In the case of multiple incoming paths, the diagram and/or the conditions set in prior blocks will dictate when the transfer happens (i.e., the number of paths that must reach the go-to-flag in order to initiate the transfer of flow). In other words, if multiple incoming paths are present, the behavior will depend on the connections and settings prior to the flag. You should use the Simulation Debugger to review the execution sequence for your diagram in order to assure that the transfer happens as intended.

Loops

The following flowchart shows a simple example of how a flag marker and go-to-flag pair can form a loop. In this example, if the number generated by the standard block is higher than 50, the go-to-flag block transfers the flow of execution to the flag marker. The loop will continue to repeat until the task produces a value less than 50.
IMPORTANT: Avoid configurations that would create infinite loops. It may cause RENO to be unresponsive or create unresolved issues. You can test your flowchart for any errors before running a simulation by using the Debug tool.

Subroutines
Subroutines are specific tasks that are separate from the main task of the flowchart. The following configuration, for example, shows a flowchart with a main task and a subroutine task. In this case, the main task is to compute for the total cost of repairs. The subroutine task is executed only when the product failure does not cause a fire, in which case, the subroutine computes for either type B or C costs, and then passes that value back to the main task so that it can be counted as part of the total cost. Notice that due to the location of the flag marker called "Costs," the main task skips the computation of the type A repair whenever the subroutine is executed.
Chapter 11: RENO Flowcharts

To build a subroutine in RENO, follow these two steps:

1. Create the subroutine task in the same diagram as the main flowchart. Use a flag marker as the starting block for the subroutine, as shown in the example above.

2. Double-click the flag marker of the subroutine task to open its Block Properties window, and then select the **Execute on Call Only** check box, as shown next. This setting allows the subroutine to be executed only when it is called by a go-to-flag block. Note that this check box will appear only when the flag marker is used as a starting block. If you do not select this setting, the subroutine task may be executed before it is called by the main task (see also Flowchart Configurations and Execution for a discussion on how flowcharts are executed).
Advanced Configurations

- Aside from marking a spot in the path of a flowchart, a flag marker may be used to store the value passed to it during simulation into a variable. For example, in the configuration shown next, the summing gate adds the outputs of Blocks A and B, but it cannot store the resulting value; it only passes the result to the next block in the flowchart. In this case, the flag marker can store the value from the summing gate into a storage variable, as well as pass that same value to Block C.

![Diagram of flowchart](image)

The following picture shows the Block Properties window of the flag marker in the example.
Stop Flags
A stop flag halts the simulation process when it is encountered. No further simulations, runs or analyses will be performed until you next simulate the flowchart. A stop flag can have any number of incoming paths, and no outgoing paths. The following example shows how a stop flag may be used to stop the simulation from progressing when a certain condition is met.

Counter Blocks
A counter block increments its value by a specified amount each time the simulation passes through it, and then passes the recorded value to the next block in the flowchart. It may have multiple incoming and outgoing paths. The following example shows a counter block that
records the number of loops that it goes through. The counter block passes its tally to the conditional block that stops the loop when the condition is met.

The following picture shows the Block Properties window of the counter block in the example. In this case, the **Start Value** field indicates that the count starts at 0, and the **Increment By** field indicates that the start value increments by 1 every time the simulation passes through the block.

The **Counter Type** field allows you to configure how the block will keep count. There are three options:

- **Reset After Each Simulation**. A simulation is a single pass through the flowchart. However, if the flowchart contains one or more loops, and the counter block is within a loop, the simulation may pass through the block multiple times. In this case, the block
will count the number of loops repeated, and then reset once the simulation has reached the end of the flowchart.

- **Reset After Each Run.** A run is a set of simulations. The counter block will reset after the specified number of simulations have been completed.

- **Reset After Analysis.** An analysis is a set of runs. The counter block will reset after each set of runs has been completed.

In addition to passing the recorded value to the next block in the flowchart, the counter block may also be configured to store its output in a variable. The **Storage Variable** field displays the name of the storage variable, if any.

**Advanced Configurations**

- If your block has multiple incoming paths, you can configure the block to not pass an output or compute a result until the block has received a certain number of inputs. This allows you to control the number of inputs that the block processes at any given time. To do this, enter a value in the **Required Number of Executed Incoming Paths** field in the Block Properties window. Note that this value simply refers to how many inputs are required, and does not distinguish based on which path(s) the inputs come from. For example, if there are three incoming paths and three required inputs, one input from each path would trigger the block, but so would three inputs from the first path. An asterisk (*) in this field means that the required number of inputs is equal to the number of paths into the block. See **Flowchart Configurations and Execution** for an example.

**Reset Blocks**

A reset block forces all RENO static functions in the flowchart to generate new values during simulation. Any other resources that are dependent on these values are also recalculated.

You can also recompute only the static function(s) that you specify by using a standard block and entering the following RENO internal function: "staticfunc_reset(NAME)," where NAME is the name of the static function, as shown in the example below.
A reset block can have one incoming path and multiple outgoing paths.

**UI Blocks**

A user interface (UI) block pauses flowchart simulation until the user provides some form of input, then passes its value to the next block(s) in the flowchart. For example, consider the following configuration.

Let's assume that Block A passes a value of 3 to Block B, the UI block. At this point, the simulation will be paused and a message will be displayed to the user. Depending on how the UI block is configured, the message can do one of two things:

- Display the UI block's value (3).
- Give the user the opportunity to enter a value for the UI block.

In both cases, the user can then either continue simulation or cancel simulation. Additionally, the user can specify that no further messages will be shown for the UI block during the current analysis.
Chapter 11: RENO Flowcharts

In the following picture, the UI block is configured to display a message showing its value. The **Message** field contains the wording that will be displayed in the message.

The message is shown next.

In this case, if the user continues the simulation, the value of 3 will be passed to Block C.

In the following picture, the UI block is configured to allow the user to enter a value for the UI block. The **Message** field contains the wording that will be displayed in the message. The **Allow Changing the Value** check box is selected, which adds an input field to the message.
The message is shown next.

In this case, the user can keep the original value (3) or enter a new value for the UI block. The **Reset** icon resets the input field to its original value.
Chapter 11: RENO Flowcharts

If the user continues the simulation, the value in the input field will be passed to Block C.

UI blocks may accept up to one incoming path (input value), and may have multiple outgoing paths (i.e., the same output value is passed to more than one block). In addition to passing the output to the next block(s) in the flowchart, the UI block may be configured to store its output in a variable. The Storage Variable field in the Block Properties window of the block displays the name of the variable, if any.

Subchart Blocks
Subchart blocks represent other flowcharts within the project. Subchart blocks are generally used to break down a larger flowchart into simpler steps to reduce complexity and improve traceability.

For example, in the flowchart shown next, the subchart block called "Cost of Repair" represents another flowchart in the project called "Repair Flowchart" (as shown in the inset). The subchart block processes the incoming value by using a copy of the flowchart that it represents, and then passes the output to the next block in the path.

When you add a subchart block, you will be required to select the flowchart that the block represents or calls. Circular references are not permitted (i.e., a subchart block cannot call the flowchart in which it is placed), and any flowchart called by a subchart block must have a single starting block and a single end block.

During simulation, subchart blocks use a copy of the flowchart they represent, and not the actual flowchart that was created. This means that:

- You do not need to run a simulation of the actual flowchart before using it in a subchart block.
• You can create configurations where several subchart blocks call the same flowchart. Each copy of the flowchart will return different outputs based on the variables passed to it during simulation.

• If a subchart block calls a flowchart that has a result storage block, then the output value of that result storage block is also reported in the Results Explorer. For example, the flowchart shown above has a result storage block called "Expected Costs." In addition, the "Repair Flowchart" also has a result storage block called "Sum." The values stored in both results storage blocks are reported in the Results Explorer, as shown in the navigation panel in the next picture.

As you can see, for any result storage block not located in the main flowchart:

• The navigation panel displays the name of the block and the name of the flowchart (in curly brackets) in which the block is used.

• The block's worksheet includes a Flowchart(s) Location field, which displays the name of the main flowchart, the name of the subchart block and the name of the flowchart in which the block is used.

**Note:** Double-clicking a subchart block will open the flowchart that the block is based on. Open the Block Properties window for a subchart block by selecting the block and choosing the command on the ribbon or pressing CTRL+E. To get a quick preview of the subchart without actually opening it, select the block and either press SPACE or choose Flowchart > Selection > Quick View.
Chapter 11: RENO Flowcharts

RENO Resources

RENO resources are objects that serve to store or generate values used in flowcharts. They cannot, however, be placed directly into flowcharts; instead, they are referenced or called by the blocks within the flowcharts. Any RENO resource is available to be called by any flowchart within the project.

Like all other types of Synthesis resources, RENO resources can be created and edited via the Resource Manager. In addition, when the resource is updated with new information, the change is reflected automatically in all flowcharts in which it is used. There are several types of RENO resources:

- Variables
- RENO functions and static functions
- RENO simulation definitions
- RENO tables
- Models

Note that variables and models may be used by other Synthesis applications. The remaining types are exclusive to RENO.

While the values of some resources (variables and tables) may change during the simulation process, once simulation has been completed, each resource contains only the original value(s) that you entered in its properties window (unless it is a variable set to never reset). If you wish to keep the value(s) of the resource used during simulation, you must use a result storage block within the flowchart to store the value(s). This means that the underlying value of the resource is unchanged by simulation, and therefore simulation of one flowchart will not affect other flowcharts that use the resource.

What's Changed? In previous versions of the software, RENO resources were known as definitions.

Naming RENO Resources

When you create a RENO resources, it is important to name it in a meaningful way, so that it is easy to understand what the resource does and how it is intended to be used. While a default name is supplied upon creation, it is strongly recommended that you choose a more descriptive name.

Names for RENO resources must meet the following requirements:

- Must be unique within the project.
• Must be text; cannot be a number or anything that evaluates to a number, such as Pi or RENO internal functions.
• Cannot start with a number.
• Cannot contain spaces or any of the following characters: \ / : * ? " < > | ‘ ~ @ # $ % ^ & ( ) ;

For models and variables, these naming requirements are enforced only if you have selected the Enforce RENO compatibility check box in the Application Setup window. You cannot use models and variables in RENO flowcharts if their names are non-compliant.

RENO Functions and Static Functions
RENO functions and static functions store equations. The key difference is that a RENO function is always recomputed whenever it is encountered during simulation, and it allows you to pass input variables (also known as parameters or arguments) to the equation while simulation is in progress. A static function, on the other hand, is computed only once, before the simulation begins, and its value will remain constant while the simulation is in progress. It will be recomputed only after the current simulation ends and before the next simulation begins (unless manually forced to recompute).

As a rule of thumb, use a RENO static function if you need the final value of the equation before the simulation even begins, and use a RENO function if you expect the equation to find the values of its parameters during the simulation. The following example illustrates these concepts.

What’s Changed? In previous versions of the software, RENO static functions were known as equation variables.

Suppose you wish to calculate the area of an object: Area = Length * Width, where Length = 106 and Width = 112. To use a static function to calculate the area, you can define the numerical values directly within the equation or use other RENO resources (e.g., variables, models, etc.) to represent those values, as shown in the following example.
Once you have defined the static function, you can use it in a flowchart by referencing its name, as shown in the following example.

![RENO Static Function](image)

**Tip:** You can force all static functions in a flowchart to recompute during simulation by using a reset block. You can also recompute only the static function(s) that you specify by using the RENO internal function called "staticfunc_reset."

Now suppose that Length is a random number from 100 to 150, and Width = 112. In this case, you first need to obtain the length of the object before you can compute its area, but the value for length can be obtained only during simulation. A RENO function would therefore be more appropriate for handling this problem.

There are two ways to use RENO functions: you can use other RENO resources to supply the values for the equation (similar to the example shown above for the RENO static function), or you can choose to explicitly define the parameters of the equation by using the optional **Function Parameters** field, as shown in the example below.
When you explicitly define the parameters, you will be required to define their inputs whenever you use the equation in a flowchart. You can do this by referencing the function name as shown in the example below (where "in" represents the output of the block that obtains the length, and width is set to a value of 112). The Preview area shows the order in which the inputs must be entered.
The expressions in RENO functions and static functions can include:

- Numerical values
- **Standard and special operators**
- Predefined mathematical functions (exp, log, sin, etc.)
- RENO internal functions
- RENO resources
- References to any Synthesis Workbooks

You can enter the equation manually, or you can use the function selector or the equation editor to assist you.

RENO resources, Synthesis Workbooks and internal functions are automatically color-coded to assist in reading the equation. When the cursor is positioned on one of these items, a preview area appears and displays a summary of the item. If the item is a resource, you can click the View icon in the Preview area to open that resource's properties window.
You can enclose a resource name in single quotes to reference it by name. When the item using the expression is transferred to another project or database, any resource referenced by name will not be transferred along with it. If the destination project contains a resource with the same name as the one referenced by name, that resource will be used during simulation of the transferred item. For example, if you export a diagram that contains a block using the expression 'Model1'(1000) from Project1 to Project2, Model1 will not be transferred along with that diagram. If Project2 already contains a model called Model1, that model will be used in simulating the transferred diagram. You can also reference Synthesis Workbooks by name.

**IMPORTANT:** All values and results are assumed to be in terms of the default unit specified for the database. See Using Time Units in RENO for details on how this may affect your analysis.

### RENO Simulation Definitions

A RENO simulation definition enables you to trigger simulation of a BlockSim diagram from within a RENO flowchart by using certain RENO internal functions, so that you can use one or more results from the simulation in the flowchart.

**Note:** You can access BlockSim analytical diagrams for use in RENO flowcharts by using the analytical diagram's published model.

New in Version 11, you can now specify a start time for the simulation in addition to an end time.

The following example shows a scenario where an RBD of a computer is simulated by the block called "Simulate Computer." The resulting system downtime is retrieved by the block called "Computer Downtime" and evaluated by the conditional block. If the downtime is greater than or equal to 300 hours over the 10,000 hour simulation period, then the computer is deemed to have insufficient availability.
The following picture shows the simulation definition that is used to simulate the "Computer" RBD. This performs a run of 1,000 simulations of the RBD called "Computer," each simulation for a period of 10,000 hours.

The "Simulate Computer" block uses this simulation definition as the parameter for the RENO internal function called "simulate," as shown next.
The "Computer Downtime" block can then retrieve the downtime for the "Computer" RBD by using the same simulation definition as the parameter for the RENO internal function called "sr_downtime," as shown next.

The value retrieved is then passed to the conditional block for evaluation.
Another way to use a simulation definition is demonstrated next, using the same simulation definition as in the example above.

This conditional block checks the incoming value to determine if it is greater than 0. If it is, then the "Computer" RBD is simulated 1,000 times, each for a period of 10,000 hours, as specified by the simulation definition. The resulting mean availability value for the system is then passed along the outgoing "true" path.

The BlockSim diagram called by the simulation definition can be either a simulation RBD or a simulation fault tree. If the desired diagram does not exist, you can use the icons beside the Diagram field to create it.

For the Start Time, End Time and Number of Simulations fields, the expression can include:

- Numerical values
- Standard and special operators
- Predefined mathematical functions (exp, log, sin, etc.)
- RENO internal functions
RENO resources

References to any Synthesis Workbooks

You can enter the equation manually, or you can use the function selector or the equation editor to assist you.

RENO resources, Synthesis Workbooks and internal functions are automatically color-coded to assist in reading the equation. When the cursor is positioned on one of these items, a preview area appears and displays a summary of the item. If the item is a resource, you can click the View icon in the Preview area to open that resource's properties window.

You can enclose a resource name in single quotes to reference it by name. When the item using the expression is transferred to another project or database, any resource referenced by name will not be transferred along with it. If the destination project contains a resource with the same name as the one referenced by name, that resource will be used during simulation of the transferred item. For example, if you export a diagram that contains a block using the expression 'Model1'(1000) from Project1 to Project2, Model1 will not be transferred along with that diagram. If Project2 already contains a model called Model1, that model will be used in simulating the transferred diagram. You can also reference Synthesis Workbooks by name.

**IMPORTANT:** All values and results are assumed to be in terms of the default unit specified for the database. See Using Time Units in RENO for details on how this may affect your analysis.

Note that the seed used in the simulation is taken from the current RENO simulation and a single thread is always used.

**RENO Tables**

A RENO table stores an array of values in rows and columns. This table can have up to 65,536 rows and 256 columns. The following example shows the properties of a RENO table called "Tickets." A reference to a RENO table requires inputs for the column number or name and the row number. For example, both Tickets(1,1) and Tickets(A,1) are references to the cell located in the first column and first row of the table.
IMPORTANT: You can change the name of a column by double-clicking its heading; however, making this change can break existing references to table cells. For this reason, it is preferred to use column numbers in references. Additionally, it is recommended that you edit the column names only upon creating the table.

RENO tables store only numerical values, and the values can be used or manipulated during simulation by using certain RENO internal functions. The following configuration, for example, shows how to use two particular internal functions. In this example, the first block evaluates to a table reference, which draws the value stored in the specified cell. The second block evaluates the "table_removerow" function, which deletes the specified row from the specified table. The third block evaluates the "table_rowcount" function, which returns the number of rows that contain data in the specified table.
The values in the RENO table can be retained during simulation or reset to their original values at specific times, depending on your choice in the **When to Reset** field of the table's Block Properties window. The options are:

- **Reset After Each Simulation** (default setting)
- **Reset After Each Run** (i.e., reset after each set of simulations)
- **Reset After Analysis** (i.e., reset after each set of runs)

When the simulations end, the table always returns to the original values. If you wish to keep the values stored in the table during simulation, you must use a **result storage block** to store them.

### Function Selector and Equation Editor

The **function selector** and the **equation editor** can be used to create string expressions (i.e., equations) to be evaluated in **flowchart standard blocks**, **RENO functions and static functions**, or to specify conditional inputs or outputs for **conditional blocks**, **binary nodes**, **logic gates** and **branch gates**.

To access the function selector or the equation editor, you can:

- Right-click inside the equation, input or output field and choose **Show [Function Selector/Equation Editor]**.
- Press **CTRL+SPACE** (function selector) or **SHIFT+SPACE** (equation editor).
- Click the arrow that appears when you click inside the equation, input or output field and choose **Show [Function Selector/Equation Editor]** on the shortcut menu that appears.

### Function Selector

You can use the function selector to quickly add any of the following to the equation:

- **Variables**
- **RENO functions and static functions**
- **RENO simulation definitions**
Chapter 11: RENO Flowcharts

- RENO tables
- Synthesis Workbooks
- Models
- RENO internal functions
- RENO predefined functions

**IMPORTANT:** All values and results are assumed to be in terms of the default unit specified for the database. See *Using Time Units in RENO* for details on how this may affect your analysis.

In the picture shown next, the function selector is being used to display a list of RENO static functions that have been created for use in the project.

Choose the item type from the **Item Category** drop-down list at the bottom of the function selector (or choose **All** if you want to see all items available for inclusion). The **Item List** will display the items of that type that are currently available in the project. You can search within the item list by typing the search term in the field above the item list.

When you select an item, basic information about it will be displayed in the **Preview** area on the right side of the function selector. You can double-click the item to insert it into the equation and close the function selector. If the selected item requires parameter inputs, you may be prompted to provide those inputs depending on whether the **Add parameters when inserting functions using function selector** check box is selected on the **Display page** of the Application Setup. If you are not prompted, you will need to enter the parameters manually.

While using the function selector, you can also:

- View or edit the properties of a resource by selecting the resource and clicking the **View/Edit Resource** icon ( ⬇️ ).
• Add a new resource by clicking the **Add New Resource** icon ( ![Add New Resource](image)). If a resource type is currently selected in the item category list, the new resource will be of that type. Otherwise, you can choose the resource type on the shortcut menu that appears.

• Open the equation editor by clicking the **Open Equation Editor** icon ( ![Open Equation Editor](image)).

### Equation Editor

The equation editor functions similarly to the function selector, but it has an equation area on the left side of the window that displays the equation that you are building. You can add to the equation by typing directly in this area, or by double-clicking items in the list on the right.

To view or edit the properties of a resource, select the resource and choose **Edit Resource**.

To add a new resource, choose the relevant **Add New** command. If a resource type is currently selected in the item category list, you can create a resource of that type only. Otherwise, all **Add New** commands will be available. New resources will appear in the item list.

When you are finished building the equation in the equation area, click **OK** to insert the equation into the block or resource properties.

### RENO Standard and Special Operators

The following operators can be used in expressions in RENO blocks and RENO resources. The standard operators are available for use in other locations, such as reports; special operators are reserved for use only in RENO blocks and RENO resources.

<table>
<thead>
<tr>
<th>Standard Arithmetic Operator</th>
<th>Meaning (Example)</th>
</tr>
</thead>
<tbody>
<tr>
<td>+ (plus sign)</td>
<td>Addition (3+3=6)</td>
</tr>
<tr>
<td>- (minus sign)</td>
<td>Subtraction (3–1=2)</td>
</tr>
<tr>
<td></td>
<td>Negation (–1)</td>
</tr>
<tr>
<td>* (asterisk)</td>
<td>Multiplication (3*3=9)</td>
</tr>
<tr>
<td>/ (forward slash)</td>
<td>Division (3/3=1)</td>
</tr>
<tr>
<td>% (percent sign)</td>
<td>Percent (20%=0.2)</td>
</tr>
</tbody>
</table>
### RENO Special Arithmetic Operator

<table>
<thead>
<tr>
<th>Operator</th>
<th>Meaning (Example)</th>
</tr>
</thead>
<tbody>
<tr>
<td>\ (backward slash)</td>
<td>Returns the integer result of a division (11\2=5)</td>
</tr>
<tr>
<td>] (right bracket)</td>
<td>Modulus, remainder of the division 12]\5=2</td>
</tr>
<tr>
<td>[ (left bracket)</td>
<td>n-th root (2[16]=4, 3[64]=4)</td>
</tr>
<tr>
<td>! (exclamation mark)</td>
<td>Factorial (3!=6)</td>
</tr>
<tr>
<td># (number sign)</td>
<td>Logarithm (b#n where b is the base and n is the number, or 2#8=3)</td>
</tr>
</tbody>
</table>

### RENO Comparison Logic Operator

True/false comparison operators return False=0, True=1

<table>
<thead>
<tr>
<th>Operator</th>
<th>Meaning (Example)</th>
</tr>
</thead>
<tbody>
<tr>
<td>= (equal)</td>
<td>Equal (3=2 returns 0, 2=2 returns 1)</td>
</tr>
<tr>
<td>&gt; (greater than sign)</td>
<td>Greater than (3&gt;2 returns 1, 3&lt;2 returns 0)</td>
</tr>
<tr>
<td>&lt; (less than sign)</td>
<td>Less than (3&lt;2 returns 0, 3&gt;2 returns 1)</td>
</tr>
<tr>
<td>&gt;= (greater than or equal to sign)</td>
<td>Greater than or equal to (3&gt;=2 returns 1)</td>
</tr>
<tr>
<td>&lt;= (less than or equal to sign)</td>
<td>Less than or equal to (3&lt;=2 returns 0)</td>
</tr>
<tr>
<td>&lt;&gt; (not equal to sign)</td>
<td>Not equal to (2&lt;&gt;2 returns 0)</td>
</tr>
<tr>
<td>{ (left curly bracket)</td>
<td>Smallest of the two (3{2 returns 2)</td>
</tr>
<tr>
<td>} (right curly bracket)</td>
<td>Largest of the two (3}2 returns 3)</td>
</tr>
<tr>
<td></td>
<td>(pipe)</td>
</tr>
</tbody>
</table>
& (ampersand)  AND (0|1 returns 0, 1|0 returns 0, 1|1 returns 1, 0|0 returns 0)

<table>
<thead>
<tr>
<th>Reserved Constants</th>
<th>Meaning (Example)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pi</td>
<td>Return Pi to the precision used (3.141592654)</td>
</tr>
<tr>
<td>e</td>
<td>Return e to the precision used (2.718281828)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Reserved for Future Use</th>
<th>Meaning (Example)</th>
</tr>
</thead>
<tbody>
<tr>
<td>? (question mark)</td>
<td>Reserved (10? returns 10)</td>
</tr>
<tr>
<td>' (apostrophe)</td>
<td>Reserved (10' returns 10)</td>
</tr>
<tr>
<td>&quot; (quotation mark)</td>
<td>Reserved (10&quot; returns 10)</td>
</tr>
<tr>
<td>: (colon)</td>
<td>Reserved (10:10 returns 10)</td>
</tr>
</tbody>
</table>

**Flowchart Configurations and Execution**

RENO's simulations are based on the properties of the [flowchart blocks](#), [RENO resources](#) and the configuration of the flowchart. There are almost no inherent limits on the configuration of a RENO flowchart; this provides you with the flexibility to model any scenario you wish to examine.

In general, each path in the flowchart is placed in a queue, and the simulation executes each path based on its order of priority in the queue. However, there may be situations where the order in which the paths are executed is important to the outcome of the simulation. The following examples demonstrate how to use RENO's advanced configuration settings to control the order of execution.

**Tip:** Use the [Debug tool](#) to run a step-by-step simulation on your flowchart to trace the output and verify whether the flowchart behaves as intended.
Example 1: Blocks with Multiple Outgoing Paths

Consider a block (Block A) that has three outgoing paths. The order of execution of the outgoing paths is based on the connector priority, as shown in the following example. In this case, the path represented by connector 1 will be simulated first, followed by the path for connector 2 and then for connector 3. The simulation continues down each path until it reaches an end, and only then is the next path in the queue executed. A path reaches an end when it is stopped by a block that requires a certain number of executed incoming paths (see Example 2) or it reaches the last block in the path.

To display or hide the connector priorities, select or clear the Show Connector Priorities check box on the diagram's control panel.

What's Changed? In versions prior to Synthesis, the Ordered Relations command was used at the block level to show connector priorities.

By default, the connector priority is determined by the order in which the connectors were connected. You can change a connector's priority number by right-clicking the connector and choosing any of the following commands on the shortcut menu: Increase Priority, Decrease Priority, Set to First Priority or Set to Last Priority. You can also specify the priority by choosing Flowchart > Selection > Connector Priority.

Note the following special cases:

- Conditional blocks and logic gates have advanced configurations that allow you to continue execution on both true and false paths. In this case, the simulation will execute
the "true" path first. Once it reaches the end of that path, the simulation will then execute the "false" path and continue until that path also ends.

- Connector priority also applies to subroutines. The simulation will execute each path in the subroutine queue until it ends (i.e., makes a full pass through the main flowchart). For example, in the following flowchart, the simulation will execute the subroutine as follows:
  
  - **Main Path**: Block A → Conditional Block → Go to Flag B → Flag Marker B → Subroutine Path 1 → Subroutine Path 2
  
  - **Subroutine Path 1**: Block C → Go-to-Flag A → Flag Marker A → Block B → Result Storage.
  
  - **Subroutine Path 2**: Block D → Go-to-Flag A → Flag Marker A → Block B → Result Storage.
Example 2: Blocks that Require a Certain Number of Inputs

If a block has multiple incoming paths, you can configure the block to not pass an output or compute a result until the block has received a certain number of inputs. This configuration is available for the following blocks:

- **Result storage blocks**
- **Logic gates**
- **Summing gates**
- **Counter blocks**

Enter the desired value in the **Required Number of Executed Incoming Paths** field in the Block Properties window of the applicable block. Note that this value simply refers to how many inputs are required, and does not distinguish based on which path(s) the inputs come from. For example, if there are three incoming paths and three required inputs, one input from each path would trigger the block, but so would three inputs from the first path.

The following example shows a summing gate that is configured to require 2 inputs before it passes any output to the result storage block. (The connector priorities of the starting block's outgoing paths are also shown to provide context.) In this case, the summing gate will pass two results to the result storage block: once with the value of blocks A+B, and once with the value of blocks C+D.

If the summing gate were configured to require 3 inputs, then the result of blocks A+B+C would be passed to the result storage block, and the value from block D would be ignored.
If the summing gate were configured to require only 1 input, then the value of blocks A, B, C and D would be passed to the result storage block, without the summing gate performing any mathematical operation on the values.

**Example 3: Flowchart with Multiple Starting Paths**

In a flowchart with a single starting path, the blocks are simulated in the order they were added to the path. However, if the flowchart has multiple starting paths, then each path is placed in a queue and the simulation executes each path based on the block IDs of the starting blocks. A block ID is a number assigned to the block when it is created. You can display or hide the IDs of all the blocks in a flowchart by selecting the option in the Block ID field on the Background and Grid page of the Diagram Style window.

*Note:* Block IDs cannot be edited; therefore, to have full control over the execution of a flowchart, we recommend that you add a single starting block to the flowchart and define the connector priorities, as demonstrated in Example 1.

The following example shows a flowchart that has three starting blocks (with the block IDs shown). Each starting block represents an individual path. The starting block with the lowest block ID number has the highest priority in the queue; therefore, in this case, the first path to be simulated is Path 3, followed by Path 2 and then Path 1.
Chapter 11: RENO Flowcharts

Note that you can have more than one flowchart within the same diagram, allowing you to test more than one case in the same diagram or create subroutines. The separate flowcharts will be put into the queue based on the block IDs of their starting blocks.

If your flowchart contains subroutines, you must configure the starting blocks of the subroutines to be executed only when they are called by go-to-flag blocks; otherwise, the simulation will consider the subroutines to be separate flowcharts.

Debugging a Flowchart
RENO's Simulation Debugger is a simple tool that allows you to trace and examine the output of a flowchart by running a step-by-step simulation through each block. You can access the tool by clicking the Debug icon on the control panel of the diagram or by choosing Simulation > Debug.

This opens a window that starts the debugging session. The flowchart being evaluated is displayed in the upper window, while details about the progress of the session are displayed in the bottom window.

Tip: RENO's simulations are based on the properties of the flowchart blocks, RENO resources and the configuration of the flowchart. If your flowchart does not behave as intended, see the Flowchart Configurations and Execution topic for help.

The Debug window includes the following commands:

- **Run** begins a simulation of the flowchart and displays the result of each step in the simulation. You can control the speed of the simulation and other factors via the Debug Options window.

- **Step Into** allows you to view one step of the simulation at a time. Each time you click the Step Into command, RENO executes the next step in the flowchart. The current block is highlighted in the flowchart, and the details of the step are displayed. If the next block in the flowchart is a subchart block, the simulation steps inside the subchart to show the details.

- **Step Over** allows you to execute the subchart in the simulation without stepping inside the subchart.
**Step Out** is available only when you are viewing the progress of the simulation of a subchart. It allows you to step out of the subchart and continue the flow of the simulation in the parent flowchart. The subchart will be executed, but that part of the simulation will not be shown.

**Stop** halts the simulation.

**Options** opens the Debug Options window, which allows you to control how the debug session simulates the flowchart.

- The **Use a Seed** check box allows you to specify a starting point from which the random numbers used in the debug session will be generated. The same random numbers and, therefore, the same simulation results will be generated when the same seed value is used.

- The **Number of Simulations** field allows you to specify how many individual simulations in the flowchart should be performed during the debug session.

- The **Show Inside Subdiagrams** check box allows you to display the simulation of the subchart when using the Run command. If cleared, the subchart will be executed, but that part of the simulation will not be shown.

- The **Time Delay** field allows you to specify the amount of time, in seconds, between steps when using the Run command.

**End Session** closes the Debug window.

---

**Flowchart Control Panel**

The control panel associated with RENO flowcharts consists of multiple pages, each containing options for performing particular tasks. This topic focuses on the Simulation page of the RENO flowchart control panel, which contains most of the tools you will need to simulate a diagram. For more information about the control panel in general, see [Control Panels](#).

**Control Panel Simulation Page**

- The **Simulation** area displays the status and results of the simulation.
• **Status** If the light is green, then the simulation has been performed. If the light is red, then the simulation has not been performed. A simulated diagram will remain in the simulated state unless a change is made to the structure of the diagram (e.g., a block is added, a connector is removed, etc.).

• **Show Simulation Details** (...) displays the most recently generated simulation results in the [Results Explorer](http://blocksim.reliasoft.com).

• Select the **Show Block Values** check box to display the most recent value for each block (except for reset blocks and subchart blocks) at the end of the last simulation in the block's description. The location and appearance of the block description can be changed via the Diagram Style window or the Block Style window. (For information on modifying appearance settings, see [Diagram Skins and Appearance Settings](http://blocksim.reliasoft.com).) If you have made any changes to the flowchart since the last simulation, no values will be displayed.

To perform a single simulation of the flowchart using the seed that is currently specified in the [RENO Simulation window](http://blocksim.reliasoft.com), click the **Update Block Values** icon.

• ![Update Block Values](http://blocksim.reliasoft.com)

• Select the **Show Block Functions** check box to display information about the function the block performs in the block's description. Specifically, for each block type, the following will be shown. (For block types not shown in this list, nothing is displayed.)

  • Flowchart standard blocks: equation
  • Result storage blocks: result type (e.g., average, sum, etc.)
  • Conditional blocks: condition (e.g., =, >, etc.)
  • Logic gates: gate type (e.g., AND, OR, etc.)
  • Summing gates: operation
  • Go-to-flag blocks: the target flag marker
  • Counter blocks: counter type (i.e., when the counter resets)
Chapter 11: RENO Flowcharts

- Subchart blocks: the flowchart that is being used as a subchart

- Select the Show Connector Priorities check box to display the order of execution of the outgoing paths from each block. This order is based on the connector priority and can be changed by selecting a connector and then choosing Flowchart > Selection > Connector Priority.

- The Information area displays information about the diagram or the currently selected block. If no block is selected in the diagram, the Information area displays the number of blocks in the diagram and information about the diagram creation and last modification. If a block is selected in the diagram, it displays a subset of the properties found in the Block Properties window. If you have selected a result storage block of type array in a simulated flowchart, you can click the Transfer Data to Weibull++ icon in the Information area of the control panel to create a Weibull++ life data folio containing the stored values.

<table>
<thead>
<tr>
<th>Time to Failure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Result Storage</td>
</tr>
<tr>
<td>Stored Result</td>
</tr>
<tr>
<td>Storage Variable</td>
</tr>
<tr>
<td>Required Paths</td>
</tr>
<tr>
<td>Comments</td>
</tr>
</tbody>
</table>

This area also offers a Comments field; click the field heading to enter comments. For blocks, these comments are also accessible in the Identifiers properties in the Block Properties window.

- The Tools area on the left side of the control panel gives you quick access to the tools you will need to analyze the diagram and generate additional results.

  Simulate opens the RENO Simulation window, which allows you to specify simulation settings for the current diagram and run the simulation.

  Plot creates a plot based on the simulation results. Clicking the Plot icon before the diagram has been simulated will automatically perform the simulation and then plot the data.

  Debug opens the RENO Simulation Debugger, which allows you to trace and examine the output of a flowchart by running a step-by-step simulation through each block.
Flowchart Simulation

RENO Simulation Window
To simulate a RENO flowchart, choose Simulation > Simulation > Simulate or click the Simulate icon.

**Tip:** The following terms apply to simulating RENO flowcharts:

- A *simulation* is a single pass through the flowchart. Note that this may pass through blocks multiple times if your flowchart includes one or more loops.
- A *run* is a set of simulations.
- An *analysis* is a set of runs.

When simulating, you have three basic choices of what to do:

- **Perform a single run**, consisting of anywhere from 1 to 100,000,000 simulations.
- **Perform a sensitivity analysis**, which involves varying either one or two variables and performing a run at each setting. This allows you to evaluate the effect of each of the variables on the results.
- **Perform multiple analyses**, which involves performing multiple sensitivity analyses in order to minimize or maximize the value of a specified result storage block.

The area at the top of the RENO Simulation window displays the status of the simulation. For information on configuring this display, see RENO Simulation Status Display.

During simulation, you can click **Cancel** to stop the simulation at the current point. The results will be provided for the simulations (if any) that were completed before you stopped the process. When simulation is complete, you can click the **Details** button to view the results of the simulation in the Results Explorer. Click the **Simulate** button to re-run the simulation.

**Note:** Once you have simulated a flowchart, the settings you have specified in the RENO Simulation window are saved along with the diagram so that you or another user can easily simulate the flowchart again using the same settings. The first time you simulate a flowchart, the settings default to the settings used for the last simulation that was performed on your computer.

**Performing a Single Run**
To perform a single run, you will need only the settings on the General Settings tab of the window. First, specify the **Number of Simulations** that you want the run to consist of.
If you need your results to be repeatable, select the **Use a Seed** check box and enter a seed, which specifies a starting point from which the random numbers used in simulation will be generated. The same random numbers and, therefore, the same simulation results will be generated when the same seed value is used.

In the Advanced Simulation Settings area, make sure that both sensitivity analysis and multiple analyses are disabled, then click **Simulate**.

**Performing a Sensitivity Analysis**

Sensitivity analysis allows you to evaluate the effect of one or two variables on the results by performing a run at each of a range of settings.

To perform a sensitivity analysis, first specify the settings for each run on the General Settings tab of the window.

On the Sensitivity Analysis tab, specify whether you want to modify one or two variables by selecting either the **One Way** check box or both the **One Way** and **Two Way** check boxes. In each case, choose the variable from the **Variable** drop-down list, then specify the range of settings for the variable. The **Start** value will be used in the first run. The **End** value is the maximum value that can be used in the simulations; the largest value used will be less than or equal to this. **Increment by** is the amount by which the start value will be increased for each subsequent run.

These settings determine how many runs will be performed. For example, let's say that the number of simulations specified on the General tab is 1,000. You select the **One Way** check box and, for a selected variable, you enter a **Start** value of 100, an **End** value of 500 and an **Increment by** value of 100, as shown next.

```
<table>
<thead>
<tr>
<th>Variable</th>
<th>Start</th>
<th>End</th>
<th>Increment by</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>100</td>
<td>500</td>
<td>100</td>
</tr>
</tbody>
</table>
```

With these settings, the 1,000 simulations will be run with the variable valued at 100, again with it valued at 200, again at 300 and so on until they have been run with the variable at its maximum value of 500. In this case, that would mean that the analysis will consist of 5 runs, with 1,000 simulations performed for each run.

**Note:** In the **Variable** drop-down list, you can also choose to vary the number of simulations performed or the seed used.
Performing Multiple Analyses

You can perform multiple sensitivity analyses in order to minimize or maximize the value of a result storage block. When performing multiple analyses, RENO performs the first sensitivity analysis and finds the value of the variable at which the result storage block of interest is either lowest or highest (depending on whether you are minimizing or maximizing the value). It then takes an interval surrounding that value, divides it up according to the increment specified for sensitivity analysis and performs the specified number of runs on that interval. This process is repeated until specified stopping conditions are reached, refining the interval and the minimum/maximum result with each analysis.

To perform multiple analyses, first specify the settings for each run on the General Settings tab of the window, then specify the sensitivity analysis settings.

On the Multiple Analyses tab, select the Perform Multiple Analyses check box, then specify the following settings:

- In the Analyses Action area, choose the Result Storage block that you want to work with, and the Action you want to perform on it (i.e., whether you want to minimize or maximize the value of the selected result storage block). Note that you cannot choose a result storage block that is set to store an array of values.

- In the Simulation Options area:
  - Use the Increase Simulations field to specify a number by which the number of simulations is either incremented or multiplied for each consecutive sensitivity analysis. Click the operator (+ or x) to toggle between incrementing and multiplying. This option allows you to, for example, perform more simulations at each consecutive analysis so that early analyses over a broad range take less time, while final analyses are performed in detail.
  - In the Procedure field, specify how to calculate the range for each consecutive analysis. For instance, if you choose +/- 2 Increments, then RENO will take the "best" value of the variable from the most recent analysis (i.e., the one that yields the most desirable result for the result storage block) and, for the next analysis, will use a range that spans from two increments below that value to two increments above it. The increments are those used in the previous analysis.

For example, let's assume that you use the sensitivity analysis settings specified above (i.e., variable = Time, start = 100, end = 500, increment = 100) and the multiple analyses settings shown next.
The results of the simulation are shown next.

<table>
<thead>
<tr>
<th>Analysis 1 - Time</th>
<th>Cost</th>
<th>Analysis 2 - Time</th>
<th>Cost</th>
<th>Analysis 3 - Time</th>
<th>Cost</th>
<th>Analysis 4 - Time</th>
<th>Cost</th>
<th>Analysis 5 - Time</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>396.142582</td>
<td>300</td>
<td>539.268765</td>
<td>400</td>
<td>452.766425</td>
<td>400</td>
<td>459.838628</td>
<td>412.5</td>
<td>456.945669</td>
</tr>
<tr>
<td>300</td>
<td>219.817072</td>
<td>300</td>
<td>487.920369</td>
<td>400</td>
<td>452.691649</td>
<td>412.5</td>
<td>456.855721</td>
<td>418.25</td>
<td>459.077303</td>
</tr>
<tr>
<td>500</td>
<td>539.334656</td>
<td>400</td>
<td>495.8454154</td>
<td>400</td>
<td>457.581814</td>
<td>425</td>
<td>455.667714</td>
<td>425</td>
<td>459.589631</td>
</tr>
<tr>
<td>500</td>
<td>459.921511</td>
<td>500</td>
<td>467.570687</td>
<td>475</td>
<td>465.896379</td>
<td>437.5</td>
<td>455.701986</td>
<td>431.25</td>
<td>456.396318</td>
</tr>
</tbody>
</table>

With these settings, Analysis 1 consists of runs performed with the Time variable at 100, 200, 300, 400 and 500. The minimum value for the Costs variable in the first analysis is found at 400. The range for Analysis 2 is +/- 1 increment around 400 (i.e., 300 - 500), and that range is divided into the same number of steps used in the previous analysis. The minimum value for the Costs variable in the second analysis is found at 450. The range for Analysis 3 is +/- 1 increment around 450, where the increment is the one used in Analysis 2 (i.e., +/- 50, yielding a range of 400 - 500). This continues until the stopping condition is reached, as explained next.

- **Stopping Condition** area, enter the maximum number of sensitivity analyses that will be run in the **Max. Analyses** field. In the **Std. Deviation** field, enter the convergence threshold at which the result is considered accurate enough. Simulation will stop when the standard deviation is reached or when the maximum number of analyses have been performed, whichever comes first.
For each variable being modified in the sensitivity analyses, you can select the **Use Integers Only** check box to ensure that the analyses will use only integer values of the variable. You can also specify a **Minimum Increment** that can be used to determine the values of the variable for the analyses. Consider the multiple analyses example above. In Analysis 5, the range of values for the variable is 412.5 - 437.5. Suppose, however, that you can adjust Time only to a 10-hour window. If you specify a minimum increment of 10, you obtain the results shown next.

<table>
<thead>
<tr>
<th>Analysis</th>
<th>Time</th>
<th>Cost</th>
<th>Analysis</th>
<th>Time</th>
<th>Cost</th>
<th>Analysis</th>
<th>Time</th>
<th>Cost</th>
<th>Analysis</th>
<th>Time</th>
<th>Cost</th>
<th>Analysis</th>
<th>Time</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>200</td>
<td>999.4</td>
<td>412.8</td>
<td>200</td>
<td>539.3</td>
<td>412.5</td>
<td>200</td>
<td>459.7</td>
<td>412.4</td>
<td>200</td>
<td>455.0</td>
<td>412.2</td>
<td>200</td>
<td>455.0</td>
<td>412.1</td>
</tr>
<tr>
<td>200</td>
<td>739.0</td>
<td>376.7</td>
<td>200</td>
<td>407.0</td>
<td>376.5</td>
<td>200</td>
<td>425.2</td>
<td>376.4</td>
<td>200</td>
<td>425.2</td>
<td>376.3</td>
<td>200</td>
<td>455.0</td>
<td>376.1</td>
</tr>
<tr>
<td>200</td>
<td>539.3</td>
<td>306.6</td>
<td>400</td>
<td>459.6</td>
<td>306.4</td>
<td>400</td>
<td>459.6</td>
<td>306.4</td>
<td>400</td>
<td>459.6</td>
<td>306.4</td>
<td>400</td>
<td>459.6</td>
<td>306.4</td>
</tr>
<tr>
<td>200</td>
<td>459.6</td>
<td>251.1</td>
<td>500</td>
<td>489.3</td>
<td>251.1</td>
<td>500</td>
<td>489.3</td>
<td>251.1</td>
<td>500</td>
<td>459.6</td>
<td>251.1</td>
<td>500</td>
<td>459.6</td>
<td>251.1</td>
</tr>
</tbody>
</table>

### RENO Simulation Status Display

The area at the top of the [RENO Simulation window](http://blocksim.reliasoft.com) displays the status of the simulation.

The following numerical information is always shown:

- **Seed Value** displays the seed value used, if any (i.e., the starting point from which the random numbers used in simulation are generated).
- **Simulation Start** displays the date and time that the simulation began.
- **ETC** displays the expected date and time of completion for the simulation.

In addition, the current number of simulations performed out of the total number of simulations scheduled to be performed is shown at the bottom of the simulation status display (e.g., 10 out of 100 simulations). You can control how often this number is updated by specifying the number of increments to divide the total number of simulations into in the **Update Increments** field in the **Display Options** area.

If you have selected **Full Display** in the **Display Options** area, a plot will also be shown in the simulation status display. This plot shows the value of the result storage block that you have chosen from the **Display Result Storage Block** drop-down list. Result storage blocks of all types except array will be available in this list. The range of values represented on the y-axis is...
controlled by your entries in the Y-Axis fields. During simulation, the current value of the selected result storage block is displayed above the plot.

## Available Results

### Flowchart Simulation Results

The Results Explorer is generally the same for BlockSim diagrams and for RENO flowcharts, with a few minor differences. Please refer to the Results Explorer topic for details on using this window.

The available worksheets are presented next.

### General Summary Results

The General Summary worksheet presents an overview of the simulation settings.

- **Number of Simulations**: The number of simulations per run in the last analysis that was performed.
- **Seed Value**: The seed value, if any, used when generating random numbers during simulation.
- **Simulation Variable 1(2)**: The name of the variable(s) modified during simulation, if any.
- **Variable Start**: The starting value of the modified variable.
- **Variable End**: The ending value of the modified variable.
- **Number of Runs**: The number of runs that were performed for the modified variable in the last analysis. Unless you performed one or more sensitivity analyses, this will be one.

### Result Storage Blocks

The Result Storage Blocks worksheets display the simulation results for each result storage block in the flowchart or in any subcharts called during simulation. Note that for any block not located in the main flowchart, the name of the flowchart in which it is used is displayed in the navigation panel. Click the name of the block in the navigation panel to display the block details on a separate worksheet for that corresponding block.

The first table displays the following information:

- **Flowchart(s) Location**: The path by which the result storage block was accessed during simulation. For example, consider a result storage block located in Flowchart 1. If you simulated Flowchart 1, then the location shown would simply be "Flowchart 1." However, if Flowchart 1 is called by "Subchart Block" in Flowchart 2, and you simulated
Chapter 11: RENO Flowcharts

Flowchart 2, then the location shown would be "Flowchart 2.Subchart Block->Flowchart 1."

- **Storage Type**: The type of data that the result storage block contains (i.e., average, sum, array, minimum, maximum, last value or normalized sum of results).

- **Runs Stored [per Analysis]**: The number of runs of simulations performed. If you performed multiple analyses, this information is for each analysis.

The second table displays the value (or values, if the result storage block is an array) of the result storage block at the end of each simulation run. If you have performed only one run, only the result storage block name and value will be displayed. If you have performed multiple runs (i.e., a single sensitivity analysis), the table will contain values for the varied variable(s) and for the result storage block. (Where two variables are varied, the values of the variable named first are in the first column (column A) and the values of the variable named second are in the heading row of the table.) If you have performed multiple analyses, the table(s) will contain values for the varied variable(s) and for the result storage block for each analysis.

### Flowchart Plots

Plots can be created and viewed by clicking the **Plot** icon located on the Simulation page of the control panel for each flowchart.

![Plot Icon](image)

If you click the **Plot** icon before the flowchart has been simulated, you will be prompted to simulate the flowchart and then the data will be plotted in the plot sheet. (Note that the **Plot** icon on the Plot sheet control panel refreshes the plot. If data or settings have been changed since the flowchart was last simulated, you must resimulate before refreshing the plot.)

You can add additional plot sheets to the flowchart by right-clicking the sheet index tabs at the bottom of the window and choosing **Insert Simulation Plot** on the shortcut menu. You can delete a plot sheet from the flowchart by selecting the plot sheet, right-clicking and choosing **Delete Plot**.

There are five plot types available in RENO. Not all plot types are available for all simulation settings. In addition, there are restrictions on the types of data that can be plotted on each plot type at each simulation setting.

- **Result Storages Plot** shows the value(s) of one or more result storage blocks plotted against either the result index (in the case of a single simulation run) or the varied variable (in the case of sensitivity analysis or multiple analyses). You can show results for single-value and array result storage blocks within the same plot.
• **Result Comparison Plot** shows the value(s) of two result storage blocks plotted against each other. Both result storage blocks must be either single-result or array; you cannot compare a single-value result storage block against an array result storage block. For single-run simulations, only array result storage blocks can be compared.

• **Pie Chart** displays the value(s) of one or more result storage blocks in pie chart format. This plot is available only for single-run simulations and for analyses where one variable is modified. For single-run simulations, you can plot the results of multiple single-value result storage blocks or of one array result storage block. For sensitivity/multiple analyses, you can plot the results of one single-value result storage block.

• **Bar Chart** displays the value(s) of one or more result storage blocks in bar chart format. This plot is available only for single-run simulations and for analyses where one variable is modified. For single-run simulations, you can plot the results of multiple single-value result storage blocks or of one array result storage block. For sensitivity/multiple analyses, you can plot the results of one single-value result storage block.

• **Probability Plot** plots the values of one or more result storage blocks against the cumulative probability of the values, based on the ranking method (Median Ranks or Kaplan-Meier) selected on the Plot page of the Application Setup. For single-run simulations, you can plot the results of one or more array result storage blocks. For sensitivity/multiple analyses where one variable is modified, you can plot the results of one or more single-value and/or array result storage blocks. For sensitivity/multiple analyses where two variables are modified, you can plot the results of one single-value or array result storage block.

The Plot Sheet control panel changes depending on the selected plot type and the simulation settings that have been used, so that it is easy for you to meet the requirements for the plot you are generating. When only one item can be plotted on an axis or on a plot, the selection area will be a drop-down list. When multiple items can be plotted, the selection area will be a list with check boxes. In both cases, the type of each result storage block will be marked in parentheses next to the block name. For those plots where you can plot only single results or only arrays, RENO will display only the result storage blocks of the correct type. For the Result Comparison plot, once you have selected the result storage block for the X-axis, only result storage blocks of the same type (i.e. single-value or array) will be displayed in the selection area for the Y-axis, as you cannot plot single values against arrays.

The Probability plot offers one additional option. You can use the **Scale** drop-down list to select the scale you would like to use for the plot.
Chapter 12: Allocation Analysis

The allocation analysis tool can help you determine the reliability requirements for individual components/assemblies that would be needed to achieve an overall reliability goal. To use the tool, you do the following:

1. **Create** the allocation analysis.
2. **Specify** a target reliability for the system at a particular time and select which of the individual blocks in the system you would like to consider for improvement.
3. **Choose** the allocation type or method that you want to use.
4. **Perform** the optimization.

You can also create an allocation analysis from within the FMRA view. These allocation analyses offer some features suited to FMRA use.

### What's Changed?

In BlockSim 7, this kind of system optimization was performed by selecting certain blocks to be considered in the calculation and specifying their maximum achievable reliability and the feasibility of achieving that reliability via their properties windows; the QCP was then used to perform the calculations. The allocation analysis tool provided in the Synthesis version allows you to select the blocks for consideration, specify the required values and perform the calculations in a single window, thereby making it simpler to set up and modify your calculations.

### Create the Allocation Analysis

To add an allocation analysis to the project, choose **Insert > Tools > Allocation Analysis**.

In the Select Diagram window that appears, select the diagram that you want to perform an allocation analysis for. Allocation analysis can be performed only for analytical diagrams, so all of the diagrams that are available in this window will be analytical diagrams. You can select any diagram that is currently in an analyzed state; diagrams that have not been analyzed will be displayed in the list but cannot be selected. (You can hide these diagrams by selecting the **Hide unavailable diagrams** check box at the bottom of the window.) When the allocation analysis folio is created, the name of the diagram that it is based on will be displayed at the bottom of the control panel; you can click the diagram name to open it.

In the allocation analysis folio, you will see a table that displays the current reliability and the reliability importance of each of the blocks in the selected diagram. **Reliability importance** is a measure of the relative importance of each component in a system with respect to the overall...
reliability of the system. These values are calculated at the mission time specified in the control panel; you can change that value in the control panel and click the Refresh button to update the values in the table accordingly. The current reliability for the entire system is displayed in the Outputs area of the control panel, and is also dependent upon the specified mission time.

**Tip:** The order of the blocks in the table is controlled by the Set Block Order command in the associated diagram.

The color coding used in the Reliability Importance column provides a quick visual indicator of how important the blocks are to the system reliability. You can adjust the threshold for the colors by clicking the Adjust Color Limits button (...) in the Color Limits field in the control panel. Move the sliders to indicate the values below which you want everything to be displayed in green (i.e., least important) and above which you want everything to be displayed in red (i.e., most important). To automatically determine a min/max for the Color Limits based on the values in the Reliability Importance column of the current tab, click the Calculate Color Limits button.

### Specify Included Blocks and Settings

Select the check box in the first column for each block that you want to consider for improvement in the allocation analysis. Any block that has a model assigned to it can be considered in the optimization process; standby and load sharing configurations are considered at the container/gate level, not at the contained block/dependent event level. You can select or clear the check box in the column header to select or clear all of the individual check boxes. The goal of an allocation analysis is to improve the reliability of the system; this purpose is best served if you do not select blocks with very low reliability importance or with very high current reliability values.

In the Inputs area of the control panel, enter the following information:

- **Target Reliability** is the system reliability that you want to reach.
- **Time** is the mission time, or the time at which the optimization will be conducted. You must specify the units for this measurement. For example, if you want to determine the optimum scenario for increasing component reliability in order to achieve a system reliability of 0.98 at 100 days, you would enter 100 in the Time field and choose Day in the Units field.
- **Iterations** allows you to specify the maximum number of iterations of the optimization algorithm to be conducted in order to obtain a solution.
Choose the Allocation Type

The software provides three allocation types that can be used to logically apportion the system reliability across the selected blocks. Select the desired allocation type in the **Allocation Type** field in the control panel. Available allocation types include:

- **The equal** allocation type achieves the specified target reliability for the system by determining a single target reliability value that all selected blocks must reach, regardless of their current reliability or reliability importance. If you select this allocation type, you do not need to enter any additional information for each block.

- **The weighted** allocation type allows you to specify a weight for each selected block, which is used in determining the block's target reliability. If you select this allocation type, you will need to enter a weight for each selected block. If all selected blocks are given the same weight, they will all have the same target reliability.

- **The cost optimized** allocation type allows you to meet the system's target reliability at the lowest possible cost. This allocation type determines the target reliability for each selected block based on the maximum reliability that can be achieved for the block and the relative difficulty or cost of increasing the block's reliability. If you select this allocation type, you will need to enter two additional values for each selected block:
  - In the Maximum Achievable Reliability column, enter the greatest reliability that the component can possibly reach at the mission time specified in the control panel. This value is a limiting reliability that the component will approach, but not reach. It should be based on engineering judgment and experience, taking into account the current state of the art of the component and other similar factors.
  - In the Feasibility column, specify the difficulty of increasing the component's reliability, relative to that of increasing the reliability of the rest of the components in the system. Depending on the design complexity, technological limitations, etc., certain components can be very hard to improve. Clearly, the more difficult it is to improve the reliability of the component, the greater the cost. In the drop-down for each cell in this column, there are two ways to specify this value. You can select to use a predefined feasibility value, in which case you simply move the marker on the scale to the desired location between Easy (0.1) and Hard (9.9). You can also select to enter your own feasibility equation. If you choose to do this, the equation, or function, must meet the following requirements:
    - The function must include a reference to the reliability of the component, which is denoted by an R.
    - The function must return a positive value.
The function must be described in notation similar to that used in Excel. Since the evaluation is relative, any feasibility functions that you enter should be correlated with one another. In addition, you should not use your own functions for some components and the predefined feasibility values for others unless you are sure that your functions are correlated to the function used to calculate the predefined values. For this reason, it is preferable to use the predefined values unless you have a compelling reason to do otherwise.

The default feasibility function used in BlockSim is defined by:

\[
C_i(R_i) = e^{\left(1-f\right)^{\frac{R_i-R_{\min,i}}{R_{\max,i}-R_i}}}
\]

where:
- \(C_i(R_i)\) is the penalty (or cost) function as a function of component reliability.
- \(f\) is the feasibility (or cost index) of improving a component's reliability relative to the other components in the system.
- \(R_{\min,i}\) is the current reliability at the time at which the optimization is to be performed.
- \(R_{\max,i}\) is the maximum achievable reliability at the time at which the optimization is to be performed.

**Perform the Analysis**

Click the **Optimize** icon.

Once optimization has been performed, the following information will be displayed for each selected block:

- The target reliability, which is the reliability of the component at the specified mission end time that would be required in the optimum scenario to increase component reliability to reach the specified reliability goal.
- Equivalent parallel units, which indicates the number of identical blocks that would be required in a parallel configuration for the particular block to meet the specified reliability goal, in lieu of increasing the component's reliability.
In addition, the **System Reliability** field in the **Outputs** area of the control panel will display the reliability of the system if the optimum scenario is implemented (i.e., if all selected blocks are improved to their target reliability values).

**Note:** Subdiagram blocks are displayed as hyperlinks. You can click the name of the subdiagram block to add another tab to the allocation analysis folio, where you can perform allocation analysis for the subdiagram.

You can click the **Transfer to Spreadsheet** icon to save the results in a **Synthesis Workbook**.

The Select Workbook window that appears allows you to select an existing workbook or add a new one to the project. If you select an existing workbook, you can select the **Overwrite Existing Sheets** check box to overwrite the current contents of the workbook. If you do not select this check box, a new sheet will be added to the workbook. If you select to add a new workbook, you will be prompted for the workbook name.

You can click the **Send to Excel** icon to save the results as an Excel file.

In either a Synthesis Workbook or an Excel file, the results will look like the ones shown next.
## Chapter 12: Allocation Analysis

The first row displays the name of the optimized diagram and the allocation type that was used in the optimization. For each selected block, the following information is shown:

- The block name.
- Any inputs that you entered:
  - For the Equal allocation type, no block-level inputs are shown.
  - For the Weighted allocation type, the **Weight** for each block is displayed.
  - For the Cost Optimized allocation type, the **Maximum Achievable Reliability** and the **Feasibility** for each block are displayed.
- **RI (Time)** is the block's reliability importance at the specified mission time.
- **Reliability (Time)** is the block's reliability at the specified mission time if no improvements are made.

<table>
<thead>
<tr>
<th>Block Name</th>
<th>Max. Achievable Reliability</th>
<th>Feasibility</th>
<th>RI (100)</th>
<th>Reliability (100)</th>
<th>Target Reliability (100)</th>
<th>Equivalent Parallel Units *</th>
</tr>
</thead>
<tbody>
<tr>
<td>Block 0</td>
<td>1</td>
<td>Hard (9)</td>
<td>0.876672</td>
<td>0.983882</td>
<td>0.9901</td>
<td>1.02579</td>
</tr>
<tr>
<td>Block 1</td>
<td>1</td>
<td>Moderate (6)</td>
<td>0.894777</td>
<td>0.963872</td>
<td>0.983411</td>
<td>1.181391</td>
</tr>
<tr>
<td>Block 2</td>
<td>1</td>
<td>Easy (1)</td>
<td>0.000032</td>
<td>0.997503</td>
<td>0.997503</td>
<td>1</td>
</tr>
<tr>
<td>Block 3</td>
<td>1</td>
<td>Easy (1)</td>
<td>0.002165</td>
<td>0.999963</td>
<td>0.999963</td>
<td>1</td>
</tr>
<tr>
<td>Block 4</td>
<td>1</td>
<td>Easy (3)</td>
<td>0.9581</td>
<td>0.904837</td>
<td>0.975685</td>
<td>1.580098</td>
</tr>
</tbody>
</table>

### System Results

<table>
<thead>
<tr>
<th>Reliability (100)</th>
<th>Target Reliability (100)</th>
<th>Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.866925</td>
<td>0.95</td>
<td>Hour</td>
</tr>
</tbody>
</table>

* Equivalent Parallel Units

Number of Equivalent Parallel Units
Indicates the number of blocks that would be required in a parallel configuration for this particular block, in lieu of increasing the block's reliability.
• **Target Reliability (Time)** is the block's goal reliability at the specified mission time in order to meet the target system reliability.

• **Equivalent Parallel Units** is the number of identical blocks that would be required in a parallel configuration for the particular block to meet the specified reliability goal, in lieu of increasing the component’s reliability.

The System Results include the following:

• **Reliability (Time)** is the system's reliability at the specified mission time if no improvements are made.

• **Target Reliability (Time)** is the system's reliability at the specified mission time if the optimum scenario is implemented. This is the **Target Reliability** that you specified on the control panel.

• **Units** displays the units that were specified for the mission time.

**FMRA Allocation Analysis**

Following the steps above, you can create an allocation analysis based on any analytical FMRA diagram that inherits its reliability from its dependents. You can also create allocation analyses for such diagrams directly within the FMRA view by choosing **FMRA > Calculations > Allocation Analysis**.

Allocation analyses created in this way offer some different features that are suited to FMRA use.

• All analyses for subdiagrams are created when the allocation analysis is created. Simply click the tabs at the bottom of the folio to access them.

• Two views are available. The Tabs view corresponds to the standard view in all allocation analyses. The Hierarchy view shows the entire allocation, including any subdiagrams, listed in the order of the items' hierarchical level. If you use this view to calculate, all tabs in the Tabs view are calculated.

• When working in the Tabs view, you can choose **Allocation > Transfer > Transfer Target Reliability to FMRA** to transfer the calculated target reliability values for each block to the associated FMRA item in Xfmea/RCM++/RBI.

An allocation analysis created from within the FMRA view will not appear in the current project explorer. However, you can reopen it by choosing the command again.
About Reliability Importance

Reliability importance is a measure of how much effect each component has on the overall reliability of the system. One simple way to demonstrate this concept is to look at a series system. In general, the least reliable component in a series system has the greatest effect on the reliability of the system.

Consider three components arranged reliability-wise in series, where $R_1 = 70\%$, $R_2 = 80\%$ and $R_3 = 85\%$ (for a given time). In the table shown next, we can examine the effect of each component's reliability on the overall system reliability.

<table>
<thead>
<tr>
<th>Component 1</th>
<th>Component 2</th>
<th>Component 3</th>
<th>System</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.7</td>
<td>0.8</td>
<td>0.85</td>
<td>0.476</td>
</tr>
<tr>
<td>0.8</td>
<td>0.8</td>
<td>0.85</td>
<td>0.544</td>
</tr>
<tr>
<td>0.7</td>
<td>0.9</td>
<td>0.85</td>
<td>0.536</td>
</tr>
<tr>
<td>0.7</td>
<td>0.8</td>
<td>0.95</td>
<td>0.532</td>
</tr>
</tbody>
</table>

The first row of the table shows the given reliabilities for each component and the corresponding system reliability. In each of the following rows, the reliability of one component has been increased by 10% while keeping the reliabilities of the other components at the given values. This allows us to observe the effect of each component's reliability on the overall system reliability. It is clear that the highest value for the system's reliability was achieved when the reliability of Component 1, which is the least reliable component, was increased by a value of 10%. In other words, Component 1 has a higher reliability importance.

In simple systems such as this series system configuration, it is easy to identify the weak components. However, in more complex systems this becomes quite a difficult task. The value of the reliability importance depends both on the reliability of a component and its position in the system. BlockSim calculates this value automatically.

Mathematically, reliability importance is the partial derivative of the system reliability equation with respect to a component's reliability. The reliability importance, $IR_i$, of component $i$ in a system of $n$ components is given by:

$$IR_i = \frac{\partial R_S}{\partial R_i}$$
where:

- $R_s$ is the system reliability.

For more information about reliability importance and the various ways it is used within BlockSim, please read "Reliability Importance Measures of Components in a Complex System" at: [http://www.weibull.com/hotwire/issue66/relbasics66.htm](http://www.weibull.com/hotwire/issue66/relbasics66.htm).
Chapter 13: Optimum Replacement Window

The Optimum Replacement window helps you to determine the best time to inspect and/or replace components, based on the costs for planned (i.e., preventive) and unplanned (i.e., corrective) maintenance. If you are calculating the optimum inspection time, it also considers the failure detection threshold.

Preventive maintenance is a logical choice if, and only if, the following two conditions are met:

- Condition #1: The failure rate of the component in question increases with time, implying wearout.
- Condition #2: The overall cost of the preventive maintenance action must be less than the overall cost of a corrective action (including downtime costs, loss of production, lawsuits over the failure of a safety-critical item, loss of goodwill, etc.).


Analyze a Block or Diagram

To access the Optimum Replacement window for a single block, click the Optimum Replacement icon in the Block Properties window.

To consider multiple blocks in the same diagram, open the diagram and choose [Diagram/Fault Tree] > Calculation > Optimum Replacement. For an FMRA diagram, choose FMRA > Calculations > Optimum Replacement.

Available Blocks

You can perform individual block calculations for standard blocks (including contained blocks) in RBDs and for events (including dependent events) in fault trees. You can also perform an
individual calculation for a standby container; in this case, the switch is the item that is
optimized, not the container itself.

If you are working with a diagram or FMRA, use the **Available Blocks** area on the left side of the
window to select which of the eligible components to analyze.

**Tip:** The order of the blocks in the list does not affect the calculations. If you want to change the order
for convenience or cosmetic reasons, it is controlled by the **Set Block Order** command in the associated
diagram.

To be available for inclusion in the optimization calculations:

- Blocks must have a failure model.
- Switches must have a failure model assigned.
- The failure model for a switch or a block must meet the following requirements.
  - Fixed reliability and exponential distributions are not allowed.
  - Weibull distributions must have beta > 1.
  - Gamma distributions must have k > 1.
  - Loglogistic distributions must have std < 1.
  - For generalized gamma distributions and mixed Weibull distributions, there must be an increasing failure rate within at least one time period. A local optimum can then be found within intervals with an increasing failure rate.

**Planned and Unplanned Replacement Costs**

In the table, the columns with white backgrounds require input. The **Planned Replacement Cost** and **Unplanned Replacement Cost** are always required.

For blocks in an analytical diagram, you can type the cost directly into each cell.

For blocks in a simulation diagram, you have the option to estimate the cost based on the simulation results, if desired. Make sure the diagram is simulated and then click **Auto Fill Simulation Costs**.

If you want to add additional costs that were not estimated from the simulation, click the arrow in the cell to show both inputs.
Inspection Cost and Failure Detection

If you want to calculate optimum inspection times, make sure the **Show Inspection Columns** command is toggled on.

**Inspection Cost** is the cost for the inspection task(s) or the inspection portion of the on condition task(s).

**Failure Detection** is the failure detection threshold (FDT), which is the percentage of the item's life that must have elapsed in order for approaching failure to be detected.

Calculation Options

If you are working with a diagram instead of with a single block, when you click **Calculate**, you can choose from the following options:

- **Individual** - Calculate the individual optimum replacement time for each item. If you are calculating optimum inspection times, you must use this option.

- **Common** - Calculate a common optimum replacement time, which is the most cost-effective time to replace all of the selected items concurrently.

- **Clusters** - Calculate clustered optimum replacement times, which allows you to specify a number of groups in which to replace the selected items. For example, if you enter 3 in the **Number of clusters** field, the software will determine the three best times to replace groups of items such that all of the selected items are replaced at one of the three times, at overall minimum cost.
Results and Plots
The table shows the results for each block. The total costs per unit time based on all included blocks are displayed under the table.

Click Cost vs. Time Plot to show a plot of the results.

Create Tasks
For simulation diagrams, you can click Create Maintenance Task(s) > At [Replacement/Inspection] Time to create preventive and/or inspection tasks for one or more of the items.

The window that appears allows you to select which items to create tasks for. Preventive tasks created in this way restore the item to as good as new condition and are scheduled at fixed intervals based on item age, equal to the optimum replacement time.
Chapter 14: FRED Reports

You can use the analytical results and maintainability/availability simulation results for your BlockSim diagrams and fault trees to generate Failure Reporting, Evaluating and Display (FRED) Reports. These reports provide a graphical demonstration of the reliability and maintainability/availability characteristics of the components in a system and help to identify the components that may require improvement.

To add a FRED report to the project, choose Insert > Reports and Plots > FRED Report.

In the Select Diagram window that appears, select the diagram that you want to create the report for. You can select any diagram that is currently in an analyzed state; diagrams that have not been analyzed will be displayed in the list but cannot be selected.

You can create a FRED report for any FMRA diagram that inherits its reliability from its dependents by following the steps above or by selecting/opening the diagram in the FMRA view and choosing FMRA > Calculations > FRED Report.

The FRED report will be displayed, as shown next.
The pentagon-shaped block in the first row represents the results for the first diagram included in the FRED report. This block will always show the time at which the results are reported for the system and its blocks.

- For analytical FRED reports, you can specify the result time in the **At Time** field on the control panel. You can also set the time units by selecting an option from the **Units** drop-down list. When you click **Recalculate**, the FRED report will update all of the blocks to show their results at the new time and/or units.

- For simulation FRED reports, results are reported at the simulation end time. You can set the time units by selecting an option from the **Units** drop-down list. The FRED report will automatically update all of the blocks to show results based on the new units.

The boxes in the following row represent the blocks and subdiagrams in the first diagram. For any subdiagram that appears in the FRED report, you can add a row below it that shows the blocks in the subdiagram. To do this, select the subdiagram and either double-click it or choose **FRED > Levels > Append Level Below**.
**Note:** For simulation diagrams that contain subdiagrams, you must select the **Report subdiagram results** check box on the **Analysis Settings page** of the diagram control panel in order for the subdiagram results to be available for use in the FRED report. If you have not selected this check box, subdiagram blocks in the FRED report will show "N/A" instead of results. If you attempt to append a level below such a block, you will see a message that explains the problem and offers you the opportunity to resimulate the diagram with the subdiagram results reported.

You can also expand all subdiagrams in the report by choosing **FRED > Levels > Auto Expand**.

To remove a single row, select the subdiagram block that the row was appended to and then choose **FRED > Levels > Remove Level(s) Below**.

You can clear all additional rows by choosing **FRED > Levels > Restart FRED Report**. This clears all levels of the FRED report except the original diagram so that you can restart the report creation.

You can print the report by choosing **Home > Print > Print**. You can also import and export FRED reports among projects.

The FRED reports that you create in the current project will be listed under the Reports folder in the **current project explorer**.

**Specifying the Metrics Shown**

New in Version 11, you can select which metrics you want to show on the blocks in the FRED report.

- To include a metric in the report, select its check box in the **Available Results** list on the control panel.

- You can change the order in which the metrics are displayed in the report by dragging the metrics up and down within the list.

- Double-click a metric in the list to set it as the **primary metric** (indicated by a green check mark in the list). The color-coding in the FRED report will be based on this metric. The primary metric can be shown on the blocks, but it does not have to be.
Tip: You can select any number of metrics for inclusion in the report. This may cause you to need to resize the blocks so that they are big enough to contain all of the results. One easy way to do this is to select all affected blocks and choose FRED > Options > Block Style to resize all of them at once, then choose FRED > Levels > Auto Arrange to automatically adjust the diagram to accommodate the new size.

Available metrics for analytical FRED reports:

The abbreviations used on the blocks within the diagram are shown [in brackets].

- **Reliability**: The probability that the system or block will operate without failure for the given period of time. [R]

- **Probability of Failure**: The probability that the system or block will fail in the given period of time. [Q]

- **Reliability Importance** (blocks only): A relative measure of how much effect each block has on the overall reliability of the system. [Imp]

Available metrics for simulation FRED reports:

The abbreviations used on the blocks within the diagram are shown [in brackets].

- **Mean Availability (All Events)**: Includes all downing events during the time of the simulation. This is calculated by dividing the system uptime by the total simulation time or the block uptime by the total simulation time. [Ao]

- **Mean Availability (w/o PM, OC & Inspection)**: Includes only downing events associated with corrective tasks, but not preventive, on condition or inspection tasks, during the time of the simulation. [Am]

- **Uptime**: The total amount of time that the system or block was up (i.e., operational) during the simulation. [Uptime]

- **Downtime**: The total amount of time that the system or block was down (i.e., not operational) during the simulation. [Downtime]

- **Mean Time Between Failures (Uptime)**: The mean time between failures, considering only the time that the system or block was up. This is calculated by dividing system uptime by the number of system failures, or dividing block uptime by the number of block failures. [MTBF_u]

- **Mean Time Between Failures (Total time)**: The mean time between failures, based on the total simulation time and including all failures. [MTBF_t]

- **Mean Time Between Downing Events (Uptime)**: The mean time between all downing events, considering only the time that the system or block was up. This is calculated by
dividing system uptime by the number of system downing events, or dividing block uptime by the number of block downing events. [MTBDE_u]

- **Mean Time Between Downing Events (Total time):** The mean time between all downing events, based on the total simulation time. This is calculated by dividing the simulation run time by the number of downing events. [MTBDE_t]

- **Mean Time to Repair:** The total downtime associated with corrective tasks divided by the number of failures. [MTTR]

- **Mean Time to Maintain:** The total downtime divided by the number of downing events. [MTTM]

- **RS FCI** (blocks and subdiagrams only): The ReliaSoft Failure Criticality Index for each block. This is a relative index showing the percentage of times that a failure of the block caused a system failure (i.e., the number of system failures caused by the block divided by the total number of system failures). Note that this relates only to failures; it does not include every event that could bring the system down (such as routine maintenance). [FCI]

- **RS DECI** (blocks and subdiagrams only): The ReliaSoft Downing Event Criticality Index for each block. This is a relative index showing the percentage of times that a downing event of the block caused the system to go down (i.e., the number of system downing events caused by the block divided by the total number of system downing events). [DECI]

- **RS DTCI** (blocks and subdiagrams only): The ReliaSoft Downtime Criticality Index for the block. This is a relative index showing the contribution of the block to the system's downtime (i.e., the system downtime caused by the block divided by the total system downtime). [DTCI]

- **RS BCCI** (blocks and subdiagrams only): The ReliaSoft Block Cost Criticality Index for the block. This is a relative index showing the contribution of the block to the system's total costs (i.e., the total block costs divided by the total costs). [BCCI]

**Primary Metric**

A color scale, displayed in the report’s legend, is used to rank the blocks according to a chosen primary metric. This metric is indicated by a green check mark in the Available Results list on the control panel. You can set any result as the primary metric at any time by double-clicking the result name.

You can change the range of values represented by the color scale by choosing FRED > Options > Set Color Limits
or by clicking the (...) button on the control panel to open the Set Color Limits window and set a new lower limit and upper limit. For example, if the primary metric is reliability and you want to highlight the blocks with a reliability under a certain percentage, set the lower limit of the spectrum to that value, then refresh the plot. If **Show all values in legend** is selected in the Set Color Limits window, the legend will show the full range of values; if it is not selected, the legend will show only the values between the upper and lower limits that you have specified. The preview shows how the specified settings will appear in the legend.

To automatically determine a minimum/maximum for the color limits based on the blocks in the diagram, click the **Calculate Color Limits** icon on the control panel.

**Diagram Appearance**

As with other diagrams, you can change the appearance of FRED reports by choosing **FRED > Options > Diagram Style**.

You can also change the appearance of the blocks by choosing **FRED > Options > Block Style**.

For information on modifying appearance settings, see [Diagram Skins and Appearance Settings](http://blocksim.reliasoft.com).
Chapter 15: Failure Modes and Reliability Analysis (FMRA)

The Failure Modes and Reliability Analysis (FMRA) feature is available in both Xfmea/RCM++/RBI and BlockSim.

In Xfmea/RCM++/RBI, the FMRA displays all of the system hierarchy and FMEA records from the current project that could have an impact on system reliability/maintainability/criticality calculations (which may include items, functions, failures and causes). If you define the necessary properties for these records (reliability policy, operating time, etc.), you can use the FMRA to calculate or simulate a variety of results based on the assumption of a reliability-wise series configuration.

For more advanced analyses — including the ability to change the reliability-wise configuration — you can synchronize the FMRA you built in Xfmea/RCM++/RBI with reliability block diagrams in BlockSim.

Enabling and Viewing the FMRA

In both Xfmea/RCM++/RBI and BlockSim, you can use the Show FMRA command in the View tab of the ribbon to enable or disable the feature for your computer. (You can set this separately for each application.)

To view the FMRA once it is enabled:

- In Xfmea/RCM++/RBI, go to the FMRA tab in the System panel.
- In BlockSim, go to the FMRA tab of the current project explorer.
Chapter 15: Failure Modes and Reliability Analysis (FMRA)

Note: In BlockSim, you can view the FMRA only when you have a single project open.

**FMRA Columns**

To hide or display columns in the FMRA, or change the column order, right-click the column headings and choose **Customize Columns**. (You can also change the column order by dragging and dropping column headings into the desired positions.) These preferences are set separately for each application, and they are stored per computer/username.

- **Name** displays the record description/name. This column cannot be hidden.
- **User Access** displays a status indicator when the record is in use (leanor), when you don't have permission to edit (leton) or when the record is locked by an FMEA change log (demon).
- **Record Type** indicates whether the record is an item from the system hierarchy, or a function, failure or cause from an FMEA.
• **Synchronized** with BlockSim displays if the record is being synchronized with an FMRA diagram in BlockSim. (See [FMRA Diagrams and Reliability-Wise Configurations](#).)

• **Reliability Policy** displays one of the following. (See [Setting the Reliability Policies](#).)
  
  • **Inherit** indicates that the record's reliability/maintainability will be determined by its dependent records.
  
  • **Default (Not Set)** indicates that the record is set to "Define at this level" but does not yet have an assigned URD. The software will assume that the reliability is 100%.
  
  • The name of the **universal reliability definition (URD)** that is assigned to the record.

• **Mirror Group** displays the name of the mirror group that a cause belongs to, if any. All the causes in a mirror group are treated as the exact same event. (See [Using Mirror Groups in an FMRA](#).)

The remaining columns pertain to FMRA results, which are discussed in [Analytical Results in an FMRA](#) and [Simulation Results in an FMRA](#).

### Building the FMRA Hierarchy

The FMRA hierarchy will automatically display any records from the Xfmea/RCM++/RBI system hierarchy and FMEA that are relevant to the reliability/maintainability/criticality calculations. This may include items, functions, failures and causes.

You also have the option to add records directly within the FMRA hierarchy in either Xfmea/RCM++/RBI or BlockSim. Any records that you add in this manner will also appear in the system hierarchy or FMEA.

### Adding New Records

The options for adding new records will depend on the record that is currently selected and the reliability policies. If a record's **reliability policy** is set to "Define at this level," you will not be able to add new dependents via the FMRA because those records would be irrelevant to the reliability/maintainability/criticality calculations.
Chapter 15: Failure Modes and Reliability Analysis (FMRA)

The following commands may be available in the FMRA tab of the ribbon, and when you right-click inside the FMRA hierarchy.

- **Add System** adds a new top-level system hierarchy item.
- **Add Next Level Item** adds a new system hierarchy item below the one that is currently selected.
- **Add Same Level Item** adds a new system hierarchy item in the same level as the one that is currently selected.
- **Add Function** adds a new function to the FMEA. If an FMEA does not already exist for this item, it will be created automatically.
- **Add Failure** adds a new failure to the FMEA.
- **Add Cause** adds a new cause to the FMEA. If the FMEA does not already include an effect to add the cause to, one will be created automatically.

**Note:** The FMRA always adds causes under the last effect in the FMEA hierarchy. If you want to add causes under different effects, you must add them directly in the FMEA.

### Deleting Records

To delete a record, select it in the hierarchy and press **DELETE** (or choose **Home > Edit > Delete**). The record will be deleted, along with any dependents. **There is no undo for deleting a record.**

### Using Cut/Copy to Move or Duplicate Records

To move or duplicate records in the FMRA, you can use the same cut/copy and paste commands that are available in the Xfmea/RCM++/RBI system hierarchy and FMEA.

The FMRA does not allow drag/drop, move up/move down or promote/demote.

**Tip:** Remember that after an item has been cut or copied, any edits that are made to the original will also be applied to its copy in the Clipboard. Likewise, if you delete the original, its copy will also be deleted from the Clipboard (and cannot be pasted later).
Setting FMRA Record Properties

Setting the Reliability Policies
The reliability policy determines the reliability/maintainability characteristics for the records in an FMRA.

To view or set the reliability policy in Xfmea/RCM++/RBI, select the record in the system hierarchy or FMRA and go to the Reliability Policy heading in the Properties tab. (Note that the following picture includes the maintainability characteristics that can be defined in RCM++ or RBI. In Xfmea, only the reliability model will be displayed.)

In BlockSim, right-click the record in the FMRA and choose Inherit or Define at This Level. If a record is set to define at this level, you can use the Block Properties window to view or edit the universal reliability definition (URD).

When creating or assigning URDs to records in an FMRA, note that:

- An item's model represents the item's reliability (i.e., the probability that the item will not fail for the specified period of time).
- A function's model represents the probability that the item will fail to perform its intended function within the specified period of time.
- A failure's model represents the probability that the failure will occur within the specified period of time.
- A cause's model represents the probability that the cause will occur within the specified period of time.

Tip: In Xfmea/RCM++/RBI only, you can use the Batch Update Reliability Policy window to change the policy types of multiple records all at once.
Basic Reliability Policy Types
Two basic reliability policy types are available for all FMRA records in both Xfmea/RCM++/RBI and BlockSim:

- **Inherit** indicates that the record will inherit its reliability/maintainability characteristics from the URDs assigned to its dependents. In the following example, System 1 inherits from its two components; while SubSystem 1 inherits from its two causes (URD_1 and URD_2) and SubSystem 2 inherits from its failure (URD_3).

<table>
<thead>
<tr>
<th>Name</th>
<th>Reliability Policy</th>
</tr>
</thead>
<tbody>
<tr>
<td>System 1</td>
<td>Inherit</td>
</tr>
<tr>
<td>SubSystem 1</td>
<td>Inherit</td>
</tr>
<tr>
<td>Function 1</td>
<td>Inherit</td>
</tr>
<tr>
<td>Failure 1.1</td>
<td>Inherit</td>
</tr>
<tr>
<td>Cause 1.1.1</td>
<td>URD_1</td>
</tr>
<tr>
<td>Cause 1.1.2</td>
<td>URD_2</td>
</tr>
<tr>
<td>SubSystem 2</td>
<td>Inherit</td>
</tr>
<tr>
<td>Function 2</td>
<td>Inherit</td>
</tr>
<tr>
<td>Failure 2.1</td>
<td>URD_3</td>
</tr>
</tbody>
</table>

- **Define at this level** allows you to assign a URD directly to the record. The reliability policy will either display the name of the URD or “Default (Not Set)” If the URD is not set, the software assumes the reliability is 100% (i.e., the item never fails, the cause never occurs, etc.).

**Tip:** If you use this option with a record that has dependents, the software will hide those dependents in the FMRA because they will be irrelevant to the FMRA’s calculations.

Only in Xfmea, RCM++ or RBI
In Xfmea, RCM++ and RBI only, you also have the option to set the reliability policies based on the occurrence ratings from risk priority number (RPN) calculations or the failure probability ratings from criticality analysis. (See Using Rating Scales to Set the Reliability Policy.)

When selected, a read-only probability of failure model (i.e., the probability that the cause or failure mode will occur) will be automatically assigned to the record based on the rating assigned in the FMEA.

- **Based on Initial Occurrence** or **Based on Revised Occurrence**: These options are only available for causes, and only when the initial and/or revised occurrence properties are enabled for the project (on the FMEA > RPNs page in the interface style).
• **Based on Failure Probability**: This option is only available for failure records, and only when the failure probability field is enabled for the project (on the FMEA > Criticality page in the interface style).

In RBI only, you can use the model generated in the risk based inspection analysis results:

• **Based on RBI analysis**: This option is only available for RBI components, and only when the option to do so is selected when generating the RBI results. When selected, the model generated by the RBI analysis will be assigned to the component. If you later recalculate the results, this model will change.

### Using Rating Scales to Set the Reliability Policy

In Xfmea, RCM++ and RBI, you have the option to set reliability policies for the FMRA based on the occurrence ratings used in RPN calculations or the failure probability ratings used for qualitative criticality analysis. For example, you might use this feature to:

• Generate a preliminary baseline reliability estimate based on occurrence ratings that have been assigned to cause records in an FMEA, and then update the estimate later when actual data is available. (See [http://www.reliawiki.org/index.php/Using_FMRA_to_Estimate_Baseline_Reliability](http://www.reliawiki.org/index.php/Using_FMRA_to_Estimate_Baseline_Reliability).)

*IMPORTANT*: Results based on occurrence ratings are appropriate only for preliminary estimates; it is highly recommended to carefully consider the assumptions behind these results, and to update the reliability policies when better information becomes available.

• Perform a quantitative criticality analysis based on failure probability ratings that have been assigned to failure records in an FMEA.

### Viewing or Editing the Rating Scale

To use occurrence or failure probability ratings to set the reliability policy in an FMRA, there must be an appropriate quantitative model associated with each qualitative rating in the scale. In a secure database, only users with the "Edit project properties" permission can modify the rating scales in the current project.

To open the Occurrence scale (used in RPN calculations), choose **Project > Management > Configurable Settings > Occurrence**.

To open the Failure Probability scale (used in criticality analysis), choose **Project > Management > Configurable Settings > Failure Probability**.
To configure either type of scale, you must enter the **Occurrence Probability** \((Q)\) for each rating in the scale (this was called “Quantitative Value” in Version 8 and 9). As an example, here’s an excerpt from the “RS DFR Focus” occurrence scale that is installed with the software, where “1 in 1 Million” is 0.000001, and so on.

<table>
<thead>
<tr>
<th>Value</th>
<th>Occurrence Probability</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1E-06</td>
<td>1 in 1 Million</td>
</tr>
<tr>
<td>2</td>
<td>1E-05</td>
<td>1 in 100,000</td>
</tr>
<tr>
<td>3</td>
<td>0.0001</td>
<td>1 in 10,000</td>
</tr>
<tr>
<td>4</td>
<td>0.001</td>
<td>1 in 1,000</td>
</tr>
<tr>
<td>5</td>
<td>0.002</td>
<td>1 in 500</td>
</tr>
</tbody>
</table>

Then specify whether each value will be treated as a fixed probability that does not vary with time, or converted to an exponential distribution.

If you choose to use distributions, the software will treat the value as an unreliability point at the specified time and use this point to solve for the exponential distribution’s parameter (using the same method available in the [Quick Parameter Estimator](http://blocksim.reliasoft.com)).

For example, if the value is 0.01 and the time is 1,000 hours, the model will be an exponential distribution with \(\lambda = 1.01 \times 10^{-5}\) (or Mean Time = 99,499.16 hours if you’ve selected that option in the Application Setup).

**Note:** If you edit these ratings for a standard library via the Profiles/Libraries Manager, the time specified for this option will always be entered in base units. This is because the same standard library might be used by different databases with different time units.

### Using the Rating to Set the Reliability Policy

When users are performing an analysis, they first set the ratings for the cause or failure records. Then, they select the record in the FMRA and choose to set the **Reliability Policy**:

- **Based on Initial Occurrence** or **Based on Revised Occurrence**: These options are only available for causes, and only when the initial and/or revised occurrence properties are enabled for the project (on the FMEA > RPNs page in the interface style).
• **Based on Failure Probability**: This option is only available for failure records, and only when the failure probability field is enabled for the project (on the FMEA > Criticality page in the interface style).

The software assigns a read-only probability of failure model (i.e., the probability that the cause or failure mode will occur) based on the current rating. If you later change the rating for the cause or failure record, the reliability policy model will be updated automatically.

![Reliability Policy Table]

**Batch Update Reliability Policies**

In Xfmea/RCM++/RBI only, the Batch Update Reliability Policy window makes it easy to change the **reliability policy type** for multiple FMRA records at the same time.

To open the window, choose **FMRA > Calculations > Policy Update**.

**Inherit vs. Define**

• If you select **Inherit**, you will need to make sure that dependent records have reliability policies defined.

• If you select **Define at this level**, any records that previously had a different policy will be changed to "Default (Not Set)" status. The software will assume that their reliability is 100% unless/until you assign a URD.

**Sub-items or FMEA**

In Version 11, you can now consider whether the item has sub-items and/or an FMEA. For example:

![Select Records and Set Policy Types]

Define at the component level in the system hierarchy

![Select Records and Set Policy Types]

Inherit from the component FMEA (if applicable) or define at the component level
Chapter 15: Failure Modes and Reliability Analysis (FMRA)

Based on Rating Scale
If you select Based on Failure Probability, Based on Initial Occurrence or Based on Revised Occurrence, the following logic applies. (See Using Rating Scales to Set the Reliability Policy.)

- If there is no URD, the software sets the reliability policy to “based on” even if a rating is not yet defined.
- If there is a URD and a rating has been defined, the software sets the reliability policy to “based on.” This will change the reliability model associated with the URD.
- If there is a URD and the rating has not been defined, the software will not change the reliability policy. The reliability model associated with the URD will remain unchanged.

Using Mirror Groups in an FMRA
In both Xfmea/RCM++/RBI and BlockSim, you can use the Mirrors commands in the FMRA tab of the ribbon to place the exact same cause record in more than one location in the FMRA.

This is useful when you need to consider common cause failures (i.e., single faults that result in the failure of multiple components). Typical examples of common cause failures include impact, vibration, temperature, contaminants, miscalibration, improper maintenance, and so forth.

All cause records in a mirror group (i.e., "mirrored causes") represent the very same cause for the purpose of FMRA calculations/simulations. To accommodate this, the use of mirror groups will change the properties of cause records in the following ways. Note that there is no undo for changed cause properties.

- When a cause is added to a new mirror group or an existing empty group (i.e., one that includes no other causes), that cause’s properties will determine the group’s properties.
Chapter 15: Failure Modes and Reliability Analysis (FMRA)

- When a cause is added to a mirror group that already includes other causes, that cause’s properties (e.g., the short description, reliability policy, etc.) will be changed to match the group’s properties.

- If you change the properties of a mirrored cause, that change will also be applied to all other causes in the same mirror group.

Also note that, because mirror groups are Synthesis resources, clearing or removing the causes will not delete the mirror group resource from the project. To delete a resource, use the Resource Manager.

Setting the Operation Properties for an FMRA

Before you perform analytical calculations or simulations in the FMRA, make sure you at least specify the operating time for the top-level item. If applicable, you can also specify other operation properties at the individual item level.

These properties are located under the Operation heading when you select an item in the FMRA in Xfmea/RCM++/RBI.

- **Operating Time**: The amount of time for which the system is expected to operate (and the time for which the results are estimated). This can be modified at the system level only. When you perform a simulation-based calculation, you can also edit this value in the simulation settings window.

- **Current Age**: The age of the item at the start of the analysis. It allows you to define items that have already accumulated age prior to the start of the current mission (i.e., used components).

- **Qty**: The number of identical sub-items represented. New in Version 11, this property allows you to represent multiple copies of the same item with the same properties without having to create individual items (e.g., the 4 tires on a car). A value greater than 1 in this field will cause the item to be represented in the FMRA Diagram as a multi block. By default, the multi block will be configured so that the items are connected in series, but you can manually change this to a parallel configuration. (For more information on multi blocks, see Standard Blocks and Basic Configuration in the BlockSim/RENO documentation.) This value is taken into account at all levels for FMRA calculations performed in Xfmea/RCM++/RBI; it does not apply at the system level in FMRA calculations in BlockSim.
**Duty Cycle:** Allows you to model situations where the actual usage during system operation is not identical to the usage for which you have data (either from testing or from the field). This can include situations where the item:

- Does not operate continuously (e.g., a DVD drive that was tested in continuous operation, but in actual use within a computer accumulates only 18 minutes of usage for every hour the computer operates).
- Is subjected to loads that are greater than or less than the rated loads (e.g., a motor that is rated to operate at 1,000 rpm but is being used at 800 rpm).
- Is affected by changes in environmental stress (e.g., a laptop computer that is typically used indoors at room temperature, but is being used outdoors in tropical conditions).

In these cases, continuous operation at the rated load is considered to be a duty cycle of 1. Any other level of usage is expressed as a percentage of the rated load value or operating time. For example, consider the DVD drive mentioned above; its duty cycle value would be 18 min / 60 min = 0.3. A duty cycle value higher than 1 indicates a load in excess of the rated value.

If a duty cycle is specified for a subsystem or item, it specifies the percentage of operation as relates to the parent item. That is, the effects of the duty cycle for a parent item and the duty cycle for a sub-item are compounded. For instance, if a system has a duty cycle of 2 and its subsystem has a duty cycle of 0.3, the effective duty cycle for the subsystem would be 2 x 0.3 = 0.6, or about 2/3 the rated load value or operating time.


**Maintenance Group:** Allows you to model situations in which some event within the group can trigger maintenance for other item(s). This field is applicable only for FMRA simulations in RCM++/RBI, and it considers system hierarchy items only.

*Note:* Maintenance groups defined for top-level systems in RCM++/RBI will not transfer to FMRA diagrams in BlockSim if you use FMRA synchronization. Similarly, maintenance groups defined for FMEA records in BlockSim's diagrams will not transfer to RCM++/RBI. This is because the applications use different structures to represent the FMRA hierarchy.
Allocate Target Reliability and Availability

In Xfmea/RCM++/RBI, the **Reliability/Availability** fields in the Properties tab of the Analysis Panel allow you to enter the target reliability and availability that you hope to achieve, and compare them to the current estimates from the **Failure Modes and Reliability Analysis (FMRA)**.

You can set the targets for a system or assembly and then use the FMRA to automatically allocate the targets for sub-items (and also failures/effects/causes if the item's reliability policy is set to "inherit" from the FMEA).

This feature uses an "equal allocation" approach that distributes the reliability/availability uniformly so the target defined for system/assembly will be met. It assumes a reliability-wise series configuration.

<table>
<thead>
<tr>
<th>Name</th>
<th>Reliability Policy</th>
<th>Target Reliability</th>
</tr>
</thead>
<tbody>
<tr>
<td>System 1</td>
<td>Inherit</td>
<td>0.900000</td>
</tr>
<tr>
<td>SubSystem 1</td>
<td>SubSystem 1 URD</td>
<td>0.965489</td>
</tr>
<tr>
<td>SubSystem 2</td>
<td>SubSystem 2 URD</td>
<td>0.965489</td>
</tr>
<tr>
<td>SubSystem 3</td>
<td>SubSystem 3 URD</td>
<td>0.965489</td>
</tr>
</tbody>
</table>

To perform the allocation:

1. Go to the FMRA tab in the system panel. (See [Enabling and Viewing the FMRA](#).)

2. Select a system or assembly in the hierarchy and enter the target reliability/availability in the Properties tab.

3. Choose **FMRA > Allocation > [Allocate Target Reliability] or [Allocate Target Availability]**.
Highlights Based on Target Reliability/Availability

The FMRA in Xfmea/RCM++/RBI applies automatic color-coding in the Properties tab of the Analysis Panel to highlight situations when the expected reliability/availability does not meet the specified targets. The highlights can be applied to the calculated/simulated values, and also to the cause occurrence ratings if applicable.

Highlighting the Calculated/Simulated Values

For all records in the FMRA, if the calculated/simulated current value is less than the target value, the field will be highlighted in red.

For example, in the following picture, the Current Reliability calculated via the FMRA (.816780) is highlighted because it is less than the target (.95).

The Current Availability simulated via the FMRA (.971283) is not highlighted because it exceeds the target (.95).

Highlighting the Occurrence Ratings

Highlight colors will also be applied when you have selected a cause record in the FMRA. If the quantitative value associated with the occurrence rating meets the target, the field will be highlighted in green. If not, it will be highlighted in red.

For example, in the following picture, the quantitative probability of failure associated with an Initial Occurrence rating of 8 (Q = .1) is highlighted in red because it does not meet the target reliability of .95.

The probability of failure associated with a Revised Occurrence rating of 6 (Q = .01) is highlighted in green because it exceeds the target.
FMRA Diagrams and Reliability-Wise Configurations

By default, the records in an FMRA are assumed to have a reliability-wise series configuration. In other words, if any failure mode occurs or any component fails, then the entire system fails. However, you can use BlockSim's FMRA diagrams to represent more complex configurations.

To do this, choose FMRA > Refresh > Synchronize FMRA to refresh the FMRA and create the associated diagrams and blocks.

Note the following about FMRA synchronization:

- Changes that are made in BlockSim are synchronized and propagated to Xfmea/RCM++/RBI automatically, although you may need to refresh the view to see them (View > Refresh).

- When records are added to the current FMRA in Xfmea/RCM++/RBI, they will not be displayed in BlockSim's FMRA hierarchy until you synchronize the FMRA (FMRA > Refresh > Synchronize FMRA). This will refresh the FMRA hierarchy and create the associated diagrams and blocks. Depending on the changes that were made in Xfmea/RCM++/RBI, this may affect your FMRA diagrams.

- If you no longer wish to synchronize the FMRA with BlockSim diagrams, you can choose View > FMRA > Disassociate FMRA to delete all of the FMRA diagrams and close the FMRA view. You can resynchronize at any time.

Working with FMRA Diagrams

It is important to note that the diagrams that you work with from within the FMRA are distinct from the other diagrams in BlockSim’s current project explorer. FMRA diagrams relate to the analysis being performed in the project using Xfmea/RCM++/RBI. They are accessible only via the FMRA view, while all other diagrams are accessible only from the Standard tab of BlockSim’s current project explorer.

Each record in the FMRA hierarchy represents a reliability block diagram, with the exception of the lowest-level record in each branch, which represents a block in the parent diagram. The levels of the hierarchy are expressed using subdiagrams. For example, consider the FMRA hierarchy shown next.
Now, let’s look at the branch of the FMRA that begins with SubSystem 1. The associated FMRA diagrams are:

As you can see, the causes are assumed to be in a series configuration, as is the case with all reliability-wise configurations built in Xfmea/RCM++/RBI. Working with the FMRA in BlockSim
allows you to change the reliability-wise configuration. For instance, let's imagine that the causes are actually in a parallel configuration—in other words, the item will not fail if only Cause 1.1.1 happens OR only Cause 1.1.2 occurs, but the item will fail if both occur. To represent this, you would change the Failure 1.1 diagram as follows (with the first node acting as a starter block):

![Failure 1.1 Diagram](image)

**Analytical and Simulation FMRA Diagrams**

By default, the FMRA diagrams are created as *analytical diagrams* (which use the exact algebraic equation for the model but impose limitations on what can be modeled and what results can be obtained). You can choose **FMRA > Inheritance > Toggle Diagram Type** to change them to *simulation diagrams* (which provide more modeling options and results but must be analyzed with discrete event simulation; repairable systems must be represented using simulation diagrams), or to change simulation diagrams to analytical ones. This command changes all of the FMRA diagrams in the project; you cannot have both analytical and simulation FMRA diagrams in the same project.

Like any other RBD, the diagram type affects the available functionality, both in terms of configuration and results. For instance, maintenance groups can be assigned only in simulation RBDs. You can analyze or simulate an FMRA diagram just as you would any other RBD, and can generate plots and QCP results for each diagram. You also can perform analytical calculations or simulation at the FMRA level.

**FMRA Calculations**
Chapter 15: Failure Modes and Reliability Analysis (FMRA)

Analytical Results in an FMRA
The analytical results in the FMRA may include reliability or probability of failure (which are available in both Xfmea/RCM++/RBI and BlockSim), and criticality (which is available only in Xfmea/RCM++/RBI).

To perform analytical calculations, choose FMRA > Calculations > Calculate (Reliability).

In Xfmea/RCM++/RBI, if there are multiple systems (top-level items) or if the FMRA is synchronized with BlockSim, you will be prompted to specify a) which systems to calculate and/or b) whether to consider a more complex reliability-wise configuration that may have been modeled in the BlockSim diagrams. (See Calculation Options Window.)

In BlockSim, these calculations are available when you are using analytical FMRA diagrams. If there is only one system in the FMRA, this will calculate results for the entire FMRA. If there are multiple systems, you will be asked to choose whether you want to calculate the entire system hierarchy or just the currently selected system and its dependents.

Reliability and Probability of Failure
You can display the following FMRA columns in both Xfmea/RCM++/RBI and BlockSim:

- **Analytical Results Status** displays a green indicator light if the analytical results are based on the current inputs. It displays a red light if they are not.

- **Reliability (Analytical)** displays the record's calculated reliability at the system's specified operating time. In Xfmea/RCM++/RBI, the reliability for each item will also be displayed in the **Current Reliability** field of the Properties tab when the item is selected. This value will be highlighted in red if it is below the specified target reliability.

- **Probability of Failure (Analytical)** displays the record's probability of failure at the system's specified operating time. This is the complement of reliability (1-R).

Criticality Analysis
In Xfmea/RCM++/RBI only, you can also display the following FMRA columns for quantitative criticality analysis:

- **Mode Ratio** displays the probability that the item failure will be due to the failure mode under consideration.

- **Prob of Loss** displays a factor from 0 to 1 that describes the probability that this failure mode would result in a system failure. By default, this is set to 1 (Actual Loss).

- **Criticality** displays the calculated criticality value. This column must be displayed when the mode ratio or probability of loss is displayed.
Calculation Options Window (Xfmea/RCM++/RBI)
In Xfmea/RCM++/RBI only, the Calculation Options window lets you choose which system(s) in the failure modes and reliability analysis (FMRA) will be calculated and which application will be used to perform the calculations.

If the FMRA has multiple systems, or if it has records synchronized with BlockSim, this window will appear when you calculate the FMRA.

In the What items do you want to calculate? area, you can choose to perform calculations only for the system that is currently selected, or for all the systems in the hierarchy.

In the Calculation Method area:

- The Calculate using BlockSim option is available only when there are records in the FMRA that are currently synchronized with BlockSim. If you calculate using this option, the software synchronizes all records and then returns results based on the reliability-wise configuration of the synchronized RBDs in BlockSim.

- The Calculate using current application option is always available. If you calculate using this option, the software will assume a reliability-wise series configuration among all the records in the FMRA.

Simulation Results in an FMRA
The simulation results in an FMRA consider both reliability and maintainability characteristics in order to estimate availability, operating costs, and other useful metrics about the operation of a repairable system over time. They are available in RCM++/RBI and BlockSim.

Tip: When you perform FMRA simulations in RCM++/RBI, the software always assumes a reliability-wise series configuration. If you modified the configuration using BlockSim, then you must perform the simulation within BlockSim in order to take the new configuration into account.

To perform an FMRA simulation in RCM++/RBI, choose FMRA > Calculations > Simulate (Availability).

A window will open where you can change the simulation settings. Click OK to perform the simulation.
In BlockSim, you can use the simulation batch mode to get simulation results. To do this, change the diagrams to simulation diagrams and choose FMRA > Calculations > Simulate (Availability). Then click Run to perform the simulation.

A Note about Simulation with Constant Models
Note that it is not possible to simulate failure times if the reliability policy is defined with a constant value (rather than a distribution that varies with time). Thus, the costs estimated from the simulation will always be zero for any record with a constant reliability model. In such cases, you may wish to change the affected reliability policies to time-dependent distributions before simulating again.

Simulation Results
• Simulation Results Status displays a green light if the simulation results are based on the current inputs. It displays a red light if they are not.
• Operating Cost displays the total costs that accrued during the simulation. Note that this will always be zero if the reliability is defined by a constant value (rather than a time-dependent distribution).
• Cost per Operating Time displays the operating cost divided by the total operating time.
• Availability displays the average availability (i.e., uptime divided by total operating time). This is a metric that reflects the probability that the item is operational (not failed or undergoing repair) when it is requested for use during the simulation.
• RS FCI (ReliaSoft Failure Criticality Index) is a relative index showing the percentage of times a failure of the component caused a system failure (i.e., the number of system failures caused by the component divided by the total number of system failures). Note that this relates only to failures; it does not include every event that could bring the system down (such as routine maintenance).
• RS DECI (ReliaSoft Downing Event Criticality Index) is a relative index showing the percentage of times that a downing event of the component caused the system to go down (i.e., the number of system downing events caused by the component divided by the total number of system downing events). Note that this only relates to downing events with a non-zero duration.
• RS DTCI (ReliaSoft Downtime Criticality Index) is a relative index showing the contribution of each component’s downtime to the system’s downtime (i.e., the system downtime caused by the component divided by the total system downtime).
Chapter 16: Simulation Worksheets

Simulation worksheets allow you to vary values that are used when simulating a BlockSim RBD or a RENO flowchart. This allows you to investigate the effect of one or more settings on the simulation results.

Simulation worksheets consist of columns that can be defined as inputs or outputs. The input values are used during simulation, and they can be entered manually or transferred from a DOE experiment design. Values in output columns are determined through simulation. For example, you might design an experiment in a Weibull++/ALTA design folio and transfer all the factor level combinations to the simulation worksheet. Then you could simulate the experiment in BlockSim and transfer the output values back to the Weibull++/ALTA design folio to analyze the results. If, on the other hand, you do not want to test all combinations of all factor settings, you can enter the desired combinations of settings by hand.

In general, using a simulation worksheet will include the following steps:

- **Create the Variables and the Diagram in BlockSim/RENO**
- **Define the Factor Settings**
- **Define the Simulation Worksheet Columns in BlockSim/RENO**
- **Simulate the Worksheet in BlockSim/RENO**
- **Analyze the Results in Weibull++/ALTA**
- **Verify the Results in BlockSim/RENO**

Depending on what you are trying to achieve, some of the steps may not be necessary.

In this topic, we will consider an example in which we explore options for maintaining a spare part pool, with a goal of maximizing system availability while minimizing the cost of the pool. The factors that we will vary are the number of spare parts initially in the pool, the frequency with which the pool is restocked and the number of parts added to the pool at each restock.

Create the Variables and the Diagram in BlockSim/RENO

Build the diagram for the system in BlockSim/RENO. Use variables to represent the factors whose settings you want to investigate. Depending on the factors you are studying, you might use the variables directly (as field inputs for BlockSim blocks and resources, or in equations and functions in RENO) or via a dynamic model. In BlockSim diagrams, the following fields can be defined using a variable:
In standard blocks:
  - Current age
  - Duty cycle
  - Throughput

In contained standby blocks and contained load sharing blocks:
  - Duty cycle

In subdiagram blocks:
  - Duty cycle

In crews:
  - Number of tasks (visible when there is a limit to the number of tasks the crew can perform at the same time)

In spare part pools:
  - Initial stock level
  - Capacity if Pool has maximum capacity is selected
  - For scheduled restocks:
    - Restock every
    - Number added per restock
  - For restocking as needed:
    - Restock when stock drops to
    - Number added per restock
  - For emergency spare provisions:
    - Number added per emergency

In scheduled tasks performed at fixed or dynamic intervals:
  - Interval value

Any field that takes a model can use a dynamic model; it is up to you to decide if exploring various values for that field will yield useful results.
**IMPORTANT**: In RENO flowcharts, you will need to store the results of interest in variables. The **When to Reset** field for output variables must be set to **Never Reset** in order for the results to be available to the simulation worksheet. This ensures that the results are available to the simulation worksheet, rather than the variables being reset to their initial values.

**Example**

The spare part pool that is used by the tasks in our example is configured as shown next. The cost per item is specified as a constant model equal to $10 and the holding cost is specified as a constant model equal to $10 per month. Since the factors of interest (i.e., the initial stock level, the frequency of restocking and the number added per restock) will not be held constant, they are assigned to variables. These variables represent factor values that will be specified in the simulation worksheet.
Define the Factor Settings

For the factors of interest, you will decide on the settings to be used in simulation and the combinations of factor settings that should be tried (i.e., that will be used as inputs to the simulation).

- One way to do this is to build an experiment design in a Weibull++/ALTA design folio and then transfer the factor settings to a new simulation worksheet. After creating the DOE in Weibull++/ALTA, choose Data > Simulation Worksheets > Transfer to Simulation Worksheet.

http://blocksim.reliasoft.com
This will ensure that the factor settings are tested in combinations appropriate to
determine the effects of each factor and of factorial interactions.

- In some situations, not all factor setting combinations may be possible. For instance,
  let’s say that you are considering two versions of a part, one that costs $100 and has a
  reliability of 0.97 at 1,000 hours and another that costs $85 and has a reliability of 0.92
  at 1,000 hours. You can vary the cost of replacement and the block reliability to account
  for these scenarios. You would not, however, want to run a simulation using a cost of
  $85 and a reliability of 0.97, since that combination does not reflect an available part. In
  cases like this, you can add a new simulation worksheet to the project by choosing
  Insert > Simulation Worksheets > Add Simulation Worksheet.

After adding the new worksheet, you can enter the desired factor values manually, as
shown next. (Note that the column names were changed by right-clicking the column
header and choosing Rename Column on the shortcut menu.)

<table>
<thead>
<tr>
<th></th>
<th>Replacement Cost</th>
<th>Reliability at 1,000 Hours</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>100</td>
<td>0.97</td>
</tr>
<tr>
<td>2</td>
<td>85</td>
<td>0.92</td>
</tr>
</tbody>
</table>

While you have the simulation worksheet open, it will be read-only in other applications. For
instance, if you create the simulation worksheet in Weibull++/ALTA, it will be read-only in
BlockSim and RENO until you do one of the following:

- Close the simulation worksheet, or
- Click Commit and Lock on the control panel. This will commit the data in the simulation
  worksheet to the database and lock the simulation worksheet within the current
  application so that it will be available within other applications.

In either case, if you already have the simulation worksheet open in a read-only state, you will
need to click Unlock and Edit on the control panel once you have released the lock in the
original application.

Example
The experiment used in our example is a general full factorial design using the following
settings:
The first fifteen rows of the simulation worksheet that is created in the transfer process are shown next.

<table>
<thead>
<tr>
<th>Initial Stock Level</th>
<th>Restock Time</th>
<th>Number Added per Restock</th>
<th>System Availability</th>
<th>Pool Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>500</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>500</td>
<td>3</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>2000</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>2000</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>5</td>
<td>1000</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>1</td>
<td>2000</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>1</td>
<td>1000</td>
<td>5</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>5</td>
<td>2000</td>
<td>3</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>4</td>
<td>500</td>
<td>3</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>3</td>
<td>500</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>1</td>
<td>500</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>5</td>
<td>2000</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>4</td>
<td>500</td>
<td>5</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>4</td>
<td>2000</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>5</td>
<td>500</td>
<td>3</td>
<td></td>
</tr>
</tbody>
</table>

*Note: Complete data set is not shown.*

**Define the Simulation Worksheet Columns in BlockSim/RENO**

Once the factor settings have been entered in the simulation worksheet, you will simulate the worksheet in BlockSim/RENO. The software will perform a set of simulations for each combination of factor settings in order to obtain response values. In BlockSim/RENO, open the simulation worksheet and click the **Simulate** icon on the control panel.
The Select Diagram window will appear, allowing you to select the diagram that will be used to simulate the response values (i.e., the data source) for the simulation worksheet.

**Note:** You can also click the **Associated Data Sources** icon to specify or change the source diagram.

The Worksheet Simulation window then appears, allowing you to specify the information contained in each column of the simulation worksheet.

- In the **Source of Variable Inputs** area, assign the variables representing the factors of interest to the appropriate input columns in the worksheet. Available variables will be shown in the drop-down list for each column. If a factor of interest is represented by a dynamic model, choose the variable upon which the dynamic model is based.

**What's Changed?** Starting in Version 11, you can choose to assign the simulation end time to one of the input columns. This allows you to obtain results as a function of time.

- In the **Simulation Output** area, for each result column, specify the result to be entered:
  
  - If the associated diagram is a BlockSim simulation RBD, define the function to calculate from each simulation. This is done by clicking the cell associated with the result column to open a limited version of the Function Wizard, where only the simulation functions are available.
  
  - If the associated diagram is a RENO flowchart, select the variable to read for the result.

**Example**

The Worksheet Simulation window used in our example is shown next.
The output columns were specified as follows:
Chapter 16: Simulation Worksheets

Select Simulation Function

[Options for Select Simulation Function]

Select Result Type

[Options for Select Result Type with 'Mean Availability' highlighted]
Simulate the Worksheet in BlockSim/RENO

With all columns defined, you can perform the simulation in BlockSim/RENO.

- Click the **Edit Simulation Settings** button to open the Batch Mode Simulation Settings window. This is an abbreviated version of BlockSim's **Maintainability/Availability Simulation window** or of the **RENO simulation window**, depending on whether the associated diagram is a simulation RBD or a RENO flowchart. The settings that you specify will apply to the simulation performed for each row (i.e., each factor setting combination). Specify the desired simulation settings and click **OK** to return to the Worksheet Simulation window.

- Click **Run** to perform the simulations. The results will be entered in the simulation worksheet.

- Commit and lock the simulation worksheet to make it available for analysis in Weibull++/ALTA.
Example
The simulation settings used in our example are shown next.

The first fifteen rows of the simulation worksheet, with results, are shown next.

<table>
<thead>
<tr>
<th>Initial Stock Level</th>
<th>Restock Time</th>
<th>Number Added per Restock</th>
<th>System Availability</th>
<th>Pool Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>500</td>
<td>4</td>
<td>0.9023542272, 1380.75053</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>500</td>
<td>3</td>
<td>0.9030720215, 1363.074631</td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>2000</td>
<td>1</td>
<td>0.2684987514, 159.8430884</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>2000</td>
<td>4</td>
<td>0.5268783099, 284.789089</td>
</tr>
<tr>
<td>5</td>
<td>5</td>
<td>1000</td>
<td>2</td>
<td>0.6754819262, 408.3385279</td>
</tr>
<tr>
<td>6</td>
<td>1</td>
<td>1000</td>
<td>1</td>
<td>0.2101938712, 76.59627093</td>
</tr>
<tr>
<td>7</td>
<td>1</td>
<td>2000</td>
<td>5</td>
<td>0.8930326011, 115.376282</td>
</tr>
<tr>
<td>8</td>
<td>5</td>
<td>2000</td>
<td>3</td>
<td>0.5256116136, 336.6203036</td>
</tr>
<tr>
<td>9</td>
<td>4</td>
<td>500</td>
<td>3</td>
<td>0.9031430308, 1418.818016</td>
</tr>
<tr>
<td>10</td>
<td>3</td>
<td>500</td>
<td>1</td>
<td>0.6515371131, 307.0716965</td>
</tr>
<tr>
<td>11</td>
<td>1</td>
<td>500</td>
<td>1</td>
<td>0.6024989174, 223.760133</td>
</tr>
<tr>
<td>12</td>
<td>5</td>
<td>2000</td>
<td>4</td>
<td>0.6245792068, 408.2404636</td>
</tr>
<tr>
<td>13</td>
<td>4</td>
<td>500</td>
<td>5</td>
<td>0.9031430388, 1449.721292</td>
</tr>
<tr>
<td>14</td>
<td>4</td>
<td>2000</td>
<td>2</td>
<td>0.497140000, 1331.541228</td>
</tr>
<tr>
<td>15</td>
<td>5</td>
<td>500</td>
<td>3</td>
<td>0.9031430308, 1418.818016</td>
</tr>
</tbody>
</table>

Note: Complete data set is not shown.
Chapter 16: Simulation Worksheets

Analyze the Results in Weibull++/ALTA

The results that were derived from the simulation can now be analyzed. To do this:

- Open the simulation worksheet in Weibull++/ALTA. (If it was already open, click the Refresh icon on the control panel to load the results and unlock the simulation worksheet for use in Weibull++/ALTA.)

- Transfer the results to a design folio for analysis. You can do either of the following:
  
  - **Transfer to Standard Design Folio** transfers the defined input and output columns to the factor and response columns in an existing standard design folio.

    In the window that appears, select the design folio to transfer to and match up the columns in the design folio (factor/response columns) with the columns in the simulation worksheet (input/output columns), as shown next.

    ![Transfer to Standard Design Folio](image)

    Note that all data will be transferred from the simulation worksheet, so if you have made changes to the input/factor columns in the simulation worksheet, those changes will be transferred to the design folio.

  
  - **Transfer to Free Form Folio** transfers the defined input and results columns to a new free form folio.
You can then perform any analysis you choose in Weibull++/ALTA, including optimization.

**Example**

The results of optimization for our example are shown next. A single optimal solution is found with Initial Stock Level = 1, Restock Time = 975.1698 and Number Added per Restock = 5. This gives a system availability of .9048 and pool cost of 1183.30.

**Verify the Results in BlockSim/RENO**

Because BlockSim/RENO and Weibull++/ALTA rely on different methodologies to arrive at results, predictions made by Weibull++/ALTA will vary from the simulated results generated by BlockSim/RENO. Therefore, the optimal settings selected by Weibull++/ALTA must be simulated in BlockSim/RENO to ensure that the predicted results are reliable. To do this, return to BlockSim/RENO and, for each of the variables, set its initial value to the value given in the
optimal solution and then simulate the diagram directly (i.e., not via the simulation worksheet) to make sure that the results are close to those estimated in Weibull++/ALTA.

Example
The simulation results from BlockSim are shown next. The results show a mean system availability of 0.8924 and a total cost for the pool of $1162.55. These values are very close to the estimated values in Weibull++/ALTA.
Chapter 17: BlockSim and RENO Settings

The Application Setup contains personal preferences that are stored per computer/username. These include default settings for new analyses/plots that you create from this computer, as well as personal preferences that don’t affect shared analysis data stored in the database.

In addition, note that the region and language settings will determine how dates, times, decimals, currency, etc. are displayed on your computer.

To open the Application Setup window, choose File > Application Setup.

The settings on the pages listed under Synthesis Settings are the same for all Synthesis desktop applications; the pages listed under the application name contain settings that apply only to the current applications.

Synthesis Settings

Synthesis Settings

The Synthesis Settings page of the Application Setup can be changed from within any Synthesis desktop application.

- **Interface** sets the language and the skin (color scheme) for the software interface. Selecting a skin shows you a preview of the changes in the Application Setup window. The change takes effect in the rest of the interface the next time you launch each application.

  Note that a language change will not affect applications that are currently available only in English. For a list of supported languages, see http://www.reliasoft.com/languages/index.htm.

- **Open With** sets the Synthesis application to launch by default when you double-click an *.rsr11, *.rsf11 or *.rserp file from this computer. If you want to be prompted to choose an application each time, select Show the Synthesis Launcher.

- **Recent Repositories List** sets the maximum number of recently saved database files to be displayed in the "Recent Repositories" list in the Backstage view.
- **Auto Save** specifies when folios and diagrams will be saved automatically. The application always saves folios/diagrams upon calculate or close. If you want to also save periodically while you're editing, specify an interval. This can be useful if you're working across a network in an enterprise database. (This setting does not apply to Synthesis files.)

- **Other**

  - **Allow multiple projects (project explorer)** applies to Synthesis desktop applications that use the current project explorer (i.e., Weibull++, ALTA, BlockSim, RENO, RGA, and Lambda Predict). Select the check box if you want to have multiple projects open at the same time. There is a separate setting for project windows in Xfmea/RCM++/RBI. (See Working with Multiple Projects.)

  - **Show project name in opened folios** applies to Synthesis desktop applications that use the current project explorer (i.e., Weibull++, ALTA, BlockSim, RENO, RGA, and Lambda Predict). It shows the project name in [brackets] on the tab or window caption. This may be useful when you have multiple projects open at the same time.

  - **Use web-based help**. Select the check box to always make F1 and other help commands open the most up-to-date help file from the Internet when possible. If you clear this check box, they open the local help file that was installed with the software.

  - **Display ReliaSoft Online pane** shows the ReliaSoft Online pane in the Backstage view. If you do not have Internet connection or you simply want to reclaim the space allocated to these features, you can clear the check box to hide these panels.

  - **Highlight 'Active' category in ribbon** applies a highlight color to the label that shows which tabs are currently active.

  - **Use non-modal Resource Manager** locks the Resource Manager in a top window position so it can remain open while you have access to the project. If not selected, you must close the Resource Manager to return to the project.

  - **Warn when changing metric associations** shows a warning when you select an existing metric in a situation that will change the metric’s associated model. (See Showing Metrics in Folios/Diagrams.)

  - **Hide unused project folders** applies to Synthesis desktop applications that use the current project explorer (i.e., Weibull++, ALTA, BlockSim, RENO, RGA, and Lambda Predict). It hides from view all folders that do not contain any project items.
• **Highlight colors** sets the colors used to color-code values in the following analyses:
  - Results in the FMRA in BlockSim and Xfmea/RCM++/RBI
  - Certain BlockSim plots
  - BlockSim FRED reports
  - BlockSim allocation analysis
  - Spread of failure rate contributions in a prediction folio in Lambda Predict.

**Backup/Check Out Options**

The Backup/Check Out Options page of the Application Setup can be changed from within any Synthesis desktop application.

  - **Standard Repository Maintenance** applies to standard database files (*.rsr11) only. It allows you to automatically save a backup of a database in the location you specify when you close the application. The backup file will be named after the database file with the backup date appended (e.g., RSRepository1_2016-01-15.rsr11).

You can specify how many days of backups can be automatically saved (up to 10), but note that only one backup will be saved per day (e.g., if you open and close the same database three times in one day, only the final closing of the database will be saved in the backup folder).

Note that you can also create backups manually at any time by choosing **File > Save As**. For more tips on keeping databases running smoothly, see [Backups and Database Maintenance: Protecting Your Data](#).

  - **Check In/Out** specifies the default save location for projects that you check out from a database.

**Other Synthesis Settings**

The Synthesis Settings > Other page of the Application Setup can be changed from within any Synthesis desktop application.

  - **Model, Variable and Workbook Names** disallows spaces and special characters in the names of models (including those published from any Synthesis desktop application) and variables, and in the names of workbooks created in BlockSim/RENO. This will ensure that all models, variables and workbooks can be used in RENO equations.
• **Display Object IDs.** Select the check box to always display the unique object identifier (object ID) of each project and resource in the repository. The project IDs will be displayed in the Manage Projects window and in the Edit Project Properties window, while the resource IDs will be displayed in the Resource Manager.

• **Copy Plot Graphic** sets the default file type to use when copying a plot to the Clipboard as an image. If you will be pasting copied plots into Synthesis Workbooks, choose **Metafile for Synthesis Use.** If you will be pasting them into external applications, choose **Bitmap** or **Metafile for External Use.**

• This default setting is used when you copy a plot using **Home > Copy** or **CTRL+C.** If you want to choose the graphic on the spot, you can do so by right-clicking the plot and choosing the **Copy Plot Graphic** command on the shortcut menu.

• **Hierarchical Trees** sets the maximum number of lines for displaying names and descriptions in any of the hierarchical tree interfaces used in Xfmea, RCM++, RBI, Lambda Predict and MPC.

• **Alternative Credentials** applies to secure databases. It allows you to either save your alternative credentials (so your account is automatically logged in whenever you open a secure database from a different domain) or clear the credentials from this computer.

• **Diagram Skins Utility** converts diagram skins created in Synthesis Version 9 to the latest version. Click the **Convert** link, and in the window that opens, select the name of the skin(s) that you wish to convert. You will need to close and re-launch the application to use the converted skin(s). (See "Converting Version 9 Skins" in the BlockSim, Weibull++/ALTA or Xfmea/RCM++/RBI documentation.)

## Application-Specific Settings

### Calculations Settings

The Calculations page of BlockSim/RENO's Application Setup contains default settings that will be applied to calculated results when you create a new diagram or analysis in BlockSim or RENO. Note that some of the configurable settings that are saved with the diagram/analysis can still be modified from the control panel and others can now be modified via the **Item Properties** window.

• **Precision to be Displayed on Calculations** sets the math precision (number of decimal places) and the point at which the software will switch to scientific notation. For example, if the scientific notation tolerance is set to 5, then any number that is larger than $10^5$ will be displayed using scientific notation.
• **Precision for Convergence Criteria** sets the tolerance that will be used as the convergence limit (degree of accuracy) for mathematical iterations (e.g., a value of 4 indicates 1E-4 tolerance).

• **Fault Tree Tracer Options** sets the maximum number of blocks to read and maximum percentage of memory to be consumed by the fault tree tracer utility. The trace will terminate when any of the specified maximum values are exceeded. Setting lower values can help prevent out-of-memory issues. The memory threshold must be a value between 0 and 1, where 1 indicates no limit).

• **Other Options**
  - **Use identical block simplification by default for new diagrams.** Select this check box to use identical block simplification (IBS) for analytical diagrams. When IBS is used, the software looks for blocks with identical failure characteristics and attempts to simplify the equation, if possible, when analyzing the diagram. This is useful when analyzing large diagrams that contain a lot of the same blocks. You can also select to use IBS from the analysis settings page for analytical diagrams.
  - **Use mean time for the exponential distribution.** By default, lambda is used as the scale parameter of the exponential distribution. Select the check box if you prefer to use MTTF (1/lambda) instead.

**Plot Settings**
The Plot page of BlockSim/RENO's Application Setup contains default settings that will be applied when you create a new plot sheet in BlockSim or RENO. Note that some of the configurable settings that are saved with the plot can still be modified from the control panel, others can be modified via the Show/Hide Plot Items window (Plot > Actions > Show/Hide Plot Items), and still others via the Plot Setup.

• **Settings for Numbers in Axis Labels** sets the math precision (number of decimal places) and the point at which the software will switch to scientific notation for the X- and Y-axis labels.

• **Settings for Plot Sheets**
  - **Enable auto refresh** activates the auto refresh option.
  - **Show legends on plots** displays information about the objects shown on the plot.
  - **Show user, date and time** displays the user name, date and time on plots. The user information comes from your user account in the current database (see
Chapter 17: BlockSim and RENO Settings

User Login and Contact Information window) and is displayed at the bottom right corner of the plot.

- **Show outline on plots** displays the canvas border on the plot.
- **Show program ID on plots** displays the software name and URL in the Header Title section of the plot (e.g., Weibull++ - www.reliasoft.com).

- **Other Options**
  - **Enable interactive plot** highlights each point, line, slice or bar on the plot when you move the pointer over it. Point coordinates/values will be displayed on highlighted objects. Note that if you change this setting, you must redraw the plot to see the change.

- **BlockSim Plots: Allow plotting reliability and importance for diagrams with static blocks** includes the reliability and importance values for diagrams that contain static blocks (i.e., blocks that use a constant model).

- **RENO Plots: Ranking Method - Probability Plot** specifies the ranking method (Median Ranks or Kaplan-Meier) that is used in the flowchart Probability plot.

- **Set color limits** opens the Set Color Limits window, which allows you to set the color limits used in bar charts. Choose the metric of interest from the Plot Type drop-down list. You can then set both lower and upper color limits by dragging the markers on the scale between 0% and 100%. For example, in a Block Expected Failures plot, the blocks are displayed according to their RS FCI values, so if you wanted to change the default color limits used in that plot, you would choose RS DECI/RS FCI from the Metric drop-down list, then use the sliders to specify the desired color limits. If **Show all values (0-100%) in legend** is selected, the legend will show the full range of values; if it is not selected, the legend will show only the values between the upper and lower limits that you have specified. The preview shows how the specified settings will appear in the legend.

**Display Settings**
The Display page of BlockSim/RENO's Application Setup contains default settings that will be applied when you create a new diagram or workbook in BlockSim or RENO.

- **Truncate block names when the number of characters exceeds** sets the maximum number of characters displayed for block names.
Chapter 17: BlockSim and RENO Settings

**RENO Equation**

- **Add parameters when inserting functions using function selector.** Select the check box to automatically prompt for parameter inputs when you use the function selector or equation editor to insert functions into equations.

- **Validate equations during editing.** Select the check box to have RENO automatically check equations for errors while you are editing them. If not selected, equations will be validated upon simulation.

**Other Options**

- **Default folio font** sets the default font for sheets in new workbooks.

- **Show list of distributions on hovering** displays the distribution/model drop-down list when you move the pointer over the bar (e.g., in the Distribution Estimator). If not selected, you must click the bar to display the list.

**Other Settings**

The Other Settings page of BlockSim/RENO’s Application Setup allows you to set some other preferences that are applicable only to BlockSim and RENO.

- **Project**

  - **Show the Project Wizard when creating new projects** displays a wizard that helps you select the first new diagram to create in a project. If not selected, the new project will be blank.

  - **Ask to apply changes when selecting different block in Block Properties window** displays a window asking if you want to apply the changes you made to the active block when you select another block from the Active Block drop-down menu in the Block Properties window. If not selected, the changes will automatically be saved to the active block and the window will not appear when you select another block from the Active Block drop-down menu.

  - **Ask to apply changes when using the Format Painter** displays a window with the Format Painter that allows you to specify which settings will be applied to another block.

  - **Show warning when changing the IBS status** displays a warning message when you select or clear the Use IBS check box on the analysis settings page for analytical diagrams.
• **Show warning when an unused block is found in the maintenance template** displays a warning message when you attempt to run a simulation on a phase diagram with an associated maintenance template that includes a block not used in any of the operational phases.

• **Ask for confirmation when connecting multiple blocks.** By default, when you have multiple blocks selected in a diagram and you add a connector to one of the selected blocks, the connection goes only to the block you place the connector on. Select the check box to be prompted to add connections to all of the selected blocks.

• **Check analysis for inconsistencies prior to simulation** checks for inconsistencies in a simulation RDD or fault tree prior to simulating it.

• **While QCP is open, have access to all folios** locks the QCP in a top window position (i.e., non-modal) so it can remain open while you have access to all diagrams. The calculations performed in the QCP will be based on the currently active diagram. If not selected, you must close the QCP in order to return to the diagrams. This setting can also be changed from within the QCP by selecting or clearing the **Non-Modal QCP** option in the **Options** drop-down list.

• **Show warning when removing a resource** displays a warning message when you attempt to remove a resource that is in use.

• **BlockSim/RENO View Mode** is applicable if you have a license for both BlockSim and RENO. In that case, the default (**Let the license decide**) will always show the interface for both applications together. If you want the option to see the interface for BlockSim only or for RENO only, choose **Select on startup**.

---

**Conversion Settings**

The Conversion page of BlockSim/RENO's Application Setup allows you to set the default conversion options for importing from previous versions of BlockSim. As described in **Converting from BlockSim 6 or 7 Files**, many properties were defined for individual blocks instead of being assigned to reusable resources, as they are in the Synthesis version. Because of this, the same information may have been defined in multiple locations in the original project. Using the Conversion page, you can set the default conversion settings that determine whether identical records will be merged into one resource.
Reset Settings

The Reset Settings page of the Application Setup allows you to restore some or all of the settings to their original configuration. Note that it’s recommended to close all windows before resetting settings. If the change does not take effect immediately, restart the application.

- **Reset Common Synthesis Settings** resets the settings under the Synthesis Settings heading in the Application Setup.

- **Reset Application Settings** resets the settings under the current application's heading in the Application Setup. It also clears any saved default column headings in life data (Weibull++), life-stress data (ALTA) and growth data (RGA) folios.

- **Reset Application Form Settings** resets the form settings for the current application (e.g., size and location of windows).

- **Reset Plot Settings** resets the Plot Setup settings that are applied by default when you create a new plot in the current application.

- **Reset FIDES Settings** (Lambda Predict only) resets the predefined FIDES settings (e.g., saved pi factors, process audits, etc.) that are applied by default when you create a new repository. (See FIDES Settings Manager in the Lambda Predict documentation.)

- **Reset Component Defaults** (Lambda Predict only) resets the component property values that are applied by default when you add a new component to a prediction. (See Default Component Properties in the Lambda Predict documentation.)

- **Reset All Settings** resets all the saved settings for the current application. This is the same as clicking all of the individual "Reset" buttons above.

Project Item Settings

Synthesis desktop applications offer a variety of configurable settings that are stored per computer/username and managed via the Application Setup.

Your personalized application setup determines the default settings for new folios, diagrams and flowcharts that you create in Weibull++, ALTA, BlockSim, RENO and RGA. The relevant settings are also saved with each individual folio/diagram and are accessible from the Item Properties window. This makes it possible to have different settings for different analyses, and also ensures that any given analysis will be the same for all database users.
Chapter 17: BlockSim and RENO Settings

To view and edit the configurable settings in the Item Properties window, select the folio, diagram or flowchart in the current project explorer and choose Project > Current Item > Item Properties.

The settings are displayed on the second tab of the properties window. (In a secure database, the settings can be edited only if the user is the project owner or has the "Create/edit project items" permission.)

If you modify the settings for a particular project item, the new preferences will be saved with the folio/diagram. The default preferences for new folios/diagrams in the application setup will remain unchanged.

Region and Language Settings

The Region and Language settings for your particular computer will have some impact on the way some information is displayed in Synthesis applications.

Users with different regional and language settings can work together on the same analysis projects because, in most cases, the basic information is stored in the database and the software simply displays it in the format preferred by each user. For example, if the date September 25, 2015 is stored in the database, User A might see it as "9/25/2015" while User B might see "25-Sep-15."

This topic first explains how to view or change the Region and Language settings on your computer and then discusses some specific considerations for Synthesis applications, including:

- Which language is selected by default when you install the software
- How dates and times will be entered and displayed
- How decimal values and currency will be entered and displayed
- Which measurement system is the default for the Page Setup window

Viewing or Changing the Region and Language Settings for Your Computer

To view or change the region and language settings:

- In Windows 8 or Windows 10, move the pointer to the lower left corner of the desktop, then right-click and choose Control Panel. Click the Clock, Language, and Region option then click the Region link.
• In Windows 7, choose Start > Control Panel and then click the Region and Language link.

As an example, the Windows 7 interface is shown here. The Windows 8 and Windows 10 versions look different but function similarly.

Other relevant settings are managed via the Customize Format window:

• In Windows 8 or Windows 10, click the Additional settings button.
• In Windows 7, click the Additional settings button.

As an example, the Windows 7 interface is shown next.
Note: To see the changed settings in the Synthesis application, you must close the application, and then restart it.

Which Language is Selected by Default When You Install the Software

The user interface for Synthesis desktop applications is available in several languages. You can change this language at any time by choosing an option from the Language drop-down list on the Synthesis Settings page of the Application Setup.
When you first install the software, it will check your computer's current language as it is set in the *Format* field in the Windows Region and Language window. If that language is supported in Synthesis, Synthesis will use those settings; however, if that language is not supported, Synthesis will use the default setting of English.

**Defining Date and Time Formats**

Dates and times appear frequently throughout the Synthesis interface, including (but not limited to):

- The dates in the plot legend area of a plot in all Synthesis applications.
- The history provided throughout Synthesis applications (e.g., for resources, FMEA records, diagrams, in history logs, etc.).
- The dates in the worksheet view and in the record properties windows in Xfmea, RCM++, RBI and MPC.
- The dates in the "dates of failure" format and "usage" format of the Weibull++ warranty folios.

The *Short date* field from the Windows Region and Language window determines how dates are displayed. You can select any standard format (e.g., M/d/yyyy, dd/MMM/yy, yy/MM/dd) or you can create your own format using the available date notations.

The *Short time* field determines how times are displayed. You can select any standard format (e.g., h:mm tt, HH:mm, HH'h'mm) or you can create your own format using the available time notations.

The Windows settings do not apply to the following items:

- Dates and times in spreadsheet utilities (e.g., a spreadsheet module in Synthesis Workbooks, General Spreadsheets, etc.).
- Dates and times displayed in the Weibull++ event log folio are created by the folio and are not affected by the computer's settings.

**Changing the Decimal Symbol, the List Separator and the Currency Symbol**

How decimal values are displayed depends on the value of the *Decimal symbol* field on the Numbers page of the Windows Customized Format window, which determines which character is used to indicate the decimal portion of a number (e.g., 85.25 or 85,25). In addition, the character used to separate the arguments in a list depends on the value of the *List separator* field. These settings affect how you enter functions in a spreadsheet module in Synthesis Workbooks or in General Spreadsheets, either manually or by using the Function Wizard.
Chapter 17: BlockSim and RENO Settings

For example, if the decimal symbol value is a comma, and the list separator value is a semicolon, you would enter a function like this:
=RELIABILITY("Weibull!Folio1!Data 1";500;100;0,9)). Whereas, if the decimal symbol is a period and the list separator is a comma, it would be
=RELIABILITY("Weibull!Folio1!Data 1",500,100,0.9)).

The currency symbol that is displayed in the software depends on the selection in the Currency symbol field on the Currency page of the Windows Customized Format window.

**Setting the Measurement System in the Page Setup**

On the Margins tab of any Synthesis desktop application's Page Setup window (Home > Print > Page Setup), the Units field determines which unit of measure (inches [U.S.] or centimeters [Metric]) is used for the page margins on print output. The field includes the System's default option. Selecting this option means that the measurement system used is determined by the value of the Windows Customize Format window's Measurement system field, and it will change if the computer's settings change.

**Tip:** If you want the page margins to always be the same, you can select a specific unit of measure and not use the System's default option.
Chapter 18: Synthesis Platform Tools

Categories, Identifiers and Filters

Defining Categories
In all Synthesis desktop applications, you can use flexible categories and identifiers to filter and group analysis data in a way that fits your specific needs. There are two types:

- **Project Categories** can be applied to projects in all desktop applications.
- **Item Categories** can be applied to project items (e.g., folios, diagrams, system hierarchy items) and resources (e.g., models, URDs) in all desktop applications except MPC.

This topic describes how to define the categories that will be available throughout the current database. To learn how to use them to filter and group data, see Project and Item Filters. (For additional options related to categories for system hierarchy items, see Item Categories in Xfmea/RCM++/RBI in the Xfmea/RCM++/RBI documentation.)

Accessing the Project/Item Categories Window
There are two ways to access the Project/Item Categories window and specify which categories will be available throughout the current database. (In a secure database, these are available only for users with the “Manage project/item categories” permission.)

To open the window from the backstage view, choose File > Manage Repository > Project/Item Categories.

Alternatively, you can click inside any Category drop-down list (e.g., in a properties window, filter, etc.) and click the Edit Categories icon.
Adding, Renaming and Deleting Categories

- To rename an existing category, double-click inside the cell and edit the text.

- To add a new category in the same level as the one that is currently selected, click Add.

- To add a new category in the level below the one that is currently selected, click Add Below.

- To move a selected category up or down within the same level, select the row and click Up or Down.

- To move a selected category to a different level, click Promote or Demote.

- To delete a category, select the row and press the Delete key or click the icon. To delete all categories at the same time, click Clear All. There is no undo for delete.
Synthesis Identifiers

In all Synthesis desktop applications, you can use flexible identifiers and categories to filter and group analysis data in a way that fits your specific needs. The Synthesis identifiers are available for project explorer items (e.g., folios, diagrams, plots, etc.) and there is one standard set of identifier fields for all relevant locations.

<table>
<thead>
<tr>
<th>Category</th>
<th>Bulb A</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part Number</td>
<td>PN12345</td>
</tr>
<tr>
<td>Version</td>
<td>Rev 1</td>
</tr>
<tr>
<td>Supplier</td>
<td>Acme Chandelier</td>
</tr>
<tr>
<td>Application</td>
<td>Chandelier</td>
</tr>
<tr>
<td>Description</td>
<td>Light bulb</td>
</tr>
<tr>
<td>Comments</td>
<td>Based on in-house test data.</td>
</tr>
<tr>
<td>Keywords</td>
<td>Bulb, Life, Test Data</td>
</tr>
</tbody>
</table>

This topic describes how to view and edit identifiers for each type of resource or analysis, and how existing identifiers will be converted from Version 8 or 9. To learn how to use identifiers to filter and group data, see Project and Item Filters.

For Synthesis Resources

To view and edit the identifiers for most types of Synthesis resources, you can simply open the properties window and select the Identifiers node. They can also be edited via the Batch Properties Editor. Note that:

- For published models, the identifiers are obtained from the analysis (e.g., Weibull++ folio, BlockSim diagram, etc.). To make a change, you must first edit the identifiers for the analysis and then republish the model.

- Identifiers are not applicable for the following resource types: Variables, Maintenance Groups, Mirror Groups, Actions and Controls.

For Project Explorer Items

To view and edit the identifiers for folios, diagrams, plots and other analyses in Weibull++, ALTA, BlockSim, RENO or Lambda Predict, select the item in the current project explorer and choose Project > Current Item > Item Properties.
Chapter 18: Synthesis Platform Tools

The identifiers are always displayed on the first tab of the properties window.

When applicable, the fields are also visible on the Identifiers page of the control panel. If a folio has multiple data sheets, you can use this page to define separate identifiers for each sheet. Note that the Folio Identifiers will be used in item filters and in the Synthesis Explorer; while the Data Sheet Identifiers will be used when publishing a model.

You can use an asterisk (*) in any or all of the data sheet fields to apply the same text from the corresponding folio field. As an example, the following picture shows the identifiers for a Weibull++ life data folio that contains multiple data sheets for each design prototype of a new chandelier bulb in development. Although most of the data sheet identifiers will be the same as the folio (indicated with *), the Version and Comments fields have been modified for each data sheet. The data sheet identifiers will be used when you publish a model.

For System Hierarchy Items
To view and edit the identifiers in Xfmea, RCM++ and RBI, select an item in the system hierarchy and go to the Properties tab in the Analysis panel. The same set of identifiers will be used for all analyses associated with that item (e.g., FMEA, control plan, etc.).
The fields are grouped together under the Identifiers heading. Name, Category and Keywords will always be displayed. The remaining identifiers may be hidden or renamed based on the configurable settings for the current project. (See Configurable Settings in the Xfmea/RCM++/RBI documentation.)

For Diagram Blocks
To view and edit identifiers for diagram blocks in BlockSim, open the block properties and select the Identifiers node. The fields are also visible on the Identifiers page of the control panel when the block is selected.

You can use these identifiers in BlockSim’s Find utility and in the Batch Properties Editor.
Conversion from Version 8/9
The following table shows how the "global identifiers" from previous versions will be mapped when you convert existing data in a Version 8/9 database (where “-” indicates no change).

Project and Item Filters
In many locations throughout all Synthesis desktop applications, you can use flexible filters to limit a list of projects, project items (e.g., folios, diagrams, system hierarchy items, etc.) or resources (e.g., models, URDs, etc.).

The drop-down list contains the filters you have saved in this database, plus any filters that another user has chosen to share with other database users.

http://blocksim.reliasoft.com
Use the drop-down list to apply an existing filter. To stop filtering the list, select **Show All** (formerly called "Default filter").

**Sharing Filters with Other Users**
To share a saved filter, open the filter's properties window and select the **Show to all repository users** check box.

In a secure database, a shared filter can be edited or deleted only by a) the user who created the filter or b) a user with the "Manage other repository settings" permission.

**Project Filters**
Project filters can be applied to lists that contain project names such as the **Project Manager** and **Synthesis Explorer**. Now in Version 11, the filter can either be a query based on specified criteria, or a selected list of projects.

- **Based on Criteria.** You can match **All Criteria** (AND query) or **Any Criteria** (OR query):
  - Owner (**project owner**)
  - Category (**project category**)
  - Analysis/Feature (whether the project contains analyses associated with the specified application or feature)
  - Last Updated By
  - Last Updated Date

- **Based on Selected Projects.** Click the **Add** button to select the projects you want to include, or the **Remove** button to remove a selected project from view.

Clear the **Show locked projects** check box if you want to exclude **locked projects** from the results, even if they meet the criteria.

Projects are always grouped based on whether they are **public, private or reference**. For additional grouping, select the **Group by category** and/or **Group by owner** check boxes. If you select both, the results will be grouped first by project category and then by project owner. For example:
Chapter 18: Synthesis Platform Tools

Item Filters
Item filters can be applied to lists that contain project items and resources such as the Current Project Explorer and Resource Manager.

Select whether the item must match All Criteria (AND query) or Any Criteria (OR query):

- Category (item category)
- Created By
- Last Updated By
- Last Updated Date
- Synthesis identifiers (Name, Part Number, Version, Application, Supplier, Description, Comments and Keywords)

Synthesis Explorer
The Synthesis Explorer is available in all Synthesis desktop applications except MPC. You can use this flexible tool to explore all of the different analyses that are stored in the current database.

To access the utility, choose Home > Synthesis > Synthesis Explorer.

To reduce the amount of time required to populate the grid, first use the project and item filters (discussed below) to limit your search, then click Load Data.
The analyses shown in the explorer may include:

- Project items in Weibull++, ALTA, BlockSim, RENO, RGA and Lambda Predict (e.g., folios, diagrams, plots, Synthesis Workbooks, etc.).

- Analyses that are associated with system hierarchy items in Xfmea, RCM++ or RBI (e.g., FMEAs, control plans, risk based inspection analyses, etc.).

- Project Plans that can be created for any project.

You can filter/sort/group the analyses based on Synthesis application, analysis type, analysis creator and many other properties. You can also present the information in a wide variety of dashboard charts.

This topic summarizes the tools you can use to find and organize data in the Synthesis Explorer’s flexible grid. For information about presenting the data graphically, see Synthesis Explorer Dashboards. For a list of the properties that can be used in either the grid or the dashboard, see Synthesis Explorer Properties.

Save and Apply Views

Once you have customized the Synthesis Explorer’s grid to suit a particular purpose (using the built-in find/filter, column configuration and grouping features described below), you can save the preferences as a view that can be used again whenever you need it. A view is saved in the database and available only to the user who created it.

To create a view, first configure the grid to suit your particular needs and then click Save View.

To quickly apply these same preferences again at any time, click Apply View and select one of the saved views from the list.

Note: The view does not affect filtering that has been applied from the Project Filter, Item Filter or Category Panel.

Project and Item Filters

The Synthesis Explorer can utilize the same project and item filters that are available in many other locations throughout Synthesis desktop applications. For example, with the custom filters shown below, the Synthesis Explorer will show only analyses performed by Department A (project filter) that were modified within the last month (item filter).
To remove either filter, select **Show All** from the drop-down list. To remove both filters at the same time, select **Data > Clear Filters**.

After you clear or change these filters, you must click **Load Data** again to update the grid.

**Category Panel**
The category panel provides a quick way to filter the data based only on item category. For example, you might use the panel to first view the analyses for Category A and then quickly switch to see the analyses for Category B.

To show or hide the panel, click **Data > Show Category Panel**.

When there are many categories, the tools at the top of the panel can help you find and select the one(s) you need.

**Built-in Find/Filter, Configuration and Grouping Tools**
The Synthesis Explorer offers the same filter, column configuration and grouping tools that are built in to other Synthesis utilities that use a similar grid (e.g., the Resource Manager). For details about how to use each feature, see:

- **Finding and Filtering Records**
- **Configuring Columns**
- **Grouping Panel**
Synthesis Explorer Dashboards
You can use the flexible Synthesis Dashboard utility for presenting data from the Synthesis Explorer.

As with any other Synthesis dashboard, you can use the Dashboard Viewer to select any of the layouts that have been predefined for this type of data, and you can use the Dashboard Layout Manager to create or edit layouts.

(In a secure database, the Dashboard Layout Manager is available only for users with the “Manage dashboard layouts” permission.)

Values and Arguments
When you’re creating bar charts or pie charts based on Synthesis Explorer data, note that the argument(s) determine the bars or slices shown in the chart and the value will always be the quantity of analyses that fit the specified criteria.

If you use the default Count option when specifying the value, then any of the Synthesis Explorer properties will return the same quantities. You may prefer to choose the one that gives the most appropriate chart label(s). For example, the following pie chart uses the same property (“Application Source”) for both the Value and Argument in order to display the total quantity/percentage of analyses for each Synthesis application.

**Tip:** Use the Design tab of the ribbon to configure the chart labels and other settings to fit your particular preferences. For example, in this chart, the Data Labels are configured to display the Argument, Value and Percent (e.g., BlockSim: 648 (23.44%).}
If there is ever a situation in which you want to show only the number of distinct values for a particular property, you can use the **Count Distinct** option instead. For example, the following pie chart uses **User Created By (Count Distinct)** for the value in order to show the number of users who created analyses with each Synthesis application.
As you can see from looking at both charts, the “Count” shows that there are 648 total BlockSim analyses; while “Count Distinct” shows that only 18 distinct users created BlockSim analyses.

**Filtering the Data**

Any filters that are currently applied in the Synthesis Explorer grid will not be reflected in the dashboard charts. However, you can incorporate filters directly into the dashboard layout. For example, if you want to show all of the Weibull++ analyses that were created by a particular user, you can create a filter like the one shown next. (See Using the Filter Editor.)

In addition (or instead), you can configure the layout with one or more *master filters* that allow individual users to change the filters on-the-fly in the Dashboard Viewer. As an example, the following picture shows a layout in which the user’s current selections in the two grids determine which analyses will be reflected in the pie chart at any given time. (See Configuring a Master Filter and Using Master Filters.)
Synthesis Explorer Properties
The following properties will be available when you are using either the grid or dashboard in the Synthesis Explorer.

**Application**
- **Application Source** is the primary Synthesis application (or product family) for viewing or editing the analysis. (Note that Project Planners and Simulation Worksheets are listed under Synthesis because they can be created/edited from more than one product family.)
- **Application Activated?** indicates whether the primary application is activated on your computer.

**Project**
- **Project Name** is the project in which the analysis is stored.
- **Project Type** indicates whether it is a public, private or reference project.

**Analysis**
- **Analysis Name** is the name of the folio, diagram, plot, system hierarchy item, etc.
• **Analysis Type** and **Variant** indicate the type of analysis. This can include project items (e.g., folios, diagrams, plots, etc.) and specific analyses that are associated with a system hierarchy item in Xfmea, RCM++ or RBI (e.g., FMEAs, risk based inspection analyses, etc.). The variant is used to distinguish:
  - Analytical vs. simulation RBDs and fault trees in BlockSim.
  - Discrete vs. continuous Markov diagrams in BlockSim.
  - The specific prediction standard in Lambda Predict (e.g., MIL-217, Telcordia, etc.). If the prediction folio uses more than one standard, this will show as “Multiple.” If a standard has not yet been added to the prediction folio, the variant field will be blank.

**Categories and Synthesis Identifiers**
*Note that these properties are preceded with “SI” in the Dashboard Layout Designer, so that all Synthesis identifiers can be grouped together in the data source panel.*

- **Category** is the category assigned to the analysis.
- **Name, Part Number, Version, Supplier, Application, Description, Comments** and **Keywords** are the standard Synthesis identifiers that can be defined for the analysis. Note that Xfmea/RCM++/RBI analyses use the identifiers defined for the system hierarchy item they are associated with.

**Creation and Last Update**
- **User Created** and **Date Created** indicate the database user who originally created the analysis, and the associated date/time.
- **User Updated** and **Date Updated** indicate the database user who last modified the analysis, and the associated date/time.

**Synthesis Locator Links**
Synthesis Locator Links provide quick access to specific analyses in a Synthesis repository (similar to Windows shortcuts). You can save these link files anywhere on your computer or network, e-mail to a colleague, post on the Internet or an intranet, etc.

When you double-click (open) a Synthesis Locator Link file (*.rsrl11), it will launch the appropriate Synthesis application and go directly to a specific project item (e.g., folio, diagram, plot, system hierarchy item, etc.) or FMEA record (e.g., function, failure, etc.), as long as the following conditions are met:
  - The database still resides in the same location and you have access to the server.
You have an active user account in the database.

The required Synthesis application is activated on your computer.

**Tip:** In the case of a standard database or Synthesis file, the locator link stores the pathname/filename that was open when the *.rsll file was created. If that was a mapped network drive (e.g., P:\Synthesis\Repository1.rsll), the link will only work if all other users have that drive mapped to the same letter. To make sure the link works for all users, you may need to open the database from the UNC pathname (e.g., \SharedDrive\Synthesis\Repository1.rsll) before creating a locator link file.

### Creating a Locator Link

In an enterprise database, you can choose to either send the file by e-mail or save it to a specified location. In a standard database or Synthesis file, the only option is to save the file because it is likely that the pathname may only work on your own PC (as discussed above).

- For an item selected in a current project explorer (Weibull++/ALTA, BlockSim/RENO, RGA or Lambda Predict), choose **Project > Current Item > Save Locator Link**.

- For an item selected in an Xfmea/RCM++/RBI system hierarchy, choose **System Hierarchy > Current Item > Save Locator Link**.

- For an item, structure or zone selected in an MPC hierarchy, choose **[Systems/Structures/Zones] > Tools > Save Locator Link**.

**Note:** If you get a "Locator Link is not properly formatted" message, the locator link may be corrupted or is using old encryption. Create a new locator link using the methods described above.

### Posting Locator Links on a Web Page

Remember that Synthesis Locator Links are files that must be opened from a computer where Synthesis desktop applications are installed. If you post the *.rsll as a standard link on an HTML web page, you will need to instruct users to download the file (instead of opening directly from the web browser).
**Watches and Alerts**

Automated alerts can be an effective tool to facilitate communication and track the status of assigned responsibilities.

Alerts can be sent via e-mail, **SMS text message** and/or **Synthesis portal messages**, depending on the **Receive automated alerts** preference specified for your **personal user account**.

- Alerts via portal message are always available in any database.
- Alerts via e-mail or SMS are only available if they are enabled for the database, and a valid SMTP server has been defined. (See **Enable Alerts via E-mail or SMS**.)

Alerts can now be sent for:

- Any Synthesis resource that you have personally subscribed to “watch.” (See **Subscribing to a Watch**.)

- Action resources, under any of the following conditions:
  - You have personally subscribed to watch the action.
  - You are the action’s creator, person responsible or assigned reviewer/approver and the database has been configured to auto-subscribe a watch for that role. (See **Action Alert Preferences**.)
  - You are assigned via the Action Monitors window. (See **Action and Gate Monitors**.)

- Project Planner gates, under either of the following conditions:
  - You have personally subscribed to watch the gate.
  - You are assigned via the Gate Monitors window.

- Change logs you have been assigned to approve in Xfmea/RCM++/RBI. (See **Electronic Approval Tracking** in the Xfmea/RCM++/RBI documentation.)
Enable Alerts via E-mail or SMS

To configure a database to enable alerts via e-mail and/or SMS text message, choose File > Manage Repository > Repository Settings.

In a secure database, this is available only for users with the “Manage other repository settings” permission.

What’s Changed? In prior versions, similar preferences were defined in the E-mail and Other Settings window.

1. Select the Enable Alerts via E-mail or SMS check box.

2. Specify a valid SMTP port and SMTP server. (You may need to consult with the IT professionals who have configured the e-mail server used within your organization.)

<table>
<thead>
<tr>
<th>SMTP port</th>
<th>SMTP server</th>
</tr>
</thead>
<tbody>
<tr>
<td>25</td>
<td>&lt;Insert a valid SMTP address&gt;</td>
</tr>
</tbody>
</table>

3. Enter your e-mail address (or a valid SMS text messaging address if you prefer) in the Recipient address for test message field and then click Send Test Message.

   Recipient address for the test message
   YourEmail@Company.com
   Send Test Message

   If the test message cannot be sent, an error will be displayed. If that happens, you can update the settings and try again until the message is delivered successfully.

Subscribing to a Watch

Users can personally subscribe to “watch” specific Synthesis resources, Project Planner gates and MPC tasks that are of particular interest to them. This generates an alert (via e-mail, SMS text message and/or Synthesis portal message) each time the record is changed.
Chapter 18: Synthesis Platform Tools

Subscribing and Unsubscribing
To personally subscribe/unsubscribe to a watch, open the resource, Project Planner gate or MPC task and select or clear the Alert me on changes to this record check box. The alert types shown for this option will depend on your alert preferences, as described in the section below.

Note that the “watch” feature is not applicable for the following types of resources: Variables, Maintenance Groups, Mirror Groups, Controls, Maintenance Templates (in BlockSim) or RENO-specific resources (Functions, Static Functions, Simulation Definitions and Tables).

Receiving Alerts
Alerts can be sent via e-mail, SMS text message and/or Synthesis portal message, depending on the Receive automated alerts preference specified in your personal user account.

• Alerts via portal message are always available in any database.
• Alerts via e-mail or SMS are only available if they are enabled for the database, and a valid SMTP server has been defined. (See Enable Alerts via E-mail or SMS.)

No Cascading Alerts
Alerts are generated only when the record you’re watching is edited directly. For example, if you are watching a universal reliability definition (URD):

• An alert will be sent if someone replaces Model A with Model B in the URD window.
• An alert will not be sent if there is a change to an existing model, crew, etc. that is already assigned to the URD, unless you have also subscribed to watch the dependent resource that was changed.

Special Considerations for Actions and Gates
For action resources only, there are some additional features designed to maintain continuity with prior versions of Synthesis and enhance the actions management functionality. Specifically:

• Action changes that are applied via the FMEA worksheet in Xfmea/RCM++/RBI will not initiate an alert. The change must be saved via the action properties window.
• The database can be configured to auto-subscribe watches for users with the following roles: Action Creator, Person Responsible or Reviewer (aka “approver”). Each user can choose to personally unsubscribe later if desired. (See Action Alert Preferences.)
• The Action Monitors window allows you to specify individual users and/or groups of users who will always receive alerts for the action, regardless of whether they have
personally subscribed to a watch. For example, this allows you to set up an alert for a user who doesn’t have access to view or modify the project (and therefore can’t personally subscribe to a watch).

A similar feature, the Gate Monitors window, is available for Project Planner gates. (See Action and Gate Monitors.)

**Action Alert Preferences**

To configure the action alert preferences for the database, choose **File > Manage Repository > Repository Settings**.

In a secure database, this is available only for users with the “Manage other repository settings” permission.

**What’s Changed?** In prior versions, similar preferences were defined in the E-mail and Other Settings window.

- **Introduction to each action alert sent via e-mail.** This field allows you to specify the default text (up to 1,000 characters) that will be used at the beginning of each action alert e-mail sent from this database.

- **Automatically set ‘watch’ for.** Users can personally subscribe to “watch” specific Synthesis resources and Project Planner gates that are of particular interest to them. For action resources only, the database can also be configured to auto-subscribe watches for users that have particular roles in a given action, as shown in the picture above. Note that each user can choose to personally unsubscribe later if desired (by opening the action record and clearing the check box under the Watch heading).
Action and Gate Monitors

The Action Monitors window (for action resources) and the Gate Monitors heading (for Project Planner gates) allow you to specify individual users and/or groups of users who will always receive alerts for the record, regardless of whether they have personally subscribed to a “watch.”

For example, this allows you to set up an alert for a user who doesn’t have access to view or modify the project (and therefore can’t personally subscribe to a watch).

Action Monitors

For actions, click the **Action Monitors** icon in the action’s ribbon.

This replaces the “E-mail Notifications” feature from prior versions, and you can choose any of the user groups or individual user accounts defined in the current database.

The action will also appear under the **I am monitoring** heading in My Portal, Actions Explorer and Synthesis Enterprise Portal (along with the actions that the user has personally subscribed to watch).

Gate Monitors

For Project Planner gates, the assigned users are listed under the **Gate Monitors** heading. Click the **Edit** icon to select the users you wish to assign.

This replaces the “Team” feature from Xfmea/RCM++/RBI Version 9, and you can choose to assign any of the individual user accounts in the database.

What is Your SMS Address?

If you choose to receive alerts via SMS text messaging, the address will usually be your cell phone number @ the provider’s e-mail domain. As a courtesy, the table below provides a list of domains for popular providers in the United States (as of March 2015). Of course, you may need to check with your provider to obtain the most up-to-date information.
For example, if you use T-Mobile in the US and your cell number is 555-123-4567, your SMS address will be 5551234567@tmomail.net.

<table>
<thead>
<tr>
<th>Provider</th>
<th>Domain</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alltel</td>
<td>@message.alltel.com</td>
</tr>
<tr>
<td>Amp'd</td>
<td>@vtext.com</td>
</tr>
<tr>
<td>Boost</td>
<td>@myboostmobile.com</td>
</tr>
<tr>
<td>AT&amp;T</td>
<td>@txt.att.net</td>
</tr>
<tr>
<td>Metrocall</td>
<td>@page.metrocall.com</td>
</tr>
<tr>
<td>Nextel</td>
<td>@messaging.nextel.com</td>
</tr>
<tr>
<td>Sprint</td>
<td>@messaging.sprintpcs.com</td>
</tr>
<tr>
<td>T-Mobile</td>
<td>@tmomail.net</td>
</tr>
<tr>
<td>US Cellular</td>
<td>@mms.uscc.net</td>
</tr>
<tr>
<td>Verizon</td>
<td>@vtext.com</td>
</tr>
<tr>
<td>Virgin (USA)</td>
<td>@vmobl.com</td>
</tr>
<tr>
<td>Windstream</td>
<td>@windstream.net</td>
</tr>
</tbody>
</table>

**History Logs**

By default, all projects and project items automatically show information about when an item was created and last updated, and by whom. For example, system hierarchy items in Xfmea/RCM++/RBI show this information under the History heading on the Properties tab, while folios and diagrams in Weibull++ and BlockSim show the information in the Item Properties window (Project > Current Item > Item Properties).

In addition to the basic information provided, you have the option to activate a full history log that shows more detailed information such as the type of change that was made (e.g., add, edit or delete), the record that was changed and the specific property, and the value before and after the change.
History logs will increase the size of a database and will cause a slight degradation in performance; hence, they must be activated on a per project basis. If desired, you can configure the database to automatically activate history logs for each new project by choosing File > Manage Repository > Repository Settings, and then selecting the option under the Other Settings tab in the window. (In secure databases, this is available only if the user has the "Manage other repository settings" permission.)

Once a history log is activated, the project history log shows the changes for all items in the project, and individual record history logs show the changes for selected items only.

**Tip:** If you want to monitor and control revisions made to FMEAs, DVP&Rs or Control Plans in Xfmea/RCM++/RBI, the use of change logs may be more appropriate. See Change Logs in the Xfmea/RCM++/RBI documentation.

### Activating a Project History Log

To activate the history log for a project, choose Project > Management > History Log, or right click the project in the project list and choose the command on the shortcut menu. (In secure databases, this is available only if the user is the project owner, or has the applicable "manage all projects" permissions.)

In the Project History Log window that appears, click Activate.

Once the log has been activated, the database will start keeping records of all changes that are performed throughout the entire project for any of the Synthesis applications. You can filter the records by the last update date, application, user or type of change. For example, you might choose to display a list of all changes that were made by Joe User in the last week, or a list of all changes that were made by any user in Weibull++ today, and so on.

You can deactivate the history log at any time from this window. When you do this, the recorded data is retained unless you select to clear it in the confirmation message that appears.

### Creating and Managing Archives

You can limit the amount of information that is visible in the log by archiving older entries that are no longer of interest. Entries that have been archived can still be viewed in the Project History Log window if you specifically select to view them, but they will no longer be visible in the Record History Log windows.
Archives are named based on the date they were created. For example, if you archive entries through **One week ago**, all entries in the history log that are dated as of one week ago or earlier will be stored in an archive that is named after the current date.

To view the contents of an archive, select the archive of interest from the *Archive* drop-down list in the *Filter Based On* area. To delete an archive, click the *Delete* icon that appears in the field.

**Note:** When a [restore point](#) is created for a project or when a project is [checked out](#), all current entries in the history log are automatically archived.

### Viewing Record History Logs

In addition to the project history log, you can view a log that shows only the changes made to a selected item (archived entries will not be shown). The History Log icon 📋 will be displayed whenever the log is available:

- For folios, diagrams, multiplots (such as overlay plots), reports and worksheets, right-click the item in the current project explorer and choose *Item Properties*, then in the window that appears, click the *History Log* icon in the Identifiers tab.
- For system hierarchy items in Xfmea/RCM++/RBI and MPC, select the item then click the *History Log* icon in the Properties panel.
- For FMEAs, DVP&Rs and other analyses in Xfmea/RCM++/RBI, right-click the analysis’s tab in the Analysis panel and choose the *History Log* command on the shortcut menu.
- For resources (e.g., models, actions, etc.), the *History Log* icon will be available when you edit the item or view its properties.

### Import, Export and Data Conversion

Synthesis applications provide a variety of different tools for import, export and data conversion from external files and between Synthesis repositories. The options will vary depending on which application you are currently using.
In desktop applications, you can:

- Import data from an existing database when you are creating a new one.
- Convert and import data from prior version files.
- Import/export selected projects.

When applicable, you can also:

- Import/export selected project items or Synthesis resources.
- Import from an Excel spreadsheet or delimited text file into a data folio.
- Use XML files to import/export system configuration information in BlockSim or Lambda Predict.

These features can be accessed either from the Import/Export Wizard (Project > Management > Import/Export) or from the Backstage View.

In addition to the common functionality described in this chapter, some Synthesis applications provide other data transfer and import/export utilities that fit specific needs (e.g., the Import Bill of Materials feature in Lambda Predict, the Excel templates in Xfmea/RCM++/RBI, the ability to share analysis details between specific Synthesis applications.). For more information about these specialized tools, please consult the documentation for the particular application(s) involved.

**Importing from an Existing Repository**

When you are creating a new Synthesis repository, you have the option to import repository settings (e.g., user accounts, security groups, project categories, etc.) and/or entire analysis projects from another database.

If the Import from existing repository check box is selected when you start to create a new database, the Import Data from Existing Repository window will be displayed.

First, use the drop-down list or browse icon 📁 to select the database that you want to import from. This can be a standard database (*.rsr11) or an enterprise database connection file (*.rserp).

Then, use the check boxes to select the settings and/or projects you wish to import.

Finally, click OK to create the new database with the selected data imported.
Importing from Prior Version Files

There are two ways to convert and import data from project files and standard database files that were created in previous versions of the software.

- **Importing to a new standard database (File > Open Repository)**
- **Importing to an existing database and project (Import > Other file)**

The options depend on which Synthesis application you're currently using:

- For Weibull++, ALTA, RGA and BlockSim/RENO, you can use either method.
- For Lambda Predict, Xfmea/RCM++ and MPC, you must use the File > Open Repository method to import the data into a new project in a new standard database.

Finally, for an enterprise database created in Xfmea/RCM++ 5, there is a dedicated utility that you can access from the Backstage View. (See Converting Xfmea/RCM++ 5 Databases.)

Importing to a New Standard Database (File > Open Repository)

For all Synthesis desktop applications, you can use the File > Open Repository method to import data from a project file or standard database that was created in a previous version of the software. This imports the data to a new project in a new standard database.

1. Choose **File > Open Repository.**
2. Browse for the file and click **Open.**
3. The conversion process will begin immediately for most applications. In BlockSim and MPC only, you will be prompted to specify some preferences and then click **OK** to proceed.
   - See **Converting from BlockSim 6 or 7 Files.**
   - See **Converting MPC 3 Databases.**

*Note that although the conversion of Xfmea/RCM++ 5 databases does not require any user input, the process does apply some assumptions to address changes in the functionality and data structure between versions. (See Converting Xfmea/RCM++ 5 Databases.)*
When the process completes, the original file will remain unchanged and the new standard database will be created in the same folder.

**Tip:** Once the new database has been created, you can use the Import/Export Projects feature to copy the data into an existing database, if desired.

### Importing to an Existing Database and Project (Import > Other file)
For the applications and file types shown in the following table, you can use the Import > Other file method to import data from a project file that was created in a previous version of the software. This imports the data to a selected project in an existing standard database or enterprise database.

<table>
<thead>
<tr>
<th>Weibull++/ALTA</th>
<th>RGA</th>
<th>BlockSim/RENO</th>
</tr>
</thead>
<tbody>
<tr>
<td>ReliaSoft Office 7 projects (*.rso7)</td>
<td>RGA 7 projects (*.rga7)</td>
<td>BlockSim 7 projects (*.rbp)</td>
</tr>
<tr>
<td>Weibull++ 7 projects (*.rwp)</td>
<td>RGA 6 projects (*.rga)</td>
<td>BlockSim 6 projects (*.rb6)</td>
</tr>
<tr>
<td>ALTA 7 projects (*.ralp)</td>
<td></td>
<td>RENO 1 projects (*.rnp)</td>
</tr>
<tr>
<td>Weibull++ 6 projects (*.rw6)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ALTA 6 projects (*.ra6)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DOE++ 1 projects (*.rdoe)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Do the following:

1. Create a new project or open an existing project that you want to import the data into.
2. Choose **Project > Management > Import/Export > Import**.
3. In the Import wizard, choose **Other file** and click **OK**.
4. The conversion process will begin immediately for most applications. In BlockSim only, you will be prompted to specify some preferences and then click **OK** to proceed. (See Converting from BlockSim 6 or 7 Files.)
Note that although the conversion of Xfmea/RCM++ 5 databases does not require any user input, the process does apply some assumptions to address changes in the functionality and data structure between versions. (See Converting Xfmea/RCM++ 5 Databases.)

When the process completes, the original file will remain unchanged and the converted data will be copied into the selected project.

Converting from BlockSim 6 or 7 Files
When you import from a BlockSim 6 (*.rb6) or BlockSim 7 (*.rbp) file, the Conversion Settings window allows you to specify:

- Whether you want the diagrams to be converted to analytical diagrams, simulation diagrams, or both.
- Whether the application will attempt to merge identical records when certain block properties are converted to Synthesis resources. For example, if the old diagram has two blocks with the same failure distribution, this can be imported as two separate but identical failure models, or as a single failure model that's linked from both blocks.

Tip: The default preferences for merging identical resources upon conversion are set on the Conversion page of BlockSim’s Application Setup (File > Application Setup). Note that any changes you make in the Conversion Settings window will update your preferences in the Application Setup. In other words, the same options will be selected by default the next time you attempt to convert a BlockSim 6 or 7 file on this computer.

Conversion Constraints and Differences
Numerous improvements have been made to the modeling capabilities and underlying analysis and simulation algorithms used in the Synthesis version of BlockSim. As a result, analysis or simulation of diagrams imported from previous versions of BlockSim may yield results that differ from the results originally obtained. In particular, results may differ in the following cases and/or for the following reasons:

- Simulation diagrams:
  - When multiple blocks are used in conjunction with subdiagrams, the underlying order of block expansion differs between versions, so results may differ.
In the Synthesis version, containers are treated as subdiagrams. The underlying order of block expansion differs between versions, so results may differ. However, some special cases will produce identical results. These include cases where:

- The container is the only block in the diagram.
- The container is at the end of the list in the original diagram (i.e., it was created last and has the highest block ID, which is automatically assigned by the software upon block creation).
- The load on contained load sharing blocks is calculated differently. Version 7 required a life-stress relationship for such configurations and based the re-calculation of load after block failure on that relationship; the Synthesis version calculates load using the weight proportionality factor as a multiplier.
- Normal/lognormal distributions have increased precision in the Synthesis version.
- Maintenance tasks that are performed at specified intervals (based on item age or calendar time) for multiple blocks are performed in a different order, producing results that are not identical, although the difference will not be statistically significant.
- Indirect cost is calculated differently. In version 7, the following was calculated at the end of the simulation:

\[ \text{Indirect cost} = \text{Average stock level} \times \text{Holding cost per item} \times \text{Simulation end time} \]

In the Synthesis version, the indirect cost is calculated for each simulation and then averaged at the end to yield the indirect cost that is shown. This is because holding cost per item may be a distribution in the Synthesis version.

- The order in which random numbers are assigned in general is by block ID. This means that if diagrams have the same blocks with the same IDs in both the previous version and the current version, the results will be identical. Standby containers represent an exception to this. In version 7, the order of blocks is overwritten by the standby priority. Therefore, results may not be identical with standby containers if the block IDs do not match the block standby priorities. The difference should not be statistically significant.
- For mirrored blocks, in version 7, the block that fails is the source and all the other mirrors are assigned these failures. In the Synthesis version, the failures are assigned to the mirrored block with the lowest block ID. If the failure source is not the block with the lowest ID, then the results will be different between versions.
• Mirrored blocks inside subdiagrams are handled differently. In version 7, they were treated as different groups of mirrors; the Synthesis version treats them as the same group. This may produce results that are statistically different.

• Throughput is not available in fault trees in the Synthesis version.

• The throughput property **Send units to failed blocks** works differently for subdiagrams in the Synthesis version, in that it applies to the whole diagram. That is, if the current block is set to not send units to failed blocks and the next block is a subdiagram that is not operating, then the throughput will be re-routed if possible or the current block will accumulate backlog.

• Phases have different rules on how interrupted events are handled and may give different results when re-simulating.

• In the Synthesis version, containers do not exist in maintenance phases. Thus, the availability results for containers in phase simulation may be different than in previous versions.

• **Analytical diagrams:**

  • The load on contained load sharing blocks is calculated differently. Version 7 required a life-stress relationship for such configurations and based the re-calculation of load after block failure on that relationship; the Synthesis version calculates load using the weight proportionality factor as a multiplier.

  • Mirrored blocks inside subdiagrams are handled differently. In version 7, they were treated as different groups of mirrors; the Synthesis version treats them as the same group. This may produce results that are statistically different.

• **Other issues of interest when opening BlockSim 7 files:**

  • Nodes do not have failure/maintenance properties in the Synthesis version. Therefore, if a node has failure properties in BlockSim 7, it will be imported in the current version as two blocks: a node with the $k$-out-of-$n$ and the throughput properties (if applicable) and a block with the failure properties positioned immediately after the node. If the node does not have failure properties, a second block will not be imported.

  • The load on contained load sharing blocks is calculated differently. Version 7 required a life-stress relationship for such configurations and based the re-calculation of load after block failure on that relationship; the Synthesis version calculates load using the weight proportionality factor as a multiplier. Because of this, if you convert a diagram that uses load sharing containers, you will need to manually configure the contained load sharing blocks after conversion.
• Simulation FRED reports will be imported, but cannot be restarted or have levels appended/removed until the diagram is resimulated.

In addition, certain rules apply when importing maintenance properties from BlockSim 7:

• Preventive maintenance:
  • For each preventive maintenance setting, a new task will be created. For example, if the preventive maintenance policy is set to be performed upon system down and upon system age, two tasks will be created.
  • For each task created, the duration, crews, restoration factor, etc. will be identical.

• Inspections:
  • For each inspection setting, a new task will be created. For example, if the inspection policy is set to be performed upon system down and upon system age, two tasks will be created.
  • For each task created, the duration, crews, restoration factor, etc. will be identical. Note that inspections do not use pools.
  • If a detection threshold is defined in version 7, an on condition task will be created instead of an inspection task in the Synthesis version. A threshold is defined in version 7 if a Failure Detection Threshold greater than 0 and less than 1 is specified or if a P-F Interval greater than 0 is specified.
    • The inspection properties from version 7 will be transferred to the inspection properties of the on condition task in the Synthesis version.
    • The threshold (i.e., detection) information from version 7 will be transferred to the failure detection properties of the on condition task in the Synthesis version.
    • The preventive maintenance properties from version 7 will be transferred to the on condition task (upon detection) properties of the on condition task in the Synthesis version.
  • If a detection threshold is defined in version 7 but no preventive maintenance properties are defined, then only an inspection task will be created (i.e., the threshold is ignored).
Chapter 18: Synthesis Platform Tools

- PM/Inspection based on group:
  - A task will be added and assigned to the maintenance group that the block belongs to. For example, if Block 1 belongs to Item Group 1 and has an inspection policy based on group maintenance in version 7, then in the Synthesis version an inspection task will be created and will be set to be performed upon group maintenance. Maintenance Group 1 will be checked in the list of groups that will trigger a maintenance, and Block 1 will be assigned to Maintenance Group 1.
  - If the block does not belong to a group, a task will not be added.
  - The corrective maintenance properties will be imported as corrective tasks.
  - A preventive maintenance action or an inspection based on maintenance phase and associated with a block in a standard phase will not be imported.

Converting Xfmea/RCM++ 5 Databases
This topic describes how to convert/import data from an Xfmea/RCM++ 5 database into a Synthesis repository.

For information about converting and importing data from an Xfmea/RCM++ 5 library, please consult the "Configurable Settings" chapter in the Xfmea/RCM++/RBI documentation.

Standard Databases (*.rx5)
For Xfmea/RCM++ 5 standard databases, you must convert the entire *.rx5 file to a new Synthesis standard repository. (Later, you can use the Import/Export Projects feature to copy specific projects into an existing database, if desired.)

Do the following:

1. In the Synthesis version of Xfmea, RCM++ or RBI, choose File > Open Repository.
2. Select RCM++ 5/Xfmea 5 (*.rx5) from the Files of type drop-down list.
3. Select the file you wish to convert and click Open.

The application will create a new standard database file in the same directory with the extension *.rsr11; the existing *.rx5 file will remain unchanged.

Enterprise Databases
For Xfmea/RCM++ 5 enterprise databases, you can select which analysis projects and settings you wish to import into a Synthesis enterprise repository that has already been created. You must be a member of the Admin group in the Synthesis enterprise repository to perform this task.

http://blocksim.reliasoft.com
Do the following:

1. Connect with the enterprise database you want to import into.
2. Choose **File > Manage Repository > Import from Version 5**.
3. In the area at the top of the Import from Version 5 Enterprise Database window, enter the connection information for the Version 5 enterprise database and click **Connect**.
4. The table shows all of the data and settings in the original database. Use the check boxes to select which data you wish to import and then click **OK** to start the transfer.

**Note:** If you are importing into a SQL Server database, the **Create SQL Server login** check box will be displayed at the bottom of the window. This is applicable only if you are importing user accounts. (See [SQL Server Logins or Using Windows Impersonation](#).)

**Conversion Assumptions and Tips**

When you convert data from an Xfmea/RCM++ 5 database, please consider the following assumptions and tips:

- **Conversion to Synthesis Resources**

  Certain types of information in the Version 5 projects will be converted to **resources** in the Synthesis version. This includes reliability information (which will be converted to models), controls and actions. In these cases, records that have identical properties will be merged into a single resource. For example, if there were two identical actions in the original project, a single action would be created as a resource in the Synthesis project and used in both locations.

- **Conversion to Security Groups**

  If you are working with secure databases, the access levels and access groups in Version 5 will be converted to **security groups** in Synthesis. Specifically:

  - **Repository-level security:** User permissions assigned by access level in Version 5 will be assigned by the corresponding security group in the Synthesis version. For example, if a user had the Admin access level in the original database, then that user will be assigned to the Admin security group in the Synthesis version. If there is no corresponding security group in the Synthesis version, the user will be imported with no security groups assigned, and a user with "Admin" access level permissions will have to manually assign security groups to the imported user.

  - **Project-level security:** For each access group in the Version 5 database, a security group will be created in the Synthesis repository. Because the Version 5 access
groups could have different access levels for different users in the same group, it is not possible to automatically determine which permissions should be assigned for the new security group in the Synthesis version. Therefore, these groups will initially be assigned the default permissions; you can edit the permissions via the Security Groups tab of the Users and Security window. Projects that had access limited by access group in Version 5 will continue to have their security set by the appropriate security group(s) at the project level in the Synthesis version.

- **Configurable Settings for Converted Projects**

  When you convert an existing project from Version 5, the application will add new configurable settings for new features that were added in the Synthesis version. For example, the configurable PFD Worksheet settings will be added to the interface style, the quantitative values will be added to the occurrence rating scale, etc.

  It is important to note that these default settings may need to be modified after the conversion. For details, please consult the "Configurable Settings" section in the Xfmea/RCM++/RBI documentation.

---

**Converting MPC 3 Databases**

If you have an existing systems and powerplant analysis that was created in MPC 3, it is easy to convert the *.rsm file into a new Synthesis repository.

Choose **File > Open Repository**, select MPC 3 (*.rsm) from the **Files of type** drop-down list, and then browse for the desired file.

When prompted to enter a username and password, enter the administrative login from the old *.rsm file.

**Note:** By default, a converted Version 3 database is a secure database that transfers any user accounts that were defined in the old database. After the new database has been created, the administrator should review the automatically created user accounts and update as appropriate. See **Security Options** for more information about database-level security.

The final step is to use the Tasks Conversion window to review the task records that will be imported and make any updates that may be needed (see details below). Once you have completed the review, click **OK** to start the import.

When the process completes, there will be a new standard database file in the same folder and with the same name as the original *.rsm file. The new file will have the extension *.rsr11 and the original *.rsm file will remain unchanged.
Chapter 18: Synthesis Platform Tools

Tasks Conversion Window
The Tasks Conversion window displays a list of all of the tasks defined in the original database and allows you to review how the records will be converted upon import. For any properties that are displayed with blue text, you have the option to change the task record data before it is imported.

Some task properties are handled a bit differently in the Synthesis version than they were in Version 3. Specifically:

- Some of the Task Types that were combined in Version 3 are now categorized separately in the Synthesis version (e.g., Operational Check (OPC) and Visual Check (VCK) are now separate task types).

- In Version 3, the task Interval was always stored as a text field. In the Synthesis version, you can choose whether each task's interval will be stored as a text field or if it will instead be recorded as a number with an associated time unit (e.g., 2000 flight hours can now be stored as value=2000 and time unit = FHr). Numbers may be easier to sort and will also make it possible to perform simulation-based reliability calculations if you choose to import the analysis project to RCM++ or RBI.

- The Zonal field from Version 3 is called Zonal Candidate in the Synthesis version. This is now a yes/no field that can be set to Yes only if the failure effect categorization (FEC) is set to 5 or 8 (i.e., a safety issue) and the task type is "General Visual Inspection (GVI)." Also in the Synthesis version, the Zone field will be enabled only if Zonal Candidate is set to Yes.

The following subsections describe the default conversion logic for Task Type, Interval and Zone.

Task Type
For the Discard and Restoration task types, there is no difference between Version 3 and the Synthesis version. The text in the Task Type (New Value) column will be displayed in italics to indicate that this property cannot be changed via the Tasks Conversion window.

```
<table>
<thead>
<tr>
<th>Task Type (Old Value)</th>
<th>Task Type (New Value)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discard (DS)</td>
<td>Discard (DIS)</td>
</tr>
<tr>
<td>Restoration (RS)</td>
<td>Restoration (RST)</td>
</tr>
</tbody>
</table>
```

For the remaining task types, the software will use the logic specified below to suggest a task type, but the property will be displayed in blue text to indicate that it can be edited. If you disagree with the default selection, you can choose one of the other eligible task types from the drop-down list, as shown in the following example.
When the task type was set to **Inspection/Functional Check (IN)** in Version 3, the following logic will be applied in the specified order. For example, if the task description contains both the word "Visual" and the word "Function," the General Visual Inspection task type will be applied by default because the word "Visual" will be matched first.

<table>
<thead>
<tr>
<th>If the task description contains:</th>
<th>The default option is to import the task as:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visual</td>
<td>General Visual Inspection</td>
</tr>
<tr>
<td>Special Detail</td>
<td>Special Detailed Inspection</td>
</tr>
<tr>
<td>Health Monitor</td>
<td>Scheduled Structural Health Monitoring</td>
</tr>
<tr>
<td>Function</td>
<td>Functional Check</td>
</tr>
<tr>
<td><strong>none of the words/phrases listed above</strong></td>
<td>Detailed Inspection (DET)</td>
</tr>
</tbody>
</table>

When the task type was set to **Lubrication/Servicing (LU)** in Version 3, the default option is to import the task as Servicing (SVC) if the task description contains "Servic" and as Lubrication (LUB) if it does not.

When the task type was set to **Operational/Visual Check (OP)** in Version 3, the default option is to import the task as Visual Check (VCK) if the description contains "Visual" and as Operational Check (OPC) if it does not.

**Tip:** The task types in the Synthesis version of MPC are determined by the requirements of the MSG-3 guidelines and cannot be changed. However, the abbreviations can be configured to fit your particular preferences. If you want to change the default task type abbreviations (e.g., if you don't want to use DIS for Discard, RST for Restoration, etc.), click the **Task Type Abbreviations** button. The changes that you make in the Define Task Type Abbreviations window will automatically apply to all analyses in the current database. This window is also accessible from **File > Manage Repository > Task Types.**
Interval Type and Interval

Two options are displayed at the top of the Tasks Conversion window to determine how the task intervals will be imported:

- If you choose **Transfer all intervals as text**, the interval type for all imported task records will be set to **Based on Events (Text)** and the interval will be stored as a text field (just like in MPC 3). The Interval (New Value) column will be displayed in blue text to indicate that you can change the text if desired before the import.

- If you choose **Transfer intervals as numeric if possible**, the application will check to see if the original task interval begins with a number and is followed by a space and at least one text character. If it does (e.g., "2000 flt/hr"), the default option is to import it as a number with an associated time unit. If not (e.g., "Per Mfg Life Limit"), the default is to import as text. Either way, you have the option to change both the interval type and new value before the import. For example:

  ![Interval Conversion Table]

  **Tip:** If you want to change the time units displayed in the drop-down list, click the **Time Units** button. The changes that you make in the **Time and Usage Units window** will apply immediately to the tasks that you are currently importing, and also to all other analyses you may later add to this database. This window is also accessible from **File > Manage Repository > Time and Usage Units**.

The Tasks Conversion window uses a variety of techniques to try to match the text field from Version 3 with one of the specified time units in the Synthesis version. There will be a match if...
the name or abbreviation of a Synthesis version time unit either starts with or contains the text in the Version 3 field. For some predefined time units, the software also recognizes other commonly used abbreviations for the time unit (e.g., the software will recognize any of the following abbreviations as flight hours: Flt/Hr, Flight H, Flt H or Flt/H).

If your data set contains a task interval that is not recognized, you can do any of the following:

- Edit the text in the Interval (New Value) column so it will match either the name or the abbreviation of a predefined time unit. For example, if the Version 3 task record contains a misspelling for "2000 flight hours," you can click inside the cell and remove the extra i.

- Click the Time Units button and define a new time unit for the database with a name or abbreviation that matches the data you want to import. For example, if the Version 3 task record has an interval of "5 Weeks," you can open the "Time and Usage Units" window and create a new time unit with the name "Weeks."

- Click Cancel to close the Tasks Conversion window then edit the original tasks in MPC 3 before starting the import again.

Zonal Candidate and Zone

If all of the following conditions are met, the Zonal Candidate (New Value) column will be set to Yes by default and any information from the Zone field will be transferred during the import:

- The failure effect categorization (FEC) is set to 5 or 8 (i.e., it is a safety issue).
- The Task Type is set to General Visual Inspection (GVI).
- The Zonal property in the original MPC 3 analysis contains the word "Transfer."

If you don't want the task to be considered for zonal analysis even though it meets the requirements, you can click inside the Zonal Candidate (New Value) column and choose No from the drop-down list. If this column displays No in italics, this indicates that at least one of these conditions is not met and the property cannot be changed.

<table>
<thead>
<tr>
<th>Zonal (Old Value)</th>
<th>Zonal Candidate (New Value)</th>
<th>Zone (Old Value)</th>
<th>Zone (New Value)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transfer</td>
<td>Yes</td>
<td>400</td>
<td>400</td>
</tr>
<tr>
<td>-</td>
<td>No</td>
<td>400</td>
<td></td>
</tr>
<tr>
<td>Transfer</td>
<td>Yes</td>
<td>400</td>
<td>-100</td>
</tr>
<tr>
<td>No</td>
<td>Yes</td>
<td>400</td>
<td></td>
</tr>
</tbody>
</table>

http://blocksim.reliasoft.com
Importing/Exporting Projects

All Synthesis desktop applications make it easy to import or export selected projects from one database to another.

Note that when importing/exporting a project between databases, any resources and FMEAs used by the project will be automatically imported/exported along with the project as local resources, even if they were originally reference resources or global resources. If you do not want the reference resources to be converted to local resources, you must import the both the project and the reference project at the same time. (See Local, Global and Reference Resources.)

To import a project, first choose Project > Management > Import/Export.

In MPC, the Import/Export window opens directly. In all other applications, a wizard displays the options that are relevant for the current application. Select Projects and click OK.

Once the Import Projects or Export Projects window is open, do the following:

1. Use the drop-down list or browse icon to select the database that you want to import from or export to.
   - This can be any existing standard database (*.rsr11) or enterprise database connection file (*.rserp).
   - If you are exporting, you can also use the add icon to create a new standard database to export into.

2. The tree displays the projects that are available to be imported or exported. If desired, you can use the Filter and Find tools to limit the list of projects displayed. (See Project Manager.)

3. Use the check boxes to select which project(s) you want to import/export then click OK to copy the data.
The following considerations apply:

- The names of projects must be unique within each Synthesis repository. If you attempt to import/export a project with a name that already exists in the destination database, the application will automatically increment the name. For example, if "Project1" already exists, the new project might be renamed to "Project1_1."

- If the project has a category, the application will first attempt to match it to an existing category in the destination database. If a matching category does not already exist, and you have the permission to create project categories in the destination database, it will be created automatically.

- If you select a project of a type that you don't have permission to create in the destination database (private, public or reference), it will be converted to a type that you do have permission to create. For example, if you select to import a reference project but you don't have the "Create and own reference projects" permission in the destination database, the project will be imported as a public or private project, and any links from other projects will be broken.

**Importing/Exporting Project Items or Resources**

When applicable, Synthesis applications make it easy to import/export selected project items (e.g., folios, diagrams, plot sheets, Synthesis Workbooks, etc.) or Synthesis resources (e.g., models, maintenance tasks, etc.) between existing projects. The projects can be in the same database or in different databases.

First, open the project you want to import to or export from. Then open the import/export window, there are two ways:

- If you have selected the Allow multiple projects option in the Synthesis Settings page of the Application Setup, you can open both projects simultaneously and then drag/drop items from one project to another.

  OR

- Choose Project > Management > Import/Export.

  ![arrow]

In the wizard, choose Items (not available for Xfmea/RCM++/RBI and MPC) or Resources (not available for MPC) and click OK.
Once the Import window or Export window is open, do the following:

1. Use the drop-down list or browse icon to select the database you want to import from or export to.
   - This can be any existing standard database (*.rsr11) or enterprise database connection file (*.rserp).
   - If you are exporting, you can create a new standard database and project by clicking the icon.

2. Use the tree in the Source Project or Destination Project area to select the project you want to import from or export to. If desired, you can use the Filter and Find tools to limit the list of projects displayed. (See Project Manager.)

3. Use the check boxes in the Items to Import or Items to Export area to select which project items or resources you want to import/export.
   - For project items, this area will display the same folders that appear in the current project explorer. A +/- icon next to the folder indicates that it contains at least one project item that can be imported or exported.
   - For resources, this area will display a folder for each type of Synthesis resource that exists in the selected project.

4. Click Import or Export to copy the data.

Note: The names of project items and resources must be unique within each Synthesis project. If you attempt to import/export something with a name that already exists in the destination project, the application will automatically increment the name. For example, if "Folio1" already exists, the new folio might be renamed to "Folio1_1," "Folio1_2," etc.

Keeping Associated Items/Resources Together
The application will automatically copy any item/resource that is linked to the imported or exported item, even if you did not specifically select to import/export them. Some examples:

- A multilplot, such as an overlay plot, side-by-side plot, or 3D plot, will automatically import/export a copy of the folios or diagrams that were used to generate the plot.
Chapter 18: Synthesis Platform Tools

- A **BlockSim diagram** will automatically import/export a copy of any utilized subdiagrams and resources.
- A **RENO flowchart** will automatically import/export a copy of any utilized subcharts, resources and Synthesis Workbooks.
- A **Synthesis Workbook** or **special analysis folio/tool** (e.g., allocation analysis, stress-strength analysis, etc.) will automatically import/export a copy of its data sources.
- A **URD** will automatically import/export a copy of the models, maintenance tasks, crews, etc. that were used to build the URD. The same applies to any resource that is built upon another resource.

Note that when importing/exporting project items between databases, the resources are imported/exported as local resources in the destination database, even if they were originally reference resources or global resources. For more information on how importing/exporting affects a resource, see [Local, Global and Reference Resources](http://blocksim.reliasoft.com).

**Tip:** If you do not want a RENO flowchart to import/export an associated resource or workbook, you can enclose the resource/workbook name in single quotes to reference it by name only. For example, if you export a diagram that contains a block using the expression `'Model1'(1000)`, Model1 will not be transferred along with that diagram. If the destination project already contains a model called Model1, that model will be used in simulating the transferred diagram.

---

### Importing from Excel or Delimited Text Files into a Folio

In Weibull++/ALTA and RGA, it is easy to import data from any of the following file types into a folio.

- Excel files (*.xls, *.xlsx)
- Tab, comma, space and semicolon delimited files (*.txt, *.csv, *.prn, *.smc)

**Tip:** Other Synthesis applications use different tools for importing/exporting via Excel (i.e., for importing Bill of Materials data in Lambda Predict and failure mode data in Xfmea/RCM++/RBI and MPC). For more information about those features, please consult the documentation for each particular application.

First, open the project that you want to import into and choose **Project > Management > Import/Export**.

---

632  [http://blocksim.reliasoft.com](http://blocksim.reliasoft.com)
In the wizard, choose **Other file** and click **OK**.

Browse for the file you wish to import from and click **Open**. Note that:

- In DOE design folios, the data will be copied into a new free form folio, where you can then designate columns for factors and responses and analyze the data. If you are importing from an Excel file that has multiple worksheets, the sheet that was active the last time the file was opened will be used.

- In Weibull++/ALTA and RGA, you will need to specify which data will be imported and how it will be mapped to the columns in the particular type of data folio. The rest of this topic describes how to map the data for import into a Weibull++, ALTA or RGA data folio.

**Selecting Which Data Sheets Will Be Imported**

The left side of the utility displays the data from the Excel or delimited text file that is currently selected. If you wish to open a different source file, click **Open**.

If you are importing from an Excel file that has multiple worksheets, use the tabs at the bottom of the window to view and set the import preferences for each sheet.

Use the options at the top of the control panel for each sheet to specify whether the data will be imported.

- **Do not import sheet**: The control panel will not contain any other options and the data will not be imported.

- **Import sheet**: The control panel displays the options you need to either manually map the columns or use a template to automatically apply the same mapping that was used for another file.

**Using the Control Panel to Map the Columns That Will Be Imported**

If you are not using a template, or if you need to modify the settings after an import template has been applied, do the following:

1. Use the **Data Type** drop-down list to specify which type of folio to import into. This can be different for each sheet, and it determines which options will be available in the rest of the control panel.

2. Click inside each column that you wish to import and then click the corresponding button in the control panel to map it to a column in the data folio. This updates the column heading and maps the data to a column in the data folio.

   - If the heading displays a letter, the data in that column will not be imported.
Chapter 18: Synthesis Platform Tools

- If the heading displays a name, the data will be imported to the column associated with that name.

- To remove the column mapping, click inside the column and click the corresponding button again.

As an example, the following picture shows data that will be imported into a Weibull++ life data folio. Column A will not be imported. The rest of the data has been assigned to columns that are used in the folios.

3. If you are importing to an ALTA life-stress data folio, use the Number of Stresses field to specify how many stress columns will be created in the new folio (maximum = 8). Note that:
   - If you enter a value that is less than the number of columns that were mapped with the Stress button, the "extra" stress column data will not be imported.
   - If the number is greater, the additional stress columns will be created in the new folio and you can enter the data later.

4. If the source file contains column headings or other introductory material that should not be imported, use the Start from Row field to specify where the actual data begins. For example, in the picture above, the first row contains heading labels so the data import should begin from Row 2.

Setting the Import Template Directory

If you will be importing data from multiple files that have the same structure, you can use saved template files (*.waim in Weibull++/ALTA or *.rgaim in RGA) to automatically map the columns for all other similar files that you need to import from.

By default, template files will be stored at C:\Users\<username>\AppData\Roaming\ReliaSoft\<application>\Import Templates. This
directory determines which templates will be displayed in the Import Template drop-down list in the control panel. It also sets the default path for saving any new templates you create.

If you want to access templates from a different location, click the Import Template Directory button at the top of the window and select a different folder.

**Creating a New Import Template**

1. Open a data file and use the control panel buttons to map the columns.
2. Click the Save icon in the Import Template area on the control panel.
3. Specify a name and click Save.

**Applying a Saved Import Template**

1. Open the data file and select Import sheet to display the rest of the control panel options.
2. Make sure the Import Template Directory is set to the folder that contains the applicable template file(s).
3. Use the drop-down list in the Import Template area to select the template you want to apply.

The utility will automatically assign the column mappings defined in the template. If desired, you can use the control panel to make further adjustments before import.

4. When you are satisfied with the mapping, click Import to create the new folio.

**Tip:** If you make adjustments after applying the template, you have the option to click Save in the Import Template area to either replace the existing template, or create a new template with a different name.
Chapter 18: Synthesis Platform Tools

Importing the Data
When you are ready to import the data, click the Import button.

By default, the application will import the data into a new folio. The status bar will display "Import into New Folio," as shown in the following example.

If you prefer to import into an existing folio instead, click the Import to Existing Folio button and choose one of the available folios. When you return to the import window, the status bar will now display the name of the selected folio, as shown in the next example.

Using XML in BlockSim and Lambda Predict
In BlockSim and Lambda Predict, you have the option to use XML (extensible markup language) files to import or export system configuration data and item properties. XML files can be used to transfer data to/from other applications or database systems.

In BlockSim, the XML files include the block properties and information about how the blocks are connected in a reliability block diagram or fault tree diagram. They do not include visual aspects such as diagram style settings, block style settings, etc. BlockSim supports both import and export via XML.

In Lambda Predict, the XML files include the structure of the system hierarchy in a prediction folio and some of the item properties. Lambda Predict supports export to XML.

Exporting to XML
To create an XML file, first open the project and then choose Project > Management > Import/Export > Export.

In the wizard, choose Other file and click OK.

Specify the desired pathname/filename and click Save. This will export the relevant information for all of the diagrams or prediction folios in the current project. Other project items (such as RENO flowcharts, plots, attachments, etc.) are not included.

Importing from XML
There are two ways to import from an XML file.

http://blocksim.reliasoft.com
If you want to import to a new project in a new standard database:

1. Choose **File > Open Repository**.
2. Browse for the file and click **Open**.

If you want to import to a selected project in an existing standard database or enterprise database:

1. Create a new project or open an existing project that you want to import into.
2. Choose **Project > Management > Import/Export > Import**.

In the wizard, choose **Other file** and click **OK**.
3. Browse for the file and click **Open**.

**Attachments**

All Synthesis desktop applications allow you to attach URLs and/or files that were created in other applications. This helps you to keep supporting documentation all together in the same place with your analysis. The locations where you can attach files will vary depending on which Synthesis application you are using.

In all Synthesis desktop applications, attachments can be either linked or embedded.

- **Linked** attachments may be URLs or files. For these attachments, the software stores the path to the URL or file. This allows you to open the resource in its original location (e.g., Internet, intranet or network directory), provided that the necessary software is installed on your computer and the link is valid. The files themselves are not stored inside the database. If your organization chooses to implement a web-based Synthesis Enterprise Portal (SEP) for an enterprise database, note that File Links (i.e., stored paths to local files on your computer or network) will not be accessible in most web browsers due to security settings. When you delete a file link or URL, this simply removes the link, leaving the original file untouched.

- **Embedded** attachments are always files (i.e., you cannot embed a URL). For these attachments, the software stores a complete copy of the attached file inside the database. Please note that embedded attachments will increase the file size of the database. When you delete an embedded file, the actual file is deleted from the database and this cannot be undone (unless you happen to have a saved backup or restore point that you could roll back to).
Two windows are used to work with attachments. The Attachments window allows you to manage all of the URLs/files attached to a particular location (e.g., project, resource, hierarchy record or block).

The Add/Edit Attachment window is used to specify the details of an individual file or URL, and will be displayed whenever you choose to create or edit an attachment.

If you are attaching a file, the Address field will display a Browse icon (📁) so you can select the file to be attached.
If you are attaching a URL, the **Name** field will be populated automatically as you type the URL into the **Address** field. This is for your convenience only and you can specify a different name if desired.

**Attachment Locations**
As mentioned above, the locations where you can attach files will vary depending on which Synthesis application you are using.

*Tip:* In most cases, the caption bar in the Attachments window will provide an indication of which type of attachment you are working with. For example, when you are working with project-level attachments, the caption bar will indicate "Project:" followed by the specific name of the project.

**Project Attachments**
All Synthesis desktop applications support attachments at the project level. In all applications, project attachments can be displayed/managed from the **Attachments** icon in the Project Properties window.

For most applications, project attachments can also be displayed/managed from the Attachments folder in the current project explorer.

In Xfmea, RCM++, RBI and MPC (which do not have a current project explorer), you can also access the project attachments by selecting **Project > Synthesis > Attachments**.

**Synthesis Resource Attachments**
All of the applications that utilize Synthesis resources support attachments at the resource level. For example, you can attach a file to a URD, a model, etc.
Chapter 18: Synthesis Platform Tools

To access attachments for an existing resource, you can click the Attachments icon in the resource’s properties window.

Hierarchy Attachments
Some applications, including Xfmea, RCM++, RBI, Lambda Predict and MPC, support attachments for individual items or records in a system hierarchy or analysis hierarchy. For example, in Xfmea, you can create attachments for a particular item, or for a particular record in the FMEA for that item.

To access attachments for items or records in a hierarchy, you can double-click inside the Attachments column. (If this column is not displayed on your computer, right-click inside the column headings and choose Customize Columns.) You can also choose Tools > Attachments on the ribbon tab for the hierarchy that you are currently working with.

For records in an analysis hierarchy (such as FMEA or functional failure analysis), the attachment icon can also be accessed from within the record properties window.

Block Attachments
BlockSim supports attachments for individual blocks in a diagram. To access attachments for a block, you can click the Attachments icon in the Block Properties window.

Select Existing Text Window
The Select Existing Text window provides a list of existing descriptions that might apply to the current text field or analysis. This can help to save time on data entry, ensure consistency and facilitate brainstorming. The utility is used extensively in applications such as Xfmea, RCM++, RBI and MPC, and it is also available for certain text fields in other Synthesis desktop applications.
In Version 11, there are now two ways this utility might be used:

- **Replace or append text in the current field** - If you click the icon inside a text field, you can select one description and either replace the current text or append the new text to the end.

- **Create one or multiple new records** - If you use one of the ribbon commands in an FMEA or P-Diagram (e.g., Add Multiple Functions > Select Existing Text), you can select multiple descriptions and the utility will use your selection(s) to create new record(s).

The options will vary depending on the record/field type, and whether you are updating a single description or adding new records. The following example shows how the tool may be used to populate the function description in an FMEA.

![Image of tool usage]

**Tip:** The descriptions are sorted alphabetically under each heading. When the table has focus, you can type a letter to move to the next description that begins with the letter.

### Project and Item Filters

This window utilizes the same project and item filters that are available in many other locations throughout Synthesis desktop applications. For example, when searching for text for an item in the system hierarchy, you could use a Project Filter to search for analyses performed by Department A and then use an Item Filter to show only those analyses that were modified in the last month.

![Image of filters]

In addition, when applicable:

- **Current Project** limits the results to data in the current project.
**Current Item Branch** limits the results to those found in the current branch of the system hierarchy.

**Record Filter**

When applicable, the **Record Filter** shows the possible sources for the current record type and field that you can choose to include or exclude. The specific **record types** vary depending on the field.

![Record Filter Image]

**Phrase Sets**

FMEA records in Xfmea, RCM++ and RBI also have the option to include text from selected phrase sets.

![Phrase Sets Image]

**Field Text**

Use the drop-down list in the **Field Text** area to specify how to match the specified keywords, then type the keywords into the input box.

- **Contains** returns descriptions that contain the exact string entered.
- **Contains Any** and **Contains All** allow you to enter multiple keywords (separated by commas) and returns descriptions that contain at least one (any) or all of the keywords entered.
• **Begins With** returns descriptions where the exact string entered appears at the start of the field.

• **is** returns descriptions where the exact string entered matches the whole field.

**Record Filter Options**
When the descriptions can be obtained from more than one type of analysis (e.g., when PFMEA failures can be copied from FMEA causes, or when control plan operations can be copied from PFD Worksheet operations), the headings in the table identify the source. You can use the Record Filter to specify which source(s) to include.

**FMEAs**

<table>
<thead>
<tr>
<th>FMEA Functions</th>
<th>System Hierarchy Items</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>P-Diagram Ideal Responses</td>
</tr>
<tr>
<td></td>
<td>PFD Worksheet Operations</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>FMEA Failures</th>
<th>P-Diagram Error States</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>FMEA Causes</td>
</tr>
<tr>
<td></td>
<td>PFD Worksheet Product Characteristics</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>FMEA Effects</th>
<th>FMEA Failures</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>FMEA Causes</th>
<th>P-Diagram Change Over Times</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>P-Diagram Control Factors</td>
</tr>
<tr>
<td></td>
<td>P-Diagram Piece-to-Piece</td>
</tr>
<tr>
<td></td>
<td>PFD Worksheet Process Characteristics</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>FMEA Controls</th>
<th>Control Plan Methods</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>DVP&amp;R Test/Specification Methods</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>FMEA Actions</th>
<th>DVP&amp;R Test/Specification Methods</th>
</tr>
</thead>
</table>

**P-Diagrams**

<table>
<thead>
<tr>
<th>Input Signal</th>
<th>System Hierarchy Items</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Control Factors</th>
<th>FMEA Causes</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Error States</th>
<th>FMEA Failures</th>
</tr>
</thead>
</table>
### Ideal Response

<table>
<thead>
<tr>
<th>Ideal Response</th>
<th>FMEA Functions</th>
</tr>
</thead>
</table>
| Piece-to-Piece | Analysis Plan Assumptions  
FMEA Causes  
PFD Worksheet Product Characteristics |
| Usage          | Analysis Plan Assumptions |
| Environment    | Analysis Plan Assumptions |
| Change Over Time | Analysis Plan Assumptions  
FMEA Causes |

---

### Control Plans, PFD Worksheets and DVP&Rs

| Control Plan Part/Process Number | FMEA Functions  
PFD Worksheet Operations |
|----------------------------------|----------------------|
| Control Plan Process Name/Operation Description | FMEA Functions  
PFD Worksheet Operations |
| Control Plan Product Characteristic | PFD Worksheet Product Characteristic  
FMEA Causes  
FMEA Failures |
| Control Plan Process Characteristic | PFD Worksheet Process Characteristics  
FMEA Causes |
| Control Plan Method              | FMEA Controls |
| PFD Worksheet Operation Description | System Hierarchy Items |
| DVP&R Test/Specification Method  | FMEA Controls  
FMEA Actions |
Check Spelling
Synthesis desktop applications offer the ability to check the spelling of your text. This utility is available in different places within the software. For windows that offer the spell check functionality (e.g., Project Properties window, etc.), the Check Spelling icon will be displayed within the window itself. For data sheets, spreadsheets and system hierarchies that offer the functionality, the Check Spelling icon will be available on the ribbon and you can access it by choosing Home > Edit > Spelling.

Note: In system hierarchies (Xfmea, RCM++, RBI, MPC and Lambda Predict), the utility will check the property fields of the selected item only. This means that sub-items and text in analysis tabs, such as the FMEA tab in Xfmea, are not checked.

Whenever text that is not in the application's dictionary is found, the Check Spelling window displays the text in question and offers a list of suggestions to verify the error or confirm the correction, as shown in the following example.

- Ignore Once ignores the current instance of the highlighted word but continues to highlight it if the same word appears again.
- Ignore All ignores all instances of the word in the current form.
- Add to Dictionary adds the highlighted word to the dictionary on your computer so the spell checker will not treat it as a misspelling. The dictionary file is saved in the default Documents folder on your computer (e.g., My Documents\ReliaSoft\Dictionaries).
- Change replaces the current instance of the highlighted word with the word that is currently selected in the Suggestions area. If no word is selected, the first one will be
used. Double-clicking a word in the Suggestions area is another way to change the highlighted text.

- **Change All** replaces all instances of the highlighted word with the word that is currently selected in the Suggestions area. If no word is selected, the first one will be used.

- **Options** opens the Spelling Options window, which provides additional settings to how the spell checker functions:
  
  - The **General options** area provides a list of the types of text that can be ignored by the spell checker (e.g., numbers, e-mail addresses, etc.). Select or clear each check box to specify how the spell checker will work on your computer.
  
  - In the **Edit custom dictionary** area, the **Edit** button opens a window that displays all of the words that you have added to the custom dictionary on your computer. You can edit the custom dictionary by adding or removing words in the list and then clicking **OK**.

  - **International dictionaries** allows you to choose the language of the dictionary that will be used on your computer.

  - **Undo Last** reverses the last change that was made.

**Results Window**

The Results window is used in many Synthesis applications to show detailed calculation results. From this window, you can edit the results, copy the results to the Clipboard or print the results.

- **Paste** pastes the contents of the Clipboard into the current control.

- **Cut** cuts the selected text to the Clipboard. Data stored in the Clipboard can be pasted into this and other applications.

- **Copy** copies the selected text to the Clipboard. Data stored in the Clipboard can be pasted into this and other applications.

- **Paste Special** opens the Paste Special window, which allows you to paste specific cell contents or attributes (such as formulas, formats, or comments) from the Clipboard.

- **Quick Print** sends the current document directly to the default printer without making changes.

- **Print** opens the Print window, which allows you to specify the printer and the printing options.
- **Send to Excel** allows you to save the current selection as a Microsoft Excel (*.xls) file and then opens that file in Excel, if it is installed on your computer.

Note that the Results window may contain multiple sheets, accessible via the page index tabs at the bottom of the window.

### Quick Parameter Estimator (QPE)

The Quick Parameter Estimator (QPE) allows you to estimate the parameters of a distribution based on information you have about the reliability of a product, the probability of an event occurring or the typical duration of a task. In all Synthesis desktop applications, you can open the QPE from the Model properties window or the Model wizard by clicking the QPE icon.

In Weibull++/ALTA, it's also accessible from the Home tab of the ribbon and several analysis interfaces (including the Weibull++ life data folio, the Monte Carlo and SimuMatic utilities, and the Expected Failure Times Plot).

The QPE includes a Wizard view and an Expert view, described below. You can toggle between the different views by clicking the Use Expert or Use Wizard button at the bottom-left corner of the window.

- The **Wizard view** automatically selects a distribution and estimates that distribution's parameters based on your responses to a series of questions. The first page of the Wizard view asks you to choose among three different types of models that you can build with the QPE. Subsequent pages will ask more specific questions related to your selected model.

- The **Expert view** allows you to estimate the parameters of a distribution using either two unreliability values at specified times or one unreliability value and the other parameter(s) of the distribution. Unlike the Wizard view, you must select a distribution to solve the parameter(s) for.

### Quick Parameter Estimator Wizard View

To use the Wizard view of the Quick Parameter Estimator (QPE), simply follow the prompts on each page. The first page will present and describe three different types of models that you can build with the QPE. Below are the three models and the kind of information you'll need to provide in subsequent pages.
To build a **Reliability model** you need to provide information about:

- How age affects the product's reliability.
- The product's intended design life and the estimated warranty time.
- Best-case, worst-case and most likely unreliability estimates for the product at the end of the design life and warranty time.

To build an **Event occurrence model** you need to provide information about:

- Whether age affects the probability of the event's occurrence.
- Best-case, worst-case and most likely estimates for how often the event will occur.

To build a **Task duration model** you need to provide information about:

- Best-case, worst-case and most likely estimates for how long it will take to complete the task.

The last window will display the tool's selected distribution and the calculated parameters. It will also provide one of the two options described below.

- If you opened the QPE from an analysis folio or utility, the **Update** button will be available in case you wish to update that window using the selected distribution, calculated parameters and selected time units.
- In Weibull++/ALTA, if you opened the QPE from the ribbon, the **Finish & Copy** button will be available in case you wish to copy the parameters results to the Windows Clipboard.

---

**Quick Parameter Estimator Expert View**

Follow the steps below to use the Expert view of the Quick Parameter Estimator (QPE):

- Choose a distribution from the **Distribution** drop-down list. This is the distribution that you will solve the parameter(s) for. Then choose the appropriate time units from the **Units** drop-down list.
  - If you are not sure which distribution to select, consider using the **Wizard view** of the QPE instead.
  - Your choice of time units applies to all time inputs and applicable parameters of the distribution (such as the eta parameter when the Weibull distribution is used).
• Select an appropriate option in the **Quantification Method** area.

  • The **Unreliability and a Parameter** method solves for one parameter of the distribution. It requires one unreliability point (i.e., an unreliability value at a specified time) and the values of all the parameters of the selected distribution except the parameter you will solve for.

    • If you select this method, you must then enter one unreliability point in the **Point #1** area. For example, if you believe that your product has an unreliability of 10% at 100 hours, then you would enter **100** in the **Time** field and **0.10** in the **Unreliability** field.

    • In the **Solve for Parameter** area, select the parameter that you wish to solve for. The remaining parameters in this area will have input fields enabled. Enter the known values of these parameters.

  • The **Two Unreliability Points** method solves for all the parameters of the distribution. It requires two unreliability points that you will provide in the **Point #1** and **Point #2** areas.

    *Tip:* If you are building an event occurrence or task duration model, you can treat an "unreliability" point as the probability that an event will occur or that a task will be completed by a specified time. For example, if you are modeling the probability of an event's occurrence and you believe that there is a probability of 30% that the event will occur before 150 hours, then you would enter **0.3** in the **Unreliability** field and **150** in the **Time** field.

• Click **Calculate** to solve for the unknown parameter(s).

• Click the **Update** button to update the model using the selected distribution, calculated parameters and selected time units.

**Quick Parameter Estimator (ALTA)**

In ALTA only, another version of the Quick Parameter Estimator (QPE) allows you to estimate the parameters of a model based on information you have about the reliability of a product at normal and accelerated stress levels. You can open the QPE from the ribbon by choosing **Home > Tools > Quick Parameter Estimator (ALTA).**

You can also open the ALTA QPE from the ALTA life-stress data folio (by leaving the folio's data sheet empty and clicking Calculate), as well as the stress-dependent Monte Carlo and stress-dependent SimuMatic utilities.
Chapter 18: Synthesis Platform Tools

Follow the steps below to use the ALTA QPE:

- The first page of the window will be used to estimate the product's mean life under normal stress conditions.
  - Choose a model from the Model drop-down list. This is the model that you will solve the parameter(s) for. Then choose the appropriate time units from the Units drop-down list.
    - Your choice of time units applies to all time inputs and applicable parameters of the model (such as the eta parameter when the Weibull distribution is used).
  - Select an appropriate option in the Quantification Method area:
    - The Unreliability and a Parameter method solves for one parameter of the model. It requires one unreliability point (i.e., an unreliability value at a specified time) and the values of all the parameters of the selected model except the parameter you will solve for.
      - If you select this method, you must then enter one unreliability point for normal use conditions in the Point #1 area. For example, if you believe that your product has an unreliability of 10% at 100 hours under normal use conditions, then you would enter 100 in the Time field and 0.10 in the Unreliability field.
      - In the Solve for Parameter area, select the parameter that you wish to solve for. The remaining parameters in this area will have input fields enabled. Enter the known values of these parameters.
    - The Two Unreliability Points method solves for all the parameters of the model. It requires two unreliability points under normal use conditions that you will provide in the Point #1 and Point #2 areas.
  - In the Use Stress Level area, you must enter the stress level that the product will experience under normal conditions. In multi-stress situations, this stress level will be a combination of stress values for each stress type.
    - If the Number of Stresses field is enabled, enter the number of stresses that will be used in your model. (Note that different models have different requirements for the number of stresses that can be used.)
    - Click the arrow inside the Use Stress Value(s) field. In the table that appears, enter a stress value for each stress type. If there are multiple stress values, they will appear in the field separated by semicolons.
• Click Next > to go to the Life at Each Stress Level page. The Use Stress Level area of the page will display the product’s mean life at the specified use stress level based on your previous inputs. In the Accelerated Level 1 area, you must enter the estimated mean life for the product at an accelerated stress level.

• To enter the accelerated stress level, double-click inside the Stress Value(s) field. In the table that appears, enter the stress value for each stress.
In the Characteristic Life field, enter the product's characteristic life at the associated accelerated stress level.

- For the Weibull distribution, the characteristic life is equal to the value of the eta parameter (i.e., the time at which unreliability = 63.2%).
- For the lognormal distribution, it is equal to Exp(Log-mean) (i.e., the time at which unreliability = 50%).
- For the exponential distribution, it is equal to the mean life.

Note: The number of accelerated stress levels you must provide life estimates for will equal the number of stresses that will be used in the selected model. For example, if the model uses two stress types, as shown above, then there will be an Accelerated Life 2 area in which you must provide a characteristic life estimate for a second accelerated stress level.

Click Next > again to see the calculated parameters.

- If you opened the QPE from another utility, such as the ALTA Monte Carlo tool, you may click the Update button if you wish to update the Monte Carlo tool with the model, parameters and time units defined in the QPE.
- If you opened the QPE from the ribbon, you may click the Finish & Copy button if you wish to copy the results to the Windows Clipboard.
Chapter 19: Synthesis Resources

In Synthesis applications except MPC, resources contain various types of information that can be shared between analyses. Resources may be created in one application and then shared with other Synthesis applications where they may be relevant. When the resource is updated with new information, the change is reflected in all analyses that rely upon it.

An example of a Synthesis resource is a model that represents a product's probability of operating successfully over time. The model may be defined manually or published from an application such as Weibull++/ALTA, RGA or Lambda Predict. Then it can be used in applications such as BlockSim, Xfmea, RCM++ or RBI as part of the universal reliability definition (URD) of a particular component/assembly.

Note: In a secure database, the ability to create, edit and delete resources is available only if the user a) is the project owner, b) has the applicable "resources" permissions, or c) has the applicable "manage all projects" permissions.

Types of Resources
The following tables describe the types of resources that you can use in different Synthesis applications. These resources can be created while you're performing an analysis and also from the Resource Manager. (In a secure database, the ability to create, edit and delete resources is available only if the user a) is the project owner, b) has the applicable "resources" permissions, or c) has the applicable "manage all projects" permissions.)

Used in Multiple Applications

<table>
<thead>
<tr>
<th>Resource</th>
<th>Used In</th>
</tr>
</thead>
<tbody>
<tr>
<td>Universal reliability definitions (URDs)</td>
<td>BlockSim, RCM++, Xfmea, RBI</td>
</tr>
<tr>
<td>Variables</td>
<td>BlockSim, RENO</td>
</tr>
</tbody>
</table>

Universal reliability definitions (URDs) describe a set of reliability and maintenance characteristics for a particular component/assembly.

Variables store numerical values that can be programatically varied during simulation.
**Models** can represent probabilities, durations or costs, either fixed or time-dependent. They are used by other resources to represent the reliability of a component, the duration of a task, the expected cost of a repair, etc.

<table>
<thead>
<tr>
<th>Models</th>
<th>Can be published from analyses in Weibull++, ALTA, BlockSim, RGA and Lambda Predict, or created manually. Used in BlockSim, RENO, Xfmea, RCM++ and RBI.</th>
</tr>
</thead>
</table>

**Tasks** represent maintenance activities:

- **Corrective** tasks are unplanned maintenance performed when a failure occurs.
- **Scheduled** tasks can include preventive maintenance, inspections and on condition maintenance.

<table>
<thead>
<tr>
<th>Tasks</th>
<th>BlockSim, RCM++, RBI</th>
</tr>
</thead>
</table>

**Task packages** represent groups of tasks that are performed together at scheduled intervals.

<table>
<thead>
<tr>
<th>Task packages</th>
<th>BlockSim, RCM++, RBI</th>
</tr>
</thead>
</table>

**Crews** represent the personnel who will perform a maintenance task.

<table>
<thead>
<tr>
<th>Crews</th>
<th>BlockSim, RCM++, RBI</th>
</tr>
</thead>
</table>

**Spare part pools** determine whether a spare part will be available, how long it will take to obtain and how much it will cost.

<table>
<thead>
<tr>
<th>Spare part pools</th>
<th>BlockSim, RCM++, RBI</th>
</tr>
</thead>
</table>

**Metrics** display any numerical value of interest, and track how it changes over time.

<table>
<thead>
<tr>
<th>Metrics</th>
<th>All applications except MPC via the Project Planner; analyses in Weibull++, ALTA, BlockSim, RGA, Xfmea, RCM++ and RBI</th>
</tr>
</thead>
</table>

**Maintenance groups** are used to model situations in which some event within the group can trigger maintenance or state changes for other components/assemblies.

<table>
<thead>
<tr>
<th>Maintenance groups</th>
<th>BlockSim, RCM++, RBI</th>
</tr>
</thead>
</table>

**Mirror groups** are used to represent the exact same component/event in more than one location within your analysis.

| Mirror groups | BlockSim, RCM++, Xfmea, RBI |
**Chapter 19: Synthesis Resources**

<table>
<thead>
<tr>
<th><strong>Actions</strong></th>
<th>describe specific assignments that need to be performed.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>All applications via <a href="#">My Portal; Project Planner</a> and FMEAs in RCM++, RBI and Xfmea</td>
</tr>
<tr>
<td><strong>Controls</strong></td>
<td>may be used in FMEAs and/or control plans to represent methods to reduce or eliminate the risk associated with potential failures.</td>
</tr>
<tr>
<td></td>
<td>RCM++, Xfmea, RBI</td>
</tr>
</tbody>
</table>

**Used Only in BlockSim**

<table>
<thead>
<tr>
<th>Resource</th>
<th>Used In</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Switches</strong></td>
<td>describe how the activity transfers between active and standby blocks in BlockSim's standby containers/gates.</td>
</tr>
<tr>
<td></td>
<td>BlockSim</td>
</tr>
<tr>
<td><strong>Maintenance templates</strong></td>
<td>define the activities that will be performed during a maintenance phase in a phase diagram.</td>
</tr>
<tr>
<td></td>
<td>BlockSim</td>
</tr>
</tbody>
</table>

**Used Only in RENO**

<table>
<thead>
<tr>
<th>Resource</th>
<th>Used In</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>RENO functions</strong></td>
<td>store equations that are evaluated based on input values passed to the function during simulation.</td>
</tr>
<tr>
<td></td>
<td>RENO</td>
</tr>
<tr>
<td><strong>RENO static functions</strong></td>
<td>store equations that are evaluated before simulation begins.</td>
</tr>
<tr>
<td></td>
<td>RENO</td>
</tr>
<tr>
<td><strong>RENO simulation definitions</strong></td>
<td>are used to trigger simulation of a BlockSim diagram from within a RENO flowchart, allowing you to use one or more results from the simulation in the flowchart.</td>
</tr>
<tr>
<td></td>
<td>RENO</td>
</tr>
<tr>
<td><strong>RENO tables</strong></td>
<td>store arrays of values in rows and columns.</td>
</tr>
<tr>
<td></td>
<td>RENO</td>
</tr>
</tbody>
</table>
Chapter 19: Synthesis Resources

Used Only in ALTA

<table>
<thead>
<tr>
<th>Resource</th>
<th>Used In</th>
</tr>
</thead>
<tbody>
<tr>
<td>Profiles</td>
<td>ALTA</td>
</tr>
</tbody>
</table>

Profiles represent values that vary with time. They can be used to describe stress levels under test conditions.

Local, Global and Reference Resources

There are three types of resources:

📚 **Local resources** can be used only within the project in which they were created, and are therefore available only to users with permissions within that project.

🔍 **Reference resources** (which are resources created in a reference project) can be used in any project throughout the database. However, in a secure database, they can be created and edited only by users who have the "Create/edit/delete local resources" permission within the reference project. These resources can be selected by any user who has at least the "Read" permission in the reference project. Users without permissions in the reference project can see the reference resources wherever they are used, but they will not be able to select or modify them.

🌍 **Global resources** can be used in any project throughout the database. In a secure database, they can only be created and edited by users who have the “Create/edit/delete global resources” permission. However, they can be selected by any database user.

To make a resource global, select it in the Resource Manager and choose **Home > Actions > Make Global**.

Making a resource global cannot be undone and this option is not available for all resource types. If you make a resource global, any resources assigned to it will become global as well (e.g., if a URD has an assigned model, making that URD global will also make the model global, regardless of whether it was originally local or reference).

Parent/Child Resource Relationships

Certain resources can have other resources assigned to them (e.g., URDs can have models and tasks assigned to them, tasks can have models, crews and spare part pools assigned to them, etc.). This can be considered a "parent/child" relationship.
When you create a resource from within its parent, the child resource will be of the same type as its parent. For example, if you are working with a global URD and you add a model to it, the model will be global. If you are working with a reference task and you add a crew to it, the crew will be added to the reference project that contains the task.

When you assign existing resources to a parent resource, the following rules apply:

- Any resource assigned to a reference resource must be either a reference resource within the same project or a global resource (e.g., a local model cannot be assigned to a reference URD, nor can a model in "Reference Project 2" be assigned to a URD in "Reference Project 1").

- Any resource assigned to a global resource must be either a reference resource or a global resource (e.g., a local model cannot be assigned to a global URD).

**Keeping Resources Together**

The application will automatically keep copies of a project's resources and linked FMEAs when the project is restored, checked out, imported or exported.

- When you create a **restore point**, any reference resources, global resources or linked FMEAs used in the project are converted to local resources/FMEAs and stored with the backup.

- When you **check out** a project for local editing, any reference resources, global resources or linked FMEAs used in the project are converted to local resources/FMEAs and stored with the project.

- When importing/exporting a project item that uses reference resources, global resources or linked FMEAs:
  - If you import/export within the same database, the references will remain unchanged.
  - If you import/export between databases, the destination project will contain local copies of the original resources/FMEAs.

- When **importing/exporting a project**:
  - If you import/export a project that uses global resources, the destination project will contain local copies of the original resources.
  - If you import/export a project that uses reference resources or linked FMEAs:
    - The references/FMEAs will be maintained if you also import/export the reference project at the same time.
Chapter 19: Synthesis Resources

- If you don’t import/export the reference project at the same time, the new project will instead contain copies of the original resources/FMEAs.

Creating and Selecting Resources

This topic describes how to use resource wizards to create and edit Synthesis resources while you’re performing an analysis or creating a URD. In addition, you may also need to:

- Use the Resource Manager to see all of the resources that are available to use in the current project. In addition to creating and editing resources, the manager also allows you to:
  - Delete resources that are no longer needed.
  - Create global resources that are available to all projects in the database.
  - Publish a model that is linked to an existing analysis.

(In a secure database, the ability to create, edit and delete resources is available only if the user a) is the project owner, b) has the applicable "resources" permissions, or c) has the applicable "manage all projects" permissions.)

Opening a Resource Wizard

Throughout all Synthesis desktop applications, the availability of a resource wizard is usually indicated by an ellipsis (...) or an arrow in the resource field. Simply click twice in the field to open the wizard.
Tip: If a resource is already assigned in the field, you can edit it directly without opening the wizard by clicking the Edit icon that appears in the field.

Back Arrow and Main Page
Each wizard contains multiple pages with different options on each page. If the option you need is not immediately visible, you can click the Back arrow to see the Main page, which shows all the options that are applicable for the current situation.

As an example, the following pictures show some of the different options that will be available on the Main page for specific situations and resource types.
If a model hasn't been defined...

Model Wizard

Select Existing Model
New Distribution
New Constant
New Dynamic
Settings

OK Cancel

If a task hasn't been defined...

Task Wizard

New Task
Select Existing Tasks
Settings

OK Cancel

If a task has already been defined...

Task Wizard

Select Existing Tasks
View/Edit Selected Task
Duplicate Task
Remove Task
Settings

OK Cancel

## Selecting an Existing Resource

The Select page of the wizard displays a list of existing resources that meet the criteria specified on the Settings page. You can then further limit the list by typing inside the text box.

As an example, the following pictures show a situation in which the settings are configured to display up to 2,000 models (more resources take longer to load) from the current project only (called local resources), and the user has selected to see only the ones in which the name includes “bulb.”

Selecting an Existing Resource

The Select page of the wizard displays a list of existing resources that meet the criteria specified on the Settings page. You can then further limit the list by typing inside the text box.

As an example, the following pictures show a situation in which the settings are configured to display up to 2,000 models (more resources take longer to load) from the current project only (called local resources), and the user has selected to see only the ones in which the name includes “bulb.”
In addition, for model resources only, you must specify whether you want to display the model parameters in the list (which also takes longer to load); and if so, the number of decimal places (called Parameter Precision) and the point at which the software will switch to scientific notation (called Parameter Tolerance).

To change the initial criteria for the list, click the Back arrow and then click the Settings button on the main page.

Alternatively, if you need more information about the available resources and/or a wider range of filtering tools, you can click the icon to open the Select Resource window.

**Creating a Resource**

In most wizards, you can click the Create New button or icon to create a new resource.

In the model wizard, click the button or icon for the type of model you want to create:

- New Constant
- New Distribution
- New Dynamic

**Editing a Resource**

If a resource has already been assigned, you can view and/or edit its properties by clicking the View/Edit button or icon in the field or in the wizard.

Any changes you make will apply everywhere that the resource is used. This includes analyses in other Synthesis applications.

**Removing a Resource**

If a resource has already been assigned, you can remove it from this location by clicking the Remove button or icon.
The resource will remain in the database for use in other locations. If you want to completely remove a resource from the database, you’ll need to use the Resource Manager or Select Resource window.

**Universal Reliability Definitions (URDs)**

A universal reliability definition (URD) describes a set of reliability and maintenance characteristics for a particular component/assembly. Like any other Synthesis resource, you can create or edit URDs while you're performing a relevant analysis, and from the Resource Manager.

*Note:* Depending on where you are using a URD, only those properties that are relevant are applied. For example, if you apply a URD to a block in an analytical diagram in BlockSim, only the failure model associated with the URD will be applied to the block.

**Naming the Resource**

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the Synthesis resources you need for your analyses.

**Hierarchy Tab**

Use the Hierarchy tab to view and/or edit the URD's properties. You can choose or create:

- A **model** to describe the behavior associated with the URD. This can be a reliability model, a probability of failure model or an event occurrence model.

- A **corrective task** that describes the maintenance action taken to restore a failed component to operational status.

- Zero, one or many **scheduled tasks** that describe the preventive maintenance, inspections and/or on condition maintenance tasks. The order in which the tasks are displayed reflects the priority with which tasks that are scheduled in the same way (see Task Scheduling) will be performed; for example, if there are two tasks scheduled based on interval and they conflict, the task higher in the priority list will be performed and the lower priority task will be disregarded. You can use the up and down arrows in the cells in this column to move the tasks up and down the priority list.
Additionally, the following are shown:

- **Identifiers** contains additional identifying information that can be used to search for this resource.

- **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the record.

- **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

**Filtered Tab**

Use the Filtered tab to see the resources that are shown in the Hierarchy tab, filtered by resource type. For example, the following picture shows the crews used in this URD.

Double-click any row to view or edit the properties of the resource.

You can change the columns shown in this view by clicking the Column Chooser icon.
Chapter 19: Synthesis Resources

Trace Usage
For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

Models
In Synthesis applications, *models* can represent probabilities, durations or costs, either fixed or time-dependent. They are used by other resources to represent the reliability of a component, the duration of a task, the expected cost of a repair and many other characteristics.

Like any other Synthesis resource, you can create or edit models while you’re performing a relevant analysis, and from the Resource Manager. In addition, you can publish models that are based on an existing analysis (e.g., a life data analysis in Weibull++, a diagram in BlockSim, etc.).

This topic describes the properties for both types of models. The interface will vary based on the particular situation.

Naming the Resource
For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the Synthesis resources you need for your analyses.

Associated Analysis
In published models only, the Associated Analysis area identifies the analysis that the model is based on. If the published model reflects the latest analysis results, the status is "Synchronized." If the analysis has been modified since the model was last published, the status is "Out of Sync."

**Tip:** If you have the ability to open the original analysis (i.e., if the required Synthesis application is activated on your computer and your user account has permissions to access the analysis), the Source will be configured as a link and there will also be a Data Source button at the bottom of the window.

Model Category
The category determines where and how a model can be used. If you are using a resource wizard to create a new model, it will be assigned automatically based on what’s relevant for the
current field. If you are publishing a model or creating it from the Resource Manager, you must select the appropriate option. Once a model has been created, you cannot change its category.

- **Reliability, Probability of Failure** and **Event Occurrence** models represent a likelihood of occurrence.
- **Duration** models represent a length of time.
- **Cost per Unit Time** models are used for costs that accrue over time (e.g., the crew charges $50 per hour).
- **Cost** models are used for costs that don’t depend on time (e.g., the part costs $100 or the crew charges $50 per service call in addition to their hourly rate).

## Model Type

- **A distribution** model represents behavior that varies based on factors such as time and/or applied stress. For a published model, the inputs and parameters will be specified automatically based on the associated analysis. For manually created models, you can:
  - Select a distribution from the drop-down list and then enter the required parameter(s).
  - Use the **Quick Parameter Estimator (QPE)** to estimate the parameters of a distribution based on what you know about the behavior.

**Tip:** A published model includes one additional parameter that is not relevant for manually created models. **PNZ** stands for percent non-zero. A value of 1 indicates that there are no zero failure times in the data set (which is the most common scenario in life data analysis). A decimal value indicates that the data set does include zero failure times (such as out-of-the-box failures, for example). In such cases, the parameters are calculated based on the non-zero failure times, and then the PNZ value is used as a multiplier when calculating certain metrics (e.g., reliability, unreliability).

- **A constant** model represents a fixed probability (e.g., 0.9), duration (e.g., 2 hours) or cost (e.g., $10 or $10 per hour).
- **A dynamic** model represents a fixed probability, duration or cost, based on a specified **variable**. The variable can then be programmatically varied during simulation in one of two ways, thereby changing the value of the model for successive simulation runs.
  - For RENO flowcharts, the variable can be varied using RENO’s sensitivity analysis/multiple analyses features.
  - When simulating a simulation worksheet, the values used by the variable will be specified in the worksheet.
Chapter 19: Synthesis Resources

When dynamic models are used outside of these circumstances, they are treated as constant models using the defined initial value of the variable.

**Additional Tools**

Additionally, the following are shown:

- **Identifiers** contains additional identifying information that can be used to search for this resource.

- **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the record.

- **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

**Publishing Models**

This topic provides general information about how to create and work with published models, which are model resources that have been published from and continue to be associated with an existing analysis. For information about additional options and requirements in specific applications, see:

- "Publishing Fitted and Analytical Models" in the BlockSim documentation.
- "Publishing Models from R-DOE Results" in the Weibull++/ALTA documentation.
- "Publishing from Failure Rate Predictions" in the Lambda Predict documentation.
- "Publishing Models from Analysis Results" in the RGA documentation.

The Synthesis Platform does not automatically update the published model when something changes in the original analysis, but users have the option to republish the model at any time. For any other analysis that uses the model, the change will be reflected the next time that other analysis is recalculated/resimulated.
Publishing Tools

For most Synthesis desktop applications, the following model publishing tools are found on the Publishing page of the control panel. In Lambda Predict, they are located on the Publishing tab of the Properties panel.

Publish Model publishes the analysis to a model, making it accessible to all Synthesis applications.

- If the analysis has never been published, this will create a new model and you will be prompted to specify the name and category.
- If the analysis has already been published, this will update the existing model and change the model's status from "Out of Sync" to "Synchronized."

Publish to Existing Model allows you to select an existing model (using the Select Resource window) and replace it with an association to the current analysis.

Trace Usage opens the Dependency Viewer, which allows you to see where the model is used.

View Model displays the properties for the published model. This information will be available to any Synthesis user who is considering whether to use the model in a particular analysis.

Remove Association removes the link between the current analysis and the published model. The model will continue to be a resource in the database but it can no longer be synchronized with the analysis.

Published Model Summary

After the model has been published, the summary table in the control panel (or Publishing tab in Lambda Predict) will display the model's name, along with the following details:

- When the Status changes from "Unpublished" to "Published," the label becomes a link that opens the model's properties window.
- Linked? indicates whether the published model has been used. If the model is in use, you can click the link in this field to open the Dependency Viewer.
- Synchronized? displays "Synchronized" if the published model reflects the latest results from the associated analysis. If that analysis has been modified since the model was last published (e.g., if more data has been added, an analysis setting has changed, etc.), the status will display as "Out of Sync."
Chapter 19: Synthesis Resources

- The **Created By** and **Modified By** fields display the names of the users who created and last updated the model. Click either of the links to see the dates and times.

### Model Basis and Status

When a model has been published from an existing analysis, its properties window will include the following additional information:

<table>
<thead>
<tr>
<th>Associated Analysis</th>
</tr>
</thead>
<tbody>
<tr>
<td>Model Name</td>
</tr>
<tr>
<td>Source</td>
</tr>
<tr>
<td>Application</td>
</tr>
<tr>
<td>Type</td>
</tr>
<tr>
<td>Status</td>
</tr>
</tbody>
</table>

- **Source** is the Synthesis analysis that the model was published from.
- **Application** is the Synthesis application that is required to view/edit the original analysis.
- **Type** is the kind of folio or diagram that the model is based on. For example, this might be a life data folio in Weibull++, an analytical diagram in BlockSim, a failure rate prediction in Lambda Predict, etc.
- **Status** displays "Synchronized" if the published model reflects the latest results from the associated analysis. If that analysis has been modified since the model was last published (e.g., if more data has been added, an analysis setting has changed, etc.), the status will display as "Out of Sync."

**Tip:** If you have the ability to view the original analysis (i.e., if the required Synthesis application is activated on your computer and your user account has permissions to access the analysis), the **Source** will be configured as a link and there will also be a **Data Source** button at the bottom of the window.

### Tasks

To properly analyze repairable systems, we first need to understand how components in these systems are restored (i.e., the maintenance activities that are performed on the components). In general, maintenance is defined as any action that restores failed units to an operational condition or keeps non-failed units in an operational state. For repairable systems, maintenance plays a vital role in the life of a system. It affects the system's overall reliability, availability, downtime, cost of operation, etc.
In Synthesis applications, maintenance activities are represented using tasks, which are resources that can be shared among analyses and can be managed via the Resource Manager. There are two basic kinds of tasks, which comprise four task classes:

- **Corrective tasks** are the action(s) taken to restore a failed component to operational status. These cannot be scheduled, as the component's exact failure time is not known before it happens.

- **Scheduled tasks** can be performed on a known schedule, based on time, component condition or other factors. These include:
  - Preventive tasks
  - Inspection tasks
  - On condition tasks

Tasks are assigned to URDs, which are in turn used to represent a set of properties that can be applied to standard blocks in RBDs and to events in fault trees.

The Maintenance Task window allows you to create, view and edit all classes of maintenance tasks. It can be accessed by clicking the Create New or View/Edit icon in the Task wizard, which is accessed from Task fields in properties windows (e.g., the Corrective Maintenance Task field in the Universal Reliability Definition window).

It can also be accessed from the Corrective Tasks and Scheduled Tasks pages of the Resource Manager by choosing Home > Edit > New, by selecting a task and choosing Home > Edit > View or by double-clicking a task.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the Synthesis resources you need for your analyses.

The following options must be configured for all classes of tasks. Configuration options that are specific to particular task classes are presented in the corresponding sections.

- **Basic Task Properties**
  
  - **Task duration** allows you to assign a model, which may represent a fixed time or a distribution, to describe the duration of the task. You can choose an existing model or create a new one. If no model is assigned, it is assumed that the task has a duration of zero (i.e., immediate repair).
• **Crew for task** allows you to choose or create one or more crews that can perform the task. If multiple crews are assigned to the task and a crew is needed, they will be checked for availability in the order in which they are displayed in this list. Use the Priority Up and Priority Down arrows that appear when you click a crew name in the list to move it up and down in the list. If a crew is needed and all crews are engaged, the crew with the shortest wait time is chosen to perform the task.

If no crew is assigned, it is assumed that the work will be done by some undefined crew that is always available.

• **Restoration** These properties allow you to specify the degree to which the block will be restored after the performance of the task. In the *How much does this task restore the item?* field, you can specify that the item will be returned to as good as new condition (i.e., full repair, equal to a restoration factor of 1), to the same condition it was in when it failed (i.e., "as bad as old" or minimal repair, equal to a restoration factor of 0), or you can choose **Partial restoration**. This option provides you with the ability to model maintenance involving "used parts" or imperfect maintenance. The **Restoration amount** field will appear; you can specify the amount of restoration achieved by the task either by entering the value as a percentage or by clicking the arrow and using the slider bar that appears. If you specify anything other than 0% or 100%, you will need to specify what the restoration effect applies to (i.e., the restoration type). You can select:

  • **Only damage accumulated since last repair**: Each repair will remove only the damage since the last repair (i.e., the nth repair cannot remove the damage incurred before the (n-1)th repair). Note that in this context any task is considered a repair and any damage that has occurred since the last event (corrective task, preventive task, inspection or on condition task) will be reduced.

  • **All accumulated damage**: Each repair can reduce any damage accumulated up to that failure.

For simulation, the application uses the restoration factor to determine the new age of the block after the maintenance action.

For example, consider an automotive engine that fails after 6 years. If the engine is rebuilt and the rebuilding task has a 50% restoration factor:

• **If Only damage accumulated since last repair** is selected, the initial rebuild has the effect of rejuvenating the engine to a condition as if it were 3 years old.

  The engine fails again after 3 years (when it again reaches the effective "age" of 6 years), but the rebuild this time affects only the age accumulated after the first
rebuild. Thus the engine has an effective age of 4.5 years after the second rebuild 
\((3 + 3 \times (1 - 0.5) = 4.5)\).

After the second rebuild, the engine fails again after a period of 1.5 years (when it 
again reaches the effective age of 6 years) and a third rebuild is required. The 
effective age of the engine after the third rebuild is 5.25 years \((4.5 + 1.5 \times (1 - 0.5) = 
5.25)\).

- If **All accumulated damage** is selected, the initial rebuild has the effect of 
rejuvenating the engine to a condition as if it were 3 years old.

The engine fails again after 3 years (when it again reaches an effective age of 6 
years) and another rebuild is required. This rebuild also rejuvenates the engine by 
50%, thus making it effectively 3 years old again.

After the second rebuild, the engine fails again after a period of 3 years (when it 
again reaches the effective age of 6 years) and a third rebuild is required. The 
effective age of the engine after the third rebuild is 3 years.

Compare the following tables to see how the two options differ.

### Only Damage Accumulated Since Last Repair

<table>
<thead>
<tr>
<th>Time</th>
<th>Time Since Last Repair</th>
<th>Effective Age Before Repair</th>
<th>Effective Age After Repair</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start = 0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>6 years</td>
<td>6</td>
<td>6</td>
<td>3</td>
</tr>
<tr>
<td>9 years</td>
<td>3</td>
<td>6</td>
<td>4.5</td>
</tr>
<tr>
<td>10.5 years</td>
<td>1.5</td>
<td>6</td>
<td>5.25</td>
</tr>
</tbody>
</table>

### All Accumulated Damage

<table>
<thead>
<tr>
<th>Time</th>
<th>Time Since Last Repair</th>
<th>Effective Age Before Repair</th>
<th>Effective Age After Repair</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start = 0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>6 years</td>
<td>6</td>
<td>6</td>
<td>3</td>
</tr>
</tbody>
</table>
Chapter 19: Synthesis Resources

<table>
<thead>
<tr>
<th>9 years</th>
<th>3</th>
<th>6</th>
<th>3</th>
</tr>
</thead>
<tbody>
<tr>
<td>12 years</td>
<td>3</td>
<td>6</td>
<td>3</td>
</tr>
</tbody>
</table>

The ReliaWiki resource portal has more information on restoration factors at: http://www.reliawiki.org/index.php/Repairable_Systems_Analysis_Through_Simulation.

- **Additional Costs to Consider** allows you to choose or create models to represent costs that are always associated with the task. **Cost per task** uses a cost model, and **Downtime rate** uses a cost per unit time model. If no models are assigned, it is assumed that there are no additional costs.

- **Identifiers** contains additional identifying information that can be used to search for this resource.

- **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the record.

- **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

- **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

**Corrective Tasks**

Corrective maintenance consists of the action(s) taken to restore a failed component to operational status. Corrective maintenance is performed at unpredictable intervals because a component's failure time is not known a priori.

Corrective tasks:

- Always bring the block down.
- May bring the system down.
- Require spare parts.
In addition to the common task properties, the following options are used to configure corrective tasks in the Maintenance Task window:

- **Task Scheduling** allows you to specify when the corrective task will be performed.
  - If you choose **Upon item failure**, the task will be initiated upon failure of the component.
  - If you choose **When found failed during an inspection**, the task will be initiated if the component is found to be failed at the next scheduled inspection. This is useful in the case of "hidden failures" (i.e., failures that are not apparent until an inspection is performed) and in cases where the component is not considered mission critical and repair can wait until the next scheduled maintenance.
    - If a preventive task takes place before the next inspection, then preventive maintenance (not corrective maintenance) will be performed to restore the block. The downtime, etc. will depend on the preventive task properties.
    - If a corrective task is performed upon inspection and an inspection finds the block failed, then the total downtime includes the full inspection duration followed by the corrective task duration.

If you have selected to perform a corrective task upon inspection and an inspection or preventive task does not occur after the failure, then the block will never be restored. This could happen under either of the following circumstances:

- Neither an inspection nor a preventive task is specified for the block.
  and/or
- The conditions have not been met to perform an inspection or preventive task.

- **Basic Repair Properties > Spare Part Pool** allows you to choose or create a spare part pool that will be used in performing the task. If a spare part pool is not assigned, it is assumed that unlimited free spares are always immediately available.

For corrective and preventive tasks, the simulation requests a crew as soon as a task is initiated; however, the crew does not begin performing the task unless/until the spare part is available.
The total time for the task consists of:

- The time to complete corrective and preventive maintenance (based on the corrective task or preventive task properties).

PLUS

- The longer of the following times:
  - The time to obtain the spare part (based on the spare part pool).

OR

- The time to obtain an available crew (based on crew availability) and any logistical delay time associated with the crew.

For example, if the block fails at 10 hours (on the system clock), the corrective task will take 5 hours, the time required to obtain the spare will be 48 hours and the logistical delay time associated with the crew is 8 hours, then:

- The spare will arrive at 58 hours (on the system clock).
- The crew will be requested at 10 hours and will arrive at 18 hours (on the system clock).
- The maintenance will be completed at 63 hours (on the system clock).
- The total time for the corrective maintenance will be 53 hours (48 for the spare plus 5 for the task).
- The crew will have traveled for 8 hours, waited 40 hours for the spare part and performed the task for 5 hours for a total of 53 hours (including waiting for the spare part).

If the spare part is available without delay and all other conditions are the same, then:

- The crew will be requested at 10 hours and will arrive at 18 hours (on the system clock).
- The maintenance will be completed at 23 hours (on the system clock).
- The total time for the corrective maintenance will be 13 hours (8 for the crew plus 5 for the task).
- The crew will have traveled for 8 hours and performed the task for 5 hours for a total of 13 hours.
• **Task Consequences**

  • **Does this task bring the system down?**: By default, corrective tasks will not bring the system down unless having the block down brings the system down based on the reliability-wise configuration in the diagram. If you answer Yes, the task will bring the system down even if the task has a zero duration. This forces the task to be included in the count of system downing events, regardless of the task’s duration.

  • **Does this task bring the item down?**: It is assumed that a block will always be down when a corrective task is performed, even a task with a zero duration; thus, this option cannot be changed.

---

**Preventive Tasks**

Preventive maintenance is the practice of repairing or replacing components or subsystems before they fail in order to promote continuous system operation or to avoid dangerous or inconvenient failures. The schedule for preventive maintenance is based on observation of past system behavior, component wearout mechanisms and knowledge of which components are vital to continued system operation. In addition, cost is always a factor in the scheduling of preventive maintenance. In many circumstances, it is financially more sensible to replace parts or components at predetermined intervals rather than to wait for a failure that may result in a costly disruption in operations.

Preventive tasks:

  • Always bring the block down.

  • May bring the system down.

  • Require spare parts.

Only one preventive task can be performed on a block at any given time.

In addition to the common task properties, the following options are used to configure preventive tasks in the Maintenance Task window:

  • **Task Class** allows you to specify the kind of maintenance that the task performs: preventive, inspection or on condition. The options available in the Maintenance Task window will vary depending on your choice in this field.

  • **Task Scheduling** allows you to specify the circumstances under which the task will be performed. (See [Task Scheduling](#).)
• **Basic Task Properties > Spare Part Pool** allows you to choose or create a spare part pool to assign to the task. The spare part pool describes the conditions that determine whether a spare part will be available when needed and specifies the time and costs associated with obtaining the spare part. If a spare part pool is not assigned, it is assumed that unlimited free spares are always immediately available.

For corrective and preventive tasks, the simulation requests a crew as soon as a task is initiated; however, the crew does not begin performing the task unless/until the spare part is available. For a complete explanation of how this affects the total time for the task, see Corrective Tasks.

• **Task Consequences**

  - **Does this task bring the system down?**: By default, preventive tasks will not bring the system down unless having the block down brings the system down based on the reliability-wise configuration in the diagram. If you answer Yes, the task will bring the system down, even if the task has a zero duration. This forces the task to be included in the count of system downing events, regardless of the task's duration.

  - **Does this task bring the item down?**: It is assumed that a block will always be down when a preventive task is performed, even a task with a zero duration; thus, this option cannot be changed.

  - **If bringing the item down causes the system to go down, do you still perform the task?**: If you answer Yes, the task will be performed even if doing so brings the system down, either because the task itself brings the system down or because the task brings the block down and the block being down causes the system to go down. If you answer No and the task brings the system down, the task will never be performed during simulation unless the system is already down for another reason. For instance, a preventive task that is specified to be performed upon system down will be performed even if it brings the system down regardless of your answer here. This is because the system is already down, which is what triggered the task in the first place.

A preventive task that does not bring the system down at the preventive maintenance time will still be factored into the simulation even if its duration will bring the system down at a later time.

For a preventive task that is scheduled to occur based on item age and for which you have answered No to this question, if the task is going to bring the system down, then it will not take place. If, however, the block reaches the age again (after restoration by a corrective action, inspection or another type of preventive maintenance) and this time it will not bring the system down, then it will be performed.
• **Perform this task even if the item failed before this task was scheduled to occur?** If you answer Yes, the task will be performed even if the item has already failed. In other words, the item’s "clock" is not stopped upon failure, and the item's "virtual age" is used to trigger the task. This option is available only for preventive and inspection tasks that are scheduled based on item age.

• **RCM** properties are text-based properties that are used to keep track of details that may be helpful in reliability centered maintenance analysis, but are not used in reliability/maintainability simulations. These properties are shown only if they are enabled for the project via the interface style settings in RCM++/RBI.

• **Status**: The status of the task (choose from a drop-down list). This setting could be used if you want to keep track of all tasks that have been considered, regardless of whether they end up in the actual maintenance plan (e.g. recommended, rejected, assigned).

• **Proposed Interval**: The interval that was initially proposed for the task. This may be different from the interval that is actually assigned to the task. For example, you may wish to use this property if the team originally suggests a particular interval for the task (perhaps the calculated optimum interval) but then decides to assign a different interval (perhaps an interval that is more convenient for packaging a group of tasks).

• **Reference Document**: A reference to another document that provides more detailed information about the task (e.g. procedure instructions).

• **Condition**: A description of the condition that indicates that a failure will occur (e.g. a threshold for a measurement of wear, vibration, etc). Typically, this field is used for on condition maintenance tasks.

• **Zone**: The zone of the system in which the task will be performed. Typically, this field is used for aircraft MSG-3 analyses.

• **Access**: The access that will be required in order to perform the task. Typically, this field is used for aircraft MSG-3 analyses.

**Note**: A preventive task with a restoration factor of 0 will generate a new failure with the current age.

**Inspection Tasks**

Inspections are used in order to uncover hidden failures (also called "dormant failures"); they are also used as part of on condition tasks to detect impending failures so that preventive maintenance can be performed.
**What's Changed?** In previous versions of BlockSim, you could assign failure detection properties to an inspection task and set it to trigger a preventive task, thereby creating an on condition maintenance action. The Synthesis version of BlockSim offers on condition tasks, eliminating the need to create your own. Therefore, failure detection properties are now available only for on condition tasks, not for regular inspection tasks.

In general, no maintenance action is performed on the component during an inspection unless the component is found failed, in which case a corrective maintenance action is initiated. However, there might be cases where a partial restoration of the inspected item would be performed during an inspection. For example, when checking the motor oil in a car between scheduled oil changes, one might occasionally add some oil in order to keep it at a constant level. This sort of restoration is not considered to be preventive maintenance; the deciding factor is that inspection tasks do not use spare parts. Note that an inspection task that triggers a corrective task will not restore the failed block. Only the corrective task will restore the block.

Inspection tasks (including the inspection and associated minor work):

- May bring the block down.
- May bring the system down; if the task brings the system down, it also brings the block down.
- Do not use spare parts.

In addition to the common task properties, the following options are used to configure inspection tasks in the Maintenance Task window:

- **Task Class** allows you to specify the kind of maintenance that the task performs: preventive, inspection or on condition. The options available in the Maintenance Task window will vary depending on your choice in this field.

- **Task Scheduling** allows you to specify the circumstances under which the task will be performed. (See Task Scheduling.)

- **Task Consequences**: An inspection task will not bring the block down unless one of the following options is selected.
  - **Does this task bring the system down?**: If you answer Yes, when the task is performed, the system will be down, even if the task has a zero duration. If not selected, the task will bring the system down only if it brings the block down and having the block down brings the system down based on the reliability-wise configuration in the diagram. If this option is selected, even tasks with a zero duration will bring the system down. This forces the task to be included in the count of system downing events, regardless of the task's duration.
• **Does this task bring the item down?** If you answer *Yes*, when the task is performed, the block will be down. Even tasks with a zero duration will bring the block down in this case.

• **Perform this task even if the item failed before this task was scheduled to occur?** If you answer *Yes*, the task will be performed even if the item has already failed. This option is available only for preventive and inspection tasks that are scheduled based on item age, including the inspection portion of on condition tasks.

• **RCM** properties are text-based properties that are used to keep track of details that may be helpful in reliability centered maintenance analysis, but are not used in reliability/maintainability simulations. These properties are shown only if they are enabled for the project via the interface style settings in RCM++/RBI.

• **Status**: The status of the task (choose from a drop-down list). This setting could be used if you want to keep track of all tasks that have been considered, regardless of whether they end up in the actual maintenance plan (e.g. recommended, rejected, assigned).

• **Proposed Interval**: The interval that was initially proposed for the task. This may be different from the interval that is actually assigned to the task. For example, you may wish to use this property if the team originally suggests a particular interval for the task (perhaps the calculated optimum interval) but then decides to assign a different interval (perhaps an interval that is more convenient for packaging a group of tasks).

• **Reference Document**: A reference to another document that provides more detailed information about the task (e.g., procedure instructions).

• **Condition**: A description of the condition that indicates that a failure will occur (e.g. a threshold for a measurement of wear, vibration, etc). Typically, this field is used for on condition maintenance tasks.

• **Zone**: The zone of the system in which the task will be performed. Typically, this field is used for aircraft MSG-3 analyses.

• **Access**: The access that will be required in order to perform the task. Typically, this field is used for aircraft MSG-3 analyses.

To understand how inspections work during simulation, you should be aware of the following:

• Multiple non-downing inspections cannot occur on the same block at the same time.
Chapter 19: Synthesis Resources

- A non-downing inspection with a restoration factor greater than 0 restores the block based on the age of the block at the beginning of the inspection (i.e., the task duration is not restored).

### On Condition Tasks

On condition maintenance relies on the capability to detect failures before they happen so that preventive maintenance can be initiated. If, during an inspection, maintenance personnel can find evidence that the equipment is approaching the end of its life, then it may be possible to delay the failure, prevent it from happening or replace the equipment at the earliest convenience rather than allowing the failure to occur and possibly cause severe consequences.

In BlockSim, on condition tasks consist of an inspection task that triggers a preventive task when an impending failure is detected during inspection.

For on condition tasks, the Inspection properties allow you to configure the inspection portion of the task, and the options are identical to those available for configuring inspection tasks. The On Condition Task (Upon Detection) properties allow you to configure the preventive portion of the task. The options are the same as those available for configuring preventive tasks, except that the Task Scheduling properties are not available. Instead, Failure Detection properties are used to specify the "warning period" that spans from the time when a potential failure can first be detected to the time when the failure occurs.

To define the Failure Detection properties, first specify when the task is likely to detect an imminent failure. If you choose *When a certain percentage of the life of the item has been consumed*, you must then specify the percentage of the item's life that must have elapsed in order for approaching failure to be detected. This is called the *failure detection threshold* (FDT). For example, if the FDT is 0.9 and the item will fail at 1,000 days, the approaching failure can begin to be detected at 900 days. If you choose *Within a fixed time frame prior to failure*, you must then specify the amount of time before a failure when the approaching failure can be detected by inspection. This is called the *P-F interval*. For example, if the P-F interval is 200 days and the item will fail at 1,000 days, the approaching failure can begin to be detected at 800 days.

On condition tasks can be set to perform the preventive portion of the task even if the item failed before the approaching failure could be detected. If the inspection portion of the task is scheduled based on item age, you can answer *Yes* to the Perform this task even if the item failed before this task was scheduled to occur? option.

Note the following simulation assumptions regarding on condition tasks:

- An inspection that finds a block at or beyond the failure detection threshold or within the range of the P-F interval will trigger the associated preventive task as long as preventive maintenance can be performed on that block.
• If a non-downing inspection triggers a preventive maintenance action because the failure detection threshold or P-F interval range was reached, no other maintenance task will be performed between the inspection and the triggered preventive task; tasks that would otherwise have happened at that time due to system age, system down or group maintenance will be ignored.

• A preventive task that would have been triggered by a non-downing inspection will not happen if the block fails during the inspection, as corrective maintenance will take place instead.

• If a failure will occur within the failure detection threshold or P-F interval set for the inspection, but the preventive task is only supposed to be performed when the system is down, the simulation waits until the requirements of the preventive task are met to perform the preventive maintenance.

• If the on condition inspection triggers the preventive maintenance part of the task, the simulation assumes that the maintenance crew will forego any routine servicing associated with the inspection part of the task. In other words, the restoration will come from the preventive maintenance, so any restoration factor defined for the inspection will be ignored in these circumstances.

**Task Scheduling**

The following information applies to the task scheduling properties for **preventive tasks**, **inspection tasks** and the inspection portion of **on condition tasks**.

Click the arrow in the **When is this task performed?** field to define the criteria for performing the task. The remaining fields in the task scheduling properties will depend on your selection in this field. The task can be performed:

• **At certain intervals.** If you select this option, you must then specify:
  - Whether the interval is fixed or dynamic.
  - Whether the interval is based on the item's age or on calendar time.

• **Upon certain events.** If you select this option, you can choose for the task to be performed:
  - Whenever the system is down for any reason. No further task scheduling properties are required for this option.
  - Based on events in a **maintenance group**. The task will be performed when user-specified events occur in one or more user-specified maintenance groups. The
item that the task is assigned to does not need to be part of the selected maintenance group(s).

- When a maintenance phase in a phase diagram starts. Please note that if the task is selected to be performed only at the start of a maintenance phase and the item that the task is associated with is not included in the maintenance phase's associated maintenance template, the task will never be performed. No further task scheduling properties are required for this option.

The remaining task scheduling properties for each type of schedule are given next. For any interval that you specify, you will be asked to specify the time units used.

- Fixed interval based on either item age or calendar time: Enter the interval when the task will be performed (e.g., if you enter 100, the task will be scheduled for 100, 200, 300, etc.).
  - Item age refers to the accumulated age of the block, which gets adjusted each time the block is repaired (i.e., restored). If the block is repaired at least once during the simulation, this will be different from the elapsed simulation time. For example, if the restoration factor is 1 (i.e., "as good as new") and the assigned interval is 100 days based on item age, then the task will be scheduled to be performed for the first time at 100 days of elapsed simulation time. However, if the block fails at 85 days and it takes 5 days to complete the repair, then the block will be fully restored at 90 days and its accumulated age will be reset to 0 at that point. Therefore, if another failure does not occur in the meantime, the task will be performed for the first time 100 days later at 190 days of elapsed simulation time.
  - Calendar time refers to the elapsed simulation time. If the assigned interval is 100 days based on calendar time, then the task will be performed for the first time at 100 days of elapsed simulation time, for the second time at 200 days of elapsed simulation time and so on, regardless of whether the block fails and gets repaired correctly between those times.

If the task is performed at fixed intervals, you can select the **Override task scheduling properties with a task package** option to assign the task to a task package, which is a group of tasks that are performed together at scheduled intervals. (Note that if a task has
been assigned to a task package, the task scheduling properties will be disabled and displayed in italics.)

- **Dynamic interval based on either item age or calendar time**: The task will be performed at variable user-specified intervals. This can be used, for example, to schedule maintenance to be performed with increasing frequency as an item gets older. The **Dynamic intervals** field shows the number of intervals specified. Click the button (...) to open the Intervals window, which allows you to enter the item age intervals when the task will be performed. The intervals are the actual time between maintenance (i.e., they are not cumulative).

- **Based on events in a maintenance group**: Specify the events that can trigger the task (i.e., a block fails; a corrective, preventive or inspection task starts; a block is restored to operation), and choose the maintenance group(s) in which the event(s) must occur in order to trigger the task.

**Note:** For preventive and inspection tasks that are scheduled based on item age, you can use the **Perform this task even if the item failed before this task was scheduled to occur?** property to determine whether actual age or "virtual age" is considered. If you answer **Yes**, the task will be performed even if the item has already failed. In other words, the item's "clock" is not stopped upon failure, and the item's virtual age is used to trigger the task.

---

**Crews**

Crews are resources that can be shared among analyses and can be managed via the **Resource Manager**. You can assign the crews to maintenance **tasks**.

The Crew window allows you to create, view and edit crews. It can be accessed by clicking the **Create New** or **View/Edit** icon in the Crew wizard, which is accessed from **Crew** fields in properties windows (e.g., the **Crew for task** field in the **Maintenance Task window**).

It can also be accessed from the Crews page of the Resource Manager by choosing **Home > Edit > New**, by selecting a crew and choosing **Home > Edit > View** or by double-clicking a crew.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see **Default Name Formats window**). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the Synthesis resources you need for your analyses.
The following settings are available to configure the crew:

- **Crew**

  - **Direct cost** allows you to choose or create a model to represent the direct cost per unit time to engage the crew (e.g., the hourly charge for the time that the crew spends performing the task). This field uses a cost per unit time model. If no model is assigned, it is assumed that there is no cost.

  - **Cost per incident** allows you to choose or create a model to represent the cost per incident to engage the crew (e.g., if you have to pay a fixed fee instead of or in addition to the hourly rate). This field uses a cost model. If no model is assigned, it is assumed that there is no cost.

  - **Is there a limit to the number of tasks this crew can perform at the same time?** If you answer Yes, you must specify the limit in the **Number of tasks** field. For example, if the crew can only fix 3 components at any given time and 4 components fail at the same time, then the crew will not be able to fix the fourth component until one of the other components has been restored.

  - **Logistic Delay** allows you to choose or create a model to describe the delay time before the crew can start the task. If no model is assigned, it is assumed that the crew can start the task immediately without any delays (i.e., immediate repair). The crew with the highest priority is always called upon first, regardless of logistic wait times for the crews. If a crew is needed and all crews are engaged, the crew with the shortest wait time is chosen to perform the task.

For a given simulation, a crew's logistic time is constant across that one simulation for the task. It is taken randomly from its distribution or from its fixed time.

For on condition tasks, if the same crew performs the inspection and preventive maintenance and there are logistic delays associated with the crew, the logistic delays will be factored into the simulation for both parts of the task.

- If **Include logistic delay in cost** is selected, then the time spent waiting for the crew (including logistic delay and any delay incurred due to limits on the number of tasks the crew can perform simultaneously) will be included when calculating crew costs, based on the direct cost specified for the crew.

- If **Include part delay in cost** is selected, then the time spent by the crew waiting for spare parts will be included when calculating crew costs, based on the direct cost specified for the crew.

- **Identifiers** contains additional identifying information that can be used to search for this resource.
• **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the record.

• **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

• **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the **Dependency Viewer**.

### Spare Part Pools

Spare part pools are resources that can be shared among analyses and can be managed via the **Resource Manager**. A spare part pool describes the conditions that determine whether a spare part will be available when needed and specifies the time and costs associated with obtaining the spare part. You can assign the pools to maintenance tasks.

The Spare Part Pool window allows you to create, view and edit spare part pools. It can be accessed by clicking the **Create New** or **View/Edit** icon in the Spare Part Pool wizard, which is accessed from **Spare Part Pool** fields in properties windows (e.g., in the **Maintenance Task window**).

It can also be accessed from the Spare Part Pools page of the Resource Manager by choosing **Home > Edit > New**, by selecting a spare part pool and choosing **Home > Edit > View** or by double-clicking a spare part pool.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see **Default Name Formats window**). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the Synthesis resources you need for your analyses.
Chapter 19: Synthesis Resources

The following settings are available to configure the spare part pool:

- **Spares**
  
  - **Direct cost per dispensed item** allows you to specify the direct cost of each spare part in the pool.
  
  - **Spare acquisition type**: You can select **Unlimited spares** to indicate that an unlimited number of spare parts exist in the pool (i.e., if a spare part is required, it will always be available). If you select **Limited number of spares**, the Pool Restock properties and the Emergency Spare Provisions properties will become available. In addition, you will need to define the following properties:
    
    - **Initial stock level** is the number of spare parts in the pool at the start of simulation.
    
    - **Holding Cost ($/Hour in pool)** allows you to choose or create a model to represent the cost of holding a spare part in the pool. The time unit used is the default unit for the database. This field uses a cost per unit time model. If no model is assigned, it is assumed that there is no cost. (To determine which time unit is defined as the default, you can open the Define Units window by choosing File > Manage Repository > Time and Usage Units. The default unit is the one that is selected in the Use as Default column.)
    
    - If you select the **Pool has maximum capacity** check box, you will need to specify the maximum number of items that can exist in the spare part pool at any given time. The restock options will add parts only up to this maximum capacity. For example, suppose that the maximum capacity is 20 units and the restock quantity is 5 units. If the current stock level is 18 when a restock is triggered (either on a scheduled interval or because the stock fell to a specified level), then only 2 units will be added to the spare part pool, even though the restock options call for the addition of 5 units at each restock.

If you select **Fixed probability of stockout**, the Emergency Spare Provisions properties will become available. In addition, you will need to enter the probability of running out of stock as a decimal value.

- **Logistic Time for Spare Acquisition** allows you to choose or create a model to describe the amount of time required to obtain the part when it is required for maintenance, assuming that the part is in stock. This field uses a duration model. If no model is assigned, it is assumed that the spare part is available for use immediately.
The **Pool Restock** properties allow you to define how the spare part pool will be restocked. These properties are available only if you have selected the **Limited number of spares** option in the **Spare acquisition type** field. You can select either or both of the following restock schemes:

- If the **Scheduled restock** option is selected, the pool will be restocked at fixed intervals. The following properties will be available:
  - **Restock every** allows you to specify the time interval at which the pool will be restocked.
  - **Number added per restock** allows you to specify the number of parts that are added to the pool at every scheduled interval.

- If the **Restock as needed** option is selected, the pool will be restocked when the stock drops to a specified quantity. This option is available only if the initial stock level entered is at least 1. The following properties will be available:
  - **Restock when stock drops to** allows you to specify the number of parts in the pool that will trigger the restock (e.g., when the stock drops to 5, order more parts).
  - **Number added per restock** allows you to specify the number of parts that are added to the pool when the restock condition has been met.
  - **Required time for stock arrival** allows you to choose or create a model to describe the amount of time required for the new parts to arrive after the restock has been initiated. This field uses a duration model. If no model is assigned, it is assumed that the parts arrive immediately.
  - **Off-site spare part pool** allows you to assign an off-site spare part pool to the current pool. If specified, this pool is considered to be the source for restocking the current pool, which allows you to describe properties for the next level of spare parts that can be accessed when needed. If no off-site spares pool is specified, the parts are assumed to be ordered and no properties are described for the source.

**Tip:** Circular references between spare part pools are not permitted. In other words, if Pool 1 calls Pool 2 as its off-site spare part pool, and Pool 2 calls Pool 1 as its off-site spare part pool, BlockSim will display a message notifying you of the problem upon simulation.

- The **Emergency Spare Provisions** properties allow you to define the circumstances when the spare part pool is empty but a spare part is required for a task. These properties are available only if you have selected either the **Limited number of spares** option or the
Fixed probability of stockout option in the Spare acquisition type field. Selecting the Can obtain emergency spares if needed option indicates that a spare part can be obtained if required and the spare part pool is empty; otherwise, the repair will be delayed until more spare parts arrive in the spare part pool. Selecting this option makes the following properties available:

- **Number added per emergency** allows you to specify the number of parts that are added to the pool when an emergency acquisition occurs.

- **Additional costs for emergency spares** allows you to choose or create a model to represent a per incident cost for emergency acquisition of spares (e.g., there is a $50 surcharge when emergency spares are required). This field uses a cost model. If no model is assigned, it is assumed that there is no cost.

- **Required time for emergency spare** allows you to choose or create a model to describe the amount of time required for the emergency spare parts to arrive after the emergency acquisition has been initiated. This field uses a duration model. If no model is assigned, it is assumed that the parts arrive immediately.

- **Off-site spare part pool** allows you to assign an emergency off-site spare part pool to the current pool. This allows you to create another level of spare parts that can be accessed for the emergency acquisition.

- **Identifiers** contains additional identifying information that can be used to search for this resource.

- **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the **View Item History** icon to open the Record History Log for the record.

- **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

- **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the **Dependency Viewer**.
Metrics

A metric is a Synthesis resource that provides a flexible way to display any numerical value of interest, and track how it changes over time. This can be used for tracking and displaying a variety of Key Performance Indicators (KPIs) and other values, including:

- Reliability metrics (e.g., reliability, BX% life, etc.) calculated from a model resource.
- Any result from a simulated BlockSim diagram.
- The completion percentage and resource usage for Project Planner gates.
- The reliability or availability calculated from an FMRA in Xfmea/RCM++/RBI.
- Any other user-defined value that you wish to display and track.

Like any other Synthesis resource, you can create or edit metrics from the Resource Manager, and while you’re performing a relevant analysis. (See Showing Metrics in Folios/Diagrams, Using Metrics in Project Planner Gates and Pushing Metrics from an FMRA.)

If your organization chooses to implement a web-based Synthesis Enterprise Portal, it's easy to choose specific metrics that you want to access quickly from any web-enabled device.

**Note:** Metrics are always local resources. They cannot be made global. Metrics in a reference project are local to that project and can't be selected for use in other projects.
Chapter 19: Synthesis Resources

Metric Types
The following pictures demonstrate the four basic options for specifying the value that will be displayed and tracked.

<table>
<thead>
<tr>
<th>Calculate from a model resource</th>
<th>Obtain from a BlockSim simulation diagram</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Metric Type" /></td>
<td><img src="image" alt="Metric Type" /></td>
</tr>
<tr>
<td>- Type</td>
<td>Reliability Given Time</td>
</tr>
<tr>
<td><img src="image" alt="Associated Model" /></td>
<td><img src="image" alt="Associated Model" /></td>
</tr>
<tr>
<td>- Model</td>
<td>Widget LDA [WB2 (1.5, 1000)]</td>
</tr>
<tr>
<td>- Time</td>
<td>100 (Hr)</td>
</tr>
</tbody>
</table>

Enter any user-defined value

<table>
<thead>
<tr>
<th>Metric Type</th>
<th>Constant</th>
</tr>
</thead>
<tbody>
<tr>
<td>- Type</td>
<td>Constant</td>
</tr>
<tr>
<td>- Value</td>
<td>100</td>
</tr>
</tbody>
</table>

The value is "pushed" from a Project Planner gate or FMRA

<table>
<thead>
<tr>
<th>Metric Type</th>
<th>Application Driven Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>- Type</td>
<td>Application Driven Value</td>
</tr>
</tbody>
</table>

Calculated Result and Saved Values
The Calculated Result field shows the latest calculated value for the metric. This will be updated automatically if the associated analysis or model changes, and the latest result will be stored in an array of saved values.

You can then click the View Saved Values icon to view the history of how the metric has changed over time.

![View Saved Values](image)

If you change any of the properties that affect the way the result is calculated, you will be prompted to decide whether to clear the array of values that were saved before the change.

For example:

- If you change the metric from Reliability to Probability of Failure, or from 1,000 hours to 500 hours, you will probably want to clear the array so the timeline of saved values is not misleading.

- Alternatively, if you change the metric’s associated model from prototype1 to prototype2 to prototype3 at different stages of development, you may wish to keep the
saved values after each change so the timeline shows the improvement across all three stages.

In the Metric Results Viewer, you can also choose to clear the entire history or delete only a particular saved value.

The results viewer also allows you to copy the values to the Clipboard so you can paste into another application. For example, if the metric stores the calculated reliability at different points in time, you may wish to analyze the data with a reliability growth model in RGA.

- **Copy > All rows (dates)** copies the exact dates shown in the table.
- **Copy > All rows (cumulative days)** replaces the dates with the cumulative number of days since the date of the last saved value. For example, if the first date is 1/1/2015 and the second date is 12/31/2015, the cumulative days would be 0 for the first date and 365 for the second date.

**Target Conditions and Result Indicator**

The **Target Conditions** feature color-codes the current value of the metric. If all specified conditions are met, then the metric's value will be displayed in green. If one or more conditions are not met, then it will be in red. For example, in the following pictures, the result is green if the estimated system reliability is at least 80%, and red if it is not.

The **Result Indicator** feature color-codes the indicator that shows whether the value has increased or decreased since the prior saved value. If the direction of the change is desirable, the indicator will be green; if it is undesirable, the indicator will be red. As an example, the following pictures are from the SEP.

**Identifiers, History, Watch and Trace Usage**

As with most other Synthesis resources:

- **Identifiers** contains additional identifying information that can be used to search for this resource.
Chapter 19: Synthesis Resources

- **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the record.

- **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.

- **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

**Showing Metrics in Folios/Diagrams**
The Publishing page of the control panel shows all of the metric resources that are associated with the current analysis. (The metrics can be created and edited either from the Resource Manager or the control panel.) This applies for:

- Data sheets in Weibull++, ALTA or RGA that have a published model.

- Analytical or simulation diagrams in BlockSim that have a published model for the entire system (either a fitted model or an analytical model).

- Simulation diagrams in BlockSim that have simulation results.

This makes it easy to see the metrics that have been created for each analysis (which may also be displayed in relevant Project Planner gates or in the Synthesis Enterprise Portal website) and to see the history of how the analysis results changed over time. It also provides a convenient way to create new metrics for the analysis, if desired.

As an example, the following picture shows a typical scenario for Weibull++. In Weibull++, ALTA or RGA, the control panel shows all metrics that are associated with the model published from the current data sheet. In BlockSim, it shows all metrics that are associated with a model published from the diagram and/or obtained from the diagram’s simulation results.

- Double-click a metric to see its properties and history of saved values.

- A **Watch** icon will be shown beside any metric for which you have subscribed to receive an alert when the resource is changed.

- Click the **Metric Summary** icon to see a quick report of all the metrics displayed in the current branch.

http://blocksim.reliasoft.com
• Click the **Create New** icon to create a new metric.

**Associating Existing Metrics with a Different Data Sheet**

When an analysis changes (e.g., new data, after a design change, etc.), you may choose to simply update the existing data sheet and recalculate, or keep the original analysis unchanged and perform the updated analysis in a new data sheet.

If you decided to create a new data sheet, there are two ways to ensure that the metrics will reflect the complete history from both analyses:

**Publish to the existing model from the new data sheet**

If you want the published model to reflect the latest analysis results, you can simply transfer both the model and the associated metrics to the new data sheet. To do that:

1. Calculate the new data sheet and then go to the Publishing page of the control panel.
2. Click **Publish to Existing Model** and then select the model from the original data sheet.

**Change the model for the existing metrics**
If you want to keep the original published model associated with the original data sheet, you can publish a new model for the new data sheet and then transfer the metrics to the new model. To do that:

1. Publish a new model for the new data sheet.
2. From either the original data sheet’s control panel or the Resource Manager, open each metric that was associated with the original data sheet and change the **Associated Model**.

As a shortcut, you can click the **Select Existing** icon on the new data sheet’s control panel and choose one or more existing metrics in the Select Resource window. It is important to keep in mind that when you do this, you are changing the associated model for each selected metric.

**Using Metrics in Project Planner Gates**
There are two ways to utilize **metrics** in a **Project Planner** gate:

**Relevant Metrics**
For any gate in a project plan, you can choose to display up to three metrics that are relevant to this stage of the project (e.g., the target reliability, the latest calculated reliability, etc.).

Use the fields under the **Relevant Metrics** heading to select an existing metric or create a new one.
Push to Metrics

For any gate in a project plan, you can also choose to push any of the following values to a metric resource. This makes it easy to see the history of all saved values, and enables users to subscribe to receive alerts when the metric changes. You can also choose to show this information in the Synthesis Enterprise Portal if a web-based portal is implemented for the current database.

- **Percent Completed** is the percentage of the total duration of dependent actions/gates that is complete. For example, if Action 1 (duration = 3 days) is complete and Action 2 (duration = 1 day) is incomplete, the progress is 75%.

- **Actual Man Hours %** is the percentage of planned hours that have been used to complete the gate.

- **Actual Costs %** is the percentage of the budget that has actually been used to complete the gate.

Use the fields under the **Push to Metrics** heading to create a new metric or select an existing metric that is not already assigned to receive a pushed value. (Note that only unused metrics are shown in this list.)

When you first assign a metric in one of these fields, the current value will be automatically saved to the metric. Subsequently, the value will be recalculated each time an associated action or gate is changed. If the value is found to have changed, it will be saved to the metric. To see the current saved value, click inside the field. This will also display a result indicator and the **View Saved Values** icon, which you can click to see a history of all saved values.
Pushing Metrics from an FMRA

The **Push to Metrics** fields on the Properties tab of the Analysis panel in Xfmea/RCM++/RBI enable you to "push" the reliability and availability values that were calculated/simulated from the Failure Modes and Reliability Analysis (FMRA) to Synthesis metric resources.

This makes it easy to see the history of all saved values while you’re working in the FMRA, and enables users to subscribe to receive alerts when the metric changes. If desired, you can also choose to show this information in a specific Project Planner gate (under the Relevant Metrics heading), and in the Synthesis Enterprise Portal if a web-based portal is implemented for the current database.

1. Go to the FMRA tab in the system panel. (See Enabling and Viewing the FMRA in the Xfmea/RCM++/RBI documentation.)

2. Select any item in the FMRA hierarchy and use the fields under the **Push to Metrics** heading to create a new metric or select an existing metric that is not already assigned to receive a pushed value.

3. Calculate and/or simulate the FMRA:
   a. To calculate the reliability, choose **FMRA > Calculations > Calculate (Reliability).**

---

http://blocksim.reliasoft.com
b. To simulate the availability, choose **FMRA > Calculations > Simulate (Availability)**.

4. Each time you calculate/simulate the FMRA, the latest value(s) will be automatically saved to the metric(s). To see the history of all saved values, click **View Saved Values**.

<table>
<thead>
<tr>
<th>Reliability / Availability</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target Reliability</td>
<td>0.99</td>
</tr>
<tr>
<td>Current Reliability</td>
<td>0.933695</td>
</tr>
<tr>
<td>Target Availability</td>
<td>0.99</td>
</tr>
<tr>
<td>Current Availability</td>
<td>0.994000</td>
</tr>
</tbody>
</table>

Variables

A variable is a **resource** that stores a numerical value and allows you to assign a name to that value. You can then use the variable name in place of the actual value in the equations that you create. You can also use variables in functions and/or as conditional output values in conditional blocks, logic gates and branch gates.

A variable starts with an assigned initial value, which may be fixed or varied during simulation. You can use variables:

- In RENO, to act as a constant (i.e., maintain a fixed numerical value during simulation).
- In RENO, to temporarily store the output value of a block during simulation. See the next section for more information.
- In RENO, to perform a sensitivity analysis, which involves varying the value of one or two variables between runs (i.e., sets of simulations). For example, if you are analyzing potential investment strategies, you may wish to vary the number of years that you will be investing and/or the percentage of your income that will be invested to see how different inputs will affect the final results.
- As the basis for a **dynamic model**, which represents a fixed probability, duration or cost. The variable can be programmatically varied during simulation, thereby changing the value of the model for successive simulation runs.
Chapter 19: Synthesis Resources

- As inputs for certain fields in BlockSim simulation RBDs via simulation worksheets, allowing programmatic variation of the field value during simulation.

**What's Changed?** In previous versions of RENO, variables that stored fixed values were known as constants, and variables that stored outputs were known as storage variables.

### Using Variables to Store Output Values in RENO

You can use variables to hold numerical values passed to them during simulation. In RENO, the following blocks are able to store their output values in variables:

- Standard blocks
- Result storage blocks
- Flag markers
- Counter blocks

Depending on your choice in the **When to Reset** field of the variable's properties window, you can configure the variable to retain the value passed to it during simulation or reset the variable to its initial value at specific times. The options are:

- **Reset After Each Simulation** (i.e., reset after a single pass through the flowchart)
- **Reset After Each Run** (i.e., reset after each set of simulations)
- **Reset After Analysis** (i.e., reset after each set of runs)
- **Never Reset**

When the simulations end, the variable always returns to its initial starting value unless you have selected **Never Reset**. If you wish to keep the value used during simulation, you can use a result storage block to store it.

**Example**

The following example demonstrates two things: a) how a variable may be used to store an output value and b) how a variable may be used in an equation.

In the following configuration, the first block calculates the gross profit from a sale, and then stores its output into a variable called "Profit." The conditional block determines whether the gross profit exceeds 500. If the output is true, the third block deducts the sale's commission from the profit, and overwrites the stored value with the new output.
The following picture shows the properties window of the variable called "Profit." The initial value of this variable is set to 0.

The following picture shows the Block Properties window of the first block in the example. The output of the equation is stored in the variable.
The following picture shows the Block Properties window of the third block in the flowchart. The equation shows that the commission is deducted from the existing value in the variable, and then the variable is overwritten with the new result. At the end of the simulation, the result storage block in the flowchart stores the final value of the variable, and then the variable resets to 0.
Profiles

New in Version 11, a profile is a Synthesis resource that allows you to represent a value that varies with time. It consists of a basic pattern that either repeats as a cycle or occurs once and then continues from its last defined setting.

What’s Changed? The profile resource replaces the stress profile functionality that was available in previous versions of ALTA PRO.

This topic describes how to create profiles, which can be defined by entering values manually or by importing data from nCode GlyphWorks.

To learn how to use profiles in ALTA life-stress data folios, see Time-Dependent Stress Profiles in the ALTA documentation.

Creating Profiles

Like any other Synthesis resource, you can create or edit profiles from the Resource Manager, and while you’re performing a relevant analysis. To create a profile:

1. Define a pattern for how a stress level will change over a specified period of time. The pattern you will define consists of a series of segments, where each segment has a specified duration and either:
   - a constant stress value, or
   - a function that takes a time value and returns a stress value.

These segments are defined in the spreadsheet, as shown next.

<table>
<thead>
<tr>
<th>Segment Start</th>
<th>Segment End</th>
<th>Stress ( S(t) )</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>1100</td>
<td>328</td>
</tr>
<tr>
<td>1100</td>
<td>2200</td>
<td>338</td>
</tr>
<tr>
<td>2200</td>
<td>3300</td>
<td>348</td>
</tr>
</tbody>
</table>

- **Segment Start** is calculated automatically by the software and cannot be entered manually. The first segment’s start time is always 0. For every subsequent segment, the start time is identical to the prior segment's end time.

- **Segment End** allows you to enter the end time for each segment, which must be smaller than the end time of the next segment.

- **Stress \( S(t) \)** is the stress value or function for the segment. If the stress level will stay constant during a segment, enter a constant value (e.g., 30). If the level will
change during a segment, enter the value as a function of time (e.g., at time = 20, the function $t + 20$ will return a value of 40). When entering a function, you must use $t$ or $T$ as the time variable.

**Tip:** Because stress units (e.g., volts) and time units (e.g., hours) are not defined in the profile, it is important to apply profiles only to folios that are intended to use the same stress and time units. In the Profile window, you may want to rename column headings (by right-clicking the heading) or use the Comments page as a reminder of which units are applicable to that profile.

For example, suppose the stress unit is psi and the time unit is seconds. Now suppose you wanted to define the following 120-second pattern: a stress value of 30 psi for 60 seconds, followed by a stress value of 50 psi for 30 seconds, followed by a stress function that begins at 50 psi and gradually decreases at a rate of 1 psi per second for the remainder of the pattern. For this pattern, you could fill out the spreadsheet as follows:

<table>
<thead>
<tr>
<th>Segment Start</th>
<th>Segment End</th>
<th>Stress $S(t)$</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>60</td>
<td>30</td>
</tr>
<tr>
<td>60</td>
<td>90</td>
<td>50</td>
</tr>
<tr>
<td>90</td>
<td>120</td>
<td>$50 - (t - 90)$</td>
</tr>
</tbody>
</table>

Notice that the last segment of this profile uses a stress function. Since $t$ is the test time (or, if the profile is cyclical, the time since the pattern was last restarted), $t = 90$ when the last segment begins. So the last segment’s stress level starts at $50 - (90 - 90) = 50$. Then, at 91 seconds, the stress level will have dropped to $50 - (91 - 90) = 49$. After another second it will have dropped to $50 - (92 - 90) = 48$, and so on.

2. Next, choose the appropriate option in the **After Last Segment** area of the control panel. Your selection here will determine what happens after the end time of the profile’s last segment (in the above example, after time = 120).

If you select **Continue with last value**, all times after the last segment will use the value/function defined in the last segment.

If you select **Repeat cycle**, the entire pattern of segments will be treated as a repeating cycle.

For example, suppose you defined a pattern that is made up of five segments, each an hour long and increasing stepwise from the segment before. The graphs below illustrate the difference between continuing from the last stress (left) and selecting to repeat (right). In this example, the test has a duration of 20 hours, and the graphs explain what would happen through the entire duration of the test.
3. Before you can use the new profile in your analysis, you must save any changes you have made and validate the current profile settings. To do this, click the **Validate Profile** icon.

After you save the changes in your profile, the **Profile Summary** area will appear. Click the **Detailed Summary** icon to open the Results window, which shows the current profile in a worksheet that you can copy or print.

To view a stress vs. time plot of the profile, click the **Plot** icon. (See **Synthesis Plot Utilities** for general information on plots.)

**Note:** Clicking the **Validate Profile** icon will not automatically update your stress vs. time plot. To make sure your plot reflects the most recent profile information, click the **Plot** icon.

If desired, you can use the Comments page of the control panel to enter notes or other text that will be saved with the profile.

**Importing Data from nCode GlyphWorks**

New in Version 11, you can import **nCode GlyphWorks** time series data from .S3T files for use as stress profiles. The stress values in the .S3T file must be greater than zero in order for the data to be imported.
To import data from an nCode .S3T file, first create a new profile from the Resource Manager (Project > Synthesis > Resource Manager). In the Profile window, click the Import from GlyphWorks icon on the control panel.

This launches the import wizard, which guides you through the steps required to import data from the file. You can then edit the resulting imported data, if desired. Note that if you update the .S3T file in GlyphWorks, the associated profile in ALTA will not be updated automatically. You must re-import the data to reflect the changes.

**Tip:** Because stress and time units are not defined in the profile, it is important to apply profiles only to folios that are intended to use the same stress and time units. In the Profile window, you may want to rename column headings (by right-clicking the heading) or use the Comments page as a reminder of which units were used by the data imported from the nCode file.

### Maintenance Groups

Maintenance groups are resources that are available for use throughout the project and can be managed via the Resource Manager. A maintenance group is a set of blocks or system hierarchy items where some event within the group can trigger either maintenance or state changes for one or more blocks or items, either within the group or outside of it. You can use a maintenance group:

- **In BlockSim:** To turn a block on or off. State change triggers are used to activate or deactivate a block when items in one or more specified maintenance groups go down or are restored. The block whose state is being changed may or may not belong to any of the maintenance groups. This allows you to model a cold standby configuration (i.e., one where the component cannot fail when in standby) without using a standby container, which may be useful if you are using a parallel or complex configuration, as blocks can be connected only in series in standby containers.

- **In BlockSim, RCM++ or RBI:** To trigger a scheduled task (i.e., a preventive task, inspection or on condition task). You can set the task to be performed based on events in one or more maintenance groups. Triggering events within the maintenance group can include block/item failure; start of corrective, preventive or inspection tasks; and/or block/items restoration. The block(s)/item(s) affected by the task may or may not belong to any of the maintenance groups. For example, if you want to perform preventive maintenance on Component A every time you perform corrective maintenance on Component B, then you can assign Component B to Maintenance Group 1 and then set the preventive task assigned to Component A to be performed
upon the start of corrective maintenance within Maintenance Group 1. See Task Scheduling for more information on how tasks can be scheduled.

**Note:** In BlockSim diagrams, blocks that belong to a maintenance group have a red circle at the upper left corner of the block. You can change the size of the indicator via the relevant Block Corner Indicators page of the Diagram Style window. You can change the color used for each maintenance group via the Maintenance Group Manager.

The Maintenance Group window allows you to create, view and edit maintenance groups. It can be accessed by clicking the Create New or View/Edit icon in the Maintenance Group wizard.

It can also be accessed from the Maintenance Groups page of the Resource Manager by choosing Home > Edit > New, by selecting a maintenance group and choosing Home > Edit > View or by double-clicking a maintenance group.

At the top of the window, you can specify the maintenance group name. You can replace the default name with your own name of up to 150 characters, if desired. To change the default names, choose File > Manage Repository > Default Name Formats. (In a secure database, this is available only to users with the "Manage other repository settings" permission.)

You can also enter comments about the maintenance group in this window.

For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

**Maintenance Group Manager**

In BlockSim only, the Maintenance Group Manager allows you to add blocks to or remove blocks from a maintenance group without having to go into each block's properties individually. This window can be accessed by choosing Project > Data Management > Maintenance Group Manager or, when you are viewing the Maintenance Groups page of the Resource Manager, by choosing Home > Actions > Maintenance Group Manager.
Chapter 19: Synthesis Resources

The **Maintenance Group** area allows you to choose an existing maintenance group from the drop-down list. In addition, you can click the **Select Existing** icon to open the **Select Resource window**. If there is not an existing maintenance group that meets your needs, you can create a new one by clicking the **Create New** icon to open a window that allows you to specify a name for the new maintenance group, as well as any comments. Click the **View** icon to view the characteristics of the selected maintenance group.

You can also click the **Indicator Style** icon to modify the appearance of the corner indicator that will appear on each block that belongs to the maintenance group, including:

- The indicator's background color, fill color and fill style. The background color is the underlying color applied to the indicator; the fill color is applied over the background color in the pattern specified by the fill style.
• The style (e.g., solid, dash, etc.), color and thickness of the indicator border.

You can change the size of the indicator via the relevant Block Corner Indicators page of the Diagram Style window.

The Blocks area displays all of the blocks in the maintenance group, in the format [Diagram Name]\{Block Name\}.

• To add a block to the maintenance group, you can select the diagram and block in the Add Block area and click the Add to Maintenance Group button. You also can select the block(s) in the diagram, press CTRL+SHIFT and drag the block to the list in the Blocks area of the Maintenance Group Manager.

• To view a block in the maintenance group, select the block in the list and click the Select on Diagram button. The diagram will be displayed with the block selected.

• To remove a block from the maintenance group, select the block in the list and click the Remove from List button.

**Mirror Groups**

Mirror groups are resources that are available for use throughout the project and can be managed via the Resource Manager. You can use a mirror group:

• In BlockSim: To place the same block in more than one location (i.e., to represent a single component more than once in a diagram or in multiple diagrams within a project). See Mirroring (Using Blocks in Multiple Locations) in the BlockSim documentation.

• In the FMRA in BlockSim, Xfmea, RCM++ or RBI: To place the same cause in more than one location in the FMRA hierarchy, in order to consider common cause failures. See Using Mirror Groups in an FMRA in the Xfmea/RCM++/RBI documentation.

**Task Packages**

Task packages are resources that can be shared among analyses and can be managed via the Resource Manager. They represent groups of tasks that are performed together at scheduled intervals, for the most efficient allocation of resources and downtime management.
Chapter 19: Synthesis Resources

The Task Package window allows you to create, view and edit task packages. It can be accessed by clicking the Create New or View/Edit icon in the Task Package wizard, which is accessed from the Task Package field that appears when you select the Override task scheduling properties with a task package option for a preventive, inspection or on-condition task that is scheduled to be performed at fixed intervals.

It can also be accessed from the Task Packages page of the Resource Manager by choosing Home > Edit > New, by selecting a task package and choosing Home > Edit > View or by double-clicking a task package.

For a new resource, a name will be proposed automatically based on the default naming criteria established for the current database (see Default Name Formats window). You can replace this with your own name of up to 150 characters, if desired. Remember that the name and identifiers are the primary way in which your team will be able to find the Synthesis resources you need for your analyses.

The following settings are available to configure the task package:

- In the **Perform every** field, enter the length of the interval at which the task package will be performed. You must specify time units for this value.

- The **Auto-Packaging Intervals** fields allow you to specify a range of scheduled intervals that will automatically be incorporated into the task package if the user clicks the Auto-Package Tasks button at the bottom of the Maintenance Task Packaging window in RCM++/RBI. The time units for these fields are the same as those specified for the Perform every field. For example, if you enter 150 hours in the Start time field and 200 hours in the End time field, then tasks that are scheduled to be performed at fixed intervals from 150 to 200 hours can automatically be included in the task package to be performed at the scheduled time of the task package rather than at their individually scheduled times.

- **Identifiers** contains additional identifying information that can be used to search for this resource.

- **History** provides information about when the record was created and last updated. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the record.

- **Watch** allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the resource is changed.
• **Trace Usage.** For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

## Actions

Throughout the Synthesis Platform, your team can use actions to track specific assignments that need to be performed. These versatile Synthesis resources can be used multiple times in different locations, if appropriate. Specifically, actions can be created, displayed and/or managed:

- via [Project Plans](#) or the [Resource Manager](#) in all Synthesis desktop applications except MPC.
- via [My Portal](#) or [Actions Explorer](#) in all Synthesis desktop applications.
- via the [Synthesis Enterprise Portal](#) (if it is implemented for your database).
- via FMEAs or Test Plans in Xfmea/RCM++/RBI.

For specific instructions regarding how to create or edit an action in each location, please consult the documentation for that particular feature. This section focuses on general considerations that will be applicable regardless of where/how the action is being used.

**Tip:** If an action is used in an FMEA, the properties window will be different depending on the current context. If you’re using Xfmea/RCM++/RBI and you open the action from the FMEA or My Portal, the window includes additional features that provide quick access to associated FMEA records (failures, causes, etc.) and the FMEA change log (if activated). These features are not available if you open the action from another location (e.g., Resource Manager, Project Planner, Actions Explorer) or in another application, because the associated FMEA can’t be opened in those situations.

## Actions as Resources

As with any other Synthesis resource:

- Any changes to the action properties will be reflected in all locations where the resource is used.

- If you remove an action from an FMEA or Project Plan, the resource will remain in the project unless/until an authorized user deletes it from the database (via My Portal, Resource Manager or Actions Explorer).
Chapter 19: Synthesis Resources

**Note:** Actions are always local resources. They cannot be made global. Actions in a reference project are local to that project and can't be selected for use in other projects.

### Configurable Settings

Some properties for action records can be configured via interface style settings. See Configurable Settings.

### Show/Hide Properties for Individual Records

You can also use the following ribbon commands to show/hide certain features for a particular action record.

- **Generic vs. Detailed:** A detailed action contains additional properties for describing a specific test that needs to be performed (Specifications, Requirements and Reports). These properties are not configurable, and they can be used in the new Test Plans features in Xfmea/RCM++/RBI. (See Test Plans in the Xfmea/RCM++/RBI documentation.)

- **Show Resources:** The resources fields (Team, Facility, Material and Additional Costs) are used for calculating costs and resource utilization. They are always enabled but you can toggle this command to hide or display them for any particular action record. The Check Utilization command provides a summary of the resources that have already been assigned. (See Costs and Man Hours.)

- **Show Review/Approval:** If the Reviewer property is enabled in the configurable settings for the current project, you can toggle this command to hide or display these fields for any given action. The Review Action command will be enabled if you are assigned to review the action and it is ready to be reviewed. (See Review and Approve Actions.)

### Priority

The color-coded Priority command provides a consistent scale for prioritizing actions across all projects in the database. (The same options are also available for gates in the Project Planner.)
This is intended to be used instead of the configurable **Action Priority** field from prior versions, which can be different for different projects. When you convert from a Version 8/9 database, the software will attempt to match any priorities that were assigned with the old configurable drop-down list. For example, if you were using the default "High," "Medium" and "Low" labels that were shipped with Version 8/9 libraries, they will automatically be mapped to the corresponding options in the new ribbon command.

**Action Status and Review Status**

The action’s status bar displays two complementary status indicators. The first one is based on the actual and expected start date and completion date. It indicates that the action is not started, in progress or complete and whether it is on time or running late. (See **Action Timeline and Status**.)

The second one is based on whether a reviewer has been assigned in the Review/Approval section and, if so, the status of that review.

**E-mail and Alerts**

The **E-mail** command will be enabled if an authorized user has defined a valid SMTP server. This allows you to manually send an e-mail containing the current action details to any valid e-mail address.

If a valid SMTP server has been defined within the database, your team can also choose to use automated alerts (via e-mail or SMS text message). Each individual user can subscribe to “watch” specific action resources, and the database can also be configured to auto-subscribe users assigned to specific roles for the action. (See **Watches and Alerts**.)
Click Action Monitors to specify individual users and/or groups of users who will always receive alerts for the record, regardless of whether they have personally subscribed to a “watch.” (See Action and Gate Monitors.)

Add to Outlook Calendar

The Add to Outlook Calendar command will be enabled if Microsoft Outlook is installed on your computer.

It launches Outlook’s interface for creating a new calendar event and automatically populates the subject and date. You can modify the details as needed before saving the new event to your calendar.

Note that you may need to give focus to the Outlook application in order to see the window.

Person Responsible and Resources

For each action resource, you can assign both an individual database user who is primarily responsible for completing the action and a team of users who are also involved. You also have the option to track the percentage of their available time that is planned to be utilized for the activity.

Tip: If a user is assigned as person responsible and also belongs to the team, the costs and utilization values will be summed. For example, the application assumes that the utilization is X% as person responsible plus an additional Y% as a member of the team.

Person Responsible

The Person Responsible field can be enabled or disabled, depending on the configurable settings for the current project. If you want to use personalized alerts, track resource utilization etc., you must select a database user. Alternatively, you can type a text description (up to 150 characters) that will be displayed in the FMEA spreadsheet.
Tip: If you want to change the person responsible for multiple actions simultaneously (e.g., if a user changes roles and his/her actions need to be reassigned), use the Actions Explorer.

If the **Set action creator as 'Person Responsible' by default** check box is selected in the **Repository Settings window**, then the person who created the action is automatically shown in the **Person Responsible** field, but that can be changed.

**Resources**

The **Resources** fields are always enabled but you can toggle the **Show Resources** command to hide or display them for any particular action record.

You can select from the teams, facilities and materials resources that have been predefined within the database (or create them on-the-fly if you have the required permissions). In a secure database, only users with the **“Manage project planning resources and working days” permission** will be able to create and edit these resources. (See **Project Planning Resources**.)

<table>
<thead>
<tr>
<th>Resources</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Team</td>
<td>Gizmo Design Team (5%)</td>
</tr>
<tr>
<td>Facility</td>
<td>AE5 Test Lab (2%)</td>
</tr>
<tr>
<td>Material</td>
<td>N/A</td>
</tr>
<tr>
<td>Additional Costs</td>
<td>1000</td>
</tr>
</tbody>
</table>

**Check Utilization**

If you need to **view the utilizations** of users and facilities for the current action, click **Check Utilization**.

**Action Timeline and Status**

For all action resources, the status is determined automatically based on the actual and expected start/completion dates. If an action is included in the Project Planner, its **expected timeline** can automatically shift in response to delays in prior activities. If the action is not included in the plan, the expected dates are always identical to the originally planned dates.
The following status indicators are displayed in the status bar of the action properties window and in other relevant locations. (Note that the status bar now also displays a separate review status to indicate whether a user has been assigned to review/approve the action and, if so, the status of the review. See Review and Approve Actions.)

- **Not Started**: The action hasn't started, but it can still start on time.
- **Past Start Date**: The action hasn't started, and it is too late to start on time.
- **In Progress**: The action has started.
- **Past Due**: The action hasn't completed, and it is too late to complete on time.
- **Completed - On Time**: The action completed on time.
- **Completed - Late**: The action completed late.

### Costs and Man Hours

For action resources, you can now track the planned vs. actual usage for both costs and man hours.

The **Planned Cost** and **Actual Cost** fields can be enabled or disabled, depending on the configurable settings for the current project. If the properties are enabled, the planned costs will always be calculated automatically based on the action duration, person responsible and project planning resources. For the actual costs, you can choose to enter manually or use the automatic calculations.

#### Enter Manually

If you prefer to enter the actual costs/hours instead of using the automatically calculated values, select Yes in the **Manually enter costs/man hours?** field.

<table>
<thead>
<tr>
<th>Manually enter costs/man hours?</th>
<th>No</th>
<th>Manually enter costs/man hours?</th>
<th>Yes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actual Cost</td>
<td>240.00</td>
<td>Actual Cost</td>
<td>475</td>
</tr>
<tr>
<td>Actual Man Hours</td>
<td>2.4</td>
<td>Actual Man Hours</td>
<td>5</td>
</tr>
</tbody>
</table>

**Let the software calculate** \hspace{10cm} **Enter the values yourself**

### Calculate Automatically

The automatic calculations are based on:

- The Duration (the number of working days from the start date to the due/completion date).
• The Person Responsible and/or the Team:
  • The % utilization is set in each action record.
  • The Hours per Day and Cost Category are set in each user account record.
• The Facility (e.g., test lab or other facility needed to complete the action):
  • The % utilization is set in each action record.
  • The Max Hours per Day and Cost Category are set in each facility properties record.
• The Materials (e.g., test samples or other material needed to complete the action):
  • The Quantity and Cost Category are set in the material properties record.
• Any Additional Costs that are defined directly in each action record.

The following simple examples demonstrate how each type of cost is calculated.

**Personnel Costs**

**Action Duration:** 5 working days

**Joe Engineer:** Works 8 hours per day (5 days x 8 hours = 40 hours)

  Time is billed at $100 per hour (no “per instance” cost)

  Assigned as Person Responsible with 5% utilization (40 hours x .05 = 2 hours)

  Also belongs to the assigned Team with 1% utilization (40 hours x .01 = .4 hours)

The calculated values for Joe’s work on this action are 2.4 man hours and 2.4 x $100 = $240.

**Facilities Costs**

**Action Duration:** 5 working days

**ABC Test Lab:** Is available up to 8 hours per day (5 days x 8 hours = 40 hours)

  The utilization for this action is 20% (40 hours x .20 = 8 hours)

  Costs $500 “per instance” plus $50 per hour

The calculated cost for using this facility to complete the action is $500 + (8x$50) = $900.
Materials Costs

Gizmo Prototype: Costs $5000 to produce the batch of test units (the “per instance” cost)

The test requires 10 samples

Each unit costs $500 (the “direct cost per hour or unit”)

The calculated cost for the materials required to complete the action is $5000 + (10x$500) = $10,000.

Action Status Updates

For all action resources, the Progress (Status Updates) area displays any notes that have been added to report progress. The software automatically adds these updates under certain conditions (e.g., upon review/approval), and you can also create updates manually when needed.

To add a new note, click Add Status Update in the action’s ribbon or click the heading and then click the Add icon that becomes visible.

The type that you select in the Add Status Update window can affect the actual start and completion dates of the action, and also update the action status. (See Action Timelines and Status.)

- **Not Started** allows you to record comments without entering a start date. If an actual start date has already been entered, the update will remove the date and change the action’s status back to Not Started.

- **In Progress**
  - If an actual start date is not already defined, sets the current date as the Actual Start Date and allows you to specify the % Completed. This will change the action’s status to In Progress.
• If the action is already in progress, allows you to add another note and update the completion percentage.

• **Completed** sets the current date as the **Completion Date**. This will change the action’s status to either **Completed-On Time** or **Completed Late**.

To delete an existing note, click inside the field and then click the **Delete** icon that becomes visible. **There is no undo for delete.**

| Progress (Status Updates) | 2/3/2015 4:04 PM - Reliability Engineer - 0 %
|  | This is a short message to record progress for an action that is still in progress. |

**Review and Approve Actions**

**Action resources** can be marked for review and approval. If the Reviewer property is enabled in the **configurable settings for the current project**, you can click **Show Review/Approval** in the action ribbon to hide or display these fields for any given action.

(Note that if an action has been assigned for review or is already reviewed, you can no longer hide the fields.)

**Assigning a Reviewer**

If an action has not yet been reviewed, any user who is able to edit the record can assign or change the reviewer at any time.

In a secure database, the Reviewer drop-down list contains all of the database users who have the "Approve actions" permission.

• If a user has been assigned to review the action but an actual completion date is not entered, the review status will be **Reviewer Assigned**.

• When the completion date is entered and the action is ready for review, the status will be **Pending Approval**.

**Tip**: If you want to change the assigned reviewer for multiple actions simultaneously (e.g., if a user changes roles and his/her actions need to be reassigned), use the **Actions Explorer**.
Chapter 19: Synthesis Resources

Reviewing and Approving the Action
When you are assigned to review/approve an action that has been completed, the record will be highlighted for you in My Portal (and in the Synthesis Enterprise Portal if implemented), and you may also receive automated alerts (via e-mail and/or SMS) if applicable.

To record your decision, open the action record and choose Review Action.

In the Review Action window, you can choose one of the following options:

- **Approve action** assigns the review date/time and marks the status Approved.
- **Reject and re-open action** removes the completion date and marks the status Rejected and in progress. The team can perform any rework that is needed and resubmit the action for another review.
- **Reject and close action** marks the status Rejected and closed.

You can enter your comments directly in this window, or enter/update them later in the comments field.

![Review/Approval Window](image)

Configurable Settings for Actions and Controls
Some of the properties in action records and in control records are configurable via the interface style settings that have been defined for the current project. The interface style is used in Xfmea/RCM++/RBI to customize a variety of analysis fields to fit the organization’s particular preferences and needs. (See Configurable Settings in the Xfmea/RCM++/RBI documentation.)

You can view/edit the configurable settings for actions and controls from any Synthesis desktop application by clicking Configurable Settings of the action properties window or the control properties window. (In secure databases, this is available only if the user is the project owner, or has the "Edit project properties" permission.)
Any changes to these settings will apply to all records of that type in the current project.

**Actions Explorer**

The Actions Explorer is available in all Synthesis desktop applications except MPC. You can use this flexible tool to explore all of the *action resources* that are stored in the current database.

To access the utility, choose **Home > Synthesis > Actions Explorer**.

To reduce the amount of time required to populate the grid, first use the Project, Status, User and/or Date filters to limit your search, then click **Load Data**.

![Actions Explorer Grid](image)

**Add, Edit and Delete Actions**

When actions are loaded in the grid, you can use the following ribbon commands to add, edit and delete actions. (In a secure database, the ability to add or edit an action is only available for users with the "Create/edit/delete local resources" or "Create/edit/delete local resources" permission in the relevant project.)

To delete or edit multiple actions at the same time, press **CTRL** or **SHIFT** while clicking rows in the grid. Selected rows will be highlighted.

- **Add Action** creates a new action resource in the project that currently has focus.
- **Edit Action** allows you to view and edit all of the properties of the action that is currently selected.
- **Delete Action** deletes all of the actions that are currently selected. There is no undo for delete.
- **Assign Person Responsible** and **Assign Reviewer** allow you to set (or change) the person responsible or reviewer for all of the actions that are currently selected.

**Save and Apply Views**

Once you have customized the grid to suit a particular purpose (using the built-in filter, column configuration and grouping features described below), you can save the preferences as a view that can be used again whenever you need it. A view is saved in the database and available only to the user who created it.
Chapter 19: Synthesis Resources

To create a view, first configure the grid to suit your particular needs and then click **Save View**.

To quickly apply these same preferences again at any time, click **Apply View** and select one of the saved views from the list.

**Note**: The view does not affect filtering that has been applied from the Project, Status, User and/or Date filters, or from the Relevance Panel.

---

**Project, Status, User and Date Filters**
The Actions Explorer can utilize the same project filter that is available in many other locations throughout Synthesis desktop applications.

You can also filter by status (e.g., In Progress, Completed, etc.), user (e.g., Person Responsible or Reviewer) and date (e.g., Planned Start Date, Actual Start Date, etc.).

After you clear or change these filters, you must click **Load Data** again to update the grid.

---

**Relevance Panel**
The relevance panel provides a quick way to filter the actions based on how they are relevant to you (based on your personal username).

- **I am responsible for**
  - You are assigned in the **Person Responsible** field.

- **I am a team member in**
  - You belong to the team assigned in the **Team** field.

- **I need to review/approve**
  - You are assigned in the **Reviewer** field.
• **I am monitoring**
  - You are assigned in the Action Monitors window, or you have personally subscribed to "watch" the action.

• **Other actions I created**
  - You are listed in the **Created By** field and none of the other roles apply.

• **All actions**
  - Displays all actions, regardless of whether they’re relevant to you.

### Built-in Find/Filter, Configuration and Grouping Tools
The Actions Explorer offers the same filter, column configuration and grouping tools that are built in to other Synthesis utilities that use a similar grid (e.g., the **Resource Manager**). For details about how to use each feature, see:

- [Finding and Filtering Records](#)
- [Configuring Columns](#)
- [Grouping Panel](#)

### Controls
Controls are **Synthesis resources** used in FMEAs that are the methods or actions currently planned or already in place to reduce or eliminate risk. Controls can be managed via the **Resource Manager**.

As with any other Synthesis resource:

- Any changes to the control properties will be reflected in all locations where the resource is used.
- If you remove a control from an FMEA, it will remain in the project unless/until an authorized user deletes it from the database.
- If a control resource is not currently used in an FMEA, you can delete it via the Resource Manager. (In a secure database, this is possible only if the user a) is the **project owner**, b) is the control creator, or c) has the applicable "create/edit/delete resources" permission.)
For existing resources, the link at the bottom of the window indicates how many times the resource is currently being used. If you need more information, click the link or the icon to open the Dependency Viewer.

**Note:** Controls are always local resources. They cannot be made global. Controls in a reference project are local to that project and can't be selected for use in other projects.

For specific instructions on using controls in FMEAs, see the "Controls in FMEAs" topic in the Xfmea/RCM++/RBI documentation.

### Configurable Settings

Some properties for controls can be configured via interface style settings. See Configurable Settings.

### Resource Manager

The Resource Manager allows you to create, view, edit and delete Synthesis resources. It also helps you to trace where each resource is used, and to create global resources that are available to all projects in the database.

To open the Resource Manager, choose **Project > Synthesis > Resource Manager**.

To use the utility, choose the type of resource that you want to work with in the navigation panel on the left side of the window. A table that displays the resources of the selected type will be shown on the right side of the window.

**Tip:** When you need to create or edit a large number of resources, you can also use Synthesis APIs to import the data from an Excel file or other data source. For example, the URDExample_V10.xlsm file at C:\Users\Public\Documents\ReliaSoft\Examples10\API enables you to quickly create/update multiple URDs with some basic properties (models and corrective tasks). If you have the necessary software coding experience, you can expand this tool or create your own custom applications to meet specific needs.
Resource Filter
The Resource Manager can utilize the same resource filter that is available in many other locations throughout Synthesis desktop applications.

Built-in Find/Filter, Configuration and Grouping Tools
The Resource Manager offers the same filter, column configuration and grouping tools that are built in to other Synthesis utilities that use a similar grid (e.g., the Synthesis Explorer, Actions Explorer, etc.). For details about how to use each feature, see:

- Finding and Filtering Records
- Configuring Columns
- Grouping Panel

Creating, Viewing, Editing and Deleting Resources
You can:

- Create a new resource of the selected type by choosing Home > Edit > New.

To add multiple resources at the same time, specify the quantity in the Home > Batch Add > Number to Add field and then choose Home > Batch Add > Add Items. You will specify the properties for one of the new resources, and the additional resources will be duplicates of that. You can then edit each resource individually, or you can go to the Batch Properties Editor to edit them in a spreadsheet format.

- Duplicate an existing resource by selecting the row in the table and choosing Home > Edit > Duplicate. You can choose to duplicate just the selected resource, or choose Cascade Duplicate to duplicate the resource and all resources assigned to it, at all levels (e.g., cascade duplicating a corrective task will also duplicate the task's duration model, the assigned crew and all models assigned to the crew, etc.).
Chapter 19: Synthesis Resources

- View or edit an existing resource by double-clicking the row in the table or by selecting the row and choosing Home > Edit > View.

- Delete an existing resource by selecting the row in the table and choosing Home > Edit > Delete.

You cannot delete a resource that is currently being used in any other resource or analysis.

**Note:** A published model cannot be edited or deleted from the Resource Manager. If changes are needed, you must update the original analysis and then republish the model. If you wish to delete the model, you must first remove the association with the original analysis and also make sure the model is not being used. (See **Publishing Models**.)

**Tracing Where Resources Are Used**

With a single resource selected, you can choose Home > Actions > Trace Usage to open the Dependency Viewer, which provides information on where the resource is used and any additional resources that the currently selected resource itself uses.

If you need to know which resources are not currently being used (e.g., because you want to delete obsolete records), choose Administration > Selection > Show Only Unused.

**Local and Global and Reference Resources**

As explained in **Local, Global and Reference Resources**, the availability of Synthesis resources for use is determined by their scope. *Local resources* are available only in the current project. *Reference resources* are available for any project within the database, depending on the user's permissions within the reference project. *Global resources* are available for use in any project in the database.

The far left column in the Resource Manager displays an icon that indicates whether each resource is local, global or a reference resource.

![Local Resource](image1.png) ![Global Resource](image2.png) ![Reference Resource](image3.png)
You can use the **Home > Filter > [Show Local/Show Global/Show References]** commands to toggle the types of resources shown in the Resource Manager.

**Exporting Information from the Resource Manager**

To print the current view of the Resource Manager, choose **Home > Edit > Print**.

To send the contents of the Resource Manager to Excel, or to a built-in **Synthesis Workbook** or spreadsheet if that's available in the current application, choose **Administration > Actions > Transfer Report**.

You can send either the current item (i.e., the table for the currently displayed page) or the full report (i.e., the tables for all pages in the Resource Manager).

**Finding and Filtering Records**

This topic describes the find and filter tools that are built in to the Resource Manager and other Synthesis utilities that use a similar grid. Each of these tools can be used separately, or in conjunction with the others.

**Find Panel**

The Find panel allows you to search for a word or phrase across all of the available properties. When you enter text, it will:

- Show only the rows that contain the text you specified.
- Highlight all of the locations where the matching text occurs.
Chapter 19: Synthesis Resources

To show or hide this panel, toggle the **Show Find Panel** command on the ribbon or in the shortcut menu that appears when you right-click a column heading.

To stop filtering the data, clear the text box.

**Auto Filter Row**

The Auto Filter Row allows you to automatically filter the grid by matching text in one or more columns. For example, the following grid shows only the rows in which the model name contains "Component A" and the distribution contains "Weib."

To display or hide this row, toggle the **Show Auto Filter Row** command on the ribbon or in the shortcut menu that appears when you right-click a column heading.

**Advanced Filters**

The Advanced Filters allow you to choose an automatically generated filter or create a quick custom filter. The automatically generated filters are based on the unique values that currently exist in the column.
For example, the following picture is based on a data set that contains models from three different categories. If you choose one of the automatically generated filters (e.g., "Reliability"), the grid will display only models of that one selected category.

If you want to see models from two of those categories (e.g., either "Reliability" or "Probability of Failure"), you can choose (Custom) and create a quick custom filter like this:

![Custom AutoFilter](image)

If a filter has been applied for a particular column, select (All) to remove it.

**Current Query Criteria**

When you are filtering the grid using the Auto Filter Row, Advanced Filters and/or Edit Filter window (described below), the current query criteria will be displayed at the bottom of the window. For example:

```
[Model Category] = 'Reliability' And Contains([Model Name], 'Component A', 'Reliability') And Contains([Distribution], 'Web')
```

- Click the X to delete the current set of filter criteria.
• Clear the check box to remove the current set of criteria without deleting it. Select the check box if you want to re-apply it.

• Click  to choose from a list of filter criteria that were recently applied.

Edit Filter
The Edit Filter window provides the most flexibility to refine and adjust a filter in either a grid or a Dashboard layout. To access the tool, click the Edit Filter button to the right of the current query criteria (if applicable), or choose Edit Filter from the shortcut menu.

As an example, the following filter from the Resource Manager will display only cost per unit time models in which the rate equals either $120 per hour or $2 per minute.

• Click a red label if you want to:
  • change the logical operator (And, Or, Not And, Not Or)
  • add or remove a group
  • add a condition
  • clear the entire filter
• Use the  and  icons to add or remove conditions within an existing group.
• Click a blue label if you want to change the property (e.g., Model Name, Created By, etc.).
• Click a green label if you want to change the relational operator (e.g., Equals, Contains, Begins with, etc.).

• Click a gray or black label if you want to enter or change the value.

### Configuring Columns
This topic describes the capabilities for selecting, reordering, resizing and sorting columns that are built in to the Resource Manager and other Synthesis utilities that use a similar grid.

#### Selecting Columns
To specify which columns will be displayed in the grid, click **Select Columns**.

In the utility's window or panel for selecting columns, use the check boxes to choose which columns will be displayed. As an example, the following pictures show the window and panel for model resources in the Resource Manager.
Chapter 19: Synthesis Resources

**Reordering Columns**

To change the column order, drag the column heading into the desired position.

<table>
<thead>
<tr>
<th>Model Name</th>
<th>Distribution</th>
<th>Model Category</th>
<th>Model Unit</th>
<th>Parameter 1</th>
<th>Parameter 2</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Model Category</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Resizing Columns**

To resize columns, you can do any of the following:

- Drag the edge of the column heading to the desired position.
- Double-click the edge of the column heading or right-click it and choose **Fit This Column**. This will resize the column to fit its data.
- Right-click any column heading and choose **Fit All Columns**. This will resize all columns to fit their own data.

**Sorting Columns**

To sort the grid by one column at a time, you can simply click the column heading to sort in ascending order (↑), or click it again to sort in descending order (↓).

To sort the grid by multiple columns, right-click each column in the desired order and choose **Sort Ascending** or **Sort Descending** each time. For example, the following picture shows Synthesis Explorer data sorted first by project (ascending) and then by category (descending).

<table>
<thead>
<tr>
<th>Application Source</th>
<th>Project Name</th>
<th>Category</th>
<th>Analysis Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Weibull++</td>
<td>Project 1</td>
<td>Cat B</td>
<td>Weibull++ Standard Fdrio</td>
</tr>
<tr>
<td>Weibull++</td>
<td>Project 1</td>
<td>Cat A</td>
<td>Weibull++ Standard Fdrio</td>
</tr>
<tr>
<td>Weibull++</td>
<td>Project 2</td>
<td>Cat B</td>
<td>Weibull++ Standard Fdrio</td>
</tr>
<tr>
<td>Weibull++</td>
<td>Project 2</td>
<td>Cat A</td>
<td>Weibull++ Standard Fdrio</td>
</tr>
<tr>
<td>Weibull++</td>
<td>Project 3</td>
<td>Cat C</td>
<td>Weibull++ Standard Fdrio</td>
</tr>
</tbody>
</table>

To stop sorting, right-click any column heading and choose **Clear All Sorting**.
Grouping Panel

This topic describes the grouping panel capability that is built in to the Resource Manager and other Synthesis utilities that use a similar grid.

When you are working with a large amount of data, it may be convenient to group it based on one or more properties. For example, the following picture shows resources in the Resource Manager grouped first by keyword and then by model category.

To group the data without opening the grouping panel, right-click any column heading and choose Group By This Column. Alternatively, you can choose Show Grouping Panel to display the panel and then drag column headings into or out of the panel to configure the groups.

When the grouping panel is displayed, you can also:

- Click the column heading to change the sort order between ascending (升) or descending (降).
- Drag column headings within the panel to change the grouping order. For example, if you prefer to group first by model category and then by keyword, drag the column headings as shown below.
Removing Unused and Duplicate Resources
The Resource Manager provides several tools to make it easy to delete unused resources and merge duplicate resources.

Finding and Removing Unused Resources
To find unused resources of the selected type, choose Administration > Selection > Show Only Unused.

Once you have found the unused resources, you can decide which ones to delete.

You can return to viewing all resources of the selected type by choosing the Show All command.

Finding Duplicate Resources
You may sometimes have duplicate resources within a project (i.e., several models that all represent the identical distribution, several tasks that are identical, etc.) within a project. For example, this might happen if you have imported diagrams that all reference the same model, but the imports happened at separate times and therefore the model had to be imported again each time.

To find duplicate resources, choose Administration > Selection > Show Only Duplicates.

In the window that appears, select the properties that must match in order for the resources to be considered duplicates. For example, if you are looking for duplicate URDs, you might select...
to compare the model, corrective task and scheduled tasks, but not the URD name. Once you have selected the columns to compare, click OK to show the duplicate resources.

You can merge multiple resources of the same type into one resource, either automatically or manually. Note that models must be of the same category in order to be merged, and you cannot merge published models.

**IMPORTANT:** Merging cannot be undone, and only the information from the "target" resource (i.e., the resource that you merge the others into) will be retained.

### Automatically Merging Duplicates
To merge resources automatically, choose Administration > Actions > Merge All Duplicates.

This will find all sets of duplicates within the selected resource type (e.g., three identical Weibull models and 2 identical lognormal models); and for each set, it will merge the duplicates into the first instance found. After you confirm that this is what you want to do, you will be prompted to select the properties that must match in order for the resources to be considered duplicates. The process begins as soon as you select at least one column and click OK. It cannot be undone.

### Selecting Resources to Merge
To merge resources manually, select the resources and choose Administration > Actions > Merge & Delete.

The window shows a list of the resources you selected to merge and allows you to choose which one will be retained (i.e., the one that the other selected resources will be merged into). After you click OK, this resource will be used in all places where the other selected resources were previously used.

### Select Resource Window
The Select Resource window allows you to choose an existing resource to use at your current location. You will see this window in situations like the following:

- When you click the Select Existing icon in any resource wizard.
Chapter 19: Synthesis Resources

- When you are adding an existing action in an FMEA or in the Project Planner, or an existing control in an FMEA.

The Select Resource window is similar to the Resource Manager, but it shows only the resource type that you are currently working with. The functionality of the window will vary slightly depending on where you have opened the window from.

- If you can select only one resource (e.g., in a resource wizard), each row in the table will contain a radio button that allows you to select the resource for use. If you can select multiple resources (e.g., adding existing actions or controls in an FMEA), each row will have a check box instead.

- Actions, controls and metrics are always local, so the commands to show global or reference resources will not be available in these cases.

- The ability to apply an item filter is available only for resources that have a full set of Synthesis identifiers. This excludes actions and controls.

- Some resources may not be available for selection. For example:
  - In an FMEA, you can't select an action or control that is already assigned to the current cause.
  - In the project planner, an action cannot be added if it is already in use in the project plan or if its start date is either before or more than a year after the gate's start date.
  - A metric can't be selected to have a value pushed to it if it's already in use somewhere else, or if it's a type that is not compatible with the current use.

**Trace Usage**

**Dependency Viewer**

Because resources can be used multiple times, it is important to know where a given resource is used before making changes to it. The Dependency Viewer, which is accessed by clicking the Trace Usage icon in each resource properties window or in the Resource Manager, provides information on where the resource is used and what additional resources, if any, it uses.

The selected resource is shown in the Current Selection area in the middle of the Dependency Viewer.
The items that use the selected resource, if any, will be displayed in the **This [resource] is used by** area on the left. If it uses any resources, those resources will be displayed in the **This [resource] uses** area on the right. For example, in the picture shown next, the selected resource is a URD. It is used by Block 1 in a BlockSim diagram and by SubSystem 1 in an FMEA analysis. The URD uses an assigned model and two tasks.

You can edit any resource shown in the Dependency Viewer by right-clicking it and choosing **Edit Item** on the shortcut menu. The resource's properties window will open.

You can double-click an item in either area to make it the current selection in the window. For example, you could double-click a task used by the URD to see the model(s), crew(s) and/or spare part pool(s) that the task uses.

As you change selected items, each previous item that you selected will be added to the “path” of recent selections at the top of the window; click **Back** to go back through the path to the previously selected items. For example, the following picture shows a path in which the user started with the URD, then proceeded to its corrective maintenance task, the crew for that task and the logistic delay for that crew (not shown in the path because it is the current selection). The button now provides a quick way to go back through those same resources in reverse order if needed.

You can click the **Diagram View** button to open the diagram view of the Dependency Viewer. The currently selected item will be the main block in the diagram that is created.
Choosing What You See

In the Current Selection area, you can choose what is shown in the This [resource] is used by area. You have the option to skip the URD and/or the block that the resource is used by. For example, the image below shows the connections among analyses and resources that we have been discussing. If you have selected to show all levels, you can trace from Reliability Model to URD 1 to Block 1 to RBD 1. But if you have selected Skip Blocks and RBDs, it just shows that Reliability Model is used by RBD 1.

![Diagram of connections among analyses and resources]

Note that blocks are always skipped in RENO flowcharts (i.e., only the flowchart will be shown as the precedent for a resource used by any block within the flowchart).

Dependency Viewer - Diagram View

The diagram view of the Dependency Viewer, which is accessed by clicking the Diagram View button, offers a diagram-based alternative to help you understand the connections among resources in your project.

To understand how to use this view, consider the same example shown in the Dependency Viewer topic. Clicking the Diagram View button for that example will yield a diagram view that shows only the main item (in this case, the URD), which is marked with a flag:
To view a graphical representation of the information that was shown in the Dependency Viewer, choose **Add One Level Precedents** and **Add One Level Dependents**. This will show the items that use the resource (i.e., its precedents), and the resources that it uses, if any (i.e., its dependents).
If you want to see all levels, choose **Add All Precedents** and **Add All Dependents**:

![Diagram showing a network of blocks and arrows connecting them, representing a reliability block diagram (RBD) and a typical reliability model.](http://blocksim.reliasoft.com)

If you want to add or remove one branch at a time, click the green arrows on the sides of the blocks. Alternatively, if you want to remove one branch, select the block and choose **Delete Precedents** or **Delete Dependents**.

To set a different item as the main item in the diagram, select it and choose **Set Block as Main**. This serves the same purpose as changing the selected block in the Dependency Viewer.

Use the commands in the Options group of the ribbon's Home tab to specify how the diagram will be constructed:

- Select **Reuse Items** to show each item only once in the diagram. For example, if you are viewing a URD that is used by two blocks in the same diagram and you choose **Add All Precedents**, the Reuse Items command will affect the display as shown next:
Chapter 19: Synthesis Resources

This command must be selected before the diagram is created, or you must clear the current diagram to apply it.

- Use the Show Blocks in RBDs/FTs and Show URDs commands to determine whether blocks and/or URDs are shown as intermediate steps between resources and the analyses in which they are used.

- Select Show Item ID to display the internal ID assigned to each resource, block and/or diagram. These IDs can be used to differentiate among items that share the same name.

The Diagram tab of the ribbon offers zoom options and printing options, as well as the ability to copy the diagram or to export it as a graphics file.

**Batch Properties Editor**

The Batch Properties Editor is designed to support batch editing of most types of local resources in the current project. In BlockSim, it also allows you to edit the blocks used in the diagrams. It enables you to edit the properties in a convenient grid, rather than opening the properties window for each individual resource/block. This utility is available for all desktop applications except MPC.

To open the Batch Properties Editor, choose Project > Synthesis > Batch Properties Editor.

To use the utility, choose the type of resource or diagram that you want to work with in the navigation panel on the left side of the window. The right side of the window shows the
resources or blocks you can edit. For information on configuring the table and limiting the items shown, refer to the Configuring Columns and Finding and Filtering Records topics.

| Tip: If you change the information in one column, it may affect the information required in another column. For example, if you are editing a model and you change the Model Type column from "Weibull-2" to "Weibull-3," then the Parameter 3 column will change from "N/A" to requiring a numerical input for the third parameter for the Weibull distribution (i.e., gamma). |

The changes you make in the Batch Properties Editor will be saved when you close the window. You can also choose Home > Display > Refresh to commit your changes immediately and refresh the Batch Properties Editor to display the most current information, including recent changes by other users.

Note the following:

- **Gray Background.** If the property does not apply to the corresponding resource or block, "N/A" will appear in the column and the cell will have a gray background. Properties that cannot be edited via the Batch Properties Editor, such as the model category, will also have a gray background.

- **Published Models.** Models created by publishing results from an analysis in a Synthesis application cannot be edited in the Batch Properties Editor. To edit a model that was published from an analysis, you must return to the original data source, make the necessary changes, recalculate and republish the model.

- **Model Parameters.** Since the required parameters for a model will vary depending on the model type, the way you use the parameter columns in the Batch Properties Editor will vary. The parameter columns in the Batch Properties Editor for each model type are presented in the table shown next.
You can choose the Spreadsheet Editor command on the ribbon to open the Spreadsheet Editor, which displays the resources or blocks in a spreadsheet-based view. This enables you to use the capabilities inherent in a spreadsheet (e.g., batch copying, formulas, etc.) to make editing multiple items easier. When you are finished editing, choose Close > OK to save your changes and close the Spreadsheet Editor or Close > Cancel to close the Spreadsheet Editor without saving your changes.

Exporting Information from the Batch Properties Editor

To print the contents of the Batch Properties Editor, choose Administration > Output > Print command on the ribbon.

To send the contents of the Batch Properties Editor to Excel, or to a built-in Synthesis Workbook or spreadsheet if that's available in the current application, choose Administration > Output > Transfer Report.
Chapter 19: Synthesis Resources

You can send either the current item (i.e., the table for the currently displayed page) or the full report (i.e., the tables for all pages in the Batch Properties Editor).

**Tip:** When you need to create or edit a large number of resources, you can also use Synthesis APIs to import the data from an Excel file or other data source. For example, the URDExample_V10.xlsm file at C:\Users\Public\Documents\ReliaSoft\Examples10\API enables you to quickly create/update multiple URDs with some basic properties (models and corrective tasks). If you have the necessary software coding experience, you can expand this tool or create your own custom applications to meet specific needs.
Chapter 20: Synthesis Project Planner

The Project Planner provides extensive project planning and management capabilities, including the ability to create timelines, evaluate progress, track resource usage and estimate costs. Any project in a Synthesis repository can be associated with a project plan.

The Project Planner allows you to create, edit or view the plan in any Synthesis desktop application except MPC. If the Synthesis Enterprise Portal (SEP) has been implemented for an enterprise database, you can also access a streamlined view of the plan from any web-enabled device.

Creating a Project Plan

Each project in the database can have a project plan. To view the plan from within an open project, choose Project > Management > Project Planner. (In a secure database, any user with "read" access to the project will be able to view the plan and update any actions that are assigned to them. However, only users with the “Create/edit project plans” permission will be able to create or edit the plan.)

A blank plan will be created automatically the first time you open the Project Planner in a given project. By default, the project plan shows a sample starting gate, which records the date you opened the project plan for the first time. You can edit the sample gate and start building the plan from there.

Importing or Starting Again from a Blank Plan

Alternatively, you can start again from a blank plan or import an existing project plan from another project. In the Project Planner, choose Project Planner > Plan > Create Project Plan. (In a secure database, this command is available only to users with the “Create/edit project plans” permission.)
Then choose one of the following options. In both cases, you will need to enter the date the plan will begin in the **Set Start Date** field at the bottom of the window.

- Choose **Blank** to start again from a blank plan. This will delete all of the current gates (*there is no undo for delete*). It will also remove any actions that are assigned to the plan. The action resources will remain in the database unless/until an authorized user deletes them from the database via My Portal, Resource Manager or Actions Explorer.

**OR**

- Choose **Import from another project** to import an existing plan. You can import from another project in the current database or from any other existing standard or enterprise database.

Choose a source repository and source project for the import. The **Plan Preview** area shows the gates and actions (if any) in the project that is currently selected. By default, the import includes both gates and actions. If you want to import gates only, clear the **Include actions** check box at the bottom of the window.

**Tip:** If you want to use any of the Design for Reliability (DFR) project planning “starter” templates that were installed with Xfmea/RCM++/RBI Version 9, you can either import directly from one of your own projects (converted to Version 11), or use the "Project_Planner_Templates_Rev1" database (choose **File > Help > Open Examples Folder** then open the file in the "Project Planner" folder). To preserve the integrity of this database, a copy will be created.

---

**Project Plan Hierarchy**

In the **Project Planner**, the plan consists of gates arranged in a tree-based hierarchy to represent the different phases of a process. You can also include action resources that represent specific assignments that need to be performed. For example, the configuration below shows a plan with five top-level gates (Concept Phase, Design Phase, etc.), where each gate has its own sub-gates and actions.
Certain properties of higher-level gates (e.g., status and dates) are determined by the properties of their dependent gates and actions. For example, the "Concept Phase" above has two direct dependents. If these are marked as complete, then "Concept Phase" is automatically marked complete. (See Gates in the Project Plan for details on how gates inherit their properties.)

In this way, the planner makes it easy for you to monitor how the progress of individual activities relates to the completion of the entire process.

**Project Planner Columns**

To hide or display Project Planner columns, right-click the column headings then click Customize Columns. (You can also change the column order by dragging and dropping column headings into the desired positions.) These settings are stored per computer/username. Any project that you open on this computer will have the same columns displayed, but other users may have different display preferences.

- **General** columns display graphics/text to summarize the status, as well as the priority level and percent completion.

- **Planned Timeline** columns display information about the original plan, including planned start/due dates and resource usage. You can also display the percentage of the budget that is allocated to different project planning resources (i.e., teams, facilities and materials).

- **Expected Timeline** columns display expected start/completion dates given any delays that may have occurred for prior activities, as well as estimates of the costs/man hours to date. (See Project Planner Timelines.)

- **Actual Timeline** columns display actual start/completion dates, as well as the costs/man hours that were used for completed gates/actions.
• **Delta Values** columns compare two different values, such as the difference between an action's actual and planned costs.

• **Relevant Metrics** display values for up to three selected metrics. (See Using Metrics in Project Planner Gates.)

• **Notes** display other applicable information, including descriptions, completion notes and whether an attached file exists.

Project Planner Timelines
For gates in the Project Planner, and for any action resource that is included in a project plan, three different timelines are used to track progress:

• The **Planned** timeline consists of the originally planned start/completion dates.

• The **Actual** timeline records when a gate or action has actually started or completed.

• The **Expected** timeline shows the start/completion dates that are now expected given the current situation. For project plans that use precedents, the expected dates for an activity automatically shift in response to delays in prior activities.

All of these timelines can be shown in gate/action properties and in the Project Planner hierarchy columns. The expected dates are used to determine the status (e.g., past start date, past due, etc.) and are also shown on the summary panel.

Planned Dates
For actions and for gates with no specified precedent, the planned start/completion dates are entered directly in the Gate Properties window.

For gates with precedents, the planned start date is automatically set to the working day following the precedent's due date (i.e., planned completion date). By using precedents in your plan, you guarantee that there will be no gaps between one gate's due date and the next one's start date.

In addition, the software uses the following rules to make sure a gate's planned timeline is consistent with that of its dependent gates and actions:

• If a gate's planned start date is changed (e.g., because of changes to a prior gate's planned duration), the planned dates of all dependents will be shifted in the same way.

• You cannot change a dependent's planned start date to precede that of its parent gate.

• If a dependent's due date is changed so that it comes after its parent gate's due date, the parent gate's due date will be changed to match it.
Actual Dates
Actual start/completion dates are entered directly for actions and for gates with no dependents. For gates that have dependents:

- The parent gate's actual start date is automatically set to match the earliest actual start date of its dependents.
- Once all the dependents have completion dates, the latest of those dates is set as the parent gate's actual completion.

Expected Dates
By default, expected start/completion dates are equal to the planned dates. However, if the gate/action is part of a plan that uses precedents, the two timelines can differ.

Specifically, when precedents are used, the expected dates will automatically shift in response to recorded delays in prior gates (while the planned dates remain unchanged). For example, if Gate A is the precedent of Gate B, and Gate A completes two days late, then the expected dates for Gate B will be its planned dates + two days. The same will apply to any other gates with precedents that trace back to Gate A.

As an example, consider the following Gantt chart for a plan that has not yet started. The planned and expected timelines (shown in gray and black, respectively) are identical at first.

![Gantt chart example](image)

However, if Gate A completes late (shown in red), the expected timeline shifts for the remaining gates. (The overall plan bars at the top also indicate that the expected duration for the entire plan has now increased by two days.)
Project Planner Gates

Each gate in the Project Planner has its own properties and a status that is determined based on its expected start/completion dates. Additional information about progress and resource usage is available in the summary panel.

To view the properties of a gate, double-click it, or select it and choose Project Planner > Gate > Edit Gate.

Gate Properties

- The Gate fields provide general information about the gate, including its Name, Description and:
  - Deliverables are what will be produced and delivered as a result of completing the gate.
  - Priority is a ranking of the gate's importance ("Low," "High," etc.).
- The Precedent Gate field identifies the gate that must be completed before the current gate can start, if any. If you choose to use precedents in a project plan:
  - The precedent gate must be on the same level in the hierarchy as the current gate. (If the Use Precedence option is selected, the precedent will be suggested automatically for each new gate you create but you can change it manually if desired.)
  - When a gate has a precedent, its planned start date will be automatically set to the working day after the precedent's due date. In addition, delays in the precedent will automatically shift the expected timeline for future gates.
- The Planned Timeline consists of the originally planned start/completion dates.
- The Expected Timeline shows the start/completion dates that are now expected given the current situation. For project plans that use precedents, the expected dates for an activity automatically shift in response to delays in prior activities. (See Project Planner Timelines.)
- The Actual Timeline records when a gate or action has actually started or completed. If the gate has dependents, these dates are automatically inherited in the following way:
  - The actual start date is the earliest actual start date from the dependents.
• The actual completion date is the latest actual completion date from the dependents.

• The Relevant Metrics fields let you display up to three relevant metrics in the gate. The Push to Metrics fields let you "push" the gate's percent completed and actual vs. planned resource usage to metrics so they can be tracked and displayed in other locations. (See Using Metrics in Project Planner Gates.)

• The History fields display information about when the gate was created and last modified. If the history log has been activated at the project level, you can click the View Item History icon to open the Record History Log for the item.

• Watch allows each individual user to subscribe to receive an alert (via e-mail, SMS text message or portal message) when the gate is changed. (See Subscribing to a Watch.)

• Gate Monitors allows you to specify individual users and/or groups of users who will receive alerts for the gate, regardless of whether they have personally subscribed to a watch. (See Action and Gate Monitors.)

**Gate Status**

The gate status (which is displayed in the summary panel and in the status bar) is determined based on the same logic used for action statuses, which takes into account the expected start/completion date and any actual dates. For example, a gate's status is "Past Start Date" if it hasn't started and it's too late to start by the expected date, while "Past Due" means it is too late to complete on time.

![Gate properties](image)

**Actions in Project Plans**

You can add actions to gates in the Project Planner in order to track specific assignments that need to be performed as part of specific phases of the plan. These are the same action resources that can be included in My Portal and Synthesis Enterprise Portal, as well as FMEAs or Test Plans in Xfmea/RCM++/RBI.

When you add an action to a gate in the Project Planner, the software will:

• Use timelines in the action that automatically shift in response to delays in prior activities, which will affect how the action's status is determined.

• Display the action's plan summary in the Action properties window.
• Use the action’s status, percent complete and resources to “roll up” to the gate it is assigned to.

Adding Actions to the Plan
With a gate selected in the Project Planner, choose Project Planner > Action > Add Action. (In a secure database, this is only available to users with the “Create/edit project plans” permission.)

- **Add Action** creates a new action resource.
- **Reuse Action Resources** allows you to select existing action(s) from the project that a) are not already used in the current plan and b) have dates that fit within the current gate. Specifically, the action’s start date can’t be before or more than a year after the gate’s start date. (See Select Resource window.)
- **Reuse FMEA Actions** allows you to select one or more Xfmea/RCM++/RBI system hierarchy items from the current project that have FMEAs. You can then select to use existing action(s) from those particular FMEAs in the project plan.

Project Plan Summary Panel
The project plan summary panel displays information about start/completion dates, status, progress and resource usage for an entire project plan, and for individual gates and actions.

The summary panel is accessible from multiple locations across the Synthesis Platform:

- From the **Project Planner**, you can select a gate or action in the hierarchy to view its summary, or you can select the project at the top of the hierarchy to view a summary of the entire plan.
- The gate/action properties window shows the summary for that gate/action.
- The **Plan Summary Page in My Portal** displays a summary of the entire plan for the project that currently has focus.
- These summaries are also displayed in the web-based **Synthesis Enterprise Portal (SEP)**, if it is implemented for an enterprise database.
In most cases, this shows the current date. If you are working in the Project Planner and you want to see what the statuses would be on a different date, click the green “play” arrow (▶) and then select a different date from the calendar. When you’re ready to return to the current date, click the green “pause” bars (■).

This bar displays the name of the project, gate or action that the summary applies to, followed by:

- The EXPECTED start date and completion date. (This will be the same as the planned dates unless a prior delay has caused the expected dates to shift.)
- The ACTUAL start date and completion date (if the action is in progress or complete).
- The current status. (See *Action Timeline and Status*.)

For actions, the progress bar shows the percentage entered by the user. For gates, it shows the percentage of the total duration of dependent actions/gates that is complete. For example, if Action 1 (duration = 3 days) is complete and Action 2 (duration = 1 day) is incomplete, the progress is 75%.
For resource usage, the black bars show the planned man hours and costs. The colored bars show either the expected usage to date (estimated based on the number of days in progress), or the actual usage if complete. (See Costs and Man Hours.)

- **Yellow** = In progress and usage to date is still within plan
- **Orange** = In progress and usage to date has exceeded plan
- **Green** = Complete and actual usage was within plan
- **Red** = Complete and actual usage exceeded plan

The pie chart will be visible only for projects or gates that have at least one action assigned (either directly or via dependent gates).

- **Not Started** = Actions that have not started and can complete on time
- **In Progress** = Actions that are in progress and can complete on time
- **Completed** = Actions that have a completion date
- **Past Due** = Actions that can no longer complete on time
Check Utilization

The Check Utilization window lets you examine the utilizations for individual users and facilities across one or more actions. It displays the total utilization for each resource on each specific date, so you can easily identify dates when the resource is over-utilized and make any adjustments that may be needed.

- To view utilizations for a specific action, open the action and choose Tools > Check Utilization.
- To view utilizations across multiple actions, open the Project Planner and choose Project Planner > Tools > Check Utilization.

If you open the utility from the Project Planner ribbon, there are two options. By default, it shows Only actions in this plan. Alternatively, you can choose to see utilizations from All actions in the project (even if they are not used in the plan).

Regardless of whether you’re checking a single action or the entire project plan, the utility shows All resource utilizations by default. Alternatively, you can choose to see Only utilizations over 100%.

Over-utilized resources (i.e., those with a utilization that exceeds 100%) are shown in red.

Double-click a resource to view its total utilization for each specific date, as well as the action(s) that use the resource on each date. For example, according to the window shown next, Joe Reliability's highest utilization for a single day exceeds 100%. By double-clicking his name, you can see that he is assigned to two actions that overlap on 1/6/2016, and as a result his combined utilization for that day is 105%.
Project Planner Gantt View

The Project Planner also includes a Gantt chart that makes it easy to visualize the timelines in your project and examine how different planning resources are utilized over time.

To access this view, click Gantt at the bottom of the Project Planner.

- Use the Gantt Type drop-down list on the control panel to specify what to display:
  - Project Plan shows timelines for gates and actions.
  - Personnel Utilization and Facility Utilization show the utilizations for the person responsible, team and/or facilities. (See Project Planning Resources.)
  - In the Gantt Display area, select the part of the plan you want to view in the Filter drop-down list. For example you could view a specific gate (and its dependents) or a specific user (and all their utilizations). If you want to change the widths of columns that contain dates, use the Fit Mode.

- In the Date Selections area:
  - Select to view the entire plan or focus only on a specific date range.
  - Specify whether each column represents a specific number of Days, or Other increments such as weeks, months, quarters, etc.

- In the Date Display area:
  - If each column represents a single day, select whether to display Non-Working Days. If displayed, those columns will have a gray background. (See Working Days/Holidays.)
  - Use Show Planned, Show Expected and Show Actual to specify which timeline bars will be displayed.
    - To specify the colors that will be used in both the project plan Gantt chart and the timeline plot, choose View > Settings > Set Colors. (See Set Colors for Project Planner.)
    - For the planned and actual timeline bars in the project plan chart, you can also choose whether to Show Percent Completed.
• If you are using one of the utilization charts and the date columns each represent more than a single day, use the **Calculate Utilization As** area to specify how to calculate the utilization. This can be:

  • The **Max** (highest) daily utilization among all days in the interval. For example, if the interval is 3 days and the utilizations were 15%, 0% and 10%, the max will be 15%.
  
  • The **Average** across only the days in the interval that have utilizations. For example, if the interval is 5 days but the resource was only utilized on 3 of those days, the average will be the total utilization/3 days.
  
  • The **Overall Average** across all working days in the interval. For example, if the interval is 5 working days, the overall average will be the total utilization/5 days even if the resource was not utilized every day.

---

**Project Planner Plot View**

The **Project Planner** includes a plot view that makes it easy to visualize the **timelines** in your project.

To access this view, click **Plot** at the bottom of the Project Planner.

![Plot button](image)

• Use the **Filter Options** area to select whether to filter the data by **Gate** or by using a **Date** range. You can also choose to view data for **Top Level Gates** only.

• In the Display Options area:

  • **Show Planned, Show Expected** and **Show Actual** determine which timelines will be shown in the plot.

  • To specify the colors that will be used in both the project plan Gantt chart and the plot, choose **View > Settings > Set Colors**. (See **Set Colors for Project Planner**.)

  • **Display Actions** shows the dependent actions for each gate.

  • **Show Project Item** shows the “project” gate at the top of the hierarchy.

  • **Show First Gate on Top** determines whether the gate with the earliest start date will show at the top or bottom of the chart.
• **Auto Refresh** refreshes the plot automatically whenever changes have been made. If this option is cleared, you can click the **Redraw Plot** icon (/loader.png) to refresh the display.

• **Keep Aspect Ratio** maintains the proportional relationship between the width and height of the plot image.

### Set Colors

To open the Set Colors window for the **Project Planner**, choose **View > Settings > Set Colors**.

- The **Gate and Action Options** apply to the Gantt chart (if viewing the plan), plan hierarchy and plot.

![Gate and Action Options](image)

- The **Date Display** options apply only to the Gantt chart and plot.

![Date Display](image)

- The **Utilization Threshold Colors** apply only when using the Gantt chart to view team or facility utilization.
Project Planner Dashboards

You can use the flexible Synthesis Dashboard utility for presenting data from any Project Planner in the database.

To access this feature, open the planner and choose Project Planner > Tools > Dashboard.

As with any other Synthesis dashboard, you can use the Dashboard Viewer to select any of the layouts that have been predefined for this type of data. In a secure database, only users with the "Manage dashboard layouts" permission can use the Dashboard Manager to create or edit layouts.

Data Source Drop-Down List

When you are creating a dashboard layout based on project plan data, the drop-down list at the top of the Data Source Panel gives the following options:

- **Actions** returns data only from actions in the current plan.
- **Gates** returns data only from gates in the current plan.
- **Gates/Actions** returns data from both actions and gates.
• **Facilities** returns data from the facilities assigned to actions.

• **Personnel** returns data from the person responsible and/or team assigned to actions.

Each data source allows you to choose relevant fields from the record properties, summary panel and/or project plan hierarchy.

Note that all of the data fields used within a particular dashboard item must come from the same source. For example, you can’t combine fields from the “Actions” data source and the “Gates” data source in the same chart. If you want to create a chart that includes both actions and gates, use the fields from the “Gates/Actions” data source instead.

### Examples for Different Field Types

The icon for each field indicates the data type: 📔 text, 📊 number or 📅 date. There are many possible ways to use these fields in your own customized dashboard layouts. The following simple examples demonstrate basic applications for each data type.

#### Example Using Counts

This pie chart uses the **Count** value for a text field to show the actions in the current project plan broken down by status. The argument determines the slices shown in the pie.

**Tip:** If you want to see both the quantity and the percentage, choose Design > Data Labels > Argument, Value And Percent.
Example Using Numbers
This bar chart uses the **Sum** values for two number fields to show the top 5 most costly actions in the current project plan, with comparison to the planned cost. The arguments determine how the bars are labeled, grouped and sorted.

Example Using Dates
This grid uses the **Exact Date** for two date fields to show a list of all actions in the current plan that are due in the current month. (To set the criteria that filters the records shown in the grid, right-click inside the chart and choose **Edit Filter**.)
Project Planner Ribbon

Project Planner Tab
The Project Planner tab in the Project Planner ribbon contains the following commands.

Project Planner

Refresh updates the Project Planner hierarchy, if necessary. For example, if multiple users are accessing the same plan simultaneously, this will update the plan to reflect any changes made by other users.

Create Project Plan opens the Create Project Plan window so you can start again from a blank plan, or import an existing plan from another project.

Delete Entire Plan deletes every gate and removes every action from the plan.
**Item Properties** allows you to view or edit the Synthesis Identifiers defined for the current plan. These identifiers can be used in the Synthesis Explorer to explore all of the different types of analyses (including project plans) in the current database.

### Clipboard

- **Paste** pastes the contents of the Clipboard into the level below the selected gate (or on the same level of the selected action). If you want to paste gates only (without sub-gates and actions), use the **Paste Without Actions** command.

- **Cut** cuts the selected gate/action and any dependents to the Clipboard. You can paste this information into another Project Planner within the same database.

- **Copy** copies the selected gate/action and any dependents to the Clipboard. To copy everything, use the **Copy Entire Plan** command. You can paste this information into another Project Planner within the same database.

- **Delete** deletes the selected gate/action and any dependents.

### Gate

- **Add Gate**
  - **Add Same Level Gate** adds a gate on the same level as the selected gate.
  - **Add Next Level Gate** adds a gate one level below the selected gate.
  - **Add Gate** adds a top-level gate to the end of the plan.
  - **Insert Gate** inserts a gate at the selected location.

- **Use Precedence**, when selected, automatically sets a new gate's precedent to the prior gate, which allows you to take advantage of expected timelines and ensure that there are no gaps between gates. If you clear this option, the default precedent will be "None."

- **Edit Gate** opens the Gate Properties window.

- **Promote** and **Demote** moves the selected gate to the next higher or lower level in the plan. An item can be demoted only if there is another item on the same level and above the selected item that it can be demoted under.
Chapter 20: Synthesis Project Planner

Action

Add Action

- **Add Action** creates a new action resource.

- **Reuse Action Resources** allows you to select existing action(s) from the project that a) are not already used in the current plan and b) have dates that fit within the current gate. Specifically, the action’s start date can’t be before or more than a year after the gate’s start date. (See Select Resource window.)

- **Reuse FMEA Actions** allows you to select one or more Xfmea/RCM++/RBI system hierarchy items from the current project that have FMEAs. You can then select to use existing action(s) from those particular FMEAs in the project plan.

Edit Action opens action properties window. (See Actions in the Project Planner.)

Tools

Remove Gaps in Dates automatically assigns precedents to every applicable gate. This ensures that there will be no gaps in the planned or expected timelines, and it allows the expected dates for an activity to automatically shift in response to delays in prior activities. (See Project Planner Timelines.) You can choose to remove gaps in the Entire Plan or just for the gates that fall under the selected Branch.

Check Utilization opens the Check Utilization window so you can examine the utilizations for individual users and facilities across multiple actions (e.g., is a particular user assigned to too many actions at the same time, or is a particular test facility already booked for a particular timeframe).

Expand All and Collapse All expands or collapses the gates in the project plan hierarchy.

Dashboard

- **Dashboard Viewer** opens the Dashboard Viewer so you can view dashboards based on predefined layouts.

- **Dashboard Manager** opens the Dashboard Layout Manager so you can create, edit and delete the predefined layouts that will be available for any Synthesis user to view for any project plan in the database.
Excel Import/Export

- **Export View to Excel** exports the entire hierarchy and all displayed columns to an Excel sheet in a format that's suitable for presentation.

- **Import Hierarchy** and **Export Hierarchy** use an Excel format that's suitable for recreating the plan hierarchy in another project plan using information about precedents, outline level, etc.

**Copy Current View** copies the currently visible contents of the plan hierarchy or Gantt chart to the Clipboard as a graphic that can be pasted to other applications.

**View Tab**
The View tab in the **Project Planner** ribbon contains the following commands.

**View**

- **Color Code Deltas** applies highlight colors to any “Delta Values” columns for dates or durations that are displayed in the project plan hierarchy (e.g., the difference between the planned duration and the actual duration, or between the expected completion date and the actual completion date). Highlights are applied on a gradient from blue (ahead of schedule) to red (significant delay).

- **Fit All Columns** automatically resizes all columns to fit their own data.

**Settings**

- **Customize Columns** allows you to hide or display specific columns in the plan hierarchy.

- **Save View** and **Apply View** create or apply a view that stores your preferences for which columns to display in the plan hierarchy and which colors to use for gates, actions, timelines and utilizations. Each view is saved per computer/username.

- **Set Colors** allows you to select the colors to use for gates, actions, timelines and utilizations.

**Zoom**

- **Normal Zoom** sets the degree of magnification to 100%

- **Zoom In** and **Zoom Out** increase or decrease the font size by 25% increments.
Custom Zoom allows you to specify the zoom percentage.
Chapter 21: Synthesis Plot Utilities

Synthesis applications offer a variety of plotting utilities for visual presentation of your analysis results. The following topics provide general information about built-in utilities, where the types of plots/charts available are predefined based on the analysis method and type of data you are working with. For more information about specific plot types, please consult the documentation for the relevant analysis.

Tip: In addition to the built-in plotting utilities described here, you can also create your own custom plots/charts in the Synthesis Workbooks and Synthesis Dashboards.

Basic Plot Features

This topic describes some basic features and capabilities that are available in most built-in plot utilities in Synthesis desktop applications (i.e., utilities where the types of plots available are predefined based on the analysis method and type of data you are working with). For information about creating your own custom charts in Synthesis Workbooks or Synthesis Dashboards, see Custom Charts or Dashboard Layout Designer.

Redraw Plots

A plot needs to be refreshed whenever its data source has been recalculated or when its inputs or settings have been modified. This ensures that the plot reflects the most current results. In most plot sheets, the control panel displays a status light that indicates whether the plot needs to be refreshed. A green light indicates that the data and the plot are in sync, while a red light indicates that the plot is out of sync with the latest analysis.

You can manually update a plot to reflect any changes by clicking the Redraw Plot icon in the plot’s control panel.

Alternatively, a plot can be refreshed automatically whenever changes have been made by selecting the Auto Refresh check box on the plot’s control panel.
Chapter 21: Synthesis Plot Utilities

Identify a Plot’s Source Analysis
For most plots, the control panel displays a blue link that displays the plot’s source analysis, as shown in the following example for a Weibull++ plot. You can click the link to open the folio and view the data set.

In some specialty plots (side-by-side plot, life comparison tool, etc.), you can select the source analysis for the plot by clicking the icon on the plot’s control panel or ribbon.

If the plot contains results from more than one analysis (e.g., overlay plots), the control panel includes a button that allows you to add or remove analyses from the plot, as shown in the example below for Weibull++ data sheets. In addition, you can click and drag the data sheets to the desired order.

Show or Hide Plot Items
When applicable, a plot may provide options for showing or hiding certain plot items such as data points, lines, probability scales, etc. The available options depend on the plot type and analysis. To view the options for the plot you are working with, choose Plot > Actions > Show/Hide Plot Items or right-click the plot and choose Show/Hide Items on the shortcut menu.

Select the check box for each item you want to appear in the plot, or clear the item’s check box to hide the item from view.

Scaling
When applicable, the plot control panel may display X and Y scaling boxes that show the minimum and maximum values for the x- and y-axes. You can clear the check boxes and click inside the fields to manually edit the values, or select the check boxes to have the application choose the appropriate values for the range, based on the data.
Zoom

The zoom function is available for plots that allow both X and Y scales to be adjusted. To zoom in or out of a plot, click inside the plot, point the mouse pointer over the area of interest, and then rotate the mouse wheel. Press \texttt{ESC} to return to the original scale.

For non-3D plots, you can also select a specific area to zoom in by holding the \texttt{CTRL} + \texttt{SHIFT} keys while clicking and dragging the mouse over the desired area. You can customize the color and line style of the zoom rectangle via the Zoom page of the Plot Setup.

Aspect Ratio

Plots are automatically resized whenever you resize the plot sheets. To maintain the proportional relationship between the width and height of the plot image, select the Keep Aspect Ratio check box on the plot’s control panel (as shown in the first example below). Clear the check box if you wish to stretch the dimensions of the plot graphic to fill the plot sheet (as shown in the second example below).
Show Coordinates

To show the coordinates for a location on a plot, press **SHIFT** and click the plot (no need to hold down the mouse button). To stop showing the coordinates and return the pointer to its normal mode, click the plot again.

To track the coordinates on a plot line, click the line. A crosshair shows the current location on the line. The crosshair will stay on the line and track the coordinates as you move the pointer.

When applicable, you can add a label that displays the coordinates of a location by pressing **CTRL + ALT** and then clicking the location you want labeled.
Add Custom Labels
When applicable, you can add a custom label to a plot by pressing **CTRL** and then clicking the plot. A label named "Default" will appear in the plot. Select the label to edit the text directly in the plot or double-click it to open the Edit Label window, which gives you the option to select a font style or format.

You can then move the label by clicking it and dragging its yellow handle to the desired location on the plot. (For more extensive annotations, see ReliaSoft Draw.)

Move Plot Items
If your plot has lines or points that are obscuring one or the other, you can move an item by pressing **ALT** and clicking the item. The Move Plot Item window will appear, giving you the option to move the selected item either to the front or back of the obscuring graphic.

Export or Copy Plot Graphics
You can save a plot graphic as a *.wmf, *.png, *.gif, or *.jpg file for use in other applications by clicking the Export Plot Graphic icon on the plot's control panel, or by choosing [Plot/3D Plot] > Actions > Export Plot Graphic if applicable.
In addition, you can save a plot graphic to the Clipboard by clicking the Copy Plot Graphic icon on the plot's control panel or by choosing [Plot/3D Plot] > Actions > Copy Plot Graphic if applicable.

When saving a 3D plot graphic to the Clipboard, the image will be in *.bmp format. For all other types of plots there are three choices: If you will be pasting copied plots into any one of the spreadsheets built in to Synthesis desktop applications (e.g., Synthesis Workbooks or General Spreadsheets), choose Metafile Optimized for Synthesis Spreadsheet. If you will be pasting them into external applications, choose Bitmap or Metafile Optimized for External Use.

### Setting Confidence Bounds

If your analysis includes calculations for confidence bounds, you can display the bounds in the associated plot by clicking the Confidence Bounds link on the plot control panel or by choosing Plot > Confidence Bounds > Confidence Bounds.

Depending on the type of data you are working with, you may be presented with different options for setting up the confidence bounds on the plot. (The ReliaWiki resource portal provides information on the background theory of confidence bounds at: http://www.reliawiki.org/index.php/Confidence Bounds.)

In the Confidence Bounds Setup window, you will need to:

1. Select which lines to show on the plot (e.g., two-sided, bottom one-sided, etc.)
2. Select which type of bounds to show on the plot. This may be the bounds on the time estimate (Type I), bounds on the reliability/unreliability estimate (Type II: Reliability); or when applicable, bounds on functions such as number of failures, growth potential, etc. (Type II: Function).
3. Enter the percent confidence level.

To change the level of detail at which the bounds are plotted, adjust the Resolution slider. You can click and drag the slider or, for fine adjustments, click the slider and then use the arrow keys. The number of points plotted to create the lines is displayed next to the field name. Note that higher resolutions will take longer to plot.

To hide the confidence bounds, choose Plot > Confidence Bounds > Hide Confidence Bounds.
Setting Target Markers

When applicable, the plot control panel may display the Target Reliability link or the Target MTBF/FI link. Both give you the option to display markers for target values on the plot.

You can select to show a specified target value (displayed as a horizontal line), target time value (displayed as a vertical line), and/or insert a marker at the point where the two target values intersect. Below is an example for a plot that shows the target reliability.

Click the Add + or Remove – icon to manage the list of target values to be displayed. You can add up to 5 sets of target values/markers to a plot.
Chapter 21: Synthesis Plot Utilities

Plot Setup

The Plot Setup utility provides advanced settings for customizing the look of a plot to meet your needs and preferences. It allows you to: a) make changes and apply them to the current plot; b) save the changes and use them as default settings for all new plots; c) restore previously saved default values; or c) reset all settings to the shipped defaults.

**Tip:** You can quickly set some basic default settings for all new plots created in the current Synthesis desktop application via the Plots page of the Application Setup (File > Application Setup). The Application Setup also allows you to set some default analysis settings that may affect the appearance of plots (varies depending on the Synthesis desktop application).

To open the Plot Setup, click the Plot Setup icon on the plot’s control panel.
Alternatively, you can double-click the item on the plot you wish to edit (e.g., points, lines, etc.) and the Plot Setup will open and display automatically the options associated with that item.

To apply your changes to the current plot, click **OK**. To save your changes as the new defaults, or restore previously saved defaults, or reset to shipped defaults, click the **Defaults** button. (See **Plot Defaults Window** for more information.)

### Plot Elements

The Plot Setup is divided into pages that contain related settings for particular plot elements. The available pages/elements will depend on the type of plot you are working with.

As an example, the following picture identifies some of the basic plot elements that can be configured via the Plot Setup.

### Plot Setup: Plot Titles Page

The Plot Titles page allows you to define the main, header and footer titles used in the plot and to change the text font and color.

Select or clear the **Show** check box to determine whether the title will be shown on the plot. Click the **Set Font** button next to the corresponding input box to open the Font window, which allows you to set the font type, style, size, color and text orientation.
Chapter 21: Synthesis Plot Utilities

Each asterisk (*) represents the default title text. For the main title, this is defined on the Titles Text page of the Plot Defaults window. If you type new text in an input box, either alone or in addition to the asterisk, the text you type will be displayed on the plot. For example, if you add (Helicopter) to the Main Title field, the default main title will be displayed, followed by "(Helicopter)." The changes you make will be applied regardless of plot type, so the main title of a Failure Rate vs Time plot would then be "Failure Rate vs Time (Helicopter)" and the main title of a System Failures plot would be "System Failures (Helicopter)." (This assumes that you have not changed the default main titles from the ones shipped with the application.)

You can use the ENTER key to add additional lines to the header title and the footer title.

To add an image file to the header title or footer title, click Set Image then browse for the file you want to include. Click Open. (You can select an image that uses one of the following formats: *.bmp, *.gif, *.jpg, *.jpeg, or *.ico.) The selected image appears next to the Set Image button. The image will also appear at the left side of the header or footer text. To remove the image, click Clear Image.

Plot Setup: Axis Titles/Labels Page

The Axis Titles/Labels page allows you to define the information used with the x-axis and y-axis, including the titles, axis labels and the numbers displayed in the axis labels. This page is not available when you are working with a pie chart.

The options on this page will vary depending on the plot style you are working with.

- Axis Titles
  - Select or clear the Show check box to determine whether the title will be shown on the plot. Click the Set Font button next to the corresponding input box to open the Font window, which allows you to set the font type, style, size, color and orientation of the text.

Each asterisk (*) represents the default title text. If you type new text in an input box, either alone or in addition to the asterisk, the text you type will be displayed on the plot. For example, if you add (Hours) to the Y-Axis Title field, the default y-Axis title will be displayed, followed by "(Hours)." The changes you make will be applied regardless of plot type, so the y-axis title of a Static Reliability Importance plot would then be "Static Reliability Importance (Hours)" and the y-axis title of a Throughput vs. Time plot would be "Throughput(t) (Hours)." (This assumes that you have not changed the default axis titles from the ones shipped with the application.)
• **Axis Labels**

  - **Axis Labels** options, when selected, displays the numerical labels for the x-axis and/or the y-axis in the plot.
  
  - If available for the plot type, click the **Custom Labels** button next to the corresponding option to open the Custom Axis Labels window, which allows you to add user-defined numerical labels to the x-axis or y-axis of the plot. Note that values outside the plot's display range are accepted but will not be shown.

  Click the **Set Font** button next to the corresponding option to open the Font window, which allows you to set the font type, style, size, color and orientation of the text.

• **Numbers in Axis Labels**

  Use the options in this area to configure the mathematical precision (number of decimal places) and scientific tolerance of the values shown on the axes.

  The scientific tolerance sets the point at which the numbers will be converted to normalized scientific notation. For example, setting the scientific tolerance to 3 means that all numbers with a value of 1,000 or more will be converted to normalized scientific notation (e.g., 1.0E +3).

  **Note:** When you are working with a bar chart, the Numbers in Axis Labels area will contain settings for only the axis representing the dependent variable. This is affected by the orientation of your bar chart; if you are using vertical bars, this area will contain settings for the y-axis, and if you are using horizontal bars, it will contain settings for the x-axis. It is important to be aware that the settings for one axis will not transfer to the other axis when you change the bar orientation. You will need to return to this page and reenter the settings.

---

**Plot Setup: Plot Labels Page**

The Plot Labels page allows you to customize the labels for items (e.g., bars, slices, points) shown in the plot as well as for custom labels used in the plot.

The options on this page will vary depending on the plot style you are working with. All available options are presented below.

• **Bar Labels** (available only for bar charts)

  - To display the y-axis value of each bar with the bar, select the **Show Bar Labels** check box. (You can set the bar style using the **Bar Orientation** field on the Bars page of the Plot Setup.)
• **Show Bar Labels Even if Zero** if selected, bars with a y-axis value of 0 will be shown with a label of "0." The number of decimal places in the label will conform to the y-axis math precision value specified on the Axis Titles/Labels page.

• **Point Labels** (available only for line plots)
  - To display the coordinates for each point at the lower right of the point, select the **Show Point Coordinates** check box. If this option is not selected, you can still display the coordinates for each point in a pop-up box by pointing to the point.
  - To display the point label in the same color as the border of the point itself, select the **Use Point Border Color** check box.
  - If there are overlapping points, select the **Show Point Multiplier** check box to display the number of points to the right of the point.

• **Slice Labels** (available only for pie charts)
  - To label the slices of the pie chart according to the components they represent, select the **Show Slice Labels** check box.
  - To label the slices of the pie chart with the percentage of the whole that they represent, select the **Show Slice Size** check box.

• **Custom Plot Labels** allows you to control the appearance of custom plot labels. You can add custom labels to your plot by pressing **CTRL** and clicking the plot.
  - **Delete Labels** deletes all custom labels on the plot.
  - **Reset Labels** immediately resets all custom labels on the plot to use the settings specified via the **Set Font** button. This allows you to apply the settings to existing custom labels rather than just new labels created after changing the settings.

• **Bar Label Position** (available only for bar charts) allows you to specify whether you want the bar labels located within the bars or outside of the bars.

For all labels, you can click the **Set Font** button in the section to open the Font window, which allows you to set the font type, style, size and color for labels of that type.

**Plot Setup: Legend Page**
The Legend page allows you to customize the display of the legend on the current plot.
The options on this page will vary depending on the plot style you are working with. All available options are presented below.

- To display the legend on the plot, select the **Show Legend** check box.
  - To include on the legend a color definition for each point/line/bar/slice shown in the plot, select the **Show Plot Items** check box.

- To include lines above and below the legend and the user information, select the **Show Legend Border** check box. Use the options to the right to modify the appearance of the border. To change the color of the border, click the **Color** box to the left of the **Thickness** box. Adjust the thickness of the border by entering a positive integer in the input box. Change the style of the line (e.g., solid, dashed, etc.) by clicking the **Line Style** box to the right of the **Color** box.

- To display the text of the legend in the same color as the lines, points, bars and/or slices on the plot, select the **Use Item Color** check box. If not selected, the text will be red.

- **Show Analysis Information** if selected, the legend will display information about the analysis shown on the plot, including the data source and/or the settings used in the calculation, if applicable.

- To display the plot description (including the plot type) on the plot, select the **Show Plot Description** check box.

- To show the user display name, company and the date and time the plot was generated on the plot, select the **Show User Information** check box. (You set the display name and company using the User Login and Contact Information Window.)

- The legend area allows you to specify the amount of space used for the legend.
  - **Fixed Legend Width** if selected, the legend will remain the same size regardless of the information it contains. You can set the percentage of the canvas width that the legend will occupy.
  - **Maximum Legend Width** if selected, the legend will automatically recalculate its width based on the information it contains. You can set the maximum percentage of the canvas area that the legend will occupy.
Chapter 21: Synthesis Plot Utilities

Click the **Set Font** button next to the corresponding option to open the Font window, which allows you to set the font type, style, size and color of the text.

- For bar and pie charts in BlockSim and RENO only, **Color Spectrum** allows you to set the color limits for the plot.
  - You can set both lower and upper color limits by dragging the markers on the scale between 0% and 100%.
  - **Show all values (0-100%) in legend** if selected, the legend will show the full range of values; if not selected, the legend will show only the values between the upper and lower limits that you have specified.

The preview shows how the specified settings will appear in the legend.

**Plot Setup: Canvas Page**

The Canvas page allows you to customize the color, style and thickness of the plot borders and title lines, along with the appearance of the rest of the plot sheet.

- **Plot Canvas and Area**
  - **Canvas Back Color** allows you to choose the color for the area outside the plot (i.e., the area containing the titles, labels, legend, etc.).
  - **Canvas Border** allows you to determine if the border around the plot field will be displayed and, if so, to set the color.
  - **Plot Area Back Color** allows you to choose the color for the plot background.

- **Plot Area Border Lines** allows you to hide or show each of the specified lines, as well as to choose a color, a thickness and a style for each. The borders referred to in this area are the borders of the plot area itself (i.e., the bottom border is the x-axis, etc.).
  - To show or hide a line, select or clear the associated check box.
  - To change the color of any of the lines, click the **Color** field. The drop-down list that appears allows you to choose from custom colors, web-safe colors or the colors used in the current Windows system settings. You can add colors to the Custom page by right-clicking one of the color boxes in the bottom two rows.
  - You can adjust the thickness of a line by entering a positive integer in the input box. A value of 1 will draw the thinnest possible line and other values such as 2, 3, etc. will draw thicker lines. Note that the size of the thinnest possible line is dependent upon your screen resolution.
• In addition, you can change the style of each line by clicking the **Line Style** box to the right of the **Thickness** box. A list providing line style options (e.g., solid, dashed, etc.) will appear. Choose the line style you want and it will appear in the **Line Style** box.

• To highlight each object (i.e., point, line, bar or slice) on the plot as you point to it, select the **Highlight Selected Plot Item** check box. When an object is active, you can click it to open the Plot Setup window and edit the properties specific to that object. The remaining options in this area are available only if this option is selected.

  • **Fill Color** allows you to specify a foreground color to be used on the highlighted active object.

  • **Back Color** allows you to specify a background color to be used on the highlighted active object. This color is not used if the selected fill style does not use a background color (i.e., solid or transparent fill style).

  • **Fill Style** allows you to select a style of hatching to be used on the highlighted active object.

**Plot Setup: Grid Page**

The Grid page allows you to customize the color, style and thickness of the grid lines and to set the number of axis divisions used. This page is not available when you are working with a pie chart.

The options on this page will vary depending on the plot style you are working with. All available options are presented below.

• **Axis Division Lines** allows you to hide or show each of the axis division lines, as well as to choose a color, a thickness and a style for each.

  • To show or hide a line, select or clear the associated check box.

  • To change the color of any of the grid lines, click the **Color** box. The drop-down that appears allows you to choose from custom colors, web-safe colors or the colors used in the current Windows system settings. You can add colors to the Custom page by right-clicking one of the color boxes in the bottom two rows.

  • You can adjust the thickness of a grid line by entering a positive integer in the input box. A value of 1 will draw the thinnest possible line and other values such as 2, 3, etc. will draw thicker lines. Note that the size of the thinnest possible line is dependent upon your screen resolution.
In addition, you can change the style of each line by clicking the Line Style box to the right of the thickness box. A list providing line style options (e.g., solid, dashed, etc.) will appear. Choose the line style you want and it will appear in the Line Style box.

- **Number of Axis Divisions** allows you to set the number of major and minor divisions for each axis.

*Note:* When you are working with a bar chart, the Grid page will contain settings for only the axis representing the dependent variable. This is affected by the orientation of your bar chart; if you are using vertical bars, this area will contain settings for the y-axis, and if you are using horizontal bars, it will contain settings for the x-axis. It is important to be aware that the settings for one axis will not transfer to the other axis when you change the bar orientation. You will need to return to this page and reenter the settings.

### Plot Setup: Bars Page

The Bars page allows you to customize the appearance of the bars in the plot. This page is available only when you are working with a bar chart.

- **Bar Border Lines** allows you to hide or show the border line for the bars, as well as to select a color, a thickness and a style for the border.

- **Bar Orientation** allows you to select how you want the plot laid out. You can choose to use vertical bars or horizontal bars.

### Plot Setup: Slices Page

The Slices page allows you to customize the appearance of the slices in the plot. This page is available only when you are working with a pie chart.

- **Pie Settings**
  - **Rank** if selected, you can specify the ranking of the slices that you want to view. For example, entering 5 will cause only the five largest slices to be shown in the plot.
  - **Threshold** if selected, you can specify a minimum size (in percentage of the whole) for the slices that you want to view. For example, entering 0.1 will cause only slices accounting for ten percent or more of the whole to be shown in the plot.
Chapter 21: Synthesis Plot Utilities

- **Show Remaining Slices as Other** if selected, all remaining slices that do not meet the rank or threshold criterion specified will be shown in the plot as "other." This option is available only if you have specified a rank, a threshold or both.

- **Other Slice Color** allows you to choose the color used to represent "other" slices. This option is available only if you have selected the **Show Remaining Slices as Other** option.

- **Slice Border Lines** allows you to hide or show the border line for the slices, as well as to select a color, a thickness and a style for the border.

- **Chart Type** allows you to select how you want the plot laid out. You can choose to use an area chart (blocks), cake chart (layers) or pie chart (wedges).

- **Numbers in Slice Labels** allows you to set the number of decimal places to be displayed in slice labels.

**Plot Setup: Plot Items Page**

The Plot Items page allows you to specify details of the appearance of the points, lines, bars and/or slices on the plot.

The options available on this page will vary depending on the plot style that you are currently working with.

The following options are available for all plot styles:

- **Choose an Item to Configure** allows you to choose which plot element the settings on this page apply to.

- **Show** allows you to select whether or not the plot element you currently chose to configure will be shown on the plot. Depending on the plot style that you are currently working with, you may select to show the bars, slice, line and/or points. This option is not available for all plots.

For bar charts and pie charts, the following option applies.

- **Area Fill Color and Style** allows you to specify the appearance of the bar or slice representing the selected item. To change the color of the bar or slice, click the **Color** box. You can select a fill style from the drop-down list.

For line plots, the following options apply:

- **Line Settings** allows you to specify the appearance of the line representing the selected item. To change the color of the line, click the **Color** box. You can adjust the thickness of a grid line by entering a positive integer in the input box. Adjust the thickness of the line...
by entering a positive integer in the input box. Change the style of each line such as solid, dashed, etc., by clicking the **Line Style** box.

- **Point Settings**
  - **Color, Shape, Size and Fill** allows you to specify the appearance of the point body. To change the color of the point, click the **Color** box. You can select a point shape from the drop-down list, select the size of the point (with 1 being the smallest point) and select a fill style from the drop-down list.
  - **Border Color, Thickness and Style** allows you to modify the appearance of the border of the points. To change the color of the border, click the **Color** box. Adjust the thickness of the border by entering a positive integer in the input box. Change the style of each line such as solid, dashed, etc., by clicking the **Line Style** box.

Certain point shapes are drawn using only the border color. These include minus, pike, plus and x-cross.

**Plot Setup: Offsets Page**

The Offsets page allows you to specify the distance of various components from the edge of the plot area.

**Automatically calculate positions from edges of plot sheet** if selected, automatically calculates the offsets for maximum plot display and readability. If not selected, you can manually specify the offsets of the plot's left, right, top and bottom edges; the offset of the legend from the right edge of the plot area; and the offset of the main, x-axis, y-axis, header and footer titles. The offset values are set as a percentage of the canvas area.

For your reference, the following picture shows which plot elements are affected by each of the offset settings. (Note that the plot is generated from BlockSim, but the settings are the same for all Synthesis desktop applications.)
Chapter 21: Synthesis Plot Utilities

Plot Setup: Zoom Page

The Zoom page allows you to customize the options used when zooming in on a plot by using the mouse wheel. Zooming works only for plots with scales. For more information, see Basic Plot Features.

Allow Zoom if selected, allows the plot zoom feature to be used.

- **Factor** use this option to set the amount of the magnification each time you use the mouse wheel on the plot. The lower the number, the greater the increase in the magnification.

- Use the **Border Color, Thickness and Style** option to set the appearance of the zoom box. To change the color of the border, click the **Color** box to the left of the **Thickness** box. Adjust the thickness of the border by entering a positive integer in the input box. Change the style of the line (e.g., solid, dashed, etc.) by clicking the **Line Style** box to the right of the **Color** box.

- **Fill Style** allows you to select a style of hatching to be used on the zoom box.
• **Fill Color** allows you to specify a foreground color to be used on the zoom box. This color is not used if the selected fill style does not use a background color (i.e., solid or transparent fill style).

• **Background color** allows you to specify a background color to be used on the zoom box. This color is not used if the selected fill style does not use a background color (i.e., solid or transparent fill style).

### Plot Defaults Window

Each time you open the Plot Setup window, the changes that you make will apply only to the current plot unless you specify otherwise. To specify settings to be used as defaults for all subsequent plots or to re-apply default settings to the current plot, click the **Defaults** button to open the Plot Defaults window.

The Plot Defaults window gives you the flexibility to set the default settings for the three main areas of a plot: the plot titles, the plot item settings and the general display areas. You can choose to separately save, load or restore the default settings of each main area or you can set the default settings for all areas at once.

The Plot Defaults window consists of nine pages:

• **All Defaults page.** This page controls the settings for all the other plot setup pages. When you click a button on this page, the effects apply to all pages. This allows you to quickly make changes without having to individually change each of the other pages.

• **Titles Text page.** This page allows you to customize default plot titles for each plot type without having to view a plot of that type. For example, you can display a Failure Rate vs. Time plot while changing the titles for a System Failures plot.

• **Plot Items Display page.** This page allows you to customize the details of the default appearance of the lines, points, bars and/or slices of every plot type without having to individually change each plot.

• **General page.** This page controls the settings for the five section pages below it. When you click a button on this page, the effects apply to the Titles Display, Labels, Legend, Canvas and Grid and Offsets pages.

• The Titles Display, Labels, Legend, Canvas and Grid and Offsets pages control the settings of their individual sections. When you click a button on one of these pages, the effects apply only to that specific section.
Three Defaults buttons appear on every page of the Plot Defaults window. The scope of their effects differs slightly depending on the page you are working with.

- **Save Defaults** saves settings for use as the default settings for all subsequent plots. This will overwrite the previous default settings.

- **Load Defaults** enters the saved default values for the settings. You can then click OK in the Plot Setup window to apply the default settings to the current plot. This is an easy way to undo changes you have made in the Plot Setup window and re-apply default settings.

- **Restore Defaults** clears the saved default settings and restores the default values that are shipped with the application.

The scope of the Defaults buttons' effects changes as follows:

- For the Titles and Plot Item Display pages, these buttons save/load/restore the settings specified on the current page.

- For the Titles Display, Labels, Legend, Canvas and Grid and Offsets pages, these buttons save/load/restore all current settings on the corresponding page(s) of the Plot Setup window (e.g., clicking **Save Defaults** on the Canvas and grid page of the Plot Defaults window will save the settings from the Canvas, Grid, Bars and Slices pages).

**Note:** The settings affected by the Defaults buttons on the Titles Display, Labels, Legend, Canvas and Grid and Offsets pages include all settings relevant to the section, regardless of whether they are currently available or not. For example, if you have previously specified settings for a pie chart and are now specifying settings for a bar chart, the settings that you created for the pie chart will be saved as defaults when you click **Save Defaults** and will be applied to subsequent pie charts.

- For the All Defaults and General pages, clicking these buttons is equivalent to clicking them on all of the subordinate pages.

### Plot Defaults Window: Titles Text Page

The Titles Text page of the Plot Defaults window allows you to customize default plot titles for each plot type.

- **Titles** allows you to select the plot type that you are changing the default titles for.

- **Main** allows you to type the default main title for the plot.

- **X-Axis** allows you to type the default title for the x-axis for the plot.

- **Y-Axis** allows you to type the default title for the y-axis for the plot.
Chapter 21: Synthesis Plot Utilities

Plot Defaults Window: Plot Items Display Page

*Plot Item Type* allows you to select the style of plot that you want to specify default settings for. The settings you specify are retained in the background when you choose a new item in this list, so you can specify settings for each type and save all of them, if desired.

The options on this page are identical to those on the [Plot Items page](http://blocksim.reliasoft.com) of the Plot Setup window for the corresponding plot style.

ReliaSoft Draw

ReliaSoft Draw (RS Draw) is a metafile graphics editor that allows you to annotate and customize your plots. With RS Draw, you can insert text, draw an object, mark the coordinates of a particular point or paste another picture into your plot. You can also re-arrange the objects in your plot by selecting and moving them to the positions you desire. In addition, you can save the annotated plot in one of the following formats: *.rdc, *.jpg, *.gif, *.png or *.wmf.

RS Draw is available by clicking the icon on the plot control panel.

See [ReliaSoft Draw Help](http://blocksim.reliasoft.com) for information on the features available in ReliaSoft Draw. If you do not currently have Internet access, this link will not work, but you can browse to the local copy of the help file by opening the Help\RSDraw\rsdraw.htm file in your Synthesis application directory.

Overlay Plots

Available in Weibull++, ALTA, BlockSim and RGA, overlay plots give you the ability to display results from multiple analyses in a single plot. This allows you to easily compare different data sets, analysis methods or distributions. For example, you may wish to show the reliability plots of two product designs in the same plot or compare a simulation-based data set with actual data obtained from fielded products.

Creating an Overlay Plot

Before using an overlay plot, you must first analyze the data sets (or simulate the diagrams) you wish to include in the plot. You can then add an overlay plot to the project by choosing **Insert > Reports and Plots > Overlay Plot**.
In the window that appears, select the data sheets/diagrams you want to include in the plot (up to a maximum of 20) and click **OK** to create the plot sheet. The plot sheet will be saved automatically under the **Multiplots** heading in the current project explorer.

**Tip:** In Weibull++, ALTA and RGA, you can add additional plot sheets to a folio by choosing **[Life Data/Life-Stress Data/Growth Data] > Folio Sheets > Insert Additional Plot.** The additional sheets can function as overlay plots to display results from multiple data sheets in the current folio on a single plot.

### Adding or Removing Analyses

To add or remove analyses from an overlay plot, click the button on the control panel, as shown in the example below for data sheets.

If you later delete an analysis that is referenced by the plot, the plot will remain available and will continue to show the results of the analysis until you redraw the plot (by clicking the **Redraw Plot** icon on the control panel).

Note that importing or exporting an overlay plot will automatically import/export the associated source analyses. (See **Importing/Exporting Project Items or Resources**.)

### Available Plot Types for Overlay Plots

The available plots depend on the analysis or type of data you are working with.

**For Weibull++/ALTA**

Probability plots, contour plots and ALTA stress plots are available only if the data sets have been calculated with the same distribution. This is because the scales or axes in those types of plots vary for different types of distributions.

In DOE design folios, plots that are intended to be viewed as singular plots will not be available for inclusion in overlay plots. These include the comparison chart, Pareto chart, interaction matrix, term effect plot, cube plot, residual histogram, residual autocorrelation plot, and Box-Cox transformation plot. In addition, only plots that are common to the type(s) of design you have selected will be available in the overlay plot. If a plot type is unavailable for any of the included design types, it will be unavailable in the overlay plot.
Chapter 21: Synthesis Plot Utilities

**For BlockSim**

You can compare data from analytical and simulation diagrams in the same plot, but keep in mind that analytical diagrams always show the reliability over time (does not account for repairs) while simulation diagrams always show the point reliability over time (may include repairs).

**For RGA**

Only plots that are common to the analyses you have selected will be available in the overlay plot. If a plot type is unavailable for any of the included analyses, it will be unavailable in the overlay plot. It is possible for the selected analyses to not have any common plot types.

**Side-By-Side Plots**

Available in Weibull++, ALTA and RGA, side-by-side plots give you the ability to display different plots for a single data set all in a single window for easy comparison.

To add a side-by-side plot to a project, choose **Insert > Reports and Plots > Side-by-Side Plot**.

In the window that appears, select the analysis/data sheet you want to plot and click OK to create the plot sheet.

To view a single plot in greater detail, double-click the plot. You can double-click the plot again to return to the side-by-side view.

**Choosing Plots to Display**

The control panel provides options for selecting the type of plots to display. For most analyses, the **Vary** area will be available, which contains two options:

- The vary **Plot Types** option allows you to create different plots for the same data set. For example, you might wish to display both the Reliability vs. Time plot and the Failure Rate vs. Time plot of the data set.

- The vary **Distributions** or **Models** option allows you to compare how different distributions or models fit a particular data set. For example, you might wish to display a reliability plot for different life distributions, as shown next.
3D Plots
Available in Weibull++, ALTA and for two-way sensitivity analysis in RENO, 3D plots give you the ability to graph functions with three variables, such as the reliability at a given time and stress level. In addition, Weibull++ and ALTA offer the option to create 3D overlay plots, which are similar to regular overlay plots but displayed in 3D space.

Creating 3D Plots
Before creating a plot, you must first analyze the data sets (or in RENO, you must first run the simulation for the two-way sensitivity analysis).

To add a 3D plot to the project, choose Insert > Reports and Plots > 3D Plot.

To add a 3D overlay plot to a project (Weibull++ and ALTA only), choose Insert > Reports and Plots > 3D Overlay Plot.

In both cases, the plots are automatically saved and stored in the Multiplots heading in the current project explorer.
Defining the X, Y and Z Axes
The control panel in the 3D plot folio contains basic settings for defining the X, Y and Z axes. (For advanced customization options, see 3D Plot Setup.)

The Begin and End fields, as shown next, display the minimum and maximum values for the axes. You can click inside these fields to manually edit the values, or select the Autoscale check box to have the application automatically choose the appropriate values for the range.

![Parameter Fields Example](image)

Whenever applicable, the Parameter fields will be displayed, as shown in the example above. Click these fields to change which parameter lies on which axis. The name of the parameter associated with the axis will be displayed next to that axis’s label.

Rotating 3D Plots
The XYZ indicator shown at the lower-left of a 3D plot represents the plot’s horizontal rotation (azimuth) and vertical rotation (elevation) in 3D space. Any changes to a plot’s rotation are reflected in the XYZ indicator, helping you to visualize the plot’s orientation on the screen.

![3D Plot Rotation](image)

There are several ways to rotate or manipulate a 3D plot, using the mouse, keyboard shortcuts or the view cube.
Using a Mouse and Keyboard Shortcuts

<table>
<thead>
<tr>
<th>If you want to</th>
<th>Use a mouse</th>
<th>Use keyboard shortcuts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate the plot or change the viewing angle</td>
<td>Click anywhere in the plot area, and then press and hold the left mouse button while moving the pointer.</td>
<td>Press the Up, Down, Left or Right arrow keys.</td>
</tr>
<tr>
<td>Move the plot without changing its rotation</td>
<td>Click anywhere in the plot area, and then press and hold the right mouse button while moving the pointer.</td>
<td>Hold the SHIFT key while pressing the Up, Down, Left, or Right arrow keys.</td>
</tr>
<tr>
<td>Zoom in or out</td>
<td>Rotate the mouse wheel. Alternatively, you can choose <strong>3D Plot &gt; Display &gt; Zoom In or Zoom out.</strong></td>
<td>Press the W or S keys.</td>
</tr>
<tr>
<td>Automatically center the plot on canvas</td>
<td>Choose <strong>3D Plot &gt; Display &gt; Center on Canvas.</strong></td>
<td>N/A</td>
</tr>
</tbody>
</table>

Using the View Cube

The View Cube helps you to easily orient a 3D plot using predefined viewpoints. The cube is located at the lower-right of the 3D plot.

The letters on the cube represent a particular viewpoint. For instance, clicking the "F" side of the cube orients the plot such that you are looking directly at the plot’s front side (e.g., Y and Z plane).

- Front
You can rotate the cube in the same way you would rotate any 3D plot (i.e., press and hold the left mouse button while moving the pointer anywhere on the screen; or press the Up, Down, Left or Right arrow keys on your keyboard).

3D Plot Setup
The 3D Plot Setup allows you to customize the look of 3D plots to meet your needs. It gives you full control over the settings used for individual 3D plots and the default settings for all new 3D plots.

To access the 3D Plot Setup, choose 3D Plot > Actions > 3D Plot Setup.

Alternatively, you can double-click the item on the plot you wish to edit. This will automatically open the 3D Plot Setup and display the options associated with that item. The available options in the 3D Plot Setup will vary, depending on the plot type. You can move the mouse pointer over an option to display its definition.
To apply your changes to the current plot only, click **OK**.

To save your changes and use them as the default setting for all new 3D plots, click the **Save as Default** button. This will overwrite the previous default settings.

To restore the previously saved defaults, click the **Load Defaults** button. This is an easy way to undo changes you have made in the 3D Plot Setup and re-apply default settings.

To reset all settings to the default values that were shipped with the application, click the **Reset** button.
The Synthesis Workbook is a custom reporting tool that is built directly into many Synthesis applications, including Weibull++/ALTA, RGA and BlockSim. It combines two reporting modules—Spreadsheets and Word Processing—into the same flexible interface, thereby replacing the Analysis Workbook and Word Report Template functionality from prior versions.

**Tip:** If you convert a project from Synthesis 10 or earlier, any Analysis Workbooks and Word Report Templates will be automatically converted to Synthesis Workbooks.

If your organization has implemented a Synthesis Enterprise Portal (SEP) website for an enterprise database, you can choose to publish selected Synthesis Workbook reports to be accessed from any web-enabled device. See Publishing to SEP.

**Synthesis Workbook Wizard**

To add a new Synthesis Workbook in an existing project, choose Insert > Reports and Plots > Synthesis Workbook.

This launches the wizard, which gives you the opportunity to assign the first associated data source and/or select a saved template, if desired. (Note that the examples shown here are from Weibull++ but similar functionality is available in ALTA, RGA and BlockSim.)

**If you prefer to start with a blank report:**

Simply click OK and then click Yes when prompted to confirm that you want to create the report without associating a data source. (You will be able to associate data source(s) later if you wish.)

**If you want to assign the first data source:**

Click Select and choose one of the available analyses (i.e., a data sheet in Weibull++/ALTA and RGA, or a diagram in BlockSim). When you return to the wizard, click OK to create the report.

Note that you will be able to associate more data sources after the report is created, and change any of those assignments at any time. (See Associated Data Sources.)
If you want to use a saved template:

Click **Spreadsheet** or **Word Processing**. Select the **Based on Existing Template** check box and then choose a template from either the Standard tab (templates that are installed with the software) or the User tab (templates you have saved). Then click **OK** to create the report. (See **Synthesis Workbook Templates**.)

**Associated Data Sources**

In **Synthesis Workbooks** in Weibull++/ALTA, RGA and BlockSim, you have the option to associate multiple data sources that can be used for any function that obtains data or results from an existing analysis. (To obtain results from a DOE analysis in Weibull++/ALTA, see **DOE Analysis Report**.)

When you create this type of function, you will have the option to use an index to specify which of the currently assigned default data sources will be used. For example, if you want to compare the reliability values calculated from two different analyses, you can use

```
=RELIABILITY(Default1,1000) to get the result from the first default data source, and
=RELIABILITY(Default2,1000) to get the result from the second default data source.
```

Although you will be prompted to associate the first data source when you create the report, you can add or change associated data sources for an existing report at any time.

**Associating Data Sources**

For Synthesis Workbooks, the Information panel (located on the right side of the window) shows which analyses are currently assigned as default data sources. To have the panel always display, click the pushpin icon into the vertical position.
To add or remove analyses, choose **Home > Report > Associate Data Sources** or click the icon in the Information panel.

The following picture shows the windows for Weibull++. Similar functionality is available in ALTA, RGA and BlockSim.

Note that:

- In **Weibull++/ALTA**, you can select any data sheet from a folio that contains a life data analysis:
  - Life data folio
  - Life-stress data folio
Chapter 22: Synthesis Workbooks

- Non-parametric LDA folio
- Warranty analysis folio
- Degradation analysis folios (the results shown in the report will be based on the analysis of the extrapolated failure/suspension times)

- In RGA, you can select any data sheet in a growth data folio.
- In BlockSim, you can select any analytical diagram, simulation diagram or phase diagram. The function results can either be based directly on the analyzed/simulated diagram, or based on a model that has been fitted to the diagram. You specify this preference on the diagram’s control panel, using the Report folio model drop-down list on the Analysis Settings page.

Linking Multiple Data Sources with Different Time Units

In BlockSim, function results that are time-based (e.g., downtime, time to event, etc.) will be returned in the System Base Unit (SBU) for the repository. However, in Weibull++/ALTA or RGA, each function result is returned in the units used by its data source. If you wish to compare the results from multiple data sources that use different time units, there are two possible scenarios:

- Convert the data in the original data source. For example, if one data set is in "hours" and another is in "days," you could use the Change Units feature to automatically convert the data in the first analysis from "hours" to "days."

  **Tip:** If you want to keep the original analysis unchanged, you could create a copy of the data sheet, then convert the duplicate data sheet to use the new units.

- Manually adjust the functions so they return results in the same units. For example, if the data set is in "days" and you want the results to display the B10 life in "hours," you could adjust the function by adding a conversion ratio. For example, if 1 day is equivalent to 24 hours, you could edit the function as follows:
  
  \[(\text{TIMEATPF("Weibull!Week!Data1", 0.1)} \times 24)\]

Synthesis Workbook Templates

In Synthesis Workbooks, saved templates make it easy to reuse the same report multiple times — in different analysis projects and with different data sets.
**Note:** For DOE analyses, instead of saved templates for the entire workbook, you can use saved profiles in the [DOE Report Generator](#).

In addition to the *Standard* templates that are installed with the software, you can also create your own *User* templates that are saved from any existing report. Note that the templates are module-specific (i.e., compatible with either the spreadsheet module or the word processing module).

### Saving Your Own Templates

It is easy to create a template from any Synthesis Workbook that is currently open.

Select either the spreadsheet or the word processing module, then choose **Document > Save Template**.

You can name and store the custom templates however you wish. To share a template with other users, you can simply send them a copy of the file, or you can save the file in a shared network location that multiple users can access.

### Using a Template

You can select a template when you create a new Synthesis Workbook. (See [Synthesis Workbook Wizard](#).)

Alternatively, you can use the steps below to apply or change the template for an existing workbook at any time.

**IMPORTANT:** This will replace any existing content in the current module, and the change can’t be undone.

1. Select either the spreadsheet or word processing module and then choose **Document > Open Template**.

2. Select a template from either tab then click **OK** to apply the template to the new or existing report.

   - The **Standard** tab displays the templates that are installed with the software and stored in the applicable sub-folder under `C:\Users\Public\Documents\ReliaSoft\Templates`. 
Chapter 22: Synthesis Workbooks

- The User tab displays custom templates that were saved from an existing report. These can be stored in any location that is convenient for you. If the custom template you need is not displayed, click the Open icon to browse for the desired template and add it to the list.

Spreadsheet Module
The spreadsheet module in Synthesis Workbooks provides functionality similar to Microsoft Excel (with built-in functions and complete in-cell formula support), and it can be used to integrate data and/or results from multiple analyses at the same time.

Send to Excel
To export all sheets in the spreadsheet module to a Microsoft Excel file, choose Home > Report > Send to Excel.

Inserting Functions
- To build and insert functions that utilize a referenced analysis (data source), see Function Wizard - Data Sources.
- To add math, date, logic and other functions, see Function Wizard - Formulas.

Showing Formulas
To display the formulas instead of the calculated results in the worksheet cells, choose Formulas > Formula Auditing > Show Formulas.
You can toggle the formula display on and off.

Recalculate Formulas
By default, the spreadsheet automatically recalculates all formulas whenever you open the workbook or when the cells that a formula depends on have changed. However, if your spreadsheet contains a large number of formulas, the recalculation process may take more time and every change may require you to wait several seconds or minutes for the application to recalculate all values. In this case, you can control when calculation occurs by changing the setting to manual calculations.

To use manual calculations, choose Formulas > Calculation > Calculation Options, and then choose the Manual option. To change the settings back to automatic calculations, choose the Automatic option.

To recalculate all formulas when in Manual mode choose Formulas > Calculate > Calculate Now.

The Calculate Now command can also be used to refresh the spreadsheet. A spreadsheet needs to be refreshed whenever its referenced data source(s) has been recalculated. This ensures that the spreadsheet reflects the most current results.

Adding Custom Charts
To create your own custom chart, first select the cells that contain the relevant data, then go to Document > Charts and choose a chart type and style. (See Custom Charts in Synthesis Workbooks.)

Defining Names
To create variable names that reference specific spreadsheet cells, see Defined Names.
**Word Processing Module**

The word processing module in Synthesis Workbooks offers custom reporting functionality that is similar to a Microsoft Word document. You may prefer to use this tool if you want to have a more polished, professional looking report.

This module has two tabs located at the bottom of the window: Design and Review. Use the Design tab to add text, functions and plot holders. Use the Review tab to see the results before you generate the final report.

To export the report to Microsoft Word, choose **Send to Word**.

---

**Using the Function Wizard**

To use the Function Wizard to build and insert functions that utilize a referenced analysis (data source), choose **Home > Report > Function Wizard**. (See [Function Wizard - Data Sources](#).)

---

**Using the Plot Wizard**

To use the Plot Wizard to generate a variety of plots based on a referenced analysis, choose **Home > Report > Plot Wizard**. These are the same types of plots that are generated in an analysis folio or diagram plot sheets. (See [Plot Wizard](#).)

---

**Using Spreadsheet References**

To reference cells from the spreadsheet module (within the same workbook), choose **Home > Report > Spreadsheet Reference** and select the desired cells. The link between the word processing and spreadsheet modules is dynamic; when data in the spreadsheet is changed, the word processing module is automatically updated. (See [Spreadsheet References](#).)

---

**Formulas and Functions**

**Function Wizard - Data Sources**

In both the spreadsheet module and word processing module for Synthesis Workbooks in Weibull++/ALTA, RGA and BlockSim, you can build functions that return results based on an analyzed folio or diagram.

---

*Note:* To insert math, date, logic and other functions into the spreadsheet module of a Synthesis Workbook, see [Function Wizard - Formulas](#).
Using the Function Wizard

To open the Function Wizard in Synthesis Workbooks, choose **Home > Report > Function Wizard**.

Select a function from the navigation panel and enter any required inputs. The following picture shows the most complex configuration as an example. After entering the inputs, click **Insert** to place the function into the report at the current cursor location. You can move and/or modify the function expression after it has been inserted.

For spreadsheet functions:

- The bracketed parameters indicate that the input is optional. In the example above, the **Add Time** and **Confidence Level** parameters are optional.

- You can use cell references as inputs. For example, instead of entering 1000 for a time input, you could specify to use whatever time is currently entered into cell A10, using either the relative reference (A10) or the absolute reference ($A$10). (See **Cell References**.)

- You can use variable names as inputs. (See **Defined Names**.)

- You can type the function expressions directly in the cell once you are familiar with the syntax. For more information, see **Data Entry Tips for Functions**.

For the word processing module:

- The brackets are part of the function field and are not optional.
Chapter 22: Synthesis Workbooks

- The functions will not return any results until you either switch to the Review tab or generate the report in Microsoft Word.

**Selecting a Data Source (if Applicable)**

There are two ways to specify the data source:

- **Use the Data Source Name** (spreadsheets module only): This approach will return results based on a specific data sheet or diagram.

  In the Function Wizard, clear the Use Default check box and click the Select button to choose the data source, as shown next. In this example, the function will return results based on the data sheet called "Data1" in the Weibull++ life data folio called "Folio1."

![Data Source Image](image)

- **Use a Data Source Index** (spreadsheet and word processing modules): This approach allows you to use the report as a template and return results based on a given data set.

  First, you must add data sources to the Synthesis Workbook (see Associated Data Sources). Then, in the Function Wizard, click the Data Source Index drop-down list and choose the index number of the desired data source. (In spreadsheets, select the Use Default check box to access the Data Source Index drop-down list.)

![Data Source Index Image](image)
Function Wizard - Formulas
In the spreadsheet module for Synthesis Workbooks in Weibull++/ALTA, RGA and BlockSim, you can insert functions that perform math, date, logic and other operations.

Using the Function Library
The quickest way to add a function is to select it from the appropriate function category drop-down list, then select the cells of interest (hold down the CTRL key to select nonconsecutive cells) and press ENTER. You can move and/or modify the function expression after it has been inserted.

For example, to calculate the average reliability for the following units, you would choose Formulas > Function Library > AutoSum > Average. Select cells B3 through B9 and press ENTER. Note that the cell references can be relative (B3:B9) or absolute ($B$3:$B$9). (See Referencing a Cell.)

Using the Function Wizard
To use the Function Wizard, choose Formulas > Function Library > Insert Function.

Select a function from the drop-down list and click OK. Then in the Function Argument window, enter the input by either selecting the cells in the sheet or typing them directly into the appropriate field. For information relating to entering text as an input, cell references, and working with date and time functions, see Data Entry Tips for Functions.
For example, to exclude the value from unit 4 (failure due to operator error) from the average, you would select cells B3 through B5 for **Number 1**, and B7 through B9 for **Number 2**.

![Excel screenshot](image)

**Data Entry Tips for Functions**

This topic provides some data entry tips for using spreadsheet functions in Synthesis Workbooks and general spreadsheets. If you create the function using the Function Wizard, most of the syntax and formatting issues will be handled automatically. However, you have the option to create or modify function expressions directly in spreadsheet cells.

*Note:* For DOE design folios, you can disregard any tips related to *data source functions* (i.e., functions that obtain data or results from a specific data sheet or diagram). For that type of analysis, you can use the **DOE Analysis Reports** feature to obtain results from a design, multiple linear regression or one-way ANOVA folio, or any of the measurement systems analysis folios.

**Case Sensitivity**

The functions are not case sensitive.

**Entering Text as an Input**

When entering text as an input to a function, you must enclose it in quotation marks. This includes situations where you need to specify the data source – `DISTR("Weibull!Folio1!Data1")` – and situations where you need enter a time or date value in one of the accepted text formats – `DAY("22-Aug-2014")`. 
Regional Settings
If your regional settings use a comma as the decimal separator, you must use a semicolon to separate function arguments (e.g., =RELIABILITY("Weibull!Folio1!Data1";A4)).

Referencing a Cell in the Same Sheet
If you want to use another cell in the same sheet, enter the cell reference with a letter to identify the column and a number to identify the row. The cell references can be relative (e.g., B2) or absolute (e.g. $B$2).

- A relative reference points to a cell based on its relative position to the current cell (e.g., B2). When the cell containing the reference is copied, the reference is adjusted to point to a new cell with the same relative offset as the original cell.

- An absolute reference points to a cell at an exact location. Absolute references are designated by placing a dollar sign ($) in front of the row and/or column that is to be absolute. For instance, $B$2 is an absolute reference that points to the cell located in Column B, Row 2 regardless of the position of the cell containing the reference.

For example, if you want to obtain the probability of failure for the time that has been entered in cell B2, the function could be either =PROBFAIL(B2) or =PROBFAIL($B$2). You can type the cell location directly into the field or click the Function Wizard’s Insert Workbook Reference icon to insert the reference to the cell currently selected in the sheet. If you want to insert an absolute reference, press CTRL while you click the icon.

Another option is to use the Defined Names tool to assign a name to the cell and use the name in all of the function expressions that require that input. (See Defined Names.)

Referencing a Cell in a Different Sheet
To reference a cell in a different sheet from the one in which the formula is entered, use an exclamation mark (!) after the sheet name. For instance, =Sheet1!$B$2 is a reference to the cell located in Column B, Row 2 in Sheet 1. When referencing a cell in a different sheet from the one in which the formula is entered, the reference must be absolute. If the reference is not absolute, the calculations will not be carried out properly.

You can only reference sheets in the same workbook.

Referencing a Cell in a Data Source
Some functions (e.g., DATAENTRY and FMATRIX) require you to reference a particular cell in a data source. This must be defined differently than references to a cell in a spreadsheet. For data source cell references, you must identify first the row and then the column, and use a
number rather than a letter to represent the column (e.g., A=1, B=2, C=3 and so on). For example:

- \( =\text{DATAENTRY} (\text{Default1}, 2, 1) \) returns the value that was entered into cell A2 in the Weibull++, ALTA or RGA folio that is the data source for this function.

- \( =\text{FMATRIX} (\text{Default1}, 2, 1) \) returns the value from the second row in the first column of the Fisher variance/covariance matrix that was calculated for that data source.

### Creating Composite Functions

It is possible to combine different types of data sources and/or functions to create a composite function. For example, in the following formula, two different data sources are used to return the difference between the reliability at 100 hours calculated from the specific Weibull++ life data folio data sheet called "Weibull!Target!Data1" and the reliability at 100 hours calculated from any given Weibull++ data sheet that is currently first in the list of associated data sources for the workbook or General Spreadsheet.

\[
= (\text{RELIABILITY}("\text{Weibull!Target!Data1}",100)) - \text{RELIABILITY} (\text{Default1}, 100)
\]

In the next example, nested functions are used to round up the returned reliability result to the nearest two decimals.

\[
=\text{ROUNDUP}((\text{RELIABILITY} (\text{Default1}, 1000)), 2)
\]

### Omitting Optional Inputs in the Middle of a Function

If you do not use an optional input in the middle of the function, the function expression must specifically indicate that the input is being omitted. For example, when using the Weibull++ reliability function \( \text{RELIABILITY} (\text{Data} \_\text{Src}, \text{Age}, [\text{Add Time}], [\text{Confidence Level}]) \), if you want to get the confidence bound on the reliability, you must use two commas (,,) to indicate that the [Add Time] input is intentionally blank, before entering the [Confidence Level] in its usual fourth position (e.g., \( =\text{RELIABILITY} (\text{Default1}, 1000,, 0.95) \)).

Note that this is handled automatically if you use the Function Wizard to build and insert the function expression.

### Working with Date Functions

When using one of the spreadsheet date functions (\( \text{DAY} \), \( \text{DAYS360} \), \( \text{MONTH} \), \( \text{WEEKDAY} \) and \( \text{YEAR} \)) to enter a date, you can use one of the following accepted text formats:

- Month/Day/Year ("8/22/2014"). For example, \( =\text{DAY} ("8/22/2014") \) returns 22.

- Day-Month-Year ("22-Aug-2014"). For example, \( =\text{MONTH} ("22-Aug-2014") \) returns 8 (because August is the 8th month).
If you do not include the year (e.g., “8/22” or “22-Aug”), the current year is assumed.

Alternatively, you can use the date’s serial number (which is the number of elapsed days since January 1, 1900). For example, =YEAR(41873) returns 2014.

- You can obtain a date’s serial number using either of the following two functions. This may be helpful in cases where you want to filter, sort or use the date(s) in calculations.
  - The **DATE** function uses the inputs of other cells to obtain the serial number. For example, if you have dates specified in three cells where A2=Year, B2=Month and C2=Day, =DATE(A2, B2, C2) returns the serial number for that date.

<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>D2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>=DATE(A2, B2, C2)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>Year</td>
<td>Month</td>
<td>Day</td>
<td>Serial #</td>
</tr>
<tr>
<td>2</td>
<td>2014</td>
<td>8</td>
<td>22</td>
<td>41873</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- The **DATEVALUE** function requires you to enter the date in an accepted text format. For example, =DATEVALUE("8/22/2014") returns 41873.

Finally, you can also use the results of other functions within a date function. For example:

- To return the month from today’s current date, use: =MONTH(TODAY())
- To return the day of the week for a date that is specified in three separate cells (A2=Year, B2=Month and C2=Day), use: =WEEKDAY(DATE(A2, B2, C2))

<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>D2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>=WEEKDAY(DATE(A2, B2, C2))</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>Year</td>
<td>Month</td>
<td>Day</td>
<td>Weekday</td>
</tr>
<tr>
<td>2</td>
<td>2014</td>
<td>8</td>
<td>22</td>
<td>6</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td>(Friday is the 6th day of the week.)</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Working with Time Functions**

When using one of the spreadsheet time functions (**HOUR**, **MINUTE** and **SECOND**) to enter a time, you can use one of the following valid text formats:

- Hour:Minute[:Second] [AM/PM]. For example, =HOUR("4:48:10 PM") returns 16 (the hour using the 24 hour system).
- Month/Day/Year Hour:Minute[:Second] [AM/PM]. For example, =MINUTE("8/22/2014 4:48:10 PM") returns 48.
Alternatively, you can use the hour, minute or second’s serial number (which is the fractional portion of a 24 hour day). For example, \(\text{=MINUTE(0.70011574)}\) returns 48 (as the specified serial number represents 4:48 PM).

- You can calculate a time’s serial number using either of the following two functions. This may be helpful in cases where you want to filter, sort or use the time(s) in calculations.
  - The **TIME** function uses the inputs of other cells to obtain the serial number. For example, if you have dates specified in three cells where \(\text{A2=Hour, B2=Minute and C2=Second, =Time(A2,B2,C2)}\) returns the serial number for that time.

<table>
<thead>
<tr>
<th>D2</th>
<th>=TIME(A2,B2,C2)</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>B</td>
</tr>
<tr>
<td>1</td>
<td><strong>Hour</strong></td>
</tr>
<tr>
<td>2</td>
<td>16</td>
</tr>
<tr>
<td>3</td>
<td></td>
</tr>
</tbody>
</table>

- The **TIMEVALUE** function requires you to enter the time as text in one of the accepted text formats. For example, \(\text{=TIMEVALUE("4:48:10 PM")}\) returns 0.70011574.

Finally, you can also use the results of other functions within a time function. For example:

- To generate current values, you can use the **NOW** function. If the current time is 4:48 PM, then \(\text{=HOUR(NOW())}\) returns 16.

**Returning Confidence Bounds**

For functions in Weibull++/ALTA and RGA that return confidence bounds, note that the **Function Wizard** for data sources only inserts one-sided bounds. If you want to show two-sided bounds, you can insert the same function twice — once at the lower confidence bound and once at the upper confidence bound. For example, for a 90% confidence level, you would set the lower confidence bound at 5% and the upper confidence bound at 95%.
In a spreadsheet, you can use the same function (with different input parameters) to obtain any of the three values. For example, in Weibull++:

\[ =\text{RELIABILITY}(\text{Default1}, 1000) \] returns the estimated value

\[ =\text{RELIABILITY}(\text{Default1}, 1000,, 0.05) \] returns the lower one-sided bound at 5%

\[ =\text{RELIABILITY}(\text{Default1}, 1000,, 0.95) \] returns the upper one-sided bound at 95%

Note that the above function expressions for the confidence bounds uses two commas (,,) to indicate that another optional input ([Add Time]) was intentionally left blank. For more information about the syntax for functions containing multiple optional inputs, see Data Entry Tips for Functions.

In a word processing module for Synthesis Workbooks, the wizard provides separate functions for confidence bounds. For example, use the Reliability function to get the estimated value and use the Bound on Reliability function to get each one-sided confidence bound.

**Plot Wizard**

In the word processing module for Synthesis Workbooks in Weibull++/ALTA, RGA and BlockSim, you can use the Plot Wizard to generate a variety of plots based on a referenced analysis. These are the same types of plots that are generated in folio or diagram plot sheets. Although you also have the option to copy/paste a static plot graphic from any folio or diagram plot sheet into the report, using the Plot Wizard makes it easy to change the associated data source when you reuse the template and ensures that the plot in the generated report will always show the latest analysis. (For DOE design folios, you can use the DOE Analysis Reports feature to insert plots from a design, multiple linear regression or one-way ANOVA folio, or any of the measurement systems analysis folios.)

To open the Plot Wizard, choose Home > Report > Plot Wizard.
The following picture shows the plot wizard in Weibull++. Similar functionality is available for RGA and BlockSim.

There are three steps to use this tool:

1. Select the plot type (and enter the inputs, if applicable)
2. Select the data source
3. Insert the plot holder

**Select the Plot Type**

First, select one of the available plot types from the panel on the left side. The right side of the wizard displays some information about the plot that is currently selected.

If applicable, this area also allows you to make relevant inputs (e.g., for ALTA plots that require you to select a specific stress column).

**Select the Data Source**

To specify the data source that the plot will be based on, choose a number from the **Data Source Index** drop-down list, as shown next. Using the index makes it easy to reuse the same template with a variety of different data sets.
Insert the Plot Holder

When the plot is fully defined, click **Insert** to place it at the current cursor location. You can move and/or resize the plot holder after it has been inserted. The plot holder shown next will return the reliability vs. time plot for whatever data source is currently second in the list of associated data sources.

Plot holders will not return any results until you view it in the Review tab or generate the report (**Home > Report > Send to Word**).
Custom Charts

In the spreadsheet module for Synthesis Workbooks, you can use the Document > Chart commands to insert your own custom charts. The charts can be placed anywhere in the spreadsheet, and are dynamic (automatically update when the data used to create the chart is changed).

Adding a Chart

1. Select the cells that contain the data of interest. In the example data below, the headings are included in the selection and will be used as the legend labels.

   ![Reliability vs. Time Chart](chart.png)

<table>
<thead>
<tr>
<th>Time</th>
<th>Reliability</th>
<th>Product A</th>
<th>Product B</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>0.99996</td>
<td>0.99586</td>
<td></td>
</tr>
<tr>
<td>200</td>
<td>0.99920</td>
<td>0.96401</td>
<td></td>
</tr>
<tr>
<td>300</td>
<td>0.99506</td>
<td>0.87716</td>
<td></td>
</tr>
<tr>
<td>400</td>
<td>0.98217</td>
<td>0.72349</td>
<td></td>
</tr>
<tr>
<td>500</td>
<td>0.95220</td>
<td>0.52071</td>
<td></td>
</tr>
<tr>
<td>600</td>
<td>0.89495</td>
<td>0.31434</td>
<td></td>
</tr>
<tr>
<td>700</td>
<td>0.80119</td>
<td>0.15282</td>
<td></td>
</tr>
</tbody>
</table>

2. Choose Document > Charts. Choose the chart type, and then click a chart subtype that you want to use.
3. To move the chart, click and drag the chart to the desired location.

4. To resize the chart, click the chart and then drag the sizing handles to the desired size.

Changing the Data Displayed on an Axis
To change the way the data series is displayed on the axes, click the chart, then choose Design > Data > Switch Row/Column.

Changing the Chart Type and/or Data Set
You can change the type of chart and/or the data that is used in a chart at any time. To do this, click the chart and then:

- To change the chart type, choose Design > Type > Change Chart Type. Select the desired type.
• To change the data set, choose Design > Data > Select Data. Select the cells that contain the data of interest.

Applying a Chart Layout and/or Chart Style

• To apply a predefined chart layout, choose Design > Chart Layouts. As an example, the following picture shows some of the options for 2-dimensional bar charts. To see the rest, click the arrow in the bottom-right corner.

If none of the predefined options are suitable for your chart, choose Layout > Labels, then select the option you want to customize. The following picture shows the options for the vertical axis.

• To apply a predefined chart style, choose Design > Chart Styles.

Renaming Chart and Axes Titles

When displaying chart and/or axes titles, you can rename the titles by right-clicking the chart and selecting the appropriate title option from the shortcut menu. For example, choosing Change Chart Title opens the following window:
Modifying the Axes and Gridlines
To hide or display axes and/or gridlines, choose **Layout > Axes > Axes** or **Gridlines**.

- When displaying axes, you can change direction of the x-axis and/or change the scale of the y-axis.
- When displaying gridlines, you can increase or decrease the number of gridlines for both the axes.

Defined Names
In the **spreadsheet module** for Synthesis Workbooks and **general spreadsheets** in Weibull++/ALTA and RGA folios, you can create variable names that reference specific spreadsheet cells. The names can then be used in any formula or function within the same workbook.

For example, say you want to obtain the reliability of a Weibull++ data set. The operating time is stored in cell B5 of the spreadsheet:

\[
\text{=RELIABILITY("Weibull!Bulb!Data1!"$B$5)}
\]

You can create a defined name for the operating time to make the formula easier to understand and maintain. In this case, the formula might be rewritten as:

\[
\text{=RELIABILITY("Weibull!Bulb!Data1!"OpTime)}
\]

You can then use the defined name **OpTime** in any other formula in the workbook that requires the operating time.

Syntax Rules for Names
- The first character of a name must be a letter or an underscore. The remaining characters can be letters, numbers, periods and underscores. Names are not case sensitive.
• Spaces are not allowed as part of a name. An underscore (_ ) or period ( . ) can be used as a word separator.

• Symbols, except for underscores ( _ ), periods ( . ) and backslashes ( \ ), aren’t allowed.

Managing Names
To view and manage defined names:

• In Synthesis Workbooks, choose Formula > Defined Names > Name Manager.
• In general spreadsheets, choose Sheet > Format and View > Defined Names.

You can then use the New, Edit, or Delete commands in the window to create or modify the names.

Defining Names
There are several ways to define a name.

Define a Name via the Name Manager
This method applies to both Synthesis Workbooks and general spreadsheets.

1. Select a cell or range of cells.
2. Create a new name:
   • In Synthesis Workbooks choose Formulas > Defined Names > Define Name (or choose Formulas > Defined Names > Name Manager, then click the New button in the window).
   • In general spreadsheets, choose Sheet > Format and View > Defined Names. Then in the window, click the New button.
3. Type a name into the Name field. In the Scope drop-down list, choose whether this name will be used for the entire workbook or a specific sheet. The Comment field is optional.

   The selected cell/range will already be defined in the Refers to field, but you can click into the spreadsheet and select different cells, if desired.
Define a Name via the Name Box (Synthesis Workbook Only)
This method applies only to the spreadsheet module of Synthesis Workbooks. Select the cell or range of cells, click the Name box and type a name. Press Enter to create the name.

Define a Name via the Selection Command (Synthesis Workbook Only)
If the fields are already labeled in the spreadsheet, you can use them to create names.

1. Select the cells of interest (including the row or column labels), then choose Formulas > Defined Names > Create from Selection.

2. In the window, select the location of the labels. Click OK.
Spreadsheet References

In Synthesis Workbooks, the *spreadsheet reference* feature provides integration between the spreadsheet and word processing modules in the same workbook. You can insert a reference from any cell, or consecutive range of cells, from the spreadsheet into a desired location in the word processing document. If the referenced cells in the spreadsheet are changed, the word processing module is automatically updated. The changes are visible when you use the Review tab to see a preview or generate the Word report.

To insert a spreadsheet reference, place the cursor at the desired location in the word processing document and choose **Home > Report > Spreadsheet Reference**.

Note that you can also use the Spreadsheet Reference function in the word processing module’s **Function Wizard**.

The Select Cells window shows the contents of the spreadsheet module in the current workbook. Select a cell or range of consecutive cells and click **OK**.
For the example data shown above, the entry would look like this:

```
[TBLSSREF(Sheet1!B2:D10)]
```

### DOE Analysis Reports

The DOE Analysis Reports feature allows you to insert selected analysis results and plots into a Synthesis Workbook.

This feature is available for any analyzed response in a design, multiple linear regression, one-way ANOVA or measurement systems analysis folio. The report can display any result that's available in the folio's Analysis Summary window for the selected response, as well as any applicable plot.

This topic describes how to **build and insert a DOE analysis report**, and how to **use saved profiles** for reports that you need to generate frequently. Note that you can insert multiple reports into the same spreadsheet or word processing document, if desired. Each additional report will be appended to the end.
Inserting a DOE Analysis Report

1. Select either the spreadsheet or word processing module in a Synthesis Workbook and choose Home > Report > DOE Analysis Report.

2. In the Select Response window, choose an analyzed response to copy the results from and click OK.

3. In the DOE Analysis Report window, the Available Report Items area (left) shows all of the available results and plots for the selected response. The Selected Report Items area (middle) shows the selected results/plots, in the order in which they will appear. You can:
   a. Choose Profiles > Open Profile to apply all of the relevant selections from a saved report profile. (See Using DOE Report Profiles.)
   b. Build/modify the list using double-click, drag and drop or the Add/Remove and Up/Down buttons.

   Note that you can include multiple instances of the same report item, if desired.

4. When you click each selected report item, the Item Properties area (right) allows you to view/change the name (heading) that will be used in the report, if desired.

   For plots, you can also click the Preview Plot button to see what the plot will look like in the report. Any plot settings you change in the plot preview will be used in the generated report but will not affect the folio the report is based on.


Using DOE Report Profiles

When the DOE Analysis Report window is open, you can save the current settings (i.e., report item selections), or load settings that were previously saved.

- To save all your current report settings for use in future reports, choose Profiles > Save Profile.

Then specify the name and location of the DOE report file (*.drt) that will store the settings.
• To overwrite all the settings in the DOE Analysis Report window and use the settings from a DOE report file instead, choose **Profiles > Open Profile**.

![Folder Icon]

Then select the *.drt file that has all the desired settings.

**Note:** When you load report items from a DOE report file, only the items that apply to the selected folio/response will be included in the report.
Chapter 23: Synthesis Dashboards

The dashboard is a flexible tool for graphical presentation of data. This can include bar and pie charts, gauges, maps, etc.

All Synthesis users can view dashboards based on predefined layouts (see Dashboard Viewer). The viewer is available in the following locations in Synthesis desktop applications:

- Project Planner
- Synthesis Explorer
- Simulation diagram results in BlockSim (see FMEA in the BlockSim/RENO documentation)
- FMEA and FMRA data in Xfmea/RCM++ (see FMEA Dashboards in the Xfmea/RCM++/RBI documentation)
- Synthesis Data Warehouse (SDW) data in Weibull++ and RGA

In a secure database, only users with the "Manage dashboard layouts" permission can manage and create predefined layouts (see Dashboard Layout Manager and Dashboard Layout Designer).

If your organization chooses to implement a web-based Synthesis Enterprise Portal (SEP) for an enterprise database, you can also share selected dashboards to be accessed from any web-enabled device!
Dashboard Viewer

Any user can access the Dashboard Viewer in a variety of locations throughout Synthesis desktop applications for graphical presentation of the latest analysis data.

When dashboard functionality is available for the data you’re working with (e.g., Project Planner, Synthesis Explorer, simulation diagrams in BlockSim, etc.), choose Dashboard > Dashboard Viewer to open the viewer.

Select any of the predefined dashboard layouts from the drop-down list to see the latest charts for the current data set.

Resizing Panels

To resize the dashboard items vertically and/or horizontally, click between two items and drag the resize cursor (↕) to the height and/or width you want. This option is available when a dashboard contains multiple items.
Chapter 23: Synthesis Dashboards

**Showing Details in Charts and Pies**
To see more details about the underlying data, move the mouse pointer over a bar or slice. For example, when the pointer is over a bar in a chart, the values for the x and y axes will be displayed in the tooltip.

![Component Total Cost Chart](image)

**Drill Downs and Master Filters**
For information about how to use charts that have been configured for a drill down, see [Viewing Drill Downs](#). For information about how to use charts that have been configured with master filters, see [Using Master Filters](#).

**Sorting and Filtering Data in a Grid**
- To sort the data in ascending or descending order, click the column heading.
- To filter the data, click the Advanced Filter icon to see a drop-down list of filters that you can apply. The dashboard uses the same advanced filters functionality that is built in to other Synthesis utilities (e.g., Resource Manager, Synthesis Explorer, etc.). (See [Finding and Filtering Records](#).)

**Printing or Exporting the Dashboard**
To print the entire dashboard, or export it as a *.pdf file or as an image, click the **Export To** icon.
**Viewing Drill Downs**

An easy way to determine if the dashboard was configured for drill down is to look for the arrow in the caption bar, if the bar is visible.

To drill down, double-click an area of interest.

To drill up, click the arrow (📍) until you have reached the desired level or right-click the chart, then choose **Drill Up**.
Using Master Filters
When a dashboard with master filters is created, it can be configured for single or multiple filtering. If you see either of the following, then filtering is enabled:

- For **single** filtering, the dashboard title is followed by light gray text.

![Dashboard Server 1](image)

- For **multiple** filtering, the **Clear Master Filter** icon displays in the caption bar, if the bar is visible.

![Component](image)

Note that if you see both the icon and light gray text, this means that multiple filtering is enabled, but only one item in the filter is selected.

**Single Filtering**
For single filtering, you can only select one item at a time. You will not be able to clear the view, only select a different item.

**Multiple Filtering**
For multiple filtering, you can select as many filter items as you want to view. Hold down **SHIFT** while clicking to select consecutive elements or hold down **CTRL** while clicking for nonconsecutive items.

In the example shown next, the grid was set up as the master multiple filter. The chart and pie charts display the data for the four parts selected in the grid.
Chapter 23: Synthesis Dashboards

Dashboard Layout Manager
You can use the Dashboard Layout Manager to create, edit and delete the predefined dashboard layouts that will be available for any Synthesis user to view for a particular data set. (In a secure database, this is available only for users with the "Manage dashboard layouts" permission.)

To open the Dashboard Layout Manager, choose the command from any Synthesis interface that supports dashboard functionality (e.g., Project Planner, Synthesis Explorer, simulation diagrams in BlockSim, etc.). It will display only the layouts for that particular data type.

To reset the view, click the Clear Master Filter icon or right-click, then choose Clear Master Filter.

http://blocksim.reliasoft.com
You can also open the Dashboard Layout Manager from the **Backstage view** (File > Manage Repository > Dashboard Manager). It will display all of the layouts for any data type. If you want to see only the layouts specific to the application you are using, select the check box.

![Check box for Show only layouts specific to the current application](image)

**Show in Viewer**
Use the check boxes in the Show in Viewer column to select which of the predefined layouts will be available to all database users via the **Dashboard Viewer**. If you clear a check box, the layout will not show in the viewer’s drop-down list but will remain in the manager’s list.

<table>
<thead>
<tr>
<th>Name</th>
<th>Show in Viewer</th>
</tr>
</thead>
<tbody>
<tr>
<td>System Dashboard</td>
<td>✔️</td>
</tr>
<tr>
<td>BlockDashboard</td>
<td>✔️</td>
</tr>
<tr>
<td>Crew Dashboard</td>
<td></td>
</tr>
</tbody>
</table>

Use the up/down arrows to change the order of the layouts that are shown in the viewer’s drop-down list.

![Up and down arrows](image)

**Layout Properties**
For all dashboard layouts that are selected to show in the Dashboard Viewer, the name that will be visible in the list is set from the Layout Properties window. To view or change these properties, select a row in the table and click the **Properties** button (or right-click and choose **Properties**).

![Properties button](image)

The description and update history are available to help you manage the layouts; that information is not visible to all database users.
Importing Layouts
It is easy to reuse dashboard layouts that were created in other databases. Click the Import button and then select the database you want to import from. If you are using the Dashboard Layout Manager in the Backstage view, you can import layouts of any type. If you’re using a manager from one of the locations where dashboards are used, you can only import layouts of the current type.

Dashboard Layout Designer
You can use the Dashboard Layout Designer to create or edit each predefined dashboard layout. (In a secure database, this is available only for users with the "Manage dashboard layouts" permissions.)

To access this window, first open the Dashboard Layout Manager and then choose to either create a new layout or edit an existing one.

Separate Layouts for Each Data Type
Each dashboard layout is designed to be used with a specific data type, which determines which fields are available and where the dashboard can be viewed. For information about creating dashboards for each particular type of data, see:

- Project Planner Dashboards
- Synthesis Explorer Dashboards
- Simulation Diagram Dashboards (in the BlockSim/RENO documentation)
- FMEA Dashboards (in the Xfmea/RCM++/RBI documentation)
- Synthesis Data Warehouse (SDW) Dashboards (available in Weibull++/ALTA and RGA)

Configuring a Dashboard Item
This topic demonstrates some of the basic steps for configuring a dashboard item (bar chart, pie chart, gauges, etc.) in the Dashboard Layout Designer. The simple bar chart in this example is based on block-level simulation results from a reliability block diagram in BlockSim. The data source options will be different for other locations where dashboards are available, see Project Planner, Synthesis Explorer, Simulation Diagram Dashboards (BlockSim/RENO), FMEA Dashboards (Xfmea/RCM++/RBI) or SDW Dashboards (Weibull++/ALTA and RGA).
In a secure database, only users with the "Manage dashboard layouts" permissions can create layouts.

**Add the Chart**
Add a chart to the Layout panel by choosing Home > Insert > Chart.

**Define the Chart Data**
1. Select a data source from the drop-down list in the Data Source panel, if applicable.

2. Choose the data field (or fields) that will be displayed in the y-axis of the bar chart, then drag each field into the Values area in the DATA ITEMS panel. For this example, the chart will display total operating cost, cost from preventive maintenance and cost from corrective maintenance.

Note that when different data sources are available, all of the data fields used within a chart must come from the same source.
Chapter 23: Synthesis Dashboards

**Tip:** To replace a data item, drag a new field on top of the current one. To remove a field, drag it anywhere outside of the data item; and to completely clear the DATA ITEMS panel, right-click the chart and select **Remove Data Items.**

3. Use the drop-down list to see which values are available for this data field (e.g., count, sum, average, etc.) and choose one to display in the chart. Note that the same option must be selected for all values in the same chart.

Because we want the total cost from all blocks that meet the given criteria, we use the default **Sum** for this example.

![DATA ITEMS Panel](image)

4. If appropriate, use the **Rename** command to change the name that will be displayed in the chart legend, tooltip, etc.

![Rename Data Item](image)

5. Choose the data field that will be displayed in the x-axis, then drag it to the **Argument** bar.
Filter the Data
To filter the data displayed in the chart, choose Data > Filtering > Edit Filter.

Use the Filter Editor to define the criteria. For this example, we’re using the “Not And” operator to exclude any blocks with a name that contains “Hub.”

Tip: You can use hidden data items to filter based on fields that are not displayed in the chart.

Sort by “Top N”
To configure the chart to show only the top 5, bottom 10, etc., use the Top N command in the Argument data item’s drop-down list.
Chapter 23: Synthesis Dashboards

For this example, we’re showing only the Top 5 blocks, based on total operating cost. The results are displayed from highest to lowest and the order cannot be changed.

Tip: Alternatively, you could use the Sort by command to sort by the argument data item — which is labeled (Value) in this menu — or by any of the value data items. Click the Argument bar to toggle the sort between ascending and descending order.

Other Design Options
Click the Design tab on the ribbon to access other configurable options for this type of chart. For example:

1. To hide or display the caption bar above the chart, choose Show Caption.

   ![Show Caption]

   We will keep it displayed for this example.

2. To change the title in the caption bar to something more meaningful, choose Edit Names.

   ![Edit Names]

   For this example, we will set the Dashboard item name to “Top 5 Blocks by Total Operating Cost” and clear all of the Series fields to make sure the latest data item name (set via the Rename command in the data item’s drop-down list) will always be used in the chart legend and tooltip.
3. To change the y-axis title to a more meaningful name, choose **Y-Axis Settings**.
Available Dashboard Items

The following dashboard items can be added to any layout. You can add the same type of item more than once, if desired. To insert an item, choose **Home > Insert**, then click one of the following options.

<table>
<thead>
<tr>
<th>Pivot</th>
<th>Chart</th>
<th>Gauges</th>
<th>Choropleth Map</th>
<th>Range Filter</th>
<th>Scatter Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Grid</td>
<td>Pies</td>
<td>Cards</td>
<td>Geo Point Map</td>
<td>Text Box</td>
<td>Image</td>
</tr>
</tbody>
</table>

Data Types

There are two types of data that can be used in a dashboard item: measure or dimension.

- **Measure** data is calculated (sum, count, average, etc.). For example, the values on the y-axis of a chart, the size of a slice in a pie or a target value in a card or gauge. Values and targets are forms of measure data.

- **Dimension** data can be sorted but is not calculated. For example, the bars in chart, slices in a pie or text in a grid column. Arguments and series are forms of dimension data.

Data Shaping

You can use the Dimensions and/or Measures bars in the HIDDEN DATA ITEMS panel when you want to perform data shaping (filtering, sorting or Top N) but do not want the data to be displayed in the dashboard item. Data shaping is available for any dashboard item, except text boxes and images.

- The data fields contained in the **Dimensions** bar can be used in the Filter Editor window to create filter conditions based on their values. Dimensions in this area have the same sorting functionality that is available in the argument, attribute or series DATA ITEMS area.

- The data fields contained in the **Measures** bar can be used in the Sort by submenu and in the Top N Values window for data sorting. Measures in this area have the same calculation functionality that is available in the values and target DATA ITEMS area.
Configuring a Drill Down

Drill down can be enabled for the following dashboard items:

- Grids: Specify two or more columns
- Charts and pies: Specify two or more arguments and/or series
- Gauges: Specify two or more series
- Cards: Specify two or more series

Configuring a Drill Down Sequence

1. In the Dashboard Layout Designer window, select the chart or grid you want to drill down.

2. Drag the additional data fields into the Arguments area in the appropriate order for the desired drill down sequence.

For example, you can use the following sequence to configure a pie chart in a Synthesis Explorer dashboard to first show analyses by application source, then drill down to analysis type.

3. Choose Data > Filtering > Drill Down. This command is a toggle; choose the command again to disable the drill down.

When any user views this layout in the Dashboard Viewer, he/she will be able to double-click inside the chart to drill down, and use the arrow (↑) to drill back up. (See Viewing Drill Downs.)

Tip: To make it easy to identify a drill down in the Dashboard Viewer, display the dashboard item’s caption bar (Design > Common > Show Caption).

Filtering

Using the Filter Editor

You can use the Filter Editor to incorporate filters into dashboard items that contain dimension data. Arguments and series are forms of dimension data.
This type of filtering only applies to the dashboard item you have selected. To filter the data across the entire dashboard, see Configuring a Master Filter.

**Dimension Data Locations**
Dimension data can be used in any or all of the following areas:

- Dimension bar in the HIDDEN DATA ITEMS panel.
- Dimension, argument and/or series bars in the DATA ITEMS panel.

An easy way to determine if a data field is a dimension, argument or series, is to look for the sort arrow to the left of the data field name.

**Configuring a Filter**

1. In the Dashboard Layout Designer window, select a dashboard item, then choose Data > Filtering > Edit Filter. This command is also available in the shortcut menu when you right-click the dashboard item.

2. In the Filter Editor window, define the criteria. The dashboard uses the same Edit Filter functionality that is built in to other Synthesis utilities (e.g., Resource Manager, Synthesis Explorer, etc.). (See Finding and Filtering Records.)

In the following example, a chart was created for data that was extracted from XFRACAS into the Synthesis Data Warehouse (SDW) in Weibull++.
Because we are interested in only the chandelier parts (not the whole unit) and data from 2010 and later, we can apply the following filter to remove the unwanted data:

**Configuring a Master Filter**

A master filter can be used to filter data across the entire dashboard. Grids, pies, charts, gauges, cards and maps dashboard items can be used as master filters.

There are two types of master filters that can be configured:

- **A Single filter** allows you to select one item at a time. You will not be able to clear the filter, only select a different item.
A Multiple filter allows you to select one or more items at a time. You can also clear the filter to view all items at any time. This is the most flexible option.

For example, suppose your layout contains a grid, a chart and a pie, and the grid is configured as the multiple master filter. When you select items in the grid, only the data for those items will display in the chart and pie.

Configuring a Master Filter
In the Dashboard Layout Designer window, select the dashboard item, then enable the master filtering by choosing Data > Interactivity > [Single Master Filter/Multiple Master Filter]. This command is a toggle; choose the command again to disable it.

When any user views this layout in the Dashboard Viewer, he/she can use the filter to view only the data of interest. (See Using Master Filters.)

Note that you can prevent a specific dashboard item from being affected by master filters, by selecting it in the Layout panel and then choosing Data > Interactivity settings > Ignore Master Filters. This command is a toggle; choose the command again to disable it.

Tip: To make it easy to identify that a dashboard item is configured for filtering in the Dashboard Viewer, display the item's caption bar (Design > Common > Show Caption).
Chapter 24: Synthesis Data Warehouse

Available in Weibull++, ALTA and RGA, the Synthesis Data Warehouse (formerly called “Reliability Data Warehouse”) enables you to access data from an XFRACAS incident tracking system for the purpose of life data analysis (in Weibull++/ALTA) or repairable system/reliability growth analysis (in RGA). You can also set up custom connections to obtain reliability-related data from external data sources (including Access, Oracle and SQL Server). You can also get data directly from your own custom reports created in ReliaSoft's XFRACAS.

You can then transfer the data to an analysis folio in Weibull++, ALTA or RGA, or use the flexible Synthesis Dashboard utility to explore and present the data in a variety of graphical charts and grids. (See Transferring from the SDW to an Analysis Folio or SDW Dashboards.) In addition, if a Synthesis Enterprise Portal has been implemented for an enterprise database, users can also access SDW dashboards from any web-enabled device.

To open the SDW in Weibull++, ALTA or RGA, choose Home > Synthesis > Synthesis Data Warehouse.

Managing Data Sources

The available data sources are listed in the data source manager on the left side of the window. They may include:

- Static data collections that were extracted from XFRACAS at a particular point in time (and will not change if incidents are later added or updated). These can be either Weibull++/ALTA data or RGA data. (See Extracting Data from XFRACAS.)

- Custom connections that have a live link to a specified external database or to a predefined report created in XFRACAS. (See Custom Connections in the SDW.)

- Static data collections that were extracted from a custom connection at a particular point in time (and will not change if the original data source changes). (See Import to a Static Data Collection.)

If you are working with a long list of available data sources, this panel can utilize the same categories, identifiers and item filters that are available in many other locations throughout Synthesis desktop applications.

To create, delete, rename or edit the properties for these data sources, use the Manage Data Sources commands, or right-click inside the panel.
The Properties window allows you to enter identifiers for each data source, and to view its history.

**Built-in Find/Filter, Configuration and Grouping Tools**

Double-click any data source to display the data in a grid on the right side of the window. The SDW offers the same filter, column configuration and grouping tools that are built in to other Synthesis utilities that use a similar grid (e.g., the Synthesis Explorer, Actions Explorer, etc.). For details about how to use each feature, see:

- **Finding and Filtering Records**
- **Configuring Columns**
- **Grouping Panel**

**Building the Data Set**

The "Include in Analysis?" column shows whether each row will be included in the data set when it is transferred to Weibull++, ALTA or RGA, or viewed in a dashboard.

- **Include**: Data points that will be included in the data set are shown in green.
- **Invalid**: In XFRACAS data collections, incidents with a State Time of less than 0 are automatically set as invalid. These rows are shown in red.
- **Ignore**: In XFRACAS data collections, incidents with a State Time of 0 that are marked as suspensions in the State FS column are automatically set to be ignored. These rows are shown in gray.
- **Exclude**: Incidents that have been manually excluded are shown in blue.

By default, incidents that are marked as Invalid or Ignore will be excluded from the data set. To manually include or exclude specific data points, select the row(s) and choose **Build Data Set > Include** or **Build Data Set > Exclude**.
To view only those rows that are included, choose View > Show Only Included. You can toggle this command off to show all records.

In XFRACAS data collections, you can also select the row and choose Build Data Set > View XFRACAS Incident to open the incident in your web browser. This command is available only if you have permission to view incidents in the current XFRACAS entity (which is set via the XFRACAS administrative interface).

Extracting Data from XFRACAS

When you are working with an enterprise database that contains XFRACAS data, or a standard database that has a connection to external XFRACAS tables, you can use the Synthesis Data Warehouse to extract static data collections. These can be either Weibull++/ALTA data or RGA data, and the collections will not change if incidents are later added or updated in XFRACAS. (Alternatively, if you need a live link to a predefined report that has already been created in XFRACAS, see Connect to XFRACAS Report.)

To extract a static data collection from XFRACAS, first open the SDW in Weibull++, ALTA or RGA and then choose Manage Data Sources > Get XFRACAS Data.

(In a secure database, this is available only to users with the "Create/edit/delete SDW data collections" permission. Additionally, users must have the "Synthesis - Read Data" permissions for the associated XFRACAS tables.)

In the XFRACAS to SDW window, choose an Entity to import from, then select the check box for each part that you want to extract the incident (i.e., failure) data for. If needed, you can use the Auto Filter Row to filter the grid by matching text in one or more columns. (For extremely large data sets, this row will be hidden and a Filter window will be available instead.)
Click **Next**, then specify other settings or fields to import:

- **Time Metric** allows you to choose which metric to use with the data. The options are based on the metrics that your system administrator has enabled for the XFRACAS entity.

- **Incident Detail Fields** allow you to map customized detail fields from the XFRACAS incident to one of the user-defined field columns in the SDW collection. The following field types can be mapped:
  
  - **StringUDF1-3**: Alphanumeric Input Box, Check Box, Company, Contacts, Currency, Date, Numeric Input Box, Users, Yes/No Button, or the Select List, Administrative Controlled field type
  
  - **NumberUDF1-3**: Currency or Numeric Input Box
  
  - **DateUDF1-3**: Date

- In RGA, additional options are available:
  
  - **Include Non-Chargeable** extracts incidents that are marked as either chargeable or non-chargeable in XFRACAS. If you clear the check box, it will extract only chargeable incidents.
  
  - **Only System Down Events** extracts only those incidents that brought the system down.
  
  - **Filter by Date Commissioned** extracts only incidents for systems that were commissioned between the specified dates.

Click **Next**, then enter a name for the data collection and any **Synthesis identifiers** that you want to use.

When you click **OK**, the extraction process will begin. Depending on the amount of data that you are extracting, this may take some time.
You can then use the data collection to transfer data to an analysis folio or explore/present in the dashboard utility. For information about the fields that will be available either in the Build Data Set tab or in the Dashboard Designer, see Data Fields for XFRACAS Data Collections.

Data Fields for XFRACAS Data Collections

The following fields are available for use in dashboard layouts for XFRACAS data collections and for data sets created via the Synthesis API. These are the same columns available in the Build Data Set tab. The fields in custom connections will depend on the data source itself.

- **Address Location**: the location of the owner of the system. This corresponds to the Location field in the XFRACAS contact.
- **Category**: the incident category. This corresponds to the Category field in the XFRACAS incident and, in conjunction with the failure type assigned during part repair/replacement, determines whether the data row is chargeable (i.e., is considered a failure for reliability calculations) or non-chargeable (i.e., is considered a suspension). For more information, see the “Incident Disposition Area” topic in the XFRACAS documentation.
- **Chargeable**: the chargeable code value (where 0 = non-chargeable, 1 = chargeable): equivalent to the Category Chargeable and Category Non-Chargeable lists in the XFRACAS Admin List page. This is to be used to calculate the failure state (StateFS). XFRACAS categories can also be viewed within an XFRACAS incident.
- **CompanyOwner**: the owner of the system. This corresponds to the Company field in the XFRACAS contact.
- **DataID**: the database ID of the row.
- **DataSetID**: the ID of the data set that the row belongs to. This is useful if you are viewing multiple data sets at the same time.
- **DateUDF1-3**: user-defined fields for dates. You can choose up to 3 detail fields in XFRACAS incidents to import to these columns.
- **ExtractedBy, ExtractedDate and ExtractedName**: identify the user who extracted the data from XFRACAS, the date of extraction and the name of the SDW data collection.
- **FailureMode**: the failure mode associated with the incident. This is chosen or created in the Failure Mode field in the XFRACAS incident.
- **IncidentAction**: the action taken to address the incident (whether a part was removed or installed). This is not related to XFRACAS actions. In XFRACAS data sets, repaired and...
replaced parts will be represented using two rows of data—one will be for removing the part, and one for installing it.

- **IncidentEntityDisplayID**: the incident number assigned by XFRACAS, which includes the prefix for the entity that it is associated with (e.g., E1-201).
- **IncidentID**: the database ID of the incident.
- **IncidentOccurrenceDate**: the date when the incident happened. This corresponds to the **Occurrence Date** field in the XFRACAS incident.
- **IncidentRepairDate**: the date that part repair or replacement was completed. This corresponds to the **Completed Date** field that applies to the XFRACAS incident resolution.
- **IncidentResolution**: notes regarding the resolution of the incident. This corresponds to the **Incident Resolution** field in the XFRACAS incident.
- **IsLRU**: indicates whether the item is a line replaceable unit (LRU). This does not correspond to an XFRACAS field; it can be used when creating data sets via the Synthesis API.
- **LastInspectedTime**: the last inspected time. For exporting XFRACAS data sets to Weibull++, this is equal to the state time for the data row. For exporting XFRACAS data sets to RGA, it is the amount of time the system has accrued at the last reported incident.
- **NumberInState**: equivalent to the Number in State column in a Weibull++ life data folio for grouped data. In data sets from XFRACAS, this value will always be 1.
- **NumberUDF1-3**: user-defined fields for numbers. You can choose up to 3 detail fields in XFRACAS incidents to import to these columns.
- **ParentPartID, ParentPartName, ParentPartNumber** and **ParentPartVersion**: identifiers for the "parent" of the part that the incident pertains to. If the part doesn't have a parent (i.e., it is a top level part), this information will be identical to the information for the part itself.
- **PartHID** and **PartID**: the part’s hierarchy identification number and database identification number. In XFRACAS, these are assigned by the system and shown in the HID and Part ID fields that are displayed for the generic part on the Template page.
- **PartName, PartNumber** and **PartVersion**: identifiers for the part that the incident pertains to. In XFRACAS, this information is specified for the generic part, and serialized parts based on the generic part will use the same information.
• **PartOrder**: the order in which the part was replaced. This corresponds to the order in the repair/replace table in the XFRACAS incident.

• **PartSerialHID, PartSerialMfgCode and PartSerialNumber**: relevant only if the incident was assigned to a part in a serialized system. They represent the part’s serial hierarchy identification number, manufacturing code and serial number. In XFRACAS, the PartSerialHID is assigned by the system and shown in the Serial HID field that is displayed for the serialized part on the Serialized page.

• **ReportType**: how the incident was reported. This corresponds to the type chosen in the Report Type field in the XFRACAS incident.

• **RootCause**: the root cause of the failure mode. This is chosen or created in the Root Cause field in the XFRACAS incident.

• **StateFS**: This allows the user to understand if a data row is considered a failure (F) or a suspension (S) for the purposes of reliability calculations. In XFRACAS data sets, this is based on the incident category assigned in the XFRACAS incident, in conjunction with the failure type assigned during part repair/replacement. For more information, see the “Incident Disposition Area” topic in the XFRACAS documentation.

• **StateTime**: the amount of time accrued on the part. This is based on the run hours calculated by XFRACAS.

• **StateTimeRestore**: the amount of time required for the repair. This corresponds to the Repair Duration field in the XFRACAS incident.

• **StringUDF1-3**: user-defined fields for strings. You can choose up to 3 detail fields in XFRACAS incidents to import to these columns.

• **TimeMetric**: the time metric to use for the data. The options are based on the metrics that have been enabled for the XFRACAS entity.

• **TopLevelCommissionDate**: the commission date of the top level part in the system. This corresponds to the commission date of the associated CSI in XFRACAS.

• **TopLevelPartID, TopLevelPartName, TopLevelPartNumber and TopLevelPartVersion**: identifiers for the top level part in the system that the incident pertains to.

• **TopLevelSerialHID and TopLevelSerialNumber**: relevant only if the incident was assigned to a part in a serialized system. They represent the serial hierarchy identification number and serial number of the top level part in the serialized system. This information is used by RGA and Weibull++ to distinguish the system in which the failure occurred.
Transferring from the SDW to an Analysis Folio

Follow the steps below to transfer a data set from the Synthesis Data Warehouse (SDW) to a Weibull++, ALTA or RGA analysis folio.

1. In Weibull++, ALTA or RGA, choose Home > Synthesis > Synthesis Data Warehouse.

2. In the SDW, double-click the data you want to transfer to an analysis folio.

3. In the data table, use the Include in Analysis? column to mark any data points that need to be excluded from the transfer. You can double-click the cell to toggle the options, or select the row and choose Build Data Set > Include or Exclude.

In data collections imported from XFRACAS:

- Incidents with StateTime = 0 and StateFS = S (suspension) are automatically marked Ignore.
- Incidents with StateTime < 0 are automatically marked Invalid.

4. Choose Transfer > Transfer to New Folio.
Follow the on-screen prompts to select the data type and map the SDW fields to columns in the new analysis folio.

**Tips for Mapping the Columns**

- **State F or S** (in Weibull++/ALTA) indicates whether a data point represents a failure (F) or suspension (S). If the data source field does not use the F and S codes, use the Define Values as Failures/Suspension area to specify which value(s) represents each state.

- **Event** (in RGA) indicates whether the data point represents a failure (F) that will be transferred for analysis, or some other event that will not be analyzed as a failure. When a data point is marked as a suspension (S) for transfer to RGA, it will be considered only if it affects the recorded system end time. For example, if the System End Time column indicates that the system was last inspected at 1,000 hours but there is a suspension for that system at 1,100 hours, the later time will be used in the folio.

- Time and quantity columns, such as **State End Time** and **Number in State**, can only be mapped to fields with a numeric data type (e.g., number, currency, etc.).

- **Classification** and **Mode** columns (in RGA) can be mapped to any SDW user-defined field that contains the data. (See Extracting Data from XFRACAS.)
• **Subset ID** columns (in Weibull++/ALTA) or **Comment** columns (in RGA) allow you to choose multiple SDW fields to display in the same folio column. The data from the fields will be concatenated and separated by dashes (e.g., "Report Type – Category"). Use the check boxes to select the fields and then use the arrows to specify the order.

![Set Subset ID Column 1](image)

### SDW Dashboards

This topic describes how to use the **Synthesis Dashboard utility** for exploring and presenting data from the **Synthesis Data Warehouse**. If a **Synthesis Enterprise Portal** has been implemented for an enterprise database, users can also access SDW dashboards from any web-enabled device.

For static data collections, a variety of dashboard layouts can be predefined. For custom connections, there can be only one layout for each connection.

1. In Weibull++, ALTA or RGA, choose **Home > Synthesis > Synthesis Data Warehouse**.

2. Double-click the static data collection or custom connection that contains, or links to, the data you want to view in the dashboard.

3. On the Build Data Set tab, select which rows to include or exclude. (See **Building the Data Set**.)

4. If an appropriate dashboard layout has already been predefined, switch to the Dashboard Viewer tab or choose **Dashboard > Dashboard Viewer**. If multiple layouts are available, use the drop-down list at the top of the viewer to choose what to display.

5. If you need to create a new layout, choose **Dashboard > Dashboard Manager** (for a static data collection) or **Dashboard Designer** (for a custom connection).
(In a secure database, the Dashboard Layout Manager and the Dashboard Layout Designer are available only for users with the “Manage dashboard layouts” permission.)

For information on the data fields available for use in dashboard layouts for SDW data collections, see Data Fields for XFRACAS Data Collections.

Custom Connections in the SDW

The Custom Connections feature in the Synthesis Data Warehouse allows you to create a live link to an external data source (Access, Oracle or SQL Server). This enables you to get data from your own custom and third-party databases for transferring to an analysis folio in Weibull++, ALTA or RGA, or for viewing in the SDW dashboards.

You can also get data directly from your own custom reports created in XFRACAS.

A custom connection data source always shows the latest information from the original database or report and you can only create one dashboard layout per connection. You can also use these connections to import data into a static Weibull++/ALTA or RGA data collection, if desired.

Connect to an External Database

To create a live link to an external database:

1. Choose Manage Data Sources > Add Custom Connection > To External Database.

2. In the Add Custom Connection window:
   a. Enter the Display Name that will identify this custom connection in the SDW data source list.
   b. Enter the connection settings for a Microsoft SQL Server, Oracle or Access database. (See Connection Issues below for more information about the Use impersonation option for SQL Server.)
Chapter 24: Synthesis Data Warehouse

c. After you have specified the database, the Table Name field shows a list of the available tables. Select the main one that contains the data you want to use in the SDW.

d. If you want to create aliases for column names, build a query that combines data from multiple tables or enter your own SQL, select the Open Query Editor/Builder check box.

e. If you want to create the dashboard layout for this data source immediately after defining the connection/query, select the Open Dashboard Designer check box.

f. Click OK to proceed.

3. If you selected to customize the query, you can use the Query Editor to type or paste your own query, or select a stored procedure. If you need further tools, click the Run Query Builder button. The Query Builder can serve three purposes:

a. The bottom-center panel shows the fields that will be included in the data set. If desired, you can use the Alias column to change the names that will be displayed in the SDW grid and dashboard layouts.

b. If the tables are linked by foreign keys, you can use the tool to build a query that combines fields from multiple tables.

c. You can also enter your own SQL in this tool; select the Allow SQL Editing check box and type or paste your own query.

When you are finished in the Query Builder, click OK to return to the Query Editor, where you can click Finish to save your changes.

4. If you selected to open the Dashboard Designer, you can use it to create a single dashboard layout for this data source.

If you want to change the query or create/modify the dashboard layout at a later time, select the custom connection in the data source manager and choose Dashboard > Dashboard Designer.

From within the Dashboard Designer window, choose Home > Query > Edit to customize the query.
Connection Issues
There will be a "connection failed" message if the database is not found at the specified name/location or if you don’t have permission to access it.

If your organization has implemented a Synthesis Enterprise Portal (SEP) website, the administrator may need to take additional steps to make the dashboards visible to all users via the SEP website. For details, consult the print-ready implementation guide (*.pdf).

- **Oracle** - the password is stored with the custom connection; therefore, both the desktop applications and SEP website will attempt to connect in the same way for all users.

- **SQL Server** - the Use impersonation option in the custom connection allows you to enter a login for a one-time extraction to an SDW data collection, but this login is not saved in SDW.

  For subsequent attempts, the desktop applications will connect with the current user’s Windows login, whereas the SEP website will use the login that the website uses to connect with the Synthesis repository (if the Synthesis repository is SQL Server) or with the IIS "application pool identity" (if the Synthesis repository is Oracle).

- **Access** - the SDW can only connect with databases that are not password protected and must have access to the folder where the database is stored. It is recommended to use the UNC pathname (e.g., \servername\foldername rather than P:\foldername) when you create the custom connection.

  The desktop applications will attempt to access the file with the current user’s Windows login, whereas the SEP website can only access files stored directly on the web server or in a network folder that can be accessed by the website’s IIS "application pool identity."

  **Tip:** For Access databases with the *.accdb file type, the dashboard can only be displayed if the database was created with the same version of Microsoft Office (32-bit vs. 64-bit) that is installed on each individual user’s computer (for Synthesis desktop applications) or on the web server (for SEP).

  To ensure that the dashboard will display regardless of which version of Microsoft Office is installed, use the *.mdb file type instead of *.accdb.

Connect to XFRACAS Report
Creating a custom connection to a predefined XFRACAS report enables you to use the SDW to view any type of XFRACAS data (not just data collections extracted for life data or repairable systems analysis). If a Synthesis Enterprise Portal has been implemented for an enterprise...
database, users can also access the dashboards created for these reports from any web-enabled device.

**Tip:** For information about creating SDW reports in XFRACAS, see the "Report Builder" topic in the XFRACAS documentation.

To create a live link to an SDW report that has already been created in XFRACAS:

1. Choose **Manage Data Sources > Add Custom Connection > To XFRACAS Report**.

2. In the Select Report window, select any of the XFRACAS SDW reports that have been predefined in the database.

3. Click **OK** to load the data.

**Import to a Static Data Collection**

In the **Synthesis Data Warehouse**, a **custom connection** provides a live link to an external database or XFRACAS report, while a static data collection stores Weibull++/ALTA or RGA data that was extracted at a particular point in time.

A static data collection can contain **data extracted directly from XFRACAS**. If desired, you can also create a static Weibull++/ALTA or RGA data collection by importing data from a custom connection. To do this:

1. Right-click the custom connection in the data source manager and choose **Import**.

2. In the Import Data from Custom Connection window:
   a. The **Map Data Source Fields to Columns** section specifies which field from the custom connection will be mapped to a column that’s available in a Weibull++/ALTA or RGA data collection.
   b. The **Define Values as Failures/Suspensions** section displays all of the unique values from the field that is currently mapped to the State FS column. Specify whether each value should be considered a failure or a suspension.
   c. The Preview tab allows you to see what the data collection will look like based on your selections.

3. Click **OK** to create the static data collection.
Chapter 25: Synthesis Enterprise Portal

If your organization chooses to implement a web-based Synthesis Enterprise Portal (SEP) for an enterprise database, the entire team – including managers and colleagues who don’t have Synthesis desktop applications installed – will have the opportunity to access key analysis and project management details from any web-enabled device.

In Version 11, the website has a completely redesigned interface with more at-a-glance summaries and better usability on mobile devices.

SEP Home

Completely redesigned in Version 11, the personalized SEP home page provides an intuitive, at-a-glance overview of the information you’re tracking via the website, such as actions, recent messages, reports, metrics and more.

For example, this panel shows the status of the gates and actions for the project plan that is currently active for you in SEP. Use the drop-down list to choose a different project or click to see the full project plan.

You can choose which panels are displayed in your own home page, and also change the order (see Customizing the SEP Home Page).
Chapter 25: Synthesis Enterprise Portal

Project Plans
The SEP website shows a streamlined view of the project plan for each project you have permission to view. Project plans are created and edited via the Synthesis desktop applications (except MPC) and the website always displays the most recent information from the plan.

![Project Plan Table](image)

New in Version 11, the "My Projects" feature makes it easy to access the projects that you frequently need to view in SEP (see My Projects in SEP).

Actions and Portal Messages
The SEP website allows you to create, view and edit the same actions and portal messages that are visible to you from the desktop applications (see Portal Messages and Managing Actions in SEP).

Redesigned in Version 11, the web interfaces now offer better display from mobile devices, and more capabilities (including links/attachments).

Project and Analysis Summaries
The SEP website shows a summary from each analysis project you have permission to view. This may include:

- The overall status of the project plan, and all of the actions (from FMEAs, the project plan or standalone) that are being tracked for the project.
- The KPIs (metric resources) that have been defined for the project.
- The analysis summaries and reports that have been published to SEP from Weibull++/ALTA, BlockSim/RENO, RGA or Lambda Predict (see Publishing to SEP).
- All of the files and website resources that have been linked or attached to the project.
**System Hierarchies and FMEAs**

The SEP website shows the system hierarchies and FMEAs created in Xfmea/RCM++/RBI. The website always displays the most recent information from the project.

You can also access any generated reports that have been published to the website in Word, Excel, PDF or HTML format (see Save/Publish Reports in the Xfmea/RCM++/RBI documentation).

![Hierarchy View](image1)

### Dashboards & Reports

Redesigned in Version 11, the "Watch This Report" feature makes it easier to manage the specific dashboards and reports you want to be able to access quickly via the SEP website. This includes:

- A wide variety of graphical dashboards based on predefined layouts for different types of data (project plans, Synthesis Explorer, simulation diagram results, FMEAs or Synthesis Data Warehouse).

- A flexible, web-based "spreadsheet viewer" and "document viewer" for Synthesis Workbook reports that have been published to SEP.

For details, see Dashboards & Reports in SEP.

**Metrics (Key Performance Indicators)**

The SEP website shows all of the KPIs (metric resources) that have been created in desktop applications for the projects you have permission to view – no publishing required.

Redesigned in Version 11, the metrics are now easier to scan "at-a-glance" to help you monitor performance and support decision making.
Synthesis Explorer and Synthesis Data Warehouse

The SEP website shows all of the Synthesis Explorer or Synthesis Data Warehouse (SDW) dashboards that have been predefined in the desktop applications.

- **Synthesis Explorer dashboards** provide a flexible way to explore all the different analyses that are stored in the Synthesis repository (e.g., application source, analysis type, created by, last update, etc.).

- **SDW dashboards** present charts and results from any of the data collections or custom connections that have been created in Weibull++/ALTA or RGA. This can include data extracted from ReliaSoft's XFRACAS or from external databases and systems (CMMS, EAM, etc.).

XFRACAS

ReliaSoft's XFRACAS is a highly configurable web-based failure reporting, analysis and corrective action system (FRACAS) with integrated capabilities for part tracking, root cause analysis and team-based problem resolution.

If your organization implements both the SEP and XFRACAS websites for the same enterprise repository, the SEP can include links to the XFRACAS reports, charts, actions and incidents of particular interest to each user (see SEP and XFRACAS).

How to Implement the SEP

This topic provides a general overview of the steps required to implement a web-based Synthesis Enterprise Portal for your organization.

When you are ready to configure a website, the print-ready implementation guide (*.pdf) provides more detailed instructions for each step.
Establish the Database and Web Server(s)

The SEP is a web-based system based on the .NET Framework and is designed to be n-tier, scalable, distributable, robust and able to be deployed across multiple servers or on a single computer.

If you plan to host the database and website on the same server, you will need:

- Windows 2008 R2 or Windows 2012 (Windows 2003 is not supported)
- .NET 4.0
- IIS with support for serving ASP.NET
- SQL Server 2008 or newer OR Oracle 10g or newer (32-bit and 64-bit versions of all, full version only)

Install the Website and Connect to a Synthesis Repository

Once you have established the database and web server(s), a system administrator will need to:

1. Run the Synthesis Enterprise Portal setup to create the website.
2. Run the Product Activation tool to activate your SEP license.
3. Run the Synthesis Admin tool to either create a new Synthesis repository or connect to an existing one. You can also use this utility to create Synthesis Platform user accounts if desired.

Remember that ReliaSoft's XFRACAS, Synthesis desktop applications and the SEP website are all designed to connect with the same data repository. If you already have a database established, you can use the admin tool to integrate it with the SEP.

Set Up Synthesis Platform User Accounts and Permissions

Once the Synthesis repository has been created, you can use the Synthesis Admin tool or any of the desktop applications to create Synthesis Platform user accounts and set access permissions. You must create an account for anyone who will be able to edit or view data in the Synthesis desktop applications or SEP website. (User accounts for the XFRACAS website are managed separately.)

If your organization uses Microsoft Active Directory, you can save time by importing user information from the directory to create the user accounts.
Assign SEP Access to Users
Once the Synthesis Platform user accounts have been created (via desktop application or the Admin tool), you can use the SEP website to specify which of the database users will have access to the web portal.

Click the SEP Admin link in the top-right corner of the website and then use the Select SEP Users section to specify which user accounts will have website access.

The counters above the user table identify how many more SEP users are allowed under your current license.

Enable Publish to Synthesis Enterprise Portal
Some SEP-related features in Synthesis desktop applications (e.g., the ability to publish analysis summaries, workbooks, reports, etc.) will be visible only if the Enable publish to Synthesis Enterprise Portal option is set to "Yes" for the database.

This can be set from the SEP Admin page in the website or from the Repository Settings window in any of the desktop applications.

Configure Custom Content for Home
The optional "Custom Content" area in the SEP home page enables your organization to integrate a banner or other custom content into the site, if desired. This can be configured from the SEP Admin page in the website.
The SEPDefault.htm file is installed in the CustomContent folder under the root directory for the SEP website. You can choose to edit this file on the web server or replace it with a URL to another web page.

**Configure 'Custom Content' for the home page:**

- **Visible:** [ ]
- **Height in pixels:** 100

**Caption:** Title of the Panel in the Home Page

- Use SEPDefault.htm on the application web server
- Use a page from another website (HTTP only)
  
  http://www.mysite.com/banner_page.htm

**Note:** If the content of the page is taller than the specified **height in pixels**, users with IOS devices will not be able to scroll.

### Configure URLs for Links to Actions in SEP

When an SEP website is implemented for a Synthesis repository, the action alert e-mails and portal messages generated by any of the Synthesis applications can include links to view the action details in SEP. The applications build the links based on the settings specified on the SEP Admin page in the website. If an administrator has not specified an IIS prefix, the action alerts will not include links to SEP.

- **SEP Server - IIS Prefix:** enter the server name and folder for the website that you see in the browser’s address bar (e.g., servername/SEP).

- **Website Uses SSL (https for URLs):** select **Yes** if the web server has been configured with a Secure Socket Layer (SSL) certificate for the SEP website and the URLs need to start with https rather than http.

If these settings do not match your website configuration, the links attached to the action alerts will give an error message when users attempt to open the page in a web browser (e.g., "File or directory not found," "Access forbidden" or "This page can’t be displayed").
Configure Links Between XFRACAS and SEP
If your organization implements both the SEP and XFRACAS websites for the same enterprise repository, you can use the Admin Preferences page in XFRACAS (Admin > Configure > Preferences) to enable links between the two websites.

- **SEP → XFRACAS:**
  - Specify the **XFRACAS Server - IIS Prefix** (e.g., servername/XFRACAS)
  - **XFRACAS → SEP:**
    - Specify the **Synthesis Enterprise Portal Server - IIS Prefix** (e.g., servername/SEP)
    - Set **Synthesis - Display Synthesis Enterprise Portal (SEP) Command** to True

Distribute SEP Website Link to All Users
Once the web portal has been implemented, users can access the site with any web browser that supports the following doctype. If the site is private (e.g., http://InternalServer/SEP), the system administrator may need to provide users with instructions for how to access the website on the internal network from their mobile devices (e.g., via VPN or some other method).

```xml
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
```

Customizing the SEP Home Page
The personalized SEP home page provides an intuitive, at-a-glance overview of the information you're tracking via the website.

Custom Content
The optional "Custom Content" area enables your organization to integrate a banner or other custom content into the site if desired. This can be configured on the SEP Admin page by any user with "administrative" permissions in the repository (see **How to Implement the SEP**).

If the custom content is enabled for a repository, the same panel will be displayed at the top of the home page for all SEP users.

Home Page Panels
For the rest of the home page panels, each user can choose which panels are displayed, and also change the order.
To modify your personalized home page, click **Edit Home Layout** in the top-right corner of the page.

When the page is in the edit mode, the panels will have a yellow background color and a (+) or (-) icon will appear in each title bar:

- Use the title bar to drag and drop a panel into a different position on the page.
- Use the icon to hide (-) or show (+) the panel.

To save your preferences and leave the edit mode, click **Save Layout**.

**Tip:** If you click the **Restore Defaults** button on the User Preferences page, your personalized home page layout will be reset to the default.

### My Projects in SEP

New in Version 11, the "My Projects" feature makes it easy to access the projects that you frequently need to view in the Synthesis Enterprise Portal (SEP) website.

For any SEP page that shows data from a particular project (e.g., project plan, project summary or any of the analysis summaries), the **Change Project** button in the top-right corner allows you to view that same type of data from another project.

The first popup provides quick access to the projects that you have personally selected for quick access in SEP.
Chapter 25: Synthesis Enterprise Portal

Click **Select Projects** to modify this list or view a project that's not already in the list.

The right side shows your list of "My Projects" (i.e., the short list of projects that will appear first whenever you click **Change Project**).

The left side shows all the projects in the database that you have permission to view. You can apply any of the project filters that were created in Synthesis desktop applications, or use the **Find** box to filter by specific text in the project name.

**Add to My Projects**

**View Now** (i.e., view the project without adding it to your list)

**Remove from My Projects**

Indicates that the project is already in your list.
Tip: If you want to have quick access to the same set of projects while working in the Synthesis desktop applications, you can create a project filter that contains the same list. Select to filter based on Selected projects in the Project Filter window.

Managing Actions in SEP
If your organization chooses to implement the Synthesis Enterprise Portal (SEP) website for an enterprise repository, the entire team can view the latest project plans and FMEAs from any web-enabled device. This includes the assigned actions that are incorporated into those analyses, as well as any other standalone actions that are being tracked through the Synthesis Platform.

With major enhancements and usability improvements in Version 11, the options for managing actions in SEP are better than ever.

My Actions Panel in SEP Home
The "My Actions" panel in the SEP home page shows actions that are relevant to you and still require action of some kind (i.e., not started, not completed or need to be reviewed). They are listed in the order of urgency, up to the maximum number that will fit in the panel.

This may include any of the actions that are eligible to be displayed for you on the Actions page of My Portal in Synthesis desktop applications. To specify your preferences for the website, click your name on the right side of the header to open the User Preferences page, and select any of the following options:

Select actions to list on the home page:
- I need to review/approve
- I am responsible for
- I am a team member in
- I am monitoring
- Other actions I created

My Actions Page
The My Actions page displays all of your actions in a flexible table that you can filter, sort and group to meet your needs. It also provides the option to create a new action directly from the website.
Chapter 25: Synthesis Enterprise Portal

Create Action
When you click the Create Action button in the top-right corner of the page, this will add a new action in the project that is currently active for you in the SEP.

If you want to create the action in a different project, click the link in the header, as shown below, to go to the Project Summary page, and then use the Change Project button to select a different project.

Filter, Sort and Group the Table
The table can display all actions that are relevant to you in some way and still require action of some kind, including actions that did not fit in your home page. You can filter, sort and group the table on-the-fly to display the actions that are of interest at any given time. These settings will be reset to the defaults when you navigate away from the page.

- **Relevance** - the check boxes at the top of the page provide a quick way to filter the table based on how the actions are relevant to you. This is independent from your settings on the User Preferences page, which only affect the SEP home page.

- **Find Panel** - when you type in the input box, the table will show the actions that contain the text in any of the visible fields, and it will highlight all locations where the matching text occurs.

- **Grouping Panel** - the grouping panel (located under the input box) determines how the actions are grouped in the table. Drag and drop column headings into or out of this panel to change the grouping.
Chapter 25: Synthesis Enterprise Portal

**Column Headings**

- To change the column order, drag and drop the column headings into the desired position.

- When applicable, click the con to sort the property in ascending or descending order.

- When applicable, click the to apply one of the built-in filters (blanks, non-blanks or unique values).

**Actions in a Project Summary**

The Project Summary page provides a list of all the actions that have been assigned within the current project.

To access this page, select **Projects** in the SEP menu and use the **Change Project** button to specify which project summary is currently displayed.
Actions in a Project Plan or FMEA

The website includes full details for any actions that are incorporated into a project plan or FMEA. If you have permission to edit an action in a desktop application, you can perform the same updates via the website.

- To access a project plan, select **Project Plans** in the SEP menu and use the **Change Project** button to specify which project’s plan you want to view. In the project plan, click an action link to view the full details.

- To access an FMEA, click **Projects** in the SEP menu and use the **Change Project** button to specify which project’s system hierarchy and FMEAs you want to view. Then click the **Xfmea/RCM++/RBI** link.

In the system hierarchy, click an action link to view the full details.
Links to SEP from Action Alert E-mails and Portal Messages

The action alert e-mails and portal messages generated by any of the Synthesis applications can include links to view the action details in the SEP. The applications build the links based on the settings specified on the SEP Admin page in the website.

If these links are not working properly for your SEP website, see How to Implement the SEP.

Publishing to SEP

The Synthesis Enterprise Portal website does not display all of the analyses that were performed in Synthesis desktop applications. Instead, your team can decide which analyses to make available via the web, and publish selected analysis summaries and reports.

These features are only available when:

- You are connected to an enterprise database that has an SEP website implemented and the Enable publish to Synthesis Enterprise Portal option is set to "Yes" for the database.
- You have the "Publish to Synthesis Enterprise Portal" permission.

<table>
<thead>
<tr>
<th>Synthesis Application</th>
<th>What can be published</th>
</tr>
</thead>
<tbody>
<tr>
<td>Weibull++/ALTA</td>
<td>• Synthesis Workbooks</td>
</tr>
<tr>
<td></td>
<td>• Life Data analyses</td>
</tr>
<tr>
<td></td>
<td>• Non-Parametric LDA analyses</td>
</tr>
<tr>
<td></td>
<td>• Parametric RDA analyses</td>
</tr>
<tr>
<td></td>
<td>• Life-Stress Data analyses</td>
</tr>
<tr>
<td></td>
<td>• DOE Designs</td>
</tr>
<tr>
<td></td>
<td>• One Way ANOVA</td>
</tr>
<tr>
<td></td>
<td>• Measurement Systems analyses</td>
</tr>
<tr>
<td></td>
<td>• Multiple Linear Regression</td>
</tr>
<tr>
<td>RGA</td>
<td>• Synthesis Workbooks</td>
</tr>
<tr>
<td></td>
<td>• Growth Data analyses</td>
</tr>
</tbody>
</table>
### Chapter 25: Synthesis Enterprise Portal

| BlockSim/RENO          | • Synthesis Workbooks  
|                       | • Analytical RBDs and Fault Trees  
|                       | • Simulation RBDs and Fault Trees (including dashboards)  
|                       | • Phase Diagrams (including dashboards)  
|                       | • Markov Diagrams  
|                       | • RENO Flowcharts  
| Lambda Predict        | • Generated reports published directly to SEP  
|                       | • Stored plot graphics  
| Xfmea, RCM++ and RBI  | • Generated reports saved with the project  
|                       | • *System hierarchy and FMEAs, including dashboards, are also visible on the website — no publishing required*  

**Note:** If you have published analysis summaries and you get a "Link is not properly formatted" message when you open the original analysis (e.g., "Open in Weibull++"), the link may be corrupted or is using old encryption. Republish the analysis to refresh the link.

### Data Sheets or Diagrams

To publish an analysis summary from Weibull++/ALTA, RGA or BlockSim/RENO, open the data sheet or diagram and click **Publish SEP Summary** on the Publishing page of the control panel. (For DOE design folios, the "Data" tab with analyzed response data must be selected.)

![Publish SEP Summary](http://blocksim.reliasoft.com)
For data sheets, this displays a preview of the spreadsheet summary. Click **Publish SEP Summary** again to complete the process.

After publishing, the panel displays "Synchronized" if the web version reflects the latest results from the analysis. If the analysis has been modified (e.g., if more data has been added, an analysis setting has changed, etc.), it displays "Out of Sync" and you will need to recalculate and republish to update the website.

To remove the summary from the website, click **Remove SEP Summary**.

**Synthesis Workbooks**

To publish a **Synthesis Workbook** from Weibull++/ALTA, RGA or BlockSim/RENO, open the module in the workbook that you want to share (spreadsheet or word processing document), then click **Home > SEP > Publish Report**.

The status bar indicates that the spreadsheet or document is visible via the SEP website, and when the web version was last updated.

If you subsequently make a change in the desktop application, you will need to republish to update the website.

If you want to remove the report from the website, open the module and click **Home > SEP > Remove Report**.

**Prediction Reports and Plots**

To publish a report or plot from Lambda Predict, select any standard item or block in the prediction folio and choose **Prediction Tools > Share > Publish SEP Summary** (or click the icon on the **Publishing** tab of the Properties panel).

Then use the Select Report window to build the report and click **OK**. (See **Lambda Predict Reports** in the Lambda Predict documentation.)
You can publish multiple reports from the same prediction folio, but only one report for each standard item/block. For example, the following picture shows two reports published from the same folio. If you later republish from the same standard item/block, the new report will replace what was previously published.

Xfmea/RCM++/RBI Reports
To publish a report generated in Xfmea/RCM++/RBI, use the Reports window to build the document, select at least one of the Save/Publish file formats on the ribbon (Word, Excel, or PDF) and click Generate Report.

To see all of the generated report documents that have been saved with the project (and therefore will be visible via SEP), click Published Reports Manager. You can also use the manager to edit the name and description that will show in the website.

For more information, see Save/Publish Reports in the Xfmea/RCM++/RBI documentation.

Dashboards and Reports in SEP
Dashboards and Synthesis Workbook reports are available throughout the Synthesis Enterprise Portal (SEP) website when you view different types of data.

For example, when you view a particular project plan in the website, you can select to view the latest information from the plan in any of the dashboard layouts that are currently available for that type of data.

Likewise, when you review the Weibull++/ALTA, RGA or BlockSim/RENO analyses for a particular project, you can see any Synthesis Workbook reports (spreadsheets or documents) that were published to the website.
Save, Copy or E-mail the URL
When you view a dashboard or Synthesis Workbook in the SEP website, the link for the web page (URL) includes the identifiers required to open the same report again later if the data/report is still visible in SEP and the user has permission to view the data.

- For dashboards, this will display the latest data from the analysis using the latest version of the predefined layout.
- For Synthesis Workbooks, this will display the latest published version of the report.

You can use the Save URL, Copy URL and E-mail URL links at the top of the web page, or copy/paste the URL from the browser’s address bar.

Watch This Report
Redesigned in Version 11, the "Watch This Report" feature makes it easier to manage the specific dashboards and reports you want to be able to access quickly via the SEP website.

What's Changed? This replaces the "Share" feature that was used in SEP 10. If you upgrade a Version 10 database, any dashboards and reports that were "shared" with you in Version 10 will be "watched" by you in Version 11.

To watch a report, navigate to it in the website and click the Watch button or link, then enter the name and description that will show in your personalized list of "My Dashboards & Reports."
Chapter 25: Synthesis Enterprise Portal

If you have an XFRACAS website that is linked to the SEP, the sites will automatically create a watch in SEP for any charts or reports that you are watching in XFRACAS. If you delete or rename the SEP watch, this will not change the original watch in XFRACAS.

Click Reports in the SEP menu to see the list of dashboards and reports you are currently watching in SEP. You can filter by name/description, project or report type.

![Dashboard List](image)

If you want to change the sort order, first clear all the filters and then click to drag and drop the reports into the desired position.

The first 5 reports will show in your personalized SEP home page (unless you have chosen to hide the "My Dashboards & Reports" panel).

**SEP and XFRACAS**

ReliaSoft's XFRACAS is a highly configurable web-based failure reporting, analysis and corrective action system (FRACAS) with integrated capabilities for part tracking, root cause analysis and team-based problem resolution.

If your organization implements both the SEP and XFRACAS websites for the same enterprise repository, the SEP can include links to XFRACAS records that are of interest to the user.

**Configure Links Between Websites**

In order to enable links between SEP and XFRACAS, a user with administrative permissions in XFRACAS must specify the paths that will be used in URLs for each website. (See How to Implement the SEP.)

When these preferences are set, SEP's menu will include a link to XFRACAS, and XFRACAS's ribbon will include an icon for SEP.
XFRACAS Reports and Charts
The "watch" feature in XFRACAS provides a quick and convenient way to access the XFRACAS reports and charts that you use most often (e.g., incident count by responsible part, all open incidents for a particular system, etc.).

When the websites are linked, these XFRACAS reports and charts will be automatically added to the list of dashboards and reports that you are watching in SEP. If you later decide to modify or delete the duplicate watch in SEP, this will not affect your settings in XFRACAS. (See Dashboards and Reports in SEP.)

XFRACAS Actions
The actions in XFRACAS (called "XFRACAS actions") are managed separately from the actions in Synthesis desktop applications and SEP (called "Synthesis actions"). The SEP always shows the Synthesis actions that are relevant to a particular user and project (see Managing Actions in SEP.)

If you also want to see your XFRACAS actions in SEP, choose to show the "XFRACAS Actions" panel in the SEP home page. (See Customizing the SEP Home Page.)

The SEP panel shows the same XFRACAS actions that you have chosen to display under Uncompleted Actions in your XFRACAS portal. (See XFRACAS Portal in the XFRACAS documentation.)

Tip: You can also choose to show Synthesis actions in your XFRACAS Portal, if desired. Open the My Portal Preferences page in XFRACAS and configure the Display My Open Synthesis Actions option.

XFRACAS Incidents
If you want to see XFRACAS incidents in SEP, choose to show the "XFRACAS Incidents" panel in the SEP home page.

The SEP panel shows the same XFRACAS incidents that you have choose to display under Display My Unclosed Incidents in your XFRACAS Portal.

Quick Links in SEP
The Quick Links feature allows you to create your own personalized list of links within the Synthesis Enterprise Portal (SEP) website. In Version 11, these links are now visible in the SEP menu.
Chapter 25: Synthesis Enterprise Portal

Link to a Page in SEP
To create a link to a page in the SEP website (e.g., for quick access to a particular project summary, FMEA system hierarchy, assigned action, etc.), navigate to the page and then click the Save URL link at the top-right corner of the page. You will be prompted to specify the name that will show in your list of quick links.

Link to an External Website
To create a link to an external website (e.g., a company intranet, document management system, etc.), click the Quick Links heading or icon in the SEP menu to open the My Quick Links page.

Use the Add New Link section to specify the name and URL.

Add New Link

<table>
<thead>
<tr>
<th>Name</th>
<th>Acme Intranet</th>
</tr>
</thead>
<tbody>
<tr>
<td>URL</td>
<td><a href="https://OurIntranet">https://OurIntranet</a></td>
</tr>
</tbody>
</table>

Note: When entering a URL link, this can only be to a web address. It cannot be to a network share path.

Move, Rename or Remove a Link
To move a link, change the name that shows in the menu or remove a link, click the Quick Links heading or icon in the SEP menu to open the My Quick Links page.

In the Manage Current Links section, you can change where the link displays, edit the link name or delete the link. For online links, you can also edit the URL.
SEP User Preferences

The User Preferences page in the Synthesis Enterprise Portal (SEP) allows you to manage your own personal preferences for the website.

Click your name in the top-right corner of the website to open the page.

Change interface language

Use the drop-down list to choose any of the languages that are available for Synthesis desktop applications.

This will update the interface labels, but the data and configurable settings that have been entered by users will remain in the original language. For example, this includes (but is not limited to):

- Names, descriptions, identifiers and remarks that are entered by users
- Action property labels that are configurable within each project
- Published analysis summaries and reports
- System hierarchies and FMEA data
- Etc.
When starting the SEP always load
This setting determines which project will be displayed first for SEP features that show information from a particular project (e.g., project plan, project summary or creating a new action). You can choose:

- The last project used in any Synthesis application
- The last project set/used in the SEP web interface

You can use the Change Project button and "My Projects" feature at any time to change the project that is currently active in SEP.

Select actions to list on the home page
This setting allows you to choose which of the actions that may be relevant to you will be shown in the "My Actions" panel on the home page. (Note that if you’re also using Synthesis desktop applications, your preferences for the Actions page of My Portal will be managed separately.)

- I need to review/approve
  - You are assigned in the Reviewer field.

- I am responsible for
  - You are assigned in the Person Responsible field.

- I am a team member in
  - You belong to the team assigned in the Team field.

- I am monitoring
  - You are assigned in the Action Monitors window, or you have personally subscribed to “watch” the action.

- Other actions I created
  - You are listed in the Created By field and none of the other roles apply.

Receive automated alerts
These are the same options that you can set from the User Login and Contact Information window in a Synthesis desktop application. (See Watches and Alerts.)

Note that alerts via e-mail and SMS text are available only if a valid SMTP server has been defined for the database and your user account has an e-mail address/SMS contact defined. (See Enable Alerts via E-mail or SMS.)
Number of decimals for metrics in SEP

This preference determines how many decimal places will be used in the metric element on SEP web pages. If you are also using Synthesis desktop applications, this may be different than your preference in the Application Setup (File > Application Setup).
End User License Agreement

Click Wrap Agreement at time of product installation

BY INSTALLING THIS SOFTWARE OR BY CLICKING THE “I ACCEPT” BUTTON AND ACCEPTING THIS LICENSE IN ACCORDANCE WITH SOFTWARE INSTALLATION AND LICENSE ACCEPTANCE PROCEDURE YOU AGREE TO THE TERMS OF THIS LICENSE WHICH WILL BIND YOU, THE COMPANY ON WHO’S BEHALF YOU ARE ENTERING INTO THIS LICENSE AGREEMENT, AND ITS EMPLOYEES, AS APPLICABLE.

THIS LICENSE AGREEMENT IS A LEGAL AGREEMENT BETWEEN HBM UNITED KINGDOM LTD A COMPANY INCORPORATED IN UNITED KINGDOM WHOSE REGISTERED NUMBER IS 1589921 AND WHOSE REGISTERED OFFICE IS AT TECHNOLOGY CENTRE, ADVANCED MANUFACTURING PARK, BRUNEL WAY, CATCLIFFE, ROTHERHAM S60 5WG (THE ‘LICENSOR’) AND THE END USER LICENSEE OR ITS REPRESENTATIVE/AGENT AUTHORISED TO BIND THE END USER LICENSEE (‘YOU’).

PLEASE READ THIS CAREFULLY BEFORE USING THE SOFTWARE PRODUCTS

A: BACKGROUND

THIS LICENSE AGREEMENT SHALL BE BETWEEN YOU AND THE LICENSOR REGARDLESS OF WHETHER YOU HAVE PURCHASED THE SOFTWARE PRODUCTS DIRECTLY FROM THE LICENSOR OR AN AUTHORIZED RESELLER AS SET OUT BELOW.

THE LICENSOR APPOINTS EXPERIENCED PROVIDERS OF SOFTWARE RESELLER SERVICES WHO DISTRIBUTE THE SOFTWARE PRODUCTS TO END USERS (‘AUTHORISED RESELLER’).

IF YOU HAVE PURCHASED THE SOFTWARE PRODUCTS AND ANY ASSOCIATED SUPPORT AND MAINTENANCE SERVICES FROM AN AUTHORIZED RESELLER, SUCH PRODUCTS AND SERVICES WILL BE PROVIDED DIRECTLY TO YOU BY THE RELEVANT AUTHORIZED RESELLER AND ALL PAYMENTS SHALL BE MADE TO THE AUTHORIZED RESELLER ON THE AUTHORIZED RESELLER’S TERMS AND PRICES.

IF YOU HAVE PURCHASED THE SOFTWARE PRODUCT AND SUPPORT AND MAINTENANCE SERVICES DIRECTLY FROM THE LICENSOR, SUCH SUPPORT AND MAINTENANCE SERVICES WILL BE DEALT WITH IN A SEPARATE AGREEMENT BETWEEN YOU AND THE LICENSOR AND ALL PAYMENTS WILL BE MADE TO THE LICENSOR AND GOVERNED BY THE LICENSOR’S TERMS OF SALE.

B: PROPERTY OF LICENSOR

THE LICENSOR, OR, WHERE APPLICABLE, THE RELEVANT MEMBER OF THE LICENSOR’S CORPORATE GROUP, IS THE ENTIRE LEGAL AND BENEFICIAL OWNER OF CERTAIN SOFTWARE PRODUCT(S) (‘THE SOFTWARE PRODUCT’) AS SET OUT IN THE QUOTATION OF INFORMATION, WHICH SHALL ALSO INCLUDE YOUR LICENSE KEY, SENT TO YOU BY EMAIL EITHER BY THE LICENSOR OR, IF YOU HAVE PURCHASED THE SOFTWARE PRODUCTS FROM AN AUTHORIZED RESELLER, BY THE AUTHORIZED RESELLER (‘QUOTATION’). THE LICENSOR IS WILLING TO GRANT YOU A LICENSE TO USE THE SOFTWARE PRODUCT ONLY IF YOU ACCEPT ALL THE TERMS AND CONDITIONS SET OUT BELOW.

C: LICENSE TO BE GRANTED

THE LICENSOR IS PROPOSING TO GRANT YOU ONE OF THE FOUR FORMS OF LICENSE IN RESPECT OF THE SOFTWARE PRODUCT. DETAILS OF EACH FORM OF LICENSE ARE SET OUT IN CLAUSES 2.1 AND 3 BELOW. THE FORM OF LICENSE THAT IS PROPOSED TO BE

D: LICENSE ACCEPTANCE PROCEDURE

BY CLICKING ON THE ACCEPTANCE BUTTON WHICH FOLLOWS THIS LICENSE AGREEMENT (MARKED 'DO YOU ACCEPT THESE TERMS AND CONDITIONS?'), YOU INDICATE ACCEPTANCE OF THIS LICENSE AGREEMENT AND THE LIMITED WARRANTY AND LIMITATION OF LIABILITY SET OUT IN THIS LICENSE AGREEMENT. SUCH ACCEPTANCE IS ON YOUR OWN BEHALF, IF YOU ARE AN INDIVIDUAL AND ON BEHALF OF ANY CORPORATE ENTITY WHICH EMPLOYS YOU OR WHICH YOU REPRESENT (‘CORPORATE LICENSEE’) IN ENTERING INTO THIS LICENSE AND YOU WARRANT THAT YOU HAVE THE NECESSARY AUTHORITY TO BIND THE CORPORATE ENTITY IN THIS RESPECT OR THAT THE AUTHORISED REPRESENTATIVES OF THE CORPORATE ENTITY ARE AWARE OF YOUR ACCEPTANCE OF THIS AGREEMENT ON ITS BEHALF. IN THIS LICENSE AGREEMENT, ‘YOU’ REFERS TO THE LICENSEE, ANY SUCH CORPORATE LICENSEE, OR BOTH, AS A COMMON SENSE INTERPRETATION OF THE RELEVANT SECTION DICTATES.

E: LICENSE REJECTION PROCEDURE

IF YOU DO NOT ACCEPT THESE TERMS AND CONDITIONS, YOU SHOULD CLICK ON THE “I DO NOT ACCEPT” BUTTON, DELETE THE SOFTWARE PRODUCTS FROM YOUR COMPUTER AND PROMPTLY (AND IN ANY EVENT, WITHIN 14 DAYS OF RECEIPT) RETURN TO THE RESELLER (A) ANY MEDIA; AND (B) ANY OTHER ITEMS PROVIDED, THAT ARE PART OF THIS PRODUCT.

F: OTHER AGREEMENTS

IF THE LICENSOR HAS EXPRESSLY AGREED WITH YOU IN WRITING THAT YOUR USE OF THE SOFTWARE PRODUCTS IS GOVERNED BY A PRIOR EXECUTED LICENSE AGREEMENT WITH THE LICENSOR, SUCH AGREEMENT SHALL APPLY INSTEAD OF THE FOLLOWING TERMS AND CONDITIONS TO THE EXTENT THAT THEY CONFLICT.

YOU SHOULD PRINT A COPY OF THIS LICENSE AGREEMENT FOR FUTURE REFERENCE.

LICENSE AGREEMENT

1. Ownership of Software Products and Copies

1.1 The Software Products and any printed materials or electronic documentation accompanying the Software Products (‘Documentation’) are copyrighted works of authorship, and are also protected under applicable database laws. The Licensor, or, where applicable, the relevant member of the Licensor’s corporate group, retains ownership of the Software Products and all subsequent copies of the Software Products, regardless of the form in which the copies may exist. This License Agreement is not a sale of the original Software Products or any copies.

2. Commercial License

2.1 In consideration of you agreeing to abide by the terms of this License Agreement and payment of the applicable license fees either to the Licensor or, if you have purchased the Software Products from an Authorised Reseller, to the Authorised Reseller (as specified in the Quotation), the Licensor hereby grants to you a personal, non-exclusive, and (unless expressly agreed otherwise by the Licensor in accordance with
clause 5.1) non-transferable license to use the Software Products and the Documentation on the terms of this License Agreement. The license shall take one of the following forms, (and shall be set out in the Quotation):

(a) **Annual License:**

(i) **Duration** – this License shall continue for a period of 12 months (‘Initial Period’) from the date of delivery of the Quotation (“the Delivery Date”) and, provided that you have paid all applicable renewal fees, from year to year thereafter unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

(ii) **Termination** – you must give the Licensor 90 day’s written notice prior to the anniversary of the Delivery Date, such notice not to expire before such anniversary date.

(b) **Paid Up License:**

(i) **Duration** – this License shall continue for a period of 25 years from the Delivery Date unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

(ii) **Conversion** - this License may be converted to a CDS (this may include CRS and CDRS which are specific variations of CDS and collectively known as CDS) License, upon application to either the Licensor or the Authorised Reseller (if you have purchased the Software Products from an Authorised Reseller), and payment of an additional fee to the Licensor or the Authorised Reseller (as applicable), which shall be additional to the fees paid or payable in respect of any maintenance and support services provided by either the Licensor or the Authorised Reseller (if you have purchased the Software Products from an Authorised Reseller). You may reverse this conversion to the same terms as agreed in the Paid Up License at the anniversary of the conversion by giving the Licensor 90 days written notice prior to the anniversary of the Delivery Date, such notice not to expire before the anniversary of the Delivery Date.

(c) **CDS/CRS/CDRS License:**

(i) **Access** – subject to the terms and conditions of this License Agreement, you may access any of the Software Products in the Quotation at any one time and in any combination up to the number of subscriptions granting you access to the Software Products for simultaneous use by you and purchased by you pursuant to this Agreement (‘Access Credits’). In the event the number of Access Credits reaches the number of Access Credits duly paid for by you (‘Access Limit’), you may add additional Access Credits (or, alternatively, at any time during the Term) which shall be charged in accordance with either the Licensor’s prices or the Authorised Reseller’s prices (if you have purchased the Software Products from an Authorised Reseller). Such increase in Access Credits shall apply to the following 12 month period, unless you give the Licensor or the Authorised Reseller (as applicable) written notice at least 90 days in advance of the expiry of the Initial Period, that you do not wish to sustain such increase in Access Credits. You may opt to reduce the number of Access Credits with 90 days written notice in advance of the 12 month period following from the anniversary of the Delivery Date, provided that the total number of Access Credits does not fall below the minimum threshold set by the Licensor or the Authorised Reseller (as applicable) or below the initial number of Access Credits calculated at the time of conversion of any Paid Up License.

(ii) **Duration** - this License shall continue for the Initial Period and, provided that you have paid for the applicable Access Credits, from year to year thereafter unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

(iii) **Reporting** – in order to serve our customers better, the Licensor needs to be able to understand how its customers use the CDS system. As a condition of your continued access to the system, you are asked to provide to the Licensor on a quarterly basis, the CDS log file. You will be provided with easy-to-follow instructions on how to do this.
Termination – you must give the Licensor 90 days written notice in advance of the expiry of the Initial Period of your intention to discontinue the CDS License, such notice not to expire before the anniversary of the Delivery Date, and you must have submitted all reports required of you in clause 2.1(c)(iii) above. Failure to provide such notice and reports will mean that the license shall automatically continue on the same terms until terminated in accordance with this clause.

2.2 As an end user licensee of the Software Products, you may, subject to the following conditions and any conditions specified in the Quotation:

(a) use and copy the Software Products only for use on any computer system that is detailed in the release notes of the respective Software Product and which is licensed, leased and/or controlled by you (the Corporate Licensee) or any member of your corporate group, which expression includes the Corporate Licensee's majority-owned subsidiaries, any parent company having a majority-owned interest in the Corporate Licensee, and such parent's majority-owned subsidiaries;

(b) load the Software Products into and use it only on computers at the locations specified in the Quotation and which are under your control;

(c) copy the Software Products only for back-up and archival purposes and make up to three copies of the Documentation, provided that the original and each copy is kept in your possession and that your installation and use of the Software Products does not exceed any restrictions contained in the Quotation.

3. Demonstration License

3.1 If the Licensor has provided you with the Software Products free of charge for evaluation purposes, this clause 3 shall apply to your use of the Software Products.

3.2 You may use the Software Product on a computer solely for the purposes of evaluating the Software Product.

3.3 The Software Product is provided to you free of charge and on an “AS IS” basis, without any technical support or warranty of any kind from us including, without limitation, a warranty of satisfactory quality, fitness for purpose and non-infringement.

3.4 This License shall continue for a period of 30 days from the Delivery Date unless terminated in accordance with any provision of clause 10 below or any other applicable clause of this License Agreement or until such License is converted into an Annual License, Paid Up License or CDS License, if earlier.

3.5 As part of the Licensor’s testing and evaluation of the Software Products, you shall share with the Licensor the input and views received and any reports and analysis produced promptly upon receipt of such feedback.

3.6 Clauses 4, 5.1(a), 6.1(b), 6.1(f), 8.1, 8.2, 8.5, 10.1(a) of this License Agreement shall not apply to a Demonstration License.

4. Delivery and Risk

4.1 The Software Products shall consist of one copy of the object code of the Software Products on machine-readable form only, on the disk, dongle or other media on which the Software Product is delivered as described in the Quotation (the “Media”). Risk in the Media shall pass to you on delivery. If any part of the Media shall thereafter be lost, damaged or destroyed, you must contact either the Licensor or the Authorised Reseller from whom you have purchased the Software Products who will arrange for a repair or replacement of such Media at a cost (if any) determined by the Licensor or the Authorised Reseller (as applicable).

5. License Restrictions

5.1 You may not nor permit others to:

(a) transfer the Software Products from one location to another, without the express written consent of the Licensor and provided such transfers do not exceed two in any twelve month period. It will be a condition of the grant of any such consent that the Software Products held on hard drives at the current location must be erased and you must enter into a new license agreement with the Licensor before a
Software Products license key is provided to you. The administration charge (currently US $1,500) will be payable by you in respect of such transfer. This charge is only applicable to end user licensees who do not have a support and maintenance services agreement with the Licensor or Authorised Reseller;

(b) exceed the number of concurrent users specified in the Quotation, if any;

(c) sub-license, sell, assign, rent, pledge, lease, transfer or otherwise dispose of the Software Products, on a temporary or permanent basis, without the prior written consent of the Licensor;

(d) translate, reverse engineer, decompile, disassemble, modify or create derivative works based on the Software Products except as permitted by law;

(e) make copies of the Software Products, in whole or part, except for back-up or archival purposes as permitted in this License Agreement;

(f) use any back-up copy of the Software Products for any purpose other than to replace the original copy in the event that it is destroyed or becomes defective;

(g) copy the Documentation (except as provided by this License Agreement);

(h) adapt, modify, delete or translate the Documentation in any way for any purpose whatsoever;

(i) vary, delete or obscure any notices of proprietary rights or any product identification or restrictions on or in the Software Products.

6. Undertakings

6.1 You undertake:

(a) to ensure that, prior to use of the Software Products by your employees or agents, all such parties are notified of this License and the terms of this License Agreement and that any such use as aforesaid is in accordance with the terms of this License Agreement;

(b) to replace the current version of the Software Product with any updated or upgraded version or new release provided by the Licensor or the Authorised Reseller (if applicable) under the terms of this License Agreement immediately on receipt of such version or release;

(c) to use the Software Products only as described in the Documentation and subject to the restrictions as set out in clause 5 (License Restrictions above);

(d) to reproduce and include the Licensor’s copyright notice (or such other party’s copyright notice as specified on the Software Products) on all and any copies of the Software Products, including any partial copies of the Software Products as permitted to be made under the terms of this License Agreement;

(e) to hold all drawings, specifications, data (including object and source codes), Software Products listings and all other information relating to the Software Products confidential and not at any time, during this License or after its expiry, disclose the same, whether directly or indirectly, to any third party without the Licensor’s consent, and

(f) to effect and maintain adequate security measures to safeguard the Software Product from access or use by any unauthorised person and indemnify the Licensor for losses flowing from your failure to do so.

7. Intellectual Property Rights

7.1 You acknowledge that all intellectual property rights in the Software Product and the Documentation throughout the world belong to the Licensor, that rights in the Software Product are licensed (not sold) to you, and that you have no rights in, or to, the Software Product or the Documentation other than the right to use them in accordance with the terms of this License Agreement.

7.2 You acknowledge that you have no right to have access to the Software Product in source code form or in unlocked coding or with comments.
7.3 The integrity of this Software Product is protected by technical protection measures ("TPM") so that the intellectual property rights, including copyright, in the software of the Licensor are not misappropriated. You must not attempt in any way to remove or circumvent any such TPM, nor to apply, manufacture for sale, hire, import, distribute, sell, nor let, offer, advertise or expose for sale or hire, nor have in your possession for private or commercial purposes, any means whose sole intended purpose is to facilitate the unauthorised removal or circumvention of such TPM.

8. **Limited Warranty**

8.1 Subject to the limitations and exclusions of liability below and providing the Software is used in accordance with the Documentation and on an operating system or computer for which it was designed, the Licensor warrants that (a) the Media on which the Software Products is furnished will be free from material defects under normal use for a period of 90 days from the date of delivery (the "Warranty Period"); and that (b) during the Warranty Period, the Software Product will, when properly used, perform substantially in accordance with the functions described in the Documentation; and (c) that the Documentation correctly describes the operation of the Software Product in all material respects.

8.2 If, within the Warranty Period, you notify the Licensor in writing of any defect or fault in the Software Product in consequence of which it fails to perform substantially in accordance with the Documentation, and such defect or fault does not result from you having amended the Software Product or used it in contravention of the terms of this License Agreement, the Licensor will, at its sole option, i) repair or replace the Software Product, provided that you make available all information that may be necessary to assist the Licensor in resolving the defect or fault, including sufficient information to enable the Licensor to recreate the defect or fault, or ii) terminate this License Agreement immediately by notice in writing to you and the Licensor will refund or if the Software Products have been purchased from an Authorised Reseller will procure that the Authorised Reseller shall refund; any of the fees paid as at the date of termination (less a reasonable sum in respect of your use of the Software Product to the date of termination) on return of the Software Product and all copies thereof. The Licensor’s obligation under this clause 8.2 is subject to your compliance with clause 6.1(b).

8.3 You acknowledge that the Software Product has not been developed to meet your individual requirements and that it is therefore your responsibility to ensure that the facilities and functions of the Software Product as described in the Documentation meet your requirements.

8.4 You acknowledge that the Software Product may not be free of bugs or errors and you agree that the existence of any minor errors shall not constitute a breach of this License Agreement.

8.5 The Licensor shall not be liable under the said warranty above if the Software Product fails to operate in accordance with the said warranty as a result of any modification, variation or addition to the Software Products not performed by the Licensor or caused by any abuse, corruption or incorrect use of the Software Products, including use of the Software Products with equipment or other software which is incompatible.

8.6 All other conditions, warranties or other terms which might have effect or be implied or incorporated into this License Agreement or any collateral contract, whether by statute, common law or otherwise, are hereby excluded, including, without limitation, the implied conditions, warranties or other terms as to satisfactory quality, fitness for purpose or the use of reasonable skill and care.

9. **Exclusion of Liability**

9.1 Nothing in this License Agreement shall limit or exclude the liability of either party for death or personal injury resulting from negligence, for fraud or for fraudulent misrepresentation.

9.2 Subject to clause 9.1, the Licensor shall have no liability for any losses or damages which may be suffered by you (or any person claiming under or through you), whether the same are suffered directly or indirectly or are immediate or consequential, and whether the same arise in contract, tort (including negligence) or otherwise howsoever, which fall within any of the following:

(a) loss of income;
(b) loss of business profits or contracts;
(c) business interruption;
(d) loss of the use of money or anticipated savings;
(e) loss of information;
(f) loss of opportunity, goodwill or reputation;
(g) loss of, damage to or corruption of data; or
(h) any indirect or consequential loss or damage of any kind howsoever arising and whether caused by tort (including negligence), breach of contract or otherwise;

provided that this clause 9.2 shall not prevent claims for loss of or damage to your tangible property that fall within the terms of clause 8 or a claim for a refund of the license fees paid to the Licensor or the Authorised Reseller (as applicable) for the license of the Software Products.

9.3 Subject to clause 9.1 and clause 9.2, the Licensor's maximum aggregate liability under or in connection with this License Agreement, or any collateral contract, whether in contract, tort (including negligence) or otherwise, shall be limited to a sum equal to the fees paid by you to the Licensor or the Authorised Reseller (as applicable) for the license of the Software Products.

9.4 Subject to clause 9.1, clause 9.2 and clause 9.3, the Licensor's liability for infringement of third party intellectual property rights shall be limited to breaches of third party rights subsisting in the UK and USA.

9.5 This License Agreement sets out the full extent of the Licensor's obligations and liabilities in respect of the supply of the Software Products and Documentation. In particular, there are no conditions, warranties, representations or other terms, express or implied, that are binding on the Licensor except as specifically stated in this License Agreement. Any condition, warranty, representation or other term concerning the supply of the Software Products and Documentation which might otherwise be implied into, or incorporated in, this License Agreement, or any collateral contract, whether by statute, common law or otherwise, is hereby excluded to the fullest extent permitted by law.

10. Term and Termination

10.1 This License Agreement is effective for the period referred to clause 2.1 or until otherwise terminated in accordance with that clause. The Licensor may terminate this License Agreement immediately by written notice to you if:

(a) save in respect of a Paid Up License, if you purchase the Software Products directly from the Licensor, you fail to pay any renewal or other fees due by you to the Licensor in respect of this License Agreement;
(b) you fail to comply with any provisions of this License Agreement;
(c) you commit a material or persistent breach of this License Agreement which you fail to remedy (if remediable) within 14 days after the service on you of written notice requiring you to do so; or
(d) a petition for a bankruptcy order to be made against you has been presented to the court; or
(e) where you, as the Corporate Licensee, become insolvent or unable to pay its (the company’s) debts, enters into liquidation, whether voluntary or compulsory (other than for reasons of bona fide amalgamation or reconstruction), passes a resolution for its winding-up, has a receiver or administrator manager, trustee, liquidator or similar officer appointed over the whole or any part of its assets, makes any composition or arrangement with its creditors or takes or suffers any similar action in consequence of its debt, or becomes unable to pay its debts or ceases to trade.

10.2 In the event of termination in accordance with clause 10.1 you must immediately pay to the Licensor any sums due to the Licensor under the License Agreement and (at the Licensor’s sole option) you must return, destroy or delete all copies of the Software Products from all storage media in your control and, in the case of destruction, certify to us that you have done so.
11. Export

11.1 You will comply with all applicable laws, rules, and regulations governing export of goods and information, including the laws of the countries in which the Software Products was created. In particular, you will not export or re-export, directly or indirectly, separately or as a part of a system, the Software Products or other information relating thereto to any country for which an export license or other approval is required, without first obtaining such license or other approval.

12. General

12.1 You agree that the Licensor shall have the right, after supplying undertakings as to confidentiality, to audit any computer system on which the Software Products are installed in order to verify compliance with this License Agreement.

12.2 You agree that the Licensor may use your company name in Licensor’s customer lists and other promotional materials describing your company as a customer or user of Licensor’s software or services, as applicable, unless it receives written notice from you objecting to such use.

12.3 This License Agreement, its subject matter or its formation (including non-contractual disputes or claims) shall be governed by and construed in accordance with English law and submitted to the non-exclusive jurisdiction of the English courts.

12.4 This License Agreement constitutes the complete and exclusive statement of the agreement between the Licensor and you with respect to the subject matter of this License and supersedes all proposals, representations, understandings and prior agreements, whether oral or written, and all other communications between us relating to that subject matter except for those expressly referred to in this License Agreement.

12.5 Any clause in this License Agreement that is found to be invalid or unenforceable shall be deemed deleted and the remainder of this License Agreement shall not be affected by that deletion.

12.6 Failure or neglect by either party to exercise any of its rights or remedies under this License Agreement will not be construed as a waiver of that party’s rights nor in any way affect the validity of the whole or part of this License Agreement nor prejudice that party’s right to take subsequent action.

12.7 This License Agreement is personal to you and you may not assign, transfer, sub-contract or otherwise part with this License or any right or obligation under it without the Licensor’s prior written consent.
End User License Agreement

Click Wrap Agreement at time of product installation

BY INSTALLING THIS SOFTWARE OR BY CLICKING THE “I ACCEPT” BUTTON AND ACCEPTING THIS LICENSE IN ACCORDANCE WITH SOFTWARE INSTALLATION AND LICENSE ACCEPTANCE PROCEDURE YOU AGREE TO THE TERMS OF THIS LICENSE WHICH WILL BIND YOU, THE COMPANY ON WHO’S BEHALF YOU ARE ENTERING INTO THIS LICENSE AGREEMENT, AND ITS EMPLOYEES, AS APPLICABLE.

THIS LICENSE AGREEMENT IS A LEGAL AGREEMENT BETWEEN HBM UNITED KINGDOM LTD A COMPANY INCORPORATED IN UNITED KINGDOM WHOSE REGISTERED NUMBER IS 1589921 AND WHOSE REGISTERED OFFICE IS AT TECHNOLOGY CENTRE, ADVANCED MANUFACTURING PARK, BRUNEL WAY, CATCLIFFE, ROTHERHAM S60 5WG (THE ‘LICENSOR’) AND THE END USER LICENSEE OR ITS REPRESENTATIVE/AGENT AUTHORISED TO BIND THE END USER LICENSEE (‘YOU’).

PLEASE READ THIS CAREFULLY BEFORE USING THE SOFTWARE PRODUCTS

A: BACKGROUND

THIS LICENSE AGREEMENT SHALL BE BETWEEN YOU AND THE LICENSOR REGARDLESS OF WHETHER YOU HAVE PURCHASED THE SOFTWARE PRODUCTS DIRECTLY FROM THE LICENSOR OR AN AUTHORISED RESELLER AS SET OUT BELOW.

THE LICENSOR APPOINTS EXPERIENCED PROVIDERS OF SOFTWARE RESALE SERVICES WHO DISTRIBUTE THE SOFTWARE PRODUCTS TO END USERS (‘AUTHORISED RESELLER’). IF YOU HAVE PURCHASED THE SOFTWARE PRODUCTS AND ANY ASSOCIATED SUPPORT AND MAINTENANCE SERVICES FROM AN AUTHORISED RESELLER, SUCH PRODUCTS AND SERVICES WILL BE PROVIDED DIRECTLY TO YOU BY THE RELEVANT AUTHORISED RESELLER AND ALL PAYMENTS SHALL BE MADE TO THE AUTHORISED RESELLER ON THE AUTHORISED RESELLER’S TERMS AND PRICES.

IF YOU HAVE PURCHASED THE SOFTWARE PRODUCT AND SUPPORT AND MAINTENANCE SERVICES DIRECTLY FROM THE LICENSOR, SUCH SUPPORT AND MAINTENANCE SERVICES WILL BE DEALT WITH IN A SEPARATE AGREEMENT BETWEEN YOU AND THE LICENSOR AND ALL PAYMENTS WILL BE MADE TO THE LICENSOR AND GOVERNED BY THE LICENSOR’S TERMS OF SALE.

B: PROPERTY OF LICENSOR

THE LICENSOR, OR, WHERE APPLICABLE, THE RELEVANT MEMBER OF THE LICENSOR’S CORPORATE GROUP, IS THE ENTIRE LEGAL AND BENEFICIAL OWNER OF CERTAIN SOFTWARE PRODUCT(S) (‘THE SOFTWARE PRODUCT’) AS SET OUT IN THE QUOTATION OF INFORMATION, WHICH SHALL ALSO INCLUDE YOUR LICENSE KEY, SENT TO YOU BY EMAIL EITHER BY THE LICENSOR OR, IF YOU HAVE PURCHASED THE SOFTWARE PRODUCTS FROM AN AUTHORISED RESELLER, BY THE AUTHORISED RESELLER (‘QUOTATION’). THE LICENSOR IS WILLING TO GRANT YOU A LICENSE TO USE THE SOFTWARE PRODUCT ONLY IF YOU ACCEPT ALL THE TERMS AND CONDITIONS SET OUT BELOW.

C: LICENSE TO BE GRANTED

THE LICENSOR IS PROPOSING TO GRANT YOU ONE OF THE FOUR FORMS OF LICENSE IN RESPECT OF THE SOFTWARE PRODUCT. DETAILS OF EACH FORM OF LICENSE ARE SET OUT IN CLAUSES 2.1 AND 3 BELOW. THE FORM OF LICENSE THAT IS PROPOSED TO BE

D: LICENSE ACCEPTANCE PROCEDURE

BY CLICKING ON THE ACCEPTANCE BUTTON WHICH FOLLOWS THIS LICENSE AGREEMENT (MARKED 'DO YOU ACCEPT THESE TERMS AND CONDITIONS?'), YOU INDICATE ACCEPTANCE OF THIS LICENSE AGREEMENT AND THE LIMITED WARRANTY AND LIMITATION OF LIABILITY SET OUT IN THIS LICENSE AGREEMENT. SUCH ACCEPTANCE IS ON YOUR OWN BEHALF, IF YOU ARE AN INDIVIDUAL AND ON BEHALF OF ANY CORPORATE ENTITY WHICH EMPLOYS YOU OR WHICH YOU REPRESENT (‘CORPORATE LICENSEE’) IN ENTERING INTO THIS LICENSE AND YOU WARRANT THAT YOU HAVE THE NECESSARY AUTHORITY TO BIND THE CORPORATE ENTITY IN THIS RESPECT OR THAT THE AUTHORISED REPRESENTATIVES OF THE CORPORATE ENTITY ARE AWARE OF YOUR ACCEPTANCE OF THIS AGREEMENT ON ITS BEHALF. IN THIS LICENSE AGREEMENT, ‘YOU’ REFERS TO THE LICENSEE, ANY SUCH CORPORATE LICENSEE, OR BOTH, AS A COMMON SENSE INTERPRETATION OF THE RELEVANT SECTION DICTATES.

E: LICENSE REJECTION PROCEDURE

IF YOU DO NOT ACCEPT THESE TERMS AND CONDITIONS, YOU SHOULD CLICK ON THE “I DO NOT ACCEPT” BUTTON, DELETE THE SOFTWARE PRODUCTS FROM YOUR COMPUTER AND PROMPTLY (AND IN ANY EVENT, WITHIN 14 DAYS OF RECEIPT) RETURN TO THE RESELLER (A) ANY MEDIA; AND (B) ANY OTHER ITEMS PROVIDED, THAT ARE PART OF THIS PRODUCT.

F: OTHER AGREEMENTS

IF THE LICENSOR HAS EXPRESSLY AGREED WITH YOU IN WRITING THAT YOUR USE OF THE SOFTWARE PRODUCTS IS GOVERNED BY A PRIOR EXECUTED LICENSE AGREEMENT WITH THE LICENSOR, SUCH AGREEMENT SHALL APPLY INSTEAD OF THE FOLLOWING TERMS AND CONDITIONS TO THE EXTENT THAT THEY CONFLICT.

YOU SHOULD PRINT A COPY OF THIS LICENSE AGREEMENT FOR FUTURE REFERENCE.

LICENSE AGREEMENT

1. Ownership of Software Products and Copies

   1.1 The Software Products and any printed materials or electronic documentation accompanying the Software Products (‘Documentation’) are copyrighted works of authorship, and are also protected under applicable database laws. The Licensor, or, where applicable, the relevant member of the Licensor’s corporate group, retains ownership of the Software Products and all subsequent copies of the Software Products, regardless of the form in which the copies may exist. This License Agreement is not a sale of the original Software Products or any copies.

2. Commercial License

   2.1 In consideration of you agreeing to abide by the terms of this License Agreement and payment of the applicable license fees either to the Licensor or, if you have purchased the Software Products from an Authorised Reseller, to the Authorised Reseller (as specified in the Quotation), the Licensor hereby grants to you a personal, non-exclusive, and (unless expressly agreed otherwise by the Licensor in accordance with
clause 5.1) non-transferable license to use the Software Products and the Documentation on the terms of this License Agreement. The license shall take one of the following forms, (and shall be set out in the Quotation):

(a) **Annual License:**

   (i) **Duration** – this License shall continue for a period of 12 months (‘Initial Period’) from the date of delivery of the Quotation (‘the Delivery Date’) and, provided that you have paid all applicable renewal fees, from year to year thereafter unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

   (ii) **Termination** – you must give the Licensor 90 day’s written notice prior to the anniversary of the Delivery Date, such notice not to expire before such anniversary date.

(b) **Paid Up License:**

   (i) **Duration** – this License shall continue for a period of 25 years from the Delivery Date unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

   (ii) **Conversion** - this License may be converted to a CDS (this may include CRS and CDRS which are specific variations of CDS and collectively known as CDS) License, upon application to either the Licensor or the Authorised Reseller (if you have purchased the Software Products from an Authorised Reseller), and payment of an additional fee to the Licensor or the Authorised Reseller (as applicable), which shall be additional to the fees paid or payable in respect of any maintenance and support services provided by either the Licensor or the Authorised Reseller (if you have purchased the Software Products from an Authorised Reseller). You may reverse this conversion to the same terms as agreed in the Paid Up License at the anniversary of the conversion by giving the Licensor 90 days written notice prior to the anniversary of the Delivery Date, such notice not to expire before the anniversary of the Delivery Date.

(c) **CDS/CRS/CDRS License:**

   (i) **Access** – subject to the terms and conditions of this License Agreement, you may access any of the Software Products in the Quotation at any one time and in any combination up to the number of subscriptions granting you access to the Software Products for simultaneous use by you and purchased by you pursuant to this Agreement (‘Access Credits’). In the event the number of Access Credits reaches the number of Access Credits duly paid for by you (‘Access Limit’), you may add additional Access Credits (or, alternatively, at any time during the Term) which shall be charged in accordance with either the Licensor’s prices or the Authorised Reseller’s prices (if you have purchased the Software Products from an Authorised Reseller). Such increase in Access Credits shall apply to the following 12 month period, unless you give the Licensor or the Authorised Reseller (as applicable) written notice at least 90 days in advance of the expiry of the Initial Period, that you do not wish to sustain such increase in Access Credits. You may opt to reduce the number of Access Credits with 90 days written notice in advance of the 12 month period following from the anniversary of the Delivery Date, provided that the total number of Access Credits does not fall below the minimum threshold set by the Licensor or the Authorised Reseller (as applicable) or below the initial number of Access Credits calculated at the time of conversion of any Paid Up License.

   (ii) **Duration** - this License shall continue for the Initial Period and, provided that you have paid for the applicable Access Credits, from year to year thereafter unless terminated in accordance with any provision of clause 10 below or any other clause of this License Agreement.

   (iii) **Reporting** – in order to serve our customers better, the Licensor needs to be able to understand how its customers use the CDS system. As a condition of your continued access to the system, you are asked to provide to the Licensor on a quarterly basis, the CDS log file. You will be provided with easy-to-follow instructions on how to do this.
Termination – you must give the Licensor 90 days written notice in advance of the expiry of the Initial Period of your intention to discontinue the CDS License, such notice not to expire before the anniversary of the Delivery Date, and you must have submitted all reports required of you in clause 2.1(c)(iii) above. Failure to provide such notice and reports will mean that the license shall automatically continue on the same terms until terminated in accordance with this clause.

2.2 As an end user licensee of the Software Products, you may, subject to the following conditions and any conditions specified in the Quotation:

(a) use and copy the Software Products only for use on any computer system that is detailed in the release notes of the respective Software Product and which is licensed, leased and/or controlled by you (the Corporate Licensee) or any member of your corporate group, which expression includes the Corporate Licensee's majority-owned subsidiaries, any parent company having a majority-owned interest in the Corporate Licensee, and such parent's majority-owned subsidiaries;

(b) load the Software Products into and use it only on computers at the locations specified in the Quotation and which are under your control;

(c) copy the Software Products only for back-up and archival purposes and make up to three copies of the Documentation, provided that the original and each copy is kept in your possession and that your installation and use of the Software Products does not exceed any restrictions contained in the Quotation.

3. Demonstration License

3.1 If the Licensor has provided you with the Software Products free of charge for evaluation purposes, this clause 3 shall apply to your use of the Software Products.

3.2 You may use the Software Product on a computer solely for the purposes of evaluating the Software Product.

3.3 The Software Product is provided to you free of charge and on an “AS IS” basis, without any technical support or warranty of any kind from us including, without limitation, a warranty of satisfactory quality, fitness for purpose and non-infringement.

3.4 This License shall continue for a period of 30 days from the Delivery Date unless terminated in accordance with any provision of clause 10 below or any other applicable clause of this License Agreement or until such License is converted into an Annual License, Paid Up License or CDS License, if earlier.

3.5 As part of the Licensor’s testing and evaluation of the Software Products, you shall share with the Licensor the input and views received and any reports and analysis produced promptly upon receipt of such feedback.

3.6 Clauses 4, 5.1(a), 6.1(b), 6.1(f), 8.1, 8.2, 8.5, 10.1(a) of this License Agreement shall not apply to a Demonstration License.

4. Delivery and Risk

4.1 The Software Products shall consist of one copy of the object code of the Software Products on machine-readable form only, on the disk, dongle or other media on which the Software Product is delivered as described in the Quotation (the “Media”). Risk in the Media shall pass to you on delivery. If any part of the Media shall thereafter be lost, damaged or destroyed, you must contact either the Licensor or the Authorised Reseller from whom you have purchased the Software Products who will arrange for a repair or replacement of such Media at a cost (if any) determined by the Licensor or the Authorised Reseller (as applicable).

5. License Restrictions

5.1 You may not nor permit others to:

(a) transfer the Software Products from one location to another, without the express written consent of the Licensor and provided such transfers do not exceed two in any twelve month period. It will be a condition of the grant of any such consent that the Software Products held on hard drives at the current location must be erased and you must enter into a new license agreement with the Licensor before a
Software Products license key is provided to you. The administration charge (currently US $1,500) will be payable by you in respect of such transfer. This charge is only applicable to end user licensees who do not have a support and maintenance services agreement with the Licensor or Authorised Reseller;

(b) exceed the number of concurrent users specified in the Quotation, if any;

(c) sub-license, sell, assign, rent, pledge, lease, transfer or otherwise dispose of the Software Products, on a temporary or permanent basis, without the prior written consent of the Licensor;

(d) translate, reverse engineer, decompile, disassemble, modify or create derivative works based on the Software Products except as permitted by law;

(e) make copies of the Software Products, in whole or part, except for back-up or archival purposes as permitted in this License Agreement;

(f) use any back-up copy of the Software Products for any purpose other than to replace the original copy in the event that it is destroyed or becomes defective;

(g) copy the Documentation (except as provided by this License Agreement);

(h) adapt, modify, delete or translate the Documentation in any way for any purpose whatsoever;

(i) vary, delete or obscure any notices of proprietary rights or any product identification or restrictions on or in the Software Products.

6. Undertakings

6.1 You undertake:

(a) to ensure that, prior to use of the Software Products by your employees or agents, all such parties are notified of this License and the terms of this License Agreement and that any such use as aforesaid is in accordance with the terms of this License Agreement;

(b) to replace the current version of the Software Product with any updated or upgraded version or new release provided by the Licensor or the Authorised Reseller (if applicable) under the terms of this License Agreement immediately on receipt of such version or release;

(c) to use the Software Products only as described in the Documentation and subject to the restrictions as set out in clause 5 (License Restrictions above);

(d) to reproduce and include the Licensor’s copyright notice (or such other party’s copyright notice as specified on the Software Products) on all and any copies of the Software Products, including any partial copies of the Software Products as permitted to be made under the terms of this License Agreement;

(e) to hold all drawings, specifications, data (including object and source codes), Software Products listings and all other information relating to the Software Products confidential and not at any time, during this License or after its expiry, disclose the same, whether directly or indirectly, to any third party without the Licensor’s consent, and

(f) to effect and maintain adequate security measures to safeguard the Software Product from access or use by any unauthorised person and indemnify the Licensor for losses flowing from your failure to do so.

7. Intellectual Property Rights

7.1 You acknowledge that all intellectual property rights in the Software Product and the Documentation throughout the world belong to the Licensor, that rights in the Software Product are licensed (not sold) to you, and that you have no rights in, or to, the Software Product or the Documentation other than the right to use them in accordance with the terms of this License Agreement.

7.2 You acknowledge that you have no right to have access to the Software Product in source code form or in unlocked coding or with comments.
7.3 The integrity of this Software Product is protected by technical protection measures ("TPM") so that the intellectual property rights, including copyright, in the software of the Licensor are not misappropriated. You must not attempt in any way to remove or circumvent any such TPM, nor to apply, manufacture for sale, hire, import, distribute, sell, nor let, offer, advertise or expose for sale or hire, nor have in your possession for private or commercial purposes, any means whose sole intended purpose is to facilitate the unauthorised removal or circumvention of such TPM.

8. Limited Warranty

8.1 Subject to the limitations and exclusions of liability below and providing the Software is used in accordance with the Documentation and on an operating system or computer for which it was designed, the Licensor warrants that (a) the Media on which the Software Products is furnished will be free from material defects under normal use for a period of 90 days from the date of delivery (the “Warranty Period”); and that (b) during the Warranty Period, the Software Product will, when properly used, perform substantially in accordance with the functions described in the Documentation; and (c) that the Documentation correctly describes the operation of the Software Product in all material respects.

8.2 If, within the Warranty Period, you notify the Licensor in writing of any defect or fault in the Software Product in consequence of which it fails to perform substantially in accordance with the Documentation, and such defect or fault does not result from you having amended the Software Product or used it in contravention of the terms of this License Agreement, the Licensor will, at its sole option, i) repair or replace the Software Product, provided that you make available all information that may be necessary to assist the Licensor in resolving the defect or fault, including sufficient information to enable the Licensor to recreate the defect or fault, or ii) terminate this License Agreement immediately by notice in writing to you and the Licensor will refund or if the Software Products have been purchased from an Authorised Reseller will procure that the Authorised Reseller shall refund; any of the fees paid as at the date of termination (less a reasonable sum in respect of your use of the Software Product to the date of termination) on return of the Software Product and all copies thereof. The Licensor’s obligation under this clause 8.2 is subject to your compliance with clause 6.1(b).

8.3 You acknowledge that the Software Product has not been developed to meet your individual requirements and that it is therefore your responsibility to ensure that the facilities and functions of the Software Product as described in the Documentation meet your requirements.

8.4 You acknowledge that the Software Product may not be free of bugs or errors and you agree that the existence of any minor errors shall not constitute a breach of this License Agreement.

8.5 The Licensor shall not be liable under the said warranty above if the Software Product fails to operate in accordance with the said warranty as a result of any modification, variation or addition to the Software Products not performed by the Licensor or caused by any abuse, corruption or incorrect use of the Software Products, including use of the Software Products with equipment or other software which is incompatible.

8.6 All other conditions, warranties or other terms which might have effect or be implied or incorporated into this License Agreement or any collateral contract, whether by statute, common law or otherwise, are hereby excluded, including, without limitation, the implied conditions, warranties or other terms as to satisfactory quality, fitness for purpose or the use of reasonable skill and care.

9. Exclusion of Liability

9.1 Nothing in this License Agreement shall limit or exclude the liability of either party for death or personal injury resulting from negligence, for fraud or for fraudulent misrepresentation.

9.2 Subject to clause 9.1, the Licensor shall have no liability for any losses or damages which may be suffered by you (or any person claiming under or through you), whether the same are suffered directly or indirectly or are immediate or consequential, and whether the same arise in contract, tort (including negligence) or otherwise howsoever, which fall within any of the following:

(a) loss of income;
(b) loss of business profits or contracts;
(c) business interruption;
(d) loss of the use of money or anticipated savings;
(e) loss of information;
(f) loss of opportunity, goodwill or reputation;
(g) loss of, damage to or corruption of data; or
(h) any indirect or consequential loss or damage of any kind howsoever arising and whether caused by tort (including negligence), breach of contract or otherwise;

provided that this clause 9.2 shall not prevent claims for loss of or damage to your tangible property that fall within the terms of clause 8 or a claim for a refund of the license fees paid to the Licensor or the Authorised Reseller (as applicable) for the license of the Software Products.

9.3 Subject to clause 9.1 and clause 9.2, the Licensor's maximum aggregate liability under or in connection with this License Agreement, or any collateral contract, whether in contract, tort (including negligence) or otherwise, shall be limited to a sum equal to the fees paid by you to the Licensor or the Authorised Reseller (as applicable) for the license of the Software Products.

9.4 Subject to clause 9.1, clause 9.2 and clause 9.3, the Licensor's liability for infringement of third party intellectual property rights shall be limited to breaches of third party rights subsisting in the UK and USA.

9.5 This License Agreement sets out the full extent of the Licensor's obligations and liabilities in respect of the supply of the Software Products and Documentation. In particular, there are no conditions, warranties, representations or other terms, express or implied, that are binding on the Licensor except as specifically stated in this License Agreement. Any condition, warranty, representation or other term concerning the supply of the Software Products and Documentation which might otherwise be implied into, or incorporated in, this License Agreement, or any collateral contract, whether by statute, common law or otherwise, is hereby excluded to the fullest extent permitted by law.

10. Term and Termination

10.1 This License Agreement is effective for the period referred to clause 2.1 or until otherwise terminated in accordance with that clause. The Licensor may terminate this License Agreement immediately by written notice to you if:

(a) save in respect of a Paid Up License, if you purchase the Software Products directly from the Licensor, you fail to pay any renewal or other fees due by you to the Licensor in respect of this License Agreement;
(b) you fail to comply with any provisions of this License Agreement;
(c) you commit a material or persistent breach of this License Agreement which you fail to remedy (if remediable) within 14 days after the service on you of written notice requiring you to do so; or
(d) a petition for a bankruptcy order to be made against you has been presented to the court; or
(e) where you, as the Corporate Licensee, become insolvent or unable to pay its (the company’s) debts, enters into liquidation, whether voluntary or compulsory (other than for reasons of bona fide amalgamation or reconstruction), passes a resolution for its winding-up, has a receiver or administrator manager, trustee, liquidator or similar officer appointed over the whole or any part of its assets, makes any composition or arrangement with its creditors or takes or suffers any similar action in consequence of its debt, or becomes unable to pay its debts or ceases to trade.

10.2 In the event of termination in accordance with clause 10.1 you must immediately pay to the Licensor any sums due to the Licensor under the License Agreement and (at the Licensor’s sole option) you must return, destroy or delete all copies of the Software Products from all storage media in your control and, in the case of destruction, certify to us that you have done so.
11. **Export**

11.1 You will comply with all applicable laws, rules, and regulations governing export of goods and information, including the laws of the countries in which the Software Products was created. In particular, you will not export or re-export, directly or indirectly, separately or as a part of a system, the Software Products or other information relating thereto to any country for which an export license or other approval is required, without first obtaining such license or other approval.

12. **General**

12.1 You agree that the Licensor shall have the right, after supplying undertakings as to confidentiality, to audit any computer system on which the Software Products are installed in order to verify compliance with this License Agreement.

12.2 You agree that the Licensor may use your company name in Licensor’s customer lists and other promotional materials describing your company as a customer or user of Licensor’s software or services, as applicable, unless it receives written notice from you objecting to such use.

12.3 This License Agreement, its subject matter or its formation (including non-contractual disputes or claims) shall be governed by and construed in accordance with English law and submitted to the non-exclusive jurisdiction of the English courts.

12.4 This License Agreement constitutes the complete and exclusive statement of the agreement between the Licensor and you with respect to the subject matter of this License and supersedes all proposals, representations, understandings and prior agreements, whether oral or written, and all other communications between us relating to that subject matter except for those expressly referred to in this License Agreement.

12.5 Any clause in this License Agreement that is found to be invalid or unenforceable shall be deemed deleted and the remainder of this License Agreement shall not be affected by that deletion.

12.6 Failure or neglect by either party to exercise any of its rights or remedies under this License Agreement will not be construed as a waiver of that party’s rights nor in any way affect the validity of the whole or part of this License Agreement nor prejudice that party’s right to take subsequent action.

12.7 This License Agreement is personal to you and you may not assign, transfer, sub-contract or otherwise part with this License or any right or obligation under it without the Licensor’s prior written consent.